Neuigkeiten für Microsoft Word 2000-Entwickler

Zur Unterstützung der neuen und verbesserten Funktionen in Microsoft Word 2000 wurden umfangreiche Änderungen am Visual Basic-Objektmodell vorgenommen.

Neue Sprachelemente

In den folgenden Themen finden Sie die Sprachelemente für Visual Basic, die neu in Microsoft Word 2000 sind.

Neue Objekte

Neue Eigenschaften (nach Objekten sortiert)

Neue Eigenschaften (alphabetisch sortiert)

Neue Methoden (nach Objekten sortiert)

Neue Methoden (alphabetisch sortiert)

Neue Ereignisse

Sprachspezifische Eigenschaften und Methoden

Verborgene Sprachelemente

Im Folgenden finden Sie eine Liste mit den Eigenschaften, die in Word 2000 verborgen sind.

Verborgene Eigenschaften


Objekte, Eigenschaften und Methoden verstehen

Objekte sind die fundamentalen Bausteine von Visual Basic; fast alles, was Sie in Visual Basic machen, betrifft die Modifizierung von Objekten. Jedes Element von Word (Dokumente, Tabellen, Absätze, Textmarken, Felder usw.) kann in Visual Basic durch ein Objekt dargestellt werden.

Was sind Objekte und Auflistungen?

Ein Objekt stellt ein Element von Word dar, z. B. ein Dokument, einen Absatz, eine Textmarke oder ein einzelnes Zeichen. Eine Auflistung ist ein Objekt, das mehrere andere Objekte enthält, normalerweise der selben Art; beispielsweise sind alle Textmarkenobjekte in einem Dokument in einem einzelnen Auflistungsobjekt enthalten. Mit Hilfe von Eigenschaften und Methoden können Sie ein einzelnes Objekt oder eine ganze Auflistung von Objekten modifizieren.

Was ist eine Eigenschaft?

Eine Eigenschaft ist ein Attribut eines Objekts oder ein Aspekt seines Verhaltens. Beispielsweise gehören zu den Eigenschaften eines Dokuments dessen Name, sein Inhalt und sein Speicherstatus, aber ebenso, ob die Änderungsverfolgung eingeschaltet ist. Zum Ändern der Charakteristika eines Objekts ändern Sie die Werte seiner Eigenschaften.

Zum Festlegen des Wertes einer Eigenschaft schreiben Sie nach dem Verweis auf ein Objekt einen Punkt, den Eigenschaftsnamen, ein Gleichheitszeichen und den neuen Eigenschaftswert. Im folgenden Beispiel wird im Dokument MyDoc.doc die Änderungsverfolgung eingeschaltet.

Documents("MyDoc.doc").TrackRevisions = True

In diesem Beispiel verweist Documents auf die Auflistung der geöffneten Dokumente. Der Name MyDoc.doc kennzeichnet ein einzelnes Dokument in der Auflistung. Die TrackRevisions-Eigenschaft wird speziell für dieses eine Dokument festgelegt.

Manche Eigenschaften können nicht festgelegt werden. Das Hilfethema für eine Eigenschaft gibt an, ob diese Eigenschaft festgelegt (Schreib-Lese-Zugriff) oder nur gelesen (Nur-Lese-Zugriff) werden kann.

Sie können Informationen über ein Objekt erhalten, indem Sie sich den Wert von einer seiner Eigenschaften zurückgeben lassen. Im folgenden Beispiel wird der Name des aktiven Dokuments zurückgegeben.

docName = ActiveDocument.Name

In diesem Beispiel verweist ActiveDocument auf das Dokument im aktiven Fenster in Word. Der Name dieses Dokuments wird der Variablen docName zugewiesen.

Anmerkung Das Hilfethema für die einzelnen Eigenschaften gibt an, ob Sie diese Eigenschaft festlegen (Schreib-Lese-Zugriff), nur lesen (Nur-Lese-Zugriff) oder nur schreiben (Nur-Schreib-Zugriff) können. Der Objektkatalog im Visual Basic-Editor zeigt ebenfalls den Schreib-Lese-Status unten im Katalogfenster an, wenn die Eigenschaft ausgewählt ist.

Was ist eine Methode?

Eine Methode ist eine Aktion, die ein Objekt durchführen kann. Da ein Dokument gedruckt werden kann, hat das Document-Objekt beispielsweise auch eine PrintOut-Methode. Methoden haben oft Argumente, die näher bestimmen, wie die Aktion durchgeführt wird. Im folgenden Beispiel werden die ersten drei Seiten des aktiven Dokuments gedruckt.

ActiveDocument.PrintOut From:=1, To:=3

In den meisten Fällen handelt es sich bei Methoden um Aktionen und bei Eigenschaften um Merkmale. Die Verwendung einer Methode führt dazu, dass mit einem Objekt etwas geschieht, während bei Verwendung einer Eigenschaft Informationen über das Objekt zurückgegeben werden oder ein Merkmal des Objekts geändert wird.

Rückgabe eines Objekts

Die meisten Objekte werden zurückgegeben, indem ein einzelnes Objekt der Auflistung zurückgegeben wird. Die Documents-Auflistung enthält beispielsweise die geöffneten Word-Dokumente. Sie verwenden die Documents-Eigenschaft des Application-Objekts (des obersten Objekts in der Objekthierarchie von Word) zur Rückgabe der Documents-Auflistung.

Nachdem Sie auf die Auflistung zugegriffen haben, können Sie ein einzelnes Objekt zurückgeben, indem Sie einen Indexwert in Klammern angeben (ähnlich wie beim Arbeiten mit Datenfeldern). Der Indexwert ist normalerweise eine Nummer oder ein Name. Weitere Informationen finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Im folgenden Beispiel wird die Documents-Eigenschaft zum Zugriff auf die Documents-Auflistung verwendet. Die Indexnummer wird zur Rückgabe des ersten Dokuments in der Documents-Auflistung verwendet. Die Close-Methode wird dann auf das Document-Objekt angewandt, um das erste Dokument in der Documents-Auflistung zu schließen.

Documents(1).Close

Im folgenden Beispiel wird zum Identifizieren eines Document-Objekts innerhalb der Documents-Auflistung ein (als String angegebener) Name verwendet.

Documents("Sales.doc").Close

Auflistungsobjekte haben oft Methoden und Eigenschaften, die Sie zum Modifizieren der gesamten Auflistung der Objekte verwenden können. Das Documents-Objekt hat eine Save-Methode, die alle Dokumente in der Auflistung speichert. Im folgenden Beispiel werden die geöffneten Dokumente mit Hilfe der Save-Methode gespeichert.

Documents.Save

Dem Document-Objekt steht auch eine Save-Methode zum Speichern eines einzelnen Dokuments zur Verfügung. Im folgenden Beispiel wird das Dokument Report.doc gespeichert.

Documents("Report.doc").Save

Wenn ein Objekt zurückgegeben werden soll, das sich weiter unten in der Word-Objekthierarchie befindet, müssen Sie einen "Drilldown" zu diesem Objekt ausführen, indem Sie Eigenschaften und Methoden zum Zurückgeben von Objekten verwenden.

Damit Sie sehen, wie dies funktioniert, öffnen Sie den Visual Basic-Editor, und klicken Sie im Menü Ansicht auf Objektkatalog. Klicken Sie links in der Liste Klassen auf Application. Klicken Sie dann rechts in der Liste der Elemente auf ActiveDocument. Der Text unten im Objektkatalog zeigt an, dass ActiveDocument eine schreibgeschützte Eigenschaft ist, die ein Document-Objekt zurückgibt. Klicken Sie unten im Objektkatalog auf Document; das Document-Objekt wird in der Liste Klassen automatisch markiert, und die Liste Elemente zeigt die Elemente des Document-Objekts an. Führen Sie einen Bildlauf durch die Liste der Elemente durch, bis Sie Close finden. Klicken Sie auf die Close-Methode. Der Text unten im Fenster Objektkatalog zeigt die Syntax für die Methode an. Weitere Informationen über die Methode erhalten Sie, wenn Sie F1 drücken oder auf die Schaltfläche Hilfe klicken und zum Hilfethema Close-Methode springen.

Mit diesen Informationen können Sie die folgende Anweisung zum Schließen des aktiven Dokuments schreiben.

ActiveDocument.Close SaveChanges:=wdSaveChanges

Im folgenden Beispiel wird das aktive Dokumentfenster maximiert.

ActiveDocument.ActiveWindow.WindowState = wdWindowStateMaximize

Die ActiveWindow-Eigenschaft gibt ein Window-Objekt zurück, das das aktive Fenster darstellt. Für die WindowState-Eigenschaft wird die Maximierungskonstante eingestellt (wdWindowStateMaximize).

Im folgenden Beispiel wird ein neues Dokument erstellt und das Dialogfeld Speichern unter angezeigt, so dass das Dokument mit einem Namen versehen werden kann.

Documents.Add.Save

Die Documents-Eigenschaft gibt die Documents-Auflistung zurück. Die Add-Methode erstellt ein neues Dokument und gibt ein Document-Objekt zurück. Die Save-Methode wird dann auf das Document-Objekt angewandt.

Wie Sie sehen, verwenden Sie Methoden oder Eigenschaften, um einen Drilldown zu einem Objekt durchzuführen. Das heißt, Sie geben ein Objekt zurück, indem Sie auf ein in der Objekthierarchie darüber liegendes Objekt eine Methode anwenden oder einem solchen Objekt eine Eigenschaft zuweisen. Nachdem Sie das gewünschte Objekt zurückgegeben haben, können Sie die Methoden dieses Objekts anwenden und seine Eigenschaften steuern. Einen Überblick über die Hierarchie der Objekte finden Sie unter Microsoft Word-Objekte.

Wie Sie Hilfe über Objekte, Methoden und Eigenschaften erhalten

Bis Sie mit dem Word-Objektmodell vertraut sind, können Sie ein paar Hilfsmittel verwenden, die Ihnen helfen, einen Drilldown durch die Hierarchie auszuführen.

  • Elemente automatisch auflisten. Wenn Sie im Visual Basic-Editor nach einem Objekt einen Punkt (.) eingeben, wird eine Liste der verfügbaren Eigenschaften und Methoden angezeigt. Wenn Sie beispielsweise Application. eingeben, wird eine Dropdownliste der Methoden und Eigenschaften des Application-Objekts angezeigt.

  • Hilfe. Sie können auch die Hilfe verwenden, um herauszufinden, welche Eigenschaften und Methoden bei einem Objekt verwendet werden können. Jedes Objektthema in der Hilfe enthält einen Eigenschaften- und Methoden-Sprung, der eine Liste der Eigenschaften und Methoden für das Objekt anzeigt. Drücken Sie im Objektkatalog oder in einem Modul F1, um zum entsprechenden Hilfethema zu gelangen.

  • Microsoft Word-Objekte Dieses Thema veranschaulicht, wie Word-Objekte in der Hierarchie angeordnet sind. Klicken Sie auf ein Objekt in der Grafik, damit das entsprechende Hilfethema angezeigt wird.

  • Objektkatalog. Der Objektkatalog im Visual Basic-Editor zeigt die Elemente (Eigenschaften und Methoden) der Word-Objekte an.


Häufig gestellte Visual Basic-Fragen

Wie erhalte ich ein Exemplar des Microsoft Office 2000/Visual Basic-Programmierhandbuches?

Allgemeine Fragen

Wie wandle ich meine WordBasic-Makros in Visual Basic um?

Wie finde ich das Visual Basic-Äquivalent für einen WordBasic-Befehl oder eine -Funktion?

Wie zeichne ich Makros auf?

Was sind Objekte, Eigenschaften und Methoden?

Wie finde ich heraus, welche Eigenschaft oder Methode ich benötige?

Wie erhalte ich von einer Auflistung ein einzelnes Objekt zurück?

Fragen über Word-Funktionen

Wie spreche ich das aktive Element an (beispielsweise einen Absatz, eine Tabelle oder ein Feld)?

Was ist ein Range-Objekt?

Wie spreche ich Wörter, Sätze, Absätze oder Abschnitte in einem Dokument an?

Ich erhalte dauernd den Fehler "Objekt unterstützt diese Eigenschaft oder Methode nicht"; wie kann ich ihn vermeiden?

Wie kann ich Dokumente erstellen, öffnen, speichern und schließen?

Wie markiere ich Text in einem Dokument?

Wie füge ich Text in ein Dokument ein?

Ich erhalte dauernd den Fehler "Das angeforderte Element der Auflistung ist nicht vorhanden"; wie kann ich ihn vermeiden?

Wie durchlaufe ich alle Elemente einer Auflistung?

Wie fordere ich den Benutzer zur Eingabe von Daten auf?

Wie gebe ich Text aus einem Dokument zurück?

Wie weiß ich, ob die Application-Eigenschaft vor einer Eigenschaft oder Methode auf der obersten Ebene benötigt wird?

Wie zeige ich ein integriertes Microsoft Word-Dialogfeld an?

Ich erhalte dauernd einen Fehler, wenn ich versuche, auf eine Tabellenzeile oder -spalte zuzugreifen; wie kann ich ihn vermeiden?


Automatisierung häufiger Aufgaben in Word

Dieses Thema enthält einige häufige Aufgaben in Word und den Visual Basic-Code, der zum Durchführen der Aufgaben benötigt wird.

Dem Text Formatierung zuweisen

Text bearbeiten

Text oder Formatierung suchen und ersetzen

Verschiedenartige Aufgaben

Mit Tabellen arbeiten

Mit Dokumenten arbeiten


Text in ein Dokument einfügen

Verwenden Sie die InsertAfter- oder InsertBefore-Methode zum Einfügen von Text vor oder nach einem Selection- oder Range-Objekt. Im folgenden Beispiel wird am Ende des aktiven Dokuments Text eingefügt.

ActiveDocument.Content.InsertAfter Text:=" the end."

Im folgenden Beispiel wird vor der Markierung Text eingefügt.

Selection.InsertBefore Text:="new text "

Nach Anwendung der InsertBefore- oder InsertAfter-Methode wird das Range- oder Selection-Objekt erweitert, damit es auch den neuen Text umfasst. Verwenden Sie die Collapse-Methode zum Reduzieren eines Selection- oder Range-Objekts zum Anfangs- oder Endpunkt.


Markierung von Text in einem Dokument

Verwenden Sie die Select-Methode zum Markieren eines Elements in einem Dokument. Die Select-Methode steht von mehreren Objekten aus zur Verfügung, beispielsweise dem Bookmark-, Field-, Range- und dem Table-Objekt. Im folgenden Beispiel wird die erste Tabelle im aktiven Dokument markiert.

ActiveDocument.Tables(1).Select

Im folgenden Beispiel wird das erste Feld im aktiven Dokument markiert.

ActiveDocument.Fields(1).Select

Im folgenden Beispiel werden die ersten vier Absätze im aktiven Dokument markiert. Die Range-Methode wird zum Erstellen eines Range-Objekts verwendet, das sich auf die ersten vier Absätze bezieht. Die Select-Methode wird dann auf das Range-Objekt angewandt.

Set myRange = ActiveDocument.Range( _
    Start:=ActiveDocument.Paragraphs(1).Range.Start, _
    End:=ActiveDocument.Paragraphs(4).Range.End)
myRange.Select

Weitere Informationen finden Sie unter Arbeiten mit dem Selection-Objekt.


Text bearbeiten

Dieses Thema enthält Visual Basic-Beispiele, die sich auf die folgenden Aufgaben beziehen:

  • Feststellen, ob Text markiert ist

  • Reduzierung einer Markierung oder eines Bereichs

  • Erweiterung einer Markierung oder eines Bereichs

  • Ein Range-Objekt neu definieren

  • Text ändern

Informationen und Beispiele über andere Bearbeitungsaufgaben finden Sie bei den folgenden Themen:

Zurückgabe von Text aus einem Dokument

Text in einem Dokument markieren

Text in ein Dokument einfügen

Einen Teil eines Dokuments manipulieren

Feststellen, ob Text markiert ist

Die Type-Eigenschaft des Selection-Objekts gibt Informationen über die Art der Markierung zurück. Im folgenden Beispiel wird eine Meldung angezeigt, wenn die Markierung eine Einfügemarke ist.

If Selection.Type = wdSelectionIP Then MsgBox "Nothing is selected"

Reduzierung einer Markierung oder eines Bereichs

Verwenden Sie die Collapse-Methode zum Reduzieren eines Selection- oder Range-Objekts auf seinen Anfangs- oder Endpunkt. Im folgenden Beispiel wird die Markierung auf eine Einfügemarke am Anfang der Markierung reduziert.

Selection.Collapse Direction:=wdCollapseStart

Im folgenden Beispiel wird das Objekt myRange getilgt, so dass die Einfügemarke dann an dessen Endpunkt steht (nach dem ersten Wort).

Set myRange = ActiveDocument.Words(1)
myRange.Collapse Direction:=wdCollapseEnd

Erweiterung einer Markierung oder eines Bereichs

Im folgenden Beispiel wird die MoveEnd-Methode zum Erweitern des Endes der Markierung verwendet, damit sie drei weitere Wörter umfasst. Die MoveLeft-, MoveRight-, MoveUp- und MoveDown-Methoden können auch zur Erweiterung eines Selection-Objekts verwendet werden.

Selection.MoveEnd Unit:=wdWord, Count:=3

Im folgenden Beispiel wird die MoveEnd-Methode zum Erweitern von oRange verwendet, damit die ersten drei Absätze im aktiven Dokument in den Bereich mitaufgenommen werden.

Set oRange = ActiveDocument.Paragraphs(1).Range
oRange.MoveEnd Unit:=wdParagraph, Count:=2

Ein Range-Objekt neu definieren

Verwenden Sie die SetRange-Methode zum Neudefinieren eines vorhandenen Range-Objekts. Weitere Informationen finden Sie unter Working with Range objects.

Text ändern

Sie können vorhandenen Text ändern, indem Sie den Inhalt eines Bereichs ändern. Die folgende Anweisung ändert das erste Wort im aktiven Dokument, indem die Text-Eigenschaft auf "The " festgelegt wird.

ActiveDocument.Words(1).Text = "The "

Sie können auch die Delete-Methode zum Löschen von vorhandenem Text verwenden und dann mit Hilfe der InsertAfter- oder InsertBefore-Methode neuen Text einfügen. Im folgenden Beispiel wird der erste Absatz im aktiven Dokument gelöscht und neuer Text eingefügt.

Set myRange = ActiveDocument.Paragraphs(1).Range
With myRange
    .Delete
    .InsertAfter Text:="New text"
    .InsertParagraphAfter
End With


Zuweisen von Formatierungen für Text

Dieses Thema enthält Visual Basic-Beispiele für die folgenden Aufgaben:

  • Anwenden einer Formatierung auf die Markierung

  • Anwenden von Formatierung auf einen Bereich

  • Einfügen von Text und Anwenden von Zeichen- und Absatzformatierung

  • Umschalten des Leerraums vor einem Absatz zwischen 12 Punkt und Null

  • Umschalten der Fettformatierung

  • Vergrößern des linken Seitenrandes um 0,5 Zoll

Anwenden einer Formatierung auf die Markierung

Im folgenden Beispiel wird die Selection-Eigenschaft verwendet, um dem markierten Text Zeichen- und Absatzformatierung zuzuweisen. Verwenden Sie die Font-Eigenschaft für den Zugriff auf Zeichenformatierungs-Eigenschaften und -Methoden und die ParagraphFormat-Eigenschaft für den Zugriff auf Absatzformatierungs-Eigenschaften und -Methoden.

With Selection.Font
    .Name = "Times New Roman"
    .Size = 14
    .AllCaps = True
End With
With Selection.ParagraphFormat
    .LeftIndent = InchesToPoints(0.5)
    .Space1
End With

Anwenden von Formatierung auf einen Bereich

Im folgenden Beispiel wird ein Range-Objekt definiert, das sich auf die ersten drei Absätze im aktiven Dokument bezieht. Das Range-Objekt (myRange) wird formatiert, indem ihm Eigenschaften des Font- und des ParagraphFormat-Objekts zugewiesen werden.

Set myRange = ActiveDocument.Range( _
    Start:=ActiveDocument.Paragraphs(1).Range.Start, _
    End:=ActiveDocument.Paragraphs(3).Range.End)
With myRange
    .Font.Name = "Arial"
    .ParagraphFormat.Alignment = wdAlignParagraphJustify
End With

Einfügen von Text und Anwenden von Zeichen- und Absatzformatierung

Im folgenden Beispiel wird am Anfang des aktuellen Dokuments das Wort "Title" eingefügt. Der erste Absatz ist zentriert ausgerichtet, und nach dem Absatz wird ein Leerraum von einem halben Zoll hinzugefügt. Das Wort "Title" wird mit der Schriftart Arial in 24 Punkt formatiert.

Set oRange = ActiveDocument.Range(Start:=0, End:=0)
With oRange
    .InsertAfter Text:="Title"
    .InsertParagraphAfter
    .Font.Name = "Arial"
    .Font.Size = 24
End With
With ActiveDocument.Paragraphs(1)
    .Alignment = wdAlignParagraphCenter
    .SpaceAfter = InchesToPoints(.5)
End With

Umschalten des Leerraums vor einem Absatz zwischen 12 Punkt und Null

Im folgenden Beispiel wird der Leerraum vor der Formatierung des ersten Absatzes in der Markierung umgeschaltet. Das Makro ruft den aktuellen Wert "Abstand vor" ab, und wenn der Wert 12 Punkt ist, wird der Leerraum vor der Formatierung entfernt (die SpaceBefore-Eigenschaft wird auf Null gesetzt). Wenn der Wert von "Abstand vor" ungleich 12 ist, dann wird die SpaceBefore-Eigenschaft auf 12 Punkt festgelegt.

Set oParagraph = Selection.Paragraphs(1)
If oParagraph.SpaceBefore = 12 Then
    oParagraph.SpaceBefore = 0
Else
    oParagraph.SpaceBefore = 12
End If

Umschalten der Fettformatierung

Im folgenden Beispiel wird die Fettformatierung des markierten Textes umgeschaltet.

Selection.Font.Bold = wdToggle

Vergrößern des linken Seitenrandes um 0,5 Zoll

Im folgenden Beispiel wird der linke Seitenrand um 0,5 Zoll vergrößert. Das PageSetup-Objekt enthält alle Attribute für die Seiteneinrichtung eines Dokuments (linker Seitenrand, Seitenrand unten, Papierformat usw.) als Eigenschaften. Die LeftMargin-Eigenschaft wird zur Rückgabe und zum Festlegen der Einstellung für den linken Rand verwendet.

iMargin = ActiveDocument.PageSetup.LeftMargin
iMargin = iMargin + InchesToPoints(0.5)
ActiveDocument.PageSetup.LeftMargin = iMargin


Text oder Formatierung suchen und ersetzen

Suchen und ersetzen ist vom Find- und Replacement-Objekt aus möglich. Das Find-Objekt steht dem Selection- und dem Range-Objekt zur Verfügung. Die Suchaktion unterscheidet sich etwas, je nachdem, ob Sie vom Selection- oder dem Range-Objekt aus auf das Find-Objekt zugreifen.

Text suchen und ersetzen

Wenn vom Selection-Objekt aus auf das Find-Objekt zugegriffen und das Suchkriterium gefunden wird, wird die Markierung geändert. Im folgenden Beispiel wird das nächste Vorkommen des Worts "Hello" markiert. Wenn das Ende des Dokuments erreicht ist, bevor das Wort "Hello" gefunden wurde, wird die Suche abgebrochen.

With Selection.Find
    .Forward = True
    .Wrap = wdFindStop
    .Text = "Hello"
    .Execute
End With

Das Find-Objekt umfasst Eigenschaften, die sich auf die Optionen im Dialogfeld Suchen und ersetzen beziehen (wählen Sie Suchen im Menü Bearbeiten). Sie können die einzelnen Eigenschaften des Find-Objekts einstellen oder bei der Execute-Methode Argumente verwenden, wie im folgenden Beispiel zu sehen ist.

Selection.Find.Execute FindText:="Hello", _
    Forward:=True, Wrap:=wdFindStop

Text suchen, ohne die Markierung zu ändern

Wenn von einem Range-Objekt aus auf das Find-Objekt zugegriffen wird und die Suchkriterien gefunden werden, wird die Markierung nicht geändert, aber das Range-Objekt wird neu definiert. Im folgenden Beispiel wird das erste Vorkommen des Worts "blue" im aktiven Dokument gesucht. Wenn die Suchoperation erfolgreich ist, wird der Bereich neu definiert und dem Wort "blue" Fettformatierung zugewiesen.

With ActiveDocument.Content.Find
    .Text = "blue"
    .Forward = True
    .Execute
    If .Found = True Then .Parent.Bold = True
End With

Im folgenden Beispiel wird mit Hilfe von Argumenten der Execute-Methode dasselbe Ergebnis erzielt wie im vorherigen Beispiel.

Set myRange = ActiveDocument.Content
myRange.Find.Execute FindText:="blue", Forward:=True
If myRange.Find.Found = True Then myRange.Bold = True

Verwendung des Replacement-Objekts

Das Replacement-Objekt stellt die Ersetzungskriterien für eine Suchen-und-ersetzen-Operation dar. Die Eigenschaften und Methoden des Replacement-Objekts entsprechen den Optionen im Dialogfeld Suchen und ersetzen im Menü Bearbeiten.

Das Replacement-Objekt steht vom Find-Objekt aus zur Verfügung. Im folgenden Beispiel wird jedes Vorkommen des Wortes "hi" durch "hello" ersetzt. Die Markierung ändert sich, wenn die Suchkriterien gefunden werden, weil vom Selection-Objekt aus auf das Find-Objekt zugegriffen wird.

With Selection.Find
    .ClearFormatting
    .Text = "hi"
    .Replacement.ClearFormatting
    .Replacement.Text = "hello"
    .Execute Replace:=wdReplaceAll, Forward:=True, _
        Wrap:=wdFindContinue
End With

Im folgenden Beispiel wird die Fettformatierung im aktiven Dokument entfernt. Die Bold-Eigenschaft ist True für das Find-Objekt und False für das Replacement-Objekt. Zum Suchen und Ersetzen von Formatierung legen Sie den Such- und Ersetzungstext auf leere Zeichenfolgen ("") fest und das Argument Format der Execute-Methode auf True. Die Markierung bleibt ungeändert, weil von einem Range-Objekt aus auf das Find-Objekt zugegriffen wird (die Content-Eigenschaft gibt ein Range-Objekt zurück).

With ActiveDocument.Content.Find
    .ClearFormatting
    .Font.Bold = True
    With .Replacement
        .ClearFormatting
        .Font.Bold = False
    End With
    .Execute FindText:="", ReplaceWith:="", _
        Format:=True, Replace:=wdReplaceAll
End With


Zurückgabe von Text von einem Dokument

Verwenden Sie die Text-Eigenschaft zur Zurückgabe von Text von einem Range- oder Selection-Objekt. Im folgenden Beispiel wird der nächste Absatz, der mit der Formatvorlage "Überschrift 1" formatiert ist, markiert. Der Inhalt der Text-Eigenschaft wird mit der Funktion MsgBox angezeigt.

With Selection.Find
    .ClearFormatting
    .Style = wdStyleHeading1
    .Execute FindText:="", Format:=True, _
        Forward:=True, Wrap:=wdFindStop
    If .Found = True Then MsgBox Selection.Text
End With

Die folgende Anweisung gibt den markierten Text zurück.

strText = Selection.Text

Im folgenden Beispiel wird das erste Wort im aktiven Dokument zurückgegeben. Jedes Element in der Words-Auflistung ist ein Range-Objekt, das ein Wort darstellt.

aFirst = ActiveDocument.Words(1).Text
MsgBox aFirst

Im folgenden Beispiel wird der Text zurückgegeben, der mit der ersten Textmarke im aktiven Dokument verbunden ist.

If ActiveDocument.Bookmarks.Count >= 1 Then
    bookText = ActiveDocument.Bookmarks(1).Range.Text
    MsgBox bookText
End If


Arbeiten mit Document-Objekten

In Visual Basic sind die Methoden zum Modifizieren von Dateien Methoden des Document-Objekts oder des Documents-Auflistungsobjekts.

Ein neues Dokument erstellen

Die Documents-Auflistung umfasst alle geöffneten Dokumente. Wenn Sie ein neues Dokument erstellen möchten, verwenden Sie die Add-Methode, mit der Sie der Documents-Auflistung ein Document-Objekt hinzufügen. Mit der folgenden Anweisung wird ein neues Dokument erstellt.

Documents.Add

Ein besseres Verfahren zum Erstellen eines neuen Dokuments besteht darin, den Rückgabewert einer Objektvariablen zuzuweisen. Die Add-Methode gibt ein Document-Objekt zurück, das sich auf das neue Dokument bezieht. Im folgenden Beispiel wird das Document-Objekt, das von der Add-Methode zurückgegeben wird, der Objektvariablen newDoc zugewiesen. Dann werden mehrere Eigenschaften und Methoden des Document-Objekts festgelegt. Sie können das neue Dokument leicht mit Hilfe der Objektvariablen newDoc steuern.

Set newDoc = Documents.Add
With newDoc
    .Content.Font.Name = "Arial"
    .SaveAs FileName:="Sample.doc"
End With

Ein Dokument öffnen

Zum Öffnen eines vorhandenen Dokuments verwenden Sie die Open-Methode der Documents-Auflistung. Mit der folgenden Anweisung wird das Dokument MyDocument.doc aus dem Ordner MyFolder geöffnet.

Documents.Open FileName:="C:\MyFolder\MyDocument.doc"

Ein vorhandenes Dokument speichern

Zum Speichern eines einzelnen Dokuments verwenden Sie die Save-Methode des Document-Objekts. Mit der folgenden Anweisung wird das Dokument Sales.doc gespeichert.

Documents("Sales.doc").Save

Sie können alle geöffneten Dokumente speichern, indem Sie die Save-Methode auf die Documents-Auflistung anwenden. Mit der folgenden Anweisung werden alle geöffneten Dokumente gespeichert.

Documents.Save

Ein neues Dokument speichern

Zum Speichern eines einzelnen Dokuments verwenden Sie die SaveAs-Methode bei einem Document-Objekt. Mit der folgenden Anweisung wird das aktive Dokument als Temp.doc im aktuellen Ordner gespeichert.

ActiveDocument.SaveAs FileName:="Temp.doc"

Das Argument FileName kann den Dateinamen oder den vollständigen Pfad (zum Beispiel C:\Dokumente\Temporäre Datei.doc) enthalten.

Dokumente schließen

Zum Schließen eines einzelnen Dokuments verwenden Sie die Close-Methode bei einem Document-Objekt. Mit der folgenden Anweisung wird das Dokument Sales.doc geschlossen und gespeichert.

Documents("Sales.doc").Close SaveChanges:=wdSaveChanges

Sie können alle geöffneten Dokumente schließen, indem Sie die Close-Methode auf die Documents-Auflistung anwenden. Mit der folgenden Anweisung werden alle Dokumente geschlossen, ohne die Änderungen zu speichern.

Documents.Close SaveChanges:=wdDoNotSaveChanges

Im folgenden Beispiel wird der Benutzer aufgefordert, jedes Dokument zu speichern, bevor es geschlossen wird.

For Each aDoc In Documents
    aDoc.Save NoPrompt:=False
    aDoc.Close
Next

Ein Dokument aktivieren

Zum Wechsel des aktiven Dokuments verwenden Sie die Activate-Methode bei einem Document-Objekt. Mit der folgenden Anweisung wird das geöffnete Dokument MyDocument.doc aktiviert.

Documents("MyDocument.doc").Activate

Feststellen, ob ein Dokument geöffnet ist

Um zu ermitteln, ob ein Dokument geöffnet ist, können Sie die Documents-Auflistung mit Hilfe der Anweisung For Each...Next durchlaufen. Im folgenden Beispiel wird das Dokument Sample.doc aktiviert, wenn das Dokument geöffnet ist, oder Sample.doc wird geöffnet, wenn dieses Dokument momentan nicht geöffnet ist.

For Each aDoc In Documents
    If InStr(1, aDoc.Name, "sample.doc", 1) Then
        aDoc.Activate
    Else
        docFound = False
    End If
Next aDoc
If docFound = False Then _
    Documents.Open FileName:="C:\Documents\Sample.doc"

Auf das aktive Dokument Bezug nehmen

Anstatt über den Namen oder die Indexnummer auf ein Dokument Bezug zu nehmen, beispielsweise Documents("Sales.doc"), gibt die ActiveDocument-Eigenschaft ein Document-Objekt zurück, das sich auf das aktive Dokument (das Dokument mit dem Fokus) bezieht. Im folgenden Beispiel wird der Name des aktiven Dokuments angezeigt oder eine Meldung, wenn keine Dokumente geöffnet sind.

If Documents.Count >= 1 Then
    MsgBox ActiveDocument.Name
Else
    MsgBox "No documents are open"
End If


 Arbeiten mit Range-Objekten

Arbeiten mit Range-Objekten

Eine häufige Aufgabe in Visual Basic besteht darin, einen Bereich in einem Dokument anzugeben und dann mit diesem etwas zu tun, beispielsweise Text einzufügen oder Formatierung zuzuweisen. Vielleicht wollen Sie ein Makro schreiben, das ein Wort oder einen Satz in einem Teil eines Dokuments sucht. Der Teil des Dokuments kann durch ein Range-Objekt dargestellt werden. Nachdem das Range-Objekt identifiziert wurde, können Methoden und Eigenschaften des Range-Objekt angewandt bzw. zugewiesen werden, um den Inhalt des Bereichs zu modifizieren.

Ein Range-Objekt bezieht sich auf einen zusammenhängenden Bereich in einem Dokument. Jedes Range-Objekt wird durch eine Start- und Endzeichenposition definiert. So ähnlich wie Textmarken in einem Dokument verwendet werden, werden Range-Objekte in Visual Basic-Prozeduren zum Kennzeichnen bestimmter Teile eines Dokuments verwendet. Ein Range-Objekt kann so klein wie die Einfügemarke sein oder so groß wie das gesamte Dokument. Aber im Gegensatz zu einer Textmarke ist ein Range-Objekt nur vorhanden, während die Prozedur, in der es definiert wird, ausgeführt wird.

Die Start-, End- und StoryType-Eigenschaften kennzeichnen ein Range-Objekt eindeutig. Die Start- und End-Eigenschaften geben die Start- und Endzeichenposition des Range-Objekts zurück oder legen sie fest. Die Zeichenposition am Anfang des Dokuments ist 0 (Null), die Position nach dem ersten Zeichen ist eins usw. Es gibt 11 verschiedene Arten von Dokumentkomponenten, die von den WdStoryType-Konstanten der StoryType-Eigenschaft dargestellt werden.

Anmerkung Range-Objekte sind unabhängig von der Markierung. Das heißt, Sie können einen Bereich definieren und modifizieren, ohne die aktuelle Markierung zu ändern. Sie können in einem Dokument auch mehrere Bereiche definieren, während es nur eine Markierung pro Dokumentausschnitt gibt.

Verwendung der Range-Methode

Die Range-Methode wird zum Erstellen eines Range-Objekts im angegebenen Dokument verwendet. Die Range-Methode (des Document-Objekts) gibt ein Range-Objekt zurück, das sich in der Haupt-Dokumentkomponente befindet, wenn ein Start- und Endpunkt vorgegeben ist. Im folgenden Beispiel wird ein Range-Objekt erstellt, das der Variablen myRange zugewiesen wird.

Set myRange = ActiveDocument.Range(Start:=0, End:=10)

Die Variable myRange bezieht sich auf die ersten zehn Zeichen im aktiven Dokument. Sie können sehen, dass das Range-Objekt erstellt wurde, als Sie eine Eigenschaft oder Methode auf das Range-Objekt angewandt haben, das in der Variablen myRange gespeichert ist. Im folgenden Beispiel wird den ersten zehn Zeichen im aktiven Dokument Fettformatierung zugewiesen.

Set myRange = ActiveDocument.Range(Start:=0, End:=10)
myRange.Bold = True

Wenn Sie sich mehrmals auf ein Range-Objekt beziehen müssen, können Sie die Anweisung Set verwenden, mit der Sie eine Variable mit dem Range-Objekt gleichsetzen können. Wenn Sie jedoch an einem Range-Objekt nur eine einzige Aktion durchführen müssen, ist es nicht nötig, das Objekt in einer Variablen zu speichern. Dieselben Ergebnisse können mit nur einer Anweisung erreicht werden, die den Bereich kennzeichnet und die Bold-Eigenschaft ändert.

ActiveDocument.Range(Start:=0, End:=10).Bold = True

Wie eine Textmarke kann ein Bereich eine Gruppe von Zeichen umfassen oder eine Stelle in einem Dokument markieren. Das Range-Objekt im folgenden Beispiel hat denselben Start- und Endpunkt. Der Bereich enthält keinen Text. Im folgenden Beispiel wird am Anfang des aktiven Dokuments Text eingefügt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myRange.InsertBefore "Hello "

Sie können den Anfangs- und Endpunkt eines Bereichs definieren, indem Sie die Nummern der Zeichenpositionen verwenden, wie das oben zu sehen war, oder Sie verwenden die Start- und End-Eigenschaften bei Objekten wie Selection, Bookmark oder Range. Im folgenden Beispiel wird ein Range-Objekt erstellt, das am Anfang des zweiten Absatzes beginnt und nach dem dritten Absatz endet.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(2).Range.Start, _
    End:=myDoc.Paragraphs(3).Range.End)

Weitere Informationen und Beispiele finden Sie unter der Range-Methode.

Verwendung der Range-Eigenschaft

Die Range-Eigenschaft erscheint bei mehreren Objekten wie Paragraph, Bookmark und Cell und wird zur Rückgabe eines Range-Objekts verwendet. Im folgenden Beispiel wird ein Range-Objekt zurückgegeben, das sich auf den ersten Absatz im aktiven Dokument bezieht.

Set myRange = ActiveDocument.Paragraphs(1).Range

Nachdem Sie ein Range-Objekt erstellt haben, können Sie jede seiner Eigenschaften oder Methoden zum Modifizieren des Range-Objekts verwenden. Im folgenden Beispiel wird der zweite Absatz im aktiven Dokument markiert.

ActiveDocument.Paragraphs(2).Range.Select

Wenn Sie zahlreiche Eigenschaften oder Methoden auf dasselbe Range-Objekt anwenden müssen, können Sie die Struktur With…End With verwenden. Im folgenden Beispiel wird der Text im ersten Absatz des aktiven Dokuments formatiert.

Set myRange = ActiveDocument.Paragraphs(1).Range
With myRange
    .Bold = True
    .ParagraphFormat.Alignment = wdAlignParagraphCenter
    .Font.Name = "Arial"
End With

Weitere Informationen und Beispiele finden Sie unter der Range-Eigenschaft.

Ein Range-Objekt neu definieren

Verwenden Sie die SetRange-Methode zum Neudefinieren eines vorhandenen Range-Objekts. Im folgenden Beispiel wird myRange als die aktuelle Markierung definiert. Die SetRange-Methode definiert myRange neu, so dass der Bereich die aktuelle Markierung und die nächsten zehn Zeichen umfasst.

Set myRange = Selection.Range
myRange.SetRange Start:=myRange.Start, End:=myRange.End + 10

Weitere Informationen und Beispiele finden Sie unter der SetRange-Methode.

Hinweis Wenn Sie in Ihren Makros Fehler beseitigen, können Sie die Select-Methode verwenden, um sicherzustellen, dass ein Range-Objekt sich auf den richtigen Textbereich bezieht. Im folgenden Beispiel wird beispielsweise das Range-Objekt aRange markiert. Das Objekt aRange bezieht sich auf den zweiten und dritten Absatz im aktiven Dokument.

Set aRange = ActiveDocument.Paragraphs(2).Range
aRange.SetRange Start:=aRange.Start, _
    End:=ActiveDocument.Paragraphs(3).Range.End
aRange.Select


Zuweisen von Bereichen

Sie haben verschiedene Möglichkeiten, ein vorhandenes Range-Objekt einer Variable zuzuweisen. In diesem Thema werden die Ergebnisse von zwei verschiedenen Techniken erläutert. In den folgenden Beispielen verweisen die Variablen Range1 und Range2 auf Range-Objekte. In den folgenden Anweisungen werden den Variablen Range1 und Range2 z. B. das erste und zweite Wort im aktiven Dokument zugeordnet.

Set Range1 = ActiveDocument.Words(1)
Set Range2 = ActiveDocument.Words(2)

Gleichsetzen verschiedener Range-Objektvariablen

In der folgenden Anweisung wird für die Bereichsvariable Range2 festgelegt, dass sie die gleiche Position wie Range1 hat.

Set Range2 = Range1

Sie haben jetzt zwei Variablen, die den gleichen Bereich darstellen. Wenn Sie den Anfangs- oder Endpunkt oder den Text von Range2 manipulieren, wirkt sich dies auf Range1 und umgekehrt aus.

Beachten Sie, dass die folgende Anweisung gleichbedeutend mit Range2.Text = Range1.Text ist. Durch diese Anweisung wird die Standardeigenschaft von Range1 (Text-Eigenschaft) der Standardeigenschaft von Range2 zugewiesen. Die Objektverweise werden dabei nicht geändert.

Range2 = Range1

Die Bereiche (Range2 und Range1) haben den gleichen Inhalt, sie können jedoch auf andere Positionen im Dokument oder sogar auf verschiedene Dokumente verweisen.

Zur Verwendung der Duplicate-Eigenschaft

Durch die folgende Anweisung wird ein neues, dupliziertes Range-Objekt, Range2 erstellt, das den gleichen Anfangs- und Endpunkt und den gleichen Text wie Range1 hat.

Set Range2 = Range1.Duplicate

Wenn Sie den Anfangs- oder Endpunkt von Range 1 ändern, wirkt sich dies nicht auf Range2 und umgekehrt aus. Da diese beiden Bereiche auf die gleiche Position im Dokument verweisen, wirken sich Änderungen am Text in einem Bereich auch auf den Text im anderen Bereich aus.


Modifizierung eines Teils eines Dokuments

Visual Basic enthält Objekte, die Sie zum Modifizieren der folgenden Dokumentelemente verwenden können: Zeichen, Wörter, Sätze, Absätze und Abschnitte. Die folgende Tabelle enthält die Eigenschaften, die diesen Dokumentelementen entsprechen, und die Objekte, die sie zurückgeben.

Dieser Ausdruck | Gibt dieses Objekt zurück
Words(Index) | Range
Characters(Index) | Range
Sentences(Index) | Range
Paragraphs(Index) | Paragraph
Sections(Index) | Section

Wenn diese Eigenschaften ohne Index verwendet werden, wird ein Auflistungsobjekt mit demselben Namen zurückgegeben. Beispielsweise gibt die Paragraphs-Eigenschaft das Paragraphs-Auflistungsobjekt zurück. Wenn Sie aber ein Element innerhalb dieser Auflistungen durch den Index kennzeichnen, wird das Objekt in der zweiten Spalte der Tabelle zurückgegeben. Beispielsweise gibt Words(1) ein Range-Objekt zurück. Nachdem Sie ein Range-Objekt haben, können Sie jede der Bereichs-Eigenschaften oder -Methoden zum Modifizieren des Range-Objekts verwenden. Die folgende Anweisung kopiert z. B. das erste Wort in der Markierung in die Zwischenablage.

Selection.Words(1).Copy

Hinweis Die Elemente in den Paragraphs- und Sections-Auflistungen sind singuläre Formen der Auflistung und keine Range-Objekte. Die Range-Eigenschaft (die ein Range-Objekt zurückgibt) steht den Paragraph- und Section-Objekten aber zur Verfügung. Beispielsweise kopiert die folgende Anweisung den ersten Absatz im aktiven Dokument in die Zwischenablage.

ActiveDocument.Paragraphs(1).Range.Copy

Alle Dokumentelement-Eigenschaften in der vorherigen Tabelle stehen den Document-, Selection- und Range-Objekten zur Verfügung. Im folgenden Beispiel wird demonstriert, wie Sie von Document-, Selection- und Range-Objekten zu diesen Eigenschaften hinunterbohren können.

Im folgenden Beispiel wird die Groß-/Kleinschreibung des ersten Worts im aktiven Dokument festgelegt.

ActiveDocument.Words(1).Case = wdUpperCase

Im folgenden Beispiel wird der untere Seitenrand des aktuellen Abschnitts auf 0,5 Zoll festgelegt.

Selection.Sections(1).PageSetup.BottomMargin = InchesToPoints(0.5)

Im folgenden Beispiel wird der Text im aktiven Dokument mit doppeltem Zeilenabstand versehen (die Content-Eigenschaft gibt ein Range-Objekt zurück).

ActiveDocument.Content.ParagraphFormat.Space2

Modifizierung einer Gruppe von Dokumentelementen

Zum Modifizieren eines Textbereichs, der aus einer Gruppe von Dokumentelementen (Zeichen, Wörtern, Sätzen, Absätzen oder Abschnitten) besteht, müssen Sie ein Range-Objekt erstellen. Die Range-Methode erstellt ein Range-Objekt, wenn ein Start- und Endpunkt vorgegeben ist. Die folgende Anweisung erstellt beispielsweise ein Range-Objekt, das sich auf die ersten zehn Zeichen im aktiven Dokument bezieht.

Set myRange = ActiveDocument.Range(Start:=0, End:=10)

Wenn Sie die Start- und End-Eigenschaft bei einem Range-Objekt verwenden, können Sie ein neues Range-Objekt erstellen, das sich auf eine Gruppe von Dokumentelementen bezieht. Die folgende Anweisung erstellt z. B. ein Range-Objekt (myRange), das sich auf die ersten drei Wörter im aktiven Dokument bezieht.

Set Doc = ActiveDocument
Set myRange = Doc.Range(Start:=Doc.Words(1).Start, _
    End:=Doc.Words(3).End)

Im folgenden Beispiel wird ein Range-Objekt (myRange) erstellt, das am Anfang des zweiten Absatzes beginnt und nach dem dritten Absatz endet.

Set Doc = ActiveDocument
Set myRange = Doc.Range(Start:=Doc.Paragraphs(2).Range.Start, _
    End:=Doc.Paragraphs(3).Range.End)

Weitere Informationen über das Definieren von Range-Objekten finden Sie unter Arbeiten mit Range-Objekten.


Arbeiten mit dem Selection-Objekt

Wenn Sie in Word an einem Dokument arbeiten, markieren Sie normalerweise Text und führen dann eine Aktion durch, beispielsweise Formatierung des Textes oder Texteingabe. In Visual Basic ist es normalerweise nicht nötig, den Text zu markieren, bevor Sie ihn modifizieren. Sie erstellen vielmehr ein Range-Objekt, das sich auf einen bestimmten Teil des Dokuments bezieht. Informationen über das Definieren von Range-Objekten finden Sie unter Arbeiten mit Range-Objekten. Wenn Ihr Code aber auf die Markierung reagieren oder diese ändern soll, können Sie das mit dem Selection-Objekt tun.

Die Select-Methode aktiviert ein Objekt. Beispielsweise markiert die folgende Anweisung das erste Wort im aktiven Dokument.

ActiveDocument.Words(1).Select

Weitere Beispiele zur Select-Methode finden Sie unter Select-Methode oder Markierung von Text in einem Dokument.

Die Selection-Eigenschaft gibt ein Selection-Objekt zurück, das die aktive Markierung in einem Dokument-Fensterausschnitt darstellt. In einem Dokument-Fensterausschnitt kann sich nur ein Selection-Objekt befinden und nur ein Selection-Objekt kann aktiv sein. Im folgenden Beispiel wird die Absatzformatierung der Absätze in der Markierung geändert.

Selection.Paragraphs.LeftIndent = InchesToPoints(0.5)

Im folgenden Beispiel wird nach der Markierung das Wort "Hello" eingefügt.

Selection.InsertAfter Text:="Hello"

Im folgenden Beispiel wird dem markierten Text Fettformatierung zugewiesen.

Selection.Font.Bold = True

Die Makroaufzeichnung erstellt oft ein Makro, das die Selection-Eigenschaft verwendet. Das folgende Beispiel wurde mit der Makroaufzeichnung erstellt. Das Makro weist den ersten zwei Wörtern im Dokument Fettformatierung zu.

Selection.HomeKey Unit:=wdStory
Selection.MoveRight Unit:=wdWord, Count:=2, Extend:=wdExtend
Selection.Font.Bold = wdToggle

Im folgenden Beispiel wird dieselbe Aufgabe ohne Verwendung der Selection-Eigenschaft durchgeführt.

ActiveDocument.Range(Start:=0, _
    End:=ActiveDocument.Words(2).End).Bold = True


Mit Tabellen arbeiten

Dieses Thema enthält Visual Basic-Beispiele, die sich auf die folgenden Aufgaben beziehen:

  • Einfügen von Text in eine Tabellenzelle

  • Eine Tabelle erstellen, Text einfügen und Formatierung zuweisen

  • Text aus einer Tabellenzelle zurückgeben, ohne Rückgabe der Zellenendemarke

  • Text in eine Tabelle umwandeln

  • Den Inhalt jeder Tabellenzelle zurückgeben

  • Alle Tabellen im aktiven Dokument in ein neues Dokument kopieren

Einfügen von Text in eine Tabellenzelle

Im folgenden Beispiel wird in der ersten Zelle der ersten Tabelle im aktiven Dokument Text eingefügt. Die Cell-Methode gibt ein einzelnes Cell-Objekt zurück. Die Range-Eigenschaft gibt ein Range-Objekt zurück. Die Delete-Methode wird zum Löschen des vorhandenen Textes verwendet, und die InsertAfter-Methode fügt den Text "Cell 1,1" ein.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1).Cell(Row:=1, Column:=1).Range
        .Delete
        .InsertAfter Text:="Cell 1,1"
    End With
End If

Eine Tabelle erstellen, Text einfügen und Formatierung zuweisen

Im folgenden Beispiel wird am Anfang des Dokuments eine Tabelle mit vier Spalten und drei Zeilen eingefügt. Die Struktur For Each...Next wird dazu verwendet, jede Zelle in der Tabelle durchzugehen. Innerhalb der Struktur For Each...Next wird die InsertAfter-Methode zum Einfügen von Text in die Tabellenzellen (Zelle 1, Zelle 2 usw.) verwendet.

Set oDoc = ActiveDocument
Set oTable = oDoc.Tables.Add( _
    Range:=oDoc.Range(Start:=0, End:=0), NumRows:=3, _
    NumColumns:=4)
iCount = 1
For Each oCell In oTable.Range.Cells
    oCell.Range.InsertAfter "Cell " & iCount
    iCount = iCount + 1
Next oCell
oTable.AutoFormat Format:=wdTableFormatColorful2, _
    ApplyBorders:=True, ApplyFont:=True, ApplyColor:=True

Text aus einer Tabellenzelle zurückgeben, ohne Rückgabe der Zellenendemarke

In den folgenden Beispielen wird der Inhalt jeder Zelle in der ersten Zeile der ersten Dokumenttabelle zurückgegeben und angezeigt.

Set oTable = ActiveDocument.Tables(1)
For Each aCell In oTable.Rows(1).Cells
    Set myRange = ActiveDocument.Range(Start:=aCell.Range.Start, _
        End:=aCell.Range.End - 1)
    MsgBox myRange.Text
Next aCell

Set oTable = ActiveDocument.Tables(1)
For Each aCell In oTable.Rows(1).Cells
    Set myRange = aCell.Range
    myRange.MoveEnd Unit:=wdCharacter, Count:=-1
    MsgBox myRange.Text
Next aCell

Text in eine Tabelle umwandeln

Im folgenden Beispiel wird am Anfang des aktiven Dokuments durch Tabstopps getrennter Text eingefügt und dann der Text in eine Tabelle umgewandelt.

Set oRange1 = ActiveDocument.Range(Start:=0, End:=0)
oRange1.InsertBefore "one" & vbTab & "two" & vbTab & "three" & vbCr
Set oTable1 = oRange1.ConvertToTable( _
    Separator:=Chr(9), NumRows:=1, NumColumns:=3)

Den Inhalt jeder Tabellenzelle zurückgeben

Im folgenden Beispiel wird ein Datenfeld definiert, wobei die Anzahl der Elemente gleich der Anzahl der Zellen in der ersten Dokumenttabelle ist (es wird Option Base 1 vorausgesetzt). Die Struktur For Each...Next wird zur Rückgabe des Inhalts jeder Tabellenzelle und zum Zuweisen des Textes zum entsprechenden Datenfeldelement verwendet.

If ActiveDocument.Tables.Count >= 1 Then
    Set oTable = ActiveDocument.Tables(1)
    iNumCells = oTable.Range.Cells.Count
    ReDim aCells(iNumCells)
    i = 1
    For Each oCell In oTable.Range.Cells
        Set myRange = oCell.Range
        myRange.MoveEnd Unit:=wdCharacter, Count:=-1
        aCells(i) = myRange.Text
        i = i + 1
    Next oCell
End If

Alle Tabellen im aktiven Dokument in ein neues Dokument kopieren

In diesem Beispiel werden die Tabellen des aktuellen Dokuments in ein neues Dokument kopiert.

If ActiveDocument.Tables.Count >= 1 Then
    Set oDoc1 = ActiveDocument
    Set MyRange = Documents.Add.Range(Start:=0, End:=0)
    For Each oTable In oDoc1.Tables
        oTable.Range.Copy
        With MyRange
            .Paste
            .Collapse Direction:=wdCollapseEnd
            .InsertParagraphAfter
            .Collapse Direction:=wdCollapseEnd
        End With
    Next
End If


Bezugnahme auf das aktive Dokumentelement

Wenn Sie sich auf den aktiven Absatz, die aktive Tabelle, das aktive Feld oder ein anderes Dokumentelement beziehen möchten, verwenden Sie die Selection-Eigenschaft zur Rückgabe eines Selection-Objekts. Vom Selection-Objekt aus können Sie auf alle Absätze in der Markierung oder auf den ersten Absatz in der Markierung zugreifen. Im folgenden Beispiel wird der erste Absatz in der Markierung mit einem Rahmen versehen.

Selection.Paragraphs(1).Borders.Enable = True

Im folgenden Beispiel werden alle Absätze in der Markierung mit einem Rahmen versehen.

Selection.Paragraphs.Borders.Enable = True

Im folgenden Beispiel wird der ersten Zeile der ersten Tabelle in der Markierung eine Schattierung zugewiesen.

Selection.Tables(1).Rows(1).Shading.Texture = wdTexture10Percent

Wenn die Markierung keine Tabelle enthält, tritt ein Fehler auf. Verwenden Sie die Count-Eigenschaft, um zu ermitteln, ob in der Markierung eine Tabelle enthalten ist. Im folgenden Beispiel wird der ersten Zeile der ersten Tabelle in der Markierung eine Schattierung zugewiesen.

If Selection.Tables.Count >= 1 Then
    Selection.Tables(1).Rows(1).Shading.Texture = wdTexture10Percent
Else
    MsgBox "Selection doesn't include a table"
End If

Im folgenden Beispiel wird der ersten Zeile jeder Tabelle in der Markierung eine Schattierung zugewiesen. Zum Durchlaufen der einzelnen Tabellen in der Markierung wird die For Each...Next-Schleife verwendet.

If Selection.Tables.Count >= 1 Then
    For Each aTable In Selection.Tables
        aTable.Rows(1).Shading.Texture = wdTexture10Percent
    Next aTable
End If


Verwenden von Ereignissen mit dem Application-Objekt

Um eine Ereignisroutine für ein Ereignis des Application-Objekts zu erstellen, müssen die folgenden drei Schritte ausgeführt werden:

  1. Deklarieren Sie eine Objektvariable in einem Klassenmodul, damit auf die Ereignisse geantwortet wird.

  2. Schreiben Sie die spezifischen Ereignisprozeduren.

  3. Initialisieren Sie das deklarierte Objekt aus einem anderen Modul.

Deklarieren der Objektvariable

Bevor Sie Prozeduren für die Ereignisse des Application-Objekts schreiben können, muss ein neues Klassenmodul erstellt und ein Objekt vom Typ Application mit Ereignissen deklariert werden. Angenommen, ein neues Klassenmodul wird mit dem Namen "EventClassModule" erstellt. Das neue Klassenmodul enthält den folgenden Code:

Public WithEvents App As Word.Application

Schreiben von Ereignisprozeduren

Nachdem das neue Objekt mit Ereignissen deklariert wurde, erscheint es in dem Dropdownlistenfeld Objekt im Klassenmodul, und Sie können Ereignisprozeduren für das neue Objekt schreiben. (Wenn Sie das neue Objekt im Feld "Objekt" markieren, werden die gültigen Ereignisse für das Objekt im Dropdownlistenfeld Prozedur aufgelistet.) Wählen Sie aus dieser Liste ein Ereignis aus. Es wird dem Klassenmodul eine leere Prozedur hinzugefügt.

Private Sub App_DocumentChange()

End Sub

Initialisieren des deklarierten Objekts

Bevor die Prozedur abläuft, muss eine Verbindung zwischen dem deklarierten Objekt im Klassenmodul ("App" in diesem Beispiel) und dem Application-Objekt hergestellt werden. Diese Verbindung kann mit dem folgenden Code aus einem beliebigen Modul hergestellt werden:

Dim X As New EventClassModule
Sub Register_Event_Handler()
    Set X.App = Word.Application
End Sub

Starten Sie die Prozedur "Register_Event_Handler". Nachdem die Prozedur gestartet wurde, verweist das App-Objekt im Klassenmodul auf das Application-Objekt von Word. Die Ereignisprozeduren im Klassenmodul werden dann gestartet, sobald die Ereignisse eintreten.


Verwenden von Ereignissen mit dem Document-Objekt

Das Document-Objekt unterstützt drei Ereignisse: Close, New und Open. In das Klassenmodul "DiesesDokument" werden Prozeduren geschrieben, die auf diese Ereignisse antworten. Mit den folgenden Schritten können Sie eine Ereignisprozedur erstellen.

  1. Doppelklicken Sie auf DiesesDokument in Ihrem Standardprojekt oder Dokumentprojekt im Fenster "Projekt-Explorer". (In der Ordneransicht befindet sich DiesesDokument im Ordner Microsoft Word Objekte.)

  2. Markieren Sie Dokument im Dropdownlistenfeld Objekt.

  3. Markieren Sie im Dropdownlistenfeld Prozedur ein Ereignis.

    Dem Klassenmodul wird eine leere Subroutine hinzugefügt.

  4. Fügen Sie die Visual Basic-Anweisungen hinzu, die gestartet werden sollen, wenn das Ereignis eintritt.

Das folgende Beispiel zeigt eine New-Ereignisprozedur im Standardprojekt an, das ausgeführt wird, wenn ein neues Dokument erstellt wird, das auf der Formatvorlage "Standard" basiert.

Private Sub Document_New()
    MsgBox "New document was created"
End Sub

Das folgende Beispiel zeigt eine Close-Ereignisprozedur in einem Dokumentprojekt an, das nur dann abläuft, wenn das Dokument geschlossen ist.

Private Sub Document_Close()
    MsgBox "Closing the document"
End Sub

Anders als bei Auto-Makros haben Ereignisprozeduren in der Dokumentvorlage "Standard" keinen globalen Bereich. So treten z. B. Ereignisprozeduren in der Dokumentvorlage "Standard" nur dann auf, wenn es sich bei der zugewiesenen Vorlage auch um die Dokumentvorlage "Standard" handelt.

Wenn ein automatisches Makro in einem Dokument und der damit verbundenen Vorlage existiert, wird nur das automatische Makro ausgeführt, das im Dokument gespeichert ist. Wenn eine Ereignisprozedur für ein Document-Ereignis in einem Dokument und der damit verbundenen Vorlage vorhanden ist, werden beide Ereignisprozeduren ausgeführt.

Hinweis Informationen über das Erstellen von Ereignisprozeduren für das Application-Objekt, finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.


Verwenden von Ereignissen mit ActiveX-Steuerelementen

Word-Dokumente können ActiveX-Steuerelemente enthalten. Mit der Steuerelement-Toolbox können Sie ActiveX-Steuerelemente (z. B. Befehlsschaltflächen, Kontrollkästchen und Listenfelder) einfügen. Mit den folgenden Schritten können Sie ein ActiveX-Kontrollkästchen-Steuerelement mit einem LostFocus-Ereignis hinzufügen.

  1. Klicken Sie mit der rechten Maustaste auf eine Symbolleiste in Word und anschließend auf Steuerelement-Toolbox.

  2. Klicken Sie auf das Steuerelement Kontrollkästchen.

    In das aktive Dokument wird ein Kontrollkästchen-Steuerelement eingefügt.

  3. Klicken Sie mit der rechten Maustaste auf das Kontrollkästchen-Steuerelement und dann auf Code anzeigen.

    Word wechselt zum Visual Basic-Editor und zeigt das Klassenmodul ThisDocument mit dem Kontrollkästchen an, das im Dropdownlistenfeld Objekt markiert ist.

  4. Markieren Sie das Ereignis LostFocus im Dropdownlistenfeld Prozedur.

    Dem Klassenmodul wird eine leere Prozedur hinzugefügt.

  5. Fügen Sie die Visual Basic-Anweisungen hinzu, die ablaufen sollen, wenn das Ereignis eintritt.

Das folgende Beispiel zeigt eine LostFocus-Ereignisprozedur, die abläuft, wenn CheckBox1 den Fokus verliert. Das Makro zeigt den Status von CheckBox1 mit der Value-Eigenschaft (True für "markiert" und False für "gelöscht") an.

Private Sub CheckBox1_LostFocus()
    MsgBox CheckBox1.Value
End Sub

Damit Sie die Ereignisprozedur am Bildschirm verfolgen können, wechseln Sie wieder zu Word, in das Dokument mit dem angezeigten Kontrollkästchen. Klicken Sie auf der Steuerelement-Toolbox auf die Schaltfläche Entwurfsmodus beenden. Markieren oder löschen Sie das Kontrollkästchen, und klicken Sie anschließend auf ein anderes Element im Dokument. Das Kontrollkästchen verliert den Fokus, woraufhin Ihre Prozedur LostFocus gestartet wird. Es wird ein Meldungsfeld mit der Angabe True bzw. False angezeigt.

Word implementiert die LostFocus- und GotFocus-Ereignisse für ActiveX-Steuerelemente in einem Word-Dokument. Die anderen Ereignisse im Dropdownlistenfeld Prozedur sind in der Hilfe von Microsoft Forms dokumentiert.


Aufzeichnen eines Makros für das Generieren von Code

Wenn Sie sich nicht sicher sind, welche Visual Basic-Methode oder -Eigenschaft Sie verwenden sollen, können Sie die Makroaufzeichnung aktivieren und die Aktion manuell ausführen. Die Makroaufzeichnung konvertiert Ihre Aktionen in Visual Basic-Code. Nachdem Ihre Aktionen aufgezeichnet wurden, können Sie den Code Ihren Wünschen entsprechend ändern. Wenn Sie sich z. B. nicht sicher sind, welche Eigenschaft oder Methode für einen Absatzeinzug verwendet wird, gehen Sie wie folgt vor:

  1. Wählen Sie im Menü Extras den Befehl Makro, und klicken Sie anschließend auf Aufzeichnen.

  2. Ändern Sie gegebenenfalls den Standardnamen für das Makro, und klicken Sie auf OK, um die Aufzeichnung zu beginnen.

  3. Wählen Sie im Menü Format den Befehl Absatz.

  4. Ändern Sie den Wert für den linken Absatzeinzug, und klicken Sie auf OK.

  5. Klicken Sie auf der Symbolleiste Aufzeichnung beenden auf die Schaltfläche Beenden.

  6. Wählen Sie im Menü Extras den Befehl Makro, und klicken Sie anschließend auf Makros.

  7. Wählen Sie den Namen für das Makro (siehe Schritt 2), und klicken Sie auf die Schaltfläche Bearbeiten.

Betrachten Sie den Visual Basic-Code für die Festlegung der Eigenschaft, die dem linken Absatzeinzug (der LeftIndent-Eigenschaft) entspricht. Positionieren Sie die Einfügemarke auf LeftIndent, und drücken Sie F1, oder klicken Sie auf die Schaltfläche Hilfe. Innerhalb eines Themas können Sie dann Beispiele aufrufen und die Objekte einsehen, die die LeftIndent-Eigenschaft unterstützen (klicken Sie auf Betrifft).

Anmerkung Aufgezeichnete Makros geben das Selection-Objekt mit der Selection-Eigenschaft zurück. Durch die folgende Anweisung werden die markierten Absätze um einen halben Zoll eingerückt.

Selection.ParagraphFormat.LeftIndent = InchesToPoints(0.5)

Sie können jedoch das aufgezeichnete Makro ändern, um mit Range-Objekten zu arbeiten. Informationen hierzu finden Sie unter Überarbeiten aufgezeichneter Visual Basic-Makros.

Die zum Aufzeichnen von Makros erforderlichen Schritte finden Sie unter Erstellen eines Makros.


Aufgezeichnete Visual Basic-Makros überarbeiten

Die Makroaufzeichnung ist eine große Hilfe beim Ausfindigmachen der Visual Basic-Methoden und -Eigenschaften, die Sie verwenden wollen. Wenn Sie nicht wissen, welche Eigenschaften und Methoden Sie verwenden sollen, schalten Sie die Makroaufzeichnung ein, und führen Sie die Aktion manuell durch. Die Makroaufzeichnung übersetzt Ihre Aktionen in Visual Basic-Code. Es gibt aber einige Einschränkungen beim Aufzeichnen von Makros. Folgendes lässt sich nicht aufzeichnen:

  • Bedingte Verzweigungen

  • Variablenzuweisungen

  • Schleifenstrukturen

  • Benutzerdefinierte Formulare

  • Fehlerbehandlung

  • Textmarkierungen mit der Maus (Sie müssen Tastenkombinationen verwenden).

Zum Erweitern Ihrer Makros wollen Sie vielleicht den Code überarbeiten, der in Ihrem Modul aufgezeichnet wurde.

Entfernung der Selection-Eigenschaft

Makros, die über die Makroaufzeichnung erstellt wurden, sind von der Markierung abhängig. Am Anfang der meisten aufgezeichneten Makro-Anweisungen sehen Sie "Selection". Aufgezeichnete Makros verwenden die Selection-Eigenschaft zur Zurückgabe des Selection-Objekts. Im folgenden Beispiel wird die Markierung zur Textmarke Temp verschoben, und nach der Textmarke wird Text eingefügt.

Sub Macro1()
Selection.Goto What:=wdGotoBookmark, Name:="Temp"
Selection.MoveRight Unit:=wdCharacter, Count:=1
Selection.TypeText Text:="New text"
End Sub

Dieses Makro führt die Aufgabe durch, aber es hat eine Reihe von Nachteilen. Erstens: Wenn das Dokument keine Textmarke "Temp" hat, generiert das Makro einen Fehler. Zweitens: Das Makro verschiebt die Markierung, was möglicherweise ungeeignet ist. Diese beiden Probleme können gelöst werden, indem man das Makro so überarbeitet, dass es das Selection-Objekt nicht verwendet. Dies ist das überarbeitete Makro:

Sub MyMacro()
If ActiveDocument.Bookmarks.Exists("Temp") = True Then
    endloc = ActiveDocument.Bookmarks("Temp").End
    ActiveDocument.Range(Start:=endloc, _
        End:=endloc).InsertAfter "New text"
End If
End Sub

Die Exists-Methode wird zum Prüfen verwendet, ob die Textmarke Temp vorhanden ist. Wenn die Textmarke gefunden wird, wird die Endzeichenposition der Textmarke durch die End-Eigenschaft zurückgegeben. Zum Schluss wird die Range-Methode zur Zurückgabe eines Range-Objekts verwendet, das sich auf die Endposition der Textmarke bezieht, so dass mit der InsertAfter-Methode Text eingefügt werden kann. Weitere Informationen über die Definition von Range-Objekten finden Sie unter Arbeiten mit Range-Objekten.

Verwendung von With…End With

Makro-Anweisungen, die sich auf dasselbe Objekt beziehen, können mit der Struktur With…End With vereinfacht werden. Beispielsweise wurde das folgende Makro aufgezeichnet, als über einem Dokument ein Titel hinzugefügt wurde.

Sub Macro1()
Selection.HomeKey Unit:=wdStory
Selection.TypeText Text:="Title"
Selection.ParagraphAlignment.Alignment = wdAlignParagraphCenter
End Sub

Die Selection-Eigenschaft wird bei jeder Anweisung zur Zurückgabe eines Selection-Objekts verwendet. Das Makro kann so vereinfacht werden, dass die Selection-Eigenschaft nur einmal verwendet wird.

Sub MyMacro()
With Selection
    .HomeKey Unit:=wdStory
    .TypeText Text:="Title"
    .ParagraphAlignment.Alignment = wdAlignParagraphCenter
End With
End Sub

Dieselbe Aufgabe kann auch ohne Verwendung des Selection-Objekts durchgeführt werden. Das folgende Makro verwendet zum Durchführen derselben Aufgabe ein Range-Objekt am Anfang des aktiven Dokuments.

Sub MyMacro()
With ActiveDocument.Range(Start:=0, End:=0)
    .InsertAfter "Title"
    .ParagraphFormat.Alignment = wdAlignParagraphCenter
End With
End Sub

Entfernung überflüssiger Eigenschaften

Wenn Sie ein Makro aufzeichnen, bei dem in einem Dialogfeld eine Option ausgewählt wird, zeichnet die Makroaufzeichnung die Einstellungen aller Optionen im Dialogfeld auf, auch wenn Sie nur eine oder zwei der Optionen ändern. Wenn Sie nicht alle Optionen ändern müssen, können Sie die unnötigen Eigenschaften aus dem aufgezeichneten Makro entfernen. Das folgende aufgezeichnete Makro enthält eine Anzahl von Optionen des Dialogfelds Absatz im Menü Format.

Sub Macro1()
With Selection.ParagraphFormat
    .LeftIndent = InchesToPoints(0)
    .RightIndent = InchesToPoints(0)
    .SpaceBefore = 6
    .SpaceAfter = 6
    .LineSpacingRule = 0
    .Alignment = wdAlignParagraphLeft
    .WidowControl = True
    .KeepWithNext = False
    .KeepTogether = False
    .PageBreakBefore = False
    .NoLineNumber = False
    .Hyphenation = True
    .FirstLineIndent = InchesToPoints(0)
    .OutlineLevel = 10
End With
End Sub

Wenn Sie jedoch nur den Leerraum vor und nach dem Absatz ändern wollen, können Sie das Makro folgendermaßen ändern:

Sub MyMacro()
With Selection.ParagraphFormat
    .SpaceBefore = 6
    .SpaceAfter = 6
End With
End Sub

Das vereinfachte Makro wird schneller ausgeführt, weil es weniger Eigenschaften festlegt. Nur der "Abstand vor" und der "Abstand nach" werden geändert; alle anderen Einstellungen für die markierten Absätze bleiben ungeändert.

Entfernung überflüssiger Argumente

Wenn die Makroaufzeichnung eine Methode aufzeichnet, werden die Werte aller Argumente mitaufgenommen. Das folgende Makro wurde aufgezeichnet, als das Dokument "Test.doc" geöffnet wurde. Das resultierende Makro enthält alle Argumente für die Open-Methode.

Sub Macro1()
Documents.Open FileName:="C:\My Documents\Test.doc", _
    ConfirmConversions:= False, ReadOnly:=False, _
    AddToRecentFiles:=False, PasswordDocument:="", _
    PasswordTemplate:="", Revert:=False, _
    WritePasswordDocument:="", _
    WritePasswordTemplate:="", Format:=wdOpenFormatAuto
End Sub

Die Argumente, die nicht nötig sind, können aus dem aufgezeichneten Makro entfernt werden. Beispielsweise könnten Sie alle Argumente entfernen, die mit einer leeren Zeichenfolge besetzt wurden (z. B. WritePasswordDocument:=""), wie im folgenden zu sehen ist:

Sub MyMacro()
Documents.Open FileName:="C:\My Documents\Test.doc", _
    ConfirmConversions:= False, _
    ReadOnly:=False, AddToRecentFiles:=False, _
    Revert:=False, Format:=wdOpenFormatAuto
End Sub


Auto-Makros

Durch Benennen des Makros mit einem besonderen Namen können Sie es automatisch starten, wenn Sie Operationen ausführen (z. B. das Starten von Word oder Öffnen eines Dokuments). Word erkennt die folgenden Namen als Auto-Makros:

Name des Makros | Ausführung
AutoExec | Beim Starten von Word oder Laden einer globalen Vorlage
AutoNew | Beim Erstellen eines neuen Dokuments
AutoOpen | Beim Öffnen eines vorhandenen Dokuments
AutoClose | Beim Schließen eines Dokuments
AutoExit | Beim Beenden von Word oder Entladen einer globalen Vorlage

Auto-Makros werden in Codemodulen erkannt, wenn sie eine der folgenden Bedingungen erfüllen.

  • Das Modul ist nach dem Namen des Auto-Makros benannt (z. B. "AutoExec") und enthält eine Prozedur mit der Bezeichnung "Main".

  • Eine Prozedur in einem Modul ist nach dem Auto-Makro benannt.

Auto-Makros können, wie alle anderen Makros auch, in der Dokumentvorlage Normal.dot, einer anderen Vorlage oder in einem Dokument gespeichert werden. Damit ein Auto-Makro ausgeführt werden kann, muss es sich entweder in der Vorlage Normal.dot, im aktiven Dokument oder in der Dokumentvorlage befinden, die für das aktive Dokument verwendet wurde. Die einzige Ausnahme bildet das Makro "AutoExec", das nur dann automatisch abläuft, wenn es an einem der folgenden Orte gespeichert wurde: in der Vorlage Normal.dot, in einer Vorlage, die global über das Dialogfeld Dokumentvorlagen und Add-Ins geladen wird, oder in einer globalen Vorlage, die im Ordner Startup abgelegt ist.

Bei einem Namenskonflikt (d. h., mehrere Auto-Makros haben denselben Namen) startet Word das Auto-Makro, das am ehesten dem Kontext entspricht. Wenn Sie z. B. ein AutoClose-Makro in einem Dokument und der damit verbundenen Vorlage erstellen, wird nur das im Dokument enthaltene automatische Makro ausgeführt. Wenn Sie ein AutoNew-Makro in der Dokumentvorlage Normal.dot erstellen, wird das Makro dann ausgeführt, wenn im Dokument oder der damit verbundenen Vorlage kein Makro mit der Bezeichnung AutoNew vorhanden ist.

Anmerkung Wenn Sie die Taste STRG gedrückt halten, werden Auto-Makros nicht gestartet. Erstellen Sie z. B. ein neues Dokument, das auf einer Vorlage basiert, die ein AutoNew-Makro enthält, können Sie den Start dieses AutoNew-Makros dadurch verhindern, dass Sie im Dialogfeld Neu (Menü Datei) auf OK klicken und dabei die Taste STRG so lange gedrückt halten, bis das neue Dokument angezeigt wird. Bei einem Makro, das ein Auto-Makro auslösen kann, können Sie den Start von Auto-Makros mit der folgenden Anweisung verhindern.

WordBasic.DisableAutoMacros


Ändern von Word-Befehlen

Die meisten Word-Befehle können Sie ändern, indem Sie diese in Makros umwandeln. So können Sie z. B. den Befehl Öffnen im Menü Datei so ändern, dass nicht mehr eine Liste mit Word-Dokumenten (Dateien mit der Dateinamenerweiterung .doc) angezeigt wird, sondern alle Dateien des aktuellen Ordners.

Damit eine Liste der integrierten Word-Befehle im Dialogfeld Makros angezeigt werden kann, muss im Feld Makros in die Option Word-Befehlen aktiviert sein. Es wird jeder Menübefehl und jeder Befehl aufgelistet, der auf einer Symbolleiste oder über Shortcuts verfügbar ist. Menübefehle beginnen mit dem Menünamen und dem zugehörigen Befehl. So ist z. B. der Befehl Speichern im Menü Datei mit der Bezeichnung DateiSpeichern aufgeführt.

Sie können einen Word-Befehl durch ein Makro ersetzen, indem Sie dem Makro denselben Namen zuweisen, den der Word-Befehl hat. Wenn Sie z. B. das Makro "DateiSpeichern" erstellen, dann startet Word dieses Makro, wenn Sie im Menü Datei den Befehl Speichern wählen, auf der Symbolleiste auf die Schaltfläche Speichern klicken oder die Tastenkombination für DateiSpeichern drücken.

Dieses Beispiel enthält die einzelnen Schritte für das Ändern des Befehls "DateiSpeichern".

  1. Wählen Sie im Menü Extras den Befehl Makro, und klicken Sie anschließend auf Makros.

  2. Wählen Sie Word-Befehlen im Feld Makros in.

  3. Wählen Sie DateiSpeichern im Feld Makroname.

  4. Wählen Sie im Feld Makros in eine Vorlage oder Dokumentposition, um das Makro abzulegen. Wählen Sie z. B. Normal.dot (Globale Dokumentvorlage), um ein globales Makro zu erstellen (der Befehl DateiSpeichern wird für alle Dokumente geändert).

  5. Klicken Sie auf die Schaltfläche Erstellen.

Das Makro DateiSpeichern erscheint wie unten angezeigt.

Sub FileSave()
'
' FileSave Macro
' Saves the active document or template
'
    ActiveDocument.Save

End Sub

Sie können zusätzliche Anweisungen hinzufügen oder die vorhandene Anweisung ActiveDocument.Save entfernen. Jedes Mal, wenn der Befehl DateiSpeichern ausgeführt wird, läuft nicht der Word-Befehl, sondern Ihr Makro "DateiSpeichern" ab. Um den ursprünglichen Befehl wiederherzustellen, muss das Makro "DateiSpeichern" entweder umbenannt oder gelöscht werden.

Anmerkung Sie können einen Word-Befehl auch ersetzen, indem Sie mit der Subroutine "Main" ein Codemodul erstellen, das nach einem Word-Befehl (z. B. "DateiSpeichern") benannt ist.


Speichern von Werten bei Beendigung eines Makros

Wenn ein Makro endet, werden die in seinen Variablen enthaltenen Werte nicht automatisch auf einem Datenträger gespeichert. Wenn ein Wert erhalten bleiben soll, muss dieser Wert außerhalb des Makros gespeichert werden, bevor die Ausführung des Makros abgeschlossen ist. In diesem Thema werden fünf Speicherorte beschrieben, an denen Makrowerte einfach gespeichert und von denen sie abgerufen werden können.

Dokumentvariablen

Mit Dokumentvariablen können Sie Werte als Teil eines Dokuments oder einer Dokumentvorlage speichern. So können Sie Makrowerte beispielsweise in dem Dokument oder der Dokumentvorlage speichern, in dem oder in der das Makro enthalten ist. Sie können Variablen einem Dokument oder einer Dokumentvorlage hinzufügen, indem Sie die Add-Methode der Variables-Auflistung verwenden. Im folgenden Beispiel wird die ThisDocument-Eigenschaft verwendet, um eine Dokumentvariable am selben Ort zu speichern wie das aktuell ausgeführte Makro (Dokument oder Dokumentvorlage).

ThisDocument.Variables.Add Name:="Age", Value:=12

Im folgenden Beispiel wird die Value-Eigenschaft mit einem Variable-Objekt verwendet, um den Wert einer Dokumentvariable zurückzugeben.

num = ThisDocument.Variables("Age").Value

Anmerkung Zum Einfügen einer Dokumentvariable in ein Dokument können Sie das DOCVARIABLE-Feld verwenden.

Dokumenteigenschaften

Wie mit Dokumentvariablen können Werte auch mit Hilfe von Dokumenteigenschaften als Teil eines Dokuments oder einer Dokumentvorlage gespeichert werden. Dokumenteigenschaften können im Dialogfeld Eigenschaften (Menü Datei) eingesehen werden.

Nach dem Objektmodell von Word werden Dokumenteigenschaften in zwei Gruppen eingeteilt: integrierte und benutzerdefinierte Dokumenteigenschaften. Benutzerdefinierte Dokumenteigenschaften sind die Eigenschaften, die im Dialogfeld Eigenschaften auf der Registerkarte Anpassen angezeigt werden. Als integrierte Dokumenteigenschaften gelten die Eigenschaften auf allen Registerkarten im Dialogfeld Eigenschaften mit Ausnahme der Registerkarte Anpassen.

Für den Zugriff auf integrierte Eigenschaften verwenden Sie die BuiltInDocumentProperties-Eigenschaft. Diese gibt eine DocumentProperties-Auflistung zurück, die die integrierten Dokumenteigenschaften enthält. Verwenden Sie die CustomDocumentProperties-Eigenschaft zur Rückgabe einer DocumentProperties-Auflistung, die die benutzerdefinierten Dokumenteigenschaften enthält. Im folgenden Beispiel wird eine benutzerdefinierte Dokumenteigenschaft mit dem Namen "YourName" am selben Ort erstellt, an dem sich das momentan ausgeführte Makro befindet (Dokument oder Dokumentvorlage).

ThisDocument.CustomDocumentProperties.Add Name:="YourName", _
    LinkToContent:=False, Value:="Joe", Type:=msoPropertyTypeString

Integrierte Dokumenteigenschaften können nicht der DocumentProperties-Auflistung hinzugefügt werden, die durch die BuiltInDocumentProperties-Eigenschaft zurückgegeben wird. Sie können jedoch den Inhalt einer integrierten Dokumenteigenschaft abrufen oder den Wert einer integrierten Dokumenteigenschaft mit Schreib-Lese-Zugriff ändern.

Anmerkung Zum Einfügen von Dokumenteigenschaften in ein Dokument können Sie das DOCPROPERTY-Feld verwenden.

AutoText-Einträge

AutoText-Einträge können verwendet werden, um Informationen in einer Dokumentvorlage zu speichern. Anders als Dokumentvariablen oder -eigenschaften können AutoText-Einträge neben Makrovariablen auch andere Elemente enthalten, wie zum Beispiel formatierten Text oder eine Grafik. Verwenden Sie zum Erstellen eines neuen AutoText-Eintrags die Add-Methode in Verbindung mit der AutoTextEntries-Auflistung. Im folgenden Beispiel wird ein AutoText-Eintrag mit dem Namen "MyText" erstellt, der den Inhalt der Markierung enthält. Wenn die folgende Anweisung Teil eines Makros in Dokumentvorlage ist, wird der AutoText-Eintrag in der Dokumentvorlage gespeichert. Andernfalls wird der AutoText-Eintrag in der Dokumentvorlage des Dokumentes gespeichert, in dem sich die Anweisung befindet.

ThisDocument.AttachedTemplate.AutoTextEntries.Add Name:="MyText", _
    Range:=Selection.Range

Verwenden Sie die Value-Eigenschaft in Verbindung mit einem AutoTextEntry-Objekt, wenn Sie den Inhalt eines AutoText-Eintragsobjekts abrufen möchten.

Einstellungsdateien

Mit der PrivateProfileString-Eigenschaft können Sie die in einer Einstellungsdatei enthaltenen Informationen festlegen und abrufen. Die Struktur einer Windows-Einstellungsdatei entspricht der Struktur der WIN.INI-Datei in Windows 3.1. Im folgenden Beispiel wird der Schlüssel DocNum im Abschnitt DocTracker der Datei Macro.ini auf 1 gesetzt.

System.PrivateProfileString( _
    FileName:="C:\My Documents\Macro.ini", _
    Section:="DocTracker", Key:="DocNum") = 1

Nach dem Ausführen der obigen Anweisung enthält die Datei Macro.ini den folgenden Text.

[DocTracker]
DocNum=1

Die PrivateProfileString-Eigenschaft besitzt drei Argumente: FileName, Section und Key. Mit dem Argument FileName werden Pfad und Dateiname für eine Einstellungsdatei festgelegt. Das Argument Section gibt den Abschnittsnamen an, der in Klammern vor dem zugehörigen Schlüssel steht. (Die Klammern gehören nicht zum Abschnittsnamen!) Das Argument Key gibt den Namen des Schlüssels an, gefolgt von einem Gleichheitszeichen (=) und der Einstellung.

Verwenden Sie dieselbe PrivateProfileString-Eigenschaft, um eine Einstellung aus einer Einstellungsdatei abzurufen. Im folgenden Beispiel wird die DocNum-Einstellung aus dem Abschnitt DocTracker der Datei Macro.ini abgerufen.

num = System.PrivateProfileString( _
    FileName:="C:\My Documents\Macro.ini", _
    Section:="DocTracker", Key:="DocNum")

Windows-Registrierung

Mit der PrivateProfileString-Eigenschaft können Sie Einstellungen in der Windows-Registrierung vornehmen und aus dieser abrufen. Im folgenden Beispiel wird das Programmverzeichnis von Word 2000 aus der Windows-Registrierung abgerufen.

aSec = "HKEY_CURRENT_USER\Software\Microsoft" _
    & "\Office\9.0\Word\Options"
programDir = System.PrivateProfileString(FileName:="", _
    Section:=aSec, Key:="PROGRAMDIR")
MsgBox programDir

Die PrivateProfileString-Eigenschaft besitzt drei Argumente: FileName, Section und Key. Zum Festlegen oder für die Rückgabe eines Wertes aus einem Registrierungseintrag definieren Sie für das Argument FileName einen leeren String (""). Das Argument Section enthält den vollständigen Pfad zum Unterschlüssel der Registrierung, und das Argument Key enthält den Namen eines Eintrags in dem durch das Argument Section angegebenen Unterschlüssel.

Zum Festlegen von Informationen in der Windows-Registrierung können Sie auch die folgende Syntax für PrivateProfileString verwenden.

System.PrivateProfileString(FileName, Section, Key) = Value

Im folgenden Beispiel wird in der Windows-Registrierung im Unterschlüssel Options für Word 9.0 der Eintrag DOC-PATH auf C:\ gesetzt.

aSec = "HKEY_CURRENT_USER\Software\Microsoft" _
    & "\Office\9.0\Word\Options"
System.PrivateProfileString(FileName:="", _
    Section:=aSec, Key:="DOC-PATH") = "C:\"


Verwenden von ActiveX-Steuerelementen in einem Dokument

Genauso wie Sie benutzerdefinierten Dialogfeldern ActiveX-Steuerelemente hinzufügen können, können Sie Dokumenten direkt Steuerelemente hinzufügen. So können Benutzern direkt auf Makros zuzugreifen, ohne dazu Dialogfelder aufrufen zu müssen. Verwenden Sie das folgende Verfahren, um Ihrem Dokument ActiveX-Steuerelemente hinzuzufügen. Weitere Informationen über die Verwendung von ActiveX-Steuerlementen in Word finden Sie unter Verwenden von ActiveX-Steuerelementen in Word-Dokumenten.

  1. Hinzufügen von Steuerelementen zu einem Dokument

    Um ein Steuerelement auf der Zeichnungsebene eines Dokuments einzufügen, klicken Sie in der Steuerelement-Toolbox auf ein Steuerelement. Zum Einfügen eines Steuerelements auf der Textebene klicken Sie bei gedrückter UMSCHALTTASTE in der Steuerelement-Toolbox auf ein Steuerelement.

  2. Festlegen der Eigenschaften von Steuerelementen

    Klicken Sie im Entwurfsmodus mit der rechten Maustaste auf ein Steuerelement, und klicken Sie dann auf Eigenschaften, um das Eigenschaftenfenster einzublenden.

  3. Initialisieren der Steuerelemente

    Sie können Steuerelemente in einer Prozedur initialisieren.

  4. Schreiben von Ereignisprozeduren

    Alle Steuerlemente verfügen über einen vordefinierten Satz von Ereignissen. So verfügt beispielsweise eine Befehlsschaltfläche über ein Click-Ereignis, das eintritt, wenn der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren verfassen, die ausgeführt werden, wenn das betreffende Ereignis eintritt.

  5. Verwenden der Werte von Steuerelementen beim Ausführen von Code

    Einige Eigenschaften können während der Laufzeit festgelegt werden.


Erstellen eines benutzerdefinierten Dialogfeldes

Verwenden Sie die folgende Prozedur zum Erstellen eines benutzerdefinierten Dialogfeldes:

  1. Erstellen eines UserForms

    Klicken Sie im Visual Basic-Editor im Menü Einfügen auf UserForm.

  2. Hinzufügen von Steuerelementen zu einem UserForm

    Suchen Sie in der Toolbox das Steuerelement, das Sie einfügen möchten, und ziehen Sie es auf das Formular.

  3. Festlegen der Eigenschaften von Steuerelementen

    Klicken Sie im Entwurfsmodus mit der rechten Maustaste auf ein Steuerelement und dann auf Eigenschaften, um das Eigenschaftenfenster zu öffnen.

  4. Initialisieren der Eigenschaften von Steuerelementen

    Sie können die Steuerelemente vor dem Anzeigen des Formulars in einer Prozedur initialisieren oder dem Initialize-Ereignis des Formulars Code hinzufügen.

  5. Schreiben von Ereignisprozeduren

    Steuerelemente haben einen vordefinierten Ereignissatz. So hat z. B. eine Befehlsschaltfläche ein Click-Ereignis, das eintritt, sobald der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren verfassen, die aufgerufen werden, wenn die entsprechenden Ereignisse eintreten.

  6. Anzeigen des Dialogfeldes

    Verwenden Sie die Show-Methode zum Anzeigen eines UserForms.

  7. Verwenden der Werte von Steuerelementen beim Ausführen von Code

    Einige Eigenschaften können zur Laufzeit festgelegt werden. Vom Benutzer eingestellte Werte für Steuerelemente im Dialogfeld gehen verloren, wenn das Dialogfeld geschlossen wird.


Anzeigen von integrierten Dialogfeldern bei Word

Mit integrierten Dialogfeldern können Sie Benutzereingaben aufrufen oder Word mit Visual Basic steuern. Die Show-Methode des Dialog-Objekts zeigt eine Aktion in einem integrierten Dialogfeld an und führt diese Aktion aus. Um auf ein bestimmtes integriertes Dialogfeld von Word zugreifen zu können, geben Sie eine WdWordDialog-Konstante mit der Dialogs-Eigenschaft an. So zeigt z. B. die folgende Makro-Anweisung das Dialogfeld Öffnen an (wdDialogFileOpen).

Dialogs(wdDialogFileOpen).Show

Wenn Sie auf OK klicken, während eine Datei markiert ist, wird diese Datei geöffnet (Die Aktion wird ausgeführt). Das folgende Beispiel zeigt das Dialogfeld Drucken an (wdDialogFilePrint).

Dialogs(wdDialogFilePrint).Show

Legt die DefaultTab-Eigenschaft fest, um auf eine bestimmte Registerkarte in einem Dialogfeld von Word zuzugreifen. Das folgende Beispiel zeigt die Registerkarte Page Border im Dialogfeld Rahmen und Schattierung an (Menü Format).

With Dialogs(wdDialogFormatBordersAndShading)
    .DefaultTab = wdDialogFormatBordersAndShadingTabPageBorder
    .Show
End With

Die Display-Methode zeigt ein Dialogfeld an, ohne die Aktionen im Dialogfeld auszuführen. Dies empfiehlt sich besonders dann, wenn mit dem integrierten Dialogfeld der Benutzer aufgefordert werden und die Einstellungen zurückgegeben werden sollen. Die folgende Makro-Anweisung zeigt z. B. die Registerkarte Benutzer-Info aus dem Dialogfeld Optionen an und gibt anschließend den Benutzernamen zurück und zeigt ihn an.

With Dialogs(wdDialogToolsOptionsUserInfo)
    .Display
    MsgBox .Name
End With

Wurde im vorherigen Beispiel der Benutzername geändert, wird diese Änderung nicht im Dialogfeld festgelegt. Mit der Execute-Methode können Sie die Einstellungen im Dialogfeld ausführen, ohne das Dialogfeld anzuzeigen. Das folgende Beispiel zeigt das Dialogfeld "Benutzer-Info" an. Wenn der Name keine leere Zeichenfolge ist, werden die Einstellungen im Dialogfeld mit der Execute-Methode übernommen.

With Dialogs(wdDialogToolsOptionsUserInfo)
    .Display
    If .Name <> "" Then .Execute
End With

Zurückgeben und Ändern von Einstellungen für Dialogfelder

Bevor eine Einstellung für ein Dialogfeld zurückgegeben oder geändert wird, muss das individuelle Dialogfeld identifiziert werden. Dies wird mit der Dialogs-Eigenschaft und einer WdWordDialog-Konstante durchgeführt. Das folgende Beispiel gibt ein Dialog-Objekt zurück, das sich auf das Dialogfeld Absatz (Menü Format) bezieht.

Set myDialog = Dialogs(wdDialogFormatParagraph)

Nachdem Sie ein Dialog-Objekt haben, können Optionen im Dialogfeld zurückgegeben oder festgelegt werden. Das folgende Beispiel zeigt den rechten Einzug des Dialogfelds Absatz an.

Set myDialog = Dialogs(wdDialogFormatParagraph)
Msgbox "Right indent = " & myDialog.RightIndent

Viele integrierte Dialogfelder von Word haben Argumente, mit denen Sie Werte aus einem Dialogfeld festlegen oder aufrufen können (RightIndent im vorherigen Beispiel). Informationen darüber, welche Argumente Ihnen zur Verfügung stehen, finden Sie unter Integrierte Argumentlisten für Dialogfelder.

Einstellungen für Dialogfelder können nicht nur zurückgegeben, sondern auch festgelegt werden. Das folgende Beispiel aktiviert im Dialogfeld Absatz das Kontrollkästchen Absätze nicht trennen.

With Dialogs(wdDialogFormatParagraph)
    .KeepWithNext = 1
    .Execute
End With

Das Kontrollkästchen Absätze nicht trennen ist aktiviert, und die Execute-Methode legt den Wert für die geänderten Einstellungen im Dialogfeld fest. Die folgenden Visual Basic-Anweisungen entsprechen den vier Anweisungen im vorherigen Beispiel.

Selection.Paragraphs(1).KeepWithNext = True

Wenn ein Wert mit einer Eigenschaft oder Methode festgelegt werden kann, empfiehlt es sich nicht, ein Dialog-Objekt zu verwenden, um einen Wert zu ändern.

Hinweis Mit der Update-Methode können Sie sicherstellen, dass es sich bei den Werten im Dialogfeld um die aktuellen Werte handelt. Gegebenenfalls können Sie die Update-Methode verwenden, wenn Sie in Ihrem Makro zu Anfang eine Dialogfeldvariable definieren, wobei später die aktuellen Einstellungen zurückgegeben oder geändert werden sollen.

Vordefinieren von Einstellungen für Dialogfelder

Die vorherigen Beispiele haben zwar Dialogfeldwerte für das Zurückgeben und Festlegen, Dialogfelder werden jedoch nicht angezeigt. Sie können außerdem die Einstellungen in einem integrierten Dialogfeld von Word ändern, bevor Sie die Show-Methode verwenden. So können Sie zum Beispiel den Suchtext ändern, bevor Sie das Dialogfeld Suchen und Ersetzen (Menü Bearbeiten) anzeigen. Das folgende Beispiel zeigt das Dialogfeld Suchen und Ersetzen an, wobei das Wort "Blau" im Bearbeitungsfeld Suchen nach vordefiniert ist.

With  Dialogs(wdDialogEditFind)
    .Find = "Blue"
    .Show
End With

Das folgende Beispiel zeigt das Dialogfeld Öffnen an, in dem alle Dateinamen angezeigt werden.

With Dialogs(wdDialogFileOpen)
    .Name = "*.*"
    .Show
End With

Methoden für das Schließen von Dialogfeldern prüfen

Der Wert, der von den Show- und Display-Methoden zurückgegeben wird, gibt an, auf welcher Schaltfläche geklickt wurde, um das Dialogfeld zu schließen. Das folgende Beispiel zeigt das Dialogfeld Manueller Wechsel an, wobei eine Meldung in der Statusleiste angezeigt wird, wenn Sie auf OK klicken.

If Dialogs(wdDialogInsertBreak).Show = -1 Then
    StatusBar = "Break inserted"
End If
Rückgabewert | Beschreibung
-2 | Die Schaltfläche Schließen.
-1 | Die Schaltfläche OK.
0 | Die Schaltfläche Abbrechen.
> 0 | Eine Befehlsschaltfläche: 1 ist die erste Schaltfläche, 2 die zweite Schaltfläche usw.


Verwenden der DAOs von Microsoft Word

Sie können die Eigenschaften, Objekte und Methoden der Data Access-Objekte (DAOs) genau so verwenden, wie Sie Microsoft Word-Eigenschaften, Objekte und Methoden verwenden und auf diese verweisen. Nachdem Sie einen Verweis auf die DAO-Objektbibliothek erstellt haben, können Sie Datenbanken öffnen, Abfragen für Datensätze entwerfen und ausführen und die Ergebnisse nach Word exportieren.

Verweisen auf ein DAO

Bevor Sie ein DAO verwenden können, muss ein Verweis zur DAO-Objektbibliothek hergestellt werden. Mit den folgenden Schritten können Sie diesen Verweis erstellen.

  1. Wechseln Sie zum Visual Basic-Editor.

  2. Klicken Sie im Menü Extras auf Verweise.

  3. Klicken Sie im Feld Verfügbare Verweise auf Microsoft DAO 3.6-Object Library.

Ist Microsoft DAO 3.6 Object Library im Feld Verfügbare Verweise nicht enthalten, starten Sie Office Professional Setup, um die Data Access-Objekte für Visual Basic zu installieren. Die Microsoft DAO 3.6 Object Library ist in der Einzelversion von Word oder in Microsoft Office 2000 Standard nicht enthalten.

Das folgende Beispiel öffnet die Datenbank "Northwind" und fügt die Elemente der Tabelle "Shippers" in das aktive Dokument ein.

Set Db = OpenDatabase _
    (Name:="C:\Microsoft Office\Office\" _
    & "Samples\fpnwind.mdb")
Set Rs = Db.OpenRecordset(Name:="Shippers")
For I = 0 To Rs.RecordCount - 1
    Selection.InsertAfter Text:=Rs.Fields(1).Value
    Rs.MoveNext
    Selection.Collapse Direction:=wdCollapseEnd
    Selection.InsertParagraphAfter
Next I
Rs.Close
Db.Close

Mit der OpenDatabase-Methode können Sie eine Verbindung mit einer Datenbank herstellen und die Datenbank öffnen. Nachdem Sie die Datenbank geöffnet haben, können Sie mit der OpenRecordset-Methode auf eine Tabelle zugreifen oder Ergebnisse abfragen. Mit der Move-Methode können Sie durch den Datensatz navigieren. Mit der Seek-Methode können Sie einen bestimmten Datensatz suchen. Wenn Sie keinen gesamten Datensatz, sondern nur eine Untermenge mit Datensätzen benötigen, verwenden Sie die CreateQueryDef-Methode, um eine benutzerdefinierte Abfrage für das Markieren von Datensätzen zu entwerfen, die Ihren Kriterien entsprechen. Schließen Sie Ihre Datenbank mit der Close-Methode, um Speicher zu sparen.

Anmerkung Weitere Informationen über ein bestimmtes DAO-Objekt, eine Methode oder eine Eigenschaft finden Sie unter Hilfe für Data Access-Objekte.


Kommunizieren mit anderen Anwendungen

Neben dem Arbeiten mit Word-Daten soll Ihre Anwendung vielleicht auch Daten mit anderen Anwendungen wie Microsoft Excel, PowerPoint oder Access austauschen. Sie können mit anderen Anwendungen kommunizieren, indem Sie Automation (früher OLE-Automation) oder Dynamischen Datenaustausch (DDE, Dynamic Data Exchange) verwenden.

Tipp Ausführliche Informationen über die Verwendung der Automation zum Steuern von Anwendungen aus Word heraus finden Sie unter Erwerben des Microsoft Office 2000/Visual Basic Programmierhandbuches.

Automatisieren von Word aus einer anderen Anwendung heraus

Mit Automation können Sie Daten zurückgeben, bearbeiten und exportieren, indem Sie Objekte, Eigenschaften und Methoden einer anderen Anwendung ansprechen. Anwendungsobjekte, die von einer anderen Anwendung angesprochen werden können, werden Automationsobjekte genannt.

Um Word einer anderen Automation-Anwendung verfügbar zu machen, besteht der erste Schritt darin, einen Verweis auf das Application-Objekt von Word herzustellen. In Visual Basic verwenden Sie die Funktion CreateObject oder GetObject zur Rückgabe eines Verweises auf das Application-Objekt von Word. In einer Microsoft Excel-Prozedur könnten Sie z. B. die folgende Anweisung verwenden.

Set wrd = CreateObject("Word.Application")

Mit dieser Anweisung wird das Application-Objekt in Word für Automation verfügbar gemacht. Wenn Sie die Objekte, Eigenschaften und Methoden des Application-Objekts von Word verwenden, können Sie Word steuern. Mit der folgenden Anweisung wird beispielsweise ein neues Word-Dokument erstellt.

wrd.Documents.Add

Die Funktion CreateObject startet eine Word-Sitzung, die von der Automation nicht geschlossen wird, wenn die das Application-Objekt ansprechende Objektvariable ungültig wird. Wenn der Objektverweis auf das Schlüsselwort Nothing eingestellt wird, wird Word nicht geschlossen. Verwenden Sie stattdessen die Quit-Methode zum Schließen der Word-Anwendung. Im folgenden Beispiel für Microsoft Excel wird der Word-Startpfad angezeigt. Die Quit-Methode wird zum Schließen der neuen Instanz von Word verwendet, nachdem der Startpfad angezeigt wurde.

Set wrd = CreateObject("Word.Application")
MsgBox wrd.Options.DefaultFilePath(wdStartupPath)
wrd.Quit

Automatisieren einer anderen Anwendung aus Word heraus

Wenn Sie Automation von Word aus für den Austausch von Daten mit einer anderen Anwendung einsetzen möchten, erhalten Sie mit der Funktion CreateObject oder GetObject zuerst einen Verweis auf die Anwendung. Verwenden Sie dann die Objekte, Eigenschaften und Methoden der anderen Anwendung zum Hinzufügen, Ändern oder Löschen von Daten. Wenn Sie mit Ihren Änderungen fertig sind, schließen Sie die Anwendung. Im folgenden Word-Beispiel wird der Microsoft Excel-Startpfad angezeigt. Sie können die Anweisung Set mit dem Schlüsselwort Nothing zum Löschen einer Objektvariablen verwenden. Dies hat dieselbe Wirkung wie das Schließen der Anwendung.

Set myobject = CreateObject("Excel.Application")
MsgBox myobject.StartupPath
Set myobject = Nothing

Informationen über das Verweisen auf eine Objektbibliothek und die Verwendung der darin enthaltenen Objekte finden Sie unter den Themen Automation verstehen und Eine Referenz zu einer Typ-Bibliothek herstellen.

Arbeiten mit Dynamischem Datenaustausch (DDE)

Wenn eine Anwendung Automation nicht unterstützt, könnte DDE eine Alternative sein. DDE ist ein Protokoll, mit dessen Hilfe zwei Anwendungen miteinander kommunizieren können, indem sie kontinuierlich und automatisch Daten über einen DDE-"Kanal" austauschen. Zur Steuerung einer DDE-Konversation zwischen zwei Anwendungen richten Sie einen Kanal ein, wählen ein Thema aus, fordern Daten an bzw. senden Daten und schließen dann den Kanal. In der folgenden Tabelle sind die Aufgaben aufgeführt, die Word mit DDE durchführt, und die Methoden, durch die die einzelnen Aufgaben in Visual Basic gesteuert werden.

Aufgabe | Methode
Starten von DDE | DDEInitiate
Empfangen von Text aus einer anderen Anwendung | DDERequest
Senden von Text an eine andere Anwendung | DDEPoke
Ausführen eines Befehls in einer anderen Anwendung | DDEExecute
Schließen des DDE-Kanals | DDETerminate
Schließen aller DDE-Kanäle | DDETerminateAll


Programmtechnische OLE-Bezeichner

Sie können einen programmtechnischen OLE-Bezeichner (manchmal auch als ProgID bezeichnet) verwenden, um ein Automatisierungsobjekt zu erstellen. In den folgenden Tabellen sind die programmtechnischen OLE-Bezeichner für die ActiveX-Steuerelemente, Microsoft Office-Anwendungen und Microsoft Office-Webkomponenten aufgeführt.

ActiveX-Steuerelemente

Microsoft Access

Microsoft Excel

Microsoft Graph

Microsoft Office-Webkomponenten

Microsoft Outlook

Microsoft PowerPoint

Microsoft Word

ActiveX-Steuerelemente

Wenn Sie die in der folgenden Tabelle aufgeführten ActiveX-Steuerelemente erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner.

Steuerelement | Bezeichner
CheckBox | Forms.CheckBox.1
ComboBox | Forms.ComboBox.1
CommandButton | Forms.CommandButton.1
Frame | Forms.Frame.1
Image | Forms.Image.1
Label | Forms.Label.1
ListBox | Forms.ListBox.1
MultiPage | Forms.MultiPage.1
OptionButton | Forms.OptionButton.1
ScrollBar | Forms.ScrollBar.1
SpinButton | Forms.SpinButton.1
TabStrip | Forms.TabStrip.1
TextBox | Forms.TextBox.1
ToggleButton | Forms.ToggleButton.1

Microsoft Access

Um die in der folgenden Tabelle aufgeführten Objekte von Microsoft Access zu erstellen, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Access-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Access.Application, Access.Application.9
CurrentData | Access.CodeData, Access.CurrentData
CurrentProject | Access.CodeProject, Access.CurrentProject
DefaultWebOptions | Access.DefaultWebOptions

Microsoft Excel

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Excel erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Excel-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner | Anmerkungen
Application | Excel.Application, Excel.Application.9 |
Workbook | Excel.AddIn |
Workbook | Excel.Chart, Excel.Chart.8 | Gibt eine Arbeitsmappe mit zwei Tabellenblättern zurück; eines für das Diagramm und eines für die enthaltenen Daten. Das Tabellenblatt mit dem Diagramm ist das aktive Tabellenblatt.
Workbook | Excel.Sheet, Excel.Sheet.8 | Gibt eine Arbeitsmappe mit einem Tabellenblatt zurück.

Microsoft Graph

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Graph erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt in der neuesten Graph-Version, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | MSGraph.Application, MSGraph.Application.8
Chart | MSGraph.Chart, MSGraph.Chart.8

Microsoft Office-Webkomponenten

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Office-Webkomponenten erstellen möchten, verwenden Sie einen der entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version der Microsoft Office-Webkomponenten, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
ChartSpace | OWC.Chart, OWC.Chart.9
DataSourceControl | OWC.DataSourceControl, OWC.DataSourceControl.9
ExpandControl | OWC.ExpandControl, OWC.ExpandControl.9
PivotTable | OWC.PivotTable, OWC.PivotTable.9
RecordNavigationControl | OWC.RecordNavigationControl, OWC.RecordNavigationControl.9
Spreadsheet | OWC.Spreadsheet, OWC.Spreadsheet.9

Microsoft Outlook

Wenn Sie eines der in der folgenden Tabelle aufgeführte Objekt von Microsoft Outlook erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version von Microsoft Outlook, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Outlook.Application, Outlook.Application.9

Microsoft PowerPoint

Wenn Sie eines der in der folgenden Tabelle aufgeführte Objekt von Microsoft PowerPoint erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt der neuesten Version von Microsoft PowerPoint, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | PowerPoint.Application, PowerPoint.Application.9

Microsoft Word

Wenn Sie eines der in der folgenden Tabelle aufgeführten Objekte von Microsoft Word erstellen möchten, verwenden Sie den entsprechenden programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummersuffix verwenden, erstellen Sie ein Objekt in der neuesten Version von Microsoft Word, die auf dem Rechner verfügbar ist, auf dem das Makro ausgeführt wird.

Objekt | Bezeichner
Application | Word.Application, Word.Application.9
Document | Word.Document, Word.Document.9, Word.Template.8
Global | Word.Global


Konvertieren von WordBasic-Makros nach Visual Basic

Word 2000 konvertiert die Makros in einer Vorlage von Word 6.x oder Word 95 automatisch, wenn Sie zum ersten Mal einen der folgenden Vorgänge ausführen:

  • die Vorlage öffnen

  • ein neues Dokument nach der Vorlage erstellen

  • die Vorlage mit einem Dokument verbinden, indem Sie den Befehl Vorlagen (Menü Extras) verwenden.

Während der Konvertierung der Makros wird in der Statusleiste eine Meldung angezeigt. Nachdem die Konvertierung abgeschlossen ist, müssen Sie die Vorlage speichern, um die konvertierten Makros beizubehalten. Sollten Sie die Vorlage nicht speichern, wird Word die Makros erneut konvertieren, wenn Sie die Vorlage beim nächsten Mal aufrufen.

Anmerkung Word 2000 kann Word 2.x-Makros nicht direkt konvertieren. Sie müssen stattdessen Ihre Word 2.x-Vorlagen in Word 6.x oder Word 95 öffnen, speichern und anschließend in Word 2000 öffnen.

Im Konvertierungsvorgang wird jedes Makro zu einem Visual Basic-Modul konvertiert. Zur Ansicht der konvertierten Makros zeigen Sie im Menü Extras auf Makro und klicken auf Makros. Die Makro-Namen im Dialogfeld Makros werden als Makroname.Main angezeigt, wobei Main sich hier auf die Unterroutine Main im konvertierten Makro bezieht (die Unterroutine, die in früheren Versionen von Word mit Sub MAIN beginnt). Um das konvertierte Makro zu bearbeiten, markieren Sie den Namen eines Makros und klicken auf Bearbeiten, um das Visual Basic-Modul im Visual Basic-Editor anzuzeigen.

Jede WordBasic-Anweisung wird für die Ausführung in Visual Basic für Applikationen angepasst. Die konvertierten WordBasic-Makros entsprechen in ihrer Funktion den neuen Makros von Visual Basic für Applikationen, die Sie möglicherweise schreiben oder aufzeichnen, sie sind jedoch nicht identisch. Das folgende Beispiel zeigt ein WordBasic-Makro in einer Word 95-Vorlage.

Sub MAIN
FormatFont .Name = "Arial", .Points = 10
Insert "Hello World"
End Sub

Wenn die Vorlage in Word 2000 geöffnet wird, wird das Makro zu folgendem Code konvertiert.

Public Sub Main()
WordBasic.FormatFont Font:="Arial", Points:=10
WordBasic.Insert "Hello World"
End Sub

Jede Anweisung in dem konvertierten Makro beginnt mit der WordBasic-Eigenschaft. WordBasic ist eine Eigenschaft des Word 2000-Objektmodells, das ein Objekt mit allen WordBasic-Anweisungen und -Funktionen zurückgibt. Mit Hilfe dieses Objekts können WordBasic-Makros in Word 2000 ausgeführt werden.

Anmerkung Wenn Sie beim Speichern die ursprüngliche Vorlage mit der Vorlage überschreiben, werden die WordBasic-Makros unwiederbringlich gelöscht, und die konvertierten Makros können in früheren Versionen von Word nicht mehr verwendet werden.

Das folgende Visual Basic-Makro entspricht in seiner Funktion dem vorhergehenden WordBasic-Makro, verwendet aber nicht die WordBasic-Eigenschaft.

Public Sub Main()
With Selection.Font
    .Name = "Arial"
    .Size = 10
End With
Selection.TypeText Text:="Hello World"
End Sub


Unterschiede in den Begriffen zwischen WordBasic und Visual Basic

Der Hauptunterschied zwischen Visual Basic for Applications und WordBasic ist folgender: Während die Sprache WordBasic eine einheitliche Liste von ungefähr 900 Befehlen umfasst, besteht Visual Basic aus einer Hierarchie von Objekten, von denen jedes über einen bestimmten Satz von Methoden und Eigenschaften (ähnlich den Anweisungen und Funktionen in WordBasic) verfügt. Während die meisten der WordBasic-Befehle jederzeit ausgeführt werden können, stellt Visual Basic zu einem bestimmten Zeitpunkt nur die Methoden und Eigenschaften der verfügbaren Objekte bereit.

Objekte sind die fundamentalen Bausteine von Visual Basic; fast alles, was Sie in Visual Basic machen, betrifft die Modifizierung von Objekten. Jedes Element von Word – Dokumente, Absätze, Felder, Textmarken usw. – kann in Visual Basic durch ein Objekt dargestellt werden. Im Gegensatz zu Befehlen in einer unstrukturierten Liste gibt es Objekte, auf die nur von anderen Objekten zugegriffen werden kann. Auf das Font-Objekt kann beispielsweise von verschiedenen Objekten zugegriffen werden, u. a. vom Style-, Selection- und Find-Objekt.

Die Programmieraufgabe, Fettformatierung zuzuweisen, demonstriert die Unterschiede zwischen den zwei Programmiersprachen. Die folgende WordBasic-Anweisung weist der Markierung Fettformatierung zu.

Bold 1

Das folgende Beispiel ist das Visual Basic-Äquivalent zum Auszeichnen der Markierung mit dem Attribut "fett".

Selection.Font.Bold = True

Visual Basic verfügt über keine Anweisung oder Funktion Bold. Stattdessen gibt es eine Eigenschaft namens Bold. (Eine Eigenschaft ist normalerweise ein Attribut eines Objekts, beispielsweise seine Größe, seine Farbe, oder ob es fett ausgezeichnet ist oder nicht.) Bold ist eine Eigenschaft des Font-Objekts. Desgleichen ist Font eine Eigenschaft des Selection-Objekts, die ein Font-Objekt zurückgibt. Wenn Sie die Objekthierarchie beachten, können Sie die Anweisung schreiben, die der Markierung Fettformatierung zuweist.

Die Bold-Eigenschaft ist eine Boolesche Eigenschaft mit Schreib-Lese-Zugriff. Das bedeutet, dass die Bold-Eigenschaft auf True oder False (ein oder aus) gesetzt oder der aktuelle Wert zurückgegeben werden kann. Die folgende WordBasic-Anweisung gibt einen Wert zurück, der anzeigt, ob der Markierung Fettformatierung zugewiesen wurde.

x = Bold()

Das folgende Beispiel ist das Visual Basic-Äquivalent für die Zurückgabe des Fettformatierungsstatus der Markierung.

x = Selection.Font.Bold

Die prinzipielle Arbeitsweise in Visual Basic

Zur Durchführung einer Aufgabe in Visual Basic müssen Sie das entsprechende Objekt bestimmen. Wenn Sie beispielsweise Zeichenformatierung zuweisen wollen, die Sie im Dialogfeld Zeichen gefunden haben, verwenden Sie das Font-Objekt. Dann müssen Sie bestimmen, wie die Anweisung durch die Word-Objekthierarchie vom Application-Objekt zum Font-Objekt "nach unten bohren" soll, durch die Objekte, die das Font-Objekt enthalten, das Sie modifizieren wollen. Nachdem Sie den Pfad zu Ihrem Objekt (z. B. Selection.Font) festgelegt haben, verwenden Sie den Objektkatalog, die Hilfe oder Funktionen wie "Elemente automatisch auflisten" im Visual Basic Editor zum Ermitteln, welche Eigenschaften und Methoden dem Objekt zugewiesen werden können. Weitere Information über das Hinunterbohren zu Objekten mit Hilfe der Eigenschaften und Methoden finden Sie unter Objekte, Eigenschaften und Methoden verstehen.

Eigenschaften und Methoden stehen oft mehreren Objekten in der Word-Objekthierarchie zur Verfügung. Die folgende Anweisung weist beispielsweise dem gesamten Dokument Fettformatierung zu.

ActiveDocument.Content.Bold = True

Auch Objekte selbst sind oft an mehr als einer Stelle in der Objekthierarchie vorhanden. Eine Illustration des Word-Objektmodells finden Sie unter Microsoft Word-Objekte.

Wenn Sie den WordBasic-Befehl für die Aufgabe kennen, die Sie in Word 2000 durchführen wollen, schauen Sie nach unter Visual Basic Entsprechungen für WordBasic-Befehle.

Die Selection- und Range-Objekte

Die meisten WordBasic-Befehle modifizieren die Markierung. Beispielsweise weist der Befehl Fett der Markierung Fettformatierung zu. Der Befehl EinfügenFeld fügt an der Einfügemarke ein Feld ein. Jedes Mal, wenn Sie in Visual Basic mit der Markierung arbeiten wollen, verwenden Sie die Selection-Eigenschaft zum Zurückgeben des Selection-Objekts. Die Markierung kann ein Textblock sein oder nur die Einfügemarke.

Im folgenden Visual Basic-Beispiel werden nach der Markierung Text und ein neuer Absatz eingefügt.

Selection.InsertAfter Text:="Hello World"
Selection.InsertParagraphAfter

Neben dem Arbeiten mit der Markierung können Sie verschiedene Textbereiche in einem Dokument definieren und mit ihnen arbeiten. Ein Range-Objekt bezieht sich auf einen zusammenhängenden Bereich in einem Dokument mit einer Startzeichenposition und einer Endzeichenposition. Auf ähnliche Art, wie Textmarken in einem Dokument verwendet werden, werden Range-Objekte in Visual Basic zum Kennzeichnen von Teilen eines Dokuments verwendet. Aber im Gegensatz zu einer Textmarke ist ein Range-Objekt für den Benutzer unsichtbar, wenn es nicht mit Hilfe der Select-Methode markiert wurde. Sie können z. B. Visual Basic verwenden, um irgendwo im Dokument Fettformatierung zuzuweisen, ohne die Markierung zu ändern. Im folgenden Beispiel wird den ersten 10 Zeichen im aktiven Dokument Fettformatierung zugewiesen.

ActiveDocument.Range(Start:=0, End:=10).Bold = True

Im folgenden Beispiel wird dem ersten Absatz Fettformatierung zugewiesen.

ActiveDocument.Paragraphs(1).Range.Bold = True

In diesen beiden Beispielen wird im aktiven Dokument die Formatierung geändert, ohne die Markierung zu ändern. Weitere Informationen über das Range-Objekt finden Sie unter Arbeiten mit Range-Objekten.


Visual Basic-Entsprechungen zu WordBasic-Befehlen

Um die Visual Basic-Eigenschaft oder -Methode zu finden, die einem WordBasic-Befehl entspricht, klicken Sie auf den ersten Buchstaben des WordBasic-Befehlsnamen. Lassen Sie dann die Liste der WordBasic-Befehle abrollen, bis Sie den entsprechenden Befehl gefunden haben. Die rechte Spalte enthält Beispiele zur Visual Basic-Syntax sowie Verweise zu Themen der Hilfe für Microsoft Word Visual Basic.

Weitere Informationen zur Umwandlung von Makros finden Sie unter Umwandlung von WordBasic-Makros in Visual Basic.

Weitere Informationen zu Unterschieden zwischen WordBasic und Visual Basic finden Sie unter Unterschiede in den Begriffen zwischen WordBasic und Visual Basic.


Visual Basic-Entsprechungen A

A |
Abbrechen | Selection.ColumnSelectMode = False Selection.ExtendMode = False Selection.EscapeKey
AbrufenAddInKennung(Name) | x = Addins(Name).Index
AbrufenAddInName$(Num) | x = Addins(Num).Name
AbrufenAdresse$() | x = Application.GetAddress
AbrufenAutoKorrektur$(Name) | x = AutoCorrect.Entries(Name).Value
AbrufenAutoKorrekturAusnahme$() | x = AutoCorrect.FirstLetterExceptions(Num).Name x = AutoCorrect.TwoInitialCapsExceptions(Num).Name
AbrufenAutoText$() | x = ActiveDocument.AttachedTemplate.AutoTextEntries(Name).Value
AbrufenDokumentEigenschaft(), AbrufenDokumentEigenschaft$() | x = ActiveDocument.CustomDocumentProperties(Name).Value ' oder x = ActiveDocument.BuiltInDocumentProperties(Name).Value
AbrufenDokumentVar$(Name) | x = ActiveDocument.Variables(Name).Value
AbrufenDokumentVarName$(Nummer) | x = ActiveDocument.Variables(Num).Name
AbrufenFeldDaten$() | x = Selection.Fields(1).Data
AbrufenFormularFeldergebnis(), AbrufenFormularFeldergebnis$() | x = ActiveDocument.FormFields(Name).Result
AbrufenMarkierungAnfangPosition() | x = Selection.Start
AbrufenMarkierungEndePosition() | x = Selection.End
AbrufenMergeField$() | x = ActiveDocument.MailMerge.DataSource.DataFields(Name).Value
AbrufenSysteminfo$(21) AbrufenSysteminfo$(22) AbrufenSysteminfo$(23) AbrufenSysteminfo$(24) AbrufenSysteminfo$(25) AbrufenSysteminfo$(26) AbrufenSysteminfo$(27) AbrufenSysteminfo$(28) AbrufenSysteminfo$(29) AbrufenSysteminfo$(30) AbrufenSysteminfo$(31) AbrufenSysteminfo$(32) | x = System.OperatingSystem x = System.ProcessorType ' nicht verfügbar x = System.Version ' nicht verfügbar x = System.FreeDiskSpace ' nicht verfügbar x = System.MathCoprocessorInstalled x = System.Country x = System.LanguageDesignation x = System.VerticalResolution x = System.HorizontalResolution Die Werte 512 bis 526 gelten nur für Macintosh.
AbrufenText$(Position1, Position2) | x = ActiveDocument.Range(Pos1, Pos2).Text
AbrufenTextmarke$(Name) | x = ActiveDocument.Bookmarks(Name).Range.Text
AbrufenVerzeichnis$() | x = WordBasic.[GetDirectory$]()
Abs(Zahl) | Abs(Number)
AbsatzAbstandSchließen | Selection.Paragraphs.CloseUp
AbsatzAbstandVor | Selection.Paragraphs.OpenUp
AbsatzBlock, AbsatzBlock() | Selection.Paragraphs.Alignment = wdAlignParagraphJustify
AbsätzeNichtTrennen, AbsätzeNichtTrennen() | ActiveDocument.Paragraphs(1).KeepWithNext = True x = ActiveDocument.Paragraphs(1).KeepWithNext
Absatzkontrolle, Absatzkontrolle() | ActiveDocument.Paragraphs(1).WidowControl = True x = ActiveDocument.Paragraphs(1).WidowControl
AbsatzLinks, AbsatzLinks() | Selection.Paragraphs.Alignment = wdAlignParagraphLeft
AbsatzOben, AbsatzOben() | Selection.MoveUp Unit:=wdParagraph, Count:=1, Extend:=wdMove
AbsatzRechts, AbsatzRechts() | Selection.Paragraphs.Alignment = wdAlignParagraphRight
AbsatzSeitenwOberhalb, AbsatzSeitenwOberhalb() | ActiveDocument.Paragraphs(1).PageBreakBefore = True x = ActiveDocument.Paragraphs(1).PageBreakBefore
AbsatzUnten, AbsatzUnten() | Selection.MoveDown Unit:=wdParagraph, Count:=1, Extend:=wdMove
AbsatzZeilenNichtTrennen, AbsatzZeilenNichtTrennen() | ActiveDocument.Paragraphs(1).KeepTogether = True x = ActiveDocument.Paragraphs(1).KeepTogether
AbsatzZentriert, AbsatzZentriert() | Selection.Paragraphs.Alignment = wdAlignParagraphCenter x = Selection.Paragraphs.Alignment
AddInHinzufügen | Addins.Add
AddInsLöschen | Addins.Unload
AddInStatus Status = AddInStatus(Name) | Addins(Name).Installed = True State = Addins(Name).Installed State = Addins(Name).Compiled State = Addins(Name).AutoLoad
AdresseHinzufügen | Application.AddAddress
Aktivieren Name | Windows(Name).Activate ' oder Documents(Name).Activate
AktivierenFormularFeld | ActiveDocument.FormFields(Name).Enabled = True
AlleAnzeigen, AlleAnzeigen() | Windows(1).View.ShowAll = True x = ActiveWindow.View.ShowAll
AlleDropDownEinträgeEntfernen | ActiveDocument.FormFields(1).DropDown.ListEntries.Clear
AmAnfangDesDokuments() | If Selection.Type = wdSelectionIP and Selection.Start = 0 Then atStart = True
AmEndeDesDokuments() | If Selection.Type = wdSelectionIP and Selection.End = ActiveDocument.Content.End - 1 Then atEnd = True
AndererAusschnitt | ActiveWindow.ActivePane.Next.Activate
AnmerkungsRefVonMarkierung$() | x = Selection.Comments(1).Reference
AnsichtAnmerkungen | ActiveWindow.View.SplitSpecial = wdPaneComments
AnsichtEndnotenBereich, AnsichtEndnotenBereich() | ActiveWindow.View.SplitSpecial = wdPaneEndnotes x = ActiveWindow.View.SplitSpecial
AnsichtEndnotenFortsetzungsHinweis | ActiveWindow.View.SplitSpecial = wdPaneEndnoteContinuationNotice
AnsichtEndnotenFortsetzungsTrennlinie | ActiveWindow.View.SplitSpecial = wdPaneEndnoteContinuationSeparator
AnsichtEndnotenTrennlinie | ActiveWindow.View.SplitSpecial = wdPaneEndnoteSeparator
AnsichtFeldfunktionen | ActiveWindow.View.ShowFieldCodes = True
AnsichtFormatierungsleiste, AnsichtFormatierungsleiste() | CommandBars("Format").Visible = True x = CommandBars("Format").Visible
AnsichtFußnoten, AnsichtFußnoten() | If ActiveDocument.Footnotes.Count >= 1 Then ActiveWindow.View.SplitSpecial = wdPaneFootnotes ElseIf ActiveDocument.Endnotes.Count >= 1 Then ActiveWindow.View.SplitSpecial = wdPaneEndnotes End If ' Mit der Information-Eigenschaft können Sie bestimmen, ob die Markierung in einem Fußnoten- oder Endnotenausschnitt liegt. x = Selection.Information(wdInFootnoteEndnotePane)
AnsichtFußnotenBereich, AnsichtFußnotenBereich() | ActiveWindow.View.SplitSpecial = wdPaneFootnotes x = ActiveWindow.View.SplitSpecial
AnsichtFußnotenFortsetzungsHinweis | ActiveWindow.View.SplitSpecial = wdPaneFootnoteContinuationNotice
AnsichtFußnotenFortsetzungsTrennlinie | ActiveWindow.View.SplitSpecial = wdPaneFootnoteContinuationSeparator
AnsichtFußnotenTrennlinie | ActiveWindow.View.SplitSpecial = wdPaneFootnoteSeparator
AnsichtFußzeile, AnsichtFußzeile() | ActiveWindow.View.SplitSpecial = wdPaneCurrentPageFooter ' oder With ActiveWindow.View .Type = wdPrintView .SeekView = wdSeekCurrentPageFooter End With ' Mit der StoryType-Eigenschaft geben Sie den aktiven Artikel/Fensterausschnitt zurück. aPane = Selection.StoryType
AnsichtGliederung, AnsichtGliederung() | Windows(1).View.Type =wdOutlineView x = Windows(1).View.Type
AnsichtKonzept, AnsichtKonzept() | ActiveWindow.View.Draft = True x = ActiveWindow.View.Draft
AnsichtKopfFußzeileSchließen | ActiveWindow.View.SeekView = wdSeekMainDocument
AnsichtKopfzeile, AnsichtKopfzeile() | ActiveWindow.View.SplitSpecial = wdPaneCurrentPageHeader ' oder With ActiveWindow.View .Type = wdPrintView .SeekView = wdSeekCurrentPageHeader End With ' Mit der StoryType-Eigenschaft geben Sie den aktiven Artikel/Fensterausschnitt zurück. aPane = Selection.StoryType
AnsichtLayout, AnsichtLayout() | Windows(Name).View.Type =wdPrintView x = Windows(Name).View.Type
AnsichtLineal, AnsichtLineal() | ActiveWindow.DisplayRulers = True x = ActiveWindow.DisplayRulers
AnsichtMenüs() | Wird in Word 2000 nicht verwendet
AnsichtNormal, AnsichtNormal() | ActiveWindow.View.Type =wdNormalView x = ActiveWindow.View.Type
AnsichtNormalKopfzeileBereich Art, ErsteSeite, GeradeUngeradeSeiten, AbstandKopfzeile, AbstandFußzeile | With ActiveDocument.PageSetup .DifferentFirstPageHeaderFooter = True .OddAndEvenPagesHeaderFooter = True .HeaderDistance = Num .FooterDistance = Num End With ActiveWindow.View.SeekView = WdSeekView
AnsichtRahmenSymbolleiste | CommandBars("Rahmen").Visible = True
AnsichtStatusleiste, AnsichtStatusleiste() | Application.DisplayStatusBar = True x = Application.DisplayStatusBar
AnsichtSymbolleisten VergrößerteSchaltflächen, QuickInfo, QuickInfoMitShortcut, Vorgabe, Löschen, Anzeigen | With CommandBars .LargeButtons = True .DisplayToolTips = True .DisplayKeysInToolTips = True End With CommandBars(Name).Reset CommandBars(Name).Delete CommandBars(Name).Visible = True
AnsichtZeichnungsSymbolleiste | CommandBars("Zeichnen").Visible = True
AnsichtZentraldokument, AnsichtZentraldokument() | ActiveWindow.View.Type = wdMasterView aView = ActiveWindow.View.Type
AnsichtZentraldokumentUmschalten | If ActiveWindow.View.Type = wdOutlineView Then ActiveWindow.View.Type = wdMasterView ElseIf ActiveWindow.View.Type = wdMasterView Then ActiveWindow.View.Type = wdOutlineView End If
AnsichtZoom OptimaleBreite AnsichtZoom ZweiSeiten AnsichtZoom GanzeSeite AnsichtZoom AnzSpalten, AnzTabZeilen AnsichtZoom ZoomProzent | Windows(Name).View.Zoom.PageFit = wdPageFitBestFit With ActiveWindow.View.Zoom .PageColumns = 2 .PageRows = 1 End With ActiveWindow.View.Zoom.PageFit = wdPageFitFullPage With ActiveWindow.View.Zoom .PageColumns = Num .PageRows = Num End With ActiveWindow.View.Zoom.Percentage = Num
AnsichtZoom100 | Windows(1).View.Zoom.Percentage = 100
AnsichtZoom200 | ActiveWindow.View.Zoom.Percentage = 200
AnsichtZoom75 | ActiveWindow.View.Zoom.Percentage = 75
ÂnsichtZoomGanzeSeite | ActiveWindow.View.Zoom.PageFit = wdPageFitFullPage
AnsichtZoomSeitenbreite | Windows(Name).View.Zoom.PageFit = wdPageFitBestFit
AnwAktiv(Name) | Tasks(Name).Exists
AnwAktivieren Name | Tasks(Name).Activate
AnwAnzeigen Name AnwAnzeigen | Tasks(Name).Visible = True Application.Visible = True
AnwFensterBreite Name, Breite AnwFensterBreite Breite | Tasks(Name).Width = Width Application.Width = Width
AnwFensterHöhe Name, Höhe AnwFensterHöhe Höhe | Tasks(Name).Height = Höhe Application.Height = Höhe
AnwFensterLinks Name, Horizontale Position AnwFensterLinks Horizontale Position | Tasks(Name).Left = Horizpos Application.Left = Horizpos
AnwFensterOben Name, Vertikale Position AnwFensterOben Vertikale Position | Tasks(Name).Top = Vertpos Application.Top = Vertpos
AnwGrößeÄndern Name, Breite, Höhe AnwGrößeÄndern Breite, Höhe | Tasks(Name).Resize Width:=Width, Height:=Height Application.Resize Width:=Width, Height:=Height
AnwInfo$(1) AnwInfo$(2) AnwInfo$(3) AnwInfo$(4) AnwInfo$(5) AnwInfo$(6) AnwInfo$(7) AnwInfo$(8) AnwInfo$(9) AnwInfo$(10) AnwInfo$(13) AnwInfo$(14) AnwInfo$(15) AnwInfo$(16) AnwInfo$(17) AnwInfo$(18) AnwInfo$(19) AnwInfo$(20) AnwInfo$(21) AnwInfo$(22) AnwInfo$(23) AnwInfo$(24) AnwInfo$(25) AnwInfo$(26) AnwInfo$(27) | MsgBox System.OperatingSystem & Chr(32) & System.Version x = Application.Version x = Application.SpecialMode x = Application.Left x = Application.Top x = Application.UsableWidth x = Application.UsableHeight x = Application.WindowState(wdWindowStateMaximize) x = WordBasic.[AppInfo$](9) x = WordBasic.[AppInfo$](10) x = System.MathCoprocessorInstalled x = Application.MouseAvailable x = System.FreeDiskSpace x = Application.International(wdProductLanguageID) x = Application.International(wdListSeparator) x = Application.International(wdDecimalSeparator) x = Application.International(wdThousandsSeparator) x = Application.International(CurrencyCode) x = Application.International(wd24HourClock) x = Application.International(wdInternationalAM) x = Application.International(wdInternationalPM) x = Application.International(wdTimeSeparator) x = Application.International(wdDateSeparator) x = WordBasic.[AppInfo$](26) x = Application.LanguageSettings.LanguageID(msoLanguageIDUI)
AnwMaximieren Name AnwMaximieren | Tasks(Name).WindowState = wdWindowStateMaximize Application.WindowState = wdWindowStateMaximize
AnwMinimieren Name AnwMinimieren | Tasks(Name).WindowState = wdWindowStateMinimize Application.WindowState = wdWindowStateMinimize
AnwNachrichtSenden | Tasks(Name).SendWindowMessage
AnwNamenHolen, AnwNamenHolen() | ' Task-Auflistung durchgehen i = 1 For Each aTask In Tasks aArray(i) = aTask.Name i = i + 1 Next aTask
AnwSchließen Name | Tasks(Name).Close
AnwVerbergen Name | Tasks(Name).Visible = False
AnwVerschieben Name, Horizontale Position, Vertikale Position AnwVerschieben Horizontale Position, Vertikale Position | Tasks(Name).Move Left:=Horizpos, Top:=Vertpos Application.Move Left:=Horizpos, Top:=Vertpos
AnwWiederherstellen Name AnwWiederherstellen | Tasks(Name).WindowState = wdWindowStateNormal Application.WindowState = wdWindowStateNormal
AnwZählen() | Tasks.Count
AnzeigeAktualisieren, AnzeigeAktualisieren() | Application.ScreenUpdating = True
AnzeigeAktualisierung | Application.ScreenRefresh
AOCEAbsenderHolen$() | send = ActiveDocument.Mailer.Sender
AOCEBenutzerBestätigen() | x = WordBasic.AOCEAuthenticateUser
AOCEBetreffBestimmen | ActiveDocument.Mailer.Subject = Text
AOCEBetreffHolen$() | sub = ActiveDocument.Mailer.Subject
AOCEEmpfängerHinzufügen | ActiveDocument.Mailer.Recipients = Array(Name) ActiveDocument.Mailer.CCRecipients = Array(Name) ActiveDocument.Mailer.BCCRecipients = Array(Name)
AOCEEmpfängerHolen$() | rec = ActiveDocument.Mailer.Recipients ccRec = ActiveDocument.Mailer.CCRecipients bccRec = ActiveDocument.Mailer.BCCRecipients
AOCEEmpfängerZählen() | x = Ubound(ActiveDocument.Mailer.Recipients) x = Ubound(ActiveDocument.Mailer.CCRecipients) x = Ubound(ActiveDocument.Mailer.BCCRecipients)
AOCEFeldImAdressfeldLöschen | ActiveDocument.Mailer.Recipients = ""
AOCENachrichtSenden | ActiveDocument.SendMailer
Asc(Zeichenfolge) | Asc(String)
AttributAbrufen(Dateiname) | GetAttr(Filename)
AttributBestimmen Dateiname, Attribut | SetAttr Dateiname, Attribut
AufzählungNumerierungEntfernen | Selection.Range.ListFormat.RemoveNumbers
AusführenDruckManager | Nicht verfügbar
AusschnittSchließen | ActiveWindow.ActivePane.Close
AuswInfo(Typ) | x = Selection.Information(WdInformation)
AutoFestlegenIndexEintrag | ActiveDocument.Indexes.AutoMarkEntries
AutoMakroUnterdrücken | WordBasic.DisableAutoMacros
AutomatischÄndern | Application.AutomaticChange
AutoText | Selection.Range.InsertAutoText
AutoTextBestimmen | Templates(Name).AutoTextEntries.Add
AutoTextName$(Nummer, Kontext) | x = ActiveDocument.AttachedTemplate.AutoTextEntries(Num).Name


Visual Basic-Entsprechungen B

B |
BearbeitenAbonnieren | Selection.Range.SubscribeTo
BearbeitenAbonnierenOptionen | ActiveDocument.EditionOptions
BearbeitenAllesMarkieren | ActiveDocument.Content.Select ' oder Selection.WholeStory
BearbeitenAusschneiden | Selection.Range.Cut
BearbeitenAutoText .Name= Name, .Hinzufügen BearbeitenAutoText .Name= Name, .EinfügenAls = 0, .Einfügen BearbeitenAutoText .Name= Name, .Löschen | ActiveDocument.AttachedTemplate.AutoTextEntries.Add ActiveDocument.AttachedTemplate.AutoTextEntries(Name).Insert Where:=Range, RichText:=True Templates(Name).AutoTextEntries(Name).Delete
BearbeitenEinfügen | Selection.Range.Paste
BearbeitenErsetzenAbsatz | Selection.Find.Replacement.ParagraphFormat
BearbeitenErsetzenFV | Selection.Find.Replacement.Style
BearbeitenErsetzenHervorgehoben | Selection.Find.Replacement.Highlight = True
BearbeitenErsetzenLöschenFormatierung | Selection.Find.Replacement.ClearFormatting
BearbeitenErsetzenNichtHervorgehoben | Selection.Find.Replacement.Highlight = False
BearbeitenErsetzenPositionsrahmen | Selection.Find.Replacement.Frame
BearbeitenErsetzenRahmen | Selection.Find.Replacement.Borders
BearbeitenErsetzenSprache | Selection.Find.Replacement.LanguageID
BearbeitenErsetzenTabstops | Selection.Find.Replacement.ParagraphFormat.TabStops
BearbeitenErsetzenZeichen | Selection.Find.Replacement.Font
BearbeitenGeheZu | Selection.Goto
BearbeitenGrafik | Selection.ShapeRange(1).Activate
BearbeitenHerausgebenOptionen | ActiveDocument.EditionOptions
BearbeitenInhalteEinfügen | Selection.Range.PasteSpecial
BearbeitenKopieren | Selection.Range.Copy
BearbeitenKopierenAlsGrafik | Selection.Range.CopyAsPicture
BearbeitenLöschen | Selection.Range.Delete
BearbeitenNeuenVerlegerErstellen | Selection.Range.CreatePublisher
BearbeitenObjekt | Selection.InlineShapes(1).OLEFormat.Edit ' oder Selection.ShapeRange(1).OLEFormat.Edit
BearbeitenRückgängig | ActiveDocument.Undo
BearbeitenSchaltflächenSymbol | WordBasic.EditButtonImage
BearbeitenSuchen | Selection.Find
BearbeitenSuchenAbsatz | Selection.Find.ParagraphFormat
BearbeitenSuchenFV | Selection.Find.Style
BearbeitenSuchenGefunden() | Selection.Find.Found
BearbeitenSuchenHervorgehoben | Selection.Find.Highlight = True
BearbeitenSuchenLöschenFormatierung | Selection.Find.ClearFormatting
BearbeitenSuchenNichtHervorgehoben | Selection.Find.Highlight = False
BearbeitenSuchenPositionsrahmen | Selection.Find.Frame
BearbeitenSuchenRahmen | Selection.Find.Borders
BearbeitenSuchenSprache | Selection.Find.LanguageID
BearbeitenSuchenTabstops | Seleciton.Find.ParagraphFormat.TabStops
BearbeitenSuchenZeichen | Selection.Find.Font
BearbeitenTextmarke .Name = Name, .Hinzufügen BearbeitenTextmarke .Name = Name, .Löschen BearbeitenTextmarke .Name = Name, .GeheZu BearbeitenTextmarke .Name = Name, .SortNach | ActiveDocument.Bookmarks.Add Name:=Name, Range:=Range ActiveDocument.Bookmarks(Name).Delete ActiveDocument.Bookmarks(Name).Select ActiveDocument.Bookmarks.DefaultSorting = wdSortByName
BearbeitenVerknüpfungen ModusAktualisieren, Geschützt, GrafikSpeichernInDok, JetztAktualisieren, QuellDateiÖffnen, VerknüpfungAufheben, Verknüpfung, Anwendung, Element, Dateiname | ActiveDocument.Shapes(1).OLEFormat.Open ' oder ActiveDocument.InlineShapes(1).OLEFormat.Open With ActiveDocument.InlineShapes(1).LinkFormat .AutoUpdate = True .Locked = True .SavePictureWithDocument = True .Update .BreakLink .Application.Name .SourceFullName End With
BearbeitenWiederherstellen | ActiveDocument.Redo
BearbeitenWiederholen | Repeat
Beep | Beep
BefehleAuflisten | Application.ListCommands
BefehlGültig() | Verwenden Sie die IsObjectValid-Eigenschaft, um festzustellen, ob der Verweis auf eine Objektvariable gültig ist. Eine Objektvariable, die "Nichts" zurückgibt, ist ebenfalls ungültig.
Begin Dialog...End Dialog | Erstellen und Anzeigen eines benutzerdefinierten Formulars. Weitere Informationen über das Hinzufügen von Steuerelementen zu einem Formular finden Sie unter Hinzufügen eines Steuerelements zu einem Formular.
BeginnDokument, BeginnDokument() | Selection.HomeKey Unit:=wdStory, Extend:=wdMove
BeginnFenster, BeginnFenster() | Selection.MoveUp Unit:=wdWindow
BeginnSpalte, BeginnSpalte() | Selection.StartOf Unit:=wdColumn, Extend:=wdMove
BeginnTabellenzeile, BeginnTabellenzeile() | Selection.StartOf Unit:=wdRow, Extend:=wdMove
BeginnTextmarkeBestimmen Name BeginnTextmarkeBestimmen Textmarke1, Textmarke2 | Range.Bookmarks(Name).End = Range.Bookmarks(Name).Start ActiveDocument.Bookmarks(Book1).Start = ActiveDocument.Bookmarks(Book2).Start
BeginnZeile, BeginnZeile() | Selection.HomeKey Unit:=wdLine, Extend:=wdMove
BestimmenDateiErstelltVonUndTyp | Nur Macintosh
BestimmenDokumentEigenschaft | ActiveDocument.BuiltInDocumentProperties.Add ' oder ActiveDocument.CustomDocumentProperties.Add
BestimmenDokumentEigenschaftVerknüpfung Name, Quelle | ActiveDocument.CustomDocumentProperties(Name).LinkSource = Source
BestimmenFormularFeldergebnis Name, "Text" BestimmenFormularFeldergebnis Name, 1 BestimmenFormularFeldergebnis Name, Zahl BestimmenFormularFeldergebnis Name, , StandardErgebnis | ActiveDocument.FormFields(Name).Result = "Text" ActiveDocument.FormFields(Name).CheckBox.Value = True ActiveDocument.FormFields(Name).DropDown.Value = Num Verwenden Sie die Default-Eigenschaft mit einem CheckBox-, DropDown- oder TextInput-Objekt.
BildAb, BildAb() | Selection.MoveDown Unit:=wdScreen, Count:=1, Extend:=wdMove
BildAuf, BildAuf() | Selection.MoveUp Unit:=wdScreen, Count:=1, Extend:=wdMove


Visual Basic-Entsprechungen C

C |
Call | Call ' oder WordBasic.Call ' oder Application.Run
CancelButton | CommandButton
ChDefaultDir Pfad, wdDefaultFilePath | Options.DefaultFilePath(WdDefaultFilePath) = Path
ChDir Pfad | ChDir Path ' oder Application.ChangeFileOpenDirectory
CheckBox | CheckBox-Steuerelement
Chr$(Zahl) | Chr(Num)
Close | Close
ComboBox | ComboBox control


Visual Basic-Entsprechungen D

D |
Date$() | Date
Datei Nummer | RecentFiles(Num).Open
DateiAblegen | ActiveDocument.Post
DateiAllesSchließen | Documents.Close
DateiAllesSpeichern | Documents.Save
DateiAOCEAdreßfeldEinblenden | Nur Macintosh
DateiAOCEAdreßfeldHinzufügen | ActiveDocument.HasMailer = True
DateiAOCEAdreßfeldLöschen | ActiveDocument.HasMailer = False
DateiAOCEAllenAntwortenNachricht | Nur Macintosh
DateiAOCENachrichtBeantworten | Nur Macintosh
DateiAOCENachrichtSenden | ActiveDocument.SendMailer
DateiAOCENachrichtWeiterleiten | ActiveDocument.ForwardMailer
DateiAOCENächsterBrief | Application.NextLetter
DateiBeenden | Application.Quit
DateiBeenden | Application.Quit
DateiDateiInfo Titel, Betreff, Autor, Stichwörter, Kommentar, Dateiname, Verzeichnis, DokVorlage, ErstellDatum, LetztesSpeicherDatum, ZuletztGespeichertVon, ÜberarbeitungsNummer, ZuletztGedruckt, AnzSeiten, AnzWörter, AnzZeichen, AnzAbsätze, AnzZeilen, DateiGröße | With ActiveDocument .BuiltInDocumentProperties(wdPropertyTitle) .BuiltInDocumentProperties(wdPropertySubject) .BuiltInDocumentProperties(wdPropertyLastAuthor) .BuiltInDocumentProperties(wdPropertyKeywords) .BuiltInDocumentProperties(wdPropertyComments) .Name .Path .BuiltInDocumentProperties(wdPropertyTemplate) .BuiltInDocumentProperties(wdPropertyTimeCreated) .BuiltInDocumentProperties(wdPropertyTimeLastSaved) .BuiltInDocumentProperties(wdPropertyLastAuthor) .BuiltInDocumentProperties(wdPropertyRevision) .BuiltInDocumentProperties(wdPropertyVBATotalEdit) .BuiltInDocumentProperties(wdPropertyTimeLastPrinted) .BuiltInDocumentProperties(wdPropertyPages) .BuiltInDocumentProperties(wdPropertyWords) .BuiltInDocumentProperties(wdPropertyCharacters) .BuiltInDocumentProperties(wdPropertyParas) .BuiltInDocumentProperties(wdPropertyLines) .BuiltInDocumentProperties(wdPropertyBytes) End With
DateiDrucken | ActiveDocument.PrintOut
DateiDruckenEineKopie | Nur Macintosh
DateiDruckenStandard | ActiveDocument.PrintOut
DateiDruckereinrichtung | ActivePrinter
DateiEigenschaften | WordBasic.FileProperties
DateiErstelltVon$() | Nur Macintosh
DateiGrafikSchließen | ActiveDocument.Close
DateiKopieren | FileCopy
DateiListe Nummer | RecentFiles(Num).Open
DateiMacBenutzerSeiteEinrichtenGX | Nur Macintosh
DateiMacSeiteEinrichten | Nur Macintosh
DateiMacSeiteEinrichtenGX | Nur Macintosh
DateiManager | Application.FileSearch
DateiName$() DateiName$(Nummer) | x = ActiveDocument.FullName x = RecentFiles(Num).Name & Application.PathSeparator & RecentFiles(Num).Path
DateiNameAusFenster$() | x = Windows(1).Document.FullName
DateiNameInfo$() | x = WordBasic.[FileNameInfo$]() x = ActiveDocument.Name x = ActiveDocument.Path x = ActiveDocument.FullName
DateiNeu Dokumentvorlage | Documents.Add Template:=Filename
DateiNeuStandard | Documents.Add
DateiÖffnen | Documents.Open
DateiSchließen | ActiveDocument.Close
DateiSeiteEinrichten Registerkarte, SeitenrandOben, SeitenrandUnten, SeitenrandLinks, SeitenrandRechts, BundSteg, SeitenLänge, SeitenHöhe, HochQuer, ErsteSeite, ÜbrigeSeiten, AusrichtungVertikal, AnwAuf, Standard, GgbrSeiten, AbstandKopfzeile, AbstandFußzeile, AbschnittsBeginn, GeradeUngeradeSeiten, ErsteSeiteAnders, Endnoten, ZeilenNr, AnfangsNr, VomText, Zählintervall, NumerierArt | With ActiveDocument.PageSetup .TopMargin = Num .BottomMargin = Num .LeftMargin = Num .RightMargin = Num .Gutter = Num .PageHeight = Num .PageWidth = Num .Orientation = WdOrientation .FirstPageTray = WdPaperTray .OtherPagesTray = WdPaperTray .VerticalAlignment = WdVerticalAlignment .SetAsTemplateDefault .MirrorMargins = True .HeaderDistance = Num .FooterDistance = Num .SectionStart = WdSectionStart .OddAndEvenPagesHeaderFooter = True .DifferentFirstPageHeaderFooter = True .SuppressEndnotes = True With LineNumbering .Active =True .StartingNumber = Num .DistanceFromText = Num .CountBy = Num .RestartMode = WdNumberingRule End With End With
DateiSeitenansicht, DateiSeitenansicht() | PrintPreview = True x = PrintPreview
DateiSeitenansichtGanzerBildschirm | PrintPreview = True ActiveWindow.View.FullScreen = True
DateiSeitenansichtSeiten, DateiSeitenansichtSeiten() | With ActiveWindow.View.Zoom .PageColumns = 2 .PageRows = 1 End With
DateiSenden | ActiveDocument.SendMail
DateiSpeichern | ActiveDocument.Save
DateiSpeichernUnter | ActiveDocument.SaveAs
DateiTemplaten | ActiveDocument.AttachedTemplate = Template
DateiTyp$() | Nur Macintosh
DateiUmwandlungenBestätigen | Options.ConfirmConversions = True
DateiVerteiler Betreff, Nachricht, Zugleich, ZurückWennBeendet, StatusVerfolgen, Zulassen DateiVerteiler VerteilerHinzufügen DateiVerteiler DokumentWeiterleiten DateiVerteiler EmpfängerHinzufügen DateiVerteiler VorgabeVerteiler DateiVerteiler VerteilerLöschen | With ActiveDocument.RoutingSlip .Subject = Text .Message = Text .Delivery = WdRoutingSlipDelivery .ReturnWhenDone = True .TrackStatus = True .Protect = WdProtectionType End With ActiveDocument.HasRoutingSlip = True ActiveDocument.Route ActiveDocument.RoutingSlip.AddRecipient ActiveDocument.RoutingSlip.Reset ActiveDocument.HasRoutingSlip = False
Daten = DDERequest$(Kanalnummer, Element) | Data = DDERequest(Channel, Item)
DatumSeriell() | DateSerial
DatumWert() | DateValue
DDEExecute Kanalnummer, Befehl | DDEExecute Channel, Command
DDEPoke Kanalnummer, Element, Daten | DDEPoke Channel, Item, Data
DDETerminate Kanalnummer | DDETerminate Channel
DDETerminateAll | DDETerminateAll
Declare | Declare
DefaultDir$() | x = DefaultFilePath(WdDefaultFilePath)
Dialog, Dialog() | Dialogs(WdWordDialog).Show
DialogEditor | ShowVisualBasicEditor = True
Dim | Dim
DlgAktivieren, DlgAktivieren() |
DlgDateeiVorschau |
DlgDateiSeitenansicht, DlgDateiSeitenansicht$() |
DlgFokus, DlgFokus$() |
DlgGrafikSetzen |
DlgKontrollKennung() | Die dynamischen Dialogfunktionen in WordBasic wurden durch benutzerdefinierte Formulare ersetzt. Weitere Informationen hierzu finden Sie in den Themen der Hilfe für Microsoft-Formulare (FM20.HLP>LANGREF).
DlgListenfeldDatenfeld, DlgListenfeldDatenfeld() |
DlgSichtbar, DlgSichtbar() |
DlgText, DlgText$() |
DlgWert, DlgWert() |
DlgWerteLaden, DlgWerteLaden() |
DlgWerteSpeichern |
DokumentBearbeitetBestimmen 1 | ActiveDocument.Saved = False
DokumentEigenschaftLöschen Name | ActiveDocument.CustomDocumentProperties(Name).Delete
DokumentEigenschaftName$() | x = ActiveDocument.CustomDocumentProperties(Num).Name ' oder x = ActiveDocument.BuiltInDocumentProperties(Num).Name
DokumentEigenschaftTyp() | x = ActiveDocument.CustomDocumentProperties(Name).Type
DokumentEigenschaftVorhanden() | ' DocumentProperties-Auflistung durchgehen For Each aProp In ActiveDocument.CustomDocumentProperties If aProp.Name = Name Then itExists = True Next aProp
DokumentFensterBreite | ActiveWindow.Width = Width
DokumentFensterHöhe | ActiveWindow.Height = Height
DokumentFensterPosLinks | ActiveWindow.Left = Horizpos
DokumentFensterPosOben | ActiveWindow.Top = Vertpos
DokumentFensterTeilen, DokumentFensterTeilen() | ActiveWindow.SplitVertical = 50 x = ActiveWindow.SplitVertical
DokumentGröße Breite, Höhe | With ActiveWindow .Height = Width .Width = Height End With
DokumentHatRechtschreibfehler() | x = ActiveDocument.SpellingErrors.Count
DokumentMaximieren, DokumentMaximieren() | ActiveWindow.WindowState = wdWindowStateMaximize
DokumentMinimieren, DokumentMinimieren() | ActiveWindow.WindowState = wdWindowStateMinimize
DokumentSchließen | ActiveWindow.Close
DokumentSchutz() | x = ActiveDocument.ProtectionType
DokumentSperren, DokumentSperren() | ActiveDocument.Subdocuments(1).Locked = True State = ActiveDocument.Subdocuments(1).Locked
DokumentStatistik Dateiname, Verzeichnis, Template, Titel, Erstellt, ZuletztGespeichert, ZuletztLastSavedBy, Überarbeitung, Zeit, PrintDate, Seiten, Wörter, Zeichen, Absätze, Zeilen, DateiGröße | With ActiveDocument var1 = .Name var2 = .Path var3 = .BuiltInDocumentProperties(wdPropertyTemplate) var4 = .BuiltInDocumentProperties(wdPropertyTitle) var5 = .BuiltInDocumentProperties(wdPropertyTimeCreated) var6 = .BuiltInDocumentProperties(wdPropertyTimeLastSaved) var7 = .BuiltInDocumentProperties(wdPropertyLastAuthor) var8 = .BuiltInDocumentProperties(wdPropertyRevision) var9 = .BuiltInDocumentProperties(wdPropertyVBATotalEdit) var10 = .BuiltInDocumentProperties(wdPropertyTimeLastPrinted) var11 = .BuiltInDocumentProperties(wdPropertyPages) var12 = .BuiltInDocumentProperties(wdPropertyWords) var13 = .BuiltInDocumentProperties(wdPropertyCharacters) var14 = .BuiltInDocumentProperties(wdPropertyParas) var15 = .BuiltInDocumentProperties(wdPropertyLines) var16 = .BuiltInDocumentProperties(wdPropertyBytes) End With
DokumentVariableBestimmen Name, Wert | ActiveDocument.Variables.Add Name, Value
DokumentVerschieben Horizontale Position, Vertikale Position | With ActiveWindow .Top = VertPos .Left = HorizPos End With
DokumentWiederherstellen | ActiveWindow.WindowState = wdWindowStateNormal
DoppeltUnterstreichen, DoppeltUnterstreichen() | Selection.Font.UnderLine = wdUnderlineDouble x = Selection.Font.UnderLine
DOSNachWin$() | x = WordBasic.[DOSToWin$](StringToTranslate)
DropDownEintragEntfernen | ActiveDocument.FormFields(1).DropDown.ListEntries(1).Delete
DropDownEintragHinzufügen | ActiveDocument.FormFields(1).DropDown.ListEntries.Add
DropDownFormularFeld | ActiveDocument.FormFields.Add Range:=Range, Type:=wdFieldFormDropDown
DropListBox | ComboBox-Steuerelement
Durchstreichen, Durchstreichen() | Selection.Font.StrikeThrough = True


Visual Basic-Entsprechungen E

E
EinblendenAlleÜberschriften | ActiveWindow.View.ShowAllHeadings
EinblendenAnmerkungVon Name | ActiveDocument.Comments.ShowBy = Name
EinblendenNächsteKopfFußzeile | ActiveWindow.View.NextHeaderFooter
EinblendenVorherigeKopfFußzeile | ActiveWindow.View.PreviousHeaderFooter
Einfügen Selection.InsertAfter Text:=Text

' oder

Selection.TypeText Text:=Text
EinfügenAbbildungsVerzeichnis | ActiveDocument.TablesOfFigures.Add
EinfügenAbsatz Selection.InsertParagraphAfter

' oder

Selection.TypeParagraph
EinfügenAbschnittsWechsel | Selection.Range.InsertBreak Type:=WdBreakType
EinfügenAdresse | Application.GetAddress
EinfügenAnmerkung | ActiveDocument.Comments.Add
EinfügenAutoBeschriftung Lösch, AlleLösch, BeschrKategorie, Position With AutoCaptions(Name)

.AutoInsert = True

.CaptionLabel.Name = Text

.CaptionLabel.Position = WdCaptionPosition

End With

AutoCaptions.CancelAutoInsert
EinfügenAutoText | Selection.Range.InsertAutoText
EinfügenBeschriftung | Selection.InsertCaption
EinfügenBeschriftungHinzu | CaptionLabels.Add
EinfügenBeschriftungNumerierung BeschrKategorie, FormatNumerierung, KapitelNummer, Ebene, TrennZeichen With CaptionLabels(Name)

.ChapterStyleLevel = Num

.Separator = WdSeparatorType

.NumberStyle = WdCaptionNumberStyle

.IncludeChapterNumber = True

End With
EinfügenDatei Name, Bereich, UmwandlungBestätigen, Verknüpfung | Selection.InsertFile
EinfügenDatenbank | Selection.Range.InsertDatabase
EinfügenDatumZeit | Selection.InsertDateTime
EinfügenDiagramm | ActiveDocument.Shapes.AddOLEObject
EinfügenExcelTabelle | ActiveDocument.Shapes.AddOLEObject
EinfügenFeld Feldtyp | ActiveDocument.Fields.Add Range:=Range, Type:=Field_type
EinfügenFeldDaten | ActiveDocument.Fields(1).Data = Text
EinfügenFeldDatum | Selection.Fields.Add Range:=Range, Type:=wdFieldDate
EinfügenFeldSeite | ActiveDocument.Fields.Add Range:=Range, Type:=wdFieldPage
EinfügenFeldzeichen | Selection.Fields.Add Range:=Range, Type:=wdFieldEmpty, PreserveFormatting:=False
EinfügenFeldZeit | ActiveDocument.Fields.Add Range:=Range, Type:=wdFieldTime
EinfügenFormel | ActiveDocument.Shapes.AddOLEObject
EinfügenFormularFeld Eintrag, Verlassen, Name, Aktivierung, TextArt, TextStandard, TextBreite, TextFormat, KontrollGröße, KontrollBreite, KontrollStandard, Art, HilfeGehörtZu, HilfeText, StatGehörtZu, StatusleisteText Set myField = ActiveDocument.FormFields.Add(Range:=Bange, Type:=WdFieldType)

With myField

.EntryMacro = Text

.ExitMacro = Text

.Name = Text

.Enabled = True

.OwnHelp = True

.HelpText = Text

.OwnStatus = True

.StatusText = Text

End With

With myField.TextInput

.Width = Num

.Default = Text

.EditType

End With

With myField.CheckBox

.Size = Num

.AutoSize = True

.Default = True

End With
EinfügenFußnote FußnotenZeichen, FußEndnotenArt ActiveDocument.Footnotes.Add Range:=Range, Text:=Text

ActiveDocument.Endnotes.Add Range:=Range, Text:=Text
EinfügenIndex | ActiveDocument.Indexes.Add
EinfügenInhaltsverzeichnis | ActiveDocument.TablesOfContents.Add
EinfügenKlang | Selection.InlineShapes.AddOLEObject ClassType:="SoundRec"
EinfügenManuellerWechsel | Selection.InsertBreak Type:=WdBreakType
EinfügenMergeField | ActiveDocument.MailMerge.Fields.Add
EinfügenObjekt | ActiveDocument.Shapes.AddOLEObject
EinfügenPosRahmen | Selection.Frames.Add
EinfügenQuerverweis | Selection.InsertCrossReference
EinfügenSammlung | NormalTemplate.AutoTextEntries("Sammlung").Insert Where:=Range
EinfügenSchaltflächenSymbol | CommandBars(Name).Controls(1).PasteFace
EinfügenSeitenwechsel | Selection.InsertBreak Type:=wdPageBreak
EinfügenSeitenzahlen | ActiveDocument.Sections(1).Footers(wdHeaderFooterPrimary).PageNumbers.Add
EinfügenSonderzeichen | Selection.InsertSymbol
EinfügenSpaltenwechsel | Selection.InsertBreak Type:=wdColumnBreak
EinfügenWordArt | ActiveDocument.Shapes.AddOLEObject
EinfügenZeichnung | ActiveDocument.Shapes.AddOLEObject
EingabeUnterdrücken | Application.EnableCancelKey = WdEnableCancelKey
Einzug | ActiveDocument.Paragraphs(1).TabIndent
EmpfängerAdreßSchriftart ' Stellen Sie die Eigenschaften des Font-Objekts ein

With ActiveDocument.Envelope.Address.Font

.Size = Num

.ColorIndex = WdColorIndex

.Bold = True

End With
EndeDokument, EndeDokument() | Selection.EndKey Unit:=wdStory
EndeFenster, EndeFenster() | Selection.MoveDown Unit:=wdWindow
EndeSpalte, EndeSpalte() | Selection.EndOf Unit:=wdColumn, Extend:=wdMove
EndeTabellenzeile, EndeTabellenzeile() | Selection.EndKey Unit:=wdRow, Extend:=wdMove
EndeTextmarkeBestimmen Name

EndeTextmarkeBestimmen Name1, Name2

 Range.Bookmarks(Name).Start = Range.Bookmarks(Name).End

ActiveDocument.Bookmarks(Name1).End = ActiveDocument.Bookmarks(Name2).End
EndeWindows | Tasks.ExitWindows
EndeZeile, EndeZeile() | Selection.EndKey Unit:=wdLine, Extend:=wdMove
EndnotenFußnotenVertauschen Selection.Footnotes.Convert

' oder

Selection.Endnotes.Convert
EndnotenUmwZuFußnoten | ActiveDocument.Endnotes.Convert
EntfernenPosRahmen While Selection.Frames.Count > 0

Selection.Frames(1).Delete

Wend
Eof() | EOF()
Err | Err
Error | Error
ExtrasAbschnittSchützen Zulassen, Abschnitt | ActiveDocument.Sections(num).ProtectedForForms = True
ExtrasAnpassen Registerkarte With Dialogs(WdWordDialog)

.DefaultTab = WdWordDialogTab

.Show

End With
ExtrasAnpassenMenü MenüArt, Position, Kategorie, Name, Menü, AmEndeZufügen, MenüText, Umbenennen, Hinzufügen, Entfernen, VorgabeAlle, BefehlWert, Kontext CustomizationContext = Template oder Document

CommandBars(Name).Controls(Num).Delete

CommandBars(name).Controls.Add Type:=msoControlButton, ID:=Num, Before:=Num

CommandBars(name).Controls(Num).Caption = Text
ExtrasAnpassenMenüleiste Kontext, Position, MenüArt, MenüText, Menü, Hinzufügen, Entfernen, Umbenennen CustomizationContext = Template oder Document

CommandBars(Name).Delete

CommandBars.Add

CommandBars(name).Name = Text
ExtrasAnpassenTastatur TastenSchlüssel, TastenSchlüssel2, Kategorie, Name, Hinzufügen, Entfernen, VorgabeAlles, BefehlWert, Kontext CustomizationContext = Template oder Document

KeyBindings.Add

CustomizationContext = Template oder Document

FindKey(BuildKeyCode(Wdkey, Wdkey)).Disable

CustomizationContext = Template oder Document

KeyBindings.ClearAll
ExtrasAufzählungStandard | Selection.Range.ListFormat.ApplyBulletDefault
ExtrasAutoKorrektur AnfangsbuchstabenGroß, SatzAnfangGroß, Days, Feststelltaste, TextErsetzen

ExtrasAutoKorrektur AnfZeichenTypogr

ExtrasAutoKorrektur Formatierung, Ersetzen, Durch, Hinzufügen

ExtrasAutoKorrektur Formatierung, Ersetzen, Durch, Hinzufügen

ExtrasAutoKorrektur .Ersetzen = Text, .Löschen

 With AutoCorrect

.CorrectInitialCaps = True

.CorrectSentenceCaps = True

.CorrectDays = True

.CorrectCapsLock = True

.ReplaceText = True

End with

Options.AutoFormatAsYouTypeReplaceQuotes = True

AutoCorrectEntries.AddRichText Name:= Text, Range:=Range

AutoCorrectEntries.Add Name:= Text, Value:= Text

AutoCorrectEntries(name).Delete
ExtrasAutoKorrekturAnfangsbuchstabenGroß, ExtrasAutoKorrekturAnfangsbuchstabenGroß() | AutoCorrect.CorrectInitialCaps = True
ExtrasAutoKorrekturAnfZeichenTypogr, ExtrasAutoKorrekturAnfZeichenTypogr() | Options.AutoFormatAsYouTypeReplaceQuotes = True
ExtrasAutoKorrekturAusnahmen Registerkarte = 0, Name, Hinzufügen

ExtrasAutoKorrekturAusnahmen Registerkarte = 1, Name, Hinzufügen

ExtrasAutoKorrekturAusnahmen Registerkarte = 0, AutomatischHinzufügen

ExtrasAutoKorrekturAusnahmen Registerkarte = 1, AutomatischHinzufügen

ExtrasAutoKorrekturAusnahmen Registerkarte = 0, Name, Löschen

ExtrasAutoKorrekturAusnahmen Registerkarte = 1, Name, Löschen

 FirstLetterExceptions.Add Name

TwoInitialCapsExceptions.Add Name

AutoCorrect.FirstLetterAutoAdd = True

AutoCorrect.TwoInitialCapsAutoAdd = True

FirstLetterExceptions(Name).Delete

TwoInitialCapsExceptions(Name).Delete
ExtrasAutokorrekturFeststelltasteAus, ExtrasAutokorrekturFeststelltasteAus() | AutoCorrect.CorrectCapsLock = True
ExtrasAutoKorrekturSatzanfangGroß, ExtrasAutoKorrekturSatzanfangGroß() | AutoCorrect.CorrectSentenceCaps = True
ExtrasAutoKorrekturTextErsetzen, ExtrasAutoKorrekturTextErsetzen() | AutoCorrect.ReplaceText = True
ExtrasBerechnen, ExtrasBerechnen() | Selection.Range.Calculate
ExtrasBriefumschlagErstellen DruckenBriefumschlagEtikett

ExtrasBriefumschlagErstellen HinzufügenZuDokument

 ActiveDocument.Envelope.Insert

ActiveDocument.Envelope.PrintOut
ExtrasDokumentschutzAufheben | ActiveDocument.UnProtect(Password:=Text)
ExtrasDokumentSchützen | ActiveDocument.Protect
ExtrasEtikettenErstellen DruckenBriefumschlagEtikett

ExtrasEtikettenErstellen HinzufügenZuDokument

 Application.MailingLabel.PrintOut

Application.MailingLabel.CreateNewDocument
ExtrasFeldManager | Application.Run MacroName:="ToolsManageFields"
ExtrasGrammatik | ActiveDocument.CheckGrammar
ExtrasGrammatikStatistikDatenfeld ' ReadabilityStatistics-Auflistung durchgehen

i = 1

For Each aStat In ActiveDocument.ReadabilityStatistics

aArray(i) = aStat.Value

i = i + 1

Next aStat
ExtrasGrößeAnpassen | ActiveDocument.FitToPages
ExtrasMakro Name, Ausführen, Bearbeiten, Anzeigen, Löschen, Umbenennen, Beschreibung, NeuerName, BeschriftungBestimmen Application.Run

Application.OrganizerDelete

Application.OrganizerRename

With Dialogs(wdDialogToolsMacro)

.Show = "templateName"

.Name = "macroName"

.Edit = True

.Execute

End With

With Dialogs(wdDialogToolsMacro)

.Show = "templateName"

.Name = "macroName"

.Description = "newDescription"

.SetDesc = True

.Execute

End With
ExtrasMergeRecHinzufügen WordBasic.ToolsAddRecordDefault

' oder wenn die Datenquelle eine Word-Tabelle ist

Selection.Tables(1).Cell(Row:=Selection.Information(wdMaximumNumberOfRows), _

Column:=Selection.Information(wdMaximumNumberOfColumns)).Select

Selection.MoveRight Unit:=wdCell
ExtrasMergeRecLöschen WordBasic.ToolsRemoveRecordDefault

' oder wenn die Datenquelle eine Word-Tabelle ist

Selection.Tables(1).Rows(1).Delete
ExtrasNumerierungAufzählungen Ersetzen, Schriftart, ZeichenNum, Art, FormatGliederung, AutoAktualisierung, FormatNumerierung, TrennZeich, BeginnenMit, Punkt, HängEinzug, Einzug, Entfernen With ListGalleries(wdNumberGallery).ListTemplates(1).ListLevels(1)

.NumberFormat = "%1."

.TrailingCharacter = WdTrailingCharacter

.NumberStyle = WdListNumberStyle

.Alignment = WdListLevelAlignment

.TextPosition = InchesToPoints(Num)

.TabPosition = InchesToPoints(Num)

.ResetOnHigher = True

.StartAt = Num

.Font.Size = Num

End With

Selection.Range.ListFormat.ApplyListTemplate _

ListTemplate:=ListGalleries(wdNumberGallery).ListTemplates(1)
ExtrasNumerierungStandard | Selection.Range.ListFormat.ApplyNumberDefault
ExtrasOptionen | Dialogs(WdWordDialog).Show
ExtrasOptionenAllgemein Seitenumbruch, WPHelp, WPDocNavKeys, BlauerBildschirm, FehlerSignal, VerknüpfungAktualisieren, NachrichtenAlsAnlage, Maße, SchaltflächeBetätigen, MenünamenInKurzform, RTFInZwischenablage, UmwandlungBestätigen, TipAssistentAktiv, ZuletztGeöffneteDateien, ZuletztGeöffneteDateienAnzahl With Options

.Pagination = True

.WPHelp = True

.WPDocNavKeys = True

.BlueScreen = True

.EnableSound = True

.UpdateLinksAtOpen = True

.SendMailAttach = True

.MeasurementUnit = WdUnits

.ButtonFieldClicks = Num

.ShortMenuNames = True

.RTFInClipboard = True

.ConfirmConversions = True

End With

Assistant.ActivateWizard

With Application

.DisplayRecentFiles = True

.RecentFiles.Maximum = Num

End With
ExtrasOptionenAnsicht KonzeptSchriftart, TextflußImFenster, GrafikPlatzhalter, Feldfunktionen, Textmarken, FeldSchattierung, HRollen, VRollen, BreiteFVAnzeige, TabStopps, Leerzeichen, Absatz, Bindestriche, Verborgen, AlleAnzeigen, Zeichnungen, VerankerungsPunkte, TextBegrenzung, VLineal, Hervorhebung

ExtrasOptionenAnsicht Statusleiste

 With ActiveWindow.View

.Draft = True

.WrapToWindow = True

.ShowPicturePlaceHolders = True

.ShowFieldCodes = True

.ShowBookmarks = True

.FieldShading = WdFieldShading

.Parent.DisplayHorizontalScrollBar = True

.Parent.DisplayVerticalScrollBar = True

.Parent.StyleAreaWidth = Num

.ShowTabs = True

.ShowSpaces = True

.ShowParagraphs = True

.ShowHyphens = True

.ShowHiddenText = True

.ShowAll = True

.ShowDrawings = True

.ShowObjectAnchors = True

.ShowTextBoundaries = True

.Parent.DisplayVerticalRuler = True

.ShowHighlight = True

End With

Application.DisplayStatusBar = True
ExtrasOptionenAutoFormat FVSchützen, FVÜberschriftenZuweisen, FVAufzählZuweisen, FVAllenAbsätzenZuweisen, AnführungszeichenErsetzen, SymbolErsetzen, AufzählungZuweisen, ReplaceOrdinals, BrücheErsetzen, OptionenAnzeigenFür

ExtrasOptionenAutoFormat RahmenZuweisen, AufzählungZuweisen, FVÜberschriftenZuweisen, NumerierungZuweisen, BrücheErsetzen, ReplaceOrdinals, AnführungszeichenErsetzen, SymbolErsetzen, OptionenAnzeigenFür

Zu den folgenden Argumenten gibt es keine Visual Basic-Entsprechung: AbsatzAusrichten, TabAusrichten, AufzählungszeichenErsetzen, LeereAbsätzeAusrichten.

 With Options

.AutoFormatPreserveStyles = True

.AutoFormatApplyHeadings = True

.AutoFormatApplyLists = True

.AutoFormatApplyOtherParas = True

.AutoFormatReplaceQuotes = True

.AutoFormatReplaceSymbols = True

.AutoFormatApplyBulletedLists = True

.AutoFormatReplaceOrdinals = True

.AutoFormatReplaceFractions = True

End With

With Options

.AutoFormatAsYouTypeApplyBorders = True

.AutoFormatAsYouTypeApplyBulletedLists = True

.AutoFormatAsYouTypeApplyHeadings = True

.AutoFormatAsYouTypeApplyNumberedLists = True

.AutoFormatAsYouTypeReplaceFractions = True

.AutoFormatAsYouTypeReplaceOrdinals = True

.AutoFormatAsYouTypeReplaceQuotes = True

.AutoFormatAsYouTypeReplaceSymbols = True

End With
ExtrasOptionenBearbeiten MarkierungErsetzen, DragUndDrop, AutoWortMarkierung, EINFGFürEinfügen, Überschreiben, MitLeerzeichenAusschneidenEinfügen, GroßbuchstabenAkzentZulassen, GrafikEditor, TabEinzug With Options

.ReplaceSelection = True

.AllowDragAndDrop = True

.AutoWordSelection = True

.INSKeyForPaste = True

.Overtype = True

.SmartCutPaste = True

.AllowAccentedUppercase = True

.PictureEditor = Text

.TabIndentKey = True

End With
ExtrasOptionenBenutzerInfo Name, Initialen, Adresse With Application

.UserName = Text

.UserInitials = Text

.UserAddress = Text

End With
ExtrasOptionenDateiablage | Options.DefaultFilePath (WdDefaultFilePath) = Text
ExtrasOptionenDrucken Konzept, Umgekehrt, FelderAktualisieren, DateiInfo, FeldfunktionenAnzeigen, Anmerkungen, EinblendenTextVerborgen, BriefumschlagZufuhr, VerknüpfungenAktualisieren, Hintergrund, Zeichnungselemente, StandardEinzug, FormularDaten, HoheAuflösung, PSÜberText With Options

.PrintDraft = True

.PrintReverse = True

.UpdateFieldsAtPrint = True

.PrintProperties = True

.PrintFieldCodes = True

.PrintComments = True

.PrintHiddenText = True

.EnvelopeFeederInstalled = True

.UpdateLinksAtPrint = True

.PrintBackground = True

.PrintDrawingObjects = True

.DefaultTray = Text

.DefaultTrayID = WdPaperTray

End With

With ActiveDocument

.PrintFormsData = True

.PrintFractionalWidths = True

.PrintPostScriptOverText = True

End With
ExtrasOptionenGrammatik Optionen, RechtschreibungPrüfen, EinblendenDokStatistik With Options

.CheckGrammarWithSpelling = True

.ShowReadabilityStatistics = True

End With

ActiveDocument.ActiveWritingStyle(Language) = Text
ExtrasOptionenKompatibilität | ActiveDocument.Compatibility Type:=WdCompatibility
ExtrasOptionenRechtschreibung ImmerVorschlagen, NurStandardWbuch, GroßschreibungIgnorieren, WortMitZahlenIgnorieren, VorgabeAlleIgnorieren, Type, BenutzerWBuchn, AutomatischeRechtschreibprüfung, RechtschreibKennzAusblenden, ErneutPrüfen With Options

.SuggestSpellingCorrections = True

.SuggestFromMainDictionaryOnly = True

.IgnoreUppercase = True

.IgnoreMixedDigits = True

.CheckSpellingAsYouType = True

End With

With ActiveDocument

.SpellingChecked = False

.ShowSpellingErrors = True

End With

Application.ResetIgnoreAll

Languages(wdLanguageID).SpellingDictionaryType = wdDictionaryType

CustomDictionaries.Add
ExtrasOptionenSpeichern ErstellenSicherungskopie, Schnellspeicherung, DateiInfoAufforderung, GlobalDotAbfrage, UrsprungGrafikFormat, AutoSpeichern, SpeicherIntervall

ExtrasOptionenSpeichern FormularDaten, Kennwort, KennwortSchreiben, SchreibschutzEmpfehlen, EinbettenSchriftarten

 With Options

.CreateBackup = True

.AllowFastSave = True

.SavePropertiesPrompt = True

.SaveNormalPrompt = True

.BackgroundSave = True

.SaveInterval = Number

End With

With ActiveDocument

.SaveFormsData = True

.Password = Text

.WritePassword = Text

.ReadOnlyRecommended = True

.EmbedTrueTypeFonts = True

End With

ExtrasOptionenÜberarbeitung NeuerTextMarkierung, GelöschterTextMarkierung, ÜberarbeitenZeilenMarkierung, NeuerTextFarbe, GelöschterTextFarbe, ÜberarbeitenZeilenFarbe, Hervorhebungsfarbe With Options

.InsertedTextMark = WdInsertedTextMark

.DeletedTextMark = WdDeletedTextMark

.RevisedLinesMark = WdRevisedLinesMark

.InsertedTextColor = WdColorIndex

.DeletedTextColor = WdColorIndex

.RevisedLinesColor = WdColorIndex

.DefaultHighlightColorIndex = WdColorIndex

End With
ExtrasRechtschreibAuswahl | Selection.Range.CheckSpelling
ExtrasRechtschreibung | ActiveDocument.CheckSpelling
ExtrasRechtschreibungErneutPrüfen | ActiveDocument.SpellingChecked = False
ExtrasSeitenumbruch | ActiveDocument.Repaginate
ExtrasSilbentrennung AutoSilbentrennung, GroßbuchstabenTrennen, SilbentrennZone, MaximaleBindestriche With ActiveDocument

.AutoHyphenation = True

.HyphenateCaps = True

.HyphenationZone = Num

.ConsecutiveHyphensLimit = Num

End With
ExtrasSilbentrennungManuell | ActiveDocument.ManualHyphenation
ExtrasSprache Sprache, Standard Selection.Range.LanguageID = WdLanguageID

ActiveDocument.Styles(wdStyleNormal).LanguageID = WdLanguageID
ExtrasThesaurus | Selection.Range.CheckSynonyms
ExtrasÜberarbeiten Überarbeiten, AnsichtÜberarbeitung, DruckÜberarbeitung, AllesAnnehmen, AlleAblehnen With ActiveDocument

.TrackRevisions = True

.PrintRevisions = True

.ShowRevisions = True

End With

With Selection.Range.Revisions

.AcceptAll

.RejectAll

End With
ExtrasÜberarbeitenArt() | aType = ActiveDocument.Revisions(1).Type
ExtrasÜberarbeitenAutor$() | anAuthor = Selection.Range.Revisions(1).Author
ExtrasÜberarbeitenDatum$() | aDate = ActiveDocument.Revisions(1).Date
ExtrasÜberarbeitenPrüfen EinblendenKorrekturMarkierung, VerbergenKorrekturmarkierung, Textfluß, VorherigesSuchen, Weitersuchen, ÜberarbeitungAnnehmen, ÜberarbeitungAblehnen ActiveDocument.ShowRevisions = True

Selection.NextRevision

Selection.PreviousRevision

Selection.Range.Revisions.AcceptAll

Selection.Range.Revisions.RejectAll
ExtrasÜberarbeitungVerbinden | ActiveDocument.Merge FileName:=Name
ExtrasVersionsVergleich | ActiveDocument.Compare
ExtrasWeitereEinstellungen | Wird bei Windows 95 und Windows NT nicht verwendet.
ExtrasWörterZählen ZählenFußnoten, Seiten, Wörter, Zeichen, Absätze, Zeilen | ActiveDocument.ComputeStatistics Statistic:=WdStatistic, IncludeFootnotesAndEndnotes:=True


Visual Basic-Entsprechungen F

F |
FeldaktionAusführen | Selection.Fields(1).DoClick
FeldAnzeigeUmschalten | Selection.Fields.ToggleShowCodes
FelderAktualisieren | ActiveDocument.Sections(1).Range.Fields.Update ActiveDocument.Fields(Num).Update
FeldFreigabe | Selection.Paragraphs(1).Range.Fields.Locked = False ActiveDocument.Fields(Num).Locked = False
FeldSperren | ' Sie können ein einzelnes Feld oder eine Gruppe von Feldern innerhalb eines Bereichs sperren. Selection.Fields.Locked = True ActiveDocument.Fields(1).Locked =True
FeldTrennzeichen$ | Application.DefaultTableSeparator
Fenster Nummer | Window(Num).Activate
FensterAlleAnordnen | Windows.Arrange ArrangeStyle:=wdTiled
FensterAusschnitt() | Verwenden Sie die Split-Eigenschaft, um zu bestimmen, ob ein Fenster geteilt ist. Verwenden Sie die StoryType-Eigenschaft mit dem Selection-Objekt, um den Ausschnitt oder Artikel der Markierung zu bestimmen.
FensterListe Nummer | Window(Num).Activate
FensterName$() | aCap = ActiveWindow.Caption
FensterNeuesFenster | Windows.Add ' oder ActiveWindow.NewWindow
Fett, Fett() | Selection.Font.Bold = True x = Selection.Font.Bold
FileDocumentLayout | Nur Macintosh
FilePreview | Image-Steuerelement
Files$() | Dir()
FilialDokEinfügen | ActiveDocument.Subdocuments.AddFromFile Range:=Range
FilialDokEntfernen | ActiveDocument.Subdocuments(1).Delete
FilialDokErstellen | ActiveDocument.Subdocuments.AddFromRange
FilialDokÖffnen | ActiveDocument.Subdocuments(Name).Open
FilialDokTeilen | ActiveDocument.Subdocuments(1).Split Range:=Range
FilialDokVerbinden | ActiveDocument.Subdocuments.Merge
For...Next | For...Next
FormatAbsatz EinzugLinks, EinzugRechts, Vor, Nach, ZeilenabstandArt, Zeilenabstand, Ausrichtung, AbsatzSteuerung, MitNächstemAbsatz, ZeilenNichtTrennen, Seitenwechsel, OhneZeilennumerierung, NichtTrennen, Registerkarte, ErstzeilenEinzug | With ActiveDocument.Paragraphs(1) .LeftIndent = Num .RightIndent = Num .SpaceBefore = Num .SpaceAfter = Num .LineSpacingRule = WdLineSpacing .LineSpacing = Num .Alignment = WdParagraphAlignment .WidowControl = True .KeepWithNext = True .KeepTogether = True .PageBreakBefore = True .NoLineNumber = True .Hyphenation = True .FirstLineIndent = Num End With With Dialogs(wdDialogFormatParagraph) .DefaultTab = WdWordDialogTab .Show End With
FormatAbschnitt Abschnittsbeginn, AusrichtungVertikal, Endnoten, ZeilenNr, Anfangsnr, VomText, Zählintervall, NumerierArt | With ActiveDocument.PageSetup .VerticalAlignment = WdVerticalAlignment .SectionStart = WdSectionStart .SuppressEndnotes = True With LineNumbering .Active =True .StartingNumber = Num .DistanceFromText = Num .CountBy = Num .RestartMode = WdNumberingRule End With End With
FormatAbsenderSchriftart | ' Stellen Sie die Eigenschaften des Font-Objekts ein With ActiveDocument.Envelope.ReturnAddress.Font .Size = Num .ColorIndex = WdColorIndex .Bold = True End With
FormatAufzählung Punkt, Farbe, Ausrichtung, Einzug, Abstand, HängeEinzug, ZeichenNum, Schriftart | With ListGalleries(wdBulletGallery).ListTemplates(1).ListLevels(1) .NumberFormat = ChrW(Num) .NumberStyle = wdListNumberStyleBullet .NumberPosition = Num .Alignment = WdListLevelAlignment .TextPosition = Num .TabPosition = Num With .Font .Size = Num .Name = Text .ColorIndex = WdColorIndex End With End With
FormatAufzählungStandard, FormatAufzählungStandard() | Selection.Range.ListFormat.ApplyBulletDefault Selection.Range.ListFormat.RemoveNumbers
FormatAufzählungUndNumerierung Entfernen, HängeEinzug, Voreinstellung | Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=ListGalleries(WdListGalleryType).ListTemplates(Num) Selection.Range.ListFormat.RemoveNumbers
FormatAutoFormat | ActiveDocument.AutoFormat
FormatEinfügen | Selection.PasteFormat
FormatFormatvorlage Name, Löschen, Verbinden, NeuerName, BasiertAuf, NächsteFV, Art, Dateiname, Quelle, ZurTemplate, Definieren, Umbenennen, Zuweisen | With ActiveDocument.Styles(Name) .Delete .NameLocal = Name .BaseStyle = Text .NextParagraphStyle = Style x = .Type End With Application.OrganizerCopy With ActiveDocument .UpdateStyles .CopyStylesFromTemplate End With ActiveDocument.Styles.Add Selection.Style = Name
FormatFormatvorlagenGruppe | ActiveDocument.CopyStylesFromTemplate
FormatFVDefAbsatz | ' Stellen Sie die Eigenschaften des ParagraphFormat -Objekts ein With ActiveDocument.Styles(Name).ParagraphFormat .SpaceAfter = Num .RightIndent = Num End With
FormatFVDefNum | ' Stellen Sie die Eigenschaften des ListLevel -Objekts ein With ActiveDocument.Styles(Name). ListGalleries(WdListGalleryType).ListTemplates(Num).ListLevels(Num) .NumberFormat = "%1)" .TrailingCharacter = wdTrailingTab .NumberStyle = wdListNumberStyleArabic End With
FormatFVDefPosRahmen | ' Stellen Sie die Eigenschaften des Frame -Objekts ein With ActiveDocument.Styles(Name).Frame .Width = Num .VerticalPosition = Num End With
FormatFVDefRahmen | ' Stellen Sie die Eigenschaften des Borders -Objekts ein With ActiveDocument.Styles(Name).Borders .Enable = True .Shadow = True End With
FormatFVDefSprache | ActiveDocument.Styles(Name).LanguageID = WdLanguageID
FormatFVDefTab | ' Stellen Sie die Eigenschaften des TabStops -Objekts ein ActiveDocument.Styles(Name).ParagraphFormat.TabStops(1).Leader = WdTabLeader
FormatFVDefZeichen | ' Stellen Sie die Eigenschaften des Font -Objekts ein With ActiveDocument.Styles(Name).Font .Bold = True .Name = "Arial" End With
FormatGegliederteListe | ' Stellen Sie die Eigenschaften des ListLevel-Objekts ein, und verwenden Sie die ApplyListTemplate-Methode Set atemp = ListGalleries(wdOutlineNumberGallery).ListTemplates(Num) atemp.ListLevels(1).NumberStyle = wdListNumberStyleLowercaseLetter Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=atemp
FormatGrafik GrößeBestimmen, RahmenÄndernLinks, RahmenÄndernRechts, RahmenÄndernOben, RahmenÄndernUnten, SkalierenX, SkalierenY, GrößeX, GrößeY | With ActiveDocument.InlineShapes(1) .Width = Num .Height = Num .ScaleHeight = Num .ScaleWidth = Num With .PictureFormat .CropBottom = Num .CropLeft = Num .CropRight = Num .CropTop = Num End With End With
FormatGroßKleinschreibung | Selection.Range.Case = WdCharacterCase
FormatInitial Position, Schriftart, InitialHöhe, AbstZumText | With ActiveDocument.Paragraphs(1).DropCap .Position = WdDropPosition .FontName = Text .LinesToDrop = Num .DistanceFromText = Num End With
FormatKopfFußzeileVerknüpfen | ActiveDocument.Sections(Num).Headers(WdHeaderFooterIndex).LinkToPrevious = True ' oder ActiveDocument.Sections(Num).Footers(WdHeaderFooterIndex).LinkToPrevious = True
FormatKopieren | Selection.CopyFormat
FormatLegende Art, Abst, Winkel, Ansatz, Länge, RahmenLinie, AutoVerbinden, LeisteHinzufügen | With ActiveDocument.Shapes(1).Callout .Type = MsoCalloutType .Gap = Num .Angle = MsoCalloutAngleType .Drop = Num .DropType = MsoCalloutDropType .Length = Num .Border = MsoTriState .AutoAttach = MsoTriState .Accent = MsoTriState End With
FormatNumerierung | ' Stellen Sie die Eigenschaften des ListLevel-Objekts ein, und verwenden Sie die ApplyListTemplate-Methode Set atemp = ListGalleries(wdNumberGallery).ListTemplates(Num) With atemp.ListLevels(1) .NumberFormat = "%1." .TrailingCharacter = wdTrailingTab .NumberStyle = wdListNumberStyleArabic End With Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=atemp
FormatNummerStandard, FormatNummerStandard() | Selection.Range.ListFormat.ApplyNumberDefault Selection.Range.ListFormat.RemoveNumbers
FormatPosRahmen Textfluss, BreiteMaß, BreiteAuswahl, HöheMaß, HöheAuswahl, PositionHoriz, PositionHorizGemVon, AbstZumText, PositionVert, PositionVertGemVon, AbstVertZumText, MitTextVerschieben, VerankerungsPunktFixieren, PosRahmenEntfernen | With ActiveDocument.Frames(1) .TextWrap = True .WidthRule = WdFrameSizeRule .Width = Num .Height = Num .HeightRule = WdFrameSizeRule .HorizontalPosition = Num .RelativeHorizontalPosition = WdRelativeHorizontalPosition .HorizontalDistanceFromText = Num .VerticalPosition = Num .RelativeVerticalPosition = WdRelativeVerticalPosition .VerticalDistanceFromText = Num .LockAnchor = True .Delete End With
FormatRahmenSchattierung Schattierung, ObenRahmenlinie, LinksRahmenlinie, UntenRahmenlinie, RechtsRahmenlinie, HorizontalRahmenlinie, VertikalRahmenlinie, FarbeOben, FarbeLinks, FarbeUnten, FarbeRechts, FarbeHorizontal, FarbeVertikal, FeineSchattierung, VomText, Schattiert, Vordergrund, Hintergrund, Registerkarte | With ActiveDocument.Paragraphs(1).Borders .Shadow = True .DistanceFromBottom = Num .DistanceFromTop = Num .DistanceFromLeft = Num .DistanceFromRight = Num End With With Selection.Shading .Texture = WdTextureIndex .BackgroundPatternColorIndex = WdColorIndex .ForegroundPatternColorIndex = WdColorIndex End With With ActiveDocument.Paragraphs(1) .Borders(WdBorderType).LineStyle = WdLineStyle .Borders(WdBorderType).LineWidth = WdLineWidth .Borders(WdBorderType).ColorIndex = WdColorIndex End With With Dialogs(wdDialogFormatBordersAndShading) .DefaultTab = WdWordDialogTab .Show End With
FormatSeitenzahl KapitelNummer, NumNeuBeginnen, NumFormat, AnfangsNr, Ebene, TrennZeichen | With Section.Footers(wdHeaderFooterPrimary).PageNumbers .IncludeChapterNumber = True .RestartNumberingAtSection = True .NumberStyle = WdPageNumberStyle .StartingNumber = Num .HeadingLevelForChapter = Num .ChapterPageSeparator = WdSeparatorType End With
FormatSpalten Spalten, SpaltenBreite, SpaltenAbstand, GleicherSpaltenabstand, Zwischenlinie | With ActiveDocument.TextColumns .SetCount NumColumns:=Num .Width = Num .Spacing = Num .EvenlySpaced = False .LineBetween = False End With
FormatTabulator Position, StandardTabs, Ausrichten, Füllzeichen, Bestimmen, Lösch, AlleLösch | With Selection.Paragraphs.TabStops .ClearAll .Add Position:=Num, Alignment:= WdTabAlignment, Leader:= WdTabLeader .Item(1).Clear End With ActiveDocument.DefaultTabStop
FormatÜberschriftenNumerierung | ' Stellen Sie die Eigenschaften des ListLevel-Objekts ein, und verwenden Sie die ApplyListTemplate-Methode Set atemp = ListGalleries(wdOutlineNumberGallery).ListTemplates(Num) With atemp.ListLevels(1) .NumberFormat = "Chapter %1" .TrailingCharacter = wdTrailingNone .NumberStyle = wdListNumberStyleArabic End With Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=atemp
FormatÜberschriftenNummer | With ListGalleries(WdListGalleryType).ListTemplates(Num).ListLevels(Num) ' Stellen Sie die Eigenschaften des ListLevel-Objekts ein, und verwenden Sie die ApplyListTemplate -Methode End With
Formatvorlage | Selection.Style = wdStyleHeading1
FormatZeichen Punkt, Unterstrichen, Farbe, Durchstreichen, Hochgestellt, Tiefgestellt, Schattiert, Verborgen, Kapitälchen, Großbuchstaben, Umriss, Laufweite, Position, Unterschneidung, UnterschneidungMin, Standard, Registerkarte, Schriftart, Fett, Kursiv | With Selection.Font .Size = Num .Underline = True .ColorIndex = WdColorIndex .StrikeThrough = True .Superscript = Num .Subscript = Num .Shadow = True .Hidden = True .SmallCaps = True .AllCaps = True .Outline = True .Spacing = Num .Position = Num .Kerning = Num .SetAsTemplateDefault .Font = Name .Bold = True .Italic = True End With With Dialogs(wdDialogFormatFont) .DefaultTab = WdWordDialogTab .Show End With
FormatZeichnungsElement | Stellen Sie die Eigenschaften des Shape-Objekts ein.
FormularfelderSchattieren | ActiveDocument.FormFields.Shaded = True
FormularFeldLeeren | ActiveDocument.FormFields(1).TextInput.Clear
FormularFeldOptionen Eintrag, Verlassen, Name, Aktivierung, TextArt, TextBreite, TextStandard, TextFormat, KontrollGröße, KontrollBreite, KontrollStandard, Art, HilfeGehörtZu, HilfeText, StatGehörtZu, StatusleisteText | With ActiveDocument.FormFields(1) .EntryMacro = Text .ExitMacro = Text .Name = Text .Enabled = True .OwnHelp = True .HelpText = Text .OwnStatus = True .StatusText = Text .Type = WdFieldType End With With ActiveDocument.FormFields(1).TextInput .Width = Num .Default = Text .EditType End With With ActiveDocument.FormFields(1).CheckBox .Size = Num .AutoSize = True .Default = True End With
FreihandSchreibmodusUmschalten | WordBasic.ToggleScribbleMode
Function...End Function | Function…End Function
FußEndnotenOptionen FußnotenPosition, FußnotenNumerierungAls, FußnotenBeginnenMit, FußnotenNeuBeginnenMit, EndnotenPosition, EndnotenNumerierungAls, EndnotenNumerierungMit, EndnotenNeuBeginnenMit | With ActiveDocument.Footnotes .Location = WdFootnoteLocation .NumberingRule = WdNumberingRule .NumberStyle = WdNoteNumberStyle .StartingNumber = Num End With With ActiveDocument.Endnotes .Location = WdEndnoteLocation .NumberingRule = WdNumberingRule .NumberStyle = WdNoteNumberStyle .StartingNumber = Num End With
FußnotenUmwZuEndnoten | ActiveDocument.Footnotes.Convert
FVBeschreibung$() | x = Selection.Style.Description
FVName$() | x = Selection.Style.NameLocal


Visual Basic-Entsprechungen G

G |
GanzerBildschirmUmschalten | ActiveWindow.View.FullScreen = Not ActiveWindow.View.FullScreen
GefundenDateiName$() | Application.FileSearch.FoundFiles(Num)
GeheZuAnmerkungsbereich | Selection.Comments(1).Scope.Select
GeheZuKopfFußzeile | If Selection.HeaderFooter.IsHeader = True Then ActiveWindow.ActivePane.View.SeekView = wdSeekCurrentPageFooter Else ActiveWindow.ActivePane.View.SeekView = wdSeekCurrentPageHeader End If
GeheZuNächsterAnmerkung GeheZuNächsterEndnote GeheZuNächsterFußnote GeheZuNächsterSeite GeheZuNächstemAbschnitt GeheZuNächstemFilialDok | Selection.GoToNext(wdGoToComment) Selection.GoToNext(wdGoToEndnote) Selection.GoToNext(wdGoToFootnote) Selection.GotoNext(wdGoToPage) Selection.GotoNext(wdGoToSection) Selection.NextSubdocument
GetCurValues | Dialogs(WdWordDialog).Update
GetPrivateProfileString$() | x = System.PrivateProfileString(Filename, Section, Key)
GetProfileString$() | x = System.ProfileString(Section, Key)
GliederungAbsatzNachOben | Selection.Range.Relocate Direction:=wdRelocateUp
GliederungAbsatzNachUnten | Selection.Range.Relocate Direction:=wdRelocateDown
GliederungErsteZeileAnzeigen, GliederungErsteZeileAnzeigen() | ActiveWindow.View.ShowFirstLineOnly = True x = ActiveWindow.View.ShowFirstLineOnly
GliederungErweitern | ActiveWindow.View.ExpandOutline
GliederungFormatAnzeigen | AcitveWindow.View.ShowFormat = True
GliederungHöherstufen | Selection.Paragraphs.OutlinePromote
GliederungReduzieren | ActiveWindow.View.CollapseOutline
GliederungsEbene() | aLevel = Selection.Paragraphs.OutlineLevel
GliederungTieferstufen | Selection.Paragraphs.OutlineDemote
Goto | GoTo
GoToPreviousItem | Selection.GoTo What:=WdGoToItem, Which:=wdGoToPrevious
Großbuchstaben, Großbuchstaben() | Selection.Font.AllCaps = True x = Selection.Font.AllCaps
GrößeSymbolleiste Name, Breite | CommandBars(Name).Width = Num
GroßKleinschreibungÄndern, GroßKleinschreibungÄndern() | Selection.Range.Case = WdCharacterCase x = Selection.Range.Case
GroupBox | Frame-Steuerelement


Visual Basic-Entsprechungen H

H |
HängenderEinzug | ActiveDocument.Paragraphs(1).TabHangingIndent
Hervorheben, Hervorheben() | Selection.Range.HighlightColorIndex = WdColorIndex x = Selection.Range.HighlightColorIndex
HervorhebungsFarbe, HervorhebungsFarbe() | Selection.Range.HighlightColorIndex = WdColorIndex x = Selection.Range.HighlightColorIndex
Heute() | Dim x As Long x = DateSerial(Year(Date), Month(Date), Day(Date))
Hilfe | Assistant.Help
HilfeAktivesFenster | Application.Help HelpType:=wdHelpActiveWindow
HilfeBeispieleUndDemos | Wird in Word 2000 nicht verwendet.
HilfeIndex | Application.Help HelpType:=wdHelpIndex
HilfeInfo | Application.Help HelpType:=wdHelpAbout
HilfeInhalt | Application.Help HelpType:=wdHelpContents
HilfeKurzübersicht | Wird in Word 2000 nicht verwendet.
HilfeMSN | Wird in Word 2000 nicht verwendet.
HilfeSoftwareService | Application.Help HelpType:=wdHelpPSSHelp
HilfeSuchen | Application.Help HelpType:=wdHelpSearch
HilfeSymbol | Application.HelpTool
HilfeTastatur | Wird in Word 2000 nicht verwendet.
HilfeTipsUndTricks | Assistant.FeatureTips = True
HilfeVerwenden | Application.Help HelpType:=wdHelpUsingHelp
HochFormatUmschalten | ActiveDocument.PageSetup.TogglePortrait
Hochgestellt, Hochgestellt() | Selection.Font.Superscript = True x = Selection.Font.Superscript
HöherstufenListe | Selection.Range.ListFormat.ListIndent
HRollen, HRollen() | ActiveWindow.HorizontalPercentScrolled = Num Num = ActiveWindow.VerticalPercentScrolled
HSeite | ActiveWindow.LargeScroll ToRight:=Num ' oder ActiveWindow.LargeScroll ToLeft:=Num
HZeile | ActiveWindow.SmallScroll ToRight:=Num ' oder ActiveWindow.SmallScroll ToLeft:=Num


Visual Basic-Entsprechungen I

I |
If...Then...Else | If...Then...Else
IncludePicture Name, DateiVerknüpfen, Neu | ActiveDocument.Shapes.AddPicture ActiveDocument.InlineShapes.New Range:=Range
IndexEintragFestlegen | ActiveDocument.Indexes.MarkEntry
InfoAnzeigen | Application.ShowMe
InhaltsverzeichnisEintragAuswählen | ActiveDocument.TablesOfContents.MarkEntry
Input | Input
Input$() | Input()
InputBox$() | InputBox
InStr() | InStr()
Int() | Int()
IstAutoKorrekturAusnahme() | For Each xItem In AutoCorrect.FirstLetterExceptions If xItem.Name = "apt." Then isFound = True Next xItem For Each aItem In AutoCorrect.TwoInitialCapsExceptions If aItem.Name = "THem" Then aExists = True Next aItem
IstDokumentEigenschaftBenutzerdefiniert() | For Each aProp In ActiveDocument.CustomDocumentProperties If aProp.Name = "age" Then isFound = True Next aProp
IstDokumentEigenschaftSchreibgeschützt() | x = WordBasic.IsDocumentPropertyReadOnly(Name)
IstDokumentGeändert() | x = Not ActiveDocument.Saved
IstMakro() | Wird in Word 2000 nicht verwendet.
IstNurAusführen() | x = ActiveDocument.VBProject.Protection
IstTemplateGeändert() | x = Not ActiveDocument.AttachedTemplate.Saved


Visual Basic-Entsprechungen J bis L

J |
Jahr | Year()
Jetzt() | Now

K |
Kanal = DDEInitiate (Anwendung, Objekt) | Chan = DDEInitiate(Application, Topic)
Kapitälchen, Kapitälchen() | Selection.Font.SmallCaps = True
Kasten, Kasten() | With Selection.Borders .OutsideLineStyle = wdLineStyleSingle .OutsideLineWidth = wdLineWidth075pt End With x = Selection.Borders.OutsideLineStyle
Kill Dateiname | Kill Filename
KontrollkästchenFormularFeld | ActiveDocument.FormFields.Add Range:=Range, Type:=wdFieldFormCheckBox
Konturschrift, Konturschrift() | Selection.Font.Outline = True x = Selection.Font.Outline
Konverter$(Nummer) | x = FileConverters(Num).ClassName
KonverterSuchen(Name) | x = FileConverters(Name).SaveFormat
KopfFußzeilenVerknüpfungUmschalten | ActiveDocument.Sections(2).Headers(wdHeaderFooterPrimary).LinkToPrevious
Kursiv, Kursiv() | Selection.Font.Italic = True

L |
LCase$() | LCase() ' oder LCase$()
LeereTextmarke(Name) | x = ActiveDocument.Bookmarks(Name).Empty
Left$() | Left$() ' oder Left()
Len() | Len()
Let | Let
LetztesWortLöschen | Selection.Delete Unit:=wdWord, Count:=-1
Line Input | Line Input
ListBox | ListBox-Steuerelement
Lof() | LOF()
LöschenAddIn Name | Addins(Name).Delete
LöschenZeichen$(Zeichenfolge) | x = CleanString(String)
LTrim$() | LTrim()
Lupe, Lupe() | ActiveWindow.View.Magnifier = True State = ActiveWindow.View.Magnifier


Visual Basic-Entsprechungen M

M |
MacID$() | Nur Macintosh
MacScript, MacScript$() | Nur Macintosh
MailAllenAntworten | Application.MailMessage.ReplyAll
MailAntworten | Application.MailMessage.Reply
MailNachrichtEigenschaften | Application.MailMessage.DisplayProperties
MailNachrichtenkopfEinAusblenden | Application.MailMessage.ToggleHeader
MailNachrichtLöschen | Application.MailMessage.Delete
MailNachrichtVerschieben | Application.MailMessage.DisplayMoveDialog
MailNachrichtWeiterleiten | Application.MailMessage.Forward
MailNächsteNachricht | Application.MailMessage.GoToNext
MailNamenAuswählen | Application.MailMessage.DisplaySelectNamesDialog
MailNamenÜberprüfen | Application.MailMessage.CheckName
MailVorherigeNachricht | Application.MailMessage.GoToPrevious
MakroAufzeichnungUnterbrechen | WordBasic.PauseRecorder
MakroBeschr$() | x = WordBasic.[MacroDesc$](Name)
MakroDateiName$() | Wird in Word 2000 nicht verwendet.
MakroKopieren | Application.OrganizerCopy
MakroName$() | x = WordBasic.[MacroName$](Num)
MakroNameAusFenster$() | Wird in Word 2000 nicht verwendet.
MakroSchlüssel$() | x = KeyBindings(1).Command
Markierung$() | Text = Selection.Text
MarkierungAktuellAbstand | Selection.SelectCurrentSpacing
MarkierungAktuellAusrichtung | Selection.SelectCurrentAlignment
MarkierungAktuellEinzug | Selection.SelectCurrentIndent
MarkierungAktuellFarbe | Selection.SelectCurrentColor
MarkierungAktuellSatz | Selection.Sentences(1).Select
MarkierungAktuellSchriftart | Selection.SelectCurrentFont
MarkierungAktuellTab | Selection.SelectCurrentTabs
MarkierungAktuellWort | Selection.Words(1).Select
MarkierungArt() MarkierungArt 1 | aType = Selection.Type(Type) Selection.Collapse Direction:=wdCollapseStart
MarkierungDateiName$() | aFileName = Selection.Document.FullName
MarkierungErweitern | ' aktiviert Erweiterungsmodus Selection.ExtendMode = True ' erweitert die Markierung Selection.Expand Unit:=wdUnits
MarkierungsbereichBestimmen Zeichenposition1, Zeichenposition2 | ActiveDocument.Range(Start:=Charpos1, End:=Charpos2).Select
MarkierungVerkleinern | Selection.Shrink
MenüEintragMakro$() | x = CommandBars(Name).Controls(Num).OnAction
MenüEintragText$() | x = CommandBars(Name).Controls(Num).Caption
MenüModus | WordBasic.MenuMode
MenüText$() | x = CommandBars.ActiveMenuBar.Controls(Num).Caption
MergeFieldName$(Nummer) | x = ActiveDocument.MailMerge.DataSource.FieldNames(Num)
MicrosoftAccess | WordBasic.MicrosoftAccess ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftExcel | WordBasic.MicrosoftExcel ' oder If Tasks.Exists("Microsoft Excel") = True Then Tasks("Microsoft Excel").Activate Tasks("Microsoft Excel").WindowState = wdWindowStateMaximize Else Shell "C:\MSOffice\Excel\Excel.exe" End If
MicrosoftFoxPro | WordBasic.MicrosoftFoxPro ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftMail | WordBasic.Mail ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftPowerPoint | WordBasic.PowerPoint ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftProject | WordBasic.Project ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftPublisher | WordBasic.Publisher ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftSchedule | WordBasic.Schedule ' oder verwenden Sie die im Microsoft Excel-Beispiel gezeigte Vorgehensweise
MicrosoftSystemInfo | System.MSInfo
Mid$() | Mid$() ' oder Mid()
Minute() | Minute()
MkDir Pfad | MkDir Path_name
ModusErweitern() | x= Selection.ExtendMode
Monat() | Month()
MsgBox, MsgBox() | MsgBox, MsgBox()


Visual Basic-Entsprechungen N

N |
N/A | Options.WPHelp = True
N/A | ActiveDocument.TablesOfAuthorities.MarkCitation ActiveDocument.TablesOfAuthorities.MarkAllCitations
N/A | ActiveDocument.TablesOfAuthorities.Add
N/A | Options.SetWPHelpOptions
N/A | ActiveDocument.TablesOfAuthoritiesCategories(Num).Name = Name
NächsterRechtschreibfehler | Selection.GoToNext What:=wdGoToSpellingError
NächsterTab() | x = ActiveDocument.Paragraphs(1).TabStops(1).Next.Position
NächsteSeite, NächsteSeite() | Selection.GoToNext What:=wdGoToPage ' oder ActiveWindow.View.Type = wdPrintView ActiveWindow.PageScroll Down:=1
NächstesFeld, NächstesFeld() | Selection.GoToNext What:=wdGoToField ' oder Selection.NextField
NächstesFenster | ActiveWindow.Next.Activate
NächstesObjekt | Selection.GoToNext What:=wdGoToObject ' oder Selection.MoveRight Unit:=wdItem
NächsteZelle | Selection.Move Unit:=wdCell, Count:=1 ' oder Selection.Cells(1).Next.Select
Name | Name
Name = SymbolleistenName$() | Name = CommandBars(Num).Name
Name = TextmarkeName$(Nummer) | Name = ActiveDocument.Bookmarks(Num).Name
NeuBenennenMenü | CommandBars.ActiveMenuBar.Controls(name).Caption = Newname
NeueSymbolleiste | CommandBars.Add
NumerierungÜberspringen, NumerierungÜberspringen() | Selection.Range.ListFormat.RemoveNumbers
Nummer = Fenster() | Num = ActiveWindow.Index


Visual Basic-Entsprechungen O bis Q

O |
ObjektAktivieren | ActiveDocument.Shapes(1).OLEFormat.Activate ' oder ActiveDocument.InlineShapes(1).OLEFormat.Activate
ObjektUmwandeln SymbolNummer, AktivierenAls, SymbolDateiname, Beschriftung, ObjektTyp, SymbolAnzeigen | With ActiveDocument.Shapes(1).OLEFormat .IconIndex = Num .ActivateAs = Text .IconPath & Application.PathSeparator & .IconName .IconLabel = Text .ClassType = Text .DisplayAsIcon = True End With
OhneRahmenlinien, OhneRahmenlinien() | Selection.Borders.Enable = False ' oder Selection.Borders(wdBorderLeft).LineStyle = wdLineStyleNone x = Selection.Range.Borders.Enable
OK | WordBasic.OK
OKButton | CommandButton control
On Error | On Error
OnTime | Application.OnTime
Open | Open
OptionButton | OptionButton-Steuerelement
OptionGroup | Frame-Steuerelement
Organisieren | Application.OrganizerCopy Application.OrganizerDelete Application.OrganizerRename

P |
PfadVonMacPfad$() | x = WordBasic.[PathFromMacPath$](Path)
PfadVonWinPfad$() | x = WordBasic.[PathFromWinPath$](Path)
Picture | Image-Steuerelement
Print | Print Print
PunktiertUnterstreichen, PunktiertUnterstreichen() | Selection.Font.UnderLine= wdUnderlineDotted x = Selection.Font.UnderLine
PushButton | CommandButton-Steuerelement
Q |
QuelleAktualisieren | ActiveDocument.Paragraphs(1).Range.Fields.UpdateSource ActiveDocument.Fields(Num).UpdateSource


Visual Basic-Entsprechungen R

R |
RahmenlinieInnen, RahmenlinieInnen() | With Selection.Borders .InsideLineStyle = wdLineStyleSingle .InsideLineWidth = wdLineWidth075pt End With x = Selection.Borders.InsideLineStyle
RahmenlinieLinks, RahmenlinieLinks() | With ActiveDocument.Paragraphs(1).Borders(wdBorderLeft) .LineStyle = wdLineStyleSingle .LineWidth= wdLineWidth075pt End With x = ActiveDocument.Paragraphs(1).Borders(wdBorderLeft).LineStyle
RahmenlinienArt, RahmenlinienArt() | Selection.Borders(wdBorderType).LineStyle = wdLineStyle x = ActiveDocument.Paragraphs(1).Borders(wdBorderType).LineStyle
RahmenlinieOben, RahmenlinieOben() | With Selection.Paragraphs(1).Borders(wdBorderTop) .LineStyle = wdLineStyleSingle .LineWidth= wdLineWidth075pt End With x = ActiveDocument.Paragraphs(1).Borders(wdBorderTop).LineStyle
RahmenlinieRechts, RahmenlinieRechts() | With ActiveDocument.Paragraphs(1).Borders(wdBorderRight) .LineStyle = wdLineStyleSingle .LineWidth= wdLineWidth075pt End With x = ActiveDocument.Paragraphs(1).Borders(wdBorderRight).LineStyle
RahmenlinieUnten, RahmenlinieUnten() | With ActiveDocument.Paragraphs(1).Borders(wdBorderBottom) .LineStyle = wdLineStyleSingle .LineWidth = wdLineWidth075pt End With x = ActiveDocument.Paragraphs(1).Borders(wdBorderBottom).LineStyle
Read | Input #
RechtschreibprüfungDurchgeführt, RechtschreibprüfungDurchgeführt() | ActiveDocument.Content.SpellingChecked = True x = ActiveDocument.Content.SpellingChecked
Redim | ReDim
REM | REM
Right$() | Right() ' oder Right$()
RmDir Pfad | RmDir Path
Rnd(Zahl) | Rnd(Number)
RTrim$() | RTrim() ' oder RTrim$()
RückEinzugAbsatz | Selection.Paragraphs.TabIndent Count:=-1
RückEinzugSeitenrand | ActiveDocument.Paragraphs(1).TabHangingIndent Count:=-1


Visual Basic-Entsprechungen S

S |
Sammlung | NormalTemplate.AutoTextEntries.AppendToSpike
Sanduhr | System.Cursor = WdCursorType
SatzLinks 1,1 | Selection.Sentences(1).Previous(Unit:=wdSentence, Count:=1).Select
SatzRechts 1, 1 | Selection.Sentences(1).Next(Unit:=wdSentence, Count:=1).Select
SchaltflächeHinzufügen | CommandBars(Name).Controls.Add
SchaltflächeLöschen | CommandBars(Name).Controls(Num).Delete
SchaltflächenSymbolKopieren | CommandBars(Name).Controls(1).CopyFace
SchaltflächenSymbolWählen | With CommandBars(Name).Controls(1) .FaceId = Num .TooltipText = Text End With
SchaltflächeVerschieben | CommandBars(Name).Controls(1).Move
Schattiert, Schattiert() | Selection.Font.Shadow = True x = Selection.Font.Shadow
SchattierungsMuster, SchattierungsMuster() | Selection.Shading.Texture = WdTextureIndex
Schriftart, Schriftart$() | Selection.Font.Name = Text x = Selection.Font.Name
SchriftartenErsetzung | Application.SubstituteFont
Schriftgrad, Schriftgrad() | Selection.Font.Size = Num x = Selection.Font.Size
SchriftgradAuswahl | Application.Run MacroName:="FontSizeSelect"
SchriftVergrößern | Selection.Font.Grow
SchriftVergrößernEinPunkt | Selection.Font.Size = Selection.Font.Size + 1
SchriftVerkleinern | Selection.Font.Shrink
SchriftVerkleinernEinPunkt | Selection.Font.Size = Selection.Font.Size - 1
Seek Dateinummer, Position Seek(Dateinummer) | Seek[#]Filenumber,Position Seek(Filenumber)
SeitenansichtSchließen | ActiveDocument.ClosePrintPreview
Sekunde(Zeit) | Second(Time)
Select Case | Select Case
SendKeys Tasten, Warten | SendKeys Keys, Wait
Seriendruck FehlerPrüfen, Ziel, SeriendruckMergeRec, Von, Bis, Unterdrücken, Seriendruck, MailBetreff, AlsAnlageSenden, SerienbriefAdresse | With ActiveDocument.MailMerge .Check .Destination = WdMailMergeDestination .DataSource.FirstRecord = Num .DataSource.LastRecord = Num .SuppressBlankLines = True .MailSubject = Text .MailAsAttachment = True .MailAddressFieldName = Text .Execute End With
SeriendruckAbfrageOptionen | ActiveDocument.MailMerge.DataSource.QueryString = Text
SeriendruckAdreßbuchVerwenden | ActiveDocument.MailMerge.UseAddressBook
SeriendruckAnDrucker | ActiveDocument.MailMerge.Destination = wdSendToPrinter
SeriendruckAnfrageChevronsUmwandeln, SeriendruckAnfrageChevronsUmwandeln() | FileConverters.ConvertMacWordChevrons = WdChevronConvertRule State = FileConverters.ConvertMacWordChevrons
SeriendruckAnsichtDaten, SeriendruckAnsichtDaten() | ActiveDocument.MailMerge.ViewMailMergeFieldCodes = True x = ActiveDocument.MailMerge.ViewMailMergeFieldCodes
SeriendruckChevronsUmwandeln, SeriendruckChevronsUmwandeln() | FileConverters.ConvertMacWordChevrons = WdChevronConvertRule State = FileConverters.ConvertMacWordChevrons
SeriendruckDatenMaske | ActiveDocument.DataForm
SeriendruckDatenQuelle$(0) SeriendruckDatenQuelle$(1) SeriendruckDatenQuelle$(2) SeriendruckDatenQuelle$(3) | x = ActiveDocument.MailMerge.DataSource.Name x = ActiveDocument.MailMerge.DataSource.HeaderSourceName x = ActiveDocument.MailMerge.DataSource.Type x = ActiveDocument.MailMerge.DataSource.HeaderSourceType
SeriendruckDatenQuelleBearbeiten | Documents(Name).MailMerge.EditDataSource
SeriendruckDatenQuelleErstellen | ActiveDocument.MailMerge.CreateDataSource
SeriendruckEinfügenBestimmen | ActiveDocument.MailMerge.Fields.AddSet
SeriendruckEinfügenEingeben | Documents(Name).MailMerge.Fields.AddFillIn
SeriendruckEinfügenFrage | Documents(Name).MailMerge.Fields.AddAsk
SeriendruckEinfügenMergeRec | ActiveDocument.MailMerge.Fields.AddMergeRec
SeriendruckEinfügenNächster | Documents(1).MailMerge.Fields.AddNext
SeriendruckEinfügenNächsterWenn | ActiveDocument.MailMerge.Fields.AddNextIf
SeriendruckEinfügenSeq | ActiveDocument.MailMerge.Fields.AddMergeSeq
SeriendruckEinfügenÜberspringen | ActiveDocument.MailMerge.Fields.AddSkipIf
SeriendruckEinfügenWenn | ActiveDocument.MailMerge.Fields.AddIf
SeriendruckErsterMergeRec | ActiveDocument.MailMerge.DataSource.ActiveRecord = wdFirstRecord
SeriendruckGeheZuMergeRec, SeriendruckGeheZuMergeRec() | ActiveDocument.MailMerge.DataSource.ActiveRecord = Num x = ActiveDocument.MailMerge.DataSource.ActiveRecord
SeriendruckHauptdokumentArt, SeriendruckHauptdokumentArt() | ActiveDocument.MailMerge.MainDocumentType = WdMailMergeMainDocType State = ActiveDocument.MailMerge.MainDocumentType
SeriendruckHauptdokumentBearbeiten | ActiveDocument.MailMerge.EditMainDocument
SeriendruckInDokument | Documents(Name).MailMerge.Destination = wdSendToNewDocument
SeriendruckLetzterMergeRec | Documents(Name).MailMerge.DataSource.ActiveRecord = wdLastRecord
SeriendruckLösen | ActiveDocument.MailMerge.MainDocumentType = wdNotAMergeDocument
SeriendruckManager | Dialogs(wdDialogMailMergeHelper).Show
SeriendruckMergeRecGefunden() | x = ActiveDocument.MailMerge.DataSource.FindRecord
SeriendruckMergeRecSuchen | ActiveDocument.MailMerge.DataSource.FindRecord
SeriendruckNächsterMergeRec | ActiveDocument.MailMerge.DataSource.ActiveRecord = wdNextRecord
SeriendruckÖffnenDatenQuelle | Documents(1).MailMerge.OpenDataSource
SeriendruckÖffnenSteuersatzQuelle | Documents(Name).MailMerge.OpenHeaderSource
SeriendruckPrüfen | ActiveDocument.MailMerge.Check
SeriendruckStatus() | theState = ActiveDocument.MailMerge.State
SeriendruckSteuersatzQuelleBearbeiten | Documents(1).MailMerge.EditHeaderSource
SeriendruckSteuersatzQuelleErstellen | Documents(Name).MailMerge.CreateHeaderSource
SeriendruckVorherigerMergeRec | ActiveDocument.MailMerge.DataSource.ActiveRecord = wdPreviousRecord
SetPrivateProfileString Abschnitt, Eintrag, Einstellung, Dateiname | System.PrivateProfileString(Filename, Section, Key) = Setting
SetProfileString Abschnitt, Eintrag, Einstellung | System.ProfileString(Section, Key) = Setting
Sgn() | Sgn()
Shell | Shell
ShowHeading Nummer | Windows(Name).View.ShowHeading Level:=Num
SortDatenfeld | WordBasic.SortArray
SpalteMarkieren | Selection.ColumnSelectMode = True
Sprache, Sprache$() | Selection.LanguageID
StandardFV | Selection.Style = wdStyleNormal
StandardZeichenLaufweite | Selection.Font.Spacing = 0
StandardZeichenPosition | Selection.Font.Position = 0
SteuerungAusführen | WordBasic.ControlRun ' oder Shell Appfilename
Stop | Stop
Str$(Zahl) | Str(Number) Str$(Number)
String$(Anzahl, Zeichen) | String(Count, Character) String$(Count, Character)
Stunde() | Hour
Sub...End Sub | Sub...End Sub
SuchenWiederholen | Application.Run MacroName:="RepeatFind"
SymbolleistenSchaltflächenMakro$() | x = CommandBars(Name).Controls(1).OnAction
SymbolleistenStatus(Name) | CommandBars(Name).Visible = True
SymbolleisteVerschieben | With CommandBars(Name) .Top = Num .Left = Num End With CommandBars(Name).Position = MsoBarPosition
SymbolSchriftart | Selection.Font.Name = "Symbol"


Visual Basic-Entsprechungen T

T |
TabAusricht$(Position) | aType = Selection.Paragraphs(num).TabStops(Pos).Leader
TabelleAktualisierenAutoFormat | Selection.Tables(1).UpdateAutoFormat
TabelleAutoFormat | ActiveDocument.Tables(1).AutoFormat
TabelleAutoSumme | ActiveDocument.Tables(1).Cell(Row, Column).AutoSum
TabelleFormel | ActiveDocument.Tables(1).Cell(Row, Column).Formula
TabelleGitternetzlinien, TabelleGitternetzlinien() | ActiveWindow.View.TableGridlines = True x = ActiveWindow.View.TableGridlines
TabelleInText | Selection.Tables(1).ConvertToText
TabelleSortieren | ActiveDocument.Tables(1).Sort
TabelleSortierenANachZ | ActiveDocument.Tables(1).SortAscending
TabelleSortierenZNachA | ActiveDocument.Tables(1).SortDescending
TabelleSpalteEinfügen | Selection.Tables(1).Columns.Add
TabelleSpalteLöschen | ActiveDocument.Tables(1).Columns(Num).Delete ' oder ActiveDocument.Tables(1).Columns.Delete
TabelleSpalteMarkieren | Selection.Tables(1).Columns(Num).Select
TabelleSpaltenBreite SpaltenBreite, LinealArt TabelleSpaltenBreite OptimaleBreite TabelleSpaltenBreite NächsteSpalte TabelleSpaltenBreite VorherigeSpalte TabelleSpaltenBreite AbstandZwischenSpalten | ActiveDocument.Tables(1).Columns.SetWidth ColumnWidth:=Num, Rulerstyle:=wdRulerStyle ActiveDocument.Tables(1).Columns.AutoFit Selection.Columns(1).Next.Select Selection.Columns(1).Previous.Select ActiveDocument.Tables(1).Rows.SpaceBetweenColumns = Num
TabelleTabelleEinfügen AnzSpalten, AnzTabZeilen TabelleTabelleEinfügen AnzSpalten, AnzTabZeilen, Format, Anwenden TabelleTabelleEinfügen AnzSpalten, AnzTabZeilen, UmwandelnVon | ActiveDocument.Tables.Add Range:=Range, NumRows:=Num, NumColumns:=Num ActiveDocument.Tables.Add(Range:=Range, NumRows:=Num, NumColumns:=Num).AutoFormat Selection.ConvertToTable Separator:=WdTableFieldSeparator, NumRows:=Num, NumColumns:=Num
TabelleTabelleMarkieren | ActiveDocument.Tables(1).Select
TabelleTeilen | Selection.Tables(1).Split
TabelleÜberschriften, TabelleÜberschriften() | Selection.Tables(1).Rows(Num).HeadingFormat = True ' oder Selection.Tables(1).Rows.HeadingFormat = True x = Selection.Tables(1).Rows.HeadingFormat
TabelleZeileEinfügen | Selection.Tables(1).Rows.Add
TabelleZeileLöschen | ActiveDocument.Tables(1).Rows(Num).Delete ' oder ActiveDocument.Tables(1).Rows.Delete
TabelleZeileMarkieren | Selection.Tables(1).Rows(Num).Select
TabelleZeilenHöhe LinealArt, ZeilenabstandArt, Zeilenabstand, EinzugLinks, Ausrichtung, ZeilenTrennenZulassen TabelleZeilenHöhe NächsteZeile TabelleZeilenHöhe VorherigeZeile | With ActiveDocument.Tables(Num).Rows(Num) .SetHeight RowHeight:= Num, HeightRule:=WdRowHeightRule .Alignment = WdRowAlignment .SetLeftIndent LeftIndent:=Num, RulerStyle:=WdRulerStyle .AllowBreakAcrossPages = True End With Selection.Rows(1).Next.Select Selection.Rows(1).Previous.Select
TabelleZellenEinfügen | Selection.Tables(1).Columns(Num).Cells.Add
TabelleZellenLöschen FelderVerschieben | ActiveDocument.Tables(1).Cell(Row, Column).Delete ShiftCells:=WdDeleteCells
TabelleZellenTeilen | Selection.Tables(1).Cells(Row, Column).Split
TabelleZellenVerbinden | Selection.Cells.Merge
TabstopArt() | x = Selection.ParagraphFormat.TabStops(1).Alignment
Tag() | Day
Tage360() | DateDiff
TastenSchlüssel() | x = KeyBindings(1).KeyCode
TemplateBearbeitetBestimmen 0 | Documents(Name).AttachedTemplate.Saved = True ' oder Templates(Name).Saved = True
TemplateSpeichern | ActiveDocument.AttachedTemplate.Save ' oder Templates(Name).Save
Text | Label-Steuerelement
TextBox | TextBox-Steuerelement
TextFormularFeld | ActiveDocument.FormFields.Add Range:=Range, Type:=wdFieldFormTextInput
TextInTabelle | Selection.ConvertToTable
TextKopieren | Application.Run MacroName:="CopyText"
TextkörperUmschalten | ActiveWindow.View.ShowMainTextLayer = Not ActiveWindow.View.ShowMainTextLayer
TextmarkeKopieren | ActiveDocument.Bookmarks(Name).Copy(Name)
TextmarkenVergleichen() | If ActiveDocument.Bookmarks(Name) = ActiveDocument.Bookmarks(Name) Then same = True End If Die Start- und die End-Eigenschaft können verwendet werden, um die Anfangs- und die Endposition zweier Textmarken zu vergleichen.
TextmarkeVorhanden(Name) | x = ActiveDocument.Bookmarks.Exists(Name)
TextVerschieben | WordBasic.MoveText
TieferstufenListe | Selection.Range.ListFormat.ListOutdent
TieferstufenZuTextKörper | Selection.Paragraphs(1).OutlineDemoteToBody
Tiefgestellt, Tiefgestellt() | Selection.Font.Subscript = True x = Selection.Font.Subscript
Time$() | Time() ' oder Time$()
TipAssistent | Keine direkte Entsprechung ' zeigt einen speziellen Tipp an, wenn Word gestartet wird Assistant.FeatureTips = True
ToolsAutoCorrectDays, ToolsAutoCorrectDays() | AutoCorrect.CorrectDays = True
ToolsGetSpelling, ToolsGetSpelling() | GetSpellingSuggestions
ToolsGetSynonyms, ToolsGetSynonyms() | SynonymInfo


Visual Basic-Entsprechungen U und V

U |
Überschreiben | Options.Overtype = True
UCase$(Zeichenfolge) | UCase(String) ' oder UCase$(String)
Umgebung$() | Environ$()
UmwAlleFußnotenEndnoten | ActiveDocument.Endnotes.SwapWithFootnotes ' oder ActiveDocument.Footnotes.SwapWithEndnotes
Unterstrichen, Unterstrichen() | ActiveDocument.Words(1).Underline = True Status = Selection.Font.Underline

V |
Val(Text) | Val(Text)
VariablenAnzeigen | Fügen Sie im Visual Basic-Editor einen watch-Ausdruck hinzu.
Verbinden | System.Connect
Verborgen | Selection.Font.Hidden = True
VerknüpfungLösenFelder | Selection.Range.Fields.Unlink ActiveDocument.Fields(Num).Unlink
VolumeAktivieren | Application.MountVolume
VorgabeAbsatz, VorgabeAbsatz() | Selection.Paragraphs.Reset
VorgabeFußnotenTrennlinieOderHinweis | ActiveDocument.Endnotes.ResetContinuationNotice ActiveDocument.Footnotes.ResetContinuationNotice ActiveDocument.Endnotes.ResetContinuationSeparator ActiveDocument.Footnotes.ResetContinuationSeparator
VorgabeSchaltflächenSymbol | CommandBars(Name).Controls(1).Reset
VorherigerTab() | x = ActiveDocument.Paragraphs(1).TabStops(1).Previous.Position
VorherigeSeite, VorherigeSeite() | Selection.GoToPrevious What:=wdGoToPage ' oder ActiveWindow.View.Type = wdPrintView ActiveWindow.PageScroll Up:=1
VorherigesFeld, VorherigesFeld() | Selection.GoToPrevious What:=wdGoToField ' oder Selection.PreviousField
VorherigesFenster | ActiveWindow.Previous.Activate
VorherigesObjekt | Selection.GoToPrevious What:=wdGoToObject ' oder Selection.MoveLeft Unit:=wdItem
VorherigeZelle, VorherigeZelle() | Selection.Move Unit:=wdCell, Count:=-1 ' oder Selection.Cells(1).Previous.Select
VRollen, VRollen() | ActiveWindow.VerticalPercentScrolled = Num Num = ActiveWindow.VerticalPercentScrolled
VSeite | ActiveWindow.LargeScroll Down:=Num ' oder ActiveWindow.LargeScroll Up:=Num
VZeile | ActiveWindow.SmallScroll Down:=Num ' oder ActiveWindow.SmallScroll Up:=Num


Visual Basic-Entsprechungen W bis Z

W |
While...Wend | While...Wend
WinNachDOS$() | x = WordBasic.[WinToDOS$](StringToTranslate)
Wochentag(Datum) | Weekday(Date)
WortLinks Anzahl WortLinks Anzahl, Markierung | Selection.MoveLeft Unit:=wdWord, Count:=1, Extend:=wdMove Selection.MoveStart Unit:=wdWord, Count:=-1 ' oder Selection.MoveLeft Unit:=WdWord, Count:=1, Extend:=wdExtend
WortLöschen | Selection.Words(1).Delete
WortRechts 1 WortRechts 1, 1 | Selection.MoveRight Unit:=wdWord, Count:=1, Extend:=wdMove Selection.MoveEnd Unit:=wdWord, Count:=1 ' oder Selection.MoveRight Unit:=WdWord, Count:=1, Extend:=wdExtend
WortUnterstreichen, WortUnterstreichen() | Selection.Range.Underline = wdUnderlineWords Status = Selection.Range.Underline
Write | Write

Z |
ZählenAddIns() | x = Addins.Count
ZählenAutoKorrekturAusnahmen(0) ZählenAutoKorrekturAusnahmen(1) | x = AutoCorrect.FirstLetterExceptions.Count x = AutoCorrect.TwoInitialCapsExceptions.Count
ZählenAutoTextEinträge() | x = ActiveDocument.AttachedTemplate.AutoTextEntries.Count
ZählenDateien() | x = RecentFiles.Count
ZählenDokumentEigenschaften() | x = ActiveDocument.BuiltInDocumentProperties.Count ' oder x = ActiveDocument.CustomDocumentProperties.Count
ZählenDokumentVariablen() | x = ActiveDocument.Variables.Count
ZählenExtrasGrammatikStatistik() | x = ActiveDocument.Content.ReadabilityStatistics.Count
ZählenFenster() | x = Windows.Count
ZählenFormatvorlagen() | x = ActiveDocument.Styles.Count ' oder x = ActiveDocument.AttachedTemplate.OpenAsDocument.Styles.Count ' um integrierte Formatvorlagen von der Zählung auszuschließen For Each xSty In ActiveDocument.Styles If xSty.BuiltIn = False Then aCount = aCount + 1 Next xSty
ZählenGefundeneDateien() | x = Application.FileSearch.FoundFiles.Count
ZählenMakros() | ' keine direkte Entsprechung ' zählt die Anzahl der mit der Dokumentvorlage "Normal" verbundenen Module For Each xItem In NormalTemplate.VBProject.VBComponents If xItem.Type = vbext_ct_StdModule Then Count = Count + 1 Next x MsgBox Count
ZählenMenüEintrag() | x = CommandBars(Name).Controls.Count
ZählenMenüs() | x = CommandBars.ActiveMenuBar.Controls.Count
ZählenMergeFielder() | x = ActiveDocument.MailMerge.Fields.Count
ZählenSchriftarten() | x = FontNames.Count ' oder x = PortraitFontNames.Count ' oder x = LandscapeFontNames.Count
ZählenSprachen() | x = Languages.Count
ZählenSymbolleisten() | For Each xCB In CommandBars If xCB.Type = msoBarTypeNormal Then aCount = aCount + 1 Next xCB
ZählenSymbolleistenSchaltflächen() | x = CommandBars(Name).Controls.Count
ZählenTasten() | CustomizationContext = Template or Document x = KeyBindings.Count
ZählenTextmarken() | x = ActiveDocument.Bookmarks.Count
ZählenVerzeichnisse() | myPath = "C:\" myName = Dir(myPath, vbDirectory) Do While myName <> "" If myName <> "." And myName <> ".." Then If (GetAttr(myPath & myName) And vbDirectory) = vbDirectory Then count = count + 1 End If End If myName = Dir Loop MsgBox count & " directories"
ZeichenFarbe, ZeichenFarbe() | Selection.Font.ColorIndex = WdColorIndex x = Selection.Font.ColorIndex
ZeichenLinks 1 ZeichenLinks 1, 1 Zahl = ZeichenLinks(1) | Selection.MoveLeft Unit:=wdCharacter, Count:=1, Extend:=wdMove Selection.MoveLeft Unit:=wdCharacter, Count:=1, Extend:=wdExtend Num = Selection.MoveLeft(Unit:=wdCharacter, Count:=1)
ZeichenRechts 1 ZeichenRechts 1, 1 Zahl = ZeichenRechts(1) | Selection.MoveRight Unit:=wdCharacter, Count:=1, Extend:=wdMove Selection.MoveRight Unit:=wdCharacter, Count:=1, Extend:=wdExtend Num = Selection.MoveRight(Unit:=wdCharacter, Count:=1)
ZeichenVorgabe, ZeichenVorgabe() | Selection.Font.Reset
Zeichnungsobjekt-Anweisungen und -Funktionen | Verwenden Sie die Eigenschaften und Methoden der folgenden Objekte: Shape, Shapes und ShapeRange.
Zeilenabstand1, Zeilenabstand1() | Selection.Paragraphs.Space1 x = Selection.Paragraphs.LineSpacing
Zeilenabstand2, Zeilenabstand2() | Selection.Paragraphs.Space2 x = Selection.Paragraphs.LineSpacing
ZeilenabstandEinsKommaFünf, ZeilenabstandEinsKommaFünf() | Selection.Paragraphs.Space15 x = Selection.Paragraphs.LineSpacing
ZeileOben, ZeileOben() | Selection.MoveUp Unit:= wdLine, Count:=1, Extend:=wdMove
ZeileUnten, ZeileUnten() | Selection.MoveDown Unit:=wdLine, Count:=1, Extend:=wdMove
ZeitSeriell() | TimeSerial
ZeitWert() | TimeValue
ZurückEinfügemarke | Application.GoBack
ZwischenablageAnzeigen | Application.ShowClipboard


Microsoft Word-Objekte

Application-Objekt

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Neue Ereignisse

In der folgenden alphabetisch sortierten Liste werden die Methoden aufgeführt, die in Microsoft Word 2000 zum Application-Objekt hinzugefügt wurden.

DocumentBeforeClose

DocumentBeforePrint

DocumentBeforeSave

DocumentOpen

NewDocument

WindowActivate

WindowBeforeDoubleClick

WindowBeforeRightClick

WindowDeactivate

WindowSelectionChange


Close-Ereignis

Tritt ein, wenn ein Dokument geschlossen wird.

Syntax

Private Sub Document_Close()

Hinweise

Wenn die Ereignisprozedur in einer Dokumentvorlage gespeichert ist, wird die Prozedur aufgerufen, sobald ein neues, auf dieser Dokumentvorlage basierendes Dokument geöffnet oder die Dokumentvorlage selbst geschlossen wird (nachdem sie als Dokument geöffnet wurde).

Informationen über die Verwendung von Ereignissen mit einem Document-Objekt finden Sie unter Verwenden von Ereignissen mit dem Document-Objekt.


Beispiel zum Close-Ereignis

In diesem Beispiel wird eine Sicherungskopie des Dokuments auf dem Dateiserver angelegt, wenn das Dokument geschlossen wird. (Diese Prozedur wird in einem Dokument gespeichert, nicht in einer Dokumentvorlage.)

Private Sub Document_Close()
    ThisDocument.Save
    ThisDocument.SaveAs "\\network\backup\" & ThisDocument.Name
End Sub


DocumentBeforeClose-Ereignis

Tritt unmittelbar vor dem Schließen eines geöffneten Dokuments ein.

Syntax

Private Sub object_DocumentBeforeClose(ByVal Doc As Document, ByVal Cancel As Boolean)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Doc Das Dokument, das geschlossen wird.

Cancel False, wenn das Ereignis eintritt. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird das Dokument beim Beenden der Prozedur nicht geschlossen.


Beispiel zum DocumentBeforeClose-Ereignis

In diesem Beispiel wird der Benutzer vor dem Schließen eines Dokuments zum Klicken auf Ja oder Nein aufgefordert.

Private Sub App_DocumentBeforeClose _
        (ByVal Doc As Document, _
        Cancel As Boolean)
    a = MsgBox("Do you really " _
        & "want to close the document?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


DocumentBeforePrint-Ereignis

Tritt ein, bevor ein Dokument gedruckt wird.

Syntax

Private Sub object_DocumentBeforePrint(ByVal Doc As Document, ByVal Cancel As Boolean)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Doc Das Dokument, das gedruckt wird.

Cancel False, wenn das Ereignis eintritt. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird das Dokument beim Beenden der Prozedur nicht gedruckt.


Beispiel zum DocumentBeforePrint-Ereignis

In diesem Beispiel wird der Benutzer vor dem Drucken eines Dokuments zum Klicken auf Ja oder Nein aufgefordert.

Private Sub App_DocumentBeforePrint _
        (ByVal Doc As Document, _
        Cancel As Boolean)
    a = MsgBox("Have you checked the " _
        & "printer for letterhead?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


DocumentBeforeSave-Ereignis

Tritt ein, bevor ein geöffnetes Dokument gespeichert wird.

Syntax

Private Sub object_DocumentBeforeSave(ByVal Doc As Document, ByVal SaveAsUI As Boolean, ByVal Cancel As Boolean)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen zum Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Object.

Doc Das Dokument, das gespeichert wird.

SaveAsUI True, wenn das Dialogfeld Speichern unter angezeigt werden soll.

Cancel False, wenn das Ereignis eintritt. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird das Dokument beim Beenden der Prozedur nicht gespeichert.


Beispiel zum DocumentBeforeSave-Ereignis

In diesem Beispiel wird der Benutzer vor dem Speichern eines Dokuments zum Klicken auf Ja oder Nein aufgefordert.

Private Sub App_DocumentBeforeSave _
        (ByVal Doc As Document, _
        ByVal SaveAsUI As Boolean, _
        Cancel As Boolean)
    a = MsgBox("Do you really want to " _
        & "save the document?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


DocumentChange-Ereignis

Tritt auf, wenn ein neues Dokument erstellt, wenn ein vorhandenes Dokument geöffnet oder ein anderes Dokument zum aktiven Dokument gemacht wird.

Syntax

Private Sub-Objekt_DocumentChange()

Objekt Ein Objekt vom Typ Application, das mit Ereignissen in einem Klassenmodul deklariert wurde. Informationen über die Verwendung von Ereignissen mit einem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.


Beispiel zum DocumentChange-Ereignis

In diesem Beispiel werden alle offenen Fenster angeordnet, wenn der Dokument-Fokus gewechselt wird.

Private Sub myApp_DocumentChange()
    Application.Windows.Arrange wdTiled
End Sub


DocumentOpen-Ereignis

Tritt ein, wenn ein Dokument geöffnet wird.

Syntax

Private Sub object_DocumentOpen(ByVal Doc As Document)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Object.

Doc Das Dokument, das geöffnet wird.


Beispiel zum DocumentOpen-Ereignis

In diesem Beispiel werden alle geöffneten Fenster beim Öffnen eines Dokuments angeordnet.

Private Sub App_DocumentOpen(ByVal Doc As Document)
    Application.Windows.Arrange wdTiled
End Sub


GotFocus-Ereignis

Tritt auf, wenn der Fokus auf ein eingebettetes ActiveX-Steuerelement gerichtet wird.

Informationen über die Verwendung von Ereignissen mit ActiveX-Steuerelementen finden Sie unter Verwenden von Ereignissen mit ActiveX-Steuerelementen.

Syntax

Private Sub-Objekt_GotFocus()

Objekt Der Name eines ActiveX-Steuerelements.


Beispiel zum GotFocus-Ereignis

In diesem Beispiel wird eine Meldung angezeigt, wenn der Fokus zu Kontrollkästchen1 wechselt.

Private Sub CheckBox1_GotFocus()
    Msgbox "Check this box if you are a permanent employee."
End Sub


LostFocus-Ereignis

Tritt auf, wenn der Fokus von einem eingebetteten ActiveX-Steuerelement weg bewegt wird.

Informationen über die Verwendung von Ereignissen mit ActiveX-Steuerelementen finden Sie unter Verwenden von Ereignissen mit ActiveX-Steuerelementen.

Syntax

Private Sub-Objekt_LostFocus()

Objekt Der Name eines ActiveX-Steuerelements.


Beispiel zum LostFocus-Ereignis

In diesem Beispiel bleibt Befehlsschaltfläche1 deaktiviert, bis der Benutzer einen Wert in Kontrollkästchen1 eingibt.

Private Sub TextBox1_LostFocus()
    If TextBox1.Value = "" Then
        CommandButton1.Enabled = False
    Else
        CommandButton1.Enabled = True
    End If
End Sub


New-Ereignis

Tritt auf, wenn ein Dokument auf Grundlage der Dokumentvorlage erstellt wird. Eine Prozedur für das New-Ereignis wird nur aufgerufen, wenn sie in einer Dokumentvorlage gespeichert ist.

Syntax

Private Sub Document_New()

Anmerkungen

Informationen über die Verwendung von Ereignissen mit einem Document-Objekt finden Sie unter Verwenden von Ereignissen mit dem Document-Objekt.


NewDocument-Ereignis

Tritt ein, wenn ein Dokument erstellt wird.

Syntax

Private Sub object_NewDocument(ByVal Doc As Document)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Doc Das neue Dokument.


Beispiel zum NewDocument-Ereignis

In diesem Beispiel werden alle geöffneten Fenster beim Erstellen eines neuen Dokuments angeordnet.

Private Sub App_NewDocument(ByVal Doc As Document)
    Application.Windows.Arrange wdTiled
End Sub


Open-Ereignis

Tritt beim Öffnen eines Dokuments ein.

Syntax

Private Sub Document_Open()

Hinweise

Wenn die Ereignisprozedur in einer Dokumentvorlage gespeichert ist, wird die Prozedur aufgerufen, wenn ein auf dieser Dokumentvorlage basierendes neues Dokument oder die Dokumentvorlage als Dokument geöffnet wird.

Informationen über die Verwendung von Ereignissen mit einem Document-Objekt finden Sie unter Verwenden von Ereignissen mit dem Document-Objekt.


Beispiel zum Open-Ereignis

In diesem Beispiel wird eine Meldung beim Öffnen eines Dokuments angezeigt.

Private Sub Document_Open()
    Msgbox "This document is copywrited"
End Sub


Quit-Ereignis

Tritt auf, wenn der Benutzer Word beendet.

Syntax

Private Sub-Objekt_Quit()

Objekt Ein Objekt vom Typ Application, das mit Ereignissen in einem Klassenmodul deklariert wurde. Informationen über die Verwendung von Ereignissen mit einem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.


Beispiel zum Quit-Ereignis

In diesem Beispiel wird sichergestellt, dass die Standard- und die Format-Symbolleiste angezeigt werden, bevor der Benutzer Word beendet. Als Ergebnis werden die Standard- und die Format-Symbolleiste angezeigt, wenn der Benutzer Word erneut startet.

Private Sub myApp_Quit()
    CommandBars("Standard").Visible = True
    CommandBars("Formatting").Visible = True
End Sub


WindowActivate-Ereignis

Tritt ein, wenn ein Dokumentfenster aktiviert wird.

Syntax

Private Sub object_WindowActivate(ByVal Doc As Word.Document, ByVal Wn As Word.Window)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt oder dem Document-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt und Verwenden von Ereignissen mit dem Document-Objekt.

Doc Wird nur in Verbindung mit dem Application-Objekt verwendet. Das im aktivierten Fenster angezeigte Dokument.

Wn Das Fenster, das aktiviert wird.


Beispiel zum WindowActivate-Ereignis

In diesem Beispiel wird jedes Dokumentfenster beim Aktivieren maximiert.

Private Sub App_WindowActivate _
        (ByVal Wn As Word.Window)
    Wn.WindowState = wdWindowStateMaximize
End Sub


WindowBeforeDoubleClick-Ereignis

Tritt beim Doppelklicken in den Arbeitsbereich eines Dokumentfensters ein, bevor der durch das Doppelklicken standardmäßig aktivierte Vorgang gestartet wird.

Syntax

Private Sub object_WindowBeforeDoubleClick(ByVal Sel As Selection, ByVal Cancel As Boolean)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Die aktuelle Markierung.

Cancel False, wenn das Ereignis eintritt. Wenn die Ereignisprozedur dieses Argument auf True setzt, wird beim Beenden der Prozedur der durch das Doppelklicken standardmäßig aktivierte Vorgang nicht ausgeführt.


Beispiel zum WindowBeforeDoubleClick-Ereignis

In diesem Beispiel wird der Benutzer vor der standardmäßigen Ausführung eines durch Doppelklicken aktivierten Vorgangs zum Klicken auf Ja oder Nein aufgefordert.

Private Sub App_WindowBeforeDoubleClick _
        (ByVal Sel As Selection, _
        Cancel As Boolean)
    a = MsgBox("Selection = " & Sel & vbLf & vbLf _
        & "Continue with operation on this selection?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


WindowBeforeRightClick-Ereignis

Tritt beim Klicken mit der rechten Maustaste in den Arbeitsbereich eines Dokumentfensters ein, bevor der hierdurch standardmäßig aktivierte Vorgang gestartet wird.

Syntax

Private Sub object_WindowBeforeRightClick(ByVal Sel As Selection, ByVal Cancel As Boolean)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Die aktuelle Markierung.

Cancel False, wenn das Ereignis eintritt. Wenn die Ereignisprozedur das Argument auf True setzt, wird beim Beenden der Prozedur der beim Klicken mit der rechten Maustaste standardmäßig aktivierte Vorgang nicht ausgeführt.


Beispiel zum WindowBeforeRightClick-Ereignis

In diesem Beispiel wird der Benutzer vor der standardmäßig Ausführung eines durch Klicken mit der rechten Maustaste aktivierten Vorgangs zum Klicken auf Ja oder Nein aufgefordert.

Private Sub App_WindowBeforeRightClick _
        (ByVal Sel As Selection, _
        Cancel As Boolean)
    a = MsgBox("Selection = " & Sel & vbLf & vbLf _
        & "Continue with operation on this selection?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


WindowDeactivate-Ereignis

Tritt ein, wenn ein Dokumentfenster deaktiviert wird.

Syntax

Private Sub object_WindowDeactivate(ByVal Doc As Word.Document, ByVal Wn As Word.Window)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt oder dem Document-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt und unter Verwenden von Ereignissen mit dem Document-Objekt.

Doc Wird nur in Verbindung mit dem Application-Objekt verwendet. Das im deaktivierten Fenster angezeigte Dokument.

Wn Das deaktivierte Fenster.


Beispiel zum WindowDeactivate-Ereignis

In diesem Beispiel wird jedes Dokumentfenster beim Deaktivieren minimiert.

Private Sub App_WindowDeactivate _
        (ByVal Wn As Word.Window)
    Wn.WindowState = wdWindowStateMinimize
End Sub


WindowSelectionChange-Ereignis

Tritt ein, wenn die Markierung im aktiven Dokumentfenster geändert wird.

Syntax

Private Sub object_WindowSelectionChange(ByVal Sel As Selection)

object Ein Objekt vom Typ Application, das zusammen mit Ereignissen in einem Klassenmodul deklariert wird. Weitere Informationen über das Verwenden von Ereignissen mit dem Application-Objekt finden Sie unter Verwenden von Ereignissen mit dem Application-Objekt.

Sel Die neue Markierung.


Beispiel zum WindowSelectionChange-Ereignis

In diesem Beispiel wird die neue Markierung fett formatiert.

Private Sub App_WindowSelectionChange _
        (ByVal Sel As Selection)
    Sel.Font.Bold = True
End Sub


Neue Methoden (nach Objekten sortiert)

In der folgenden Tabelle sind die Methoden aufgeführt, die in Microsoft Word 2000 zu bereits vorhandenen Objekten hinzugefügt wurden (nach Objektname sortiert).

Objekt | Neue Methoden
Application | DefaultWebOptions, GetDefaultTheme, KeyboardBidi, KeyboardLatin, Keyboard, PixelsToPoints, PointsToPixels, ProductCode, SetDefaultTheme, ToggleKeyboard
Document | ApplyTheme, CheckConsistency, DetectLanguage, ReloadAs, RemoveTheme, WebPagePreview
Find | ClearAllFuzzyOptions, SetAllFuzzyOptions
Frameset | AddNewFrame
Global | PixelsToPoints, PointsToPixels
InlineShapes | AddHorizontalLineStandard, AddHorizontalLine, AddPictureBullet
Pane | NewFrameset, TOCInFrameset
Paragraph | IndentCharWidth, IndentFirstLineCharWidth
ParagraphFormat | IndentCharWidth, IndentFirstLineCharWidth
Paragraphs | IndentCharWidth, IndentFirstLineCharWidth
Range | ConvertHangulAndHanja, DetectLanguage, ModifyEnclosure, PasteAsNestedTable, PhoneticGuide, TCSCConverter
Selection | BoldRun, CreateAutoTextEntry, DetectLanguage, InsertColumnsRight, InsertRowsAbove, InsertRowsBelow, ItalicRun, LtrPara, LtrRun, PasteAsNestedTable, RtlPara, RtlRun, SelectCell
Table | AutoFitBehavior
WebOptions | UseDefaultFolderSuffix
Window | GetPoint, RangeFromPoint, ScrollIntoView, SetFocus


Accept-Methode

Nimmt die angegebene Überarbeitung an. Die Korrekturmarkierungen werden entfernt, und die Überarbeitung wird in das Dokument integriert.

Syntax

Ausdruck.Accept

Ausdruck Erforderlich. Ein Ausdruck, der ein Revision-Objekt zurückgibt.


AcceptAll-Methode

Nimmt alle Überarbeitungen in einem Dokument oder Bereich an. Die Korrekturmarkierungen werden entfernt, und die Überarbeitungen werden in das Dokument integriert.

Syntax

Ausdruck.AcceptAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Revisions-Objekt zurückgibt.

Anmerkungen

Mit der AcceptAllRevisions-Methode werden alle Korrekturen in einem Dokument akzeptiert.


AcceptAllRevisions-Methode

Übernimmt alle überwachten Änderungen im angegebenen Dokument.

Syntax

Ausdruck.AcceptAllRevisions

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur AcceptAllRevisions-Methode

In diesem Beispiel wird der Haupttextbereich im aktiven Dokument nach überwachten Änderungen durchsucht. Falls solche Änderungen gefunden werden, nimmt das Beispiel alle Korrekturen in allen Dokumentkomponenten im Dokument auf.

If ActiveDocument.Revisions.Count >= 1 Then _
    ActiveDocument.AcceptAllRevisions


Activate-Methode

Aktiviert ein angegebenes Objekt.

Syntax 1

Ausdruck.Activate(Wait)

Syntax 2

Ausdruck.Activate

Ausdruck Erforderlich. Ein Ausdruck, der ein Task-Objekt (Syntax 1) oder ein anderes Objekt (Syntax 2) zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Wait Optional Boolean. Nur Task-Objekt. True, um zu warten, bis der Benutzer Word aktiviert hat, bevor die Aufgabe aktiviert wird. False, um die Aufgabe sofort zu aktivieren, auch wenn Word nicht aktiviert ist.


ActivateAs-Methode

Legt den Windows-Registrierungswert fest, der die Standardanwendung zum Aktivieren des angegebenen OLE-Objekts bestimmt.

Syntax

Ausdruck.ActivateAs(ClassType)

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEFormat-Objekt zurückgibt.

ClassType String erforderlich. Der Name der Anwendung, in der ein OLE-Objekt geöffnet wird. Wenn Sie eine Liste der Objekttypen sehen wollen, als die das OLE-Objekt aktiviert werden kann, klicken Sie auf das Objekt, und öffnen Sie dann das Dialogfeld Umwandeln (Menü Bearbeiten, Untermenü Objekt). Sie können die Zeichenfolge ClassType finden, indem Sie ein Objekt als zeilenfixierte Form einfügen und sich dann die Feldfunktionen ansehen. Der Klassentyp des Objekts steht entweder nach dem Wort "EMBED" oder dem Wort "LINK".


Beispiel zur ActivateAs-Methode

In diesem Beispiel wird festgelegt, dass die erste bewegliche Form im aktiven Dokument in Microsoft Excel geöffnet werden soll, und dann wird die Form aktiviert. Damit das Beispiel funktioniert, muss diese Form ein OLE-Objekt sein, das in Microsoft Excel geöffnet werden kann.

With ActiveDocument.Shapes(1).OLEFormat
    .ActivateAs ClassType:="Excel.Sheet"
    .Activate
End With


Add-Methode

Fügt einer Auflistung ein weiteres Element hinzu, wie in der folgenden Tabelle dargestellt. Klicken Sie auf den Namen eines Objekts in der Tabelle, wenn Sie weitere Informationen zur Add-Methode für dieses Objekt erhalten möchten.

Objekt | Beschreibung
AddIns | Fügt der Liste der verfügbaren Add-Ins ein Add-In hinzu.
AutoCorrectEntries | Fügt der Liste der verfügbaren AutoKorrektur-Einträge einen unformatierten AutoKorrektur-Eintrag hinzu.
AutoTextEntries | Fügt der Liste der verfügbaren AutoText-Einträge einen AutoText-Eintrag hinzu.
Bookmarks | Fügt einem Bereich eine Textmarke hinzu.
CaptionLabels | Fügt eine benutzerdefinierte Beschriftungskategorie hinzu.
Cells, Rows, Columns | Fügt einer Tabelle eine Zelle, Zeile oder Spalte hinzu.
Comments | Fügt einem Bereich einen Kommentar hinzu.
CustomLabels | Fügt ein benutzerdefiniertes Adressetikett hinzu.
Dictionaries | Fügt der Auflistung von aktiven Benutzerwörterbüchern ein neues Benutzerwörterbuch hinzu.
Documents | Fügt der Auflistung geöffneter Dokumente ein neues, leeres Dokument hinzu.
Endnotes, Footnotes | Fügt einem Bereich eine Fuß- oder Endnote hinzu.
Fields | Fügt einem Bereich ein Feld hinzu.
FirstLetterExceptions, OtherCorrectionsExceptions, TwoInitialCapsExceptions | Fügt der Liste der AutoKorrrektur-Ausnahmen eine neue Ausnahme hinzu.
FormFields | Fügt einem Bereich ein neues Formularfeld hinzu.
Frames | Fügt einem Bereich, einer Markierung oder einem Dokument einen Frame hinzu.
HangulAndAlphabetExceptions | Fügt der Liste der Autokorrektur-Ausnahmen eine neue Ausnahme hinzu.
HangulHanjaConversionDictionaries | Fügt der Auflistung von aktiven Umwandlungswörterbüchern ein neues Umwandlungswörterbuch hinzu.
HeadingStyles | Fügt einem Dokument eine neue Überschriftenformatvorlage hinzu. Die neue Überschriftenformatvorlage wird beim Erstellen eines Inhalts- oder Abbildungsverzeichnisses immer berücksichtigt.
Hyperlinks | Fügt einem Bereich, einer Markierung oder einem Dokument einen neuen Hyperlink hinzu.
Indexes | Fügt einem Dokument einen neuen Index hinzu.
KeyBindings | Fügt eine Tastenkombination für ein Makro, einen integrierten Befehl, eine Schriftart, einen AutoText-Eintrag, eine Formatvorlage oder ein Symbol hinzu.
ListEntries | Fügt einem Dropdown-Formularfeld ein Element hinzu.
ListTemplates | Erstellt eine neue Listenvorlage.
MailMergeFields | Fügt dem Datenquellendokument ein Seriendruckfeld hinzu.
PageNumbers | Fügt einer Kopf- oder Fußzeile in einem Abschnitt Seitenzahlen hinzu.
Panes | Fügt einem Fenster einen neuen Ausschnitt hinzu.
Paragraphs | Fügt einem Dokument einen neuen, leeren Abschnitt hinzu.
RecentFiles | Fügt der Liste zuletzt geöffneter Dateien eine Datei hinzu.
Sections | Fügt einem Dokument einen neuen Abschnitt hinzu.
Styles | Fügt der Liste von Formatvorlagen eine neue, benutzerdefinierte Formatvorlage hinzu.
Tables | Fügt einem Dokument eine neue, leere Tabelle hinzu.
TablesOfAuthorities | Fügt einem Dokument ein Rechtsgrundlagenverzeichnis hinzu.
TablesOfContents | Fügt einem Dokument ein Inhaltsverzeichnis hinzu.
TablesOfFigures | Fügt einem Dokument ein Abbildungsverzeichnis hinzu.
TabStops | Fügt einem Dokument einen benutzerdefinierten Tabstopp hinzu.
TextColumns | Fügt einem Dokument oder einem Abschnitt eine neue Textspalte hinzu.
Variables | Fügt einem Dokument eine Variable hinzu.
Windows | Fügt ein neues Fenster für ein Dokument hinzu.


Add-Methode (AddIns-Auflistung)

Fügt die Datei, die durch FileName spezifiziert wurde, zur Liste der verfügbaren Add-Ins hinzu.

Syntax

Ausdruck.Add(FileName, Install)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

FileName String erforderlich. Der Pfad für die Vorlage oder WLL.

Install Variant optional. True, wenn das Add-In installiert werden soll. False, wenn das Add-In in die Liste der Add-Ins aufgenommen, aber nicht installiert werden soll. Der Standardwert ist True.

Anmerkungen

Verwenden Sie die Installed-Eigenschaft eines Add-Ins, wenn Sie wissen wollen, ob es bereits installiert ist.


Beispiel zur Add-Methode (AddIns-Auflistung)

In diesem Beispiel wird eine Vorlage "MyFax.dot" installiert und in die Liste der Add-Ins im Dialogfeld Vorlagen und Add-Ins aufgenommen.

AddIns.Add FileName:="C:\Program Files\Microsoft Office" _
    & "\Templates\Letters & Faxes\MyFax.dot", Install:=True


AddAddress-Methode

Fügt zu dem Adressbuch einen Eintrag hinzu. Jeder Eintrag hat einen Wert für eine oder mehrere Markenkennungen.

Syntax

Ausdruck.AddAddress(TagID, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

TagID String-Datenfeld erforderlich. Die Werte für die Markenkennung des neuen Adresseintrags. Jedes Element im Datenfeld kann eine der Zeichenfolgen enthalten, die in der folgenden Tabelle aufgeführt werden. Nur der angezeigte Name ist notwendig, alle anderen Einträge sind optional.

Markenkennung | Beschreibung
PR_DISPLAY_NAME | Der Name, der im Dialogfeld Adressbuch angezeigt wird
PR_COURTESY_TITLE | Anrede (zum Beispiel "Frau" oder "Dr.")
PR_GIVEN_NAME | Vornamen
PR_SURNAME | Nachname
PR_STREET_ADDRESS | Straße
PR_LOCALITY | Stadt oder Ort
PR_STATE_OR_PROVINCE | Staat oder Provinz
PR_POSTAL_CODE | Postleitzahl
PR_COUNTRY | Land
PR_TITLE | Position
PR_COMPANY_NAME | Firma
PR_DEPARTMENT_NAME | Name der Abteilung innerhalb der Firma
PR_OFFICE_LOCATION | Büro
PR_PRIMARY_TELEPHONE_NUMBER | Primäre Telefonnummer
PR_PRIMARY_FAX_NUMBER | Primäre Faxnummer
PR_OFFICE_TELEPHONE_NUMBER | Büro-Telefonnummer
PR_OFFICE2_TELEPHONE_NUMBER | Zweite Büro-Telefonnummer
PR_HOME_TELEPHONE_NUMBER | Private Telefonummer
PR_CELLULAR_TELEPHONE_NUMBER | Funktelefonnummer
PR_BEEPER_TELEPHONE_NUMBER | Pager-Telefonnummer
PR_COMMENT | Text auf der Registerkarte Notizen für den Adresseintrag
PR_EMAIL_ADDRESS | E-Mail-Adresse
PR_ADDRTYPE | Typ der E-Mail-Adresse
PR_OTHER_TELEPHONE_NUMBER | Alternative Telefonnummer (nicht Privat oder Büro)
PR_BUSINESS_FAX_NUMBER | Geschäftliche Faxnummer
PR_HOME_FAX_NUMBER | Private Faxnummer
PR_RADIO_TELEPHONE_NUMBER | C-Netz-Telefonnummer
PR_CAPSS | Initialen
PR_LOCATION | Ort, im Format Gebäudenummer/Zimmernummer (z. B. 7/3007 bedeutet Zimmer 3007 in Gebäude 7)
PR_CAR_TELEPHONE_NUMBER | Auto-Telefonnummer

Value String-Datenfeld erforderlich. Die Werte des neuen Adresseintrags. Jedes Element entspricht einem Element im TagID-Datenfeld. Weitere Informationen finden Sie im Beispiel.


Beispiel zur AddAddress-Methode

In diesem Beispiel wird ein Eintrag dem Adressbuch hinzugefügt.

Dim tagIDArray(0 To 3) As String
Dim valueArray(0 To 3) As String
tagIDArray(0) = "PR_DISPLAY_NAME"
tagIDArray(1) = "PR_GIVEN_NAME"
tagIDArray(2) = "PR_SURNAME"
tagIDArray(3) = "PR_COMMENT"
valueArray(0) = "Kim Buhler"
valueArray(1) = "Kim"
valueArray(2) = "Buhler"
valueArray(3) = "This is a comment"
Application.AddAddress TagID:=tagIDArray(), Value:=valueArray()


AddAsk-Methode

Fügt ein ASK-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Bei einer Aktualisierung zeigt ein ASK-Feld ein Dialogfeld an, in dem Sie aufgefordert werden, Text einzugeben, der einer bestimmten Textmarke zugeordnet werden soll.

Syntax

Ausdruck.AddAsk(Range, Name, Prompt, DefaultAskText, AskOnce)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position für das ASK-Feld.

Name String erforderlich. Der Name der Textmarke, der die Antwort oder ein Vorgabetext zugewiesen wird. Verwenden Sie ein REF-Feld mit dem Namen der Textmarke, um das Ergebnis in einem Dokument anzuzeigen.

Prompt Variant optional. Der Text, der im Dialogfeld angezeigt wird.

DefaultAskText Variant optional. Die Standardantwort, die im Textfeld erscheint, wenn das Dialogfeld angezeigt wird. Entspricht dem Schalter \d für ein ASK-Feld.

AskOnce Variant optional. True, wenn das Dialogfeld nur einmal und nicht jedes Mal angezeigt wird, wenn ein neuer Datensatz zusammengeführt wird. Entspricht dem Schalter \o für ein ASK-Feld.


Beispiel zur AddAsk-Methode

In diesem Beispiel wird ein ASK-Feld am Ende des aktiven Seriendruckhauptdokuments hinzugefügt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.MailMerge.Fields.AddAsk Range:=myRange, _
    Prompt:="Type your company name", _
    Name:="company", AskOnce:=True

In diesem Beispiel wird ein ASK-Feld hinter dem letzten Seriendruckfeld in Main.doc hinzugefügt.

Set myMMFields = Documents("Main.doc").MailMerge.Fields
myMMFields(myMMFields.Count).Select
Selection.MoveRight Unit:=wdWord, Count:=1, Extend:=wdMove
myMMFields.AddAsk Range:=Selection.Range, Name:="name", _
    Prompt:="What is your name"


AddCallout-Methode

Erstellt eine Legende mit Linie ohne Rahmen. Gibt ein Shape-Objekt zurück, das die neue Legende darstellt.

Syntax

Ausdruck.AddCallout(Type, Left, Top, Width, Height, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

Type Long erforderlich. Dabei kann es sich um eine der folgenden MsoCalloutType-Konstanten handeln: msoCalloutOne (eine horizontale oder vertikale Legende mit Linie aus einem Segment), msoCalloutTwo (eine Legende mit Linie aus einem Segment, die sich frei drehen lässt), msoCalloutThree (eine Linie aus zwei Segmenten) oder msoCalloutFour (eine Linie aus drei Segmenten).

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der Legende, relativ zur Verankerung.

Width, Height Single erforderlich. Breite und Höhe des Begrenzungsrechtecks der Legende in Punkt.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, an den die Legende gebunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und die Legende relativ zum oberen und linken Blattrand positioniert.

Anmerkungen

Sie können vielfältige Legenden mit der AddShape-Methode einfügen.


Beispiel zur AddCallout-Methode

In diesem Beispiel wird eine Legende einem neu angelegten Dokument hinzugefügt und anschließend 45 Grad als Winkel der Legende festgelegt.

Set myDocument = Documents.Add
Set myCall = myDocument.Shapes.AddCallout(msoCalloutTwo, _
    72, 36, 25, 25)
myCall.Callout.Angle = msoCalloutAngle45


 AddCurve-Methode

AddCurve-Methode

Erstellt eine Bézier-Kurve. Gibt ein Shape-Objekt zurück, das die neue Kurve darstellt.

Syntax

Ausdruck.AddCurve(SafeArrayOfPoints, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

SafeArrayOfPoints Variant erforderlich. Ein Datenfeld mit Koordinatenpaaren, die die Scheitel- und Kontrollpunkte der Kurve festlegen. Als ersten Punkt legen Sie den Startscheitelpunkt und die zwei Kontrollpunkte für das erste Bézier-Segment fest. Anschließend bestimmen Sie für jedes weitere Kurvensegment einen Scheitelpunkt und zwei Kontrollpunkte. Als letztes legen Sie den Endscheitelpunkt der Kurve fest. Beachten Sie, dass Sie immer 3n + 1 Punkte festlegen. Dabei steht n für die Anzahl der Kurvensegmente.

Anchor Variant optional. Ein Range-Objekt, das den Text repräsentiert, an den die Kurve gebunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und die Kurve relativ zum oberen und linken Blattrand positioniert.


Beispiel zur AddCurve-Methode

In diesem Beispiel wird eine Bézier-Kurve mit zwei Segmenten myDoc hinzugefügt und die Kurve mit dem zweiten Absatz verankert.

Dim pts(1 To 7, 1 To 2) As Single
pts(1, 1) = 0
pts(1, 2) = 0
pts(2, 1) = 72
pts(2, 2) = 72
pts(3, 1) = 100
pts(3, 2) = 40
pts(4, 1) = 20
pts(4, 2) = 50
pts(5, 1) = 90
pts(5, 2) = 120
pts(6, 1) = 60
pts(6, 2) = 30
pts(7, 1) = 150
pts(7, 2) = 90
Set myDoc = ActiveDocument
myDoc.Shapes.AddCurve pts, myDoc.Paragraphs(2).Range


AddFillIn-Methode

Fügt ein einem Seriendruck-Hauptdokument ein FILLIN-Feld hinzu. Gibt ein MailMergeField-Objekt zurück. Bei einer Aktualisierung zeigt ein FILLIN-Feld ein Dialogfeld an, in dem Sie aufgefordert werden, Text einzugeben, der im Dokument an der Position des FILLIN-Felds eingefügt wird.

Hinweis Verwenden Sie die Add-Methode mit dem Fields-Auflistungsobjekt, um ein FILLIN-Feld in ein anderes als ein Seriendruck-Hauptdokument einzufügen.

Syntax

Ausdruck.AddFillIn(Range, Prompt, DefaultFillInText, AskOnce)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des FILLIN-Felds.

Prompt Variant optional. Der Text, der im Dialogfeld angezeigt wird.

DefaultFillinText Variant optional. Die Standardantwort, die im Textfeld erscheint, wenn das Dialogfeld angezeigt wird. Entspricht dem Schalter \d für ein FILLIN-Feld.

AskOnce Variant optional. True, wenn die Eingabeaufforderung nur einmal und nicht immer angezeigt wird, wenn ein neuer Datensatz hinzugefügt wird. Entspricht dem Schalter \o für ein FILLIN-Feld. Der Standardwert lautet False.


Beispiel zur AddFillIn-Methode

In diesem Beispiel wird ein FILLIN-Feld hinzugefügt, in dem Sie aufgefordert werden, einen Namen nach "Name:" einzugeben.

With Selection
    .Collapse Direction:=wdCollapseStart
    .InsertAfter "Name: "
    .Collapse Direction:=wdCollapseEnd
End With
ActiveDocument.MailMerge.Fields.AddFillin Range:=Selection.Range, _
    Prompt:="Your name?", DefaultFillInText:="Joe", AskOnce:=True


AddFromFile-Methode

Fügt das angegebene Filialdokument am Anfang der Auswahl in das Zentraldokument ein und liefert ein Subdocument-Objekt.

Hinweis Ein Fehler tritt auf, wenn es sich bei der aktiven Ansicht nicht um die Gliederungs- oder Zentraldokumentansicht handelt.

Syntax

Ausdruck.AddFromFile(Name, ConfirmConversions, ReadOnly, PasswordDocument, PasswordTemplate, Revert, WritePasswordDocument, WritePasswordTemplate)

Ausdruck Erforderlich. Ein Ausdruck, der ein Subdocuments-Objekt zurückgibt.

Name String erforderlich. Der Dateiname des Filialdokuments, das in das Zentraldokument eingefügt wird.

ConfirmConversions Variant optional. True, um die Konvertierung der Datei im Dialogfeld Datei konvertieren zu bestätigen, wenn die Datei ein anderes als das Word-Format hat.

ReadOnly Variant optional. True, um das Filialdokument als schreibgeschütztes Dokument einzufügen.

PasswordDocument Variant optional. Das nötige Kennwort, um ein Filialdokument mit Kennwortschutz zu öffnen.

PasswordTemplate Variant optional. Das nötige Kennwort, um eine mit Kennwortschutz versehene Vorlage zu öffnen, die mit dem Filialdokument verbunden ist.

Revert Variant optional. Bestimmt, was passiert, wenn Name der Dateiname eines offenen Dokuments ist. True, um die gespeicherte Version des Filialdokuments einzufügen. False, um die geöffnete Version des Filialdokuments einzufügen, in der eventuell ungesicherte Änderungen enthalten sind.

WritePasswordDocument Variant optional. Das nötige Kennwort, um Änderungen in einem schreibgeschützten Dokument zu speichern.

WritePasswordTemplate Variant optional. Das nötige Kennwort, um Änderungen an einer schreibgeschützten Vorlage zu speichern, die mit dem Filialdokument verbunden ist.


Beispiel zur AddFromFile-Methode

In diesem Beispiel wird das Filialdokument "Subdoc.doc" in das aktive Dokument eingefügt.

ActiveDocument.ActiveWindow.View.Type = wdMasterView
ActiveDocument.Subdocuments.AddFromFile _
    Name:="C:\MyFolder\Subdoc.doc"

In diesem Beispiel wird das mit Kennwortschutz versehene Filialdokument "MySubdoc.doc" als schreibgeschütztes Dokument in das aktive Dokument eingefügt.

Selection.Range.Subdocuments.AddFromFile Name:="MySubdoc.doc", _
    ReadOnly:=True, PasswordDocument:="MyPassword"


AddFromRange-Methode

Erstellt ein oder mehrere Filialdokumente aus dem Text im angegebenen Bereich und liefert ein SubDocument-Objekt.

Hinweis Der Bereich muss mit einer integrierten Formatvorlage einer Überschriftsebene (z. B. Überschrift 1) beginnen. Filialdokumente werden an jedem Absatz mit demselben Überschriftsformat erstellt. Filialdokumente werden zusammen mit dem Zentraldokument gespeichert und automatisch mit Text aus der ersten Zeile der Datei benannt.

Syntax

Ausdruck.AddFromRange(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Subdocuments-Objekt zurückgibt.

Range Range-Objekt erforderlich. Das Range-Objekt, mit den ein oder mehrere Filialdokumente erstellt werden.


Beispiel zur AddFromRange-Methode

In diesem Beispiel werden ein oder mehrere Filialdokumente aus der Auswahl erstellt.

ActiveDocument.ActiveWindow.View.Type = wdMasterView
ActiveDocument.SubDocuments.AddFromRange Range:=Selection.Range


AddHorizontalLine-Methode

Fügt eine auf einer Grafikdatei basierende horizontale Linie in das aktuelle Dokument ein.

Syntax

Ausdruck.AddHorizontalLine(FileName, Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

FileName String erforderlich. Der Dateiname der Grafik, die Sie für die horizontale Linie verwenden möchten.

Range Variant optional. Der Bereich, über dem Microsoft Word die horizontale Linie einfügt. Wenn dieses Argument weggelassen wird, fügt Word die horizontale Linie über der aktuellen Markierung ein.

Hinweise

Zum Einfügen einer horizontalen Linie, die nicht auf einer vorhandenen Grafikdatei basiert, verwenden Sie die AddHorizontalLineStandard-Methode.


AddHorizontalLineStandard-Methode

Fügt eine horizontale Linie im aktuellen Dokument ein.

Syntax

Ausdruck.AddHorizontalLineStandard(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

Range Variant optional. Der Bereich, über dem Microsoft Word die horizontale Linien einfügt. Wenn dieses Argument weggelassen wird, fügt Word die horizontale Linie über der aktuellen Markierung ein.

Hinweise

Zum Einfügen einer horizontalen Linie, die auf einer bestehenden Grafikdatei basiert, verwenden Sie die AddHorizontalLine-Methode.


Beispiel zur AddHorizontalLineStandard-Methode

Dieses Beispiel fügt eine horizontale Linie über dem fünften Absatz des aktiven Dokuments ein.

ActiveDocument.Paragraphs(5).Range _
    .InlineShapes.AddHorizontalLineStandard


AddIf-Methode

Fügt ein IF-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Bei einer Aktualisierung vergleicht ein IF-Feld ein Feld in einem Datensatz mit einem bestimmten Wert und fügt den geeigneten Text, abhängig vom Vergleichsergebnis, ein.

Syntax

Ausdruck.AddIf(Range, MergeField, Comparison, CompareTo, TrueAutoText, TrueText, FalseAutoText, FalseText)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des IF-Felds.

MergeField String erforderlich. Der Name des Seriendruckfelds.

Comparison Long erforderlich. Der Operator für den Vergleichsausdruck. Dabei kann es sich um eine der folgenden WdMailMergeComparison-Konstanten handeln: wdMergeIfEqual, wdMergeIfGreaterThan, wdMergeIfGreaterThanOrEqual, wdMergeIfIsBlank, wdMergeIfIsNotBlank, wdMergeIfLessThan, wdMergeIfLessThanOrEqual oder wdMergeIfNotEqual.

CompareTo Variant optional. Der Text, der mit dem Inhalt von MergeField verglichen wird.

TrueAutoText Variant optional. Der AutoText-Eintrag, der bei einem übereinstimmenden Vergleich eingefügt wird. Wird dieses Argument angegeben, wird TrueText ignoriert.

TrueText Variant optional. Der Text, der eingefügt wird, wenn der Vergleich übereinstimmt.

FalseAutoText Variant optional. Der AutoText-Eintrag, der bei einem nicht übereinstimmenen Vergleich eingefügt wird. Wird dieses Argument angegeben, wird FalseText ignoriert.

FalseText Variant optional. Der Text, der eingefügt wird, wenn der Vergleich nicht übereinstimmt.


Beispiel zur AddIf-Methode

In diesem Beispiel wird "for your personal use" eingefügt, wenn das Seriendruckfeld Company leer ist, und "for your business", wenn das Seriendruckfeld Company einen Inhalt hat.

ActiveDocument.MailMerge.Fields.AddIf Range:=Selection.Range, _
    MergeField:="Company", Comparison:=wdMergeIfIsBlank, _
    TrueText:="for your personal use", _
    FalseText:="for your business"


AddLabel-Methode

Erstellt ein Etikett. Gibt ein Shape-Objekt zurück, das das neue Etikett darstellt.

Syntax

Ausdruck.AddLabel(Orientation, Left, Top, Width, Height, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

Orientation Long erforderlich. Die Textausrichtung. Dies kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (beispielsweise Deutsch) ab.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Etiketts relativ zur Verankerung.

Width, Height Single erforderlich. Breite und Höhe des Etiketts in Punkt.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, an den das Etikett gebunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt, und das Etikett wird relativ zum oberen und linken Blattrand positioniert.


Beispiel zur AddLabel-Methode

In diesem Beispiel wird ein Etikett mit dem Text "Testetikett" einem neuen Dokument hinzugefügt.

Set myDocument = Documents.Add
Set myLabel = myDocument.Shapes _
    .AddLabel(Orientation:=msoTextOrientationHorizontal, _
    Left:=100, Top:=100, Width:=300, Height:=200)
myLabel.TextFrame.TextRange = "Test Label"


AddLine-Methode

Erstellt eine Linie. Gibt ein Shape-Objekt zurück, das eine neue Linie darstellt.

Syntax

Ausdruck.AddLine(BeginX, BeginY, EndX, EndY, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Startpunkts der Linie, relativ zur Verankerung.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunkts der Linie, relativ zur Verankerung.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, an den die Linie gebunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt, und die Linie wird relativ zum oberen und linken Blattrand positioniert.

Anmerkungen

Um einen Pfeil zu erstellen, formatieren Sie die Linie mit der Line-Eigenschaft.


Beispiel zur AddLine-Methode

In diesem Beispiel wird eine gestrichelte grüne Linie einem neuen Dokument hinzugefügt.

Set myDocument = Documents.Add
Set myLine = myDocument.Shapes.AddLine(100, 100, 60, 20)
With myLine.Line
    .DashStyle = msoLineDash
    .ForeColor.RGB = RGB(0, 128, 0)
End With

In diesem Beispiel wird eine Linie dem aktiven Dokument hinzugefügt und anschließend die Linie als roter Pfeil formatiert.

Set myLine = ActiveDocument.Shapes.AddLine(100, 100, 60, 20)
With myLine.Line
    .BeginArrowheadStyle = msoArrowheadNone
    .EndArrowheadStyle = msoArrowheadTriangle
    .ForeColor.RGB = RGB(128, 0, 0)
End With


AddMergeRec-Methode

Fügt ein MERGEREC-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein MERGEREC-Feld fügt während des Seriendrucks die Nummer des aktuellen Datensatzes ein (die Datensatzposition im aktuellen Abfrageergebnis).

Syntax

Ausdruck.AddMergeRec(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt

Range Erforderliches Range-Objekt. Die Position des MERGEREC-Felds.


Beispiel zur AddMergeRec-Methode

In diesem Beispiel wird Text und ein MERGEREC-Feld zu Beginn des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.MailMerge.Fields.AddMergeRec Range:=myRange
myRange.InsertAfter "Record Number: "


AddMergeSeq-Methode

Fügt ein MERGESEQ-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein MERGESEQ-Feld fügt eine Nummer ein basierend auf der Reihenfolge, in der Datensätze eingefügt werden (z. B. wenn Satz 50 der Sätze 50 bis 100 eingefügt wird, fügt MERGESEQ die Nummer 1 ein).

Syntax

Ausdruck.AddMergeSeq(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des MERGESEQ-Felds.


Beispiel zur AddMergeSeq-Methode

In diesem Beispiel wird Text und ein MERGESEQ-Feld am Ende des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.MailMerge.Fields.AddMergeSeq Range:=myRange
myRange.InsertAfter "Sequence Number: "


AddNewFrame-Methode

Fügt einer Framesseite einen neuen Frame hinzu.

Syntax

Ausdruck.AddNewFrame(Where)

Ausdruck Erforderlich. Ein Ausdruck, der ein Frameset-Objekt zurückgibt.

Where Long erforderlich. Legt fest, an welcher Stelle der neue Frame relativ zum angegebenen Frame eingefügt werden soll. Dies kann eine der folgenden WdFramesetNewFrameLocation-Konstanten sein: wdFramesetNewFrameAbove, wdFramesetNewFrameBelow, wdFramesetNewFrameLeft oder wdFramesetNewFrameRight.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur AddNewFrame-Methode

In diesem Beispiel wird ein neuer Frame unmittelbar rechts neben dem angegebenen Frame eingefügt.

ActiveDocument.ActiveWindow.ActivePane.Frameset _
    .AddNewFrame wdFramesetNewFrameRight


AddNext-Methode

Fügt ein NEXT-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein NEXT-Feld springt auf den nächsten Datensatz, damit Daten aus mehr als einem Satz im selben Dokument zusammengeführt werden können (z. B. ein Bogen mit Adressaufklebern).

Syntax

Ausdruck.AddNext(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des NEXT-Felds.


AddNextIf-Methode

Fügt ein NEXTIF-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein NEXTIF-Feld vergleicht zwei Ausdrücke, und wenn das Ergebnis des Vergleichs wahr ist, wird der nächste Datensatz mit dem aktuellen Seriendruckdokument zusammengeführt.

Syntax

Ausdruck.AddNextIf(Range, MergeField, Comparison, CompareTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des NEXTIF-Felds.

MergeField String erforderlich. Der Name des Seriendruckfelds.

Comparison Long erforderlich. Der Operator für den Vergleichsausdruck. Dabei kann es sich um eine der folgenden WdMailMergeComparison-Konstanten handeln: wdMergeIfEqual, wdMergeIfGreaterThan, wdMergeIfGreaterThanOrEqual, wdMergeIfIsBlank, wdMergeIfIsNotBlank, wdMergeIfLessThan, wdMergeIfLessThanOrEqual oder wdMergeIfNotEqual.

CompareTo String erforderlich. Der Text, der mit dem Inhalt von MergeField verglichen wird.


Beispiel zur AddNextIf-Methode

In diesem Beispiel wird ein NEXTIF-Feld vor dem ersten MERGEFIELD-Feld in die Datei Main.doc eingefügt. Wenn die nächste Postleitzahl gleich 98004 ist, wird der nächste Datensatz mit dem aktuellen Seriendruckdokument zusammengeführt.

Documents("Main.doc").MailMerge.Fields(1).Select
Selection.Collapse Direction:=wdCollapseStart
Documents("Main.doc").MailMerge.Fields.AddNextIf _
    Range:=Selection.Range, MergeField:="PostalCode", _
    Comparison:=wdMergeIfEqual, CompareTo:="98004"


AddNodes-Methode

Fügt am Ende der Freihandfigur, die gerade erstellt wird, ein neues Segment hinzu sowie die Knoten, die das Segment definieren. Sie können diese Methode anwenden, so oft Sie wollen, wenn Sie Knoten zur Freihandfigur hinzufügen wollen, die Sie gerade erstellen. Wenn Sie mit dem Hinzufügen von Knoten fertig sind, verwenden Sie die ConvertToShape-Methode zum Erstellen der Freihandfigur, die Sie soeben definiert haben. Wenn Sie Knoten einer Freihandfigur hinzufügen wollen, nachdem sie erstellt wurde, verwenden Sie die Insert-Methode der ShapeNodes-Auflistung.

Syntax

Ausdruck.AddNodes(SegmentType, EditingType, X1, Y1, X2, Y2, X3, Y3)

Ausdruck Erforderlich. Ein Ausdruck, der ein FreeformBuilder-Objekt zurückgibt.

SegmentType Long erforderlich. Der Segmenttyp, der hinzugefügt werden soll. Dies kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.

EditingType Long erforderlich. Die Editing-Eigenschaft des Scheitelpunkts. Dies kann eine der beiden folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (kann nicht msoEditingSmooth oder msoEditingSymmetric sein). Wenn SegmentType msoSegmentLine ist, muss EditingType msoEditingAuto sein.

X1 Single erforderlich. Wenn EditingType des neuen Segments msoEditingAuto ist, spezifiziert dieses Argument den horizontalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum Endpunkt des neuen Segments. Wenn EditingType des neuen Knotens msoEditingCorner ist, spezifiziert dieses Argument den horizontalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum ersten Kontrollpunkt für das neue Segment.

Y1 Single erforderlich. Wenn EditingType des neuen Segments msoEditingAuto ist, spezifiziert dieses Argument den vertikalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum Endpunkt des neuen Segments. Wenn EditingType des neuen Knotens msoEditingCorner ist, spezifiziert dieses Argument den vertikalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum ersten Kontrollpunkt für das neue Segment.

X2 Single optional. Wenn EditingType des neuen Segments msoEditingCorner ist, spezifiziert dieses Argument den horizontalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum zweiten Kontrollpunkt für das neue Segment. Wenn EditingType des neuen Segments msoEditingAuto ist, geben Sie keinen Wert für dieses Argument an.

Y2 Single optional. Wenn EditingType des neuen Segments msoEditingCorner ist, spezifiziert dieses Argument den vertikalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum zweiten Kontrollpunkt für das neue Segment. Wenn EditingType des neuen Segments msoEditingAuto ist, geben Sie keinen Wert für dieses Argument an.

X3 Single optional. Wenn EditingType des neuen Segments msoEditingCorner ist, spezifiziert dieses Argument den horizontalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum Endpunkt des neuen Segments. Wenn EditingType des neuen Segments msoEditingAuto ist, geben Sie keinen Wert für dieses Argument an.

Y3 Single optional. Wenn EditingType des neuen Segments msoEditingCorner ist, spezifiziert dieses Argument den vertikalen Abstand (in Punkt) der linken oberen Ecke des Dokuments zum Endpunkt des neuen Segments. Wenn EditingType des neuen Segments msoEditingAuto ist, geben Sie keinen Wert für dieses Argument an.


Beispiel zur AddNodes-Methode

In diesem Beispiel wird eine Freihandfigur mit fünf Scheitelpunkten zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


AddOLEControl-Methode

Shapes-Objekt: Erstellt ein ActiveX-Steuerelement. Gibt das Shape-Objekt zurück, das das neue ActiveX-Steuerelement darstellt.

InlineShapes-Objekt: Erstellt ein ActiveX-Steuerelement. Gibt das InlineShape-Objekt zurück, das das neue ActiveX-Steuerelement darstellt.

Syntax 1

Ausdruck.AddOLEControl(ClassType, Left, Top, Width, Height, Anchor)

Syntax 2

Ausdruck.AddOLEControl(ClassType, Range)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

ClassType String optional. Der lange OLE-Klassenname oder der programmtechnische Bezeichner für das ActiveX-Steuerelement, das erstellt werden soll.

Informationen über verfügbare Klassentypen finden Sie unter Programmtechnische OLE-Bezeichner

Left, Top Variant optional. Die Position (in Punkt) der linken, oberen Ecke des neuen Objekts relativ zum Verankerungspunkt.

Width, Height Variant optional. Die Breite und Höhe des ActiveX-Steuerelements, in Punkt.

Anchor Variant optional. Der Bereich, in dem das ActiveX-Steuerelement eingebunden ist. Wenn Anchor angegeben wird, wird der Verankerungspunkt am Anfang des ersten Absatzes im Verankerungsbereich positioniert. Lässt man dieses Argument weg, wird der Verankerungspunkt aber automatisch platziert, und das ActiveX-Steuerelement wird relativ zur oberen und linken Kante der Seite positioniert.

Range Variant optional. Der Bereich, in dem das ActiveX-Steuerelement im Text platziert wird. Das ActiveX-Steuerelement ersetzt den Bereich, wenn dieser nicht reduziert ist. Lässt man dieses Argument weg, wird das ActiveX-Steuerelement automatisch platziert.

Anmerkungen

ActiveX-Steuerelemente werden in Word als Shape-Objekte oder InlineShape-Objekte dargestellt. Wenn Sie die Eigenschaften für ein ActiveX-Steuerelement modifizieren wollen, verwenden Sie die Object-Eigenschaft des OLEFormat-Objekts für die angegebene Form oder die zeilenfixierte Form.


Beispiel zur AddOLEControl-Methode

In diesem Beispiel wird dem aktiven Dokument ein Kontrollkästchen hinzugefügt.

ActiveDocument.Shapes.AddOLEControl ClassType:="Forms.CheckBox.1"

In diesem Beispiel wird dem aktiven Dokument ein Kombinationsfeld hinzugefügt.

ActiveDocument.Shapes.AddOLEControl ClassType:="Forms.ComboBox.1"

In diesem Beispiel wird dem aktiven Dokument ein Kontrollkästchen hinzugefügt, dessen Markierung entfernt und dann eine Beschriftung für das Kontrollkästchen hinzugefügt.

Set myCB = ActiveDocument.Shapes _
    .AddOLEControl(ClassType:="Forms.CheckBox.1")
With myCB.OLEFormat.Object
    .Value = False
    .Caption = "Check if over 21"
End With


AddOLEObject-Methode

Shapes-Objekt: Erstellt ein OLE-Objekt. Gibt das Shape-Objekt zurück, das das neue OLE-Objekt darstellt.

InlineShapes-Objekt: Erstellt ein OLE-Objekt. Gibt das InlineShape-Objekt zurück, das das neue OLE-Objekt darstellt.

Syntax 1

Ausdruck.AddOLEObject(ClassType, FileName, LinkToFile, DisplayAsIcon, IconFileName, IconIndex, IconLabel, Left, Top, Width, Height, Anchor)

Syntax 2

Ausdruck.AddOLEObject(ClassType, FileName, LinkToFile, DisplayAsIcon, IconFileName, IconIndex, IconLabel, Range)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

ClassType String optional. Der Name der Anwendung, die zum Aktivieren des angegebenen OLE-Objekts verwendet wird. Sie können eine Liste der verfügbaren Anwendungen im Feld Objekttyp auf der Registerkarte Neu erstellen im Dialogfeld Objekt (Menü Einfügen) sehen. Die Zeichenfolge ClassType können Sie finden, indem Sie ein Objekt als zeilenfixierte Form einfügen und sich dann die Feldfunktionen ansehen. Der Klassentyp des Objekts steht entweder nach dem Wort "EMBED" oder dem Wort "LINK". Sie müssen für das Objekt eines der Argumente ClassType oder FileName angeben, aber nicht beide.

Informationen über verfügbare Klassentypen finden Sie unter Programmtechnische OLE-Bezeichner.

FileName Variant optional. Die Datei, von der das Objekt erstellt werden soll. Wenn dieses Argument weggelassen wird, wird der aktuelle Ordner verwendet. Sie müssen für das Objekt entweder das Argument ClassType oder FileName angeben, aber nicht beide.

LinkToFile Variant optional. True, wenn das OLE-Objekt mit der Datei verknüpft werden soll, von der es erstellt wurde. False, wenn das OLE-Objekt eine unabhängige Kopie der Datei werden soll. Wenn Sie für ClassType einen Wert angegeben haben, muss das Argument LinkToFile False sein. Der Standardwert ist False.

DisplayAsIcon Variant optional. True, wenn das OLE-Objekt als Symbol angezeigt werden soll. Der Standardwert ist False.

IconFileName Variant optional. Die Datei, die das Symbol enthält, das angezeigt werden soll.

IconIndex Variant optional. Die Indexnummer des Symbols innerhalb von IconFileName. Die Reihenfolge der Symbole in der angegebenen Datei entspricht der Reihenfolge, in der die Symbole im Dialogfeld Anderes Symbol (Menü Einfügen, Dialogfeld Objekt) erscheinen, wenn das Kontrollkästchen Als Symbol markiert ist. Das erste Symbol in der Datei hat die Indexnummer 0 (Null). Wenn in IconFileName kein Symbol mit der vorgegebenen Indexnummer vorhanden ist, wird das Symbol mit der Indexnummer 1 (das zweite Symbol in der Datei) verwendet. Der Standardwert ist 0 (Null).

IconLabel Variant optional. Eine Bezeichnung (Beschriftung), die unter dem Symbol angezeigt werden soll.

Left, Top Variant optional. Die Position (in Punkt) der linken, oberen Ecke des neuen Objekts relativ zum Verankerungspunkt.

Width, Height Variant optional. Die Breite und Höhe des OLE-Objekts, in Punkt.

Anchor Variant optional. Der Bereich, in dem das OLE-Objekt eingebunden ist. Wenn Anchor angegeben wurde, wird der Verankerungspunkt am Anfang des ersten Absatzes im Verankerungsbereich positioniert. Wenn Anchor nicht angegeben wurde, wird der Verankerungspunkt automatisch platziert, und das OLE-Objekt wird relativ zur oberen und linken Kante der Seite positioniert.

Range Variant optional. Der Bereich, in dem das OLE-Objekt im Text platziert wird. Das OLE-Objekt ersetzt den Bereich, wenn dieser nicht reduziert ist. Wenn dieses Argument weggelassen wird, wird das Objekt automatisch platziert.


Beispiel zur AddOLEObject-Methode

In diesem Beispiel wird dem aktiven Dokument ein neues bewegliches Bitmap-Bild hinzugefügt. Das Bitmap-Bild wird mit einer anderen Datei verknüpft.

ActiveDocument.Shapes.AddOLEObject _
    FileName:="c:\my documents\MyDrawing.bmp", _
    LinkToFile:=True

In diesem Beispiel wird dem Dokument eine neue Microsoft Excel-Tabelle hinzugefügt. Die Tabelle ersetzt den zweiten Absatz.

ActiveDocument.InlineShapes.AddOLEObject _
    ClassType:="Excel.Sheet", DisplayAsIcon:=False, _
    Range:=ActiveDocument.Paragraphs(2).Range


AddPicture-Methode

Shapes-Objekt: Erstellt eine Grafik aus einer vorhandenen Datei. Gibt das Shape-Objekt zurück, das die neue Grafik darstellt.

InlineShapes-Objekt: Erstellt eine Grafik aus einer vorhandenen Datei. Gibt das InlineShape-Objekt zurück, das die neue Grafik darstellt.

Syntax 1

Ausdruck.AddPicture(FileName, LinkToFile, SaveWithDocument, Left, Top, Width, Height, Anchor)

Syntax 2

Ausdruck.AddPicture(FileName, LinkToFile, SaveWithDocument, Range)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

FileName String erforderlich. Die Datei, von der aus das Objekt erstellt werden soll. Wenn dieses Argument weggelassen wird, wird der aktuelle Ordner verwendet.

LinkToFile Variant optional. True, wenn die Grafik mit der Datei verknüpft werden soll, aus der sie erstellt wurde. False, wenn die Grafik eine unabhängige Kopie der Datei werden soll. Der Standardwert ist False.

SaveWithDocument Variant optional. True, wenn die verknüpfte Grafik mit dem Dokument gespeichert werden soll. Der Standardwert ist False.

Left, Top Variant optional. Die Position (in Punkt) der linken, oberen Ecke der neuen Grafik relativ zum Verankerungspunkt.

Width, Height Variant optional. Die Breite und Höhe der Grafik, in Punkt.

Anchor Variant optional. Der Bereich, in den die Grafik eingebunden wird. Wenn Anchor angegeben wird, wird der Verankerungspunkt am Anfang des ersten Absatzes im Verankerungsbereich positioniert. Lässt man dieses Argument weg, wird der Verankerungspunkt aber automatisch platziert, und die Grafik wird relativ zur oberen und linken Kante der Seite positioniert.

Range Variant optional. Der Bereich, in dem die Grafik im Text platziert wird. Die Grafik ersetzt den Bereich, wenn dieser nicht reduziert ist. Lässt man dieses Argument weg, wird die Grafik automatisch platziert.


AddPictureBullet-Methode

Fügt ein Bildaufzählungszeichen, das auf einer Grafikdatei basiert, in das aktuelle Dokument ein.

Syntax

Ausdruck.AddPictureBullet(FileName, Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

FileName String erforderlich. Der Dateiname der Grafik, die Sie für das Bildaufzählungszeichen verwenden möchten.

Range Variant optional. Der Bereich, in dem Microsoft Word das Bildaufzählungszeichen einfügt. Word fügt das Bildaufzählungszeichen jedem Absatz im Bereich hinzu. Wird dieses Argument weggelassen, fügt Word das Bildaufzählungszeichen zu jedem Absatz in der aktuellen Markierung hinzu.


Beispiel zur AddPictureBullet-Methode

Dieses Beispiel fügt jedem Absatz im markierten Text ein Bildaufzählungszeichen hinzu und verwendet hierzu eine Datei mit dem Namen RedBullet.gif.

Selection.InlineShapes.AddPictureBullet _
    "C:\My Documents\RedBullet.gif"


 AddPolyline-Methode

AddPolyline-Methode

Erstellt einen offenen Polygonzug oder ein geschlossenes Vieleck. Gibt ein Shape-Objekt zurück, das den neuen Polygonzug oder das Vieleck darstellt.

Syntax

Ausdruck.AddPolyline(SafeArrayOfPoints, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

SafeArrayOfPoints Variant erforderlich. Ein Datenfeld mit Koordinatenpaaren, die die Scheitelpunkte der Polygonzeichnung festlegen.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, an den der Polygonzug gebunden ist. Wenn Anchor angegeben ist, wird der Anker am Anfang des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument weggelassen, wird der Verankerungsbereich automatisch ausgewählt, und der Polygonzug wird relativ zum oberen und linken Rand der Seite positioniert.

Anmerkungen

Sie erstellen ein geschlossenes Vieleck, indem Sie dieselben Koordinaten dem ersten und letzten Scheitelpunkt einer Polygonzeichnung zuweisen.


Beispiel zur AddPolyline-Methode

In diesem Beispiel wird ein Dreieck myDocument hinzugefügt. Weil die Koordinaten des ersten und letzten Punkts des Dreiecks identisch sind, ist das Polygon geschlossen und gefüllt.

Dim triArray(1 To 4, 1 To 2) As Single
triArray(1, 1) = 25
triArray(1, 2) = 100
triArray(2, 1) = 100
triArray(2, 2) = 150
triArray(3, 1) = 150
triArray(3, 2) = 50
triArray(4, 1) = 25     ' Last point has same coordinates as first
triArray(4, 2) = 100
Set myDocument = Documents.Add
myDocument.Shapes.AddPolyline triArray


AddRecipient-Methode

Fügt einen Empfängernamen der angegebenen Verteilerliste hinzu.

Hinweis Wenn sich der Empfängername nicht im globalen Adressbuch befindet, tritt ein Fehler auf.

Syntax

Ausdruck.AddRecipient(Recipient)

Ausdruck Erforderlich. Ein Ausdruck, der ein RoutingSlip-Objekt zurückgibt.

Recipient String erforderlich. Der Empfängername.


Beispiel zur AddRecipient-Methode

In diesem Beispiel wird das aktive Dokument an zwei Empfänger nacheinander weitergeleitet.

ActiveDocument.HasRoutingSlip = True
With ActiveDocument.RoutingSlip
    .Subject = "Status Document"
    .AddRecipient Recipient:="Tim O' Brien"
    .AddRecipient Recipient:="Karin Gallagher"
    .Delivery = wdOneAfterAnother
End With
ActiveDocument.Route


AddRichText-Methode

Legt einen formatierten AutoKorrektur-Eintrag an, in dem alle Textattribute des bestimmten Bereichs bewahrt werden. Gibt ein AutoCorrectEntry-Objekt zurück. Die RichText-Eigenschaft für Einträge, die mit dieser Methode hinzugefügt wurden, gibt True zurück. Wenn AddRichText nicht verwendet wird, dann entsprechen eingefügte AutoCorrect-Einträge der aktuell verwendeten Formatvorlage.

Syntax

Ausdruck.AddRichText(Name, Bereich)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrectEntries-Objekt zurückgibt.

Name Erforderliche Zeichenfolge. Der Text, der automatisch durch Bereich ersetzt wird.

Bereich Erforderliches Range-Objekt. Der formatierte Text, den Word automatisch bei der Eingabe von Name einfügt.


Beispiel zur AddRichText-Methode

In diesem Beispiel wird der markierte Text als formatierter AutoKorrektur-Eintrag gespeichert, der immer bei der Eingabe von "NewText" eingefügt wird.

'checks for text selected
If Selection.Type = wdSelectionNormal Then
    AutoCorrect.Entries.AddRichText "NewText", Selection.Range
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird das dritte Wort im aktiven Dokument als ein formatierter AutoKorrektur-Eintrag gespeichert, der immer bei der Eingabe von "NewText" automatisch eingefügt wird.

AutoCorrect.Entries.AddRichText "NewText", ActiveDocument.Words(3)


AddSet-Methode

Fügt ein SET-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein SET-Feld definiert den Text der angegebenen Textmarke.

Syntax

Ausdruck.AddSet(Range, Name, ValueText, ValueAutoText)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des SET-Felds.

Name String erforderlich. Der Name der Textmarke, der ValueText zugeordnet wurde.

ValueText Variant optional. Der Text, der der Textmarke zugeordnet wurde, die mit dem Argument Name festgelegt wurde.

ValueAutoText Variant optional. Der AutoText-Eintrag mit dem Text, der der Textmarke zugeordnet wurde, die mit dem Argument Name festgelegt wurde. Bei Angabe dieses Arguments, wird ValueText ignoriert.


Beispiel zur AddSet-Methode

In diesem Beispiel wird ein SET-Feld zu Beginn des aktiven Dokuments hinzugefügt, dann ein REF-Feld eingefügt, um den Text nach der Auswahl anzuzeigen.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.MailMerge.Fields.AddSet Range:=myRange, _
    Name:="Name", ValueText:="Joe Smith"
Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Fields.Add Range:=Selection.Range, _
    Type:=wdFieldRef, Text:="Name"


AddShape-Methode

Erstellt eine AutoForm. Gibt ein Shape-Objekt zurück, das die neue AutoForm darstellt.

Syntax

Ausdruck.AddShape(Type, Left, Top, Width, Height, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

Type Long erforderlich. Der Typ der AutoForm, die erstellt wird. Dabei kann es sich um eine beliebige MsoAutoShapeType-Konstante handeln.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der AutoForm, relativ zur Verankerung.

Width, Height Single erforderlich. Die Breite und Höhe des Begrenzungsrechtecks der AutoForm in Punkt.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, an den die AutoForm gebunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und die AutoForm relativ zum oberen und linken Blattrand positioniert.

Anmerkungen

Um den Typ der hinzugefügten AutoForm zu ändern, legen Sie die AutoShapeType-Eigenschaft fest.


Beispiel zur AddShape-Methode

In diesem Beispiel wird ein Rechteck einem neuen Dokument hinzugefügt.

Set myDocument = Documents.Add
myDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200


AddSkipIf-Methode

Fügt ein SKIPIF-Feld in ein Seriendruck-Hauptdokument ein. Gibt ein MailMergeField-Objekt zurück. Ein SKIPIF-Feld vergleicht zwei Ausdrücke, und wenn das Ergebnis des Vergleichs True lautet, verschiebt SKIPIF den nächsten Datensatz in der Datenquelle und startet ein neues Dokument.

Syntax

Ausdruck.AddSkipIf(Range, MergeField, Comparison, CompareTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Erforderliches Range-Objekt. Die Position des SKIPIF-Felds.

MergeField String erforderlich. Der Name des Seriendruckfelds.

Comparison Long erforderlich. Der Operator für den Vergleichsausdruck. Dabei kann es sich um eine der folgenden WdMailMergeComparison-Konstanten handeln: wdMergeIfEqual, wdMergeIfGreaterThan, wdMergeIfGreaterThanOrEqual, wdMergeIfIsBlank, wdMergeIfIsNotBlank, wdMergeIfLessThan, wdMergeIfLessThanOrEqual oder wdMergeIfNotEqual.

CompareTo Variant optional. Der Text, der mit dem Inhalt von MergeField verglichen wird.


Beispiel zur AddSkipIf-Methode

In diesem Beispiel wird ein SKIPIF-Feld vor dem ersten MERGEFIELD-Feld in die Datei Main.doc eingefügt. Wenn die nächste Postleitzahl gleich 98040 ist, wird der nächste Datensatz übersprungen.

Documents("Main.doc").MailMerge.Fields(1).Select
Selection.Collapse Direction:=wdCollapseStart
Documents("Main.doc").MailMerge.Fields.AddSkipIf _
    Range:=Selection.Range, MergeField:="PostalCode", _
    Comparison:=wdMergeIfEqual, CompareTo:="98040"


AddTextbox-Methode

Erstellt ein Textfeld. Gibt ein Shape-Objekt zurück, das das neue Textfeld darstellt.

Syntax

Ausdruck.AddTextbox(Orientation, Left, Top, Width, Height, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

Orientation Long erforderlich. Die Textausrichtung. Dies kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (beispielsweise Deutsch) ab.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Textfelds relativ zur Verankerung.

Width, Height Single erforderlich. Höhe und Breite des Textfelds in Punkt.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, mit dem das Textfeld verbunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und das Textfeld relativ zum oberen und linken Blattrand positioniert.


Beispiel zur AddTextbox-Methode

In diesem Beispiel wird ein Textfeld mit dem Text "Testfeld" einem neuen Dokument hinzugefügt.

Set myDocument = Documents.Add
Set myTBox = myDocument.Shapes _
    .AddTextBox(Orientation:=msoTextOrientationHorizontal, _
    Left:=100, Top:=100, Width:=300, Height:=200)
myTBox.TextFrame.TextRange = "Test Box"


AddTextEffect-Methode

Erstellt ein WordArt-Objekt. Gibt ein Shape-Objekt zurück, das ein neues WordArt-Objekt darstellt.

Syntax

Ausdruck.AddTextEffect(PresetTextEffect, Text, FontName, FontSize, FontBold, FontItalic, Left, Top, Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der eine Shapes-Auflistung zurückgibt.

PresetTextEffect Long erforderlich. Ein vorgegebener Texteffekt. Dabei kann es sich um eine der folgenden MsoPresetTextEffect-Konstanten handeln.

msoTextEffect1

msoTextEffect2

msoTextEffect3

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

 msoTextEffect16

msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect20

msoTextEffect21

msoTextEffect22

msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect30

Die Werte dieser Konstanten entsprechen den Formaten, die im Dialogfeld WordArt-Katalog aufgeführt werden (von links nach rechts und von oben nach unten nummeriert).

Text String erforderlich. Der Text in der WordArt-Form.

FontName String erforderlich. Der Name der Schriftart für die WordArt-Form.

FontSize Single erforderlich. Die Größe (in Punkt) der Schriftart für die WordArt-Form.

FontBold Long erforderlich. True, um die Formatierung Fett für die Schriftart der WordArt-Form festzulegen.

FontItalic Long erforderlich. True, um die Formatierung Kursiv für die Schriftart der WordArt-Form festzulegen.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der WordArt-Form relativ zur Verankerung

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, mit dem die WordArt-Form verbunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und die WordArt-Form relativ zum oberen und linken Blattrand positioniert.

Anmerkungen

Wenn Sie WordArt einem Dokument hinzufügen, hängt die Höhe und Breite der WordArt von der Textmenge ab, die Sie angeben.


Beispiel zur AddTextEffect-Methode

In diesem Beispiel wird eine WordArt-Form mit dem Text "Test" dem aktiven Dokument hinzugefügt und mit dem zweiten Absatz verankert.

ActiveDocument.Shapes.AddTextEffect _
    PresetTextEffect:=msoTextEffect11, _
    Text:="Test Text", _
    FontName:="Arial Black", _
    FontSize:=36, _
    FontBold:=True, _
    FontItalic:=False, _
    Left:=InchesToPoints(1), _
    Top:=InchesToPoints(1), _
    Anchor:=ActiveDocument.Paragraphs(2).Range


AddToFavorites-Methode

Erstellt eine Verknüpfung mit dem Dokument oder Hyperlink und fügt sie zu dem Favoriten-Ordner hinzu.

Syntax

Ausdruck.AddToFavorites

Ausdruck Erforderlich. Ein Ausdruck, der ein Document- oder Hyperlink-Objekt zurückgibt.


Beispiel zur AddToFavorites-Methode

In diesem Beispiel wird im aktiven Dokument für jeden Hyperlink einen Shortcut erstellt und dem Ordner Favoriten hinzugefügt.

For Each myHyperlink In ActiveDocument.Hyperlinks
    myHyperlink.AddToFavorites
Next myHyperlink

In diesem Beispiel wird ein Shortcut zu Sales.doc erstellt und dem Ordner Favoriten hinzugefügt. Wenn in diesem Beispiel "Sales.doc" momentan nicht geöffnet ist, wird das Dokument im Ordner C:\Documents geöffnet.

For Each doc in Documents
    If LCase(doc.Name) = "sales.doc" Then isOpen = True
Next doc
If isOpen <> True Then Documents.Open _
    FileName:="C:\Documents\Sales.doc"
Documents("Sales.doc").AddToFavorites


After-Methode

Gibt das nächste TabStop-Objekt rechts von Position zurück.

Syntax

Ausdruck.After(Position)

Ausdruck Erforderlich. Ein Ausdruck, der eine TabStops-Auflistung zurückgibt.

Position Single erforderlich. Gibt eine Stelle auf dem Lineal an, in Punkt.


Beispiel zur After-Methode

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments die Ausrichtung des ersten benutzerdefinierten Tabstopps, der mehr als 1 Zoll vom linken Seitenrand entfernt ist, geändert.

Set ts = ActiveDocument.Paragraphs(1).TabStops _
    .After(InchesToPoints(1))
ts.Alignment = wdAlignTabCenter


Align-Methode

Richtet die Formen im angegebenen Bereich von Formen aus.

Syntax

Ausdruck.Align(AlignCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

AlignCmd Long erforderlich. Gibt die Art an, wie die Formen im angegebenen Formbereich ausgerichtet werden sollen. Dies kann eine der folgenden MsoAlignCmd-Konstanten sein: msoAlignBottoms, msoAlignCenters, msoAlignLefts, msoAlignMiddles, msoAlignRights oder msoAlignTops.

RelativeTo Long erforderlich. True, wenn Formen relativ zur Kante des Dokuments ausgerichtet werden sollen. False, wenn Formen relativ zueinander ausgerichtet werden sollen.


Beispiel zur Align-Methode

In diesem Beispiel werden in myDocument die linken Kanten aller Formen in der Formenauswahl an der linken Kante der Form ausgerichtet, die sich im Bereich am weitesten links befindet.

Set myShapeRange = Selection.ShapeRange
myShapeRange.Align msoAlignLefts, False


AppendToSpike-Methode

Löscht den angegebenen Bereich und nimmt den Inhalt des Bereichs in die Sammlung auf (einem integrierten AutoText-Eintrag). Diese Methode gibt die Sammlung als ein AutoTextEntry-Objekt zurück.

Syntax

Ausdruck.AppendToSpike(Bereich)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoTextEntries-Objekt zurückgibt.

Bereich Erforderliches Range-Objekt. Der Bereich, der gelöscht und an die Sammlung angehängt wird.

Hinweise

Die AppendToSpike-Methode ist nur für die AutoTextEntries-Auflistung in der Dokumentvorlage Normal gültig.


Beispiel zur AppendToSpike-Methode

In diesem Beispiel wird die Markierung gelöscht und der Inhalt der Sammlung in der Dokumentvorlage Normal angehängt.

If Len(Selection.Range.Text) > 1 Then
    NormalTemplate.AutoTextEntries.AppendToSpike _
        Range:=Selection.Range
End If

In diesem Beispiel wird die Sammlung gelöscht. Das erste und dritte Wort im aktiven Dokument wird an die Sammlung der Dokumentvorlage Normal angehängt. Der Inhalt der Sammlung wird daraufhin an der Einfügemarke eingefügt.

Dim atEntry As AutoTextEntry
Selection.Collapse Direction:=wdCollapseStart
For Each atEntry In NormalTemplate.AutoTextEntries
    If atEntry.Name = "Spike" Then atEntry.Delete
Next atEntry
With NormalTemplate.AutoTextEntries
    .AppendToSpike Range:=ActiveDocument.Words(3)
    .AppendToSpike Range:=ActiveDocument.Words(1)
    .Item("Spike").Insert Where:=Selection.Range
End With


Apply-Methode

AutoCorrectEntry-Objekt: Ersetzt einen Bereich durch den Wert eines bestimmten AutoKorrektur-Eintrages.

Shape oder ShapeRange-Objekt: Weist eine bestimmte Formatierung einer Form zu, die mit der PickUp-Methode kopiert wurde.

Syntax 1

Ausdruck.Apply(Range)

Syntax 2

Ausdruck.Apply

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrectEntry-Objekt (Syntax 1) oder ein Shape- oder ShapeRange-Objekt (Syntax 2) zurückgibt.

Range Range-Objekt erforderlich. Der Bereich, der durch den AutoKorrektur-Eintrag ersetzt wird.

Anmerkungen

Wenn Sie die Formatierung des Shape- oder ShapeRange-Objekts nicht zuvor mit der PickUp-Methode kopiert haben, wird ein Fehler bei der Benutzung der Apply-Methode erzeugt.


ApplyBulletDefault-Methode

Versieht die Absätze im Bereich des angegebenen ListFormat-Objekts mit Aufzählungszeichen und Formatierungen. Wurden die Absätze bereits mit Aufzählungszeichen formatiert, entfernt diese Methode die Aufzählungszeichen und die Formatierung.

Syntax

Ausdruck.ApplyBulletDefault(DefaultListBehavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListFormat-Objekt zurückgibt.

DefaultListBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word neue, weborientierte Formatierungen für eine bessere Listenanzeige verwendet. Dabei kann es sich um eine der folgenden Konstanten handeln: wdWord8ListBehavior (Verwenden von Microsoft Word 97-kompatiblen Formatierungen) oder wdWord9ListBehavior (Verwenden von weborientierten Formatierungen). Aus Kompatibilitätsgründen ist die Standardkonstante wdWord8ListBehavior. Bei neuen Prozeduren sollten Sie jedoch wdWord9ListBehavior verwenden, um die Vorteile der verbesserten, weborientierten Formatierungen bei Einzügen und Listen mit mehreren Ebenen nutzen zu können.


Beispiel zur ApplyBulletDefault-Methode

In diesem Beispiel werden die Absätze in der Auswahl mit Aufzählungszeichen und Formatierung versehen. Wenn bereits Aufzählungszeichen in der Auswahl vorhanden sind, werden in diesem Beispiel die Aufzählungszeichen und die Formatierung entfernt.

Selection.Range.ListFormat.ApplyBulletDefault

In diesem Beispiel wird der zweite Absatz in MyDoc.doc entweder mit einem Aufzählungszeichen und Formatierung versehen oder ein Aufzählungszeichen und Formatierung entfernt.

Documents("MyDoc.doc").Paragraphs(2).Range.ListFormat _
    .ApplyBulletDefault

In diesem Beispiel wird die Variable myRange auf einen Bereich mit den Absätzen drei bis sechs des aktiven Dokuments gesetzt, und überprüft, ob der Bereich eine Listenformatierung enthält. Wird keine Listenformatierung gefunden, werden Standardaufzählungszeichen hinzugefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range( _
    Start:= myDoc.Paragraphs(3).Range.Start, _
    End:=myDoc.Paragraphs(6).Range.End)
If myRange.ListFormat.ListType = wdListNoNumbering Then
    myRange.ListFormat.ApplyBulletDefault
End If


ApplyListTemplate-Methode

Weist dem angegebenen List- oder ListFormat-Objekt mehrere Listenformatierungs-Charakteristika zu.

Syntax 1

Ausdruck.ApplyListTemplate(ListTemplate, ContinuePreviousList, DefaultListBehavior)

Syntax 2

Ausdruck.ApplyListTemplate(ListTemplate, ContinuePreviousList, ApplyToDefaultListBehavior)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein List-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein ListFormat-Objekt zurückgibt.

ListTemplate ListTemplate-Objekt erforderlich. Die Listenvorlage, die zugewiesen wird.

ContinuePreviousList Variant optional. True, um die Nummerierung der vorherigen Liste fortzusetzen; False, um eine neue Liste zu beginnen.

ApplyTo Variant optional. Der Teil der Liste, dem die Listenvorlage zugewiesen wird. Dabei kann es sich um eine der folgenden WdListApplyTo-Konstanten handeln: wdListApplyToSelection, wdListApplyToWholeList oder wdListApplyToThisPointForward.

DefaultListBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word neue, weborientierte Formatierungen für eine bessere Listenanzeige verwendet. Dabei kann es sich um eine der folgenden Konstanten handeln: wdWord8ListBehavior (Verwenden von Microsoft Word 97-kompatiblen Formatierungen) oder wdWord9ListBehavior (Verwenden von weborientierten Formatierungen). Aus Kompatibilitätsgründen ist die Standardkonstante wdWord8ListBehavior. Bei neuen Prozeduren sollten Sie jedoch wdWord9ListBehavior verwenden, um die Vorteile der verbesserten, weborientierten Formatierungen bei Einzügen und Listen mit mehreren Ebenen nutzen zu können.


Beispiel zur ApplyListTemplate-Methode

In diesem Beispiel wird der Variablen myRange ein Bereich im aktiven Dokument zugewiesen und überprüft, ob in diesem Bereich eine Listenformatierung vorhanden ist. Wenn keine Listenformatierung zugewiesen wurde, wird dem Bereich die vierte Listenvorlage für Gliederungsnummern zugewiesen.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range( _
    Start:= myDoc.Paragraphs(3).Range.Start, _
    End:=myDoc.Paragraphs(6).Range.End)
If myRange.ListFormat.ListType = wdListNoNumbering Then
    myRange.ListFormat.ApplyListTemplate _
        ListTemplate:=ListGalleries(wdOutlineNumberGallery) _
        .ListTemplates(4)
End If

In diesem Beispiel wird der Variablen myList die vierte Liste in MyDocument.doc zugewiesen. Die dritte Listenvorlage wird den Aufzählungen der Liste zugewiesen.

Set myList = Documents("MyDocument.doc").Lists(4)
myList.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdBulletGallery).ListTemplates(3)

In diesem Beispiel wird der Variablen myLstRange die Listenformatierung des zweiten Absatzes von MyDocument.doc zugewiesen. Das Beispiel weist der Liste dann ab diesem Punkt die dritte Listenvorlage für nummerierte Listen zu.

Set myLstRange = Documents("MyDocument.doc").Paragraphs(2) _
    .Range.ListFormat
myLstRange.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdNumberGallery) _
    .ListTemplates(3), _
    ApplyTo:=wdListApplyToThisPointForward


ApplyNumberDefault-Methode

Formatiert Absätze im Bereich des angegebenen ListFormat-Objekts mit dem Standard-Nummerierungsschema. Wurden die Absätze bereits als nummerierte Liste formatiert, entfernt diese Methode die Nummerierung und die Formatierung.

Syntax

Ausdruck.ApplyNumberDefault(DefaultListBehavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListFormat-Objekt zurückgibt.

DefaultListBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word neue, weborientierte Formatierungen für eine bessere Listenanzeige verwendet. Dabei kann es sich um eine der folgenden Konstanten handeln: wdWord8ListBehavior (Verwenden von Microsoft Word 97-kompatiblen Formatierungen) oder wdWord9ListBehavior (Verwenden von weborientierten Formatierungen). Aus Kompatibilitätsgründen ist die Standardkonstante wdWord8ListBehavior. Bei neuen Prozeduren sollten Sie jedoch wdWord9ListBehavior verwenden, um die Vorteile der verbesserten, weborientierten Formatierungen bei Einzügen und Listen mit mehreren Ebenen nutzen zu können.


Beispiel zur ApplyNumberDefault-Methode

In diesem Beispiel werden die Absätze in der Auswahl formatiert. Wenn es sich bei der Auswahl bereits um eine formatierte Liste handelt, werden in diesem Beispiel die Nummerierung und die Formatierung entfernt.

Selection.Range.ListFormat.ApplyNumberDefault

In diesem Beispiel wird der Variablen myRange ein Bereich mit den Absätzen drei bis sechs des aktiven Dokuments zugewiesen und überprüft, ob der Bereich eine Listenformatierung enthält. Wird keine Listenformatierung gefunden, werden Standardaufzählungszeichen hinzugefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range( _
    Start:= myDoc.Paragraphs(3).Range.Start, _
    End:=myDoc.Paragraphs(6).Range.End)
If myRange.ListFormat.ListType = wdListNoNumbering Then
    myRange.ListFormat.ApplyNumberDefault
End If


ApplyOutlineNumberDefault-Methode

Versieht die Absätze im Bereich des angegebenen ListFormat-Objekts mit dem Standardnummerierungsschema für Gliederungen. Wurden die Absätze bereits als Gliederung formatiert, entfernt diese Methode die Nummerierung und die Formatierung.

Syntax

Ausdruck.ApplyOutlineNumberDefault(DefaultListBehavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListFormat-Objekt zurückgibt.

DefaultListBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word neue, weborientierte Formatierungen für eine bessere Listenanzeige verwendet. Dabei kann es sich um eine der folgenden Konstanten handeln: wdWord8ListBehavior (Verwenden von Microsoft Word 97-kompatiblen Formatierungen) oder wdWord9ListBehavior (Verwenden von weborientierten Formatierungen). Aus Kompatibilitätsgründen ist die Standardkonstante wdWord8ListBehavior. Bei neuen Prozeduren sollten Sie jedoch wdWord9ListBehavior verwenden, um die Vorteile der verbesserten, weborientierten Formatierungen bei Einzügen und Listen mit mehreren Ebenen nutzen zu können.

Anmerkungen

Diese Methode entfernt keine integrierten Überschriftenformatvorlagen, die Absätzen zugewiesen wurden.


Beispiel zur ApplyOutlineNumberDefault-Methode

In diesem Beispiel werden die Absätze in der Auswahl mit einer Gliederungsnummerierung versehen. Wenn es sich bei der Auswahl bereits um eine Gliederung handelt, werden in diesem Beispiel die Nummerierung und Formatierung entfernt.

Selection.Range.ListFormat.ApplyOutlineNumberDefault

In diesem Beispiel wird der Variablen myRange ein Bereich mit den Absätzen drei bis sechs des aktiven Dokuments zugewiesen und überprüft, ob der Bereich eine Listenformatierung enthält. Wird keine Listenformatierung gefunden, werden Standardaufzählungszeichen hinzugefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range( _
    Start:= myDoc.Paragraphs(3).Range.Start, _
    End:=myDoc.Paragraphs(6).Range.End)
If myRange.ListFormat.ListType = wdListNoNumbering Then
    myRange.ListFormat.ApplyOutlineNumberDefault
End If


ApplyPageBordersToAllSections-Methode

Weist die angegebene Seitenrahmenformatierung allen Abschnitten in einem Dokument zu.

Syntax

Ausdruck.ApplyPageBordersToAllSections

Ausdruck Erforderlich. Ein Ausdruck, der ein Borders-Objekt zurückgibt.


Beispiel zur ApplyPageBordersToAllSections-Methode

In diesem Beispiel wird ein einzeiliger Seitenrahmen allen Abschnitten im aktiven Dokument zugewiesen.

With ActiveDocument.Sections(1)
    For Each aBord In .Borders
        aBord.LineStyle = wdLineStyleSingle
        aBord.LineWidth = wdLineWidth050pt
    Next aBord
    .Borders.ApplyPageBordersToAllSections
End With


 ApplyTheme-Methode

ApplyTheme-Methode

Weist einem geöffneten Dokument ein Design zu.

Syntax

Ausdruck.ApplyTheme(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Name String erforderlich. Der Name des Designs sowie alle weiteren Formatierungsoptionen, die Sie übernehmen möchten. Das Format dieser Zeichenfolge heißt "theme nnn" in dem theme und nnn folgendermaßen definiert sind:

Zeichenfolge | Beschreibung
theme | Der Name des Ordners, in dem die Daten des gewünschten Designs gespeichert sind. (Der Standardspeicherort für Designdatenordner heißt C:\Programme \Gemeinsame Dateien\Microsoft Shared\Themen) Verwenden Sie bevorzugt den Ordnernamen des Designs anstelle des Anzeigenamens, der im Dialogfeld Design (Menü Format, Befehl Design) angezeigt wird.
nnn | Eine dreistellige Ziffernfolge, die angibt, welche Designformatierungsoptionen aktiviert werden sollen (1 zum Aktivieren, 0 zum Deaktivieren). Die Ziffern entsprechen den Kontrollkästchen Lebendige Farben, Aktive Grafiken und Hintergrundbild im Dialogfeld Design (Menü Format, Befehl Design). Falls die Zeichenfolge ausgelassen worden ist, beträgt der Standardwert nnn "011" (Aktive Grafiken und Hintergrundbild sind aktiviert).


Beispiel zur ApplyTheme-Methode

In diesem Beispiel wird das Design Artsy für das aktive Dokument übernommen und die Option Lebendige Farben aktiviert.

ActiveDocument.ApplyTheme "artsy 100"


Arrange-Methode

Ordnet alle geöffneten Dokumentfenster im Anwendungsarbeitsbereich an.

Syntax

Ausdruck.Arrange(ArrangeStyle)

Ausdruck Ein Ausdruck, der ein Windows-Objekt zurückgibt.

ArrangeStyle Variant optional. Die Fensteranordnung. Dies kann eine der folgenden beiden WdArrangeStyle-Konstanten sein: wdIcons oder wdTiled.


Beispiel zur Arrange-Methode

In diesem Beispiel werden alle geöffneten Fenster so angeordnet, dass sie sich nicht überlappen.

Windows.Arrange ArrangeStyle:=wdTiled

In diesem Beispiel werden alle geöffneten Fenster minimiert und dann die minimierten Fenster angeordnet.

For Each aWindow In Windows
    aWindow.Activate
    aWindow.WindowState = wdWindowStateMinimize
Next aWindow
Windows.Arrange ArrangeStyle:=wdIcons


AutoFit-Methode

Ändert die Breite einer Tabellenspalte, um sie der Breite des Textes anzupassen. Die Art, wie der Text in den Zellen umgebrochen wird, wird dabei nicht geändert.

Syntax

Ausdruck.AutoFit

Ausdruck Erforderlich. Ein Ausdruck, der ein Column- oder Columns-Objekt zurückgibt.

Hinweise

Wenn die Tabelle bereits so breit wie der Abstand zwischen dem linken und rechten Rand ist, ist diese Methode wirkungslos.


AutoFitBehavior-Methode

Bestimmt, wie Microsoft Word die Tabellengröße ändert, wenn AutoAnpassen verwendet wird. Word kann die Tabellengröße anhand des Inhalts der Tabellenzellen oder der Breite des Dokumentfensters ändern. Sie können diese Methode auch verwenden, um AutoAnpassen zu deaktivieren, so dass die Tabellengröße unabhängig von Zelleninhalt und -breite festgelegt wird.

Syntax

Ausdruck.AutoFitBehavior(Behavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt.

Behavior Long erforderlich. Gibt an, wie Word die Größe der angegebenen Tabelle bei Verwendung von AutoAnpassen ändert. Dabei handelt es sich um eine der folgenden WdAutoFitBehavior-Konstanten: wdAutoFitContent, wdAutoFitFixed oder wdAutoFitWindow.

Hinweise

Wenn Sie Behavior auf wdAutoFitContent oder wdAutoFitWindow setzen und die AllowAutoFit-Eigenschaft auf False gesetzt ist, wird die AllowAutoFit-Eigenschaft auf True gesetzt. Wenn Sie Behavior auf wdAutoFitFixed setzen und die AllowAutoFit-Eigenschaft auf True gesetzt ist, wird die AllowAutoFit-Eigenschaft auf False gesetzt.


Beispiel zur AutoFitBehavior-Methode

In diesem Beispiel wird die Einstellung für AutoAnpassen für die erste Tabelle im aktiven Dokument so eingestellt, dass die Breite automatisch anhand der Breite des Dokumentfensters geändert wird.

ActiveDocument.Tables(1).AutoFitBehavior _
    wdAutoFitWindow


AutoFormat-Methode

Table-Objekt: Weist einer Tabelle ein vordefiniertes Aussehen zu. Die Argumente für diese Methode entsprechen den Optionen im Dialogfeld Tabelle AutoFormat im Menü Tabelle.

Document- oder Range-Objekt: Formatiert ein Dokument automatisch. Verwenden Sie die Kind-Eigenschaft zum Spezifizieren einer Dokumentart.

Syntax 1

Ausdruck.AutoFormat(Format, ApplyBorders, ApplyShading, ApplyFont, ApplyColor, ApplyHeadingRows, ApplyLastRow, ApplyFirstColumn, ApplyLastColumn, AutoFit)

Syntax 2

Ausdruck.AutoFormat

Ausdruck Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt (Syntax 1), oder ein Ausdruck, der ein Document- oder Range-Objekt zurückgibt (Syntax 2).

Format Variant optional. Das vordefinierte Tabellenformat. Dies kann eine der WdTableFormat-Konstanten sein. Der Standardwert ist wdTableFormatSimple1.

ApplyBorders Variant optional. True, wenn die Rahmeneigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyShading Variant optional. True, wenn die Schattierungseigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyFont Variant optional. True, wenn die Schriftarteigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyColor Variant optional. True, wenn die Farbeigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyHeadingRows Variant optional. True, wenn die Überschriftzeile-Eigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyLastRow Variant optional. True, wenn die Letzte-Zeile-Eigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist False.

ApplyFirstColumn Variant optional. True, wenn die Erste-Spalte-Eigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist True.

ApplyLastColumn Variant optional. True, wenn die Letzte-Spalte-Eigenschaften des angegebenen Formats zugewiesen werden sollen. Der Standardwert ist False.

AutoFit Variant optional. True, wenn die Breite der Tabellenspalten so viel wie möglich verringert werden soll, ohne die Art zu ändern, wie Text in den Zellen umbrochen wird. Der Standardwert ist True.


Beispiel zur AutoFormat-Methode

In diesem Beispiel werden in einem neuen Dokument eine 5x5-Tabelle erstellt und der Tabelle alle Eigenschaften des Formats Colorful 2 zugewiesen.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=5, NumColumns:=5)
myTable.AutoFormat Format:=wdTableFormatColorful2

In diesem Beispiel werden der Tabelle, in der sich momentan die Einfügemarke befindet, alle Eigenschaften des Formats Classic 2 zugewiesen. Wenn die Einfügemarke nicht in einer Tabelle ist, wird ein Meldungsfeld angezeigt.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).AutoFormat Format:=wdTableFormatClassic2
Else
    MsgBox "The insertion point is not in a table."
End If

In diesem Beispiel wird das aktive Dokument automatisch formatiert.

Selection.Range.AutoFormat


AutoMarkEntries-Methode

Fügt dem angegebenen Dokument automatisch XE-Felder (Indexeintrag) hinzu, wobei die Einträge aus einer Konkordanzdatei verwendet werden.

Anmerkung Eine Konkordanzdatei ist ein Word-Dokument, das eine Tabelle mit zwei Spalten enthält, mit Ausdrücken in der ersten Spalte, die in ein Verzeichnis aufgenommen werden sollen, und Indexeinträgen in der zweiten Spalte.

Syntax

Ausdruck.AutoMarkEntries(ConcordanceFileName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Indexes-Objekt zurückgibt.

ConcordanceFileName String erforderlich. Der Name der Konkordanzdatei, die eine Liste von Elementen enthält, die in ein Verzeichnis aufgenommen werden sollen.


Beispiel zur AutoMarkEntries-Methode

In diesem Beispiel werden Indexeinträge zu Thesis.doc hinzugefügt, die sich auf die Einträge in C:\Documents\List.doc stützen.

Documents("Thesis.doc").Indexes.AutoMarkEntries _
    ConcordanceFileName:="C:\Documents\List.doc"


AutomaticChange-Methode

Führt eine AutoFormat-Aktion durch, wenn vom Office-Assistenten eine Änderung vorgeschlagen wird. Wenn keine AutoFormat-Aktion aktiv ist, wird durch diese Methode ein Fehler erzeugt.

Syntax

Ausdruck.AutomaticChange()

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur AutomaticChange-Methode

In diesem Beispiel wird eine AutoFormat-Aktion des Office-Assistenten durchgeführt, sofern eine aktiv ist.

Application.AutomaticChange


AutomaticLength-Methode

Spezifiziert, dass das erste Segment der Legendenlinie (das Segment, das am Legendentextfeld ansetzt) automatisch skaliert wird, wenn die Legende verschoben wird. Verwenden Sie die CustomLength-Methode zum Spezifizieren, dass das erste Segment der Legendenlinie die feste Länge, die von der Length-Eigenschaft zurückgegeben wird, immer beibehält, wenn die Legende verschoben wird. Betrifft nur Legenden, deren Linien aus mehr als einem Segment bestehen (die Typen msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.AutomaticLength

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Anmerkungen

Durch die Anwendung dieser Methode wird die AutoLength-Eigenschaft auf True eingestellt.


Beispiel zur AutomaticLength-Methode

In diesem Beispiel wird in myDocument für die Legendenlinie für Form eins zwischen der automatischen Skalierung und derjenigen mit fester Länge des ersten Segments umgeschaltet. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


AutoScroll-Methode

Führt einen automatischen Bildlauf durch den angegebenen Ausschnitt durch.

Hinweis Diese Methode läuft so lange fortlaufend ab, bis sie manuell durch Tastendruck oder Mausklick angehalten wird.

Syntax

Ausdruck.AutoScroll(Velocity)

Ausdruck Erforderlich. Ein Ausdruck, der ein Pane-Objekt zurückgibt.

Velocity Long Erforderlich. Die Geschwindigkeit für den Bildlauf. Dies kann ein Wert von – 100 bis 100 sein. Mit – 100 führen Sie einen schnellen Bildlauf nach links, mit 100 einen schnellen Bildlauf nach rechts durch.


Beispiel zur AutoScroll-Methode

Dieses Beispiel führt einen langsamen Bildlauf nach links bei dem aktiven Fensterausschnitt durch.

ActiveDocument.ActiveWindow.ActivePane.AutoScroll _
    Velocity:=-20

Dieses Beispiel führt einen schnellen Bildlauf nach rechts bei dem aktiven Fensterausschnitt durch.

ActiveDocument.ActiveWindow.ActivePane.AutoScroll _
    Velocity:=100


AutoSum-Methode

Fügt ein = (Formula)-Feld ein, das die Summe der Werte in den Tabellenzellen über oder links von der Zelle, die im Ausdruck angegeben ist, berechnet und anzeigt. Informationen darüber, wie Word feststellt, welche Werte zu addieren sind, finden Sie unter Formula-Methode.

Syntax

Ausdruck.AutoSum

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-Objekt zurückgibt.


AutoSummarize-Methode

Erstellt eine automatische Zusammenfassung des angegebenen Dokuments und gibt ein Range-Objekt zurück. Entspricht den Optionen des Befehls AutoZusammenfassen (Menü Extras).

Syntax

Ausdruck.AutoSummarize(Length, Mode, UpdateProperties)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Length Variant optional. Die Länge der Zusammenfassung als Prozentwert der Gesamtlänge des Dokuments (je höher die Zahl, desto mehr Details werden in der Zusammenfassung einbezogen).

Mode Variant optional. Gibt an, wie die Zusammenfassung angezeigt wird. Dies kann eine der folgenden WdSummaryMode-Konstanten sein.

Konstante | Beschreibung
wdSummaryModeHighlight | Hebt die Schlüsselpunkte im angegebenen Dokument hervor und zeigt die AutoZusammenfassen-Symbolleiste an.
WdSummaryModeInsert | Fügt eine Zusammenfassung am Anfang des angegebenen Dokuments ein.
WdSummaryModeCreateNew | Erstellt ein neues Dokument und fügt die Zusammenfassung ein.
WdSummaryModeHideAllButSummary | Hebt alle Elemente mit Ausnahme der Zusammenfassung hervor und zeigt die AutoZusammenfassen-Symbolleiste an.

UpdateProperties Variant optional. True, um die Schlüsselwörter und Kommentare im Dialogfeld Eigenschaften (Menü Datei) zu aktualisieren, indem der Inhalt der Zusammenfassung für das angegebene Dokument übernommen wird.


Beispiel zur AutoSummarize-Methode

Dieses Beispiel erstellt eine automatische Zusammenfassung des aktiven Dokuments durch Hervorheben der Schlüsselpunkte.

ActiveDocument.AutoSummarize Length:=30, _
    Mode:=wdSummaryModeHighlight, _
    UpdateProperties:=True


Before-Methode

Gibt das nächste TabStop-Objekt links von Position zurück.

Syntax

Ausdruck.Before(Position)

Ausdruck Erforderlich. Ein Ausdruck, der eine TabStops-Auflistung zurückgibt.

Position Single erforderlich. Gibt eine Stelle auf dem Lineal in Punkt an.


Beispiel zur Before-Methode

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments die Ausrichtung des ersten benutzerdefinierten Tabstopps, der weniger als 2 Zoll vom linken Seitenrand entfernt ist, geändert.

Set ts = ActiveDocument.Paragraphs(1) _
    .TabStops.Before(InchesToPoints(2))
ts.Alignment = wdAlignTabCenter


 BoldRun-Methode

BoldRun-Methode

Sprachspezifische Informationen

Adds the bold character format to or removes it from the current run. If the run contains a mix of bold and non-bold text, this method adds the bold character format to the entire run.

Syntax

expression.BoldRun

expression Required. An expression that returns a Selection object.

Remarks

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur BoldRun-Methode

Sprachspezifische Informationen

This example toggles the bold formatting for the current selection.

Selection.BoldRun


BreakForwardLink-Methode

Unterbricht die Weiterleitungsverknüpfung für den angegebenen Textpositionsrahmen, wenn die Verknüpfung vorhanden ist.

Syntax

Ausdruck.BreakForwardLink

Ausdruck Erforderlich. Ein Ausdruck, der ein TextFrame-Objekt zurückgibt.

Anmerkungen

Wenn diese Methode einer Form in der Mitte einer Formenkette mit verknüpften Textpositionsrahmen zugewiesen wird, wird die Kette unterbrochen. Es verbleiben zwei Sätze mit verknüpften Formen. Der Text verbleibt jedoch in der ersten Datenreihe der verknüpften Formen.


Beispiel zur BreakForwardLink-Methode

Dieses Beispiel erstellt ein neues Dokument, fügt eine Kette mit drei verknüpften Textfeldern hinzu und hebt anschließend die Verknüpfung nach dem zweiten Textfeld auf.

Documents.Add
Set myTB = ActiveDocument.Shapes.AddTextbox _
    (Orientation:=msoTextOrientationHorizontal, _
    Left:=InchesToPoints(1.5), _
    Top:=InchesToPoints(0.5), _
    Width:=InchesToPoints(1), _
    Height:=InchesToPoints(0.5))
myTB.TextFrame.TextRange = "This is some text. " _
    & "This is some more text. This is even more text."
Set myTB2 = ActiveDocument.Shapes.AddTextbox _
    (Orientation:=msoTextOrientationHorizontal, _
    Left:=InchesToPoints(1.5), _
    Top:=InchesToPoints(1.5), _
    Width:=InchesToPoints(1), _
    Height:=InchesToPoints(0.5))
Set myTB3 = ActiveDocument.Shapes.AddTextbox _
    (Orientation:=msoTextOrientationHorizontal, _
    Left:=InchesToPoints(1.5), _
    Top:=InchesToPoints(2.5), _
    Width:=InchesToPoints(1), _
    Height:=InchesToPoints(0.5))
myTB.TextFrame.Next = myTB2.TextFrame
myTB2.TextFrame.Next = myTB3.TextFrame
MsgBox "Textboxes 1, 2, and 3 are linked."
myTB2.TextFrame.BreakForwardLink


BreakLink-Methode

Hebt die Verknüpfung zwischen der Quelldatei und dem angegebenen OLE-Objekt, der angegebenen Grafik oder dem verknüpften Feld auf.

Hinweis Nachdem Sie diese Methode angewandt haben, wird das Verknüpfungsergebnis nicht mehr automatisch aktualisiert, wenn die Quelldatei geändert wird.

Syntax

Ausdruck.BreakLink

Ausdruck Erforderlich. Ein Ausdruck, der ein LinkFormat-Objekt zurückgibt.


Beispiel zur BreakLink-Methode

In diesem Beispiel werden im aktiven Dokument die Verknüpfungen zu allen OLE-Objekten aktualisiert und dann aufgehoben.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        s.LinkFormat.Update
        s.LinkFormat.BreakLink
    End If
Next s


BuildFreeform-Methode

Konstruiert ein Freihandfigur-Objekt. Gibt ein FreeformBuilder-Objekt zurück, das die Freihandfigur beim Aufbau darstellt. Verwenden Sie die AddNodes-Methode zum Hinzufügen von Segmenten zur Freihandfigur. Nachdem Sie mindestens ein Segment zur Freihandfigur hinzugefügt haben, können Sie die ConvertToShape-Methode verwenden zum Umwandeln des FreeformBuilder-Objekts in ein Shape-Objekt, das die geometrische Beschreibung hat, die Sie im FreeformBuilder-Objekt definiert haben.

Syntax

Ausdruck.BuildFreeform(EditingType, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

EditingType Long erforderlich. Die Editing-Eigenschaft des ersten Knotens. Dies kann eine der beiden folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (kann nicht msoEditingSmooth oder msoEditingSymmetric sein).

X1, Y1 Single erforderlich. Die Position (in Punkt) des ersten Knotens in der Freihandfigur relativ zur oberen linken Ecke des Dokuments.


Beispiel zur BuildFreeform-Methode

In diesem Beispiel wird eine Freihandfigur mit fünf Scheitelpunkten zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


BuildKeyCode-Methode

Gibt eine eindeutige Zahl für eine bestimmte Tastenkombination zurück.

Syntax

Ausdruck.BuildKeyCode(Arg1, Arg2, Arg3, Arg4)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Arg1 Long erforderlich. Eine Taste, die Sie mit einer der WdKey-Konstanten bestimmen.

Arg2 – Arg4 Variant optional. Eine Taste, die Sie mit einer der WdKey-Konstanten bestimmen.


Beispiel zur BuildKeyCode-Methode

In diesem Beispiel wird die Tastenkombination ALT + F1 dem Befehl Organisieren zugewiesen.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCode:=BuildKeyCode(Arg1:=wdKeyAlt, _
    Arg2:=wdKeyF1), KeyCategory:=wdKeyCategoryCommand, _
    Command:="Organizer"

In diesem Beispiel wird die Tastenzuordnung ALT+F1 aus der Dokumentvorlage Normal entfernt.

CustomizationContext = NormalTemplate
FindKey(BuildKeyCode(Arg1:=wdKeyAlt, Arg2:=wdKeyF1)).Clear

In diesem Beispiel wird angezeigt, welcher Befehl der Taste F1 zugewiesen wurde.

CustomizationContext = NormalTemplate
MsgBox FindKey(BuildKeyCode(Arg1:=wdKeyF1)).Command


Calculate-Methode

Berechnet einen mathematischen Ausdruck innerhalb eines Bereichs oder einer Markierung. Gibt das Ergebnis als Single zurück.

Syntax

Ausdruck.Calculate

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.


Beispiel zur Calculate-Methode

In diesem Beispiel wird ein mathematischer Ausdruck am Anfang des aktiven Dokuments eingefügt und der Ausdruck berechnet. Dann wird das Ergebnis dem Bereich angefügt. Das Ergebnis ist "1 + 1 = 2".

Set myRange = ActiveDocument.Range(0, 0)
myRange.InsertBefore "1 + 1 "
myRange.InsertAfter "= " & myRange.Calculate

In diesem Beispiel wird der markierte mathematische Ausdruck berechnet und das Ergebnis angezeigt.

MsgBox "And the answer is... " & Selection.Calculate


CancelAutoInsert-Methode

Verhindert, dass Word automatisch Elemente jeder Art mit Beschriftungen versieht.

Syntax

Ausdruck.CancelAutoInsert

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCaptions-Objekt zurückgibt.


Beispiel zur CancelAutoInsert-Methode

In diesem Beispiel wird Word daran gehindert, Elemente, gleich welcher Art, mit Beschriftungen zu versehen.

AutoCaptions.CancelAutoInsert


CanContinuePreviousList-Methode

Gibt eine WdContinue-Konstante (wdContinueDisabled, wdResetList oder wdContinueList) zurück, die anzeigt, ob die Formatierung von der vorherigen Liste fortgeführt werden kann.

Syntax

Ausdruck.CanContinuePreviousList(ListTemplate)

Ausdruck Erforderlich. Ein Ausdruck, der ein List- oder ListFormat-Objekt zurückgibt.

ListTemplate ListTemplate-Objekt erforderlich. Eine Listenvorlage, die den vorherigen Absätzen im Dokument zugewiesen wurde.

Anmerkungen

Diese Methode gibt den Status der Optionen Liste fortführen und Neu nummerieren im Dialogfeld Nummerierung und Aufzählungen für das angegebene Listenformat zurück. Um die Einstellungen dieser Optionen zu ändern, setzen Sie das ContinuePreviousList-Argument der ApplyListTemplate-Methode.


Beispiel zur CanContinuePreviousList-Methode

In diesem Beispiel wird überprüft, ob die Nummerierung von einer vorherigen Liste deaktiviert wurde. Wenn nicht, wird die aktuelle Listenvorlage zugewiesen. Es wird festgelegt, dass die Nummerierung von der vorherigen Liste fortgesetzt wird. Wenn die Auswahl nicht innerhalb der zweiten Liste ist, tritt bei diesem Beispiel ein Fehler auf.

Set myLF = Selection.Range.ListFormat
temp = myLF.CanContinuePreviousList( _
    ListTemplate:=myLF.ListTemplate)
If temp <> wdContinueDisabled Then
    myLF.ApplyListTemplate ListTemplate:=myLF.ListTemplate, _
        ContinuePreviousList:=True
End If


Cell-Methode

Gibt ein Cell-Objekt zurück, das eine Zelle in einer Tabelle darstellt.

Syntax

Ausdruck.Cell(Row, Column)

Ausdruck Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt.

Row Long erforderlich. Die Nummer der Tabellenzeile der Zelle, die zurückgegeben werden soll. Kann eine ganze Zahl zwischen 1 und der Anzahl der Zeilen in der Tabelle sein.

Column Long erforderlich. Die Nummer der Tabellenspalte der Zelle, die zurückgegeben werden soll. Kann eine ganze Zahl zwischen 1 und der Anzahl der Spalten in der Tabelle sein.


Beispiel zur Cell-Methode

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt und in die erste und letzte Zelle in der Tabelle Text eingefügt.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
With myTable
    .Cell(1,1).Range.InsertAfter "First cell"
    .Cell(myTable.Rows.Count, _
        myTable.Columns.Count).Range.InsertAfter "Last Cell"
End With

In diesem Beispiel wird im aktiven Dokument die erste Zelle in der ersten Tabelle gelöscht.

If ActiveDocument.Tables.Count >= 1 Then
    ActiveDocument.Tables(1).Cell(1, 1).Delete
End If


CentimetersToPoints-Methode

Ändert eine Maßeinheit von Zentimeter in Punkt (1 cm = 28,35 Punkt). Die geänderte Maßeinheit wird als Single zurückgegeben.

Syntax

Ausdruck.CentimetersToPoints(Centimeters)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Centimeters Single. Der Zentimeterwert, der in Punkt angegeben werden soll.


Beispiel zur CentimetersToPoints-Methode

In diesem Beispiel wird allen Absätzen in der Markierung ein zentrierter Tabstopp hinzugefügt. Der Tabstopp wird 1,5 Zentimeter vom linken Rand entfernt gesetzt.

Selection.Paragraphs.TabStops.Add _
    Position:=CentimetersToPoints(1.5), _
    Alignment:=wdAlignTabCenter

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument ein Erstzeileneinzug von 2,5 Zentimetern festgelegt.

ActiveDocument.Paragraphs(1).FirstLineIndent = _
    CentimetersToPoints(2.5)


ChangeFileOpenDirectory-Methode

Legt den Ordner fest, in dem Word nach Dokumenten sucht. Der Inhalt des angegebenen Ordners wird im Dialogfeld Öffnen (Menü Datei) angezeigt, wenn Sie es das nächste Mal aufrufen.

Hinweis Word sucht solange im angegebenen Ordner nach Dokumenten, bis der Benutzer einen anderen Ordner im Dialogfeld Öffnen wählt oder die aktuelle Word-Sitzung beendet wird. Mit der DefaultFilePath-Eigenschaft ändern Sie den Standardordner für Dokumente aller Word-Sitzungen.

Syntax

Ausdruck.ChangeFileOpenDirectory(Path)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Path String erforderlich. Der Pfad für den Ordner, in dem Word nach Dokumenten sucht.


Beispiel zur ChangeFileOpenDirectory-Methode

In diesem Beispiel wird der Ordner geändert, in dem Word nach Dokumenten sucht. Anschließend wird die Datei "Test.doc" geöffnet.

ChangeFileOpenDirectory "C:\My Documents"
Documents.Open FileName:="Test.doc"

In diesem Beispiel wird der Ordner geändert, in dem Word nach Dokumenten sucht. Anschließend wird das Dialogfeld Öffnen angezeigt.

ChangeFileOpenDirectory "C:\"
Dialogs(wdDialogFileOpen).Show


Check-Methode

Simuliert eine Seriendruckoperation. Die Verarbeitung wird unterbrochen, um alle Fehler bei ihrem Auftreten zu protokollieren.

Syntax

Ausdruck.Check

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.


CheckConsistency-Methode

Sprachspezifische Informationen

Searches all text in a Japanese language document and displays instances where character usage is inconsistent for the same words.

Syntax

expression.CheckConsistency

expression Required. An expression that returns a Document object.

Remarks

For more information on editing Japanese text in Microsoft Word, see Editing tools for Japanese text.


Beispiel zur CheckConsistency-Methode

This example checks the consistency of Japanese characters in the active document.

ActiveDocument.CheckConsistency


CheckGrammar-Methode

Syntax 1: Beginnt eine Rechtschreib- und Grammatikprüfung für das angegebene Dokument oder den Bereich. Wenn das Dokument oder der Bereich Fehler enthält, zeigt diese Methode das Dialogfeld Rechtschreibung und Grammatik (Menü Extras) an, die Option Grammatikprüfung ist gewählt. Wird diese Methode einem Dokument zugewiesen, werden alle verfügbaren Textelemente (z. B. Kopfzeilen, Fußzeilen und Textfelder) überprüft.

Syntax 2: Überprüft eine Zeichenfolge auf grammatische Fehler. Gibt True zurück, wenn die Zeichenfolge keine Fehler enthält.

Syntax 1

Ausdruck.CheckGrammar()

Syntax 2

Ausdruck.CheckGrammar(String)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Document- oder Range-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

String String erforderlich. Die Zeichenfolge, die auf grammatische Fehler überprüft werden soll.


Beispiel zur CheckGrammar-Methode

In diesem Beispiel wird eine Rechtschreib- und Grammatikprüfung für alle Textelemente im aktiven Dokument begonnen.

ActiveDocument.CheckGrammar

In diesem Beispiel wird eine Rechtschreib- und Grammatikprüfung für Abschnitt zwei in MyDocument.doc begonnen.

Set Range2 = Documents("MyDocument.doc").Sections(2).Range
Range2.CheckGrammar

In diesem Beispiel wird eine Rechtschreib- und Grammatikprüfung für die Auswahl begonnen.

Selection.Range.CheckGrammar

In diesem Beispiel wird das Ergebnis der Grammatikprüfung der Auswahl angezeigt.

pass = Application.CheckGrammar(String:=Selection.Text)
MsgBox "Selection is grammatically correct: " & pass


CheckName-Methode

Prüft die Gültigkeit der E-Mail-Adressen, die in der aktiven E-Mail-Nachricht in den Zeilen To:, Cc: und Bcc: erscheinen. Diese Methode steht nur zur Verfügung, wenn Sie Word als E-Mail-Editor verwenden.

Anmerkung Wenn die Namen nicht gültig sind, wird das Dialogfeld Namen überprüfen angezeigt.

Syntax

Ausdruck.CheckName

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur CheckName-Methode

In diesem Beispiel werden die E-Mail-Adressen, die in der aktiven E-Mail-Nachricht erscheinen, auf ihre Gültigkeit überprüft.

Application.MailMessage.CheckName


CheckSpelling-Methode

Syntax 1: Beginnt eine Rechtschreibprüfung für die angegebene Sprache oder den Bereich. Wenn das Dokument oder der Bereich Fehler enthält, zeigt diese Methode das Dialogfeld Rechtschreibung und Grammatik (Menü Extras), die Option Grammatik während der Eingabe überprüfen ist nicht gewählt. Wird diese Methode einem Dokument zugewiesen, werden alle verfügbaren Dokumentkomponenten (z. B. Kopfzeilen, Fußzeilen und Textfelder) überprüft.

Syntax 2: Überprüft eine Zeichenfolge auf Rechtschreibfehler. Gibt True zurück, wenn die Zeichenfolge keine Fehler enthält.

Syntax 1

Ausdruck.CheckSpelling(CustomDictionary, IgnoreUppercase, AlwaysSuggest, CustomDictionary2 – CustomDictionary10)

Syntax 2

Ausdruck.CheckSpelling(Word, CustomDictionary, IgnoreUppercase, MainDictionary, CustomDictionary2 – CustomDictionary10)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Document- oder Range-Objekt zurückgibt.

Syntax 2: Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Word String erforderlich. Der Text, dessen Rechtschreibung überprüft wird.

CustomDictionary Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen des Benutzerwörterbuchs zurückgibt.

IgnoreUppercase Variant optional. True, wenn Groß-/Kleinschreibung ignoriert wird. Wird dieses Argument ausgelassen, wird der aktuelle Wert der IgnoreUppercase-Eigenschaft benutzt.

AlwaysSuggest Variant optional. True, wenn Word immer alternative Schreibweisen vorschlägt. Wird dieses Argument ausgelassen, wird der aktuelle Wert der SuggestSpellingCorrections-Eigenschaft benutzt.

MainDictionary Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen des Standardwörterbuchs zurückgibt.

CustomDictionary2 – CustomDictionary10 Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen eines zusätzlichen Benutzerwörterbuchs zurückgibt. Sie können bis zu neun zusätzliche Wörterbücher angeben.


Beispiel zur CheckSpelling-Methode

In diesem Beispiel wird die Rechtschreibprüfung aller verfügbaren Dokumentkomponenten im aktiven Dokument begonnen.

ActiveDocument.CheckSpelling

In diesem Beispiel wird eine Rechtschreibprüfung von Abschnitt zwei in MyDocument.doc begonnen. Die Rechtschreibprüfung umfasst alle Wörter in Großbuchstaben und überprüft die Wörter anhand von zwei Benutzerwörterbüchern und dem Standardwörterbuch.

Set range2 = Documents("MyDocument.doc").Sections(2).Range
range2.CheckSpelling IgnoreUpperCase:=False, _
    CustomDictionary:="MyWork.Dic", _
    CustomDictionary2:="MyTechnical.Dic"

In diesem Beispiel wird eine Rechtschreibprüfung der Auswahl begonnen.

Selection.Range.CheckSpelling

In diesem Beispiel wird das Ergebnis der Rechtschreibprüfung der Auswahl angezeigt.

pass = Application.CheckSpelling(Word:=Selection.Text)
MsgBox "Selection has no spelling errors: " & pass


CheckSynonyms-Methode

Zeigt das Dialogfeld Thesaurus an (Untermenü Sprache, Menü Extras), das alternative Wörter oder Synonyme für den Text im angegebenen Bereich auflistet.

Syntax

Ausdruck.CheckSynonyms

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur CheckSynonyms-Methode

In diesem Beispiel wird das Dialogfeld Thesaurus mit Synonymen für den markierten Text angezeigt.

Selection.Range.CheckSynonyms

In diesem Beispiel wird das Dialogfeld Thesaurus mit Synonymen für das erste Wort im aktiven Dokument angezeigt.

ActiveDocument.Words(1).CheckSynonyms


CleanString-Methode

Entfernt nicht druckbare Zeichen (Zeichencodes 1 – 29) und spezielle Word-Zeichen aus der angegebenen Zeichenfolge oder ersetzt sie durch Leerzeichen (Zeichencode 32), wie im Abschnitt "Hinweise" beschrieben. Das Ergebnis wird als Zeichenfolge zurückgegeben.

Syntax

Ausdruck.CleanString(String)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

String String erforderlich. Die Quellzeichenfolge.

Hinweise

Die folgenden Zeichen werden wie in der Tabelle beschrieben umgewandelt.

Zeichencode | Beschreibung
7 (Warnton) | Wird entfernt, wenn nicht das Zeichen 13 (Absatz) voransteht, und dann in Zeichen 9 (Tabulator) umgewandelt.
10 (Zeilenvorschub) | Wird in Zeichen 13 (Absatz) umgewandelt, wenn nicht das Zeichen 13 voransteht, und dann entfernt.
13 (Absatz) | Bleibt unverändert.
31 (bedingter Trennstrich) | Wird entfernt.
160 (geschütztes Leerzeichen) | Wird in Zeichen 32 (Leerzeichen) umgewandelt.
172 (bedingter Trennstrich) | Wird entfernt.
176 (geschütztes Leerzeichen) | Wird in Zeichen 32 (Leerzeichen) umgewandelt.
182 (Absatzmarke) | Wird entfernt.
183 (Aufzählungszeichen) | Wird in Zeichen 32 (Leerzeichen) umgewandelt.


Beispiel zur CleanString-Methode

In diesem Beispiel werden nicht druckbare Zeichen aus dem markierten Text entfernt, und das Ergebnis wird in ein neues Dokument eingefügt.

cleanUp = Application.CleanString(Selection.Text)
Set myDoc = Documents.Add
myDoc.Content.InsertAfter cleanUp

In diesem Beispiel werden nicht druckbare Zeichen aus der markierten Feldfunktion entfernt, und das Ergebnis wird angezeigt.

ActiveDocument.ActiveWindow.View.ShowFieldCodes = True
ActiveDocument.Fields(1).Select
MsgBox Application.CleanString(Selection.Text)


Clear-Methode

DropCap-Objekt: Entfernt die Formatierung eines Initials.

KeyBinding-Objekt: Entfernt die Tastenkombination aus der KeyBindings-Auflistung und setzt den integrierten Befehl auf die Standardtastenbelegung zurück.

ListEntries-Objekt: Entfernt alle Elemente von einem Dropdown-Formularfeld.

TabStop-Objekt: Entfernt den spezifischen angepassten Tabstopp.

TextInput-Objekt: Löscht den Text vom spezifizierten Textformularfeld.

Syntax

Ausdruck.Clear

Ausdruck Erforderlich. Ein Ausdruck, der ein DropCap-, KeyBinding-, ListEntries-, TabStop- oder TextInput-Objekt zurückgibt.


ClearAll-Methode

TabStops-Objekt: Löscht alle benutzerdefinierten Tabstopps aus den angegebenen Absätzen.

KeyBindings-Objekt: Löscht alle benutzerdefinierten Tastenkombinationen und lädt die ursprünglichen Tastenkombinationen von Microsoft Word.

Dictionaries- oder HangulHanjaConversionDictionaries-Objekt: Entfernt alle Benutzerwörterbücher oder Umwandlungswörterbücher aus dem Speicher.

Syntax

Ausdruck.ClearAll

Ausdruck Erforderlich. Ein Ausdruck, der ein TabStops-, KeyBindings-, Dictionaries- oder HangulHanjaConversionDictionaries-Objekt zurückgibt.

Anmerkungen

Einen einzelnen Tabstopp löschen Sie mit der Clear-Methode des TabStop-Objekts. Mit der ClearAll-Methode werden keine Standard-Tabstopps gelöscht. Standard-Tabstopps manipulieren Sie mit der DefaultTabStop-Eigenschaft für das Dokument.

Nachdem Sie die ClearAll-Methode mit dem KeyBindings-Objekt verwendet haben, werden die Tastenkombinationen in der angegebenen Vorlage oder im Dokument auf ihre Standardeinstellungen zurückgesetzt. Sie bestimmen vor dem Aufruf der ClearAll-Methode ein Dokument oder eine Vorlage mit der CustomizationContext-Eigenschaft.

Wird die ClearAll-Methode mit einem Dictionaries- oder HangulHanjaConversionDictionaries-Objekt verwendet, werden die Benutzerwörterbücher oder Umwandlungswörterbücher nicht gelöscht. Nach dem Aufruf dieser Methode ist die Anzahl der Benutzerwörterbücher oder Umwandlungswörterbücher in der Auflistung 0 (Null).


ClearAllFuzzyOptions-Methode

Sprachspezifische Informationen

Clears all nonspecific search options associated with Japanese text.

Syntax

expression.ClearAllFuzzyOptions

expression Required. An expression that returns a Find object.

Remarks

This method sets the following properties to False:

MatchFuzzyAY

MatchFuzzyBV

MatchFuzzyByte

MatchFuzzyCase

MatchFuzzyDash

MatchFuzzyDZ

MatchFuzzyHF

MatchFuzzyHiragana

MatchFuzzyIterationMark

 MatchFuzzyKanji

MatchFuzzyKiKu

MatchFuzzyOldKana

MatchFuzzyProlongedSoundMark

MatchFuzzyPunctuation

MatchFuzzySmallKana

MatchFuzzySpace

MatchFuzzyTC

MatchFuzzyZJ

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur ClearAllFuzzyOptions-Methode

This example clears all nonspecific options before executing a search in the selected range. If the word " baiorin baiorin baiorin baiorin baiorin " is formatted as bold, the entire paragraph will be selected and copied to the Clipboard.

With Selection.Find
    .ClearFormatting
    .ClearAllFuzzyOptions
    .Font.Bold = True
    .Execute FindText:="  baiorin   baiorin   baiorin   baiorin   baiorin ", Format:=True, Forward:=True
    If .Found = True Then
        .Parent.Expand Unit:=wdParagraph
        .Parent.Copy
    End If
End With


ClearFormatting-Methode

Entfernt Formatierung, die als Teil einer Such- oder Ersetzungsoperation angegeben wurde. Entspricht der Schaltfläche Keine Formatierung im Dialogfeld Suchen und Ersetzen im Menü Bearbeiten.

Anmerkung Um sicherzustellen, dass keine unerwünschten Formate als Kriterien in einer Such- oder Ersetzungsoperation berücksichtigt werden, wenden Sie diese Methode an, bevor Sie die Operation durchführen.

Syntax

Ausdruck.ClearFormatting

Ausdruck Erforderlich. Ein Ausdruck, der ein Find- oder Replacement-Objekt zurückgibt.


Beispiel zur ClearFormatting-Methode

In diesem Beispiel wird die Formatierung von den Such- oder Ersetzen-Kriterien entfernt, bevor im gesamten aktiven Dokument das Wort "Inc." durch "incorporated" ersetzt wird.

Set myRange = ActiveDocument.Content
With myRange.Find
    .ClearFormatting
    .Replacement.ClearFormatting
    .MatchWholeWord = True
    .Execute FindText:="Inc.", _
        ReplaceWith:="incorporated", Replace:=wdReplaceAll
End With

In diesem Beispiel wird die Formatierung von den Suchkriterien entfernt, bevor die Markierung durchsucht wird. Wenn das Wort "Hello" mit Fettformatierung gefunden wird, wird der ganze Absatz markiert und in die Zwischenablage kopiert.

With Selection.Find
    .ClearFormatting
    .Font.Bold = True
    .Execute FindText:="Hello", Format:=True, Forward:=True
    If .Found = True Then
        .Parent.Expand Unit:=wdParagraph
        .Parent.Copy
    End If
End With


Close-Methode

Syntax 1: Schließt das angegebene Dokument oder die angegebenen Dokumente.

Syntax 2: Schließt das angegebene Fenster.

Syntax 3: Schließt den angegebenen Ausschnitt oder den angegebenen Task.

Syntax 1

Ausdruck.Close(SaveChanges, OriginalFormat, RouteDocument)

Syntax 2

Ausdruck.Close(SaveChanges, RouteDocument)

Syntax 3

Ausdruck.Close

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Document- oder Documents-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.

Syntax 3: Erforderlich. Ein Ausdruck, der ein Pane- oder Task-Objekt zurückgibt.

SaveChanges Variant optional. Spezifiziert die Speichern-Aktion für das Dokument. Dies kann eine der folgenden WdSaveOptions-Konstanten sein: wdDoNotSaveChanges, wdPromptToSaveChanges oder wdSaveChanges.

OriginalFormat Variant optional. Spezifiziert das Speichern-Format für das Dokument. Dies kann eine der folgenden WdOriginalFormat-Konstanten sein: wdOriginalDocumentFormat, wdPromptUser oder wdWordDocument.

RouteDocument Variant optional. True, wenn das Dokument zum nächsten Empfänger weitergeleitet werden soll. Wenn das Dokument keinen Verteiler beigefügt hat, wird dieses Argument ignoriert.


ClosePrintPreview-Methode

Wechselt die Seitenansicht des angegebenen Dokuments zur vorherigen Ansicht. Wenn das angegebene Dokument nicht in der Seitenansicht angezeigt wird, wird ein Fehler erzeugt.

Syntax

Ausdruck.ClosePrintPreview

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur ClosePrintPreview-Methode

Dieses Beispiel wechselt beim aktiven Fenster von der Seitenansicht zur Normalansicht.

If ActiveDocument.PrintPreview = True Then _
    ActiveDocument.ClosePrintPreview
ActiveDocument.ActiveWindow.View.Type = wdNormalView


CloseUp-Methode

Entfernt den Leerraum vor den angegebenen Absätzen.

Syntax

Ausdruck.CloseUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

ActiveDocument.Paragraphs(1).CloseUp
ActiveDocument.Paragraphs(1).SpaceBefore = 0


Beispiel zur CloseUp-Methode

In diesem Beispiel wird der Leerraum vor dem ersten Absatz in der Markierung entfernt.

Selection.Paragraphs(1).CloseUp

In diesem Beispiel wird die Formatvorlage Heading 1 im aktiven Dokument geändert, so dass vor Absätzen, die mit Heading 1 formatiert sind, kein Leerraum ist.

ActiveDocument.Styles("Heading 1").ParagraphFormat.CloseUp


Collapse-Methode

Reduziert einen Bereich oder eine Markierung auf die Anfangs- oder Endposition. Nach der Reduzierung eines Bereichs oder einer Markierung sind der Anfangs- und der Endpunkt gleich.

Syntax

Ausdruck.Collapse(Direction)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Direction Variant optional. Die Richtung, in die der Bereich oder die Markierung reduziert werden soll. Kann eine der folgenden zwei WdCollapseDirection-Konstanten sein: wdCollapseEnd oder wdCollapseStart. Die Standardeinstellung ist wdCollapseStart.

Anmerkungen

Wenn Sie wdCollapseEnd zum Reduzieren eines Bereichs verwenden, der sich auf einen ganzen Absatz bezieht, befindet sich der Bereich nach der abschließenden Absatzmarke (am Anfang des nächsten Absatzes). Sie können aber den Bereich ein Zeichen zurückverschieben, indem Sie nach dem Reduzieren des Bereichs die MoveEnd-Methode verwenden, wie es im folgenden Beispiel gezeigt wird.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.Collapse Direction:=wdCollapseEnd
myRange.MoveEnd Unit:=wdCharacter, Count:=-1


CollapseOutline-Methode

Reduziert den Text unter der Markierung oder dem angegebenen Bereich um eine Überschriftenebene.

Hinweis Wenn sich das Dokument nicht in der Gliederungs- oder Zentraldokument-Ansicht befindet, wird ein Fehler erzeugt.

Syntax

Ausdruck.CollapseOutline(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.

Range Optionales Range-Objekt. Der Absatzbereich, der reduziert werden soll. Wenn Sie dieses Argument nicht angeben, wird die gesamte Markierung reduziert.


Beispiel zur CollapseOutline-Methode

Dieses Beispiel weist dem zweiten Absatz im aktiven Dokument die Formatvorlage "Heading 2" zu, wechselt das aktive Fenster in die Gliederungsansicht und reduziert den Text unter dem zweiten Absatz im Dokument.

ActiveDocument.Paragraphs(2).Style = wdStyleHeading2
With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .CollapseOutline Range:=ActiveDocument.Paragraphs(2).Range
End With

Dieses Beispiel reduziert jede Überschrift im Dokument um eine Ebene.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .CollapseOutline Range:=ActiveDocument.Content
End With


Compare-Methode

Zeigt Korrekturmarkierungen an, um anzuzeigen, an welchen Stellen das angegebene Dokument von einem anderen abweicht.

Syntax

Ausdruck.Compare(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Name String erforderlich. Der Name des Dokuments, mit dem das Dokument verglichen wird, das mit Ausdruck angegeben wurde.


Beispiel zur Compare-Methode

In diesem Beispiel wird das aktive Dokument mit dem Dokument "First Rev.doc" im Ordner Draft verglichen.

ActiveDocument.Compare Name:="C:\Draft\First Rev.doc"


ComputeStatistics-Methode

Syntax 1: Gibt eine auf dem Inhalt des angegebenen Dokuments basierende Statistik zurück.

Syntax 2: Gibt eine auf dem Inhalt des angegebenen Bereichs basierende Statistik zurück.

Syntax 1

Ausdruck.ComputeStatistics(Statistic, IncludeFootnotesAndEndnotes)

Syntax 2

Ausdruck.ComputeStatistics(Statistic)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Statistic Long erforderlich. Die Statistik als eine der folgenden WdStatistic-Konstanten: wdStatisticCharacters, wdStatisticCharactersWithSpaces, wdStatisticFarEastCharacters, wdStatisticLines, wdStatisticPages, wdStatisticParagraphs oder wdStatisticWords.

IncludeFootnotesAndEndnotes Variant optional. True, um Fußnoten und Endnoten bei der Berechnung von Statistiken einzubeziehen. Wird dieses Argument ausgelassen, gilt als Standardwert False.

Hinweise

Einige der oben aufgelisteten Konstanten stehen möglicherweise nicht zur Verfügung. Dies richtet sich nach der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch).


Beispiel zur ComputeStatistics-Methode

In diesem Beispiel wird die Anzahl der Wörter und Zeichen im ersten Absatz von Report.doc angezeigt.

Set myRange = Documents("Report.doc").Paragraphs(1).Range
wordCount = myRange.ComputeStatistics(Statistic:=wdStatisticWords)
charCount = _
    myRange.ComputeStatistics(Statistic:=wdStatisticCharacters)
MsgBox "The first paragraph contains " & wordCount _
    & " words and a total of " & charCount & " characters."

In diesem Beispiel wird die Anzahl der Wörter im aktiven Dokument einschließlich der Fußnoten angezeigt.

MsgBox _
    ActiveDocument.ComputeStatistics(Statistic:=wdStatisticWords, _
    IncludeFootnotesAndEndnotes:=True) & " words"


Connect-Methode

Stellt eine Verbindung zu einem Netzlaufwerk her.

Syntax

Ausdruck.Connect(Path, Drive, Password)

Ausdruck Erforderlich. Ein Ausdruck, der ein System-Objekt zurückgibt.

Path String erforderlich. Der Pfad für das Netzlaufwerk (z. B. "\\Projekt\Info").

Drive Variant optional. Eine Nummer, die dem Buchstaben entspricht, den Sie dem Netzlaufwerk zuweisen wollen, wobei 0 (Null) dem ersten verfügbaren Laufwerkbuchstaben entspricht, 1 dem zweiten verfügbaren Laufwerkbuchstaben usw. Wenn dieses Argument weggelassen wird, wird der nächste verfügbare Buchstabe verwendet.

Password Variant optional. Das Kennwort, wenn das Netzlaufwerk mit einem Kennwort geschützt ist.

Hinweise

Verwenden Sie die Dialogs-Eigenschaft mit der Konstanten wdDialogConnect zur Anzeige des Dialogfelds Verbindung zu Netzlaufwerk. Im folgenden Beispiel wird das Dialogfeld Verbindung zu Netzlaufwerk mit einem voreingestellten Pfad angezeigt.

With Dialogs(wdDialogConnect)
    .Path = "\\Marketing\Public"
    .Show
End With


Beispiel zur Connect-Methode

In diesem Beispiel wird eine Verbindung zu einem Netzlaufwerk (\\Projekt\Info) hergestellt, das mit dem Kennwort "Smiley" geschützt ist, und das Netzlaufwerk dem nächsten zur Verfügung stehenden Laufwerksbuchstaben zugewiesen.

System.Connect Path:="\\Project\Info", Password:="smiley"

In diesem Beispiel wird eine Verbindung zu einem Netzlaufwerk (\\Team1\Public) hergestellt und das Netzlaufwerk dem dritten zur Verfügung stehenden Laufwerksbuchstaben zugewiesen.

System.Connect Path:="\\Team1\Public", Drive:=2


Convert-Methode

Footnotes-oder Endnotes-Objekt: Wandelt Endnoten in Fußnoten um oder umgekehrt.

ListTemplate-Objekt: Wandelt eine Liste mit mehreren Ebenen in eine Liste mit einer Ebene um.

Syntax 1

Ausdruck.Convert

Syntax 2

Ausdruck.Convert(Level)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListTemplate Objekt (Syntax 1) oder ein Endnotes- oder Footnotes-Objekt zurückgibt (Syntax 2).

Level Long optional. Die Ebene, die zur Formatierung der neuen Liste verwendet wird. Wenn eine Liste mit mehreren Ebenen in eine Liste mit einer Ebene umgewandelt wird, kann dieses Argument eine Zahl von 1 bis 9 annehmen. Wenn eine Liste mit einer Ebene in eine Liste mit mehreren Ebenen umgewandelt wird, ist 1 der einzige gültige Wert. Wird dieses Argument ausgelassen, wird 1 verwendet.

Hinweise

Die Convert-Methode kann nicht auf eine Listenvorlage angewandt werden, die aus der ListGalleries-Auflistung stammt.


ConvertHangulAndHanja-Methode

Sprachspezifische Informationen

Converts the specified range from hangul to hanja or vice versa.

Syntax

expression.ConvertHangulAndHanja(ConversionsMode, FastConversion, CheckHangulEnding, EnableRecentOrdering, CustomDictionary)

expression Required. An expression that returns a Range object.

ConversionsMode Optional Variant. Sets the direction for the conversion between hangul and hanja. Can be either of the following WdMultipleWordConversionsMode constants: wdHangulToHanja or wdHanjaToHangul. The default value is the current value of the MultipleWordConversionsMode property.

FastConversion Optional Variant. True if Microsoft Word automatically converts a word with only one suggestion for conversion. The default value is the current value of the HangulHanjaFastConversion property.

CheckHangulEnding Optional Variant. True if Word automatically detects hangul endings and ignores them. The default value is the current value of the CheckHangulEndings property. This argument is ignored if the ConversionsMode argument is set to wdHanjaToHangul.

EnableRecentOrdering Optional Variant. True if Word displays the most recently used words at the top of the suggestions list. The default value is the current value of the EnableHangulHanjaRecentOrdering property.

CustomDictionary Optional Variant. The name of a custom hangul-hanja conversion dictionary. Use this argument in order to use a custom dictionary with hangul-hanja conversions not contained in the main dictionary.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur ConvertHangulAndHanja-Methode

This example converts the current selection from hangul to hanja.

Selection.Range.ConvertHangulAndHanja _
    ConversionsMode:=wdHangulToHanja, _
    FastConversion:=True, _
    EnableRecentOrdering:= True


ConvertNumbersToText-Methode

Ändert die Listennummern und LISTNUM-Felder im angegebenen Document-, List-, oder ListFormat-Objekt in Text.

Syntax

Ausdruck.ConvertNumbersToText(NumberType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-, List- oder ListFormat-Objekt zurückgibt.

NumberType Variant optional. Der Nummerntyp, der konvertiert werden soll. Dabei kann es sich um eine der folgenden WdNumberType-Konstanten handeln: wdNumberParagraph, wdNumberListNum oder wdNumberAllNumbers. Der Standardwert lautet bei LISTNUM-Feldern wdNumberListNum, in allen anderen Fällen wdNumberAllNumbers.

Hinweise

Es gibt zwei Nummerntypen: vorgegebene Nummern (wdNumberParagraph), die Sie einem Absatz zuweisen, wenn Sie eine Dokumentvorlage im Dialogfeld Nummerierung und Aufzählungen wählen, und LISTNUM-Felder (wdNumberListNum), mit denen Sie Absätze mit mehreren Nummern versehen können.

Die ConvertNumbersToText-Methode ist nützlich, um das Dokument mit einer Anwendung zu bearbeiten, die keine Listenformatierung oder LISTNUM-Felder erkennt.

Anmerkung Nachdem Sie Listennummern in Text umgewandelt haben, können Sie sie nicht mehr in einer Liste manipulieren.


Beispiel zur ConvertNumbersToText-Methode

In diesem Beispiel werden Listennummern und LISTNUM-Felder im aktiven Dokument in Text umgewandelt.

ActiveDocument.ConvertNumbersToText

In diesem Beispiel werden die Nummern in der ersten Liste in Text umgewandelt.

ActiveDocument.Lists(1).ConvertNumbersToText

In diesem Beispiel werden die vorgegebenen Nummern in myRange in Text umgewandet. Die LISTNUM-Felder werden dabei nicht beeinflusst.

Set myDoc = ActiveDocument
Set myRange = _
    myDoc.Range(Start:=myDoc.Paragraphs(12).Range.Start, _
    End:=myDoc.Paragraphs(20).Range.End)
myRange.ListFormat.ConvertNumbersToText wdNumberParagraph


ConvertTo-Methode

Wandelt das angegebene OLE-Objekt von einer Klasse in eine andere um und gibt Ihnen die Möglichkeit, das Objekt in einer anderen Server-Anwendung zu bearbeiten oder die Art zu ändern, wie das Objekt im Dokument angezeigt wird.

Syntax

Ausdruck.ConvertTo(ClassType, DisplayAsIcon, IconFileName, IconIndex, IconLabel)

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEFormat-Objekt zurückgibt.

ClassType Variant optional. Der Name der Anwendung, die zum Aktivieren des OLE-Objekts verwendet wird. Sie können eine Liste der verfügbaren Anwendungen im Feld Objekttyp auf der Registerkarte Neu erstellen im Dialogfeld Objekt (Menü Einfügen) sehen. Sie können die Zeichenfolge ClassType finden, indem Sie ein Objekt als zeilenfixierte Form einfügen und sich dann die Feldfunktionen ansehen. Der Klassentyp des Objekts steht entweder nach dem Wort "EMBED" oder dem Wort "LINK".

DisplayAsIcon Variant optional. True, wenn das OLE-Objekt als Symbol angezeigt werden soll. Der Standardwert ist False.

IconFileName Variant optional. Die Datei, die das Symbol enthält, das angezeigt werden soll.

IconIndex Variant optional. Die Indexnummer des Symbols innerhalb von IconFileName. Die Reihenfolge der Symbole in der angegebenen Datei entspricht der Reihenfolge in der die Symbole im Dialogfeld Anderes Symbol (Menü Einfügen, Dialogfeld Objekt) erscheinen, wenn das Kontrollkästchen Als Symbol markiert ist. Das erste Symbol in der Datei hat die Indexnummer 0 (Null). Wenn in IconFileName kein Symbol mit der vorgegebenen Indexnummer vorhanden ist, wird das Symbol mit der Indexnummer 1 (das zweite Symbol in der Datei) verwendet. Der Standardwert ist 0 (Null).

IconLabel Variant optional. Eine Bezeichnung (Beschriftung), die unter dem Symbol angezeigt werden soll.


ConvertToFrame-Methode

Wandelt die angegebene Form in einen Positionsrahmen um. Gibt ein Frame-Objekt zurück, das den neuen Positionsrahmen darstellt.

Syntax

Ausdruck.ConvertToFrame

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Hinweise

Formen, die keinen angehängten Text unterstützen, können nicht in Positionsrahmen umgewandelt werden. Für Grafiken, OLE-Objekte und ActiveX-Steuerelemente wird die ConvertToInlineShape-Methode verwendet.

Wenn Sie diese Methode bei einem ShapeRange-Objekt verwenden, das mehrere Formen enthält, wird ein Fehler erzeugt.

In Word 97 und allen späteren Versionen sind Positionsrahmen durch Textfelder ersetzt worden.


Beispiel zur ConvertToFrame-Methode

Dieses Beispiel erstellt ein Textfeld mit dem markierten Text, und wandelt das Textfeld anschließend in einen Positionsrahmen um.

If Selection.Type = wdSelectionNormal Then
    Selection.CreateTextbox
    Selection.ShapeRange.ConvertToFrame
End If


ConvertToInlineShape-Methode

Wandelt die angegebene Form auf der Zeichnungsebene eines Dokuments in eine eingebettete Form auf der Textebene um. Sie können nur Formen umwandeln, die Grafiken, OLE-Objekte oder ActiveX-Steuerelemente darstellen. Diese Methode gibt ein InlineShape-Objekt zurück, das die Grafik oder das OLE-Objekt darstellt.

Syntax

Ausdruck.ConvertToInlineShape

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Anmerkungen

Formen, die angehängten Text unterstützen, können nicht in eingebettete Formen umgewandelt werden. Verwenden Sie für diese Formen die ConvertToFrame-Methode.

Wenn Sie diese Methode bei einem ShapeRange-Objekt verwenden, das mehrere Formen enthält, wird ein Fehler erzeugt.


Beispiel zur ConvertToInlineShape-Methode

Dieses Beispiel wandelt jede Grafik in "MeinDok.doc" in eine eingebettete Form um.

For Each s In Documents("MyDoc.doc").Shapes
    If s.Type = msoPicture Then
        s.ConvertToInlineShape
    End If
Next s


ConvertToShape-Methode

InlineShape-Objekt: Konvertiert eine eingebettete Form in eine frei bewegliche Form. Gibt ein Shape-Objekt zurück, das die neue Form darstellt.

FreeformBuilder-Objekt: Erstellt eine Form mit den geometrischen Eigenschaften des angegebenen Objekts. Gibt ein Shape-Objekt zurück, das die neue Form darstellt.

Syntax 1

Ausdruck.ConvertToShape

Syntax 2

Ausdruck.ConvertToShape(Anchor)

Ausdruck Erforderlich. Ein Ausdruck, der ein InlineShape-Objekt (Syntax 1) oder ein FreeformBuilder-Objekt (Syntax 2) zurückgibt.

Anchor Variant optional. Ein Range-Objekt, das den Text darstellt, mit dem eine Form verbunden ist. Wird Anchor festgelegt, wird die Verankerung zu Beginn des ersten Absatzes im Verankerungsbereich positioniert. Wird dieses Argument ausgelassen, wird der Verankerungsbereich automatisch gewählt und die Form relativ zum oberen und linken Blattrand positioniert.

Hinweise

Die AddNodes-Methode muss einem FreeformBuilder-Objekt mindestens einmal zugewiesen worden sein, bevor Sie die ConvertToShape-Methode benutzen können.


Beispiel zur ConvertToShape-Methode

In diesem Beispiel wird die erste eingebettete Form im aktiven Dokument in eine frei bewegliche Form konvertiert.

ActiveDocument.InlineShapes(1).ConvertToShape

In diesem Beispiel wird myDocument ein Freihandobjekt mit fünf Scheitelpunkten hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


ConvertToTable-Methode

Wandelt Text innerhalb eines Bereichs oder einer Markierung in eine Tabelle um. Gibt die Tabelle als Table-Objekt zurück.

Syntax

Ausdruck.ConvertToTable(Separator, NumRows, NumColumns, InitialColumnWidth, Format, ApplyBorders, ApplyShading, ApplyFont, ApplyColor, ApplyHeadingRows, ApplyLastRow, ApplyFirstColumn, ApplyLastColumn, AutoFit, AutoFitBehavior, DefaultTableBehavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Separator Variant optional. Gibt das Zeichen an, das zum Separieren von Text in die Zellen verwendet wird. Kann ein Zeichen oder eine der folgenden WdTableFieldSeparator-Konstanten sein: wdSeparateByCommas, wdSeparateByDefaultListSeparator, wdSeparateByParagraphs oder wdSeparateByTabs. Lässt man dieses Argument weg, dann wird der Wert der DefaultTableSeparator-Eigenschaft verwendet.

NumRows Variant optional. Die Anzahl der Zeilen in der Tabelle. Lässt man dieses Argument weg, legt Microsoft Word basierend auf dem Inhalt des Bereichs oder der Markierung die Anzahl der Zeilen fest.

NumColumns Variant optional. Die Anzahl der Spalten in der Tabelle. Lässt man dieses Argument weg, legt Word basierend auf dem Inhalt des Bereichs oder der Markierung die Anzahl der Spalten fest.

InitialColumnWidth Variant optional. Die anfängliche Breite jeder Spalte, in Punkt. Lässt man dieses Argument weg, berechnet Word die Spaltenbreite und passt sie an, so dass die Tabelle von einem Seitenrand zum andern reicht.

Format Variant optional. Gibt eines der vordefinierten Formate an, die im Dialogfeld Tabelle AutoFormat aufgelistet sind (Menü Tabelle). Kann eine der folgenden WdTableFormat-Konstanten sein:

wdTableFormat3DEffects1

wdTableFormat3DEffects2

wdTableFormat3DEffects3

wdTableFormatClassic1

wdTableFormatClassic2

wdTableFormatClassic3

wdTableFormatClassic4

wdTableFormatColorful1

wdTableFormatColorful2

wdTableFormatColorful3

wdTableFormatColumns1

wdTableFormatColumns2

wdTableFormatColumns3

wdTableFormatColumns4

wdTableFormatColumns5

wdTableFormatContemporary

wdTableFormatElegant

wdTableFormatGrid1

wdTableFormatGrid2

wdTableFormatGrid3

wdTableFormatGrid4

wdTableFormatGrid5

 wdTableFormatGrid6

wdTableFormatGrid7

wdTableFormatGrid8

wdTableFormatList1

wdTableFormatList2

wdTableFormatList3

wdTableFormatList4

wdTableFormatList5

wdTableFormatList6

wdTableFormatList7

wdTableFormatList8

wdTableFormatNone

wdTableFormatProfessional

wdTableFormatSimple1

wdTableFormatSimple2

wdTableFormatSimple3

wdTableFormatSubtle1

wdTableFormatSubtle2

wdTableFormatWeb1

wdTableFormatWeb2

wdTableFormatWeb3

ApplyBorders Variant optional. True, wenn die Rahmeneigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyShading Variant optional. True, wenn die Schattierungseigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyFont Variant optional. True, wenn die Zeicheneigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyColor Variant optional. True, wenn die Farbeigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyHeadingRows Variant optional. True, wenn die Überschrifteigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyLastRow Variant optional. True, wenn die Letzte-Zeile-Eigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyFirstColumn Variant optional. True, wenn die Erste-Spalte-Eigenschaften des angegebenen Formats zugewiesen werden sollen.

ApplyLastColumn Variant optional. True, wenn die Letzte-Spalte-Eigenschaften des angegebenen Formats zugewiesen werden sollen.

AutoFit Variant optional. True, wenn die Breite der Tabellenspalten so viel wie möglich verkleinert werden soll, ohne die Art zu ändern, wie der Text in den Zellen umgebrochen wird.

AutoFitBehavior Variant optional. Legt die Regeln für AutoAnpassen fest, nach denen die Größe einer Tabelle in Word geändert wird. Dies kann eine der folgenden WdAutoFitBehavior-Konstanten sein: wdAutoFitContent, wdAutoFitFixed oder wdAutoFitWindow. Wenn DefaultTableBehavior auf wdWord8TableBehavior gesetzt ist, wird dieses Argument ignoriert.

DefaultTableBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word automatisch die Zellengröße in einer Tabelle ändert, damit der Zelleninhalt passt (AutoAnpassen). Dies kann eine der folgenden Konstanten sein: wdWord8TableBehavior (AutoAnpassen deaktiviert) oder wdWord9TableBehavior (AutoAnpassen aktiviert). Der Standardwert ist wdWord8TableBehavior.


Beispiel zur ConvertToTable-Methode

In diesem Beispiel werden die ersten drei Absätze im aktiven Dokument in eine Tabelle umgewandelt.

Set aDoc = ActiveDocument
Set myRange = aDoc.Range(Start:=aDoc.Paragraphs(1).Range.Start, _
    End:=aDoc.Paragraphs(3).Range.End)
myRange.ConvertToTable Separator:=wdSeparateByParagraphs

In diesem Beispiel wird an der Einfügemarke Text eingefügt und dann der durch Komma getrennte Text in eine Tabelle mit Formatierung umgewandelt.

With Selection
    .Collapse
    .InsertBefore "one, two, three"
    .InsertParagraphAfter
    .InsertAfter "one, two, three"
    .InsertParagraphAfter
End With
Set myTable = _
    Selection.ConvertToTable(Separator:=wdSeparateByCommas, _
    Format:=wdTableFormatList8)


ConvertToText-Methode

Wandelt eine Tabelle in Text um und gibt ein Range-Objekt zurück, das den mit Trennzeichen versehenen Text darstellt.

Syntax

Ausdruck.ConvertToText(Separator, NestedTables)

Ausdruck Erforderlich. Ein Ausdruck, der ein Row-, Rows- oder Table-Objekt zurückgibt.

Separator Variant optional. Das Zeichen, das die umgewandelten Spalten begrenzt (Absatzmarken begrenzen die umgewandelten Zeilen). Dies kann eine der folgenden WdTableFieldSeparator-Konstanten sein: wdSeparateByCommas, wdSeparateByDefaultListSeparator, wdSeparateByParagraphs oder wdSeparateByTabs. Der Standardwert ist wdSeparateByTabs.

NestedTables Variant optional. True, wenn verschachtelte Tabellen in Text umgewandelt werden. Wenn Separator nicht auf wdSeparateByParagraphs gesetzt ist, wird dieses Argument ignoriert. Der Standardwert ist True.

Hinweise

Wenn Sie die ConvertToText-Methode auf ein Table-Objekt anwenden, wird das Objekt gelöscht. Wenn Sie einen Verweis zum umgewandelten Inhalt der Tabelle aufrechterhalten wollen, müssen Sie das Range-Objekt, das von der ConvertToText-Methode zurückgegeben wird, einer neuen Objektvariablen zuweisen. Im folgenden Beispiel wird die erste Tabelle im aktiven Dokument in Text umgewandelt und dann als Aufzählung formatiert.

Set myTable = ActiveDocument.Tables(1)
Set aRange = _
    myTable.ConvertToText(Separator:=wdSeparateByParagraphs)
aRange.ListFormat.ApplyListTemplate ListTemplate:=ListGalleries( _
    wdBulletGallery).ListTemplates(1)


Beispiel zur ConvertToText-Methode

In diesem Beispiel wird eine Tabelle erstellt und diese dann in Text umgewandelt. Als Trennzeichen werden Tabulatoren verwendet.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=3)
i = 1
For Each aCell In myTable.Range.Cells
    aCell.Range.InsertAfter "Cell " & i
    i = i + 1
Next aCell
MsgBox "Click OK to convert table to text."
Set myRange = myTable.ConvertToText(Separator:=wdSeparateByTabs)

In diesem Beispiel wird die Tabelle, die die Markierung enthält, in Text umgewandelt, mit Leerzeichen zwischen den Spalten.

If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).ConvertToText Separator:=" "
Else
    MsgBox "The insertion point is not in a table."
End If


Copy-Methode

Syntax 1: Kopiert das angegebene Objekt in die Zwischenablage.

Syntax 2: Legt die Textmarke, die durch das Argument Name spezifiziert wurde, auf die Stelle fest, die von einer anderen Textmarke markiert wurde, und gibt ein Bookmark-Objekt zurück.

Syntax 1

Ausdruck.Copy

Syntax 2

Ausdruck.Copy(Name)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Field-, FormField-, Frame-, MailMergeField-, PageNumber-, Range- oder Selection-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Bookmark-Objekt zurückgibt.

Name String erforderlich. Der Name der neuen Textmarke.


CopyAsPicture-Methode

Die CopyAsPicture-Methode funktioniert genauso wie die Copy-Methode für Range- und Selection-Objekte. Weitere Informationen über diese Methode erhalten Sie im Sprachverzeichnis der Macintosh-Edition von Microsoft Office 98.

Syntax

Ausdruck.CopyAsPicture

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.


CopyFormat-Methode

Kopiert die Zeichenformatierung des ersten Zeichens im gewählten Text. Wenn eine Absatzmarke gewählt wurde, wird zusätzlich zur Zeichenformatierung die Absatzformatierung kopiert.

Hinweis Mit der PasteFormat-Methode weisen Sie die kopierte Formatierung einer anderen Auswahl zu.

Syntax

Ausdruck.CopyFormat

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur CopyFormat-Methode

In diesem Beispiel wird die Formatierung des ersten Absatzes auf den zweiten Absatz im aktiven Dokument kopiert.

ActiveDocument.Paragraphs(1).Range.Select
Selection.CopyFormat
ActiveDocument.Paragraphs(2).Range.Select
Selection.PasteFormat

In diesem Beispiel wird die Auswahl reduziert und die Zeichenformatierung auf das nächste Wort kopiert.

With Selection
    .Collapse Direction:=wdCollapseStart
    .CopyFormat
    .Next(Unit:=wdWord, Count:=1).Select
    .PasteFormat
End With


CopyStylesFromTemplate-Methode

Kopiert Formatvorlagen von der angegebenen Vorlage in ein Dokument.

Syntax

Ausdruck.CopyStylesFromTemplate(Template)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Template String erforderlich. Der Dateiname der Vorlage.

Anmerkungen

Wenn Formatvorlagen von einer Vorlage in ein Dokument kopiert werden, werden Formatvorlagen mit gleichem Namen im Dokument neu definiert, damit sie mit den Formatvorlagenbeschreibungen in der Vorlage übereinstimmen. Eindeutige Formatvorlagen von der Vorlage werden in das Dokument kopiert. Eindeutige Formatvorlagen im Dokument bleiben intakt.


Beispiel zur CopyStylesFromTemplate-Methode

In diesem Beispiel werden die Formatvorlagen von der Vorlage des aktiven Dokuments in das Dokument kopiert.

ActiveDocument.CopyStylesFromTemplate _
    Template:=ActiveDocument.AttachedTemplate.FullName

In diesem Beispiel werden die Formatvorlagen von der Vorlage "Sales96.dot" nach "Sales.doc" kopiert.

Documents("Sales.doc").CopyStylesFromTemplate _
    Template:="C:\MSOffice\Templates\Sales96.dot"


CountNumberedItems-Methode

Gibt die Nummer der Aufzählungs- oder Nummerierungszeichen und LISTNUM-Felder im angegebenen Document-, List- oder ListFormat-Objekt zurück.

Syntax

Ausdruck.CountNumberedItems(NumberType, Level)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-, List- oder ListFormat-Objekt zurückgibt.

NumberType Variant optional. Der Nummerntyp, der gezählt wird. Dabei kann es sich um eine der folgenden WdNumberType-Konstanten handeln: wdNumberParagraph, wdNumberListNum oder wdNumberAllNumbers. Der Standardwert lautet wdNumberAllNumbers.

Level Variant optional. Eine Nummer, die der Nummerierungsebene, die gezählt werden soll, entspricht. Wird dieses Argument ausgelassen, werden alle Ebenen gezählt.

Anmerkungen

Aufzählungspunkte werden gezählt, wenn entweder wdNumberParagraph oder wdNumberAllNumbers (Standard) für NumberType angegeben wird.

Es gibt zwei Nummerntypen: vorgegebene Nummern (wdNumberParagraph), mit denen Sie Absätze versehen können, indem Sie eine Vorlage im Dialogfeld Nummerierung und Aufzählungen wählen, und LISTNUM-Felder (wdNumberListNum), mit deren Hilfe Sie einen Absatz mit mehr als einer Nummer versehen können.


Beispiel zur CountNumberedItems-Methode

In diesem Beispiel wird die aktuelle Auswahl als Liste mit der zweiten Vorlage für nummerierte Listen formatiert. Das Beispiel zählt dann die Aufzählungszeichen und LISTNUM-Felder im aktiven Dokument und zeigt das Ergebnis in einem Meldungsfeld an.

Selection.Range.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdNumberGallery).ListTemplates(2)
Msgbox ActiveDocument.CountNumberedItems

In diesem Beispiel wird die Anzahl der Aufzählungszeichen erster Ebene im aktiven Dokument gezählt.

Msgbox ActiveDocument.Content.ListFormat _
    .CountNumberedItems(Level:=1)

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die Anzahl der Elemente aller Listen in MyLetter angezeigt.

i = 1
Set myDoc = Documents("MyLetter.doc")
For Each li In myDoc.Lists
    Msgbox "List " & i & " has " _
        & li.CountNumberedItems & " items."
    i = i + 1
Next li

In diesem Beispiel wird die Anzahl der LISTNUM-Felder in der Variablen myRange gezählt. Das Ergebnis wird in einem Meldungsfeld angezeigt.

Set myDoc = ActiveDocument
Set myRange = _
    myDoc.Range(Start:=myDoc.Paragraphs(12).Range.Start, _
    End:=myDoc.Paragraphs(50).Range.End)
numfields = myRange.ListFormat.CountNumberedItems(wdNumberListNum)
Msgbox numfields


CreateAutoTextEntry-Methode

Fügt der AutoTextEntries-Auflistung basierend auf der aktuellen Markierung ein neues AutoTextEntry-Objekt hinzu.

Syntax

Ausdruck.CreateAutoTextEntry(Name, StyleName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Name String erforderlich. Der vom Benutzer einzugebende Text zum Aufrufen des neuen AutoText-Eintrags.

StyleName String erforderlich. Die Kategorie, in der der neue AutoText-Eintrag im Menü AutoText aufgeführt wird.


Beispiel zur CreateAutoTextEntry-Methode

In diesem Beispiel wird ein neuer AutoText-Eintrag mit der Bezeichnung "handdel" erstellt. Dieser wird in der Kategorie "Mailing Instructions" aufgeführt. Hierbei wird angenommen, dass "HAND DELIVERY" der aktuell markierte Text ist.

Selection.CreateAutoTextEntry "handdel", _
    "Mailing Instructions"


CreateDataSource-Methode

Erstellt ein Word-Dokument, in dem Seriendruckdaten in einer Tabelle gespeichert werden. Die neue Datenquelle wird an das angegebene Dokument angehängt, das dadurch - falls noch nicht geschehen - zum Hauptdokument wird.

Syntax

Ausdruck.CreateDataSource(Name, PasswordDocument, WritePasswordDocument, HeaderRecord, MSQuery, SQLStatement, SQLStatement1, Connection, LinkToSource)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Name Variant optional. Der Pfad- und Dateiname der neuen Datenquelle.

PasswordDocument Variant optional. Das Kennwort, mit dem die neue Datenquelle geöffnet wird.

WritePasswordDocument Variant optional. Das nötige Kennwort, um Änderungen der Datenquelle zu speichern.

HeaderRecord Variant optional. Feldnamen für den Steuerdatensatz. Wenn Sie dieses Argument auslassen, wird der Standard-Steuerdatensatz verwendet: "Titel, Vorname, Name, Position, Firma, Adresse1, Adresse2, Postleitzahl, Ort, Bundesland, Land, Tel_privat, Tel_geschäftlich". Trennen Sie die Feldnamen mit dem Listentrennzeichen, das Sie unter Ländereinstellungen in der Systemsteuerung festgelegt haben.

MSQuery Variant optional. True, um Microsoft Query zu laden, wenn es installiert wurde. Die FileName-, PasswordDoc- und HeaderRecord-Argumente werden ignoriert.

SQLStatement Variant optional. Definiert Abfrageoptionen zum Laden von Daten.

SQLStatement1 Variant optional. Bei Abfragezeichenfolgen von mehr als 255 Zeichen bestimmen Sie mit SQLStatement den ersten Teil der Zeichenfolge und mit SQLStatement1 den zweiten.

Connection Variant optional. Ein Bereich, auf dem die Abfrage ausgeführt wird, die Sie mit SQLStatement bestimmen. Wie Sie den Bereich festlegen, hängt davon ab, wie Daten geladen werden. Zum Beispiel:

  • Bei Daten, die Sie mit ODBC laden, legen Sie eine Verbindungszeichenfolge fest.

  • Bei Daten, die Sie aus Microsoft Excel mit dynamischem Datenaustausch (DDE) laden, bestimmen Sie einen benannten Bereich.

  • Wenn Sie Daten aus Microsoft Access laden, verwenden Sie die Begriffe "Tabelle" oder "Abfrage", gefolgt vom Namen der Tabelle oder Abfrage.

LinkToSource Variant optional. True, um die Abfrage bei jedem Öffnen des Hauptdokuments durchzuführen, die durch Connection und SQLStatement festgelegt wird.


Beispiel zur CreateDataSource-Methode

In diesem Beispiel wird ein neues Datenquellendokument "Data.doc" erstellt und als Datenquelle an das aktive Dokument angehängt. Die neue Datenquelle enthält eine Tabelle mit fünf Spalten mit den Feldnamen, die mit dem HeaderRecord-Argument bestimmt werden.

ActiveDocument.MailMerge.CreateDataSource _
    Name:="C:\My Documents\Data.doc", _
    HeaderRecord:="Name, Address, City, State, Zip"


CreateHeaderSource-Methode

Erstellt ein Word-Dokument, in dem ein Steuerdatensatz gespeichert wird, der bei einem Seriendruck den Steuerdatensatz in der Datenquelle ersetzt. Diese Methode ordnet die neue Steuersatzquelle dem angegebenen Dokument zu. Das Dokument wird zum Hauptdokument, falls es noch kein Hauptdokument ist.

Hinweis Die neue Steuersatzquelle ordnet Seriendruckfeldnamen in einer Tabelle.

Syntax

Ausdruck.CreateHeaderSource(Name, PasswordDocument, WritePasswordDocument, HeaderRecord)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Name String erforderlich. Der Pfad- und Dateiname der neuen Steuersatzquelle.

PasswordDocument Variant optional. Das Kennwort, mit dem die neue Steuersatzquelle geöffnet wird.

WritePasswordDocument Variant optional. Das nötige Kennwort, um Änderungen der Steuersatzquelle zu speichern.

HeaderRecord Variant optional. Eine Zeichenfolge, die die Feldnamen des Steuerdatensatzes festlegt. Wenn Sie dieses Argument auslassen, wird der Standard-Steuerdatensatz verwendet: "Titel, Vorname, Name, Position, Firma, Adresse1, Adresse2, Postleitzahl, Ort, Bundesland, Land, Tel_privat, Tel_geschäftlich." Trennen Sie die Feldnamen unter Windows mit dem Listentrennzeichen, das Sie unter Ländereinstellungen in der Systemsteuerung festgelegt haben.


Beispiel zur CreateHeaderSource-Methode

In diesem Beispiel wird eine Steuersatzquelle mit fünf Feldnamen erzeugt und die neue Steuersatzquelle "Header.doc" wird dem aktiven Dokument zugeordnet.

ActiveDocument.MailMerge.CreateHeaderSource Name:="Header.doc", _
    HeaderRecord:="Name, Address, City, State, Zip"

In diesem Beispiel wird eine Steuersatzquelle für das Dokument "Main.doc" erzeugt (mit dem Standard-Steuerdatensatz) und die Datenquelle "Data.doc" geöffnet.

With Documents("Main.doc").MailMerge
    .CreateHeaderSource Name:="Fields.doc"
    .OpenDataSource Name:="C:\My Documents\Data.doc"
End With


CreateLetterContent-Methode

Erstellt auf Grundlage der angegebenen Briefelemente ein LetterContent-Objekt und gibt es zurück.

Syntax

Ausdruck.CreateLetterContent(DateFormat, IncludeHeaderFooter, PageDesign, LetterStyle, Letterhead, LetterheadLocation, LetterheadSize, RecipientName, RecipientAddress, Salutation, SalutationType, RecipientReference, MailingInstructions, AttentionLine, Subject, CCList, ReturnAddress, SenderName, Closing, SenderCompany, SenderJobTitle, SenderInitials, EnclosureNumber, InfoBlock, RecipientCode, RecipientGender, ReturnAddressShortForm, SenderCity, SenderCode, SenderGender, SenderReference)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

DateFormat String erforderlich. Das Datum für den Brief.

IncludeHeaderFooter Boolean erforderlich. True, um eine Kopf- und Fußzeile aus der Vorlage zu übernehmen.

PageDesign String erforderlich. Der Name der mit dem Dokument verbundenen Dokumentvorlage.

LetterStyle Long erforderlich. Das Layout des Dokuments. Dabei kann es sich um eine der folgenden WdLetterStyle-Konstanten handeln: wdFullBlock, wdModifiedBlock oder wdSemiBlock.

Letterhead Boolean erforderlich. True, um Platz für einen gedruckten Briefkopf zu reservieren.

LetterheadLocation Long erforderlich. Die Position des gedruckten Briefkopfs. Dabei kann es sich um eine der folgenden WdLetterheadLocation-Konstanten handeln: wdLetterBottom, wdLetterLeft, wdLetterRight oder wdLetterTop.

LetterheadSize Single erforderlich. Die Größe des Platzes (in Punkt), der für den gedruckten Briefkopf reserviert wird.

RecipientName String erforderlich. Der Name des Empfängers.

RecipientAddress String erforderlich. Die Postanschrift des Empfängers.

Salutation String erforderlich. Der Text der Briefanrede.

SalutationType Long erforderlich. Der Typ der Briefanrede. Dabei kann es sich um eine der folgenden WdSalutationType-Konstanten handeln: wdSalutationBusiness, wdSalutationFormat, wdSalutationInformal oder wdSalutationOther.

RecipientReference String erforderlich. Die Referenztextzeile des Briefes (z. B. "Betrifft:").

MailingInstructions String erforderlich. Der Text für die Versandanweisungen des Briefes (z. B. "Einschreiben").

AttentionLine String erforderlich. Der Text für die Betreffzeile.

Subject String erforderlich. Der Text für das Thema des angegebenen Briefs.

CCList String erforderlich. Die Namen der Personen, die eine Kopie (CC) des Briefes erhalten sollen.

ReturnAddress String erforderlich. Der Text der Absenderadresse für den Brief.

SenderName String erforderlich. Der Name der Person, die den Brief versendet.

Closing String erforderlich. Der Text für den Briefschluss.

SenderCompany String erforderlich. Der Firmenname des Absenders.

SenderJobTitle String erforderlich. Die Position des Absenders.

SenderInitials String erforderlich. Die Initialen des Absenders.

EnclosureNumber Long erforderlich. Die Anzahl der Anlagen für den Brief.

InfoBlock Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

RecipientCode Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

RecipientGender Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

ReturnAddressShortForm Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

SenderCity Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

SenderCode Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

SenderGender Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

SenderReference Variant optional. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.


Beispiel zur CreateLetterContent-Methode

Im folgenden Beispiel wird mit der CreateLetterContent-Methode ein neues LetterContent-Objekt im aktiven Dokument erstellt, und anschließend wird dieses Objekt mit der RunLetterWizard-Methode verwendet.

Set myLetter = ActiveDocument _
    .CreateLetterContent(DateFormat:="July 31, 1996", _
    IncludeHeaderFooter:=False, PageDesign:="", _
    LetterStyle:=wdFullBlock, Letterhead:=True, _
    LetterheadLocation:=wdLetterTop, _
    LetterheadSize:=InchesToPoints(1.5), _
    RecipientName:="Dave Edson", _
    RecipientAddress:="436 SE Main St." & vbCr _
    & "Bellevue, WA 98004", _
    Salutation:="Dear Dave,", _
    SalutationType:=wdSalutationInformal, _
    RecipientReference:="", MailingInstructions:="", _
    AttentionLine:="", Subject:="End of year report", _
    CCList:="", ReturnAddress:="", _
    SenderName:="", Closing:="Sincerely yours,", _
    SenderCompany:="", SenderJobTitle:="", _
    SenderInitials:="", EnclosureNumber:=0)
ActiveDocument.RunLetterWizard LetterContent:=myLetter


CreateNewDocument-Methode

Syntax 1: Erstellt ein neues, mit dem angegebenen Hyperlink verknüpftes Dokument. Gibt ein Document-Objekt zurück.

Syntax 2: Erstellt ein neues Etikettendokument mit den Standardetikettenoptionen oder von Ihnen angegebenen Optionen. Gibt ein Document-Objekt zurück.

Syntax 1

Ausdruck.CreateNewDocument(FileName, EditNow, Overwrite)

Syntax 2

Ausdruck.CreateNewDocument(Name, Address, AutoText, ExtractAddress, LaserTray)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein MailingLabel-Objekt zurückgibt.

FileName String erforderlich. Der Dateiname des angegebenen Dokuments.

EditNow Boolean erforderlich. True, wenn das angegebene Dokument unmittelbar in der ihm zugeordneten Bearbeitungsumgebung geöffnet werden soll. Der Standardwert ist True.

Overwrite Boolean erforderlich. True, wenn ein gegebenenfalls vorhandenes Dokument mit dem gleichen Namen im selben Ordner überschrieben werden soll. False, wenn eine vorhandene Datei mit dem gleichen Namen beibehalten werden soll und das FileName-Argument einen neuen Dateinamen angibt. Der Standardwert ist False.

Name Variant optional. Der Name des Adressetiketts.

Address Variant optional. Der Text für das Adressetikett.

AutoText Variant optional. Der Name des AutoText-Eintrags mit dem Text für das Adressetikett.

ExtractAddress Variant optional. True, um anstelle des Address-Arguments den Adresstext zu benutzen, der mit der benutzerdefinierten Textmarke "EnvelopeAddress" markiert ist.

LaserTray Variant optional. Die Papierzufuhr für Laserdrucker. Dabei kann es sich um eine der folgenden WdPaperTray-Konstanten handeln:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormatBin

wdPrinterTractorFeed

wdPrinterUpperBin


Beispiel zur CreateNewDocument-Methode

In diesem Beispiel wird auf der Grundlage des neuen Hyperlinks im ersten Dokument ein neues Dokument erstellt und dieses anschließend zur Bearbeitung in Microsoft Word geladen. Das Dokument heißt Overview.doc; eine gegebenenfalls vorhandene Datei mit gleichem Namen im Ordner \\Server1\Annual wird überschrieben.

With Documents(1)
    Set objHyper = _
        .Hyperlinks.Add(Anchor:=Selection.Range, _
        Address:="\\Server1\Annual\Overview.doc")
    objHyper.CreateNewDocument _
        FileName:="\\Server1\Annual\Overview.doc", _
        EditNow:=True, Overwrite:=True
End With

In diesem Beispiel wird ein neues Avery 2160-Etikettendokument mit einer vordefinierten Adresse angelegt.

addr = "Dave Edson" & vbCr & "123 Skye St." _
    & vbCr & "Our Town, WA  98004"
Application.MailingLabel.CreateNewDocument _
    Name:="2160 mini", Address:=addr, ExtractAddress:=False

In diesem Beispiel wird ein neues Avery 5664-Versandetikettendokument mit dem gewählten Text als Adresse erstellt.

addr = Selection.Text
Application.MailingLabel.CreateNewDocument _
    Name:="5664", Address:=addr, _
    LaserTray:=wdPrinterUpperBin

In diesem Beispiel wird ein neues selbstklebendes Etikettendokument mit dem Text der Textmarke "BriefumschlagAdresse" erstellt.

If ActiveDocument.Bookmarks.Exists("EnvelopeAddress") = True Then
    Application.MailingLabel.CreateNewDocument _
        Name:="Self Adhesive Tab 1 1/2""", ExtractAddress:=True
End If


CreateTextbox-Methode

Zieht ein standardgroßes Textfeld um die Auswahl. Wenn es sich bei der Auswahl um eine Einfügemarke handelt, ändert diese Methode den Zeiger in ein Fadenkreuz, damit der Benutzer das Textfeld zeichnen kann.

Syntax

Ausdruck.CreateTextbox

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Anmerkungen

Diese Methode hat dieselben Auswirkungen wie das Klicken auf die Schaltfläche Textfeld auf der Symbolleiste Zeichnen. Ein Textfeld ist ein Rechteck mit einem verbundenen Textpositionsrahmen.


Beispiel zur CreateTextbox-Methode

In diesem Beispiel wird ein Textfeld um die Auswahl gezogen und anschließend die Linienart des Textfelds geändert.

If Selection.Type = wdSelectionNormal Then
    Selection.CreateTextbox
    Selection.ShapeRange(1).Line.DashStyle =msoLineDashDot
End If


CustomDrop-Methode

Legt den vertikalen Abstand (in Punkt) der Kante des Rechtecks fest, das den Textbereich begrenzt, von der Stelle, an der die Legendenlinie am Textfeld ansetzt. Dieser Abstand wird von der oberen Kante des Textfelds gemessen, außer wenn die AutoAttach-Eigenschaft auf True festgelegt ist und das Textfeld sich links vom Ursprung der Legendenlinie (der Stelle, auf die die Legende hinweist) befindet. In diesem Fall wird der Abstand des Ansatzes von der unteren Kante des Textfelds gemessen.

Syntax

Ausdruck.CustomDrop(Drop)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Drop Single erforderlich. Der Ansatzabstand, in Punkt.

Anmerkungen

Wenn die PresetDrop-Methode vorher zum Festlegen des Ansatzes für die angegebene Legende verwendet wurde, verwenden Sie die Anweisung PresetDrop msoCalloutDropCustom, bevor Sie die CustomDrop-Methode anwenden, so dass die benutzerdefinierte Einstellung des Ansatzes wirksam wird.


Beispiel zur CustomDrop-Methode

In diesem Beispiel wird in myDocument ein voreingestellter Ansatz annulliert, der für Form eins festgelegt wurde, der benutzerdefinierte Ansatzabstand auf 14 Punkt festgelegt und spezifiziert, dass der Ansatzabstand immer von oben gemessen wird. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    .PresetDrop msoCalloutDropCustom
    .CustomDrop 14
    .AutoAttach = False
End With


CustomLength-Methode

Spezifiziert, dass das erste Segment der Legendenlinie (das Segment, das am Legendentextfeld ansetzt) immer eine feste Länge beibehält, wenn die Legende verschoben wird. Verwenden Sie die AutomaticLength-Methode zum Spezifizieren, dass das erste Segment der Legendenlinie immer automatisch skaliert wird, wenn die Legende verschoben wird. Betrifft nur Legenden, deren Linien aus mehr als einem Segment bestehen (die Typen msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.CustomLength(Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Length Single erforderlich. Die Länge des ersten Segments der Legende, in Punkt.

Anmerkungen

Durch die Anwendung dieser Methode wird die AutoLength-Eigenschaft auf False eingestellt und die Length-Eigenschaft auf den Wert, der für das Argument Length angegeben wird.


Beispiel zur CustomLength-Methode

In diesem Beispiel wird in myDocument für die Legendenlinie für Form eins zwischen der automatischen Skalierung und derjenigen mit fester Länge des ersten Segments umgeschaltet. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


Cut-Methode

Entfernt das angegebene Objekt aus dem Dokument und platziert es in die Zwischenablage.

Syntax

Ausdruck.Cut

Ausdruck Erforderlich. Ein Ausdruck, der ein Field-, FormField-, Frame-, MailMergeField-, PageNumber-, Range- oder Selection-Objekt zurückgibt.

Anmerkungen

Wenn Ausdruck ein Range- oder Selection-Objekt zurückgibt, wird der Inhalt des Objekts in die Zwischenablage ausgeschnitten, aber das reduzierte Objekt bleibt im Dokument.


Beispiel zur Cut-Methode

In diesem Beispiel wird das erste Feld im aktiven Dokument ausgeschnitten und an der Einfügemarke eingefügt.

If ActiveDocument.Fields.Count >= 1 Then
    ActiveDocument.Fields(1).Cut
    Selection.Collapse Direction:=wdCollapseEnd
    Selection.Paste
End If

In diesem Beispiel wird im ersten Absatz das erste Wort ausgeschnitten und am Ende des Absatzes eingefügt.

With ActiveDocument.Paragraphs(1).Range
    .Words(1).Cut
    .Collapse Direction:=wdCollapseEnd
    .Move Unit:=wdCharacter, Count:=-1
    .Paste
End With

In diesem Beispiel wird der Inhalt der Markierung ausgeschnitten und in ein neues Dokument eingefügt.

If Selection.Type = wdSelectionNormal Then
    Selection.Cut
    Documents.Add.Content.Paste
End If


DataForm-Methode

Zeigt das Dialogfeld Datenmaske an, in dem Sie Datensätze hinzufügen, löschen oder ändern können.

Hinweis Sie können diese Methode für Seriendruck-Hauptdokumente, Seriendruck-Datenquellen oder beliebige Dokumente einsetzen, die durch Tabellenzellen oder Trennzeichen getrennte Daten enthalten.

Syntax

Ausdruck.DataForm

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur DataForm-Methode

Dieses Beispiel zeigt das Dialogfeld DataForm an, wenn das aktive Dokument ein Seriendruck-Dokument ist.

If ActiveDocument.MailMerge.State <> wdNormalDocument Then
    ActiveDocument.DataForm
End If

In diesem Beispiel wird in einem neuen Dokument eine Tabelle erstellt und dann das Dialogfeld Data Form angezeigt.

Set aDoc = Documents.Add
With aDoc
    .Tables.Add Range:=aDoc.Content, NumRows:=2, NumColumns:=2
    .Tables(1).Cell(1, 1).Range.Text = "Name"
    .Tables(1).Cell(1, 2).Range.Text = "Age"
    .DataForm
End With


DDEExecute-Methode

Sendet einen Befehl oder eine Befehlsfolge durch den angegebenen DDE-Kanal (DDE = Dynamic Data Exchange/Dynamischer Datenaustausch) zu einer Anwendung.

Syntax

Ausdruck.DDEExecute(Channel, Command)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

Command String erforderlich. Ein Befehl oder eine Befehlsfolge, die von der empfangenden Anwendung (dem DDE-Server) erkannt wird. Wenn die empfangende Anwendung den angegebenen Befehl nicht ausführen kann, tritt ein Fehler auf.


Beispiel zur DDEExecute-Methode

In diesem Beispiel wird ein neues Tabellenblatt in Microsoft Excel angelegt. Die XLM-Makro-Anweisung zum Anlegen eines neuen Tabellenblatts ist New(1).

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[New(1)]"
DDETerminate Channel:=chan

In diesem Beispiel wird das Microsoft Excel-Makro "Macro1" in Personal.xls ausgeführt.

aChan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=aChan, Command:="[Run(" & Chr(34) & _
    "Personal.xls!Macro1" & Chr(34) & ")]"
DDETerminate Channel:=aChan


DDEInitiate-Methode

Öffnet einen DDE-Kanal (DDE = Dynamic Data Exchange/Dynamischer Datenaustausch) zu einer anderen Anwendung und gibt die Kanalnummer zurück.

Syntax

Ausdruck.DDEInitiate(App, Topic)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

App String erforderlich. Der Name der Anwendung.

Topic String erforderlich. Der Name eines DDE-Themas – beispielsweise der Name eines geöffneten Dokuments – das von der Anwendung erkannt wird, zu der Sie gerade einen Kanal öffnen.

Anmerkungen

Bei erfolgreicher Ausführung gibt die DDEInitiate-Methode die Nummer des geöffneten Kanals zurück. Alle nachfolgenden DDE-Funktionen verwenden diese Nummer zur Angabe des Kanals.


Beispiel zur DDEInitiate-Methode

In diesem Beispiel wird eine DDE-Konversation mit dem Thema System initiiert und die Microsoft Excel-Arbeitsmappe Sales.xls geöffnet. In dem Beispiel wird der DDE-Kanal geschlossen, ein Kanal zu Sales.xls initiiert, und Text in die Zelle R1C1 eingefügt.

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[OPEN(" & Chr(34) _
    & "C:\Sales.xls" & Chr(34) & ")]
DDETerminate Channel:=chan
chan = DDEInitiate(App:="Excel", Topic:="Sales.xls")
DDEPoke Channel:=chan, Item:="R1C1", Data:="1996 Sales"
DDETerminate Channel:=chan


DDEPoke-Methode

Verwendet einen geöffneten DDE-Kanal (DDE = Dynamic Data Exchange/Dynamischer Datenaustausch) zum Senden von Daten zu einer Anwendung.

Syntax

Ausdruck.DDEPoke(Channel, Item, Data)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

Item String erforderlich. Das Element innerhalb eines DDE-Themas, zu dem die angegebenen Daten gesendet werden sollen.

Data String erforderlich. Die Daten, die zur empfangenden Anwendung (dem DDE-Server) gesendet werden sollen.

Anmerkungen

Wenn die DDEPoke-Methode nicht erfolgreich ist, tritt ein Fehler auf.


Beispiel zur DDEPoke-Methode

In diesem Beispiel wird die Microsoft Excel-Arbeitsmappe Sales.xls geöffnet und "1996 Sales" in die Zelle R1C1 eingefügt.

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[OPEN(" & Chr(34) _
    & "C:\Sales.xls" & Chr(34) & ")]
DDETerminate Channel:=chan
chan = DDEInitiate(App:="Excel", Topic:="Sales.xls")
DDEPoke Channel:=chan, Item:="R1C1", Data:="1996 Sales"
DDETerminate Channel:=chan


DDERequest-Methode

Verwendet einen geöffneten DDE-Kanal (DDE = Dynamic Data Exchange/Dynamischer Datenaustausch), um Informationen von der empfangenden Anwendung anzufordern, und gibt die Informationen als Zeichenfolge zurück.

Syntax

Ausdruck.DDERequest(Channel, Item)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

Item String erforderlich. Das Element, das angefordert werden soll.

Anmerkungen

Wenn Sie in der Server-Anwendung vom Thema Daten anfordern, müssen Sie das Element in dem Thema angeben, dessen Inhalt Sie abrufen. In Microsoft Excel sind beispielsweise Zellen zulässige Elemente, und Sie verweisen auf sie, indem Sie entweder das Format "R1C1" oder benannte Verweise verwenden.

Microsoft Excel und andere Anwendungen, die DDE unterstützen, erkennen ein Thema namens "System". Drei Standard-Elemente im Thema "System" werden in der folgenden Tabelle beschrieben. Beachten Sie, dass Sie eine Liste der anderen Elemente im Thema "System" erhalten können, wenn Sie das Element "SysItems" verwenden.

Element im Thema "System" | Wirkung
SysItems | Gibt eine Liste aller Elemente im Thema "System" zurück.
Topics | Gibt eine Liste aller verfügbaren Themen zurück.
Formats | Gibt eine Liste aller Zwischenablage-Formate zurück, die von Word unterstützt werden.


Beispiel zur DDERequest-Methode

In diesem Beispiel wird die Microsoft Excel-Arbeitsmappe Book1.xls geöffnet und der Inhalt von Zelle R1C1 abgerufen.

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[OPEN(" & Chr(34) _
    & "C:\My Documents\Book1.xls" & Chr(34) & ")]"
DDETerminate Channel:=chan
chan = DDEInitiate(App:="Excel", Topic:="Book1.xls")
MsgBox DDERequest(Channel:=chan, Item:="R1C1")
DDETerminateAll

In diesem Beispiel wird ein Kanal zum Thema "System" in Microsoft Excel geöffnet und dann das Element "Topics" verwendet, damit eine Liste der verfügbaren Themen zurückgegeben wird. In dem Beispiel wird die Themenliste, die alle geöffneten Arbeitsmappen enthält, nach der Markierung eingefügt.

aChan = DDEInitiate(App:="Excel", Topic:="System")
topicList = DDERequest(Channel:=aChan, Item:="Topics")
Selection.InsertAfter topicList
DDETerminate Channel:=aChan


DDETerminate-Methode

Schließt den angegebenen DDE-Kanal zu einer anderen Anwendung.

Syntax

Ausdruck.DDETerminate(Channel)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.


DDETerminateAll-Methode

Schließt alle DDE-Kanäle (DDE = Dynamic Data Exchange/Dynamischer Datenaustausch), die von Word geöffnet wurden. Diese Methode schließt keine Kanäle, die von Client-Anwendungen zu Word geöffnet wurden. Sie entspricht der Ausführung der DDETerminate-Methode für jeden geöffneten Kanal.

Syntax

Ausdruck.DDETerminateAll

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Hinweise

Wenn Sie ein Makro unterbrechen, das einen DDE-Kanal öffnet, könnten Sie versehentlich einen Kanal geöffnet lassen. Geöffnete Kanäle werden beim Beenden eines Makros nicht automatisch geschlossen, und jeder geöffnete Kanal verbraucht Systemressourcen. Deshalb empfiehlt es sich, diese Methode anzuwenden, wenn Sie in einem Makro, das einen oder mehrere DDE-Kanäle öffnet, Fehler beseitigen.


Beispiel zur DDETerminateAll-Methode

In diesem Beispiel wird die Microsoft Excel-Arbeitsmappe Book1.xls geöffnet, Text in die Zelle R2C3 eingefügt und die Arbeitsmappe gespeichert. Anschließend werden alle DDE-Kanäle geschlossen.

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[OPEN(" & Chr(34) & _
    "C:\My Documents\Book1.xls" & Chr(34) & ")]"
DDETerminate Channel:=chan
chan = DDEInitiate(App:="Excel", Topic:="Book1.xls")
DDEPoke Channel:=chan, Item:="R2C3", Data:="Hello World"
DDEExecute Channel:=chan, Command:="[Save]"
DDETerminateAll


DefaultWebOptions-Methode

Gibt das DefaultWebOptions-Objekt zurück. Dieses Objekt enthält globale Attribute auf Anwendungsebene, die von Microsoft Word verwendet werden, wenn Sie ein Dokument als Webseite speichern oder eine Webseite öffnen.

Syntax

Ausdruck.DefaultWebOptions

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur DefaultWebOptions-Methode

In diesem Beispiel wird überprüft, ob die Standardcodierung für das Dokument Western ist. Anschließend wird die Zeichenfolge strDocEncoding entsprechend eingestellt.

If Application.DefaultWebOptions.Encoding _
        = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Other"
End If


Delete-Methode

Syntax 1: Löscht das angegebene Objekt.

Syntax 2: Löscht eine oder mehrere Tabellenzellen und steuert die Verschiebung der übrigen Zellen.

Syntax 3: Löscht die angegebene Anzahl von Zeichen oder Wörtern. Diese Methode gibt einen Wert zurück, der die Anzahl der gelöschten Elemente angibt. Sie gibt 0 (Null) zurück, wenn der Löschvorgang nicht erfolgreich war.

Syntax 1

Ausdruck.Delete

Syntax 2

Ausdruck.Delete(ShiftCells)

Syntax 3

Ausdruck.Delete(Unit, Count)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Objekt der Liste zurückgibt, die erscheint, wenn Sie auf "Betrifft" klicken.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Cell- oder ein Cells-Objekt zurückgibt.

Syntax 3: Erforderlich. Ein Ausdruck, der ein Range- oder ein Selection-Objekt zurückgibt.

ShiftCells Variant optional. Die Richtung, in der die übrigen Zellen verschoben werden sollen. Dies kann eine der folgenden WdDeleteCells-Konstanten sein: wdDeleteCellsEntireColumn, wdDeleteCellsEntireRow, wdDeleteCellsShiftLeft oder wdDeleteCellsShiftUp.

Unit Variant optional. Die Einheit, die zum Löschen vor oder nach dem reduzierten Bereich oder der Markierung verwendet werden soll. Dies kann eine der folgenden WdUnits-Konstanten sein: wdCharacter oder wdWord. Der Standardwert ist wdCharacter.

Count Variant optional. Die Anzahl der zu löschenden Einheiten. Sie löschen Einheiten hinter dem Bereich oder markierten Abschnitt, indem Sie ihn reduzieren und eine positive Zahl verwenden. Wenn Sie Einheiten vor dem Bereich oder markierten Abschnitt löschen möchten, reduzieren Sie ihn und verwenden Sie eine negative Zahl.


Beispiel zur Delete-Methode

In diesem Beispiel wird die Markierung gelöscht.

Selection.Delete

In diesem Beispiel wird die Markierung reduziert, und die beiden Wörter hinter der Einfügemarke werden gelöscht.

Selection.Collapse Direction:=wdCollapseStart
Selection.Delete Unit:=wdWord, Count:=2

In diesem Beispiel wird myRange reduziert, und die beiden Zeichen vor der Einfügemarke werden gelöscht.

Set myRange = Selection.Words(1)
myRange.Collapse Direction:=wdCollapseStart
myRange.Delete Unit:=wdCharacter, Count:=-2

In diesem Beispiel wird die erste Zelle der ersten Tabelle im ersten Dokument gelöscht.

Documents(1).Tables(1).Cell(1, 1).Delete _
    ShiftCells:=wdDeleteCellsShiftLeft

Falls die Textmarke "temp" im aktiven Dokument enthalten ist, wird sie in diesem Beispiel gelöscht.

If ActiveDocument.Bookmarks.Exists("temp") Then
    ActiveDocument.Bookmarks("temp").Delete
End If

In diesem Beispiel wird die Formatvorlage "Intro" aus der Datei "Sales.doc" gelöscht. Für Absätze, die mit der Formatvorlage "Intro" formatiert sind, wird wieder die Formatvorlage Standard verwendet.

Documents("Sales.doc").Styles("Intro").Delete

In diesem Beispiel wird das erste Wort im aktiven Dokument gelöscht.

ActiveDocument.Words(1).Delete


DetectLanguage-Methode

Analysiert den angegebenen Text, um festzustellen, in welcher Sprache er geschrieben ist.

Syntax

Ausdruck.DetectLanguage

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-, Range- oder Selection-Objekt zurückgibt.

Hinweise

Die Ergebnisse der DetectLanguage-Methode werden Zeichen für Zeichen in der LanguageID-Eigenschaft gespeichert. Um die LanguageID-Eigenschaft zu lesen, müssen Sie zunächst eine Markierung oder einen Textbereich angeben.

Wenn DetectLanguage auf ein Document-Objekt bezogen ist, wird jeder verfügbare Text im Dokument überprüft (Kopfzeilen, Fußzeilen, Textfelder usw.). Wenn der angegebene Text einen unvollständigen Satz enthält, wird die Markierung oder der Bereich bis zum Ende des Satzes erweitert.

Wurde die DetectLanguage-Methode bereits auf den angegebenen Text angewendet, ist die LanguageDetected-Eigenschaft auf True eingestellt. Wenn Sie die Sprache des angegebenen Textes neu bewerten möchten, müssen Sie LanguageDetected zunächst auf False setzen.

Weitere Informationen über die automatische Spracherkennung finden Sie unter Automatische Spracherkennung.


Beispiel zur DetectLanguage-Methode

In diesem Beispiel wird die Sprache überprüft, in der das aktuelle Dokument geschrieben ist, und anschließend wird das Ergebnis angezeigt.

With ActiveDocument
    If .LanguageDetected = True Then
        x = MsgBox("This document has already " _
            & "been checked. Do you want to check " _
            & "it again?", vbYesNo)
        If x = vbYes Then
            .LanguageDetected = False
            .DetectLanguage
        End If
    Else
        .DetectLanguage
    End If
    If .Range.LanguageID = wdEnglishUS Then
        MsgBox "This is a U.S. English document."
    Else
        MsgBox "This is not a U.S. English document."
    End If
End With


Disable-Methode

Entfernt eine bestimmte Tastenkombination, wenn sie zur Zeit einem Befehl zugeordnet ist. Danach hat die Tastenkombination keine Auswirkungen mehr. Diese Methode hat dieselbe Wirkung wie Klicken auf die Schaltfläche Entfernen im Dialogfeld Tastatur anpassen (Menü Extras, Untermenü Anpassen).

Hinweis Verwenden Sie die Clear-Methode mit einem KeyBinding-Objekt, um einen integrierten Befehl auf die Standard-Tastenbelegung zurückzusetzen. Es ist nicht nötig, ein KeyBinding-Objekt zu entfernen oder erneut anzubinden, bevor Sie es an anderer Stelle hinzufügen.

Syntax

Ausdruck.Disable

Ausdruck Erforderlich. Ein Ausdruck, der ein KeyBinding-Objekt zurückgibt.


Beispiel zur Disable-Methode

In diesem Beispiel wird die Tastenzuordnung STRG+UMSCHALT+F entfernt. Diese Tastenkombination ist standardmäßig dem Befehl Fett zugeordnet.

CustomizationContext = NormalTemplate
FindKey(BuildKeyCode(wdKeyControl, wdKeyShift, wdKeyB)).Disable

In diesem Beispiel wird die Tastenkombination STRG+UMSCHALT+O dem Befehl Organisieren zugewiesen. Dann wird die Disable-Methode aufgerufen, um die Tastenkombination STRG+UMSCHALT+O zu entfernen, und eine Meldung wird angezeigt.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyO, _
    wdKeyControl, wdKeyShift), _
    KeyCategory:=wdKeyCategoryCommand, Command:="Organizer"
With FindKey(BuildKeyCode(wdKeyO, wdKeyControl, wdKeyShift))
    MsgBox .Command & " is assigned to CTRL+Shift+O"
    .Disable
    If .Command = "" Then MsgBox _
        "Nothing is assigned to CTRL+Shift+O"
End With

In diesem Beispiel werden alle Tastenzuordnungen aus dem globalen Makro "Macro1" entfernt.

CustomizationContext = NormalTemplate
For Each aKey In KeysBoundTo _
        (KeyCategory:=wdKeyCategoryMacro, Command:="Macro1")
    aKey.Disable
Next aKey


Display-Methode

Zeigt das angegebene, integrierte Word-Dialogfeld an, bis es vom Benutzer geschlossen wird oder die festgelegte Zeitspanne vergangen ist. Gibt ein Long zurück, das angibt, auf welche Schaltfläche geklickt wurde, um das Dialogfeld zu schließen.

Zurückgegebener Wert | Beschreibung
-2 | Die Schaltfläche Schließen.
-1 | Die Schaltfläche OK.
0 (Null) | Die Schaltfläche Abbrechen.
> 0 (Null) | Eine Befehlsschaltfläche: 1 ist die erste Schaltfläche, 2 ist die zweite usw.

Hinweis Aktionen oder Einstellungen, die während der Anzeige eines Dialogfelds mit dieser Methode initiiert bzw. festgelegt wurden, werden nicht umgesetzt. Verwenden Sie die Show-Methode, wenn Sie ein Dialogfeld anzeigen und Aktionen durchführen oder Einstellungen zuweisen möchten.

Syntax

Ausdruck.Display(TimeOut)

Ausdruck Erforderlich. Ein Ausdruck, der ein Dialog-Objekt zurückgibt.

TimeOut Variant optional. Die Zeitspanne, die Word vergehen lässt, bevor das Dialogfeld automatisch geschlossen wird. Eine Einheit entspricht etwa 0,001 Sekunden. Durch mehrere gleichzeitige Systemaktivitäten erhöht sich möglicherweise der effektive Zeitwert. Wird dieses Argument ausgelassen, wird das Dialogfeld geschlossen, wenn es der Benutzer schließt.


DisplayMoveDialog-Methode

Zeigt das Dialogfeld Verschieben an, in dem der Benutzer eine neue Stelle für die aktive E-Mail-Nachricht in einem zur Verfügung stehenden Nachrichtenspeicher angeben kann. Diese Methode ist nur verfügbar, wenn Sie Word als E-Mail-Editor verwenden.

Syntax

Ausdruck.DisplayMoveDialog

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur DisplayMoveDialog-Methode

In diesem Beispiel wird das Dialogfeld Verschieben für die aktive E-Mail-Nachricht angezeigt.

Application.MailMessage.DisplayMoveDialog


DisplayProperties-Methode

Zeigt das Dialogfeld Eigenschaften für die aktive E-Mail-Nachricht an. Diese Methode steht nur zur Verfügung, wenn Sie Word als E-Mail-Editor verwenden.

Syntax

Ausdruck.DisplayProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur DisplayProperties-Methode

In diesem Beispiel wird das Dialogfeld Eigenschaften für die aktive E-Mail-Nachricht angezeigt.

Application.MailMessage.DisplayProperties


DisplaySelectNamesDialog-Methode

Zeigt das Dialogfeld Namen auswählen an, in dem der Benutzer zu den Zeilen To:, Cc: und Bcc: in der aktiven, nicht abgeschickten E-Mail-Nachricht Adressen hinzufügen kann. Diese Methode steht nur zur Verfügung, wenn Sie Word als E-Mail-Editor verwenden.

Syntax

Ausdruck.DisplaySelectNamesDialog

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur DisplaySelectNamesDialog-Methode

In diesem Beispiel wird für die aktive E-Mail-Nachricht das Dialogfeld Namen auswählen angezeigt.

Application.MailMessage.DisplaySelectNamesDialog


Distribute-Methode

Verteilt Formen gleichzeitig im angegebenen Formenbereich. Sie legen fest, ob die Formen horizontal oder vertikal und ob sie über die ganze Seite oder nur über den Platz verteilt werden, den sie ursprünglich in Anspruch nahmen.

Syntax

Ausdruck.Distribute(DistributeCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

DistributeCmd Long erforderlich. Bestimmt, ob die Formen im Bereich horizontal oder vertikal verteilt werden. Dabei kann es sich um eine der folgenden MsoDistributeCmd-Konstanten handeln: msoDistributeHorizontally oder msoDistributeVertically.

RelativeTo Long erforderlich. True, um die Formen gleichmäßig über den gesamten horizontalen oder vertikalen Leerraum auf der Seite zu verteilen. False, um die Formen innerhalb des horizontalen oder vertikalen Leerraums zu verteilen, den der Formenbereich ursprünglich in Anspruch nahm.


DistributeHeight-Methode

Legt eine gleiche Höhe für die angegebenen Zeilen oder Zellen fest.

Syntax

Ausdruck.DistributeHeight

Ausdruck Erforderlich. Ein Ausdruck, der ein Cells- oder Rows-Objekt zurückgibt.


Beispiel zur DistributeHeight-Methode

In diesem Beispiel wird die Höhe der Zeilen in der ersten Tabelle so eingestellt, dass sie alle die gleiche Höhe haben.

ActiveDocument.Tables(1).Rows.DistributeHeight

In diesem Beispiel wird die Höhe der ersten drei Zeilen in der ersten Tabelle so eingestellt, dass sie alle die gleiche Höhe haben.

If ActiveDocument.Tables.Count >= 1 Then
    Set myRange = ActiveDocument.Range(Start:=ActiveDocument _
        .Tables(1).Rows(1).Range.Start, _
        End:=ActiveDocument.Tables(1).Rows(3).Range.End)
    myRange.Rows.DistributeHeight
End If


DistributeWidth-Methode

Legt die gleiche Breite für die angegebenen Spalten oder Zellen fest.

Syntax

Ausdruck.DistributeWidth

Ausdruck Erforderlich. Ein Ausdruck, der ein Cells oder Columns-Objekt zurückgibt.


Beispiel zur DistributeWidth-Methode

In diesem Beispiel wird die Breite der Spalten in der ersten Tabelle so eingestellt, dass alle gleich breit sind.

ActiveDocument.Tables(1).Columns.DistributeWidth

In diesem Beispiel wird die Breite der gewählten Zellen eingestellt.

If Selection.Cells.Count >= 2 Then
    Selection.Cells.DistributeWidth
End If


DoClick-Methode

Klickt auf das angegebene Feld. Wenn es sich bei dem Feld um ein GOTOBUTTON-Feld handelt, verschiebt diese Methode die Einfügemarke zur angegebenen Position oder wählt die angegebene Textmarke. Wenn es sich bei dem Feld um ein MACROBUTTON-Feld handelt, ruft diese Methode das angegebene Makro auf. Wenn es sich bei dem Feld um ein HYPERLINK-Feld handelt, springt diese Methode zur Zielposition.

Syntax

Ausdruck.DoClick

Ausdruck Erforderlich. Ein Ausdruck, der ein Field-Objekt zurückgibt.


Beispiel zur DoClick-Methode

Wenn es sich beim ersten Feld in der Auswahl um ein GOTOBUTTON-Feld handelt, wird in diesem Beispiel auf das Feld geklickt (die Einfügemarke wird zur angegebenen Position bewegt, oder die angegebene Textmarke wird gewählt).

Set myField = Selection.Fields(1)
If myField.Type = wdFieldGoToButton Then myField.DoClick


DoVerb-Methode

Fordert, dass ein OLE-Objekt eines seiner verfügbaren Verben (die Aktionen, die ein OLE-Objekt durchführt, um seinen Inhalt zu aktivieren) ausführt. Jedes OLE-Objekt unterstützt einen Satz von Verben, die zu diesem Objekt gehören.

Syntax

Ausdruck.DoVerb(VerbIndex)

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEFormat-Objekt zurückgibt.

VerbIndex Variant optional. Das Verb, das das OLE-Objekt ausführen soll. Wenn dieses Argument weggelassen wird, wird das Standardverb gesendet. Wenn das OLE-Objekt das angeforderte Verb nicht unterstützt, tritt ein Fehler auf. Dies kann eine der WdOLEVerb-Konstanten sein.

Konstante | Beschreibung
wdOLEVerbPrimary | Führt das Verb aus, das aufgerufen wird, wenn der Benutzer auf das Objekt doppelklickt.
wdOLEVerbShow | Zeigt dem Benutzer das Objekt zum Bearbeiten oder zur Ansicht. Verwenden Sie diese Konstante zum Anzeigen eines neu eingefügten Objekts, wenn es erstmalig bearbeitet werden soll.
wdOLEVerbOpen | Öffnet das Objekt in einem separaten Fenster.
wdOLEVerbHide | Entfernt die Benutzeroberfläche des Objekts aus der Ansicht.
wdOLEVerbUIActivate | Aktiviert das betreffende Objekt und zeigt alle Hilfsmittel der Benutzeroberfläche an, die das Objekt benötigt, z. B. Menüs oder Symbolleisten.
wdOLEVerbInPlaceActivate | Führt das Objekt aus und installiert dessen Fenster, aber installiert keine Hilfsmittel der Benutzeroberfläche.
wdOLEVerbDiscardUndoState | Zwingt das Objekt, jeden Rückgängig-Zustand aufzugeben, den es möglicherweise aufrechterhält; beachten Sie, dass das Objekt aber aktiv bleibt.


Beispiel zur DoVerb-Methode

In diesem Beispiel wird im aktiven Dokument das Standard-Verb zum Server für das erste bewegliche OLE-Objekt gesandt.

ActiveDocument.Shapes(1).OLEFormat.DoVerb


Duplicate-Methode

Erstellt ein Duplikat des angegebenen Shape- oder ShapeRange-Objekts, fügt den neuen Bereich von Formen um einen Standard-Offset von den ursprünglichen Formen versetzt zur Shapes-Auflistung hinzu, und gibt dann das neue Shape-Objekt zurück.

Syntax

Ausdruck.Duplicate

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.


Beispiel zur Duplicate-Methode

In diesem Beispiel wird im aktiven Dokument ein Duplikat von Form eins erstellt und dann die Füllung für die neue Form geändert.

Set newShape = ActiveDocument.Shapes(1).Duplicate
With newShape
    .Fill.PresetGradient msoGradientVertical, 1, msoGradientGold
End With


Edit-Methode

Öffnet das angegebene OLE-Objekt zum Bearbeiten in der Anwendung, in der es erstellt wurde.

Syntax

Ausdruck.Edit

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEFormat-Objekt zurückgibt.


EditDataSource-Methode

Öffnet die Seriendruckdatenquelle oder wechselt zu dieser Datei.

Syntax

Ausdruck.EditDataSource

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Hinweise

Wenn es sich bei der Datenquelle um ein Word-Dokument handelt, öffnen Sie mit dieser Methode die Datenquelle (oder Sie aktivieren eine bereits offene Datenquelle).

Wenn Word mit Hilfe des dynamischen Datenaustausches auf die Daten (DDE) zugreift, z. B. über Microsoft Excel oder Microsoft Access, wird mit dieser Methode die Datenquelle angezeigt, die sich im Programm befindet.

Wenn Word über eine ODBC-Verbindung auf Daten zugreift, werden die Daten in einem Word-Dokument angezeigt. Ist Microsoft Query installiert, erscheint eine Meldung, und Sie haben die Möglichkeit, Microsoft Query anzuzeigen, anstatt die Daten zu konvertieren.


Beispiel zur EditDataSource-Methode

Dieses Beispiel öffnet oder aktiviert die Datenquelle, die dem Dokument "Sales.doc" zugeordnet ist.

Documents("Sales.doc").MailMerge.EditDataSource

In diesem Beispiel wird die zugeordnete Datenquelle geöffnet oder aktiviert, wenn es sich dabei um ein Word-Dokument handelt.

Set myDataSource = ActiveDocument.MailMerge.DataSource
If myDataSource.Type = wdMergeInfoFromWord Then
    ActiveDocument.MailMerge.EditDataSource
End If


EditHeaderSource-Methode

Öffnet die Steuersatzquelle, die einem Seriendruck-Hauptdokument zugeordnet wurde oder aktiviert eine bereits offene Steuersatzquelle.

Hinweis Wenn das Seriendruck-Hauptdokument über keine Steuersatzquelle verfügt, verursacht diese Methode einen Fehler.

Syntax

Ausdruck.EditHeaderSource

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.


Beispiel zur EditHeaderSource-Methode

In diesem Beispiel wird eine Steuersatzquelle dem aktiven Dokument zugeordnet und geöffnet.

With ActiveDocument.MailMerge
    .MainDocumentType = wdFormLetters
    .OpenHeaderSource Name:="C:\My Documents\Header.doc"
    .EditHeaderSource
End With

In diesem Beispiel wird die Steuersatzquelle geöffnet, wenn dem aktiven Dokument eine Steuersatzdatei zugeordnet wurde.

Set MM = ActiveDocument.MailMerge
If MM.State = wdMainAndSourceAndHeader Or _
        MM.State = wdMainAndHeader Then
    MM.EditHeaderSource
End If


EditMainDocument-Methode

Aktiviert das Seriendruckhauptdokument, das der angegebenen Datensatzquelle oder Datenquelle zugeordnet ist.

Hinweis Ein Fehler tritt auf, wenn das Hauptdokument nicht geöffnet ist. Verwenden Sie die Open-Methode, wenn das Hauptdokument zur Zeit nicht geöffnet ist.

Syntax

Ausdruck.EditMainDocument

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.


Beispiel zur EditMainDocument-Methode

Dieses Beispiel versucht, das Hauptdokument zu aktivieren, das der aktiven Datenquelle zugeordnet ist. Wenn das Hauptdokument nicht offen ist, erscheint das Dialogfeld Öffnen und eine Meldung in der Statusleiste.

On Error GoTo errorhandler
Documents("Data.doc").MailMerge.EditMainDocument
errorhandler:
If Err = 4605 Then StatusBar = "Main document is not open"
Dialogs(wdDialogFileOpen).Show


EditType-Methode

Legt Optionen für das angegebene Textformularfeld fest.

Syntax

Ausdruck.EditType(Type, Default, Format, Enabled)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextInput-Objekt zurückgibt.

Type Long erforderlich. Der Textfeldtyp. Dies kann eine der folgenden WdTextFormFieldType-Konstanten sein: wdCalculationText, wdCurrentDateText, wdCurrentTimeText, wdDateText, wdNumberText oder wdRegularText.

Default Variant optional. Der Standardtext, der im Textfeld erscheint.

Format Variant optional. Die Format-Zeichenfolge, die zum Formatieren des Texts, der Zahl oder des Datums verwendet wird (beispielsweise "0,00", "Erster Buchstabe gross" oder "dd-MM-yyyy"). Weitere Beispiele für Formate finden Sie in der Formatliste für den angegebenen Textformularfeldtyp im Dialogfeld Optionen für Felder.

Enabled Variant optional. True, wenn das Formularfeld für Texteingabe aktiviert werden soll.


Beispiel zur EditType-Methode

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Textformularfeld "Today" hinzugefügt. Die EditType-Methode wird zum Festlegen des Typs auf wdCurrentDateText und zum Festlegen des Datumformats auf "M/d/yy" verwendet.

With ActiveDocument.FormFields.Add _
        (Range:=ActiveDocument.Range(0, 0), _
        Type:=wdFieldFormTextInput)
    .Name = "Today"
    .TextInput.EditType Type:=wdCurrentDateText, _
        Format:="M/d/yy", Enabled:=False
End With


Enable-Methode

Formatiert das erste Zeichen im angegebenen Absatz als Initialbuchstaben.

Syntax

Ausdruck.Enable

Ausdruck Erforderlich. Ein Ausdruck, der ein DropCap-Objekt zurückgibt.


Beispiel zur Enable-Methode

In diesem Beispiel wird der erste Absatz in der Markierung so formatiert, dass er mit einem Initialbuchstaben beginnt.

With Selection.Paragraphs(1).DropCap
    .Enable
    .LinesToDrop = 2
    .FontName = "Arial"
End With


EndKey-Methode

Verschiebt oder erweitert die Auswahl bis zum Ende der angegebenen Einheit. Diese Methode gibt eine ganze Zahl zurück, die die Anzahl der Zeichen angibt, um die die Auswahl oder das aktive Ende tatsächlich verschoben wurden, oder sie gibt 0 (Null) zurück, wenn die Verschiebung fehlschlug.

Hinweis Diese Methode entspricht der Funktionalität der Taste ENDE.

Syntax

Ausdruck.EndKey(Unit, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben oder erweitert wird. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdStory, wdColumn, wdLine oder wdRow. Der Standardwert lautet wdLine.

Extend Variant optional. Bestimmt die Art, wie die Auswahl verschoben wird. Dabei kann es sich um eine der folgenden WdMovementType-Konstanten handeln: wdMove oder wdExtend. Wenn der Wert dieses Arguments wdMove lautet, wird die Auswahl zu einer Einfügemarke reduziert und ans Ende der angegebenen Einheit verschoben. Wenn er wdExtend lautet, wird das Ende der Auswahl bis zum Ende der angegebenen Einheit erweitert. Der Standardwert lautet wdMove.


Beispiel zur EndKey-Methode

In diesem Beispiel wird die Auswahl zum Ende der aktuellen Zeile verschoben und die Anzahl der Zeichen, um die verschoben wurde, werden der Variablen pos zugewiesen.

pos = Selection.EndKey(Unit:=wdLine, Extend:=wdMove)

In diesem Beispiel wird die Auswahl zum Anfang der aktuellen Tabellenspalte verschoben, dann wird die Auswahl bis zum Ende der Spalte erweitert.

If Selection.Information(wdWithInTable) = True Then
    Selection.HomeKey Unit:=wdColumn, Extend:=wdMove
    Selection.EndKey Unit:=wdColumn, Extend:=wdExtend
End If

In diesem Beispiel wird die Auswahl zum Ende der aktuellen Dokumentkomponente verschoben. Wenn sich die Auswahl in der Haupttextkomponente befindet, wird die Auswahl zum Ende des Dokuments verschoben.

Selection.EndKey Unit:=wdStory, Extend:=wdMove


EndOf-Methode

Verschiebt die Position des letzten Zeichens eines Bereichs oder einer Markierung oder erweitert den Bereich oder die Markierung bis zum Ende der nächsten angegebenen Texteinheit. Diese Methode gibt einen Wert zurück, der die Anzahl der Zeichenpositionen angibt, um die der Bereich oder die Markierung verschoben oder erweitert wurde (Verschiebung erfolgt im Dokument vorwärts).

Syntax

Ausdruck.EndOf(Unit, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Position des letzten Zeichens verschoben werden soll. Kann eine der folgenden WdUnits-Konstanten sein: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, kann auch wdLine verwendet werden. Die Standardeinstellung ist wdWord.

Extend Variant optional. Kann eine der folgenden zwei WdMovementType-Konstanten sein: wdMove oder wdExtend. Wenn wdMove verwendet wird, werden beide Enden des Range- oder Selection-Objekts zum Ende der angegebenen Einheit hin verschoben. Wenn wdExtend verwendet wird, wird das Ende des Bereichs oder der Markierung zum Ende der angegebenen Einheit hin erweitert. Die Standardeinstellung ist wdMove.

Hinweise

Wenn die Anfangs- und die Endposition für den Bereich oder die Markierung bereits am Ende der angegebenen Einheit sind, verschiebt oder erweitert diese Methode den Bereich oder die Markierung nicht. Wenn beispielsweise die Markierung am Ende eines Worts und des anschließenden Leerzeichens ist, ändert die folgende Anweisung die Markierung nicht (char ist 0 (Null)).

char = Selection.EndOf(Unit:=wdWord, Extend:=wdMove)


Beispiel zur EndOf-Methode

In diesem Beispiel wird die Markierung bis zum Ende des Absatzes erweitert.

charmoved = Selection.EndOf(Unit:=wdParagraph, Extend:=wdExtend)
If charmoved = 0 Then MsgBox "Selection unchanged"

In diesem Beispiel wird myRange bis zum Ende des ersten Worts in der Markierung (nach dem anschließenden Leerzeichen) verschoben.

Set myRange = Selection.Characters(1)
myRange.EndOf Unit:=wdWord, Extend:=wdMove

In diesem Beispiel wird eine Tabelle erstellt und die erste Zelle in Zeile zwei markiert. Dann wird die Markierung bis zum Ende der Spalte erweitert.

Set myRange = ActiveDocument.Range(0, 0)
Set myTable = ActiveDocument.Tables.Add(Range:=myRange, _
    NumRows:=5, NumColumns:=3)
myTable.Cell(2, 1).Select
Selection.EndOf Unit:=wdColumn, Extend:=wdExtend


EscapeKey-Methode

Bricht einen Modus ab, beispielsweise den Erweiterungsmodus oder Spaltenauswahl (entspricht dem Drücken der Taste ESC).

Syntax

Ausdruck.EscapeKey

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur EscapeKey-Methode

In diesem Beispiel wird der Erweiterungsmodus eingeschaltet und dann abgebrochen.

With Selection
    .ExtendMode = True
    .EscapeKey
End With


Execute-Methode

Informationen über die Execute-Methode erhalten Sie, indem Sie auf einen der folgenden Objektnamen klicken:

Dialog

Find

KeyBinding

MailMerge


Execute-Methode (Dialog-, KeyBinding- und MailMerge-Objekte)

Dialog-Objekt: Weist die aktuellen Einstellungen eines Word-Dialogfelds zu.

KeyBinding-Objekt: Ruft den Befehl auf, der einer bestimmten Tastenkombination zugewiesen ist.

MailMerge-Objekt: Führt eine bestimmte Seriendruck-Operation durch.

Syntax 1

Ausdruck.Execute(Pause)

Syntax 2

Ausdruck.Execute

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt (Syntax 1) oder ein Dialog-Objekt oder KeyBinding-Objekt (Syntax 2) zurückgibt.

Pause Variant optional. True, um Word bei einem Seriendruckfehler anzuhalten und ein Dialogfeld mit Hinweisen zur Fehlerbehandlung anzuzeigen. False, um Fehler in einem neuen Dokument zu protokollieren.


Beispiel zur Execute-Methode (Dialog-, KeyBinding- und MailMerge-Objekte)

Im folgenden Beispiel wird das Kontrollkästchen Absätze nicht trennen auf der Registerkarte Textfluss im Dialogfeld Absatz aktiviert.

With Dialogs(wdDialogFormatParagraph)
    .KeepWithNext = 1
    .Execute
End With

In diesem Beispiel wird die Tastenkombination STRG+UMSCHALT+C dem Befehl DateiSchließen zugewiesen und die Tastenkombination ausgeführt (das Dokument wird geschlossen).

CustomizationContext = ActiveDocument.AttachedTemplate
Keybindings.Add KeyCode:=BuildKeyCode(wdKeyControl, _
    wdKeyShift, wdKeyC), KeyCategory:=wdKeyCategoryCommand, _
    Command:="FileClose"
FindKey(BuildKeyCode(wdKeyControl, wdKeyShift, wdKeyC)).Execute

In diesem Beispiel wird ein Seriendruck durchgeführt, wenn es sich beim aktiven Dokument um ein Hauptdokument mit einer Datenquelle handelt.

Set myMerge = ActiveDocument.MailMerge
If myMerge.State = wdMainAndDataSource Then MyMerge.Execute


Execute-Methode (Find-Objekt)

Führt den angegebenen Suchvorgang aus. Gibt True zurück, wenn die Suche erfolgreich ist.

Syntax

Ausdruck.Execute(FindText, MatchCase, MatchWholeWord, MatchWildcards, MatchSoundsLike, MatchAllWordForms, Forward, Wrap, Format, ReplaceWith, Replace, MatchKashida, MatchDiacritics, MatchAlefHamza, MatchControl)

Ausdruck Erforderlich. Ein Ausdruck, der ein Find-Objekt zurückgibt.

FindText Variant optional. Der zu suchende Text. Verwenden Sie eine leere Zeichenfolge (""), wenn Sie nur nach Formatierungen suchen möchten. Sie können nach Sonderzeichen suchen, indem Sie entsprechende Zeichencodes angeben. Beispielsweise entspricht "^p" einer Absatzmarke und "^t" einem Tabstoppzeichen. Eine Liste der Sonderzeichen finden Sie unter Sonderzeichen für Dokumentelemente, die gesucht und ersetzt werden können.

Wenn MatchWildcards auf True gesetzt ist, können Sie Platzhalterzeichen und andere weitergehende Suchkriterien angeben. So wird zum Beispiel mit "*(ung)" nach allen Wörtern gesucht, die auf "ung" enden. Weitere Informationen finden Sie unter Eingeben von Platzhalterzeichen für Elemente, die Sie finden möchten.

Wenn Sie nach einem Symbolzeichen suchen möchten, geben Sie das Zirkumflexzeichen (^), eine Null (0) und dann den Zeichencode des Symbols ein. So entspricht "^0150" beispielsweise einem Gedankenstrich (–).

MatchCase Variant optional. True gibt an, dass beim Suchtext die Groß- und Kleinschreibung beachtet werden soll. Entspricht dem Kontrollkästchen Groß-/Kleinschreibung im Dialogfeld Suchen und Ersetzen (Menü Bearbeiten).

MatchWholeWord Variant optional. True, wenn nur nach ganzen Wörtern und nicht nach Teilen von längeren Wörtern gesucht werden soll. Entspricht dem Kontrollkästchen Nur ganzes Wort suchen im Dialogfeld Suchen und Ersetzen.

MatchWildcards Variant optional. True, wenn nach Text mit Hilfe eines bestimmten Suchoperators gesucht werden soll. Entspricht dem Kontrollkästchen Mit Mustervergleich im Dialogfeld Suchen und Ersetzen.

MatchSoundsLike Variant optional. True, wenn nach Wörtern gesucht werden soll, die ähnlich lauten wie der Suchtext. Entspricht dem Kontrollkästchen Ähnliche Schreibweise im Dialogfeld Suchen und Ersetzen.

MatchAllWordForms Variant optional. True, wenn alle Formen des Suchtextes gesucht werden sollen. Entspricht dem Kontrollkästchen Alle Wortformen suchen im Dialogfeld Suchen und Ersetzen.

Forward Variant optional. True, wenn vorwärts gesucht werden soll (zum Dokumentende hin).

Wrap Variant optional. Steuert das weitere Vorgehen, wenn die Suche nicht am Dokumentanfang begonnen wurde und das Dokumentende erreicht ist (oder umgekehrt, falls Forward auf False gesetzt ist). Dieses Argument steuert außerdem die Verfahrensweise, wenn eine Markierung oder ein Bereich vorgegeben ist und der Suchtext dort nicht gefunden wird. Es kann sich um eine der folgenden WdFindWrap-Konstanten handeln.

Konstante | Beschreibung
wdFindAsk | Nach der Suche in der Markierung oder im Bereich zeigt Microsoft Word eine Meldung mit der Frage an, ob die Suche im übrigen Dokument fortgesetzt werden soll.
wdFindContinue | Die Suche wird fortgesetzt, wenn der Anfang oder das Ende des Suchbereichs erreicht ist.
wdFindStop | Die Suche wird beendet, wenn der Anfang oder das Ende des Suchbereichs erreicht ist.

Format Variant optional. True, um neben dem Suchtext nach Formatierungen oder nach Formatierungen anstelle des Suchtextes zu suchen.

ReplaceWith Variant optional. Der Text, durch den der Suchtext ersetzt werden soll. Um den durch das Find-Argument angegebenen Text zu löschen, verwenden Sie eine leere Zeichenfolge (""). Sonderzeichen und weitergehende Suchkriterien werden auf dieselbe Weise angegeben wie für das Find-Argument. Wenn Sie ein grafisches Objekt oder ein anderes Element, das kein Text ist, als Ersetzung angeben möchten, fügen Sie das Element in die Zwischenablage ein, und geben Sie für ReplaceWith "^c" an.

Replace Variant optional. Gibt die Anzahl der vorzunehmenden Ersetzungen an: eine, alle oder keine. Es kann sich um eine der folgenden WdReplace-Konstanten handeln: wdReplaceAll, wdReplaceNone oder wdReplaceOne.

MatchKashida Variant optional. True, wenn bei der Suche in einem arabischsprachigen Dokument Text mit übereinstimmenden Kashidas gesucht werden soll. Dieses Argument steht Ihnen abhängig von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

MatchDiacritics Variant optional. True, wenn bei der Suche in einem Dokument in einer Sprache mit der Schreibrichtung von rechts nach links diakritische Zeichen gesucht werden sollen. Dieses Argument steht Ihnen abhängig von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

MatchAlefHamza Variant optional. True, wenn bei der Suche in einem arabischsprachigen Dokument Text mit übereinstimmenden Alef Hamzas gesucht werden soll. Dieses Argument steht Ihnen abhängig von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

MatchControl Variant optional. True, wenn bei der Suche in einem Dokument in einer Sprache mit der Schreibrichtung von rechts nach links Text mit übereinstimmenden bidirektionalen Steuerzeichen gesucht werden soll. Dieses Argument steht Ihnen abhängig von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

Hinweise

Wenn nicht anders festgelegt, erhält der Text, durch den der Suchtext ersetzt werden soll, das Format des im Dokument ersetzten Textes. Wenn Sie beispielsweise die Zeichenfolge "abc" durch "xyz" ersetzen, wird jedes Vorkommen von "abc" im Format Fett durch die Zeichenfolge "xyz" im Format Fett ersetzt.

Wenn MatchCase auf False gesetzt ist, wird jedes Vorkommen des Suchtextes in Großbuchstaben unabhängig davon, ob der Such- bzw. Ersetzungstext in Groß- oder Kleinbuchstaben eingegeben wurde, durch den Ersetzungstext in Großbuchstaben ersetzt. Im vorigen Beispiel würde beispielsweise jedes Vorkommen von "ABC" durch "XYZ" ersetzt.


Beispiel zur Execute-Methode (Find-Objekt)

In diesem Beispiel wird der Begriff "library" gesucht und das nächste Auftreten dieses Begriffs markiert.

With Selection.Find
    .ClearFormatting
    .MatchWholeWord = True
    .MatchCase = False
    .Execute FindText:="library"
End With

In diesem Beispiel wird jedes Vorkommen des Wortes "hi" im aktiven Dokument gefunden und durch "hello" ersetzt.

Set myRange = ActiveDocument.Content
myRange.Find.Execute FindText:="hi", _
    ReplaceWith:="hello", Replace:=wdReplaceAll


Exists-Methode

Stellt fest, ob die angegebene Textmarke oder der Task existiert. Gibt True zurück, wenn die Textmarke oder der Task existiert.

Syntax

Ausdruck.Exists(Name)

Ausdruck Ein Ausdruck, der ein Bookmarks- oder Tasks-Objekt zurückgibt.

Name String erforderlich. Ein Textmarken- oder Task-Name.


Beispiel zur Exists-Methode

In diesem Beispiel wird festgestellt, ob die Textmarke "start" im aktiven Dokument existiert. Wenn die Textmarke existiert, wird sie gelöscht.

If ActiveDocument.Bookmarks.Exists("start") = True Then
    ActiveDocument.Bookmarks("start").Delete
End If

In diesem Beispiel wird festgestellt, ob das Windows-Rechnerprogramm aktiv ist (wenn der Task existiert). Wenn das Rechnerprogramm nicht aktiv ist, wird es von der Shell-Anweisung gestartet. Ist das Rechnerprogramm aktiv, wird die Anwendung ausgeführt.

If Tasks.Exists("Calculator") = False Then
    Shell "Calc.exe"
Else
    Tasks("Calculator").Activate
End If
Tasks("Calculator").WindowState = wdWindowStateNormal


ExitWindows-Methode

Schließt alle offenen Anwendungen, beendet Microsoft Windows und meldet die aktuelle Benutzerin/den aktuellen Benutzer ab. Diese Methode speichert keine Änderungen an offenen Word-Dokumenten. Sie werden jedoch aufgefordert, Änderungen in anderen offenen Windows-Anwendungen zu speichern.

Syntax

Ausdruck.ExitWindows

Ausdruck Erforderlich. Ein Ausdruck, der ein Tasks-Objekt zurückgibt.


Beispiel zur ExitWindows-Methode

In diesem Beispiel werden alle offenen Word-Dokumente gespeichert, Word wird beendet und danach Microsoft Windows.

Documents.Save NoPrompt:=True, _
    OriginalFormat:=wdOriginalDocumentFormat
Tasks.ExitWindows


Expand-Methode

Erweitert den angegebenen Bereich oder die angegebene Markierung. Gibt die Anzahl der Zeichen zurück, die zu dem Bereich oder der Markierung hinzugefügt wurden.

Syntax

Ausdruck.Expand(Unit)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die der Bereich erweitert werden soll. Kann eine der folgenden WdUnits-Konstanten sein: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt repräsentiert, kann auch wdLine verwendet werden. Die Standardeinstellung ist wdWord.


ExpandOutline-Methode

Erweitert den Text unter der Markierung oder dem angegebenen Bereich um eine Überschriftenebene.

Hinweis Wenn sich das Dokument nicht in der Gliederungs- oder Zentraldokument-Ansicht befindet, wird ein Fehler erzeugt.

Syntax

Ausdruck.ExpandOutline(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.

Range Optionales Range-Objekt. Der Absatzbereich, der erweitert werden soll. Wenn Sie dieses Argument nicht angeben, wird die gesamte Markierung erweitert.


Beispiel zur ExpandOutline-Methode

Dieses Beispiel erweitert jede Überschrift im Dokument um eine Ebene.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .ExpandOutline Range:=ActiveDocument.Content
End With

Dieses Beispiel erweitert den aktiven Absatz im Fenster von "Document2".

With Windows("Document2")
    .Activate
    .View.Type = wdOutlineView
    .View.ExpandOutline
End With


Extend-Methode

Erweitert die Markierung bis (einschließlich) zur nächsten Instanz des angegebenen Zeichens.

Syntax

Ausdruck.Extend(Character)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Character Variant optional. Das Zeichen, bis zu dem die Markierung erweitert wird. Bei diesem Argument wird nach Groß- und Kleinschreibung unterschieden. Es muss einen String darstellen, da sonst ein Fehler auftritt.


Beispiel zur Extend-Methode

In diesem Beispiel wird die Markierung bis zur nächsten Instanz eines großen "R" (einschließlich) erweitert und dann die Markierung um ein Zeichen verkleinert.

With Selection
    .Extend Character:="R"
    .MoveLeft Unit:=wdCharacter, Count:=1, Extend:=wdExtend
End With


FindRecord-Methode

Durchsucht den Inhalt einer bestimmten Seriendruckdatenquelle nach Text in einem bestimmten Feld. Gibt True zurück, wenn der Suchtext gefunden wird.

Hinweis Entspricht der Schaltfläche Datensatz suchen auf der Symbolleiste Seriendruck.

Syntax

Ausdruck.FindRecord(FindText, Field)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeDataSource-Objekt zurückgibt.

FindText String erforderlich. Der Text, nach dem gesucht wird.

Field String erforderlich. Der Name des Felds, nach dem gesucht wird.


Beispiel zur FindRecord-Methode

In diesem Beispiel wird ein Seriendruckdokument für den ersten Datensatz angezeigt, in dem das Feld "FirstName" mit "Joe" belegt ist. Wird ein Datensatz gefunden, wird die Nummer des Datensatzes in der numRecord-Variablen gespeichert.

ActiveDocument.MailMerge.ViewMailMergeFieldCodes = False
Set myMMData = ActiveDocument.MailMerge.DataSource
If myMMData.FindRecord(FindText:="Joe", _
        Field:="FirstName") = True Then
    numRecord = myMMData.ActiveRecord
End If


FitToPages-Methode

Verringert den Schriftgrad von Text so weit, dass das Dokument um eine Seite kürzer wird. Es tritt ein Fehler auf, wenn Word die Seitenanzahl nicht um eine Seite verringern kann.

Syntax

Ausdruck.FitToPages

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel für die FitToPages-Methode

In diesem Beispiel wird versucht, die Seitenanzahl im aktiven Dokument um eine Seite zu verringern.

On Error GoTo errhandler
ActiveDocument.FitToPages
errhandler:
If Err = 5538 Then MsgBox "Fit to pages failed"

In diesem Beispiel wird versucht, die Seitenanzahl aller geöffneten Dokumente jeweils um eine Seite zu verringern.

For Each doc In Documents
    doc.FitToPages
Next doc


Flip-Methode

Kippt die angegebene Form um ihre horizontale oder vertikale Achse.

Syntax

Ausdruck.Flip(FlipCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

FlipCmd Long erforderlich. Gibt an, ob die Form horizontal oder vertikal gekippt werden soll. Dies kann eine der beiden folgenden MsoFlipCmd-Konstanten sein: msoFlipHorizontal oder msoFlipVertical.


Beispiel zur Flip-Methode

In diesem Beispiel wird zu myDocument ein Dreieck hinzugefügt, das Dreieck dupliziert und dann das Duplikatdreieck vertikal gekippt sowie rot ausgefüllt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRightTriangle, _
        10, 10, 50, 50).Duplicate
    .Fill.ForeColor.RGB = RGB(255, 0, 0)
    .Flip msoFlipVertical
End With


Follow-Methode

Zeigt ein Cachespeicher-Dokument an, das mit dem angegebenen Hyperlink-Objekt verbunden ist, wenn es bereits heruntergeladen wurde. Andernfalls löst diese Methode den Hyperlink auf, lädt das Zieldokument herunter und zeigt das Dokument in der entsprechenden Anwendung an.

Hinweis Wenn der Hyperlink das Dateiprotokoll verwendet, öffnet diese Methode das Dokument, anstatt es herunterzuladen.

Syntax

Ausdruck.Follow(NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

NewWindow Variant optional. True, wenn das Zieldokument in einem neuen Fenster angezeigt werden soll. Der Standardwert ist False.

AddHistory Variant optional. Dieses Argument ist für zukünftige Anwendungen reserviert.

ExtraInfo Variant optional. Eine Zeichenfolge oder ein Byte-Datenfeld, das zusätzliche Informationen für HTTP spezifiziert, die zum Auflösen des Hyperlinks verwendet werden. Sie können beispielsweise ExtraInfo zum Spezifizieren der Koordinaten eines Bildschemas, des Inhalts eines Formulars oder eines FAT-Dateinamens verwenden. Die Zeichenfolge wird, in Abhängigkeit des Wertes von Method, entweder gesendet oder angehängt. Verwenden Sie die ExtraInfoRequired-Eigenschaft zum Ermitteln, ob zusätzliche Informationen benötigt werden.

Method Variant optional. Spezifiziert die Art, wie zusätzliche Informationen für HTTP behandelt werden. Dies kann eine der folgenden MsoExtraInfoMethod-Konstanten sein:

Konstante | Beschreibung
msoMethodGet | ExtraInfo ist eine Zeichenfolge, die an die Adresse angehängt wird.
msoMethodPost | ExtraInfo wird als Zeichenfolge oder als Byte-Datenfeld gesendet.

HeaderInfo Variant optional. Eine Zeichenfolge, die Kopfzeilen-Informationen für die HTTP-Anforderung spezifiziert. Der Standardwert ist eine leere Zeichenfolge. Sie können mehrere Kopfzeilen zu einer einzigen Zeichenfolge kombinieren, indem Sie die folgende Syntax verwenden: "Zeichenfolge1" & vbCr & "Zeichenfolge2". Die angegebene Zeichenfolge wird automatisch in ANSI-Zeichen umgewandelt. Beachten Sie, dass das Argument HeaderInfo möglicherweise Standard-HTTP-Kopfzeilen-Felder überschreibt.


FollowHyperlink-Methode

Zeigt ein Cachespeicher-Dokument an, wenn es bereits heruntergeladen wurde. Andernfalls löst diese Methode den Hyperlink auf, lädt das Zieldokument herunter und zeigt das Dokument in der entsprechenden Anwendung an.

Anmerkung Wenn der Hyperlink das Dateiprotokoll verwendet, öffnet diese Methode das Dokument, anstatt es herunterzuladen.

Syntax

Ausdruck.FollowHyperlink(Address, SubAddress, NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Address String erforderlich. Die Adresse des Zieldokuments.

SubAddress Variant optional. Der Ort innerhalb des Zieldokuments. Der Standardwert ist eine leere Zeichenfolge.

NewWindow Variant optional. True, wenn der Zielort in einem neuen Fenster angezeigt werden soll. Der Standardwert ist False.

AddHistory Variant optional. True, wenn die Verknüpfung zu dem Verlaufsordner des aktuellen Tages hinzugefügt werden soll.

ExtraInfo Variant optional. Eine Zeichenfolge oder ein Byte-Datenfeld, das zusätzliche Informationen für HTTP spezifiziert, die zum Auflösen des Hyperlinks verwendet werden sollen. Sie können beispielsweise ExtraInfo zum Spezifizieren der Koordinaten eines Bildschemas, des Inhalts eines Formulars oder eines FAT-Dateinamens verwenden. Die Zeichenfolge wird, in Abhängigkeit des Wertes von Method, entweder gesendet oder angehängt. Verwenden Sie die ExtraInfoRequired-Eigenschaft zum Ermitteln, ob zusätzliche Informationen benötigt werden.

Method Variant optional. Gibt die Art an, wie zusätzliche Informationen für HTTP behandelt werden. Dies kann eine der folgenden MsoExtraInfoMethod-Konstanten sein:

Konstante | Beschreibung
msoMethodGet | ExtraInfo ist eine Zeichenfolge, die an die Adresse angehängt wird.
msoMethodPost | ExtraInfo wird als Zeichenfolge oder als Byte-Datenfeld gesendet.

HeaderInfo Variant optional. Eine Zeichenfolge, die Kopfzeilen-Informationen für die HTTP-Anforderung spezifiziert. Der Standardwert ist eine leere Zeichenfolge. Sie können mehrere Kopfzeilen zu einer einzigen Zeichenfolge kombinieren, indem Sie die folgende Syntax verwenden: "Zeichenfolge1" & vbCr & "Zeichenfolge2". Die angegebene Zeichenfolge wird automatisch in ANSI-Zeichen umgewandelt. Beachten Sie, dass das Argument HeaderInfo Standard-HTTP-Kopfzeilen-Felder überschreiben könnte.


Beispiel zur FollowHyperlink-Methode

In diesem Beispiel wird der angegebenen URL-Adresse gefolgt und die Microsoft Homepage in einem neuen Fenster angezeigt.

ActiveDocument.FollowHyperlink _
    Address:="http://www.Microsoft.com", _
    NewWindow:=True, AddHistory:=True

In diesem Beispiel wird das HTML-Dokument "Default.htm" angezeigt.

ActiveDocument.FollowHyperlink Address:="file:C:\Pages\Default.htm"


Formula-Methode

Fügt ein = (Formula)-Feld in eine Tabellenzelle ein, das die angegebene Formel enthält.

Syntax

Ausdruck.Formula(Formula, NumFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-Objekt zurückgibt.

Formula Variant optional. Die mathematische Formel, die das = (Formula)-Feld berechnen soll. Verweise auf Tabellenzellen wie in Tabellenkalkulationsprogrammen sind zulässig. So gibt "=SUM(A4:C4)" beispielsweise die ersten drei Werte in der vierten Zeile an. Weitere Informationen über das = (Formula)-Feld finden Sie unter Feldfunktionen: = (Formula)-Feld.

NumFormat Variant optional. Ein Format für das Ergebnis des = (Formula)-Feldes. Informationen über die Formattypen, die Sie anwenden können, finden Sie unter Numerisches Bild (\#).

Hinweise

Formula ist optional, solange sich über oder links von der Zelle, in der die Einfügemarke steht, mindestens eine Zelle mit einem Wert befindet. Wenn die Zellen über der Einfügemarke Werte enthalten, lautet das eingefügte Feld {=SUM(ABOVE)}; wenn die Zellen links von der Einfügemarke Werte enthalten, lautet das eingefügte Feld {=SUM(LEFT)}. Wenn sowohl die Zellen über der Einfügemarke als auch die Zellen links von der Einfügemarke Werte enthalten, ermittelt Word nach den folgenden Regeln, welche SUM-Funktion eingefügt werden soll:

  • Wenn die Zelle unmittelbar über der Einfügemarke einen Wert enthält, fügt Word {=SUM(ABOVE)} ein.

  • Wenn die Zelle unmittelbar über der Einfügemarke keinen Wert enthält und die Zelle unmittelbar links von der Einfügemarke einen Wert enthält, fügt Word {=SUM(LEFT)} ein.

  • Wenn keine benachbarte Zelle einen Wert enthält, fügt Word {=SUM(ABOVE)} ein.

  • Wenn Formula nicht angegeben wird und alle Zellen über und links von der Einfügemarke leer sind, tritt ein Fehler auf.


Beispiel zur Formula-Methode

In diesem Beispiel wird am Anfang des aktiven Dokuments eine 3x3 Tabelle erstellt und anschließend der Mittelwert der Zahlen in der ersten Spalte berechnet.

Set myRange = ActiveDocument.Range(0, 0)
Set myTable = ActiveDocument.Tables.Add(myRange, 3, 3)
With myTable
    .Cell(1,1).Range.InsertAfter "100"
    .Cell(2,1).Range.InsertAfter "50"
    .Cell(3,1).Formula Formula:="=Average(Above)"
End With

In diesem Beispiel wird an der Einfügemarke eine Formel eingefügt, die in den Zellen über der markierten Zelle die größte Zahl ermittelt.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).Formula Formula:="=Max(Above)"
Else
   MsgBox "The insertion point is not in a table."
End If


Forward-Methode

Öffnet eine neue E-Mail-Nachricht mit einer leeren Zeile To: zum Weiterleiten der aktiven Nachricht. Diese Methode steht nur zur Verfügung, wenn Sie Word als E-Mail-Editor verwenden.

Syntax

Ausdruck.Forward

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur Forward-Methode

In diesem Beispiel wird eine neue E-Mail-Nachricht zum Weiterleiten der aktiven Nachricht geöffnet.

Application.MailMessage.Forward


GetAddress-Methode

Gibt eine Adresse aus dem Standardadressbuch zurück.

Syntax

Ausdruck.GetAddress(Name, AddressProperties, UseAutoText, DisplaySelectDialog, SelectDialog, CheckNamesDialog, RecentAddressesChoice, UpdateRecentAddresses)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Name Variant optional. Der Name des Empfängers, wie er im Dialogfeld Namen auswählen im Adressbuch angegeben ist.

AddressProperties Variant optional. Wenn UseAutoText True ist, wird in diesem Argument der Name eines AutoText-Eintrags angegeben, der eine Sequenz von Adressbucheigenschaften definiert. Wenn UseAutoText False ist oder weggelassen wird, definiert dieses Argument ein benutzerdefiniertes Layout. Gültige Adressbuch-Eigenschaftsnamen oder Sätze von Adressbuch-Eigenschaftsnamen sind von spitzen Klammern ("<" und ">") umgeben und durch ein Leerzeichen oder eine Absatzmarke getrennt (z. B. "<PR_GIVEN_NAME> <PR_SURNAME>" & vbCr & "<PR_OFFICE_TELEPHONE_NUMBER>").

Wenn dieses Argument weggelassen wird, wird der Standard-AutoText-Eintrag "AdressLayout" verwendet. Wenn "AdressLayout" nicht definiert wurde, wird die folgende Adress-Layout-Definition verwendet: "<PR_GIVEN_NAME> <PR_SURNAME>" & vbCr & "<PR_STREET_ADDRESS>" & vbCr & "<PR_LOCALITY>" & ", " & "<PR_STATE_OR_PROVINCE>" & " " & "<PR_POSTAL_CODE>" & vbCr & "<PR_COUNTRY>".

Eine Liste der zulässigen Adressbucheigenschaftsnamen finden Sie bei der AddAddress-Methode.

UseAutoText Variant optional. True, wenn AddressProperties den Namen eines AutoText-Eintrags angibt, der eine Sequenz von Adressbucheigenschaften definiert; False, wenn AddressProperties ein benutzerdefiniertes Layout spezifiziert.

DisplaySelectDialog Variant optional. Gibt an, ob das Dialogfeld Namen auswählen angezeigt wird. In der folgenden Tabelle sind die zulässigen Werte und deren Bedeutung aufgelistet.

Wert | Ergebnis
0 (Null) | Das Dialogfeld Name auswählen wird nicht angezeigt.
1 oder weggelassen | Das Dialogfeld Name auswählen wird angezeigt.
2 | Das Dialogfeld Name auswählen wird nicht angezeigt, und es wird keine Suche nach einem bestimmten Namen durchgeführt. Die Adresse, die von dieser Methode zurückgegeben wird, ist die vorherige ausgewählte Adresse.

SelectDialog Variant optional. Gibt an, wie das Dialogfeld Namen auswählen angezeigt werden sollte (d. h., in welchem Modus). In der folgenden Tabelle sind die zulässigen Werte und deren Bedeutung aufgelistet.

Wert | Anzeigemodus
0 (Null) oder weggelassen | Durchsuchungsmodus
1 | Erstellmodus nur mit dem Feld To:
2 | Erstellmodus mit beiden Feldern To: und CC:

CheckNamesDialog Variant optional. True, wenn der Wert des Arguments Name nicht spezifisch genug ist und das Dialogfeld Namen überprüfen angezeigt werden soll.

RecentAddressesChoice Variant optional. True, wenn die Liste der zuletzt verwendeten Absenderadressen verwendet werden soll.

UpdateRecentAddresses Variant optional. True, wenn der Liste der zuletzt verwendeten Adressen eine Adresse hinzugefügt werden soll; False, wenn die Adresse nicht hinzugefügt werden soll. Wenn SelectDialog auf 1 oder 2 gesetzt wird, wird dieses Argument ignoriert.


Beispiel zur GetAddress-Methode

In diesem Beispiel wird der Variablen letAddress John Smiths Adresse zugewiesen, die Einfügemarke an den Anfang des Dokuments verschoben und die Adresse eingefügt. Die eingefügte Adresse erhält die Standard-Adressbucheigenschaften.

letAddress = Application.GetAddress(Name:="John Smith", _
    CheckNamesDialog:=True)
ActiveDocument.Range(Start:=0, End:=0).InsertAfter letAddress

Im folgenden Beispiel wird Kim Buhlers Adresse zurückgegeben, wobei der AutoText-Eintrag "My Address Layout" als Layout-Definition verwendet wird. "My Address Layout" ist in der aktiven Vorlage definiert und enthält einen Satz von Adresseigenschaften, die der Variablen text$ zugewiesen wurden. In dem Beispiel wird Kim Buhlers Adresse auch der Liste der zuletzt verwendeten Adressen hinzugefügt.

Dim TagIDArray(0 To 3) As String
Dim ValueArray(0 To 3) As String
TagIDArray(0) = "PR_DISPLAY_NAME"
TagIDArray(1) = "PR_GIVEN_NAME"
TagIDArray(2) = "PR_SURNAME"
TagIDArray(3) = "PR_COMMENT"
ValueArray(0) = "Display_Name"
ValueArray(1) = "John"
ValueArray(2) = "Smith"
ValueArray(3) = "This is a comment"
Application.AddAddress TagID:=TagIDArray(), Value:=ValueArray()
addr = Application.GetAddress(Name:="John Smith", _
    UpdateRecentAddresses:=True)


GetCrossReferenceItems-Methode

Gibt ein Datenfeld von Elementen zurück, auf die auf der Basis des angegebenen Querverweistyps verwiesen werden kann. Das Datenfeld entspricht den Elementen, die im Feld Für welche im Dialogfeld Querverweis im Menü Einfügen aufgelistet werden.

Hinweis Ein Element, das von dieser Methode zurückgegeben wird, kann als Argument ReferenceWhich für die InsertCrossReference-Methode verwendet werden.

Syntax

Ausdruck.GetCrossReferenceItems(ReferenceType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

ReferenceType Variant erforderlich. Der Elementtyp, zu dem Sie einen Querverweis einfügen wollen. Dies kann eine der folgenden WdReferenceType-Konstanten sein: wdRefTypeBookmark, wdRefTypeEndnote, wdRefTypeFootnote, wdRefTypeHeading oder wdRefTypeNumberedItem.


Beispiel zur GetCrossReferenceItems-Methode

In diesem Beispiel wird im aktiven Dokument der Name der ersten Textmarke angezeigt, auf die man über Querverweis verweisen kann.

If ActiveDocument.Bookmarks.Count >= 1 Then
    myBookmarks = ActiveDocument.GetCrossReferenceItems( _
        wdRefTypeBookmark)
    MsgBox myBookmarks(1)
End If

In diesem Beispiel wird die GetCrossReferenceItems-Methode zum Abrufen einer Liste von Überschriften verwendet, auf die man über Querverweis verweisen kann, und dann wird ein Querverweis auf die Seite eingefügt, die die Überschrift "introduction" enthält.

myHeadings = _
    ActiveDocument.GetCrossReferenceItems(wdRefTypeHeading)
For i = 1 To Ubound(myHeadings)
    If Instr(LCase$(myHeadings(i)), "introduction") Then
        Selection.InsertCrossReference _
            ReferenceType:=wdRefTypeHeading, _
            ReferenceKind:=wdPageNumber, ReferenceItem:=i
        Selection.InsertParagraphAfter
    End If
Next i


 GetDefaultTheme-Methode

GetDefaultTheme-Methode

Gibt den Namen des Standard-Designs zurück sowie die Design-Formatierungsoptionen, die Microsoft Word für neue Dokumente, E-Mail-Nachrichten oder Webseiten verwendet.

Syntax

Ausdruck.GetDefaultTheme(DocumentType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

DocumentType Long erforderlich. Der Typ des neuen Dokuments, für das Sie den Namen des Standarddesigns abrufen möchten. Es kann sich um eine der folgenden WdDocumentMedium-Konstanten handeln: wdDocument, wdEmailMessage oder wdWebPage.

Hinweise

Sie können auch die ThemeName-Eigenschaft verwenden, um das Standarddesign für neue E-Mail-Nachrichten zurückzugeben oder einzurichten.


Beispiel zur GetDefaultTheme-Methode

In diesem Beispiel wird der Name des Designs angezeigt, das Word für neue Webseiten verwendet.

MsgBox Application.GetDefaultTheme(wdWebPage)


GetLetterContent-Methode

Lädt die Briefelemente im aktiven Dokument und gibt ein LetterContent-Objekt zurück.

Syntax

Ausdruck.GetLetterContent

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur GetLetterContent-Methode

In diesem Beispiel werden die Anrede und der Name des Empfängers aus dem Brief im aktiven Dokument angezeigt.

MsgBox ActiveDocument.GetLetterContent.Salutation _
    & ActiveDocument.GetLetterContent.RecipientName

In diesem Beispiel werden die Briefelemente im aktiven Dokument geladen, die CC-Liste der Empfänger von Kopien wird mit der CClist-Eigenschaft geändert und anschließend das aktive Dokument mit der SetLetterContent-Methode aktualisiert, um die Änderungen zu reflektieren.

Set myLetterContent = ActiveDocument.GetLetterContent
With myLetterContent
    .CCList = "J. Burns, L. Scarpaczyk, K. Wong"
    .RecipientName = "Amy Anderson"
    .RecipientAddress = "123 Main" & vbCr & "Bellevue, WA  98004"
    .LetterStyle = wdFullBlock
End With
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


GetPoint-Methode

Gibt die Bildschirmkoordinaten des angegebenen Bereichs oder der angegebenen Form zurück.

Syntax

Ausdruck.GetPoint(ScreenPixelsLeft, ScreenPixelsTop, ScreenPixelsWidth, ScreenPixelsHeight, obj)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.

ScreenPixelsLeft Long erforderlich. Der Name der Variablen, an die Microsoft Word den Wert für den linken Rand des Objekts zurückgeben soll.

ScreenPixelsTop Long erforderlich. Der Name der Variablen, an die Microsoft Word den Wert für den oberen Rand des Objekts zurückgeben soll.

ScreenPixelsWidth Long erforderlich. Der Name der Variablen, an die Microsoft Word den Wert für die Breite des Objekts zurückgeben soll.

ScreenPixelsHeight Long erforderlich. Der Name der Variablen, an die Microsoft Word den Wert für die Höhe des Objekts zurückgeben soll.

obj Object erforderlich. Ein Range- oder Shape-Objekt.

Hinweise

Wenn nicht der gesamte Bereich oder die gesamte Form auf dem Bildschirm sichtbar ist, tritt ein Fehler auf.


Beispiel zur GetPoint-Methode

In diesem Beispiel wird die aktuelle Markierung überprüft, und die Bildschirmkoordinaten der aktuellen Markierung werden zurückgegeben.

Dim pLeft As Long
Dim pTop As Long
Dim pWidth As Long
Dim pHeight As Long

ActiveWindow.GetPoint pLeft, pTop, pWidth, pHeight, _
    Selection.Range
MsgBox "Left = " & pLeft & vbLf _
    & "Top = " & pTop & vbLf _
    & "Width = " & pWidth & vbLf _
    & "Height = " & pHeight


GetSpellingSuggestions-Methode

Syntax 1: Gibt eine SpellingSuggestions-Auflistung zurück, die die Wörter darstellt, die als Ersatz für das erste Wort im angegebenen Bereich vorgeschlagen wurden.

Syntax 2: Gibt eine SpellingSuggestions-Auflistung zurück, die die Wörter darstellt, die als Ersatz für ein gegebenes Wort vorgeschlagen wurden.

Syntax 1

Ausdruck.GetSpellingSuggestions(CustomDictionary, IgnoreUppercase, MainDictionary, SuggestionMode, CustomDictionary2 – CustomDictionary10)

Syntax 2

Ausdruck.GetSpellingSuggestions(Word, CustomDictionary, IgnoreUppercase, MainDictionary, SuggestionMode, CustomDictionary2 – CustomDictionary10)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Syntax 2: Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Word String erforderlich. Das Wort, dessen Rechtschreibung überprüft wird.

CustomDictionary Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen des Benutzerwörterbuchs zurückgibt.

IgnoreUppercase Variant optional. True, wenn die Groß-/Kleinschreibung ignoriert wird. Wird dieses Argument ausgelassen, wird der aktuelle Wert der IgnoreUppercase-Eigenschaft benutzt.

MainDictionary Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen des Standardwörterbuchs zurückgibt. Wenn Sie kein Standardwörterbuch angeben, benutzt Word das Standardwörterbuch, das der Sprachformatierung in Word oder dem ersten Wort im Bereich entspricht.

SuggestionMode Variant optional. Legt fest, wie Word Vorschläge zur Rechtschreibung macht. Dabei kann es sich um eine der folgenden WdSpellingWordType-Konstanten handeln. Der Standardwert ist WdSpellword.

Konstante | Beschreibung
wdSpellword | Word schlägt die richtige Schreibweise für das Wort oder das erste Wort im angegebenen Bereich vor.
wdWildcard | Word gibt Ersatzvorschläge, die den Suchkriterien für ein Wort mit den Platzhaltern Fragezeichen (?) oder Sternchen (*) entspricht.
wdAnagram | Word schlägt Anagramme für das Wort vor. Word schlägt keine Anagramme aus einem Benutzerwörterbuch vor.

Anmerkung Diese Parameter können abhängig von der verwendeten Wörterbuchdatei ignoriert werden.

CustomDictionary2 – CustomDictionary10 Variant optional. Entweder ein Ausdruck, der ein Dictionary-Objekt oder den Dateinamen eines zusätzlichen Benutzerwörterbuchs zurückgibt. Sie können bis zu neun zusätzliche Benutzerwörterbücher angeben.

Hinweise

Wenn das Wort richtig geschrieben wurde, gibt die Count-Eigenschaft des SpellingSuggestions-Objekt 0 (Null) zurück.


Beispiel zur GetSpellingSuggestions-Methode

In diesem Beispiel wird nach alternativen Vorschlägen zur Rechtschreibung für das erste Wort in der Auswahl gesucht. Wenn es Vorschläge gibt, wird eine Rechtschreibüberprüfung der Auswahl durchgeführt.

If Selection.Range.GetSpellingSuggestions.Count = 0 Then
    Msgbox "No suggestions."
Else
    Selection.Range.CheckSpelling
End If

In diesem Beispiel wird nach alternativen Vorschlägen zur Rechtschreibung für das Wort "?ook" gesucht. Zu den Vorschlägen gehören Ersetzungen des Platzhalters "?". Alle vorgeschlagenen Schreibweisen werden in Meldungsfeldern angezeigt.

Set sugList = GetSpellingSuggestions(Word:="?ook", _
    SuggestionMode:=wdWildcard)
If sugList.Count = 0 Then
    Msgbox "No suggestions."
Else
    For each sug in sugList
        Msgbox sug.Name
    Next sug
End If


GoBack-Methode

Bewegt die Einfügemarke zwischen den drei Positionen im aktiven Dokument, an denen zuletzt Bearbeitungen vorgenommen wurden (entspricht dem Drücken von UMSCHALT+F5).

Syntax

Ausdruck.GoBack

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur GoBack-Methode

In diesem Beispiel wird die zuletzt verwendete Datei geöffnet und die Einfügemarke an die Position gesetzt, an der zuletzt eine Bearbeitung vorgenommen wurde.

RecentFiles(1).Open
Application.GoBack


GoForward-Methode

Verschiebt die Einfügemarke vorwärts an die drei letzten Positionen, an denen im aktiven Dokument Änderungen vorgenommen wurden.

Syntax

Ausdruck.GoForward

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur GoForward-Methode

In diesem Beispiel wird die Einfügemarke zu nächsten Position mit einer Änderung verschoben.

Application.GoForward


GoTo-Methode

Document- oder Range-Objekt: Gibt ein Range-Objekt zurück, das die Startposition des angegebenen Elements darstellt, beispielsweise einer Seite, einer Textmarke oder eines Feldes.

Selection-Objekt: Verschiebt die Einfügemarke zu der Zeichenposition unmittelbar vor dem angegebenen Element und gibt ein Range-Objekt zurück (außer für die Konstanten wdGoToGrammaticalError, wdGoToProofreadingError oder wdGoToSpellingError).

Hinweis Wenn Sie diese Methode mit der Konstanten wdGoToGrammaticalError, wdGoToProofreadingError oder wdGoToSpellingError verwenden, enthält das Range-Objekt, das zurückgegeben wird, einen Grammatikfehlertext oder Rechtschreibfehlertext.

Syntax

Ausdruck.GoTo(What, Which, Count, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-, Range- oder Selection-Objekt zurückgibt.

What Variant optional. Die Art des Elements, zu dem der Bereich oder die Markierung verschoben werden soll. Dies kann eine der folgenden WdGoToItem-Konstanten sein:

wdGoToBookmark

wdGoToComment

wdGoToEndnote

wdGoToEquation

wdGoToField

wdGoToFootnote

wdGoToGrammaticalError

wdGoToGraphic

wdGoToHeading

 wdGoToLine

wdGoToObject

wdGoToPage

wdGoToPercent

wdGoToProofreadingError

wdGoToSection

wdGoToSpellingError

wdGoToTable

Which Variant optional. Das Element, zu dem der Bereich oder die Markierung verschoben werden soll. Dies kann eine der folgenden WdGoToDirection-Konstanten sein: wdGoToAbsolute, wdGoToFirst, wdGoToLast, wdGoToNext, wdGoToPrevious oder wdGoToRelative.

Die folgenden beiden Beispiele sind funktional äquivalent. In ihnen wird die Markierung zur ersten Überschrift im Dokument verschoben.

Selection.GoTo What:=wdGoToHeading, Which:=wdGoToFirst
Selection.GoTo What:=wdGoToHeading, Which:=wdGoToAbsolute, Count:=1

Count Variant optional. Die Nummer des Elements im Dokument. Der Standardwert ist 1. Im folgenden Beispiel wird die Markierung zur vierten Zeile im Dokument verschoben.

Selection.GoTo What:=wdGoToLine, Which:=wdGoToAbsolute, Count:=4

Nur positive Werte sind zulässig. Zur Angabe eines Elements, das vor dem Bereich oder der Markierung steht, verwenden Sie wdGoToPrevious als Argument Which, und geben Sie einen Wert Count an. Im folgenden Beispiel wird die Markierung um zwei Zeilen nach oben verschoben.

Selection.GoTo What:=wdGoToLine, Which:=wdGoToPrevious, Count:=2

Name Variant optional. Wenn das Argument What wdGoToBookmark, wdGoToComment, wdGoToField oder wdGoToObject ist, spezifiziert dieses Argument einen Namen. Im folgenden Beispiel wird zum nächsten Feld DATE gesprungen.

Selection.GoTo What:=wdGoToField, Name:="Date"


GoToNext-Methode

Range- oder Selection-Objekt: Gibt ein Range-Objekt zurück, das sich auf die Startposition des nächsten Elements oder der Stelle bezieht, die durch das Argument What spezifiziert wurde. Wenn Sie diese Methode auf das Selection-Objekt anwenden, verschiebt die Methode die Markierung zum angegebenen Element (außer für die Konstanten wdGoToGrammaticalError, wdGoToProofreadingError und wdGoToSpellingError).

Anmerkung Wenn Sie diese Methode mit den Konstanten wdGoToGrammaticalError, wdGoToProofreadingError oder wdGoToSpellingError verwenden, enthält das Range-Objekt, das zurückgegeben wird, einen gefundenen Grammatikfehlertext oder Rechtschreibfehlertext.

MailMessage-Objekt: Zeigt die nächste Nachricht an, wenn Sie Word als E-Mail-Editor verwenden.

Syntax 1

Ausdruck.GoToNext(What)

Syntax 2

Ausdruck.GoToNext

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt (Syntax 1) oder ein MailMessage-Objekt (Syntax 2) zurückgibt.

What Long erforderlich. Das Element, zu dem der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine der folgenden WdGoToItem-Konstanten sein: wdGoToBookmark, wdGoToComment, wdGoToEndnote, wdGoToEquation, wdGoToField, wdGoToFootnote, wdGoToGrammaticalError, wdGoToGraphic, wdGoToHeading, wdGoToLine, wdGoToObject, wdGoToPage, wdGoToPercent, wdGoToProofreadingError, wdGoToSection, wdGoToSpellingError oder wdGoToTable.


Beispiel zur GoToNext-Methode

In diesem Beispiel wird im aktiven Dokument auf Seite 2 oben eine Textmarke hinzugefügt.

Set myRange = ActiveDocument.Words(1).GoToNext(What:=wdGoToPage)
ActiveDocument.Bookmarks.Add Name:="Page2", Range:=myRange

In diesem Beispiel wird zum nächsten Feld gesprungen und dieses markiert.

With Selection
    Set myRange = .GoToNext(What:=wdGoToField)
    .MoveRight Unit:=wdWord, Extend:=wdExtend
    .Fields(1).Select
End With


GoToPrevious-Methode

Range- oder Selection-Objekt: Gibt ein Range-Objekt zurück, das sich auf die Startposition des vorherigen Elements oder der Stelle bezieht, die durch das Argument What spezifiziert wurde. Wenn die Methode auf ein Selection-Objekt angewandt wird, verschiebt GoToPrevious die Markierung zum angegebenen Element.

MailMessage-Objekt: Zeigt die vorherige Nachricht an, wenn Sie Word als E-Mail-Editor verwenden.

Syntax 1

Ausdruck.GoToPrevious(What)

Syntax 2

Ausdruck.GoToPrevious

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt (Syntax 1) oder ein MailMessage-Objekt (Syntax 2) zurückgibt.

What Long erforderlich. Das Element, zu dem der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine der folgenden WdGoToItem-Konstanten sein: wdGoToBookmark, wdGoToComment, wdGoToEndnote, wdGoToEquation, wdGoToField, wdGoToFootnote, wdGoToGrammaticalError, wdGoToGraphic, wdGoToHeading, wdGoToLine, wdGoToObject, wdGoToPage, wdGoToPercent, wdGoToProofreadingError, wdGoToSection, wdGoToSpellingError oder wdGoToTable.


Beispiel zur GoToPrevious-Methode

In diesem Beispiel wird im aktiven Dokument zum vorherigen Feld gesprungen.

Selection.GoToPrevious What:=wdGoToField

In diesem Beispiel wird ein Bereich erstellt, der sich auf den letzten Fußnotenverweis im aktiven Dokument bezieht.

Set myRange = ActiveDocument.Words.Last _
    .GoToPrevious(What:=wdGoToFootnote)
myRange.Expand Unit:=wdCharacter


Group-Methode

Fasst die Formen im angegebenen Bereich zu einer Gruppe zusammen. Gibt die gruppierten Formen als ein einziges Shape-Objekt zurück.

Syntax

Ausdruck.Group

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Da eine Gruppe von Formen wie eine einzige Form behandelt wird, ändern das Gruppieren von Formen und das Aufheben der Gruppierung die Anzahl der Elemente in der Shapes-Auflistung und die Indexnummern von Elementen, die nach den betroffenen Elementen in der Auflistung stehen.


Beispiel zur Group-Methode

In diesem Beispiel werden zwei Formen zu myDocument hinzugefügt, die zwei neuen Formen zu einer Gruppe zusammengefasst, die Ausfüllfarbe für die Gruppe eingestellt, die Gruppe gedreht und im Hintergrund der Zeichnungsebene platziert.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape(msoShapeCan, 50, 10, 100, 200).Name = "shpOne"
    .AddShape(msoShapeCube, 150, 250, 100, 200).Name = "shpTwo"
    With .Range(Array("shpOne", "shpTwo")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .Rotation = 45
        .ZOrder msoSendToBack
    End With
End With


Grow-Methode

Ändert den Schriftgrad in den nächsthöheren Grad. Wenn sich in der Auswahl oder im Bereich mehrere Schriftgrade befinden, wird jeder Grad in den nächsthöheren geändert.

Syntax

Ausdruck.Grow

Ausdruck Erforderlich. Ein Ausdruck, der ein Font-Objekt zurückgibt.


Beispiel zur Grow-Methode

In diesem Beispiel wird der Schriftgrad des vierten Wortes in einem neuen Dokument erhöht.

Set myRange = Documents.Add.Content
myRange.InsertAfter "This is a test of the Grow method."
MsgBox "Click OK to increase the font size of the fourth word."
myRange.Words(4).Font.Grow

In diesem Beispiel wird der Schriftgrad des gewählten Textes erhöht.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Grow
Else
    MsgBox "You need to select some text."
End If


Help-Methode

Zeigt die Informationen der Hilfe an.

Syntax

Ausdruck.Help(HelpType)

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

HelpType Variant erforderlich. Das Thema oder Fenster der Hilfe. Dabei kann es sich um eine der WdHelpType-Konstanten handeln, die in der folgenden Tabelle aufgeführt sind.

Konstante | Beschreibung
wdHelp | Öffnet das Dialogfeld Hilfethemen.
wdHelpAbout | Öffnet das Dialogfeld Info (Menü ?).
wdHelpActiveWindow | Zeigt Hilfe mit der Beschreibung des Befehls, der mit der aktiven Ansicht oder dem Ausschnitt verbunden ist.
wdHelpContents | Öffnet das Dialogfeld Hilfethemen.
wdHelpHWP | Zeigt Hilfethemen für Benutzer von AreA Hangul an.
wdHelpIchitaro | Zeigt Hilfethemen für Benutzer von Ichitaro an.
wdHelpIndex | Öffnet das Dialogfeld Hilfethemen.
wdHelpPE2 | Zeigt Hilfethemen für Benutzer von IBM Personal Editor 2 an.
wdHelpPSSHelp | Zeigt Informationen zum Microsoft Software Service an.
wdHelpSearch | Öffnet das Dialogfeld Hilfethemen.
wdHelpUsingHelp | Zeigt eine Liste der Hilfethemen mit einer Beschreibung zur Verwendung von Hilfe an.

Hinweise

Einige der oben aufgeführten Konstanten stehen Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.


HelpTool-Methode

Ändert den Zeiger von einem Pfeil in ein Fragezeichen, was bedeutet, dass durch Klicken auf einen Befehl oder ein Bildschirmelement kontextbezogene Hilfe aufgerufen werden kann. Wenn Sie auf Text klicken, blendet Word ein Feld ein, in dem die aktuellen Formate von Absätzen und Zeichen beschrieben werden. Durch Drücken von ESC wird der Zeiger wieder als Pfeil dargestellt.

Syntax

Ausdruck.HelpTool()

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur HelpTool-Methode

In diesem Beispiel wird der Mauszeiger von einem Pfeil in ein Fragezeichen geändert.

Application.HelpTool


HomeKey-Methode

Verschiebt oder erweitert die Auswahl bis zum Anfang der angegebenen Einheit. Diese Methode gibt eine ganze Zahl zurück, die die Anzahl der Zeichen angibt, um die die Auswahl tatsächlich verschoben wurde, oder sie gibt 0 (Null) zurück, wenn die Verschiebung fehlschlug.

Hinweis Diese Methode entspricht der Funkionalität der Taste POS 1.

Syntax

Ausdruck.HomeKey(Unit, Extend)

Ausdruck Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben oder erweitert wird. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdStory, wdColumn, wdLine oder wdRow. Der Standardwert lautet wdLine.

Extend Variant optional. Bestimmt die Art, wie die Auswahl verschoben wird. Dabei kann es sich um eine der folgenden WdMovementType-Konstanten handeln: wdMove oder wdExtend. Wenn der Wert dieses Arguments wdMove lautet, wird die Auswahl zu einer Einfügemarke reduziert und zum Anfang der angegebenen Einheit verschoben. Wenn er wdExtend lautet, wird der Anfang der Auswahl bis zum Anfang der angegebenen Einheit erweitert. Der Standardwert lautet wdMove.


Beispiel zur HomeKey-Methode

In diesem Beispiel wird die Auswahl bis zum Anfang der aktuellen Dokumentkomponente verschoben. Wenn sich die Auswahl in der Haupttextkomponente befindet, wird die Auswahl zum Anfang des Dokuments verschoben.

Selection.HomeKey Unit:=wdStory, Extend:=wdMove

In diesem Beispiel wird die Auswahl zum Anfang der aktuellen Zeile verschoben und die Anzahl der Zeichen, um die verschoben wurde, werden der Variablen pos zugewiesen.

pos = Selection.HomeKey(Unit:=wdLine, Extend:=wdMove)
If pos = 0 Then StatusBar = "Selection was not moved"


InchesToPoints-Methode

Ändert eine Maßeinheit von Zoll in Punkt (1 Zoll = 72 Punkt). Die geänderte Maßeinheit wird als Single zurückgegeben.

Syntax

Ausdruck.InchesToPoints(Inches)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Inches Single erforderlich. Der Zollwert, der in Punkt geändert werden soll.


Beispiel zur InchesToPoints-Methode

In diesem Beispiel werden für den Abstand vor den markierten Absätzen 0,25 Zoll festgelegt.

Selection.ParagraphFormat.SpaceBefore = InchesToPoints(0.25)

In diesem Beispiel werden alle geöffneten Dokumente gedruckt, nachdem für den linken und rechten Seitenrand 0,65 Zoll festgelegt wurden.

For Each openDoc in Documents
    With openDoc
        .PageSetup.LeftMargin = InchesToPoints(0.65)
        .PageSetup.RightMargin = InchesToPoints(0.65)
        .PrintOut
    End With
Next openDoc


IncrementBrightness-Methode

Ändert die Helligkeit der Grafik um den angegebenen Wert. Verwenden Sie die Brightness-Eigenschaft zum Festlegen der absoluten Helligkeit der Grafik.

Syntax

Ausdruck.IncrementBrightness(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wieviel der Wert der Brightness-Eigenschaft für die Grafik geändert werden soll. Ein positiver Wert macht die Grafik heller; ein negativer Wert macht sie dunkler.

Hinweise

Sie können die Helligkeit einer Grafik nicht über die obere oder untere Grenze für die Brightness-Eigenschaft hinaus anpassen. Wenn die Brightness-Eigenschaft beispielsweise anfangs auf 0,9 eingestellt wurde, und Sie geben 0,3 für das Argument Increment an, wird das resultierende Helligkeitsniveau 1,0 sein, nämlich die obere Grenze für die Brightness-Eigenschaft, und nicht 1,2.


Beispiel zur IncrementBrightness-Methode

In diesem Beispiel wird in myDocument ein Duplikat von Form eins erzeugt und dann das Duplikat verschoben und dunkler gemacht. Damit das Beispiel funktioniert, muss Form eins eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Duplicate
    .PictureFormat.IncrementBrightness -0.2
    .IncrementLeft 50
    .IncrementTop 50
End With


IncrementContrast-Methode

Ändert den Kontrast der Grafik um den angegebenen Wert. Verwenden Sie die Contrast-Eigenschaft zum Festlegen des absoluten Kontrasts für die Grafik.

Syntax

Ausdruck.IncrementContrast(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wieviel der Wert der Contrast-Eigenschaft für die Grafik geändert werden soll. Ein positiver Wert erhöht den Kontrast, ein negativer Wert verringert ihn.

Hinweise

Sie können den Kontrast einer Grafik nicht über die obere oder untere Grenze für die Contrast-Eigenschaft hinaus anpassen. Wenn die Contrast-Eigenschaft beispielsweise anfangs auf 0,9 eingestellt wurde, und Sie geben 0,3 für das Argument Increment an, wird das resultierende Kontrastniveau 1,0 sein, nämlich die obere Grenze für die Contrast-Eigenschaft, und nicht 1,2.


Beispiel zur IncrementContrast-Methode

In diesem Beispiel wird in myDocument der Kontrast für alle eingebetteten OLE-Objekte erhöht, die nicht bereits auf maximalen Kontrast eingestellt wurden.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    If s.Type = msoEmbeddedOLEObject Then
        s.PictureFormat.IncrementContrast 0.1
    End If
Next


IncrementLeft-Methode

Verschiebt die angegebene Form horizontal um die angegebene Punktanzahl.

Syntax

Ausdruck.IncrementLeft(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit die Form horizontal verschoben werden soll, in Punkt. Ein positiver Wert verschiebt die Form nach rechts; ein negativer Wert verschiebt sie nach links.


Beispiel zur IncrementLeft-Methode

In diesem Beispiel wird Form eins in myDocument dupliziert, die Füllfarbe für das Duplikat festgelegt, dieses 70 Punkt nach rechts und 50 Punkt nach oben verschoben sowie um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


IncrementOffsetX-Methode

Ändert die horizontale Position des Schattens um die angegebene Punktanzahl. Verwenden Sie die OffsetX-Eigenschaft zum Festlegen der absoluten horizontalen Position des Schattens.

Syntax

Ausdruck.IncrementOffsetX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit der Schatten horizontal verschoben werden soll, in Punkt. Ein positiver Wert verschiebt den Schatten nach rechts; ein negativer Wert verschiebt ihn nach links.


Beispiel zur IncrementOffsetX-Methode

In diesem Beispiel wird der Schatten von Form drei in myDocument um 3 Punkt nach links verschoben.

Set myDocument = ActiveDocument
myDocument.Shapes(3).Shadow.IncrementOffsetX -3


IncrementOffsetY-Methode

Ändert die vertikale Position des Schattens um die angegebene Punktanzahl. Verwenden Sie die OffsetY-Eigenschaft zum Festlegen der absoluten vertikalen Position des Schattens.

Syntax

Ausdruck.IncrementOffsetY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit der Schatten vertikal verschoben werden soll, in Punkt. Ein positiver Wert verschiebt den Schatten nach unten; ein negativer Wert verschiebt ihn nach oben.


Beispiel zur IncrementOffsetY-Methode

In diesem Beispiel wird der Schatten von Form drei in myDocument um 3 Punkt nach oben verschoben.

Set myDocument = ActiveDocument
myDocument.Shapes(3).Shadow.IncrementOffsetY -3


IncrementRotation-Methode

Ändert die Drehung der angegebenen Form um die z-Achse um die angegebene Gradanzahl. Verwenden Sie die Rotations-Eigenschaft zum Festlegen der absoluten Drehung der Form.

Syntax

Ausdruck.IncrementRotation(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel Grad die Form gedreht werden soll. Ein positiver Wert dreht die Form im Uhrzeigersinn; ein negativer Wert dreht sie entgegen dem Uhrzeigersinn.

Hinweise

Zum Drehen einer dreidimensionalen Form um die x-Achse oder die y-Achse verwenden Sie die IncrementRotationX-Methode bzw. die IncrementRotationY-Methode.


Beispiel zur IncrementRotation-Methode

In diesem Beispiel wird Form eins in myDocument dupliziert, die Füllfarbe für das Duplikat festgelegt, dieses 70 Punkt nach rechts und 50 Punkt nach oben verschoben und um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


IncrementRotationX-Methode

Ändert die Drehung der angegebenen Form um die x-Achse um die eingestellte Gradzahl. Verwenden Sie die RotationX-Eigenschaft, um die absolute Drehung der Form um die x-Achse einzustellen.

Syntax

Ausdruck.IncrementRotationX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um welchen Wert (in Grad) sich die Drehung der Form um die x-Achse ändern soll. Es kann sich um einen Wert zwischen – 90 und 90 handeln. Ein positiver Wert dreht die Form nach oben; ein negativer Wert dreht sie nach unten.

Hinweise

Sie können die Drehung um die x-Achse der angegebenen Form nicht über die obere bzw. untere Begrenzung der RotationX-Eigenschaft (90 Grad bis – 90 Grad) hinaus einstellen. Wenn die RotationX-Eigenschaft beispielsweise anfänglich auf 80 gesetzt ist und Sie für das Increment-Argument 40 angeben, wird der resultierende Drehwinkel nicht 120, sondern 90 (die obere Begrenzung der RotationX-Eigenschaft) betragen.

Um die Drehung einer Form um die y-Achse zu ändern, verwenden Sie die IncrementRotationY-Methode. Die Drehung um die z-Achse ändern Sie mit der IncrementRotation-Methode.


IncrementRotationY-Methode

Ändert die Drehung der angegebenen Form um die y-Achse um die eingestellte Gradzahl. Verwenden Sie die RotationY-Eigenschaft, um die absolute Drehung der Form um die y-Achse einzustellen.

Syntax

Ausdruck.IncrementRotationY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um welchen Wert (in Grad) sich die Drehung der Form um die y-Achse ändern soll. Es kann sich um einen Wert zwischen – 90 und 90 handeln. Ein positiver Wert dreht die Form nach links, ein negativer Wert dreht sie nach rechts.

Hinweise

Um die Drehung einer Form um die x-Achse zu ändern, verwenden Sie die IncrementRotationX-Methode. Die Drehung um die z-Achse ändern Sie mit der IncrementRotation-Methode.

Sie können die Drehung um die y-Achse der angegebenen Form nicht über die obere bzw. untere Begrenzung der RotationY-Eigenschaft (90 Grad bis – 90 Grad) hinaus einstellen. Wenn die RotationY-Eigenschaft beispielsweise anfänglich auf 80 gesetzt ist und Sie für das Increment-Argument 40 angeben, wird der resultierende Drehwinkel nicht 120, sondern 90 (die obere Begrenzung der RotationY-Eigenschaft) sein.


Beispiel zur IncrementRotationY-Methode

In diesem Beispiel wird Form eins in myDocument um 10 Grad nach rechts geneigt. Form eins muss eine verdrängte Form sein, damit Sie die Wirkung dieses Codefragments sehen können.

Set myDocument = ActiveDocument
myDocument.Shapes(1).ThreeD.IncrementRotationY -10


IncrementTop-Methode

Verschiebt die angegebene Form vertikal um die angegebene Punktanzahl.

Syntax

Ausdruck.IncrementTop(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, wie weit das Shape-Objekt vertikal verschoben werden soll, in Punkt. Ein positiver Wert verschiebt die Form nach unten; ein negativer Wert verschiebt sie nach oben.


Beispiel zur IncrementTop-Methode

In diesem Beispiel wird Form eins in myDocument dupliziert, die Füllfarbe für das Duplikat festgelegt, dieses 70 Punkt nach rechts und 50 Punkt nach oben verschoben sowie um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


Indent-Methode

Rückt einen oder mehrere Absätze um eine Ebene ein.

Hinweis Diese Methode entspricht dem Klicken auf die Schaltfläche Einzug vergrößern auf der Format-Symbolleiste.

Syntax

Ausdruck.Indent

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph- oder Paragraphs-Objekt zurückgibt.


IndentCharWidth-Methode

Sprachspezifische Informationen

Indents one or more paragraphs by a specified number of characters.

Syntax

expression.IndentCharWidth(Count)

expression Required. An expression that returns a Paragraph, Paragraphs, or ParagraphFormat object.

Count Required Integer. The number of characters by which the specified paragraphs are to be indented.

Hinweise

Using this method is equivalent to clicking the Increase Indent button on the Formatting toolbar.


Beispiel zur IndentCharWidth-Methode

This example indents the first paragraph of the active document by 10 characters.

With ActiveDocument.Paragraphs(1)
    .IndentCharWidth 10
End With


IndentFirstLineCharWidth-Methode

Sprachspezifische Informationen

Indents the first line of one or more paragraphs by a specified number of characters.

Syntax

expression.IndentFirstLineCharWidth(Count)

expression Required. An expression that returns a Paragraph, Paragraphs, or ParagraphFormat object.

Count Required Integer. The number of characters by which the first line of each specified paragraph is to be indented.


Beispiel zur IndentFirstLineCharWidth-Methode

This example indents the first line of the first paragraph in the active document by 10 characters.

With ActiveDocument.Paragraphs(1)
    .IndentFirstLineCharWidth 10
End With


 InRange-Methode

InRange-Methode

Gibt True zurück, wenn der Bereich oder die Markierung, auf den/die die Methode angewandt wurde, in dem Bereich enthalten ist, der durch das Argument Range angegeben wird.

Syntax

Ausdruck.InRange(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Range Range-Objekt erforderlich. Der Bereich, mit dem Ausdruck verglichen werden soll.

Anmerkungen

Diese Methode ermittelt, ob der Bereich oder die Markierung, der/die von Ausdruck zurückgegeben wird, in dem angegebenen Range enthalten ist, indem sowohl die Anfangs- und Endzeichenpositionen als auch der Artikel verglichen werden.


Beispiel zur InRange-Methode

In diesem Beispiel wird ermittelt, ob die Markierung im ersten Absatz des aktiven Dokuments enthalten ist.

status = Selection.InRange(ActiveDocument.Paragraphs(1).Range)

In diesem Beispiel wird myRange mit dem ersten Wort im aktiven Dokument gleichgesetzt. Wenn myRange nicht in der Markierung enthalten ist, wird myRange markiert.

Set myRange = ActiveDocument.Words(1)
If myRange.InRange(Selection.Range) = False Then myRange.Select

In diesem Beispiel wird eine Meldung angezeigt, wenn die Markierung in der Fußnotenkomponente ist.

If Selection.InRange(ActiveDocument _
        .StoryRanges(wdFootnotesStory)) Then
    MsgBox "Selection in footnotes"
End If


Insert-Methode

AutoTextEntry-Objekt: Fügt den AutoText-Eintrag anstelle des angegebenen Bereichs ein. Wenn Sie den Bereich nicht ersetzen möchten, verwenden Sie zuvor die Collapse-Methode. Der eingefügte AutoText-Eintrag wird als ein Range-Objekt zurückgegeben.

Envelope-Objekt: Fügt einen Briefumschlag als separaten Abschnitt am Anfang des angegebenen Dokuments ein. Die Argumente für diese Methode entsprechen den Optionen auf der Registerkarte Briefumschläge im Dialogfeld Umschläge und Etiketten (Menü Extras).

Syntax 1

Ausdruck.Insert(Where, RichText)

Syntax 2

Ausdruck.Insert(ExtractAddress, Address, AutoText, OmitReturnAddress, ReturnAddress, ReturnAutoText, PrintBarCode, PrintFIMA, Size, Height, Width, FeedSource, AddressFromLeft, AddressFromTop, ReturnAddressFromLeft, ReturnAddressFromTop, DefaultFaceUp, DefaultOrientation)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoTextEntry-Objekt (Syntax 1) oder ein Envelope-Objekt (Syntax 2) zurückgibt.

Where Range-Objekt erforderlich. Der Ort des AutoText-Eintrags.

RichText Variant optional. True, wenn der AutoText-Eintrag mit seiner ursprünglichen Formatierung eingefügt werden soll.

ExtractAddress Variant optional. True, wenn der als EnvelopeAddress-Textmarke markierte Text (eine benutzerdefinierte Textmarke) als Empfängeradresse verwendet werden soll.

Address Variant optional. Eine Zeichenfolge, die die Empfängeradresse angibt (wird ignoriert, wenn ExtractAddress auf True gesetzt ist).

AutoText Variant optional. Eine Zeichenfolge, die den AutoText-Eintrag für die Adresse angibt. Wenn angegeben, wird Address ignoriert.

OmitReturnAddress Variant optional. True, wenn die Absenderadresse ausgelassen werden soll.

ReturnAddress Variant optional. Eine Zeichenfolge, die die Absenderadresse angibt.

ReturnAutoText Variant optional. Eine Zeichenfolge, die den AutoText-Eintrag für die Absenderadresse angibt. Wenn angegeben, wird ReturnAddress ignoriert.

PrintBarCode Variant optional. True, wenn ein POSTNET Barcode hinzugefügt werden soll. Nur für U.S.-Post.

PrintFIMA Variant optional. True, wenn ein "Facing Identification Mark" (FIMA) zur Vorsortierung von Rückantwortumschlägen hinzugefügt werden soll. Nur für US-Post.

Size Variant optional. Eine Zeichenfolge zur Bestimmung des Umschlagformats. Die Zeichenfolge sollte einer der Größen entsprechen, die links im Feld Umschlagformat im Dialogfeld Umschlagoptionen aufgelistet sind (z. B. "Size 10" oder "C4").

Height Variant optional. Die Höhe des Umschlags (in Punkten), wenn das Argument Size auf "Custom size" gesetzt ist.

Width Variant optional. Die Breite des Umschlags (in Punkten), wenn das Argument Size auf "Custom size" gesetzt ist.

FeedSource Variant optional. True, wenn mit der FeedSource-Eigenschaft des Envelope-Objekts angegeben wird, welcher Papierschacht zum Drucken des Umschlags verwendet werden soll.

AddressFromLeft Variant optional. Der Abstand zwischen dem linken Umschlagrand und der Empfängeradresse (in Punkten).

AddressFromTop Variant optional. Der Abstand zwischen dem oberen Umschlagrand und der Empfängeradresse (in Punkten).

ReturnAddressFromLeft Variant optional. Der Abstand zwischen dem linken Umschlagrand und der Absenderadresse (in Punkten).

ReturnAddressFromTop Variant optional. Der Abstand zwischen dem oberen Umschlagrand und der Absenderadresse (in Punkten).

DefaultFaceUp Variant optional. True, um den Umschlag mit der Vorderseite nach oben, False, um ihn mit der Vorderseite nach unten zu bedrucken.

DefaultOrientation Variant optional. Die Ausrichtung des Umschlags. Dabei kann es sich um folgende WdEnvelopeOrientation-Konstanten handeln: wdLeftPortrait, wdCenterPortrait, wdRightPortrait, wdLeftLandscape, wdCenterLandscape, wdRightLandscape, wdLeftClockwise, wdCenterClockwise oder wdRightClockwise.


InsertAfter-Methode

Fügt den angegebenen Text am Ende eines Bereichs oder einer Markierung ein. Nach Anwendung dieser Methode wird der Bereich oder die Markierung erweitert, damit der neue Text einbezogen wird.

Anmerkung Sie können Zeichen wie Anführungszeichen, Tabstoppzeichen und geschützte Bindestriche einfügen, indem Sie die Funktion Chr mit der InsertAfter-Methode verwenden. Sie können auch folgende Visual Basic-Konstanten verwenden: vbCr, vbLf, vbCrLf und vbTab.

Syntax

Ausdruck.InsertAfter(Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection- oder Range-Objekt zurückgibt.

Text String erforderlich. Der einzufügende Text.

Hinweise

Wenn Sie diese Methode mit einem Bereich oder einer Markierung verwenden, die sich auf einen ganzen Absatz bezieht, wird der Text nach der abschließenden Absatzmarke eingefügt (der Text wird am Anfang des nächsten Absatzes erscheinen). Wenn Sie Text am Ende eines Absatzes einfügen wollen, ermitteln Sie den Endpunkt und subtrahieren 1 von dieser Stelle (die Absatzmarke ist ein Zeichen), wie es im folgenden Beispiel gezeigt wird.

Set doc = ActiveDocument
Set rngRange = _
    doc.Range(doc.Paragraphs(1).Start, _
    doc.Paragraphs(1).End - 1)
rngRange.InsertAfter _
    " This is now the last sentence in paragraph one."

Wenn der Bereich oder die Markierung jedoch mit einer Absatzmarke endet, die gleichzeitig das Ende des Dokuments darstellt, fügt Word den Text vor der letzten Absatzmarke ein, anstatt einen neuen Absatz am Ende des Dokuments zu erstellen.

Auch wenn der Bereich oder die Markierung aus einer Textmarke besteht, fügt Word den angegebenen Text ein, erweitert aber weder den Bereich oder die Markierung noch die Textmarke, um den neuen Text aufzunehmen.


Beispiel zur InsertAfter-Methode

In diesem Beispiel wird am Ende des aktiven Dokuments Text eingefügt. Die Content-Eigenschaft gibt ein Range-Objekt zurück.

ActiveDocument.Content.InsertAfter "end of document"

In diesem Beispiel wird am Ende der Markierung Text eingefügt und dann die Markierung zu einer Einfügemarke reduziert.

With Selection
    .InsertAfter "appended text"
    .Collapse Direction:=wdCollapseEnd
End With

In diesem Beispiel wird Text aus einem Eingabefeld als zweiter Absatz im aktiven Dokument eingefügt.

response = InputBox("Type some text")
With ActiveDocument.Paragraphs(1).Range
    .InsertAfter "1." & Chr(9) & response
    .InsertParagraphAfter
End With


InsertAutoText-Methode

Vergleicht den Text im oder um den angegebenen Bereich mit dem Namen eines vorhandenen AutoText-Eintrags. Wird eine Übereinstimmung gefunden, dann ersetzt InsertAutoText diesen Text mit dem AutoText-Eintrag. Wenn keine Übereinstimmung gefunden wird, tritt ein Fehler auf.

Hinweis Einen bestimmten AutoText-Eintrag fügen Sie mit der Insert-Methode und einem AutoTextEntry-Objekt ein.

Syntax

Ausdruck.InsertAutoText

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur InsertAutoText-Methode

In diesem Beispiel wird ein AutoText-Eintrag eingefügt, mit dem der Text einer Auswahl übereinstimmt.

Documents.Add
Selection.TypeText "Best w"
Selection.Range.InsertAutoText

In diesem Beispiel wird ein AutoText-Eintrag eingefügt, dessen Name dem ersten Wort im aktiven Dokument entspricht.

Documents.Add
Selection.TypeText "In "
Set myRange = ActiveDocument.Words(1)
myRange.InsertAutoText


InsertBefore-Methode

Fügt den angegebenen Text vor der Markierung oder dem Bereich ein. Nachdem der Text eingefügt wurde, wird die Markierung oder der Bereich erweitert, um den neuen Text einzuschließen. Wenn es sich bei der Markierung oder dem Bereich um eine Textmarke handelt, wird auch die Textmarke erweitert, um den neuen Text einzuschließen.

Anmerkung Mit der Chr-Funktion der InsertBefore-Methode fügen Sie Zeichen, wie Anführungzeichen, Tabstoppzeichen und geschützte Trennstriche, ein. Sie können auch die folgenden Visual Basic-Konstanten verwenden: vbCr, vbLf, vbCrLf und vbTab.

Syntax

Ausdruck.InsertBefore(Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Text String erforderlich. Der Text, der eingefügt wird.


Beispiel zur InsertBefore-Methode

In diesem Beispiel wird der Text "Hamlet" (in Anführungsstrichen) vor der Auswahl eingefügt und dann wird die Auswahl reduziert.

With Selection
    .InsertBefore Chr(34) & "Hamlet" & Chr(34) & Chr(32)
    .Collapse Direction:=wdCollapseEnd
End With

In diesem Beispiel wird der Text "Einleitung" als separater Absatz am Anfang des aktiven Dokuments eingefügt.

With ActiveDocument.Content
    .InsertParagraphBefore
    .InsertBefore "Introduction"
End With

In diesem Beispiel werden alle Schriftartnamen in der FontNames-Auflistung in ein neues Dokument eingefügt.

Documents.Add
For Each aFont In FontNames
    With Selection
        .InsertBefore aFont
        .Collapse Direction:=wdCollapseEnd
        .TypeParagraph
    End With
Next aFont


InsertBreak-Methode

Fügt einen Seiten-, Spalten- oder Abschnittswechsel ein.

Syntax

Ausdruck.InsertBreak(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Type Variant optional. Der Typ des einzufügenden Wechsels. Kann eine der folgenden WdBreakType-Konstanten sein: wdPageBreak, wdColumnBreak, wdSectionBreakNextPage, wdSectionBreakContinuous, wdSectionBreakEvenPage, wdSectionBreakOddPage, wdLineBreak, wdLineBreakClearLeft, wdLineBreakClearRight oder wdTextWrappingBreak. Die Standardeinstellung ist wdPageBreak.

Hinweise

Wenn Sie einen Seiten- oder Spaltenwechsel einfügen, wird der Bereich oder die Markierung durch den Wechsel ersetzt. Wenn Sie den Bereich oder die Markierung nicht ersetzen wollen, verwenden Sie die Collapse-Methode, bevor Sie die InsertBreak-Methode verwenden. Wenn Sie einen Abschnittswechsel einfügen, wird der Wechsel unmittelbar vor dem Range- oder Selection-Objekt eingefügt.

Einige der oben aufgelisteten Konstanten stehen Ihnen eventuell nicht zur Verfügung, je ausgewählter oder installierter Sprachunterstützung (z. B. amerikanisches Englisch).


Beispiel zur InsertBreak-Methode

In diesem Beispiel wird ein fortlaufender Abschnittswechsel unmittelbar vor der Markierung eingefügt.

Selection.InsertBreak Type:=wdSectionBreakContinuous

In diesem Beispiel wird unmittelbar nach dem zweiten Absatz des aktiven Dokuments ein Seitenwechsel eingefügt.

Set myRange = ActiveDocument.Paragraphs(2).Range
With myRange
    .Collapse Direction:=wdCollapseEnd
    .InsertBreak Type:=wdPageBreak
End With


InsertCaption-Methode

Fügt eine Beschriftung unmittelbar vor oder nach dem angegebenen Bereich oder der angegebenen Markierung ein.

Syntax

Ausdruck.InsertCaption(Label, Title, TitleAutoText, Position)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Label Variant erforderlich. Die Beschriftungskategorie, die eingefügt werden soll. Kann eine Zeichenfolge oder eine der folgenden WdCaptionLabelID-Konstanten sein: wdCaptionEquation, wdCaptionFigure oder wdCaptionTable. Wenn die Kategorie noch nicht definiert wurde, tritt ein Fehler auf. Verwenden Sie die Add-Methode mit dem CaptionLabels-Objekt zum Definieren neuer Beschriftungskategorien.

Title Variant optional. Die Zeichenfolge, die unmittelbar nach der Kategorie in der Beschriftung eingefügt werden soll (ignoriert, wenn TitleAutoText angegeben wird).

TitleAutoText Variant optional. Der AutoText-Eintrag, dessen Inhalt Sie unmittelbar nach der Kategorie in der Beschriftung einfügen wollen (hat Priorität vor dem Text, der durch Title angegeben wird).

Position Variant optional. Gibt an, ob die Beschriftung über oder unter dem Selection- oder Range-Objekt eingefügt wird. Kann eine der folgenden zwei WdCaptionPosition-Konstanten sein: wdCaptionPositionAbove oder wdCaptionPositionBelow.


Beispiel zur InsertCaption-Methode

In diesem Beispiel wird eine Beschriftung unter der ersten Tabelle des aktiven Dokuments eingefügt.

ActiveDocument.Tables(1).Range.InsertCaption _
    Label:=wdCaptionTable, _
    Position:=wdCaptionPositionBelow

In diesem Beispiel wird eine Abbildungsbeschriftung an der Einfügemarke eingefügt.

Selection.Collapse Direction:=wdCollapseStart
Selection.InsertCaption Label:="Figure", _
    Title:=": Sales Results", Position:=wdCaptionPositionBelow


InsertCells-Methode

Fügt Zellen in eine vorhandene Tabelle ein. Die Anzahl der eingefügten Zellen entspricht der Anzahl der Zellen in der Auswahl.

Hinweis Sie können Zellen auch mit der Add-Methode eines Cells-Objekts hinzufügen.

Syntax

Ausdruck.InsertCells(ShiftCells)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

ShiftCells Variant optional. Dabei kann es sich um eine der folgenden WdInsertCells-Konstanten handeln.

Konstante | Beschreibung
wdInsertCellsEntireColumn | Fügt eine ganze Spalte links neben der Spalte mit der Auswahl ein.
wdInsertCellsEntireRow | Fügt eine ganze Zeile oberhalb der Zeile mit der Auswahl ein.
wdInsertCellsShiftDown | Fügt neue Zellen oberhalb der gewählten Zellen ein.
wdInsertCellsShiftRight | Fügt neue Zellen links neben den gewählten Zellen ein.


Beispiel zur InsertCells-Methode

In diesem Beispiel werden neue Zellen links neben den gewählten Zellen eingefügt, und dann wird ein einfacher roter Rahmen um die Auswahl gezogen.

If Selection.Cells.Count >= 1 Then
    Selection.InsertCells ShiftCells:=wdInsertCellsShiftRight
    For Each aBorder In Selection.Borders
        aBorder.LineStyle = wdLineStyleSingle
        aBorder.ColorIndex = wdRed
    Next aBorder
End If


InsertColumns-Methode

Fügt Spalten links neben der Spalte mit der Auswahl ein. Ein Fehler tritt auf, wenn es sich bei der Auswahl nicht um eine Tabelle handelt.

Hinweis Die Anzahl der eingefügten Spalten entspricht der Anzahl der markierten Spalten. Sie können Spalten auch mit der Add-Methode des Columns-Objekts hinzufügen.

Syntax

Ausdruck.InsertColumns

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


InsertColumnsRight-Methode

Fügt rechts neben der aktuellen Markierung Spalten ein.

Syntax

Ausdruck.InsertColumnsRight

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Hinweise

Microsoft Word fügt ebenso viele Spalten ein, wie in der aktuellen Markierung vorhanden sind.

Um diese Methode verwenden zu können, muss sich die aktuelle Markierung in einer Tabelle befinden.


Beispiel zur InsertColumnsRight-Methode

In diesem Beispiel wird die zweite Spalte in der ersten Tabelle markiert und rechts davon eine neue Spalte eingefügt.

ActiveDocument.Tables(1).Columns(2).Select
Selection.InsertColumnsRight


InsertCrossReference-Methode

Fügt einen Querverweis in eine Überschrift, Textmarke, Fußnote oder Endnote oder in ein Element ein, für das eine Beschriftungskategorie definiert wurde (z. B. eine Gleichung, Abbildung oder Tabelle).

Syntax

Ausdruck.InsertCrossReference(ReferenceType, ReferenceKind, ReferenceItem, InsertAsHyperLink, IncludePosition)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

ReferenceType Variant erforderlich. Der Elementtyp, für den ein Querverweis eingefügt wird. Dabei kann es sich um eine der folgenden WdReferenceType-Konstanten handeln: wdRefTypeBookmark, wdRefTypeEndnote, wdRefTypeFootnote, wdRefTypeHeading oder wdRefTypeNumberedItem. Es kann sich auch um eine WdCaptionLabelID-Konstante (wdCaptionEquation, wdCaptionFigure oder wdCaptionTable) oder eine benutzerdefinierte Beschriftungskategorie handeln.

ReferenceKind Long erforderlich. Die Informationen, die der Querverweis enthält. Dabei kann es sich um eine der folgenden WdReferenceKind-Konstanten handeln: wdContentText, wdEndnoteNumber, wdEndnoteNumberFormatted, wdEntireCaption, wdFootnoteNumber, wdFootnoteNumberFormatted, wdNumberFullContext, wdNumberNoContext, wdNumberRelativeContext, wdOnlyCaptionText, wdOnlyLabelAndNumber, wdPageNumber oder wdPosition.

ReferenceItem Variant erforderlich. Wenn ReferenceType den Wert wdRefTypeBookmark hat, legt dieses Argument den Namen des Querverweises fest. Bei allen anderen ReferenceType-Werten bestimmt dieses Argument die Elementnummer oder den Namen im Feld Verweistyp im Dialogfeld Querverweis. Mit der GetCrossReferenceItems-Methode geben Sie eine Liste der Elementnamen zurück, die mit diesem Argument verwendet werden kann.

InsertAsHyperLink Variant optional. True, um einen Querverweis als Hyperlink auf ein Element, auf das Bezug genommen wird, einzufügen.

IncludePosition Variant optional. True, um abhängig von der Position des Referenzobjekts zum Querverweis die Angaben "oberhalb" oder "unterhalb" einzufügen.

Hinweise

Wenn Sie wdPageNumber als Wert für ReferenceKind angeben, müssen Sie eventuell einen Seitenumbruch für das Dokument durchführen, damit Sie die korrekten Informationen zu den Querverweisen sehen können.


Beispiel zur InsertCrossReference-Methode

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Querverweis auf die Seite mit der ersten Textmarke eingefügt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myBookmarks = ActiveDocument _
    .GetCrossReferenceItems(wdRefTypeBookmark)
With myRange
    .InsertBefore "Page "
    .Collapse Direction:=wdCollapseEnd
    .InsertCrossReference ReferenceType:=wdRefTypeBookmark, _
        ReferenceKind:=wdPageNumber, ReferenceItem:=myBookmarks(1)
End With

In diesem Beispiel wird ein Satz mit zwei Querverweisen eingefügt: ein Querverweis auf den Text einer Überschrift und der andere auf die Seite, auf der der Text der Überschrift erscheint.

With Selection
    .Collapse Direction:=wdCollapseStart
    .InsertBefore "For more information, see "
    .Collapse Direction:=wdCollapseEnd
    .InsertCrossReference ReferenceType:=wdRefTypeHeading, _
        ReferenceKind:=wdContentText, ReferenceItem:=1
    .InsertAfter " on page "
    .Collapse Direction:=wdCollapseEnd
    .InsertCrossReference ReferenceType:=wdRefTypeHeading, _
        ReferenceKind:=wdPageNumber, ReferenceItem:=1
    .InsertAfter "."
End With


InsertDatabase-Methode

Ruft Daten aus einer Datenquelle (beispielsweise einem separaten Word-Dokument, einer Microsoft Excel-Tabelle oder einer Microsoft Access-Datenbank) ab und fügt sie an Stelle des angegebenen Bereichs als Tabelle ein.

Syntax

Ausdruck.InsertDatabase(Format, Style, LinkToSource, Connection, SQLStatement, SQLStatement1, PasswordDocument, PasswordTemplate, WritePasswordDocument, WritePasswordTemplate, DataSource, From, To, IncludeFields)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Format Variant optional. Ein Format, das im Feld Formate im Dialogfeld Tabelle AutoFormat auf dem Menü Tabelle aufgelistet ist. Dies kann eine der WdTableFormat-Konstanten sein. Die Zellen in der Tabelle werden standardmäßig mit einem Rahmen versehen.

Style Variant optional. Die Attribute des durch Format spezifizierten AutoFormats, die der Tabelle zugewiesen werden. Verwenden Sie die Summe einer Kombination der folgenden Werte:

Wert | Bedeutung
0 (Null) | Ohne
1 | Rahmen
2 | Schattierung
4 | Schriftart
8 | Farbe
16 | Automatisch anpassen
32 | Überschriftzeilen
64 | Letzte Zeile
128 | Erste Spalte
256 | Letzte Spalte

LinkToSource Variant optional. True, wenn eine Verknüpfung zwischen der neuen Tabelle und der Datenquelle hergestellt werden soll.

Connection Variant optional. Ein Bereich, in dem die Abfrage durchgeführt werden soll, die durch SQLStatement angegeben wird. Wie Sie den Bereich spezifizieren, hängt davon ab, wie die Daten abgerufen werden. Zum Beispiel:

  • Wenn Daten durch ODBC abgerufen werden, spezifizieren Sie eine Verbindungs-Zeichenfolge.

  • Wenn Daten von Microsoft Excel mit Hilfe von Dynamischem Datenaustausch (DDE) abgerufen werden, geben Sie einen benannten Bereich an oder "Gesamtes Tabellenblatt".

  • Wenn Daten von Microsoft Access abgerufen werden, geben Sie das Wort "Tabelle" oder "Abfrage" an und dahinter den Namen einer Tabelle oder Abfrage.

SQLStatement String optional. Eine optionale Abfragezeichenfolge, die eine Untermenge der Daten in einer primären Datenquelle abruft, die in das Dokument eingefügt werden sollen.

SQLStatement1 String optional. Wenn die Abfragezeichenfolge länger als 255 Zeichen ist, bezeichnet SQLStatement den ersten Teil der Zeichenfolge und SQLStatement1 den zweiten Teil.

PasswordDocument Variant optional. Das Kennwort (wenn eines vorhanden ist), das zum Öffnen der Datenquelle benötigt wird.

PasswordTemplate Variant optional. Wenn die Datenquelle ein Word-Dokument ist, ist dieses Argument das Kennwort (wenn es eines gibt), das zum Öffnen der zugewiesenen Vorlage benötigt wird.

WritePasswordDocument Variant optional. Das Kennwort, das zum Speichern von Änderungen im Dokument benötigt wird.

WritePasswordTemplate Variant optional. Das Kennwort, das zum Speichern von Änderungen in der Vorlage benötigt wird.

DataSource Variant optional. Der Pfad und Dateiname der Datenquelle.

From Variant optional. Die Nummer des ersten Datensatzes im Bereich der Datensätze, die eingefügt werden sollen.

To Variant optional. Die Nummer des letzten Datensatzes im Bereich der Datensätze, die eingefügt werden sollen.

IncludeFields Variant optional. True, wenn Feldnamen aus der Datenquelle in die erste Zeile der neuen Tabelle aufgenommen werden sollen.


Beispiel zur InsertDatabase-Methode

In diesem Beispiel wird die Microsoft Excel-Kalkulationstabelle "Data.xls" nach der Markierung eingefügt. Der Style-Wert (191) ist eine Kombination der Zahlen 1, 2, 4, 8, 16, 32 und 128.

With Selection
    .Collapse Direction:=wdCollapseEnd
    .Range.InsertDatabase _
        Format:=wdTableFormatSimple2, Style:=191, _
        LinkToSource:=False, Connection:="Entire Spreadsheet", _
        DataSource:="C:\MSOffice\Excel\Data.xls"
End With


InsertDateTime-Methode

Fügt das aktuelle Datum oder die aktuelle Zeit oder beides ein, entweder als Text oder als TIME-Feld.

Syntax

Ausdruck.InsertDateTime(DateTimeFormat, InsertAsField, InsertAsFullWidth), DateLanguage, CalendarType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

DateTimeFormat Variant optional. Das Format, das zur Anzeige des Datums oder der Zeit oder von beidem verwendet werden soll. Wenn dieses Argument weggelassen wird, verwendet Microsoft Word das kurze Datumsformat aus der Windows-Systemsteuerung (Symbol Ländereinstellungen).

InsertAsField Variant optional. True, wenn die angegebene Information als TIME-Feld eingefügt werden soll. Der Standardwert ist True.

InsertAsFullWidth Variant optional. True, um die angegebenen Informationen als Doppelbyteziffern einzufügen. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

DateLanguage Variant optional. Stellt die Sprache ein, in der das Datum und die Uhrzeit angezeigt werden sollen. Es kann sich um eine der folgenden WdDateLanguage-Konstanten handeln: wdDateLanguageBidi oder wdDateLanguageLatin. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.

CalendarType Variant optional. Stellt den Kalendertyp ein, der für die Anzeige des Datums und der Uhrzeit verwendet wird. Es kann sich um eine der folgenden WdCalendarTypeBi-Konstanten handeln: wdCalendarTypeBidi oder wdCalendarTypeGregorian. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.


Beispiel zur InsertDateTime-Methode

In diesem Beispiel wird ein TIME-Feld für das aktuelle Datum eingefügt. Ein mögliches Ergebnis könnte "März 09, 1999" sein.

Selection.InsertDateTime DateTimeFormat:="MMMM dd, yyyy", _
    InsertAsField:=True

In diesem Beispiel wird das aktuelle Datum am Ende des aktiven Dokuments eingefügt. Ein mögliches Ergebnis könnte "01/12/99" sein.

With ActiveDocument.Content
    .Collapse Direction:=wdCollapseEnd
    .InsertDateTime DateTimeFormat:="MM/dd/yy", _
        InsertAsField:=False
End With

In diesem Beispiel wird in der Fußzeile des aktiven Dokuments ein TIME-Feld für das aktuelle Datum eingefügt.

ActiveDocument.Sections(1).Footers(wdHeaderFooterPrimary).Range _
    .InsertDateTime DateTimeFormat:="MMMM dd, yyyy", _
    InsertAsField:=True


InsertFile-Methode

Fügt die gesamte oder einen Teil der angegebenen Datei ein.

Syntax

Ausdruck.InsertFile(FileName, Range, ConfirmConversions, Link, Attachment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

FileName String erforderlich. Der Pfad und Dateiname der einzufügenden Datei. Wenn Sie keinen Pfad angeben, nimmt Word an, dass die Datei im aktuellen Ordner ist.

Range Variant optional. Wenn die angegebene Datei ein Word-Dokument ist, bezieht sich dieser Parameter auf eine Textmarke. Ist die Datei ein anderer Typ (beispielsweise eine Microsoft Excel Tabelle), dann bezieht sich dieser Parameter auf einen benannten Bereich oder einen Zellenbereich (zum Beispiel R1C1:R3C4).

ConfirmConversions Variant optional. True, wenn Word Sie zum Bestätigen der Umwandlung auffordern soll, wenn Dateien in anderen Formaten als das Word-Dokument-Format eingefügt werden.

Link Variant optional. True, wenn die Datei unter Verwendung eines INCLUDETEXT-Feldes eingefügt werden soll.

Attachment Variant optional. True, wenn die Datei als Anhang in eine E-Mail-Nachricht gegeben werden soll.


Beispiel zur InsertFile-Methode

In diesem Beispiel wird zum Einfügen der Datei TEST.DOC an der Einfügemarke ein INCLUDETEXT-Feld verwendet.

Selection.Collapse Direction:=wdCollapseEnd
Selection.InsertFile FileName:="C:\TEST.DOC", Link:=True

In diesem Beispiel wird ein neues Dokument erstellt, und anschließend wird der Inhalt jeder Textdatei im Ordner C:\TMP in das neue Dokument eingefügt.

Documents.Add
ChDir "C:\TMP"
myName = Dir("*.TXT")
While myName <> ""
    With Selection
        .InsertFile FileName:=myName, ConfirmConversions:=False
        .InsertParagraphAfter
        .InsertBreak Type:=wdSectionBreakNextPage
        .Collapse Direction:=wdCollapseEnd
    End With
    myName = Dir()
Wend


InsertFormula-Methode

Fügt ein = (Formula)-Feld ein, das bei der Auswahl eine Formel enthält.

Hinweis Diese Formel ersetzt die Auswahl, wenn diese nicht reduziert ist.

Syntax

Ausdruck.Formula(Formula, NumberFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Formula Variant optional. Die mathematische Formel, die das = (Formula)-Feld auswerten soll. Tabellenblattreferenzen zu Tabellenzellen sind gültig. So gibt "=SUM(A4:C4)" z. B. die ersten drei Werte in der vierten Zeile an. Weitere Informationen über das = (Formula)-Feld finden Sie bei Feldfunktionen: = (Formula)-Feld.

NumberFormat Variant optional. Ein Format für das Ergebnis des = (Formula)-Felds. Informationen über die verschiedenen Arten von Formaten, die verwendet werden können, finden Sie bei Numerisches Bild (\#).

Anmerkungen

Wenn Sie mit einer Tabellenkalkulationsanwendung wie beispielsweise Microsoft Excel arbeiten, ist es oft einfacher, alles oder einen Teil eines Tabellenblattes in ein Dokument einzubetten, als das = (Formula)-Feld in einer Tabelle zu verwenden.

Das Formula-Argument ist nur optional, wenn die Auswahl in einer Zelle ist und mindestens eine Zelle über oder links von der Zelle mit der Einfügemarke einen Wert enthält. Wenn die Zellen über der Einfügemarke einen Wert enthalten, ist das eingefügte Feld {=SUM(ABOVE)}; wenn die Zellen links von der Einfügemarke einen Wert enthalten, ist das eingefügte Feld {=SUM(LEFT)}. Wenn sowohl die Zellen über als auch die Zellen links der Einfügemarke einen Wert enthalten, verwendet Word zur Ermittlung der einzufügenden SUM-Funktion folgende Regeln:

  • Enthält die Zelle direkt über der Einfügemarke einen Wert, fügt Word {=SUM(ABOVE)} ein.

  • Enthält die Zelle direkt über der Einfügemarke keinen Wert, dafür aber die Zelle direkt links von der Einfügemarke, fügt Word {=SUM(LEFT)} ein.

  • Enthält weder die Zelle direkt über noch die Zelle direkt unter der Einfügemarke einen Wert, fügt Word {=SUM(ABOVE)} ein.

  • Wenn Sie Formula nicht angeben und alle Zellen über und links von der Einfügemarke leer sind, erzeugt das = (Formula)-Feld einen Fehler.


Beispiel zur InsertFormula-Methode

In diesem Beispiel wird am Anfang des Dokuments eine Tabelle mit drei Zeilen und drei Spalten erstellt und dann der Durchschnitt aller Zahlen in der ersten Spalte errechnet.

Set MyRange = ActiveDocument.Range(0, 0)
Set myTable = ActiveDocument.Tables.Add(MyRange, 3, 3)
With myTable
    .Cell(1, 1).Range.InsertAfter "100"
    .Cell(2, 1).Range.InsertAfter "50"
    .Cell(3, 1).Select
End With
Selection.InsertFormula Formula:="=Average(Above)"

In diesem Beispiel wird ein Formelfeld eingefügt, das von einem durch die Textmarke "GrossSales" repräsentierten Wert subtrahiert wird. Das Ergebnis wird als Dollarzeichen formatiert.

Selection.Collapse Direction:=wdCollapseStart
Selection.InsertFormula Formula:= "=GrossSales-45,000.00", _
    NumberFormat:="$#,##0.00"


InsertParagraph-Methode

Ersetzt den angegebenen Bereich oder die angegebene Markierung durch einen neuen Absatz.

Anmerkung Nachdem diese Methode verwendet wurde, ist der Bereich oder die Markierung der neue Absatz.

Syntax

Ausdruck.InsertParagraph

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Hinweise

Wenn Sie den Bereich oder die Markierung nicht ersetzen wollen, verwenden Sie die Collapse-Methode, bevor Sie diese Methode verwenden. Die InsertParagraphAfter-Methode fügt einen neuen Absatz im Anschluss an ein Range- oder Selection-Objekt ein.


InsertParagraphAfter-Methode

Fügt eine Absatzmarke nach einem Bereich oder einer Markierung ein.

Anmerkung Nach Anwendung dieser Methode wird der Bereich oder die Markierung erweitert, damit der neue Absatz einbezogen wird.

Syntax

Ausdruck.InsertParagraphAfter

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.


Beispiel zur InsertParagraphAfter-Methode

In diesem Beispiel wird ein neuer Absatz nach dem aktuellen Absatz eingefügt.

With Selection
    .Move Unit:=wdParagraph
    .InsertParagraphAfter
    .Collapse Direction:=wdCollapseStart
End With

In diesem Beispiel wird am Anfang des aktiven Dokuments Text als neuer Absatz eingefügt.

Set myRange = ActiveDocument.Range(0, 0)
With myRange
    .InsertBefore "Title"
    .ParagraphFormat.Alignment = wdAlignParagraphCenter
    .InsertParagraphAfter
End With

In diesem Beispiel wird am Ende des aktiven Dokuments ein Absatz eingefügt. Die Content-Eigenschaft gibt ein Range-Objekt zurück.

ActiveDocument.Content.InsertParagraphAfter


InsertParagraphBefore-Methode

Fügt einen neuen Absatz vor der angegebenen Auswahl oder dem Bereich ein.

Hinweis Nach Zuweisung dieser Methode wird der Bereich oder die Auswahl erweitert, um den neuen Absatz einzuschließen.

Syntax

Ausdruck.InsertParagraphBefore

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection- oder Range-Objekt zurückgibt.


Beispiel zur InsertParagraphBefore-Methode

In diesem Beispiel wird ein neuer Absatz am Anfang des aktiven Dokuments eingefügt.

ActiveDocument.Range(Start:=0, End:=0).InsertParagraphBefore

In diesem Beispiel wird der Text "Hello" als neuer Absatz vor der Auswahl eingefügt.

With Selection
    .InsertParagraphBefore
    .InsertBefore "Hello"
End With


InsertRows-Methode

Fügt eine bestimmte Anzahl Zeilen oberhalb der ersten Zeile der Auswahl ein. Ein Fehler tritt auf, wenn es sich bei der Auswahl nicht um eine Tabelle handelt.

Hinweis Sie können Zeilen auch mit der Add-Methode des Rows-Objekts hinzufügen.

Syntax

Ausdruck.InsertRows(NumRows)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

NumRows Variant optional. Die Anzahl der Zeilen, die hinzugefügt werden.


InsertRowsAbove-Methode

Fügt über der aktuellen Markierung Zeilen ein.

Syntax

Ausdruck.InsertRowsAbove

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Hinweise

Microsoft Word fügt ebenso viele Zeilen ein, wie in der aktuellen Markierung vorhanden sind.

Um diese Methode verwenden zu können, muss sich die aktuelle Markierung in einer Tabelle befinden.


Beispiel zur InsertRowsAbove-Methode

In diesem Beispiel wird die zweite Zeile in der ersten Tabelle markiert und darüber eine neue Zeile eingefügt.

ActiveDocument.Tables(1).Rows(2).Select
Selection.InsertRowsAbove


InsertRowsBelow-Methode

Fügt Zeilen unter der aktuellen Markierung ein.

Syntax

Ausdruck.InsertRowsBelow

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Hinweise

Microsoft Word fügt ebenso viele Zeilen ein, wie in der aktuellen Markierung vorhanden sind.

Um diese Methode verwenden zu können, muss sich die aktuelle Markierung in einer Tabelle befinden.


Beispiel zur InsertRowsBelow-Methode

In diesem Beispiel wird die zweite Zeile in der ersten Tabelle markiert und darunter eine neue Zeile eingefügt.

ActiveDocument.Tables(1).Rows(2).Select
Selection.InsertRowsBelow


InsertSymbol-Methode

Fügt ein Symbol an der Stelle des angegebenen Bereichs oder der angegebenen Markierung ein.

Anmerkung Wenn Sie den Bereich oder die Markierung nicht ersetzen möchten, verwenden Sie die Collapse-Methode, bevor Sie mit der InsertSymbol-Methode arbeiten.

Syntax

Ausdruck.InsertSymbol(CharacterNumber, Font, Unicode, Bias)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

CharacterNumber Long erforderlich. Die Zeichennummer des gewünschten Symbols. Dieser Wert ist immer gleich der Summe aus 31 und der Zahl, die der Position des Symbols in der Tabelle der Symbole entspricht (gezählt von links nach rechts). Um beispielsweise ein Delta-Zeichen (Postion 37 in der Tabelle der Symbole) in der Symbol-Schriftart einzufügen, setzen Sie CharacterNumber auf 68.

Font Variant optional. Der Name der Schriftart, die das Symbol enthält.

Unicode Variant optional. True, um das durch CharacterNumber angegebene Unicode-Zeichen einzufügen; False, um das durch CharacterNumber angegebene ANSI-Zeichen einzufügen. Der Standardwert ist False.

Bias Variant optional. Stellt die Zeichenneigung für Symbole ein. Dieses Argument kann zum Einstellen der richtigen Zeichenneigung für ostasiatische Zeichen verwendet werden. Es kann sich um eine der folgenden WdFontBias-Konstanten handeln: wdFontBiasDefault, wdFontBiasDontCare oder wdFontBiasFareast. Dieses Argument steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.


Beispiel zur InsertSymbol-Methode

In diesem Beispiel wird ein Doppelpfeil an der Einfügemarke eingefügt.

With Selection
    .Collapse Direction:=wdCollapseStart
    .InsertSymbol CharacterNumber:=171, _
        Font:="Symbol", Unicode:=False
End With

In diesem Beispiel werden am Anfang des ersten Absatzes in der Markierung ein Aufzählungszeichen und ein Tabstop eingefügt.

Set myRange = Selection.Paragraphs(1).Range
With myRange
    .Collapse Direction:=wdCollapseStart
    .InsertSymbol CharacterNumber:=183, _
        Font:="Symbol", Unicode:=False
    .MoveStart Unit:=wdCharacter, Count:=1
    .InsertAfter vbTab
End With


 InStory-Methode

InStory-Methode

True, wenn die Auswahl oder der Bereich, dem die Methode zugewiesen wird, sich in derselben Dokumentkomponente befindet, wie der mit dem Range-Argument angegebene Bereich.

Hinweis Ein Bereich kann nur zu einer Dokumentkomponente gehören.

Syntax

Ausdruck.InStory(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Range Range-Objekt erforderlich. Das Range-Objekt, dessen Dokumentkomponente mit derjenigen verglichen wird, die Ausdruck enthält.


Beispiel zur InStory-Methode

In diesem Beispiel wird ermittelt, ob sich die Auswahl in derselben Dokumentkomponente wie der erste Absatz im aktiven Dokument befindet. Im Meldungsfeld wird "False" angezeigt, weil sich die Auswahl in der primären Kopfzeilenkomponente und der erste Absatz in der Haupttextkomponente befindet.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageHeader
End With
same = Selection.InStory(ActiveDocument.Paragraphs(1).Range)
MsgBox same

In diesem Beispiel wird bestimmt, ob sich Range1 und Range2 in derselben Dokumentkomponente befinden. Falls ja, wird Range1 Fett formatiert.

Set Range1 = Selection.Words(1)
Set Range2 = ActiveDocument.Range(Start:=20, End:=100)
If Range1.InStory(Range:=Range2) = True Then
    Range1.Font.Bold = True
End If


IsEqual-Methode

True, wenn die Markierung oder der Bereich, auf die/den diese Methode angewandt wird, gleich dem Bereich ist, der durch das Argument Range angegeben wurde. Diese Methode vergleicht sowohl die Anfangs- und Endzeichenposition als auch die Dokumentkomponentenart. Wenn alle drei dieser Elemente für beide Objekte gleich sind, sind die Objekte gleich.

Syntax

Ausdruck.IsEqual(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Range Range-Objekt erforderlich. Das Range-Objekt, das mit Ausdruck verglichen wird.


Beispiel zur IsEqual-Methode

In diesem Beispiel wird die Markierung mit dem zweiten Absatz im aktiven Dokument verglichen. Wenn die Markierung nicht gleich dem zweiten Absatz ist, wird der zweite Absatz markiert.

If Selection.IsEqual(ActiveDocument _
        .Paragraphs(2).Range) = False Then
    ActiveDocument.Paragraphs(2).Range.Select
End If

In diesem Beispiel wird Range1 mit Range2 verglichen, um zu ermitteln, ob sie gleich sind. Wenn die zwei Bereiche gleich sind, wird der Inhalt von Range1 gelöscht.

Set Range1 = Selection.Words(1)
Set Range2 = ActiveDocument.Words(3)
If Range1.IsEqual(Range:=Range2) = True Then
    Range1.Delete
End If


 ItalicRun-Methode

ItalicRun-Methode

Sprachspezifische Informationen

Adds the italic character format to or removes it from the current run. If the run contains a mix of italic and non-italic text, this method adds the italic character format to the entire run.

Syntax

expression.ItalicRun

expression Required. An expression that returns a Selection object.

Hinweise

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ItalicRun-Methode

This example toggles the italic formatting for the current selection.

Selection.ItalicRun


Item-Methode

Gibt ein Element einer Auflistung zurück, entweder über die Position oder über den Namen.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf "Betrifft".

Index Variant erforderlich. Der Name oder die Indexnummer eines Elements der Auflistung. Der Index kann ein numerischer Ausdruck sein (eine Zahl von 1 bis zum Wert der Count-Eigenschaft der Auflistung), eine Konstante oder eine Zeichenfolge. Weitere Informationen über die Verwendung der Item-Methode mit einer bestimmten Auflistung finden Sie im Hilfe-Thema für diese Auflistung.

Anmerkungen

Wenn der Wert, der als Index bereitgestellt wird, mit keinem vorhandenen Element der Auflistung übereinstimmt, tritt ein Fehler auf.

Die Item-Methode ist die Standardmethode für Auflistungen. Deshalb sind die folgenden zwei Codezeilen äquivalent.

Application.Documents(1)
Application.Documents.Item(1)


Beispiel zur Item-Methode

In diesem Beispiel wird der Name des ersten Dokuments in der Documents-Auflistung angezeigt.

If Documents.Count >= 1 Then
    MsgBox Documents.Item(1).Name
End If

In diesem Beispiel wird die Textmarke "temp" im aktiven Dokument markiert.

If ActiveDocument.Bookmarks.Exists("temp") = True Then
    ActiveDocument.Bookmarks.Item("temp").Select
End If

In diesem Beispiel werden zwei Namen der MyNames-Auflistung hinzugefügt. Die Item-Methode wird angewandt, damit jedes dieser Elemente in der Auflistung zurückgegeben wird.

Dim MyNames As New Collection
MyNames.Add Item:="Dave Edson"
MyNames.Add Item:="Tim O'Brien"
MsgBox MyNames.Item(1) & vbCr & MyNames.Item(2)

In diesem Beispiel werden alle Elemente im Dropdown-Formularfeld "Colors" gelöscht und dann die Namen zweier Farben hinzugefügt. Die Item-Methode wird zum Anzeigen der ersten Farbe im Dropdown-Formularfeld verwendet.

With ActiveDocument.FormFields("Colors").DropDown.ListEntries
    .Clear
    .Add Name:="Blue"
    .Add Name:="Red"
    MsgBox .Item(1).Name
End With


Key-Methode

Liefert ein KeyBinding-Objekt, das die angegebene benutzerdefinierte Tastenkombination repräsentiert. Wenn diese Tastenkombination nicht existiert, liefert diese Methode Nothing.

Syntax

Ausdruck.Key(KeyCode, KeyCode2)

Ausdruck Erforderlich. Ein Ausdruck, der ein KeyBindings- oder KeysBoundTo-Objekt zurückgibt.

KeyCode Long erforderlich. Eine Taste, die Sie mit einer der WdKey-Konstanten festlegen.

KeyCode2 Variant optional. Eine zweite Taste, die Sie mit einer der WdKey-Konstanten festlegen.

Anmerkungen

Mit der BuildKeyCode-Methode erstellen Sie das KeyCode- oder KeyCode2-Argument.


Keyboard-Methode

Gibt die Sprache und Layouteinstellungen der Tastatur zurück oder stellt sie ein.

Syntax

Ausdruck.Keyboard(LangId)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

LangId Long optional. Die Kombination von Sprache und Layout, nach der Microsoft Word die Tastatur einrichtet. Wenn dieses Argument weggelassen wird, gibt die Methode die aktuellen Einstellungen für Sprache und Layout zurück.

Hinweise

Microsoft Windows verfolgt die Einstellungen für die Tastatursprache und für das Layout mit Hilfe eines Variablentyps, der die Zugriffsnummer auf die Eingabesprache darstellt und häufig auch als HKL bezeichnet wird. Das niederwertige Datenwort der Zugriffsnummer entspricht dem Sprachbezeichner, und das höherwertige Datenwort ist eine Zugriffsnummer für ein Tastaturlayout.


KeyboardBidi-Methode

Sprachspezifische Informationen

Sets the keyboard language to a right-to-left language and the text entry direction to right-to-left.

Syntax

expression.KeyboardBidi

expression Required. An expression that returns an Application object.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur KeyboardBidi-Methode

Sprachspezifische Informationen

This example configures the keyboard for right-to-left language entry.

Application.KeyboardBidi


KeyboardLatin-Methode

Sprachspezifische Informationen

Sets the keyboard language to a left-to-right language and the text entry direction to left-to-right.

Syntax

expression.KeyboardLatin

expression Required. An expression that returns an Application object.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur KeyboardLatin-Methode

Sprachspezifische Informationen

This example configures the keyboard for left-to-right language entry.

Application.KeyboardLatin


KeyString-Methode

Liefert die Zeichenfolge der Tastenkombination bestimmter Tasten z. B. STRG+UMSCHALT+A.

Syntax

Ausdruck.KeyString(KeyCode, KeyCode2)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

KeyCode Long erforderlich. Eine Taste, die Sie mit einer der WdKey-Konstanten festlegen.

KeyCode2 Variant optional. Eine zweite Taste, die Sie mit einer der WdKey-Konstanten festlegen.

Anmerkungen

Mit der BuildKeyCode-Methode erstellen Sie das KeyCode- oder KeyCode2-Argument.


Beispiel zur KeyString-Methode

In diesem Beispiel wird die Zeichenfolge der Tastenkombination STRG+UMSCHALT+A für die folgenden WdKey-Konstanten angezeigt: wdKeyControl, wdKeyShift und wdKeyA.

CustomizationContext = ActiveDocument.AttachedTemplate
MsgBox KeyString(KeyCode:=BuildKeyCode(wdKeyControl, _
    wdKeyShift, wdKeyA))


LargeScroll-Methode

Rollt ein Fenster oder einen Ausschnitt um die angegebene Anzahl von Bildschirmen. Diese Methode ist äquivalent zum Klicken unmittelbar vor oder unmittelbar nach dem Bildlauffeld auf der horizontalen und vertikalen Bildlaufleiste.

Syntax

Ausdruck.LargeScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein Pane- oder Window-Objekt zurückgibt.

Down Variant optional. Die Anzahl der Bildschirme, um die das Fenster nach unten gerollt werden soll.

Up Variant optional. Die Anzahl der Bildschirme, um die das Fenster nach oben gerollt werden soll.

ToRight Variant optional. Die Anzahl der Bildschirme, um die das Fenster nach rechts gerollt werden soll.

ToLeft Variant optional. Die Anzahl der Bildschirme, um die das Fenster nach links gerollt werden soll.

Hinweise

Wenn sowohl Down als auch Up angegeben wird, wird das Fenster um die Differenz der Argumente gerollt. Wenn beispielsweise Down gleich 2 und Up gleich 4 ist, wird das Fenster um zwei Bildschirme nach oben gerollt. Wenn sowohl ToLeft als auch ToRight angegeben wird, wird das Fenster entsprechend um die Differenz der Argumente gerollt.

Jedes dieser Argumente kann eine negative Zahl sein. Wenn keine Argumente angegeben werden, wird das Fenster einen Bildschirm nach unten gerollt.


Beispiel zur LargeScroll-Methode

In diesem Beispiel wird das aktive Fenster einen Bildschirm nach unten gerollt.

ActiveDocument.ActiveWindow.LargeScroll Down:=1

In diesem Beispiel wird das aktive Fenster geteilt und dann zwei Bildschirme nach oben und einen Bildschirm nach rechts gerollt.

With ActiveDocument.ActiveWindow
    .Split = True
    .LargeScroll Up:=2, ToRight:=1
End With


LinesToPoints-Methode

Ändert eine Maßeinheit von Zeile in Punkt (1 Zeile = 12 Punkt). Gibt die geänderte Maßeinheit als Single zurück.

Syntax

Ausdruck.LinesToPoints(Lines)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Lines Single erforderlich. Der Zeilenwert, der in Punkt geändert werden soll.


Beispiel zur LinesToPoints-Methode

In diesem Beispiel werden in den Absätzen der Markierung für den Zeilenabstand drei Zeilen festgelegt.

With Selection.ParagraphFormat
    .LineSpacingRule = wdLineSpaceMultiple
    .LineSpacing = LinesToPoints(3)
End With


LinkToListTemplate-Methode

Verknüpft die angegebene Formatvorlage mit einer Listenvorlage, damit die Formatierung in der Formatvorlage Listen zugewiesen werden kann.

Syntax

Ausdruck.LinkToListTemplate(ListTemplate, ListLevelNumber)

Ausdruck Erforderlich. Ein Ausdruck, der ein Style-Objekt zurückgibt.

ListTemplate ListTemplate-Objekt erforderlich. Die Listenvorlage, mit der die Formatvorlage verknüpft wird.

ListLevelNumber Variant optional. Eine ganze Zahl, die der Listenebene entspricht, mit der die Formatvorlage verknüpft wird. Wird dieses Argument ausgelassen, wird die Ebene der Formatvorlage benutzt.


Beispiel zur LinkToListTemplate-Methode

In diesem Beispiel wird eine neue Listenvorlage erstellt. Dann werden die Formatvorlagen für die Überschriften 1 bis 9 mit den Ebenen 1 bis 9 verknüpft. Die neue Listenvorlage wird danach dem Dokument zugewiesen. Alle mit einer Formatvorlage für die Überschriften formatierten Abschnitte nehmen die Nummerierung aus der Listenvorlage an.

Set LT = ActiveDocument.ListTemplates.Add(OutlineNumbered:=True)
For x = 1 To 9
    With LT.ListLevels(x)
        .NumberStyle = wdListNumberStyleArabic
        .NumberPosition = InchesToPoints(0.25 * (x - 1))
        .TextPosition = InchesToPoints(0.25 * x)
        .NumberFormat = "%" & x & "."
    End With
    With ActiveDocument.Styles("Heading " & x)
       .LinkToListTemplate ListTemplate:=LT
    End With
Next x
ActiveDocument.Content.ListFormat.ApplyListTemplate _
    ListTemplate:=LT


ListCommands-Methode

Erstellt ein neues Dokument und fügt dann eine Tabelle von Word-Befehlen zusammen mit den dazugehörigen Tastenkombinationen und den entsprechenden Menüzuweisungen ein.

Syntax

Ausdruck.ListCommands(ListAllCommands)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

ListAllCommands Boolean erforderlich. True, um alle Word-Befehle und ihre Zuweisungen (angepasste oder integrierte) einzubeziehen. False, um nur Befehle mit angepassten Zuweisungen einzubeziehen.


Beispiel zur ListCommands-Methode

In diesem Beispiel wird ein neues Dokument erstellt, in dem alle Word-Befehle zusammen mit den zugehörigen Tastenkombinationen und Menüzuweisungen aufgelistet sind. Dann wird das neue Dokument gedruckt und ohne Speichern der Änderungen geschlossen.

Application.ListCommands ListAllCommands:=True
With ActiveDocument
    .PrintOut
    .Close SaveChanges:=wdDoNotSaveChanges
End With


ListIndent-Methode

Erhöht die Listenebene von Absätzen im Bereich des angegebenen ListFormat-Objekts in Schritten von einer Ebene.

Syntax

Ausdruck.ListIndent

Ausdruck Erforderlich. Ein Ausdruck, der ein ListFormat-Objekts zurückgibt.


Beispiel zur ListIndent-Methode

In diesem Beispiel werden alle Absätze in der ersten Liste in Document 1 eingezogen.

Documents(1).Lists(1).Range.ListFormat.ListIndent

In diesem Beispiel werden die Absätze 4 bis 8 im aktiven Dokument als Gliederung formatiert, und die Absätze werden um eine Ebene eingezogen.

Set myDoc = ActiveDocument
Set myRange = _
    myDoc.Range(Start:= myDoc.Paragraphs(4).Range.Start, _
    End:=myDoc.Paragraphs(8).Range.End)
With myrange.ListFormat
    .ApplyOutlineNumberDefault
    .ListIndent
End With


ListOutdent-Methode

Reduziert die Listenebene der Absätze im Bereich des angegebenen ListFormat-Objekts in Schritten von einer Ebene.

Syntax

Ausdruck.ListOutdent

Ausdruck Erforderlich. Ein Ausdruck, der ein ListFormat-Objekt zurückgibt.


Beispiel zur ListOutdent-Methode

In diesem Beispiel wird der Einzug aller Absätze in der ersten Liste im aktiven Dokument um eine Ebene reduziert.

ActiveDocument.Lists(1).Range.ListFormat.ListOutdent

In diesem Beispiel werden die Absätze 4 bis 8 in MyDoc.doc als Gliederung formatiert, und der Einzug des ersten Absatzes in der Liste wird entfernt.

Set myDoc = Documents("MyDoc.doc")
Set myRange = _
    myDoc.Range(Start:= myDoc.Paragraphs(4).Range.Start, _
    End:=myDoc.Paragraphs(8).Range.End)
With myrange.ListFormat
    .ApplyOutlineNumberDefault
    .ListIndent
End With
myDoc.Paragraphs(4).Range.ListFormat.ListOutdent


LookupNameProperties-Methode

Schlägt einen Namen in der globalen Adressbuchliste nach und zeigt das Dialogfeld Eigenschaften mit Informationen über den angegebenen Namen an. Wenn diese Methode mehr als eine Übereinstimmung findet, erscheint das Dialogfeld Namen überprüfen.

Syntax 1

Ausdruck.LookupNameProperties(Name)

Syntax 2

Ausdruck.LookupNameProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt (Syntax 1) oder ein Range-Objekt (Syntax 2) zurückgibt.

Name String erforderlich. Ein Name im globalen Adressbuch.


Beispiel zur LookupNameProperties-Methode

In diesem Beispiel wird der Name "Don Funk" im Adressbuch nachgeschlagen und das Dialogfeld Properties für "Don Funk" angezeigt.

Application.LookupNameProperties Name:="Don Funk"

In diesem Beispiel wird der gewählte Name im Adressbuch nachgeschlagen und das Dialogfeld Properties für diese Person angezeigt.

Selection.Range.LookupNameProperties


LtrPara-Methode

Sprachspezifische Informationen

Sets the reading order and alignment of the specified paragraphs to left-to-right.

Syntax

expression.LtrPara

expression Required. An expression that returns a Selection object.

Remarks

For all selected paragraphs, this method sets the reading order to left-to-right. If a paragraph with a right-to-left reading order is also right-aligned, this method reverses its reading order and sets its paragraph alignment to left-aligned.

Use the ReadingOrder property to change the reading order without affecting paragraph alignment.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur LtrPara-Methode

Sprachspezifische Informationen

This example sets the reading order and alignment of the current selection to left-to-right if the selection is styled as "Normal."

If Selection.Style = "Normal" Then _
    Selection.LtrPara


 LtrRun-Methode

LtrRun-Methode

Sprachspezifische Informationen

Sets the reading order and alignment of the specified run to left-to-right.

Syntax

expression.LtrRun

expression Required. An expression that returns a Selection object.

Remarks

For the specified run, this method sets the reading order to left-to-right. If a paragraph in the run with a right-to-left reading order is also right-aligned, this method reverses its reading order and sets its paragraph alignment to left-aligned.

Use the ReadingOrder property to change the reading order without affecting paragraph alignment.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur LtrRun-Methode

Sprachspezifische Informationen

This example sets the reading order and alignment of the specified run to left-to-right if the selection is styled as "Normal."

If Selection.Style = "Normal" Then _
    Selection.LtrRun


MakeCompatibilityDefault-Methode

Legt die Kompatibilitätsoptionen auf der Registerkarte Kompatibilität im Dialogfeld Optionen im Menü Extras als Standardeinstellung für neue Dokumente fest.

Syntax

Ausdruck.MakeCompatibilityDefault

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur MakeCompatibilityDefault-Methode

In diesem Beispiel werden ein paar Kompatibilitätsoptionen für das aktive Dokument festgelegt und dann die aktuellen Kompatibilitätsoptionen zu Standardeinstellungen gemacht.

With ActiveDocument
    .Compatibility(wdSuppressSpBfAfterPgBrk) = True
    .Compatibility(wdExpandShiftReturn) = True
    .Compatibility(wdUsePrinterMetrics) = True
    .Compatibility(wdNoLeading) = False
    .MakeCompatibilityDefault
End With


ManualHyphenation-Methode

Initiiert die manuelle Silbentrennung eines Dokuments Zeile für Zeile. Der Benutzer wird aufgefordert, die jeweiligen Vorschläge zur Silbentrennung anzunehmen oder abzulehnen.

Syntax

Ausdruck.ManualHyphenation

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur ManualHyphenation-Methode

Dieses Beispiel startet die manuelle Silbentrennung für das aktive Dokument.

ActiveDocument.ManualHyphenation

In diesem Beispiel werden Optionen für die Silbentrennung eingestellt. Anschließend wird die manuelle Silbentrennung für MyDoc.doc gestartet.

With Documents("MyDoc.doc")
    .HyphenationZone = InchesToPoints(0.25)
    .HyphenateCaps = False
    .ManualHyphenation
End With


MarkAllCitations-Methode

Fügt nach allen Vorkommen des ShortCitation-Textes ein TA-Feld (Eintragfeld für das Rechtsgrundlagenverzeichnis) ein.

Syntax

Ausdruck.MarkAllCitations(ShortCitation, LongCitation, LongCitationAutoText, Category)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfAuthorities-Objekt zurückgibt.

ShortCitation String erforderlich. Der Text für den kurzen Eintrag, so wie er im Dialogfeld Zitat festlegen angezeigt wird (Menü Einfügen, Befehl Index und Verzeichnisse).

LongCitation Variant optional. Der Text für den langen Eintrag, wie er im Rechtsgrundlagenverzeichnis angezeigt wird.

LongCitationAutoText Variant optional. Der Name für den AutoText-Eintrag, der den Text des langen Eintrags enthält, wie er im Rechtsgrundlagenverzeichnis angezeigt wird.

Category Variant optional. Die Nummer der Kategorie, die dem Eintrag zugeordnet wird. Hierbei entspricht 1 der ersten Kategorie im Feld Kategorie des Dialogfeldes Zitat festlegen, 2 der zweiten Kategorie und so weiter.


Beispiel zur MarkAllCitations-Methode

In diesem Beispiel werden alle Vorkommen von "Forrester v. Craddock" im aktuellen Dokument mit einem TA-Feld markiert, das einen Verweis auf "Forrester v. Craddock, 51 Wn. 2d 315 (1957)" herstellt.

ActiveDocument.TablesOfAuthorities.MarkAllCitations _
    ShortCitation:="Forrester v. Craddock", Category:=1, _
    LongCitation:="Forrester v. Craddock, 51 Wn. 2d 315 (1957)"


MarkAllEntries-Methode

Fügt nach allen Instanzen des Textes in Range ein XE-Feld (Indexeintrag) ein.

Syntax

Ausdruck.MarkAllEntries(Range, Entry, EntryAutoText, CrossReference, CrossReferenceAutoText, BookmarkName, Bold, Italic)

Ausdruck Erforderlich. Ein Ausdruck, der ein Indexes-Objekt zurückgibt.

Range Range-Objekt erforderlich. Der Bereich, dessen Text überall im Dokument mit einem XE-Feld markiert wird.

Entry Variant optional. Der Text, der im Index erscheinen soll, in der Form HauptEintrag[:Untereintrag].

EntryAutoText Variant optional. Der AutoText-Eintrag, der den Text enthält, der im Index erscheinen soll (wenn dieses Argument angegeben wird, wird Entry ignoriert).

CrossReference Variant optional. Ein Querverweis, der im Index erscheinen wird.

CrossReferenceAutoText Variant optional. Der Name des AutoText-Eintrags, der den Text für einen Querverweis enthält (wenn dieses Argument angegeben wird, wird CrossReference ignoriert).

BookmarkName Variant optional. Der Name der Textmarke, die den Seitenbereich markiert, der im Index erscheinen soll. Wenn dieses Argument weggelassen wird, erscheint die Seitenzahl, die das XE-Feld enthält, im Index.

Bold Variant optional. True, wenn den Seitenzahlen für Indexeinträge Fettformatierung zugewiesen werden soll.

Italic Variant optional. True, wenn den Seitenzahlen für Indexeinträge Kursivformatierung zugewiesen werden soll.


Beispiel zur MarkAllEntries-Methode

Dieses Beispiel markiert den gewählten Text mit XE-Feldern im gesamten Dokument und aktualisiert dann den ersten XE-Eintrag im Dokument.

If Selection.Type = wdSelectionNormal Then
    ActiveDocument.Indexes.MarkAllEntries Range:=Selection.Range, _
        Entry:=Selection.Range.Text, Italic:=True
    ActiveDocument.Indexes(1).Update
End If


MarkCitation-Methode

Fügt ein TA-Feld (Eintragfeld für das Rechtsgrundlagenverzeichnis) ein und gibt das Feld als Field-Objekt zurück.

Syntax

Ausdruck.MarkCitation(Range, ShortCitation, LongCitation, LongCitationAutoText, Category)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfAuthorities-Objekt zurückgibt.

Range Range-Objekt erforderlich. Die Position des Eintrags für das Rechtsgrundlagenverzeichnis. Das TA-Feld wird nach Range eingefügt.

ShortCitation String erforderlich. Der Text für den kurzen Eintrag, so wie er im Dialogfeld Zitat festlegen angezeigt wird (Menü Einfügen, Befehl Index und Verzeichnisse).

LongCitation Variant optional. Der lange Eintrag, wie er im Rechtsgrundlagenverzeichnis angezeigt wird.

LongCitationAutoText Variant optional. Der Name für den AutoText-Eintrag, der den Text des langen Eintrags enthält, wie er im Rechtsgrundlagenverzeichnis angezeigt wird.

Category Variant optional. Die Nummer der Kategorie, die dem Eintrag zugeordnet wird. Hierbei entspricht 1 der ersten Kategorie im Feld Kategorie des Dialogfeldes Zitat festlegen, 2 der zweiten Kategorie und so weiter.


Beispiel zur MarkCitation-Methode

In diesem Beispiel wird ein Eintrag für das Rechtsgrundlagenverzeichnis (TA-Feld) für den markierten Text eingefügt. Der lange Eintrag lautet "Forrester v. Craddock", und als Kategorie wird "Other Cases" festgelegt.

ActiveDocument.TablesOfAuthorities.MarkCitation _
    Range:=Selection.Range, ShortCitation:=Selection.Range.Text, _
    LongCitation:="Forrester v. Craddock", Category:=1

In diesem Beispiel wird ein Eintrag für das Rechtsgrundlagenverzeichnis für den markierten Text eingefügt. Im Rechtsgrundlagenverzeichnis wird als Eintrag der Text angezeigt, der in der Eingabeaufforderung des Dialogfeldes eingegeben wird, und als Kategorie wird "Other Authorities" festgelegt.

citationText = InputBox("Type citation text")
ActiveDocument.TablesOfAuthorities.MarkCitation _
    Range:=Selection.Range, ShortCitation:=Selection.Range.Text, _
    LongCitation:=citationText, Category:=3


MarkEntry-Methode

Syntax 1: Fügt ein XE-Feld (Indexeintrag) nach dem angegebenen Bereich ein. Das XE-Feld wird als Field-Objekt zurückgegeben.

Syntax 2: Fügt ein TC-Feld nach dem angegebenen Bereich ein. Das TC-Feld wird als Field-Objekt zurückgegeben.

Syntax 1

Ausdruck.MarkEntry(Range, Entry, EntryAutoText, CrossReference, CrossReferenceAutoText, BookmarkName, Bold, Italic)

Syntax 2

Ausdruck.MarkEntry(Range, Entry, EntryAutoText, TableID, Level)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Indexes-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein TablesOfContents- oder TablesOfFigures-Objekt zurückgibt.

Range Range-Objekt erforderlich. Die Position des Eintrags. Das XE- oder TC-Feld wird nach Range eingefügt.

Entry Variant optional. Der Text, der im Index, Inhaltsverzeichnis oder Abbildungsverzeichnis erscheint. Zur Kennzeichnung eines Untereintrags fügen Sie den Haupteintragstext und den Untereintragstext durch einen Doppelpunkt getrennt (:) ein (zum Beispiel "Einführung: Das Produkt").

EntryAutoText Variant optional. Der Name des AutoText-Eintrags, der Text für den Index, das Abbildungsverzeichnis oder Inhaltsverzeichnis enthält (Entry wird ignoriert).

CrossReference Variant optional. Ein Querverweis, der im Index erscheinen wird (zum Beispiel "Siehe Äpfel").

CrossReferenceAutoText Variant optional. Der Name des AutoText-Eintrags, der den Text für einen Querverweis enthält (CrossReference wird ignoriert).

BookmarkName Variant optional. Der Name der Textmarke, die den Seitenbereich kennzeichnet, der im Index erscheinen soll. Wenn dieses Argument weggelassen wird, erscheint im Index die Nummer der Seite, die das XE-Feld enthält.

Bold Variant optional. True, wenn der Eintrag Seitenzahlen im Index fett formatiert werden soll.

Italic Variant optional. True, wenn der Eintrag Seitenzahlen im Index kursiv formatiert werden soll.

TableID Variant optional. Ein Kennzeichen aus einem Buchstaben für das Abbildungsverzeichnis- oder Inhaltsverzeichnis-Element (beispielsweise "I" für eine "Illustration").

Level Variant optional. Eine Ebene für den Eintrag im Inhaltsverzeichnis oder Abbildungsverzeichnis.


Beispiel zur MarkEntry-Methode

In diesem Beispiel wird im aktiven Dokument nach der Markierung ein Indexeintrag eingefügt. Der Text des Untereintrags ist der Text aus der Markierung.

If Selection.Type = wdSelectionNormal Then
    ActiveDocument.Indexes.MarkEntry Range:=Selection.Range, _
        Entry:="Introduction:" & Selection.Range.Text, Italic:=True
End If

In diesem Beispiel wird ein Inhaltsverzeichniseintrag eingefügt, der auf den markierten Text verweist. Der Text, der in das Eingabefeld getippt wird, erscheint im Inhaltsverzeichnis. Am Anfang des aktiven Dokuments wird dann ein Inhaltsverzeichnis hinzugefügt, das Felder verwendet.

entryText = InputBox("Type entry text")
ActiveDocument.TablesOfContents.MarkEntry _
    Range:=Selection.Range, Entry:=entryText
Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfContents.Add _
    Range:=myRange, UseFields:=True, _
    UseHeadingStyles:=False


Merge-Methode

Cell-Objekt: Verbindet die angegebene Tabellenzelle mit einer anderen Zelle. Das Ergebnis ist eine einzige Tabellenzelle.

Cells-Objekt: Verbindet die angegebenen Tabellenzellen miteinander. Das Ergebnis ist eine einzige Tabellenzelle.

Document-Objekt: Integriert die Änderungen, die in einem Dokument mit Korrekturmarkierungen gekennzeichnet wurden, in ein anderes Dokument.

Subdocument-Objekt: Verbindet die angegebenen Filialdokumente eines Zentraldokuments zu einem einzigen Filialdokument.

Syntax 1

Ausdruck.Merge(MergeTo)

Syntax 2

Ausdruck.Merge

Syntax 3

Ausdruck.Merge(FileName)

Syntax 4

Ausdruck.Merge(FirstSubdocument, LastSubdocument)

Ausdruck Syntax 1: Ein Ausdruck, der ein Cell-Objekt zurückgibt.

Syntax 2: Ein Ausdruck, der ein Cells-Objekt zurückgibt.

Syntax 3: Ein Ausdruck, der ein Document-Objekt zurückgibt.

Syntax 4: Ein Ausdruck, der ein Subdocuments-Objekt zurückgibt.

MergeTo Cell erforderlich. Die Zelle mit der verbunden wird.

FileName String erforderlich. Der Pfad- und Dateiname des Originaldokuments, in dem die Korrekturen integriert werden sollen.

FirstSubdocument Variant optional. Das erste Filialdokument in einem Filialdokumentenbereich, der verbunden werden soll.

LastSubdocument Variant optional. Das letzte Filialdokument in einem Filialdokumentenbereich, der verbunden werden soll.


Beispiel zur Merge-Methode

In diesem Beispiel werden die ersten zwei Zellen in Tabelle 1 im aktiven Dokument miteinander verbunden. Dann werden die Tabellenränder entfernt.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1)
        .Cell(Row:=1, Column:=1).Merge _
            MergeTo:=.Cell(Row:=1, Column:=2)
        .Borders.Enable = False
    End With
End If

In diesem Beispiel werden die Änderungen aus Sales1.doc in Sales2.doc (das aktive Dokument) integriert.

If InStr(1, ActiveDocument.Name, "sales2.doc", 1) Then _
    ActiveDocument.Merge FileName:="C:\Docs\Sales1.doc"

In diesem Beispiel werden die Zellen in Zeile 1 der Auswahl zu einer einzigen Zelle verbunden. Dann wird der Zelle eine Schattierung zugewiesen.

If Selection.Information(wdWithInTable) = True Then
    Set myrow = Selection.Rows(1)
    myrow.Cells.Merge
    myrow.Shading.Texture = wdTexture10Percent
End If

In diesem Beispiel werden das erste und das zweite Filialdokument im aktiven Dokument zu einem Filialdokument verbunden.

If ActiveDocument.Subdocuments.Count >= 2 Then
    Set aDoc = ActiveDocument
    aDoc.Subdocuments.Merge _
        FirstSubdocument:=aDoc.Subdocuments(1), _
        LastSubdocument:=aDoc.Subdocuments(2)
End If


MillimetersToPoints-Methode

Ändert eine Maßeinheit von Millimeter in Punkt (1 mm = 2,85 Punkt). Die geänderte Maßeinheit wird als Single zurückgegeben.

Syntax

Ausdruck.MillimetersToPoints(Millimeters)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Millimeters Single erforderlich. Der Millimeterwert, der in Punkt geändert werden soll.


Beispiel zur MillimetersToPoints-Methode

In diesem Beispiel werden für die Silbentrennzone im aktiven Dokument 8,8 Millimeter festgelegt.

ActiveDocument.HyphenationZone = MillimetersToPoints(8.8)

Dieses Beispiel erhöht den Abstand zwischen den markierten Zeichen auf 2,85 Punkt.

Selection.Font.Spacing = MillimetersToPoints(1)


ModifyEnclosure-Methode

Sprachspezifische Informationen

Adds, modifies, or removes an enclosure around the specified character or characters.

Syntax

expression.ModifyEnclosure(Style, Symbol, EnclosedText)

expression Required. An expression that returns a Range object.

Style Required Variant. The style of the enclosure. Can be one of the following WdEncloseStyle constants: wdEncloseStyleLarge, wdEncloseStyleNone, or wdEncloseStyleSmall.

Symbol Optional Variant. The symbol in which to enclose the specified range. Can be one of the following WdEnclosureType constants: wdEnclosureCircle, wdEnclosureDiamond, wdEnclosureSquare, or wdEnclosureTriangle. The default is wdEnclosureCircle.

EnclosedText Optional Variant. The characters that you want to enclose. If you include this argument, Microsoft Word replaces the specified range with the enclosed characters. If you don't specify text to enclose, Microsoft Word encloses all text in the specified range.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur ModifyEnclosure-Methode

Sprachspezifische Informationen

This example replaces the current selection with the number 25 enclosed in a circle.

Selection.Range.ModifyEnclosure wdEncloseStyleLarge, _
    wdEnclosureCircle, "25"


Move-Methode

Range- oder Selection-Objekt: Reduziert den angegebenen Bereich oder die Markierung auf ihre Startposition oder Endposition und verschiebt das reduzierte Objekt dann um die angegebene Anzahl von Einheiten. Diese Methode gibt einen Wert zurück, der die Anzahl der Einheiten anzeigt, um die das Objekt tatsächlich verschoben wurde, oder sie gibt 0 (Null) zurück, wenn die Verschiebung nicht erfolgreich war.

Application- oder Task-Objekt: Positioniert ein Task-Fenster oder das aktive Dokumentfenster.

Syntax 1

Ausdruck.Move(Unit, Count)

Syntax 2

Ausdruck.Move(Left, Top)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt (Syntax 1), oder ein Ausdruck, der ein Application- oder Task-Objekt zurückgibt (Syntax 2).

Unit Variant optional. Die Einheit, um die der reduzierte Bereich oder die reduzierte Markierung verschoben werden soll. Dies kann eine der folgenden WdUnits-Konstanten sein: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, können Sie auch wdLine verwenden. Der Standardwert ist wdCharacter.

Count Variant optional. Die Anzahl der Einheiten, um die der angegebene Bereich oder die Markierung verschoben werden soll. Wenn Count eine positive Zahl ist, wird das Objekt zu seiner Endposition reduziert und im Dokument um die angegebene Anzahl von Einheiten vorwärts verschoben. Wenn Count eine negative Zahl ist, wird das Objekt zu seiner Startposition reduziert und um die angegebene Anzahl von Einheiten rückwärts verschoben. Der Standardwert ist 1. Sie können auch die Reduktionsrichtung steuern, indem Sie die Collapse-Methode vor der Move-Methode anwenden.

Wenn der Bereich oder die Markierung in der Mitte einer Einheit ist oder nicht reduziert ist, zählt das Verschieben zum Anfang oder Ende der Einheit wie das Verschieben um eine ganze Einheit.

Left Long erforderlich. Die horizontale Bildschirmposition des angegebenen Fensters.

Top Long erforderlich. Die vertikale Bildschirmposition des angegebenen Fensters.

Hinweise

Die Startposition und Endposition eines reduzierten Bereichs oder der reduzierten Markierung sind gleich.

Die Anwendung der Move-Methode auf einen Bereich ordnet den Text im Dokument nicht um. Der Bereich wird vielmehr neu definiert, so dass er sich auf eine andere Stelle im Dokument bezieht.

Wenn Sie die Move-Methode auf einen Bereich anwenden, der keine Range-Objektvariable ist (beispielsweise Selection.Paragraphs(3).Range.Move), ist die Methode wirkungslos.

Beim Verschieben eines Selection-Objekts wird die Markierung reduziert und die Einfügemarke im Dokument entweder vorwärts oder rückwärts verschoben.


MoveDown-Methode

Verschiebt die Auswahl nach unten und gibt die Anzahl der Einheiten zurück, um die sie verschoben wurde.

Anmerkung Mit der wdWindow-Konstante können Sie an den Anfang oder an das Ende des aktuellen Fensters gehen. Mit der wdWindow-Konstante verschieben Sie die Auswahl unabhängig vom Wert Count (größer als 1 oder kleiner als – 1) nur um eine Einheit. Verwenden Sie die wdScreen-Konstante, wenn Sie die Auswahl um mehr als eine Bildschirmseite verschieben möchten.

Syntax

Ausdruck.MoveDown(Unit, Count, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben werden soll. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdLine, wdParagraph, wdWindow, oder wdScreen. Der Standardwert lautet wdLine.

Count Variant optional. Die Anzahl der Einheiten, um die die Auswahl verschoben werden soll. Der Standardwert beträgt 1.

Extend Variant optional. Dabei kann es sich um wdMove oder wdExtend handeln. Wenn Sie wdMove verwenden, wird die Auswahl zu einer Einfügemarke reduziert und nach unten verschoben. Wenn Sie wdExtend verwenden, wird die Auswahl nach unten erweitert. Der Standardwert lautet wdMove.


Beispiel zur MoveDown-Methode

In diesem Beispiel wird die Auswahl um eine Zeile nach unten erweitert.

Selection.MoveDown Unit:=wdLine, Count:=1, Extend:=wdExtend

In diesem Beispiel wird die Auswahl um drei Absätze nach unten verschoben. Wenn das Verschieben erfolgreich ausgeführt werden konnte, wird an der Einfügemarke "Company" eingefügt.

unitsMoved = Selection.MoveDown(Unit:=wdParagraph, _
    Count:=3, Extend:=wdMove)
If unitsMoved = 3 Then Selection.Text = "Company"

In diesem Beispiel wird die aktuelle Zeilennummer angezeigt, die Auswahl um drei Zeilen nach unten verschoben und wiederum die aktuelle Zeilennummer angezeigt.

MsgBox "Line " & Selection.Information(wdFirstCharacterLineNumber)
Selection.MoveDown Unit:=wdLine, Count:=3, Extend:=wdMove
MsgBox "Line " & Selection.Information(wdFirstCharacterLineNumber)


MoveEnd-Methode

Verschiebt die Endzeichenposition eines Bereichs oder einer Markierung. Diese Methode gibt eine ganze Zahl zurück, die die Anzahl der Einheiten angibt, um die der Bereich oder die Markierung tatsächlich verschoben wurde, oder sie gibt 0 (Null) zurück, wenn die Verschiebung nicht erfolgreich war.

Syntax

Ausdruck.MoveEnd(Unit, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Endzeichenposition verschoben werden soll. Kann eine der folgenden WdUnits-Konstanten sein: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, kann man auch wdLine verwenden. Die Standardeinstellung ist wdCharacter.

Count Variant optional. Die Anzahl der Einheiten, um die verschoben werden soll. Wenn diese Zahl positiv ist, wird die Endzeichenposition im Dokument vorwärts verschoben. Wenn diese Zahl negativ ist, wird das Ende rückwärts verschoben. Wenn die Endposition die Anfangsposition überholt, wird der Bereich reduziert und die beiden Zeichenpositionen werden zusammen verschoben. Die Standardeinstellung ist 1.


MoveEndUntil-Methode

Verschiebt die Endposition des angegebenen Bereichs oder der Markierung bis eines der angegebenen Zeichen im Dokument gefunden wird. Wenn die Verschiebung im Dokument vorwärts erfolgt, wird der Bereich oder die Markierung erweitert.

Anmerkungen

Diese Methode gibt die Anzahl der Zeichen, um die die Endposition des angegebenen Bereichs oder der Markierung verschoben wurde, als Long-Wert zurück. Wenn keine Cset-Zeichen gefunden werden, wird der Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück. Wenn die Endposition rückwärts zu einem Punkt bewegt wird, der vor der ursprünglichen Startposition liegt, wird die Startposition auf die neue Endposition festgelegt.

Syntax

Ausdruck.MoveEndUntil(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen.

Count Variant optional. Die maximale Anzahl an Zeichen, um die der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der Konstanten wdForward oder wdBackward. Wenn Count eine positive Zahl ist, wird der Bereich oder die Markierung im Dokument vorwärts verschoben. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben. Der Standardwert ist wdForward.


Beispiel zur MoveEndUntil-Methode

In diesem Beispiel wird die Markierung im Dokument vorwärts erweitert, bis der Buchstabe "a" gefunden wird. In dem Beispiel wird dann die Markierung um ein Zeichen erweitert, damit der Buchstabe "a" darin enthalten ist.

With Selection
    .MoveEndUntil Cset:="a", Count:=wdForward
    .MoveRight Unit:=wdCharacter, Count:=1, Extend:=wdExtend
End With

In diesem Beispiel wird die Markierung im Dokument vorwärts erweitert, bis ein Tabstopp gefunden wird. Wenn in den nächsten 100 Zeichen kein Tabstoppzeichen gefunden wird, wird die Markierung nicht erweitert.

char = Selection.MoveEndUntil(Cset:=vbTab, Count:=100)
If char = 0 Then StatusBar = "Selection not moved"


MoveEndWhile-Methode

Verschiebt die Endzeichenposition eines Bereichs oder einer Markierung, solange eines der angegebenen Zeichen im Dokument gefunden wird.

Hinweise

Solange eines der Zeichen in Cset gefunden wird, wird die Endposition des angegebenen Bereichs oder der Markierung verschoben. Diese Methode gibt die Anzahl der Zeichen, um die die Endposition des Bereichs oder der Markierung verschoben wurde, als Long-Wert zurück. Wenn keine Cset-Zeichen gefunden werden, wird der Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück. Wenn die Endposition rückwärts zu einem Punkt verschoben wird, der vor der ursprünglichen Startposition liegt, wird die Startposition auf der neuen Endposition festgelegt.

Syntax

Ausdruck.MoveEndWhile(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen.

Count Variant optional. Die maximale Anzahl von Zeichen, um die der Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der beiden Konstanten wdForward oder wdBackward. Wenn Count eine positive Zahl ist, wird der Bereich oder die Markierung im Dokument vorwärts verschoben. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben. Der Standardwert ist wdForward.


Beispiel zur MoveEndWhile-Methode

In diesem Beispiel wird die Endposition der Markierung vorwärts verschoben, solange ein Leerzeichen gefunden wird.

Selection.MoveEndWhile Cset:=" ", Count:=wdForward

In diesem Beispiel wird die Endposition der Markierung vorwärts verschoben, solange Count kleiner als oder gleich 10 ist und einer der Buchstaben von "a" bis "h" gefunden wird.

Selection.MoveEndWhile Cset:="abcdefgh", Count:=10


MoveLeft-Methode

Verschiebt die Auswahl nach links und gibt die Anzahl der Einheiten zurück, um die sie verschoben wurde.

Syntax

Ausdruck.MoveLeft(Unit, Count, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben werden soll. Es kann sich um eine der folgenden WdUnits-Konstanten handeln: wdCell, wdCharacter, wdWord oder wdSentence. Der Standardwert lautet wdCharacter.

Count Variant optional. Die Anzahl der Einheiten, um die die Auswahl verschoben werden soll. Der Standardwert lautet 1.

Extend Variant optional. Dabei kann es sich um wdMove oder wdExtend handeln. Wenn Sie wdMove verwenden, wird die Auswahl zu einer Einfügemarke reduziert und nach links verschoben. Wenn Sie wdExtend verwenden, wird die Auswahl nach links erweitert. Der Standardwert lautet wdMove.

Hinweise

Wenn Unit den Wert wdCell hat, kann das Argument Extend nur den Wert wdMove haben.


Beispiel zur MoveLeft-Methode

In diesem Beispiel wird die Auswahl um ein Zeichen nach links verschoben. Wenn der Vorgang erfolgreich durchgeführt wurde, gibt MoveLeft den Wert 1 zurück.

If Selection.MoveLeft = 1 Then MsgBox "Move was successful"

In diesem Beispiel wird die Feldschattierung für das ausgewählte Feld aktiviert, ein DATE-Feld eingefügt und die Auswahl nach links verschoben, um das Feld auszuwählen.

ActiveDocument.ActiveWindow.View.FieldShading = _
    wdFieldShadingWhenSelected
With Selection
    .Fields.Add Range:=Selection.Range, Type:=wdFieldDate
    .MoveLeft Unit:=wdWord, Count:=1
End With

In diesem Beispiel wird die Auswahl zur vorherigen Tabellenzelle verschoben.

If Selection.Information(wdWithInTable) = True Then
    Selection.MoveLeft Unit:=wdCell, Count:=1, Extend:=wdMove
End If


MoveRight-Methode

Verschiebt die Auswahl nach rechts und gibt die Anzahl der Einheiten zurück, um die sie verschoben wurde.

Syntax

Ausdruck.MoveRight(Unit, Count, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben werden soll. Es kann sich um eine der folgenden WdUnits-Konstanten handeln: wdCell, wdCharacter, wdWord oder wdSentence. Der Standardwert lautet wdCharacter.

Count Variant optional. Die Anzahl der Einheiten, um die die Auswahl verschoben werden soll. Der Standardwert beträgt 1.

Extend Variant optional. Dabei kann es sich um wdMove oder wdExtend handeln. Wenn Sie wdMove verwenden, wird die Auswahl zu einer Einfügemarke reduziert und nach rechts verschoben. Wenn Sie wdExtend verwenden, wird die Auswahl nach rechts erweitert. Der Standardwert lautet wdMove.

Anmerkungen

Wenn Unit den Wert wdCell hat, kann das Argument Extend nur den Wert wdMove haben.


Beispiel zur MoveRight-Methode

In diesem Beispiel wird die Auswahl vor das vorherige Feld verschoben und anschließend das Feld ausgewählt.

With Selection
    Set MyRange = .GoTo(wdGoToField, wdGoToPrevious)
    .MoveRight Unit:=wdWord, Count:=1, Extend:=wdExtend
    If Selection.Fields.Count = 1 Then Selection.Fields(1).Update
End With

In diesem Beispiel wird die Auswahl um ein Zeichen nach rechts verschoben. Wenn der Vorgang erfolgreich ausgeführt wurde, gibt MoveRight den Wert 1 zurück.

If Selection.MoveRight = 1 Then MsgBox "Move was successful"

In diesem Beispiel wird die Auswahl zur nächsten Tabellenzelle verschoben.

If Selection.Information(wdWithInTable) = True Then
    Selection.MoveRight Unit:=wdCell, Count:=1, Extend:=wdMove
End If


MoveStart-Methode

Verschiebt die Startposition des angegebenen Bereichs oder der Markierung. Diese Methode gibt eine ganze Zahl zurück, die die Anzahl der Einheiten anzeigt, um die die Startposition des Bereichs oder der Markierung tatsächlich verschoben wird, oder sie gibt 0 (Null) zurück, wenn die Verschiebung nicht erfolgreich war.

Syntax

Ausdruck.MoveStart(Unit, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Startposition des angegebenen Bereichs oder der Markierung verschoben werden soll. Dies kann eine der folgenden WdUnits-Konstanten sein: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, können Sie auch wdLine verwenden. Der Standardwert ist wdCharacter.

Count Variant optional. Die maximale Anzahl der Einheiten, um die der angegebene Bereich oder die Markierung verschoben werden soll. Wenn Count eine positive Zahl ist, wird die Startposition des Bereichs oder der Markierung im Dokument vorwärts verschoben. Wenn es eine negative Zahl ist, wird die Startposition rückwärts verschoben. Wenn die Startposition vorwärts zu einer Position über die Endposition hinaus verschoben wird, wird der Bereich oder die Markierung reduziert, und die Start- und Endposition fallen zusammen. Der Standardwert ist 1.


MoveStartUntil-Methode

Verschiebt die Startposition des angegebenen Bereichs oder der Markierung bis eines der angegebenen Zeichen im Dokument gefunden wird. Wenn die Verschiebung rückwärts durch das Dokument erfolgt, wird der Bereich oder die Markierung erweitert.

Anmerkungen

Diese Methode gibt die Anzahl der Zeichen, um die die Startposition des angegebenen Bereichs oder der Markierung verschoben wurde, als Long-Wert zurück. Wenn keine Cset-Zeichen gefunden werden, wird der angegebene Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück. Wenn die Startposition vorwärts zu einem Punkt hinter der Endposition verschoben wird, wird der Bereich oder die Markierung reduziert, und die Start- und Endposition fallen zusammen.

Syntax

Ausdruck.MoveStartUntil(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen.

Count Variant optional. Die maximale Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der Konstanten wdForward oder wdBackward. Wenn Count eine positive Zahl ist, wird der Bereich oder die Markierung im Dokument vorwärts verschoben. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben. Der Standardwert ist wdForward.


Beispiel zur MoveStartUntil-Methode

In diesem Beispiel wird die Markierung rückwärts erweitert, bis der Großbuchstabe "I" gefunden wird.

Selection.MoveStartUntil Cset:="I", Count:=wdBackward

Wenn im ersten Absatz in der Markierung ein Dollarzeichen ($) enthalten ist, wird in diesem Beispiel myRange direkt vor das Dollarzeichen verschoben.

Set myRange = Selection.Paragraphs(1).Range
leng = myRange.End - myRange.Start
myRange.Collapse Direction:=wdCollapseStart
myRange.MoveStartUntil Cset:="$", Count:=leng


MoveStartWhile-Methode

Verschiebt die Startposition des angegebenen Bereichs oder der Markierung, solange eines der angegebenen Zeichen im Dokument gefunden wird.

Hinweise

Solange eines der Zeichen in Cset gefunden wird, wird die Startposition des Bereichs oder der Markierung verschoben. Diese Methode gibt die Anzahl der Zeichen, um die die Startposition des Bereichs oder der Markierung verschoben wurde, als Long-Wert zurück. Wenn keine Zeichen aus Cset gefunden werden, wird der Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück. Wenn die Startposition vorwärts zu einer Position hinter der ursprünglichen Endposition verschoben wird, wird die Endposition auf der neuen Startposition festgelegt.

Syntax

Ausdruck.MoveStartWhile(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen.

Count Variant optional. Die maximale Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der Konstanten wdForward und wdBackward. Wenn Count eine positive Zahl ist, wird der Bereich oder die Markierung im Dokument vorwärts verschoben. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben. Der Standardwert ist wdForward.


Beispiel zur MoveStartWhile-Methode

In diesem Beispiel wird die Startposition der Markierung rückwärts durch das Dokument verschoben, solange ein Leerzeichen gefunden wird.

Selection.MoveStartWhile Cset:=" ", Count:=wdBackward

In diesem Beispiel wird die Startposition der Markierung rückwärts durch das Dokument verschoben, solange Count kleiner oder gleich 10 ist und einer der Buchstaben von "a" bis "h" gefunden wird.

Selection.MoveStartWhile Cset:="abcdefgh", Count:=-10


MoveUntil-Methode

Verschiebt den angegebenen Bereich oder die Markierung, bis eines der angegebenen Zeichen im Dokument gefunden wird.

Hinweise

Diese Methode gibt die Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben wurde, als Long-Wert zurück. Wenn Count größer als 0 (Null) ist, gibt diese Methode die Anzahl der Zeichen, um die verschoben wurde, plus 1 zurück. Wenn Count kleiner als 0 (Null) ist, gibt diese Methode die Anzahl der Zeichen, um die verschoben wurde, minus 1 zurück. Wenn keine Cset-Zeichen gefunden werden, wird der Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück.

Syntax

Ausdruck.MoveUntil(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen. Wenn eines der Zeichen in Cset gefunden wird, bevor der Count-Wert erreicht wird, wird der angegebene Bereich oder die Markierung unmittelbar vor diesem Zeichen als Einfügemarke positioniert.

Count Variant optional. Die maximale Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der Konstanten wdForward oder wdBackward. Wenn Count eine positive Zahl ist, wird der Bereich oder die Markierung im Dokument vorwärts verschoben, beginnend an der Endposition. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben, beginnend an der Startposition. Der Standardwert ist wdForward.


Beispiel zur MoveUntil-Methode

In diesem Beispiel wird myRange durch die nächsten 100 Zeichen im Dokument vorwärts verschoben, bis das Zeichen "t" gefunden wird.

Set myRange = ActiveDocument.Words(1)
myRange.MoveUntil Cset:="t", Count:=100

In diesem Beispiel wird die Markierung vorwärts zum Ende des aktiven Absatzes verschoben, und dann wird die Anzahl der Zeichen angezeigt, um die die Markierung verschoben wurde.

x = Selection.MoveUntil(Cset:=Chr$(13), Count:=wdForward)
MsgBox x-1 & " character positions were moved"


MoveUp-Methode

Verschiebt die Auswahl nach oben und gibt die Anzahl der Einheiten zurück, um die sie verschoben wurde.

Hinweis Mit der wdWindow-Konstante können Sie an den Anfang oder an das Ende des aktuellen Fensters gehen. Mit der wdWindow-Konstante verschieben Sie die Auswahl unabhängig vom Wert Count (größer als 1 oder kleiner als – 1) nur um eine Einheit. Verwenden Sie die wdScreen-Konstante, wenn Sie die Auswahl um mehr als eine Bildschirmseite verschieben möchten.

Syntax

Ausdruck.MoveUp(Unit, Count, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Auswahl verschoben werden soll. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdLine, wdParagraph, wdWindow oder wdScreen. Der Standardwert lautet wdLine.

Count Variant optional. Die Anzahl der Einheiten, um die die Auswahl verschoben werden soll. Der Standardwert lautet 1.

Extend Variant optional. Sie können entweder wdMove oder wdExtend verwenden. Wenn Sie wdMove verwenden, wird die Auswahl zu einer Einfügemarke reduziert und nach oben verschoben. Wenn Sie wdExtend verwenden, wird die Auswahl nach oben erweitert. Der Standardwert lautet wdMove.


Beispiel zur MoveUp-Methode

In diesem Beispiel wird die Auswahl zum Anfang des vorherigen Absatzes verschoben.

Selection.MoveRight
Selection.MoveUp Unit:=wdParagraph, Count:=2, Extend:=wdMove

In diesem Beispiel wird die aktuelle Zeilennummer angezeigt, die Auswahl um drei Zeilen nach oben verschoben und wiederum die aktuelle Zeilennummer angezeigt.

MsgBox "Line " & Selection.Information(wdFirstCharacterLineNumber)
Selection.MoveUp Unit:=wdLine, Count:=3, Extend:=wdMove
MsgBox "Line " & Selection.Information(wdFirstCharacterLineNumber)


MoveWhile-Methode

Verschiebt den angegebenen Bereich oder die Markierung, solange eines der angegebenen Zeichen im Dokument gefunden wird.

Hinweise

Solange eines der Zeichen in Cset gefunden wird, wird der angegebene Bereich oder die Markierung verschoben. Das resultierende Range- oder Selection-Objekt wird als Einfügemarke nach den gefundenen Cset-Zeichen positioniert. Diese Methode gibt die Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben wurde, als Long-Wert zurück. Wenn keine Cset-Zeichen gefunden werden, wird der Bereich oder die Markierung nicht geändert, und die Methode gibt 0 (Null) zurück.

Syntax

Ausdruck.MoveWhile(Cset, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Cset Variant erforderlich. Ein oder mehrere Zeichen.

Count Variant optional. Die maximale Anzahl der Zeichen, um die der angegebene Bereich oder die Markierung verschoben werden soll. Dies kann eine Zahl sein oder eine der Konstanten wdForward oder wdBackward. Wenn Count eine positive Zahl ist, wird der angegebene Bereich oder die Markierung im Dokument vorwärts verschoben, beginnend an der Endposition. Wenn es eine negative Zahl ist, wird der Bereich oder die Markierung rückwärts verschoben, beginnend an der Startposition. Der Standardwert ist wdForward.


Beispiel zur MoveWhile-Methode

In diesem Beispiel wird die Markierung hinter nachfolgende Tabulatoren verschoben.

Selection.MoveWhile Cset:=vbTab, Count:=wdForward

In diesem Beispiel wird aRange verschoben, solange einer der folgenden Buchstaben (Groß- oder Kleinbuchstaben) gefunden wird: "a", "t" oder "i".

Set aRange = ActiveDocument.Characters(1)
aRange.MoveWhile Cset:="atiATI", Count:=wdForward


MSInfo-Methode

Startet die Anwendung Microsoft Systeminfo, wenn sie noch nicht aktiv ist oder wechselt zu dieser Anwendung, wenn sie bereits läuft.

Syntax

Ausdruck.MSInfo

Ausdruck Erforderlich. Ein Ausdruck, der ein System-Objekt zurückgibt.


Beispiel zur MSInfo-Methode

In diesem Beispiel wird die Anwendung Microsoft Systeminfo gestartet oder auf sie gewechselt.

System.MSInfo


New-Methode

Fügt ein leeres, 1 Quadratzoll großes Word-Grafikobjekt ein, das von einem Rahmen umgeben ist. Diese Methode gibt die neue Grafik als InlineShape-Objekt zurück.

Syntax

Ausdruck.New(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein InlineShapes-Objekt zurückgibt.

Range Range-Objekt erforderlich. Der Ort der neuen Grafik.


NewFrameset-Methode

Erstellt eine neue, auf dem angegebenen Fensterausschnitt basierende Framesseite.

Syntax

Ausdruck.NewFrameset

Ausdruck Required. Ein Ausdruck, der ein Pane-Objekt zurückgibt.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur NewFrameset-Methode

In diesem Beispiel wird ein Dokument mit dem Namen Temp.doc geöffnet und anschließend eine neue Framesseite erstellt, deren einziger Frame die Datei Temp.doc enthält.

Documents.Open "C:\My Documents\Temp.doc"
ActiveDocument.ActiveWindow.ActivePane.NewFrameset


NewWindow-Methode

Öffnet ein neues Fenster mit demselben Dokument wie das angegebene Fenster. Gibt ein Window-Objekt zurück.

Hinweis Ein Doppelpunkt (:) und eine Nummer erscheinen in der Fensterbeschriftung, wenn mehr als ein Fenster für ein Dokument geöffnet ist.

Syntax

Ausdruck.NewWindow

Ausdruck Erforderlich. Ein Ausdruck, der ein Application- oder Window-Objekt zurückgibt.

Anmerkungen

Wenn die NewWindow-Methode mit dem Application-Objekt verwendet wird, wird für das aktive Fenster ein neues Fenster geöffnet. Die beiden folgenden Anweisungen sind in funktioneller Hinsicht äquivalent.

Set myWindow = ActiveDocument.ActiveWindow.NewWindow
Set myWindow = NewWindow


Beispiel zur NewWindow-Methode

In diesem Beispiel wird eine Meldung angezeigt, die die Anzahl der Fenster angibt, die vor und nach dem Öffnen eines neuen Fensters für Document1 vorhanden sind.

MsgBox Windows.Count & " windows open"
Windows("Document1").NewWindow
MsgBox Windows.Count & " windows open"

In diesem Beispiel wird ein neues Fenster geöffnet, dann werden alle geöffneten Fenster angeordnet, anschließend wird das neue Fenster geschlossen. Zum Schluss werden die geöffneten Fenster neu angeordnet.

Set myWindow = NewWindow
Windows.Arrange ArrangeStyle:=wdTiled
myWindow.Close
Windows.Arrange ArrangeStyle:=wdTiled


Next-Methode

Syntax 1: Wird die Methode dem Browser-Objekt zugewiesen, wird die Auswahl zum nächsten Element verschoben, das vom Browser-Ziel angegeben wird. Mit der Target-Eigenschaft ändern Sie das Browser-Ziel.

Syntax 2: Gibt den nächsten Absatz als ein Paragraph-Objekt zurück.

Syntax 3: Gibt ein Range-Objekt relativ zur angegebenen Auswahl oder zum Bereich zurück.

Hinweis Wenn sich der Bereich oder die Auswahl direkt vor der angegebenen Einheit befindet, wird der Bereich oder die Auswahl zur folgenden Einheit verschoben. Wenn sich beispielsweise die Auswahl direkt vor einem Wort befindet, wird die Auswahl im folgenden Befehl zum nächsten Wort verschoben.

Selection.Next(Unit:=wdWord, Count:=1).Select

Syntax 1

Ausdruck.Next

Syntax 2

Ausdruck.Next(Count)

Syntax 3

Ausdruck.Next(Unit, Count)

Ausdruck Syntax 1: Ein Ausdruck, der ein Browser-Objekt zurückgibt.

Syntax 2: Ein Ausdruck, der ein Paragraph-Objekt zurückgibt.

Syntax 3: Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, können Sie auch wdLine verwenden. Der Standardwert lautet wdCharacter.

Count Long optional. Die Anzahl der Absätze (Syntax 2) oder Einheiten (Syntax 3), um die nach vorn verschoben werden soll. Der Standardwert lautet 1.


NextCitation-Methode

Sucht das nächste Vorkommen des durch ShortCitation angegebenen Textes und markiert dieses.

Syntax

Ausdruck.NextCitation(ShortCitation)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfAuthorities-Objekt zurückgibt.

ShortCitation String erforderlich. Der Text des kurzen Eintrags.


Beispiel zur NextCitation-Methode

In diesem Beispiel wird der nächste Eintrag im aktuellen Dokument markiert, der mit "in re" beginnt.

ActiveDocument.TablesOfAuthorities.NextCitation _
    ShortCitation:="in re"


NextField-Methode

Markiert das nächste Feld. Wenn ein Feld gefunden wird, gibt diese Methode ein Field-Objekt zurück; andernfalls gibt sie Nothing zurück.

Syntax

Ausdruck.NextField

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur NextField-Methode

In diesem Beispiel wird das nächste Feld in der Markierung aktualisiert.

If Not (Selection.NextField Is Nothing) Then
    Selection.Fields.Update
End If

In diesem Beispiel wird das nächste Feld in der Markierung ausgewählt, und wenn ein Feld gefunden wird, wird in der Statusleiste eine Meldung angezeigt.

Set myField = Selection.NextField
If Not (myField Is Nothing) Then StatusBar = "Field found"


NextHeaderFooter-Methode

Wenn die Markierung in einer Kopfzeile ist, springt diese Methode zur nächsten Kopfzeile innerhalb des aktuellen Abschnitts (beispielsweise von einer ungeraden Kopfzeile zu einer geraden) oder zur ersten Kopfzeile im folgenden Abschnitt. Wenn die Markierung in einer Fußzeile ist, springt diese Methode zur nächsten Fußzeile.

Hinweis Wenn die Markierung in der letzten Kopfzeile oder Fußzeile im letzten Abschnitt des Dokuments ist, oder wenn sie sich überhaupt nicht in einer Kopfzeile oder Fußzeile befindet, tritt ein Fehler auf.

Syntax

Ausdruck.NextHeaderFooter

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.


Beispiel zur NextHeaderFooter-Methode

In diesem Beispiel wird im aktiven Dokument die erste Kopfzeile angezeigt und dann zur nächsten Kopfzeile gesprungen. Das Dokument muss mindestens zwei Seiten lang sein.

ActiveDocument.PageSetup.DifferentFirstPageHeaderFooter = True
With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView =wdSeekFirstPageHeader
    .NextHeaderFooter
End With


NextRevision-Methode

Sucht die nächste Überarbeitung und gibt sie als Revision-Objekt zurück.

Syntax

Ausdruck.NextRevision(Wrap)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Wrap Variant optional. True , um mit der Suche nach einer Korrektur am Anfang des Dokuments fortzufahren, nachdem das Ende des Dokuments erreicht wurde. Der Standardwert ist False.


Beispiel zur NextRevision-Methode

In diesem Beispiel wird die nächste Überarbeitung, die nach dem fünften Absatz im aktiven Dokument gefunden wird, abgelehnt. Die Variable myRev wird auf Nothing gesetzt, wenn keine Überarbeitung gefunden wird.

If ActiveDocument.Paragraphs.Count >= 5 Then
    Set myRange = ActiveDocument.Paragraphs(5).Range
    myRange.Select
    Set myRev = Selection.NextRevision
    If Not (myRev Is Nothing) Then myRev.Reject
End If

In diesem Beispiel wird die nächste gefundene Überarbeitung angenommen, wenn die Art der Überarbeitung eingefügter Text ist.

Set myRev = Selection.NextRevision(Wrap:=True)
If Not (myRev Is Nothing) Then
    If myRev.Type = wdRevisionInsert Then myRev.Accept
End If


NextSubdocument-Methode

Markiert das nächste Filialdokument. Wenn kein weiteres Filialdokument vorhanden ist, tritt ein Fehler auf.

Syntax

Ausdruck.NextSubdocument

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.


Beispiel zur NextSubdocument-Methode

In diesem Beispiel wird das aktive Dokument in Zentraldokument-Ansicht umgeschaltet und das erste Filialdokument markiert.

If ActiveDocument.Subdocuments.Count >= 1 Then
    ActiveDocument.ActiveWindow.View.Type = wdMasterView
    Selection.HomeKey unit:=wdStory, Extend:=wdMove
    Selection.NextSubdocument
End If


OneColorGradient-Methode

Legt die angegebene Füllung auf eine einfarbige fließende Farbe fest.

Syntax

Ausdruck.OneColorGradient(Style, Variant, Degree)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Der Stil der fließenden Farbe. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical. (Die Konstante msoGradientFromTitle wird nur in PowerPoint verwendet.)

Variant Long erforderlich. Die Variante der fließenden Farbe. Dies kann ein Wert von 1 bis 4 sein, entsprechend den vier Varianten auf der Registerkarte Graduell im Dialogfeld Fülleffekte. Wenn Style msoGradientFromCenter ist, kann dieses Argument 1 oder 2 sein.

Degree Single erforderlich. Der Grad der fließenden Farbe. Dies kann ein Wert zwischen 0,0 (dunkel) und 1,0 (hell) sein.


Beispiel zur OneColorGradient-Methode

In diesem Beispiel wird ein Rechteck mit einer einfarbigen fließenden Füllfarbe zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 80).Fill
    .ForeColor.RGB = RGB(0, 128, 128)
    .OneColorGradient msoGradientHorizontal, 1, 1
End With


OnTime-Methode

Startet einen Hintergrund-Timer, der ein Makro zum angegebenen Datum und zur angegebenen Uhrzeit ausführt.

Syntax

Ausdruck.OnTime(When, Name, Tolerance)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

When Variant erforderlich. Die Uhrzeit, an der das Makro ausgeführt werden soll. Dies kann eine Zeichenfolge sein, die eine Uhrzeit angibt (zum Beispiel "16:30"), oder es kann eine fortlaufende Zahl sein, die von einer Funktion wie TimeValue oder TimeSerial zurückgegeben wird (zum Beispiel TimeValue("2:30 Uhr") oder TimeSerial(14, 30, 00)). Sie können auch das Datum einbeziehen (zum Beispiel "30.06 4:15 Uhr" oder TimeValue("30.06. 4:15 Uhr")).

Verwenden Sie die Summe der zurückgegebenen Werte der Now-Funktion und entweder die TimeValue- oder die TimeSerial-Funktion, um einen Timer so einzustellen, dass ein Makro in einem bestimmten Zeitabstand nach dem Ausführen der Anweisung gestartet wird. Verwenden Sie beispielsweise Now+TimeValue("00:05:30"), wenn ein Makro 5 Minuten und 30 Sekunden nach dem Ausführen der Anweisung gestartet werden soll.

Name String erforderlich. Der Name des auszuführenden Makros. Geben Sie den vollständigen Pfad für das Makro an, damit sicher das richtige Makro ausgeführt wird (zum Beispiel "Projekt.Modul1.Makro1"). Damit das Makro ausgeführt werden kann, muss das Dokument oder die Vorlage verfügbar sein, wenn die OnTime-Anweisung ausgeführt wird und der Zeitpunkt aktuell ist, der mit When festgelegt wurde. Es ist daher zu empfehlen, das Makro unter "Normal.dot" oder einer anderen globalen Vorlage zu speichern, die automatisch geladen wird.

Tolerance Variant optional. Der maximale Zeitraum (in Sekunden), der vergehen kann, bevor ein Makro abgebrochen wird, das zu dem mit When festgelegten Zeitpunkt nicht ausgeführt wurde. Makros können nicht immer zum angegebenen Zeitpunkt ausgeführt werden. Wenn beispielsweise noch eine Sortierung durchgeführt oder ein Dialogfeld angezeigt wird, verzögert sich die Ausführung des Makros, bis Word den Vorgang abgeschlossen hat. Ist dieses Argument 0 (Null) oder wird es weggelassen, wird das Makro unabhängig davon ausgeführt, wie viel Zeit seit dem durch When festgelegten Zeitpunkt vergangen ist.

Anmerkungen

In Word kann jeweils nur ein mit OnTime festgelegter Hintergrund-Timer eingesetzt werden. Wenn Sie einen weiteren Timer starten, bevor ein vorhandener Timer ausgeführt werden konnte, wird der vorhandene Timer abgebrochen.


Beispiel zur OnTime-Methode

In diesem Beispiel wird das Makro "MyMacro" im aktuellen Modul um 15:55 Uhr ausgeführt.

Application.OnTime When:="15:55:00", Name:="MyMacro"

In diesem Beispiel wird das Makro "Macro1" 15 Sekunden nach dem Ausführen des Beispiels ausgeführt. Der Makroname enthält den Namen des Projekts und des Moduls.

Application.OnTime When:=Now + TimeValue("00:00:15"), _
    Name:="Project1.Module1.Macro1"

In diesem Beispiel wird das Makro "Start" um 13:30 Uhr ausgeführt. Der Makroname enthält den Namen des Projekts und des Moduls.

Application.OnTime When:=TimeValue("1:30 pm"), _
    Name:="VBAProj.MyModule.Start"


Open-Methode

Syntax 1: Öffnet das angegebene Dokument und fügt es der Documents-Auflistung hinzu. Gibt ein Document-Objekt zurück.

Syntax 2: Öffnet das angegebene Objekt. Wenn die Methode auf ein Subdocument- oder RecentFile-Objekt angewandt wird, gibt Syntax 2 ein Document-Objekt zurück.

Syntax 1

Ausdruck.Open(FileName, ConfirmConversions, ReadOnly, AddToRecentFiles, PasswordDocument, PasswordTemplate, Revert, WritePasswordDocument, WritePasswordTemplate, Format, Encoding, Visible)

Syntax 2

Ausdruck.Open

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Documents-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein OLEFormat-, RecentFile-, Subdocument- oder Version-Objekt zurückgibt.

FileName Variant erforderlich. Der Name des Dokuments (Pfade sind zulässig).

ConfirmConversions Variant optional. True, wenn die Datei nicht im Microsoft Word-Format vorliegt und das Dialogfeld Datei konvertieren angezeigt werden soll.

ReadOnly Variant optional. True, wenn das Dokument schreibgeschützt geöffnet werden soll.

AddToRecentFiles Variant optional. True, wenn unten im Menü Datei ein Dateiname der Liste der zuletzt verwendeten Dateien hinzugefügt werden soll.

PasswordDocument Variant optional. Das Kennwort zum Öffnen des Dokuments.

PasswordTemplate Variant optional. Das Kennwort zum Öffnen der Vorlage.

Revert Variant optional. Steuert das Verhalten, wenn Name der Dateiname eines geöffneten Dokuments ist. True, wenn nicht gespeicherte Änderungen im geöffneten Dokument verworfen werden und die Datei neu geöffnet werden soll. False, wenn das geöffnete Dokument aktiviert werden soll.

WritePasswordDocument Variant optional. Das Kennwort zum Speichern von Änderungen im Dokument.

WritePasswordTemplate Variant optional. Das Kennwort zum Speichern von Änderungen in der Vorlage.

Format Variant optional. Das Dateikonvertierungsprogramm, das zum Öffnen des Dokuments verwendet werden soll. Dies kann eine der folgenden WdOpenFormat-Konstanten sein: wdOpenFormatAllWord, wdOpenFormatAuto, wdOpenFormatDocument, wdOpenFormatEncodedText, wdOpenFormatRTF, wdOpenFormatTemplate, wdOpenFormatText, wdOpenFormatUnicodeText oder wdOpenFormatWebPages. Der Standardwert ist wdOpenFormatAuto.

Wenn Sie ein externes Dateiformat angeben wollen, weisen Sie die OpenFormat-Eigenschaft einem FileConverter-Objekt zu, damit der Wert ermittelt wird, der mit diesem Argument verwendet werden soll.

Encoding Variant optional. Die bei der Anzeige des gespeicherten Dokuments von Microsoft Word zu verwendende Dokumentcodierung (Codepage oder Zeichensatz). Eine beliebige gültige MsoEncoding-Konstante ist möglich. Eine Liste gültiger MsoEncoding-Konstanten finden Sie im Objektkatalog von Visual Basic-Editor. Der Standardwert ist die Codepage des Systems. Long Schreib-Lese-Zugriff.

Visible Variant optional. True, wenn das Dokument in einem sichtbaren Fenster geöffnet wird. Die Standardeinstellung ist True.


OpenAsDocument-Methode

Öffnet die angegebene Dokumentvorlage als Dokument und gibt ein Document-Objekt zurück.

Anmerkung Wenn eine Dokumentvorlage als Dokument geöffnet wird, dann kann der Benutzer den Inhalt der Dokumentvorlage bearbeiten. Eventuell ist dies nötig, wenn eine Eigenschaft oder Methode (z. B. die Styles-Eigenschaft) nicht vom Template-Objekt zur Verfügung steht.

Syntax

Ausdruck.OpenAsDocument()

Ausdruck Erforderlich. Ein Ausdruck, der ein Template-Objekt zurückgibt.


Beispiel zur OpenAsDocument-Methode

In diesem Beispiel wird die Dokumentvorlage geöffnet, die dem aktiven Dokument zugeordnet ist. Ein Meldungsfeld wird angezeigt, wenn die Dokumentvorlage mehr als eine Absatzmarke enthält, dann wird die Dokumentvorlage geschlossen.

Set aDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
If aDoc.Content.Text <> Chr(13) Then
    MsgBox "Template is not empty"
Else
    MsgBox "Template is empty"
End If
aDoc.Close SaveChanges:=wdDoNotSaveChanges

In diesem Beispiel wird eine Kopie der Dokumentvorlage Normal als "Backup.dot" gespeichert.

Set aDoc = NormalTemplate.OpenAsDocument
With aDoc
    .SaveAs FileName:="Backup.dot"
    .Close SaveChanges:=wdDoNotSaveChanges
End With

In diesem Beispiel wird die Formatierung der Formatvorlage "Heading 1" in der Dokumentvorlage geändert, die dem aktiven Dokument zugeordnet ist. Die UpdateStyles-Methode aktualisiert die Formatvorlagen im aktiven Dokument.

Set aDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
With aDoc.Styles(wdStyleHeading1).Font
    .Name = "Arial"
    .Size = 16
    .Bold = False
End With
aDoc.Close SaveChanges:=wdSaveChanges
ActiveDocument.UpdateStyles


OpenDataSource-Methode

Bindet eine Datenquelle an das angegebene Dokument, das dadurch zum Hauptdokument wird, falls es bisher noch kein Hauptdokument war.

Syntax

Ausdruck.OpenDataSource(Name, Format, ConfirmConversions, ReadOnly, LinkToSource, AddToRecentFiles, PasswordDocument, PasswordTemplate, Revert, WritePasswordDocument, WritePasswordTemplate, Connection, SQLStatement, SQLStatement1)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Name String erforderlich. Der Dateiname der Datenquelle. Sie können eine Microsoft Query-Datei (.qry) angeben, anstatt eine Datenquelle, eine Verbindungs- oder eine Abfragezeichenfolge festzulegen.

Format Variant optional. Der Dateikonverter, um das Dokument zu öffnen. Dabei kann es sich um eine der folgenden WdOpenFormat-Konstanten handeln: wdOpenFormatAllWord, wdOpenFormatAuto, wdOpenFormatDocument, wdOpenFormatEncodedText, wdOpenFormatRTF, wdOpenFormatTemplate, wdOpenFormatText, wdOpenFormatUnicodeText oder wdOpenFormatWebPages. Der Standardwert lautet wdOpenFormatAuto.

Bei der Festlegung eines externen Dateiformats verwenden Sie die OpenFormat-Eigenschaft mit einem FileConverter-Objekt, um den Wert für dieses Argument zu ermitteln.

ConfirmConversions Variant optional. True, um das Dialogfeld Datei konvertieren anzuzeigen, wenn die Datei nicht das Word-Format hat.

ReadOnly Variant optional. True, um die Datenquelle schreibgeschützt zu öffnen.

LinkToSource Variant optional. True, um die Abfrage bei jedem Öffnen des Hauptdokuments durchzuführen, die durch Connection und SQLStatement festgelegt wird.

AddToRecentFiles Variant optional. True, um den Dateinamen in die Liste der zuletzt geöffneten Dateien unten im Menü Datei aufzunehmen.

PasswordDocument Variant optional. Das Kennwort, mit dem die Datenquelle geöffnet wird.

PasswordTemplate Variant optional. Das Kennwort, mit dem die Vorlage geöffnet wird.

Revert Variant optional. Bestimmt, was passiert, wenn Name der Dateiname eines geöffneten Dokuments ist. Bei True werden alle nicht gesicherten Änderungen am geöffneten Dokument verworfen und die Datei wird erneut geöffnet; False, um das geöffnete Dokument zu aktivieren.

WritePasswordDocument Variant optional. Das Kennwort, mit dem Änderungen am Dokument gespeichert werden.

WritePasswordTemplate Variant optional. Das Kennwort, mit dem Änderungen an der Vorlage gespeichert werden.

Connection Variant optional. Ein Bereich, auf dem die Abfrage ausgeführt wird, die Sie mit SQLStatement bestimmen. Wie Sie den Bereich festlegen, hängt davon ab, wie Daten geladen werden. Zum Beispiel:

  • Bei Daten, die Sie mit ODBC laden, legen Sie eine Verbindungszeichenfolge fest.

  • Bei Daten, die Sie aus Microsoft Excel mit dynamischem Datenaustausch (DDE) laden, bestimmen Sie einen benannten Bereich.

  • Wenn Sie Daten aus Microsoft Access laden, verwenden Sie die Begriffe "Tabelle" oder "Abfrage" gefolgt von dem Namen der Tabelle oder Abfrage.

SQLStatement Variant optional. Definiert Abfrageoptionen zum Laden von Daten.

SQLStatement1 Variant optional. Bei Abfragezeichenfolgen von mehr als 255 Zeichen bestimmen Sie mit SQLStatement den ersten Teil der Zeichenfolge und mit SQLStatement1 den zweiten.

Hinweise

Um die ODBC-Verbindung und Abfragezeichenfolgen zu ermitteln, setzen Sie die Abfrageoptionen manuell, und geben Sie die Verbindungszeichenfolge mit der QueryString-Eigenschaft zurück. In der folgenden Tabelle finden Sie einige häufig genutzte SQL-Schlüsselwörter.

Schlüsselwort | Beschreibung
DSN | Der Name der ODBC-Datenquelle
UID | Die Benutzer-Login-ID
PWD | Das benutzerdefinierte Kennwort
DBQ | Der Dateiname der Datenbank
FIL | Der Dateityp


Beispiel zur OpenDataSource-Methode

In diesem Beispiel wird ein neues Hauptdokument erzeugt und die Tabelle "Customers" der Microsoft Access-Datenbank Nordwind.mdb zugeordnet.

Set myDoc = Documents.Add
With myDoc.MailMerge
    .MainDocumentType = wdFormLetters
    .OpenDataSource _
        Name:="C:\MSOffice\Access\Samples\Northwind.mdb", _
        LinkToSource:=True, AddToRecentFiles:=False, _
        Connection:="TABLE Orders
End With

In diesem Beispiel wird ein neues Hauptdokument erzeugt und die Microsoft Excel-Tabelle Names.xls zugeordnet. Mit dem Connection-Argument werden Daten aus dem Bereich "Verkäufe" geladen.

Set myDoc = Documents.Add
With myDoc.MailMerge
    .MainDocumentType = wdCatalog
    .OpenDataSource Name:="C:\My Documents\Names.xls", _
        ReadOnly:=True, _
        Connection:="Sales"
End With

In diesem Beispiel wird mit ODBC die Microsoft Access-Datenbank "NorthWind.mdb" dem aktiven Dokument zugeordnet. Mit dem SQLStatement-Argument werden die Datensätze in der Tabelle "Customers" gewählt.

With ActiveDocument.MailMerge
    .MainDocumentType = wdFormLetters
    constr = "DSN=MS Access Databases;" _
        & "DBQ=C:\Access\NorthWind.mdb;" _
        & "FIL=RedISAM;"
   .OpenDataSource Name:="C:\MSOffice\Access\NorthWind.mdb", _
        Connection:=constr, SQLStatement:="SELECT * FROM Customers"
End With


OpenHeaderSource-Methode

Ordnet dem angegebenen Dokument eine Seriendruck-Datensatzquelle zu.

Anmerkung Bei einer zugeordneten Datensatzquelle wird nicht der Steuerdatensatz in der Datenquelle, sondern der erste Datensatz der Datensatzquelle benutzt.

Syntax

Ausdruck.OpenHeaderSource(Name, Format, ConfirmConversions, ReadOnly, AddToRecentFiles, PasswordDocument, PasswordTemplate, Revert, WritePasswordDocument, WritePasswordTemplate)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Name String erforderlich. Der Pfad- und Dateiname der neuen Steuersatzquelle.

Format Variant optional. Der Dateikonverter, um das Dokument zu öffnen. Dabei kann es sich um eine der folgenden WdOpenFormat-Konstanten handeln: wdOpenFormatAllWord, wdOpenFormatAuto, wdOpenFormatDocument, wdOpenFormatEncodedText, wdOpenFormatRTF, wdOpenFormatTemplate, wdOpenFormatText, wdOpenFormatUnicodeText oder wdOpenFormatWebPages. Der Standardwert lautet wdOpenFormatAuto.

Bei der Festlegung eines externen Dateiformats verwenden Sie die OpenFormat-Eigenschaft mit einem FileConverter-Objekt, um den Wert für dieses Argument zu ermitteln.

ConfirmConversions Variant optional. True, um das Dialogfeld Datei konvertieren anzuzeigen, wenn die Datei nicht das Word-Format hat.

ReadOnly Variant optional. True, um die Steuersatzquelle schreibgeschützt zu öffnen.

AddToRecentFiles Variant optional. True, um den Dateinamen in die Liste der zuletzt geöffneten Dateien unten im Menü Datei aufzunehmen.

PasswordDocument Variant optional. Das Kennwort, mit dem die Datei der Steuersatzquelle geöffnet wird.

PasswordTemplate Variant optional. Das notwendige Kennwort, um die Vorlage der Steuersatzquelle zu öffnen.

Revert Variant optional. Bestimmt, was passiert, wenn Name der Dateiname eines geöffneten Dokuments ist. Bei True werden alle nicht gesicherten Änderungen am geöffneten Dokument verworfen und die Datei wird erneut geöffnet; False, um das geöffnete Dokument zu aktivieren.

WritePasswordDocument Variant optional. Das nötige Kennwort, um Änderungen an der Datei der Steuersatzquelle zu speichern.

WritePasswordTemplate Variant optional. Das nötige Kennwort, um Änderungen an der Vorlage der Steuersatzquelle zu speichern.


Beispiel zur OpenHeaderSource-Methode

In diesem Beispiel wird das aktive Dokument als Hauptdokument für Formbriefe bestimmt und die Steuersatzquelle "Header.doc" dem aktiven Dokument und dem Datendokument "Names.doc" zugewiesen.

With ActiveDocument.MailMerge
    .MainDocumentType = wdFormLetters
    .OpenHeaderSource Name:="C:\My Documents\Header.doc", _
         Revert:=False, AddToRecentFiles:=False
    .OpenDataSource Name:="C:\My Documents\Names.doc"
End With


OpenOrCloseUp-Methode

Wenn der Abstand vor den angegebenen Absätzen 0 (Null) ist, legt diese Methode ihn auf 12 Punkt fest. Ist der Abstand vor den Absätzen größer als 0 (Null), legt diese Methode ihn auf 0 (Null) fest.

Syntax

Ausdruck.OpenOrCloseUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.


Beispiel zur OpenOrCloseUp-Methode

In diesem Beispiel wird die Formatierung des ersten Absatzes im aktiven Dokument umgeschaltet, so dass entweder 12 Punkt Leerraum vor dem Absatz eingefügt werden oder kein Leerraum vor dem Absatz bleibt.

ActiveDocument.Paragraphs(1).OpenOrCloseUp


OpenUp-Methode

Legt den Leerraum vor den angegebenen Absätzen auf 12 Punkt fest.

Syntax

Ausdruck.OpenUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

ActiveDocument.Paragraphs(1).OpenUp
ActiveDocument.Paragraphs(1).SpaceBefore = 12


Beispiel zur OpenUp-Methode

In diesem Beispiel wird im aktiven Dokument die Formatierung des zweiten Absatzes geändert, so dass vor dem Absatz ein Leerraum von 12 Punkt bleibt.

ActiveDocument.Paragraphs(2).OpenUp


OrganizerCopy-Methode

Kopiert die angegebenen Elemente AutoText-Eintrag, Symbolleiste, Formatvorlage oder Makroprojekt-Elemente aus dem Quelldokument oder der Quellvorlage in das Zieldokument bzw. in die Zielvorlage.

Syntax

Ausdruck.OrganizerCopy(Source, Destination, Name, Object)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Source String erforderlich. Der Name der Dokument- oder Vorlagendatei, die das zu kopierende Element enthält.

Destination String erforderlich. Der Name der Dokument- oder Vorlagendatei, in die ein Element kopiert werden soll.

Name String erforderlich. Der Name des zu kopierenden Elements (AutoText-Eintrag, Symbolleiste, Formatvorlage oder Makro).

Object Long erforderlich. Die Art des zu kopierenden Elements. Dies kann eine der folgenden WdOrganizerObject-Konstanten sein: wdOrganizerObjectAutoText, wdOrganizerObjectCommandBars, wdOrganizerObjectProjectItems oder wdOrganizerObjectStyles.


Beispiel zur OrganizerCopy-Methode

In diesem Beispiel werden alle AutoText-Einträge der mit dem aktiven Dokument verbundenen Vorlage in die Vorlage "Normal" kopiert.

For Each aEntry In ActiveDocument.AttachedTemplate.AutoTextEntries
    Application.OrganizerCopy _
        Source:=ActiveDocument.AttachedTemplate.FullName, _
        Destination:=NormalTemplate.FullName, Name:=aEntry.Name, _
        Object:=wdOrganizerObjectAutoText
Next aEntry

Im folgenden Beispiel wird die Formatvorlage nach C:\Templates\MyTemplate.dot kopiert, falls die Formatvorlage "SubText" im aktiven Dokument vorhanden ist.

For Each sty In ActiveDocument.Styles
    If sty = "SubText" Then
        Application.OrganizerCopy Source:=ActiveDocument.Name, _
            Destination:="C:\Templates\MyTemplate.dot", _
            Name:="SubText", _
            Object:=wdOrganizerObjectStyles
    End If
Next sty


OrganizerDelete-Methode

Löscht die angegebenen Elemente Formatvorlage, AutoText-Eintrag, Symbolleiste oder Makroprojekt-Element, aus einem Dokument oder einer Vorlage.

Syntax

Ausdruck.OrganizerDelete(Source, Name, Object)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Source String erforderlich. Der Dateiname des Dokuments oder der Vorlage, das/die das zu löschende Element enthält.

Name String erforderlich. Der Name des zu löschenden Elements (Formatvorlage, AutoText-Eintrag, Symbolleiste oder Makro).

Object Long erforderlich. Die Art des zu kopierenden Elements. Dies kann eine der folgenden WdOrganizerObject-Konstanten sein: wdOrganizerObjectAutoText, wdOrganizerObjectCommandBars, wdOrganizerObjectProjectItems oder wdOrganizerObjectStyles.


Beispiel zur OrganizerDelete-Methode

In diesem Beispiel wird die Symbolleiste "Custom1" aus der Vorlage "Normal" gelöscht.

For Each cb In CommandBars
    If cb.Name = "Custom 1" Then
        Application.OrganizerDelete Source:=NormalTemplate.Name, _
            Name:="Custom 1", Object:=wdOrganizerObjectCommandBars
    End If
Next cb

In diesem Beispiel wird der Benutzer aufgefordert, alle AutoText-Einträge in der mit dem aktiven Dokument verbundenen Vorlage zu löschen. Klickt der Benutzer auf die Schaltfläche "Yes", werden die AutoText-Einträge gelöscht.

For Each entry In ActiveDocument.AttachedTemplate.AutoTextEntries
    response = MsgBox("Do you want to delete the " & entry.Name _
        & " AutoText entry?", vbYesNoCancel)
    If response = vbYes Then
        With ActiveDocument.AttachedTemplate
            Application.OrganizerDelete _
                Source:= .Path & "\" & .Name, _
                Name:=entry.Name, _
                Object:=wdOrganizerObjectAutoText
        End With
    ElseIf response = vbCancel Then
        Exit For
    End If
Next entry


OrganizerRename-Methode

Benennt die angegebenen Elemente Formatvorlage, AutoText-Eintrag, Symbolleiste oder Makroprojekt-Element in einem Dokument oder einer Vorlage um.

Syntax

Ausdruck.OrganizerRename(Source, Name, NewName, Object)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Source String erforderlich. Der Dateiname des Dokuments oder der Vorlage, das/die das umzubenennende Element enthält.

Name String erforderlich. Der Name des umzubenennenden Elements (Formatvorlage, AutoText-Eintrag, Symbolleiste oder Makro).

NewName String erforderlich. Der neue Name für das Element.

Object Long erforderlich. Die Art des zu kopierenden Elements. Dies kann eine der folgenden WdOrganizerObject-Konstanten sein: wdOrganizerObjectAutoText, wdOrganizerObjectCommandBars, wdOrganizerObjectProjectItems oder wdOrganizerObjectStyles.


Beispiel zur OrganizerRename-Methode

In diesem Beispiel wird der Name der Formatvorlage "SubText" im aktiven Dokument in "SubText2" geändert.

For Each sty In ActiveDocument.Styles
    If sty.NameLocal = "SubText" Then
        Application.OrganizerRename _
            Source:=ActiveDocument.Name, Name:="SubText", _
            NewName:="SubText2", Object:=wdOrganizerObjectStyles
    End If
Next sty

In diesem Beispiel wird der Name des Makromoduls "Module1" in der verbundenen Vorlage in "MyMacros" geändert.

dot = ActiveDocument.AttachedTemplate.Name
Application.OrganizerRename Source:=dot, Name:="Module1", _
    NewName:="MyMacros", Object:=wdOrganizerObjectProjectItems


Outdent-Methode

Entfernt eine Einzugsebene für einen oder mehrere Absätze.

Hinweis Diese Methode entspricht dem Klicken auf die Schaltfläche Einzug verkleinern auf der Format-Symbolleiste.

Syntax

Ausdruck.Outdent

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph- oder Paragraphs-Objekt zurückgibt.


Beispiel zur Outdent-Methode

In diesem Beispiel werden alle Absätze im aktiven Dokument zweimal eingerückt und dann bei dem ersten Absatz eine Einzugsebene entfernt.

With ActiveDocument.Paragraphs
    .Indent
    .Indent
End With
ActiveDocument.Paragraphs(1).Outdent


OutlineDemote-Methode

Weist dem angegebenen Absatz oder den angegebenen Absätzen die Überschrift-Formatvorlage der nächstniederen Ebene (Überschrift 1 bis Überschrift 8) zu. Wenn beispielsweise ein Absatz mit der Formatvorlage Überschrift 2 formatiert ist, stuft diese Methode den Absatz tiefer, indem die Formatvorlage in Überschrift 3 geändert wird.

Syntax

Ausdruck.OutlineDemote

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph- oder Paragraphs-Objekt zurückgibt.


OutlineDemoteToBody-Methode

Wandelt den angegebenen Absatz oder die angegebenen Absätze in Textkörper um, indem die Formatvorlage Normal zugewiesen wird.

Syntax

Ausdruck.OutlineDemoteToBody

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph- oder Paragraphs-Objekt zurückgibt.


Beispiel zur OutlineDemoteToBody-Methode

In diesem Beispiel werden die markierten Absätze in Textkörper umgewandelt, indem die Formatvorlage Normal zugewiesen wird.

Selection.Paragraphs.OutlineDemoteToBody

In diesem Beispiel wird das aktive Fenster in Gliederungsansicht umgeschaltet und der erste Absatz in der Markierung in Textkörper umgewandelt.

ActiveDocument.ActiveWindow.View.Type = wdOutlineView
Selection.Paragraphs(1).OutlineDemoteToBody


OutlinePromote-Methode

Weist dem angegebenen Absatz oder den angegebenen Absätzen die Überschrift-Formatvorlage der nächsthöheren Ebene (Überschrift 1 bis Überschrift 8) zu. Wenn beispielsweise ein Absatz mit der Formatvorlage Überschrift 2 formatiert ist, stuft diese Methode den Absatz höher, indem die Formatvorlage in Überschrift 1 geändert wird.

Syntax

Ausdruck.OutlinePromote

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph- oder Paragraphs-Objekt zurückgibt.


Beispiel zur OutlinePromote-Methode

In diesem Beispiel werden die markierten Absätze höhergestuft.

Selection.Paragraphs.OutlinePromote

In diesem Beispiel wird das aktive Fenster in Gliederungsansicht umgeschaltet und der erste Absatz im aktiven Dokument höhergestuft.

ActiveDocument.ActiveWindow.View.Type = wdOutlineView
ActiveDocument.Paragraphs(1).OutlinePromote


PageScroll-Methode

Führt bei dem angegebenen Ausschnitt oder Fenster einen seitenweisen Bildlauf durch.

Syntax

Ausdruck.PageScroll(Down, Up)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window- oder Pane-Objekt zurückgibt.

Down Variant optional. Die Anzahl der Seiten, mit denen ein Bildlauf nach unten durchgeführt werden soll. Wenn Sie dieses Argument nicht angeben, wird von dem Wert 1 ausgegangen.

Up Variant optional. Die Anzahl der Seiten, mit denen ein Bildlauf nach oben durchgeführt werden soll.

Hinweise

Die PageScroll-Methode ist nur verfügbar, wenn Sie sich in der Drucklayoutansicht oder in der Weblayoutansicht befinden. Diese Methode hat keinen Einfluss auf die Position der Einfügemarke.

Wenn Down und Up beide angegeben sind, wird der Bildlauf um die Differenz der beiden Argumente durchgeführt. Wenn z. B. Down 2 ist und Up 4 ist, wird ein Bildlauf um zwei Seiten nach oben durchgeführt.


Beispiel zur PageScroll-Methode

Dieses Beispiel führt im aktiven Fenster einen Bildlauf um drei Seiten nach unten durch.

ActiveDocument.ActiveWindow.View.Type = wdPrintView
ActiveDocument.ActiveWindow.PageScroll Down:=3

Dieses Beispiel führt im aktiven Ausschnitt einen Bildlauf um eine Seite nach oben durch.

ActiveDocument.ActiveWindow.View.Type = wdPrintView
ActiveDocument.ActiveWindow.ActivePane.PageScroll Up:=1

Dieses Beispiel führt im aktiven Ausschnitt einen Bildlauf um eine Seite nach unten durch.

ActiveDocument.ActiveWindow.View.Type = wdPrintView
ActiveDocument.ActiveWindow.PageScroll


Paste-Methode

Fügt den Inhalt der Zwischenablage am angegebenen Bereich oder an der angegebenen Markierung ein. Wenn Sie den Inhalt des Bereichs oder der Markierung nicht ersetzen wollen, verwenden Sie die Collapse-Methode, bevor Sie diese Methode verwenden.

Syntax

Ausdruck.Paste

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Anmerkungen

Wenn diese Methode mit einem Range-Objekt verwendet wird, wird der Bereich erweitert, damit der Inhalt der Zwischenablage einbezogen wird. Wenn diese Methode mit einem Selection-Objekt verwendet wird, wird die Markierung nicht erweitert, um den Inhalt der Zwischenablage einzubeziehen, sondern die Markierung wird nach dem eingefügten Inhalt der Zwischenablage positioniert.


PasteAsNestedTable-Methode

Fügt eine oder mehrere Zellen als verschachtelte Tabelle in den markierten Bereich ein.

Syntax

Ausdruck.PasteAsNestedTable

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Hinweise

Sie können PasteAsNestedTable nur dann verwenden, wenn die Zwischenablage eine oder mehrere Zellen enthält und der markierte Bereich eine oder mehreren Zellen im aktuellen Dokument umfasst.


Beispiel zur PasteAsNestedTable-Methode

In diesem Beispiel wird der Inhalt der Zwischenablage in die dritte Zelle der ersten Tabelle im aktiven Dokument eingefügt.

ActiveDocument.Tables(1).Rows(1).Cells(3).Range _
    .PasteAsNestedTable


PasteFormat-Methode

Weist die Formatierung der Auswahl zu, die mit der CopyFormat-Methode kopiert wurde. Wenn beim Aufruf der CopyFormat-Methode eine Absatzmarke gewählt wurde, weist Word zusätzlich zur Zeichenformatierung auch die Absatzformatierung zu.

Syntax

Ausdruck.PasteFormat

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur PasteFormat-Methode

In diesem Beispiel wird die Absatz- und Zeichenformatierung vom ersten Absatz der Auswahl auf den nächsten Absatz der Auswahl kopiert.

With Selection
    .Paragraphs(1).Range.Select
    .CopyFormat
    .Paragraphs(1).Next.Range.Select
    .PasteFormat
End With

In diesem Beispiel wird die Auswahl reduziert und die Zeichenformatierung auf das nächste Wort kopiert.

With Selection
    .Collapse Direction:=wdCollapseStart
    .CopyFormat
    .Next(Unit:=wdWord, Count:=1).Select
    .PasteFormat
End With


PasteSpecial-Methode

Fügt den Inhalt der Zwischenablage ein. Im Gegensatz zur Paste-Methode können Sie bei PasteSpecial das Format der eingefügten Daten steuern und (optional) eine Verknüpfung zur Quelldatei (z. B. einer Microsoft Excel-Tabelle) herstellen.

Anmerkung Wenn Sie den Inhalt des angegebenen Bereichs oder der Markierung nicht ersetzen wollen, verwenden Sie die Collapse-Methode, bevor Sie diese Methode anwenden. Wenn Sie diese Methode anwenden, wird der Bereich oder die Markierung nicht erweitert, um den Inhalt der Zwischenablage einzuschließen.

Syntax

Ausdruck.PasteSpecial(IconIndex, Link, Placement, DisplayAsIcon, DataType, IconFileName, IconLabel)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

IconIndex Variant optional. Wenn DisplayAsIcon True ist, ist dieses Argument eine Zahl, die dem Symbol entspricht, das Sie in der Programmdatei verwenden wollen, die durch IconFilename spezifiziert wurde. Symbole erscheinen im Dialogfeld Symbol ändern (im Menü Einfügen, Befehl Objekt, Registerkarte Neu erstellen): 0 (Null) entspricht dem ersten Symbol, 1 entspricht dem zweiten Symbol usw. Wenn dieses Argument weggelassen wird, wird (standardmäßig) das erste Symbol verwendet.

Link Variant optional. True, wenn eine Verknüpfung zur Quelldatei des Inhalts der Zwischenablage hergestellt werden soll. Der Standardwert ist False.

Placement Variant optional. Dies kann eine der beiden folgenden WdOLEPlacement-Konstanten sein: wdFloatOverText oder wdInLine. Der Standardwert ist wdInLine.

DisplayAsIcon Variant optional. True, wenn die Verknüpfung als Symbol angezeigt werden soll. Der Standardwert ist False.

DataType Variant optional. Ein Format für den Inhalt der Zwischenablage, wenn dieser in das Dokument eingefügt wird. Dies kann eine der folgenden WdPasteDataType-Konstanten sein: wdPasteBitmap, wdPasteDeviceIndependentBitmap, wdPasteEnhancedMetafile, wdPasteHTML, wdPasteHyperlink, wdPasteMetafilePicture, wdPasteOLEObject, wdPasteRTF, wdPasteShape oder wdPasteText. Das Standardformat verändert sich in Abhängigkeit vom Inhalt der Zwischenablage.

IconFileName Variant optional. Wenn DisplayAsIcon True ist, ist dieses Argument der Pfad und Dateiname für die Datei, in der das Symbol gespeichert ist, das angezeigt werden soll.

IconLabel Variant optional. Wenn DisplayAsIcon True ist, ist dieses Argument der Text, der unter dem Symbol erscheint.


Beispiel zur PasteSpecial-Methode

In diesem Beispiel wird der Inhalt der Zwischenablage an der Einfügemarke als unformatierter Text eingefügt.

Selection.Collapse Direction:=wdCollapseStart
Selection.Range.PasteSpecial DataType:=wdPasteText

In diesem Beispiel wird der markierte Text kopiert und als Hyperlink in ein neues Dokument eingefügt.

If Selection.Type = wdSelectionNormal Then
    Selection.Copy
    Documents.Add.Content.PasteSpecial Link:=True, _
        DataType:=wdPasteHyperlink
End If


Patterned-Methode

Legt die angegebene Füllung auf ein Muster fest.

Syntax

Ausdruck.Patterned(Pattern)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Pattern Long erforderlich. Das Muster, das für die angegebene Füllung verwendet werden soll. Dies kann eine der MsoPatternType-Konstanten sein.

Anmerkungen

Verwenden Sie die BackColor- und die ForeColor-Eigenschaft zum Festlegen der Farben, die in dem Muster verwendet werden.


Beispiel zur Patterned-Methode

In diesem Beispiel wird ein Oval mit einem gemusterten Füllbereich zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeOval, 60, 60, 80, 40).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(0, 0, 255)
    .Patterned msoPatternDarkVertical
End With


PhoneticGuide-Methode

Sprachspezifische Informationen

Adds phonetic guides to the specified range.

Syntax

expression.PhoneticGuide(Text, Alignment, Raise, FontSize, FontName)

expression Required. An expression that returns a Range object.

Text Required String. The phonetic text to add.

Alignment Optional Long. The alignment of the added phonetic text. Can be one of the following WdPhoneticGuideAlignmentType constants.

Constant | Description
wdPhoneticGuideAlignmentCenter | Microsoft Word centers phonetic text over the specified range. This is the default value.
wdPhoneticGuideAlignmentLeft | Word left-aligns phonetic text with the specified range.
wdPhoneticGuideAlignmentRight | Word right-aligns phonetic text with the specified range.
wdPhoneticGuideAlignmentOneTwoOne | Word adjusts the inside and outside spacing of the phonetic text in a 1:2:1 ratio.
wdPhoneticGuideAlignmentZeroOneZero | Word adjusts the inside and outside spacing of the phonetic text in a 0:1:0 ratio.

Raise Optional Long. The distance (in points) from the top of the text in the specified range to the top of the phonetic text. If no value is specified, Word automatically sets the phonetic text at an optimum distance above the specified range.

FontSize Optional Long. The font size to use for the phonetic text. If no value is specified, Word uses a font size 50% smaller than the text in the specified range.

FontName Optional String. The name of the font to use for the phonetic text. If no value is specified, Word uses the same font as the text in the specified range.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur PhoneticGuide-Methode

Sprachspezifische Informationen

This example adds a phonetic guide to the selected phrase "tres chic."

Selection.Range.PhoneticGuide Text:="tray sheek", _
    Alignment:= wdPhoneticGuideAlignmentCenter, _
    Raise:=11, FontSize:=7


PicasToPoints-Methode

Ändert eine Maßeinheit von Pica in Punkt (1 Pica = 12 Punkt). Die geänderte Maßeinheit wird als Single zurückgegeben.

Syntax

Ausdruck.PicasToPoints(Picas)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Picas Single erforderlich. Der Pica-Wert, der in Punkt geändert werden soll.


Beispiel zur PicasToPoints-Methode

In diesem Beispiel werden Zeilennummern in das aktive Dokument eingefügt, und als Abstand zwischen den Zeilennummern und dem Dokumenttext werden 4 Pica festgelegt.

With ActiveDocument.PageSetup.LineNumbering
    .Active = True
    .DistanceFromText = PicasToPoints(4)
End With

In diesem Beispiel werden als Erstzeileneinzug der ausgewählten Absätze 3 Pica festgelegt.

Selection.ParagraphFormat.FirstLineIndent = PicasToPoints(3)


PickUp-Methode

Kopiert die Formatierung der angegebenen Form. Verwenden Sie die Apply-Methode, wenn die kopierte Formatierung einer anderen Form zugewiesen werden soll.

Syntax

Ausdruck.PickUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.


Beispiel zur PickUp-Methode

In diesem Beispiel wird in myDocument die Formatierung von Form eins kopiert und dann die kopierte Formatierung der Form zwei zugewiesen.

Set myDocument = ActiveDocument
With myDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


PixelsToPoints-Methode

Rechnet eine Maßangabe von Pixel in Punkt um. Gibt die geänderte Maßangabe als Single zurück.

Syntax

Ausdruck.PixelsToPoints(Pixels, fVertical)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Pixels Single erforderlich. Der Wert in Pixel, der in Punkt umgerechnet werden soll.

fVertical Variant optional. True, wenn vertikale Pixel umgerechnet werden sollen, False, wenn horizontale Pixel umgerechnet werden sollen.


Beispiel zur PixelsToPoints-Methode

In diesem Beispiel wird die Höhe und Breite eines in Pixel gemessenen Objekts in Punkt angezeigt.

MsgBox "320x240 pixels is equivalent to " _
    & PixelsToPoints(320, False) & "x" _
    & PixelsToPoints(240, True) _
    & " points on this display."


PointsToCentimeters-Methode

Konvertiert ein Punkt-Maß in Zentimeter (1 Zentimeter = 28,35 Punkt). Gibt das konvertierte Maß als Single zurück.

Syntax

Ausdruck.PointsToCentimeters(Points)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Das Maß in Punkt.


Beispiel zur PointsToCentimeters-Methode

In diesem Beispiel wird ein Maß von 30 Punkt in die entsprechende Anzahl Zentimeter konvertiert.

MsgBox PointsToCentimeters(30) & " centimeters"

In diesem Beispiel wird der Wert der Variablen data (ein Maß in Punkt) in Zentimeter, Zoll, Linie, Millimeter oder Pica, abhängig vom Wert der Variablen unit (ein Wert von 1 bis 5, der die Maßeinheit bestimmt), konvertiert.

Select Case unit
    Case 1
        result = PointsToCentimeters(data)
    Case 2
        result = PointsToInches(data)
    Case 3
        result = PointsToLines(data)
    Case 4
        result = PointsToMillimeters(data)
    Case 5
        result = PointsToPicas(data)
    Case Else
        Error 5
End Select


PointsToInches-Methode

Konvertiert ein Punkt-Maß in Zoll (1 Zoll = 72 Punkt). Gibt das konvertierte Maß als Single zurück.

Syntax

Ausdruck.PointsToInches(Points)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Das Maß in Punkt.


Beispiel zur PointsToInches-Methode

In diesem Beispiel wird das Maß des oberen Rands im aktiven Dokument in Zoll konvertiert. Das Ergebnis wird in einem Meldungsfeld angezeigt.

MsgBox PointsToInches(ActiveDocument.Sections(1) _
    .PageSetup.TopMargin)

In diesem Beispiel wird der Wert der Variablen data (ein Maß in Punkt) in Zentimeter, Zoll, Linie, Millimeter oder Pica, abhängig vom Wert der Variablen unit (ein Wert von 1 bis 5, der die Maßeinheit bestimmt), konvertiert.

Select Case unit
    Case 1
        result = PointsToCentimeters(data)
    Case 2
        result = PointsToInches(data)
    Case 3
        result = PointsToLines(data)
    Case 4
        result = PointsToMillimeters(data)
    Case 5
        result = PointsToPicas(data)
    Case Else
        Error 5
End Select


PointsToLines-Methode

Konvertiert ein Punkt-Maß in Linie (1 Linie = 12 Punkt). Gibt das konvertierte Maß als Single zurück.

Syntax

Ausdruck.PointsToLines(Points)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Das Maß in Punkt.


Beispiel zur PointsToLines-Methode

In diesem Beispiel wird der Wert für den Zeilenabstand des ersten Abstands in der Auswahl von Punkt in Linie konvertiert.

MsgBox PointsToLines(Selection.Paragraphs(1).LineSpacing) _
    & " lines"

In diesem Beispiel wird der Wert der Variablen data (ein Maß in Punkt) in Zentimeter, Zoll, Linie, Millimeter oder Pica, abhängig vom Wert der Variablen unit (ein Wert von 1 bis 5, der die Maßeinheit bestimmt), konvertiert.

Select Case unit
    Case 1
        result = PointsToCentimeters(data)
    Case 2
        result = PointsToInches(data)
    Case 3
        result = PointsToLines(data)
    Case 4
        result = PointsToMillimeters(data)
    Case 5
        result = PointsToPicas(data)
    Case Else
        Error 5
End Select


PointsToMillimeters-Methode

Konvertiert ein Punkt-Maß in Millimeter (1 Millimeter = 2.835 Punkt). Gibt das konvertierte Maß als Single zurück.

Syntax

Ausdruck.PointsToMillimeters(Points)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Das Maß in Punkt.


Beispiel zur PointsToMillimeters-Methode

In diesem Beispiel wird 72 Punkt in die entsprechende Anzahl Millimeter konvertiert.

MsgBox PointsToMillimeters(72) & " millimeters"

In diesem Beispiel wird der Wert der Variablen data (ein Maß in Punkt) in Zentimeter, Zoll, Linie, Millimeter oder Pica, abhängig vom Wert der Variablen unit (ein Wert von 1 bis 5, der die Maßeinheit bestimmt), konvertiert.

Select Case unit
    Case 1
        result = PointsToCentimeters(data)
    Case 2
        result = PointsToInches(data)
    Case 3
        result = PointsToLines(data)
    Case 4
        result = PointsToMillimeters(data)
    Case 5
        result = PointsToPicas(data)
    Case Else
        Error 5
End Select


PointsToPicas-Methode

Konvertiert ein Punkt-Maß in Pica (1 Pica = 12 Punkt). Gibt das konvertierte Maß als Single zurück.

Syntax

Ausdruck.PointsToPicas(Points)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Das Maß in Punkt.


Beispiel zur PointsToPicas-Methode

In diesem Beispiel wird 36 Punkt in die entsprechende Anzahl Pica umgewandelt.

MsgBox PointsToPicas(36) & " picas"

In diesem Beispiel wird der Wert der Variablen data (ein Maß in Punkt) in Zentimeter, Zoll, Linie, Millimeter oder Pica, abhängig vom Wert der Variablen unit (ein Wert von 1 bis 5, der die Maßeinheit bestimmt), konvertiert.

Select Case unit
    Case 1
        result = PointsToCentimeters(data)
    Case 2
        result = PointsToInches(data)
    Case 3
        result = PointsToLines(data)
    Case 4
        result = PointsToMillimeters(data)
    Case 5
        result = PointsToPicas(data)
    Case Else
        Error 5
End Select


PointsToPixels-Methode

Rechnet eine Maßangabe von Punkt in Pixel um. Gibt die umgerechnete Maßangabe als Single zurück.

Syntax

Ausdruck.PointsToPixels(Points, fVertical)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Points Single erforderlich. Der Wert in Punkt, der in Pixel umgerechnet werden soll.

fVertical Variant optional. True wenn in vertikale Pixel umgerechnet werden soll, False, wenn in horizontale Pixel umgerechnet werden soll.


Beispiel zur PointsToPixels-Methode

In diesem Beispiel wird die Höhe und Breite eines in Punkt gemessenen Objekts in Pixel angezeigt.

MsgBox "180x120 points is equivalent to " _
    & PointsToPixels(180, False) & "x" _
    & PointsToPixels(120, True) _
    & " pixels on this display."


Post-Methode

Sendet das angegebene Dokument zu einem öffentlichen Ordner in Microsoft Exchange. Diese Methode zeigt das Dialogfeld In Exchange-Ordner ablegen an, so dass ein Ordner ausgewählt werden kann.

Syntax

Ausdruck.Post

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur Post-Methode

In diesem Beispiel wird das Dialogfeld In Exchange-Ordner ablegen angezeigt, so dass das aktive Dokument zu einem öffentlichen Ordner gesendet werden kann.

ActiveDocument.Post


PresentIt-Methode

Öffnet PowerPoint und lädt dabei das angegebene Word-Dokument.

Syntax

Ausdruck.PresentIt

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur PresentIt-Methode

In diesem Beispiel wird eine Kopie des Dokuments "MyPresentation.doc" an PowerPoint gesandt.

Documents("MyPresentation.doc").PresentIt


PresetDrop-Methode

Gibt an, ob die Legendenlinie oben, unten oder in der Mitte des Legendentextfelds ansetzt, oder ob sie an einem Punkt ansetzt, der einen angegebenen Abstand von der Oberkante oder Unterkante des Textfelds hat.

Syntax

Ausdruck.PresetDrop(DropType)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

DropType Long erforderlich. Die Anfangsposition der Legendenlinie relativ zum Rechteck, das den Textbereich begrenzt. Dies kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter, msoCalloutDropCustom oder msoCalloutDropTop. Wenn Sie msoCalloutDropCustom angeben, werden die Werte der Drop- und der AutoAttach-Eigenschaft sowie die relativen Positionen des Legendentextfelds und des Legendenlinienursprungs (der Stelle, auf die die Legende hinweist) zum Ermitteln verwendet, wo die Legendenlinie am Textfeld ansetzt.


Beispiel zur PresetDrop-Methode

In diesem Beispiel wird spezifiziert, dass in myDocument die Legendenlinie für Form eins an der Oberkante des Rechtecks ansetzt, das den Textbereich begrenzt. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
myDocument.Shapes(1).Callout.PresetDrop msoCalloutDropTop

In diesem Beispiel wird für Form eins in myDocument zwischen zwei voreingestellten Ansätzen umgeschaltet. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropTop Then
        .PresetDrop msoCalloutDropBottom
    ElseIf .DropType = msoCalloutDropBottom Then
        .PresetDrop msoCalloutDropTop
    End If
End With


PresetGradient-Methode

Legt die angegebene Füllung auf eine voreingestellte fließende Farbe fest.

Syntax

Ausdruck.PresetGradient(Style, Variant, PresetGradientType)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Der Stil der fließenden Farbe. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical. (Die Konstante msoGradientFromTitle wird nur in PowerPoint verwendet.)

Variant Long erforderlich. Die Variante der fließenden Farbe. Dies kann ein Wert von 1 bis 4 sein, entsprechend den vier Varianten auf der Registerkarte Graduell im Dialogfeld Fülleffekte. Wenn Style msoGradientFromCenter ist, kann dieses Argument 1 oder 2 sein.

PresetGradientType Long erforderlich. Die Art der fließenden Farbe. Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

 msoGradientLateSunset

msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat


Beispiel zur PresetGradient-Methode

In diesem Beispiel wird zu myDocument ein Rechteck mit einer voreingestellten fließenden Füllfarbe hinzugefügt.

Set myDocument = ActiveDocument
myDocument.Shapes.AddShape(msoShapeRectangle, 90, 90, 140, 80) _
    .Fill.PresetGradient msoGradientHorizontal, 1, msoGradientBrass


PresetTextured-Methode

Legt die angegebene Füllung auf eine voreingestellte Textur fest.

Syntax

Ausdruck.PresetTextured(PresetTexture)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PresetTexture Long erforderlich. Die voreingestellte Textur. Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat


Beispiel zur PresetTextured-Methode

In diesem Beispiel wird zu myDocument ein Rechteck mit einer Texturfüllung "Grüner Marmor" hinzugefügt.

Set myDocument = ActiveDocument
myDocument.Shapes.AddShape(msoShapeCan, 90, 90, 40, 80) _
    .Fill.PresetTextured msoTextureGreenMarble


Previous-Methode

Syntax 1: Wird die Methode dem Browser-Objekt zugewiesen, wird die Auswahl zum vorherigen Element verschoben, das vom Browser-Ziel angegeben wird. Mit der Target-Eigenschaft ändern Sie das Browser-Ziel.

Syntax 2: Gibt den vorherigen Absatz als ein Paragraph-Objekt zurück.

Syntax 3: Gibt ein Range-Objekt relativ zur angegebenen Auswahl oder zum Bereich zurück.

Hinweis Wenn sich der Bereich oder die Auswahl direkt nach der angegebenen Einheit befindet, wird der Bereich oder die Auswahl zur vorherigen Einheit verschoben. Wenn sich beispielsweise die Auswahl direkt nach einem Wort befindet (vor dem anschließenden Leerzeichen), wird die Auswahl im folgenden Befehl zum vorherigen Wort verschoben.

Selection.Previous(Unit:=wdWord, Count:=1).Select

Syntax 1

Ausdruck.Previous

Syntax 2

Ausdruck.Previous(Count)

Syntax 3

Ausdruck.Previous(Unit, Count)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Browser-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Paragraph-Objekt zurückgibt.

Syntax 3: Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Dabei kann es sich um eine der folgenden WdUnits-Konstanten handeln: wdCharacter, wdWord, wdSentence, wdParagraph, wdSection, wdStory, wdCell, wdColumn, wdRow oder wdTable. Wenn Ausdruck ein Selection-Objekt zurückgibt, können Sie auch wdLine verwenden. Der Standardwert lautet wdCharacter.

Count Variant optional. Die Anzahl der Absätze (Syntax 2) oder Einheiten (Syntax 3), um die zurück verschoben werden soll. Der Standardwert lautet 1.


PreviousField-Methode

Markiert das vorherige Feld. Wenn ein Feld gefunden wird, gibt diese Methode ein Field-Objekt zurückgibt; andernfalls gibt sie Nothing zurück.

Syntax

Ausdruck.PreviousField

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur PreviousField-Methode

In diesem Beispiel wird das vorherige Feld (das Feld unmittelbar vor der Markierung) aktualisiert.

If Not (Selection.PreviousField Is Nothing) Then
    Selection.Fields.Update
End If

In diesem Beispiel wird das vorherige Feld markiert, und wenn ein Feld gefunden wird, wird in der Statusleiste eine Meldung angezeigt.

Set myField = Selection.PreviousField
If Not (myField Is Nothing) Then StatusBar = "Field found"


PreviousHeaderFooter-Methode

Wenn die Markierung in einer Kopfzeile ist, springt diese Methode zur vorherigen Kopfzeile innerhalb des aktuellen Abschnitts (beispielsweise von einer geraden Kopfzeile zu einer ungeraden) oder zur letzten Kopfzeile im vorherigen Abschnitt. Wenn die Markierung in einer Fußzeile ist, springt diese Methode zur vorherigen Fußzeile.

Hinweis Wenn die Markierung in der ersten Kopfzeile oder Fußzeile im ersten Abschnitt des Dokuments ist, oder wenn sie sich überhaupt in keiner Kopfzeile oder Fußzeile befindet, tritt ein Fehler auf.

Syntax

Ausdruck.PreviousHeaderFooter

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.


Beispiel zur PreviousHeaderFooter-Methode

In diesem Beispiel wird ein gerader Abschnittswechsel eingefügt, das aktive Fenster in die Seitenlayoutansicht gesetzt, die aktuelle Kopfzeile angezeigt und anschließend zur vorherigen Kopfzeile gesprungen.

Selection.Collapse Direction:=wdCollapseStart
Selection.InsertBreak Type:=wdSectionBreakEvenPage
With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageHeader
    .PreviousHeaderFooter
End With


PreviousRevision-Methode

Sucht die vorherige Überarbeitung und gibt sie als Revision-Objekt zurück.

Syntax

Ausdruck.PreviousRevision(Wrap)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Wrap Variant optional. True, um mit der Suche nach einer Korrektur am Ende des Dokuments fortzufahren, wenn der Anfang des Dokuments erreicht wurde. Der Standardwert ist False.


Beispiel zur PreviousRevision-Methode

In diesem Beispiel wird die letzte Überarbeitung im ersten Abschnitt des aktiven Dokuments ausgewählt und das Datum und die Zeit der Überarbeitung angezeigt.

Selection.EndOf Unit:=wdStory, Extend:=wdMove
Set myRev = Selection.PreviousRevision
If Not (myRev Is Nothing) Then MsgBox myRev.Date

In diesem Beispiel wird die vorherige gefundene Überarbeitung abgelehnt, wenn die Art der Überarbeitung gelöschter oder eingefügter Text ist. Ist die Überarbeitung ein Wechsel der Formatvorlage, wird die Überarbeitung angenommen.

Set myRev = Selection.PreviousRevision(Wrap:=True)
If Not (myRev Is Nothing) Then
    Select Case myRev.Type
        Case wdRevisionDelete
            myRev.Reject
        Case wdRevisionInsert
            myRev.Reject
        Case wdRevisionStyle
            myRev.Accept
    End Select
End If


PreviousSubdocument-Methode

Markiert das vorherige Filialdokument. Wenn kein weiteres Filialdokument vorhanden ist, tritt ein Fehler auf.

Syntax

Ausdruck.PreviousSubdocument

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.


Beispiel zur PreviousSubdocument-Methode

In diesem Beispiel wird das aktive Dokument in Zentraldokument-Ansicht umgeschaltet und das vorherige Filialdokument markiert.

If ActiveDocument.Subdocuments.Count >= 1 Then
    ActiveDocument.ActiveWindow.View.Type = wdMasterView
    Selection.EndKey Unit:=wdStory, Extend:=wdMove
    Selection.PreviousSubdocument
End If


PrintOut-Methode

Druckt ein Objekt, wie in der folgenden Tabelle gezeigt. Sie erhalten eine genauere Beschreibung der PrintOut-Methode für ein bestimmtes Objekt, indem Sie es in der Tabelle auswählen.

Objekt | Beschreibung
Application, Document, Window | Druckt das angegebene Dokument komplett oder teilweise
Envelope | Druckt einen Umschlag, ohne ihn zu dem aktiven Dokument hinzuzufügen
MailingLabel | Druckt ein Etikett oder eine Seite mit Etiketten mit der gleichen Adresse


PrintOut-Methode (Application-, Document- und Window-Objekte)

Druckt das angegebene Dokument ganz oder teilweise. Die Argumente dieser Methode entsprechen den Optionen im Dialogfeld Drucken (Menü Datei).

Syntax

Ausdruck.PrintOut(Background, Append, Range, OutputFileName, From, To, Item, Copies, Pages, PageType, PrintToFile, Collate, FileName, ActivePrinterMacGX, ManualDuplexPrint, PrintZoomColumn, PrintZoomRow, PrintZoomPaperWidth, PrintZoomPaperHeight)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-, Document- oder Window-Objekt zurückgibt.

Background Variant optional. True, um das Makro fortzusetzen, während Microsoft Word das Dokument druckt.

Append Variant optional. True, um das angegebene Dokument an den Dateinamen anzuhängen, der mit dem OutputFileName-Argument festgelegt wurde. False, um den Inhalt von OutputFileName zu überschreiben.

Range Variant optional. Der Druckbereich. Dabei kann es sich um eine der folgenden WdPrintOutRange-Konstanten handeln: wdPrintAllDocument, wdPrintCurrentPage, wdPrintFromTo, wdPrintRangeOfPages oder wdPrintSelection.

OutputFileName Variant optional. Wenn True als Wert für PrintToFile festgelegt wurde, legt dieses Argument Pfad und Dateiname der Ausgabedatei fest.

From Variant optional. Die Nummer der Startseite, wenn wdPrintFromTo als Wert für Range festgelegt wurde.

To Variant optional. Die Nummer der Endseite, wenn wdPrintFromTo als Wert für Range festgelegt wurde.

Item Variant optional. Das zu druckende Element. Dabei kann es sich um eine der folgenden WdPrintOutItem-Konstanten handeln: wdPrintAutoTextEntries, wdPrintComments, wdPrintDocumentContent, wdPrintKeyAssignments, wdPrintProperties oder wdPrintStyles.

Copies Variant optional. Die Anzahl der zu druckenden Exemplare.

Pages Variant optional. Die zu druckenden Seitenzahlen und Druckbereiche, durch Kommas getrennt. Beispielsweise druckt "2, 6-10" die Seite 2 und die Seiten 6 bis 10.

PageType Variant optional. Der zu druckende Seitentyp. Dabei kann es sich um eine der folgenden WdPrintOutPages-Konstanten handeln: wdPrintAllPages, wdPrintEvenPagesOnly oder wdPrintOddPagesOnly.

PrintToFile Variant optional. True, um die Druckeranweisungen in eine Datei zu schreiben. Stellen Sie sicher, dass ein Dateiname mit OutputFileName festgelegt wird.

Collate Variant optional. Beim Drucken von mehreren Exemplaren eines Dokuments werden bei True alle Seiten des Dokuments gedruckt, bevor mit dem Drucken des nächsten Exemplars begonnen wird.

FileName Variant optional. Der Pfad und Dateiname des zu druckenden Dokuments. Wird dieses Argument ausgelassen, druckt Word das aktive Dokument. Steht nur mit dem Application-Objekt zur Verfügung.

ActivePrinterMacGX Variant optional. Dieses Argument ist nur in Microsoft Office 98 Macintosh Edition verfügbar. Zusätzliche Informationen über dieses Argument finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.

ManualDuplexPrint Variant optional. True, um ein doppelseitiges Dokument auf einem Drucker ohne Ausrüstung für doppelseitiges Drucken zu drucken. Ist dieses Argument auf True gesetzt, werden die PrintBackground- und PrintReverse-Eigenschaften ignoriert. Verwenden Sie die PrintOddPagesInAscendingOrder- und PrintEvenPagesInAscendingOrder-Eigenschaften, um den Ausdruck bei manuellen doppelseitigen Druckvorgängen zu steuern. Dieses Argument ist abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

PrintZoomColumn Variant optional. Die Anzahl der Seiten, die Word horizontal auf einer Seite unterbringen soll. Möglich sind 1, 2, 3 oder 4. Verwenden Sie für den Ausdruck mehrerer Seiten auf einem Blatt zusätzlich das PrintZoomRow-Argument.

PrintZoomRow Variant optional. Die Anzahl der Seiten, die Word vertikal auf einer Seite unterbringen soll. Möglich sind 1, 2 oder 4. Verwenden Sie für den Ausdruck mehrerer Seiten auf einem Blatt zusätzlich das PrintZoomColumn-Argument.

PrintZoomWidth Variant optional. Die Breite in Twip, auf die Word gedruckte Seiten skalieren soll (20 Twip = 1 Punkt; 72 Punkt = 1 Zoll = 2,54 cm).

PrintZoomHeight Variant optional. Die Höhe in Twip, auf die Word gedruckte Seiten skalieren soll (20 Twip = 1 Punkt; 72 Punkt = 1 Zoll = 2,54 cm).


Beispiel zur PrintOut-Methode (Application-, Document- und Window-Objekte)

In diesem Beispiel wird die aktuelle Seite des aktiven Dokuments gedruckt.

ActiveDocument.PrintOut Range:=wdPrintCurrentPage

In diesem Beispiel werden alle Dokumente im aktuellen Ordner gedruckt. Mit der Dir-Funktion werden alle Dateinamen mit der Dateinamenerweiterung .doc angezeigt.

adoc = Dir("*.DOC")
While adoc <> ""
    Application.PrintOut FileName:=adoc
    adoc = Dir()
Wend

In diesem Beispiel werden die ersten drei Seiten des Dokuments im aktiven Fenster gedruckt.

ActiveDocument.ActiveWindow.PrintOut _
    Range:=wdPrintFromTo, From:="1", To:="3"

In diesem Beispiel werden die Kommentare im aktiven Dokument gedruckt.

If ActiveDocument.Comments.Count >= 1 Then
    ActiveDocument.PrintOut Item:=wdPrintComments
End If

In diesem Beispiel wird das aktive Dokument mit sechs Seiten auf jedem Blatt ausgedruckt.

ActiveDocument.PrintOut PrintZoomColumn:=3, _
    PrintZoomRow:=2

In diesem Beispiel wird das aktive Dokument in einer auf 75% verringerten Größe ausgedruckt.

ActiveDocument.PrintOut _
    PrintZoomWidth:=0.75*(8.5*1440), _
    PrintZoomHeight:=0.75*(11*1440)


PrintOut-Methode (Envelope-Objekt)

Druckt einen Umschlag, ohne ihn zu dem aktiven Dokument hinzuzufügen.

Syntax

Ausdruck.PrintOut(ExtractAddress, Address, AutoText, OmitReturnAddress, ReturnAddress, ReturnAutoText, PrintBarCode, PrintFIMA, Size, Height, Width, FeedSource, AddressFromLeft, AddressFromTop, ReturnAddressFromLeft, ReturnAddressFromTop, DefaultFaceUp, DefaultOrientation)

Ausdruck Erforderlich. Ein Ausdruck, der ein Envelope-Objekt zurückgibt.

ExtractAddress Variant optional. True, um den mit einer Textmarke "EnvelopeAddress" (einer benutzerdefinierten Textmarke) versehenen Text als Empfängeradresse zu verwenden.

Address Variant optional. Eine Zeichenfolge zur Bestimmung der Empfängeradresse (wird ignoriert, wenn ExtractAddress auf True gesetzt ist).

AutoText Variant optional. Der Name des AutoText-Eintrags, der eine Empfängeradresse enthält.

OmitReturnAddress Variant optional. True, wenn die Absenderadresse ausgelassen werden soll.

ReturnAddress Variant optional. Eine Zeichenfolge zur Bestimmung der Absenderadresse.

ReturnAutoText Variant optional. Der Name des AutoText-Eintrags, der eine Absenderadresse enthält.

PrintBarCode Variant optional. True, um einen POSTNET Barcode hinzuzufügen. Nur für U.S.-Post.

PrintFIMA Variant optional. True, um ein "Facing Identification Mark" (FIM-A) hinzuzufügen, zur Vorsortierung von Rückantwortumschlägen. Nur für US-Post.

Size Variant optional. Eine Zeichenfolge zur Bestimmung des Umschlagformats. Die Zeichenfolge sollte einer der Größen entsprechen, die links im Feld Umschlagformat im Dialogfeld Umschlagoptionen aufgeführt sind (z. B. "Size 10").

Height Variant optional. Die Höhe des Umschlags (in Punkten), wenn das Argument Größe auf "Custom size" gesetzt ist.

Width Variant optional. Die Breite des Umschlags (in Punkten), wenn das Argument Größe auf "Custom size" gesetzt ist.

FeedSource Variant optional. True, um mit der FeedSource-Eigenschaft des Envelope-Objekts den Papierschacht zu bestimmen, der zum Drucken des Umschlags verwendet werden soll.

AddressFromLeft Variant optional. Der Abstand zwischen dem linken Umschlagrand und der Empfängeradresse (in Punkten).

AddressFromTop Variant optional. Der Abstand zwischen dem oberen Umschlagrand und der Empfängeradresse (in Punkten).

ReturnAddressFromLeft Variant optional. Der Abstand zwischen dem linken Umschlagrand und der Absenderadresse (in Punkten).

ReturnAddressFromTop Variant optional. Der Abstand zwischen dem oberen Umschlagrand und der Absenderadresse (in Punkten).

DefaultFaceUp Variant optional. True, um den Umschlag mit der Vorderseite nach oben, False um ihn mit der Vorderseite nach unten zu drucken.

DefaultOrientation Variant optional. Die Ausrichtung des Umschlags. Dabei kann es sich um eine der folgenden WdEnvelopeOrientation-Konstanten handeln: wdLeftPortrait, wdCenterPortrait, wdRightPortrait, wdLeftLandscape, wdCenterLandscape, wdRightLandscape, wdLeftClockwise, wdCenterClockwise oder wdRightClockwise.


Beispiel zur PrintOut-Methode (Envelope-Objekt)

In diesem Beispiel wird ein Umschlag mit der Adresse des Benutzers als Absender und vordefinierten Empfängeradresse gedruckt.

recep = "Don Funk" & vbCr & "123 Skye St." & vbCr & _
    "OurTown, WA 98107"
ActiveDocument.Envelope.PrintOut Address:=recep, _
    ReturnAddress:=Application.UserAddress, _
    Size:="Size 10", PrintBarCode:=True


PrintOut-Methode (MailingLabel-Objekt)

Druckt ein Etikett oder eine Seite mit Etiketten mit der gleichen Adresse.

Syntax

Ausdruck.PrintOut(Name, Address, ExtractAddress, LaserTray, SingleLabel, Row, Column)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailingLabel-Objekt zurückgibt.

Name Variant optional. Der Name auf dem Adressetikett.

Address Variant optional. Der Text für die Etikettadresse.

ExtractAddress Variant optional. True, wenn der mit der Textmarke "EnvelopeAddress" (eine benutzerdefinierte Textmarke) markierte Text für das Etikett verwendet werden soll. Wenn dieses Argument spezifiziert ist, werden Address und AutoText ignoriert.

LaserTray Variant optional. Der zu verwendende Schacht des Laserdruckers. Dies kann eine der folgenden WdPaperTray-Konstanten sein:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormatBin

wdPrinterTractorFeed

wdPrinterUpperBin

SingleLabel Variant optional. True, um ein einzelnes Etikett zu drucken. False, wenn eine ganze Seite mit demselben Etikett gedruckt werden soll.

Row Variant optional. Die Etikettzeile für ein einzelnes Etikett. Ungültig, wenn SingleLabel mit False angegeben ist.

Column Variant optional. Die Etikettspalte für ein einzelnes Etikett. Ungültig, wenn SingleLabel mit False angegeben ist.


Beispiel zur PrintOut-Methode (MailingLabel-Objekt)

In diesem Beispiel wird eine Seite mit Avery 5664-Adressetiketten gedruckt, wobei die angegebene Adresse verwendet wird.

addr = "Jane Doe" & vbCr & "123 Skye St." _
    & vbCr & "OurTown, WA 98107"
Application.MailingLabel.PrintOut Name:="5664", Address:=addr


PrintPreview-Methode

Wechselt die Ansicht zur Seitenansicht.

Anmerkung Zusätzlich zur PrintPreview-Methode können Sie die PrintPreview-Eigenschaft auf True oder False einstellen, um die Seitenansicht zu aktivieren bzw. zu deaktivieren. Sie können die Ansicht auch wechseln, indem Sie die Type-Eigenschaft für das View-Objekt auf wdPrintPreview setzen.

Syntax

Ausdruck.PrintPreview

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur PrintPreview-Methode

Dieses Beispiel zeigt das aktive Dokument in der Seitenansicht an, wenn es sich derzeit in einem anderen Ansichtsmodus befindet.

If Application.PrintPreview = False Then
    ActiveDocument.PrintPreview
End If


ProductCode-Methode

Gibt den global eindeutigen Bezeichner (GUID) von Microsoft Word als String zurück.

Syntax

Ausdruck.ProductCode

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur ProductCode-Methode

In diesem Beispiel wird der GUID für Microsoft Word angezeigt.

MsgBox Application.ProductCode


Protect-Methode

Verhindert Änderungen am angegebenen Dokument. Benutzer können geschützte Dokumente nur begrenzt ändern, z. B. ist es möglich, Anmerkungen hinzuzufügen, Korrekturfunktionen aufzurufen oder ein Formular auszufüllen.

Hinweis Wenn Sie diese Methode einem bereits geschützten Dokument zuweisen, tritt ein Fehler auf.

Syntax

Ausdruck.Protect(Type, NoReset, Password)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Type Long erforderlich. Die Art des Schutzes für das angegebene Dokument. Dabei kann es sich um eine der folgenden WdProtectionType-Konstanten handeln: wdAllowOnlyComments, wdAllowOnlyFormFields, wdAllowOnlyRevisions oder wdNoProtection.

NoReset Variant optional. False, um Formularfelder auf ihre Standardwerte zurückzusetzen. True, um die aktuellen Formularfeldwerte zu übernehmen, wenn das angegebene Dokument geschützt ist. Wenn Type nicht wdAllowOnlyFormFields lautet, wird das NoReset-Argument ignoriert.

Password Variant optional. Das Kennwort, das den Schutz des angegebenen Dokuments aufhebt.


Beispiel zur Protect-Methode

In diesem Beispiel wird das aktive Dokument mit dem Dokumentschutz für Formulare versehen, ohne den Inhalt der Formularfelder zurückzusetzen.

If ActiveDocument.ProtectionType = wdNoProtection Then
    ActiveDocument.Protect _
        Type:=wdAllowOnlyFormFields, NoReset:=True
End If

In diesem Beispiel wird Monthly Report.doc so geschützt, dass nur Anmerkungen hinzugefügt werden können. Nur mit dem Kennwort "free" kann der Dokumentschutz aufgehoben werden.

Set myDoc = Documents("Monthly Report.doc")
myDoc.Protect Type:=wdAllowOnlyComments, Password:="free"


Quit-Methode

Beendet Word und speichert die geöffneten Dokumente oder leitet sie weiter (optional).

Syntax

Ausdruck.Quit(SaveChanges, Format, RouteDocument)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

SaveChanges Variant optional. Legt fest, ob geänderte Dokumente vor dem Beenden von Word gespeichert werden. Dies kann eine der folgenden WdSaveOptions-Konstanten sein: wdDoNotSaveChanges, wdPromptToSaveChanges oder wdSaveChanges.

OriginalFormat Variant optional. Legt fest, wie Word Dokumente speichert, deren ursprüngliches Format kein Word-Dokumentformat war. Dies kann eine der folgenden WdOriginalFormat-Konstanten sein: wdOriginalDocumentFormat, wdPromptUser oder wdWordDocument.

RouteDocument Variant optional. True, um das Dokument an den nächsten Empfänger weiterzuleiten. Ist dem Dokument kein Verteiler zugeordnet, wird dieses Argument ignoriert.


Beispiel zur Quit-Methode

In diesem Beispiel wird Word beendet und der Benutzer aufgefordert, die Dokumente zu speichern, die seit dem letzten Speichern geändert wurden.

Application.Quit SaveChanges:=wdPromptToSaveChanges

In diesem Beispiel wird der Benutzer aufgefordert, alle Dokumente zu speichern. Klickt der Benutzer auf die Schaltfläche "Yes", werden alle Dokumente vor dem Beenden von Word im Word-Format gespeichert.

response = MsgBox("Do you want to save all documents?", vbYesNo)
If response = vbYes Then Application.Quit _
    SaveChanges:=wdSaveChanges, OriginalFormat:=wdWordDocument


Range-Methode

Document-Objekt: Gibt ein Range-Objekt zurück, indem die angegebenen Start- und Endzeichenpositionen verwendet werden. Informationen über Range-Objekte finden Sie unter Arbeiten mit Range-Objekten.

Shapes-Objekt: Gibt ein ShapeRange-Objekt zurück, das eine Untermenge von Formen in der Shapes-Auflistung darstellt.

Syntax 1

Ausdruck.Range(Start, End)

Syntax 2

Ausdruck.Range(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt (Syntax 1) oder ein Shapes-Objekt (Syntax 2) zurückgibt.

Start Long optional. Die Startzeichenposition.

End Long optional. Die Endzeichenposition.

Index Variant erforderlich. Gibt an, welche Formen in den angegebenen Bereich eingeschlossen werden sollen. Dies kann eine ganze Zahl sein, die die Indexnummer einer Form innerhalb der Shapes-Auflistung angibt, eine Zeichenfolge, die den Namen einer Form angibt, oder ein Variant-Datenfeld, das ganze Zahlen oder Zeichenfolgen enthält.

Hinweise

Zeichenpositionswerte beginnen am Anfang des Dokuments bei 0 (Null). Alle Zeichen werden mitgezählt, auch nicht druckbare Zeichen. Ausgeblendete Zeichen werden mitgezählt, auch wenn sie nicht angezeigt werden. Wenn Sie für die Range-Methode keine Start- und Endzeichenpositionen angeben, wird das gesamte Dokument als Range-Objekt zurückgegeben.

ShapeRange-Objekte umfassen keine InlineShape-Objekte. Ein InlineShape-Objekt ist äquivalent zu einem Zeichen und wie ein Zeichen innerhalb eines Textbereichs positioniert. Shape-Objekte sind an einem Textbereich verankert (standardmäßig die Markierung), aber sie können auf der Seite beliebig positioniert werden. Ein Shape-Objekt erscheint immer auf derselben Seite wie der Bereich, an dem es verankert ist.

Die meisten Operationen, die Sie mit einem Shape-Objekt durchführen können, können Sie auch mit einem ShapeRange-Objekt durchführen, das eine einzige Form enthält. Manche Operationen führen zu einem Fehler, wenn sie auf einem ShapeRange-Objekt durchgeführt werden, das mehrere Formen enthält.


RangeFromPoint-Methode

Gibt das Range- oder Shape-Objekt zurück, das sich an der durch die Bildschirmkoordinaten angegebenen Stelle befindet. Wenn sich an den angegebenen Koordinaten kein Bereich und keine Form befindet, gibt die Methode Nothing zurück.

Syntax

Ausdruck.RangeFromPoint(x, y)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.

x Long erforderlich. Der horizontale Abstand (in Pixel) zwischen dem linken Bildschirmrand und dem Punkt.

y Long erforderlich. Der vertikale Abstand (in Pixel) zwischen dem oberen Bildschirmrand und dem Punkt.


Beispiel zur RangeFromPoint-Methode

In diesem Beispiel wird ein neues Dokument erstellt und diesem ein fünfzackiger Stern hinzugefügt. Anschließend wird die Bildschirmposition der Form ermittelt und berechnet, wo sich der Mittelpunkt der Form befindet. Mit diesen Koordinaten wird die RangeFromPoint-Methode verwendet, um einen Verweis auf die Form zurückzugeben und ihre Füllfarbe zu ändern.

Dim pLeft As Long
Dim pTop As Long
Dim pWidth As Long
Dim pHeight As Long
Dim myShape As Object
Dim newDoc As New Document

With newDoc
    .Shapes.AddShape msoShape5pointStar, _
        288, 100, 100, 72
    .ActiveWindow.GetPoint pLeft, pTop, _
        pWidth, pHeight, .Shapes(1)
    Set myShape = .ActiveWindow.RangeFromPoint(pLeft _
        + pWidth * 0.5, pTop + pHeight * 0.5)
    myShape.Fill.ForeColor.RGB = RGB(80, 160, 130)
End With


Rebind-Methode

Ändert den Befehl, der einer bestimmten Tastenkombination zugewiesen ist.

Syntax

Ausdruck.Rebind(KeyCategory, Command, CommandParameter)

Ausdruck Erforderlich. Ein Ausdruck, der ein KeyBinding-Objekt zurückgibt.

KeyCategory Long erforderlich. Die Tastenkategorie der angegebenen Tastenkombination. Dabei kann es sich um eine der folgenden WdKeyCategory-Konstanten handeln:

WdKeyCategoryAutoText

WdKeyCategoryCommand

WdKeyCategoryDisable

WdKeyCategoryFont

WdKeyCategoryMacro

 WdKeyCategoryNil

WdKeyCategoryPrefix

WdKeyCategoryStyle

WdKeyCategorySymbol

Command String erforderlich. Der Name des angegebenen Befehls.

CommandParameter Variant optional. Zusätzlicher Text, der zur Ausführung des mit Command festgelegten Befehls nötig ist. Informationen zu den Werten für dieses Argument finden Sie unter Add-Methode für das KeyBindings-Objekt.


Beispiel zur Rebind-Methode

In diesem Beispiel wird die Tastenkombination STRG+UMSCHALT+S erneut dem Befehl FileSaveAs zugewiesen.

CustomizationContext = NormalTemplate
Set myKey = FindKey(BuildKeyCode(wdKeyControl, wdKeyShift, wdKeyS))
myKey.Rebind KeyCategory:=wdKeyCategoryCommand, _
    Command:="FileSaveAs"

In diesem Beispiel werden erneut alle dem Makro "Macro1" zugewiesenen Tasten an das Makro "ReportMacro" gebunden.

CustomizationContext = ActiveDocument.AttachedTemplate
For Each myKey In KeysBoundTo(KeyCategory:=wdKeyCategoryMacro, _
    Command:="Macro1")
    myKey.Rebind KeyCategory:=wdKeyCategoryMacro, _
        Command:="ReportMacro"
Next myKey


Redo-Methode

Stellt die letzte Aktion wieder her, die rückgängig gemacht wurde (kehrt die Undo-Methode um). Gibt True zurück, wenn die Aktionen erfolgreich wiederhergestellt wurden.

Syntax

Ausdruck.Redo(Times)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Times Variant optional. Die Anzahl der Aktionen, die wiederhergestellt werden können.


Beispiel zur Redo-Methode

In diesem Beispiel werden die letzten beiden Aktionen in der Wiederherstellungsliste von "Sales.doc" wiederhergestellt.

Documents("Sales.doc").Redo 2

In diesem Beispiel wird die letzte Aktion im aktiven Dokument wiederhergestellt. Wenn die Aktion erfolgreich wiederhergestellt wurde, wird in der Statusleiste eine Meldung angezeigt.

On Error Resume Next
If ActiveDocument.Redo = False Then _
    StatusBar = "Redo was unsuccessful"


Regroup-Methode

Gruppiert die Gruppe, zu der der angegebene Formbereich zuvor gehörte. Gibt die gruppierten Formen als ein einzelnes Shape-Objekt zurück.

Syntax

Ausdruck.Regroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Hinweise

Die Regroup-Methode stellt nur die Gruppe der ersten zuvor gruppierten Form wieder her, die sie in der angegebenen ShapeRange-Auflistung findet. Deshalb wird nur eine der Gruppen wiederhergestellt, wenn der angegebene Formbereich Formen enthält, die zuvor zu unterschiedlichen Gruppen gehörten.

Beachten Sie, dass sich beim Gruppieren und Auflösen einer Gruppierung die Anzahl der Elemente in der Shapes-Auflistung ändert und sich die Indexnummern der Elemente nach den betroffenen Elementen in der Auflistung ändern, weil eine Formengruppe als eine einzelne Form betrachtet wird.


Beispiel zur Regroup-Methode

In diesem Beispiel werden die Formen der Auswahl im aktiven Fenster gruppiert. Dieses Beispiel funktioniert nur, wenn die Formen zuvor gruppiert und ihre Gruppierung aufgehoben wurde.

ActiveDocument.ActiveWindow.Selection.ShapeRange.Regroup


Reject-Methode

Lehnt die angegebene Überarbeitung ab. Die Korrekturmarkierungen werden entfernt, und der Originaltext bleibt erhalten.

Hinweis Formatierungsänderungen können nicht abgelehnt werden.

Syntax

Ausdruck.Reject

Ausdruck Erforderlich. Ein Ausdruck, der ein Revision-Objekt zurückgibt.


RejectAll-Methode

Lehnt alle Überarbeitungen in einem Bereich ab. Die Überarbeitungsmarkierungen werden entfernt, wobei der Originaltext erhalten bleibt.

Syntax

Ausdruck.RejectAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Revisions-Objekt zurückgibt.

Anmerkungen

Verwenden Sie die RejectAllRevisions-Methode, um alle Überarbeitungen in einem Dokument abzulehnen. Formatänderungen können nicht abgelehnt werden.


RejectAllRevisions-Methode

Lehnt alle überwachten Änderungen im angegebenen Dokument ab.

Syntax

Ausdruck.RejectAllRevisions

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur RejectAllRevisions-Methode

In diesem Beispiel wird der Haupttextbereich im aktiven Dokument nach überwachten Änderungen durchsucht. Falls solche Änderungen gefunden werden, lehnt das Beispiel alle Korrekturen in allen Dokumentkomponenten ab.

If ActiveDocument.Revisions.Count >= 1 Then _
    ActiveDocument.RejectAllRevisions


Reload-Methode

Lädt ein Dokument neu, das sich im Cachespeicher befindet, indem der Hyperlink zum ursprünglichen Dokument aufgelöst und dieses heruntergeladen wird.

Hinweis Wenn auf das Dokument schon vorher zugegriffen wurde, stellt diese Methode sicher, dass nicht die Cachespeicher-Version des angegebenen Dokuments verwendet wird. Wenn das angegebene Dokument nicht vom World Wide Web oder einem lokalen Intranet geöffnet wurde, tritt ein Fehler auf.

Syntax

Ausdruck.Reload

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


ReloadAs-Methode

Lädt ein auf einem HTML-Dokument basierendes Dokument unter Verwendung der angegebenen Dokumentcodierung erneut.

Syntax

Ausdruck.ReloadAs(Encoding)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Encoding Long erforderlich. Eine beliebige, gültige MsoEncoding-Konstante ist möglich. Eine Liste der gültigen MsoEncoding-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.


Beispiel zur ReloadAs-Methode

In diesem Beispiel wird das aktuelle Dokument mit kyrillischer Codierung erneut geladen.

ActiveDocument.ReloadAs msoEncodingCyrillic


Relocate-Methode

Verschiebt in der Gliederungsansicht die Absätze innerhalb des angegebenen Bereichs hinter den nächsten sichtbaren Absatz oder vor den vorherigen sichtbaren Absatz. Ein Textkörper wird mit einer Überschrift nur verschoben, wenn der Textkörper in der Gliederungsansicht reduziert wurde, oder wenn er Teil des Bereichs ist.

Syntax

Ausdruck.Relocate(Direction)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Direction Long erforderlich. Die Richtung der Verschiebung. Kann eine der zwei folgenden WdRelocate-Konstanten sein: wdRelocateUp oder wdRelocateDown.


Beispiel zur Relocate-Methode

In diesem Beispiel werden der dritte, vierte und fünfte Absatz im aktiven Dokument unter den nächsten (sechsten) Absatz verschoben.

theStart = ActiveDocument.Paragraphs(3).Range.Start
theEnd = ActiveDocument.Paragraphs(5).Range.End
Set myRange = ActiveDocument.Range(Start:=theStart, End:=theEnd)
ActiveDocument.ActiveWindow.View.Type = wdOutlineView
myRange.Relocate Direction:=wdRelocateDown

In diesem Beispiel wird der erste Absatz in der Markierung vor den vorherigen Absatz verschoben.

ActiveDocument.ActiveWindow.View.Type = wdOutlineView
Selection.Paragraphs(1).Range.Relocate Direction:=wdRelocateUp


RemoveNumbers-Methode

Entfernt Zahlen oder Aufzählungszeichen vom angegebenen Document-, List- oder ListFormat-Objekt.

Syntax

Ausdruck.RemoveNumbers(NumberType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-, List- oder ListFormat-Objekt zurückgibt.

NumberType Variant optional. Der Zahlentyp, der entfernt werden soll. Dabei kann es sich um eine der folgenden WdNumberType-Konstanten handeln: wdNumberParagraph, wdNumberListNum oder wdNumberAllNumbers. Der Standardwert ist wdNumberAllNumbers.

Anmerkungen

Wenn diese Methode einem List-Objekt zugewiesen wird, werden Zahlen nur von Absätzen in der angegebenen Liste entfernt. Eingeschobene Zahlen aus anderen Listen werden übersprungen. Wird diese Methode einem ListFormat-Objekt für einen Textbereich zugewiesen, werden alle Zahlen aus der Liste im Bereich entfernt.


Beispiel zur RemoveNumbers-Methode

In diesem Beispiel werden alle Aufzählungszeichen oder Zahlen von allen nummerierten Absätzen in der Auswahl entfernt.

Selection.Range.ListFormat.RemoveNumbers

In diesem Beispiel werden die Zahlen am Anfang aller nummerierten Absätze im aktiven Dokument entfernt.

ActiveDocument.RemoveNumbers wdNumberParagraph

In diesem Beispiel werden die LISTNUM-Felder aus der Auswahl entfernt.

Selection.Range.ListFormat.RemoveNumbers wdNumberListNum

In diesem Beispiel werden die Aufzählungszeichen und Zahlen aus der dritten Liste in MyDocument.doc entfernt.

If Documents("MyDocument.doc").Lists.Count >= 3 Then
    Documents("MyDocument.doc").Lists(3).RemoveNumbers
End If


 RemoveTheme-Methode

RemoveTheme-Methode

Entfernt das aktive Design aus dem aktuelle Dokument.

Syntax

Ausdruck.RemoveTheme

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur RemoveTheme-Methode

In diesem Beispiel wird das aktive Design aus dem aktuellen Dokument entfernt.

ActiveDocument.RemoveTheme


Repaginate-Methode

Führt einen Seitenumbruch für das gesamte Dokument durch.

Syntax

Ausdruck.Repaginate

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur Repaginate-Methode

In diesem Beispiel wird ein Seitenumbruch für das aktive Dokument durchgeführt, wenn es seit dem letzten Speichern geändert wurde.

If ActiveDocument.Saved = False Then ActiveDocument.Repaginate

In diesem Beispiel wird ein Seitenumbruch für alle geöffneten Dokumente durchgeführt.

For Each doc In Documents
    doc.Repaginate
Next doc


Repeat-Methode

Wiederholt die jeweils zuletzt durchgeführte Bearbeitungsaktion einmal oder mehrere Male. Gibt True zurück, wenn die Befehle erfolgreich wiederholt wurden.

Anmerkung Die Verwendung dieser Methode entspricht der Verwendung des Befehls Wiederholen im Menü Bearbeiten.

Syntax

Ausdruck.Repeat(Times)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Times Variant optional. Die Anzahl der gewünschten Wiederholungen des letzten Befehls.


Beispiel zur Repeat-Methode

In diesem Beispiel wird der Text "Hello", gefolgt von zwei Absätzen, eingefügt (die zweite Eingabeaktion wird einmal wiederholt).

Selection.TypeText "Hello"
Selection.TypeParagraph
Repeat

In diesem Beispiel wird der letzte Befehl dreimal wiederholt (sofern er wiederholt werden kann).

On Error Resume Next
If Repeat(3) = True Then StatusBar = "Action repeated"


Reply-Methode

Öffnet eine neue E-Mail-Nachricht mit der Absenderadresse auf der Zeile To: zum Beantworten der aktiven Nachricht.

Syntax

Ausdruck.Reply

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


ReplyAll-Methode

Öffnet eine neue E-Mail-Nachricht mit der Adresse des Absenders sowie aller anderen Empfänger auf der Zeile To: und gegebenenfalls allen anderen Empfängeradressen auf der Zeile Cc: zum Beantworten der aktiven Nachricht.

Syntax

Ausdruck.ReplyAll

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur ReplyAll-Methode

In diesem Beispiel wird eine neue E-Mail-Nachricht zum Beantworten der aktiven Nachricht geöffnet.

Application.MailMessage.ReplyAll


Reset-Methode

Font-Objekt: Entfernt manuelle Zeichenformatierung (Formatierung, die ohne Formatvorlage zugewiesen wurde). Wenn Sie beispielsweise ein Wort manuell fett auszeichnen und die zugrunde liegende Formatvorlage unformatierter Text ist (nicht fett), entfernt die Reset-Methode das Fettformat.

Paragraph-, Paragraphs- oder ParagraphFormat-Objekt: Entfernt manuelle Absatzformatierung (Formatierung, die ohne Formatvorlage zugewiesen wurde). Wenn Sie beispielsweise einen Absatz manuell rechts ausrichten und die zugrunde liegende Formatvorlage hat eine andere Ausrichtung, ändert die Reset-Methode die Ausrichtung so, dass sie mit der Formatierung der zugrunde liegenden Formatvorlage übereinstimmt.

RoutingSlip-Objekt: Setzt den Verteiler zurück, so dass mit derselben Empfängerliste und Empfängerinformation eine neue Weiterleitung initiiert werden kann. Die Weiterleitung muss beendet sein, bevor Sie diese Methode verwenden.

InlineShape-Objekt: Entfernt Änderungen, die an einer eingebetteten Figur vorgenommen wurden.

ListGallery-Objekt: Setzt die Listenvorlage, die durch Index für den angegebenen Listenkatalog spezifiziert wurde, auf das integrierte Listenvorlagenformat zurück.

Syntax 1

Ausdruck.Reset

Syntax 2

Ausdruck.Reset(Index)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Font-, RoutingSlip-, InlineShape-, Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein ListGallery-Objekt zurückgibt.

Index Long erforderlich. Eine Zahl von 1 bis 7, die einem Format im angegebenen Listenkatalog entspricht. Lässt man die Option Ohne außer Acht, werden die Formate von links nach rechts nummeriert, beginnend mit der obersten Zeile.


ResetContinuationNotice-Methode

Setzt den Fortsetzungshinweis einer Fuß- oder Endnote auf die Standardmeldung zurück. Die Standardmeldung ist leer (kein Text).

Syntax

Ausdruck.ResetContinuationNotice

Ausdruck Erforderlich. Ein Ausdruck, der ein Endnotes- oder Footnotes-Objekt zurückgibt.


Beispiel zur ResetContinuationNotice-Methode

In diesem Beispiel wird der Endnoten-Fortsetzungshinweis für das aktuelle Dokument zurückgesetzt.

ActiveDocument.Endnotes.ResetContinuationNotice

In diesem Beispiel wird der Fußnoten-Fortsetzungshinweis zurückgesetzt, und die Startnummer für das Fußnotenzeichen wird auf 2 im Sales.doc gesetzt.

With Documents("Sales.doc").Sections(1).Range.Footnotes
    .ResetContinuationNotice
    .NumberingRule = wdRestartContinuous
    .StartingNumber = 2
End With


ResetContinuationSeparator-Methode

Setzt die Fortsetzungstrennlinie für eine Fuß- oder Endnote auf die Standardtrennlinie zurück. Bei der Standardtrennlinie handelt es sich um eine lange horizontale Linie, die den Dokumenttext von den Fuß-/ Endnoten trennt, die von der vorherigen Seite fortgesetzt wurden.

Syntax

Ausdruck.ResetContinuationSeparator

Ausdruck Erforderlich. Ein Ausdruck, der ein Endnotes- oder Footnotes-Objekt zurückgibt.


Beispiel zur ResetContinuationSeparator-Methode

In diesem Beispiel wird die Fortsetzungstrennlinie für Fußnoten auf die Standardtrennlinie zurückgesetzt.

ActiveDocument.Footnotes.ResetContinuationSeparator

In diesem Beispiel wird die Fortsetzungstrennlinie der Endnoten für den ersten Abschnitt in allen offenen Dokumenten zurückgesetzt.

For Each doc In Documents
    doc.Sections(1).Range.Endnotes.ResetContinuationSeparator
Next doc


ResetIgnoreAll-Methode

Löscht die Liste der Wörter, die bei einer Rechtschreibprüfung bisher ignoriert wurden. Nach der Verwendung dieser Methode werden alle vorher ignorierten Wörter zusammen mit den anderen Wörtern geprüft.

Syntax

Ausdruck.ResetIgnoreAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Hinweise

Damit Sie die ResetIgnoreAll-Methode verwenden können, müssen Sie die SpellingChecked-Eigenschaft auf False setzen.


Beispiel zur ResetIgnoreAll-Methode

In diesem Beispiel wird die Liste der Wörter gelöscht, die bei einer vorhergehenden Rechtschreibprüfung ignoriert wurden, und dann eine neue Rechtschreibprüfung des aktiven Dokuments begonnen.

Application.ResetIgnoreAll
ActiveDocument.SpellingChecked = False
ActiveDocument.CheckSpelling


ResetRotation-Methode

Setzt die Projektionsdrehung um die x-Achse und die y-Achse auf 0 (Null) zurück, so dass die Projektionsfront nach vorne gerichtet ist. Diese Methode setzt nicht die Drehung um die z-Achse zurück.

Syntax

Ausdruck.ResetRotation

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Anmerkungen

Zum Festlegen der Projektionsdrehung um die x-Achse und die y-Achse auf einen anderen Wert als 0 (Null) verwenden Sie die RotationX- bzw. RotationY-Eigenschaft des ThreeDFormat-Objekts. Zum Festlegen der Projektionsdrehung um die z-Achse verwenden Sie die Rotation-Eigenschaft des Shape-Objekts, das die Projektionsform darstellt.


Beispiel zur ResetRotation-Methode

In diesem Beispiel wird in myDocument für die Projektion von Form eins die Drehung um die x-Achse und die y-Achse auf 0 (Null) zurückgesetzt.

Set myDocument = ActiveDocument
myDocument.Shapes(1).ThreeD.ResetRotation


ResetSeparator-Methode

Setzt die Trennlinien für Fuß- oder Endnoten auf die Standardtrennlinie zurück. Bei der Standardtrennlinie handelt es sich um eine kurze horizontale Linie, die den Dokumenttext von den Fuß-/ Endnoten trennt.

Syntax

Ausdruck.ResetSeparator

Ausdruck Erforderlich. Ein Ausdruck, der ein Endnotes- oder Footnotes-Objekt zurückgibt.


Beispiel zur ResetSeparator-Methode

In diesem Beispiel wird die Fußnoten-Trennlinie auf die Standardtrennlinie zurückgesetzt.

ActiveDocument.Footnotes.ResetSeparator

In diesem Beispiel wird die Trennlinie der Endnoten in dem Dokument zurückgesetzt, in dem sich die Markierung befindet.

Selection.Endnotes.ResetSeparator


Resize-Methode

Legt die Größe des Word-Anwendungsfensters oder des angegebenen Task-Fensters fest. Ist das Fenster maximiert oder minimiert, wird ein Fehler ausgegeben.

Anmerkung Mit der Width- oder Height-Eigenschaft können Sie die Fensterbreite bzw. -höhe unabhängig voneinander einstellen.

Syntax

Ausdruck.Resize(Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application- oder Task-Objekt zurückgibt.

Width Long erforderlich. Die Breite des Fensters in Punkt.

Height Long erforderlich. Die Höhe des Fensters in Punkt.


Beispiel zur Resize-Methode

In diesem Beispiel wird das Microsoft Excel-Anwendungsfenster auf eine Breite von 6 Zoll und eine Höhe von 4 Zoll eingestellt.

If Tasks.Exists("Microsoft Excel") = True Then
    With Tasks("Microsoft Excel")
        .WindowState = wdWindowStateNormal
        .Resize Width:=InchesToPoints(6), Height:=InchesToPoints(4)
    End With
End If

In diesem Beispiel wird das Word-Anwendungsfenster auf eine Breite von 7 Zoll und eine Höhe von 6 Zoll eingestellt.

With Application
    .WindowState = wdWindowStateNormal
    .Resize Width:=InchesToPoints(7), Height:=InchesToPoints(6)
End With


Route-Methode

Mit der aktuellen Verteilerliste wird das angegebene Dokument versandt.

Anmerkungen

Ein Fehler tritt auf, wenn das Dokument nicht mit einer Verteilerliste versehen ist. Mit der HasRoutingSlip-Eigenschaft bestimmen Sie, ob ein Dokument eine angehängte Verteilerliste hat. Wenn Sie ein Dokument weiterleiten, wird die Routed-Eigenschaft auf True gesetzt.

Syntax

Ausdruck.Route

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur Route-Methode

Wenn das aktive Dokument mit einer Verteilerliste versehen ist, wird es in diesem Beispiel weitergeleitet.

If ActiveDocument.HasRoutingSlip = True Then ActiveDocument.Route

In diesem Beispiel wird das Dokument "Feedback.doc" an zwei Empfänger nacheinander weitergeleitet.

Documents("Feedback.doc").HasRoutingSlip = True
With Documents("Feedback.doc").RoutingSlip
    .Subject = "Your feedback please..."
    .AddRecipient Recipient:="Tad Orman"
    .AddRecipient Recipient:="David Simpson"
    .Delivery = wdOneAfterAnother
End With
Documents("Status.doc").Route


RtlPara-Methode

Sprachspezifische Informationen

Sets the reading order and alignment of the specified paragraphs to right-to-left.

Syntax

expression.RtlPara

expression Required. An expression that returns a Selection object.

Remarks

For all selected paragraphs, this method sets the reading order to right-to-left. If a paragraph with a left-to-right reading order is also left-aligned, this method reverses its reading order and sets its paragraph alignment to right-aligned.

Use the ReadingOrder property to change the reading order without affecting paragraph alignment.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur RtlPara-Methode

This example sets the reading order and alignment of the current selection to right-to-left if the selection isn't styled as "Normal."

If Selection.Style <> "Normal" Then _
    Selection.RtlPara


 RtlRun-Methode

RtlRun-Methode

Sprachspezifische Informationen

Sets the reading order and alignment of the specified run to right-to-left.

Syntax

expression.RtlRun

expression Required. An expression that returns a Selection object.

Remarks

For the specified run, this method sets the reading order to right-to-left. If a paragraph in the run with a left-to-right reading order is also left-aligned, this method reverses its reading order and sets its paragraph alignment to right-aligned.

Use the ReadingOrder property to change the reading order without affecting paragraph alignment.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur RtlRun-Methode

This example sets the reading order and alignment of the specified run to right-to-left if the selection isn't styled as "Normal."

If Selection.Style <> "Normal" Then _
    Selection.RtlRun


Run-Methode

Führt ein Visual Basic-Makro aus.

Syntax

Ausdruck.Run(MacroName, varg1, varg2, varg3, varg4, varg5, varg6, varg7, varg8, varg9, varg10, varg11, varg12, varg13, varg14, varg15, varg16, varg17, varg18, varg19, varg20, varg21, varg22, varg23, varg24, varg25, varg26, varg27, varg28, varg29, varg30)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

MacroName String erforderlich. Der Name des Makros. Kann aus einer beliebigen Kombination von Dokumentvorlagen-, Modul- und Makroname bestehen. So sind beispielsweise die folgenden Aussagen gültig:

Application.Run "Normal.Module1.MAIN"
Application.Run "MyProject.MyModule.MyProcedure"
Application.Run "'My Document.doc'!ThisModule.ThisProcedure"

Wenn Sie den Namen des Dokuments festlegen, kann Ihr Code nur Makros in Dokumenten ausführen, die mit dem aktuellen Inhalt in Verbindung stehen, und nicht alle Makros in allen Dokumenten.

varg1...varg30 Variant optional. Parameterwerte für Makros. Sie können für das angegebene Makro bis zu 30 Parameterwerte festlegen.

Hinweise

Obwohl Visual Basic-Code ein Makro direkt (ohne Verwendung dieser Methode) aufrufen kann, ist diese Methode hilfreich, wenn der Makroname in einer Variable gespeichert ist (weitere Informationen finden Sie im Beispiel zu diesem Thema). Die folgenden Anweisungen erfüllen dieselbe Funktion.

Normal.Module2.Macro1
Call Normal.Module2.Macro1
Application.Run MacroName:="Normal.Module2.Macro1"


RunAutoMacro-Methode

Führt ein Auto-Makro aus, das im angegebenen Dokument gespeichert ist. Wenn das angegebene Auto-Makro nicht vorhanden ist, passiert nichts.

Hinweis Verwenden Sie die Run-Methode zum Ausführen eines Makros.

Syntax

Ausdruck.RunAutoMacro(Which)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Which Long erforderlich. Das Auto-Makro, das ausgeführt werden soll. Dies kann eine der folgenden WdAutoMacros-Konstanten sein: wdAutoClose, wdAutoExec, wdAutoExit, wdAutoNew oder wdAutoOpen.


Beispiel zur RunAutoMacro-Methode

In diesem Beispiel wird im aktiven Dokument das AutoOpen-Makro ausgeführt.

ActiveDocument.RunAutoMacro Which:=wdAutoOpen


RunLetterWizard-Methode

Ruft den Brief-Assistenten mit dem angegebenen Dokument auf.

Syntax

Ausdruck.RunLetterWizard(LetterContent, WizardMode)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

LetterContent Variant optional. Ein LetterContent-Objekt. Alle belegten Eigenschaften im LetterContent-Objekt werden als vorab ausgefüllte Elemente in den Dialogfeldern des Brief-Assistenten angezeigt. Wenn Sie dieses Argument auslassen, wird automatisch mit der GetLetterContent-Methode ein LetterContent-Objekt aus dem angegebenen Dokument erstellt.

WizardMode Variant optional. True, um das Dialogfeld Brief-Assistent als eine Reihe von Arbeitsschritten mit den Schaltflächen Weiter, Zurück und Fertigstellen anzuzeigen. False, um das Dialogfeld Brief-Assistent anzuzeigen, als wäre es über das Menü Extras (ein Dialogfeld zum Festlegen von Eigenschaften mit den Schaltflächen OK und Abbrechen) geöffnet worden. Der Standardwert lautet True.

Hinweise

Verwenden Sie die CreateLetterContent-Methode, um ein LetterContent-Objekt mit verschiedenen Eigenschaften für Briefelemente zu erstellen. Verwenden Sie die GetLetterContent-Methode, um ein LetterContent-Objekt zurückzugeben, dessen Grundlage der Inhalt des angegebenen Dokuments ist. Sie können das daraus resultierende LetterContent-Objekt mit der RunLetterWizard-Methode verwenden, um Elemente mit dem Dialogfeld Brief-Assistent vorzugeben.


Beispiel zur RunLetterWizard-Methode

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften werden für das Objekt festgelegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
With myContent
    .Salutation ="Hello"
    .SalutationType = wdSalutationOther
    .SenderName = Application.UserName
    .SenderInitials =Application.UserInitials
End With
Documents.Add.RunLetterWizard _
    LetterContent:=myContent, WizardMode:=True

Das folgende Beispiel erstellt mit der CreateLetterContent-Methode ein neues LetterContent-Objekt im aktiven Dokument und verwendet dann dieses Objekt mit der RunLetterWizard-Methode.

Set myLetter = ActiveDocument _
    .CreateLetterContent(DateFormat:="July 31, 1999", _
    IncludeHeaderFooter:=False, _
    PageDesign:="C:\MSOffice\Templates" _
    & "\Letters & Faxes\Contemporary Letter.dot", _
    LetterStyle:=wdFullBlock, Letterhead:=True, _
    LetterheadLocation:=wdLetterTop, _
    LetterheadSize:=InchesToPoints(1.5), _
    RecipientName:="Dave Edson", _
    RecipientAddress:="436 SE Main St." _
    & vbCr & "Bellevue, WA 98004", _
    Salutation:="Dear Dave,", _
    SalutationType:=wdSalutationInformal, _
    RecipientReference:="", MailingInstructions:="", _
    AttentionLine:="", Subject:="End of year report", _
    CCList:="", ReturnAddress:="", SenderName:="", _
    Closing:="Sincerely yours,", SenderCompany:="", _
    SenderJobTitle:="", SenderInitials:="", _
    EnclosureNumber:=0)
ActiveDocument.RunLetterWizard LetterContent:=myLetter


Save-Methode

Syntax 1: Speichert das angegebene Dokument bzw. die angegebene Vorlage. Falls das Dokument bzw. die Vorlage noch nicht gespeichert wurde, wird der Benutzer im Dialogfeld Speichern unter aufgefordert, einen Dateinamen einzugeben.

Syntax 2: Speichert alle Dokumente in der Documents-Auflistung. Falls ein Dokument noch nicht gespeichert wurde, wird der Benutzer im Dialogfeld Speichern unter aufgefordert, einen Dateinamen einzugeben.

Syntax 3: Speichert eine Version des angegebenen Dokuments mit einem Kommentar.

Syntax 1

Ausdruck.Save

Syntax 2

Ausdruck.Save(NoPrompt, OriginalFormat)

Syntax 3

Ausdruck.Save(Comment)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Document-oder Template-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Documents-Objekt (Auflistung) zurückgibt.

Syntax 3: Erforderlich. Ein Ausdruck, der ein Versions-Objekt zurückgibt.

NoPrompt Variant optional. True, wenn Word alle Dokumente automatisch speichern soll. False, wenn Word den Benutzer auffordern soll, die Dokumente zu speichern, die seit dem letzten Speichern geändert wurden.

OriginalFormat Variant optional. Gibt an, wie die Dokumente gespeichert werden. Dies kann eine der folgenden WdOriginalFormat-Konstanten sein: wdOriginalDocumentFormat, wdPromptUser oder wdWordDocument.

Comment Variant optional. Die Kommentarzeichenfolge, die mit der Version gespeichert wird.


SaveAs-Methode

Speichert das angegebene Dokument unter einem neuen Namen oder in einem neuen Format. Die Argumente für diese Methode entsprechen den Optionen im Dialogfeld Speichern unter (Menü Datei).

Syntax

Ausdruck.SaveAs(FileName, FileFormat, LockComments, Password, AddToRecentFiles, WritePassword, ReadOnlyRecommended, EmbedTrueTypeFonts, SaveNativePictureFormat, SaveFormsData, SaveAsAOCELetter)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

FileName Variant optional. Der Name für das Dokument. Als Standard gilt der Name des aktuellen Ordners und der aktuellen Datei. Wenn das Dokument noch nicht gespeichert wurde, wird der Standardname verwendet (z. B. "Dok1.doc"). Wenn bereits ein Dokument mit dem angegebenen FileName vorhanden ist, wird das Dokument überschrieben, wobei vorher keine Eingabeaufforderung für den Benutzer angezeigt wird.

eFileFormat Variant optional. Das Format, in dem das Dokument gespeichert wird. Kann eine der folgenden WdSaveFormat-Konstanten sein: wdFormatDocument, wdFormatDOSText, wdFormatDOSTextLineBreaks, wdFormatEncodedText, wdFormatHTML, wdFormatRTF, wdFormatTemplate, wdFormatText, wdFormatTextLineBreaks oder wdFormatUnicodeText. Um ein Dokument in einem anderen Format zu speichern, geben Sie den entsprechenden Wert für die SaveFormat-Eigenschaft des FileConverter-Objekts an.

LockComments Variant optional. True, wenn das Dokument für Kommentare gesperrt werden soll.

Password Variant optional. Eine Kennwortzeichenfolge zum Öffnen des Dokuments.

AddToRecentFiles Variant optional. True, wenn das Dokument zu der Liste der zuletzt verwendeten Dateien im Menü Datei hinzugefügt werden soll.

WritePassword Variant optional. Eine Kennwortzeichenfolge zum Speichern von Änderungen am Dokument.

ReadOnlyRecommended Variant optional. True, wenn Word beim Öffnen des Dokuments den Status "Schreibgeschützt" vorschlagen soll.

EmbedTrueTypeFonts Variant optional. True, wenn TrueType-Schriftarten mit dem Dokument gespeichert werden sollen.

SaveNativePictureFormat Variant optional. Wenn Grafiken von einer anderen Plattform (z. B. Macintosh) importiert wurden, wird mit True nur die Windows-Version der importierten Grafiken gespeichert.

SaveFormsData Variant optional. True, wenn die von einem Benutzer in ein Formular eingegebenen Daten als Datensatz gespeichert werden sollen.

SaveAsAOCELetter Variant optional. Wenn mit dem Dokument ein Adressfeld verbunden ist, wird das Dokument mit True als AOCE-Brief gespeichert (das Adressfeld wird gespeichert).


Beispiel zur SaveAs-Methode

In diesem Beispiel wird das aktive Dokument als "Text.rtf" im RTF-Format (Rich Text Format) gespeichert.

ActiveDocument.SaveAs FileName:="Text.rtf", FileFormat:=wdFormatRTF

In diesem Beispiel wird das aktive Dokument im Textdateiformat mit der Dateinamenerweiterung ".txt" gespeichert.

myDocname = ActiveDocument.Name
pos = InStr(myDocname, ".")
If pos > 0 Then
    myDocname = Left(myDocname, pos - 1)
    myDocname = myDocname & ".txt"
    ActiveDocument.SaveAs FileName:=myDocname, _
        FileFormat:=wdFormatText
End If

In diesem Beispiel wird der Wert der SaveFormat-Eigenschaft für das WordPerfect 6.x-Konvertierungsprogramm abgerufen und dieser Wert mit der SaveAs-Methode verwendet.

For Each cnv In Application.FileConverters
    If cnv.ClassName = "WrdPrfctWin" Then
        ActiveDocument.SaveAs FileName:="MyWP.doc", _
            FileFormat:=cnv.SaveFormat
    End If
Next cnv

In diesem Beispiel wird "MyDoc.doc" mit einem Schreibschutz-Kennwort gespeichert, dann wird das Dokument geschlossen.

With Documents("MyDoc.doc")
    .SaveAs WritePassword:="pass"
    .Close
End With


ScaleHeight-Methode

Vergrößert oder verkleinert die Höhe der Form maßstabgerecht um einen angegebenen Faktor. Für Grafiken und OLE-Objekte können Sie angeben, ob die Form relativ zur ursprünglichen Größe oder relativ zur aktuellen Größe vergrößert oder verkleinert werden soll. Formen, die keine Grafiken oder OLE-Objekte sind, werden immer relativ zu ihrer aktuellen Höhe vergrößert oder verkleinert.

Syntax

Ausdruck.ScaleHeight(Factor, RelativeToOriginalSize, Scale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Spezifiziert das Verhältnis zwischen der Höhe der Form nach der Größenänderung und der aktuellen oder ursprünglichen Höhe. Soll beispielsweise ein Rechteck um 50 Prozent größer gemacht werden, geben Sie für dieses Argument 1,5 an.

RelativeToOriginalSize Long erforderlich. True, wenn die Form relativ zu ihrer ursprünglichen Größe vergrößert oder verkleinert werden soll. False, wenn die Form relativ zu ihrer aktuellen Größe vergrößert oder verkleinert werden soll. Sie können für dieses Argument nur dann True angeben, wenn die angegebene Form eine Grafik oder ein OLE-Objekt ist.

Scale Long optional. Der Teil der Form, der bei der Skalierung der Form seine Position behält. Dies kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleHeight-Methode

In diesem Beispiel werden alle Grafiken und OLE-Objekte in myDocument auf 175 Prozent ihrer ursprünglichen Höhe und Breite vergrößert und alle anderen Formen auf 175 Prozent ihrer aktuellen Höhe und Breite.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    Select Case s.Type
        Case msoEmbeddedOLEObject, msoLinkedOLEObject, _
                msoOLEControlObject, _
                msoLinkedPicture, msoPicture
            s.ScaleHeight 1.75, True
            s.ScaleWidth 1.75, True
        Case Else
            s.ScaleHeight 1.75, False
            s.ScaleWidth 1.75, False
    End Select
Next


ScaleWidth-Methode

Vergrößert oder verkleinert die Breite der Form maßstabgerecht um einen angegebenen Faktor. Für Grafiken und OLE-Objekte können Sie angeben, ob die Form relativ zu ihrer ursprünglichen Größe oder relativ zur aktuellen Größe vergrößert oder verkleinert werden soll. Formen, die keine Grafiken oder OLE-Objekte sind, werden immer relativ zu ihrer aktuellen Breite vergrößert oder verkleinert.

Syntax

Ausdruck.ScaleWidth(Factor, RelativeToOriginalSize, Scale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Spezifiziert das Verhältnis zwischen der Breite der Form nach der Größenänderung und der aktuellen oder ursprünglichen Breite. Soll beispielsweise ein Rechteck um 50 Prozent größer gemacht werden, geben Sie für dieses Argument 1,5 an.

RelativeToOriginalSize Long erforderlich. True, wenn die Form relativ zu ihrer ursprünglichen Größe vergrößert oder verkleinert werden soll. False, wenn sie relativ zu ihrer aktuellen Größe vergrößert oder verkleinert werden soll. Sie können für dieses Argument nur dann True angeben, wenn die angegebene Form eine Grafik oder ein OLE-Objekt ist.

Scale Long optional. Der Teil der Form, der bei der Skalierung der Form seine Position behält. Dies kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight, msoScaleFromMiddle oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleWidth-Methode

In diesem Beispiel werden alle Grafiken und OLE-Objekte in myDocument auf 175 Prozent ihrer ursprünglichen Höhe und Breite vergrößert und alle anderen Formen auf 175 Prozent ihrer aktuellen Höhe und Breite.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    Select Case s.Type
        Case msoEmbeddedOLEObject, msoLinkedOLEObject, _
                msoOLEControlObject, _
                msoLinkedPicture, msoPicture
            s.ScaleHeight 1.75, True
            s.ScaleWidth 1.75, True
        Case Else
            s.ScaleHeight 1.75, False
            s.ScaleWidth 1.75, False
    End Select
Next


ScreenRefresh-Methode

Aktualisiert die Anzeige auf dem Monitor mit den aktuellen Informationen im Videopufferspeicher. Mit dieser Methode deaktivieren Sie Bildschirmaktualisierungen nach dem Aufruf der ScreenUpdating-Eigenschaft.

Syntax

Ausdruck.ScreenRefresh

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Hinweise

ScreenRefresh aktiviert die Bildschirmaktualisierung für genau eine Instruktion und deaktiviert sie dann sofort wieder. Nachfolgende Instruktionen aktualisieren den Bildschirm solange nicht mehr, bis die Bildschirmaktualisierung mit der ScreenUpdating-Eigenschaft wieder aktiviert wird.


Beispiel zur ScreenRefresh-Methode

In diesem Beispiel wird die Bildschirmaktualisierung deaktiviert, Test.doc geöffnet, Text eingefügt, der Bildschirm aktualisiert und dann das Dokument geschlossen (und die Änderungen gespeichert).

ScreenUpdating = False
Documents.Open FileName:="C:\DOCS\TEST.DOC"
Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myRange.InsertBefore "new"
Application.ScreenRefresh
ActiveDocument.Close SaveChanges:=wdSaveChanges
ScreenUpdating = True


ScrollIntoView-Methode

Führt einen Bildlauf durch das Dokument durch, bis der angegebene Bereich bzw. die Form im Dokumentfenster angezeigt wird.

Syntax

Ausdruck.ScrollIntoView(Obj, Start)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.

Obj Objekt erforderlich. Ein Range- oder Shape-Objekt.

Start Boolean optional. True, wenn die obere linke Ecke des Bereichs bzw. der Form in der oberen linken Ecke des Dokumentfensters angezeigt wird. False, wenn die untere rechte Ecke des Bereichs bzw. der Form in der unteren rechten Ecke des Dokumentfensters angezeigt wird. Der Standardwert ist True.

Hinweise

Wenn der Bereich bzw. die Form größer als das Dokumentfenster ist, wird im Start-Argument definiert, welcher Ausschnitt des Bereichs bzw. der Form als erstes angezeigt wird. Diese Methode kann nicht in der Gliederungsansicht verwendet werden.


Beispiel zur ScrollIntoView-Methode

In diesem Beispiel wird ein Bildlauf durch das aktive Dokument durchgeführt, so dass die aktuelle Markierung im Dokumentfenster angezeigt wird.

ActiveWindow.ScrollIntoView Selection.Range, True


Select-Methode

Wählt das angegebene Objekt aus.

Anmerkung Nach Verwendung dieser Methode können Sie die Selection-Eigenschaft verwenden, wenn ein Selection-Objekt zurückgegeben werden soll. Weitere Informationen erhalten Sie unter Arbeiten mit dem Selection-Objekt.

Syntax

Ausdruck.Select

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt der Betrifft-Liste zurückgibt.


SelectAll-Methode

Markiert alle Formen im Haupttextbereich oder in allen Kopf- und Fußzeilen des Dokuments.

Syntax

Ausdruck.SelectAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Hinweise

Mit dieser Methode werden keine InlineShape-Objekte ausgewählt.


Beispiel zur SelectAll-Methode

In diesem Beispiel werden alle Formen im aktiven Dokument markiert.

ActiveDocument.Shapes.SelectAll

In diesem Beispiel werden alle Formen in den Kopf- und Fußzeilen im aktiven Dokument markiert und jede Form mit einem Schatten versehen.

With ActiveDocument.ActiveWindow
    .View.Type = wdPrintView
    .ActivePane.View.SeekView = wdSeekCurrentPageHeader
End With
ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary) _
    .Shapes.SelectAll
Selection.ShapeRange.Shadow.Type = msoShadow10


SelectCell-Methode

Markiert die gesamte Zelle, in der sich die aktuelle Markierung befindet. Wenn Sie diese Methode verwenden möchten, muss die aktuelle Markierung in einer einzelnen Zelle enthalten sein.

Syntax

Ausdruck.SelectCell

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCell-Methode

In diesem Beispiel wird die gesamte Zelle markiert, die die aktuelle Markierung enthält.

Selection.SelectCell


SelectColumn-Methode

Wählt die Spalte mit der Einfügemarke oder alle Spalten der Auswahl. Ein Fehler tritt auf, wenn es sich bei der Auswahl nicht um eine Tabelle handelt.

Syntax

Ausdruck.SelectColumn

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectColumn-Methode

In diesem Beispiel wird die Auswahl auf ihren Endpunkt reduziert, und dann wird die Spalte mit der Einfügemarke gewählt.

Selection.Collapse Direction:=wdCollapseEnd
If Selection.Information(wdWithInTable) = True Then
    Selection.SelectColumn
End If


SelectCurrentAlignment-Methode

Erweitert die Auswahl nach vorn, bis eine andere Absatzausrichtung auftritt.

Syntax

Ausdruck.SelectCurrentAlignment

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Anmerkungen

Es gibt vier Arten der Absatzausrichtung: linksbündig, zentriert, rechtsbündig und Blocksatz.


Beispiel zur SelectCurrentAlignment-Methode

In diesem Beispiel wird die Einfügemarke an den Anfang des ersten Absatzes nach dem aktuellen Absatz, der nicht dieselbe Ausrichtung hat wie der aktuelle Absatz, verschoben. Wenn die Ausrichtung von der Auswahl bis zum Ende des Dokuments gleich ist, wird die Auswahl ans Ende des Dokuments verschoben und eine Meldung angezeigt.

Selection.SelectCurrentAlignment
Selection.Collapse Direction:=wdCollapseEnd
If Selection.End = ActiveDocument.Content.End - 1 Then
    MsgBox "No change in alignment found."
End If


SelectCurrentColor-Methode

Erweitert die Auswahl nach vorn, bis Text mit einer anderen Farbe auftritt.

Syntax

Ausdruck.SelectCurrentColor

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCurrentColor-Methode

In diesem Beispiel wird die Auswahl vom Anfang des Dokuments bis zum ersten Zeichen ausgedehnt, das mit einer anderen Farbe formatiert ist. Dann wird die Anzahl der Zeichen in der resultierenden Auswahl angezeigt.

Selection.HomeKey Unit:=wdStory, Extend:=wdMove
Selection.SelectCurrentColor
n = Len(Selection.Text)
MsgBox "Contiguous characters with the same color: " & n


SelectCurrentFont-Methode

Erweitert die Auswahl nach vorn, bis Text mit einer anderen Schriftart oder einem anderen Schriftgrad auftritt.

Syntax

Ausdruck.SelectCurrentFont

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCurrentFont-Methode

In diesem Beispiel wird die Auswahl erweitert, bis Text mit einer anderen Schriftart oder einem anderen Schriftgrad auftritt. Das Beispiel ruft dann die Grow-Methode auf, um die Größe des gewählten Textes mit dem nächsten verfügbaren Schriftgrad zu erhöhen.

With Selection
    .SelectCurrentFont
    .Font.Grow
End With


SelectCurrentIndent-Methode

Erweitert die Auswahl nach vorn, bis Text mit anderen linken oder rechten Absatzeinzügen auftritt.

Syntax

Ausdruck.SelectCurrentIndent

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCurrentIndent-Methode

Dieses Beispiel springt zum Anfang des ersten Absatzes in der Auswahl, der andere Einzüge hat als der erste Absatz im aktiven Dokument.

With Selection
    .HomeKey Unit:=wdStory, Extend:=wdMove
    .SelectCurrentIndent
    .Collapse Direction:=wdCollapseEnd
End With

In diesem Beispiel wird ermittelt, ob alle Absätze im aktiven Dokument mit denselben linken und rechten Einzügen formatiert sind. Dann wird ein Meldungsfeld mit dem Ergebnis angezeigt.

With Selection
    .HomeKey Unit:=wdStory, Extend:=wdMove
    .SelectCurrentIndent
    .Collapse Direction:=wdCollapseEnd
End With
If Selection.End = ActiveDocument.Content.End - 1 Then
    MsgBox "All paragraphs share the same left " _
        & "and right indents."
Else
    MsgBox "Not all paragraphs share the same left " _
        & "and right indents."
End If


SelectCurrentSpacing-Methode

Erweitert die Auswahl nach vorn, bis ein Absatz mit einem anderen Zeilenabstand auftritt.

Syntax

Ausdruck.SelectCurrentSpacing

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCurrentSpacing-Methode

In diesem Beispiel werden alle aufeinander folgende Absätze mit demselben Zeilenabstand gewählt und dann wird der Zeilenabstand auf einfachen Zeilenabstand geändert.

With Selection
    .SelectCurrentSpacing
    .ParagraphFormat.Space1
End With


SelectCurrentTabs-Methode

Erweitert die Auswahl nach vorn, bis ein Absatz mit anderen Tabstopps auftritt.

Syntax

Ausdruck.SelectCurrentTabs

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectCurrentTabs-Methode

In diesem Beispiel wird der zweite Absatz im aktiven Dokument gewählt. Dann wird die Auswahl erweitert, so dass sie alle Absätze mit denselben Tabstopps enthält.

Set myRange = ActiveDocument.Paragraphs(2).Range
myRange.Select
Selection.SelectCurrentTabs

Dieses Beispiel wählt Absätze mit denselben Tabstopps und lädt die Position des ersten Tabstopps. Die Auswahl wird zum nächsten Absatzbereich mit denselben Tabstopps bewegt. Dann versieht das Beispiel die aktuelle Auswahl mit den Tabstopp-Einstellungen der ersten Absatzgruppe.

With Selection
    .SelectCurrentTabs
    pos = .Paragraphs.TabStops(1).Position
    .Collapse Direction:=wdCollapseEnd
    .SelectCurrentTabs
    .Paragraphs.TabStops.Add Position:=pos
End With


SelectRow-Methode

Wählt die Zeile mit der Einfügemarke oder alle Zeilen der Auswahl. Ein Fehler tritt auf, wenn es sich bei der Auswahl nicht um eine Tabelle handelt.

Syntax

Ausdruck.SelectRow

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SelectRow-Methode

In diesem Beispiel wird die Auswahl auf ihren Startpunkt reduziert, und dann wird die Zeile mit der Einfügemarke gewählt.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Information(wdWithInTable) = True Then
    Selection.SelectRow
End If


SendFax-Methode

Application-Objekt: Startet den Fax-Assistenten.

Document-Objekt: Sendet das angegebene Dokument als Fax ohne Eingriffe des Benutzers.

Syntax 1

Ausdruck.SendFax

Syntax 2

Ausdruck.SendFax(Address, Subject)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt (Syntax 1) oder ein Document-Objekt (Syntax 2) zurückgibt.

Address String erforderlich. Die Faxnummer des Empfängers.

Subject Variant optional. Der Text für die Betreffzeile. Maximal 255 Zeichen sind erlaubt.


Beispiel zur SendFax-Methode

In diesem Beispiel wird das aktive Dokument als Fax versandt.

ActiveDocument.SendFax Address:="12065551234", _
   Subject:="Important Fax"

Das Beispiel startet den Fax-Assistenten.

Application.SendFax


SendMail-Methode

Öffnet ein Nachrichtenfenster zum Senden des angegebenen Dokuments über Microsoft Exchange.

Hinweis Mit der SendMailAttach-Eigenschaft können Sie steuern, ob das Dokument als Text im Nachrichtenfenster oder als Anlage gesendet wird.

Syntax

Ausdruck.SendMail

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur SendMail-Methode

In diesem Beispiel wird das aktive Dokument als Anlage einer Nachricht gesendet.

Options.SendMailAttach = True
ActiveDocument.SendMail


SendWindowMessage-Methode

Sendet eine Windows-Nachricht und die dazugehörigen Parameter an den angegebenen Task.

Syntax

Ausdruck.SendWindowMessage(Meldung, wParam, IParam)

Ausdruck Erforderlich. Ein Ausdruck, der ein Task-Objekt zurückgibt.

Meldung Long erforderlich. Eine hexadezimale Zahl, die der Nachricht zugeordnet ist, die Sie senden möchten. Wenn Sie über das Microsoft Platform Software Development Kit verfügen, können Sie unter dem Namen der Nachricht in den Steuersatzdateien (z. B. Winuser.h) die zugeordnete hexadezimale Zahl nachsehen (vor dem hexadezimalen Wert muss &h stehen).

wParam, lParam Long erforderlich. Entsprechende Parameter für die Nachricht, die Sie senden. Informationen über die Bedeutung dieser Werte finden Sie in der in Microsoft Platform Software Development Kit enthaltenen Dokumentation unter dem Themenverweis für diese Nachricht. Zum Aufrufen der entsprechenden Werte benötigen Sie möglicherweise das Dienstprogramm "Spy" (ist im Kit enthalten).


Beispiel zur SendWindowMessage-Methode

Wenn der Editor aktiv ist, wird in diesem Beispiel das Dialogfeld Info angezeigt (im Editor), indem eine WM_COMMAND-Nachricht an den Editor gesendet wird. Mit der SendWindowMessage-Methode wird die WM_COMMAND-Nachricht (111 ist der hexadezimale Wert für WM_COMMAND) mit den Parametern 11 und 0 gesendet. Die wParam-und lParam-Werte wurden mit dem Dienstprogramm "Spy" bestimmt.

For Each myTask In Tasks
    If InStr(myTask.Name, "Notepad") > 0 Then
        myTask.Activate
        myTask.SendWindowMessage &h111, 11, 0
    End If
Next myTask


SetAllFuzzyOptions-Methode

Sprachspezifische Informationen

Activates all nonspecific search options associated with Japanese text.

Syntax

expression.SetAllFuzzyOptions

expression Required. An expression that returns a Find object.

Remarks

This method sets the following properties to True:

MatchFuzzyAY

MatchFuzzyBV

MatchFuzzyByte

MatchFuzzyCase

MatchFuzzyDash

MatchFuzzyDZ

MatchFuzzyHF

MatchFuzzyHiragana

MatchFuzzyIterationMark

 MatchFuzzyKanji

MatchFuzzyKiKu

MatchFuzzyOldKana

MatchFuzzyProlongedSoundMark

MatchFuzzyPunctuation

MatchFuzzySmallKana

MatchFuzzySpace

MatchFuzzyTC

MatchFuzzyZJ

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur SetAllFuzzyOptions-Methode

This example activates all nonspecific options before executing a search in the selected range. If the word " baiorin baiorin baiorin baiorin baiorin " is formatted as bold, the entire paragraph is selected and copied to the Clipboard.

With Selection.Find
    .ClearFormatting
    .SetAllFuzzyOptions
    .Font.Bold = True
    .Execute FindText:="  baiorin   baiorin   baiorin   baiorin   baiorin ", Format:=True, Forward:=True
    If .Found = True Then
        .Parent.Expand Unit:=wdParagraph
        .Parent.Copy
    End If
End With


SetAsTemplateDefault-Methode

Font-Objekt: Legt die angegebene Schriftartformatierung als Standard für das aktive Dokument und alle neuen Dokumente fest, die auf der aktiven Vorlage basieren. Die Standard-Schriftartformatierung wird in der Formatvorlage Normal gespeichert.

PageSetup-Objekt: Legt die angegebene Seiteneinrichtung-Formatierung als Standard für das aktive Dokument und alle neuen Dokumente fest, die auf der aktiven Vorlage basieren.

Syntax

Ausdruck.SetAsTemplateDefault

Ausdruck Erforderlich. Ein Ausdruck, der ein Font- oder PageSetup-Objekt zurückgibt.


Beispiel zur SetAsTemplateDefault-Methode

In diesem Beispiel wird die Zeichenformatierung in der Markierung als Standard festgelegt.

Selection.Font.SetAsTemplateDefault

In diesem Beispiel werden die Einstellungen des linken und rechten Seitenrands für das aktive Dokument geändert, anschließend wird die Seiteneinrichtung-Formatierung als Standard festgelegt.

With ActiveDocument.PageSetup
    .LeftMargin = InchesToPoints(1)
    .RightMargin = InchesToPoints(1)
    .SetAsTemplateDefault
End With


SetCount-Methode

Ordnet Text in der angegebenen Anzahl von Textspalten an.

Hinweis Sie können auch die Add-Methode des TextColumns-Objekts zum Hinzufügen einer einzelnen Spalte zur TextColumns-Auflistung verwenden.

Syntax

Ausdruck.SetCount(NumColumns)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextColumns-Objekt zurückgibt.

NumColumns Long erforderlich. Die Anzahl der Spalten, in denen der Text angeordnet werden soll.


Beispiel zur SetCount-Methode

In diesem Beispiel wird der Text im aktiven Dokument in zwei gleich breiten Spalten angeordnet.

ActiveDocument.PageSetup.TextColumns.SetCount NumColumns:=2

In diesem Beispiel wird der Text im ersten Abschnitt von Brochure.doc in drei gleich breiten Spalten angeordnet.

Documents("Brochure.doc").Sections(1) _
    .PageSetup.TextColumns.SetCount NumColumns:=3


 SetDefaultTheme-Methode

SetDefaultTheme-Methode

Legt ein Standarddesign für Microsoft Word fest, das für neue Dokumente, E-Mail-Nachrichten oder Webseiten verwendet wird.

Syntax

Ausdruck.SetDefaultTheme(Name, DocumentType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Name String erforderlich. Der Name des Designs, das Sie als Standarddesign verwenden möchten, sowie gewünschte Formatierungsoptionen des Designs. Das Format dieser Zeichenfolge lautet "theme nnn", wobei theme und nnn folgendermaßen definiert sind:

Zeichenfolge | Beschreibung
theme | Der Name des Ordners, in dem die Daten des gewünschten Designs gespeichert sind. (Der Standardspeicherort für die Designdatenordner ist C:\Programme \Gemeinsame Dateien\Microsoft Shared\Themen.) Statt dem im Dialogfeld Design (Menü Format, Befehl Design) angezeigten Namen müssen Sie den Ordnernamen des Designs verwenden.
nnn | Eine dreistellige Ziffernfolge, die angibt, welche Designformatierungsoptionen aktiviert werden sollen (1 zum Aktivieren, 0 zum Deaktivieren). Die Ziffern entsprechen den Kontrollkästchen Lebendige Farben, Aktive Grafiken und Hintergrundbild im Dialogfeld Design (Menü Format, Befehl Design). Wenn diese Zeichenfolge fehlt, wird für nnn der Standardwert "011" verwendet (Aktive Grafiken und Hintergrundbild sind aktiviert).

DocumentType Long erforderlich. Der Typ des neuen Dokuments, dem Sie ein Standarddesign zuordnen möchten. Hierbei kann es sich um eine der folgenden WdDocumentMedium-Konstanten handeln: wdDocument, wdEmailMessage oder wdWebPage.

Hinweise

Wenn Sie ein Standarddesign festlegen, wird dieses nicht dem leeren Dokument zugeordnet, das automatisch beim Starten von Word erstellt wird. Allen neuen, anschließend erstellten Dokumenten wird das Standarddesign zugewiesen.

Sie können auch die ThemeName-Eigenschaft verwenden, um das Standarddesign für neue E-Mail-Nachrichten zurückzugeben und festzulegen.


Beispiel zur SetDefaultTheme-Methode

In diesem Beispiel wird festgelegt, dass Microsoft Word für alle neuen E-Mail-Nachrichten das Design Blaupause verwendet.

Application.SetDefaultTheme "blueprnt", wdEmailMessage

In diesem Beispiel wird festgelegt, dass Word für alle neuen Webseiten das Design Expedition mit (aktiviertem Kontrollkästchen) Aktive Grafiken verwendet.

Application.SetDefaultTheme "expeditn 010", wdWebPage


SetEditingType-Methode

Legt den Editing Type des Knotens fest, der durch Index spezifiziert ist. Wenn der Knoten ein Kontrollpunkt für ein gekrümmtes Segment ist, legt diese Methode den Editing Type des benachbarten Knotens fest, der zwei Segmente verbindet. Beachten Sie, dass diese Methode, in Abhängigkeit vom Editing Type, die Position von benachbarten Knoten beeinflussen könnte.

Syntax

Ausdruck.SetEditingType(Index, EditingType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Editing Type festgelegt werden soll.

EditingType Long erforderlich. Die Editing-Eigenschaft des Scheitelpunkts. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric.


Beispiel zur SetEditingType-Methode

In diesem Beispiel werden in myDocument in Form drei alle Eckknoten in geglättete Knoten umgewandelt. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


SetExtrusionDirection-Methode

Legt die Richtung fest, in der die Extrusionsausdehnung von der extrudierten Form weggerichtet ist.

Syntax

Ausdruck.SetExtrusionDirection(PresetExtrusionDirection)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetExtrusionDirection Long erforderlich. Gibt die Extrusionsrichtung an. Dies kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft oder msoExtrusionTopRight.

Hinweise

Mit dieser Methode wird die PresetExtrusionDirection-Eigenschaft auf die Richtung festgelegt, die durch das Argument PresetExtrusionDirection angegeben ist.


Beispiel zur SetExtrusionDirection-Methode

In diesem Beispiel wird spezifiziert, dass die Projektion für Form eins in myDocument sich der Obergrenze der Form zu ausdehnt, und die Beleuchtung für die Projektion von links kommt.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


SetFocus-Methode

Setzt den Fokus des angegebenen Dokumentfensters auf den Textkörper einer E-Mail-Nachricht. Wenn das Dokument keine E-Mail-Nachricht ist, hat diese Methode keine Auswirkung.

Syntax

Ausdruck.SetFocus

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.


Beispiel zur SetFocus-Methode

In diesem Beispiel wird die Kopfzeile einer E-Mail-Nachricht eingeblendet und der Fokus auf den Textkörper der Nachricht gesetzt.

ActiveWindow.EnvelopeVisible = True
ActiveWindow.SetFocus


SetHeight-Methode

Legt die Höhe von Tabellenzeilen oder Zellen fest.

Syntax

Ausdruck.SetHeight(RowHeight, HeightRule)

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-, Cells-, Row- oder Rows-Objekt zurückgibt.

RowHeight Single erforderlich. Die Höhe der Zeile oder Zeilen, in Punkt.

HeightRule Variant optional. Die Regel zum Festsetzen der Höhe der angegebenen Zellen. Dies kann eine der folgenden WdRowHeightRule-Konstanten sein: wdRowHeightAtLeast, wdRowHeightAuto oder wdRowHeightExactly. Der Standardwert ist wdRowHeightAtLeast.

Anmerkungen

Beim Festlegen der SetHeight-Eigenschaft eines Cell- oder Cells-Objekts wird automatisch die Eigenschaft für die gesamte Zeile festgelegt.


Beispiel zur SetHeight-Methode

In diesem Beispiel wird eine Tabelle erstellt und dann für die erste Zeile eine feste Zeilenhöhe von 0,5 Zoll (36 Punkt) festgelegt.

Set newDoc = Documents.Add
Set aTable = _
    newDoc.Tables.Add(Range:=Selection.Range, NumRows:=3, _
    NumColumns:=3)
aTable.Rows(1).SetHeight RowHeight:=InchesToPoints(0.5), _
    HeightRule:=wdRowHeightExactly

In diesem Beispiel wird die Zeilenhöhe der markierten Zellen auf mindestens 18 Punkt festgelegt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells.SetHeight RowHeight:=18, _
        HeightRule:=wdRowHeightAtLeast
Else
    MsgBox "The insertion point is not in a table."
End If


SetLeftIndent-Methode

Legt den Einzug für eine Zeile oder für Zeilen in einer Tabelle fest.

Syntax

Ausdruck.SetLeftIndent(LeftIndent, RulerStyle)

Ausdruck Erforderlich. Ein Ausdruck, der ein Row- oder Rows-Objekt zurückgibt.

LeftIndent Single erforderlich. Der Abstand (in Punkt) zwischen dem aktuellen linken Rand der angegebenen Zeile und dem gewünschten linken Rand.

RulerStyle Long erforderlich. Steuert die Art, wie Word die Tabelle anpasst, wenn der linke Einzug geändert wird. Dies kann eine der folgenden WdRulerStyle-Konstanten sein.

Konstante | Beschreibung
wdAdjustFirstColumn | Passt nur den linken Rand der ersten Spalte an, die Positionen der anderen Spalten und des rechten Tabellenrandes bleiben erhalten.
wdAdjustNone | Passt den linken Rand der Zeile bzw. Zeilen an, die Breite aller Spalten bleibt erhalten, da diese nach links oder rechts verschoben werden. Dies ist der Standardwert.
wdAdjustProportional | Passt den linken Rand der ersten Spalte an. Die Position des rechten Tabellenrandes bleibt erhalten, indem die Breite der Zellen in der bzw. den angegebenen Zeilen proportional angepasst wird.
wdAdjustSameWidth | Passt den linken Rand der ersten Spalte an. Die Position des rechten Tabellenrandes bleibt erhalten, indem die Breite aller Zellen in der bzw. den angegebenen Zellen auf denselben Wert gesetzt wird.

Hinweise

Die oben beschriebenen Auswirkungen von WdRulerStyle beziehen sich auf linksbündige Tabellen. Die Auswirkungen von WdRulerStyle können bei zentrierten und rechtsbündigen Tabellen zu unvorhergesehenen Ergebnissen führen. In solchen Fällen sollte die SetLeftIndent-Methode mit Vorsicht verwendet werden.


Beispiel zur SetLeftIndent-Methode

In diesem Beispiel wird in einem neuen Dokument eine Tabelle erstellt und die erste Zeile um 0,5 Zoll (36 Punkt) eingezogen. Wenn Sie den linken Einzug ändern, werden die Breiten der Zellen so angepasst, dass die rechte Kante der Tabelle erhalten bleibt.

Set aDoc = Documents.Add
Set myTable = aDoc.Tables.Add(Range:=Selection.Range, NumRows:=3, _
    NumColumns:=3)
myTable.Rows(1).SetLeftIndent LeftIndent:=InchesToPoints(0.5), _
    RulerStyle:=wdAdjustSameWidth

In diesem Beispiel wird im aktiven Dokument die erste Zeile in Tabelle eins um 18 Punkt eingezogen, und die Breite der ersten Spalte wird so schmäler gemacht, dass die Position der rechten Kante der Tabelle erhalten bleibt.

If ActiveDocument.Tables.Count >= 1 Then
    ActiveDocument.Tables(1).Rows.SetLeftIndent LeftIndent:=18, _
        RulerStyle:=wdAdjustFirstColumn
End If


SetLetterContent-Methode

Fügt den Inhalt des angegebenen LetterContent-Objekts in ein Dokument ein.

Syntax

Ausdruck.SetLetterContent(LetterContent)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

LetterContent LetterContent-Objekt erforderlich. Das LetterContent-Objekt, das die verschiedenen Elemente des Briefes enthält.

Anmerkungen

Diese Methode entspricht der RunLetterWizard-Methode mit der Ausnahme, dass das Dialogfeld Brief-Assistent nicht angezeigt wird. Auf Grundlage des Inhalts des LetterContent-Objekts verändert diese Methode Briefelemente im angegebenen Dokument, indem sie Briefelemente hinzufügt, löscht oder umformatiert.


Beispiel zur SetLetterContent-Methode

In diesem Beispiel werden die Elemente des Brief-Assistenten im aktiven Dokument geladen, der Text in der Betreffzeile wird geändert und das aktive Dokument mit der SetLetterContent-Methode aktualisiert, um die Änderungen zu reflektieren.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.AttentionLine = "Greetings"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


SetPosition-Methode

Legt den Ort des Knotens fest, der durch Index spezifiziert wurde. Beachten Sie, dass diese Methode, in Abhängigkeit vom Editing Type des Knotens, die Position benachbarter Knoten beeinflussen könnte.

Syntax

Ausdruck.SetPosition(Index, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Position festgelegt werden soll.

X1, Y1 Single erforderlich. Die Position (in Punkt) des neuen Knotens relativ zur linken, oberen Ecke des Dokuments.


Beispiel zur SetPosition-Methode

In diesem Beispiel wird Knoten zwei in Form drei in myDocument um 200 Punkt nach rechts und 300 Punkt nach unten verschoben. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(1, 1)
    currYvalue = pointsArray(1, 2)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


SetRange-Methode

Stellt die Anfangs- und Endzeichenposition für den Bereich oder die Markierung ein.

Anmerkung Zeichenpositionswerte beginnen am Anfang der Dokumentkomponente, wobei der erste Wert 0 (Null) ist. Alle Zeichen werden mitgezählt, auch nicht druckbare Zeichen. Ausgeblendete Zeichen werden mitgezählt, auch wenn sie nicht angezeigt werden.

Syntax

Ausdruck.SetRange(Start, End)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Start Long erforderlich. Die Anfangszeichenposition des Bereichs oder der Markierung.

End Long erforderlich. Die Endzeichenposition des Bereichs oder der Markierung.

Anmerkungen

Die SetRange-Methode definiert die Anfangs- und Endpositionen eines vorhandenen Selection- oder Range-Objekts neu. Diese Methode unterscheidet sich von der Range-Methode, die zum Erstellen eines Bereichs verwendet wird, wenn eine Anfangs- und Endposition gegeben ist.


Beispiel zur SetRange-Methode

In diesem Beispiel werden die ersten 10 Zeichen im Dokument markiert.

Selection.SetRange Start:=0, End:=10

In diesem Beispiel wird SetRange zum Neudefinieren von myRange verwendet, damit er sich auf die ersten drei Absätze im aktiven Dokument bezieht.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.SetRange Start:=myRange.Start, _
    End:=ActiveDocument.Paragraphs(3).Range.End

In diesem Beispiel wird SetRange zum Neudefinieren von myRange verwendet, damit er sich auf den Bereich bezieht, der am Anfang des Dokuments beginnt und am Ende der aktuellen Markierung aufhört.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myRange.InsertAfter "Hello "
myRange.SetRange Start:=myRange.Start, End:=Selection.End

In diesem Beispiel wird die Markierung bis zum Ende des Dokuments erweitert.

Selection.SetRange Start:=Selection.Start, _
    End:=ActiveDocument.Content.End


SetSegmentType-Methode

Legt den Segmenttyp des Segments fest, das dem Knoten folgt, der durch Index spezifiziert wurde. Wenn der Knoten ein Kontrollpunkt für ein gekrümmtes Segment ist, legt diese Methode den Segmenttyp für diese Kurve fest. Beachten Sie, dass dies die Gesamtzahl der Knoten beeinflussen könnte, indem benachbarte Knoten eingefügt oder gelöscht werden.

Syntax

Ausdruck.SetSegmentType(Index, SegmentType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Segmenttyp festgelegt werden soll.

SegmentType Long erforderlich. Gibt an, ob das Segment gerade oder gekrümmt ist. Dies kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.


Beispiel zur SetSegmentType-Methode

In diesem Beispiel werden in myDocument in Form drei alle geraden Segmente in gekrümmte Segmente umgewandelt. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


SetShapesDefaultProperties-Methode

Weist die Formatierung der angegebenen Form einer Standardform für das Dokument zu. Neue Formen erben viele Attribute von der Standardform.

Syntax

Ausdruck.SetShapesDefaultProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Anmerkungen

Diese Methode entspricht dem Befehl Als Vorgabe für AutoForm festlegen im Menü Zeichnen in der Zeichnen-Symbolleiste.


Beispiel zur SetShapesDefaultProperties-Methode

Dieses Beispiel fügt zu myDocument ein Rechteck hinzu, formatiert die Füllung des Rechtecks, weist die Formatierung des Rechtecks der Standardform zu, und fügt dem Dokument anschließend ein anderes (kleineres) Rechteck hinzu. Das zweite Rechteck hat die gleiche Füllung wie das erste Rechteck.

Set mydocument = ActiveDocument
With mydocument.Shapes
    With .AddShape(msoShapeRectangle, 5, 5, 80, 60)
        With .Fill
            .ForeColor.RGB = RGB(0, 0, 255)
            .BackColor.RGB = RGB(0, 204, 255)
            .Patterned msoPatternHorizontalBrick
        End With
        ' Sets formatting for default shapes
        .SetShapesDefaultProperties
    End With
    ' New shape has default formatting
    .AddShape msoShapeRectangle, 90, 90, 40, 30
End With


SetThreeDFormat-Methode

Legt das voreingestellte Extrusionsformat fest. Jedes voreingestellte Extrusionsformat enthält einen Satz von voreingestellten Werten für die verschiedenen Eigenschaften der Extrusion.

Syntax

Ausdruck.SetThreeDFormat(PresetThreeDFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetThreeDFormat Long erforderlich. Spezifiziert ein voreingestelltes Extrusionsformat, das einer der Optionen (sie sind von links nach rechts und von oben nach unten nummeriert) entspricht, die angezeigt werden, wenn Sie auf der Symbolleiste Zeichnen auf die Schaltfläche 3D klicken. Dies kann eine der folgenden MsoPresetThreeDFormat-Konstanten sein: msoThreeD1, msoThreeD2, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8, msoThreeD9, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19 oder msoThreeD20. Beachten Sie, dass ein Fehler auftritt, wenn Sie für dieses Argument PresetThreeDFormatMixed angeben.

Hinweise

Mit dieser Methode wird die PresetThreeDFormat-Eigenschaft auf das Format festgelegt, das durch das Argument PresetThreeDFormat spezifiziert wurde.


Beispiel zur SetThreeDFormat-Methode

In diesem Beispiel wird ein Oval zu myDocument hinzugefügt und dessen Projektionsformat auf den 3D-Stil "12" festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeOval, _
        30, 30, 50, 25).ThreeD
    .Visible = True
    .SetThreeDFormat msoThreeD12
End With


SetWidth-Methode

Legt die Breite von Spalten oder Zellen in einer Tabelle fest.

Syntax

Ausdruck.SetWidth(ColumnWidth, RulerStyle)

Ausdruck Erforderlich. Ein Ausdruck, der ein Cell-, Cells-, Column- oder Columns-Objekt zurückgibt.

ColumnWidth Single erforderlich. Die Breite der angegebenen Spalte oder Spalten in Punkt.

RulerStyle Long erforderlich. Steuert die Art, wie Word die Zellbreiten anpasst. Dies kann eine der folgenden WdRulerStyle-Konstanten sein.

Konstante | Beschreibung
wdAdjustFirstColumn | Legt die Breite der Zellen in der ersten Spalte nur auf den angegebenen Wert fest. Bei mehr als einer Spalte bleiben der rechte Rand der Tabelle und die Positionen der anderen Spalten erhalten.
wdAdjustNone | Legt die Breite aller ausgewählten Zellen oder Spalten auf den angegebenen Wert fest. Die Breite aller nicht ausgewählten Spalten bleibt erhalten, indem diese nach Bedarf nach rechts oder links verschoben werden. Dies ist der Standardwert.
wdAdjustProportional | Legt die Breite der Spalten in der ersten Spalte nur auf den angegebenen Wert fest. Wenn mehrere Spalten ausgewählt sind, bleiben der rechte Tabellenrand und die Positionen der nicht ausgewählten Spalten erhalten, indem die Breite der anderen ausgewählten Spalten proportional angepasst wird. Wenn nur eine Zelle oder Spalte ausgewählt wurde, bleibt der rechte Tabellenrand erhalten, indem die Breite der anderen Zellen oder Spalten proportional angepasst wird.
wdAdjustSameWidth | Legt die Breite der Zellen in der ersten Spalte nur auf den angegebenen Wert fest. Der rechte Tabellenrand bleibt erhalten, indem die Breite aller übrigen Zellen oder Spalten auf denselben Wert gesetzt wird.

Hinweise

Die oben beschriebenen Auswirkungen von WdRulerStyle beziehen sich auf linksbündige Tabellen. Die Auswirkungen von WdRulerStyle können bei zentrierten und rechtsbündigen Tabellen zu unvorhergesehenen Ergebnissen führen. In solchen Fällen sollte die SetWidth-Methode mit Vorsicht verwendet werden.


Beispiel zur SetWidth-Methode

In diesem Beispiel wird in einem neuen Dokument eine Tabelle erstellt und die Breite der ersten Zelle in der zweiten Zeile auf 1,5 Zoll festgelegt. In dem Beispiel bleiben die Breiten der anderen Zellen in der Tabelle erhalten.

Set newDoc = Documents.Add
Set myTable = _
    newDoc.Tables.Add(Range:=Selection.Range, NumRows:=3, _
    NumColumns:=3)
myTable.Cell(2,1).SetWidth _
    ColumnWidth:=InchesToPoints(1.5), _
    RulerStyle:=wdAdjustNone

In diesem Beispiel wird die Breite der Zelle, die die Einfügemarke enthält, auf 36 Punkt festgelegt. In dem Beispiel wird auch die erste Spalte so schmäler gemacht, dass die Position der rechten Kante der Tabelle erhalten bleibt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).SetWidth ColumnWidth:=36, _
        RulerStyle:=wdAdjustFirstColumn
Else
    MsgBox "The insertion point is not in a table."
End If


SetWPHelpOptions-Methode

Legt die Optionen für die WordPerfect-Hilfefunktion fest.

Syntax

Ausdruck.SetWPHelpOptions(CommandKeyHelp, DocNavigationKeys, MouseSimulation, DemoGuidance, DemoSpeed, HelpType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Options-Objekt zurückgibt.

CommandKeyHelp Variant optional. Setzen Sie dieses Argument auf True, wenn beim Drücken einer Tastenkombination für WordPerfect® für DOS Anweisungen oder eine Vorführung einer gleichwertigen Kombination für Word angezeigt werden soll. In der Statusleiste wird ein Hinweis auf die aktivierte WordPerfect-Hilfe angezeigt.

DocNavigationKeys Variant optional. Setzen Sie dieses Argument auf True, wenn die Tasten BILD-AUF, BILD-AB, POS1, ENDE und ESC dieselbe Funktion wie in WordPerfect haben sollen.

MouseSimulation Variant optional. Setzen Sie dieses Argument auf True, wenn der Mauszeiger auf die Optionen gesetzt werden soll, die von der WordPerfect-Hilfe bei Vorführungen aktiviert bzw. ausgewählt werden.

DemoGuidance Variant optional. Ist dieses Argument auf True gesetzt, so wird Hilfetext eingeblendet, wenn vom Benutzer bei Vorführungen der WordPerfect-Hilfe Eingaben erforderlich sind.

DemoSpeed Variant optional. Die Geschwindigkeit von Vorführungen der WordPerfect-Hilfe. Einer der folgenden Werte ist möglich.

Wert | Geschwindigkeit
0 (Null) | Schnell
1 | Mittel
2 | Langsam

HelpType Variant optional. Gibt an, ob in der WordPerfect-Hilfe Hilfetext angezeigt oder der WordPerfect-Befehl vorgeführt wird. Kann die Werte 0 (Null) für Hilfetext oder 1 für Vorführungen annehmen.


Beispiel zur SetWPHelpOptions-Methode

In diesem Beispiel werden die Optionen für die WordPerfect-Hilfe festgelegt.

Options.SetWPHelpOptions _
    CommandKeyHelp:=True, _
    DocNavigationKeys:=True, _
    MouseSimulation:=True, _
    DemoGuidance:=True, _
    DemoSpeed:=0, _
    HelpType:=0


Show-Methode

Zeigt Aktionen an, die im angegebenen integrierten Word-Dialogfeld gestartet wurden, und führt sie aus. Gibt ein Long zurück, das angibt, auf welche Schaltfläche zum Schließen des Dialogfelds geklickt wurde.

Rückgabewert | Beschreibung
-2 | Die Schaltfläche Schließen.
-1 | Die Schaltfläche OK.
0 (Null) | Die Schaltfläche Abbrechen.
> 0 (Null) | Eine Befehlsschaltfläche: 1 ist die erste Schaltfläche, 2 die zweite usw.

Hinweis Mit der Display-Methode können Sie ein Dialogfeld anzeigen lassen, wobei keine Aktionen ausgeführt oder Einstellungen zugewiesen werden, wenn das Dialogfeld geschlossen wird.

Syntax

Ausdruck.Show(TimeOut)

Ausdruck Erforderlich. Ein Ausdruck, der ein Dialog-Objekt zurückgibt.

TimeOut Variant optional. Die Zeitspanne, die Word vergehen lässt, bis das Dialogfeld automatisch geschlossen wird. Eine Einheit beträgt etwa 0,001 Sekunden. Durch mehrere gleichzeitige Systemaktivitäten kann sich der effektive Zeitwert erhöhen. Wird dieses Argument ausgelassen, wird das Dialogfeld geschlossen, wenn es der Benutzer verlässt.


ShowAllHeadings-Methode

Schaltet zwischen der Anzeige des gesamten Textes (Überschriften und Textkörper) und der Anzeige nur von Überschriften um.

Hinweis Diese Methode erzeugt einen Fehler, wenn die Ansicht nicht Gliederungsansicht oder Zentraldokument-Ansicht ist.

Syntax

Ausdruck.ShowAllHeadings

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.


Beispiel zur ShowAllHeadings-Methode

In diesem Beispiel wird die ShowHeading-Methode zur Anzeige aller Überschriften (ohne Textkörper) verwendet, und dann wird die Anzeige umgeschaltet, so dass der gesamte Text (Überschriften und Textkörper) in Gliederungsansicht zu sehen ist.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .ShowHeading 9
    .ShowAllHeadings
End With


ShowHeading-Methode

Zeigt alle Überschriften bis zur angegebenen Überschriftsebene an und blendet untergeordnete Überschriften und Textkörper aus.

Hinweis Diese Methode erzeugt einen Fehler, wenn die Ansicht nicht die Gliederungsansicht oder die Zentraldokument-Ansicht ist.

Syntax

Ausdruck.ShowHeading(Level)

Ausdruck Erforderlich. Ein Ausdruck, der ein View-Objekt zurückgibt.

Level Long erforderlich. Die Ebene der Gliederungsüberschrift (eine Zahl zwischen 1 und 9).


Beispiel zur ShowHeading-Methode

In diesem Beispiel wird das aktive Fenster in die Gliederungsansicht umgeschaltet und jeder Text angezeigt, der mit der Formatvorlage Überschrift 1 formatiert ist. Der Textkörper und alle anderen Arten von Überschriften sind ausgeblendet.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .ShowHeading 1
End With

In diesem Beispiel wird das Fenster für Dokument1 in die Gliederungsansicht umgeschaltet und jeder Text angezeigt, der mit den Formatvorlagen Überschrift 1, Überschrift 2 oder Überschrift 3 formatiert ist.

With Windows("Document1").View
    .Type = wdOutlineView
    .ShowHeading 3
End With


ShowMe-Methode

Zeigt den Office-Assistenten oder das Hilfefenster an, wenn weitere Informationen verfügbar sind. Wenn keine weiteren Informationen verfügbar sind, wird durch diese Methode eine Meldung erzeugt, die darauf hinweist, dass kein verbundenes Hilfethema vorhanden ist.

Syntax

Ausdruck.ShowMe()

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur ShowMe-Methode

In diesem Beispiel wird die TippAssistent-Aktion "ShowMe" ausgeführt, sofern sie verfügbar ist.

Application.ShowMe


Shrink-Methode

Font-Objekt: Ändert den Schriftgrad in den nächstkleineren Grad. Wenn sich in der Auswahl oder im Bereich mehrere Schriftgrade befinden, wird jeder Grad in den nächstkleineren geändert.

Selection-Objekt: Verkleinert die Auswahl auf die nächstkleinere Texteinheit. Die Reihenfolge ist folgende: ganzes Dokument, Abschnitt, Absatz, Satz, Wort, Einfügemarke.

Syntax

Ausdruck.Shrink

Ausdruck Erforderlich. Ein Ausdruck, der ein Font- oder Selection-Objekt zurückgibt.


Beispiel zur Shrink-Methode

In diesem Beispiel wird eine Zeile immer kleiner werdender Zs in ein neues Dokument eingefügt.

Set myRange = Documents.Add.Content
myRange.Font.Size = 45
For Count = 1 To 5
    myRange.InsertAfter "Z"
    For Count2 = 1 to 3
        myRange.Characters(Count).Font.Shrink
    Next Count2
Next Count

In diesem Beispiel wird der Schriftgrad des gewählten Textes um einen Grad verkleinert.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Shrink
Else
    MsgBox "You need to select some text."
End If


SmallScroll-Methode

Rollt ein Fenster oder einen Ausschnitt um die angegebene Anzahl von Zeilen. Diese Methode ist äquivalent zum Klicken auf die Bildlaufpfeile auf der horizontalen und der vertikalen Bildlaufleiste.

Syntax

Ausdruck.SmallScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein Pane- oder Window-Objekt zurückgibt.

Down Variant optional. Die Anzahl der Zeilen, um die das Fenster abwärts gerollt werden soll. Eine "Zeile" entspricht der gerollten Distanz beim einmaligen Klicken auf den Bildlaufpfeil abwärts auf der vertikalen Bildlaufleiste.

Up Variant optional. Die Anzahl der Zeilen, um die das Fenster aufwärts gerollt werden soll. Eine "Zeile" entspricht der gerollten Distanz beim einmaligen Klicken auf den Bildlaufpfeil aufwärts auf der vertikalen Bildlaufleiste.

ToRight Variant optional. Die Anzahl der Zeilen, um die das Fenster nach rechts gerollt werden soll. Eine "Zeile" entspricht der gerollten Distanz beim einmaligen Klicken auf den Bildlaufpfeil rechts auf der horizontalen Bildlaufleiste.

ToLeft Variant optional. Die Anzahl der Zeilen, um die das Fenster nach links gerollt werden soll. Eine "Zeile" entspricht der gerollten Distanz beim einmaligen Klicken auf den Bildlaufpfeil links auf der horizontalen Bildlaufleiste.

Anmerkungen

Wenn sowohl Down als auch Up angegeben wird, wird das Fenster um die Differenz der Argumente gerollt. Wenn beispielsweise Down gleich 3 und Up gleich 6 ist, wird das Fenster um drei Zeilen nach oben gerollt. Wenn sowohl ToLeft als auch ToRight angegeben wird, wird das Fenster entsprechend um die Differenz der Argumente gerollt.

Jedes dieser Argumente kann eine negative Zahl sein. Wenn keine Argumente angegeben werden, wird das Fenster eine Zeile abwärts gerollt.


Beispiel zur SmallScroll-Methode

In diesem Beispiel wird das aktive Fenster eine Zeile abwärts gerollt.

ActiveDocument.ActiveWindow.SmallScroll Down:=1

In diesem Beispiel wird das aktive Fenster geteilt und dann aufwärts und nach links gerollt.

With ActiveDocument.ActiveWindow
    .Split = True
    .SmallScroll Up:=5, ToLeft:=5
End With


Solid-Methode

Legt die angegebene Füllung auf eine einheitliche Farbe fest. Verwenden Sie diese Methode, wenn Sie eine Füllung mit fließender Farbe, eine Textur- oder gemusterte Füllung oder eine Hintergrundfüllung wieder in eine einfarbige Füllung umwandeln möchten.

Syntax

Ausdruck.Solid

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.


Beispiel zur Solid-Methode

In diesem Beispiel werden alle Füllungen in myDocument in einheitliche rote Füllungen umgewandelt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    With s.Fill
        .Solid
        .ForeColor.RGB = RGB(255, 0, 0)
    End With
Next


Sort-Methode

Syntax 1: Sortiert die angegebene Tabellenspalte.

Syntax 2: Sortiert die angegebene Tabelle.

Syntax 3: Sortiert die Absätze im angegebenen Bereich oder in der Markierung.

Syntax 1

Ausdruck.Sort(ExcludeHeader, SortFieldType, SortOrder, CaseSensitive, BidiSort, IgnoreThe, IgnoreKashida, IgnoreDiacritics, IgnoreHe, LanguageID)

Syntax 2

Ausdruck.Sort(ExcludeHeader, FieldNumber, SortFieldType, SortOrder, FieldNumber2, SortFieldType2, SortOrder2, FieldNumber3, SortFieldType3, SortOrder3, CaseSensitive, BidiSort, IgnoreThe,IgnoreKashida, IgnoreDiacritics,IgnoreHe, LanguageID)

Syntax 3

Ausdruck.Sort(ExcludeHeader, FieldNumber, SortFieldType, SortOrder, FieldNumber2, SortFieldType2, SortOrder2, FieldNumber3, SortFieldType3, SortOrder3, SortColumn, Separator, CaseSensitive,BidiSort, IgnoreThe, IgnoreKashida, IgnoreDiacritics, IgnoreHe, LanguageID)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Column-Objekt zurückgibt.

Syntax 2: Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt.

Syntax 3: Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

ExcludeHeader Variant optional. True, wenn die erste Zeile oder der erste Absatz von der Sortieroperation ausgeschlossen werden soll. Die Standardeinstellung lautet False.

FieldNumber, FieldNumber2, FieldNumber3 Variant optional. Die Felder, nach denen sortiert werden soll. Microsoft Word sortiert nach FieldNumber, dann nach FieldNumber2 und dann nach FieldNumber3.

SortFieldType, SortFieldType2, SortFieldType3 Variant optional. Die Sortierart für Spalten (Syntax 1) oder die jeweilige Sortierart für FieldNumber, FieldNumber2 und FieldNumber3 (Syntax 2 und Syntax 3). Kann eine der folgenden WdSortFieldType-Konstanten sein: wdSortFieldAlphanumeric, wdSortFieldDate, wdSortFieldJapanJIS, wdSortFieldKoreaKS, wdSortFieldNumeric, wdSortFieldStroke oder wdSortFieldSyllable. Der Standardwert ist wdSortFieldAlphanumeric. Einige dieser Konstanten sind abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

SortOrder, SortOrder2, SortOrder3 Variant optional. Die Sortierreihenfolge für Spalten (Syntax 1) oder die Sortierreihenfolge, die verwendet werden soll, wenn FieldNumber, FieldNumber2 und FieldNumber3 sortiert werden (Syntax 2 und Syntax 3). Kann eine der folgenden WdSortOrder-Konstanten sein: wdSortOrderAscending oder wdSortOrderDescending. Die Standardeinstellung ist wdSortAscending.

SortColumn Variant optional. True, wenn nur die Spalte sortiert werden soll, die durch das Range- oder Selection-Objekt spezifiziert wurde.

Separator Variant optional. Das Feldtrennzeichen. Kann eine der folgenden WdSortSeparator-Konstanten sein: wdSortSeparateByCommas, wdSortSeparateByDefaultTableSeparator oder wdSortSeparateByTabs. Die Standardeinstellung ist wdSortSeparateByCommas. Wenn sich der Bereich oder die Markierung in einer Tabelle befindet, wird dieses Argument ignoriert.

CaseSensitive Variant optional. True, wenn bei der Sortierung Groß- und Kleinschreibung berücksichtigt werden soll. Die Standardeinstellung ist False.

BidiSort Variant optional. True, wenn nach den Regeln der von rechts nach links geschriebenen Schriftarten sortiert werden soll. Dieses Argument ist abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

IgnoreThe Variant optional. True, wenn der arabische Buchstabe "Alef Lam" beim Sortieren von Texten ignoriert werden soll, die von rechts nach links geschrieben werden. Dieses Argument ist abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

IgnoreKashida Variant optional. True, wenn Kashidas beim Sortieren von Texten ignoriert werden sollen, die von rechts nach links geschrieben werden. Dieses Argument ist abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

IgnoreDiacritics Variant optional. True, um bidirektionale Steuerzeichen zu ignorieren, wenn Sie einen Text in einer von rechts nach links geschriebenen Sprache sortieren. Dieses Argument ist abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

IgnoreHe Variant optional. True, um den hebräischen Buchstaben "He" zu ignorieren, wenn Sie einen Text in einer von rechts nach links geschriebenen Sprache sortieren. Dieses Argument ist abhängig von der installierten bzw. ausgewählten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

LanguageID Variant optional. Gibt die Sortiersprache an. Kann eine der WdLanguageID-Konstanten sein.

Hinweise

Wenn Sie Absätze innerhalb einer Tabellenzelle sortieren möchten, beziehen Sie nur die Absätze und nicht die Zellenendemarke in die Sortierung ein. Wenn Sie die Zellenendemarke in eine Markierung oder einen Bereich einbeziehen und dann versuchen, die Absätze zu sortieren, zeigt Word eine Meldung an, dass keine gültigen Datensätze zum Sortieren gefunden wurden.


SortAscending-Methode

Sortiert Absätze oder Tabellenzeilen in aufsteigender alphanumerischer Reihenfolge. Der erste Absatz oder die erste Tabellenzeile wird als Steuerdatensatz angesehen und nicht in die Sortierung einbezogen. Verwenden Sie die Sort-Methode, wenn der Steuerdatensatz in die Sortierung einbezogen werden soll.

Anmerkung Diese Methode stellt eine vereinfachte Form der Sortierung dar, die für Seriendruck-Datenquellen vorgesehen ist, die Datenspalten enthalten. Bei den meisten Sortieraufgaben verwenden Sie die Sort-Methode.

Syntax

Ausdruck.SortAscending

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-, Selection- oder Table-Objekt zurückgibt.


Beispiel zur SortAscending-Methode

In diesem Beispiel wird die Tabelle, die die Markierung enthält, in aufsteigender Reihenfolge sortiert.

If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).SortAscending
Else
    MsgBox "The insertion point is not in a table."
End If


SortDescending-Methode

Sortiert Absätze oder Tabellenzeilen in absteigender alphanumerischer Reihenfolge. Der erste Absatz oder die erste Tabellenzeile wird als Steuerdatensatz angesehen und nicht in die Sortierung einbezogen. Verwenden Sie die Sort-Methode, wenn der Steuerdatensatz in die Sortierung einbezogen werden soll.

Hinweis Diese Methode stellt eine vereinfachte Form der Sortierung dar, die für Seriendruck-Datenquellen vorgesehen ist, die Datenspalten enthalten. Bei den meisten Sortieraufgaben verwenden Sie die Sort-Methode.

Syntax

Ausdruck.SortDescending

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-, Selection- oder Table-Objekt zurückgibt.


Beispiel zur SortDescending-Methode

In diesem Beispiel wird in einem neuen Dokument eine 5x5-Tabelle erstellt, Text in jede Zelle eingefügt und dann die Tabelle in absteigender alphanumerischer Reihenfolge sortiert.

Set newDoc = Documents.Add
Set myTable = _
    newDoc.Tables.Add(Range:=Selection.Range, NumRows:=5, _
    NumColumns:=5)
For iRow = 1 To myTable.Rows.Count
    For iCol = 1 To myTable.Columns.Count
        Set MyRange = myTable.Rows(iRow).Cells(iCol).Range
        MyRange.InsertAfter "Cell" & Str$(iRow) & "," & Str$(iCol)
    Next iCol
Next iRow
MsgBox "Click OK to sort in descending order."
myTable.SortDescending

In diesem Beispiel wird die Tabelle, die die Einfügemarke enthält, in absteigender alphanumerischer Reihenfolge sortiert.

If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).SortDescending
Else
    MsgBox "The insertion point is not in a table."
End If


Space1-Methode

Legt für die angegebenen Absätze einfachen Zeilenabstand fest. Der genaue Zeilenabstand wird durch den Schriftgrad der größten Zeichen in jedem Absatz bestimmt.

Syntax

Ausdruck.Space1

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

ActiveDocument.Paragraphs(1).Space1
ActiveDocument.Paragraphs(1).LineSpacingRule = wdLineSpaceSingle


Beispiel zur Space1-Methode

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments der Zeilenabstand in einfachen Zeilenabstand geändert.

ActiveDocument.Paragraphs(1).Space1


Space15-Methode

Formatiert die angegebenen Absätze mit eineinhalbfachem Zeilenabstand. Der genaue Zeilenabstand ist dadurch bestimmt, dass 6 Punkt zum Schriftgrad des größten Zeichens in jedem Absatz addiert werden.

Syntax

Ausdruck.Space15

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

ActiveDocument.Paragraphs(1).Space15
ActiveDocument.Paragraphs(1).LineSpacingRule = wdLineSpace1pt5


Beispiel zur Space15-Methode

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments der Zeilenabstand in eineinhalbfachen Zeilenabstand geändert.

ActiveDocument.Paragraphs(1).Space15


Space2-Methode

Legt für die angegebenen Absätze doppelten Zeilenabstand fest. Der genaue Zeilenabstand ist dadurch bestimmt, dass 12 Punkt zum Schriftgrad des größten Zeichens in jedem Absatz addiert werden.

Syntax

Ausdruck.Space2

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

ActiveDocument.Paragraphs(1).Space2
ActiveDocument.Paragraphs(1).LineSpacingRule = wdLineSpaceDouble


Beispiel zur Space2-Methode

In diesem Beispiel wird im ersten Absatz in der Markierung der Zeilenabstand in doppelten Zeilenabstand geändert.

Selection.Paragraphs(1).Space2


Split-Methode

Cell-Objekt: Teilt eine einzelne Tabellenzelle in mehrere Zellen auf.

Cells-Objekt: Teilt einen Bereich von Tabellenzellen auf.

Subdocument-Objekt: Teilt ein vorhandenes Filialdokument in der Zentraldokument- oder Gliederungsansicht in zwei Filialdokumente auf derselben Ebene auf. Die Teilung erfolgt am Anfang des angegebenen Bereichs. Wenn das aktive Dokument weder in Zentraldokument- noch in Gliederungsansicht ist, oder wenn der Bereich nicht am Anfang eines Absatzes in einem Filialdokument ist, tritt ein Fehler auf.

Table-Objekt: Fügt einen leeren Absatz unmittelbar über der angegebenen Zeile in der Tabelle ein und gibt ein Table-Objekt zurück, das die angegebene Zeile und die darauf folgenden Zeilen enthält.

Syntax 1

Ausdruck.Split(NumRows, NumColumns)

Syntax 2

Ausdruck.Split(NumRows, NumColumns, MergeBeforeSplit)

Syntax 3

Ausdruck.Split(Range)

Syntax 4

Ausdruck.Split(BeforeRow)

Ausdruck Syntax 1: Ein Ausdruck, der ein Cell-Objekt zurückgibt.

Syntax 2: Ein Ausdruck, der ein Cells-Objekt zurückgibt.

Syntax 3: Ein Ausdruck, der ein Subdocument-Objekt zurückgibt.

Syntax 4: Ein Ausdruck, der ein Table-Objekt zurückgibt.

NumColumns Variant optional. Die Anzahl der Spalten, in die die Zelle oder die Gruppe von Zellen aufgeteilt werden soll.

NumRows Variant optional. Die Anzahl der Zeilen, in die die Zelle oder die Gruppe von Zellen aufgeteilt werden soll.

MergeBeforeSplit Variant optional. True, wenn die Zellen vor der Aufteilung zusammengefasst werden sollen.

Range Range-Objekt erforderlich. Der Bereich, der zu einem separaten Filialdokument wird, wenn das Filialdokument aufgeteilt wird.

BeforeRow Variant erforderlich. Die Zeile, vor der die Tabelle aufgeteilt werden soll. Dies kann eine Zeilennummer oder ein Row-Objekt sein.


SplitTable-Methode

Fügt über der ersten Zeile in der Markierung einen leeren Absatz ein. Wenn die Markierung sich nicht in der ersten Zeile der Tabelle befindet, wird die Tabelle in zwei Tabellen geteilt.

Hinweis Wenn die Markierung sich nicht in einer Tabelle befindet, tritt ein Fehler auf.

Syntax

Ausdruck.SplitTable

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur SplitTable-Methode

Wenn die Markierung in einer Tabelle ist, wird in diesem Beispiel die Tabelle geteilt.

If Selection.Information(wdWithInTable) = True Then
    Selection.SplitTable
End If

In diesem Beispiel wird die erste Tabelle im aktiven Dokument zwischen der ersten und zweiten Zeile geteilt.

ActiveDocument.Tables(1).Rows(2).Select
Selection.SplitTable


StartOf-Methode

Verschiebt oder erweitert die Startposition des angegebenen Bereichs oder der Markierung zum Anfang der nächsten angegebenen Texteinheit. Diese Methode gibt einen Wert zurück, der die Anzahl der Zeichen anzeigt, um die der Bereich oder die Markierung verschoben oder erweitert wurde. Die Methode gibt eine negative Zahl zurück, wenn die Verschiebung rückwärts durch das Dokument erfolgt.

Syntax

Ausdruck.StartOf(Unit, Extend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Unit Variant optional. Die Einheit, um die die Startposition des angegebenen Bereichs oder der Markierung verschoben werden soll. Dies kann eine der folgenden WdUnits-Konstanten sein: wdCell, wdCharacter, wdColumn, wdParagraph, wdRow, wdSection, wdSentence, wdStory, wdTable oder wdWord. Wenn Ausdruck ein Selection-Objekt zurückgibt, können Sie auch wdLine verwenden. Der Standardwert ist wdWord.

Extend Variant optional. Dies kann eine der beiden folgenden WdMovementType-Konstanten sein: wdMove oder wdExtend. Wenn Sie wdMove verwenden, werden beide Enden des Bereichs oder der Markierung zum Anfang der angegebenen Einheit verschoben. Wenn Sie wdExtend verwenden, wird der Anfang des Bereichs oder der Markierung zum Anfang der angegebenen Einheit erweitert. Der Standardwert ist wdMove.

Anmerkungen

Wenn sich der Anfang des angegebenen Bereichs oder der Markierung bereits am Anfang der angegebenen Einheit befindet, verschiebt oder erweitert diese Methode den Bereich oder die Markierung nicht. Wenn die Markierung sich beispielsweise am Anfang einer Zeile befindet, wird im folgenden Beispiel 0 (Null) zurückgegeben und die Markierung nicht geändert.

char = Selection.StartOf(Unit:=wdLine, Extend:=wdMove)


Beispiel zur StartOf-Methode

In diesem Beispiel wird der Text von der Einfügemarke bis zum Anfang der Zeile markiert. Die Anzahl der markierten Zeichen wird in charmoved gespeichert.

Selection.Collapse Direction:=wdCollapseStart
charmoved = Selection.StartOf(Unit:=wdLine, Extend:=wdExtend)

In diesem Beispiel wird myRange zum Anfang des zweiten Satzes im Dokument verschoben (myRange wird reduziert und am Anfang des zweiten Satzes positioniert). In dem Beispiel wird die Select-Methode verwendet, damit man sieht, wo myRange liegt.

Set myRange = ActiveDocument.Sentences(2)
myRange.StartOf Unit:=wdSentence, Extend:=wdMove
myRange.Select

In diesem Beispiel wird die Markierung zum Anfang des Absatzes verschoben.

Selection.StartOf Unit:=wdParagraph, Extend:=wdMove


SubstituteFont-Methode

Legt Optionen zur Schriftartenzuweisung fest, die im Dialogfeld Schriftarten-Ersetzung dargestellt werden (Registerkarte Kompatibilität, Dialogfeld Optionen, Menü Extras).

Syntax

Ausdruck.SubstituteFont(UnavailableFont, SubstituteFont)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

UnavailableFont String erforderlich. Der Name einer Schriftart, die auf dem Computer nicht zur Verfügung steht und der Sie eine andere Schriftart zur Anzeige und zum Drucken zuweisen wollen.

SubstituteFont String erforderlich. Der Name einer Schriftart, die auf dem Computer zur Verfügung steht und die Sie als Ersatz für die nicht verfügbare Schriftart zuweisen wollen.


Beispiel zur SubstituteFont-Methode

In diesem Beispiel ersetzt Courier Myfont.

Application.SubstituteFont UnavailableFont:= "Myfont", _
    SubstituteFont:= "Courier"


SwapWithEndnotes-Methode

Konvertiert alle Fußnoten in einem Dokument in Endnoten und umgekehrt.

Anmerkung Einen Fußnoten- oder Endnotenbereich konvertieren Sie mit der Convert-Methode.

Syntax

Ausdruck.SwapWithEndnotes

Ausdruck Erforderlich. Ein Ausdruck, der ein Footnotes-Objekt zurückgibt


Beispiel zur SwapWithEndnotes-Methode

In diesem Beispiel werden die Fußnoten im aktiven Dokument in Endnoten konvertiert und die Endnoten in Fußnoten.

ActiveDocument.Footnotes.SwapWithEndnotes


SwapWithFootnotes-Methode

Konvertiert alle Endnoten in einem Dokument zu Fußnoten und umgekehrt.

Anmerkung Einen Fußnoten- oder Endnotenbereich konvertieren Sie mit der Convert-Methode.

Syntax

Ausdruck.SwapWithFootnotes

Ausdruck Erforderlich. Ein Ausdruck, der ein Endnotes-Objekt zurückgibt.


Beispiel zur SwapWithFootnotes-Methode

In diesem Beispiel werden die Endnoten im aktiven Dokument in Fußnoten umgewandelt und die Fußnoten in Endnoten.

ActiveDocument.Endnotes.SwapWithFootnotes


TabHangingIndent-Methode

Legt einen hängenden Einzug auf eine angegebene Anzahl von Tabstopps fest. Kann zum Entfernen von Tabstopps von einem hängenden Einzug verwendet werden, wenn der Wert von Count eine negative Zahl ist.

Syntax

Ausdruck.TabHangingIndent(Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Count Integer erforderlich. Die Anzahl der Tabstopps, um die eingerückt werden soll (wenn positiv), oder die Anzahl der Tabstopps, die vom Einzug entfernt werden sollen (wenn negativ).


Beispiel zur TabHangingIndent-Methode

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument ein hängender Einzug auf den zweiten Tabstopp festgelegt.

ActiveDocument.Paragraphs(1).TabHangingIndent(2)

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument der hängende Einzug um einen Tabstopp zurückversetzt.

ActiveDocument.Paragraphs(1).TabHangingIndent(-1)


TabIndent-Methode

Legt den linken Einzug für die angegebenen Absätze auf eine angegebene Anzahl von Tabstopps fest. Kann auch zum Versetzen des Einzugs verwendet werden, wenn der Wert von Count eine negative Zahl ist.

Syntax

Ausdruck.TabIndent(Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraph-, Paragraphs- oder ParagraphFormat-Objekt zurückgibt.

Count Integer erforderlich. Die Anzahl der Tabstopps, um die eingerückt werden soll (wenn positiv), oder die Anzahl der Tabstopps, die vom Einzug entfernt werden sollen (wenn negativ).


Beispiel zur TabIndent-Methode

In diesem Beispiel wird der erste Absatz im aktiven Dokument zum zweiten Tabstopp eingerückt.

ActiveDocument.Paragraphs(1).TabIndent(2)

In diesem Beispiel wird im aktiven Dokument der Einzug des ersten Absatzes einen Tabstopp zurückgesetzt.

ActiveDocument.Paragraphs(1).TabIndent(-1)


TCSCConverter-Methode

Sprachspezifische Informationen

Converts the specified range from Traditional Chinese to Simplified Chinese or vice versa.

Syntax

expression.TCSCConverter(WdTCSCConverterDirection, CommonTerms, UseVariants)

expression Required. An expression that returns a Range object.

WdTCSCConverterDirection Required Long. Can be one of the following WdTCSCConverterDirection constants.

Constant | Description
wdTCSCConverterDirectionAuto | Converts in the appropriate direction based on the detected language of the specified range.
wdTCSCConverterDirectionSCTC | Converts from Simplified Chinese to Traditional Chinese.
wdTCSCConverterDirectionTCSC | Converts from Traditional Chinese to Simplified Chinese.

CommonTerms Optional Boolean. True if Microsoft Word converts common expressions intact rather than converting on a character-by-character basis.

UseVariants Optional Boolean. True if Word uses Taiwan, Hong Kong, and Macao character variants. Can only be used if translating from Simplified Chinese to Traditional Chinese.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur TCSCConverter-Methode

This example converts the current selection from Simplified Chinese to Traditional Chinese. It converts common expressions intact and uses regional character variants.

Selection.Range.TCSCConverter _
    wdTCSCConverterDirectionSCTC, True, True


TOCInFrameset-Methode

Erstellt ein Inhaltsverzeichnis aus dem angegebenen Dokument und zeigt das Verzeichnis in einem neuen Frame im linken Bereich der Framesseite an.

Syntax

Ausdruck.TOCInFrameset

Ausdruck Erforderlich. Ein Ausdruck, der ein Pane-Objekt zurückgibt.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur TOCInFrameset-Methode

In diesem Beispiel wird eine Datei mit dem Namen Proposal.doc geöffnet, auf deren Grundlage eine Framesseite erstellt wird. Im linken Bereich der Seite wird ein Frame mit einem Inhaltsverzeichnis für die Datei eingefügt.

Documents.Open "C:\My Documents\Proposal.doc"
ActiveDocument.ActiveWindow.ActivePane.NewFrameset
ActiveDocument.ActiveWindow.ActivePane.TOCInFrameset


ToggleFormsDesign-Methode

Schaltet den Formularentwurfsmodus ein oder aus. Wenn Word im Formularentwurfsmodus ist, wird die Steuerelement-Toolbox-Symbolleiste angezeigt. Sie können diese Symbolleiste zum Einfügen von ActiveX-Steuerelementen wie Befehlsschaltflächen, Bildlaufleisten und Optionsfeldern verwenden. Im Formularentwurfsmodus werden Ereignisprozeduren nicht ausgeführt, und wenn Sie auf ein eingebettetes Steuerelement klicken, erscheinen die Ziehpunkte zur Größenänderung.

Syntax

Ausdruck.ToggleFormsDesign

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur ToggleFormsDesign-Methode

In diesem Beispiel wird zum Formularentwurfsmodus umgeschaltet, wenn die Steuerelement-Toolbox-Symbolleiste momentan nicht angezeigt wird.

If CommandBars("Control Toolbox").Visible = False Then
    ActiveDocument.ToggleFormsDesign
End If


ToggleHeader-Methode

Schaltet die Anzeige der Kopfzeile in der aktiven E-Mail-Nachricht um.

Syntax

Ausdruck.ToggleHeader

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMessage-Objekt zurückgibt.


Beispiel zur ToggleHeader-Methode

In diesem Beispiel wird die Anzeige der Kopfzeile in der aktiven E-Mail-Nachricht umgeschaltet.

Application.MailMessage.ToggleHeader


ToggleKeyboard-Methode

Sprachspezifische Informationen

Switches the keyboard language setting between right-to-left and left-to-right languages.

Syntax

expression.ToggleKeyboard

expression Required. An expression that returns an Application object.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ToggleKeyboard-Methode

This example asks the user whether to switch the keyboard language setting between right-to-left and left-to-right languages.

x = MsgBox("Switch the keyboard language setting?", vbYesNo)
If x = vbYes Then Application.ToggleKeyboard


TogglePortrait-Methode

Schaltet für ein Dokument oder einen Abschnitt zwischen den Seitenausrichtungen Hochformat und Querformat um.

Syntax

Ausdruck.TogglePortrait

Ausdruck Erforderlich. Ein Ausdruck, der ein PageSetup-Objekt zurückgibt.

Anmerkungen

Wenn die angegebenen Abschnitte unterschiedliche Seitenausrichtung haben, tritt ein Fehler auf.


Beispiel zur TogglePortrait-Methode

In diesem Beispiel wird die Seitenausrichtung für das aktive Dokument geändert.

ActiveDocument.PageSetup.TogglePortrait

In diesem Beispiel wird die Seitenausrichtung für alle Abschnitte in der Markierung geändert. Wenn die anfängliche Ausrichtung aller Abschnitte nicht gleich ist, tritt ein Fehler auf.

Selection.PageSetup.TogglePortrait


ToggleShowCodes-Methode

Schaltet um zwischen der Anzeige der Feldfunktionen oder der Feldergebnisse.

Hinweis Mit der ShowCodes-Eigenschaft bestimmen Sie die Anzeige eines einzelnen Felds.

Syntax

Ausdruck.ToggleShowCodes

Ausdruck Erforderlich. Ein Ausdruck, der ein Fields-Objekt zurückgibt.


Beispiel zur ToggleShowCodes Methode

In diesem Beispiel wird die Anzeige der Felder in der Auswahl umgeschaltet (entspricht der Tastenkombination UMSCHALT+F9).

Selection.Fields.ToggleShowCodes

In diesem Beispiel wird die Anzeige der Felder im aktiven Dokument umgeschaltet (entspricht der Tastenkombination ALT+F9).

ActiveDocument.Fields.ToggleShowCodes


ToggleVerticalText-Methode

Schaltet die Textflussrichtung im angegebenen WordArt-Objekt von horizontal nach vertikal um oder umgekehrt.

Syntax

Ausdruck.ToggleVerticalText

Ausdruck Erforderlich. Ein Ausdruck, der ein TextEffectFormat-Objekt zurückgibt.

Anmerkungen

Bei Verwendung der ToggleVerticalText-Methode werden die Werte der Width- und der Height-Eigenschaft des Shape-Objekts, das das WordArt-Objekt darstellt, vertauscht. Die Left- und die Top-Eigenschaft bleiben ungeändert.

Die Flip-Methode und Rotation-Eigenschaft des Shape-Objekts und die RotatedChars-Eigenschaft und ToggleVerticalText-Methode des TextEffectFormat-Objekts beeinflussen alle die Zeichenorientierung und die Richtung des Textflusses in einem Shape-Objekt, das ein WordArt-Objekt darstellt. Möglicherweise müssen Sie durch Versuche herausfinden, wie die Wirkungen dieser Eigenschaften und Methoden kombiniert werden müssen, damit Sie das Ergebnis erhalten, das Sie haben wollen.


Beispiel zur ToggleVerticalText-Methode

In diesem Beispiel wird zu myDocument ein WordArt-Objekt hinzugefügt, das den Text "Test" enthält, und zwischen horizontalem Textfluss (der Standard für den angegebenen WordArt-Stil msoTextEffect1) und vertikalem Textfluss umgeschaltet.

Set myDocument = ActiveDocument
Set newWordArt = _
    myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, FontBold:=False, _
    FontItalic:=False, Left:=100, Top:=100)
newWordArt.TextEffect.ToggleVerticalText


TwoColorGradient-Methode

Legt die angegebene Füllung auf einen zweifarbigen Verlauf fest.

Syntax

Ausdruck.TwoColorGradient(Style, Variant)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Der Stil der fließenden Füllfarbe. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical. (Die Konstante msoGradientFromTitle wird nur in PowerPoint verwendet.)

Variant Long erforderlich. Die Variante der fließenden Füllfarbe. Dies kann ein Wert von 1 bis 4 sein, entsprechend den vier Varianten auf der Registerkarte Graduell im Dialogfeld Fülleffekte. Wenn Style msoGradientFromCenter ist, kann dieses Argument 1 oder 2 sein.


Beispiel zur TwoColorGradient-Methode

In diesem Beispiel wird zu myDocument ein Rechteck mit einer zweifarbigen fließenden Füllung hinzugefügt und die Hintergrund- und Vordergrundfarbe für die Füllung festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 40, 80).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(0, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


TypeBackspace-Methode

Löscht das Zeichen vor einer reduzierten Auswahl (einer Einfügemarke). Wenn die Auswahl nicht zu einer Einfügemarke reduziert ist, wird die Auswahl gelöscht.

Hinweis Diese Methode entspricht der Funktionalität der RÜCKTASTE.

Syntax

Ausdruck.TypeBackspace

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur TypeBackspace-Methode

In diesem Beispiel wird das Zeichen vor der Einfügemarke (der reduzierten Auswahl) gelöscht.

With Selection
    .Collapse Direction:=wdCollapseEnd
    .TypeBackspace
End With

In diesem Beispiel wird die Auswahl bis zum Ende des aktuellen Absatzes (einschließlich der Absatzmarke) erweitert. Dann wird die Auswahl gelöscht.

With Selection
    .EndOf Unit:=wdParagraph, Extend:=wdExtend
    .TypeBackspace
End With


TypeParagraph-Methode

Fügt einen neuen, leeren Absatz ein. Wenn die Auswahl nicht reduziert ist, wird sie durch den neuen Absatz ersetzt. Mit der InsertParagraphAfter- oder InsertParagraphBefore-Methode fügen Sie einen neuen Absatz ein, ohne den Inhalt der Auswahl zu löschen.

Hinweis Diese Methode entspricht der Funktionalität der EINGABETASTE.

Syntax

Ausdruck.TypeParagraph

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.


Beispiel zur TypeParagraph-Methode

Dieses Beispiel reduziert die Auswahl auf ihr Ende und fügt dann nachfolgend einen neuen Absatz ein.

With Selection
    .Collapse Direction:=wdCollapseEnd
    .TypeParagraph
End With


TypeText-Methode

Fügt den angegebenen Text ein. Wenn die ReplaceSelection-Eigenschaft True ist, wird die Auswahl durch den angegebenen Text ersetzt. Wenn ReplaceSelection den Wert False hat, wird der angegebene Text vor der Auswahl eingefügt.

Syntax

Ausdruck.TypeText(Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Selection-Objekt zurückgibt.

Text String erforderlich. Der einzufügende Text.


Beispiel zur TypeText-Methode

Wenn im Dialogfeld Optionen auf der Registerkarte Bearbeiten die Option Eingabe ersetzt Auswahl aktiviert ist, wird in diesem Beispiel die Auswahl zu einer Einfügemarke reduziert und anschließend "Hello" eingefügt. So wird verhindert, dass vorhandener Text aus dem Dokument ersetzt wird.

If Options.ReplaceSelection = True Then
    Selection.Collapse Direction:=wdCollapseStart
    Selection.TypeText Text:="Hello"
End If

In diesem Beispiel wird "Title" eingefügt, gefolgt von einem neuen Absatz.

Options.ReplaceSelection = False
With Selection
    .TypeText Text:="Title"
    .TypeParagraph
End With


Undo-Methode

Macht die letzte Aktion oder eine Folge von Aktionen rückgängig, die in der Undo-Liste angezeigt werden. Gibt True zurück, wenn die Aktionen erfolgreich rückgängig gemacht wurden.

Syntax

Ausdruck.Undo(Times)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Times Variant optional. Die Anzahl der Aktionen, die rückgängig gemacht werden können.


UndoClear-Methode

Löscht die Liste der Aktionen, die für das angegebene Dokument rückgängig gemacht werden können. Entspricht der Liste der Elemente, die erscheint, wenn Sie auf der Standard-Symbolleiste auf den Pfeil neben der Schaltfläche Rückgängig klicken.

Hinweis Nehmen Sie diese Methode in ein Makro am Ende auf, damit keine Visual Basic-Aktionen im Dialogfeld Rückgängig (beispielsweise "VBA-Selection.InsertAfter") erscheinen.

Syntax

Ausdruck.UndoClear

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur UndoClear-Methode

In diesem Beispiel wird die Liste der Aktionen gelöscht, die für das aktive Dokument rückgängig gemacht werden können.

ActiveDocument.UndoClear


Ungroup-Methode

Hebt die Gruppierung von gruppierten Formen in der angegebenen Form oder dem Bereich von Formen auf. Zerlegt Grafiken und OLE-Objekte innerhalb der angegebenen Form oder des Bereichs von Formen. Gibt die Formen mit der aufgehobenen Gruppierung als einzelnes ShapeRange-Objekt zurück.

Syntax

Ausdruck.Ungroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Da eine Gruppe von Formen als ein einzelnes Objekt behandelt wird, ändern die Gruppierung und Aufhebung der Gruppierung von Formen die Anzahl der Elemente in der Shapes-Auflistung und die Indexnummern von Elementen, die nach den betroffenen Elementen in der Auflistung stehen.


Beispiel zur Ungroup-Methode

In diesem Beispiel wird in myDocument die Gruppierung von gruppierten Formen aufgehoben, und Grafiken oder OLE-Objekte werden zerlegt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    s.Ungroup
Next

In diesem Beispiel wird die Gruppierung von gruppierten Formen in myDocument aufgehoben, ohne dass Grafiken oder OLE-Objekte im Dokument zerlegt werden.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    If s.Type = msoGroup Then s.Ungroup
Next


Unlink-Methode

Field-Objekt: Ersetzt den angegebenen Text durch das aktuellste Ergebnis.

Fields-Objekt: Ersetzt alle Felder in der Fields-Auflistung durch ihre aktuellsten Ergebnisse.

Syntax

Ausdruck.Unlink

Ausdruck Erforderlich. Ein Ausdruck, der ein Field- oder Fields-Objekt zurückgibt.

Hinweise

Wenn Sie die Verknüpfung zu einem Feld aufheben, wird sein aktuellstes Ergebnis in Text oder Grafik umgewandelt. Eine automatische Aktualisierung ist nicht länger möglich. Beachten Sie dabei, dass die Verknüpfungen zu einigen Feldern — z. B. XE- (Index-Eintrag-) Felder und SEQ- (Folge-) Felder — nicht aufgehoben werden kann.


Beispiel Unlink-Methode

In diesem Beispiel wird die Verknüpfung zum ersten Feld in "Sales.doc" aufgehoben.

Documents("Sales.doc").Fields(1).Unlink

In diesem Beispiel werden alle Felder im ersten Bereich des aktiven Dokuments aktualisiert und ihre Verknüpfungen aufgehoben.

With ActiveDocument.Sections(1).Range.Fields
    .Update
    .Unlink
End With


Unload-Methode

Entfernt alle geladenen Add-Ins aus dem Speicher und entfernt sie, abhängig vom Wert des RemoveFromList-Arguments, von der AddIns-Auflistung.

Syntax

Ausdruck.Unload(RemoveFromList)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

RemoveFromList Boolean erforderlich. True, um die aus dem Speicher entfernten Add-Ins aus der AddIns-Auflistung zu löschen (die Namen werden aus dem Dialogfeld Vorlagen und Add-Ins entfernt). False, um die aus dem Speicher entfernten Add-Ins in der Auflistung zu belassen.

Wenn die Autoload-Eigenschaft für ein aus dem Speicher entferntes Add-In True zurückgibt, kann Unload das Add-In nicht aus der AddIns-Auflistung entfernen, unabhängig davon, welcher Wert RemoveFromList zugewiesen wurde.

Anmerkungen

Um eine Dokumentvorlage oder WLL aus dem Speicher zu entfernen, setzen Sie die Installed-Eigenschaft des AddIn-Objekts auf False. Um eine Dokumentvorlage oder WLL aus der AddIns-Auflistung zu entfernen, wenden Sie die Delete-Methode auf das AddIn-Objekt an.


Beispiel zur Unload-Methode

In diesem Beispiel werden alle Add-Ins im Dialogfeld Vorlagen und Add-Ins entfernt. Die Namen der Add-Ins bleiben in der AddIns-Auflistung.

If AddIns.Count > 0 Then AddIns.UnLoad RemoveFromList:=False


UnProtect-Methode

Hebt den Dokumentschutz für das angegebene Dokument auf. Wenn das Dokument nicht geschützt ist, wird durch diese Methode ein Fehler generiert.

Syntax

Ausdruck.UnProtect(Password)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Password Variant optional. Die zum Schutz des Dokuments verwendete Kennwortzeichenfolge. Bei Kennwörtern wird nach Groß- und Kleinschreibung unterschieden. Wenn das Dokument mit einem Kennwort geschützt ist und das korrekte Kennwort nicht angegeben wird, fordert ein Dialogfeld den Benutzer auf, das Kennwort einzugeben.


Beispiel zur UnProtect-Methode

In diesem Beispiel wird der Schutz des aktiven Dokuments aufgehoben, wobei "Blue" als Kennwort verwendet wird. Wenn dem Dokument ein Kennwort zugeordnet ist, fordert ein Dialogfeld den Benutzer auf, das Kennwort einzugeben.

If ActiveDocument.ProtectionType <> wdNoProtection Then
    ActiveDocument.Unprotect Password:="Blue"
End If

Dieses Beispiel hebt den Schutz des aktiven Dokuments auf. Text wird eingefügt, und das Dokument ist für Überarbeitungen geschützt.

Set aDoc = ActiveDocument
If aDoc.ProtectionType <> wdNoProtection Then
    aDoc.Unprotect
    Selection.InsertBefore "department six"
    aDoc.Protect Type:=wdAllowOnlyRevisions, Password:="Blue"
End If


Update-Methode

Dialog-Objekt: Aktualisiert die Werte, die in einem integrierten Microsoft Word-Dialogfeld angezeigt werden.

Field- oder Fields-Objekt: Aktualisiert das Ergebnis des angegebenen Objekts. Wird diese Methode einem Field-Objekt zugewiesen, gibt sie True bei einer erfolgreichen Aktualisierung des Felds zurück. Wenn sie einer Fields-Auflistung zugewiesen wird, gibt sie 0 (Null) zurück, falls bei der Aktualisierung der Felder keine Fehler auftreten, oder sie gibt den Index des ersten Felds mit einem Fehler zurück.

Index-, TableOfAuthorities-, TableOfContents- oder TableOfFigures-Objekt: Aktualisiert die Einträge im angegebenen Index, Rechtsgrundlagenverzeichnis (nur für US), Abbildungsverzeichnis oder Inhaltsverzeichnis.

LinkFormat-Objekt: Aktualisiert die angegebene Verknüpfung.

Anmerkung Mit der UpdatePageNumbers-Methode aktualisieren Sie die Seitennummern von Elementen in einem Inhalts- oder Abbildungsverzeichnis.

Syntax

Ausdruck.Update

Ausdruck Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf "Betrifft".


UpdateAutoFormat-Methode

Aktualisiert die Tabelle mit den Merkmalen eines vordefinierten Tabellenformats. Wenn Sie zum Beispiel einer Tabelle ein Tabellenformat mit AutoFormat zuweisen und anschließend Zeilen und Spalten einfügen, erscheint die Tabelle möglicherweise nicht mehr vollständig im vordefinierten Format. UpdateAutoFormat stellt das Format wieder her.

Syntax

Ausdruck.UpdateAutoFormat

Ausdruck Erforderlich. Ein Ausdruck, der ein Table-Objekt zurückgibt.


Beispiel zur UpdateAutoFormat-Methode

In diesem Beispiel wird eine Tabelle erstellt und dieser ein vordefiniertes Format zugewiesen. Dann wird der Tabelle eine Zeile hinzugefügt und anschließend für die gesamte Tabelle das vordefinierte Format wiederhergestellt.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 5, 5)
With myTable
    .AutoFormat Format:=wdTableFormatColumns1
    .Rows.Add BeforeRow:=myTable.Rows(1)
End With
MsgBox "Click OK to reapply autoformatting."
myTable.UpdateAutoFormat

In diesem Beispiel wird für die Tabelle, die die Einfügemarke enthält, die vordefinierte Formatierung wiederhergestellt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).UpdateAutoFormat
Else
    MsgBox "The insertion point is not in a table."
End If


UpdateDocument-Methode

Aktualisiert den Briefumschlag im Dokument mit den aktuellen Briefumschlageinstellungen.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Briefumschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.

Syntax

Ausdruck.UpdateDocument

Ausdruck Erforderlich. Ein Ausdruck, der ein Envelope-Objekt zurückgibt.


Beispiel zur UpdateDocument-Methode

In diesem Beispiel wird der Briefumschlag zu "Report.doc" so formatiert, dass eine benutzerdefinierte Briefumschlaggröße (11,43 cm x 19,05 cm) verwendet wird.

On Error GoTo errhandler
With Documents("Report.doc").Envelope
    .DefaultHeight = InchesToPoints(4.5)
    .DefaultWidth = InchesToPoints(7.5)
    .UpdateDocument
End With
errhandler:
If Err = 5852 Then MsgBox "Report.doc doesn't include an envelope"

In diesem Beispiel wird ein Briefumschlag mit einer vordefinierten Adresse dem aktiven Dokument hinzugefügt.

addr = "Darlene Rudd" & vbCr & "1234 E. Main St." _
    & vbCr & "Our Town, WA  98004"
ret = "Patricia Reed" & vbCr & "N. 33rd St." _
    & vbCr & "Other Town, WA  98040"
ActiveDocument.Envelope.Insert Address:=addr, ReturnAddress:=ret
With ActiveDocument.Envelope
    .DefaultPrintBarCode = True
    .DefaultPrintFIMA = True
    .UpdateDocument
End With


UpdatePageNumbers-Methode

Aktualisiert die Seitenzahlen für Elemente im angegebenen Inhaltsverzeichnis oder Abbildungsverzeichnis.

Syntax

Ausdruck.UpdatePageNumbers

Ausdruck Erforderlich. Ein Ausdruck, der ein TableOfContents- oder TableOfFigures-Objekt zurückgibt.


Beispiel zur UpdatePageNumbers-Methode

In diesem Beispiel werden alle Abbildungsverzeichnisse in Sales.doc aktualisiert.

For Each figs In Documents("Sales.doc").TablesOfFigures
    figs.UpdatePageNumbers
Next figs

In diesem Beispiel wird an der Einfügemarke ein Seitenwechsel eingefügt, und dann werden für das erste Inhaltsverzeichnis im aktiven Dokument die Seitenzahlen aktualisiert.

Selection.Collapse Direction:=wdCollapseStart
Selection.InsertBreak Type:=wdPageBreak
ActiveDocument.TablesOfContents(1).UpdatePageNumbers


UpdateSource-Methode

Schreibt die Änderungen, die an den Ergebnissen eines INCLUDETEXT-Felds vorgenommen wurden, in das Quelldokument zurück.

Hinweis Das Quelldokument muss als Word-Dokument formatiert worden sein.

Syntax

Ausdruck.UpdateSource

Ausdruck Erforderlich. Ein Ausdruck, der ein Field- oder Fields-Objekt zurückgibt.


Beispiel zur UpdateSource-Methode

In diesem Beispiel werden die INCLUDETEXT-Felder im aktiven Dokument aktualisiert.

For Each aField In ActiveDocument.Fields
    If aField.Type = wdFieldIncludeText Then aField.UpdateSource
Next aField


UpdateStyles-Methode

Kopiert alle Formatvorlagen aus der zugeordneten Dokumentvorlage in das Dokument, wobei vorhandene gleichnamige Formatvorlagen überschrieben werden.

Syntax

Ausdruck.UpdateStyles

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur UpdateStyles-Methode

In diesem Beispiel werden die Formatvorlagen aus der dazugehörigen Dokumentvorlage in alle geöffneten Dokumente kopiert und diese Dokumente dann geschlossen.

For Each aDoc In Documents
    aDoc.UpdateStyles
    aDoc.Close SaveChanges:=wdSaveChanges
Next aDoc

In diesem Beispiel wird die Formatierung der Formatvorlage "Heading 1" in der Dokumentvorlage geändert, die dem aktiven Dokument zugeordnet ist. Die UpdateStyles-Methode aktualisiert die Formatvorlagen im aktiven Dokument, einschließlich der Formatvorlage "Heading 1".

Set aDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
With aDoc.Styles(wdStyleHeading1).Font
    .Name = "Arial"
    .Bold = False
End With
aDoc.Close SaveChanges:=wdSaveChanges
ActiveDocument.UpdateStyles


UpdateSummaryProperties-Methode

Aktualisiert den Schwerpunkt- und Kommentartext im Dialogfeld Eigenschaften im Menü Datei, damit der Inhalt der AutoZusammenfassung für das angegebene Dokument widergespiegelt wird.

Syntax

Ausdruck.UpdateSummaryProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur UpdateSummaryProperties-Methode

In diesem Beispiel werden im aktiven Dokument Schwerpunkte hervorgehoben, und das Datei-Info im Dialogfeld Eigenschaften im Menü Datei wird aktualisiert.

With ActiveDocument
    .AutoSummarize Length:=wd25Percent, _
        Mode:=wdSummaryModeHighlight
    .UpdateSummaryProperties
End With


UseAddressBook-Methode

Wählt das Adressbuch, das als Datenquelle bei einer Seriendruckoperation benutzt wird.

Syntax

Ausdruck.UseAddressBook(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMerge-Objekt zurückgibt.

Type String erforderlich. Das Adressbuch, das als Datenquelle für die Seriendruckoperation benutzt wird. Die Zeichenfolge entspricht der Dateinamenerweiterung des Programms, die im Register festgelegt wurde (z. B. "olk" für Outlook, "scd" für Schedule+ oder "pab" für das persönliche Adressbuch).


Beispiel zur UseAddressBook-Methode

In diesem Beispiel wird ein neues Hauptdokument angelegt, das das Persönliche Adressbuch als Datenquelle verwendet.

Set myDoc = Documents.Add
With myDoc.MailMerge
    .MainDocumentType = wdFormLetters
    .UseAddressBook Type:="pab"
End With


UseDefaultFolderSuffix-Methode

Setzt die Endung des Ordners für das angegebene Dokument auf die Standardendung bei der ausgewählten bzw. installierten Sprachunterstützung.

Syntax

Ausdruck.UseDefaultFolderSuffix

Ausdruck Erforderlich. Ein Ausdruck, der ein WebOptions-Objekt zurückgibt.

Hinweise

Microsoft Word verwendet das Ordnersuffix, wenn Sie ein Dokument als Webseite speichern, lange Dateinamen verwenden und festlegen, dass Hilfsdateien in einem separaten Ordner gespeichert werden (wenn also die UseLongFileNames- und OrganizeInFolder-Eigenschaften auf True gesetzt sind).

Das Suffix erscheint im Ordnernamen nach dem Dokumentnamen. Wenn das Dokument beispielsweise Dok1 heißt und als Sprache Deutsch eingestellt ist, lautet der Ordnername Dok1-Dateien. Die verfügbaren Ordnersuffixe sind im Thema für die FolderSuffix-Eigenschaft aufgeführt.


Beispiel zur UseDefaultFolderSuffix-Methode

In diesem Beispiel wird als Ordnersuffix für das aktive Dokument die Standardeinstellung festgelegt.

ActiveDocument.WebOptions.UseDefaultFolderSuffix


UserPicture-Methode

Füllt die angegebene Form mit einem großen Bild. Wenn Sie die Form mit kleinen Kacheln eines Bildes füllen wollen, verwenden Sie die UserTextured-Methode.

Syntax

Ausdruck.UserPicture(PictureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PictureFile String erforderlich. Der Name der Grafikdatei.


Beispiel zur UserPicture-Methode

In diesem Beispiel werden zwei Rechtecke zu myDocument hinzugefügt. Das linke Rechteck wird mit einem großen Bild der Grafik in tiles.bmp gefüllt; das rechte Rechteck wird mit vielen kleinen Kacheln der Grafik in tiles.bmp gefüllt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape(msoShapeRectangle, 0, 0, 200, 100).Fill _
        .UserPicture "c:\windows\tiles.bmp"
    .AddShape(msoShapeRectangle, 300, 0, 200, 100).Fill _
        .UserTextured "c:\windows\tiles.bmp"
End With


UserTextured-Methode

Füllt die angegebene Form mit kleinen Kacheln eines Bildes. Wenn Sie die Form mit einem großen Bild füllen wollen, verwenden Sie die UserPicture-Methode.

Syntax

Ausdruck.UserTextured(TextureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

TextureFile String erforderlich. Der Name der Grafikdatei.


Beispiel zur UserTextured-Methode

In diesem Beispiel werden zu myDocument zwei Rechtecke hinzugefügt. Das linke Rechteck wird mit einem großen Bild der Grafik in tiles.bmp gefüllt; das rechte Rechteck wird mit vielen kleinen Kacheln der Grafik in tiles.bmp gefüllt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape(msoShapeRectangle, 0, 0, 200, 100).Fill _
        .UserPicture "c:\windows\tiles.bmp"
    .AddShape(msoShapeRectangle, 300, 0, 200, 100).Fill _
        .UserTextured "c:\windows\tiles.bmp"
End With


ValidLinkTarget-Methode

Bestimmt, ob der Textpositionsrahmen der einen Form mit dem Textpositionsrahmen einer anderen Form verknüpft werden kann. Gibt True zurück, wenn es sich bei TargetTextFrame um ein gültiges Ziel handelt. Gibt False zurück, wenn TargetTextFrame bereits Text enthält oder bereits verknüpft ist, beziehungsweise wenn die Form keinen zugeordneten Text unterstützt.

Syntax

Ausdruck.ValidLinkTarget(TargetTextFrame)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextFrame-Objekt zurückgibt.

TargetTextFrame Erforderliches TextFrame-Objekt. Der Ziel-Textpositionsrahmen, mit dem der Textpositionsrahmen verknüpft werden soll, der von dem Ausdruck zurückgegeben wird.


Beispiel zur ValidLinkTarget-Methode

Dieses Beispiel prüft, ob die Textpositionsrahmen für die erste und zweite Form im aktiven Dokument mit einer anderen Form verknüpft werden kann. Wenn dies der Fall ist, werden die beiden Textpositionsrahmen verknüpft.

Set myFrame1 = ActiveDocument.Shapes(1).TextFrame
Set myFrame2 = ActiveDocument.Shapes(2).TextFrame
If myFrame1.ValidLinkTarget(myFrame2) = True Then
    myFrame1.Next = myFrame2
End If


ViewCode-Methode

Zeigt das Codefenster des gewählten ActiveX-Steuerelements im angegebenen Dokument an.

Hinweis Diese Methode steht nur außerhalb von Word zur Verfügung.

Syntax

Ausdruck.ViewCode

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


ViewPropertyBrowser-Methode

Zeigt das Eigenschaftsfenster des gewählten ActiveX-Steuerelements im angegebenen Dokument an.

Hinweis Diese Methode steht nur außerhalb von Word zur Verfügung.

Syntax

Ausdruck.ViewPropertyBrowser

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


WebPagePreview-Methode

Zeigt eine Vorschau des aktuellen Dokuments, wie es als Webseite gespeichert aussehen würde.

Syntax

Ausdruck.WebPagePreview

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.


Beispiel zur WebPagePreview-Methode

In diesem Beispiel wird das aktuelle Dokument so angezeigt, wie es als Webseite gespeichert aussehen würde.

ActiveDocument.WebPagePreview


 WholeStory-Methode

WholeStory-Methode

Erweitert einen Bereich oder eine Markierung, damit die gesamte Dokumentkomponente einbezogen wird.

Syntax

Ausdruck.WholeStory

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Anmerkungen

Die folgenden Anweisungen, in denen myRange ein gültiges Range-Objekt ist, sind in funktioneller Hinsicht äquivalent:

myRange.WholeStory
myRange.Expand Unit:=wdStory


Beispiel zur WholeStory-Methode

In diesem Beispiel wird myRange erweitert, damit die gesamte Dokumentkomponente einbezogen wird, und anschließend wird dem Bereich die Schriftart Arial zugewiesen.

Set myRange = Selection.Range
myRange.WholeStory
myRange.Font.Name = "Arial"

In diesem Beispiel wird myRange erweitert, damit die gesamte Kommentarkomponente (wdCommentsStory) einbezogen wird, und anschließend werden die Kommentare in ein neues Dokument kopiert.

If ActiveDocument.Comments.Count >= 1 Then
    Set myRange = Activedocument.Comments(1).Range
    myRange.WholeStory
    myRange.Copy
    Documents.Add.Content.Paste
End If


ZOrder-Methode

Verschiebt die angegebene Form vor oder hinter andere Formen in der Auflistung (das heißt, die Position der Form wird in z-Richtung geändert).

Syntax

Ausdruck.ZOrder(ZOrderCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

ZOrderCmd Long erforderlich. Gibt an, wohin die angegebene Form relativ zu den anderen Formen verschoben werden soll. Dies kann eine der folgenden MsoZOrderCmd-Konstanten sein: msoBringForward, msoBringInFrontOfText, msoBringToFront, msoSendBackward, msoSendBehindText oder msoSendToBack.

Anmerkungen

Verwenden Sie die ZOrderPosition-Eigenschaft zum Ermitteln der aktuellen Position einer Form in der z-Richtung.


Beispiel zur ZOrder-Methode

In diesem Beispiel wird zu myRange ein Oval hinzugefügt und dann das Oval als zweites von hinten in der z-Richtung platziert, wenn mindestens eine andere Form auf dem Dokument vorhanden ist.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


Neue Objekte

In der folgenden Tabelle sind die Objekte aufgeführt, die in Visual Basic für Microsoft Word 2000 neu aufgenommen wurden.

Objekt | Beschreibung
DefaultWebOptions | Die globalen Attribute auf Anwendungsebene, die von Microsoft Word beim Speichern eines Dokuments als Webseite und beim Öffnen einer Webseite verwendet werden.
Email | Eine E-Mail-Nachricht.
EmailAuthor | Der Autor einer E-Mail-Nachricht.
EmailOptions | Die globalen Attribute auf Anwendungsebene, die von Microsoft Word beim Erstellen, Bearbeiten und Beantworten von E-Mail-Nachrichten verwendet werden.
EmailSignature | Informationen über die E-Mail-Signaturen, die von Microsoft Word beim Erstellen, Bearbeiten und Beantworten von E-Mail-Nachrichten verwendet werden.
Frameset | Ein Frame auf einer Framesseite. Weitere Informationen zum Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.
HangulAndAlphabetException | Eine einzelne Hangul oder alphabetische AutoKorrektur-Ausnahme.
HangulAndAlphabetExceptions | Eine Auflistung von HangulAndAlphabetException-Objekten, die alle Hangul oder alphabetische AutoKorrektur-Ausnahmen enthält.
HangulHanjaConversionDictionaries | Eine Auflistung von Dictionary-Objekten, die die aktivierten benutzerdefinierten Hangul-Hanja-Umwandlungswörterbücher enthält.
HorizontalLineFormat | Die Formatinformationen für eine horizontale Linie.
OtherCorrectionsException | Eine einzelne AutoKorrektur-Ausnahme.
OtherCorrectionsExceptions | Eine Auflistung von OtherCorrectionsException-Objekten, in der die Wörter erfasst sind, die nicht automatisch von Microsoft Word korrigiert werden.
WebOptions | Die Attribute auf Dokumentebene, die von Microsoft Word beim Speichern eines Dokuments als Webseite und beim Öffnen einer Webseite verwendet werden.


AddIn-Objekt

Repräsentiert ein installiertes oder nicht installiertes Add-In. Das AddIn-Objekt ist ein Element der AddIns-Auflistung. Die AddIns-Auflistung enthält alle Add-Ins, die Word zur Verfügung stehen, unabhängig davon, ob sie zurzeit geladen sind. Die AddIns-Auflistung enthält die globalen Vorlagen oder Word Add-In-Bibliotheken (WLLs), die im Dialogfeld Vorlagen und Add-Ins (Menü Extras) angezeigt werden.

Verwendung von AddIn-Objekten

Verwenden Sie AddIns(Index) mit Index als Add-In-Name oder Indexnummer, um ein AddIn-Objekt zurückzugeben. Sie müssen den Namen genauso schreiben, wie er im Dialogfeld Vorlagen und Add-Ins erscheint (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird Letter.dot als globale Vorlage geladen.

AddIns("Letter.dot").Installed = True

Die Indexnummer gibt die Position des Add-Ins in der Liste an, die im Dialogfeld Vorlagen und Add-Ins angezeigt wird. Die folgende Anweisung zeigt den Pfad des ersten verfügbaren Add-Ins an.

If Addins.Count >= 1 Then MsgBox Addins(1).Path

In diesem Beispiel wird eine Liste der Add-Ins am Anfang des aktiven Dokuments erstellt. Die Liste enthält den Namen, Pfad und Installationsstatus der verfügbaren Add-Ins.

With ActiveDocument.Range(Start:=0, End:=0)
    .InsertAfter "Name" & vbTab & "Path" & vbTab & "Installed"
    .InsertParagraphAfter
    For Each oAddIn In AddIns
        .InsertAfter oAddIn.Name & vbTab & oAddIn.Path & vbTab _
            & oAddIn.Installed
        .InsertParagraphAfter
    Next oAddIn
    .ConvertToTable
End With

Mit der Add-Methode nehmen Sie ein Add-In in die Liste der verfügbaren Add-Ins auf und installieren es (optional) mit dem Install-Argument.

AddIns.Add FileName:="C:\Templates\Other\Letter.dot", Install:=True

Ein Add-In aus der Liste der verfügbaren Add-Ins installieren Sie mit der Installed-Eigenschaft.

AddIns("Letter.dot").Installed = True

Hinweis Mit der Compiled-Eigenschaft bestimmen Sie, ob es sich bei einem AddIn-Objekt um eine Vorlage oder eine WLL handelt.


AddIns-Objekt (Auflistung)

Eine Auflistung mit AddIn-Objekten, die alle Word zur Verfügung stehenden Add-Ins darstellt, unabhängig davon, ob diese geladen sind oder nicht. Die AddIns-Auflistung enthält die globalen Vorlagen oder Word Add-In-Bibliotheken (WLLs), die im Dialogfeld Vorlagen und Add-Ins (Menü Extras) angezeigt werden.

Verwendung der AddIns-Auflistung

Mit der AddIns-Eigenschaft geben Sie die AddIns-Auflistung zurück. In diesem Beispiel werden Name und Installationsstatus aller verfügbaren Add-Ins angezeigt.

For Each ad In AddIns
    If ad.Installed = True Then
        MsgBox ad.Name & " is installed"
    Else
        MsgBox ad.Name & " is available but not installed"
    End If
Next ad

Mit der Add-Methode nehmen Sie ein Add-In in die Liste der verfügbaren Add-Ins auf und installieren es (optional) mit dem Install-Argument.

AddIns.Add FileName:="C:\Templates\Other\Letter.dot", Install:=True

Ein Add-In aus der Liste der verfügbaren Add-Ins installieren Sie mit der Installed-Eigenschaft.

AddIns("Letter.dot").Installed = True

Verwenden Sie AddIns(Index) mit Index als Add-In-Name oder Indexnummer, um ein AddIn-Objekt zurückzugeben. Sie müssen den Namen genauso schreiben, wie er im Dialogfeld Vorlagen und Add-Ins erscheint (Großschreibung muss nicht unbedingt eingehalten werden). Ein Add-In aus der Liste der verfügbaren Add-Ins installieren Sie mit der Installed-Eigenschaft. Im folgenden Beispiel wird Letter.dot als globale Vorlage geladen.

AddIns("Letter.dot").Installed = True

Hinweis Wenn das Add-In nicht in den Benutzervorlagen, den Workgroupvorlagen oder den Startordnern abgelegt ist, müssen Sie bei der Indizierung des Add-Ins den vollen Pfad und Dateinamen angeben.

Anmerkungen

Mit der Compiled-Eigenschaft bestimmen Sie, ob es sich bei einem AddIn-Objekt um eine Vorlage oder eine WLL handelt.


Adjustments-Objekt

Enthält eine Auflistung der Korrekturwerte für das angegebene AutoShape- oder WordArt-Objekt. Jeder Korrekturwert repräsentiert eine Art, in der ein Korrektur-Ziehpunkt eingestellt werden kann. Weil einige Korrektur-Ziehpunkte auf zwei Arten eingestellt werden können, z. B. können einige Ziehpunkte horizontal und vertikal eingestellt werden, kann eine Form mehr Korrekturwerte als Korrektur-Ziehpunkte haben. Eine Form kann über bis zu acht Korrekturen verfügen.

Verwendung von Adjustments-Objekten

Verwenden Sie die Adjustments-Eigenschaft, um ein Adjustments-Objekt zurückzugeben. Verwenden Sie Adjustments(Index) mit Index als Indexnummer des Korrekturwerts, um einen einzelnen Korrekturwert zurückzugeben.

Für die verschiedenen Formen gibt es eine unterschiedliche Anzahl von Korrekturwerten. Unterschiedliche Korrekturen ändern die Geometrie einer Form auf verschiedene Art. Außerdem sind die gültigen Wertebereiche für die verschiedenen Korrekturen unterschiedlich. Beispielsweise illustriert die folgende Abbildung, wie jeder der vier Korrekturwerte einer Legende mit Pfeil nach rechts die Geometrie der Legende beeinflusst.

Legende mit Pfeil nach rechts mit unterschiedlichen Korrektur-Ziehpunkten

Anmerkung Weil alle korrigierbaren Formen über unterschiedliche Korrekturgruppen verfügen, überprüfen Sie das Verhalten der Korrekturen einer bestimmten Form am besten, indem Sie manuell eine Instanz der Form anlegen, die Korrekturen bei aktivierter Makroaufzeichnung vornehmen und anschließend den aufgezeichneten Code überprüfen.

In der folgenden Tabelle finden Sie eine Zusammenfassung der gültigen Korrekturwerte für die unterschiedlichen Korrekturtypen. Wenn Sie einen Wert außerhalb des gültigen Wertebereichs festlegen, wird in den meisten Fällen der Korrektur der nächste gültige Wert der Korrektur zugewiesen.

Typ der Korrektur | Gültige Werte
Linear (horizontal oder vertikal) | Im Allgemeinen repräsentiert der Wert 0,0 die linke obere Ecke und der Wert 1,0 die rechte untere Ecke der Form. Gültige Werte entsprechen den gültigen Korrekturen, die Sie manuell an der Form vornehmen können. Wenn Sie beispielsweise manuell einen Ziehpunkt nur halb über die Form ziehen können, ist der maximale Wert der entsprechenden Korrektur 0,5. Für Formen, z. B. Legenden, bei denen die Werte 0,0 und 1,0 die Grenzen des Rechtecks darstellen, das durch den Start- und Endpunkt der Legendenlinie definiert wird, sind negative Zahlen und Zahlen größer als 1,0 gültige Werte.
Radial | Der Korrekturwert von 1,0 entspricht der Breite der Form. Der Maximalwert lautet 0,5 bzw. mehr als die Hälfte der Form.
Winkel | Werte werden in Grad ausgedrückt. Wenn Sie einen Wert außerhalb des Wertebereichs festlegen, d. h. -180 bis 180, wird dieser Wert auf den entsprechenden Wert im Wertebereich umgerechnet.

Im folgenden Beispiel wird dem aktiven Dokument eine Legende mit Pfeil nach rechts hinzugefügt, und die Korrekturwerte für die Legende werden festgelegt. Beachten Sie, dass die Form über vier Korrekturen verfügt, obwohl sie nur drei Ziehpunkte hat. Die Korrekturen drei und vier betreffen beide den Ziehpunkt zwischen Spitze und Hals des Pfeils.

Set rac = ActiveDocument.Shapes _
    .AddShape(msoShapeRightArrowCallout, 10, 10, 250, 190)
With rac.Adjustments
    .Item(1) = 0.5    'adjusts width of text box
    .Item(2) = 0.15   'adjusts width of arrow head
    .Item(3) = 0.8    'adjusts length of arrow head
    .Item(4) = 0.4    'adjusts width of arrow neck
End With


Application-Objekt

Repräsentiert die Word-Anwendung. Das Application-Objekt enthält Eigenschaften und Methoden, die Objekte der Hauptebene zurückgeben. Zum Beispiel gibt die ActiveDocument-Eigenschaft ein Document-Objekt zurück.

Verwendung des Application-Objekts

Mit der Application-Eigenschaft geben Sie das Application-Objekt zurück. In diesem Beispiel wird der Benutzername für Word angezeigt.

MsgBox Application.UserName

Viele der Eigenschaften und Methoden, die gängigen Objekte der Benutzerschnittstelle zurückgeben, z. B. das aktive Dokument (ActiveDocument-Eigenschaft), können ohne den Application-Objektkennzeichner verwendet werden. Sie können z. B. anstelle von Application.ActiveDocument.PrintOut folgendes eingeben: ActiveDocument.PrintOut. Eigenschaften und Methoden, die ohne den Application-Objektkennzeichner benutzt werden, werden als "global" betrachtet. Um die globalen Eigenschaften und Methoden im Objektkatalog anzuzeigen, klicken Sie auf <globale> oben in der Liste im Feld Klassen.

Hinweise

Wenn Sie mit Automation (früher OLE-Automatisierung) Word aus einer anderen Anwendung heraus steuern, geben Sie mit der CreateObject- oder GetObject-Funktion ein Application-Objekt für Word zurück. Im folgenden Beispiel für Microsoft Excel werden Word (falls es nicht bereits läuft) und ein vorhandenes Dokument geöffnet.

Set wrd = GetObject(, "Word.Application")
wrd.Visible = True
wrd.Documents.Open "C:\My Documents\Temp.doc"
Set wrd = Nothing


AutoCaption-Objekt

Stellt eine Beschriftung dar, die automatisch beim Einfügen von Elementen, z. B. Tabellen, Bildern oder OLE-Objekten, in ein Dokument eingefügt werden kann. Das AutoCaption-Objekt ist ein Element der AutoCaptions-Auflistung. Die AutoCaptions-Auflistung enthält alle Beschriftungen im Dialogfeld AutoBeschriftung (Menü Einfügen, Untermenü Beschriftung).

Verwendung des AutoCaption-Objekts

Verwenden Sie AutoCaptions(Index) mit Index als dem Namen der Beschriftung oder der Indexnummer, um ein AutoCaption-Objekt zurückzugeben. Die Beschriftungsnamen entsprechen den Elementen im Dialogfeld AutoBeschriftung (Menü Einfügen, Untermenü Beschriftung). Sie müssen den Namen genauso schreiben, wie er im Dialogfeld AutoBeschriftung erscheint (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird die automatische Beschriftung von Word-Tabellen aktiviert.

AutoCaptions("Microsoft Word Table").AutoInsert = True

Die Indexnummer stellt die Position des AutoCaption-Objekts in der Liste der Elemente im Dialogfeld AutoBeschriftung dar. Im folgenden Beispiel wird der Name des ersten Elements im Dialogfeld AutoBeschriftung angezeigt.

MsgBox AutoCaptions(1).Name

AutoCaption-Objekte können nicht mit einem Programm in die AutoCaptions-Auflistung aufgenommen oder aus ihr entfernt werden.


AutoCaptions-Objekt (Auflistung)

Eine Auflistung mit AutoCaption-Objekten, die die Beschriftungen darstellen, die beim Einfügen von Elementen, z. B. Tabellen, Bilder oder OLE-Objekte, in einem Dokument automatisch hinzugefügt werden können.

Verwendung der AutoCaptions-Auflistung

Verwenden Sie die AutoCaptions-Eigenschaft, um die AutoCaptions-Auflistung zurückzugeben. Im folgenden Beispiel werden die Namen der gewählten Elemente im Dialogfeld AutoBeschriftung angezeigt.

For Each autoCap In AutoCaptions
    If autoCap.AutoInsert = True Then
        MsgBox autoCap.Name & " is configured for auto insert"
    End If
Next autoCap

Die AutoCaptions-Auflistung enthält alle Beschriftungen im Dialogfeld AutoBeschriftung (Menü Einfügen, Befehl Beschriftung). AutoCaption-Objekte können nicht mit einem Programm in die AutoCaptions-Auflistung aufgenommen oder aus ihr entfernt werden.

Verwenden Sie AutoCaptions(Index), wobei Index der Namen der Beschriftung oder die Indexnummer ist, mit der ein AutoCaption-Objekt zurückgegeben wird. Die Beschriftungsnamen entsprechen den Elementen im Dialogfeld AutoBeschriftung (Menü Einfügen, Befehl Beschriftung). Sie müssen den Namen genauso schreiben, wie er im Dialogfeld AutoBeschriftung angezeigt wird (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird der Beschriftungstext "Microsoft Word Table" angezeigt.

MsgBox AutoCaptions("Microsoft Word Table").CaptionLabel.Name

Die Indexnummer stellt die Position des AutoCaption-Objekts in der Liste der Beschriftungen im Dialogfeld AutoBeschriftung dar. Im folgenden Beispiel wird der Name des ersten gewählten Dokuments im Dialogfeld AutoBeschriftung angezeigt.

MsgBox AutoCaptions(1).Name


AutoCorrect-Objekt

Stellt die AutoKorrektur-Funktionalität in Word dar.

Verwendung des AutoCorrect-Objekts

Verwenden Sie die AutoCorrect-Eigenschaft, um ein AutoCorrect-Objekt zurückzugeben. Im folgenden Beispiel werden die Optionen der AutoKorrektur aktiviert. Außerdem wird ein AutoKorrektur-Eintrag erstellt.

With AutoCorrect
    .CorrectCapsLock = True
    .CorrectDays = True
    .Entries.Add Name:="usualy", Value:="usually"
End With

Die Entries-Eigenschaft gibt das AutoCorrectEntries-Objekt zurück, das die AutoKorrektur-Einträge im Dialogfeld AutoKorrektur (Menü Extras) darstellt.


AutoCorrectEntry-Objekt

Stellt einen einzelnen AutoKorrektur-Eintrag dar. Das AutoCorrectEntry-Objekt ist ein Element der AutoCorrectEntries-Auflistung. Die AutoCorrectEntries-Auflistung enthält die Einträge im Dialogfeld AutoKorrektur (Menü Extras).

Verwendung des AutoCorrectEntry-Objekts

Verwenden Sie Entries(Index), wobei Index der Name oder die Indexnummer des AutoKorrektur-Eintrags ist, mit dem ein AutoCorrectEntry-Objekt zurückgegeben wird. Sie müssen den Namen genauso schreiben, wie er im Dialogfeld AutoKorrektur unter Ersetzen angezeigt wird (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird der Wert des vorhandenen AutoKorrektur-Eintrags "teh" gesetzt.

AutoCorrect.Entries("teh").Value = "the"

Mit der Apply-Methode fügen Sie einen AutoKorrektur-Eintrag im festgelegten Bereich ein. Im folgenden Beispiel wird ein AutoKorrektur-Eintrag hinzugefügt, der dann anstelle der Markierung eingefügt wird.

AutoCorrect.Entries.Add Name:="hellp", Value:="hello"
AutoCorrect.Entries("hellp").Apply Range:=Selection.Range

Mit der Add- oder AddRichText-Methode nehmen Sie einen AutoKorrektur-Eintrag in die Liste der verfügbaren Einträge auf. Im folgenden Beispiel wird der unformatierte AutoKorrektur-Eintrag für die falsche Schreibweise von "their" hinzugefügt.

AutoCorrect.Entries.Add Name:="thier", Value:="their"

Im folgenden Beispiel wird ein AutoKorrektur-Eintrag mit der Bezeichnung "PMO" erzeugt, der auf Text und Formatierung der Markierung beruht.

AutoCorrect.Entries.AddRichText Name:="PMO", Range:=Selection.Range


AutoCorrectEntries-Objekt (Auflistung)

Eine Auflistung mit AutoCorrectEntry-Objekten, die alle in Word verfügbaren AutoKorrektur-Einträge darstellen. Die AutoCorrectEntries-Auflistung enthält alle Einträge im Dialogfeld AutoKorrektur (Menü Extras).

Verwendung der AutoCorrectEntries-Auflistung

Verwenden Sie die Entries-Eigenschaft, um die AutoCorrectEntries-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der AutoCorrectEntry-Objekte in der AutoCorrectEntries-Auflistung angezeigt.

MsgBox AutoCorrect.Entries.Count

Mit der Add- oder der AddRichText-Methode nehmen Sie einen AutoKorrektur-Eintrag in die Liste der verfügbaren Einträge auf. Im folgenden Beispiel wird der unformatierte AutoKorrektur-Eintrag für die falsche Schreibweise des Wortes "their" hinzugefügt.

AutoCorrect.Entries.Add Name:="thier", Value:="their"

Im folgenden Beispiel wird ein AutoKorrektur-Eintrag mit der Bezeichnung "PMO" erstellt, der auf Text und Formatierung der Markierung beruht.

AutoCorrect.Entries.AddRichText Name:="PMO", Range:=Selection.Range

Verwenden Sie Entries(Index), wobei Index der Namen oder die Indexnummer des AutoKorrektur-Eintrags ist, mit dem ein AutoCorrectEntry-Objekt zurückgegeben wird. Sie müssen den Namen genauso schreiben, wie er im Dialogfeld AutoKorrektur unter Ersetzen angezeigt wird (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird der Wert des vorhandenen AutoKorrektur-Eintrags "teh" gesetzt.

AutoCorrect.Entries("teh").Value = "the"

Im folgenden Beispiel werden Name und Wert des ersten AutoKorrektur-Eintrags angezeigt.

MsgBox "Name = " & AutoCorrect.Entries(1).Name & vbCr & _
    "Value " & AutoCorrect.Entries(1).Value


AutoTextEntry-Objekt

Stellt einen einzelnen AutoText-Eintrag dar. Das AutoTextEntry-Objekt ist ein Element der AutoTextEntries-Auflistung. Die AutoTextEntries-Auflistung enthält alle AutoText-Einträge in der angegebenen Vorlage. Die Einträge werden auf der Registerkarte AutoText im Dialogfeld AutoKorrektur (Menü Extras) aufgelistet.

Verwendung des AutoTextEntry-Objekts

Verwenden Sie AutoTextEntries(Index) mit Index als dem Namen oder der Indexnummer des AutoText-Eintrags, um ein AutoTextEntry-Objekt zurückzugeben. Sie müssen den Namen genauso schreiben, wie er auf der Registerkarte AutoText im Dialogfeld AutoKorrektur erscheint (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird der Wert des vorhandenen AutoText-Eintrags "cName" gesetzt.

NormalTemplate.AutoTextEntries("cName").Value = _
    "The Johnson Company"

Im folgenden Beispiel werden Name und Wert des ersten AutoText-Eintrags in der mit dem aktiven Dokument verbundenen Vorlage angezeigt.

Set myTemplate = ActiveDocument.AttachedTemplate
MsgBox "Name = " & myTemplate.AutoTextEntries(1).Name & vbCr _
    & "Value " & myTemplate.AutoTextEntries(1).Value

Im folgenden Beispiel wird der globale AutoText-Eintrag "TheWorld" an der Einfügemarke eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
NormalTemplate.AutoTextEntries("TheWorld").Insert _
    Where:=Selection.Range

Mit der Add-Methode nehmen Sie ein AutoTextEntry-Objekt in die AutoTextEntries-Auflistung auf. Im folgenden Beispiel wird der AutoText-Eintrag "Blue", der auf dem Text in der Auswahl basiert, der Auflistung hinzugefügt.

NormalTemplate.AutoTextEntries.Add Name:="Blue", _
    Range:=Selection.Range


AutoTextEntries-Objekt (Auflistung)

Eine Auflistung mit AutoTextEntry-Objekten, die die AutoText-Einträge in einer Vorlage darstellen. Die AutoTextEntries-Auflistung enthält alle Einträge auf der Registerkarte AutoText im Dialogfeld AutoKorrektur (Menü Extras).

Verwendung des AutoTextEntries-Objekts

Mit der AutoTextEntries-Eigenschaft geben Sie die AutoTextEntries-Auflistung zurück. Das folgende Beispiel stellt fest, ob sich das AutoTextEntry-Objekt "test" in der AutoTextEntries-Auflistung befindet.

For Each i In NormalTemplate.AutoTextEntries
    If LCase(i.Name) = "test" Then MsgBox "AutoText entry exists"
Next i

Mit der Add-Methode nehmen Sie einen AutoText-Eintrag in die AutoTextEntries-Auflistung auf. Im folgenden Beispiel wird der AutoText-Eintrag "Blue", der auf der Auswahl basiert, der Auflistung hinzugefügt.

NormalTemplate.AutoTextEntries.Add Name:="Blue", _
    Range:=Selection.Range

Verwenden Sie AutoTextEntries(Index) mit Index als dem Namen oder der Indexnummer des AutoText-Eintrags, um ein AutoTextEntry-Objekt zurückzugeben. Sie müssen den Namen genauso schreiben, wie er auf der Registerkarte AutoText im Dialogfeld AutoKorrektur erscheint (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird der Wert des vorhandenen AutoText-Eintrags "cName" gesetzt.

NormalTemplate.AutoTextEntries("cName").Value = _
    "The Johnson Company"

Im folgenden Beispiel werden Name und Wert des ersten AutoText-Eintrags in der mit dem aktiven Dokument verbundenen Vorlage angezeigt.

Set myTemplate = ActiveDocument.AttachedTemplate
MsgBox "Name = " & myTemplate.AutoTextEntries(1).Name & vbCr _
    & "Value " & myTemplate.AutoTextEntries(1).Value


Bookmark-Objekt

Repräsentiert eine einzelne Textmarke. Das Bookmark-Objekt ist ein Element der Bookmarks-Auflistung. Die Bookmarks-Auflistung enthält alle Textmarken im Dialogfeld Textmarke (Menü Einfügen).

Verwendung des Bookmark-Objekts

Verwenden Sie Bookmarks(Index) mit Index als dem Namen oder der Indexnummer der Textmarke, um ein Bookmark-Objekt zurückzugeben. Halten Sie sich genau an die Schreibweise des Textmarkennamens (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird die Textmarke "temp" im aktiven Dokument gewählt.

ActiveDocument.Bookmarks("temp").Select

Die Indexnummer repräsentiert die Position der Textmarke im Selection- oder Range-Objekt. Für das Document-Objekt repräsentiert die Indexnummer die Position der Textmarke in der alphabetischen Textmarkenliste im Dialogfeld Textmarken (klicken Sie auf Name, um die Liste der Textmarken alphabetisch zu sortieren). Im folgenden Beispiel wird der Name der zweiten Textmarke in der Bookmarks-Auflistung angezeigt.

MsgBox ActiveDocument.Bookmarks(2).Name

Mit der Add-Methode fügen Sie eine Textmarke in einen Dokumentbereich ein. Im folgenden Beispiel wird die Auswahl markiert, indem die Textmarke "temp" hinzugefügt wird.

ActiveDocument.Bookmarks.Add Name:="temp", Range:=Selection.Range

Hinweise

Weisen Sie die BookmarkID-Eigenschaft auf ein Range- oder Selection-Objekt zu, um die Indexnummer des Bookmark-Objekts in der Bookmarks-Auflistung zurückzugeben. Im folgenden Beispiel wird die Indexnummer der Textmarke "temp" im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Bookmarks("temp").Range.BookmarkID

Sie können vordefinierte Textmarken mit der Bookmarks-Eigenschaft verwenden. Im folgenden Beispiel wird die Textmarke "currpara" auf die Position gesetzt, die durch die vordefinierte Textmarke "\Para" markiert wurde.

ActiveDocument.Bookmarks("\Para").Copy "currpara"

Mit der Exists-Methode stellen Sie fest, ob eine Textmarke bereits in der Auswahl, im Bereich oder im Dokument vorhanden ist. Das folgende Beispiel stellt vor der Auswahl der Textmarke sicher, dass die Textmarke "temp" im aktiven Dokument vorhanden ist.

If ActiveDocument.Bookmarks.Exists("temp") = True Then
    ActiveDocument.Bookmarks("temp").Select
End If


Bookmarks-Objekt (Auflistung)

Eine Auflistung von Bookmark-Objekten, die die Textmarken in der angegebenen Auswahl, im Bereich oder im Dokument darstellt.

Verwendung der Bookmarks-Auflistung

Mit der Bookmarks-Eigenschaft liefern Sie die Bookmarks-Auflistung. Das folgende Beispiel stellt vor der Auswahl der Textmarke sicher, dass die Textmarke "temp" im aktiven Dokument vorhanden ist.

If ActiveDocument.Bookmarks.Exists("temp") = True Then
    ActiveDocument.Bookmarks("temp").Select
End If

Mit der Add-Methode setzen Sie eine Textmarke für einen Bereich in einem Dokument. Im folgenden Beispiel wird die Auswahl markiert, indem die Textmarke "temp" hinzugefügt wird.

ActiveDocument.Bookmarks.Add Name:="temp", Range:=Selection.Range

Verwenden Sie Bookmarks(Index) mit Index als dem Namen oder der Indexnummer der Textmarke, um ein Bookmark-Objekt zurückzugeben. Halten Sie sich genau an die Schreibweise des Textmarkennamens (Großschreibung muss nicht unbedingt eingehalten werden). Im folgenden Beispiel wird die Textmarke "temp" im aktiven Dokument gewählt.

ActiveDocument.Bookmarks("temp").Select

Die Indexnummer repräsentiert die Position der Textmarke im Selection- oder Range-Objekt. Für das Document-Objekt repräsentiert die Indexnummer die Position der Textmarke in der alphabetischen Textmarkenliste im Dialogfeld Textmarken (klicken Sie auf Name, um die Liste der Textmarken alphabetisch zu sortieren). Im folgenden Beispiel wird der Name der zweiten Textmarke in der Bookmarks-Auflistung angezeigt.

MsgBox ActiveDocument.Bookmarks(2).Name

Hinweise

Die ShowHidden-Eigenschaft beeinflusst die Anzahl der Elemente in der Bookmarks-Auflistung. Wenn ShowHidden auf True gesetzt ist, befinden sich ausgeblendete Textmarken in der Bookmarks-Auflistung.


Border-Objekt

Repräsentiert den Rahmen eines Objekts. Das Border-Objekt ist ein Element der Borders-Auflistung.

Verwendung des Border-Objekts

Verwenden Sie Borders(Index), wobei Index den Rahmen identifiziert, um ein einzelnes Border-Objekt zurückzugeben. Bei Index kann es sich um eine der folgenden WdBorderType-Konstanten handeln: wdBorderBottom, wdBorderDiagonalDown, wdBorderDiagonalUp, wdBorderHorizontal, wdBorderLeft, wdBorderRight, wdBorderTop oder wdBorderVertical. Mit der LineStyle-Eigenschaft weisen Sie eine Rahmenlinie einem Border-Objekt zu. Im folgenden Beispiel wird ein doppelter Rahmen unterhalb des ersten Absatzes im aktiven Dokument zugewiesen.

With ActiveDocument.Paragraphs(1).Borders(wdBorderBottom)
    .LineStyle = wdLineStyleDouble
    .LineWidth = wdLineWidth025pt
End With

Im folgenden Beispiel wird ein einfacher Rahmen um den ersten Buchstaben in der Auswahl gezogen.

With Selection.Characters(1)
    .Font.Size = 36
    .Borders.Enable = True
End With

Im folgenden Beispiel wird ein Schmuckrahmen um alle Seiten im ersten Abschnitt gezogen.

For Each aBorder In ActiveDocument.Sections(1).Borders
    With aBorder
        .ArtStyle = wdArtSeattle
        .ArtWidth = 20
    End With
Next aBorder

Border-Objekte können nicht zu der Borders-Auflistung hinzugefügt werden. Die Anzahl der Elemente in der Borders-Auflistung ist begrenzt und vom Objekttyp abhängig. Zum Beispiel gibt es in der Borders-Auflistung sechs Elemente für Tabellen, aber nur vier für Absätze.


Borders-Objekt (Auflistung)

Eine Auflistung von Border-Objekten, die den Rahmen eines Objekts darstellen.

Verwenden der Borders-Auflistung

Verwenden Sie die Borders-Eigenschaft, um die Borders-Auflistung zurückzugeben. Im folgenden Beispiel wird der Standardrahmen dem ersten Absatz im aktiven Dokument zugewiesen.

ActiveDocument.Paragraphs(1).Borders.Enable = True

Border-Objekte können nicht der Borders-Auflistung hinzugefügt werden. Die Anzahl der Elemente in der Borders-Auflistung ist begrenzt und je nach Objekttyp unterschiedlich. Zum Beispiel gibt es in der Borders-Auflistung für Tabellen sechs Elemente, für Absätze aber nur vier.

Verwenden Sie Borders(Index), wobei Index den Rahmen für die Rückgabe eines einzelnen Border-Objekts angibt. Bei Index kann es sich um eine der folgenden WdBorderType-Konstanten handeln: wdBorderBottom, wdBorderDiagonalDown, wdBorderDiagonalUp, wdBorderHorizontal, wdBorderLeft, wdBorderRight, wdBorderTop oder wdBorderVertical. Einige dieser Konstanten sind abhängig von der installierten bzw. ausgewählten Sprachunterstützung (zum Beispiel Deutsch) möglicherweise nicht verfügbar. Mit der LineStyle-Eigenschaft weisen Sie einem Border-Objekt eine Rahmenlinie zu. Im folgenden Beispiel wird unterhalb des ersten Absatzes im aktiven Dokument ein doppelter Rahmen zugewiesen.

With ActiveDocument.Paragraphs(1).Borders(wdBorderBottom)
    .LineStyle = wdLineStyleDouble
    .LineWidth = wdLineWidth025pt
End With

Im folgenden Beispiel wird ein einfacher Rahmen um den ersten Buchstaben in der Markierung gezogen.

With Selection.Characters(1)
    .Font.Size = 36
    .Borders.Enable = True
End With

Im folgenden Beispiel wird ein Schmuckrahmen um alle Seiten im ersten Abschnitt gezogen.

For Each aBorder In ActiveDocument.Sections(1).Borders
    With aBorder
        .ArtStyle = wdArtSeattle
        .ArtWidth = 20
    End With
Next aBorder


Browser-Objekt

Stellt ein Browsertool dar, mit dem die Einfügemarke auf Objekte im Dokument bewegt wird. Dieses Werkzeug besteht aus drei Schaltflächen oben auf der vertikalen Bildlaufleiste.

Verwendung des Browser-Objekts

Mit der Browser-Eigenschaft geben Sie das Browser-Objekt zurück. Im folgenden Beispiel wird die Einfügemarke vor das nächste Feld im aktiven Dokument bewegt.

With Application.Browser
    .Target = wdBrowseField
    .Next
End With

Im folgenden Beispiel wird die Einfügemarke zur vorherigen Tabelle bewegt und die Tabelle ausgewählt.

With Application.Browser
    .Target = wdBrowseTable
    .Previous
End With
If Selection.Information(wdWithInTable) = True Then
    Selection.Tables(1).Select
End If


CalloutFormat-Objekt

Enthält Eigenschaften und Methoden, die Legenden mit Linie betreffen.

Verwendung von CalloutFormat-Objekten

Verwenden Sie die Callout-Eigenschaft, um ein CalloutFormat-Objekt zurückzugeben. Im folgenden Beispiel werden die folgenden Attribute von Form 3 (einer Legende mit Linie) im aktiven Dokument bestimmt: Die Legende verfügt über eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt; der Winkel zwischen der Legendenlinie und der Seite des Legendentextfelds beträgt 30 Grad; um den Legendentext wird kein Rahmen gezogen; die Legendenlinie wird mit der Oberkante des Legendentextfelds verbunden, und die Legendenlinie besteht aus zwei Segmenten. Dieses Beispiel funktioniert nur, wenn es sich bei Form 3 um eine Legende handelt.

With ActiveDocument.Shapes(3).Callout
    .Accent = True
    .Angle = msoCalloutAngle30
    .Border = False
    .PresetDrop msoCalloutDropTop
    .Type = msoCalloutThree
End With


CaptionLabel-Objekt

Stellt eine einzelne Beschriftungskategorie dar. Das CaptionLabel-Objekt ist ein Element der CaptionLabels-Auflistung. Die Elemente in der CaptionLabels-Auflistung werden im Feld Etikett im Dialogfeld Beschriftung (Menü Einfügen) aufgeführt.

Verwendung des CaptionLabel-Objekts

Verwenden Sie CaptionLabels(Index) mit Index als dem Namen oder der Indexnummer der Beschriftungskategorie, um ein einzelnes CaptionLabel-Objekt zurückzugeben. Im folgenden Beispiel wird die Formatvorlage für Nummerierungen für die Beschriftungskategorie "Figure" gesetzt.

CaptionLabels("Figure").NumberStyle = _
    wdCaptionNumberStyleLowercaseLetter

Die Indexnummer repräsentiert die Position der Beschriftungskategorie in der CaptionLabels-Auflistung. Im folgenden Beispiel wird die erste Beschriftungskategorie angezeigt.

MsgBox CaptionLabels(1).Name

Mit der Add-Methode fügen Sie eine benutzerdefinierte Beschriftungskategorie hinzu. Im folgenden Beispiel wird die Beschriftungskategorie "Photo" hinzugefügt.

CaptionLabels.Add Name:="Photo"


CaptionLabels-Objekt (Auflistung)

Eine Auflistung mit CaptionLabel-Objekten, die die verfügbaren Beschriftungskategorien darstellt. Die Elemente in der CaptionLabels-Auflistung werden im Feld Etikett im Dialogfeld Beschriftung (Menü Einfügen) aufgeführt.

Verwendung der CaptionLabels-Auflistung

Mit der CaptionLabels-Eigenschaft geben Sie die CaptionLabels-Auflistung zurück. Standardmäßig enthält die CaptionLabels-Auflistung drei integrierte Beschriftungskategorien: Abbildung, Tabelle und Gleichung.

Mit der Add-Methode fügen Sie eine benutzerdefinierte Beschriftungskategorie hinzu. Im folgenden Beispiel wird die Beschriftungskategorie "Photo" hinzugefügt.

CaptionLabels.Add Name:="Photo"

Verwenden Sie CaptionLabels(Index) mit Index als dem Namen oder der Indexnummer der Beschriftungskategorie, um ein einzelnes CaptionLabel-Objekt zurückzugeben. Im folgenden Beispiel wird die Formatvorlage für die Nummerierung für die Beschriftungskategorie "Figure" gesetzt.

CaptionLabels("Figure").NumberStyle = _
    wdCaptionNumberStyleLowercaseLetter

Die Indexnummer repräsentiert die Position der Beschriftungskategorie in der CaptionLabels-Auflistung. Im folgenden Beispiel wird die erste Beschriftungskategorie angezeigt.

MsgBox CaptionLabels(1).Name


Cell-Objekt

Stellt eine einzelne Zelle einer Tabelle dar. Das Cell-Objekt ist ein Element der Cells-Auflistung. Die Cells-Auflistung stellt alle Zellen im angegebenen Objekt dar.

Verwenden des Cell-Objekts

Verwenden Sie Cell(Zeile, Spalte), wobei Zeile die Zeilennummer und Spalte die Spaltennummer darstellt, oder Cells(Index), wobei Index die Indexnummer darstellt, zur Rückgabe eines Cell-Objekts. Im folgenden Beispiel wird der zweiten Zelle der ersten Zeile eine Schattierung zugewiesen.

Set myCell = ActiveDocument.Tables(1).Cell(Row:=1, Column:=2)
myCell.Shading.Texture = wdTexture20Percent

Im folgenden Beispiel wird der ersten Zelle der ersten Spalte eine Schattierung zugewiesen.

ActiveDocument.Tables(1).Rows(1).Cells(1).Shading _
    .Texture = wdTexture20Percent

Mit der Add-Methode fügen Sie zu der Cells-Auflistung ein Cell-Objekt hinzu. Wenn Sie neue Zellen einfügen möchten, können Sie auch die InsertCells-Methode des Selection-Objekts verwenden. Im folgenden Beispiel wird vor der ersten Zelle in myTable eine neue Zelle eingefügt.

Set myTable = ActiveDocument.Tables(1)
myTable.Range.Cells.Add BeforeCell:=myTable.Cell(1, 1)

Im folgenden Beispiel wird ein Bereich (myRange), festgelegt, der sich auf die ersten zwei Zellen der ersten Tabelle bezieht. Nach der Festlegung des Bereichs werden die Zellen mit der Merge-Methode kombiniert.

Set myTable = ActiveDocument.Tables(1)
Set myRange = ActiveDocument.Range(myTable.Cell(1, 1) _
    .Range.Start, myTable.Cell(1, 2).Range.End)
myRange.Cells.Merge

Hinweise

Verwenden Sie die Rows- oder Columns-Auflistung mit der Add-Methode, um eine Zeile oder Spalte aus Zellen hinzuzufügen.

Bei einem Selection-Objekt wird mit der Information-Eigenschaft die aktuelle Zeilen- und Spaltennummer zurückgegeben. Im folgenden Beispiel wird die Breite der ersten Zelle in der Auswahl geändert und anschließend die Zeilen- und Spaltennummer der Zelle angezeigt.

If Selection.Information(wdWithInTable) = True Then
    With Selection
        .Cells(1).Width = 22
        MsgBox "Cell " & .Information(wdStartOfRangeRowNumber) _
            & "," & .Information(wdStartOfRangeColumnNumber)
    End With
End If


Cell-Objekt (Auflistung)

Eine Auflistung von Cell-Objekten in einer Tabellenspalte oder -zeile, der Auswahl oder dem Bereich einer Tabelle.

Verwendung des Cell-Objekts

Mit der Cells-Eigenschaft wird die Cells-Auflistung zurückgegeben. Im folgenden Beispiel werden die Zellen der ersten Zeile in Tabelle 1 des aktiven Dokuments auf eine Breite von 30 Punkt formatiert.

ActiveDocument.Tables(1).Rows(1).Cells.Width = 30

Im folgenden Beispiel wird die Anzahl der Zellen in der aktuellen Zeile zurückgegeben.

num = Selection.Rows(1).Cells.Count

Mit der Add-Methode fügen Sie zu der Cells-Auflistung ein Cell-Objekt hinzu. Sie können neue Zellen auch mit der InsertCells-Methode des Selection-Objekts einfügen. Im folgenden Beispiel wird vor der ersten Zelle in myTable eine Zeile eingefügt.

Set myTable = ActiveDocument.Tables(1)
myTable.Range.Cells.Add BeforeCell:=myTable.Cell(1, 1)

Verwenden Sie zur Rückgabe eines Cell-Objekts den Befehl Cell(Zeile, Spalte), wobei Zeile die Zeilennummer und Spalte die Spaltennummer darstellt, oder den Befehl Cells(Index), wobei Index die Indexnummer darstellt. Im folgenden Beispiel wird die zweite Zelle der ersten Zeile in Tabelle 1 mit einer Schattierung versehen.

Set myCell = ActiveDocument.Tables(1).Cell(Row:=1, Column:=2)
myCell.Shading.Texture = wdTexture20Percent

Im folgenden Beispiel wird die erste Zelle der ersten Zeile mit einer Schattierung versehen.

ActiveDocument.Tables(1).Rows(1).Cells(1).Shading _
    .Texture = wdTexture20Percent

Hinweise

Verwenden Sie die Add-Methode mit der Rows- oder Columns-Auflistung, um eine Zeile oder Spalte aus Zellen hinzuzufügen. Im folgenden Beispiel wird zu der ersten Tabelle des aktiven Dokuments eine Spalte hinzugefügt. Anschließend werden Zahlen in die erste Spalte eingefügt.

Set myTable = ActiveDocument.Tables(1)
Set aColumn = myTable.Columns.Add(BeforeColumn:=myTable.Columns(1))
For Each aCell In aColumn.Cells
    aCell.Range.Delete
    aCell.Range.InsertAfter num + 1
    num = num + 1
Next aCell


 Characters-Objekt (Auflistung)

Characters-Objekt (Auflistung)

Eine Auflistung von Zeichen in einer Auswahl, einem Bereich oder einem Dokument. Es gibt kein Character-Objekt; stattdessen stellt jedes Element in der Characters-Auflistung ein Range-Objekt dar, das ein Zeichen repräsentiert.

Verwendung der Characters-Auflistung

Mit der Characters-Eigenschaft liefern Sie eine Characters-Auflistung. Das folgende Beispiel zeigt an, wie viele Zeichen gewählt wurden.

MsgBox Selection.Characters.Count & " characters are selected"

Verwenden Sie Characters(Index) mit Index als der Indexnummer, um ein Range-Objekt zurückzugeben, das ein Zeichen darstellt. Die Indexnummer repräsentiert die Position eines Zeichens in der Characters-Auflistung. Im folgenden Beispiel wird der erste Buchstabe in der Auswahl auf 24 Punkt fett formatiert.

With Selection.Characters(1)
    .Bold = True
    .Font.Size = 24
End With

Hinweise

Die Count-Eigenschaft für die Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Haupt-Dokumentkomponente zurück. Mit dem Range-Objekt können Sie die Elemente in anderen Dokumentkomponenten zählen.

Für die Characters-Auflistung steht keine Add-Methode zur Verfügung. Verwenden Sie stattdessen die InsertAfter- oder InsertBefore-Methode, um Zeichen zu einem Range-Objekt hinzuzufügen. Im folgenden Beispiel wird ein neuer Absatz nach dem ersten Absatz im aktiven Dokument eingefügt.

With ActiveDocument
    .Paragraphs(1).Range.InsertParagraphAfter
    .Paragraphs(2).Range.InsertBefore "New Text"
End With


CheckBox-Objekt

Repräsentiert ein einzelnes Kontrollkästchen-Formularfeld.

Verwendung des CheckBox-Objekts

Verwenden Sie FormFields(Index) mit Index als der Indexnummer des Textmarkennamens für das Kontrollkästchen, um ein einzelnes FormField-Objekt zurückzugeben. Verwenden Sie die CheckBox-Eigenschaft mit dem FormField-Objekt, um ein CheckBox-Objekt zurückzugeben. Im folgenden Beispiel wird das Kontrollkästchen "Check1" im aktiven Dokument gewählt.

ActiveDocument.FormFields("Check1").CheckBox.Value = True

Die Indexnummer repräsentiert die Position des Formularfelds in der FormFields-Auflistung. Im folgenden Beispiel wird der Typ des ersten Formularfelds überprüft. Wenn es sich um ein Kontrollkästchen handelt, wird es gewählt.

If ActiveDocument.FormFields(1).Type = wdFieldFormCheckBox Then
    ActiveDocument.FormFields(1).CheckBox.Value = True
End If

Im folgenden Beispiel wird festgestellt, ob das Objekt ffield gültig ist, bevor die Größe des Kontrollkästchens auf 14 Punkt geändert wird.

Set ffield = ActiveDocument.FormFields(1).CheckBox
If ffield.Valid = True Then
    ffield.AutoSize = False
    ffield.Size = 14
Else
    MsgBox "First field is not a check box"
End If

Verwenden Sie die Add-Methode mit dem FormFields-Objekt, um ein Kontrollkästchen-Formularfeld hinzuzufügen. Im folgenden Beispiel wird ein Kontrollkästchen am Anfang des aktiven Dokuments hinzugefügt. Der Name wird auf "Color" gesetzt, und dann wird das Kontrollkästchen gewählt.

With ActiveDocument.FormFields.Add(Range:=ActiveDocument.Range _
    (Start:=0,End:=0), Type:=wdFieldFormCheckBox)
    .Name = "Color"
    .CheckBox.Value = True
End With


ColorFormat-Objekt

Repräsentiert die Farbe eines einfarbigen Objekts oder die Vorder- bzw. Hintergrundfarbe eines Objekts mit einer fließenden oder gemusterten Füllung. Mit der RGB-Eigenschaft können Sie einen bestimmten Rot-Grün-Blau-Wert für Farben festlegen.

Verwendung von ColorFormat-Objekten

Verwenden Sie eine der in der folgenden Tabelle aufgeführten Eigenschaften, um ein ColorFormat-Objekt zurückzugeben.

Verwenden Sie diese Eigenschaft | Mit diesem Objekt | Um ein ColorFormat-Objekt zurückzugeben, das Folgendes repräsentiert
BackColor | FillFormat | Hintergrundfüllfarbe (für eine schattierte oder gemusterte Füllung)
ForeColor | FillFormat | Vordergrundfüllfarbe (oder die Füllfarbe für eine einfarbige Füllung)
BackColor | LineFormat | Hintergrundlinienfarbe (für eine gemusterte Linie)
ForeColor | LineFormat | Vordergrundlinienfarbe (oder die Linienfarbe für eine einfarbige Linie)
ForeColor | ShadowFormat | Schattenfarbe
ExtrusionColor | ThreeDFormat | Farbe der Seiten eines projizierten Objekts

Verwenden Sie die RGB-Eigenschaft, um einen bestimmten Rot-Grün-Blau-Wert für eine Farbe festzulegen. Im folgenden Beispiel wird zu dem aktiven Dokument ein Rechteck hinzugefügt, und anschließend werden die Vorder- und Hintergrundfarbe und ein fließender Farbverlauf für die Füllung des Rechtecks festgelegt.

With ActiveDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


Column-Objekt

Stellt eine einzelne Tabellenspalte dar. Das Column-Objekt ist ein Element der Columns-Auflistung. Die Columns-Auflistung enthält alle Spalten einer Tabelle, einer Markierung oder eines Bereichs.

Verwendung des Column-Objekts

Verwenden Sie Columns(Index), um ein einzelnes Column-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Spalte in der Columns-Auflistung dar (von links nach rechts gezählt).

Im folgenden Beispiel wird Spalte eins in Tabelle eins im aktiven Dokument markiert.

ActiveDocument.Tables(1).Columns(1).Select

Verwenden Sie die Column-Eigenschaft mit einem Cell-Objekt, um ein Column-Objekt zurückzugeben. Im folgenden Beispiel wird der Text in Zelle eins gelöscht, neuer Text eingefügt und anschließend die gesamte Spalte sortiert.

With ActiveDocument.Tables(1).Cell(1, 1)
    .Range.Delete
    .Range.InsertBefore "Sales"
    .Column.Sort
End With

Verwenden Sie die Add-Methode, um zu einer Tabelle eine Spalte hinzuzufügen. Im folgenden Beispiel wird zu der ersten Tabelle im aktiven Dokument eine Spalte hinzugefügt und dann den Spalten die gleiche Breite zugewiesen.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    myTable.Columns.Add BeforeColumn:=myTable.Columns(1)
    myTable.Columns.DistributeWidth
End If

Hinweise

Verwenden Sie die Information-Eigenschaft mit einem Selection-Objekt, um die aktuelle Spaltennummer zurückzugeben. Im folgenden Beispiel wird die aktuelle Spalte markiert und anschließend die Spaltennummer in einem Meldungsfeld angezeigt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Columns(1).Select
    MsgBox "Column " _
        & Selection.Information(wdStartOfRangeColumnNumber)
End If


Columns-Objekt (Auflistung)

Eine Auflistung von Column-Objekten, die die Spalten einer Tabelle darstellen.

Verwendung der Columns-Auflistung

Verwenden Sie die Columns-Eigenschaft, um die Columns-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Column-Objekte in der Columns-Auflistung für die erste Tabelle im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Tables(1).Columns.Count

Im folgenden Beispiel wird eine Tabelle mit sechs Spalten und drei Zeilen erstellt. Anschließend werden die einzelnen Spalten mit einem jeweils progressiv steigenden (dunkleren) Schattierungsprozentsatz formatiert.

Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=6)
For Each col In myTable.Columns
    col.Shading.Texture = 2 + i
    i = i + 1
Next col

Verwenden Sie die Add-Methode, um zu einer Tabelle eine Spalte hinzuzufügen. Im folgenden Beispiel wird zu der ersten Tabelle im aktiven Dokument eine Spalte hinzugefügt. Anschließend wird den Spalten die gleiche Breite zugewiesen.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    myTable.Columns.Add BeforeColumn:=myTable.Columns(1)
    myTable.Columns.DistributeWidth
End If

Verwenden Sie Columns(Index), um ein einzelnes Column-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Spalte in der Columns-Auflistung dar (von links nach rechts gezählt). Im folgenden Beispiel wird die erste Spalte in der ersten Tabelle markiert.

ActiveDocument.Tables(1).Columns(1).Select


Comment-Objekt

Stellt einen einzelnen Kommentar dar. Das Comment-Objekt ist ein Element der Comments-Auflistung. Die Comments-Auflistung enthält Kommentare einer Markierung, eines Bereichs oder eines Dokuments.

Verwendung des Comment-Objekts

Verwenden Sie Comments(Index), um ein einzelnes Comment-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Kommentars in der angegebenen Markierung, dem angegebenen Bereich oder dem angegebenen Dokument dar. Im folgenden Beispiel wird der Autor des ersten Kommentars im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Comments(1).Author

Verwenden Sie die Add-Methode, um zu dem angegebenen Bereich einen Kommentar hinzuzufügen. Im folgenden Beispiel wird unmittelbar nach der Markierung ein Kommentar hinzugefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Comments.Add Range:=Selection.Range, _
    Text:="review this"

Verwenden Sie die Reference-Eigenschaft, um die dem angegebenen Kommentar zugewiesene Verweismarke zurückzugeben. Verwenden Sie die Range-Eigenschaft, um den mit dem angegebenen Kommentar verbundenen Text zurückzugeben. Im folgenden Beispiel wird der mit dem ersten Kommentar im aktiven Dokument verbundene Text angezeigt.

MsgBox ActiveDocument.Comments(1).Range.Text


Comments-Objekt (Auflistung)

Eine Auflistung von Comment-Objekten, die die Kommentare in einer Markierung, einem Bereich oder einem Dokument darstellen.

Verwendung der Comments-Auflistung

Verwenden Sie die Comments-Eigenschaft, um die Comments-Auflistung zurückzugeben. Im folgenden Beispiel werden die von Don Funk im aktiven Dokument erstellten Kommentare angezeigt.

ActiveDocument.ActiveWindow.View.SplitSpecial = wdPaneComments
ActiveDocument.Comments.ShowBy = "Don Funk"

Verwenden Sie die Add-Methode, um zu dem angegebenen Bereich einen Kommentar hinzuzufügen. Im folgenden Beispiel wird unmittelbar nach der Markierung ein Kommentar hinzugefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Comments.Add Range:=Selection.Range, _
    Text:="review this"

Verwenden Sie Comments(Index), um ein einzelnes Comment-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Kommentars in der angegebenen Markierung, dem angegebenen Bereich oder dem angegebenen Dokument dar. Im folgenden Beispiel wird der Autor des ersten Kommentars im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Comments(1).Author

Im folgenden Beispiel werden die Initialen des Autors des ersten Kommentars in der Markierung angezeigt.

If Selection.Comments.Count >= 1 Then MsgBox _
    Selection.Comments(1).Initial


CustomLabel-Objekt

Stellt ein benutzerdefiniertes Adressetikett dar. Das CustomLabel-Objekt ist ein Element der CustomLabels-Auflistung. Die CustomLabels-Auflistung enthält alle im Dialogfeld Etiketten einrichten aufgeführten, benutzerdefinierten Adressetiketten.

Verwendung des CustomLabel-Objekts

Verwenden Sie CustomLabels(Index), um ein einzelnes CustomLabel-Objekt zurückzugeben, wobei Index der Name des benutzerdefinierten Etiketts oder die Indexnummer ist. Im folgenden Beispiel wird ein neues Dokument mit einem bereits vorhandenen benutzerdefinierten Etikett-Layout "My Labels" erstellt.

Set ML = Application.MailingLabel
If ML.CustomLabels("My Labels").Valid = True Then
    ML.CreateNewDocument Name:="My Labels"
Else
    MsgBox "The My Labels custom label is not available"
End If

Die Indexnummer stellt die Position des benutzerdefinierten Adressetiketts in der CustomLabels-Auflistung dar. Im folgenden Beispiel wird der Name des ersten benutzerdefinierten Adressetiketts angezeigt.

If Application.MailingLabel.CustomLabels.Count >= 1 Then
    MsgBox Application.MailingLabel.CustomLabels(1).Name
End If

Anmerkung CustomLabel-Objekte werden in der CustomLabels-Auflistung alphabetisch sortiert; ihre Indexnummern werden bei einer Änderung des Inhalts der Auflistung dynamisch neu zugewiesen. Es ist deshalb sicherer, sich auf den Namen eines bestimmten CustomLabel-Objekts zu beziehen, als auf seine Indexnummer.

Verwenden Sie die Add-Methode, um ein benutzerdefiniertes Etikett zu erstellen. Im folgenden Beispiel wird das benutzerdefinierte Adressetikett "My Labels" hinzugefügt und das Seitenformat eingestellt.

Set ML = _
    Application.MailingLabel.CustomLabels.Add(Name:="My Labels", _
    DotMatrix:=False)
ML.PageSize = wdCustomLabelA4


CustomLabels-Objekt (Auflistung)

Eine Auflistung von CustomLabel-Objekten, die im Dialogfeld Etiketten einrichten verfügbar sind. Diese Auflistung enthält benutzerdefinierte Etiketten aller Druckertypen (Matrix-, Laser- und Tintenstrahldrucker).

Verwendung der CustomLabels-Auflistung

Verwenden Sie die CustomLabels-Eigenschaft, um die CustomLabels-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der verfügbaren benutzerdefinierten Etiketten angezeigt.

MsgBox Application.MailingLabel.CustomLabels.Count

Verwenden Sie die Add-Methode, um ein benutzerdefiniertes Etikett zu erstellen. Im folgenden Beispiel wird das benutzerdefinierte Adressetikett "My Labels" hinzugefügt und das Seitenformat eingestellt.

Set ML = _
    Application.MailingLabel.CustomLabels.Add(Name:="My Labels", _
    DotMatrix:=False)
ML.PageSize = wdCustomLabelA4

Verwenden Sie CustomLabels(Index), um ein einzelnes CustomLabel-Objekt zurückzugeben, wobei Index der Name des benutzerdefinierten Etiketts oder die Indexnummer ist. Im folgenden Beispiel wird ein neues Dokument mit einem bereits vorhandenen benutzerdefinierten Etikett-Layout "My Labels" erstellt.

Set ML = Application.MailingLabel
If ML.CustomLabels("My Labels").Valid = True Then
    ML.CreateNewDocument Name:="My Labels"
Else
    MsgBox "The My Labels custom label is not available"
End If

Die Indexnummer stellt die Position des benutzerdefinierten Adressetiketts in der CustomLabels-Auflistung dar. Im folgenden Beispiel wird der Name des ersten benutzerdefinierten Adressetiketts angezeigt.

If Application.MailingLabel.CustomLabels.Count >= 1 Then
    MsgBox Application.MailingLabel.CustomLabels(1).Name
End If


DefaultWebOptions-Objekt

Enthält globale Attribute auf Anwendungsebene, die von Microsoft Word verwendet werden, wenn Sie ein Dokument als Webseite speichern oder eine Webseite öffnen. Sie können Attribute entweder auf Anwendungsebene (global) oder auf Dokumentebene zurückgeben oder festlegen. (Beachten Sie, dass die Attributwerte der einzelnen Dokumente je nach Attributwert zum Zeitpunkt der Speicherung des Dokuments unterschiedlich sein können.) Attributeinstellungen auf Dokumentebene setzen die Attributeinstellungen auf Anwendungsebene außer Kraft. Attribute auf Dokumentebene sind im WebOptions-Objekt enthalten.

Verwendung des DefaultWebOptions-Objekts

Verwenden Sie die DefaultWebOptions-Methode, um das DefaultWebOptions-Objekt zurückzugeben. Im folgenden Beispiel wird geprüft, ob PNG (Portable Network Graphics) als Bildformat zulässig ist. Die Variable strImageFileType wird entsprechend festgelegt.

Set objAppWebOptions = Application.DefaultWebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        strImageFileType = "PNG"
    Else
        strImageFileType = "JPG"
    End If
End With


Dialog-Objekt

Stellt ein integriertes Dialogfeld dar. Das Dialog-Objekt ist ein Element der Dialogs-Auflistung. Die Dialogs-Auflistung enthält alle integrierten Dialogfelder in Word. Sie können kein neues integriertes Dialogfeld erstellen oder der Dialogs-Auflistung hinzufügen.

Verwendung des Dialog-Objekts

Mit Dialogs(Index) können Sie ein einzelnes Dialog-Objekt zurückgeben. (Index ist eine WdWordDialog-Konstante, die das Dialogfeld bezeichnet.) Das folgende Beispiel zeigt die Aktionen an, die im integrierten Dialogfeld Öffnen (Menü Datei) benötigt werden, und führt die Aktionen aus.

dlgAnswer = Dialogs(wdDialogFileOpen).Show

Die WdWordDialog-Konstanten werden aus dem Präfix "wdDialog" und dem Namen des Menüs sowie des Dialogfelds gebildet. Die Konstante für das Dialogfeld Seite einrichten lautet z. B. wdDialogFilePageSetup, und die Konstante für das Dialogfeld Neu lautet wdDialogFileNew. Weitere Informationen über das Arbeiten mit integrierten Dialogfeldern von Word finden Sie unter Anzeigen von integrierten Dialogfeldern bei Word.


Dialogs-Objekt (Auflistung)

Eine Auflistung von Dialog-Objekten in Word. Jedes Dialog-Objekt stellt ein in Word integriertes Dialogfeld dar.

Verwendung der Dialogs-Auflistung

Verwenden Sie die Dialogs-Eigenschaft, um die Dialogs-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der verfügbaren, integrierten Dialogfelder angezeigt.

MsgBox Dialogs.Count

Sie können kein neues, integriertes Dialogfeld erstellen oder der Dialogs-Auflistung hinzufügen. Verwenden Sie Dialogs(Index), um ein einzelnes Dialog-Objekt zurückzugeben, wobei Index die WdWordDialog-Konstante ist, die das Dialogfeld bezeichnet. Im folgenden Beispiel wird das integrierte Dialogfeld Öffnen angezeigt.

dlgAnswer = Dialogs(wdDialogFileOpen).Show

Weitere Informationen hierzu finden Sie unter Anzeigen von integrierten Dialogfeldern bei Word.


Dictionary-Objekt

Repräsentiert ein Wörterbuch. Dictionary-Objekte, die Benutzerwörterbücher darstellen, sind Elemente der Dictionaries-Auflistung. Andere Wörterbuch-Objekte werden mit den Eigenschaften der Languages-Auflistung zurückgegeben. Dazu gehören die ActiveSpellingDictionary-, ActiveGrammarDictionary-, ActiveThesaurusDictionary- und ActiveHyphenationDictionary-Eigenschaften.

Verwendung des Dictionary-Objekts

Verwenden Sie CustomDictionaries(Index) mit Index als einer Indexnummer oder dem Namen des Wörterbuchs als Zeichenfolge, um ein einzelnes Dictionary-Objekt zurückzugeben, das ein Benutzerwörterbuch darstellt. Im folgenden Beispiel wird das erste Wörterbuch in der Auflistung zurückgegeben.

CustomDictionaries(1)

Im folgenden Beispiel wird das Wörterbuch "MyDictionary" zurückgegeben.

CustomDictionaries("MyDictionary")

Mit der ActiveCustomDictionary-Eigenschaft definieren Sie ein Benutzerwörterbuch aus der Auflistung, in das neue Wörter aufgenommen werden. Wenn Sie versuchen, mit dieser Eigenschaft ein Wörterbuch zu definieren, bei dem es sich nicht um ein Benutzerwörterbuch handelt, tritt ein Fehler auf.

Mit der Add-Methode nehmen Sie ein neues Benutzerwörterbuch in die Auflistung der aktiven Benutzerwörterbücher auf. Wenn es keine Datei mit dem durch FileName bestimmten Namen gibt, legt Word eine solche Datei an. Im folgenden Beispiel wird "MyCustom.dic" in die Auflistung der Benutzerwörterbücher aufgenommen.

CustomDictionaries.Add FileName:="MyCustom.dic"

Hinweise

Die Position eines Wörterbuchs ermitteln Sie mit der Name- und Path-Eigenschaft. Im folgenden Beispiel wird ein Meldungsfeld mit den vollständigen Pfadangaben aller Wörterbücher angezeigt.

For Each d in CustomDictionaries
    Msgbox d.Path & Application.PathSeparator & d.Name
Next d

Mit der LanguageSpecific-Eigenschaft stellen Sie fest, ob einem bestimmten Benutzerwörterbuch eine bestimmte Sprache mit der LanguageID-Eigenschaft zugewiesen werden kann. Wenn es sich um ein sprachspezifisches Wörterbuch handelt, wird nur Text in der bestimmten Sprache damit überprüft.

Für alle Sprachen mit installierten Korrekturhilfen können Sie die ActiveGrammarDictionary-, ActiveHyphenationDictionary-, ActiveSpellingDictionary- und ActiveThesaurusDictionary-Eigenschaft verwenden, um die entsprechenden Dictionary-Objekte zurückzugeben. Im folgenden Beispiel wird die vollständige Pfadangabe des aktiven Rechtschreibwörterbuchs in der US-amerikanischen Version von Word zurückgegeben.

Set myspell = Languages(wdEnglishUS).ActiveSpellingDictionary
MsgBox mySpell.Path & Application.PathSeparator & mySpell.Name

Die ReadOnly-Eigenschaft liefert True für .lex-Dateien (integrierte Wörterbücher) und False für .dic-Dateien (Benutzerwörterbücher).


Dictionaries-Objekt (Auflistung)

Eine Auflistung mit Dictionary-Objekten, die die aktiven Benutzerwörterbücher enthalten.

Verwendung der Dictionaries-Auflistung

Mit der CustomDictionaries-Eigenschaft liefern Sie die Auflistung der zur Zeit aktiven Benutzerwörterbücher. Im folgenden Beispiel werden die Namen aller aktiven Benutzerwörterbücher angezeigt.

For Each d In CustomDictionaries
    Msgbox d.Name
Next d

Mit der Add-Methode nehmen Sie ein neues Benutzerwörterbuch in die Auflistung der aktiven Benutzerwörterbücher auf. Wenn es keine Datei mit dem durch FileName bestimmten Namen gibt, legt Word eine solche Datei an. Im folgenden Beispiel wird "MyCustom.dic" in die Auflistung der Benutzerwörterbücher aufgenommen.

CustomDictionaries.Add FileName:="MyCustom.dic"

Mit der ClearAll-Methode entfernen Sie alle Benutzerwörterbücher aus dem Speicher. Beachten Sie jedoch, dass bei dieser Methode die Wörterbuchdateien nicht gelöscht werden. Nach der Anwendung dieser Methode ist die Anzahl der Benutzerwörterbücher in der Auflistung 0 (Null). Im folgenden Beispiel werden die Benutzerwörterbücher aus dem Speicher entfernt und eine neue Benutzerwörterbuchdatei erstellt. Das neue Wörterbuch wird als aktives Benutzerwörterbuch festgelegt, in das Word automatisch alle neuen Wörter aufnimmt.

With CustomDictionaries
    .ClearAll
    .Add FileName:= "MyCustom.dic"
    .ActiveCustomDictionary = CustomDictionaries(1)
End With

Hinweise

Sie definieren das aktive Wörterbuch, in das alle neuen Wörter aufgenommen werden, mit der ActiveCustomDictionary-Eigenschaft. Wenn Sie versuchen, mit dieser Eigenschaft ein Wörterbuch zu definieren, bei dem es sich nicht um ein Benutzerwörterbuch handelt, tritt ein Fehler auf.

Die Maximum-Eigenschaft gibt die maximale Anzahl gleichzeitig geladener Benutzerwörterbücher zurück, die die Anwendung unterstützt. Word unterstützt maximal 10.


Document-Objekt

Stellt ein Dokument dar. Das Document-Objekt ist ein Element der Documents-Auflistung. Die Documents-Auflistung enthält alle derzeit in Word geöffneten Document-Objekte.

Verwendung des Document-Objekts

Verwenden Sie Documents(Index), um ein einzelnes Document-Objekt zurückzugeben, wobei Index der Name des Dokuments oder die Indexnummer ist. Im folgenden Beispiel wird das Dokument "Report.doc" ohne Speichern von Änderungen geschlossen.

Documents("Report.doc").Close SaveChanges:=wdDoNotSaveChanges

Die Indexnummer stellt die Position des Dokuments in der Documents-Auflistung dar. Im folgenden Beispiel wird das erste Dokument der Documents-Auflistung aktiviert.

Documents(1).Activate

Verwendung von ActiveDocument

Sie können die ActiveDocument-Eigenschaft verwenden, um auf das Dokument mit dem Fokus zu verweisen. Im folgenden Beispiel wird die Activate-Methode verwendet, um das Dokument "Document1" zu aktivieren. Außerdem wird die Seitenausrichtung auf Querformat eingestellt und das Dokument gedruckt.

Documents("Document1").Activate
ActiveDocument.PageSetup.Orientation = wdOrientLandscape
ActiveDocument.PrintOut


Documents-Objekt (Auflistung)

Eine Auflistung aller Document-Objekte, die derzeit in Word geöffnet sind.

Verwendung der Documents-Auflistung

Verwenden Sie die Documents-Eigenschaft, um die Documents-Auflistung zurückzugeben. Im folgenden Beispiel werden die Namen der geöffneten Dokumente angezeigt.

For Each aDoc In Documents
    aName = aName & aDoc.Name & vbCr
Next aDoc
MsgBox aName

Verwenden Sie die Add-Methode, um ein neues, leeres Dokument zu erstellen und es zu der Documents-Auflistung hinzuzufügen. Im folgenden Beispiel wird ein auf der Dokumentvorlage "Normal.dot" basierendes Dokument erstellt.

Documents.Add

Verwenden Sie die Open-Methode, um eine Datei zu öffnen. Im folgenden Beispiel wird das Dokument "Sales.doc" geöffnet.

Documents.Open FileName:="C:\My Documents\Sales.doc"

Verwenden Sie Documents(Index), um ein einzelnes Document-Objekt zurückzugeben, wobei Index der Name des Dokuments oder die Indexnummer ist. Die folgende Anweisung schließt das Dokument "Report.doc", ohne Änderungen zu speichern.

Documents("Report.doc").Close SaveChanges:=wdDoNotSaveChanges

Die Indexnummer stellt die Position des Dokuments in der Documents-Auflistung dar. Im folgenden Beispiel wird das erste Dokument der Documents-Auflistung aktiviert.

Documents(1).Activate

Hinweise

Im folgenden Beispiel wird die Documents-Auflistung durchgegangen, um festzustellen, ob das Dokument "Report.doc" geöffnet ist. Wenn das Dokument in der Documents-Auflistung enthalten ist, wird es aktiviert, ist es nicht darin enthalten, wird es geöffnet.

For Each doc In Documents
    If doc.Name = "Report.doc" Then found = True
Next doc
If found <> True Then
    Documents.Open FileName:="C:\Documents\Report.doc"
Else
    Documents("Report.doc").Activate
End If


DropCap-Objekt

Stellt einen Initialbuchstaben am Beginn eines Absatzes dar. Es gibt keine DropCaps-Auflistung. Jedes Paragraph-Objekt enthält nur ein DropCap-Objekt.

Verwendung des DropCap-Objekts

Verwenden Sie die DropCap-Eigenschaft, um ein DropCap-Objekt zurückzugeben. Im folgenden Beispiel wird für den ersten Buchstaben im ersten Absatz des aktiven Dokuments ein Initialbuchstabe eingesetzt.

With ActiveDocument.Paragraphs(1).DropCap
    .Enable
    .Position = wdDropNormal
End With


DropDown-Objekt

Stellt ein Dropdown-Formularfeld dar, das eine Liste von Elementen in einem Formular enthält.

Verwendung des DropDown-Objekts

Verwenden Sie FormFields(Index), um ein einzelnes FormField-Objekt zurückzugeben, wobei Index die Indexnummer oder der Name der dem Dropdown-Formularfeld zugeordneten Textmarke ist. Verwenden Sie die DropDown-Eigenschaft mit dem FormField-Objekt, um ein DropDown-Objekt zurückzugeben. Im folgenden Beispiel wird das erste Element im Dropdown-Formularfeld "DropDown" im aktiven Dokument ausgewählt.

ActiveDocument.FormFields("DropDown1").DropDown.Value = 1

Die Indexnummer stellt die Position des Formularfelds in der FormFields-Auflistung dar. Im folgenden Beispiel wird der Typ des ersten Formularfelds im aktiven Dokument überprüft. Wenn es sich um ein Dropdown-Formularfeld handelt, wird das zweite Element markiert.

If ActiveDocument.FormFields(1).Type = wdFieldFormDropDown Then
    ActiveDocument.FormFields(1).DropDown.Value = 2
End If

Im folgenden Beispiel wird festgestellt, ob das durch ffield dargestellte Formularfeld ein gültiges Dropdown-Formularfeld ist, bevor ihm ein Element hinzugefügt wird.

Set ffield = ActiveDocument.FormFields(1).DropDown
If ffield.Valid = True Then
    ffield.ListEntries.Add Name:="Hello"
Else
    MsgBox "First field is not a drop down"
End If

Verwenden Sie die Add-Methode mit der FormFields-Auflistung, um ein Dropdown-Formularfeld hinzuzufügen. Im folgenden Beispiel wird am Anfang des aktiven Dokuments ein Dropdown-Formularfeld eingefügt. Anschließend werden dem Formularfeld Elemente hinzugefügt.

Set ffield = ActiveDocument.FormFields.Add( _
    Range:=ActiveDocument.Range(Start:=0, End:=0), _
    Type:=wdFieldFormDropDown)
With ffield
    .Name = "Colors"
    With .DropDown.ListEntries
        .Add Name:="Blue"
        .Add Name:="Green"
        .Add Name:="Red"
    End With
End With


Email-Objekt

Stellt eine E-Mail-Nachricht dar. Es ist keine Emails-Auflistung vorhanden; jedes Document-Objekt enthält nur ein Email-Objekt.

Verwendung des Email-Objekts

Verwenden Sie die Email-Eigenschaft, um das Email-Objekt zurückzugeben. Das Email-Objekt und seine Eigenschaften sind nur dann gültig, wenn das aktive Dokument eine noch nicht gesendete Weiterleitung oder Antwort oder eine neue E-Mail-Nachricht ist.

In diesem Beispiel wird der Name der Formatvorlage zurückgegeben, die dem aktuellen E-Mail-Verfasser zugeordnet ist.

MsgBox ActiveDocument.Email _
    .CurrentEmailAuthor.Style.NameLocal

Anmerkung Der Name der Formatvorlage für den Verfasser entspricht dem Wert, der von der UserName-Eigenschaft zurückgegeben wird.


EmailAuthor-Objekt

Stellt den Autor einer E-Mail-Nachricht dar. Es ist keine EmailAuthors-Auflistung vorhanden; jedes Email-Objekt enthält nur ein EmailAuthor-Objekt.

Verwendung des EmailAuthor-Objekts

Verwenden Sie die CurrentEmailAuthor-Eigenschaft, um das EmailAuthor-Objekt zurückzugeben. Das EmailAuthor-Objekt und seine Eigenschaften sind nur dann gültig, wenn das aktive Dokument eine noch nicht gesendete Weiterleitung oder Antwort oder eine neue E-Mail-Nachricht ist.

In diesem Beispiel wird die dem aktuellen Verfasser zugeordnete Formatvorlage für noch nicht gesendete Antworten, Weiterleitungen oder neue E-Mail-Nachrichten zurückgegeben und der Name der dieser Formatvorlage zugewiesenen Schriftart angezeigt.

Set MyEmailStyle = _
    ActiveDocument.Email.CurrentEmailAuthor.Style
Msgbox MyEmailStyle.Font.Name


EmailOptions-Objekt

Enthält globale Attribute auf Anwendungsebene, die von Microsoft Word verwendet werden, wenn Sie E-Mail-Nachrichten und -Antworten erstellen und bearbeiten.

Verwendung des EmailOptions-Objekts

Verwenden Sie die EmailOptions-Eigenschaft, um das EmailOptions-Objekt zurückzugeben.

In diesem Beispiel wird die Schriftartfarbe der Standardformatvorlage geändert, die zum Erstellen von neuen E-Mail-Nachrichten verwendet wird.

Application.EmailOptions.ComposeStyle.Font.Color = _
    wdColorBrightGreen

In diesem Beispiel wird Word so eingestellt, dass Kommentare in E-Mail-Nachrichten von Word mit den Initialen "WK" versehen werden.

Application.EmailOptions.MarkCommentsWith = "WK"
Application.EmailOptions.MarkComments = True

In diesem Beispiel werden die Signaturen geändert, die Word an ausgehende E-Mail-Nachrichten sowie an Antworten auf E-Mail-Nachrichten anfügt.

With Application.EmailOptions.EmailSignature
    .NewMessageSignature = "Signature1"
    .ReplyMessageSignature = "Reply2"
End With


EmailSignature-Objekt

Enthält Informationen über die E-Mail-Signaturen, die Microsoft Word verwendet, wenn Sie E-Mail-Nachrichten und -Antworten erstellen und bearbeiten. Es ist keine EmailSignatures-Auflistung vorhanden; jedes EmailOptions-Objekt enthält nur ein EmailSignature-Objekt.

Verwendung des EmailSignature-Objekts

Verwenden Sie die EmailSignature-Eigenschaft, um das EmailSignature-Objekt zurückzugeben.

In diesem Beispiel werden die Signaturen geändert, die Word an neue ausgehende E-Mail-Nachrichten und Antworten auf E-Mail-Nachrichten anfügt.

With Application.EmailOptions.EmailSignature
    .NewMessageSignature = "Signature1"
    .ReplyMessageSignature = "Reply2"
End With


Endnote-Objekt

Stellt eine Endnote dar. Das Endnote-Objekt ist ein Element der Endnotes-Auflistung. Die Endnotes-Auflistung stellt die Endnoten in einer Markierung, einem Bereich oder einem Dokument dar.

Verwendung des Endnote-Objekts

Verwenden Sie Endnotes(Index), um ein einzelnes Endnote-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Endnote in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel wird der ersten Endnote in der Markierung die Formatierung "Rot" zugewiesen.

If Selection.Endnotes.Count >= 1 Then
    Selection.Endnotes(1).Reference.Font.ColorIndex = wdRed
End If

Verwenden Sie die Add-Methode, um zu der Endnotes-Auflistung eine Endnote hinzuzufügen. Im folgenden Beispiel wird unmittelbar nach der Markierung eine Endnote eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Endnotes.Add Range:=Selection.Range , _
    Text:="The Willow Tree, (Lone Creek Press, 1996)."


Endnotes-Objekt (Auflistung)

Eine Auflistung von Endnote-Objekten, die alle Endnoten in einer Markierung, einem Bereich oder einem Dokument darstellen.

Verwendung der Endnotes-Auflistung

Verwenden Sie die Endnotes-Eigenschaft, um die Endnotes-Auflistung zurückzugeben. Im folgenden Beispiel wird die Position von Endnoten im aktiven Dokument festgelegt.

ActiveDocument.Endnotes.Location = wdEndOfSection

Verwenden Sie die Add-Methode, um zu der Endnotes-Auflistung eine Endnote hinzuzufügen. Im folgenden Beispiel wird unmittelbar hinter der Markierung eine Endnote eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Endnotes.Add Range:=Selection.Range , _
    Text:="The Willow Tree, (Lone Creek Press, 1996)."

Verwenden Sie Endnotes(Index), um ein einzelnes Endnote-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Endnote in einer Markierung, einem Bereich oder einem Dokument dar. Im folgenden Beispiel wird der ersten Endnote in der Markierung die Formatierung "Rot" zugewiesen.

If Selection.Endnotes.Count >= 1 Then
    Selection.Endnotes(1).Reference.Font.ColorIndex = wdRed
End If


Envelope-Objekt

Stellt einen Umschlag dar. Es gibt keine Envelopes-Auflistung. Jedes Document-Objekt enthält nur ein Envelope-Objekt.

Verwendung des Envelope-Objekts

Verwenden Sie die Envelope-Eigenschaft, um das Envelope-Objekt zurückzugeben. Im folgenden Beispiel wird zu einem neuen Dokument ein Umschlag hinzugefügt. Der Abstand zwischen dem oberen Rand des Umschlags und der Adresse wird auf 2,25 Zoll festgelegt.

Set myDoc = Documents.Add
addr = "Michael Matey" & vbCr & "123 Skye St." _
    & vbCr & "Redmond, WA 98107"
retaddr = "Cora Edmonds" & vbCr & "456 Erde Lane" & vbCr _
    & "Redmond, WA 98107"
With myDoc.Envelope
    .Insert Address:=addr, ReturnAddress:=retaddr
    .AddressFromTop = InchesToPoints(2.25)
End With

Hinweise

Das Envelope-Objekt ist unabhängig davon verfügbar, ob zu dem angegebenen Dokument ein Umschlag hinzugefügt wurde oder nicht. Es wird jedoch ein Fehler erzeugt, wenn Sie eine der folgenden Eigenschaften verwenden, zu dem Dokument aber kein Umschlag hinzugefügt wurde: Address, AddressFromleft, AddressFromTop, FeedSource, ReturnAddress, ReturnAddressFromLeft, ReturnAddressFromTop und UpdateDocument.

Im folgenden Beispiel wird gezeigt, wie das On-Error-GoTo-Argument verwendet wird, um den Fehler zu umgehen, der erzeugt wird, wenn zu dem aktiven Dokument kein Umschlag hinzugefügt wurde. Wurde zu dem Dokument jedoch ein Umschlag hinzugefügt, wird die Absenderadresse angezeigt.

On Error GoTo ErrorHandler
MsgBox ActiveDocument.Envelope.Address
ErrorHandler:
If Err = 5852 Then MsgBox _
    "Envelope is not in the specified document"

Verwenden Sie die Insert-Methode, um zu dem angegebenen Dokument einen Umschlag hinzuzufügen. Verwenden Sie die PrintOut-Methode, um die Eigenschaften eines Umschlags einzustellen und den Umschlag zu drucken, ohne ihn zu dem Dokument hinzuzufügen.


Field-Objekt

Stellt ein Feld dar. Das Field-Objekt ist ein Element der Fields-Auflistung. Die Fields-Auflistung stellt die Felder in einer Markierung, einem Bereich oder einem Dokument dar.

Verwendung des Field-Objekts

Verwenden Sie Fields(Index), um ein einzelnes Field-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Feldes in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel werden die Feldfunktion und das Ergebnis des ersten Felds im aktiven Dokument angezeigt.

If ActiveDocument.Fields.Count >= 1 Then
    MsgBox "Code =  " & ActiveDocument.Fields(1).Code & vbCr _
        & "Result =  " & ActiveDocument.Fields(1).Result & vbCr
End If

Verwenden Sie die Add-Methode, um zu der Fields-Auflistung ein Feld hinzuzufügen. Im folgenden Beispiel wird ein DATE-Feld am Beginn der Markierung eingefügt und anschließend das Ergebnis angezeigt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldDate)
MsgBox myField.Result

Die wdFieldDate-Konstante ist Teil der WdFieldType-Gruppe von Konstanten, die die verschiedenen Feldtypen enthält.


Fields-Objekt (Auflistung)

Eine Auflistung von Field-Objekten, die alle Felder in einer Markierung, einem Bereich oder einem Dokument darstellen.

Verwendung der Fields-Auflistung

Verwenden Sie die Fields-Eigenschaft, um die Fields-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Felder in der Markierung aktualisiert.

Selection.Fields.Update

Verwenden Sie die Add-Methode, um zu der Fields-Auflistung ein Feld hinzuzufügen. Im folgenden Beispiel wird ein DATE-Feld am Beginn der Markierung eingefügt und anschließend das Ergebnis angezeigt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldDate)
MsgBox myField.Result

Verwenden Sie Fields(Index), um ein einzelnes Field-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Felds in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel werden die Feldfunktion und das Ergebnis des ersten Felds im aktiven Dokument angezeigt.

If ActiveDocument.Fields.Count >= 1 Then
    MsgBox "Code =  " & ActiveDocument.Fields(1).Code & vbCr _
        & "Result =  " & ActiveDocument.Fields(1).Result & vbCr
End If

Hinweise

Verwenden Sie die Fields-Eigenschaft mit einem MailMerge-Objekt, um die MailMergeFields-Auflistung zurückzugeben.

Die Count-Eigenschaft für die Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Hauptdokumentkomponente zurück. Mit dem Range-Objekt können Sie Elemente in anderen Dokumentkomponenten zählen.


FileConverter-Objekt

Stellt einen Dateikonvertierer dar, der zum Öffnen oder Speichern von Dateien verwendet wird. Das FileConverter-Objekt ist ein Element der FileConverters-Auflistung. Die FileConverters-Auflistung enthält alle installierten Dateikonvertierer zum Öffnen und Speichern von Dateien.

Verwendung des FileConverter-Objekts

Verwenden Sie FileConverters(Index), um ein einzelnes FileConverter-Objekt zurückzugeben, wobei Index ein Klassenname oder die Indexnummer ist. Im folgenden Beispiel werden die für den Microsoft Excel Tabellenblattkonvertierer registrierten Erweiterungen angezeigt.

MsgBox FileConverters("MSBiff").Extensions

Die Indexnummer stellt die Position des Dateikonvertiers in der FileConverters-Auflistung dar. Im folgenden Beispiel wird der Formatname des ersten Dateikonvertierers angezeigt.

MsgBox FileConverters(1).FormatName

Sie können keine neuen Dateikonvertierer erstellen oder zu der FileConverters-Auflistung hinzufügen. FileConverter-Objekte werden bei der Installation von Microsoft Office oder durch Installieren zusätzlicher Dateikonvertierer hinzugefügt. Verwenden Sie entweder die CanSave- oder die CanOpen-Eigenschaft, um festzustellen, ob ein FileConverter-Objekt zum Öffnen oder Speichern von Dokumenten verwendet werden kann.

Hinweise

Dateikonvertierer zum Speichern von Dokumenten werden im Dialogfeld Speichern unter aufgelistet. Dateikonvertierer zum Öffnen von Dateien werden in einem Dialogfeld angezeigt, wenn im Menü Extras im Dialogfeld Optionen auf der Registerkarte Allgemein das Kontrollkästchen Konvertierung beim Öffnen bestätigen markiert ist.


FileConverters-Objekt (Auflistung)

Eine Auflistung von FileConverter-Objekten, die alle zum Öffnen und Speichern von Dateien verfügbaren Dateikonvertierer darstellen.

Verwendung der FileConverters-Auflistung

Verwenden Sie die FileConverters-Eigenschaft, um die FileConverters-Auflistung zurückzugeben. Im folgenden Beispiel wird festgestellt, ob ein WordPerfect 6.0-Konverter verfügbar ist.

For Each conv In FileConverters
    If conv.FormatName = "WordPerfect 6.x" Then
        MsgBox "WordPerfect 6.0 converter is installed"
    End if
Next conv

Die Add-Methode ist für die FileConverters-Auflistung nicht verfügbar. FileConverter-Objekte werden bei der Installation von Microsoft Office oder durch Installation von zusätzlichen Konvertern hinzugefügt.

Verwenden Sie FileConverters(Index), um ein einzelnes FileConverter-Objekt zurückzugeben, wobei Index ein Klassenname oder eine Indexnummer ist. Im folgenden Beispiel werden die für den Microsoft Excel Tabellenblattkonvertierer registrierten Erweiterungen angezeigt.

MsgBox FileConverters("MSBiff").Extensions

Die Indexnummer stellt die Position des Dateikonvertierers in der FileConverters-Auflistung dar. Im folgenden Beispiel wird der Formatname des ersten Dateikonvertierers angezeigt.

MsgBox FileConverters(1).FormatName

Hinweise

Dateikonvertierer zum Speichern von Dokumenten werden im Dialogfeld Speichern unter aufgelistet. Dateikonvertierer zum Öffnen von Dateien werden in einem Dialogfeld angezeigt, wenn im Menü Extras im Dialogfeld Optionen auf der Registerkarte Allgemein das Kontrollkästchen Konvertierung beim Öffnen bestätigen markiert ist.


FillFormat-Objekt

Repräsentiert die Formatierung der Füllung einer Form. Eine Form kann eine einfarbige, fließende, Struktur-, Muster-, Bild- oder halbtransparente Füllung haben.

Verwendung von FillFormat-Objekten

Verwenden Sie die Fill-Eigenschaft, um ein FillFormat-Objekt zurückzugeben. Im folgenden Beispiel werden Farbverlauf und Farbe der Füllung des Rechtecks festgelegt.

With ActiveDocument.Shapes _
        .AddShape(msoShapeRectangle, 90, 90, 90, 80).Fill
    .ForeColor.RGB = RGB(0, 128, 128)
    .OneColorGradient msoGradientHorizontal, 1, 1
End With

Hinweise

Viele Eigenschaften des FillFormat-Objekts sind schreibgeschützt. Um eine dieser Eigenschaften festzulegen, müssen Sie die entsprechende Methode zuweisen.


Find-Objekt

Stellt die Kriterien für eine Suchoperation dar. Die Eigenschaften und Methoden des Find-Objekts entsprechen den Optionen im Dialogfeld Suchen und Ersetzen.

Verwendung des Find-Objekts

Mit der Find-Eigenschaft können Sie ein Find-Objekt zurückgeben. Das folgende Beispiel sucht und markiert das nächste Auftreten des Worts "hi".

With Selection.Find
    .ClearFormatting
    .Text = "hi"
    .Execute Forward:=True
End With

Das folgende Beispiel sucht das Auftreten des Worts "hello" im aktiven Dokument und ersetzt dieses Wort durch "hi".

Set myRange = ActiveDocument.Content
myRange.Find.Execute FindText:="hi", ReplaceWith:="hello", _
    Replace:=wdReplaceAll

Hinweise

Wenn Sie zum Find-Objekt aus dem Selection-Objekt gelangt sind, wird die Markierung geändert, wenn der Text gefunden wird, der mit den Suchkriterien übereinstimmt. Das folgende Beispiel markiert das nächste Auftreten des Worts "blue".

Selection.Find.Execute FindText:="blue", Forward:=True

Wenn Sie zum Find-Objekt aus dem Range-Objekt gelangt sind, wird die Markierung nicht geändert, wenn der Text ermittelt wird, der mit den Suchkriterien übereinstimmt. Es wird jedoch das Range-Objekt neu definiert. Das folgende Beispiel sucht das erste Auftreten des Worts "blue" im aktiven Dokument. Wird das Wort "blue" im Dokument ermittelt, wird myRange neu definiert und das Wort "blue" fett formatiert.

Set myRange = ActiveDocument.Content
myRange.Find.Execute FindText:="blue", Forward:=True
If myRange.Find.Found = True Then myRange.Bold = True


FirstLetterException-Objekt

Stellt eine Abkürzung dar, die von der automatischen Korrektur ausgeschlossen ist. Das FirstLetterException-Objekt ist ein Element der FirstLetterExceptions-Auflistung. Die FirstLetterExceptions-Auflistung enthält alle ausgeschlossenen Abkürzungen.

Hinweis Das erste Zeichen, das einem Punkt folgt, wird automatisch großgeschrieben, wenn die CorrectSentenceCaps-Eigenschaft auf True eingestellt ist. Das Zeichen, das Sie nach einem Element in der FirstLetterExceptions-Auflistung eingeben, wird nicht großgeschrieben.

Verwendung des FirstLetterException-Objekts

Verwenden Sie FirstLetterExceptions(Index), um ein einzelnes FirstLetterException-Objekt zurückzugeben, wobei Index die Abkürzung oder die Indexnummer ist. Im folgenden Beispiel wird die Abkürzung "appt." aus der FirstLetterExceptions-Auflistung gelöscht.

AutoCorrect.FirstLetterExceptions("appt.").Delete

Im folgenden Beispiel wird der Name des ersten Elements in der FirstLetterExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.FirstLetterExceptions(1).Name

Verwenden Sie die Add-Methode, um der Liste für die auszuschließenden Anfangsbuchstaben eine Abkürzung hinzuzufügen. Im folgenden Beispiel wird dieser Liste die Abkürzung "addr." hinzugefügt.

AutoCorrect.FirstLetterExceptions.Add Name:="addr."


FirstLetterExceptions-Objekt (Auflistung)

Eine Auflistung von FirstLetterException-Objekten, die die Abkürzungen darstellen, die von der automatischen Korrektur ausgeschlossen sind.

Hinweis Das erste Zeichen, das einem Punkt folgt, wird automatisch großgeschrieben, wenn die CorrectSentenceCaps-Eigenschaft auf True eingestellt ist. Die FirstLetterExceptions-Auflistung enthält Ausnahmen von diesem Vorgang (z. B. Abkürzungen wie "adr." und "verabr.").

Verwendung der FirstLetterExceptions-Auflistung

Verwenden Sie die FirstLetterExceptions-Eigenschaft, um die FirstLetterExceptions-Auflistung zurückzugeben. Im folgenden Beispiel wird die Abkürzung "addr." aus der FirstLetterExceptions-Auflistung gelöscht, falls sie darin enthalten ist.

For Each aExcept In AutoCorrect.FirstLetterExceptions
    If aExcept.Name = "addr." Then aExcept.Delete
Next aExcept

Im folgenden Beispiel wird ein neues Dokument erstellt, in das alle Ausnahmen von der AutoKorrektur eingefügt werden.

Documents.Add
For Each aExcept In AutoCorrect.FirstLetterExceptions
    With Selection
        .InsertAfter aExcept.Name
        .InsertParagraphAfter
        .Collapse Direction:=wdCollapseEnd
    End With
Next aExcept

Verwenden Sie die Add-Methode, um der Liste für die auszuschließenden Anfangsbuchstaben eine Abkürzung hinzuzufügen. Im folgenden Beispiel wird dieser Liste die Abkürzung "addr." hinzugefügt.

AutoCorrect.FirstLetterExceptions.Add Name:="addr."

Verwenden Sie FirstLetterExceptions(Index), um ein einzelnes FirstLetterException-Objekt zurückzugeben, wobei Index die Abkürzung oder die Indexnummer ist. Im folgenden Beispiel wird die Abkürzung "appt." aus der FirstLetterExceptions-Auflistung gelöscht.

AutoCorrect.FirstLetterExceptions("appt.").Delete

Im folgenden Beispiel wird der Name des ersten Elements in der FirstLetterExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.FirstLetterExceptions(1).Name


Font-Objekt

Enthält Zeichenformatierungen (Schriftartname, Schriftgrad, Farbe usw.) für ein Objekt.

Verwendung des Font-Objekts

Verwenden Sie die Font-Eigenschaft, um das Font-Objekt zurückzugeben. In der folgenden Anweisung wird der Markierung die Formatierung "Fett" zugewiesen.

Selection.Font.Bold = True

Im folgenden Beispiel werden dem ersten Absatz im aktiven Dokument die folgenden Formatierungen zugewiesen: 24 Punkt, Arial und kursiv.

Set myRange = ActiveDocument.Paragraphs(1).Range
With myRange.Font
    .Bold = True
    .Name = "Arial"
    .Size = 24
End With

Im folgenden Beispiel wird die Formatierung der Formatvorlage "Überschrift 2" im aktiven Dokument in "Arial" und "Fett" geändert.

With ActiveDocument.Styles(wdStyleHeading2).Font
    .Name = "Arial"
    .Italic = True
End With

Hinweise

Sie können das Schlüsselwort New verwenden, um ein neues, unabhängiges Font-Objekt zu erstellen. Im folgenden Beispiel wird ein Font-Objekt erstellt, dann werden Formatierungseigenschaften eingestellt, und anschließend wird das Font-Objekt dem ersten Absatz im aktiven Dokument zugewiesen.

Set myFont = New Font
myFont.Bold = True
myFont.Name = "Arial"
ActiveDocument.Paragraphs(1).Range.Font = myFont

Sie können ein Font-Objekt auch duplizieren, indem Sie die Duplicate-Eigenschaft verwenden. Im folgenden Beispiel wird eine neue Zeichenformatvorlage mit der Zeichenformatierung der Markierung sowie kursiver Formatierung erstellt. Die Formatierung der Markierung wird nicht geändert.

Set aFont = Selection.Font.Duplicate
aFont.Italic = True
ActiveDocument.Styles.Add(Name:="Italics", _
    Type:=wdStyleTypeCharacter).Font = aFont


FontNames-Objekt

Stellt eine Liste der Namen aller verfügbaren Schriftarten dar.

Verwendung des FontNames-Objekts

Verwenden Sie die FontNames-, LandscapeFontNames- oder PortraitFontNames-Eigenschaft, um das FontNames-Objekt zurückzugeben. Im folgenden Beispiel wird die Anzahl der verfügbaren Hochformat-Schriftarten angezeigt.

MsgBox PortraitFontNames.Count & " fonts available"

In diesem Beispiel werden alle Schriftartnamen im FontNames-Objekt am Ende des aktiven Dokuments aufgelistet.

For Each aFont In FontNames
    ActiveDocument.Range.InsertAfter aFont & vbCr
Next aFont

Verwenden Sie FontNames(Index), um den Namen einer Schriftart zurückzugeben, wobei Index die Indexnummer ist. Im folgenden Beispiel wird der erste Schriftartname im FontNames-Objekt angezeigt.

MsgBox FontNames(1)

Anmerkungen

Sie können der Liste der verfügbaren Schriftart-Namen keine Namen hinzufügen und auch keine Namen daraus entfernen.


Footnote-Objekt

Stellt eine Fußnote dar, die sich am Ende der Seite oder unterhalb des Textes befindet. Das Footnote-Objekt ist ein Element der Footnotes-Auflistung. Die Footnotes-Auflistung stellt die Fußnoten in einer Markierung, einem Bereich oder einem Dokument dar.

Verwendung des Footnote-Objekts

Verwenden Sie Footnotes(Index), um ein einzelnes Footnote-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Fußnote in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel wird der ersten Fußnote in der Markierung die Formatierung "Rot" zugewiesen.

If Selection.Footnotes.Count >= 1 Then
    Selection.Footnotes(1).Reference.Font.ColorIndex = wdRed
End If

Verwenden Sie die Add-Methode, um zu der Footnotes-Auflistung eine Fußnote hinzuzufügen. Im folgenden Beispiel wird unmittelbar nach der Markierung eine automatisch nummerierte Fußnote eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Footnotes.Add Range:=Selection.Range , _
    Text:="The Willow Tree, (Lone Creek Press, 1996)."

Hinweise

Fußnoten, die sich am Ende eines Dokuments oder Abschnitts befinden, werden als Endnoten betrachtet und sind in der Endnotes-Auflistung enthalten.


Footnotes-Objekt (Auflistung)

Eine Auflistung von Footnote-Objekten, die alle Fußnoten in einer Markierung, einem Bereich oder einem Dokument darstellen.

Verwendung der Footnotes-Auflistung

Verwenden Sie die Footnotes-Eigenschaft, um die Footnotes-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Fußnoten im aktiven Dokument in Endnoten geändert.

ActiveDocument.Footnotes.SwapWithEndnotes

Verwenden Sie die Add-Methode, um zu der Footnotes-Auflistung eine Fußnote hinzuzufügen. Im folgenden Beispiel wird unmittelbar nach der Markierung eine Fußnote eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Footnotes.Add Range:=Selection.Range , _
    Text:="The Willow Tree, (Lone Creek Press, 1996)."

Verwenden Sie Footnotes(Index), um ein einzelnes Footnote-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Fußnote in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel wird der ersten Fußnote in der Markierung die Formatierung "Rot" zugewiesen.

If Selection.Footnotes.Count >= 1 Then
    Selection.Footnotes(1).Reference.Font.ColorIndex = wdRed
End If

Hinweise

Fußnoten, die sich am Ende eines Dokuments oder Abschnitts befinden, werden als Endnoten betrachtet und sind in der Endnotes-Auflistung enthalten.


FormField-Objekt

Stellt ein einzelnes Formularfeld dar. Das FormField-Objekt ist ein Element der FormFields-Auflistung.

Verwendung des FormField-Objekts

Verwenden Sie FormFields(Index), um ein einzelnes FormField-Objekt zurückzugeben, wobei Index ein Textmarkenname oder eine Indexnummer ist. Im folgenden Beispiel wird das Ergebnis des Formularfelds "Text1" auf "Don Funk" festgelegt.

ActiveDocument.FormFields("Text1").Result = "Don Funk"

Die Indexnummer stellt die Position des Formularfelds in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel wird der Name des ersten Formularfelds in der Markierung angezeigt.

If Selection.FormFields.Count >= 1 Then
    MsgBox Selection.FormFields(1).Name
End If

Verwenden Sie die Add-Methode mit dem FormFields-Objekt, um ein Formularfeld hinzuzufügen. Im folgenden Beispiel wird am Anfang des aktiven Dokuments ein Kontrollkästchen eingefügt und anschließend das Kontrollkästchen markiert.

Set ffield = ActiveDocument.FormFields.Add( _
    Range:=ActiveDocument.Range(Start:=0, End:=0), _
    Type:=wdFieldFormCheckBox)
ffield.CheckBox.Value = True

Hinweise

Verwenden Sie die CheckBox-, DropDown- und TextInput-Eigenschaften mit dem FormField-Objekt, um das CheckDown-, das DropDown- und das TextInput-Objekt zurückzugeben. Im folgenden Beispiel wird das Kontrollkästchen "Check1" markiert.

ActiveDocument.FormFields("Check1").CheckBox.Value = True


FormFields-Objekt (Auflistung)

Eine Auflistung von FormField-Objekten, die alle Formularfelder in einer Markierung, einem Bereich oder einem Dokument darstellen.

Verwendung der FormFields-Auflistung

Verwenden Sie die FormFields-Eigenschaft, um die FormFields-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Textformularfelder im aktiven Dokument gezählt.

For Each aField In ActiveDocument.FormFields
    If aField.Type = wdFieldFormTextInput Then count = count + 1
Next aField
MsgBox "There are " & count & " text boxes in this document"

Verwenden Sie die Add-Methode mit dem FormFields-Objekt, um ein Formularfeld hinzuzufügen. Im folgenden Beispiel wird am Anfang des aktiven Dokuments ein Kontrollkästchen eingefügt und anschließend das Kontrollkästchen markiert.

Set ffield = ActiveDocument.FormFields.Add( _
    Range:=ActiveDocument.Range(Start:=0,End:=0), _
    Type:=wdFieldFormCheckBox)
ffield.CheckBox.Value = True

Verwenden Sie FormFields(Index), um ein einzelnes FormField-Objekt zurückzugeben, wobei Index ein Textmarkenname oder eine Indexnummer ist. Im folgenden Beispiel wird das Ergebnis des Formularfelds "Text1" auf "Don Funk" festgelegt.

ActiveDocument.FormFields("Text1").Result = "Don Funk"

Die Indexnummer stellt die Position des Formularfelds in der Markierung, im Bereich oder im Dokument dar. Im folgenden Beispiel wird der Name des ersten Formularfelds in der Markierung angezeigt.

If Selection.FormFields.Count >= 1 Then
    MsgBox Selection.FormFields(1).Name
End If


Frame-Objekt

Stellt einen Positionsrahmen dar. Das Frame-Objekt ist ein Element der Frames-Auflistung. Die Frames-Auflistung enthält alle Positionsrahmen in einer Markierung, einem Bereich oder einem Dokument.

Verwendung des Frame-Objekts

Verwenden Sie Frames(Index), um ein einzelnes Frame-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Positionsrahmens in der Markierung, im Bereich oder im Dokument dar. Das folgende Beispiel lässt Text um den ersten Positionsrahmen im aktiven Dokument fließen.

ActiveDocument.Frames(1).TextWrap = True

Verwenden Sie die Add-Methode, wenn Sie einen Positionsrahmen um einen Bereich einfügen möchten. Im folgenden Beispiel wird um den ersten Absatz im aktiven Dokument ein Positionsrahmen eingefügt.

ActiveDocument.Frames.Add _
    Range:=ActiveDocument.Paragraphs(1).Range

Hinweise

Sie können Text um ein Shape- oder ein ShapeRange-Objekt fließen lassen, indem Sie die WrapFormat-Eigenschaft verwenden. Sie können ein Shape- oder ein ShapeRange-Objekt positionieren, indem Sie die Top- und die Left-Eigenschaft verwenden.


Frames-Objekt (Auflistung)

Eine Auflistung von Frame-Objekten in einer Markierung, einem Bereich oder einem Dokument.

Verwendung der Frames-Auflistung

Verwenden Sie die Frames-Eigenschaft, um die Frames-Auflistung zurückzugeben. Im folgenden Beispiel werden die Rahmenlinien von allen Positionsrahmen im aktiven Dokument entfernt.

For Each aFrame In ActiveDocument.Frames
    aFrame.Borders.Enable = False
Next aFrame

Verwenden Sie die Add-Methode, wenn Sie einen Positionsrahmen um einen Bereich einfügen möchten. Im folgenden Beispiel wird um den ersten Absatz im aktiven Dokument ein Positionsrahmen eingefügt.

ActiveDocument.Frames.Add _
    Range:=ActiveDocument.Paragraphs(1).Range

Verwenden Sie Frames(Index), um ein einzelnes Frame-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Positionsrahmens in der Markierung, im Bereich oder im Dokument dar. Das folgende Beispiel lässt Text um den ersten Positionsrahmen im ersten Abschnitt des aktiven Dokuments fließen.

ActiveDocument.Sections(1).Range.Frames(1).TextWrap = True

Hinweise

Sie können Text um ein Shape- oder ein ShapeRange-Objekt fließen lassen, indem Sie die WrapFormat-Eigenschaft verwenden. Sie können ein Shape- oder ein ShapeRange-Objekt positionieren, indem Sie die Top- und die Left-Eigenschaft verwenden.

Die Count-Eigenschaft für die Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Hauptkomponente zurück. Mit dem Range-Objekt können Sie Elemente in anderen Dokumentkomponenten zählen.


Frameset-Objekt

Stellt eine gesamte Framesseite oder einen einzelnen Frame auf einer Framesseite dar. Es ist keine Framesets-Auflistung vorhanden; jedes Document- oder Pane-Objekt enthält nur ein Frameset-Objekt.

Verwendung des Frameset-Objekts

Verwenden Sie die Frameset-Eigenschaft, um das Frameset-Objekt zurückzugeben. Bei Eigenschaften oder Methoden, die alle Frames auf einer Framesseite betreffen, verwenden Sie das Frameset-Objekt des Document-Objekts (ActiveWindow.Document.Frameset). Bei Eigenschaften oder Methoden, die einzelne Frames auf einer Framesseite betreffen, verwenden Sie das Frameset-Objekt des Pane-Objekts (ActiveWindow.ActivePane.Frameset).

In diesem Beispiel wird eine Datei mit dem Namen Proposal.doc geöffnet, eine auf der Datei beruhende Framesseite erstellt und ein Frame (links auf der Seite) mit einem Inhaltsverzeichnis für die Datei hinzugefügt.

Documents.Open "C:\My Documents\proposal.doc"
ActiveDocument.ActiveWindow.ActivePane.NewFrameset
ActiveDocument.ActiveWindow.ActivePane.TOCInFrameset

In diesem Beispiel wird rechts neben dem angegebenen Frame ein neuer Frame hinzugefügt.

ActiveDocument.ActiveWindow.ActivePane.Frameset _
    .AddNewFrame wdFramesetNewRight

In diesem Beispiel wird als Name des dritten untergeordneten Frameset-Objekts der Framesseite "BottomFrame" festgelegt.

ActiveWindow.Document.Frameset _
    .ChildFramesetItem(3).FrameName = "BottomFrame"

In diesem Beispiel wird der angegebene Frame mit einer lokalen Datei namens Order.htm. verknüpft. Es wird festgelegt, dass der Frame in der Größe geändert werden kann, mit Bildlaufleisten in einem Webbrowser angezeigt wird und 25 Prozent der Höhe des aktiven Fensters einnimmt.

With ActiveDocument.ActiveWindow.ActivePane.Frameset
    .FrameDefaultURL = "C:\My Documents\order.htm"
    .FrameLinkToFile = True
    .FrameResizable = True
    .FrameScrollbarType = wdScrollbarTypeYes
    .HeightType = wdFramesetSizeTypePercent
    .Height = 25
End With

In diesem Beispiel wird Microsoft Word so eingestellt, dass Framerahmenlinien auf der angegebenen Framesseite angezeigt werden.

ActiveDocument.ActiveWindow.ActivePane.Frameset _
    .FrameDisplayBorders = True

In diesem Beispiel wird für die Framerahmenlinien auf der Framesseite eine Breite von 6 Punkt und die Farbe Gelbbraun festgelegt.

With ActiveWindow.Document.Frameset
    .FramesetBorderColor = wdColorTan
    .FramesetBorderWidth = 6
End With

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


FreeformBuilder-Objekt

Repräsentiert die Geometrie einer Freihandform, während sie konstruiert wird.

Verwendung von FreeformBuilder-Objekten

Verwenden Sie die BuildFreeform-Methode, um ein FreeformBuilder-Objekt zurückzugeben. Verwenden Sie die AddNodes-Methode, um Knoten zu einer Freihandform hinzuzufügen. Verwenden Sie die ConvertToShape-Methode, um die Form zu erstellen, die im FreeformBuilder-Objekt definiert wurde, und um sie in die Shapes-Auflistung zu übernehmen. Im folgenden Beispiel wird eine Freihandform mit vier Segmenten zu dem aktiven Dokument hinzugefügt.

With ActiveDocument.Shapes _
        .BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Global-Objekt

Enthält Eigenschaften und Methoden der obersten Ebene, denen nicht die Application-Eigenschaft vorausgehen muss. So haben z. B. die folgenden beiden Anweisungen das gleiche Ergebnis:

Documents(1).Content.Bold = True
Application.Documents(1).Content.Bold = True


GroupShapes-Objekt (Auflistung)

Repräsentiert die einzelnen Formen in einer gruppierten Form. Jede Form wird von einem Shape-Objekt dargestellt. Wenn Sie diesem Objekt die Item-Methode zuweisen, können Sie mit einzelnen Formen in einer Gruppe arbeiten, ohne die Gruppierung aufzuheben.

Verwendung der Groupshapes-Auflistung

Verwenden Sie die GroupItems-Eigenschaft, um die GroupShapes-Auflistung zurückzugeben. Verwenden Sie GroupItems(Index) mit Index als Nummer der einzelnen Form in einer gruppierten Form, um eine einzelne Form aus der GroupShapes-Auflistung zurückzugeben. Im folgenden Beispiel werden zu dem aktiven Dokument drei Dreiecke hinzugefügt. Sie werden gruppiert, und eine Farbe wird für die gesamte Gruppe festgelegt. Anschließend wird nur die Farbe für das zweite Dreieck geändert.

With ActiveDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, _
        10, 10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, _
        150, 10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, _
        300, 10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


HangulAndAlphabetException-Objekt

Sprachspezifische Informationen

HangulAndAlphabetExceptions collection (HangulAndAlphabetException object)

Represents a single hangul or alphabet AutoCorrect exception. The HangulAndAlphabetException object is a member of the HangulAndAlphabetExceptions collection. The HangulAndAlphabetExceptions collection includes all hangul or alphabet AutoCorrect exceptions and corresponds to the items listed on the Korean tab in the AutoCorrect Exceptions dialog box (AutoCorrect command, Tools menu).

Using the HangulAndAlphabetException Object

Use HangulAndAlphabetExceptions(index), where index is the hangul or alphabet AutoCorrect exception name or the index number, to return a single HangulAndAlphabetException object. The following example deletes the alphabet AutoCorrect exception named "hello."

AutoCorrect.HangulAndAlphabetExceptions("hello").Delete

The index number represents the position of the hangul or alphabet AutoCorrect exception in the HangulAndAlphabetExceptions collection. The following example displays the name of the first item in the HangulAndAlphabetExceptions collection.

MsgBox AutoCorrect.HangulAndAlphabetExceptions(1).Name

If the value of the HangulAndAlphabetAutoAdd property is True, words are automatically added to the list of hangul and alphabet AutoCorrect exceptions. Use the Add method to add an item to the HangulAndAlphabetExceptions collection. The following example adds "goodbye" to the list of alphabet AutoCorrect exceptions.

AutoCorrect.HangulAndAlphabetExceptions.Add Name:="goodbye"

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


HangulAndAlphabetExceptions-Auflistungsobjekt

Sprachspezifische Informationen

HangulAndAlphabetExceptions collection (HangulAndAlphabetException object)

A collection of HangulAndAlphabetException objects that represent all hangul or alphabet AutoCorrect exceptions. This list corresponds to the list of AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box (AutoCorrect command, Tools menu).

Using the HangulAndAlphabetExceptions Collection

Use the HangulAndAlphabetExceptions property to return the HangulAndAlphabetExceptions collection. The following example displays the items in this collection.

For Each aHan In AutoCorrect.HangulAndAlphabetExceptions
    MsgBox aHan.Name
Next aHan

If the value of the HangulAndAlphabetAutoAdd property is True, words are automatically added to the list of hangul and alphabet AutoCorrect exceptions. Use the Add method to add an item to the HangulAndAlphabetExceptions collection. The following example adds "hello" to the list of alphabet AutoCorrect exceptions.

AutoCorrect.HangulAndAlphabetExceptions.Add Name:="hello"

Use HangulAndAlphabetExceptions(index), where index is the hangul or alphabet AutoCorrect exception name or the index number, to return a single HangulAndAlphabetException object. The following example deletes the alphabet AutoCorrect exception named "goodbye."

AutoCorrect.HangulAndAlphabetExceptions("goodbye").Delete

The index number represents the position of the hangul or alphabet AutoCorrect exception in the HangulAndAlphabetExceptions collection. The following example displays the name of the first item in the HangulAndAlphabetExceptions collection.

MsgBox AutoCorrect.HangulAndAlphabetExceptions(1).Name

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


HangulHanjaConversionDictionaries-Objekt (Auflistung)

Sprachspezifische Informationen

HangulHanjaConversionDictionaries collection (Dictionary object)

A collection of Dictionary objects that includes the active custom hangul-hanja conversion dictionaries.

Using the HangulHanjaConversionDictionaries Collection

Use the HangulHanjaDictionaries property to return the collection of currently active custom conversion dictionaries. The following example displays the names of all the active custom conversion dictionaries.

For Each d In HangulHanjaDictionaries
    Msgbox d.Name
Next d

Use the Add method to add a new custom conversion dictionary to the collection of active custom conversion dictionaries. If there isn't a file with the name specified by FileName, Microsoft Word creates it. The following example adds "Hanja1.hhd" to the collection of custom conversion dictionaries.

CustomDictionaries.Add FileName:="Hanja1.hhd"

Use the ClearAll method to unload all custom conversion dictionaries. Note, however, that this method doesn't delete the dictionary files. After you use this method, the number of custom conversion dictionaries in the collection is 0 (zero). The following example clears the custom conversion dictionaries and creates a new custom conversion dictionary file. The new dictionary is set as the active custom dictionary, to which Word will automatically add any new words it encounters.

With HangulHanjaDictionaries
    .ClearAll
    .Add FileName:= "Hanja1.hhd"
    .ActiveCustomDictionary = HangulHanjaDictionaries(1)
End With

Remarks

You set the custom dictionary to which new words are added by using the ActiveCustomDictionary property. If you try to set this property to a dictionary that isn't a custom conversion dictionary, an error occurs.

The Maximum property returns the maximum number of simultaneous custom conversion dictionaries that the application can support. For Word, this maximum is 10.

For more information on using Word with East Asian languages, see Word features for East Asian languages.


HeaderFooter-Objekt

Stellt eine einzelne Kopf- oder Fußzeile dar. Das HeaderFooter-Objekt ist ein Element der HeaderFooters-Auflistung. Die HeaderFooters-Auflistung enthält alle Kopf- und Fußzeilen im angegebenen Dokumentabschnitt.

Verwendung des HeaderFooter-Objekts

Verwenden Sie Headers(Index) oder Footers(Index), um ein einzelnes HeaderFooter-Objekt zurückzugeben, wobei Index eine der WdHeaderFooterIndex-Konstanten (wdHeaderFooterEvenPages, wdHeaderFooterFirstPage oder wdHeaderFooterPrimary) ist. Im folgenden Beispiel wird der Text der ersten Kopfzeile und der ersten Fußzeile im ersten Abschnitt des aktiven Dokuments geändert.

With ActiveDocument.Sections(1)
    .Headers(wdHeaderFooterPrimary).Range.Text = "Header text"
    .Footers(wdHeaderFooterPrimary).Range.Text = "Footer text"
End With

Sie können auch ein einzelnes HeaderFooter-Objekt zurückgeben, indem Sie die HeaderFooter-Eigenschaft mit einem Selection-Objekt verwenden.

Anmerkung Sie können zu der HeaderFooters-Auflistung keine HeaderFooter-Objekte hinzufügen.

Hinweise

Verwenden Sie die DifferentFirstPageHeaderFooter-Eigenschaft mit dem PageSetup-Objekt, um die erste Seite abweichend von den anderen Seiten festzulegen. Im folgenden Beispiel wird in die Fußzeile der ersten Seite im aktiven Dokument Text eingefügt.

With ActiveDocument
    .PageSetup.DifferentFirstPageHeaderFooter = True
    .Sections(1).Footers(wdHeaderFooterFirstPage) _
        .Range.InsertBefore _
        "Written by Joe Smith"
End With

Verwenden Sie die OddAndEvenPagesHeaderFooter-Eigenschaft mit dem PageSetup-Objekt, um für gerade und ungerade Seiten unterschiedliche Kopf- und Fußzeilen anzugeben. Wenn für die OddAndEvenPagesHeaderFooter-Eigenschaft True festgelegt ist, können Sie eine ungerade Kopf- oder Fußzeile zurückgeben, indem Sie wdHeaderFooterPrimary verwenden, und Sie können eine gerade Kopf- oder Fußzeile zurückgeben, indem Sie wdHeaderFooterEvenPages verwenden.

Verwenden Sie die Add-Methode mit dem PageNumbers-Objekt, um zu einer Kopf- oder Fußzeile eine Seitenzahl hinzuzufügen. Im folgenden Beispiel werden zu der ersten Fußzeile im ersten Abschnitt des aktiven Dokuments Seitenzahlen hinzugefügt.

With ActiveDocument.Sections(1)
    .Footers(wdHeaderFooterPrimary).PageNumbers.Add
End With


HeadersFooters-Objekt (Auflistung)

Eine Auflistung von HeaderFooter-Objekten, die die Kopf- oder Fußzeilen im angegebenen Abschnitt eines Dokuments darstellen.

Verwendung der HeaderFooters-Auflistung

Verwenden Sie die Headers- oder Footers-Eigenschaft, um die HeaderFooters-Auflistung zurückzugeben. Im folgenden Beispiel wird der Text der ersten Fußzeile im ersten Abschnitt des aktiven Dokuments angezeigt.

With ActiveDocument.Sections(1).Footers(wdHeaderFooterPrimary)
    If .Range.Text <> vbCr Then
        MsgBox .Range.Text
    Else
        MsgBox "Footer is empty"
    End If
End With

Anmerkung Sie können zu der HeaderFooters-Auflistung keine HeaderFooter-Objekte hinzufügen.

Verwenden Sie Headers(Index) oder Footers(Index), um ein einzelnes HeaderFooter-Objekt zurückzugeben, wobei Index eine der WdHeaderFooterIndex-Konstanten (wdHeaderFooterEvenPages, wdHeaderFooterFirstPage oder wdHeaderFooterPrimary) ist. Im folgenden Beispiel wird der Text der ersten Kopfzeile und der ersten Fußzeile im ersten Abschnitt des aktiven Dokuments geändert.

With ActiveDocument.Sections(1)
    .Headers(wdHeaderFooterPrimary).Range.Text = "Header text"
    .Footers(wdHeaderFooterPrimary).Range.Text = "Footer text"
End With

Sie können auch ein einzelnes HeaderFooter-Objekt zurückgeben, indem Sie die HeaderFooter-Eigenschaft mit einem Selection-Objekt verwenden.

Hinweise

Verwenden Sie die DifferentFirstPageHeaderFooter-Eigenschaft mit dem PageSetup-Objekt, um die erste Seite abweichend von den anderen Seiten festzulegen. Im folgenden Beispiel wird in die Fußzeile der ersten Seite des aktiven Dokuments Text eingefügt.

With ActiveDocument
    .PageSetup.DifferentFirstPageHeaderFooter = True
    .Sections(1).Footers(wdHeaderFooterFirstPage) _
        .Range.InsertBefore _
        "Written by Kate Edson"
End With

Verwenden Sie die OddAndEvenPagesHeaderFooter-Eigenschaft mit dem PageSetup-Objekt, um für gerade und ungerade Seiten unterschiedliche Kopf- und Fußzeilen anzugeben. Wenn die OddAndEvenPagesHeaderFooter-Eigenschaft auf True eingestellt ist, können Sie eine ungerade Kopf- oder Fußzeile zurückgeben, indem Sie wdHeaderFooterPrimary verwenden, und Sie können eine gerade Kopf- oder Fußzeile zurückgeben, indem Sie wdHeaderFooterEvenPages verwenden.

Verwenden Sie die Add-Methode mit dem PageNumbers-Objekt, um zu einer Kopf- oder Fußzeile eine Seitenzahl hinzuzufügen. Im folgenden Beispiel werden zu der Fußzeile der ersten Seite im ersten Abschnitt des aktiven Dokuments Seitenzahlen hinzugefügt.

With ActiveDocument.Sections(1)
    .PageSetup.DifferentFirstPageHeaderFooter = True
    .Footers(wdHeaderFooterPrimary).PageNumbers.Add _
        FirstPage:=True
End With


HeadingStyle-Objekt

Stellt eine Formatvorlage dar, die verwendet wird, um ein Inhalts- oder Abbildungsverzeichnis zu erstellen. Das HeadingStyle-Objekt ist ein Element der HeadingStyles-Auflistung.

Verwendung des HeadingStyle-Objekts

Verwenden Sie HeadingStyles(Index), um ein einzelnes HeadingStyle-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Formatvorlage in der HeadingStyles-Auflistung dar. Im folgenden Beispiel wird (am Beginn des aktiven Dokuments) ein aus der Formatvorlage "Title" erstelltes Abbildungsverzeichnis hinzugefügt. Anschließend wird der Name der ersten Formatvorlage in der HeadingStyles-Auflistung angezeigt.

Set myTOF = ActiveDocument.TablesOfFigures.Add _
    (Range:=ActiveDocument.Range(0, 0), AddedStyles:="Title")
MsgBox myTOF.HeadingStyles(1).Style

Verwenden Sie die Add-Methode, um der HeadingStyles-Auflistung eine Formatvorlage hinzuzufügen. Im folgenden Beispiel wird am Beginn des aktiven Dokuments ein Inhaltsverzeichnis eingefügt. Anschließend wird die Formatvorlage "Title" zu der Liste der Formatvorlagen hinzugefügt, die zur Erstellung eines Inhaltsverzeichnisses verwendet werden.

Set myToc = ActiveDocument.TablesOfContents.Add _
    (Range:=ActiveDocument.Range(0, 0), UseHeadingStyles:=True, _
     LowerHeadingLevel:=3, UpperHeadingLevel:=1)
myToc.HeadingStyles.Add Style:="Title", Level:=2


HeadingStyles-Objekt (Auflistung)

Eine Auflistung von HeadingStyle-Objekten, die die Formatvorlagen darstellen, die für die Erstellung eines Abbildungs- oder Inhaltsverzeichnisses verwendet werden.

Verwendung der HeadingStyles-Auflistung

Verwenden Sie die HeadingStyles-Eigenschaft, um die HeadingStyles-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Elemente in der HeadingStyles-Auflistung für das erste Inhaltsverzeichnis im aktiven Dokument angezeigt.

MsgBox ActiveDocument.TablesOfContents(1).HeadingStyles.Count

Verwenden Sie die Add-Methode, um zu der HeadingStyles-Auflistung eine Formatvorlage hinzuzufügen. Im folgenden Beispiel wird am Beginn des aktiven Dokuments ein Inhaltsverzeichnis eingefügt. Anschließend wird die Formatvorlage "Title" zu der Liste der Formatvorlagen hinzugefügt, die für die Erstellung eines Inhaltsverzeichnisses verwendet werden.

Set myToc = ActiveDocument.TablesOfContents.Add _
    (Range:=ActiveDocument.Range(0, 0), UseHeadingStyles:=True, _
     LowerHeadingLevel:=3, UpperHeadingLevel:=1)
myToc.HeadingStyles.Add Style:="Title", Level:=2

Verwenden Sie HeadingStyles(Index), um ein einzelnes HeadingStyle-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Formatvorlage in der HeadingStyles-Auflistung dar. Im folgenden Beispiel wird (am Beginn des aktiven Dokuments) ein Abbildungsverzeichnis eingefügt, das aus der Formatvorlage "Title" erstellt wurde. Anschließend wird der Name der ersten Formatvorlage in der HeadingStyles-Auflistung angezeigt.

Set myTOF = ActiveDocument.TablesOfFigures.Add _
    (Range:=ActiveDocument.Range(0, 0), AddedStyles:="Title")
MsgBox myTOF.HeadingStyles(1).Style


HorizontalLineFormat-Objekt

Stellt eine Formatierung für horizontale Linien dar.

Verwendung des HorizontalLineFormat-Objekts

Verwenden Sie die HorizontalLineFormat-Eigenschaft, um ein HorizontalLineFormat-Objekt zurückzugeben. In diesem Beispiel wird die Ausrichtung für eine neue horizontale Linie festgelegt.

Selection.InlineShapes.AddHorizontalLineStandard
ActiveDocument.InlineShapes(1) _
    .HorizontalLineFormat.Alignment = _
    wdHorizontalLineAlignLeft

In diesem Beispiel wird eine horizontale Linie ohne 3D-Schattierung hinzugefügt.

Selection.InlineShapes.AddHorizontalLineStandard
ActiveDocument.InlineShapes(1) _
    .HorizontalLineFormat.NoShade = True

In diesem Beispiel wird eine horizontale Linie hinzugefügt, deren Länge auf 50 Prozent der Fensterbreite festgelegt wird.

Selection.InlineShapes.AddHorizontalLineStandard
ActiveDocument.InlineShapes(1) _
    .HorizontalLineFormat.PercentWidth = 50


Hyperlink-Objekt

Stellt einen Hyperlink dar. Das Hyperlink-Objekt ist ein Element der Hyperlinks-Auflistung.

Verwendung des Hyperlink-Objekts

Mit der Hyperlink-Eigenschaft können Sie ein Hyperlink-Objekt zurückgeben, das einer Form zugewiesen wird, die nur einen Hyperlink haben darf. Das folgende Beispiel aktiviert den Hyperlink, der der ersten Form im aktiven Dokument zugewiesen ist.

ActiveDocument.Shapes(1).Hyperlink.Follow

Mit Hyperlinks(Index) können Sie ein einzelnes Hyperlink-Objekt aus einem Dokument, Bereich oder einer Markierung zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel aktiviert den ersten Hyperlink in der Markierung.

If Selection.HyperLinks.Count >= 1 Then
    Selection.HyperLinks(1).Follow
End If


Hyperlinks-Objekt (Auflistung)

Stellt die Auflistung mit Hyperlink-Objekten in einem Dokument, Bereich oder einer Markierung dar.

Verwendung der Hyperlinks-Auflistung

Mit der Hyperlinks-Eigenschaft können Sie die Hyperlinks-Auflistung zurückgeben. Das folgende Beispiel prüft bei allen Hyperlinks in Dokument 1, ob eine Verknüpfung existiert, die das Wort "Microsoft" in der Adresse enthält. Wird ein Hyperlink gefunden, wird dieser mit der Follow-Methode aktiviert.

For Each hLink In Documents(1).Hyperlinks
    If InStr(hLink.Address, "Microsoft") <> 0 Then
        hLink.Follow
        Exit For
    End If
Next hLink

Mit der Add-Methode können Sie einen Hyperlink erstellen und zu der Hyperlinks-Auflistung hinzufügen. Das folgende Beispiel erstellt einen neuen Hyperlink zur MSN Website.

ActiveDocument.Hyperlinks.Add Address:="http://www.msn.com/", _
    Anchor:=Selection.Range

Mit Hyperlinks(Index), können Sie ein einzelnes Hyperlink-Objekt in einem Dokument, Bereich oder einer Markierung zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel aktiviert den ersten Hyperlink in der Markierung.

If Selection.HyperLinks.Count >= 1 Then
    Selection.HyperLinks(1).Follow
End If

Hinweise

Die Count-Eigenschaft gibt für diese Auflistung in einem Dokument nur die Anzahl der Elemente im Haupttext zurück. Mit der Auflistung und dem Range-Objekt können Sie Elemente in anderen Komponenten zählen.


Index-Objekt

Stellt einen einzelnen Index dar. Das Index-Objekt ist ein Element der Indexes-Auflistung. Die Indexes-Auflistung enthält alle Indexe im angegebenen Dokument.

Verwendung des Index-Objekts

Verwenden Sie Indexes(Index), um ein einzelnes Index-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Index-Objekts im Dokument dar. Im folgenden Beispiel wird der erste Index im aktiven Dokument aktualisiert.

If ActiveDocument.Indexes.Count >= 1 Then
    ActiveDocument.Indexes(1).Update
End If

Verwenden Sie die Add-Methode, um einen Index zu erstellen und ihn der Indexes-Auflistung hinzuzufügen. Im folgenden Beispiel wird am Ende des aktiven Dokuments ein Index erstellt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.Indexes.Add Range:=myRange, Type:=wdIndexRunin


Indexes-Objekt (Auflistung)

Eine Auflistung von Index-Objekten, die alle Indexe im angegebenen Dokument darstellen.

Verwendung der Indexes-Auflistung

Verwenden Sie die Indexes-Eigenschaft, um die Indexes-Auflistung zurückzugeben. Im folgenden Beispiel werden Indexe im aktiven Dokument im Format "Klassisch" formatiert.

ActiveDocument.Indexes.Format = wdIndexClassic

Verwenden Sie die Add-Methode, um einen Index zu erstellen und ihn der Indexes-Auflistung hinzuzufügen. Im folgenden Beispiel wird am Ende des aktiven Dokuments ein Index erstellt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.Indexes.Add Range:=myRange, Type:=wdIndexRunin

Verwenden Sie Indexes(Index), um ein einzelnes Index-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Index-Objekts im Dokument dar. Im folgenden Beispiel wird der erste Index im aktiven Dokument aktualisiert.

If ActiveDocument.Indexes.Count >= 1 Then
    ActiveDocument.Indexes(1).Update
End If


InlineShape-Objekt

Stellt ein Objekt in der Textebene eines Dokuments dar. Bei einer Inlineform kann es sich lediglich um ein Bild, ein OLE-Objekt oder ein ActiveX-Steuerelement handeln. InlineShape-Objekte werden wie Zeichen behandelt und wie Zeichen innerhalb einer Textzeile positioniert. Das InlineShape-Objekt ist ein Element der InlineShapes-Auflistung. Die InlineShapes-Auflistung enthält alle Formen in einem Dokument, einem Bereich oder einer Markierung.

Verwendung von InlineShape-Objekten

Verwenden Sie InlineShapes(Index). Dabei ist Index die Indexnummer, mit der ein einzelnes InlineShape-Objekt zurückgegeben wird. Inlineformen haben keine Namen. Im folgenden Beispiel wird die erste Inlineform im aktiven Dokument aktiviert.

ActiveDocument.InlineShapes(1).Activate

Hinweise

Shape-Objekte sind mit einem Textbereich verankert, aber frei beweglich und können an beliebiger Stelle auf der Seite positioniert werden. Mit der ConvertToInlineShape- und der ConvertToShape-Methode können Sie Formen eines Typs in Formen eines anderen Typs umwandeln. Sie können nur Bilder, OLE-Objekte und ActiveX-Steuerelemente in Inlineformen umwandeln. Verwenden Sie die Type-Eigenschaft, um den Typ einer Inlineform zurückzugeben: Bild, verknüpftes Bild, eingebettetes OLE-Objekt, verknüpftes OLE-Objekt oder ActiveX-Steuerelement.

Wenn Sie ein Dokument öffnen, das in einer früheren Version von Word erstellt wurde, werden Bilder zu Inlineformen konvertiert.


InlineShapes-Objekt (Auflistung)

Eine Auflistung von InlineShape-Objekten, die alle Inlineformen in einem Dokument, einem Bereich oder einer Markierung darstellt.

Verwendung der InlineShapes-Auflistung

Verwenden Sie die InlineShapes-Eigenschaft, um die InlineShapes-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Inlineformen im aktiven Dokument in Shape-Objekte umgewandelt.

For Each iShape In ActiveDocument.InlineShapes
    iShape.ConvertToShape
Next iShape

Verwenden Sie die New-Methode, um ein neues Bild als Inlineform zu erstellen. Mit der AddPicture- und der AddOLEObject-Methode können Sie Bilder oder OLE-Objekte hinzufügen und mit einer Quelldatei verknüpfen. Verwenden Sie die AddOLEControl-Methode, um ein ActiveX-Steuerelement hinzuzufügen.

Hinweise

Shape-Objekte sind mit einem Textbereich verankert, aber frei beweglich und können an beliebiger Stelle auf der Seite positioniert werden. Mit der ConvertToInlineShape- und der ConvertToShape-Methode können Sie Formen eines Typs in Formen eines anderen Typs umwandeln. Sie können nur Bilder, OLE-Objekte und ActiveX-Steuerelemente in Inlineformen umwandeln.

Die Count-Eigenschaft für diese Auflistung in einem Dokument gibt nur die Anzahl der Elemente im Haupttextbereich zurück. Um die Elemente anderer Textkomponenten zu zählen, verwenden Sie die Auflistung mit dem Range-Objekt.

Wenn Sie ein Dokument öffnen, das in einer früheren Version von Word erstellt wurde, werden Bilder zu Inlineformen konvertiert.


KeyBinding-Objekt

Stellt eine benutzerdefinierte Tastenbelegung im aktuellen Kontext dar. Das KeyBinding-Objekt ist ein Element der KeyBindings-Auflistung. Benutzerdefinierte Tastenbelegungen werden im Dialogfeld Tastatur anpassen erstellt.

Verwendung des KeyBinding-Objekts

Mit KeyBindings(Index) können Sie ein einzelnes KeyBinding-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel zeigt den Befehl an, der dem ersten KeyBinding-Objekt in der KeyBindings-Auflistung zugewiesen wurde.

MsgBox KeyBindings(1).Command

Sie können auch mit der FindKey-Eigenschaft und der Key-Methode ein KeyBinding-Objekt zurückgeben.


KeyBindings-Objekt (Auflistung)

Eine Auflistung mit KeyBinding-Objekten, die die benutzerdefinierten Tastenbelegungen im aktuellen Kontext darstellen. Benutzerdefinierte Tastenbelegungen werden im Dialogfeld Tastatur anpassen erstellt.

Verwendung der KeyBindings-Auflistung

Mit der KeyBindings-Eigenschaft können Sie die KeyBindings-Auflistung zurückgeben. Das folgende Beispiel fügt nach der Markierung den Namen des Befehls und die Tastenkombination für jedes Element der KeyBindings-Auflistung ein.

CustomizationContext = NormalTemplate
For Each aKey In KeyBindings
    Selection.InsertAfter aKey.Command & vbTab _
        & aKey.KeyString & vbCr
    Selection.Collapse Direction:=wdCollapseEnd
Next aKey

Mit der Add-Methode können Sie der KeyBindings-Auflistung ein KeyBinding-Objekt hinzufügen. Das folgende Beispiel fügt die Tastenkombination STRG+ALT+H der Formatvorlage "Überschrift 1" im aktiven Dokument hinzu.

CustomizationContext = ActiveDocument
KeyBindings.Add KeyCategory:=wdKeyCategoryStyle, _
    Command:="Heading 1", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyH)

Mit KeyBindings(Index), können Sie ein einzelnes KeyBinding-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel zeigt den Befehl an, der dem ersten KeyBinding-Objekt in der KeyBindings-Auflistung zugewiesen wurde.

MsgBox KeyBindings(1).Command


KeysBoundTo-Objekt (Auflistung)

Eine Auflistung mit KeyBinding-Objekten, die einem Befehl, einer Formatvorlage, einem Makro oder einem anderen Element im aktuellen Kontext zugewiesen sind.

Verwendung der KeysBoundTo-Auflistung

Mit der KeysBoundTo-Eigenschaft können Sie die KeysBoundTo-Auflistung zurückgeben. Das folgende Beispiel zeigt die Tastenkombinationen an, die dem Befehl FileNew in der Dokumentvorlage "Normal" zugewiesen sind.

CustomizationContext = NormalTemplate
For Each myKey In KeysBoundTo(KeyCategory:=wdKeyCategoryCommand, _
    Command:="FileNew")
    myStr = myStr & myKey.KeyString & vbCr
Next myKey
MsgBox myStr

Das folgende Beispiel zeigt den Namen des Dokuments oder der Vorlage an, in dem die Tasten für das Makro "Macro1" abgelegt sind.

Set kb = KeysBoundTo(KeyCategory:=wdKeyCategoryMacro, _
    Command:="Macro1")
MsgBox kb.Context.Name


Language-Objekt

Stellt eine Sprache dar, die bei der Korrektur oder Formatierung in Word verwendet wird. Das Language-Objekt ist ein Element der Languages-Auflistung.

Verwendung des Language-Objekts

Mit Languages(Index) können Sie ein einzelnes Language-Objekt zurückgeben. Dabei kann Index der Wert der Name-Eigenschaft, der Wert der NameLocal-Eigenschaft, eine der WdLanguageID-Konstanten oder eine der MsoLanguageID-Konstanten sein. (Eine Liste der gültigen WdLanguageID- und MsoLanguageID-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.)

Die Name-Eigenschaft gibt den Namen einer Sprache zurück, während die NameLocal-Eigenschaft den Namen einer Sprache in der Sprache des Benutzers zurückgibt. Im folgenden Beispiel wird in der deutschen Version von Word die Zeichenfolge "Italiano" für Name und "Italienisch Italien" für NameLocal zurückgegeben.

Msgbox Languages(wdItalian).Name
Msgbox Languages(wdItalian).NameLocal

Rückgabe der aktiven Wörterbücher für die Rechtschreibung

Mit der ActiveGrammarDictionary-, ActiveHyphenationDictionary-, ActiveSpellingDictionary- und ActiveThesaurusDictionary-Eigenschaft geben Sie die entsprechenden Dictionary-Objekte für alle Sprachen mit installierten Korrekturhilfen zurück. Im folgenden Beispiel wird der vollständige Pfad für das aktive Rechtschreibwörterbuch in der deutschen Version von Word zurückgegeben.

Set myspell = Languages(wdEnglishUS).ActiveSpellingDictionary
MsgBox mySpell.Path & Application.PathSeparator & mySpell.Name

Einstellen des Schreibstils

Der Schreibstil besteht aus einer Reihe von Regeln, die von der Grammatikprüfung benutzt werden. Die WritingStyleList-Eigenschaft gibt ein Datenfeld mit Zeichenfolgen zurück, die die verfügbaren Schreibstile für die angegebene Sprache darstellen. Im folgenden Beispiel wird die Liste der verfügbaren Schreibstile für US-Englisch zurückgegeben.

WrStyles = Languages(wdEnglishUS).WritingStyleList
For i = 1 To UBound(WrStyles)
    MsgBox WrStyles(i)
Next i

Mit der DefaultWritingStyle-Eigenschaft legen Sie den von Word zu verwendenden Standardschreibstil fest.

Languages(wdEnglishUS).DefaultWritingStyle = "Casual"

Mit der ActiveWritingStyle-Eigenschaft können Sie den Standardschreibstil überschreiben. Diese Eigenschaft wird dem angegebenen Dokument für Text in einer bestimmten Sprache zugewiesen. Im folgenden Beispiel wird der Schreibstil für die Überprüfung von englischen (U.S.), französischen und deutschen Textstellen im aktiven Dokument festgelegt.

With ActiveDocument
    .ActiveWritingStyle(wdEnglishUS) = "Technical"
    .ActiveWritingStyle(wdFrench) = "Commercial"
    .ActiveWritingStyle(wdGerman) = "Technisch/Wiss"
End With

Hinweise

Für jede zu überprüfende Sprache müssen Korrekturhilfen installiert werden. Weitere Informationen über das Arbeiten in anderen Sprachen finden Sie unter Sprachspezifische Informationen.

Wenn Sie Text als wdNoProofing markieren, überspringt Word bei der Rechtschreib- und Grammatikprüfung den markierten Text. Wenn Sie Text für eine bestimmte Sprache markieren oder keine Prüfung durchführen möchten, verwenden Sie den Befehl Sprache bestimmen (Menü Extras, Untermenü Sprache).


Languages-Objekt (Auflistung)

Eine Auflistung von Language-Objekten, die Sprachen für die Korrektur und Formatierung in Word darstellen.

Verwenden der Languages-Auflistung

Verwenden Sie die Languages-Eigenschaft, um die Languages-Auflistung zurückzugeben. Im folgenden Beispiel wird der lokalisierte Name für alle Sprachen angezeigt.

For Each la In Languages
    Msgbox la.NameLocal
Next la

Mit Languages(Index) können Sie ein einzelnes Language-Objekt zurückgeben. Dabei kann Index der Wert der Name-Eigenschaft, der Wert der NameLocal-Eigenschaft, eine der WdLanguageID-Konstanten oder eine der MsoLanguageID-Konstanten sein. (Eine Liste der gültigen WdLanguageID- und MsoLanguageID-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.)

Hinweise

Die Count-Eigenschaft gibt die Anzahl der Sprachen zur Formatierung von Text (Sprachen, für die Korrekturhilfen verfügbar sind) zurück. Für eine Überprüfung müssen Sie die entsprechenden Korrekturhilfen für jede zu überprüfende Sprache installieren. Für die folgenden Funktionen benötigen Sie sowohl eine .dll- als auch eine .lex-Datei: Thesaurus, Rechtschreibprüfung, Grammatikprüfung und Silbentrennung.

Wenn Sie Text mit wdNoProofing markieren, überspringt Word bei der Rechtschreib- und Grammatikprüfung den markierten Text. Wenn Sie Text für eine bestimmte Sprache markieren oder keine Prüfung durchführen möchten, verwenden Sie den Befehl Sprache bestimmen (Menü Extras, Untermenü Sprache).


LetterContent-Objekt

Stellt die Elemente eines Briefes dar, der vom Brief-Assistenten erstellt wurde.

Verwendung des LetterContent-Objekts

Mit der GetLetterContent-Methode oder der CreateLetterContent-Methode können Sie ein LetterContent-Objekt zurückgeben. Das folgende Beispiel ruft den Namen des Empfängers für den Brief aus dem aktiven Dokument ab und zeigt ihn an.

Set myLetterContent = ActiveDocument.GetLetterContent
MsgBox myLetterContent.RecipientName

Das folgende Beispiel verwendet die CreateLetterContent-Methode, um ein neues LetterContent-Objekt zu erstellen, das anschließend mit der RunLetterWizard-Methode verwendet wird.

Set myLetter = ActiveDocument _
    .CreateLetterContent(DateFormat:="July 11, 1996", _
    IncludeHeaderFooter:=False, _
    PageDesign:="C:\MSOffice\Templates\Letters & " _
        & "Faxes\Contemporary Letter.dot", _
    LetterStyle:=wdFullBlock, Letterhead:=True, _
    LetterheadLocation:=wdLetterTop, _
    LetterheadSize:=InchesToPoints(1.5), _
    RecipientName:="Dave Edson", _
    RecipientAddress:="100 Main St." & vbCr _
        & "Bellevue, WA 98004", _
    Salutation:="Dear Dave,", _
    SalutationType:=wdSalutationInformal, _
    RecipientReference:="", MailingInstructions:="", _
    AttentionLine:="", _
    Subject:="End of year report", CCList:="", ReturnAddress:="", _
    SenderName:="", Closing:="Sincerely yours,", _
    SenderCompany:="", _
    SenderJobTitle:="", SenderInitials:="", EnclosureNumber:=0)
ActiveDocument.RunLetterWizard _
    LetterContent:=myLetter, WizardMode:=True

Hinweise

Die CreateLetterContent-Methode erstellt ein LetterContent-Objekt. Es sind jedoch zahlreiche Argumente erforderlich. Wenn Sie lediglich einige Eigenschaften festlegen möchten, können Sie mit dem Schlüsselwort New ein neues, allein stehendes LetterContent-Objekt erstellen. Das folgende Beispiel erstellt ein LetterContent-Objekt, legt einige Eigenschaften fest, und verwendet anschließend das LetterContent-Objekt mit der RunLetterWizard-Methode, um den Brief-Assistenten zu starten. Die vordefinierten Werte werden als Standardeinstellungen übernommen.

Set myLetter = New LetterContent
With myLetter
    .AttentionLine = "Read this"
    .EnclosureNumber = 1
    .Letterhead = True
    .LetterheadLocation = wdLetterTop
    .LetterheadSize = InchesToPoints(2)
End With
Documents.Add.RunLetterWizard LetterContent:=myLetter, _
    WizardMode:=True

Sie können ein LetterContent-Objekt mit der Duplicate-Eigenschaft duplizieren. Das folgende Beispiel ruft die Briefelemente im aktiven Dokument ab und erstellt ein Duplikat. Das Beispiel ordnet das Duplikat zu aLetter zu und setzt den Namen und die Adresse des Empfängers auf leere Zeichenfolgen zurück. Die RunLetterWizard-Methode startet den Brief-Assistenten, wobei die Werte in dem überarbeiteten LetterContent-Objekt (aLetter) als Standardeinstellungen verwendet werden.

Set aLetter = ActiveDocument.GetLetterContent.Duplicate
With aLetter
    .RecipientName = ""
    .RecipientAddress = ""
End With
Documents.Add.RunLetterWizard LetterContent:=aLetter, _
    WizardMode:=True

Die SetLetterContent-Methode fügt den Inhalt des angegebenen LetterContent-Objekts in ein Dokument ein. Das folgende Beispiel ruft die Briefelemente aus dem aktiven Dokument ab, ändert die Anmerkungslinie und verwendet anschließend die SetLetterContent-Methode, um das aktive Dokument zu aktualisieren, indem die Änderungen übernommen werden.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.AttentionLine = "Greetings"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


LineFormat-Objekt

Repräsentiert die Formatierung einer Linie und einer Pfeilspitze. Für eine Linie enthält das LineFormat-Objekt Informationen zur Formatierung der Linie, für eine Form mit einem Rahmen enthält dieses Objekt die Informationen zur Formatierung des Rahmens.

Verwendung von LineFormat-Objekten

Verwenden Sie die Line-Eigenschaft, um ein LineFormat-Objekt zurückzugeben. Im folgenden Beispiel wird eine blaue, gestrichelte Linie zu dem aktiven Dokument hinzugefügt. Am Startpunkt der Linie befindet sich ein kurzes, schmales Oval und am Endpunkt ein langes Dreieck im Querformat.

With ActiveDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


LineNumbering-Objekt

Stellt die Zeilennummern am linken Rand oder jeweils links der Spalten im Zeitungsstil dar.

Verwendung des LineNumbering-Objekts

Verwenden Sie die LineNumbering-Eigenschaft, um das LineNumbering-Objekt zurückzugeben. Im folgenden Beispiel wird dem Text im ersten Abschnitt des aktiven Dokuments Zeilennummerierung zugewiesen.

With ActiveDocument.Sections(1).PageSetup.LineNumbering
    .Active = True
    .CountBy = 5
    .RestartMode = wdRestartPage
End With

Im folgenden Beispiel wird den Seiten im aktuellen Abschnitt Zeilennummerierung zugewiesen.

Selection.PageSetup.LineNumbering.Active = True


LinkFormat-Objekt

Stellt die Art und Weise dar, wie die Verknüpfung eines OLE-Objekts oder einer Grafik erfolgt.

Verwendung des LinkFormat-Objekts

Verwenden Sie die LinkFormat-Eigenschaft für eine Form, eine zeilenfixierte Form oder ein Feld zur Zurückgabe des LinkFormat-Objekts. Im folgenden Beispiel wird im aktiven Dokument die Verknüpfung für die erste Form aufgehoben.

ActiveDocument.Shapes(1).LinkFormat.BreakLink

Hinweise

Nicht alle Arten von Formen, zeilenfixierten Formen und Feldern können mit einer Quelle verknüpft werden. Verwenden Sie die Type-Eigenschaft für die Shape- und InlineShape-Objekte zum Ermitteln, ob eine bestimmte Form verknüpft werden kann. Die Type-Eigenschaft für ein Field-Objekt gibt die Feld-Kategorie zurück.

Sie können die Update-Methode und die AutoUpdate-Eigenschaft zum Aktualisieren von Verknüpfungen verwenden. Zur Zurückgabe oder zum Festlegen des vollständigen Pfades der Quelldatei einer bestimmten Verknüpfung verwenden Sie die SourceFullName-Eigenschaft.


List-Objekt

Stellt ein einzelnes Listenformat dar, das angegebenen Absätzen in einem Dokument zugewiesen wurde. Das List-Objekt ist ein Element der Lists-Auflistung.

Verwendung des List-Objekts

Verwenden Sie Lists(Index), um ein einzelnes List-Objekt zurückzugeben, wobei Index für die Indexnummer steht. Im folgenden Beispiel wird die Anzahl der Elemente in Liste eins im aktiven Dokument zurückgegeben.

mycount = ActiveDocument.Lists(1).CountNumberedItems

Um alle Absätze, die Listenformatierungen enthalten, zurückzugeben, verwenden Sie die ListParagraphs-Eigenschaft. Um die Absätze als Bereich zurückzugeben, verwenden Sie die Range-Eigenschaft.

Hinweise

Verwenden Sie die ApplyListTemplate-Methode mit dem List-Objekt, um einer vorhandenen Liste ein anderes Listenformat zuzuweisen. Um zu einem Dokument eine neue Liste hinzuzufügen, verwenden Sie die ApplyListTemplate-Methode mit dem ListFormat-Objekt für einen angegebenen Bereich.

Verwenden Sie die CanContinuePreviousList-Methode, um festzustellen, ob Sie die Listenformatierung von einer zuvor dem Dokument zugewiesenen Liste fortsetzen können.

Verwenden Sie die CountNumberedItems-Methode, um die Anzahl der Elemente in einer Aufzählung oder einer nummerierten Liste zurückzugeben, einschließlich der LISTNUM-Felder.

Um festzustellen, ob eine Liste mehrere Listenvorlagen enthält, verwenden Sie die SingleListTemplate-Eigenschaft.

Sie können die einzelnen List-Objekte innerhalb eines Dokuments bearbeiten, jedoch empfiehlt es sich, mit dem ListFormat -Objekt zu arbeiten, um genauere Einstellungen vornehmen zu können.

Listen mit Bildaufzählungszeichen sind in der Lists-Auflistung nicht enthalten und können mit dem List-Objekt nicht verändert werden.


Lists-Objekt (Auflistung)

Eine Auflistung von List-Objekten, die alle Listen im angegebenen Dokument darstellt.

Verwenden der Lists-Auflistung

Verwenden Sie die Lists-Eigenschaft, um die Lists-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Elemente in jeder einzelnen Liste des aktiven Dokuments angezeigt.

For Each li In ActiveDocument.Lists
    MsgBox li.CountNumberedItems
Next li

Mit Lists(Index) können Sie ein einzelnes List-Objekt zurückgeben, wobei Index die Indexnummer ist. Im folgenden Beispiel wird der zweiten Liste im aktiven Dokument das erste Listenformat (None ausgenommen) auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungszeichen zugewiesen.

Set temp1 = ListGalleries(wdNumberGallery).ListTemplates(1)
ActiveDocument.Lists(2).ApplyListTemplate ListTemplate:=temp1

Hinweise

Wenn Sie zum Zählen der Lists-Auflistung die For Each...Next-Schleife verwenden, werden die Listen in einem Dokument in umgekehrter Reihenfolge zurückgegeben. Im folgenden Beispiel werden die Einträge jeder einzelnen Liste im aktiven Dokument gezählt, beginnend am Ende des Dokuments.

For Each li In ActiveDocument.Lists
   MsgBox li.CountNumberedItems
Next li

Zum Hinzufügen einer neuen Liste zu einem Dokument verwenden Sie die ApplyListTemplate-Methode mit dem ListFormat-Objekt für einen bestimmten Bereich.

Sie können die einzelnen List-Objekte innerhalb eines Dokuments bearbeiten, eine größere Kontrolle erreichen Sie aber, wenn Sie mit dem ListFormat-Objekt arbeiten.

Listen mit Bildaufzählungzeichen sind nicht in der Lists-Auflistung enthalten.


ListEntry-Objekt

Stellt ein Element in einem Dropdown-Formularfeld dar. Das ListEntry-Objekt ist ein Element der ListEntries-Auflistung. Die ListEntries-Auflistung enthält alle Elemente in einem Dropdown-Formularfeld.

Verwendung des ListEntry-Objekts

Verwenden Sie ListEntries(Index), um ein einzelnes ListEntry-Objekt zurückzugeben, wobei Index der Name des Listeneintrags oder die Indexnummer ist. Die Indexnummer stellt die Position des Eintrags im Dropdown-Formularfeld dar (das erste Element entspricht Indexnummer 1). Im folgenden Beispiel wird der Eintrag "Blue" aus dem Dropdown-Formularfeld "Color" gelöscht.

ActiveDocument.FormFields("Color").DropDown _
    .ListEntries("Blue").Delete

Im folgenden Beispiel wird das erste Element im Dropdown-Formularfeld "Color" angezeigt.

MsgBox _
    ActiveDocument.FormFields("Color").DropDown.ListEntries(1).Name

Verwenden Sie die Add-Methode, um einem Dropdown-Formularfeld ein Element hinzuzufügen. Im folgenden Beispiel wird ein Dropdown-Formularfeld eingefügt. Anschließend werden dem Formularfeld "Red", "Blue" und "Green" hinzugefügt.

Set myField = _
    ActiveDocument.FormFields.Add(Range:=Selection.Range, _
    Type:=wdFieldFormDropDown)
With myField.DropDown.ListEntries
    .Add Name:="Red"
    .Add Name:="Blue"
    .Add Name:="Green"
End With


ListEntries-Objekt (Auflistung)

Eine Auflistung von ListEntry-Objekten, die alle Elemente in einem Dropdown-Formularfeld darstellen.

Verwendung der ListEntries-Auflistung

Verwenden Sie die ListEntries-Eigenschaft, um die ListEntries-Auflistung zurückzugeben. Im folgenden Beispiel werden die Elemente angezeigt, die im Formularfeld "Drop1" erscheinen.

For Each le In _
    ActiveDocument.FormFields("Drop1").DropDown.ListEntries
    MsgBox le.Name
Next le

Verwenden Sie die Add-Methode, um einem Dropdown-Formularfeld ein Element hinzuzufügen. Im folgenden Beispiel wird ein Dropdown-Formularfeld eingefügt. Anschließend werden dem Formularfeld "Red", "Blue" und "Green" hinzugefügt.

Set myField = _
    ActiveDocument.FormFields.Add(Range:=Selection.Range, _
     Type:=wdFieldFormDropDown)
With myField.DropDown.ListEntries
    .Add Name:="Red"
    .Add Name:="Blue"
    .Add Name:="Green"
End With

Verwenden Sie ListEntries(Index), um ein einzelnes ListEntry-Objekt zurückzugeben, wobei Index der Name des Listeneintrags oder die Indexnummer ist. Die Indexnummer stellt die Position des Eintrags im Dropdown-Formularfeld dar (das erste Element entspricht Indexnummer 1). Im folgenden Beispiel wird der Eintrag "Blue" aus dem Dropdown-Formularfeld "Color" gelöscht.

ActiveDocument.FormFields("Color").DropDown _
    .ListEntries("Blue").Delete

Im folgenden Beispiel wird das erste Element im Dropdown-Formularfeld "Color" angezeigt.

MsgBox _
    ActiveDocument.FormFields("Color").DropDown.ListEntries(1).Name


ListFormat-Objekt

Stellt die Attribute der Listenformatierung dar, die den Absätzen in einem Bereich zugewiesen werden können.

Verwendung des ListFormat-Objekts

Verwenden Sie die ListFormat-Eigenschaft, um das ListFormat-Objekt für einen Bereich zurückzugeben. Im folgenden Beispiel wird der Auswahl das Standardformat für Listen mit Aufzählungszeichen zugewiesen.

Selection.Range.ListFormat.ApplyBulletDefault

Zuweisen einer Listenvorlage

Verwenden Sie die ApplyBulletDefault-, ApplyNumberDefault- und die ApplyOutlineNumberDefault-Methode, um auf einfache Art und Weise Listenformatierung zuzuweisen. Diese Methoden entsprechen jeweils dem ersten Listenformat (None ausgeschlossen) in den einzelnen Registerkarten im Dialogfeld Aufzählungen und Nummerierung.

Verwenden Sie die ApplyListTemplate-Methode, um ein anderes als das Standardformat zuzuweisen. Mit dieser Methode können Sie das Listenformat (die Listenvorlage) angeben, die Sie zuweisen möchten.

Zurückgeben der Liste oder der Listenvorlage

Verwenden Sie die List- oder die ListTemplate-Eigenschaft, um die im ersten Absatz im angegebenen Bereich verwendete Liste oder Listenvorlage zurückzugeben.

Hinweise

Verwenden Sie die ListFormat-Eigenschaft mit einem Range-Objekt, um auf die für den angegebenen Bereich verfügbaren Listenformatierungseigenschaften und -methoden zuzugreifen. Im folgenden Beispiel wird dem zweiten Absatz im aktiven Dokument das Standardformat für Listen mit Aufzählungszeichen zugewiesen.

ActiveDocument.Paragraphs(2).Range.ListFormat.ApplyBulletDefault

Ist im Dokument bereits eine Liste definiert, verwenden Sie die Lists-Eigenschaft, um auf ein List-Objekt zuzugreifen. Im folgenden Beispiel wird das Format der im vorigen Beispiel erstellten Liste in das erste Nummerierungsformat der Registerkarte Nummerierung im Dialogfeld Aufzählungen und Nummerierung geändert.

ActiveDocument.Lists(1).ApplyListTemplate _
    ListTemplate:=ListGalleries(2).ListTemplates(1)


ListGallery-Objekt

Stellt einen einzelnen Katalog von Listenformaten dar. Das ListGallery-Objekt ist ein Element der ListGalleries-Auflistung. Die einzelnen ListGallery-Objekte stellen jeweils eine der drei Registerkarten im Dialogfeld Aufzählungen und Nummerierung dar.

Verwendung des ListGallery-Objekts

Verwenden Sie ListGalleries(Index), um ein einzelnes ListGallery-Objekt zurückzugeben, wobei Index wdBulletGallery, wdNumberGallery oder wdOutlineNumberGallery ist.

Im folgenden Beispiel wird das dritte Listenformat (None ausgeschlossen) in der Registerkarte Aufzählungen im Dialogfeld Aufzählungen und Nummerierung zurückgegeben und anschließend der Auswahl zugewiesen.

Set temp3 = ListGalleries(wdBulletGallery).ListTemplates(3)
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:= temp3

Zurücksetzen einer Listenvorlage im Katalog

Verwenden Sie die Modified-Eigenschaft für das ListGallery-Objekt, um zu überprüfen, ob die angegebene Listenvorlage die in Word vordefinierte Formatierung enthält. Um die Formatierung auf das ursprüngliche Listenformat zurückzusetzen, verwenden Sie die Reset-Methode für das ListGallery-Objekt.


ListGalleries-Objekt (Auflistung)

Eine Auflistung von ListGallery-Objekten, die die drei Registerkarten im Dialogfeld Aufzählungen und Nummerierung darstellen.

Verwendung der ListGalleries-Auflistung

Verwenden Sie die ListGalleries-Eigenschaft, um die ListGalleries-Auflistung zurückzugeben. Im folgenden Beispiel wird die Auflistung der Listenkataloge abgerufen. Anschließend werden die sieben Listenvorlagen (Formate) auf das in Word vordefinierte Listenvorlagenformat zurückgesetzt.

For Each lg In ListGalleries
    For x = 1 To 7
        lg.Reset(x)
    Next x
Next lg

Verwenden Sie ListGalleries(Index), um ein einzelnes ListGallery-Objekt zurückzugeben, wobei Index wdBulletGallery, wdNumberGallery oder wdOutlineNumberGallery ist.

Im folgenden Beispiel wird das dritte Listenformat (None ausgeschlossen) in der Registerkarte Aufzählungen im Dialogfeld Aufzählungen und Nummerierung zurückgegeben und anschließend der Auswahl zugewiesen.

Set temp3 = ListGalleries(wdBulletGallery).ListTemplates(3)
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:= temp3

Zurücksetzen einer Listenvorlage im Katalog

Verwenden Sie die Modified-Eigenschaft mit dem ListGallery-Objekt, um zu überprüfen, ob die angegebene Listenvorlage die in Word vordefinierte Formatierung enthält. Um die Formatierung auf das ursprüngliche Listenformat zurückzusetzen, verwenden Sie die Reset-Methode für das ListGallery-Objekt.


ListLevel-Objekt

Stellt eine einzelne Listenebene dar, d. h. entweder die einzige Ebene für eine Aufzählung bzw. eine nummerierte Liste oder eine der neun Ebenen einer gegliederten Liste. Das ListLevel-Objekt ist ein Element der ListLevels-Auflistung.

Verwendung des ListLevel-Objekts

Verwenden Sie ListLevels(Index), um ein einzelnes ListLevel-Objekt zurückzugeben, wobei Index für eine Zahl zwischen 1 und 9 steht. Im folgenden Beispiel wird die Listenebene eins der Listenvorlage eins im aktiven Dokument so eingestellt, dass sie mit 4 beginnt.

ActiveDocument.ListTemplates(1).ListLevels(1).StartAt = 4

Hinweise

Mit dem ListLevel-Objekt haben Sie Zugriff auf alle Formatierungseigenschaften für die angegebene Listenebene, d. h. die Alignment-, Font-, NumberFormat-, NumberPosition-, NumberStyle- und TrailingCharacter-Eigenschaft.

Um eine Listenebene zuzuweisen, bestimmen Sie zunächst den Bereich oder die Liste, und verwenden Sie dann die ApplyListTemplate-Methode. Jeder Tabstopp am Anfang eines Absatzes wird in eine Listenebene übersetzt. Ein Absatz, der z. B. mit drei Tabstopps beginnt, wird nach Verwendung der ApplyListTemplate-Methode zu einer Liste mit drei Ebenen.


ListLevels-Objekt (Auflistung)

Eine Auflistung von ListLevel-Objekten, die alle Listenebenen einer Listenvorlage darstellen, d. h. entweder die einzige Ebene für eine Aufzählung bzw. eine nummerierte Liste oder eine der neun Ebenen einer gegliederten Liste.

Verwendung der ListLevels-Auflistung

Verwenden Sie die ListLevels-Eigenschaft, um die ListLevels-Auflistung zurückzugeben. Im folgenden Beispiel wird die Variable mytemp als erste Listenvorlage im aktiven Dokument festgelegt. Anschließend werden die einzelnen Ebenen bearbeitet, wobei für deren Nummerierung Kleinbuchstaben festgelegt werden.

Set mytemp = ActiveDocument.ListTemplates(1)
For Each lev In mytemp.ListLevels
    lev.NumberStyle = wdListNumberStyleLowercaseLetter
Next lev

Verwenden Sie ListLevels(Index), um ein einzelnes ListLevel-Objekt zurückzugeben, wobei Index eine Zahl zwischen 1 und 9 ist. Im folgenden Beispiel wird die Listenebene eins der Listenvorlage eins im aktiven Dokument so eingestellt, dass sie bei 4 beginnt.

ActiveDocument.ListTemplates(1).ListLevels(1).StartAt = 4

Anmerkung Sie können einer Listenvorlage keine neuen Ebenen hinzufügen.

Hinweise

Um eine Listenebene zuzuweisen, bestimmen Sie zunächst den Bereich oder die Liste, und verwenden Sie dann die ApplyListTemplate-Methode. Jeder Tabstopp am Anfang eines Absatzes wird in eine Listenebene übersetzt. Aus einem Absatz, der z. B. mit drei Tabstopps beginnt, wird nach Verwendung der ApplyListTemplate-Methode eine Liste mit drei Ebenen.


ListParagraphs-Objekt (Auflistung)

Eine Auflistung von Paragraph-Objekten, die die Absätze des angegebenen Dokuments, der Liste oder des Bereiches mit zugewiesener Listenformatierung darstellen.

Verwenden der ListParagraphs-Auflistung

Verwenden Sie die ListParagraphs-Eigenschaft, um die ListParagraphs-Auflistung zurückzugeben. Im folgenden Beispiel wird die Auflistung von Absätzen mit Listenformatierung im aktiven Dokument hervorgehoben.

For Each para in ActiveDocument.ListParagraphs
    para.Range.HighlightColorIndex = wdTurquoise
Next para

Mit ListParagraphs(Index) können Sie ein einzelnes Paragraph-Objekt mit Listenformatierung zurückgeben, wobei Index die Indexnummer ist.

Hinweise

Absätze können zwei Arten von Listenformatierungen aufweisen. Der erste Typ enthält am Anfang jedes Absatzes in der Liste eine automatisch hinzugefügte Nummer oder ein Aufzählungszeichen. Der zweite Typ enthält LISTNUM-Felder, die an einer beliebigen Stelle innerhalb des Absatzes platziert werden können. Pro Absatz kann mehr als ein LISTNUM-Feld vorhanden sein.

Zum Hinzufügen von Listenformatierungen zu Absätzen können Sie die ApplyListTemplate-, die ApplyBulletDefault-, die ApplyNumberDefault- oder die ApplyOutlineNumberDefault-Methode verwenden. Sie greifen auf diese Methoden aus dem ListFormat-Objekt für einen festgelegten Bereich zu.

Die Count-Eigenschaft für diese Auflistung in einem Dokument gibt nur die Anzahl der Elemente im Hauptartikel zurück. Zum Zählen von Elementen in anderen Artikeln verwenden Sie die Auflistung mit dem Range-Objekt.


ListTemplate-Objekt

Stellt eine einzelne Listenvorlage dar, die alle Formatierungen enthält, durch die eine Liste definiert ist. Das ListTemplate-Objekt ist ein Element der ListTemplates-Auflistung. Jedes der sieben Formate (None ausgeschlossen), die jeweils auf den drei Registerkarten im Dialogfeld Nummerierung und Aufzählungszeichen enthalten sind, entspricht einem Listenvorlagen-Objekt. Von den drei ListGallery-Objekten in der ListGalleries-Auflistung aus kann auf diese vordefinierten Listenvorlagen zugegriffen werden. Dokumente und Dokumentvorlagen können auch Auflistungen von Listenvorlagen enthalten.

Verwendung des ListTemplate-Objekts

Verwenden Sie ListTemplates(Index), um eine einzelne Listenvorlage aus einem Listenkatalog zurückzugeben, wobei Index für eine Zahl zwischen 1 und 7 steht. Im folgenden Beispiel wird das dritte Listenformat (None ausgeschlossen) auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungszeichen zurückgegeben.

Set temp3 = ListGalleries(2).ListTemplates(3)

Anmerkung Manche Eigenschaften und Methoden (z. B. Convert und Add) können nicht für Listenvorlagen eingesetzt werden, auf die von einem Listenkatalog aus zugegriffen wurde. Sie können diese Listenvorlagen bearbeiten, jedoch können Sie deren Listenkatalog-Typ nicht ändern (wdBulletGallery, wdNumberGallery oder wdOutlineNumberGallery).

Im folgenden Beispiel wird eine Objektvariable festgelegt, die der in der dritten Liste im aktiven Dokument verwendeten Listenvorlage entspricht. Anschließend wird diese Listenvorlage der Auswahl zugewiesen.

Set myLt = ActiveDocument.ListTemplates(3)
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myLt

Verwenden Sie die Add-Methode, um zu der Auflistung von Listenvorlagen in einem Dokument oder einer Dokumentvorlage eine Listenvorlage hinzuzufügen.

Zurücksetzen einer Listenvorlage im Katalog

Verwenden Sie die Modified-Eigenschaft mit dem ListGallery-Objekt, um festzustellen, ob die angegebene Listenvorlage die in Word vordefinierte Formatierung enthält. Um die Formatierung auf das ursprüngliche Listenformat zurückzusetzen, verwenden Sie die Reset-Methode für das ListGallery-Objekt.

Hinweise

Nachdem Sie ein ListTemplate-Objekt zurückgegeben haben, geben Sie mit ListLevels(Index) ein einzelnes ListLevel-Objekt zurück, wobei Index für eine Zahl zwischen 1 und 9 steht. Mit einem ListLevel-Objekt haben Sie Zugriff auf alle Formatierungseigenschaften für die angegebene Listenebene, d. h. auf Alignment, Font, NumberFormat, NumberPosition, NumberStyle und TrailingCharacter.

Verwenden Sie die Convert-Methode, um eine Listenvorlage mit mehreren Ebenen in eine Vorlage mit einer Ebene umzuwandeln.


ListTemplates-Objekt (Auflistung)

Eine Auflistung von ListTemplate-Objekten, die die sieben vordefinierten Listenformate auf den einzelnen Registerkarten im Dialogfeld Nummerierung und Aufzählungszeichen darstellt.

Verwendung der ListTemplates-Auflistung

Verwenden Sie die ListTemplates-Eigenschaft, um die ListTemplates-Auflistung zurückzugeben. Im folgenden Beispiel wird eine Meldung mit dem Status der Ebenen (eine oder mehrere Ebenen) für jede Listenvorlage im aktiven Dokument angezeigt.

For Each lt In ActiveDocument.ListTemplates
    MsgBox "This is a multiple-level list template - " _
    & lt.OutlineNumbered
Next LT

Verwenden Sie die Add-Methode, um zu der Auflistung im angegebenen Dokument oder in der angegebenen Dokumentvorlage eine Listenvorlage hinzuzufügen. Im folgenden Beispiel wird zu dem aktiven Dokument eine neue Listenvorlage hinzugefügt und diese anschließend der Auswahl zugewiesen.

Set myLT = ActiveDocument.ListTemplates.Add
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myLT

Verwenden Sie ListTemplates(Index), um eine einzelne Listenvorlage aus einem Listenkatalog zurückzugeben, wobei Index für eine Zahl zwischen 1 und 7 steht. Im folgenden Beispiel wird eine Objektvariable festgelegt, die der in der dritten Liste im aktiven Dokument verwendeten Listenvorlage entspricht. Anschließend wird diese Listenvorlage der Auswahl zugewiesen.

Set mylt = ActiveDocument.ListTemplates(3)
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=mylt

Anmerkung Manche Eigenschaften und Methoden (z. B. Convert und Add) können nicht für Listenvorlagen eingesetzt werden, auf die von einem Listenkatalog aus zugegriffen wurde. Sie können diese Listenvorlagen bearbeiten, jedoch können Sie deren Listenkatalog-Typ nicht ändern (wdBulletGallery, wdNumberGallery oder wdOutlineNumberGallery).

Zurücksetzen einer Listenvorlage im Katalog

Verwenden Sie die Modified-Eigenschaft mit dem ListGallery-Objekt, um festzustellen, ob die angegebene Listenvorlage die in Word vordefinierte Formatierung enthält. Um die Formatierung auf das ursprüngliche Listenformat zurückzusetzen, verwenden Sie die Reset-Methode für das ListGallery-Objekt.

Anmerkungen

Nachdem Sie ein ListTemplate-Objekt zurückgegeben haben, geben Sie mit ListLevels(Index) ein einzelnes ListLevel-Objekt zurück, wobei Index für eine Zahl von 1 bis 9 steht. Mit einem ListLevel-Objekt haben Sie Zugriff auf alle Formatierungseigenschaften für die angegebene Listenebene, d. h. auf Alignment, Font, NumberFormat, NumberPosition, NumberStyle und TrailingCharacter.

Verwenden Sie die Convert-Methode, um eine Listenvorlage mit mehreren Ebenen in eine Vorlage mit einer Ebene umzuwandeln.


MailingLabel-Objekt

Stellt ein Adressetikett dar.

Verwendung des MailingLabel-Objekts

Verwenden Sie die MailingLabel-Eigenschaft, um das MailingLabel-Objekt zurückzugeben. Im folgenden Beispiel werden Standardoptionen für Adressetiketten eingestellt.

With Application.MailingLabel
    .DefaultLaserTray = wdPrinterLowerBin
    .DefaultPrintBarCode = True
End With

Verwenden Sie die PrintOut-Methode, um ein im Feld Bestellnummer im Dialogfeld Etiketten einrichten aufgelistetes Adressetikett zu drucken. Im folgenden Beispiel wird eine Seite von Avery 5162 Standard-Adressetiketten mit der angegebenen Adresse gedruckt.

addr = "Katie Jordan" & vbCr & "123 Skye St." _
    & vbCr & "OurTown, WA 98107"
Application.MailingLabel.PrintOut Name:="5162", Address:=addr

Hinweise

Verwenden Sie die CustomLabels-Eigenschaft, um ein benutzerdefiniertes Adressetikett zu formatieren oder zu drucken. Im folgenden Beispiel wird die Anzahl von Etiketten für das benutzerdefinierte Etikett "MyLabel" in Quer- und Längsrichtung eingestellt.

With Application.MailingLabel.CustomLabels("MyLabel")
    .NumberAcross = 2
    .NumberDown = 5
End With


MailMerge-Objekt

Stellt die Seriendruck-Funktion in Word dar.

Verwendung des MailMerge-Objekts

Verwenden Sie die MailMerge-Eigenschaft, um das MailMerge-Objekt zurückzugeben. Das MailMerge-Objekt ist immer verfügbar, unabhängig davon, ob der Seriendruckvorgang begonnen hat oder nicht. Verwenden Sie die State-Eigenschaft, um den Status des Seriendruckvorgangs festzustellen. Im folgenden Beispiel wird ein Seriendruck ausgeführt, wenn das aktive Dokument ein Hauptdokument mit einer ihm zugewiesenen Datenquelle ist.

If ActiveDocument.MailMerge.State = wdMainAndDataSource Then
    ActiveDocument.MailMerge.Execute
End If

Im folgenden Beispiel wird das Hauptdokument mit den ersten drei Datensätzen in der ihm zugewiesenen Datenquelle verbunden. Anschließend wird das Ergebnis an den Drucker übertragen.

Set myMerge = ActiveDocument.MailMerge
If myMerge.State = wdMainAndSourceAndHeader Or _
    myMerge.State = wdMainAndDataSource Then
    With myMerge.DataSource
        .FirstRecord = 1
        .LastRecord = 3
    End With
End If
With myMerge
    .Destination = wdSendToPrinter
    .Execute
End With


MailMergeDataField-Objekt

Stellt ein einzelnes Seriendruckfeld in einer Datenquelle dar. Das MailMergeDataField-Objekt ist ein Element der MailMergeDataFields-Auflistung. Die MailMergeDataFields-Auflistung enthält alle Datenfelder in einer Seriendruck-Datenquelle (z. B.: Name, Adresse und Stadt).

Verwendung des MailMergeDataField-Objekts

Verwenden Sie DataFields(Index), um ein einzelnes MailMergeDataField-Objekt zurückzugeben, wobei Index der Name des Datenfeldes oder die Indexnummer ist. Die Indexnummer stellt die Position des Datenfeldes in der Seriendruck-Datenquelle dar. Im folgenden Beispiel wird der erste Wert aus dem Feld "FName" in der dem aktiven Dokument zugewiesenen Datenquelle abgerufen.

first = _
    ActiveDocument.MailMerge.DataSource.DataFields("FName").Value

Im folgenden Beispiel wird der Name des ersten Feldes in der dem aktiven Dokument zugewiesenen Datenquelle angezeigt.

MsgBox ActiveDocument.MailMerge.DataSource.DataFields(1).Name

Sie können der MailMergeDataFields-Auflistung keine Felder hinzufügen. Alle Datenfelder in einer Datenquelle werden automatisch in die MailMergeDataFields-Auflistung aufgenommen.


MailMergeDataFields-Objekt (Auflistung)

Eine Auflistung von MailMergeDataField-Objekten, die die Datenfelder in einer Seriendruck-Datenquelle darstellen.

Verwendung der MailMergeDataFields-Auflistung

Verwenden Sie die DataFields-Eigenschaft, um die MailMergeDataFields-Auflistung zurückzugeben. Im folgenden Beispiel werden die Namen aller Felder in der zugewiesenen Datenquelle angezeigt.

For Each afield In ActiveDocument.MailMerge.DataSource.DataFields
    MsgBox afield.Name
Next afield

Sie können der MailMergeDataFields-Auflistung keine Felder hinzufügen. Wenn einer Datenquelle ein Datenfeld hinzugefügt wird, wird dieses Feld automatisch in die MailMergeDataFields-Auflistung aufgenommen. Verwenden Sie die EditDataSource-Methode, um den Inhalt einer Datenquelle zu bearbeiten. Im folgenden Beispiel wird einer Tabelle in der zugewiesenen Datenquelle das Datenfeld "Author" hinzugefügt.

If ActiveDocument.MailMerge.DataSource.Type = _
        wdMergeInfoFromWord Then
    ActiveDocument.MailMerge.EditDataSource
    With ActiveDocument.Tables(1)
        .Columns.Add
        .Cell(Row:=1, Column:=.Columns.Count).Range.Text = "Author"
    End With
End If

Verwenden Sie DataFields(Index), um ein einzelnes MailMergeDataField-Objekt zurückzugeben, wobei Index der Name des Datenfeldes oder die Indexnummer ist. Die Indexnummer stellt die Position des Datenfeldes in der Seriendruck-Datenquelle dar. Im folgenden Beispiel wird der erste Wert aus dem Feld "FName" in der dem aktiven Dokument zugewiesenen Datenquelle abgerufen.

first = _
    ActiveDocument.MailMerge.DataSource.DataFields("FName").Value

Im folgenden Beispiel wird der Name des ersten Datenfeldes in der dem aktiven Dokument zugewiesenen Datenquelle angezeigt.

MsgBox ActiveDocument.MailMerge.DataSource.DataFields(1).Name


MailMergeDataSource-Objekt

Stellt die Seriendruck-Datenquelle in einer Seriendruck-Operation dar.

Verwendung des MailMergeDataSource-Objekts

Mit der DataSource-Eigenschaft können Sie das MailMergeDataSource-Objekt zurückgeben. Das folgende Beispiel zeigt den Namen der Datenquelle an, die dem aktiven Dokument zugewiesen ist.

If ActiveDocument.MailMerge.DataSource.Name <> "" Then _
    MsgBox ActiveDocument.MailMerge.DataSource.Name

Das folgende Beispiel zeigt die Feldnamen in der Datenquelle an, die dem aktiven Dokument zugewiesen ist.

For Each aField In ActiveDocument.MailMerge.DataSource.FieldNames
    MsgBox aField.Name
Next aField

Das folgende Beispiel öffnet die Datenquelle, die der Datei "Form letter.doc" zugewiesen ist, und bestimmt, ob das Feld "FirstName" den Namen "Kate" enthält.

With Documents("Form letter.doc").MailMerge
    .EditDataSource
    If .DataSource.FindRecord(FindText:="Kate", _
            Field:="FirstName") = True Then
        MsgBox "Data was found"
    End If
End With


MailMergeField-Objekt

Stellt ein einzelnes Seriendruckfeld in einem Dokument dar. Das MailMergeDataField-Objekt ist ein Element der MailMergeDataFields-Auflistung. Die MailMergeDataFields-Auflistung enthält alle seriendruckbezogenen Felder eines Dokuments.

Verwendung des MailMergeField-Objekts

Mit Fields(Index) können Sie ein einzelnes MailMergeField-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel zeigt die Feldfunktion des ersten Seriendruckfelds im aktiven Dokument an.

MsgBox ActiveDocument.MailMerge.Fields(1).Code

Mit der Add-Methode können Sie der MailMergeFields-Auflistung ein Seriendruckfeld hinzufügen. Das folgende Beispiel ersetzt die Markierung durch ein Namenszusatz-Seriendruckfeld.

ActiveDocument.MailMerge.Fields.Add Range:=Selection.Range, _
    Name:="MiddleInitial"

Hinweise

Bei der MailMergeFields-Auflistung stehen zusätzliche Methoden zur Verfügung, z. B. AddAsk und AddFillIn, mit denen Felder für Seriendruck-Operationen hinzugefügt werden können.


MailMergeFields-Objekt (Auflistung)

Eine Auflistung mit MailMergeField-Objekten, die die seriendruckbezogenen Felder in einem Dokument darstellen.

Verwendung der MailMergeFields-Auflistung

Mit der Fields-Eigenschaft können Sie die MailMergeFields-Auflistung zurückgeben. Das folgende Beispiel fügt nach dem letzten Seriendruckfeld im aktiven Dokument ein ASK-Feld hinzu.

Set myMMFields = ActiveDocument.MailMerge.Fields
myMMFields(myMMFields.Count).Select
Selection.MoveRight Unit:=wdWord, Count:=1, Extend:=wdMove
ActiveDocument.MailMerge.Fields.AddAsk Range:=Selection.Range, _
    Name:="Name", Prompt:="Type your name", AskOnce:=True

Mit der Add-Methode können Sie der MailMergeFields-Auflistung ein Seriendruckfeld hinzufügen. Das folgende Beispiel ersetzt die Markierung durch ein MiddleInitial-Seriendruckfeld.

ActiveDocument.MailMerge.Fields.Add Range:=Selection.Range, _
    Name:="MiddleInitial"

Mit Fields(Index) können Sie ein einzelnes MailMergeField-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel zeigt die Feldfunktion des ersten Seriendruckfeldes im aktiven Dokument an.

MsgBox ActiveDocument.MailMerge.Fields(1).Code

Hinweise

Bei der MailMergeFields-Auflistung stehen zusätzliche Methoden zur Verfügung, z. B. AddAsk und AddFillIn, mit denen Felder für Seriendruck-Operationen hinzugefügt werden können.


MailMergeFieldName-Objekt

Stellt den Namen eines Seriendruckfeldes in einer Datenquelle dar. Das MailMergeFieldName-Objekt ist ein Element der MailMergeFieldNames-Auflistung. Die MailMergeFieldNames-Auflistung enthält die Namen aller Datenfelder in einer Seriendruck-Datenquelle.

Verwendung des MailMergeFieldName-Objekts

Verwenden Sie FieldNames(Index), um ein einzelnes MailMergeFieldName-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position des Feldes in der Seriendruck-Datenquelle dar. Im folgenden Beispiel wird der Name des letzten Feldes in der dem aktiven Dokument zugewiesenen Datenquelle abgerufen.

alast = ActiveDocument.MailMerge.DataSource.FieldNames.Count
afirst = ActiveDocument.MailMerge.DataSource.FieldNames(alast).Name
MsgBox afirst

Sie können der MailMergeFieldNames-Auflistung keine Felder hinzufügen. Die Namen der Felder in einer Datenquelle werden automatisch in die MailMergeFieldNames-Auflistung aufgenommen.


MailMergeFieldNames-Objekt (Auflistung)

Eine Auflistung von MailMergeFieldName-Objekten, die die Namen der Felder in einer Seriendruck-Datenquelle darstellen.

Verwendung der MailMergeFieldNames-Auflistung

Verwenden Sie die FieldNames-Eigenschaft, um die MailMergeFieldNames-Auflistung zurückzugeben. Im folgenden Beispiel werden die Namen der Felder in der dem aktiven Dokument zugewiesenen Datenquelle angezeigt.

For Each afield In ActiveDocument.MailMerge.DataSource.FieldNames
    MsgBox afield.Name
Next afield

Sie können der MailMergeFieldNames-Auflistung keine Namen hinzufügen. Wenn einer Datenquelle ein Feld hinzugefügt wird, wird der Name des Feldes automatisch in die MailMergeFieldNames-Auflistung aufgenommen. Verwenden Sie die EditDataSource-Methode, um den Inhalt einer Datenquelle zu bearbeiten. Im folgenden Beispiel wird einer Tabelle in der dem aktiven Dokument zugewiesenen Datenquelle das Datenfeld "Author" hinzugefügt.

If ActiveDocument.MailMerge.DataSource.Type = _
        wdMergeInfoFromWord Then
    ActiveDocument.MailMerge.EditDataSource
    With ActiveDocument.Tables(1)
        .Columns.Add
        .Cell(Row:=1, Column:=.Columns.Count).Range.Text = "Author"
    End With
End If


MailMessage-Objekt

Stellt die aktive E-Mail-Nachricht dar, wenn Sie Word als E-Mail-Editor verwenden.

Verwendung des MailMessage-Objekts

Verwenden Sie die MailMessage-Eigenschaft zur Zurückgabe des MailMessage-Objekts. Das folgende Beispiel prüft die Gültigkeit der E-Mail-Adressen, die in der aktiven E-Mail-Nachricht erscheinen.

Application.MailMessage.CheckName

Anmerkungen

Bei den Methoden des MailMessage-Objekts ist es erforderlich, dass Sie Word als E-Mail-Editor verwenden und dass eine E-Mail-Nachricht aktiv ist. Wenn eine dieser Bedingungen nicht erfüllt ist, tritt ein Fehler auf.


OLEFormat-Objekt

Stellt die OLE-Charakteristika (außer Verknüpfung) für ein OLE-Objekt, ActiveX-Steuerelement oder Feld dar.

Verwendung des OLEFormat-Objekts

Verwenden Sie die OLEFormat-Eigenschaft für eine Form, eine zeilenfixierte Form oder ein Feld zur Zurückgabe des OLEFormat-Objekts. Im folgenden Beispiel wird der Klassentyp für die erste Form im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Shapes(1).OLEFormat.ClassType

Anmerkungen

Nicht alle Arten von Formen, zeilenfixierten Formen und Feldern haben OLE-Fähigkeiten. Verwenden Sie die Type-Eigenschaft für die Shape- und InlineShape-Objekte zum Ermitteln, in welche Kategorie die angegebene Form oder die zeilenfixierte Form fällt. Die Type-Eigenschaft für ein Field-Objekt gibt die Feld-Kategorie zurück.

Sie können die Activate-, Edit-, Open- und DoVerb-Methoden zum Automatisieren eines OLE-Objekts verwenden.

Verwenden Sie die Object-Eigenschaft zur Zurückgabe eines Objekts, das ein ActiveX-Steuerelement oder OLE-Objekt darstellt. Bei diesem Objekt können Sie die Eigenschaften und Methoden der Containeranwendung oder des ActiveX-Steuerelements verwenden.


Options-Objekt

Stellt Anwendungs- und Dokumentoptionen in Word dar. Zahlreiche Eigenschaften des Options-Objekts entsprechen Elementen im Dialogfeld Optionen (Menü Extras).

Verwendung des Options-Objekts

Mit der Options-Eigenschaft können Sie das Options-Objekt zurückgeben. Das folgende Beispiel legt drei Anwendungsoptionen für Word fest.

With Options
    .AllowDragAndDrop = True
    .ConfirmConversions = False
    .MeasurementUnit = wdPoints
End With


OtherCorrectionsException-Objekt

Stellt eine AutoKorrektur-Ausnahme dar. Das OtherCorrectionsException-Objekt ist ein Element der OtherCorrectionsExceptions-Auflistung. Die OtherCorrectionsExceptions-Auflistung enthält alle Wörter, die von Microsoft Word nicht automatisch korrigiert werden. Diese Liste entspricht der Liste der AutoKorrektur-Ausnahmen auf der Registerkarte Weitere Korrekturen im Dialogfeld AutoKorrektur-Ausnahmen (Menü Extras, Befehl AutoKorrektur).

Verwendung des OtherCorrectionsException-Objekts

Verwenden Sie OtherCorrectionsExceptions(Index), wobei Index der Name der AutoKorrektur-Ausnahme oder die Indexnummer ist, für die Rückgabe eines einzelnen OtherCorrectionsException-Objekts. Im folgenden Beispiel wird "WTop" aus der Liste der AutoKorrektur-Ausnahmen entfernt.

AutoCorrect.OtherCorrectionsExceptions("WTop").Delete

Die Indexnummer stellt die Position der AutoKorrektur-Ausnahme in der OtherCorrectionsExceptions-Auflistung dar. Im folgenden Beispiel wird der Name des ersten Elements in der OtherCorrectionsExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.OtherCorrectionsExceptions(1).Name

Wenn der Wert der OtherCorrectionsAutoAdd-Eigenschaft True ist, werden Wörter automatisch in die Liste der AutoKorrektur-Ausnahmen aufgenommen. Mit der Add-Methode können Sie der OtherCorrectionsExceptions-Auflistung ein Element hinzufügen. Im folgenden Beispiel wird der Liste der AutoKorrektur-Ausnahmen der Ausdruck "TipTop" hinzugefügt.

AutoCorrect.OtherCorrectionsExceptions.Add Name:="TipTop"


OtherCorrectionsExceptions-Objekt (Auflistung)

Eine Auflistung von OtherCorrectionsException-Objekten. Diese Objekte bilden die Liste der Wörter, die in Microsoft Word nicht automatisch korrigiert werden. Die Liste entspricht der Liste der AutoKorrektur-Ausnahmen, die im Dialogfeld AutoKorrektur-Ausnahmen auf der Registerkarte Weitere Korrekturen aufgeführt sind (Menü Extras, Befehl AutoKorrektur).

Verwenden der OtherCorrectionsExceptions-Auflistung

Verwenden Sie die OtherCorrectionsExceptions-Eigenschaft, um die OtherCorrectionsExceptions-Auflistung zurückzugeben. Im folgenden Beispiel werden die Elemente dieser Auflistung angezeigt.

For Each aCap In AutoCorrect.OtherCorrectionsExceptions
    MsgBox aCap.Name
Next aCap

Wenn der Wert der OtherCorrectionsAutoAdd-Eigenschaft True ist , werden Wörter automatisch in die Liste der AutoKorrektur-Ausnahmen aufgenommen. Mit der Add-Methode können Sie der OtherCorrectionsExceptions-Auflistung ein Element hinzufügen. Im folgenden Beispiel wird der Ausdruck "TipTop" in die Liste der AutoKorrektur-Ausnahmen aufgenommen.

AutoCorrect.OtherCorrectionsExceptions.Add Name:="TipTop"

Verwenden Sie OtherCorrectionsExceptions(Index), wobei Index der Namen oder die Indexnummer für die Rückgabe eines einzelnen OtherCorrectionsException-Objekts ist. Im folgenden Beispiel wird gezeigt, wie "WTop" aus der Liste der AutoKorrektur-Ausnahmen entfernt wird.

AutoCorrect.OtherCorrectionsExceptions("WTop").Delete

Die Indexnummer stellt die Position der AutoKorrektur-Ausnahme in der OtherCorrectionsExceptions-Auflistung dar. Im folgenden Beispiel wird der Name des ersten Elements in der OtherCorrectionsExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.OtherCorrectionsExceptions(1).Name


PageNumber-Objekt

Stellt eine Seitenzahl in einer Kopf- oder Fußzeile dar. Das PageNumber-Objekt ist ein Element der PageNumbers-Auflistung. Die PageNumbers-Auflistung enthält alle Seitenzahlen einer einzelnen Kopf- oder Fußzeile.

Verwendung des PageNumber-Objekts

Mit PageNumbers(Index) können Sie ein einzelnes PageNumber-Objekt zurückgeben. (Index ist die Indexnummer.) In den meisten Fällen enthält eine Kopf- oder Fußzeile lediglich eine Seitenzahl mit der Indexnummer 1. Das folgende Beispiel zentriert die erste Seitenzahl der primären Kopfzeile in Abschnitt 1 des aktiven Dokuments.

ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary) _
    .PageNumbers(1).Alignment = wdAlignPageNumberCenter

Mit der Add-Methode können Sie zu einer Kopf- oder Fußzeile eine Seitenzahl (ein PAGE-Feld) hinzufügen. Das folgende Beispiel fügt zu der primären Fußzeile im ersten Abschnitt und allen folgenden Abschnitten eine Seitenzahl hinzu. Die Seitenzahl erscheint nicht auf der ersten Seite.

With ActiveDocument.Sections(1)
    .Footers(wdHeaderFooterPrimary).PageNumbers.Add _
        PageNumberAlignment:=wdAlignPageNumberLeft, _
        FirstPage:=False
End With


PageNumbers-Objekt (Auflistung)

Eine Auflistung mit PageNumber-Objekten, die die Seitenzahlen in einer einzelnen Kopf- oder Fußzeile darstellen.

Verwendung der PageNumbers-Auflistung

Mit der PageNumbers-Eigenschaft können Sie die PageNumbers-Auflistung zurückgeben. Das folgende Beispiel beginnt die Seitennummerierung ab Seite 3 im ersten Abschnitt des aktiven Dokuments.

ActiveDocument.Sections(1).Footers(wdHeaderFooterPrimary) _
    .PageNumbers.StartingNumber = 3

Mit der Add-Methode können Sie zu Kopf- oder Fußzeilen Seitenzahlen hinzufügen. Das folgende Beispiel fügt zu der primären Fußzeile im ersten Abschnitt eine Seitenzahl hinzu.

With ActiveDocument.Sections(1)
    .Footers(wdHeaderFooterPrimary).PageNumbers.Add _
        PageNumberAlignment:=wdAlignPageNumberLeft, _
        FirstPage:=False
End With

Um zu einem Dokument mit mehreren Abschnitten Seitenzahlen hinzufügen oder ändern zu können, ändern Sie die Seitenzahlen in jedem Abschnitt, oder legen Sie für die LinkToPrevious-Eigenschaft True fest.

Mit PageNumbers(Index) können Sie ein einzelnes PageNumber-Objekt zurückgeben. (Index ist die Indexnummer.) In den meisten Fällen enthält eine Kopf- oder Fußzeile lediglich eine Seitenzahl mit der Indexnummer 1. Das folgende Beispiel zentriert die erste Seitenzahl der primären Kopfzeile in Abschnitt 1 des aktiven Dokuments.

ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary) _
    .PageNumbers(1).Alignment = wdAlignPageNumberCenter


PageSetup-Objekt

Stellt die Beschreibung der Seiteneinrichtung dar. Das PageSetup-Objekt enthält alle Seiteneinrichtungsattribute eines Dokuments (linker Rand, unterer Rand, Papierformat usw.) als Eigenschaften.

Verwendung des PageSetup-Objekts

Mit der PageSetup-Eigenschaft können Sie das PageSetup-Objekt zurückgeben. Das folgende Beispiel legt das Hochformat für den ersten Abschnitt im aktiven Dokument fest und druckt anschließend das Dokument.

ActiveDocument.Sections(1).PageSetup.Orientation = _
    wdOrientLandscape
ActiveDocument.PrintOut

Das folgende Beispiel legt alle Ränder für das Dokument "Sales.doc" fest.

With Documents("Sales.doc").PageSetup
    .LeftMargin = InchesToPoints(0.75)
    .RightMargin = InchesToPoints(0.75)
    .TopMargin = InchesToPoints(1.5)
    .BottomMargin = InchesToPoints(1)
End With


Pane-Objekt

Stellt einen Fensterausschnitt dar. Das Pane-Objekt ist ein Element der Panes-Auflistung. Die Panes-Auflistung enthält alle Fensterausschnitte für ein einzelnes Fenster.

Verwendung des Pane-Objekts

Mit Panes(Index) können Sie ein einzelnes Pane-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel schließt den aktiven Ausschnitt.

If ActiveDocument.ActiveWindow.Panes.Count >= 2 Then _
    ActiveDocument.ActiveWindow.ActivePane.Close

Mit der Add-Methode oder der Split-Eigenschaft können Sie einen Fensterausschnitt hinzufügen. Das folgende Beispiel teilt das aktive Fenster bei 20 Prozent der aktuellen Fenstergröße.

ActiveDocument.ActiveWindow.Panes.Add SplitVertical:=20

Das folgende Beispiel teilt das aktive Fenster in zwei Hälften.

ActiveDocument.ActiveWindow.Split = True

Mit der SplitSpecial-Eigenschaft können Sie Kommentare, Fußnoten oder Endnoten in einem separaten Ausschnitt anzeigen.

Anmerkungen

Ein Fenster hat dann mehrere Ausschnitte, wenn das Fenster geteilt ist oder sich nicht in der Drucklayoutansicht befindet und Informationen (z. B. Fußnoten oder Kommentare) angezeigt werden. Das folgende Beispiel zeigt den Ausschnitt für die Kommentare in der Normalansicht an und fordert anschließend zum Schließen des Ausschnitts auf.

ActiveDocument.ActiveWindow.View.Type = wdNormalView
If ActiveDocument.Comments.Count >= 1 Then
    ActiveDocument.ActiveWindow.View.SplitSpecial = wdPaneComments
    response = _
        MsgBox("Do you want to close the comments pane?", vbYesNo)
    If response = vbYes Then _
        ActiveDocument.ActiveWindow.ActivePane.Close
End If


Panes-Objekt (Auflistung)

Eine Auflistung mit Pane-Objekten, die die Fensterausschnitte für ein einzelnes Fenster darstellen.

Verwendung der Panes-Auflistung

Mit der Panes-Eigenschaft können Sie die Panes-Auflistung zurückgeben. Das folgende Beispiel teilt das aktive Fenster und blendet das Lineal für jeden Ausschnitt aus.

ActiveDocument.ActiveWindow.Split = True
For Each aPane In ActiveDocument.ActiveWindow.Panes
    aPane.DisplayRulers = False
Next aPane

Mit der Add-Methode oder der Split-Eigenschaft können Sie einen Fensterausschnitt hinzufügen. Das folgende Beispiel teilt das aktive Fenster bei 20 Prozent der aktuellen Fenstergröße.

ActiveDocument.ActiveWindow.Panes.Add SplitVertical:=20

Das folgende Beispiel teilt das aktive Fenster in zwei Hälften.

ActiveDocument.ActiveWindow.Split = True

Mit der SplitSpecial-Eigenschaft können Sie Kommentare, Fußnoten oder Endnoten in einem separaten Ausschnitt anzeigen.

Anmerkungen

Ein Fenster hat dann mehrere Ausschnitte, wenn es geteilt ist oder wenn es sich nicht in der Drucklayoutansicht befindet und Informationen (z. B. Fußnoten oder Kommentare) angezeigt werden. Das folgende Beispiel zeigt den Ausschnitt für die Fußnoten in der Normalansicht an und fordert anschließend den Benutzer auf, den Ausschnitt zu schließen.

ActiveDocument.ActiveWindow.View.Type = wdNormalView
If ActiveDocument.Footnotes.Count >= 1 Then
    ActiveDocument.ActiveWindow.View.SplitSpecial = wdPaneFootnotes
    response = _
        MsgBox("Do you want to close the footnotes pane?", vbYesNo)
    If response = vbYes Then _
        ActiveDocument.ActiveWindow.ActivePane.Close
End If


Paragraph-Objekt

Stellt einen einzelnen Absatz in einer Markierung, einem Bereich oder einem Dokument dar. Das Paragraph-Objekt ist ein Element der Paragraphs-Auflistung. Die Paragraphs-Auflistung enthält alle Absätze in einer Markierung, einem Bereich oder einem Dokument.

Verwendung des Paragraph-Objekts

Mit Paragraphs(Index) können Sie ein einzelnes Paragraph-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel richtet den ersten Absatz im aktiven Dokument rechts aus.

ActiveDocument.Paragraphs(1).Alignment = wdAlignParagraphRight

Mit der Add, InsertParagraph, InsertParagraphAfter oder InsertParagraphBefore-Methode können Sie zu einem Dokument einen neuen, leeren Absatz hinzufügen. Das folgende Beispiel fügt eine Absatzmarke vor den ersten Absatz in der Markierung ein.

Selection.Paragraphs.Add Range:=Selection.Paragraphs(1).Range

Das folgende Beispiel fügt ebenfalls eine Absatzmarke vor dem ersten Absatz in der Markierung ein.

Selection.Paragraphs(1).Range.InsertParagraphBefore


Paragraphs-Objekt (Auflistung)

Eine Auflistung mit Paragraph-Objekten in einer Markierung, einem Bereich oder einem Dokument.

Verwendung der Paragraphs-Auflistung

Mit der Paragraphs-Eigenschaft können Sie die Paragraphs-Auflistung zurückgeben. Das folgende Beispiel formatiert die markierten Absätze mit doppeltem Abstand rechtsbündig.

With Selection.Paragraphs
    .Alignment = wdAlignParagraphRight
    .LineSpacingRule = wdLineSpaceDouble
End With

Mit der Add-, InsertParagraph-, InsertParagraphAfter- oder InsertParagraphBefore-Methode können Sie zu einem Dokument einen neuen Absatz hinzufügen. Das folgende Beispiel fügt einen neuen Absatz vor den ersten Absatz in der Markierung ein.

Selection.Paragraphs.Add Range:=Selection.Paragraphs(1).Range

Das folgende Beispiel fügt ebenfalls einen neuen Absatz vor den ersten Absatz in der Markierung ein.

Selection.Paragraphs(1).Range.InsertParagraphBefore

Mit Paragraphs(Index) können Sie ein einzelnes Paragraph-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel richtet den ersten Absatz im aktiven Dokument rechts aus.

ActiveDocument.Paragraphs(1).Alignment = wdAlignParagraphRight

Hinweise

Die Count-Eigenschaft gibt für diese Auflistung in einem Dokument nur die Anzahl der Elemente im Haupttext zurück. Mit der Auflistung und dem Range-Objekt können Sie die Elemente anderer Komponenten zurückgeben.


ParagraphFormat-Objekt

Stellt alle Formatierungen für einen Absatz dar.

Verwendung des ParagraphFormat-Objekts

Verwenden Sie die Format-Eigenschaft, um das ParagraphFormat-Objekt für einen Absatz oder Absätze zurückzugeben. Die ParagraphFormat-Eigenschaft gibt das ParagraphFormat-Objekt für eine Markierung, einen Bereich, eine Formatvorlage, ein Find-Objekt oder ein Replacement-Objekt zurück. Das folgende Beispiel zentriert den dritten Absatz des aktiven Dokuments.

ActiveDocument.Paragraphs(3).Format.Alignment = _
    wdAlignParagraphCenter

Das folgende Beispiel sucht den nächsten Absatz mit doppeltem Zeilenabstand nach der Markierung.

With Selection.Find
    .ClearFormatting
    .ParagraphFormat.LineSpacingRule = wdLineSpaceDouble
    .Text = ""
    .Forward = True
    .Wrap = wdFindContinue
End With
Selection.Find.Execute

Hinweise

Mit dem New-Schlüsselwort können Sie ein neues, eigenständiges ParagraphFormat-Objekt erstellen. Das folgende Beispiel erstellt ein ParagraphFormat-Objekt, legt einige Formatierungseigenschaften dafür fest und weist dann alle seine Eigenschaften dem ersten Absatz des aktiven Dokuments zu.

Dim myParaF As New ParagraphFormat
myParaF.Alignment = wdAlignParagraphCenter
myParaF.Borders.Enable = True
ActiveDocument.Paragraphs(1).Format = myParaF

Sie können mit der Duplicate-Eigenschaft auch eine eigenständige Kopie eines vorhandenen ParagraphFormat-Objekts erstellen. Das folgende Beispiel kopiert das Absatzformat des ersten Absatzes im aktiven Dokument und speichert die Formatierung in myDup. Das Beispiel ändert den linken Einzug von myDup auf 1 Inch (ca. 2,54 cm), erstellt ein neues Dokument, fügt Text in das Dokument ein und weist dem Text das Absatzformat von myDup zu.

Set myDup = ActiveDocument.Paragraphs(1).Format.Duplicate
myDup.LeftIndent = InchesToPoints(1)
Documents.Add
Selection.InsertAfter "This is a new paragraph."
Selection.Paragraphs.Format = myDup


PictureFormat-Objekt

Enthält Eigenschaften und Methoden, die Bilder und OLE-Objekte betreffen. Das LinkFormat-Objekt enthält Eigenschaften und Methoden, die nur verknüpfte OLE-Objekte betreffen. Das OLEFormat-Objekt enthält Eigenschaften und Methoden, die OLE-Objekte betreffen, unabhängig davon, ob diese verknüpft sind oder nicht.

Verwendung von PictureFormat-Objekten

Verwenden Sie die PictureFormat-Eigenschaft, um ein PictureFormat-Objekt zurückzugeben. Im folgenden Beispiel werden Helligkeit, Kontrast und Farbtransformation für Form 1 im aktiven Dokument festgelegt und zusätzlich 18 Punkt vom unteren Rand des Bildes abgeschnitten. Dieses Beispiel funktioniert nur, wenn es sich bei Form 1 um ein Bild oder ein OLE-Objekt handelt.

With ActiveDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = 0.7
    .ColorType = msoPictureGrayScale
    .CropBottom = 18
End With


ProofreadingErrors-Objekt (Auflistung)

Eine Auflistung mit Rechtschreib- oder Grammatikfehlern für das angegebene Dokument oder den Bereich. Es gibt kein ProofreadingError-Objekt; stattdessen sind alle Elemente in der ProofreadingErrors-Auflistung Range-Objekte, die einen Rechtschreib- oder Grammatikfehler repräsentieren.

Verwendung der ProofreadingErrors-Auflistung

Mit der SpellingErrors- oder GrammaticalErrors-Eigenschaft geben Sie die ProofreadingErrors-Auflistung zurück. Im folgenden Beispiel werden die Rechtschreib- und Grammatikfehler in der Auswahl gezählt, und das Ergebnis wird in einem Meldungsfeld angezeigt.

Set pr1 = Selection.Range.SpellingErrors
   sc = pr1.Count
Set pr2 = Selection.Range.GrammaticalErrors
   gc = pr2.Count
Msgbox "Spelling errors: " & sc & vbCr _
    & "Grammatical errors: " & gc

Verwenden Sie SpellingErrors(Index) mit Index als der Indexnummer, um einen einzelnen Rechtschreibfehler (repräsentiert durch ein Range-Objekt) zurückzugeben. Im folgenden Beispiel wird der zweite Rechtschreibfehler in der Auswahl gesucht und dann gewählt.

Set myRange = Selection.Range.SpellingErrors(2)
myRange.Select

Verwenden Sie GrammarErrors(Index) mit Index als der Indexnummer, um einen einzelnen Grammatikfehler (repräsentiert durch ein Range-Objekt) zurückzugeben. Im folgenden Beispiel wird der Satz mit dem ersten Grammatikfehler in der Auswahl zurückgegeben.

Set myRange = Selection.Range.GrammaticalErrors(1)
Msgbox myRange.Text

Hinweise

Die Count-Eigenschaft für die Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Hauptkomponente zurück. Mit dem Range-Objekt können Sie die Elemente in anderen Dokumentkomponenten zählen. Wenn alle Wörter im Dokument oder Bereich richtig geschrieben wurden und grammatikalisch richtig sind, gibt die Count-Eigenschaft für das ProofreadingErrors-Objekt 0 (Null) zurück, und die SpellingChecked- und GrammarChecked-Eigenschaften geben True zurück.


Range-Objekt

Stellt eine fortlaufende Fläche in einem Dokument dar. Jedes Range-Objekt wird durch eine Anfangs- und Endposition eines Zeichens definiert. Ähnlich wie bei Textmarken werden Range-Objekte in Visual Basic-Prozeduren verwendet, um bestimmte Bestandteile eines Dokuments zu identifizieren. Ein Range-Objekt besteht im Gegensatz zur Textmarke jedoch nur für die Dauer des Ablaufs der Prozedur, die das Objekt definiert hat.

Anmerkung Range-Objekte sind nicht von der Markierung abhängig, d. h., Sie können einen Bereich definieren und manipulieren, ohne die Markierung zu ändern. Sie können auch mehrere Bereiche in einem Dokument definieren, wohingegen nur eine Markierung pro Ausschnitt existieren kann.

Verwendung des Range-Objekts

Mit der Range-Methode können Sie ein Range-Objekt zurückgeben, das durch die Zeichenpositionen am Anfang und Ende definiert ist. Das folgende Beispiel gibt ein Range-Objekt zurück, das auf die ersten 10 Zeichen im aktiven Dokument verweist.

Set myRange = ActiveDocument.Range(Start:=0, End:=10)

Mit der Range-Eigenschaft können Sie ein Range-Objekt zurückgeben, das durch den Anfang und das Ende eines anderen Objekts definiert ist. Die Range-Eigenschaft kann vielen Objekten zugewiesen werden (z. B. Paragraph, Bookmark und Cell). Das folgende Beispiel gibt ein Range-Objekt zurück, das auf den ersten Absatz im aktiven Dokument verweist.

Set aRange = ActiveDocument.Paragraphs(1).Range

Das folgende Beispiel gibt ein Range-Objekt zurück, das auf den zweiten bis vierten Absatz im aktiven Dokument verweist.

Set aRange = ActiveDocument.Range( _
    Start:=ActiveDocument.Paragraphs(2).Range.Start, _
    End:=ActiveDocument.Paragraphs(4).Range.End)

Weitere Informationen über das Arbeiten mit Range-Objekten finden Sie unter Arbeiten mit Range-Objekten.


ReadabilityStatistic-Objekt

Repräsentiert die Lesbarkeitsstatistik für ein Dokument oder einen Bereich. Das ReadabilityStatistic-Objekt ist ein Element der ReadabilityStatistics-Auflistung.

Verwendung des ReadabilityStatistic-Objekts

Verwenden Sie ReadabilityStatistics(Index) mit Index als einer Indexnummer, um ein einzelnes ReadabilityStatistic-Objekt zurückzugeben. Die statistischen Angaben sind wie folgt geordnet: Wörter, Zeichen, Absätze, Sätze, Sätze pro Absatz, Wörter pro Satz, Zeichen pro Wort, Passivsätze, Flesch Lesbarkeitsgrad und Flesch-Kincaid Grade Level. Im folgenden Beispiel wird die Zeichenzählung für das aktive Dokument zurückgegeben.

Msgbox ActiveDocument.Content.ReadabilityStatistics(2).Value


ReadabilityStatistics-Objekt (Auflistung)

Eine Auflistung mit ReadabilityStatistic-Objekten für ein Dokument oder einen Bereich.

Verwenden der ReadabilityStatistics-Auflistung

Mit der ReadabilityStatistics-Eigenschaft liefern Sie die ReadabilityStatistics-Auflistung. Im folgenden Beispiel wird die Lesbarkeitsstatistik für die Auswahl aufgezählt, und jede Angabe wird in einem Meldungsfeld angezeigt.

For each rs in Selection.Range.ReadabilityStatistics
    Msgbox rs.Name & " - " & rs.Value
Next rs

Verwenden Sie ReadabilityStatistics(Index) mit Index als der Indexnummer, um ein einzelnes ReadabilityStatistic-Objekt zurückzugeben. Die statistischen Angaben sind wie folgt geordnet: Wörter, Zeichen, Absätze, Sätze, Sätze pro Absatz, Wörter pro Satz, Zeichen pro Wort, Passivsätze, Flesch Lesbarkeitsgrad und Flesch-Kincaid Grade Level. Im folgenden Beispiel wird die Wortzählung für das aktive Dokument angegeben.

Set myRange = ActiveDocument.Content
wordval = myRange.ReadabilityStatistics(1).Value
Msgbox wordval


RecentFile-Objekt

Stellt die zuletzt benutzte Datei dar. Das RecentFile-Objekt ist ein Element der RecentFiles-Auflistung. Die RecentFiles-Auflistung enthält alle Dateien, die zuletzt benutzt wurden. Die Elemente der RecentFiles-Auflistung werden unten im Menü Datei angezeigt.

Verwendung des RecentFile-Objekts

Verwenden Sie RecentFiles(Index), um ein einzelnes RecentFile-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Datei im Menü Datei dar. Im folgenden Beispiel wird das erste Dokument in der RecentFiles-Auflistung geöffnet.

If RecentFiles.Count >= 1 Then RecentFiles(1).Open

Verwenden Sie die Add-Methode, um der RecentFiles-Auflistung eine Datei hinzuzufügen. Im folgenden Beispiel wird das aktive Dokument der Liste der zuletzt benutzten Dateien hinzugefügt.

If ActiveDocument.Saved = True Then
    RecentFiles.Add Document:=ActiveDocument.FullName, _
        ReadOnly:=True
End If

Hinweise

Die SaveAs- und die Open-Methode enthalten ein AddToRecentFiles-Argument, durch das gesteuert wird, ob eine Datei beim Öffnen oder Speichern der Liste der zuletzt benutzten Dateien hinzugefügt wird.


RecentFiles-Objekt (Auflistung)

Eine Auflistung von RecentFile-Objekten, die die zuletzt benutzten Dateien darstellen. Die Elemente der RecentFiles-Auflistung werden unten im Menü Datei angezeigt.

Verwendung der RecentFiles-Auflistung

Verwenden Sie die RecentFiles-Eigenschaft, um die RecentFiles-Auflistung zurückzugeben. Im folgenden Beispiel wird die maximale Anzahl von Dateien, die die RecentFiles-Auflistung enthalten kann, auf fünf festgelegt.

RecentFiles.Maximum = 5

Verwenden Sie die Add-Methode, um der RecentFiles-Auflistung eine Datei hinzuzufügen. Im folgenden Beispiel wird das aktive Dokument der Liste der zuletzt benutzten Dateien hinzugefügt.

If ActiveDocument.Saved = True Then
    RecentFiles.Add Document:=ActiveDocument.FullName, _
        ReadOnly:=True
End If

Verwenden Sie RecentFiles(Index), um ein einzelnes RecentFile-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Datei im Menü Datei dar. Im folgenden Beispiel wird das erste Dokument in der RecentFiles-Auflistung geöffnet.

If RecentFiles.Count >= 1 Then RecentFiles(1).Open

Hinweise

Die SaveAs- und die Open-Methode enthalten ein AddToRecentFiles-Argument, durch das gesteuert wird, ob eine Datei beim Öffnen oder Speichern der Liste der zuletzt benutzten Dateien hinzugefügt wird.


Replacement-Objekt

Stellt die Kriterien für das Ersetzen bei einer Suchen-und-Ersetzen-Operation dar. Die Eigenschaften und Methoden des Replacement-Objekts entsprechen den Optionen im Dialogfeld Suchen und Ersetzen.

Verwendung des Replacement-Objekts

Mit der Replacement-Eigenschaft können Sie ein Replacement-Objekt zurückgeben. Das folgende Beispiel ersetzt das nächste Auftreten des Worts "hi" durch das Wort "hello".

With Selection.Find
    .Text = "hi"
    .ClearFormatting
    .Replacement.Text = "hello"
    .Replacement.ClearFormatting
    .Execute Replace:=wdReplaceOne, Forward:=True
End With

Um Formatierung suchen und ersetzen zu können, muss sowohl für den Suchtext und den neuen Text eine Zeichenfolge ("") festgelegt werden. Legen Sie anschließend für das Format-Argument der Execute-Methode den Wert True fest. Das folgende Beispiel entfernt die gesamte Fettformatierung im aktiven Dokument. Für die Bold-Eigenschaft gilt True beim Find-Objekt und False beim Replacement-Objekt.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Font.Bold = True
    .Text = ""
    With .Replacement
        .ClearFormatting
        .Font.Bold = False
        .Text = ""
    End With
    .Execute Format:=True, Replace:=wdReplaceAll
End With


Revision-Objekt

Stellt eine Änderung dar, die durch eine Korrekturmarkierung gekennzeichnet wurde. Das Revision-Objekt ist ein Element der Revisions-Auflistung. Die Revisions-Auflistung enthält alle Korrekturmarkierungen in einem Bereich oder Dokument.

Verwendung des Revision-Objekts

Mit Revisions(Index) können Sie ein einzelnes Revision-Objekt zurückgeben. (Index ist die Indexnummer.) Die Indexnummer stellt die Position der Überarbeitung im Bereich oder im Dokument dar. Das folgende Beispiel zeigt den Namen des Verfassers für die erste Überarbeitung in Abschnitt 1 des aktiven Dokuments an.

MsgBox ActiveDocument.Sections(1).Range.Revisions(1).Author

Die Add-Methode ist für die Revisions-Auflistung nicht verfügbar. Revision-Objekte werden dann hinzugefügt, wenn der Versionsvergleich aktiviert ist. Legen Sie für die TrackRevisions-Eigenschaft True fest, um Überarbeitungen zu verfolgen, die am Dokumenttext vorgenommen wurden. Das folgende Beispiel aktiviert die Überarbeitungsverfolgung und fügt anschließend "Action" vor die Markierung ein.

ActiveDocument.TrackRevisions = True
Selection.InsertBefore "Action "


Revisions-Objekt (Auflistung)

Eine Auflistung mit Revision-Objekten, die die Änderungen darstellen, die in einem Bereich oder Dokument mit Korrekturmarkierungen gekennzeichnet wurden.

Verwendung der Revisions-Auflistung

Mit der Revisions-Eigenschaft können Sie die Revisions-Auflistung zurückgeben. Das folgende Beispiel zeigt die Anzahl der Überarbeitungen in der Haupttext-Komponente an.

MsgBox ActiveDocument.Revisions.Count

Das folgende Beispiel nimmt alle Überarbeitungen in der Markierung an.

For Each myRev In Selection.Range.Revisions
    myRev.Accept
Next myRev

Das folgende Beispiel nimmt alle Überarbeitungen im ersten Absatz der Markierung an.

Set myRange = Selection.Paragraphs(1).Range
myRange.Revisions.AcceptAll

Die Add-Methode ist für die Revisions-Auflistung nicht verfügbar. Revision-Objekte werden hinzugefügt, wenn der Versionsvergleich aktiviert ist. Legen Sie für die TrackRevisions-Eigenschaft True fest, um Überarbeitungen zu verfolgen, die am Dokumenttext vorgenommen wurden. Das folgende Beispiel aktiviert die Überarbeitungsverfolgung im aktiven Dokument und fügt anschließend "The " vor die Markierung ein.

ActiveDocument.TrackRevisions = True
Selection.InsertBefore "The "

Mit Revisions(Index) können Sie ein einzelnes Revision-Objekt zurückgeben. (Index ist die Indexnummer.) Die Indexnummer stellt die Position der Überarbeitung in dem Bereich oder Dokument dar. Das folgende Beispiel zeigt den Namen des Verfassers für die erste Überarbeitung im ersten Abschnitt an.

MsgBox ActiveDocument.Sections(1).Range.Revisions(1).Author

Hinweise

Die Count-Eigenschaft gibt für diese Auflistung in einem Dokument nur die Anzahl der Elemente im Haupttext zurück. Mit der Auflistung und dem Range-Objekt können Sie die Elemente anderer Komponenten zurückgeben.


RoutingSlip-Objekt

Stellt den Verteiler dar, der dem Dokument zugewiesen wurde. Mit einem Verteiler können Sie ein Dokument in einem elektronischen Mail-System weiterleiten.

Verwendung des RoutingSlip-Objekts

Mit der RoutingSlip-Eigenschaft können Sie das RoutingSlip-Objekt zurückgeben. Das folgende Beispiel leitet das aktive Dokument nacheinander an die angegebenen Empfänger weiter.

ActiveDocument.HasRoutingSlip = True
With ActiveDocument.RoutingSlip
    .Subject = "Project Documentation"
    .AddRecipient "Don Funk"
    .AddRecipient "Dave Edson"
    .Delivery = wdOneAfterAnother
End With
ActiveDocument.Route

Hinweise

Das RoutingSlip-Objekt ist erst dann vorhanden und kann verwendet werden, wenn für die HasRoutingSlip-Eigenschaft des Dokuments True gilt.


Row-Objekt

Stellt eine Zeile in einer Tabelle dar. Das Row-Objekt ist ein Element der Rows-Auflistung. Die Rows-Auflistung enthält alle Zeilen in der angegebenen Markierung, dem angegebenen Bereich oder der angegebenen Tabelle.

Verwendung des Row-Objekts

Verwenden Sie Rows(Index), um ein einzelnes Row-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Zeile in der Markierung, im Bereich oder in der Tabelle dar. Im folgenden Beispiel wird die erste Zeile der ersten Tabelle im aktiven Dokument gelöscht.

ActiveDocument.Tables(1).Rows(1).Delete

Verwenden Sie die Add-Methode, um zu einer Tabelle eine Zeile hinzuzufügen. Im folgenden Beispiel wird vor der ersten Zeile in der Markierung eine Zeile eingefügt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Rows.Add BeforeRow:=Selection.Rows(1)
End If

Hinweise

Verwenden Sie die Cells-Eigenschaft, um einzelne Zellen in einem Row-Objekt zu ändern. Im folgenden Beispiel wird zu der Markierung eine Tabelle hinzugefügt. Anschließend werden in jede Zelle der zweiten Zeile der Tabelle Zahlen eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
If Selection.Information(wdWithInTable) = False Then
    Set myTable = _
        ActiveDocument.Tables.Add(Range:=Selection.Range, _
        NumRows:=3, NumColumns:=5)
    For Each aCell In myTable.Rows(2).Cells
        i = i + 1
        aCell.Range.Text = i
    Next aCell
End If


Rows-Objekt (Auflistung)

Eine Auflistung von Row-Objekten, die die Tabellenzeilen in der angegebenen Markierung, dem angegebenen Bereich oder der angegebenen Tabelle darstellen.

Verwendung der Rows-Auflistung

Verwenden Sie die Rows-Eigenschaft, um die Rows-Auflistung zurückzugeben. Im folgenden Beispiel werden die Zeilen der ersten Tabelle im aktiven Dokument zwischen dem linken und rechten Seitenrand zentriert.

ActiveDocument.Tables(1).Rows.Alignment = wdAlignRowCenter

Verwenden Sie die Add-Methode, um zu einer Tabelle eine Zeile hinzuzufügen. Im folgenden Beispiel wird vor der ersten Zeile in der Markierung eine Zeile eingefügt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Rows.Add BeforeRow:=Selection.Rows(1)
End If

Verwenden Sie Rows(Index), um ein einzelnes Row-Objekt zurückzugeben, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position der Zeile in der Markierung, im Bereich oder in der Tabelle dar. Im folgenden Beispiel wird die erste Zeile der ersten Tabelle im aktiven Dokument gelöscht.

ActiveDocument.Tables(1).Rows(1).Delete


Section-Objekt

Stellt einen einzelnen Abschnitt in einer Markierung, einem Bereich oder einem Dokument dar. Das Section-Objekt ist ein Element der Sections-Auflistung. Die Sections-Auflistung enthält alle Abschnitte in einer Markierung, einem Bereich oder einem Dokument.

Verwendung des Section-Objekts

Mit Sections(Index) können Sie ein einzelnes Section-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel ändert die linken und rechten Seitenränder für den ersten Abschnitt im aktiven Dokument.

With ActiveDocument.Sections(1).PageSetup
    .LeftMargin = InchesToPoints(0.5)
    .RightMargin = InchesToPoints(0.5)
End With

Mit der Add- oder der InsertBreak-Methode können Sie zu einem Dokument einen neuen Abschnitt hinzufügen. Das folgende Beispiel fügt am Anfang des aktiven Dokuments einen neuen Abschnitt hinzu.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.Sections.Add Range:=myRange
myRange.InsertParagraphAfter

Das folgende Beispiel fügt einen Abschnittswechsel über den ersten Absatz der Markierung ein.

Selection.Paragraphs(1).Range.InsertBreak _
    Type:=wdSectionBreakContinuous

Anmerkung Die Headers- und Footers-Eigenschaften des angegebenen Section-Objekts geben ein HeadersFooters-Objekt zurück.


Sections-Objekt (Auflistung)

Eine Auflistung mit Section-Objekten in einer Markierung, einem Bereich oder einem Dokument.

Verwendung der Sections-Auflistung

Mit der Sections-Eigenschaft können Sie die Sections-Auflistung zurückgeben. Das folgende Beispiel fügt Text an das Ende des letzten Abschnitts im aktiven Dokument hinzu.

With ActiveDocument.Sections.Last.Range
    .Collapse Direction:=wdCollapseEnd
    .InsertAfter "end of document"
End With

Mit der Add- oder der InsertBreak-Methode können Sie zu einem Dokument einen neuen Abschnitt hinzufügen. Das folgende Beispiel fügt einen neuen Abschnitt an den Anfang des aktiven Dokuments hinzu.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.Sections.Add Range:=myRange
myRange.InsertParagraphAfter

Das folgende Beispiel zeigt die Anzahl der Abschnitte im aktiven Dokument an, fügt einen Abschnittswechsel über den ersten Absatz der Markierung hinzu und zeigt anschließend die Anzahl der Abschnitte erneut an.

MsgBox ActiveDocument.Sections.Count & " sections"
Selection.Paragraphs(1).Range.InsertBreak _
    Type:=wdSectionBreakContinuous
MsgBox ActiveDocument.Sections.Count & " sections"

Mit Sections(Index) können Sie ein einzelnes Section-Objekt zurückgeben. (Index ist die Indexnummer.) Das folgende Beispiel ändert die linken und rechten Seitenränder für den ersten Abschnitt im aktiven Dokument.

With ActiveDocument.Sections(1).PageSetup
    .LeftMargin = InchesToPoints(0.5)
    .RightMargin = InchesToPoints(0.5)
End With


Selection-Objekt

Stellt die Markierung in einem Fensterausschnitt dar. Die Markierung umgibt entweder eine Fläche im Dokument oder wird an einer Einfügemarke reduziert.

Anmerkung Es kann nur jeweils ein Selection-Objekt pro Fensterausschnitt eines Dokuments existieren und lediglich ein Selection-Objekt aktiv sein.

Verwendung des Selection-Objekts

Mit der Selection-Eigenschaft können Sie das Selection-Objekt zurückgeben. Das folgende Beispiel reduziert die Markierung (gegebenenfalls) und verschiebt die Einfügemarke an das Ende der aktuellen Zeile.

Selection.EndKey Unit:=wdLine, Extend:=wdMove

Das folgende Beispiel aktualisiert die Feldergebnisse in der Markierung.

If Selection.Fields.Count >= 1 Then Selection.Fields.Update

Mit der Type-Eigenschaft können Sie den Markierungstyp (z. B. eine Blockmarkierung oder eine Einfügemarke) zurückgeben. Das folgende Beispiel markiert den aktuellen Absatz, wenn es sich bei der Markierung um eine Einfügemarke handelt.

If Selection.Type = wdSelectionIP Then
    Selection.Paragraphs(1).Range.Select
End If

Mit der Information-Eigenschaft können Sie Informationen über die Markierung zurückgeben. Wenn sich die Markierung in einer Tabelle befindet, zeigt das folgende Beispiel die Nummer oder die Zeilen und Spalten in der Tabelle an.

If Selection.Information(wdWithInTable) = True Then
    MsgBox "Columns = " _
        & Selection.Information(wdMaximumNumberOfColumns) _
        & vbCr & "Rows = " _
        & Selection.Information(wdMaximumNumberOfRows)
End If

Mit der Select-Methode können Sie ein Element in einem Dokument markieren. Das folgende Beispiel markiert die erste Textmarke des aktiven Dokuments und formatiert sie rot.

If ActiveDocument.Bookmarks.Count >= 1 Then
    ActiveDocument.Bookmarks(1).Select
    Selection.Font.ColorIndex = wdRed
End If

Das Selection-Objekt enthält außerdem verschiedene Methoden, mit denen Sie eine vorhandene Markierung erweitern oder verschieben können. So hat z. B. die MoveDown-Methode ein Extend-Argument, für das Sie wdExtend festlegen können. Das folgende Beispiel markiert die nächsten drei Absätze im aktiven Fenster.

With Selection
    .StartOf Unit:=wdParagraph, Extend:=wdMove
    .MoveDown Unit:=wdParagraph, Count:=3, Extend:=wdExtend
End With

Hinweise

Mit der Range-Eigenschaft können Sie ein Range-Objekt aus dem Selection-Objekt zurückgeben. Das folgende Beispiel definiert die Variable myRange als markierten Bereich.

Set myRange = Selection.Range

Wenn Sie Makros aufzeichnen, werden bei der Makroaufzeichnung häufig Änderungen am Selection-Objekt aufgezeichnet. Das folgende aufgezeichnete Makro weist den ersten beiden Wörtern des Dokuments Fettformatierung zu und fügt anschließend einen neuen Absatz ein.

Selection.HomeKey Unit:=wdStory
Selection.MoveRight Unit:=wdWord, Count:=2, Extend:=wdExtend
Selection.Font.Bold = wdToggle
Selection.MoveRight Unit:=wdCharacter, Count:=1
Selection.TypeParagraph

Im folgenden Beispiel wird das Gleiche ausgeführt wie im vorhergehenden Beispiel, wobei jedoch nicht das Selection-Objekt verwendet wird.

Set myRange = ActiveDocument.Range(Start:=0, _
    End:=ActiveDocument.Words(2).End)
myRange.Bold = True
myRange.InsertParagraphAfter

Es kann zwar nur ein Selection-Objekt pro Fensterausschnitt existieren, Sie können jedoch mehrere Range-Objekte in einem einzelnen Dokument definieren. Ein Range-Objekt stellt einen Dokumentbereich dar, der unter Umständen markiert werden kann. Mit Range-Objekten können Sie ein Dokument mit wenigen Bildschirmaktualisierungen manipulieren. Weitere Informationen finden Sie unter Arbeiten mit Range-Objekten.


 Sentences-Objekt (Auflistung)

Sentences-Objekt (Auflistung)

Eine Auflistung von Range-Objekten, die alle Sätze in einer Markierung, einem Bereich oder einem Dokument darstellt. Es gibt kein Sentence-Objekt.

Verwendung der Sentences-Auflistung

Verwenden Sie die Sentences-Eigenschaft, um die Sentences-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der markierten Sätze angezeigt.

MsgBox Selection.Sentences.Count & " sentences are selected"

Verwenden Sie Sentences(Index), um ein Range-Objekt zurückzugeben, das einen Satz darstellt, wobei Index die Indexnummer ist. Die Indexnummer stellt die Position eines Satzes in der Sentences-Auflistung dar. Im folgenden Beispiel wird der erste Satz im aktiven Dokument formatiert.

With ActiveDocument.Sentences(1)
    .Bold = True
    .Font.Size = 24
End With

Hinweise

Die Count-Eigenschaft für die Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Hauptkomponente zurück. Mit dem Range-Objekt können Sie Elemente in anderen Dokumentkomponenten zählen.

Die Add-Methode ist für die Sentences-Auflistung nicht verfügbar. Verwenden Sie stattdessen die InsertAfter- oder die InsertBefore-Methode, um zu einem Range-Objekt einen Satz hinzuzufügen. Im folgenden Beispiel wird nach dem ersten Absatz im aktiven Dokument ein Satz eingefügt.

With ActiveDocument
    MsgBox .Sentences.Count & " sentences"
    .Paragraphs(1).Range.InsertParagraphAfter
    .Paragraphs(2).Range.InsertBefore "The house is blue."
    MsgBox .Sentences.Count & " sentences"
End With


Shading-Objekt

Enthält Schattierungseigenschaften für ein Objekt.

Verwendung des Shading-Objekts

Verwenden Sie die Shading-Eigenschaft, um das Shading-Objekt zurückzugeben. Im folgenden Beispiel wird dem ersten Absatz im aktiven Dokument eine hellgraue Schattierung zugewiesen.

ActiveDocument.Paragraphs(1).Shading.Texture = wdTexture10Percent

Im folgenden Beispiel wird der Markierung eine Schattierung mit unterschiedlichen Farben für Vorder- und Hintergrund zugewiesen.

With Selection.Shading
    .Texture = wdTexture20Percent
    .ForegroundPatternColorIndex = wdBlue
    .BackgroundPatternColorIndex = wdYellow
End With

Im folgenden Beispiel wird der ersten Zeile in der ersten Tabelle im aktiven Dokument eine vertikal verlaufende Linienstruktur zugewiesen.

ActiveDocument.Tables(1).Rows(1).Shading.Texture = _
    wdTextureVertical


ShadowFormat-Objekt

Repräsentiert die Schattenformatierung einer Form.

Verwendung von ShadowFormat-Objekten

Verwenden Sie die Shadow-Eigenschaft, um ein ShadowFormat-Objekt zurückzugeben. Im folgenden Beispiel wird zu dem aktiven Dokument ein schattiertes Rechteck hinzugefügt. Der halb-transparente, blaue Schatten ist um 5 Punkt nach rechts und 3 Punkt nach oben vom Rechteck aus versetzt.

With ActiveDocument.Shapes _
        .AddShape(msoShapeRectangle, 50, 50, 100, 200).Shadow
    .ForeColor.RGB = RGB(0, 0, 128)
    .OffsetX = 5
    .OffsetY = -3
    .Transparency = 0.5
    .Visible = True
End With


Shape-Objekt

Repräsentiert ein Objekt auf der Zeichenebene, z. B. eine AutoForm, ein Freihandobjekt, ein OLE-Objekt, ein ActiveX-Steuerelement oder ein Bild. Das Shape-Objekt ist ein Element der Shapes-Auflistung, die alle Formen im Haupttextbereich eines Dokuments oder in allen Kopf- und Fußnoten eines Dokuments enthält.

Eine Form ist immer mit einem Verankerungsbereich verbunden. Sie können das Shape an einer beliebigen Stelle auf der Seite mit der Verankerung positionieren.

Anmerkung Formen werden von drei Objekten repräsentiert: von der Shapes-Auflistung, die alle Formen in einem Dokument repräsentiert; von der ShapeRange-Auflistung, die einen bestimmten Teilbereich der Formen in einem Dokument repräsentiert (z. B. könnte ein ShapeRange-Objekt die Formen 1 und 4 im Dokument oder alle markierten Formen im Dokument repräsentieren); von dem Shape-Objekt, das eine einzelne Form im Dokument darstellt. Wenn Sie gleichzeitig mit mehreren Formen oder mit Formen in der Auswahl arbeiten, verwenden Sie eine ShapeRange-Auflistung.

Verwendung von Shape-Objekten

Dieser Abschnitt beschreibt, wie Sie:

  • Eine vorhandene Form in einem Dokument zurückgeben, die nach Name oder Nummer indiziert wurde.

  • Eine oder mehrere Formen in einer Auswahl zurückgeben.

  • Eine neu angelegte Form zurückgeben.

  • Eine einzelne Form aus einer Gruppe zurückgeben.

  • Eine neu angelegte Formengruppe zurückgeben.

Zurückgeben einer vorhandenen Form in einem Dokument

Verwenden Sie Shapes(Index) mit Index als Namen oder Indexnummer, um ein einzelnes Shape-Objekt zurückzugeben. Im folgenden Beispiel wird Form 1 im aktiven Dokument horizontal gekippt.

ActiveDocument.Shapes(1).Flip msoFlipHorizontal

Im folgenden Beispiel wird die Form "Rectangle 1" im aktiven Dokument horizontal gekippt.

ActiveDocument.Shapes("Rectangle 1").Flip msoFlipHorizontal

Jeder Form wird ein Standardname zugewiesen, wenn sie erstellt wird. Wenn Sie beispielsweise drei unterschiedliche Formen zu einem Dokument hinzufügen, werden sie u. U. "Rechteck 2", "Textfeld 3" und "Oval 4" benannt. Mit der Name-Eigenschaft können Sie einer Form einen sinnvolleren Namen geben.

Zurückgeben einer oder mehrerer Formen in einer Auswahl

Verwenden Sie Selection.ShapeRange(Index) mit Index als Namen oder Indexnummer, um ein Shape-Objekt zurückzugeben, das eine Form in einer Auswahl repräsentiert. Im folgenden Beispiel wird die Füllung der ersten Form in der Auswahl festgelegt, vorausgesetzt, in der Auswahl befindet sich mindestens eine Form.

Selection.ShapeRange(1).Fill.ForeColor.RGB = RGB(255, 0, 0)

Im folgenden Beispiel wird die Füllung für alle Formen in der Auswahl festgelegt, vorausgesetzt, in der Auswahl befindet sich mindestens eine Form.

Selection.ShapeRange.Fill.ForeColor.RGB = RGB(255, 0, 0)

Zurückgeben einer neu angelegten Form

Um ein Shape-Objekt zu der Auflistung der Formen im angegebenen Dokument hinzuzufügen oder ein Shape-Objekt zurückzugeben, das die neu angelegte Form repräsentiert, verwenden Sie eine der folgenden Methoden der Shapes-Auflistung: AddCallout, AddCurve, AddLabel, AddLine, AddOleControl, AddOleObject, AddPolyline, AddShape, AddTextbox, AddTextEffect oder BuildFreeForm. Im folgenden Beispiel wird ein Rechteck zu dem aktiven Dokument hinzugefügt.

ActiveDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200

Zurückgeben einer einzelnen Form aus einer Gruppe

Verwenden Sie GroupItems(Index) mit Index als Namen der Form innerhalb der Gruppe, um ein Shape-Objekt zurückzugeben, das eine einzelne Form in einer gruppierten Form darstellt.

Zurückgeben einer neu angelegten Formengruppe

Verwenden Sie die Group- oder Regroup-Methode, um einen Formbereich zu gruppieren und ein einzelnes Shape-Objekt zurückzugeben, das die neu angelegte Gruppe darstellt. Nach dem Anlegen der Gruppe können Sie mit ihr auf dieselbe Weise arbeiten wie mit jeder anderen Form.

Verankern und Positionieren einer Form

Jedes Shape-Objekt ist mit einem Textbereich verankert. Eine Form ist mit dem Anfang des ersten Absatzes verankert, das den Verankerungsbereich enthält. Die Form befindet sich immer auf derselben Seite wie ihre Verankerung.

Sie können die Verankerung anzeigen, indem Sie True als Wert für die ShowObjectAnchors-Eigenschaft festlegen. Die Top- und die Left-Eigenschaft der Form bestimmen ihre horizontale und vertikale Position. Die RelativeHorizontalPosition- und RelativeVerticalPosition-Eigenschaft der Form bestimmen, ob die Position vom Absatz mit der Verankerung, von der Spalte, die den Absatz mit der Verankerung enthält, von dem Seiten- oder dem Blattrand gemessen wird.

Wenn True als Wert der LockAnchor-Eigenschaft festgelegt wurde, können Sie die Verankerung nicht von ihrer Position auf der Seite wegziehen.

Formatieren einer Form

Verwenden Sie die Fill-Eigenschaft, um das FillFormat-Objekt zurückzugeben, das alle Eigenschaften und Methoden zum Formatieren der Füllung einer geschlossenen Form enthält. Die Shadow-Eigenschaft gibt das ShadowFormat-Objekt zurück, mit dem Sie einen Schatten formatieren. Verwenden Sie die Line-Eigenschaft, um das LineFormat-Objekt zurückzugeben, das alle Eigenschaften und Methoden zum Formatieren von Linien und Pfeilen enthält. Die TextEffect-Eigenschaft gibt das TextEffectFormat-Objekt zurück, mit dem Sie WordArt formatieren. Die Callout-Eigenschaft gibt das CalloutFormat-Objekt zurück, mit dem Sie Legenden mit Linien formatieren. Die WrapFormat-Eigenschaft gibt das WrapFormat-Objekt zurück, mit dem Sie festlegen, wie Text um Formen umbrochen wird. Die ThreeD-Eigenschaft gibt das ThreeDFormat-Objekt zurück, mit dem Sie 3D-Formen erstellen. Mit der PickUp- und Apply-Methode können Sie die Formatierung von einer Form auf eine andere übertragen.

Verwenden Sie die SetShapesDefaultProperties-Methode mit einem Shape-Objekt, um die Formatierung der Standardform für das Dokument festzulegen. Neue Formen erben viele Attribute von der Standardform.

Andere wichtige Eigenschaften für Formen

Verwenden Sie die Type-Eigenschaft, um den Typ der Form festzulegen: z. B. Freihandform, AutoForm, OLE-Objekt, Legende oder verknüpftes Bild. Verwenden Sie die AutoShapeType-Eigenschaft, um den Typ der AutoForm festzulegen: z. B. oval, rechteckig oder sprechblasenförmig.

Verwenden Sie die Width- und Height-Eigenschaften, um die Größe der Form festzulegen.

Die TextFrame-Eigenschaft gibt das TextFrame-Objekt zurück, das alle Eigenschaften und Methoden zum Verbinden von Text mit Formen und Verknüpfen von Text in Textrahmen enthält.

Hinweise

Shape-Objekte sind mit einem Textbereich verankert, aber frei beweglich und können an beliebiger Stelle auf der Seite positioniert werden. InlineShape-Objekte werden wie Zeichen behandelt und wie Zeichen innerhalb einer Textzeile positioniert. Mit der ConvertToInlineShape- und der ConvertToShape-Methode können Sie Formen eines Typs in in Formen eines anderen Typs umwandeln. Sie können nur Bilder, OLE-Objekte und ActiveX-Steuerelemente in eingebettete Formen umwandeln.


Shapes-Objekt (Auflistung)

Eine Auflistung mit Shape-Objekten, die alle Formen in einem Dokument oder alle Formen in den Kopf- oder Fußzeilen eines Dokuments repräsentiert. Jedes Shape-Objekt repräsentiert ein Objekt auf der Zeichenebene, z. B. eine AutoForm, eine Freihandform, ein OLE-Objekt oder ein Bild.

Anmerkung Wenn Sie mit einem Teilbereich der Formen in einem Dokument arbeiten wollen, beispielsweise nur mit den AutoFormen oder den gewählten Formen in einem Dokument, müssen Sie eine ShapeRange-Auflistung mit den Formen erstellen, mit denen Sie arbeiten wollen.

Verwendung der Shapes-Auflistung

Verwenden Sie die Shapes-Eigenschaft, um die Shapes-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Formen im aktiven Dokument gewählt.

ActiveDocument.Shapes.SelectAll

Anmerkung Wenn Sie gleichzeitig bestimmte Aktionen mit allen Formen in einem Dokument durchführen wollen (z. B. eine Eigenschaft festlegen oder löschen), verwenden Sie die Range-Methode, um ein ShapeRange-Objekt mit allen Formen in der Shapes-Auflistung zu erstellen. Weisen Sie anschließend die entsprechende Eigenschaft oder Methode dem ShapeRange-Objekt zu.

Verwenden Sie eine der folgenden Methoden der Shapes-Auflistung: AddCallout, AddCurve, AddLabel, AddLine, AddOleControl, AddOleObject, AddPolyline, AddShape, AddTextbox, AddTextEffect oder BuildFreeForm, um eine Form zu einem Dokument hinzuzufügen und ein Shape-Objekt zurückzugeben, das die neu erstellte Form repräsentiert. Im folgenden Beispiel wird ein Rechteck zu dem aktiven Dokument hinzugefügt.

ActiveDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200

Verwenden Sie Shapes(Index) mit Index als Namen oder Indexnummer, um ein einzelnes Shape-Objekt zurückzugeben. Im folgenden Beispiel wird Form 1 im aktiven Dokument horizontal gekippt.

ActiveDocument.Shapes(1).Flip msoFlipHorizontal

In diesem Beispiel wird die Form "Rectangle 1" im aktiven Dokument horizontal gekippt.

ActiveDocument.Shapes("Rectangle 1").Flip msoFlipHorizontal

Jeder Form wird ein Standardname zugewiesen, wenn sie erstellt wird. Wenn Sie beispielsweise drei unterschiedliche Formen zu einem Dokument hinzufügen, werden sie unter Umständen "Rechteck 2", "Textfeld 3" und "Oval 4" benannt. Mit der Name-Eigenschaft können Sie einer Form einen sinnvolleren Namen geben.

Hinweise

Die Shapes-Auflistung enthält keine InlineShape-Objekte. InlineShape-Objekte werden wie Zeichen behandelt und wie Zeichen innerhalb einer Textzeile positioniert. Shape-Objekte sind mit einem Textbereich verankert, aber frei beweglich und können an beliebiger Stelle auf der Seite positioniert werden. Mit der ConvertToInlineShape- und der ConvertToShape-Methode können Sie Formen eines Typs in Formen eines anderen Typs umwandeln. Sie können nur Bilder, OLE-Objekte und ActiveX-Steuerelemente in eingebettete Formen umwandeln.

Die Count-Eigenschaft für diese Auflistung in einem Dokument gibt nur die Anzahl der Elemente im Haupttextbereich zurück. Um die Formen in den Kopf- und Fußzeilen zu zählen, verwenden Sie die Shapes-Auflistung mit einem beliebigen HeaderFooter-Objekt.


ShapeNode-Objekt

Repräsentiert die Geometrie und alle die Geometrie bearbeitenden Eigenschaften der Knoten einer benutzerdefinierten Freihandform. Zu den Knoten gehören auch die Scheitelpunkte zwischen den Segmenten der Freihandform und die Kontrollpunkte für Kurvensegmente. Das ShapeNode-Objekt ist ein Element der ShapeNodes-Auflistung. Die ShapeNodes-Auflistung enthält alle Knoten in einer Freihandform.

Verwendung von ShapeNode-Objekten

Verwenden Sie Nodes(Index) mit Index als Knoten-Indexnummer, um ein einzelnes ShapeNode-Objekt zurückzugeben. Wenn es sich bei Knoten 1 in Form 3 im aktiven Dokument um einen Eckpunkt handelt, verwandelt das folgende Beispiel ihn zu einem Übergangspunkt. Dieses Beispiel funktioniert nur, wenn es sich bei Form 3 um eine Freihandform handelt.

With ActiveDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeNodes-Objekt (Auflistung)

Eine Auflistung aller ShapeNode-Objekte in der angegebenen Freihandform. Jedes ShapeNode-Objekt repräsentiert entweder einen Knoten zwischen Segmenten in einer Freihandform oder einen Kontrollpunkt eines Kurvensegments in einer Freihandform. Sie können eine Freihandform manuell oder mit der BuildFreeform- und der ConvertToShape Methode erstellen.

Verwendung der ShapeNodes-Auflistung

Verwenden Sie die Nodes-Eigenschaft, um die ShapeNodes-Auflistung zurückzugeben. Im folgenden Beispiel wird Knoten 4 in Form 3 im aktiven Dokument gelöscht. Dieses Beispiel funktioniert nur, wenn es sich bei Form 3 um eine Freihandform mit mindestens vier Knoten handelt.

ActiveDocument.Shapes(3).Nodes.Delete 4

Verwenden Sie die Insert-Methode, um einen neuen Knoten zu erstellen und ihn zur ShapeNodes-Auflistung hinzuzufügen. Im folgenden Beispiel wird ein Übergangspunkt mit einem Kurvensegment nach Knoten 4 in Form 3 im aktiven Dokument eingefügt. Dieses Beispiel funktioniert nur, wenn es sich bei Form 3 um eine Freihandform mit mindestens vier Knoten handelt.

With ActiveDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With

Verwenden Sie Nodes(Index) mit Index als Knoten-Indexnummer, um ein einzelnes ShapeNode-Objekt zurückzugeben. Wenn es sich bei Knoten 1 in Form 3 im aktiven Dokument um einen Eckpunkt handelt, verwandelt das folgende Beispiel ihn zu einem Übergangspunkt. Dieses Beispiel funktioniert nur, wenn es sich bei Form 3 um eine Freihandform handelt.

With ActiveDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeRange-Objekt (Auflistung)

Repräsentiert einen Formbereich, bei dem es sich um eine Reihe von Formen in einem Dokument handelt. Ein Formbereich muss mindestens eine einzelne Form und kann höchstens alle Formen in einem Dokument enthalten. Bei der Bildung eines Formbereichs können Sie jede beliebige Form aufnehmen, die Sie aus allen Formen in einem Dokument oder der Auswahl wählen. Beispielsweise können Sie eine ShapeRange-Auflistung erstellen, die die ersten drei Formen in einem Dokument, alle Formen in einem Dokument oder alle Freihandformen in einem Dokument enthält.

Anmerkung Die meisten Operationen, die Sie einem Shape-Objekt zuweisen, können Sie auch einem ShapeRange-Objekt mit nur einer Form zuweisen. Einige Operationen verursachen einen Fehler, wenn Sie sie mit einem ShapeRange-Objekt mit mehreren Formen durchführen.

Verwendung der ShapeRange-Auflistung

Dieser Abschnitt beschreibt, wie Sie:

  • Eine Gruppe von Formen zurückgeben, die Sie nach dem Namen oder der Indexnummer festlegen.

  • Ein ShapeRange-Objekt in einer Auswahl oder einem Bereich zurückgeben.

Zurückgeben einer Gruppe von Formen, die Sie nach Name oder Indexnummer festlegen

Verwenden Sie Shapes.Range(Index) mit Index als Namen oder Indexnummer der Form oder des Datenfelds, das entweder Namen oder Indexnummer von Formen enthält, um eine ShapeRange-Auflistung zurückzugeben, die eine Gruppe von Formen in einem Dokument darstellt. Mit der Array-Funktion können Sie ein Datenfeld mit Namen oder Indexnummern erstellen. Im folgenden Beispiel wird das Füllmuster für die Formen 1 und 3 im aktiven Dokument festgelegt.

ActiveDocument.Shapes.Range(Array(1, 3)).Fill.Patterned _
    msoPatternHorizontalBrick

Im folgenden Beispiel werden die Formen "Oval 4" und "Rectangle 5" im aktiven Dokument gewählt.

ActiveDocument.Shapes.Range(Array("Oval 4", "Rectangle 5")).Select

Obwohl Sie mit der Range-Methode eine beliebige Anzahl von Formen zurückgeben können, ist die Verwendung der Item-Methode einfacher, wenn Sie nur ein einzelnes Element der Auflistung zurückgeben wollen. Beispielsweise ist Shapes(1) einfacher als Shapes.Range(1).

Zurückgeben eines ShapeRange-Objekts in einer Auswahl oder in einem Bereich

Verwenden Sie Selection.ShapeRange(Index) mit Index als Namen oder Indexnummer, um ein Shape-Objekt zurückzugeben, das eine Form in der Auswahl repräsentiert. Im folgenden Beispiel wird die Füllung für die erste Form in der Auswahl festgelegt, unter der Voraussetzung, dass sich wenigstens eine Form in der Auswahl befindet.

Selection.ShapeRange(1).Fill.ForeColor.RGB = RGB(255, 0, 0)

In diesem Beispiel werden alle Formen im ersten Abschnitt des aktiven Dokuments gewählt.

Set myRange = ActiveDocument.Sections(1).Range
myRange.ShapeRange.Select

Ausrichten, Verteilen und Gruppieren von Formen in einem ShapeRange-Objekt

Verwenden Sie die Align-, die Distribute- und die ZOrder-Methode, um eine Gruppe von Formen, relativ zueinander oder relativ zum Dokument, zu positionieren.

Verwenden Sie die Group-, die Regroup- und die UnGroup-Methode, um eine einzelne Form aus einem Formbereich zu erstellen und damit zu arbeiten. Die GroupItems-Eigenschaft des Shape-Objekts gibt das GroupShapes-Objekt zurück, das alle Formen repräsentiert, die gruppiert wurden, um eine Form zu bilden.

Hinweise

Bei der Aufzeichnung von Formen wird immer die ShapeRange-Eigenschaft verwendet.

Ein ShapeRange-Objekt enthält keine InlineShape-Objekte.


SpellingSuggestion-Objekt

Repräsentiert einen einzelnen Vorschlag der Rechtschreibprüfung für ein falsch geschriebenes Wort. Das SpellingSuggestion-Objekt ist ein Element der SpellingSuggestions-Auflistung. Die SpellingSuggestions-Auflistung enthält alle Vorschläge für ein bestimmtes Wort oder für das erste Wort in einem angegebenen Bereich.

Verwenden des SpellingSuggestion-Objekts

Verwenden Sie GetSpellingSuggestions(Index) mit Index als der Indexnummer, um ein einzelnes SpellingSuggestion-Objekt zurückzugeben. Im folgenden Beispiel wird überprüft, ob es Rechtschreibvorschläge für das erste Wort im aktiven Dokument gibt. Falls ja, wird der erste Vorschlag in einem Meldungsfeld angezeigt.

If ActiveDocument.Words(1).GetSpellingSuggestions.Count <> 0 Then
    MsgBox _
        ActiveDocument.Words(1).GetSpellingSuggestions.Item(1).Name
EndIf

Hinweise

Die Count-Eigenschaft für das SpellingSuggestions-Objekt gibt 0 (Null) zurück, wenn das Wort richtig geschrieben wurde oder es keine Vorschläge gibt.


SpellingSuggestions-Objekt (Auflistung)

Eine Auflistung mit SpellingSuggestion-Objekten, die die Vorschläge für ein bestimmtes Wort oder das erste Wort im angegebenen Bereich darstellen.

Verwendung der SpellingSuggestions-Auflistung

Mit der GetSpellingSuggestions-Methode liefern Sie die SpellingSuggestions-Auflistung. Wird die SpellingSuggestions-Methode einem Application-Objekt zugewiesen, muss das zu überprüfende Wort angegeben werden. Wird die GetSpellingSuggestions-Methode einem Bereich zugewiesen, wird das erste Wort im Bereich überprüft. Im folgenden Beispiel wird überprüft, ob es für beliebige Wörter im aktiven Dokument Vorschläge zur Rechtschreibung gibt. Falls ja, werden die Vorschläge in einem Meldungsfeld angezeigt.

For Each wd In ActiveDocument.Words
    Set sugg = wd.GetSpellingSuggestions
    If sugg.Count <> 0 Then
        For Each ss In sugg
            MsgBox ss.Name
        Next ss
    End If
Next wd

Hinweise

Es ist nicht möglich, Vorschläge aus der Auflistung der Rechtschreibvorschläge zu entfernen oder in sie aufzunehmen. Vorschläge zur Rechtschreibung werden dem Standardwörterbuch und den Benutzerwörterbüchern entnommen.


 StoryRanges-Objekt (Auflistung)

StoryRanges-Objekt (Auflistung)

Eine Auflistung von Range-Objekten, die Dokumentkomponenten in einem Dokument repräsentieren.

Verwendung der StoryRanges-Auflistung

Verwenden Sie die StoryRanges-Eigenschaft, um die StoryRanges-Auflistung zurückzugeben. Im folgenden Beispiel wird die manuelle Zeichenformatierung von Text in allen Dokumentkomponenten im aktiven Dokument entfernt, außer im Haupttextbereich.

For Each aStory In ActiveDocument.StoryRanges
    If aStory.StoryType <> wdMainTextStory Then aStory.Font.Reset
Next aStory

Die Add-Methode steht nicht für die StoryRanges-Auflistung zur Verfügung. Die Anzahl der Dokumentkomponenten in der StoryRanges-Auflistung ist endlich.

Verwenden Sie StoryRanges(Index) mit Index als einer WdStoryType-Konstanten, um eine einzelne Dokumentkomponente als ein Range-Objekt zurückzugeben. Im folgenden Beispiel wird zu der primären Kopfzeilenkomponente Text hinzugefügt und anschließend angezeigt.

ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary).Range _
    .Text = "Header text"
MsgBox ActiveDocument.StoryRanges(wdPrimaryHeaderStory).Text

Im folgenden Beispiel wird der Text der Fußnoten im aktiven Dokument in ein neues Dokument kopiert.

If ActiveDocument.Footnotes.Count >= 1 Then
    ActiveDocument.StoryRanges(wdFootnotesStory).Copy
    Documents.Add.Content.Paste
End If

Hinweise

Wenn Sie versuchen, eine Dokumentkomponente zurückzugeben, die im angegebenen Dokument nicht zur Verfügung steht, tritt ein Fehler auf. Im folgenden Beispiel wird festgestellt, ob eine Fußnotenkomponente im aktiven Dokument zur Verfügung steht oder nicht.

On Error GoTo errhandler
Set MyRange = ActiveDocument.StoryRanges(wdFootnotesStory)
errhandler:
If Err = 5941 Then MsgBox "The footnotes story is not available."

Verwenden Sie die NextStoryRange-Eigenschaft, um alle Dokumentkomponenten in einem Dokument zu durchlaufen. Im folgenden Beispiel wird in allen Dokumentkomponenten im aktiven Dokument der Text "Microsoft Word" gesucht. Wenn der Text gefunden wird, wird er kursiv formatiert.

For Each myStoryRange In ActiveDocument.StoryRanges
    myStoryRange.Find.Execute _
        FindText:="Microsoft Word", Forward:=True
    While myStoryRange.Find.Found
        myStoryRange.Italic = True
        myStoryRange.Find.Execute _
            FindText:="Microsoft Word", Forward:=True
    Wend
    While Not (myStoryRange.NextStoryRange Is Nothing)
        Set myStoryRange = myStoryRange.NextStoryRange
        myStoryRange.Find.Execute _
            FindText:="Microsoft Word", Forward:=True
        While myStoryRange.Find.Found
            myStoryRange.Italic = True
            myStoryRange.Find.Execute _
                FindText:="Microsoft Word", Forward:=True
        Wend
    Wend
Next myStoryRange


Style-Objekt

Repräsentiert eine einzelne, integrierte oder benutzerdefinierte Formatvorlage. Das Style-Objekt enthält Stilattribute (Schriftart, Schriftschnitt, Absatzabstand, usw.) als Eigenschaften des Style-Objekts. Das Style-Objekt ist ein Element der Styles-Auflistung. Die Styles-Auflistung enthält alle Formatvorlagen im angegebenen Dokument.

Verwendung von Style-Objekten

Verwenden Sie Styles(Index) mit Index als Namen der Formatvorlage, einer WdBuiltinStyle-Konstanten oder Indexnummer, um ein einzelnes Style-Objekt zurückzugeben. Rechtschreibung und Leerzeichen des Namens der Formatvorlage müssen genau eingehalten werden, aber nicht unbedingt die Großschreibung. Im folgenden Beispiel wird der Schriftartname der benutzerdefinierten Formatvorlage "Color" im aktiven Dokument geändert.

ActiveDocument.Styles("Color").Font.Name = "Arial"

Im folgenden Beispiel wird festgelegt, dass die integrierte Formatvorlage Überschrift 1 nicht fett formatiert wird.

ActiveDocument.Styles(wdStyleHeading1).Font.Bold = False

Die Indexnummer der Formatvorlage repräsentiert die Position der Formatvorlage in der alphabetisch sortierten Liste der Formatvorlagennamen. Beachten Sie, dass Styles(1) die erste Formatvorlage in der alphabetischen Liste ist. Im folgenden Beispiel werden die Basis-Formatvorlage und der Name der ersten Formatvorlage in der Styles-Auflistung angezeigt.

MsgBox "Base style= " _
    & ActiveDocument.Styles(1).BaseStyle & vbCr _
    & "Style name= " & ActiveDocument.Styles(1).NameLocal

Um eine Formatvorlage einem Bereich, einem Absatz oder mehreren Absätzen zuzuweisen, legen Sie als Wert für die Style-Eigenschaft den Namen einer benutzerdefinierten oder integrierten Formatvorlage fest. Im folgenden Beispiel wird die Formatvorlage Standard den ersten vier Absätzen im aktiven Dokument zugewiesen.

Set myRange = ActiveDocument.Range( _
    Start:=ActiveDocument.Paragraphs(1).Range.Start, _
    End:=ActiveDocument.Paragraphs(4).Range.End)
myRange.Style = wdStyleNormal

Im folgenden Beispiel wird die Formatvorlage Überschrift 1 dem ersten Absatz in der Auswahl zugewiesen.

Selection.Paragraphs(1).Style = wdStyleHeading1

Im folgenden Beispiel wird die Zeichen-Formatvorlage "Bolded" erstellt und der Auswahl zugewiesen.

Set myStyle = ActiveDocument.Styles.Add(Name:="Bolded", _
    Type:=wdStyleTypeCharacter)
myStyle.Font.Bold = True
Selection.Range.Style = "Bolded"

Hinweise

Verwenden Sie die OrganizerCopy-Methode, um Formatvorlagen zwischen Dokumenten und Dokumentvorlagen zu kopieren. Verwenden Sie die UpdateStyles-Methode, um Formatvorlagen im aktiven Dokument zu aktualisieren, damit sie den Formatdefinitionen in der verbundenen Dokumentvorlage entsprechen. Verwenden Sie die OpenAsDocument-Methode, um eine Dokumentvorlage als Dokument zu öffnen, damit Sie die Formatvorlagen in der Dokumentvorlage bearbeiten können.


Styles-Objekt (Auflistung)

Eine Auflistung von Style-Objekten, die die integrierten und benutzerdefinierten Formatvorlagen in einem Dokument repräsentiert.

Verwendung der Styles-Auflistung

Verwenden Sie die Styles-Eigenschaft, um die Styles Auflistung zurückzugeben. Im folgenden Beispiel werden alle benutzerdefinierten Formatvorlagen im aktiven Dokument gelöscht.

For Each sty In ActiveDocument.Styles
    If sty.BuiltIn = False Then sty.Delete
Next sty

Verwenden Sie die Add-Methode, um eine neue benutzerdefinierte Formatvorlage zu erstellen und sie in die Styles-Auflistung aufzunehmen. Im folgenden Beispiel wird die neue Zeichen-Formatvorlage "Introduction" hinzugefügt und als 12 Punkt Arial mit den Formatierungen "Fett" und "Kursiv" definiert. Anschließend wird die neue Zeichenformatvorlage der Auswahl zugewiesen.

Set myStyle = ActiveDocument.Styles.Add(Name:="Introduction", _
    Type:=wdStyleTypeCharacter)
With myStyle.Font
    .Bold = True
    .Italic = True
    .Name = "Arial"
    .Size = 12
End With
Selection.Range.Style = "Introduction"

Verwenden Sie Styles(Index) mit Index als Namen, eine WdBuiltinStyle-Konstante oder eine Indexnummer, um ein einzelnes Style-Objekt zurückzugeben. Rechtschreibung und Leerzeichen des Namens der Formatvorlage müssen genau eingehalten werden, aber nicht unbedingt die Großschreibung. Im folgenden Beispiel wird die Schriftart der benutzerdefinierten Formatvorlage "Color" im aktiven Dokument geändert.

ActiveDocument.Styles("Color").Font.Name = "Arial"

Im folgenden Beispiel wird festgelegt, dass die integrierte Formatvorlage Überschrift 1 nicht fett formatiert wird.

ActiveDocument.Styles(wdStyleHeading1).Font.Bold = False

Die Indexnummer der Formatvorlage repräsentiert die Position der Formatvorlage in der alphabetisch sortierten Liste der Formatvorlagennamen. Beachten Sie, dass Styles(1) die erste Formatvorlage in der alphabetischen Liste ist. Im folgenden Beispiel werden die Basis-Formatvorlage und der Name der ersten Formatvorlage in der Styles-Auflistung angezeigt.

MsgBox "Base style= " _
    & ActiveDocument.Styles(1).BaseStyle & vbCr _
    & "Style name= " & ActiveDocument.Styles(1).NameLocal

Hinweise

Das Styles-Objekt ist von einem Template-Objekt aus nicht verfügbar. Sie können jedoch mit der OpenAsDocument-Methode eine Dokumentvorlage als Dokument öffnen, um die Formatvorlagen in der Dokumentvorlage zu ändern. Im folgenden Beispiel wird die Formatierung der Formatvorlage Überschrift 1 in der mit dem aktiven Dokument verbundenen Dokumentvorlage geändert.

Set aDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
With aDoc
    .Styles(wdStyleHeading1).Font.Name = "Arial"
    .Close SaveChanges:=wdSaveChanges
End With

Verwenden Sie die OrganizerCopy-Methode, um Formatvorlagen zwischen Dokumenten und Dokumentvorlagen zu kopieren. Verwenden Sie die UpdateStyles-Methode, um Formatvorlagen im aktiven Dokument zu aktualisieren, damit sie den Formatdefinitionen in der verbundenen Dokumentvorlage entsprechen.


Subdocument-Objekt

Repräsentiert ein Filialdokument in einem Dokument oder Bereich. Das Subdocument-Objekt ist ein Element der Subdocuments-Auflistung. Die Subdocuments-Auflistung enthält alle Filialdokumente in einem Bereich oder Dokument.

Verwendung des Subdocument-Objekts

Verwenden Sie Subdocuments(Index) mit Index als Indexnummer, um ein einzelnes Subdocument-Objekt zurückzugeben. Im folgenden Beispiel werden der Pfad- und Dateiname des ersten Filialdokuments im aktiven Dokument angezeigt.

If ActiveDocument.Subdocuments(1).HasFile = True Then
    MsgBox ActiveDocument.Subdocuments(1).Path & _
        Application.PathSeparator _
        & ActiveDocument.Subdocuments(1).Name
End If

Verwenden Sie die AddFromFile- oder AddFromRange-Methode, um zu einem Dokument ein Filialdokument hinzuzufügen. Im folgenden Beispiel wird das Filialdokument "Setup.doc" am Ende des aktiven Dokuments eingefügt.

ActiveDocument.Subdocuments.Expanded = True
Selection.EndKey Unit:=wdStory
Selection.InsertParagraphBefore
ActiveDocument.Subdocuments.AddFromFile Name:="C:\Temp\Setup.doc"

Im folgenden Beispiel wird die Formatvorlage Überschrift 1 dem ersten Absatz in der Auswahl zugewiesen, und anschließend wird ein Filialdokument für den Inhalt der Auswahl erstellt.

Selection.Paragraphs(1).Style = wdStyleHeading1
With ActiveDocument.Subdocuments
    .Expanded = True
    .AddFromRange Range:=Selection.Range
End With


Subdocuments-Objekt (Auflistung)

Eine Auflistung von Subdocument-Objekten, die die Filialdokumente in einem Bereich oder einem Dokument repräsentiert.

Verwendung der Subdocuments-Auflistung

Verwenden Sie die Subdocuments-Eigenschaft, um die Subdocuments-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Filialdokumente im aktiven Dokument erweitert.

ActiveDocument.Subdocuments.Expanded = True

Verwenden Sie die AddFromFile- oder AddFromRange-Methode, um zu einem Dokument ein Filialdokument hinzuzufügen. Im folgenden Beispiel wird das Filialdokument "Setup.doc" am Ende des aktiven Dokuments eingefügt.

ActiveDocument.Subdocuments.Expanded = True
Selection.EndKey Unit:=wdStory
Selection.InsertParagraphBefore
ActiveDocument.Subdocuments.AddFromFile Name:="C:\Temp\Setup.doc"

Im folgenden Beispiel wird die Formatvorlage Überschrift 1 dem ersten Absatz in der Auswahl zugewiesen, und anschließend wird ein Filialdokument für den Inhalt der Auswahl erstellt.

Selection.Paragraphs(1).Style = wdStyleHeading1
With ActiveDocument.Subdocuments
    .Expanded = True
    .AddFromRange Range:=Selection.Range
End With

Verwenden Sie Subdocuments(Index) mit Index als Indexnummer, um ein einzelnes Subdocument-Objekt zurückzugeben. Im folgenden Beispiel werden der Pfad- und der Dateiname des ersten Filialdokuments im aktiven Dokument angezeigt.

If ActiveDocument.Subdocuments(1).HasFile = True Then
    MsgBox ActiveDocument.Subdocuments(1).Path & _
        Application.PathSeparator _
        & ActiveDocument.Subdocuments(1).Name
End If


SynonymInfo-Objekt

Stellt die Informationen über Synonyme, Antonyme, ähnliche Begriffe oder ähnliche Ausdrücke für den angegebenen Bereich oder eine bestimmte Zeichenfolge dar.

Verwendung des SynonymInfo-Objekts

Verwenden Sie die SynonymInfo-Eigenschaft, um ein SynonymInfo-Objekt zurückzugeben. Das SynonymInfo-Objekt kann entweder von einem Bereich oder von Word zurückgegeben werden. Wird es von Word zurückgegeben, bestimmen Sie das nachzuschlagende Wort oder die Phrase und eine Sprach-ID für die Prüfung. Wird es von einem Bereich zurückgegeben, verwendet Word den angegebenen Bereich als das nachzuschlagende Wort. Im folgenden Beispiel wird ein SynonymInfo-Objekt von Word zurückgegeben.

temp = SynonymInfo(Word:="meant", LanguageID:=wdEnglishUS).Found

Im folgenden Beispiel wird das SynonymInfo-Objekt von einem Bereich zurückgegeben.

temp = Selection.Range.SynonymInfo.Found

Die Found-Eigenschaft aus den vorherigen Beispielen gibt True zurück, wenn im Thesaurus eine Information für den angegebenen Bereich oder für Word gefunden wird. Beachten Sie dabei jedoch, dass diese Eigenschaft nicht nur bei Synonymen True zurückgibt, sondern auch beim Auffinden von ähnlichen Begriffen, ähnlichen Ausdrücken und Antonymen.

Viele Eigenschaften des SynonymInfo-Objekts geben ein Variant mit einem Datenfeld mit Zeichenfolgen zurück. Wenn Sie mit diesen Eigenschaften arbeiten, können Sie das zurückgegebene Datenfeld einer Variablen zuweisen und dann die Variable indizieren, um die Elemente im Datenfeld anzeigen zu lassen. Im folgenden Beispiel wird Slist die Synonymliste für die erste Bedeutung des gewählten Wortes bzw. Phrase zugewiesen. Die UBound-Funktion findet die obere Grenze des Datenfeldes, und die einzelnen Elemente werden in einem Meldungsfeld angezeigt.

Slist = Selection.Range.SynonymInfo.SynonymList(1)
For i = 1 To UBound(Slist)
    Msgbox Slist(i)
Next i

Sie können den Wert der MeaningCount-Eigenschaft überprüfen, um mögliche Fehler im Programmcode zu vermeiden. Im folgenden Beispiel wird eine Liste mit Synonymen für die zweite Bedeutung des Wortes oder der Phrase in der Markierung zurückgegeben. Diese Synonyme werden dann im Ausschnitt Immediate angezeigt.

Set synInfo = Selection.Range.SynonymInfo
If synInfo.MeaningCount >= 2 Then
    synList = synInfo.SynonymList(2)
    For i = 1 To UBound(synList)
        Debug.Print synList(i)
    Next i
Else
    MsgBox "There is no second meaning for the selection."
End If


System-Objekt

Enthält Informationen über das Computersystem.

Verwendung des System-Objekts

Verwenden Sie die System-Eigenschaft, um das System-Objekt zurückzugeben. Wenn es sich beim Betriebssystem um Windows handelt, wird im folgenden Beispiel eine Netzwerkverbindung mit \\Project\Info erstellt.

If System.OperatingSystem = "Windows" Then
    System.Connect Path:="\\Project\Info"
End If

Im folgenden Beispiel wird die aktuelle Bildschirmauflösung (z. B. "1024 x 768") angezeigt.

horz = System.HorizontalResolution
vert = System.VerticalResolution
MsgBox "Resolution = " & horz & " x " & vert


Table-Objekt

Repräsentiert eine einzelne Tabelle. Das Table-Objekt ist ein Element der Tables-Auflistung. Die Tables-Auflistung enthält alle Tabellen in der angegebenen Auswahl, im Bereich oder im Dokument.

Verwendung des Table-Objekts

Verwenden Sie Tables(Index) mit Index als Indexnummer, um ein einzelnes Table-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position der Tabelle in der Auswahl, im Bereich oder im Dokument. Im folgenden Beispiel wird die erste Tabelle im aktiven Dokument in Text konvertiert.

ActiveDocument.Tables(1).ConvertToText Separator:=wdSeparateByTabs

Verwenden Sie die Add-Methode, um zu dem angegebenen Bereich eine Tabelle hinzuzufügen. Im folgenden Beispiel wird eine Tabelle, die aus 3 x 4 Feldern besteht, am Anfang des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.Tables.Add Range:=myRange, NumRows:=3, NumColumns:=4


Tables-Objekt (Auflistung)

Tables-Auflistung ( Table-Objekt)

Eine Auflistung von Table-Objekten, die die Tabellen in einer Auswahl, einem Bereich oder einem Dokument repräsentiert.

Verwendung der Tables-Auflistung

Verwenden Sie die Tables-Eigenschaft, um die Tables-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Tabellen im aktiven Dokument mit Rahmen versehen.

For Each aTable In ActiveDocument.Tables
    aTable.Borders.OutsideLineStyle = wdLineStyleSingle
    aTable.Borders.OutsideLineWidth = wdLineWidth025pt
    aTable.Borders.InsideLineStyle = wdLineStyleNone
Next aTable

Verwenden Sie die Add-Methode, um zu dem angegebenen Bereich eine Tabelle hinzuzufügen. Im folgenden Beispiel wird eine Tabelle, die aus 3 x 4 Feldern besteht, am Anfang des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.Tables.Add Range:=myRange, NumRows:=3, NumColumns:=4

Verwenden Sie Tables(Index) mit Index als Indexnummer, um ein einzelnes Table-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position der Tabelle in der Auswahl, im Bereich oder im Dokument. Im folgenden Beispiel wird die erste Tabelle im aktiven Dokument in Text konvertiert.

ActiveDocument.Tables(1).ConvertToText Separator:=wdSeparateByTabs

Hinweise

Die Count-Eigenschaft gibt für diese Auflistung in einem Dokument nur die Anzahl der Elemente in der Hauptkomponente zurück. Um Elemente in anderen Dokumentkomponenten zu zählen, verwenden Sie die Auflistung mit dem Range-Objekt.


TableOfAuthorities-Objekt

Stellt ein einzelnes Rechtsgrundlagenverzeichnis in einem Dokument dar (ein TOA-Feld). Ein TableOfAuthorities-Objekt ist ein Element der TablesOfAuthorities-Auflistung. Die TablesOfAuthorities-Auflistung enthält alle Rechtsgrundlagenverzeichnisse in einem Dokument.

Verwendung des TableOfAuthorities-Objekts

Mit TablesOfAuthorities(index) können Sie ein einzelnes TableOfAuthorities-Objekt zurückgeben, wobei index für die Indexnummer steht. Die Indexnummer stellt die Position des Rechtsgrundlagenverzeichnisses im Dokument dar. Im folgenden Beispiel wird festgelegt, dass im ersten Rechtsgrundlagenverzeichnis des aktuellen Dokuments Kategorieüberschriften angezeigt werden. Anschließend wird das Verzeichnis aktualisiert.

With ActiveDocument.TablesOfAuthorities(1)
    .IncludeCategoryHeader = True
    .Update
End With

Verwenden Sie die Add-Methode, um einem Dokument ein Rechtsgrundlagenverzeichnis hinzuzufügen. Im folgenden Beispiel wird am Anfang des aktuellen Dokuments ein Rechtsgrundlagenverzeichnis eingefügt, in das alle Kategorien aufgenommen werden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfAuthorities.Add Range:=myRange, _
    Passim:=True, Category:=0, EntrySeparator:=", "

Anmerkung Rechtsgrundlagenverzeichnisse werden aus TOA-Feldern (Rechtsgrundlagenverzeichnisfeldern) in einem Dokument zusammengestellt. Verwenden Sie die MarkCitation-Methode, um Einträge festzulegen, die in das Rechtsgrundlagenverzeichnis aufgenommen werden sollen.


TablesOfAuthorities-Objekt (Auflistung)

Eine Auflistung von TableOfAuthorities-Objekten (TOA-Feldern), die die Rechtsgrundlagenverzeichnisse in einem Dokument darstellen.

Verwendung der TablesOfAuthorities-Auflistung

Verwenden Sie die Eigenschaft TablesOfAuthorities, um eine TablesOfAuthorities-Auflistung zurückzugeben. Im folgenden Beispiel wird allen Rechtsgrundlagenverzeichnissen im aktuellen Dokument das integrierte Format "Klassisch" zugewiesen.

ActiveDocument.TablesOfAuthorities.Format = wdTOAClassic

Verwenden Sie die Add-Methode, um einem Dokument ein Rechtsgrundlagenverzeichnis hinzuzufügen. Rechtsgrundlagenverzeichnisse werden aus TA-Feldern (Eintragfelder für Rechtsgrundlagenverzeichnisse) in einem Dokument zusammengestellt. Im folgenden Beispiel wird am Anfang des aktuellen Dokuments ein Rechtsgrundlagenverzeichnis eingefügt, in das alle Kategorien aufgenommen werden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfAuthorities.Add Range:=myRange, _
    Passim:=True, Category:=0, EntrySeparator:= ", "

Mit TablesOfAuthorities(index) können Sie ein einzelnes TableOfAuthorities-Objekt zurückgeben, wobei index für die Indexnummer steht. Die Indexnummer stellt die Position des Rechtsgrundlagenverzeichnisses im Dokument dar. Im folgenden Beispiel wird festgelegt, dass im ersten Rechtsgrundlagenverzeichnis des aktuellen Dokuments Kategorieüberschriften angezeigt werden. Anschließend wird das Verzeichnis aktualisiert.

With ActiveDocument.TablesOfAuthorities(1)
    .IncludeCategoryHeader = True
    .Update
End With


TableOfAuthoritiesCategory-Objekt

Stellt eine einzelne Kategorie für Rechtsgrundlagenverzeichnisse dar. Ein TableOfAuthoritiesCategories-Objekt ist ein Element der TablesOfAuthoritiesCategories-Auflistung. Die TablesOfAuthoritiesCategories-Auflistung enthält alle 16 Kategorien, die im Feld Kategorie auf der Registerkarte Rechtsgrundlagenverzeichnis im Dialogfeld Index und Verzeichnisse (Menü Einfügen) aufgeführt sind.

Verwendung des TableOfAuthoritiesCategory-Objekts

Mit TablesOfAuthoritiesCategories(index), können Sie ein einzelnes TableOfAuthoritiesCategory-Objekt zurückgeben, wobei index den Kategorienamen oder die Indexnummer darstellt. Im folgenden Beispiel wird die Kategorie "Rules" in "Other Provisions" umbenannt.

ActiveDocument.TablesOfAuthoritiesCategories("Rules").Name = _
    "Other Provisions"

Die Indexnummer stellt die Position der Kategorie im Dialogfeld Index und Verzeichnisse (Menü Einfügen) dar. Im folgenden Beispiel wird der Name der ersten Kategorie in der TablesOfAuthoritiesCategories-Auflistung angezeigt.

MsgBox ActiveDocument.TablesOfAuthoritiesCategories(1).Name

Die Add-Methode steht für die TablesOfAuthoritiesCategories-Auflistung nicht zur Verfügung. Die Auflistung ist auf 16 Elemente beschränkt. Mit der Eigenschaft Name können Sie jedoch eine vorhandene Kategorie umbenennen.


TablesOfAuthoritiesCategories-Objekt (Auflistung)

Eine Auflistung von TableOfAuthoritiesCategory-Objekten, die die Kategorien für Rechtsgrundlagenverzeichnisse darstellen, beispielsweise "Cases" und "Statutes". Die TablesOfAuthoritiesCategories-Auflistung enthält alle 16 Kategorien, die im Feld Kategorie auf der Registerkarte Rechtsgrundlagenverzeichnis im Dialogfeld Index und Verzeichnisse (Menü Einfügen) aufgeführt sind.

Verwendung der TablesOfAuthoritiesCategories-Auflistung

Verwenden Sie die TablesOfAuthoritiesCategories-Eigenschaft, um eine TablesOfAuthoritiesCategories-Auflistung zurückzugeben. Im folgenden Beispiel werden die Namen der Kategorien in der TablesOfAuthoritiesCategories-Auflistung angezeigt.

For Each aCat In ActiveDocument.TablesOfAuthoritiesCategories
    response = MsgBox(Prompt:=aCat, Buttons:=vbOKCancel)
    If response = vbCancel Then Exit For
Next aCat

Die Add-Methode steht für die TablesOfAuthoritiesCategories-Auflistung nicht zur Verfügung. Die Auflistung ist auf 16 Elemente beschränkt. Mit der Eigenschaft Name können Sie jedoch eine vorhandene Kategorie umbenennen.

Mit TablesOfAuthoritiesCategories(index), können Sie ein einzelnes TableOfAuthoritiesCategory-Objekt zurückgeben, wobei index den Kategorienamen oder die Indexnummer darstellt. Im folgenden Beispiel wird die Kategorie "Rules" in "Other Provisions" umbenannt.

ActiveDocument.TablesOfAuthoritiesCategories("Rules").Name = _
    "Other Provisions"

Die Indexnummer stellt die Position der Kategorie im Dialogfeld Index und Verzeichnisse (Menü Einfügen) dar. Im folgenden Beispiel wird der Name der ersten Kategorie in der TablesOfAuthoritiesCategories-Auflistung angezeigt.

MsgBox ActiveDocument.TablesOfAuthoritiesCategories(1).Name


TableOfContents-Objekt

Repräsentiert ein einzelnes Inhaltsverzeichnis in einem Dokument. Das TableOfContents-Objekt ist ein Element der TablesOfContents-Auflistung. Die TablesOfContents-Auflistung enthält alle Inhaltsverzeichnisse in einem Dokument.

Verwendung von TableOfContents-Objekten

Verwenden Sie TablesOfContents(Index) mit Index als Indexnummer, um ein einzelnes TableOfContents-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position des Inhaltsverzeichnisses im Dokument. Im folgenden Beispiel werden die Seitennummern der Elemente im ersten Abbildungsverzeichnis im aktiven Dokument aktualisiert.

ActiveDocument.TablesOfContents(1).UpdatePageNumbers

Verwenden Sie die Add-Methode, um zu dem aktiven Dokument ein Inhaltsverzeichnis hinzuzufügen. Im folgenden Beispiel wird ein Inhaltsverzeichnis am Anfang des aktiven Dokuments eingefügt. Das Beispiel generiert das Inhaltsverzeichnis aus allen Absätzen, die mit der Formatvorlage Überschrift 1, Überschrift 2 oder Überschrift 3 formatiert wurden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfContents.Add Range:=myRange, _
    UseFields:=False, UseHeadingStyles:=True, _
    LowerHeadingLevel:=3, _
    UpperHeadingLevel:=1


TablesOfContents-Objekt (Auflistung)

Eine Auflistung von TableOfContents-Objekten, die das Inhaltsverzeichnis in einem Dokument repräsentieren.

Verwendung der TablesOfContents-Auflistung

Verwenden Sie die TablesOfContents-Eigenschaft, um die TablesOfContents-Auflistung zurückzugeben. Im folgenden Beispiel wird ein Inhaltsverzeichniseintrag hinzugefügt, der auf den markierten Text im aktiven Dokument verweist.

ActiveDocument.TablesOfContents.MarkEntry Range:=Selection.Range, _
    Level:=2, Entry:="Introduction"

Verwenden Sie die Add-Methode, um zu dem aktiven Dokument ein Inhaltsverzeichnis hinzuzufügen. Im folgenden Beispiel wird ein Inhaltsverzeichnis am Anfang des aktiven Dokuments eingefügt. Das Beispiel generiert das Inhaltsverzeichnis aus allen Absätzen, die mit der Formatvorlage Überschrift 1, Überschrift 2 oder Überschrift 3 formatiert wurden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfContents.Add Range:=myRange, _
    UseFields:=False, UseHeadingStyles:=True, _
    LowerHeadingLevel:=3, _
    UpperHeadingLevel:=1

Verwenden Sie TablesOfContents(Index) mit Index als Indexnummer, um ein einzelnes TableOfContents-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position des Inhaltsverzeichnisses im Dokument. Im folgenden Beispiel werden die Seitennummern der Elemente im ersten Abbildungsverzeichnis im aktiven Dokument aktualisiert.

ActiveDocument.TablesOfContents(1).UpdatePageNumbers


TableOfFigures-Objekt

Repräsentiert ein einzelnes Abbildungsverzeichnis in einem Dokument. Das TableOfFigures-Objekt ist ein Element der TablesOfFigures-Auflistung. Die TablesOfFigures-Auflistung enthält alle Abbildungsverzeichnisse in einem Dokument.

Verwendung von TableOfFigures-Objekten

Verwenden Sie TablesOfFigures(Index) mit Index als Indexnummer, um ein einzelnes TableOfFigures-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position des Abbildungsverzeichnisses im Dokument. Im folgenden Beispiel werden die Seitennummern der Elemente im ersten Abbildungsverzeichnis im aktiven Dokument aktualisiert.

ActiveDocument.TablesOfFigures(1).UpdatePageNumbers

Verwenden Sie die Add-Methode, um zu einem Dokument ein Abbildungsverzeichnis hinzuzufügen. Ein Abbildungsverzeichnis führt die Unter- bzw. Überschriften der Abbildungen in der Reihenfolge auf, in der sie im Dokument erscheinen. Im folgenden Beispiel wird die Auswahl im aktiven Dokument durch ein Abbildungsverzeichnis ersetzt, das Beschriftungskategorien und Seitennummern enthält.

ActiveDocument.TablesOfFigures.Add Range:=Selection.Range, _
    IncludeLabel:=True, IncludePageNumbers:=True


TablesOfFigures-Objekt (Auflistung)

Eine Auflistung von TableOfFigures-Objekten, die die Abbildungsverzeichnisse in einem Dokument repräsentiert.

Verwendung der TablesOfFigures-Auflistung

Verwenden Sie die TablesOfFigures-Eigenschaft, um die TablesOfFigures-Auflistung zurückzugeben. Im folgenden Beispiel wird das Format Klassisch allen Abbildungsverzeichnissen im aktiven Dokument zugewiesen.

ActiveDocument.TablesOfFigures.Format = wdTOFClassic

Verwenden Sie die Add-Methode, um zu einem Dokument ein Abbildungsverzeichnis hinzuzufügen. Ein Abbildungsverzeichnis führt die Unter- bzw. Überschriften der Abbildungen in der Reihenfolge auf, in der sie im Dokument erscheinen. Im folgenden Beispiel wird die Auswahl im aktiven Dokument durch ein Abbildungsverzeichnis ersetzt, die Beschriftungskategorien und Seitennummern enthält.

ActiveDocument.TablesOfFigures.Add Range:=Selection.Range, _
    IncludeLabel:=True, IncludePageNumbers:=True

Verwenden Sie TablesOfFigures(Index) mit Index als der Indexnummer, um ein einzelnes TableOfFigures-Objekt zurückzugeben. Die Indexnummer repräsentiert die Position des Abbildungsverzeichnisses im Dokument. Im folgenden Beispiel werden die Seitennummern der Elemente im ersten Abbildungsverzeichnis im aktiven Dokument aktualisiert.

ActiveDocument.TablesOfFigures(1).UpdatePageNumbers


TabStop-Objekt

Stellt einen einzelnen Tabstopp dar. Das TabStop-Objekt ist ein Element der TabStops-Auflistung. Die TabStops-Auflistung stellt alle benutzerdefinierten und Standardtabstopps in einem Absatz oder in einer Gruppe von Absätzen dar.

Verwendung des TabStop-Objekts

Verwenden Sie TabStops(Index), um ein einzelnes TabStop-Objekt zurückzugeben. (Index ist die Position des Tabstopps (in Punkt) oder die Indexnummer.) Tabstopps werden nummerisch von links nach rechts entlang des Lineals indiziert. Im folgenden Beispiel wird der erste benutzerdefinierte Tabstopp aus den markierten Absätzen entfernt.

Selection.Paragraphs.TabStops(1).Clear

Im folgenden Beispiel wird ein rechts ausgerichteter Tabstopp eingefügt und mit einem Abstand von zwei Zoll zu den markierten Absätzen positioniert.

Selection.Paragraphs.TabStops(InchesToPoints(2)) _
    .Alignment = wdAlignTabRight

Mit der Add-Methode können Sie einen Tabstopp hinzufügen. Im folgenden Beispiel werden den markierten Absätzen zwei Tabstopps hinzugefügt. Der erste Tabstopp ist ein links ausgerichteter Tabulator mit Punkten als Füllzeichen und befindet sich an der Tabstoppposition 1 Zoll (72 Punkt). Der zweite Tabstopp ist zentriert und befindet sich an der Position 2 Zoll.

With Selection.Paragraphs.TabStops
    .Add Position:=InchesToPoints(1), _
        Leader:=wdTabLeaderDots, Alignment:=wdAlignTabLeft
    .Add Position:=InchesToPoints(2), Alignment:=wdAlignTabCenter
End With

Sie können auch einen Tabstopp setzen, indem Sie mit der TabStops-Eigenschaft eine Position angeben. Im folgenden Beispiel wird ein rechts ausgerichteter Tabstopp mit der Tabstopp-Position 2 Zoll eingefügt.

Selection.Paragraphs.TabStops(InchesToPoints(2)) _
    .Alignment = wdAlignTabRight

Anmerkung Legen Sie die DefaultTabStop-Eigenschaft fest, um den Abstand der Standardtabstopps einzustellen.


TabStops-Objekt (Auflistung)

Eine Auflistung mit TabStop-Objekten, die die benutzerdefinierten und Standard-Tabstopps für einen Absatz oder eine Absatzgruppe darstellt.

Verwendung der TabStops-Auflistung

Mit der TabStops-Eigenschaft können Sie die TabStops-Auflistung zurückgeben. Das folgende Beispiel löscht alle benutzerdefinierten Tabstopps aus dem ersten Absatz im aktiven Dokument.

ActiveDocument.Paragraphs(1).TabStops.ClearAll

Das folgende Beispiel fügt den markierten Absätzen einen Tabstopp an der Position 2,5 Zoll hinzu und zeigt anschließend die Position von jedem Element in der TabStops-Auflistung an.

Selection.Paragraphs.TabStops.Add Position:=InchesToPoints(2.5)
For Each aTab In Selection.Paragraphs.TabStops
    MsgBox "Position = " _
        & PointsToInches(aTab.Position) & " inches"
Next aTab

Mit der Add-Methode können Sie einen Tabstopp hinzufügen. Das folgende Beispiel fügt den markierten Absätzen zwei Tabstopps hinzu. Der erste Tabstopp ist ein links ausgerichteter Tabulator mit einem gepunkteten Füllzeichen an der Position 1 Zoll (72 Punkt). Der zweite Tabstopp ist zentriert und an der Position 2 Zoll.

With Selection.Paragraphs.TabStops
    .Add Position:=InchesToPoints(1), _
        Leader:=wdTabLeaderDots, Alignment:=wdAlignTabLeft
    .Add Position:=InchesToPoints(2), Alignment:=wdAlignTabCenter
End With

Sie können Tabstopps auch hinzufügen, indem Sie eine Position mit der TabStops-Eigenschaft angeben. Das folgende Beispiel fügt den markierten Absätzen einen rechts ausgerichteten Tabstopp an der Position 2 Zoll hinzu.

Selection.Paragraphs.TabStops(InchesToPoints(2)) _
    .Alignment = wdAlignTabRight

Mit TabStops(Index) können Sie ein einzelnes TabStop-Objekt zurückgeben. (Index ist die Position des Tabstopps in Punkt oder die Indexnummer.) Tabstopps werden numerisch von links nach rechts entlang des Lineals indiziert. Das folgende Beispiel entfernt den ersten benutzerdefinierten Tabstopp aus dem ersten Absatz im aktiven Dokument.

ActiveDocument.Paragraphs(1).TabStops(1).Clear

Das folgende Beispiel fügt den markierten Absätzen einen rechts ausgerichteten Tabstopp an der Position 2 Zoll hinzu.

Selection.Paragraphs.TabStops(InchesToPoints(2)) _
    .Alignment = wdAlignTabRight

Hinweise

Wenn Sie mit der Paragraphs-Auflistung (oder einem Bereich mit verschiedenen Absätzen) arbeiten, muss jeder Absatz der Auflistung dann einzeln geändert werden, wenn die Tabstopps nicht in allen Absätzen identisch sind. Das folgende Beispiel entfernt den Tabulator an der Position 1 Zoll aus jedem Absatz im aktiven Dokument.

For Each para In ActiveDocument.Content.Paragraphs
    para.TabStops(InchesToPoints(1)).Clear
Next para


Task-Objekt

Stellt ein einzelnen Task dar, das auf Ihrem System abläuft. Das Task-Objekt ist ein Element der Tasks-Auflistung. Die Tasks-Auflistung enthält alle Anwendungen, die aktuell auf Ihrem System ablaufen.

Verwendung des Task-Objekts

Mit Tasks(Index) können Sie ein einzelnes Task-Objekt zurückgeben. (Index ist der Name der Anwendung oder die Indexnummer.) Das folgende Beispiel wechselt zum Anwendungsfenster für den ersten sichtbaren Task der Tasks-Auflistung und ändert die Größe des Anwendungsfensters.

With Tasks(1)
    If .Visible = True Then
        .Activate
        .Width = 400
        .Height = 200
    End If
End With

Das folgende Beispiel stellt das Anwendungsfenster "Calculator" wieder her, wenn diese Anwendung in der Tasks-Auflistung enthalten ist.

If Tasks.Exists("Calculator") = True Then
    Tasks("Calculator").WindowState = wdWindowStateNormal
End If

Mit der Shell-Funktion können Sie ein ausführbares Programm starten und dieses der Tasks-Auflistung hinzufügen.


Tasks-Objekt (Auflistung)

Eine Auflistung mit Task-Objekten, die alle Tasks darstellen, die aktuell auf Ihrem System ablaufen.

Verwendung der Tasks-Auflistung

Mit der Tasks-Eigenschaft können Sie die Tasks-Auflistung zurückgeben. Das folgende Beispiel bestimmt, ob Microsoft Excel gestartet wird. Wenn Microsoft Excel bereits abläuft, wechselt dieses Beispiel zu diesem Programm und maximiert es. Andernfalls wird Microsoft Excel von diesem Beispiel gestartet.

If Tasks.Exists("Microsoft Excel") = True Then
    Tasks("Microsoft Excel").Activate
    Tasks("Microsoft Excel").WindowState = wdWindowStateMaximize
Else
    Shell "C:\Program Files\" & _
        "Microsoft Office\Office\Excel.exe"
End If

Mit der Shell-Funktion können Sie ein ausführbares Programm starten und dieses der Tasks-Auflistung hinzufügen.

Mit Tasks(Index) können Sie ein einzelnes Task-Objekt zurückgeben. (Index ist der Name der Anwendung oder die Indexnummer.) Das folgende Beispiel öffnet das Anwendungsfenster für den ersten sichtbaren Task der Tasks-Auflistung und ändert die Größe des Anwendungsfensters.

With Tasks(1)
    If .Visible = True Then
        .Activate
        .Width = 400
        .Height = 200
    End If
End With

Das folgende Beispiel stellt das Anwendungsfenster "Calculator" wieder her, wenn diese Anwendung in der Tasks-Auflistung enthalten ist.

If Tasks.Exists("Calculator") = True Then
    Tasks("Calculator").WindowState = wdWindowStateNormal
End If


Template-Objekt

Stellt eine Dokumentvorlage dar. Das Template-Objekt ist ein Element der Templates-Auflistung. Die Templates-Auflistung enthält alle verfügbaren Template-Objekte.

Verwendung des Template-Objekts

Mit Templates(Index) können Sie ein einzelnes Template-Objekt zurückgeben. (Index ist der Name der Vorlage oder die Indexnummer.) Das folgende Beispiel speichert die Vorlage "Memo2.dot", wenn sie in der Templates-Auflistung enthalten ist.

For Each aTemp In Templates
    If LCase(aTemp.Name) = "memo2.dot" Then aTemp.Save
Next aTemp

Die Indexnummer stellt die Position der Vorlage in der Templates-Auflistung dar. Das folgende Beispiel öffnet die erste Vorlage in der Templates-Auflistung.

Templates(1).OpenAsDocument

Die Add-Methode ist für die Templates-Auflistung nicht verfügbar. Sie haben stattdessen folgende Möglichkeiten, der Templates-Auflistung eine Vorlage hinzuzufügen:

  • Mit der Open-Methode und der Documents-Auflistung können Sie ein Dokument öffnen, das auf einer Vorlage basiert

  • Mit der Add-Methode und der Documents-Auflistung können Sie ein neues Dokument öffnen, das auf einer Vorlage basiert

  • Mit der Add-Methode und der Addins-Auflistung können Sie eine globale Vorlage laden

  • Mit der AttachedTemplate-Eigenschaft und dem Document-Objekt können Sie eine Vorlage mit einem Dokument verbinden

Hinweise

Mit der NormalTemplate-Eigenschaft können Sie ein Template-Objekt zurückgeben, das auf die Dokumentvorlage "Standard" verweist. Mit der AttachedTemplate-Eigenschaft können Sie eine Vorlage zurückgeben, die mit dem angegebenen Dokument verbunden ist.

Mit der DefaultFilePath-Eigenschaft können Sie die Position von Vorlagen für Benutzer oder Arbeitsgruppen zurückgeben oder festlegen (d. h., den Ordner, in dem diese Vorlagen gespeichert werden sollen). Das folgende Beispiel zeigt den Ordner für die Benutzer-Vorlagen der Registerkarte Speicherort der Datei im Dialogfeld Optionen (Menü Extras) an.

MsgBox Options.DefaultFilePath(wdUserTemplatesPath)


Templates-Objekt (Auflistung)

Eine Auflistung mit Template-Objekten, die alle Vorlagen darstellen, die aktuell verfügbar sind. Diese Auflistung enthält geöffnete Vorlagen, mit geöffneten Dokumenten verbundene Vorlagen und globale Vorlagen, die im Dialogfeld Vorlagen und Add-Ins (Menü Extras) aufgelistet sind.

Verwendung der Templates-Auflistung

Mit der Templates-Eigenschaft können Sie eine Templates-Auflistung hinzufügen. Das folgende Beispiel zeigt den Pfad und den Dateinamen von jeder Vorlage der Templates-Auflistung an.

For Each aTemp In Templates
    MsgBox aTemp.FullName
Next aTemp

Die Add-Methode ist für die Templates-Auflistung nicht verfügbar. Sie haben stattdessen folgende Möglichkeiten, der Templates-Auflistung eine Vorlage hinzuzufügen:

  • Mit der Open-Methode und der Documents-Auflistung können Sie ein Dokument öffnen, das auf einer Vorlage basiert

  • Mit der Add-Methode und der Documents-Auflistung können Sie ein neues Dokument öffnen, das auf einer Vorlage basiert

  • Mit der Add-Methode und der Addins-Auflistung können Sie eine globale Vorlage laden

  • Mit der AttachedTemplate-Eigenschaft und dem Document-Objekt können Sie eine Vorlage mit einem Dokument verbinden

Mit Templates(Index) können Sie ein einzelnes Template-Objekt zurückgeben. (Index ist der Name der Vorlage oder die Indexnummer.) Das folgende Beispiel speichert die Vorlage "Dot1.dot".

Templates("C:\MSOffice\WinWord\Templates\Dot1.dot").Save

Die Indexnummer stellt die Position der Vorlage in der Templates-Auflistung dar. Das folgende Beispiel zeigt den Dateinamen der ersten Vorlage in der Templates-Auflistung an.

MsgBox Templates(1).FullName

Hinweise

Mit der NormalTemplate-Eigenschaft können Sie ein Template-Objekt zurückgeben, das auf die Dokumentvorlage "Standard" verweist. Mit der AttachedTemplate-Eigenschaft können Sie eine Vorlage zurückgeben, die dem angegebenen Dokument angehängt ist.

Mit der DefaultFilePath-Eigenschaft können Sie die Position der Benutzer- oder Arbeitsgruppen-Vorlagen (d. h., den Ordner, in dem diese Vorlagen gespeichert werden) bestimmen. Das folgende Beispiel zeigt den Ordner für die Benutzer-Vorlagen aus der Registerkarte Speicherort der Datei im Dialogfeld Optionen (Menü Extras) an.

MsgBox Options.DefaultFilePath(wdUserTemplatePath)


TextColumn-Objekt

Stellt eine einzelne Textspalte dar. Das TextColumn-Objekt ist ein Element der TextColumns-Auflistung. Die TextColumns-Auflistung enthält alle Spalten in einem Dokument oder Dokumentabschnitt.

Verwendung des TextColumn-Objekts

Mit TextColumns(Index) können Sie ein einzelnes TextColumn-Objekt zurückgeben. (Index ist die Indexnummer.) Die Indexnummer stellt die Position der Spalte in der TextColumns-Auflistung dar (links nach rechts gezählt).

Das folgende Beispiel legt 0,5 Zoll als Abstand nach der ersten Textspalte im aktiven Dokument fest.

ActiveDocument.PageSetup.TextColumns(1).SpaceAfter = _
    InchesToPoints(0.5)

Mit der Add-Methode können Sie der Spaltenauflistung eine Spalte hinzufügen. Standardmäßig enthält die TextColumns-Auflistung eine Textspalte. Das folgende Beispiel fügt dem aktiven Dokument eine Spalte mit der Breite 2,5 Zoll hinzu.

ActiveDocument.PageSetup.TextColumns.Add _
    Width:=InchesToPoints(2.5), _
    Spacing:=InchesToPoints(0.5), EvenlySpaced:=False

Hinweise

Mit der SetCount-Methode können Sie Text in Spalten anordnen. Das folgende Beispiel ordnet den Text im aktiven Dokument in drei Spalten an.

ActiveDocument.PageSetup.TextColumns.SetCount NumColumns:=3


TextColumns-Objekt (Auflistung)

Eine Auflistung mit TextColumn-Objekten, die alle Textspalten in einem Dokument oder einem Dokumentabschnitt darstellen.

Verwendung der TextColumns-Auflistung

Mit der TextColumns-Eigenschaft können Sie eine TextColumns-Auflistung zurückgeben. Das folgende Beispiel formatiert die Spalten des ersten Abschnitts im aktiven Dokument mit gleichem Abstand und mit einer Linie zwischen den Spalten.

With ActiveDocument.Sections(1).PageSetup.TextColumns
    .EvenlySpaced = True
    .LineBetween = True
End With

Mit der Add-Methode können Sie der Spaltenauflistung eine Spalte hinzufügen. Standardmäßig enthält die TextColumns-Auflistung eine Textspalte. Das folgende Beispiel fügt dem aktiven Dokument eine Spalte mit der Breite 2,5 Zoll hinzu.

ActiveDocument.PageSetup.TextColumns.Add _
    Width:=InchesToPoints(2.5), _
    Spacing:=InchesToPoints(0.5), EvenlySpaced:=False

Hinweise

Mit der SetCount-Methode können Sie Text in Spalten anordnen. Das folgende Beispiel ordnet den Text im aktiven Dokument in drei Spalten an.

ActiveDocument.PageSetup.TextColumns.SetCount NumColumns:=3


TextEffectFormat-Objekt

Enthält Eigenschaften und Methoden, die WordArt-Objekte betreffen.

Verwendung von TextEffectFormat-Objekten

Verwenden Sie die TextEffect-Eigenschaft, um ein TextEffectFormat-Objekt zurückzugeben. Im folgenden Beispiel werden im aktiven Dokument der Name der Schriftart und die Formatierung für Form 1 festgelegt. Dieses Beispiel funktioniert nur, wenn es sich bei Form 1 um ein WordArt-Objekt handelt.

With ActiveDocument.Shapes(1).TextEffect
    .FontName = "Courier New"
    .FontBold = True
    .FontItalic = True
End With


 TextFrame-Objekt

TextFrame-Objekt

Repräsentiert den Textpositionsrahmen in einem Shape-Objekt. Enthält Text im Textpositionsrahmen und Eigenschaften zum Festlegen der Ränder und zur Ausrichtung des Textpositionsrahmens.

Verwendung von TextFrame-Objekten

Verwenden Sie die TextFrame-Eigenschaft, um das TextFrame-Objekt einer Form zurückzugeben. Die TextRange-Eigenschaft gibt ein Range-Objekt zurück, das den Textbereich innerhalb des angegebenen Textpositionsrahmens repräsentiert. Im folgenden Beispiel wird Text dem Textpositionsrahmen von Form 1 im aktiven Dokument hinzugefügt.

ActiveDocument.Shapes(1).TextFrame.TextRange.Text = "My Text"

Anmerkung Einige Formen unterstützen keinen verbundenen Text (z. B. Linien, Freihandformen, Bilder und OLE-Objekte). Wenn Sie versuchen, Eigenschaften zum Steuern von Text in Textpositionsrahmen für diese Objekte festzulegen oder zurückzugeben, tritt ein Fehler auf.

Verwenden Sie die HasText-Eigenschaft, um zu ermitteln, ob der Textpositionsrahmen Text enthält, wie das folgende Beispiel illustriert.

For Each s In ActiveDocument.Shapes
    With s.TextFrame
        If .HasText Then MsgBox .TextRange.Text
    End With
Next

Textpositionsrahmen können verknüpft werden, so dass der Text aus dem Textpositionsrahmen der einen Form in den Textpositionsrahmen einer anderen Form fließt. Verwenden Sie die Next- und Previous-Eigenschaft, um Textpositionsrahmen zu verknüpfen. Im folgenden Beispiel wird ein Textfeld (ein Rechteck mit einem Textpositionsrahmen) erstellt und mit Text versehen. Anschließend wird ein anderes Textfeld erstellt, und beide Textpositionsrahmen werden miteinander verknüpft, damit der Textfluss aus dem ersten Textpositionsrahmen im zweiten fortgesetzt wird.

Set myTB1 = ActiveDocument.Shapes.AddTextbox _
    (msoTextOrientationHorizontal, 72, 72, 72, 36)
myTB1.TextFrame.TextRange = _
    "This is some text. This is some more text."
Set myTB2 = ActiveDocument.Shapes.AddTextbox _
    (msoTextOrientationHorizontal, 72, 144, 72, 36)
myTB1.TextFrame.Next = myTB2.TextFrame

Verwenden Sie die ContainingRange-Eigenschaft, um ein Range-Objekt zurückzugeben, das die gesamte Textkomponente repräsentiert, die zwischen den verknüpften Textpositionsrahmen fließt. Im folgenden Beispiel wird die Rechtschreibung des Textes in Textfeld 3 und von Text, der mit Textfeld 3 verknüpft ist, überprüft.

Set myStory = ActiveDocument.Shapes("TextBox 3") _
    .TextFrame.ContainingRange
myStory.CheckSpelling


TextInput-Objekt

Stellt ein einzelnes Textformularfeld dar.

Verwendung des TextInput-Objekts

Mit FormFields(Index) können Sie ein FormField-Objekt zurückgeben. (Index ist entweder der Name der Textmarke, der dem Textformularfeld zugewiesen ist, oder die Indexnummer.) Mit der TextInput-Eigenschaft und dem FormField-Objekt können Sie ein TextInput-Objekt zurückgeben. Das folgende Beispiel löscht den Inhalt des Textformularfeldes "Text1" im aktiven Dokument.

ActiveDocument.FormFields("Text1").TextInput.Clear

Die Indexnummer stellt die Position des Formularfeldes in der FormFields-Auflistung dar. Das folgende Beispiel prüft den Typ des ersten Formularfeldes im aktiven Dokument. Handelt es sich um ein Textformularfeld, legt das Beispiel "Mission Critical" als Wert für das Feld fest.

If ActiveDocument.FormFields(1).Type = wdFieldFormTextInput Then
    ActiveDocument.FormFields(1).Result = "Mission Critical"
End If

Das folgende Beispiel bestimmt, ob die Variable ffield ein gültiges Textformularfeld im aktiven Dokument darstellt, bevor diese als Standardtext festgelegt wird.

Set ffield = ActiveDocument.FormFields(1).TextInput
If ffield.Valid = True Then
    ffield.Default = "Type your name here"
Else
    MsgBox "First field is not a text box"
End If

Mit der Add-Methode und dem FormFields-Objekt können Sie ein Textformularfeld hinzufügen. Das folgende Beispiel fügt ein Textformularfeld an den Anfang des aktiven Dokuments ein und legt anschließend als Namen für das Formularfeld die Bezeichnung "FirstName" fest.

Set ffield = ActiveDocument.FormFields.Add( _
    Range:=ActiveDocument.Range(Start:=0, End:=0), _
    Type:=wdFieldFormTextInput)
ffield.Name = "FirstName"


TextRetrievalMode-Objekt

Stellt die Optionen dar, die steuern, wie Text aus einem Range-Objekt abgerufen wird.

Verwendung des TextRetrievalMode-Objekts

Mit der TextRetrievalMode-Eigenschaft können Sie ein TextRetrievalMode-Objekt zurückgeben. Das folgende Beispiel zeigt den Text des ersten Satzes im aktiven Dokument an. Feldfunktionen und ausgeblendeter Text werden nicht eingeschlossen.

With ActiveDocument.Sentences(1).TextRetrievalMode
    .IncludeHiddenText = False
    .IncludeFieldCodes = False
    MsgBox .Parent.Text
End With

Hinweise

Wenn Sie die ViewType, IncludeHiddentText oder IncludeFieldCodes-Eigenschaft des TextRetrievalMode-Objekts ändern, wirken sich Ihre Änderungen nicht auf die Bildschirmanzeige aus. Die Änderungen bestimmen stattdessen den Text, der von einem Range-Objekt abgefragt wird, wenn Sie die Text-Eigenschaft verwenden.


ThreeDFormat-Objekt

Repräsentiert die dreidimensionale Formatierung einer Form.

Verwendung von ThreeDFormat-Objekten

Verwenden Sie die ThreeD-Eigenschaft, um ein ThreeDFormat-Objekt zurückzugeben. Im folgenden Beispiel wird dem aktiven Dokument ein Oval hinzugefügt. Anschließend wird festgelegt, dass das Oval mit einer Tiefe von 50 Punkt projiziert wird und die Projektion violett ist.

Set myShape = ActiveDocument.Shapes _
    .AddShape(msoShapeOval, 90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    ' RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With

Hinweise

Sie können einigen Formen keine dreidimensionale Formatierung zuweisen, z. B. abgeschrägten Formen oder mehreren nicht verbundenen Strecken. Die meisten Eigenschaften und Methoden des ThreeDFormat-Objekts werden fehlschlagen, wenn sie einem solchen Objekt zugewiesen werden.


TwoInitialCapsException-Objekt

Stellt eine einzelne AutoCorrect-Ausnahme für große Anfangsbuchstaben dar. Das TwoInitialCapsException-Objekt ist ein Element der TwoInitialCapsExceptions-Auflistung. Die TwoInitialCapsExceptions-Auflistung enthält alle Elemente, die im Feld Nicht korrigieren der Registerkarte WOrtanfang GRoß im Dialogfeld AutoKorrektur-Ausnahmen angezeigt werden.

Verwendung des TwoInitialCapsException-Objekts

Mit TwoInitialCapsExceptions(Index) können Sie ein einzelnes TwoInitialCapsException-Objekt zurückgeben, wobei Index den Namen der Ausnahme für große Anfangsbuchstaben oder die Indexnummer darstellt. Im folgenden Beispiel wird die Ausnahme "KMenu" gelöscht.

AutoCorrect.TwoInitialCapsExceptions("KMenu").Delete

Die Indexnummer stellt die Position der Ausnahme für große Anfangsbuchstaben in der TwoInitialCapsExceptions-Auflistung dar. Im folgenden Beispiel wird der Name des ersten Elements der TwoInitialCapsExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.TwoInitialCapsExceptions(1).Name

Wenn die TwoInitialCapsAutoAdd-Eigenschaft auf True gesetzt ist, werden der Liste mit Ausnahmen für große Anfangsbuchstaben automatisch Wörter hinzugefügt. Mit der Add-Methode können Sie der TwoInitialCapsExceptions-Auflistung Elemente hinzufügen. Im folgenden Beispiel wird der Liste der Ausnahmen für große Anfangsbuchstaben das Wort "INdustry" hinzugefügt.

AutoCorrect.TwoInitialCapsExceptions.Add Name:="INdustry"


TwoInitialCapsExceptions-Objekt (Auflistung)

Eine Auflistung mit TwoInitialCapsException-Objekten, die alle Elemente im Feld Nicht korrigieren der Registerkarte WOrtanfang GRoß im Dialogfeld AutoKorrektur-Ausnahmen darstellen.

Verwendung der TwoInitialCapsExceptions-Auflistung

Mit der TwoInitialCapsExceptions-Eigenschaft können Sie die TwoInitialCapsExceptions-Auflistung zurückgeben. Im folgenden Beispiel werden die Elemente dieser Auflistung angezeigt.

For Each aCap In AutoCorrect.TwoInitialCapsExceptions
    MsgBox aCap.Name
Next aCap

Wenn die TwoInitialCapsAutoAdd-Eigenschaft auf True gesetzt ist, werden der Liste mit Ausnahmen für große Anfangsbuchstaben automatisch Wörter hinzugefügt. Mit der Add-Methode können Sie der TwoInitialCapsExceptions-Auflistung Elemente hinzufügen. Im folgenden Beispiel wird der Liste der Ausnahmen für große Anfangsbuchstaben das Wort "INdustry" hinzugefügt.

AutoCorrect.TwoInitialCapsExceptions.Add Name:="INdustry"

Mit TwoInitialCapsExceptions(Index) können Sie ein einzelnes TwoInitialCapsException-Objekt zurückgeben, wobei Index den Namen der Ausnahme für große Anfangsbuchstaben oder die Indexnummer darstellt. Im folgenden Beispiel wird die Ausnahme "KMenu" gelöscht.

AutoCorrect.TwoInitialCapsExceptions("KMenu").Delete

Die Indexnummer stellt die Position der Ausnahme für große Anfangsbuchstaben in der TwoInitialCapsExceptions-Auflistung dar. Im folgenden Beispiel wird der Name des ersten Elements der TwoInitialCapsExceptions-Auflistung angezeigt.

MsgBox AutoCorrect.TwoInitialCapsExceptions(1).Name


Variable-Objekt

Stellt eine Variable dar, die als Teil eines Dokuments abgelegt wird. Dokumentvariablen werden verwendet, um die Makro-Einstellungen zwischen Makro-Sitzungen zu erhalten. Das Variable-Objekt ist ein Element der Variables-Auflistung. Die Variables-Auflistung enthält alle Dokumentvariablen in einem Dokument oder einer Vorlage.

Verwendung des Variable-Objekts

Mit Variables(Index) können Sie ein einzelnes Variable-Objekt zurückgeben. (Index ist der Name der Dokumentvariablen oder die Indexnummer.) Das folgende Beispiel zeigt den Wert der Dokumentvariablen "Temp" im aktiven Dokument an.

MsgBox ActiveDocument.Variables("Temp").Value

Die Indexnummer stellt die Position der Dokumentvariablen in der Variables-Auflistung dar. Die letzte Variable, die der Variables-Auflistung hinzugefügt wurde, hat die Indexnummer 1, die vorletzte Variable hat die Indexnummer 2 usw. Das folgende Beispiel zeigt den Namen der ersten Dokumentvariablen im aktiven Dokument an.

MsgBox ActiveDocument.Variables(1).Name

Mit der Add-Methode können Sie einem Dokument eine Variable hinzufügen. Das folgende Beispiel fügt dem aktiven Dokument die Dokumentvariable "Temp" mit dem Wert 12 hinzu.

ActiveDocument.Variables.Add Name:="Temp", Value:="12"

Wenn Sie versuchen, eine Dokumentvariable mit einem Namen hinzuzufügen, der in der Variables-Auflistung bereits vorhanden ist, wird ein Fehler erzeugt. Dieser Fehler wird vermieden, wenn Sie die Auflistung aufzählen, bevor neue Variablen hinzugefügt werden. Wenn die Dokumentvariable "Blue" bereits im aktiven Dokument vorhanden ist, legt das folgende Beispiel dafür den Wert 6 fest. Wenn diese Variable nicht bereits vorhanden ist, fügt dieses Beispiel die Variable dem Dokument hinzu und legt dafür den Wert 6 fest.

For Each aVar In ActiveDocument.Variables
    If aVar.Name = "Blue" Then num = aVar.Index
Next aVar
If num = 0 Then
    ActiveDocument.Variables.Add Name:="Blue", Value:=6
Else
    ActiveDocument.Variables(num).Value = 6
End If

Hinweise

Dokumentvariablen werden so lange für den Benutzer ausgeblendet, bis ein DOCVARIABLE-Feld mit dem geeigneten Namen für die Variable eingefügt wird. Das folgende Beispiel fügt dem aktiven Dokument die Dokumentvariable "Temp" hinzu und fügt anschließend ein DOCVARIABLE-Feld ein, um den Wert in der Variablen anzuzeigen.

With ActiveDocument
    .Variables.Add Name:="Temp", Value:="12"
    .Fields.Add Range:=Selection.Range, _
        Type:=wdFieldDocVariable, Text:="Temp"
End With
ActiveDocument.ActiveWindow.View.ShowFieldCodes = False

Um einer Vorlage eine Dokumentvariable hinzuzufügen, öffnen Sie die Vorlage als Dokument mit der OpenAsDocument-Methode. Das folgende Beispiel legt den Benutzernamen (aus dem Dialogfeld Optionen) in die Vorlage ab, die mit dem aktiven Dokument verbunden ist.

ScreenUpdating = False
With ActiveDocument.AttachedTemplate.OpenAsDocument
    .Variables.Add Name:="UserName", Value:=Application.UserName
    .Close SaveChanges:=wdSaveChanges
End With


Variables-Objekt (Auflistung)

Eine Auflistung mit Variable-Objekten, die die Variablen darstellen, die einem Dokument oder einer Vorlage hinzugefügt wurden. Dokumentvariablen werden verwendet, um Makro-Einstellungen zwischen Makro-Sitzungen zu speichern.

Verwendung der Variables-Auflistung

Mit der Variables-Eigenschaft können Sie die Variables-Auflistung zurückgeben. Das folgende Beispiel zeigt die Anzahl der Variablen im Dokument "Sales.doc" an

MsgBox Documents("Sales.doc").Variables.Count & " variables"

Mit der Add-Methode können Sie einem Dokument eine Variable hinzufügen. Das folgende Beispiel fügt dem aktiven Dokument die Dokumentvariable "Temp" mit dem Wert 12 hinzu.

ActiveDocument.Variables.Add Name:="Temp", Value:="12"

Wenn Sie versuchen, eine Dokumentvariable mit einem Namen hinzuzufügen, der bereits in der Variables-Auflistung vorhanden ist, wird ein Fehler erzeugt. Dieser Fehler wird vermieden, wenn Sie die Auflistung aufzählen, bevor Sie neue Variablen hinzufügen. Ist im aktiven Dokument die Dokumentvariable "Blue" bereits vorhanden, legt das folgende Beispiel dafür den Wert 6 fest. Ist dies nicht der Fall, wird die Variable mit dem Wert 6 hinzugefügt.

For Each aVar In ActiveDocument.Variables
    If aVar.Name = "Blue" Then num = aVar.Index
Next aVar
If num = 0 Then
    ActiveDocument.Variables.Add Name:="Blue", Value:=6
Else
    ActiveDocument.Variables(num).Value = 6
End If

Mit Variables(Index) können Sie ein einzelnes Variable-Objekt zurückgeben. (Index ist der Name der Dokumentvariablen oder die Indexnummer.) Das folgende Beispiel zeigt den Wert der Dokumentvariablen "Temp" im aktiven Dokument an.

MsgBox ActiveDocument.Variables("Temp").Value

Die Indexnummer stellt die Position der Dokumentvariablen in der Variables-Auflistung dar. Die erste Variable, die der Variables-Auflistung hinzugefügt wurde, hat die Indexnummer 1, die zweite Variable hat die Indexnummer 2 usw. Das folgende Beispiel zeigt den Namen der ersten Dokumentvariablen im aktiven Dokument an.

MsgBox ActiveDocument.Variables(1).Name

Um einer Vorlage eine Dokumentvariable hinzuzufügen, öffnen Sie die Vorlage als Dokument mit der OpenAsDocument-Methode. Das folgende Beispiel legt den Benutzernamen (aus dem Dialogfeld Optionen) in die Vorlage ab, die mit dem aktiven Dokument verbunden ist.

ScreenUpdating = False
With ActiveDocument.AttachedTemplate.OpenAsDocument
    .Variables.Add Name:="UserName", Value:= Application.UserName
    .Close SaveChanges:=wdSaveChanges
End With


Version-Objekt

Stellt eine einzelne Version eines Dokuments dar. Das Version-Objekt ist ein Element der Versions-Auflistung. Die Versions-Auflistung enthält alle Versionen des angegebenen Dokuments.

Verwendung des Version-Objekts

Mit Versions(Index) können Sie ein einzelnes Version-Objekt zurückgeben. (Index ist die Indexnummer.) Die Indexnummer stellt die Position der Version in der Versions-Auflistung dar. Die erste Version, die der Versions-Auflistung hinzugefügt wurde, hat die Indexnummer 1. Das folgende Beispiel zeigt die Kommentare, den Verfasser und das Datum der ersten Version des aktiven Dokuments an.

If ActiveDocument.Versions.Count >= 1 Then
    With ActiveDocument.Versions(1)
        MsgBox "Comment = " & .Comment & vbCr & "Author = " & _
            .SavedBy & vbCr & "Date = " & .Date
    End With
End If

Mit der Save-Methode können Sie der Versions-Auflistung ein Element hinzufügen. Das folgende Beispiel fügt eine Version des aktiven Dokuments mit dem angegebenen Kommentar hinzu.

ActiveDocument.Versions.Save _
    Comment:="incorporated Judy's revisions"


Versions-Objekt (Auflistung)

Eine Auflistung mit Version-Objekten, die alle Versionen eines Dokuments darstellen. Entspricht den Elementen, die im Dialogfeld Version (Menü Datei) aufgelistet sind.

Verwendung der Versions-Auflistung

Mit der Versions-Eigenschaft können Sie die Versions-Auflistung zurückgeben. Das folgende Beispiel deaktiviert die Option, die neue Dokumentversionen automatisch erstellt.

ActiveDocument.Versions.AutoVersion = wdAutoVersionOff

Mit der Save-Methode können Sie der Versions-Auflistung ein Element hinzufügen. Das folgende Beispiel fügt eine Version mit dem angegebenen Kommentar hinzu.

ActiveDocument.Versions.Save _
    Comment:="incorporated Judy's revisions"

Mit Versions(Index) können Sie ein einzelnes Version-Objekt zurückgeben. (Index ist die Indexnummer.) Die Indexnummer stellt die Position der Version in der Versions-Auflistung dar. Die erste Version, die der Versions-Auflistung hinzugefügt wurde, hat die Indexnummer 1. Das folgende Beispiel zeigt die Kommentare, den Verfasser und das Datum der ersten Version des aktiven Dokuments an.

If ActiveDocument.Versions.Count >= 1 Then
    With ActiveDocument.Versions(1)
        MsgBox "Comment = " & .Comment & vbCr & "Author = " & _
            .SavedBy & vbCr & "Date = " & .Date
    End With
End If


View-Objekt

Enthält die Ansichtsattribute (Alle anzeigen, Feldschattierung, Tabellen-Gitternetzlinien usw.) für ein Fenster oder einen Ausschnitt.

Verwendung des View-Objekts

Mit der View-Eigenschaft können Sie das View-Objekt zurückgeben. Das folgende Beispiel legt die Ansichtsoptionen für das aktive Fenster fest.

With ActiveDocument.ActiveWindow.View
    .ShowAll = True
    .TableGridlines = True
    .WrapToWindow = False
End With

Hinweise

Mit der Type-Eigenschaft können Sie die Ansicht ändern. Das folgende Beispiel wechselt das aktive Fenster zur Normalansicht.

ActiveDocument.ActiveWindow.View.Type = wdNormalView

Mit der Percentage-Eigenschaft können Sie die Textgröße am Bildschirm ändern. Das folgende Beispiel vergrößert die Textgröße auf 120 Prozent.

ActiveDocument.ActiveWindow.View.Zoom.Percentage = 120

Mit der SeekView-Eigenschaft können Sie Kommentare, Endnoten, Fußnoten bzw. die Kopf- oder Fußzeile des Dokuments anzeigen. Das folgende Beispiel zeigt die aktuelle Fußzeile im aktiven Fenster in der Drucklayoutansicht an.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageFooter
End With


WebOptions-Objekt

Enthält Attribute auf Dokumentebene, die von Microsoft Word verwendet werden, wenn Sie ein Dokument als Webseite speichern oder eine Webseite öffnen. Sie können Attribute entweder auf Anwendungsebene (global) oder auf Dokumentebene zurückgeben oder festlegen. (Beachten Sie, dass die Attributwerte der einzelnen Dokumente je nach Attributwert zum Zeitpunkt der Speicherung des Dokuments unterschiedlich sein können.) Attributeinstellungen auf Dokumentebene setzen die Attributeinstellungen auf Anwendungsebene außer Kraft. Attribute auf Anwendungsebene sind im DefaultWebOptions-Objekt enthalten.

Verwendung des WebOptions-Objekts

Verwenden Sie die WebOptions-Eigenschaft, um das WebOptions-Objekt zurückzugeben. Im folgenden Beispiel wird überprüft, ob PNG (Portable Network Graphics) als Bildformat zulässig ist; anschließend wird die Variable strImageFileType entsprechend festgelegt.

Set objAppWebOptions = ActiveDocument.WebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        strImageFileType = "PNG"
    Else
        strImageFileType = "JPG"
    End If
End With


Window-Objekt

Stellt ein Fenster dar. Viele Dokumentcharakteristika (z. B. Bildlaufleisten und Lineale) sind Eigenschaften des Fensters. Das Window-Objekt ist ein Element der Windows-Auflistung. Die Windows-Auflistung für das Application-Objekt enthält alle Fenster der Anwendung, wohingegen die Windows-Auflistung für das Document-Objekt lediglich die Fenster enthält, die im angegebenen Dokument angezeigt werden.

Verwendung des Window-Objekts

Mit Windows(Index) können Sie ein einzelnes Window-Objekt zurückgeben. (Index ist der Name des Fensters oder die Indexnummer.) Das folgende Beispiel maximiert das Fenster für Document1.

Windows("Document1").WindowState = wdWindowStateMaximize

Die Indexnummer steht links neben dem Namen des Fensters im Menü Fenster. Das folgende Beispiel zeigt die Beschriftung für das erste Fenster der Windows-Auflistung an.

MsgBox Windows(1).Caption

Mit der Add- oder der NewWindow-Methode können Sie der Windows-Auflistung ein neues Fenster hinzufügen. Jede der folgenden Anweisungen erstellt ein neues Fenster für das Dokument im aktiven Fenster.

ActiveDocument.ActiveWindow.NewWindow
NewWindow
Windows.Add

Hinweise

Sind mehrere Fenster für ein Dokument geöffnet, erscheint in der Fensterbeschriftung ein Doppelpunkt (:) sowie eine Zahl.

Wenn Sie zur Seitenansicht wechseln, wird ein neues Fenster erstellt. Dieses Fenster wird aus der Windows-Auflistung entfernt, wenn Sie die Seitenansicht schließen.


Windows-Objekt (Auflistung)

Eine Auflistung mit Window-Objekten, die alle verfügbaren Fenster darstellt. Die Windows-Auflistung enthält für das Application-Objekt alle Fenster in der Anwendung, wohingegen die Windows-Auflistung für das Document-Objekt lediglich die Fenster enthält, die das angegebene Dokument anzeigen.

Verwendung der Windows-Auflistung

Mit der Windows-Eigenschaft können Sie die Windows-Auflistung zurückgeben. Das folgende Beispiel teilt alle Fenster so, dass sich die Fenster nicht überlappen.

Windows.Arrange ArrangeStyle:=wdTiled

Mit der Add-Methode oder der NewWindow-Methode können Sie der Windows-Auflistung ein neues Fenster hinzufügen. Jede der folgenden Anweisungen erstellt ein neues Fenster für das Dokument im aktiven Fenster.

ActiveDocument.ActiveWindow.NewWindow
NewWindow
Windows.Add

Mit Windows(Index) können Sie ein einzelnes Window-Objekt zurückgeben. (Index ist der Name des Fensters oder die Indexnummer.) Das folgende Beispiel maximiert das Fenster für Document1.

Windows("Document1").WindowState = wdWindowStateMaximize

Die Indexnummer steht links neben dem Namen des Fensters im Menü Fenster. Das folgende Beispiel zeigt die Beschriftung des ersten Fensters in der Windows-Auflistung an.

MsgBox Windows(1).Caption

Hinweise

Sind mehrere Fenster für ein Dokument geöffnet, erscheint in der Fensterbeschriftung ein Doppelpunkt (:) sowie eine Zahl.

Wenn Sie zur Seitenansicht wechseln, wird ein neues Fenster erstellt. Dieses Fenster wird aus der Windows-Auflistung entfernt, wenn Sie die Seitenansicht schließen.


Words-Objekt (Auflistung)

Eine Auflistung mit Wörtern in einer Markierung, einem Bereich oder Dokument. Jedes Element der Words-Auflistung ist ein Range-Objekt, das ein Wort darstellt. Es gibt kein Word-Objekt.

Verwendung der Words-Auflistung

Mit der Words-Eigenschaft können Sie das Words-Objekt zurückgeben. Das folgende Beispiel zeigt an, wie viele Wörter aktuell markiert sind.

MsgBox Selection.Words.Count & " words are selected"

Mit Words(Index) können Sie ein Range-Objekt zurückgeben, das ein Wort darstellt. (Index ist die Indexnummer.) Die Indexnummer stellt die Position des Wortes in der Words-Auflistung dar. Das folgende Beispiel formatiert das erste Wort in der Markierung 24 Punkt kursiv.

With Selection.Words(1)
    .Italic = True
    .Font.Size = 24
End With

Das Element in der Words-Auflistung enthält sowohl das Wort als auch die Abstände nach dem Wort. Mit der RTrim-Funktion können Sie die nachstehenden Leerzeichen entfernen, z. B. RTrim(ActiveDocument.Words(1). Das folgende Beispiel markiert das erste Wort (und die nachstehenden Leerzeichen) im aktiven Dokument.

ActiveDocument.Words(1).Select

Hinweise

Wenn die Auswahl die Stelle der Einfügung darstellt und direkt nach ihr ein Leerzeichen folgt, bezieht sich der Befehl Selection.Words(1) auf das der Auswahl voranstehene Wort. Wenn die Auswahl die Stelle der Einfügung darstellt und direkt nach ihr ein Zeichen folgt, bezieht sich der Befehl Selection.Words(1) auf das der Auswahl nachstehende Wort.

Die Count-Eigenschaft für diese Auflistung in einem Dokument gibt nur die Anzahl der Elemente in der Hauptkomponente zurück. Verwenden Sie zum Zählen von Elementen in anderen Textabschnitten die Auflistung mit dem Range-Objekt. In der Summe der Count-Eigenschaft sind auch Satz- und Absatzzeichen enthalten. Verwenden Sie zur Ermittlung der tatsächlichen Wortzahl eines Dokuments das Dialogfeld Word Count. Im folgenden Beispiel wird die Anzahl der Wörter des aktiven Dokuments ermittelt und als Wert der Variablen numWords zugewiesen.

Set temp = Dialogs(wdDialogToolsWordCount)
' Execute the dialog box in order to refresh its data.
temp.Execute
numWords = temp.Words

Weitere Informationen über das Aufrufen integrierter Dialogfelder erhalten Sie unter Anzeigen von in Word integrierten Dialogfeldern.

Die Add-Methode ist für die Words-Auflistung nicht verfügbar. Sie können stattdessen mit der InsertAfter-Methode oder der InsertBefore-Methode einem Range-Objekt Text hinzufügen. Das folgende Beispiel fügt Text nach dem ersten Wort im aktiven Dokument ein.

ActiveDocument.Range.Words(1).InsertAfter "New text "


WrapFormat-Objekt

Stellt alle Eigenschaften zum Umbrechen eines Textes um eine Form oder einen Formbereich dar.

Verwendung von WrapFormat-Objekten

Verwenden Sie die WrapFormat-Eigenschaft, um das WrapFormat-Objekt zurückzugeben. Im folgenden Beispiel wird dem aktiven Dokument ein Oval hinzugefügt und festgelegt, dass der Dokumenttext um die linke und rechte Seite des Quadrats umbrochen wird, das das Oval umgibt. Zwischen dem Dokumenttext und den oberen, unteren, linken und rechten Seiten des Quadrats wird ein Rand von 0,1 Zoll festgelegt.

Set myOval = _
    ActiveDocument.Shapes.AddShape(msoShapeOval, 36, 36, 100, 35)
With myOval.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


Zoom-Objekt

Enthält Zoom-Optionen (z. B. den Zoomfaktor) für ein Fenster oder einen Ausschnitt. Das Zoom-Objekt ist ein Element der Zooms-Auflistung.

Verwendung des Zoom-Objekts

Mit der Zoom-Eigenschaft des View-Objekts können Sie ein einzelnes Zoom-Objekt zurückgeben. Das folgende Beispiel legt als Zoomfaktor für das aktive Fenster 110 Prozent fest.

ActiveDocument.ActiveWindow.View.Zoom.Percentage = 110

Mit Zooms(Index) können Sie ein einzelnes Zoom-Objekt zurückgeben. Der durch Index angegebene Ansichtstyp kann eine der folgenden WdViewType-Konstanten sein: wdMasterView, wdNormalView, wdOutlineView, wdPrintPreview, wdPrintView oder wdWebView. Im folgenden Beispiel wird der Zoomfaktor für das aktive Fenster so eingestellt, dass eine ganze Seite sichtbar ist.

ActiveDocument.ActiveWindow.ActivePane _
    .Zooms(wdPrintView).PageFit = wdPageFitFullPage

Die Add-Methode ist für die Zooms-Auflistung nicht verfügbar. Die Zooms-Auflistung enthält ein einzelnes Zoom-Objekt für jeden Ansichtstyp (Gliederung, Normal, Layoutansicht usw.).


Zooms-Objekt (Auflistung)

Eine Auflistung mit Zoom-Objekten, die die Zoom-Optionen für jede Ansicht (Gliederung, Normal, Layoutansicht usw.) darstellt.

Verwendung der Zooms-Auflistung

Mit der Zooms-Eigenschaft können Sie die Zooms-Auflistung zurückgeben. Das folgende Beispiel legt einen Zoomfaktor von 100 Prozent für das aktive Fenster in der Normalansicht fest.

ActiveDocument.ActiveWindow.ActivePane _
    .Zooms(wdNormalView).Percentage = 100

Die Add-Methode ist für die Zooms-Auflistung nicht verfügbar. Die Zooms-Auflistung enthält ein einzelnes Zoom-Objekt für jeden Ansichtstyp (Gliederung, Normal, Layoutansichten usw.). Sie können mit For Each...Next die Zooms-Auflistung nicht aufzählen.

Mit Zooms(Index) können Sie ein einzelnes Zoom-Objekt zurückgeben. (Index bezeichnet den Ansichtstyp.) Der Ansichtstyp, der durch Index angegeben wird, kann eine der folgenden WdViewType-Konstanten sein: wdMasterView, wdNormalView, wdOutlineView, wdPrintPreview, wdPrintView oder wdWebPreview. Im folgenden Beispiel wird der Zoomfaktor für das aktive Fenster so eingestellt, dass eine ganze Seite sichtbar ist.

ActiveDocument.ActiveWindow.ActivePane _
    .Zooms(wdPrintView).PageFit = wdPageFitFullPage

Mit der Zoom-Eigenschaft des View-Objekts können Sie ein einzelnes Zoom-Objekt zurückgeben. Das folgende Beispiel legt einen Zoomfaktor von 110 Prozent für das aktive Fenster fest.

ActiveDocument.ActiveWindow.View.Zoom.Percentage = 110


Neue Eigenschaften (nach Objekten sortiert)

In der folgenden Tabelle sind die Eigenschaften aufgeführt, die in Microsoft Word 2000 zu den bereits vorhandenen Objekten hinzugefügt wurden (nach Objektnamen sortiert).

Objekt | Neue Eigenschaften
Application | AnswerWizard, CheckLanguage, COMAddIns, EmailOptions, FeatureInstall, HangulHanjaDictionaries, Language, LanguageSettings
AutoCorrect | CorrectHangulAndAlphabet, CorrectKeyboardSetting, HangulAndAlphabetAutoAdd, HangulAndAlphabetExceptions, OtherCorrectionsAutoAdd, OtherCorrectionsExceptions, ReplaceTextFromSpellingChecker
Border | Color
Borders | InsideColor, OutsideColor
Cell | BottomPadding, FitText, LeftPadding, NestingLevel, PreferredWidth, PreferredWidthType, RightPadding, TopPadding, WordWrap
Cells | NestingLevel, PreferredWidth, PreferredWidthType
Column | NestingLevel, PreferredWidth, PreferredWidthType
Columns | NestingLevel, PreferredWidth, PreferredWidthType
DefaultWebOptions | AllowPNG, AlwaysSaveInDefaultEncoding, BrowserLevel, CheckIfOfficeIsHTMLEditor, CheckIfWordIsDefaultHTMLEditor, Encoding, FolderSuffix, Fonts, OptimizeForBrowser, OrganizeInFolder, PixelsPerInch, RelyOnCSS, RelyOnVML, ScreenSize, UpdateLinksOnSave, UseLongFileNames
Dialog | CommandName
Document | ActiveTheme, ActiveThemeDisplayName, ClickAndTypeParagraphStyle, Email, FarEastLineBreakLanguage, FarEastLineBreakLevel, Frameset, GridOriginFromMargin, GridSpaceBetweenHorizontalLines, GridSpaceBetweenVerticalLines, HTMLProject, JustificationMode, KerningByAlgorithm, LanguageDetected, NoLineBreakAfter, NoLineBreakBefore, OpenEncoding, OptimizeForWord97, SaveEncoding, Scripts, VBASigned, WebOptions
Email | CurrentEmailAuthor
EmailOptions | ComposeStyle, EmailSignature, MarkComments, MarkCommentsWith, ReplyStyle, ThemeName, UseThemeStyle
EmailSignature | NewMessageSignature, ReplyMessageSignature
Find | CorrectHangulEndings, MatchAlefHamza, MatchByte, MatchControl, MatchDiacritics, MatchFuzzy, MatchKashida, NoProofing
Font | BoldBi, Color, ColorIndexBi, DiacriticColor, DisableCharacterSpaceGrid, EmphasisMark, ItalicBi, NameBi, SizeBi, UnderlineColor
Frameset | ChildFramesetCount, ChildFramesetItem, FrameDefaultURL, FrameDisplayBorders, FrameLinkToFile, FrameName, FrameResizable, FrameScrollbarType, FramesetBorderColor, FramesetBorderWidth, HeightType, ParentFrameset, WidthType
Global | AnswerWizard, HangulHanjaDictionaries, LanguageSettings
HangulHanjaConversionDictionaries | BuiltinDictionary
HorizontalLineFormat | NoShade, PercentWidth, WidthType
Hyperlink | EmailSubject, ScreenTip, TextToDisplay
Index | Filter, IndexLanguage, SortBy
InlineShape | AlternativeText, HorizontalLineFormat, Script
Options | AddBiDirectionalMarksWhenSavingTextFile, AddControlCharacters, AddHebDoubleQuote, AllowClickAndTypeMouse, AllowCombinedAuxiliaryForms, AllowCompoundNounProcessing, AllowPixelUnits, ApplyFarEastFontsToAscii, ArabicMode, ArabicNumeral, AutoFormatApplyFirstIndents, AutoFormatAsYouTypeApplyClosings, AutoFormatAsYouTypeApplyDates, AutoFormatAsYouTypeApplyFirstIndents, AutoFormatAsYouTypeAutoLetterWizard, AutoFormatAsYouTypeDeleteAutoSpaces, AutoFormatAsYouTypeInsertClosings, AutoFormatAsYouTypeInsertOvers, AutoFormatAsYouTypeMatchParentheses, AutoFormatAsYouTypeReplaceFarEastDashes, AutoFormatDeleteAutoSpaces, AutoFormatMatchParentheses, AutoFormatReplaceFarEastDashes, AutoKeyboardSwitching, CheckHangulEndings, ConvertHighAnsiToFarEast, CursorMovement, DefaultBorderColor, DiacriticColorVal, DisplayGridLines, DocumentViewDirection, EnableHangulHanjaRecentOrdering, EnableMisusedWordsDictionary, HangulHanjaFastConversion, HebrewMode, IMEAutomaticControl, InlineConversion, InterpretHighAnsi, MatchFuzzyAY, MatchFuzzyBV, MatchFuzzyByte, MatchFuzzyCase, MatchFuzzyDash, MatchFuzzyDZ, MatchFuzzyHF, MatchFuzzyHiragana, MatchFuzzyIterationMark, MatchFuzzyKanji, MatchFuzzyKiKu, MatchFuzzyOldKana, MatchFuzzyProlongedSoundMark, MatchFuzzyPunctuation, MatchFuzzySmallKana, MatchFuzzySpace, MatchFuzzyTC, MatchFuzzyZJ, MonthNames, MultipleWordConversionsMode, OptimizeForWord97byDefault, PrintEvenPagesInAscendingOrder, PrintOddPagesInAscendingOrder, ShowControlCharacters, ShowDiacritics, StrictFinalYaa, StrictInitialAlefHamza, UseCharacterUnit, UseDiffDiacColor, UseGermanSpellingReform, VisualSelection
PageNumbers | DoubleQuote
PageSetup | CharsLine, GutterPos, GutterStyle, LayoutMode, LinesPage, SectionDirection, TwoPagesOnOne
Pane | Frameset
Paragraph | AddSpaceBetweenFarEastAndAlpha, AddSpaceBetweenFarEastAndDigit, AutoAdjustRightIndent, BaseLineAlignment, CharacterUnitFirstLineIndent, CharacterUnitLeftIndent, CharacterUnitRightIndent, DisableLineHeightGrid, FarEastLineBreakControl, HalfWidthPunctuationOnTopOfLine, HangingPunctuation, LineUnitAfter, LineUnitBefore, ReadingOrder, SpaceAfterAuto, SpaceBeforeAuto, WordWrap
ParagraphFormat | AddSpaceBetweenFarEastAndAlpha, AddSpaceBetweenFarEastAndDigit, AutoAdjustRightIndent, BaseLineAlignment, CharacterUnitFirstLineIndent, CharacterUnitLeftIndent, CharacterUnitRightIndent, DisableLineHeightGrid, FarEastLineBreakControl, HalfWidthPunctuationOnTopOfLine, HangingPunctuation, LineUnitAfter, LineUnitBefore, ReadingOrder, SpaceAfterAuto, SpaceBeforeAuto, WordWrap
Paragraphs | AddSpaceBetweenFarEastAndAlpha, AddSpaceBetweenFarEastAndDigit, AutoAdjustRightIndent, BaseLineAlignment, CharacterUnitFirstLineIndent, CharacterUnitLeftIndent, CharacterUnitRightIndent, DisableLineHeightGrid, FarEastLineBreakControl, HalfWidthPunctuationOnTopOfLine, HangingPunctuation, LineUnitAfter, LineUnitBefore, ReadingOrder, SpaceAfterAuto, SpaceBeforeAuto, WordWrap
Range | BoldBi, CharacterWidth, CombineCharacters, DisableCharacterSpaceGrid, EmphasisMark, FitTextWidth, HorizontalInVertical, ItalicBi, Kana, LanguageDetected, NoProofing, Scripts, TopLevelTables, TwoLinesInOne
Replacement | NoProofing
Row | NestingLevel
Rows | AllowOverlap, NestingLevel, TableDirection, WrapAroundText
Selection | FitTextWidth, LanguageDetected, NoProofing, TopLevelTables
Shading | BackgroundPatternColor, ForegroundPatternColor
Shape | AlternativeText, Script
ShapeRange | AlternativeText
Style | NoProofing
Table | AllowAutoFit, AllowPageBreaks, BottomPadding, LeftPadding, NestingLevel, PreferredWidth, PreferredWidthType, RightPadding, TableDirection, TopPadding
TableOfContents | HidePageNumbersInWeb, UseHyperlinks
TableOfFigures | HidePageNumbersInWeb, UseHyperlinks
Tables | NestingLevel
Template | FarEastLineBreakLanguage, FarEastLineBreakLevel, JustificationMode, KerningByAlgorithm, NoLineBreakAfter, NoLineBreakBefore, NoProofing
TextColumns | FlowDirection
View | ShowOptionalBreaks
WebOptions | AllowPNG, BrowserLevel, Encoding, FolderSuffix, OptimizeForBrowser, OrganizeInFolder, PixelsPerInch, RelyOnCSS, RelyOnVML, ScreenSize, UseLongFileNames
Window | DisplayLeftScrollBar, DisplayRightRuler, EnvelopeVisible, IMEMode
WrapFormat | AllowOverlap


Accent-Eigenschaft

True, wenn eine vertikale Markierungsleiste den Legendentext von der Legendenlinie trennt. Long Schreib-Lese-Zugriff.


AccentedLetters-Eigenschaft

True, wenn der angegebene Index separate Überschriften für mit Akzenten versehene Buchstaben enthält (z. B. Wörter, die mit "À" beginnen, stehen unter einer Überschrift und Wörter, die mit "A" beginnen unter einer anderen). Boolean Schreib-Lese-Zugriff.


Beispiel zur AccentedLetters-Eigenschaft

In diesem Beispiel wird der erste Index im aktiven Dokument als einspaltiger Index formatiert. Alle alphabetischen Gruppen werden durch den entsprechenden Buchstaben angeführt, und für Buchstaben mit Akzenten gibt es eigene Überschriften.

If ActiveDocument.Indexes.Count >= 1 Then
    With ActiveDocument.Indexes(1)
        .HeadingSeparator = wdHeadingSeparatorLetter
        .NumberOfColumns = 1
        .AccentedLetters = True
    End With
End If


Active-Eigenschaft

LineNumbering-Objekt: True, falls die Zeilennummerierung für ein festgelegtes Dokument, einen Abschnitt oder Abschnitte aktiviert ist. Es können True, False oder wdUndefined. Read/write Long vorkommen.

Selection-Objekt: True, wenn die Markierung im angegebenen Fenster oder Fensterausschnitt aktiv ist. Boolean Nur-Lese-Zugriff.

Window object: True, wenn das angegebene Fenster aktiv ist. Boolean Nur-Lese-Zugriff.


ActiveCustomDictionary-Eigenschaft

Gibt ein Dictionary-Objekt, das das benutzerdefinierte Wörterbuch repräsentiert, in welches Wörter aufgenommen werden, zurück oder legt es fest. Schreib-Lese-Zugriff.


Beispiel zur ActiveCustomDictionary-Eigenschaft

In diesem Beispiel werden die vollständige Pfadangabe und der Name des aktiven benutzerdefinierten Wörterbuchs angezeigt.

Set myCust = Application.CustomDictionaries.ActiveCustomDictionary
MsgBox myCust.Path & Application.PathSeparator & myCust.Name

In diesem Beispiel werden alle vorhandenen benutzerdefinierten Wörterbücher gelöscht, ein benutzerdefiniertes Wörterbuch mit der Bezeichnung "Home.dic" hinzugefügt und dann das neue Wörterbuch geladen.

Application.CustomDictionaries.ClearAll
Set myCust = Application.CustomDictionaries _
    .Add(FileName:="C:\Program Files" _
    & "\Microsoft Office\Office\Home.dic")
CustomDictionaries.ActiveCustomDictionary = myCust


ActiveDocument-Eigenschaft

Gibt ein Document-Objekt zurück, das das aktive Dokument (das Dokument mit dem Fokus) darstellt. Wenn keine Dokumente geöffnet sind, tritt ein Fehler auf. Nur-Lese-Zugriff.


Beispiel zur ActiveDocument-Eigenschaft

In diesem Beispiel wird der Name des aktiven Dokuments oder, wenn keine Dokumente geöffnet sind, eine Meldung angezeigt.

If Documents.Count >= 1 Then
    MsgBox ActiveDocument.Name
Else
    MsgBox "No documents are open"
End If

In diesem Beispiel wird die Auswahl zu einer Einfügemarke reduziert. Anschließend wird ein Bereich für die nächsten fünf Zeichen in der Auswahl erstellt.

Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.Range Start:=Selection.Start, End:=Selection.Start+5

In diesem Beispiel wird Text am Anfang des aktiven Dokuments eingefügt und das Dokument anschließend gedruckt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
With myRange
    .InsertBefore "Company Report"
    .Font.Name = "Arial"
    .Font.Size = 24
    .InsertParagraphAfter
End With
ActiveDocument.PrintOut


ActiveGrammarDictionary-Eigenschaft

Gibt ein Dictionary-Objekt zurück, das das aktive Grammatikwörterbuch für die angegebene Sprache darstellt. Nur-Lese-Zugriff.

Hinweise

Wurde kein Grammatikwörterbuch für die angegebene Sprache installiert, gibt diese Eigenschaft Nothing zurück.


Beispiel zur ActiveGrammarDictionary-Eigenschaft

In diesem Beispiel werden die vollständige Pfadangabe und der Dateiname des aktiven Grammatikwörterbuchs angezeigt.

myLang = Selection.LanguageID
Set myGram = Languages(myLang).ActiveGrammarDictionary
MsgBox myGram.Path & Application.PathSeparator & myGram.Name


ActiveHyphenationDictionary-Eigenschaft

Gibt ein Dictionary-Objekt zurück, das das aktive Wörterbuch für die Silbentrennung der angegebenen Sprache darstellt. Nur-Lese-Zugriff.

Hinweise

Wurde kein Wörterbuch für die Silbentrennung der angegebenen Sprache installiert, gibt diese Eigenschaft Nothing zurück.


Beispiel zur ActiveHyphenationDictionary-Eigenschaft

In diesem Beispiel werden die vollständige Pfadangabe und der Dateiname des aktiven Wörterbuchs für die Silbentrennung angezeigt.

myLang = Selection.LanguageID
Set myHyph = Languages(myLang).ActiveHyphenationDictionary
MsgBox myHyph.Path & Application.PathSeparator & myHyph.Name


ActivePane-Eigenschaft

Gibt ein Pane-Objekt zurück, das den aktiven Fensterausschnitt für das angegebene Fenster darstellt. Nur-Lese-Zugriff.


Beispiel zur ActivePane-Eigenschaft

In diesem Beispiel wird das aktive Fenster geteilt. Anschließend wird der Fensterausschnitt aktiviert, der auf den aktiven Ausschnitt folgt.

With ActiveDocument.ActiveWindow
    .Split = True
    .ActivePane.Next.Activate
    MsgBox "Pane " & .ActivePane.Index & " is active"
End With

In diesem Beispiel wird das erste Fenster aktiviert, und im aktiven Fensterauschnitt werden Tabstopps angezeigt.

With Windows(1)
    .Activate
    .ActivePane.View.ShowTabs = True
End With


ActivePrinter-Eigenschaft

Gibt den Namen des aktiven Druckers zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur ActivePrinter-Eigenschaft

In diesem Beispiel wird der Name des aktiven Druckers angezeigt.

MsgBox "The name of the active printer is " & ActivePrinter

In diesem Beispiel wird der Netzwerkdrucker HP LaserJet IIISi als aktiver Drucker gewählt.

ActivePrinter = "HP LaserJet IIISi on \\printers\laser"

In diesem Beispiel wird der lokale Drucker HP LaserJet 4 an LPT1 als aktiver Drucker gewählt.

ActivePrinter = "HP LaserJet 4 local on LPT1:"


ActiveRecord-Eigenschaft

Gibt den aktiven Datensatz für den Seriendruck zurück oder legt ihn fest. Dies kann eine gültige Datensatznummer im Abfrageergebnis sein oder eine der folgenden WdMailMergeActiveRecord-Konstanten: wdFirstRecord, wdLastRecord, wdNextRecord, wdNoActiveRecord oder wdPreviousRecord. Long Schreib-Lese-Zugriff.

Hinweis Die aktive Datensatznummer entspricht der Position des Datensatzes im Abfrageergebnis, das mit den aktuellen Abfrageoptionen erstellt wurde. Diese Zahl muss nicht unbedingt der Position des Datensatzes in der Datenquelle entsprechen.


Beispiel zur ActiveRecord-Eigenschaft

In diesem Beispiel werden die Feldfunktionen für den Seriendruck im aktiven Dokument ausgeblendet, so dass die Daten für den Seriendruck im Hauptdokument sichtbar werden. Der aktive Datensatz wird dann auf den nächsten Datensatz in der Datenquelle verschoben.

If ActiveDocument.MailMerge.MainDocumentType <> _
        wdNotAMergeDocument Then
    With ActiveDocument.MailMerge
        .ViewMailMergeFieldCodes = False
        .DataSource.ActiveRecord = wdNextRecord
    End With
End If

In diesem Beispiel wird die numerische Position des aktiven Datensatzes von Main2.doc zurückgegeben.

If Documents("Main2.doc").MailMerge.State = _
        wdMainAndDataSource Or _
        wdMainAndSourceAndHeader Then
    num = Documents("Main2.doc").MailMerge _
        .DataSource.ActiveRecord
End If


ActiveSpellingDictionary-Eigenschaft

Gibt ein Dictionary-Objekt zurück, das das aktive Wörterbuch für die angegebene Sprache darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wenn kein Wörterbuch für die angegebene Sprache installiert wurde, gibt diese Eigenschaft Nothing zurück.


Beispiel zur ActiveSpellingDictionary-Eigenschaft

In diesem Beispiel werden die vollständige Pfadangabe und der Dateiname des aktiven Wörterbuchs für die Rechtschreibung zurückgegeben.

myLang = Selection.LanguageID
Set mySpell = Languages(myLang).ActiveSpellingDictionary
MsgBox mySpell.Path & Application.PathSeparator & mySpell.Name


 ActiveTheme-Eigenschaft

ActiveTheme-Eigenschaft

Gibt den Namen des aktiven Designs und die Formatierungsoptionen des Designs für das angegebene Dokument zurück. Gibt "None" zurück, wenn für das Dokument kein aktives Design vorhanden ist. String Nur-Lese-Zugriff.

Hinweise

Eine Erklärung des von dieser Eigenschaft zurückgegebenen Wertes finden Sie unter der ApplyTheme-Methode unter Name-Argument. Dieser Wert entspricht möglicherweise nicht dem im Dialogfeld Design (Menü Format, Befehl Design) aufgeführten Anzeigenamen des Designs. Verwenden Sie zur Rückgabe des Anzeigenamens eines Designs die ActiveThemeDisplayName-Eigenschaft.


 ActiveThemeDisplayName-Eigenschaft

ActiveThemeDisplayName-Eigenschaft

Gibt den Anzeigenamen des aktiven Designs für das angegebene Dokument zurück. Wenn für das Dokument kein aktives Design vorhanden ist, wird "None" zurückgegeben. String Nur-Lese-Zugriff.

Hinweise

Der Anzeigename eines Designs ist der im Dialogfeld Design (Menü Format, Befehl Design) angezeigte Name. Dieser Name entspricht möglicherweise nicht der Zeichenfolge, die Sie zum Festlegen eines Standarddesigns oder zum Zuweisen eines Designs zu einem Dokument verwenden würden.


Beispiel zur ActiveThemeDisplayName-Eigenschaft

In diesem Beispiel wird der Anzeigename des aktiven Designs für das aktuelle Dokument angezeigt.

MsgBox ActiveDocument.ActiveThemeDisplayName


ActiveThesaurusDictionary-Eigenschaft

Gibt ein Dictionary-Objekt zurück, das das aktive Thesaurus-Wörterbuch für die angegebene Sprache darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wenn für die angegebene Sprache kein Thesaurus-Wörterbuch installiert ist, gibt diese Eigenschaft Nothing zurück.


Beispiel zur ActiveThesaurusDictionary-Eigenschaft

In diesem Beispiel werden der vollständige Pfad- und Dateiname des aktiven Thesaurus-Wörterbuchs zurückgegeben.

myLang = Selection.LanguageID
Set myThes = Languages(myLang).ActiveThesaurusDictionary
MsgBox myThes.Path & Application.PathSeparator & myThes.Name


ActiveWindow-Eigenschaft

Gibt ein Window-Objekt zurück, das das aktive Fenster darstellt (das Fenster mit dem Fokus). Wenn keine Fenster geöffnet sind, tritt ein Fehler auf. Nur-Lese-Zugriff.


Beispiel zur ActiveWindow-Eigenschaft

In diesem Beispiel wird der Beschriftungstext des aktiven Fensters angezeigt.

MsgBox ActiveDocument.ActiveWindow.Caption

In diesem Beispiel wird ein neues Fenster für das aktive Fenster des aktiven Dokuments geöffnet. Anschließend werden alle Fenster nebeneinander angeordnet.

Set myWindow = ActiveDocument.ActiveWindow.NewWindow
Windows.Arrange ArrangeStyle:=wdTiled

In diesem Beispiel wird das erste Dokumentfenster geteilt.

Documents(1).ActiveWindow.Split= True


ActiveWritingStyle-Eigenschaft

Gibt den Schreibstil für eine angegebene Sprache im angegebenen Dokument zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkung Die WritingStyleList-Eigenschaft gibt ein Array mit den Namen der verfügbaren Schreibstile zurück.

Syntax

Ausdruck.ActiveWritingStyle(LanguageID)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

LanguageID Variant erforderlich. Die Sprache, deren Schreibstil für das angegebene Dokument festgelegt werden soll. Dabei kann es sich um eine Zeichenfolge oder eine der folgenden WdLanguageID-Konstanten handeln:

wdAfrikaans

wdAlbanian

wdArabic

wdArabicAlgeria

wdArabicBahrain

wdArabicEgypt

wdArabicIraq

wdArabicJordan

wdArabicKuwait

wdArabicLebanon

wdArabicLibya

wdArabicMorocco

wdArabicOman

wdArabicQatar

wdArabicSyria

wdArabicTunisia

wdArabicUAE

wdArabicYemen

wdArmenian

wdAssamese

wdAzeriCyrillic

wdAzeriLatin

wdBasque

wdBelgianDutch

wdBelgianFrench

wdBengali

wdBosniaHerzegovina

wdBrazilianPortuguese

wdBulgarian

wdBurmese

wdByelorussian

wdCatalan

wdChineseHongKong

wdChineseMacao

wdChineseSingapore

wdCroatian

wdCzech

wdDanish

wdDutch

wdEnglishAUS

wdEnglishBelize

wdEnglishCanadian

wdEnglishCaribbean

wdEnglishIreland

wdEnglishJamaica

wdEnglishNewZealand

wdEnglishPhilippines

wdEnglishSouthAfrica

wdEnglishTrinidad

wdEnglishUK

wdEnglishUS

wdEnglishZimbabwe

wdEstonian

wdFaeroese

wdFarsi

wdFinnish

wdFrench

wdFrenchCameroon

wdFrenchCanadian

wdFrenchCotedIvoire

wdFrenchLuxembourg

wdFrenchMali

wdFrenchMonaco

wdFrenchReunion

wdFrenchSenegal

wdFrenchWestIndies

wdFrenchZaire

wdFrisianNetherlands

wdGaelicIreland

wdGaelicScotland

wdGalician

wdGeorgian

wdGerman

wdGermanAustria

wdGermanLiechtenstein

wdGermanLuxembourg

wdGreek

wdGujarati

wdHebrew

wdHindi

wdHungarian

wdIcelandic

wdIndonesian

wdItalian

wdJapanese

wdKannada

wdKashmiri

wdKazakh

 wdKhmer

wdKirghiz

wdKonkani

wdKorean

wdLanguageNone

wdLao

wdLatvian

wdLithuanian

wdLithuanianClassic

wdMacedonian

wdMalayalam

wdMalayBruneiDarussalam

wdMalaysian

wdMaltese

wdManipuri

wdMarathi

wdMexicanSpanish

wdMongolian

wdNepali

wdNoProofing

wdNorwegianBokmol

wdNorwegianNynorsk

wdOriya

wdPolish

wdPortuguese

wdPunjabi

wdRhaetoRomanic

wdRomanian

wdRomanianMoldova

wdRussian

wdRussianMoldova

wdSamiLappish

wdSanskrit

wdSerbianCyrillic

wdSerbianLatin

wdSesotho

wdSimplifiedChinese

wdSindhi

wdSlovak

wdSlovenian

wdSorbian

wdSpanish

wdSpanishArgentina

wdSpanishBolivia

wdSpanishChile

wdSpanishColombia

wdSpanishCostaRica

wdSpanishDominicanRepublic

wdSpanishEcuador

wdSpanishElSalvador

wdSpanishGuatemala

wdSpanishHonduras

wdSpanishModernSort

wdSpanishNicaragua

wdSpanishPanama

wdSpanishParaguay

wdSpanishPeru

wdSpanishPuertoRico

wdSpanishUruguay

wdSpanishVenezuela

wdSutu

wdSwahili

wdSwedish

wdSwedishFinland

wdSwissFrench

wdSwissGerman

wdSwissItalian

wdTajik

wdTamil

wdTatar

wdTelugu

wdThai

wdTibetan

wdTraditionalChinese

wdTsonga

wdTswana

wdTurkish

wdTurkmen

wdUkrainian

wdUrdu

wdUzbekCyrillic

wdUzbekLatin

wdVenda

wdVietnamese

wdWelsh

wdXhosa

wdZulu

Hinweise

Einige der oben aufgelisteten Konstanten stehen Ihnen möglicherweise nicht zur Verfügung. Dies ist abhängig von der Sprachunterstützung (z. B. Deutsch), die Sie ausgewählt oder installiert haben.


Beispiel zur ActiveWritingStyle-Eigenschaft

In diesem Beispiel wird der Schreibstil für Französisch, Deutsch und Englisch (Nordamerika) für das aktive Dokument gesetzt. Für dieses Beispiel müssen die Grammatikdateien für Französisch, Deutsch und Englisch (Nordamerika) installiert sein.

With ActiveDocument
    .ActiveWritingStyle(wdFrench) = "Commercial"
    .ActiveWritingStyle(wdGerman) = "Technisch/Wiss"
    .ActiveWritingStyle(wdEnglishUS) = "Technical"
End With

In diesem Beispiel wird der Schreibstil für die Sprache in der Auswahl zurückgegeben.

myLang = Selection.LanguageID
MsgBox ActiveDocument.ActiveWritingStyle(myLang)


AddBiDirectionalMarksWhenSavingTextFile-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word adds bidirectional control characters when saving a document as a text file. Read/write Boolean.

Remarks

Saving text files with bidirectional control characters preserves right-to-left and left-to-right properties, and preserves the order of neutral characters.

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur AddBiDirectionalMarksWhenSavingTextFile-Eigenschaft

Sprachspezifische Informationen

This example sets Word to add bidirectional control characters when saving a document as a text file.

Options.AddBiDirectionalMarksWhenSavingTextFile = True


AddControlCharacters-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word adds bidirectional control characters when cutting and copying text. Read/write Boolean.

Remarks

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur AddControlCharacters-Eigenschaft

This example sets Word to add bidirectional control characters when cutting and copying text.

Options.AddControlCharacters = True


AddHebDoubleQuote-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word encloses number formats in double quotation marks ("). Read/write Boolean.

Remarks

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur AddHebDoubleQuote-Eigenschaft

Sprachspezifische Informationen

This example sets Word to enclose number formats in double quotation marks (").

Options.AddHebDoubleQuote = True


AddIns-Eigenschaft

Gibt eine AddIns-Auflistung zurück, die alle verfügbaren Add-Ins darstellt, unabhängig davon, ob diese aktuell geladen sind oder nicht. Die AddIns-Auflistung beinhaltet die globalen Vorlagen und Word-Add-In-Bibliotheken (WLLs), die im Dialogfeld Dokumentenvorlagen und Add-Ins (Menü Extras) aufgelistet sind. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur AddIns-Eigenschaft

In diesem Beispiel wird die Gesamtanzahl der Add-Ins zurückgegeben.

myCount = AddIns.Count

In diesem Beispiel wird der Name jedes Add-Ins in der AddIns-Auflistung angezeigt.

For Each aAddIn In AddIns
    MsgBox aAddIn.Name
Next aAddIn


Address-Eigenschaft

Hyperlink-Objekt: Gibt die Adresse (beispielsweise einen Dateinamen oder URL) des angegebenen Hyperlinks zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Envelope-Objekt: Gibt die Empfängeradresse für Briefumschläge als Range-Objekt zurück. Nur-Lese-Zugriff.

Anmerkung Wenn dem angegebenen Dokument kein Briefumschlag hinzugefügt wurde und Sie diese Eigenschaft verwenden, tritt ein Fehler auf.


AddressFromLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der linken Umschlagkante und der Empfängeradresse zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


Beispiel zur AddressFromLeft-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und ein Umschlag mit einer zuvor definierten Empfänger- und Absenderanschrift hinzugefügt. Das Beispiel legt dann fest, dass der Abstand zwischen der linken Umschlagkante und der Empfängeradresse 9,53 cm beträgt.

addr = "James Allard" & vbCr & "123 Skye St." & vbCr _
    & "Our Town, WA  98004"
retaddr = "Rich Andrews" & vbCr & "123 Main" & vbCr _
    & "Other Town, WA  98004"
With Documents.Add.Envelope
    .Insert Address:=addr, ReturnAddress:=retaddr
    .AddressFromLeft = InchesToPoints(3.75)
End With
ActiveDocument.ActiveWindow.View.Type = wdPrintView


AddressFromTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der oberen Umschlagkante und der Empfängeradresse zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


Beispiel zur AddressFromTop-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und ein Umschlag mit einer zuvor definierten Empfänger- und Absenderanschrift hinzugefügt. Das Beispiel legt dann fest, dass der Abstand zwischen der oberen Umschlagkante und der Empfängeradresse 4,45 cm und zwischen der linken Umschlagkante und der Empfängeradresse 9,53 cm beträgt.

addr = "Michael Bunney" & vbCr & "123 Skye St." & vbCr _
    & "Our Town, WA  98040"
retaddr = "Kate Dresen" & vbCr & "123 Main" & vbCr _
    & "Other Town, WA  98040"
With Documents.Add.Envelope
    .Insert Address:=addr, ReturnAddress:=retaddr
    .AddressFromTop = InchesToPoints(1.75)
    .AddressFromLeft = InchesToPoints(3.75)
End With
ActiveDocument.ActiveWindow.View.Type = wdPrintView


AddressStyle-Eigenschaft

Gibt ein Style-Objekt zurück, das die Formatvorlage für die Empfängeradresse auf dem Briefumschlag darstellt. Nur-Lese-Zugriff.

Hinweis Wenn ein Briefumschlag einem Dokument hinzugefügt wird, dann wird mit der Formatvorlage "Envelope Address" formatierter Text automatisch aktualisiert.


Beispiel zur AddressStyle-Eigenschaft

In diesem Beispiel wird die Formatierung der Schriftart der Formatvorlage "Envelope Address" geändert.

With ActiveDocument.Envelope.AddressStyle.Font
    .Bold = False
    .Name = "Times New Roman"
    .Size = 16
End With


AddSpaceBetweenFarEastAndAlpha-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically add spaces between Japanese and Latin text for the specified paragraphs. This property returns wdUndefined if it’s set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur AddSpaceBetweenFarEastAndAlpha-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically add spaces between Japanese and Latin text for the first paragraph in the active document.

ActiveDocument.Paragraphs(1).AddSpaceBetweenFarEastAndAlpha = True


AddSpaceBetweenFarEastAndDigit-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically add spaces between Japanese text and numbers for the specified paragraphs. This property returns wdUndefined if it’s set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur AddSpaceBetweenFarEastAndDigit-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically add spaces between Japanese text and numbers for the first paragraph in the active document.

ActiveDocument.Paragraphs(1).AddSpaceBetweenFarEastAndDigit = True


Adjustments-Eigenschaft

Gibt ein Adjustments-Objekt zurück, das Anpassungswerte für alle Anpassungen in der angegebenen Form enthält. Betrifft ein Shape- oder ShapeRange-Objekt, das eine AutoForm oder ein WordArt-Objekt darstellt. Nur-Lese-Zugriff.


Beispiel zur Adjustments-Eigenschaft

In diesem Beispiel wird in myDocument der Wert der Anpassung eins der Form drei auf 0,25 festgelegt.

Set myDocument = ActiveDocument
myDocument.Shapes(3).Adjustments(1) = 0.25


Alignment-Eigenschaft

ListLevel-Objekt: Gibt die Ausrichtung für die Listenebene für die Listenvorlage zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdListLevelAlignment-Konstanten handeln: wdListLevelAlignCenter,wdListLevelAlignLeft oder wdListLevelAlignRight. Long Schreib-Lese-Zugriff.

HorizontalLineFormat-Objekt: Gibt die Ausrichtung für die horizontale Linie zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdHorizontalLineAlignment-Konstanten handeln: wdHorizontalLineAlignCenter, wdHorizontalLineAlignLeft oder wdHorizontalLineAlignRight. Long Schreib-Lese-Zugriff.

PageNumber-Objekt: Gibt die Ausrichtung für die Seitenzahl zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdPageNumberAlignment-Konstanten handeln: wdAlignPageNumberCenter, wdAlignPageNumberInside, wdAlignPageNumberLeft, wdAlignPageNumberOutside oder wdAlignPageNumberRight. Long Schreib-Lese-Zugriff.

Paragraph-, Paragraphs- oder ParagraphFormat-Objekt: Gibt die Ausrichtung für die angegebenen Absätze zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdParagraphAlignment-Konstanten handeln: wdAlignParagraphLeft, wdAlignParagraphCenter, wdAlignParagraphDistribute, wdAlignParagraphRight, wdAlignParagraphJustify, wdAlignParagraphJustifyHi, wdAlignParagraphJustifyLow oder wdAlignParagraphJustifyMed. Long Schreib-Lese-Zugriff. Einige der aufgeführten Konstanten sind abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht verfügbar.

Row- oder Rows-Objekt: Gibt die Ausrichtung für die angegebenen Zeilen zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdRowAlignment-Konstanten handeln: wdAlignRowLeft, wdAlignRowCenter oder wdAlignRowRight. Long Schreib-Lese-Zugriff.

TabStop-Objekt: Gibt die Ausrichtung für den angegebenen Tabstopp zurück oder legt sie fest. Hierbei kann es sich um eine der folgenden WdTabAlignment-Konstanten handeln: wdAlignTabBar, wdAlignTabCenter, wdAlignTabDecimal, wdAlignTabLeft, wdAlignTabList oder wdAlignTabRight. Long Schreib-Lese-Zugriff.


Beispiel zur Alignment-Eigenschaft

In diesem Beispiel wird der erste Absatz im aktiven Dokument rechts ausgerichtet.

ActiveDocument.Paragraphs(1).Alignment = _
    wdAlignParagraphRight

In diesem Beispiel werden im aktiven Dokument alle Zeilen der ersten Tabelle zentriert.

ActiveDocument.Tables(1).Rows.Alignment = _
    wdAlignRowCenter

In diesem Beispiel wird der erste Tabstop im ersten Absatz des aktiven Dokuments zentriert.

ActiveDocument.Paragraphs(1).TabStops(1).Alignment = _
    wdAlignTabCenter


AllCaps-Eigenschaft

True, wenn die Schriftart als reine Großbuchstaben-Schriftart formatiert wird. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie AllCaps auf True setzen, wird SmallCaps auf False gesetzt und umgekehrt.


Beispiel zur AllCaps-Eigenschaft

In diesem Beispiel wird der dritte Absatz im aktiven Dokument überprüft, ob er Text mit der Formatierung Großbuchstaben enthält.

If ActiveDocument.Paragraphs(3).Range.Font.AllCaps = True Then
    MsgBox "Text is all caps."
Else
    MsgBox "Text is not all caps."
End if

In diesem Beispiel wird der markierte Text mit Großbuchstaben formatiert.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.AllCaps = True
Else
    MsgBox "You need to select some text."
End If


AllowAccentedUppercase-Eigenschaft

True, wenn Akzente beibehalten werden, wenn ein Buchstabe in einem französischen Text in einen Großbuchstaben umgewandelt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft betrifft nur Text mit der Markierung "Französisch". Bei allen anderen Sprachen werden Akzente immer beibehalten, selbst dann, wenn die AllowAccentedUppercase-Eigenschaft auf False gesetzt wurde.

Wenn Sie ein Zeichen in Kleinbuchstaben zurückverwandeln, nachdem das Akzentzeichen entfernt wurde, dann wird das Akzentzeichen nicht angezeigt.


Beispiel zur AllowAccentedUppercase-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass Akzentzeichen entfernt werden, wenn Zeichen in einem französischen Text in Großbuchstaben umgewandelt werden.

Options.AllowAccentedUppercase = False

In diesem Beispiel wird der Status der Option Großbuchstaben behalten Akzent auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.AllowAccentedUppercase


AllowAutoFit-Eigenschaft

True, wenn Zellen in einer Tabelle von Microsoft Word automatisch auf die Größe ihres Inhalts angepasst werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AllowAutoFit-Eigenschaft

In diesem Beispiel wird die erste Tabelle im aktiven Dokument so eingestellt, dass ihre Größe je nach Inhalt automatisch angepasst wird.

ActiveDocument.Tables(1).AllowAutoFit = True


AllowBreakAcrossPages-Eigenschaft

True, wenn der Text in einer Tabellenzeile oder in mehreren Tabellenzeilen bei einem Seitenwechsel abgetrennt werden darf. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur AllowBreakAcrossPages-Eigenschaft

In diesem Beispiel wird ein neues Dokument mit einer 5x5 Tabelle erstellt und verhindert, dass die dritte Zeile der Tabelle beim Seitenumbruch abgetrennt wird.

Set newDoc = Documents.Add
Set aTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=5, NumColumns:=5)
aTable.Rows(3).AllowBreakAcrossPages = False

In diesem Beispiel wird ermittelt, ob die Zeilen in der aktuellen Tabelle bei einem Seitenumbruch auf zwei Seiten aufgeteilt werden können. Wenn die Einfügemarke nicht in einer Tabelle ist, wird ein Meldungsfeld angezeigt.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Tables.Count = 0 Then
    MsgBox "The insertion point is not in a table."
Else
    allowBreak = Selection.Rows.AllowBreakAcrossPages
End If


AllowClickAndTypeMouse-Eigenschaft

True, wenn Klicken und Eingeben aktiviert ist. Boolean Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über Klicken und Eingeben finden Sie unter Übersicht über Klicken und Eingeben.


Beispiel zur AllowClickAndTypeMouse-Eigenschaft

In diesem Beispiel wird überprüft, ob Klicken und Eingeben aktiviert ist. Ist dies nicht der Fall, wird diese Funktion je nach Wahl des Benutzers eingestellt.

If Options.AllowClickAndTypeMouse = False Then
    x = MsgBox("Do you want to use Click and Type?", _
        vbYesNo)
    If x = vbYes Then
        Options.AllowClickAndTypeMouse = True
        MsgBox "Click and Type enabled!"
    End If
End If


AllowCombinedAuxiliaryForms-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores auxiliary verb forms when checking spelling in a Korean language document. Read/write Boolean.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur AllowCombinedAuxiliaryForms-Eigenschaft

Sprachspezifische Informationen

This example asks the user whether Microsoft Word should ignore auxiliary verb forms when checking spelling in a Korean language document.

If Options.AllowCombinedAuxiliaryForms = False Then
    x = MsgBox("Do you want to ignore auxiliary " _
        & "verb forms when checking spelling?", _
        vbYesNo)
    If x = vbYes Then
        Options.AllowCombinedAuxiliaryForms = True
        MsgBox "Auxiliary verb forms will be ignored!"
    End If
End If


AllowCompoundNounProcessing-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores compound nouns when checking spelling in a Korean language document. Read/write Boolean.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur AllowCompoundNounProcessing-Eigenschaft

Sprachspezifische Informationen

This example asks the user whether Microsoft Word should ignore compound nouns when checking spelling in a Korean language document.

If Options.AllowCompoundNounProcessing = False Then
    x = MsgBox("Do you want to ignore compound " _
        & "nouns when checking spelling?", _
        vbYesNo)
    If x = vbYes Then
        Options.AllowCompoundNounProcessing = True
        MsgBox "Compound nouns will be ignored!"
    End If
End If


AllowDragAndDrop-Eigenschaft

True, wenn durch Drag & Drop eine Markierung verschoben oder kopiert werden kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur AllowDragAndDrop-Eigenschaft

In diesem Beispiel wird die Drag-und-Drop-Bearbeitungsfunktion aktiviert.

Options.AllowDragAndDrop = True

In diesem Beispiel wird der Status der Option Textbearbeitung durch Drag & Drop auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.AllowDragAndDrop


AllowFastSave-Eigenschaft

True, wenn Word nur Änderungen an einem Dokument speichert. Beim erneuten Öffnen des Dokuments benutzt Word die gespeicherten Änderungen, um das Dokument zu rekonstruieren. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die AllowFastSave- und CreateBackup-Eigenschaften können nicht gleichzeitig auf True gesetzt werden.


Beispiel zur AllowFastSave-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass das vollständige Dokument gespeichert wird und dann wird das aktive Dokument gespeichert.

Options.AllowFastSave = False
ActiveDocument.Save

In diesem Beispiel wird der aktuelle Status der Option Schnellspeicherung zulassen auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.AllowFastSave


AllowOverlap-Eigenschaft

Rows-Objekt: Gibt einen Wert zurück, mit dem bestimmt wird, ob die angegebenen Zeilen andere Zeilen überlappen dürfen, oder legt diesen Wert fest. Gibt wdUndefined zurück, wenn sich unter den angegebenen Zeilen sowohl überlappende als auch nicht überlappende Zeilen befinden. Der Wert kann entweder auf True oder False gesetzt werden. Long Schreib-Lese-Zugriff. Durch Einstellen von AllowOverlap auf True wird auch WrapAroundText auf True gesetzt. Durch Einstellen von WrapAroundText auf False wird auch AllowOverlap auf False gesetzt.

WrapFormat-Objekt: Gibt einen Wert zurück, mit dem bestimmt wird, ob eine bestimmte Form andere Formen überlappen darf, oder legt diesen Wert fest. Der Wert kann entweder auf True oder auf False gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweise

Da in HTML keine überlappenden Tabellen oder Formen unterstützt werden, wird AllowOverlap in der Weblayoutansicht ignoriert.


Beispiel zur AllowOverlap-Eigenschaft

In diesem Beispiel wird festgelegt, dass Text um die markierte Tabelle umbrochen wird und die Tabelle keine anderen umbrochenen Tabellen überlappt.

Selection.Rows.WrapAroundText = True
Selection.Rows.AllowOverlap = False

In diesem Beispiel wird festgelegt, dass die erste Form im aktiven Dokument andere Formen überlappen darf.

ActiveDocument.Shapes(1).WrapFormat.AllowOverlap = True


AllowPageBreaks-Eigenschaft

True, wenn innerhalb der angegebenen Tabelle ein Seitenumbruch zugelassen ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur AllowPageBreaks-Eigenschaft

In diesem Beispiel wird die zweite Tabelle im aktiven Dokument so eingestellt, dass ein Seitenumbruch in der Tabelle zugelassen ist.

ActiveDocument.Tables(2).AllowPageBreaks = True


AllowPixelUnits-Eigenschaft

True, wenn in Microsoft Word für HTML-Funktionen, die Maßangaben unterstützen, als Standardmaßeinheit Pixel verwendet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AllowPixelUnits-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Pixel als Standardmaßeinheit für HTML-Funktionen zulässig sind.

Options.AllowPixelUnits = True


AllowPNG-Eigenschaft

True, wenn das Grafikformat PNG (Portable Network Graphics) beim Speichern eines Dokuments als Webseite zugelassen ist. False, wenn PNG nicht als Ausgabeformat zugelassen ist. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Hinweise

Wenn Sie Grafiken im PNG-Format speichern und die von Ihnen in Betracht gezogenen Webbrowser dieses Format unterstützen, können Sie die Bildqualität erhöhen oder die Größe dieser Grafikdateien verringern und so die Ladezeit der Seite verkürzen.


Beispiel zur AllowPNG-Eigenschaft

In diesem Beispiel wird PNG als Ausgabeformat für das aktive Dokument aktiviert.

ActiveDocument.WebOptions.AllowPNG = True

Alternativ hierzu kann PNG für die Anwendung als allgemeiner Standard für neu erstellte Dokumente aktiviert werden.

Application.DefaultWebOptions.AllowPNG = True


 AlternativeText-Eigenschaft

AlternativeText-Eigenschaft

Gibt den auf einer Webseite mit einer Form verbundenen alternativen Text zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur AlternativeText-Eigenschaft

Im folgenden Beispiel wird der alternative Text für die im aktiven Fenster ausgewählte Form festgelegt. Die ausgewählte Form ist die Grafik einer Wildente.

ActiveWindow.Selection.ShapeRange _
    .AlternativeText = "This is a mallard duck."


AlwaysInFront-Eigenschaft

True, wenn Rahmen vor dem Dokumenttext angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AlwaysInFront-Eigenschaft

In diesem Beispiel wird ein grafischer Seitenrahmen vor dem Text im ersten Abschnitt des aktiven Dokuments hinzugefügt.

With ActiveDocument.Sections(1)
    .Borders.AlwaysInFront = True
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtPeople
        aBord.ArtWidth = 15
    Next aBord
End With


AlwaysSaveInDefaultEncoding-Eigenschaft

True, wenn beim Speichern einer Webseite oder eines unformatierten Dokuments unabhängig von der ursprünglichen Codierung beim Öffnen des Dokuments die Standardcodierung verwendet wird. False, wenn die ursprüngliche Codierung des Dokuments verwendet wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Hinweise

Die Encoding-Eigenschaft kann zum Einstellen der Standardcodierung verwendet werden.


Beispiel zur AlwaysSaveInDefaultEncoding-Eigenschaft

In diesem Beispiel wird als Codierung die Standardcodierung eingestellt. Die Codierung wird verwendet, wenn Sie das Dokument als Webseite speichern.

Application.DefaultWebOptions _
    .AlwaysSaveInDefaultEncoding = True


Anchor-Eigenschaft

Gibt ein Range-Objekt zurück, das den Verankerungsbereich für die angegebene Form oder den Formbereich darstellt. Nur-Lese-Zugriff.

Anmerkungen

Alle Shape-Objekte werden zwar mit einem Textbereich verankert, können jedoch an eine beliebige Stelle auf der Seite positioniert werden, die den Anker enthält. Wenn Sie den Verankerungsbereich beim Erstellen der Form angeben, wird der Anker an den Anfang des ersten Absatzes positioniert, der den Verankerungsbereich enthält. Geben Sie keinen Verankerungsbereich an, wird dieser automatisch markiert und die Form wird relativ zur Oberseite und den linken Rändern der Seite positioniert.

Die Form verbleibt immer auf der gleichen Seite wie ihr Anker. Wenn für die LockAnchor-Eigenschaft der Form True gilt, können Sie den Anker nicht aus seiner Position auf der Seite ziehen.

Wenn Sie diese Eigenschaft bei einem ShapeRange-Objekt verwenden, das mehrere Formen enthält, wird ein Fehler erzeugt.


Beispiel zur Anchor-Eigenschaft

Dieses Beispiel markiert den Absatz, mit dem die erste Form im aktiven Dokument verankert ist.

ActiveDocument.Shapes(1).Anchor.Paragraphs(1).Range.Select


Angle-Eigenschaft

Gibt den Winkel der Legendenlinie zurück oder legt ihn fest. Wenn die Legendenlinie mehr als ein Liniensegment enthält, gibt diese Eigenschaft den Winkel des Segments zurück, das am weitesten vom Legendentextfeld entfernt ist, oder legt ihn fest. Dies kann eine der folgenden MsoCalloutAngleType-Konstanten sein: msoCalloutAngle30, msoCalloutAngle45, msoCalloutAngle60, msoCalloutAngle90, msoCalloutAngleAutomatic oder msoCalloutAngleMixed. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie den Wert dieser Eigenschaft auf etwas anderes als msoCalloutAngleAutomatic festlegen, behält die Legendenlinie einen festen Winkel bei, wenn Sie die Legende ziehen.


Beispiel zur Angle-Eigenschaft

In diesem Beispiel wird in myDocument der Legendenwinkel für die Legende "Leg1" auf 90 Grad eingestellt.

Set myDocument = Documents(1)
myDocument.Shapes("co1").Callout.Angle = msoCalloutAngle90


AnimateScreenMovements-Eigenschaft

True, wenn Word Mausbewegungen animiert, animierte Cursor verwendet oder bestimmte Aktionen, z. B. Speichern im Hintergrund oder Operationen zum Suchen und Ersetzen, animiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AnimateScreenMovements-Eigenschaft

In diesem Beispiel wird Word so konfiguriert, dass Bewegungen auf dem Bildschirm animiert werden.

Options.AnimateScreenMovements = True

In diesem Beispiel wird der aktuelle Status der Option Bildschirm-Animation auf der Registerkarte Allgemein im Dialogfeld Optionen (Menü Extras) zurückgegeben.

temp = Options.AnimateScreenMovements


Animation-Eigenschaft

Gibt den der Schriftart zugewiesenen Animationstyp zurück oder legt diesen fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdAnimation-Konstanten handeln:

wdAnimationBlinkingBackground

wdAnimationLasVegasLights

wdAnimationMarchingBlackAnts

wdAnimationMarchingRedAnts

wdAnimationNone

 wdAnimationShimmer

wdAnimationSparkleText


Beispiel zur Animation-Eigenschaft

In diesem Beispiel wird der Text in einem neuen Dokument mit Animationseffekten versehen.

Set newDoc = Documents.Add
With newDoc.Content
    .InsertAfter "This is a test of animation."
    .Font.Animation = wdAnimationLasVegasLights
End With

In diesem Beispiel wird der markierte Text mit Animationseffekten versehen.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Animation = wdAnimationShimmer
Else
    MsgBox "You need to select some text."
End If


AnswerWizard-Eigenschaft

Gibt ein AnswerWizard-Objekt zurück, in dem sich die Dateien für die Suchmaschine der Onlinehilfe befinden. Nur-Lese-Zugriff.


AntonymList-Eigenschaft

Gibt eine Liste von Antonymen für das Wort oder den Ausdruck zurück. Die Liste wird als Zeichenfolge zurückgegeben. Variant Nur-Lese-Zugriff.

Anmerkungen

Die AntonymList-Eigenschaft ist eine Eigenschaft des SynonymInfo-Objekts, das entweder von einem Bereich oder der Anwendung zurückgegeben werden kann. Wenn dieses Objekt von der Anwendung zurückgegeben wird, geben Sie das Wort an, das nachgeschlagen werden soll, und die Sprache, die verwendet werden soll. Wenn das Objekt von einem Bereich zurückgegeben wird, wird der Bereich unter Verwendung der Sprache des Bereichs nachgeschlagen.


Beispiel zur AntonymList-Eigenschaft

In diesem Beispiel wird eine Liste von Antonymen für das Wort "big" in US-Englisch zurückgegeben.

Alist = SynonymInfo(Word:="big", _
    LanguageID:=wdEnglishUS).AntonymList
For i = 1 To UBound(Alist)
    Msgbox Alist(i)
Next i

In diesem Beispiel wird eine Liste von Antonymen für das Wort oder den Ausdruck in der Markierung zurückgegeben und im Direktfenster des Visual Basic Editors angezeigt.

antList = Selection.Range.SynonymInfo.AntonymList
If UBound(antList) <> 0 Then
    For i = 1 To UBound(antList)
        Debug.Print antList(i) & Str(i)
    Next i
Else
    Msgbox "No antonyms were found."
End If

In diesem Beispiel wird für das dritte Wort im aktiven Dokument eine Liste von Antonymen zurückgegeben, wenn es welche gibt.

Set myRange = ActiveDocument.Words(3)
myalist = myRange.SynonymInfo.AntonymList
If Ubound(myalist) = 0 Then
    MsgBox "There are no antonyms for the third word."
Else
    For i = 1 To UBound(myalist)
        Msgbox myalist(i)
    Next I
End If


Application-Eigenschaft

Wird diese Eigenschaft ohne Objektkennzeichner verwendet, gibt sie ein Application-Objekt zurück, das die Microsoft Word-Anwendung darstellt. Wird diese Eigenschaft mit Objektkennzeichner verwendet, gibt sie ein Application-Objekt zurück, das die Anwendung darstellt, mit der das festgelegte Objekt erstellt wurde. (Wenn Sie diese Eigenschaft mit einem OLE-Automation-Objekt verwenden, wird die Anwendung dieses Objekts zurückgegeben). Nur-Lese-Zugriff.

Hinweis Mit den Funktionen CreateObject und GetObject erhalten Sie Zugriff auf ein OLE-Automation-Objekt.


Beispiel zur Application-Eigenschaft

In diesem Beispiel werden Bildlaufleisten, Bildschirmtipps und die Statusleiste für Microsoft Word angezeigt.

With Application
    .DisplayScrollBars = True
    .DisplayScreenTips = True
    .DisplayStatusBar = True
End With

In diesem Beispiel wird der Microsoft Excel-Startpfad eingeblendet, wenn Microsoft Excel aktiv ist.

If Tasks.Exists(Name:="Microsoft Excel") = True Then
    Set myobject = GetObject("", "Excel.Application")
    MsgBox myobject.Application.StartupPath
    Set myobject = Nothing
End If


ApplyFarEastFontsToAscii-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word applies East Asian fonts to Latin text. Read/write Boolean.

Remarks

This property applies only when you have selected an East Asian language for editing. If this property is False and you apply an East Asian font to a specified range, Word will not apply the font to any Latin text in the range.

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur ApplyFarEastFontsToAscii-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to apply East Asian fonts to Latin text.

Options.ApplyFarEastFontsToAscii = True


ArabicMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the mode for the Arabic spelling checker. Read/write Long. Can be one of the following WdAraSpeller constants.

Constant | Description
wdFinalYaa | The spelling checker uses spelling rules regarding Arabic words ending with the letter yaa.
wdInitialAlef | The spelling checker uses spelling rules regarding Arabic words beginning with an alef hamza.
wdBoth | The spelling checker uses spelling rules regarding both Arabic words ending with the letter yaa and Arabic words beginning with an alef hamza.
wdNone | The spelling checker ignores spelling rules regarding either Arabic words ending with the letter yaa or Arabic words beginning with an alef hamza.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ArabicMode-Eigenschaft

Sprachspezifische Informationen

This example sets the spelling checker to ignore spelling rules regarding Arabic words beginning with an alef hamza.

Options.ArabicMode = wdInitialAlef


ArabicNumeral-Eigenschaft

Sprachspezifische Informationen

Returns or sets the numeral style for an Arabic language document. Can be one of the following WdNumeralArabic constants: wdNumeralArabic, wdNumeralContext, wdNumeralHindi, or wdNumeralSystem. Read/write Long.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ArabicNumeral-Eigenschaft

Sprachspezifische Informationen

This example sets the numeral style to Hindi.

Options.ArabicNumeral = wdNumeralHindi


ArtStyle-Eigenschaft

Gibt das Design eines grafischen Seitenrahmens für ein Dokument zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdPageBorderArt-Konstanten handeln:

wdArtApples

wdArtArchedScallops

wdArtBabyPacifier

wdArtBabyRattle

wdArtBalloons3Colors

wdArtBalloonsHotAir

wdArtBasicBlackDashes

wdArtBasicBlackDots

wdArtBasicBlackSquares

wdArtBasicThinLines

wdArtBasicWhiteDashes

wdArtBasicWhiteDots

wdArtBasicWhiteSquares

wdArtBasicWideInline

wdArtBasicWideMidline

wdArtBasicWideOutline

wdArtBats

wdArtBirds

wdArtBirdsFlight

wdArtCabins

wdArtCakeSlice

wdArtCandyCorn

wdArtCelticKnotwork

wdArtCertificateBanner

wdArtChainLink

wdArtChampagneBottle

wdArtCheckedBarBlack

wdArtCheckedBarColor

wdArtCheckered

wdArtChristmasTree

wdArtCirclesLines

wdArtCirclesRectangles

wdArtClassicalWave

wdArtClocks

wdArtCompass

wdArtConfetti

wdArtConfettiGrays

wdArtConfettiOutline

wdArtConfettiStreamers

wdArtConfettiWhite

wdArtCornerTriangles

wdArtCouponCutoutDashes

wdArtCouponCutoutDots

wdArtCrazyMaze

wdArtCreaturesButterfly

wdArtCreaturesFish

wdArtCreaturesInsects

wdArtCreaturesLadyBug

wdArtCrossStitch

wdArtCup

wdArtDecoArch

wdArtDecoArchColor

wdArtDecoBlocks

wdArtDiamondsGray

wdArtDoubleD

wdArtDoubleDiamonds

wdArtEarth1

wdArtEarth2

wdArtEclipsingSquares1

wdArtEclipsingSquares2

wdArtEggsBlack

wdArtFans

wdArtFilm

wdArtFirecrackers

wdArtFlowersBlockPrint

wdArtFlowersDaisies

wdArtFlowersModern1

wdArtFlowersModern2

wdArtFlowersPansy

wdArtFlowersRedRose

wdArtFlowersRoses

wdArtFlowersTeacup

wdArtFlowersTiny

wdArtGäms

wdArtGingerbreadMan

wdArtGradient

wdArtHandmade1

wdArtHandmade2

wdArtHeartBalloon

wdArtHeartGray

wdArtHearts

wdArtHeebieJeebies

 wdArtHolly

wdArtHouseFunky

wdArtHypnotic

wdArtIceCreamCones

wdArtLightBulb

wdArtLightning1

wdArtLightning2

wdArtMapleLeaf

wdArtMapleMuffins

wdArtMapPins

wdArtMarquee

wdArtMarqueeToothed

wdArtMoons

wdArtMosaic

wdArtMusicNotes

wdArtNorthwest

wdArtOvals

wdArtPackages

wdArtPalmsBlack

wdArtPalmsColor

wdArtPaperClips

wdArtPapyrus

wdArtPartyFavor

wdArtPartyGlass

wdArtPencils

wdArtPeople

wdArtPeopleHats

wdArtPeopleWaving

wdArtPoinsettias

wdArtPostageStamp

wdArtPumpkin1

wdArtPushPinNote1

wdArtPushPinNote2

wdArtPyramids

wdArtPyramidsAbove

wdArtQuadrants

wdArtRings

wdArtSafari

wdArtSawtooth

wdArtSawtoothGray

wdArtScaredCat

wdArtSeattle

wdArtShadowedSquares

wdArtSharksTeeth

wdArtShorebirdTracks

wdArtSkyrocket

wdArtSnowflakeFancy

wdArtSnowflakes

wdArtSombrero

wdArtSouthwest

wdArtStars

wdArtStars3D

wdArtStarsBlack

wdArtStarsShadowed

wdArtStarsTop

wdArtSun

wdArtSwirligig

wdArtTornPaper

wdArtTornPaperBlack

wdArtTrees

wdArtTriangleParty

wdArtTriangles

wdArtTribal1

wdArtTribal2

wdArtTribal3

wdArtTribal4

wdArtTribal5

wdArtTribal6

wdArtTwistedLines1

wdArtTwistedLines2

wdArtVine

wdArtWaveline

wdArtWeavingAngles

wdArtWeavingBraid

wdArtWeavingRibbon

wdArtWeavingStrips

wdArtWhiteFlowers

wdArtWoodwork

wdArtXIllusions

wdArtZanyTriangles

wdArtZigZag

wdArtZigZagStitch


Beispiel zur ArtStyle-Eigenschaft

In diesem Beispiel wird ein Rahmen aus schwarzen Punkten um jede Seite im ersten Abschnitt der Auswahl hinzugefügt.

For Each aBorder In Selection.Sections(1).Borders
    aBorder.ArtStyle = wdArtBasicBlackDots
    aBorder.ArtWidth = 6
Next aBorder

In diesem Beispiel wird ein Grafikrahmen um alle Seiten in Abschnitt 1 im aktiven Dokument hinzugefügt.

With ActiveDocument.Sections(1)
    .Borders.AlwaysInFront = True
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtPeople
        aBord.ArtWidth = 15
    Next aBord
End With


ArtWidth-Eigenschaft

Gibt die Breite (in Punkt) des angegebenen grafischen Seitenrahmens zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur ArtWidth-Eigenschaft

In diesem Beispiel wird ein 6 Punkt breiter gepunkteter Rahmen um alle Seiten im ersten Abschnitt der Auswahl hinzugefügt.

For Each aBorder In Selection.Sections(1).Borders
    aBorder.ArtStyle = wdArtBasicBlackDots
    aBorder.ArtWidth = 6
Next aBorder


Assistant-Eigenschaft

Gibt ein Assistant-Objekt, das einen Office-Assistenten darstellt, zurück. Nur-Lese-Zugriff.


Beispiel zur Assistant-Eigenschaft

In diesem Beispiel wird der Office-Assistent angezeigt.

Assistant.Visible = True

In diesem Beispiel wird der Office-Assistent angezeigt und auf dem Bildschirm nach links oben bewegt.

With Assistant
    .Visible = True
    .Move xLeft:=100, yTop:=100
End With

In diesem Beispiel wird der Office-Assistent mit einer benutzerdefinierten Nachricht in einer Sprechblase angezeigt.

With Assistant
    .Visible = True
    Set bln = .NewBalloon
    With bln
        .Mode = msoModeAutoDown
        .Text = "Hello"
        .Button = msoButtonSetNone
        .Show
    End With
End With


AttachedTemplate-Eigenschaft

Gibt ein Template-Objekt zurück, das die dem angegebenen Dokument zugeordnete Dokumentvorlage darstellt. Um diese Eigenschaft festzulegen, geben Sie entweder den Namen der Dokumentvorlage oder einen Ausdruck an, der ein Template-Objekt zurückgibt. Variant Schreib-Lese-Zugriff.


Beispiel zur AttachedTemplate-Eigenschaft

In diesem Beispiel wird der Name und Pfad der Dokumentvorlage angezeigt, die dem aktiven Dokument zugeordnet ist.

Set myTemplate = ActiveDocument.AttachedTemplate
MsgBox myTemplate.Path & Application.PathSeparator _
    & myTemplate.Name

In diesem Beispiel wird der Inhalt der Sammlung (ein integrierter AutoText-Eintrag) am Anfang des ersten Dokuments eingefügt.

Set myRange = Documents(1).Range(0, 0)
Documents(1).AttachedTemplate.AutoTextEntries("Spike") _
    .Insert myRange

In diesem Beispiel wird die Dokumentvorlage "Letter.dot" dem aktiven Dokument zugeordnet.

ActiveDocument.AttachedTemplate = "C:\Templates\Letter.dot"


AttentionLine-Eigenschaft

Gibt den Text für die Zeile "attention" eines Briefes, der vom Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur AttentionLine-Eigenschaft

In diesem Beispiel werden die Elemente des Brief-Assistenten aus dem aktiven Dokument geladen. Wenn die Zeile "attention" nicht leer ist, wird in diesem Beispiel der Text in einem Meldungsfeld angezeigt.

If ActiveDocument.GetLetterContent.AttentionLine <> "" Then
    MsgBox ActiveDocument.GetLetterContent.AttentionLine
End If

In diesem Beispiel werden die Elemente des Brief-Assistenten aus dem aktiven Dokument geladen, der Text in der Zeile "attention" wird geändert und anschließend das Dokument mit der SetLetterContent-Methode aktualisiert, damit die Änderungen wiedergegeben werden.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.AttentionLine = "Greetings"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


Author-Eigenschaft

Comment-Objekt: Gibt den Autornamen für einen Kommentar zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Revision-Objekt: Gibt den Namen des Benutzers zurück, der die angegebene Überarbeitung gemacht hat. String Nur-Lese-Zugriff.

Hinweise

Wenn Sie den Namen des Autors für einen Kommentar ändern, wird auch der Autor aller anderen Kommentare des Dokuments geändert.


Beispiel zur Author-Eigenschaft

In diesem Beispiel werden der Autorname und die Initialen für den ersten Kommentar im aktiven Dokument festgelegt.

If ActiveDocument.Comments.Count >= 1 Then
    With ActiveDocument.Comments(1)
        .Author = "Joe Smith"
        .Initial = "JAS"
    End With
End If

In diesem Beispiel wird der Autorname für den ersten Kommentar in der Markierung zurückgegeben.

If Selection.Comments.Count >= 1 Then _
    aAuthor = Selection.Comments(1).Author

In diesem Beispiel wird der Autorname für die erste Überarbeitung im ersten markierten Abschnitt angezeigt.

Set myRange = Selection.Sections(1).Range
MsgBox "Revisions made by " & myRange.Revisions(1).Author


AutoAdjustRightIndent-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically adjust the right indent for the specified paragraphs if you’ve specified a set number of characters per line. Returns wdUndefined if the AutoAdjustRightIndent property is set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur AutoAdjustRightIndent-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically adjust the right indent for the selected paragraphs if you’ve specified a set number of characters per line.

With Selection.ParagraphFormat
    .AutoAdjustRightIndent = True
End With


AutoAttach-Eigenschaft

True, wenn die Stelle, an der die Legendenlinie am Legendentextfeld ansetzt, sich in Abhängigkeit davon ändert, ob der Ursprung der Legendenlinie (auf den die Legende hinweist) sich links oder rechts vom Legendentextfeld befindet. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn der Wert dieser Eigenschaft True ist, wird der Ansatzwert (der vertikale Abstand der Kante des Legendentextfelds von der Stelle, an der die Legendenlinie ansetzt) von der oberen Kante des Textfelds gemessen, wenn sich das Textfeld rechts vom Ursprung befindet, und er wird von der unteren Kante des Textfelds gemessen, wenn sich das Textfeld links vom Ursprung befindet. Wenn der Wert dieser Eigenschaft False ist, wird der Ansatzwert immer von der oberen Kante des Textfelds gemessen, unabhängig von den relativen Positionen des Textfelds und des Ursprungs. Verwenden Sie die CustomDrop-Methode zum Festlegen des Ansatzwerts, und verwenden Sie die Drop-Eigenschaft zum Zurückgeben des Ansatzwerts.

Das Festlegen dieser Eigenschaft hat nur dann Auswirkungen auf eine Legende, wenn diese einen explizit festgelegten Ansatzwert hat, das heißt, wenn der Wert der DropType-Eigenschaft msoCalloutDropCustom ist. Legenden haben standardmäßig explizit festgelegte Ansatzwerte, wenn sie erstellt werden.


Beispiel zur AutoAttach-Eigenschaft

In diesem Beispiel werden zu myDocument zwei Legenden hinzugefügt. Wenn Sie für jede dieser Legenden das Textfeld vom Ursprung der Legendenlinie nach links ziehen, wird sich die Stelle auf dem Textfeld, an der die Legendenlinie ansetzt, für die automatisch verbundene Legende ändern.

Set myDocument = ActiveDocument
With myDocument.Shapes
    With .AddCallout(msoCalloutTwo, 100, 170, 200, 50)
        .TextFrame.TextRange.Text = "auto-attached"
        .Callout.AutoAttach = True
    End With
    With .AddCallout(msoCalloutTwo, 100, 350, 200, 50)
        .TextFrame.TextRange.Text = "not auto-attached"
        .Callout.AutoAttach = False
    End With
End With


AutoCaptions-Eigenschaft

Gibt eine AutoCaptions-Auflistung zurück, die die Beschriftungen darstellt, die automatisch beim Einfügen von Elementen, z. B. Tabellen und Bildern, hinzugefügt werden. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur AutoCaptions-Eigenschaft

In diesem Beispiel werden die Namen aller Elemente angezeigt, die automatisch beim Einfügen in das Dokument mit einer Beschriftung versehen werden.

For Each aCaption In AutoCaptions
    If aCaption.AutoInsert Then MsgBox aCaption.Name
Next aCaption


AutoCorrect-Eigenschaft

Gibt ein AutoCorrect-Objekt zurück, das die aktuellen AutoKorrektur-Optionen, Einträge und Ausnahmen enthält. Nur-Lese-Zugriff.


Beispiel zur AutoCorrect-Eigenschaft

In diesem Beispiel wird ein AutoKorrektur-Ersetzungseintrag hinzugefügt. Nach Ausführung dieses Codes werden alle Instanzen von "sr" in einem Dokument automatisch durch "Silvia Richter" ersetzt.

AutoCorrect.Entries.Add Name:= "sr", Value:= "Stella Richards"

Dieses Beispiel löscht den angegebenen AutoKorrektur-Eintrag, falls einer gefunden wird.

myValue = InputBox("Enter the AutoCorrect entry to delete.")
For Each anEntry in AutoCorrect.Entries
    If anEntry.Name = myValue Then
        myMatch = True
        myConfirm = MsgBox("Are you sure you want to delete " & _
            anEntry.Name, 4)
        If myConfirm = vbYes Then
            anEntry.Delete
        End If
    End If
Next anEntry
If myMatch <> True Then
    MsgBox "There was no AutoCorrect entry: " & myValue
End If


AutoFormatApplyBulletedLists-Eigenschaft

True, wenn Zeichen (wie Sternchen, Bindestriche und Größer-als-Zeichen) am Anfang von Listenabsätzen durch Aufzählungszeichen aus dem Dialogfeld Nummerierung und Aufzählungen (Menü Format) ersetzt werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatApplyBulletedLists-Eigenschaft

In diesem Beispiel werden in der aktuellen Markierung alle Zeichen, die am Anfang von Listenabsätzen verwendet werden, durch Aufzählungszeichen ersetzt.

Options.AutoFormatApplyBulletedLists = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Automatische Aufzählung auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatApplyBulletedLists


AutoFormatApplyFirstIndents-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word replaces a space entered at the beginning of a paragraph with a first-line indent when Word formats a document or range automatically. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatApplyFirstIndents-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to replace a space entered at the beginning of a paragraph with a first-line indent and automatically formats the selected range.

Options.AutoFormatApplyFirstIndents = True
Selection.Range.AutoFormat


AutoFormatApplyHeadings-Eigenschaft

True, wenn den Überschriften automatisch Formatvorlagen zugewiesen werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatApplyHeadings-Eigenschaft

In diesem Beispiel werden den Überschriften in der aktuellen Markierung die Formatvorlagen Überschrift 1 bis Überschrift 9 zugewiesen.

Options.AutoFormatApplyHeadings = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Überschriften auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatApplyHeadings


AutoFormatApplyLists-Eigenschaft

True, wenn den Listen automatisch Formatvorlagen zugewiesen werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatApplyLists-Eigenschaft

In diesem Beispiel werden allen Listen in der aktuellen Markierung Formatvorlagen zugewiesen.

Options.AutoFormatApplyLists = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Listen auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatApplyLists


AutoFormatApplyOtherParas-Eigenschaft

True, wenn den Absätzen, die keine Überschriften oder Listenelemente sind, automatisch Formatvorlagen zugewiesen werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatApplyOtherParas-Eigenschaft

In diesem Beispiel werden den Absätzen in der aktuellen Markierung automatisch Formatvorlagen zugewiesen.

Options.AutoFormatApplyOtherParas = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Anderen Absätzen auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatApplyOtherParas


AutoFormatAsYouTypeApplyBorders-Eigenschaft

True, wenn eine Folge von drei oder mehr Bindestrichen (-), Gleichheitszeichen (=) oder Unterstreichungszeichen (_) automatisch durch eine bestimmte Rahmenlinie ersetzt wird, wenn die EINGABETASTE gedrückt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bindestriche (-) werden durch eine 0,75-Punkt-Linie ersetzt, Gleichheitszeichen (=) werden durch eine 0,75-Punkt-Doppellinie ersetzt, und Unterstreichungszeichen (_) werden durch eine 1,5-Punkt-Linie ersetzt.


Beispiel zur AutoFormatAsYouTypeApplyBorders-Eigenschaft

In diesem Beispiel werden Folgen von drei oder mehr Bindestrichen (-), Gleichheitszeichen (=) oder Unterstreichungszeichen (_) in Rahmenlinien umgewandelt.

Options.AutoFormatAsYouTypeApplyBorders = True

In diesem Beispiel wird die aktuelle Einstellung für die Option Rahmen auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

MsgBox Options.AutoFormatAsYouTypeApplyBorders


AutoFormatAsYouTypeApplyBulletedLists-Eigenschaft

True, wenn Aufzählungszeichen (wie Sternchen, Bindestriche und Größer-als-Zeichen) während der Eingabe durch Aufzählungszeichen aus dem Dialogfeld Nummerierung und Aufzählungen (Menü Format) ersetzt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeApplyBulletedLists-Eigenschaft

In diesem Beispiel werden Zeichen durch Aufzählungszeichen ersetzt, wenn sie in eine Liste eingegeben werden.

Options.AutoFormatAsYouTypeApplyBulletedLists = True

In diesem Beispiel wird der Status der Option Automatische Aufzählung auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeApplyBulletedLists


AutoFormatAsYouTypeApplyClosings-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically apply the Closing style to letter closings as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeApplyClosings-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically apply the Closing style to letter closings as you type.

Options.AutoFormatAsYouTypeApplyClosings = True


AutoFormatAsYouTypeApplyDates-Eigenschaft

Sprachspezifische Informationen

True if if Microsoft Word is set to automatically apply the Date style to dates as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeApplyDates-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically apply the Date style to dates as you type.

Options.AutoFormatAsYouTypeApplyDates = True


AutoFormatAsYouTypeApplyFirstIndents-Eigenschaft

Sprachspezifische Informationen

True if if Microsoft Word is set to automatically replace a space entered at the beginning of a paragraph with a first-line indent as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeApplyFirstIndents-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically replace a space entered at the beginning of a paragraph with a first-line indent as you type.

Options.AutoFormatAsYouTypeApplyFirstIndents = True


AutoFormatAsYouTypeApplyHeadings-Eigenschaft

True, wenn während der Eingabe den Überschriften automatisch Formatvorlagen zugewiesen werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeApplyHeadings-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass während der Eingabe den Überschriften die Formatvorlagen Überschrift 1 bis Überschrift 9 automatisch zugewiesen werden.

Options.AutoFormatAsYouTypeApplyHeadings = True

In diesem Beispiel wird der Status der Option Überschriften auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeApplyHeadings


AutoFormatAsYouTypeApplyNumberedLists-Eigenschaft

True, wenn Absätze automatisch als Listen mit Nummerierungen mit einem Nummerierungsschema aus dem Dialogfeld Nummerierung und Aufzählungen (Menü Format) formatiert werden, je nachdem, was eingegeben wird. Wenn beispielsweise ein Absatz mit "1.1" und einem Tabstoppzeichen anfängt, fügt Word automatisch "1.2" und ein Tabstoppzeichen ein, nachdem die EINGABETASTE gedrückt wurde. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeApplyNumberedLists-Eigenschaft

In diesem Beispiel werden Listen während der Eingabe automatisch nummeriert.

Options.AutoFormatAsYouTypeApplyNumberedLists = True

In diesem Beispiel wird der Status der Option Automatische Nummerierung auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeApplyNumberedLists


AutoFormatAsYouTypeApplyTables-Eigenschaft

True, wenn Word automatisch eine Tabelle erstellt, wenn Sie ein Pluszeichen, mehrere Bindestriche, ein weiteres Pluszeichen usw. eingeben und dann die EINGABETASTE drücken. Die Pluszeichen werden zu Spaltenrändern, und die Bindestriche bestimmen die Spaltenbreite. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeApplyTables-Eigenschaft

In diesem Beispiel wird Word so konfiguriert, dass Tabellen automatisch bei der Eingabe erstellt werden.

Options.AutoFormatAsYouTypeApplyTables = True

In diesem Beispiel wird der Status der Option Tabellen auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeApplyTables


AutoFormatAsYouTypeAutoLetterWizard-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically start the Letter Wizard when the user enters a letter salutation or closing. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeAutoLetterWizard-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically start the Letter Wizard when the user enters a letter salutation or closing.

Options.AutoFormatAsYouTypeAutoLetterWizard = True


AutoFormatAsYouTypeDefineStyles-Eigenschaft

True, wenn Word auf der Basis der manuellen Formatierung automatisch neue Formatvorlagen erstellt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeDefineStyles-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es während der Eingabe automatisch Formatvorlagen erstellt.

Options.AutoFormatAsYouTypeDefineStyles = True

In diesem Beispiel wird der Status der Option Formatvorlagen basierend auf Formatierung definieren auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeDefineStyles


AutoFormatAsYouTypeDeleteAutoSpaces-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically delete spaces inserted between Japanese and Latin text as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeDeleteAutoSpaces-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically delete spaces inserted between Japanese and Latin text as you type.

Options.AutoFormatAsYouTypeDeleteAutoSpaces = True


AutoFormatAsYouTypeFormatListItemBeginning-Eigenschaft

True, wenn Word die Zeichenformatierung, die dem Anfang eines Listenelements zugewiesen wurde, bei dem nächsten Listenelement wiederholt. Boolean Schreib-Lese-Zugriff.


AutoFormatAsYouTypeFormatListItemBeginning Beispiel

In diesem Beispiel wird Word so konfiguriert, dass Zeichenformatierungen am Anfang von Listenelementen automatisch wiederholt zugewiesen werden.

Options.AutoFormatAsYouTypeFormatListItemBeginning = True

In diesem Beispiel wird der Status der Option Listeneintrag wie vorherigen formatieren auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeFormatListItemBeginning


AutoFormatAsYouTypeInsertClosings-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically insert the corresponding memo closing when the user enters a memo heading. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeInsertClosings-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically insert the corresponding memo closing when the user enters a memo heading.

Options.AutoFormatAsYouTypeInsertClosings = True


AutoFormatAsYouTypeInsertOvers-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically insert " ijou ijou " when the user enters " ki " or " an ". Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeInsertOvers-Eigenschaft

Sprachspezifische Informationen

In diesem Beispiel wird Microsoft Word so eingestellt, dass bei der Eingabe von " ki " oder " an " automatisch " ijou ijou " eingesetzt wird.

Options.AutoFormatAsYouTypeInsertOvers = True


AutoFormatAsYouTypeMatchParentheses-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically correct improperly paired parentheses as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeMatchParentheses-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically correct improperly paired parentheses as you type.

Options.AutoFormatAsYouTypeMatchParentheses = True


AutoFormatAsYouTypeReplaceFarEastDashes-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically correct long vowel sounds and dash use as you type. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatAsYouTypeReplaceFarEastDashes-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically correct long vowel sounds and dash use as you type.

Options.AutoFormatAsYouTypeReplaceFarEastDashes = True


AutoFormatAsYouTypeReplaceFractions-Eigenschaft

True, wenn während der Eingabe eingegebene Brüche durch Brüche des aktuellen Zeichensatzes ersetzt werden. Beispielsweise wird "1/2" durch "½" ersetzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeReplaceFractions-Eigenschaft

In diesem Beispiel wird die automatische Ersetzung eingegebener Brüche ausgeschaltet.

Options.AutoFormatAsYouTypeReplaceFractions = False

In diesem Beispiel wird der Status der Option Brüche (1/2) durch Sonderzeichen (½) auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeReplaceFractions


AutoFormatAsYouTypeReplaceHyperlinks-Eigenschaft

True, wenn E-Mail-Adressen, Server- und Freigabenamen (auch UNC-Pfade genannt) und Internet-Adressen (auch URLs genannt) automatisch bei der Eingabe in Hyperlinks umgewandelt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Word wandelt alle Textstellen, die wie E-Mail-Adressen, UNC oder URL aussehen, in Hyperlinks um. Word überprüft nicht die Gültigkeit von Hyperlinks.


Beispiel zur AutoFormatAsYouTypeReplaceHyperlinks-Eigenschaft

In diesem Beispiel wird aktiviert, dass Word automatisch alle Internet- oder Netzwerkpfade bei der Eingabe der Pfadangaben in Hyperlinks umwandelt.

Options.AutoFormatAsYouTypeReplaceHyperlinks = True

In diesem Beispiel wird der Status der Option Internet und Netzwerkangaben durch Hyperlinks auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeReplaceHyperlinks


AutoFormatAsYouTypeReplaceOrdinals-Eigenschaft

True, wenn während der Eingabe die Ordnungszahlsuffixe "st", "nd", "rd" und "th" durch dieselben hochgestellten Buchstaben ersetzt werden. Beispielsweise wird "1st" durch "1" und ein hochgestelltes "st" ersetzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeReplaceOrdinals-Eigenschaft

In diesem Beispiel wird die automatische Ersetzung von Ordnungszahlen durch hochgestellte Buchstaben eingeschaltet.

Options.AutoFormatAsYouTypeReplaceOrdinals = True

In diesem Beispiel wird der Status der Option Englische Ordnungszahlen (1st) hochstellen auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeReplaceOrdinals


AutoFormatAsYouTypeReplacePlainTextEmphasis-Eigenschaft

True, wenn während der Eingabe die manuelle Hervorhebung von Zeichen automatisch durch Zeichenformatierung ersetzt wird. Beispielsweise wird "*fett*" in "fett" geändert und "_unterstreichen_" in "unterstreichen". Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeReplacePlainTextEmphasis-Eigenschaft

In diesem Beispiel wird die Ersetzung der manuellen Hervorhebung von Zeichen durch Zeichenformatierung eingeschaltet.

Options.AutoFormatAsYouTypeReplacePlainTextEmphasis = True

In diesem Beispiel wird der Status der Option *Fett* und _unterstrichten_ durch Formatierung auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeReplacePlainTextEmphasis


AutoFormatAsYouTypeReplaceQuotes-Eigenschaft

True, wenn während der Eingabe gerade Anführungszeichen automatisch in typographische Anführungszeichen umgewandelt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatAsYouTypeReplaceQuotes-Eigenschaft

In diesem Beispiel wird die automatische Ersetzung während der Eingabe von geraden Anführungszeichen durch typographische Anführungszeichen eingeschaltet.

Options.AutoFormatAsYouTypeReplaceQuotes = True

In diesem Beispiel wird der Status der Option Gerade Anführungszeichen durch typographische auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceQuotes


AutoFormatAsYouTypeReplaceSymbols-Eigenschaft

True, wenn zwei fortlaufende Bindestriche (--) während des Schreibens durch einen Gedankenstrich (–) oder einen langen Gedankenstrich (—) ersetzt werden. Boolean Schreib-Lese-Zugriff.

Hinweis Wenn Sie die Bindestriche mit vorangehenden und nachstehenden Leerzeichen eingeben, ersetzt Word die Bindestriche durch einen Gedankenstrich; ohne nachstehende Leerzeichen werden die Bindestriche durch einen langen Gedankenstrich ersetzt.


Beispiel zur AutoFormatAsYouTypeReplaceSymbols-Eigenschaft

In diesem Beispiel wird der Austausch von Bindestrichen durch Symbole während der Eingabe aktiviert.

Options.AutoFormatAsYouTypeReplaceSymbols = True

In diesem Beispiel wird der Status der Option Konzept-Symbole (--) durch formatierte (—) auf der Registerkarte AutoFormat während der Eingabe im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatAsYouTypeReplaceSymbols


AutoFormatDeleteAutoSpaces-Eigenschaft

Sprachspezifische Informationen

True if spaces inserted between Japanese and Latin text will be deleted when Microsoft Word formats a document or range automatically. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatDeleteAutoSpaces-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically delete spaces between Japanese and Latin text, and then it formats the current selection.

Options.AutoFormatDeleteAutoSpaces = True
Selection.Range.AutoFormat


AutoFormatMatchParentheses-Eigenschaft

Sprachspezifische Informationen

True if improperly paired parentheses are corrected when Microsoft Word formats a document or range automatically. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatMatchParentheses-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically correct pairs of parentheses, and then it formats the current selection.

Options.AutoFormatMatchParentheses = True
Selection.Range.AutoFormat


AutoFormatPlainTextWordMail-Eigenschaft

True, wenn Word E-Mail-Nachrichten mit unformatiertem Text automatisch formatiert, sobald sie in Word geöffnet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatPlainTextWordMail-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass E-Mail-Nachrichten mit unformatiertem Text beim Öffen automatisch formatiert werden.

Options.AutoFormatPlainTextWordMail = True

In diesem Beispiel wird der Status der Option WordMail-Dokumente im Textformat auf der Registerkarte AutoFormat des Dialogfeldes AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatPlainTextWordMail


AutoFormatPreserveStyles-Eigenschaft

True, wenn früher zugewiesene Formatvorlagen erhalten bleiben, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatPreserveStyles-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es, wenn es automatisch formatiert, vorhandene Formatvorlagen erhält und Überschriften, Listen und andere Absätze mit Formatvorlagen formatiert. Word formatiert dann automatisch die aktuelle Markierung.

With Options
    .AutoFormatPreserveStyles = True
    .AutoFormatApplyHeadings = True
    .AutoFormatApplyLists = True
    .AutoFormatApplyOtherParas = True
End With
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Formatvorlagen auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatPreserveStyles


AutoFormatReplaceFarEastDashes-Eigenschaft

Sprachspezifische Informationen

True if long vowel sound and dash use is corrected when Microsoft Word formats a document or range automatically. Read/write Boolean.

Remarks

For more information on Japanese AutoFormat options, see AutoFormat options for Japanese text.


Beispiel zur AutoFormatReplaceFarEastDashes-Eigenschaft

This example sets Microsoft Word to automatically correct the use of long vowel sounds and dashes, and then it formats the current selection.

Options.AutoFormatReplaceFarEastDashes = True
Selection.Range.AutoFormat


AutoFormatReplaceFractions-Eigenschaft

True, wenn eingegebene Brüche durch Brüche aus dem aktuellen Zeichensatz ersetzt werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Beispielsweise wird "1/2" durch "½" ersetzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatReplaceFractions-Eigenschaft

In diesem Beispiel wird die Ersetzung von eingegebenen Brüchen eingeschaltet, und anschließend wird die aktuelle Markierung automatisch formatiert.

Options.AutoFormatReplaceFractions = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Brüche (1/2) durch Sonderzeichen (½) auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceFractions


AutoFormatReplaceHyperlinks-Eigenschaft

True, wenn E-Mail-Adressen, Server- und Freigabenamen auch (UNC-Pfade genannt) und Internet-Adressen (auch URLs genannt) automatisch formatiert werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Word wandelt alle Textstellen, die wie E-Mail-Adressen, UNC oder URL aussehen, in Hyperlinks um. Word überprüft nicht die Gültigkeit von Hyperlinks.


Beispiel zur AutoFormatReplaceHyperlinks-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass automatisch alle Internet- oder Netzwerkpfade durch Hyperlinks ersetzt werden. Dann wird die Auswahl automatisch formatiert.

Options.AutoFormatReplaceHyperlinks = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Internet und Netzwerkangaben durch Hyperlinks auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceHyperlinks


AutoFormatReplaceOrdinals-Eigenschaft

True, wenn die Ordnungszahlsuffixe "st", "nd", "rd" und "th" durch dieselben hochgestellten Buchstaben ersetzt werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Beispielsweise wird "1st" durch "1", gefolgt von einem hochgestellten "st" ersetzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatReplaceOrdinals-Eigenschaft

In diesem Beispiel wird die automatische Ersetzung von Ordnungszahlen durch hochgestellte Zeichen eingeschaltet, und anschließend wird die aktuelle Markierung automatisch formatiert.

Options.AutoFormatReplaceOrdinals = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Englische Ordnungszahlen (1st) hochstellen auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceOrdinals


AutoFormatReplacePlainTextEmphasis-Eigenschaft

True, wenn die manuelle Hervorhebung von Zeichen durch Zeichenformatierung ersetzt wird, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Beispielsweise wird "*fett*" in "fett" geändert und "_unterstreichen_" in "unterstreichen". Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatReplacePlainTextEmphasis-Eigenschaft

In diesem Beispiel wird die Ersetzung der manuellen Hervorhebung von Zeichen durch Zeichenformatierung eingeschaltet

Options.AutoFormatReplacePlainTextEmphasis = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option *Fett* und _unterstrichen_ durch Formatierung auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplacePlainTextEmphasis


AutoFormatReplaceQuotes-Eigenschaft

True, wenn gerade Anführungszeichen automatisch in typographische Anführungszeichen geändert werden, wenn Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatReplaceQuotes-Eigenschaft

In diesem Beispiel wird die automatische Ersetzung gerader Anführungszeichen durch typographische Anführungszeichen eingeschaltet, und anschließend wird die aktuelle Markierung automatisch formatiert.

Options.AutoFormatReplaceQuotes = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Gerade Anführungszeichen durch typographische auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceQuotes


AutoFormatReplaceSymbols-Eigenschaft

True, wenn zwei fortlaufende Bindestriche (--) durch einen Gedankenstrich (–) oder einen langen Gedankenstrich (—) ersetzt werden, sobald Word ein Dokument oder einen Bereich automatisch formatiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoFormatReplaceSymbols-Eigenschaft

In diesem Beispiel wird der Austausch von Bindestrichen durch Symbole aktiviert und dann die aktuelle Auswahl automatisch formatiert.

Options.AutoFormatReplaceSymbols = True
Selection.Range.AutoFormat

In diesem Beispiel wird der Status der Option Konzept-Symbole (--) durch formatierte (—) auf der Registerkarte AutoFormat im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Options.AutoFormatReplaceSymbols


AutoFormatType-Eigenschaft

Gibt die Art der automatischen Formatierung zurück, die auf die angegebene Tabelle angewendet wurde. Long Nur-Lese-Zugriff.

Es kann sich um eine der folgenden WdTableFormat-Konstanten handeln:

wdTableFormat3DEffects1

wdTableFormat3DEffects2

wdTableFormat3DEffects3

wdTableFormatClassic1

wdTableFormatClassic2

wdTableFormatClassic3

wdTableFormatClassic4

wdTableFormatColorful1

wdTableFormatColorful2

wdTableFormatColorful3

wdTableFormatColumns1

wdTableFormatColumns2

wdTableFormatColumns3

wdTableFormatColumns4

wdTableFormatColumns5

wdTableFormatContemporary

wdTableFormatElegant

wdTableFormatGrid1

wdTableFormatGrid2

wdTableFormatGrid3

wdTableFormatGrid4

wdTableFormatGrid5

 wdTableFormatGrid6

wdTableFormatGrid7

wdTableFormatGrid8

wdTableFormatList1

wdTableFormatList2

wdTableFormatList3

wdTableFormatList4

wdTableFormatList5

wdTableFormatList6

wdTableFormatList7

wdTableFormatList8

wdTableFormatNone

wdTableFormatProfessional

wdTableFormatSimple1

wdTableFormatSimple2

wdTableFormatSimple3

wdTableFormatSubtle1

wdTableFormatSubtle2

wdTableFormatWeb1

wdTableFormatWeb2

wdTableFormatWeb3

Anmerkung Verwenden Sie die AutoFormat-Methode, um die automatische Formatierung auf eine Tabelle anzuwenden.


Beispiel zur AutoFormatType-Eigenschaft

In diesem Beispiel wird die erste Tabelle im aktiven Dokument mit dem AutoFormat Classic 1 formatiert, wenn das aktuelle Format Simple 1, Simple 2 oder Simple 3 lautet.

If ActiveDocument.Tables.Count >= 1 Then
    If ActiveDocument.Tables(1).AutoFormatType <= 3 Then
        ActiveDocument.Tables(1).AutoFormat _
            Format:=wdTableFormatClassic1
    End If
End If


AutoHyphenation-Eigenschaft

True, wenn für das angegebene Dokument die automatische Silbentrennung aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoHyphenation-Eigenschaft

In diesem Beispiel wird die automatische Silbentrennung aktiviert, wobei die Silbentrennzone 0,25 Zoll beträgt. Wörter in Großbuchstaben werden nicht getrennt.

With ActiveDocument
    .HyphenationZone = InchesToPoints(0.25)
    .HyphenateCaps = False
    .AutoHyphenation = True
End With


AutoInsert-Eigenschaft

True, wenn eine Beschriftung automatisch beim Einfügen eines Elements in ein Dokument eingefügt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoInsert-Eigenschaft

In diesem Beispiel wird Word aktiviert, Tabellen automatisch mit Beschriftungen zu versehen. Dann wird die Auswahl zu einer Einfügemarke reduziert und eine Tabelle eingefügt. Die neue Tabelle wird automatisch mit einer Beschriftung versehen.

AutoCaptions("Microsoft Word Table").AutoInsert = True
Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.Tables.Add Range:=Selection.Range, NumRows:=2, _
NumColumns:=2


AutoKeyboardSwitching-Eigenschaft

True, wenn Microsoft Word die Tastatursprache automatisch entsprechend Ihrer jeweiligen Eingaben wechselt. Boolean Schreib-Lese-Zugriff.

Hinweise

Um diese Eigenschaft verwenden zu können, muss die CheckLanguage-Eigenschaft auf True gesetzt sein.

Weitere Informationen zur Verwendung von Word bei mehreren Sprachen finden Sie unter Fehlerbehebung bei mehrsprachigem Text und automatischer Spracherkennung.


Beispiel zur AutoKeyboardSwitching-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, zwischen aktivierter und deaktivierter automatischer Tastaturumschaltung bei mehrsprachigen Dokumenten auszuwählen.

x = MsgBox("Enable automatic keyboard switching?", vbYesNo)
If x = vbYes Then
    Application.CheckLanguage = True
    Options.AutoKeyboardSwitching = True
    MsgBox "Automatic keyboard switching enabled!"
End If


AutoLength-Eigenschaft

True, wenn das erste Segment der Legendenlinie (das Segment, das am Legendentextfeld ansetzt) immer automatisch skaliert wird, wenn die Legende verschoben wird. False, wenn das erste Segment der Legende die feste Länge, die durch die Length-Eigenschaft spezifiziert wurde, immer beibehält, wenn die Legende verschoben wird. Betrifft nur Legenden, deren Linien aus mehr als einem Segment bestehen (die Typen msoCalloutThree und msoCalloutFour). Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die AutomaticLength-Methode zum Festlegen dieser Eigenschaft auf True und die CustomLength-Methode zum Festlegen dieser Eigenschaft auf False.


Beispiel zur AutoLength-Eigenschaft

In diesem Beispiel wird in myDocument für die Legendenlinie für Form eins zwischen der automatischen Skalierung und derjenigen mit fester Länge des ersten Segments umgeschaltet. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


AutoLoad-Eigenschaft

True, wenn das angegebene Add-In automatisch beim Start von Word geladen wird. Add-Ins, die sich im Word-Ordner AutoStart befinden, werden automatisch geladen. Boolean Nur-Lese-Zugriff.


Beispiel zur Autoload-Eigenschaft

In diesem Beispiel werden die Namen aller Add-Ins angezeigt, die beim Start von Word automatisch geladen wurden.

For Each myAddin In Addins
    If myAddin.Autoload = True Then
        MsgBox myAddin.Name
        afound = True
    End If
Next myAddin
If afound <> True Then _
    MsgBox "No add-ins were loaded automatically."

In diesem Beispiel wird ermittelt, ob das Add-In "Gallery.dot" automatisch geladen wurde.

For Each aAddin In Addins
    If InStr(LCase$(aAddin.Name), "gallery.dot") > 0 Then
        If aAddin.Autoload = True Then Msgbox "Autoload"
    End If
Next aAddin


AutomaticallyUpdate-Eigenschaft

True, wenn die Formatvorlage automatisch auf der Basis der Auswahl neu definiert wird. False, wenn Word zum Bestätigen auffordert, bevor die Formatvorlage auf der Basis der Auswahl neu definiert wird. Eine Formatvorlage kann neu definiert werden, wenn sie einer Auswahl zugewiesen wird, die dieselbe Formatvorlage, aber unterschiedliche manuelle Formatierung hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutomaticallyUpdate-Eigenschaft

In diesem Beispiel wird eine Formatvorlage namens "myStyle" erstellt, die ohne Bestätigung neu definiert werden kann.

Set myDoc = Documents.Add
Set myStyle = myDoc.Styles.Add("myStyle")
With myStyle
    .BaseStyle = myDoc.Styles(wdStyleNormal)
    .ParagraphFormat.LineSpacingRule = wdLineSpaceDouble
    .AutomaticallyUpdate = True
End With


AutoShapeType-Eigenschaft

Gibt den Formtyp für das angegebene Shape- oder ShapeRange-Objekt zurück, der eine andere AutoForm darstellen muss als eine Linie oder Freihandfigur, oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie den Typ einer Form ändern, behält die Form ihre Größe, Farbe und andere Attribute bei.

Dies kann eine der folgenden MsoAutoShapeType-Konstanten sein:

msoShape16pointStar

msoShape24pointStar

msoShape32pointStar

msoShape4pointStar

msoShape5pointStar

msoShape8pointStar

msoShapeActionButtonBackorPrevious

msoShapeActionButtonBeginning

msoShapeActionButtonCustom

msoShapeActionButtonDocument

msoShapeActionButtonEnd

msoShapeActionButtonForwardorNext

msoShapeActionButtonHelp

msoShapeActionButtonHome

msoShapeActionButtonInformation

msoShapeActionButtonMovie

msoShapeActionButtonReturn

msoShapeActionButtonSound

msoShapeArc

msoShapeBalloon

msoShapeBentArrow

msoShapeBentUpArrow

msoShapeBevel

msoShapeBlockArc

msoShapeCan

msoShapeChevron

msoShapeCircularArrow

msoShapeCloudCallout

msoShapeCross

msoShapeCube

msoShapeCurvedDownArrow

msoShapeCurvedDownRibbon

msoShapeCurvedLeftArrow

msoShapeCurvedRightArrow

msoShapeCurvedUpArrow

msoShapeCurvedUpRibbon

msoShapeDiamond

msoShapeDonut

msoShapeDoubleBrace

msoShapeDoubleBracket

msoShapeDoubleWave

msoShapeDownArrow

msoShapeDownArrowCallout

msoShapeDownRibbon

msoShapeExplosion1

msoShapeExplosion2

msoShapeFlowchartAlternateProcess

msoShapeFlowchartCard

msoShapeFlowchartCollate

msoShapeFlowchartConnector

msoShapeFlowchartData

msoShapeFlowchartDecision

msoShapeFlowchartDelay

msoShapeFlowchartDirectAccessStorage

msoShapeFlowchartDisplay

msoShapeFlowchartDocument

msoShapeFlowchartExtract

msoShapeFlowchartInternalStorage

msoShapeFlowchartMagneticDisk

msoShapeFlowchartManualInput

msoShapeFlowchartManualOperation

msoShapeFlowchartMerge

msoShapeFlowchartMultidocument

msoShapeFlowchartOffpageConnector

msoShapeFlowchartOr

msoShapeFlowchartPredefinedProcess

msoShapeFlowchartPreparation

msoShapeFlowchartProcess

msoShapeFlowchartPunchedTape

msoShapeFlowchartSequentialAccessStorage

 msoShapeFlowchartSort

msoShapeFlowchartStoredData

msoShapeFlowchartSummingJunction

msoShapeFlowchartTerminator

msoShapeFoldedCorner

msoShapeHeart

msoShapeHexagon

msoShapeHorizontalScroll

msoShapeIsoscelesTriangle

msoShapeLeftArrow

msoShapeLeftArrowCallout

msoShapeLeftBrace

msoShapeLeftBracket

msoShapeLeftRightArrow

msoShapeLeftRightArrowCallout

msoShapeLeftRightUpArrow

msoShapeLeftUpArrow

msoShapeLightningBolt

msoShapeLineCallout1

msoShapeLineCallout1AccentBar

msoShapeLineCallout1BorderandAccentBar

msoShapeLineCallout1NoBorder

msoShapeLineCallout2

msoShapeLineCallout2AccentBar

msoShapeLineCallout2BorderandAccentBar

msoShapeLineCallout2NoBorder

msoShapeLineCallout3

msoShapeLineCallout3AccentBar

msoShapeLineCallout3BorderandAccentBar

msoShapeLineCallout3NoBorder

msoShapeLineCallout4

msoShapeLineCallout4AccentBar

msoShapeLineCallout4BorderandAccentBar

msoShapeLineCallout4NoBorder

msoShapeMixed

msoShapeMoon

msoShapeNoSymbol

msoShapeNotchedRightArrow

msoShapeNotPrimitive

msoShapeOctagon

msoShapeOval

msoShapeOvalCallout

msoShapeParallelogram

msoShapePentagon

msoShapePlaque

msoShapeQuadArrow

msoShapeQuadArrowCallout

msoShapeRectangle

msoShapeRectangularCallout

msoShapeRegularPentagon

msoShapeRightArrow

msoShapeRightArrowCallout

msoShapeRightBrace

msoShapeRightBracket

msoShapeRightTriangle

msoShapeRoundedRectangle

msoShapeRoundedRectangularCallout

msoShapeSmileyFace

msoShapeStripedRightArrow

msoShapeSun

msoShapeTrapezoid

msoShapeUpArrow

msoShapeUpArrowCallout

msoShapeUpDownArrow

msoShapeUpDownArrowCallout

msoShapeUpRibbon

msoShapeUTurnArrow

msoShapeVerticalScroll

msoShapeWave


Beispiel zur AutoShapeType-Eigenschaft

In diesem Beispiel werden in myDocument alle 16-Punkt-Sterne durch 32-Punkt-Sterne ersetzt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    If s.AutoShapeType = msoShape16pointStar Then
        s.AutoShapeType = msoShape32pointStar
    End If
Next


AutoSize-Eigenschaft

True, wenn die Größe des Kontrollkästchens durch den Schriftgrad des umgebenden Textes bestimmt wird. False, wenn die Größe des Kontrollkästchens durch die Size-Eigenschaft bestimmt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoSize-Eigenschaft

In diesem Beispiel wird die Größe des Kontrollkästchens "Check1" auf Auto gesetzt, dann wird das Kontrollkästchen gewählt.

With ActiveDocument.FormFields("Check1").CheckBox
    .AutoSize = True
    .Value = True
End With


AutoTextEntries-Eigenschaft

Gibt eine AutoTextEntries-Auflistung zurück, die alle AutoText-Einträge in der angegebenen Dokumentvorlage darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur AutoTextEntries-Eigenschaft

In diesem Beispiel wird - falls vorhanden - der AutoText-Eintrag "Hello" aus der zugeordneten Dokumentvorlage gelöscht.

For Each entry In ActiveDocument.AttachedTemplate.AutoTextEntries
    If entry.Name = "Hello" Then entry.Delete
Next entry

In diesem Beispiel wird der AutoText-Eintrag "Temp" in die Dokumentvorlage Normal aufgenommen. Der Inhalt des AutoText-Eintrages (das erste Wort im Dokument) wird daraufhin in einem Meldungsfeld angezeigt.

Set myEntry = NormalTemplate.AutoTextEntries.Add(Name:="Temp", _
    Range:=ActiveDocument.Words(1))
MsgBox myEntry.Value

In diesem Beispiel wird der Inhalt der Markierung als AutoText-Eintrag "Address" in der zugeordneten Dokumentvorlage gespeichert.

If Len(Selection.Text) > 1 Then
    ActiveDocument.AttachedTemplate.AutoTextEntries.Add _
        Range:=Selection.Range, Name:="Address"
End If


AutoUpdate-Eigenschaft

True, wenn die angegebene Verknüpfung beim Öffnen der Container-Datei oder beim Ändern der Quelldatei automatisch aktualisiert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoUpdate-Eigenschaft

In diesem Beispiel werden im aktiven Dokument alle Formen aktualisiert, die verknüpfte OLE-Objekte sind, wenn Word nicht so eingestellt ist, dass Verknüpfungen automatisch aktualisiert werden.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        If s.LinkFormat.AutoUpdate = False Then s.LinkFormat.Update
    End If
Next s

In diesem Beispiel werden im aktiven Dokument alle Felder aktualisiert, die nicht automatisch aktualisiert werden.

For Each afield In ActiveDocument.Fields
    If afield.LinkFormat.AutoUpdate = False Then _
        afield.LinkFormat.Update
Next afield


AutoVersion-Eigenschaft

Gibt den Status der Option für automatisches Speichern von Dokumentversionen zurück oder legt ihn fest. Dies kann eine der beiden folgenden WdAutoVersions-Konstanten sein: wdAutoVersionOff oder wdAutoVersionOnClose. Long Schreib-Lese-Zugriff.

Hinweis Wenn die AutoVersion-Eigenschaft auf wdAutoVersionOnClose eingestellt ist, wird eine Dokumentversion automatisch gespeichert, wenn das Dokument geschlossen wird.


Beispiel zur AutoVersion-Eigenschaft

In diesem Beispiel wird die Option zum automatischen Speichern einer Dokumentversion beim Schließen des aktiven Dokuments deaktiviert.

ActiveDocument.Versions.AutoVersion = wdAutoVersionOff

In diesem Beispiel wird in der Statusleiste eine Meldung angezeigt, wenn die Option zum automatischen Speichern einer Dokumentversion für Report.doc aktiv ist.

If Documents("Report.doc").Versions.AutoVersion = _
        wdAutoVersionOnClose Then
    StatusBar = "A version will be automatically saved"
End If


AutoWordSelection-Eigenschaft

True, wenn durch Ziehen gleichzeitig ein Wort und nicht ein Zeichen markiert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoWordSelection-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass beim Markieren durch Ziehen einzelne Zeichen und nicht ganze Wörter markiert werden.

Options.AutoWordSelection = False

In diesem Beispiel wird der Status der Option Wörter automatisch markieren auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.AutoWordSelection


BackColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Hintergrundfarbe für den angegebenen Füllbereich oder die gemusterte Linie darstellt, oder legt es fest. Schreib-Lese-Zugriff.


Beispiel zur BackColor-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt, und dann werden die Vordergrundfarbe, die Hintergrundfarbe und die fließende Farbe für die Füllung des Rechtecks festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With

In diesem Beispiel wird zu myDocument eine gemusterte Linie hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


Background-Eigenschaft

Gibt ein Shape-Objekt zurück, das das Hintergrundbild für das angegebene Dokument darstellt. Nur-Lese-Zugriff.

Anmerkung Der Hintergrund ist nur in der Weblayoutansicht sichtbar.


BackgroundPatternColor-Eigenschaft

Gibt die 24-Bit-Farbe zurück, die dem Hintergrund des Shading-Objekts zugewiesen ist, oder stellt sie ein. Kann eine beliebige gültige WdColor-Konstante oder ein Wert sein, der von der RGB-Funktion zurückgegeben wird. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.


BackgroundPatternColorIndex-Eigenschaft

Gibt die Farbe, die auf den Hintergrund des Shading-Objekts angewendet wurde, zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow


Beispiel zur BackgroundPatternColorIndex-Eigenschaft

In diesem Beispiel wird die Hintergrundfarbe Zyan auf den ersten Absatz im aktiven Dokument angewendet.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.Shading.BackgroundPatternColorIndex = wdTurquoise

In diesem Beispiel wird eine Tabelle an der Einfügemarke eingefügt und der ersten Zelle eine hellgraue Hintergrundschattierung zugewiesen.

Selection.Collapse Direction:=wdCollapseStart
Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=2, NumColumns:=2)
myTable.Cell(1, 1).Shading.BackgroundPatternColorIndex = wdGray25


BackgroundPrintingStatus-Eigenschaft

Gibt die Anzahl der Druckaufträge in der im Hintergrund aktiven Druckerwarteschlange zurück. Long Nur-Lese-Zugriff.


Beispiel zur BackgroundPrintingStatus-Eigenschaft

In diesem Beispiel wird die Anzahl der Word-Druckaufträge zurückgegeben, die sich derzeit in der Druckerwarteschlange zum Drucken im Hintergrund befinden.

If Options.PrintBackground = True Then
    jobs = Application.BackgroundPrintingStatus
End If

In diesem Beispiel wird eine Meldung in der Statusleiste angezeigt, wenn die Anzahl der Druckaufträge größer als 0 (Null) ist.

If Application.BackgroundPrintingStatus > 0 Then
    StatusBar = Application.BackgroundPrintingStatus _
        & " print jobs are queued up"
End If


BackgroundSave-Eigenschaft

True, wenn Word Dokumente im Hintergrund speichert. Wenn Word im Hintergrund speichert, kann der Benutzer mit der Eingabe fortfahren und Befehle wählen. Boolean Schreib-Lese-Zugriff.


Beispiel zur BackgroundSave-Eigenschaft

In diesem Beispiel wird es dem Benutzer ermöglicht, mit der Arbeit an einem Dokument fortzufahren, während es von Word gespeichert wird.

Options.BackgroundSave = True

In diesem Beispiel wird der aktuelle Status der Option Speicherung im Hintergrund zulassen auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.BackgroundSave


BackgroundSavingStatus-Eigenschaft

Gibt die Anzahl der Dateien in der Warteschlange zurück, die im Hintergrund gespeichert werden sollen. Long Nur-Lese-Zugriff.


Beispiel zur BackgroundSavingStatus-Eigenschaft

In diesem Beispiel wird in der Statusleiste die Anzahl der Dokumente angezeigt, die zur Zeit gespeichert werden.

Options.BackgroundSave =True
Documents.Add
ActiveDocument.SaveAs
    While Application.BackgroundSavingStatus <> 0
        StatusBar = "Documents remaining to save: " _
            & Application.BackgroundSavingStatus
    DoEvents
Wend


BaseLineAlignment-Eigenschaft

Sprachspezifische Informationen

Returns or sets the baseline font alignment. Can be one of the following WdBaselineAlignment constants: wdBaselineAlignAuto, wdBaselineAlignBaseline, wdBaselineAlignCenter, wdBaselineAlignFarEast50, or wdBaselineAlignTop. Read/write Long.


Beispiel zur BaseLineAlignment-Eigenschaft

This example sets Microsoft Word to automatically adjust the baseline font alignment in the active document.

ActiveDocument.BaseLineAlignment = wdBaselineAlignAuto


BaseStyle-Eigenschaft

Gibt eine vorhandene Formatvorlage zurück oder legt eine Formatvorlage fest, auf der die Formatierung einer anderen Formatvorlage basieren kann. Zum Festlegen dieser Eigenschaft geben Sie entweder den lokalen Namen der Basis-Formatvorlage an, eine ganze Zahl oder eine WdBuiltinStyle-Konstante oder ein Objekt, das die Basis-Formatvorlage darstellt. Variant Schreib-Lese-Zugriff.

Eine Liste der WdBuiltinStyle-Konstanten finden Sie unter Style-Eigenschaft.


Beispiel zur BaseStyle-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und diesem anschließend eine neue Absatz-Formatvorlage namens "meineÜberschrift" hinzugefügt. Als Basis-Formatvorlage für die neue Formatvorlage wird Überschrift 1 zugewiesen. Dann wird ein linker Einzug von 1 Zoll (72 Punkt) für die neue Formatvorlage festgelegt.

Set myDoc = Documents.Add
Set myHeading = myDoc.Styles.Add("myHeading")
With myHeading
    .BaseStyle = myDoc.Styles(wdStyleHeading1)
    .ParagraphFormat.LeftIndent = 72
End With

In diesem Beispiel wird die Basis-Formatvorlage zurückgegeben, die für die Absatz-Formatvorlage Textkörper verwendet wird.

base = ActiveDocument.Styles(wdStyleBodyText).BaseStyle
MsgBox base


BeginArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt sie fest. Dies kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadLength-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt diese fest. Dies kann eine der folgenden MsoArrowheadStyle-Konstanten sein: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadStyle-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadWidth-Eigenschaft

Gibt die Breite der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt sie fest. Dies kann eine der folgenden MsoArrowheadWidth-Konstanten sein: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadWidth-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = Documents(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BlueScreen-Eigenschaft

True, wenn Word Text als weiße Zeichen auf blauem Hintergrund anzeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur BlueScreen-Eigenschaft

In diesem Beispiel wird der Benutzer gefragt, ob Text weiß auf blauem Hintergrund angezeigt werden soll. Die Schaltflächen "Ja" und "Nein" werden für die Antwort angezeigt.

If MsgBox("Do you want white on blue?", 36, _
        "BlueScreen?") = vbYes Then
    Options.BlueScreen = True
Else
    Options.BlueScreen = False
End If


Bold-Eigenschaft

True, wenn die Schriftart oder der Bereich fett formatiert sind. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.


BoldBi-Eigenschaft

Sprachspezifische Informationen

True if the font or range is formatted as bold. Returns True, False or wdUndefined (for a mixture of bold and non-bold text). Can be set to True, False, or wdToggle. Read/write Long.

Remarks

The BoldBi property applies to text in a right-to-left language.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur BoldBi-Eigenschaft

This example makes the first paragraph in the active right-to-left language document bold.

ActiveDocument.Paragraphs(1).Range.BoldBi = True


Bookmark-Eigenschaft

Gibt den Namen der Textmarke zurück, aus der Einträge für das Rechtsgrundlagenverzeichnis gelesen werden, oder legt ihn fest. String Schreib-Lese-Zugriff.

Hinweise

Die Bookmark-Eigenschaft entspricht dem Schalter \b in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld).


BookmarkID-Eigenschaft

Gibt die Nummer der Textmarke, die den Anfang der angegebenen Auswahl oder des Bereichs einschließt, zurück. Wenn keine entsprechende Textmarke existiert, wird 0 (Null) zurückgegeben. Die Nummer entspricht der Position der Textmarke im Dokument, 1 für die erste Textmarke, 2 für die zweite, usw. Long Nur-Lese-Zugriff.


Beispiel zur BookmarkID-Eigenschaft

In diesem Beispiel wird die Nummer der Textmarke angezeigt, die den Anfang der Auswahl einschließt.

MsgBox "Bookmark " & Selection.BookmarkID

In diesem Beispiel wird die Textmarke "Temp" am Anfang des Dokuments eingefügt, wenn sich dort nicht bereits eine Textmarke befindet.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseStart
If myRange.BookmarkID = 0 Then
    ActiveDocument.Bookmarks.Add Name:="temp", Range:=myRange
End If


Bookmarks-Eigenschaft

Gibt eine Bookmarks-Auflistung zurück, die alle Textmarken in einem Dokument, Bereich oder einer Auswahl darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Bookmarks-Eigenschaft

In diesem Beispiel werden die Positionen der Start- und Endzeichen der ersten Textmarke im ersten Dokument abgerufen.

With ActiveDocument.Bookmarks(1)
    BookStart = .Start
    BookEnd = .End
End With

In diesem Beispiel wird die aMarks()-Matrix verwendet, um die Namen aller Textmarken im aktiven Dokument zu speichern.

If ActiveDocument.Bookmarks.Count >= 1 Then
    ReDim aMarks(ActiveDocument.Bookmarks.Count - 1)
    i = 0
    For Each aBookmark In ActiveDocument.Bookmarks
        aMarks(i) = aBookmark.Name
        i = i + 1
    Next aBookmark
End If

In diesem Beispiel wird die Formatierung Fett auf den ersten Bereich des mit einer Textmarke versehenen Textes in der Auswahl zugewiesen.

If Selection.Bookmarks.Count >= 1 Then
    Selection.Bookmarks(1).Range.Bold = True
End If


Border-Eigenschaft

True, wenn der Text in der angegebenen Legende von einem Rahmen umgeben ist. Long Schreib-Lese-Zugriff.


Borders-Eigenschaft

Gibt eine Borders-Auflistung zurück, die alle Rahmen für das angegebene Objekt darstellt. Schreib-Lese-Zugriff.

Weitere Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Borders-Eigenschaft

In diesem Beispiel werden der ersten Tabelle im aktiven Dokument Rahmenlinien innen und außen zugewiesen.

Set myTable = ActiveDocument.Tables(1)
With myTable.Borders
    .InsideLineStyle = wdLineStyleSingle
    .OutsideLineStyle = wdLineStyleDouble
End With

In diesem Beispiel wird um das erste Zeichen in der Markierung ein Rahmen eingefügt. Ist keine Markierung vorhanden, wird der Rahmen dem ersten Zeichen hinter der Einfügemarke zugewiesen.

Selection.Characters(1).Borders.Enable = True

In diesem Beispiel wird allen zentrierten Absätzen im aktiven Dokument eine Rahmenlinie unten zugewiesen.

For Each para In ActiveDocument.Paragraphs
    If para.Alignment = wdAlignParagraphCenter Then
        para.Borders(wdBorderBottom).LineStyle = wdLineStyleSingle
        para.Borders(wdBorderBottom).LineWidth = wdLineWidth300pt
    End If
Next para

In diesem Beispiel wird um alle Seiten im aktuellen Abschnitt ein Rahmen eingefügt.

For Each aBorder In Selection.Sections(1).Borders
    aBorder.ArtStyle = wdArtBasicBlackDots
    aBorder.ArtWidth = 6
Next aBorder


BottomMargin-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der unteren Seitenkante und der unteren Begrenzung des Textkörpers zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur BottomMargin-Eigenschaft

In diesem Beispiel wird für das aktive Dokument der untere Seitenrand auf 72 Punkt (1 Zoll) und der obere Seitenrand auf 2 Zoll festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

With ActiveDocument.PageSetup
    .BottomMargin = 72
    .TopMargin = InchesToPoints(2)
End With

In diesem Beispiel wird für alle Abschnitte in der aktuellen Markierung der untere Seitenrand auf 2,5 Zoll festgelegt.

Selection.PageSetup.BottomMargin = InchesToPoints(2.5)

In diesem Beispiel wird der untere Seitenrand für Abschnitt 1 in der Markierung zurückgegeben. Die PointsToInches-Methode wird zur Umwandlung des Ergebnisses in Zoll verwendet.

myvar = Selection.Sections(1).PageSetup.BottomMargin
MsgBox PointsToInches(myvar) & " inches"


BottomPadding-Eigenschaft

Gibt den Abstand (in Punkt) zurück, der unterhalb des Inhalts einer einzelnen Zelle oder aller Zellen der Tabelle hinzugefügt wird, oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Die Einstellung der BottomPadding-Eigenschaft überschreibt die Einstellung der BottomPadding-Eigenschaft für die gesamte Tabelle.


Beispiel zur BottomPadding-Eigenschaft

In diesem Beispiel wird der untere Abstand der ersten Tabelle im aktiven Dokument auf 40 Pixel festgelegt.

ActiveDocument.Tables(1).BottomPadding = _
    PixelsToPoints(40, True)


Brightness-Eigenschaft

Gibt die Helligkeit der angegebenen Grafik oder des angegebenen OLE-Objekts zurück oder legt sie fest. Der Wert für diese Eigenschaft muss eine Zahl zwischen 0,0 (am schwächsten) und 1,0 (am hellsten) sein. Single Schreib-Lese-Zugriff.


Beispiel zur Brightness-Eigenschaft

In diesem Beispiel wird in myDocument die Helligkeit für Form eins festgelegt. Form eins muss eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActiveDocument
myDocument.Shapes(1).PictureFormat.Brightness = 0.3


BrowseExtraFileTypes-Eigenschaft

Legt "text/html" als Wert für diese Eigenschaft fest, damit Hyperlinked-HTML-Dateien in Word geöffnet werden können (anstatt im Standard-Internet-Browser). String Schreib-Lese-Zugriff.


Beispiel zur BrowseExtraFileTypes-Eigenschaft

In diesem Beispiel wird festgelegt, dass Hyperlinked-HTML-Dateien in Word (anstatt im Standard-Internet-Browser) geöffnet werden können.

Application.BrowseExtraFileTypes = "text/html"


Browser-Eigenschaft

Gibt ein Browser-Objekt zurück, das die Schaltfläche Objekt für Durchsuchen markieren auf der vertikalen Bildlaufleiste darstellt. Nur-Lese-Zugriff.


BrowserLevel-Eigenschaft

DefaultWebOptions-Objekt: Gibt die Version des Webbrowsers zurück, auf den neue in Microsoft Word erstellte Webseiten ausgerichtet werden sollen, oder legt diese fest. Dabei kann es sich um eine der folgenden WdBrowserLevel-Konstanten handeln: wdBrowserLevelMicrosoftInternetExplorer5 oder wdBrowserLevelV4. Long Schreib-Lese-Zugriff.

WebOptions-Objekt: Gibt die Version des Webbrowsers zurück, auf den die angegebene Webseite ausgerichtet werden soll, oder legt diese fest. Diese Eigenschaft wird ignoriert, wenn die OptimizeForBrowser-Eigenschaft auf False gesetzt ist. Dabei kann es sich um eine der folgenden WdBrowserLevel-Konstanten handeln: wdBrowserLevelMicrosoftInternetExplorer5 oder wdBrowserLevelV4. Long Schreib-Lese-Zugriff.

Hinweise

Nach Festlegen der BrowserLevel-Eigenschaft für das DefaultWebOptions-Objekt stimmt die BrowserLevel-Eigenschaft für alle neuen und von Ihnen in Word erstellten Webseiten mit der globalen Einstellung überein.


Beispiel zur BrowserLevel-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word neue Webseiten für Microsoft Internet Explorer 5 optimiert. Es wird dann auf Grundlage dieser Einstellung eine Webseite erstellt.

With Application.DefaultWebOptions
    .BrowserLevel _
        = wdBrowserLevelMicrosoftInternetExplorer5
    .OptimizeForBrowser = True
End With
Documents.Add DocumentType:=wdNewWebPage

In diesem Beispiel wird eine neue Webseite erstellt und für Microsoft Internet Explorer 5 optimiert.

Documents.Add DocumentType:=wdNewWebPage
With ActiveDocument.WebOptions
    .BrowserLevel _
        = wdBrowserLevelMicrosoftInternetExplorer5
    .OptimizeForBrowser = True
End With


BrowseToWindow-Eigenschaft

True, wenn die Zeilen nicht am rechten Rand der Seite, sondern an der rechten Seite des Ausschnitts umbrochen werden. Dies kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.

Anmerkung Diese Eigenschaft gibt in der Weblayoutansicht immer True und in der Drucklayoutansicht wdUndefined zurück.


BrowseWidth-Eigenschaft

Gibt die Breite der Fläche in Punkt zurück, in der der Text im angegebenen Ausschnitt umbrochen wird. Long Nur-Lese-Zugriff.

Anmerkung Diese Eigenschaft funktioniert nur in der Weblayoutansicht.


Build-Eigenschaft

Gibt die Version und die Versionsnummer von Word zurück. String Nur-Lese-Zugriff.


Beispiel zur Build-Eigenschaft

In diesem Beispiel wird die Version und die Versionsnummer von Word angezeigt.

MsgBox Prompt:=Application.Build, Title:="Microsoft Word Version"


BuiltIn-Eigenschaft

True, wenn das angegebene Objekt eine der integrierten Formatvorlagen oder Beschriftungskategorie in Word ist. Boolean Nur-Lese-Zugriff.

Hinweise

Sie können integrierte Formatvorlagen in allen Sprachen angeben, indem Sie die WdBuiltinStyle-Konstanten verwenden, oder innerhalb einer Sprache, indem Sie den Formatvorlagennamen für die Sprachversion von Word verwenden. Wenn Sie beispielsweise in den Spracheinstellungen für Microsoft Office US-Englisch festlegen, sind die folgenden Anweisungen äquivalent:

ActiveDocument.Styles(wdStyleHeading1)
ActiveDocument.Styles("Heading 1")


BuiltinDictionary-Eigenschaft

Sprachspezifische Information

Returns a Dictionary object that represents the main dictionary Microsoft Word uses during conversion between hangul and hanja. Read-only.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur BuiltinDictionary-Eigenschaft

This example displays the full path for the main hangul-hanja conversion dictionary.

With HangulHanjaDictionaries.BuiltinDictionary
    Msgbox .Path & Application.PathSeparator & .Name
End With


BuiltInDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle integrierten Dokumenteigenschaften des angegebenen Dokuments darstellt. Nur-Lese-Zugriff.

Anmerkung Wenn Microsoft Word keinen Wert für eine der integrierten Dokumenteigenschaften definiert, wird beim Lesen der Value-Eigenschaft ein Fehler erzeugt.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung erhalten Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Hinweise

Verwenden Sie zum Zurückgeben eines einzelnen DocumentProperty-Objekts, das eine bestimmte integrierte Dokumenteigenschaft darstellt, den Befehl BuiltinDocumentProperties(Index), wobei Index für eine der folgenden WdBuiltInProperty-Konstanten steht.

wdPropertyAppName

wdPropertyAuthor

wdPropertyBytes

wdPropertyCategory

wdPropertyCharacters

wdPropertyCharsWSpaces

wdPropertyComments

wdPropertyCompany

wdPropertyFormat

wdPropertyHiddenSlides

wdPropertyHyperlinkBase

wdPropertyKeywords

wdPropertyLastAuthor

wdPropertyLines

wdPropertyManager

 wdPropertyMMClips

wdPropertyNotes

wdPropertyPages

wdPropertyParas

wdPropertyRevision

wdPropertySecurity

wdPropertySlides

wdPropertySubject

wdPropertyTemplate

wdPropertyTimeCreated

wdPropertyTimeLastPrinted

wdPropertyTimeLastSaved

wdPropertyTitle

wdPropertyVBATotalEdit

wdPropertyWords

Verwenden Sie die CustomDocumentProperties-Eigenschaft, um die Auflistung mit benutzerdefinierten Dokumenteigenschaften zurückzugeben.


Beispiel zur BuiltInDocumentProperties-Eigenschaft

In diesem Beispiel wird eine Liste der integrierten Eigenschaften am Ende des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
For Each prop In ActiveDocument.BuiltInDocumentProperties
    With myRange
        .InsertParagraphAfter
        .InsertAfter prop.Name & "= "
        On Error Resume Next
        .InsertAfter prop.Value
    End With
Next

In diesem Beispiel wird die Anzahl der Wörter im aktiven Dokument angezeigt.

wrds = ActiveDocument.BuiltInDocumentProperties(wdPropertyWords)
MsgBox "This document contains " & wrds & " words."


ButtonFieldClicks-Eigenschaft

Gibt die Anzahl der nötigen Klicks (ein oder zwei) zurück oder legt sie fest, um ein GOTOBUTTON- oder MACROBUTTON-Feld auszuführen. Long Schreib-Lese-Zugriff.


Beispiel zur ButtonFieldClicks-Eigenschaft

In diesem Beispiel wird die Anzahl der nötigen Klicks festgelegt, um ein MACROBUTTON - oder GOTOBUTTON -Feld mit einem Klick auszuführen.

Options.ButtonFieldClicks = 1


CalculateOnExit-Eigenschaft

True, wenn Verweise auf das angegebene Formularfeld immer automatisch aktualisiert werden, sobald das Feld verlassen wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ein REF-Feld kann als Verweis auf den Inhalt eines Formularfelds verwendet werden. Zum Beispiel verweist {REF Zwischensumme} auf das Formularfeld, das durch die Textmarke "Zwischensumme" gekennzeichnet ist.


Beispiel zur CalculateOnExit-Eigenschaft

In diesem Beispiel werden in Form.doc Verweise auf Formularfelder nicht automatisch aktualisiert, wenn das Formularfeld verlassen wird.

For Each aFField In Documents("Form.doc").FormFields
    aFField.CalculateOnExit = False
Next aFField

In diesem Beispiel werden einem neuen Dokument ein Textformularfeld und ein REF-Feld hinzugefügt. Immer wenn Text eingegeben und das Feld "Text1" verlassen wird, wird das REF-Feld automatisch aktualisiert.

With Documents.Add
    .FormFields.Add Range:=Selection.Range, _
        Type:=wdFieldFormTextInput
    .Fields.Add Range:=Selection.Range, _
        Type:=wdFieldRef, Text:="Text1"
    .FormFields("Text1").CalculateOnExit = True
    .Protect Type:=wdAllowOnlyFormFields
End With


Callout-Eigenschaft

Gibt ein CalloutFormat-Objekt zurück, das Legendenformatierungseigenschaften für die angegebene Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die Legenden darstellen. Nur-Lese-Zugriff.


Beispiel zur Callout-Eigenschaft

In diesem Beispiel werden zu myDocument ein Oval und eine Legende, die auf das Oval zeigt, hinzugefügt. Der Legendentext wird keinen Rahmen haben, aber eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


CanOpen-Eigenschaft

True, wenn das angegebene Dateikonvertierungsprogramm zum Öffnen von Dateien bestimmt ist. Boolean Nur-Lese-Zugriff.

Hinweis Die CanSave-Eigenschaft gibt True zurück, wenn das angegebene Dateikonvertierungsprogramm zum Speichern (Exportieren) von Dateien verwendet werden kann.


Beispiel zur CanOpen-Eigenschaft

In diesem Beispiel wird ermittelt, ob das erste Dateikonvertierungsprogramm Dateien öffnen kann.

If FileConverters(1).CanOpen = True Then
    MsgBox FileConverters(1).FormatName & " can open files"
End If

In diesem Beispiel wird ermittelt, ob das WordPerfect6x-Dateikonvertierungsprogramm zum Öffnen von Dateien verwendet werden kann. Wenn die CanOpen-Eigenschaft True zurückgibt, wird das Dokument "Test.wp" geöffnet.

If FileConverters("WordPerfect6x").CanOpen = True Then
    Documents.Open FileName:="C:\Test.wp", _
        Format:=FileConverters("WordPerfect6x").OpenFormat
End If


CanSave-Eigenschaft

True, wenn das angegebene Dateikonvertierungsprogramm zum Speichern von Dateien bestimmt ist. Boolean Nur-Lese-Zugriff.

Hinweis Die CanOpen-Eigenschaft gibt True zurück, wenn das angegebene Dateikonvertierungsprogramm zum Öffnen (Importieren) von Dateien verwendet werden kann.


Beispiel zur CanSave-Eigenschaft

In diesem Beispiel wird ermittelt, ob das WordPerfect-Konvertierungsprogramm zum Speichern von Dateien verwendet werden kann. Wenn der Rückgabewert True ist, wird das aktive Dokument im WordPerfect 6.x-Format gespeichert.

If Application.FileConverters("WordPerfect6x").CanSave = True Then
    num = Application.FileConverters("WordPerfect6x").SaveFormat
    ActiveDocument.SaveAs FileName:="C:\Document.wp", _
        FileFormat:=num
End If

In diesem Beispiel wird eine Meldung angezeigt, die angibt, ob das dritte Konvertierungsprogramm in der FileConverters-Auflistung Dateien speichern kann.

If FileConverters(3).CanSave = True Then
    MsgBox FileConverters(3).FormatName & " can save files"
Else
    MsgBox FileConverters(3).FormatName & " cannot save files"
End If


CapsLock-Eigenschaft

True, wenn die FESTSTELLTASTE aktiviert ist. Boolean Nur-Lese-Zugriff.


Beispiel zur CapsLock-Eigenschaft

In diesem Beispiel wird der aktuelle Status der FESTSTELLTASTE gelesen.

theState = Application.CapsLock


Caption-Eigenschaft

TableOfFigures-Objekt: Gibt die Beschriftung zurück, die die Elemente identifiziert, die in ein Abbildungsverzeichnis aufgenommen werden sollen, oder legt sie fest. Entspricht dem Schalter \c für ein TOC-Feld. String Schreib-Lese-Zugriff.

Window- oder Application-Objekt: Gibt den Beschriftungstext für das angegebene Dokument- oder Anwendungsfenster zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Soll die Beschriftung des Anwendungsfensters in den Standardtext geändert werden, stellen Sie diese Eigenschaft als leere Zeichenfolge ("") ein.


CaptionLabel-Eigenschaft

Gibt die Beschriftungskategorie (beispielsweise "Abbildung", "Tabelle" oder "Gleichung") der angegebenen Beschriftung zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft kann durch eine Zeichenfolge oder eine WdCaptionLabelID-Konstante festgelegt werden.


CaptionLabels-Eigenschaft

Gibt eine CaptionLabels-Auflistung zurück, die alle verfügbaren Beschriftungen darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur CaptionLabels-Eigenschaft

In diesem Beispiel wird die Formatvorlage für die Nummerierung von Tabellenbeschriftungen festgelegt.

CaptionLabels(wdCaptionTable).NumberStyle = _
    wdCaptionNumberStyleLowercaseRoman

In diesem Beispiel wird eine neue Beschriftung mit dem Namen "Photo" hinzugefügt und dann wird eine Foto-Beschriftung eingefügt.

CaptionLabels.Add Name:="Photo"
With Selection
    .InsertParagraphAfter
    .InsertCaption Label:="Photo"
End With


Case-Eigenschaft

Gibt die Groß-/Kleinschreibung des Textes im angegebenen Bereich zurück oder legt sie fest. Kann eine der folgenden WdCharacterCase-Konstanten sein: wdFullWidth, wdHalfWidth, wdHiragana, wdKatakana, wdLowerCase, wdNextCase, wdTitleSentence, wdTitleWord, wdToggleCase oder wdUpperCase. Long Schreib-Lese-Zugriff.

Hinweise

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt davon ab, welche Sprachunterstützung (z. B. Deutsch) Sie ausgewählt oder installiert haben.


Beispiel zur Case-Eigenschaft

In diesem Beispiel wird das erste Wort in der Markierung in Großbuchstaben verwandelt.

Selection.Words(1).Case = wdUpperCase

In diesem Beispiel beginnt jeder Satz im ersten Absatz des Dokuments mit einem Großbuchstaben.

Set myRange = ActiveDocument.Paragraphs(1).Range
For Each Sent In myRange.Sentences
    Sent.Case = wdTitleSentence
Next Sent


Category-Eigenschaft

Gibt die Kategorie der Einträge zurück, die in ein Rechtsgrundlagenverzeichnis aufgenommen werden sollen, oder legt sie fest. Entspricht dem Schalter \c in einem TOA-Feld. Die Werte 1 bis 16 entsprechen den Elementen in der Liste Kategorie auf der Registerkarte Rechtsgrundlagenverzeichnis im Dialogfeld Index und Verzeichnisse. Long Schreib-Lese-Zugriff.

Anmerkung Die Zahl 0 (Null), die alle Kategorien darstellt, kann bei dieser Eigenschaft nicht verwendet werden. Sie können den Wert 0 allerdings beim Einfügen eines Rechtsgrundlagenverzeichnisses verwenden, um festzulegen, dass alle Kategorien aufgenommen werden sollen. Im folgenden Beispiel wird ein Rechtsgrundlagenverzeichnis mit Einträgen aus allen Kategorien eingefügt.

ActiveDocument.TablesOfAuthorities.Add _
    Range:=Selection.Range, Category:=0


Beispiel zur Category-Eigenschaft

In diesem Beispiel wird festgelegt, dass das erste Rechtsgrundlagenverzeichnis im aktuellen Dokument alle Einträge der ersten Kategorie enthält (standardmäßig die Kategorie "Cases").

If ActiveDocument.TablesOfAuthorities.Count >= 1 Then
    ActiveDocument.TablesOfAuthorities(1).Category = 1
End If


CCList-Eigenschaft

Gibt die Empfänger zurück, die eine Kopie des Briefes erhalten, der mit dem Brief-Assistenten erstellt wurde, oder legt diese Empfänger fest. String Schreib-Lese-Zugriff.


Beispiel zur CCList-Eigenschaft

In diesem Beispiel wird der Text der CC-Liste des aktiven Dokuments angezeigt.

MsgBox ActiveDocument.GetLetterContent.CCList

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, die Empfänger von Kopien werden mit der CClist-Eigenschaft festgelegt und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myLetterContent = New LetterContent
myLetterContent.CCList = "K. Jordan, D. Funk, D. Morrison"
ActiveDocument.RunLetterWizard LetterContent:=myLetterContent


Cells-Eigenschaft

Gibt eine Cells-Auflistung zurück, die die Tabellenzellen in einer Spalte, einer Zeile, in der Markierung oder in einem Bereich darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Cells-Eigenschaft

In diesem Beispiel wird eine 3x3 Tabelle erstellt und jeder Zelle in der Tabelle eine fortlaufende Zellennummer zugewiesen.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
i = 1
For Each c In myTable.Range.Cells
    c.Range.InsertAfter "Cell " & i
    i = i + 1
Next c

In diesem Beispiel wird die Hintergrundfarbe der aktuellen Zelle auf Rot eingestellt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).Shading.BackgroundPatternColorIndex = wdRed
Else
    MsgBox "The insertion point is not in a table."
End If


ChapterPageSeparator-Eigenschaft

Gibt das Trennzeichen, das zwischen der Kapitelnummer und der Seitennummer verwendet wird, zurück oder legt es fest. Kann eine der folgenden WdSeparatorType-Konstanten sein: wdSeparatorColon, wdSeparatorEmDash, wdSeparatorEnDash, wdSeparatorHyphen, oder wdSeparatorPeriod. Long Schreib-Lese-Zugriff.

Hinweise

Bevor Sie Seitennummern erstellen können, die Kapitelnummern beinhalten, muss den Dokumentüberschriften ein Gliederungsformat mit Nummerierung zugewiesen worden sein, das Formatvorlagen aus dem Dialogfeld Nummerierung und Aufzählungen verwendet. In Visual Basic verwenden Sie die ApplyListTemplate-Methode dazu.


Beispiel zur ChapterPageSeparator-Eigenschaft

Im ersten Teil dieses Beispiels wird ein neues Dokument erstellt, diesem werden Kapitelüberschriften und Seitenwechsel hinzugefügt, und dann wird das Dokument formatiert, indem das letzte Gliederungsformat mit Nummerierung verwendet wird, das im Dialogfeld Nummerierung und Aufzählungen aufgelistet ist. Im zweiten Teil des Beispiels werden der Kopfzeile zentrierte Seitennummern einschließlich der Kapitelnummer hinzugefügt; ein kurzer Gedankenstrich trennt die Kapitelnummer und die Seitennummer.

Documents.Add
For i = 1 To 5
    With Selection
        .TypeParagraph
        .InsertBreak
    End With
Next i
ActiveDocument.Content.Style = wdStyleHeading1
ActiveDocument.Content.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(7)

Set myHead = ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary)
With myHead.PageNumbers
    .Add PageNumberAlignment:=wdAlignPageNumberCenter
    .NumberStyle = wdPageNumberStyleArabic
    .IncludeChapterNumber = True
    .HeadingLevelForChapter = 0
    .ChapterPageSeparator = wdSeparatorEnDash
End With


ChapterStyleLevel-Eigenschaft

Gibt die Überschrift-Formatvorlage zurück, die ein neues Kapitel kennzeichnet, wenn Kapitelnummern mit der angegebenen Beschriftungskategorie einbezogen werden, oder legt sie fest. Die Nummer 1 entspricht Überschrift 1, 2 entspricht Überschrift 2 usw. Long Schreib-Lese-Zugriff.

Hinweis Die IncludeChapterNumber-Eigenschaft muss auf True gesetzt werden, damit Kapitelnummern mit Beschriftungskategorien einbezogen werden.


Beispiel zur ChapterStyleLevel-Eigenschaft

In diesem Beispiel wird die Beschriftungskategorie der Tabelle so formatiert, dass eine Kapitelnummer einbezogen wird. Die Kapitelnummer wird Absätzen entnommen, die mit der Formatvorlage Überschrift 2 formatiert sind.

With CaptionLabels(wdCaptionTable)
    .IncludeChapterNumber = True
    .ChapterStyleLevel = 2
End With


Characters-Eigenschaft

Gibt eine Characters-Auflistung zurück, die die Zeichen in einem Dokument, einem Bereich oder einer Markierung darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Characters-Eigenschaft

In diesem Beispiel wird das erste Zeichen in der Markierung angezeigt. Wenn nichts markiert ist, wird das Zeichen unmittelbar nach der Einfügemarke angezeigt.

char = Selection.Characters(1).Text
MsgBox "The first character is... " & char

In diesem Beispiel wird die Anzahl der Zeichen im ersten Satz des aktiven Dokuments zurückgegeben (Leerzeichen werden mitgezählt).

numchars = ActiveDocument.Sentences(1).Characters.Count


CharacterUnitFirstLineIndent-Eigenschaft

Sprachspezifische Information

Returns or sets the value (in characters) for a first-line or hanging indent. Use a positive value to set a first-line indent, and use a negative value to set a hanging indent. Read/write Single.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CharacterUnitFirstLineIndent-Eigenschaft

This example sets a first-line indent of one character for the first paragraph in the active document.

ActiveDocument.Paragraphs(1) _
    .CharacterUnitFirstLineIndent = 1

This example sets a hanging indent of 1.5 characters for the second paragraph in the active document.

ActiveDocument.Paragraphs(2) _
    .CharacterUnitFirstLineIndent = -1.5


CharacterUnitLeftIndent-Eigenschaft

Sprachspezifische Informationen

Returns or sets the left indent value (in characters) for the specified paragraphs. Read/write Single.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CharacterUnitLeftIndent-Eigenschaft

This example sets the left indent of the first paragraph in the active document to one character from the left margin.

ActiveDocument.Paragraphs(1) _
    .CharacterUnitLeftIndent = 1


CharacterUnitRightIndent-Eigenschaft

Sprachspezifische Informationen

Returns or sets the right indent value (in characters) for the specified paragraphs. Read/write Single.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CharacterUnitRightIndent-Eigenschaft

This example sets the right indent for all paragraphs in the active document to one character from the right margin.

ActiveDocument.Paragraphs _
    .CharacterUnitRightIndent = 1


CharacterWidth-Eigenschaft

Sprachspezifische Informationen

Returns or sets the character width of the specified range. Can be either of the following WdCharacterWidth constants: wdWidthFullWidth or wdWidthHalfWidth. Can also be wdUndefined if the range contains text of different widths. Read/write Long.

Remarks

If you set the CharacterWidth property to wdUndefined, an error occurs.

For more information on editing Japanese text in Microsoft Word, see Editing tools for Japanese text.


Beispiel zur CharacterWidth-Eigenschaft

This example converts the current selection to half-width characters.

Selection.Range.CharacterWidth = wdWidthHalfWidth


CharsLine-Eigenschaft

Sprachspezifische Informationen

Returns or sets the number of characters per line in the document grid. Read/write Single.


Beispiel zur CharsLine-Eigenschaft

Sprachspezifische Informationen

This example sets the number of characters per line to 42 for the active document.

ActiveDocument.PageSetup.CharsLine = 42


CheckBox-Eigenschaft

Gibt ein CheckBox-Objekt zurück, das ein Kontrollkästchen-Formularfeld darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wird die CheckBox-Eigenschaft auf ein FormField-Objekt angewendet, bei dem es sich nicht um ein Kontrollkästchen-Formularfeld handelt, dann entsteht durch die Eigenschaft kein Fehler, aber die Valid-Eigenschaft für das zurückgegebene Objekt lautet False.


Beispiel zur CheckBox-Eigenschaft

In diesem Beispiel wird das Kontrollkästchen "Blue" gelöscht.

ActiveDocument.FormFields("Blue").CheckBox.Value = False

In diesem Beispiel wird der aktuelle Wert mit dem Standardwert des Kontrollkästchens "Check1" verglichen. Wenn beide Werte identisch sind, wird die Variable same auf True gesetzt.

Set myField = ActiveDocument.FormFields("Check1").CheckBox
If myField.Default = myField.Value Then same = True


CheckGrammarAsYouType-Eigenschaft

True, wenn Word die Grammatik überprüft und Fehler bei der Eingabe automatisch markiert. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft markiert grammatische Fehler. Um sie jedoch auf dem Bildschirm anzuzeigen, müssen Sie die ShowGrammaticalErrors-Eigenschaft auf True setzen.


Beispiel zur CheckGrammarAsYouType-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word bei der Eingabe auf grammatische Fehler überprüft und die im aktiven Dokument gefundenen Fehler angezeigt werden.

Options.CheckGrammarAsYouType = True
ActiveDocument.ShowGrammaticalErrors = True

In diesem Beispiel wird der Status der Option Grammatik während der Eingabe prüfen auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen (Menü Extras) angezeigt.

temp = Options.CheckGrammarAsYouType


CheckGrammarWithSpelling-Eigenschaft

True, wenn Word die Grammatik während der Rechtschreibprüfung überprüft. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft legt fest, ob Word die Grammatik überprüft, wenn Sie mit dem Befehl Rechtschreibung (Menü Extras) die Rechtschreibprüfung aufrufen.

Um die Rechtschreib- oder die Grammatikprüfung mit einer Visual Basic-Prozedur aufzurufen, verwenden Sie die CheckSpelling-Methode, um nur die Rechtschreibung zu prüfen. Verwenden Sie die CheckGrammar-Methode, um die Grammatik und die Rechtschreibung zu prüfen.


Beispiel zur CheckGrammarWithSpelling-Eigenschaft

In diesem Beispiel wird der Status der Option Grammatik zusammen mit Rechtschreibung prüfen auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben. Ist diese Option markiert, werden die Rechtschreibung und die Grammatik geprüft, andernfalls wird nur die Rechtschreibung geprüft.

If Options.CheckGrammarWithSpelling = True Then
    ActiveDocument.CheckGrammar
Else
    ActiveDocument.CheckSpelling
End If


CheckHangulEndings-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word automatically detects hangul endings and ignores them during conversion from hangul to hanja. Read/write Boolean.

Remarks

If converting from hanja to hangul, this property is ignored.

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CheckHangulEndings-Eigenschaft

Sprachspezifische Informationen

This example asks the user whether to set Microsoft Word to automatically detect hangul endings and ignore them during conversion from hangul to hanja.

x = MsgBox("Check hangul endings during " _
    & "conversion from hangul to hanja?", vbYesNo)
If x = vbYes Then
    Options.CheckHangulEndings = True
Else
    Options.CheckHangulEndings = False
End If


CheckIfOfficeIsHTMLEditor-Eigenschaft

True, wenn beim Starten von Microsoft Word überprüft wird, ob es sich bei bei einer Office-Anwendung um den Standard-HTML-Editor handelt. False, wenn diese Überprüfung von Word nicht durchgeführt wird. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft wird nur angewendet, wenn der von Ihnen verwendete Webbrowser HTML-Bearbeitung und HTML-Editoren unterstützt.

Wenn Sie einen anderen HTML-Editor verwenden möchten, müssen Sie diese Eigenschaft auf False setzen und anschließend den Editor als Standard-HTML-Editor des Systems registrieren.


Beispiel zur CheckIfOfficeIsHTMLEditor-Eigenschaft

In diesem Beispiel wird Microsoft Word so eingestellt, dass nicht überprüft wird, ob es sich bei einer Office-Anwendung um den Standard-HTML-Editor handelt.

Application.DefaultWebOptions _
    .CheckIfOfficeIsHTMLEditor = False


CheckIfWordIsDefaultHTMLEditor-Eigenschaft

True, wenn Microsoft Word beim Starten des Programms überprüft, ob Word selbst der Standard-HTML-Editor ist. False, wenn diese Überprüfung von Word nicht durchgeführt wird. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft kommt nur zum Einsatz, wenn der von Ihnen verwendete Webbrowser HTML-Bearbeitung und HTML-Editoren unterstützt.

Wenn Sie einen anderen HTML-Editor verwenden möchten, müssen Sie diese Eigenschaft auf False setzen und den Editor anschließend als Standard-HTML-Editor des Systems registrieren.


Beispiel zur CheckIfWordIsDefaultHTMLEditor-Eigenschaft

In diesem Besipiel wird Microsoft Word so eingestellt, dass vom Programm überprüft wird, ob es selbst der HTML-Editor ist.

Application.DefaultWebOptions _
    .CheckIfWordIsDefaultHTMLEditor = True


CheckLanguage-Eigenschaft

True, wenn die von Ihnen verwendete Sprache von Microsoft Word bei der Eingabe automatisch erkannt wird. Boolean Schreib-Lese-Zugriff.

Hinweise

Wenn Sie Word nicht für die Arbeit mit mehreren Sprachen eingerichtet haben, gibt die CheckLanguage-Eigenschaft den Wert False zurück. Weitere Informationen über die automatische Spracherkennung finden Sie unter Automatische Spracherkennung.


Beispiel zur CheckLanguage-Eigenschaft

In diesem Beispiel wird überprüft, ob die automatische Spracherkennung aktiviert ist.

If Application.CheckLanguage = True Then
    MsgBox "Automatic language detection is activated!"
End If


CheckSpellingAsYouType-Eigenschaft

True, wenn Word die Rechtschreibung überprüft und Fehler automatisch bei der Eingabe markiert. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft markiert Rechtschreibfehler, um sie aber auf dem Bildschirm anzuzeigen, müssen Sie die ShowSpellingErrors-Eigenschaft auf True setzen.


Beispiel zur CheckSpellingAsYouType-Eigenschaft

In diesem Beispiel wird die automatische Rechtschreibprüfung in Word deaktiviert.

Options.CheckSpellingAsYouType = False

In diesem Beispiel wird festgelegt, dass Word die Rechtschreibung bei der Eingabe überprüft und alle gefundenen Fehler im aktiven Dokument angezeigt werden.

Options.CheckSpellingAsYouType = True
ActiveDocument.ShowSpellingErrors = True

In diesem Beispiel wird der Status der Option Rechtschreibung während der Eingabe überprüfen auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen (Menü Extras) angezeigt.

temp = Options.CheckSpellingAsYouType


ChildFramesetCount-Eigenschaft

Gibt die Anzahl der untergeordneten Frameset-Objekte zurück, die dem angegebenen Frameset-Objekt zugeordnet sind. Diese Eigenschaft betrifft nur Frameset-Objekte vom Typ wdFramesetTypeFrameset. Long Nur-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur ChildFramesetCount-Eigenschaft

In diesem Beispiel wird die Anzahl der untergeordneten Frameset-Objekte angezeigt, die in dem Frameset-Objekt enthalten sind, das die angegebene Framesseite darstellt.

MsgBox ActiveWindow.Document_
    .Frameset.ChildFramesetCount


ChildFramesetItem-Eigenschaft

Gibt das Frameset-Objekt zurück, welches das vom Index-Argument angegebene untergeordnete Frameset-Objekt darstellt. Diese Eigenschaft gilt nur für Frameset-Objekte vom Typ wdFramesetTypeFrameset. Nur-Lese-Zugriff.

Syntax

Ausdruck.ChildFramesetItem(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Frameset-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des angegebenen Frames.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur ChildFramesetItem-Eigenschaft

In diesem Beispiel wird der Name für den dritten untergeordneten Frame des angegebenen Frames auf "BottomFrame" festgelegt.

ActiveWindow.Document.Frameset _
    .ChildFramesetItem(3).FrameName = "BottomFrame"


ClassName-Eigenschaft

Gibt einen eindeutigen Namen zurück, der das Datei-Konvertierungsprogramm kennzeichnet. String Nur-Lese-Zugriff.


Beispiel zur ClassName-Eigenschaft

In diesem Beispiel wird der Klassenname und der Formatname des ersten Konvertierungsprogramms in der FileConverters-Auflistung angezeigt.

MsgBox "ClassName= " & FileConverters(1).ClassName & vbCr _
    & "FormatName= " & FileConverters(1).FormatName

Wenn ein HTML-Datei-Konvertierungsprogramm zur Verfügung steht, wird in diesem Beispiel das HTML-Format als Standard-Speicherformat festgelegt.

For Each aFile In FileConverters
    If aFile.ClassName = "HTML" Then _
        Application.DefaultSaveFormat = "HTML"
Next aFile


ClassType-Eigenschaft

Gibt den Klassentyp für das angegebene OLE-Objekt, die Grafik oder das Feld zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für verknüpfte Objekte außer DDE-Verknüpfungen schreibgeschützt.

Sie können eine Liste der verfügbaren Anwendungen im Feld Objekttyp auf der Registerkarte Neu erstellen im Dialogfeld Objekt (Menü Einfügen) sehen. Die Zeichenfolge ClassType können Sie finden, indem Sie ein Objekt als zeilenfixierte Form einfügen und sich dann die Feldfunktionen ansehen. Der Klassentyp des Objekts steht entweder nach dem Wort "EMBED" oder dem Wort "LINK".


Beispiel zur ClassType-Eigenschaft

In diesem Beispiel werden alle beweglichen Formen im aktiven Dokument durchlaufen und festgelegt, dass alle verknüpften Microsoft Excel-Tabellen automatisch aktualisiert werden sollen.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        If s.OLEFormat.ClassType = "Excel.Sheet" Then
            s.LinkFormat.AutoUpdate = True
        End If
    End If
Next


ClickAndTypeParagraphStyle-Eigenschaft

Gibt das durch Klicken und Eingeben zugewiesene Standardabsatzformat im angegebenen Dokument zurück oder legt es fest. Um diese Eigenschaft einzustellen, müssen Sie entweder den lokalen Namen der Formatvorlage, eine ganze Zahl bzw. eine WdBuiltinStyle-Konstante oder ein Objekt angeben, das diese Formatvorlage darstellt. Variant Schreib-Lese-Zugriff.

Eine Liste der WdBuiltinStyle-Konstanten finden Sie im Them zur Style-Eigenschaft.

Hinweise

Wenn die InUse-Eigenschaft für die angegebene Formatvorlage auf False gesetzt ist, tritt ein Fehler auf.

Weitere Informationen über Klicken und Eingeben finden Sie unter Übersicht über Klicken und Eingeben.


Beispiel zur ClickAndTypeParagraphStyle-Eigenschaft

In diesem Beispiel wird das durch Klicken und Eingeben auf unformatierten Text angewendete Standardabsatzformat festgelegt.

With ActiveDocument
    x = "Plain Text"
    If .Styles(x).InUse Then
        .ClickAndTypeParagraphStyle = x
    Else
        MsgBox "Sorry, this style is not in use yet."
    End If
End With


Closing-Eigenschaft

Gibt den Briefschluss für einen Brief, der mit dem Brief-Assistenten erstellt wurde (z. B. "Mit freundlichen Grüßen"), zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur Closing-Eigenschaft

In diesem Beispiel wird der Briefschluss aus dem aktiven Dokument angezeigt.

MsgBox ActiveDocument.GetLetterContent.Closing

In diesem Beispiel werden die Briefelemente aus dem aktiven Dokument geladen, der Text für den Briefschluss durch Festlegen der Closing-Eigenschaft geändert, und anschließend wird das Dokument mit der SetLetterContent-Methode aktualisiert, damit die Änderungen wiedergegeben werden.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.Closing = "Sincerely yours,"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


Code-Eigenschaft

Gibt ein Range-Objekt zurück, das eine Feldfunktion repräsentiert. Bei einer Feldfunktion handelt es sich um alles, was durch Feldzeichen ({ }) eingeschlossen ist, einschließlich der führenden und anschließenden Leerzeichen. Sie können auf eine Feldfunktion zugreifen, ohne die Darstellung der Feldergebnisse zu ändern. Schreib-Lese-Zugriff.


CodeName-Eigenschaft

Gibt den Codenamen für das angegebene Dokument zurück. String Nur-Lese-Zugriff.

Anmerkungen

Beim Codenamen handelt es sich um den Namen des Moduls, das die Makros für ein Dokument enthält. Der Standardname des Moduls lautet "ThisDocument", das Sie im Fenster Projekt anzeigen können. Informationen zur Verwendung der Ereignisse mit dem Document-Objekt, finden Sie unter Verwenden von Ereignissen mit dem Document-Objekt.


Beispiel zur CodeName-Eigenschaft

In diesem Beispiel wird das Codefenster für das aktive Dokument zurückgegeben.

Msgbox ActiveDocument.CodeName


Color-Eigenschaft

Gibt die 24-Bit-Farbe für das angegebene Border- oder Font-Objekt zurück oder legt sie fest. Hierbei kann es sich um eine beliebige gültige WdColor-Konstante oder einen von der RGB-Funktion zurückgegebenen Wert handeln. Long Schreib-Lese-Zugriff.

Hinweise

Die Liste gültiger WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.


ColorIndex-Eigenschaft

Gibt die Farbe für das angegebene Rahmen- oder Schriftartobjekt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Hierbei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln.

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Hinweise

Die wdByAuthor-Konstante ist für Rahmen- und Schriftartobjekte nicht gültig.


ColorIndexBi-Eigenschaft

Sprachspezifische Informationen

Returns or sets the color for the specified Font object in a right-to-left language document. Read/write Long.

Can be one of the following WdColorIndex constants.

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Remarks

The wdByAuthor constant is not valid for Font objects.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ColorIndexBi-Eigenschaft

Sprachspezifische Informationen

This example sets the color of the Font object to teal.

Selection.Font.ColorIndexBi = wdTeal


ColorType-Eigenschaft

Gibt die Art der Farbtransformation, die der angegebenen Grafik oder dem OLE-Objekt zugewiesen wurde, zurück oder legt sie fest. Dies kann eine der folgenden MsoPictureColorType-Konstanten sein: msoPictureAutomatic, msoPictureBlackAndWhite, msoPictureGrayscale, msoPictureMixed oder msoPictureWatermark. Long Schreib-Lese-Zugriff.


Beispiel zur ColorType-Eigenschaft

In diesem Beispiel wird in myDocument die Farbtransformation für Form eins auf Graustufen festgelegt. Form eins muss eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActiveDocument
myDocument.Shapes(1).PictureFormat.ColorType = msoPictureGrayScale


Column-Eigenschaft

Bookmark-Objekt: True, wenn die angegebene Textmarke eine Tabellenspalte ist. Boolean Nur-Lese-Zugriff.

Cell-Objekt: Gibt ein Column-Objekt zurück, das die Tabellenspalte darstellt, die die angegebene Zelle enthält. Nur-Lese-Zugriff.


ColumnIndex-Eigenschaft

Gibt die Nummer der Tabellenspalte zurück, die die angegebene Zelle enthält. Long Nur-Lese-Zugriff.


Beispiel zur ColumnIndex-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument eine Tabelle erstellt, nacheinander jede Zelle in der ersten Zeile markiert, und die Nummer der Spalte zurückgegeben, die die markierte Zelle enthält.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
For Each aCell In myTable.Rows(1).Cells
    aCell.Select
    MsgBox "This is column " & aCell.ColumnIndex
Next aCell

In diesem Beispiel wird die Spaltennummer der Zelle, die die Einfügemarke enthält, zurückgegeben.

Msgbox Selection.Cells(1).ColumnIndex


Columns-Eigenschaft

Gibt eine Columns-Auflistung zurück, die alle Tabellenspalten im Bereich, in der Markierung oder in der Tabelle darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


ColumnSelectMode-Eigenschaft

True, wenn der Spaltenmarkierungsmodus aktiv ist. In der Statusleiste erscheinen die Buchstaben "Sp", wenn dieser Modus aktiv ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur ColumnSelectMode-Eigenschaft

In diesem Beispiel wird eine Textspalte gewählt, die zwei Wörter in der Breite und drei Wörter nach unten umfasst. Die Auswahl wird dann in die Zwischenablage kopiert, und der Spaltenmarkierungsmodus wird deaktiviert.

With Selection
    .Collapse Direction:=wdCollapseStart
    .ColumnSelectMode = True
    .MoveRight Unit:=wdWord, Count:=2, Extend:=wdExtend
    .MoveDown Unit:=wdLine, Count:=2, Extend:=wdExtend
    .Copy
    .ColumnSelectMode = False
End With


 COMAddIns-Eigenschaft

COMAddIns-Eigenschaft

Gibt einen Verweis auf die COMAddIns-Auflistung zurück, die alle gegenwärtig in Microsoft Word geladenen Component Object Model (COM)-Add-Ins darstellt. Diese sind im Dialogfeld COM-Add-Ins aufgeführt. Im Dialogfeld Anpassen (Menü Extras) können Sie dem Menü Extras den Befehl COM-Add-Ins hinzufügen. Nur-Lese-Zugriff.


CombineCharacters-Eigenschaft

Sprachspezifische Informationen

True if the specified range contains combined characters. Read/write Boolean.

Remarks

For more information on editing Japanese text in Word, see Editing tools for Japanese text.


Beispiel zur CombineCharacters-Eigenschaft

Sprachspezifische Informationen

This example combines the characters in the selected range.

Selection.Range.CombineCharacters = True


Command-Eigenschaft

Gibt den Befehl zurück, der einer bestimmten Tastenkombination zugewiesen ist. String Nur-Lese-Zugriff.


CommandBars-Eigenschaft

Gibt eine CommandBars-Auflistung zurück, die die Menüleiste sowie alle Symbolleisten in Word darstellt. Nur-Lese-Zugriff.

Weitere Informationen über die Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Hinweise

Verwenden Sie die CustomizationContext-Eigenschaft, um den Kontext der Dokumentvorlage bzw. des Dokuments vor dem Öffnen der CommandBars-Auflistung festzulegen.


Beispiel zur CommandBars-Eigenschaft

In diesem Beispiel werden alle Schaltflächen der Statusleiste vergrößert und die QuickInfo aktiviert.

With CommandBars
    .LargeButtons = True
    .DisplayTooltips = True
End With

In diesem Beispiel wird die Symbolleiste Zeichnen am unteren Rand des Anwendungsfensters angezeigt.

With CommandBars("Drawing")
    .Visible = True
    .Position = msoBarBottom
End With

In diesem Beispiel wird der Symbolleiste Standard die Schaltfläche Versionen hinzugefügt.

CustomizationContext = NormalTemplate
CommandBars("Standard").Controls.Add Type:=msoControlButton, _
    ID:=2522, Before:=4


CommandName-Eigenschaft

Gibt den Namen der Prozedur zurück, durch die das angegebene integrierte Dialogfeld angezeigt wird. String Nur-Lese-Zugriff.

Hinweise

Weitere Informationen über integrierte Dialogfelder in Word finden Sie unter Anzeigen von integrierten Dialogfeldern bei Word.


Beispiel zur CommandName-Eigenschaft

In diesem Beispiel wird der Name der Prozedur FileSaveAs angezeigt, mit der das Dialogfeld Speichern unter (Menü Datei) eingeblendet wird.

MsgBox Dialogs(wdDialogFileSaveAs).CommandName


CommandParameter-Eigenschaft

Gibt den Befehlsparameter zurück, der der angegebenen Tastenkombination zugewiesen ist. String Nur-Lese-Zugriff.

Hinweis Informationen über Befehle, die Parameter brauchen, finden Sie unter Add-Methode (KeyBindings-Objekt). Verwenden Sie die Command-Eigenschaft zur Zurückgabe des Namens des Befehls, der der angegebenen Tastenkombination zugewiesen ist.


Beispiel zur CommandParameter-Eigenschaft

In diesem Beispiel wird dem Befehl FontSize eine Tastenkombination zugewiesen, mit einem Befehlsparameter von 8. Verwenden Sie die CommandParameter-Eigenschaft zur Anzeige des Befehlsparameters zusammen mit dem Namen des Befehls und der Tastenkombination.

Set aKey = KeyBindings.Add(KeyCategory:=wdKeyCategoryCommand, _
    Command:="FontSize", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyS), _
    CommandParameter:="8")
MsgBox aKey.Command & Chr$(32) & aKey.CommandParameter _
    & vbCr & aKey.KeyString


Comment-Eigenschaft

Gibt den Kommentar zurück, der mit der angegebenen Version eines Dokuments verbunden ist. String Nur-Lese-Zugriff.


Comments-Eigenschaft

Gibt eine Comments-Auflistung zurück, die alle Kommentare im angegebenen Dokument, Bereich oder in der angegebenen Markierung enthält. Nur-Lese-Zugriff.

Weitere Informationen zum Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Comments-Eigenschaft

In diesem Beispiel wird dem markierten Text ein Kommentar hinzugefügt.

ActiveDocument.ActiveWindow.View.ShowHiddenText = True
Selection.Comments.Add Range:=Selection.Range, Text:="Approved"

Dieses Beispiel vergleicht den Autorennamen jedes einzelnen Kommentars im aktiven Dokument mit dem Benutzernamen auf der Registerkarte Benutzer-Info im Dialogfeld Optionen (Menü Extras). Stimmen die Namen nicht überein, wird das Anmerkungszeichen so formatiert, dass es in Rot angezeigt wird.

For Each comm In ActiveDocument.Comments
    If comm.Author <> Application.UserName Then _
        comm.Reference.Font.ColorIndex = wdRed
Next comm


Compatibility-Eigenschaft

True, wenn die Kompatibilitätsoption aktiviert ist, die durch das Type-Argument spezifiziert wurde. Kompatibilitätsoptionen legen fest, wie ein Dokument in Microsoft Word angezeigt wird. Diese Optionen sind auf der Registerkarte Kompatibilität im Dialogfeld Optionen im Menü Extras aufgelistet. Boolean Schreib-Lese-Zugriff.

Syntax

Ausdruck.Compatibility(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Document-Objekt zurückgibt.

Type Long erforderlich. Dies kann eine der folgenden WdCompatibility-Konstanten sein.

Konstante | Beschreibung
wdAlignTablesRowByRow | True, wenn Tabellenzeilen von Word 2000 unabhängig voneinander ausgerichtet werden.
wdAutospaceLikeWW7 | True, wenn in Word 2000 automatisch Abstände wie in Word 95 einstellt werden.
wdConvMailMergeEsc | True, wenn in Word 2000 Zeichen korrekt interpretiert werden, vor denen in Seriendruck-Datenquellen von Word-Version 2.x umgekehrte Schrägstriche (\) stehen. Zum Beispiel \" wird interpretiert als ".
wdDontAdjustLineHeightInTable | True, wenn die Zeilenhöhe in Tabellen von Word 2000 nicht an die Rasterhöhe angpasst wird.
wdDontBalanceSingleByteDoubleByteWidth | True, wenn die Breite von Single Byte-Zeichen und Double Byte-Zeichen in Word 2000 nicht ausgeglichen wird.
wdDontULTrailSpace | True, wenn nachstehende Leerzeichen in Word 2000 nicht unterstrichen werden.
wdDontUseHTMLParagraphAutoSpacing | True, wenn in Word 2000 kein automatischer Absatzabstand für HTML verwendet wird.
wdExactOnTop | True, wenn in Word 2000 Text am oberen Rand des Bereichs platziert wird, der bei der Verwendung von genauem Zeilenabstand für die Zeile reserviert ist.
wdExpandShiftReturn | True, wenn in Word 2000 Zeichenabstände in Zeilen erweitert werden, die mit Umschalt-Eingabe enden.
wdFootnoteLayoutLikeWW8 | True, wenn das Fußnotenlayout in Word 2000 wie in Word 6.x/95/97 gestaltet wird.
wdForgetLastTabAlignment | True, wenn beim Einfügen eines neuen Tabstopps die letzte Tabulatorausrichtung von Word 2000 ignoriert wird.
wdLayoutRawTableWidth | True, wenn das Tabellenlayout in Word 2000 mit ungefährer Breite erfolgt.
wdLayoutTableRowsApart | True, wenn das Layout von Tabellenzeilen in Word 2000 getrennt voneinander erfolgt.
wdLeaveBackslashAlone | True, wenn umgekehrte Schrägstriche in Word 2000 nicht in Yen-Zeichen konvertiert werden.
wdLineWrapLikeWord6 | True, wenn der Zeilenumbruch in Word 2000 wie in Word 6.0 erfolgt.
wdMWSmallCaps | True, wenn Kapitälchen-Formatierung in Word 2000 wie in Word-Version 5.x für den Macintosh zugewiesen wird, wodurch etwas größere Kapitälchen erzeugt werden.
wdNoColumnBalance | True, wenn in Word 2000 kein Textspaltenausgleich bei fortlaufendem Abschnittswechsel durchgeführt wird.
wdNoExtraLineSpacing | True, wenn der Zeilenabstand in Word 2000 wie in WordPerfect-Version 5.x behandelt wird. Dieses Argument steht nur in Word-Version 7.0 zur Verfügung.
wdNoLeading | True, wenn Textzeilen in Word 2000 wie in Word-Version 5.x für den Macintosh ohne Durchschuss angezeigt werden.
wdNoSpaceForUL | True, wenn in Word 2000 bei Unterstreichung kein zusätzlicher Leerraum hinzugefügt wird. Dieses Argument steht nur in Word-Version 7.0 zur Verfügung.
wdNoSpaceRaiseLower | True, wenn in Word 2000 bei Hoch-/Tiefstellung kein zusätzlicher Leerraum hinzugefügt wird.
wdNoTabHangIndent | True, wenn in Word 2000 einem Absatz, der mit einem hängenden Einzug formatiert ist, nicht automatisch ein Tabstopp hinzugefügt wird.
wdOrigWordTableRules | True, wenn in Word 2000 Tabellenrahmen wie bei Word-Version 5.x für den Macintosh zusammengefügt werden.
wdPrintBodyTextBeforeHeader | True, wenn die Haupttextebene in Word 2000 vor den Kopf- und Fußzeilen-Ebenen gedruckt wird (die normale Reihenfolge wird umgekehrt). Dadurch kann Word in der Haupttext-Ebene PostScript-Codes verarbeiten wie bei Word-Version 5.x für den Macintosh.
wdPrintColBlack | True, wenn in Word 2000 Farben auf Schwarzweißdruckern schwarz gedruckt werden.
wdShapeLayoutLikeWW8 | True, wenn in Word 2000 automatische Layoutformen wie in Word 97 verwendet werden.
wdShowBreaksInFrames | True, wenn in Word 2000 manuelle ("harte") Seiten- oder Spaltenwechsel in den jeweiligen Frames angezeigt werden.
wdSpacingInWholePoints | True, wenn Maße für Zeichenabstände in Word 2000 zur nächsten ganzen Zahl auf- oder abgerundet werden.
wdSubFontBySize | True, wenn in Word 2000 Schriftarten ersetzt werden, die auf dem Schriftgrad von Dokumenten in WordPerfect-Version 6.0 basieren. Dieses Argument steht nur in Word-Version 7.0 zur Verfügung.
wdSuppressBottomSpacing | True, wenn in Word 2000 zusätzlicher Zeilenabstand unten auf der Seite entfernt wird.
wdSuppressSpBfAfterPgBrk | True, wenn in Word 2000 Leerraum vor oder nach harten Seiten- und Spaltenwechseln entfernt wird.
wdSuppressTopSpacing | True, wenn in Word 2000 zusätzlicher Zeilenabstand oben auf der Seite entfernt wird.
wdSuppressTopSpacingMac5 | True, wenn in Word 2000 zusätzlicher Leerraum oben auf der Seite wie bei Word-Version 5.x für den Macintosh behandelt wird.
wdSwapBordersFacingPages | True, wenn in Word 2000 auf ungeraden Seiten auf der rechten Seite ein linker Absatzrahmen (kein Kasten) gedruckt wird, wenn im Menü Datei im Dialogfeld Seite einrichten auf der Registerkarte Seitenlayout das Kontrollkästchen Gerade/ungerade anders oder auf der Registerkarte Seitenränder das Kontrollkästchen Gegenüberliegende Seiten markiert ist.
wdTransparentMetafiles | True, wenn in Word 2000 die Fläche hinter Metafile-Grafiken nicht "geleert" wird.
wdTruncateFontHeight | True, wenn in Word 2000 der Schriftgrad wie bei WordPerfect-Version 6.x für Windows auf- oder abgerundet wird. Dieses Argument steht nur in Word-Version 7.0 zur Verfügung.
wdUsePrinterMetrics | True, wenn in Word 2000 Druckermaße für das Layout des Dokuments verwendet werden.
wdUseWord97LineBreakingRules | True, wenn in Word 2000 für asiatischen Text die Regeln für den Zeilenumbruch aus Word 97 verwendet werden.
wdWPJustification | True, wenn in Word 2000 Text im Blocksatz wie bei WordPerfect-Version 6.x angeordnet wird.
wdWPSpaceWidth | True, wenn in Word 2000 die Standardbreite der Abstände zwischen Wörtern so festgelegt wird, dass sie der Standardbreite von WordPerfect-Version 5.x für Windows und WordPerfect-Version 6.0 für DOS entspricht.
wdWrapTrailSpaces | True, wenn in Word 2000 Leerzeichen am Zeilenende in die nächste Zeile umbrochen werden.
wdWW6BorderRules | True, wenn in Word 2000 linke und rechte Begrenzungen von Textzeilen in Rahmen wie in Word-Version 6.x behandelt werden.

Hinweise

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt von der gewählten bzw. installierten Sprachunterstützung (z. B. Deutsch Deutschland) ab.


Beispiel zur Compatibility-Eigenschaft

In diesem Beispiel wird für das aktive Dokument die Option "Abstand vor" nach Seiten- oder Spaltenwechsel unterdrücken auf der Registerkarte Kompatibilität im Dialogfeld Optionen im Menü Extras aktiviert.

ActiveDocument.Compatibility(wdSuppressSpBfAfterPgBrk) = True

In diesem Beispiel wird die Option Bei hängendem Einzug keinen automatischen Tabstop hinzufügen ein- oder ausgeschaltet.

ActiveDocument.Compatibility(wdNoTabHangIndent) = Not _
    ActiveDocument.Compatibility(wdNoTabHangIndent)


 Compiled-Eigenschaft

Compiled-Eigenschaft

True, wenn es sich beim angegebenen Add-In um eine Word Add-In-Bibliothek (WLL) handelt, False, wenn es sich beim Add-In um eine Dokumentvorlage handelt. Boolean Nur-Lese-Zugriff.


Beispiel zur Compiled-Eigenschaft

In diesem Beispiel wird ermittelt, wie viele WLLs zur Zeit geladen sind.

count = 0
For Each aAddin in Addins
    If aAddin.Compiled = True And aAddin.Installed = True Then
        count = count + 1
    End If
Next aAddin
MsgBox Str(count) & " WLL's are loaded"

Wenn es sich beim ersten Add-In um eine Dokumentvorlage handelt, wird die Vorlage aus dem Speicher entfernt und geöffnet.

If Addins(1).Compiled = False Then
    Addins(1).Installed = False
    Documents.Open FileName:=AddIns(1).Path _
        & Application.PathSeparator _
        & AddIns(1).Name
End If


ComposeStyle-Eigenschaft

Gibt ein Style-Objekt zurück, das die zum Verfassen von neuen E-Mail-Nachrichten verwendete Formatvorlage darstellt. Nur-Lese-Zugriff.


Beispiel zur ComposeStyle-Eigenschaft

In diesem Beispiel wird der Name der Standardformatvorlage angezeigt, das zum Verfassen von neuen E-Mail-Nachrichten verwendet wird.

MsgBox Application.EmailOptions.ComposeStyle.NameLocal

In diesem Beispiel wird die Schriftfarbe der zum Verfassen von neuen E-Mail-Nachrichten verwendeten Standardformatvorlage geändert.

Application.EmailOptions.ComposeStyle.Font.Color = _
    wdColorBrightGreen


ConfirmConversions-Eigenschaft

True, wenn Word das Dialogfeld Datei konvertieren vor dem Öffnen oder Einfügen einer Datei, bei der es sich nicht um ein Word-Dokument oder eine Vorlage handelt, anzeigt. Im Dialogfeld Datei konvertieren wählt der Benutzer das Format, aus dem die Datei konvertiert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ConfirmConversions-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass das Dialogfeld Datei konvertieren immer beim Öffnen einer Datei angezeigt wird, bei der es sich nicht um ein Word-Dokument oder eine Vorlage handelt.

Options.ConfirmConversions = True

In diesem Beispiel wird der aktuelle Status der Option Konvertierung beim Öffnen bestätigen auf der Registerkarte Allgemein im Dialogfeld Optionen zurückgegeben.

temp = Options.ConfirmConversions


ConnectString-Eigenschaft

Gibt die Verbindungszeichenfolge für die angegebene Seriendruck-Datenquelle zurück. String Nur-Lese-Zugriff.


Beispiel zur ConnectString-Eigenschaft

In diesem Beispiel wird ein neues Hauptdokument erzeugt und die Tabelle "Customers" aus der Microsoft Access-Datenbank "Northwind.mdb" zugeordnet. Die Verbindungszeichenfolge wird in einem Meldungsfeld angezeigt.

Set myDoc = Documents.Add
With myDoc.MailMerge
    .MainDocumentType = wdFormLetters
    .OpenDataSource _
        Name:="C:\MSOffice\Access\Samples\Northwind.mdb", _
        LinkToSource:=True, AddToRecentFiles:=False, _
        Connection:="TABLE Customers
    MsgBox .DataSource.ConnectString
End With


ConsecutiveHyphensLimit-Eigenschaft

Gibt die maximale Anzahl von fortlaufenden Zeilen zurück, die mit Bindestrichen enden können, oder legt sie fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf 0 (Null) eingestellt wird, kann eine beliebige Anzahl von fortlaufenden Zeilen mit Bindestrichen enden.


Beispiel zur ConsecutiveHyphensLimit-Eigenschaft

In diesem Beispiel wird für MyReport.doc die automatische Silbentrennung aktiviert und die Anzahl der fortlaufenden Zeilen, die mit Bindestrichen enden können, auf zwei begrenzt.

With Documents("MyReport.doc")
    .AutoHyphenation = True
    .ConsecutiveHyphensLimit = 2
End With

In diesem Beispiel wird keine Begrenzung für die Anzahl der fortlaufenden Zeilen festgelegt, die mit Bindestrichen enden können.

ActiveDocument.ConsecutiveHyphensLimit = 0


Container-Eigenschaft

Gibt das Objekt zurück, das die Containeranwendung für das angegebene OLE-Objekt darstellt. Nur-Lese-Zugriff.

Hinweise

Diese Eigenschaft stellt einen Zugriff auf die Container-Eigenschaft des angegebenen Dokuments zur Verfügung, wenn das Dokument in einer anderen Anwendung als im OLE-Objekt eingebettet wurde.

Die Container-Eigenschaft stellt auch einen Pfad zum Objekt-Modell der Containeranwendung bereit, wenn ein Word-Dokument als ActiveX-Dokument geöffnet wird, z. B. wenn ein Word-Dokument in der Microsoft Office-Sammelmappe oder mit dem Internet Explorer geöffnet wird.


Beispiel zur Container-Eigenschaft

In diesem Beispiel wird der Name der Containeranwendung für die erste Form im aktiven Dokument angezeigt. Das Beispiel funktioniert nur, wenn es sich bei der Form um ein OLE-Objekt handelt.

Msgbox ActiveDocument.Shapes(1).OLEFormat.Object.Container.Name


ContainingRange-Eigenschaft

Gibt ein Range-Objekt zurück, das das gesamte Protokoll in einer Datenreihe mit Formen darstellt, die verknüpfte Textpositionsrahmen haben, zu dem der angegebene Textpositionsrahmen gehört. Nur-Lese-Zugriff.


Beispiel zur ContainingRange-Eigenschaft

Dieses Beispiel führt die Rechtschreibprüfung in "TextFeld 1" und bei Text in Textpositionsrahmen durch, die mit "TextFeld 1" verknüpft sind.

Set myStory = ActiveDocument.Shapes("TextBox 1") _
    .TextFrame.ContainingRange
myStory.CheckSpelling


 Content-Eigenschaft

Content-Eigenschaft

Gibt ein Range-Objekt zurück, das die Haupt-Dokumentkomponente darstellt. Nur-Lese-Zugriff.

Hinweise

Die folgenden zwei Anweisungen sind äquivalent:

Set mainStory = ActiveDocument.Content
Set mainStory = ActiveDocument.StoryRanges(wdMainTextStory)


Beispiel zur Content-Eigenschaft

In diesem Beispiel werden die Schriftart und der Schriftgrad des Textes im aktiven Dokument in Arial 10 Punkt geändert.

Set myRange = ActiveDocument.Content
With myRange.Font
    .Name = "Arial"
    .Size = 10
End With

In diesem Beispiel wird am Ende des Dokuments "Changes.doc" Text eingefügt. Die For Each...Next-Anweisung wird zum Ermitteln verwendet, ob das Dokument geöffnet ist.

For Each aDocument In Documents
    If InStr(LCase$(aDocument.Name), "changes.doc") Then
        Set myRange = Documents("Changes.doc").Content
        myRange.InsertAfter "the end."
    End If
Next aDocument


Context-Eigenschaft

Liefert ein Objekt, das die Speicherstelle für die angegebene Tastenzuordnung darstellt. Diese Eigenschaft gibt ein Document-, Template- oder Application-Objekt zurück. Nur-Lese-Zugriff.

Hinweis Integrierte Tastenzuordnungen (z. B. STRG+K für Kursiv) liefern das Application-Objekt als Kontext. Alle von Ihnen hinzugefügten Tastenkombinationen liefern ein Document- oder Template-Objekt, abhängig vom Kontext der Anpassung zum Zeitpunkt, als das KeyBinding-Objekt hinzugefügt wurde.


Beispiel zur Context-Eigenschaft

In diesem Beispiel wird der Name des Dokuments oder der Dokumentvorlage angezeigt, in der das Makro "Makro1" gespeichert ist.

Set kb = KeysBoundTo(KeyCategory:=wdKeyCategoryMacro, _
    Command:="Macro1")
MsgBox kb.Context.Name

In diesem Beispiel wird die Taste F2 dem Befehl Kursiv zugewiesen und dann werden mit der For Each...Next-Schleife die Tasten mit dem Kontext angezeigt, die dem Befehl Kursiv zugewiesen wurden.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCategory:=wdKeyCategoryCommand, _
    Command:="Italic", KeyCode:=wdKeyF2
For Each oKey In _
        KeysBoundTo(KeyCategory:=wdKeyCategoryCommand, _
        Command:="Italic")
    MsgBox oKey.KeyString & vbCr & oKey.Context.Name
Next


ContinuationNotice-Eigenschaft

Gibt ein Range-Objekt zurück, das den Fortsetzungshinweis einer Fußnote oder Endnote darstellt. Nur-Lese-Zugriff.


Beispiel zur ContinuationNotice-Eigenschaft

In diesem Beispiel wird der Fortsetzungshinweis der aktuellen Fußnote durch den Text "Continued..." ersetzt.

With ActiveDocument.Footnotes.ContinuationNotice
    .Delete
    .InsertBefore "Continued..."
End With


ContinuationSeparator-Eigenschaft

Gibt ein Range-Objekt zurück, das die Fortsetzungstrennlinie einer Fußnote oder Endnote repräsentiert. Nur-Lese-Zugriff.


Beispiel zur ContinuationSeparator-Eigenschaft

In diesem Beispiel wird die Fortsetzungstrennlinie der aktuellen Endnote durch eine Reihe von Unterstrichen ersetzt.

With ActiveDocument.Endnotes.ContinuationSeparator
    .Delete
    .InsertBefore "____"
End With


Contrast-Eigenschaft

Gibt den Kontrast für die angegebene Grafik oder das angegebene OLE-Objekt zurück oder legt ihn fest. Der Wert für diese Eigenschaft muss eine Zahl zwischen 0,0 (der geringste Kontrast) und 1,0 (der größte Kontrast) sein. Single Schreib-Lese-Zugriff.


Beispiel zur Contrast-Eigenschaft

In diesem Beispiel wird der Kontrast für Form eins in myDocument festgelegt. Form eins muss eine Grafik oder ein OLE-Objekt sein.

Set myDocument = Documents(1)
myDocument.Shapes(1).PictureFormat.Contrast = 0.8


ConvertHighAnsiToFarEast-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word converts text that is associated with an East Asian font to the appropriate font when it opens a document. Read/write Boolean.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur ConvertHighAnsiToFarEast-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to convert text that is associated with an East Asian font to the appropriate font when it opens a document.

Options.ConvertHighAnsiToFarEast = True


ConvertMacWordChevrons-Eigenschaft

Steuert die Umwandlung von Text, der in Chevron-Zeichen (« ») eingeschlossen ist, in Seriendruckfelder. Long Schreib-Lese-Zugriff.

Kann eine der folgenden WdChevronConvertRule-Konstanten sein:

Konstante | Beschreibung
wdAlwaysConvert | Das Konvertierungsprogramm versucht, Text, der in Chevron-Zeichen (« ») eingeschlossen ist, in Seriendruckfelder umzuwandeln.
wdNeverConvert | Das Konvertierungsprogramm lässt den Text durch, ohne eine Interpretation zu versuchen.
wdAskToConvert, wdAskToNotConvert | Das Konvertierungsprogramm fordert den Benutzer auf, anzugeben, ob Chevron-Zeichen umgewandelt oder nicht umgewandelt werden sollen, wenn ein Word für Macintosh-Dokument geöffnet wird.

Hinweise

Dokumente im Format Word für Macintosh Version 4.0 und 5.x verwenden Chevron-Zeichen zum Kennzeichnen von Seriendruckfeldern.


Beispiel zur ConvertMacWordChevrons-Eigenschaft

In diesem Beispiel wird die ConvertMacWordChevrons-Eigenschaft so festgelegt, dass Text, der in Chevron-Zeichen eingeschlossen ist, in Seriendruckfelder umgewandelt wird. Anschließend wird das Dokument "Mac Word Dokument" geöffnet.

FileConverters.ConvertMacWordChevrons = wdAlwaysConvert
Documents.Open FileName:="C:\Documents\Mac Word Document"


CorrectCapsLock-Eigenschaft

True, wenn Word automatisch Instanzen korrigiert, bei denen Sie die FESTSTELLTASTE bei der Eingabe versehentlich gedrückt haben. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectCapsLock-Eigenschaft

In diesem Beispiel wird festgestellt, ob Word so konfiguriert ist, dass Fehler mit der FESTSTELLTASTE automatisch korrigiert werden.

If AutoCorrect.CorrectCapsLock = True Then
    MsgBox "Correct CAPS LOCK is active."
Else
    MsgBox "Correct CAPS LOCK is not active."
End If


CorrectDays-Eigenschaft

True, wenn Word automatisch den ersten Buchstaben von Wochentagen in einen Großbuchstaben umwandelt. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectDays-Eigenschaft

In diesem Beispiel wandelt Word automatisch den ersten Buchstaben von Wochentagen in einen Großbuchstaben um.

AutoCorrect.CorrectDays = True

In diesem Beispiel wird der Wert der CorrectDays-Eigenschaft umgeschaltet.

AutoCorrect.CorrectDays = Not AutoCorrect.CorrectDays


CorrectHangulAndAlphabet-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word automatically applies the correct font to Latin words typed in the middle of hangul text or vice versa. Read/write Boolean.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CorrectHangulAndAlphabet-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically apply the correct font to Latin words typed in the middle of hangul text or vice versa.

AutoCorrect.CorrectHangulAndAlphabet = True


CorrectHangulEndings-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word automatically corrects hangul endings when replacing hangul text. Read/write Boolean.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur CorrectHangulEndings-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to automatically correct hangul endings when replacing hangul text.

With Selection.Find
    .Forward = True
    .Wrap = wdFindContinue
    .Format = False
    .CorrectHangulEndings = True
End With


CorrectInitialCaps-Eigenschaft

True, wenn Word automatisch den zweiten Buchstaben in einen Kleinbuchstaben umwandelt, wenn die ersten zwei Buchstaben eines Worts als Großbuchstaben eingegeben wurden. Aus "WOrt" wird zum Beispiel nach der Korrektur "Wort". Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectInitialCaps-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word Fehler bei Großbuchstaben am Wortanfang automatisch korrigiert.

AutoCorrect.CorrectInitialCaps = True


CorrectKeyboardSetting-Eigenschaft

True, wenn Microsoft Word bei der Eingabe von Text in einer von der Tastatursprache abweichenden Sprache die Wörter von automatisch in ihrem jeweiligen Alphabet darstellt. Boolean Schreib-Lese-Zugriff.

Hinweise

Um die CorrectKeyboardSetting-Eigenschaft verwenden zu können, muss die CheckLanguage-Eigenschaft auf True gesetzt sein.

Weitere Informationen über das Verwenden von Word mit mehreren Sprachen finden Sie unter Fehlerbehebung bei mehrsprachigem Text und automatischer Spracherkennung.


Beispiel zur CorrectKeyboardSetting-Eigenschaft

In diesem Beispiel wird ein Dialogfeld angezeigt, in dem der Benutzer wählen kann, ob Fremdwörter von Microsoft Word automatisch in ihrem jeweiligen Alphabet dargestellt werden sollen.

x = MsgBox("Do you want Microsoft Word to tranpose " _
    & "foreign words to their native alphabet?", _
    vbYesNo
If x = vbYes Then
    Application.CheckLanguage = True
    AutoCorrect.CorrectKeyboardSetting = True
    MsgBox "Automatic keyboard correction enabled!"
End If


CorrectSentenceCaps-Eigenschaft

True, wenn Word automatisch den ersten Buchstaben eines Satzes als Großbuchstaben darstellt. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectSentenceCaps-Eigenschaft

In diesem Beispiel wird der Wert der CorrectSentenceCaps-Eigenschaft umgeschaltet.

AutoCorrect.CorrectSentenceCaps = Not _
    AutoCorrect.CorrectSentenceCaps


Count-Eigenschaft

Gibt die Anzahl der Elemente in der angegebenen Auflistung zurück. Long Nur-Lese-Zugriff.


CountBy-Eigenschaft

Gibt zurück, neben jeder wievielten Zeile eine Zeilennummer angezeigt wird, oder legt dies fest. Wenn Sie die CountBy-Eigenschaft beispielsweise auf 5 setzen, wird neben jeder fünften Zeile eine Zeilennummer angezeigt. Die Zeilennummern werden nur in der Seitenlayoutansicht und der Seitenansicht angezeigt. Long Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft ist nur wirksam, wenn die Active-Eigenschaft des LineNumbering-Objekts auf True gesetzt ist.


Beispiel zur CountBy-Eigenschaft

In diesem Beispiel wird die Zeilennummerierung für das aktive Dokument eingeschaltet. Die Zeilennummer wird auf jeder fünften Zeile angezeigt, und die Zeilennummerierung beginnt für jeden neuen Abschnitt von vorn.

With ActiveDocument.PageSetup.LineNumbering
    .Active = True
    .CountBy = 5
    .RestartMode = wdRestartSection
End With


Country-Eigenschaft

Gibt die Ländereinstellung des Systems zurück. Long Nur-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdCountry-Konstanten handeln:

wdArgentina

wdBrazil

wdCanada

wdChile

wdChina

wdDenmark

wdFinland

wdFrance

wdGermany

wdIceland

wdItaly

wdJapan

 wdKorea

wdLatinAmerica

wdMexico

wdNetherlands

wdNorway

wdPeru

wdSpain

wdSweden

wdTaiwan

wdUK

wdUS

wdVenezuela


Beispiel zur Country-Eigenschaft

Wenn die Country-Eigenschaft wdGermany zurückgibt, wird der Wert für den oberen Seitenrand von Punkt in Zentimeter konvertiert.

If System.Country = wdUS Then
    topMgn = ActiveDocument.PageSetup.TopMargin
    MsgBox "Top margin is " & PointsToInches(topMgn)
End If


CreateBackup-Eigenschaft

True, wenn Word beim Speichern eines Dokuments immer eine Sicherungskopie anlegt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die CreateBackup- und AllowFastSave-Eigenschaften können nicht gleichzeitig auf True gesetzt werden.


Beispiel zur CreateBackup-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass automatisch eine Sicherungskopie angelegt wird und dann wird das aktive Dokument gespeichert.

Options.CreateBackup = True
ActiveDocument.Save

In diesem Beispiel wird der aktuelle Status der Option Sicherungskopie immer erstellen auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.CreateBackup


Creator-Eigenschaft

Gibt eine 32-Bit-Ganzzahl zurück, die auf die Anwendung verweist, in der das angegebene Objekt erstellt wurde. Falls z. B. das Objekt in Microsoft Word erstellt wurde, gibt diese Eigenschaft die hexadezimale Zahl 4D535744 zurück, die für die Zeichenfolge "MSWD" steht. Der Wert kann auch durch die wdCreatorCode-Konstante repräsentiert werden. Long Nur-Lese-Zugriff.

Hinweise

Die Creator-Eigenschaft ist für die Verwendung mit dem Macintosh bestimmt, wo jede Anwendung einen aus vier Zeichen bestehenden Erstellungscode aufweist. Der Erstellungscode von Microsoft Word lautet beispielsweise MSWD. Weitere Informationen über diese Eigenschaft finden Sie im Sprachenverzeichnis der Macintosh-Edition von Microsoft Office 98.


Beispiel zur Creator-Eigenschaft

Dieses Beispiel zeigt in einer Meldung an, mit welcher Anwendung myObject erstellt wurde.

Set myObject = ActiveDocument
If myObject.Creator = wdCreatorCode Then
    MsgBox "This is a Microsoft Word object"
Else
    MsgBox "This is not a Microsoft Word object"
End If


CropBottom-Eigenschaft

Gibt die Punktanzahl zurück, die vom unteren Ende des angegebenen Bildes oder OLE-Objekts abgeschnitten wird, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Wenn Sie z. B. ein Bild mit der Originalhöhe 100 Punkt einfügen und es skalieren, um die Höhe auf 200 Punkt zu ändern, und anschließend für die CropBottom-Eigenschaft 50 festlegen, dann werden 100 Punkt (nicht 50) vom unteren Ende des Bildes abgeschnitten.


Beispiel zur CropBottom-Eigenschaft

In diesem Beispiel wird ein 20 Punkt großer Teil vom unteren Ende der Form 3 im aktiven Dokument abgeschnitten. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

ActiveDocument.Shapes(3).PictureFormat.CropBottom = 20

In diesem Beispiel wird der vom Benutzer festgelegte prozentuale Anteil vom unteren Ende der gewählten Form abgeschnitten, unabhängig davon, ob die Form skaliert wurde oder nicht. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

percentToCrop = InputBox("What percentage do you want " _
    & "to crop off the bottom of this picture?")
Set shapeToCrop = _
    ActiveDocument.ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropBottom = cropPoints


CropLeft-Eigenschaft

Gibt die Punktanzahl zurück, die von der linken Seite des angegebenen Bildes oder OLE-Objekts abgeschnitten wird, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Wenn Sie z. B. ein Bild mit der Originalhöhe 100 Punkt einfügen und es skalieren, um die Höhe auf 200 Punkt zu ändern, und anschließend für die CropLeft-Eigenschaft 50 festlegen, dann werden 100 Punkt (nicht 50) von der linken Seite des Bildes abgeschnitten.


Beispiel zur CropLeft-Eigenschaft

In diesem Beispiel wird ein 20 Punkt großer Teil von der linken Seite der Form 3 im aktiven Dokument abgeschnitten. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

ActiveDocument.Shapes(3).PictureFormat.CropLeft = 20

In diesem Beispiel wird der vom Benutzer festgelegte prozentuale Anteil von der linken Seite der gewählten Form abgeschnitten, unabhängig davon, ob die Form skaliert wurde oder nicht. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

percentToCrop = InputBox("What percentage do you want " _
    & "to crop off the left of this picture?")
Set shapeToCrop = _
    ActiveDocument.ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropLeft = cropPoints


CropRight-Eigenschaft

Gibt die Punktanzahl zurück, die von der rechten Seite des angegebenen Bildes oder OLE-Objekts abgeschnitten wird, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Wenn Sie z. B. ein Bild einfügen, dessen Originalbreite 100 Punkt beträgt, und es skalieren, um die Breite auf 200 Punkt zu ändern, und anschließend für die CropRight-Eigenschaft 50 festlegen, dann werden 100 Punkt (nicht 50) von der rechten Seite des Bildes abgeschnitten.


Beispiel zur CropRight-Eigenschaft

In diesem Beispiel wird ein 20 Punkt großer Teil von der rechten Seite der Form 3 im aktiven Dokument abgeschnitten. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

ActiveDocument.Shapes(3).PictureFormat.CropRight = 20

In diesem Beispiel wird der vom Benutzer festgelegte prozentuale Anteil von der rechten Seite der gewählten Form abgeschnitten, unabhängig davon, ob die Form skaliert wurde oder nicht. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

percentToCrop = InputBox("What percentage do you want " _
    & "to crop off the right of this picture?")
Set shapeToCrop = _
    ActiveDocument.ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropRight = cropPoints


CropTop-Eigenschaft

Gibt die Punktanzahl zurück, die vom oberen Ende des angegebenen Bildes oder OLE-Objekts abgeschnitten wird, oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweis Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Wenn Sie z. B. ein Bild mit der Originalhöhe 100 Punkt einfügen und es skalieren, um die Höhe auf 200 Punkt zu ändern, und anschließend für die CropTop-Eigenschaft 50 festlegen, dann werden 100 Punkt (nicht 50) vom oberen Ende des Bildes abgeschnitten.


Beispiel zur CropTop-Eigenschaft

In diesem Beispiel wird ein 20 Punkt großer Teil vom oberen Ende der Form 3 im aktiven Dokument abgeschnitten. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

ActiveDocument.Shapes(3).PictureFormat.CropTop = 20

In diesem Beispiel wird der vom Benutzer festgelegte prozentuale Anteil vom oberen Ende der gewählten Form abgeschnitten, unabhängig davon, ob die Form skaliert wurde oder nicht. Dieses Beispiel funktioniert nur, wenn es sich bei der Form um ein Bild oder ein OLE-Objekt handelt.

percentToCrop = InputBox("What percentage do you want " _
    & "to crop off the top of this picture?")
Set shapeToCrop = _
    ActiveDocument.ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropTop = cropPoints


CurrentEmailAuthor-Eigenschaft

Gibt ein EmailAuthor-Objekt zurück, das den Autor der aktuellen E-Mail-Nachricht darstellt. Nur-Lese-Zugriff.


Beispiel zur CurrentEmailAuthor-Eigenschaft

In diesem Beispiel wird der Name der Formatvorlage zurückgegeben, die dem Autor der aktuellen E-Mail zugeordnet ist.

MsgBox ActiveDocument.Email _
    .CurrentEmailAuthor.Style.NameLocal


Cursor-Eigenschaft

Gibt den Status (die Form) des Zeigers zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdCursorType-Konstanten handeln: wdCursorIBeam, wdCursorNormal, wdCursorNorthwestArrow oder wdCursorWait. Long Schreib-Lese-Zugriff.


CursorMovement-Eigenschaft

Sprachspezifische Informationen

Returns or sets how the insertion point progresses within bidirectional text. Read/write Long.

Can be either of the following WdCursorMovement constants.

Constant | Description
wdCursorMovementLogical | Insertion point progresses according to the direction of the language Microsoft Word detects.
wdCursorMovementVisual | Insertion point progresses to the next visually adjacent character.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur CursorMovement-Eigenschaft

Sprachspezifische Informationen

This example sets the insertion point to progress to the next visually adjacent character as it moves through bidirectional text.

Options.CursorMovement = wdCursorMovementVisual


CustomDictionaries-Eigenschaft

Gibt ein Dictionaries-Objekt zurück, das die Sammlung der aktiven benutzerdefinierten Wörterbücher darstellt. Aktive benutzerdefinierte Wörterbücher werden in einem Kontrollkästchen im Dialogfeld Benutzerwörterbücher markiert. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur CustomDictionaries-Eigenschaft

In diesem Beispiel wird ein neues, leeres, benutzerdefiniertes Wörterbuch in die Sammlung aufgenommen. Die Pfadangabe und der Dateiname des neuen benutzerdefinierten Wörterbuchs werden in einem Meldungsfeld angezeigt.

Set myHome = CustomDictionaries.Add(Filename:="Home.dic")
Msgbox myHome.Path & Application.PathSeparator & myHome.Name

In diesem Beispiel werden alle benutzerdefinierten Wörterbücher entfernt, so dass keine benutzerdefinierten Wörterbücher aktiv sind. Die Dateien der benutzerdefinierten Wörterbücher werden jedoch nicht gelöscht.

CustomDictionaries.ClearAll

In diesem Beispiel werden die Namen aller benutzerdefinierten Wörterbücher in der Sammlung angezeigt.

For Each di In CustomDictionaries
    MsgBox di.Name
Next di


CustomDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle benutzerdefinierten Dokumenteigenschaften des angegebenen Dokuments darstellt. Nur-Lese-Zugriff.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung erhalten Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Hinweise

Verwenden Sie die BuiltInDocumentProperties-Eigenschaft, um die Auflistung integrierter Dokumenteigenschaften zurückzugeben.


Beispiel zur CustomDocumentProperties-Eigenschaft

In diesem Beispiel wird eine Liste der benutzerdefinierten Dokumenteigenschaften am Ende des aktiven Dokuments eingefügt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
For Each prop In ActiveDocument.CustomDocumentProperties
    With myRange
        .InsertParagraphAfter
        .InsertAfter prop.Name & "= "
        .InsertAfter prop.Value
    End With
Next

In diesem Beispiel wird "Sales.doc" mit einer benutzerdefinierten, integrierten Eigenschaft versehen.

thename = InputBox("Please type your name", "Name")
Documents("Sales.doc").CustomDocumentProperties.Add _
    Name:="YourName", LinkToContent:=False, Value:=thename, _
    Type:=msoPropertyTypeString


CustomizationContext-Eigenschaft

Gibt ein Template- oder Document-Objekt zurück oder legt es fest, das die Dokumentvorlage oder das Dokument darstellt, in dem Änderungen der Menüleisten, Symbolleisten und Tastenbelegungen gespeichert sind. Entspricht dem Wert im Feld Speichern in auf der Registerkarte Befehle im Dialogfeld Anpassen (Menü Extras). Schreib-Lese-Zugriff.


Beispiel zur CustomizationContext-Eigenschaft

In diesem Beispiel wird die Tastenkombination ALT+CTRL+W dem Befehl DateiSchließen zugewiesen. Die Tastaturanpassung wird in der Dokumentvorlage Normal gespeichert.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyControl, _
    wdKeyAlt, wdKeyW), _
    KeyCategory:=wdKeyCategoryCommand, Command:="FileClose"

In diesem Beispiel wird die Schaltfläche Version der Standard-Symbolleiste hinzugefügt. Die Anpassung der Symbolleiste wird in der mit dem aktiven Dokument verbundenen Dokumentvorlage gespeichert.

CustomizationContext = ActiveDocument.AttachedTemplate
Application.CommandBars("Standard").Controls.Add _
    Type:=msoControlButton, _
    ID:=2522, Before:=8


CustomLabels-Eigenschaft

Gibt eine CustomLabels-Sammlung zurück, die die verfügbaren benutzerdefinierten Adressetiketten darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur CustomLabels-Eigenschaft

In diesem Beispiel werden ein neues benutzerdefiniertes Adressetikett mit der Bezeichnung "AdminAddress" und eine Seite mit Adressetiketten mit einer vordefinierten Absenderadresse erstellt.

addr = "Administration" & vbCr & "Mail Stop 22-16"
Set myLabel = Application.MailingLabel _
    .CustomLabels.Add(Name:="AdminAddress", DotMatrix:= False)
With myLabel
    .Height = InchesToPoints(0.5)
    .Width = InchesToPoints(1)
    .HorizontalPitch = InchesToPoints(2.06)
    .VerticalPitch = InchesToPoints(0.5)
    .NumberAcross = 4
    .NumberDown = 20
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.28)
    .TopMargin = InchesToPoints(0.5)
End With
Application.MailingLabel.CreateNewDocument _
    Name:="AdminAddress", Address:=addr


CustomTab-Eigenschaft

True, wenn der angegebene Tabstopp ein benutzerdefinierter Tabstopp ist. Boolean Nur-Lese-Zugriff.


Beispiel zur CustomTab-Eigenschaft

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments die Auflistung von Tabstopps durchlaufen, und alle benutzerdefinierten Tabstopps, die gefunden werden, werden links ausgerichtet.

For each ts in ActiveDocument.Paragraphs(1).TabStops
    If ts.CustomTab = True Then ts.Alignment = wdAlignTabLeft
Next ts


DashStyle-Eigenschaft

Gibt die Strichart für die angegebene Linie zurück oder legt sie fest. Dabei kann es sich um eine der folgenden MsoLineDashStyle-Konstanten handeln: msoLineDash, msoLineDashDot, msoLineDashDotDot, msoLineDashStyleMixed, msoLineLongDash, msoLineLongDashDot, msoLineRoundDot, msoLineSolid oder msoLineSquareDot. Long Schreib-Lese-Zugriff.


Beispiel zur DashStyle-Eigenschaft

In diesem Beispiel wird eine blaue, gestrichelte Linie zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


Data-Eigenschaft

Gibt Daten in einem ADDIN-Feld zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweis Die Daten sind in der Feldfunktion oder dem Ergebnis nicht sichtbar; Sie können nur auf die Daten Zugriff erhalten, indem der Wert der Data-Eigenschaft zurückgegeben wird. Wenn es sich beim Feld nicht um ein ADDIN-Feld handelt, wird diese Eigenschaft einen Fehler verursachen.


DataFields-Eigenschaft

Gibt eine MailMergeDataFields-Auflistung zurück, die Felder in der angegebenen Seriendruck-Datenquelle darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur DataFields-Eigenschaft

In diesem Beispiel werden die Namen aller Felder in der Datenquelle angezeigt, die dem aktuellen Seriendruck-Hauptdokument zugeordnet wurden.

For Each mField In ActiveDocument.MailMerge.DataSource.DataFields
    MsgBox mField.Name
Next mField

In diesem Beispiel wird der Wert des Feldes NachName im ersten Datensatz der Datenquelle, die "Main.doc" zugeordnet wurde, angezeigt.

With Documents("Main.doc").MailMerge.DataSource
    .ActiveRecord = wdFirstRecord
    MsgBox .DataFields("LastName").Value
End With


DataSource-Eigenschaft

Gibt ein MailMergeDataSource-Objekt zurück, das sich auf die Datenquelle bezieht, die einem Seriendruck-Hauptdokument zugeordnet wurde. Nur-Lese-Zugriff.


Beispiel zur DataSource-Eigenschaft

In diesem Beispiel wird der Name der Datenquelle angezeigt, die dem aktiven Dokument zugeordnet wurde.

If ActiveDocument.MailMerge.DataSource.Name <> "" Then _
    MsgBox ActiveDocument.MailMerge.DataSource.Name

In diesem Beispiel wird der nächste Satz in der Datenquelle angezeigt, die Main.doc zugeordnet ist.

ActiveDocument.ActiveWindow.View.ShowFieldCodes = False
With Documents("Main.doc").MailMerge
    .ViewMailMergeFieldCodes = False
    .DataSource.ActiveRecord = wdNextRecord
End With


Date-Eigenschaft

Revision-Objekt: Das Datum und die Zeit der Überarbeitung. Date Nur-Lese-Zugriff.

Version-Objekt: Das Datum und die Zeit des Speicherns der Dokumentversion. Date Nur-Lese-Zugriff.


DateFormat-Eigenschaft

Gibt das Datum für einen Brief zurück, der mit dem Brief-Assistenten erstellt wurde, oder legt es fest. String Schreib-Lese-Zugriff.


Beispiel zur DateFormat-Eigenschaft

In diesem Beispiel wird das Datum aus dem Brief im aktiven Dokument angezeigt.

MsgBox ActiveDocument.GetLetterContent.DateFormat

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, das aktuelle Datum wird als Inhalt für die Datumszeile festgelegt und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set aLetterContent = New LetterContent
aLetterContent.DateFormat = Date$
ActiveDocument.RunLetterWizard LetterContent:=aLetterContent


Default-Eigenschaft

CheckBox-Objekt: Gibt den Standardwert für ein Kontrollkästchen zurück oder legt ihn fest. True, wenn der Standardwert "Markiert" lautet. Boolean Schreib-Lese-Zugriff.

DropDown-Objekt: Gibt das Standard-Dropdownelement zurück oder legt es fest. Das erste Element in einem Dropdown-Formularfeld ist 1, das zweite ist 2, usw. Long Schreib-Lese-Zugriff.

TextInput-Objekt: Gibt den Text, der den Standard-Textfeld-Inhalt darstellt, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


DefaultBorderColor-Eigenschaft

Gibt die für neue Border-Objekte zu verwendende 24-Bit-Standardfarbe zurück oder legt diese fest. Dabei kann es sich um jede gültige WdColor-Konstante oder einen durch die RGB-Funktion zurückgebebenen Wert handeln. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.


DefaultBorderColorIndex-Eigenschaft

Gibt die Standardlinienfarbe für Rahmen zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Anmerkung Wenn die Enable-Eigenschaft des Borders-Objekts auf True gesetzt ist, werden die Standardlinienstärke, das Standardformat und die Standardlinienfarbe für Rahmen verwendet.


Beispiel zur DefaultBorderColorIndex-Eigenschaft

In diesem Beispiel wird die Standard-Linienfarbe und -art für Rahmen geändert und ein Rahmen wird um den ersten Absatz im aktiven Dokument gezogen.

ActiveDocument.Paragraphs(1).Borders.Enable = True
With Options
    .DefaultBorderColorIndex = wdRed
    .DefaultBorderLineStyle = wdLineStyleDouble
End With


DefaultBorderLineStyle-Eigenschaft

Gibt die Standard-Rahmenlinienart zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdLineStyle-Konstanten handeln:

wdLineStyleDashDot

wdLineStyleDashDotDot

wdLineStyleDashDotStroked

wdLineStyleDashLargeGap

wdLineStyleDashSmallGap

wdLineStyleDot

wdLineStyleDouble

wdLineStyleDoubleWavy

wdLineStyleEmboss3D

wdLineStyleEngrave3D

wdLineStyleInset

wdLineStyleNone

wdLineStyleOutset

 wdLineStyleSingle

wdLineStyleSingleWavy

wdLineStyleThickThinLargeGap

wdLineStyleThickThinMedGap

wdLineStyleThickThinSmallGap

wdLineStyleThinThickLargeGap

wdLineStyleThinThickMedGap

wdLineStyleThinThickSmallGap

wdLineStyleThinThickThinLargeGap

wdLineStyleThinThickThinMedGap

wdLineStyleThinThickThinSmallGap

wdLineStyleTriple


Beispiel zur DefaultBorderLineStyle-Eigenschaft

In diesem Beispiel wird die Standard-Linienart auf doppelt gesetzt.

Options.DefaultBorderLineStyle = wdLineStyleDouble

In diesem Beispiel wird die aktuelle Standard-Linienart zurückgegeben.

temp = Options.DefaultBorderLineStyle


DefaultBorderLineWidth-Eigenschaft

Gibt die Standard-Linienstärke für Ränder zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdLineWidth-Konstanten handeln: wdLineWidth025pt, wdLineWidth050pt, wdLineWidth075pt, wdLineWidth100pt, wdLineWidth150pt, wdLineWidth225pt, wdLineWidth300pt, wdLineWidth450pt oder wdLineWidth600pt. Long Schreib-Lese-Zugriff.

Hinweis Wenn die Enable-Eigenschaft des Borders-Objekts auf True gesetzt ist, werden Standard-Linienart und Standard-Linienstärke benutzt.


Beispiel zur DefaultBorderLineWidth-Eigenschaft

In diesem Beispiel wird die Standard-Linienstärke geändert und jeder Absatz der Auswahl mit einer Umrahmung versehen.

Options.DefaultBorderLineWidth = wdLineWidth050pt
Selection.Borders.Enable = True


DefaultFaceUp-Eigenschaft

True, wenn Briefumschläge standardmäßig mit der Schriftseite nach oben eingezogen werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur DefaultFaceUp-Eigenschaft

In diesem Beispiel wird festgelegt, dass Briefumschläge standardmäßig mit der Schriftseite nach oben eingezogen werden. Die UpdateDocument-Methode aktualisiert den Briefumschlag im aktiven Dokument.

With ActiveDocument.Envelope
    .DefaultFaceUp = True
    .DefaultOrientation = wdCenterPortrait
    .UpdateDocument
End With

In diesem Beispiel wird eine Meldung angezeigt, die den Anwender darüber informiert, wie Briefumschläge, entsprechend der Standardeinstellung, in den Drucker eingezogen werden.

If ActiveDocument.Envelope.DefaultFaceUp = True Then
    MsgBox "Feed envelopes face up."
Else
    MsgBox "Feed envelopes face down."
End If


DefaultFilePath-Eigenschaft

Gibt den Standardordner für Elemente wie Dokumente, Vorlagen und Grafiken, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Syntax

Ausdruck.DefaultFilePath(Path)

Ausdruck Erforderlich. Ein Ausdruck, der ein Options-Objekt zurückgibt.

Path Long erforderlich. Der festzulegende Standardordner. Dabei kann es sich um eine der folgenden WdDefaultFilePath-Konstanten handeln:

wdAutoRecoverPath

wdBorderArtPath

wdCurrentFolderPath

wdDocumentsPath

wdGraphicsFiltersPath

wdPicturesPath

wdProgramPath

wdProofingToolsPath

wdStartupPath

 wdStyleGalleryPath

wdTempFilePath

wdTextConvertersPath

wdToolsPath

wdTutorialPath

wdUserOptionsPath

wdUserTemplatesPath

wdWorkgroupTemplatesPath

Hinweise

Die neuen Einstellungen treten sofort in Kraft.

Mit einer leeren Zeichenfolge ("") können Sie die Einstellung aus der Registerdatenbank von Windows entfernen.


Beispiel zur DefaultFilePath-Eigenschaft

In diesem Beispiel wird der Standardordner für Word-Dokumente festgelegt.

Options.DefaultFilePath(wdDocumentsPath) = "c:\My Documents"

In diesem Beispiel wird der aktuelle Standardpfad für Benutzer-Vorlagen (entspricht der Standardpfadeinstellung auf der Registerkarte Speicherort der Datei im Dialogfeld Optionen) zurückgegeben.

temp = Options.DefaultFilePath(wdUserTemplatesPath)


DefaultHeight-Eigenschaft

Gibt die Standardhöhe für Briefumschläge in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie die DefaultHeight- oder DefaultWidth-Eigenschaft festlegen, wird die Umschlaggröße automatisch auf benutzerdefiniertes Format im Dialogfeld Umschlagoptionen (Menü Extras) gesetzt. Mit der DefaultSize-Eigenschaft setzen Sie die Standardgröße auf eine vordefinierte Größe.


Beispiel zur DefaultHeight-Eigenschaft

In diesem Beispiel wird die Standardgröße für Briefumschläge auf 11,43 cm x 19,05 cm gesetzt.

With ActiveDocument.Envelope
    .DefaultHeight = InchesToPoints(4.5)
    .DefaultWidth = InchesToPoints(7.5)
End With


DefaultHighlightColorIndex-Eigenschaft

Gibt die Farbe zum Hervorheben von Text, der mit der Schaltfläche Hervorhebung (Format-Symbolleiste) formatiert wurde, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

wdGreen

 wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow


Beispiel zur DefaultHighlightColorIndex-Eigenschaft

In diesem Beispiel wird die Standardfarbe für Hervorhebungen auf "BrightGreen" gesetzt. Die neue Farbe wird keinem Text zugewiesen, der zuvor hervorgehoben wurde.

Options.DefaultHighlightColorIndex = wdBrightGreen

In diesem Beispiel wird der aktuelle Standardfarbindex für Hervorhebungen zurückgegeben.

temp = Options.DefaultHighlightColorIndex


DefaultLabelName-Eigenschaft

Gibt den Namen des Standard-Adressaufklebers zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkung Um die Zeichenfolge des integrierten Etiketts zu finden, wählen Sie das Etikett im Dialogfeld Etiketten einrichten (Menü Extras, Dialogfeld Umschläge und Etiketten, Registerkarte Etiketten, Schaltfläche Optionen). Klicken Sie anschließend auf Details, und überprüfen Sie das Feld Etikettbezeichnung, in dem Sie die korrekte Zeichenfolge dieser Eigenschaft finden. Um ein benutzerdefiniertes Etikett als Standard-Adressetikett zu definieren, verwenden Sie den Etikettnamen aus dem Dialogfeld Details, oder verwenden Sie die Name-Eigenschaft mit einem CustomLabel-Objekt.

Hinweise

Wenn Sie ein neues Etiketten-Dokument aus einem CustomLabel-Objekt erstellen, wird die DefaultLabelName-Eigenschaft automatisch auf den Namen des CustomLabel-Objekts gesetzt.


Beispiel zur DefaultLabelName-Eigenschaft

In diesem Beispiel wird der Name des aktuellen Standard-Adressetiketts zurückgegeben.

Msgbox Application.MailingLabel.DefaultLabelName

In diesem Beispiel wird das Adressetikett "Avery Standard, 5160" als Standard-Adressetikett festgelegt.

Application.MailingLabel.DefaultLabelName = "5160"


DefaultLaserTray-Eigenschaft

Gibt den Standard-Papierschacht mit den Bogen für die Adressetiketten zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdPaperTray-Konstanten handeln:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormatBin

wdPrinterTractorFeed

wdPrinterUpperBin


Beispiel zur DefaultLaserTray-Eigenschaft

In diesem Beispiel wird überprüft, ob der Drucker für die Adressetiketten auf manuellen Einzug der Etiketten eingestellt ist und eine Meldung in der Statusleiste angezeigt.

If Application.MailingLabel.DefaultLaserTray = _
        wdPrinterManualEnvelopeFeed Then
    StatusBar = "Printer set for feeding labels manually"
Else
    StatusBar = "Check printer paper tray setting"
End If

In diesem Beispiel wird der Papierschacht für die Adressetiketten auf die obere Papierkassette eingestellt.

Application.MailingLabel.DefaultLaserTray = wdPrinterUpperBin


DefaultOmitReturnAddress-Eigenschaft

True, wenn der Absender standardmäßig auf Briefumschlägen weggelassen wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DefaultOmitReturnAddress-Eigenschaft

In diesem Beispiel wird der Absender standardmäßig bei neuen Umschlägen weggelassen.

ActiveDocument.Envelope.DefaultOmitReturnAddress = True

In diesem Beispiel wird der Status der Absenderadresse in einem Meldungsfeld angezeigt.

If ActiveDocument.Envelope.DefaultOmitReturnAddress = True Then
    MsgBox "A return address is not included by default."
Else
    MsgBox "A return address is included by default."
End If


DefaultOpenFormat-Eigenschaft

Gibt das Standard-Dateikonvertierungsprogramm zurück, das zum Öffnen von Dokumenten verwendet wird, oder legt es fest. Dies kann eine Zahl sein, die von der OpenFormat-Eigenschaft zurückgegeben wird, oder eine der folgenden WdOpenFormat-Konstanten: wdOpenFormatAllWord, wdOpenFormatAuto, wdOpenFormatDocument, wdOpenFormatEncodedText, wdOpenFormatRTF, wdOpenFormatTemplate, wdOpenFormatText, wdOpenFormatUnicodeText oder wdOpenFormatWebPages. Long Schreib-Lese-Zugriff.

Anmerkung Verwenden Sie das Argument Format mit der Open-Methode zum Spezifizieren eines Dateikonvertierungsprogramms, wenn Sie ein einzelnes Dokument öffnen.


Beispiel zur DefaultOpenFormat-Eigenschaft

In diesem Beispiel wird das Standard-Dateikonvertierungsprogramm zum Öffnen von Dokumenten auf das Word-Dokumentformat festgelegt und dann Forcast.doc geöffnet.

Options.DefaultOpenFormat = wdOpenFormatDocument
Documents.Open FileName:="C:\Sales\Forcast.doc"

In diesem Beispiel wird das Standard-Dateikonvertierungsprogramm zum Öffnen von Dokumenten auf automatisches Ermitteln des zu verwendenden Dateikonvertierungsprogramms festgelegt, wenn Dokumente geöffnet werden.

Options.DefaultOpenFormat = wdOpenFormatAuto

In diesem Beispiel wird das Standard-Konvertierungsprogramm zum Öffnen von Dokumenten auf das WordPerfect 6.x-Format festgelegt.

Options.DefaultOpenFormat = _
    FileConverters("WordPerfect6x").OpenFormat


DefaultOrientation-Eigenschaft

Gibt die Standardausrichtung zum Einzug von Umschägen zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdEnvelopeOrientation-Konstanten handeln: wdCenterClockwise, wdCenterLandscape, wdCenterPortrait, wdLeftClockwise, wdLeftLandscape, wdLeftPortrait, wdRightClockwise, wdRightLandscape oder wdRightPortrait. Long Schreib-Lese-Zugriff.


Beispiel zur DefaultOrientation-Eigenschaft

In diesem Beispiel wird festgelegt, dass Briefumschläge mit der Schriftseite nach oben, zentriert und in Hochformat eingezogen werden.

With ActiveDocument.Envelope
    .DefaultFaceUp = True
    .DefaultOrientation = wdCenterPortrait
    MsgBox "Feed envelopes centered, face up, " _
        & "in portrait orientation"
End With


DefaultPrintBarCode-Eigenschaft

True, wenn Umschlägen oder Adressettiketten standardmäßig ein POSTNET Barcode hinzugefügt wird. Boolean Schreib-Lese-Zugriff.

Anmerkung Gilt nur für US-amerikanische Post. Bei Umschlägen muss diese Eigenschaft auf True gesetzt werden, bevor die DefaultPrintFIMA-Eigenschaft festgelegt wird.


Beispiel zur DefaultPrintBarCode-Eigenschaft

In diesem Beispiel werden die Standardeinstellungen für Umschläge so festgelegt, dass sie einen Barcode und ein "Facing Identification Mark" (FIM-A) beinhalten. Nur für US-Post.

With ActiveDocument.Envelope
    .DefaultPrintBarCode = True
    .DefaultPrintFIMA = True
End With

In diesem Beispiel wird der Status des Barcodes in einem Meldungsfeld angezeigt.

If ActiveDocument.Envelope.DefaultPrintBarCode = False Then
    MsgBox "A bar code is not included by default"
Else
    MsgBox "A bar code is included by default"
End If


DefaultPrintFIMA-Eigenschaft

True, wenn Umschlägen standardmäßig eine Facing Identification Mark (FIM-A) hinzugefügt wird. Boolean Schreib-Lese-Zugriff.

Anmerkung Nur für US-Post. FIM-A-Codes werden zum Vorsortieren von Rückantwortumschlägen verwendet. Ehe Sie diese Eigenschaft setzen können, muss die DefaultPrintBarCode-Eigenschaft auf True gesetzt werden.


Beispiel zur DefaultPrintFIMA-Eigenschaft

In diesem Beispiel wird festgelegt, dass Umschläge standardmäßig mit Barcode und Facing Identification Mark (FIM-A) versehen werden.

With ActiveDocument.Envelope
    .DefaultPrintBarCode = True
    .DefaultPrintFIMA = True
End With


DefaultSaveFormat-Eigenschaft

Gibt das Standardformat, das im Feld Dateityp im Dialogfeld Speichern unter (Menü Datei) erscheint zurück oder legt ihn fest. Entspricht dem Feld Dateien speichern als: auf der Registerkarte Speichern im Dialogfeld Optionen (Menü Extras). String Schreib-Lese-Zugriff.

Anmerkungen

Die mit dieser Eigenschaft verwendete Zeichenfolge ist der Name einer Dateikonvertierungsklasse. Die Klassennamen für interne Word-Formate werden in der folgenden Tabelle aufgeführt.

Word-Format | Klassenname des Dateikonverters
Word-Dokument | ""
Dokumentvorlage | "Dot"
Nur Text | "Text"
Nur Text + Zeilenwechsel | "CRText"
MS-DOS-Text | "8Text"
MS-DOS-Text + Zeilenwechsel | "8CRText"
Rich Text Format | "Rtf"
Unicode-Text | "Unicode"

Sie ermitteln die Klasse eines externen Dateikonvertierungsprogrammes mit Hilfe der ClassName-Eigenschaft mit FileConverter-Objekt.


Beispiel zur DefaultSaveFormat-Eigenschaft

In diesem Beispiel wird das Format Word-Dokument als Standardformat zum Speichern bestimmt.

Application.DefaultSaveFormat = ""

In diesem Beispiel wird die aktuelle Einstellung des Felds Dateien speichern als: auf der Registerkarte Speichern im Dialogfeld Optionen (Menü Extras) zurückgegeben.

Msgbox Application.DefaultSaveFormat


DefaultSize-Eigenschaft

Gibt die Standardgröße für Briefumschläge zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweis Die zurückgegebene Zeichenfolge entspricht der rechten Seite der Zeichenfolge im Feld Umschlagformat im Dialogfeld Optionen für Umschläge. Wenn Sie entweder die DefaultHeight- oder die DefaultWidth-Eigenschaft festlegen, wird die Briefumschlaggröße automatisch in "Benutzerdefiniertes Format" im Dialogfeld Optionen für Umschläge (Menü Extras) geändert, und diese Eigenschaft gibt "Benutzerdefiniertes Format" zurück.


Beispiel zur DefaultSize-Eigenschaft

In diesem Beispiel wird als Standardbriefumschlaggröße C4 (229 x 324 mm) festgelegt.

ActiveDocument.Envelope.DefaultSize = "C4"

In diesem Beispiel wird der Benutzer gefragt, ob die Standardbriefumschlaggröße auf Größe 10 geändert werden soll. Bei einer positiven Anwort wird die Größe entsprechend geändert. Die UpdateDocument-Methode ändert die Briefumschlaggröße für das aktive Dokument. Wenn kein Briefumschlag dem aktiven Dokument hinzugefügt wurde, wird ein Meldungsfeld angezeigt.

On Error GoTo errhandler
response = MsgBox("Do you want to set the " _
    & "default envelope to Size 10?", 4)
If response = vbYes Then
    With ActiveDocument.Envelope
        .DefaultSize = "Size 10"
        .UpdateDocument
    End With
End If
errhandler:
If Err = 5852 Then MsgBox "An envelope isn't part of this document"


DefaultSorting-Eigenschaft

Gibt die Sortieroption der im Dialogfeld Textmarke (Menü Einfügen) angezeigten Textmarkennamen zurück oder legt sie fest. Es kann sich dabei um eine der folgenden WdBookmarkSortBy-Konstanten handeln: wdSortByLocation oder wdSortByName. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft beeinflusst nicht die Reihenfolge der Bookmark-Objekte in der Bookmarks-Auflistung.


Beispiel zur DefaultSorting-Eigenschaft

In diesem Beispiel werden Textmarken entsprechend ihrer Position sortiert und dann wird das Dialogfeld Textmarke angezeigt.

ActiveDocument.Bookmarks.DefaultSorting = wdSortByLocation
Dialogs(wdDialogInsertBookmark).Show


DefaultTab-Eigenschaft

Gibt die aktive Registerkarte zurück oder legt sie fest, wenn das angegebene Dialogfeld angezeigt wird. Dies kann jede der WdWordDialogTab-Konstanten sein. Die Liste gültiger WdWordDialogTab-Konstanten finden Sie im Objektkatalog des Visual Basic Editors. Long Schreib-Lese-Zugriff.


DefaultTableSeparator-Eigenschaft

Gibt ein einzelnes Zeichen zurück oder legt es fest, mit dem Text in Zellen getrennt wird, wenn Text zu einer Tabelle konvertiert wird. String Schreib-Lese-Zugriff.

Hinweis Der Wert der DefaultTableSeparator-Eigenschaft wird verwendet, wenn das Separator-Argument beim Aufruf der ConvertToTable-Methode ausgelassen wird.


Beispiel zur DefaultTableSeparator-Eigenschaft

In diesem Beispiel wird das Standardtrennzeichen für Tabellen geändert.

Application.DefaultTableSeparator = "%"


DefaultTabStop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen den Standard-Tabstopps im angegebenen Dokument zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur DefaultTabStop-Eigenschaft

In diesem Beispiel werden die Standard-Tabstopps im aktiven Dokument auf 1 Zoll festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

ActiveDocument.DefaultTabStop = InchesToPoints(1)


DefaultTray-Eigenschaft

Gibt den Standard-Papierschacht, den der Drucker zum Drucken von Dokumenten verwendet, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Beim Setzen dieser Eigenschaft wählen Sie eine der Zeichenfolgen im Feld Standardschacht auf der Registerkarte Drucken im Dialogfeld Optionen. Diese Optionen setzen Sie auch, wenn Sie mit der DefaultTrayID-Eigenschaft eine WdPaperTray-Konstante festlegen.


DefaultTrayID-Eigenschaft

Gibt den Standard-Papierschacht, den der Drucker zum Drucken von Dokumenten verwendet zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdPaperTray-Konstanten handeln:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormalBin

wdPrinterTractorFeed

wdPrinterUpperBin

Anmerkungen

Mit der DefaultTray-Eigenschaft und einer Zeichenfolge aus dem Feld Standardschacht auf der Registerkarte Drucken im Dialogfeld Optionen setzen Sie dieselbe Option.


Beispiel zur DefaultTrayID-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word den oberen Papierschacht verwendet. Dann wird das aktive Dokument gedruckt.

Options.DefaultTrayID = wdPrinterUpperBin
ActiveDocument.PrintOut

In diesem Beispiel wird der Status der Option Standardschacht auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

currTray = Options.DefaultTrayID


DefaultWidth-Eigenschaft

Gibt den Wert für die Standard-Briefumschlagbreite in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie die DefaultHeight- oder DefaultWidth-Eigenschaft festlegen, wird die Briefumschlaggröße automatisch auf benutzerdefiniertes Format im Dialogfeld Optionen für Umschläge (Menü Extras) gesetzt. Mit der DefaultSize-Eigenschaft setzen Sie die Standardgröße auf eine vordefinierte Größe.


Beispiel zur DefaultWidth-Eigenschaft

In diesem Beispiel werden die benutzerdefinierte Standardgröße und Höhe für Briefumschläge festgelegt und ein Briefumschlag dem aktiven Dokument hinzugefügt.

addr = "Tim O' Brien " & vbCr & "123 Skye St." _
    & vbCr & "Bellevue, WA  98004"
ret = "Dave Edson" & vbCr & "123 West Main" _
    & vbCr & "Seattle, WA  98004"
With ActiveDocument.Envelope
    .DefaultWidth = InchesToPoints(9)
    .DefaultHeight = InchesToPoints(3.85)
End With
ActiveDocument.Envelope.Insert Address:=addr, ReturnAddress:=ret


DefaultWritingStyle-Eigenschaft

Gibt den von der Grammatikprüfung verwendeten Standardschreibstil für die angegebene Sprache zurück oder legt ihn fest. Der Name des Schreibstils ist der lokalisierte Name der angegebenen Sprache. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft steuert die globalen Einstellungen für den Schreibstil. Wenn Sie diese Eigenschaft festlegen, müssen Sie den genauen Namen aus dem Feld Schreibstil auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen (Menü Extras) benutzen.

Die ActiveWritingStyle-Eigenschaft legt den Schreibstil für alle Sprachen im Dokument fest. Die ActiveWritingStyle-Einstellung überschreibt die DefaultWritingStyle-Einstellung.


Beispiel zur DefaultWritingStyle-Eigenschaft

In diesem Beispiel wird der Standardschreibstil in einem Meldungsfeld zurückgegeben.

myLang = Selection.LanguageID
Msgbox Languages(myLang).DefaultWritingStyle

In diesem Beispiel wird der Schreibstil für Deutsch auf "Casual" gesetzt und dann die Grammatik und die Rechtschreibung im aktiven Dokument überprüft.

Languages(wdEnglishUS).DefaultWritingStyle = "Casual"
ActiveDocument.CheckGrammar


DeletedTextColor-Eigenschaft

Gibt die Farbe des Textes zurück, der bei aktiviertem Versionsvergleich gelöscht wird, oder legt diese fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdByAuthor

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Hinweise

Ist die DeletedTextColor-Eigenschaft auf wdByAuthor gesetzt, weist Word jedem der ersten acht Autoren, die ein Dokument bearbeiten, automatisch eine eindeutige Farbe zu.


Beispiel zur DeletedTextColor-Eigenschaft

In diesem Beispiel wird als Farbe für gelöschten Text "BrightGreen" zugewiesen.

Options.DeletedTextColor = wdBrightGreen

In diesem Beispiel wird der aktuelle Status der Option Farbe unter Gelöschter Text auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.DeletedTextColor


DeletedTextMark-Eigenschaft

Gibt das Format des Textes, der gelöscht wurde, während die Änderungsverfolgung aktiv ist, zurück oder legt es fest. Dabei kann es sich um eine der folgenden WdDeletedTextMark-Konstanten handeln: wdDeletedTextMarkCaret, wdDeletedTextMarkHidden, wdDeletedTextMarkPound oder wdDeletedTextMarkStrikeThrough. Long Schreib-Lese-Zugriff.


Beispiel zur DeletedTextMark-Eigenschaft

In diesem Beispiel wird "StrikeThrough" auf gelöschten Text angewendet.

Options.DeletedTextMark = wdDeletedTextMarkStrikeThrough

In diesem Beispiel wird der aktuelle Status der Option Markierung unter Gelöschter Text auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.DeletedTextMark


Delivery-Eigenschaft

Gibt die Zustellmethode zur Verteilung des Dokuments zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdRoutingSlipDelivery-Konstanten handeln: wdAllAtOnce oder wdOneAfterAnother. Long Schreib-Lese-Zugriff vor Beginn der Verteilung; Long Nur-Lese-Zugriff während der Verteilung.


Beispiel zur Delivery-Eigenschaft

In diesem Beispiel wird das Dokument "Status.doc" nacheinander an zwei Empfänger verteilt.

Documents("Status.doc").HasRoutingSlip = True
With Documents("Status.doc").RoutingSlip
    .Subject = "Status Doc"
    .AddRecipient Recipient:="Don Funk"
    .AddRecipient Recipient:="Eric Maffei"
    .Delivery = wdOneAfterAnother
End With
Documents("Status.doc").Route


Depth-Eigenschaft

Gibt die Tiefe der Projektion der Form zurück oder legt sie fest. Es kann ein Wert zwischen -600 und 9600 sein (positive Werte erzeugen eine Projektion, deren Vorderseite die Originalform ist; negative Werte erzeugen eine Projektion, deren Rückseite die Originalform ist). Single Schreib-Lese-Zugriff.


Beispiel zur Depth-Eigenschaft

In diesem Beispiel wird ein Oval zu myDocument hinzugefügt und dann spezifiziert, dass das Oval auf eine Tiefe von 50 Punkt projiziert werden und die Projektion purpurrot sein soll.

Set myDocument = ActiveDocument
Set myShape = myDocument.Shapes.AddShape(msoShapeOval, _
    90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    ' RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With


Description-Eigenschaft

Gibt die Beschreibung der angegebenen Formatvorlage zurück. Eine typische Beschreibung für die Formatvorlage Überschrift 2 könnte beispielsweise lauten: "Normal + Schriftart: Arial, 12 pt, Fett, Kursiv, Abstand Vor 12 pt Nach 3 pt, Absatz mit folgendem zusammenhalten, Ebene 2". String Nur-Lese-Zugriff.


Beispiel zur Description-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und eine Liste der Formatvorlagen des aktiven Dokuments und deren Beschreibungen eingefügt, wobei die Listenspalten durch Tabstopps getrennt sind.

Set myDoc = ActiveDocument
Set newDoc = Documents.Add
For Each sty In myDoc.Styles
    With newDoc.Range
        .InsertAfter Text:=sty.NameLocal & Chr(9) & sty.Description
        .InsertParagraphAfter
    End With
Next sty


Destination-Eigenschaft

Gibt das Ziel der Seriendruckergebnisse zurück oder legt es fest. Dabei kann es sich um eine der folgenden WdMailMergeDestination-Konstanten handeln: wdSendToEmail, wdSendToFax, wdSendToNewDocument oder wdSendToPrinter. Long Schreib-Lese-Zugriff.


Beispiel zur Destination-Eigenschaft

In diesem Beispiel werden die Ergebnisse einer Seriendruckoperation in eine neue Datei übertragen.

Set mm = ActiveDocument.MailMerge
If mm.State = wdMainAndDataSource Then
    mm.Destination = wdSendToNewDocument
    mm.Execute
End If


DiacriticColor-Eigenschaft

Sprachspezifische Informationen

Returns or sets the 24-bit color to be used for diacritics for the specified Font object. Can be any valid WdColor constant or a value returned by the RGB function. Read/write Long.

Remarks

For a list of valid WdColor constants, see the Object Browser in the Visual Basic Editor.

The value of the UseDiffDiacColor property must be True in order to use this property.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


DiacriticColorVal-Eigenschaft

Sprachspezifische Informationen

Returns or sets the 24-bit color to be used for diacritics in a right-to-left language document. Can be any valid WdColor constant or a value returned by the RGB function. Read/write Long.

Remarks

For a list of valid WdColor constants, see the Object Browser in the Visual Basic Editor.

The value of the UseDiffDiacColor property must be True in order to use this property.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur DiacriticColorVal-Eigenschaft

Sprachspezifische Informationen

This example sets the color for diacritics to bright green.

If Options.UseDiffDiacColor = True Then _
    Options.DiacriticColorVal = wdColorBrightGreen


Dialogs-Eigenschaft

Gibt eine Dialogs-Auflistung zurück, die alle integrierten Dialogfelder in Word repräsentiert. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Dialogs-Eigenschaft

In diesem Beispiel wird das integrierte Dialogfeld Suchen angezeigt. Im Feld Suchen nach wird der Begriff "Hello" eingetragen.

Set dlg = Dialogs(wdDialogEditFind)
With dlg
    .Find = "Hello"
    .Show
End With

In diesem Beispiel wird das integrierte Dialogfeld Öffnen angezeigt. Im Dialogfeld werden alle Dateitypen angezeigt.

With Dialogs(wdDialogFileOpen)
    .Name = "*.*"
    .Show
End With

In diesem Beispiel wird das aktive Dokument gedruckt. Dabei werden die Einstellungen im Dialogfeld Drucken verwendet.

Dialogs(wdDialogFilePrint).Execute


DifferentFirstPageHeaderFooter-Eigenschaft

True, wenn eine unterschiedliche Kopf- oder Fußzeile auf der ersten Seite verwendet wird. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur DifferentFirstPageHeaderFooter-Eigenschaft

In diesem Beispiel wird jeder Abschnitt im aktiven Dokument auf Kopf- und Fußzeilen überprüft, die unterschiedlich zu denen auf der ersten Seite sind. Eine Meldung wird angezeigt, wenn solche Kopf- oder Fußzeilen gefunden werden.

For Each sec In ActiveDocument.Sections
    If sec.PageSetup.DifferentFirstPageHeaderFooter = True Then
    Msgbox "Section " & sec.Index _
        & " has different first page headers & footers."
    End If
Next sec


DisableCharacterSpaceGrid-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the setting for the number of characters per line on the Document Grid tab (PageSetup command, File menu). Returns wdUndefined if the DisableCharacterSpaceGrid property is set to True for only some of the specified paragraphs. Read/write Boolean.


Beispiel zur DisableCharacterSpaceGrid-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to ignore the setting for the number of characters per line for the selected text.

With Selection.Font
    .DisableCharacterSpaceGrid = True
End With


DisableLineHeightGrid-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word aligns characters in the specified paragraphs to the line grid when a set number of lines per page is specified. Returns wdUndefined if the DisableLineHeightGrid property is set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur DisableLineHeightGrid-Eigenschaft

Sprachspezifische Informationen

This example sets Microsoft Word to align characters in the selected paragraphs to the line grid if you’ve specified a set number of lines per page.

With Selection.ParagraphFormat
    .DisableLineHeightGrid = True
End With


DisplayAlerts-Eigenschaft

Gibt die Art, wie bestimmte Warnungen und Meldungen während der Ausführung eines Makros behandelt werden, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Kann eine der folgenden WdAlertLevel-Konstanten sein.

Konstante | Beschreibung
wdAlertsNone | Es werden keine Warnungen oder Meldungsfelder angezeigt. Wenn ein Makro auf ein Meldungsfeld trifft, wird die Standardeinstellung gewählt und die Ausführung des Makros fortgesetzt.
wdAlertsMessageBox | Nur Meldungsfelder werden angezeigt; Fehler werden abgefangen und dem Makro zurückgegeben.
wdAlertsAll | Alle Meldungsfelder und Warnungen werden angezeigt; Fehler werden dem Makro zurückgegeben.

Anmerkung Wenn Sie diese Eigenschaft auf wdAlertsNone oder wdAlertsMessageBox einstellen, setzt Word sie nicht auf wdAlertsAll zurück, wenn Ihr Makro die Ausführung anhält. Sie sollten Ihr Makro so schreiben, dass es die DisplayAlerts-Eigenschaft immer auf wdAlertsAll zurücksetzt, wenn es die Ausführung anhält.


Beispiel zur DisplayAlerts-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es alle Warnungen und Meldungsfelder anzeigt, wenn Makros ausgeführt werden.

Application.DisplayAlerts = wdAlertsAll

In diesem Beispiel wird die aktuelle Einstellung der DisplayAlerts-Eigenschaft zurückgegeben.

temp = Application.DisplayAlerts


DisplayAsIcon-Eigenschaft

True, wenn das angegebene Objekt als Symbol angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayAsIcon-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das den Namen jeder beweglichen Form enthält, die als Symbol auf dem aktiven Dokument angezeigt wird.

For Each s In ActiveDocument.Shapes
    If s.OLEFormat.DisplayAsIcon Then
        MsgBox s.Name & " is displayed as an icon."
    End If
Next s

In diesem Beispiel wird im aktiven Dokument eine Microsoft Excel-Tabelle als verknüpftes OLE-Objekt eingefügt und dann das Objekt als Symbol angezeigt.

Set myObj = ActiveDocument.Shapes.AddOLEObject _
    (FileName:="c:\program files\microsoft office" _
    & "\office\examples\samples.xls", LinkToFile:=True)
myObj.OLEFormat.DisplayAsIcon = True


DisplayAutoCompleteTips-Eigenschaft

True, wenn Word während der Eingabe Tipps anzeigt, die Text zur Vervollständigung von Wörtern, Daten oder Sätzen vorschlagen. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayAutoCompleteTips-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es während der Eingabe Tipps anzeigt, die Text zur Vervollständigung von Wörtern, Daten oder Phrasen vorschlagen.

Application.DisplayAutoCompleteTips = True

In diesem Beispiel wird der Status der Option Rest des Wortes oder Datums während der Eingabe als Tipp vorschlagen auf der Registerkarte AutoText im Dialogfeld AutoKorrektur (Menü Extras) zurückgegeben.

temp = Application.DisplayAutoCompleteTips


DisplayGridLines-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word displays the document grid. This property is the equivalent of the Gridlines command on the View menu. Read/write Boolean.

Remarks

This property affects only the document grid. For table gridlines, use the TableGridlines property.


Beispiel zur DisplayGridLines-Eigenschaft

Sprachspezifische Informationen

This example switches between displaying and hiding the document grid in the active window.

Options.DisplayGridLines = Not Options.DisplayGridLines


DisplayHorizontalScrollBar-Eigenschaft

True, wenn für das angegebene Fenster eine horizontale Bildlaufleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayHorizontalScrollBar-Eigenschaft

In diesem Beispiel werden für das aktive Fenster vertikale und horizontale Bildlaufleisten angezeigt.

With ActiveDocument.ActiveWindow
    .DisplayHorizontalScrollBar = True
    .DisplayVerticalScrollBar = True
End With

In diesem Beispiel wird die Anzeige der horizontalen Bildlaufleiste des Fensters für Document1 umgeschaltet.

Set aWin = Windows("Document1")
aWin.DisplayHorizontalScrollBar = _
    Not aWin.DisplayHorizontalScrollBar


DisplayLeftScrollBar-Eigenschaft

Sprachspezifische Informationen

True if the vertical scroll bar appears on the left side of the document window. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur DisplayLeftScrollBar-Eigenschaft

Sprachspezifische Informationen

This example displays the vertical scroll bar on the left side of the active window.

ActiveWindow.DisplayLeftScrollBar = True


DisplayRecentFiles-Eigenschaft

True, wenn die Namen der zuletzt bearbeiteten Dateien im Menü Datei angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayRecentFiles-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass maximal sechs Dateinamen im Menü Datei angezeigt werden.

Application.DisplayRecentFiles = True
RecentFiles.Maximum = 6

In diesem Beispiel wird die Liste der zuletzt benutzten Dateien aus dem Menü Datei entfernt.

Application.DisplayRecentFiles = False


DisplayRightRuler-Eigenschaft

Sprachspezifische Informationen

True if the vertical ruler appears on the right side of the document window in print layout view. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur DisplayRightRuler-Eigenschaft

Sprachspezifische Informationen

This example sets the active window to print layout view and displays the vertical ruler on the right side.

With ActiveWindow
    .View = wdPrintView
    .DisplayRightRuler = True
End With


DisplayRulers-Eigenschaft

True, wenn für das angegebene Fenster oder den angegebenen Ausschnitt Lineale angezeigt werden. Diese Eigenschaft ist gleichwertig mit dem Befehl Lineal auf dem Menü Ansicht. Boolean Schreib-Lese-Zugriff.

Hinweis Wenn DisplayRulers False ist, werden das horizontale und das vertikale Lineal nicht angezeigt, ohne den Status der DisplayVerticalRuler-Eigenschaft zu berücksichtigen.


Beispiel zur DisplayRulers-Eigenschaft

In diesem Beispiel wird für das aktive Fenster die Linealanzeige umgeschaltet.

ActiveDocument.ActiveWindow.DisplayRulers = _
    Not ActiveDocument.ActiveWindow.DisplayRulers

In diesem Beispiel wird das Fenster zur Drucklayoutansicht umgeschaltet und das horizontale und vertikale Lineal angezeigt.

With ActiveDocument.ActiveWindow
    .View.Type = wdPrintView
    .DisplayVerticalRuler = True
    .DisplayRulers = True
End With


DisplayScreenTips-Eigenschaft

True, wenn Kommentare, Fußnoten und Hyperlinks als Bildschirmtipps angezeigt werden. Text, der Kommentare enthält, wird hervorgehoben. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayScreenTips-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word Kommentare, Fußnoten und Endnoten als Bildschirmtipps (QuickInfos) anzeigt. Außerdem wird Text mit der Markierung, dass Kommentare vorhanden sind, hervorgehoben.

Application.DisplayScreenTips = True

In diesem Beispiel wird der aktuelle Status der Option QuickInfo auf der Registerkarte Ansicht im Dialogfeld Optionen zurückgegeben.

temp = Application.DisplayScreenTips


DisplayScrollBars-Eigenschaft

True, wenn Word eine Bildlaufleiste in mindestens einem Dokumentfenster anzeigt. False, wenn in keinem Fenster Bildlaufleisten angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn die DisplayScrollBars-Eigenschaft auf True gesetzt wird, dann werden horizontale und vertikale Bildlaufleisten in allen Fenstern angezeigt. Wird diese Eigenschaft auf False gesetzt, dann werden die Bildlaufleisten in allen Fenstern ausgeschaltet.

Verwenden Sie die DisplayHorizontalScrollBar- und DisplayVerticalScrollBar-Eigenschaften, um einzelne Bildlaufleisten im angegebenen Fenster anzuzeigen.


Beispiel zur DisplayScrollBars-Eigenschaft

In diesem Beispiel werden horizontale und vertikale Bildlaufleisten in allen Fenstern angezeigt.

Application.DisplayScrollBars = True

In diesem Beispiel wird True zurückgegeben, wenn in einem Fenster wenigstens eine Bildlaufleiste angezeigt wird.

temp = Application.DisplayScrollBars


DisplayStatusBar-Eigenschaft

True, wenn die Statusleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayStatusBar-Eigenschaft

In diesem Beispiel wird die Statusleiste umgeschaltet.

Application.DisplayStatusBar = Not Application.DisplayStatusBar

In diesem Beispiel werden die Bildlaufleisten und die Statusleiste angezeigt.

With Application
    .DisplayScrollBars = True
    .DisplayStatusBar = True
End With


DisplayVerticalRuler-Eigenschaft

True, wenn für das angegebene Fenster oder den angegebenen Ausschnitt ein vertikales Lineal angezeigt wird. Boolean Schreib-Lese-Zugriff.

Anmerkung Ein vertikales Lineal erscheint nur in der Druckayoutansicht und nur, wenn die DisplayRulers-Eigenschaft auf True eingestellt ist.


Beispiel zur DisplayVerticalRuler-Eigenschaft

In diesem Beispiel wird jedes Fenster in der Windows-Auflistung in der Drucklayoutansicht umgeschaltet und das horizontale und vertikale Lineal angezeigt.

For Each myWindow In Windows
    With myWindow
        .View.Type = wdPrintView
        .DisplayRulers = True
        .DisplayVerticalRuler = True
    End With
Next myWindow

In diesem Beispiel werden für das aktive Fenster das horizontale und das vertikale Lineal ausgeblendet.

With ActiveDocument.ActiveWindow
    .DisplayVerticalRuler = False
    .DisplayRulers = False
End With


DisplayVerticalScrollBar-Eigenschaft

True, wenn für das angegebene Fenster eine vertikale Bildlaufleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayVerticalScrollBar-Eigenschaft

In diesem Beispiel werden für jedes Fenster in der Windows-Auflistung die vertikale und die horizontale Bildlaufleiste angezeigt.

For Each myWindow In Windows
    myWindow.DisplayVerticalScrollBar = True
    myWindow.DisplayHorizontalScrollBar = True
Next myWindow

In diesem Beispiel wird für das aktive Fenster die Anzeige der vertikalen Bildlaufleiste umgeschaltet.

Set aWindow = ActiveDocument.ActiveWindow
aWindow.DisplayVerticalScrollBar = _
    Not aWindow.DisplayVerticalScrollBar


DistanceBottom-Eigenschaft

Rows-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem unteren Rand der angegebenen Tabelle zurück oder legt diesen fest. Diese Eigenschaft bleibt ohne Auswirkung, wenn WrapAroundText auf False gesetzt ist. Single Schreib-Lese-Zugriff.

WrapFormat-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem unteren Rand des textfreien Bereichs um die angegebene Form zurück oder legt ihn fest. Größe und Form der angegebenen Form bestimmen mit den Werten der Type- und Side-Eigenschaften des WrapFormat-Objekts die Größe und Form des textfreien Bereichs. Single Schreib-Lese-Zugriff.


Beispiel zur DistanceBottom-Eigenschaft

In diesem Beispiel wird festgelegt, dass der Text die erste Tabelle im aktiven Dokument umfließt und dass der Abstand des umfließenden Textes zu allen Seiten der Tabelle 20 Punkt beträgt.

With ActiveDocument.Tables(1).Rows
    .WrapAroundText = True
    .DistanceLeft = 20
    .DistanceRight = 20
    .DistanceTop = 20
    .DistanceBottom = 20
End With

In diesem Beispiel wird dem aktiven Dokument eine Ellipse hinzugefügt. Außerdem legen Sie fest, dass der Dokumenttext links und rechts des Quadrats umbrochen wird, das die Ellipse umgibt. Das Beispiel legt einen 0,1-Zoll-Rand zwischen dem Dokumenttext und der oberen, unteren, linken und rechten Seite des Quadrats fest.

Set myOval = ActiveDocument.Shapes.AddShape(msoShapeOval, _
    36, 36, 100, 35)
With myOval.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


DistanceFrom-Eigenschaft

Gibt den Wert, zurück oder legt ihn fest, der anzeigt, ob der festgelegte Seitenrahmen vom Seitenrand oder vom Text, den der Rahmen umgibt, gemessen wird. Dabei kann es sich um eine der folgenden WdBorderDistanceFrom-Konstanten handeln: wdBorderDistanceFromPageEdge oder wdBorderDistanceFromText. Long Schreib-Lese-Zugriff.


DistanceFromBottom-Eigenschaft

Gibt den Abstand (in Punkt) zwischen Text und dem unteren Rahmen zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft mit einem Seitenrahmen verwenden, können Sie entweder den Abstand zwischen Text und unterem Seitenrahmen oder den Abstand zwischen Seitenrand und unterem Seitenrahmen festlegen. Von welcher Stelle aus der Abstand gemessen wird, hängt vom Wert der DistanceFrom-Eigenschaft ab.


Beispiel zur DistanceFromBottom-Eigenschaft

In diesem Beispiel wird ein Rahmen um den ersten Absatz des aktiven Dokuments hinzugefügt und 6 Punkt als Abstand zwischen Text und unterem Rahmen festgelegt.

With ActiveDocument.Paragraphs(1).Borders
    .Enable = True
    .DistanceFromBottom = 6
End With

In diesem Beispiel wird ein Rahmen um alle Tabellen in Sales.doc hinzugefügt. Das Beispiel legt außerdem 3 Punkt als Abstand zwischen Text und Rahmen für die oberen und unteren Rahmen und 6 Punkt für die linken und rechten Rahmen fest.

For Each myTable In Documents("Sales.doc").Tables
    With myTable.Borders
        .OutsideLineStyle = wdLineStyleSingle
        .OutsideLineWidth = wdLineWidth150pt
        .DistanceFromBottom = 3
        .DistanceFromTop = 3
        .DistanceFromLeft = 6
        .DistanceFromRight = 6
    End With
Next myTable


DistanceFromLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem Text und dem linken Rand zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft mit einem Seitenrahmen verwenden, können Sie entweder den Abstand zwischen Text und linkem Rahmen oder den Abstand zwischen linkem Seitenrand und linkem Rahmen festlegen. Von welcher Stelle aus der Abstand gemessen wird, hängt vom Wert der DistanceFrom-Eigenschaft ab.


Beispiel zur DistanceFromLeft-Eigenschaft

In diesem Beispiel wird ein Rahmen um jeden Positionsrahmen des aktiven Dokuments hinzugefügt und 5 Punkt als Abstand zwischen Positionsrahmen und Rahmen festgelegt.

For Each aFrame In ActiveDocument.Frames
    With aFrame.Borders
        .Enable = True
        .DistanceFromLeft = 5
        .DistanceFromRight = 5
        .DistanceFromTop = 5
        .DistanceFromBottom = 5
    End With
Next aFrame

In diesem Beispiel wird ein Rahmen um den ersten Absatz des aktiven Dokuments hinzugefügt und 3 Punkt als Abstand zwischen Text und linkem Rahmen festgelegt.

With ActiveDocument.Paragraphs(1).Borders
    .Enable = True
    .DistanceFromLeft = 3
End With


DistanceFromRight-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der rechten Textkante und dem rechten Rahmen zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft mit einem Seitenrahmen verwenden, können Sie entweder den Abstand zwischen Text und rechtem Rahmen oder den Abstand zwischen rechtem Seitenrand und rechtem Rahmen festlegen. Von welcher Stelle aus der Abstand gemessen wird, hängt vom Wert der DistanceFrom-Eigenschaft ab.


Beispiel zur DistanceFromRight-Eigenschaft

In diesem Beispiel wird ein Rahmen um alle Absätze der Auswahl hinzugefügt, und 3 Punkt wird als Abstand zwischen Text und rechtem Rahmen festgelegt.

With Selection.Paragraphs.Borders
    .Enable = True
    .DistanceFromRight = 3
End With

In diesem Beispiel wird ein einfacher Rand um alle Seiten in Abschnitt 1 des aktiven Dokuments hinzugefügt. Das Beispiel legt außerdem 22 Punkt als Abstand zwischen dem rechten und linken Rahmen und den entsprechenden Rändern der Seite fest.

With ActiveDocument.Sections(1)
    For Each aBord In .Borders
        aBord.LineStyle = wdLineStyleSingle
        aBord.LineWidth = wdLineWidth050pt
    Next aBord
    With .Borders
        .DistanceFrom = wdBorderDistanceFromPageEdge
        .DistanceFromLeft = 22
        .DistanceFromRight = 22
    End With
End With


DistanceFromText-Eigenschaft

DropCap-Objekt: Gibt den Abstand (in Punkt) zwischen dem Initial im Seitenrahmen und dem Absatztext zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

LineNumbering-Objekt: Gibt den Abstand (in Punkt) zwischen der rechten Kante der Zeilennummern und der rechten Kante des Dokumenttextes zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur DistanceFromText-Eigenschaft

In diesem Beispiel werden dem aktiven Dokument Zeilennummern hinzugefügt. Der Abstand zwischen Zeilennummern und dem linken Rahmen beträgt 36 Punkt (1,27 cm).

With ActiveDocument.PageSetup.LineNumbering
    .Active = True
    .CountBy = 5
    .DistanceFromText = 36
End With

In diesem Beispiel wird ein Initial im Seitenrahmen für den ersten Absatz im aktiven Dokument festgelegt. Der Versatz für das Initial im Seitenrahmen wird dann auf 12 Punkt festgelegt.

With ActiveDocument.Paragraphs(1).DropCap
    .Enable
    .FontName= "Arial"
    .Position = wdDropNormal
    .DistanceFromText = 12
End With


DistanceFromTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen Text und oberem Rahmen zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft mit einem Seitenrahmen verwenden, können Sie entweder den Abstand zwischen Text und oberem Seitenrahmen oder den Abstand zwischen Seitenrand und oberem Seitenrahmen festlegen. Von welcher Stelle aus der Abstand gemessen wird, hängt vom Wert der DistanceFrom-Eigenschaft ab.


Beispiel zur DistanceFromTop-Eigenschaft

In diesem Beispiel wird ein Rahmen um alle Absätze der Auswahl hinzugefügt und 3 Punkt als Abstand zwischen Text und oberem Rahmen festgelegt.

With Selection.Borders
    .Enable = True
    .DistanceFromTop = 3
End With

In diesem Beispiel wird ein Rahmen um alle Seiten in Abschnitt 1 der Auswahl hinzugefügt. Das Beispiel legt außerdem 6 Punkt als Abstand zwischen Text und Seitenrahmen fest.

With Selection.Sections(1)
    For Each aBorder In .Borders
        aBorder.ArtStyle = wdArtSeattle
        aBorder.ArtWidth = 22
    Next aBorder
    With .Borders
        .DistanceFrom = wdBorderDistanceFromText
        .DistanceFromTop = 6
        .DistanceFromLeft = 6
        .DistanceFromBottom = 6
        .DistanceFromRight = 6
    End With
End With


DistanceLeft-Eigenschaft

Rows-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem linken Rand der angegebenen Tabelle zurück oder legt diesen fest. Diese Eigenschaft bleibt ohne Auswirkung, wenn WrapAroundText auf False gesetzt ist. Single Schreib-Lese-Zugriff.

WrapFormat-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem linken Rand des textfreien Bereichs um die angegebene Form zurück oder legt ihn fest. Größe und Form der angegebenen Form bestimmen mit den Werten der Type- und Side-Eigenschaften des WrapFormat-Objekts die Größe und Form des textfreien Bereichs. Single Schreib-Lese-Zugriff.


Beispiel zur DistanceLeft-Eigenschaft

In diesem Beispiel wird festgelegt, dass der Text die erste Tabelle im aktiven Dokument umfließt und dass der Abstand des umfließenden Textes zu allen Seiten der Tabelle 20 Punkt beträgt.

With ActiveDocument.Tables(1).Rows
    .WrapAroundText = True
    .DistanceLeft = 20
    .DistanceRight = 20
    .DistanceTop = 20
    .DistanceBottom = 20
End With

In diesem Beispiel wird dem aktiven Dokument eine Ellipse hinzugefügt. Außerdem legen Sie fest, dass der Text die Ellipse eng umbricht. Das Beispiel legt einen 0,1-Zoll-Rand zwischen dem Dokumenttext und der oberen, unteren, linken und rechten Seite der Ellipse fest.

Set myOval = ActiveDocument.Shapes.AddShape(msoShapeOval, _
    0, 0, 200, 50)
With myEll.WrapFormat
    .Type = wdWrapTight
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


DistanceRight-Eigenschaft

Rows-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem rechten Rand der angegebenen Tabelle zurück oder legt diesen fest. Diese Eigenschaft bleibt ohne Auswirkung, wenn WrapAroundText auf False gesetzt ist. Single Schreib-Lese-Zugriff.

WrapFormat-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem rechten Rand des textfreien Bereichs um die angegebene Form zurück oder legt ihn fest. Größe und Form der angegebenen Form bestimmen mit den Werten der Type- und Side-Eigenschaften des WrapFormat-Objekts die Größe und Form des textfreien Bereichs. Single Schreib-Lese-Zugriff.


Beispiel zur DistanceRight-Eigenschaft

In diesem Beispiel wird festgelegt, dass der Text die erste Tabelle im aktiven Dokument umfließt und dass der Abstand des umfließenden Textes zu allen Seiten der Tabelle 20 Punkt beträgt.

With ActiveDocument.Tables(1).Rows
    .WrapAroundText = True
    .DistanceLeft = 20
    .DistanceRight = 20
    .DistanceTop = 20
    .DistanceBottom = 20
End With

In diesem Beispiel wird dem aktiven Dokument eine Ellipse hinzugefügt. Außerdem legen Sie fest, dass der Dokumenttext links und rechts des Quadrats umbrochen wird, das die Ellipse umgibt. Das Beispiel legt einen 0,1-Zoll-Rand zwischen dem Dokumenttext und der oberen, unteren, linken und rechten Seite des Quadrats fest.

Set myOval = ActiveDocument.Shapes.AddShape(msoShapeOval, _
    0, 0, 200, 50)
With myOval.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


DistanceTop-Eigenschaft

Rows-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem oberen Rand der angegebenen Tabelle zurück oder legt diesen fest. Diese Eigenschaft bleibt ohne Auswirkung, wenn WrapAroundText auf False gesetzt ist. Single Schreib-Lese-Zugriff.

WrapFormat-Objekt: Gibt den Abstand (in Punkt) zwischen dem Dokumenttext und dem oberen Rand des textfreien Bereichs um die angegebene Form zurück oder legt ihn fest. Größe und Form der angegebenen Form bestimmen mit den Werten der Type- und Side-Eigenschaften des WrapFormat-Objekts die Größe und Form des textfreien Bereichs. Single Schreib-Lese-Zugriff.


Beispiel zur DistanceTop-Eigenschaft

In diesem Beispiel wird festgelegt, dass der Text die erste Tabelle im aktiven Dokument umfließt und dass der Abstand des umfließenden Textes zu allen Seiten der Tabelle 20 Punkt beträgt.

With ActiveDocument.Tables(1).Rows
    .WrapAroundText = True
    .DistanceLeft = 20
    .DistanceRight = 20
    .DistanceTop = 20
    .DistanceBottom = 20
End With

In diesem Beispiel wird dem aktiven Dokument eine Ellipse hinzugefügt. Außerdem legen Sie fest, dass der Dokumenttext links und rechts des Quadrats umbrochen wird, das die Ellipse umgibt. Das Beispiel legt einen 0,1-Zoll-Rand zwischen dem Dokumenttext und der oberen, unteren, linken und rechten Seite des Quadrats fest.

Set myOval = ActiveDocument.Shapes.AddShape(msoShapeOval, _
    0, 0, 200, 50)
With myOval.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


Document-Eigenschaft

Gibt ein mit dem angegebenen Ausschnitt, Fenster oder der angegebenen Markierung verbundenes Document-Objekt zurück. Nur-Lese-Zugriff.


DocumentMap-Eigenschaft

True, wenn die Dokumentstruktur sichtbar ist. Boolean Schreib-Lese-Zugriff.


DocumentMapPercentWidth-Eigenschaft

Gibt die Breite der Dokumentstruktur als Prozentwert der Breite des angegebenen Fensters zurück oder legt diese fest. Long Schreib-Lese-Zugriff.


Beispiel zur DocumentMapPercentWidth-Eigenschaft

Dieses Beispiel zeigt die Dokumentstruktur für das aktive Fenster an und legt für die Breite der Struktur 25 Prozent der Fensterbreite fest.

With ActiveDocument.ActiveWindow
    .DocumentMap = True
    .DocumentMapPercentWidth = 25
End With


Documents-Eigenschaft

Gibt eine Documents-Auflistung zurück, die alle geöffneten Dokumente darstellt. Nur-Lese-Zugriff.

Weitere Informationen zum Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Documents-Eigenschaft

In diesem Beispiel wird ein neues Dokument mit der Vorlage "Normal" erstellt und anschließend das Dialogfeld Save as angezeigt.

Documents.Add.Save

In diesem Beispiel werden geöffnete Dokumente gespeichert, die seit dem letzten Speichern geändert wurden.

For Each aDoc In Documents
   If aDoc.Saved = False Then aDoc.Save
Next aDoc

In diesem Beispiel werden alle geöffneten Dokumente gedruckt, nachdem der rechte sowie der linke Seitenrand auf 0,5 Zoll eingestellt wurden.

For Each openDoc In Documents
    With openDoc
        .PageSetup.LeftMargin = InchesToPoints(0.5)
        .PageSetup.RightMargin = InchesToPoints(0.5)
        .PrintOut
    End With
Next openDoc

In diesem Beispiel wird MyDoc.doc als schreibgeschütztes Dokument geöffnet.

Documents.Open FileName:="C:\MyFiles\MyDoc.doc", ReadOnly:=True


DocumentViewDirection-Eigenschaft

Sprachspezifische Informationen

Returns or sets the alignment and reading order for the entire document. Read/write Long.

Can be either of the following WdDocumentViewDirection constants.

Constant | Description
wdDocumentViewLtr | Displays the document with left alignment and left-to-right reading order.
wdDocumentViewRtl | Displays the document with right alignment and right-to-left reading order.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur DocumentViewDirection-Eigenschaft

This example sets the alignment to right and the reading order to right-to-left for the entire document.

Options.DocumentViewDirection = wdDocumentViewRtl


DotMatrix-Eigenschaft

True, wenn der Druckertyp für das angegebene benutzerdefinierte Etikett "Nadeldrucker" lautet. False, wenn es sich beim Druckertyp entweder um "Laser" oder "Tintenstrahl" handelt. Boolean Nur-Lese-Zugriff.


Beispiel zur DotMatrix-Eigenschaft

In diesem Beispiel werden der Name und der Druckertyp für das erste benutzerdefinierte Adressetikett angezeigt.

Set myLabel = Application.MailingLabel
If myLabel.CustomLabels.Count >= 1 Then
    If myLabel.CustomLabels(1).DotMatrix = True Then
        MsgBox myLabel.CustomLabels(1).Name & " is dot matrix"
    Else
        MsgBox myLabel.CustomLabels(1).Name _
            & " is laser or ink jet"
    End If
End If


DoubleQuote-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word encloses the specified PageNumbers object in double quotation marks ("). Read/write Boolean.

Remarks

To set Word to enclose page numbers in double quotation marks by default, use the AddHebDoubleQuote property.

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur DoubleQuote-Eigenschaft

This example encloses the page numbers in the first footer of the active document in double quotation marks (").

ActiveDocument.Sections(1).Footers(1) _
    .PageNumbers.DoubleQuote = True


DoubleStrikeThrough-Eigenschaft

True, wenn die angegebene Schriftart als doppelt durchgestrichener Text formatiert ist. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle festgelegt werden. Long Schreib-Lese-Zugriff.

Hinweis Zum Einstellen oder Zurückgeben der Formatierung von einfach durchgestrichenem Text verwenden Sie die StrikeThrough-Eigenschaft. Durch Einstellung von DoubleStrikeThrough auf True wird StrikeThrough auf False eingestellt und umgekehrt.


Beispiel zur DoubleStrikeThrough-Eigenschaft

In diesem Beispiel wird dem markierten Text die Formatierung "DoubleStrikeThrough" zugewiesen.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.DoubleStrikeThrough = True
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird die Formatierung "DoubleStrikeThrough" vom ersten Wort im aktiven Dokument entfernt und der erste Buchstabe im Wort groß geschrieben.

With ActiveDocument.Words(1)
    .Font.DoubleStrikeThrough = False
    .Case = wdTitleSentence
End With


Draft-Eigenschaft

True, wenn der gesamte Text in einem Fenster in derselben serifenlosen Schriftart mit minimaler Formatierung angezeigt wird, um den Bildschirmaufbau zu beschleunigen. Boolean Schreib-Lese-Zugriff.


Beispiel zur Draft-Eigenschaft

In diesem Beispiel wird der Inhalt des Fensters für Dokument1 in der Konzeptschriftart angezeigt.

Windows("Document1").View.Draft = True

In diesem Beispiel wird für das aktive Fenster die Option Konzeptschriftart umgeschaltet.

ActiveDocument.ActiveWindow.View.Draft = _
    Not ActiveDocument.ActiveWindow.View.Draft


Drop-Eigenschaft

Für Legenden mit einem explizit festgelegten Ansatz-Wert gibt diese Eigenschaft den vertikalen Abstand (in Punkt) der Kante des Rechtecks, das den Textbereich begrenzt, von der Stelle, an der die Legendenlinie am Textfeld ansetzt, zurück. Dieser Abstand wird von der oberen Kante des Textfelds gemessen, außer wenn die AutoAttach-Eigenschaft True ist und das Textfeld sich links vom Ursprung der Legendenlinie (der Stelle, auf die die Legende hinweist) befindet. In diesem Fall wird der Abstand des Ansatzes von der unteren Kante des Textfelds gemessen. Single Nur-Lese-Zugriff.

Anmerkungen

Verwenden Sie die CustomDrop-Methode zum Festlegen des Werts dieser Eigenschaft.

Der Wert dieser Eigenschaft spiegelt die Position des Legendenlinien-Ansatzes am Textfeld nur dann genau wider, wenn die Legende einen explizit festgelegten Ansatzwert hat, das heißt, wenn der Wert der DropType-Eigenschaft msoCalloutDropCustom ist. Verwenden Sie die Anweisung PresetDrop msoCalloutCustomDrop zum Festlegen der DropType-Eigenschaft auf msoCalloutDropCustom.


DropCap-Eigenschaft

Gibt ein DropCap-Objekt zurück, das für den angegebenen Absatz einen Anfangs-Großbuchstaben im Text darstellt. Nur-Lese-Zugriff.


Beispiel zur DropCap-Eigenschaft

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument ein Anfangs-Großbuchstabe im Text festgelegt.

With ActiveDocument.Paragraphs(1).DropCap
    .FontName = "Arial"
    .Position = wdDropNormal
    .LinesToDrop = 3
    .DistanceFromText = InchesToPoints(0.1)
End With


DropDown-Eigenschaft

Gibt ein DropDown-Objekt zurück, das ein Dropdown-Formularfeld darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wird die DropDown-Eigenschaft auf ein FormField-Objekt angewendet, bei dem es sich nicht um ein Kontrollkästchen-Formularfeld handelt, dann entsteht durch die Eigenschaft kein Fehler, aber die Valid-Eigenschaft für das zurückgegebene Objekt lautet False.


Beispiel zur DropDown-Eigenschaft

In diesem Beispiel wird der Text des gewählten Elements im Dropdown-Formularfeld "Colors" angezeigt.

Set myDrop = ActiveDocument.FormFields("Colors").DropDown
MsgBox myDrop.ListEntries(myDrop.Value).Name

In diesem Beispiel wird "Seattle" in das Dropdown-Formularfeld "Places" in Form.doc aufgenommen.

With Documents("Form.doc").FormFields("Places") _
        .DropDown.ListEntries
    .Add Name:="Seattle"
End With


DropType-Eigenschaft

Gibt einen Wert zurück, der anzeigt, wo die Legendenlinie am Legendentextfeld ansetzt. Dies kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter, msoCalloutDropCustom, msoCalloutDropMixed oder msoCalloutDropTop. Long Nur-Lese-Zugriff.

Anmerkungen

Wenn der Legenden-Ansatztyp msoCalloutDropCustom ist, ermitteln die Werte der Drop- und AutoAttach-Eigenschaft die relativen Positionen des Legendentextfelds sowie des Legendenlinien-Ursprungs (der Stelle, auf die die Legende hinweist), wo die Legendenlinie am Textfeld ansetzt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetDrop-Methode zum Festlegen des Werts dieser Eigenschaft.


Beispiel zur DropType-Eigenschaft

In diesem Beispiel wird geprüft, ob Form drei in myDocument eine Legende mit einem benutzerdefinierten Ansatz ist. Wenn das der Fall ist, ersetzt der Code den benutzerdefinierten Ansatz durch einen von zwei voreingestellten Ansätzen, in Abhängigkeit davon, ob der benutzerdefinierte Ansatzwert größer oder kleiner als die halbe Höhe des Legendentextfelds ist.

Set myDocument = ActiveDocument
With myDocument.Shapes(3)
    If .Type = msoCallout Then
        With .Callout
            If .DropType = msoCalloutDropCustom Then
                If .Drop < .Parent.Height / 2 Then
                    .PresetDrop msoCalloutDropTop
                Else
                    .PresetDrop msoCalloutDropBottom
                End If
            End If
        End With
    End If
End With


Duplicate-Eigenschaft

Font-Objekt: Gibt ein Font-Objekt zurück, das die Zeichenformatierung für die angegebene Schriftart repräsentiert. Nur-Lese-Zugriff.

LetterContent-Objekt: Gibt ein LetterContent-Objekt zurück, das den Inhalt des angegebenen Briefes repräsentiert, der vom Brief-Assistenten erstellt wurde. Nur-Lese-Zugriff.

ParagraphFormat-Objekt: Gibt ein ParagraphFormat-Objekt zurück, das die Absatzformatierung des angegebenen Absatzes repräsentiert. Nur-Lese-Zugriff.

Range-Objekt: Gibt ein Range-Objekt zurück, das alle Eigenschaften des angegebenen Bereichs repräsentiert. Nur-Lese-Zugriff.

TextRetrievalMode-Objekt: Gibt ein TextRetrievalMode-Objekt zurück, das die Optionen repräsentiert, die das Abrufen von Text vom angegebenen Range-Objekt betreffen. Nur-Lese-Zugriff.

Anmerkungen

Mit der Duplicate-Eigenschaft können Sie die Einstellungen aller Eigenschaften eines duplizierten Font-, LetterContent- oder ParagraphFormat-Objekts übernehmen. Sie können das von der Duplicate-Eigenschaft zurückgegebene Objekt einem anderen Objekt desselben Typs zuweisen, um gleichzeitig alle Einstellungen zuzuweisen. Bevor Sie ein dupliziertes Objekt einem anderen Objekt zuweisen, können Sie beliebige Eigenschaften des duplizierten Objekts ändern, ohne dass sich diese Änderungen auf das Original auswirken.

Wenn Sie ein Range-Objekt duplizieren, können Sie die Position des Start- und Endzeichens im duplizierten Bereich ändern, ohne dass dadurch der Originalbereich betroffen wäre.


Beispiel zur Duplicate-Eigenschaft

In diesem Beispiel wird das Range-Objekt dupliziert, das der Variablen myRange zugewiesen ist. Der duplizierte Bereich wird auf seinen Endpunkt reduziert, um ein Zeichen erweitert, und anschließend wird dieses Zeichen in einen Großbuchstaben umgewandelt. Danach wird die Formatierung "Italic" dem ursprünglichen Range-Objekt (myRange)zugewiesen.

Set myRange = Selection.Range
With myRange.Duplicate
    .Collapse Direction:=wdCollapseEnd
    .Expand Unit:=wdCharacter
    .Case = wdUpperCase
End With
myRange.Font.Italic = True

In diesem Beispiel wird als Wert für die Variable myDupFont die Zeichenformatierung der Auswahl festgelegt, die Formatierung "Bold" wird von myDupFont entfernt und stattdessen die Formatierung "Italic" hinzugefügt. Das Beispiel erstellt außerdem ein neues Dokument, fügt Text in das Dokument ein und weist dann die in myDupFont gespeicherte Formatierung dem Text zu.

Set myDupFont = Selection.Font.Duplicate
With myDupFont
    .Bold = False
    .Italic = True
End With
Documents.Add
Selection.InsertAfter "This is some text."
Selection.Font = myDupFont

In diesem Beispiel wird die Absatzformatierung des ersten Absatzes im aktiven Dokument dupliziert und die Formatierung in der Variablen myDup gespeichert. Anschließend wird 1 Zoll als Wert für den linken Einzug für myDup festgelegt. Das Beispiel erstellt außerdem ein neues Dokument, fügt Text in das Dokument ein und weist dann die in myDup gespeicherte Absatzformatierung dem Text zu.

ActiveDocument.Range(Start:=0, End:=0).InsertAfter _
    "Paragraph Number 1"
Set myDup = ActiveDocument.Paragraphs(1).Format.Duplicate
myDup.LeftIndent = InchesToPoints(1)
Documents.Add
Selection.InsertAfter "This is a new paragraph."
Selection.Paragraphs.Format = myDup


EditingType-Eigenschaft

Wenn der angegebene Knoten ein Scheitelpunkt ist, gibt diese Eigenschaft einen Wert zurück, der anzeigt, wie Änderungen, die am Knoten vorgenommen wurden, sich auf die zwei Segmente auswirken, die mit dem Knoten verbunden sind. Dies kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric. Wenn der Knoten ein Kontrollpunkt für ein gekrümmtes Segment ist, gibt diese Eigenschaft den Editing-Typ des angrenzenden Scheitelpunkts zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetEditingType-Methode zum Festlegen des Werts dieser Eigenschaft.


Beispiel zur EditingType-Eigenschaft

In diesem Beispiel werden in myDocument in Form drei alle Eckknoten in geglättete Knoten umgewandelt. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


Email-Eigenschaft

Gibt ein Email-Objekt zurück, das alle auf E-Mail bezogenen Eigenschaften des aktuellen Dokuments enthält. Nur-Lese-Zugriff.


EmailOptions-Eigenschaft

Gibt ein EmailOptions-Objekt zurück, das die globalen Einstellungen für das Verfassen von E-Mail-Nachrichten enthält. Nur-Lese-Zugriff.


Beispiel zur EmailOptions-Eigenschaft

In diesem Beispiel wird festgelegt, dass Kommentare in E-Mail-Nachrichten von Microsoft Word markiert werden.

Application.EmailOptions.MarkComments = True


EmailSignature-Eigenschaft

Gibt ein EmailSignature-Objekt zurück, das die Signaturen darstellt, die Microsoft Word an ausgehende E-Mail-Nachrichten anhängt. Nur-Lese-Zugriff.


Beispiel zur EmailSignature-Eigenschaft

In diesem Beispiel werden die Signaturen angezeigt, die Word an ausgehende E-Mail-Nachrichten anhängt.

With Application.EmailOptions.EmailSignature
    If .NewMessageSignature = "" Then
        MsgBox "There is no signature for new " _
            & "e-mail messages!"
    Else
        MsgBox "The signature for new e-mail" _
            & "messages is: " & vbLf & vbLf _
            & .NewMessageSignature
    End If
End With


EmailSubject-Eigenschaft

Gibt die Zeichenfolge für die Betreffzeile des angegebenen Hyperlinks zurück oder legt diese fest. Die Betreffzeile wird der Internetadresse des Hyperlinks oder URLs angefügt. String Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft wird im Allgemeinen in Verbindung mit E-Mail-Hyperlinks verwendet. Der Wert dieser Eigenschaft hat Vorrang vor jedem durch die Address-Eigenschaft festgelegten E-Mail-Betreff desselben Hyperlink-Objekts.


Beispiel zur EmailSubject-Eigenschaft

In diesem Beispiel wird das aktive Dokument auf E-Mail-Hyperlinks überprüft. Wenn Hyperlinks mit einer leere Betreffzeile gefunden werden, wird in diese "NewProducts" eingefügt.

For Each hlk In ActiveDocument.Hyperlinks
    If hlk.Address Like "mailto*" And _
            hlk.Address = hlk.EmailSubject Then
        hlk.EmailSubject = "NewProducts"
    End If
Next hlk


EmbedTrueTypeFonts-Eigenschaft

True, wenn Word TrueType-Schriftarten in einem Dokument beim Speichern einbettet. Dadurch sind andere Benutzer in der Lage, das Dokument mit denselben Schriftarten wie bei der Erstellung anzuzeigen. Boolean Schreib-Lese-Zugriff.


Beispiel zur EmbedTrueTypeFonts-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass TrueType-Schriftarten automatisch beim Speichern eines Dokuments eingebettet werden und dann wird das aktive Dokument gespeichert.

ActiveDocument.EmbedTrueTypeFonts = True
ActiveDocument.Save

In diesem Beispiel wird der aktuelle Status der Option TrueType-Schriftarten einbetten auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = ActiveDocument.EmbedTrueTypeFonts


Emboss-Eigenschaft

True, wenn die angegebene Schriftart erhaben formatiert ist. Gibt True, False oder wdUndefined zurück. Kann auf True, False oder wdToggle eingestellt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Stellt man Emboss auf True ein, wird Engrave auf False eingestellt, und umgekehrt.


Beispiel zur Emboss-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument der zweite Satz in erhabener Schrift formatiert.

With Documents.Add.Content
    .InsertAfter "This is the first sentence. "
    .InsertAfter "This is the second sentence. "
    .Sentences(2).Font.Emboss = True
End With

In diesem Beispiel wird der markierte Text in erhabener Schrift formatiert.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Emboss = True
Else
    MsgBox "You need to select some text."
End If


EmphasisMark-Eigenschaften

Sprachspezifische Informationen

Returns or sets the emphasis mark for a character or designated character string. Can be one of the following WdEmphasisMark constants: wdEmphasisMarkNone, wdEmphasisMarkOverComma, wdEmphasisMarkOverSolidCircle, wdEmphasisMarkOverWhiteCircle, or wdEmphasisMarkUnderSolidCircle. Read/write Long.


Beispiel zur EmphasisMark-Eigenschaft

This example sets the emphasis mark over the fourth word in the active document to a comma.

ActiveDocument.Words(4).EmphasisMark = wdEmphasisMarkOverComma


Empty-Eigenschaft

True, wenn die angegebene Textmarke leer ist. Eine leere Textmarke markiert eine Position (eine reduzierte Auswahl); Text wird nicht markiert. Boolean Nur-Lese-Zugriff.

Hinweis Ein Fehler tritt auf, wenn die angegebene Textmarke nicht existiert. Mit der Exists-Eigenschaft können Sie feststellen, ob eine Textmarke existiert.


Beispiel zur Empty-Eigenschaft

In diesem Beispiel wird festgestellt, ob die Textmarke "temp" existiert und leer ist.

If ActiveDocument.Bookmarks.Exists("temp") = True Then
    If ActiveDocument.Bookmarks("temp").Empty = True Then _
    MsgBox "The Temp bookmark is empty"
End If


Enable-Eigenschaft

Gibt die Rahmenformatierung für das angegebene Objekt zurück oder legt sie fest. Gibt True oder wdUndefined zurück, wenn die Rahmenformatierung ganz oder teilweise auf das angegebene Objekt angewendet wurde. Sie kann auf True, False oder eine WdLineStyle-Konstante gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Enable-Eigenschaft betrifft alle Ränder für das angegebene Objekt. True wählt als Linienart die Standard-Linienart und als Linienstärke die Standard-Linienstärke. Die Standard-Linienart und die Standard-Linienstärke legen Sie mit der DefaultBorderLineWidth-Eigenschaft und der DefaultBorderLineStyle-Eigenschaft fest.

Um alle Ränder eines Objekts zu entfernen, setzen Sie, wie im folgenen Beispiel, die Enable-Eigenschaft auf False.

ActiveDocument.Tables(1).Borders.Enable = False

Um einen einzigen Rahmen zu entfernen oder zu ziehen, benutzen Sie Borders(Index) mit Index als einer WdBorderType-Konstanten, um einen Rahmen zurückzugeben, und legen Sie dann die LineStyle-Eigenschaft fest. Das folgende Beispiel entfernt den unteren Rahmen aus myRange.

myRange.Borders(wdBorderBottom).LineStyle = wdLineStyleNone


EnableCancelKey-Eigenschaft

Gibt die Vorgehensweise zurück, die Word bei der Umsetzung von Unterbrechungen durch den Benutzer mit STRG+PAUSE durchführt, oder legt sie fest. Dies kann eine der folgenden WdEnableCancelKey-Konstanten sein: wdCancelDisabled (verhindert die Unterbrechung eines Makros durch STRG+PAUSE) oder wdCancelInterrupt (ermöglicht die Unterbrechung eines Makros durch STRG+PAUSE). Long Schreib-Lese-Zugriff.

Hinweise

Gehen Sie bei der Verwendung dieser Eigenschaft sorgfältig vor. Wenn Sie wdCancelDisabled einsetzen, haben Sie keine Möglichkeit, eine Endlosschleife oder einen anderen nicht selbstterminierenden Code zu unterbrechen. Die EnableCancelKey-Eigenschaft wird nicht auf wdCancelInterrupt zurückgesetzt, wenn die Ausführung des Codes beendet ist. Wenn Sie die Eigenschaft also nicht ausdrücklich zurücksetzen, bleibt sie für die gesamte Word-Sitzung auf wdCancelDisabled gesetzt.


Beispiel zur EnableCancelKey-Eigenschaft

In diesem Beispiel wird festgelegt, dass eine Zählerschleife durch STRG+PAUSE nicht unterbrochen werden kann.

Application.EnableCancelKey = wdCancelDisabled
For i = 1 To 10000
    StatusBar = i
Next i
Application.EnableCancelKey = wdCancelInterrupt


Enabled-Eigenschaft

True, bei einem aktivierten Formularfeld. Der Inhalt eines aktivierten Formularfelds kann beim Ausfüllen des Formulars geändert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur Enabled-Eigenschaft

Wenn es sich beim ersten Formularfeld im aktiven Dokument um ein aktiviertes Kontrollkästchen handelt, dann wird in diesem Beispiel das Kontrollkästchen gewählt.

Set myFField = ActiveDocument.FormFields(1)
If myFField.Enabled = True And _
        myFField.Type = wdFieldFormCheckBox Then
    myFField.CheckBox.Value = True
End If


EnableFirstPageInSection-Eigenschaft

True, wenn Seitenrahmen für die erste Seite in der Auswahl aktiviert sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableFirstPageInSection-Eigenschaft

In diesem Beispiel wird ein Rahmen um die erste Seite im ersten Abschnitt der Auswahl hinzugefügt.

With Selection.Sections(1)
    .Borders.EnableFirstPageInSection = True
    .Borders.EnableOtherPagesInSection = False
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtPeople
        aBord.ArtWidth = 15
    Next aBord
End With


EnableHangulHanjaRecentOrdering-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word displays the most recently used words at the top of the suggestions list during conversion between hangul and hanja. Read/write Boolean.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur EnableHangulHanjaRecentOrdering-Eigenschaft

This example asks the user whether to set Microsoft Word to display the most recently used words at the top of the suggestions list during conversion between hangul and hanja.

x = MsgBox("Display most recently used words " _
    & "at the top of the suggestions list?", vbYesNo)
If x = vbYes Then
    Options.EnableHangulHanjaRecentOrdering = True
Else
    Options.EnableHangulHanjaRecentOrdering = False
End If


EnableMisusedWordsDictionary-Eigenschaft

True, wenn Microsoft Word bei der Rechtschreib- und Grammatikprüfung in einem Dokument nach falsch verwendeten Wörtern sucht (nur bei englischen Texten mit installierter englischer Rechtschreib- und Grammatikprüfung). Boolean Schreib-Lese-Zugriff.

Hinweise

Word sucht nach folgenden falsch verwendeten Wörtern: falsche Verwendung von Adjektiven und Adverben, Komparativen und Superlativen, "like" als Konjunktion, "nor" anstelle von "or," "what" anstelle von "which," "who" anstelle von "whom," Maßeinheiten, Konjunktionen, Präpositionen und Pronomen.


Beispiel zur EnableMisusedWordsDictionary-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word bei der Rechtschreib- und Grammatikprüfung die falsche Verwendung von Wörtern ignoriert.

Options.EnableMisusedWordsDictionary = False


EnableOtherPagesInSection-Eigenschaft

True, wenn Seitenrahmen für alle Seiten, außer der ersten Seite, im Abschnitt aktiviert sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableOtherPagesInSection-Eigenschaft

In diesem Beispiel wird ein Rahmen um alle Seiten, außer der ersten Seite, im ersten Abschnitt der Auswahl hinzugefügt.

With Selection.Sections(1)
    .Borders.EnableFirstPageInSection = False
    .Borders.EnableOtherPagesInSection = True
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtBabyRattle
        aBord.ArtWidth = 22
    Next aBord
End With


EnableSound-Eigenschaft

True, wenn ein Geräusch ertönt, sobald ein Fehler in Word auftritt. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableSound-Eigenschaft

In diesem Beispiel wird die Option Audio-Feedback auf der Registerkarte Allgemein im Dialogfeld Optionen, abhängig von der Benutzereingabe, festgelegt.

If MsgBox("Do you want Word to beep on errors?", 36) = vbYes Then
    Options.EnableSound = True
Else
    Options.EnableSound = False
End If


EnclosureNumber-Eigenschaft

Gibt die Anzahl der Anlagen für einen Brief, der mit dem Brief-Assistenten erstellt wurde, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur EnclosureNumber-Eigenschaft

In diesem Beispiel wird die Anzahl der Anlagen angezeigt, die für das aktive Dokument festgelegt wurde.

MsgBox ActiveDocument.GetLetterContent.EnclosureNumber

In diesem Beispiel werden Briefelemente aus dem aktiven Dokument geladen, die Anzahl der Anlagen wird mit der EnclosureNumber-Eigenschaft geändert und anschließend das aktive Dokument mit der SetLetterContent-Methode aktualisiert, um die Änderungen zu reflektieren.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.EnclosureNumber = "5"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


Encoding-Eigenschaft

Gibt die Dokumentcodierung (Codepage oder Zeichensatz) zurück, die beim Betrachten eines gespeicherten Dokuments vom Webbrowser verwendet werden soll, oder legt diese fest. Dabei kann es sich um jede gültige MsoEncoding-Konstante handeln. Standardmäßig ist die Codepage des Systems festgelegt. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen MsoEncoding-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors. Sie können keine Konstante mit dem Suffix AutoDetect verwenden. Diese Konstanten werden von der ReloadAs-Methode verwendet.


Beispiel zur Encoding-Eigenschaft

In diesem Beispiel wird überprüft, ob die Standarddokumentcodierung Western vorliegt, und anschließend die String-Variable strDocEncoding entsprechend festgelegt.

If Application.DefaultWebOptions.Encoding _
        = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Other"
End If


End-Eigenschaft

Gibt die Endzeichenposition einer Markierung, eines Bereichs oder einer Textmarke zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkung Wenn diese Eigenschaft auf einen Wert kleiner als die Start-Eigenschaft eingestellt wird, dann wird die Start-Eigenschaft auf denselben Wert eingestellt (das heißt, die Start- und die End-Eigenschaft sind gleich).

Hinweise

Die Selection-, Range- und Bookmark-Objekte haben alle eine Anfangsposition und eine Endposition. Die Endposition ist der Punkt, der am weitesten vom Anfang der Dokumentkomponente entfernt ist.

Diese Eigenschaft gibt die Endzeichenposition relativ zum Anfang der Dokumentkomponente zurück. Die Hauptdokumentkomponente (wdMainTextStory) beginnt mit der Zeichenposition 0 (Null). Sie können die Größe einer Markierung, eines Bereichs oder einer Textmarke ändern, indem Sie diese Eigenschaft einstellen.


EndArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Ende der angegebenen Linie zurück oder legt sie fest. Dies kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadLength-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Ende der angegebenen Linie zurück oder legt sie fest. Dabei kann es sich um eine der folgenden MsoArrowheadStyle-Konstanten handeln: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadStyle-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadWidth-Eigenschaft

Gibt die Breite der Pfeilspitze am Ende der angegebenen Linie zurück oder legt diese fest. Dabei kann es sich um eine der folgenden MsoArrowheadWidth-Konstanten handeln: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadWidth-Eigenschaft

In diesem Beispiel wird zu myDocument eine Linie hinzugefügt. Am Anfangspunkt der Linie ist ein kurzes, schmales Oval und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


Endnotes-Eigenschaft

Gibt eine Endnotes-Auflistung zurück, die alle Endnoten in einem Bereich, einer Markierung oder einem Dokument darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Endnotes-Eigenschaft

Dieses Beispiel positioniert die Endnoten im aktiven Dokument am Ende des Dokuments und formatiert die Endnotenzeichen als römische Ziffern in Kleinschreibung.

With ActiveDocument.Endnotes
    .Location = wdEndOfDocument
    .NumberStyle = wdNoteNumberStyleLowercaseRoman
End With


Engrave-Eigenschaft

True, wenn die Schriftart als Gravur formatiert ist. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie Engrave auf True setzen, wird Emboss auf False gesetzt und umgekehrt.


Beispiel zur Engrave-Eigenschaft

In diesem Beispiel wird der erste Buchstabe im aktiven Dokument als Gravur formatiert.

Set myRange = ActiveDocument.Characters(1)
With myRange.Font
    .Size = 20
    .Engrave = True
End With

In diesem Beispiel wird die Schriftart für die Auswahl als Gravur formatiert.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Engrave = True
Else
    MsgBox "You need to select some text."
End If


EnlargeFontsLessThan-Eigenschaft

Gibt den Schriftgrad zurück, unter dem Bildschirmschriftarten automatisch vergrößert werden, oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft hat nur Auswirkungen auf den Text, wie er in der Weblayoutansicht zu sehen ist. Die Schriftgrade, die auf der Symbolleiste Format angezeigt und zum Drucken verwendet werden, werden nicht geändert.


Entries-Eigenschaft

Gibt eine AutoCorrectEntries-Auflistung zurück, in der die aktuelle Liste der AutoCorrect-Einträge wiedergegeben wird. Diese Liste entspricht der Liste der AutoKorrektur-Einträge auf der Registerkarte AutoKorrektur im Dialogfeld AutoKorrektur (Menü Extras). Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Entries-Eigenschaft

In diesem Beispiel wird die Gesamtanzahl aller AutoKorrektur-Einträge angezeigt.

MsgBox AutoCorrect.Entries.Count

Dieses Beispiel löscht den angegebenen AutoKorrektur-Eintrag, falls einer gefunden wird.

myValue = InputBox("Enter the AutoCorrect entry to delete.")
For Each anEntry in AutoCorrect.Entries
    If anEntry.Name = myValue Then
        myMatch = True
        myConfirm = MsgBox("Are you sure you want to delete " _
            & anEntry.Name, 4)
        If myConfirm = vbYes Then
            anEntry.Delete
        End If
    End If
Next anEntry
If myMatch <> True Then
    MsgBox "There was no AutoCorrect entry: " & myValue
End If


EntryMacro-Eigenschaft

Gibt den Namen des Eingabe-Makros für das angegebene Formularfeld zurück oder legt ihn fest (CheckBox, DropDown oder TextInput). Das Eingabe-Makro wird aufgerufen, wenn das Formularfeld fokussiert wird. String Schreib-Lese-Zugriff.


Beispiel zur EntryMacro-Eigenschaft

In diesem Beispiel wird das Makro "Blue" dem ersten Formularfeld in "Form.doc" zugewiesen.

Documents("Form.doc").FormFields(1).EntryMacro = "Blue"

In diesem Beispiel wird das Makro "Breadth" dem Formularfeld "Text1" im aktiven Dokument zugewiesen.

ActiveDocument.FormFields("Text1").EntryMacro = "Breadth"


EntrySeparator-Eigenschaft

Gibt die Zeichen (bis zu fünf) zurück, die zwischen die Einträge in einem Rechtsgrundlagenverzeichnis und die entsprechenden Seitenzahlen gesetzt werden, oder legt sie fest. Als Standardwert wird ein Tabulatorzeichen mit Punkten als Füllzeichen verwendet. Entspricht dem Schalter \e in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). String Schreib-Lese-Zugriff.


Beispiel zur EntrySeparator-Eigenschaft

In diesem Beispiel wird ein Rechtsgrundlagenverzeichnis in das aktuelle Dokument eingefügt und dann festgelegt, dass zwischen den Einträgen und den entsprechenden Seitenzahlen Kommata gesetzt werden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
ActiveDocument.TablesOfAuthorities.Add Range:=myRange, Category:=1
For Each aToa In ActiveDocument.TablesOfAuthorities
    aToa.EntrySeparator = ", "
Next aToa

In diesem Beispiel wird das Trennzeichen zwischen den Einträgen und den entsprechenden Seitenzahlen im ersten Rechtsgrundlagenverzeichnis zurückgegeben.

entrysep = ActiveDocument.TablesOfAuthorities(1).EntrySeparator


Envelope-Eigenschaft

Gibt ein Envelope-Objekt zurück, das die Funktionalität des Briefumschlags und den Briefumschlag im angegebenen Dokument repräsentiert. Nur-Lese-Zugriff.


EnvelopeFeederInstalled-Eigenschaft

True, wenn der aktuelle Drucker über einen speziellen Einzug für Briefumschläge verfügt. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnvelopeFeederInstalled-Eigenschaft

In diesem Beispiel wird das aktive Dokument als Umschlag gedruckt, falls ein Einzug für Briefumschläge installiert wurde.

If Options.EnvelopeFeederInstalled = True Then
    ActiveDocument.Envelope.PrintOut _
        AddressFromLeft:=InchesToPoints(3), _
        AddressFromTop:=InchesToPoints(1.5)
Else
    Msgbox "No envelope feeder available."
End If


EnvelopeVisible-Eigenschaft

True, wenn die Kopfzeile der E-Mail-Nachricht im Dokumentfenster sichtbar ist. Der Standardwert ist False. Diese Eigenschaft hat keine Auswirkung, wenn es sich bei dem Dokument nicht um eine E-Mail-Nachricht handelt. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnvelopeVisible-Eigenschaft

In diesem Beispiel wird die Kopfzeile einer E-Mail-Nachricht dargestellt.

ActiveWindow.EnvelopeVisible = True


EvenlySpaced-Eigenschaft

True, wenn Textspalten den gleichen Abstand voneinander haben. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie die Spacing- oder Width-Eigenschaft des TextColumns-Objekts einstellen, wird die EvenlySpaced-Eigenschaft automatisch auf True gesetzt. Durch die Einstellung der EvenlySpaced-Eigenschaft können auch die Einstellungen für die Spacing- und die Width-Eigenschaft des TextColumns-Objekts geändert werden.


Beispiel zur EvenlySpaced-Eigenschaft

In diesem Beispiel werden im aktiven Dokument die Spalten so eingestellt, dass sie den gleichen Abstand voneinander haben.

Set myCols = ActiveDocument.PageSetup.TextColumns
    If myCols.Count > 1 Then myCols.EvenlySpaced = True

In diesem Beispiel wird der Status der Option Gleiche Spaltenbreite im Dialogfeld Spalten (Menü Format) zurückgegeben.

temp = ActiveDocument.PageSetup.TextColumns.EvenlySpaced


Exists-Eigenschaft

True, wenn das angegebene HeaderFooter-Objekt vorhanden ist. Boolean Schreib-Lese-Zugriff.

Hinweis Standardmäßig existiert die primäre Kopf- und Fußzeile in allen neuen Dokumenten. Mit dieser Methode können Sie bestimmen, ob Kopf- oder Fußzeilen auf der ersten Seite oder auf ungeraden Seiten vorhanden sind. Sie können auch mit der DifferentFirstPageHeaderFooter- oder der OddAndEvenPagesHeaderFooter-Eigenschaft die Anzahl der Kopf- und Fußzeilen im angegebenen Dokument oder Abschnitt zurückgeben oder festlegen.


Beispiel zur Exists-Eigenschaft

Existiert in Abschnitt 1 eine Kopfzeile auf der ersten Seite, wird der Text für die Kopfzeile festgelegt.

Set aSection = ActiveDocument.Sections(1)
If aSection.Headers(wdHeaderFooterFirstPage).Exists = True Then
    aSection.Headers(wdHeaderFooterFirstPage).Range.Text = _
        "First Page"
End If


ExitMacro-Eigenschaft

Gibt den Namen des Schließ-Makros für das angegebene Formularfeld (CheckBox, DropDown oder TextInput) zurück. Das Schließ-Makro wird aufgerufen, wenn das Formularfeld den Fokus verliert. String Schreib-Lese-Zugriff.


Beispiel zur ExitMacro-Eigenschaft

In diesem Beispiel wird das Makro "Reformat" dem ersten Formularfeld in der Markierung zugewiesen.

If Selection.FormFields.Count > 0 Then _
    Selection.FormFields(1).ExitMacro = "Reformat"

In diesem Beispiel wird das Makro "Blue" dem letzten Formularfeld in "Form.doc" zugewiesen.

iMax = Documents("Form.doc").FormFields.Count
Documents("Form.doc").FormFields(iMax).ExitMacro = "Blue"


Expanded-Eigenschaft

True, wenn Filialdokumente im angegebenen Dokument erweitert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur Expanded-Eigenschaft

In diesem Beispiel werden alle Filialdokumente im aktiven Zentraldokument erweitert.

If ActiveDocument.Subdocuments.Count >= 1 Then
    ActiveDocument.Subdocuments.Expanded = True
End If

In diesem Beispiel wird der Wert der Expanded-Eigenschaft gewechselt, so dass alle Filialdokumente im aktiven Dokument erweitert und reduziert werden.

ActiveDocument.Subdocuments.Expanded = _
    Not ActiveDocument.Subdocuments.Expanded

Dieses Beispiel stellt fest, ob die Filialdokumente in Bericht.doc erweitert sind, und zeigt eine Meldung mit ihrem Status an.

If Documents("Report.doc").Subdocuments.Expanded = True Then
    MsgBox "All available information is displayed."
Else
    MsgBox "Expand subdocuments for more information."
End If


ExtendMode-Eigenschaft

True, wenn der Markierungserweiterungsmodus aktiv ist. In der Statusleiste erscheinen die Buchstaben "ERW", wenn dieser Modus aktiv ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur ExtendMode-Eigenschaft

In diesem Beispiel wird die Auswahl an den Anfang der aktiven Zeile verschoben, dann wird die Markierung auf die zwei nachfolgenden Zeilen erweitert. Der Auswahl wird dann die Formatierung Kursiv zugewiesen, und der Markierungserweiterungsmodus wird deaktiviert.

With Selection
    .Collapse Direction:=wdCollapseStart
    .HomeKey Unit:=wdLine, Extend:=wdMove
    .ExtendMode = True
    .MoveDown Unit:=wdLine, Count:=2
    .Font.Italic = True
    .ExtendMode = False
End With

In diesem Beispiel wird der gesamte Text in der Auswahl, von der Einfügemarke bis zur Textmarke "Temp", gewählt.

With Selection
    .Collapse Direction:=wdCollapseStart
    .ExtendMode = True
    Selection.GoTo What:=wdGoToBookmark, Name:="temp"
    .ExtendMode = False
End With


Extensions-Eigenschaft

Gibt die Dateinamenerweiterungen zurück, die mit dem angegebenen FileConverter-Objekt verbunden sind. String Nur-Lese-Zugriff.


Beispiel zur Extensions-Eigenschaft

In diesem Beispiel werden der Name und die Dateinamenerweiterungen des ersten Dateikonvertierungsprogramms angezeigt.

Set aConverter = FileConverters(1)
MsgBox "The file extensions for " & aConverter.FormatName _
    & " files are: " & aConverter.Extensions


ExtraInfoRequired-Eigenschaft

True, wenn zusätzliche Informationen zum Auflösen des angegebenen Hyperlinks benötigt werden. Boolean Nur-Lese-Zugriff.

Hinweis Sie können zusätzliche Informationen spezifizieren, indem Sie das Argument ExtraInfo mit der Follow- oder FollowHyperlink-Methode verwenden. Sie können beispielsweise ExtraInfo zum Spezifizieren der Koordinaten eines Bildschemas, des Inhalts eines Formulars oder eines FAT-Dateinamens verwenden.


Beispiel zur ExtraInfoRequired-Eigenschaft

In diesem Beispiel wird ein Hyperlink zu www.msn.de eingefügt und dann dem Hyperlink gefolgt, wenn keine zusätzlichen Informationen benötigt werden.

With Selection
    .Collapse Direction:=wdCollapseEnd
    .InsertAfter "MSN "
    .Previous
End With
Set myLink = ActiveDocument.Hyperlinks.Add( _
    Address:="http://www.msn.com", _
    Anchor:=Selection.Range)
If myLink.ExtraInfoRequired = False Then
    myLink.Follow
End If


ExtrusionColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Farbe der Projektion der Form darstellt. Nur-Lese-Zugriff.


ExtrusionColorType-Eigenschaft

Gibt einen Wert zurück oder legt ihn fest, der anzeigt, ob die Projektionsfarbe auf der Füllfarbe der projizierten Form (der Stirnseite der Projektion) basiert und sich automatisch ändert, wenn die Füllfarbe der Form sich ändert, oder ob die Projektionsfarbe unabhängig von der Füllfarbe der Form ist. Dies kann eine der folgenden MsoExtrusionColorType-Konstanten sein: msoExtrusionColorAutomatic (die Projektionsfarbe basiert auf der Form-Füllfarbe), msoExtrusionColorCustom (die Projektionsfarbe ist unabhängig von der Form-Füllfarbe) oder msoExtrusionColorTypeMixed. Long Schreib-Lese-Zugriff.


Beispiel zur ExtrusionColorType-Eigenschaft

Wenn Form eins in myDocument eine automatische Projektionsfarbe hat, wird in diesem Beispiel der Projektion eine benutzerdefinierte gelbe Farbe zugewiesen.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    If .ExtrusionColorType = msoExtrusionColorAutomatic Then
        .ExtrusionColor.RGB = RGB(240, 235, 16)
    End If
End With


FarEastLineBreakControl-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word applies East Asian line-breaking rules to the specified paragraphs. Returns wdUndefined if the FarEastLineBreakControl property is set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur FarEastLineBreakControl-Eigenschaft

This example sets Word to apply East Asian line-breaking rules to the first paragraph in the active document.

ActiveDocument.Paragraphs(1).FarEastLineBreakControl = True


FarEastLineBreakLanguage-Eigenschaft

Sprachspezifische Informationen

Returns or sets the East Asian language to use when breaking lines of text in the specified document or template. Can be any of the following WdFarEastLineBreakLanguageID constants: wdLineBreakJapanese, wdLineBreakKorean, wdLineBreakSimplifiedChinese, or wdLineBreakTraditionalChinese. Read/write Long.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur FarEastLineBreakLanguage-Eigenschaft

This example sets Word to break lines in the current document based on Korean language rules.

ActiveDocument.FarEastLineBreakLanguage = _
    wdLineBreakKorean


FarEastLineBreakLevel-Eigenschaft

Sprachspezifische Informationen

Returns or sets the line break control level for the specified document. Can be one of the following WdFarEastLineBreakLevel constants: wdFarEastLineBreakLevelCustom, wdFarEastLineBreakLevelNormal, or wdFarEastLineBreakLevelStrict. Read/write Long. This property is ignored if the FarEastLineBreakControl property is set to False.


Beispiel zur FarEastLineBreakLevel-Eigenschaft

This example sets Microsoft Word to perform line breaking on first-level kinsoku characters in the active document.

ActiveDocument.FarEastLineBreakLevel = _
    wdJustificationModeCompressKana


FeatureInstall-Eigenschaft

Gibt zurück oder legt fest, wie Microsoft Word Aufrufe von Methoden oder Eigenschaften bearbeitet, die noch nicht installierte Funktionen voraussetzen. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden MsoFeatureInstall-Konstanten handeln.

Konstante | Wert | Beschreibung
msoFeatureInstallNone | 0 | Standardwert. Ein generischer Laufzeit-Automatisierungsfehler wird beim Aufrufen von nicht installierten Features erzeugt.
msoFeatureInstallOnDemand | 1 | Der Benutzer wird zur Installation von neuen Funktionen aufgefordert.
msoFeatureInstallOnDemandWithUI | 2 | Während der Installation wird eine Statusanzeige angezeigt. Der Benutzer wird nicht aufgefordert, neue Features zu installieren.

Hinweise

Sie können die msoFeatureInstallOnDemandWithUI-Konstante verwenden, um während der Installation nicht den Eindruck zu erwecken, dass die Anwendung nicht mehr reagiert. Verwenden Sie die msoFeatureInstallNone-Konstante, um Funktionen nur von dem Entwickler installieren zu lassen.

Wenn Sie die DisplayAlerts-Eigenschaft auf False gesetzt haben, werden Benutzer nicht zum Installieren von neuen Funktionen aufgefordert, selbst wenn die FeatureInstall-Eigenschaft auf msoFeatureInstallOnDemand gesetzt ist. Wenn die DisplayAlerts-Eigenschaft auf True gesetzt ist, wird eine Fortschrittsanzeige eingeblendet, vorausgesetzt, die FeatureInstall-Eigenschaft ist auf msoFeatureInstallOnDemand gesetzt.


Beispiel zur FeatureInstall-Eigenschaft

In diesem Beispiel wird eine neue Instanz von Microsoft Excel aktiviert und der Wert der FeatureInstall-Eigenschaft überprüft. Wenn die Eigenschaft auf msoFeatureInstallNone gesetzt ist, blendet der Code ein Nachrichtenfeld ein, in dem der Benutzer gefragt wird, ob er die Einstellungen der Eigenschaft verändern möchte. Wenn der Benutzer mit "Ja" antwortet, wird die Eigenschaft auf msoFeatureInstallOnDemand gesetzt.

Dim ExcelApp As New Excel.Application, _
    Reply As Integer
With ExcelApp
    If .FeatureInstall = msoFeatureInstallNone Then
        Reply = MsgBox("Uninstalled features for " _
            & "this application may " & vbCrLf _
            & "cause a run-time error when called." _
            & vbCrLf & vbCrLf _
            & "Would you like to change this setting" & vbCrLf _
            & "to automatically install missing features?", _
            vbYesNo, "Feature Install Setting")
            If Reply = vbYes Then
                .FeatureInstall = msoFeatureInstallOnDemand
            End If
    End If
End With


FeedSource-Eigenschaft

Gibt die Papierzufuhr für den Briefumschlag zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdPaperTray-Konstanten handeln:

wdPrinterAutomaticSheetFeed

wdPrinterManualFeed

wdPrinterDefaultBin

wdPrinterMiddleBin

wdPrinterEnvelopeFeed

wdPrinterOnlyBin

wdPrinterFormSource

wdPrinterPaperCassette

 wdPrinterLargeCapacityBin

wdPrinterSmallFormatBin

wdPrinterLargeFormatBin

wdPrinterTractorFeed

wdPrinterLowerBin

wdPrinterUpperBin

wdPrinterManualEnvelopeFeed

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


Beispiel zur FeedSource-Eigenschaft

In diesem Beispiel wird der Anwender gefragt, ob Briefumschläge dem Drucker manuell zugeführt werden. Bei einer positiven Antwort wird die Papierzufuhr auf manuelle Umschlagzufuhr gesetzt.

response = MsgBox("Are the envelopes manually fed?", vbYesNo)
If response = vbYes then
    On Error GoTo errhandler
    ActiveDocument.Envelope.FeedSource = _
        wdPrinterManualEnvelopeFeed
    errhandler:
    If Err = 5852 Then MsgBox _
        "Envelope not part of the active document"
End If


Field-Eigenschaft

Gibt ein Field-Objekt zurück, das das mit der angegebenen Form verbundene Feld darstellt. Nur-Lese-Zugriff.

Hinweis Mit der Fields-Eigenschaft geben Sie die Fields-Auflistung zurück.


FieldNames-Eigenschaft

Gibt eine MailMergeFieldNames-Auflistung zurück, die die Namen aller Felder in der angegebenen Seriendruck-Datenquelle darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur FieldNames-Eigenschaft

In diesem Beispiel wird der Name des ersten Felds in der Datenquelle angezeigt, die dem aktiven Seriendruck-Hauptdokument zugeordnet wurde.

MsgBox ActiveDocument.MailMerge.DataSource.FieldNames(1).Name

In diesem Beispiel wird das Datenfeld mNames() verwendet, um die Namen aller Seriendruckfelder in der Datenquelle zu speichern, die dem aktiven Dokument zugeordnet ist.

Set MM = ActiveDocument.MailMerge
num = ActiveDocument.MailMerge.DataSource.FieldNames.Count - 1
ReDim mNames(num)
i = 0
For Each aMergeField In MM.DataSource.FieldNames
    mNames(i) = aMergeField.Name
    i = i + 1
Next aMergeField


Fields-Eigenschaft

Document-, Range- oder Selection-Objekt: Gibt eine Fields-Auflistung zurück, die alle Felder in einem Dokument, Bereich oder einer Markierung darstellt. Nur-Lese-Zugriff.

Anmerkung Wenn die Fields-Eigenschaft auf das Document-Objekt angewendet wird, gibt sie eine Fields-Auflistung zurück, die nur die Felder in den Dokumentkomponenten des Haupttextes enthält.

MailMerge-Objekt: Gibt eine MailMergeFields-Auflistung zurück, die alle seriendruckbezogenen Felder im angegebenen Dokument enthält. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


FieldShading-Eigenschaft

Gibt die Bildschirm-Schattierung für Formularfelder zurück oder legt sie fest. Dies kann eine der folgenden WdFieldShading-Konstanten sein: wdFieldShadingAlways, wdFieldShadingNever oder wdFieldShadingWhenSelected. Long Schreib-Lese-Zugriff.


Beispiel zur FieldShading-Eigenschaft

In diesem Beispiel wird für alle Formularfelder im aktiven Fenster die Feldschattierung aktiviert.

ActiveDocument.ActiveWindow.View.FieldShading = _
    wdFieldShadingAlways


FileConverters-Eigenschaft

Gibt eine FileConverters-Auflistung zurück, die alle Dateikonvertierungsprogramme darstellt, die Word zur Verfügung stehen. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur FileConverters-Eigenschaft

In diesem Beispiel wird der Pfad des WordPerfect 5.0-Dateikonvertierungsprogramms angezeigt.

MsgBox FileConverters("WrdPrfctDOS50").Path

In diesem Beispiel wird eine Meldung angezeigt, die angibt, ob das dritte Konvertierungsprogramm in der FileConverters-Auflistung Dateien speichern kann.

If FileConverters(3).CanSave = True Then
    MsgBox FileConverters(3).FormatName & " can save files"
Else
    MsgBox FileConverters(3).FormatName & " cannot save files"
End If

In diesem Beispiel wird der Name des letzten Dateikonvertierungsprogramms angezeigt.

Set aConverter = FileConverters(FileConverters.Count)
MsgBox "The file extensions for " & aConverter.FormatName & _
    " files are: " & aConverter.Extensions


FileSearch-Eigenschaft

Gibt ein FileSearch-Objekt zurück, mit dem Dateien mit einer absoluten oder relativen Pfadangabe gesucht werden können. Nur-Lese-Zugriff.


Beispiel zur FileSearch-Eigenschaft

In diesem Beispiel werden die Dateinamen im Ordner "My Documents", die mit 99 beginnen, in mehreren Meldungsfeldern angezeigt.

With Application.FileSearch
    .FileName = "99*.*"
    .LookIn = "C:\My Documents"
    .Execute
    For I = 1 to .FoundFiles.Count
        MsgBox .FoundFiles(I)
    Next I
End With


Fill-Eigenschaft

Gibt ein FillFormat-Objekt zurück, das Ausfüllformatierungseigenschaften für die angegebene Form enthält. Nur-Lese-Zugriff.


Beispiel zur Fill-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt, dann werden die Vordergrundfarbe, die Hintergrundfarbe und die fließende Farbe für die Füllung des Rechtecks festgelegt.

Set myDocument = Documents(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


Filter-Eigenschaft

Sprachspezifische Informationen

Returns or sets a value that specifies how Microsoft Word classifies the first character of entries in the specified index. Can be any of the following WdIndexFilter constants: wdIndexFilterAiueo, wdIndexFilterAkasatana, wdIndexFilterChosung, wdIndexFilterLow, wdIndexFilterMedium, wdIndexFilterFull, or wdIndexFilterNone. Read/write Long.


Beispiel zur Filter-Eigenschaft

This example inserts an index at the end of the active document. right-aligns the page numbers, and then sets Microsoft Word to classify index entries as " akasatana akasatana akasatana akasatana akasatana ".

Set myRange = ActiveDocument.Range _
    (Start:=ActiveDocument.Content.End -1, _
    End:=ActiveDocument.Content.End -1)
ActiveDocument.Indexes.Add(Range:=myRange, Type:=wdIndexIndent, _
    RightAlignPageNumbers:=True).Filter = wdIndexFilterAkasatana


Find-Eigenschaft

Gibt ein Find-Objekt zurück, das die Kriterien für eine Suchoperation enthält. Nur-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft mit einem Selection-Objekt verwendet wird, wird die Markierung geändert, falls die Suchoperation erfolgreich ist. Wird diese Eigenschaft mit einem Range-Objekt verwendet, dann wird die Markierung nicht geändert, außer wenn die Select-Methode angewandt wird.


FindKey-Eigenschaft

Liefert ein KeyBinding-Objekt, das die angegebene Tastenkombination darstellt. Nur-Lese-Zugriff.

Syntax

Ausdruck.FindKey(KeyCode, KeyCode2)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt liefert.

KeyCode Long erforderlich. Eine Taste, die Sie mit einer der WdKey-Konstanten bestimmen.

KeyCode2 Variant optional. Eine zweite Taste, die Sie mit einer der WdKey-Konstanten bestimmen.

Anmerkungen

Mit der BuildKeyCode-Methode erstellen Sie das KeyCode- oder KeyCode2-Argument.


Beispiel zur FindKey-Eigenschaft

In diesem Beispiel wird die Tastenkombination ALT+UMSCHALT+F12 in der Vorlage deaktiviert, die mit dem aktiven Dokument verbunden ist. Im Beispiel wird dargestellt, wie Sie mit der BuildKeyCode-Methode ein KeyBinding-Objekt mit mehr als zwei Tasten zurückgeben.

CustomizationContext = ActiveDocument.AttachedTemplate
FindKey(KeyCode:=BuildKeyCode(wdKeyAlt, wdKeyShift, _
    wdKeyF12)).Disable

In diesem Beispiel wird der Befehl angezeigt, der der Taste F1 zugewiesen ist.

CustomizationContext = NormalTemplate
MsgBox FindKey(KeyCode:=wdKeyF1).Command


First-Eigenschaft

Sentences-, Words- und Characters-Objekte: Gibt ein Range-Objekt zurück, das den ersten Satz, das erste Wort oder das erste Zeichen in einem Dokument, in der Markierung oder in einem Bereich darstellt. Nur-Lese-Zugriff.

Columns-, Paragraphs-, Rows- und Sections-Objekte: Gibt das erste Element in der angegebenen Auflistung zurück. Nur-Lese-Zugriff. Zum Beispiel gibt jede der beiden folgenden Anweisungen ein Paragraph-Objekt zurück, das den ersten Absatz in der Markierung darstellt.

Selection.Paragraphs.First
Selection.Paragraphs(1)


FirstLetterAutoAdd-Eigenschaft

True, wenn Word automatisch Abkürzungen in die Liste der AutoKorrektur-Ausnahmen Erster Buchstabe aufnimmt. Word nimmt eine Abkürzung in diese Liste auf, wenn Sie sofort den Buchstaben nach dem Punkt, den Word nach der Abkürzung in einen Großbuchstaben umwandelt, löschen und erneut eingeben. Boolean Schreib-Lese-Zugriff.


Beispiel zur FirstLetterAutoAdd-Eigenschaft

In diesem Beispiel wird verhindert, dass Word automatisch Abkürzungen in die Liste der AutoKorrektur-Ausnahmen Erster Buchstabe aufnimmt.

AutoCorrect.FirstLetterAutoAdd = False


FirstLetterExceptions-Eigenschaft

Gibt eine FirstLetterExceptions-Auflistung zurück, die die Liste der Abkürzungen darstellt, nach denen Word nicht automatisch den nächsten Buchstaben in einen Großbuchstaben umwandelt. Diese Liste entspricht der Liste der AutoKorrektur-Ausnahmen auf der Registerkarte Erster Buchstabe im Dialogfeld AutoKorrektur-Ausnahmen (Befehl AutoKorrektur, Menü Extras). Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur FirstLetterExceptions-Eigenschaft

In diesem Beispiel wird "bspw." in die Liste der AutoKorrektur-Ausnahmen Erster Buchstabe aufgenommen.

AutoCorrect.FirstLetterExceptions.Add "apt."

Dieses Beispiel entfernt eine bestimmte, vorhandene Ausnahme aus der Liste der AutoKorrektur-Ausnahmen Erster Buchstabe.

myValue = InputBox("Enter the First Letter exception to delete.")
For Each anEntry in AutoCorrect.FirstLetterExceptions
    If anEntry.Name = myValue Then
        myMatch = True
        myConfirm = MsgBox("Are you sure you want to delete " _
            & anEntry.Name, 4)
        If myConfirm = vbYes Then
            anEntry.Delete
        End If
    End If
Next anEntry
If myMatch <> True Then
    MsgBox "There was no First Letter exception: " & myValue
End If


FirstLineIndent-Eigenschaft

Gibt den Wert (in Punkt) für einen Erstzeileneinzug oder hängenden Einzug zurück oder legt ihn fest. Verwenden Sie einen positiven Wert zum Festlegen eines Erstzeileneinzugs und einen negativen Wert, um einen hängenden Einzug festzulegen. Single Schreib-Lese-Zugriff.


Beispiel zur FirstLineIndent-Eigenschaft

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument ein Erstzeileneinzug von 1 Zoll festgelegt.

ActiveDocument.Paragraphs(1).FirstLineIndent = _
    InchesToPoints(1)

In diesem Beispiel wird für den zweiten Absatz im aktiven Dokument ein hängender Einzug von 0,5 Zoll festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

ActiveDocument.Paragraphs(2).FirstLineIndent = _
    InchesToPoints(-0.5)


FirstPageTray-Eigenschaft

Gibt den Papierzufuhr-Schacht, der für die erste Seite eines Dokuments oder Abschnitts verwendet werden soll, zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Kann eine der folgenden WdPaperTray-Konstanten sein:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormatBin

wdPrinterTractorFeed

wdPrinterUpperBin


Beispiel zur FirstPageTray-Eigenschaft

In diesem Beispiel wird der Papierzufuhr-Schacht festgelegt, der zum Drucken der ersten Seite jedes Abschnitts im aktiven Dokument verwendet werden soll.

ActiveDocument.PageSetup.FirstPageTray = wdPrinterLowerBin

In diesem Beispiel wird der Papierzufuhr-Schacht festgelegt, der zum Drucken der ersten Seite jedes Abschnitts in der Markierung verwendet werden soll.

Selection.PageSetup.FirstPageTray = wdPrinterUpperBin


FirstRecord-Eigenschaft

Gibt die Nummer des ersten Datensatzes zurück, der in einer Seriendruckoperation zusammengeführt wird, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur FirstRecord-Eigenschaft

In diesem Beispiel wird das Hauptdokument mit den Datensätzen 1 bis 3 zusammengeführt, und die Seriendruckdokumente werden an den Drucker übergeben.

With ActiveDocument.MailMerge
    .DataSource.FirstRecord = 1
    .DataSource.LastRecord = 3
    .Destination = wdSendToPrinter
    .Execute
End With


FitText-Eigenschaft

True, wenn Microsoft Word den in eine Zelle eingegeben Text verkleinert, damit er in die Spaltenbreite passt. Boolean Schreib-Lese-Zugriff.

Hinweise

Wenn die FitText-Eigenschaft auf True gesetzt ist, bleibt der Schriftgrad des Textes unverändert, aber die Breite der Zeichen wird angepasst, damit der gesamte Text in die Zelle passt.


FitTextWidth-Eigenschaft

Sprachspezifische Informationen

Returns or sets the width (in the current measurement units) in which Microsoft Word fits the text in the current selection or range. Read/write Single.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur FitTextWidth-Eigenschaft

This example fits the current selection into a space 5 centimeters wide.

Selection.FitTextWidth = CentimetersToPoints(5)


Flags-Eigenschaft

Gibt Eigenschaften der Markierung zurück oder legt sie fest. Dies kann eine der folgenden WdSelectionFlags-Konstanten sein: wdSelActive, wdSelAtEOL, wdSelOvertype, wdSelReplace oder wdSelStartActive. Long Schreib-Lese-Zugriff.

Anmerkung Wenn Sie die Flags-Eigenschaft auf wdSelAtEOL setzen, wird das Ende der Auswahl aktiviert.


Beispiel zur Flags-Eigenschaft

In diesem Beispiel wird das erste Wort im aktiven Dokument markiert. Das erste Meldungsfeld zeigt "False" an, weil das Ende der Markierung aktiv ist. Die Flag-Eigenschaft macht den Anfang der Markierung aktiv, und das zweite Meldungsfeld zeigt "True" an.

ActiveDocument.Words(1).Select
MsgBox Selection.StartIsActive
Selection.Flags = wdSelStartActive
MsgBox Selection.StartIsActive

In diesem Beispiel wird für die Markierung der Überschreibmodus eingeschaltet.

Selection.Flags = wdSelOvertype


FlowDirection-Eigenschaft

Sprachspezifische Informationen

Returns or sets the direction in which text flows from one text column to the next. Read/write Long.

Can be either of the following WdFlowDirection constants.

Constant | Description
wdFlowLtr | Text in columns flows from left to right.
wdFlowRtl | Text in columns flows from right to left.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur FlowDirection-Eigenschaft

This example sets the flow direction so that text flows through the specified columns from right to left.

ActiveDocument.PageSetup.TextColumns.FlowDirection = _
    wdFlowRtl


FocusInMailHeader-Eigenschaft

True, wenn sich die Einfügemarke im Nachrichtenkopf einer E-Mail-Nachricht befindet (z. B. im Feld An). Boolean Nur-Lese-Zugriff.


Beispiel zur FocusInMailHeader-Eigenschaft

In diesem Beispiel wird in der Statusleiste eine Meldung angezeigt, wenn sich die Einfügemarke im Nachrichtenkopf einer E-Mail-Nachricht befindet.

If Application.FocusInMailHeader = True Then
    StatusBar = "Selection is in message header"
End If


FolderSuffix-Eigenschaft

Gibt das Ordnersuffix zurück, das Microsoft Word verwendet, wenn Sie ein Dokument als Webseite speichern, lange Dateinamen verwenden oder Hilfsdateien in einem separaten Ordner speichern, wenn also die UseLongFileNames und OrganizeInFolder-Eigenschaften auf True gesetzt sind. String Nur-Lese-Zugriff.

Hinweise

In neu erstellten Dokumenten wird das von der FolderSuffix-Eigenschaft des DefaultWebOptions-Objekts zurückgegebene Suffix verwendet. Der Wert der FolderSuffix-Eigenschaft des WebOptions-Objekts kann sich von dem des DefaultWebOptions-Objekts unterscheiden, wenn das Dokument zuvor in einer anderen Sprachversion von Microsoft Word bearbeitet wurde. Sie können die UseDefaultFolderSuffix-Methode verwenden, um das Suffix in die Sprache zu übertragen, mit der Sie zu diesem Zeitpunkt in Microsoft Office 2000 arbeiten.

Standardmäßig ist der Name des Hilfsordners gleichlautend mit dem Namen der Webseite, erweitert um einen Unterstrich (_), einen Punkt (.) oder einen Bindestrich (-) sowie das Wort "Dateien", das in der Sprache der Version von Word erscheint, in der die Datei als Webseite gespeichert wurde. Wenn Sie zum Beispiel die niederländische Version von Word verwenden, um eine Datei mit dem Namen Seite1 als Webseite zu speichern, lautet der Standardname des Hilfsordners Seite1_bestanden.

Die folgende Tabelle enthält alle Sprachversionen von Office 2000 und verzeichnet den entsprechenden Wert der LanguageID-Eigenschaft und das zugehörige Ordnersuffix. In den Sprachen, die in der Tabelle nicht aufgeführt sind, wird das Suffix .files verwendet.

Sprache | LanguageID | Ordnersuffix
Arabisch | 1025 | .files
Baskisch | 1069 | _fitxategiak
Brasilianisch | 1046 | _arquivos
Bulgarisch | 1026 | .files
Chinesisch, traditionell | 1028 | .files
Chinesisch, vereinfacht | 2052 | .files
Dänisch | 1030 | -filer
Deutsch | 1031 | -Dateien
Englisch | 1033 | _files
Estnisch | 1061 | _failid
Finnisch | 1035 | _tiedostot
Französisch | 1036 | _fichiers
Griechisch | 1032 | .files
Hebräisch | 1037 | .files
Italienisch | 1040 | -file
Japanisch | 1041 | .files
Katalanisch | 1027 | _fitxers
Koreanisch | 1042 | .files
Kroatisch | 1050 | _datoteke
Lettisch | 1062 | _fails
Litauisch | 1063 | _bylos
Niederländisch | 1043 | _bestanden
Norwegisch | 1044 | -filer
Polnisch | 1045 | _pliki
Portugiesisch | 2070 | _ficheiros
Rumänisch | 1048 | .files
Russisch | 1049 | .files
Schwedisch | 1053 | -filer
Serbisch (Kyrillisch) | 3098 | .files
Serbisch (Lateinisch) | 2074 | _fajlovi
Slovakisch | 1051 | .files
Slowenisch | 1060 | _datoteke
Spanisch | 3082 | _archivos
Thailändisch | 1054 | .files
Tschechisch | 1029 | _soubory
Türkisch | 1055 | _dosyalar
Ukrainisch | 1058 | .files
Ungarisch | 1038 | _elemei
Vietnamesisch | 1066 | .files


Beispiel zur FolderSuffix-Eigenschaft

In diesem Beispiel wird das vom aktiven Dokument verwendete Ordnersuffix zurückgegeben. Das Suffix wird in der Stringvariable strFolderSuffix zurückgegeben.

strFolderSuffix = _
    ActiveDocument.WebOptions.FolderSuffix


Font-Eigenschaft

Gibt ein Font-Objekt zurück, das die Zeichenformatierung des angegebenen Objekts darstellt, oder legt eines fest. Zum Festlegen dieser Eigenschaft geben Sie einen Ausdruck an, der ein Font-Objekt zurückgibt. Font Schreib-Lese-Zugriff.


FontBold-Eigenschaft

True, wenn die Schrift im angegebenen WordArt-Objekt fett ausgezeichnet ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontBold-Eigenschaft

In diesem Beispiel wird in myDocument die Schrift für Form drei fett ausgezeichnet, wenn die Form ein WordArt-Objekt ist.

Set myDocument = ActiveDocument
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


FontItalic-Eigenschaft

True, wenn die Schrift im angegebenen WordArt-Objekt kursiv ausgezeichnet ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontItalic-Eigenschaft

In diesem Beispiel wird in myDocument die Schrift für die Form "WordArt 4" kursiv ausgezeichnet.

Set myDocument = ActiveDocument
myDocument.Shapes("WordArt 4").TextEffect.FontItalic = True


FontName-Eigenschaft

Gibt den Schriftartnamen für den Anfangs-Großbuchstaben im Text zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


FontNames-Eigenschaft

Gibt ein FontNames-Objekt zurück, das die Namen aller verfügbaren Querschriftarten enthält. Nur-Lese-Zugriff.


Beispiel zur FontNames-Eigenschaft

In diesem Beispiel werden die Schriftartnamen in der FontNames-Auflistung angezeigt.

For Each aFont In FontNames
    response = MsgBox(Prompt:=aFont, Buttons:=vbOKCancel)
    If response = vbCancel Then Exit For
Next aFont


Fonts-Eigenschaft

Gibt die WebPageFonts-Auflistung zurück, die den Zeichensatz darstellt, der in Microsoft Word zum Öffnen einer Webseite verwendet wird, wenn entweder keine Informationen über die Schriftart in der Webseite angegeben sind oder die aktuelle Standardschriftart den Zeichensatz auf der Webseite nicht anzeigen kann. Nur-Lese-Zugriff.


FontSize-Eigenschaft

Gibt den Schriftgrad für das angegebene WordArt-Objekt in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur FontSize-Eigenschaft

In diesem Beispiel wird in myDocument der Schriftgrad für die Form "WordArt 2" auf 16 Punkt festgelegt.

Set myDocument = ActiveDocument
myDocument.Shapes("WordArt 2").TextEffect.FontSize = 16


FooterDistance-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der Fußzeile und der unteren Seitenkante zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur FooterDistance-Eigenschaft

In diesem Beispiel wird der Abstand zwischen der Fußzeile und der unteren Seitenkante auf 0,5 Zoll festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

ActiveDocument.PageSetup.FooterDistance = InchesToPoints(0.5)

In diesem Beispiel wird der Abstand zwischen der Fußzeile und der unteren Seitenkante für alle Abschnitte in der Markierung auf 1 Zoll festgelegt.

Selection.Range.PageSetup.FooterDistance = 72


Footers-Eigenschaft

Gibt eine HeadersFooters-Auflistung zurück, die die Fußzeilen im angegebenen Abschnitt darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Footers-Eigenschaft

In diesem Beispiel wird im ersten Abschnitt des aktiven Dokuments der ersten Fußzeile eine rechts ausgerichtete Seitenzahl hinzugefügt.

With ActiveDocument.Sections(1).Footers(wdHeaderFooterPrimary)
    .PageNumbers.Add PageNumberAlignment:=wdAlignPageNumberRight
End With


Footnotes-Eigenschaft

Gibt eine Footnotes-Auflistung zurück, die alle Fußnoten in einem Bereich, einer Markierung oder einem Dokument darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Footnotes-Eigenschaft

In diesem Beispiel wird das Fußnotenzeichen für die Fußnoten im aktiven Dokument in Kleinbuchstaben geändert, die mit dem Buchstaben "c" beginnen.

With ActiveDocument.Footnotes
    .StartingNumber = 3
    .NumberStyle = wdNoteNumberStyleLowercaseLetter
End With

In diesem Beispiel wird automatisch eine nummerierte Fußnote an der Einfügemarke eingefügt.

Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.Footnotes.Add Range:=Selection.Range, _
    Text:="(Lone Creek Press, 1995)"


ForeColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Vordergrundfarbe für den Füllbereich, die Linie oder den Schatten darstellt, oder legt es fest. Schreib-Lese-Zugriff.


Beispiel zur ForeColor-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt, und dann werden die Vordergrundfarbe, die Hintergrundfarbe und die fließende Farbe für die Füllfarbe des Rechtecks festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With

In diesem Beispiel wird zu myDocument eine gemusterte Linie hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


ForegroundPatternColor-Eigenschaft

Gibt die 24-Bit-Farbe zurück, die für den Vordergrund des Shading-Objekts verwendet wird, oder legt diese fest. Diese Farbe wird für die Punkte und Linien im Schattierungsmuster verwendet. Dabei kann es sich um eine beliebige gültige WdColor-Konstante oder einen von der RGB-Funktion zurückgegebenen Wert handeln. Long Schreib-Lese-Zugriff.

Hinweise

Die Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.


ForegroundPatternColorIndex-Eigenschaft

Gibt die Farbe, die auf den Vordergrund eines Shading-Objekts angewendet werden soll, zurück oder legt sie fest. Diese Farbe wird auf alle Punkte und Linien im Muster für die Bildschattierung angewendet. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow


Beispiel zur ForegroundPatternColorIndex-Eigenschaft

In diesem Beispiel wird eine Bildschattierung mit unterschiedlichen Farben für Vorder- und Hintergrund auf die Markierung benutzt.

With Selection.Shading
    .Texture = wdTexture30Percent
    .ForegroundPatternColorIndex = wdBlue
    .BackgroundPatternColorIndex = wdYellow
End With


Format-Eigenschaft

Gibt die Formatierung des angegebenen Objekts zurück oder legt diese fest, wie in der folgenden Tabelle beschrieben.

Objekt | Beschreibung
Indexes | Gibt die Formatierung für die Indexe des angegebenen Dokuments zurück oder legt diese fest. Es kann sich um eine der folgenden WdIndexFormat-Konstanten handeln: wdIndexBulleted, wdIndexClassic, wdIndexFancy, wdIndexFormal, wdIndexModern, wdIndexSimple oder wdIndexTemplate. Long Schreib-Lese-Zugriff.
Find | True, wenn der Find-Vorgang Formatierungen umfasst. Boolean Schreib-Lese-Zugriff.
Paragraph, Paragraphs | Gibt ein ParagraphFormat-Objekt zurück oder legt dieses fest, das die Formatierung des angegebenen Absatzes oder der Absätze zurückgibt. Schreib-Lese-Zugriff.
TablesOfAuthorities | Gibt die Formatierung des Rechtsgrundlagenverzeichnisses im angegebenen Dokument zurück oder legt diese fest. Dabei kann es sich um eine der folgenden WdTOAFormat-Konstanten handeln: wdTOAClassic, wdTOADistinctive, wdTOAFormal, wdTOASimple oder wdTOATemplate. Long Schreib-Lese-Zugriff.
TablesOfContents | Gibt die Formatierung des Inhaltsverzeichnisses im angegebenen Dokument zurück oder legt diese fest. Dabei kann es sich um eine der folgenden WdTOCFormat-Konstanten handeln:, wdTOCClassic, wdTOCDistinctive, wdTOCFancy, wdTOCFormal, wdTOCModern, wdTOCSimple oder wdTOCTemplate. Long Schreib-Lese-Zugriff.
TablesOfFigures | Gibt die Formatierung des Abbildungsverzeichnisses im angegebenen Dokument zurück oder legt diese fest. Dabei kann es sich um eine der folgenden WdTOFFormat-Konstanten handeln: wdTOFCentered, wdTOFClassic, wdTOFDistinctive, wdTOFFormal, wdTOFSimple oder wdTOFTemplate. Long Schreib-Lese-Zugriff.
TextInput | Gibt die Textformatierung des angegebenen Textfeldes zurück. String Nur-Lese-Zugriff. Verwenden Sie die EditType-Methode des TextInput-Objekts, um die Textformatierung festzulegen.


FormatName-Eigenschaft

Gibt den Namen des angegebenen Dateikonvertierungsprogramms zurück. Die Formatnamen erscheinen im Feld Dateityp, Dialogfeld Speichern unter im Menü Datei. String Nur-Lese-Zugriff.


Beispiel zur FormatName-Eigenschaft

In diesem Beispiel wird der Formatname des ersten Konvertierungsprogramms in der FileConverters-Auflistung angezeigt.

MsgBox FileConverters(1).FormatName

In diesem Beispiel wird das Datenfeld AvailableConv() zum Speichern der Namen aller verfügbaren Dateikonvertierungsprogramme verwendet.

ReDim AvailableConv(FileConverters.Count - 1)
i = 0
For Each aConverter In FileConverters
    AvailableConv(i) = aConverter.FormatName
    i = i + 1
Next aConverter


FormattedText-Eigenschaft

Gibt ein Range-Objekt zurück, das den formatierten Text im angegebenen Bereich oder in der Markierung enthält, oder legt es fest. Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft gibt ein Range-Objekt mit der Zeichenformatierung und dem Text aus dem angegebenen Bereich oder der Markierung zurück. Das Range-Objekt enthält auch Absatzformatierung, wenn in dem Bereich oder in der Markierung eine Absatzmarke enthalten ist.

Wenn Sie diese Eigenschaft festlegen, wird der Text im Bereich oder in der Markierung durch formatierten Text ersetzt. Wenn Sie den vorhandenen Text nicht ersetzen wollen, verwenden Sie die Collapse-Methode vor der Verwendung dieser Eigenschaft (siehe das erste Beispiel).


Beispiel zur FormattedText-Eigenschaft

In diesem Beispiel wird der erste Absatz im Dokument einschließlich seiner Formatierung kopiert und der formatierte Text an der Einfügemarke eingefügt.

Selection.Collapse Direction:=wdCollapseStart
Selection.FormattedText = ActiveDocument.Paragraphs(1).Range

In diesem Beispiel werden der Text und die Formatierung von der Markierung in ein neues Dokument kopiert.

Set myRange = Selection.FormattedText
Documents.Add.Content.FormattedText = myRange


FormFields-Eigenschaft

Gibt eine FormFields-Auflistung zurück, die alle Formularfelder in einem Dokument, Bereich oder einer Markierung darstellt. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur FormFields-Eigenschaft

In diesem Beispiel wird der Inhalt des Formularfelds "Text1" auf "Name" gesetzt.

ActiveDocument.FormFields("Text1").Result = "Name"

In diesem Beispiel wird der Typ des ersten Formularfelds in Abschnitt zwei geladen.

myType = ActiveDocument.Sections(2).Range.FormFields(1).Type
Select Case myType
    Case wdFieldFormTextInput
        thetype = "TextBox"
    Case wdFieldFormDropDown
        thetype = "DropDown"
    Case wdFieldFormCheckBox
        thetype = "CheckBox"
End Select

In diesem Beispiel wird der Name des ersten Formularfelds in der Markierung angezeigt.

If Selection.FormFields.Count > 0 Then
    MsgBox Selection.FormFields(1).Name
End If


FormsDesign-Eigenschaft

True, wenn sich das angegebene Dokument im Formularentwurfsmodus befindet. Boolean Nur-Lese-Zugriff.

Anmerkung Diese Eigenschaft gibt immer False zurück, wenn sie in von Word ausgeführtem Code verwendet wird. Sie gibt jedoch den richtigen Wert zurück, wenn die Ausführung automatisiert ist. Wenn sie zum Beispiel von Excel aus ausgeführt wird, und Sie sich im Entwurfsmodus befinden, wird True zurückgegeben.

Hinweise

Wenn sich Word im Formularentwurfsmodus befindet, wird die Steuerelement-Toolbox angezeigt. Mit dieser Symbolleiste fügen Sie ActiveX-Steuerelemente ein, z. B. Befehlsschaltflächen, Bildlaufleisten und Optionsfelder. Im Formularentwurfsmodus werden ereignisgesteuerte Prozeduren nicht ausgeführt. Wenn Sie auf ein eingebettetes Steuerelement klicken, erscheinen die Ziehpunkte dieses Elements.


Beispiel zur FormsDesign-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das angibt, ob sich das angegebene Dokument im Formularentwurfsmodus befindet oder nicht. Das Beispiel gibt immer False zurück.

Msgbox ActiveDocument.FormsDesign


Forward-Eigenschaft

True, wenn die Suchoperation das Dokument vorwärts (zum Dokumentende hin) durchsucht. False, wenn das Dokument rückwärts (zum Dokumentanfang hin) durchsucht wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur Forward-Eigenschaft

In diesem Beispiel wird in der Markierung das nächste Vorkommen des Wortes "hi" durch "hello" ersetzt.

With Selection.Find
    .Forward = True
    .Text = "hi"
    .ClearFormatting
    .Replacement.Text = "hello"
    .Execute Replace:=wdReplaceOne
End With

Im folgenden Beispiel wird das Dokument rückwärts nach dem Wort "Microsoft" durchsucht. Wenn das Wort gefunden wird, wird es automatisch markiert.

Selection.Collapse Direction:=wdCollapseStart
With Selection.Find
    .Forward = False
    .ClearFormatting
    .MatchWholeWord = True
    .MatchCase = False
    .Wrap = wdFindContinue
    .Execute FindText:="Microsoft"
End With


Found-Eigenschaft

SynonymInfo-Objekt: True, wenn der Thesaurus Synonyme, Antonyme, verwandte Wörter oder verwandte Ausdrücke für das Wort oder den Ausdruck findet. Boolean Nur-Lese-Zugriff.

Find-Objekt: True, wenn die Suche zu einer Übereinstimmung führt. Boolean Nur-Lese-Zugriff.


Beispiel zur Found-Eigenschaft

In diesem Beispiel wird überprüft, ob der Thesaurus synonyme Vorschläge für das Wort "authorize" enthält.

Set myword = SynonymInfo(Word:="authorize", _
    LanguageID:=wdEnglishUS)
If myword.Found = True Then
    Msgbox "The thesaurus has suggestions."
Else
    Msgbox "The thesaurus has no suggestions."
End If

In diesem Beispiel wird überprüft, ob der Thesaurus synonyme Vorschläge für die Markierung enthält. Wenn das der Fall ist, wird in dem Beispiel das Dialogfeld Thesaurus mit den aufgelisteten Synonymen angezeigt.

Set mySyninfo = Selection.Range.SynonymInfo
If mySyninfo.Found = True Then
    Selection.Range.CheckSynonyms
Else
    Msgbox "The thesaurus has no suggestions."
End If

In diesem Beispiel wird die Formatierung von dem Kriterium "Suchen" entfernt, bevor die Markierung gesucht wird. Wenn das fettgedruckte Wort "Hello" gefunden wird, wird der gesamte Absatz markiert und in die Zwischenablage kopiert.

With Selection.Find
    .ClearFormatting
    .Font.Bold = True
    .Execute FindText:="Hello", Format:=True, Forward:=True
    If .Found = True Then
        .Parent.Expand Unit:=wdParagraph
        .Parent.Copy
    End If
End With


Frame-Eigenschaft

Gibt ein Frame-Objekt zurück, das die Rahmenformatierung für die angegebene Formatvorlage oder Suchen-und-Ersetzen-Operation darstellt. Nur-Lese-Zugriff.


FrameDefaultURL-Eigenschaft

Gibt die Webseite oder ein anderes Dokument zurück, das beim Öffnen der Framesseite in einem angegebenen Frame angezeigt werden soll, oder legt dieses fest. String Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FrameDefaultURL-Eigenschaft

In diesem Beispiel wird festgelegt, dass im angegebenen Frame eine lokale Datei mit dem Namen Order.htm angezeigt wird.

With ActiveDocument.ActiveWindow.ActivePane.Frameset
    .FrameDefaultURL = "C:\My Documents\Order.htm"
    .FrameLinkToFile = True
End With


FrameDisplayBorders-Eigenschaft

True, wenn die Framerahmenlinien auf der angegebenen Framesseite angezeigt werden. Boolean Schreib-Lese-Zugriff.

Hinweise

Für weitere Informationen über die Erstellung von Framesseiten klicken Sie auf Erstellen von Framesseiten.


Beispiel zur FrameDisplayBorders-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word Framerahmenlinien in der angegebenen Framesseite anzeigt.

ActiveDocument.ActiveWindow.ActivePane.Frameset _
    .FrameDisplayBorders = True


FrameLinkToFile-Eigenschaft

True, wenn es sich bei der Webseite oder einem anderen Dokument, das durch die FrameDefaultURL-Eigenschaft festgelegt wurde, um eine externe Datei handelt, zu der Microsoft Word im angegebenen Frame lediglich eine Verknüpfung erhält. Boolean Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FrameLinkToFile-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word lediglich eine Verknüpfung vom angegebenen Frame zum Dokument Order.htm erhält.

With ActiveDocument.ActiveWindow.ActivePane.Frameset
    .FrameDefaultURL = "C:\My Documents\Order.htm"
    .FrameLinkToFile = True
End With


FrameName-Eigenschaft

Gibt den Namen des angegebenen Frames auf der Framesseite zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FrameName-Eigenschaft

In diesem Beispiel wird für den angegebenen Frame der Name "BottomFrame" festgelegt.

ActiveWindow.Document.Frameset _
    .ChildFramesetItem(3).FrameName = "BottomFrame"


FrameResizable-Eigenschaft

True, wenn der Benutzer die Größe des angegebenen Frames beim Anzeigen der Framesseite in einem Webbrowser ändern kann. Boolean Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen einer Framesseite finden Sie unter Erstellen von Framesseiten.


Beispiel zur FrameResizable-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Größe des angegebenen Frames bei der Ansicht in einem Webbrowser änderbar ist.

With ActiveDocument.ActiveWindow.ActivePane.Frameset
    .FrameDefaultURL = "C:\My Documents\Order.htm"
    .FrameResizable = True
End With


Frames-Eigenschaft

Gibt eine Frames-Sammlung zurück, die alle Rahmen in einem Dokument, einem Bereich oder einer Auswahl darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


FrameScrollBarType-Eigenschaft

Gibt zurück, ob bei Ansicht der Framesseite in einem Webbrowser für den angegebenen Frame Bildlaufleisten verfügbar sind, oder legt dieses fest. Long Schreib-Lese-Zugriff. Hierbei kann es sich um eine der WdScrollBarType-Konstanten aus der nachfolgend aufgeführten Tabelle handeln.

Konstante | Beschreibung
wdScrollBarTypeAuto | Bildlaufleisten sind im angegebenen Frame nur dann verfügbar, wenn der Inhalt so groß ist, dass er nicht in den vorgesehenen Platz passt.
wdScrollBarTypeNo | Für den angegebenen Frame sind grundsätzlich keine Bildlaufleisten verfügbar.
wdScrollBarTypeYes | Für den angegebenen Frame sind immer Bildlaufleisten verfügbar.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FrameScrollBarType-Eigenschaft

In diesem Beispiel wird festgelegt, dass Bildlaufleisten für den angegebenen Frame immer zur Verfügung stehen, unabhängig davon, ob für den Inhalt des Frames ein Bildlauf erforderlich ist.

With ActiveDocument.ActiveWindow.ActivePane.Frameset
    .FrameDefaultURL = "C:\My Documents\Order.htm"
    .FrameScrollBarType = wdScrollBarTypeYes
End With


Frameset-Eigenschaft

Gibt ein Frameset-Objekt zurück, das eine ganze Framesseite darstellt oder einen einzelnen Frame auf einer Framesseite. Nur-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen einer Framesseite finden Sie unter Erstellen einer Framesseite.


FramesetBorderColor-Eigenschaft

Gibt die Farbe der Framerahmenlinien auf der angegebenen Framesseite zurück oder legt die Farbe fest. Hierbei kann es sich um eine der folgenden WdColor-Konstanten oder um einen Wert handeln, der von der RGB-Funktion zurückgegeben wird. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FramesetBorderColor-Eigenschaft

In diesem Beispiel wird Gelbbraun als Farbe für die Framerahmenlinien der angegebenen Framesseite festgelegt.

With ActiveWindow.Document.Frameset
    .FramesetBorderColor = wdColorTan
    .FramesetBorderWidth = 6
End With


FramesetBorderWidth-Eigenschaft

Gibt die Breite (in Punkt) des Rahmens zurück, der den Frame auf der angegebenen Framesseite umgibt, oder legt die Breite fest. Single Schreib-Lese-Zugriff.

Hinweise

Weitere Informationen über das Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur FramesetBorderWidth-Eigenschaft

In diesem Beispiel wird die Breite von Framerahmenlinien auf der angegebenen Framesseite auf 6 Punkt gesetzt.

With ActiveWindow.Document.Frameset
    .FramesetBorderColor = wdColorTan
    .FramesetBorderWidth = 6
End With


FreeDiskSpace-Eigenschaft

Gibt den verfügbaren Plattenspeicher für das aktuelle Laufwerk in Byte an. Mit der ChDir-Anweisung ändern Sie das aktuelle Laufwerk. Long Nur-Lese-Zugriff.

Hinweis 1 Kilobyte besteht aus 1024 Byte und 1 Megabyte aus 1.048.576 Byte.


Beispiel zur FreeDiskSpace-Eigenschaft

In diesem Beispiel wird die Größe des freien Festplattenspeichers überprüft. Stehen weniger als 10 MB zur Verfügung, wird eine Meldung angezeigt.

If (System.FreeDiskSpace \ 1048576) < 10 Then _
    MsgBox "Low disk space"


FullName-Eigenschaft

Gibt den Namen des angegebenen Dokuments oder der angegebenen Vorlage zurück, einschließlich seines Pfads auf der Festplatte oder im Web. String Nur-Lese-Zugriff.

Hinweise

Die Verwendung dieser Eigenschaft ist äquivalent zur sequentiellen Verwendung der Path-, PathSeparator- und Name-Eigenschaft.


Beispiel zur FullName-Eigenschaft

In diesem Beispiel werden der Pfad und der Dateiname des aktiven Dokuments angezeigt (dabei wird angenommen, dass das Dokument gespeichert wurde).

MsgBox ActiveDocument.FullName

In diesem Beispiel werden der Pfad und der Dateiname der Vorlage angezeigt, die mit dem aktiven Dokument verbunden ist.

MsgBox ActiveDocument.AttachedTemplate.FullName


FullScreen-Eigenschaft

True, wenn sich das Fenster in der Ansicht Ganzer Bildschirm befindet. Boolean Schreib-Lese-Zugriff.


Beispiel zur FullScreen-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Ansicht Ganzer Bildschirm umgeschaltet.

ActiveDocument.ActiveWindow.View.FullScreen = True

In diesem Beispiel wird das Fenster für Sales.doc aktiviert und die Ansicht Ganzer Bildschirm ausgeschaltet.

With Windows("Sales.doc")
    .Activate
    .View.FullScreen = False
End With


Gap-Eigenschaft

Gibt den horizontalen Abstand (in Punkt) zwischen dem Ende der Legendenlinie und dem Rechteck, das den Textbereich begrenzt, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur Gap-Eigenschaft

In diesem Beispiel wird für Form eins in myDocument der Abstand zwischen der Legendenlinie und dem Rechteck, das den Textbereich begrenzt, auf 3 Punkt festgelegt. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
myDocument.Shapes(1).Callout.Gap = 3


GradientColorType-Eigenschaft

Gibt die Art der fließenden Farbe für den angegebenen Füllbereich zurück. Dies kann eine der folgenden MsoGradientColorType-Konstanten sein: msoGradientColorMixed, msoGradientOneColor, msoGradientPresetColors oder msoGradientTwoColors. Long Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient-, PresetGradient- oder TwoColorGradient-Methode zum Festlegen der Art der fließenden Farbe für den Füllbereich.


Beispiel zur GradientColorType-Eigenschaft

In diesem Beispiel wird für alle Formen in myDocument, die eine zweifarbige, fließende Füllfarbe haben, der Füllbereich in eine voreingestellte fließende Füllfarbe umgewandelt.

Set myDocument = Documents(1)
For Each s In myDocument.Shapes
    With s.Fill
        If .GradientColorType = msoGradientTwoColors Then
            .PresetGradient msoGradientHorizontal, 1, _
                msoGradientBrass
        End If
    End With
Next


GradientDegree-Eigenschaft

Gibt einen Wert zurück, der anzeigt, wie dunkel oder hell eine einfarbige, fließende Füllfarbe ist. Ein Wert von 0 (Null) bedeutet, dass Schwarz mit der Vordergrundfarbe der Form vermischt wurde, um die fließende Farbe zu bilden; ein Wert von 1 bedeutet, dass Weiß beigemischt wurde; und Werte zwischen 0 und 1 bedeuten, dass der Vordergrundfarbe ein dunklerer oder hellerer Farbton beigemischt wurde. Single Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient-Methode zum Festlegen des Grades der fließenden Farbe für den Füllbereich.


Beispiel zur GradientDegree-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und der Grad seiner fließenden Füllfarbe so festgelegt, dass er mit demjenigen der Form "Rectangle 2" übereinstimmt. Wenn Rechteck 2 keine einfarbige, fließende Füllfarbe hat, funktioniert dieses Beispiel nicht.

Set myDocument = ActiveDocument
With myDocument.Shapes
    gradDegree1 = .Item("Rectangle 2").Fill.GradientDegree
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(0, 128, 128)
        .OneColorGradient msoGradientHorizontal, 1, gradDegree1
    End With
End With


GradientStyle-Eigenschaft

Gibt den Stil der fließenden Farbe für den angegebenen Füllbereich zurück. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal, msoGradientMixed oder msoGradientVertical. (Die Konstante msoGradientFromTitle wird nur in PowerPoint verwendet.) Long Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient- oder TwoColorGradient-Methode zum Festlegen des Stils der fließenden Farbe für den Füllbereich.

Hinweis Versucht man, diese Eigenschaft für einen Füllbereich zurückzugeben, der keine fließende Farbe hat, tritt ein Fehler auf. Verwenden Sie die Type-Eigenschaft zum Ermitteln, ob der Füllbereich eine fließende Farbe hat.


Beispiel zur GradientStyle-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dessen Stil der fließenden Füllfarbe so festgelegt, dass er mit demjenigen der Form "rect1" übereinstimmt. Damit das Beispiel funktioniert, muss Rechteck 1 eine fließende Füllfarbe haben.

Set myDocument = ActiveDocument
With myDocument.Shapes
    gradStyle1 = .Item("rect1").Fill.GradientStyle
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .OneColorGradient gradStyle1, 1, 1
    End With
End With


GradientVariant-Eigenschaft

Gibt die Variante der fließenden Farbe für den angegebenen Füllbereich als ganzzahligen Wert zwischen 1 und 4 für die meisten fließenden Füllfarben zurück. Wenn der Stil der fließenden Farbe msoGradientFromCenter ist, gibt diese Eigenschaft entweder 1 oder 2 zurück. Die Werte für diese Eigenschaft entsprechen den Varianten der fließenden Farbe (die von links nach rechts und von oben nach unten nummeriert sind) auf der Registerkarte Graduell im Dialogfeld Fülleffekte. Long Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient- oder TwoColorGradient-Methode zum Festlegen der Variante der fließenden Farbe für den Füllbereich.


Beispiel zur GradientVariant-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dessen Variante der fließenden Füllfarbe so festgelegt, dass sie mit derjenigen der Form "rect" übereinstimmt. Damit das Beispiel funktioniert, muss Rechteck 1 eine fließende Füllfarbe haben.

With ActiveDocument.Shapes
    gradVar1 = .Item("rect1").Fill.GradientVariant
    With .AddShape(msoShapeRectangle, 0, 0, 40, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .OneColorGradient msoGradientHorizontal, gradVar1, 1
    End With
End With


GrammarChecked-Eigenschaft

True, wenn eine Grammatikprüfung für einen angegebenen Bereich oder ein Dokument durchgeführt wurde. False, wenn die Grammatik eines Teils des angegebenen Bereichs oder Dokuments nicht überprüft wurde. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Um die Grammatik in einem Bereich oder Dokument erneut zu überprüfen, setzen Sie die GrammarChecked-Eigenschaft auf False.


Beispiel zur GrammarChecked-Eigenschaft

In diesem Beispiel wird ermittelt, ob die Grammatik im aktiven Dokument überprüft wurde. Falls ja, wird die Anzahl der Wörter angezeigt. Wurde die Grammatik nicht überprüft, wird mit der Rechtschreib- und der Grammatikprüfung begonnen.

Set myStat = ActiveDocument.ReadabilityStatistics
passGram = ActiveDocument.GrammarChecked
If passGram = True Then
    Msgbox myStat(1).Name & " - " & myStat(1).Value
Else
    ActiveDocument.CheckGrammar
End If

In diesem Beispiel wird die GrammarChecked-Eigenschaft für das aktive Dokument auf False gesetzt und dann erneut eine Grammatikprüfung durchgeführt.

ActiveDocument.GrammarChecked = False
ActiveDocument.CheckGrammar


GrammaticalErrors-Eigenschaft

Gibt eine ProofreadingErrors-Sammlung zurück, die die Sätze darstellt, in denen bei der Grammatikprüfung des angegebenen Dokuments oder des Bereichs ein Fehler auftrat. Es kann sich um mehr als einen Fehler pro Satz handeln. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Werden keine Grammatikfehler gefunden, gibt die Count-Eigenschaft für das ProofreadingErrors-Objekt, das durch die GrammaticalErrors-Eigenschaft zurückgegeben wird, 0 (Null) zurück.


Beispiel zur GrammaticalErrors-Eigenschaft

In diesem Beispiel wird der dritte Absatz im aktiven Dokument auf grammatikalische Fehler überprüft, und alle Sätze mit mindestens einem Fehler werden angezeigt.

Set myErrors = ActiveDocument.Paragraphs(3).Range.GrammaticalErrors
For Each myerr In myErrors
    MsgBox myerr.Text
Next myerr

In diesem Beispiel wird das aktive Dokument auf grammatikalische Fehler überprüft. Wenn Fehler gefunden werden, wird eine neue Rechtschreib- und Grammatikprüfung gestartet.

If ActiveDocument.GrammaticalErrors.Count = 0 Then
    Msgbox "There are no grammatical errors."
Else
    ActiveDocument.CheckGrammar
End If


GridDistanceHorizontal-Eigenschaft

Document-Objekt: Gibt die Größe des horizontalen Abstands zwischen den nicht sichtbaren Gitternetzlinien zurück, die in Microsoft Word verwendet werden, wenn Sie im angegebenen Dokument AutoFormen oder ostasiatische Zeichen zeichnen, verschieben oder deren Größe ändern, oder legt die Größe des horizontalen Abstands fest. Single Schreib-Lese-Zugriff.

Options-Objekt: Gibt die Größe des horizontalen Abstands zwischen nicht sichtbaren Gitternetzlinien zurück oder setzt diesen fest. Word verwendet diese Gitternetzlinien, wenn Sie in neuen Dokumenten AutoFormen oder ostasiatische Zeichen zeichnen, verschieben oder ihre Größe ändern. Single Schreib-Lese-Zugriff.


Beispiel zur GridDistanceHorizontal-Eigenschaft

In diesem Beispiel werden der horizontale und der vertikale Abstand zwischen Gitternetzlinien festgelegt. Anschließend wird die Funktion Am Raster ausrichten für das aktuelle Dokument aktiviert.

With ActiveDocument
    .GridDistanceHorizontal = 9
    .GridDistanceVertical = 9
    .SnapToGrid = True
End With

In diesem Beispiel werden der horizontale und der vertikale Abstand zwischen Gitternetzlinien festgelegt. Dann wird die Funktion Am Raster ausrichten für ein neues Dokument aktiviert.

With Options
    .GridDistanceHorizontal = InchesToPoints(0.2)
    .GridDistanceVertical = InchesToPoints(0.2)
    .SnapToGrid = True
End With
Documents.Add


GridDistanceVertical-Eigenschaft

Document-Objekt: Gibt die Größe des vertikalen Abstands zwischen nicht sichtbaren Gitternetzlinien zurück oder legt sie fest. Microsoft Word verwendet die Gitternetzlinien, wenn Sie im angegebenen Dokument AutoFormen oder ostasiatische Zeichen zeichnen, verschieben oder deren Größe ändern. Single Schreib-Lese-Zugriff.

Options-Objekt: Gibt die Größe des vertikalen Abstands zwischen nicht sichtbaren Gitternetzlinien zurück oder legt sie fest. Word verwendet die Gitternetzlinien, wenn Sie in neuen Dokumenten AutoFormen oder ostasiatische Zeichen zeichnen, verschieben oder deren Größe ändern. Single Schreib-Lese-Zugriff.


Beispiel zur GridDistanceVertical-Eigenschaft

In diesem Beispiel werden der horizontale und der vertikale Abstand zwischen Gitternetzlinien festgelegt. Danach wird die Funktion Am Raster ausrichten für das aktuelle Dokument aktiviert.

With ActiveDocument
    .GridDistanceHorizontal = 9
    .GridDistanceVertical = 9
    .SnapToGrid = True
End With

In diesem Beispiel werden der horizontale und der vertikale Abstand zwischen Gitternetzlinien festgelegt. Anschließend wird die Funktion Am Raster ausrichten für ein neues Dokument aktiviert.

With Options
    .GridDistanceHorizontal = InchesToPoints(0.2)
    .GridDistanceVertical = InchesToPoints(0.2)
    .SnapToGrid = True
End With
Documents.Add


GridOriginFromMargin-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word starts the character grid from the upper-left corner of the page. Read/write Boolean.


Beispiel zur GridOriginFromMargin-Eigenschaft

This example sets Microsoft Word to start the character grid for the active document from the upper-left corner of the page.

ActiveDocument.GridOriginFromMargin = True


GridOriginHorizontal-Eigenschaft

Document-Objekt: Gibt den Punkt relativ zur linken Seitenkante zurück, an dem das nicht sichtbare Gitter zum Zeichnen, Verschieben oder Ändern der Größe von AutoFormen oder ostasiatischen Zeichen im angegebenen Dokument beginnen soll, oder legt diesen Punkt fest. Single Schreib-Lese-Zugriff.

Options-Objekt: Gibt den Punkt relativ zur linken Seitenkante zurück, an dem das nicht sichtbare Gitter zum Zeichnen, Verschieben oder Ändern der Größe von AutoFormen oder ostasiatischen Zeichen in neuen Dokumenten beginnen soll, oder legt diesen Punkt fest. Single Lese-Schreib-Zugriff.


Beispiel zur GridOriginHorizontal-Eigenschaft

In diesem Beispiel werden der horizontale und der vertikale Punkt für den Gitterursprung sowie der horizontale und vertikale Abstand zwischen den Gitternetzlinien festgelegt. Anschließend wird die Funktion Am Raster ausrichten für das aktuelle Dokument aktiviert.

With ActiveDocument
    .GridOriginHorizontal = 80
    .GridOriginVertical = 90
    .GridDistanceHorizontal = 9
    .GridDistanceVertical = 9
    .SnapToGrid = True
End With

In diesem Beispiel werden der horizontale und der vertikale Punkt für den Gitterursprung sowie der horizontale und vertikale Abstand zwischen den Gitternetzlinien festgelegt. Dann wird die Funktion Am Raster ausrichten für ein neues Dokument aktiviert.

With Options
    .GridOriginHorizontal = InchesToPoints(1)
    .GridOriginVertical = InchesToPoints(2)
    .GridDistanceHorizontal = InchesToPoints(0.1)
    .GridDistanceVertical = InchesToPoints(0.1)
    .SnapToGrid = True
End With
Documents.Add


GridOriginVertical-Eigenschaft

Document-Objekt: Gibt den Punkt, relativ zur oberen Seitenkante, zurück, an dem im angegebenen Dokument das nicht sichtbare Gitter zum Zeichnen, Verschieben oder Ändern der Größe von AutoFormen oder ostasiatischen Zeichen beginnen soll, oder legt diesen Punkt fest. Single Schreib-Lese-Zugriff.

Options-Objekt: Gibt den Punkt, relativ zur oberen Seitenkante, zurück, an dem in neuen Dokumenten das nicht sichtbare Gitter zum Zeichnen, Verschieben oder Ändern der Größe von AutoFormen oder ostasiatischen Zeichen beginnen soll, oder legt diesen Punkt fest. Single Schreib-Lese-Zugriff.


Beispiel zur GridOriginVertical-Eigenschaft

In diesem Beispiel werden der horizontale und der vertikale Punkt für den Gitterursprung sowie der horizontale und vertikale Abstand zwischen den Gitternetzlinien festgelegt. Dann wird die Funktion Am Raster ausrichten für das aktuelle Dokument aktiviert.

With ActiveDocument
    .GridOriginHorizontal = 80
    .GridOriginVertical = 90
    .GridDistanceHorizontal = 9
    .GridDistanceVertical = 9
    .SnapToGrid = True
End With

In diesem Beispiel werden der horizontale und der vertikale Punkt für den Gitterursprung sowie der horizontale und vertikale Abstand zwischen den Gitternetzlinien festgelegt. Dann wird die Funktion Am Raster ausrichten für ein neues Dokument aktiviert.

With Options
    .GridOriginHorizontal = InchesToPoints(1)
    .GridOriginVertical = InchesToPoints(2)
    .GridDistanceHorizontal = InchesToPoints(0.2)
    .GridDistanceVertical = InchesToPoints(0.2)
    .SnapToGrid = True
End With
Documents.Add


GridSpaceBetweenHorizontalLines-Eigenschaft

Sprachspezifische Informationen

Returns or sets the interval at which Microsoft Word displays horizontal character gridlines in print layout view. Read/write Long.


Beispiel zur GridSpaceBetweenHorizontalLines-Eigenschaft

This example sets Microsoft Word to display every fifth horizontal character gridline.

ActiveDocument.GridSpaceBetweenHorizontalLines = 5


GridSpaceBetweenVerticalLines-Eigenschaft

Sprachspezifische Informationen

Returns or sets the interval at which Microsoft Word displays vertical character gridlines in print layout view. Read/write Long.


Beispiel zur GridSpaceBetweenVerticalLines-Eigenschaft

This example sets Microsoft Word to display every other vertical character gridline.

ActiveDocument.GridSpaceBetweenVerticalLines = 2


GroupItems-Eigenschaft

Gibt ein GroupShapes-Objekt zurück, das die einzelnen Formen in der angegebenen Gruppe darstellt. Verwenden Sie die Item-Methode des GroupShapes-Objekts zur Zurückgabe einer einzelnen Form der Gruppe. Betrifft Shape- oder ShapeRange-Objekte, die gruppierte Formen darstellen. Nur-Lese-Zugriff.


Beispiel zur GroupItems-Eigenschaft

In diesem Beispiel werden zu myDocument drei Dreiecke hinzugefügt, diese gruppiert, eine Farbe für die gesamte Gruppe festgelegt und dann nur die Farbe für das zweite Dreieck geändert.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, _
        10, 10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, _
        150, 10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, _
        300, 10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


Gutter-Eigenschaft

Zurückgeben oder Festlegen der Breite (in Punkt) des zusätzlichen Seitenrands (Bundsteg), der jeder Seite in einem Dokument oder Abschnitt zum Binden hinzugefügt wird. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn die MirrorMargins-Eigenschaft auf True gesetzt ist, fügt die Gutter-Eigenschaft den Bundsteg dem inneren Seitenrand hinzu. Andernfalls wird der zusätzliche Leerraum dem linken Seitenrand zugeschlagen.


GutterPos-Eigenschaft

Sprachspezifische Informationen

Returns or sets on which side the gutter appears in a document. Can be either of the following WdGutterStyle constants: wdGutterPosLeft or wdGutterPosRight. Read/write Long.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur GutterPos-Eigenschaft

This example sets the gutter to appear on the right side of the document.

ActiveDocument.PageSetup.GutterPos = wdGutterPosRight


GutterStyle-Eigenschaft

Sprachspezifische Informationen

Returns or sets whether Microsoft Word uses gutters for the current document based on a right-to-left language or a left-to-right language. Can be either of the following WdGutterStyleOld constants: wdGutterStyleBidi or wdGutterStyleLatin. Read/write Long.

Remarks

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur GutterStyle-Eigenschaft

This example sets the current document to follow a gutter style for a right-to-left language document.

ActiveDocument.PageSetup.GutterStyle = wdGutterStyleBidi


HalfWidthPunctuationOnTopOfLine-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word changes punctuation symbols at the beginning of a line to half-width characters for the specified paragraphs. This property returns wdUndefined if it’s set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur HalfWidthPunctuationOnTopOfLine-Eigenschaft

This example sets Microsoft Word to change punctuation symbols at the beginning of a line to half-width characters for the first paragraph in the active document.

ActiveDocument.Paragraphs(1).HalfWidthPunctuationOnTopOfLine = True


HangingPunctuation-Eigenschaft

Sprachspezifische Informationen

True if hanging punctuation is enabled for the specified paragraphs. This property returns wdUndefined if it’s set to True for only some of the specified paragraphs. Read/write Long.


Beispiel zur HangingPunctuation-Eigenschaft

This example enables hanging punctuation for the first paragraph in the active document.

ActiveDocument.Paragraphs(1).HangingPunctuation = True


HangulAndAlphabetAutoAdd-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word automatically adds words to the list of hangul and alphabet AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box (AutoCorrect command, Tools menu). Word adds a word to this list if you delete and then retype a word that you didn't want Word to correct. Read/write Boolean.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur HangulAndAlphabetAutoAdd-Eigenschaft

This example sets Microsoft Word to automatically add words to the list of hangul and alphabet AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box.

AutoCorrect.HangulAndAlphabetAutoAdd = True


HangulAndAlphabetExceptions-Eigenschaft

Sprachspezifische Informationen

Returns a HangulAndAlphabetExceptions collection that represents the list of hangul and alphabet AutoCorrect exceptions. This list corresponds to the list of hangul and alphabet AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box (AutoCorrect command, Tools menu). Read-only.

For information about returning a single member of a collection, see Returning an Object from a Collection.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur HangulAndAlphabetExceptions-Eigenschaft

This example prompts the user to delete or keep each hangul and alphabet AutoCorrect exception on the Korean tab in the AutoCorrect Exceptions dialog box.

For Each anEntry In _
        AutoCorrect.HangulAndAlphabetExceptions
    response = MsgBox("Delete entry: " _
        & anEntry.Name, vbYesNoCancel)
    If response = vbYes Then
        anEntry.Delete
    Else
        If response = vbCancel Then End
    End If
Next anEntry


HangulHanjaDictionaries-Eigenschaft

Sprachspezifische Informationen

Returns a HangulHanjaConversionDictionaries collection that represents all the active custom conversion dictionaries. Active custom conversion dictionaries are marked with a check in the Custom Dictionaries dialog box. Read-only.

For information about returning a single member of a collection, see Returning an Object from a Collection.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur HangulHanjaDictionaries-Eigenschaft

This example adds a new, blank custom dictionary to the collection. The path and file name of the new custom dictionary are then displayed in a message box.

Set myHome = _
    HangulHanjaDictionaries.Add(Filename:="Home.hhd")
Msgbox myHome.Path & Application.PathSeparator _
    & myHome.Name

This example deactivates all custom dictionaries so that no custom dictionaries are active. It does not delete the custom dictionary files.

HangulHanjaDictionaries.ClearAll

This example displays the name of each custom dictionary in the collection.

For Each di In HangulHanjaDictionaries
    MsgBox di.Name
Next di


HangulHanjaFastConversion-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word automatically converts a word with only one suggestion during conversion between hangul and hanja. Read/write Boolean.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur HangulHanjaFastConversion-Eigenschaft

This example asks the user whether to set Microsoft Word to use fast conversion during conversion between hangul and hanja.

x = MsgBox("Use fast conversion?", vbYesNo)
If x = vbYes Then
    Options.HangulHanjaFastConversion = True
Else
    Options.HangulHanjaFastConversion = False
End If


HasFile-Eigenschaft

True, wenn das angegebene Filialdokument in einer Datei gespeichert wurde. Boolean Nur-Lese-Zugriff.


Beispiel zur HasFile-Eigenschaft

In diesem Beispiel werden die Dateinamen aller Filialdokumente im aktiven Dokument angezeigt. Es wird auch eine Meldung für jedes noch nicht gespeicherte Filialdokument ausgegeben.

For Each subdoc In ActiveDocument.Subdocuments
    subdoc.Range.Select
    If subdoc.HasFile = True Then
        MsgBox subdoc.Path & Application.PathSeparator _
            & subdoc.Name
    Else
        MsgBox "This subdocument has not been saved."
    End If
Next subdoc


HasHorizontal-Eigenschaft

True, wenn ein horizontaler Rahmen einem Objekt zugewiesen werden kann. Boolean Nur-Lese-Zugriff.

Anmerkungen

Horizontale Rahmen können Bereichen mit Zellen in zwei oder mehr Zeilen in einer Tabelle oder Bereichen mit mindestens zwei Absätzen zugewiesen werden.


Beispiel zur HasHorizontal-Eigenschaft

In diesem Beispiel werden einfache horizontale Rahmen zugewiesen, wenn die Auswahl horizontale Rahmen unterstützt.

If Selection.Borders.HasHorizontal = True Then
    Selection.Borders(wdBorderHorizontal).LineStyle = _
        wdLineStyleSingle
End If


HasPassword-Eigenschaft

True, wenn ein Kennwort zum Öffnen des angegebenen Dokuments benötigt wird. Boolean Nur-Lese-Zugriff.


Beispiel zur HasPassword-Eigenschaft

In diesem Beispiel wird das Kennwort "kittycat" für das aktive Dokument festgelegt und dann eine Bestätigungsmeldung angezeigt.

ActiveDocument.Password = "kittycat"
If ActiveDocument.HasPassword = True Then _
    MsgBox "The password is set."


HasRoutingSlip-Eigenschaft

True, wenn das angegebene Dokument mit einer Verteilerliste versehen ist. Eine Verteilerliste wird erstellt, wenn Sie diese Eigenschaft auf True setzen; setzen Sie sie dagegen auf False, wird die Verteilerliste gelöscht. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasRoutingSlip-Eigenschaft

In diesem Beispiel wird die Verteilerliste vom Dokument "Sales 1995.doc" entfernt.

Documents("Sales 1995.doc").HasRoutingSlip = False

Wenn das aktive Dokument mit einer Verteilerliste versehen ist, wird es in diesem Beispiel an die Empfänger weitergeleitet.

If ActiveDocument.HasRoutingSlip = True Then
    ActiveDocument.Route
End If


HasText-Eigenschaft

True, wenn die angegebene Form mit Text verbunden ist. Boolean Nur-Lese-Zugriff.


Beispiel zur HasText-Eigenschaft

Wenn Form zwei in myDocument Text enthält, wird in diesem Beispiel eine Meldung angezeigt, falls der Text über seinen Rahmen hinausläuft.

Set myDocument = ActiveDocument
With myDocument.Shapes(2).TextFrame
    If .HasText = True Then
        If .Overflowing = True Then
            Msgbox "Text overflows the frame."
        End If
    End If
End With


HasVertical-Eigenschaft

True, wenn ein vertikaler Rahmen dem angegebenen Objekt zugewiesen werden kann. Boolean Nur-Lese-Zugriff.

Anmerkungen

Vertikale Rahmen können Bereichen mit Zellen in zwei oder mehr Tabellenspalten zugewiesen werden.


Beispiel zur HasVertical-Eigenschaft

Wenn die Auswahl vertikale Rahmen unterstützt, weist dieses Beispiel einen einfachen vertikalen Rahmen zu.

If Selection.Borders.HasVertical = True Then
    Selection.Borders(wdBorderVertical).LineStyle = _
        wdLineStyleSingle
End If


HeaderDistance-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der Kopfzeile und der oberen Seitenkante zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur HeaderDistance-Eigenschaft

In diesem Beispiel wird der Abstand zwischen der Kopfzeile und der oberen Seitenkante angezeigt. Die PointsToInches-Methode wird zur Umwandlung von Punkt in Zoll verwendet.

dist = ActiveDocument.PageSetup.HeaderDistance
Msgbox PointsToInches(dist) & " inches"


HeaderFooter-Eigenschaft

Gibt ein HeaderFooter-Objekt für die angegebene Auswahl oder den Bereich zurück. Nur-Lese-Zugriff.

Hinweis Ein Fehler tritt auf, wenn sich die Markierung nicht innerhalb einer Kopf- oder Fußzeile befindet.


Beispiel zur HeaderFooter-Eigenschaft

In diesem Beispiel wird die Fußzeile der aktuellen Seiten mit einer zentrierten Seitennummer versehen.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageFooter
End With
Selection.HeaderFooter.PageNumbers.Add _
    PageNumberAlignment:=wdAlignPageNumberCenter


Headers-Eigenschaft

Gibt eine HeadersFooters-Auflistung zurück, die die Kopfzeilen im angegebenen Abschnitt darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Zur Zurückgabe einer HeadersFooters-Auflistung, die die Fußzeilen im angegebenen Abschnitt darstellt, verwenden Sie die Footers-Eigenschaft.


HeaderSourceName-Eigenschaft

Gibt Pfad und Dateiname der Steuersatzquelle, die dem angegebenen Seriendruck-Hauptdokument zugeordnet ist, zurück oder legt sie fest. String Nur-Lese-Zugriff.


Beispiel zur HeaderSourceName-Eigenschaft

Wenn eine Steuersatzquelle dem aktiven Dokument zugeordnet wurde, wird in diesem Beispiel der Dateiname angezeigt.

hName = ActiveDocument.MailMerge.DataSource.HeaderSourceName
If hName <> "" Then MsgBox hName

In diesem Beispiel wird die Steuersatzquelle geöffnet, die dem aktiven Dokument zugeordnet ist, wenn es sich bei der Quelle um ein Word-Dokument handelt.

Set dSource = ActiveDocument.MailMerge.DataSource
If dSource.HeaderSourceType = wdMergeInfoFromWord Then
    Documents.Open FileName:=dSource.HeaderSourceName
End If


HeaderSourceType-Eigenschaft

Gibt einen Wert zurück, der die Art angibt, die die Steuersatzquelle für die Seriendruckoperation zur Verfügung gestellt hat. Dabei kann es sich um eine der folgenden WdMailMergeDataSource-Konstanten handeln: wdMergeInfoFromAccessDDE, wdMergeInfoFromExcelDDE, wdMergeInfoFromMSQueryDDE, wdMergeInfoFromODBC, wdMergeInfoFromWord oder wdNoMergeInfo. Long Nur-Lese-Zugriff.


Beispiel zur HeaderSourceType-Eigenschaft

In diesem Beispiel wird die Steuersatzquelle geöffnet, die dem aktiven Dokument zugeordnet ist, wenn es sich bei der Quelle um ein Word-Dokument handelt.

Set dSource = ActiveDocument.MailMerge.DataSource
If dSource.HeaderSourceType = wdMergeInfoFromWord Then
    Documents.Open FileName:=dSource.HeaderSourceName
End If


HeadingFormat-Eigenschaft

True, wenn die angegebene Zeile oder die angegebenen Zeilen als Tabellenüberschrift formatiert sind. Zeilen, die als Tabellenüberschrift formatiert sind, werden wiederholt, wenn eine Tabelle sich über mehr als eine Seite erstreckt. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur HeadingFormat-Eigenschaft

In diesem Beispiel wird am Anfang des aktiven Dokuments eine 5x5 Tabelle erstellt und dann der ersten Tabellenzeile das Tabellenüberschrift-Format zugewiesen.

Set myRange = ActiveDocument.Range(0, 0)
Set myTable = ActiveDocument.Tables.Add(myRange, 5, 5)
myTable.Rows(1).HeadingFormat = True

In diesem Beispiel wird ermittelt, ob die Zeile, die die Einfügemarke enthält, als Tabellenüberschrift formatiert ist.

If Selection.Information(wdWithInTable) = True Then
    If Selection.Rows(1).HeadingFormat = True Then _
        MsgBox "The current row is a table heading"
Else
    MsgBox "The insertion point is not in a table."
End If


HeadingLevelForChapter-Eigenschaft

Gibt die Formatvorlage der Überschriftsebene, die den Kapitelüberschriften im Dokument zugewiesen wurde, zurück oder legt sie fest. Kann eine Zahl von 0 (Null) bis 8 sein, entsprechend den Überschriftsebenen 1 bis 9. Long Schreib-Lese-Zugriff.

Hinweise

Bevor Sie Seitennummern erstellen können, die Kapitelnummern enthalten, muss den Dokumentüberschriften ein Gliederungsformat mit Nummerierung zugewiesen worden sein, das Formatvorlagen aus dem Dialogfeld Nummerierung und Aufzählungen verwendet. Verwenden Sie in Visual Basic die ApplyListTemplate-Methode dazu.


Beispiel zur HeadingLevelForChapter-Eigenschaft

Im ersten Teil dieses Beispiels wird ein neues Dokument erstellt, werden Kapitelüberschriften und Seitenwechsel hinzugefügt, und dann wird das Dokument formatiert, indem das letzte Gliederungsformat mit Nummerierung verwendet wird, das im Dialogfeld Nummerierung und Aufzählungen aufgelistet ist. Im zweiten Teil des Beispiels werden der Kopfzeile zentrierte Seitennummern einschließlich der Kapitelnummer hinzugefügt; ein kurzer Gedankenstrich trennt die Kapitelnummer und die Seitennummer. Für die Kapitelnummer wird die erste Überschriftsebene verwendet, und für die Seitennummer werden römische Ziffern in Kleinbuchstaben verwendet.

Documents.Add
For i = 1 To 5
    With Selection
        .TypeParagraph
        .InsertBreak
    End With
Next i
ActiveDocument.Content.Style = wdStyleHeading1
ActiveDocument.Content.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(7)

Set myHead = ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary)
With myHead.PageNumbers
    .Add PageNumberAlignment:=wdAlignPageNumberCenter
    .NumberStyle = wdPageNumberStyleArabic
    .IncludeChapterNumber = True
    .HeadingLevelForChapter = 0
    .ChapterPageSeparator = wdSeparatorEnDash
End With


HeadingSeparator-Eigenschaft

Gibt den Text zwischen alphabetischen Gruppen (Einträgen, die mit demselben Buchstaben anfangen) im Index zurück oder legt ihn fest. Entspricht dem Schalter \h für ein INDEX-Feld. Dies kann eine der folgenden WdHeadingSeparator-Konstanten sein: wdHeadingSeparatorBlankLine, wdHeadingSeparatorLetter, wdHeadingSeparatorLetterFull, wdHeadingSeparatorLetterLow oder wdHeadingSeparatorNone. Long Schreib-Lese-Zugriff.


Beispiel zur HeadingSeparator-Eigenschaft

In diesem Beispiel wird der erste Index für das aktive Dokument in einer einzelnen Spalte formatiert, so dass vor jeder alphabetischen Gruppe der entsprechende Buchstabe steht.

If ActiveDocument.Indexes.Count >= 1 Then
    With ActiveDocument.Indexes(1)
        .HeadingSeparator = wdHeadingSeparatorLetter
        .NumberOfColumns = 1
    End With
End If


HeadingStyles-Eigenschaft

Gibt ein HeadingStyles-Objekt zurück, das weitere Formatvorlagen darstellt, die zum Erstellen eines Inhaltsverzeichnisses oder Abbildungsverzeichnisses verwendet werden (andere Formatvorlagen als Überschrift 1 – Überschrift 9). Nur-Lese-Zugriff.


Beispiel zur HeadingStyles-Eigenschaft

In diesem Beispiel wird der HeadingStyles-Auflistung eine Formatvorlage hinzugefügt, und dann werden die Namen aller Formatvorlagen in der Auflistung angezeigt.

If ActiveDocument.TablesOfContents.Count >=1 Then
    ActiveDocument.TablesOfContents(1).HeadingStyles.Add _
        Style:="Title", Level:=2
    For Each hStyle In _
            ActiveDocument.TablesOfContents(1).HeadingStyles
        MsgBox hStyle.Style
    Next hStyle
End If

In diesem Beispiel wird der HeadingStyles-Auflistung in einem Inhaltsverzeichnis für Verkauf.doc eine Formatvorlage "Blue" hinzugefügt.

With Documents("Sales.doc")
    .Styles.Add Name:="Blue"
    .TablesOfContents(1).UseHeadingStyles = True
    .TablesOfContents(1).HeadingStyles.Add Style:="Blue", Level:=4
End With


HebrewMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the mode for the Hebrew spelling checker. Read/write Long.

Can be one of the following WdHebSpellStart constants.

Constant | Description
wdFullScript | The spelling checker follows rules for the conventional script required by the Hebrew Language Academy for writing text without diacritics.
wdPartialScript | The spelling checker follows rules for the traditional script used only for text with diacritics.
wdMixedScript | The spelling checker follows rules for full and partial script and allows non-conventional spelling variations. Only completely unrecogznied words are highlighted as potential mistakes.
wdMixedAuthorizedScript | The spelling checker follows rules for full and partial script, but highlights as potential mistakes any spelling variations not permitted within either system and any completely unrecogznied words.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur HebrewMode-Eigenschaft

This example sets the spelling checker to check spelling based on the conventional script required by the Hebrew Language Academy for writing text with diacritics.

Options.HebrewMode = wdFullScript


Height-Eigenschaft

Gibt die Höhe des angegebenen Objekts (in Punkt, wenn nicht anders ausgewiesen) zurück oder legt sie fest, entsprechend der folgenden Tabelle.

Objekt | Höhe
Application | Gibt die Höhe des aktiven Dokumentfensters zurück oder legt sie fest. Long Schreib-Lese-Zugriff.
Cell, Cells | Gibt die Höhe der angegebenen Zelle oder Zellen in einer Tabelle zurück oder legt sie fest. Wenn die HeightRule-Eigenschaft der angegebenen Zeile wdRowHeightAuto ist, gibt Height wdUndefined zurück; durch Festlegen der Height-Eigenschaft wird HeightRule auf wdRowHeightAtLeast festgelegt. Single Schreib-Lese-Zugriff.
CustomLabel | Gibt die Höhe des angegebenen benutzerdefinierten Adressetiketts zurück oder legt sie fest. Single Schreib-Lese-Zugriff.
Frame | Gibt die Höhe des angegebenen Rahmens zurück oder legt sie fest. Single Schreib-Lese-Zugriff.
Frameset | Gibt die Höhe des angegebenen Frameset-Objekts zurück oder legt sie fest. Long Schreib-Lese-Zugriff. Die HeightType-Eigenschaft legt die Einheit fest, in der der Wert dargestellt wird.
InlineShape | Gibt die Höhe der angegebenen eingebetteten Form zurück oder legt sie fest. Single Schreib-Lese-Zugriff.
Row, Rows | Gibt die Höhe der angegebenen Zeile oder Zeilen in einer Tabelle zurück oder legt sie fest. Wenn die HeightRule-Eigenschaft der angegebenen Zeile wdRowHeightAuto ist, gibt Height wdUndefined zurück; durch Festlegen der Height-Eigenschaft wird HeightRule auf wdRowHeightAtLeast festgelegt. Single Schreib-Lese-Zugriff.
Shape, ShapeRange | Gibt die Höhe der angegebenen Form zurück oder legt sie fest. Single Schreib-Lese-Zugriff.
Task | Gibt die Höhe des angegebenen Task-Fensters zurück oder legt sie fest. Long Schreib-Lese-Zugriff.
Window | Gibt die Höhe des Fensters zurück oder legt sie fest. Sie können diese Eigenschaft nicht festlegen, wenn das Fenster maximiert oder minimiert ist. Verwenden Sie die UsableHeight-Eigenschaft des Application-Objekts zum Ermitteln der Maximalgröße für das Fenster. Verwenden Sie die WindowState-Eigenschaft zum Ermitteln des Fensterstatus. Long Schreib-Lese-Zugriff.


HeightRule-Eigenschaft

Cell-, Cells-, Row- und Rows-Objekte: Gibt die Regel zum Festsetzen der Höhe der angegebenen Zellen oder Zeilen zurück oder legt sie fest. Dies kann eine der folgenden WdRowHeightRule-Konstanten sein: wdRowHeightAtLeast, wdRowHeightAuto oder wdRowHeightExactly. Long Schreib-Lese-Zugriff.

Frame-Objekt: Gibt die Regel zum Festsetzen der Höhe des angegebenen Rahmens zurück oder legt sie fest. Dies kann eine der folgenden WdFrameSizeRule-Konstanten sein: wdFrameAtLeast, wdFrameAuto oder wdFrameExact. Long Schreib-Lese-Zugriff.

Anmerkungen

Beim Festlegen der HeightRule-Eigenschaft eines Cell- oder Cells-Objekts wird automatisch die Eigenschaft für die gesamte Zeile festgelegt.


Beispiel zur HeightRule-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument eine 3x3-Tabelle erstellt und dann für die zweite Zeile eine minimale Zeilenhöhe von 24 Punkt festgelegt.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=3)
With myTable.Rows(2)
    .Height = 24
    .HeightRule = wdRowHeightAtLeast
End With

In diesem Beispiel wird die Höhenregel für die markierten Zeilen so festgelegt, dass die Höhe automatisch an die höchste Zelle in der Zeile angepasst wird.

If Selection.Information(wdWithInTable) = True Then
    Selection.Rows.HeightRule = wdRowHeightAuto
Else
    MsgBox "The insertion point is not in a table."
End If

In diesem Beispiel werden Höhe und Breite des ersten Rahmens im aktiven Dokument auf genau 1 Zoll festgelegt.

If ActiveDocument.Frames.Count >= 1 Then
    With ActiveDocument.Frames(1)
        .HeightRule = wdFrameExact
        .Height = InchesToPoints(1)
        .WidthRule = wdFrameExact
        .Width = InchesToPoints(1)
    End With
End If


HeightType-Eigenschaft

Gibt den Breitentyp für den angegebenen Frame auf einer Framesseite zurück oder legt ihn fest. Long Schreib-Lese-Zugriff. Dabei kann es sich um eine der in der folgenden Tabelle aufgelisteten WdFramesetSizeType-Konstanten handeln.

Konstante | Beschreibung
wdFramesetSizeTypeFixed | Microsoft Word interpretiert die Höhe des angegebenen Frames als konstanten Wert (in Punkt).
wdFramesetSizeTypePercent | Word interpretiert die Höhe des angegebenen Frames als prozentualer Teil der Bildschirmbreite.
wdFramesetSizeTypeRelative | Word interpretiert die Höhe des angegebenen Frames bezogen auf die Breite anderer Frames auf derselben Framesseite.


Beispiel zur HeightType-Eigenschaft

In diesem Beispiel wird die Höhe des ersten Frameset-Objekts auf der angegebenen Framesseite auf 25 Prozent der Höhe des Fensters festgelegt.

With ActiveDocument.ActiveWindow.Panes(1).Frameset
    .HeightType = wdFramesetSizeTypePercent
    .Height = 25
End With


HelpText-Eigenschaft

Gibt den Text, der in einem Meldungsfeld angezeigt wird, zurück oder legt ihn fest, wenn das Formularfeld den Fokus hat und der Benutzer F1 drückt. Wenn die OwnHelp-Eigenschaft auf True gesetzt ist, dann spezifiziert HelpText den Wert der Text-Zeichenfolge. Wenn OwnHelp auf False gesetzt ist, dann spezifiziert HelpText den Namen eines AutoText-Eintrags mit dem Hilfetext für das Formularfeld. String Schreib-Lese-Zugriff.


Beispiel zur HelpText-Eigenschaft

In diesem Beispiel wird der Hilfetext für das Formularfeld "Name" festgelegt.

With ActiveDocument.FormFields("Name")
    .OwnHelp = True
    .HelpText = "Type your full legal name."
End With


Hidden-Eigenschaft

True, wenn die Schriftart als ausgeblendeter Text formatiert wurde. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Um die Anzeige von ausgeblendetem Text zu steuern, benutzen Sie die ShowHiddenText-Eigenschaft des View-Objekts.

Um zu steuern, ob Eigenschaften und Methoden, die Range-Objekte zurückgeben, ausgeblendeten Text enthalten oder ausschließen, wenn ausgeblendeter Text nicht angezeigt wird, benutzen Sie die IncludeHiddenText-Eigenschaft des TextRetrievalMode-Objekts.


Beispiel zur Hidden-Eigenschaft

In diesem Beispiel wird Text eingefügt und die Kennwortnummer als ausgeblendeter Text formatiert.

Selection.Collapse Direction:=wdCollapseEnd
With Selection.Range
    .InsertAfter "Smith account password: 8116"
    .Words(5).Font.Hidden = True
End With

In diesem Beispiel wird die Auswahl nach ausgeblendetem Text überprüft.

If Selection.Type = wdSelectionNormal Then
    If Selection.Font.Hidden = wdUndefined or _
            Selection.Font.Hidden = True Then
        MsgBox "There's hidden text in the selection."
    Else
        MsgBox "No hidden text in the selection."
    End If
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird der gesamte ausgeblendete Text im aktiven Fenster sichtbar gemacht, und dann wird die Auswahl als ausgeblendeter Text formatiert.

ActiveDocument.ActiveWindow.View.ShowHiddenText = True
If Selection.Type = wdSelectionNormal Then _
    Selection.Font.Hidden = True


HidePageNumbersInWeb-Eigenschaft

Gibt zurück oder legt fest, dass Seitennummern in einem Inhaltsverzeichnis oder einem Abbildungsverzeichnis beim Veröffentlichen im Web ausgeblendet werden sollen. Boolean Schreib-Lese-Zugriff.


Beispiel zur HidePageNumbersInWeb-Eigenschaft

In diesem Beispiel werden die Seitenzahlen im ersten Inhaltsverzeichnis ausgeblendet, wenn das Dokument im Web veröffentlicht werden soll.

ActiveDocument.TableOfContents(1).HidePageNumbersInWeb = True


Highlight-Eigenschaft

Find-Objekt: True, wenn die Formatierung Hervorheben in die Suchkriterien aufgenommen wird. Kann True, False oder wdUndefined zurückgeben oder auf einen dieser Werte eingestellt werden. Long Schreib-Lese-Zugriff.

Hinweis Der Wert wdUndefined kann mit dem Find-Objekt verwendet werden, wenn der Status der Formatierung "Hervorheben" in der Markierung oder dem Bereich, die bzw.der durchsucht wird, ignoriert werden soll.

Replacement-Objekt: True, wenn die Formatierung "Hervorheben" dem Ersetzungstext zugewiesen wird. Kann True, False oder wdUndefined zurückgeben oder auf diese Werte eingestellt werden. Long Schreib-Lese-Zugriff.


HighlightColorIndex-Eigenschaft

Gibt die Farbe für Hervorhebungen im angegebenen Bereich zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln: wdNoHighlight, wdBlack, wdBlue, wdBrightGreen, wdDarkBlue, wdDarkRed, wdDarkYellow, wdGray25, wdGray50, wdGreen, wdPink, wdRed, wdTeal, wdTurquoise, wdViolet, wdWhite oder wdYellow. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft auf wdNoHighlight setzen, wird die Farbe für Hervorhebungen (falls vorhanden) vom angegebenen Bereich entfernt.


Beispiel zur HighlightColorIndex-Eigenschaft

In diesem Beispiel werden Formatierungen für Hervorhebungen aus der Auswahl entfernt.

Selection.Range.HighlightColorIndex = wdNoHighlight

In diesem Beispiel werden alle Textmarken im aktiven Dokument mit Gelb hervorgehoben.

For Each abookmark In ActiveDocument.Bookmarks
    abookmark.Range.HighlightColorIndex = wdYellow
Next abookmark


HorizontalDistanceFromText-Eigenschaft

Gibt den horizontalen Abstand zwischen einem Rahmen und dem umgebenden Text in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur HorizontalDistanceFromText-Eigenschaft

In diesem Beispiel wird ein Rahmen um die Auswahl gezogen, und der horizontale Abstand zwischen Rahmen und Text auf 12 Punkt festgelegt.

Set myFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)
myFrame.HorizontalDistanceFromText = 12

In diesem Beispiel wird ein Rahmen um den ersten Absatz gezogen, und verschiedene Rahmeneigenschaften werden festgelegt.

Set aFrame = ActiveDocument.Frames.Add _
    (Range:=ActiveDocument.Paragraphs(1).Range)
With aFrame
    .HorizontalDistanceFromText = InchesToPoints(0.25)
    .VerticalDistanceFromText = InchesToPoints(0.25)
    .HeightRule = wdFrameAuto
    .WidthRule = wdFrameAuto
    .Borders.Enable = False
End With


HorizontalFlip-Eigenschaft

True, wenn die angegebene Form um die vertikale Achse gekippt wurde. Long Nur-Lese-Zugriff.


Beispiel zur HorizontalFlip-Eigenschaft

In diesem Beispiel wird jede Form in myDocument in ihrem Originalzustand wiederhergestellt, wenn sie horizontal oder vertikal gekippt wurde.

For Each s In ActiveDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


HorizontalInVertical-Eigenschaft

Sprachspezifische Informationen

Returns or sets the formatting for horizontal text set within vertical text. Can be one of the following WdHorizontalInVerticalType constants: wdHorizontalInVerticalFitInLine, wdHorizontalInVerticalNone, or wdHorizontalInVerticalResizeLine. Read/write Long.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur HorizontalInVertical-Eigenschaft

This example formats the current selection as horizontal text within a run of vertical text, fitting the text to the width of the line of vertical text.

Selection.Range.HorizontalInVertical = _
    wdHorizontalInVerticalFitInLine


HorizontalLineFormat-Eigenschaft

Gibt ein HorizontalLineFormat-Objekt zurück, das die horizontale Zeilenformatierung für das angegebene InlineShape-Objekt enthält. Nur-Lese-Zugriff.


Beispiel zur HorizontalLineFormat-Eigenschaft

In diesem Beispiel wird die Länge der angegebenen horizontalen Zeile auf 50% der Fensterbreite festgelegt.

ActiveDocument.InlineShapes(1).HorizontalLineFormat _
    .PercentWidth = 50


HorizontalPercentScrolled-Eigenschaft

Gibt die horizontale Rollposition als Prozentwert der Dokumentbreite zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur HorizontalPercentScrolled-Eigenschaft

In diesem Beispiel wird der Prozentwert angezeigt, um den das aktive Fenster horizontal gerollt wurde.

MsgBox ActiveDocument.ActiveWindow.HorizontalPercentScrolled & "%"

In diesem Beispiel wird der aktive Ausschnitt des Fensters für Dokument1 horizontal ganz nach links gerollt.

With Windows("Document1")
    .Activate
    .ActivePane.HorizontalPercentScrolled = 0
End With


HorizontalPitch-Eigenschaft

Gibt den horizontalen Abstand (in Punkt) zwischen der linken Kante des einen benutzerdefinierten Etiketts und der linken Kante des nächsten Adressetiketts zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf einen Wert geändert wird, der für das Layout des angegebenen Etiketts nicht gültig ist, tritt ein Fehler auf.


Beispiel zur HorizontalPitch-Eigenschaft

In diesem Beispiel wird das Layout eines bereits vorhandenen benutzerdefinierten Etiketts "Laser labels" festgelegt. Der horizontale Abstand zwischen der linken Kante des einen Etiketts und der linken Kante des nächsten Etiketts wird auf 4,19 Zoll (ca. 10,64 cm) gesetzt.

With Application.MailingLabel.CustomLabels("Laser labels")
    .Height = InchesToPoints(2)
    .HorizontalPitch = InchesToPoints(4.19)
    .NumberAcross = 2
    .NumberDown = 5
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.16)
    .TopMargin = InchesToPoints(0.5)
    .VerticalPitch = InchesToPoints(2)
    .Width = InchesToPoints(4)
End With


HorizontalPosition-Eigenschaft

Frame-Objekt: Gibt den horizontalen Abstand zwischen der Rahmenkante und dem mit der RelativeHorizontalPosition-Eigenschaft angegebenen Element zurück oder legt ihn fest. Dabei kann es sich um eine Zahl, die die Abmessung in Punkt angibt, oder um eine der folgenden WdFramePosition-Konstanten handeln: wdFrameLeft, wdFrameRight, wdFrameCenter, wdFrameInside oder wdFrameOutside. Single Schreib-Lese-Zugriff.

Rows-Objekt: Gibt den horizontalen Abstand zwischen dem Zeilenende und dem durch die RelativeHorizontalPosition-Eigenschaft festgelegten Element zurück oder legt diesen fest. Dabei kann es sich um eine Zahl, die das Maß in Punkt wiedergibt, oder eine der folgenden WdTablePosition-Konstanten handeln: wdTableLeft, wdTableRight, wdTableCenter, wdTableInside oder wdTableOutside. Single Schreib-Lese-Zugriff. Diese Eigenschaft ist ohne Wirkung, wenn WrapAroundText auf False gesetzt ist.


Beispiel zur HorizontalPosition-Eigenschaft

In diesem Beispiel wird der erste Rahmen im aktiven Dokument horizontal zum rechten Rand ausgerichtet.

If ActiveDocument.Frames.Count >= 1 Then
    With ActiveDocument.Frames(1)
        .RelativeHorizontalPosition = _
            wdRelativeHorizontalPositionMargin
        .HorizontalPosition = wdFrameRight
    End With
End If

In diesem Beispiel wird die erste Tabelle im aktiven Dokument horizontal zum rechten Rand ausgerichtet.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1).Rows
        .RelativeHorizontalPosition = _
            wdRelativeHorizontalPositionMargin
        .HorizontalPosition = wdTableRight
    End With
End If


HorizontalResolution-Eigenschaft

Gibt die horizontale Bildschirmauflösung in Pixeln an. Long Nur-Lese-Zugriff.


Beispiel zur HorizontalResolution-Eigenschaft

In diesem Beispiel wird die aktuelle Bildschirmauflösung (z. B. "1024 x 768") angezeigt.

horz = System.HorizontalResolution
vert = System.VerticalResolution
MsgBox "Resolution = " & horz & " x " & vert


HTMLProject-Eigenschaft

Gibt ein HTMLProject-Objekt im angegebenen Dokument zurück. Das HTMLProject stellt eine von oben nach unten gegliederte Projektstruktur dar, wie im Projektexplorer im Microsoft Skript-Editor. Nur-Lese-Zugriff.


Hyperlink-Eigenschaft

Gibt ein Hyperlink-Objekt zurück, das das Hyperlink repräsentiert, das mit dem angegebenen Shape-, InlineShape- oder ShapeRange-Objekt verbunden ist. Nur-Lese-Zugriff.

Hinweis Ist mit der angegebenen Form kein Hyperlink verbunden, tritt ein Fehler auf.


Hyperlinks-Eigenschaft

Gibt eine Hyperlinks-Auflistung zurück, die alle Hyperlinks im angegebenen Dokument, Bereich oder der Markierung darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Hyperlinks-Eigenschaft

In diesem Beispiel wird die Zieladresse des zweiten Hyperlinks in Home.doc angezeigt.

If Documents("Home.doc").Hyperlinks.Count >= 2 Then
    MsgBox Documents("Home.doc").Hyperlinks(2).Name
End If

In diesem Beispiel wird zur Adresse des ersten Hyperlinks in der Markierung gesprungen.

If Selection.Hyperlinks.Count >= 1 Then
    Selection.Hyperlinks(1).Follow
End If

In diesem Beispiel wird der Name jedes Hyperlinks im aktiven Dokument angezeigt, der das Wort "Microsoft" in seiner Adresse enthält.

For Each aHyperlink In ActiveDocument.Hyperlinks
    If InStr(LCase(aHyperlink.Address), "microsoft") <> 0 Then
        MsgBox aHyperlink.Name
    End If
Next aHyperlink


HyphenateCaps-Eigenschaft

True, wenn Wörter in Großbuchstaben getrennt werden können. Boolean Schreib-Lese-Zugriff.


Beispiel zur HyphenateCaps-Eigenschaft

In diesem Beispiel wird die automatische Silbentrennung für das aktive Dokument aktiviert und die Silbentrennung für Wörter in Großbuchstaben ermöglicht.

With ActiveDocument
    .AutoHyphenation = True
    .HyphenateCaps = True
End With


Hyphenation-Eigenschaft

True, wenn die angegebenen Absätze in die automatische Silbentrennung einbezogen werden. False, wenn die angegebenen Absätze von der automatischen Silbentrennung ausgeschlossen werden sollen. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur Hyphenation-Eigenschaft

In diesem Beispiel wird die automatische Silbentrennung für alle Absätze im aktiven Dokument ausgeschaltet, die die Formatvorlage Normal haben.

ActiveDocument.Styles("Normal").ParagraphFormat.Hyphenation = False


HyphenationZone-Eigenschaft

Gibt die Breite der Silbentrennzone in Punkt zurück oder legt sie fest. Die Silbentrennzone ist der maximale Abstand, den Word zwischen dem Ende des letzten Wortes einer Zeile und dem rechten Seitenrand einhält. Long Schreib-Lese-Zugriff.


Beispiel zur HyphenationZone-Eigenschaft

In diesem Beispiel wird die automatische Silbentrennung für MyReport.doc aktiviert. Die Silbentrennzone ist auf 36 Punkt (0,5 Zoll) eingestellt.

With Documents("MyReport.doc")
    .AutoHyphenation = True
    .HyphenationZone = 36
End With

In diesem Beispiel wird die Silbentrennzone auf 0,25 Zoll (18 Punkt) eingestellt und anschließend die manuelle Silbentrennung für das aktive Dokument gestartet.

With ActiveDocument
    .HyphenationZone = InchesToPoints(0.25)
    .ManualHyphenation
End With


IconIndex-Eigenschaft

Gibt das Symbol zurück, das verwendet wird, wenn die DisplayAsIcon-Eigenschaft True ist, oder legt es fest: 0 (Null) entspricht dem ersten Symbol, 1 entspricht dem zweiten Symbol, usw. Lässt man dieses Argument weg, wird (standardmäßig) das erste Symbol verwendet. Long Schreib-Lese-Zugriff.


Beispiel zur IconIndex-Eigenschaft

In diesem Beispiel wird in einem Meldungsfeld die Symbol-Indexnummer für die erste markierte Form zurückgegeben, die als Symbol angezeigt wird.

If Selection.ShapeRange.Count >= 1 Then
    Set myOLEF = Selection.ShapeRange(1).OLEFormat
    With myOLEF
        If .DisplayAsIcon = True Then Msgbox .IconIndex
    End With
End If


IconLabel-Eigenschaft

Gibt den Text, der unter dem Symbol für ein OLE-Objekt angezeigt wird, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur IconLabel-Eigenschaft

In diesem Beispiel wird der Text unter dem Symbol für die erste Form in der Markierung geändert.

If Selection.ShapeRange.Count >= 1 Then
    Set myOLEF = Selection.ShapeRange(1).OLEFormat
    With myOLEF
        .DisplayAsIcon = True
        .IconLabel = "My Icon"
    End With
End If


IconName-Eigenschaft

Gibt die Programmdatei, in der das Symbol für ein OLE-Objekt gespeichert ist, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur IconName-Eigenschaft

In diesem Beispiel wird die erste Form in der Markierung geändert, die als Symbol angezeigt werden soll. Als Text unter dem Symbol wird der Dateiname des Symbols festgelegt.

If Selection.ShapeRange.Count >= 1 Then
    Set myOLEF = Selection.ShapeRange(1).OLEFormat
    With myOLEF
        .DisplayAsIcon = True
        .IconLabel = .IconName
    End With
End If


IconPath-Eigenschaft

Gibt den Pfad der Datei zurück, in der das Symbol für ein OLE-Objekt gespeichert ist. Nur-Lese-Zugriff.


Beispiel zur IconPath-Eigenschaft

In diesem Beispiel wird für jedes bewegliche, eingebettete OLE-Objekt, das im aktiven Dokument als Symbol angezeigt wird, der Pfad angezeigt.

For each s in ActiveDocument.Shapes
    If s.Type = msoEmbeddedOLEObject Then
        If s.OLEFormat.DisplayAsIcon = True Then _
            Msgbox s.OLEFormat.IconPath
    End If
Next s


ID-Eigenschaft

CaptionLabel-Objekt: Wenn die BuiltIn-Eigenschaft des CaptionLabel-Objekts True zurückgibt, gibt ID den Typ für die angegebene Beschriftungskategorie zurück. Dies kann eine der folgenden WdCaptionLabelID-Konstanten sein: wdCaptionEquation, wdCaptionFigure oder wdCaptionTable. Wenn die BuiltIn-Eigenschaft False zurückgibt, gibt ID False zurück. Long Nur-Lese-Zugriff.

Cell, Paragraph, Range, Row oder Table-Objekt: Gibt beim Speichern des Dokuments als Webseite die kennzeichnende Beschriftung für das ausgewählte Objekt zurück oder legt diese fest. String Schreib-Lese-Zugriff. Sie können eine Beschriftung als Hyperlink-Referenz von anderen Webseiten oder auf derselben Webseite verwenden.

Language-Objekt: Gibt eine Nummer zurück, die die angegebene Sprache identifiziert. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden WdLanguageID-Konstanten sein:

wdAfrikaans

wdAlbanian

wdArabic

wdArabicAlgeria

wdArabicBahrain

wdArabicEgypt

wdArabicIraq

wdArabicJordan

wdArabicKuwait

wdArabicLebanon

wdArabicLibya

wdArabicMorocco

wdArabicOman

wdArabicQatar

wdArabicSyria

wdArabicTunisia

wdArabicUAE

wdArabicYemen

wdArmenian

wdAssamese

wdAzeriCyrillic

wdAzeriLatin

wdBasque

wdBelgianDutch

wdBelgianFrench

wdBengali

wdBosniaHerzegovina

wdBrazilianPortuguese

wdBulgarian

wdBurmese

wdByelorussian

wdCatalan

wdChineseHongKong

wdChineseMacao

wdChineseSingapore

wdCroatian

wdCzech

wdDanish

wdDutch

wdEnglishAUS

wdEnglishBelize

wdEnglishCanadian

wdEnglishCaribbean

wdEnglishIreland

wdEnglishJamaica

wdEnglishNewZealand

wdEnglishPhilippines

wdEnglishSouthAfrica

wdEnglishTrinidad

wdEnglishUK

wdEnglishUS

wdEnglishZimbabwe

wdEstonian

wdFaeroese

wdFarsi

wdFinnish

wdFrench

wdFrenchCameroon

wdFrenchCanadian

wdFrenchCotedIvoire

wdFrenchLuxembourg

wdFrenchMali

wdFrenchMonaco

wdFrenchReunion

wdFrenchSenegal

wdFrenchWestIndies

wdFrenchZaire

wdFrisianNetherlands

wdGaelicIreland

wdGaelicScotland

wdGalician

wdGeorgian

wdGerman

wdGermanAustria

wdGermanLiechtenstein

wdGermanLuxembourg

wdGreek

wdGujarati

wdHebrew

wdHindi

wdHungarian

wdIcelandic

wdIndonesian

wdItalian

wdJapanese

wdKannada

wdKashmiri

wdKazakh

 wdKhmer

wdKirghiz

wdKonkani

wdKorean

wdLanguageNone

wdLao

wdLatvian

wdLithuanian

wdLithuanianClassic

wdMacedonian

wdMalayalam

wdMalayBruneiDarussalam

wdMalaysian

wdMaltese

wdManipuri

wdMarathi

wdMexicanSpanish

wdMongolian

wdNepali

wdNoProofing

wdNorwegianBokmol

wdNorwegianNynorsk

wdOriya

wdPolish

wdPortuguese

wdPunjabi

wdRhaetoRomanic

wdRomanian

wdRomanianMoldova

wdRussian

wdRussianMoldova

wdSamiLappish

wdSanskrit

wdSerbianCyrillic

wdSerbianLatin

wdSesotho

wdSimplifiedChinese

wdSindhi

wdSlovak

wdSlovenian

wdSorbian

wdSpanish

wdSpanishArgentina

wdSpanishBolivia

wdSpanishChile

wdSpanishColombia

wdSpanishCostaRica

wdSpanishDominicanRepublic

wdSpanishEcuador

wdSpanishElSalvador

wdSpanishGuatemala

wdSpanishHonduras

wdSpanishModernSort

wdSpanishNicaragua

wdSpanishPanama

wdSpanishParaguay

wdSpanishPeru

wdSpanishPuertoRico

wdSpanishUruguay

wdSpanishVenezuela

wdSutu

wdSwahili

wdSwedish

wdSwedishFinland

wdSwissFrench

wdSwissGerman

wdSwissItalian

wdTajik

wdTamil

wdTatar

wdTelugu

wdThai

wdTibetan

wdTraditionalChinese

wdTsonga

wdTswana

wdTurkish

wdTurkmen

wdUkrainian

wdUrdu

wdUzbekCyrillic

wdUzbekLatin

wdVenda

wdVietnamese

wdWelsh

wdXhosa

wdZulu

Einige der oben aufgelisteten Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der installierten oder ausgewählten Sprachunterstützung ab (beispielsweise Deutsch).


Beispiel zur ID-Eigenschaft

In diesem Beispiel werden die integrierten Beschriftungskategorie-Namen und -ID-Werte angezeigt.

For Each cl In CaptionLabels
    If cl.BuiltIn = True Then MsgBox cl.Name & " " & cl.ID
Next cl

In diesem Beispiel wird die ID der aktuellen Markierung auf "target" festgesetzt. Die Markierung wird als Ziel eines Hyperlinks im selben Dokument festgesetzt, definiert als <A HREF="#target">History</A>.

Selection.Range.ID = "target"

In diesem Beispiel wird die Markierung mit der isländischen Korrekturhilfensprache formatiert.

Selection.LanguageID = Languages("Icelandic").ID


IgnoreInternetAndFileAddresses-Eigenschaft

True, wenn Dateinamenserweiterungen, MS-DOS-Pfade, E-Mail-Adressen, Server- und Freigabenamen (auch UNC-Pfade genannt) und Internet-Adressen (auch URLs genannt) bei der Rechtschreibprüfung ignoriert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IgnoreInternetAndFileAddresses-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Dateinamen und Internet-Adressen ignoriert werden. Dann wird die Rechtschreibung des aktiven Dokuments überprüft.

Options.IgnoreInternetAndFileAddresses = True
ActiveDocument.CheckSpelling

In diesem Beispiel wird der aktuelle Status der Option Internet und Dateiadressen ignorieren auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.IgnoreInternetAndFileAddresses


IgnoreMixedDigits-Eigenschaft

True, wenn Wörter, die Zahlen enthalten, bei der Rechtschreibprüfung ignoriert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IgnoreMixedDigits-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es Wörter ignoriert, die Zahlen enthalten. Anschließend wird die Rechtschreibung im aktiven Dokument geprüft.

Options.IgnoreMixedDigits = True
ActiveDocument.CheckSpelling

In diesem Beispiel wird der aktuelle Status der Option Wörter mit Zahlen ignorieren auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.IgnoreMixedDigits


IgnoreUppercase-Eigenschaft

True, wenn Wörter, die aus lauter Großbuchstaben bestehen, bei der Rechtschreibprüfung ignoriert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IgnoreUppercase-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es Wörter, die aus lauter Großbuchstaben bestehen, ignoriert. Anschließend wird die Rechtschreibung im aktiven Dokument geprüft.

Options.IgnoreUppercase = True
ActiveDocument.CheckSpelling

In diesem Beispiel wird der aktuelle Status der Option Wörter in Großbuchstaben ignorieren auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.IgnoreUppercase


IMEAutomaticControl-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word is set to automatically open and close the Japanese Input Method Editor (IME). Read/write Boolean.


Beispiel zur IMEAutomaticControl-Eigenschaft

This example sets Microsoft Word to automatically open and close the Japanese Input Method Editor (IME).

Options.IMEAutomaticControl = True


IMEMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the default start-up mode for the Japanese Input Method Editor (IME). Read/write Long. Can be one of the following WdIMEMode constants.

Constant | Description
wdIMEModeAlpha | Activates the IME in half-width Latin mode.
wdIMEModeAlphaFull | Activates the IME in full-width Latin mode.
wdIMEModeHangul | Activates the IME in half-width hangul mode.
wdIMEModeHangulFull | Activates the IME in full-width hangul mode.
wdIMEModeHiragana | Activates the IME in full-width hiragana mode.
wdIMEModeKatakana | Activates the IME in full-width katakana mode.
wdIMEModeKatakanaHalf | Activates the IME in half-width katakana mode
wdIMEModeNoControl | Does not change the IME mode.
wdIMEModeOff | Disables the IME and activates Latin text entry.
wdIMEModeOn | Activates the IME.


IncludeCategoryHeader-Eigenschaft

True, wenn der Kategoriename für eine Gruppe von Einträgen (beispielsweise "Cases") im Rechtsgrundlagenverzeichnis angezeigt wird. Entspricht dem Schalter \h in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeCategoryHeader-Eigenschaft

In diesem Beispiel wird festgelegt, dass in allen Rechtsgrundlagenverzeichnissen im aktiven Dokument Kategorienamen angezeigt werden.

For Each TOA In ActiveDocument.TablesOfAuthorities
    TOA.IncludeCategoryHeader = True
Next TOA


IncludeChapterNumber-Eigenschaft

True, wenn eine Kapitelnummer mit Seitennummern oder einer Beschriftungskategorie einbezogen wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeChapterNumber-Eigenschaft

In diesem Beispiel werden im aktiven Dokument in der Fußzeile für Abschnitt eins Seitennummern eingefügt. Die Seitennummern beziehen die Kapitelnummer ein.

With ActiveDocument.Sections(1).Footers _
        (wdHeaderFooterPrimary).PageNumbers
    .Add
    .IncludeChapterNumber = True
    .HeadingLevelForChapter = 1
End With

In diesem Beispiel wird die Kapitelnummer von der Formatvorlage "Überschrift 2" zu Beschriftungen von Abbildungen hinzugefügt und die Formatvorlage für die Nummerierung der Beschriftung festgelegt. Dann wird eine neue Beschriftung für Abbildungen eingefügt. Das Dokument sollte bereits eine Formatvorlage "Überschrift 2" mit Nummerierung enthalten.

With CaptionLabels(wdCaptionFigure)
    .IncludeChapterNumber = True
    .ChapterStyleLevel = 2
    .NumberStyle = wdCaptionNumberStyleUppercaseLetter
End With
Selection.InsertCaption Label:="Figure", Title:=": History"


IncludeFieldCodes-Eigenschaft

True, wenn der aus dem angegebenen Bereich abgerufene Text Feldfunktionen enthält. Boolean Schreib-Lese-Zugriff.

Hinweis Der Standardwert entspricht der Einstellung der Option Feldfunktionen auf der Registerkarte Ansicht im Dialogfeld Optionen (Menü Extras). Dieser Wert ist gültig, bis Sie diese Eigenschaft festlegen. Weisen Sie die Text-Eigenschaft einem Range-Objekt zu, um Text aus dem angegebenen Bereich abzurufen.


Beispiel zur IncludeFieldCodes-Eigenschaft

In diesem Beispiel wird der Text des ersten Absatzes im aktiven Dokument in einem Meldungsfeld angezeigt. Die IncludeFieldCodes-Eigenschaft wird aufgerufen, damit auch Feldfunktionen angezeigt werden.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.TextRetrievalMode.IncludeFieldCodes = False
MsgBox myRange.Text

In diesem Beispiel werden Feldfunktionen und ausgeblendeter Text aus dem Bereich mit einem Bezug auf den markierten Text ausgeschlossen. Dann wird der Text in einem Meldungsfeld angezeigt.

If Selection.Type = wdSelectionNormal Then
    Set myRange = Selection.Range
    With myRange.TextRetrievalMode
        .IncludeHiddenText = False
        .IncludeFieldCodes = False
    End With
    MsgBox myRange.Text
End If


IncludeHeaderFooter-Eigenschaft

True, wenn Kopf- und Fußzeile aus der Vorlage in einen Brief übernommen werden, der vom Brief-Assistenten erstellt wurde. Boolean Schreib-Lese-Zugriff.

Hinweis Mit der PageDesign-Eigenschaft legen Sie den Namen der Vorlage fest, die mit einem Dokument verbunden ist, das der Brief-Assistent erstellt hat.


Beispiel zur IncludeHeaderFooter-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, Kopf- und Fußzeile werden aus der Vorlage "Aktueller Brief" übernommen, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
With myContent
    .PageDesign = "C:\MSOffice\Templates\Letters & " _
        & "Faxes\Contemporary Letter.dot"
    .IncludeHeaderFooter = True
End With
Documents.Add.RunLetterWizard LetterContent:=myContent


IncludeHiddenText-Eigenschaft

True, wenn der aus dem angegebenen Bereich abgerufene Text ausgeblendeten Text enthält. Boolean Schreib-Lese-Zugriff.

Hinweis Der Standardwert entspricht der Einstellung der Option Ausgeblendeter Text auf der Registerkarte Ansicht im Dialogfeld Optionen (Menü Extras). Dieser Wert ist gültig, bis Sie diese Eigenschaft festlegen. Weisen Sie die Text-Eigenschaft einem Range-Objekt zu, um Text aus dem angegebenen Bereich abzurufen.


Beispiel zur IncludeHiddenText-Eigenschaft

In diesem Beispiel wird der Text des ersten Satzes im aktiven Dokument in einem Meldungsfeld angezeigt. Die IncludeHiddenText-Eigenschaft wird aufgerufen, damit auch ausgeblendeter Text angezeigt wird.

Set myRange = ActiveDocument.Sentences(1)
myRange.TextRetrievalMode.IncludeHiddenText = True
MsgBox myRange.Text

In diesem Beispiel wird eine Nachricht versandt, wenn die gesamte Auswahl als ausgeblendeter Text formatiert ist.

If Selection.Type = wdSelectionNormal Then
    Set myRange = Selection.Range
    myRange.TextRetrievalMode.IncludeHiddenText = False
    If myRange.Text = "" Then MsgBox "Selection is hidden"
End If


IncludeLabel-Eigenschaft

True, wenn die Beschriftungskategorie und Beschriftungsnummer in ein Abbildungsverzeichnis aufgenommen werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeLabel-Eigenschaft

In diesem Beispiel wird das erste Abbildungsverzeichnis im aktiven Dokument so formatiert, dass Beschriftungskategorien (beispielsweise Bild 1) nicht in das Verzeichnis aufgenommen werden.

If ActiveDocument.TablesOfFigures.Count >= 1 Then
    ActiveDocument.TablesOfFigures(1).IncludeLabel = False
End If

In diesem Beispiel wird ein Abbildungsverzeichnis an Stelle der Markierung hinzugefügt und dann das Verzeichnis so formatiert, dass Beschriftungskategorien aufgenommen werden.

Set TOF = ActiveDocument.TablesOfFigures _
    .Add(Range:=Selection.Range, _
    Caption:="Figure")
TOF.IncludeLabel = True


IncludePageNumbers-Eigenschaft

True, wenn Seitenzahlen in das Inhaltsverzeichnis oder Abbildungsverzeichnis aufgenommen werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludePageNumbers-Eigenschaft

In diesem Beispiel wird im aktiven Dokument das erste Inhaltsverzeichnis so formatiert, dass rechtsbündige Seitenzahlen aufgenommen werden.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .IncludePageNumbers = True
        .RightAlignPageNumbers = True
    End With
End If


IncludeSequenceName-Eigenschaft

Gibt das Erkennungszeichen des SEQ-Feldes (Reihenfolgefeldes) für ein Rechtsgrundlagenverzeichnis zurück oder legt dieses fest. Entspricht dem Schalter \s in einem TOA-Feld. String Schreib-Lese-Zugriff.


Beispiel für IncludeSequenceName-Eigenschaft

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Rechtsgrundlagenverzeichnis eingefügt und dann festgelegt, dass vor den Seitenzahlen die Feldnummer der Reihenfolge "Chapter" eingefügt wird (beispielsweise "Chapter 2-14").

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
Set myToa = ActiveDocument.TablesOfAuthorities.Add(Range:=myRange)
myToa.IncludeSequenceName = "Chapter"

In diesem Beispiel wird der Name der Reihenfolge für das erste Rechtsgrundlagenverzeichnis zurückgegeben.

seq = ActiveDocument.TablesOfAuthorities(1).IncludeSequenceName


Index-Eigenschaft

Gibt eine Nummer zurück, die die Position eines Elements in einer Auflistung anzeigt. Long Nur-Lese-Zugriff.


Indexes-Eigenschaft

Gibt eine Indexes-Auflistung zurück, die alle Indizes im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Indexes-Eigenschaft

In diesem Beispiel wird am Ende des aktiven Dokuments ein Index hinzugefügt.

Set MyRange = _
    ActiveDocument.Range(Start:=ActiveDocument.Content.End - 1, _
    End:=ActiveDocument.Content.End - 1)
ActiveDocument.Indexes.Add Range:=MyRange, NumberOfColumns:=1, _
    HeadingSeparator:=False

In diesem Beispiel wird ein Indexeintrag für den markierten Text eingefügt.

If Selection.Type = wdSelectionNormal Then
    ActiveDocument.Indexes.MarkEntry Range:=Selection.Range, _
        Entry:=Selection.Range.Text
End If


IndexLanguage-Eigenschaft

Gibt die für den angegebenen Index zu verwendende Sortiersprache zurück oder legt diese fest. Dabei kann es sich um jede gültige WdLanguageID-Konstante handeln. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdLanguageID-Kostanten finden Sie im Objektkatalog im Visual Basic-Editor. Einige der im Objektkatalog aufgeführten Konstanten sind unter Umständen nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung ab (beispielsweise Deutsch).


Beispiel zur IndexLanguage-Eigenschaft

In diesem Beispiel wird die Sortiersprache des ersten Index im aktiven Dokument auf Englisch (Neuseeland) festgelegt.

ActiveDocument.Indexes(1).IndexLanguage = _
    wdEnglishNewZealand


InfoBlock-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Diese Eigenschaft ist möglicherweise nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung ab (beispielsweise Deutsch).


Information-Eigenschaft

Gibt Informationen über die angegebene Markierung oder den Bereich zurück. Variant Nur-Lese-Zugriff.

Syntax

Ausdruck.Information(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range- oder Selection-Objekt zurückgibt.

Type Long erforderlich. Die Informationen, die zurückgegeben werden sollen. Dabei kann es sich um eine der folgenden WdInformation-Konstanten handeln:

  • wdActiveEndAdjustedPageNumber Gibt die Zahl der Seite zurück, die das aktive Ende der angegebenen Markierung oder des Bereichs enthält. Wenn Sie eine Anfangszahl für die Seitenzahlen festlegen oder manuelle Anpassungen vornehmen, wird die angepasste Seitenzahl zurückgegeben (im Gegensatz zu wdActiveEndPageNumber).

  • wdActiveEndPageNumber Gibt die Zahl der Seite zurück, die das aktive Ende der angegebenen Markierung oder des Bereichs enthält, wobei vom Anfang des Dokuments an gezählt wird. Manuelle Anpassungen der Seitenzahlen werden ignoriert (im Gegensatz zu wdActiveEndAdjustedPageNumber).

  • wdActiveEndSectionNumber Gibt die Zahl des Abschnitts zurück, der das aktive Ende der angegebenen Markierung oder des Bereichs enthält.

  • wdAtEndOfRowMarker Gibt True zurück, wenn sich die angegebene Markierung oder der Bereich am Zeilenendezeichen einer Tabelle befindet.

  • wdCapsLock Gibt True zurück, wenn die Feststelltaste aktiviert ist.

  • wdEndOfRangeColumnNumber Gibt die Zahl der Tabellenspalte zurück, die das Ende der angegebenen Markierung oder des Bereichs enthält.

  • wdEndOfRangeRowNumber Gibt die Zahl der Tabellenzeile zurück, die das Ende der angegebenen Markierung oder des Bereichs enthält.

  • wdFirstCharacterColumnNumber Gibt die Position des ersten Zeichens der angegebenen Markierung oder des Bereichs zurück. Wenn die Markierung oder der Bereich ausgeblendet ist, wird umgehend die Zahl des Zeichens rechts von der Markierung oder dem Bereich zurückgegeben. (Dies entspricht der Zahl der Zeichenspalte, die in der Statusleiste hinter "Sp" angezeigt wird.)

  • wdFirstCharacterLineNumber Gibt die Zahl der Zeile des ersten Zeichens der Markierung zurück. Wenn die Pagination-Eigenschaft False ist oder die Draft-Eigenschaft True ist, wird – 1 zurückgegeben.

  • wdFrameIsSelected Gibt True zurück, wenn die Markierung oder der Bereich einen vollständigen Rahmen oder ein vollständiges Textfeld abdeckt.

  • wdHeaderFooterType Gibt einen Wert zurück, der den Typ der Kopf- oder Fußzeile anzeigt, die die angebene Markierung oder den Bereich enthält (siehe folgende Tabelle).
    Wert | Typ der Kopf- oder Fußzeile
    – 1 | None (die Markierung oder der Bereich befindet sich nicht in einer Kopf-/Fußzeile)
    0 (Null) | Kopfzeile auf einer geraden Seite
    1 | Kopfzeile auf einer ungeraden Seite (oder die einzige Kopfzeile, wenn keine geraden und ungeraden Kopfzeilen vorhanden sind)
    2 | Fußzeile auf einer geraden Seite
    3 | Fußzeile auf einer ungeraden Seite (oder die einzige Fußzeile, wenn keine geraden und ungeraden Fußzeilen vorhanden sind)
    4 | Kopfzeile auf der ersten Seite
    5 | Fußzeile auf der ersten Seite

  • wdHorizontalPositionRelativeToPage Gibt die horizontale Position der angegebenen Markierung oder des Bereichs zurück. Dabei handelt es sich um den Abstand zwischen dem linken Rand der Markierung oder des Bereichs und dem linken Rand der Seite in Punkten (1 Punkt = 20 Twips, 72 Punkte = 1 Zoll, ca. 2,54cm). Wenn sich die Markierung bzw. der Bereich nicht im Bildschirmbereich befindet, wird – 1 zurückgegeben.

  • wdHorizontalPositionRelativeToTextBoundary Gibt die horizontale Lage der angegebenen Markierung oder des Bereichs zurück, relativ zum linken Rand des nächsten umgebenden Textrandes gemessen in Punkten (1 Punkt = 20 Twips, 72 Punkte = 1 Zoll (2,54cm). Wenn sich die Markierung oder der Bereich nicht im Bildschirmbereich befindet, wird – 1 zurückgegeben.

  • wdInClipboard Informationen über diese Konstante finden Sie im Sprachenverzeichnis der Microsoft Office 98 Macintosh Edition.

  • wdInCommentPane Gibt True zurück, wenn es sich bei der angegebenen Markierung oder dem Bereich um einen Anmerkungsausschnitt handelt.

  • wdInEndnote Gibt True zurück, wenn die angegebene Markierung oder der Bereich sich in einem Endnotenbereich der Drucklayoutansicht oder im Endnotenausschnitt der Normalansicht befindet.

  • wdInFootnote Gibt True zurück, wenn die angegebene Markierung oder der Bereich sich in einem Fußnotenbereich der Drucklayoutansicht oder im Fußnotenausschnitt der Normalansicht befindet.

  • wdInFootnoteEndnotePane Gibt True zurück, wenn die angegebene Markierung oder der Bereich sich im Fußnoten- oder Endnotenausschnitt der Normalansicht oder in einem Fußnoten- oder Endnotenbereich der Drucklayoutansicht befindet. Weitere Informationen erhalten Sie in der Beschreibung der Konstanten wdInFootnote und wdInEndnote in den vorhergehenden Absätzen.

  • wdInHeaderFooter Gibt True zurück, wenn die Markierung oder der Bereich sich im Kopf- oder Fußzeilenausschnitt befindet oder in einer Kopf- oder Fußzeile der Drucklayoutansicht.

  • wdInMasterDocument Gibt True zurück, wenn die Markierung sich in einem Zentraldokument befindet (d. h., einem Dokument, das mindestens ein Filialdokument enthält).

  • wdInWordMail Gibt einen Wert zurück, der die Position der Markierung oder des Bereichs anzeigt (siehe folgende Tabelle).
    Wert | Position
    0 (Null) | Die Markierung oder der Bereich befindet sich nicht in einer E-Mail-Nachricht.
    1 | Die Markierung bzw. der Bereich befindet sich in einer E-Mail-Nachricht, die Sie versenden.
    2 | Die Markierung bzw. der Bereich befindet sich in einer E-Mail-Nachricht, die Sie lesen.

  • wdMaximumNumberOfColumns Gibt die größte Anzahl an Tabellenspalten in einer beliebigen Zeile in der Markierung oder dem Bereich zurück.

  • wdMaximumNumberOfRows Gibt die größte Anzahl an Tabellenzeilen in der Tabelle in der angegebenen Markierung oder dem Bereich zurück.

  • wdNumberOfPagesInDocument Gibt die Anzahl an Seiten in dem Dokument zurück, das der Markierung oder dem Bereich zugeordnet ist.

  • wdNumLock Gibt True zurück, wenn die NUM-TASTE aktiviert ist.

  • wdOverType Gibt True zurück, wenn der Überschreibmodus aktiviert ist. Die Overtype-Eigenschaft kann zur Änderung des Status des Überschreibmodus verwendet werden.

  • wdReferenceOfType Gibt einen Wert zurück, der anzeigt, wo sich die Markierung im Verhältnis zu einem Fußnoten-, Endnoten- oder Kommentarzeichen befindet (siehe folgende Tabelle).
    Wert | Beschreibung
    – 1 | Die Markierung oder der Bereich beinhaltet unter anderem ein Fußnoten-, Endnoten- oder Kommentarzeichen.
    0 (Null) | Die Markierung oder der Bereich befindet sich nicht vor einem Fußnoten-, Endnoten- oder Kommentarzeichen.
    1 | Die Markierung oder der Bereich befindet sich vor einem Fußnotenzeichen.
    2 | Die Markierung oder der Bereich befindet sich vor einem Endnotenzeichen.
    3 | Die Markierung oder der Bereich befindet sich vor einem Kommentarzeichen.

  • wdRevisionMarking Gibt True zurück, wenn das Verfolgen von Änderungen aktiviert ist.

  • wdSelectionMode Gibt einen Wert zurück, der den aktuellen Markierungsmodus anzeigt (siehe folgende Tabelle).
    Wert | Markierungsmodus
    0 (Null) | Normale Markierung
    1 | Erweiterte Markierung (in der Statusleiste wird "ERW" angezeigt)
    2 | Spaltenmarkierung (in der Statusleiste wird "SP" angezeigt)

  • wdStartOfRangeColumnNumber Gibt die Zahl der Tabellenspalte zurück, die den Anfang der Markierung oder des Bereichs enthält.

  • wdStartOfRangeRowNumber Gibt die Zahl der Tabellenzeile zurück, die den Anfang der Markierung oder des Bereichs enthält.

  • wdVerticalPositionRelativeToPage Gibt die vertikale Position der Markierung oder des Bereichs zurück. Diese ergibt sich aus dem Abstand zwischen dem oberen Rand der Markierung und dem oberen Rand der Seite und wird in Punkten gemessen (1 Punkt = 20 Twips, 72 Punkte = 1 Zoll, ca. 2,54cm). Wenn die Markierung nicht im Dokumentenfenster sichtbar ist, wird – 1 zurückgegeben.

  • wdVerticalPositionRelativeToTextBoundary Gibt die vertikale Position der Markierung bzw. des Bereichs zurück. Diese ergibt sich relativ zum oberen Rand des nächsten umgebenden Textrandes und wird in Punkten gemessen (1 Punkt = 20 Twips, 72 Punkte= 1 Zoll, ca. 2,54cm). Dies ist nützlich für die Bestimmung der Position der Einfügestelle innerhalb eines Rahmens oder einer Tabellenzelle. Wenn die Markierung nicht sichtbar ist, wird – 1 zurückgegeben.

  • wdWithInTable Gibt True zurück, wenn sich die Markierung in einer Tabelle befindet.

  • wdZoomPercentage Gibt die Prozentangabe der aktuellen Zoomstufe zurück, wie durch die Percentage-Eigenschaft festgelegt.


Beispiel zur Information-Eigenschaft

In diesem Beispiel werden die aktuelle Seitenzahl und die Gesamtzahl der Seiten im aktiven Dokument angezeigt.

MsgBox "The selection is on page " & _
    Selection.Information(wdActiveEndPageNumber) & " of page " _
    & Selection.Information(wdNumberOfPagesInDocument)

Wenn die Markierung innerhalb einer Tabelle ist, wird in in diesem Beispiel die Tabelle markiert.

If Selection.Information(wdWithInTable) Then _
    Selection.Tables(1).Select

In diesem Beispiel wird eine Meldung angezeigt, die die aktuelle Abschnittsnummer angibt.

Selection.Collapse Direction:=wdCollapseStart
MsgBox "The insertion point is in section " & _
    Selection.Information(wdActiveEndSectionNumber)


Initial-Eigenschaft

Gibt die Initialen des mit einem bestimmten Kommentar verbundenen Benutzers zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur Initial-Eigenschaft

Dieses Beispiel zeigt die Initialen des Benutzers an, der den ersten Kommentar in der Markierung erstellt hat.

If Selection.Comments.Count >= 1 Then
    MsgBox "Comment made by " & Selection.Comments(1).Initial
End If

Dieses Beispiel überprüft die mit den einzelnen Kommentaren im ersten Dokumentabschnitt verbundenen Autoreninitialen. Lauten die Autoreninitialen "MSOffice", werden sie im Beispiel zu "KAE" geändert.

Set myRange = ActiveDocument.Sections(1).Range
For Each comm In myRange.Comments
    If comm.Initial = "MSOffice" Then comm.Initial = "KAE"
Next comm


InlineConversion-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word displays an unconfirmed character string in the Japanese Input Method Editor (IME) as an insertion between existing (confirmed) character strings. Read/write Boolean.


Beispiel zur InlineConversion-Eigenschaft

This example sets Microsoft Word to display an unconfirmed character string in the Japanese Input Method Editor (IME) as an insertion between existing (confirmed) character strings.

Options.InlineConversion = True


InlineShape-Eigenschaft

Gibt ein InlineShape-Objekt zurück, das das Bild, das OLE-Objekt oder das ActiveX-Steuerelement repräsentiert und das Ergebnis eines INCLUDEPICTURE- oder EMBED-Felds ist. Nur-Lese-Zugriff.

Anmerkungen

Ein InlineShape-Objekt wird wie ein Zeichen behandelt und innerhalb einer Textzeile positioniert.


InlineShapes-Eigenschaft

Gibt eine InlineShapes-Auflistung zurück, die alle InlineShape-Objekte in einem Dokument, einem Bereich oder in der Auswahl repräsentiert. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur InlineShapes-Eigenschaft

In diesem Beispiel wird die Anzahl der Formen und der eingebetteten Formen im aktiven Dokument angezeigt.

Set doc = ActiveDocument
Msgbox "InlineShape = " & doc.InlineShapes.Count & _
    vbCr & "Shapes = " & doc.Shapes.Count


InsertedTextColor-Eigenschaft

Gibt die Farbe von Text, der eingefügt wurde, während die Änderungsverfolgung aktiv ist, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdByAuthor

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Anmerkungen

Wurde die InsertedTextColor-Eigenschaft auf wdByAuthor gesetzt, dann weist Word automatisch eine eindeutige Farbe den ersten acht Autoren zu, die ein Dokument überarbeiten.


Beispiel zur InsertedTextColor-Eigenschaft

In diesem Beispiel wird als Farbe für eingefügten Text Dunkelrot zugewiesen.

Options.InsertedTextColor = wdDarkRed

In diesem Beispiel wird der aktuelle Status der Option Farbe unter Eingefügter Text auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.InsertedTextColor


InsertedTextMark-Eigenschaft

Gibt das Format des Textes, der eingefügt wurde, während die Änderungsverfolgung aktiv ist, zurück oder legt es fest. Dabei kann es sich um eine der folgenden WdInsertedTextMark-Konstanten handeln: wdInsertedTextMarkNone, wdInsertedTextMarkBold, wdInsertedTextMarkDoublelUnderline, wdInsertedTextMarkItalic oder wdInsertedTextMarkUnderline. Long Schreib-Lese-Zugriff.


Beispiel zur InsertedTextMark-Eigenschaft

In diesem Beispiel wird "Doppelt unterstrichen" auf eingefügten Text angewendet.

Options.InsertedTextMark = wdInsertedTextMarkDoubleUnderline

In diesem Beispiel wird der aktuelle Status der Option Markierung unter Eingefügter Text auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.InsertedTextMark


Inside-Eigenschaft

True, wenn das angegebene Objekt mit einem Innenrahmen versehen werden kann. Boolean Nur-Lese-Zugriff.


InsideColor-Eigenschaft

Gibt die 24-Bit-Farbe der inneren Rahmenlinien zurück oder legt diese fest. Dabei kann es sich um eine beliebige WdColor-Konstante oder ein durch die RGB-Funktion zurückgegebenen Wert handeln. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog im Visual Basic-Editor.

Wenn die InsideLineStyle-Eigenschaft entweder auf wdLineStyleNone oder auf False gesetzt ist, hat das Setzen dieser Eigenschaft keine Auswirkungen.


InsideColorIndex-Eigenschaft

Gibt die Farbe der Rahmenlinie innen zurück oder legt sie fest. Dies kann eine der folgenden WdColorIndex-Konstanten sein: wdAuto, wdBlack, wdBlue, wdBrightGreen, wdDarkBlue, wdDarkRed, wdDarkYellow, wdGray25, wdGray50, wdGreen, wdPink, wdRed, wdTeal, wdTurquoise, wdViolet, wdWhite oder wdYellow. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die InsideLineStyle-Eigenschaft entweder auf wdLineStyleNone oder auf False festgelegt ist, hat das Festlegen dieser Eigenschaft keine Auswirkungen.


Beispiel zur InsideColorIndex-Eigenschaft

In diesem Beispiel werden in der ersten Tabelle im aktiven Dokument Rahmen zwischen den Zeilen und Spalten hinzugefügt und dann die Farben für die Rahmenlinien innen und außen festgelegt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    With myTable.Borders
        .InsideLineStyle = True
        .InsideColorIndex = wdBrightGreen
        .OutsideColorIndex = wdPink
    End With
End If

In diesem Beispiel werden rote Rahmenlinien zwischen den ersten vier Absätzen im aktiven Dokument hinzugefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(1).Range.Start, _
    End:=myDoc.Paragraphs(4).Range.End)
With myRange.Borders
    .InsideLineStyle = wdLineStyleSingle
    .InsideLineWidth = wdLineWidth150pt
    .InsideColorIndex = wdRed
End With


InsideLineStyle-Eigenschaft

Gibt die innere Umrahmung des angegebenen Objekts zurück oder legt sie fest. Gibt wdUndefined zurück, wenn mehr als eine Umrahmungsart auf das angegebene Objekt angewendet wurde. Sonst wird False oder eine WdLineStyle-Konstante zurückgegeben. Kann auf True, False oder eine WdLineStyle-Konstante gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweise

True wählt als Linienart die Standardlinienart und als Linienstärke die Standardlinienstärke. Die Standardlinienart und die Standardlinienstärke legen Sie mit der DefaultBorderLineWidth-Eigenschaft und der DefaultBorderLineStyle-Eigenschaft fest.

Mit jeder der folgenden Anweisungen entfernen Sie die innere Umrahmung von der ersten Tabelle im aktiven Dokument.

ActiveDocument.Tables(1).Borders.InsideLineStyle = wdLineStyleNone
ActiveDocument.Tables(1).Borders.InsideLineStyle = False


Beispiel zur InsideLineStyle-Eigenschaft

In diesem Beispiel werden Ränder zwischen Zeilen und zwischen Spalten in der ersten Tabelle im aktiven Dokument hinzugefügt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    myTable.Borders.InsideLineStyle = True
End If

In diesem Beispiel werden Ränder zwischen den ersten vier Absätzen im Dokument eingefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(1).Range.Start, _
    End:=myDoc.Paragraphs(4).Range.End)
With myRange.Borders
    .InsideLineStyle = wdLineStyleSingle
    .InsideLineWidth = wdLineWidth150pt
End With


InsideLineWidth-Eigenschaft

Gibt die Liniensträrke des Innenrahmens eines Objekts zurück oder legt sie fest. Gibt wdUndefined zurück, wenn das Objekt einen Innenrahmen mit mehr als einer Linienstärke hat. Sonst werden False oder eine WdLineWidth-Konstante zurückgegeben. Sie kann auf True, False oder eine der folgenden WdLineWidth-Konstanten gesetzt werden: wdLineWidth025pt, wdLineWidth050pt, wdLineWidth075pt, wdLineWidth100pt, wdLineWidth150pt, wdLineWidth225pt, wdLineWidth300pt, wdLineWidth450pt oder wdLineWidth600pt. Long Schreib-Lese-Zugriff.


Beispiel zur InsideLineWidth-Eigenschaft

In diesem Beispiel werden Ränder zwischen Zeilen und zwischen Spalten der ersten Tabelle im aktiven Dokument hinzugefügt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    myTable.Borders.InsideLineStyle = wdLineStyleDot
    myTable.Borders.InsideLineWidth = wdLineWidth050pt
End If

In diesem Beispiel wird ein gepunkteter Rahmen zwischen den ersten vier Absätzen im aktiven Dokument hinzugefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(1).Range.Start, _
    End:=myDoc.Paragraphs(4).Range.End)
myRange.Borders.InsideLineStyle = wdLineStyleDot
myRange.Borders.InsideLineWidth = wdLineWidth075pt


INSKeyForPaste-Eigenschaft

True, wenn Sie mit Hilfe der EINFG-TASTE den Inhalt der Zwischenablage kopieren können. Boolean Schreib-Lese-Zugriff.


Beispiel zur INSKeyForPaste-Eigenschaft

In diesem Beispiel wird die Taste EINFG aktiviert, um den Inhalt der Zwischenablage einzufügen.

Options.INSKeyForPaste = True

In diesem Beispiel wird der Status der Option Zum Einfügen EINFG-TASTE benutzen auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.INSKeyForPaste


Installed-Eigenschaft

True, wenn das angegebene Add-In installiert (geladen) wurde. Geladene Add-Ins werden im Dialogfeld Vorlagen und Add-Ins (Menü Extras) gewählt. Boolean Schreib-Lese-Zugriff.

Hinweis Nicht installierte Add-Ins werden in der AddIns-Auflistung aufgeführt. Um eine Dokumentvorlage oder eine WLL aus der AddIns-Auflistung zu entfernen, wenden Sie die Delete-Methode auf das AddIn-Objekt an. (Der Add-In-Name wird aus dem Dialogfeld Vorlagen und Add-Ins entfernt). Um alle Dokumentvorlagen und WLLs aus dem Speicher zu entfernen, wenden Sie die Unload-Methode auf die AddIns-Auflistung an.


Beispiel zur Installed-Eigenschaft

In diesem Beispiel wird die globale Dokumentvorlage "gallery.dot" aus dem Speicher entfernt.

Addins("Gallery.dot").Installed = False

In diesem Beispiel wird AlleFinden.wll geladen.

Addins("C:\Templates\FindAll.wll").Installed = True

In diesem Beispiel wird Eigen.dot geladen.

AddIns("C:\Program Files\Microsoft Office\" _
    & "Templates\Custom.dot").Installed = True

In diesem Beispiel wird in der Statusleiste eine Meldung angezeigt, wenn Dot1.dot als globale Dokumentvorlage geladen wurde.

If AddIns("Dot1.dot").Installed = True Then _
    StatusBar = "Dot1.dot is loaded"


International-Eigenschaft

Gibt Informationen zu den aktuellen länderspezifischen und internationalen Einstellungen zurück. Variant Nur-Lese-Zugriff.

Syntax

Ausdruck.International(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Long erforderlich. Gibt ein einzelnes zurückzugebendes Element an. Dies kann eine der folgenden WdInternationalIndex-Konstanten sein.

Konstante | Beschreibung
wd24HourClock | Gibt True bei 24-Stunden-Zeitangabe und False bei 12-Stunden-Zeitangabe zurück.
wdCurrencyCode | Gibt das Währungssymbol zurück (DM in Deutsch).
wdDateSeparator | Gibt das Datumstrennzeichen zurück (. in Deutsch).
wdDecimalSeparator | Gibt das Dezimaltrennzeichen zurück (, in Deutsch).
wdInternationalAM | Gibt die für die Angabe der Uhrzeit vor 12 Uhr verwendete Zeichenfolge zurück (im Englischen z. B. 10 AM).
wdInternationalPM | Gibt die für die Angabe der Uhrzeit nach 12 Uhr verwendete Zeichenfolge zurück (im Englischen z. B. 2 PM).
wdListSeparator | Gibt das Listentrennzeichen zurück (; in Deutsch).
wdProductLanguageID | Gibt die Sprachversion von Word zurück.
wdThousandsSeparator | Gibt das Tausender-Trennzeichen zurück (. in Deutsch).
wdTimeSeparator | Gibt das Zeittrennzeichen zurück (: in Deutsch).


Beispiel zur International-Eigenschaft

In diesem Beispiel wird das Währungsformat in der Statusleiste angezeigt.

StatusBar = "Currency Format: " _
    & Application.International(wdCurrencyCode)


InterpretHighAnsi-Eigenschaft

Gibt zurück oder stellt ein, wie Microsoft Word Text interpretiert, der Zeichen mit Zeichencodes von 128 bis 255 (oberer ANSI-Bereich) enthält. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdHighAnsiText-Konstanten handeln.

Konstante | Beschreibung
wdAutoDetectHighAnsiFarEast | Word interpretiert nur dann Text im oberen ANSI-Bereich als ostasiatische Zeichen, wenn Word Text in ostasiatischen Sprachen automatisch erkennt.
wdHighAnsiIsFarEast | Word interpretiert allen Text im oberen ANSI-Bereich als ostasiatische Zeichen.
wdHighAnsiIsHighAnsi | Word interpretiert keinen Text im oberen ANSI-Bereich als ostasiatische Zeichen.

Hinweise

Weitere Informationen über die Verwendung von Word mit ostasiatischen Sprachen finden Sie unter Word-Funktionen für ostasiatische Sprachen.


Beispiel zur InterpretHighAnsi-Eigenschaft

In diesem Beispiel wird Microsoft Word so eingestellt, dass aller Text im oberen ANSI-Bereich als ostasiatische Zeichen interpretiert wird.

Options.InterpretHighAnsi = wdHighAnsiIsFarEast


InUse-Eigenschaft

True, wenn es sich bei der angegebenen Formatvorlage um eine integrierte handelt, die modifiziert oder im Dokument zugewiesen wurde oder wenn dies eine neue Formatvorlage ist, die im Dokument erstellt wurde. Boolean Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft gibt nicht an, ob zurzeit Text mit dieser Formatvorlage im Dokument vorhanden ist. Die InUse-Eigenschaft der Formatvorlage bleibt auf True gesetzt, wenn der Text gelöscht wird, der mit der Formatvorlage formatiert wurde. Bei integrierten Formatvorlagen, die niemals im Dokument verwendet wurden, gibt diese Eigenschaft False zurück.


Beispiel zur InUse-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit den Namen aller Formatvorlagen angezeigt, die zurzeit im aktiven Dokument benutzt werden.

Set mydoc = ActiveDocument
msg = "Styles in use:" & vbCr
For Each sty In mydoc.Styles
    If sty.InUse = True Then
        With mydoc.Content.find
            .ClearFormatting
            .Text = ""
            .Style = sty
            .Execute Format:=True
            If .Found = True Then
               msg = msg & sty & vbCr
            End If
        End With
    End If
Next sty
MsgBox msg


IPAtEndOfLine-Eigenschaft

True, wenn sich die Einfügemarke am Ende einer Zeile befindet, die in der nächsten Zeile umbrochen wird. False, wenn die Auswahl nicht reduziert ist, wenn sich die Einfügemarke nicht am Ende einer Zeile oder wenn sich die Einfügemarke vor einer Absatzmarke befindet. Boolean Nur-Lese-Zugriff.


Beispiel zur IPAtEndOfLine-Eigenschaft

Wenn sich die Einfügemarke nicht am Ende der Zeile befindet, wird sie in diesem Beispiel dorthin bewegt.

Selection.Collapse Direction:=wdCollapseEnd
If Selection.IPAtEndOfLine = False Then
    Selection.EndKey Unit:=wdLine, Extend:=wdMove
End If


IsEndOfRowMark-Eigenschaft

True, wenn die angegebene Auswahl oder der Bereich reduziert ist und sich an der Zeilenendemarke in einer Tabelle befindet. Boolean Nur-Lese-Zugriff.

Hinweis Diese Eigenschaft entspricht dem folgenden Ausdruck:

Selection.Information(wdAtEndOfRowMarker)


Beispiel zur IsEndOfRowMark-Eigenschaft

In diesem Beispiel wird die Auswahl reduziert und die aktuelle Zeile gewählt, wenn sich die Einfügemarke am Ende der Zeile befindet (direkt vor der Zeilenendemarkierung).

Selection.Collapse Direction:=wdCollapseEnd
If Selection.IsEndOfRowMark = True Then
    Selection.Rows(1).Select
End If


IsFirst-Eigenschaft

True, wenn die angegebene Spalte oder Zeile die erste in der Tabelle ist. Boolean Nur-Lese-Zugriff.


Beispiel zur IsFirst-Eigenschaft

In diesem Beispiel wird ermittelt, ob die erste Zeile in der Markierung die erste Zeile in der Tabelle ist.

MsgBox Selection.Rows(1).IsFirst


IsHeader-Eigenschaft

True, wenn das angegebene HeaderFooter-Objekt eine Kopfzeile ist. Boolean Nur-Lese-Zugriff.


Beispiel zur IsHeader-Eigenschaft

In diesem Beispiel wird die Fußzeile markiert und eine Seitenzahl hinzugefügt.

With ActiveDocument.ActiveWindow.ActivePane.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageHeader
End With
If Selection.HeaderFooter.IsHeader = True Then
    ActiveDocument.ActiveWindow.ActivePane.View _
        .SeekView = wdSeekCurrentPageFooter
End If
Selection.HeaderFooter.PageNumbers.Add


IsLast-Eigenschaft

True, wenn die angegebene Spalte oder Zeile die letzte in der Tabelle ist. Boolean Nur-Lese-Zugriff.


Beispiel zur IsLast-Eigenschaft

In diesem Beispiel wird ermittelt, ob die zweite Zeile die letzte Zeile in der Tabelle ist.

MsgBox ActiveDocument.Tables(1).Rows(2).IsLast

In diesem Beispiel wird ermittelt, ob die erste Spalte in der Markierung die letzte Spalte in der Tabelle ist.

If Selection.Information(wdWithInTable) = True Then
    MsgBox Selection.Columns(1).IsLast
End If


IsMasterDocument-Eigenschaft

True, wenn es sich beim angegebenen Dokument um ein Zentraldokument handelt. Ein Zentraldokument enthält ein oder mehrere Filialdokumente. Boolean Nur-Lese-Zugriff.


Beispiel zur IsMasterDocument-Eigenschaft

Wenn es sich beim aktiven Dokument um ein Zentraldokument handelt, wechselt dieses Beispiel in die Zentraldokumentansicht und das erste Filialdokument wird geöffnet.

If ActiveDocument.IsMasterDocument = True Then
    ActiveDocument.ActiveWindow.View.Type = wdMasterView
    ActiveDocument.Subdocuments(1).Open
Else
    MsgBox "This document is not a master document."
End If


IsObjectValid-Eigenschaft

True, wenn die angegebene Variable gültig ist, die auf ein Objekt Bezug nimmt. False, wenn das Objekt gelöscht wurde, auf das sich die Variable bezieht. Boolean Nur-Lese-Zugriff.

Syntax

Ausdruck.IsObjectValid(Object)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Object Object erforderlich. Eine Variable, die auf ein Objekt Bezug nimmt.


Beispiel zur IsObjectValid-Eigenschaft

In diesem Beispiel wird eine Tabelle dem aktiven Dokument hinzugefügt, und sie wird der Variablen aTable zugewiesen. Anschließend löscht das Beispiel die erste Tabelle im Dokument. Wenn die Tabelle, auf die sich aTable bezieht, nicht die erste Tabelle im Dokument war (d. h. aTable ist immer noch ein gültiges Objekt), werden alle Rahmen in dieser Tabelle entfernt.

Set aTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=2, NumColumns:=3)
ActiveDocument.Tables(1).Delete
If IsObjectValid(aTable) = True Then aTable.Borders.Enable = False


IsSubdocument-Eigenschaft

True, wenn das angegebene Dokument in einem eigenen Dokumentfenster als Filialdokument eines Zentraldokuments geöffnet wird. Boolean Nur-Lese-Zugriff.


Beispiel zur IsSubdocument-Eigenschaft

Dieses Beispiel stellt fest, ob Verkäufe.doc ein Filialdokument ist, anschließend wird eine Meldung mit dem Dokumentstatus angezeigt.

If Documents("Sales.doc").IsSubdocument = True Then
    MsgBox "Sales.doc is a subdocument."
Else
    MsgBox "Sales.doc is not a subdocument."
End If


Italic-Eigenschaft

True, wenn Schriftart oder Bereich kursiv formatiert sind. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.


ItalicBi-Eigenschaft

Sprachspezifische Informationen

True if the font or range is formatted as italic. Returns True, False or wdUndefined (for a mixture of italic and non-italic text). Can be set to True, False, or wdToggle. Read/write Long.

Remarks

The ItalicBi property applies to text in a right-to-left language.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ItalicBi-Eigenschaft

This example makes the first paragraph in the active right-to-left language document italic.

ActiveDocument.Paragraphs(1).Range.ItalicBi = True


Item-Eigenschaft

Gibt den Anpassungswert, der durch das Argument Index spezifiziert wird, zurück oder legt ihn fest. Bei linearen Anpassungen entspricht ein Anpassungswert von 0,0 allgemein der linken oder oberen Kante der Form, und ein Wert von 1,0 entspricht allgemein der rechten oder unteren Kante der Form. Anpassungen können aber für manche Formen über die Begrenzungen der Form hinausgehen. Bei radialen Anpassungen entspricht ein Anpassungswert von 1,0 der Breite der Form. Bei Winkelanpassungen wird der Anpassungswert in Grad angegeben. Die Item-Eigenschaft wird nur Formen zugewiesen, die Anpassungen haben. Single Schreib-Lese-Zugriff.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Adjustments-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer der Anpassung.

Hinweise

AutoForm- und WordArt-Objekte haben bis zu acht Anpassungen.


Beispiel zur Item-Eigenschaft

In diesem Beispiel werden zu myDocument zwei Kreuze hinzugefügt, und dann wird der Wert für die Anpassung eins (die einzige auf diesem AutoForm-Typ) auf jedem Kreuz festgelegt.

Set myDocument = Documents(1)
With myDocument.Shapes
    .AddShape(msoShapeCross, _
        10, 10, 100, 100).Adjustments.Item(1) = 0.4
    .AddShape(msoShapeCross, _
        150, 10, 100, 100).Adjustments.Item(1) = 0.2
End With

In diesem Beispiel wird dasselbe Ergebnis erzielt wie im vorherigen Beispiel, auch wenn es nicht explizit die Item-Eigenschaft verwendet.

Set myDocument = Documents(1)
With myDocument.Shapes
    .AddShape(msoShapeCross, _
        10, 10, 100, 100).Adjustments(1) = 0.4
    .AddShape(msoShapeCross, _
        150, 10, 100, 100).Adjustments(1) = 0.2
End With


JoinBorders-Eigenschaft

True, wenn vertikale Rahmen an den Rändern von Absätzen und Tabellen entfernt werden, um horizontale Rahmen mit dem Seitenrahmen verbinden zu können. Boolean Schreib-Lese-Zugriff.


Beispiel zur JoinBorders-Eigenschaft

In diesem Beispiel wird ein Rahmen um alle Seiten im ersten Abschnitt der Auswahl hinzugefügt. Das Beispiel entfernt außerdem die horizontalen Rahmen an den Rändern von Tabellen und Absätzen und verbindet dadurch die horizontalen Rahmen mit den Seitenrahmen.

With Selection.Sections(1)
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtBalloonsHotAir
        aBord.ArtWidth = 15
    Next aBord
    With .Borders
        .DistanceFromLeft = 2
        .DistanceFromRight = 2
        .DistanceFrom = wdBorderDistanceFromText
        .JoinBorders = True
    End With
End With


JustificationMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the character spacing adjustment for the specified document. Can be one of the following WdJustificationMode constants: wdJustificationModeCompress, wdJustificationModeCompressKana, or wdJustificationModeExpand. Read/write Long.


Beispiel zur JustificationMode-Eigenschaft

This example sets Microsoft Word to compress only punctuation marks when adjusting character spacing.

ActiveDocument.JustificationMode = wdJustificationModeCompressKana


Kana-Eigenschaft

Sprachspezifische Informationen

Returns or sets whether the specified range of Japanese language text is hiragana or katakana. Can be either of the following WdKana constants: wdKanaHiragana or wdKanaKatakana. Can also be wdUndefined if the range contains a mix of hiragana and katakana or if the range contains some non-Japanese text. Read/write Long.

Remarks

If you set the Kana property to wdUndefined, an error occurs.

For more information on editing Japanese text in Microsoft Word, see Editing tools for Japanese text.


Beispiel zur Kana-Eigenschaft

This example displays what type of Japanese text the current selection contains.

Select Case Selection.Range.Kana
    Case wdKanaHiragana
        MsgBox "This text is hiragana."
    Case wdKanaKatakana
        MsgBox "This text is katakana."
    Case wdUndefined
        MsgBox "This text is neither solely " _
            & "hiragana nor katakana."
End Select


KeepEntryFormatting-Eigenschaft

True, wenn die Formatierung der Einträge für das Rechtsgrundlagenverzeichnis auf die Einträge im angegebenen Verzeichnis selbst übertragen wird. Entspricht dem Schalter \f in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Boolean Schreib-Lese-Zugriff.


Beispiel zur KeepEntryFormatting-Eigenschaft

In diesem Beispiel werden die Formatierungen der Einträge im ersten Rechtsgrundlagenverzeichnis des aktiven Dokuments entfernt (den TOA-Feldern wird der Schalter \f hinzugefügt).

If ActiveDocument.TablesOfAuthorities.Count >= 1 Then
    ActiveDocument.TablesOfAuthorities(1) _
        .KeepEntryFormatting = False
End If


KeepTogether-Eigenschaft

True, falls alle Zeilen in den angegebenen Absätzen auf derselben Seite bleiben, wenn Word die Seiten des Dokuments neu umbricht. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur KeepTogether-Eigenschaft

In diesem Beispiel werden die Absätze im aktiven Dokument so formatiert, dass in jedem Absatz alle Zeilen auf derselben Seite sind, wenn Word die Seiten des Dokuments neu umbricht.

ActiveDocument.Paragraphs.KeepTogether = True


KeepWithNext-Eigenschaft

True, falls der angegebene Absatz auf derselben Seite bleibt wie der nachfolgende Absatz, wenn Word die Seiten des Dokuments neu umbricht. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur KeepWithNext-Eigenschaft

In diesem Beispiel bleiben der dritte bis sechste Absatz im aktiven Dokument auf derselben Seite .

For i = 3 To 5
    ActiveDocument.Paragraphs(i).KeepWithNext = True
Next i


KernedPairs-Eigenschaft

True, wenn Zeichenpaare im angegebenen WordArt-Objekt unterschnitten sind. Long Schreib-Lese-Zugriff.


Beispiel zur KernedPairs-Eigenschaft

In diesem Beispiel wird für Form drei in myDocument die Zeichenpaar-Unterschneidung eingeschaltet, wenn die Form ein WordArt-Objekt ist.

Set myDocument = ActiveDocument
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.KernedPairs =True
    End If
End With


Kerning-Eigenschaft

Gibt den kleinsten Schriftgrad an, für den Word Kerning automatisch anpasst, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


KerningByAlgorithm-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word kerns half-width Latin characters and punctuation marks in the specified document. Read/write Boolean.


Beispiel zur KerningByAlgorithm-Eigenschaft

This example sets Microsoft Word to kern half-width Latin characters and punctuation marks in the active document.

ActiveDocument.KerningByAlgorithm = True


KeyBindings-Eigenschaft

Gibt eine KeyBindings-Auflistung zurück, die benutzerdefinierte Tastenzuordnungen darstellt, die aus einem Tastencode, einer Tastenkategorie und einem Befehl bestehen. Nur-Lese-Zugriff.


Beispiel zur KeyBindings-Eigenschaft

In diesem Beispiel wird die Tastenkombination STRG+ALT+W dem Befehl DateiSchließen zugewiesen. Die Tastenzuordnung wird in der Dokumentvorlage "Normal" gespeichert.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, _
    wdKeyW), KeyCategory:=wdKeyCategoryCommand, _
    Command:="FileClose"

In diesem Beispiel wird der Befehlsname und die Zeichenfolge der Tastenkombination für jedes Element in der KeyBindings-Auflistung eingefügt.

CustomizationContext = NormalTemplate
For Each aKey In KeyBindings
    Selection.InsertAfter aKey.Command & vbTab _
        & aKey.KeyString & vbCr
    Selection.Collapse Direction:=wdCollapseEnd
Next aKey


KeyCategory-Eigenschaft

Gibt den Elementtyp zurück, der einer bestimmten Tastenkombination zugewiesen wurde. Long Nur-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdKeyCategory-Konstanten handeln:

wdKeyCategoryAutoText

wdKeyCategoryCommand

wdKeyCategoryDisable

wdKeyCategoryFont

wdKeyCategoryMacro

 wdKeyCategoryNil

wdKeyCategoryPrefix

wdKeyCategoryStyle

wdKeyCategorySymbol


Beispiel zur KeyCategory-Eigenschaft

In diesem Beispiel werden die Tasten angezeigt, die Schriftartennamen zugewiesen wurden. Eine Meldung erscheint, wenn keiner Taste Schriftarten zugewiesen wurden.

For Each aKey In KeyBindings
    If aKey.KeyCategory = wdKeyCategoryFont Then
        Count = Count + 1
        MsgBox aKey.Command & vbCr & aKey.KeyString
    End If
Next aKey
If Count = 0 Then MsgBox "Keys haven't been assigned to fonts"


KeyCode-Eigenschaft

Liefert eine eindeutige Nummer für die erste Taste in der angegebenen Tastenkombination. Long Nur-Lese-Zugriff.

Hinweis Diese Nummer wird mit der BuildKeyCode-Methode erzeugt, wenn Sie Tastenkombinationen mit der Add-Methode des KeyBindings-Objekts hinzufügen.


KeyCode2-Eigenschaft

Liefert eine eindeutige Nummer für die zweite Taste in der angegebenen Tastenkombination. Long Nur-Lese-Zugriff.


Beispiel zur KeyCode2-Eigenschaft

In diesem Beispiel werden die Tastencodes für alle Tasten in der KeyBindings-Auflistung (die Auflistung aller benutzerdefinierten Tasten im aktiven Dokument) angezeigt.

CustomizationContext = ActiveDocument
For Each aKey In KeyBindings
    If aKey.KeyCode2 <> wdNoKey Then
        MsgBox aKey.KeyString & vbCr & "KeyCode1 = " _
            & aKey.KeyCode & vbCr & "KeyCode2 = " & aKey.KeyCode2
    Else
        MsgBox aKey.KeyString & vbCr _
            & "KeyCode1 = " & aKey.KeyCode
    End If
Next aKey


KeysBoundTo-Eigenschaft

Gibt ein KeysBoundTo-Objekt zurück, das alle Tastenkombinationen darstellt, die dem angegebenen Element zugewiesen wurden. Nur-Lese-Zugriff.

Syntax

Ausdruck.KeysBoundTo(KeyCategory, Command, CommandParameter)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

KeyCategory Long erforderlich Die Kategorie der Tastenkombination. Dabei kann es sich um eine der folgenden WdKeyCategory-Konstanten handeln: wdKeyCategoryAutoText, wdKeyCategoryCommand, wdKeyCategoryFont, wdKeyCategoryMacro, wdKeyCategoryStyle oder wdKeyCategorySymbol.

Command String erforderlich. Der Name des Befehls.

CommandParameter Variant optional. Eventuell vorhandener zusätzlicher Text, der von dem Befehl benötigt wird, der durch Command festgelegt wurde. Weitere Informationen finden Sie im Abschnitt "Anmerkungen" unter Add-Methode (KeyBindings-Objekt)..


Beispiel zur KeysBoundTo-Eigenschaft

In diesem Beispiel werden alle Tastenkombinationen angezeigt, die dem Befehl FileOpen in der mit dem aktiven Dokument verbundenen Dokumentvorlage zugeordnet sind.

CustomizationContext = ActiveDocument.AttachedTemplate
For Each myKey In _
        KeysBoundTo(KeyCategory:=wdKeyCategoryCommand, _
        Command:="FileOpen")
    myStr = myStr & myKey.KeyString & vbCr
Next myKey
MsgBox myStr

In diesem Beispiel werden alle Tastenkombinationen aus Makro1 in der Dokumentvorlage Normal entfernt.

CustomizationContext = NormalTemplate
For Each aKey In _
        KeysBoundTo(KeyCategory:=wdKeyCategoryMacro, _
        Command:="Macro1")
    aKey.Disable
Next aKey


KeyString-Eigenschaft

Liefert die Zeichenfolge der Tastenkombination für die angegebenen Tasten z. B. STRG+UMSCHALT+A. String Nur-Lese-Zugriff.


Beispiel zur KeyString-Eigenschaft

In diesem Beispiel wird die Zeichenfolge der Tastenkombination für die erste benutzerdefinierte Tastenkombination in der Dokumentvorlage Normal angezeigt.

CustomizationContext = NormalTemplate
If KeyBindings.Count >= 1 Then
    MsgBox KeyBindings(1).KeyString
End If

In diesem Beispiel wird eine Meldung angezeigt, wenn sich die Tastenkombination ALT+STRG+W in der KeyBindings-Auflistung befindet.

CustomizationContext = NormalTemplate
aCode = BuildKeyCode(wdKeyAlt, wdKeyControl, wdKeyW)
For Each aKey In KeyBindings
    If aCode = aKey.KeyCode Then
        MsgBox aKey.KeyString & " is already in use"
    End If
Next aKey


Kind-Eigenschaft

Document-Objekt: Gibt den Formattyp zurück, den Word bei der automatischen Formatierung des angegebenen Dokuments verwendet, oder legt ihn fest. Dies kann eine der folgenden WdDocumentKind-Konstanten sein: wdDocumentEmail, wdDocumentLetter oder wdDocumentNotSpecified. Long Schreib-Lese-Zugriff.

Field-Objekt: Gibt die Art der Verknüpfung für ein Field-Objekt zurück. Long Nur-Lese-Zugriff.

Es kann eine der folgenden wdFieldKind-Konstanten sein.

Konstante | Beschreibung
wdFieldKindHot | Ein Feld, das automatisch jedes Mal, wenn es angezeigt wird oder wenn die Seite neu formatiert wird, aktualisiert wird, das aber auch manuell aktualisiert werden kann (z. B. INCLUDEPICTURE oder FORMDROPDOWN).
WdFieldKindWarm | Ein Feld, das aktualisiert werden kann und ein Ergebnis hat. Diese Art umfasst sowohl Felder, die automatisch bei Änderungen der Quelle aktualisiert werden, als auch Felder, die manuell aktualisiert werden können (z. B. DATE oder INCLUDETEXT).
WdFieldKindNone | Ein ungültiges Feld (z. B. zwei Feldzeichen ohne Inhalt).
WdFieldKindCold | Ein Feld, das kein Ergebnis hat (z. B. XE-Felder (Indexeintrag), TC-Felder (Verzeichniseintrag) oder private Felder).


Beispiel zur Kind-Eigenschaft

In diesem Beispiel wird der Benutzer gefragt, ob es sich beim aktiven Dokument um eine E-Mail-Nachricht handelt. Lautet die Antwort "Ja", wird das Dokument als E-Mail-Nachricht formatiert.

response = MsgBox("Is this document an email message?", vbYesNo)
If response = vbYes Then
    ActiveDocument.Kind = wdDocumentEmail
    ActiveDocument.Content.AutoFormat
End If

In diesem Beispiel werden alle "warmen" verknüpften Felder in dem aktiven Dokument aktualisiert.

For Each aField In ActiveDocument.Fields
    If aField.Kind = wdFieldKindWarm Then aField.Update
Next aField


Label-Eigenschaft

Gibt eine Zeichenfolge zurück, die dazu verwendet wird, den Teil der Quelldatei zu kennzeichnen, der verknüpft wurde. Wenn beispielsweise die Quelldatei eine Microsoft Excel-Arbeitsmappe ist, könnte die Label-Eigenschaft "MeineArbeitsmappe!R3C1:R4C2" zurückgeben, wenn das OLE-Objekt nur ein paar Zellen aus der Tabelle enthält. String Nur-Lese-Zugriff.

Hinweis Diese Eigenschaft funktioniert nur bei Formen, Inline Shapes oder Feldern, die verknüpfte OLE-Objekte sind.


Beispiel zur Label-Eigenschaft

In diesem Beispiel wird die Bezeichnung für das erste Feld im aktiven Dokument zurückgegeben.

MsgBox ActiveDocument.Fields(1).OLEFormat.Label


LandscapeFontNames-Eigenschaft

Gibt ein FontNames-Objekt zurück, das die Namen aller verfügbaren Schriftarten enthält. Nur-Lese-Zugriff.


Beispiel zur LandscapeFontNames-Eigenschaft

In diesem Beispiel werden die Namen für Querschriftarten im FontNames-Objekt am Ende des aktiven Dokuments angezeigt.

For Each aFont In LandscapeFontNames
    response = MsgBox(Prompt:=aFont, Buttons:=vbOKCancel)
    If response = vbCancel Then Exit For
Next aFont


Language-Eigenschaft

Gibt die für die Microsoft Word-Benutzeroberfläche ausgewählte Sprache zurück. Dabei kann es sich um eine beliebige gültige MsoLanguageID-Konstante handeln. Long Nur-Lese-Zugriff.

Hinweise

Eine Liste der gültigen MsoLanguageID-Konstanten finden Sie im Objektkatalog des Visual Basic-Editor.

Der Wert dieser Eigenschaft ist identisch mit dem Wert, der von folgendem Ausdruck zurückgegeben wird:

Application.LanguageSettings _
    .LanguageID(msoLanguageIDUI)


LanguageDesignation-Eigenschaft

Gibt die Sprachzuweisung der Systemsoftware zurück. String Nur-Lese-Zugriff.


Beispiel zur LanguageDesignation-Eigenschaft

In diesem Beispiel wird "U.S. English" angezeigt, wenn die LanguageDesignation-Eigenschaft "English (US)" zurückgibt.

If System.LanguageDesignation = "English (US)" Then MsgBox "U.S. English"


LanguageDetected-Eigenschaft

Gibt einen Wert zurück, der angibt, ob Microsoft Word die Sprache des ausgewählten Textes erkannt hat, oder legt diesen Wert fest. Boolean Schreib-Lese-Zugriff.

Hinweise

Überprüfen Sie die LanguageID-Eigenschaft nach den Ergebnissen aller bisherigen Spracherkennungen.

Die LanguageDetected-Eigenschaft ist auf True gesetzt, wenn die DetectLanguage-Methode aufgerufen wird. Um die Sprache des ausgewählten Textes erneut auszuwerten, müssen Sie zunächst LanguageDetected auf False setzen.

Weitere Informationen über automatische Spracherkennung finden Sie unter Automatische Spracherkennung.


Beispiel zur LanguageDetected-Eigenschaft

In diesem Beispiel wird das aktuelle Dokument überprüft, um die Sprache festzustellen, in der es verfasst ist. Das Ergebnis wird angezeigt.

With ActiveDocument
    If .LanguageDetected = True Then
        x = MsgBox("This document has already " _
            & "been checked. Do you want to check " _
            & "it again?", vbYesNo)
        If x = vbYes Then
            .LanguageDetected = False
            .DetectLanguage
        End If
    Else
        .DetectLanguage
    End If
    If .Range.LanguageID = wdEnglishUS Then
        MsgBox "This is a U.S. English document."
    Else
        MsgBox "This is not a U.S. English document."
    End If
End With


LanguageID-Eigenschaft

Gibt die Sprache für das angegebene Objekt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdLanguageID-Konstanten handeln:

wdAfrikaans

wdAlbanian

wdArabic

wdArabicAlgeria

wdArabicBahrain

wdArabicEgypt

wdArabicIraq

wdArabicJordan

wdArabicKuwait

wdArabicLebanon

wdArabicLibya

wdArabicMorocco

wdArabicOman

wdArabicQatar

wdArabicSyria

wdArabicTunisia

wdArabicUAE

wdArabicYemen

wdArmenian

wdAssamese

wdAzeriCyrillic

wdAzeriLatin

wdBasque

wdBelgianDutch

wdBelgianFrench

wdBengali

wdBosniaHerzegovina

wdBrazilianPortuguese

wdBulgarian

wdBurmese

wdByelorussian

wdCatalan

wdChineseHongKong

wdChineseMacao

wdChineseSingapore

wdCroatian

wdCzech

wdDanish

wdDutch

wdEnglishAUS

wdEnglishBelize

wdEnglishCanadian

wdEnglishCaribbean

wdEnglishIreland

wdEnglishJamaica

wdEnglishNewZealand

wdEnglishPhilippines

wdEnglishSouthAfrica

wdEnglishTrinidad

wdEnglishUK

wdEnglishUS

wdEnglishZimbabwe

wdEstonian

wdFaeroese

wdFarsi

wdFinnish

wdFrench

wdFrenchCameroon

wdFrenchCanadian

wdFrenchCotedIvoire

wdFrenchLuxembourg

wdFrenchMali

wdFrenchMonaco

wdFrenchReunion

wdFrenchSenegal

wdFrenchWestIndies

wdFrenchZaire

wdFrisianNetherlands

wdGaelicIreland

wdGaelicScotland

wdGalician

wdGeorgian

wdGerman

wdGermanAustria

wdGermanLiechtenstein

wdGermanLuxembourg

wdGreek

wdGujarati

wdHebrew

wdHindi

wdHungarian

wdIcelandic

wdIndonesian

wdItalian

wdJapanese

wdKannada

wdKashmiri

wdKazakh

 wdKhmer

wdKirghiz

wdKonkani

wdKorean

wdLanguageNone

wdLao

wdLatvian

wdLithuanian

wdLithuanianClassic

wdMacedonian

wdMalayalam

wdMalayBruneiDarussalam

wdMalaysian

wdMaltese

wdManipuri

wdMarathi

wdMexicanSpanish

wdMongolian

wdNepali

wdNoProofing

wdNorwegianBokmol

wdNorwegianNynorsk

wdOriya

wdPolish

wdPortuguese

wdPunjabi

wdRhaetoRomanic

wdRomanian

wdRomanianMoldova

wdRussian

wdRussianMoldova

wdSamiLappish

wdSanskrit

wdSerbianCyrillic

wdSerbianLatin

wdSesotho

wdSimplifiedChinese

wdSindhi

wdSlovak

wdSlovenian

wdSorbian

wdSpanish

wdSpanishArgentina

wdSpanishBolivia

wdSpanishChile

wdSpanishColombia

wdSpanishCostaRica

wdSpanishDominicanRepublic

wdSpanishEcuador

wdSpanishElSalvador

wdSpanishGuatemala

wdSpanishHonduras

wdSpanishModernSort

wdSpanishNicaragua

wdSpanishPanama

wdSpanishParaguay

wdSpanishPeru

wdSpanishPuertoRico

wdSpanishUruguay

wdSpanishVenezuela

wdSutu

wdSwahili

wdSwedish

wdSwedishFinland

wdSwissFrench

wdSwissGerman

wdSwissItalian

wdTajik

wdTamil

wdTatar

wdTelugu

wdThai

wdTibetan

wdTraditionalChinese

wdTsonga

wdTswana

wdTurkish

wdTurkmen

wdUkrainian

wdUrdu

wdUzbekCyrillic

wdUzbekLatin

wdVenda

wdVietnamese

wdWelsh

wdXhosa

wdZulu

Hinweise

Sie müssen für ein Benutzerwörterbuch zuerst True als Wert für die LanguageSpecific-Eigenschaft festlegen, bevor Sie die LanguageID bestimmen. Sprachspezifische Benutzerwörterbücher überprüfen nur Text, der für diese Sprache formatiert wurde.

Einige der oben aufgelisteten Konstanten sind möglicherweise nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch) ab.


LanguageIDFarEast-Eigenschaft

Gibt eine ostasiatische Sprache für das angegebene Objekt zurück oder legt sie fest. Dies kann eine beliebige gültige WdLanguageID-Konstante sein. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdLanguageID-Konstanten finden Sie im Objektkatalog im Visual Basic-Editor.

Dies ist das empfohlene Verfahren, um eine ostasiatische Sprache eines Dokuments zurückzugeben oder diese zu setzen, das in einer ostasiatischen Word-Version erstellt wurde.


Beispiel zur LanguageIDFarEast-Eigenschaft

In diesem Beispiel wird die Sprache der Markierung auf Koreanisch festgelegt.

Selection.LanguageIDFarEast = wdKorean


LanguageIDOther-Eigenschaft

Gibt die Sprache für das angegebene Objekt zurück oder legt sie fest. Dies kann eine beliebige gültige WdLanguageID-Konstante sein. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdLanguageID-Konstanten finden Sie im Objektkatalog im Visual Basic-Editor.

Dies ist das empfohlene Verfahren zum Zurückgeben oder Festlegen der Sprache eines westlichen Textes in einem Dokument, das in einer Microsoft Word-Version für Sprachen mit Schreibrichtung von rechts nach links erstellt wurde.


Beispiel zur LanguageIDOther-Eigenschaft

In diesem Beispiel wird die Sprache der Markierung auf Französisch festgelegt.

Selection.LanguageIDOther = wdFrench


Languages-Eigenschaft

Gibt eine Languages-Auflistung zurück, die die Korrektursprachen im Dialogfeld Sprachen (Menü Extras) darstellt. Nur-Lese-Zugriff.

Weitere Informationen zum Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


LanguageSettings-Eigenschaft

Gibt das LanguageSettings-Objekt zurück, das Informationen über die Spracheinstellungen in Microsoft Word enthält. Nur-Lese-Zugriff.


LanguageSpecific-Eigenschaft

True, wenn das Benutzerwörterbuch nur für Text, der für eine bestimmte Sprache formatiert wurde, verwendet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur LanguageSpecific-Eigenschaft

In diesem Beispiel wird überprüft, ob sprachspezifische Benutzerwörterbücher vorhanden sind. Falls welche gefunden werden, werden sie in diesem Beispiel aus der Liste der aktiven Benutzerwörterbücher entfernt.

For each d in CustomDictionaries
   If d.LanguageSpecific = True Then d.Delete
Next d

In diesem Beispiel wird ein Benutzerwörterbuch hinzugefügt, das nur solchen Text überprüft, der als "Deutsch" formatiert wurde.

Set myD = CustomDictionaries.Add("MyGerman.dic")
myD.LanguageSpecific = True
myD.LanguageID = wdGerman


Last-Eigenschaft

Sentences-, Words- und Characters-Objekte: Gibt ein Range-Objekt zurück, das den letzten Satz, das letzte Wort oder das letzte Zeichen in einem Dokument, in der Markierung oder in einem Bereich darstellt. Nur-Lese-Zugriff.

Columns-, Paragraphs-, Rows- und Sections-Objekte: Gibt das letzte Element in der angegebenen Auflistung zurück. Nur-Lese-Zugriff. Zum Beispiel gibt jede der beiden folgenden Anweisungen ein Paragraph-Objekt zurück, das den letzten Absatz in der Markierung darstellt.

Selection.Paragraphs.Last
Selection.Paragraphs(Selection.Paragraphs.Count)


LastRecord-Eigenschaft

Gibt die Nummer des letzten Datensatzes, der in einer Seriendruckoperation zusammengeführt wird, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur LastRecord-Eigenschaft

In diesem Beispiel wird das Hauptdokument mit den Datensätzen 2 bis 4 zusammengeführt, und die Seriendruckdokumente werden in ein neues Dokument übertragen.

With ActiveDocument.MailMerge
    .DataSource.FirstRecord = 2
    .DataSource.LastRecord = 4
    .Destination = wdSendToNewDocument
    .Execute
End With


LayoutMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the layout mode for the current document. Read/write Long.

Can be one of the following WdLayoutMode constants.

Constant | Description
wdLayoutModeDefault | No grid is used to lay out text.
wdLayoutModeGenko | Text is laid out on a grid; the user specifies the number of lines and the number of characters per line. As the user types, Microsoft Word automatically aligns characters with gridlines.
wdLayoutModeGrid | Text is laid out on a grid; the user specifies the number of lines and the number of characters per line. As the user types, Microsoft Word doesn't automatically align characters with gridlines.
wdLayoutModeLineGrid | Text is laid out on a grid; the user specifies the number of lines, but not the number of characters per line.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur LayoutMode-Eigenschaft

This example sets the layout mode for the active document so that Microsoft Word automatically aligns typed text to a grid.

ActiveDocument.PageSetup.LayoutMode = wdLayoutModeGenko


Leader-Eigenschaft

Gibt das Füllzeichen für das angegebene TabStop-Objekt zurück oder legt es fest. Kann eine der folgenden WdTabLeader-Konstanten sein: wdTabLeaderDashes, wdTabLeaderDots, wdTabLeaderHeavy, wdTabLeaderLines, wdTabLeaderMiddleDot oder wdTabLeaderSpaces. Long Schreib-Lese-Zugriff.


Beispiel zur Leader-Eigenschaft

In diesem Beispiel wird in allen Absätzen des aktiven Dokuments das Füllzeichen für alle Tabstops mit Füllzeichen in Gedankenstrich geändert.

For each tb in ActiveDocument.Paragraphs.TabStops
    If tb.Leader <> wdTabLeaderSpaces Then
        tb.Leader = wdTabLeaderDashes
    End If
Next tb


Left-Eigenschaft

Application-, Task- oder Window-Objekt: Gibt die horizontale Position des aktiven Dokuments (Application) oder des angegebenen Tasks oder Fensters in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Shape- oder ShapeRange-Objekt: Gibt die horizontale Position der angegebenen Form oder den Formenbereich in Punkt zurück oder legt sie fest. Dabei kann es sich auch um eine der folgenden WdShapePosition-Konstanten handeln: wdShapeLeft, wdShapeRight, wdShapeCenter, wdShapeInside, oder wdShapeOutside. Single Schreib-Lese-Zugriff.

Hinweise

Die Position einer Form wird von der oberen linken Ecke des Begrenzungsrechtecks der Form zu seiner Verankerung gemessen. Die RelativeHorizontalPosition-Eigenschaft steuert, ob die Verankerung an einem Zeichen, einer Spalte, am Rand oder an der Seitenkante positioniert wird.

Bei einem ShapeRange-Objekt mit mehreren Formen legt die Left-Eigenschaft die horizontale Position aller Formen fest.


LeftIndent-Eigenschaft

Paragraph-, Paragraphs- oder ParagraphFormat-Objekt: Gibt den linken Einzugswert (in Punkt) für die angegebenen Absätze zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Row- oder Rows-Objekt: Gibt den Abstand (in Punkt) zwischen dem linken Seitenrand und der linken Textkante in den angegebenen Zeilen zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur LeftIndent-Eigenschaft

In diesem Beispiel wird der linke Einzug des ersten Absatzes im aktiven Dokument auf 1 Zoll festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

ActiveDocument.Paragraphs(1).LeftIndent = InchesToPoints(1)

In diesem Beispiel wird für alle Zeilen der ersten Tabelle im aktiven Dokument der linke Einzug festgelegt.

ActiveDocument.Tables(1).Rows.LeftIndent = InchesToPoints(1)


LeftMargin-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der linken Seitenkante und der linken Begrenzung des Textkörpers zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn die MirrorMargins-Eigenschaft auf True gesetzt ist, steuert die LeftMargin-Eigenschaft die Einstellung für den inneren Seitenrand und die RightMargin-Eigenschaft die Einstellung für den äußeren Seitenrand.


Beispiel zur LeftMargin-Eigenschaft

In diesem Beispiel wird für den zweiten Abschnitt des aktiven Dokuments der linke Seitenrand auf 1 Zoll (72 Punkt) festgelegt.

ActiveDocument.Sections(2).PageSetup.LeftMargin = 72


LeftPadding-Eigenschaft

Gibt den Abstand (in Punkt) zurück, der auf der linken Seite dem Inhalt einer einzelnen Zelle oder allen Zellen einer Tabelle hinzugefügt werden soll, oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Die Einstellung der LeftPadding-Eigenschaft für eine einzelne Zelle überschreibt die Einstellung der LeftPadding-Eigenschaft für die gesamte Tabelle.


Beispiel zur LeftPadding-Eigenschaft

In diesem Beispiel wird der linke Abstand für die erste Tabelle im aktiven Dokument auf 40 Pixel festgelegt.

ActiveDocument.Tables(1).LeftPadding = _
    PixelsToPoints(40, False)


Length-Eigenschaft

Wenn Sie als Wert für die AutoLength-Eigenschaft der angegebenen Legende False festlegen, gibt die Length-Eigenschaft die Länge (in Punkt) des ersten Liniensegments der Legende zurück (das Segment, das mit dem Anmerkungstextfeld verbunden ist). Diese Eigenschaft betrifft nur Legenden mit Linien, die aus mehreren Segmenten bestehen (msoCalloutThree und msoCalloutFour). Single Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann nur gelesen werden. Mit der CustomLength-Methode legen Sie den Wert der Eigenschaft für das CalloutFormat-Objekt fest.


Beispiel zur Length-Eigenschaft

Wenn das erste Liniensegment in der Legende "legende1" eine feste Länge hat, wird in diesem Beispiel festgelegt, als Länge des ersten Liniensegments der Legende "legende2" auch diese Länge festzulegen. Dieses Beispiel funktioniert nur, wenn die Linien beider Legenden aus mehreren Segmenten bestehen.

With ActiveDocument.Shapes
    With .Item("co1").Callout
        If Not .AutoLength Then len1 = .Length
    End With
    If len1 Then .Item("co2").Callout.CustomLength len1
End With


Letterhead-Eigenschaft

True, wenn in einem Brief, der mit dem Brief-Assistenten erstellt wurde, Platz für einen gedruckten Briefkopf reserviert wird. Boolean Schreib-Lese-Zugriff.

Hinweis Mit der LetterheadSize-Eigenschaft bestimmen Sie die Größe des für den Briefkopf reservierten Platzes.


LetterheadLocation-Eigenschaft

Gibt die Position des gedruckten Briefkopfs in einem Brief, der mit dem Brief-Assistenten erstellt wurde, zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdLetterheadLocation-Konstanten handeln: wdLetterBottom, wdLetterLeft, wdLetterRight oder wdLetterTop. Long Schreib-Lese-Zugriff.


Beispiel zur LetterheadLocation-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, ein 1 Zoll breiter Platz wird am oberen Seitenrand für den gedruckten Briefkopf reserviert und anschließend der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set aLetterContent = New LetterContent
With aLetterContent
    .Letterhead = True
    .LetterheadLocation = wdLetterTop
    .LetterheadSize = InchesToPoints(1)
End With
ActiveDocument.RunLetterWizard LetterContent:=aLetterContent


LetterheadSize-Eigenschaft

Gibt die Größe des Platzes (in Punkt), der für einen gedruckten Briefkopf in einem mit dem Brief-Assistenten erstellten Brief reserviert wird, zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur LetterheadSize-Eigenschaft

In diesem Beispiel werden die Elemente des Brief-Assistenten aus dem aktiven Dokument geladen, die Einstellungen für den gedruckten Briefkopf geändert, und dann wird das aktive Dokument mit der SetLetterContent-Methode aktualisiert, um die Änderungen zu reflektieren.

Set myLetterContent = ActiveDocument.GetLetterContent
With myLetterContent
    .Letterhead = True
    .LetterheadLocation = wdLetterTop
    .LetterheadSize = InchesToPoints(1.5)
End With
ActiveDocument.SetLetterContent LetterContent:=myLetterContent


LetterStyle-Eigenschaft

Gibt das Layout eines Briefes, der mit dem Brief-Assistenten erstellt wurde, zurück oder legt es fest. Dabei kann es sich um eine der folgenden WdLetterStyle-Konstanten handeln: wdFullBlock, wdModifiedBlock oder wdSemiBlock. Long Schreib-Lese-Zugriff.


Beispiel zur LetterStyle-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, ein Briefformat gewählt und anschließend der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set aLetterContent = New LetterContent
aLetterContent.LetterStyle = wdFullBlock
ActiveDocument.RunLetterWizard _
    LetterContent:=aLetterContent, WizardMode:=True


Level-Eigenschaft

HeadingStyle-Objekt: Gibt die Ebene der Überschriften-Formatvorlage in einem Inhalts- oder Abbildungsverzeichnis zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Subdocument-Objekt: Gibt die Überschriftenebene, mit der das Filialdokument erstellt wird, zurück. Long Nur-Lese-Zugriff.


Beispiel zur Level-Eigenschaft

In diesem Beispiel wird an der Einfügemarke im aktiven Dokument ein Inhaltsverzeichnis hinzugefügt, und dann werden die Ebenen der Formatvorlagen für Überschriften geändert.

ActiveDocument.TablesOfContents.Add _
    Range:=Selection.Range, _
    RightAlignPageNumbers:=True, _
    UseHeadingStyles:=True, _
    UpperHeadingLevel:=1, _
    LowerHeadingLevel:=3, _
    IncludePageNumbers:=True, _
    TableID:=wdTOCFormal
With ActiveDocument.TablesOfContents(1).HeadingStyles
    .Add Style:="Title", Level:=1
    .Add Style:="SubTitle", Level:=2
    .Add Style:="List Bullet", Level:=3
End With
With ActiveDocument.TablesOfContents(1)
    .HeadingStyles(1).Level = 2
    .HeadingStyles(2).Level = 4
    .HeadingStyles(3).Level = 6
End With

Dieses Beispiel durchsucht alle Filialdokumente im aktiven Dokument und zeigt die Überschriftenebene des Filialdokuments an.

i = 1
If ActiveDocument.Subdocuments.Count > = 1 Then
    For each s in ActiveDocument.Subdocuments
        MsgBox "The heading level for SubDoc " & i _
            & " is " & s.Level
        i = i + 1
    Next s
Else
    MsgBox "There are no subdocuments defined."
End If


Line-Eigenschaft

Gibt ein LineFormat-Objekt zurück, das Linienformatierungseigenschaften für die angegebene Form enthält. (Bei einer Linie stellt das LineFormat-Objekt die Linie selbst dar; bei einer Form mit einem Rahmen stellt das LineFormat-Objekt den Rahmen dar.) Nur-Lese-Zugriff.


LineBetween-Eigenschaft

True, wenn zwischen allen Spalten in der TextColumns-Auflistung vertikale Linien sind. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur LineBetween-Eigenschaft

In diesem Beispiel wird jeder Abschnitt im aktiven Dokument durchlaufen und ein Meldungsfeld angezeigt, wenn die Textspalten in dem Abschnitt durch vertikale Linien getrennt sind.

i = 1
For each s in ActiveDocument.Sections
    If s.PageSetup.TextColumns.LineBetween = True Then
        MsgBox "The columns in section " & i & " contain lines."
    End If
    i = i + 1
Next s


LineNumbering-Eigenschaft

Gibt das LineNumbering-Objekt zurück, das die Zeilennummern für das angegebene PageSetup-Objekt darstellt, oder legt es fest. Schreib-Lese-Zugriff.

Hinweise

Sie müssen sich in der Seitenlayoutansicht befinden, wenn Sie die Zeilennummerierung sehen möchten.


Beispiel zur LineNumbering-Eigenschaft

In diesem Beispiel wird die Zeilennummerierung für das aktive Dokument aktiviert.

ActiveDocument.PageSetup.LineNumbering.Active = True

In diesem Beispiel wird die Zeilennummerierung für das Dokument MyDocument.doc aktiviert. Die Startnummer wird auf 1 gesetzt, jede fünfte Zeilennummer wird angezeigt, und die Nummerierung ist über alle Abschnitte des Dokuments fortlaufend.

set myDoc = Documents("MyDocument.doc")
With myDoc.PageSetup.LineNumbering
    .Active = True
    .StartingNumber = 1
    .CountBy = 5
    .RestartMode = wdRestartContinuous
End With

In diesem Beispiel wird die Zeilennummerierung im aktiven Dokument so eingestellt wie die Zeilennummerierung in MyDocument.doc.

ActiveDocument.PageSetup.LineNumbering = Documents("MyDocument.doc") _
    .PageSetup.LineNumbering


LineSpacing-Eigenschaft

Gibt den Zeilenabstand (in Punkt) für die angegebenen Absätze zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweise

Die LineSpacing-Eigenschaft kann festgelegt werden, nachdem die LineSpacingRule-Eigenschaft auf wdLineSpaceAtLeast, wdLineSpaceExactly oder wdLineSpaceMultiple eingestellt wurde. Wird wdLineSpaceAtLeast verwendet, kann der Zeilenabstand größer oder gleich, aber niemals kleiner als der angegebene Wert LineSpacing sein. Wird wdLineSpaceExactly verwendet, weicht der Zeilenabstand niemals vom angegebenen Wert LineSpacing ab, selbst wenn innerhalb des Absatzes eine größere Schriftart verwendet wird. Wird wdLineSpaceMultiple verwendet, muss ein Wert in Punkt für die LineSpacing-Eigenschaft angegeben werden.

Verwenden Sie die LinesToPoints-Methode zur Umwandlung einer Anzahl von Zeilen in den entsprechenden Wert in Punkt. Beispielsweise gibt LinesToPoints(2) den Wert 24 zurück.


LineSpacingRule-Eigenschaft

Gibt den Zeilenabstand für die angegebenen Absätze zurück oder legt ihn fest. Kann eine der folgenden WdLineSpacing-Konstanten sein: wdLineSpace1pt5, wdLineSpaceAtLeast, wdLineSpaceDouble, wdLineSpaceExactly, wdLineSpaceMultiple oder wdLineSpaceSingle. Long Schreib-Lese-Zugriff.

Hinweise

Verwenden Sie wdLineSpaceSingle, wdLineSpace1pt5 oder wdLineSpaceDouble zum Festlegen des Zeilenabstands auf einen dieser Werte. Soll der Zeilenabstand auf eine genaue Punktanzahl oder eine vielfache Anzahl von Zeilen festgelegt werden, müssen Sie auch die LineSpacing-Eigenschaft angeben.


Beispiel zur LineSpacingRule-Eigenschaft

In diesem Beispiel werden die Zeilen im ersten Absatz des aktiven Dokuments mit doppeltem Zeilenabstand formatiert.

ActiveDocument.Paragraphs(1).LineSpacingRule = _
    wdLineSpaceDouble

In diesem Beispiel wird die ZeilenabstandArt zurückgegeben, die für den ersten Absatz in der Markierung verwendet wird.

lrule = Selection.Paragraphs(1).LineSpacingRule


LinesPage-Eigenschaft

Sprachspezifische Informationen

Returns or sets the number of lines per page in the document grid. Read/write Single.


Beispiel zur LinesPage-Eigenschaft

This example sets the number of lines per page to 35 for the active document.

ActiveDocument.PageSetup.LinesPage = 35


LinesToDrop-Eigenschaft

Gibt die Höhe des angegebenen Initials im Seitenrand, in Zeilen, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur LinesToDrop-Eigenschaft

In diesem Beispiel wird das erste Zeichen im aktiven Dokument als Initial im Seitenrand mit einer Höhe von drei Zeilen formatiert.

With ActiveDocument.Paragraphs(1).DropCap
    .Enable
    .Position = wdDropNormal
    .LinesToDrop = 3
End With


LineStyle-Eigenschaft

Gibt die Rahmenlinienart für das angegebene Dokument zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdLineStyle-Konstanten handeln:

wdLineStyleDashDot

wdLineStyleDashDotDot

wdLineStyleDashDotStroked

wdLineStyleDashLargeGap

wdLineStyleDashSmallGap

wdLineStyleDot

wdLineStyleDouble

wdLineStyleDoubleWavy

wdLineStyleEmboss3D

wdLineStyleEngrave3D

wdLineStyleInset

wdLineStyleNone

wdLineStyleOutset

 wdLineStyleSingle

wdLineStyleSingleWavy

wdLineStyleThickThinLargeGap

wdLineStyleThickThinMedGap

wdLineStyleThickThinSmallGap

wdLineStyleThinThickLargeGap

wdLineStyleThinThickMedGap

wdLineStyleThinThickSmallGap

wdLineStyleThinThickThinLargeGap

wdLineStyleThinThickThinMedGap

wdLineStyleThinThickThinSmallGap

wdLineStyleTriple

Hinweise

Wenn Sie die LineStyle-Eigenschaft für einen Bereich festlegen, der sich auf einzelne Zeichen oder Wörter bezieht, wird ein Zeichenrahmen zugewiesen.

Wenn Sie die LineStyle-Eigenschaft für einen oder mehrere Absätze festlegen, wird ein Absatzrahmen zugewiesen. Mit der InsideLineStyle-Eigenschaft ziehen Sie einen Rahmen zwischen aufeinander folgende Absätze.

Wenn Sie die LineStyle-Eigenschaft für einen Abschnitt festlegen, wird ein Seitenrahmen um die Seiten im Abschnitt gezogen.


Beispiel zur LineStyle-Eigenschaft

Wenn es sich bei der Auswahl um einen Absatz oder eine reduzierte Auswahl handelt, wird in diesem Beispiel ein einfacher 0,75 Punkt breiter Absatzrahmen oberhalb der Auswahl eingefügt. Wenn sich in der Auswahl kein Absatz befindet, wird ein Rahmen um den gewählten Text gezeichnet.

With Selection.Borders(wdBorderTop)
    .LineStyle = wdLineStyleSingle
    .LineWidth = wdLineWidth075pt
End With

In diesem Beispiel wird ein doppelter 1,5 Punkt breiter Rahmen allen Rahmen im aktiven Dokument hinzugefügt.

For Each aFrame In ActiveDocument.Frames
    With aFrame.Borders(wdBorderBottom)
        .LineStyle = wdLineStyleDouble
        .LineWidth = wdLineWidth150pt
    End With
Next aFrame

Im folgenden Beispiel wird ein Rahmen um das vierte Wort im aktiven Dokument gezogen. Wenn Sie Text einen einfachen Rahmen (in diesem Beispiel ein oberer Rahmen) zuweisen, wird ein Rahmen um den Text gezogen.

ActiveDocument.Words(4).Borders(wdBorderTop) _
    .LineStyle = wdLineStyleSingle


LineUnitAfter-Eigenschaft

Sprachspezifische Informationen

Returns or sets the amount of spacing (in gridlines) after the specified paragraphs. Read/write Single.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur LineUnitAfter-Eigenschaft

This example sets the spacing after the first paragraph in the active document to one gridline.

ActiveDocument.Paragraphs(1).LineUnitAfter = 1


LineUnitBefore-Eigenschaft

Sprachspezifische Informationen

Returns or sets the amount of spacing (in gridlines) before the specified paragraphs. Read/write Single.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur LineUnitBefore-Eigenschaft

This example sets the spacing before the second paragraph in the active document to one gridline.

ActiveDocument.Paragraphs(2).LineUnitBefore = 1


LineWidth-Eigenschaft

Gibt die Linienstärke des Rahmens eines Objekts zurück oder legt sie fest. Es wird eine WdLineWidth-Konstante oder wdUndefined zurückgegeben, wenn das Objekt entweder keinen Rahmen oder Rahmen mit mehreren Linienstärken aufweist. True, False oder eine der folgenden WdLineWidth-Konstanten können angegeben werden: wdLineWidth025pt, wdLineWidth050pt, wdLineWidth075pt, wdLineWidth100pt, wdLineWidth150pt, wdLineWidth225pt, wdLineWidth300pt, wdLineWidth450pt oder wdLineWidth600pt. Long Schreib-Lese-Zugriff.

Hinweis Wenn die angegebene Linienstärke für die Linienart des Rahmens nicht verfügbar ist, generiert diese Eigenschaft einen Fehler. Die für eine bestimmte Linienart verfügbaren Linienstärken können Sie dem Dialogfeld Rahmen und Schattierung (Menü Format) entnehmen.


Beispiel zur LineWidth-Eigenschaft

In diesem Beispiel wird der ersten Zeile in Tabelle eins des aktiven Dokuments eine Rahmenlinie unten hinzugefügt.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1).Rows(1).Borders(wdBorderBottom)
        .LineStyle = wdLineStyleSingle
        .LineWidth = wdLineWidth050pt
    End With
End If

In diesem Beispiel wird links der Markierung eine gewellte rote Linie eingefügt.

With Selection.Borders(wdBorderLeft)
    .LineStyle = wdLineStyleSingleWavy
    .LineWidth = wdLineWidth075pt
    .ColorIndex = wdRed
End With


LinkedStyle-Eigenschaft

Gibt den Namen der Formatvorlage, die mit dem angegebenen ListLevel-Objekt verknüpft ist, zurück oder legt sie fest. String Schreib-Lese-Zugriff..


Beispiel zur LinkedStyle-Eigenschaft

In diesem Beispiel wird die Variable myListTemp auf die erste Listenvorlage (exkl. Ohne) auf der Registerkarte Gliederung im Dialogfeld Nummerierung und Aufzählungen gesetzt. Jede Ebene der Liste ist mit einer passenden Formatvorlage für Überschriften verknüpft.

Set myListTemp = _
    ListGalleries(wdOutlineNumberGallery).ListTemplates(1)
For Each mylevel In myListTemp.ListLevels
    mylevel.LinkedStyle = "Heading " & mylevel.index
Next mylevel


LinkFormat-Eigenschaft

Gibt ein LinkFormat-Objekt zurück, das die Verknüpfungsoptionen des angegebenen Felds, der eingebetteten Form oder der Form darstellt, die mit einer Datei verknüpft ist. Nur-Lese-Zugriff.


Beispiel zur LinkFormat-Eigenschaft

In diesem Beispiel wird eine Grafik als eingebettete Form eingefügt (mit einem INCLUDEPICTURE-Feld), und anschließend wird der Name der Quelle (Kacheln.bmp) angezeigt.

Set iShape = ActiveDocument.InlineShapes _
    .AddPicture(FileName:="C:\windows\Tiles.bmp", _
    LinkToFile:=True, SaveWithDocument:=False, _
    Range:=Selection.Range)
MsgBox iShape.LinkFormat.SourceName

In diesem Beispiel werden alle Felder im aktiven Dokument aktualisiert, die nicht automatisch aktualisiert werden.

For Each afield In ActiveDocument.Fields
    If afield.LinkFormat.AutoUpdate = False _
        Then afield.LinkFormat.Update
Next afield


LinkToPrevious-Eigenschaft

True, wenn die angegebene Kopf- oder Fußzeile mit der entsprechenden Kopf- oder Fußzeile im vorherigen Abschnitt verknüpft ist. Wenn eine Kopf- oder Fußzeile verknüpft ist, entspricht ihr Inhalt der vorherigen Kopf- oder Fußzeile. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die LinkToPrevious-Eigenschaft ist solange auf True gesetzt, bis Sie sie ändern. Deshalb können Sie Kopfzeilen, Fußzeilen und Seitennummern dem gesamten Dokument zuweisen, wenn Sie im ersten Abschnitt mit Kopfzeilen, Fußzeilen oder Seitennummern arbeiten. Im folgenden Beispiel werden z. B. Seitennummern allen Abschnitten des aktiven Dokuments zugewiesen.

ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary).PageNumbers.Add

Die LinkToPrevious-Eigenschaft ist für jede Kopf- oder Fußzeile individuell gültig. Zum Beipiel können Sie die LinkToPrevious-Eigenschaft für Kopfzeilen auf Seiten mit geraden Seitennummern auf True, aber für Fußzeilen auf Seiten mit geraden Seitennummern auf False setzen.


Beispiel zur LinkToPrevious-Eigenschaft

Im ersten Teil dieses Beispiels wird ein neues Dokument mit zwei Abschnitten angelegt. Im zweiten Teil werden eindeutige Kopfzeilen für gerade und ungerade Seiten in den Abschnitten 1 und 2 des neuen Dokuments erstellt.

Documents.Add
With Selection
    For j = 1 to 4
        .TypeParagraph
        .InsertBreak
        .TypeParagraph
    Next j
End With
With ActiveDocument
    .Paragraphs(5).Range.InsertBreak Type:=wdSectionBreakNextPage
    .PageSetup.OddAndEvenPagesHeaderFooter = True
End With
With ActiveDocument.Sections(2)
    With .Headers(wdHeaderFooterPrimary)
        .LinkToPrevious = False
        .Range.InsertBefore "Section 2 Odd Header"
    End With
    With .Headers(wdHeaderFooterEvenPages)
        .LinkToPrevious = False
        .Range.InsertBefore "Section 2 Even Header"
    End With
End With
With ActiveDocument.Sections(1)
    .Headers(wdHeaderFooterPrimary) _
        .Range.InsertBefore "Section 1 Odd Header"
    .Headers(wdHeaderFooterEvenPages) _
        .Range.InsertBefore "Section 1 Even Header"
End With


List-Eigenschaft

Gibt ein List-Objekt zurück, das die erste formatierte Liste im angegebenen ListFormat-Objekt darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wenn der erste Absatz im Bereich des ListFormat-Objekt nicht als Liste formatiert ist, gibt die List-Eigenschaft Nothing zurück.


ListEntries-Eigenschaft

Gibt eine ListEntries-Auflistung zurück, die alle Elemente in einem DropDown-Objekt darstellt Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ListEntries-Eigenschaft

In diesem Beispiel wird der Text des aktiven Elements aus dem Dropdown-Formularfeld "DropDown1" geladen.

Set myField = ActiveDocument.FormFields("DropDown1").DropDown
num = myField.Value
myName = myField.ListEntries(num).Name

In diesem Beispiel wird die Gesamtanzahl der Elemente im aktiven Dropdown-Formularfeld (das Dokument sollte als Formular geschützt sein) angezeigt. Bei zwei oder mehr Elementen wird das zweite Element als aktives Element festgelegt.

Set myField = Selection.FormFields(1)
If myfield.Type = wdFieldFormDropDown Then
    num = myField.DropDown.ListEntries.Count
    If num >= 2 Then myField.DropDown.Value = 2
End If


ListFormat-Eigenschaft

Gibt ein ListFormat-Objekt zurück, das alle Formatmerkmale des Bereichs darstellt. Nur-Lese-Zugriff.


Beispiel zur ListFormat-Eigenschaft

In diesem Beispiel wird der Variablen myDoc ein Bereich zugewiesen, der die Absätze drei bis sechs des aktiven Dokuments enthält. Das Beispiel weist dem Bereich dann entweder das Standardformat für Gliederungen zu oder entfernt es, abhängig davon, ob das Format dem Bereich bereits vorher zugewiesen wurde.

Set myDoc = ActiveDocument
Set myRange = _
    myDoc.Range(Start:= myDoc.Paragraphs(3).Range.Start, _
    End:=myDoc.Paragraphs(6).Range.End)
myRange.ListFormat.ApplyOutlineNumberDefault

In diesem Beispiel wird allen Absätzen in der Auswahl die zweite Listenvorlage auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungen zugewiesen.

Selection.Range.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdNumberGallery).ListTemplates(2)


ListGalleries-Eigenschaft

Gibt eine ListGalleries-Sammlung zurück, die die drei Kataloge für Listenvorlagen darstellt (Aufzählungen, Nummerierung und Gliederung). Jeder Katalog entspricht einer Registerkarte im Dialogfeld Nummerierung und Aufzählungen. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ListGalleries-Eigenschaft

In diesem Beispiel wird die Variable mylsttmp auf die zweite Listenvorlage der Registerkarte Gliederung im Dialogfeld Nummerierung und Aufzählungen gesetzt. Das Beispiel weist dann die Vorlage der ersten Liste im aktiven Dokument zu.

Set mylsttmp = _
    ListGalleries(wdOutlineNumberGallery).ListTemplates(2)
ActiveDocument.Lists(1).ApplyListTemplate ListTemplate:=mylsttmp

In diesem Beispiel wird durch die ListGalleries-Sammlung geblättert, und alle Vorlagen in den Katalogen für Listenvorlagen werden auf die integrierte Vorlage gesetzt.

For Each listgal In ListGalleries
    For i = 1 To 7
        listgal.Reset(i)
    Next i
Next listgal


ListLevelNumber-Eigenschaft

Style-Objekt: Gibt die Listenebene für die angegebene Formatvorlage zurück. Long Nur-Lese-Zugriff.

ListFormat-Objekt: Gibt die Listenebene für den ersten Absatz im angegebenen ListFormat-Objekt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur ListLevelNumber-Eigenschaft

In diesem Beispiel wird die Listenebene für den dritten Absatz im aktiven Dokument zurückgegeben.

lev = ActiveDocument.Paragraphs(3).Range.ListFormat.ListLevelNumber

In diesem Beispiel wird die Listenebene der Formatvorlage "Überschrift 3" angezeigt.

Msgbox ActiveDocument.Styles(wdStyleHeading3).ListLevelNumber


ListLevels-Eigenschaft

Gibt eine ListLevels-Sammlung zurück, die alle Ebenen für das angegebene ListTemplate darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ListLevels-Eigenschaft

In diesem Beispiel wird der Variablen myListTemp die erste Listenvorlage (exkl. Ohne) auf der Registerkarte Gliederung im Dialogfeld Nummerierung und Aufzählungen zugewiesen. Jede Ebene der Liste ist mit einer passenden Formatvorlage für Überschriften verknüpft.

Set myListTemp = _
    ListGalleries(wdOutlineNumberGallery).ListTemplates(1)
For Each mylevel In myListTemp.ListLevels
    mylevel.LinkedStyle = "Heading " & mylevel.index
Next mylevel


ListParagraphs-Eigenschaft

Gibt eine ListParagraphs-Sammlung zurück, die alle nummerierten Absätze in der Liste, dem Dokument oder dem Bereich darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ListParagraphs-Eigenschaft

In diesem Beispiel wird ein gelber Hintergrund jedem nummerierten oder mit Aufzählungszeichen versehenen Absatz im ersten Dokument zugewiesen.

For Each numpar In Documents(1).ListParagraphs
    numpar.Shading.BackgroundPatternColorIndex = wdYellow
Next numpar

In diesem Beispiel werden die Absätze in der zweiten Liste im aktiven Dokument doppelt unterstrichen.

For Each mypara In ActiveDocument.Lists(2).ListParagraphs
    mypara.Range.Underline = wdUnderlineDouble
Next mypara


Lists-Eigenschaft

Gibt eine Lists-Sammlung mit allen formatierten Listen im angegebenen Dokument zurück. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


ListString-Eigenschaft

Gibt eine Zeichenfolge zurück, die das Erscheinungsbild des Listenwerts des ersten Absatzes im Bereich für das angegebene ListFormat-Objekt darstellt. Für den zweiten Absatz in einer alphabetischen Liste würde B zurückgegeben. String Nur-Lese-Zugriff.

Anmerkungen

Für eine Aufzählung müssen Sie die korrekte Schriftart verwenden, um die Zeichenfolge zu sehen. Die meisten Aufzählungszeichen verwenden die Schriftart "Symbol" oder "Wingdings".

Mit der ListValue-Eigenschaft geben Sie den numerischen Wert des Absatzes zurück.


Beispiel zur ListString-Eigenschaft

In diesem Beispiel werden der numerische Wert des ersten Absatzes in der Auswahl und die Darstellung dieses Wertes als Zeichenfolge angezeigt.

v = Selection.Range.ListFormat.ListValue
lstring = Selection.Range.ListFormat.ListString
MsgBox "List value " & v _
    & " is represented by the string " & lstring


ListTemplate-Eigenschaft

Gibt ein ListTemplate-Objekt zurück, das die Listenformatierung für das angegebene Style- oder ListFormat-Objekt darstellt. Nur-Lese-Zugriff.

Anmerkungen

Eine Listenvorlage enthält die gesamte Formatierung, die eine bestimmte Liste definiert. Jedes der sieben Formate (exkl. Ohne), die Sie auf jeder Registerkarte im Dialogfeld Nummerierung und Aufzählungen finden, entspricht einer Listenvorlage. Dokumente und Vorlagen können auch Sammlungen mit Listenvorlagen enthalten.

Ist der erste Absatz im Bereich für das ListFormat-Objekt nicht als Liste formatiert, gibt die ListTemplate-Eigenschaft Nothing zurück.


ListTemplates-Eigenschaft

Gibt eine ListTemplates-Sammlung zurück, die alle Listenformate für das angegebene Dokument, die Vorlage oder den Listenkatalog darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ListTemplates-Eigenschaft

In diesem Beispiel wird der Variablen mytemp die erste Vorlage der Registerkarte Gliederung im Dialogfeld Nummerierung und Aufzählungen zugewiesen. Die Vorlage wird verändert, so dass Kleinbuchstaben für alle Ebenen benutzt werden, und dann der zweiten Liste im aktiven Dokument zugewiesen.

Set mytemp = ListGalleries(wdOutlineNumberGallery).ListTemplates(1)
For each lev in mytemp.ListLevels
    lev.NumberStyle = wdListNumberStyleLowercaseLetter
Next lev
ActiveDocument.Lists(2).ApplyListTemplate ListTemplate:=mytemp

In diesem Beispiel wird die Anzahl der Listenvorlagen im aktiven Dokument angezeigt.

Msgbox ActiveDocument.ListTemplates.Count


ListType-Eigenschaft

Gibt die Listentypen zurück, die sich im Bereich für das angegebene ListFormat-Objekt befinden. Dabei kann es sich um eine der folgenden WdListType-Konstanten handeln: wdListBullet, wdListListNumOnly, wdListMixedNumbering, wdListNoNumbering, wdListOutlineNumbering oder wdListSimpleNumbering. Long Nur-Lese-Zugriff.

Anmerkungen

Die wdListListNumOnly-Konstante bezieht sich auf LISTNUM-Felder. Das sind Felder, die in den Text eines Absatzes eingefügt werden können.


Beispiel zur ListType-Eigenschaft

Dieses Beispiel überprüft, ob es sich bei der ersten Liste im aktiven Dokument um eine einfache nummerierte Liste handelt. Wenn ja, wird die vierte Listenvorlage auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungen zugewiesen.

Set myList = ActiveDocument.Lists(1)
If myList.Range.ListFormat.ListType = wdListSimpleNumbering Then
    myList.ApplyListTemplate _
        ListTemplate:=ListGalleries(wdNumberGallery) _
        .ListTemplates(4)
End If


ListValue-Eigenschaft

Gibt den numerischen Wert des ersten Absatzes im Bereich des angegebenen ListFormat-Objekts zurück. Wenn Sie z. B. die ListValue-Eigenschaft dem zweiten Absatz einer alphabetischen Liste zuweisen, wird 2 zurückgegeben. Long Nur-Lese-Zugriff.

Anmerkungen

Mit der ListString-Eigenschaft geben Sie eine Zeichenfolge zurück, die das Erscheinungsbild des Listenwerts darstellt.

Wenn es sich beim ListFormat-Objekt um eine Aufzählung handelt, gibt ListValue 1 zurück.

Wenn es sich beim ListFormat-Objekt um eine Gliederung handelt, gibt ListValue den numerischen Wert des ersten Absatzes zurück, wie er in der Reihenfolge der Absätze mit derselben Ebene auftritt. Wird z. B. die ListValue-Eigenschaft einem Absatz mit der Nummerierung "A.2" zugewiesen, wird 2 zurückgegeben.

Diese Eigenschaft gibt nicht den Wert für ein LISTNUM-Feld zurück.


Beispiel zur ListValue-Eigenschaft

In diesem Beispiel werden der numerische Wert des ersten Absatzes in der Auswahl und die Darstellung dieses Wertes als Zeichenfolge angezeigt.

v = Selection.Range.ListFormat.ListValue
lstring = Selection.Range.ListFormat.ListString
MsgBox "List value " & v _
    & " is represented by the string " & lstring


Location-Eigenschaft

Footnotes-Objekt: Gibt die Position aller Fußnoten zurück oder legt sie fest. Dabei kann es sich um die folgenden WdFootnoteLocation-Konstanten handeln: wdBottomOfPage oder wdBeneathText. Long Schreib-Lese-Zugriff.

Endnotes-Objekt: Gibt die Position aller Endnoten zurück oder legt sie fest. Dabei kann es sich um die folgenden WdEndnoteLocation-Konstanten handeln: wdEndOfSection oder wdEndOfDocument. Long Schreib-Lese-Zugriff.


Beispiel zur Location-Eigenschaft

In diesem Beispiel werden Fußnoten am Ende jeder Seite positioniert.

ActiveDocument.Footnotes.Location = wdBottomOfPage

In diesem Beispiel werden alle Endnoten am Ende von Abschnitten positioniert.

ActiveDocument.Endnotes.Location = wdEndOfSection


LockAnchor-Eigenschaft

Frame-Objekt: True, wenn der angegebene Positionsrahmen gesperrt ist. Die Positionsrahmenverankerung zeigt an, wo der Positionsrahmen in der Normalansicht erscheint. Sie können eine gesperrte Positionsrahmenverankerung nicht neu positionieren. Boolean Schreib-Lese-Zugriff.

Shape- oder ShapeRange-Objekt: True, wenn die Verankerung des angegebenen Shape- oder ShapeRange-Objekts mit dem Verankerungsbereich gesperrt ist. Sie können die Verankerung einer Form nicht durch Ziehen verschieben (die Verankerung bewegt sich nicht, wenn die Form verschoben wird), wenn die Verankerung der Form gesperrt ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ein Shape-Objekt ist mit einem Textbereich verankert, aber Sie können es an beliebiger Stelle der Seite positionieren. Die Form ist mit dem Anfang des ersten Absatzes verankert, der den Verankerungsbereich enthält. Eine Form bleibt immer auf derselben Seite wie ihre Verankerung.


Beispiel zur LockAnchor-Eigenschaft

In diesem Beispiel wird die Verankerung des ersten Positionsrahmens in Abschnitt 2 des aktiven Dokuments gesperrt.

Set myRange = ActiveDocument.Sections(2).Range
If TypeName(myRange) <> "Nothing" And myRange.Frames.Count > 0 Then
    myRange.Frames(1).LockAnchor = True
End If

In diesem Beispiel wird ein neues Dokument erstellt. Eine Form wird hinzugefügt und anschließend die Verankerung der Form gesperrt.

Set myDoc = Documents.Add
Set myShape = myDoc.Shapes.AddShape(msoShapeBalloon, _
    100, 100, 140, 70)
myShape.LockAnchor = True
ActiveDocument.ActiveWindow.View.ShowObjectAnchors = True

In diesem Beispiel wird eine Meldung zurückgegeben, die den Sperrstatus für alle Formen im aktiven Dokument angibt.

For x = 1 to ActiveDocument.Shapes.Count
    Msgbox "Shape " & x & " is locked - " _
        & ActiveDocument.Shapes(x).LockAnchor
Next x


LockAspectRatio-Eigenschaft

True, wenn die angegebene Form beim Ändern ihrer Größe die ursprünglichen Proportionen beibehält. False, wenn man bei der Größenänderung die Höhe und Breite der Form unabhängig voneinander ändern kann. Long Schreib-Lese-Zugriff.


Beispiel zur LockAspectRatio-Eigenschaft

In diesem Beispiel wird zu myDocument ein Würfel hinzugefügt. Der Würfel kann verschoben und in seiner Größe verändert werden, aber das Verhältnis von Höhe zu Breite kann nicht geändert werden.

Set myDocument = ActiveDocument
myDocument.Shapes.AddShape(msoShapeCube, _
    50, 50, 100, 200).LockAspectRatio = True


Locked-Eigenschaft

Subdocument-Objekt: True, wenn ein Filialdokument in einem Zentraldokument geschützt ist. Boolean Schreib-Lese-Zugriff.

LinkFormat-Objekt: True, wenn ein Field-, InlineShape- oder Shape-Objekt geschützt ist, damit es nicht automatisch aktualisiert wird. Ein Fehler tritt auf, wenn Sie diese Eigenschaft einem Shape-Objekt zuweisen, bei dem es sich um ein unverankertes verknüpftes Bild handelt (d. h. um ein Bild, das mit der AddPicture-Methode des Shapes-Objekts hinzugefügt wurde). Boolean Schreib-Lese-Zugriff.

Field oder MailMergeField-Objekt: True, wenn das angegebene Feld geschützt ist. Sie können die Ergebnisse von geschützten Feldern nicht aktualisieren. Boolean Schreib-Lese-Zugriff.

Fields-Objekt: True, wenn alle Felder in der Fields-Auflistung geschützt sind. Kann die Werte True, False oder wdUndefined (wenn einige Felder in der Auflistung geschützt sind) annehmen. Long Schreib-Lese-Zugriff.


Beispiel zur Locked-Eigenschaft

In diesem Beispiel wird das erste Filialdokument im angegebenen Zentraldokument überprüft. Das Zentraldokument wird so eingestellt, dass ein geschütztes Filialdokument nur mit Anmerkungen versehen werden darf.

If ActiveDocument.Subdocuments(1).Locked = True Then
    ActiveDocument.Protect Type:=wdAllowOnlyComments
End If

In diesem Beispiel wird ein DATE-Feld am Anfang der Auswahl eingefügt, dann wird das Feld geschützt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldDate)
myField.Locked = True

In diesem Beispiel werden alle Felder in der Auswahl geschützt.

Selection.Fields.Locked = True

In diesem Beispiel wird eine Meldung angezeigt, wenn einige Felder im aktiven Dokument geschützt sind.

Set theFields = ActiveDocument.Fields
If theFields.Locked = wdUndefined Then
    MsgBox "Some fields are locked"
ElseIf theFields.Locked = False Then
    MsgBox "No fields are locked"
ElseIf theFields.Locked = True Then
    MsgBox "All fields are locked"
End If


LowerHeadingLevel-Eigenschaft

Gibt die End-Überschriftsebene für ein Inhaltsverzeichnis oder Abbildungsverzeichnis zurück oder legt sie fest. Entspricht dem Endwert, der mit dem Schalter \o für ein TOC-Feld verwendet wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie die UpperHeadingLevel Eigenschaft, wenn die Start-Überschriftsebene festgelegt werden soll. Soll beispielsweise die Syntax für das TOC-Feld {TOC \o "1-3"} eingestellt werden, stellen Sie die LowerHeadingLevel-Eigenschaft auf 3 ein und die UpperHeadingLevel-Eigenschaft auf 1.


Beispiel zur LowerHeadingLevel-Eigenschaft

In diesem Beispiel wird im aktiven Dokument das erste Inhaltsverzeichnis so formatiert, dass Einträge angezeigt werden, die mit den Formatvorlagen Überschrift 2, Überschrift 3 oder Überschrift 4 formatiert sind.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .UseHeadingStyles = True
        .UpperHeadingLevel = 2
        .LowerHeadingLevel = 4
    End With
End If


MacroContainer-Eigenschaft

Gibt ein Template- oder Document-Objekt zurück, das eine Vorlage oder ein Dokument darstellt, in dem das Modul mit der laufenden Prozedur gespeichert ist. Nur-Lese-Zugriff.


Beispiel zur MacroContainer-Eigenschaft

In diesem Beispiel wird der Name des Dokuments oder der Vorlage, in dem sich das Modul mit der laufenden Prozedur befindet, gespeichert.

Set cntnr = MacroContainer
MsgBox cntnr.Name


Magnifier-Eigenschaft

True, wenn in der Seitenansicht der Mauszeiger als Vergrößerungsglas dargestellt wird und damit anzeigt, dass der Benutzer in einen bestimmten Seitenbereich klicken kann, um diesen zu vergrößern, oder um den Bereich zu verkleinern, damit eine oder mehrere ganze Seiten zu sehen sind. Boolean Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft erzeugt einen Fehler, wenn die Ansicht nicht die Seitenansicht ist.


Beispiel zur Magnifier-Eigenschaft

In diesem Beispiel wird zur Seitenansicht umgeschaltet und der Mauszeiger in eine Einfügemarke umgewandelt.

PrintPreview = True
ActiveDocument.ActiveWindow.View.Magnifier = False


MailAddressFieldName-Eigenschaft

Gibt den Namen des Felds mit der E-Mail-Adresse, die benutzt wird, wenn als Seriendruckziel elektronische Post bestimmt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur MailAddressFieldName-Eigenschaft

In diesem Beispiel wird das Dokument "Formbrief.doc" mit dem zugeordneten Datendokument verbunden. Die Ergebnisse werden an die E-Mail-Adressen im Seriendruckfeld "E-Mail" gesandt.

With Documents("Form Letter.doc").MailMerge
    .MailAddressFieldName = "Email"
    .MailSubject = "Amazing offer"
    .Destination = wdSendToEmail
    .Execute
End With


MailAsAttachment-Eigenschaft

True, wenn Seriendruckdokumente, deren Seriendruckziel eine E-Mail-Meldung oder ein Fax ist, als Anlagen versendet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur MailAsAttachment-Eigenschaft

In diesem Beispiel wird eine Seriendruckoperation ausgeführt, und die Ergebnisse werden als Anlagen zu E-Mail-Nachrichten versandt. Die E-Mail-Adressen werden im Seriendruckfeld "E-Mail_adr" gespeichert.

With Documents("Main.doc").MailMerge
    .MailAsAttachment = True
    .Destination = wdSendToEmail
    .MailSubject = "Special offer"
    .MailAddressFieldName = "MailAddress"
    .Execute
End With


MailingInstructions-Eigenschaft

Gibt den Text der Versandanweisungen (z. B. "Einschreiben") für einen Brief, der mit dem Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur MailingInstructions-Eigenschaft

In diesem Beispiel werden die Elemente des Brief-Assistenten aus dem aktiven Dokument geladen, der Text für die Versandanweisungen geändert, und anschließend wird mit der SetLetterContent-Methode das aktive Dokument aktualisiert, um die Änderungen zu reflektieren.

Set myLetterContent = ActiveDocument.GetLetterContent
myLetterContent.MailingInstructions = "Air Mail"
ActiveDocument.SetLetterContent LetterContent:=myLetterContent

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften (einschließlich des Textes für die Versandanweisungen) werden festgelegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
With myContent
    .RecipientReference = "In reply to:"
    .Salutation ="Hello"
    .MailingInstructions = "Certified Mail"
End With
Documents.Add.RunLetterWizard LetterContent:=myContent


MailingLabel-Eigenschaft

Gibt ein MailingLabel-Objekt zurück, das ein Adressetikett darstellt. Nur-Lese-Zugriff.


Beispiel zur MailingLabel-Eigenschaft

In diesem Beispiel wird ein neues Avery 42-121 - Computer-Etikett-Dokument erstellt, das eine vordefinierte Adresse verwendet.

addr = "Dave Edson" & vbCr & "123 Skye St." _
    & vbCr & "Our Town, WA  98004"
Application.MailingLabel.CreateNewDocument _
    Name:="2160 mini", Address:=addr, ExtractAddress:=False


MailMerge-Eigenschaft

Gibt ein MailMerge-Objekt zurück, das die Seriendruckfunktionalität für das angegebene Dokument darstellt. Nur-Lese-Zugriff.

Hinweis Das MailMerge-Objekt steht zur Verfügung, unabhängig davon, ob es sich beim angegebenen Dokument um ein Seriendruck-Hauptdokument handelt. Mit der State-Eigenschaft ermitteln Sie den aktuellen Status des Seriendruckvorgangs.


MailMergeDataView-Eigenschaft

True, wenn Seriendruckdaten anstelle von Seriendruckfeldern im angegebenen Fenster angezeigt werden. Boolean Schreib-Lese-Zugriff.

Hinweis Wenn es sich beim angegebenen Fenster nicht um ein Hauptdokument handelt, tritt ein Fehler auf.


Beispiel zur MailMergeDataView-Eigenschaft

Wenn sich im aktiven Dokument mindestens ein Seriendruckfeld befindet, werden in diesem Beispiel die Seriendruckdaten aus dem ersten Datensatz der verbundenen Datenquelle angezeigt.

If ActiveDocument.MailMerge.Fields.Count >= 1 Then
    ActiveDocument.MailMerge.DataSource.ActiveRecord = 1
    ActiveDocument.ActiveWindow.View.ShowFieldCodes = False
    ActiveDocument.ActiveWindow.View.MailMergeDataView = True
End If

In diesem Beispiel wird zwischen der Anzeige der Seriendruckfelder und der resultierenden Daten umgeschaltet.

With ActiveDocument.ActiveWindow.View
    .ShowFieldCodes = False
    .MailMergeDataView = Not .MailMergeDataView
End With


MailMessage-Eigenschaft

Gibt ein MailMessage-Objekt zurück, das die aktive E-Mail-Nachricht darstellt. Nur-Lese-Zugriff.


Beispiel zur MailMessage-Eigenschaft

In diesem Beispiel wird das Dialogfeld Namen auswählen für die aktive E-Mail-Nachricht angezeigt.

Application.MailMessage.DisplaySelectNamesDialog


MailSubject-Eigenschaft

Gibt die Themenzeile, die benutzt wird, wenn als Seriendruckziel elektronische Post bestimmt wurde, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur MailSubject-Eigenschaft

In diesem Beispiel wird das Dokument "Offer.doc" mit dem zugeordneten Datendokument verbunden. Die Ergebnisse werden an die E-Mail-Adressen im Seriendruckfeld EmailNamen gesandt. Das Thema der Meldung lautet "Amazing Offer".

With Documents("Offer.doc").MailMerge
    .MailAddressFieldName = "EmailNames"
    .MailSubject = "Amazing Offer"
    .Destination = wdSendToEmail
    .Execute
End With


MailSystem-Eigenschaft

Gibt das E-Mail-System (oder die Systeme) zurück, die auf dem Hostrechner installiert sind. Dabei kann es sich um eine der folgenden WdMailSystem-Konstanten handeln: wdMAPI, wdMAPIandPowerTalk, wdPowerTalk oder wdNoMailSystem. Long Nur-Lese-Zugriff.

Hinweise

Einige der oben aufgeführten Konstanten stehen nur in der Microsoft Office 98 Macintosh Edition zur Verfügung. Weitere Informationen zu diesen Konstanten finden Sie in der Hilfe für das Sprachverzeichnis, die in Microsoft Office 98 Macintosh Edition enthalten ist.


Beispiel zur MailSystem-Eigenschaft

In diesem Beispiel wird das auf dem Hostrechner installierte Mail-System angezeigt.

ms = Application.MailSystem
If ms <> wdNoMailSystem Then
    MsgBox "This machine has a mail system installed."
Else
    MsgBox "This machine has no mail system installed."
End If


MainDocumentType-Eigenschaft

Gibt den Typ des Seriendruckhauptdokuments zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden WdMailMergeMainDocType-Konstanten handeln: wdCatalog, wdEnvelopes, wdFormLetters, wdMailingLabels oder wdNotAMergeDocument. Long Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft für ein Dokument setzen, bei dem es sich bereits um ein Hauptdokument handelt, wird die zugeordnete Datenquelle entfernt.


Beispiel zur MainDocumentType-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und zu einem Katalog-Hauptdokument für einen Seriendruckvorgang gemacht.

Set myDoc = Documents.Add
myDoc.MailMerge.MainDocumentType = wdCatalog

In diesem Beispiel wird ermittelt, ob es sich beim aktiven Dokument um ein Hauptdokument für einen Seriendruckvorgang handelt, und dann wird eine Meldung in der Statusleiste angezeigt.

Set doc = ActiveDocument
If doc.MailMerge.MainDocumentType = wdNotAMergeDocument Then
    StatusBar = "Not a mail merge main document"
Else
    StatusBar = "Document is a mail merge main document."
End If


MAPIAvailable-Eigenschaft

True, wenn MAPI installiert ist. Boolean Nur-Lese-Zugriff.


Beispiel zur MAPIAvailable-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn MAPI installiert ist.

If Application.MAPIAvailable = True Then
    MsgBox "MAPI is available"
End If


MapPaperSize-Eigenschaft

True, wenn für das Standard-Papierformat eines anderen Landes (z. B. Letter) formatierte Dokumente automatisch angepasst werden, damit sie korrekt auf dem Standard-Papierformat ihrer Ländereinstellung (z. B. A4) gedruckt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft betrifft nur den Ausdruck des Dokuments, die Formatierung bleibt unverändert.


Beispiel zur MapPaperSize-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word das Papierformat entsprechend der Ländereinstellung anpasst.

Options.MapPaperSize = True

In diesem Beispiel wird der Status der Option Anpassen auf A4/US Letter auf der Registerkarte Drucken im Dialogfeld Optionen (Menü Extras) zurückgegeben.

temp = Options.MapPaperSize


MarginBottom-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der Unterkante des Textrahmens und der Unterkante des einbeschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginBottom-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dem Rechteck Text hinzugefügt. Dann werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der linken Kante des Textrahmens und der linken Kante des einbeschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginLeft-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dem Rechteck Text. Dann werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginRight-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der rechten Kante des Textrahmens und der rechten Kante des einbeschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginRight-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dem Rechteck Text. Dann werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der Oberkante des Textrahmens und der Oberkante des einbeschriebenen Rechtecks der Form, die den Text enthält, zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginTop-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und dem Rechteck Text. Dann werden die Ränder für den Textrahmen festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarkComments-Eigenschaft

True, wenn Microsoft Word die Benutzerkommentare in E-Mail-Nachrichten markiert. Boolean Lese-Schreib-Zugriff.

Hinweise

Diese Eigenschaft markiert die Kommentare mit dem Wert der MarkCommentsWith-Eigenschaft. Der Standardwert der MarkCommentsWith-Eigenschaft ist der Wert für die UserName-Eigenschaft.


MarkCommentsWith-Eigenschaft

Gibt die Zeichenfolge zurück, mit der Microsoft Word Kommentare in E-Mail-Nachrichten markiert, oder legt diese fest. String Lese-Schreib-Zugriff.

Hinweise

Der Standardwert ist der Wert für die UserName-Eigenschaft.


Beispiel zur MarkCommentsWith-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word Kommentare in E-Mail-Nachrichten mit den Initialen "WK" markiert.

Application.EmailOptions.MarkCommentsWith = "WK"
Application.EmailOptions.MarkComments = True


MatchAlefHamza-Eigenschaft

Sprachspezifische Informationen

True if find operations match text with matching alef hamzas in an Arabic language document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur MatchAlefHamza-Eigenschaft

This example sets the current find operation to match alef hamzas.

Selection.Find.MatchAlefHamza = True


MatchAllWordForms-Eigenschaft

True, wenn beim Suchvorgang nach allen Formen des Suchtextes gesucht wird. Boolean Schreib-Lese-Zugriff.

Anmerkung Verwenden Sie die Text-Eigenschaft des Find-Objekts oder das FindText-Argument mit der Execute-Methode, um den Text festzulegen, der in einem Dokument gesucht werden soll.


Beispiel zur MatchAllWordForms-Eigenschaft

In diesem Beispiel wird die nächste in der Markierung gefundene Form des Wortes "sit" markiert. Wenn keine Form des Wortes "sit" gefunden wird, wird eine Meldung angezeigt.

With Selection.Find
    .MatchAllWordForms = True
    .Text = "sit"
    .Execute Format:=False
    If .Found = False Then MsgBox "Not Found"
End With


MatchByte-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word distinguishes between full-width and half-width letters or characters during a search. Read/write Boolean.


Beispiel zur MatchByte-Eigenschaft

This example searches for the term " mikurosofato mikurosofato mikurosofato mikurosofato mikurosofato mikurosofato mikurosofato " in the specified range without distinguishing between full-width and half-width characters.

With Selection.Find
    .ClearFormatting
    .MatchWholeWord = True
    .MatchByte = False
    .Execute FindText:="  mikurosofato   mikurosofato   mikurosofato   mikurosofato   mikurosofato   mikurosofato   mikurosofato "
End With


MatchCase-Eigenschaft

True, wenn die Suchoperation Groß-/Kleinschreibung beachtet. Boolean Schreib-Lese-Zugriff.

Hinweis Verwenden Sie die Text-Eigenschaft des Find-Objekts oder verwenden Sie das Argument FindText mit der Execute-Methode zum Spezifizieren des Textes, der in einem Dokument gesucht werden soll.


Beispiel zur MatchCase-Eigenschaft

In diesem Beispiel wird in der Markierung das nächste Vorkommen des Wortes "lesen" ohne Beachtung der Groß-/Kleinschreibung markiert.

With Selection.Find
    .ClearFormatting
    .MatchWholeWord = True
    .MatchCase = False
    .Execute FindText:="library"
End With


MatchControl-Eigenschaft

Sprachspezifische Informationen

True if find operations match text with matching bidirectional control characters in a right-to-left language document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur MatchControl-Eigenschaft

This example sets the current find operation to match bidirectional control characters.

Selection.Find.MatchControl = True


MatchDiacritics-Eigenschaft

Sprachspezifische Informationen

True if find operations match text with matching diacritics in a right-to-left language document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur MatchDiacritics-Eigenschaft

This example sets the current find operation to match diacritics.

Selection.Find.MatchDiacritics = True


MatchFuzzy-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word uses the nonspecific search options for Japanese text during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


MatchFuzzyAY-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " a " and " ya " following i -row and e -row characters during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyAY-Eigenschaft

This example sets Microsoft Word to ignore the distinction between " a " and " ya " following i -row and e -row characters during a search.

Options.MatchFuzzyAY = True


MatchFuzzyBV-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " ba " and " vua vua " and between " ha " and " fua fua " during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyBV-Eigenschaft

This example sets Microsoft Word to ignore the distinction between " ba " and " vua vua " and between " ha " and " fua fua " during a search.

Options.MatchFuzzyBV = True


MatchFuzzyByte-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between full-width and half-width characters (Latin or Japanese) during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


MatchFuzzyByte-Eigenschaft Example

This example sets Microsoft Word to ignore the distinction between full-width and half-width characters (Latin or Japanese) during a search.

Options.MatchFuzzyByte = True


MatchFuzzyCase-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between uppercase and lowercase letters during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyCase-Eigenschaft

This example sets Microsoft Word to ignore the distinction between uppercase and lowercase letters during a search.

Options.MatchFuzzyCase = True


MatchFuzzyDash-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between minus signs, long vowel sounds, and dashes during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyDash-Eigenschaft

This example sets Microsoft Word to ignore the distinction between minus signs, long vowel sounds, and dashes during a search.

Options.MatchFuzzyDash = True


MatchFuzzyDZ-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " di " and " zi " and between " du " and " zu " during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


MatchFuzzyDZ-Eigenschaft Example

This example sets Microsoft Word to ignore the distinction between " di " and " zi " and between " du " and " zu " during a search.

Options.MatchFuzzyDZ = True


MatchFuzzyHF-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " heyu heyu " and " fuyu fuyu " and between " beyu beyu " and " vuyu vuyu " during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


MatchFuzzyHF-Eigenschaft Example

This example sets Microsoft Word to ignore the distinction between " heyu heyu " and " fuyu fuyu " and between " beyu beyu " and " vuyu vuyu " during a search.

Options.MatchFuzzyHF = True


MatchFuzzyHiragana-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between hiragana and katakana during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyHiragana-Eigenschaft

This example sets Microsoft Word to ignore the distinction between hiragana and katakana during a search.

Options.MatchFuzzyHiragana = True


MatchFuzzyIterationMark-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between types of repetition marks during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyIterationMark-Eigenschaft

This example sets Microsoft Word to ignore the distinction between types of repetition marks during a search.

Options.MatchFuzzyIterationMark = True


MatchFuzzyKanji-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between standard and nonstandard kanji ideography during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyKanji-Eigenschaft

This example sets Microsoft Word to ignore the distinction between standard and nonstandard kanji ideography during a search.

Options.MatchFuzzyKanji = True


MatchFuzzyKiKu-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " ki " and " ku " before sa -row characters during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyKiKu-Eigenschaft

This example sets Microsoft Word to ignore the distinction between " ki " and " ku " before sa -row characters during a search.

Options.MatchFuzzyKiKu = True


MatchFuzzyOldKana-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between new kana and old kana characters during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyOldKana-Eigenschaft

This example sets Microsoft Word to ignore the distinction between new kana and old kana characters during a search.

Options.MatchFuzzyOldKana = True


MatchFuzzyProlongedSoundMark-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between short and long vowel sounds during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyProlongedSoundMark-Eigenschaft

This example sets Microsoft Word to ignore the distinction between short and long vowel sounds during a search.

Options.MatchFuzzyProlongedSoundMark = True


MatchFuzzyPunctuation-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between types of punctuation marks during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyPunctuation-Eigenschaft

This example sets Microsoft Word to ignore the distinction between types of punctuation marks during a search

Options.MatchFuzzyPunctuation = True


MatchFuzzySmallKana-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between diphthongs and double consonants during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzySmallKana-Eigenschaft

This example sets Microsoft Word to ignore the distinction between diphthongs and double consonants during a search.

Options.MatchFuzzySmallKana = True


MatchFuzzySpace-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between space markers used during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzySpace-Eigenschaft

This example sets Microsoft Word to ignore the distinction between space markers used during a search.

Options.MatchFuzzySpace = True


MatchFuzzyTC-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " tsui tsui ", " tei tei ", and " chi ", and between " dei dei " and " ji " during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyTC-Eigenschaft

This example sets Microsoft Word to ignore the distinction between " tsui tsui ", " tei tei ", and " chi ", and between " dei dei " and " ji " during a search.

Options.MatchFuzzyTC = True


MatchFuzzyZJ-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word ignores the distinction between " se " and " shie shie " and between " ze " and " jie jie " during a search. Read/write Boolean.

Remarks

For more information on Japanese nonspecific search options, see Nonspecific search options for Japanese text.


Beispiel zur MatchFuzzyZJ-Eigenschaft

This example sets Microsoft Word to ignore the distinction between " se " and " shie shie " and between " ze " and " jie jie " during a search.

Options.MatchFuzzyZJ = True


MatchKashida-Eigenschaft

Sprachspezifische Informationen

True if find operations match text with matching kashidas in an Arabic language document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur MatchKashida-Eigenschaft

This example sets the current find operation to match kashidas.

Selection.Find.MatchKashida = True


MatchSoundsLike-Eigenschaft

True, wenn beim Suchvorgang auch nach Wörtern mit einer ähnlichen Schreibweise wie der Suchtext gesucht wird. Boolean Schreib-Lese-Zugriff.

Anmerkung Verwenden Sie die Text-Eigenschaft des Find-Objekts oder das FindText-Argument mit der Execute-Methode, um den Text festzulegen, der in einem Dokument gesucht werden soll.


Beispiel zur MatchSoundsLike-Eigenschaft

In diesem Beispiel wird das nächste Wort in der Markierung markiert, das eine ähnliche Schreibweise wie das Wort "fun" aufweist (beispielsweise "funny").

With Selection.Find
    .ClearFormatting
    .Text = "fun"
    .MatchFuzzy = False
    .MatchSoundsLike = True
    .Execute Format:=False, Forward:=True, Wrap:=wdFindContinue
End With


MatchWholeWord-Eigenschaft

True, wenn die Suchoperation nur ganze Wörter sucht und keinen Text, der Teil eines größeren Wortes ist. Boolean Schreib-Lese-Zugriff.

Hinweis Verwenden Sie die Text-Eigenschaft des Find-Objekts oder verwenden Sie das Argument FindText mit der Execute-Methode zum Spezifizieren des Textes, der in einem Dokument gesucht werden soll.


Beispiel zur MatchWholeWord-Eigenschaft

In diesem Beispiel wird die Formatierung von den Such- und Ersetzen-Kriterien entfernt, bevor im gesamten aktiven Dokument das Wort "Kap." durch "Kapitel" ersetzt wird.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Replacement.ClearFormatting
    .MatchWholeWord = True
    .Execute FindText:="Inc.", _
        ReplaceWith:="incorporated", Replace:=wdReplaceAll
End With


MatchWildcards-Eigenschaft

True, wenn der zu suchende Text Platzhalter für die Suche enthält. Entspricht dem Kontrollkästchen Mit Mustervergleich im Dialogfeld Suchen und Ersetzen (Menü Bearbeiten). Boolean Schreib-Lese-Zugriff.

Anmerkung Verwenden Sie die Text-Eigenschaft des Find-Objekts oder das Argument FindText der Execute-Methode zum Festlegen des Textes, der in einem Dokument gesucht werden soll.


Beispiel zur MatchWildcards-Eigenschaft

In diesem Beispiel wird das nächste Wort mit drei Buchstaben, das mit einem "s" anfängt und mit "t" aufhört, gesucht und markiert.

With Selection.Find
    .ClearFormatting
    .Text = "s?t"
    .MatchAllWordForms = False
    .MatchSoundsLike = False
    .MatchFuzzy = False
    .MatchWildcards = True
    .Execute Format:=False, Forward:=True
End With


MathCoprocessorAvailable-Eigenschaft

True, wenn ein mathematischer Koprozessor im System installiert wurde. Boolean Nur-Lese-Zugriff.


Beispiel zur MathCoprocessorAvailable-Eigenschaft

In diesem Beispiel wird eine Meldung mit dem Hinweis angezeigt, dass ein mathematischer Koprozessor im System installiert wurde.

If Application.MathCoprocessorAvailable = True Then
    MsgBox "A math coprocessor is installed."
Else
    MsgBox "A math coprocessor is not installed."
End If


MathCoprocessorInstalled-Eigenschaft

True, wenn ein mathematischer Koprozessor im System installiert wurde. Boolean Nur-Lese-Zugriff.


Beispiel zur MathCoprocessorInstalled-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, dass ein mathematischer Koprozessor im System installiert wurde.

If System.MathCoprocessorInstalled = True Then
    MsgBox "A math coprocessor is installed."
End If


Maximum-Eigenschaft

RecentFiles-Objekt: Gibt die maximale Anzahl der zuletzt verwendeten Dateien zurück, die im Menü Datei angezeigt werden können, oder legt sie fest. Dies kann eine Zahl von 0 (Null) bis 9 sein. Long Schreib-Lese-Zugriff.

Dictionaries-Objekt oder HangulHanjaConversionDictionaries-Objekt: Gibt die maximal zulässige Anzahl von Benutzer- oder Konvertierungswörterbüchern zurück. Long Nur-Lese-Zugriff.


Beispiel zur Maximum-Eigenschaft

In diesem Beispiel wird die Liste der zuletzt verwendeten Dateien deaktiviert.

RecentFiles.Maximum = 0

Dieses Beispiel gibt eine Meldung aus, wenn die Anzahl der Benutzerwörterbücher der maximal zulässigen Anzahl entspricht. Ist die maximale Anzahl nicht erreicht, wird ein mit "MeinWörterbuch.dic" benanntes Benutzerwörterbuch hinzugefügt.

If CustomDictionaries.Count = CustomDictionaries.Maximum Then
    MsgBox "Cannot add another dictionary file"
Else
    CustomDictionaries.Add "MyDictionary.dic"
End If

In diesem Beispiel wird die Anzahl der Einträge in der Liste der zuletzt verwendeten Dateien um 1 erhöht.

num = RecentFiles.Maximum
If num <> 9 Then RecentFiles.Maximum = num + 1


MeaningCount-Eigenschaft

Gibt die Anzahl der Einträge in der Liste der Bedeutungen zurück, die im Thesaurus für das Wort oder den Ausdruck gefunden wurden. Gibt 0 (Null) zurück, wenn keine Bedeutungen gefunden wurden. Long Nur-Lese-Zugriff.

Anmerkungen

Jede Bedeutung stellt eine eindeutige Liste von Synonymen für das Wort oder den Ausdruck dar.

Die Listen der verwandten Wörter, verwandten Ausdrücke und Antonyme werden nicht als Einträge in der Liste der Bedeutungen mitgezählt.


Beispiel zur MeaningCount-Eigenschaft

In diesem Beispiel wird überprüft, ob irgendwelche Bedeutungen für die Markierung gefunden wurden. Wenn welche gefunden wurden, wird die Liste der Bedeutungen im Direktfenster des Visual Basic Editors angezeigt.

Set mySynInfo = Selection.Range.SynonymInfo
If mySynInfo.MeaningCount <> 0 Then
    myList = mySynInfo.MeaningList
    For i = 1 To Ubound(myList)
        Debug.Print myList(i)
    Next i
Else
    Msgbox "There were no meanings found."
End If


MeaningList-Eigenschaft

Gibt die Liste der Bedeutungen für das Wort oder den Ausdruck zurück. Die Liste wird als Zeichenfolgenbereich zurückgegeben. Variant Nur-Lese-Zugriff.

Anmerkungen

Die Listen der verwandten Wörter, verwandten Ausdrücke und Antonyme werden nicht als Einträge in der Liste der Bedeutungen mitgezählt.


Beispiel zur MeaningList-Eigenschaft

In diesem Beispiel wird überprüft, ob irgendwelche Bedeutungen für das dritte Wort in MyDoc.doc gefunden wurden. Wenn das der Fall ist, werden die Bedeutungen in einer Reihe von Meldungsfeldern angezeigt.

Set mySyn = Documents("MyDoc.doc").Words(3).SynonymInfo
If mySyn.MeaningCount <> 0 Then
    myList = mySyn.MeaningList
    For i = 1 To UBound(myList)
        Msgbox myList(i)
    Next i
Else
    Msgbox "There were no meanings found."
End If


MeasurementUnit-Eigenschaft

Gibt die Standard-Maßeinheit für Word zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdMeasurementUnits-Konstanten handeln: wdCentimeters, wdInches, wdMillimeters, wdPicas oder wdPoints. Long Schreib-Lese-Zugriff.


Beispiel zur MeasurementUnit-Eigenschaft

In diesem Beispiel wird die Standard-Maßeinheit für Word als Punkte festgelegt.

Options.MeasurementUnit = wdPoints

In diesem Beispiel wird die aktuelle Maßeinheit zurückgegeben, die auf der Registerkarte Allgemein im Dialogfeld Optionen gewählt wurde.

CurrUnit = Options.MeasurementUnit


Message-Eigenschaft

Gibt den Meldungstext für die angegebene Verteilerliste zurück oder legt sie fest. Dieser Text ist der Textkörper der E-Mail-Nachricht, mit der das Dokument weitergeleitet wird. String Schreib-Lese-Zugriff.


Beispiel zur Message-Eigenschaft

In diesem Beispiel wird das aktive Dokument mit einer Verteilerliste versehen, Thema und Textkörper festgelegt, ein Empfänger hinzugefügt und dann das Dokument verteilt.

ActiveDocument.HasRoutingSlip = True
With ActiveDocument.RoutingSlip
    .Subject = "Status Doc"
    .Message = "Please fill in your status."
    .AddRecipient Recipient:="Kate Dresen"
End With
ActiveDocument.Route

Wenn das Dokument "Monatsbericht" mit einer Verteilerliste versehen wurde, wird in diesem Beispiel der Meldungstext angezeigt.

Set myDoc = Documents("Monthly Report.doc")
If myDoc.HasRoutingSlip = True _
    Then MsgBox myDoc.RoutingSlip.Message


MinimumFontSize-Eigenschaft

Gibt den kleinsten Schriftgrad (in Punkt) zurück, der im angegebenen Fensterausschnitt angezeigt wird, oder legt diesen fest. Long Schreib-Lese-Zugriff.

Anmerkung Diese Eigenschaft wirkt sich nur auf die Anzeige von Text in der Weblayoutansicht aus. Die Schriftgrade, die auf der Befehlsleiste Format angezeigt und beim Drucken verwendet werden, werden nicht geändert.


Beispiel zur MinimumFontSize-Eigenschaft

Dieses Beispiel legt die Online-Ansicht für das aktive Fenster und anschließend 12 Punkt als Mindestschriftgrad für den aktiven Ausschnitt fest.

With ActiveDocument.ActiveWindow
    .View.Type = wdWebView
    .ActivePane.MinimumFontSize = 12
End With

Dieses Beispiel gibt den Mindestschriftgrad für den aktiven Ausschnitt zurück.

Msgbox _
    ActiveDocument.ActiveWindow.ActivePane.MinimumFontSize


MirrorMargins-Eigenschaft

True, wenn bei gegenüberliegenden Seiten die inneren Seitenränder gleich breit und die äußeren Seitenränder gleich breit sind. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die MirrorMargins-Eigenschaft auf True gesetzt ist, steuert die LeftMargin-Eigenschaft die Einstellung für innere Seitenränder und die RightMargin-Eigenschaft die Einstellung für äußere Seitenränder.


Beispiel zur MirrorMargins-Eigenschaft

In diesem Beispiel werden im aktiven Dokument die inneren Seitenränder auf 1 Zoll (72 Punkt) festgelegt und die äußeren Seitenränder auf 0,5 Zoll. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

With ActiveDocument.PageSetup
    .MirrorMargins = True
    .LeftMargin = 72
    .RightMargin = InchesToPoints(0.5)
End With


Modified-Eigenschaft

True, wenn es sich bei der angegebenen Listenvorlage nicht um die integrierte Listenvorlage für diese Position im Listenkatalog handelt. Boolean Nur-Lese-Zugriff.

Syntax

Ausdruck.Modified(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListGallery-Objekt zurückgibt.

Index Long erforderlich. Eine Ziffer von 1 bis 7, die der Position der Dokumentvorlage im Dialogfeld Nummerierung und Aufzählungen entspricht. Wenn Sie die Option Ohne überspringen, werden die Dokumentvorlagen, von links nach rechts, beginnend mit der obersten Zeile, nummeriert.

Anmerkungen

Mit der Reset-Methode setzen Sie eine Listenvorlage aus dem Listenkatalog auf die integrierte Listenvorlage zurück.


Beispiel zur Modified-Eigenschaft

In diesem Beispiel wird überprüft, ob die erste Vorlage auf der Registerkarte Aufzählungen im Dialogfeld Nummerierung und Aufzählungen geändert wurde. Falls ja, wird die Listenvorlage zurückgesetzt.

temp = ListGalleries(wdBulletGallery).Modified(1)
If temp = True Then
    ListGalleries(wdBulletGallery).Reset(1)
Else
   Msgbox "This is the built-in list template."
End If


MonthNames-Eigenschaft

Sprachspezifische Informationen

Returns or sets how Microsoft Word displays western month names in Arabic. Can be one of the following WdMonthNames constants: wdMonthNamesArabic, wdMonthNamesEnglish, or wdMonthNamesFrench. Read/write Long.

Remarks

For more information on using Word with right-to-left languages, see About right-to-left language features.


Beispiel zur MonthNames-Eigenschaft

This example sets Word to display western month names in English in an Arabic language document.

Options.MonthNames = wdMonthNamesEnglish


MouseAvailable-Eigenschaft

True, wenn für das System eine Maus verfügbar ist. Boolean Nur-Lese-Zugriff.


Beispiel zur MouseAvailable-Eigenschaft

In diesem Beispiel wird eine Meldung ausgegeben, wenn keine Maus verfügbar ist.

If Application.MouseAvailable = False Then
    Msgbox "Make sure your mouse is plugged in."
Else
    Msgbox "Mouse is available"
End If


MultipleWordConversionsMode-Eigenschaft

Sprachspezifische Informationen

Returns or sets the direction for conversion between hangul and hanja. Can be either of the following WdMultipleWordConversionsMode constants: wdHangulToHanja or wdHanjaToHangul. Read/write Long.

Remarks

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur MultipleWordConversionsMode-Eigenschaft

This example sets Microsoft Word to convert from hangul to hanja by default.

Options.MultipleWordConversionsMode = wdHangulToHanja


Name-Eigenschaft

Gibt den Namen für das angegebene Objekt zurück oder legt diesen fest, wie in der folgenden Tabelle beschrieben.

Objekt | Beschreibung
AddIn, Dictionary, Document, FileConverter, RecentFile, Subdocument, Template, MailMergeDataSource |  | Gibt den Dateinamen des Objekts zurück. String Nur-Lese-Zugriff.
Application |  | Gibt den Namen der Anwendung zurück (beispielsweise "Microsoft Word"). String Nur-Lese-Zugriff.
AutoCaption, CaptionLabel |  | Gibt den Namen der Beschriftung zurück. String Nur-Lese-Zugriff.
AutoCorrectEntry, AutoTextEntry |  | Gibt den Namen des AutoKorrektur- oder AutoText-Eintrags zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
Bookmark |  | Gibt den Namen der Textmarke zurück. String Nur-Lese-Zugriff.
CustomLabel |  | Gibt den Namen des benutzerdefinierten Adressetiketts zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
FirstLetterException, HangulAndAlphabetException, OtherCorrectionsException, TwoInitialCapsException |  | Gibt das Wort zurück, das eine Ausnahme für AutoKorrektur-Aktionen darstellt. String Nur-Lese-Zugriff.
Font |  | Gibt den Namen der Schriftart zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
FormField |  | Gibt den Namen des Formularfeldes zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
Language |  | Gibt den Namen der Sprache der Korrekturhilfen zurück. String Nur-Lese-Zugriff.
ListEntry |  | Gibt den Namen des Elements des Dropdownformularfeldes zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
ListTemplate |  | Gibt einen optionalen Namen für die Listenvorlage zurück oder legt diesen fest. Dieser kann in Verbindung mit der Name-Anweisung eines LISTNUM-Feldes verwendet werden. String Schreib-Lese-Zugriff.
MailMergeDataField, MailMergeFieldName |  | Gibt den Namen des Seriendruckfeldes zurück. String Nur-Lese-Zugriff.
MailMergeDataSource |  | Gibt den vollständigen Namen der Datenquelle zurück. String Nur-Lese-Zugriff.
Shape, ShapeRange |  | Gibt den Namen der Form zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
Hyperlink |  | Gibt den angezeigten Namen des Hyperlink zurück (so wie er im Verlaufsordner angezeigt wird). String Nur-Lese-Zugriff.
ReadabilityStatistic |  | Gibt den Namen der Lesbarkeitsstatistik zurück. String Nur-Lese-Zugriff.
SpellingSuggestion |  | Gibt den Rechtschreibvorschlag zurück. String Nur-Lese-Zugriff.
TableOfAuthoritiesCategory |  | Gibt den Namen der Kategorie des Rechtsgrundlagenverzeichnisses zurück oder legt diesen fest. String Schreib-Lese-Zugriff.
Task |  | Gibt den Namen der Aufgabe zurück. String Nur-Lese-Zugriff.
Variable |  | Gibt den Namen der Dokumentvariable zurück. String Nur-Lese-Zugriff.


NameAscii-Eigenschaft

Gibt die Schriftart zurück, die für westlichen Text (Zeichen mit Zeichencodes von 0 (Null) bis 127) verwendet wird oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweise

In der US-Englisch-Version von Microsoft Word ist der Standardwert dieser Eigenschaft Times New Roman. Verwenden Sie die Name-Eigenschaft zum Ändern der Schriftart, die dem gesamten Text zugewiesen wurde und auf der Symbolleiste Format im Feld Schriftart angezeigt wird.


Beispiel zur NameAscii-Eigenschaft

In diesem Beispiel wird die Schriftart für westlichen Text festgelegt.

Selection.Font.NameAscii = "Century"


NameBi-Eigenschaft

Sprach-spezifische Informationen

Returns or sets the name of the font in a right-to-left language document. Read/write String.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur NameBi-Eigenschaft

This example formats the selection with Arial font.

With Selection.Font
    .NameBi = "Arial"
End With


NameFarEast-Eigenschaft

Gibt einen ostasiatischen Schriftartnamen zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Hinweise

In der US-englischen Version von Microsoft Word ist der Standardwert dieser Eigenschaft "Times New Roman". Dies empfiehlt sich, um die Schriftart für Text in einer ostasiatischen Sprache in einem Dokument, das in einer ostasiatischen Version von Word erstellt wurde, zurückzugeben oder festzulegen.


Beispiel zur NameFarEast-Eigenschaft

In diesem Beispiel wird der fernöstliche Schriftartname angezeigt, der der Markierung zugewiesen wurde.

MsgBox Selection.Font.NameFarEast


NameLocal-Eigenschaft

Language-Objekt: Gibt den Namen einer Sprache der Korrekturhilfe in der Sprache des Benutzers zurück. String Nur-Lese-Zugriff.

Style-Objekt: Gibt den Namen einer integrierten Formatvorlage in der Sprache des Benutzers zurück. Durch die Festlegung dieser Eigenschaft wird eine benutzerdefinierte Formatvorlage umbenannt oder ein Alias zu einer integrierten Formatvorlage hinzugefügt. String Schreib-Lese-Zugriff.


Beispiel zur NameLocal-Eigenschaft

In diesem Beispiel wird der Name der Formatvorlage (in der Sprache des Benutzers) angezeigt, die den markierten Absätzen zugewiesen ist. Wenn der Markierung mehrere Formatvorlagen zugewiesen wurden, wird der Name der ersten Formatvorlage angezeigt.

MsgBox Selection.Paragraphs.Style.NameLocal

Im folgenden Beispiel wird der Name "MyH1" als Alias für die Formatvorlage "Überschrift1" im aktiven Dokument definiert.

ActiveDocument.Styles("Heading 1").NameLocal = "MyH1"

In diesem Beispiel wird die Formatvorlage "Test" in "Intro" umbenannt.

ActiveDocument.Styles("Test").NameLocal = "Intro"

In diesem Beispiel wird der Name der deutschen Sprache in zwei Versionen angezeigt – zuerst in der Sprache des Benutzers und dann auf deutsch.

MsgBox Languages(wdGerman).NameLocal
MsgBox Languages(wdGerman).Name


NameOther-Eigenschaft

Gibt die Schriftart zurück, die für Zeichen verwendet wird, deren Zeichencode zwischen 128 und 255 liegt, oder legt diese fest. String Schreib-Lese-Zugriff.

Hinweise

In der US-englischen-Version von Microsoft Word ist der Standardwert dieser Eigenschaft "Times New Roman". Verwenden Sie die Name-Eigenschaft zum Ändern der Schriftart, die dem gesamten Text zugewiesen wurde und deren Name auf der Symbolleiste Format im Feld Schriftart angezeigt wird.


Beispiel zur NameOther-Eigenschaft

In diesem Beispiel wird die Schriftart festgelegt, die für Zeichen verwendet wird, deren Zeichencode zwischen 128 und 255 liegt.

Selection.Font.NameOther = "Century"


NestingLevel-Eigenschaft

Gibt die Schachtelungsebene der angegebenen Zellen, Spalten, Zeilen oder Tabellen zurück. Long Nur-Lese-Zugriff.

Hinweise

Die oberste Tabelle liegt auf Schachtelungsbene 1. Die Ebene jeder folgenden geschachtelten Tabelle liegt um eins höher als die Ebene der vorhergehenden Tabelle.


Beispiel zur NestingLevel-Eigenschaft

In diesem Beispiel wird ein neues Dokument und dann eine geschachtelte Tabelle mit drei Ebenen erstellt. Anschließend wird in die erste Zelle jeder Tabelle die entsprechende Schachtelungsebene eingefügt.

Documents.Add
ActiveDocument.Tables.Add Selection.Range, _
    3, 3, wdWord9TableBehavior, wdAutoFitContent
With ActiveDocument.Tables(1).Range
    .Copy
    .Cells(1).Range.Text = .Cells(1).NestingLevel
    .Cells(5).Range.PasteAsNestedTable
    With .Cells(5).Tables(1).Range
        .Cells(1).Range.Text = .Cells(1).NestingLevel
        .Cells(5).Range.PasteAsNestedTable
        With .Cells(5).Tables(1).Range
            .Cells(1).Range.Text = _
                .Cells(1).NestingLevel
        End With
    End With
End With


NewMessageSignature-Eigenschaft

Gibt die Signatur zurück, die Microsoft Wort an neue E-Mail-Nachrichten anhängt, oder legt diese fest. String Schreib-Lese-Zugriff.

Hinweise

Beim Festlegen dieser Eigenschaft müssen Sie den Namen einer E-Mail-Signatur verwenden, die Sie im Dialogfeld E-Mail-Optionen erstellt haben. Auf dieses Dialogfeld können Sie im Menü Extras, Registerkarte Allgemein, Dialogfeld Optionen zugreifen.


Beispiel zur NewMessageSignature-Eigenschaft

In diesem Beispiel wird die Signatur geändert, die Word an neue ausgehende E-Mail-Nachrichten anhängt.

With Application.EmailOptions.EmailSignature
    .NewMessageSignature = "Signature1"
End With


Next-Eigenschaft

Gibt das nächste Objekt in der Auflistung zurück. Nur-Lese-Zugriff.


NextParagraphStyle-Eigenschaft

Gibt die Formatvorlage zurück oder legt sie fest, die automatisch einem neuen Absatz zugewiesen werden soll, der nach einem mit der angegebenen Formatvorlage formatierten Absatz eingefügt wurde. Zum Festlegen dieser Eigenschaft geben Sie entweder den lokalen Namen der nächsten Formatvorlage, eine ganze Zahl oder eine WdBuiltinStyle-Konstante an oder ein Objekt, das die nächste Formatvorlage darstellt. Variant Schreib-Lese-Zugriff.

Eine Liste der WdBuiltinStyle-Konstanten finden Sie unter Style-Eigenschaft.


Beispiel zur NextParagraphStyle-Eigenschaft

In diesem Beispiel wird festgelegt, dass im aktiven Dokument auf die Formatvorlage Überschrift 1 die Formatvorlage Überschrift 2 folgen soll.

ActiveDocument.Styles(wdStyleHeading1).NextParagraphStyle = _
    ActiveDocument.Styles(wdStyleHeading2)

In diesem Beispiel wird ein neues Dokument erstellt und eine Absatz-Formatvorlage namens "MeineFormatvorlage" hinzugefügt. Die neue Formatvorlage basiert auf der Formatvorlage Normal, im nächsten Absatz folgt die Formatvorlage Überschrift 3, die neue Formatvorlage hat einen linken Einzug von 1 Zoll (72 Punkt) und ist fett.

Set myDoc = Documents.Add
Set myStyle = myDoc.Styles.Add(Name:= "MyStyle")
    With myStyle
        .BaseStyle = wdStyleNormal
        .NextParagraphStyle = wdStyleHeading3
        .ParagraphFormat.LeftIndent = 72
        .Font.Bold = True
    End With


 NextStoryRange-Eigenschaft

NextStoryRange-Eigenschaft

Gibt ein Range-Objekt zurück, das sich auf die nächste Dokumentkomponente bezieht, wie in der folgenden Tabelle zu sehen ist. Nur-Lese-Zugriff.

Art der Dokumentkomponente | Element, das von der NextStoryRange-Methode zurückgegeben wird
wdMainTextStory, wdFootnotesStory, wdEndnotesStory und wdCommentsStory | Gibt immer Nothing zurück
wdTextFrameStory | Die Dokumentkomponente des nächsten Satzes von verknüpften Textfeldern
wdEvenPagesHeaderStory, wdPrimaryHeaderStory, wdEvenPagesFooterStory, wdPrimaryFooterStory, wdFirstPageHeaderStory, wdFirstPageFooterStory | Die Dokumentkomponente des nächsten Abschnitts derselben Art


Beispiel zur NextStoryRange-Eigenschaft

In diesem Beispiel wird im aktiven Dokument in den ersten zwei Abschnitten den geraden Kopfzeilen Text hinzugefügt.

If ActiveDocument.Sections.Count >= 2 Then
    With ActiveDocument
        .PageSetup.OddAndEvenPagesHeaderFooter = True
        .Sections(1).Headers(wdHeaderFooterEvenPages) _
            .Range.Text = "Even Header"
        .Sections(2).Headers(wdHeaderFooterEvenPages) _
            .LinkToPrevious = False
        .StoryRanges(wdEvenPagesHeaderStory) _
            .NextStoryRange.Text = "Even Header 2"
    End With
End If

In diesem Beispiel wird im aktiven Dokument jede Dokumentkomponente nach dem Text "Microsoft Word" durchsucht. In dem Beispiel wird auch jeder gefundenen Textstelle Kursivformatierung zugewiesen.

For Each myStoryRange In ActiveDocument.StoryRanges
    myStoryRange.Find.Execute  _
        FindText:="Microsoft Word", Forward:=True
    While myStoryRange.Find.Found
        myStoryRange.Italic = True
        myStoryRange.Find.Execute  _
            FindText:="Microsoft Word", Forward:=True
    Wend
    While Not (myStoryRange.NextStoryRange Is Nothing)
        Set myStoryRange = myStoryRange.NextStoryRange
        myStoryRange.Find.Execute  _
            FindText:="Microsoft Word", Forward:=True
        While myStoryRange.Find.Found
            myStoryRange.Italic = True
            myStoryRange.Find.Execute  _
                FindText:="Microsoft Word", Forward:=True
        Wend
    Wend
Next myStoryRange


Nodes-Eigenschaft

Gibt eine ShapeNodes-Auflistung zurück, die die geometrische Beschreibung der angegebenen Form darstellt. Betrifft Shape- oder ShapeRange-Objekte, die Freihandfiguren darstellen.


Beispiel zur Nodes-Eigenschaft

In diesem Beispiel wird in myDocument in Form drei nach Knoten vier ein Übergangsknoten mit einem gekrümmten Abschnitt hinzugefügt. Form drei muss eine Freihandfigur mit mindestens vier Knoten sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With


NoLineBreakAfter-Eigenschaft

Sprach-spezifische Informationen

Returns or sets the kinsoku characters after which Microsoft Word will not break a line. Read/write String.


Beispiel zur NoLineBreakAfter-Eigenschaft

This example sets "$", "(", "[", "\", and "{" as the kinsoku characters after which Microsoft Word will not break a line in the active document.

ActiveDocument.NoLineBreakAfter = "$([\{"


NoLineBreakBefore-Eigenschaft

Sprach-spezifische Informationen

Returns or sets the kinsoku characters before which Microsoft Word will not break a line. Read/write String.


Beispiel zur NoLineBreakBefore-Eigenschaft

This example sets "!", ")", and "]" as the kinsoku characters before which Microsoft Word will not break a line in the active document.

ActiveDocument.NoLineBreakBefore = "!)]"


NoLineNumber-Eigenschaft

True, wenn Zeilennummern für angegebene Absätze unterdrückt werden. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.

Hinweise

Mit der LineNumbering-Eigenschaft setzen Sie Zeilennummern.


Beispiel zur NoLineNumber-Eigenschaft

In diesem Beispiel wird die Zeilennummerierung für das aktive Dokument aktiviert. Die Startnummer wird auf 1 gesetzt, und die Nummerierung ist in allen Bereichen des Dokuments fortlaufend. Die Zeilennummerierung wird dann für den zweiten Absatz unterdrückt.

With ActiveDocument.PageSetup.LineNumbering
    .Active = True
    .StartingNumber = 1
    .CountBy = 1
    .RestartMode = wdRestartContinuous
End With
ActiveDocument.Paragraphs(2).NoLineNumber = True


NoProofing-Eigenschaft

Find- oder Replacement-Objekt: True, wenn Microsoft Word Text sucht oder ersetzt, den die Rechtschreib- und Grammatikprüfung ignoriert. Long Schreib-Lese-Zugriff.

Range- oder Selection-Objekt: True, wenn die Rechtschreib- und Grammatikprüfung den angegebenen Text ignoriert. Gibt wdUndefined zurück, wenn die NoProofing-Eigenschaft nur für einen Teil des angegebenen Textes auf True gesetzt ist. Long Schreib-Lese-Zugriff.

Style-Objekt: True, wenn die Rechtschreib- und Grammatikprüfung mit dieser Formatvorlage formatierten Text ignoriert. Long Schreib-Lese-Zugriff.

Template-Objekt: True, wenn die Rechtschreib- und Grammatikprüfung Dokumente ignoriert, die auf der Grundlage dieser Dokumentvorlage erstellt wurden. Long Schreib-Lese-Zugriff.


Beispiel zur NoProofing-Eigenschaft

In diesem Beispiel wird in Text, der von der Rechtschreib- und Grammatikprüfung ignoriert wird, nach der Zeichenfolge "hi" gesucht.

With Selection.Find
    .ClearFormatting
    .Text = "hi"
    .NoProofing = True
    .Execute Forward:=True
End With

In diesem Beispiel wird festgelegt, dass die aktuelle Markierung von der Rechtschreib- und Grammatikprüfung ignoriert wird.

Selection.NoProofing = True

In diesem Beispiel wird festgelegt, dass Text, der im aktiven Dokument mit der Formatvorlage "Test" formatiert wurde, von der Rechtschreib- und Grammatikprüfung ignoriert wird.

ActiveDocument.Styles("Test").NoProofing = True


NormalizedHeight-Eigenschaft

True, wenn alle Zeichen (Groß- und Kleinbuchstaben) im angegebenen WordArt-Objekt gleich groß sind. Long Schreib-Lese-Zugriff.


Beispiel zur NormalizedHeight-Eigenschaft

In diesem Beispiel wird zu myDocument ein WordArt-Objekt hinzugefügt, das den Text "Test Effect" enthält, und das neue WordArt-Objekt erhält den Namen "texteff1". Der Code macht dann alle Zeichen in der Form "texteff1" gleich groß.

Set myDocument = ActiveDocument
myDocument.Shapes.AddTextEffect(PresetTextEffect:=msoTextEffect1, _
    Text:="Test Effect", FontName:="Courier New", _
    FontSize:=44, FontBold:=True, _
    FontItalic:=False, Left:=10, Top:=10).Name = "texteff1"
myDocument.Shapes("texteff1").TextEffect.NormalizedHeight = True


NormalTemplate-Eigenschaft

Gibt ein Template-Objekt zurück, das die Dokumentvorlage Normal darstellt. Nur-Lese-Zugriff.


Beispiel zur NormalTemplate-Eigenschaft

In diesem Beispiel wird der AutoText-Eintrag "Test" aus der Dokumentvorlage Normal eingefügt, wenn sich dieser Eintrag in der AutoTextEntries-Auflistung befindet.

For Each entry In NormalTemplate.AutoTextEntries
    If entry.Name = "Test" Then entry.Insert Where:=Selection.Range
Next entry

In diesem Beispiel wird die Dokumentvorlage Normal gespeichert, falls Änderungen daran vorgenommen wurden.

If NormalTemplate.Saved = False Then NormalTemplate.Save


NoShade-Eigenschaft

True, wenn Microsoft Word die angegebene horizontale Linie ohne 3D-Schattierung zeichnet. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft kann nur auf horizontale Linien angewendet werden, die nicht aus einer bestehenden Grafikdatei stammen.


Beispiel zur NoShade-Eigenschaft

In diesem Beispiel wird eine horizontale Linie ohne 3D-Schattierung eingefügt.

Selection.InlineShapes.AddHorizontalLineStandard
ActiveDocument.InlineShapes(1) _
    .HorizontalLineFormat.NoShade = True


NumberAcross-Eigenschaft

Gibt die Anzahl der benutzerdefinierten Adressetiketten, die vertikal auf eine Seite passen, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf einen Wert geändert wird, der für das Layout des angegebenen Etiketts nicht gültig ist, tritt ein Fehler auf.


Beispiel zur NumberAcross-Eigenschaft

In diesem Beispiel wird ein neues benutzerdefiniertes Etikett mit der Bezeichnung "Dept. Labels" erstellt und das Layout inkl. der Anzahl der Etiketten, die vertikal auf die Seite passen, definiert.

Set myLabel = Application.MailingLabel.CustomLabels _
    .Add(Name:="Dept. Labels", DotMatrix:=False)
With myLabel
    .Height = InchesToPoints(0.5)
    .HorizontalPitch = InchesToPoints(2.06)
    .NumberAcross = 4
    .NumberDown = 4
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.28)
    .TopMargin = InchesToPoints(0.5)
    .VerticalPitch = InchesToPoints(2)
    .Width = InchesToPoints(1.75)
End With


NumberDown-Eigenschaft

Gibt die Anzahl der benutzerdefinierten Adressetiektten, die horizontal auf eine Seite passen, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf einen Wert geändert wird, der für das Layout des angegebenen Etiketts nicht gültig ist, tritt ein Fehler auf.


Beispiel zur NumberDown-Eigenschaft

In diesem Beispiel wird die Anzahl der Etiketten, die vertikal und horizontal auf eine Seite passen, für das erste benutzerdefinierte Etikett in CustomLabels-Sammlung angezeigt.

numAcr = Application.MailingLabel.CustomLabels(1).NumberAcross
numDwn = Application.MailingLabel.CustomLabels(1).NumberDown
MsgBox Prompt:= "Number of labels across " & numAcr & vbCr _
    & "Number of labels down " & numDwn & vbCr , _
    Title:="Label Page Configuration"


NumberFormat-Eigenschaft

Gibt das Zahlenformat für die angegebene Listenebene zurück oder legt es fest. String Schreib-Lese-Zugriff.

Anmerkungen

Das Prozentzeichen (%), gefolgt von einer beliebigen Zahl von 1 bis 9, stellt das Zahlenformat der entsprechende Listenebene dar. Wünschen Sie z. B. als Format für die erste Ebene "Artikel I", "Artikel II", usw., wählen Sie als Zeichenkette für die NumberFormat-Eigenschaft "Artikel %1", und setzen Sie die NumberStyle-Eigenschaft auf wdListNumberStyleUpperCaseRoman.

Wurde die NumberStyle-Eigenschaft auf wdListNumberStyleBullet gesetzt, darf die Zeichenfolge für die NumberFormat-Eigenschaft nur ein Zeichen enthalten.


Beispiel zur NumberFormat-Eigenschaft

In diesem Beispiel wird eine Listenvorlage erzeugt, in der jede Ebene eingerückt und mit einer arabischen Ziffer und einem Punkt formatiert wird. Die neue Listenvorlage wird dann der Auswahl zugewiesen.

Set LT = ActiveDocument.ListTemplates.Add(OutlineNumbered:=True)
For x = 1 To 9
    With LT.ListLevels(x)
        .NumberStyle = wdListNumberStyleArabic
        .NumberPosition = InchesToPoints(0.25 * (x - 1))
        .TextPosition = InchesToPoints(0.25 * x)
        .NumberFormat = "%" & x & "."
    End With
Next x
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=LT


NumberingRule-Eigenschaft

Gibt die Art der Fußnoten- oder Endnotennummerierung nach einem Seitenumbruch oder Abschnittswechsel zurück oder legt sie fest. Dabei kann es sich um die folgenden WdNumberingRule-Konstanten handeln: wdRestartContinuous, wdRestartSection oder wdRestartPage (nur Fußnoten). Long Schreib-Lese-Zugriff.


Beispiel zur NumberingRule-Eigenschaft

In diesem Beispiel wird die Endnotennummerierung nach jedem Abschnittswechsel im aktiven Dokument erneut gestartet.

ActiveDocument.Endnotes.NumberingRule = wdRestartSection

Wenn die Fußnotennummerierung im ersten Abschnitt so eingestellt ist, dass sie nach jedem Abschnittswechsel erneut gestartet wird, dann wird sie in diesem Beispiel so eingestellt, dass die Nummerierung auf jeder Seite erneut gestartet wird.

Set myRange = ActiveDocument.Sections(1).Range
If myRange.Footnotes.NumberingRule = wdRestartSection Then
    myRange.Footnotes.NumberingRule = wdRestartPage
End If


NumberOfColumns-Eigenschaft

Gibt die Anzahl der Spalten für jede Seite eines Index zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkung Wird 0 (Null) angegeben, wird die Anzahl der Spalten im Index auf dieselbe Anzahl wie im Dokument eingestellt.


Beispiel zur NumberOfColumns-Eigenschaft

In diesem Beispiel wird im ersten Index die Anzahl der Spalten auf dieselbe Anzahl wie im aktiven Dokument eingestellt.

ActiveDocument.Indexes(1).NumberOfColumns = 0

In diesem Beispiel wird für jeden Index im aktiven Dokument ein Zwei-Spalten-Format eingestellt.

For Each myIndex In ActiveDocument.Indexes
    myIndex.NumberOfColumns = 2
Next myIndex


NumberPosition-Eigenschaft

Gibt die Position (in Punkt) der Nummer oder des Aufzählungszeichens für das angegebene ListLevel-Objekt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Sie können die Position der Nummer oder des Aufzählungszeichens, die Position des Tabulators und die Position des Textes, der umbrochen wird, für alle Listenebenen festlegen.


Beispiel zur NumberPosition-Eigenschaft

In diesem Beispiel wird der Einzug aller Ebenen der dritten Dokumentvorlage für Gliederungen gesetzt. Jede Listenebene wird um 0,25 Zoll (18 Punkt) weiter als die vorherige Ebene eingezogen.

r = 0
For Each lev In ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(3).ListLevels
        lev.Alignment = wdListLevelAlignLeft
        lev.NumberPosition = r
        r = r + 18
Next lev

In diesem Beispiel wird der Einzug für die erste Ebene der letzten Dokumentvorlage für nummerierte Listen auf 0,5 Zoll gesetzt.

With ListGalleries(wdNumberGallery).ListTemplates(7).ListLevels(1)
    .Alignment = wdListLevelAlignLeft
    .NumberPosition = InchesToPoints(0.5)
End With


NumberStyle-Eigenschaft

Gibt das Zahlenformat für das angegebene Objekt zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Bei einem CaptionLabel-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdCaptionNumberStyle-Konstanten handeln:

wdCaptionNumberStyleArabic

wdCaptionNumberStyleArabicFullWidth

wdCaptionNumberStyleArabicLetter1

wdCaptionNumberStyleArabicLetter2

wdCaptionNumberStyleChosung

wdCaptionNumberStyleGanada

wdCaptionNumberStyleHanjaRead

wdCaptionNumberStyleHanjaReadDigit

wdCaptionNumberStyleHebrewLetter1

wdCaptionNumberStyleHebrewLetter2

wdCaptionNumberStyleKanji

wdCaptionNumberStyleKanjiDigit

wdCaptionNumberStyleKanjiTraditional

wdCaptionNumberStyleLowercaseLetter

wdCaptionNumberStyleLowercaseRoman

wdCaptionNumberStyleNumberInCircle

wdCaptionNumberStyleSimpChinNum2

wdCaptionNumberStyleSimpChinNum3

wdCaptionNumberStyleTradChinNum2

wdCaptionNumberStyleTradChinNum3

wdCaptionNumberStyleUppercaseLetter

wdCaptionNumberStyleUppercaseRoman

wdCaptionNumberStyleZodiac1

wdCaptionNumberStyleZodiac2

Bei einem Footnotes- oder Endnotes-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdNoteNumberStyle-Konstanten handeln:

wdNoteNumberStyleArabic

wdNoteNumberStyleArabicFullWidth

wdNoteNumberStyleArabicLetter1

wdNoteNumberStyleArabicLetter2

wdNoteNumberStyleHanjaRead

wdNoteNumberStyleHanjaReadDigit

wdNoteNumberStyleHebrewLetter1

wdNoteNumberStyleHebrewLetter2

wdNoteNumberStyleKanji

wdNoteNumberStyleKanjiDigit

wdNoteNumberStyleKanjiTraditional

wdNoteNumberStyleLowercaseLetter

wdNoteNumberStyleLowercaseRoman

wdNoteNumberStyleNumberInCircle

wdNoteNumberStyleSimpChinNum1

wdNoteNumberStyleSimpChinNum2

wdNoteNumberStyleSymbol

wdNoteNumberStyleTradChinNum1

wdNoteNumberStyleTradChinNum2

wdNoteNumberStyleUppercaseLetter

wdNoteNumberStyleUppercaseRoman

Bei einem PageNumbers-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdPageNumberStyle-Konstanten handeln:

wdPageNumberStyleArabic

wdPageNumberStyleArabicFullWidth

wdPageNumberStyleArabicLetter1

wdPageNumberStyleArabicLetter2

wdPageNumberStyleHanjaRead

wdPageNumberStyleHanjaReadDigit

wdPageNumberStyleHebrewLetter1

wdPageNumberStyleHebrewLetter2

wdPageNumberStyleKanji

wdPageNumberStyleKanjiDigit

wdPageNumberStyleKanjiTraditional

wdPageNumberStyleLowercaseLetter

wdPageNumberStyleLowercaseRoman

wdPageNumberStyleNumberInCircle

wdPageNumberStyleSimpChinNum1

wdPageNumberStyleSimpChinNum2

wdPageNumberStyleTradChinNum1

wdPageNumberStyleTradChinNum2

wdPageNumberStyleUppercaseLetter

wdPageNumberStyleUppercaseRoman

Bei einem ListLevel-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdListNumberStyle-Konstanten handeln:

wdListNumberStyleAiueo

wdListNumberStyleAiueoHalfWidth

wdListNumberStyleArabic

wdListNumberStyleArabic1

wdListNumberStyleArabic2

wdListNumberStyleArabicFullWidth

wdListNumberStyleArabicLZ

wdListNumberStyleBullet

wdListNumberStyleCardinalText

wdListNumberStyleChosung

wdListNumberStyleGanada

wdListNumberStyleGBNum1

wdListNumberStyleGBNum2

wdListNumberStyleGBNum3

wdListNumberStyleGBNum4

wdListNumberStyleHangul

wdListNumberStyleHanja

wdListNumberStyleHanjaRead

wdListNumberStyleHanjaReadDigit

wdListNumberStyleHebrew1

wdListNumberStyleHebrew2

wdListNumberStyleIroha

wdListNumberStyleIrohaHalfWidth

wdListNumberStyleKanji

wdListNumberStyleKanjiDigit

wdListNumberStyleKanjiTraditional

wdListNumberStyleKanjiTraditional2

wdListNumberStyleLegal

wdListNumberStyleLegalLZ

wdListNumberStyleLowercaseLetter

wdListNumberStyleLowercaseRoman

wdListNumberStyleNone

wdListNumberStyleNumberInCircle

wdListNumberStyleOrdinal

wdListNumberStyleOrdinalText

wdListNumberStyleSimpChinNum1

wdListNumberStyleSimpChinNum2

wdListNumberStyleSimpChinNum3

wdListNumberStyleSimpChinNum4

wdListNumberStyleTradChinNum1

wdListNumberStyleTradChinNum2

wdListNumberStyleTradChinNum3

wdListNumberStyleTradChinNum4

wdListNumberStyleUppercaseLetter

wdListNumberStyleUppercaseRoman

wdListNumberStyleZodiac1

wdListNumberStyleZodiac2

wdListNumberStyleZodiac3

Hinweise

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch) ab.


Beispiel zur NumberStyle-Eigenschaft

In diesem Beispiel wird ein alternatives Zahlenformat für die Dokumentvorlage für Gliederungen erstellt.

Set myTemp = ListGalleries(wdOutlineNumberGallery).ListTemplates(3)
For i = 1 to 9
    If i Mod 2 = 0 Then
        myTemp.ListLevels(i).NumberStyle = _
            wdListNumberStyleUppercaseRoman
    Else
        myTemp.ListLevels(i).NumberStyle = _
            wdListNumberStyleLowercaseRoman
    End If
Next i

In diesem Beispiel wird das Zahlenformat für alle Gliederungen im aktiven Dokument auf Großbuchstaben geändert.

For Each lt In ActiveDocument.ListTemplates
    For Each ll In lt.listlevels
       ll.NumberStyle = wdListNumberStyleUppercaseLetter
    Next ll
Next lt

In diesem Beispiel wird eine Bildunterschrift an der Einfügemarke eingefügt. Der Gliederungsbuchstabe wird als Großbuchstabe formatiert.

CaptionLabels(wdCaptionFigure).NumberStyle = _
    wdCaptionNumberStyleUppercaseLetter
Selection.Collapse Direction:=wdCollapseEnd
Selection.InsertCaption Label:="Figure"

In diesem Beispiel wird die Formatierung für Fuß- und Endnoten im aktiven Dokument festgelegt.

With ActiveDocument
    .Footnotes.NumberStyle = wdNoteNumberStyleLowercaseRoman
    .Endnotes.NumberStyle = wdNoteNumberStyleUppercaseRoman
End With

In diesem Beispiel werden Seitennummern in der Fußzeile des aktiven Dokuments als klein geschriebene römische Ziffern formatiert.

For Each sec In ActiveDocument.Sections
    sec.Footers(wdHeaderFooterPrimary).PageNumbers _
        .NumberStyle = wdPageNumberStyleLowercaseRoman
Next sec


NumLock-Eigenschaft

Gibt den Status der NUM-TASTE zurück. True, wenn mit den Tasten der Zehnertastatur Zahlen eingefügt werden. False, wenn mit den Tasten die Einfügemarke bewegt wird. Boolean Nur-Lese-Zugriff.


Beispiel zur NumLock-Eigenschaft

In diesem Beispiel wird der aktuelle Status der FESTSTELLTASTE zurückgegeben.

theState = Application.NumLock


Object-Eigenschaft

Gibt ein Objekt zurück, das die Schnittstelle des angegebenen OLE-Objekts auf der obersten Ebene darstellt. Diese Eigenschaft gibt Ihnen die Möglichkeit, auf die Eigenschaften und Methoden eines ActiveX-Steuerelements zuzugreifen oder auf die Anwendung, in der ein OLE-Objekt erstellt wurde. Diese Eigenschaft ist nur funktionsfähig, wenn das OLE-Objekt OLE-Automation unterstützt. Object Nur-Lese-Zugriff.


Beispiel zur Object-Eigenschaft

In diesem Beispiel wird der Wert der ersten Form im aktiven Dokument festgelegt. Damit das Beispiel funktioniert, muss die erste Form ein ActiveX-Steuerelement sein (ein Kontrollkästchen oder ein Optionsfeld).

With ActiveDocument.Shapes(1).OLEFormat
    .Activate
    Set myObj = .Object
End With
myObj.Value = True

In diesem Beispiel wird dem aktiven Dokument ein neues ActiveX-Steuerelement hinzugefügt und dieses aktiviert. Dann werden einige seiner Eigenschaften festgelegt.

Set myOB = ActiveDocument.Shapes _
    .AddOLEControl(ClassType:="Forms.OptionButton.1")
With myOB.OLEFormat
    .Activate
    Set myObj = .Object
End With
With myObj
    .Value = False
    .Caption = "My Caption"
    .AutoSize = True
End With


Obscured-Eigenschaft

True, wenn der Schatten der angegebenen Form ausgefüllt erscheint und durch die Form abgedunkelt ist, selbst wenn die Form keine Füllung hat. False, wenn der Schatten keine Füllung hat und der Umriss des Schattens durch die Form zu sehen ist, wenn die Form keine Füllung hat. Long Schreib-Lese-Zugriff.


Beispiel zur Obscured-Eigenschaft

In diesem Beispiel werden in myDocument für Form drei die horizontale und die vertikale Position des Schattens relativ zur Form festgelegt. Der Schatten ist von der Form aus um 5 Punkt nach rechts versetzt und um 3 Punkt nach oben. Wenn die Form noch keinen Schatten hat, wird ihr in diesem Beispiel einer hinzugefügt. Der Schatten wird ausgefüllt und durch die Form abgedunkelt sein, auch wenn die Form keine Füllung hat.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
    .Obscured = True
End With


OddAndEvenPagesHeaderFooter-Eigenschaft

True, wenn das angegebene PageSetup-Objekt unterschiedliche Kopfzeilen und Fußzeilen für ungeradzahlige Seiten und geradzahlige Seiten hat. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur OddAndEvenPagesHeaderFooter-Eigenschaft

In diesem Beispiel werden in Dokument1 für ungeradzahlige Seiten und geradzahlige Seiten unterschiedliche Kopf- und Fußzeilen erstellt.

Set myDoc = Documents("Document1")
myDoc.PageSetup.OddAndEvenPagesHeaderFooter = True
With myDoc.Sections(1)
    .Headers(wdHeaderFooterPrimary).Range _
        .InsertAfter "Odd Header"
    .Headers(wdHeaderFooterEvenPages).Range _
        .InsertAfter "Even Header"
End With


OffsetX-Eigenschaft

Gibt die horizontale Position des Schattens relativ zur angegebenen Form in Punkt zurück oder legt sie fest. Ein positiver Wert versetzt den Schatten von der Form aus nach rechts; ein negativer Wert versetzt ihn nach links. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie einen Schatten horizontal oder vertikal von seiner aktuellen Position etwas versetzen wollen, ohne dass Sie eine absolute Position angeben müssen, verwenden Sie die IncrementOffsetX-Methode bzw. die IncrementOffsetY-Methode.


Beispiel zur OffsetX-Eigenschaft

In diesem Beispiel werden in myDocument für Form drei die horizontale und die vertikale Position des Schattens relativ zur Form festgelegt. Der Schatten ist von der Form aus um 5 Punkt nach rechts versetzt und um 3 Punkt nach oben. Wenn die Form noch keinen Schatten hat, wird ihr in diesem Beispiel einer hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OffsetY-Eigenschaft

Gibt die vertikale Position des Schattens relativ zur angegebenen Form in Punkt zurück oder legt sie fest. Ein positiver Wert versetzt den Schatten von der Form aus nach rechts; ein negativer Wert versetzt ihn nach links. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie einen Schatten von seiner aktuellen Position horizontal oder vertikal etwas versetzen wollen, ohne dass Sie eine absolute Position angeben müssen, verwenden Sie die IncrementOffsetX-Methode bzw. die IncrementOffsetY-Methode.


Beispiel zur OffsetY-Eigenschaft

In diesem Beispiel werden in myDocument für Form drei die horizontale und die vertikale Position des Schattens relativ zur Form festgelegt. Der Schatten ist von der Form aus um 5 Punkt nach rechts versetzt und um 3 Punkt nach oben. Wenn die Form noch keinen Schatten hat, wird ihr in diesem Beispiel einer hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OLEFormat-Eigenschaft

Gibt ein OLEFormat-Objekt zurück, das die OLE-Charakteristika (andere als Verknüpfung) für die angegebene Form, die zeilenfixierte Form oder das angegebene Feld darstellt. Nur-Lese-Zugriff.


Beispiel zur OLEFormat-Eigenschaft

In diesem Beispiel werden alle beweglichen Formen auf dem aktiven Dokument durchlaufen und festgelegt, dass alle verknüpften Microsoft Excel-Tabellen automatisch aktualisiert werden.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        If s.OLEFormat.ProgID = "Excel.Sheet" Then
            s.LinkFormat.AutoUpdate = True
        End If
    End If
Next


OpenEncoding-Eigenschaft

Gibt die zum Öffnen des angegebenen Dokuments verwendete Codierung zurück. Dabei kann es sich um eine beliebige gültige MsoEncoding-Konstante handeln. Long Nur-Lese-Zugriff.

Hinweise

Eine Liste der gültigen MsoEncoding-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.

Sie können keine Konstante mit dem Suffix "AutoDetect" verwenden. Diese Konstanten werden bei der ReloadAs-Methode verwendet.


Beispiel zur OpenEncoding-Eigenschaft

In diesem Beispiel wird geprüft, ob das aktuelle Dokument mit der UTF7-Codierung geöffnet wurde.

If ActiveDocument.OpenEncoding = msoEncodingUTF7 Then
    MsgBox "This is a UTF7-encoded text file!"
Else
    MsgBox "This is not a UTF7-encoded text file!"
End If


OpenFormat-Eigenschaft

Gibt das Dateiformat des angegebenen Dateikonvertierungsprogramms zurück. Dies kann eine der folgenden WdOpenFormat-Konstanten sein: wdOpenFormatAllWord, wdOpenFormatAuto, wdOpenFormatDocument, wdOpenFormatEncodedText, wdOpenFormatRTF, wdOpenFormatTemplate, wdOpenFormatText, wdOpenFormatUnicodeText oder wdOpenFormatWebPages. Es kann sich auch um eine eindeutige Nummer handeln, die ein externes Dateikonvertierungsprogramm darstellt. Long Nur-Lese-Zugriff.


Beispiel zur OpenFormat-Eigenschaft

Dieses Beispiel zeigt den eindeutigen Formatwert sowie den Formatnamen für das Konvertierungsprogramm an, das Sie für das Öffnen von Dokumenten verwenden können.

For Each fc In FileConverters
    If fc.CanOpen = True Then _
        MsgBox fc.OpenFormat & vbCr & fc.FormatName
Next fc

Dieses Beispiel öffnet die Datei "Data.wp" mit dem WordPerfect 6x Dateikonvertierungsprogramm.

Documents.Open FileName:="C:\Data.wp", _
    Format:=FileConverters("WordPerfect6x").OpenFormat


OperatingSystem-Eigenschaft

Gibt den Namen des aktuellen Betriebssystems zurück (zum Beispiel "Windows" oder "Windows NT"). String Nur-Lese-Zugriff.


Beispiel zur OperatingSystem-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, die den Namen des aktuellen Betriebssystems enthält.

MsgBox "This computer is running " & System.OperatingSystem


OptimizeForBrowser-Eigenschaft

DefaultWebOptions-Objekt: True, wenn Microsoft Word neue, in Word erstellte Webseiten für den Webbrowser optimiert, der durch die BrowserLevel-Eigenschaft festgelegt wird. Boolean Schreib-Lese-Zugriff.

WebOptions-Objekt: True, wenn Word die angegebene Webseite für den Webbrowser optimiert, der durch die BrowserLevel-Eigenschaft festgelegt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur OptimizeForBrowser-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word neue Webseiten für Microsoft Internet Explorer 5 optimiert. Anschließend wird auf der Grundlage dieser Einstellung eine Webseite erstellt.

With Application.DefaultWebOptions
    .BrowserLevel _
        = wdBrowserLevelMicrosoftInternetExplorer5
    .OptimizeForBrowser = True
End With
Documents.Add DocumentType:=wdNewWebPage

In diesem Beispiel wird eine neue Webseite erstellt und für Microsoft Internet Explorer 5 optimiert.

Documents.Add DocumentType:=wdNewWebPage
With ActiveDocument.WebOptions
    .BrowserLevel _
        = wdBrowserLevelMicrosoftInternetExplorer5
    .OptimizeForBrowser = True
End With


OptimizeForWord97-Eigenschaft

True, wenn Microsoft Word das aktuelle Dokument durch Deaktivieren aller inkompatiblen Formatierungen für die Ansicht in Word 97 optimiert. Boolean Schreib-Lese-Zugriff.

Hinweise

Um alle neuen Dokumente standardmäßig für Word 97 zu optimieren, verwenden Sie die OptimizeForWord97byDefault-Eigenschaft.


OptimizeForWord97byDefault-Eigenschaft

True, wenn Microsoft Word alle neuen Dokumente durch Deaktivieren aller inkompatiblen Formatierungen für die Ansicht in Word 97 optimiert. Boolean Schreib-Lese-Zugriff.

Hinweise

Um ein einzelnes Dokument für Word 97 zu optimieren, verwenden Sie die OptimizeForWord97-Eigenschaft.


Beispiel zur OptimizeForWord97byDefault-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word in neuen Dokumenten alle zu Word 97 inkompatiblen Formatierungen deaktiviert. Anschließend wird ein neues Dokument erstellt, dessen OptimizeForWord97-Eigenschaft automatisch auf True gesetzt wird.

Options.OptimizeForWord97byDefault = True
MsgBox Documents.Add(DocumentType:=wdNewBlankDocument) _
    .OptimizeForWord97


Options-Eigenschaft

Gibt ein Options-Objekt zurück, das für Anwendungseinstellungen steht, die in Word vorgenommen werden können. Nur-Lese-Zugriff.


Beispiel zur Options-Eigenschaft

In diesem Beispiel wird die Schnellspeicherung deaktiviert und das aktive Dokument dann gespeichert.

Options.AllowFastSave = False
ActiveDocument.Save

In diesem Beispiel wird Umsatz.doc mit Kommentaren und Feldergebnissen gedruckt.

With Options
    .PrintFieldCodes = False
    .PrintComments = True
End With
Documents("Sales.doc").PrintOut


OrganizeInFolder-Eigenschaft

True, wenn alle Hilfsdateien, wie beispielsweise Hintergrundstrukturen und Grafiken, beim Speichern des angegebenen Dokuments als Webseite in einem separaten Ordner zusammengefasst werden. False, wenn Hilfsdateien in demselben Ordner wie die Webseite gespeichert werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Der neue Ordner wird in dem Ordner erstellt, in dem Sie die Webseite gespeichert haben, und wird nach dem Dokument benannt. Wenn Sie lange Dateinamen verwenden, wird dem Namen des Ordners ein Suffix hinzugefügt. Die FolderSuffix-Eigenschaft gibt das Suffix des Ordners für die gewählte oder installierte Sprachunterstützung bzw. das Standardsuffix des Ordners zurück.

Beim Speichern eines Dokuments, dessen OrganizeInFolder-Eigenschaft beim letzten Speichern auf einen anderen Wert eingestellt war, verschiebt Microsoft Word die Hilfsdateien entsprechend in den Ordner oder aus dem Ordner.

Wenn Sie keine langen Dateinamen verwenden, die UseLongFileNames-Eigenschaft also auf False gesetzt ist, speichert Microsoft Word alle Hilfsdateien automatisch in einem separaten Ordner. Die Dateien können nicht in demselben Ordner wie die Webseite gespeichert werden.


Beispiel zur OrganizeInFolder-Eigenschaft

In diesem Beispiel wird festgelegt, dass alle Hilfsdateien in demselben Ordner gespeichert werden, wenn das Dokument als Webseite gespeichert wird.

Application.DefaultWebOptions.OrganizeInFolder = False


Orientation-Eigenschaft

PageSetup-Objekt: Gibt die Ausrichtung der Seite zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdOrientation-Konstanten handeln: wdOrientLandscape oder wdOrientPortrait. Long Schreib-Lese-Zugriff.

Range- oder Selection-Objekt: Gibt die Ausrichtung des Textes im Bereich oder in der Markierung zurück oder legt sie fest, wenn die Funktion Textrichtung aktiviert ist. Dabei kann es sich um eine der folgenden WdTextOrientation-Konstanten handeln: wdTextOrientationDownward, wdTextOrientationHorizontal, wdTextOrientationHorizontalRotatedFarEast, wdTextOrientationUpward oder wdTextOrientationVerticalFarEast. Long Schreib-Lese-Zugriff.

TextFrame-Objekt: Gibt die Ausrichtung von Text, der sich in einem Positionsrahmen befindet, zurück oder legt sie fest. Dabei kann es sich um eine der folgenden MsoTextOrientation-Konstanten handeln: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Long Schreib-Lese-Zugriff.

Hinweise

Die Verfügbarkeit der oben aufgeführten Konstanten hängt von der ausgewählten bzw. installierten Sprachunterstützung (zum Beispiel Deutsch) ab.

Sie können die Ausrichtungen für einen Textpositionsrahmen, einen Bereich oder eine Markierung innerhalb eines Textpositionsrahmens festlegen. Informationen zu den Unterschieden zwischen einem Textpositionsrahmen und einem Textfeld finden Sie in den Erläuterungen zum TextFrame-Objekt.


Beispiel zur Orientation-Eigenschaft

In diesem Beispiel wird die Ausrichtung des Dokuments "MeinDokument.doc" geändert, und anschließend wird das Dokument gedruckt. Das Beispiel ändert die Ausrichtung des Dokuments zurück in Hochformat.

Set myDoc = Documents("MyDocument.doc")
With myDoc
    .PageSetup.Orientation = wdOrientLandscape
    .PrintOut
    .PageSetup.Orientation = wdOrientPortrait
End With

In diesem Beispiel wird ein neues Dokument erstellt. Text wird eingefügt und damit ein Textfeld erstellt. Anschließend wird die Ausrichtung des Textrahmens festgelegt, so dass der Text sich nach oben neigt.

Set mydoc = Documents.Add
Selection.TypeText "This is some text."
mydoc.Content.Select
Selection.CreateTextbox
mydoc.Shapes(1).TextFrame.Orientation = msoTextOrientationUpward


OtherCorrectionsAutoAdd-Eigenschaft

True, wenn Microsoft Word automatisch Wörter zur Liste der AutoKorrektur-Ausnahmen hinzufügt. Auf diese Liste können Sie auf der Registerkarte Weitere Korrekturen im Dialogfeld AutoKorrektur-Ausnahmen (Menü Extras, Befehl AutoKorrektur) zugreifen. Word fügt ein Wort auf dieser Liste ein, wenn Sie ein Wort, das Word nicht korrigieren sollte, löschen und danach wieder eingeben. Boolean Schreib-Lese-Zugriff.


Beispiel zur OtherCorrectionsAutoAdd-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word auf der Registerkarte Weitere Korrekturen im Dialogfeld AutoKorrektur-Ausnahmen automatisch Wörter zur Liste der AutoKorrektur-Ausnahmen hinzufügt.

AutoCorrect.OtherCorrectionsAutoAdd = True


OtherCorrectionsExceptions-Eigenschaft

Gibt eine OtherCorrectionsExceptions-Auflistung zurück. Diese Auflistung stellt eine Liste der Wörter dar, die von Microsoft Word nicht automatisch korrigiert werden. Diese Liste stimmt mit der Liste der AutoKorrektur-Ausnahmen überein, die auf der Registerkarte Weitere Korrekturen (Menü Extras, Befehl AutoKorrektur, Dialogfeld AutoKorrektur-Ausnahmen) angezeigt wird. Nur-Lese-Zugriff.

Informationen über die Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur OtherCorrectionsExceptions-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, jeden Eintrag in der Liste der AutoKorrektur-Ausnahmen auf der Registerkarte Weitere Korrekturen im Dialogfeld AutoCorrect Exceptions zu löschen oder zu behalten.

For Each anEntry In _
        AutoCorrect.OtherCorrectionsExceptions
    response = MsgBox("Delete entry: " _
        & anEntry.Name, vbYesNoCancel)
    If response = vbYes Then
        anEntry.Delete
    Else
        If response = vbCancel Then End
    End If
Next anEntry


OtherPagesTray-Eigenschaft

Gibt den Papierzufuhr-Schacht zurück oder legt ihn fest, der für alle Seiten außer der ersten Seite eines Dokuments oder Abschnitts verwendet werden soll. Long Schreib-Lese-Zugriff.

Kann eine der folgenden WdPaperTray-Konstanten sein:

wdPrinterAutomaticSheetFeed

wdPrinterDefaultBin

wdPrinterEnvelopeFeed

wdPrinterFormSource

wdPrinterLargeCapacityBin

wdPrinterLargeFormatBin

wdPrinterLowerBin

wdPrinterManualEnvelopeFeed

 wdPrinterManualFeed

wdPrinterMiddleBin

wdPrinterOnlyBin

wdPrinterPaperCassette

wdPrinterSmallFormatBin

wdPrinterTractorFeed

wdPrinterUpperBin


Beispiel zur OtherPagesTray-Eigenschaft

In diesem Beispiel wird der Papierzufuhr-Schacht festgelegt, der zum Drucken aller Seiten außer der ersten Seite jedes Abschnitts im aktiven Dokument verwendet werden soll.

ActiveDocument.PageSetup.OtherPagesTray = wdPrinterUpperBin

In diesem Beispiel wird der Papierzufuhr-Schacht festgelegt, der zum Drucken aller Seiten außer der ersten Seite jedes Abschnitts in der Markierung verwendet werden soll.

Selection.PageSetup.OtherPagesTray = wdPrinterLowerBin


Outline-Eigenschaft

True, wenn die Schriftart als Konturschrift formatiert ist. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle eingestellt werden. Long Schreib-Lese-Zugriff.


OutlineLevel-Eigenschaft

Gibt die Gliederungsebene für die angegebenen Absätze zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdOutlineLevel-Konstanten handeln: wdOutLineLevel1, wdOutLineLevel2, wdOutLineLevel3, wdOutLineLevel4, wdOutLineLevel5, wdOutLineLevel6, wdOutLineLevel7, wdOutLineLevel8, wdOutLineLevel9 oder wdOutLineLevelBodyText. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn einem Absatz eine Überschrift-Formatvorlage zugewiesen wurde (Überschrift 1 bis Überschrift 9), entspricht die Gliederungsebene der Überschrift-Formatvorlage und kann nicht geändert werden.

Gliederungsebenen sind nur in der Gliederungsansicht oder im Dokumentstrukturbereich sichtbar.


Beispiel zur OutlineLevel-Eigenschaft

In diesem Beispiel wird die Gliederungsebene des ersten Absatzes im aktiven Dokument zurückgegeben.

temp = ActiveDocument.Paragraphs(1).OutlineLevel

In diesem Beispiel werden die Gliederungsebenen für alle Absätze im aktiven Dokument festgelegt. Zuerst wird die Formatvorlage "Normal" allen Absätzen zugewiesen. Mit dem Mod-Operator wird bestimmt, welche Gliederungsebenen (1, 2 oder 3) aufeinander folgenden Absätzen im Dokument zugewiesen werden und dann wird zur Gliederungsansicht gewechselt.

Set myParas = ActiveDocument.Paragraphs
ActiveDocument.Paragraphs.Style = wdStyleNormal
For x = 1 To myParas.Count
    If x Mod 3 = 1 Then
        myParas(x).OutlineLevel = wdOutlineLevel1
    ElseIf x Mod 3 = 2 Then
        myParas(x).OutlineLevel = wdOutlineLevel2
    Else
        myParas(x).OutlineLevel = wdOutlineLevel3
    End If
Next x
ActiveDocument.ActiveWindow.View.Type = wdOutlineView


OutlineNumbered-Eigenschaft

True, wenn es sich beim angegebenen ListTemplate-Objekt um eine Gliederung handelt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie diese Eigenschaft auf False setzen, wird die Listenvorlage in eine Liste mit einer Ebene und der Formatierung für die erste Ebene konvertiert.

Sie können diese Eigenschaft nicht für ein ListTemplate-Objekt verwenden, das von einem ListGallery-Objekt zurückgegeben wurde.


Beispiel zur OutlineNumbered-Eigenschaft

In diesem Beispiel wird die gewählte Gliederung in eine Aufzählung mit einer Ebene umgewandelt.

Selection.Range.ListFormat.ListTemplate.OutlineNumbered = False

In diesem Beispiel wird überprüft, ob es sich bei der dritten Liste in MyDoc.doc um eine Gliederung handelt. Falls ja, wird die dritte Listenvorlage für Gliederungen zugewiesen.

Set myltemp = Documents("MyDoc.doc").Lists(3).Range _
    .ListFormat.ListTemplate
num = myltemp.OutlineNumbered
If num = True Then ActiveDocument.Lists(3).ApplyListTemplate _
    ListTemplate:=ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(3)


OutsideColor-Eigenschaft

Gibt die 24-Bit-Farbe der äußeren Rahmenlinien zurück oder legt diese fest. Dabei kann es sich um eine beliebige gültige WdColor-Konstante oder um einen Wert handeln, der von der RGB-Funktion zurückgegeben wurde. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog im Visual Basic-Editors.

Wenn die OutsideLineStyle Eigenschaft auf wdLineStyleNone oder False gesetzt ist, hat das Festlegen dieser Eigenschaft keine Auswirkungen.


OutsideColorIndex-Eigenschaft

Gibt die Farbe der Rahmenlinien außen zurück oder legt sie fest. Dies kann eine der folgenden WdColorIndex-Konstanten sein: wdAuto, wdBlack, wdBlue, wdBrightGreen, wdDarkBlue, wdDarkRed, wdDarkYellow, wdGray25, wdGray50, wdGreen, wdPink, wdRed, wdTeal, wdTurquoise, wdViolet, wdWhite oder wdYellow. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die OutsideLineStyle-Eigenschaft auf wdLineStyleNone oder False festgelegt ist, hat das Festlegen dieser Eigenschaft keine Auswirkungen.


Beispiel zur OutsideColorIndex-Eigenschaft

In diesem Beispiel werden in der ersten Tabelle im aktiven Dokument Rahmen zwischen den Zeilen und Spalten hinzugefügt und dann die Farben für Rahmenlinien innen und außen festgelegt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    With myTable.Borders
        .InsideLineStyle = True
        .InsideColorIndex = wdBrightGreen
        .OutsideColorIndex = wdPink
    End With
End If

In diesem Beispiel wird um den ersten Absatz im aktiven Dokument eine 0,75-Punkt breite, rote doppelte Rahmenlinie hinzugefügt.

With ActiveDocument.Paragraphs(1).Borders
    .OutsideLineStyle = wdLineStyleDouble
    .OutsideLineWidth = wdLineWidth075pt
    .OutsideColorIndex = wdRed
End With


OutsideLineStyle-Eigenschaft

Gibt den äußeren Rahmen für das angegebene Objekt zurück oder legt ihn fest. Gibt wdUndefined zurück, wenn mehrere Ränder dem angegebenen Objekt zugewiesen wurden. Sonst wird False oder eine WdLineStyle-Konstante zurückgegeben. Die Eigenschaft kann auf True, False oder eine WdLineStyle-Konstante gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweise

True wählt als Linienart die Standardlinienart und als Linienstärke die Standardlinienstärke. Die Standardlinienart und die Standardlinienstärke legen Sie mit der DefaultBorderLineWidth-Eigenschaft und der DefaultBorderLineStyle-Eigenschaft fest.

Mit jeder der folgenden Anweisungen entfernen Sie die äußere Umrahmung von der ersten Tabelle im aktiven Dokument.

ActiveDocument.Tables(1).Borders.OutsideLineStyle = wdLineStyleNone
ActiveDocument.Tables(1).Borders.OutsideLineStyle = False


Beispiel zur OutsideLineStyle-Eigenschaft

In diesem Beispiel wird ein 0,75 Punkt starker doppelter Rahmen um den ersten Absatz im aktiven Dokument gezogen.

With ActiveDocument.Paragraphs(1).Borders
    .OutsideLineStyle = wdLineStyleDouble
    .OutsideLineWidth = wdLineWidth075pt
End With

In diesem Beispiel wird ein Rahmen um die erste Tabelle im aktiven Dokument gezogen.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    myTable.Borders.OutsideLineStyle = wdLineStyleSingle
End If


OutsideLineWidth-Eigenschaft

Gibt die Linienstärke des Außenrahmens eines Objekts zurück oder legt sie fest. Gibt wdUndefined zurück, wenn das Objekt einen Außenrahmen mit mehreren Linienstärken hat. Sonst wird False oder eine WdLineWidth-Konstante zurückgegeben. Sie kann auf True, False oder eine der folgenden WdLineWidth-Konstanten gesetzt werden: wdLineWidth025pt, wdLineWidth050pt, wdLineWidth075pt, wdLineWidth100pt, wdLineWidth150pt, wdLineWidth225pt, wdLineWidth300pt, wdLineWidth450pt oder wdLineWidth600pt. Long Schreib-Lese-Zugriff.


Beispiel zur OutsideLineWidth-Eigenschaft

In diesem Beispiel wird die erste Tabelle im aktiven Dokument mit einem wellenförmigen Rahmen versehen.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1).Borders
        .OutsideLineStyle = wdLineStyleSingleWavy
        .OutsideLineWidth = wdLineWidth075pt
    End With
End If

In diesem Beispiel werden die ersten vier Absätze im aktiven Dokument mit einem gepunkteten Rahmen versehen.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(1).Range.Start, _
    End:=myDoc.Paragraphs(4).Range.End)
myRange.Borders.OutsideLineStyle = wdLineStyleDot
myRange.Borders.OutsideLineWidth = wdLineWidth075pt


Overflowing-Eigenschaft

True, wenn der Text innerhalb des angegebenen Textpositionsrahmens nicht vollständig in den Positionsrahmen passt. Boolean Nur-Lese-Zugriff.


Beispiel zur Overflowing-Eigenschaft

Dieses Beispiel prüft, ob der Text in "MyTextBox" im zugehörigen Textpositionsrahmen überläuft. Wenn dies der Fall ist, fügt das Beispiel ein anderes Textfeld ein und verknüpft die beiden Textfelder so, dass der Text in das andere Feld fließt.

Set myTBox = ActiveDocument.Shapes("MyTextBox")
If myTBox.TextFrame.Overflowing = True Then
    Set nextTBox = ActiveDocument.Shapes. _
        AddTextbox(msoTextOrientationHorizontal, 72, 72, 100, 200)
    MyTBox.TextFrame.Next = nextTBox.TextFrame
End If


Overtype-Eigenschaft

True, wenn der Überschreiben-Modus aktiv ist. Im Überschreiben-Modus wird jeweils ein vorhandenes Zeichen durch ein neu eingegebenes Zeichen ersetzt. Ist der Überschreiben-Modus nicht aktiv, werden die vorhandenen Zeichen durch die neu eingegebenen Zeichen nach rechts verschoben. Boolean Schreib-Lese-Zugriff.


Beispiel zur Overtype-Eigenschaft

Dieses Beispiel zeigt bei aktivem Überschreiben-Modus ein Meldungsfeld an, in dem angegeben werden kann, ob der Überschreiben-Modus deaktiviert werden soll. Wenn der Benutzer auf die Schaltfläche Ja klickt, wird der Überschreiben-Modus deaktiviert.

If Options.Overtype = True Then
    aButton = MsgBox("Overtype is on. Turn off?", 4)
    If aButton = vbYes Then Options.Overtype = False
End If


OwnHelp-Eigenschaft

Legt die Quelle des Textes fest, der in einem Meldungsfeld angezeigt wird, wenn ein Formularfeld den Fokus hat oder wenn der Benutzer F1 drückt. Bei True wird der Text angezeigt, der durch die HelpText-Eigenschaft festgelegt wird. Bei False wird der Text im AutoText-Eintrag angezeigt, der durch die HelpText-Eigenschaft festlegt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur OwnHelp-Eigenschaft

In diesem Beispiel wird dem Hilfetext für das erste Formularfeld in der aktuellen Markierung der Inhalt des AutoText-Eintrags "Beispiel" zugewiesen.

With Selection.Sections(1).Range.FormFields(1)
    .OwnHelp = False
    .HelpText = "Sample"
End With


OwnStatus-Eigenschaft

Legt die Quelle des Textes fest, der bei einem Formularfeld, das den Fokus hat, in der Statusleiste angezeigt wird. Bei True wird der Text angezeigt, der durch die StatusText-Eigenschaft festgelegt wird. Bei False wird der Text des AutoText-Eintrags angezeigt, der durch die StatusText-Eigenschaft festgelegt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur OwnStatus-Eigenschaft

In diesem Beispiel wird dem Hilfetext in der Statusleiste für das Formularfeld "Konto" der Inhalt des AutoText-Eintrags "Konto" zugewiesen.

With ActiveDocument.FormFields("Account")
    .OwnStatus = False
    .StatusText = "Acct"
End With


PageBreakBefore-Eigenschaft

True, wenn ein Seitenwechsel vor den angegebenen Absätzen erzwungen wird. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur PageBreakBefore-Eigenschaft

In diesem Beispiel wird vor dem ersten Absatz in der Markierung ein Seitenwechsel erzwungen.

Selection.Paragraphs(1).PageBreakBefore = True


PageColumns-Eigenschaft

Gibt die Anzahl der Seiten zurück, die in der Seitenlayoutansicht oder der Seitenansicht gleichzeitig nebeneinander auf dem Bildschirm angezeigt werden sollen, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur PageColumns-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Seitenlayoutansicht gesetzt, und es werden zwei Seiten nebeneinander angezeigt.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .Zoom.PageColumns = 2
    .Zoom.PageRows = 1
End With

In diesem Beispiel wird das Dokumentfenster für Hello.doc in die Seitenlayoutansicht gesetzt, und es wird eine ganze Seite angezeigt.

With Windows("Hello.doc").View
    .Type = wdPrintView
    With .Zoom
        .PageColumns = 1
        .PageRows = 1
        .PageFit = wdPageFitFullPage
    End With
End With


PageDesign-Eigenschaft

Gibt den Namen der Dokumentvorlage, die mit dem Dokument verbunden ist, das vom Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur PageDesign-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt, einschließlich der Kopf- und Fußzeilen, aus der Dokumentvorlage "Aktueller Brief" erstellt und der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
With myContent
    .PageDesign = "C:\MSOffice\Templates\" _
        & "Letters & Faxes\Contemporary Letter.dot"
    .IncludeHeaderFooter = True
End With
Documents.Add.RunLetterWizard LetterContent:=myContent


PageFit-Eigenschaft

Gibt die Ansichtsvergrößerung eines Fensters zurück oder legt sie fest, so dass entweder die gesamte Seite sichtbar ist oder die gesamte Breite der Seite zu sehen ist. Dies kann eine der folgenden WdPageFit-Konstanten sein: wdPageFitBestFit, wdPageFitFullPage, wdPageFitNone oder wdPageFitTextFit. Long Schreib-Lese-Zugriff.

Hinweise

Die wdPageFitFullPage-Konstante hat keine Wirkung, wenn das Dokument nicht in der Seitenlayoutansicht ist.

Ist die PageFit-Eigenschaft auf wdPageFitBestFit eingestellt, werden die Zoom-Prozente jedes Mal automatisch neu berechnet, wenn die Größe des Dokumentfensters sich geändert hat. Wird diese Eigenschaft auf wdPageFitNone eingestellt, werden bei Änderung der Fenstergröße die Zoom-Prozente nicht neu berechnet.


Beispiel zur PageFit-Eigenschaft

In diesem Beispiel werden die Vergrößerungsprozente des Fensters für Letter.doc so geändert, dass die gesamte Breite des Textes sichtbar ist.

With Windows("Letter.doc").View
    .Type = wdNormalView
    .Zoom.PageFit = wdPageFitBestFit
End With

In diesem Beispiel wird das aktive Fenster in die Seitenlayoutansicht umgeschaltet und die Vergrößerung so geändert, dass die gesamte Seite sichtbar ist.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .Zoom.PageFit = wdPageFitFullPage
End With


PageHeight-Eigenschaft

Gibt die Seitenhöhe in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Die Einstellung der PageHeight-Eigenschaft ändert die PaperSize-Eigenschaft in wdPaperCustom.

Verwenden Sie die PaperSize-Eigenschaft zum Einstellen der Seitenhöhe und Seitenbreite auf eine vordefinierte Papiergröße wie Letter oder A4.


Beispiel zur PageHeight-Eigenschaft

In diesem Beispiel wird für das aktive Dokument die Seitenhöhe auf 9 Zoll festgelegt.

With ActiveDocument.PageSetup
    .PageHeight = InchesToPoints(9)
    .PageWidth = InchesToPoints(7)
End With


PageNumbers-Eigenschaft

Gibt eine PageNumbers-Auflistung zurück, die alle Seitenzahl-Felder darstellt, die in der angegebenen Kopf- oder Fußzeile enthalten sind. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


PageNumberSeparator-Eigenschaft

Gibt die Zeichen (bis zu fünf) zurück, mit denen einzelne Seitenverweise in einem Rechtsgrundlagenverzeichnis getrennt werden, oder legt sie fest. Standardmäßig werden ein Komma und ein Leerzeichen eingesetzt. Entspricht dem Schalter \l in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). String Schreib-Lese-Zugriff.


Beispiel zur PageNumberSeparator-Eigenschaft

In diesem Beispiel wird festgelegt, dass in den Rechtsgrundlagenverzeichnissen im aktiven Dokument Kommata verwendet werden, um Seitenverweise zu trennen (beispielsweise "9,12").

For Each myTOA In ActiveDocument.TablesOfAuthorities
    myTOA.PageNumberSeparator = ","
Next myTOA


PageRangeSeparator-Eigenschaft

Gibt die Zeichen (bis zu fünf) zurück, die im Rechtsgrundlagenverzeichnis zwischen die erste und letzte Seite in jedem Seitenbereich gesetzt werden. Als Standard wird ein Halbgeviertstrich verwendet. Entspricht dem Schalter \g in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld. String Schreib-Lese-Zugriff.


Beispiel zur PageRangeSeparator-Eigenschaft

In diesem Beispiel wird festgelegt, dass im ersten Rechtsgrundlagenverzeichnis im aktiven Dokument ein Bindestrich mit führendem und nachfolgendem Leerzeichen als Trennzeichen für Seitenbereiche verwendet wird (beispielsweise "9 - 12").

ActiveDocument.TablesOfAuthorities(1).PageRangeSeparator = " - "


PageRows-Eigenschaft

Gibt die Anzahl der Seiten zurück, die in der Seitenlayoutansicht oder der Seitenansicht gleichzeitig übereinander auf dem Bildschirm angezeigt werden sollen, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur PageRows-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Seitenansicht umgeschaltet, und es werden zwei Seiten übereinander angezeigt.

PrintPreview = True
With ActiveDocument.ActiveWindow.View.Zoom
    .PageColumns = 1
    .PageRows = 2
End With


PageSetup-Eigenschaft

Gibt ein PageSetup-Objekt zurück, das mit dem angegebenen Dokument, Bereich, dem angegebenen Abschnitt bzw. den angegebenen Abschnitten oder der angegebenen Markierung verbunden ist. Nur-Lese-Zugriff.


Beispiel zur PageSetup-Eigenschaft

In diesem Beispiel wird der rechte Seitenrand des aktiven Dokuments auf 72 Punkt (1 Zoll) eingestellt.

ActiveDocument.PageSetup.RightMargin = InchesToPoints(1)

In diesem Beispiel wird der Bundsteg für den ersten Abschnitt in Zusammenfassung.doc auf 36 Punkt (0,5 Zoll) eingestellt.

Documents("Summary.doc").Sections(1).PageSetup.Gutter = 36

In diesem Beispiel wird der Abstand der Kopfzeile bzw. der Fußzeile zum oberen bzw. zum unteren Seitenrand auf 18 Punkt (0,25 Zoll) eingestellt. Diese Änderung der Formatierung wird dem Bereich zugewiesen, der die Markierung enthält.

With Selection.PageSetup
    .FooterDistance = 18
    .HeaderDistance = 18
End With

Dieses Beispiel zeigt die Einstellung des linken Seitenrands in Zoll an.

MsgBox PointsToInches(ActiveDocument.PageSetup.LeftMargin) _
    & " inches"


PageSize-Eigenschaft

Gibt das Seitenformat für das angegebene benutzerdefinierte Adressetikett zurück oder legt es fest. Dies kann eine der folgenden WdCustomLabelPageSize-Konstanten sein: wdCustomLabelA4, wdCustomLabelA4LS, wdCustomLabelA5, wdCustomLabelA5LS, wdCustomLabelB4JIS, wdCustomLabelB5, wdCustomLabelFanfold, wdCustomLabelHigaki, wdCustomLabelHigakiLS, wdCustomLabelLetter, wdCustomLabelLetterLS, wdCustomLabelMini wdCustomLabelVertHalfSheet oder wdCustomLabelVertHalfSheetLS. Long Schreib-Lese-Zugriff.

Hinweise

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung ab (z. B. Deutsch).


Beispiel zur PageSize-Eigenschaft

In diesem Beispiel wird ein neues benutzerdefiniertes Etikett namens "Privatadresse" erstellt, und dann werden verschiedene Eigenschaften für das Etikett festgelegt, einschließlich des Seitenformats.

Set myLabel = Application.MailingLabel _
    .CustomLabels.Add(Name:="Home Address", DotMatrix:=False)
With myLabel
    .Height = InchesToPoints(0.5)
    .HorizontalPitch = InchesToPoints(2.06)
    .NumberAcross = 4
    .NumberDown = 20
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.28)
    .TopMargin = InchesToPoints(0.5)
    .VerticalPitch = InchesToPoints(0.5)
    .Width = InchesToPoints(1.75)
End With


PageWidth-Eigenschaft

Gibt die Seitenbreite in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Die Einstellung der PageWidth-Eigenschaft ändert die PaperSize-Eigenschaft in wdPaperCustom.

Verwenden Sie die PaperSize-Eigenschaft zum Einstellen der Seitenhöhe und Seitenbreite auf eine vordefinierte Papiergröße wie Letter oder A4.


Beispiel zur PageWidth-Eigenschaft

In diesem Beispiel wird die Seitenbreite für Dokument1 zurückgegeben. Die PointsToInches-Methode wird zur Umwandlung von Punkt in Zoll verwendet.

Set doc1set = Documents("Document1").PageSetup
Msgbox "The page width is " _
    & PointsToInches(doc1set.PageWidth) & " inches."


Pagination-Eigenschaft

True, wenn Word bei Dokumenten einen Seitenumbruch im Hintergrund durchführt. Boolean Schreib-Lese-Zugriff.


Beispiel zur Pagination-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass der Seitenumbruch im Hintergrund durchgeführt wird.

Options.Pagination = True

In diesem Beispiel wird der aktuelle Status der Option Seitenumbruch im Hintergrund auf der Registerkarte Allgemein im Dialogfeld Optionen zurückgegeben.

temp = Options.Pagination


Panes-Eigenschaft

Gibt eine Panes-Auflistung zurück, die alle Fensterausschnitte für das angegebene Fenster darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elementes einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Panes-Eigenschaft

In diesem Beispiel wird das aktive Fenster in zwei Hälften geteilt.

If ActiveDocument.ActiveWindow.Panes.Count = 1 Then _
    ActiveDocument.ActiveWindow.Panes.Add

In diesem Beispiel wird im Fenster für Dokument2 der erste Ausschnitt aktiviert.

Windows("Document2").Panes(1).Activate


PaperSize-Eigenschaft

Gibt das Papierformat zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdPaperSize-Konstanten handeln:

wdPaper10x14

wdPaper11x17

wdPaperA3

wdPaperA4

wdPaperA4Small

wdPaperA5

wdPaperB4

wdPaperB5

wdPaperCSheet

wdPaperCustom

wdPaperDSheet

wdPaperEnvelope10

wdPaperEnvelope11

wdPaperEnvelope12

wdPaperEnvelope14

wdPaperEnvelope9

wdPaperEnvelopeB4

wdPaperEnvelopeB5

wdPaperEnvelopeB6

wdPaperEnvelopeC3

wdPaperEnvelopeC4

 wdPaperEnvelopeC5

wdPaperEnvelopeC6

wdPaperEnvelopeC65

wdPaperEnvelopeDL

wdPaperEnvelopeItaly

wdPaperEnvelopeMonarch

wdPaperEnvelopePersonal

wdPaperESheet

wdPaperExecutive

wdPaperFanfoldLegalGerman

wdPaperFanfoldStdGerman

wdPaperFanfoldUS

wdPaperFolio

wdPaperLedger

wdPaperLegal

wdPaperLetter

wdPaperLetterSmall

wdPaperHinweis

wdPaperQuarto

wdPaperStatement

wdPaperTabloid

Anmerkungen

Wenn Sie die PageHeight-Eigenschaft oder die PageWidth-Eigenschaft setzen, wird die PaperSize-Eigenschaft auf wdPaperCustom geändert.


Beispiel zur PaperSize-Eigenschaft

In diesem Beispiel wird das Papierformat für das erste Dokument auf Legal gesetzt.

Documents(1).PageSetup.PaperSize = wdPaperLegal


ParagraphFormat-Eigenschaft

Gibt ein ParagraphFormat-Objekt, das die Absatzeinstellungen für den angegebenen Bereich, die Auswahl, die Suchen- bzw. Ersetzenoperation oder die Formatvorlage darstellt, zurück oder legt ihn fest. Schreib-Lese-Zugriff.


Beispiel zur ParagraphFormat-Eigenschaft

In diesem Beispiel wird die Absatzformatierung für die aktuelle Auswahl auf rechtsbündig gesetzt.

Selection.ParagraphFormat.Alignment = wdAlignParagraphRight

In diesem Beispiel wird die Absatzformatierung für den Bereich gesetzt, der den gesamten Inhalt von MyDocument.doc enthält. Die Absätze in diesem Dokument sind zweizeilig und haben einen benutzerdefinierten Tabstop bei 0,25 Zoll.

Set myRange = Documents("MyDoc.doc").Content
With myRange.ParagraphFormat
    .Space2
    .TabStops.Add Position:=InchesToPoints(.25)
End With

In diesem Beispiel wird die Formatvorlage Überschrift 2 für das aktive Dokument modifiziert. Mit dieser Formatvorlage formatierte Absätze werden bis zum ersten Tabstop eingezogen und sind zweizeilig.

With ActiveDocument.Styles(wdStyleHeading2).ParagraphFormat
    .TabIndent(1)
    .Space2
End With

In diesem Beispiel werden alle zweizeilig formatierten Absätze im aktiven Dokument gesucht und mit anderthalbzeiligem Zeilenabstand formatiert.

With ActiveDocument.Content.Find
    .ClearFormatting
    .ParagraphFormat.Space2
    .Replacement.ClearFormatting
    .Replacement.ParagraphFormat.Space15
    .Execute FindText:="", ReplaceWith:="", _
        Replace:=wdReplaceAll
End With


Paragraphs-Eigenschaft

Gibt eine Paragraphs-Auflistung zurück, die alle Absätze im angegebenen Dokument, Bereich oder in der Markierung darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Paragraphs-Eigenschaft

In diesem Beispiel wird im aktiven Dokument für die Auflistung aller Absätze in Abschnitt 1 der einfache Zeilenabstand festgelegt.

ActiveDocument.Sections(1).Range.Paragraphs.LineSpacingRule = _
    wdLineSpaceSingle

In diesem Beispiel wird für den ersten Absatz in der Markierung doppelter Zeilenabstand eingestellt.

Selection.Paragraphs(1).LineSpacingRule = wdLineSpaceDouble


Parent-Eigenschaft

Gibt das übergeordnete Objekt des angegebenen Objekts zurück. Nur-Lese-Zugriff.


ParentFrameset-Eigenschaft

Gibt das übergeordnete Frameset-Objekt des angegebenen Frameset-Objekts auf einer Framesseite zurück. Nur-Lese-Zugriff.

Hinweise

Weitere Informationen zum Erstellen von Framesseiten finden Sie unter Erstellen von Framesseiten.


Beispiel zur ParentFrameset-Eigenschaft

In diesem Beispiel werden die untergeordneten Frameset-Objekte zurückgegeben, die zum übergeordneten Frameset-Objekt des angegebenen Frames gehören.

MsgBox ActiveDocument.ActiveWindow.ActivePane _
    .Frameset.ParentFrameset.ChildFramesetCount


PartOfSpeechList-Eigenschaft

Gibt eine Liste von Sprachelementen zurück. Sie entspricht den Bedeutungen, die für das Wort oder den Ausdruck gefunden wurden, das bzw. der im Thesaurus nachgeschlagen wurde. Die Liste wird als Integerbereich zurückgegeben. Variant Nur-Lese-Zugriff.

Hinweise

Die Liste der Sprachelemente wird als Bereich zurückgegeben, der aus den folgenden WdPartOfSpeech-Konstanten besteht: wdAdjective, wdAdverb, wdConjunction, wdIdiom, wdInterjection, wdNoun, wdOther, wdPreposition, wdPronoun und wdVerb. Die Bereichselemente sind so geordnet, dass sie den Elementen entsprechen, die von der MeaningList-Eigenschaft zurückgegeben werden.


Beispiel zur PartOfSpeechList-Eigenschaft

In diesem Beispiel wird überprüft, ob der Thesaurus irgendwelche Bedeutungen für die Markierung gefunden hat. Wenn das der Fall ist, werden die Bedeutungen und ihre entsprechenden Sprachelemente in einer Reihe von Meldungsfeldern angezeigt.

Set mySynInfo = Selection.Range.SynonymInfo
If mySynInfo.MeaningCount <> 0 Then
    myList = mySynInfo.MeaningList
    myPos = mySynInfo.PartOfSpeechList
    For i = 1 To UBound(myPos)
        Select Case myPos(i)
            Case wdAdjective
                 pos = "adjective"
            Case wdNoun
                 pos = "noun"
            Case wdAdverb
                 pos = "adverb"
            Case wdVerb
                 pos = "verb"
            Case Else
                 pos = "other"
        End Select
        MsgBox myList(i) & " found as " & pos
    Next i
Else
    MsgBox "There were no meanings found."
End If


Passim-Eigenschaft

True, wenn fünf oder mehr Verweise auf Seiten in derselben Quelle durch "Passim" ersetzt werden sollen. Entspricht dem Schalter \p in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Boolean Schreib-Lese-Zugriff.


Beispiel zur Passim-Eigenschaft

In diesem Beispiel wird festgelegt, dass im ersten Rechtsgrundlagenverzeichnis in Brief.doc statt "Passim" Seitenverweise verwendet werden.

Documents("Brief.doc").TablesOfAuthorities(1).Passim = False

In diesem Beispiel wird festgelegt, dass jedes Vorkommen von fünf oder mehr Seitenverweisen auf dieselbe Quelle in den Rechtsgrundlagenverzeichnissen im aktiven Dokument durch "Passim" ersetzt werden.

For Each myTOA In ActiveDocument.TablesOfAuthorities
    myToa.Passim = True
Next myTOA


Password-Eigenschaft

Legt ein Kennwort fest, das zum Öffnen des angegebenen Dokuments bereitgestellt werden muss. String Nur-Schreib-Zugriff.


Beispiel zur Password-Eigenschaft

In diesem Beispiel wird Gewinn.doc geöffnet, ein Kennwort für das Dokument festgelegt und dieses dann geschlossen.

Set myDoc = Documents _
    .Open(FileName:="C:\My Documents\Earnings.doc")
myDoc.Password = "why"
myDoc.Close


Path-Eigenschaft

Gibt den Laufwerk- oder Webpfad an das angegebene AddIn-, Application-, Dictionary-, Document-, FileConverter-, RecentFile-, Subdocument- oder Template-Objekt zurück. String Nur-Lese-Zugriff.

Hinweise

Der Pfad enthält kein nachstehendes Zeichen (zum Beispiel: C:\MSOffice oder http://MyServer). Mit der PathSeparator-Eigenschaft können Sie das Zeichen eingeben, das Ordner und Laufwerkbuchstaben trennt. Mit der Name-Eigenschaft können Sie den Dateinamen ohne Pfad, mit der FullName-Eigenschaft den Dateinamen zusammen mit dem Pfad zurückgeben.

Anmerkung Mit der PathSeparator-Eigenschaft können Sie Webadressen erstellen, obwohl diese Schrägstriche (/) enthalten. Der Standardwert der PathSeparator-Eigenschaft ist ein umgekehrter Schrägstrich (\).


PathSeparator-Eigenschaft

Gibt das Zeichen zurück, mit dem Ordnernamen voneinander getrennt werden. Diese Eigenschaft gibt einen umgekehrten Schrägstrich (\) zurück.

Hinweise

Mit dem PathSeparator können Sie Webadressen erstellen, obwohl diese Schrägstriche (/) enthalten.

Anmerkung Die FullName-Eigenschaft gibt den Pfad und den Dateinamen in einer Zeichenfolge zurück.


Beispiel zur PathSeparator-Eigenschaft

In diesem Beispiel werden der Pfad und der Dateiname des aktiven Dokuments angezeigt.

MsgBox ActiveDocument.Path & Application.PathSeparator & _
    ActiveDocument.Name

Wenn das erste Add-In eine Vorlage ist, wird sie in diesem Beispiel herausgenommen und geöffnet.

If Addins(1).Compiled = False Then
    Addins(1).Installed = False
    Documents.Open FileName:=AddIns(1).Path _
        & Application.PathSeparator _
        & AddIns(1).Name
End If


Pattern-Eigenschaft

Gibt einen Wert zurück, der das Muster darstellt, das dem angegebenen Füllbereich oder der angegebenen Linie zugewiesen wurde. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBrick

msoPatternDivot

msoPatternDottedDiamond

msoPatternDottedGrid

msoPatternHorizontalBrick

 msoPatternLargeCheckerBoard

msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamond

msoPatternPlaid

msoPatternShingle

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamond

msoPatternSphere

msoPatternTrellis

msoPatternWave

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal

msoPatternZigZag

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die Patterned-Methode zum Festlegen des Musters für den Füllbereich oder die Linie.

Verwenden Sie die BackColor- und die ForeColor-Eigenschaft zum Festlegen der Farben, die in dem Muster verwendet werden.


Beispiel zur Pattern-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und sein Füllmuster so festgelegt, dass es mit dem der Form "rect1" übereinstimmt. Das neue Rechteck hat dasselbe Muster wie Recht1, aber nicht unbedingt dieselben Farben. Die Farben, die in dem Muster verwendet werden, werden mit der BackColor- und der ForeColor-Eigenschaft festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    pattern1 = .Item("rect1").Fill.Pattern
    With .AddShape(msoShapeRectangle, 100, 100, 120, 80).Fill
        .ForeColor.RGB = RGB(128, 0, 0)
        .BackColor.RGB = RGB(0, 0, 255)
        .Patterned pattern1
    End With
End With

In diesem Beispiel wird eine gemusterte Linie zu myDocument hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 100, 250, 0).Line
    .Weight = 6
    .ForeColor.RGB = RGB(0, 0, 255)
    .BackColor.RGB = RGB(128, 0, 0)
    .Pattern = msoPatternDarkDownwardDiagonal
End With


Percentage-Eigenschaft

Gibt die Vergrößerung für ein Fenster als Prozentwert zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Percentage-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Normalansicht umgeschaltet und die Vergrößerung auf 80 Prozent eingestellt.

With ActiveDocument.ActiveWindow.View
    .Type = wdNormalView
    .Zoom.Percentage = 80
End With

In diesem Beispiel wird die Vergrößerung des aktiven Fensters um 10 Prozent erhöht.

Set myZoom = ActiveDocument.ActiveWindow.View.Zoom
myZoom.Percentage = myZoom.Percentage + 10


PercentWidth-Eigenschaft

Gibt die Länge der angegebenen horizontalen Linie als prozentualen Wert der Fensterbreite zurück oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweise

Durch Einstellen dieser Eigenschaft wird auch die WidthType-Eigenschaft auf wdHorizontalLinePercentWidth gesetzt.


Beispiel zur PercentWidth-Eigenschaft

In diesem Beispiel wird eine horizontale Linie hinzugefügt und deren Länge auf 50 Prozent der Fensterbreite gesetzt.

Selection.InlineShapes.AddHorizontalLineStandard
ActiveDocument.InlineShapes(1) _
    .HorizontalLineFormat.PercentWidth = 50


Perspective-Eigenschaft

True, wenn die Extrusion perspektivisch erscheint, das heißt, wenn sich die Extrusionswände zu einem Fluchtpunkt verjüngen. False, wenn die Extrusion eine Parallel- oder Senkrechtextrusion ist, das heißt, wenn sich die Wände nicht zu einem Fluchtpunkt verjüngen. Long Schreib-Lese-Zugriff.


Beispiel zur Perspective-Eigenschaft

In diesem Beispiel wird die Projektionstiefe für Form eins in myDocument auf 100 Punkt festgelegt und spezifiziert, dass die Projektion parallel oder senkrecht sein soll.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .Depth = 100
    .Perspective = False
End With


PictureEditor-Eigenschaft

Gibt den Namen der Anwendung zurück oder legt ihn fest, mit der Bilder bearbeitet werden. String Schreib-Lese-Zugriff.

Hinweise

Sie müssen die genaue Wortwahl benutzen, die im Feld Bild-Editor auf der Registerkarte Bearbeiten im Dialogfeld Optionen angezeigt wird. Sonst wird die Standardeinstellung "Microsoft Word" verwendet.

Wenn der Name der von Ihnen verwendeten Grafikanwendung nicht in der Liste erscheint, dann bitten Sie den Hersteller der Grafikanwendung um Anweisungen.


Beispiel zur PictureEditor-Eigenschaft

In diesem Beispiel wird die Anwendung zur Bildbearbeitung festgelegt.

Options.PictureEditor = "Microsoft Word"

In diesem Beispiel wird der Name der Anwendung zur Bildbearbeitung zurückgegeben.

MsgBox Options.PictureEditor


PictureFormat-Eigenschaft

Gibt ein PictureFormat-Objekt zurück, das Grafikformatierungseigenschaften für das angegebene Objekt enthält. Betrifft Shape-, ShapeRange- oder InlineShape-Objekte, die Grafiken oder OLE-Objekte darstellen. Nur-Lese-Zugriff.


Beispiel zur PictureFormat-Eigenschaft

In diesem Beispiel werden die Helligkeit und der Kontrast für Form eins in myDocument eingestellt. Form eins muss eine Grafik oder ein OLE-Objekt sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = .75
End With


PixelsPerInch-Eigenschaft

Gibt die Dichte (in Pixel pro Zoll) von Grafiken, Bildern und Tabellenzellen auf einer Webseite zurück oder legt diese fest. Der Einstellungsbereich liegt zwischen 19 und 480, für übliche Bildschirmgrößen werden im Allgemeinen die Werte 72, 96 oder 120 festgelegt. Die Standardeinstellung beträgt 96. Long Schreib-Lese-Zugriff.

Hinweise

Durch diese Eigenschaft wird die Größe von Bildern und Zellen auf der angegebenen Webseite im Verhältnis zur Größe des Textes festgelegt, wenn Sie das gespeicherte Dokument in einem Webbrowser betrachten. Die resultierenden Abmessungen des Bildes oder der Zelle sind das Ergebnis der ursprünglichen Abmessungen (in Zoll), multipliziert mit der Anzahl von Pixel pro Zoll.

Mit der ScreenSize-Eigenschaft können Sie die optimale Bildschirmgröße für den vorgesehenen Webbrowser einstellen.


Beispiel zur PixelsPerInch-Eigenschaft

In diesem Beispiel wird die Auflösung in Pixel abhängig von der Zielbildschirmgröße des Webbrowsers eingestellt.

With Application.DefaultWebOptions
    Select Case .ScreenSize
        Case msoScreenSize800x600
            .PixelsPerInch = 72
        Case msoScreenSize1024x768
            .PixelsPerInch = 96
        Case Else
            .PixelsPerInch = 120
    End Select
End With


 Points-Eigenschaft

Points-Eigenschaft

Gibt die Position des angegebenen Knotens als Koordinatenpaar zurück. Jede Koordinate wird in Punkt ausgedrückt. Variant Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetPosition-Methode zum Festlegen der Position des Knotens.


Beispiel zur Points-Eigenschaft

In diesem Beispiel wird Knoten zwei in Form drei in myDocument um 200 Punkt nach rechts und um 300 Punkt nach unten verschoben. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(1, 1)
    currYvalue = pointsArray(1, 2)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


PortraitFontNames-Eigenschaft

Gibt ein FontNames-Objekt mit den Namen aller verfügbaren Portrait-Schriftarten zurück. Nur-Lese-Zugriff.


Beispiel zur PortraitFontNames-Eigenschaft

In diesem Beispiel wird eine Liste von Portrait-Schriftarten an der Einfügemarke eingefügt.

For Each aFont In PortraitFontNames
    With Selection
        .Collapse Direction:=wdCollapseEnd
        .InsertAfter aFont
        .InsertParagraphAfter
        .Collapse Direction:=wdCollapseEnd
    End With
Next aFont


Position-Eigenschaft

CaptionLabel-Objekt: Gibt die Position des Textes der Beschriftungskategorie zurück oder legt sie fest. Dies kann eine der folgenden WdCaptionPosition-Konstanten sein: wdCaptionPositionAbove oder wdCaptionPositionBelow. Long Schreib-Lese-Zugriff.

DropCap-Objekt: Gibt die Position eines Initialbuchstabens zurück oder legt sie fest. Dies kann eine der folgenden WdDropPosition-Konstanten sein: wdDropMargin, wdDropNone oder wdDropNormal. Long Schreib-Lese-Zugriff.

Font-Objekt: Gibt die Position von Text (in Punkt) relativ zur Grundlinie zurück oder legt sie fest. Eine positive Zahl verschiebt den Text nach oben, eine negative Zahl verschiebt den Text nach unten. Long Schreib-Lese-Zugriff.

TabStop-Objekt: Gibt die Position eines Tabstopps relativ zum linken Seitenrand zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur Position-Eigenschaft

Dieses Beispiel verschiebt den markierten Text um 2 Punkt nach unten.

Selection.Font.Position = -2

In diesem Beispiel wird den markierten Absätzen ein rechter Tabstop, 2 Zoll vom linken Seitenrand entfernt hinzugefügt. Die Position des Tabstops wird dann in einem Meldungsfeld angezeigt.

With Selection.Paragraphs.TabStops
    .ClearAll
    .Add Position:=InchesToPoints(2), Alignment:=wdAlignTabRight
    MsgBox .Item(1).Position & " or " & _
        PointsToInches(.Item(1).Position) & " inches"
End With

In diesem Beispiel wird der erste Absatz im aktiven Dokument so eingestellt, dass er mit einem Initialbuchstaben beginnt. Die Position des DropCap-Objekts wird auf wdDropNormal eingestellt.

With ActiveDocument.Paragraphs(1).DropCap
    .Enable
    .FontName= "Arial"
    .Position = wdDropNormal
End With


PreferredWidth-Eigenschaft

Gibt die bevorzugte Breite (in Punkt oder als prozentualen Anteil der Fensterbreite) für die angegebenen Zellen oder Spalten oder die angegebene Tabelle zurück oder legt diese fest. Single Schreib-Lese-Zugriff.

Hinweise

Wenn die PreferredWidthType-Eigenschaft auf wdPreferredWidthPoints gesetzt wird, gibt die PreferredWidth-Eigenschaft die Breite in Punkt zurück oder legt diese fest. Wenn die PreferredWidthType-Eigenschaft auf wdPreferredWidthPercent gesetzt wird, gibt die PreferredWidth-Eigenschaft die Breite als prozentualen Anteil der Fensterbreite zurück oder legt diese fest.


PreferredWidthType-Eigenschaft

Gibt die Maßeinheit zurück, die für die bevorzugte Breite der angegebenen Zellen oder Spalten oder der angegebenen Tabelle verwendet werden soll, oder legt diese fest. Dabei kann es sich um eine der folgenden WdPreferredWidthType-Konstanten handeln: wdPreferredWidthAuto, wdPreferredWidthPercent oder wdPreferredWidthPoints. Long Schreib-Lese-Zugriff.


Beispiel zur PreferredWidthType-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word die bevorzugte Breite als prozentualen Anteil der Fensterbreite annimmt. Anschließend wird die bevorzugte Breite der ersten Tabelle im Dokument auf 50 Prozent der Fensterbreite festgelegt.

With ActiveDocument.Tables(1)
    .PreferredWidthType = wdPreferredWidthPercent
    .PreferredWidth = 50
End With


PresetExtrusionDirection-Eigenschaft

Gibt die Richtung zurück, in die die Projektion von der projizierten Form weggeführt werden soll (von der Vorderansicht der Projektion aus gesehen). Dies kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft, msoExtrusionTopRight oder msoPresetExtrusionDirectionMixed. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Zum Festlegen des Werts dieser Eigenschaft verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur PresetExtrusionDirection-Eigenschaft

In diesem Beispiel wird jede Projektion in myDocument, die sich zur linken, oberen Ecke der Projektionsfront erstreckt in eine Projektion umgewandelt, die sich zur rechten, unteren Ecke der Projektionsfront erstreckt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    With s.ThreeD
        If .PresetExtrusionDirection = msoExtrusionTopLeft Then
            .SetExtrusionDirection msoExtrusionBottomRight
        End If
    End With
Next


PresetGradientType-Eigenschaft

Gibt die Art der voreingestellten fließenden Farbe für den angegebenen Füllbereich zurück. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetGradient-Methode zum Festlegen der Art der voreingestellten fließenden Farbe für die Füllung.


Beispiel zur PresetGradientType-Eigenschaft

In diesem Beispiel wird in myDocument bei allen Formen mit der voreingestellten fließenden Füllfarbe Moos die Füllung in die voreingestellte fließende Farbe Nebel umgewandelt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    With s.Fill
        If .PresetGradientType = msoGradientMoss Then
            .PresetGradient msoGradientHorizontal, 1, _
                msoGradientFog
        End If
    End With
Next


PresetLightingDirection-Eigenschaft

Gibt die Position der Lichtquelle relativ zur Projektion zurück oder legt sie fest. Dies kann eine der folgenden MsoPresetLightingDirection-Konstanten sein: msoLightingBottom, msoLightingBottomLeft, msoLightingBottomRight, msoLightingLeft, msoLightingNone, msoLightingRight, msoLightingTop, msoLightingTopLeft, msoLightingTopRight oder msoPresetLightingDirectionMixed. Long Schreib-Lese-Zugriff.

Hinweis Der festgelegte Beleuchtungseffekt ist nicht zu sehen, wenn die Projektion eine Drahtrahmenoberfläche aufweist.


Beispiel zur PresetLightingDirection-Eigenschaft

In diesem Beispiel wird spezifiziert, dass die Projektion für Form eins in myDocument der Obergrenze der Form zu gerichtet ist und die Beleuchtung für die Projektion von links kommt.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


PresetLightingSoftness-Eigenschaft

Gibt die Intensität der Projektionsbeleuchtung zurück oder legt sie fest. Dies kann eine der folgenden MsoPresetLightingSoftness-Konstanten sein: msoLightingBright, msoLightingDim, msoLightingNormal oder msoPresetLightingSoftnessMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetLightingSoftness-Eigenschaft

In diesem Beispiel wird spezifiziert, dass in myDocument die Projektion für Form eins so ausdehnt, dass Sie hell von links beleuchtet wird.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetLightingSoftness = msoLightingBright
    .PresetLightingDirection = msoLightingLeft
End With


PresetMaterial-Eigenschaft

Gibt das Projektions-Oberflächenmaterial zurück oder legt es fest. Dies kann eine der folgenden MsoPresetMaterial-Konstanten sein: msoMaterialMatte, msoMaterialMetal, msoMaterialPlastic, msoMaterialWireFrame oder msoPresetMaterialMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetMaterial-Eigenschaft

In diesem Beispiel wird spezifiziert, dass die Projektionsoberfläche für Form eins in myDocument ein Drahtrahmen sein soll.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetMaterial = msoMaterialWireFrame
End With


PresetShape-Eigenschaft

Gibt die Form des angegebenen WordArt-Objekts zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTextEffectShape-Konstanten sein:

msoTextEffectShapeArchDownCurve

msoTextEffectShapeArchDownPour

msoTextEffectShapeArchUpCurve

msoTextEffectShapeArchUpPour

msoTextEffectShapeButtonCurve

msoTextEffectShapeButtonPour

msoTextEffectShapeCanDown

msoTextEffectShapeCanUp

msoTextEffectShapeCascadeDown

msoTextEffectShapeCascadeUp

msoTextEffectShapeChevronDown

msoTextEffectShapeChevronUp

msoTextEffectShapeCircleCurve

msoTextEffectShapeCirclePour

msoTextEffectShapeCurveDown

msoTextEffectShapeCurveUp

msoTextEffectShapeDeflate

msoTextEffectShapeDeflateBottom

msoTextEffectShapeDeflateInflate

msoTextEffectShapeDeflateInflateDeflate

msoTextEffectShapeDeflateTop

 msoTextEffectShapeDoubleWave1

msoTextEffectShapeDoubleWave2

msoTextEffectShapeFadeDown

msoTextEffectShapeFadeLeft

msoTextEffectShapeFadeRight

msoTextEffectShapeFadeUp

msoTextEffectShapeInflate

msoTextEffectShapeInflateBottom

msoTextEffectShapeInflateTop

msoTextEffectShapeMixed

msoTextEffectShapePlainText

msoTextEffectShapeRingInside

msoTextEffectShapeRingOutside

msoTextEffectShapeSlantDown

msoTextEffectShapeSlantUp

msoTextEffectShapeStop

msoTextEffectShapeTriangleDown

msoTextEffectShapeTriangleUp

msoTextEffectShapeWave1

msoTextEffectShapeWave2

Anmerkungen

Beim Festlegen der PresetTextEffect-Eigenschaft wird automatisch die PresetShape-Eigenschaft eingestellt.


Beispiel zur PresetShape-Eigenschaft

In diesem Beispiel wird die Form aller WordArt-Objekte in myDocument auf ein Chevron-Zeichen festgelegt, dessen Mittelpunkt nach unten zeigt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetShape = msoTextEffectShapeChevronDown
    End If
Next


PresetTextEffect-Eigenschaft

Gibt den Stil des angegebenen WordArt-Objekts zurück oder legt ihn fest. Die Werte für diese Eigenschaft entsprechen den Formaten im Dialogfeld WordArt-Katalog (die von links nach rechts und von oben nach unten nummeriert sind). Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTextEffect-Konstanten sein:

msoTextEffect1

msoTextEffect2

msoTextEffect3

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

msoTextEffect16

 msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect20

msoTextEffect21

msoTextEffect22

msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect30

msoTextEffectMixed

Anmerkungen

Durch das Festlegen der PresetTextEffect-Eigenschaft werden automatisch viele andere Formatierungseigenschaften der angegebenen Form eingestellt.


Beispiel zur PresetTextEffect-Eigenschaft

In diesem Beispiel wird für alle WordArt-Objekte in myDocument der Stil auf den ersten Stil festgelegt, der im Dialogfeld WordArt-Katalog aufgelistet wird.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetTextEffect = msoTextEffect1
    End If
Next


PresetTexture-Eigenschaft

Gibt die voreingestellte Textur für den angegebenen Füllbereich zurück. Long Nur-Lese-Zugriff.

Dies kann eine der folgenden MsoPresetTexture-Konstanten sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetTextured-Methode zum Festlegen der voreingestellten Textur für den Füllbereich.


Beispiel zur PresetTexture-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck hinzugefügt und festgelegt, dass dessen voreingestellte Textur mit derjenigen der Form zwei übereinstimmt. Damit das Beispiel funktioniert, muss Form zwei eine voreingestellte Texturfüllung haben.

Set myDocument = ActiveDocument
With myDocument.Shapes
    presetTexture2 = .Item(2).Fill.PresetTexture
    .AddShape(msoShapeRectangle, 100, 0, 40, 80).Fill _
        .PresetTextured presetTexture2
End With


PresetThreeDFormat-Eigenschaft

Gibt das voreingestellte Extrusionsformat zurück. Jedes voreingestellte Extrusionsformat enthält einen Satz von voreingestellten Werten für die verschiedenen Eigenschaften der Extrusion. Wenn der Extrusion ein benutzerdefiniertes und kein voreingestelltes Format zugewiesen wurde, gibt diese Eigenschaft msoPresetThreeDFormatMixed zurück. Dabei kann es sich um eine der folgenden MsoPresetThreeDFormat-Konstanten handeln: msoPresetThreeDFormatMixed, msoThreeD1, msoThreeD2, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8, msoThreeD9, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19 oder msoThreeD20. Die Werte für diese Eigenschaft entsprechen den Optionen (von links nach rechts und von oben nach unten nummeriert), die eingeblendet werden, wenn Sie auf die Schaltfläche 3D auf der Symbolleiste Zeichnen klicken. Long Nur-Lese-Zugriff.

Hinweise

Diese Eigenschaft ist schreibgeschützt. Zum Festlegen des voreingestellten Extrusionsformats verwenden Sie die SetThreeDFormat-Methode.


Beispiel zur PresetThreeDFormat-Eigenschaft

In diesem Beispiel wird in myDocument das Projektionsformat für Form eins auf den 3D-Stil "12" festgelegt, wenn die Form anfangs ein benutzerdefiniertes Projektionsformat hat.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    If .PresetThreeDFormat = msoPresetThreeDFormatMixed Then
        .SetThreeDFormat msoThreeD12
    End If
End With


Previous-Eigenschaft

Gibt das vorherige Objekt in der Auflistung zurück. Nur-Lese-Zugriff.


PreviousBookmarkID-Eigenschaft

Gibt die Nummer der letzten Textmarke zurück, die vor oder an derselben Stelle wie die angegebene Auswahl oder der Bereich beginnt. Wenn keine entsprechende Textmarke existiert wird 0 (Null) zurückgegeben. Long Nur-Lese-Zugriff.


Beispiel zur PreviousBookmarkID-Eigenschaft

In diesem Beispiel wird die vorherige Textmarke im aktiven Dokument gewählt.

num = Selection.PreviousBookmarkID
If num <> 0 Then ActiveDocument.Content.Bookmarks(num).Select

In diesem Beispiel wird der Name der Textmarke vor dem zweiten Absatz angezeigt.

num = ActiveDocument.Paragraphs(2).Range.PreviousBookmarkID
If num <> 0 Then MsgBox ActiveDocument.Content.Bookmarks(num).Name


PrintBackground-Eigenschaft

True, wenn Word im Hintergrund druckt. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintBackground-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Dokumente im Hintergrund gedruckt werden, und dann wird das aktive Dokument gedruckt.

Options.PrintBackground = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Drucken im Hintergrund auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintBackground


PrintComments-Eigenschaft

True, wenn Word Kommentare auf eine neue Seite am Ende des Dokuments druckt. Boolean Schreib-Lese-Zugriff.

Amerkungen

Wird die PrintComments-Eigenschaft auf True gesetzt, dann wird automatisch die PrintHiddenText-Eigenschaft auf True gesetzt. Wird jedoch PrintComments-Eigenschaft auf False gesetzt, hat dies keinen Einfluss auf die Einstellung der PrintHiddenText-Eigenschaft.


Beispiel zur PrintComments-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Kommentare gedruckt werden und dann wird das aktive Dokument gedruckt.

Options.PrintComments = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Kommentar auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintComments


PrintDraft-Eigenschaft

True, wenn Word mit minimaler Formatierung druckt. Boolean Schreib-Lese-Zugriff.

Anmerkung Nicht alle Drucker unterstützen Konzeptdruck.


Beispiel zur PrintDraft-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Konzeptdruck verwendet und dann das aktive Dokument gedruckt wird.

Options.PrintDraft = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Konzeptausdruck auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintDraft


PrintDrawingObjects-Eigenschaft

True, wenn Word Zeichnungsobjekte druckt. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintDrawingObjects-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Zeichnungsobjekte gedruckt werden und dann wird das aktive Dokument gedruckt.

Options.PrintDrawingObjects = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Zeichnungsobjekte auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintDrawingObjects


PrintEvenPagesInAscendingOrder-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word prints even pages in ascending order during manual duplex printing. Read/write Boolean.

Remarks

If the ManualDuplexPrint argument of the PrintOut method is False, this property is ignored.

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur PrintEvenPagesInAscendingOrder-Eigenschaft

This example sets Microsoft Word to print odd pages in ascending order and even pages in descending order during manual duplex printing and prints the active document.

Options.PrintOddPagesInAscendingOrder = True
Options.PrintEvenPagesInAscendingOrder = False
ActiveDocument.PrintOut ManualDuplexPrint:=True


PrintFieldCodes-Eigenschaft

True, wenn Word Feldfunktionen anstelle von Feldergebnissen druckt. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintFieldCodes-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Feldfunktionen gedruckt werden und dann wird das aktive Dokument gedruckt.

Options.PrintFieldCodes = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Feldfunktionen auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintFieldCodes


PrintFormsData-Eigenschaft

True, wenn Word auf ein vorgedrucktes Formular nur die Daten druckt, die in das entsprechende Online-Formular eingegeben wurden. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintFormsData-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass nur die Daten aus einem Online-Formular gedruckt werden und dann wird das aktive Dokument gedruckt.

ActiveDocument.PrintFormsData = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option In Formularen nur Daten drucken auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = ActiveDocument.PrintFormsData


PrintFractionalWidths-Eigenschaft

True, wenn das angegebene Dokument so formatiert ist, dass zum Anzeigen und Drucken von Zeichen "Optimaler Wortzwischenraum" verwendet wird. Boolean Schreib-Lese-Zugriff.

Anmerkung In Windows gibt diese Eigenschaft immer False zurück. Zusätzliche Informationen über diese Eigenschaft erhalten Sie im Sprachverzeichnis der Microsoft Office 98 Macintosh Edition.


PrintHiddenText-Eigenschaft

True, wenn ausgeblendeter Text gedruckt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird die PrintHiddenText-Eigenschaft auf False gesetzt, dann wird automatisch die PrintComments-Eigenschaft auf False gesetzt. Wird jedoch die PrintHiddenText-Eigenschaft auf True gesetzt, so hat dies keine Auswirkungen auf die Einstellung der PrintComments-Eigenschaft.


Beispiel zur PrintHiddenText-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass ausgeblendeter Text gedruckt wird, und dann wird das aktive Dokument gedruckt.

Options.PrintHiddenText = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Ausgeblendeten Text auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintHiddenText


PrintOddPagesInAscendingOrder-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word prints odd pages in ascending order during manual duplex printing. Read/write Boolean.

Remarks

If the ManualDuplexPrint argument of the PrintOut method is False, this property is ignored.

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur PrintOddPagesInAscendingOrder-Eigenschaft

This example sets Microsoft Word to print odd pages in ascending order and even pages in descending order during manual duplex printing and prints the active document.

Options.PrintOddPagesInAscendingOrder = True
Options.PrintEvenPagesInAscendingOrder = False
ActiveDocument.PrintOut ManualDuplexPrint:=True


PrintPostScriptOverText-Eigenschaft

True, wenn PRINT-Feld-Anweisungen (z. B. PostScript-Befehle) in einem Dokument über Text und Grafiken auf einem PostScript-Drucker gedruckt werden. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft bestimmt, ob Postscript-Code aus einem konvertierten Word für Macintosh-Dokument gedruckt wird. Bei Dokumenten ohne PRINT-Felder hat diese Eigenschaft keine Auswirkungen.


Beispiel zur PrintPostScriptOverText-Eigenschaft

In diesem Beispiel wird bestimmt, dass Word PRINT-Feld-Anweisungen oberhalb von Text und Grafiken gedruckt werden, dann wird das aktive Dokument gedruckt.

ActiveDocument.PrintPostScriptOverText = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option PostScript über Text drucken auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

currSet = ActiveDocument.PrintPostScriptOverText


PrintPreview-Eigenschaft

True, wenn die aktuelle Ansicht die Seitenansicht ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintPreview-Eigenschaft

Dieses Beispiel wechselt zur Seitenansicht.

PrintPreview = True

Dieses Beispiel wechselt im aktiven Fenster von der Seitenansicht zur Normalansicht.

PrintPreview = False
ActiveDocument.ActiveWindow.View.Type = wdNormalView


PrintProperties-Eigenschaft

True, wenn Word Dokumenteigenschaften auf einer extra Seite am Ende des Dokuments ausdruckt. False, wenn Dokumenteigenschaften nicht ausgedruckt wird. Dokumenteigenschaften findet man im Dialogfeld Eigenschaften (Menü Datei). Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintProperties-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es Dokumenteigenschaften auf einer extra Seite am Ende des Dokuments ausdruckt, und anschließend wird das aktive Dokument ausgedruckt.

Options.PrintProperties = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Dokumenteigenschaften auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintProperties


PrintReverse-Eigenschaft

True, wenn Word Seiten in umgekehrter Reihenfolge druckt. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintReverse-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Seiten in umgekehrter Reihenfolge gedruckt werden, und dann wird das aktive Dokument gedruckt.

Options.PrintReverse = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Umgekehrte Druckreihenfolge auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.PrintReverse


PrintRevisions-Eigenschaft

True, wenn Korrekturmarkierungen mit dem Dokument gedruckt werden. False, wenn Korrekturmarkierungen nicht gedruckt werden (das heißt, Überarbeitungen werden gedruckt, als wären sie angenommen worden). Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintRevisions-Eigenschaft

In diesem Beispiel wird das aktive Dokument ohne Korrekturmarkierungen gedruckt.

With ActiveDocument
    .PrintRevisions = False
    .PrintOut
End With


PrivateProfileString-Eigenschaft

Gibt eine Zeichenfolge in einer Initialisierungsdatei oder der Windows-Registrierungsdatenbank zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Syntax

Ausdruck.PrivateProfileString(Filename, Section, Key)

Ausdruck Erforderlich. Ein Ausdruck, der ein System-Objekt zurückgibt.

Filename String erforderlich. Der Dateiname für die Initialisierungsdatei. Wenn kein Pfad angegeben wird, wird der Windows-Ordner vorausgesetzt. Wenn Sie Windows 95, Windows 98 oder Windows NT verwenden, um den Wert eines Eintrags der Registrierungsdatenbank zurückzugeben, muss Filename eine leere Zeichenfolge ("") sein.

Section String erforderlich. Der Name des Abschnitts in der Initialisierungsdatei, der Key enthält. In einer Windows-Initialisierungsdatei erscheint der Abschnittsname zwischen Klammern vor den zugehörigen Schlüsseln (geben Sie bei Section die Klammern nicht mit an). Wenn Sie den Wert eines Eintrags aus der Windows-Registrierungsdatenbank zurückgeben, sollte Section der vollständige Pfad zum Unterschlüssel sein, einschließlich der Unterstruktur (z. B. "HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options").

Key String erforderlich. Die Schlüsseleinstellung oder der Wert des Eintrags der Registrierungsdatenbank, den Sie abrufen wollen. In einer Windows-Initialisierungsdatei folgt auf den Schlüsselnamen ein Gleichheitszeichen (=) und die Einstellung. Wenn Sie den Wert eines Eintrags aus der Windows-Registrierungsdatenbank zurückgeben, sollte Key der Name eines Eintrags in dem Unterschlüssel sein, der in Section angegeben wird (beispielsweise "STARTUP-PATH").

Hinweise

Sie können Makros schreiben, die eine Initialisierungsdatei zum Speichern und Abrufen von Einstellungen verwenden. Beispielsweise können Sie den Namen des aktiven Dokuments speichern, wenn Sie Word verlassen, so dass dieses Dokument automatisch geöffnet werden kann, wenn Sie Word das nächste Mal starten. Eine Initialisierungsdatei ist eine Textdatei mit Informationen, die wie die Informationen in der Windows 3.x-Datei WIN.INI angeordnet sind.


Beispiel zur PrivateProfileString-Eigenschaft

In diesem Beispiel wird der aktuelle Dokumentname als Einstellung LastFile unter der Überschrift MacroSettings in Settings.txt eingestellt.

System.PrivateProfileString("C:\Settings.txt", "MacroSettings", _
    "LastFile") = ActiveDocument.FullName

In diesem Beispiel wird die Einstellung LastFile aus Settings.txt zurückgegeben und dann das Dokument geöffnet, das in LastFile gespeichert ist.

LastFile = System.PrivateProfileString("C:\Settings.Txt", _
    "MacroSettings", "LastFile")
If LastFile <> "" Then Documents.Open FileName:=LastFile

In diesem Beispiel wird der Wert eines EmailName-Eintrags aus der Windows-Registrierungsdatenbank angezeigt.

aName = System.PrivateProfileString("", _
    "HKEY_CURRENT_USER\Software\Microsoft\" _
    & "Windows\CurrentVersion\Internet Settings", "EmailName")
MsgBox aName


ProcessorType-Eigenschaft

Gibt den Prozessortyp zurück, der im System eingesetzt wird (z. B. i486). String Nur-Lese-Zugriff.


Beispiel zur ProcessorType-Eigenschaft

In diesem Beispiel wird eine Meldung in der Statuszeile angezeigt, wenn es sich beim verwendeten Prozessor nicht um einen Pentium handelt.

If System.ProcessorType <> "Pentium" Then _
    StatusBar = "Please wait..."


ProfileString-Eigenschaft

Gibt einen Wert eines Eintrags in der Windows-Registrierungsdatenbank unter dem folgenden Unterschlüssel HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Syntax

Ausdruck.ProfileString(Section, Key)

Ausdruck Erforderlich. Ein Ausdruck, der ein System-Objekt zurückgibt.

Section String erforderlich. Ein Unterschlüssel in der Windows-Registrierungsdatenbank unter dem Unterschlüssel "HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word".

Key String erforderlich. Der Name eines Eintrags im Unterschlüssel, der in Section angegeben ist (z. B. "BackgroundPrint" im Unterschlüssel "Options").


Beispiel zur ProfileString-Eigenschaft

In diesem Beispiel wird der Startpfad abgerufen und angezeigt, der in der Windows-Registrierungsdatenbank gespeichert ist.

MsgBox System.ProfileString("Options", "STARTUP-PATH")

In diesem Beispiel wird der Wert für einen Eintrag in der Windows-Registrierungsdatenbank festgelegt und zurückgegeben (der Unterschlüssel "SubkeyName" wird unter HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word hinzugefügt).

System.ProfileString("SubkeyName", "EntryName") = "Value"
MsgBox System.ProfileString("SubkeyName", "EntryName")


 ProgID-Eigenschaft

ProgID-Eigenschaft

Gibt den programmtechnischen Bezeichner (ProgID) für das angegebene OLE-Objekt zurück. String Nur-Lese-Zugriff.

Hinweise

Die ProgID- und ClassType-Eigenschaft geben (standardmäßig) dieselbe Zeichenfolge zurück. Sie können die ClassType-Eigenschaft für DDE-Verknüpfungen aber ändern.

Informationen über programmtechnische Bezeichner finden Sie unter Programmtechnische OLE-Bezeichner.


Beispiel zur ProgID-Eigenschaft

In diesem Beispiel werden alle beweglichen Formen im aktiven Dokument durchlaufen und festgelegt, dass alle verknüpften Microsoft Excel-Tabellen automatisch aktualisiert werden sollen.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        If s.OLEFormat.ProgID = "Excel.Sheet" Then
            s.LinkFormat.AutoUpdate = True
        End If
    End If
Next


Protect-Eigenschaft

Gibt den Schutztyp für das Dokument mit der angegebenen Verteilerliste zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdProtectionType-Konstanten handeln: wdAllowOnlyComments, wdAllowOnlyFormFields, wdAllowOnlyRevisions oder wdNoProtection. Long Schreib-Lese-Zugriff.


Protected-Eigenschaft

True, wenn Sie die angegebene Tastenkombination nicht im Dialogfeld Tastatur anpassen (Menü Extras) ändern können. Boolean Nur-Lese-Zugriff.

Hinweis Mit der Add-Methode des KeyBindings-Objekts wird eine Tastenkombination unabhängig vom Status dieser Eigenschaft hinzugefügt.


ProtectedForForms-Eigenschaft

True, wenn der angegebene Abschnitt für Formulare geschützt ist. Wenn ein Abschnitt für Formulare geschützt ist, können Sie nur in Formularfeldern Text markieren und modifizieren. Boolean Schreib-Lese-Zugriff.

Hinweis Zum Schützen eines ganzen Dokuments verwenden Sie die Protect-Methode des Document-Objekts.


Beispiel zur ProtectedForForms-Eigenschaft

In diesem Beispiel wird im aktiven Dokument der zweite Abschnitt für Formulare geschützt.

If ActiveDocument.Sections.Count >= 2 Then _
    ActiveDocument.Sections(2).ProtectedForForms = True

In diesem Beispiel wird der Schutz des ersten Abschnitts in der Markierung aufgehoben.

Selection.Sections(1).ProtectedForForms = False

In diesem Beispiel wird der Schutz für den ersten Abschnitt in der Markierung umgeschaltet.

Selection.Sections(1).ProtectedForForms = Not _
    Selection.Sections(1).ProtectedForForms


ProtectionType-Eigenschaft

Gibt die Art des Dokumentschutzes für das angegebene Dokument zurück. Dies kann eine der folgenden WdProtectionType-Konstanten sein: wdAllowOnlyComments, wdAllowOnlyFormFields, wdAllowOnlyRevisions oder wdNoProtection. Long Nur-Lese-Zugriff.


Beispiel zur ProtectionType-Eigenschaft

Wenn das aktive Dokument nicht bereits geschützt ist, wird es durch das folgende Beispiel für Kommentare geschützt.

If ActiveDocument.ProtectionType = wdNoProtection Then
    ActiveDocument.Protect Type:=wdAllowOnlyComments
End If

In diesem Beispiel wird der Schutz des aktiven Dokuments aufgehoben.

Set Doc = ActiveDocument
If Doc.ProtectionType <> wdNoProtection Then Doc.Unprotect


QueryString-Eigenschaft

Gibt die Abfragezeichenfolge (SQL-Anweisung) zurück oder legt sie fest, um eine Untermenge der Daten in eine Seriendruck-Datenquelle zu laden. String Schreib-Lese-Zugriff.


Beispiel zur QueryString-Eigenschaft

Dieses Beispiel gibt die Abfragezeichenfolge für die mit dem aktiven Dokument verbundene Datenquelle zurück.

qString = ActiveDocument.MailMerge.DataSource.QueryString


Range-Eigenschaft

Gibt ein Range-Objekt zurück, das den Teil eines Dokuments darstellt, der in dem angegebenen Objekt enthalten ist. Nur-Lese-Zugriff.

Weitere Informationen darüber, wie ein Bereich aus einem Dokument oder ein Formbereich aus einer Auflistung von Formen zurückgegeben wird, finden Sie bei der Range-Methode.


Beispiel zur Range-Eigenschaft

In diesem Beispiel wird dem ersten Absatz im aktiven Dokument die Formatvorlage Überschrift 1 zugewiesen.

ActiveDocument.Paragraphs(1).Range.Style = wdStyleHeading1

In diesem Beispiel wird die erste Zeile der Tabelle 1 kopiert.

If ActiveDocument.Tables.Count >= 1 Then _
    ActiveDocument.Tables(1).Rows(1).Range.Copy

In diesem Beispiel wird der Text des ersten Kommentars im Dokument geändert.

With ActiveDocument.Comments(1).Range
    .Delete
    .InsertBefore "new comment text"
End With

In diesem Beispiel wird am Ende von Abschnitt 1 Text eingefügt.

Set myRange = ActiveDocument.Sections(1).Range
With myRange
    .MoveEnd Unit:=wdCharacter, Count:=-1
    .Collapse Direction:=wdCollapseEnd
    .InsertParagraphAfter
    .InsertAfter "End of section"
End With


ReadabilityStatistics-Eigenschaft

Gibt eine ReadabilityStatistics-Sammlung zurück, die die statistischen Angaben zur Lesbarkeit für das angegebene Dokument oder den Bereich darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur ReadabilityStatistics-Eigenschaft

In diesem Beispiel werden alle statistischen Angaben zur Lesbarkeit mit dem entsprechenden Wert für Dokument 1 angezeigt.

For Each rs In Documents(1).ReadabilityStatistics
    Msgbox rs.Name & " - " & rs.Value
Next rs


ReadingOrder-Eigenschaft

Sprachspezifische Informationen

Returns or sets the reading order of the specified paragraphs without changing their alignment. Can be either of the following WdReadingOrder constants: wdReadingOrderLtr (left-to-right) or wdReadingOrderRtl (right-to-left). Read/write Long.

Remarks

Use the LtrPara, LtrRun, RtlPara, and RtlRun methods to change the paragraph alignment along with the reading order.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ReadingOrder-Eigenschaft

This example sets the reading order of the first paragraph to right-to-left.

ActiveDocument.Paragraphs(1).ReadingOrder = _
    wdReadingOrderRtl


ReadOnly-Eigenschaft

Document- oder RecentFile-Objekt: True, wenn Änderungen am Dokument nicht im Originaldokument gespeichert werden können. Boolean Schreib-Lese-Zugriff für das RecentFile-Objekt; Boolean Nur-Lese-Zugriff für das Document-Objekt.

Dictionary-Objekt: True, wenn das angegebene Wörterbuch nicht geändert werden kann. Boolean Nur-Lese-Zugriff.

Hinweis Die aktiven Grammatik-, Silbentrennungs-, Rechtschreib- und Thesaurus-Wörterbücher sind schreibgeschützt. Benutzerwörterbücher haben Schreib-Lese-Zugriff.


ReadOnlyRecommended-Eigenschaft

True, wenn Word beim Öffnen des Dokuments immer ein Meldungsfeld anzeigt, in dem dem Benutzer vorgeschlagen wird, es schreibgeschützt zu öffnen. Boolean Schreib-Lese-Zugriff.


Beispiel zur ReadOnlyRecommended-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word, wenn es das Dokument öffnet, vorschlägt, dass das Dokument schreibgeschützt geöffnet werden soll.

ActiveDocument.ReadOnlyRecommended = True

In diesem Beispiel wird der aktuelle Status der Option Schreibschutz empfehlen auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = ActiveDocument.ReadOnlyRecommended


RecentFiles-Eigenschaft

Gibt eine RecentFiles-Auflistung mit den zuletzt geöffneten Dateien zurück. Nur-Lese-Zugriff.

Weitere Informationen zum Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur RecentFiles-Eigenschaft

In diesem Beispiel wird das erste Element der RecentFiles-Auflistung geöffnet (der erste Dokumentname im unteren Teil des Menüs Datei).

If RecentFiles.Count >= 1 Then RecentFiles(1).Open

In diesem Beispiel werden die Namen der einzelnen Dateien in der RecentFiles-Auflistung angezeigt.

For Each rFile In RecentFiles
    MsgBox rFile.Name
Next rFile


RecipientAddress-Eigenschaft

Gibt die Postanschrift des Empfängers des Briefes, der vom Brief-Assistent erstellt wurde, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur RecipientAddress-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften (einschließlich der Empfängeradresse) werden festgelegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Dim oLC as New LetterContent
With oLC
    .ReturnAddress = Application.UserAddress
    .RecipientName = "Amy Anderson"
    .RecipientAddress = "123 Main" & vbCr & "Bellevue, WA  98004"
End With
Documents.Add.RunLetterWizard LetterContent:=oLC, WizardMode:=True


RecipientCode-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


RecipientGender-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der gewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


RecipientName-Eigenschaft

Gibt den Namen des Empfängers des Briefes, der vom Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur RecipientName-Eigenschaft

In diesem Beispiel werden die Anrede und der Empfängername im aktiven Dokument angezeigt.

MsgBox ActiveDocument.GetLetterContent.Salutation _
    & Space(1) & ActiveDocument.GetLetterContent.RecipientName

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften (einschließlich der Empfängeradresse) werden festgelegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Dim oLC as New LetterContent
With oLC
    .LetterStyle = wdFullBlock
    .ReturnAddress = Application.UserAddress
    .RecipientName = "Amy Anderson"
    .RecipientAddress = "123 Main" & vbCr & "Bellevue, WA  98004"
End With
Documents.Add.RunLetterWizard LetterContent:=oLC, WizardMode:=True


RecipientReference-Eigenschaft

Gibt die Referenzzeile (z. B. "Betrifft:") für einen Brief, der vom Brief-Assistenten erstellt wurde, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur RecipientReference-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften werden festgelegt (einschließlich der Referenzzeile), und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
With myContent
    .RecipientReference = "In reply to:"
    .Salutation ="Hello"
    .MailingInstructions = "Certified Mail"
End With
Documents.Add.RunLetterWizard LetterContent:=myContent


Recipients-Eigenschaft

Gibt einen Empfängernamen aus der angegebenen Verteilerliste zurück. String Nur-Lese-Zugriff.

Syntax

Ausdruck.Recipients(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein RoutingSlip-Objekt zurückgibt.

Index Variant optional. Eine Nummer, die den Empfänger angibt (in der Empfängerliste).


Beispiel zur Recipients-Eigenschaft

In diesem Beispiel wird ein Empfänger in die Verteilerliste von Verkäufe.doc aufgenommen, dann wird der Name des Empfängers angezeigt.

If Documents("Sales.doc").HasRoutingSlip = True Then
    Documents("Sales.doc").RoutingSlip.AddRecipient _
        Recipient:="Aaron Con"
    MsgBox Documents("Sales.doc").RoutingSlip.Recipients(1)
End If


Reference-Eigenschaft

Gibt ein Range-Objekt zurück, das eine Fußnote, eine Endnote oder einen Kommentar darstellt. Nur-Lese-Zugriff.


Beispiel zur Reference-Eigenschaft

In diesem Beispiel wird myRange das erste Fußnotenzeichen im aktiven Dokument zugewiesen, und dann wird das Fußnotenzeichen kopiert.

Set myRange = ActiveDocument.Footnotes(1).Reference
myRange.Copy

In diesem Beispiel werden die Kommentarzeichen in der Markierung rot formatiert.

For Each comm In Selection.Comments
    comm.Reference.Font.ColorIndex = wdRed
Next comm


RelatedExpressionList-Eigenschaft

Gibt eine Liste von Ausdrücken zurück, die mit dem angegebenen Wort oder dem angegebenen Ausdruck verwandt sind. Die Liste wird als Zeichenfolgenbereich zurückgegeben. Variant Nur-Lese-Zugriff.

Anmerkungen

Normalerweise werden sehr wenig verwandte Ausdrücke im Thesaurus gefunden.


Beispiel zur RelatedExpressionList-Eigenschaft

In diesem Beispiel wird überprüft, ob verwandte Ausdrücke für die Markierung gefunden wurden. Wenn das der Fall ist, werden die Bedeutungen in einer Reihe von Meldungsfeldern angezeigt. Wenn keine gefunden wurden, wird dies in einem Meldungsfeld angegeben.

Set mySinfo = Selection.Range.SynonymInfo
If mySinfo.Found = True Then
    myRelList = mysInfo.RelatedExpressionList
    If UBound(myRelList) <> 0 Then
        For i = 1 To UBound(myRelList)
            Msgbox myRelList(i)
        Next i
    Else
        Msgbox "There were no related expressions found."
    End If
End If


RelatedWordList-Eigenschaft

Gibt eine Liste von Wörtern zurück, die mit dem angegebenen Wort oder dem angegebenen Ausdruck verwandt sind. Die Liste wird als Zeichenfolgenbereich zurückgegeben. Variant Nur-Lese-Zugriff.


Beispiel zur RelatedWordList-Eigenschaft

In diesem Beispiel wird überprüft, ob für das dritte Wort im aktiven Dokument verwandte Wörter gefunden wurden. Wenn das der Fall ist, werden die Bedeutungen in einer Reihe von Meldungsfeldern angezeigt. Wenn keine verwandten Wörter gefunden werden, wird dies in einem Meldungsfeld angegeben.

Set mySynon = ActiveDocument.Words(3).SynonymInfo
If mySynon.Found = True Then
    myWdList = mySynon.RelatedWordList
    If UBound(myWdList) <> 0 Then
        For i = 1 To UBound(myWdList)
            Msgbox myWdList(i)
        Next i
    Else
        Msgbox "There were no related words found."
    End If
End If


RelativeHorizontalPosition-Eigenschaft

Legt fest, worauf sich die horizontale Position eines Rahmens, einer Form oder einer Gruppe von Zeilen bezieht. Dabei kann es sich um eine der folgenden WdRelativeHorizontalPosition-Konstanten handeln: wdRelativeHorizontalPositionCharacter, wdRelativeHorizontalPositionColumn, wdRelativeHorizontalPositionMargin oder wdRelativeHorizontalPositionPage. Long Schreib-Lese-Zugriff.


Beispiel zur RelativeHorizontalPosition-Eigenschaft

In diesem Beispiel wird ein Rahmen um die Auswahl gezogen. Der Rahmen wird horizontal mit dem rechten Rand ausgerichtet.

Set myFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)
With myFrame
    .RelativeHorizontalPosition = _
        wdRelativeHorizontalPositionMargin
    .HorizontalPosition = wdFrameRight
End With

In diesem Beispiel wird das gewählte Form-Objekt neu positioniert.

With Selection.ShapeRange
    .Left = InchesToPoints(0.6)
    .RelativeHorizontalPosition = wdRelativeHorizontalPositionPage
    .Top = InchesToPoints(1)
    .RelativeVerticalPosition = wdRelativeVerticalPositionParagraph
End With


RelativeVerticalPosition-Eigenschaft

Legt fest, worauf sich die vertikale Position eines Rahmens, einer Form oder einer Gruppe von Zeilen bezieht. Dabei kann es sich um eine der folgenden WdRelativeVerticalPosition-Konstanten handeln: wdRelativeVerticalPositionLine, wdRelativeVerticalPositionMargin, wdRelativeVerticalPositionPage oder wdRelativeVerticalPositionParagraph. Long Schreib-Lese-Zugriff.


Beispiel zur RelativeVerticalPosition-Eigenschaft

In diesem Beispiel wird ein Rahmen um die Auswahl gezogen. Der Rahmen wird vertikal zur Oberkante der Seite ausgerichtet.

Set myFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)
With myFrame
    .RelativeVerticalPosition = wdRelativeVerticalPositionPage
    .VerticalPosition = wdFrameTop
End With

In diesem Beispiel wird das erste Shape-Objekt im aktiven Dokument neu positioniert.

With ActiveDocument.Shapes(1)
    .Left = InchesToPoints(0.6)
    .RelativeHorizontalPosition = wdRelativeHorizontalPositionPage
    .Top = InchesToPoints(1)
    .RelativeVerticalPosition = wdRelativeVerticalPositionParagraph
End With


RelyOnCSS-Eigenschaft

True, wenn Sie beim Anzeigen eines gespeicherten Dokuments in einem Webbrowser Cascading Style Sheets (CSS) zur Formatierung der Schriftart verwenden. Die Datei des Cascading Style Sheets wird von Microsoft Word erstellt und entweder im angegebenen Ordner oder im gleichen Ordner wie Ihre Webseite gespeichert, entsprechend dem Wert der OrganizeInFolder-Eigenschaft. False, wenn HTML-<FONT>-Tags und Cascading Style Sheets verwendet werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft sollte auf True gesetzt werden, wenn Ihr Webbrowser Cascading Style Sheets unterstützt. Dadurch haben Sie eine genauere Kontrolle über Layout und Formatierung Ihrer Webseite und können diese besser an das Erscheinungsbild Ihres Dokuments in Microsoft Word anpassen.


Beispiel zur RelyOnCSS-Eigenschaft

In diesem Beispiel werden Cascading Style Sheets als globale Standardeinstellung für die Anwendung aktiviert.

Application.DefaultWebOptions.RelyOnCSS = True


RelyOnVML-Eigenschaft

True, wenn beim Speichern eines Dokuments als Webseite aus Zeichnungsobjekten keine Bilddateien erstellt werden. False, wenn Bilder erstellt werden. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Hinweise

Sofern Ihr Webbrowser VML (Vector Markup Language) unterstützt, können Sie die Dateigrößen reduzieren, indem Sie keine Bilder für Zeichnungsobjekte erstellen. Diese Funktion wird zum Beispiel von Microsoft Internet Explorer 5 unterstützt, und Sie sollten die RelyOnVML-Eigenschaft auf True setzen, wenn Sie diesen Browser verwenden möchten. In Browsern, die VML nicht unterstützen, wird kein Bild angezeigt, wenn Sie eine Webseite betrachten, bei der diese Eigenschaft beim Speichern aktiviert war.

Sie sollten zum Beispiel keine Bilder erstellen, wenn Ihre Webseite Bilddateien enthält, die Sie zu einem früheren Zeitpunkt erstellt haben, und wenn der Speicherort des Dokuments sich vom endgültigen Speicherort der Seite auf dem Webserver unterscheidet.


Beispiel zur RelyOnVML-Eigenschaft

In diesem Beispiel wird festgelegt, dass Bilder erstellt werden, wenn das Dokument als Webseite gespeichert wird.

ActiveDocument.WebOptions.RelyOnVML = False


Replacement-Eigenschaft

Gibt ein Replacement-Objekt zurück, das die Kriterien für eine Ersetzungsoperation enthält. Nur-Lese-Zugriff.


Beispiel zur Replacement-Eigenschaft

In diesem Beispiel wird Fettformatierung vom aktiven Dokument entfernt. Die Bold-Eigenschaft ist True für das Find-Objekt und False für das Replacement-Objekt.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Font.Bold = True
    With .Replacement
        .ClearFormatting
        .Font.Bold = False
    End With
    .Execute FindText:="", ReplaceWith:="", Format:=True, _
        Replace:=wdReplaceAll
End With

In diesem Beispiel wird im aktiven Dokument jede Instanz des Wortes "Start" gesucht und durch "Ende" ersetzt. Die Suchoperation ignoriert Formatierung und beachtet die Groß-/Kleinschreibung des zu suchenden Textes ("Start").

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
With myRange.Find
    .ClearFormatting
    .Text = "Start"
    With .Replacement
        .ClearFormatting
        .Text = "End"
    End With
    .Execute Replace:=wdReplaceAll, _
        Format:=True, MatchCase:=True, _
        MatchWholeWord:=True
End With


ReplaceSelection-Eigenschaft

True, wenn Sie durch eine Eingabe oder Einfügen die Markierung ersetzen können. False, wenn eine Eingabe oder Einfügen vor der Markierung eingefügt wird und der Inhalt der Markierung erhalten bleibt. Boolean Schreib-Lese-Zugriff.


Beispiel zur ReplaceSelection-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass eine Eingabe oder Einfügung vor der Markierung hinzugefügt wird und der Inhalt der Markierung erhalten bleibt.

Options.ReplaceSelection = False

In diesem Beispiel wird der Status der Option Eingabe ersetzt Auswahl auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.ReplaceSelection


ReplaceText-Eigenschaft

True, wenn Word automatisch bestimmten Text durch Einträge aus der AutoKorrektur-Liste löscht. Boolean Schreib-Lese-Zugriff.


ReplaceTextFromSpellingChecker-Eigenschaft

True, wenn fehlerhafter Text von Microsoft Word beim Schreiben automatisch durch Vorschläge aus der Rechtschreibprüfung ersetzt werden. Word ersetzt nur die Wörter, die einen einzigen Rechtschreibfehler enthalten und für die im Wörterbuch nur eine Alternative aufgeführt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ReplaceTextFromSpellingChecker-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word fehlerhaften Text automatisch durch Korrekturvorschläge von der Rechtschreibprüfung ersetzt.

AutoCorrect.ReplaceTextFromSpellingChecker = True


ReplyMessageSignature-Eigenschaft

Gibt die Signatur zurück, die Microsoft Word an Antworten auf E-Mail-Nachrichten anhängt, oder legt diese fest. String Schreib-Lese-Zugriff.

Hinweise

Beim Festlegen dieser Eigenschaft müssen Sie den Namen einer E-Mail-Signatur verwenden, die Sie im Dialogfeld E-Mail-Optionen erstellt haben. Auf dieses Dialogfeld können Sie über die Registerkarte Allgemein im Dialogfeld Optionen (Menü Extras) zugreifen.


Beispiel zur ReplyMessageSignature-Eigenschaft

In diesem Beispiel wird die Signatur geändert, die Word an Antworten auf E-Mail-Nachrichten anhängt.

With Application.EmailOptions.EmailSignature
    .ReplyMessageSignature = "Reply2"
End With


ReplyStyle-Eigenschaft

Gibt ein Style-Objekt zurück, das die Formatvorlage darstellt, die beim Antworten auf E-Mail-Nachrichten verwendet wird. Nur-Lese-Zugriff.


Beispiel zur ReplyStyle-Eigenschaft

In diesem Beispiel wird der Name der Standardformatvorlage angezeigt, die beim Antworten auf E-Mail-Nachrichten verwendet wird.

MsgBox Application.EmailOptions.ReplyStyle.NameLocal


ResetOnHigher-Eigenschaft

Gibt die Listenebene zurück, die erreicht werden muss, bevor bei der angegebenen Listenebene mit dem Nummerierungsvorgang wieder bei 1 begonnen wird, oder legt diese fest. False, wenn die Nummerierung bei jedem Vorkommen der Listenebene fortlaufend fortgesetzt wird. Long Schreib-Lese-Zugriff.

Hinweise

Diese Funktion erlaubt Überlappungen von Listen unter Wahrung der numerischen Abfolge. Sie können die ResetOnHigher-Eigenschaft einer Listenebene auf keinen Wert setzen, der größer oder gleich seinem Index in der ListLevels-Auflistung ist.


Beispiel zur ResetOnHigher-Eigenschaft

In diesem Beispiel werden alle neun Listenebenen in der ersten Listenvorlage für Gliederungen gesetzt, um eine sequentielle Nummerierung, unabhängig von der verwendeten Ebene, fortzusetzen.

For Each li In _
        ListGalleries(wdOutlineNumberGallery) _
        .ListTemplates(1).ListLevels
    li.ResetOnHigher = False
Next li


RestartMode-Eigenschaft

Gibt die Art zurück, wie die Zeilennummerierung erfolgt, oder legt sie fest. Diese Eigenschaft gibt an, ob die Zeilennummerierung am Anfang einer neuen Seite oder eines neuen Abschnitts von vorn beginnt oder fortlaufend erfolgt. Kann eine der folgenden WdNumberingRule-Konstanten sein: wdRestartContinuous, wdRestartPage oder wdRestartSection. Long Schreib-Lese-Zugriff.

Hinweise

Sie müssen sich in der Seitenlayoutansicht befinden, wenn Sie die Zeilennummerierung sehen möchten.


Beispiel zur RestartMode-Eigenschaft

In diesem Beispiel wird die Zeilennummerierung für das aktive Dokument eingeschaltet. Die Startnummer wird auf 1 gesetzt, jede zehnte Zeilennummer wird angezeigt, und die Nummerierung beginnt am Anfang jedes Abschnitts von vorn.

set myDoc = ActiveDocument
With myDoc.PageSetup.LineNumbering
    .Active = True
    .StartingNumber = 1
    .CountBy = 10
    .RestartMode = wdRestartSection
End With


RestartNumberingAtSection-Eigenschaft

True, wenn die Seitennummerierung wieder mit 1 am Anfang des angegebenen Abschnitts beginnt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ist diese Eigenschaft auf False gesetzt, überschreibt die RestartNumberingAtSection-Eigenschaft die StartingNumber-Eigenschaft. Die Seitennummerierung des vorherigen Abschnitts kann fortgesetzt werden.


Beispiel zur RestartNumberingAtSection-Eigenschaft

In diesem Beispiel werden die Kopfzeilen im aktivem Dokument mit Seitennummern versehen. Dann wird festgelegt, dass die Seitennummerierung jedes Abschnitts mit 1 beginnt.

ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary) _
    .PageNumbers.Add Pagenumberalignment:=wdAlignPageNumberCenter
For Each s In ActiveDocument.Sections
    With s.Headers(wdHeaderFooterPrimary).PageNumbers
        .RestartNumberingAtSection = True
        .StartingNumber = 1
    End With
Next s


Result-Eigenschaft

Field-Objekt: Gibt ein Range-Objekt zurück, das ein Feldergebnis darstellt. Sie können auf ein Feldergebnis zugreifen, ohne die Darstellung der Feldfunktion zu ändern. Schreib-Lese-Zugriff.

Anmerkung Mit Hilfe der Text-Eigenschaft geben Sie Text aus einem Range-Objekt zurück.

FormField-Objekt: Gibt das Ergebnis des angegebenen Formularfelds zurück. String Schreib-Lese-Zugriff.


Beispiel zur Result-Eigenschaft

In diesem Beispiel werden die Ergebnisse aller Formularfelder im aktiven Dokument zurückgegeben.

For Each aField In ActiveDocument.FormFields
    MsgBox aField.Result
Next aField

In diesem Beispiel wird die Formatierung "Fett" auf das erste Feld in der Markierung angewendet.

If Selection.Fields.Count >= 1 Then
    Set myRange = Selection.Fields(1).Result
    myRange.Bold = True
End If


ReturnAddress-Eigenschaft

Envelope-Objekt: Gibt ein Range-Objekt zurück, das die Absenderadresse eines Briefumschlags darstellt. Nur-Lese-Zugriff.

LetterContent-Objekt: Gibt die Absenderadresse für einen Brief, der mit Hilfe des Brief-Assistenten erstellt wurde, zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


ReturnAddressFromLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der linken Briefumschlagkante und dem Absender zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


Beispiel zur ReturnAddressFromLeft-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und ein Briefumschlag mit einer vordefinierten Empfänger- und Absenderadresse hinzugefügt. Dann wird der Abstand zwischen der linken Umschlagkante und dem Absender auf 1,9 cm gesetzt.

addr = "Karin Gallagher" & vbCr & "123 Skye St." _
    & vbCr & "Our Town, WA  98004"
retaddr = "Don Funk" & vbCr & "123 Main" _
    & vbCr & "Other Town, WA  98040"
With Documents.Add.Envelope
    .Insert Address:=addr, ReturnAddress:=retaddr
    .ReturnAddressFromLeft = InchesToPoints(0.75)
End With
ActiveDocument.ActiveWindow.View.Type = wdPrintView


ReturnAddressFromTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der oberen Briefumschlagkante und dem Absender zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn Sie diese Eigenschaft aufrufen, bevor ein Umschlag dem Dokument hinzugefügt wurde, tritt ein Fehler auf.


Beispiel zur ReturnAddressFromTop-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und ein Briefumschlag mit einer vordefinierten Empfänger- und Absenderadresse hinzugefügt. Dann wird der Abstand zwischen der oberen Umschlagkante und dem Absender auf 1,27 cm und zwischen der linken Umschlagkante und dem Absender auf 1,9 cm gesetzt.

addr = "Eric Lang" & vbCr & "123 Main" _
    & vbCr & "Seattle, WA  98040"
retaddr = "Nate Sun" & vbCr & "123 Main" _
    & vbCr & "Bellevue, WA  98004"
With Documents.Add.Envelope
    .Insert Address:=addr, ReturnAddress:=retaddr
    .ReturnAddressFromTop = InchesToPoints(0.5)
    .ReturnAddressFromLeft = InchesToPoints(0.75)
End With


ReturnAddressShortForm-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


ReturnAddressStyle-Eigenschaft

Gibt ein Style-Objekt zurück, das die Formatvorlage der Absenderadresse auf dem Briefumschlag darstellt. Nur-Lese-Zugriff.

Hinweis Wenn ein Briefumschlag einem Dokument hinzugefügt wird, dann wird mit der Formatvorlage "Absenderadresse" formatierter Text automatisch aktualisiert.


Beispiel zur ReturnAddressStyle-Eigenschaft

In diesem Beispiel werden der Name der Formatvorlage und eine Beschreibung der Absenderadresse auf dem Briefumschlag angezeigt.

Set myStyle = ActiveDocument.Envelope.ReturnAddressStyle
MsgBox Prompt:=myStyle.Description, Title:=myStyle.NameLocal

In diesem Beispiel werden der Zeilenabstand und der Abstand nach der Formatierung für die Formatvorlage "Absenderadresse" für Briefumschläge festgelegt.

With ActiveDocument.Envelope.ReturnAddressStyle.ParagraphFormat
    .LineSpacingRule = wdLineSpaceExactly
    .LineSpacing = 13
    .SpaceAfter = 6
End With


ReturnWhenDone-Eigenschaft

True, wenn das Dokument mit der Verteilerliste nach der Verteilung zum ursprünglichen Absender zurückgesandt wird. Boolean Schreib-Lese-Zugriff vor der Verteilung; Boolean Nur-Lese-Zugriff während der Verteilung.


Beispiel zur ReturnWhenDone-Eigenschaft

Dieses Beispiel wird die Verteilerliste für "Umsatz 1997.doc" so einstellen, dass das Dokument an den Absender zurückgegeben wird, wenn der letzte Empfänger es gelesen hat.

If Documents("Sales 1995.doc").HasRoutingSlip = True Then
    With Documents("Sales 1995.doc").RoutingSlip
        .Delivery = wdOneAfterAnother
        .ReturnWhenDone = True
    End With
End If


RevisedLinesColor-Eigenschaft

Gibt in einem Dokument mit Überarbeitungen die Farbe der überarbeiteten Zeilen zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow


Beispiel zur RevisedLinesColor-Eigenschaft

In diesem Beispiel wird die Farbe der vertikalen Korrekturleisten auf Pink gesetzt.

Options.RevisedLinesColor = wdPink

In diesem Beispiel wird der aktuelle Status der Option Farbe unter Überarbeitete Zeilen auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.RevisedLinesColor


RevisedLinesMark-Eigenschaft

Gibt die Anordnung der vertikalen Korrekturleisten in einem Dokument mit aktivierten Änderungsverfolgungen zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdRevisedLinesMark-Konstanten handeln: wdRevisedLinesMarkNone, wdRevisedLinesMarkLeftBorder, wdRevisedLinesMarkOutsideBorder oder wdRevisedLinesMarkRightBorder. Long Schreib-Lese-Zugriff.


Beispiel zur RevisedLinesMark-Eigenschaft

In diesem Beispiel wird festgelegt, dass die vertikalen Korrekturleisten am linken Rand auf jeder Seite erscheinen.

Options.RevisedLinesMark = wdRevisedLinesMarkLeftBorder

In diesem Beispiel wird der aktuelle Status der Option Markierung unter Überarbeitete Zeilen auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen zurückgegeben.

temp = Options.RevisedLinesMark


RevisedPropertiesColor-Eigenschaft

Gibt die Farbe, mit der Formatierungsänderungen markiert, wenn die Änderungsüberwachung aktiv ist zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdColorIndex-Konstanten handeln:

wdAuto

wdBlack

wdBlue

wdBrightGreen

wdByAuthor

wdDarkBlue

wdDarkRed

wdDarkYellow

wdGray25

wdGray50

 wdGreen

wdNoHighlight

wdPink

wdRed

wdTeal

wdTurquoise

wdViolet

wdWhite

wdYellow

Anmerkungen

Wenn sich in gelöschtem oder eingefügtem Text Formatierungsänderungen befinden, wird die RevisedPropertiesColor-Eigenschaft von der DeletedTextColor- oder InsertedTextColor-Eigenschaft überschrieben.


Beispiel zur RevisedPropertiesColor-Eigenschaft

In diesem Beispiel werden Überarbeitungen im aktiven Dokument verfolgt. Die Farbe für Text mit geänderter Formatierung wird auf "Blaugrün" gesetzt und der Auswahl die Formatierung Fett zugewiesen.

ActiveDocument.TrackRevisions = True
Options.RevisedPropertiesColor = wdTeal
Selection.Font.Bold = True

In diesem Beispiel wird die Option zurückgegeben, die im Feld Farbe unter Geänderte Formatierung auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen (Menü Extras) gewählt wurde.

temp = Options.RevisedPropertiesColor


RevisedPropertiesMark-Eigenschaft

Gibt die Markierung, mit der Formatierungsänderungen angezeigt werden, wenn die Änderungsüberwachung aktiv ist zurück oder legt sie fest. Dabei kann es sich um eine der folgenden WdRevisedPropertiesMark-Konstanten handeln: wdRevisedPropertiesMarkBold, wdRevisedPropertiesMarkDoubleUnderline, wdRevisedPropertiesMarkItalic, wdRevisedPropertiesMarkNone oder wdRevisedPropertiesMarkUnderline. Long Schreib-Lese-Zugriff.


Beispiel zur RevisedPropertiesMark-Eigenschaft

In diesem Beispiel wird Text mit geänderter Formatierung doppelt unterstrichen, wenn die Änderungsüberwachung aktiv ist.

Options.RevisedPropertiesMark = _
    wdRevisedPropertiesMarkDoubleUnderline

In diesem Beispiel wird die Option zurückgegeben, die im Feld Markierung unter Geänderte Formatierung auf der Registerkarte Änderungen verfolgen im Dialogfeld Optionen (Menü Extras) gewählt wurde.

temp = Options.RevisedPropertiesMark


Revisions-Eigenschaft

Gibt eine Revisions-Auflistung zurück, die die Korrekturmarkierungen im Dokument oder Bereich darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Revisions-Eigenschaft

In diesem Beispiel wird die Anzahl der Überarbeitungen im ersten Abschnitt des aktiven Dokuments angezeigt.

MsgBox ActiveDocument.Sections(1).Range.Revisions.Count

In diesem Beispiel werden alle Überarbeitungen im ersten Absatz in der Markierung angenommen.

Set myRange = Selection.Paragraphs(1).Range
myRange.Revisions.AcceptAll


 RGB-Eigenschaft

RGB-Eigenschaft

Gibt den Rot-Grün-Blau-(RGB)-Wert der angegebenen Farbe zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.


Beispiel zur RGB-Eigenschaft

In diesem Beispiel wird Grau als Farbe der zweiten Form im aktiven Dokument festgelegt.

ActiveDocument.Shapes(2).Fill.ForeColor.RGB = RGB(128, 128, 128)

In diesem Beispiel wird Blau als Farbe des Schattens für Rechteck 1 im aktiven Dokument festgelegt.

ActiveDocument.Shapes("Rectangle 1").Shadow.ForeColor.RGB = _
    RGB(0, 0, 255)

In diesem Beispiel wird der Wert der Vordergrundfarbe der ersten Form im aktiven Dokument zurückgegeben.

MsgBox ActiveDocument.Shapes(1).Fill.ForeColor.RGB


RichText-Eigenschaft

True, wenn der Text des AutoKorrektur-Eintrags mit Formatangaben gespeichert wurde. Boolean Nur-Lese-Zugriff.


Beispiel zur RichText Property-Eigenschaft

In diesem Beispiel wird festgestellt, ob der erste AutoKorrektur-Eintrag formatiert ist.

MsgBox AutoCorrect.Entries(1).RichText


RightAlignPageNumbers-Eigenschaft

True, wenn Seitenzahlen in einem Index, Inhaltsverzeichnis oder Abbildungsverzeichnis am rechten Seitenrand ausgerichtet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur RightAlignPageNumbers-Eigenschaft

In diesem Beispiel werden im aktiven Dokument die Seitenzahlen für das erste Inhaltsverzeichnis rechts ausgerichtet.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .IncludePageNumbers = True
        .RightAlignPageNumbers = True
    End With
End If


RightIndent-Eigenschaft

Gibt den rechten Einzug (in Punkt) für die angegebenen Absätze zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur RightIndent-Eigenschaft

In diesem Beispiel wird für alle Absätze im aktiven Dokument der rechte Einzug auf 1 Zoll vom rechten Seitenrand festgelegt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

ActiveDocument.Paragraphs.RightIndent = InchesToPoints(1)


RightMargin-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der rechten Seitenkante und der rechten Begrenzung des Textkörpers zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn die MirrorMargins-Eigenschaft auf True gesetzt ist, steuert die RightMargin-Eigenschaft die Einstellung für den äußeren Seitenrand und die LeftMargin-Eigenschaft die Einstellung für den inneren Seitenrand.


Beispiel zur RightMargin-Eigenschaft

In diesem Beispiel wird die Einstellung des rechten Seitenrands für das aktive Dokument angezeigt. Die PointsToInches-Methode wird zur Umwandlung des Ergebnisses in Zoll verwendet.

With ActiveDocument.PageSetup
    Msgbox "The right margin is set to " _
        & PointsToInches(.RightMargin) & " inches."
End With

In diesem Beispiel wird für Abschnitt zwei in der Markierung der rechte Seitenrand eingestellt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

Selection.Sections(2).PageSetup.RightMargin = InchesToPoints(1)


RightPadding-Eigenschaft

Gibt den Abstand (in Punkt) zurück, der rechts neben dem Inhalt einer einzelnen Zelle oder aller Zellen in einer Tabelle hinzugefügt werden soll, oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Die Einstellung der RightPadding-Eigenschaft für eine einzelne Zelle überschreibt die Einstellung der RightPadding-Eigenschaft für die gesamte Tabelle.


Beispiel zur RightPadding-Eigenschaft

In diesem Beispiel wird der Abstand, der in der ersten Tabelle im aktiven Dokument rechts neben dem Inhalt hinzugefügt werden soll, auf 40 Pixel gesetzt.

ActiveDocument.Tables(1).RightPadding = _
    PixelsToPoints(40, False)


RotatedChars-Eigenschaft

True, wenn Zeichen im angegebenen WordArt-Objekt um 90 Grad relativ zur begrenzenden Form des WordArt-Objekts gedreht sind. False, wenn Zeichen im angegebenen WordArt-Objekt ihre ursprüngliche Orientierung relativ zur begrenzenden Form beibehalten. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn das WordArt-Objekt horizontalen Text hat, werden durch Festlegen der RotatedChars-Eigenschaft auf True die Zeichen um 90 Grad entgegen dem Uhrzeigersinn gedreht. Wenn das WordArt-Objekt vertikalen Text hat, werden durch Festlegen der RotatedChars-Eigenschaft auf False die Zeichen um 90 Grad im Uhrzeigersinn gedreht. Verwenden Sie die ToggleVerticalText-Methode zum Umschalten zwischen horizontalem und vertikalem Textfluss.

Die Flip-Methode und Rotation-Eigenschaft des Shape-Objekts und die RotatedChars-Eigenschaft und ToggleVerticalText-Methode des TextEffectFormat-Objekts beeinflussen alle die Zeichenorientierung und die Richtung des Textflusses in einem Shape-Objekt, das ein WordArt-Objekt darstellt. Möglicherweise müssen Sie durch Versuche herausfinden, wie die Wirkungen dieser Eigenschaften und Methoden kombiniert werden müssen, damit Sie das Ergebnis erhalten, das Sie haben wollen.


Beispiel zur RotatedChars-Eigenschaft

In diesem Beispiel wird zu myDocument ein WordArt-Objekt hinzugefügt, das den Text "Test" enthält, und die Zeichen werden um 90 Grad entgegen dem Uhrzeigersinn gedreht.

Set myDocument = ActiveDocument
Set newWordArt = _
    myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, _
    Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=10, Top:=10)
newWordArt.TextEffect.RotatedChars = True


Rotation-Eigenschaft

Gibt die Gradzahl zurück, um die die angegebene Form um die z-Achse gedreht wurde, oder legt sie fest. Ein positiver Wert bedeutet Drehung im Uhrzeigersinn; ein negativer Wert bedeutet Drehung entgegen dem Uhrzeigersinn. Single Schreib-Lese-Zugriff.

Anmerkungen

Zum Einstellen der Drehung einer dreidimensionalen Form um die x-Achse oder die y-Achse verwenden Sie die RotationX-Eigenschaft oder die RotationY-Eigenschaft des ThreeDFormat-Objekts.


Beispiel zur Rotation-Eigenschaft

In diesem Beispiel stimmt die Drehung aller Formen in myDocument mit der Drehung von Form eins überein.

Set myDocument = ActiveDocument
With myDocument.Shapes
    sh1Rotation = .Item(1).Rotation
    For o = 1 To .Count
        .Item(o).Rotation = sh1Rotation
    Next
End With


RotationX-Eigenschaft

Gibt die Drehung der projizierten Form um die x-Achse in Grad an oder legt sie fest. Dabei kann es sich um einen Wert von - 90 bis 90 handeln. Ein positiver Wert gibt eine Drehung nach oben, ein negativer eine Drehung nach unten an. Single Schreib-Lese-Zugriff.

Anmerkungen

Sie legen die Drehung einer projizierten Form um die y-Achse mit der RotationY-Eigenschaft des ThreeDFormat-Objekts fest. Die Drehung einer projizierten Form um die z-Achse legen Sie mit der Rotation-Eigenschaft des Shape-Objekts fest. Mit der SetExtrusionDirection-Methode ändern Sie die Richtung der Projektionsausdehnung, ohne die Vorderansicht der Projektion zu drehen.


RotationY-Eigenschaft

Gibt die Drehung der projizierten Form um die y-Achse zurück, in Grad, oder legt sie fest. Es kann ein Wert zwischen -90 und +90 sein. Ein positiver Wert zeigt Drehung nach links an; ein negativer Wert zeigt Drehung nach rechts an. Single Schreib-Lese-Zugriff.

Anmerkungen

Zum Festlegen der Drehung der projizierten Form um die x-Achse verwenden Sie die RotationX-Eigenschaft des ThreeDFormat-Objekts. Zum Festlegen der Drehung der projizierten Form um die z-Achse verwenden Sie die Rotation-Eigenschaft des Shape-Objekts. Zum Ändern der Richtung der Projektionsausdehnung ohne Drehung der Vorderansicht der Projektion verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur RotationY-Eigenschaft

In diesem Beispiel werden zu myDocument drei identische projizierte Ovale hinzugefügt, und ihre Drehung um die y-Achse wird auf -30, 0 und 30 Grad festgelegt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    With .AddShape(msoShapeOval, 30, 30, 50, 25).ThreeD
        .Visible = True
        .RotationY = -30
    End With
    With .AddShape(msoShapeOval, 30, 70, 50, 25).ThreeD
        .Visible = True
        .RotationY = 0
    End With
    With .AddShape(msoShapeOval, 30, 110, 50, 25).ThreeD
        .Visible = True
        .RotationY = 30
    End With
End With


Routed-Eigenschaft

True, wenn das angegebene Dokument an den nächsten Empfänger weitergeleitet wurde. False, wenn das Dokument noch weitergeleitet werden muss (z. B. wenn das Dokument keine Verteileriste hat oder gerade erst eine Verteilerliste erstellt wurde). Boolean Nur-Lese-Zugriff.


Beispiel zur Routed-Eigenschaft

In diesem Beispiel wird das aktuelle Dokument weitergeleitet, wenn dies noch nicht geschehen ist.

If ActiveDocument.Routed = False Then ActiveDocument.Route


RoutingSlip-Eigenschaft

Gibt ein RoutingSlip-Objekt zurück, das die Informationen der Verteilerliste für das angegebene Dokument darstellen. Mit einer Verteilerliste wird ein Dokument in einem E-Mail-System weitergeleitet. Nur-Lese-Zugriff.


Beispiel zur RoutingSlip-Eigenschaft

In diesem Beispiel wird "Status.doc" mit einer Verteilerliste versehen und dann das Dokument an die angegebenen Empfänger weitergeleitet.

Documents("Status.doc").HasRoutingSlip = True
With Documents("Status.doc").RoutingSlip
    .Subject = "Status Doc "
    .AddRecipient Recipient:="Don Funk"
    .AddRecipient Recipient:="Frida Ebbeson"
    .Delivery = wdAllAtOnce
End With
Documents("Status.doc").Route


Row-Eigenschaft

Gibt ein Row-Objekt zurück, das die Zeile darstellt, die die angegebene Zelle enthält. Nur-Lese-Zugriff.


RowIndex-Eigenschaft

Gibt die Nummer der Zeile zurück, die die angegebene Zelle enthält. Long Nur-Lese-Zugriff.


Beispiel zur RowIndex-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt, nacheinander jede Zelle in der ersten Spalte markiert und die Nummer der Zeile angezeigt, die die markierte Zelle enthält.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=3)
For Each aCell In myTable.Columns(1).Cells
    aCell.Select
    MsgBox "This is row " & aCell.RowIndex
Next aCell

In diesem Beispiel wird die Zeilennummer der ersten Zeile in der Markierung angezeigt.

If Selection.Information(wdWithInTable) = True Then
    Msgbox Selection.Cells(1).RowIndex
End If


Rows-Eigenschaft

Gibt eine Rows-Auflistung zurück, die alle Tabellenzeilen in einem Bereich, in der Markierung oder in der Tabelle darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Rows-Eigenschaft

In diesem Beispiel wird in der ersten Tabelle des aktiven Dokuments die zweite Zeile gelöscht.

ActiveDocument.Tables(1).Rows(2).Delete

In diesem Beispiel werden die Zellen in der Zeile, die die Einfügemarke enthält, mit einem Rahmen versehen.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Information(wdWithInTable) = True Then
    Selection.Rows(1).Borders.OutsideLineStyle =  wdLineStyleSingle
Else
    MsgBox "The insertion point is not in a table."
End If


Salutation-Eigenschaft

Gibt den Text für die Anrede im Brief, der vom Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


SalutationType-Eigenschaft

Gibt den Typ des Anredeformats für einen Brief, der vom Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden WdSalutationType-Konstanten handeln: wdSalutationBusiness, wdSalutationFormat, wdSalutationInformal oder wdSalutationOther. Long Schreib-Lese-Zugriff.


Beispiel zur SalutationType-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, verschiedene Eigenschaften (einschließlich des Textes für die Anrede) werden festgelegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
myContent.SalutationType = wdSalutationBusiness
Documents.Add.RunLetterWizard _
    LetterContent:=myContent, WizardMode:=True


Saved-Eigenschaft

True, wenn sich das angegebene Dokument oder die angegebene Vorlage seit dem letzten Speichern nicht geändert hat. False, wenn Word beim Schließen des Dokuments eine Aufforderung zum Speichern der Änderungen anzeigt. Boolean Schreib-Lese-Zugriff.


SavedBy-Eigenschaft

Gibt den Namen des Benutzers zurück, der die angegebene Version des Dokuments gespeichert hat. String Nur-Lese-Zugriff.


Beispiel zur SavedBy-Eigenschaft

In diesem Beispiel wird der Name des Benutzers angezeigt, der die erste Version des aktiven Dokuments gespeichert hat.

If ActiveDocument.Versions.Count >= 1 Then
    MsgBox ActiveDocument.Versions(1).SavedBy
End If

In diesem Beispiel wird eine Version des Dokuments mit einem Kommentar gespeichert und dann der Benutzername angezeigt.

ActiveDocument.Versions.Save Comment:="Added client information"
last = ActiveDocument.Versions.Count
MsgBox ActiveDocument.Versions(last).SavedBy


SaveEncoding-Eigenschaft

Gibt die für das Speichern eines Dokuments zu verwendende Codierung zurück oder legt diese fest. Dabei kann es sich um eine beliebige gültige MsoEncoding-Konstante handeln. Long Schreib-Lese-Zugriff.

Hinweise

Die Liste der gültigen MsoEncoding-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.

Sie können keine Konstante verwenden, die das Suffix "AutoDetect" enthält. Diese Konstanten werden von der ReloadAs-Methode verwendet.


Beispiel zur SaveEncoding-Eigenschaft

In diesem Beispiel wird für das Speichern des aktuellen Dokuments die Codierung Westlich vorgegeben.

ActiveDocument.SaveEncoding = msoEncodingWestern


SaveFormat-Eigenschaft

Gibt das Dateiformat des angegebenen Dokuments oder Dateikonvertierungsprogramms zurück. Dies kann eine eindeutige Zahl sein, die ein externes Dateikonvertierungsprogramm spezifiziert, oder eine der folgenden WdSaveFormat-Konstanten: wdFormatDocument, wdFormatDOSText, wdFormatDOSTextLineBreaks, wdFormatEncodedText, wdFormatHTML, wdFormatRTF, wdFormatTemplate, wdFormatText, wdFormatTextLineBreaks oder wdFormatUnicodeText. Long Nur-Lese-Zugriff.


Beispiel zur SaveFormat-Eigenschaft

Wenn in diesem Beispiel das aktive Dokument ein Rich Text Format (RTF) Dokument ist, wird es als Word-Dokument gespeichert.

If ActiveDocument.SaveFormat = wdFormatRTF Then
    ActiveDocument.SaveAs FileFormat:=wdFormatDocument
End If

In diesem Beispiel werden die Konvertierungsprogramme angezeigt, die zum Speichern von Dokumenten verwendet werden können. Das Meldungsfeld zeigt den eindeutigen Speicherformatwert und den Formatnamen an.

For Each fc In FileConverters
    If fc.CanSave = True Then _
        MsgBox fc.SaveFormat & vbCr & fc.FormatName
Next fc

In diesem Beispiel wird das aktive Dokument im WordPerfect 5.1- oder 5.2- Sekundärdateiformat gespeichert.

ActiveDocument.SaveAs _
    FileFormat:=FileConverters("WrdPrfctDat").SaveFormat


SaveFormsData-Eigenschaft

True, wenn Word die in ein Formular eingegebenen Daten als einen durch Tabstops getrennten Datensatz speichert, der in einer Datenbank verwendet werden kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur SaveFormsData-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass nur die eingegebenen Daten in einem Formular gespeichert werden.

ActiveDocument.SaveFormsData = True

In diesem Beispiel wird der aktuelle Status der Option In Formularen nur Daten speichern auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = ActiveDocument.SaveFormsData


SaveInterval-Eigenschaft

Gibt das Zeitintervall in Minuten für das Speichern von AutoWiederherstellen-Info zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Setzen Sie die SaveInterval-Eigenschaft auf 0 (Null), um das Speichern von AutoWiederherstellen-Info auszuschalten.


Beispiel zur SaveInterval-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word alle fünf Minuten AutoWiederherstellen-Info für alle geöffneten Dokumente speichert.

Options.SaveInterval = 5

In diesem Beispiel wird verhindert, dass Word AutoWiederherstellen-Info speichert.

Options.SaveInterval = 0

In diesem Beispiel wird der aktuelle Status der Option AutoWiederherstellen-Info speichern alle auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.SaveInterval


SaveNormalPrompt-Eigenschaft

True, wenn Word den Benutzer auffordert, vor Verlassen des Programms zu bestätigen, ob Veränderungen an der Dokumentvorlage Normal gespeichert werden. False, wenn Word vor Beendigung des Programms Veränderungen an der Dokumentvorlage Normal automatisch speichert. Boolean Schreib-Lese-Zugriff.


Beispiel zur SaveNormalPrompt-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Veränderungen an der Dokumentvorlage Normal automatisch vor Verlassen des Programms gespeichert werden. Dann wird das Programm beendet.

Options.SaveNormalPrompt = False
Application.Quit

In diesem Beispiel wird der aktuelle Status der Option Automatische Anfrage für Speicherung von Normal.dot auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.SaveNormalPrompt


SavePictureWithDocument-Eigenschaft

True, wenn die angegebene Grafik mit dem Dokument gespeichert wird. Boolean Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft gibt es nur bei Formen und zeilenfixierten Formen, die verknüpfte Grafiken sind.


Beispiel zur SavePictureWithDocument-Eigenschaft

In diesem Beispiel wird im aktiven Dokument die verknüpfte Grafik, die als erste zeilenfixierte Form definiert ist, gespeichert, wenn das Dokument gespeichert wird.

Set myPic = ActiveDocument.InlineShapes(1)
If myPic.Type = wdInlineShapeLinkedPicture Then
    myPic.LinkFormat.SavePictureWithDocument = True
End If


SavePropertiesPrompt-Eigenschaft

True, falls Word Dateieigenschaft-Informationen anfordert, wenn ein neues Dokument gespeichert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur SavePropertiesPrompt-Eigenschaft

In diesem Beispiel wird Word veranlasst, Dateieigenschaft-Informationen anzufordern, wenn ein neues Dokument gespeichert wird.

Options.SavePropertiesPrompt = True

In diesem Beispiel wird der aktuelle Status der Option Automatische Anfrage für Dateieigenschaften auf der Registerkarte Speichern im Dialogfeld Optionen zurückgegeben.

temp = Options.SavePropertiesPrompt


SaveSubsetFonts-Eigenschaft

True, wenn Word eine Untermenge der eingebetteten TrueType-Schriftarten mit dem Dokument speichert. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn weniger als 32 Zeichen einer TrueType-Schriftart in einem Dokument verwendet werden, bettet Word die Untermenge (nur die verwendeten Zeichen) in das Dokument ein. Werden mehr als 32 Zeichen verwendet, bettet Word die gesamte Schriftart ein.


Beispiel zur SaveSubsetFonts-Eigenschaft

In diesem Beispiel wird für ein Dokument namens "MeinDok" festgelegt, dass es nur eine Untermenge seiner eingebetteten TrueType-Schriftarten (wenn nur wenige Zeichen verwendet werden) speichert, anschließend wird "MeinDok" gespeichert.

With Documents("MyDoc")
    .EmbedTrueTypeFonts = True
    .SaveSubsetFonts = True
    .Save
End With


ScaleHeight-Eigenschaft

Skaliert die Höhe der angegebenen eingebetteten Form relativ zur Originalgröße. Single Schreib-Lese-Zugriff.


Beispiel zur ScaleHeight-Eigenschaft

Dieses Beispiel legt für die Höhe und Breite der ersten eingebetteten Form im aktiven Dokument 150 Prozent der Originalhöhe und -breite der Form fest.

With ActiveDocument.InlineShapes(1)
    .ScaleHeight = 150
    .ScaleWidth = 150
End With


ScaleWidth-Eigenschaft

Skaliert die Breite der angegebenen eingebetteten Form relativ zur Originalgröße. Single Schreib-Lese-Zugriff.


Beispiel zur ScaleWidth-Eigenschaft

Dieses Beispiel legt für die Höhe und Breite der ersten eingebetteten Form im aktiven Dokument 150 Prozent der Originalhöhe und -breite der Form fest.

With ActiveDocument.InlineShapes(1)
    .ScaleHeight = 150
    .ScaleWidth = 150
End With


Scaling-Eigenschaft

Gibt den Skalierungs-Prozentwert zurück, der der Schriftart zugewiesen wurde, oder legt ihn fest. Diese Eigenschaft streckt den Text horizontal oder drückt ihn horizontal zusammen. Die Skalierung wird als Prozentwert der aktuellen Größe angegeben. (Der Skalierungsbereich erstreckt sich von 1 bis 600). Long Schreib-Lese-Zugriff.


Beispiel zur Scaling-Eigenschaft

In diesem Beispiel wird der Text im aktiven Dokument horizontal auf 110 Prozent seines ursprünglichen Umfangs gestreckt.

ActiveDocument.Content.Font.Scaling = 110

In diesem Beispiel wird der Text im ersten Absatz in Verkauf.doc horizontal auf 90 Prozent seines ursprünglichen Umfangs zusammengedrückt.

With Documents("Sales.doc").Paragraphs(1).Range.Font
    .Scaling = 90
    .Bold = False
End With


Scope-Eigenschaft

Gibt ein Range-Objekt zurück, das den Textbereich darstellt, der durch den angegebenen Kommentar markiert ist. Nur-Lese-Zugriff.


Beispiel zur Scope-Eigenschaft

In diesem Beispiel wird der Text angezeigt, der mit dem ersten Kommentar in der Markierung verbunden ist.

If Selection.Comments.Count >= 1 Then
    Set myRange = Selection.Comments(1).Scope
    MsgBox myRange.Text
End If

In diesem Beispiel wird der mit dem letzten Kommentar im aktiven Dokument verbundene Text kopiert.

total = ActiveDocument.Comments.Count
If total >= 1 Then ActiveDocument.Comments(total).Scope.Copy


ScreenSize-Eigenschaft

Gibt die optimale Mindestgröße des Bildschirms (Breite mal Höhe, in Pixel) für das Betrachten des gespeicherten Dokuments in einem Webbrowser zurück oder legt diese fest. Dabei kann es sich um eine der unten aufgeführten MsoScreenSize-Konstanten handeln. Die Standardkonstante ist msoScreenSize800x600. Long Schreib-Lese-Zugriff.

msoScreenSize544x376

msoScreenSize640x480

msoScreenSize720x512

msoScreenSize800x600

msoScreenSize1024x768

msoScreenSize1152x882

 msoScreenSize1152x900

msoScreenSize1280x1024

msoScreenSize1600x1200

msoScreenSize1800x1440

msoScreenSize1920x1200


Beispiel zur ScreenSize-Eigenschaft

In diesem Beispiel wird die Bildschirmgröße auf 800x600 Pixel gesetzt.

Application.DefaultWebOptions.ScreenSize = _
    msoScreenSize800x600


ScreenTip-Eigenschaft

Gibt den Bildschirmtipptext zurück, der eingeblendet wird, wenn der Mauszeiger auf den angegebenen Hyperlink zeigt, oder legt diesen fest. String Schreib-Lese-Zugriff.


Beispiel zur ScreenTip-Eigenschaft

In diesem Beispiel wird der Bildschirmtipptext für den ersten Hyperlink im aktiven Dokument festgelegt.

ActiveDocument.Hyperlinks(1).ScreenTip = _
    "Home"


ScreenUpdating-Eigenschaft

True, wenn die Bildschirmaktualisierung aktiviert ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die ScreenUpdating-Eigenschaft steuert die meisten auf dem Monitor angezeigten Änderungen, während eine Prozedur ausgeführt wird. Bei deaktivierter Bildschirmaktualisierung bleiben die Symbolleisten sichtbar, und es ist immer noch möglich, dass die Prozedur Informationen über Eingabeaufforderungen in der Statusleiste, Eingabefelder, Dialogfelder und Meldungsfelder anzeigt und abruft. Sie können durch die Deaktivierung der Bildschirmaktualisierung die Geschwindigkeit einiger Prozeduren erhöhen. Sie müssen nach Beendigung der Prozedur, oder wenn sie aufgrund eines Fehlers unterbrochen wird, die ScreenUpdating-Eigenschaft auf True setzen.


Beispiel zur ScreenUpdating-Eigenschaft

Dieses Beispiel deaktivert die Bildschirmaktualisierung und fügt ein neues Dokument hinzu. 500 Textzeilen werden in das Dokument aufgenommen. Nach jeder 50. Zeile wählt das Makro die Zeile und aktualisiert den Bildschirm.

Application.ScreenUpdating = False
Documents.Add
For x = 1 To 500
    With ActiveDocument.Content
        .InsertAfter "This is line ." & x
        .InsertParagraphAfter
    End With
If x Mod 50 = 0 Then
   ActiveDocument.Paragraphs(x).Range.Select
   Application.ScreenRefresh
End If
Next x
Application.ScreenUpdating = True


Script-Eigenschaft

Gibt das Script-Objekt zurück, das einen Code- oder Skriptblock auf der angegebenen Webseite darstellt. Wenn die Seite kein Skript enthält, erfolgt keine Rückgabe. Nur-Lese-Zugriff.


Scripts-Eigenschaft

Gibt eine Scripts-Auflistung zurück, die die Auflistung von HTML-Skripten im angegebenen Document- oder Range-Objekt darstellt. Nur-Lese-Zugriff.


Beispiel zur Scripts-Eigenschaft

In diesem Beispiel wird der Text im ersten Script-Objekt des aktiven Dokuments angezeigt.

Debug.Print ActiveDocument.Scripts(1).ScriptText

In diesem Beispiel wird das zweite Script-Objekt im angegebenen Bereich auf die verwendete Sprache geprüft.

Select Case Selection.Range.Scripts(2).Language
    Case msoScriptLanguageASP
        MsgBox "Active Server Pages"
    Case msoScriptLanguageVisualBasic
        MsgBox "VBScript"
    Case msoScriptLanguageJava
        MsgBox "JavaScript"
    Case msoScriptLanguageOther
        MsgBox "Unknown type of script"
End Select


SectionDirection-Eigenschaft

Sprachspezifische Informationen

Returns or sets the reading order and alignment for the specified sections. Read/write Long.

Can be either of the following WdSectionDirection constants.

Constant | Description
wdSectionDirectionLtr | Displays the section with left alignment and left-to-right reading order.
wdSectionDirectionRtl | Displays the section with right alignment and right-to-left reading order.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur SectionDirection-Eigenschaft

This example sets the direction of the first section in the active document to right-to-left.

ActiveDocument.Sections(1).PageSetup.SectionDirection = _
    wdSectionDirectionRtl


Sections-Eigenschaft

Gibt eine Sections-Sammlung zurück, die die Abschnitte im angegebenen Dokument, im Bereich oder in der Auswahl darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


SectionStart-Eigenschaft

Gibt den Abschnittswechseltyp für das angegebene PageSetup-Objekt zurück oder legt ihn fest. Kann eine der folgenden WdSectionStart-Konstanten sein: wdSectionContinuous, wdSectionEvenPage, wdSectionNewColumn, wdSectionNewPage oder wdSectionOddPage. Long Schreib-Lese-Zugriff.


Beispiel zur SectionStart-Eigenschaft

In diesem Beispiel wird für alle Abschnitte im aktiven Dokument der Abschnittswechseltyp in fortlaufend geändert.

ActiveDocument.PageSetup.SectionStart = wdSectionContinuous

In diesem Beispiel wird der Abschnittswechseltyp zurückgegeben, der am Anfang des zweiten Abschnitts in MeinDok verwendet wird. Anschließend wird er allen Abschnitten im aktiven Dokument zugewiesen.

mytype = Documents("MyDoc.doc").Sections(2).PageSetup.SectionStart
ActiveDocument.PageSetup.SectionStart = mytype


SeekView-Eigenschaft

Gibt das Dokumentelement zurück, das in der Seitenlayoutansicht angezeigt wird, oder legt es fest. Dies kann eine der folgenden WdSeekView-Konstanten sein: wdSeekCurrentPageFooter, wdSeekCurrentPageHeader, wdSeekEndnotes, wdSeekEvenPagesFooter, wdSeekEvenPagesHeader, wdSeekFirstPageFooter, wdSeekFirstPageHeader, wdSeekFootnotes, wdSeekMainDocument, wdSeekPrimaryFooter oder wdSeekPrimaryHeader. Long Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft erzeugt einen Fehler, wenn die Ansicht nicht die Seitenlayoutansicht ist.


Beispiel zur SeekView-Eigenschaft

In diesem Beispiel werden in der Seitenlayoutansicht Fußnoten angezeigt, sofern das aktive Dokument Fußnoten enthält.

If ActiveDocument.Footnotes.Count >= 1 Then
    With ActiveDocument.ActiveWindow.View
        .Type = wdPrintView
        .SeekView = wdSeekFootnotes
    End With
End If

In diesem Beispiel wird die erste Fußzeile des aktuellen Abschnitts angezeigt.

ActiveDocument.PageSetup.DifferentFirstPageHeaderFooter = True
With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekFirstPageFooter
End With

In diesem Beispiel wird zum Hauptdokument gewechselt, wenn sich die Markierung in der Seitenlayoutansicht in einem Fußnoten- oder Endnotenbereich befindet.

Set myView = ActiveDocument.ActiveWindow.View
If myView.SeekView = wdSeekFootnotes Or _
    myView.SeekView = wdSeekEndnotes Then
    myView.SeekView = wdSeekMainDocument
End If


SegmentType-Eigenschaft

Gibt einen Wert zurück, der anzeigt, ob das Segment, das mit dem angegebenen Knoten verbunden ist, gerade oder gekrümmt ist. Dies kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine. Wenn der angegebene Knoten ein Kontrollpunkt für ein gekrümmtes Segment ist, gibt diese Eigenschaft msoSegmentCurve zurück. Long Nur-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetSegmentType-Methode zum Festlegen des Wertes dieser Eigenschaft.


Beispiel zur SegmentType-Eigenschaft

In diesem Beispiel werden in myDocument in Form drei alle geraden Segmente in gekrümmte Segmente umgewandelt. Form drei muss eine Freihandfigur sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


Selection-Eigenschaft

Gibt das Selection-Objekt zurück, das einen markierten Bereich oder einen Einfügepunkt darstellt. Nur-Lese-Zugriff.


Beispiel zur Selection-Eigenschaft

In diesem Beispiel wird der markierte Text dargestellt.

If Selection.Type = wdSelectionNormal Then MsgBox Selection.Text

In diesem Beispiel wird die Markierung von Windows 1 zum nächsten Fenster kopiert.

If Windows.Count >= 2 Then
    Windows(1).Selection.Copy
    Windows(1).Next.Activate
    Selection.Paste
End If

In diesem Beispiel wird der Markierung das Format Fett und die Schriftart Arial zugewiesen.

With Selection.Font
    .Bold = True
    .Italic = False
    .Name = "Arial"
End With

Wenn sich der Einfügepunkt nicht in der Tabelle befindet, wird die Markierung in die nächste Tabelle verschoben.

If Selection.Information(wdWithInTable) = False Then
    Selection.GoToNext What:=wdGoToTable
End If


SenderCity-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


SenderCode-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


SenderCompany-Eigenschaft

Gibt den Firmennamen der Person, die einen Brief mit dem Brief-Assistenten erstellt, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur SenderCompany-Eigenschaft

In diesem Beispiel werden die Elemente des Brief-Assistenten im aktiven Dokument geladen. Wenn der Firmenname des Senders nicht leer ist, wird der Text in einem Meldungsfeld angezeigt.

If ActiveDocument.GetLetterContent.SenderCompany <> "" Then
    MsgBox ActiveDocument.GetLetterContent.SenderCompany
End If


SenderGender-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


SenderInitials-Eigenschaft

Gibt die Initialen der Person, die einen Brief mit dem Brief-Assistenten erstellt, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur SenderInitials-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt mit dem Namen des Absenders und den Initialen aus der Registerkarte Benutzerinformationen im Dialogfeld Option (Menü Extras) erstellt. Das Beispiel legt ein neues Dokument an und ruft anschließend den Brief-Assistenten mit der RunLetterWizard-Methode auf.

Set myContent = New LetterContent
With myContent
    .SenderName = Application.UserName
    .SenderInitials =Application.UserInitials
End With
Documents.Add.RunLetterWizard _
    LetterContent:=myContent, WizardMode:=True


SenderJobTitle-Eigenschaft

Gibt die Position der Person, die einen Brief mit dem Brief-Assistenten erstellt, zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur SenderJobTitle-Eigenschaft

In diesem Beispiel werden die Elemente des Brief-Assistenten im aktiven Dokument geladen und die Position des Senders angezeigt.

Set myLetterContent = ActiveDocument.GetLetterContent
MsgBox myLetterContent.SenderJobTitle


SenderName-Eigenschaft

Gibt den Namen der Person, die einen Brief mit dem Brief-Assistenten erstellt, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur SenderName-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt mit dem Namen des Absenders und den Initialen aus der Registerkarte Benutzerinformationen im Dialogfeld Option (Menü Extras) erstellt. Das Beispiel legt ein neues Dokument an und ruft anschließend den Brief-Assistenten mit der RunLetterWizard-Methode auf.

Set myContent = New LetterContent
With myContent
    .SenderName = Application.UserName
    .SenderInitials =Application.UserInitials
End With
Documents.Add.RunLetterWizard _
    LetterContent:=myContent, WizardMode:=True


SenderReference-Eigenschaft

Wird nicht in der deutschen Version von Microsoft Word verwendet.

Hinweise

Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) ab.


SendMailAttach-Eigenschaft

True, wenn der Befehl Senden an im Menü Datei das aktive Dokument als eine Anlage zu einer Nachricht einfügt. False, wenn der Befehl Senden an den Inhalt des aktiven Dokuments als Text in die Nachricht einfügt. Boolean Schreib-Lese-Zugriff.


Beispiel zur SendMailAttach-Eigenschaft

In diesem Beispiel wird eine neue Nachricht mit dem aktiven Dokument als Anlage geöffnet.

Options.SendMailAttach = True
ActiveDocument.SendMail

In diesem Beispiel wird der Status der Option Nachricht als Anlage senden auf der Registerkarte Allgemein im Dialogfeld Optionen zurückgegeben.

Msgbox Options.SendMailAttach


Sentences-Eigenschaft

Gibt eine Sentences-Auflistung zurück, die alle Sätze im Bereich, in der Markierung oder im Dokument darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Sentences-Eigenschaft

In diesem Beispiel wird der erste Satz im aktiven Dokument kopiert.

ActiveDocument.Sentences(1).Copy

In diesem Beispiel wird der letzte Satz im aktiven Dokument gelöscht.

ActiveDocument.Sentences.Last.Delete

In diesem Beispiel wird die Anzahl der Sätze im ersten Absatz des aktiven Dokuments angezeigt.

MsgBox ActiveDocument.Paragraphs(1).Range _
    .Sentences.Count & " sentences"


Separator-Eigenschaft

Endnotes- oder Footnotes-Objekt: Gibt ein Range-Objekt zurück, das die Endnoten- oder Fußnotentrennlinie darstellt. Nur-Lese-Zugriff.

CaptionLabel-Objekt: Gibt das Zeichen zwischen der Kapitelnummer und der Folgenummer zurück oder legt dieses fest. Dabei kann es sich um eine der folgenden WdSeparatorType-Konstanten handeln: wdSeparatorColon, wdSeparatorEmDash, wdSeparatorEnDash, wdSeparatorHyphen oder wdSeparatorPeriod. Long Schreib-Lese-Zugriff.

TableOfAuthorities-Objekt: Gibt bis zu fünf Zeichen zwischen der Folgenummer und der Seitennummer zurück oder legt diese fest. Das Standardzeichen ist ein Bindestrich (-). Diese Eigenschaft entspricht dem Parameter \d für ein TOA-Feld. String Schreib-Lese-Zugriff.


Beispiel zur Separator-Eigenschaft

In diesem Beispiel wird die Beschriftung einer Abbildung eingefügt, wobei sich zwischen der Kapitelnummer und der Folgenummer ein Doppelpunkt (:) befindet.

With CaptionLabels("Figure")
    .Separator = wdSeparatorColon
    .IncludeChapterNumber = True
End With
Selection.InsertCaption "Figure"

In diesem Beispiel wird die Fußnotentrennlinie in eine einfache Rahmenlinie mit einem Einzug von 3 Zoll (ca. 7,62 cm) vom rechten Seitenrand geändert.

With ActiveDocument.Footnotes.Separator
    .Delete
    .Borders(wdBorderTop).LineStyle = wdLineStyleSingle
    .ParagraphFormat.RightIndent = InchesToPoints(3)
End With

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Rechtsgrundlagenverzeichnis eingefügt. Das Verzeichnis wird dann mit einer Folgenummer und Seitenzahl formatiert, die durch einen Bindestrich (-) getrennt sind.

Set myRange = ActiveDocument.Range(0, 0)
With ActiveDocument.TablesOfAuthorities.Add(Range:=myRange)
    .IncludeSequenceName = "Chapter"
    .Separator = "-"
End With


Shaded-Eigenschaft

True, wenn den Formularfeldern Schattierung zugewiesen wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Schattierung werden Formularfelder in einem Dokument leichter gefunden. Die Schattierung hat keinen Einfluss auf die Druckerausgabe.


Beispiel zur Shaded-Eigenschaft

In diesem Beispiel wird die Schattierung von Formularfeldern im Dokument "Arbeitsverhältnis Form.doc" entfernt.

Documents("Employment Form.doc").FormFields.Shaded = False

In diesem Beispiel wird den Formularfeldern im aktiven Dokument Schattierung hinzugefügt und das Dokument für Formulare geschützt.

With ActiveDocument
    .FormFields.Shaded = True
    .Protect Type:=wdAllowOnlyFormFields, NoReset:=True
End With


Shading-Eigenschaft

Gibt ein Shading-Objekt zurück, das sich auf die Formatierung der Schattierung des angegebenen Objekts bezieht. Nur-Lese-Zugriff.


Beispiel zur Shading-Eigenschaft

In diesem Beispiel wird dem ersten Absatz in der Auswahl eine gelbe Schattierung zugewiesen.

With Selection.Paragraphs(1).Shading
    .Texture = wdTexture12Pt5Percent
    .BackgroundPatternColorIndex = wdYellow
    .ForegroundPatternColorIndex = wdBlack
End With

In diesem Beispiel wird eine horizontale Linienstrukturierung auf die erste Zeile in Tabelle 1 angewendet.

If ActiveDocument.Tables.Count >= 1 Then
    With ActiveDocument.Tables(1).Rows(1).Shading
        .Texture = wdTextureHorizontal
    End With
End If

In diesem Beispiel wird das erste Wort im aktiven Dokument mit einer 10%igen Schattierung versehen.

ActiveDocument.Words(1).Shading.Texture = wdTexture10Percent


Shadow-Eigenschaft

Font-Objekt: True, wenn die angegebene Schriftart schattiert formatiert ist. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.

Borders-Objekt: True, wenn der angegebene Rahmen schattiert formatiert ist. Boolean Schreib-Lese-Zugriff.

Shape- und ShapeRange-Objekte: Gibt ein ShadowFormat-Objekt zurück, das die Schattierungsformatierung für die angegebene Form darstellt. Long Nur-Lese-Zugriff.


Beispiel zur Shadow-Eigenschaft

In diesem Beispiel werden in einem neuen Dokument zwei verschiedene Rahmenarten demonstriert.

Set myRange = Documents.Add.Content
With myRange
   .InsertAfter "Demonstration of border with shadow. "
   .InsertParagraphAfter
   .InsertParagraphAfter
   .InsertAfter "Demonstration of border without shadow."
End With
With ActiveDocument
    .Paragraphs(1).Borders.Shadow = True
    .Paragraphs(3).Borders.Enable = True
End With

In diesem Beispiel wird der Markierung Schattierungs- und Fettformatierung zugewiesen.

If Selection.Type = wdSelectionNormal Then
    With Selection.Font
        .Shadow = True
        .Bold = True
    End With
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird dem aktiven Dokument ein Pfeil mit Schattierungsformatierung hinzugefügt.

Set myShape = ActiveDocument.Shapes _
    .AddShape(Type:=msoShapeRightArrow, _
    Left:=90, Top:=79, Width:=64, Height:=43)
myShape.Shadow.Type = msoShadow5


Shape-Eigenschaft

Liefert ein Shape-Objekt für den angegebenen Hyperlink. Wenn der Hyperlink nicht durch eine Form dargestellt wird, tritt ein Fehler auf. Nur-Lese-Zugriff.


ShapeRange-Eigenschaft

Liefert eine ShapeRange-Auflistung, die alle Shape-Objekte im festgelegten Bereich oder in der Auswahl darstellt. Der Formenbereich kann Zeichnungen, Formen, Bilder, OLE-Objekte, ActiveX-Steuerelemente, Text-Objekte und Legenden enthalten. Nur-Lese-Zugriff.


Beispiel zur ShapeRange-Eigenschaft

In diesem Beispiel wird Violett als Füllfarbe für den Vordergrund aller Formen im aktiven Dokument festgelegt.

ActiveDocument.Content.ShapeRange.Fill.ForeColor.RGB = _
    RGB(255, 0, 255)

Im folgenden Beispiel wird die Formatierung "Schatten" allen Formen in der Auswahl zugewiesen.

Selection.ShapeRange.Shadow.Type = msoShadow6


Shapes-Eigenschaft

Liefert eine Shapes-Auflistung, die alle Shape-Objekte im angegebenen Dokument und in der Kopf- oder Fußzeile darstellt. Diese Auflistung kann Zeichnungen, Formen, Bilder, OLE-Objekte, ActiveX-Steuerelemente, Text-Objekte und Legenden enthalten. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Wenn Sie die Shapes-Eigenschaft einem Dokument zuweisen, werden alle Shape-Objekte im Haupttextbereich des Dokuments, außer Kopf- und Fußzeilen, zurückgegeben. Wenn Sie sie einem HeaderFooter-Objekt zuweisen, gibt die Shapes-Eigenschaft alle Shape-Objekte zurück, die sie in den Kopf- und Fußzeilen des Dokuments findet.


Beispiel zur Shapes-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt, ein 100 Punkt breites und 50 Punkt hohes Rechteck hinzugefügt und festgelegt, dass die obere linke Ecke des Rechtecks 5 Punkt von der linken Seitenkante und 25 Punkt von der oberen linken Ecke der Seite liegt.

Set myDoc = Documents.Add
myDoc.Shapes.AddShape msoShapeRectangle, 5, 25, 100, 50

In diesem Beispiel wird die Füllstruktur für alle Formen im aktiven Dokument festgelegt.

For each s in ActiveDocument.Shapes
    s.Fill.PresetTextured msoTextureOak
Next s

In diesem Beispiel wird die erste Form im aktiven Dokument mit einem Schatten versehen.

Set myShape = ActiveDocument.Shapes(1)
myShape.Shadow.Type = msoShadow6

In diesem Beispiel wird die Anzahl aller Formen in der primären Kopf- und Fußzeile im ersten Abschnitt des aktiven Dokuments angezeigt.

MsgBox ActiveDocument.Sections(1). _
    Headers(wdHeaderFooterPrimary).Shapes.Count


ShowAll-Eigenschaft

True, wenn alle nicht druckbaren Zeichen angezeigt werden, wie beispielsweise ausgeblendeter Text, Tabstoppmarken, Leerzeichen und Abschnittsmarken. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowAll-Eigenschaft

In diesem Beispiel werden im aktiven Fenster alle nicht druckbaren Zeichen angezeigt.

ActiveDocument.ActiveWindow.View.ShowAll = True

In diesem Beispiel wird im ersten Fenster die Anzeige der nicht druckbaren Zeichen umgeschaltet.

Windows(1).View.ShowAll = Not Windows(1).View.ShowAll


ShowAnimation-Eigenschaft

True, wenn Textanimation angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowAnimation-Eigenschaft

In diesem Beispiel wird im aktiven Fenster Textanimation eingeschaltet und dann der Markierung die Animation "Funkelnder Text" zugewiesen.

ActiveDocument.ActiveWindow.View.ShowAnimation = True
Selection.Font.Animation = wdAnimationSparkleText

In diesem Beispiel wird in allen geöffneten Fenstern Schriftanimation ausgeschaltet.

For Each aWindow In Windows
    aWindow.View.ShowAnimation = False
Next aWindow


ShowBookmarks-Eigenschaft

True, wenn am Anfang und Ende jeder Textmarke eckige Klammern angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowBookmarks-Eigenschaft

In diesem Beispiel werden in allen Fenstern um Textmarken eckige Klammern angezeigt.

For Each aWindow In Windows
    aWindow.View.ShowBookmarks = True
Next aWindow

In diesem Beispiel wird die Markierung mit einer Textmarke gekennzeichnet, werden im aktiven Dokument um jede Textmarke eckige Klammern angezeigt, und anschließend wird die Markierung reduziert.

ActiveDocument.Bookmarks.Add Range:=Selection.Range, Name:="temp"
ActiveDocument.ActiveWindow.View.ShowBookmarks = True
Selection.Collapse Direction:=wdCollapseStart


ShowBy-Eigenschaft

Gibt den Namen der Person, die das Dokument bearbeitet und deren Kommentare im Kommentarausschnitt angezeigt werden, zurück oder legt sie fest. Sie können entweder die Kommentare eines Bearbeiters oder aller Bearbeiter anzeigen. String Schreib-Lese-Zugriff.

Hinweis Setzen Sie diese Eigenschaft auf "Alle Bearbeiter", um alle Kommentare anzuzeigen."

Syntax

Ausdruck.ShowBy(Author)

Ausdruck Erforderlich. Ein Ausdruck, der ein Comments-Objekt zurückgibt.

Author String erforderlich. Der Name des Bearbeiters.


Beispiel zur ShowBy-Eigenschaft

Im folgenden Beispiel werden die Kommentare von Don Funk angezeigt.

If ActiveDocument.Comments.Count >= 1 Then
    ActiveDocument.ActiveWindow.View.SplitSpecial = wdPaneComments
    ActiveDocument.Comments.ShowBy = "Don Funk"
End If


ShowCodes-Eigenschaft

True, wenn die Feldfunktionen des angegebenen Felds angezeigt werden und nicht die Feldergebnisse. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowCodes-Eigenschaft

In diesem Beispiel wird das nächste Feld gewählt und die Feldfunktionen werden angezeigt.

With Selection
    .GoTo What:=wdGoToField
    .Expand Unit:=wdWord
    If .Fields.Count = 1 Then .Fields(1).ShowCodes = True
End With

In diesem Beispiel wird das Ergebnis des ersten Felds im aktiven Dokument aktualisiert und angezeigt.

If ActiveDocument.Fields.Count >= 1 Then
    With ActiveDocument.Fields(1)
        .Update
        .ShowCodes = False
    End With
End If


ShowControlCharacters-Eigenschaft

Sprachspezifische Informationen

True if bidirectional control characters are visible in the current document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ShowControlCharacters-Eigenschaft

This example hides bidirectional control characters in the current document.

Options.ShowControlCharacters = False


ShowDiacritics-Eigenschaft

Sprachspezifische Informationen

True if diacritics are visible in a right-to-left language document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur ShowDiacritics-Eigenschaft

This example hides diacritics in the current document.

Options.ShowDiacritics = False


ShowDrawings-Eigenschaft

True, wenn in der Seitenlayoutansicht Objekte angezeigt werden, die mit den Zeichnungstools erstellt wurden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowDrawings-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Seitenlayoutansicht gesetzt, und es werden Objekte angezeigt, die mit den Zeichnungstools erstellt wurden.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .ShowDrawings = True
End With


ShowFieldCodes-Eigenschaft

True, wenn Feldfunktionen angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowFieldCodes-Eigenschaft

In diesem Beispiel werden im Fenster für Dokument1 Feldfunktionen ausgeblendet.

Windows("Document1").View.ShowFieldCodes = False

In diesem Beispiel werden im ersten Fenster Feldfunktionen angezeigt.

Windows(1).View.ShowFieldCodes = True

In diesem Beispiel wird im aktiven Fenster die Anzeige der Feldfunktionen umgeschaltet.

ActiveDocument.ActiveWindow.View.ShowFieldCodes = _
    Not ActiveDocument.ActiveWindow.View.ShowFieldCodes


ShowFirstLineOnly-Eigenschaft

True, wenn in der Gliederungsansicht nur die erste Zeile des Textkörpers angezeigt wird. Boolean Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft erzeugt einen Fehler, wenn die Ansicht nicht die Gliederungsansicht oder die Zentraldokument-Ansicht ist.


Beispiel zur ShowFirstLineOnly-Eigenschaft

In diesem Beispiel wird das aktive Fenster in der Gliederungsansicht umgeschaltet, und es werden alle Textkörperzeilen außer der ersten ausgeblendet.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .ShowFirstLineOnly = True
End With


ShowFirstPageNumber-Eigenschaft

True, wenn auf der ersten Seite des Abschnitts die Seitennummer erscheint. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ist diese Eigenschaft auf True gesetzt, werden einem Abschnitt automatisch Seitennummern hinzugefügt.


Beispiel zur ShowFirstPageNumber-Eigenschaft

In diesem Beispiel wird geprüft, ob im aktiven Dokument auf der ersten Seite die Seitennummer erscheint. Das Ergebnis wird angezeigt.

Set myDoc = ActiveDocument
first = myDoc.Sections(1).Headers(wdHeaderFooterPrimary). _
    PageNumbers.ShowFirstPageNumber
Msgbox "This document shows numbers on the first page - " & first

In diesem Beispiel werden dem aktiven Dokument Seitennummern hinzugefügt.

ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary).PageNumbers _
    .ShowFirstPageNumber = True


ShowFormat-Eigenschaft

True, wenn in der Gliederungsansicht Zeichenformatierung zu sehen ist. Boolean Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft erzeugt einen Fehler, wenn die Ansicht nicht die Gliederungsansicht oder die Zentraldokument-Ansicht ist.


Beispiel zur ShowFormat-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Gliederungsansicht umgeschaltet und Zeichenformatierung angezeigt.

With ActiveDocument.ActiveWindow.View
    .Type = wdOutlineView
    .ShowFormat = True
End With


ShowGrammaticalErrors-Eigenschaft

True, wenn Grammatikfehler im angegebenen Dokument durch eine gewellte grüne Linie markiert werden. Boolean Schreib-Lese-Zugriff.

Hinweis Um Grammatikfehler in einem Dokument darzustellen, müssen Sie die CheckGrammarAsYouType-Eigenschaft auf True setzen.


Beispiel zur ShowGrammaticalErrors-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word die Grammatik bei der Eingabe überprüft und gefundene Fehler im aktiven Dokument angezeigt werden.

Options.CheckGrammarAsYouType = True
ActiveDocument.ShowGrammaticalErrors = True


ShowHidden-Eigenschaft

True, wenn sich ausgeblendete Textmarken in der Bookmarks-Auflistung befinden. Mit dieser Eigenschaft legen Sie auch fest, ob ausgeblendete Textmarken im Dialogfeld Textmarke (Menü Einfügen) aufgeführt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ausgeblendete Textmarken werden automatisch beim Einfügen von Querverweisen in ein Dokument eingefügt.


ShowHiddenText-Eigenschaft

True, wenn Text, der als ausgeblendeter Text formatiert ist, angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowHiddenText-Eigenschaft

In diesem Beispiel wird in jedem Fenster Text ausgeblendet, der als ausgeblendeter Text formatiert ist.

For Each myWindow In Windows
    myWindow.View.ShowHiddenText = False
Next myWindow

In diesem Beispiel wird die Anzeige von ausgeblendetem Text umgeschaltet.

ActiveDocument.ActiveWindow.View.ShowHiddenText = _
    Not ActiveDocument.ActiveWindow.View.ShowHiddenText


ShowHighlight-Eigenschaft

True, wenn Hervorhebungs-Formatierung angezeigt und mit einem Dokument gedruckt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowHighlight-Eigenschaft

In diesem Beispiel wird im aktiven Dokument die Anzeige der Hervorhebung umgeschaltet.

ActiveDocument.ActiveWindow.View.ShowHighlight = _
    Not ActiveDocument.ActiveWindow.View.ShowHighlight

In diesem Beispiel wird das aktive Dokument ohne Hervorhebungsformatierung ausgedruckt.

With ActiveDocument
    .ActiveWindow.View.ShowHighlight = False
    .PrintOut
End With


ShowHyphens-Eigenschaft

True, wenn bedingte Trennstriche angezeigt werden. Ein bedingter Trennstrich zeigt an, wo ein Wort getrennt werden soll, wenn es am Ende einer Zeile steht. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowHyphens-Eigenschaft

In diesem Beispiel wird vor der Markierung ein bedingter Trennstrich eingefügt, dann werden im aktiven Fenster bedingte Trennstriche angezeigt.

Selection.InsertBefore Chr(31)
ActiveDocument.ActiveWindow.View.ShowHyphens = True


ShowMainTextLayer-Eigenschaft

True, wenn der Text im angegebenen Dokument eingeblendet ist, wenn die Flächen für die Kopf- und Fußzeile angezeigt werden. Diese Eigenschaft entspricht der Schaltfläche Dokumenttext anzeigen/ausblenden in der Symbolleiste Kopf- und Fußzeile. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowMainTextLayer-Eigenschaft

Dieses Beispiel zeigt die Kopfzeile des Dokuments im aktiven Fenster an und blendet den Dokumenttext aus.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .SeekView = wdSeekCurrentPageHeader
    .ShowMainTextLayer = False
End With


ShowObjectAnchors-Eigenschaft

True, wenn Verankerungspunkte neben Elementen angezeigt werden, die in der Seitenlayoutansicht positioniert werden können. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowObjectAnchors-Eigenschaft

In diesem Beispiel wird ein Rahmen um die Markierung gelegt und das aktive Fenster in die Seitenlayoutansicht gesetzt, und es werden Verankerungspunkte für gerahmte Objekte angezeigt.

Selection.Frames.Add(Range:=Selection.Range).LockAnchor = True
With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .ShowObjectAnchors = True
End With


ShowOptionalBreaks-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word displays optional line breaks. Read/write Boolean.


Beispiel zur ShowOptionalBreaks-Eigenschaft

This example displays the optional line breaks in the active window.

ActiveDocument.ActiveWindow.View.ShowOptionalBreaks = True


ShowParagraphs-Eigenschaft

True, wenn Absatzmarken angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowParagraphs-Eigenschaft

In diesem Beispiel werden im aktiven Fenster Absatzmarken ausgeblendet.

ActiveDocument.ActiveWindow.View.ShowParagraphs = False


ShowPicturePlaceHolders-Eigenschaft

True, wenn leere Rahmen als Platzhalter für Grafiken angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowPicturePlaceHolders-Eigenschaft

In diesem Beispiel wird in das aktive Dokument eine Grafik eingefügt, und im aktiven Fenster werden Platzhalter für Grafiken angezeigt.

Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.InlineShapes.AddPicture Range:=Selection.Range, _
    FileName:="C:\Windows\Bubbles.bmp"
ActiveDocument.ActiveWindow.View.ShowPicturePlaceHolders = True


ShowReadabilityStatistics-Eigenschaft

True, wenn Word eine zusammenfassende Statistik mit Messungen zur Lesbarkeit nach Beendigung der Grammatikprüfung anzeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowReadabilityStatistics-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word die statistischen Angaben zur Lesbarkeit anzeigt und dann die Rechtschreibung und die Grammatik im aktiven Dokument überprüft.

Options.ShowReadabilityStatistics = True
ActiveDocument.CheckGrammar

In diesem Beispiel wird der aktuelle Status der Option Lesbarkeitsstatistik anzeigen auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.ShowReadabilityStatistics


ShowRevisions-Eigenschaft

True, wenn überwachte Änderungen im angegebenen Dokument auf dem Bildschirm angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowRevisions-Eigenschaft

In diesem Beispiel wird festgelegt, dass Änderungen im aktiven Dokument überwacht und auf dem Bildschirm angezeigt werden.

With ActiveDocument
    .TrackRevisions = True
    .ShowRevisions = True
End With


ShowSpaces-Eigenschaft

True, wenn Leerzeichen angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowSpaces-Eigenschaft

In diesem Beispiel werden vor der Markierung Leerzeichen eingefügt und im aktiven Fenster Leerzeichen angezeigt.

Selection.InsertBefore "    "
ActiveDocument.ActiveWindow.View.ShowSpaces = True


ShowSpellingErrors-Eigenschaft

True, wenn Word Rechtschreibfehler im Dokument unterstreicht. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie die Rechtschreibfehler in einem Dokument sehen wollen, müssen Sie die CheckSpellingAsYouType-Eigenschaft auf True setzen.


Beispiel zur ShowSpellingErrors-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es die wellige rote Linie verbirgt, die mögliche Rechtschreibfehler im aktiven Dokument kennzeichnet.

ActiveDocument.ShowSpellingErrors = False

In diesem Beispiel wird Word so eingestellt, dass es Rechtschreibfehler im aktiven Dokument anzeigt.

Options.CheckSpellingAsYouType = True
ActiveDocument.ShowSpellingErrors = True

In diesem Beispiel wird der aktuelle Status der Option Rechtschreibkennzeichnung ausblenden auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = ActiveDocument.ShowSpellingErrors


ShowSummary-Eigenschaft

True, wenn eine automatische Zusammenfassung für das angegebene Dokument angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowSummary-Eigenschaft

Dieses Beispiel blendet alle Elemente des aktiven Dokuments mit Ausnahme des Texts der Zusammenfassung aus.

With ActiveDocument
    .SummaryViewMode = wdSummaryModeHideAllButSummary
    .SummaryLength = 30
    .ShowSummary = True
End With


ShowTabs-Eigenschaft

True, wenn Tabstopzeichen angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowTabs-Eigenschaft

In diesem Beispiel wird vor der Markierung ein Tabstopzeichen eingefügt, und es werden im Fenster für Dokument2 Tabstopzeichen angezeigt.

With Windows("Document2")
    .Activate
    .View.ShowTabs = True
End With
Selection.InsertBefore vbTab
Selection.Collapse Direction:=wdCollapseEnd

In diesem Beispiel wird das aktive Fenster geteilt, werden im ersten Ausschnitt Tabstopzeichen angezeigt und im zweiten Ausschnitt ausgeblendet.

With ActiveDocument.ActiveWindow
    .Split = True
    .Panes(1).View.ShowTabs = True
    .Panes(2).View.ShowTabs = False
End With


ShowTextBoundaries-Eigenschaft

True, wenn in der Seitenlayoutansicht um Seitenränder, Textspalten, Objekte und Rahmen punktierte Linien angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowTextBoundaries-Eigenschaft

In diesem Beispiel wird das aktive Fenster in die Layoutansicht umgeschaltet, und es werden Textbegrenzungslinien angezeigt.

With ActiveDocument.ActiveWindow.View
    .Type = wdPrintView
    .ShowTextBoundaries = True
End With


ShowTip-Eigenschaft

True, wenn zu einem Kommentar gehöriger Text in einem Bildschirmtipp (QuickInfo) angezeigt wird. Der Bildschirmtipp bleibt angezeigt, bis mit der Maus geklickt oder eine Taste gedrückt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowTip-Eigenschaft

In diesem Beispiel wird der Bildschirmtipp für den ersten Kommentar im aktiven Dokument angezeigt.

If ActiveDocument.Comments.Count >= 1 Then
    ActiveDocument.Comments(1).ShowTip = True
End If

In diesem Beispiel wird das Infofeld für den nächsten Kommentar im aktiven Dokument angezeigt.

If ActiveDocument.Comments.Count >= 1 Then
    With Selection
        .GoTo What:=wdGotoComment, Which:=wdGotoNext
        .MoveEnd Unit:=wdWord, Count:=1
        .Comments(1).ShowTip = True
    End With
End If


ShowVisualBasicEditor-Eigenschaft

True, wenn das Fenster des Visual Basic-Editors angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowVisualBasicEditor-Eigenschaft

In diesem Beispiel wird das Fenster des Visual Basic-Editors angezeigt.

Application.ShowVisualBasicEditor = True


Side-Eigenschaft

Gibt einen Wert zurück oder legt einen Wert fest, der angibt, ob der Dokumenttext um beide Seiten der angegebenen Form, nur um die linke oder die rechte Seite der Form oder um die Seite der Form umbrochen wird, die sich am weitesten vom Seitenrand befindet. Wenn der Text nur um eine Seite der Form umbrochen wird, gibt es einen textfreien Bereich zwischen der anderen Seite der Form und dem Seitenrand. Dabei kann es sich um eine der folgenden WdWrapSideType-Konstanten handeln: wdWrapBoth, wdWrapLargest, wdWrapLeft oder wdWrapRight. Long Schreib-Lese-Zugriff.


SideMargin-Eigenschaft

Gibt die Breite des Seitenrands (in Punkt) für das angegebene Adressetikett zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf einen Wert geändert wird, der für das Layout des angegebenen Etiketts nicht gültig ist, tritt ein Fehler auf.


Beispiel zur SideMargin-Eigenschaft

In diesem Beispiel wird ein benutzerdefiniertes Etikett mit der Bezeichnung "BesucherAusweis" erstellt und das Layout festgelegt. Der linke und rechte Rand für alle Etiketten wird auf 1,9 cm festgelegt.

Set myLabel = Application.MailingLabel.CustomLabels _
    .Add(Name:="VisitorPass", DotMatrix:=False)
With myLabel
    .Height = InchesToPoints(2.17)
    .HorizontalPitch = InchesToPoints(3.5)
    .NumberAcross = 2
    .NumberDown = 4
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.75)
    .TopMargin = InchesToPoints(0.17)
    .VerticalPitch = InchesToPoints(2.17)
    .Width = InchesToPoints(3.5)
End With


SingleList-Eigenschaft

True, wenn das angegebene ListFormat-Objekt nur eine Liste enthält. Boolean Nur-Lese-Zugriff.


SingleListTemplate-Eigenschaft

True, wenn das gesamte List- oder ListFormat-Objekt dieselbe Listenvorlage benutzt. Boolean Nur-Lese-Zugriff.


Beispiel zur SingleListTemplate-Eigenschaft

In diesem Beispiel wird überprüft, ob die Auswahl mit einer einzelnen Listenvorlage formatiert ist. Wenn ja, wird die zweite Dokumentvorlage für nummerierte Listen der Auswahl zugewiesen.

Set myList = Selection.Range.ListFormat
temp = myList.SingleListTemplate
If temp = True Then
    myList.ApplyListTemplate _
        ListTemplate:=ListGalleries(wdNumberGallery) _
        .ListTemplates(2)
End If


Size-Eigenschaft

Font-Objekt: Gibt den Schriftgrad in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

CheckBox-Objekt: Gibt die Größe des angegebenen Kontrollkästchens in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


SizeBi-Eigenschaft

Sprachspezifische Informationen

Returns or sets the font size, in points. Read/write Single.

Remarks

The SizeBi property applies to text in a right-to-left language.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur SizeBi-Eigenschaft

This example sets the font size of the first word to 20 points.

With ActiveDocument.Paragraphs(1).Range
    .Words(1).Font.SizeBi = 20
End With


SmallCaps-Eigenschaft

True, wenn die Schriftart als Kapitälchen formatiert ist. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie SmallCaps auf True setzen, wird AllCaps auf False gesetzt und umgekehrt.


Beispiel zur SmallCaps-Eigenschaft

In diesem Beispiel wird der Unterschied zwischen Kapitälchen und Großbuchstaben in einem neuen Dokument demonstriert.

Set myRange = Documents.Add.Content
With myRange
    .InsertAfter "This is a demonstration of SmallCaps."
    .Words(6).Font.SmallCaps = True
    .InsertParagraphAfter
    .InsertAfter "This is a demonstration of AllCaps."
    .Words(14).Font.AllCaps = True
End With

In diesem Beispiel wird die Schriftart der gesamten Auswahl als Kapitälchen formatiert, wenn bereits ein Teil der Auswahl als Kapitälchen formatiert wurde.

If Selection.Type = wdSelectionNormal Then
    mySel = Selection.Font.SmallCaps
    If mySel = wdUndefined Then Selection.Font.SmallCaps = True
Else
    MsgBox "You need to select some text."
End If


SmartCutPaste-Eigenschaft

True, wenn Word die Abstände zwischen Wörtern und Interpunktion automatisch beim Ausschneiden und Einfügen einstellt. Boolean Schreib-Lese-Zugriff.


Beispiel zur SmartCutPaste-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass die Abstände zwischen Wörtern und Interpunktion beim Ausschneiden und Einfügen automatisch eingestellt werden, dann wird Text ausgeschnitten und in einem neu angelegtem Dokument eingefügt. Wäre die SmartCutPaste-Eigenschaft False, dann würde das zweite und dritte Wort ineinanderlaufen.

Options.SmartCutPaste = True
Set myDoc = Documents.Add
With myDoc
    .Content.InsertAfter("The brown quick fox")
    .Words(2).Cut
    .Characters(10).Paste
End With

In diesem Beispiel wird der Status der Option Ausschneiden und Einfügen mit Leerzeichenausgleich auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.SmartCutPaste


SnapToGrid-Eigenschaft

Document-Objekt: True, wenn AutoFormen oder ostasiatische Zeichen im angegebenen Dokument beim Zeichnen, Verschieben oder Ändern der Größe automatisch an einem unsichtbaren Gitter ausgerichtet werden. Boolean Schreib-Lese-Zugriff.

Options-Objekt: True, wenn AutoFormen oder ostasiatische Zeichen in neuen Dokumenten beim Zeichnen, Verschieben oder Ändern der Größe automatisch an einem unsichtbaren Gitter ausgerichtet werden. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Einstellung wird vorübergehend überschrieben, wenn Sie beim Zeichnen, Verschieben oder Ändern der Größe einer AutoForm die ALT-Taste drücken.


Beispiel zur SnapToGrid-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word ostasiatische Zeichen im aktuellen Dokument automatisch an einem unsichtbaren Gitter ausrichtet.

ActiveDocument.SnapToGrid = True

In diesem Beispiel wird festgelegt, dass Word AutoFormen in einem neuen Dokument automatisch an einem unsichtbaren Gitter ausrichtet.

Options.SnapToGrid = True
Documents.Add

In diesem Beispiel wird der Status der Option Am Raster ausrichten im Dialogfeld Am Raster ausrichten (Symbolleiste Zeichnen, Menü Zeichnen, Befehl Gitternetz) zurückgegeben.

Temp = Options.SnapToGrid


SnapToShapes-Eigenschaft

Document-Objekt: True, wenn Microsoft Word AutoFormen oder ostasiatische Zeichen automatisch an unsichtbaren Gitternetzlinien ausrichtet, die durch die vertikalen und horizontalen Ränder anderer AutoFormen oder ostasiatischer Zeichen in dem angegebenen Dokument verlaufen. Boolean Schreib-Lese-Zugriff.

Options-Objekt: True, wenn Word AutoFormen oder ostasiatische Zeichen automatisch an unsichtbaren Gitternetzlinien ausrichtet, die durch die vertikalen und horizontalen Ränder anderer AutoFormen oder ostasiatischer Zeichen in neuen Dokumenten verlaufen. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft erzeugt zusätzliche unsichtbare Gitternetzlininen für alle AutoFormen. Die SnapToShapes-Eigenschaft arbeitet unabhängig von der SnapToGrid-Eigenschaft.


Beispiel zur SnapToShapes-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word ostasiatische Zeichen automatisch an unsichtbaren Gitternetzlinien ausrichtet, die durch die horizontalen und vertikalen Ränder anderer ostasiatischer Zeichen im aktuellen Dokument verlaufen.

ActiveDocument.SnapToShapes = True

In diesem Beispiel wird festgelegt, dass Word AutoFormen automatisch an unsichtbaren Gitternetzlinien ausrichtet, die durch die horizontalen und vertikalen Ränder anderer AutoFormen in einem neuen Dokument verlaufen.

Options.SnapToShapes = True
Documents.Add

In diesem Beispiel wird der Status der Option An Formen ausrichten im Dialogfeld Am Raster ausrichten (Zeichnen-Symbolleiste, Menü Zeichnen, Befehl Gitternetz) zurückgegeben.

Temp = Options.SnapToShapes


SortBy-Eigenschaft

Sprachspezifische Informationen

Returns or sets the sorting criteria for the specified index. Can be either of the following WdIndexSortBy constants: wdIndexSortByStroke (sort by the number of strokes in a character) or wdIndexSortBySyllable (sort phonetically). Read/write Long.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur SortBy-Eigenschaft

This example sets the first index in the current document to sort by the number of strokes.

ActiveDocument.Indexes(1).SortBy = _
    wdIndexSortByStroke


SourceFullName-Eigenschaft

Gibt den Namen und Pfad der Quelldatei für das angegebene verknüpfte OLE-Objekt, die Grafik bzw. das Feld zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweise

Die Verwendung dieser Eigenschaft ist gleichwertig mit der aneinander anschließenden Verwendung der Eigenschaften SourcePath, PathSeparator und SourceName.


Beispiel zur SourceFullName-Eigenschaft

In diesem Beispiel wird im aktiven Dokument für Form 1 "MeinExcel.xls" als Quelldatei festgelegt, und es wird angegeben, dass das OLE-Objekt automatisch aktualisiert werden soll.

With ActiveDocument.Shapes(1)
    If .Type = msoLinkedOLEObject Then
        With .LinkFormat
            .SourceFullName = "c:\my documents\myExcel.xls"
            .AutoUpdate = True
        End With
    End If
End With


SourceName-Eigenschaft

Gibt den Namen der Quelldatei für das angegebene verknüpfte OLE-Objekt, die Grafik oder das Feld zurück. String Nur-Lese-Zugriff.

Hinweis Diese Eigenschaft gibt nicht den Pfad für die Quelldatei zurück.


Beispiel zur SourceName-Eigenschaft

In diesem Beispiel werden im aktiven Dokument der Pfad und Name der Quelldatei für alle Formen zurückgegeben, die verknüpfte OLE-Objekte sind.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        Msgbox s.LinkFormat.SourcePath & "\" _
            & s.LinkFormat.SourceName
    End If
Next s


SourcePath-Eigenschaft

Gibt den Pfad der Quelldatei für das angegebene verknüpfte OLE-Objekt, die Grafik oder das Feld zurück. String Nur-Lese-Zugriff.

Anmerkung Der Pfad enthält kein nachstehendes Zeichen (beispielsweise "C:\MSOffice"). Mit der PathSeparator-Eigenschaft können Sie das Zeichen hinzufügen, das Ordner und Laufwerksbuchstaben trennt. Mit der SourceName-Eigenschaft geben Sie den Dateinamen ohne den Pfad zurück, und mit der SourceFullName-Eigenschaft können Sie Dateinamen und Pfad gemeinsam zurückgeben.


Beispiel zur SourcePath-Eigenschaft

In diesem Beispiel werden im aktiven Dokument der Pfad und Name der Quelldatei für alle Formen zurückgegeben, die verknüpfte OLE-Objekte sind.

For Each s In ActiveDocument.Shapes
    If s.Type = msoLinkedOLEObject Then
        Msgbox s.LinkFormat.SourcePath & "\" _
            & s.LinkFormat.SourceName
    End If
Next s


SpaceAfter-Eigenschaft

Gibt den Abstand (in Punkt) nach dem angegebenen Absatz oder der Textspalte zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


SpaceAfterAuto-Eigenschaft

True, wenn der Abstand nach den angegebenen Absätzen von Microsoft Word automatisch eingesetzt wird. Gibt wdUndefined zurück, wenn die SpaceAfterAuto-Eigenschaft nur für manche der angegebenen Absätze auf True gesetzt ist. Kann auf True oder False gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie ein HTML-Dokument ohne Cascading Style Sheets öffnen, wird die SpaceAfterAuto-Eigenschaft von Word automatisch auf True gesetzt, so dass die Abstände zwischen den Absätzen genauso dargestellt werden, wie sie in einem Webbrowser aussehen würde.

Wenn SpaceAfterAuto auf True gesetzt wird, wird die SpaceAfter-Eigenschaft ignoriert.


Beispiel zur SpaceAfterAuto-Eigenschaft

In diesem Beispiel werden die SpaceAfterAuto-Einstellungen für das aktive Dokument dargestellt.

Select Case ActiveDocument.Paragraphs.SpaceAfterAuto
    Case True
        x = "Spacing after paragraphs is handled " _
            & "automatically for all paragraphs."
    Case False
        x = "Spacing after paragraphs is handled " _
            & "manually for all paragraphs."
    Case wdUndefined
        x = "Spacing after paragraphs is handled " _
            & "automatically for some paragraphs, " _
            & "manually for some paragraphs."
End Select


SpaceBefore-Eigenschaft

Gibt den Leerraum (in Punkt) vor den angegebenen Absätzen zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


SpaceBeforeAuto-Eigenschaft

True, wenn der Abstand vor den angegebenen Absätzen von Microsoft Word automatisch festgelegt wird. Gibt wdUndefined zurück, wenn die SpaceBeforeAuto-Eigenschaft nur für manche der angegebenen Absätze auf True gesetzt ist. Kann auf True oder False gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie ein HTML-Dokument ohne Cascading Style Sheets öffnen, wird die SpaceBeforeAuto-Eigenschaft von Word automatisch auf True gesetzt, so dass die Abstände zwischen den Absätzen genauso dargestellt werden, wie sie in einem Webbrowser aussehen würde.

Wenn SpaceBeforeAuto auf True gesetzt ist, wird die SpaceBefore-Eigenschaft ignoriert.


Beispiel zur SpaceBeforeAuto-Eigenschaft

In diesem Beispiel werden die SpaceBeforeAuto-Einstellungen für das aktive Dokument dargestellt.

Select Case ActiveDocument.Paragraphs.SpaceBeforeAuto
    Case True
        x = "Spacing before paragraphs is handled " _
            & "automatically for all paragraphs."
    Case False
        x = "Spacing before paragraphs is handled " _
            & "manually for all paragraphs."
    Case wdUndefined
        x = "Spacing before paragraphs is handled " _
            & "automatically for some paragraphs, " _
            & "manually for some paragraphs."
End Select


SpaceBetweenColumns-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem Text in benachbarten Spalten der angegebenen Zeile oder Zeilen zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur SpaceBetweenColumns-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt und dann in der ersten Zeile der Abstand zwischen Spalten auf 0,5 Zoll eingestellt.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
myTable.Rows(1).SpaceBetweenColumns = InchesToPoints(0.5)

In diesem Beispiel wird der Abstand (in Punkt) zwischen Spalten in den markierten Tabellenzeilen zurückgegeben.

If Selection.Information(wdWithInTable) = True Then
    MsgBox Selection.Rows.SpaceBetweenColumns
End If


Spacing-Eigenschaft

Font-Objekt: Gibt den Zeichenabstand in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Table-Objekt: Gibt den Abstand zwischen den Zellen einer Tabelle in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

TextColumns-Objekt: Gibt den Spaltenabstand in Punkt in einer Auflistung zurück oder legt ihn fest. Wenn Sie diese Eigenschaft gesetzt haben, ist die EvenlySpaced-Eigenschaft True. Single Schreib-Lese-Zugriff.

Hinweis Um den Abstand für eine Textspalte zurückzugeben oder zu setzen, wenn EvenlySpaced auf False gesetzt ist, verwenden Sie die SpaceAfter-Eigenschaft des TextColumn-Objekts.


Beispiel zur Spacing-Eigenschaft

In diesem Beispiel werden zwei verschiedene Zeichenabstände zu Beginn des aktiven Dokuments demonstriert.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
With myRange
    .InsertAfter "Demonstration of no character spacing. "
    .InsertParagraphAfter
    .InsertAfter "Demonstration of character spacing (1.5pt)."
    .InsertParagraphAfter
End With
ActiveDocument.Paragraphs(2).Range.Font.Spacing = 1.5

In diesem Beispiel wird der Zeichenabstand für den markierten Text auf 2 Punkt gesetzt.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Spacing = 2
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird der Abstand zwischen den Zellen in der ersten Tabelle des aktiven Dokuments auf 9 Punkt gesetzt.

ActiveDocument.Tables(1).Spacing = 9

In diesem Beispiel wird das aktive Dokument so formatiert, dass zwei Spalten mit einem Spaltenabstand von 1,27 cm (36 Punkt) dargestellt werden.

With ActiveDocument.PageSetup.TextColumns
    .SetCount NumColumns:=2
    .LineBetween = False
    .EvenlySpaced = True
    .Spacing = 36
End With


SpecialMode-Eigenschaft

True, wenn sich Word in einem Spezialmodus befindet (z. B. TextKopieren-Modus oder TextVerschieben-Modus).Boolean Nur-Lese-Zugriff.

Anmerkungen

Word wechselt in einen speziellen Kopier- oder Verschieben-Modus, wenn Sie F2 oder UMSCHALT+F2 bei der Textauswahl drücken.


Beispiel zur SpecialMode-Eigenschaft

In diesem Beispiel wird überprüft, ob sich Word in einem Spezialmodus befindet. Falls ja, wird ESC aktiviert, bevor die aktuelle Auswahl ausgeschnitten und eingefügt wird.

If Application.SpecialMode = True Then SendKeys "ESC"
With Selection
    .Cut
    .EndKey Unit:=wdStory
    .Paste
End With


SpellingChecked-Eigenschaft

True, wenn die Rechtschreibung des angegebenen Bereichs oder Dokuments überprüft wurde. False, wenn die Rechtschreibung des Bereichs oder Dokuments ganz oder teilweise nicht überprüft wurde. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Um die Rechtschreibung eines Bereichs oder Dokuments erneut zu überprüfen, setzen Sie die SpellingChecked-Eigenschaft auf False.

Mit der SpellingErrors-Eigenschaft zeigen Sie an, ob der Bereich oder das Dokument Rechtschreibfehler enthält.


Beispiel zur SpellingChecked-Eigenschaft

In diesem Beispiel wird ermittelt, ob die Rechtschreibung in Abschnitt 1 des aktiven Dokuments überprüft wurde. Wurde die Rechtschreibung nicht überprüft, startet dieses Beispiel die Rechtschreibprüfung.

Set myRange = ActiveDocument.Sections(1).Range
isChecked = myRange.SpellingChecked
If isChecked = False Then
    myRange.CheckSpelling
Else
    MsgBox "The range has already been spell checked."
End If

In diesem Beispiel wird die SpellingChecked-Eigenschaft für MyDocument.doc auf False gesetzt und die Rechtschreibprüfung für das Dokument erneut aufgerufen.

Documents("MyDocument.doc").SpellingChecked = False
Documents("MyDocument.doc").CheckSpelling IgnoreUppercase:=False


SpellingDictionaryType-Eigenschaft

Gibt den Typ der Editierhilfen zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden WdDictionaryType-Konstanten handeln: wdGrammar, wdHangulHanjaConversion, wdHangulHanjaConversionCustom, wdHyphenation, wdSpelling, wdSpellingComplete, wdSpellingCustom, wdSpellingLegal, wdSpellingMedical oder wdThesaurus. Long Schreib-Lese-Zugriff.

Hinweise

Mit dieser Eigenschaft können Sie das aktive Wörterbuch zur Rechtschreibprüfung ändern und eines der verfügbaren Erweiterungswörterbücher festlegen, die mit Word zusammenarbeiten. Anstelle des Standardwörterbuchs können Sie z. B. juristische, medizinische oder vollständige Wörterbücher verwenden.

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt von der ausgewählten oder installierten Sprachunterstützung ab (z. B. Deutsch).


Beispiel zur SpellingDictionaryType-Eigenschaft

In diesem Beispiel wird der Typ des Wörterbuchs zur Rechtschreibprüfung für Deutsch zurückgegeben.

myType = Languages(wdEnglishUS).SpellingDictionaryType

Das Beispiel aktiviert ein juristisches Wörterbuch zur Rechtschreibprüfung.

Languages(wdEnglishUS).SpellingDictionaryType = wdSpellingLegal


SpellingErrors-Eigenschaft

Gibt eine ProofreadingErrors-Sammlung zurück, die die Wörter im angegebenen Dokument oder Bereich darstellt, die als Fehler erkannt wurden. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung


Beispiel zur SpellingErrors-Eigenschaft

In diesem Beispiel wird die Rechtschreibung des aktiven Dokuments überprüft und die Anzahl der gefundenen Fehler angezeigt.

myErr = ActiveDocument.SpellingErrors.Count
If myErr = 0 Then
    Msgbox "No spelling errors found."
Else
    Msgbox myErr & " spelling errors found."
End If

In diesem Beispiel wird die Rechtschreibung im angegebenen Bereich überprüft und alle gefundenen Fehler angezeigt.

Set myErrors = ActiveDocument.Paragraphs(3).Range.SpellingErrors
If myErrors.Count = 0 Then
    Msgbox "No spelling errors found."
Else
    For Each myErr in myErrors
        Msgbox myErr.Text
    Next
End If


SpellingErrorType-Eigenschaft

Gibt die Art des Rechtschreibfehlers zurück. Dies kann eine der folgenden WdSpellingErrorType-Konstanten sein: wdSpellingCapitalization, wdSpellingCorrect oder wdSpellingNotInDictionary. Long Nur-Lese-Zugriff.

Hinweis Verwenden Sie die GetSpellingSuggestions-Methode zur Zurückgabe einer Auflistung von Wörtern, die als orthographisch richtiger Ersatz vorgeschlagen werden. Wenn ein Wort falsch geschrieben ist, gibt die CheckSpelling-Methode True zurück.


Beispiel zur SpellingErrorType-Eigenschaft

Wenn das erste Wort im aktiven Dokument nicht im Wörterbuch ist, wird in diesem Beispiel in der Statusleiste "Unbekanntes Wort" angezeigt.

Set suggs = ActiveDocument.Content.GetSpellingSuggestions
If suggs.SpellingErrorType = wdSpellingNotInDictionary Then
    StatusBar = "Unknown word"
End If


Split-Eigenschaft

True, wenn das Fenster in mehrere Ausschnitte geteilt ist. Boolean Schreib-Lese-Zugriff.


SplitSpecial-Eigenschaft

Gibt den aktiven Fensterausschnitt zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden WdSpecialPane-Konstanten sein:

wdPaneComments

wdCurrentPageFooter

wdPaneCurrentPageHeader

wdPaneEndnoteContinuationNotice

wdPaneEndnoteContinuationSeparator

wdPaneEndnotes

wdPaneEndnoteSeparator

wdPaneEvenPagesFooter

wdPaneEvenPagesHeader

 wdPaneFirstPageFooter

wdPaneFirstPageHeader

wdPaneFootnoteContinuationNotice

wdPaneFootnoteContinuationSeparator

wdPaneFootnotes

wdPaneFootnoteSeparator

wdPaneNone

wdPanePrimaryFooter

wdPanePrimaryHeader


Beispiel zur SplitSpecial-Eigenschaft

In diesem Beispiel wird im aktiven Fenster die primäre Fußzeile in einem separaten Ausschnitt angezeigt.

ActiveDocument.ActiveWindow.View.SplitSpecial = wdPanePrimaryFooter

In diesem Beispiel wird dem aktiven Dokument eine Fußnote hinzugefügt, und es werden im aktiven Fenster in einem separaten Ausschnitt alle Fußnoten angezeigt.

ActiveDocument.Footnotes.Add Range:=Selection.Range, _
    Text:="Footnote text"
With ActiveDocument.ActiveWindow.View
    .Type = wdNormalView
    .SplitSpecial = wdPaneFootnotes
End With


SplitVertical-Eigenschaft

Gibt den vertikalen Teilungs-Prozentwert für das angegebene Fenster zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Hinweis Zum Aufheben der Teilung stellen Sie diese Eigenschaft auf 0 (Null) ein oder die Split-Eigenschaft auf False.


Beispiel zur SplitVertical-Eigenschaft

In diesem Beispiel wird das aktive Fenster so geteilt, dass der obere Ausschnitt 70 Prozent des Fensters belegt.

ActiveDocument.ActiveWindow.SplitVertical = 70

In diesem Beispiel wird das Fenster für Dokument1 vertikal in zwei Hälften geteilt.

Windows("Document1").SplitVertical = 50


Start-Eigenschaft

Gibt die Anfangszeichenposition einer Markierung, eines Bereichs oder einer Textmarke zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkung Wenn diese Eigenschaft auf einen Wert eingestellt wird, der größer ist als der der End-Eigenschaft, wird die End-Eigenschaft auf denselben Wert eingestellt wie die Start-Eigenschaft.

Hinweise

Selection-, Range- und Bookmark-Objekte haben Anfangs- und Endzeichenpositionen. Die Anfangsposition bezieht sich auf die Zeichenposition, die dem Anfang der Dokumentkomponente am nächsten ist.

Diese Eigenschaft gibt die Anfangszeichenposition relativ zum Anfang der Dokumentkomponente zurück. Die Hauptdokumentkomponente (wdMainTextStory) fängt mit der Zeichenposition 0 (Null) an. Sie können die Größe einer Markierung, eines Bereichs oder einer Textmarke ändern, indem Sie diese Eigenschaft einstellen.


StartAt-Eigenschaft

Gibt die Startnummer für das angegebene ListLevel-Objekt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur StartAt-Eigenschaft

In diesem Beispiel werden das Zahlenformat und die Startnummer der dritten Listenvorlage für Gliederungen festgelegt. Da die Formatvorlage Großbuchstaben verwendet und die Startnummer 4 lautet, ist der erste Buchstabe "D".

Set mylev = ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(3).ListLevels(1)
With mylev
    .NumberStyle = wdListNumberStyleUppercaseLetter
    .StartAt = 4
End With


StartingNumber-Eigenschaft

Gibt die Start-Anmerkungsnummer, -Zeilennummer oder -Seitennummer zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Hinweise

Sie müssen in der Seitenlayoutansicht sein, wenn Sie die Zeilennummerierung sehen wollen.

Wenn diese Eigenschaft auf Seitenzahlen angewandt wird, gibt sie die Anfangsseitennummer für das angegebene HeaderFooter-Objekt zurück oder legt sie fest. Diese Nummer kann auf der ersten Seite erscheinen oder fehlen, in Abhängigkeit von der Einstellung der ShowFirstPageNumber-Eigenschaft. Ist die RestartNumberingAtSection-Eigenschaft auf False eingestellt, dann wird die StartingNumber-Eigenschaft außer Kraft gesetzt, so dass die Seitennummerierung vom vorherigen Abschnitt fortgesetzt werden kann.


Beispiel zur StartingNumber-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt und die Anfangsnummer für Fußnoten auf 10 gesetzt. Anschließend wird an der Einfügemarke eine Fußnote hinzugefügt.

Set myDoc =Documents.Add
With myDoc.Footnotes
    .StartingNumber = 10
    .Add Range:=Selection.Range, Text:="Text for a footnote"
End With

In diesem Beispiel wird für das aktive Dokument die Zeilennummerierung eingeschaltet. Die Anfangsnummer wird auf 5 festgelegt, jede fünfte Zeilennummer wird angezeigt, und am Anfang jedes Abschnitts im Dokument beginnt die Nummerierung von vorn.

With ActiveDocument.PageSetup.LineNumbering
    .Active = True
    .StartingNumber = 5
    .CountBy = 5
    .RestartMode = wdRestartSection
End With

In diesem Beispiel werden Eigenschaften für Seitennummern festgelegt. Anschließend werden der Kopfzeile des aktiven Dokuments Seitennummern hinzugefügt.

With ActiveDocument.Sections(1) _
        .Headers(wdHeaderFooterPrimary).PageNumbers
    .NumberStyle = wdPageNumberStyleArabic
    .IncludeChapterNumber = False
    .RestartNumberingAtSection = True
    .StartingNumber = 5
    .Add PageNumberAlignment:=wdAlignPageNumberCenter, _
        FirstPage:=True
End With


StartIsActive-Eigenschaft

True, wenn der Anfang der Markierung aktiv ist. Das aktive Ende der Markierung wird verschoben, wenn Sie UMSCHALT+ eine Pfeiltaste drücken. Boolean Schreib-Lese-Zugriff.


Beispiel zur StartIsActive-Eigenschaft

In diesem Beispiel wird das erste Wort im aktiven Dokument markiert. Das Meldungsfeld zeigt "False" an, weil das Ende der Markierung aktiv ist.

ActiveDocument.Words(1).Select
MsgBox Selection.StartIsActive

In diesem Beispiel wird die Markierung reduziert und das vorherige Wort markiert. Das Meldungsfeld zeigt "True" an, weil der Anfang der Markierung aktiv ist.

Selection.Collapse Direction:=wdCollapseStart
Selection.MoveLeft Unit:=wdWord, Extend:=wdExtend
MsgBox Selection.StartIsActive


StartupPath-Eigenschaft

Gibt den vollständigen Pfad des Startordners zurück oder legt ihn fest, wobei das letzte Trennzeichen ausgeschlossen wird. String Schreib-Lese-Zugriff.

Hinweis Die Vorlagen und Add-Ins, die sich im Startordner befinden, werden beim Starten von Word automatisch geladen.


Beispiel zur StartupPath-Eigenschaft

In diesem Beispiel wird der vollständige Pfad des Startordners angezeigt.

MsgBox Application.StartupPath

Dieses Beispiel ermöglicht es dem Benutzer, den Pfad des Startordners zu ändern.

x = MsgBox("Do you want to change the startup path?", vbYesNo, _
    "Current path = " & Application.StartupPath)
If x = vbYes Then
    newStartup = InputBox("Type a startup path")
    Application.StartupPath = newStartup
End If


State-Eigenschaft

Gibt den aktuellen Status einer Seriendruck-Operation zurück. Dabei kann es sich um die folgenden WdMailMergeState-Konstanten handeln: wdNormalDocument, wdMainDocumentOnly, wdMainAndDataSource, wdMainAndHeader, wdMainAndSourceAndHeader oder wdDataSource. Long Nur-Lese-Zugriff.


Beispiel zur State-Eigenschaft

In diesem Beispiel wird ein Seriendruck ausgeführt, wenn es sich beim aktiven Dokument um ein Hauptdokument mit einer verbundenen Datenquelle handelt.

Set myMerge = ActiveDocument.MailMerge
If myMerge.State = wdMainAndDataSource Then myMerge.Execute


Status-Eigenschaft

Gibt den Status der Verteilung für die angegebene Verteilerliste zurück. Dabei kann es sich um eine der folgenden WdRoutingSlipStatus-Konstanten handeln: wdNotYetRouted, wdRouteComplete oder wdRouteInProgress. Long Nur-Lese-Zugriff.


StatusBar-Eigenschaft

Zeigt den angegebenen Text in der Statusleiste an. String Nur-Schreib-Zugriff.


Beispiel zur StatusBar-Eigenschaft

In diesem Beispiel wird eine Meldung in der Statusleiste angezeigt.

StatusBar = "Please wait..."

In diesem Beispiel wird in der Statusleiste der Name der Vorlage angezeigt, die mit dem aktiven Dokument verbunden ist.

aName = ActiveDocument.AttachedTemplate.Name
StatusBar = aName & " template is attached to the active document"


StatusText-Eigenschaft

Gibt den Text zurück oder legt ihn fest, der in der Statusleiste erscheint, wenn ein Formularfeld den Fokus hat. Wenn die OwnStatus-Eigenschaft auf True gesetzt ist, dann spezifiziert StatusText den Text der Statusleiste. Wenn die OwnStatus-Eigenschaft auf False gesetzt ist, dann spezifiziert StatusText den Namen eines AutoText-Eintrags mit dem Statusleisten-Text für das Formularfeld. String Schreib-Lese-Zugriff.


Beispiel zur StatusText-Eigenschaft

In diesem Beispiel wird der Statusleisten-Hilfetext für das Formularfeld "Alter" zugewiesen.

With ActiveDocument.FormFields("Age")
    .OwnStatus = True
    .StatusText = "Type your current age."
End With


 StoryLength-Eigenschaft

StoryLength-Eigenschaft

Gibt die Anzahl der Zeichen in der Dokumentkomponente zurück, die den angegebenen Bereich oder die angegebene Auswahl enthält. Long Nur-Lese-Zugriff.


Beispiel zur StoryLength-Eigenschaft

In diesem Beispiel wird ermittelt, ob die Kopfzeile im aktiven Dokument leer ist. Wenn die Kopfzeilenkomponente nicht leer ist, wird in einem Meldungsfeld der Inhalt der Kopfzeile angezeigt. Wenn die Dokumentkopfzeile leer ist, gibt StoryLength 1 für die abschließende Absatzmarke zurück.

Set myRange = ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary).Range
If myRange.StoryLength > 1 Then MsgBox myRange.Text

In diesem Beispiel wird das Dokument, wenn es leer ist, geschlossen, ohne Änderungen zu speichern.

If ActiveDocument.Content.StoryLength = 1 Then _
    ActiveDocument.Close SaveChanges:=wdDoNotSaveChanges


StoryRanges-Eigenschaft

Gibt eine StoryRanges-Auflistung zurück, die alle Dokumentkomponenten im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur StoryRanges-Eigenschaft

Dieses Beispiel überprüft die StoryRanges-Auflistung, um festzustellen, ob wdPrimaryFooterStory Teil der StoryRanges-Auflistung ist.

For Each aStory In ActiveDocument.StoryRanges
    If aStory.StoryType = wdEvenPagesFooterStory Then
        MsgBox "Document includes an even page footer"
    End If
Next aStory

In diesem Beispiel wird die primäre Kopfzeilenkomponente mit Text versehen. Dann wird der Text angezeigt.

ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary).Range _
    .Text = "Header text"
MsgBox ActiveDocument.StoryRanges(wdPrimaryHeaderStory).Text


 StoryType-Eigenschaft

StoryType-Eigenschaft

Gibt die Art des Artikels für den angegebenen Bereich, die angegebene Markierung oder Textmarke zurück. Kann eine der folgenden WdStoryType-Konstanten sein: wdCommentsStory, wdEndnotesStory, wdEvenPagesFooterStory, wdEvenPagesHeaderStory, wdFirstPageFooterStory, wdFirstPageHeaderStory, wdFootnotesStory, wdMainTextStory, wdPrimaryFooterStory, wdPrimaryHeaderStory oder wdTextFrameStory. Long Nur-Lese-Zugriff.


Beispiel zur StoryType-Eigenschaft

In diesem Beispiel wird die Dokumentkomponentenart der Auswahl zurückgegeben.

story = Selection.StoryType

In diesem Beispiel wird der Fußnotenausschnitt geschlossen, wenn die Auswahl in der Fußnotenkomponente enthalten ist.

ActiveDocument.ActiveWindow.View.Type = wdNormalView
If Selection.StoryType = wdFootnotesStory Then _
    ActiveDocument.ActiveWindow.ActivePane.Close

In diesem Beispiel wird die Textmarke "temp" markiert, wenn die Textmarke in der Hauptdokumentkomponente des aktiven Dokuments enthalten ist.

If ActiveDocument.Bookmarks.Exists("temp") = True Then
    Set myBookmark = ActiveDocument.Bookmarks("temp")
    If myBookmark.StoryType = wdMainTextStory _
        Then myBookmark.Select
End If


StrictFinalYaa-Eigenschaft

Sprachspezifische Informationen

True if the spelling checker uses spelling rules regarding Arabic words ending with the letter yaa. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur StrictFinalYaa-Eigenschaft

This example sets the spelling checker to use spelling rules regarding Arabic words ending with the letter yaa.

Options.StrictFinalYaa = True


StrictInitialAlefHamza-Eigenschaft

Sprachspezifische Informationen

True if the spelling checker uses spelling rules regarding Arabic words beginning with an alef hamza. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur StrictInitialAlefHamza-Eigenschaft

This example sets the spelling checker to use spelling rules regarding Arabic words beginning with an alef hamza.

Options.StrictInitialAlefHamza = True


StrikeThrough-Eigenschaft

True, wenn die Schriftart durchgestrichen formatiert ist. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Hinweis Um die Formatierung Doppelt durchgestrichen zu setzen oder zurückzugeben, verwenden Sie die DoubleStrikeThrough-Eigenschaft.


Beispiel zur StrikeThrough-Eigenschaft

In diesem Beispiel wird die Formatierung Durchgestrichen den ersten drei Wörter im aktiven Dokument zugewiesen.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Words(1).Start, _
    End:=myDoc.Words(3).End)
myRange.Font.StrikeThrough = True

In diesem Beispiel wird die Formatierung Durchgestrichen dem gewählten Text zugewiesen.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.StrikeThrough = True
Else
    MsgBox "You need to select some text."
End If


Style-Eigenschaft

EmailAuthor-Objekt: Gibt ein Style-Objekt zurück, das der Formatvorlage entspricht, die dem aktuellen Verfasser von nicht gesendeten Antworten, Weiterleitungen oder neuen E-Mail-Nachrichten zugeordnet ist. Variant Nur-Lese-Zugriff.

Alle anderen Objekte: Gibt die Formatvorlage für das angegebene Objekt zurück oder legt sie fest. Um diese Eigenschaft festzulegen, muss entweder der lokale Name der Formatvorlage, eine Ganzzahl, eine WdBuiltinStyle-Konstante (siehe unter "Hinweise") oder ein Objekt angegeben werden, das der Formatvorlage entspricht. Variant Schreib-Lese-Zugriff.

Hinweise

Wenn Sie die Formatvorlage für einen Bereich zurückgeben, der mehr als eine Formatvorlage enthält, wird nur die Formatvorlage für das erste Zeichen oder den ersten Absatz zurückgegeben.

Bei der Style-Eigenschaft kann es sich um eine der folgenden WdBuiltinStyle-Konstanten handeln:

wdStyleBlockQuotation

wdStyleBodyText

wdStyleBodyText2

wdStyleBodyText3

wdStyleBodyTextFirstIndent

wdStyleBodyTextFirstIndent2

wdStyleBodyTextIndent

wdStyleBodyTextIndent2

wdStyleBodyTextIndent3

wdStyleCaption

wdStyleClosing

wdStyleCommentReference

wdStyleCommentText

wdStyleDate

wdStyleDefaultParagraphFont

wdStyleEmphasis

wdStyleEndnoteReference

wdStyleEndnoteText

wdStyleEnvelopeAddress

wdStyleEnvelopeReturn

wdStyleFooter

wdStyleFootnoteReference

wdStyleFootnoteText

wdStyleHeader

wdStyleHeading1

wdStyleHeading2

wdStyleHeading3

wdStyleHeading4

wdStyleHeading5

wdStyleHeading6

wdStyleHeading7

wdStyleHeading8

wdStyleHeading9

wdStyleHtmlAcronym

wdStyleHtmlAddress

wdStyleHtmlCite

wdStyleHtmlCode

wdStyleHtmlDfn

wdStyleHtmlKbd

wdStyleHtmlNormal

wdStyleHtmlPre

wdStyleHtmlSamp

wdStyleHtmlTt

wdStyleHtmlVar

wdStyleHyperlink

wdStyleHyperlinkFollowed

wdStyleIndex1

wdStyleIndex2

wdStyleIndex3

wdStyleIndex4

wdStyleIndex5

 wdStyleIndex6

wdStyleIndex7

wdStyleIndex8

wdStyleIndex9

wdStyleIndexHeading

wdStyleLineNumber

wdStyleList

wdStyleList2

wdStyleList3

wdStyleList4

wdStyleList5

wdStyleListBullet

wdStyleListBullet2

wdStyleListBullet3

wdStyleListBullet4

wdStyleListBullet5

wdStyleListContinue

wdStyleListContinue2

wdStyleListContinue3

wdStyleListContinue4

wdStyleListContinue5

wdStyleListNumber

wdStyleListNumber2

wdStyleListNumber3

wdStyleListNumber4

wdStyleListNumber5

wdStyleMacroText

wdStyleMessageHeader

wdStyleNavPane

wdStyleNormal

wdStyleNormalIndent

wdStyleNoteHeading

wdStylePageNumber

wdStylePlainText

wdStyleSalutation

wdStyleSignature

wdStyleStrong

wdStyleSubtitle

wdStyleTableOfAuthorities

wdStyleTableOfFigures

wdStyleTitle

wdStyleTOAHeading

wdStyleTOC1

wdStyleTOC2

wdStyleTOC3

wdStyleTOC4

wdStyleTOC5

wdStyleTOC6

wdStyleTOC7

wdStyleTOC8

wdStyleTOC9


StyleAreaWidth-Eigenschaft

Gibt die Breite der Formatvorlagenanzeige in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.

Anmerkung Wenn die StyleAreaWidth-Eigenschaft größer als 0 (Null) ist, werden links vom Text die Namen der Formatvorlagen angezeigt. Die Formatvorlagenanzeige ist in der Seitenlayoutansicht und der Weblayoutansicht nicht sichtbar.


Beispiel zur StyleAreaWidth-Eigenschaft

In diesem Beispiel wird das aktive Fenster in Normalansicht umgeschaltet und die Breite der Formatvorlagenanzeige auf 1 Zoll eingestellt.

With ActiveDocument.ActiveWindow
    .View.Type = wdNormalView
    .StyleAreaWidth = InchesToPoints(1)
End With


StyleName-Eigenschaft

Gibt den Namen der Formatvorlage zurück, die dem angegebenen AutoText-Eintrag zugewiesen wurde. String Nur-Lese-Zugriff.


Beispiel zur StyleName-Eigenschaft

In diesem Beispiel wird ein AutoText-Eintrag erstellt und anschließend der Formatvorlagen-Name des Eintrags angezeigt.

Set myentry = NormalTemplate.AutoTextEntries.Add(Name:="rsvp", _
    Range:=Selection.Range)
MsgBox myentry.StyleName


Styles-Eigenschaft

Gibt eine Styles-Auflistung für das angegebene Dokument zurück. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Styles-Eigenschaft

In diesem Beispiel wird die Formatvorlage Überschrift 1 auf jeden Absatz im aktiven Dokument angewandt, der mit dem Wort "Kapitel" beginnt.

For Each para In ActiveDocument.Paragraphs
    If para.Range.Words(1).Text = "Chapter " Then
        para.Style = ActiveDocument.Styles(wdStyleHeading1)
    End If
Next para

In diesem Beispiel wird die Dokumentvorlage geöffnet, die mit dem aktiven Dokument verbunden ist, und die Formatvorlage Überschrift 1 modifiziert. Die Dokumentvorlage wird gespeichert, und alle Formatvorlagen im aktiven Dokument werden aktualisiert.

Set tempDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
With tempDoc.Styles(wdStyleHeading1).Font
    .Name = "Arial"
    .Size = 16
End With
tempDoc.Close SaveChanges:=wdSaveChanges
ActiveDocument.UpdateStyles


SubAddress-Eigenschaft

Gibt eine benannte Stelle im Ziel des angegebenen Hyperlinks zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Hinweis Die benannte Stelle kann eine Textmarke in einem Microsoft Word-Dokument sein, eine benannte Zelle oder ein Zellverweis in einer Microsoft Excel-Tabelle, ein benanntes Objekt in einer Microsoft Access-Datenbank oder eine Foliennummer in einer Microsoft PowerPoint-Präsentation.


Beispiel zur SubAddress-Eigenschaft

In diesem Beispiel wird die Subadresse des markierten Hyperlinks angezeigt.

If Selection.Range.Hyperlinks.Count >= 1 Then
    MsgBox Selection.Range.Hyperlinks(1).SubAddress
End If

In diesem Beispiel wird im aktiven Dokument der Markierung ein Hyperlink hinzugefügt, das Hyperlink-Ziel und die -Subadresse werden festgelegt und in einem Meldungsfeld angezeigt.

Set SCut = ActiveDocument.Hyperlinks.Add( _
    Anchor:= Selection.Range, _
    Address:="C:\My Documents\Other.doc", SubAddress:= "temp")
MsgBox "The hyperlink goes to " & SCut.SubAddress


Subdocuments-Eigenschaft

Liefert eine Subdocuments-Auflistung, die alle Filialdokumente im angegebenen Bereich oder Dokument darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Subdocuments-Eigenschaft

In diesem Beispiel wird die Anzahl der eingebetteten Filialdokumente im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Subdocuments.Count

In diesem Beispiel werden die Pfad- und Dateinamen aller Filialdokumente im aktiven Dokument angezeigt.

For Each subdoc In ActiveDocument.Subdocuments
    If subdoc.HasFile = True Then
        MsgBox subdoc.Path & Application.PathSeparator _
            & subdoc.Name
    Else
        MsgBox "This subdocument has not been saved."
    End If
Next subdoc


Subject-Eigenschaft

RoutingSlip-Objekt: Gibt den Text für das Thema der E-Mail-Nachrichten, mit denen ein Dokument weitergeleitet wird, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

LetterContent-Objekt: Gibt den Text für das Thema eines Briefes, der mit dem Brief-Assistenten erstellt wurde, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur Subject-Eigenschaft

In diesem Beispiel wird das Thema und der Meldungstext für die Verteilerliste von Month End.doc erstellt.

If Documents("Month End.doc").HasRoutingSlip = True Then
    With Documents("Month End.doc").RoutingSlip
        .Subject = "End of month report"
        .Message = "I need your response on this."
    End With
End If

In diesem Beispiel wird das Thema eines Briefes angezeigt, der mit dem Brief-Assistenten erstellt wurde, wenn es sich dabei nicht um eine leere Zeichenfolge handelt.

If ActiveDocument.GetLetterContent.Subject <> "" Then
    MsgBox ActiveDocument.GetLetterContent.Subject
End If


Subscript-Eigenschaft

True, wenn die Schriftart tiefgestellt formatiert wird. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie Subscript auf True setzen, wird Superscript auf False gesetzt und umgekehrt.


Beispiel zur Subscript-Eigenschaft

In diesem Beispiel wird Text zu Beginn des aktiven Dokuments eingefügt, dann wird der elfte Buchstabe tiefgestellt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myRange.InsertAfter "Water = H20"
myRange.Characters(10).Font.Subscript = True

In diesem Beispiel wird der gewählte Text nach tiefgestelltem Text überprüft.

If Selection.Type = wdSelectionNormal Then
    mySel = Selection.Font.Subscript
    If mySel = wdUndefined or mySel = True Then
        MsgBox "Subscript text exists in the selection."
    Else
        MsgBox "No subscript text in the selection."
    End If
Else
    MsgBox "You need to select some text."
End If


SuggestFromMainDictionaryOnly-Eigenschaft

True, wenn Word Rechtschreibungsvorschläge nur aus dem Hauptwörterbuch bezieht. False, wenn es Rechtschreibungsvorschläge aus dem Hauptwörterbuch und allen Benutzerwörterbüchern bezieht, die hinzugefügt wurden. Boolean Schreib-Lese-Zugriff.


Beispiel zur SuggestFromMainDictionaryOnly-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es nur Wörter aus dem Hauptwörterbuch vorschlägt, und anschließend wird die Rechtschreibung im aktiven Dokument geprüft.

Options.SuggestFromMainDictionaryOnly = True
ActiveDocument.CheckSpelling

In diesem Beispiel wird der aktuelle Status der Option Vorschläge nur aus Hauptwörterbuch auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.SuggestFromMainDictionaryOnly


SuggestSpellingCorrections-Eigenschaft

True, wenn Word bei der Rechtschreibprüfung für jedes falsch geschriebene Wort immer alternative Schreibweisen vorschlägt. Boolean Schreib-Lese-Zugriff.


Beispiel zur SuggestSpellingCorrections-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass es für falsch geschriebene Wörter immer alternative Schreibweisen vorschlägt. Anschließend wird die Rechtschreibung im aktiven Dokument geprüft.

Options.SuggestSpellingCorrections = True
ActiveDocument.CheckSpelling

In diesem Beispiel wird der aktuelle Status der Option Immer Korrekturvorschläge unterbreiten auf der Registerkarte Rechtschreibung und Grammatik im Dialogfeld Optionen zurückgegeben.

temp = Options.SuggestSpellingCorrections


SummaryLength-Eigenschaft

Gibt die Länge der Zusammenfassung als Prozentwert der Dokumentlänge zurück oder legt sie fest. Je größer die Zahl, desto mehr Einzelheiten werden in die Zusammenfassung aufgenommen. Long Schreib-Lese-Zugriff.

Hinweis Diese Eigenschaft wirkt unmittelbar, wenn die AutoZusammenfassen-Symbolleiste angezeigt wird; andernfalls wird sie wirksam, wenn die AutoSummarize-Methode oder die SummaryViewMode-Eigenschaft das nächste Mal dem Dokument zugewiesen wird.


Beispiel zur SummaryLength-Eigenschaft

In diesem Beispiel werden im aktiven Dokument die Schwerpunkte hervorgehoben. Das Detail-Niveau wird auf 50 Prozent festgelegt.

With ActiveDocument
    .AutoSummarize Mode:=wdSummaryModeHighlight
    .SummaryLength = 50
End With

In diesem Beispiel wird die Zusammenfassung angezeigt und das Detail-Niveau auf 55 Prozent festgelegt.

With ActiveDocument
    .ShowSummary = True
    .SummaryLength = 55
End With


SummaryViewMode-Eigenschaft

Gibt die Art zurück, wie eine Zusammenfassung angezeigt wird, oder legt sie fest. Diese Eigenschaft entspricht Art der Zusammenfassung im Dialogfeld AutoZusammenfassen im Menü Extras. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden WdSummaryMode-Konstanten sein:

Konstante | Beschreibung
wdSummaryModeHighlight | Hebt die Schwerpunkte im angegebenen Dokument hervor und zeigt die AutoZusammenfassen-Symbolleiste an.
wdSummaryModeInsert | Fügt eine Zusammenfassung am Anfang des angegebenen Dokuments ein.
wdSummaryModeCreateNew | Erstellt ein neues Dokument und fügt die angegebene Zusammenfassung ein.
wdSummaryModeHideAllButSummary | Verbirgt alles außer der angegebenen Zusammenfassung und zeigt die AutoZusammenfassen-Symbolleiste an.


Beispiel zur SummaryViewMode-Eigenschaft

In diesem Beispiel wird im aktiven Dokument alles außer dem Text der Zusammenfassung ausgeblendet.

With ActiveDocument
    .SummaryViewMode = wdSummaryModeHideAllButSummary
    .SummaryLength = 60
    .ShowSummary = True
End With


Superscript-Eigenschaft

True, wenn die Schriftart hochgestellt formatiert wird. Gibt True, False oder wdUndefined (eine Mischung aus True und False) zurück. Kann auf True, False oder wdToggle gesetzt werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie Superscript auf True setzen, wird Subscript auf False gesetzt und umgekehrt.


Beispiel zur Superscript-Eigenschaft

In diesem Beispiel wird Text zu Beginn des aktiven Dokuments eingefügt und zwei Zeichen im vierten Wort hochgestellt.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
myRange.InsertAfter "Superscript in the 4th word."
ActiveDocument.Range(Start:=20, End:=22).Font.Superscript = True

In diesem Beispiel wird der gewählte Text hochgestellt.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Superscript = True
Else
    MsgBox "You need to select some text."
End If


SuppressBlankLines-Eigenschaft

True, wenn Leerzeilen bei leeren Seriendruckfeldern in einem Seriendruck-Hauptdokument unterdrückt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur SuppressBlankLines-Eigenschaft

In diesem Beispiel wird Haupt.doc geöffnet und die Seriendruckoperation ausgeführt. Bei leeren Seriendruckfeldern werden Leerzeilen im Seriendruckdokument unterdrückt.

Set myDoc = Documents.Open(FileName:="C:\My Documents\Main.doc")
With myDoc.MailMerge
    .SuppressBlankLines = True
    .Destination = wdSendToPrinter
    .Execute
End With


SuppressEndnotes-Eigenschaft

True, wenn Endnoten am Ende des nächsten Abschnitts gedruckt werden, der keine Endnoten unterdrückt. Unterdrückte Endnoten werden vor den Endnoten aus diesem Abschnitt gedruckt. Boolean Schreib-Lese-Zugriff.

Anmerkung Diese Eigenschaft hat nur Auswirkungen, wenn der Location-Eigenschaft wdEndOfSection zugewiesen wurde.


Beispiel zur SuppressEndnotes-Eigenschaft

In diesem Beispiel werden Endnoten im ersten Abschnitt des aktiven Dokuments unterdrückt.

If ActiveDocument.Endnotes.Location = wdEndOfSection Then
    ActiveDocument.Sections(1).PageSetup.SuppressEndnotes = True
End If


SurroundFooter-Eigenschaft

True, wenn ein Seitenrahmen die Fußzeile eines Dokuments umfasst. Boolean Schreib-Lese-Zugriff.


Beispiel zur SurroundFooter-Eigenschaft

In diesem Beispiel wird der Seitenrahmen in Abschnitt 1 im aktiven Dokument formatiert, damit Kopf- und Fußzeile auf allen Seiten der Auswahl vom Seitenrahmen umfasst werden.

With ActiveDocument.Sections(1).Borders
    .SurroundFooter = True
    .SurroundHeader = True
End With

In diesem Beispiel wird ein grafischer Seitenrahmen um alle Seiten in Abschnitt 1 hinzugefügt. Der Seitenrahmen umfasst nicht die Bereiche der Kopf- und Fußzeile.

With ActiveDocument.Sections(1)
    .Borders.SurroundFooter = False
    .Borders.SurroundHeader = False
    For Each aBord In .Borders
        aBord.ArtStyle = wdArtPeople
        aBord.ArtWidth = 15
    Next aBord
End With


SurroundHeader-Eigenschaft

True, wenn ein Seitenrahmen die Kopfzeile eines Dokuments umfasst. Boolean Schreib-Lese-Zugriff.


Beispiel zur SurroundHeader-Eigenschaft

In diesem Beispiel wird der Seitenrahmen in Abschnitt 1 im aktiven Dokument so formatiert, dass die Bereiche für Kopf- und Fußzeile ausgeschlossen werden.

With ActiveDocument.Sections(1).Borders
    .SurroundFooter = False
    .SurroundHeader = False
End With


SynonymInfo-Eigenschaft

Gibt ein SynonymInfo-Objekt zurück, das Informationen aus dem Thesaurus über Synonyme, Antonyme oder verwandte Wörter und Ausdrücke für das angegebene Wort oder die Formulierung enthält. Nur-Lese-Zugriff.

Syntax 1

Ausdruck.SynonymInfo

Syntax 2

Ausdruck.SynonymInfo(Word, LanguageID)

Ausdruck Syntax 1: Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Syntax 2: Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Word String erforderlich. Das Wort oder die Formulierung, die im Thesaurus nachgeschlagen werden sollen.

LanguageID Variant optional. Die Sprache, die der Thesaurus verwendet. Dabei kann es sich um eine der folgenden WdLanguageID-Konstanten handeln:

wdAfrikaans

wdAlbanian

wdArabic

wdArabicAlgeria

wdArabicBahrain

wdArabicEgypt

wdArabicIraq

wdArabicJordan

wdArabicKuwait

wdArabicLebanon

wdArabicLibya

wdArabicMorocco

wdArabicOman

wdArabicQatar

wdArabicSyria

wdArabicTunisia

wdArabicUAE

wdArabicYemen

wdArmenian

wdAssamese

wdAzeriCyrillic

wdAzeriLatin

wdBasque

wdBelgianDutch

wdBelgianFrench

wdBengali

wdBosniaHerzegovina

wdBrazilianPortuguese

wdBulgarian

wdBurmese

wdByelorussian

wdCatalan

wdChineseHongKong

wdChineseMacao

wdChineseSingapore

wdCroatian

wdCzech

wdDanish

wdDutch

wdEnglishAUS

wdEnglishBelize

wdEnglishCanadian

wdEnglishCaribbean

wdEnglishIreland

wdEnglishJamaica

wdEnglishNewZealand

wdEnglishPhilippines

wdEnglishSouthAfrica

wdEnglishTrinidad

wdEnglishUK

wdEnglishUS

wdEnglishZimbabwe

wdEstonian

wdFaeroese

wdFarsi

wdFinnish

wdFrench

wdFrenchCameroon

wdFrenchCanadian

wdFrenchCotedIvoire

wdFrenchLuxembourg

wdFrenchMali

wdFrenchMonaco

wdFrenchReunion

wdFrenchSenegal

wdFrenchWestIndies

wdFrenchZaire

wdFrisianNetherlands

wdGaelicIreland

wdGaelicScotland

wdGalician

wdGeorgian

wdGerman

wdGermanAustria

wdGermanLiechtenstein

wdGermanLuxembourg

wdGreek

wdGujarati

wdHebrew

wdHindi

wdHungarian

wdIcelandic

wdIndonesian

wdItalian

wdJapanese

wdKannada

wdKashmiri

wdKazakh

 wdKhmer

wdKirghiz

wdKonkani

wdKorean

wdLanguageNone

wdLao

wdLatvian

wdLithuanian

wdLithuanianClassic

wdMacedonian

wdMalayalam

wdMalayBruneiDarussalam

wdMalaysian

wdMaltese

wdManipuri

wdMarathi

wdMexicanSpanish

wdMongolian

wdNepali

wdNoProofing

wdNorwegianBokmol

wdNorwegianNynorsk

wdOriya

wdPolish

wdPortuguese

wdPunjabi

wdRhaetoRomanic

wdRomanian

wdRomanianMoldova

wdRussian

wdRussianMoldova

wdSamiLappish

wdSanskrit

wdSerbianCyrillic

wdSerbianLatin

wdSesotho

wdSimplifiedChinese

wdSindhi

wdSlovak

wdSlovenian

wdSorbian

wdSpanish

wdSpanishArgentina

wdSpanishBolivia

wdSpanishChile

wdSpanishColombia

wdSpanishCostaRica

wdSpanishDominicanRepublic

wdSpanishEcuador

wdSpanishElSalvador

wdSpanishGuatemala

wdSpanishHonduras

wdSpanishModernSort

wdSpanishNicaragua

wdSpanishPanama

wdSpanishParaguay

wdSpanishPeru

wdSpanishPuertoRico

wdSpanishUruguay

wdSpanishVenezuela

wdSutu

wdSwahili

wdSwedish

wdSwedishFinland

wdSwissFrench

wdSwissGerman

wdSwissItalian

wdTajik

wdTamil

wdTatar

wdTelugu

wdThai

wdTibetan

wdTraditionalChinese

wdTsonga

wdTswana

wdTurkish

wdTurkmen

wdUkrainian

wdUrdu

wdUzbekCyrillic

wdUzbekLatin

wdVenda

wdVietnamese

wdWelsh

wdXhosa

wdZulu

Hinweise

Einige der oben aufgeführten Konstanten sind möglicherweise nicht verfügbar. Dies hängt ab von der ausgewählten oder installierten Sprachunterstützung ab (z. B. Deutsch).


Beispiel zur SynonymInfo-Eigenschaft

In diesem Beispiel wird eine Liste von Antonymen für das Wort "groß" in Deutsch zurückgegeben.

Alist = SynonymInfo(Word:="big", _
    LanguageID:=wdEnglishUS).AntonymList
For i = 1 To UBound(Alist)
    Msgbox Alist(i)
Next i

In diesem Beispiel wird eine Liste von Synonymen für die erste Bedeutung der Markierung zurückgegeben.

Slist = Selection.Range.SynonymInfo.SynonymList(Meaning:=1)
For i = 1 To UBound(Slist)
    Msgbox Slist(i)
Next i


SynonymList-Eigenschaft

Gibt eine Liste von Synonymen für eine angegebene Bedeutung eines Worts oder Ausdrucks zurück. Die Liste wird als Zeichenfolgenbereich zurückgegeben. Variant Nur-Lese-Zugriff.

Syntax

Ausdruck.SynonymList(Meaning)

Ausdruck Erforderlich. Ein Ausdruck, der ein SynonymInfo-Objekt zurückgibt.

Meaning Variant erforderlich. Die Bedeutung als eine Zeichenfolge oder eine Indexnummer im Datenfeld der möglichen Bedeutungen.


Beispiel zur SynonymList-Eigenschaft

In diesem Beispiel wird eine Liste von Synonymen für das Wort "groß" zurückgegeben, wobei die Bedeutung "gewaltig" in Deutsch verwendet wird.

Slist = SynonymInfo(Word:="big", LanguageID:=wdEnglishUS) _
    .SynonymList(Meaning:="generous")
For i = 1 To UBound(Slist)
    Msgbox Slist(i)
Next i

In diesem Beispiel wird eine Liste von Synonymen für die zweite Bedeutung des markierten Worts oder Ausdrucks zurückgegeben, und diese Synonyme werden im Direktfenster des Visual Basic Editors angezeigt. Wenn es keine zweite Bedeutung oder keine Synonyme gibt, wird dies in einem Meldungsfeld angegeben.

Set mySi = Selection.Range.SynonymInfo
If mySi.MeaningCount >= 2 Then
    synList = mySi.SynonymList(Meaning:=2)
        For i = 1 To UBound(synList)
            Debug.Print synList(i)
        Next i
Else
    MsgBox "There is no second meaning for this word or phrase."
End If


System-Eigenschaft

Gibt das System-Objekt zurück, mit dem Sie das System betreffende Informationen zurückgeben oder systembetreffende Aufgaben durchführen können. Nur-Lese-Zugriff.


Beispiel zur System-Eigenschaft

In diesem Beispiel werden Informationen über das System zurückgegeben.

processor = System.ProcessorType
enviro = System.OperatingSystem

In diesem Beispiel wird eine Verbindung zu einem Netzwerklaufwerk hergestellt.

System.Connect Path:="\\Project\Info"


TabIndentKey-Eigenschaft

True, wenn Sie mit der TABULATOR- bzw. RÜCKTASTE den linken Absatzeinzug erhöhen oder vermindern können, und wenn Sie mit der RÜCKTASTE rechtsbündig ausgerichtete Absätze zentrieren und zentriert ausgerichtete Absätze links ausrichten können. Boolean Schreib-Lese-Zugriff.


Beispiel zur TabIndentKey-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Sie mit Hilfe der TABULATOR- bzw. RÜCKTASTE den linken Einzug festlegen, anstatt Tabulatoren einzufügen oder zu löschen.

Options.TabIndentKey = True

In diesem Beispiel wird der Status der Option Mit Tabulator und Rücktaste Absatzeinzug ändern auf der Registerkarte Bearbeiten im Dialogfeld Optionen zurückgegeben.

temp = Options.TabIndentKey


TabLeader-Eigenschaft

Gibt das Zeichen zwischen Einträgen und ihren Seitenzahlen in einem Index, Inhaltsverzeichnis oder Abbildungsverzeichnis zurück oder legt es fest. Dies kann eine der folgenden WdTabLeader-Konstanten sein: wdTabLeaderDashes, wdTabLeaderDots, wdTabLeaderHeavy, wdTabLeaderLines, wdTabLeaderMiddleDot oder wdTabLeaderSpaces. Long Schreib-Lese-Zugriff.


Beispiel zur TabLeader-Eigenschaft

In diesem Beispiel werden die Inhaltsverzeichnisse in Umsatz.doc formatiert, so dass ein punktiertes Füllzeichen verwendet wird.

For Each aTOC In Documents("Sales.doc").TablesOfContents
    aTOC.TabLeader = wdTabLeaderDots
Next aTOC

In diesem Beispiel wird am Ende des aktiven Dokuments ein Index hinzugefügt. Die Seitenzahlen werden mit einer gestrichelten Linie als Füllzeichen rechtsbündig ausgerichtet.

Set myRange = ActiveDocument.Range( _
    Start:=ActiveDocument.Content.End -1, _
    End:=ActiveDocument.Content.End -1)
ActiveDocument.Indexes.Add(Range:=myRange, Type:=wdIndexIndent, _
    RightAlignPageNumbers:=True).TabLeader = wdTabLeaderDashes


TableDirection-Eigenschaft

Sprachspezifische Informationen

Returns or sets the direction in which Microsoft Word orders cells in the specified table or row. Read/write Long. Can be either of the following WdTableDirection constants: wdTableDirectionLtr (left-to-right) or wdTableDirectionRtl (right-to-left). Read/write Long.

Remarks

If the TableDirection property is set to left-to-right, the selected rows are arranged with the first column in the leftmost position. If the TableDirection property is set to right-to-left, the selected rows are arranged with the first column in the rightmost position.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur TableDirection-Eigenschaft

This example sets Microsoft Word to order cells in the selected row from right to left.

Selection.Rows.TableDirection = _
    wdTableDirectionRtl


TableGridlines-Eigenschaft

True, wenn Tabellen-Gitternetzlinien angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur TableGridlines-Eigenschaft

In diesem Beispiel werden im aktiven Fenster Gitternetzlinien in Tabellen angezeigt.

ActiveDocument.ActiveWindow.View.TableGridlines = True

In diesem Beispiel werden Gitternetzlinien in Tabellen für die Ausschnitte angezeigt, die mit Fenster eins in der Windows-Auflistung verbunden sind.

For Each myPane In Windows(1).Panes
    myPane.View.TableGridlines = True
Next myPane


TableID-Eigenschaft

Gibt eine Ein-Buchstaben-Kennung zurück, die zum Aufbau eines Inhaltsverzeichnisses oder Abbildungsverzeichnisses aus TC-Feldern verwendet wird, oder legt sie fest. Entspricht dem Schalter \f für ein TOC-Feld. Beispielsweise baut "V" ein Inhaltsverzeichnis aus TC-Feldern mit Hilfe der Verzeichnis-Kennung V auf. String Schreib-Lese-Zugriff.


Beispiel zur TableID-Eigenschaft

In diesem Beispiel wird in Sales.doc nach der Markierung ein TC-Feld mit einem Kennzeichen "A" eingefügt. Das erste Inhaltsverzeichnis wird dann so formatiert, dass die Einträge "A" zusammengestellt werden.

Documents("Sales.doc").TablesOfContents.MarkEntry _
    Range:=Selection.Range, _
    Entry:="Hello", TableID:="A"
With Documents("Sales.doc").TablesOfContents(1)
    .TableID = "A"
    .UseFields = True
    .UseHeadingStyles = False
    .Update
End With

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Abbildungsverzeichnis hinzugefügt und dann das Verzeichnis so formatiert, dass die Einträge "B" zusammengestellt werden.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
Set myTOF = ActiveDocument.TablesOfFigures.Add(Range:=myRange)
With myTOF
    .UseFields = True
    .UseHeadingStyles = False
    .TableID = "B"
    .Caption = ""
End With


Tables-Eigenschaft

Gibt eine Tables-Auflistung zurück, die alle Tabellen in der der angegebenen Zelle, Tabelle oder Markierung bzw. dem angegebenen Dokument oder Bereich darstellt. Nur-Lese-Zugriff.

Informationen über die Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


TablesOfAuthorities-Eigenschaft

Gibt eine TablesOfAuthorities-Auflistung zurück, die alle Rechtsgrundlagenverzeichnisse im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Informationen über das Zurückgeben eines Elements aus einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


TablesOfAuthoritiesCategories-Eigenschaft

Gibt eine TablesOfAuthoritiesCategories-Auflistung zurück, die die verfügbaren Kategorien für Rechtsgrundlagenverzeichnisse im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung erhalten Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TablesOfAuthoritiesCategories-Eigenschaft

In diesem Beispiel wird der Name des achten Eintrags in der Kategorienliste für Rechtsgrundlagenverzeichnisse im aktiven Dokument geändert.

ActiveDocument.TablesOfAuthoritiesCategories(8).Name = "Other case"

In diesem Beispiel wird der Name der letzten Kategorie für Rechtsgrundlagenverzeichnisse angezeigt, sofern er geändert wurde.

last = ActiveDocument.TablesOfAuthoritiesCategories.Count
If ActiveDocument.TablesOfAuthoritiesCategories(last) _
    .Name <> "16" Then
    MsgBox ActiveDocument.TablesOfAuthoritiesCategories(last).Name
End If


TablesOfContents-Eigenschaft

Gibt eine TablesOfContents-Auflistung zurück, die die Inhaltsverzeichnisse im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TablesOfContents-Eigenschaft

In diesem Beispiel wird am Anfang von Sales.doc ein Inhaltsverzeichnis hinzugefügt. Das Inhaltsverzeichnis stellt Stichworttext aus TC-Feldern zusammen.

Set myRange = Documents("Sales.doc").Range(Start:=0, End:=0)
Documents("Sales.doc").TablesOfContents.Add Range:=myRange, _
    UseFields:=True, UseHeadingStyles:=False

In diesem Beispiel werden für Elemente im Inhaltsverzeichnis des aktiven Dokuments die Seitenzahlen aktualisiert.

For Each myTOC In ActiveDocument.TablesOfContents
    myTOC.UpdatePageNumbers
Next myTOC


TablesOfFigures-Eigenschaft

Gibt eine TablesOfFigures-Auflistung zurück, die die Abbildungsverzeichnisse im angegebenen Dokument darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TablesOfFigures-Eigenschaft

In diesem Beispiel wird im aktiven Dokument an der Einfügemarke ein Abbildungsverzeichnis hinzugefügt.

Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.TablesOfFigures.Add Range:=Selection.Range, _
    Caption:=wdCaptionFigure

In diesem Beispiel wird der Inhalt des ersten Abbildungsverzeichnisses in Bericht.doc aktualisiert.

Documents("Report.doc").TablesOfFigures(1).Update


TabPosition-Eigenschaft

Gibt die Tabstop-Position für das angegebene ListLevel-Objekt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur TabPosition-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Nummern aller Listenebenen im Abstand von 1,27 cm (36 Punkt) zur vorherigen Ebene eingezogen werden. Die Tabstop-Position wird auf einen Abstand von 0,64 cm (18 Punkt) zur Zahl festgelegt.

r = 0
For Each lev In ListGalleries(wdOutlineNumberGallery) _
    .ListTemplates(1).ListLevels
        lev.Alignment = wdListLevelAlignLeft
        lev.NumberPosition = r
        lev.TrailingCharacter = wdTrailingTab
        lev.TabPosition = r + 18
        r = r + 36
Next lev

In diesem Beispiel wird der Variablen myltemp die erste Vorlage für nummerierte Listen zugewiesen, und die TapStop-Position auf 2,54 cm festgelegt. Die Listenvorlage wird dann der Auswahl zugewiesen.

Set myltemp = ListGalleries(wdNumberGallery).ListTemplates(1)
myltemp.ListLevels(1).TabPosition = InchesToPoints(1)
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myltemp


TabStops-Eigenschaft

Gibt eine TabStops-Auflistung zurück oder legt eine fest, die alle benutzerdefinierten Tabstopps für die angegebenen Absätze darstellt. Schreib-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TabStops-Eigenschaft

In diesem Beispiel wird allen Absätzen im aktiven Dokument ein zentrierter Tabstopp bei 2 Zoll hinzugefügt. Die InchesToPoints-Methode wird zur Umwandlung von Zoll in Punkt verwendet.

With ActiveDocument.Paragraphs.TabStops
    .Add Position:= InchesToPoints(2), Alignment:= wdAlignTabCenter
End With

In diesem Beispiel werden für jeden Absatz im Dokument die Tabstopps so gesetzt, dass sie mit den Tabstopps im ersten Absatz übereinstimmen.

Set para1Tabs = ActiveDocument.Paragraphs(1).TabStops
ActiveDocument.Paragraphs.TabStops = para1Tabs


Target-Eigenschaft

Browser-Objekt: Gibt das Dokumentelement zurück, das durch die Previous- und Next-Methode gefunden wird, oder legt dieses fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdBrowseTarget-Konstanten handeln:

wdBrowseComment

wdBrowseEdit

wdBrowseEndnote

wdBrowseField

wdBrowseFind

wdBrowseFootnote

 wdBrowseGoTo

wdBrowseGraphic

wdBrowseHeading

wdBrowsePage

wdBrowseSection

wdBrowseTable

Hyperlink-Objekt: Gibt den Namen des Frames oder Fensters zurück, in dem der Hyperlink geladen werden soll, oder legt diesen Frame bzw. dieses Fenster fest. String Schreib-Lese-Zugriff.


Beispiel zur Target-Eigenschaft

In diesem Beispiel wird die Einfügemarke zum nächsten Kommentar im aktiven Dokument verschoben.

With Application.Browser
    .Target = wdBrowseComment
    .Next
End With

In diesem Beispiel wird festgelegt, dass der angegebene Hyperlink in einem neuen Browserfenster geöffnet wird.

ActiveDocument.Hyperlinks(1).Target = "_blank"

In diesem Beispiel wird festgelegt, dass der angegebene Hyperlink in dem mit "left" bezeichneten Frame geöffnet wird.

ActiveDocument.Hyperlinks(1).Target = "left"


Tasks-Eigenschaft

Gibt eine Tasks-Sammlung zurück, die alle Anwendungen, die zurzeit ausgeführt werden, darstellt. Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Tasks-Eigenschaft

In diesem Beispiel wird der Taschenrechner angezeigt. Wenn der Taschenrechner zurzeit nicht ausgeführt wird, startet Word den Vorgang und zeigt dann den Taschenrechner an.

If Tasks.Exists("Calculator") Then
    With Tasks("Calculator")
        .Activate
        .WindowState = wdWindowStateNormal
    End With
Else
    Shell "calc.exe"
    Tasks("Calculator").WindowState = wdWindowStateNormal
End If

In diesem Beispiel wird überprüft, ob Microsoft Excel zurzeit läuft. Wenn der Vorgang ausgeführt wird, aktiviert dieses Beispiel Microsoft Excel, sonst wird ein Meldungsfeld angezeigt.

If Tasks.Exists("Microsoft Excel") = True Then
    With Tasks("Microsoft Excel")
        .Activate
        .WindowState = wdWindowStateMaximize
    End With
Else
    Msgbox "Microsoft Excel is not currently running."
End If


Templates-Eigenschaft

Gibt eine Templates-Auflistung zurück, die alle verfügbaren Dokumentvorlagen enthält – globale Dokumentvorlagen und solche, die offenen Dokumenten zugeordnet sind. Nur-Lese-Zugriff.

Informationen zur Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Templates-Eigenschaft

In diesem Beispiel werden die Namen aller Dokumentvorlagen in der Templates-Auflistung angezeigt.

Count = 1
For Each aTemplate In Templates
    MsgBox aTemplate.Name & " is template number " & Count
    Count = Count + 1
Next aTemplate

In diesem Beispiel wird der Pfad der ersten Dokumentvorlage in thePath gespeichert, wenn es sich dabei um eine globale Dokumentvorlage handelt. Mit der ChDir-Anweisung wird der Ordner mit dem unter thePath gespeicherten Pfad zum aktuellen Ordner gemacht. Bei dieser Änderung wird das Dialogfeld Öffnen angezeigt.

If Templates(1).Type = wdGlobalTemplate Then
    thePath = Templates(1).Path
    If thePath <> "" Then ChDir thePath
    Dialogs(wdDialogFileOpen).Show
End If


Text-Eigenschaft

Range- oder Selection-Objekt: Gibt den Text im angegebenen Bereich oder in der angegebenen Markierung zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Find- oder Replacement-Objekt: Gibt den Text, der im angegebenen Bereich oder in der angegebenen Markierung gesucht oder ersetzt werden soll, zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Die Text-Eigenschaft gibt den einfachen, unformatierten Text der Markierung oder des Bereichs zurück. Wenn Sie diese Eigenschaft angeben, wird der Text des Bereichs oder der Markierung ersetzt.


TextColumns-Eigenschaft

Gibt eine TextColumns-Auflistung, die die Textspalten des angegebenen PageSetup-Objekt repräsentiert, zurück oder legt sie fest. Schreib-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Es befindet sich immer mindestens eine Textspalte in der Auflistung. Wenn Sie neue Textspalten anlegen, erweitern Sie die Auflistung um eine Spalte.


Beispiel zur TextColumns-Eigenschaft

In diesem Beispiel werden vier gleichgroße Textspalten erzeugt, die dann Abschnitt 2 im aktiven Dokument zugewiesen werden.

With ActiveDocument.Sections(2).PageSetup.TextColumns
    .SetCount NumColumns:=3
    .Add EvenlySpaced:=True
End With

In diesem Beispiel wird ein Dokument mit zwei Textspalten angelegt. Die erste Spalte ist 1,5 Zoll und die zweite 3 Zoll breit.

Set myDoc = Documents.Add
With myDoc.PageSetup.TextColumns
    .SetCount NumColumns:=1
    .Add Width:=InchesToPoints(3)
End With
With myDoc.PageSetup.TextColumns(1)
    .Width = InchesToPoints(1.5)
    .SpaceAfter = InchesToPoints(0.5)
End With


TextEffect-Eigenschaft

Gibt ein TextEffectFormat-Objekt zurück, das Formatierungseigenschaften von Texteffekten für die angegebene Form enthält. Dies gilt nur für Shape- oder ShapeRange-Objekte, die WordArt-Objekte darstellen, sowie InlineShape-Objekte. Nur-Lese-Zugriff.


Beispiel zur TextEffect-Eigenschaft

In diesem Beispiel wird in myDocument für Form drei die Schriftauszeichnung auf fett eingestellt, wenn die Form ein WordArt-Objekt ist.

Set myDocument = ActiveDocument
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


TextFrame-Eigenschaft

Gibt ein TextFrame-Objekt zurück, das den Text für die angegebene Form enthält.


Beispiel zur TextFrame-Eigenschaft

In diesem Beispiel wird zu myDocument ein Rechteck und dem Rechteck Text hinzugefügt, und die Ränder für den Textrahmen werden eingestellt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .TextRange.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


TextInput-Eigenschaft

Gibt ein TextInput-Objekt zurück, das ein Textformularfeld darstellt. Nur-Lese-Zugriff.

Anmerkungen

Wenn die TextInput-Eigenschaft auf ein FormField-Objekt angewendet wird, bei dem es sich nicht um ein Dropdown-Formularfeld handelt, dann entsteht durch die Eigenschaft kein Fehler, aber die Valid-Eigenschaft für das zurückgegebene Objekt lautet False.

Verwenden Sie die Result-Eigenschaft mit dem FormField-Objekt, um den Inhalt eines TextInput-Objekts zurückzugeben oder zuzuweisen.

ActiveDocument.FormFields("Text1").Result = "John Doe"


Beispiel zur TextInput-Eigenschaft

In diesem Beispiel wird das aktive Dokument als Formular geschützt und der Inhalt des Formularfelds "Text1" wird gelöscht.

ActiveDocument.Protect Type:=wdAllowOnlyFormFields
ActiveDocument.FormFields("Text1").TextInput.Clear

Falls das Formularfeld im aktiven Dokument ein Textformularfeld ist, das einfachen Text annimmt, dann wird in diesem Beispiel der Inhalt des Formularfelds zugewiesen.

Set myField = ActiveDocument.FormFields(1)
If myField.Type = wdFieldFormTextInput And _
    myField.TextInput.Type = wdRegularText Then
    myField.Result = "Hello"
End If


TextPosition-Eigenschaft

Gibt die Position der zweiten Zeile beim automatischen Textumbruch des angegebenen ListLevel-Objekts zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur TextPosition-Eigenschaft

In diesem Beispiel wird der Einzug aller Ebenen der ersten Listenvorlage für Gliederungen festgelegt. Jede Nummer der Listenebenen wird mit einem Abstand von 1,27 cm (36 Punkt) zur vorherigen Ebene eingezogen. Die Tapstop-Position wird auf einen Abstand von 0,64 cm (18 Punkt) zur Zahl festgelegt. Der automatische Textumbruch erhält einen Einzug von 0,64 cm (18 Punkt) zur Zahl.

r = 0
For Each lev In ListGalleries(wdOutlineNumberGallery) _
        .ListTemplates(1).ListLevels
    lev.Alignment = wdListLevelAlignLeft
    lev.NumberPosition = r
    lev.TrailingCharacter = wdTrailingTab
    lev.TabPosition = r + 18
    lev.TextPosition = r + 18
    r = r + 36
Next lev


TextRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Text im angegebenen Textpositionsrahmen darstellt. Nur-Lese-Zugriff.


Beispiel zur TextRange-Eigenschaft

In diesem Beispiel wird ein Textfeld dem aktiven Dokument hinzugefügt, und anschließend wird Text in das Textfeld eingefügt.

Set myTBox = ActiveDocument.Shapes _
    .AddTextBox(Orientation:=msoTextOrientationHorizontal, _
    Left:=100, Top:=100, Width:=300, Height:=200)
myTBox.TextFrame.TextRange = "Test Box"

In diesem Beispiel wird TextFeld 1 dem aktiven Dokument Text hinzugefügt.

ActiveDocument.Shapes("TextBox 1").TextFrame.TextRange _
    .InsertAfter("New Text")

In diesem Beispiel wird der Text von TextFeld 1 dem aktiven Dokument zurückgegeben und in einem Meldungsfeld angezeigt.

MsgBox ActiveDocument.Shapes("TextBox 1").TextFrame.TextRange.Text


TextRetrievalMode-Eigenschaft

Gibt ein TextRetrievalMode-Objekt zurück, das bestimmt, wie Text vom angegebenen Range abgerufen wird. Schreib-Lese-Zugriff.


Beispiel zur TextRetrievalMode-Eigenschaft

In diesem Beispiel wird der gewählte Text (ohne eventuell vorhandenen ausgeblendeten Text) abgerufen und am Anfang des dritten Absatzes des aktiven Dokuments eingefügt.

If Selection.Type = wdSelectionNormal Then
    Set Range1 = Selection.Range
    Range1.TextRetrievalMode.IncludeHiddenText = False
    Set Range2 = ActiveDocument.Paragraphs(2).Range
    Range2.InsertAfter Range1.Text
End If

In diesem Beispiel werden die ersten drei Absätze abgerufen und ihr Erscheinen in der Gliederungsansicht angezeigt.

Set myRange = ActiveDocument.Range(Start:=ActiveDocument _
    .Paragraphs(1).Range.Start, _
    End:=ActiveDocument.Paragraphs(3).Range.End)
myRange.TextRetrievalMode.ViewType = wdOutlineView
MsgBox myRange.Text

In diesem Beispiel werden Feldfunktionen und ausgeblendeter Text von dem Bereich ausgeschlossen, der sich auf den gewählten Text bezieht. Daraufhin wird der Text in einem Meldungsfeld angezeigt.

If Selection.Type = wdSelectionNormal Then
    Set aRange = Selection.Range
    With aRange.TextRetrievalMode
        .IncludeHiddenText = False
        .IncludeFieldCodes = False
    End With
    MsgBox aRange.Text
End If


TextToDisplay-Eigenschaft

Gibt den sichtbaren Text des angegebenen Hyperlinks in einem Dokument zurück oder legt diesen fest. String Schreib-Lese-Zugriff.


Beispiel zur TextToDisplay-Eigenschaft

In diesem Beispiel wird der Anzeigetext für den ersten Hyperlink im aktiven Dokument festgelegt.

ActiveDocument.Hyperlinks(1).TextToDisplay = _
    "Follow this link for more information..."


Texture-Eigenschaft

Gibt eine Struktur für die Schattierung des angegebenen Objekts zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdTextureIndex-Konstanten handeln:

wdTextureAuto

wdTextureSolid

wdTexture2Pt5Percent

wdTexture5Percent

wdTexture7Pt5Percent

wdTexture10Percent

wdTexture12Pt5Percent

wdTexture15Percent

wdTexture17Pt5Percent

wdTexture20Percent

wdTexture22Pt5Percent

wdTexture25Percent

wdTexture27Pt5Percent

wdTexture30Percent

wdTexture32Pt5Percent

wdTexture35Percent

wdTexture37Pt5Percent

wdTexture40Percent

wdTexture42Pt5Percent

wdTexture45Percent

wdTexture47Pt5Percent

wdTexture50Percent

wdTexture52Pt5Percent

wdTexture55Percent

wdTexture57Pt5Percent

wdTexture60Percent

wdTexture62Pt5Percent

wdTexture65Percent

 wdTexture67Pt5Percent

wdTexture70Percent

wdTexture72Pt5Percent

wdTexture75Percent

wdTexture77Pt5Percent

wdTexture80Percent

wdTexture82Pt5Percent

wdTexture85Percent

wdTexture87Pt5Percent

wdTexture90Percent

wdTexture92Pt5Percent

wdTexture95Percent

wdTexture97Pt5Percent

wdTextureDarkHorizontal

wdTextureDarkVertical

wdTextureDarkCross

wdTextureDarkDiagonalCross

wdTextureDarkDiagonalDown

wdTextureDarkDiagonalUp

wdTextureHorizontal

wdTextureVertical

wdTextureCross

wdTextureDiagonalCross

wdTextureDiagonalDown

wdTextureDiagonalUp

wdTextureNone

wdTextureSolid


TextureName-Eigenschaft

Gibt den Namen der benutzerdefinierten Texturdatei für den angegebenen Füllbereich zurück. String Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die UserTextured-Methode zum Festlegen der Texturdatei für den Füllbereich.


Beispiel zur TextureName-Eigenschaft

In diesem Beispiel wird zu myDocument ein Oval hinzugefügt. Wenn Form zwei in myDocument eine benutzerdefinierte Texturfüllung hat, wird das neue Oval die gleiche Füllung haben wie Form zwei. Wenn Form zwei eine andere Füllungsart hat, wird das neue Oval die Füllung "Grüner Marmor" haben.

Set myDocument = ActiveDocument
With myDocument.Shapes
    Set newFill = .AddShape(msoShapeOval, 0, 0, 200, 90).Fill
    With .Item(2).Fill
        If.TextureType = msoTextureUserDefined Then
            newFill.UserTextured .TextureName
        Else
            newFill.PresetTextured msoTextureGreenMarble
        End If
    End With
End With


TextureType-Eigenschaft

Gibt den Texturtyp für den angegebenen Füllbereich zurück. Dies kann eine der folgenden MsoTextureType-Konstanten sein: msoTexturePreset, msoTextureTypeMixed oder msoTextureUserDefined. Long Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetTextured-, UserPicture- oder UserTextured-Methode zum Festlegen des Texturtyps für den Füllbereich.


Beispiel zur TextureType-Eigenschaft

In diesem Beispiel wird für alle Formen in myDocument mit einer benutzerdefinierten Texturfüllung die Füllung in eine Leinentextur umgewandelt.

Set myDocument = ActiveDocument
For Each s In myDocument.Shapes
    With s.Fill
        If .TextureType = msoTextureUserDefined Then
            .PresetTextured msoTextureCanvas
        End If
    End With
Next


TextWrap-Eigenschaft

True, wenn Dokumenttext den angegebenen Rahmen umfließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur TextWrap-Eigenschaft

In diesem Beispiel wird festgelegt, dass Text nicht um den ersten Rahmen im aktiven Dokument fließt.

If ActiveDocument.Frames.Count >= 1 Then
    ActiveDocument.Frames(1).TextWrap = False
End If

In diesem Beispiel wird festgelegt, dass Text alle Rahmen im aktiven Dokument umfließt.

For Each aFrame In ActiveDocument.Frames
    aFrame.TextWrap = True
Next aFrame


 ThemeName-Eigenschaft

ThemeName-Eigenschaft

Gibt den Namen des Designs und alle zur Verfügung stehenden Formatoptionen für das Design von neuen E-Mail-Nachrichten zurück oder legt diese fest. String Schreib-Lese-Zugriff.

Hinweise

Eine Erläuterung des von dieser Eigenschaft zurückgegebenen Wertes finden Sie im Abschnitt zum Name-Argument der ApplyTheme-Methode. Unter Umständen entspricht der von dieser Eigenschaft zurückgegebene Wert nicht dem im Dialogfeld Webdesign (Menü Format, Befehl Design) angezeigten Namen des Designs. Verwenden Sie zum Zurückgeben des angezeigten Namens eines Designs die ActiveThemeDisplayName-Eigenschaft.

Sie können auch die GetDefaultTheme- und SetDefaultTheme-Methode verwenden, um das Standarddesign für neue E-Mail-Nachrichten zurückzugeben oder festzulegen.


Beispiel zur ThemeName-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word für alle neuen E-Mail-Nachrichten das Design "Blaupause" mit lebendigen Farben verwendet.

Application.EmailOptions.ThemeName = "blueprnt 100"


ThreeD-Eigenschaft

Gibt ein ThreeDFormat-Objekt zurück, das 3D-Effekt-Formatierungseigenschaften für die angegebene Form enthält. Nur-Lese-Zugriff.


Beispiel zur ThreeD-Eigenschaft

In diesem Beispiel werden die Tiefe, Projektionsfarbe, Projektionsrichtung und die Beleuchtungsrichtung für die 3D-Effekte festgelegt, die der Form eins in myDocument zugewiesen werden.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .Depth = 50
    ' RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


Top-Eigenschaft

Application-, Task- oder Window-Objekt: Gibt die vertikale Position des aktiven Dokuments (Application) oder des angegebenen Vorgangs oder Fensters in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Shape oder ShapeRange-Objekt: Gibt die vertikale Position (in Punkt) der angegebenen Form oder des Formenbereichs zurück oder legt sie fest. Single. Es kann sich auch um eine der folgenden WdShapePosition-Konstanten handeln: wdShapeTop, wdShapeBottom, wdShapeCenter, wdShapeInside oder wdShapeOutside. Schreib-Lese-Zugriff.

Hinweise

Das Festlegen der Top-Eigenschaft für das Application-Objekt betrifft nur das aktive Dokument.

Die Position einer Form wird von der oberen linken Ecke des Begrenzungsrechtecks der Form zu seiner Verankerung gemessen. Die RelativeVerticalPosition-Eigenschaft steuert, ob die Verankerung der Form an einer Zeile, einem Absatz, am Rand oder an der Seitenkante positioniert wird.

Bei einem ShapeRange-Objekt mit mehreren Formen legt die Top-Eigenschaft die vertikale Position aller Formen fest.


TopLevelTables-Eigenschaft

Gibt eine Tables-Auflistung zurück, die die Tabellen auf der obersten Schachtelungsebene des aktuellen Bereichs bzw. der aktuellen Markierung darstellt. Nur-Lese-Zugriff.

Hinweise

Diese Methode gibt eine Auflistung zurück, die nur die Tabellen auf der obersten Schachtelungsebene im Kontext des aktuellen Bereichs bzw. der aktuellen Markierung enthält. Diese Tabellen befinden sich nicht unbedingt auf der obersten Schachtelungsebene der gesamten Gruppe geschachtelter Tabellen.

Informationen über die Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TopLevelTables-Eigenschaft

In diesem Beispiel wird ein neues Dokument geöffnet, eine geschachtelte Tabelle mit drei Ebenen erstellt und anschließend in die erste Zelle jeder Tabelle ihre Schachtelungsebene eingefügt. Im Beispiel wird die zweite Spalte der Tabelle auf der zweiten Ebene markiert und anschließend die erste Tabelle auf der obersten Ebene in dieser Markierung markiert. Damit wird die innerste Tabelle markiert, obwohl sie im Kontext aller geschachtelten Tabellen nicht zu den Tabellen auf oberster Ebene zählt.

Documents.Add
ActiveDocument.Tables.Add Selection.Range, _
    3, 3, wdWord9TableBehavior, wdAutoFitContent
With ActiveDocument.Tables(1).Range
    .Copy
    .Cells(1).Range.Text = .Cells(1).NestingLevel
    .Cells(5).Range.PasteAsNestedTable
    With .Cells(5).Tables(1).Range
        .Cells(1).Range.Text = .Cells(1).NestingLevel
        .Cells(5).Range.PasteAsNestedTable
        With .Cells(5).Tables(1).Range
            .Cells(1).Range.Text = _
                .Cells(1).NestingLevel
        End With
        .Columns(2).Select
        Selection.TopLevelTables(1).Select
    End With
End With


TopMargin-Eigenschaft

Gibt den Abstand (in Punkt) zwischen der Seitenoberkante und der oberen Begrenzung des Textkörpers zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur TopMargin-Eigenschaft

In diesem Beispiel wird für den ersten Abschnitt des aktiven Dokuments der obere Seitenrand auf 72 Punkt (1 Zoll) eingestellt.

ActiveDocument.Sections(1).PageSetup.TopMargin = 72

In diesem Beispiel wird ein neues benutzerdefiniertes Etikett erstellt, und es werden mehrere Eigenschaften, einschließlich des oberen Seitenrands, eingestellt. Anschließend wird mit Hilfe der benutzerdefinierten Etiketts ein neues Dokument erstellt.

Set newlbl = Application.MailingLabel. _
    CustomLabels.Add(Name:="My Label")
With newlbl
    .Height = InchesToPoints(1.25)
    .NumberAcross = 2
    .NumberDown = 7
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0)
    .TopMargin = InchesToPoints(1)
    .Width = InchesToPoints(4.25)
End With
Application.MailingLabel.CreateNewDocument Name:="My Label"


TopPadding-Eigenschaft

Gibt den Abstand (in Punkt) zurück, der oberhalb des Inhalts einer oder aller Zellen in einer Tabelle eingefügt werden soll, oder legt diesen fest. Single Schreib-Lese-Zugriff.

Hinweise

Durch das Festlegen der TopPadding-Eigenschaft für eine einzelne Zelle wird die Einstellung für die TopPadding-Eigenschaft für die gesamte Tabelle überschrieben.


Beispiel zur TopPadding-Eigenschaft

In diesem Beispiel wird der Abstand über dem Zellinhalt für die erste Tabelle im aktiven Dokument auf 40 Pixel festgelegt.

ActiveDocument.Tables(1).TopPadding = _
    PixelsToPoints(40, True)


Tracking-Eigenschaft

Gibt das Verhältnis des horizontalen Zwischenraums, der für jedes Zeichen im angegebenen WordArt-Objekt festgelegt ist, zur Breite des Zeichens zurück oder legt es fest. Der Wert kann zwischen 0 (null) und 5 liegen. (Ein hoher Wert legt einen großen Abstand zwischen den Zeichen fest; Werte unter 1 können zur Überlappung von Zeichen führen.) Single Schreib-Lese-Zugriff.

Die folgende Tabelle gibt die Werte der Tracking-Eigenschaft wieder, die den in der Benutzeroberfläche zur Verfügung stehenden Einstellungen entsprechen.

Einstellung in Benutzeroberfläche | Äquivalenter Tracking-Eigenschaft-Wert
Sehr eng | 0,8
Eng | 0,9
Normal | 1,0
Lose | 1,2
Sehr Lose | 1,5


Beispiel zur Tracking-Eigenschaft

In diesem Beispiel wird zu myDocument ein WordArt-Objekt hinzugefügt, das den Text "Test" enthält, und spezifiziert, dass die Zeichen sehr eng nebeneinander stehen sollen.

Set myDocument = ActiveDocument
Set newWordArt = _
    myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, _
    Text:="Test", _
    FontName:="Arial Black", FontSize:=36, FontBold:=False, _
    FontItalic:=False, Left:=100, Top:=100)
newWordArt.TextEffect.Tracking = 0.8


TrackRevisions-Eigenschaft

True, wenn Änderungen im angegebenen Dokument überwacht werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur TrackRevisions-Eigenschaft

In diesem Beispiel wird festgelegt, dass Änderungen im aktiven Dokument überwacht und auf dem Bildschirm angezeigt werden.

With ActiveDocument
    .TrackRevisions = True
    .ShowRevisions = True
End With

In diesem Beispiel wird Text eingefügt, wenn der Versionsvergleich deaktiviert ist.

If ActiveDocument.TrackRevisions = False Then
    Selection.InsertBefore "new text"
End If


TrackStatus-Eigenschaft

True, wenn die E-Mail-Nachricht jedes Mal zum ursprünglichen Sender zurückgesandt wird, wenn das Dokument weitergeleitet wird. Boolean Schreib-Lese-Zugriff vor Beginn der Weiterleitung; Boolean Nur-Lese-Zugriff bei der Weiterleitung.


Beispiel zur TrackStatus-Eigenschaft

In diesem Beispiel wird das aktive Dokument mit einer Verteilerliste versehen, zwei Empfänger werden hinzugefügt, Statusmeldungen aktiviert, und dann wird das Dokument weitergeleitet.

ActiveDocument.HasRoutingSlip = True
With ActiveDocument.RoutingSlip
    .AddRecipient Recipient:="James Allard"
    .AddRecipient Recipient:="Rich Andrews"
    .TrackStatus = True
    .Parent.Route
End With


TrailingCharacter-Eigenschaft

Gibt das nach der Zahl der angegebenen Ebenen eingefügte Zeichen zurück oder legt es fest. Dabei kann es sich um eine der folgenden WdTrailingCharacter-Konstanten handeln: wdTrailingNone, wdTrailingSpace oder wdTrailingTab. Long Schreib-Lese-Zugriff.


Beispiel zur TrailingCharacter-Eigenschaft

In diesem Beispiel werden Zahlen und Textausrichtungen für alle Ebenen der sechsten Listenvorlage für Gliederungen festgelegt. Nach der Zahl folgt für alle Ebenen ein Leerzeichen.

r = 0
For Each lev In ListGalleries(wdOutlineNumberGallery) _
        .ListTemplates(6).ListLevels
    lev.Alignment = wdListLevelAlignLeft
    lev.NumberPosition = r
    lev.TextPosition = r
    lev.TrailingCharacter = wdTrailingSpace
    r = r + 18
Next lev


Transparency-Eigenschaft

Gibt den Grad der Transparenz der angegebenen Füllung, des angegebenen Schattens oder der angegebenen Linie als Wert zwischen 0,0 (undurchsichtig) und 1,0 (durchsichtig) zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Anmerkungen

Der Wert dieser Eigenschaft verändert nur einfarbige Füllungen und Linien; er hat keine Auswirkungen auf gestrichelte Linien oder die Fülleffekte "Fließend", "Struktur", "Grafik" und "Muster".


TransparencyColor-Eigenschaft

Gibt die transparente Farbe für die angegebene Grafik als Rot-Grün-Blau-Wert (RGB) zurück oder legt sie fest. Damit diese Eigenschaft wirksam wird, muss die TransparentBackground-Eigenschaft auf True eingestellt sein. Betrifft nur Bitmaps. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie durch die transparenten Teile der Grafik die ganze Strecke zu den Objekten hinter der Grafik sehen wollen, müssen Sie die Visible-Eigenschaft des FillFormat-Objekts der Grafik auf False einstellen. Wenn Ihre Grafik eine transparente Farbe hat und die Visible-Eigenschaft des FillFormat-Objekts der Grafik auf True eingestellt ist, wird die Füllung der Grafik durch die transparente Farbe sichtbar sein, aber Objekte hinter der Grafik werden verdeckt.


Beispiel zur TransparencyColor-Eigenschaft

In diesem Beispiel wird die Farbe, deren RGB-Wert von der Funktion RGB(0, 0, 255) zurückgegeben wird, als transparente Farbe für Form eins in myDocument festgelegt. Damit das Beispiel funktioniert, muss Form eins eine Bitmap sein.

blueScreen = RGB(0, 0, 255)
Set myDocument = ActiveDocument
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


TransparentBackground-Eigenschaft

True, wenn die Teile der Grafik in der Farbe, die als transparente Farbe festgelegt wurde, transparent erscheinen. Verwenden Sie die TransparencyColor-Eigenschaft zum Festlegen der transparenten Farbe. Dies betrifft nur Bitmaps. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie durch die transparenten Teile der Grafik die ganze Strecke zu den Objekten hinter der Grafik sehen wollen, müssen Sie die Visible-Eigenschaft des FillFormat-Objekts der Grafik auf False einstellen. Wenn Ihre Grafik eine transparente Farbe hat und die Visible-Eigenschaft des FillFormat-Objekts der Grafik auf True eingestellt ist, wird die Füllung der Grafik durch die transparente Farbe sichtbar sein, aber Objekte hinter der Grafik werden verdeckt.


Beispiel zur TransparentBackground-Eigenschaft

In diesem Beispiel wird die Farbe, deren RGB-Wert von der Funktion RGB(0, 0, 240) zurückgegeben wird, als transparente Farbe für Form eins in myDocument festgelegt. Damit das Beispiel funktioniert, muss Form eins eine Bitmap sein.

blueScreen = RGB(0, 0, 255)
Set myDocument = ActiveDocument
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


TwoInitialCapsAutoAdd-Eigenschaft

True, wenn Word automatisch Begriffe in die Liste der AutoKorrektur-Ausnahmen Wortanfang Groß aufnimmt. Ein Begriff wird automatisch in diese Liste aufgenommen, wenn Sie den Großbuchstaben, den Word in einen Kleinbuchstaben umgewandelt hat (der dem großgeschriebenen Anfangsbuchstaben folgt), löschen und neu eingeben. Boolean Schreib-Lese-Zugriff.


Beispiel zur TwoInitialCapsAutoAdd-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Begriffe automatisch in die Liste der AutoKorrektur-Ausnahmen Wortanfang Groß aufgenommen werden.

AutoCorrect.TwoInitialCapsAutoAdd = True


TwoInitialCapsExceptions-Eigenschaft

Gibt eine TwoInitialCapsExceptions-Sammlung zurück, die die Liste mit Begriffen der gemischten Groß-/Kleinschreibung darstellt, die Word nicht automatisch korrigiert. Diese Liste entspricht der Liste der AutoKorrektur-Ausnahmen auf der Registerkarte WOrtanfang GRoss im Dialogfeld AutoKorrektur-Ausnahmen (Befehl AutoKorrektur, Menü Extras). Nur-Lese-Zugriff.

Weitere Informationen hierzu finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur TwoInitialCapsExceptions-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, jede AutoKorrektur-Ausnahme in WOrtanfang GRoss zu löschen oder zu behalten.

For Each anEntry In AutoCorrect.TwoInitialCapsExceptions
    response = MsgBox ("Delete entry: " _
        & anEntry.Name, vbYesNoCancel)
    If response = vbYes Then
        anEntry.Delete
    Else
        If response = vbCancel Then End
    End If
Next anEntry


TwoLinesInOne-Eigenschaft

Sprachspezifische Informationen

Returns or sets whether Microsoft Word sets two lines of text in one and specifies the characters that enclose the text, if any. Can be one of the following WdTwoLinesInOneType constants: wdTwoLinesInOneAngleBrackets, wdTwoLinesInOneCurlyBrackets, wdTwoLinesInOneNoBrackets, wdTwoLinesInOneNone, wdTwoLinesInOneParentheses, or wdTwoLinesInOneSquareBrackets. Read/write Long.

Remarks

Setting the TwoLinesInOne property to wdTwoLinesInOneNoBrackets sets two lines of text in one without enclosing the text in any characters. Setting the TwoLinesInOne property to wdTwoLinesInOneNone restores a line of combined text to two separate lines.

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur TwoLinesInOne-Eigenschaft

This example formats the current selection as two lines of text in one, enclosed in parentheses.

Selection.Range.TwoLinesInOne = _
    wdTwoLinesInOneParentheses


TwoPagesOnOne-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word prints the specified document two pages per sheet. Read/write Boolean.


Beispiel zur TwoPagesOnOne-Eigenschaft

This example sets Microsoft Word to print the active document two pages per sheet.

ActiveDocument.PageSetup.TwoPagesOnOne = True


Type-Eigenschaft

Gibt den Typ des angegebenen Dokuments zurück oder legt ihn fest, wie in der folgenden Tabelle beschrieben.

Objekt | Beschreibung
CalloutFormat | Gibt den Legendentyp zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden MsoCalloutType-Konstanten handeln: msoCalloutOne, msoCalloutTwo, msoCalloutThree, msoCalloutFour oder msoCalloutMixed. Long Schreib-Lese-Zugriff.
ColorFormat | Gibt den Farbtyp der Form zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden MsoColorType-Konstanten handeln: msoColorTypeMixed, msoColorTypeRGB oder msoColorTypeScheme. Long Nur-Lese-Zugriff.
Dialog | Gibt den Typ des integrierten Dialogfelds von Microsoft Word zurück. Dabei kann es sich um eine der WdWordDialog-Konstanten handeln. Long Nur-Lese-Zugriff.
Dictionary | Gibt den Typ des Wörterbuchs zurück. Dabei kann es sich um folgende WdDictionaryType-Konstanten handeln: wdGrammar, wdHangulHanjaConversion, wdHangulHanjaConversionCustom, wdHyphenation, wdSpelling, wdSpellingComplete, wdSpellingCustom, wdSpellingLegal, wdSpellingMedical oder wdThesaurus. Long Nur-Lese-Zugriff. Einige Konstanten stehen Ihnen abgängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise Deutsch) möglicherweise nicht zur Verfügung.
Document | Gibt den Dokumenttyp zurück (Dokumentvorlage oder Dokument). Dabei kann es sich um eine der folgenden WdDocumentType-Konstanten handeln: wdTypeDocument, wdTypeFrameset oder wdTypeTemplate. Long Nur-Lese-Zugriff.
Field, FormField, MailMergeField | Gibt den Feldtyp zurück. Dabei kann es sich um eine der WdFieldType-Konstanten handeln. Long Nur-Lese-Zugriff.
FillFormat | Gibt den Typ der Füllung für die Form zurück. Dabei kann es sich um eine der folgenden MsoFillType-Konstanten handeln: msoFillBackground, msoFillGradient, msoFillMixed, msoFillPatterned, msoFillPicture, msoFillSolid oder msoFillTextured. Long Nur-Lese-Zugriff.
Frameset | Gibt den Typ des Frameset-Objekts zurück. Dabei kann es sich um eine der folgenden WdFramesetType-Konstanten handeln: wdFramesetTypeFrame oder wdFramesetTypeFrameset. Long Nur-Lese-Zugriff.
Hyperlink | Gibt den Typ des Hyperlinks zurück. Dabei kann es sich um eine der folgenden MsoHyperlinkType-Konstanten handeln: msoHyperlinkInlineShape, msoHyperlinkRange oder msoHyperlinkShape. Long Nur-Lese-Zugriff.
Index | Gibt den Indextyp zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden WdIndexType-Konstanten handeln: wdIndexIndent oder wdIndexRunin. Long Schreib-Lese-Zugriff.
InlineShape | Gibt den Typ der eingebetteten Form zurück. Dabei kann es sich um eine der folgenden WdInlineShapeType-Konstanten handeln: wdInlineShapeEmbeddedOLEObject, wdInlineShapeHorizontalLine, wdInlineShapeLinkedOLEObject, wdInlineShapeLinkedPicture, wdInlineShapeLinkedPictureHorizontalLine, wdInlineShapeOLEControlObject, wdInlineShapeOWSAnchor, wdInlineShapePicture, wdInlineShapePictureBullet, wdInlineShapePictureHorizontalLine oder wdInlineShapeScriptAnchor. Long Nur-Lese-Zugriff.
LinkFormat | Gibt den Typ der Verknüpfung zurück. Dabei kann es sich um eine der folgenden WdLinkType-Konstanten handeln: wdLinkTypeDDE, wdLinkTypeDDEAuto, wdLinkTypeImport, wdLinkTypeInclude, wdLinkTypeOLE, wdLinkTypePicture, wdLinkTypeReference oder wdLinkTypeText. Long Nur-Lese-Zugriff.
MailMergeDataSource | Gibt den Typ der Datenquelle für den Seriendruck zurück. Dabei kann es sich um eine der folgenden WdMailMergeDataSource-Konstanten handeln: wdMergeInfoFromAccessDDE, wdMergeInfoFromExcelDDE, wdMergeInfoFromMSQueryDDE, wdMergeInfoFromODBC, wdMergeInfoFromWord oder wdNoMergeInfo. Long Nur-Lese-Zugriff.
ProofreadingErrors | Gibt den Typ des Editierfehlers zurück. Dabei kann es sich um eine der folgenden WdProofreadingErrorType-Konstanten handeln: wdGrammaticalError oder wdSpellingError. Long Nur-Lese-Zugriff.
Revision | Gibt den Typ der Korrektur zurück. Dabei kann es sich um eine der folgenden WdRevisionType-Konstanten handeln: wdNoRevision, wdRevisionDelete, wdRevisionDisplayField, wdRevisionInsert, wdRevisionParagraphNumber, wdRevisionProperty, wdRevisionReconcile, wdRevisionReplace oder wdRevisionStyle. Long Nur-Lese-Zugriff.
Selection | Gibt den Typ der Markierung zurück. Dabei kann es sich um eine der folgenden WdSelectionType-Konstanten handeln: wdNoSelection, wdSelectionBlock, wdSelectionColumn, wdSelectionFrame, wdSelectionInlineShape, wdSelectionIP, wdSelectionNormal, wdSelectionRow oder wdSelectionShape. Long Nur-Lese-Zugriff.
ShadowFormat | Gibt den Typ des Formschattens zurück oder legt ihn fest. Dabei kann es sich um folgende MsoShadowType-Konstanten handeln: msoShadow1, msoShadow2, msoShadow3, msoShadow4, msoShadow5, msoShadow6, msoShadow7, msoShadow8, msoShadow9, msoShadow10, msoShadow11, msoShadow12, msoShadow13, msoShadow14, msoShadow15, msoShadow16, msoShadow17, msoShadow18, msoShadow19, msoShadow20 oder msoShadowMixed. Long Nur-Lese-Zugriff.
Shape, ShapeRange | Gibt den Typ der Form zurück. Dabei kann es sich um eine der folgenden MsoShapeType-Konstanten handeln: msoAutoShape, msoCallout, msoChart, msoComment, msoEmbeddedOLEObject, msoFormControl, msoFreeform, msoGroup, msoLine, msoLinkedOLEObject, msoLinkedPicture, msoMedia, msoOLEControlObject, msoPicture, msoPlaceholder, msoScriptAnchor, msoShapeTypeMixed, msoTable, msoTextBox oder msoTextEffect. Long Nur-Lese-Zugriff.
Style | Gibt den Typ der Formatvorlage zurück. Dabei kann es sich um eine der folgenden WdStyleType-Konstanten handeln: wdStyleTypeParagraph oder wdStyleTypeCharacter. Long Nur-Lese-Zugriff.
Template | Gibt den Typ der Dokumentvorlage zurück. Dabei kann es sich um eine der folgenden WdTemplateType-Konstanten handeln: wdAttachedTemplate, wdGlobalTemplate oder wdNormalTemplate. Long Nur-Lese-Zugriff.
TextInput | Gibt den Typ des Textformularfeldes zurück. Dabei kann es sich um eine der folgenden WdTextFormFieldType-Konstanten handeln: wdCalculationText, wdCurrentDateText, wdCurrentTimeText, wdDateText, wdNumberText oder wdRegularText. Long Nur-Lese-Zugriff.
View | Gibt den Typ der Ansicht zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden WdViewType-Konstanten handeln: wdMasterView, wdNormalView, wdOutlineView, wdPrintPreview, wdPrintView oder wdWebView. Long Schreib-Lese-Zugriff.
Window | Gibt den Fenstertyp zurück. Dabei kann es sich um eine der folgenden WdWindowType-Konstanten handeln: wdWindowDocument oder wdWindowTemplate. Long Nur-Lese-Zugriff.
WrapFormat | Gibt den Textflusstyp für die angegebene Form zurück. Dabei kann es sich um eine der folgenden WdWrapType-Konstanten handeln: wdWrapNone, wdWrapSquare, wdWrapThrough, wdWrapTight oder wdWrapTopBottom. Long Schreib-Lese-Zugriff.


Beispiel zur Type-Eigenschaft

Wenn es sich beim aktiven Fenster um ein Dokument handelt, wird in diesem Beispiel die Formatvorlage für Überschrift 1 als zentriert neu definiert.

If ActiveDocument.ActiveWindow.Type = wdWindowDocument Then
    ActiveDocument.Styles("Heading 1") _
        .ParagraphFormat.Alignment = wdAlignParagraphCenter
End If

In diesem Beispiel wechselt das aktive Fenster zur Seitenansicht. Mit der Type-Eigenschaft wird ein neues Fenster für die Seitenansicht angelegt.

ActiveDocument.ActiveWindow.View.Type = wdPrintPreview

In diesem Beispiel wird eine Meldung angezeigt, die den Typ der Formatvorlage "SubTitle" im aktiven Dokument angibt.

If ActiveDocument.Styles("SubTitle").Type = _
        wdStyleTypeParagraph Then
    MsgBox "Paragraph style"
ElseIf ActiveDocument.Styles("SubTitle").Type = _
        wdStyleTypeCharacter Then
    MsgBox "Character style"
End If

In diesem Beispiel wird die nächste Korrektur im aktiven Dokument übernommen, wenn es sich beim Korrekturtyp um eingefügten Text handelt.

Set myRev = Selection.NextRevision
If Not (myRev Is Nothing) Then
    If myRev.Type = wdRevisionInsert Then myRev.Accept
End If

In diesem Beispiel wird die Markierung graviert formatiert, wenn es sich bei der Markierung nicht um eine Einfügemarke handelt.

If Selection.Type <> wdSelectionIP Then
    Selection.Font.Engrave = True
Else
    MsgBox "You need to select some text."
End If


Underline-Eigenschaft

Gibt die Art der Unterstreichung einer Schriftart oder eines Bereichs zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdUnderline-Konstanten handeln:

wdUnderlineDash

wdUnderlineDashHeavy

wdUnderlineDashLong

wdUnderlineDashLongHeavy

wdUnderlineDotDash

wdUnderlineDotDashHeavy

wdUnderlineDotDotDash

wdUnderlineDotDotDashHeavy

wdUnderlineDotted

 wdUnderlineDottedHeavy

wdUnderlineDouble

wdUnderlineNone

wdUnderlineSingle

wdUnderlineThick

wdUnderlineWavy

wdUnderlineWavyDouble

wdUnderlineWavyHeavy

wdUnderlineWords


UnderlineColor-Eigenschaft

Gibt die 24-Bit-Farbe der Unterstreichung für das angegebene Font-Objekt zurück oder legt sie fest. Dabei kann es sich um eine beliebige gültige WdColor-Konstante oder um einen von der RGB-Funktion zurückgegebenen Wert handeln. Long Schreib-Lese-Zugriff.

Hinweise

Eine Liste der gültigen WdColor-Konstanten finden Sie im Objektkatalog des Visual Basic-Editors.

Durch Festlegen der UnderlineColor-Eigenschaft auf wdColorAutomatic wird die Farbe der Unterstreichung wieder auf die Farbe des darüberstehenden Textes gesetzt.


Beispiel zur UnderlineColor-Eigenschaft

In diesem Beispiel wird das dritte Wort im aktiven Dokument doppelt unterstrichen und die Farbe der Unterstreichung auf Türkis gesetzt.

With ActiveDocument.Words(3)
    .Underline = wdUnderlineDouble
    .Font.UnderlineColor = wdColorTurquoise
End With


Uniform-Eigenschaft

True, wenn alle Zeilen in einer Tabelle dieselbe Anzahl Spalten haben. Boolean Nur-Lese-Zugriff.


Beispiel zur Uniform-Eigenschaft

In diesem Beispiel wird eine Tabelle erstellt, die eine geteilte Zelle enthält, und dann wird ein Meldungsfeld angezeigt, das bestätigt, dass die Tabelle nicht dieselbe Anzahl Spalten in jeder Zeile hat.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 5, 5)
myTable.Cell(3, 3).Split 1, 2
If myTable.Uniform = False Then MsgBox "Table is not uniform"

In diesem Beispiel wird ermittelt, ob die Tabelle, die die Markierung enthält, in jeder Zeile dieselbe Anzahl Spalten hat.

If Selection.Information(wdWithInTable) = True Then
    MsgBox Selection.Tables(1).Uniform
End If


UpdateFieldsAtPrint-Eigenschaft

True, wenn Word automatisch Felder vor dem Drucken des Dokuments aktualisiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur UpdateFieldsAtPrint-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass Felder automatisch vor dem Drucken aktualisiert werden, und dann wird das aktive Dokument gedruckt.

Options.UpdateFieldsAtPrint = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Felder aktualisieren auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.UpdateFieldsAtPrint


UpdateLinksAtOpen-Eigenschaft

True, wenn Word automatisch alle eingebetteten OLE-Verknüpfungen beim Öffnen eines Dokuments aktualisiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur UpdateLinksAtOpen-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass alle eingebetteten OLE-Verknüpfungen beim Öffnen einer Datei aktualisiert werden.

Options.UpdateLinksAtOpen = True

In diesem Beispiel wird der aktuelle Status der Option Verknüpfungen beim Öffnen aktualisieren auf der Registerkarte Allgemein im Dialogfeld Optionen zurückgegeben.

temp = Options.UpdateLinksAtOpen


UpdateLinksAtPrint-Eigenschaft

True, wenn Word eingebettete Verknüpfungen zu anderen Dateien vor dem Drucken eines Dokuments aktualisiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur UpdateLinksAtPrint-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass eingebettete Verknüpfungen vor dem Drucken aktualisiert werden, und dann wird das aktive Dokument gedruckt.

Options.UpdateLinksAtPrint = True
ActiveDocument.PrintOut

In diesem Beispiel wird der aktuelle Status der Option Verknüpfungen aktualisieren auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

temp = Options.UpdateLinksAtPrint


UpdateLinksOnSave-Eigenschaft

True, wenn Hyperlinks und Pfade zu allen Hilfsdateien vor dem Speichern des Dokuments als Webseite automatisch aktualisiert werden. Dadurch wird gewährleistet, dass die Verknüpfungen beim Speichern auf dem neuesten Stand sind. False, wenn die Verknüpfungen nicht aktualisiert werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Sie sollten diese Eigenschaft auf False setzen, wenn der Speicherort des Dokuments und der endgültige Speicherort auf dem Webserver nicht identisch sind und die Hilfsdateien am ersten Speicherort nicht zur Verfügung stehen.


Beispiel zur UpdateLinksOnSave-Eigenschaft

In diesem Beispiel wird festgelegt, dass Verknüpfungen vor dem Speichern des Dokuments nicht aktualisiert werden.

Application.DefaultWebOptions.UpdateLinksOnSave = False


UpdateStylesOnOpen-Eigenschaft

True, wenn die Formatvorlagen im angegebenen Dokument bei jedem Öffnen des Dokuments an die Formatvorlagen in der verbundenen Dokumentvorlage angepasst werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur UpdateStylesOnOpen-Eigenschaft

In diesem Beispiel wird die Option zum Aktualisieren der Formatvorlagen für alle geöffneten Dokumente aktiviert, dann werden die Dokumente geschlossen. Wenn diese Dokumente wieder geöffnet werden, werden Änderungen an den Formatvorlagen in der verbundenen Dokumentvorlage automatisch im Dokument angezeigt.

For Each doc In Documents
    doc.UpdateStylesOnOpen = True
    doc.Close SaveChanges:=wdSaveChanges
Next doc

In diesem Beispiel wird die Option zum Aktualisieren der Formatvorlagen eines Dokuments deaktiviert, damit sich Änderungen an den Formatvorlagen in der verbundenen Dokumentvorlage nicht in der Datei "Bericht.doc" auswirken.

Documents("Report.doc").UpdateStylesOnOpen = False


UpperHeadingLevel-Eigenschaft

Gibt die Start-Überschriftsebene für ein Inhaltsverzeichnis oder Abbildungsverzeichnis zurück oder legt sie fest. Entspricht dem Startwert, der mit dem Schalter \o für ein TOC-Feld verwendet wird. Long Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie die LowerHeadingLevel-Eigenschaft zum Einstellen der End-Überschriftsebene. Soll beispielsweise für das TOC-Feld die Syntax {TOC \o "1-3"} eingestellt werden, stellen Sie die LowerHeadingLevel-Eigenschaft auf 3 ein und die UpperHeadingLevel-Eigenschaft auf 1.


Beispiel zur UpperHeadingLevel-Eigenschaft

In diesem Beispiel wird das erste Inhaltsverzeichnis im aktiven Dokument so formatiert, dass alle Überschriften, die mit den Formatvorlagen Überschrift 2 oder Überschrift 3 formatiert sind, zusammengestellt werden.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .UseHeadingStyles = True
        .UseFields = False
        .UpperHeadingLevel = 2
        .LowerHeadingLevel = 3
    End With
End If


UsableHeight-Eigenschaft

Application-Objekt: Gibt die maximale Höhe (in Punkt) zurück, die für ein Microsoft Word-Dokumentfenster festgelegt werden kann. Long Nur-Lese-Zugriff.

Window-Objekt: Gibt die Höhe (in Punkt) des aktiven Arbeitsbereichs im angegebenen Dokumentfenster zurück. Long Nur-Lese-Zugriff. Wenn der Arbeitsbereich im Dokumentfenster nicht sichtbar ist, gibt UsableHeight 1 zurück. Die tatsächlich verfügbare Höhe ergibt sich aus dem UsableHeight-Wert minus 1.


Beispiel zur UsableHeight-Eigenschaft

In diesem Beispiel wird die Größe des aktiven Dokumentfensters auf ein Viertel der maximalen Bildschirmgröße festgelegt.

With ActiveDocument.ActiveWindow
    .WindowState = wdWindowStateNormal
    .Top = 5
    .Left = 5
    .Height = (Application.UsableHeight*0.5)
    .Width = (Application.UsableWidth*0.5)
End With

In diesem Beispiel wird die Größe des Arbeitsbereichs im aktiven Dokumentfenster angezeigt.

With ActiveDocument.ActiveWindow
    MsgBox "Working area height = " _
        & .UsableHeight & vbLf _
        & "Working area width = " _
        & .UsableWidth
End With


UsableWidth-Eigenschaft

Application-Objekt: Gibt die maximale Breite (in Punkt) zurück, die für ein Microsoft Word-Dokumentfenster festgelegt werden kann. Long Nur-Lese-Zugriff.

Window-Objekt: Gibt die Breite (in Punkt) des aktiven Arbeitsbereichs im angegebenen Dokumentfenster zurück. Long Nur-Lese-Zugriff. Wenn der Arbeitsbereich im Dokumentfenster nicht sichtbar ist, gibt UsableWidth 1 zurück. Die tatsächlich verfügbare Größe ergibt sich aus dem UsableWidth-Wert minus 1.


Beispiel zur UsableWidth-Eigenschaft

In diesem Beispiel wird die Größe des aktiven Dokumentfensters auf ein Viertel der maximalen Bildschirmgröße festgelegt.

With ActiveDocument.ActiveWindow
    .WindowState = wdWindowStateNormal
    .Top = 5
    .Left = 5
    .Height = (Application.UsableHeight*0.5)
    .Width = (Application.UsableWidth*0.5)
End With

In diesem Beispiel wird die Größe des Arbeitsbereichs im aktiven Dokumentfenster angezeigt.

With ActiveDocument.ActiveWindow
    MsgBox "Working area height = " _
        & .UsableHeight & vbLf _
        & "Working area width = " _
        & .UsableWidth
End With


UseCharacterUnit-Eigenschaft

Sprachspezifische Informationen

True if Microsoft Word uses characters as the default measurement unit for the current document. Read/write Boolean.

Remarks

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur UseCharacterUnit-Eigenschaft

This example sets Word to use characters as the default measurement unit.

Options.UseCharacterUnit = True


UseDiffDiacColor-Eigenschaft

Sprachspezifische Informationen

True if you can set the color of diacritics in the current document. Read/write Boolean.

Remarks

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur UseDiffDiacColor-Eigenschaft

This example checks the UseDiffDiacColor property before setting the color of diacritics in the current selection.

If Options.UseDiffDiacColor = True Then _
    Selection.Font.DiacriticColor = wdColorBlue


UseFields-Eigenschaft

True, wenn zum Erstellen eines Inhaltsverzeichnisses oder eines Abbildungsverzeichnisses TC-Felder verwendet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur UseFields-Eigenschaft

In diesem Beispiel wird das erste Inhaltsverzeichnis im aktiven Dokument so formatiert, dass Überschrift-Formatvorlagen an Stelle von TC-Feldern verwendet werden.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .UseFields = False
        .UseHeadingStyles = True
    End With
End If

In diesem Beispiel wird nach der Markierung ein Abbildungsverzeichnis hinzugefügt und das Verzeichnis so formatiert, dass Einträge mit der Kennung "B" zusammengestellt werden.

Selection.Collapse Direction:=wdCollapseEnd
Set myTOF = ActiveDocument.TablesOfFigures _
    .Add(Range:=Selection.Range)
With myTOF
    .UseFields = True
    .TableId = "B"
    .Caption = ""
End With


UseGermanSpellingReform-Eigenschaft

True, wenn Microsoft Word bei der Rechtschreibprüfung die neuen Regeln gemäß der deutschen Rechtschreibreform verwendet. Boolean Schreib-Lese-Zugriff.

Hinweise

Diese Eigenschaft steht Ihnen abhängig von der ausgewählten bzw. installierten Sprachunterstützung (beispielsweise US-Englisch) möglicherweise nicht zur Verfügung.


Beispiel zur UseGermanSpellingReform-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word bei der Rechtschreibprüfung die neuen Regeln gemäß der deutschen Rechtschreibreform verwendet.

Options.UseGermanSpellingReform = True


UseHeadingStyles-Eigenschaft

True, wenn zum Erstellen eines Inhaltsverzeichnisses oder eines Abbildungsverzeichnisses integrierte Überschrift-Formatvorlagen verwendet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur UseHeadingStyles-Eigenschaft

In diesem Beispiel wird das erste Inhaltsverzeichnis im aktiven Dokument so formatiert, dass Einträge, die mit der Formatvorlage Überschrift 1, Überschrift 2 oder Überschrift 3 formatiert sind, zusammengestellt werden.

If ActiveDocument.TablesOfContents.Count >= 1 Then
    With ActiveDocument.TablesOfContents(1)
        .UseHeadingStyles = True
        .UseFields = False
        .UpperHeadingLevel = 1
        .LowerHeadingLevel = 3
    End With
End If

In diesem Beispiel wird an Stelle der Markierung ein Abbildungsverzeichnis hinzugefügt und dann das Verzeichnis so formatiert, dass Einträge aus TC-Feldern zusammengestellt werden.

With ActiveDocument.TablesOfFigures.Add(Range:=Selection.Range)
    .UseHeadingStyles = False
    .UseFields = True
End With


UseHyperlinks-Eigenschaft

Gibt zurück oder legt fest, ob die Einträge in einem Inhalts- oder Abbildungsverzeichnis bei der Veröffentlichung im Web als Hyperlinks formatiert werden sollen. Boolean Schreib-Lese-Zugriff.


Beispiel zur UseHyperlinks-Eigenschaft

In diesem Beispiel werden die Einträge im ersten Inhaltsverzeichnis des Dokuments vor der Veröffentlichung im Web als Hyperlinks formatiert.

ActiveDocument.TableOfContents(1).UseHyperlinks = True


UseLongFileNames-Eigenschaft

True, wenn beim Speichern des Dokuments als Webseite lange Dateinamen verwendet werden. False, wenn anstelle der langen Dateinamen das DOS-Dateiformat (8.3) verwendet wird. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Hinweise

Wenn Sie keine langen Dateinamen verwenden und für Ihr Dokument Hilfsdateien bestehen, werden diese Dateien von Microsoft Word automatisch in einem separaten Ordner abgelegt. Verwenden Sie andernfalls die OrganizeInFolder-Eigenschaft, um festzulegen, ob Hilfsdateien in einem separaten Ordner organisiert werden sollen.


Beispiel zur UseLongFileNames-Eigenschaft

In diesem Beispiel wird als globale Standardeinstellung festgelegt, dass keine langen Dateinamen verwendet werden.

Application.DefaultWebOptions.UseLongFileNames = False


UserAddress-Eigenschaft

Gibt die Adresse des Benutzers zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Anmerkungen

Die Adresse wird als Absenderadresse auf Umschlägen verwendet.


Beispiel zur UserAddress-Eigenschaft

In diesem Beispiel wird die Absenderadresse des Benutzers festgelegt. Die Funktion Chr wird zur Ausgabe eines Zeilenvorschub-Zeichens verwendet.

Application.UserAddress = "4200 Third Street NE" & Chr(10) _
    & "Anytown, WA  98999"

In diesem Beispiel wird die Adresse zurückgegeben, die in der Option Adresse auf der Registerkarte Benutzer-Info im Dialogfeld Optionen gefunden wurde.

Msgbox Application.UserAddress


UserControl-Eigenschaft

True, wenn das Dokument oder die Anwendung vom Benutzer erstellt oder geöffnet wurden. False, wenn das Dokument oder die Anwendung mit Hilfe eines Programms von einer anderen Office-Anwendung aus mit der Open-Methode, der CreateObject- oder der GetObject-Methode erstellt oder geöffnet wurden. Boolean Schreib-Lese-Zugriff für das Document-Objekt; Boolean Nur-Lese-Zugriff für das Application-Objekt.

Hinweise

Wenn Word für den Benutzer sichtbar ist, oder Sie die UserControl-Eigenschaft eines Word Application- oder Document-Objekts von einem Word-Codemodul aus aufrufen, gibt diese Eigenschaft immer True zurück.


Beispiel zur UserControl-Eigenschaft

In diesem Beispiel wird der Status der UserControl-Eigenschaft für das aktive Dokument angezeigt. Dieses Beispiel läßt sich nur dann fehlerfrei anwenden, wenn es von einer anderen Office-Anwendung aus durchgeführt wird und die Objekt-Bibliothek von Word 9.0 geladen ist.

Set wd = New Word.Application
Set wdDoc = _
    wd.Documents.Open("C:\My Documents\doc1.doc")
If wdDoc.UserControl = True Then
    MsgBox "This document was created or opened by the user."
Else
    MsgBox "This document was created programmatically."
End If


UserInitials-Eigenschaft

Gibt die Initialen des Benutzers zurück oder legt sie fest, die Word zum Aufbau von Anmerkungszeichen verwendet. String Schreib-Lese-Zugriff.


Beispiel zur UserInitials-Eigenschaft

In diesem Beispiel werden die Initialen des Benutzers festgelegt.

Application.UserInitials = "baa"

In diesem Beispiel werden die Buchstaben zurückgegeben, die in der Option Initialen auf der Registerkarte Benutzer Info im Dialogfeld Optionen gefunden wurden.

Msgbox Application.UserInitials


UserName-Eigenschaft

Gibt den Namen des Benutzers zurück oder legt ihn fest, der auf Umschlägen und als Dokumenteigenschaft "Autor" verwendet wird. String Schreib-Lese-Zugriff.


Beispiel zur UserName-Eigenschaft

In diesem Beispiel wird der Name des Benutzers festgelegt.

Application.UserName = "Andrew Fuller"

In diesem Beispiel wird der Name zurückgegeben, der in der Option Name auf der Registerkarte Benutzer Info im Dialogfeld Optionen gefunden wurde.

Msgbox Application.UserName


 UseThemeStyle-Eigenschaft

UseThemeStyle-Eigenschaft

True, wenn die im Standarddesign für E-Mail-Nachrichten festgelegte Zeichenformatvorlage in neuen E-Mail-Nachrichten verwendet wird. Wenn kein Standarddesign für E-Mail-Nachrichten festgelegt wurde, bleibt diese Eigenschaft wirkungslos. Boolean Schreib-Lese-Zugriff.


Beispiel zur UseThemeStyle-Eigenschaft

In diesem Beispiel wird das Design Artsy als Standarddesign für neue E-Mail-Nachrichten in Microsoft Word festgelegt, und es werden die in diesem Design festgelegten Zeichenformatvorlagen verwendet.

Application.EmailOptions.ThemeName = "artsy"
Application.EmailOptions.UseThemeStyle = True


Valid-Eigenschaft

CheckBox-, DropDown- oder TextInput-Objekt: True, wenn das angegebene Formularfeld-Objekt ein zulässiges Kontrollkästchen-Formularfeld, Dropdown-Formularfeld oder Textformularfeld ist. False, wenn es unzulässig ist. Boolean Nur-Lese-Zugriff.

CustomLabel-Objekt: True, wenn die verschiedenen Eigenschaften (beispielsweise Height, Width und NumberDown) für das angegebene benutzerdefinierte Etikett in ihrer Gesamtheit ein gültiges Adressetikett ergeben.

Hinweise

Verwenden Sie die Type-Eigenschaft des FormField-Objekts zum Bestimmen des Formularfeldtyps (gibt wdFieldFormCheckBox, wdFieldFormDropDown oder wdFieldFormTextInput zurück), bevor Sie die CheckBox-, DropDown- oder TextInput-Eigenschaft zuweisen. Diese Vorsichtsmaßnahme stellt sicher, dass das FormField-Objekt vom erwarteten Typ ist. Wenn das erste Formularfeld im aktiven Dokument ein Kontrollkästchen ist, wird im folgenden Beispiel das Kontrollkästchen markiert.

If ActiveDocument.FormFields(1).Type = wdFieldFormCheckBox Then
    ActiveDocument.FormFields(1).CheckBox.Value = True
End If


Beispiel zur Valid-Eigenschaft

In diesem Beispiel wird ermittelt, ob das erste Formularfeld im aktiven Dokument ein Textformularfeld ist. Wenn die Valid-Eigenschaft True ist, wird der Inhalt des Textformularfelds in "Hello" geändert.

If ActiveDocument.FormFields(1).TextInput.Valid = True Then
    ActiveDocument.FormFields(1).Result = "Hello"
End If

In diesem Beispiel wird an der Einfügemarke ein Textformularfeld hinzugefügt. Weil myFormField kein gültiges Kontrollkästchen-Formularfeld ist, zeigt das Meldungsfeld "False" an.

Selection.Collapse Direction:=wdCollapseStart
Set myFormField = ActiveDocument.FormFields.Add(Range:= _
    Selection.Range, Type:=wdFieldFormTextInput)
MsgBox myFormField.CheckBox.Valid

Wenn die Einstellungen für das benutzerdefinierte Etikett "My Labels" gültig sind, wird in diesem Beispiel ein neues Dokument von Etiketten erstellt, wobei die Einstellungen von "My Labels" verwendet werden.

addr = "James Allard" & vbCr & "123 Main St." & vbCr _
    & "Seattle, WA  98040"
If Application.MailingLabel.CustomLabels("My Labels") _
        .Valid = True Then
    Application.MailingLabel.CreateNewDocument _
        Name:="My Labels", Address:=addr
End If


Value-Eigenschaft

AutoCorrectEntry-, AutoTextEntry oder Variable-Objekt: Gibt den Wert des AutoCorrect-Eintrags, des AutoText-Eintrags oder der Dokumentvariablen zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

CheckBox-Objekt: True, wenn das Kontrollkästchen aktiviert ist. Boolean Schreib-Lese-Zugriff.

DropDown-Objekt: Gibt die Nummer des ausgewählten Elements in einem Dropdown-Formularfeld zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

MailMergeDataField-Objekt: Gibt den Inhalt des Seriendruck-Datenfelds für den aktuellen Datensatz zurück. Mit der ActiveRecord-Eigenschaft können Sie den aktiven Datensatz in einer Seriendruck-Datenquelle festlegen. String Nur-Lese-Zugriff.

ReadabilityStatistic-Objekt: Gibt den Wert der Grammatikstatistik zurück. Single Nur-Lese-Zugriff.

Hinweise

Für AutoCorrectEntry- und AutoTextEntry-Objekte gibt die Value-Eigenschaft nur die ersten 255 Zeichen des Wertes des Objekts zurück. Wenn die Value-Eigenschaft auf eine Zeichenkette mit mehr als 255 Zeichen gesetzt wird, wird ein Fehler ausgegeben.


Beispiel zur Value-Eigenschaft

In diesem Beispiel wird eine Dokumentvariable in das aktuelle Dokument eingefügt und dann der Wert der neuen Variablen angezeigt.

ActiveDocument.Variables.Add Name:="Temp2", Value:="10"
MsgBox ActiveDocument.Variables("Temp2").Value

In diesem Beispiel wird der Inhalt des aktiven Datensatzes in der mit Main.doc verbundenen Datenquelle angezeigt.

For Each dataF In _
    Documents("Main.doc").MailMerge.DataSource.DataFields
    If dataF.Value <> "" Then dRecord = dRecord & _
        dataF.Value & vbCr
Next dataF
MsgBox dRecord

In diesem Beispiel wird ein AutoKorrektur-Eintrag erstellt und dann der Wert des neuen Eintrags angezeigt.

AutoCorrect.Entries.Add Name:="i.e.", Value:="that is"
MsgBox AutoCorrect.Entries("i.e.").Value

In diesem Beispiel wird die Grammatik im aktiven Dokument überprüft und dann der Flesch Lesbarkeitsgrad-Index angezeigt.

ActiveDocument.CheckGrammar
MsgBox ActiveDocument.ReadabilityStatistics( _
    "Flesch Reading Ease").Value


Variables-Eigenschaft

Gibt eine Variables-Auflistung zurück, die alle im angegebenen Dokument gespeicherten Variablen auflistet. Nur-Lese-Zugriff.

Weitere Informationen zum Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Variables-Eigenschaft

In diesem Beispiel wird die Dokumentvariable "Wert1" dem aktiven Dokument hinzugefügt. Das Beispiel lädt dann den Wert aus der Variablen "Wert1", fügt ihm 3 hinzu und zeigt die Ergebnisse an.

ActiveDocument.Variables.Add Name:="Value1", Value:="1"
MsgBox ActiveDocument.Variables("Value1") + 3

In diesem Beispiel werden der Name und der Wert jeder Dokumentvariablen im aktiven Dokument angezeigt.

For Each myVar In ActiveDocument.Variables
    MsgBox "Name =" & myVar.Name & vbCr & "Value = " & myVar.Value
Next myVar


VBASigned-Eigenschaft

True, wenn das Visual Basic für Applikationen-Projekt für das angegebene Dokument digital signiert wurde. Boolean Nur-Lese-Zugriff.


Beispiel zur VBASigned-Eigenschaft

In diesem Beispiel wird ein Dokument mit dem Namen Temp.doc geladen und überprüft, ob es über eine digitale Signatur verfügt. Ist dies nicht der Fall, wird eine Warnmeldung angezeigt.

Documents.Open _
    FileName:="C:\My Documents\Temp.doc"
If ActiveDocument.VBASigned = False Then
    MsgBox "Warning! This document " _
        & "has not been digitally signed.", _
        vbCritical, "Digital Signature Warning"
End If


VBE-Eigenschaft

Gibt ein VBE-Objekt zurück, das den Visual Basic-Editor darstellt. Nur-Lese-Zugriff.


Beispiel zur VBE-Eigenschaft

In diesem Beispiel wird die Anzahl der Verweise angezeigt, die für das aktive Projekt verfügbar sind.

MsgBox "References = " & VBE.ActiveVBProject.References.Count


VBProject-Eigenschaft

Gibt das VBProject-Objekt für die angegebene Dokumentvorlage oder das Dokument zurück. Nur-Lese-Zugriff.

Anmerkungen

Mit dieser Eigenschaft erhalten Sie Zugriff auf Codemodule und Benutzerformulare.

Um das VBProject-Objekt im Objektkatalog anzuzeigen, wählen Sie das Kontrollfeld Microsoft Visual Basic for Applications Extensibility im Dialogfeld Verweise (Menü Extras) im Visual Basic-Editor.


Beispiel zur VBProject-Eigenschaft

In diesem Beispiel wird der Name des Visual Basic-Projekts der Dokumentvorlage Normal angezeigt.

Set normProj = NormalTemplate.VBProject
MsgBox normProj.Name

In diesem Beispiel wird der Name des Visual Basic-Projekts des aktiven Dokuments angezeigt.

Set currProj = ActiveDocument.VBProject
MsgBox currProj.Name

In diesem Beispiel wird dem aktiven Dokument ein Standard-Codemodul hinzugefügt und in "MeinModul" umbenannt.

Set newModule = ActiveDocument.VBProject.VBComponents _
    .Add(vbext_ct_StdModule)
NewModule.Name = "MyModule"


Version-Eigenschaft

Application-Objekt: Gibt die Versionsnummer von Microsoft Word zurück. String Nur-Lese-Zugriff.

System-Objekt: Gibt die Versionsnummer des Betriebssystems zurück. String Nur-Lese-Zugriff.


Versions-Eigenschaft

Gibt eine Versions-Auflistung zurück, die alle Versionen des angegebenen Dokuments darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Versions-Eigenschaft

In diesem Beispiel werden der Benutzername und das Datum der neuesten Version des Dokuments angezeigt.

If ActiveDocument.Versions.Count >= 1 Then
    Set aVersion = _
        ActiveDocument.Versions(ActiveDocument.Versions.Count)
    MsgBox "Saved by " & aVersion.SavedBy & " on " & aVersion.Date
End If

In diesem Beispiel wird eine Version von Vertrag.doc mit einem kurzen Kommentar gespeichert.

Documents("Contract.doc").Versions.Save _
    Comment:="Added a single word"


VerticalAlignment-Eigenschaft

Gibt die vertikale Ausrichtung von Text auf jeder Seite in einem Dokument, einem Abschnitt, einer Zelle oder mehreren Zellen einer Tabelle zurück oder legt diese fest. Kann eine der folgenden WdVerticalAlignment-Konstanten sein: wdAlignVerticalBottom, wdAlignVerticalCenter, wdAlignVerticalJustify oder wdAlignVerticalTop. Long Schreib-Lese-Zugriff.


Beispiel zur VerticalAlignment-Eigenschaft

In diesem Beispiel wird die vertikale Ausrichtung des ersten Dokuments geändert, so dass der Text zwischen dem oberen und unteren Seitenrand zentriert ist.

Documents(1).PageSetup.VerticalAlignment = wdAlignVerticalCenter

In diesem Beispiel wird ein neues Dokument erstellt und anschließend derselbe Absatz 10mal eingefügt. Anschließend wird die vertikale Ausrichtung des neuen Dokuments festgelegt, so dass die 10 Absätze zwischen dem oberen und unteren Seitenrand im Blocksatz angeordnet sind.

Set myDoc = Documents.Add
With myDoc.Content
    For i = 1 to 9
        .InsertAfter "This is a sentence."
        .InsertParagraphAfter
    Next i
    .InsertAfter "This is a sentence."
End With
myDoc.PageSetup.VerticalAlignment = wdAlignVerticalJustify

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt und jeder Zelle der Tabelle eine fortlaufende Zellennummer zugeordnet. Anschließend wird in dem Beispiel die Höhe der ersten Zeile auf 20 Punkt festgelegt und der Text am oberen Zellenrand vertikal ausgerichtet.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
i = 1
For Each c In myTable.Range.Cells
    c.Range.InsertAfter "Cell " & i
    i = i + 1
Next
With myTable.Rows(1)
    .Height = 20
    .Cells.VerticalAlignment = wdAlignVerticalTop
End With


VerticalDistanceFromText-Eigenschaft

Gibt den vertikalen Abstand zwischen einem Rahmen und dem umgebenden Text in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur VerticalDistanceFromText-Eigenschaft

In diesem Beispiel wird der vertikale Abstand zwischen dem gewählten Rahmen und dem umgebenden Text auf 12 Punkt gesetzt.

If Selection.Frames.Count = 1 Then
    Selection.Frames(1).VerticalDistanceFromText = 12
End If

In diesem Beispiel wird ein Rahmen um die Auswahl gezogen, und verschiedene Eigenschaften des Rahmens werden festgelegt.

Set aFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)
With aFrame
    .HorizontalDistanceFromText = InchesToPoints(0.13)
    .VerticalDistanceFromText = InchesToPoints(0.13)
    .HeightRule = wdFrameAuto
    .WidthRule = wdFrameAuto
End With


VerticalFlip-Eigenschaft

True, wenn die angegebene Form um die horizontale Achse gekippt wurde. Long Nur-Lese-Zugriff.


Beispiel zur VerticalFlip-Eigenschaft

In diesem Beispiel wird in myDocument jede Form in ihrem Originalzustand wiederhergestellt, wenn sie horizontal oder vertikal gekippt wurde.

For Each s In ActiveDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


VerticalPercentScrolled-Eigenschaft

Gibt die vertikale Bildlaufposition als Prozentwert der Dokumentlänge zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur VerticalPercentScrolled-Eigenschaft

In diesem Beispiel wird der Prozentwert angezeigt, um das das aktive Fenster vertikal gerollt wurde.

MsgBox ActiveDocument.ActiveWindow.VerticalPercentScrolled & "%"

In diesem Beispiel wird das aktive Fenster vertikal um 10 Prozent gerollt.

Set aWindow = ActiveDocument.ActiveWindow
aWindow.VerticalPercentScrolled = _
    aWindow.VerticalPercentScrolled + 10

In diesem Beispiel wird der aktive Ausschnitt des Fensters für Dokument1 vertikal zum Ende gerollt.

With Windows("Document1")
    .Activate
    .ActivePane.VerticalPercentScrolled = 100
End With


VerticalPitch-Eigenschaft

Gibt den vertikalen Abstand zwischen der Oberkante des einen Adressetiketts und der Oberkante des nächsten Adressetiketts zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.

Hinweis Wenn diese Eigenschaft auf einen Wert geändert wird, der für das Layout des angegebenen Etiketts nicht gültig ist, tritt ein Fehler auf.


Beispiel zur VerticalPitch-Eigenschaft

In diesem Beispiel wird ein benutzerdefiniertes Etikett mit der Bezeichnung "BesucherAusweis" erstellt und das Layout definiert. Der Abstand zwischen der Oberkante des einen Etiketts und der Oberkante des nächsten Etiketts ist 5,51 cm.

Set myLabel = Application.MailingLabel.CustomLabels _
    .Add(Name:="VisitorPass", DotMatrix:=False)
With myLabel
    .Height = InchesToPoints(2.17)
    .HorizontalPitch = InchesToPoints(3.5)
    .NumberAcross = 2
    .NumberDown = 4
    .PageSize = wdCustomLabelLetter
    .SideMargin = InchesToPoints(0.75)
    .TopMargin = InchesToPoints(0.17)
    .VerticalPitch = InchesToPoints(2.17)
    .Width = InchesToPoints(3.5)
End With


VerticalPosition-Eigenschaft

Frame-Objekt: Gibt den vertikalen Abstand zwischen dem Rahmen und dem durch die RelativeVerticalPosition-Eigenschaft definierten Element zurück oder legt ihn fest. Dabei kann es sich um eine Zahl handeln, die die Größe in Punkt angibt, oder um eine der folgenden WdFramePosition-Konstanten: wdFrameTop, wdFrameBottom oder wdFrameCenter. Single Schreib-Lese-Zugriff.

Rows-Objekt: Gibt den vertikalen Abstand zwischen den Zeilenrändern und dem durch die RelativeVerticalPosition-Eigenschaft definierten Element zurück oder legt ihn fest. Dabei kann es sich um eine Zahl handeln, die die Größe in Punkt angibt, oder um eine der folgenden WdTablePosition-Konstanten: wdTableTop, wdTableBottom oder wdTableCenter. Single Schreib-Lese-Zugriff. Wenn WrapAroundText auf False gesetzt ist, hat diese Eigenschaft keine Auswirkung.


Beispiel zur VerticalPosition-Eigenschaft

In diesem Beispiel wird der erste Rahmen im aktiven Dokument vertikal zur Oberkante der Seite ausgerichtet.

Set myFrame = ActiveDocument.Frames(1)
With myFrame
    .RelativeVerticalPosition = wdRelativeVerticalPositionPage
    .VerticalPosition = wdFrameTop
End With

In diesem Beispiel wird ein Rahmen um die erste Form im aktiven Dokument gezogen und 2,54 cm vom oberen Rand positioniert.

If ActiveDocument.Shapes.Count >= 1 Then
    ActiveDocument.Shapes(1).Select
    Set aFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)
    With aFrame
        .RelativeVerticalPosition = _
            wdRelativeVerticalPositionMargin
        .VerticalPosition = InchesToPoints(1)
    End With
End If

In diesem Beispiel wird die erste Tabelle im aktiven Dokument vertikal zur Oberkante der Seite ausgerichtet.

Set myTable = ActiveDocument.Tables(1).Rows
With myTable
    .RelativeVerticalPosition = wdRelativeVerticalPositionPage
    .VerticalPosition = wdTableTop
End With


VerticalResolution-Eigenschaft

Gibt die vertikale Bildschirmauflösung in Pixeln zurück. Long Nur-Lese-Zugriff.


Beispiel zur VerticalResolution-Eigenschaft

In diesem Beispiel wird die aktuelle Bildschirmauflösung angezeigt (z. B. "1024 x 768").

horz = System.HorizontalResolution
vert = System.VerticalResolution
MsgBox "Resolution = " & horz & " x " & vert


 Vertices-Eigenschaft

Vertices-Eigenschaft

Gibt die Koordinaten der Scheitelpunkte der angegebenen Freihandfigur (und der Kontrollpunkte für Bézier-Kurven) als Folge von Koordinatenpaaren zurück. Sie können die zurückgegebene Matrix als Argument für die AddCurve-Methode oder AddPolyLine-Methode verwenden. Variant Nur-Lese-Zugriff.

Die folgende Tabelle zeigt wie die Vertices-Eigenschaft die Werte im Datenfeld vertArray() mit den Koordinaten der Scheitelpunkte eines Dreiecks verbindet.

VertArray-Element | Enthält
vertArray(1, 1) | Den horizontalen Abstand des ersten Scheitelpunkts von der linken Kante des Dokuments
vertArray(1, 2) | Den vertikalen Abstand des ersten Scheitelpunkts von der oberen Kante des Dokuments
vertArray(2, 1) | Den horizontalen Abstand des zweiten Scheitelpunkts von der linken Kante des Dokuments
vertArray(2, 2) | Den vertikalen Abstand des zweiten Scheitelpunkts von der oberen Kante des Dokuments
vertArray(3, 1) | Den horizontalen Abstand des dritten Scheitelpunkts von der linken Kante des Dokuments
vertArray(3, 2) | Den vertikalen Abstand des dritten Scheitelpunkts von der oberen Kante des Dokuments


Beispiel zur Vertices-Eigenschaft

In diesem Beispiel werden die Scheitelpunktkoordinaten für Form eins in myDocument der Datenfeldvariablen vertArray() zugewiesen und die Koordinaten für den ersten Scheitelpunkt angezeigt. Bei Form eins muss es sich um eine Freihandzeichnung handeln.

Set myDocument = ActiveDocument
With myDocument.Shapes(1)
    vertArray = .Vertices
    x1 = vertArray(1, 1)
    y1 = vertArray(1, 2)
    MsgBox "First vertex coordinates: " & x1 & ", " & y1
End With

In diesem Beispiel wird eine Kurve erstellt, die die gleiche geometrische Beschreibung hat wie Form eins auf myDocument. Form eins muss zur Ausführung dieses Beispiels eine Bézier-Kurve sein, die 3n+1 Scheitelpunkte aufweist.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddCurve .Item(1).Vertices, Selection.Range
End With


View-Eigenschaft

Gibt ein View-Objekt zurück, das die Ansicht für das angegebene Fenster oder den angegebenen Ausschnitt darstellt. Nur-Lese-Zugriff.


ViewMailMergeFieldCodes-Eigenschaft

True, wenn die Seriendruckfelder im Seriendruck-Hauptdokument angezeigt werden. False, wenn Informationen aus dem aktuellen Datensatz angezeigt werden. Boolean Schreib-Lese-Zugriff.

Hinweis Wenn es sich beim aktiven Dokument um kein Seriendruck-Hauptdokument handelt, verursacht diese Eigenschaft einen Fehler. Um die Namen von Seriendruckfeldern oder ihre Ergebnisse anzuzeigen, setzen Sie die ShowFieldCodes-Eigenschaft auf False.


Beispiel zur ViewMailMergeFieldCodes-Eigenschaft

In diesem Beispiel werden die Seriendruckfelder im Haupt.doc angezeigt.

ActiveDocument.ActiveWindow.View.ShowFieldCodes = False
With Documents("Main.doc")
    .Activate
    .MailMerge.ViewMailMergeFieldCodes = True
End With

Wenn das aktive Dokument für einen Seriendruckvorgang eingerichtet wurde, werden in diesem Beispiel die Informationen aus dem aktuellen Datensatz im Hauptdokument angezeigt.

ActiveDocument.ActiveWindow.View.ShowFieldCodes = False
Set myMerge = ActiveDocument.MailMerge
If myMerge.State = wdMainAndSourceAndHeader Or _
    myMerge.State = wdMainAndDataSource Then
    myMerge.ViewMailMergeFieldCodes = False
End If


ViewType-Eigenschaft

Gibt die Ansicht eines TextRetrievalMode-Objekts zurück oder legt diese fest. Dabei kann es sich um eine der folgenden WdViewType-Konstanten handeln: wdMasterView, wdNormalView, wdOutlineView, wdPrintPreview, wdPrintView oder wdWebView. Long Schreib-Lese-Zugriff.

Hinweise

Wenn Sie die Ansicht für das TextRetrievalMode-Objekt ändern, ändert sich nicht die Bildschirmdarstellung des Dokuments. Stattdessen wird dadurch bestimmt, welche Zeichen enthalten sein werden, wenn ein Bereich abgerufen wird.


Beispiel zur ViewType-Eigenschaft

In diesem Beispiel wird die Gliederungsansicht zum Abrufen von Text festgelegt, dann wird der Inhalt des aktiven Dokuments in einem Dialogfeld angezeigt. Beachten Sie dabei, dass nur der in der Gliederungsansicht dargestellte Text abgerufen wird.

Set myText = ActiveDocument.Content
myText.TextRetrievalMode.ViewType = wdOutlineView
Msgbox myText


Visible-Eigenschaft

Application-, Window-, Task-, oder Border-Objekt: True, wenn das angegebene Objekt sichtbar ist. Boolean Schreib-Lese-Zugriff.

FillFormat-, LineFormat-, ShadowFormat-, Shape-, ShapeRange oder ThreeDFormat-Objekt: True, wenn das angegebene Objekt oder die ihm zugewiesene Formatierung sichtbar ist. Long Schreib-Lese-Zugriff.

Hinweise

Für jedes Objekt gilt, dass einige Methoden und Eigenschaften möglicherweise nicht verfügbar sind, wenn Visible den Wert False hat.


Beispiel zur Visible-Eigenschaft

In diesem Beispiel wird Word ausgeblendet.

Application.Visible = False

In diesem Beispiel wird der Rechner ausgeblendet, wenn er aktiv ist. Wenn er nicht aktiv ist, wird eine Meldung angezeigt.

If Tasks.Exists("Calculator") Then
    Tasks("Calculator").Visible = False
Else
    Msgbox "Calculator is not running."
End If

In diesem Beispiel wird eine Tabelle im aktiven Dokument erstellt, und die Standardrahmen werden von der Tabelle entfernt.

Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=12, NumColumns:=5)
For Each aBorder In myTable.Borders
    aBorder.Visible = False
Next aBorder

In diesem Beispiel wird die Formatierung "Schatten" von der ersten Form im aktiven Dokument entfernt.

ActiveDocument.Shapes(1).Shadow.Visible = False

In diesem Beispiel wird ein neues Dokument erstellt und anschließend Text und ein Rechteck hinzugefügt. Das Beispiel stellt Word außerdem so ein, dass das Rechteck während des Druckes ausgeblendet und nach Beendigung des Druckes wieder sichtbar ist.

Set myDoc = Documents.Add
Selection.TypeText Text:="This is some sample text."
With myDoc
    .Shapes.AddShape msoShapeRectangle, 200, 70, 150, 60
    .Shapes(1).Visible = False
    .PrintOut
    .Shapes(1).Visible = True
End With


VisualSelection-Eigenschaft

Sprachspezifische Informationen

Returns or sets the selection behavior based on visual cursor movement in a right-to-left language document. Read/write Long.

Can be either of the following WdVisualSelection constants.

Constant | Description
wdVisualSelectionBlock | All selected lines are the same width.
wdVisualSelectionContinuous | The selection wraps from line to line.

Remarks

The CursorMovement property must be set to wdCursorMovementVisual in order to use this property.

For more information on using Microsoft Word with right-to-left languages, see About right-to-left language features.


Beispiel zur VisualSelection-Eigenschaft

This example sets the selection behavior so that the selection wraps from line to line.

If Options.CursorMovement = wdCursorMovementVisual Then _
    Options.VisualSelection = wdVisualSelectionContinuous


WebOptions-Eigenschaft

Gibt das WebOptions-Objekt zurück, das Attribute auf Dokumentebene enthält, die Microsoft Word beim Speichern eines Dokuments als Webseite oder beim Öffnen einer Webseite verwendet. Nur-Lese-Zugriff.


Beispiel zur WebOptions-Eigenschaft

In diesem Beispiel wird festgelegt, dass Cascading Style Sheets und die Dokumentcodierung Westlich verwendet werden sollen, wenn Elemente des aktiven Dokuments als Teil einer Webseite gespeichert werden.

Set objWO = ActiveDocument.WebOptions
objWO.RelyOnCSS = True
objWO.Encoding = msoEncodingWestern


Weight-Eigenschaft

Gibt die Dicke der angegebenen Linie in Punkt zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur Weight-Eigenschaft

In diesem Beispiel wird zu myDocument eine grüne, gestrichelte Linie hinzugefügt, die zwei Punkt dick ist.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(0, 255, 255)
    .Weight = 2
End With


WidowControl-Eigenschaft

True, falls die erste und die letzte Zeile in dem angegebenen Absatz auf derselben Seite bleibt wie der übrige Absatz, wenn Word die Seiten des Dokuments neu umbricht. Kann True, False oder wdUndefined sein. Long Schreib-Lese-Zugriff.


Beispiel zur WidowControl-Eigenschaft

In diesem Beispiel werden die Absätze im aktiven Dokument so formatiert, dass die erste oder letzte Zeile eines Absatzes unten oder oben auf einer Seite allein stehen kann.

ActiveDocument.Paragraphs.WidowControl = False


Width-Eigenschaft

Frameset-Objekt: Gibt die Breite des angegebenen Frameset-Objekts zurück oder legt diese fest. Long Schreib-Lese-Zugriff. Die WidthType-Eigenschaft legt die Einheit fest, in der dieser Wert angegeben wird.

Alle anderen Objekte: Gibt die Breite des angegebenen Objekts (in Punkt) zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


WidthRule-Eigenschaft

Gibt die Regel zurück, mit der die Rahmenbreite bestimmt wird, oder legt sie fest. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdFrameSizeRule-Konstanten handeln:

Konstante | Beschreibung
wdFrameAuto | Legt die Breite entsprechend der Breite des Objekts im Rahmen fest.
wdFrameExact | Bestimmt für die Breite einen genauen Wert, der mit der Width-Eigenschaft festgelegt wird.
wdFrameAtLeast | Bestimmt als Breite einen Wert, der größer oder gleich dem mit der Width-Eigenschaft festgelegten Wert ist.


Beispiel zur WidthRule-Eigenschaft

In diesem Beispiel wird die Breite des letzten Rahmens im aktiven Dokument auf genau 72 Punkt (2,54 cm) gesetzt.

If ActiveDocument.Frames.Count >= 1 Then
    With ActiveDocument.Frames(ActiveDocument.Frames.Count)
        .WidthRule = wdFrameExact
        .Width = 72
    End With
End If


WidthType-Eigenschaft

Gibt die Breite des angegebenen Frameset- oder HorizontalLineFormat-Objekts zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Bei einem Frameset-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdFramesetSizeType-Konstanten handeln.

Konstante | Beschreibung
wdFramesetSizeTypeFixed | Microsoft Word interpretiert die Breite des angegebenen Frames als festen Wert (in Punkt).
wdFramesetSizeTypePercent | Word interpretiert die Breite des angegebenen Frames als prozentualen Anteil der Bildschirmbreite.
wdFramesetSizeTypeRelative | Word interpretiert die Breite des angegebenen Frames relativ zur Breite anderer Frames auf der Framesseite.

Bei einem HorizontalLineFormat-Objekt kann es sich bei dieser Eigenschaft um eine der folgenden WdHorizontalLineWidthType-Konstanten handeln.

Konstante | Beschreibung
wdHorizontalLineFixedWidth | Word interpretiert die Breite (Länge) der angegebenen horizontalen Linie als festen Wert (in Punkt). Dies ist der Standardwert für horizontale Linien, die mit der AddHorizontalLine-Methode hinzugefügt wurden. Durch Festlegen der Width-Eigenschaft für das einer horizontalen Linie zugewiesene InlineShape-Objekt wird die WidthType-Eigenschaft auf diesen Wert gesetzt.
wdHorizontalLinePercentWidth | Word interpretiert die Breite (Länge) der angegebenen horizontalen Linie als prozentualen Anteil der Bildschirmbreite. Dies ist der Standardwert für horizontale Linien, die mit der AddHorizontalLineStandard-Methode hinzugefügt wurden. Durch Festlegen der PercentWidth-Eigenschaft für eine horizontale Linie wird die WidthType-Eigenschaft auf diesen Wert gesetzt.


Beispiel zur WidthType-Eigenschaft

In diesem Beispiel wird die Breite des ersten Frameset-Objekts im aktiven Dokument auf 25 Prozent der Fensterbreite festgelegt.

With ActiveDocument.ActiveWindow.Panes(1).Frameset
    .WidthType = wdFramesetSizeTypePercent
    .Width = 25
End With

In diesem Beispiel werden dem aktiven Dokument horizontale Linien hinzugefügt und deren Breite verglichen.

Dim temp As InlineShape
Set temp = _
    ActiveDocument.InlineShapes.AddHorizontalLineStandard
MsgBox "AddHorizontalLineStandard - WidthType = " _
    & temp.HorizontalLineFormat.WidthType
Set temp = _
    ActiveDocument.InlineShapes.AddHorizontalLine _
    ("C:\My Documents\ArtsyRule.gif")
MsgBox "AddHorizontalLine - WidthType = " _
    & temp.HorizontalLineFormat.WidthType


WindowNumber-Eigenschaft

Gibt die Fensternummer des Dokuments zurück, das im angegebenen Fenster angezeigt wird. Wenn beispielsweise die Beschriftung des Fensters "Umsatz.doc:2" ist, gibt diese Eigenschaft die Nummer 2 zurück. Long Nur-Lese-Zugriff.

Hinweis Verwenden Sie die Index-Eigenschaft, wenn die Nummer des angegebenen Fensters in der Windows-Auflistung zurückgegeben werden soll.


Beispiel zur WindowNumber-Eigenschaft

In diesem Beispiel wird die Fensternummer des aktiven Fensters abgerufen, ein neues Fenster geöffnet und dann das Originalfenster aktiviert.

windowNum = ActiveDocument.ActiveWindow.WindowNumber
NewWindow
ActiveDocument.Windows(windowNum).Activate


Windows-Eigenschaft

Application-Objekt: Gibt eine Windows-Auflistung zurück, die alle Dokumentfenster darstellt. Die Auflistung entspricht den Fensternamen, die unten im Menü Fenster erscheinen. Nur-Lese-Zugriff.

Document-Objekt: Gibt eine Windows-Auflistung zurück, die alle Fenster für das angegebene Dokument (beispielsweise Umsatz.doc:1 und Umsatz.doc:2) darstellt. Nur-Lese-Zugriff.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


WindowState-Eigenschaft

Gibt den Status des angegebenen Dokumentfensters oder des angegebenen Task-Fensters zurück oder legt ihn fest. Dies kann eine der folgenden WdWindowState-Konstanten sein: wdWindowStateMaximize, wdWindowStateMinimize oder wdWindowStateNormal. Long Schreib-Lese-Zugriff.

Anmerkungen

Die wdWindowStateNormal-Konstante kennzeichnet ein Fenster, das nicht maximiert oder minimiert ist. Der Status eines inaktiven Fensters kann nicht eingestellt werden. Verwenden Sie die Activate-Methode, wenn Sie vor dem Einstellen des Fenster-Status ein Fenster aktivieren wollen.


Beispiel zur WindowState-Eigenschaft

In diesem Beispiel wird das aktive Fenster maximiert, wenn es nicht maximiert oder minimiert ist.

If ActiveDocument.ActiveWindow _
    .WindowState = wdWindowStateNormal Then _
    ActiveDocument.ActiveWindow.WindowState = wdWindowStateMaximize

In diesem Beispiel wird das Microsoft Excel Anwendungsfenster minimiert.

For Each myTask In Tasks
    If InStr(myTask.Name, "Microsoft Excel") > 0 Then
        myTask.Activate
        myTask.WindowState = wdWindowStateMinimize
    End If
Next myTask


Word-Eigenschaft

Gibt das Wort oder den Ausdruck zurück, das/der im Thesaurus nachgeschlagen wurde. String Nur-Lese-Zugriff.

Anmerkungen

Der Thesaurus wird manchmal eine gekürzte Version der Zeichenfolge oder des Bereichs nachschlagen, die/der zur Zurückgabe des SynonymInfo-Objekts verwendet wird. Die Word-Eigenschaft gibt Ihnen die Möglichkeit, die exakte Zeichenfolge zu sehen, die verwendet wurde.


WordBasic-Eigenschaft

Gibt ein Automation-Objekt (Word.Basic) mit Methoden für alle WordBasic-Anweisungen und Funktionen zurück, die in Word Version 6.0 und Word für Windows 95 zur Verfügung standen. Nur-Lese-Zugriff.

Hinweise

Wenn Sie eine Dokumentvorlage für Word Version 6.0 oder Word für Windows 95 mit WordBasic-Makros unter Word 2000 öffnen, werden die Makros automatisch in Visual Basic-Module konvertiert. Alle WordBasic-Anweisungen und -Funktionen im Makro werden in die entsprechenden Word.Basic-Methoden konvertiert.

Informationen über WordBasic-Anweisungen und -Funktionen finden Sie in der WordBasic-Hilfe in Word Version 6.0 oder Word für Windows 95.

Informationen darüber, wie WordBasic in Visual Basic konvertiert wird, finden Sie unter Visual Basic-Entsprechungen zu WordBasic-Befehlen.


Beispiel zur WordBasic-Eigenschaft

In diesem Beispiel wird mit dem Word.Basic-Objekt ein neues Dokument erstellt, und die verfügbaren Schriftartennamen werden eingefügt. Jeder Schriftartenname wird mit der entsprechenden Schriftart formatiert.

With WordBasic
    .FileNewDefault
    For aCount = 1 To .CountFonts()
        .Font .[Font$](aCount)
        .Insert .[Font$](aCount)
        .InsertPara
    Next
End With


Words-Eigenschaft

Gibt eine Words-Auflistung zurück, die alle Wörter in einem Bereich, in einer Markierung oder in einem Dokument darstellt. Nur-Lese-Zugriff.

Anmerkung Interpunktion und Absatzmarken in einem Dokument werden in die Words-Auflistung einbezogen.

Informationen über die Rückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Words-Eigenschaft

In diesem Beispiel wird die Anzahl der Wörter in der Markierung angezeigt. Absatzmarken, Teilwörter und Satzzeichen werden mitgezählt.

MsgBox "There are " & Selection.Words.Count & " words."

In diesem Beispiel wird in myRange (der sich vom Anfang des aktiven Dokuments bis zum Ende der Markierung erstreckt) schrittweise von einem Wort zum nächsten gegangen und jedes Vorkommen des Wortes "Franklin" (einschließlich der nachstehenden Leerstelle) in dem Bereich gelöscht.

Set myRange = ActiveDocument.Range(Start:=0, End:=Selection.End)
For Each aWord In myRange.Words
    If aWord.Text = "Franklin " Then aWord.Delete
Next aWord


WordWrap-Eigenschaft

Cell-Objekt: True, wenn Microsoft Word Text in mehrere Zeilen umbricht und die Zelle verlängert, so dass die Zellenbreite gleich bleibt. Boolean Schreib-Lese-Zugriff.

Paragraph-, Paragraphs- oder ParagraphFormat-Objekt: True, wenn Microsoft Word westlichen Text in den angegebenen Absätzen innerhalb eines Wortes umbricht. Diese Eigenschaft gibt wdUndefined zurück, wenn sie nur für einige der angegebenen Absätze auf True gesetzt ist. Long Schreib-Lese-Zugriff. Die Verfügbarkeit dieser Eigenschaft hängt von der ausgewählten bzw. installierten Sprachunterstützung (zum Beispiel Deutsch) ab.


Beispiel zur WordWrap-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word den Text in der dritten Zelle der ersten Tabelle in mehrere Zeilen umbricht, so dass die Zellenbreite unverändert bleibt.

ActiveDocument.Tables(1).Range.Cells(3).WordWrap = True

In diesem Beispiel wird festgelegt, dass Microsoft Word westlichen Text im ersten Absatz des aktiven Dokuments innerhalb eines Wortes umbricht.

ActiveDocument.Paragraphs(1).WordWrap = True


WPDocNavKeys-Eigenschaft

True, wenn die WordPerfect-Navigationstasten aktiviert sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur WPDocNavKeys-Eigenschaft

In diesem Beispiel wird Word so eingerichtet, dass WordPerfect Navigation Keys verwendet werden.

Options.WPDocNavKeys = True

In diesem Beispiel wird der Status der Option WordPerfect Navigation Keys auf der Registerkarte Allgemein im Dialogfeld Optionen zurückgegeben.

temp = Options.WPDocNavKeys


WPHelp-Eigenschaft

True, wenn beim Drücken von Tastenkombinationen, die in WordPerfect bestimmte Vorgänge auslösen, Dialogfelder angezeigt werden, in denen beschrieben wird, wie die entsprechenden Vorgänge in Word ausgeführt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur WPHelp-Eigenschaft

In diesem Beispiel wird die WordPerfect-Hilfe ein- bzw. ausgeschaltet.

Options.WPHelp = Not Options.WPHelp

In diesem Beispiel wird die Einstellung der Option Hilfe für WordPerfect-Benutzer auf der Registerkarte Allgemein im Dialogfeld Optionen angezeigt.

Msgbox Options.WPHelp


Wrap-Eigenschaft

Gibt die weitere Vorgehensweise bei einer Suche zurück oder legt sie fest, wenn das Ende des Dokuments erreicht, und die Suche nicht am Dokumentanfang begonnen wurde (oder umgekehrt, wenn Forward auf False gesetzt wird), oder wenn der Suchtext nicht in der angegebenen Auswahl oder im Bereich gefunden wird. Long Schreib-Lese-Zugriff.

Dabei kann es sich um eine der folgenden WdFindWrap-Konstanten handeln:

Konstante | Beschreibung
wdFindAsk | Nach der Durchsuchung der Auswahl oder des Bereichs erscheint eine Meldung mit der Frage, ob der Rest des Dokuments durchsucht werden soll.
wdFindContinue | Die Suchoperation wird beim Erreichen des Anfangs oder Endes des Suchbereichs fortgesetzt.
WdFindStop | Die Suchoperation endet beim Erreichen des Anfangs oder Endes des Suchbereichs.


WrapAroundText-Eigenschaft

Gibt den Umbruch für angegebene Textzeilen zurück oder legt ihn fest. Gibt wdUndefined zurück, wenn der Umbruch nur für einige der angegebenen Zeilen aktiviert ist. Die Werte True oder False sind möglich. Long Schreib-Lese-Zugriff.

Hinweise

Wird die WrapAroundText-Eigenschaft auf False gesetzt, wird auch die AllowOverlap-Eigenschaft auf False gesetzt. Wird die AllowOverlap-Eigenschaft auf True gesetzt, wird die WrapAroundText-Eigenschaft ebenfalls auf True gesetzt.


Beispiel zur WrapAroundText-Eigenschaft

In diesem Beispiel wird festgelegt. dass Microsoft Word den Text in der ersten Tabelle des Dokuments umbrechen soll.

ActiveDocument.Tables(1).Rows.WrapAroundText = True


WrapFormat-Eigenschaft

Gibt ein WrapFormat-Objekt zurück, das die Eigenschaften für den automatischen Zeilenumbruch bei der angegebenen Form oder den Formbereich enthält. Nur-Lese-Zugriff.


Beispiel zur WrapFormat-Eigenschaft

Dieses Beispiel fügt dem aktiven Dokument ein Oval hinzu und gibt an, dass der Dokumenttext einen Umbruch an den linken und rechten Seiten des Quadrats durchführt, das das Oval umschreibt. Das Beispiel legt einen Rand von 0,1 Zoll zwischen dem Dokumenttext und der Oberseite, Unterseite sowie der linken und rechten Seite des Quadrats fest.

Set myOval = _
    ActiveDocument.Shapes.AddShape(msoShapeOval, 36, 36, 90, 50)
With myOval.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


WrapToWindow-Eigenschaft

True, wenn Zeilen am rechten Rand des Dokumentfensters, nicht am rechten Seitenrand oder der rechten Spaltenbegrenzung umbrochen werden. Boolean Schreib-Lese-Zugriff.

Anmerkung Diese Eigenschaft hat sowohl in der Seitenlayoutansicht als auch in der Weblayoutansicht keine Wirkung.


Beispiel zur WrapToWindow-Eigenschaft

In diesem Beispiel wird der Text so umgebrochen, dass er in das aktive Fenster passt.

With ActiveDocument.ActiveWindow.View
    .Type = wdNormalView
    .WrapToWindow = True
End With


WritePassword-Eigenschaft

Legt ein Kennwort zum Speichern von Änderungen im angegebenen Dokument fest. String Nur-Schreib-Zugriff.


Beispiel zur WritePassword-Eigenschaft

Wenn in diesem Beispiel das aktive Dokument noch nicht vor dem Speichern von Änderungen geschützt ist, wird "geheim" als Schreibkennwort für das Dokument festgelegt.

Set myDoc = ActiveDocument
If myDoc.WriteReserved = False Then myDoc.WritePassword = "secret"


WriteReserved-Eigenschaft

True, wenn das angegebene Dokument mit einem Schreibkennwort geschützt ist. Boolean Nur-Lese-Zugriff.


Beispiel zur WriteReserved-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn das aktive Dokument ein Schreibkennwort hat.

If ActiveDocument.WriteReserved = True Then
    MsgBox "Changes cannot be made to this document."
End If


WritingStyleList-Eigenschaft

Gibt eine Zeichenfolgen-Matrix mit den Namen aller verfügbaren Schreibstile für die angegebene Sprache zurück. Variant Nur-Lese-Zugriff.


Beispiel zur WritingStyleList-Eigenschaft

In diesem Beispiel werden alle Schreibstile für Deutsch angezeigt. Jeder Schreibstil und seine Nummer im Datenfeld werden auf im Direktfenster im Visual Basic-Editor angezeigt.

WrStyles = Languages(wdEnglishUS).WritingStyleList
For i = 1 To UBound(WrStyles)
    MsgBox WrStyles(i)
    Debug.Print WrStyles(i) & " [" & Trim(Str$(i)) & "]"
Next i


Zoom-Eigenschaft

Gibt ein Zoom-Objekt zurück, das die Vergrößerung für die angegebene Ansicht darstellt. Nur-Lese-Zugriff.


Zooms-Eigenschaft

Gibt eine Zooms-Auflistung zurück, die die Vergrößerungsoptionen für jede Ansicht (Normalansicht, Gliederungsansicht, Seitenlayoutansicht usw.) darstellt. Nur-Lese-Zugriff.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Zooms-Eigenschaft

In diesem Beispiel wird die Vergrößerung in der Normalansicht für jedes geöffnete Fenster auf 100 Prozent eingestellt.

For Each myWindow In Windows
    myWindow.ActivePane.Zooms(wdNormalView).Percentage = 100
Next myWindow

In diesem Beispiel wird die Vergrößerung in der Seitenlayoutansicht so eingestellt, dass eine ganze Seite sichtbar ist.

ActiveDocument.ActiveWindow.Panes(1).Zooms(wdPrintView).PageFit = _
    wdPageFitFullPage


ZOrderPosition-Eigenschaft

Gibt die Position der angegebenen Form in der z-Richtung zurück. Shapes(1) gibt die Form im Hintergrund der z-Richtung zurück, und Shapes(Shapes.Count) gibt die Form im Vordergrund der z-Richtung zurück. Long Nur-Lese-Zugriff.

Diese Eigenschaft ist schreibgeschützt. Zum Einstellen der Position der Form in der z-Richtung verwenden Sie die ZOrder-Methode.

Anmerkungen

Die Position einer Form in der z-Richtung entspricht der Indexnummer der Form in der Shapes-Auflistung. Wenn beispielsweise vier Formen in myDocument vorhanden sind, gibt der Ausdruck myDocument.Shapes(1) die Form im Hintergrund der z-Richtung zurück, und der Ausdruck myDocument.Shapes(4) gibt die Form im Vordergrund der z-Richtung zurück.

Immer wenn Sie einer Auflistung eine neue Form hinzufügen, wird sie standardmäßig im Vordergrund der z-Richtung hinzugefügt.


Beispiel zur ZOrderPosition-Eigenschaft

In diesem Beispiel wird ein Oval zu myDocument hinzugefügt und dann das Oval als zweites von hinten in der z-Richtung platziert, wenn mindestens eine andere Form im Dokument vorhanden ist.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


Context-Eigenschaft

Die Context-Eigenschaft in Microsoft Word besitzt Nur-Lese-Zugriff. Sie gibt den gesamten Namen (mit Pfad) der Vorlage zurück, die zu dem Dokument mit dem angegebenen CommandBar-Objekt gehört.


Sprachspezifische Informationen

Hilfethemen zu sprachspezifischen Fragen können nur verwendet werden, wenn die sprachspezifische Funktion verfügbar ist. Informieren Sie sich über das Arbeiten in einer anderen Sprache oder die Installation der Korrekturhilfen für eine andere Sprache, oder wenden Sie sich an Ihren Systemadministrator, um weitere Informationen zu erhalten.


Beispiel zum New-Ereignis

In diesem Beispiel werden alle offenen Fenster angeordnet, wenn ein neues Dokument auf Grundlage der Dokumentvorlage erstellt wird. (Diese Prozedur wird in einer Dokumentvorlage, nicht in einem Dokument gespeichert.)

Private Sub Document_New()
    Application.Windows.Arrange wdTiled
End Sub


Hinzufügen von Steuerelementen zu einem Dokument

Sie können der Zeichnungs- oder Textebene eines Dokuments Steuerelemente hinzufügen. Um der Zeichnungsebene ein Steuerelement hinzuzufügen, klicken Sie in der Steuerelement-Toolbox auf das entsprechende Steuerelement. Ziehen Sie einen Korrekturziehpunkt des Steuerelements, bis die Begrenzungslinien des Steuerelements die gewünschte Größe und Form aufweisen. Um der Textebene ein Steuerelement hinzuzufügen, klicken Sie bei gedrückter UMSCHALTTASTE in der Steuerelement-Toolbox auf ein Steuerelement. Das Steuerelement wird automatisch an der Einfügemarke in das Dokument eingefügt.

Anmerkung Wenn Sie ein Steuerelement (oder eine bestimmte Anzahl "gruppierter" Steuerelemente) aus dem Formular zurück auf die Steuerelement-Toolbox ziehen, wird eine Vorlage des Steuerelements erstellt, die Sie erneut verwenden können. Dadurch haben Sie die Möglichkeit, Ihren Anwendungen ein standardisiertes Erscheinungsbild zu verleihen.


Hinzufügen von Steuerelementen zu einem UserForm

Um einem UserForm Steuerelemente hinzuzufügen, suchen Sie in der Toolbox das Steuerelement, das hinzugefügt werden soll, ziehen Sie das Steuerelement auf das Formular, und ziehen Sie anschließend einen Korrekturziehpunkt des Steuerelements, bis die Begrenzungslinien des Steuerelements die gewünschte Größe und Form aufweisen.

Anmerkung Wenn Sie ein Steuerelement (oder eine bestimmte Anzahl "gruppierter" Steuerelemente) aus dem Formular zurück auf die Toolbox ziehen, wird eine Vorlage des Steuerelements erstellt, die Sie erneut verwenden können. Dadurch haben Sie die Möglichkeit, Ihren Anwendungen ein standardisiertes Erscheinungsbild zu verleihen.

Wenn Sie dem Formular Steuerelemente hinzugefügt haben, können Sie mit den Befehlen im Menü Format im Visual Basic-Editor die Ausrichtung und den Abstand des Steuerelements anpassen.


Ermitteln, ob die Application-Eigenschaft nötig ist

Viele der Eigenschaften und Methoden des Application-Objekts können ohne den Application-Objekt-Kennzeichner verwendet werden. Beispielsweise kann die ActiveDocument-Eigenschaft ohne den Application-Objekt-Kennzeichner verwendet werden. Anstatt zu schreiben Application.ActiveDocument.PrintOut, können Sie schreiben ActiveDocument.PrintOut.

Eigenschaften und Methoden, die ohne den Application-Objekt-Kennzeichner verwendet werden können, werden als "global" angesehen. Wenn Sie die globalen Eigenschaften und Methoden im Objektkatalog sehen wollen, klicken Sie auf <globals> oben in der Liste im Feld Klassen.


Ereignisse von Steuerelementen und Dialogfeldern

Nachdem Sie Ihrem Dialogfeld oder Dokument Steuerelemente hinzugefügt haben, können Sie Ereignisprozeduren hinzufügen, um zu bestimmen, wie die Steuerelemente auf Benutzeraktionen reagieren sollen.

UserForms und Steuerelemente haben einen vordefinierten Ereignissatz. So hat z. B. eine Befehlsschaltfläche ein Click-Ereignis, das eintritt, sobald der Benutzer auf die Befehlsschaltfläche klickt. UserForms haben ein Initialize-Ereignis, das eintritt, sobald das Formular geladen wird.

Um Ereignisprozeduren für Steuerelemente oder Formulare zu schreiben, öffnen Sie ein Modul, indem Sie auf das Formular oder das Steuerelement doppelklicken, und markieren Sie das Ereignis im Dropdownlistenfeld Prozedur.

Ereignisprozeduren beinhalten den Namen des Steuerelements. So erhält z. B. die Click-Ereignisprozedur für eine Befehlsschaltfläche mit dem Namen Command1 den Namen Command1_Click.

Wenn Sie Code für eine Ereignisprozedur schreiben und anschließend den Namen des Steuerelements ändern, verbleibt Ihr Code in Prozeduren mit seinem vorherigen Namen.

So können Sie z. B. Code für das Click-Ereignis für Command1 schreiben und anschließend das Steuerelement als Command2 umbenennen. Wenn Sie auf Command2 doppelklicken, wird kein Code in der Click-Ereignisprozedur angezeigt. Sie müssen den Code dann aus Command1_Click nach Command2_Click verschieben.

Um Ihre Arbeit später zu erleichtern, empfiehlt es sich, Ihre Steuerelemente vor dem Verfassen des Codes exakt zu benennen.


Erstellen eines UserForms

Zum Erstellen eines benutzerdefinierten Dialogfeldes müssen Sie zunächst ein UserForm erstellen. Klicken Sie zum Erstellen eines UserForms im Visual Basic-Editor im Menü Einfügen auf UserForm.

Verwenden Sie das Eigenschaftenfenster, um den Namen, das Verhalten und das Aussehen des Formulars zu ändern. Um beispielsweise den Titel eines Formulars zu ändern, legen Sie die Caption-Eigenschaft fest.


Erstellen von Framesseiten

In Microsoft Word 2000 können Sie die Informationen auf Ihrer Webseite mit Hilfe von Frames organisieren und einfach zugänglich machen. Eine Framesseite, auch Frameset genannt, ist eine Webseite, die in zwei oder mehr Frames unterteilt ist, wobei in jedem Frame eine andere Webseite angezeigt wird. In einem Frame auf einer Framesseite kann außerdem eine andere Framesseite angezeigt werden. Informationen über das Erstellen von Frames und Framesseiten mit Hilfe der Benutzeroberfläche von Word finden Sie unter Erstellen von Frames und Framesseiten.

Frames und Framesseiten werden mittels einer Reihe von HTML-Tags erstellt. Um das Visual Basic-Objektmodell zum Arbeiten mit Frames und Framesseiten besser zu verstehen, sollten Sie sich die HTML-Tags der Frames und Framesseiten ansehen.

Framesseiten in HTML

In HTML werden Framesseiten und die in ihnen enthaltenen Frames durch Verwenden einer hierarchisch aufgebauten Gruppe von <FRAMESET>-Tags und <FRAME>-Tags erstellt. Ein Frameset kann sowohl Frames als auch andere Framesets enthalten. Im folgenden Beispiel wird ein Frameset in HTML erstellt, das einen Frame im oberen Teil der Seite und ein direkt darunterliegendes Frameset enthält. Dieses Frameset enthält wiederum einen Frame auf der linken Seite und ein Frameset auf der rechten Seite. Das Frameset enthält zwei übereinander angeordnete Frames.

<FRAMESET ROWS="100, *">
    <FRAME NAME=top SRC="banner.htm">
    <FRAMESET COLS="20%, *">
        <FRAME NAME=left SRC="contents.htm">
        <FRAMESET ROWS="75%, *">
            <FRAME NAME=main SRC="main.htm">
            <FRAME NAME=bottom SRC="footer.htm">
        </FRAMESET>
    </FRAMESET>
</FRAMESET>

Anmerkung Um das vorangegangene HTML-Beispiel besser zu verstehen, kopieren Sie das Beispiel in ein leeres Textdokument, benennen das Dokument mit Framesseite.htm und öffnen das Dokument in Word oder in einem Webbrowser.

Das Frameset-Objekt

Das Frameset-Objekt umfasst die Funktionalität beider Tags. Jedes Frameset-Objekt ist entweder vom Typ wdFramesetTypeFrameset oder wdFramesetTypeFrame, wobei diese Typen die HTML-Tags <FRAMESET> bzw. <FRAME> darstellen. Eigenschaften, die mit "Frameset" beginnen, gelten für Frameset-Objekte vom Typ wdFramesetTypeFrameset (FramesetBorderColor und FramesetBorderWidth). Eigenschaften, die mit "Frame" beginnen, gelten für Frameset-Objekte vom Typ wdFramesetTypeFrame (FrameDefaultURL, FrameDisplayBorders, FrameLinkToFile, FrameName, FrameResizable und FrameScrollbarType).

Durchlaufen der Frameset-Objekthierarchie

Da Framesseiten als hierarchische Gruppen von HTML-Tags definiert sind, ist auch das Objektmodell für den Zugriff auf Frameset-Objekte hierarchisch aufgebaut. Verwenden Sie die Eigenschaften ChildFramesetItem und ParentFrameset, um die Hierarchie von Frameset-Objekten zu durchlaufen. So gibt

MyFrameset.ChildFramesetItem(n)

beispielsweise ein Frameset-Objekt zurück, das dem nten <FRAMESET>- oder <FRAME>-Tag der ersten Ebene zwischen den <FRAMESET>- und </FRAMESET>-Tags entspricht, die zu MyFrameset gehören.

Wenn MyFrameset ein Frameset-Objekt ist, welches den äußersten <FRAMESET>-Tags im vorangegangenen HTML-Beispiel entspricht, dann gibt MyFrameset.ChildFramesetItem(1) ein Frameset-Objekt vom Typ wdFramesetTypeFrame zurück, das zum Frame mit dem Namen "top" gehört. In gleicher Weise gibt MyFrameset.ChildFramesetItem(2) ein Frameset-Objekt vom Typ wdFramesetTypeFrameset zurück, das wiederum zwei Frameset-Objekte enthält: Das erste Objekt entspricht dem Frame mit dem Namen "left", das zweite Objekt ist vom Typ wdFramesetTypeFrameset.

Frameset-Objekte vom Typ wdFramesetTypeFrame besitzen keine untergeordneten Frames, während Objekte vom Typ wdFramesetTypeFrameset mindestens einen untergeordneten Frame besitzen.

Im folgenden Visual Basic-Beispiel werden die Namen der vier Frames angezeigt, die im vorangegangenen HTML-Beispiel definiert wurden.

Dim MyFrameset As Frameset
Dim Name1 As String
Dim Name2 As String
Dim Name3 As String
Dim Name4 As String

Set MyFrameset = ActiveWindow.Document.Frameset

With MyFrameset
    Name1 = .ChildFramesetItem(1).FrameName
    With .ChildFramesetItem(2)
        Name2 = .ChildFramesetItem(1).FrameName
        With .ChildFramesetItem(2)
            Name3 = .ChildFramesetItem(1).FrameName
            Name4 = .ChildFramesetItem(2).FrameName
        End With
    End With
End With

Debug.Print Name1, Name2, Name3, Name4

Einzelne Frames und die gesamte Framesseite

Um das zu einem bestimmten Frame oder einer Framesseite gehörende Frameset-Objekt zurückzugeben, verwenden Sie die Frameset-Eigenschaft eines Pane-Objekts. So gibt

ActiveWindow.Panes(1).Frameset

beispielsweise das Frameset-Objekt zurück, das dem ersten Frame der Framesseite entspricht.

Die Framesseite selbst ist ein Dokument, das von den Dokumenten mit den Inhalten der verschiedenen Frames getrennt ist. Der Zugriff auf das zu einer Framesseite gehörende Frameset-Objekt erfolgt über das zugehörige Document-Objekt, auf das wiederum über das Window-Objekt zugegriffen wird, in dem die Framesseite angezeigt wird. So gibt

ActiveWindow.Document.Frameset

beispielsweise das Frameset-Objekt für die Framesseite im aktuellen Fenster zurück.

Anmerkung Wenn Sie mit Framesseiten arbeiten, gibt die ActiveDocument-Eigenschaft das Document-Objekt für den Frame im gegenwärtig aktiven Fenster zurück, nicht das der gesamten Framesseite.

Neuerstellen einer Framesseite und ihres Inhalts

In diesem Beispiel wird eine neue Framesseite mit drei Frames erstellt, in jedem Frame Text eingefügt und die Hintergrundfarbe für jeden Frame eingestellt. Im linken Frame werden zwei Hyperlinks eingefügt: Der erste Hyperlink verweist auf ein Dokument mit dem Namen One.htm im Hauptframe. Der zweite Hyperlink verweist auf ein Dokument mit dem Namen Two.htm, das das gesamte Fenster einnimmt. Für diese Hyperlinks müssen Sie Dateien mit den Namen One.htm und Two.htm erstellen oder stattdessen Namen von bereits vorhandenen Dateien eingeben.

Anmerkung Für jeden erstellen Frame wird in Word ein neues Dokument erstellt, dessen Inhalt in den neuen Frame geladen wird. In dem Beispiel wird die Framesseite gespeichert, wodurch automatisch auch die zu den drei Frames gehörenden Dokumente gespeichert werden.

Sub FramesetExample1()

    ' Create new frames page.
    Documents.Add DocumentType:=wdNewFrameset

    With ActiveWindow
        ' Add text and color to first frame.
        Selection.TypeText Text:="BANNER FRAME"
        With ActiveDocument.Background.Fill
            .ForeColor.RGB = RGB(204, 153, 255)
            .Visible = msoTrue
        End With

        ' Add new frame below top frame.
        .ActivePane.Frameset.AddNewFrame _
            wdFramesetNewFrameBelow
        ' Add text and color to bottom frame.
        .ActivePane.Frameset.FrameName = "main"
        Selection.TypeText Text:="MAIN FRAME"
        With ActiveDocument.Background.Fill
            .ForeColor.RGB = RGB(0, 128, 128)
            .Visible = msoTrue
        End With

        ' Add new frame to left of bottom frame.
        .ActivePane.Frameset.AddNewFrame _
            wdFramesetNewFrameLeft
        ' Set the width to 25% of the window width.
        With .ActivePane.Frameset
            .WidthType = wdFramesetSizeTypePercent
            .Width = 25
            .FrameName = "left"
        End With
        ' Add text and color to left frame.
        Selection.TypeText Text:="LEFT FRAME"
        With ActiveDocument.Background.Fill
            .ForeColor.RGB = RGB(204, 255, 255)
            .Visible = msoTrue
        End With
        Selection.TypeParagraph
        Selection.TypeParagraph
        ' Add hyperlinks to left frame.
        With ActiveDocument.Hyperlinks
            .Add Anchor:=Selection.Range, _
                Address:="one.htm", Target:="main"
            Selection.TypeParagraph
            Selection.TypeParagraph
            .Add Anchor:=Selection.Range, _
                Address:="two.htm", Target:="_top"
        End With

        ' Activate top frame.
        .Panes(1).Activate
        ' Set the height to 1 inch.
        With .ActivePane.Frameset
            .HeightType = wdFramesetSizeTypeFixed
            .Height = InchesToPoints(1)
            .FrameName = "top"
        End With

        ' Save the frames page and its associated files.
        .Document.SaveAs FileName:="default.htm", _
            FileFormat:=wdFormatHTML
    End With

End Sub

Erstellen einer Framesseite, in der Inhalte aus bereits vorhandenen Dateien angezeigt werden

In diesem Beispiel wird eine Framesseite ähnlich der im vorangegangenen Beispiel erstellt. Dabei wird jedoch als Standard-URL für jeden Frame ein bereits vorhandenes Dokument eingestellt, so dass in dem Frame der Inhalt des jeweiligen Dokuments angezeigt wird. Damit dieses Beispiel funktioniert, müssen Sie entweder Dateien mit den Namen Main.htm, Left.htm und Banner.htm erstellen oder die Namen von bereits vorhandenen Dateien einsetzen.

Sub FramesetExample2()

    ' Create new frames page.
    Documents.Add DocumentType:=wdNewFrameset

    With ActiveWindow
        ' Add new frame below top frame.
        .ActivePane.Frameset.AddNewFrame _
            wdFramesetNewFrameBelow
        ' Set the name and initial page for the frame.
        With .ActivePane.Frameset
            .FrameName = "main"
            .FrameDefaultURL = "main.htm"
        End With

        ' Add new frame to left of bottom frame.
        .ActivePane.Frameset.AddNewFrame _
            wdFramesetNewFrameLeft
        With .ActivePane.Frameset
            ' Set the width to 25% of the window width.
            .WidthType = wdFramesetSizeTypePercent
            .Width = 25
            ' Set the name and initial page for the frame.
            .FrameName = "left"
            .FrameDefaultURL = "left.htm"
        End With

        ' Activate top frame.
        .Panes(1).Activate
        With .ActivePane.Frameset
            ' Set the height to 1 inch.
            .HeightType = wdFramesetSizeTypeFixed
            .Height = InchesToPoints(1)
            ' Set the name and initial page for the frame.
            .FrameName = "top"
            .FrameDefaultURL = "banner.htm"
        End With

        ' Save the frameset.
        .Document.SaveAs FileName:="default.htm", _
            FileFormat:=wdFormatHTML
    End With

End Sub


Argumente für integrierte Dialogfelder

Viele der integrierten Dialogfelder in Microsoft Word besitzen Argumente, die Sie verwenden können, um in einem Dialogfeld Werte festzulegen oder Werte aus dem Dialogfeld auszulesen. Informieren Sie sich über das Anzeigen von integrierten Dialogfeldern bei Word.

WdWordDialog-Konstante | Argumente
wdDialogConnect | Drive, Path, Password
wdDialogControlRun | Application
wdDialogConvertObject | IconNumber, ActivateAs, IconFileName, Caption, Class, DisplayIcon, Floating
wdDialogCopyFile | FileName, Directory
wdDialogCreateAutoText | (keine)
wdDialogDocumentStatistics | FileName, Directory, Template, Title, Created, LastSaved, LastSavedBy, Revision, Time, Printed, Pages, Words, Characters, Paragraphs, Lines, FileSize
wdDialogDrawAlign | Horizontal, Vertical, RelativeTo
wdDialogDrawSnapToGrid | SnapToGrid, XGrid, YGrid, XOrigin, YOrigin, SnapToShapes, XGridDisplay, YGridDisplay, FollowMargins, ViewGridLines, DefineLineBasedOnGrid
wdDialogEditAutoText | Name, Context, InsertAs, Insert, Add, Define, InsertAsText, Delete, CompleteAT
wdDialogEditCreatePublisher | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogEditFind | Find, Replace, Direction, MatchCase, WholeWord, PatternMatch, SoundsLike, FindNext, ReplaceOne, ReplaceAll, Format, Wrap, FindAllWordForms, MatchByte, FuzzyFind, Destination, CorrectEnd, MatchKashida, MatchDiacritics, MatchAlefHamza, MatchControl
wdDialogEditGoTo | Find, Replace, Direction, MatchCase, WholeWord, PatternMatch, SoundsLike, FindNext, ReplaceOne, ReplaceAll, Format, Wrap, FindAllWordForms, MatchByte, FuzzyFind, Destination, CorrectEnd, MatchKashida, MatchDiacritics, MatchAlefHamza, MatchControl
wdDialogEditGoToOld | (keine)
wdDialogEditLinks | UpdateMode, Locked, SavePictureInDoc, UpdateNow, OpenSource, KillLink, Link, Application, Item, FileName
wdDialogEditObject | Verb
wdDialogEditPasteSpecial | IconNumber, Link, DisplayIcon, Class, DataType, IconFileName, Caption, Floating
wdDialogEditPublishOptions | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogEditReplace | Find, Replace, Direction, MatchCase, WholeWord, PatternMatch, SoundsLike, FindNext, ReplaceOne, ReplaceAll, Format, Wrap, FindAllWordForms, MatchByte, FuzzyFind, Destination, CorrectEnd, MatchKashida, MatchDiacritics, MatchAlefHamza, MatchControl
wdDialogEditSubscribeOptions | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogEditSubscribeTo | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogEditTOACategory | Category, CategoryName
wdDialogEmailOptions | (keine)
wdDialogFileDocumentLayout | Tab, PaperSize, TopMargin, BottomMargin, LeftMargin, RightMargin, Gutter, PageWidth, PageHeight, Orientation, FirstPage, OtherPages, VertAlign, ApplyPropsTo, Default, FacingPages, HeaderDistance, FooterDistance, SectionStart, OddAndEvenPages, DifferentFirstPage, Endnotes, LineNum, StartingNum, FromText, CountBy, NumMode, TwoOnOne, GutterPosition, LayoutMode, CharsLine, LinesPage, CharPitch, LinePitch, DocFontName, DocFontSize, PageColumns, TextFlow, FirstPageOnLeft, SectionType, RTLAlignment
wdDialogFileFind | SearchName, SearchPath, Name, SubDir, Title, Author, Keywords, Subject, Options, MatchCase, Text, PatternMatch, DateSavedFrom, DateSavedTo, SavedBy, DateCreatedFrom, DateCreatedTo, View, SortBy, ListBy, SelectedFile, Add, Delete, ShowFolders, MatchByte
wdDialogFileMacCustomPageSetupGX | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogFileMacPageSetup | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogFileMacPageSetupGX | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogFileNew | Template, NewTemplate, DocumentType, Visible
wdDialogFileOpen | Name, ConfirmConversions, ReadOnly, LinkToSource, AddToMru, PasswordDoc, PasswordDot, Revert, WritePasswordDoc, WritePasswordDot, Connection, SQLStatement, SQLStatement1, Format, Encoding, Visible
wdDialogFilePageSetup | Tab, PaperSize, TopMargin, BottomMargin, LeftMargin, RightMargin, Gutter, PageWidth, PageHeight, Orientation, FirstPage, OtherPages, VertAlign, ApplyPropsTo, Default, FacingPages, HeaderDistance, FooterDistance, SectionStart, OddAndEvenPages, DifferentFirstPage, Endnotes, LineNum, StartingNum, FromText, CountBy, NumMode, TwoOnOne, GutterPosition, LayoutMode, CharsLine, LinesPage, CharPitch, LinePitch, DocFontName, DocFontSize, PageColumns, TextFlow, FirstPageOnLeft, SectionType, RTLAlignment
wdDialogFilePrint | Background, AppendPrFile, Range, PrToFileName, From, To, Type, NumCopies, Pages, Order, PrintToFile, Collate, FileName, Printer, OutputPrinter, DuplexPrint, PrintZoomColumn, PrintZoomRow, PrintZoomPaperWidth, PrintZoomPaperHeight
wdDialogFilePrintOneCopy | (Informationen über diese Konstante finden Sie im Sprachverzeichnis von Microsoft Office 98 Macintosh Edition.)
wdDialogFilePrintSetup | Printer, Options, Network, DoNotSetAsSysDefault
wdDialogFileRoutingSlip | Subject, Message, AllAtOnce, ReturnWhenDone, TrackStatus, Protect, AddSlip, RouteDocument, AddRecipient, OldRecipient, ResetSlip, ClearSlip, ClearRecipients, Address
wdDialogFileSaveAs | Name, Format, LockAnnot, Password, AddToMru, WritePassword, RecommendReadOnly, EmbedFonts, NativePictureFormat, FormsData, SaveAsAOCELetter, WriteVersion, VersionDesc
wdDialogFileSaveVersion | (keine)
wdDialogFileSummaryInfo | Title, Subject, Author, Keywords, Comments, FileName, Directory, Template, CreateDate, LastSavedDate, LastSavedBy, RevisionNumber, EditTime, LastPrintedDate, NumPages, NumWords, NumChars, NumParas, NumLines, Update, FileSize
wdDialogFileVersions | AutoVersion, VersionDesc
wdDialogFitText | FitTextWidth
wdDialogFontSubstitution | UnavailableFont, SubstituteFont
wdDialogFormatAddrFonts | Points, Underline, Color, StrikeThrough, Superscript, Subscript, Hidden, SmallCaps, AllCaps, Spacing, Position, Kerning, KerningMin, Default, Tab, Font, Bold, Italic, DoubleStrikeThrough, Shadow, Outline, Emboss, Engrave, Scale, Animations, CharAccent, FontMajor, FontLowAnsi, FontHighAnsi, CharacterWidthGrid, ColorRGB, UnderlineColor, PointsBi, ColorBi, FontNameBi, BoldBi, ItalicBi, DiacColor
wdDialogFormatBordersAndShading | ApplyTo, Shadow, TopBorder, LeftBorder, BottomBorder, RightBorder, HorizBorder, VertBorder, TopColor, LeftColor, BottomColor, RightColor, HorizColor, VertColor, FromText, Shading, Foreground, Background, Tab, FineShading, TopStyle, LeftStyle, BottomStyle, RightStyle, HorizStyle, VertStyle, TopWeight, LeftWeight, BottomWeight, RightWeight, HorizWeight, VertWeight, BorderObjectType, BorderArtWeight, BorderArt, FromTextTop, FromTextBottom, FromTextLeft, FromTextRight, OffsetFrom, InFront, SurroundHeader, SurroundFooter, JoinBorder, LineColor, WhichPages, TL2BRBorder, TR2BLBorder, TL2BRColor, TR2BLColor, TL2BRStyle, TR2BLStyle, TL2BRWeight, TR2BLWeight, ForegroundRGB, BackgroundRGB, TopColorRGB, LeftColorRGB, BottomColorRGB, RightColorRGB, HorizColorRGB, VertColorRGB, TL2BRColorRGB, TR2BLColorRGB, LineColorRGB
wdDialogFormatBulletsAndNumbering | (keine)
wdDialogFormatCallout | Type, Gap, Angle, Drop, Length, Border, AutoAttach, Accent
wdDialogFormatChangeCase | Type
wdDialogFormatColumns | Columns, ColumnNo, ColumnWidth, ColumnSpacing, EvenlySpaced, ApplyColsTo, ColLine, StartNewCol, FlowColumnsRtl
wdDialogFormatDefineStyleBorders | ApplyTo, Shadow, TopBorder, LeftBorder, BottomBorder, RightBorder, HorizBorder, VertBorder, TopColor, LeftColor, BottomColor, RightColor, HorizColor, VertColor, FromText, Shading, Foreground, Background, Tab, FineShading, TopStyle, LeftStyle, BottomStyle, RightStyle, HorizStyle, VertStyle, TopWeight, LeftWeight, BottomWeight, RightWeight, HorizWeight, VertWeight, BorderObjectType, BorderArtWeight, BorderArt, FromTextTop, FromTextBottom, FromTextLeft, FromTextRight, OffsetFrom, InFront, SurroundHeader, SurroundFooter, JoinBorder, LineColor, WhichPages, TL2BRBorder, TR2BLBorder, TL2BRColor, TR2BLColor, TL2BRStyle, TR2BLStyle, TL2BRWeight, TR2BLWeight, ForegroundRGB, BackgroundRGB, TopColorRGB, LeftColorRGB, BottomColorRGB, RightColorRGB, HorizColorRGB, VertColorRGB, TL2BRColorRGB, TR2BLColorRGB, LineColorRGB
wdDialogFormatDefineStyleFont | Points, Underline, Color, StrikeThrough, Superscript, Subscript, Hidden, SmallCaps, AllCaps, Spacing, Position, Kerning, KerningMin, Default, Tab, Font, Bold, Italic, DoubleStrikeThrough, Shadow, Outline, Emboss, Engrave, Scale, Animations, CharAccent, FontMajor, FontLowAnsi, FontHighAnsi, CharacterWidthGrid, ColorRGB, UnderlineColor, PointsBi, ColorBi, FontNameBi, BoldBi, ItalicBi, DiacColor
wdDialogFormatDefineStyleFrame | Wrap, WidthRule, FixedWidth, HeightRule, FixedHeight, PositionHorz, PositionHorzRel, DistFromText, PositionVert, PositionVertRel, DistVertFromText, MoveWithText, LockAnchor, RemoveFrame
wdDialogFormatDefineStyleLang | Language, CheckLanguage, Default, NoProof
wdDialogFormatDefineStylePara | LeftIndent, RightIndent, Before, After, LineSpacingRule, LineSpacing, Alignment, WidowControl, KeepWithNext, KeepTogether, PageBreak, NoLineNum, DontHyphen, Tab, FirstIndent, OutlineLevel, Kinsoku, WordWrap, OverflowPunct, TopLinePunct, AutoSpaceDE, LineHeightGrid, AutoSpaceDN, CharAlign, CharacterUnitLeftIndent, AdjustRight, CharacterUnitFirstIndent, CharacterUnitRightIndent, LineUnitBefore, LineUnitAfter, OrientationBi
wdDialogFormatDefineStyleTabs | Position, DefTabs, Align, Leader, Set, Clear, ClearAll
wdDialogFormatDrawingObject | Left, PositionHorzRel, Top, PositionVertRel, LockAnchor, FloatOverText, WrapSide, TopDistanceFromText, BottomDistanceFromText, LeftDistanceFromText, RightDistanceFromText, Wrap, HRWidthType, HRHeight, HRNoshade, HRAlign, Text, AllowOverlap, HorizRule
wdDialogFormatDropCap | Position, Font, DropHeight, DistFromText
wdDialogFormatEncloseCharacters | Style, Text, Enclosure
wdDialogFormatFont | Points, Underline, Color, StrikeThrough, Superscript, Subscript, Hidden, SmallCaps, AllCaps, Spacing, Position, Kerning, KerningMin, Default, Tab, Font, Bold, Italic, DoubleStrikeThrough, Shadow, Outline, Emboss, Engrave, Scale, Animations, CharAccent, FontMajor, FontLowAnsi, FontHighAnsi, CharacterWidthGrid, ColorRGB, UnderlineColor, PointsBi, ColorBi, FontNameBi, BoldBi, ItalicBi, DiacColor
wdDialogFormatFrame | Wrap, WidthRule, FixedWidth, HeightRule, FixedHeight, PositionHorz, PositionHorzRel, DistFromText, PositionVert, PositionVertRel, DistVertFromText, MoveWithText, LockAnchor, RemoveFrame
wdDialogFormatPageNumber | ChapterNumber, NumRestart, NumFormat, StartingNum, Level, Separator, DoubleQuote, PgNumberingStyle
wdDialogFormatParagraph | LeftIndent, RightIndent, Before, After, LineSpacingRule, LineSpacing, Alignment, WidowControl, KeepWithNext, KeepTogether, PageBreak, NoLineNum, DontHyphen, Tab, FirstIndent, OutlineLevel, Kinsoku, WordWrap, OverflowPunct, TopLinePunct, AutoSpaceDE, LineHeightGrid, AutoSpaceDN, CharAlign, CharacterUnitLeftIndent, AdjustRight, CharacterUnitFirstIndent, CharacterUnitRightIndent, LineUnitBefore, LineUnitAfter, OrientationBi
wdDialogFormatPicture | SetSize, CropLeft, CropRight, CropTop, CropBottom, ScaleX, ScaleY, SizeX, SizeY
wdDialogFormatRetAddrFonts | Points, Underline, Color, StrikeThrough, Superscript, Subscript, Hidden, SmallCaps, AllCaps, Spacing, Position, Kerning, KerningMin, Default, Tab, Font, Bold, Italic, DoubleStrikeThrough, Shadow, Outline, Emboss, Engrave, Scale, Animations, CharAccent, FontMajor, FontLowAnsi, FontHighAnsi, CharacterWidthGrid, ColorRGB, UnderlineColor, PointsBi, ColorBi, FontNameBi, BoldBi, ItalicBi, DiacColor
wdDialogFormatSectionLayout | SectionStart, VertAlign, Endnotes, LineNum, StartingNum, FromText, CountBy, NumMode, SectionType
wdDialogFormatStyle | Name, Delete, Merge, NewName, BasedOn, NextStyle, Type, FileName, Source, AddToTemplate, Define, Rename, Apply, New
wdDialogFormatStyleGallery | Template, Preview
wdDialogFormatTabs | Position, DefTabs, Align, Leader, Set, Clear, ClearAll
wdDialogFormatTheme | (keine)
wdDialogFormFieldOptions | Entry, Exit, Name, Enable, TextType, TextWidth, TextDefault, TextFormat, CheckSize, CheckWidth, CheckDefault, Type, OwnHelp, HelpText, OwnStat, StatText, Calculate
wdDialogHelpAbout | APPNAME, APPCOPYRIGHT, APPUSERNAME, APPORGANIZATION, APPSERIALNUMBER
wdDialogHelpWordPerfectHelp | WPCommand, HelpText, DemoGuidance
wdDialogHelpWordPerfectHelpOptions | CommandKeyHelp, DocNavKeys, MouseSimulation, DemoGuidance, DemoSpeed, HelpType
wdDialogHorizontalInVertical | (keine)
wdDialogInsertAddCaption | Name
wdDialogInsertAutoCaption | Clear, ClearAll, Object, Label, Position
wdDialogInsertBookmark | Name, SortBy, Add, Delete, Goto, Hidden
wdDialogInsertBreak | Type
wdDialogInsertCaption | Label, TitleAutoText, Title, Delete, Position, AutoCaption
wdDialogInsertCaptionNumbering | Label, FormatNumber, ChapterNumber, Level, Separator, CapNumberingStyle
wdDialogInsertCrossReference | ReferenceType, ReferenceKind, ReferenceItem, InsertAsHyperLink, InsertPosition
wdDialogInsertDatabase | Format, Style, LinkToSource, Connection, SQLStatement, SQLStatement1, PasswordDoc, PasswordDot, DataSource, From, To, IncludeFields, WritePasswordDoc, WritePasswordDot
wdDialogInsertDateTime | DateTimePic, InsertAsField, DbCharField, DateLanguage, CalendarType
wdDialogInsertField | Field
wdDialogInsertFile | Name, Range, ConfirmConversions, Link, Attachment
wdDialogInsertFootnote | Reference, NoteType, Symbol
wdDialogInsertFormField | Entry, Exit, Name, Enable, TextType, TextWidth, TextDefault, TextFormat, CheckSize, CheckWidth, CheckDefault, Type, OwnHelp, HelpText, OwnStat, StatText, Calculate
wdDialogInsertHyperlink | (keine)
wdDialogInsertIndex | Outline, Fields, From, To, TableId, AddedStyles, Caption, HeadingSeparator, Replace, MarkEntry, AutoMark, MarkCitation, Type, RightAlignPageNumbers, Passim, KeepFormatting, Columns, Category, Label, ShowPageNumbers, AccentedLetters, Filter, SortBy, Leader, TOCUseHyperlinks, TOCHidePageNumInWeb, IndexLanguage
wdDialogInsertIndexAndTables | Outline, Fields, From, To, TableId, AddedStyles, Caption, HeadingSeparator, Replace, MarkEntry, AutoMark, MarkCitation, Type, RightAlignPageNumbers, Passim, KeepFormatting, Columns, Category, Label, ShowPageNumbers, AccentedLetters, Filter, SortBy, Leader, TOCUseHyperlinks, TOCHidePageNumInWeb, IndexLanguage
wdDialogInsertMergeField | MergeField, WordField
wdDialogInsertNumber | NumPic
wdDialogInsertObject | IconNumber, FileName, Link, DisplayIcon, Tab, Class, IconFileName, Caption, Floating
wdDialogInsertPageNumbers | Type, Position, FirstPage
wdDialogInsertPicture | Name, LinkToFile, New, FloatOverText
wdDialogInsertSubdocument | Name, ConfirmConversions, ReadOnly, LinkToSource, AddToMru, PasswordDoc, PasswordDot, Revert, WritePasswordDoc, WritePasswordDot, Connection, SQLStatement, SQLStatement1, Format, Encoding, Visible
wdDialogInsertSymbol | Font, Tab, CharNum, Unicode, Hint
wdDialogInsertTableOfAuthorities | Outline, Fields, From, To, TableId, AddedStyles, Caption, HeadingSeparator, Replace, MarkEntry, AutoMark, MarkCitation, Type, RightAlignPageNumbers, Passim, KeepFormatting, Columns, Category, Label, ShowPageNumbers, AccentedLetters, Filter, SortBy, Leader, TOCUseHyperlinks, TOCHidePageNumInWeb, IndexLanguage
wdDialogInsertTableOfContents | Outline, Fields, From, To, TableId, AddedStyles, Caption, HeadingSeparator, Replace, MarkEntry, AutoMark, MarkCitation, Type, RightAlignPageNumbers, Passim, KeepFormatting, Columns, Category, Label, ShowPageNumbers, AccentedLetters, Filter, SortBy, Leader, TOCUseHyperlinks, TOCHidePageNumInWeb, IndexLanguage
wdDialogInsertTableOfFigures | Outline, Fields, From, To, TableId, AddedStyles, Caption, HeadingSeparator, Replace, MarkEntry, AutoMark, MarkCitation, Type, RightAlignPageNumbers, Passim, KeepFormatting, Columns, Category, Label, ShowPageNumbers, AccentedLetters, Filter, SortBy, Leader, TOCUseHyperlinks, TOCHidePageNumInWeb, IndexLanguage
wdDialogLetterWizard | SenderCity, DateFormat, IncludeHeaderFooter, LetterStyle, Letterhead, LetterheadLocation, LetterheadSize, RecipientName, RecipientAddress, Salutation, SalutationType, RecipientGender, RecipientReference, MailingInstructions, AttentionLine, LetterSubject, CCList, SenderName, ReturnAddress, Closing, SenderJobTitle, SenderCompany, SenderInitials, EnclosureNumber, PageDesign, InfoBlock, SenderGender, ReturnAddressSF, RecipientCode, SenderCode, SenderReference
wdDialogListCommands | ListType
wdDialogMailMerge | CheckErrors, Destination, MergeRecords, From, To, Suppression, MailMerge, QueryOptions, MailSubject, MailAsAttachment, MailAddress
wdDialogMailMergeCheck | CheckErrors
wdDialogMailMergeCreateDataSource | FileName, PasswordDoc, PasswordDot, HeaderRecord, MSQuery, SQLStatement, SQLStatement1, Connection, LinkToSource, WritePasswordDoc
wdDialogMailMergeCreateHeaderSource | FileName, PasswordDoc, PasswordDot, HeaderRecord, MSQuery, SQLStatement, SQLStatement1, Connection, LinkToSource, WritePasswordDoc
wdDialogMailMergeFindRecord | Find, Field
wdDialogMailMergeHelper | Merge, Options
wdDialogMailMergeInsertAsk | Name, Prompt, DefaultBookmarkText, AskOnce
wdDialogMailMergeInsertFillIn | Prompt, DefaultFillInText, AskOnce
wdDialogMailMergeInsertIf | MergeField, Comparison, CompareTo, TrueAutoText, TrueText, FalseAutoText, FalseText
wdDialogMailMergeInsertNextIf | MergeField, Comparison, CompareTo
wdDialogMailMergeInsertSet | Name, ValueText, ValueAutoText
wdDialogMailMergeInsertSkipIf | MergeField, Comparison, CompareTo
wdDialogMailMergeOpenDataSource | Name, ConfirmConversions, ReadOnly, LinkToSource, AddToMru, PasswordDoc, PasswordDot, Revert, WritePasswordDoc, WritePasswordDot, Connection, SQLStatement, SQLStatement1, Format, Encoding, Visible
wdDialogMailMergeOpenHeaderSource | Name, ConfirmConversions, ReadOnly, LinkToSource, AddToMru, PasswordDoc, PasswordDot, Revert, WritePasswordDoc, WritePasswordDot, Connection, SQLStatement, SQLStatement1, Format, Encoding, Visible
wdDialogMailMergeQueryOptions | SQLStatement, SQLStatement1
wdDialogMailMergeUseAddressBook | AddressBookType
wdDialogMarkCitation | LongCitation, LongCitationAutoText, Category, ShortCitation, NextCitation, Mark, MarkAll
wdDialogMarkIndexEntry | MarkAll, Entry, Range, Bold, Italic, CrossReference, EntryAutoText, CrossReferenceAutoText, Yomi
wdDialogMarkTableOfContentsEntry | Entry, EntryAutoText, TableId, Level
wdDialogNewToolbar | Name, Context
wdDialogNoteOptions | FootnotesAt, FootNumberAs, FootStartingNum, FootRestartNum, EndnotesAt, EndNumberAs, EndStartingNum, EndRestartNum, FootNumberingStyle, EndNumberingStyle
wdDialogOrganizer | Copy, Delete, Rename, Source, Destination, Name, NewName, Tab
wdDialogPhoneticGuide | (keine)
wdDialogTableAutoFormat | HideAutoFit, Preview, Format, Borders, Shading, Font, Color, AutoFit, HeadingRows, FirstColumn, LastRow, LastColumn
wdDialogTableDeleteCells | ShiftCells
wdDialogTableFormatCell | Category
wdDialogTableFormula | Formula, NumFormat
wdDialogTableInsertCells | ShiftCells
wdDialogTableInsertRow | NumRows
wdDialogTableInsertTable | ConvertFrom, NumColumns, NumRows, InitialColWidth, Wizard, Format, Apply, AutoFit, SetDefault, Word8
wdDialogTableSort | DontSortHdr, FieldNum, Type, Order, FieldNum2, Type2, Order2, FieldNum3, Type3, Order3, Separator, SortColumn, CaseSensitive, SortBiDi, IgnoreHe, Diacritics, IgnoreThe, Kashida, Language
wdDialogTableSplitCells | NumColumns, NumRows, MergeBeforeSplit
wdDialogTableToText | ConvertTo, NestedTables
wdDialogTCSCTranslator | Direction, Varients, TranslateCommon
wdDialogTextToTable | ConvertFrom, NumColumns, NumRows, InitialColWidth, Wizard, Format, Apply, AutoFit, SetDefault, Word8
wdDialogToolsAcceptRejectChanges | ShowMarks, HideMarks, Wrap, FindPrevious, FindNext, AcceptRevisions, RejectRevisions, AcceptAll, RejectAll
wdDialogToolsAdvancedSettings | Application, Option, Setting, Delete, Set
wdDialogToolsAutoCorrect | InitialCaps, SentenceCaps, Days, CapsLock, ReplaceText, Formatting, Replace, With, Add, Delete, SmartQuotes, CorrectHangulAndAlphabet, ConvBrackets, ConvQuotes, ConvPunct, ReplaceTextFromSpellingChecker
wdDialogToolsAutoCorrectExceptions | Tab, Name, AutoAdd, Add, Delete
wdDialogToolsAutoManager | Tab
wdDialogToolsAutoSummarize | TextSize, Show, Update
wdDialogToolsBulletsNumbers | Replace, Font, CharNum, Type, FormatOutline, AutoUpdate, FormatNumber, Punctuation, StartAt, Points, Hang, Indent, Remove, DoubleQuote
wdDialogToolsCompareDocuments | Name
wdDialogToolsCreateDirectory | Directory
wdDialogToolsCreateEnvelope | ExtractAddress, LabelListIndex, LabelIndex, LabelDotMatrix, LabelTray, LabelAcross, LabelDown, EnvAddress, EnvOmitReturn, EnvReturn, PrintBarCode, SingleLabel, LabelRow, LabelColumn, PrintEnvLabel, AddToDocument, EnvWidth, EnvHeight, EnvPaperSize, PrintFIMA, UseEnvFeeder, Tab, AddrAutoText, AddrText, AddrFromLeft, AddrFromTop, RetAddrFromLeft, RetAddrFromTop, LabelTopMargin, LabelSideMargin, LabelVertPitch, LabelHorPitch, LabelHeight, LabelWidth, CustomName, RetAddrText, EnvPaperName, DefaultFaceUp, DefaultOrientation, RetAddrAutoText
wdDialogToolsCreateLabels | ExtractAddress, LabelListIndex, LabelIndex, LabelDotMatrix, LabelTray, LabelAcross, LabelDown, EnvAddress, EnvOmitReturn, EnvReturn, PrintBarCode, SingleLabel, LabelRow, LabelColumn, PrintEnvLabel, AddToDocument, EnvWidth, EnvHeight, EnvPaperSize, PrintFIMA, UseEnvFeeder, Tab, AddrAutoText, AddrText, AddrFromLeft, AddrFromTop, RetAddrFromLeft, RetAddrFromTop, LabelTopMargin, LabelSideMargin, LabelVertPitch, LabelHorPitch, LabelHeight, LabelWidth, CustomName, RetAddrText, EnvPaperName, DefaultFaceUp, DefaultOrientation, RetAddrAutoText
wdDialogToolsCustomize | KeyCode, KeyCode2, MenuType, Position, AddAll, Category, Name, Menu, AddBelow, MenuText, Rename, Add, Remove, ResetAll, CommandValue, Context, Tab
wdDialogToolsCustomizeKeyboard | KeyCode, KeyCode2, MenuType, Position, AddAll, Category, Name, Menu, AddBelow, MenuText, Rename, Add, Remove, ResetAll, CommandValue, Context, Tab
wdDialogToolsCustomizeMenuBar | Context, Position, MenuType, MenuText, Menu, Add, Remove, Rename
wdDialogToolsCustomizeMenus | KeyCode, KeyCode2, MenuType, Position, AddAll, Category, Name, Menu, AddBelow, MenuText, Rename, Add, Remove, ResetAll, CommandValue, Context, Tab
wdDialogToolsEnvelopesAndLabels | ExtractAddress, LabelListIndex, LabelIndex, LabelDotMatrix, LabelTray, LabelAcross, LabelDown, EnvAddress, EnvOmitReturn, EnvReturn, PrintBarCode, SingleLabel, LabelRow, LabelColumn, PrintEnvLabel, AddToDocument, EnvWidth, EnvHeight, EnvPaperSize, PrintFIMA, UseEnvFeeder, Tab, AddrAutoText, AddrText, AddrFromLeft, AddrFromTop, RetAddrFromLeft, RetAddrFromTop, LabelTopMargin, LabelSideMargin, LabelVertPitch, LabelHorPitch, LabelHeight, LabelWidth, CustomName, RetAddrText, EnvPaperName, DefaultFaceUp, DefaultOrientation, RetAddrAutoText
wdDialogToolsHighlightChanges | MarkRevisions, ViewRevisions, PrintRevisions, AcceptAll, RejectAll
wdDialogToolsHyphenation | AutoHyphenation, HyphenateCaps, HyphenationZone, LimitConsecutiveHyphens
wdDialogToolsLanguage | Language, CheckLanguage, Default, NoProof
wdDialogToolsMacro | Name, Run, Edit, Show, Delete, Rename, Description, NewName, SetDesc
wdDialogToolsMacroRecord | (Dieses Dialogfeld kann nicht durch ein Makro aufgerufen werden.)
wdDialogToolsManageFields | FieldName, Add, Remove, Rename, NewName
wdDialogToolsMergeDocuments | Name
wdDialogToolsOptions | Tab
wdDialogToolsOptionsAutoFormat | ApplyStylesHeadings, ApplyStylesLists, ApplyBulletedLists, ApplyStylesOtherParas, ReplaceQuotes, ReplaceOrdinals, ReplaceFractions, ReplaceSymbols, ReplacePlainTextEmphasis, ReplaceHyperlinks, PreserveStyles, PlainTextWordMail, ApplyFirstIndent, MatchParentheses, ReplaceDbDashes, ReplaceAutoSpaces
wdDialogToolsOptionsAutoFormatAsYouType | ApplyStylesHeadings, ApplyBorders, ApplyTables, ApplyDates, ApplyBulletedLists, ApplyNumberedLists, ApplyFirstIndent, ApplyClosings, ReplaceQuotes, ReplaceOrdinals, ReplaceFractions, ReplaceSymbols, ReplacePlainTextEmphasis, ReplaceHyperlinks, MatchParentheses, ReplaceAutoSpaces, ReplaceDbDashes, FormatListItemBeginning, DefineStyles, InsertOvers, InsertClosings, AutoLetterWizard, ShowOptionsFor, ApplyStylesLists, ApplySkipList, ApplyStylesOtherParas, ReplaceBullets, AdjustParaMarks, AdjustTabsSpaces, AdjustEmptyParas, PreserveStyles
wdDialogToolsOptionsBidi | DocViewDir, AddCtrlCopy, HebDoubleQuote, Numbers, Move, Sel, BiDirectional, ShowDiac, DiffDiacColor, Date, AdvanceHijri, MasterDocDir, OutlineDir, DiacriticColorVal
wdDialogToolsOptionsCompatibility | Product, Default, NoTabHangIndent, NoSpaceRaiseLower, PrintColBlack, WrapTrailSpaces, NoColumnBalance, ConvMailMergeEsc, SuppressSpBfAfterPgBrk, SuppressTopSpacing, OrigWordTableRules, TransparentMetafiles, ShowBreaksInFrames, SwapBordersFacingPages, LeaveBackslashAlone, ExpandShiftReturn, DontULTrailSpace, DontBalanceSbDbWidth, SuppressTopSpacingMac5, SpacingInWholePoints, PrintBodyTextBeforeHeader, NoLeading, NoSpaceForUL, MWSmallCaps, NoExtraLineSpacing, TruncateFontHeight, SubFontBySize, UsePrinterMetrics, WW6BorderRules, ExactOnTop, SuppressBottomSpacing, WPSpaceWidth, WPJustification, LineWrapLikeWord6, SpLayoutLikeWW8, FtnLayoutLikeWW8, DontUseHTMLParagraphAutoSpacing, DontAdjustLineHeightInTable, ForgetLastTabAlignment, UseAutospaceForFullWidthAlpha, AlignTablesRowByRow, LayoutRawTableWidth, LayoutTableRowsApart, UseWord97LineBreakingRules
wdDialogToolsOptionsEdit | ReplaceSelection, DragAndDrop, AutoWordSelection, InsForPaste, Overtype, SmartCutPaste, AllowAccentedUppercase, PictureEditor, TabIndent, BsParaAlign, InlineConversion, IMELosingFocus, AllowClickAndTypeMouse, ClickAndTypeParagraphStyle, AutoKeyBi
wdDialogToolsOptionsFileLocations | Path, Setting
wdDialogToolsOptionsFuzzy | FuzzyCase, FuzzyByte, FuzzyHira, FuzzySmKana, FuzzyMinus, FuzzyRepSymbol, FuzzyKanji, FuzzyOldKana, FuzzyLongVowel, FuzzyDZ, FuzzyBV, FuzzyTC, FuzzyHF, FuzzyZJ, FuzzyAY, FuzzyKIKU, FuzzyPunct, FuzzySpace
wdDialogToolsOptionsGeneral | Pagination, WPHelp, WPDocNavKeys, BlueScreen, ErrorBeeps, Effects3d, UpdateLinks, SendMailAttach, RecentFiles, RecentFileCount, Units, ButtonFieldClicks, ShortMenuNames, RTFInClipboard, ConfirmConversions, TipWizardActive, AnimatedCursors, VirusProtection, SeparateFont, InterpretHIANSIToDBC, ExitWithRestoreSession, AsianText, PixelsInDialogs, UseCharacterUnit
wdDialogToolsOptionsPrint | Draft, Reverse, UpdateFields, Summary, ShowCodes, Annotations, ShowHidden, EnvFeederInstalled, WidowControl, DfltTrueType, UpdateLinks, Background, DrawingObjects, FormsData, DefaultTray, PSOverText, MapPaperSize, FractionalWidths, PrOrder1, PrOrder2
wdDialogToolsOptionsSave | CreateBackup, FastSaves, SummaryPrompt, GlobalDotPrompt, NativePictureFormat, EmbedFonts, FormsData, AutoSave, SaveInterval, Password, WritePassword, RecommendReadOnly, SubsetFonts, BackgroundSave, DefaultSaveFormat, AddCtrlSave
wdDialogToolsOptionsSpellingAndGrammar | AlwaysSuggest, SuggestFromMainDictOnly, IgnoreAllCaps, IgnoreMixedDigits, ResetIgnoreAll, Type, CustomDict1, CustomDict2, CustomDict3, CustomDict4, CustomDict5, CustomDict6, CustomDict7, CustomDict8, CustomDict9, CustomDict10, AutomaticSpellChecking, FilenamesEmailAliases, UserDict1, AutomaticGrammarChecking, ForegroundGrammar, ShowStatistics, Options, RecheckDocument, IgnoreAuxFind, IgnoreMissDictSearch, HideGrammarErrors, CheckSpelling, GrLidUI, SpLidUI, DictLang1, DictLang2, DictLang3, DictLang4, DictLang5, DictLang6, DictLang7, DictLang8, DictLang9, DictLang10, HideSpellingErrors, HebSpellStart, InitialAlefHamza, FinalYaa, GermanPostReformSpell, AraSpeller, ProcessCompoundNoun
wdDialogToolsOptionsTrackChanges | InsertedTextMark, InsertedTextColor, DeletedTextMark, DeletedTextColor, RevisedLinesMark, RevisedLinesColor, HighlightColor, RevisedPropertiesMark, RevisedPropertiesColor
wdDialogToolsOptionsTypography | KerningPairs, Justification, PunctLevel, FollowingPunct, LeadingPunct, ApplyToTemplate, JapaneseKinsokuStrict, FarEastLineBreakLanguage
wdDialogToolsOptionsUserInfo | Name, Initials, Address
wdDialogToolsOptionsView | DraftFont, WrapToWindow, PicturePlaceHolders, FieldCodes, BookMarks, FieldShading, StatusBar, HScroll, VScroll, StyleAreaWidth, Tabs, Spaces, Paras, Hyphens, Hidden, ShowAll, Drawings, Anchors, TextBoundaries, VRuler, Highlight, ShowAnimation, ScrnTp, LeftScroll, RRuler, OptionalBreak, EnlargeFontsLessThan, BrowseToWindow
wdDialogToolsProtectDocument | DocumentPassword, NoReset, Type
wdDialogToolsProtectSection | Protect, Section
wdDialogToolsRevisions | MarkRevisions, ViewRevisions, PrintRevisions, AcceptAll, RejectAll
wdDialogToolsSpellingAndGrammar | SuggestionListBox, ForegroundGrammar
wdDialogToolsTemplates | Store, Template, LinkStyles
wdDialogToolsThesaurus | (keine)
wdDialogToolsUnprotectDocument | DocumentPassword
wdDialogToolsWordCount | CountFootnotes, Pages, Words, Characters, DBCs, SBCs, CharactersIncludingSpaces, Paragraphs, Lines
wdDialogTwoLinesInOne | (keine)
wdDialogUpdateTOC | (keine)
wdDialogViewZoom | AutoFit, TwoPages, FullPage, NumColumns, NumRows, ZoomPercent, TextFit
wdDialogWebOptions | (keine)
wdDialogWindowActivate | Window


Anzeigen eines benutzerdefinierten Dialogfeldes

Klicken Sie zum Testen Ihres Dialogfeldes im Visual Basic-Editor im Menü Ausführen auf Sub/UserForm ausführen.

Verwenden Sie zum Anzeigen Ihres Dialogfeldes aus Visual Basic heraus die Show-Methode. Im folgenden Beispiel wird das Dialogfeld mit dem Namen "UserForm1" angezeigt.

Private Sub GetUserName()
    UserForm1.Show
End Sub

Anmerkung Verwenden Sie in einer Ereignisprozedur, z. B. der Click-Ereignisprozedur einer Befehlsschaltfläche, die Unload-Methode, um ein Dialogfeld zu schließen.


Objekt unterstützt diese Eigenschaft oder Methode nicht

Der Fehler "Objekt unterstützt diese Eigenschaft oder Methode nicht" tritt auf, wenn Sie versuchen, eine Methode oder Eigenschaft zu verwenden, die das angegebene Objekt nicht unterstützt. Die folgende Anweisung verursacht beispielsweise einen Fehler.

ActiveDocument.Copy

Die ActiveDocument-Eigenschaft gibt ein Document-Objekt zurück. Eine Copy-Methode oder -Eigenschaft steht dem Document-Objekt nicht zur Verfügung, daher tritt ein Fehler auf. Wenn Sie feststellen wollen, welche Eigenschaften und Methoden einem Objekt zur Verfügung stehen, können Sie eines der folgenden Verfahren anwenden.

  • Verwenden Sie den Objektkatalog zum Ermitteln, welche Elemente (Eigenschaften und Methoden) für die ausgewählte Klasse (das Objekt) zur Verfügung stehen.

  • Verwenden Sie im Visual Basic-Editor die Funktion "Elemente automatisch auflisten". Wenn Sie im Visual Basic-Editor nach einer Eigenschaft oder Methode einen Punkt (.) eingeben, wird eine Liste der zur Verfügung stehenden Eigenschaften und Methoden angezeigt.

  • Verwenden Sie die Word Visual Basic-Hilfe zum Ermitteln, welche Eigenschaften und Methoden bei einem Objekt verwendet werden können. Jedes Objektthema in der Hilfe enthält einen Sprung zu Eigenschaften und Methoden, der eine Liste der Eigenschaften und Methoden für das Objekt anzeigt. Drücken Sie im Objektkatalog oder in einem Modul F1, damit das entsprechende Hilfethema angezeigt wird.

  • Verwenden Sie die Funktion TypeName zum Ermitteln des Objekttyps, der von einem Ausdruck zurückgegeben wird. Im folgenden Beispiel wird "Range" angezeigt, weil die Content-Eigenschaft ein Range-Objekt zurückgibt.
    MsgBox TypeName(ActiveDocument.Content)


Fehler beim Zugriff auf eine Tabellenzeile oder -spalte

Wenn Sie versuchen, auf eine einzelne Zeile oder Spalte in einer gezeichneten Tabelle zuzugreifen, kann ein Laufzeitfehler auftreten, wenn die Tabelle nicht einheitlich ist. Beispielsweise führt die folgende Anweisung zu einem Fehler, wenn die erste Tabelle im aktiven Dokument nicht dieselbe Anzahl von Zeilen in jeder Spalte hat.

ActiveDocument.Tables(1).Rows(1).Borders.Enable = False

Sie können diesen Fehler vermeiden, indem Sie zuerst die Zellen in einer Spalte oder Zeile mit Hilfe der SelectColumn- oder SelectRow-Methode markieren. Nach dem Erstellen der Markierung verwenden Sie die Cells-Eigenschaft beim Selection-Objekt. Im folgenden Beispiel wird die erste Zeile in der ersten Dokumenttabelle markiert. Die Cells-Eigenschaft wird für den Zugriff auf die markierten Zellen (alle Zellen in der ersten Zeile) verwendet, so dass Rahmen entfernt werden können.

ActiveDocument.Tables(1).Cell(1, 1).Select
With Selection
    .SelectRow
    .Cells.Borders.Enable = False
End With

Im folgenden Beispiel wird die erste Spalte in der ersten Dokumenttabelle markiert. Über die For Each...Next-Schleife wird jeder Zelle in der Markierung (allen Zellen in der ersten Spalte) Text hinzugefügt.

ActiveDocument.Tables(1).Cell(1, 1).Select
Selection.SelectColumn
i = 1
For Each oCell In Selection.Cells
    oCell.Range.Text = "Cell " & i
    i = i + 1
Next oCell


Aufrufen von Hilfe zu Macintosh-Stichwörtern

Sie haben Hilfe zu einem Visual Basic-Stichwort aufgerufen, das nur für den Macintosh Gültigkeit besitzt. Weitere Informationen über dieses Stichwort erhalten Sie in der Sprachverzeichnis-Hilfe, die im Lieferumfang der Microsoft Office 98 Macintosh Edition enthalten ist.


Initialisieren der Eigenschaften von Steuerelementen

Mit Visual Basic-Code in einem Makro können Sie Steuerelemente beim Ausführen des Makros initialisieren. So können Sie z. B. ein Listenfeld mit Werten füllen und Textwerte oder Optionsfelder festlegen.

Im folgenden Beispiel wird die AddItem-Methode verwendet, um Daten in ein Listenfeld mit dem Namen "lstRegions" einzufügen. Anschließend wird der Wert eines Textfeldes festgelegt und das Formular angezeigt.

Private Sub GetUserName()
    With UserForm1
        .lstRegions.AddItem "North"
        .lstRegions.AddItem "South"
        .lstRegions.AddItem "East"
        .lstRegions.AddItem "West"
        .txtSalesPersonID.Text = "00000"
        .Show
        ' ...
    End With
End Sub

Sie können auch Code im Initialize-Ereignis eines Formulars verwenden, um Startwerte für Steuerelemente des Formulars festzulegen. Der Vorteil dabei liegt darin, dass der Startcode beim Formular verbleibt. So können Sie das Formular in ein anderes Projekt kopieren, und die Steuerelemente werden initialisiert, sobald Sie die Show-Methode aufrufen, um das Dialogfeld anzuzeigen.

Private Sub UserForm_Initialize()
    With UserForm1
        With .lstRegions
            .AddItem "North"
            .AddItem "South"
            .AddItem "East"
            .AddItem "West"
        End With
        .txtSalesPersonID.Text = "00000"
    End With
End Sub


Eine Auflistung durchlaufen

Es gibt mehrere verschiedene Verfahren, wie Sie die Elemente einer Auflistung durchlaufen können. Zu empfehlen ist aber die Methode mit der For Each...Next-Schleife. In dieser Struktur wiederholt Visual Basic einen Anweisungsblock für jedes Objekt in einer Auflistung. Im folgenden Beispiel wird der Name jedes Dokuments in der Documents-Auflistung angezeigt.

For Each aDoc In Documents
    MsgBox aDoc.Name
Next aDoc

Anstatt jeden Elementnamen in einem Meldungsfeld anzuzeigen, können Sie ein Datenfeld zum Speichern der Informationen verwenden. In diesem Beispiel wird das Datenfeld aMarks() zum Speichern des Namens jeder Textmarke verwendet, die im aktiven Dokument enthalten ist.

If ActiveDocument.Bookmarks.Count >= 1 Then
    ReDim aMarks(ActiveDocument.Bookmarks.Count - 1)
    i = 0
    For Each aBookmark In ActiveDocument.Bookmarks
        aMarks(i) = aBookmark.Name
        i = i + 1
    Next aBookmark
End If

Sie können eine Auflistung durchlaufen, um eine Aufgabe an Elementen der Auflistung bedingungsweise durchzuführen. Im folgenden Beispiel werden die DATE-Felder im aktiven Dokument aktualisiert.

For Each aField In ActiveDocument.Fields
    If InStr(1, aField.Code, "Date", 1) Then aField.Update
Next aField

Sie können eine Auflistung durchlaufen, wenn Sie feststellen wollen, ob ein Element vorhanden ist. Im folgenden Beispiel wird eine Meldung angezeigt, wenn der AutoText-Eintrag "temp" Teil der AutoTextEntries-Auflistung ist.

For Each aEntry In ActiveDocument.AttachedTemplate.AutoTextEntries
    If aEntry.Name = "temp" Then _
        MsgBox "temp AutoText entry exists"
Next aEntry


Angefordertes Element der Auflistung ist nicht vorhanden.

Der Fehler "Angefordertes Element der Auflistung ist nicht vorhanden" tritt auf, wenn Sie versuchen, auf ein Objekt zuzugreifen, das nicht existiert. Beispielsweise kann die folgende Anweisung einen Fehler verursachen, wenn das aktive Dokument nicht mindestens eine Tabelle enthält.

ActiveDocument.Tables(1).Select

Um diesen Fehler beim Zugriff auf ein Element einer Auflistung zu vermeiden, müssen Sie sicherstellen, dass das Element vorhanden ist, bevor Sie auf das Auflistungselement zugreifen. Wenn Sie über die Indexnummer auf das Element zugreifen, können Sie die Count-Eigenschaft verwenden, um zu ermitteln, ob das Element vorhanden ist. Im folgenden Beispiel wird die erste Tabelle markiert, wenn im aktiven Dokument mindestens eine Tabelle vorhanden ist.

If ActiveDocument.Tables.Count >=1 Then
    ActiveDocument.Tables(1).Select
Else
    MsgBox "Document doesn't contain a table"
End If

Wenn Sie über den Namen auf ein Auflistungselement zugreifen, können Sie mit Hilfe einer For Each...Next-Schleife alle Elemente der Auflistung durchlaufen, um zu ermitteln, ob das benannte Element Teil der Auflistung ist. Im folgenden Beispiel wird der AutoKorrektur-Eintrag "acheive" gelöscht, wenn er Teil der AutoCorrectEntries-Auflistung ist.

For Each aEntry In AutoCorrect.Entries
    If aEntry.Name = "acheive" Then aEntry.Delete
Next aEntry


Verschiedene Aufgaben

Dieses Thema enthält Visual Basic-Beispiele für die folgenden Aufgaben:

  • Ändern der Ansicht

  • Einfügen von Text in eine Kopf- oder Fußzeile

  • Einstellen von Optionen

  • Ändern des Dokumentlayouts

  • Durchlaufen von Absätzen in einem Dokument

  • Anpassen von Menüs und Symbolleisten

Ändern der Ansicht

Das View-Objekt umfasst Eigenschaften und Methoden, die sich auf Ansichtsattribute (Alle anzeigen, Feldschattierung, Tabellengitternetzlinien usw.) für ein Fenster oder einen Ausschnitt beziehen. Im folgenden Beispiel wird die Ansicht in Druckansicht geändert.

ActiveDocument.ActiveWindow.View.Type = wdPrintView

Einfügen von Text in eine Kopf- oder Fußzeile

Das HeaderFooter-Objekt wird von der Headers-, Footers- und HeaderFooter-Eigenschaft zurückgegeben. Im folgenden Beispiel wird der Text in der Kopfzeile der aktuellen Seite geändert.

ActiveDocument.ActiveWindow.View.SeekView = wdSeekCurrentPageHeader
Selection.HeaderFooter.Range.Text = "Header text"

In diesem Beispiel wird ein Range-Objekt (oRange) erstellt, das sich auf die primäre Fußzeile für den ersten Abschnitt im aktiven Dokument bezieht. Nachdem das Range-Objekt festgelegt ist, wird der vorhandene Fußzeilentext gelöscht. Der Fußzeile wird das FILENAME-Feld zusammen mit zwei Tabstopps und dem AUTHOR-Feld hinzugefügt.

Set oRange = ActiveDocument.Sections(1) _
    .Footers(wdHeaderFooterPrimary).Range
With oRange
    .Delete
    .Fields.Add Range:=oRange, Type:=wdFieldFileName, Text:="\p"
    .InsertAfter Text:=vbTab & vbTab
    .Collapse Direction:=wdCollapseStart
    .Fields.Add Range:=oRange, Type:=wdFieldAuthor
End With

Erstellen von Optionen

Das Options-Objekt umfasst Eigenschaften, die Elementen im Dialogfeld Optionen des Menüs Extras entsprechen. Im folgenden Beispiel werden drei Anwendungsoptionen für Word eingestellt.

With Options
    .AllowDragAndDrop = True
    .ConfirmConversions = False
    .MeasurementUnit = wdPoints
End With

Ändern des Dokumentlayouts

Das PageSetup-Objekt enthält alle Seiteneinrichtungsattribute eines Dokuments (linker Seitenrand, Seitenrand unten, Papierformat usw.) als Eigenschaften. Im folgenden Beispiel werden die Seitenrandwerte für das aktive Dokument festgelegt.

With ActiveDocument.PageSetup
    .LeftMargin = InchesToPoints(0.75)
    .RightMargin = InchesToPoints(0.75)
    .TopMargin = InchesToPoints(1.5)
    .BottomMargin = InchesToPoints(1)
End With

Durchlaufen von Absätzen in einem Dokument

In diesem Beispiel werden alle Absätze im aktiven Dokument durchlaufen. Wenn die Einstellung "Abstand vor" für einen Absatz 6 Punkt lautet, wird der Abstand in diesem Beispiel auf 12 Punkt geändert.

For Each aPara In ActiveDocument.Paragraphs
   If aPara.SpaceBefore = 6 Then oPara.SpaceBefore = 12
Next aPara

Weitere Informationen finden Sie unter Durchlaufen einer Auflistung.

Anpassen von Menüs und Symbolleisten

Das CommandBar-Objekt stellt sowohl Menüs als auch Symbolleisten dar. Verwenden Sie die CommandBars-Eigenschaft mit einem Menünamen oder Symbolleistennamen zur Rückgabe eines einzelnen CommandBar-Objekts. Die Controls-Eigenschaft gibt ein CommandBarControls-Objekt zurück, das sich auf die Elemente auf der angegebenen Befehlsleiste bezieht. Im folgenden Beispiel wird dem Menü Extras der Befehl Wörter zählen hinzugefügt.

CustomizationContext = NormalTemplate
CommandBars("Tools").Controls.Add _
    Type:=msoControlButton, ID:=792, Before:=6

Im folgenden Beispiel wird der Symbolleiste Format der Befehl Doppelt unterstrichen hinzugefügt.

CustomizationContext = NormalTemplate
CommandBars("Formatting").Controls.Add _
    Type:=msoControlButton, ID:=60, Before:=7

Schalten Sie die Makroaufzeichnung ein, und passen Sie ein Menü oder eine Symbolleiste an, um den ID-Wert für einen bestimmten Befehl zu ermitteln (z. B. ist ID 60 der Befehl Doppelt unterstrichen).


Vordefinierte Textmarken

Word legt einige reservierte Textmarken fest und aktualisiert diese automatisch. Diese vordefinierten Textmarken können genauso verwendet werden wie die Textmarken, die in Dokumenten platziert werden, mit der Ausnahme, dass diese nicht festgelegt werden dürfen und nicht auf der Registerkarte Gehe zu im Dialogfeld Suchen und Ersetzen (Menü Bearbeiten) aufgeführt sind.

Sie können vordefinierte Textmarken mit der Bookmarks-Eigenschaft verwenden. Im folgenden Beispiel wird festgelegt, dass die Textmarke "currpara" an die Position gebracht wird, die durch die vordefinierte Textmarke "\Para" bezeichnet ist.

ActiveDocument.Bookmarks("\Para").Copy "currpara"

In der folgenden Tabelle sind die vordefinierten Textmarken aufgeführt, die in Word verfügbar sind.

Textmarke | Beschreibung
\Sel | Aktuelle Markierung oder die Einfügemarke.
\PrevSel1 | Die letzte Markierung, bei der eine Bearbeitung erfolgte. Wenn Sie zu dieser Textmarke gehen, entspricht dies einem einmaligen Aufruf der GoBack-Methode.
\PrevSel2 | Die vorletzte Markierung, bei der eine Bearbeitung erfolgte. Wenn Sie zu dieser Textmarke gehen, entspricht dies einem zweimaligen Aufruf der GoBack-Methode.
\StartOfSel | Anfang der aktuellen Markierung.
\EndOfSel | Ende der aktuellen Markierung.
\Line | Die aktuelle Zeile bzw. die erste Zeile der aktuellen Markierung. Wenn die Einfügemarke sich am Ende einer Zeile befindet, bei der es sich nicht um die letzte Zeile eines Absatzes handelt, schließt die Textmarke die gesamte nächste Zeile ein.
\Char | Aktuelles Zeichen, bei dem es sich um das Zeichen nach der Einfügemarke handelt, wenn nichts markiert ist oder das Zeichen am Anfang der Markierung steht.
\Para | Aktueller Absatz, bei dem es sich um den Absatz handelt, der die Einfügemarke enthält. Wenn mehrere Absätze markiert sind, handelt es sich um den ersten Absatz der Markierung. Wenn sich die Einfügemarke oder Markierung im letzten Absatz des Dokuments befindet, schließt die Textmarke "\Para" die Absatzmarke nicht ein.
\Section | Aktueller Abschnitt, einschließlich des Wechsels am Ende des Abschnitts, falls vorhanden. Der aktuelle Abschnitt enthält die Einfügemarke oder die Markierung. Enthält die Markierung mehrere Abschnitte, ist die Textmarke "\Section" der erste Abschnitt in der Markierung.
\Doc | Gesamter Inhalt des aktiven Dokuments, mit Ausnahme der letzten Absatzmarke.
\Page | Aktuelle Seite, einschließlich des Wechsels am Ende der Seite, falls vorhanden. Die aktuelle Seite enthält die Einfügemarke. Enthält die aktuelle Markierung mehrere Seiten, ist die Textmarke "\Page" die erste Seite der Markierung. Befindet sich die Einfügemarke oder Markierung auf der letzten Seite des Dokuments, enthält die Textmarke "\Page" nicht die letzte Absatzmarke.
\StartOfDoc | Der Anfang des Dokuments.
\EndOfDoc | Das Ende des Dokuments.
\Cell | Aktuelle Zelle in einer Tabelle, bei der es sich um die Zelle handelt, die die Einfügemarke enthält. Sind eine oder mehrere Zellen einer Tabelle in die aktuelle Markierung eingeschlossen, ist die Textmarke "\Cell" die erste Zelle in der Markierung.
\Table | Aktuelle Tabelle, bei der es sich um die Tabelle handelt, die die Einfügemarke oder die Markierung enthält. Schließt die Markierung mehrere Tabellen ein, ist die Textmarke "\Table" die gesamte erste Tabelle der Markierung. Dies ist auch der Fall, wenn nicht die gesamte Tabelle markiert ist.
\HeadingLevel | Die Überschrift, die die Einfügemarke oder die Markierung mit untergeordneten Überschriften und Text enthält. Handelt es sich bei der aktuellen Markierung um Textkörper, schließt die Textmarke "\HeadingLevel" die vorhergehende Überschrift mit allen Überschriften und Text ein, die der Überschrift untergeordnet sind.


Informationen anfordern

Es gibt mehrere verschiedene Verfahren, wie Sie von einem Benutzer Informationen anfordern können.

  • Verwenden Sie die Funktion InputBox zum Anzeigen eines Dialogfelds mit einer Meldung und einem Textfeld. Wenn der Benutzer auf OK klickt, gibt die Funktion den Text zurück, den der Benutzer eingegeben hat.

  • Verwenden Sie die Funktion MsgBox zur Anzeige einer einfachen Meldung. Sie können mehrere verschiedene Befehlsschaltflächen und Symbole anzeigen. Diese Funktion gibt eine Zahl zurück, die angibt, welche Schaltfläche angeklickt wurde.

  • Verwenden Sie ein integriertes Word-Dialogfeld, wenn Sie für eine bestimmte Word-Funktion eine Benutzereingabe erhalten wollen.

  • Verwenden Sie ein benutzerdefiniertes Formular, wenn Sie vom Benutzer eine Eingabe erhalten wollen. Informationen über das Hinzufügen von Steuerelementen zu einem Formular finden Sie unter Hinzufügen eines Steuerelements zu einem Formular.


 Zurückgeben eines Objekts aus einer Auflistung

Zurückgeben eines Objekts aus einer Auflistung

Die Item-Methode gibt ein einzelnes Objekt von einer Auflistung zurück. Im folgenden Beispiel wird der Variablen erstesDok ein Document-Objekt zugewiesen, das das erste Dokument in der Documents-Auflistung darstellt.

Set firstDoc = Documents.Item(1)

Die Item-Methode ist die Standardmethode für die meisten Auflistungen, daher können Sie dieselbe Anweisung kürzer schreiben, indem Sie das Schlüsselwort Item weglassen.

Set firstDoc = Documents(1)

Benannte Objekte

Normalerweise können Sie einen ganzzahligen Wert bei der Item-Methode angeben, aber manchmal kann es bequemer sein, ein Objekt über seinen Namen zurückzugeben. Im folgenden Beispiel erhält das Dokument Verkauf.doc den Fokus.

Documents("Sales.doc").Activate

Im folgenden Beispiel wird im aktiven Dokument der Textbereich markiert, der durch die Textmarke "temp" gekennzeichnet ist.

ActiveDocument.Bookmarks("temp").Select

Nicht in allen Auflistungen kann ein Objekt über den Namen angesprochen werden. Wenn Sie die zulässigen Auflistungsindexwerte ermitteln wollen, schauen Sie im Auflistungsobjekt-Thema nach.

Vordefinierte Indexwerte

Manche Auflistungen haben vordefinierte Indexwerte, die Sie zur Zurückgabe einzelner Objekte verwenden können. Jeder vordefinierte Indexwert wird durch eine Konstante dargestellt. Beispielsweise geben Sie bei der Borders-Eigenschaft zur Zurückgabe eines einzelnen Border-Objekts eine Konstante WdBorderType an.

Im folgenden Beispiel wird ein einzelner, 0,75 Punkt dicker Rahmen unter dem ersten Absatz in der Markierung hinzugefügt.

With Selection.Paragraphs(1).Borders(wdBorderBottom)
    .LineStyle = wdLineStyleSingle
    .LineWidth = wdLineWidth075pt
End With


Zurückgabe eines einzelnen Objekts von einer Auflistung

Informationen über die Zurückgabe eines einzelnen Objekts finden Sie im Objektthema selbst und im Auflistungsobjektthema für die Auflistung, die das Objekt enthält. Die meisten Objektthemen enthalten sowohl Informationen über die Zurückgabe eines einzelnen Objekts als auch über das Hinzufügen eines Objekts zur Auflistung dieser Objekte. Die meisten Auflistungsobjektthemen enthalten Informationen über die Zurückgabe der Auflistung selbst und über das Hinzufügen eines Objekts zu der Auflistung.

Wenn Sie die Hilfethemen für die Objekte und Auflistungen in Word durchsuchen wollen, siehe Microsoft Word-Objekte.


Verwenden der Werte von Steuerelementen beim Ausführen von Code

Einige Steuerelement-Eigenschaften können festgelegt und zurückgegeben werden, während der Visual Basic-Code läuft. Im folgenden Beispiel wird die Text-Eigenschaft eines Textfeldes auf "Hello" gesetzt.

TextBox1.Text = "Hello"

Die Daten, die ein Benutzer in einem Formular eingegeben hat, gehen verloren, sobald das Formular geschlossen wird. Wenn Sie die Werte der Steuerelemente auf einem Formular zurückgeben, nachdem das Formular entladen wurde, werden nicht die vom Benutzer eingegebenen Werte, sondern die Startwerte für die Steuerelemente zurückgegeben.

Wenn Sie die Daten speichern möchten, die in ein Formular eingegeben wurden, können Sie die Informationen in Modulvariablen speichern, während das Formular geöffnet ist. Im folgenden Beispiel wird ein Formular geöffnet, und die Formulardaten werden vor dem Entladen des Formulars in öffentlichen Variablen gespeichert.

'Code in module to declare public variables
Public strRegion As String
Public intSalesPersonID As Integer
Public blnCancelled As Boolean

'Code in form
Private Sub cmdCancel_Click()
    Module1.blnCancelled = True
    Unload Me
End Sub

Private Sub cmdOK_Click()
    'Save data
    intSalesPersonID = txtSalesPersonID.Text
    strRegion = lstRegions.List(lstRegions.ListIndex)
    Module1.blnCancelled = False
    Unload Me
End Sub

Private Sub UserForm_Initialize()
    Module1.blnCancelled = True
End Sub

'Code in module to display form
Sub LaunchSalesPersonForm()
    frmSalesPeople.Show
    If blnCancelled = True Then
        MsgBox "Operation Cancelled!", vbExclamation
    Else
        MsgBox "The Salesperson's ID is: " & _
            intSalesPersonID & _
            "The Region is: " & strRegion
    End If
End Sub


 Festlegen der Eigenschaften von Steuerelementen

Festlegen der Eigenschaften von Steuerelementen

Sie können einige Steuerelement-Eigenschaften beim Erstellen eines Makros (bevor ein Makro ausgeführt wird) setzen. Klicken Sie mit der rechten Maustaste im Entwurfsmodus auf ein Steuerelement, und klicken Sie auf Eigenschaften, um das Eigenschaftenfenster zu öffnen. Die Namen der Eigenschaften werden in der linken, die Werte in der rechten Spalte des Fensters angezeigt. Sie können den Wert einer Eigenschaft festlegen, indem Sie den neuen Wert rechts neben dem Namen der Eigenschaft eingeben.


Verwenden von ActiveX-Steuerelementen in Word-Dokumenten

Sie können in Ihre Dokumente Steuerelemente einfügen, um interaktive Dokumente, beispielsweise Online-Formulare, zu erstellen. Allgemeine Informationen über das Einfügen von und Arbeiten mit Steuerelementen finden Sie unter Verwenden von ActiveX-Steuerelementen in einem Dokument und Erstellen eines benutzerdefinierten Dialogfeldes.

Beim Arbeiten mit Steuerelementen in Dokumenten sollten Sie folgende Punkte beachten:

  • Sie können ActiveX-Steuerelemente auf der Text- oder der Zeichnungsebene des Dokuments einfügen. Um ein Steuerelement auf der Zeichnungsebene einzufügen, klicken Sie in der Steuerelement-Toolbox auf das betreffende Steuerelement. Um ein Steuerelement auf der Textebene einzufügen, klicken Sie bei gedrückter UMSCHALTTASTE in der Steuerelement-Toolbox auf ein Steuerelement.

  • Ein Steuerelement, das Sie auf der Textebene einfügen, ist ein InlineShape-Objekt, auf das Sie programmtechnisch über die InlineShapes-Auflistung zugreifen können. Ein Steuerelement, das Sie auf der Zeichnungsebene einfügen, ist ein Shape-Objekt, auf das Sie programmtechnisch über die Shapes-Auflistung zugreifen können.

  • Steuerelemente auf der Textebene werden wie Zeichen behandelt und stehen als Zeichen in einer Textzeile.

  • Im Entwurfsmodus sind auf der Zeichnungsebene eingefügte ActiveX-Steuerelemente nur in der Druckansicht oder in der Weblayoutansicht sichtbar.

  • Wenn Sie möchten, dass der Benutzer das ActiveX-Steuerelement verwendet, aber das Layout des Dokuments nicht verändert, schützen Sie das Dokument, indem Sie auf der Symbolleiste Formular auf die Schaltfläche Formular schützen klicken.

  • Word stellt für ActiveX-Steuerelemente in einem Dokument die LostFocus- und GotFocus-Ereignisse bereit. Die anderen im Listenfeld Prozedur aufgeführten Ereignisse sind in der Microsoft Forms-Hilfe (Fm20.hlp) dokumentiert. Weitere Informationen über das Verwenden von Ereignissen mit ActiveX-Steuerelementen finden Sie unter Ereignisse von Steuerelementen und Dialogfeldern und Verwenden von Ereignissen mit ActiveX-Steuerelementen.

  • Wenn Sie anstelle von ActiveX-Steuerelementen in Ihrem Dokument Formularfelder einfügen möchten, um ein Online-Formular zu erstellen, verwenden Sie die Symbolleiste Formular.

  • Das Schlüsselwort Me in einer Ereignisprozedur für ein ActiveX-Steuerelement eines Dokuments bezieht sich auf das Dokument, nicht auf das Steuerelement.

Das Schreiben von Ereigniscode für Steuerelemente in Dokumenten ähnelt dem Schreiben von Ereigniscode für Steuerelemente in Formularen. Mit den folgenden SpinUp- und SpinDown-Ereignisprozeduren wird der Wert des TextBox-Steuerelements "TextBox1" in dem Dokument geändert, dem das SpinButton-Steuerelement "SpinButton1" angehört. Der Wert des Textfeldes wird um eins vermindert, wenn der Benutzer auf den unteren bzw. linken Pfeil des Drehfeldes klickt. Der Wert wird um eins erhöht, wenn der Benutzer auf den oberen bzw. rechten Pfeil des Drehfeldes klickt.

Private Sub SpinButton1_SpinDown()
    Me.TextBox1.Value = Me.TextBox1.Value - 1
End Sub
Private Sub SpinButton1_SpinUp()
    Me.TextBox1.Value = Me.TextBox1.Value + 1
End Sub

Die folgende Click-Ereignisprozedur wechselt zur Druckansicht und setzt die Vergrößerung für das Dokument, in dem sich die Befehlsschaltfläche "cmdChangeView" befindet, auf 100 Prozent.

Private Sub cmdChangeView_Click()
    With Me.ActiveWindow.View
        .Type = wdPrintView
        .Zoom.Percentage = 100
    End With
End Sub


Herausfinden, welche Eigenschaft oder Methode verwendet werden soll

Sie können die Makroaufzeichnung verwenden, wenn Sie herausfinden wollen, welche Methoden oder Eigenschaften Sie zum Durchführen einer Aufgabe in Word benötigen. Die Makroaufzeichnung ist ein Werkzeug, das Ihre Aktionen in Visual Basic-Anweisungen übersetzt. Wenn Sie beispielsweise die Makroaufzeichnung einschalten und das Dokument Examples.doc öffnen, zeichnet die Makroaufzeichnung eine Anweisung auf, die ähnlich aussieht wie die Folgende.

Documents.Open FileName:="Examples.doc", _
    ConfirmConversions:=False, ReadOnly:= _
    False, AddToRecentFiles:=False, _
    PasswordDocument:="", PasswordTemplate:="", _
    Revert:=False, WritePasswordDocument:="", _
    WritePasswordTemplate:="", _
    Format:=wdOpenFormatAuto

Die Documents-Eigenschaft gibt die Documents Auflistung zurück, und die Open-Methode öffnet die Datei mit dem angegebenen Dateinamen. Wenn Sie erst dabei sind, Visual Basic zu lernen, wird Ihnen die Makroaufzeichnung beim Lernen helfen, welche Eigenschaften und Methoden Sie verwenden müssen, um eine Aufgabe durchzuführen.

Weitere Informationen finden Sie unter den folgenden Themen:

Erstellen eines Makros

Aufgezeichnete Visual Basic-Makros überarbeiten


ActiveX-Steuerelemente

Für weitere Informationen über ein bestimmtes Steuerelement wählen Sie ein Objekt aus der folgenden Liste aus. Für Informationen über Ereignisse wählen Sie ein Steuerelement und klicken am Beginn des Themas auf Ereignisse.

CheckBox

ComboBox

CommandButton

Frame

Image

Label

ListBox

 MultiPage

OptionButton

ScrollBar

SpinButton

TabStrip

TextBox

ToggleButton


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Microsoft Office Visual Basic-Hilfe nicht gefunden, nicht installiert oder gelöscht wurde.

So installieren Sie die Microsoft Office Visual Basic-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Visual Basic für Applikationen-Hilfe nicht gefunden, nicht installiert oder gelöscht wurde.

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Office Tools in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Das Hilfethema ist nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Microsoft Word-Hilfe nicht gefunden, nicht installiert oder gelöscht wurde.

So installieren Sie die Microsoft Word-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und erweitern Sie dann die Option Microsoft Word für Windows in der Liste der Features.

  4. Klicken Sie auf das Symbol neben Hilfe, um die Optionen für die Installation einzublenden.

  5. Klicken Sie erst auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Update durchführen.


Verborgene Eigenschaften

In Microsoft Word 2000 sind die BrowseToWindow-Eigenschaft des Pane-Objekts und die VirusProtection-Eigenschaft des Options-Objekts verborgen. Die verborgenen Eigenschaften werden nur für die Abwärtskompatiblität unterstützt.


 Sprachspezifische Eigenschaften und Methoden

Sprachspezifische Eigenschaften und Methoden

Im Microsoft Word 2000 Visual Basic-Objektmodell sind neue, sprachspezifische Schlüsselwörter vorhanden, die für asiatische Sprachen und für Sprachen mit der Schreibrichtung von rechts nach links Verwendung finden. Ob diese sprachspezifischen Schlüsselwörter verfügbar sind, hängt davon ab, welche Sprachunterstützung Sie ausgewählt bzw. installiert haben. Weitere Informationen zu sprachspezifischen Funktionen erhalten Sie unter Sprachspezifische Informationen.

Sprachspezifische Eigenschaften

In der folgenden Liste sind diejenigen Eigenschaften aufgeführt, die nur für asiatische Sprachen oder Sprachen mit der Schreibrichtung von rechts nach links verfügbar sind.

Eigenschaft | Objekt
AddBiDirectionalMarksWhenSavingTextFile | Options
AddControlCharacters | Options
AddHebDoubleQuote | Options
AddSpaceBetweenFarEastAndAlpha | Paragraph, ParagraphFormat, Paragraphs
AddSpaceBetweenFarEastAndDigit | Paragraph, ParagraphFormat, Paragraphs
AllowCombinedAuxiliaryForms | Options
AllowCompoundNounProcessing | Options
ApplyFarEastFontsToAscii | Options
ArabicMode | Options
ArabicNumeral | Options
AutoAdjustRightIndent | Paragraph, ParagraphFormat, Paragraphs
AutoFormatApplyFirstIndents | Options
AutoFormatAsYouTypeApplyClosings | Options
AutoFormatAsYouTypeApplyDates | Options
AutoFormatAsYouTypeApplyFirstIndents | Options
AutoFormatAsYouTypeAutoLetterWizard | Options
AutoFormatAsYouTypeDeleteAutoSpaces | Options
AutoFormatAsYouTypeInsertClosings | Options
AutoFormatAsYouTypeInsertOvers | Options
AutoFormatAsYouTypeMatchParentheses | Options
AutoFormatAsYouTypeReplaceFarEastDashes | Options
AutoFormatDeleteAutoSpaces | Options
AutoFormatMatchParentheses | Options
AutoFormatReplaceFarEastDashes | Options
BaseLineAlignment | Paragraph, ParagraphFormat, Paragraphs
BoldBi | Font, Range
BuiltinDictionary | HangulHanjaConversionDictionaries
CharacterUnitFirstLineIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterUnitLeftIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterUnitRightIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterWidth | Range
CharsLine | PageSetup
CheckHangulEndings | Options
ColorIndexBi | Font
CombineCharacters | Range
ConvertHighAnsiToFarEast | Options
CorrectHangulAndAlphabet | AutoCorrect
CorrectHangulEndings | Find
CursorMovement | Options
DiacriticColor | Font
DiacriticColorVal | Options
DisableCharacterSpaceGrid | Font, Range
DisableLineHeightGrid | Paragraph, ParagraphFormat, Paragraphs
DisplayGridLines | Options
DisplayLeftScrollBar | Window
DisplayRightRuler | Window
DocumentViewDirection | Options
DoubleQuote | PageNumbers
EmphasisMark | Font, Range
EnableHangulHanjaRecentOrdering | Options
FarEastLineBreakControl | Paragraph, ParagraphFormat, Paragraphs
FarEastLineBreakLanguage | Document, Template
FarEastLineBreakLevel | Document, Template
Filter | Index
FitTextWidth | Range, Selection
FlowDirection | TextColumns
GridOriginFromMargin | Document
GridSpaceBetweenHorizontalLines | Document
GridSpaceBetweenVerticalLines | Document
GutterPos | PageSetup
GutterStyle | PageSetup
HalfWidthPunctuationOnTopOfLine | Paragraph, ParagraphFormat, Paragraphs
HangingPunctuation | Paragraph, ParagraphFormat, Paragraphs
HangulAndAlphabetAutoAdd | AutoCorrect
HangulAndAlphabetExceptions | AutoCorrect
HangulHanjaDictionaries | Application, Global
HangulHanjaFastConversion | Options
HebrewMode | Options
HorizontalInVertical | Range
IMEAutomaticControl | Options
IMEMode | Window
InlineConversion | Options
ItalicBi | Font, Range
JustificationMode | Document, Template
Kana | Range
KerningByAlgorithm | Document, Template
LayoutMode | PageSetup
LinesPage | PageSetup
LineUnitAfter | Paragraph, ParagraphFormat, Paragraphs
LineUnitBefore | Paragraph, ParagraphFormat, Paragraphs
MatchAlefHamza | Find
MatchByte | Find
MatchControl | Find
MatchDiacritics | Find
MatchFuzzy | Find
MatchFuzzyAY | Options
MatchFuzzyBV | Options
MatchFuzzyByte | Options
MatchFuzzyCase | Options
MatchFuzzyDash | Options
MatchFuzzyDZ | Options
MatchFuzzyHF | Options
MatchFuzzyHiragana | Options
MatchFuzzyIterationMark | Options
MatchFuzzyKanji | Options
MatchFuzzyKiKu | Options
MatchFuzzyOldKana | Options
MatchFuzzyProlongedSoundMark | Options
MatchFuzzyPunctuation | Options
MatchFuzzySmallKana | Options
MatchFuzzySpace | Options
MatchFuzzyTC | Options
MatchFuzzyZJ | Options
MatchKashida | Find
MonthNames | Options
MultipleWordConversionsMode | Options
NameBi | Font
NoLineBreakAfter | Document, Template
NoLineBreakBefore | Document, Template
PrintEvenPagesInAscendingOrder | Options
PrintOddPagesInAscendingOrder | Options
ReadingOrder | Paragraph, ParagraphFormat, Paragraphs
SectionDirection | PageSetup
ShowControlCharacters | Options
ShowDiacritics | Options
ShowOptionalBreaks | View
SizeBi | Font
SortBy | Index
StrictFinalYaa | Options
StrictInitialAlefHamza | Options
TableDirection | Rows, Table
TwoLinesInOne | Range
TwoPagesOnOne | PageSetup
UseCharacterUnit | Options
UseDiffDiacColor | Options
UseGermanSpellingReform | Options
VisualSelection | Options

Sprachspezifische Methoden

In der folgenden Tabelle sind die Methoden aufgeführt, die nur für asiatische Sprachen oder Sprachen mit der Schreibrichtung von rechts nach links verfügbar sind.

Methode | Objekt
BoldRun | Selection
CheckConsistency | Document
ClearAllFuzzyOptions | Find
ConvertHangulAndHanja | Range
IndentCharWidth | Paragraph, ParagraphFormat, Paragraphs
IndentFirstLineCharWidth | Paragraph, ParagraphFormat, Paragraphs
ItalicRun | Selection
KeyboardBidi | Application
KeyboardLatin | Application
LtrPara | Selection
LtrRun | Selection
ModifyEnclosure | Range
PhoneticGuide | Range
RtlPara | Selection
RtlRun | Selection
SetAllFuzzyOptions | Find
TCSCConverter | Range
ToggleKeyboard | Application

Sprachspezifische Argumente

In der folgenden Tabelle sind Methoden aufgelistet, die für alle Sprachen verfügbar sind, aber ein oder mehrere sprachspezifische Argumente besitzen.

Methode | Objekt
Execute | Find
InsertDateTime | Range, Selection
InsertSymbol | Range, Selection
PrintOut | Application, Document, Window
Sort | Column, Range, Selection, Table

Anmerkung Damit Sie die sprachspezifischen Features in Microsoft Word aktivieren können, müssen Sie eine 32-Bit-Version des Betriebssystems Microsoft Windows verwenden, welches die spezielle Sprache unterstützt — zum Beispiel bietet die arabische Version von Windows 95 Rechts-nach-links-Unterstützung. Informieren Sie sich über die Anforderungen für Spachen mit der Schreibrichtung von rechts nach links oder asiatische Sprachen.


Neue Methoden (alphabetisch sortiert)

In der folgenden alphabetisch sortierten Liste werden die Methoden aufgeführt, die in Microsoft Word 2000 zu bestehenden Objekten hinzugefügt wurden.

Neue Methode | Objekt
AddHorizontalLine | InlineShapes
AddHorizontalLineStandard | InlineShapes
AddNewFrame | Frameset
AddPictureBullet | InlineShapes
ApplyTheme | Document
AutoFitBehavior | Table
BoldRun | Selection
CheckConsistency | Document
ClearAllFuzzyOptions | Find
ConvertHangulAndHanja | Range
CreateAutoTextEntry | Selection
DefaultWebOptions | Application
DetectLanguage | Document, Range, Selection
GetDefaultTheme | Application
GetPoint | Window
IndentCharWidth | Paragraph, ParagraphFormat, Paragraphs
IndentFirstLineCharWidth | Paragraph, ParagraphFormat, Paragraphs
InsertColumnsRight | Selection
InsertRowsAbove | Selection
InsertRowsBelow | Selection
ItalicRun | Selection
Keyboard | Application
KeyboardBidi | Application
KeyboardLatin | Application
LtrPara | Selection
LtrRun | Selection
ModifyEnclosure | Range
NewFrameset | Pane
PasteAsNestedTable | Range, Selection
PhoneticGuide | Range
PixelsToPoints | Application, Global
PointsToPixels | Application, Global
ProductCode | Application
RangeFromPoint | Window
ReloadAs | Document
RemoveTheme | Document
RtlPara | Selection
RtlRun | Selection
ScrollIntoView | Window
SelectCell | Selection
SetAllFuzzyOptions | Find
SetDefaultTheme | Application
SetFocus | Window
TCSCConverter | Range
TOCInFrameset | Pane
ToggleKeyboard | Application
UseDefaultFolderSuffix | WebOptions
WebPagePreview | Document


Neue Eigenschaften (alphabetisch sortiert)

In der folgenden Tabelle sind die Eigenschaften aufgeführt, die in Microsoft Word 2000 zu bereits vorhandenen Objekten hinzugefügt wurden (alphabetisch sortiert).

Neue Eigenschaft | Objekt(e)
ActiveTheme | Document
ActiveThemeDisplayName | Document
AddBiDirectionalMarksWhenSavingTextFile | Options
AddControlCharacters | Options
AddHebDoubleQuote | Options
AddSpaceBetweenFarEastAndAlpha | Paragraph, ParagraphFormat, Paragraphs
AddSpaceBetweenFarEastAndDigit | Paragraph, ParagraphFormat, Paragraphs
AllowAutoFit | Table
AllowClickAndTypeMouse | Options
AllowCombinedAuxiliaryForms | Options
AllowCompoundNounProcessing | Options
AllowOverlap | Rows, WrapFormat
AllowPageBreaks | Table
AllowPixelUnits | Options
AllowPNG | DefaultWebOptions, WebOptions
AlternativeText | InlineShape, Shape, ShapeRange
AlwaysSaveInDefaultEncoding | DefaultWebOptions
AnswerWizard | Application, Global
ApplyFarEastFontsToAscii | Options
ArabicMode | Options
ArabicNumeral | Options
AutoAdjustRightIndent | Paragraph, ParagraphFormat, Paragraphs
AutoFormatApplyFirstIndents | Options
AutoFormatAsYouTypeApplyClosings | Options
AutoFormatAsYouTypeApplyDates | Options
AutoFormatAsYouTypeApplyFirstIndents | Options
AutoFormatAsYouTypeAutoLetterWizard | Options
AutoFormatAsYouTypeDeleteAutoSpaces | Options
AutoFormatAsYouTypeInsertClosings | Options
AutoFormatAsYouTypeInsertOvers | Options
AutoFormatAsYouTypeMatchParentheses | Options
AutoFormatAsYouTypeReplaceFarEastDashes | Options
AutoFormatDeleteAutoSpaces | Options
AutoFormatMatchParentheses | Options
AutoFormatReplaceFarEastDashes | Options
AutoKeyboardSwitching | Options
BackgroundPatternColor | Shading
BaseLineAlignment | Paragraph, ParagraphFormat, Paragraphs
BoldBi | Font, Range
BottomPadding | Cell, Table
BrowserLevel | DefaultWebOptions, WebOptions
BuiltinDictionary | HangulHanjaConversionDictionaries
CharacterUnitFirstLineIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterUnitLeftIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterUnitRightIndent | Paragraph, ParagraphFormat, Paragraphs
CharacterWidth | Range
CharsLine | PageSetup
CheckHangulEndings | Options
CheckIfOfficeIsHTMLEditor | DefaultWebOptions
CheckIfWordIsDefaultHTMLEditor | DefaultWebOptions
CheckLanguage | Application
ChildFramesetCount | Frameset
ChildFramesetItem | Frameset
ClickAndTypeParagraphStyle | Document
Color | Border, Font
ColorIndexBi | Font
COMAddIns | Application
CombineCharacters | Range
CommandName | Dialog
ComposeStyle | EmailOptions
ConvertHighAnsiToFarEast | Options
CorrectHangulAndAlphabet | AutoCorrect
CorrectHangulEndings | Find
CorrectKeyboardSetting | AutoCorrect
CurrentEmailAuthor | Email
CursorMovement | Options
DefaultBorderColor | Options
DiacriticColor | Font
DiacriticColorVal | Options
DisableCharacterSpaceGrid | Font, Range
DisableLineHeightGrid | Paragraph, ParagraphFormat, Paragraphs
DisplayGridLines | Options
DisplayLeftScrollBar | Window
DisplayRightRuler | Window
DocumentViewDirection | Options
DoubleQuote | PageNumbers
Email | Document
EmailOptions | Application
EmailSignature | EmailOptions
EmailSubject | Hyperlink
EmphasisMark | Font, Range
EnableHangulHanjaRecentOrdering | Options
EnableMisusedWordsDictionary | Options
Encoding | DefaultWebOptions, WebOptions
EnvelopeVisible | Window
FarEastLineBreakControl | Paragraph, ParagraphFormat, Paragraphs
FarEastLineBreakLanguage | Document, Template
FarEastLineBreakLevel | Document, Template
FeatureInstall | Application
Filter | Index
FitText | Cell
FitTextWidth | Range, Selection
FlowDirection | TextColumns
FolderSuffix | DefaultWebOptions, WebOptions
Fonts | DefaultWebOptions
ForegroundPatternColor | Shading
FrameDefaultURL | Frameset
FrameDisplayBorders | Frameset
FrameLinkToFile | Frameset
FrameName | Frameset
FrameResizable | Frameset
FrameScrollbarType | Frameset
Frameset | Document, Pane
FramesetBorderColor | Frameset
FramesetBorderWidth | Frameset
GridOriginFromMargin | Document
GridSpaceBetweenHorizontalLines | Document
GridSpaceBetweenVerticalLines | Document
GutterPos | PageSetup
GutterStyle | PageSetup
HalfWidthPunctuationOnTopOfLine | Paragraph, ParagraphFormat, Paragraphs
HangingPunctuation | Paragraph, ParagraphFormat, Paragraphs
HangulAndAlphabetAutoAdd | AutoCorrect
HangulAndAlphabetExceptions | AutoCorrect
HangulHanjaDictionaries | Application, Global
HangulHanjaFastConversion | Options
HebrewMode | Options
HeightType | Frameset
HidePageNumbersInWeb | TableOfContents, TableOfFigures
HorizontalInVertical | Range
HorizontalLineFormat | InlineShape
HTMLProject | Document
IMEAutomaticControl | Options
IMEMode | Window
IndexLanguage | Index
InlineConversion | Options
InsideColor | Borders
InterpretHighAnsi | Options
ItalicBi | Font, Range
JustificationMode | Document, Template
Kana | Range
KerningByAlgorithm | Document, Template
Language | Application
LanguageDetected | Document, Range, Selection
LanguageSettings | Application, Global
LayoutMode | PageSetup
LeftPadding | Cell, Table
LinesPage | PageSetup
LineUnitAfter | Paragraph, ParagraphFormat, Paragraphs
LineUnitBefore | Paragraph, ParagraphFormat, Paragraphs
MarkComments | EmailOptions
MarkCommentsWith | EmailOptions
MatchAlefHamza | Find
MatchByte | Find
MatchControl | Find
MatchDiacritics | Find
MatchFuzzy | Find
MatchFuzzyAY | Options
MatchFuzzyBV | Options
MatchFuzzyByte | Options
MatchFuzzyCase | Options
MatchFuzzyDash | Options
MatchFuzzyDZ | Options
MatchFuzzyHF | Options
MatchFuzzyHiragana | Options
MatchFuzzyIterationMark | Options
MatchFuzzyKanji | Options
MatchFuzzyKiKu | Options
MatchFuzzyOldKana | Options
MatchFuzzyProlongedSoundMark | Options
MatchFuzzyPunctuation | Options
MatchFuzzySmallKana | Options
MatchFuzzySpace | Options
MatchFuzzyTC | Options
MatchFuzzyZJ | Options
MatchKashida | Find
MonthNames | Options
MultipleWordConversionsMode | Options
NameBi | Font
NestingLevel | Cell, Cells, Column, Columns, Row, Rows, Table, Tables
NewMessageSignature | EmailSignature
NoLineBreakAfter | Document, Template
NoLineBreakBefore | Document, Template
NoProofing | Find, Range, Replacement, Selection, Style, Template
NoShade | HorizontalLineFormat
OpenEncoding | Document
OptimizeForBrowser | DefaultWebOptions, WebOptions
OptimizeForWord97 | Document
OptimizeForWord97byDefault | Options
OrganizeInFolder | DefaultWebOptions, WebOptions
OtherCorrectionsAutoAdd | AutoCorrect
OtherCorrectionsExceptions | AutoCorrect
OutsideColor | Borders
ParentFrameset | Frameset
PercentWidth | HorizontalLineFormat
PixelsPerInch | DefaultWebOptions, WebOptions
PreferredWidth | Cell, Cells, Column, Columns, Table
PreferredWidthType | Cell, Cells, Column, Columns, Table
PrintEvenPagesInAscendingOrder | Options
PrintOddPagesInAscendingOrder | Options
ReadingOrder | Paragraph, ParagraphFormat, Paragraphs
RelyOnCSS | DefaultWebOptions, WebOptions
RelyOnVML | DefaultWebOptions, WebOptions
ReplaceTextFromSpellingChecker | AutoCorrect
ReplyMessageSignature | EmailSignature
ReplyStyle | EmailOptions
RightPadding | Cell, Table
SaveEncoding | Document
ScreenSize | DefaultWebOptions, WebOptions
ScreenTip | Hyperlink
Script | InlineShape, Shape
Scripts | Document, Range
SectionDirection | PageSetup
ShowControlCharacters | Options
ShowDiacritics | Options
ShowOptionalBreaks | View
SizeBi | Font
SortBy | Index
SpaceAfterAuto | Paragraph, ParagraphFormat, Paragraphs
SpaceBeforeAuto | Paragraph, ParagraphFormat, Paragraphs
StrictFinalYaa | Options
StrictInitialAlefHamza | Options
TableDirection | Rows, Table
TextToDisplay | Hyperlink
ThemeName | EmailOptions
TopLevelTables | Range, Selection
TopPadding | Cell, Table
TwoLinesInOne | Range
TwoPagesOnOne | PageSetup
UnderlineColor | Font
UpdateLinksOnSave | DefaultWebOptions
UseCharacterUnit | Options
UseDiffDiacColor | Options
UseGermanSpellingReform | Options
UseHyperlinks | TableOfContents, TableOfFigures
UseLongFileNames | DefaultWebOptions, WebOptions
UseThemeStyle | EmailOptions
VBASigned | Document
VisualSelection | Options
WebOptions | Document
WidthType | Frameset, HorizontalLineFormat
WordWrap | Cell, Paragraph, ParagraphFormat, Paragraphs
WrapAroundText | Rows


Beispiel zur AcceptAll-Methode

In diesem Beispiel werden alle Überarbeitungen im aktiven Dokument angenommen.

If ActiveDocument.Revisions.Count >= 1 Then _
    ActiveDocument.Revisions.AcceptAll

In diesem Beispiel werden alle Überarbeitungen in der Markierung angenommen.

Selection.Range.Revisions.AcceptAll


Beispiel zur Accept-Methode

In diesem Beispiel wird die nächste gefundene Überarbeitung angenommen, wenn die Art der Überarbeitung eingefügter Text ist.

Set myRev = Selection.NextRevision(Wrap:=True)
If Not (myRev Is Nothing) Then
    If myRev.Type = wdRevisionInsert Then myRev.Accept
End If

In diesem Beispiel werden alle Überarbeitungen in der Markierung angenommen.

Set myRange = Selection.Range
For Each myRev In myRange.Revisions
    myRev.Accept
Next myRev


Beispiel zur Activate-Methode

In diesem Beispiel wird das Dokument "Sales.doc." aktiviert.

Documents("Sales.doc").Activate

In diesem Beispiel wird das nächste Fenster in der Windows-Sammlung aktiviert.

ActiveDocument.ActiveWindow.Next.Activate

In diesem Beispiel wird die Anwendung Editor aktiviert, wenn Notepad in der Tasks-Sammlung enthalten ist.

For Each myTask In Tasks
    If InStr(myTask.Name, "Notepad") > 0 Then
        myTask.Activate
        myTask.WindowState = wdWindowStateNormal
    End If
Next myTask

In diesem Beispiel wird das aktive Fenster geteilt und der erste Fensterausschnitt aktiviert.

With ActiveDocument.ActiveWindow
    .SplitVertical = 50
    .Panes(1).Activate
End With


Add-Methode (AutoCorrectEntries-Auflistung)

Nimmt einen unformatierten AutoKorrektur-Eintrag in die Liste der verfügbaren Einträge auf.

Syntax

Ausdruck.Add(Name, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrectEntries-Objekt zurückgibt.

Name String erforderlich. Der Text, der automatisch durch den Text ersetzt werden soll, der in Value angegeben wird.

Value String erforderlich. Der Text, der immer dann automatisch eingefügt werden soll, wenn der in Name angegebene Text eingegeben wird.

Anmerkungen

Verwenden Sie die AddRichText-Methode zum Erstellen eines formatierten AutoKorrektur-Eintrags.


Beispiel zur Add-Methode (AutoCorrectEntries-Auflistung)

In diesem Beispiel wird ein unformatierter AutoKorrektur-Eintrag für einen häufigen Rechtschreibfehler des Worts "Fehler" aufgenommen.

AutoCorrect.Entries.Add Name:= "thier", Value:= "their"


Add-Methode (AutoTextEntries-Auflistung)

Nimmt einen AutoText-Eintrag in die Liste der verfügbaren Einträge auf.

Syntax

Ausdruck.Add(Name, Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoTextEntries-Objekt zurückgibt.

Name String erforderlich. Der Text, der bei der Eingabe einen AutoText-Eintrag initiiert.

Range Range erforderlich. Ein Textbereich, der immer dann eingefügt wird, wenn Name eingegeben wird.


Beispiel zur Add-Methode (AutoTextEntries-Auflistung)

In diesem Beispiel wird ein AutoText-Eintrag namens "MyText", der den Text in der Auswahl enthält, in die Liste aufgenommen.

NormalTemplate.AutoTextEntries.Add Name:= "MyText", _
    Range:= Selection.Range


Add-Methode (Bookmarks-Auflistung)

Fügt einem Bereich eine Textmarke hinzu.

Syntax

Ausdruck.Add(Name, Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Bookmarks-Objekt zurückgibt.

Name String erforderlich. Der Name der Textmarke. Der Name darf nur aus einem Wort bestehen.

Range Variant optional. Der Textbereich, der durch die Textmarke gekennzeichnet wird. Eine Textmarke kann einem reduzierten Bereich (der Einfügemarke) zugeordnet werden.


Beispiel zur Add-Methode (Bookmarks-Auflistung)

In diesem Beispiel wird im aktiven Dokument der Auswahl eine Textmarke "myplace" zugeordnet.

ActiveDocument.Bookmarks.Add _
    Name:= "myplace", Range:= Selection.Range

In diesem Beispiel wird an der Einfügemarke eine Textmarke "mark" eingefügt.

ActiveDocument.Bookmarks.Add Name:= "mark"

In diesem Beispiel wird dem dritten Absatz in "Letter.doc" eine Textmarke namens "third_para" zugeordnet, und anschließend werden alle Textmarken für das Dokument im aktiven Fenster angezeigt.

Set myDoc = Documents("Letter.doc")
myDoc.Bookmarks.Add Name:="third_para", _
    Range:=myDoc.Paragraphs(3).Range
myDoc.ActiveWindow.View.ShowBookmarks = True


Add-Methode (CaptionLabels-Auflistung)

Nimmt eine benutzerdefinierte Beschriftungskategorie in die Liste auf.

Syntax

Ausdruck.Add(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein CaptionLabels-Objekt zurückgibt.

Name String erforderlich. Der Name der benutzerdefinierten Beschriftungskategorie.


Beispiel zur Add-Methode (CaptionLabels-Auflistung)

In diesem Beispiel wird eine benutzerdefinierte Beschriftungskategorie namens "Demo Slide" in die Liste aufgenommen.

CaptionLabels.Add Name:="Demo Slide"


Add-Methode (Cells-, Rows- und Columns-Auflistungen)

Fügt einer Tabelle eine Zelle, Zeile oder Spalte hinzu.

Syntax 1

Ausdruck.Add(BeforeCell)

Syntax 2

Ausdruck.Add(BeforeColumn)

Syntax 3

Ausdruck.Add(BeforeRow)

Ausdruck Erforderlich. Ein Ausdruck, der ein Cells-Objekt (Syntax 1), Columns-Objekt (Syntax 2) oder Rows-Objekt (Syntax 3) zurückgibt.

BeforeCell Variant optional. Ein Cell-Objekt, das die Zelle darstellt, die unmittelbar rechts von der neuen Zelle oder den neuen Zellen stehen wird.

BeforeColumn Variant optional. Ein Column-Objekt, das die Spalte darstellt, die unmittelbar rechts von der neuen Spalte stehen wird.

BeforeRow Variant optional. Ein Row-Objekt, das die Zeile darstellt, die unmittelbar unter der neuen Zeile stehen wird.


Beispiel zur Add-Methode (Cells-, Rows- und Columns-Auflistungen)

In diesem Beispiel wird vor der ersten Zeile in der Auswahl eine neue Zeile eingefügt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Rows.Add BeforeRow:= Selection.Rows(1)
End If

In diesem Beispiel wird im aktiven Dokument eine Tabelle mit zwei Spalten und zwei Zeilen erstellt und dann vor der ersten Spalte eine weitere Spalte eingefügt. Die Breite der neuen Spalte wird auf 1,5 Zoll festgelegt.

Set myTable = ActiveDocument.Tables.Add(Selection.Range, 2, 2)
Set newCol = myTable.Columns.Add(BeforeColumn:= myTable.Columns(1))
newCol.SetWidth ColumnWidth:=InchesToPoints(1.5), _
    RulerStyle:=wdAdjustNone

In diesem Beispiel wird der ersten Tabelle eine Zeile hinzugefügt und dann in diese Zeile der Text "Cell" eingefügt.

counter = 1
Set myTable = ActiveDocument.Tables(1)
Set newrow = myTable.Rows.Add(BeforeRow:=myTable.rows(1))
For Each c In newrow.Cells
   c.Range.InsertAfter Text:="Cell " & counter
   counter = counter + 1
Next c


Add-Methode (Comments-Auflistung)

Fügt dem angegebenen Bereich einen Kommentar hinzu.

Syntax

Ausdruck.Add(Range, Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Comments-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, dem ein Kommentar hinzugefügt werden soll.

Text Variant optional. Der Kommentartext.


Beispiel zur Add-Methode (Comments-Auflistung)

In diesem Beispiel wird an der Einfügemarke ein Kommentar eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Comments.Add _
    Range:=Selection.Range, Text:="review this"

In diesem Beispiel wird dem dritten Absatz im aktiven Dokument ein Kommentar hinzugefügt.

Set myRange = ActiveDocument.Paragraphs(3).Range
ActiveDocument.Comments.Add Range:=myRange, _
    Text:="original third paragraph"


Add-Methode (CustomLabels-Auflistung)

Nimmt ein benutzerdefiniertes Adressetikett in die Liste auf.

Syntax

Ausdruck.Add(Name, DotMatrix)

Ausdruck Erforderlich. Ein Ausdruck, der ein CustomLabels-Objekt zurückgibt.

Name String erforderlich. Der Name für die benutzerdefinierten Adressetiketten.

DotMatrix Variant optional. True, wenn die Adressetiketten auf einem Matrixdrucker gedruckt werden sollen.


Beispiel zur Add-Methode (CustomLabels-Auflistung)

In diesem Beispiel wird ein benutzerdefiniertes Adressetikett namens "My Label" in die Liste aufgenommen und die Seitengröße festgelegt. Anschließend wird eine Seite dieser Etiketten erstellt.

Set ml = Application.MailingLabel.CustomLabels _
    .Add(Name:="My Label", DotMatrix:=False)
ml.PageSize = wdCustomLabelLetter
addr = "Dave Edson" & vbCr & "123 Skye St." & vbCr _
    & "Our Town, WA  98004"
Application.MailingLabel.CreateNewDocument _
    Name:="My Label", Address:=addr, ExtractAddress:=False


Add-Methode (Dictionaries-Auflistung)

Fügt das Wörterbuch, das durch FileName spezifiziert wird, der Auflistung der aktiven Benutzerwörterbücher hinzu. Wenn keine Datei mit dem durch FileName spezifizierten Namen vorhanden ist, legt Word eine an.

Syntax

Ausdruck.Add(FileName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Dictionaries-Objekt zurückgibt. Verwenden Sie die CustomDictionaries-Eigenschaft zur Zurückgabe der Auflistung der Benutzerwörterbücher.

FileName String erforderlich. Die Namenzeichenfolge der Wörterbuchdatei. Wenn in der Zeichenfolge kein Pfad angegeben ist, wird der Pfad zur Korrekturhilfe verwendet.

Anmerkungen

Die Dictionaries-Auflistung enthält nur die aktiven Benutzerwörterbücher. Dictionary-Objekte, die von der Languages-Auflistung abgeleitet sind, haben keine Add-Methode. Dazu gehören die Dictionary-Objekte, die von der ActiveSpellingDictionary-, ActiveGrammarDictionary-, ActiveThesaurusDictionary- und ActiveHyphenationDictionary-Eigenschaft zurückgegeben werden.


Beispiel zur Add-Methode (Dictionaries-Auflistung)

In diesem Beispiel werden alle Wörterbücher von der Liste der Benutzerwörterbücher entfernt und eine neue Benutzerwörterbuchdatei angelegt. Das neue Wörterbuch wird zum aktiven Benutzerwörterbuch bestimmt, in das neue Wörter automatisch aufgenommen werden.

With CustomDictionaries
    .ClearAll
    .Add FileName:= "c:\My Documents\MyCustom.dic"
    .ActiveCustomDictionary = CustomDictionaries(1)
End With

In diesem Beispiel wird ein neues Benutzerwörterbuch angelegt und einer Variablen zugewiesen. Dann wird festgelegt, dass das neue Benutzerwörterbuch für Text verwendet wird, der als Französisch (Kanada) gekennzeichnet ist. Beachten Sie, dass eine Rechtschreibprüfung für eine andere Sprache nur erfolgen kann, wenn Sie die Korrekturhilfen für diese Sprache installiert haben.

Set myDictionary = CustomDictionaries.Add(FileName:="MyFrench.dic")
With myDictionary
    .LanguageSpecific = True
    .LanguageID = wdFrenchCanadian
End With


Add-Methode (Documents-Auflistung)

Fügt der Auflistung der geöffneten Dokumente ein neues, leeres Dokument hinzu.

Syntax

Ausdruck.Add(Template, NewTemplate, DocumentType, Visible)

Ausdruck Erforderlich. Ein Ausdruck, der ein Documents-Objekt zurückgibt.

Template Variant optional. Der Name der Vorlage, die für das neue Dokument verwendet werden soll. Lässt man dieses Argument weg, wird die Vorlage Normal verwendet.

NewTemplate Variant optional. True, wenn das Dokument als Vorlage geöffnet werden soll. Der Standardwert ist False.

DocumentType Variant optional. Kann eine der folgenden WdNewDocumentType-Konstanten sein: wdNewBlankDocument, wdNewEmailMessage, wdNewFrameset oder wdNewWebPage. Die Standardkonstante ist wdNewBlankDocument.

Visible Variant optional. True, um das Dokument in einem sichtbaren Fenster zu öffnen. Wenn dieser Wert auf False gesetzt wird, öffnet Microsoft Word das Dokument, setzt aber die Visible-Eigenschaft des Dokumentfensters auf False. Der Standardwert ist True.


Beispiel zur Add-Methode (Documents-Auflistung)

In diesem Beispiel wird ein neues Dokument auf der Basis der Vorlage "Normal" angelegt.

Documents.Add

In diesem Beispiel wird ein neues Dokument auf der Basis der Vorlage "Professional Memo" erstellt.

Documents.Add Template:="C:\Program Files\Microsoft Office" _
    & "\Templates\Memos\Professional Memo.dot"

In diesem Beispiel wird eine neue Vorlage erstellt und geöffnet. Als Modell dient die Vorlage, die zum aktiven Dokument gehört.

tmpName = ActiveDocument.AttachedTemplate.FullName
Documents.Add Template:=tmpName, NewTemplate:=True


Add-Methode (Endnotes- und Footnotes-Auflistungen)

Fügt dem angegebenen Bereich eine Endnote oder Fußnote hinzu.

Syntax

Ausdruck.Add(Range, Reference, Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Endnotes- oder Footnotes-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, der für die Endnote oder Fußnote gekennzeichnet wird. Dies kann ein reduzierter Bereich sein.

Reference Variant optional. Der Text für das benutzerdefinierte Fuß- oder Endnotenzeichen. Wenn dieses Argument weggelassen wird, fügt Word ein automatisch nummeriertes Fuß-/Endnotenzeichen hinzu.

Text Variant optional. Der Text der Endnote oder Fußnote.

Anmerkungen

Verwenden Sie zum Spezifizieren eines Sonderzeichens für das Argument Reference die Syntax {FontName CharNum}. FontName ist der Name der Schriftart, die das Sonderzeichen enthält. Namen dekorativer Schriftarten erscheinen im Feld Schriftart im Dialogfeld Symbol im Menü Einfügen. CharNum ist die Summe von 31 und der Nummer, die der Position des Sonderzeichens entspricht, das Sie einfügen wollen, indem Sie von links nach rechts in der Zeichentabelle zählen. Zum Spezifizieren eines Dollarzeichens ($) an der Position 5 in der Zeichentabelle der Schriftart "Arial" wäre das Argument beispielsweise "{Symbol 36}".


Beispiel zur Add-Methode (Endnotes- und Footnotes-Auflistungen)

In diesem Beispiel wird eine automatisch nummerierte Fußnote am Ende der Auswahl eingefügt.

ActiveDocument.Footnotes.Add Range:= Selection.Range , _
    Text:= "The Willow Tree, (Lone Creek Press, 1996)."

In diesem Beispiel wird dem dritten Absatz im aktiven Dokument eine Endnote hinzugefügt.

Set myRange = ActiveDocument.Paragraphs(3).Range
ActiveDocument.Endnotes.Add Range:=myRange, _
    Text:= "Ibid., 314."

In diesem Beispiel wird eine Fußnote eingefügt, die ein benutzerdefiniertes Sonderzeichen () als Fußnotenzeichen verwendet.

ActiveDocument.Footnotes.Add Range:= Selection.Range , _
    Text:= "More information in the full report.", _
    Reference:= "{Symbol -3998}"


Add-Methode (Fields-Auflistung)

Fügt ein Feld im angegebenen Bereich hinzu.

Syntax

Ausdruck.Add(Range, Type, Text, PreserveFormatting)

Ausdruck Erforderlich. Ein Ausdruck, der ein Fields-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem Sie das Feld hinzufügen möchten. Wenn der Bereich nicht ausgeblendet ist, ersetzt das Feld den Bereich.

Type Variant optional. Die Art des hinzuzufügenden Feldes. Dabei kann es sich um eine der folgenden WdFieldType-Konstanten handeln:

wdFieldAddin

wdFieldAdvance

wdFieldAsk

wdFieldAuthor

wdFieldAutoNum

wdFieldAutoNumLegal

wdFieldAutoNumOutline

wdFieldAutoText

wdFieldAutoTextList

wdFieldBarCode

wdFieldComments

wdFieldCompare

wdFieldCreateDate

wdFieldData

wdFieldDatabase

wdFieldDate

wdFieldDDE

wdFieldDDEAuto

wdFieldDocProperty

wdFieldDocVariable

wdFieldEditTime

wdFieldEmbed

wdFieldEmpty

wdFieldExpression

wdFieldFileName

wdFieldFileSize

wdFieldFillIn

wdFieldFootnoteRef

wdFieldFormCheckBox

wdFieldFormDropDown

wdFieldFormTextInput

wdFieldFormula

wdFieldGlossary

wdFieldGotoButton

wdFieldHTMLActiveX

wdFieldHyperlink

wdFieldIf

wdFieldImport

wdFieldInclude

wdFieldIncludePicture

wdFieldIncludeText

wdFieldIndex

wdFieldIndexEntry

wdFieldInfo

 wdFieldKeyWord

wdFieldLastSavedBy

wdFieldLink

wdFieldListNum

wdFieldMacroButton

wdFieldMergeField

wdFieldMergeRec

wdFieldMergeSeq

wdFieldNext

wdFieldNextIf

wdFieldNoteRef

wdFieldNumChars

wdFieldNumPages

wdFieldNumWords

wdFieldOCX

wdFieldPage

wdFieldPageRef

wdFieldPrint

wdFieldPrintDate

wdFieldPrivate

wdFieldQuote

wdFieldRef

wdFieldRefDoc

wdFieldRevisionNum

wdFieldSaveDate

wdFieldSection

wdFieldSectionPages

wdFieldSequence

wdFieldSet

wdFieldSkipIf

wdFieldStyleRef

wdFieldSubject

wdFieldSubscriber

wdFieldSymbol

wdFieldTemplate

wdFieldTime

wdFieldTitle

wdFieldTOA

wdFieldTOAEntry

wdFieldTOC

wdFieldTOCEntry

wdFieldUserAddress

wdFieldUserInitials

wdFieldUserName

Der Standardwert ist wdFieldEmpty.

Text Variant optional. Zusätzlich für das Feld benötigter Text. Wenn Sie zum Beispiel einen Schalter für das Feld bestimmen möchten, fügen Sie ihn hier hinzu.

PreserveFormatting Variant optional. True, um die dem Feld zugewiesene Formatierung bei Aktualisierungen beizubehalten.

Hinweise

Manche Felder (wie wdFieldOCX und wdFieldFormCheckBox) können nicht mit der Add-Methode der Fields-Auflistung eingefügt werden. Stattdessen müssen Sie spezielle Methoden anwenden, wie die AddOLEControl-Methode und die Add-Methode für die FormFields-Auflistung.


Beispiel zur Add-Methode (Fields-Auflistung)

In diesem Beispiel wird am Anfang der Auswahl ein USERNAME-Feld eingefügt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldUserName)

In diesem Beispiel wird am Ende der Auswahl ein LISTNUM-Feld eingefügt. Der Startschalter legt fest, bei 3 zu beginnen.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Fields.Add Range:=Selection.Range, _
    Type:=wdFieldListNum, Text:="\s 3"

In diesem Beispiel wird am Anfang der Auswahl ein DATE-Feld eingefügt und dann das Ergebnis angezeigt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldDate)
MsgBox myField.Result


Add-Methode (FirstLetterExceptions-, OtherCorrectionsExceptions- und TwoInitialCapsExceptions-Auflistungen)

Nimmt eine neue Ausnahme in die Liste der AutoKorrektur-Ausnahmen auf.

Syntax

Ausdruck.Add(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein FirstLetterExceptions-, OtherCorrectionsExceptions- oder TwoInitialCapsExceptions-Objekt zurückgibt.

Name String erforderlich. Das Wort mit zwei Großbuchstaben am Anfang, das Microsoft Word unverändert stehen lassen soll (FirstLetterExceptions), die Abkürzung, nach der Word beim nächsten Wort nicht auf einem Großbuchstaben am Anfang beharren soll (TwoInitialCapsExceptions) oder ein beliebiges anderes Wort, das Word nicht beachten soll (OtherCorrectionsExceptions).

Anmerkungen

Wenn die TwoInitialCapsAutoAdd-Eigenschaft True ist, werden Wörter automatisch in die Liste der Ausnahmen "WOrtanfang GRoss" aufgenommen. Wenn die FirstLetterAutoAdd-Eigenschaft True ist, werden Abkürzungen automatisch in die Liste der Ausnahmen "Erster Buchstabe" aufgenommen. Wenn der Wert der OtherCorrectionsAutoAdd-Eigenschaft True ist, werden Wörter automatisch in die Liste der weiteren Korrekturausnahmen aufgenommen.


Beispiel zur Add-Methode (FirstLetterExceptions-, OtherCorrectionExceptions- und TwoInitialCapsExceptions-Auflistungen)

In diesem Beispiel wird die Abkürzung "addr." der Liste der "Ausnahmen Erster Buchstabe" hinzugefügt.

AutoCorrect.FirstLetterExceptions.Add Name:="addr."

In diesem Beispiel wird "MSOffice" der Liste der Ausnahmen "WOrtanfang GRoss" hinzugefügt.

AutoCorrect.TwoInitialCapsExceptions.Add Name:= "MSOffice"

In diesem Beispiel wird "myCompany" der Liste mit Ausnahmen weiterer Korrekturen hinzugefügt.

AutoCorrect.OtherCorrectionsExceptions.Add Name:= "myCompany"


Add-Methode (FormFields-Auflistung)

Fügt im angegebenen Bereich ein neues Formularfeld ein.

Syntax

Ausdruck.Add(Range, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein FormFields-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem das Formularfeld eingefügt werden soll. Wenn der Bereich nicht reduziert ist, ersetzt das Formularfeld den Bereich.

Type Long erforderlich. Der Formularfeldtyp, der eingefügt werden soll. Dies kann eine der folgenden WdFieldType-Konstanten sein: wdFieldFormCheckBox, wdFieldFormDropDown oder wdFieldFormTextInput.


Beispiel zur Add-Methode (FormFields-Auflistung)

In diesem Beispiel wird am Ende der Auswahl ein Kontrollkästchen eingefügt, dieses benannt und dann markiert.

Selection.Collapse Direction:=wdCollapseEnd
Set ffield = ActiveDocument.FormFields _
    .Add(Range:=Selection.Range, Type:=wdFieldFormCheckBox)
With ffield
    .Name = "Check_Box_1"
    .CheckBox.Value = True
End With


Add-Methode (Frames-Auflistung)

Fügt einem Dokument, einer Auswahl oder einem Bereich einen neuen Rahmen hinzu.

Syntax

Ausdruck.Add(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Frames-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, den der Rahmen umgeben soll.


Beispiel zur Add-Methode (Frames-Auflistung)

In diesem Beispiel wird die Auswahl mit einem Rahmen versehen.

ActiveDocument.Frames.Add Range:= Selection.Range

In diesem Beispiel wird der dritte Absatz in der Auswahl mit einem Rahmen versehen.

Set myFrame = Selection.Frames _
    .Add(Range:= Selection.Paragraphs(3).Range)


Add-Methode (HangulAndAlphabetExceptions-Auflistung)

Sprachspezifische Informationen

Adds a new exception to the list of hangul and alphabet AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box (AutoCorrect command, Tools menu).

Syntax

expression.Add(Name)

expression Required. An expression that returns a HangulAndAlphabetExceptions object.

Name Required String. The word that you don't want Microsoft Word to correct automatically.

Remarks

If the HangulAndAlphabetAutoAdd property is set to True, words are automatically added to the list of hangul and alphabet AutoCorrect exceptions.

For more information on using Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur Add-Methode (HangulAndAlphabetExceptions-Auflistung)

Sprachspezifische Informationen

This example adds "test" to the list of hangul and alphabet AutoCorrect exceptions on the Korean tab in the AutoCorrect Exceptions dialog box.

AutoCorrect.HangulAndAlphabetExceptions.Add Name:= "test"


Add-Methode (HangulHanjaConversionDictionaries-Auflistung)

Sprachspezifische Informationen

Adds the specified dictionary to the collection of active custom conversion dictionaries. If a file with the specified name doesn't exist, Microsoft Word creates one.

Syntax

expression.Add(FileName)

expression Required. An expression that returns a HangulHanjaConversionDictionaries collection.

FileName Required String. The path and file name of the dictionary you want to add. If no path is specified, the proofing tools path is used.

Remarks

Use the HangulHanjaDictionaries property to return the collection of custom conversion dictionaries. The HangulHanjaConversionDictionaries collection includes only the active custom conversion dictionaries.

Dictionary objects that are derived from the Languages collection don't have an Add method. These include the Dictionary objects returned by the ActiveSpellingDictionary, ActiveGrammarDictionary, ActiveThesaurusDictionary, and ActiveHyphenationDictionary properties.

For more information on using Microsoft Word with East Asian languages, see Word features for East Asian languages.


Beispiel zur Add-Methode (HangulHanjaConversionDictionaries-Auflistung)

Sprachspezifische Informationen

This example removes all dictionaries from the list of custom conversion dictionaries and creates a new custom dictionary file. The new dictionary is assigned to be the active custom dictionary, to which new words are automatically added.

With HangulHanjaDictionaries
    .ClearAll
    .Add FileName:= "C:\My Documents\MyCustom.hhd"
    .ActiveCustomDictionary = CustomDictionaries(1)
End With


Add-Methode (HeadingStyles-Auflistung)

Fügt einem Dokument eine neue Formatvorlage für Überschriften hinzu. Die neue Formatvorlage für Überschriften wird bei jeder Kompilierung eines Inhalts- oder Abbildungsverzeichnisses mit eingeschlossen.

Syntax

Ausdruck.Add(Style, Level)

Ausdruck Erforderlich. Ein Ausdruck, der ein HeadingStyles-Objekt zurückgibt.

Style Variant erforderlich. Die Formatvorlage, die hinzugefügt werden soll. Mit dem Namen der Zeichenfolge für die Formatvorlage oder dem Style-Objekt können Sie dieses Argument angeben.

Level Integer erforderlich. Eine Zahl, die die Überschriftsebene repräsentiert.


Beispiel zur Add-Methode (HeadingStyles-Auflistung)

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Inhaltsverzeichnis hinzugefügt, dann wird die Titel-Formatvorlage zu der Liste der Formatvorlagen, die bei der Erstellung eines Inhaltsverzeichnisses verwendet werden, hinzugefügt.

Set myToc = ActiveDocument.TablesOfContents _
    .Add(Range:=ActiveDocument.Range(0, 0), _
    UseHeadingStyles:=True, UpperHeadingLevel:=1, _
    LowerHeadingLevel:=3)
myToc.HeadingStyles.Add Style:="Title", Level:=2


Beispiel zur AddHorizontalLine-Methode

Dieses Beispiel fügt eine horizontale Linie über der aktuellen Markierung des aktiven Dokuments ein und verwendet hierzu eine Datei mit dem Namen ArtsyRule.gif.

Selection.InlineShapes.AddHorizontalLine _
    "C:\My Documents\ArtsyRule.gif"


Add-Methode (Hyperlinks-Auflistung)

Fügt dem Dokument, der Markierung oder dem Bereich einen neuen Hyperlink hinzu.

Syntax

Ausdruck.Add(Anchor, Address, SubAddress, ScreenTip, TextToDisplay, Target)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlinks-Objekt zurückgibt.

Anchor Objekt erforderlich. Der Text oder die Grafik, der/die in einen Hyperlink umgewandelt werden soll.

Address Variant optional. Die Adresse für die angegebene Verknüpfung. Die Adresse kann eine E-Mail-Adresse, eine Internetadresse oder ein Dateiname sein. Beachten Sie, dass Microsoft Word nicht überprüft, ob die Adresse richtig ist.

SubAddress Variant optional. Der Name einer Stelle innerhalb der Zieldatei, beispielsweise eine Textmarke, ein benannter Bereich oder eine Foliennummer.

ScreenTip Variant optional. Der Text, der als Bildschirmtipp angezeigt wird, wenn mit dem Mauszeiger auf den angegebenen Hyperlink gezeigt wird. Der Standardwert ist Address.

TextToDisplay Variant optional. Der Anzeigetext des angegebenen Hyperlinks. Der Wert dieses Arguments ersetzt den Text oder die Grafik, die durch Anchor angegeben ist.

Target Variant optional. Der Name des Frames oder Fensters, in den Sie den angegebenen Hyperlink laden möchten.


Beispiel zur Add-Methode (Hyperlinks-Auflistung)

In diesem Beispiel wird die Auswahl in einen Hyperlink zur Microsoft Adresse auf dem World Wide Web verwandelt.

ActiveDocument.Hyperlinks.Add Anchor:=Selection.Range, _
    Address:="http:\\www.microsoft.com"

In diesem Beispiel wird die Auswahl in einen Hyperlink umgewandelt, der mit der Textmarke "meineTextmarke" in meineDatei.doc verknüpft wird.

ActiveDocument.Hyperlinks.Add Anchor:=Selection.Range, _
    Address:="C:\My Documents\MyFile.doc", SubAddress:="MyBookMark"

In diesem Beispiel wird die erste Grafik in der Auswahl in einen Hyperlink umgewandelt.

ActiveDocument.Hyperlinks.Add Anchor:=Selection.ShapeRange(1), _
    Address:="http:\\www.microsoft.com"


Add-Methode (Indexes-Auflistung)

Fügt einem Dokument einen neuen Index hinzu.

Syntax

Ausdruck.Add(Range, HeadingSeparator, RightAlignPageNumbers, Type, NumberOfColumns, AccentedLetters, SortBy, IndexLanguage)

Ausdruck Erforderlich. Ein Ausdruck, der ein Indexes-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem der Index erscheinen soll. Der Index ersetzt den Bereich, wenn der Bereich nicht reduziert ist.

HeadingSeparator Variant optional. Der Text zwischen alphabetischen Gruppen (Einträge, die mit dem gleichen Buchstaben anfangen) im Index. Dies kann eine der folgenden WdHeadingSeparator-Konstanten sein: wdHeadingSeparatorBlankLine, wdHeadingSeparatorLetter, wdHeadingSeparatorLetterFull, wdHeadingSeparatorLetterLow oder wdHeadingSeparatorNone.

RightAlignPageNumbers Variant optional. True, wenn die Seitenzahlen mit dem rechten Rand ausgerichtet werden sollen.

Type Variant optional. Gibt an, ob die Untereinträge in der gleichen Zeile (fortlaufend) wie die Haupteinträge oder in von den Haupteinträgen getrennten Zeilen (eingerückt) sind. Dies kann eine der folgenden WdIndexType-Konstanten sein: wdIndexIndent oder wdIndexRunin.

NumberOfColumns Variant optional. Die Anzahl der Spalten für jede Indexseite. Mit der Angabe 0 (Null) wird die Anzahl der Spalten im Index auf die gleiche Anzahl wie die der Spalten im Dokument festgelegt.

AccentedLetters Variant optional. True, wenn im Index Buchstaben mit Akzenten eigene Überschriften haben (Wörter z. B., die mit "À" beginnen, und Wörter, die mit "A" beginnen, erhalten getrennte Überschriften).

SortBy Variant optional. Das für den angegebenen Index verwendete Sortierkriterium. Dies kann eine der folgenden WdIndexSortBy-Konstanten sein: wdIndexSortByStroke oder wdIndexSortBySyllable.

IndexLanguage Variant optional. Die für den angegebenen Index verwendete Sortiersprache. Dies kann jede der WdLanguageID-Konstanten sein. Eine Liste der gültigen WdLanguageID-Konstanten finden Sie im Objektkatalog im Visual Basic-Editor.

Anmerkungen

Ein Index wird aus XE-Feldern (Indexeinträge) in einem Dokument erstellt. Mit der MarkEntry-Methode können Sie Indexeinträge markieren, die in den Index aufgenommen werden sollen.


Beispiel zur Add-Methode (Indexes-Auflistung)

In diesem Beispiel wird ein Indexeintrag markiert und dann am Ende des aktiven Dokuments ein Index erstellt.

ActiveDocument.Indexes.MarkEntry _
    Range:=Selection.Range, Entry:="My Entry"
Set MyRange = ActiveDocument.Content
MyRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.Indexes.Add Range:=MyRange, Type:=wdIndexRunin


Add-Methode (KeyBindings-Auflistung)

Fügt ein neues KeyBinding-Objekt der KeyBindings-Auflistung hinzu. Ein KeyBinding-Objekt stellt eine benutzerdefinierte Tastenbelegung mit einem Tastencode, einer Tastenkategorie und einem Befehl dar.

Syntax

Ausdruck.Add(KeyCategory, Command, KeyCode, KeyCode2, CommandParameter)

Ausdruck Erforderlich. Ein Ausdruck, der ein KeyBindings-Objekt zurückgibt.

KeyCategory Long erforderlich. Die Kategorie der Tastenbelegung. Dabei kann es sich um eine der folgenden WdKeyCategory-Konstanten handeln:

wdKeyCategoryAutoText

wdKeyCategoryCommand

wdKeyCategoryDisable

wdKeyCategoryFont

wdKeyCategoryMacro

 wdKeyCategoryNil

wdKeyCategoryPrefix

wdKeyCategoryStyle

wdKeyCategorySymbol

Command String erforderlich. Der Befehl, den die angegebene Tastenkombination ausführt.

KeyCode Long erforderlich. Eine Taste, die Sie mit einer WdKey-Konstanten bestimmen.

KeyCode2 Variant optional. Eine zweite Taste, die Sie mit einer WdKey-Konstanten bestimmen.

CommandParameter Variant optional. Zusätzlicher Text, der zur Ausführung des mit Command festgelegten Befehls nötig ist. Einzelheiten dazu finden Sie im Abschnitt "Anmerkungen".

Anmerkungen

Mit der BuildKeyCode-Methode erzeugen Sie ein KeyCode- oder KeyCode2-Argument.

In der linken Spalte der folgenden Tabelle finden Sie die Befehle, die einen Befehlswert benötigen und in der rechten eine Beschreibung der CommandParameter dieser Befehle. (Sie entsprechend der Auswahl der CommandParameter im Dialogfeld Tastatur anpassen (Menü Extras), wenn Sie ein Element aus einem Listenfeld wählen, das bei der Auswahl einer der folgenden Befehle im Feld Befehle erscheint.)

Einstellung für Command | Obligatorische CommandParameter
Borders, Color oder Shading | Eine als Text angegebene Zahl, die der Einstellungsposition im Listenfeld mit den Werten entspricht. Dabei steht 0 (Null) für das erste Element, 1 für das zweite, usw.
Columns | Eine als Text angegebene Zahl zwischen 1 und 45, die der Spaltenanzahl entspricht, die Sie zuweisen.
Condensed | Ein Textmaß zwischen 0,1 Punkt und 12,75 Punkt, das in 0,05 Punkt-Schritten angegeben wird (72 Punkt = 1 Zoll).
Expanded | Ein Textmaß zwischen 0,1 Punkt und 12,75 Punkt, das in 0,05 Punkt-Schritten angegeben wird (72 Punkt = 1 Zoll).
FileOpenFile | Der Pfad- und Dateiname der Datei, die geöffnet werden soll. Ohne festgelegten Pfad wird der aktuelle Ordner verwendet.
FontSize | Ein positives Textmaß, das in 0,5 Punkt-Schritten angegeben wird (72 Punkt = 1 Zoll).
Lowered, Raised | Ein Textmaß zwischen 1 Punkt und 64 Punkt, das in 0,5 Punkt-Schritten angegeben wird (72 Punkt = 1 Zoll).
Symbol | Eine Zeichenfolge, die durch Verkettung einer Chr()-Instruktion und dem Namen einer Symbolschriftart erstellt wird (z. B. Chr(167) & "Symbol").


Beispiel zur Add-Methode (KeyBindings-Auflistung)

In diesem Beispiel wird die Tastenkombination STRG+ALT+W dem Befehl DateiSchließen zugewiesen. Die Tastaturanpassung wird in der Dokumentvorlage Normal gespeichert.

CustomizationContext = NormalTemplate
KeyBindings.Add _
    KeyCategory:=wdKeyCategoryCommand, _
    Command:="FileClose", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyW)

In diesem Beispiel wird der Tastenkombination ALT+F4 die Schriftart Arial zugewiesen und die Anzahl der Elemente in der KeyBindings-Auflistung angezeigt. Daraufhin werden die Tastenkombinationen gelöscht (und auf ihre Standardeinstellungen zurückgesetzt) und die Anzahl der Elemente in der KeyBindings-Auflistung wird erneut angezeigt.

CustomizationContext = ActiveDocument.AttachedTemplate
Set myKey = KeyBindings.Add(KeyCategory:=wdKeyCategoryFont, _
    Command:="Arial", KeyCode:=BuildKeyCode(wdKeyAlt, wdKeyF4))
MsgBox KeyBindings.Count & " keys in KeyBindings collection"
myKey.Clear
MsgBox KeyBindings.Count & " keys in KeyBindings collection"

In diesem Beispiel wird die Tastenkombination STRG+ALT+S dem Befehl Schriftart mit einem Schriftgrad von 8 Punkt zugewiesen.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCategory:=wdKeyCategoryCommand, _
    Command:="FontSize", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyS), _
    CommandParameter:="8"

In diesem Beispiel wird die Tastenkombination STRG+ALT+H der Formatvorlage "Heading 1" im aktiven Dokument zugewiesen.

CustomizationContext = ActiveDocument
KeyBindings.Add KeyCategory:=wdKeyCategoryStyle, _
    Command:="Heading 1", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyH)

In diesem Beispiel wird die Tastenkombination STRG+ALT+O dem AutoText-Eintrag "Hello" zugewiesen.

CustomizationContext = ActiveDocument
KeyBindings.Add KeyCategory:=wdKeyCategoryAutoText, _
    Command:="Hello", _
    KeyCode:=BuildKeyCode(wdKeyControl, wdKeyAlt, wdKeyO)


Add-Methode (ListEntries-Auflistung)

Fügt einem Dropdown-Formularfeld ein Element hinzu.

Syntax

Ausdruck.Add(Name, Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListEntries-Objekt zurückgibt.

Name String erforderlich. Der Name des Elements des Dropdown-Formularfelds.

Index Variant optional. Eine Zahl, die die Position des Elements in der Liste repräsentiert.


Beispiel zur Add-Methode (ListEntries-Auflistung)

In diesem Beispiel wird ein Dropdown-Formularfeld in das aktive Dokument eingefügt und dann die Elemente "Red", "Blue" und "Green" zu dem Formularfeld hinzugefügt.

Set myField = ActiveDocument.FormFields.Add(Range:= _
    Selection.Range, Type:= wdFieldFormDropDown)
With myField.DropDown.ListEntries
    .Add Name:="Red"
    .Add Name:="Blue"
    .Add Name:="Green"
End With


Add-Methode (ListTemplates-Auflistung)

Erstellt eine neue Listenvorlage.

Syntax

Ausdruck.Add(OutlineNumbered, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein ListTemplates-Objekt zurückgibt.

OutlineNumbered Variant optional. True, wenn der neuen Listenvorlage eine Gliederungsnummerierung zugewiesen werden soll.

Name Variant optional. Ein optionaler Name zur Verknüpfung der Listenvorlage mit einem LISTNUM-Feld. Sie können diesen Namen nicht zur Indizierung der Listenvorlage in die Auflistung verwenden.

Anmerkungen

Die Add-Methode kann nicht bei ListTemplates-Objekten verwendet werden, die vom ListGallery-Objekt zurückgegeben wurden. Sie können aber die bestehenden Listenvorlagen in den Katalogen verändern.


Beispiel zur Add-Methode (ListTemplates-Auflistung)

In diesem Beispiel wird dem aktiven Dokument eine neue Listenvorlage mit einer Ebene hinzugefügt. Dabei wird die Formatvorlage für Nummerierungen geändert und dann die Listenvorlage dem Abschnitt zugewiesen.

Set myList = _
    ActiveDocument.ListTemplates.Add(OutlineNumbered:=False)
myList.ListLevels(1).NumberStyle = wdListNumberStyleUpperCaseLetter
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myList


Add-Methode (MailMergeFields-Auflistung)

Fügt dem Datenquelldokument ein Seriendruck-Datenfeld hinzu.

Syntax

Ausdruck.Add(Range, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein MailMergeFields-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem das Feld erscheinen soll. Dieses Feld ersetzt den Bereich, wenn der Bereich nicht reduziert ist.

Name String erforderlich. Der Name des Feldes.


Beispiel zur Add-Methode (MailMergeFields-Auflistung)

In diesem Beispiel wird die Auswahl mit dem Datenfeld "MiddleInitial" ersetzt.

ActiveDocument.MailMerge.Fields.Add Range:= Selection.Range, _
    Name:="MiddleInitial"


Beispiel zur AddNext-Methode

In diesem Beispiel wird ein NEXT-Feld nach dem dritten MERGEFIELD-Feld in Main.doc hinzugefügt.

Documents("Main.doc").MailMerge.Fields(3).Select
Selection.Collapse Direction:=wdCollapseEnd
Documents("Main.doc").MailMerge.Fields.AddNext _
    Range:=Selection.Range


Add-Methode (PageNumbers-Auflistung)

Fügt Seitenzahlen zu Kopf- und Fußzeilen in Abschnitten hinzu.

Syntax

Ausdruck.Add(PageNumberAlignment, FirstPage)

Ausdruck Erforderlich. Ein Ausdruck, der ein PageNumbers-Objekt zurückgibt.

PageNumberAlignment Variant optional. Dies kann eine der folgenden WdPageNumberAlignment-Konstanten sein: wdAlignPageNumberCenter, wdAlignPageNumberInside, wdAlignPageNumberLeft, wdAlignPageNumberOutside oder wdAlignPageNumberRight.

FirstPage Variant optional. False, wenn die Kopf- und die Fußzeile der ersten Seite anders als die Kopf- und Fußzeilen der folgenden Seiten im Dokument sein sollen. Wenn FirstPage den Wert False hat, wird zur ersten Seite keine Seitenzahl hinzugefügt. Wenn dieses Argument ausgelassen wird, wird die Einstellung durch die DifferentFirstPageHeaderFooter-Eigenschaft gesteuert.

Anmerkungen

Wenn die LinkToPrevious-Eigenschaft für das HeaderFooter-Objekt den Wert True hat, werden die Seitenzahlen fortlaufend von einem Abschnitt zum nächsten im ganzen Dokument weitergeführt.


Beispiel zur Add-Methode (PageNumbers-Auflistung)

In diesem Beispiel wird zur primären Fußzeile im ersten Abschnitt des aktiven Dokuments eine Seitenzahl hinzugefügt.

With ActiveDocument.Sections(1)
    .Footers(wdHeaderFooterPrimary).PageNumbers.Add _
        PageNumberAlignment:= wdAlignPageNumberLeft, _
        FirstPage:= True
End With

In diesem Beispiel werden Seitenzahlen in der Kopfzeile für das aktive Dokument erstellt und formatiert.

Set myPgNum = ActiveDocument.Sections(1) _
    .Headers(wdHeaderFooterPrimary) _
    .PageNumbers.Add(PageNumberAlignment:= _
    wdAlignPageNumberCenter, FirstPage:= True)
myPgNum.Select
With Selection.Range
    .Italic = True
    .Bold = True
End With


Add-Methode (Panes-Auflistung)

Fügt einem Fenster einen neuen Ausschnitt hinzu.

Syntax

Ausdruck.Add(SplitVertical)

Ausdruck Erforderlich. Ein Ausdruck, der ein Panes-Objekt zurückgibt.

SplitVertical Variant optional. Eine Zahl, die den Prozentsatz des Fensters, das oberhalb der Teilung erscheinen soll, vom oberen bis zum unteren Rand repräsentiert.

Anmerkungen

Diese Methode funktioniert nicht, wenn das Fenster bereits geteilt ist.


Beispiel zur Add-Methode (Panes-Auflistung)

Im folgenden Beispiel wird das aktive Fenster so geteilt, dass der obere Ausschnitt 30 Prozent der gesamten Fenstergröße beträgt.

ActiveDocument.ActiveWindow.Panes.Add SplitVertical:=30


Add-Methode (Paragraphs-Auflistung)

Fügt einem Dokument einen neuen, leeren Absatz hinzu.

Syntax

Ausdruck.Add(Range)

Ausdruck Erforderlich. Ein Ausdruck, der ein Paragraphs-Objekt zurückgibt.

Range Variant optional. Der Bereich, vor dem der neue Absatz hinzugefügt werden soll. Der neue Absatz ersetzt nicht den Bereich.

Anmerkungen

Wenn Range nicht angegeben wird, wird der neue Absatz nach der Auswahl oder dem Bereich oder am Ende des Dokuments hinzugefügt. Dieses hängt von dem Ausdruck ab.


Beispiel zur Add-Methode (Paragraphs-Auflistung)

In diesem Beispiel wird der Auswahl ein neuer Absatz hinzugefügt.

Selection.Paragraphs.Add

In diesem Beispiel wird vor dem ersten Absatz in der Auswahl eine Absatzmarke hinzugefügt.

Selection.Paragraphs.Add Range:=Selection.Paragraphs(1).Range

In diesem Beispiel wird vor dem zweiten Absatz im aktiven Dokument eine Absatzmarke hinzugefügt.

ActiveDocument.Paragraphs.Add _
    Range:=ActiveDocument.Paragraphs(2).Range

In diesem Beispiel wird am Ende des aktiven Dokuments eine neue Absatzmarke hinzugefügt.

ActiveDocument.Paragraphs.Add


Beispiel zur AddPicture-Methode

In diesem Beispiel wird eine neue Grafik zu myDoc hinzugefügt. Die eingefügte Grafik wird mit der Datei verknüpft, aus der sie erstellt wurde, und sie wird mit dem Dokument gespeichert.

Set myDoc = ActiveDocument
ActiveDocument.Shapes.AddPicture _
    "C:\Program Files\Microsoft office\" _
    & "Office\Bitmaps\Styles\stone.bmp", _
    True, True


Add-Methode (RecentFiles-Auflistung)

Fügt eine Datei zur Liste der kürzlich benutzten Dateien hinzu.

Syntax

Ausdruck.Add(Document, ReadOnly)

Ausdruck Erforderlich. Ein Ausdruck, der ein RecentFiles-Objekt zurückgibt.

Document Variant erforderlich. Das Dokument, das zu der Liste der kürzlich benutzten Dateien hinzugefügt werden soll. Sie können dieses Argument angeben, indem Sie entweder den Namen der Zeichenfolge für das Dokument oder ein Document-Objekt verwenden.

ReadOnly Variant optional. True, wenn dem Dokument Nur-Lese-Zugriff eingeräumt werden soll.


Beispiel zur Add-Methode (RecentFiles-Auflistung)

In diesem Beispiel wird ein aktives Dokument zur Liste der kürzlich benutzten Dateien hinzugefügt.

If ActiveDocument.Saved = True Then
    RecentFiles.Add Document:=ActiveDocument.Name
End If


Add-Methode (Sections-Auflistung)

Fügt einem Dokument einen neuen Abschnitt hinzu.

Syntax

Ausdruck.Add(Range, Start)

Ausdruck Erforderlich. Ein Ausdruck, der ein Sections-Objekt zurückgibt.

Range Variant optional. Der Bereich, vor dem der Abschnittswechsel eingefügt werden soll. Wenn dieses Argument ausgelassen wird, wird der Abschnittswechsel am Ende des Dokuments eingefügt.

Start Variant optional. Die Art des Abschnittswechsels, der hinzugefügt werden soll. Dies kann eine der folgenden WdSectionStart-Konstanten sein: wdSectionContinuous, wdSectionEvenPage, wdSectionNewColumn, wdSectionNewPage oder wdSectionOddPage. Wenn dieses Argument ausgelassen wird, wird ein Abschnittswechsel "Next Page" hinzugefügt.


Beispiel zur Add-Methode (Sections-Auflistung)

In diesem Beispiel wird vor dem dritten Absatz im aktiven Dokument ein Abschnittswechsel "Next Page" hinzugefügt.

Set myRange = ActiveDocument.Paragraphs(3).Range
ActiveDocument.Sections.Add Range:=myRange

In diesem Beispiel wird bei der Auswahl ein fortlaufender Abschnittswechsel hinzugefügt.

Set myRange = Selection.Range
ActiveDocument.Sections.Add Range:=myRange, _
    Start:=wdSectionContinuous

In diesem Beispiel wird am Ende des aktiven Dokuments ein Abschnittswechsel "Next Page" hinzugefügt.

ActiveDocument.Sections.Add


Add-Methode (Styles-Auflistung)

Fügt der Auflistung der Formatvorlagen eine neue benutzerdefinierte Formatvorlage hinzu.

Syntax

Ausdruck.Add(Name, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Styles-Objekt zurückgibt.

Name String erforderlich. Der Name der Zeichenfolge für die neue Formatvorlage.

Type Variant optional. Die Art der neuen Formatvorlage. Diese kann eine der folgenden WdStyleType-Konstanten: wdStyleTypeParagraph oder wdStyleTypeCharacter.


Beispiel zur Add-Methode (Styles-Auflistung)

In diesem Beispiel wird eine neue Zeichenformatvorlage mit dem Namen "Introduction" hinzugefügt und fett kursiv als 12-Punkt Arial formatiert. Dann wird die neue Zeichenformatvorlage der Auswahl zugewiesen.

Set myStyle = ActiveDocument.Styles.Add(Name:="Introduction", _
    Type:=wdStyleTypeCharacter)
With myStyle.Font
    .Bold = True
    .Italic = True
    .Name = "Arial"
    .Size = 12
End With
Selection.Range.Style = "Introduction"


Add-Methode (Tables-Auflistung)

Fügt einem Dokument eine neue, leere Tabelle hinzu.

Syntax

Ausdruck.Add(Range, NumRows, NumColumns DefaultTableBehavior, AutoFitBehavior)

Ausdruck Erforderlich. Ein Ausdruck, der ein Tables-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem die Tabelle angezeigt werden soll. Die Tabelle ersetzt den Bereich, wenn der Bereich nicht reduziert ist.

NumRows Long erforderlich. Die Anzahl der Zeilen, die in der Tabelle enthalten sein sollen.

NumColumns Long erforderlich. Die Anzahl der Spalten, die in der Tabelle enthalten sein sollen.

DefaultTableBehavior Variant optional. Legt einen Wert fest, der angibt, ob Microsoft Word automatisch die Zellengröße in Tabellen ändert, damit der Zelleninhalt passt (AutoAnpassen). Dies kann eine der folgenden Konstanten sein: wdWord8TableBehavior (AutoAnpassen deaktiviert) oder wdWord9TableBehavior (AutoAnpassen aktiviert). Die Standardkonstante ist wdWord8TableBehavior.

AutoFitBehavior Variant optional. Legt die Regeln für AutoAnpassen fest, nach denen die Größe von Tabellen in Word geändert wird. Dies kann eine der folgenden WdAutoFitBehavior-Konstanten sein: wdAutoFitContent, wdAutoFitFixed oder wdAutoFitWindow. Wenn DefaultTableBehavior auf wdWord8TableBehavior gesetzt ist, wird dieses Argument ignoriert.


Beispiel zur Add-Methode (Tables-Auflistung)

In diesem Beispiel wird am Anfang des aktiven Dokuments eine leere Tabelle mit drei Zeilen und vier Spalten hinzugefügt.

Set myRange = ActiveDocument.Range(0, 0)
ActiveDocument.Tables.Add Range:=myRange, NumRows:=3, NumColumns:=4

In diesem Beispiel wird am Ende des aktiven Dokuments eine neue, leere Tabelle mit sechs Zeilen und zehn Spalten hinzugefügt.

Set MyRange = ActiveDocument.Content
MyRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.Tables.Add Range:=MyRange, NumRows:=6, _
    NumColumns:=10

In diesem Beispiel wird einem neuen Dokument eine Tabelle mit drei Zeilen und fünf Spalten hinzugefügt, und dann werden Daten in jede Zelle der Tabelle eingefügt.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 5)
With myTable
For x = 1 to 3
    For y = 1 to 5
        .Cell(x,y).Range.InsertAfter "Cell " & x & "," & y
    Next y
Next x
.Columns.AutoFit
End With


Add-Methode (TablesOfAuthorities-Auflistung)

Fügt zu einem Dokument ein Rechtsgrundlagenverzeichnis hinzu.

Syntax

Ausdruck.Add(Range, Category, Bookmark, Passim, KeepEntryFormatting, Separator, IncludeSequenceName, EntrySeparator, PageRangeSeparator, IncludeCategoryHeader, PageNumberSeparator)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfAuthorities-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem das Rechtsgrundlagenverzeichnis eingefügt werden soll. Das Rechtsgrundlagenverzeichnis ersetzt den Bereich, sofern der Bereich nicht reduziert ist.

Category Variant optional. Die Kategorie von Einträgen, die in das Rechtsgrundlagenverzeichnis aufgenommen werden sollen. Entspricht dem Schalter \c in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Die Werte 0 bis 16 entsprechen den Einträgen im Listenfeld Kategorie auf der Registerkarte Rechtsgrundlagenverzeichnis im Dialogfeld Index und Verzeichnisse (Menü Einfügen). Der Standardwert lautet 1.

Bookmark Variant optional. Der Name der Textmarke, aus dem die Einträge für das Rechtsgrundlagenverzeichnis gelesen werden. Wenn Bookmark angegeben wird, werden die Einträge nur aus dem Teil des Dokuments gelesen, der durch die Textmarke festgelegt ist. Entspricht dem Schalter \b in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld).

Passim Variant optional. Setzen Sie dieses Argument auf True, wenn fünf oder mehr Verweise auf Seiten in derselben Quelle im Rechtsgrundlagenverzeichnis durch "Passim" ersetzt werden sollen. Entspricht dem Schalter \p in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, wird angenommen, dass Passim gleich False ist.

KeepEntryFormatting Variant optional. Setzen Sie dieses Argument auf True, wenn die Formatierung der Einträge für das Rechtsgrundlagenverzeichnis auf die Einträge im Verzeichnis selbst übertragen werden sollen. Entspricht dem Schalter \f in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, wird angenommen, dass KeepEntryFormatting gleich True ist.

Separator Variant optional. Bis zu fünf Zeichen, die im Rechtsgrundlagenverzeichnis zwischen die Folgenummer und die entsprechende Seitenzahl gesetzt werden. Entspricht dem Schalter \d in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, werden Bindestriche (-) verwendet.

IncludeSequenceName Variant optional. Eine Zeichenfolge, die das Erkennungszeichen des SEQ-Feldes (Reihenfolgefeld) für das Rechtsgrundlagenverzeichnis festlegt. Entspricht dem Schalter \s in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld).

EntrySeparator Variant optional. Bis zu fünf Zeichen, die im Rechtsgrundlagenverzeichnis zwischen die Einträge und die entsprechende Seitenzahl gesetzt werden. Entspricht dem Schalter \e in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, wird kein Trennzeichen verwendet.

PageRangeSeparator Variant optional. Bis zu fünf Zeichen, die im Rechtsgrundlagenverzeichnis zwischen die erste und letzte Seite in jedem Seitenbereich gesetzt werden. Entspricht dem Schalter \g in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, wird ein Halbgeviertstrich verwendet.

IncludeCategoryHeader Variant optional. Setzen Sie dieses Argument auf True, wenn im Rechtsgrundlagenverzeichnis für jede Eintragsgruppe der Kategoriename (beispielsweise "Cases") angezeigt werden soll. Entspricht dem Schalter \h in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, wird angenommen, dass IncludeCategoryHeader gleich True ist.

PageNumberSeparator Variant optional. Bis zu fünf Zeichen, die im Rechtsgrundlagenverzeichnis zwischen einzelne Seitenzahlen in Seitenverweisen gesetzt werden. Entspricht dem Schalter \l in einem TOA-Feld (Rechtsgrundlagenverzeichnisfeld). Wenn dieses Argument fehlt, werden ein Komma und ein Leerzeichen verwendet.

Hinweise

Rechtsgrundlagenverzeichnisse werden aus TOA-Feldern (Rechtsgrundlagenverzeichnisfelder) in einem Dokument zusammengestellt. Verwenden Sie die MarkCitation-Methode, um Einträge festzulegen, die in das Rechtsgrundlagenverzeichnis aufgenommen werden sollen.


Beispiel zur Add-Methode (TablesOfAuthorities-Auflistung)

In diesem Beispiel wird am Anfang des aktiven Dokuments ein Rechtsgrundlagenverzeichnis eingefügt, das Einträge aus allen Kategorien enthält.

Set myRange = ActiveDocument.Range(0, 0)
ActiveDocument.TablesOfAuthorities.Add Range:=myRange, _
    Passim:= True, Category:= 0, EntrySeparator:= ", "


Add-Methode (TablesOfContents-Auflistung)

Fügt einem Dokument ein Inhaltsverzeichnis hinzu.

Syntax

Ausdruck.Add(Range, UseHeadingStyles, UpperHeadingLevel, LowerHeadingLevel, UseFields, TableID, RightAlignPageNumbers, IncludePageNumbers, AddedStyles), UseHyperlinks, HidePageNumbersInWeb)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfContents-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem das Inhaltsverzeichnis angezeigt werden soll. Das Inhaltsverzeichnis ersetzt den Bereich, wenn dieser nicht reduziert ist.

UseHeadingStyles Variant optional. True, wenn zur Erstellung von Inhaltsverzeichnissen integrierte Überschriftenformatvorlagen verwendet werden sollen. Der Standardwert ist True.

UpperHeadingLevel Variant optional. Die oberste Überschriftenebene für das Inhaltsverzeichnis. Entspricht dem Startwert, der mit dem Schalter "\o" für ein TOC-Feld (Inhaltsverzeichnis) verwendet wird. Der Standardwert ist 1.

LowerHeadingLevel Variant optional. Die unterste Überschriftenebene für das Inhaltsverzeichnis. Entspricht dem Endwert, der mit dem Schalter "\o" für ein TOC-Feld (Inhaltsverzeichnis) verwendet wird. Der Standardwert ist 9.

UseFields Variant optional. True, wenn zur Erstellung von Inhaltsverzeichnissen TC-Felder (Verzeichniseintrag) verwendet werden. Mit der MarkEntry-Methode können Sie Einträge markieren, die Sie in das Inhaltsverzeichnis einfügen wollen. Der Standardwert ist False.

TableID Variant optional. Ein Bezeichner, der aus einem Buchstaben besteht und zur Erstellung eines Inhaltsverzeichnisses aus TC-Feldern verwendet wird. Entspricht dem Schalter "\f" für ein TOC-Feld (Inhaltsverzeichnis). "V" erstellt z. B. ein Inhaltsverzeichnis aus TC-Feldern mit dem Bezeichner V. Wenn dieses Argument ausgelassen wird, werden keine TC-Felder verwendet.

RightAlignPageNumbers Variant optional. True, wenn die Seitenzahlen am rechten Rahmen ausgerichtet werden. Der Standardwert ist True.

IncludePageNumbers Variant optional. True, wenn Seitenzahlen im Inhaltsverzeichnis enthalten sein sollen. Der Standardwert ist True.

AddedStyles Variant optional. Der Name der Zeichenfolge für zusätzliche Formatvorlagen, der zur Kompilierung des Inhaltsverzeichnisses verwendet wird. (Andere Formatvorlagen als die Überschriftenformatvorlagen 1-9). Mit der Add-Methode eines HeadingStyles-Objekts können Sie neue Überschriftenformatvorlagen erstellen.

UseHyperlinks Variant optional. True, wenn Einträge im Inhaltsverzeichnis beim Veröffentlichen des Dokuments im Web als Hyperlinks formatiert werden sollen. Der Standardwert ist True.

HidePageNumbersInWeb Variant optional. True, wenn Seitenzahlen im Inhaltsverzeichnis beim Veröffentlichen des Dokuments im Web ausgeblendet werden sollen. Der Standardwert ist True.


Beispiel zur Add-Methode (TablesOfContents-Auflistung)

In diesem Beispiel wird am Anfang eines aktiven Dokuments ein Inhaltsverzeichnis eingefügt. Das Inhaltsverzeichnis wird aus Absätzen erstellt, die die Überschriftenformatvorlage 1, 2 und 3 oder die benutzerdefinierten Formatvorlagen meineFormatvorlage und deineFormatvorlage haben.

Set myRange = ActiveDocument.Range(0, 0)
ActiveDocument.TablesOfContents.Add _
    Range:=myRange, _
    UseFields:=False, _
    UseHeadingStyles:=True, _
    LowerHeadingLevel:=3, _
    UpperHeadingLevel:=1, _
    AddedStyles:="myStyle, yourStyle"


Add-Methode (TablesOfFigures-Auflistung)

Fügt einem Dokument ein Abbildungsverzeichnis hinzu.

Syntax

Ausdruck.Add(Range, Caption, IncludeLabel, UseHeadingStyles, UpperHeadingLevel, LowerHeadingLevel, UseFields, TableId, RightAlignPageNumbers, UseHyperlinks, HidePageNumbersInWeb)

Ausdruck Erforderlich. Ein Ausdruck, der ein TablesOfFigures-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, in dem das Abbildungsverzeichnis angezeigt werden soll.

Caption Variant optional. Die Kategorie, die die Elemente bezeichnet, die in das Abbildungsverzeichnis eingefügt werden sollen. Entspricht dem Schalter "\c" für ein TOC-Feld (Inhaltsverzeichnis). Der Standardwert ist "Abbildung".

IncludeLabel Variant optional. True, wenn die Beschriftungskategorie und die Beschriftungsnummer im Abbildungsverzeichnis enthalten sein sollen. Der Standardwert ist True.

UseHeadingStyles Variant optional. True, wenn zur Erstellung des Abbildungsverzeichnisses integrierte Überschriftenformatvorlagen verwendet werden sollen. Der Standardwert ist False.

UpperHeadingLevel Variant optional. Die oberste Überschriftenebene für das Abbildungsverzeichnis, wenn UseHeadingStyles denWert True hat. Entspricht dem Startwert, der mit dem Schalter "\o" für ein TOC-Feld (Inhaltsverzeichnis) verwendet wird. Der Standardwert ist 1.

LowerHeadingLevel Variant optional. Die unterste Überschriftenebene für das Abbildungsverzeichnis, wenn UseHeadingStyles denWert True hat. Entspricht dem Endwert, der mit dem Schalter "\o" für ein TOC-Feld (Inhaltsverzeichnis) verwendet wird. Der Standardwert ist 9.

UseFields Variant optional. True, wenn zur Erstellung des Abbildungsverzeichnisses TC-Felder (Verzeichniseintrag) verwendet werden. Mit der MarkEntry-Methode können Sie die Einträge markieren, die im Abbildungsverzeichnis enthalten sein sollen. Der Standardwert ist False.

TableId Variant optional. Ein Bezeichner, der aus einem Buchstaben besteht und zur Erstellung eines Abbildungsverzeichnisses aus TC-Feldern verwendet wird. Entspricht dem Schalter "\f" für ein TOC-Feld (Inhaltsverzeichnis). Beispielsweise erstellt "b" ein Abbildungsverzeichnis für ein Bild.

RightAlignPageNumbers Variant optional. True, wenn die Seitenzahlen am rechten Rahmen ausgerichtet werden. Der Standardwert ist True.

IncludePageNumbers Variant optional. True, wenn Seitenzahlen im Inhaltsverzeichnis enthalten sein sollen. Der Standardwert ist True.

AddedStyles Variant optional. Der Name der Zeichenfolge für zusätzliche Formatvorlagen, der zur Kompilierung des Inhaltsverzeichnisses verwendet wird. (Andere Formatvorlagen als die Überschriftenformatvorlagen 1-9). Mit der Add-Methode können Sie neue Überschriftenformatvorlagen erstellen.

UseHyperlinks Variant optional. True, wenn Einträge im Abbildungsverzeichnis beim Veröffentlichen im Web als Hyperlinks formatiert werden sollen. Der Standardwert ist True.

HidePageNumbersInWeb Variant optional. True, wenn die Seitenzahlen im Abbildungsverzeichnis beim Veröffentlichen im Web ausgeblendet werden sollen. Der Standardwert ist True.


Beispiel zur Add-Methode (TablesOfFigures-Auflistung)

In diesem Beispiel wird in das aktive Dokument ein Abbildungsverzeichnis eingefügt.

ActiveDocument.TablesOfFigures.Add Range:=Selection.Range


Add-Methode (TabStops-Auflistung)

Fügt einen benutzerdefinierten Tabstopp hinzu.

Syntax

Ausdruck.Add(Position, Alignment, Leader)

Ausdruck Erforderlich. Ein Ausdruck, der ein TabStops-Objekt zurückgibt.

Position Single erforderlich. Die Position des Tabstopps (in Punkt) relativ zum linken Rand.

Alignment Variant optional. Die Ausrichtung des Tabstopps. Dies kann eine der folgenden WdTabAlignment-Konstanten sein: wdAlignTabBar, wdAlignTabCenter, wdAlignTabDecimal, wdAlignTabLeft, wdAlignTabList oder wdAlignTabRight. Wird dieses Argument ausgelassen, wird wdAlignTabLeft verwendet.

Leader Variant optional. Die Art des Füllzeichens. Dies kann eine der folgenden WdTabLeader-Konstanten sein: wdTabLeaderDashes, wdTabLeaderDots, wdTabLeaderHeavy, wdTabLeaderLines, wdTabLeaderMiddleDot oder wdTabLeaderSpaces. Wird dieses Argument ausgelassen, wird wdTabLeaderSpaces verwendet.


Beispiel zur Add-Methode (TabStops-Auflistung)

In diesem Beispiel wird den markierten Absätzen ein Tabstopp hinzugefügt, der bei 2,5 Zoll (vom linken Rand der Seite) positioniert ist.

Selection.Paragraphs.TabStops.Add Position:=InchesToPoints(2.5)

In diesem Beispiel werden den markierten Absätzen zwei Tabstopps hinzugefügt. Der erste Tabstopp ist links ausgerichtet, hat Punkte als Füllzeichen und ist 1 Zoll (72 Punkt) vom linken Rand der Seite positioniert. Der zweite Tabstopp ist zentriert ausgerichtet und ist 2 Zoll vom linken Rand positioniert.

With Selection.Paragraphs.TabStops
    .Add Position:=InchesToPoints(1), _
        Leader:=wdTabLeaderDots, _
        Alignment:=wdAlignTabLeft
    .Add Position:=InchesToPoints(2), _
        Alignment:=wdAlignTabCenter
End With


Add-Methode (TextColumns-Auflistung)

Fügt einem Dokument oder einem Abschnitt eine neue Textspalte hinzu.

Hinweis Als Standard ist immer mindestens eine Textspalte in der TextColumns-Auflistung.

Syntax

Ausdruck.Add(Width, Spacing, EvenlySpaced)

Ausdruck Erforderlich. Ein Ausdruck, der ein TextColumns-Objekt zurückgibt.

Width Variant optional. Die Breite der nächsten Textspalte im Dokument, in Punkt.

Spacing Variant optional. Der Abstand zwischen den Textspalten im Dokument, in Punkt.

EvenlySpaced Variant optional. True, wenn zwischen allen Textspalten im Dokument ein einheitlicher Abstand sein soll.


Beispiel zur Add-Methode (TextColumns-Auflistung)

In diesem Beispiel wird ein neues Dokument erstellt und dann eine weitere 2,5-Zoll breite Textspalte zu dem Dokument hinzugefügt.

Set myDoc = Documents.Add
myDoc.PageSetup.TextColumns.Add Width:=InchesToPoints(2.5), _
    Spacing:=InchesToPoints(0.5), EvenlySpaced:=False

In diesem Beispiel wird dem aktiven Dokument eine neue Textspalte hinzugefügt und dann zwischen allen Textspalten im Dokument ein einheitlicher Abstand festgelegt.

ActiveDocument.PageSetup.TextColumns.Add _
    Width:=InchesToPoints(1.5), _
    EvenlySpaced:=True


Add-Methode (Variables-Auflistung)

Fügt dem Dokument eine Variable hinzu.

Syntax

Ausdruck.Add(Name, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein Variables-Objekt zurückgibt.

Name String erforderlich. Der Name der Dokumentenvariablen.

Value Variant optional. Der Wert für eine Dokumentenvariable.

Anmerkungen

Dokumentvariablen sind für den Benutzer nur sichtbar, wenn ein DOCVARIABLE-Feld mit dem korrekten Variablennamen eingefügt ist. Wenn Sie versuchen, eine Variable einzugeben, deren Name in der Variables-Auflistung bereits existiert, tritt ein Fehler auf. Dieses können Sie vermeiden, indem Sie sich die Auflistung aufzählen lassen, bevor Sie eine neue Variable hinzufügen.


Beispiel zur Add-Methode (Variables-Auflistung)

In diesem Beispiel wird dem aktiven Dokument eine Variable mit dem Namen "Temp" hinzugefügt und dann ein DOCVARIABLE-Feld eingefügt, um den Wert der Variablen Temp anzuzeigen.

With ActiveDocument
    .Variables.Add Name:="Temp", Value:="12"
    .Fields.Add Range:=Selection.Range, _
        Type:=wdFieldDocVariable, Text:="Temp"
End With
ActiveDocument.ActiveWindow.View.ShowFieldCodes = False

In diesem Beispiel wird der Wert der Variablen Blue auf 6 festgelegt. Wenn diese Variable noch nicht existiert, wird sie in diesem Beispiel dem Dokument hinzugefügt und auf 6 festgelegt.

For Each aVar In ActiveDocument.Variables
    If aVar.Name = "Blue" Then num = aVar.Index
Next aVar
If num = 0 Then
    ActiveDocument.Variables.Add Name:="Blue", Value:=6
Else
    ActiveDocument.Variables(num).Value = 6
End If

In diesem Beispiel wird der Benutzername (aus dem Dialogfeld Optionen) in der dem aktiven Dokument angehängten Vorlage gespeichert.

ScreenUpdating = False
With ActiveDocument.AttachedTemplate.OpenAsDocument
    .Variables.Add Name:="UserName", Value:= Application.UserName
    .Close SaveChanges:=wdSaveChanges
End With


Add-Methode (Windows-Auflistung)

Öffnet in einem offenen Fenster ein weiteres Dokumentfenster für das gleiche Dokument.

Syntax

Ausdruck.Add(Window)

Ausdruck Erforderlich. Ein Ausdruck, der ein Windows-Objekt zurückgibt.

Window Variant optional. Das Window-Objekt, für das ein weiteres Fenster geöffnet werden soll. Wird dieses Argument ausgelassen, wird ein neues Fenster für das aktive Dokument geöffnet.

Anmerkungen

In der Fensterbeschriftung erscheint ein Doppelpunkt (:) und eine Zahl, wenn mehr als ein Fenster für das Dokument geöffnet sind.


Beispiel zur Add-Methode (Windows-Auflistung)

In diesem Beispiel wird ein neues Fenster für das im aktiven Fenster angezeigte Dokument geöffnet.

Windows.Add

In diesem Beispiel wird ein neues Fenster für MyDoc.doc geöffnet.

Windows.Add Window:=Documents("MyDoc.doc").Windows(1)


Beispiel zur Apply-Methode

In diesem Beispiel wird ein AutoKorrektur-Ersetzungseintrag erzeugt und dann der AutoKorrektur-Eintrag "sr" dem gewählten Text zugewiesen.

AutoCorrect.Entries.Add Name:= "sr", Value:= "Stella Richards"
AutoCorrect.Entries("sr").Apply Selection.Range

In diesem Beispiel wird der AutoKorrektur-Eintrag "sr" dem ersten Wort im aktiven Dokument zugewiesen.

AutoCorrect.Entries("sr").Apply ActiveDocument.Words(1)

In diesem Beispiel wird die Formatierung der Form 1 im aktiven Dokument kopiert und dann die Formatierung der Form 2 im selben Dokument zugewiesen.

With ActiveDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


Beispiel zur AutoFit-Methode

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt und dann die Breite der ersten Spalte geändert, um sie der Breite des Textes anzupassen.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=3)
With myTable
    .Cell(1,1).Range.InsertAfter "First cell"
    .Columns(1).AutoFit
End With

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt und anschließend die Breite aller Spalten geändert, um sie der Breite des Textes anzupassen.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
With myTable
    .Cell(1,1).Range.InsertAfter "First cell"
    .Cell(1,2).Range.InsertAfter "This is cell (1,2)"
    .Cell(1,3).Range.InsertAfter "(1,3)"
    .Columns.AutoFit
End With


Beispiel zur AutoSum-Methode

In diesem Beispiel wird in einem neuen Dokument eine 3x3 Tabelle erstellt, und anschließend werden die Zahlen in der ersten Spalte summiert.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 3)
With MyTable
    .Cell(1,1).Range.InsertAfter "10"
    .Cell(2,1).Range.InsertAfter "15"
    .Cell(3,1).AutoSum
End With

In diesem Beispiel werden die Zahlen über oder links von der Zelle, die die Einfügemarke enthält, summiert.

Selection.Collapse Direction:=wdCollapseStart
If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).AutoSum
Else
    MsgBox "The insertion point is not in a table."
End If


Beispiel zur Check-Methode

In diesem Beispiel wird das aktive Dokument auf Seriendruckfehler hin überprüft.

theState = ActiveDocument.MailMerge.State
If theState = wdMainAndDataSource Or _
    theState = wdMainAndSourceAndHeader Then
    ActiveDocument.MailMerge.Check
End If


Beispiel zur ClearAll-Methode

In diesem Beispiel werden alle benutzerdefinierten Tabstops im aktiven Dokument gelöscht.

ActiveDocument.Paragraphs.TabStops.ClearAll

In diesem Beispiel werden alle benutzerdefinierten Tastenkombinationen in der Dokumentvorlage Normal gelöscht. Die Tastenkombinationen werden auf ihre Standardeinstellungen zurückgesetzt.

CustomizationContext = NormalTemplate
KeyBindings.ClearAll

In diesem Beispiel werden alle Benutzerwörterbücher aus dem Speicher entfernt.

CustomDictionaries.ClearAll


Beispiel zur Clear-Methode

In diesem Beispiel wird der erste benutzerdefinierte Tabstopp im ersten Absatz des aktiven Dokuments gelöscht.

ActiveDocument.Paragraphs(1).TabStops(1).Clear

In diesem Beispiel wird das Dokument als Formular geschützt und der Text vom ersten Formularfeld wird gelöscht, wenn es sich um ein Textformularfeld handelt.

ActiveDocument.Protect Type:=wdAllowOnlyFormFields, NoReset:=True
If ActiveDocument.FormFields(1).Type = wdFieldFormTextInput Then
    ActiveDocument.FormFields(1).TextInput.Clear
End If

In diesem Beispiel werden alle Elemente aus dem Formularfeld "Colors" im Sales.doc gelöscht.

Documents("Sales.doc").FormFields("Colors") _
    .DropDown.ListEntries.Clear

In diesem Beispiel wird die Formatierung eines Initials vom ersten Buchstaben im aktiven Dokument gelöscht.

Set drop = ActiveDocument.Paragraphs(1).DropCap
If Not (drop Is Nothing) Then drop.Clear

In diesem Beispiel wird die Tastenbelegung ALT+F1 aus der Vorlage "Normal" gelöscht.

CustomizationContext = NormalTemplate
FindKey(BuildKeyCode(Arg1:=wdKeyAlt, Arg2:=wdKeyF1)).Clear


Beispiel zur Close-Methode

In diesem Beispiel wird das aktive Fenster des aktiven Dokuments geschlossen und gespeichert.

ActiveDocument.ActiveWindow.Close SaveChanges:=wdSaveChanges

In diesem Beispiel wird der Benutzer aufgefordert, das aktive Dokument zu speichern, bevor es geschlossen wird. Wenn der Benutzer auf Abbrechen klickt, wird der Fehler 4198 (Befehl misslungen) abgefangen und eine Meldung angezeigt.

On Error GoTo errorHandler
ActiveDocument.Close _
    SaveChanges:=wdPromptToSaveChanges, _
    OriginalFormat:=wdPromptUser
errorHandler:
If Err = 4198 Then MsgBox "Document was not closed"

In diesem Beispiel wird Microsoft Excel aktiviert und anschließend geschlossen.

For Each myTask In Tasks
    If InStr(myTask.Name, "Microsoft Excel") > 0 Then
        myTask.Activate
        myTask.Close
    End If
Next myTask

In diesem Beispiel wird der aktive Ausschnitt geschlossen, wenn das aktive Fenster geteilt ist.

If ActiveDocument.ActiveWindow.Panes.Count >= 2 Then _
    ActiveDocument.ActiveWindow.ActivePane.Close


Beispiel zur Collapse-Methode

In diesem Beispiel wird die Markierung zu einer Einfügemarke am Anfang der vorherigen Markierung reduziert.

Selection.Collapse Direction:=wdCollapseStart

In diesem Beispiel wird myRange gleichgesetzt mit dem Inhalt des aktiven Dokuments, und myRange wird reduziert. Dann wird eine 2x2 Tabelle am Ende des Dokuments eingefügt.

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wdCollapseEnd
ActiveDocument.Tables.Add Range:=myRange, NumRows:=2, NumColumns:=2


Beispiel zur ConvertTo-Methode

In diesem Beispiel wird ein neues Dokument erstellt und dann ein eingebettetes Word-Dokument mit etwas Text eingefügt. Schließlich wird das eingebettete Dokument in eine Word-Grafik umgewandelt.

Documents.Add
Set myEmbedded = ActiveDocument.Shapes _
    .AddOLEObject(ClassType:= "Word.Document")
myEmbedded.Activate
Selection.TypeText "Test"
myEmbedded.OLEFormat.OLEFormat.ConvertTo _
    ClassType:="Word.Picture"


Beispiel zur Convert-Methode

In diesem Beispiel werden alle Endnoten im aktuellen Dokument in Fußnoten umgewandelt.

Set myEndnotes = ActiveDocument.Endnotes
If myEndnotes.Count > 0 Then myEndnotes.Convert

In diesem Beispiel werden alle Fußnoten in der aktuellen Markierung in Endnoten umgewandelt.

If Selection.Footnotes.Count > 0 Then Selection.Footnotes.Convert

In diesem Beispiel wird die erste Listenvorlage in das aktive Dokument umgewandelt. Besitzt die Listenvorlage mehrere Ebenen, werden diese auf eine Ebene reduziert oder umgekehrt.

ActiveDocument.ListTemplates(1).Convert


Beispiel zur Copy-Methode

In diesem Beispiel wird der Inhalt der Markierung in ein neues Dokument kopiert.

If Selection.Type = wdSelectionNormal Then
    Selection.Copy
    Documents.Add.Content.Paste
End If

In diesem Beispiel wird die Textmarke Book1 auf die Stelle festgelegt, die von der Textmarke Book2 markiert wurde.

ActiveDocument.Bookmarks("Book1").Copy Name:="Book2"

In diesem Beispiel wird im aktiven Dokument die Textmarke Selection auf die vordefinierte Textmarke \Sel festgelegt.

ActiveDocument.Bookmarks("\Sel").Copy Name:="Selection"

In diesem Beispiel wird der erste Absatz im aktiven Dokument kopiert und am Ende des Dokuments eingefügt.

ActiveDocument.Paragraphs(1).Range.Copy
Set myRange = ActiveDocument.Range _
    (Start:=ActiveDocument.Content.End - 1, _
    End:=ActiveDocument.Content.End - 1)
myRange.Paste

In diesem Beispiel werden die Kommentare im aktiven Dokument in die Zwischenablage kopiert.

If ActiveDocument.Comments.Count >= 1 Then
    ActiveDocument.StoryRanges(wdCommentsStory).Copy
End If


Beispiel zur DDETerminate-Methode

In diesem Beispiel wird in Microsoft Excel eine neue Arbeitsmappe angelegt und anschließend die DDE-Konversation beendet.

chan = DDEInitiate(App:="Excel", Topic:="System")
DDEExecute Channel:=chan, Command:="[New(1)]"
DDETerminate Channel:=chan


Beispiel zur Display-Methode

Dieses Beispiel zeigt das Dialogfeld Info an.

Set aDialog = Dialogs(wdDialogHelpAbout)
aDialog.Display

In diesem Beispiel wird das Dialogfeld Zoom etwa neun Sekunden lang angezeigt.

Dialogs(wdDialogViewZoom).Display TimeOut:=9000


Beispiel zur Distribute-Methode

In diesem Beispiel wird ein Formbereich mit allen AutoFormen im aktiven Dokument erstellt, und anschließend werden die Formen horizontal in diesem Bereich verteilt.

With ActiveDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numAutoShapes = 0
        ReDim autoShpArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoAutoShape Then
                numAutoShapes = numAutoShapes + 1
                autoShpArray(numAutoShapes) = .Item(i).Name
            End If
        Next
        If numAutoShapes > 1 Then
            ReDim Preserve autoShpArray(1 To numAutoShapes)
            Set asRange = .Range(autoShpArray)
            asRange.Distribute msoDistributeHorizontally, False
        End If
    End If
End With


Beispiel zur Edit-Methode

In diesem Beispiel wird im aktiven Dokument (zum Bearbeiten) das erste eingebettete OLE-Objekt (das als Form definiert wurde) geöffnet.

Set myS = ActiveDocument.Shapes
If myS.Count >= 1 Then
    If myS(1).Type = msoEmbeddedOLEObject Then
        myS(1).OLEFormat.Edit
    End If
End If

In diesem Beispiel wird im aktiven Dokument (zum Bearbeiten) das erste verknüpfte OLE-Objekt (das als Inline Shape definiert wurde) geöffnet.

Set myIS = ActiveDocument.InlineShapes
If myIS.Count >= 1 Then
    If myIS(1).Type = wdInlineShapeLinkedOLEObject Then
        myIS(1).OLEFormat.Edit
    End If
End If


Beispiel zur Expand-Methode

In diesem Beispiel wird ein Bereich erstellt, der sich auf das erste Wort im aktiven Dokument bezieht, und dann wird der Bereich erweitert, damit er sich auf den ersten Absatz im Dokument bezieht.

Set myRange = ActiveDocument.Words(1)
myRange.Expand Unit:=wdParagraph

In diesem Beispiel wird das erste Zeichen in der Markierung groß geschrieben und dann die Markierung erweitert, damit sie den ganzen Satz enthält.

With Selection
    .Characters(1).Case = wdTitleSentence
    .Expand Unit:=wdSentence
End With


Beispiel zur Follow-Methode

In diesem Beispiel wird dem ersten Hyperlink nach Home.doc gefolgt.

Documents("Home.doc").HyperLinks(1).Follow

In diesem Beispiel wird ein Hyperlink zu www.msn.com eingefügt und dann dem Hyperlink gefolgt.

With Selection
    .Collapse Direction:=wdCollapseEnd
    .InsertAfter "MSN "
    .Previous
End With
Set myLink = ActiveDocument.Hyperlinks.Add( _
    Address:="http://www.msn.com", _
    Anchor:=Selection.Range)
myLink.Follow NewWindow:=False, AddHistory:=True


Beispiel zur GoTo-Methode

In diesem Beispiel wird die Markierung zur ersten Zelle in der nächsten Tabelle verschoben.

Selection.GoTo What:=wdGoToTable, Which:=wdGoToNext

In diesem Beispiel wird im aktiven Dokument die Einfügemarke direkt vor das fünfte Endnoten-Verweiszeichen verschoben.

If ActiveDocument.Endnotes.Count >= 5 Then
    Selection.GoTo What:=wdGoToEndnote, _
        Which:=wdGoToAbsolute, Count:=5
End If

In diesem Beispiel wird im aktiven Dokument R1 dem ersten Fußnoten-Verweiszeichen gleichgesetzt.

If ActiveDocument.Footnotes.Count >= 1 Then
    Set R1 = ActiveDocument.GoTo(What:=wdGoToFootnote, _
        Which:=wdGoToFirst)
    R1.Expand Unit:=wdCharacter
End If

In diesem Beispiel wird die Markierung um vier Zeilen nach unten verschoben.

Selection.GoTo What:=wdGoToLine, Which:=wdGoToRelative, Count:=4

In diesem Beispiel wird die Markierung zwei Seiten zurück verschoben.

Selection.GoTo What:=wdGoToPage, Which:=wdGoToPrevious, Count:=2


Beispiel zur Help-Methode

In diesem Beispiel wird das Dialogfeld Hilfethemen angezeigt.

Help HelpType:=wdHelp

In diesem Beispiel wird eine Liste der Hilfethemen mit einer Beschreibung zur Verwendung von Hilfe angezeigt.

Help HelpType:=wdHelpUsingHelp


Beispiel zur IncrementRotationX-Methode

In diesem Beispiel wird Form eins in myDocument um 10 Grad nach oben geneigt. Form eins muss eine verdrängte Form sein, damit Sie die Wirkung dieses Codefragments sehen können.

Set myDocument = ActiveDocument
myDocument.Shapes(1).ThreeD.IncrementRotationX 10


Beispiel zur Indent-Methode

In diesem Beispiel werden alle Absätze im aktiven Dokument zweimal eingerückt und dann bei dem ersten Absatz eine Einzugsebene entfernt.

With ActiveDocument.Paragraphs
    .Indent
    .Indent
End With
ActiveDocument.Paragraphs(1).Outdent


Beispiel zur InsertColumns-Methode

In diesem Beispiel werden neue Spalten links neben der Spalte mit der Auswahl eingefügt. Die Anzahl der eingefügten Spalten entspricht der Anzahl der markierten Spalten.

If Selection.Information(wdWithInTable) = True Then
    With Selection
        .InsertColumns
        .Shading.Texture = wdTexture10Percent
    End With
End If


Beispiel zur InsertParagraph-Methode

In diesem Beispiel wird am Anfang des aktiven Dokuments ein neuer Absatz eingefügt.

Set myRange = ActiveDocument.Range(0, 0)
With myRange
    .InsertParagraph
    .InsertBefore "Dear Sirs,"
End With

In diesem Beispiel wird die Markierung reduziert und dann an der Einfügemarke eine Absatzmarke eingefügt.

With Selection
    .Collapse Direction:=wdCollapseStart
    .InsertParagraph
    .Collapse Direction:=wdCollapseEnd
End With


Beispiel zur InsertRows-Methode

In diesem Beispiel werden zwei neue Zeilen oberhalb der ersten Zeile der Auswahl eingefügt, und dann werden die Rahmen um die neuen Zeilen entfernt.

If Selection.Information(wdWithInTable) = True Then
    Selection.InsertRows NumRows:=2
    Selection.Borders.Enable =False
End If


Beispiel zur Insert-Methode

In diesem Beispiel wird der formatierte AutoText-Eintrag "one" nach der Markierung eingefügt.

Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.AttachedTemplate.AutoTextEntries("one").Insert _
    Where:=Selection.Range, RichText:=True

In diesem Beispiel wird dem aktiven Dokument ein Umschlag der Größe 10 hinzugefügt. Es werden dabei die Adressen verwendet, die in den Variablen tAddr und fAddr gespeichert sind.

rtn = VbCr
tAddr = "Max Benson" & rtn & "123 Skye St." _
    & rtn & "OurTown, WA 98107"
fAddr = "Paul Borm" & rtn & "456 Erde Lane" _
    & rtn & "OurTown, WA 98107"
ActiveDocument.Envelope.Insert Address:=fAddr, _
    ReturnAddress:=tAddr, Size:="Size 10"


Beispiel zur Keyboard-Methode

In diesem Beispiel wird die Einstellung für Sprache und Layout der Tastatur einer Variable zugewiesen

temp = Application.Keyboard


Beispiel zur Key-Methode

In diesem Beispiel wird der Tastenkombination ALT+F4 die Schriftart Arial zugewiesen und dann die Anzahl der Elemente in der KeyBindings-Auflistung angezeigt. Daraufhin werden die Tastenkombinationen gelöscht (und auf ihre Standardeinstellungen zurückgesetzt), und die Anzahl der Elemente in der KeyBindings-Auflistung wird erneut angezeigt.

CustomizationContext = NormalTemplate
KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyAlt, wdKeyF4), _
    KeyCategory:=wdKeyCategoryFont, Command:="Arial"
MsgBox KeyBindings.Count & " keys in KeyBindings collection"
KeyBindings.Key(KeyCode:=BuildKeyCode(wdKeyAlt, wdKeyF4)).Clear
MsgBox KeyBindings.Count & " keys in KeyBindings collection"

In diesem Beispiel wird der Tastenkombination STRG+UMSCHALT+U das Makro "Macro1" im aktiven Dokument zugewiesen. Dann wird mit der Key-Eigenschaft ein KeyBinding-Objekt zurückgegeben, damit Word den Befehlsnamen laden und anzeigen kann.

CustomizationContext = ActiveDocument
KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyControl, _
    wdKeyShift, wdKeyU), KeyCategory:=wdKeyCategoryMacro, _
    Command:="Macro1"
MsgBox KeyBindings.Key(BuildKeyCode(wdKeyControl, _
    wdKeyShift, wdKeyU)).Command

In diesem Beispiel wird ermittelt, ob die Tastenkombination STRG+UMSCHALT+A Teil der KeyBindings-Auflistung ist.

CustomizationContext = NormalTemplate
Set myKey = KeyBindings.Key(BuildKeyCode(wdKeyControl, _
    wdKeyShift,wdKeyA))
If (myKey Is Nothing) Then MsgBox _
    "Key is not in the KeyBindings collection"


Beispiel zur MoveEnd-Methode

In diesem Beispiel wird das Ende der Markierung um ein Zeichen rückwärts verschoben (die Markierungsgröße wird um ein Zeichen reduziert). Ein Leerzeichen wird als Zeichen angesehen.

Selection.MoveEnd Unit:=wdCharacter, Count:=-1

In diesem Beispiel wird das Ende der Markierung zum Zeilenende verschoben (die Markierung wird bis zum Zeilenende erweitert).

Selection.MoveEnd Unit:=wdLine, Count:=1

In diesem Beispiel wird myRange dem zweiten Wort im aktiven Dokument gleichgesetzt. Die MoveEnd-Methode wird verwendet, um die Endposition von myRange (ein Range-Objekt) ein Wort vorwärts zu verschieben. Nachdem dieses Makro ausgeführt wurde, sind das zweite und dritte Wort im Dokument markiert.

If ActiveDocument.Words.Count >= 3 Then
    Set myRange = ActiveDocument.Words(2)
    With myRange
        .MoveEnd Unit:=wdWord, Count:=1
        .Select
    End With
End If


Beispiel zur MoveStart-Methode

In diesem Beispiel wird die Startposition der Markierung ein Zeichen vorwärts bewegt (die Größe der Markierung wird um ein Zeichen verkleinert). Beachten Sie, dass ein Leerzeichen als Zeichen angesehen wird.

Selection.MoveStart Unit:=wdCharacter, Count:=1

In diesem Beispiel wird die Startposition der Markierung zum Anfang der Zeile verschoben (die Markierung wird bis zum Anfang der Zeile erweitert).

Selection.MoveStart Unit:=wdLine, Count:=-1

In diesem Beispiel wird myRange dem zweiten Wort im aktiven Dokument gleichgesetzt. Das Beispiel verwendet die MoveStart-Methode zum Verschieben der Startposition von myRange (einem Range-Objekt) um ein Wort rückwärts. Nach Ausführung dieses Makros sind das erste und zweite Wort im Dokument markiert.

If ActiveDocument.Words.Count >= 2 Then
    Set myRange = ActiveDocument.Words(2)
    With myRange
        .MoveStart Unit:=wdWord, Count:=-1
        .Select
    End With
End If


Beispiel zur Move-Methode

In diesem Beispiel wird die Markierung um zwei Wörter nach rechts verschoben und die Einfügemarke hinter dem anschließenden Leerzeichen des zweiten Worts positioniert. Wenn die Verschiebung erfolglos ist, zeigt ein Meldungsfeld an, dass die Markierung sich am Ende des Dokuments befindet.

If Selection.StoryType = wdMainTextStory Then
    wUnits = Selection.Move(Unit:=wdWord, Count:=2)
    If wUnits < 2 Then _
        MsgBox "Selection is at the end of the document"
End If

In diesem Beispiel wird Range1 dem ersten Absatz im aktiven Dokument gleichgesetzt und dann der Bereich um drei Absätze vorwärts verschoben. Nach Ausführung dieses Makros ist die Einfügemarke am Anfang des vierten Absatzes positioniert.

Set Range1 = ActiveDocument.Paragraphs(1).Range
With Range1
    .Collapse Direction:=wdCollapseStart
    .Move Unit:=wdParagraph, Count:=3
    .Select
End With

In diesem Beispiel wird die Markierung in der Tabelle um drei Zellen vorwärts verschoben.

If Selection.Information(wdWithInTable) = True Then
    Selection.Move Unit:=wdCell, Count:=3
End If

In diesem Beispiel wird die Rechneranwendung (Calc.exe) gestartet und mit der Move-Methode das Anwendungsfenster neu positioniert.

Shell "Calc.exe"
With Tasks("Calculator")
    .WindowState = wdWindowStateNormal
    .Move Top:=50, Left:=50
End With


Beispiel zur New-Methode

In diesem Beispiel wird im aktiven Dokument eine neue, leere Grafik eingefügt und ein schattierter Rahmen um die Grafik gezeichnet.

Set myPic = ActiveDocument.InlineShapes.New(Range:=Selection.Range)
myPic.Borders.Shadow = True
ActiveDocument.ActiveWindow.View.ShowFieldCodes = False


Beispiel zur Next-Methode

In diesem Beispiel wird die Einfügemarke direkt vor das nächste Kommentarzeichen im aktiven Dokument verschoben.

With Application.Browser
    .Target = wdBrowseComment
    .Next
End With

In diesem Beispiel werden die ersten neun Absätze im aktiven Dokument mit einer Nummer und einem Tabulator versehen.

For n = 0 To 8
    Set myRange = ActiveDocument.Paragraphs(1).Next(Count:=n).Range
    myRange.Collapse Direction:=wdCollapseStart
    myRange.InsertAfter n + 1 & vbTab
Next n

In diesem Beispiel wird der Absatz nach der aktuellen Auswahl gewählt.

Selection.Next(Unit:=wdParagraph, Count:=1).Select


Beispiel zur Open-Methode

In diesem Beispiel wird MyDoc.doc als schreibgeschütztes Dokument geöffnet.

Documents.Open FileName:="C:\MyFiles\MyDoc.doc", ReadOnly:=True

In diesem Beispiel wird jedes Dokument in der RecentFiles-Auflistung geöffnet.

Dim rFile As RecentFile
For Each rFile In RecentFiles
    rFile.Open
Next rFile

In diesem Beispiel wird die zuletzt verwendete Version von Report.doc geöffnet.

Set myDoc = Documents("Report.doc")
myDoc.Versions(myDoc.Versions.Count).Open

In diesem Beispiel wird Test.wp mit Hilfe des WordPerfect 6.x-Dateikonvertierungsprogramms geöffnet.

num = FileConverters("WordPerfect6x").OpenFormat
Documents.Open FileName:="C:\Test.wp", Format:=num


Beispiel zur OutlineDemote-Methode

In diesem Beispiel werden die markierten Absätze tiefergestuft.

Selection.Paragraphs.OutlineDemote

In diesem Beispiel wird der dritte Absatz im aktiven Dokument tiefergestuft.

ActiveDocument.Paragraphs(3).OutlineDemote


Beispiel zur Paste-Methode

In diesem Beispiel wird die erste Tabelle im aktiven Dokument kopiert und in ein neues Dokument eingefügt.

If ActiveDocument.Tables.Count >= 1 Then
    ActiveDocument.Tables(1).Range.Copy
    Documents.Add.Content.Paste
End If

In diesem Beispiel wird der erste Absatz im Dokument kopiert und an der Einfügemarke eingefügt.

ActiveDocument.Paragraphs(1).Range.Copy
Selection.Collapse Direction:=wdCollapseStart
Selection.Paste

In diesem Beispiel wird die Markierung kopiert und am Ende des Dokuments eingefügt.

If Selection.Type <> wdSelectionIP Then
    Selection.Copy
    Set Range2 = ActiveDocument.Content
    Range2.Collapse Direction:=wdCollapseEnd
    Range2.Paste
End If


Beispiel zur Previous-Methode

In diesem Beispiel wird die Einfügemarke in die erste Zelle (die Zelle in der oberen linken Ecke) der vorherigen Tabelle verschoben.

With Application.Browser
    .Target = wdBrowseTable
    .Previous
End With

In diesem Beispiel wird der Absatz vor der Auswahl im aktiven Dokument gewählt.

Selection.Previous(Unit:=wdParagraph, Count:=1).Select

In diesem Beispiel wird die Formatierung "Bold" dem ersten Wort im aktiven Dokument zugewiesen.

ActiveDocument.Words(2) _
    .Previous(Unit:=wdWord, Count:=1).Bold = True


Beispiel zur Range-Methode

In diesem Beispiel wird den ersten zehn Zeichen im aktiven Dokument Fettformatierung zugewiesen.

ActiveDocument.Range(Start:=0, End:=10).Bold = True

In diesem Beispiel wird ein Bereich erstellt, der am Anfang des aktiven Dokuments beginnt und am Ende der Markierung endet.

Set myRange = ActiveDocument.Range(Start:=0, End:=Selection.End)

In diesem Beispiel werden der Variablen myRange die Absätze drei bis sechs im aktiven Dokument zugewiesen und anschließend die Absätze im Bereich rechts ausgerichtet.

Set aDoc = ActiveDocument
If aDoc.Paragraphs.Count >= 6 Then
    Set myRange = aDoc.Range(aDoc.Paragraphs(3).Range.Start, _
        aDoc.Paragraphs(6).Range.End)
    myRange.Paragraphs.Alignment = wdAlignParagraphRight
End If

In diesem Beispiel wird für die erste Form im aktiven Dokument die Vordergrundfarbe der Füllung auf Purpur festgelegt.

ActiveDocument.Shapes.Range(1).Fill _
    .ForeColor.RGB = RGB(255, 0, 255)

In diesem Beispiel wird im aktiven Dokument der Form "myshape" ein Schatten zugewiesen.

ActiveDocument.Shapes.Range("myshape").Shadow.Type = msoShadow6

In diesem Beispiel werden die Formen eins und drei im aktiven Dokument ausgewählt.

ActiveDocument.Shapes.Range(Array(1, 3)).Select


Beispiel zur RejectAll-Methode

In diesem Beispiel werden alle Überarbeitungen im aktiven Dokument abgelehnt.

ActiveDocument.Revisions.RejectAll

In diesem Beispiel werden alle Überarbeitungen in der Markierung abgelehnt.

Set myRange = Selection.Range
myRange.Revisions.RejectAll


Beispiel zur Reject-Methode

In diesem Beispiel wird die nächste Überarbeitung, die im aktiven Dokument gefunden wird, abgelehnt.

If ActiveDocument.Revisions.Count >= 1 Then
    Set myRev = Selection.NextRevision
    If Not (myrev Is Nothing) Then myrev.Reject
End If

In diesem Beispiel werden die Überarbeitungen im ersten Absatz abgelehnt.

Set myRange = ActiveDocument.Paragraphs(1).Range
For Each myRev In myRange.Revisions
    myRev.Reject
Next myRev

In diesem Beispiel wird die erste Überarbeitung in der Markierung abgelehnt.

Set myRange = Selection.Range
If myRange.Revisions.Count >= 1 Then myRange.Revisions(1).Reject


Beispiel zur Reload-Methode

In diesem Beispiel wird der Hyperlink zur Adresse main im lokalen Intranet geöffnet und erneut geladen.

With ActiveDocument
    .FollowHyperlink Address:="http://main"
    .Reload
End With


Beispiel zur Reply-Methode

In diesem Beispiel wird eine neue E-Mail-Nachricht zum Beantworten der aktiven Nachricht geöffnet.

Application.MailMessage.Reply


Beispiel zur Reset-Methode

In diesem Beispiel wird manuelle Formatierung von der Markierung entfernt.

Selection.Font.Reset

In diesem Beispiel wird im aktiven Dokument manuelle Absatzformatierung vom zweiten Absatz entfernt.

ActiveDocument.Paragraphs(2).Reset

In diesem Beispiel wird das aktive Dokument vorbereitet, damit es wieder zu denselben Empfängern weitergeleitet werden kann, wie in den vorherigen Weiterleitungseinstellungen.

If ActiveDocument.HasRoutingSlip = True Then
    ActiveDocument.RoutingSlip.Reset
End If

In diesem Beispiel wird eine Grafik als eingebettete Figur eingefügt, die Helligkeit geändert und dann die Grafik auf ihre ursprüngliche Helligkeit zurückgesetzt.

Set aInLine = ActiveDocument.InlineShapes.AddPicture _
    (FileName:="C:\Windows\Bubbles.bmp", Range:=Selection.Range)
aInLine.PictureFormat.Brightness = 0.5
MsgBox "Changing brightness back"
aInLine.Reset

In diesem Beispiel wird das vierte Format, das auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungen aufgelistet ist, auf das integrierte Nummerierungsformat zurückgesetzt, und dann wird die Listenvorlage der Markierung zugewiesen.

ListGalleries(wdNumberGallery).Reset(4)
Selection.Range.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(2).ListTemplates(4)

In diesem Beispiel werden alle Listenvorlagen im Dialogfeld Nummerierung und Aufzählungen auf die integrierten Formate zurückgesetzt.

For Each lg In ListGalleries
    For i = 1 to 7
        lg.Reset Index:=i
    Next i
Next lg


Beispiel zur Run-Methode

In diesem Beispiel wird der Benutzer aufgefordert, die Namen einer Dokumentvorlage, eines Moduls, eines Makros und eines Parameterwertes einzugeben. Anschließend wird das Makro ausgeführt.

t = InputBox("Enter the template name")
md = InputBox("Enter the module name")
m = InputBox("Enter the macro name")
p = InputBox("Enter a parameter value")
Application.Run MacroName:=t & "." & md & "." & m, _
    varg1:=p


Beispiel für die Save-Methode

In diesem Beispiel wird das aktive Dokument gespeichert, wenn es seit dem letzten Speichern verändert wurde.

If ActiveDocument.Saved = False Then ActiveDocument.Save

In diesem Beispiel werden die Dokumente in der Documents-Auflistung gespeichert, ohne dies vom Benutzer bestätigen zu lassen.

Documents.Save NoPrompt:=True, _
    OriginalFormat:=wdOriginalDocumentFormat

Wenn Sales.doc geöffnet ist, wird in diesem Beispiel eine Version von Sales.doc mit einem Kommentar gespeichert.

For Each doc in Documents
    If Instr(1, doc.Name, "Sales.doc", 1) > 0 Then
        doc.Versions.Save Comment:="Minor changes to intro"
    End If
Next doc


Beispiel zur Select-Methode

In diesem Beispiel wird der erste Abschnitt im aktiven Dokument ausgewählt.

ActiveDocument.Paragraphs(1).Range.Select

In diesem Beisepiel wird Rows 1 in Tables 1 in Report.doc markiert.

Documents("Report.doc").Tables(1).Rows(1).Select

In diesem Beispiel wird das erste Feld im aktiven Dokument aktualisiert und markiert.

ActiveDocument.ActiveWindow.View.FieldShading = _
    wdFieldShadingWhenSelected
If ActiveDocument.Fields.Count >= 1 Then
    With ActiveDocument.Fields(1)
       .Update
       .Select
    End With
End If


Beispiel zur Show-Methode

In diesem Beispiel wird das Dialogfeld Suchen und Ersetzen angezeigt, wobei das Textfeld Suchen nach das Wort "Blue" enthält.

With  Dialogs(wdDialogEditFind)
    .Find = "Blue"
    .Show
End With

In diesem Beispiel werden alle Vorgänge angezeigt und ausgeführt, die im Dialogfeld Öffnen gestartet wurden. Für den Dateinamen wurde *.* angegeben, damit alle Dateinamen angezeigt werden.

With Dialogs(wdDialogFileOpen)
    .Name = "*.*"
    .Show
End With

In diesem Beispiel werden alle Vorgänge angezeigt und ausgeführt, die im Dialogfeld Zoom gestartet wurden. Wenn etwa 9 Sekunden lang keine Vorgänge gestartet werden, wird das Dialogfeld geschlossen.

Dialogs(wdDialogViewZoom).Show TimeOut:=9000


Beispiel zur Sort-Methode

In diesem Beispiel wird in einem neuen Dokument eine 5x5 Tabelle erstellt, Text in jede Zelle eingefügt und dann die Tabelle in absteigender alphanumerischer Reihenfolge sortiert.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 5, 5)
For iRow = 1 To myTable.Rows.Count
    For iCol = 1 To myTable.Columns.Count
        Set myRange= myTable.Rows(iRow).Cells(iCol).Range
        myRange.InsertAfter "Cell (" & Str$(iRow) _
            & "," & Str$(iCol) & ")"
    Next iCol
Next iRow
MsgBox "Click OK to sort in descending order."
myTable.Sort SortOrder:=wdSortOrderDescending

In diesem Beispiel werden drei Textzeilen in ein neues Dokument eingefügt und dann die Zeilen in aufsteigender alphanumerischer Reihenfolge sortiert.

Set newDoc = Documents.Add
newDoc.Content.InsertAfter "pear" & Chr(13) _
    & "zucchini" & Chr(13) _
    & "apple" & Chr(13)
newDoc.Content.Sort SortOrder:=wdSortOrderAscending


Beispiel zur Split-Methode

In diesem Beispiel wird im aktiven Dokument eine 5x5-Tabelle erstellt und vor der dritten Zeile aufgeteilt. Den Zellen in der resultierenden Tabelle (der neuen 3x5-Tabelle) wird Schattierung zugewiesen.

Set newDoc = Documents.Add
Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumColumns:=5, NumRows:=5)
myTable.Split(BeforeRow:=myTable.Rows(3)).Shading _
    .Texture = wdTexture10Percent

In diesem Beispiel wird in der ersten Tabelle die erste Zelle in zwei Zellen aufgeteilt.

ActiveDocument.Tables(1).Cell(1, 1).Split NumColumns:=2

In diesem Beispiel werden die markierten Zellen in einer einzigen Zelle zusammengefasst und dann die Zelle in drei Zellen in derselben Zeile aufgeteilt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells.Split NumRows:=1, NumColumns:=3, _
        MergeBeforeSplit:= True
End If

In diesem Beispiel wird die Markierung in einem vorhandenen Filialdokument zu einem separaten Filialdokument.

Selection.Range.Subdocuments(1).Split Range:=Selection.Range


Beispiel für die Undo-Methode

In diesem Beispiel werden die letzten beiden Aktionen rückgängig gemacht, die in "Sales.doc" durchgeführt wurden.

Documents("Sales.doc").Undo 2

In diesem Beispiel wird die letzte Aktion rückgängig gemacht. Wenn die Aktion erfolgreich rückgängig gemacht wurde, wird in der Statusleiste eine Meldung angezeigt.

On Error Resume Next
If ActiveDocument.Undo = False Then _
    StatusBar = "Undo was unsuccessful"


Beispiel zur Update-Methode

In diesem Beispiel werden alle Felder im aktiven Dokument aktualisiert. Ein Rückgabewert von 0 (Null) bedeutet, dass die Felder ohne Fehler aktualisiert wurden.

If ActiveDocument.Fields.Update = 0 Then
    MsgBox "Update Successful"
Else
    MsgBox "Field " & ActiveDocument.Fields.Update & _
        " has an error"
End If

In diesem Beispiel wird das erste Abbildungsverzeichnis im aktiven Dokument aktualisiert.

If ActiveDocument.TablesOfFigures.Count >= 1 Then
    ActiveDocument.TableOfFigures(1).Update
End If

In diesem Beispiel wird das erste Feld im aktiven Dokument aktualisiert. Anschließend erscheint in der Statusleiste eine Meldung, ob die Aktualisierung des Feldes erfolgreich war.

If ActiveDocument.Fields(1).Update = True Then
    StatusBar = "Field updated"
Else
    StatusBar = "Error, field not updated"
End If

In diesem Beispiel wird ein Dialog-Objekt zurückgegeben, das sich auf das Dialogfeld Zeichen bezieht. Die Schriftart wird anschließend dem Selection-Objekt zugewiesen und auf Arial geändert, die Werte des Dialogfelds werden aktualisiert und das Dialogfeld Zeichen wird angezeigt.

Set myDialog = Dialogs(wdDialogFormatFont)
Selection.Font.Name = "Arial"
myDialog.Update
myDialog.Show

In diesem Beispiel werden alle Felder im aktiven Dokument aktualisiert, die nicht automatisch aktualisiert werden.

For Each afield In ActiveDocument.Fields
    If afield.LinkFormat.AutoUpdate = False _
        Then afield.LinkFormat.Update
Next afield


Beispiel zur Accent-Eigenschaft

In diesem Beispiel werden zu myDocument ein Oval und eine Legende, die auf das Oval zeigt, hinzugefügt. Der Legendentext wird keinen Rahmen haben, aber eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


Beispiel zur ActiveTheme-Eigenschaft

In diesem Beispiel werden der Name des aktiven Designs und die Formatierungsoptionen des Designs für das aktuelle Dokument angezeigt.

MsgBox ActiveDocument.ActiveTheme


Beispiel zur Active-Eigenschaft

In diesem Beispiel wird das erste Fenster in der Windows-Sammlung aktiviert, wenn das Fenster zur Zeit nicht aktiv ist.

If Windows(1).Active = False Then Windows(1).Activate

In diesem Beispiel wird die Zeilennummerierung für den ersten Absatz in der Markierung aktiviert.

With Selection.Sections(1).PageSetup.LineNumbering
    .Active = True
    .CountBy = 5
    .StartingNumber = 1
End With

In diesem Beispiel wird das aktive Fenster in zwei Fensterausschnitte aufgeteilt und die Sammlung im ersten Fensterausschnitt aktiviert, wenn diese nicht schon bereits aktiviert ist.

ActiveDocument.ActiveWindow.Split = True
If ActiveDocument.ActiveWindow.Panes(1).Selection _
        .Active = False Then
    ActiveDocument.ActiveWindow.Panes(1).Activate
End If


Beispiel zur Address-Eigenschaft

In diesem Beispiel wird im aktiven Dokument der Markierung ein Hyperlink hinzugefügt, die Adresse festgelegt und dann die Adresse in einem Meldungsfeld angezeigt.

Set aHLink = ActiveDocument.Hyperlinks.Add( _
    Anchor:=Selection.Range, _
    Address:="http://forms")
MsgBox "The hyperlink goes to " & aHLink.Address

Wenn in diesem Beispiel das aktive Dokument Hyperlinks enthält, wird am Ende des Dokuments eine Liste der Hyperlink-Ziele eingefügt.

Set myRange = ActiveDocument _
    .Range(Start:=ActiveDocument.Content.End - 1)
Count = 0
For Each aHyperlink In ActiveDocument.Hyperlinks
    Count = Count + 1
    With myRange
        .InsertAfter "Hyperlink #" & Count & vbTab
        .InsertAfter aHyperlink.Address
        .InsertParagraphAfter
    End With
Next aHyperlink

In diesem Beispiel wird die Empfängeradresse angezeigt, wenn dem Dokument ein Briefumschlag hinzugefügt wurde; andernfalls wird eine Meldung angezeigt.

On Error GoTo errhandler
addr = ActiveDocument.Envelope.Address.Text
MsgBox Prompt:=addr, Title:="Delivery Address"
errhandler:
If Err = 5852 Then MsgBox "Insert an envelope into the document"


Beispiel zur BackgroundPatternColor-Eigenschaft

In diesem Beispiel wird dem ersten Absatz des aktiven Dokuments eine türkisfarbene Hintergrundschattierung zugewiesen.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.Shading.BackgroundPatternColor = _
    wdColorTurquoise

In diesem Beispiel wird an der Einfügemarke eine Tabelle eingefügt und dann der ersten Zelle eine hellgraue Hintergrundschattierung zugewiesen.

Selection.Collapse Direction:=wdCollapseStart
Set myTable = _
    ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=2, NumColumns:=2)
myTable.Cell(1, 1).Shading.BackgroundPatternColor = _
    wdColorGray25


Beispiel zur Background-Eigenschaft

In diesem Beispiel wird die Hintergrundfarbe für die Weblayoutansicht des aktiven Fensters auf Hellgrau gesetzt.

ActiveDocument.ActiveWindow.View.Type = wdWebView
With ActiveDocument.Background.Fill
    .Visible = True
    .ForeColor.RGB = RGB(192, 192, 192)
End With

In diesem Beispiel wird als Hintergrundbild für die Weblayoutansicht die Bitmap Bubbles.bmp eingestellt.

ActiveDocument.ActiveWindow.View.Type = wdWebView
ActiveDocument.Background.Fill.UserPicture _
    PictureFile:="C:\Windows\Bubbles.bmp"


Beispiel zur Bold-Eigenschaft

In diesem Beispiel wird das sechste Wort in einem neuen Dokument fett formatiert.

Set newDoc = Documents.Add
Set myRange = newDoc.Content
myRange.InsertAfter "This is a test of bold."
myRange.Words(6).Bold = True

In diesem Beispiel wird die gesamte Auswahl fett formatiert, wenn ein Teil der Auswahl bereits fett formatiert ist.

If Selection.Type = wdSelectionNormal Then
    If Selection.Font.Bold = wdUndefined Then _
        Selection.Font.Bold = True
Else
    MsgBox "You need to select some text."
End If

In diesem Beispiel wird für den gewählten Text auf fette Formatierung umgeschaltet.

If Selection.Type = wdSelectionNormal Then
    Selection.Range.Bold = wdToggle
End If

In diesem Beispiel wird die Schriftart im ersten Absatz im aktiven Dokument fett formatiert.

ActiveDocument.Paragraphs(1).Range.Bold = True


Beispiel zur Bookmark-Eigenschaft

Wenn im aktuellen Dokument ein Rechtsgrundlagenverzeichnis vorhanden ist, werden die Einträge aus dem Bereich zusammengestellt, der durch die Textmarke mit dem Namen "area" festgelegt wird.

If ActiveDocument.TablesOfAuthorities.Count >= 1 Then
    ActiveDocument.TablesOfAuthorities(1).Bookmark = "area"
End If


Beispiel zur Border-Eigenschaft

In diesem Beispiel werden zu myDocument ein Oval hinzugefügt und eine Legende, die zum Oval zeigt. Der Legendentext wird keinen Rahmen haben, aber eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = ActiveDocument
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.TextRange.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


Beispiel zur Browser-Eigenschaft

In diesem Beispiel findet ein Wechsel zum nächsten Fußnotenzeichen im aktiven Dokument statt.

With Application.Browser
    .Target = wdBrowseFootnote
    .Next
End With

In diesem Beispiel findet ein Wechsel zum nächsten Feld im aktiven Dokument statt. Der Text wird, ausgehend von der ursprünglichen Auswahl bis zum nächsten Feld, fett formatiert.

Selection.ExtendMode = True
With Application.Browser
    .Target = wdBrowseField
    .Next
End With
With Selection
    .Font.Bold = True
    .ExtendMode = False
    .Collapse Direction:=wdCollapseEnd
End With


Beispiel zur BuiltIn-Eigenschaft

In diesem Beispiel werden alle Formatvorlagen im aktiven Dokument geprüft. Wenn eine Formatvorlage gefunden wird, die nicht integriert ist, wird der Name der Formatvorlage angezeigt.

For Each sty in ActiveDocument.Styles
    If sty.BuiltIn = False Then
        Msgbox sty.NameLocal
    End If
Next

In diesem Beispiel werden alle Beschriftungskategorien geprüft, die in der Anwendung erstellt wurden. Wenn eine Beschriftungskategorie gefunden wird, die nicht integriert ist, wird der Name der Kategorie angezeigt.

For Each lb in CaptionLabels
    If lb.BuiltIn = False Then
        Msgbox lb.Name
    End If
Next


Beispiel zur CaptionLabel-Eigenschaft

In diesem Beispiel werden der Name (z. B. "Microsoft Excel-Tabelle") und die Beschriftungskategorie (beispielsweise "Abbildung") für jedes Element angezeigt, dem beim Einfügen automatisch eine Beschriftung hinzugefügt wird.

For Each myCaption In AutoCaptions
    If myCaption.AutoInsert = True Then MsgBox myCaption.Name _
        & vbCr & "Label = " & myCaption.CaptionLabel.Name
Next myCaption

In diesem Beispiel wird die Beschriftungskategorie für Word-Tabellen auf "Table" festgelegt und dann unmittelbar nach der Markierung eine neue Tabelle eingefügt.

With AutoCaptions("Microsoft Word Table")
    .AutoInsert = True
    .CaptionLabel = wdCaptionTable
End With
Selection.Collapse Direction:=wdCollapseEnd
ActiveDocument.Tables.Add Range:=Selection.Range, NumRows:=2, _
    NumColumns:=3


Beispiel zur Caption-Eigenschaft

In diesem Beispiel wird die Beschriftung jedes Fensters in der Windows-Auflistung angezeigt.

Count = 1
For Each win In Windows
    MsgBox Prompt:=win.Caption, Title:="Window" & Str(Count) & _
    " Caption"
    Count = Count + 1
Next win

In diesem Beispiel wird die Beschriftung des Anwendungsfensters auf den Standardtext eingestellt.

Application.Caption = ""

In diesem Beispiel wird die Beschriftung des aktiven Fensters auf den Namen des aktiven Dokuments eingestellt.

ActiveDocument.ActiveWindow.Caption = ActiveDocument.FullName

In diesem Beispiel wird die Beschriftung des Word-Anwendungsfensters geändert, so dass sie den Benutzernamen enthält.

Application.Caption = UserName & "'s copy of Word"

In diesem Beispiel wird eine Tabellenbeschriftung eingefügt und dann die Beschriftung des ersten Abbildungsverzeichnisses in "Table" geändert.

Selection.Collapse Direction:=wdCollapseStart
Selection.Range.InsertCaption "Table"
If ActiveDocument.TablesOfFigures.Count >= 1 Then
    ActiveDocument.TablesOfFigures(1).Caption = "Table"
End If


Beispiel zur Code-Eigenschaft

In diesem Beispiel werden die Feldfunktionen aller Felder im aktiven Dokument angezeigt.

For Each aField In ActiveDocument.Fields
    MsgBox Chr(34) & aField.Code.Text & Chr(34)
Next aField

In diesem Beispiel wird die Feldfunktion für das erste Feld im aktiven Dokument in CREATEDATE geändert.

Set myRange = ActiveDocument.Fields(1).Code
myRange.Text = " CREATEDATE "
ActiveDocument.Fields(1).Update

In diesem Beispiel wird festgestellt, ob in diesem Dokument das Seriendruckfeld "Title" enthalten ist.

For Each aField In ActiveDocument.MailMerge.Fields
    If InStr(1, aField.Code.Text, "Title", 1) Then
        MsgBox "A Title merge field is in this document"
    End If
Next aField


Beispiel zur ColorIndex-Eigenschaft

In diesem Beispiel wird im ersten Absatz des aktiven Dokuments die Farbe des Textes geändert.

ActiveDocument.Paragraphs(1).Range.Font.ColorIndex = wdGreen

In diesem Beispiel wird der markierte Text formatiert, so dass er rot erscheint.

Selection.Font.ColorIndex = wdRed

In diesem Beispiel wird um jede Zelle in der ersten Tabelle eine punktierte rote Rahmenlinie gezogen.

If ActiveDocument.Tables.Count >= 1 Then
    For Each aBorder In ActiveDocument.Tables(1).Borders
        aBorder.ColorIndex = wdRed
        aBorder.LineStyle = wdLineStyleDashDot
        aBorder.LineWidth = wdLineWidth075pt
    Next aBorder
End If


Beispiel zur Color-Eigenschaft

In diesem Beispiel wird die Farbe des Textes im ersten Absatz auf Grün geändert.

ActiveDocument.Paragraphs(1).Range.Font.Color = wdColorGreen

In diesem Beispiel wird die Farbe des markierten Textes auf Dunkelrot geändert.

Selection.Font.Color = wdColorDarkRed

In diesem Beispiel wird jede Zelle der ersten Tabelle mit einem gepunkteten Rand in Indigoblau umgeben.

If ActiveDocument.Tables.Count >= 1 Then
    For Each aBorder In ActiveDocument.Tables(1).Borders
        aBorder.Color = wdColorIndigo
        aBorder.LineStyle = wdLineStyleDashDot
        aBorder.LineWidth = wdLineWidth075pt
    Next aBorder
End If


Beispiel zur Columns-Eigenschaft

In diesem Beispiel wird die Anzahl der Spalten in der ersten Tabelle des aktiven Dokuments angezeigt.

If ActiveDocument.Tables.Count >= 1 Then
    MsgBox ActiveDocument.Tables(1).Columns.Count
End If

In diesem Beispiel wird die Breite der aktuellen Spalte auf 1 Zoll eingestellt.

If Selection.Information(wdWithInTable) = True Then
    Selection.Columns.SetWidth ColumnWidth:=InchesToPoints(1), _
        RulerStyle:=wdAdjustProportional
End If


Beispiel zur Column-Eigenschaft

In diesem Beispiel wird eine Tabelle mit einer Textmarke erstellt und dann ein Meldungsfeld angezeigt, das bestätigt, dass die Textmarke eine Tabellenspalte ist.

Set newDoc = Documents.Add
Set myTable = newDoc.Tables.Add(Selection.Range, 3, 5)
Set myCellRange = myTable.Cell(3,5).Range
myCellRange.InsertAfter "Cell(3,5)"
newDoc.Bookmarks.Add Name:="BKMK_Cell35", Range:=myCellRange
MsgBox newDoc.Bookmarks(1).Column

In diesem Beispiel wird eine 3x5 Tabelle erstellt, und die geradzahligen Spalten werden schattiert dargestellt.

Selection.Collapse Direction:=wdCollapseStart
Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=3, NumColumns:=5)
For Each aCell In myTable.Rows(1).Cells
    If aCell.ColumnIndex Mod 2 = 0 Then
        aCell.Column.Shading.Texture = wdTexture10Percent
    End If
Next aCell


Beispiel zur Command-Eigenschaft

In diesem Beispiel werden die Tasten angezeigt, die Schriftartennamen zugewiesen wurden. Eine Meldung erscheint, wenn keiner Taste Schriftarten zugewiesen wurden.

For Each aKey In KeyBindings
    If aKey.KeyCategory = wdKeyCategoryFont Then
        Count = Count + 1
        MsgBox aKey.Command & vbCr & aKey.KeyString
    End If
Next aKey
If Count = 0 Then MsgBox "Keys haven't been assigned to fonts"


Beispiel zur Comment-Eigenschaft

In diesem Beispiel wird der Kommentartext für die erste Version des aktiven Dokuments angezeigt.

If ActiveDocument.Versions.Count >= 1 Then
    MsgBox Prompt:=ActiveDocument.Versions(1).Comment, _
        Title:="First Version Comment"
End If

In diesem Beispiel wird eine Version des Dokuments mit dem Kommentar des Benutzers gespeichert und der Kommentar dann angezeigt.

Set myVersions = ActiveDocument.Versions
aComment = InputBox("Type a comment")
myVersions.Save Comment:=aComment
last = myVersions.Count
MsgBox Prompt:=myVersions(last).Comment, _
    Title:=myVersions(last).SavedBy


Beispiel zur Count-Eigenschaft

In diesem Beispiel wird die Anzahl der Absätze im aktiven Dokument angezeigt.

MsgBox "The active document contains " & _
    ActiveDocument.Paragraphs.Count & " paragraphs."

In diesem Beispiel wird die Zahl der Wörter im markierten Abschnitt angezeigt.

If Selection.Words.Count >= 1 And _
        Selection.Type <> wdSelectionIP Then
    MsgBox "The selection contains " & Selection.Words.Count _
        & " words."
End If

In diesem Beispiel werden die Feldcodes mit dem Datenfeld aFields() im aktiven Dokument gespeichert.

fcount = ActiveDocument.Fields.Count
If fcount >= 1 Then
    ReDim aFields(fcount)
    For Each aField In ActiveDocument.Fields
        aFields(aField.Index) = aField.Code.Text
    Next aField
End If


Beispiel zur Cursor-Eigenschaft

In diesem Beispiel wird eine Meldung in der Statusleiste angezeigt, und der Zeiger wechselt in seine "beschäftigte" Form.

StatusBar = "Please wait..."
For i = 1 To 1000
    System.Cursor = wdCursorWait
Next i
StatusBar = "Task completed"
System.Cursor = wdCursorNormal


Beispiel zur Data-Eigenschaft

In diesem Beispiel wird ein ADDIN-Feld an der Einfügemarke in das aktive Dokument eingefügt und die Daten für dieses Feld festgelegt.

Selection.Collapse Direction:=wdCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
    Type:=wdFieldAddin)
myField.Data = "Hidden information"


Beispiel zur Date-Eigenschaft

In diesem Beispiel wird das Datum und die Zeit des Speicherns der letzten Version des aktiven Dokuments angezeigt.

Set myDoc = ActiveDocument
If myDoc.Path <> "" Then MsgBox _
    myDoc.Versions(myDoc.Versions.Count).Date

In diesem Beispiel wird das Datum und die Zeit der nächsten Überarbeitung angezeigt, die im aktiven Dokument gefunden wurde.

If ActiveDocument.Revisions.Count >= 1 Then
    Set myRev = Selection.NextRevision
    If Not (myRev Is Nothing) Then MsgBox myRev.Date
End If


Beispiel zur DefaultBorderColor-Eigenschaft

In diesem Beispiel wird die Standardfarbe für neue Rahmen auf Blaugrün festgelegt.

Options.DefaultBorderColor = wdColorTeal


Beispiel zur DefaultTab-Eigenschaft

In diesem Beispiel wird das Dialogfeld Seite einrichten geöffnet, wobei die Registerkarte Papierzufuhr ausgewählt ist.

With Dialogs(wdDialogFilePageSetup)
    .DefaultTab = wdDialogFilePageSetupTabPaperSource
    .Show
End With


Beispiel zur DefaultTray-Eigenschaft

In diesem Beispiel wird Word so eingestellt, dass der untere Papierschacht verwendet wird.

Options.DefaultTray = "Lower tray"

In diesem Beispiel wird die Zeichenfolge im Feld Standardschacht auf der Registerkarte Drucken im Dialogfeld Optionen zurückgegeben.

Msgbox Options.DefaultTray


Beispiel zur Default-Eigenschaft

In diesem Beispiel wird der Standardtext für das Textfeld "Name" zugewiesen.

ActiveDocument.FormFields("Name").TextInput.Default = "your name"

Wenn es sich beim ersten Formularfeld im aktiven Dokument um ein Kontrollkästchen handelt, dann lädt dieses Beispiel den Standardwert.

If ActiveDocument.FormFields(1).Type = wdFieldFormCheckBox Then _
    defvalue = ActiveDocument.FormFields(1).CheckBox.Default

In diesem Beispiel wird das Standardelement für das Dropdown-Formularfeld "Colors" in Sales.doc festgelegt.

Documents("Sales.doc").FormFields("Colors").DropDown.Default = 2


Beispiel zur DiacriticColor-Eigenschaft

Sprachspezifische Informationen

This example sets the color for diacritics to blue in the current selection.

If Options.UseDiffDiacColor = True Then _
    Selection.Font.DiacriticColor = wdColorBlue


Beispiel zur DistanceFrom-Eigenschaft

In diesem Beispiel wird ein einzelner Rahmen um alle Seiten in Abschnitt 1 des aktiven Dokuments hinzugefügt und anschließend der Abstand zwischen jedem Rahmen und dem entsprechenden Seitenrand festgelegt.

With ActiveDocument.Sections(1)
    For Each aBord In .Borders
        aBord.LineStyle = wdLineStyleSingle
        aBord.LineWidth = wdLineWidth050pt
    Next aBord
    With .Borders
        .DistanceFrom = wdBorderDistanceFromPageEdge
        .DistanceFromTop = 20
        .DistanceFromLeft = 22
        .DistanceFromBottom = 20
        .DistanceFromRight = 22
    End With
End With

In diesem Beispiel wird ein Rahmen um jede Seite im ersten Abschnitt hinzugefügt und anschließend 6 Punkt als Abstand zwischen Text und Seitenrahmen festgelegt.

With Selection.Sections(1)
    For Each aBorder In .Borders
        aBorder.ArtStyle = wdArtSeattle
        aBorder.ArtWidth = 22
    Next aBorder
    With .Borders
        .DistanceFrom = wdBorderDistanceFromText
        .DistanceFromTop = 6
        .DistanceFromLeft = 6
        .DistanceFromBottom = 6
        .DistanceFromRight = 6
    End With
End With


Beispiel zur DocumentMap-Eigenschaft

In diesem Beispiel wird für das aktive Fenster die Anzeige der Dokumentstruktur umgeschaltet.

ActiveDocument.ActiveWindow.DocumentMap = _
    Not ActiveDocument.ActiveWindow.DocumentMap

In diesem Beispiel wird im Fenster für Sales.doc die Dokumentstruktur angezeigt.

Set myDoc = Documents.Open(FileName:="C:\Documents\Sales.doc")
myDoc.ActiveWindow.DocumentMap = True


Beispiel zur Document-Eigenschaft

Dieses Beispiel zeigt den Namen und den Pfad des Dokuments für die Markierung an.

Msgbox Selection.Document.FullName

Dieses Beispiel legt myDoc als mit dem aktiven Fenster verbundenes Dokument fest. Der Fokus wechselt zum nächsten Fenster, und das Fenster wird geteilt. Mit der Activate-Methode wird wieder zum ursprünglichen Dokument gewechselt.

Set myDoc = Application.ActiveWindow.Document
If Windows.Count >= 2 Then
    Application.ActiveWindow.Next.Activate
    Application.ActiveWindow.Split = True
    myDoc.Activate
End If


Beispiel zur Drop-Eigenschaft

In diesem Beispiel wird in myDocument der benutzerdefinierte Ansatz für Form eins durch einen von zwei voreingestellten Ansätzen ersetzt, in Abhängigkeit davon, ob der benutzerdefinierte Ansatzwert größer oder kleiner als die halbe Höhe des Legendentextfelds ist. Damit das Beispiel funktioniert, muss Form eins eine Legende sein.

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropCustom Then
        If .Drop < .Parent.Height / 2 Then
            .PresetDrop msoCalloutDropTop
        Else
            .PresetDrop msoCalloutDropBottom
        End If
    End If
End With


Email-Eigenschaft

In diesem Beispiel wird der Name der Formatvorlage zurückgegeben, die dem aktuellen Verfasser von E-Mail zugeordnet ist.

MsgBox ActiveDocument.Email _
    .CurrentEmailAuthor.Style.NameLocal


Beispiel zur Enable-Eigenschaft

In diesem Beispiel werden alle Ränder von der ersten Zelle in Tabelle 1 entfernt.

If ActiveDocument.Tables.Count >= 1 Then
    ActiveDocument.Tables(1).Cell(1, 1).Borders.Enable = False
End If

In diesem Beispiel wird ein gestrichelter Rahmen um den ersten Absatz in der Auswahl gezogen.

Options.DefaultBorderLineWidth = wdLineWidth025pt
Selection.Paragraphs(1).Borders.Enable = wdLineStyleDashSmallGap

In diesem Beispiel wird ein Rahmen um das erste Zeichen in der Auswahl gezogen. Wurde nichts ausgewählt, wird der Rahmen auf das erste Zeichen nach der Einfügemarke angewendet.

Selection.Characters(1).Borders.Enable = True


Beispiel zur End-Eigenschaft

In diesem Beispiel wird die Endposition der Textmarke "temp" mit der Anfangsposition der Textmarke "anfang" verglichen.

Set Book1 = ActiveDocument.Bookmarks("begin")
Set Book2 = ActiveDocument.Bookmarks("temp")
If Book2.End > Book1.Start Then Book1.Select

In diesem Beispiel wird zuerst die Endposition der Markierung gewonnen. Dieser Wert wird zum Erstellen eines Bereichs verwendet, so dass nach der Markierung ein Feld eingefügt werden kann.

pos = Selection.End
Set myRange = ActiveDocument.Range(Start:=pos, End:=pos)
ActiveDocument.Fields.Add Range:=myRange, Type:=wdFieldAuthor

In diesem Beispiel wird die Endposition von myRange um ein Zeichen geändert.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.End = myRange.End - 1


Beispiel zur Envelope-Eigenschaft

In diesem Beispiel wird die Standardgröße für Briefumschläge auf C4 (229 x 324 mm) gesetzt.

ActiveDocument.Envelope.DefaultSize = "C4"

In diesem Beispiel wird die Empfängeradresse angezeigt, wenn ein Umschlag dem Dokument hinzugefügt wurde; sonst wird ein Meldungsfeld angezeigt.

On Error GoTo errhandler
addr = ActiveDocument.Envelope.Address.Text
MsgBox Prompt:=addr, Title:="Delivery Address"
errhandler:
If Err = 5852 Then MsgBox "Add an envelope to the document"

In diesem Beispiel wird ein neues Dokument erstellt und ein Umschlag mit einer vordefinierten Empfänger- und Absenderadresse hinzugefügt.

addr = "Don Funk" & vbCr & "123 Skye St." _
    & vbCr & "Our Town, WA  98040"
retaddr = "Karin Gallagher" & vbCr & "123 Main" _
    & vbCr & "Other Town, WA  98004"
Documents.Add.Envelope.Insert Address:=addr, ReturnAddress:=retaddr
ActiveDocument.ActiveWindow.View.Type = wdPrintView


Beispiel zur ExtrusionColor-Eigenschaft

In diesem Beispiel wird zu myDocument ein Oval hinzugefügt und dann spezifiziert, dass das Oval auf eine Tiefe von 50 Punkt projiziert wird und die Projektion purpurrot sein soll.

Set myDocument = ActiveDocument
Set myShape = myDocument.Shapes.AddShape(msoShapeOval, _
    90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    ' RGB value for purple
    .ExtrusionColor.RGB = RGB(255, 100, 255)
End With


Beispiel zur Fields-Eigenschaft

In diesem Beispiel werden alle Felder im aktiven Dokument aktualisiert.

ActiveDocument.Fields.Update

In diesem Beispiel werden alle Felder in den Dokumentkomponenten des Haupttextes und in der Fußzeile des aktiven Dokuments entfernt.

For Each aField in ActiveDocument.Fields
    aField.Delete
Next aField
Set myRange = ActiveDocument.Sections(1).Footers _
    (wdHeaderFooterPrimary).Range
For Each aField In myRange.Fields
    aField.Delete
Next aField

In diesem Beispiel wird ein DATE-Feld an der Einfügemarke hinzugefügt.

With Selection
    .Collapse Direction:=wdCollapseStart
    .Fields.Add Range:=Selection.Range, Type:=wdFieldDate
End With

In diesem Beispiel wird das Seriendruckfeld "Title" an der Einfügemarke hinzugefügt.

Selection.Collapse Direction:=wdCollapseStart
ActiveDocument.MailMerge.Fields.Add Range:= Selection.Range, _
    Name:= "Title"


Beispiel zur Field-Eigenschaft

In diesem Beispiel wird eine Grafik als eingebettete Form eingefügt (mit einem INCLUDEPICTURE-Feld), anschließend wird die Feldfunktion der Form angezeigt.

Set iShape = _
    ActiveDocument.InlineShapes _
    .AddPicture(FileName:="C:\Windows\Tiles.bmp", _
    LinkToFile:=True, SaveWithDocument:=False, _
    Range:=Selection.Range)
MsgBox iShape.Field.Code.Text


Beispiel zur Find-Eigenschaft

In dem folgenden Beispiel wird das Dokument in Vorwärtsrichtung nach dem Wort "Microsoft" durchsucht. Wenn das Wort gefunden wird, wird es automatisch markiert.

With Selection.Find
    .Forward = True
    .ClearFormatting
    .MatchWholeWord = True
    .MatchCase = False
    .Wrap = wdFindContinue
    .Execute FindText:="Microsoft"
End With

In diesem Beispiel wird im aktiven Dokument am Anfang jedes Absatzes, der mit der Formatvorlage Überschrift 3 formatiert ist, "Tip: " eingefügt. Die Anweisung Do…Loop wird jedes Mal zum Wiederholen einer Reihe von Aktionen verwendet, wenn diese Formatvorlage gefunden wird.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Style = wdStyleHeading3
    Do While .Execute(FindText:="", Forward:=True, _
            Format:=True) = True
        With .Parent
            .StartOf Unit:=wdParagraph, Extend:=wdMove
            .InsertAfter "Tip: "
            .Move Unit:=wdParagraph, Count:=1
        End With
    Loop
End With


Beispiel zur First-Eigenschaft

In diesem Beispiel wird der erste Absatz in der Markierung rechts ausgerichtet.

Selection.Paragraphs.First.Alignment = wdAlignParagraphRight

In diesem Beispiel werden im aktiven Dokument der ersten Zeile in Tabelle 1 Schattierung und eine untere Rahmenlinie zugewiesen.

ActiveDocument.Tables(1).Borders.Enable = False
With ActiveDocument.Tables(1).Rows.First
    .Shading.Texture = wdTexture10Percent
    .Borders(wdBorderBottom).LineStyle = wdLineStyleSingle
End With


Beispiel zur FitText-Eigenschaft

In diesem Beispiel wird für die erste Zelle in der Markierung festgelegt, dass eingegebener Text automatisch der Breite der Zelle angepasst wird.

Selection.Cells(1).FitText = True


Beispiel zur FontName-Eigenschaft

In diesem Beispiel wird für den ersten Absatz des aktiven Dokuments Arial als Schriftart für den Anfangs-Großbuchstaben im Text festgelegt.

With ActiveDocument.Paragraphs(1).DropCap
    .FontName = "Arial"
    .Position = wdDropNormal
    .LinesToDrop = 3
    .DistanceFromText = InchesToPoints(0.1)
End With


Beispiel zur Fonts-Eigenschaft

In diesem Beispiel wird die Standardfestbreitenschrift für den Englischen/Westeuropäischen/Anderen Lateinischen Zeichensatz auf Courier New, 14 Punkt festgelegt.

With Application.DefaultWebOptions _
        .Fonts(msoCharacterSetEnglishWesternEuropeanOtherLatinScript)
    .FixedWidthFont = "Courier New"
    .FixedWidthFontSize = 14
End With


Beispiel zur Font-Eigenschaft

In diesem Beispiel wird im aktiven Dokument von der Formatvorlage Überschrift 1 die Fettformatierung entfernt.

ActiveDocument.Styles(wdStyleHeading1).Font.Bold = False

In diesem Beispiel wird im aktiven Dokument die Schriftart des zweiten Absatzes zwischen "Arial" und "Times New Roman" umgeschaltet.

Set myRange = ActiveDocument.Paragraphs(2).Range
If myRange.Font.Name = "Times New Roman" Then
    myRange.Font.Name = "Arial"
Else
    myRange.Font.Name = "Times New Roman"
End If

In diesem Beispiel wird die Schriftart des markierten Textes angezeigt.

MsgBox Selection.Font.Name

In diesem Beispiel wird die Zeichenformatierung des markierten Textes dem ersten Absatz im aktiven Dokument zugewiesen.

Set myFont = Selection.Font.Duplicate
ActiveDocument.Paragraphs(1).Range.Font = myFont

In diesem Beispiel wird der nächste Textbereich gesucht, der mit der Schriftart "Times New Roman" formatiert ist.

With Selection.Find
    .ClearFormatting
    .Font.Name = "Times New Roman"
    .Execute FindText:="", ReplaceWith:="", Format:=True, _
        Forward:=True
End With


Beispiel zur ForegroundPatternColor-Eigenschaft

In diesem Beispiel wird eine Schattierung mit blaugrünen Punkten auf einem dunkelroten Hintergrund auf die Markierung angewendet.

With Selection.Shading
    .Texture = wdTexture30Percent
    .ForegroundPatternColor = wdColorTeal
    .BackgroundPatternColor = wdColorDarkRed
End With


Beispiel zur Format-Eigenschaft

Das folgende Beispiel richtet alle Absätze im aktiven Dokument links aus.

ActiveDocument.Paragraphs.Format.Alignment = wdAlignParagraphLeft

In diesem Beispiel wird den Inhaltsverzeichnissen in Report.doc die Formatierung "Klassisch" zugewiesen.

Documents("Report.doc").TablesOfContents.Format = wdTOCClassic

Dieses Beispiel gibt die Formatierung des Texts im ersten Feld des aktiven Dokuments zurück und zeigt sie an.

If ActiveDocument.FormFields(1).Type = wdFieldFormTextInput Then
    MsgBox ActiveDocument.FormFields(1).TextInput.Format
Else
    MsgBox "First field is not a text form field"
End If

Dieses Beispiel gibt die Formatierung des ersten Absatzes im aktiven Dokument zurück und weist die Formatierung anschließend der Markierung zu.

Set paraFormat = ActiveDocument.Paragraphs(1).Format.Duplicate
Selection.Paragraphs.Format = paraFormat

In diesem Beispiel wird die Formatierung der fett formatierten Elemente im aktiven Dokument entfernt.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Font.Bold = True
    .Format = True
    .Replacement.ClearFormatting
    .Replacement.Font.Bold = False
    .Execute Forward:=True, Replace:=wdReplaceAll, _
        FindText:="", ReplaceWith:=""
End With


Beispiel zur Frameset-Eigenschaft

In diesem Beispiel wird für Framerahmenlinien auf der angegebenen Framesseite die Farbe Gelbbraun festgelegt.

With ActiveWindow.Document.Frameset
    .FramesetBorderColor = wdColorTan
    .FramesetBorderWidth = 6
End With

In diesem Beispiel wird unmittelbar rechts neben dem angegebenen Frame ein neuer Frame eingefügt.

ActiveDocument.ActiveWindow.ActivePane.Frameset _
    .AddNewFrame wdFramesetNewRight


Beispiel zur Frames-Eigenschaft

In diesem Beispiel wird festgelegt, dass Text um den Rahmen im ersten Abschnitt des aktiven Dokuments fließt.

For Each aFrame In ActiveDocument.Sections(1).Range.Frames
    aFrame.TextWrap = True
Next aFrame

In diesem Beispiel wird ein Rahmen um die Auswahl gezogen, und ein Frame-Objekt wird an die Variable myFrames zurückgegeben.

Set myFrame = ActiveDocument.Frames.Add(Range:=Selection.Range)


Beispiel zur Frame-Eigenschaft

In diesem Beispiel wird eine Formatvorlage mit einer Rahmenformatierung erstellt, dann wird die Formatvorlage dem ersten Absatz in der Auswahl zugewiesen.

Set myStyle = ActiveDocument.Styles _
    .Add(Name:="frame", Type:=wdStyleTypeParagraph)
With myStyle.Frame
    .RelativeHorizontalPosition = _
        wdRelativeHorizontalPositionMargin
    .HeightRule = wdFrameAuto
    .WidthRule = wdFrameAuto
    .TextWrap = True
End With
Selection.Paragraphs(1).Range.Style = "frame"

In diesem Beispiel wird der erste Rahmen mit Textfluss-Formatierung gesucht. Wird ein solcher Rahmen gefunden, erscheint eine Meldung in der Statusleiste.

With ActiveDocument.Content.Find
    .Text = ""
    .Frame.TextWrap = True
    .Execute Forward:=True, Wrap:=wdFindContinue, Format:=True
    If .Found = True Then StatusBar = "Frame was found"
    .Parent.Select
End With


Beispiel zur Gutter-Eigenschaft

In diesem Beispiel wird dem inneren Seitenrand des aktiven Dokuments 1 Zoll (72 Punkt) hinzugefügt.

With ActiveDocument.PageSetup
    .MirrorMargins = True
    .Gutter = 72
End With


Beispiel zur Headers-Eigenschaft

In diesem Beispiel werden im aktiven Dokument jeder Seite, außer der ersten, zentrierte Seitenzahlen hinzugefügt. (Für die erste Seite wird eine separate Kopfzeile erstellt.)

With ActiveDocument.Sections(1).Headers(wdHeaderFooterPrimary)
    .PageNumbers.Add _
        PageNumberAlignment:=wdAlignPageNumberCenter, _
        FirstPage:=False
End With

In diesem Beispiel wird im aktiven Dokument der Kopfzeile der ersten Seite Text hinzugefügt.

ActiveDocument.PageSetup.DifferentFirstPageHeaderFooter = True
With ActiveDocument.Sections(1).Headers(wdHeaderFooterFirstPage)
    .Range.InsertAfter("First Page Text")
    .Range.Paragraphs.Alignment = wdAlignParagraphRight
End With


Beispiel zur Height-Eigenschaft

In diesem Beispiel wird im aktiven Dokument in der ersten Tabelle die Höhe der Zeilen auf mindestens 20 Punkt festgelegt.

ActiveDocument.Tables(1).Rows.Height = 20

In diesem Beispiel wird die Höhe (in Punkt) der Tabellenzeile angezeigt, die die Einfügemarke enthält.

If Selection.Information(wdWithInTable) = True Then
    MsgBox Selection.Rows(1).Height
End If

In diesem Beispiel wird die Höhe des aktiven Fensters so geändert, dass der Anwendungsfensterbereich ausgefüllt wird.

With ActiveDocument.ActiveWindow
    .WindowState = wdWindowStateNormal
    .Height = Application.UsableHeight
End With

In diesem Beispiel wird eine Grafik als eingebettete Figur eingefügt und die Höhe und Breite der Grafik geändert.

Set aInLine = _
    ActiveDocument.InlineShapes.AddPicture( _
    FileName:="C:\Windows\Bubbles.bmp", _
    Range:=Selection.Range)
With aInLine
    .Height = 100
    .Width = 200
End With

In diesem Beispiel wird die Höhe des angegebenen Frameset-Objekts auf 25% der Höhe des Fensters festgelegt.

With ActiveWindow.ActivePane.Frameset
    .HeightType = wdFramesetSizeTypePercent
    .Height = 25
End With


Beispiel zur Highlight-Eigenschaft

In diesem Beispiel werden im aktiven Dokument alle Instanzen von Text mit der Formatierung "Hervorheben" gesucht und die Formatierung "Hervorheben" entfernt, indem die Highlight-Eigenschaft des Replacement-Objekts auf False festgelegt wird.

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
With myRange.Find
    .ClearFormatting
    .Highlight = True
    With .Replacement
        .ClearFormatting
        .Highlight = False
    End With
    .Execute Replace:=wdReplaceAll, Forward:=True, FindText:="", _
         ReplaceWith:="", Format:=True
End With

In diesem Beispiel wird im aktiven Dokument der nächsten Instanz von fett ausgezeichnetem Text die Formatierung "Hervorheben" zugewiesen.

With Selection.Find
    .ClearFormatting
    .Font.Bold = True
    With .Replacement
        .ClearFormatting
        .Highlight = True
    End With
    .Execute Forward:=True, FindText:="", ReplaceWith:="", _
        Format:=True
End With


Beispiel zur Hyperlink-Eigenschaft

In diesem Beispiel wird die Adresse des Hyperlinks für die erste Form im aktiven Dokument angezeigt.

MsgBox ActiveDocument.Shapes(1).Hyperlink.Address


Beispiel zur Index-Eigenschaft

In diesem Beispiel wird dem aktiven Dokument eine Dokumentvariable hinzugefügt und dann die Position der Variablen in der Variables-Auflistung zurückgegeben.

Set myVar = ActiveDocument.Variables.Add(Name:="Name", _
    Value:="Joe")
num = myVar.Index

In diesem Beispiel wird die Position des markierten Feldes in der Fields-Auflistung zurückgegeben.

num = Selection.Fields(1).Index

In diesem Beispiel wird die Nummer des ersten Fensters in der Windows-Auflistung zurückgegeben. Wenn mindestens zwei Fenster in der Windows-Auflistung vorhanden sind, aktiviert das Makro das nächste Fenster, kopiert das erste Wort, schaltet zum Originalfenster zurück und fügt den Inhalt der Zwischenablage dort ein.

Set myWindow = Windows(1)
winNum = myWindow.Index
If Windows.Count >= 2 Then
    myWindow.Next.Activate
    ActiveDocument.Words(1).Copy
    Windows(winNum).Activate
    Selection.Range.Paste
End If


Beispiel zur InlineShape-Eigenschaft

In diesem Beispiel wird die Breite der eingebetteten Form zurückgegeben, die mit dem ersten Feld im aktiven Dokument verbunden ist. Dieses Beispiel funktioniert nur, wenn es sich bei dem Feld um ein INCLUDEPICTURE-Feld handelt.

If ActiveDocument.Fields(1).Type = wdFieldIncludePicture Then
    MsgBox ActiveDocument.Fields(1).InlineShape.Width
End If


Beispiel zur InsideColor-Eigenschaft

In diesem Beispiel werden in der ersten Tabelle des aktiven Dokuments Rahmenlinien zwischen Zeilen und zwischen Spalten eingefügt. Danach werden die Farben für die äußeren und die inneren Rahmenlinien festgelegt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    With myTable.Borders
        .InsideLineStyle = True
        .InsideColor = wdColorBlueGray
        .OutsideColor = wdColorPink
    End With
End If

In diesem Beispiel werden zwischen den ersten vier Absätzen des aktiven Dokuments dunkelrote Rahmenlinien eingefügt.

Set myDoc = ActiveDocument
Set myRange = myDoc.Range(Start:=myDoc.Paragraphs(1).Range.Start, _
    End:=myDoc.Paragraphs(4).Range.End)
With myRange.Borders
    .InsideLineStyle = wdLineStyleSingle
    .InsideLineWidth = wdLineWidth150pt
    .InsideColor = wdDarkRed
End With


Beispiel zur Inside-Eigenschaft

Wenn die aktuelle Auswahl Innenränder unterstützt (d. h. mehrere Absätze oder Zellen wurden gewählt), weist dieses Beispiel einen einfachen Innenrahmen zu.

For Each aBorder In Selection.Borders
    If aBorder.Inside = True Then _
        aBorder.LineStyle = wdLineStyleSingle
Next aBorder


Beispiel zur Italic-Eigenschaft

In diesem Beispiel wird das erste Wort im aktiven Dokument kursiv formatiert.

ActiveDocument.Words(1).Italic = True

In diesem Beispiel wird die Auswahl auf die Formatierung Kursiv überprüft, die daraufhin entfernt wird.

If Selection.Type = wdSelectionNormal Then
    mySel = Selection.Font.Italic
    If mySel = wdUndefined or mySel = True Then
        MsgBox "There's italic text in selection. " _
            & "Click OK to remove."
        Selection.Font.Italic = False
    Else
        MsgBox "No italic text in the selection."
    End If
Else
    MsgBox "You need to select some text."
End If


Beispiel zur Kerning-Eigenschaft

In diesem Beispiel wird das Kerning für den gesamten Text mit einem Schriftgrad von 12 Punkt oder mehr im aktiven Dokument angepasst.

ActiveDocument.Content.Font.Kerning = 12

In diesem Beispiel wird der kleinste Schriftgrad bestimmt, für den Word automatisch das Kerning im gewählten Text anpasst.

If Selection.Type = wdSelectionNormal Then
    MsgBox Selection.Font.Kerning
Else
    MsgBox "You need to select some text."
End If


Beispiel zur KeyCode-Eigenschaft

In diesem Beispiel erscheint eine Meldung, wenn sich die Tastenkombination ALT+STRG+W in der KeyBindings-Auflistung befindet.

CustomizationContext = NormalTemplate
aCode = BuildKeyCode(wdKeyAlt, wdKeyControl, wdKeyW)
For Each aKey In KeyBindings
    If aCode = aKey.KeyCode Then
        MsgBox aKey.KeyString & " is already in use"
    End If
Next aKey


Beispiel zur LanguageID-Eigenschaft

In diesem Beispiel wird Französisch als Sprache für den zweiten Absatz im Dokument festgelegt. Anschließend wird ein neues Benutzerwörterbuch hinzugefügt, das mit dem französischen Text benutzt wird.

ActiveDocument.Paragraphs(2).Range.LanguageID = wdFrench
Set myDictionary = CustomDictionaries.Add(Filename:="French.dic")
With myDictionary
    .LanguageSpecific = True
    .LanguageID = wdFrench
End With

In diesem Beispiel wird die Formatvorlage "Title" so umformatiert, dass spanische Editierhilfen verwendet werden. Eine neue Beschreibung der Formatvorlage wird anschließend in einem Meldungsfeld angezeigt.

ActiveDocument.Styles("Title").LanguageID = wdSpanish
MsgBox ActiveDocument.Styles("Title").Description


Beispiel zur Languages-Eigenschaft

In diesem Beispiel wird der vollständige Pfad und Dateiname des derzeit aktiven Rechtschreibwörterbuchs zurückgegeben.

Set mySpell = _
    Languages(Selection.LanguageID).ActiveSpellingDictionary
MsgBox mySpell.Path & Application.PathSeparator & mySpell.Name

In diesem Beispiel werden die Namen der Korrektursprachen im aLang()-Bereich gespeichert.

ReDim aLang(Languages.Count - 1)
i = 0
For Each myLanguage In Languages
    aLang(i) = myLanguage.NameLocal
    i = i + 1
Next myLanguage


Beispiel zur Language-Eigenschaft

In diesem Beispiel wird die für die Microsoft Word-Benutzeroberfläche ausgewählte Sprache angezeigt.

If Application.Language = msoLanguageIDEnglishUS Then
    MsgBox "The user interface language is U.S. English."
Else
    MsgBox "The user interface language is not U.S. English."
End If


Beispiel zur Last-Eigenschaft

In diesem Beispiel wird der letzte Absatz im aktiven Dokument rechts ausgerichtet.

ActiveDocument.Paragraphs.Last.Alignment = wdAlignParagraphRight

In diesem Beispiel wird die letzte Zeile in Tabelle 1 gelöscht.

ActiveDocument.Tables(1).Rows.Last.Cells.Delete

In diesem Beispiel wird dem letzten Wort in der Markierung Fettformatierung zugewiesen.

If Selection.Words.Count >= 2 Then
    Selection.Words.Last.Bold = True
End If


Beispiel zur Left-Eigenschaft

In diesem Beispiel wird 100 Punkt als horizontale Position des aktiven Fensters festgelegt.

With ActiveDocument.ActiveWindow
    .WindowState = wdWindowStateNormal
    .Left = 100
    .Top = 0
End With

In diesem Beispiel wird 1 Zoll von der linken Seitenkante als horizontale Position der ersten Form im aktiven Dokument festgelegt.

With ActiveDocument.Shapes(1)
    .RelativeHorizontalPosition = _
        wdRelativeHorizontalPositionPage
    .Left = InchesToPoints(1)
End With

In diesem Beispiel wird 1 Zoll von der linken Kante der Spalte als horiziontale Position der ersten und zweiten Form im aktiven Dokument festgelegt.

With ActiveDocument.Shapes.Range(Array(1, 2))
    .RelativeHorizontalPosition = _
        wdRelativeHorizontalPositionColumn
    .Left = InchesToPoints(1)
End With


Beispiel zur Letterhead-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, am oberen Seitenrand wird ein 1 Zoll breiter Platz für einen vorgedruckten Briefkopf reserviert und anschließend der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set aLetterContent = New LetterContent
With aLetterContent
    .Letterhead = True
    .LetterheadLocation = wdLetterTop
    .LetterheadSize = InchesToPoints(1)
End With
ActiveDocument.RunLetterWizard _
    LetterContent:=aLetterContent, WizardMode:=True


Beispiel zur LineSpacing-Eigenschaft

In diesem Beispiel wird für den ersten Absatz im aktiven Dokument festgelegt, dass der Zeilenabstand immer mindestens 12 Punkt ist.

With ActiveDocument.Paragraphs(1)
    .LineSpacingRule = wdLineSpaceAtLeast
    .LineSpacing = 12
End With

In diesem Beispiel werden die markierten Absätze mit dreifachem Zeilenabstand formatiert.

With Selection.Paragraphs
    .LineSpacingRule = wdLineSpaceMultiple
    .LineSpacing = LinesToPoints(3)
End With


Beispiel zur Line-Eigenschaft

In diesem Beispiel wird zu myDocument eine blaue, gestrichelte Linie hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With

In diesem Beispiel wird zu myDocument ein Kreuz hinzugefügt und dann festgelegt, dass sein Rahmen 8 Punkt dick und rot sein soll.

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(msoShapeCross, 10, 10, 50, 70).Line
    .Weight = 8
    .ForeColor.RGB = RGB(255, 0, 0)
End With


Beispiel zur Lists-Eigenschaft

In diesem Beispiel wird die Auswahl als nummerierte Liste formatiert. Dann zeigt ein Meldungsfeld die Anzahl der Listen im aktiven Dokument an.

Selection.Range.ListFormat.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdNumberGallery).ListTemplates(2)
MsgBox "This document has " & ActiveDocument.Lists.Count _
    & " lists."

In diesem Beispiel wird die dritte Liste im aktiven Dokument mit dem Standardformat für Aufzählungen formatiert. Wurde die Liste bereits als Aufzählung formatiert, entfernt dieses Beispiel die Formatierung.

If ActiveDocument.Lists.Count >= 3 Then
    ActiveDocument.Lists(3).Range.ListFormat.ApplyBulletDefault
End If

Dieses Beispiel zeigt ein Meldungsfeld mit der Anzahl der Elemente aller Listen in MeinBrief.doc angezeigt.

Set myDoc = Documents("MyLetter.doc")
i = myDoc.Lists.Count
For each li in myDoc.Lists
    Msgbox "List " & i & " has " & li.CountNumberedItems _
        & " items."
    i = i - 1
Next li


Beispiel zur ListTemplate-Eigenschaft

In diesem Beispiel wird überprüft, welche Listenvorlage für den zweiten Absatz im aktiven Dokument verwendet wurde und dann der Markierung zugewiesen.

Set myltemp = ActiveDocument.Paragraphs(2).Range. _
    ListFormat.ListTemplate
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myltemp


Beispiel zur List-Eigenschaft

In diesem Beispiel wird die erste Liste in der Auswahl zurückgegeben und dann wird die erste Listenvorlage (exkl. Ohne) auf der Registerkarte Nummerierung im Dialogfeld Nummerierung und Aufzählungen zugewiesen. Die Auswahl kann nur eine Liste enthalten.

Set mylist = Selection.Range.ListFormat.List
mylist.ApplyListTemplate _
    ListTemplate:=ListGalleries(wdNumberGallery) _
    .ListTemplates(1)


Beispiel zur MailMerge-Eigenschaft

In diesem Beispiel wird ein Seriendruck ausgeführt, wenn es sich beim aktiven Dokument um ein Hauptdokument mit zugeordneter Datenquelle handelt.

Set myMerge = ActiveDocument.MailMerge
If myMerge.State = wdMainAndDataSource Then myMerge.Execute

In diesem Beispiel wird das Hauptdokument mit den Datensätzen 1 bis 4 zusammengeführt, und die Seriendruckdokumente werden an den Drucker übergeben.

With ActiveDocument.MailMerge
    .DataSource.FirstRecord = 1
    .DataSource.LastRecord = 4
    .Destination = wdSendToPrinter
    .SuppressBlankLines = True
    .Execute
End With


Beispiel zur MarkComments-Eigenschaft

In diesem Beispiel wird festgelegt, dass Word Kommentare in E-Mail-Nachrichten mit den Initialen "WK" markiert.

Application.EmailOptions.MarkCommentsWith = "WK"
Application.EmailOptions.MarkComments = True


Beispiel zur MatchFuzzy-Eigenschaft

This example conducts a nonspecific search for " piano piano piano " in the selected range and selects the next occurrence (for example, " piyano piyano piyano ").

With Selection.Find
    .ClearFormatting
    .Text = "  piano   piano   piano "
    .MatchFuzzy = True
    .Execute Format:=False, Forward:=True, Wrap:=wdFindContinue
End With


Beispiel zur Name-Eigenschaft

In diesem Beispiel wird eine Dokumentvariable dem aktiven Dokument hinzugefügt und dann der Name der ersten Dokumentvariablen angezeigt.

ActiveDocument.Variables.Add Name:="Temp", Value:="1"
MsgBox ActiveDocument.Variables(1).Name

In diesem Beispiel wird der Name der ersten Textmarke in Hello.doc zurückgegeben.

abook = Documents("Hello.doc").Bookmarks(1).Name

In diesem Beispiel werden die Namen der Formularfelder im aktiven Dokument angezeigt.

If ActiveDocument.FormFields.Count >= 1 Then
    For Each FF In ActiveDocument.FormFields
        FFNames = FFNames & FF.Name & vbCr
    Next FF
    MsgBox FFNames
End If

In diesem Beispiel wird der markierte Abschnitt mit der Schriftart Arial fett formatiert.

With Selection.Font
    .Name = "Arial"
    .Bold = True
End With

Dieses Beispiel weist der ersten Listenvorlage im aktiven Dokument den Namen myList zu. Dann wird an der Einfügemarke ein LISTNUM-Feld (mit der Vorlage myList verknüpft) eingefügt. Das Feld übernimmt die Formatierung der Vorlage myList.

If ActiveDocument.ListTemplates.Count >= 1 Then
    ActiveDocument.ListTemplates(1).Name = "myList"
    Selection.Collapse Direction:=wdCollapseEnd
    ActiveDocument.Fields.Add Range:=Selection.Range, _
        Type:=wdFieldListNum, Text:="myList"
End If


Beispiel zur Next-Eigenschaft

In diesem Beispiel wird das nächste Fenster aktiviert.

If Windows.Count > 1 Then ActiveDocument.ActiveWindow.Next.Activate

Wenn die Markierung in einer Tabelle ist, wird in diesem Beispiel der Inhalt der nächsten Tabellenzelle markiert.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).Next.Select
End If

In diesem Beispiel werden im aktiven Dokument die Felder im ersten Abschnitt aktualisiert, solange die Next-Methode ein Field-Objekt zurückgibt und das Feld nicht FILLIN ist.

If ActiveDocument.Sections(1).Range.Fields.Count >= 1 Then
    Set myField = ActiveDocument.Fields(1)
    While Not (myField Is Nothing)
        If myField.Type <> wdFieldFillIn Then myField.Update
        Set myField = myField.Next
    Wend
End If

In diesem Beispiel wird der zweite Absatz in der Markierung eingezogen.

Selection.Paragraphs(1).Next.Indent


Beispiel zur OptimizeForWord97-Eigenschaft

In diesem Beispiel wird geprüft, ob das aktuelle Dokument für Word 97 optimiert ist. Ist dies nicht der Fall, wird der Benutzer gefragt, ob die Optimierung vorgenommen werden soll.

If ActiveDocument.OptimizeForWord97 = False Then
    x = MsgBox("Is this document targeted at " _
        & "Word 97 users?", vbYesNo)
    If x = vbYes Then _
        ActiveDocument.OptimizeForWord97 = True
End If


Beispiel zur Outline-Eigenschaft

In diesem Beispiel wird Konturschriftformatierung auf die ersten drei Wörter im aktiven Dokument angewandt.

Set myRange = ActiveDocument.Range(Start:= _
    ActiveDocument.Words(1).Start, _
    End:=ActiveDocument.Words(3).End)
myRange.Font.Outline = True

In diesem Beispiel wird Konturschriftformatierung für den markierten Text umgeschaltet.

Selection.Font.Outline = wdToggle

In diesem Beispiel wird Konturschriftformatierung von der Markierung entfernt, wenn Konturschriftformatierung teilweise auf die Markierung angewandt wurde.

Set myFont = Selection.Font
If myFont.Outline = wdUndefined Then
    myFont.Outline = False
End If


Beispiel zur OutsideColor-Eigenschaft

In diesem Beispiel werden in der ersten Tabelle im aktiven Dokument Rahmen zwischen Zeilen und zwischen Spalten eingefügt und anschließend Farben sowohl für den Innen- als auch den Außenrahmen festgelegt.

If ActiveDocument.Tables.Count >= 1 Then
    Set myTable = ActiveDocument.Tables(1)
    With myTable.Borders
        .InsideLineStyle = True
        .InsideColor = wdColorBrightGreen
        .OutsideColor = wdColorDarkTeal
    End With
End If

In diesem Beispiel wird ein 0,75 Punkt starker, dunkelroter doppelter Rahmen um den ersten Absatz im aktiven Dokument hinzugefügt.

With ActiveDocument.Paragraphs(1).Borders
    .OutsideLineStyle = wdLineStyleDouble
    .OutsideLineWidth = wdLineWidth075pt
    .OutsideColor = wdColorDarkRed
End With


Beispiel zur PageNumbers-Eigenschaft

In diesem Beispiel wird ein neues Dokument erstellt, anschließend werden der Fußzeile Seitenzahlen hinzugefügt.

Set myDoc = Documents.Add
With myDoc.Sections(1).Footers(wdHeaderFooterPrimary)
    .PageNumbers.Add PageNumberAlignment := wdAlignPageNumberCenter
End With


Beispiel zur Parent-Eigenschaft

In diesem Beispiel wird die Variable myObject als übergeordnetes Objekt des Bookmarks-Objekts festgelegt. Im Meldungsfeld wird der Name des Objekttyps von myObject (Document) angezeigt.

Set myObject = ActiveDocument.Bookmarks.Parent
MsgBox TypeName(myObject)

In diesem Beispiel wird für die Variable myRange die Zelle eins in Tabelle eins im aktiven Dokument festgelegt. Die Breite dieser Zelle wird auf 36 Punkt geändert, und die Rahmenformatierung aus der Tabelle entfernt.

Set myRange = ActiveDocument.Tables(1).Cell(1, 1)
With myRange
    .SetWidth ColumnWidth:=36, RulerStyle:=wdAdjustNone
    .Parent.Borders.Enable = False
End With


Beispiel zur Path-Eigenschaft

Dieses Beispiel zeigt den Pfad und den Dateinamen des aktiven Dokuments an.

MsgBox ActiveDocument.Path & Application.PathSeparator & _
    ActiveDocument.Name

In diesem Beispiel wechselt der aktuelle Ordner in den Pfad, der die mit dem aktiven Dokument verbundene Vorlage enthält.

ChDir ActiveDocument.AttachedTemplate.Path

Dieses Beispiel zeigt den Pfad des ersten Add-Ins in der AddIns-Auflistung an.

If AddIns.Count >= 1 Then MsgBox AddIns(1).Path


Beispiel zur PreferredWidth-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Word die bevorzugte Breite als prozentualen Anteil einer Fensterbreite annimmt. Anschließend wird die bevorzugte Breite der ersten Tabelle im Dokument auf 50 Prozent der Fensterbreite festgelegt.

With ActiveDocument.Tables(1)
    .PreferredWidthType = wdPreferredWidthPercent
    .PreferredWidth = 50
End With


Beispiel zur Previous-Eigenschaft

In diesem Beispiel wird die Formatierung "Abstand vor" und "Abstand nach" für den Absatz unmittelbar vor der Markierung festgelegt.

Set myPara = Selection.Paragraphs(1).Previous
With myPara
    .SpaceAfter = 12
    .SpaceBefore = 6
End With

Wenn in diesem Beispiel die Markierung in einer Tabelle ist, wird der Inhalt der vorherigen Zeile markiert.

If Selection.Information(wdWithInTable) = True Then
    Selection.Rows(1).Previous.Select
End If

In diesem Beispiel wird im aktiven Dokument die Feldfunktion des vorletzten Feldes angezeigt.

Set aField = ActiveDocument _
    .Fields(ActiveDocument.Fields.Count).Previous
MsgBox "Field code = " & aField.Code


Beispiel zur Protected-Eigenschaft

In diesem Beispiel wird der Schutzstatus der Tastenkombination STRG+S angezeigt.

CustomizationContext = ActiveDocument.AttachedTemplate
MsgBox FindKey(BuildKeyCode(wdKeyControl, wdKeyS)).Protected

In diesem Beispiel wird eine Meldung angezeigt, wenn die Tastenkombination A geschützt ist.

CustomizationContext = NormalTemplate
If FindKey(BuildKeyCode(wdKeyA)).Protected = True Then
    MsgBox "The A key is protected"
End If


Beispiel zur Protect-Eigenschaft

In diesem Beispiel wird das aktive Dokument geschützt (nur Anmerkungen sind möglich) und dann verteilt.

ActiveDocument.HasRoutingSlip = True
With ActiveDocument.RoutingSlip
    .Subject = "Status Doc"
    .Protect = wdAllowOnlyComments
    .AddRecipient Recipient:="Kim Johnson"
End With
ActiveDocument.Route


Beispiel zur ReadOnly-Eigenschaft

In diesem Beispiel wird das aktive Dokument gespeichert, wenn es nicht schreibgeschützt ist.

If ActiveDocument.ReadOnly = False Then ActiveDocument.Save

In diesem Beispiel wird die zuletzt benutzte Datei als schreibgeschütztes Dokument geöffnet.

With RecentFiles(1)
    .ReadOnly = True
    .Open
End With


Beispiel zur ReplaceText-Eigenschaft

In diesem Beispiel wird die automatische Textersetzung in Word aktiviert. Bestimmter Text wird bei der Eingabe automatisch durch Einträge aus der AutoKorrektur-Liste ersetzt.

AutoCorrect.ReplaceText = True

In diesem Beispiel wird der Wert der ReplaceText-Eigenschaft umgeschaltet.

AutoCorrect.ReplaceText = Not AutoCorrect.ReplaceText


Beispiel zur ReturnAddress-Eigenschaft

In diesem Beispiel wird der Absender angezeigt, wenn ein Briefumschlag in das aktive Dokument aufgenommen wurde, sonst wird ein Meldungsfeld angezeigt.

On Error GoTo errhandler
addr = ActiveDocument.Envelope.ReturnAddress.Text
MsgBox Prompt:=addr, Title:="Return Address"
errhandler:
If Err = 5852 Then MsgBox _
    "The active document doesn't include an envelope"

In diesem Beispiel werden ein neues LetterContent-Objekt erstellt, die Absenderadresse und einige andere Eigenschaften festgelegt und dann der Brief-Assistent unter Verwendung der RunLetterWizard-Methode eingesetzt.

Dim oLC as New LetterContent
With oLC
    .LetterStyle = wdFullBlock
    .Salutation ="Hello"
    .SalutationType = wdSalutationOther
    .ReturnAddress = Application.UserAddress
End With
Documents.Add.RunLetterWizard LetterContent:=oLC


Beispiel zur RotationX-Eigenschaft

In diesem Beispiel werden drei identische projizierte Ellipsen dem aktiven Dokument hinzugefügt. Als Werte der Drehung um ihre x-Achsen werden Sie -30, 0 und 30 Grad festgelegt.

With ActiveDocument.Shapes
    With .AddShape(msoShapeOval, 30, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = -30
    End With
    With .AddShape(msoShapeOval, 90, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 0
    End With
    With .AddShape(msoShapeOval, 150, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 30
    End With
End With


Beispiel zur Row-Eigenschaft

In diesem Beispiel wird die Tabellenzeile schattiert dargestellt, die die Einfügemarke enthält.

If Selection.Information(wdWithInTable) = True Then
    Selection.Cells(1).Row.Shading.Texture = wdTexture10Percent
Else
    MsgBox "The insertion point is not in a table."
End If


Beispiel zur Salutation-Eigenschaft

In diesem Beispiel wird ein neues LetterContent-Objekt erstellt, das verschiedene Eigenschaften (einschließlich Text für die Anrede) festlegt, und anschließend wird der Brief-Assistent mit der RunLetterWizard-Methode aufgerufen.

Set myContent = New LetterContent
myContent.Salutation ="Hello,"
Documents.Add.RunLetterWizard LetterContent:=myContent


Beispiel zur Saved-Eigenschaft

In diesem Beispiel wird das aktive Dokument gespeichert, wenn es Änderungen enthält, die zuvor nicht gespeichert wurden.

If ActiveDocument.Saved = False Then ActiveDocument.Save

Dieses Beispiel ändert den Status der Vorlage Normal.dot in "unverändert". Wenn Änderungen an der Vorlage Normal.dot vorgenommen wurden, werden diese beim Beenden von Word nicht gespeichert.

NormalTemplate.Saved = True
Application.Quit


Beispiel zur Script-Eigenschaft

In diesem Beispiel wird die Skriptsprache angezeigt, die in der ersten Form des aktiven Dokuments verwendet wurde.

Set objScr = ActiveDocument.Shapes(1).Script
If Not (objScr is Nothing) Then
    Select Case objScr.Language
        Case msoScriptLanguageVisualBasic
            MsgBox "VBScript"
        Case msoScriptLanguageJava
            MsgBox "JavaScript"
        Case msoScriptLanguageASP
            MsgBox "Active Server Pages"
        Case Else
            Msgbox "Other scripting language"
    End Select
End If


Beispiel zur Sections-Eigenschaft

In diesem Beispiel wird die Seitenausrichtung für alle Abschnitte im aktiven Dokument gesetzt.

For Each sec In ActiveDocument.Sections
    sec.PageSetup.Orientation = wdOrientLandscape
Next sec

In diesem Beispiel wird ein neues Dokument erstellt und dann Text in das Dokument eingefügt. Daraufhin wird ein neuer Abschnitt im Dokument angelegt und Text in den neuen Abschnitt eingefügt.

Set myDoc = Documents.Add
Selection.InsertAfter "This is section 1."
Set mysec = myDoc.Sections.Add
mysec.Range.InsertAfter "This is section 2"


Beispiel zur Shape-Eigenschaft

In diesem Beispiel wird die Füllfarbe der Form geändert, die der erste Hyperlink im aktiven Dokument repräsentiert. Das Beispiel funktioniert nur, wenn der Hyperlink durch eine Form repräsentiert wird.

ActiveDocument.Hyperlinks(1).Shape.Fill.ForeColor.RGB = _
    RGB(255, 255, 0)


Beispiel zur ShowHidden-Eigenschaft

In diesem Beispiel wird das Dialogfeld Textmarke mit den sichtbaren und auch den ausgeblendeten Textmarken angezeigt.

ActiveDocument.Bookmarks.ShowHidden = True
Dialogs(wdDialogInsertBookmark).Show

In diesem Beispiel werden die Namen aller ausgeblendeten Textmarken in einem Dokument angezeigt. Ausgeblendete Textmarken in einem Word-Dokument beginnen mit einem Unterstrich ( _ ).

ActiveDocument.Bookmarks.ShowHidden = True
For Each aBookmark In ActiveDocument.Bookmarks
    If Left(aBookmark.Name, 1) = "_" Then MsgBox aBookmark.Name
Next aBookmark


Beispiel zur Side-Eigenschaft

In diesem Beispiel wird eine Ellipse dem aktiven Dokument hinzugefügt. Außerdem legen Sie fest, dass der Dokumenttext um die linke und rechte Seite des Quadrats umbrochen wird, das die Ellipse umgibt. Das Beispiel legt einen 0,1-Zoll-Rand zwischen dem Dokumenttext und der oberen, unteren, linken und rechten Seite des Quadrats fest.

Set myOval = ActiveDocument.Shapes.AddShape(msoShapeOval, _
    0, 0, 200, 50)
With myEll.WrapFormat
    .Type = wdWrapSquare
    .Side = wdWrapBoth
    .DistanceTop = InchesToPoints(0.1)
    .DistanceBottom = InchesToPoints(0.1)
    .DistanceLeft = InchesToPoints(0.1)
    .DistanceRight = InchesToPoints(0.1)
End With


Beispiel zur SingleList-Eigenschaft

Dieses Beispiel überprüft, ob sich nur eine Liste in der Auswahl befindet. Falls ja, wird die Standard-Dokumentvorlage für nummerierte Listen der Auswahl zugewiesen.

temp = Selection.Range.ListFormat.SingleList
If temp = True Then
  Selection.Range.ListFormat.ApplyNumberDefault
End If


Beispiel zur Size-Eigenschaft

In diesem Beispiel wird Text eingefügt und dann der Schriftgrad des sechsten Wortes im gewählten Text auf 20 Punkt eingestellt.

Selection.Collapse Direction:=wdCollapseEnd
With Selection.Range
    .Font.Reset
    .InsertBefore "This is a demonstration of font size."
    .Words(7).Font.Size = 20
End With

In diesem Beispiel wird der Schriftgrad des gewählten Textes ermittelt.

mySel = Selection.Font.Size
If mySel = wdUndefined Then
    MsgBox "There's a mix of font sizes in the selection."
Else
    MsgBox mySel & " points"
End If

In diesem Beispiel wird die Größe des Kontrollkästchens "Check1" im aktiven Dokument auf 14 Punkt eingestellt und dann das Kontrollkästchen als gewählt gesetzt.

With ActiveDocument.FormFields("Check1").CheckBox
    .AutoSize = False
    .Size = 14
    .Value = True
End With


Beispiel zur SpaceAfter-Eigenschaft

In diesem Beispiel wird der Abstand nach dem ersten Absatz im aktiven Dokument auf 12 Punkt gesetzt.

ActiveDocument.Paragraphs(1).SpaceAfter = 12

In diesem Beispiel wird bestimmt, dass das aktive Dokument drei Spalten hat. Ein Abstand von 0,5 Zoll wird nach der ersten Spalte festgelegt. Mit der InchesToPoints-Methode werden Zoll in Punkt umgewandelt.

With ActiveDocument.PageSetup.TextColumns
    .SetCount NumColumns:=3
    .LineBetween = False
    .EvenlySpaced = True
    .Item(1).SpaceAfter = InchesToPoints(0.5)
End With


Beispiel zur SpaceBefore-Eigenschaft

In diesem Beispiel wird der Abstand vor dem zweiten Absatz im aktiven Dokument auf 12 Punkt festgelegt.

ActiveDocument.Paragraphs(2).SpaceBefore = 12


Beispiel zur Split-Eigenschaft

In diesem Beispiel wird das aktive Fenster in zwei gleich große Fensterausschnitte geteilt.

ActiveDocument.ActiveWindow.Split = True

Wenn in diesem Beispiel das Fenster Dokument1 geteilt ist, wird der aktive Ausschnitt geschlossen.

If Windows("Document1").Split = True Then
    Windows("Document1").ActivePane.Close
End If


Beispiel zur Start-Eigenschaft

In diesem Beispiel werden die Anfangsposition des zweiten Absatzes und die Endposition des vierten Absatzes im aktiven Dokument zurückgegeben. Die Zeichenpositionen werden zum Erstellen des Bereichs myRange verwendet.

pos = ActiveDocument.Paragraphs(2).Range.Start
pos2 = ActiveDocument.Paragraphs(4).Range.End
Set myRange = ActiveDocument.Range(Start:=pos, End:=pos2)

In diesem Beispiel wird die Länge der Markierung ermittelt, indem die Anfangs- und die Endzeichenposition verglichen werden.

SelLength = Selection.End - Selection.Start

In diesem Beispiel wird die Anfangsposition von myRange ein Zeichen nach rechts verschoben (dadurch wird die Größe des Bereichs um ein Zeichen verkleinert).

Set myRange = Selection.Range
myRange.SetRange Start:=myRange.Start + 1, End:=myRange.End


Beispiel zur Status-Eigenschaft

Wenn das aktive Dokument mit einer Verteilerliste versehen ist, wird in diesem Beispiel eine Meldung mit dem Status der Verteilung angezeigt.

If ActiveDocument.HasRoutingSlip = True Then
    Select Case ActiveDocument.RoutingSlip.Status
        Case wdNotYetRouted
            MsgBox "The document hasn't been routed yet."
        Case wdRouteInProgress
            MsgBox "Routing is in progress."
        Case wdRouteComplete
            MsgBox "Routing is complete."
    End Select
End If

In diesem Beispiel wird die Verteilerliste für Verkäufe.doc zurückgesetzt, wenn die Verteilung beendet ist.

With Documents("Sales.doc").RoutingSlip
    If .Status = wdRouteComplete Then
        .Reset
    Else
        MsgBox "Cannot reset routing; not yet complete."
    End If
End With


Beispiel zur Style-Eigenschaft

In diesem Beispiel wird die Formatvorlage zurückgegeben, die dem aktuellen Verfasser von nicht gesendeten Antworten, Weiterleitungen und neuen E-Mail-Nachrichten zugeordnet ist, und der Name der dieser Formatvorlage zugeordneten Schriftart angezeigt.

Set MyEmailStyle = _
    ActiveDocument.Email.CurrentEmailAuthor.Style
Msgbox MyEmailStyle.Font.Name

In diesem Beispiel werden die Formatvorlagen aller Absätze im aktiven Dokument zurückgegeben.

For Each para in ActiveDocument.Paragraphs
    MsgBox para.Style
Next para

In diesem Beispiel werden die Formatvorlagen aller Zeichen in der Markierung zurückgegeben. Jedes Element in der Characters-Auflistung ist ein Range-Objekt.

For each c in Selection.Characters
    MsgBox c.Style
Next c

Dieses Beispiel weist allen Absätzen im aktiven Dokument abwechselnd die Formatvorlagen Überschrift 3 und Normal zu.

For i = 1 To ActiveDocument.Paragraphs.Count
    If i Mod 2 = 0 Then
        ActiveDocument.Paragraphs(i).Style = wdStyleNormal
    Else: ActiveDocument.Paragraphs(i).Style = wdStyleHeading3
    End If
Next i

Dieses Beispiel sucht im aktiven Dokument nach allen Vorkommen der Formatvorlage Überschrift 1 und ersetzt sie durch die Formatvorlage Überschrift 2.

With ActiveDocument.Content.Find
    .ClearFormatting
    .Style = wdStyleHeading1
    .Replacement.ClearFormatting
    .Replacement.Style = wdStyleHeading2
    .Execute FindText:="", ReplaceWith:="", _
        Replace:=wdReplaceAll, Format:=True
End With


Beispiel zur TablesOfAuthorities-Eigenschaft

In diesem Beispiel wird am Anfang des Dokuments Sales.doc ein Rechtsgrundlagenverzeichnis eingefügt. Das Rechtsgrundlagenverzeichnis enthält Einträge aller Kategorien.

Set myRange = Documents("Sales.doc").Range(Start:=0, End:=0)
Documents("Sales.doc").TablesOfAuthorities.Add Range:=myRange, _
    Category:=0, Passim:=True, IncludeCategoryHeader:=True

In diesem Beispiel werden alle Rechtsgrundlagenverzeichnisse im aktiven Dokument aktualisiert.

For Each myTOA In ActiveDocument.TablesOfAuthorities
    myTOA.Update
Next myTOA


Beispiel zur Tables-Eigenschaft

In diesem Beispiel wird im aktiven Dokument eine 5x5 Tabelle erstellt und ihr dann ein vordefiniertes Format zugewiesen.

Selection.Collapse Direction:=wdCollapseStart
Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
NumRows:=5, NumColumns:=5)
myTable.AutoFormat Format:=wdTableFormatClassic2

In diesem Beispiel werden im aktiven Dokument in die erste Spalte der ersten Tabelle Zahlen und Text eingefügt.

num = 90
For Each acell In ActiveDocument.Tables(1).Columns(1).Cells
    acell.Range.Text = num & " Sales"
    num = num + 1
Next acell


Beispiel zur Texture-Eigenschaft

In diesem Beispiel wird ein Bereich festgelegt, der sich auf den ersten Absatz im aktiven Dokument bezieht und mit einer Rasterstruktur versehen wird.

Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.Shading.Texture = wdTextureCross

In diesem Beispiel wird eine Tabelle an der Einfügemarke eingefügt, danach wird die erste Zeile in der Tabelle mit einer vertikalen Linienstruktur versehen.

Selection.Collapse Direction:=wdCollapseStart
Set myTable = ActiveDocument.Tables.Add(Range:=Selection.Range, _
    NumRows:=2, NumColumns:=2)
myTable.Rows(1).Shading.Texture = wdTextureVertical

In diesem Beispiel wird dem ersten Wort im aktiven Dokument eine 10%ige Schattierung zugewiesen.

ActiveDocument.Words(1).Shading.Texture = wdTexture10Percent


Beispiel zur Text-Eigenschaft

In diesem Beispiel wird der Text in der Markierung angezeigt. Wenn nichts markiert ist, wird das Zeichen angezeigt, das auf die Einfügemarke folgt.

MsgBox Selection.Text

In diesem Beispiel wird das erste Wort im aktiven Dokument durch "Dear" ersetzt.

Set myRange = ActiveDocument.Words(1)
myRange.Text = "Dear "

In diesem Beispiel werden in ein neues Dokument 10 Textzeilen eingefügt.

Documents.Add
For i = 1 To 10
    Selection.Text = "Line" & Str(i) & Chr(13)
    Selection.MoveDown Unit:=wdParagraph, Count:=1
Next i

In diesem Beispiel wird im aktiven Dokument "Hello" durch "Goodbye" ersetzt.

Set myRange = ActiveDocument.Content
With myRange.Find
    .ClearFormatting
    .Replacement.ClearFormatting
    .Text = "Hello"
    .Replacement.Text = "Goodbye"
    .Execute Replace:=wdReplaceAll
End With


Beispiel zur Top-Eigenschaft

In diesem Beispiel wird das Anwendungsfenster von Word 100 Punkt von der Oberkante des Bildschirms positioniert.

Application.WindowState = wdWindowStateNormal
Application.Top = 100

In diesem Beispiel wird der Rechner gestartet, und sein Fenster wird 100 Punkt von der Oberkante des Bildschirms positioniert.

Shell "Calc.exe"
With Tasks("Calculator")
    .WindowState = wdWindowStateNormal
    .Top = 100
End With

In diesem Beispiel wird 1 Zoll vom oberen Seitenrand als vertikale Position der ersten Form im aktiven Dokument festgelegt.

With ActiveDocument.Shapes(1)
    .RelativeVerticalPosition = wdRelativeVerticalPositionPage
    .Top = InchesToPoints(1)
End With

In diesem Beispiel wird 1 Zoll vom oberen Rand der Seite als vertikale Position der ersten und zweiten Form im aktiven Dokument festgelegt.

With ActiveDocument.Shapes.Range(Array(1, 2))
    .RelativeVerticalPosition = wdRelativeVerticalPositionPage
    .Top = InchesToPoints(1)
End With


Beispiel zur Transparency-Eigenschaft

In diesem Beispiel wird der Schatten von Form drei in myDocument auf halbdurchsichtiges Rot festgelegt. Wenn die Form noch keinen Schatten hat, wird ihr in diesem Beispiel einer hinzugefügt.

Set myDocument = ActiveDocument
With myDocument.Shapes(3).Shadow
    .Visible = True
    .ForeColor.RGB = RGB(255, 0, 0)
    .Transparency = 0.5
End With


Beispiel zur Underline-Eigenschaft

In diesem Beispiel wird das vierte Wort im aktiven Dokument doppelt unterstrichen formatiert.

ActiveDocument.Words(4).Underline = wdUnderlineDouble

In diesem Beispiel wird die Schriftart des gewählten Textes einfach unterstrichen formatiert.

If Selection.Type = wdSelectionNormal Then
    Selection.Font.Underline = wdUnderlineSingle
Else
    MsgBox "You need to select some text."
End If


Beispiel zur Version-Eigenschaft

In diesem Beispiel wird die Versionsnummer von Word in einem Meldungsfeld angezeigt.

Msgbox "The version of Word is " & Application.Version

In diesem Beispiel wird die Versionsnummer des Betriebssystems in einem Meldungsfeld angezeigt.

Msgbox "The system version is " & System.Version


Beispiel zur View-Eigenschaft

In diesem Beispiel wird das aktive Fenster in Ganzer-Bildschirm-Ansicht umgeschaltet.

ActiveDocument.ActiveWindow.View.FullScreen = True

In diesem Beispiel werden alle nicht druckbaren Zeichen für Ausschnitte angezeigt, die mit dem ersten Fenster in der Windows-Auflistung verbunden sind.

For Each myPane In Windows(1).Panes
    myPane.View.ShowAll = True
Next myPane

In diesem Beispiel werden für jedes Fenster in der Windows-Auflistung Ansicht-Optionen eingestellt.

For Each myWindow In Windows
    With myWindow.View
        .ShowTabs = True
        .ShowParagraphs = True
        .Type = wdNormalView
    End With
Next myWindow


Beispiel zur Width-Eigenschaft

In diesem Beispiel wird in einem neuen Dokument eine 5x5-Tabelle erstellt und dann die Breite der ersten Zelle auf 1,5 Zoll festgelegt.

Set newDoc = Documents.Add
Set myTable = _
    newDoc.Tables.Add(Range:=Selection.Range, NumRows:=5, _
    NumColumns:=5)
myTable.Cell(1, 1).Width = InchesToPoints(1.5)

In diesem Beispiel wird die Breite (in Zoll) der Zelle zurückgegeben, die die Einfügemarke enthält.

If Selection.Information(wdWithInTable) = True Then
    MsgBox PointsToInches(Selection.Cells(1).Width)
End If

In diesem Beispiel wird der Abschnitt, der die Markierung enthält, dreispaltig formatiert. Die Schleife For Each...Next wird zum Anzeigen der Breite jeder Spalte in der TextColumns-Auflistung verwendet.

Selection.PageSetup.TextColumns.SetCount NumColumns:=3
For Each acol In Selection.PageSetup.TextColumns
    MsgBox "Width= " & PointsToInches(acol.Width)
Next acol

In diesem Beispiel werden die Breite und Höhe des Mircrosoft Word-Anwendungsfensters festgelegt.

With Application
    .WindowState = wdWindowStateNormal
    .Width = 500
    .Height = 400
End With

In diesem Beispiel wird die Breite des angegebenen Frameset-Objekts auf 25 Prozent der Fensterbreite festgelegt.

With ActiveWindow.ActivePane.Frameset
    .WidthType = wdFramesetSizeTypePercent
    .Width = 25
End With


Beispiel zur Windows-Eigenschaft

In diesem Beispiel wird für das aktive Dokument die Anzahl der Fenster sowohl vor als auch nach Ausführung der NewWindow-Methode angezeigt.

MsgBox Prompt:= ActiveDocument.Windows.Count & " window(s)", _
    Title:= ActiveDocument.Name
ActiveDocument.ActiveWindow.NewWindow
MsgBox Prompt:= ActiveDocument.Windows.Count & " windows", _
    Title:= ActiveDocument.Name

In diesem Beispiel werden alle geöffneten Fenster so angeordnet, dass sie sich nicht überlappen.

Windows.Arrange ArrangeStyle:=wdTiled


Beispiel zur Word-Eigenschaft

In diesem Beispiel wird eine Liste von Synonymen für die erste Bedeutung des dritten Worts im aktiven Dokument zurückgegeben.

Set mySynObj = ActiveDocument.Words(3).SynonymInfo
SList = mySynObj.SynonymList(1)
For i = 1 To UBound(SList)
    Msgbox "A synonym for " & mySynObj.Word & " is " & SList(i)
Next i

In diesem Beispiel vergewissert man sich, dass das Wort oder der Ausdruck, das/der nachgeschlagen wurde, nicht leer ist. Wenn das Wort oder der Ausdruck nicht leer ist, wird in dem Beispiel eine Liste von Synonymen für die erste Bedeutung des Worts oder Ausdrucks zurückgegeben.

Set mySynObj = Selection.Range.SynonymInfo
If mySynObj.Word = "" Then
    Msgbox "Please select a word or phrase"
Else
    SList = mySynObj.SynonymList(1)
    For i = 1 To UBound(SList)
        Msgbox "A synonym for " & mySynObj.Word & " is " & SList(i)
    Next i
End If


Beispiel zur Wrap-Eigenschaft

Im folgenden Beispiel wird das Dokument nach dem Wort "Aspirin" in Vorwärtsrichtung durchsucht. Wenn das Ende des Dokuments erreicht wird, wird die Suche am Anfang des Dokuments fortgesetzt. Das Wort "Aspirin" wird markiert, wenn es gefunden wird.

With Selection.Find
    .Forward = True
    .ClearFormatting
    .MatchWholeWord = True
    .MatchCase = False
    .Wrap = wdFindContinue
    .Execute FindText:="aspirin"
End With


Beispiel zur Zoom-Eigenschaft

In diesem Beispiel wird der Zoom-Prozentwert jedes geöffneten Fensters auf 100 Prozent geändert.

For Each myWindow In Windows
    myWindow.View.Zoom.Percentage = 100
Next myWindow

In diesem Beispiel wird der Zoom-Prozentwert des aktiven Fensters so geändert, dass die gesamte Breite des Textes sichtbar ist.

ActiveDocument.ActiveWindow.View.Zoom.PageFit = wdPageFitBestFit


Microsoft Word-Objekte (AutoCorrect)

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (Cells)

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Documents)

Documents-Auflistung (Document-Objekt)

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts
Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts
Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts
Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Find)

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (FormFields)

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (Paragraphs)

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Range)

Range-Objekt

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Rows)

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (Selection)

Selection-Objekt

Pfeil nach rechts
Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts
Pfeil nach rechts

Pfeil nach rechts

Pfeil nach rechts
Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Styles)

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (Tables)

Pfeil nach rechts
Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil


Microsoft Word-Objekte (Templates)

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt


Microsoft Word-Objekte (Windows)

Pfeil nach rechts

Pfeil nach rechts

Legende

gelbes Feld Objekt und Auflistung
blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie zum Erweitern des Diagramms auf den roten Pfeil