Neue Funktionen für Microsoft Excel 2000-Entwickler

Das Microsoft Excel 2000 Visual Basic für Applikationen-Objektmodell enthält umfangreiche Änderungen, um die neuen und verbesserten Features von Excel zu unterstützen. Aus Gründen der Abwärtskompatibilität wurden die ersetzten Komponenten ausgeblendet und nicht entfernt. Das bedeutet, dass sie im Objektbrowser standardmäßig nicht angezeigt werden, jedoch alter Code, der die ausgeblendeten Komponenten verwendet, ohne Änderungen einwandfrei funktioniert. Beim Schreiben von neuem Code sollten Sie jedoch ausschließlich die neuen Objekte, Eigenschaften und Methoden verwenden.

Die wesentlichen Änderungen von Visual Basic für Applikationen in Microsoft Excel 2000 sind in der folgenden Tabelle aufgeführt und erläutert.

Feature | Beschreibung
ADO | Bietet eine direkte Schnittstelle für den Datenbankzugriff. ADO bildet nun die bevorzugte Methode für den Datenzugriff in Excel.
Anzeigen der Einheitenbeschriftung | Bietet Einheitenbeschriftungen, um die Lesbarkeit von Teilstrichbeschriftungen auf Diagrammachsen zu erleichtern.
Component Object Model (COM)-Add-Ins | Bietet eine konsistente Benutzeroberfläche, in der Entwickler in jeder Programmiersprache, die COM unterstützt (z. B. Microsoft Visual C++, Visual J++ und Visual Basic) Add-Ins erstellen können.
Digitale Signatur | Bietet eine Möglichkeit, festzustellen, ob das Visual Basic für Applikationen-Projekt der Arbeitsmappe digital signiert wurde.
Mehrsprachige Bearbeitung | Bietet eine verbesserte mehrsprachige Benutzeroberfläche und Bearbeitungsfeatures sowie verbesserte phonetische Textverarbeitung zur Unterstützung ostasiatischer Sprachen.
Microsoft Office-E-Mail | Bietet integrierte E-Mail-Möglichkeiten.
Microsoft Office Web Components | Bietet eine Möglichkeit, Tabellenblätter, Diagramme und PivotTable-Berichte als interaktive Webseiten zu speichern. Weitere Informationen zum Einsatz dieser Komponenten in Benutzerformularen und Dialogfeldern finden Sie unter Verwenden von Microsoft Office Web Components in Formularen.
OLAP-Datenquellen für PivotTable- und PivotChart-Berichte | Bietet Möglichkeiten zum Anzeigen und Analysieren von Daten aus Online Analytical Processing (OLAP)-Datenquellen.
PivotChart-Berichte | Bietet eine Schnittstelle zu PivotChart-Berichten, die auf Daten aus PivotTable-Berichten basieren.
Speichern im Web und Office-Webbearbeitung | Bietet Features zum Erstellen, Speichern und Bearbeiten von Webseiten. Bietet ferner eine Schnittstelle zum Speichern von Microsoft Office Web Components.
Textdatei- und Webabfragen | Bietet neue Verbesserungen zur Abfrage von Webseiten und zum Importieren von Textdateien.
Visual Basic für Applikationen 6.0 | Bietet die neuesten Sprachfeatures sowie ungebundene Benutzerformulare und Unterstützung für zusätzliche ActiveX-Steuerelemente.
Webseitenskripts | Bietet Skriptfeatures auf Webseiten für HTML-basierte Clientlösungen.

Weitere Informationen finden Sie in den folgenden Themen:

Ausgeblendete Eigenschaften und Methoden

Ausgeblendete Objekte

Methoden mit neuen, geänderten oder gelöschten Argumenten

Neue Eigenschaften (alphabetische Liste)

Neue Eigenschaften (nach Objekten geordnet)

Neue Ereignisse

Neue Methoden (alphabetische Liste)

Neue Methoden (nach Objekten geordnet)

Neue Objekte

Sprachspezifische Eigenschaften, Methoden und Funktionen


Aktivieren einer Arbeitsmappe

Wenn Sie eine Arbeitsmappe mit Hilfe der Activate-Methode aktivieren, wird sie in das aktive Fenster gelegt. Die folgende Prozedur aktiviert die geöffnete Arbeitsmappe "MyBook.xls"

Sub MakeActive()
    Workbooks("MyBook.xls").Activate
End Sub


Erstellen einer neuen Arbeitsmappe

Um eine neue Arbeitsmappe in Visual Basic zu erstellen, können Sie die Add-Methode verwenden, wie in der folgenden Prozedur dargestellt. Microsoft Excel gibt der Arbeitsmappe automatisch den Namen MappeN, wobei N die nächste verfügbare Nummer darstellt. Die neue Arbeitsmappe wird zur aktiven Arbeitsmappe.

Sub AddOne()
    Workbooks.Add
End Sub

Besser erstellt man eine neue Arbeitsmappe, indem man sie einer Objektvariablen zuweist. Im folgenden Beispiel wird das Workbook-Objekt, das von der Add-Methode zurückgegeben wird, der Objektvariablen neueMappe zugewiesen. Anschließend werden einige Eigenschaften von neueMappe festgelegt. Mit Hilfe der Objektvariable können Sie die neue Arbeitsmappe auf leichte Weise steuern.

Sub AddNew()
Set newBook = Workbooks.Add
    With newBook
        .Title = "1995 Sales"
        .Subject = "Sales"
        .SaveAs filename:="95Sales.xls"
    End With
End Sub


Öffnen einer Arbeitsmappe

Wenn Sie eine Arbeitsmappe mit Hilfe der Open-Methode öffnen, wird sie ein Element der Workbooks-Auflistung. In der folgenden Prozedur wird die Arbeitsmappe "MyBook.xls" geöffnet, die sich im Ordner "MyFolder" befindet.

Sub OpenUp()
    Workbooks.Open("C:\MyFolder\MyBook.xls")
End Sub


Verweisen auf Blätter mit Indexnummern

Eine Indexnummer ist eine fortlaufende Nummer, die einem Blatt bei Blättern des gleichen Typs auf der Grundlage der Position seines Registers (von links gezählt) zugewiesen wird. Die folgende Prozedur verwendet die Worksheets-Eigenschaft, um das erste Tabellenblatt in der aktiven Arbeitsmappe zu aktivieren.

Sub FirstOne()
    Worksheets(1).Activate
End Sub

Wenn Sie mit allen Arten von Blättern (Tabellen-, Diagramm-, Modul- und Dialogblättern) arbeiten möchten, verwenden Sie die Sheets-Eigenschaft. Die folgende Prozedur aktiviert das vierte Blatt der Arbeitsmappe.

Sub FourthOne()
    Sheets(4).Activate
End Sub

Anmerkung Die Indexreihenfolge kann sich ändern, wenn Sie Blätter verschieben, hinzufügen oder löschen.


Verweisen auf Blätter mit Namen

Mit den Eigenschaften Worksheets und Charts können Sie bei der Identifizierung von Blättern deren Namen verwenden. Die folgenden Anweisungen aktivieren verschiedene Blätter in der aktiven Arbeitsmappe.

Worksheets("Sheet1").Activate
Charts("Chart1").Activate
DialogSheets("Dialog1").Activate

Mit der Sheets-Eigenschaft können Sie auf ein Tabellen-, Diagramm-, Modul- oder Dialogblatt zugreifen; sie sind alle in der Sheets-Auflistung enthalten. Im folgenden Beispiel wird das Blatt Chart1 der aktiven Arbeitsmappe aktiviert.

Sub ActivateChart()
    Sheets("Chart1").Activate
End Sub

Anmerkung In ein Tabellenblatt eingebettete Diagramme sind Elemente der ChartObjects-Auflistung; dagegen gehören Diagramme auf separaten Blättern zur Charts-Auflistung.


Speichern von Dokumenten als Webseiten

In Microsoft Excel 2000 können Sie eine Arbeitsmappe, ein Tabellenblatt, ein Diagramm, einen Bereich, eine Abfragetabelle, einen PivotTable-Bericht, einen Druckbereich oder einen AutoFilter-Bereich in einer Webseite speichern. Darüber hinaus können Sie HTML-Dateien direkt in Excel bearbeiten.

Speichern eines Dokuments als Webseite

Das Speichern eines Dokuments als Webseite stellt den Vorgang dar, bei dem eine HTML-Datei und alle Unterstützungsdateien erstellt und gespeichert werden. Verwenden Sie dazu, wie im folgenden Beispiel gezeigt, die SaveAs-Methode, in dem die aktive Arbeitsmappe als C:\Reports\myfile.htm gespeichert wird.

ActiveWorkbook.SaveAs _
    Filename:="C:\Reports\myfile.htm", _
    FileFormat:=xlHTML

Anpassen der Webseite

Sie können das Erscheinungsbild, den Inhalt, die Unterstützung für Lese- und Schreibzugriff, Grafikformate, Bildschirmauflösung, Dateiorganisation und Codierung des HTML-Dokuments anpassen, indem Sie die Eigenschaften des DefaultWebOptions-Objekts und des WebOptions-Objekts festlegen. Das DefaultWebOptions-Objekt enthält die Eigenschaften auf Anwendungsebene. Diese Einstellungen werden von allen gleichnamigen Eigenschafteneinstellungen auf Arbeitsmappenebene überschrieben (diese befinden sich im WebOptions-Objekt).

Nach dem Festlegen der Attribute können Sie mit der Publish-Methode die Arbeitsmappe, das Tabellenblatt, das Diagramm, den Bereich, die Abfragetabelle, den PivotTable-Bericht, den Druckbereich oder den AutoFilter-Bereich in einer Webseite speichern. In dem folgenden Beispiel werden verschiedene Eigenschaften auf Anwendungsebene und anschließend die AllowPNG-Eigenschaft der aktiven Arbeitsmappe festgelegt, die die Standardeinstellung auf Anwendungsebene überschreibt. Schließlich wird der Bereich in dem Beispiel als C:\Reports\1998_Q1.htm gespeichert.

With Application.DefaultWebOptions
    .RelyonVML = True
    .AllowPNG = True
    .PixelsPerInch = 96
End With
With ActiveWorkbook
    .WebOptions.AllowPNG = False
    With .PublishObjects(1)
        .FileName = "C:\Reports\1998_Q1.htm"
        .Publish
    End With
End With

Sie können die Dateien auch direkt auf einem Webserver speichern. In dem folgenden Beispiel wird ein Bereich auf einem Webserver gespeichert, wobei die Webseite die URL-Adresse http://example.homepage.com/annualreport.htm erhält.

With ActiveWorkbook
    With .WebOptions
        .RelyonVML = True
        .PixelsPerInch = 96
    End With
    With .PublishObjects(1)
        .FileName = _
        "http://example.homepage.com/annualreport.htm"
        .Publish
    End With
End With

Öffnen eines HTML-Dokuments in Microsoft Excel

Zum Bearbeiten eines HTML-Dokuments in Excel öffnen Sie das Dokument zunächst mit der Open-Methode. In dem folgenden Beispiel wird die Datei C:\Reports\1997_Q4.htm zum Bearbeiten geöffnet.

Workbooks.Open Filename:="C:\Reports\1997_Q4.htm"

Nach dem Öffnen der Datei können Sie das Erscheinungsbild, den Inhalt, die Unterstützung für Lese- und Schreibzugriff, Grafikformate, Bildschirmauflösung, Dateiorganisation und Codierung des HTML-Dokuments anpassen, indem Sie die Eigenschaften des DefaultWebOptions- und des WebOptions-Objekts festlegen.


Verweisen auf Zellen und Bereiche

Eine häufig in Visual Basic durchzuführende Aufgabe umfasst das Festlegen einer Zelle oder eines Zellbereichs und deren Bearbeitung, wie z. B. das Eingeben einer Formel oder das Ändern des Formats. Gewöhnlich können Sie dies in einer einzigen Anweisung durchführen, die sowohl den Bereich identifiziert als auch eine Eigenschaft ändert bzw. eine Methode anwendet.

Ein Range-Objekt in Visual Basic kann entweder eine einzelne Zelle oder einen Zellbereich enthalten. Die folgenden Themen stellen die gebräuchlichsten Vorgehensweisen für das Identifizieren und Arbeiten mit Range-Objekten dar.

Wie möchten Sie auf Zellen verweisen?

In der A1-Schreibweise auf Zellen und Bereiche verweisen

Mit Indexnummern auf Zellen verweisen

Auf Zeilen und Spalten verweisen

In abgekürzter Schreibweise auf Zellen verweisen

Auf benannte Bereiche verweisen

Auf Zellen mit relativem Bezug zu anderen Zellen verweisen

Mit einem Range-Objekt auf Zellen verweisen

Auf alle Zellen in einem Tabellenblatt verweisen

Auf mehrere Bereiche verweisen


Schleifendurchlauf durch einen Zellbereich

Wenn Sie Visual Basic verwenden, ist es häufig erforderlich, dass Sie denselben Anweisungsblock für jede Zelle in einem Zellbereich ausführen. Zu diesem Zweck kombinieren Sie eine Schleifen-Anweisung mit einer oder mehreren Methoden, um jeweils eine Zelle anzugeben, und führen den Vorgang aus.

Eine Möglichkeit, einen Schleifendurchlauf durch einen Zellbereich auszuführen, besteht darin, die For...Next-Schleife zusammen mit der Cells-Eigenschaft zu verwenden. Durch Verwenden der Cells-Eigenschaft können Sie Indexnummern für Zellen durch den Schleifenzähler (bzw. sonstige Variablen oder Ausdrücke) ersetzen. Im folgenden Beispiel wird der Zeilenindex durch die Variable Zähler ersetzt. In dieser Prozedur werden die Zellen im Zellbereich C1:C20 in einer Schleife durchlaufen, und alle Zahlen, deren Absolutwert unter 0,01 liegt, auf 0 (Null) gesetzt.

Sub RoundToZero1()
    For counter = 1 To 20
        Set curCell = Worksheets("Sheet1").Cells(counter, 3)
        If Abs(curCell.Value) < 0.01 Then curCell.Value = 0
    Next counter
End Sub

Eine weitere einfache Möglichkeit zum Ausführen eines Schleifendurchlaufs durch einen Zellbereich besteht darin, die For Each...Next-Schleife zusammen mit einer von der Range-Methode zurückgegebenen Auflistung von Zellen zu verwenden. Visual Basic legt bei jedem Ausführen der Schleife automatisch eine Objektvariable für die nächste Zelle fest. In der folgenden Prozedur werden die Zellen im Zellbereich C1:C20 in einer Schleife durchlaufen, und alle Zahlen, deren Absolutwert unter 0,01 liegt, auf 0 (Null) gesetzt.

Sub RoundToZero2()
    For Each c In Worksheets("Sheet1").Range("A1:D10").Cells
        If Abs(c.Value) < 0.01 Then c.Value = 0
    Next
End Sub

Wenn Sie die Begrenzungen des Bereichs, den Sie in einer Schleife durchlaufen möchten, nicht kennen, können Sie die CurrentRegion-Eigenschaft verwenden, um den Bereich zurückzugeben, der die aktive Zelle umgibt. In der folgenden in einem Tabellenblatt ausgeführten Prozedur wird z. B. ein Schleifendurchlauf durch den Zellbereich ausgeführt, der die aktive Zelle umgibt, und alle Zahlen, deren Absolutwert unter 0,01 liegt, auf 0 (Null) gesetzt.

Sub RoundToZero3()
    For Each c In ActiveCell.CurrentRegion.Cells
        If Abs(c.Value) < 0.01 Then c.Value = 0
    Next
End Sub


Markieren und Aktivieren von Zellen

Bei der Arbeit mit Microsoft Excel markieren Sie gewöhnlich eine Zelle bzw. Zellen und führen dann eine Aktion aus, wie z. B. das Formatieren der Zellen oder das Eingeben von Werten in diese Zellen. In Visual Basic ist es in der Regel nicht notwendig, Zellen vor einer Änderung zu markieren.

Wenn Sie in Visual Basic z. B. eine Formel in Zelle D6 eingeben möchten, brauchen Sie den Bereich D6 nicht zu markieren. Sie müssen nur das Range-Objekt zurückgeben und dann für die gewünschte Formel die Formula-Eigenschaft festlegen, wie im folgenden Beispiel gezeigt wird.

Sub EnterFormula()
    Worksheets("Sheet1").Range("D6").Formula = "=SUM(D2:D5)"
End Sub

Weitere Beispiele zur Verwendung anderer Methoden, Zellen ohne vorherige Markierung zu steuern, finden Sie unter Auf Zellen und Bereiche verweisen.

Verwenden der Select-Methode und der Selection-Eigenschaft

Die Select-Methode aktiviert Blätter und darin enthaltene Objekte; die Selection-Eigenschaft gibt ein Objekt zurück, das für die aktuelle Markierung im aktiven Blatt der aktiven Arbeitsmappe steht. Vor einem erfolgreichen Verwenden der Selection-Eigenschaft müssen Sie eine Arbeitsmappe aktivieren, ein Blatt aktivieren bzw. auswählen und anschließend mit der Select-Methode einen Bereich (oder ein anderes Objekt) markieren.

Der Makro-Recorder erstellt häufig Makros, die die Select-Methode und die Selection-Eigenschaft verwenden. Die folgende Sub-Prozedur wurde mit dem Makro-Recorder erstellt und veranschaulicht, wie Select und Selection gemeinsam angewendet werden.

Sub Macro1()
    Sheets("Sheet1").Select
    Range("A1").Select
    ActiveCell.FormulaR1C1 = "Name"
    Range("B1").Select
    ActiveCell.FormulaR1C1 = "Address"
    Range("A1:B1").Select
    Selection.Font.Bold = True
End Sub

Im folgenden Beispiel wird die gleiche Aufgabe ohne vorheriges Aktivieren oder Markieren des Tabellenblatts bzw. der Zellen durchgeführt.

Sub Labels()
    With Worksheets("Sheet1")
        .Range("A1") = "Name"
        .Range("B1") = "Address"
        .Range("A1:B1").Font.Bold = True
    End With
End Sub

Markieren von Zellen im aktiven Tabellenblatt

Wenn Sie zur Markierung von Zellen die Select-Methode verwenden, bedenken Sie, dass Select nur im aktiven Tabellenblatt funktioniert. Beim Ausführen Ihrer Sub-Prozedur vom Modul aus funktioniert die Select -Methode nur dann, wenn die Prozedur das Tabellenblatt vor dem Verwenden der Select-Methode aktiviert. Als Beispiel kopiert die folgende Prozedur eine Zeile von Sheet1 in Sheet2 der aktiven Arbeitsmappe.

Sub CopyRow()
    Worksheets("Sheet1").Rows(1).Copy
    Worksheets("Sheet2").Select
    Worksheets("Sheet2").Rows(1).Select
    Worksheets("Sheet2").Paste
End Sub

Aktivieren einer Zelle innerhalb einer Markierung

Sie können zur Aktivierung einer Zelle innerhalb einer Markierung die Activate-Methode verwenden. Selbst wenn ein Zellbereich markiert ist, kann immer nur eine Zelle aktiv sein. Die folgende Prozedur markiert einen Bereich und aktiviert danach eine Zelle innerhalb des Bereichs, ohne die Markierung zu ändern.

Sub MakeActive()
    Worksheets("Sheet1").Activate
    Range("A1:D4").Select
    Range("B2").Activate
End Sub


Arbeiten mit 3D-Bereichen

Wenn Sie mit dem gleichen Bereich in mehr als einer Tabelle arbeiten, verwenden Sie die Array-Funktion, um zwei oder mehr Blätter zu markieren. Im folgenden Beispiel wird der Rahmen eines 3D-Zellbereichs formatiert.

Sub FormatSheets()
    Sheets(Array("Sheet2", "Sheet3", "Sheet5")).Select
    Range("A1:H1").Select
    Selection.Borders(xlBottom).LineStyle = xlDouble
End Sub

Im folgenden Beispiel wird die FillAcrossSheets-Methode angewendet, um sowohl Formate als auch Daten vom angegebenen Bereich in Sheet2 in die entsprechenden Bereiche in sämtlichen Tabellenblättern der aktiven Arbeitsmappe zu übertragen.

Sub FillAll()
    Worksheets("Sheet2").Range("A1:H1") _
        .Borders(xlBottom).LineStyle = xlDouble
    Worksheets.FillAcrossSheets (Worksheets("Sheet2") _
        .Range("A1:H1"))
End Sub


Arbeiten mit der aktiven Zelle

Die ActiveCell-Eigenschaft gibt ein Range-Objekt zurück, das die aktive Zelle darstellt. Sie können der aktiven Zelle jede beliebige Eigenschaft bzw. Methode eines Range-Objekts zuweisen, wie im folgenden Beispiel gezeigt wird.

Sub SetValue()
    Worksheets("Sheet1").Activate
    ActiveCell.Value = 35
End Sub

Anmerkung Sie können nur mit der aktiven Zelle arbeiten, wenn es sich bei dem Tabellenblatt um das aktive Blatt handelt.

Verschieben der aktiven Zelle

Zur Festlegung der aktiven Zelle können Sie die Activate-Methode verwenden. Die folgende Prozedur legt beispielsweise B5 als aktive Zelle fest und formatiert sie anschließend in fett.

Sub SetActive()
    Worksheets("Sheet1").Activate
    Worksheets("Sheet1").Range("B5").Activate
    ActiveCell.Font.Bold = True
End Sub

Anmerkung Um einen Zellbereich zu markieren, verwenden Sie die Select-Methode. Um eine einzelne Zelle als aktive Zelle festzulegen, verwenden Sie die Activate-Methode.

Sie können die Offset-Eigenschaft verwenden, um die aktive Zelle zu verschieben. Die folgende Prozedur fügt in die aktive Zelle des markierten Bereichs Text ein und verschiebt sie anschließend eine Zelle nach rechts, ohne die Markierung zu ändern.

Sub MoveActive()
    Worksheets("Sheet1").Activate
    Range("A1:D10").Select
    ActiveCell.Value = "Monthly Totals"
    ActiveCell.Offset(0, 1).Activate
End Sub

Markieren der die aktive Zelle umgebenden Zellen

Die CurrentRegion-Eigenschaft gibt einen von Leerzeilen und Leerspalten eingegrenzten Zellbereich zurück. Im folgenden Beispiel wird die Markierung um jene Zellen erweitert, die an die aktive Zelle grenzen und Daten enthalten. Dieser Bereich wird anschließend mit der Formatvorlage "Währung" formatiert.

Sub Region()
    Worksheets("Sheet1").Activate
    ActiveCell.CurrentRegion.Select
    Selection.Style = "Currency"
End Sub


Verwenden von ActiveX-Steuerelementen in Tabellenblättern

Dieses Thema behandelt spezielle Informationen zum Einsatz von ActiveX-Steuerelementen in Tabellenblättern und Diagrammblättern. Allgemeine Informationen zum Hinzufügen und Arbeiten mit Steuerelementen finden Sie unter Verwenden von ActiveX-Steuerelementen in einem Dokument und Erstellen eines benutzerdefinierten Dialogfelds.

Beachten Sie beim Arbeiten mit Steuerelementen in einem Tabellenblatt die folgenden Punkte.

  • Zusätzlich zu den für ActiveX-Steuerelementen verfügbaren Standardeigenschaften können in Microsoft Excel die folgenden Eigenschaften bei ActiveX-Steuerelementen verwendet werden: BottomRightCell, LinkedCell, ListFillRange, Placement, PrintObject, TopLeftCell und ZOrder.

    Diese Eigenschaften können über den Namen des ActiveX-Steuerelements festgelegt und zurückgegeben werden. In dem folgenden Beispiel erfolgt in dem Arbeitsmappenfenster ein Bildlauf so, dass sich CommandButton1 in der oberen linken Ecke befindet.

    Set t = Sheet1.CommandButton1.TopLeftCell
With ActiveWindow
    .ScrollRow = t.Row
    .ScrollColumn = t.Column
End With

  • Einige Methoden und Eigenschaften von Microsoft Excel Visual Basic werden deaktiviert, wenn ein ActiveX-Steuerelement aktiviert wird. Zum Beispiel kann die Sort-Methode nicht verwendet werden, wenn ein Steuerelement aktiv ist, so dass der folgende Code in einer Schaltflächenklick-Ereignisprozedur fehlschlägt (weil das Steuerelement weiterhin aktiv ist, nachdem der Benutzer darauf geklickt hat).
    Private Sub CommandButton1.Click
    Range("a1:a10").Sort Key1:=Range("a1")
End Sub

Sie können dieses Problem umgehen, indem Sie ein anderes Element im Tabellenblatt aktivieren, bevor Sie die fehlgeschlagene Eigenschaft oder Methode verwenden. Der folgende Code sortiert den Bereich beispielsweise:

Private Sub CommandButton1.Click
    Range("a1").Activate
    Range("a1:a10").Sort Key1:=Range("a1")
    CommandButton1.Activate
End Sub

  • Steuerelemente in einer Microsoft Excel-Arbeitsmappe, die in einem Dokument in einer anderen Anwendung eingebettet sind, funktionieren nicht, wenn der Benutzer zum Bearbeiten auf die Arbeitsmappe doppelklickt. Die Steuerelemente funktionieren, wenn der Benutzer mit der rechten Maustaste auf die Arbeitsmappe klickt und aus dem Kontextmenü den Befehl Open wählt.

  • Wenn eine Microsoft Excel-Arbeitsmappe im Dateiformat "Microsoft Excel 5.0/95-Arbeitsmappe" gespeichert wird, gehen die Informationen für ActiveX-Steuerelemente verloren.

  • Das Me-Schlüsselwort in einer Ereignisprozedur für ein ActiveX-Steuerelement in einem Tabellenblatt bezieht sich auf das Tabellenblatt und nicht auf das Steuerelement.

Hinzufügen von Steuerelementen mit Visual Basic

In Microsoft Excel werden ActiveX-Steuerelemente durch OLEObject-Objekte in der OLEObjects-Auflistung dargestellt (alle OLEObject-Objekte befinden sich ebenfalls in der Shapes-Auflistung). Um ein ActiveX-Steuerelement per Programm zu einem Tabellenblatt hinzuzufügen, verwenden Sie die Add-Methode der OLEObjects-Auflistung. In dem folgenden Beispiel wird eine Befehlsschaltfläche zu der ersten Arbeitsmappe hinzugefügt.

Worksheets(1).OLEObjects.Add "Forms.CommandButton.1", _
    Left:=10, Top:=10, Height:=20, Width:=100

Verwenden von Steuerelementeigenschaften mit Visual Basic

Am häufigsten verweist Visual Basic-Code über den Namen auf ActiveX-Steuerelemente. In dem folgenden Beispiel wird die Beschriftung des Steuerelements mit dem Namen "CommandButton1" geändert.

Sheet1.CommandButton1.Caption = "Run"

Beachten Sie, dass Sie beim Verwenden eines Steuerelementnamens außerhalb des Klassenmoduls für das Tabellenblatt, das das Steuerelement enthält, den Steuerelementnamen zusammen mit dem Blattnamen angeben müssen.

Zum Ändern des Steuerelementnamens, der in Visual Basic-Code verwendet wird, wählen Sie das Steuerelement aus und legen Sie die (Name)-Eigenschaft im Eigenschaftenfenster fest.

Da ActiveX-Steuerelemente auch durch OLEObject-Objekte in der OLEObjects-Auflistung dargestellt werden, können Sie Steuerelementeigenschaften mit Hilfe der Objekte in der Auflistung festlegen. In dem folgenden Beispiel wird die linke Position des Steuerelements mit dem Namen "CommandButton1" festgelegt.

Worksheets(1).OLEObjects("CommandButton1").Left = 10

Steuerelementeigenschaften, die nicht als Eigenschaften des OLEObject-Objekts angezeigt werden, können festgelegt werden, indem das eigentliche Steuerelementobjekt mit der Object-Eigenschaft zurückgegeben wird. In dem folgenden Beispiel wird die Beschriftung für "CommandButton1" festgelegt.

Worksheets(1).OLEObjects("CommandButton1"). _
    Object.Caption = "run me"

Da alle OLE-Objekte auch Mitglieder der Shapes-Auflistung sind, können Sie die Auflistung verwenden, um die Eigenschaften für mehrere Steuerelemente festzulegen. In dem folgenden Beispiel wird der linke Rand aller Steuerelemente des ersten Tabellenblatts ausgerichtet.

For Each s In Worksheets(1).Shapes
    If s.Type = msoOLEControlObject Then s.Left = 10
Next

Verwenden von Steuerelementnamen mit der Shapes- und der OLEObjects-Auflistung

Ein ActiveX-Steuerelement in einem Tabellenblatt verfügt über zwei Namen: der Name der Form, die das Steuerelement enthält, der beim Anzeigen des Blatts im Feld Name angezeigt wird, und den Codenamen für das Steuerelement, das im Eigenschaftenfenster in der Zelle rechts neben (Name) angezeigt wird. Wenn Sie zum ersten Mal ein Steuerelement zu einem Blatt hinzufügen, stimmen Formname und Codename überein. Wenn Sie jedoch den Formnamen oder den Codenamen ändern, wird der andere nicht automatisch entsprechend geändert.

Sie verwenden den Codenamen eines Steuerelements in dem Namen seiner Ereignisprozeduren. Wenn Sie jedoch ein Steuerelement aus der Shapes- oder der OLEObjects-Auflistung für ein Blatt zurückgeben, müssen Sie den Formnamen und nicht den Codenamen verwenden, um anhand des Namens auf das Steuerelement zu verweisen. Nehmen Sie beispielsweise an, dass Sie ein Kontrollkästchen zu einem Blatt hinzufügen, und dass der Standardformname und der Standardcodename "CheckBox1" lauten. Wenn Sie anschließend den Codenamen des Steuerelements ändern, indem Sie im Eigenschaftenfenster chkFinished neben (Name) eingeben, müssen Sie chkFinished in den Namen von Ereignisprozeduren jedoch weiterhin "CheckBox1" verwenden, um das Steuerelement aus der Shapes- oder der OLEObject-Auflistung zurückzugeben (siehe dazu folgendes Beispiel).

Private Sub chkFinished_Click()
    ActiveSheet.OLEObjects("CheckBox1").Object.Value = 1
End Sub


Verwenden von ActiveX-Steuerelementen in einem Dokument

Genau wie Sie ActiveX-Steuerelemente in benutzerdefinierte Dialogfelder einfügen können, können Sie sie auch direkt einem Dokument hinzufügen, wenn Sie den Benutzer auf elegante Weise ohne Ablenkung durch Dialogfelder mit Ihrem Makro interagieren lassen möchten. Um ActiveX-Steuerelemente in Ihr Dokument einzufügen, verfahren Sie wie folgt. Weitere Informationen über das Verwenden von ActiveX-Steuerelementen in Microsoft Excel finden Sie unter Verwenden von ActiveX-Steuerelementen in Tabellenblättern.

  1. Fügen Sie dem Dokument Steuerelemente hinzu

    Zeigen Sie die Steuerelement-Toolbox an, klicken Sie auf das einzufügende Steuerelement und anschließend auf das Dokument.

  2. Festlegen von Steuerelementeigenschaften

    Klicken Sie mit der rechten Maustaste im Entwurfsmodus auf ein Steuerelement, und klicken Sie auf Eigenschaften, um das Eigenschaftsfenster anzuzeigen.

  3. Initialisieren Sie Steuerelemente

    Sie können Steuerelemente in einer Prozedur initialisieren.

  4. Schreiben Sie Ereignisprozeduren

    Alle Steuerelemente besitzen einen vordefinierten Satz von Ereignissen. Beispielsweise besitzt eine Befehlsschaltfläche ein Click-Ereignis, das auftritt, wenn der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren schreiben, die ausgeführt werden, wenn die Ereignisse eintreten.

  5. Steuerelemente während der Ausführung von Code verwenden

    Einige Eigenschaften können zur Laufzeit festgelegt werden.


Erstellen eines benutzerdefinierten Dialogfelds

Um ein benutzerdefiniertes Dialogfeld zu erstellen, verfahren Sie wie folgt:

  1. Erstellen eines Benutzerformulars

    Klicken Sie im Menü Einfügen im Visual Basic-Editor auf UserForm.

  2. Einfügen von Steuerelementen in ein Benutzerformular

    Suchen Sie in der Toolbox das gewünschte Steuerelement und ziehen Sie es auf das Formular.

  3. Festlegen von Steuerelementeigenschaften

    Klicken Sie im Entwurfsmodus mit der rechten Maustaste auf ein Steuerelement, und klicken Sie auf Eigenschaften, um das Eigenschaftsfenster anzuzeigen.

  4. Initialisieren Sie die Steuerelemente

    Sie können Steuerelemente initialisieren, bevor Sie ein Formular anzeigen, oder Sie können dem Initialize-Ereignis des Formulars einen Code hinzufügen.

  5. Schreiben Sie Ereignisprozeduren

    Alle Steuerelemente besitzen einen vordefinierten Satz von Ereignissen. Beispielsweise besitzt eine Befehlsschaltfläche ein Click-Ereignis, das auftritt, wenn der Benutzer auf die Befehlsschaltfläche klickt. Sie können Ereignisprozeduren schreiben, die ausgeführt werden, wenn die Ereignisse eintreten.

  6. Zeigen Sie das Dialogfeld an

    Verwenden Sie die Show-Methode, um ein Benutzerformular anzuzeigen.

  7. Steuerelemente während der Ausführung von Code verwenden

    Manche Eigenschaften können zur Laufzeit festgelegt werden. Änderungen, die der Benutzer am Dialogfeld vornimmt, gehen verloren, wenn das Dialogfeld geschlossen wird.


Verwenden von Microsoft Office Web Components in Formularen

Sie können Microsoft Office Web Components in Visual Basic oder Visual Basic für Applikationen zu einem Formular auf gleiche Weise hinzufügen wie jedes andere ActiveX-Steuerelement zu einem Benutzerformular. Beachten Sie, dass Sie zwar beim Entwerfen eines Formulars die Eigenschaften-Toolbox verwenden, Sie die Eigenschaften-Toolbox jedoch nicht von einer Microsoft Office-Webkomponente aus in einem gebundenen Formular oder in einem Dialogfeld zur Laufzeit anzeigen können. Dies gilt auch für Formulare, die in anderen Designumgebungen als Visual Basic oder Visual Basic für Applikationen erstellt wurden.

Sie können ein Formular mit der ShowModal-Eigenschaft als ungebunden festlegen.


Listen der integrierten Dialogfeldargumente

Dialogfeldkonstante | Argumentliste(n)
xlDialogActivate | window_text, pane_num
xlDialogActiveCellFont | font, font_style, size, strikethrough, superscript, subscript, outline, shadow, underline, color, normal, background, start_char, char_count
xlDialogAddChartAutoformat | name_text, desc_text
xlDialogAddinManager | operation_num, addinname_text, copy_logical
xlDialogAlignment | horiz_align, wrap, vert_align, orientation, add_indent
xlDialogApplyNames | name_array, ignore, use_rowcol, omit_col, omit_row, order_num, append_last
xlDialogApplyStyle | style_text
xlDialogAppMove | x_num, y_num
xlDialogAppSize | x_num, y_num
xlDialogArrangeAll | arrange_num, active_doc, sync_horiz, sync_vert
xlDialogAssignToObject | macro_ref
xlDialogAssignToTool | bar_id, position, macro_ref
xlDialogAttachText | attach_to_num, series_num, point_num
xlDialogAttachToolbars |
xlDialogAutoCorrect | correct_initial_caps, capitalize_days
xlDialogAxes | x_primary, y_primary, x_secondary, y_secondary
xlDialogAxes | x_primary, y_primary, z_primary
xlDialogBorder | outline, left, right, top, bottom, shade, outline_color, left_color, right_color, top_color, bottom_color
xlDialogCalculation | type_num, iter, max_num, max_change, update, precision, date_1904, calc_save, save_values, alt_exp, alt_form
xlDialogCellProtection | locked, hidden
xlDialogChangeLink | old_text, new_text, type_of_link
xlDialogChartAddData | ref, rowcol, titles, categories, replace, series
xlDialogChartLocation |
xlDialogChartOptionsDataLabels |
xlDialogChartOptionsDataTable |
xlDialogChartSourceData |
xlDialogChartTrend | type, ord_per, forecast, backcast, intercept, equation, r_squared, name
xlDialogChartType |
xlDialogChartWizard | long, ref, gallery_num, type_num, plot_by, categories, ser_titles, legend, title, x_title, y_title, z_title, number_cats, number_titles
xlDialogCheckboxProperties | value, link, accel_text, accel2_text, 3d_shading
xlDialogClear | type_num
xlDialogColorPalette | file_text
xlDialogColumnWidth | width_num, reference, standard, type_num, standard_num
xlDialogCombination | type_num
xlDialogConditionalFormatting |
xlDialogConsolidate | source_refs, function_num, top_row, left_col, create_links
xlDialogCopyChart | size_num
xlDialogCopyPicture | appearance_num, size_num, type_num
xlDialogCreateNames | top, left, bottom, right
xlDialogCreatePublisher | file_text, appearance, size, formats
xlDialogCustomizeToolbar | category
xlDialogCustomViews |
xlDialogDataDelete |
xlDialogDataLabel | show_option, auto_text, show_key
xlDialogDataSeries | rowcol, type_num, date_num, step_value, stop_value, trend
xlDialogDataValidation |
xlDialogDefineName | name_text, refers_to, macro_type, shortcut_text, hidden, category, local
xlDialogDefineStyle | style_text, number, font, alignment, border, pattern, protection
xlDialogDefineStyle | style_text, attribute_num, additional_def_args, ...
xlDialogDeleteFormat | format_text
xlDialogDeleteName | name_text
xlDialogDemote | row_col
xlDialogDisplay | formulas, gridlines, headings, zeros, color_num, reserved, outline, page_breaks, object_num
xlDialogDisplay | cell, formula, value, format, protection, names, precedents, dependents, note
xlDialogEditboxProperties | validation_num, multiline_logical, vscroll_logical, password_logical
xlDialogEditColor | color_num, red_value, green_value, blue_value
xlDialogEditDelete | shift_num
xlDialogEditionOptions | edition_type, edition_name, reference, option, appearance, size, formats
xlDialogEditSeries | series_num, name_ref, x_ref, y_ref, z_ref, plot_order
xlDialogErrorbarX | include, type, amount, minus
xlDialogErrorbarY | include, type, amount, minus
xlDialogExternalDataProperties |
xlDialogExtract | unique
xlDialogFileDelete | file_text
xlDialogFileSharing |
xlDialogFillGroup | type_num
xlDialogFillWorkgroup | type_num
xlDialogFilter |
xlDialogFilterAdvanced | operation, list_ref, criteria_ref, copy_ref, unique
xlDialogFindFile |
xlDialogFont | name_text, size_num
xlDialogFontProperties | font, font_style, size, strikethrough, superscript, subscript, outline, shadow, underline, color, normal, background, start_char, char_count
xlDialogFormatAuto | format_num, number, font, alignment, border, pattern, width
xlDialogFormatChart | layer_num, view, overlap, angle, gap_width, gap_depth, chart_depth, doughnut_size, axis_num, drop, hilo, up_down, series_line, labels, vary
xlDialogFormatCharttype | apply_to, group_num, dimension, type_num
xlDialogFormatFont | color, backgd, apply, name_text, size_num, bold, italic, underline, strike, outline, shadow, object_id, start_num, char_num
xlDialogFormatFont | name_text, size_num, bold, italic, underline, strike, color, outline, shadow
xlDialogFormatFont | name_text, size_num, bold, italic, underline, strike, color, outline, shadow, object_id_text, start_num, char_num
xlDialogFormatLegend | position_num
xlDialogFormatMain | type_num, view, overlap, gap_width, vary, drop, hilo, angle, gap_depth, chart_depth, up_down, series_line, labels, doughnut_size
xlDialogFormatMove | x_offset, y_offset, reference
xlDialogFormatMove | x_pos, y_pos
xlDialogFormatMove | explosion_num
xlDialogFormatNumber | format_text
xlDialogFormatOverlay | type_num, view, overlap, gap_width, vary, drop, hilo, angle, series_dist, series_num, up_down, series_line, labels, doughnut_size
xlDialogFormatSize | width, height
xlDialogFormatSize | x_off, y_off, reference
xlDialogFormatText | x_align, y_align, orient_num, auto_text, auto_size, show_key, show_value, add_indent
xlDialogFormulaFind | text, in_num, at_num, by_num, dir_num, match_case, match_byte
xlDialogFormulaGoto | reference, corner
xlDialogFormulaReplace | find_text, replace_text, look_at, look_by, active_cell, match_case, match_byte
xlDialogFunctionWizard |
xlDialogGallery3dArea | type_num
xlDialogGallery3dBar | type_num
xlDialogGallery3dColumn | type_num
xlDialogGallery3dLine | type_num
xlDialogGallery3dPie | type_num
xlDialogGallery3dSurface | type_num
xlDialogGalleryArea | type_num, delete_overlay
xlDialogGalleryBar | type_num, delete_overlay
xlDialogGalleryColumn | type_num, delete_overlay
xlDialogGalleryCustom | name_text
xlDialogGalleryDoughnut | type_num, delete_overlay
xlDialogGalleryLine | type_num, delete_overlay
xlDialogGalleryPie | type_num, delete_overlay
xlDialogGalleryRadar | type_num, delete_overlay
xlDialogGalleryScatter | type_num, delete_overlay
xlDialogGoalSeek | target_cell, target_value, variable_cell
xlDialogGridlines | x_major, x_minor, y_major, y_minor, z_major, z_minor, 2D_effect
xlDialogImportTextFile |
xlDialogInsert | shift_num
xlDialogInsertHyperlink |
xlDialogInsertNameLabel |
xlDialogInsertObject | object_class, file_name, link_logical, display_icon_logical, icon_file, icon_number, icon_label
xlDialogInsertPicture | file_name, filter_number
xlDialogInsertTitle | chart, y_primary, x_primary, y_secondary, x_secondary
xlDialogLabelProperties | accel_text, accel2_text, 3d_shading
xlDialogListboxProperties | range, link, drop_size, multi_select, 3d_shading
xlDialogMacroOptions | macro_name, description, menu_on, menu_text, shortcut_on, shortcut_key, function_category, status_bar_text, help_id, help_file
xlDialogMailEditMailer | to_recipients, cc_recipients, bcc_recipients, subject, enclosures, which_address
xlDialogMailLogon | name_text, password_text, download_logical
xlDialogMailNextLetter |
xlDialogMainChart | type_num, stack, 100, vary, overlap, drop, hilo, overlap%, cluster, angle
xlDialogMainChartType | type_num
xlDialogMenuEditor |
xlDialogMove | x_pos, y_pos, window_text
xlDialogNew | type_num, xy_series, add_logical
xlDialogNewWebQuery |
xlDialogNote | add_text, cell_ref, start_char, num_chars
xlDialogObjectProperties | placement_type, print_object
xlDialogObjectProtection | locked, lock_text
xlDialogOpen | file_text, update_links, read_only, format, prot_pwd, write_res_pwd, ignore_rorec, file_origin, custom_delimit, add_logical, editable, file_access, notify_logical, converter
xlDialogOpenLinks | document_text1, document_text2, ..., read_only, type_of_link
xlDialogOpenMail | subject, comments
xlDialogOpenText | file_name, file_origin, start_row, file_type, text_qualifier, consecutive_delim, tab, semicolon, comma, space, other, other_char, field_info
xlDialogOptionsCalculation | type_num, iter, max_num, max_change, update, precision, date_1904, calc_save, save_values
xlDialogOptionsChart | display_blanks, plot_visible, size_with_window
xlDialogOptionsEdit | incell_edit, drag_drop, alert, entermove, fixed, decimals, copy_objects, update_links, move_direction, autocomplete, animations
xlDialogOptionsGeneral | R1C1_mode, dde_on, sum_info, tips, recent_files, old_menus, user_info, font_name, font_size, default_location, alternate_location, sheet_num, enable_under
xlDialogOptionsListsAdd | string_array
xlDialogOptionsListsAdd | import_ref, by_row
xlDialogOptionsME | def_rtl_sheet, crsr_mvmt, show_ctrl_char, gui_lang
xlDialogOptionsTransition | menu_key, menu_key_action, nav_keys, trans_eval, trans_entry
xlDialogOptionsView | formula, status, notes, show_info, object_num, page_breaks, formulas, gridlines, color_num, headers, outline, zeros, hor_scroll, vert_scroll, sheet_tabs
xlDialogOutline | auto_styles, row_dir, col_dir, create_apply
xlDialogOverlay | type_num, stack, 100, vary, overlap, drop, hilo, overlap%, cluster, angle, series_num, auto
xlDialogOverlayChartType | type_num
xlDialogPageSetup | head, foot, left, right, top, bot, hdng, grid, h_cntr, v_cntr, orient, paper_size, scale, pg_num, pg_order, bw_cells, quality, head_margin, foot_margin, notes, draft
xlDialogPageSetup | head, foot, left, right, top, bot, size, h_cntr, v_cntr, orient, paper_size, scale, pg_num, bw_chart, quality, head_margin, foot_margin, draft
xlDialogPageSetup | head, foot, left, right, top, bot, orient, paper_size, scale, quality, head_margin, foot_margin, pg_num
xlDialogParse | parse_text, destination_ref
xlDialogPasteNames |
xlDialogPasteSpecial | paste_num, operation_num, skip_blanks, transpose
xlDialogPasteSpecial | rowcol, titles, categories, replace, series
xlDialogPasteSpecial | paste_num
xlDialogPasteSpecial | format_text, pastelink_logical, display_icon_logical, icon_file, icon_number, icon_label
xlDialogPatterns | apattern, afore, aback, newui
xlDialogPatterns | lauto, lstyle, lcolor, lwt, hwidth, hlength, htype
xlDialogPatterns | bauto, bstyle, bcolor, bwt, shadow, aauto, apattern, afore, aback, rounded, newui
xlDialogPatterns | bauto, bstyle, bcolor, bwt, shadow, aauto, apattern, afore, aback, invert, apply, newfill
xlDialogPatterns | lauto, lstyle, lcolor, lwt, tmajor, tminor, tlabel
xlDialogPatterns | lauto, lstyle, lcolor, lwt, apply, smooth
xlDialogPatterns | lauto, lstyle, lcolor, lwt, mauto, mstyle, mfore, mback, apply, smooth
xlDialogPatterns | type, picture_units, apply
xlDialogPhonetic |
xlDialogPivotCalculatedField |
xlDialogPivotCalculatedItem |
xlDialogPivotClientServerSet |
xlDialogPivotFieldGroup | start, end, by, periods
xlDialogPivotFieldProperties | name, pivot_field_name, new_name, orientation, function, formats
xlDialogPivotFieldUngroup |
xlDialogPivotShowPages | name, page_field
xlDialogPivotSolveOrder |
xlDialogPivotTableOptions |
xlDialogPivotTableWizard | type, source, destination, name, row_grand, col_grand, save_data, apply_auto_format, auto_page, reserved
xlDialogPlacement | placement_type
xlDialogPrint | range_num, from, to, copies, draft, preview, print_what, color, feed, quality, y_resolution, selection, printer_text, print_to_file, collate
xlDialogPrinterSetup | printer_text
xlDialogPrintPreview |
xlDialogPromote | rowcol
xlDialogProperties | title, subject, author, keywords, comments
xlDialogProtectDocument | contents, windows, password, objects, scenarios
xlDialogProtectSharing |
xlDialogPublishAsWebPage |
xlDialogPushbuttonProperties | default_logical, cancel_logical, dismiss_logical, help_logical, accel_text, accel_text2
xlDialogReplaceFont | font_num, name_text, size_num, bold, italic, underline, strike, color, outline, shadow
xlDialogRoutingSlip | recipients, subject, message, route_num, return_logical, status_logical
xlDialogRowHeight | height_num, reference, standard_height, type_num
xlDialogRun | reference, step
xlDialogSaveAs | document_text, type_num, prot_pwd, backup, write_res_pwd, read_only_rec
xlDialogSaveCopyAs | document_text
xlDialogSaveNewObject |
xlDialogSaveWorkbook | document_text, type_num, prot_pwd, backup, write_res_pwd, read_only_rec
xlDialogSaveWorkspace | name_text
xlDialogScale | cross, cat_labels, cat_marks, between, max, reverse
xlDialogScale | min_num, max_num, major, minor, cross, logarithmic, reverse, max
xlDialogScale | cat_labels, cat_marks, reverse, between
xlDialogScale | series_labels, series_marks, reverse
xlDialogScale | min_num, max_num, major, minor, cross, logarithmic, reverse, min
xlDialogScenarioAdd | scen_name, value_array, changing_ref, scen_comment, locked, hidden
xlDialogScenarioCells | changing_ref
xlDialogScenarioEdit | scen_name, new_scenname, value_array, changing_ref, scen_comment, locked, hidden
xlDialogScenarioMerge | source_file
xlDialogScenarioSummary | result_ref, report_type
xlDialogScrollbarProperties | value, min, max, inc, page, link, 3d_shading
xlDialogSelectSpecial | type_num, value_type, levels
xlDialogSendMail | recipients, subject, return_receipt
xlDialogSeriesAxes | axis_num
xlDialogSeriesOptions |
xlDialogSeriesOrder | chart_num, old_series_num, new_series_num
xlDialogSeriesShape |
xlDialogSeriesX | x_ref
xlDialogSeriesY | name_ref, y_ref
xlDialogSetBackgroundPicture |
xlDialogSetPrintTitles | titles_for_cols_ref, titles_for_rows_ref
xlDialogSetUpdateStatus | link_text, status, type_of_link
xlDialogShowDetail | rowcol, rowcol_num, expand, show_field
xlDialogShowToolbar | bar_id, visible, dock, x_pos, y_pos, width, protect, tool_tips, large_buttons, color_buttons
xlDialogSize | width, height, window_text
xlDialogSort | orientation, key1, order1, key2, order2, key3, order3, header, custom, case
xlDialogSort | orientation, key1, order1, type, custom
xlDialogSortSpecial | sort_by, method, key1, order1, key2, order2, key3, order3, header, order, case
xlDialogSplit | col_split, row_split
xlDialogStandardFont | name_text, size_num, bold, italic, underline, strike, color, outline, shadow
xlDialogStandardWidth | standard_num
xlDialogStyle | bold, italic
xlDialogSubscribeTo | file_text, format_num
xlDialogSubtotalCreate | at_change_in, function_num, total, replace, pagebreaks, summary_below
xlDialogSummaryInfo | title, subject, author, keywords, comments
xlDialogTable | row_ref, column_ref
xlDialogTabOrder |
xlDialogTextToColumns | destination_ref, data_type, text_delim, consecutive_delim, tab, semicolon, comma, space, other, other_char, field_info
xlDialogUnhide | window_text
xlDialogUpdateLink | link_text, type_of_link
xlDialogVbaInsertFile | filename_text
xlDialogVbaMakeAddIn |
xlDialogVbaProcedureDefinition |
xlDialogView3d | elevation, perspective, rotation, axes, height%, autoscale
xlDialogWebOptionsEncoding |
xlDialogWebOptionsFiles |
xlDialogWebOptionsFonts |
xlDialogWebOptionsGeneral |
xlDialogWebOptionsPictures |
xlDialogWindowMove | x_pos, y_pos, window_text
xlDialogWindowSize | width, height, window_text
xlDialogWorkbookAdd | name_array, dest_book, position_num
xlDialogWorkbookCopy | name_array, dest_book, position_num
xlDialogWorkbookInsert | type_num
xlDialogWorkbookMove | name_array, dest_book, position_num
xlDialogWorkbookName | oldname_text, newname_text
xlDialogWorkbookNew |
xlDialogWorkbookOptions | sheet_name, bound_logical, new_name
xlDialogWorkbookProtect | structure, windows, password
xlDialogWorkbookTabSplit | ratio_num
xlDialogWorkbookUnhide | sheet_text
xlDialogWorkgroup | name_array
xlDialogWorkspace | fixed, decimals, r1c1, scroll, status, formula, menu_key, remote, entermove, underlines, tools, notes, nav_keys, menu_key_action, drag_drop, show_info
xlDialogZoom | magnification


Verwenden von Ereignissen mit Microsoft Excel-Objekten

In Microsoft Excel können Sie Ereignisprozeduren auf der Ebene von Tabellenblatt, Diagramm, Abfragetabelle, Arbeitsmappe oder Anwendung schreiben. So tritt beispielsweise das Activate-Ereignis auf der Tabellenblattebene ein, dagegen ist das SheetActivate-Ereignis sowohl auf der Arbeitsmappen- wie auch auf der Anwendungsebene verfügbar. Das SheetActivate-Ereignis für eine Arbeitsmappe tritt ein, wenn ein beliebiges Blatt der Arbeitsmappe aktiviert wird. Auf der Anwendungsebene tritt das SheetActivate-Ereignis ein, wenn ein beliebiges Blatt in einer beliebigen Arbeitsmappe geöffnet wird.

Tabellenblatt-, Diagrammblatt- und Arbeitsmappen-Ereignisprozeduren sind für alle beliebigen geöffneten Blätter oder Arbeitsmappen verfügbar. Um Ereignisprozeduren für ein eingebettetes Diagramm, eine Abfragetabelle oder ein Application-Objekt zu schreiben, müssen Sie unter Verwendung des Schlüsselwortes WithEvents in einem Klassenmodul ein neues Objekt erstellen.

Mit Hilfe der EnableEvents-Eigenschaft können Sie Ereignisse aktiveren und deaktivieren. Beispielsweise führt das Speichern einer Arbeitsmappe mit der Save-Methode zum Auftreten des BeforeSave-Ereignisses. Dies kann verhindert werden, indem Sie die EnableEvents-Eigenschaft auf False setzen, bevor Sie die Save-Methode aufrufen.

Application.EnableEvents = False
ActiveWorkbook.Save
Application.EnableEvents = True


Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic

Sie können die meisten Microsoft Excel-Tabellenfunktionen in Ihren Visual Basic-Anweisungen verwenden. Eine Liste der verwendbaren Tabellenfunktionen finden Sie unter Liste der in Visual Basic verfügbaren Tabellenfunktionen.

Anmerkung Einige Tabellenfunktionen sind in Visual Basic nicht verwendbar. Zum Beispiel wird die VERKETTEN-Funktion nicht gebraucht, da Sie in Visual Basic zum Verknüpfen mehrerer Textwerte den &-Operator verwenden können.

Aufrufen einer Tabellenfunktion aus Visual Basic

In Visual Basic werden die Microsoft Excel-Tabellenfunktionen durch das WorksheetFunction-Objekt zur Verfügung gestellt. Benutzen Sie hier den englischen Namen der Tabellenfunktion und Ihre Argumente.

Die folgende Sub-Prozedur verwendet die Tabellenfunktion Min, um den niedrigsten Wert in einem Zellbereich zu bestimmen. Zunächst wird die Variable myRange als ein Range-Objekt deklariert und dann auf den Bereich A1:C10 in Tabelle1 festgelegt. Anschließend wird der Variablen answer das Ergebnis der auf myRange angewendeten Funktion Min zugewiesen. Der Wert von answer wird dann in einem Meldungsfeld angezeigt.

Sub UseFunction()
    Dim myRange As Range
    Set myRange = Worksheets("Sheet1").Range("A1:C10")
    answer = Application.WorksheetFunction.Min(myRange)
    MsgBox answer
End Sub

Verwenden Sie eine Tabellenfunktion, die einen Bereichsbezug als Argument fordert, so müssen Sie ein Range-Objekt festlegen. Sie können z. B. die Tabellenfunktion VERGLEICH (Match in VBA) verwenden, um einen Zellbereich zu durchsuchen. In eine Zelle eines Tabellenblatts würden Sie dazu eine Formel wie =VERGLEICH(9,A1:A10,0) eingeben. In einer Prozedur in Visual Basic jedoch legen Sie ein Range-Objekt fest, um das gleiche Ergebnis zu erhalten.

Sub FindFirst()
    myVar = Application.WorksheetFunction _
        .Match(9, Worksheets(1).Range("A1:A10"), 0)
    MsgBox myVar
End Sub

Anmerkung Der Kennzeichner WorksheetFunction wird von den Funktionen in Visual Basic nicht verwendet. Namen von Funktionen können in Visual Basic und Microsoft Excel zwar identisch sein, jedoch unterschiedliche Auswirkungen haben. Zum Beispiel geben Application.WorksheetFunction.Log und Log unterschiedliche Werte zurück.

Einfügen einer Tabellenfunktion in eine Zelle

Um eine Tabellenfunktion in eine Zelle einzufügen, geben Sie die Funktion als Wert der Formula-Eigenschaft des entsprechenden Range-Objekts an. Im folgenden Beispiel wird die Tabellenfunktion ZUFALLSZAHL (RAND in VBA) der Formula-Eigenschaft des Bereichs A1:B3 in Tabelle1 der aktiven Arbeitsmappe zugewiesen.

Sub InsertFormula()
    Worksheets("Sheet1").Range("A1:B3").Formula = "=RAND()"
End Sub


Beispiel zum Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic

In diesem Beispiel wird die Tabellenfunktion RMZ (Pmt in VBA) zur Berechnung der Zahlungen für ein Hypothekendarlehen verwendet. Beachten Sie, dass dabei nicht die InputBox-Funktion, sondern die InputBox-Methode verwendet wird, so dass eine Typenüberprüfung durch die Methode möglich ist. Die Static-Anweisungen sorgen dafür, dass in Visual Basic die Werte der drei Variablen erhalten bleiben und beim nächsten Ausführen des Programms als Standardwerte angezeigt werden.

Static loanAmt
Static loanInt
Static loanTerm
loanAmt = Application.InputBox _
    (Prompt:="Loan amount (100,000 for example)", _
        Default:=loanAmt, Type:=1)
loanInt = Application.InputBox _
    (Prompt:="Annual interest rate (8.75 for example)", _
        Default:=loanInt, Type:=1)
loanTerm = Application.InputBox _
    (Prompt:="Term in years (30 for example)", _
        Default:=loanTerm, Type:=1)
payment = Application.WorksheetFunction _
    .Pmt(loanInt / 1200, loanTerm * 12, loanAmt)
MsgBox "Monthly payment is " & Format(payment, "Currency")


Arbeiten mit Formen (Zeichnungsobjekten)

Formen, oder Zeichnungsobjekte, werden durch die folgenden drei unterschiedlichen Objekte dargestellt: Shapes-Auflistung, ShapeRange-Auflistung und Shape-Objekt. Die Shapes-Auflistung verwenden Sie allgemein zum Erstellen von Formen zum Durchgehen aller Formen in einem Tabellenblatt; das Shape-Objekt verwenden Sie zum Formatieren oder Ändern einer einzelnen Form; die ShapeRange-Auflistung verwenden Sie zum Ändern mehrerer Formen auf die gleiche Art, wie Sie auf der Benutzeroberfläche mit mehreren Formen arbeiten.

Festlegen der Eigenschaften für eine Form

Viele Formateigenschaften werden nicht durch Eigenschaften festgelegt, die direkt auf das Shape- oder das ShapeRange-Objekt angewendet werden. Stattdessen werden verwandte Formeigenschaften unter Sekundärobjekten zusammengefasst, beispielsweise dem FillFormat-Objekt, das alle Eigenschaften enthält, die sich auf die Füllung der Form beziehen, oder dem LinkFormat-Objekt, das alle Eigenschaften enthält, die sich ausschließlich auf verknüpfte OLE-Objekte beziehen. Um Eigenschaften für eine Form festzulegen, müssen Sie zuerst das Objekt zurückgeben, das den Satz verwandter Formeigenschaften darstellt, und anschließend die Eigenschaften dieses zurückgegebenen Objekts festlegen. Beispielsweise können Sie mit der Fill-Eigenschaft das FillFormat-Objekt zurückgeben und danach die ForeColor-Eigenschaft des FillFormat-Objekt so festlegen, dass für die angegebene Form die Füllfarbe des Vordergrunds bestimmt wird. Dies wird im folgenden Beispiel verdeutlicht.

Worksheets(1).Shapes(1).Fill.ForeColor.RGB = RGB(255, 0, 0)

Gleichzeitiges Anwenden einer Eigenschaft oder Methode auf mehrere Formen

Auf der Benutzeroberfläche gibt es einige Operationen, die sich auch bei mehreren markierten Formen ausführen lassen; beispielsweise können Sie mehrere Formen markieren und ihre einzelnen Füllungen gleichzeitig festlegen. Andere Operationen lassen sich nur bei einer einzelnen markierten Form ausführen. Beispielsweise können Sie den Text in einer Form nur dann bearbeiten, wenn eine einzelne Form markiert ist.

Visual Basic bietet zwei Möglichkeiten, Eigenschaften und Methoden auf mehrere Formen anzuwenden. Bei beiden können Sie jeden Vorgang, den Sie mit einer einzelnen Form ausführen, auch mit einem Formbereich ausführen, unabhängig davon, ob sich der Vorgang auf der Benutzeroberfläche durchführen lässt oder nicht.

  • Wenn die Operation auf der Benutzeroberfläche bei mehrfach markierten Formen funktioniert, können Sie die gleiche Operation in Visual Basic durchführen, indem Sie eine ShapeRange-Auflistung bilden, die alle Formen enthält, mit denen Sie arbeiten möchten, und die entsprechenden Eigenschaften und Methoden direkt auf die ShapeRange-Auflistung anwenden.

  • Wenn die Operation auf der Benutzeroberfläche bei mehrfach markierten Formen nicht funktioniert, können Sie die Operation trotzdem in Visual Basic durchführen, indem Sie in der Shapes-Auflistung oder in einer ShapeRange-Auflistung, die alle zu bearbeitenden Formen enthält, einen Schleifendurchlauf ausführen und die entsprechenden Eigenschaften und Methoden auf die einzelnen Shape-Objekte der Auflistung anwenden.

Viele Eigenschaften und Formen, die sich auf das Shape-Objekt und die ShapeRange-Auflistung anwenden lassen, schlagen bei bestimmten Arten von Formen fehl, so beispielsweise die TextFrame-Eigenschaft, wenn Sie auf eine Form angewendet wird, die keinen Text enthalten kann. Solange Sie sich nicht sicher sind, dass eine bestimmte Eigenschaft oder Methode auf jede Form in einer ShapeRange-Auflistung angewendet werden kann, wenden Sie sie nicht auf die ShapeRange-Auflistung an. Wenn Sie eine dieser Eigenschaften oder Methoden auf eine Auflistung von Formen anwenden möchten, müssen Sie zuvor die Auflistung in einer Schleife bearbeiten, um durch einen Test jeder einzelnen Form sicherzustellen, dass es sich um eine gültige Form handelt.

Erstellen einer ShapeRange-Auflistung, die alle Formen eines Blattes enthält

Sie können ein ShapeRange-Objekt erstellen, das alle Shape-Objekte eines Blattes enthält, indem Sie die Formen markieren und anschließend mit Hilfe der ShapeRange-Eigenschaft ein ShapeRange-Objekt zurückgeben, das alle markierten Formen enthält.

Worksheets(1).Shapes.Select
Set sr = Selection.ShapeRange

In Microsoft Excel ist das Argument Index nicht optional für die Range-Eigenschaft der Shapes-Auflistung. Deshalb können Sie diese Eigenschaft ohne Argument nicht verwenden, um ein ShapeRange-Objekt zu erstellen, das alle Formen einer Shapes-Auflistung enthält.

Anwenden einer Eigenschaft oder Methode auf eine ShapeRange-Auflistung

Wenn Sie auf der Benutzeroberfläche eine Operation für mehrfach markierte Formen gleichzeitig durchführen können, so gelingt sie Ihnen auch von einem Programm aus, indem Sie eine ShapeRange-Auflistung bilden und anschließend darauf die entsprechenden Eigenschaften und Methoden anwenden. Im folgenden Beispiel wird ein Formbereich gebildet, der in myDocument die Formen "Großer Stern" und "Kleiner Stern" enthält, die mit einem frei beweglichen Farbverlauf versehen werden.

Set myDocument = Worksheets(1)
Set myRange = myDocument.Shapes.Range(Array("Big Star", _
    "Little Star"))
myRange.Fill.PresetGradient _
    msoGradientHorizontal, 1, msoGradientBrass

Es folgen allgemeine Richtlinien dazu, wie sich Eigenschaften und Methoden verhalten, wenn sie auf eine ShapeRange-Auflistung angewendet werden.

  • Das Anwenden einer Methode auf die Auflistung führt zu demselben Ergebnis wie das Anwenden der Methode auf jedes einzelne Shape-Objekt dieser Auflistung.

  • Das Festlegen eines Wertes für eine Eigenschaft der Auflistung führt zu demselben Ergebnis wie das Festlegen des Wertes für die Eigenschaft jeder einzelnen Form dieses Bereichs.

  • Eine Eigenschaft der Auflistung, die eine Konstante zurückgibt, gibt den Wert der Eigenschaft einer einzelnen Form dieser Auflistung zurück, falls alle Formen in der Auflistung für diese Eigenschaft den gleichen Wert besitzen. Besitzen nicht alle Formen der Auflistung diesen Wert, so wird eine "Misch"-Konstante zurückgegeben.

  • Eine Eigenschaft der Auflistung, die einen einfachen Datentyp (Long, Single oder String) zurückgibt, gibt den Wert der Eigenschaft für eine einzelne Form zurück, falls alle Formen in der Auflistung für diese Eigenschaft den gleichen Wert besitzen.

  • Der Wert mancher Eigenschaften kann nur dann zurückgegeben oder festgelegt werden, wenn sich in der Auflistung genau eine Form befindet. Gibt es mehr als eine Form in der Auflistung, so tritt ein Laufzeitfehler auf. Dies ist allgemein beim Setzen und Zurückgeben von Eigenschaften der Fall, wenn die dementsprechende Aktion auf der Benutzeroberfläche nur für eine einzelne Form möglich ist (z. B. Bearbeiten von Text in einer Form oder Bearbeiten von Punkten eines Freihandobjekts).

Diese Richtlinien gelten auch, wenn Sie Eigenschaften von Formen festlegen, die unter Sekundärobjekten der ShapeRange-Auflistung, z. B. dem FillFormat-Objekt, gruppiert sind. Wenn das Sekundärobjekt Operationen darstellt, die auf der Benutzeroberfläche bei mehrfach markierten Objekten ausführbar sind, können Sie das Objekt aus der ShapeRange-Auflistung zurückgeben und seine Eigenschaften festlegen. Beispielsweise können Sie die Fill-Eigenschaft verwenden, um das FillFormat-Objekt zurückzugeben, das die Füllungen aller Formen in der ShapeRange-Auflistung darstellt. Durch das Festlegen der Eigenschaften dieses FillFormat-Objekts werden die gleichen Eigenschaften für alle einzelnen Formen in der ShapeRange-Auflistung festgelegt.

Durchlaufen einer Shapes- oder ShapeRange-Auflistung in einer Schleife

Selbst wenn auf der Benutzeroberfläche ein Vorgang für mehrere Formen gleichzeitig durch deren Markierung und anschließendes Verwenden eines Befehls nicht durchführbar ist, können Sie dennoch die entsprechende Aktion von einem Programm aus ausführen, indem Sie in einer Shape- oder ShapeRange-Auflistung, die die zu bearbeitenden Formen enthält, in einem Schleifendurchlauf die entsprechenden Eigenschaften und Methoden auf die einzelnen Shape-Objekte der Auflistung anwenden. Im folgenden Beispiel werden alle Formen in myDocument in einer Schleife bearbeitet und die Vordergrundfarbe für jede Form, die eine AutoForm ist, geändert.

Set myDocument = Worksheets(1)
For Each sh In myDocument.Shapes
    If sh.Type = msoAutoShape Then
        sh.Fill.ForeColor.RGB = RGB(255, 0, 0)
    End If
Next

Im folgenden Beispiel wird eine ShapeRange-Auflistung gebildet, die alle aktuell markierten Formen im aktiven Fenster enthält, und für jede markierte Form die Vordergrundfarbe festgelegt.

For Each sh in ActiveWindow.Selection.ShapeRange
    sh.Fill.ForeColor.RGB = RGB(255, 0, 0)
Next

Ausrichten, Verteilen und Gruppieren von Formen in einem Formbereich

Mit den Methoden Align und Distribute können Sie einen Satz von Formen in relativer Position zueinander oder relativ zu dem Dokument, in dem sie sich befinden, positionieren. Mit der Group- oder der Regroup-Methode können Sie aus einem Satz von Formen eine einzelne gruppierte Form bilden.


 Steuern eines Microsoft Office-Programms aus einem anderen

Steuern eines Microsoft Office-Programms aus einem anderen

Wenn Sie Code in einem Microsoft Office-Programm ausführen möchten, der mit Objekten eines anderen Microsoft Office-Programms arbeitet, verfahren Sie wie folgt:

  1. Legen Sie im Dialogfeld Verweise (Menü Extras) einen Bezug auf die Typ-Bibliothek des anderen Programms fest. Danach werden die Objekte, Eigenschaften und Methoden im Objektkatalog angezeigt, und die Syntax wird zur Kompilierungszeit überprüft. Auch kontextbezogene Hilfe ist für die Objekte, Eigenschaften und Methoden verfügbar.

  2. Deklarieren Sie Objektvariablen, die auf die Objekte im anderen Programm verweisen, als eigene Typen. Achten Sie darauf, dass jeder Typ mit dem Namen des Programms gekennzeichnet ist, das das Objekt bereitstellt. Beispielsweise deklariert die folgende Anweisung eine Variable, die auf ein Word-Dokument zeigt, und eine andere, die auf eine Microsoft Excel-Arbeitsmappe verweist:
    Dim appWD As Word.Application, wbXL As Excel.Workbook

Anmerkung Sie müssen die vorherigen Schritte befolgen, wenn Ihr Code früh eingebunden werden soll.

  3. Verwenden Sie die CreateObject-Funktion zusammen mit dem programmtechnischen OLE-Bezeichner des Objekts, mit dem Sie in dem anderen Programm arbeiten möchten, wie im folgenden Beispiel dargestellt. Möchten Sie die Sitzung des anderen Programms ansehen, so setzen Sie die Visible-Eigenschaft auf True.
    Dim appWD As Word.Application

Set appWD = CreateObject("Word.Application")
appWd.Visible = True

  4. Wenden Sie Eigenschaften und Methoden auf das in der Variable enthaltene Objekt an. Beispielsweise erzeugt die folgende Anweisung ein neues Word-Dokument.
    Dim appWD As Word.Application

Set appWD = CreateObject("Word.Application.8")
appWD.Documents.Add

  5. Wenn die Arbeit mit dem anderen Programm erledigt ist, beenden Sie es mit der Quit-Methode, wie im folgenden Beispiel dargestellt.
    appWd.Quit


Programmtechnische OLE-Bezeichner

Sie können programmtechnische OLE-Bezeichner (manchmal auch ProgID genannt) zum Erstellen eines Automation-Objekts verwenden. In der folgenden Tabelle sind die programmtechnischen OLE-Bezeichner für ActiveX-Steuerelemente, Microsoft Office-Anwendungen und Microsoft Office Web Components aufgeführt.

ActiveX-Steuerelemente

Microsoft Access

Microsoft Excel

Microsoft Graph

Microsoft Office Web Components

Microsoft Outlook

Microsoft PowerPoint

Microsoft Word

ActiveX-Steuerelemente

Zum Erstellen der in der folgenden Tabelle aufgeführten ActiveX-Steuerelemente verwenden Sie die dazugehörigen programmtechnischen OLE-Bezeichner.

Zum Erstellen dieses Steuerelements | Verwenden Sie diesen Bezeichner
CheckBox | Forms.CheckBox.1
ComboBox | Forms.ComboBox.1
CommandButton | Forms.CommandButton.1
Frame | Forms.Frame.1
Image | Forms.Image.1
Label | Forms.Label.1
ListBox | Forms.ListBox.1
MultiPage | Forms.MultiPage.1
OptionButton | Forms.OptionButton.1
ScrollBar | Forms.ScrollBar.1
SpinButton | Forms.SpinButton.1
TabStrip | Forms.TabStrip.1
TextBox | Forms.TextBox.1
ToggleButton | Forms.ToggleButton.1

Microsoft Access

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Access-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von Access, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
Application | Access.Application, Access.Application.9
CurrentData | Access.CodeData, Access.CurrentData
CurrentProject | Access.CodeProject, Access.CurrentProject
DefaultWebOptions | Access.DefaultWebOptions

Microsoft Excel

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Excel-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von Excel, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner | Kommentare
Application | Excel.Application, Excel.Application.9 |
Workbook | Excel.AddIn |
Workbook | Excel.Chart, Excel.Chart.8 | Gibt eine Arbeitsmappe mit zwei Tabellenblättern zurück; eines für das Diagramm und das andere für die Daten. Das Diagrammblatt ist das aktive Tabellenblatt.
Workbook | Excel.Sheet, Excel.Sheet.8 | Gibt eine Arbeitsmappe mit einem Tabellenblatt zurück.

Microsoft Graph

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Graph-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von Graph, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
Application | MSGraph.Application, MSGraph.Application.8
Chart | MSGraph.Chart, MSGraph.Chart.8

Microsoft Office Web Components

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Office Web Componentsobjekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version der Microsoft Office Web Components, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
ChartSpace | OWC.Chart, OWC.Chart.9
DataSourceControl | OWC.DataSourceControl, OWC.DataSourceControl.9
ExpandControl | OWC.ExpandControl, OWC.ExpandControl.9
PivotTable | OWC.PivotTable, OWC.PivotTable.9
RecordNavigationControl | OWC.RecordNavigationControl, OWC.RecordNavigationControl.9
Spreadsheet | OWC.Spreadsheet, OWC.Spreadsheet.9

Microsoft Outlook

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Outlook-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von Outlook, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
Application | Outlook.Application, Outlook.Application.9

Microsoft PowerPoint

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft PowerPoint-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von PowerPoint, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
Application | PowerPoint.Application, PowerPoint.Application.9

Microsoft Word

Zum Erstellen der in der folgenden Tabelle aufgeführten Microsoft Word-Objekte verwenden Sie einen der dazugehörigen programmtechnischen OLE-Bezeichner. Wenn Sie einen Bezeichner ohne Versionsnummernsuffix verwenden, erstellen Sie ein Objekt in der höchsten Version von Word, die auf dem Computer, auf dem das Makro ausgeführt wird, verfügbar ist.

Zum Erstellen dieses Objekts | Verwenden Sie einen dieser Bezeichner
Application | Word.Application, Word.Application.9
Document | Word.Document, Word.Document.9, Word.Template.8
Global | Word.Global


Microsoft Excel-Objekte

Application-Objekt

Pfeil nach rechts
Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie auf den Pfeil, um das Diagramm zu erweitern.


Liste der in Visual Basic verfügbaren Tabellenfunktionen

Benutzen Sie den englischen Namen der Tabellenfunktion und Ihre Argumente.

A

Acos

Acosh

And

Asin

Asinh

Atan2

Atanh

AveDev

Average

B

BetaDist

BetaInv

BinomDist

C

Ceiling

ChiDist

ChiInv

ChiTest

Choose

Clean

Combin

Confidence

Correl

Cosh

Count

CountA

CountBlank

CountIf

Covar

CritBinom

D

DAverage

Days360

Db

DCount

DCountA

Ddb

Degrees

DevSq

DGet

DMax

DMin

Dollar

DProduct

DStDev

DStDevP

DSum

DVar

DVarP

E

Even

ExponDist

F

Fact

FDist

Find

FindB

FInv

Fisher

FisherInv

Fixed

Floor

Forecast

Frequency

FTest

Fv

G

GammaDist

GammaInv

GammaLn

GeoMean

Growth

H

HarMean

HLookup

HypGeomDist

I

Index

Intercept

Ipmt

Irr

IsErr

IsError

IsLogical

IsNA

IsNonText

IsNumber

Ispmt

IsText

J

K

Kurt

L

Large

LinEst

Ln

Log

Log10

LogEst

LogInv

LogNormDist

Lookup

M

Match

Max

MDeterm

Median

Min

MInverse

MIrr

MMult

Mode

N

NegBinomDist

NormDist

NormInv

NormSDist

NormSInv

NPer

Npv

O

Odd

Or

P

Pearson

Percentile

PercentRank

Permut

Phonetic

Pi

Pmt

Poisson

Power

Ppmt

Prob

Product

Proper

Pv

Q

Quartile

R

Radians

Rank

Rate

Replace

ReplaceB

Rept

Roman

Round

RoundDown

RoundUp

RSq

S

Search

SearchB

Sinh

Skew

Sln

Slope

Small

Standardize

StDev

StDevP

StEyx

Substitute

Subtotal

Sum

SumIf

SumProduct

SumSq

SumX2MY2

SumX2PY2

SumXMY2

Syd

T

Tanh

TDist

Text

TInv

Transpose

Trend

Trim

TrimMean

TTest

U

USDollar

V

Var

VarP

Vdb

VLookup

W

Weekday

Weibull

X

Y

Z

ZTest


Neue Ereignisse

Zwei neue Visual Basic für Applikationen-Ereignisse wurden zu Microsoft Excel 2000 hinzugefügt. Diese Ereignisse sind in der folgenden Liste aufgeführt.

Ereignis | Objekte
FollowHyperlink | Worksheet
SheetFollowHyperlink | Application, Workbook


Activate-Ereignis

Tritt ein, wenn eine Arbeitsmappe, ein Tabellenblatt, ein Diagrammblatt oder ein eingebettetes Diagramm aktiviert wird.

Syntax

Private Sub object_Activate()

object Chart, Workbook oder Worksheet. Informationen über die Verwendung von Ereignissen mit dem Chart-Objekt finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

Anmerkungen

Wenn Sie zwischen zwei Fenstern wechseln, die dieselbe Arbeitsmappe anzeigen, tritt das WindowActivate-Ereignis ein, jedoch nicht das Activate-Ereignis für die Arbeitsmappe.

Dieses Ereignis tritt nicht ein, wenn Sie ein neues Fenster erstellen.


Beispiel zum Activate-Ereignis

In diesem Beispiel wird der Bereich "A1:A10" sortiert, wenn das Tabellenblatt aktiviert wird.

Private Sub Worksheet_Activate()
    Range("a1:a10").Sort Key1:=Range("a1"), Order:=xlAscending
End Sub


AddinInstall-Ereignis

Tritt ein, wenn die Arbeitsmappe als Add-In installiert wird.

Syntax

Private Sub Workbook_AddinInstall()


Beispiel zum AddinInstall-Ereignis

In diesem Beispiel wird der Standardsymbolleiste ein Steuerelement hinzugefügt, wenn die Arbeitsmappe als Add-In installiert wird.

Private Sub Workbook_AddinInstall()
    With Application.Commandbars("Standard").Controls.Add
        .Caption = "The AddIn's menu item"
        .OnAction = "'ThisAddin.xls'!Amacro"
    End With End Sub
End Sub


AddinUninstall-Ereignis

Tritt ein, wenn die Arbeitsmappe als Add-In deinstalliert wird.

Syntax

Private Sub Workbook_AddinUninstall()

Anmerkungen

Das Add-In wird bei der Deinstallation nicht automatisch geschlossen.


Beispiel zum AddinUninstall-Ereignis

In diesem Beispiel wird Microsoft Excel minimiert, wenn die Arbeitsmappe als Add-In deinstalliert wird.

Private Sub Workbook_AddinUninstall()
    Application.WindowState = xlMinimized
End Sub


AfterRefresh-Ereignis

Tritt ein, wenn eine Abfrage abgeschlossen oder abgebrochen wird.

Syntax

Private Sub QueryTable_AfterRefresh(Success As Boolean)

Success True, falls die Abfrage erfolgreich abgeschlossen wurde.


Beispiel zum AfterRefresh-Ereignis

In diesem Beispiel wird durch das Argument Success festgelegt, welcher Abschnitt des Codes auszuführen ist.

Private Sub QueryTable_AfterRefresh(Success As Boolean)
    If Success
        ' Query completed successfully
    Else
        ' Query failed or was cancelled
    End If
End Sub


BeforeClose-Ereignis

Tritt ein, bevor die Arbeitsmappe geschlossen wird. Wurde die Arbeitsmappe geändert, tritt dieses Ereignis ein, bevor der Benutzer gefragt wird, ob die Änderungen gespeichert werden sollen.

Syntax

Private Sub Workbook_BeforeClose(Cancel As Boolean)

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird das Schließen abgebrochen, und die Arbeitsmappe bleibt geöffnet.


Beispiel zum BeforeClose-Ereignis

In diesem Beispiel wird die Arbeitsmappe immer gespeichert, wenn sie geändert wurde.

Private Sub Workbook_BeforeClose(Cancel as Boolean)
    If Me.Saved = False Then Me.Save
End Sub


BeforeDoubleClick-Ereignis

Tritt ein, wenn auf ein eingebettetes Diagramm oder auf ein Tabellenblatt vor Durchführung des Standard-Doppelklicks doppelgeklickt wird.

Syntax 1

Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)

Syntax 2

Private Sub object_BeforeDoubleClick(ByVal ElementID As Long, ByVal Arg1 As Long, ByVal Arg2 As Long, Cancel As Boolean)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

Target Die Zelle, die beim Doppelklick dem Mauszeiger am nächsten liegt.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird nach Beendigung der Prozedur der Standard-Doppelklick nicht ausgeführt.

ElementID Das Objekt, auf das doppelgeklickt wird. Die Bedeutung von Arg1 und Arg2 hängt von dem ElementID-Wert ab, wie in der folgenden Tabelle zu sehen ist.

ElementID | Arg1 | Arg2
xlChartArea | Keine | Keine
xlChartTitle | Keine | Keine
xlPlotArea | Keine | Keine
xlLegend | Keine | Keine
xlFloor | Keine | Keine
xlWalls | Keine | Keine
xlCorners | Keine | Keine
xlDataTable | Keine | Keine
xlSeries | SeriesIndex | PointIndex
xlDataLabel | SeriesIndex | PointIndex
xlTrendline | SeriesIndex | TrendLineIndex
xlErrorBars | SeriesIndex | Keine
xlXErrorBars | SeriesIndex | Keine
xlYErrorBars | SeriesIndex | Keine
xlLegendEntry | SeriesIndex | Keine
xlLegendKey | SeriesIndex | Keine
xlAxis | AxisIndex | AxisType
xlMajorGridlines | AxisIndex | AxisType
xlMinorGridlines | AxisIndex | AxisType
xlAxisTitle | AxisIndex | AxisType
xlDisplayUnitLabel | AxisIndex | AxisType
xlUpBars | GroupIndex | Keine
xlDownBars | GroupIndex | Keine
xlSeriesLines | GroupIndex | Keine
xlHiLoLines | GroupIndex | Keine
xlDropLines | GroupIndex | Keine
xlRadarAxisLabels | GroupIndex | Keine
xlShape | ShapeIndex | Keine
xlPivotChartDropZone | DropZoneType | Keine
xlPivotChartFieldButton | DropZoneType | PivotFieldIndex
xlNothing | Keine | Keine

In der folgenden Tabelle sind die Argumente beschrieben.

Argument | Beschreibung
SeriesIndex | Legt die Position einer bestimmten Datenreihe innerhalb der Series-Auflistung fest.
PointIndex | Legt die Position eines bestimmten Punktes in einer Datenreihe innerhalb der Points-Auflistung fest. Der Wert – 1 zeigt an, dass alle Datenpunkte ausgewählt sind.
TrendlineIndex | Legt die Position einer bestimmten Trendlinie in einer Datenreihe innerhalb der Trendlines-Auflistung fest.
AxisIndex | Gibt an, ob es sich um eine primäre oder eine sekundäre Achse handelt. Kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary.
AxisType | Gibt den Achsentyp an. Kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeriesAxis oder xlValue.
GroupIndex | Legt die Position einer bestimmten Diagrammgruppe innerhalb der ChartGroups-Auflistung fest.
ShapeIndex | Legt die Position einer bestimmten Form innerhalb der Shapes-Auflistung fest.
DropZoneType | Gibt den Typ der Ablegezone an: Spalten-, Daten-, Seiten- oder Zeilenfeld. Kann eine der folgenden XlPivotFieldOrientation-Konstanten sein: xlColumnField, xlDataField, xlPageField oder xlRowField. Die Spalten- und Zeilenfeldkonstanten geben die Datenreihen- bzw. die Rubrikenfelder an.
PivotFieldIndex | Gibt den Offset in der PivotFields-Auflistung für ein bestimmten Spalten- (Datenreihe), Daten-, Seiten oder Zeilenfeld (Rubrik) an.

Anmerkungen

Die DoubleClick-Methode löst dieses Ereignis nicht aus.

Dieses Ereignis tritt nicht ein, wenn der Benutzer auf den Rahmen einer Zelle doppelklickt.


Beispiel zum BeforeDoubleClick-Ereignis

In diesem Beispiel wird das Verhalten bei einem Standard-Doppelklick auf die Bodenfläche eines Diagramms ersetzt.

Private Sub Chart_BeforeDoubleClick(ByVal ElementID As Long, _
        ByVal Arg1 As Long, ByVal Arg2 As Long, Cancel As Boolean)
    If ElementID = xlFloor Then
        Cancel = True
        MsgBox "Chart formatting for this item is restricted."
    End If
End Sub


BeforePrint-Ereignis

Tritt ein, bevor die Arbeitsmappe (oder darin enthaltene Teile) gedruckt wird.

Syntax

Private Sub Workbook_BeforePrint(Cancel As Boolean)

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Arbeitsmappe nach Beendigung der Prozedur nicht gedruckt.


Beispiel zum BeforePrint-Ereignis

In diesem Beispiel werden vor dem Drucken alle Tabellenblätter der aktiven Arbeitsmappe aktualisiert.

Private Sub Workbook_BeforePrint(Cancel As Boolean)
    For Each wk in Worksheets
        wk.Calculate
    Next
End Sub


BeforeRefresh-Ereignis

Tritt vor jeder Aktualisierung der Abfragetabelle ein. Dazu zählen auch Aktualisierungen, die durch Aufrufen der Refresh-Methode, durch Aktionen des Benutzers im Produkt oder durch Öffnen der Arbeitsmappe, die die Abfragetabelle enthält, ausgelöst werden.

Syntax

Private Sub QueryTable_BeforeRefresh(Cancel As Boolean)

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Aktualisierung nach Beendigung der Prozedur nicht durchgeführt.


Beispiel zum BeforeRefresh-Ereignis

Dieses Beispiel wird vor der Aktualisierung der Abfragetabelle ausgeführt.

Private Sub QueryTable_BeforeRefresh(Cancel As Boolean)
    a = MsgBox("Refresh Now?", vbYesNoCancel)
    If a = vbNo Then Cancel = True
    MsgBox Cancel
End Sub


BeforeRightClick-Ereignis

Tritt ein, wenn mit der rechten Maustaste auf ein eingebettetes Diagramm oder ein Tabellenblatt vor Durchführung des Standard-Rechtsklicks geklickt wird.

Syntax 1

Private Sub object_BeforeRightClick(Cancel As Boolean)

Syntax 2

Private Sub Worksheet_BeforeRightClick(ByVal Target As Range, Cancel As Boolean)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

Target Die Zelle, die beim Rechtsklick dem Mauszeiger am nächsten liegt.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird nach Beendigung der Prozedur der Standard-Rechtsklick nicht ausgeführt.

Anmerkungen

Dieses Ereignis tritt, ebenso wie andere Tabellenblattereignisse, nicht ein, wenn Sie mit der rechten Maustaste klicken, während sich der Zeiger auf einer Form oder einer Befehlsleiste (einer Symbol- oder Menüleiste) befindet.


Beispiel zum BeforeRightClick-Ereignis

In diesem Beispiel wird für die Zellen B1:B10 ein neuer Menübefehl in das Kontextmenü eingefügt.

Private Sub Worksheet_BeforeRightClick(ByVal Target As Range, _
        Cancel As Boolean)
    For Each icbc In Application.CommandBars("cell").Controls
        If icbc.Tag = "brccm" Then icbc.Delete
    Next icbc
    If Not Application.Intersect(Target, Range("b1:b10")) _
        Is Nothing Then
            With Application.CommandBars("cell").Controls _
                .Add(Type:=msoControlButton, before:=6, _
                temporary:=True)
           .Caption = "New Context Menu Item"
           .OnAction = "MyMacro"
           .Tag = "brccm"
        End With
    End If
End Sub


BeforeSave-Ereignis

Tritt ein, bevor die Arbeitsmappe gespeichert wird.

Syntax

Private Sub Workbook_BeforeSave(ByVal SaveAsUi As Boolean, Cancel As Boolean)

SaveAsUi True, wenn das Dialogfeld Speichern unter angezeigt wird.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Arbeitsmappe nach Beendigung der Prozedur nicht gespeichert.


Beispiel zum BeforeSave-Ereignis

In diesem Beispiel wird der Benutzer aufgefordert, mit Ja oder Nein zu antworten, bevor die Arbeitsmappe gespeichert wird.

Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, _
        Cancel as Boolean)
    a = MsgBox("Do you really want to save the workbook?", vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


Calculate-Ereignis

Chart-Objekt: Tritt ein, nachdem im Diagramm neue oder geänderte Daten aufgezeichnet worden sind.

Worksheet-Objekt: Tritt ein, nachdem das Tabellenblatt neuberechnet worden ist.

Syntax

Private Sub object_Calculate()

object Chart oder Worksheet. Informationen über die Verwendung von Ereignissen mit dem Chart-Objekt finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.


Beispiel zum Calculate-Ereignis

In diesem Beispiel wird die Größe der Spalten A bis F bei jeder Neuberechnung des Tabellenblattes angepasst.

Private Sub Worksheet_Calculate()
    Columns("A:F").AutoFit
End Sub


Change-Ereignis

Tritt ein, wenn Zellen des Tabellenblattes durch den Benutzer oder durch eine externe Verknüpfung geändert werden.

Syntax

Private Sub Worksheet_Change(ByVal Target As Range)

Target Der geänderte Bereich. Er kann mehr als eine Zelle umfassen.

Anmerkungen

Dieses Ereignis tritt nicht ein, wenn sich Zellen während einer Neuberechnung verändern. Verwenden Sie das Calculate-Ereignis, um eine Neuberechnung des Blattes aufzufangen.

Durch das Löschen von Zellen wird dieses Ereignis nicht ausgelöst.


Beispiel zum Change-Ereignis

In diesem Beispiel werden geänderte Zellen in blauer Farbe dargestellt.

Private Sub Worksheet_Change(ByVal Target as Range)
    Target.Font.ColorIndex = 5
End Sub


Deactivate-Ereignis

Tritt ein, wenn das Diagramm, das Tabellenblatt oder die Arbeitsmappe deaktiviert wird.

Syntax

Private Sub object_Deactivate()

object Chart, Workbook oder Worksheet. Informationen über die Verwendung von Ereignissen mit dem Chart-Objekt finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.


Beispiel zum Deactivate-Ereignis

In diesem Beispiel werden alle geöffneten Fenster angeordnet, wenn die Arbeitsmappe deaktiviert wird.

Private Sub Workbook_Deactivate()
    Application.Windows.Arrange xlArrangeStyleTiled
End Sub


DragOver-Ereignis

Tritt ein, wenn ein Zellbereich über ein Diagramm gezogen wird.

Syntax

Private Sub object_DragOver()

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.


Beispiel zum DragOver-Ereignis

In diesem Beispiel wird die Adresse eines Zellbereichs angezeigt, der über ein Diagramm gezogen wurde.

Private Sub Chart_DragOver()
    MsgBox Selection.Address
End Sub


DragPlot-Ereignis

Tritt ein, wenn ein Zellbereich auf ein Diagramm gezogen und abgelegt wird.

Syntax

Private Sub object_DragPlot()

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.


Beispiel zum DragPlot-Ereignis

In diesem Beispiel wird der Diagrammtyp geändert, wenn ein Zellbereich auf ein Diagramm gezogen und abgelegt wird.

Private Sub Chart_DragPlot()
    Me.ChartType = xlLine
End Sub


FollowHyperlink-Ereignis

Tritt ein, wenn Sie auf einen beliebigen Hyperlink in einem Tabellenblatt klicken. Weitere Informationen zu Ereignissen auf Anwendungs- und Arbeitsmappenebene finden Sie unter dem SheetFollowHyperlink-Ereignis.

Syntax

Private Sub Worksheet_FollowHyperlink(ByVal Target As Hyperlink)

Target Hyperlink erforderlich. Ein Hyperlink-Objekt, das das Ziel des Hyperlinks darstellt.


Beispiel zum FollowHyperlink-Ereignis

In diesem Beispiel wird eine Liste oder der Verlauf aller Hyperlinks, die von dem aktiven Tabellenblatt aus besucht wurden, angezeigt.

Private Sub Worksheet_FollowHyperlink(ByVal Target As Hyperlink)
    With UserForm1
        .ListBox1.AddItem Target.Address
        .Show
    End With
End Sub


GotFocus-Ereignis

Tritt ein, wenn ein ActiveX-Steuerelement einen Eingabe-Fokus erhält.

Syntax

Private Sub Objekt_GotFocus()

Objekt Der Name eines ActiveX-Steuerelements.


Beispiel zum GotFocus-Ereignis

Dieses Beispiel wird ausgeführt, wenn ListFeld1 den Fokus erhält.

Private Sub ListBox1_GotFocus()
    ' runs when list box gets the focus
End Sub


LostFocus-Ereignis

Tritt ein, wenn ein ActiveX-Steuerelement den Eingabe-Fokus verliert.

Syntax

Private Sub Objekt_LostFocus()

Objekt Der Name eines ActiveX-Steuerelements.


Beispiel zum LostFocus-Ereignis

Dieses Beispiel wird ausgeführt, wenn ListFeld1 den Fokus verliert.

Private Sub ListBox1_LostFocus()
    ' runs when list box loses the focus
End Sub


MouseDown-Ereignis

Tritt ein, wenn eine Maustaste gedrückt wird, während sich der Zeiger über einem Diagramm befindet.

Syntax

Private Sub object_MouseDown(ByVal Button As Long, ByVal Shift As Long, ByVal X As Long, ByVal Y As Long)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

Button Die Maustaste, die gedrückt wurde. Dies kann eine der folgenden XlMouseButton-Konstanten sein: xlNoButton, xlPrimaryButton, xlSecondaryButton oder xlMiddleButton.

Shift Der Zustand der Tasten UMSCHALT, STRG und ALT beim Eintreten des Ereignisses. Dies kann einer oder eine Summe der folgenden Werte sein.

Wert | Bedeutung
0 (zero) | Keine Tasten
1 | UMSCHALTTASTE
2 | STRG-Taste
4 | ALT-Taste

X Die X-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.

Y Die Y-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.


Beispiel zum MouseDown-Ereignis

Dieses Beispiel wird ausgeführt, wenn eine Maustaste gedrückt wird, während sich der Zeiger über einem Diagramm befindet.

Private Sub Chart_MouseDown(ByVal Button As Long, _
        ByVal Shift As Long, ByVal X As Long, ByVal Y As Long)
    MsgBox "Button = " & Button & chr$(13) & _
        "Shift = " & Shift & chr$(13) & _
        "X = " & X & " Y = " & Y
End Sub


MouseMove-Ereignis

Tritt ein, wenn sich die Position des Mauszeigers über einem Diagramm ändert.

Syntax

Private Sub object_MouseMove(ByVal X As Long, ByVal Y As Long)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

X Die X-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.

Y Die Y-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.


Beispiel zum MouseMove-Ereignis

Dieses Beispiel wird ausgeführt, wenn sich die Position des Mauszeigers über einem Diagramm ändert.

Private Sub Chart_MouseMove(ByVal X As Long, ByVal Y As Long)
    MsgBox "X = " & X & " Y = " & Y
End Sub


MouseUp-Ereignis

Tritt ein, wenn eine Maustaste losgelassen wird, während sich der Zeiger über einem Diagramm befindet.

Syntax

Private Sub object_MouseUp(ByVal Button As Long, ByVal Shift As Long, ByVal X As Long, ByVal Y As Long)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

Button Die losgelassene Maustaste. Dies kann eine der folgenden XlMouseButton-Konstanten sein: xlNoButton, xlPrimaryButton, xlSecondaryButton oder xlMiddleButton.

Shift Der Zustand der Tasten UMSCHALT, STRG und ALT beim Eintreten des Ereignisses. Dies kann einer oder eine Summe der folgenden Werte sein.

Wert | Bedeutung
0 (zero) | Keine Tasten
1 | UMSCHALTTASTE
2 | STRG-TASTE
4 | ALT-TASTE

X Die X-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.

Y Die Y-Koordinate des Mauszeigers in Diagrammobjekt-Client-Koordinaten.


Beispiel zum MouseUp-Ereignis

Dieses Beispiel wird ausgeführt, wenn eine Maustaste über einem Diagramm losgelassen wird.

Private Sub Chart_MouseUp(ByVal Button As Long, _
        ByVal Shift As Long, ByVal X As Long, ByVal Y As Long)
    MsgBox "Button = " & Button & chr$(13) & _
        "Shift = " & Shift & chr$(13) & _
        "X = " & X & " Y = " & Y
End Sub


NewSheet-Ereignis

Tritt ein, wenn in einer Arbeitsmappe ein neues Blatt erstellt wird.

Syntax

Private Sub Workbook_NewSheet(ByVal Sh As Object)

Sh Das neue Blatt. Dies kann ein Worksheet- oder ein Chart-Objekt sein.


Beispiel zum NewSheet-Ereignis

In diesem Beispiel werden neue Blätter an das Ende der Arbeitsmappe verschoben.

Private Sub Workbook_NewSheet(ByVal Sh as Object)
    Sh.Move After:= Sheets(Sheets.Count)
End Sub


NewWorkbook-Ereignis

Tritt ein, wenn eine neue Arbeitsmappe erstellt wird.

Syntax

Private Sub object_NewWorkbook(ByVal Wb As Workbook)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die neue Arbeitsmappe.


Beispiel zum NewWorkbook-Ereignis

In diesem Beispiel werden geöffnete Fenster angeordnet, wenn eine neue Arbeitsmappe erstellt wird.

Private Sub App_NewWorkbook(ByVal Wb As Workbook)
    Application.Windows.Arrange xlArrangeStyleTiled
End Sub


Open-Ereignis

Tritt ein, wenn die Arbeitsmappe geöffnet wird.

Syntax

Private Sub Workbook_Open()


Beispiel zum Open-Ereignis

In diesem Beispiel wird Microsoft Excel bei jedem Öffnen der Arbeitsmappe maximiert.

Private Sub Workbook_Open()
    Application.WindowState = xlMaximized
End Sub


Resize-Ereignis

Tritt ein, wenn die Größe des Diagramms angepasst wird.

Syntax

Private Sub Objekt_Resize()

Objekt Chart oder ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit eingebetteten Diagrammen.


Beispiel zum Resize-Ereignis

In diesem Beispiel bleibt die obere linke Ecke des Diagramms an derselben Position, wenn die Größe des Diagramms angepasst wird.

Private Sub myChartClass_Resize()
    With ActiveChart.Parent
        .Left = 100
        .Top = 150
    End With
End Sub


Select-Ereignis

Tritt ein, wenn ein Diagrammelement markiert wird.

Syntax

Private Sub Objekt_Select(ByVal ElementID As Long, ByVal Arg1 As Long, ByVal Arg2 As Long)

Objekt Chart oder ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit eingebetteten Diagrammen.

ElementID, Arg1, Arg2 Das markierte Diagrammelement. Weitere Informationen über diese Argumente finden Sie unter dem BeforeDoubleClick-Ereignis.


SelectionChange-Ereignis

Tritt ein, wenn sich die Markierung in einem Arbeitsblatt ändert.

Syntax

Private Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)

Target Der neu markierte Bereich.


Beispiel zum SelectionChange-Ereignis

In diesem Beispiel wird im Arbeitsmappenfenster ein Bildlauf durchgeführt, bis sich die Markierung in der oberen linken Ecke des Fensters befindet.

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    With ActiveWindow
        .ScrollRow = Target.Row
        .ScrollColumn = Target.Column
    End With
End Sub


SeriesChange-Ereignis

Tritt ein, wenn der Benutzer den Wert eines Diagrammdatenpunktes ändert.

Syntax

Private Sub object_SeriesChange(ByVal SeriesIndex As Long, ByVal PointIndex As Long)

object Ein Objekt des Typs Chart, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Chart-Objekt.

SeriesIndex Die Position der geänderten Datenreihe innerhalb der Series-Auflistung.

PointIndex Die Position des geänderten Punktes innerhalb der Points-Auflistung.


Beispiel zum SeriesChange-Ereignis

In diesem Beispiel wird die Rahmenfarbe des Punktes geändert, wenn der Benutzer den Punktwert ändert.

Private Sub Chart_SeriesChange(ByVal SeriesIndex As Long, _
        ByVal PointIndex As Long)
    Set p = Me.SeriesCollection(SeriesIndex).Points(PointIndex)
    p.Border.ColorIndex = 3
End Sub


SheetActivate-Ereignis

Tritt ein, wenn ein beliebiges Blatt aktiviert wird.

Syntax

Private Sub object_SheetActivate(ByVal Sh As Object)

object Application oder Workbook.

Sh Das aktivierte Blatt. Dies kann ein Chart oder ein Worksheet-Objekt sein.


Beispiel zum SheetActivate-Ereignis

In diesem Beispiel wird der Name jedes aktivierten Blattes angezeigt.

Private Sub Workbook_SheetActivate(ByVal Sh As Object)
    MsgBox Sh.Name
End Sub


SheetBeforeDoubleClick-Ereignis

Tritt ein, wenn auf ein beliebiges Tabellenblatt vor Durchführung des Standard-Doppelklicks doppelgeklickt wird.

Syntax

Private Sub object_SheetBeforeDoubleClick(ByVal Sh As Object, ByVal Target As Range, ByVal Cancel As Boolean)

object Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Sh Ein Worksheet-Objekt, das das Blatt darstellt.

Target Die Zelle, die beim Auftreten des Doppelklicks dem Mauszeiger am nächsten liegt.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird nach Beendigung der Prozedur der Standard-Doppelklick nicht durchgeführt.

Anmerkungen

Dieses Ereignis tritt bei Diagrammblättern nicht ein.


Beispiel zum SheetBeforeDoubleClick-Ereignis

In diesem Beispiel wird der Standard-Doppelklick deaktiviert.

Private Sub Workbook_SheetBeforeDoubleClick(ByVal Sh As Object, _
        ByVal Target As Range, ByVal Cancel As Boolean)
    Cancel = True
End Sub


SheetBeforeRightClick-Ereignis

Tritt ein, wenn mit der rechten Maustaste auf ein beliebiges Tabellenblatt vor Durchführung des Standard-Rechtsklicks geklickt wird.

Syntax

Private Sub object_SheetBeforeRightClick(ByVal Sh As Object, ByVal Target As Range, ByVal Cancel As Boolean)

object Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Sh Ein Worksheet-Objekt, das das Blatt darstellt.

Target Die Zelle, die beim Auftreten des Rechtsklicks dem Mauszeiger am nächsten liegt.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird nach Beendigung der Prozedur der Standard-Rechtsklick nicht ausgeführt.

Anmerkungen

Dieses Ereignis tritt bei Diagrammblättern nicht ein.


Beispiel zum SheetBeforeRightClick-Ereignis

In diesem Beispiel wird die Durchführung des Standard-Rechtsklicks deaktiviert. Ein weiteres Beispiel hierzu finden Sie unter dem Beispiel zu dem BeforeRightClick-Ereignis.

Private Sub Workbook_SheetBeforeRightClick(ByVal Sh As Object, _
        ByVal Target As Range, ByVal Cancel As Boolean)
    Cancel = True
End Sub


SheetCalculate-Ereignis

Tritt nach Neuberechnung jedes Tabellenblattes auf, oder wenn beliebige geänderte Daten in einem Diagramm aufgezeichnet werden.

Syntax

Private Sub object_SheetCalculate(ByVal Sh As Object)

object Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Sh Das Blatt. Dies kann ein Chart- oder ein Worksheet-Objekt sein.


Beispiel zum SheetCalculate-Ereignis

In diesem Beispiel wird der Bereich "A1:A100" des ersten Tabellenblattes sortiert, wenn ein beliebiges Blatt der Arbeitsmappe berechnet wird.

Private Sub Workbook_SheetCalculate(ByVal Sh As Object)
    With Worksheets(1)
        .Range("a1:a100").Sort Key1:=.Range("a1")
    End With
End Sub


SheetChange-Ereignis

Tritt ein, wenn ein beliebiges Tabellenblatt durch den Benutzer oder durch eine externe Verknüpfung geändert wird.

Syntax

Private Sub object_SheetChange(ByVal Sh As Object, ByVal Source As Range)

object Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Sh Ein Worksheet-Objekt, das das Blatt darstellt.

Source Der geänderte Bereich.

Anmerkungen

Dieses Ereignis tritt bei Diagrammblättern nicht auf.


Beispiel zum SheetChange-Ereignis

Dieses Beispiel wird ausgeführt, wenn ein beliebiges Tabellenblatt geändert wird.

Private Sub Workbook_SheetChange(ByVal Sh As Object, _
        ByVal Source As Range)
    ' runs when a sheet is changed
End Sub


SheetDeactivate-Ereignis

Tritt ein, wenn ein beliebiges Blatt deaktiviert wird.

Syntax

Private Sub object_SheetDeactivate(ByVal Sh As Object)

object Application oder Workbook.

Sh Das Blatt. Dies kann ein Chart- oder ein Worksheet-Objekt sein.


Beispiel zum SheetDeactivate-Ereignis

In diesem Beispiel wird der Name jedes deaktivierten Blattes angezeigt.

Private Sub Workbook_SheetDeactivate(ByVal Sh As Object)
    MsgBox Sh.Name
End Sub


SheetFollowHyperlink-Ereignis

Tritt ein, wenn Sie in Microsoft Excel auf einen beliebigen Hyperlink klicken. Weitere Informationen zu Ereignissen auf Arbeitsmappenebene finden Sie im Hilfethema zum FollowHyperlink-Ereignis.

Syntax

Private Sub Application_SheetFollowHyperlink(ByVal Sh As Object, ByVal Target As Hyperlink)

Syntax

Private Sub Workbook_SheetFollowHyperlink(ByVal Sh As Object, ByVal Target As Hyperlink)

Sh Object erforderlich. Das Worksheet-Objekt, das den Hyperlink enthält.

Target Hyperlink erforderlich. Das Hyperlink-Objekt, das das Ziel des Hyperlinks darstellt.


Beispiel zum SheetFollowHyperlink-Ereignis

In diesem Beispiel wird eine Liste bzw. ein Verlauf aller Hyperlinks in der aktuellen Arbeitsmappe angezeigt, auf die geklickt wurde, sowie die Namen der Tabellenblätter, die die betreffenden Hyperlinks enthalten.

Private Sub Workbook_SheetFollowHyperlink(ByVal Sh as Object, _
    ByVal Target As Hyperlink)
    UserForm1.ListBox1.AddItem Sh.Name & ":" & Target.Address
    UserForm1.Show
End Sub


SheetSelectionChange-Ereignis

Tritt ein, wenn sich die Markierung in einem Arbeitsblatt ändert (tritt nicht ein, falls sich die Markierung in einem Diagrammblatt befindet).

Syntax

Private Sub Objekt_SheetSelectionChange(ByVal Sh As-Objekt, ByVal Target As Excel.Range)

Objekt Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Sh Das Arbeitsblatt, das die neue Markierung enthält.

Target Der neu markierte Bereich.


Beispiel zum SheetSelectionChange-Ereignis

In diesem Beispiel wird der Blattname und die Adresse des markierten Bereichs in der Statusleiste angezeigt.

Private Sub Workbook_SheetSelectionChange(ByVal Sh As Object, _
        ByVal Target As Excel.Range)
    Application.StatusBar = Sh.Name & ":" & Target.Address
End Sub


WindowActivate-Ereignis

Tritt ein, wenn ein Arbeitsmappenfenster aktiviert wird.

Syntax

Private Sub Objekt_WindowActivate(ByVal Wb As Excel.Workbook, ByVal Wn As Excel.Window)

Objekt Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Wird nur mit dem Application-Objekt verwendet. Die im aktivierten Fenster angezeigte Arbeitsmappe.

Wn Das aktivierte Fenster.


Beispiel zum WindowActivate-Ereignis

In diesem Beispiel wird eine Arbeitsmappe maximiert, wenn sie aktiviert wird.

Private Sub Workbook_WindowActivate(ByVal Wn As Excel.Window)
    Wn.WindowState = xlMaximized
End Sub


WindowDeactivate-Ereignis

Tritt ein, wenn ein Arbeitsmappenfenster deaktiviert wird.

Syntax

Private Sub Objekt_WindowDeactivate(ByVal Wb As Excel.Workbook, ByVal Wn As Excel.Window)

Objekt Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Wird nur mit dem Application-Objekt verwendet. Die im deaktivierten Fenster angezeigte Arbeitsmappe.

Wn Das deaktivierte Fenster.


Beispiel zum WindowDeactivate-Ereignis

In diesem Beispiel wird eine Arbeitsmappe minimiert, wenn sie deaktiviert wird.

Private Sub Workbook_WindowDeactivate(ByVal Wn As Excel.Window)
    Wn.WindowState = xlMinimized
End Sub


WindowResize-Ereignis

Tritt ein, wenn die Größe eines Arbeitsmappenfensters angepasst wird.

Syntax

Private Sub Objekt_WindowResize(ByVal Wb As Excel.Workbook, ByVal Wn As Excel.Window)

Objekt Application oder Workbook. Weitere Informationen über die Verwendung von Ereignissen mit dem Application-Objekt finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Wird nur mit dem Application-Objekt verwendet. Die in dem Fenster, dessen Größe angepasst wurde, angezeigte Arbeitsmappe.

Wn Das Fenster, dessen Größe angepasst wurde.


Beispiel zum WindowResize-Ereignis

Dieses Beispiel wird ausgeführt, wenn die Größe eines Arbeitsmappenfensters angepasst wird.

Private Sub Workbook_WindowResize(ByVal Wn As Excel.Window)
    Application.StatusBar = Wn.Caption & " resized"
End Sub


WorkbookActivate-Ereignis

Tritt ein, wenn eine beliebige Arbeitsmappe aktiviert wird.

Syntax

Private Sub app_WorkbookActivate(ByVal Wb As Workbook)

app Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die aktivierte Arbeitsmappe.


Beispiel zum WorkbookActivate-Ereignis

In diesem Beispiel werden die geöffneten Fenster angeordnet, wenn eine Arbeitsmappe aktiviert wird.

Private Sub App_WorkbookActivate(ByVal Wb As Workbook)
    Application.Windows.Arrange xlArrangeStyleTiled
End Sub


WorkbookAddinInstall-Ereignis

Tritt ein, wenn eine Arbeitsmappe als Add-In installiert wird.

Syntax

Private Sub object_WorkbookAddinInstall(ByVal Wb As Workbook)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die installierte Arbeitsmappe.


Beispiel zum WorkbookAddinInstall-Ereignis

In diesem Beispiel wird das Microsoft Excel-Fenster maximiert, wenn eine Arbeitsmappe als Add-In installiert wird.

Private Sub App_WorkbookAddinInstall(ByVal Wb As Workbook)
    Application.WindowState = xlMaximized
End Sub


WorkbookAddinUninstall-Ereignis

Tritt ein, wenn eine beliebige Add-In-Arbeitsmappe deinstalliert wird.

Syntax

Private Sub object_WorkbookAddinUninstall(ByVal Wb As Workbook)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die deinstallierte Arbeitsmappe.


Beispiel zum WorkbookAddinUninstall-Ereignis

In diesem Beispiel wird das Microsoft Excel-Fenster minimiert, wenn eine Arbeitsmappe als Add-In installiert wird.

Private Sub App_WorkbookAddinUninstall(ByVal Wb As Workbook)
    Application.WindowState = xlMinimized
End Sub


WorkbookBeforeClose-Ereignis

Tritt direkt vor dem Schließen einer beliebigen geöffneten Arbeitsmappe ein.

Syntax

Private Sub object_WorkbookBeforeClose(ByVal Wb As Workbook, ByVal Cancel As Boolean)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe, die geschlossen wird.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Arbeitsmappe nach Beendigung der Prozedur nicht geschlossen.


Beispiel zum WorkbookBeforeClose-Ereignis

In diesem Beispiel wird der Benutzer aufgefordert, mit Ja oder Nein zu antworten, bevor eine Arbeitsmappe geschlossen wird.

Private Sub App_WorkbookBeforeClose(ByVal Wb as Workbook, _
        Cancel as Boolean)
    a = MsgBox("Do you really want to close the workbook?", _
        vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


WorkbookBeforePrint-Ereignis

Tritt ein, bevor eine beliebige Arbeitsmappe gedruckt wird.

Syntax

Private Sub object_WorkbookBeforePrint(ByVal Wb As Workbook, ByVal Cancel As Boolean)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Arbeitsmappe nach Beendigung der Prozedur nicht gedruckt.


Beispiel zum WorkbookBeforePrint-Ereignis

In diesem Beispiel werden alle Tabellenblätter der Arbeitsmappe vor dem Drucken neu berechnet.

Private Sub App_WorkbookBeforePrint(ByVal Wb As Workbook, _
        Cancel As Boolean)
    For Each wk in Wb.Worksheets
        wk.Calculate
    Next
End Sub


WorkbookBeforeSave-Ereignis

Tritt ein, bevor eine beliebige geöffnete Arbeitsmappe gespeichert wird.

Syntax

Private Sub object_WorkbookBeforeSave(ByVal Wb As Workbook, ByVal SaveAsUi As Boolean, ByVal Cancel As Boolean)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe.

SaveAsUi True, wenn das Dialogfeld Save As angezeigt wird.

Cancel False, wenn das Ereignis eintritt. Falls die Ereignisprozedur dieses Argument auf True setzt, wird die Arbeitsmappe nach Beendigung der Prozedur nicht gespeichert.


Beispiel zum WorkbookBeforeSave-Ereignis

In diesem Beispiel wird der Benutzer aufgefordert, mit Ja oder Nein zu antworten, bevor eine Arbeitsmappe gespeichert wird.

Private Sub App_WorkbookBeforeSave(ByVal Wb As Workbook, _
        ByVal SaveAsUI As Boolean, Cancel as Boolean)
    a = MsgBox("Do you really want to save the workbook?", vbYesNo)
    If a = vbNo Then Cancel = True
End Sub


WorkbookDeactivate-Ereignis

Tritt ein, wenn eine beliebige geöffnete Arbeitsmappe deaktiviert wird.

Syntax

Private Sub object_WorkbookDeactivate(ByVal Wb As Workbook)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe.


Beispiel zum WorkbookDeactivate-Ereignis

In diesem Beispiel werden alle geöffneten Fenster angeordnet, wenn eine Arbeitsmappe deaktiviert wird.

Private Sub App_WorkbookDeactivate(ByVal Wb As Workbook)
    Application.Windows.Arrange xlArrangeStyleTiled
End Sub


WorkbookNewSheet-Ereignis

Tritt ein, wenn in einer beliebigen geöffneten Arbeitsmappe ein neues Blatt erstellt wird.

Syntax

Private Sub object_WorkbookNewSheet(ByVal Wb As Workbook, ByVal Sh As Object)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe.

Sh Das neue Blatt.


Beispiel zum WorkbookNewSheet-Ereignis

In diesem Beispiel wird das neue Blatt an das Ende der Arbeitsmappe verschoben.

Private Sub App_WorkbookNewSheet(ByVal Wb As Workbook, _
        ByVal Sh As Object)
    Sh.Move After:=Wb.Sheets(Wb.Sheets.Count)
End Sub


WorkbookOpen-Ereignis

Tritt ein, wenn eine Arbeitsmappe geöffnet wird.

Syntax

Private Sub object_WorkbookOpen(ByVal Wb As Workbook)

object Ein Objekt des Typs Application, das mit Ereignissen in einem Klassenmodul deklariert ist. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Wb Die Arbeitsmappe.


Beispiel zum WorkbookOpen-Ereignis

In diesem Beispiel werden alle geöffneten Fenster angeordnet, wenn eine Arbeitsmappe geöffnet wird.

Private Sub  App_WorkbookOpen(ByVal Wb As Workbook)
    Application.Windows.Arrange xlArrangeStyleTiled
End Sub


SolverAdd-Funktion

Fügt eine Nebenbedingung zum aktuellen Problem hinzu. Entspricht dem Klicken auf Solver im Menü Extras und anschließend auf Hinzufügen im Dialogfeld Solver-Parameter.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xla im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverAdd(CellRef, Relation, FormulaText)

CellRef Variant erforderlich. Ein Bezug auf eine Zelle oder einen Zellbereich, der die linke Seite einer Nebenbedingung darstellt.

Relation Integer erforderlich. Die arithmetische Beziehung zwischen der linken und rechten Seite der Nebenbedingung. Wenn Sie 4 oder 5 wählen, muss CellRef sich auf einstellbare (veränderliche) Zellen beziehen, und FormulaText darf nicht angegeben werden.

Relation | Arithmetische Beziehung
1 |  | <=
2 |  | =
3 |  | >=
4 |  | Die durch CellRef bezeichneten Zellen müssen Ganzzahlen als Endwerte enthalten.
5 |  | Die durch CellRef bezeichneten Zellen müssen als Endwert entweder 0 (Null) oder 1 enthalten.

FormulaText Variant optional. Die rechte Seite der Nebenbedingung.

Anmerkungen

Nach dem Hinzufügen von Nebenbedingungen können Sie diese mit den Funktionen SolverChange und SolverDelete bearbeiten.


Beispiel zur SolverAdd-Funktion

In diesem Beispiel werden die Solver-Funktionen verwendet, um den Gesamtgewinn in einer Geschäftsaufgabe zu maximieren. Die SolverAdd-Funktion wird eingesetzt, um dem aktuellen Problem drei Nebenbedingungen hinzuzufügen.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions precision:=0.001
SolverOK setCell:=Range("TotalProfit"), _
    maxMinVal:=1, _
    byChange:=Range("C4:E6")
SolverAdd cellRef:=Range("F4:F6"), _
    relation:=1, _
    formulaText:=100
SolverAdd cellRef:=Range("C4:E6"), _
    relation:=3, _
    formulaText:=0
SolverAdd cellRef:=Range("C4:E6"), _
    relation:=4
SolverSolve userFinish:=False
SolverSave saveArea:=Range("A33")


SolverChange-Funktion

Ändert eine bestehende Nebenbedingung. Entspricht dem Klicken im Menü Extras auf Solver und anschließend auf Ändern im Dialogfeld Solver-Parameter.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverChange(CellRef, Relation, FormulaText)

CellRef Variant erforderlich. Ein Bezug auf eine Zelle oder einen Zellbereich, der die linke Seite einer Nebenbedingung darstellt.

Relation Integer erforderlich. Die arithmetische Beziehung zwischen der linken und rechten Seite der Nebenbedingung. Wenn Sie 4 oder 5 wählen, muss CellRef sich auf einstellbare (veränderliche) Zellen beziehen, und FormulaText darf nicht angegeben werden.

Relation | Arithmetische Beziehung
1 |  | <=
2 |  | =
3 |  | >=
4 |  | Die durch CellRef bezeichneten Zellen müssen Ganzzahlen als Endwerte enthalten.
5 |  | Die durch CellRef bezeichneten Zellen müssen als Endwert entweder 0 (Null) oder 1 enthalten.

FormulaText Variant optional. Die rechte Seite der Nebenbedingung.

Anmerkungen

Falls CellRef und Relation nicht mit einer bestehenden Nebenbedingung übereinstimmen, müssen Sie die Funktionen SolverDelete und SolverAdd verwenden, um die Nebenbedingung zu ändern.


Beispiel zur SolverChange-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, eine der Nebenbedingungen geändert und das Modell erneut ausgewertet.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverChange cellRef:=Range("F4:F6"), _
    relation:=1, _
    formulaText:=200
SolverSolve userFinish:=False


SolverDelete-Funktion

Löscht eine bestehende Nebenbedingung. Entspricht dem Klicken im Menü Extras auf Solver und anschließend auf Löschen im Dialogfeld Solver-Parameter.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverDelete(CellRef, Relation, FormulaText)

CellRef Variant erforderlich. Ein Bezug auf eine Zelle oder einen Zellbereich, der die linke Seite einer Nebenbedingung darstellt.

Relation Integer erforderlich. Die arithmetische Beziehung zwischen der linken und rechten Seite der Nebenbedingung. Wenn Sie 4 oder 5 wählen, muss CellRef sich auf einstellbare (veränderliche) Zellen beziehen, und FormulaText darf nicht angegeben werden.

Relation | Arithmetische Beziehung
1 |  | <=
2 |  | =
3 |  | >=
4 |  | Die durch CellRef bezeichneten Zellen müssen Ganzzahlen als Endwerte enthalten.
5 |  | Die durch CellRef bezeichneten Zellen müssen als Endwert entweder 0 (Null) oder 1 enthalten.

FormulaText Variant optional. Die rechte Seite der Nebenbedingung.


Beispiel zur SolverDelete-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, eine der Nebenbedingungen gelöscht und das Modell erneut ausgewertet.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverDelete cellRef:=Range("C4:E6"), _
    relation:=4
SolverSolve userFinish:=False


SolverFinish-Funktion

Teilt Microsoft Excel mit, was mit dem Ergebnis geschehen und welche Art von Bericht erstellt werden soll, wenn der Lösungsvorgang abgeschlossen ist.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während der Visual Basic-Editor aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverFinish(KeepFinal, ReportArray)

KeepFinal Variant optional. Kann die Zahl 1 oder 2 sein. Wird KeepFinal auf 1 gesetzt oder ausgelassen, werden die endgültigen Lösungswerte in veränderbaren Zellen gehalten, wobei gegebenenfalls vorherige Werte überschrieben werden. Ist KeepFinal auf 2 gesetzt, werden die endgültigen Lösungswerte verworfen, und die vorherigen Werte werden wiederhergestellt.

ReportArray Variant optional. Gibt an, welche Art von Bericht Microsoft Excel erzeugen soll, wenn Solver abgeschlossen ist. Mit 1 wird ein Antwortbericht erstellt, mit 2 ein Sensitivitätsbericht und mit 3 ein Grenzwertbericht. Geben Sie mit der Funktion Array die gewünschten Berichte an, beispielsweise: ReportArray:= Array(1,3).


SolverFinishDialog-Funktion

Teilt Microsoft Excel mit, was mit dem Ergebnis geschehen und welche Art von Bericht erstellt werden soll, wenn der Lösungsvorgang abgeschlossen ist. Entspricht der SolverFinish- Funktion, zeigt jedoch nach der Lösung eines Problems zusätzlich das Dialogfeld Ergebnis an.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverFinishDialog(KeepFinal, ReportArray)

KeepFinal Variant optional. Kann die Zahl 1 oder 2 sein. Wird KeepFinal auf 1 gesetzt oder ausgelassen, werden die endgültigen Lösungswerte in veränderbaren Zellen gehalten, wobei vorherige Werte überschrieben werden. Ist KeepFinal auf 2 gesetzt, werden die endgültigen Lösungswerte verworfen, und die vorherigen Werte werden wiederhergestellt.

ReportArray Variant optional. Gibt an, welche Art von Bericht Microsoft Excel erzeugen soll, wenn Solver abgeschlossen ist. Mit 1 wird ein Antwortbericht erstellt, mit 2 ein Sensitivitätsbericht und mit 3 ein Grenzwertbericht. Geben Sie mit der Funktion Array die gewünschten Berichte an, beispielsweise: ReportArray:= Array(1,3).


Beispiel zur SolverFinishDialog-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, das Modell erneut ausgewertet und das Dialogfeld Ergebnis mit zwei vorbesetzten Optionen angezeigt.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverSolve userFinish:=True
SolverFinishDialog keepFinal:=1, reportArray:=Array(1)


SolverGet-Funktion

Gibt Informationen über die aktuellen Einstellungen für Solver zurück. Die Einstellungen werden in den Dialogfeldern Solver-Parameter und Optionen festgelegt.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverGet(TypeNum, SheetName)

TypeNum Integer erforderlich. Eine Zahl, die den Typ der gewünschten Informationen angibt. Die folgenden Einstellungen werden im Dialogfeld Solver-Parameter vorgenommen:

TypeNum | Gibt Folgendes zurück
1 | Den Bezug im Feld Zielzelle bzw. den Fehler #NV, falls Solver in dem aktiven Blatt noch nicht verwendet wurde.
2 | Eine Zahl, die der Option Zielwert entspricht. 1 steht für Max, 2 für Min und 3 für den Wert im Feld Wert.
3 | Den Wert im Feld Wert.
4 | Den Bezug (gegebenenfalls als Mehrfachbezug) im Feld Veränderbare Zellen.
5 | Die Anzahl der Nebenbedingungen.
6 | Eine Matrix der linken Seiten der Nebenbedingungen in Form von Text.
7 | Eine Matrix von Zahlen, die den Beziehungen zwischen der linken und rechten Seite der Nebenbedingungen entsprechen: 1 steht für <=, 2 für =, 3 für >=, 4 für ganzz und 5 für bin.
8 | Eine Matrix der rechten Seiten der Nebenbedingungen in Form von Text.

Die folgenden Einstellungen werden im Dialogfeld Optionen vorgenommen.

TypeNum | Gibt Folgendes zurück
9 |  | Die maximale Berechnungszeit.
10 |  | Die maximale Anzahl der Iterationen.
11 |  | Die Genauigkeit.
12 |  | Den Toleranzwert für Ganzzahlen.
13 |  | True, falls das Kontrollkästchen Lineares Modell voraussetzen aktiviert ist; False, falls es deaktiviert ist.
14 |  | True, falls das Kontrollkästchen Iterationsergebnisse anzeigen aktiviert ist; False, falls es deaktiviert ist.
15 |  | True, falls das Kontrollkästchen Automatische Skalierung anwenden aktiviert ist; False, falls es deaktiviert ist.
16 |  | Eine Zahl, die der Art der Schätzungen entspricht: 1 steht für Tangente, 2 für Quadratisch.
17 |  | Eine Zahl, die der Art der Differenzen entspricht: 1 steht für Vorwärts, 2 für Zentral.
18 |  | Eine Zahl, die der Art der Suche entspricht: 1 steht für Quasi-Newton, 2 für Gradient.
19 |  | Der Konvergenzwert.
20 |  | True, wenn das Kontrollkästchen Nicht-Negativ voraussetzen aktiviert ist.

SheetName Variant optional. Der Name des Blattes, das das Solver-Modell enthält, über das Sie Informationen benötigen. Wird SheetName weggelassen, wird dieses Blatt als aktives Blatt herangezogen.


Beispiel zur SolverGet-Funktion

In diesem Beispiel wird eine Meldung angezeigt, wenn Sie Solver nicht in Sheet1 eingesetzt haben.

Worksheets("Sheet1").Activate
state = SolverGet(typeNum:=1)
If IsError(state) Then
    MsgBox "You have not used Solver on the active sheet"
End If


SolverLoad-Funktion

Lädt die Parameter für ein bestehendes Solvermodell, die in dem Tabellenblatt gespeichert wurden.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library.

Syntax

SolverLoad(LoadArea)

LoadArea Variant erforderlich. Ein Bezug im aktiven Tabellenblatt auf einen Zellbereich, aus dem Sie eine vollständige Problemspezifikation laden möchten. Die erste Zelle in LoadArea enthält eine Formel für das Feld Zielzelle im Dialogfeld Solver-Parameter; die zweite Zelle enthält eine Formel für das Feld Veränderbare Zellen; nachfolgende Zellen enthalten Nebenbedingungen in Form von logischen Formeln. Die letzte Zelle kann optional eine Liste von Solveroptionswerten enthalten. Weitere Informationen finden Sie unter SolverOptions-Funktion. Der durch das Argument LoadArea repräsentierte Bereich kann sich auf einem beliebigen Tabellenblatt befinden. Sie müssen jedoch das Tabellenblatt angeben, falls es sich nicht um das aktive Blatt handelt. Beispielsweise wird mit SolverLoad("Sheet2!A1:A3") ein Modell von Sheet2 geladen, auch wenn dieses nicht das aktive Blatt ist.


Beispiel zur SolverLoad-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, eine der Nebenbedingungen geändert und das Modell erneut ausgewertet.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverChange cellRef:=Range("F4:F6"), _
    relation:=1, _
    formulaText:=200
SolverSolve userFinish:=False


SolverOk-Funktion

Definiert ein Solver-Grundmodell. Entspricht dem Klicken auf Solver im Menü Extras und dem anschließenden Festlegen von Optionen im Dialogfeld Solver-Parameter.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverOk(SetCell, MaxMinVal, ValueOf, ByChange)

SetCell Variant optional. Bezieht sich auf eine einzelne Zelle des aktiven Tabellenblatts. Entspricht dem Feld Zielzelle im Dialogfeld Solver-Parameter.

MaxMinVal Variant optional. Entspricht den Optionen Max, Min und Wert im Dialogfeld Solver-Parameter.

MaxMinVal | Steht für
1 | Maximieren
2 | Minimieren
3 | Vergleichen mit einem bestimmten Wert

ValueOf Variant optional. Ist MaxMinVal 3, müssen Sie den Wert angeben, mit dem die Zielzelle verglichen wird.

ByChange Variant optional. Die Zelle oder der Zellbereich, der verändert wird, um das gewünschte Ergebnis in der Zielzelle zu erreichen. Entspricht dem Feld Veränderbare Zellen im Dialogfeld Solver-Parameter.


SolverOkDialog-Funktion

Wie die SolverOK-Funktion, zeigt jedoch zusätzlich das Dialogfeld Solver an.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverOkDialog(SetCell, MaxMinVal, ValueOf, ByChange)

SetCell Variant optional. Bezieht sich auf eine einzelne Zelle des aktiven Tabellenblatts. Entspricht dem Feld Zielzelle im Dialogfeld Solver-Parameter.

MaxMinVal Variant optional. Entspricht den Optionen Max, Min und Wert im Dialogfeld Solver-Parameter.

MaxMinVal | Steht für
1 | Maximieren
2 | Minimieren
3 | Vergleichen mit einem bestimmten Wert

ValueOf Variant optional. Ist MaxMinVal 3, müssen Sie den Wert angeben, mit dem die Zielzelle verglichen wird.

ByChange Variant erforderlich. Die Zelle oder der Zellbereich, der verändert wird, um das gewünschte Ergebnis in der Zielzelle zu erreichen. Entspricht dem Feld Veränderbare Zellen im Dialogfeld Solver-Parameter.


Beispiel zur SolverOKDialog-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, alle Solveroptionen werden zurückgesetzt und das Dialogfeld Solver-Parameter wird angezeigt. Von diesem Punkt an kann Solver manuell eingesetzt werden.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverReset
SolverOKDialog setCell:=Range("TotalProfit")
SolverSolve userFinish:=False


SolverOptions-Funktion

Ermöglicht Ihnen die Angabe weiterer Optionen für das Solvermodell. Diese Funktion und ihre Argumente entsprechen den Optionen im Dialogfeld Optionen.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverOptions(MaxTime, Iterations, Precision, AssumeLinear, StepThru, Estimates, Derivatives, Search, IntTolerance, Scaling, Convergence, AssumeNonNeg)

MaxTime Variant optional. Die maximale Zeit (in Sekunden), die Microsoft Excel zur Lösung des Problems aufwendet. Der Wert muss eine positive ganze Zahl sein. Der Standardwert 100 ist für die meisten kleineren Probleme ausreichend, Sie können jedoch einen Wert bis 32.767 eingeben.

Iterations Variant optional. Die maximale Anzahl von Iterationen, die Microsoft Excel zur Lösung des Problems durchläuft. Der Wert muss eine positive ganze Zahl sein. Der Standardwert 100 ist für die meisten kleineren Probleme ausreichend, Sie können jedoch einen Wert bis 32.767 eingeben.

Precision Variant optional. Eine Zahl zwischen 0 (Null) und 1, die den Grad der Genauigkeit angibt, der zur Lösung des Problems erfüllt sein muss. Die Standardgenauigkeit beträgt 0,000001. Eine geringere Genauigkeit wird durch weniger Dezimalstellen angezeigt; beispielsweise 0,0001. Im Allgemeinen benötigt Solver um so mehr Zeit zur Lösung des Problems, je höher die angegebene Genauigkeit ist (je kleiner die Zahl).

AssumeLinear Variant optional. Falls True, wird ein lineares Modell zu Grunde gelegt. Diese Option beschleunigt zwar den Lösungsvorgang, sollte jedoch nur verwendet werden, wenn alle Beziehungen in dem Modell linear sind. Der Standardwert ist False.

StepThru Variant optional. Falls True, hält Solver bei jedem Lösungsversuch an. Sie können ein Makro an Solver übergeben, das bei jeder Pause ausgeführt wird. Verwenden Sie dazu das Argument ShowRef der Funktion SolverSolve. Wenn False, hält Solver nicht bei jedem Lösungsversuch an. Der Standardwert ist False.

Estimates Variant optional. Bestimmt den Ansatz, nach welchem anfängliche Schätzwerte für die Grundvariablen bei jeder eindimensionalen Suche ermittelt werden: 1 steht für lineare Schätzungen, 2 für quadratische Schätzungen. Bei einer linearen Schätzung wird eine lineare Extrapolation, ausgehend von einem tangentialen Vektor, vorgenommen. Bei der quadratischen Schätzung wird eine quadratische Extrapolation vorgenommen; dies führt bei nichtlinearen Problemen unter Umständen zu besseren Ergebnissen. Der Standardwert ist 1 (lineare Schätzung).

Derivatives Variant optional. Bestimmt Vorwärtsdifferenzierung oder zentrale Differenzierung bei Schätzungen für partielle Ableitungen der gesuchten Funktion und Nebenbedingungsfunktionen: 1 repräsentiert Vorwärtsdifferenzierung, 2 repräsentiert zentrale Differenzierung. Die zentrale Differenzierung erfordert mehr Tabellen-Neuberechnungen. Möglicherweise können jedoch Probleme gelöst werden, bei denen Ihnen zuvor mitgeteilt wurde, dass Solver die Lösung nicht weiter verbessern kann. Die Option der zentralen Differenzierung sollten Sie bei Nebenbedingungen wählen, deren Werte sich in der Nähe der Grenzwerte schnell ändern. Der Standardwert ist 1 (Vorwärtsdifferenzierung).

Search Variant optional. Geben Sie mit den Search-Optionen den Suchalgorithmus an, der bei jeder Iteration verwendet wird, um die Suchrichtung zu bestimmen: 1 repräsentiert das Newton-Suchverfahren, 2 das Gradient-Suchverfahren. Die Option Newton, bei der ein Quasi-Newton-Verfahren eingesetzt wird, ist die Standardeinstellung. Dieses Verfahren erfordert in der Regel mehr Speicher als das Gradient-Suchverfahren, benötigt jedoch weniger Iterationen. Das Gradient-Suchverfahren erfordert weniger Speicher als das Newton-Suchverfahren, benötigt jedoch gewöhnlich mehr Iterationen, um einen bestimmten Genauigkeitsgrad zu erreichen. Setzen Sie dieses Verfahren ein, wenn das Problem umfangreich ist und der Speicher eventuell nicht ausreicht. Das Gradient-Suchverfahren bietet sich besonders an, wenn sich bei der schrittweisen Iteration nur ein langsamer Fortschritt von Zwischenergebnis zu Zwischenergebnis abzeichnet.

IntTolerance Variant optional. Eine Dezimalzahl zwischen 0 und 1, die die Toleranz bei ganzzahligen Werten angibt. Dieses Argument wird nur berücksichtigt, wenn ganzzahlige Nebenbedingungen definiert sind. Sie können die Toleranz anpassen, die die maximale, prozentuale Abweichung von der optimalen Lösung darstellt, wenn eine ganzzahlige Bedingung für ein Element des Problems verwendet wurde. In der Regel beschleunigt eine höhere Toleranz (zulässige Abweichung in Prozent) den Lösungsvorgang.

Scaling Variant optional. Falls sich zwei oder mehr Bedingungen um mehrere Größenordnungen unterscheiden und falls True, skaliert Solver die Bedingungen bei der Berechnung auf ähnliche Größenordnungen. Dies ist nützlich, wenn sich die Eingaben (im Feld Veränderbare Zellen im Dialogfeld Solver-Parameter) und Ausgaben (in den Feldern Zielzelle und Nebenbedingungen im Dialogfeld Solver-Parameter) in ihrer Größe stark unterscheiden, beispielsweise bei der Maximierung des prozentualen Gewinns auf Grund von Investitionen in Millionenhöhe. Wenn False, rechnet Solver ohne Skalierung der Bedingungen. Der Standardwert ist False.

Convergence Variant optional. Eine Zahl zwischen 0 (Null) und 1, die den Grad der Konvergenztoleranz für den nichtlinearen Solver angibt. Wenn die relative Änderung im Zielzellenwert geringer ist als diese Toleranz während der letzten fünf Iterationen, hält Solver an und zeigt die Meldung "Solver konvergiert zur aktuellen Lösung. Alle Nebenbedingungen sind erfüllt." an.

AssumeNonNeg Variant optional. Wenn True, geht Solver von einem unteren Grenzwert von 0 (Null) für alle anpassbaren (veränderbaren) Zellen aus, für die im Listenfeld Nebenbedingung nicht explizit untere Grenzwerte angegeben wurden (die Zellen müssen nicht-negative Werte enthalten). Wenn False, verwendet Solver nur die im Listenfeld Nebenbedingung angegebenen Grenzwerte.


Beispiel zur SolverOptions-Funktion

In diesem Beispiel wird die Option Genauigkeit auf 0,001 gesetzt.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions Precision:=0.001
SolverOK SetCell:=Range("TotalProfit"), _
    MaxMinVal:=1, _
    ByChange:=Range("C4:E6")
SolverAdd CellRef:=Range("F4:F6"), _
    Relation:=1, _
    FormulaText:=100
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=3, _
    FormulaText:=0
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=4
SolverSolve UserFinish:=False
SolverSave SaveArea:=Range("A33")


SolverReset-Funktion

Setzt alle Zellmarkierungen und Nebenbedingungen im Dialogfeld Solver-Parameter zurück und stellt für alle Einstellungen im Dialogfeld Optionen die Standardwerte wieder her. Entspricht dem Klicken auf Zurücksetzen im Dialogfeld Solver-Parameter. Die SolverReset-Funktion wird automatisch aufgerufen, wenn Sie die Funktion SolverLoad aufrufen.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverReset()


Beispiel zur SolverReset-Funktion

In diesem Beispiel werden die Solver-Einstellungen auf ihre Standardwerte zurückgesetzt, bevor ein neues Problem definiert wird.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions Precision:=0.001
SolverOK SetCell:=Range("TotalProfit"), _
    MaxMinVal:=1, _
    ByChange:=Range("C4:E6")
SolverAdd CellRef:=Range("F4:F6"), _
    Relation:=1, _
    FormulaText:=100
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=3, _
    FormulaText:=0
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=4
SolverSolve UserFinish:=False
SolverSave SaveArea:=Range("A33")


SolverSave-Funktion

Speichert die Solver-Problemspezifikation im Tabellenblatt.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverSave(SaveArea)

SaveArea Variant erforderlich. Der Zellbereich, in dem das Solvermodell gespeichert werden soll. Der durch das Argument SaveArea repräsentierte Bereich kann sich in einem beliebigen Tabellenblatt befinden, Sie müssen das Tabellenblatt jedoch angeben, falls es sich nicht um das aktive Blatt handelt. Beispielsweise wird durch SolverSave("Sheet2!A1:A3") das Modell in Sheet2 gespeichert, auch wenn Sheet2 nicht das aktive Blatt ist.


Beispiel zur SolverSave-Funktion

In diesem Beispiel werden die Solver-Funktionen dazu verwendet, den Gesamtgewinn in einem Geschäftsproblem zu maximieren. Mit der Funktion SolverSave wird das aktuelle Problem in einem Bereich des aktiven Tabellenblatts gespeichert.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions Precision:=0.001
SolverOK SetCell:=Range("TotalProfit"), _
    MaxMinVal:=1, _
    ByChange:=Range("C4:E6")
SolverAdd CellRef:=Range("F4:F6"), _
    Relation:=1, _
    FormulaText:=100
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=3, _
    FormulaText:=0
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=4
SolverSolve UserFinish:=False
SolverSave SaveArea:=Range("A33")


SolverSolve-Funktion

Startet die Problemlösung durch Solver. Entspricht dem Klicken auf Lösen im Dialogfeld Solver-Parameter.

Bevor Sie diese Funktion einsetzen, müssen Sie einen Verweis auf das Solver-Add-In herstellen. Klicken Sie, während ein Visual Basic-Modul aktiv ist, im Menü Extras auf Verweise, und aktivieren Sie das Kontrollkästchen Solver.xls im Feld Verfügbare Verweise. Wenn Solver.xls unter Verfügbare Verweise nicht erscheint, klicken Sie auf Durchsuchen, und öffnen Sie Solver.xla im Unterordner \Office\Library\Solver.

Syntax

SolverSolve(UserFinish, ShowRef)

UserFinish Variant optional. Falls True, wird das Ergebnis ohne Anzeige des Dialogfelds Ergebnis zurückgegeben. Wenn False oder nicht angegeben, wird das Ergebnis zurückgegeben und das Dialogfeld Ergebnis angezeigt.

ShowRef Variant optional. Wird nur verwendet, wenn True an das StepThru-Argument der Funktion SolverOptions übergeben wird. Sie können den Namen eines Makros (als Zeichenfolge) als ShowRef-Argument übergeben. Dieses Makro wird jedesmal aufgerufen, wenn Solver eine Zwischenlösung zurückgibt.


Beispiel zur SolverSolve-Funktion

In diesem Beispiel werden die Solver-Funktionen verwendet, um den Gesamtgewinn in einem Geschäftsproblem zu maximieren. Die Funktion SolverSolve startet die Lösung durch Solver.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions Precision:=0.001
SolverOK SetCell:=Range("TotalProfit"), _
    MaxMinVal:=1, _
    ByChange:=Range("C4:E6")
SolverAdd CellRef:=Range("F4:F6"), _
    Relation:=1, _
    FormulaText:=100
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=3, _
    FormulaText:=0
SolverAdd CellRef:=Range("C4:E6"), _
    Relation:=4
SolverSolve UserFinish:=False
SolverSave SaveArea:=Range("A33")


SQLBind-Funktion

Verwenden Sie nicht SQLBind und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLBind gibt die Position an, an der die mit den Funktionen SQLRetrieve oder SQLRetrieveToFile abgerufenen Ergebnisse abgelegt werden. Ändern Sie mit SQLBind die Anordnung der Spalten der Ergebnisse einer Abfrage, oder platzieren Sie die Ergebnisspalten in nicht angrenzenden Arbeitsblattspalten.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLBind(ConnectionNum, Column, Reference)

ConnectionNum Erforderlich. Die eindeutige Kennung der Datenquelle (die von SQLOpen zurückgegeben wird), aus der Sie Ergebnisse anbinden möchten.

Column Optional. Die Spaltennummer der Ergebnismenge, die angebunden werden soll. Spalten in der Ergebnismenge werden von links nach rechts nummeriert, beginnend mit der Nummer 1. Wenn Column nicht angegeben wird, werden alle Bindungen für ConnectionNum entfernt.

Spalte 0 (Null) enthält Zeilennummern für die Ergebnismenge. Sie erhalten die Zeilennummern durch Anbinden der Spalte 0 (Null).

Reference Optional. Ein Range-Objekt, das die Position einer einzelnen Zelle in einem Tabellenblatt angibt, an die die Ergebnisse gebunden werden sollen. Wird Reference nicht angegeben, so wird die Bindung für die Spalte entfernt.

Rückgabewert

Diese Funktion gibt eine Matrix zurück, in der die gebundenen Spalten für die aktuelle Verbindung nach Spaltennummern aufgeführt sind.

Wenn SQLBind die Spalte nicht an die Zelle in dem angegebenen Bezug binden kann, wird der Fehler 2042 zurückgegeben.

Ist ConnectionNum ungültig oder wird versucht, eine nicht verfügbare Zelle zu binden, gibt SQLBind den Fehler 2015 zurück.

Bezieht sich Reference auf mehrere Zellen, gibt SQLBind den Fehler 2023 zurück.

Wird bei SQLRetrieve kein Zielparameter angegeben, so legt SQLBind die Ergebnismenge an der Position ab, die durch Reference angegeben wird.

Anmerkungen

SQLBind teilt dem Administrator der ODBC-Systemsteuerung mit, wo die von SQLRetrieve zurückgegebenen Ergebnisse abgelegt werden sollen. Die Ergebnisse werden in der Bezugszelle und den direkt darunter liegenden Zellen abgelegt.

Verwenden Sie SQLBind, um die Ergebnisse unterschiedlicher Spalten in nicht zusammenhängenden Bereichen des Arbeitsblattes abzulegen.

Sie können SQLBind für jede Spalte der Ergebnismenge verwenden. Eine Bindung bleibt solange gültig, wie die durch ConnectionNum angegebene Verbindung geöffnet ist.

Rufen Sie SQLBind nach SQLOpen und SQLExecQuery, aber vor SQLRetrieve oder SQLRetrieveToFile auf. Aufrufe von SQLBind wirken sich nicht auf bereits abgerufene Ergebnisse aus.


Beispiel zur SQLBind-Funktion

In diesem Beispiel wird eine Abfrage der Nordwind-Datenbank ausgeführt. Anschließend werden mit der SQLBind-Funktion nur die vierte und neunte Spalte der Ergebnismenge der Abfrage (der Produktname und die Bestellmenge) in Sheet1 angezeigt.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
Set output1 = Worksheets("Sheet1").Range("A1")
Set output2 = Worksheets("Sheet1").Range("B1")
SQLBind chan, 4, output1
SQLBind chan, 9, output2
SQLRetrieve chan
SQLClose chan


SQLClose-Funktion

Verwenden Sie nicht SQLClose und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLClose schließt eine Verbindung zu einer externen Datenquelle.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLClose(ConnectionNum)

ConnectionNum Erforderlich. Die eindeutige Verbindungskennung der Datenquelle, zu der die Verbindung getrennt werden soll.

Rückgabewert

Wenn die Verbindung erfolgreich getrennt wurde, gibt diese Funktion den Wert 0 (Null) zurück. Die eindeutige Verbindungskennung ist anschließend nicht mehr gültig.

Ist ConnectionNum ungültig, gibt diese Funktion den Fehler 2015 zurück.

Wenn SQLClose die Verbindung zur Datenquelle nicht trennen kann, gibt die Funktion den Fehler 2042 zurück.


Beispiel zur SQLClose-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Das in Sheet1 angezeigte Ergebnis der Abfrage ist eine Liste sämtlicher Produkte, für die eine Bestellung aufgegeben wurde.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
Set output = Worksheets("Sheet1").Range("A1")
SQLRetrieve chan, output, , , True
SQLClose chan


SQLError-Funktion

Verwenden Sie nicht SQLError und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data-Objekts (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLError gibt ausführliche Fehlerinformationen zurück, wenn sie aufgerufen wird, nachdem eine der anderen ODBC-Funktionen einen Fehler verursacht hat. Wenn SQLError selbst einen Fehler verursacht, können keine Fehlerinformationen zurückgegeben werden.

Fehlerinformationen werden im Speicher definiert und abgelegt, sobald eine ODBC-Funktion einen Fehler verursacht. Sie können die Fehlerinformationen verfügbar machen, indem Sie die Funktion SQLError aufrufen.

SQLError stellt Informationen nur für solche Fehler zur Verfügung, die beim Ausführen von ODBC-Funktionen verursacht werden. Zu Microsoft Excel-Fehlern werden keine Informationen zurückgegeben.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLError()

Rückgabewert

Wenn Fehler aufgetreten sind, gibt SQLError ausführliche Fehlerinformationen in einer zweidimensionalen Matrix zurück, in der jede Zeile die Beschreibung eines Fehlers enthält.

Jede Zeile enthält die nachfolgend beschriebenen drei Felder für Informationen, die von der Funktion SQLError bei ODBC-Fehlern zurückgegeben werden.

  • Eine Zeichenfolge, die die ODBC-Fehlerklasse und -Unterklasse bezeichnet.

  • Ein numerischer Wert, der den ursprünglichen Fehlercode der Datenquelle angibt.

  • Ein Text, der den Fehler beschreibt.

Wenn ein Funktionsaufruf mehrere Fehler auslöst, erstellt SQLError eine Zeile für jeden Fehler.

Sind in einer vorhergehenden ODBC-Funktion keine Fehler aufgetreten, gibt diese Funktion lediglich den Fehler 2042 zurück.


Beispiel zur SQLError-Funktion

In diesem Beispiel wird absichtlich ein Fehler erzeugt, indem versucht wird, unter Verwendung einer fehlerhaften Verbindungszeichenfolge (Northwind ist falsch geschrieben) eine Verbindung zur Northwind-Datenbank herzustellen. Die Fehlerinformationen werden in Sheet1 angezeigt.

chan = SQLOpen("DSN=Nortwind")
returnArray = SQLError()
For i = LBound(returnArray, 1) To UBound(returnArray, 1)
    Worksheets("Sheet1").Cells(1, i).Formula = returnArray(i)
Next i
SQLClose chan


SQLExecQuery-Funktion

Verwenden Sie nicht SQLExecQuery und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLExecQuery führt eine Abfrage einer Datenquelle aus, zu der eine Verbindung mit der Funktion SQLOpen aufgebaut wurde.

SQLExecQuery führt lediglich die Abfrage aus. Verwenden Sie SQLRetrieve oder SQLRetrieveToFile, um die Ergebnisse zu erhalten.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLExecQuery(ConnectionNum, QueryText)

ConnectionNum Erforderlich. Die von SQLOpen zurückgegebene eindeutige Verbindungskennung, die die abzufragende Datenquelle kennzeichnet.

QueryText Erforderlich. Die Abfrage, die in der Datenquelle ausgeführt werden soll. Die Syntax der Abfrage muss mit der SQL-Syntax für den jeweiligen Treiber übereinstimmen.

Rückgabewert

Der von SQLExecQuery zurückgegebene Wert hängt von der Art der SQL-Anweisung ab, wie in der folgenden Tabelle beschrieben:

SQL-Anweisung | Rückgabewert
SELECT | Die Anzahl der Spalten in der Ergebnismenge.
UPDATE, INSERT oder DELETE | Die Anzahl der Spalten, auf die sich die Anweisung auswirkt.
Alle anderen gültigen SQL-Anweisungen | 0 (Null)

Wenn SQLExecQuery die Abfrage in der angegebenen Datenquelle nicht durchführen kann, wird der Fehler 2042 zurückgegeben.

Ist ConnectionNum ungültig, gibt SQLExecQuery den Fehler 2015 zurück.

Anmerkungen

Vor dem Aufruf von SQLExecQuery müssen Sie mit SQLOpen eine Verbindung zur Datenquelle herstellen. Die von SQLOpen zurückgegebene eindeutige Verbindungskennung wird von SQLExecQuery verwendet, um Abfragen an die Datenquelle zu senden.

Wenn Sie SQLExecQuery mit einer zuvor verwendeten Verbindungskennung aufrufen, werden alle noch nicht vollständig berechneten Ergebnisse dieser Verbindung durch die neuen Ergebnisse ersetzt.


Beispiel zur SQLExecQuery-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Die in Sheet1 angezeigte Ergebnismenge ist eine Liste sämtlicher Produkte, für die eine Bestellung aufgegeben wurde.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
Set output = Worksheets("Sheet1").Range("A1")
SQLRetrieve chan, output, , , True
SQLClose chan


SQLGetSchema-Funktion

Verwenden Sie nicht SQLGetSchema und die anderen ODBC-Funktionen im Add-In XLODBBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLGetSchema gibt Informationen über die Struktur der Datenquelle einer bestimmten Verbindung zurück.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLGetSchema(ConnectionNum, TypeNum, QualifierText)

ConnectionNum Erforderlich. Die eindeutige Verbindungskennung der Datenquelle, zu der die Verbindung mit SQLOpen hergestellt wurde und für die Informationen zurückgegeben werden sollen.

TypeNum Erforderlich. Gibt die Art der Informationen an, die zurückgegeben werden sollen (siehe folgende Tabelle).

Wert | Bedeutung
1 | Eine Liste aller verfügbaren Datenquellen.
2 | Eine Liste der Datenbanken der aktuellen Verbindung.
3 | Eine Liste der Besitzer in einer Datenbank der aktuellen Verbindung.
4 | Eine Liste der Tabellen für einen bestimmten Besitzer und eine bestimmte Datenbank der aktuellen Verbindung.
5 | Eine Liste der Spalten einer bestimmten Tabelle und der zugehörigen ODBC-SQL-Datentypen in einer zweidimensionalen Matrix. Das erste Feld enthält den Spaltennamen, das zweite Feld stellt den ODBC-SQL-Datentyp der Spalte dar.
6 | Die Benutzerkennung des aktuellen Benutzers.
7 | Der Name der aktuellen Datenbank.
8 | Der Name der Datenquelle, die während der Installation oder durch den ODBC-Systemsteuerung-Administrator definiert wurde.
9 | Der Name des Datenbank-Managementsystems (DBMS), das von der Datenquelle verwendet wird, z.B. ORACLE oder SQL Server.
10 | Der Servername der Datenquelle.
11 | Die Terminologie, mit der sich die Datenquelle auf die Besitzer bezieht, z.B. "Besitzer", "Berechtigungskennung", oder "Schema".
12 | Die Terminologie, mit der sich die Datenquelle auf eine Tabelle bezieht, z.B. "Tabelle" oder "Datei".
13 | Die Terminologie, mit der sich die Datenquelle auf einen Kennzeichner bezieht, z.B. "Datenbank" oder "Ordner".
14 | Die Terminologie, mit der sich die Datenquelle auf eine Prozedur bezieht, z.B. "Datenbankprozedur", "gespeicherte Prozedur" oder "Prozedur".

QualifierText Optional. Wird nur im Zusammenhang mit den TypeNum-Werten 3, 4 und 5 angegeben. Eine Zeichenfolge, die die Suche wie in der folgenden Tabelle dargestellt kennzeichnet.

TypeNum | QualifierText
3 | Der Name der Datenbank in der aktuellen Datenquelle. SQLGetSchema gibt die Namen der Tabellenbesitzer in dieser Datenbank zurück.
4 | Eine Kombination aus Datenbank- und Besitzername. Die Syntax besteht aus dem Datenbanknamen, einem Punkt als Trennzeichen und aus dem anschließenden Besitzernamen, z.B. "datenbankName.BesitzerName". Diese Funktion gibt eine Matrix mit den Namen der Tabellen zurück, die sich in der angegebenen Datenbank befinden und dem angegebenen Besitzer zugeordnet sind.
5 | Der Name einer Tabelle. SQLGetSchema gibt Informationen über die Spalten in der Tabelle zurück.

Rückgabewert

Der Rückgabewert der ohne Fehler ausgeführten SQLGetSchema-Funktion hängt von der Art der angeforderten Informationen ab.

Wenn SQLGetSchema die angeforderten Informationen nicht finden kann, wird der Fehler 2042 zurückgegeben.

Ist ConnectionNum ungültig, gibt diese Funktion den Fehler 2015 zurück.

Anmerkungen

SQLGetSchema verwendet die ODBC API-Funktionen SQLGetInfo und SQLTables, um die angeforderten Informationen zu finden.


Beispiel zur SQLGetSchema-Funktion

In diesem Beispiel werden der Datenbankname und der Name des Datenbank-Managementsystems (DBMS) für die Northwind-Datenbank abgerufen und die Informationen danach in einem Meldungsfeld angezeigt.

databaseName = "Northwind"
chan = SQLOpen("DSN=" & databaseName)
dsName = SQLGetSchema(chan, 8)
dsDBMS = SQLGetSchema(chan, 9)
MsgBox "Database name is " & dsName & ", and its DBMS is " & dsDBMS
SQLClose chan


SQLOpen-Funktion

Verwenden Sie nicht SQLOpen und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLOpen stellt eine Verbindung zu einer Datenquelle her.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLOpen(ConnectionStr, OutputRef, DriverPrompt)

ConnectionStr Erforderlich. Stellt die Informationen zur Verfügung, die der Datenbanktreiber zum Verbinden mit einer Datenquelle benötigt. Die Informationen müssen in dem für den Treiber erforderlichen Format angegeben werden.

ConnectionStr stellt den Namen der Datenquelle und andere Informationen (z.B. Benutzerkennung und Kennwörter) zur Verfügung, die der Treiber für den Verbindungsaufbau benötigt.

Sie müssen einen in ConnectionStr verwendeten Datenquellennamen (Data Source Name (DSN)) definieren, bevor Sie die Verbindung zur Datenquelle herstellen können.

OutputRef Optional. Ein Range-Objekt (eine einzelne Zelle), das die vervollständigte Verbindungszeichenfolge enthält.

Verwenden Sie OutputRef, wenn SQLOpen die vollständige Verbindungszeichenfolge an ein Tabellenblatt zurückgeben soll.

DriverPrompt Optional. Gibt an, ob das Dialogfeld des Treibers angezeigt wird und, wenn ja, welche Optionen in dem Dialogfeld verfügbar sind. Verwenden Sie einen der Werte aus der folgenden Tabelle. Wenn DriverPrompt nicht angegeben wird, verwendet SQLOpen den Wert 2 als Standardwert.

Wert | Bedeutung
1 | Das Dialogfeld des Treibers wird immer angezeigt.
2 | Das Dialogfeld des Treibers wird nur angezeigt, wenn die Informationen in der Verbindungszeichenfolge und in der Angabe der Datenquelle nicht ausreichen, um die Verbindung vollständig herzustellen. Alle Dialogfeldoptionen stehen zur Verfügung.
3 | Wie 2 mit der Ausnahme, dass nicht erforderliche Dialogfeldoptionen abgeblendet sind und nicht zur Verfügung stehen.
4 | Das Dialogfeld des Treibers wird nicht angezeigt. Wenn die Verbindung nicht hergestellt werden kann, gibt SQLOpen einen Fehler zurück.

Rückgabewert

Wenn eine Verbindung hergestellt werden kann, gibt SQLOpen eine Nummer als eindeutige Verbindungskennung zurück. Verwenden Sie diese Verbindungskennung bei den anderen ODBC-Funktionen.

Wenn SQLOpen die Verbindung mit den von Ihnen angegebenen Informationen nicht herstellen kann, wird der Fehler 2042 zurückgegeben. Im Speicher werden weitere Fehlerinformationen abgelegt, die von SQLError ausgewertet werden können.


Beispiel zur SQLOpen-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Die in Sheet1 angezeigte Ergebnismenge ist eine Liste sämtlicher Produkte, für die eine Bestellung aufgegeben wurde.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
Set output = Worksheets("Sheet1").Range("A1")
SQLRetrieve chan, output, , , True
SQLClose chan


SQLRequest-Funktion

Verwenden Sie nicht SQL.REQUEST und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLRequest stellt eine Verbindung mit einer externen Datenquelle her und führt eine Abfrage aus einem Tabellenblatt aus. Anschließend wird das Ergebnis der Abfrage als Matrix zurückgegeben.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLRequest(Verbindung, Abfragetext, Ausgabe_Bezug, Treiber, Spaltennamen)

Verbindung Erforderlich. Stellt Informationen wie Datenquellenname, Benutzerkennung und Kennwörter zur Verfügung, die der verwendete Treiber für den Verbindungsaufbau mit einer Datenquelle benötigt. Die Informationen müssen in dem für den Treiber erforderlichen Format angegeben werden.

Sie müssen einen in Verbindung verwendeten Datenquellennamen definieren, bevor Sie die Verbindung zur Datenquelle herstellen können.

Kann SQLRequest über Verbindung nicht auf die Datenquelle zugreifen, wird der Fehler 2042 zurückgegeben.

Abfragetext Erforderlich. Die SQL-Anweisung, die in der Datenquelle ausgeführt werden soll.

Kann SQLRequest Abfragetext in der angegebenen Datenquelle nicht ausführen, wird der Fehler 2042 zurückgegeben.

Ausgabe_Bezug Optional. Ein Range-Objekt (eine einzelne Zelle), in dem die vollständige Verbindungszeichenfolge abgelegt werden soll.

Treiber Optional. Gibt an, ob das Dialogfeld des Treibers angezeigt wird und welche Optionen zur Verfügung stehen. Verwenden Sie einen der Werte aus der folgenden Tabelle. Wenn Treiber nicht angegeben wird, verwendet SQLRequest den Wert 2 als Standardwert.

Wert | Bedeutung
1 | Das Dialogfeld des Treibers wird immer angezeigt.
2 | Das Dialogfeld des Treibers wird nur angezeigt, wenn die Informationen in der Verbindungszeichenfolge und in der Angabe der Datenquelle nicht ausreichen, um die Verbindung vollständig herzustellen. Alle Dialogfeldoptionen stehen zur Verfügung.
3 | Das Dialogfeld des Treibers wird nur angezeigt, wenn die Informationen in der Verbindungszeichenfolge und in der Angabe der Datenquelle nicht ausreichen, um die Verbindung vollständig herzustellen. Nicht erforderliche Dialogfeldoptionen sind abgeblendet und stehen nicht zur Verfügung.
4 | Das Dialogfeld des Treibers wird nicht angezeigt. Wenn die Verbindung nicht hergestellt werden kann, wird ein Fehler zurückgegeben.

Spaltennamen Optional. True, wenn Spaltennamen als erste Zeile der Ergebnisse zurückgegeben werden sollen. False, wenn keine Spaltennamen zurückgegeben werden sollen. False ist der Standardwert, wenn Spaltennamen nicht angegeben wird.

Anmerkungen

Die Argumente für die Funktion SQLRequest stehen in einer anderen Reihenfolge als bei der SQL.REQUEST-Makrofunktion.

Rückgabewert

Wird diese Funktion erfolgreich ausgeführt, wird eine Matrix mit den Ergebnismengen oder die Anzahl der Zeilen, auf die sich die Abfrage ausgewirkt hat, zurückgegeben.

Kann SQLRequest nicht alle Aktionen durchführen, gibt die Funktion einen Fehler zurück und legt die Fehlerinformationen für SQLError im Speicher ab.

Wenn SQLRequest über Verbindung nicht auf die Datenquelle zugreifen kann, wird der Fehler 2042 zurückgegeben.


Beispiel zur SQLRequest-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Das Ergebnis der Abfrage, das in Sheet1 angezeigt wird, ist eine Liste aller Produkte, für die eine Bestellung abgegeben wurde. Die Funktion SQLRequest schreibt die vollständige Verbindungszeichenfolge in Sheet2.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
returnArray = SQLRequest("DSN=" & databaseName, _
            queryString, _
            Worksheets("Sheet1").Range("A1"), _
            2, True)
For i = LBound(returnArray, 1) To UBound(returnArray, 1)
    For j = LBound(returnArray, 2) To UBound(returnArray, 2)
        Worksheets("Sheet1").Cells(i, j).Formula = _
            returnArray(i, j)
    Next j
Next i


SQLRetrieve-Funktion

Verwenden Sie nicht SQLRetrieve und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLRetrieve ruft alle Ergebnisse oder einen Teil der Ergebnisse einer zuvor ausgeführten Abfrage ab.

Vor dem Aufruf von SQLRetrieve müssen Sie mit SQLOpen eine Verbindung herstellen, mit SQLExecQuery eine Abfrage ausführen und die Ergebnisse bereithalten.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLRetrieve(ConnectionNum, DestinationRef, MaxColumns, MaxRows, ColNamesLogical, RowNumsLogical, NamedRngLogical, FetchFirstLogical)

ConnectionNum Erforderlich. Die eindeutige Verbindungskennung, die von SQLOpen zurückgegeben wird und für die Ergebnisse bereitstehen, die durch SQLExecQuery erzeugt wurden.

Ist ConnectionNum ungültig, gibt SQLExecQuery den Fehler 2015 zurück.

DestinationRef Optional. Ein Range-Objekt, das die Position angibt, an der die Ergebnisse abgelegt werden sollen. Diese Funktion überschreibt alle Werte in den Zellen ohne Bestätigungsmöglichkeit.

Bezieht sich DestinationRef auf eine einzelne Zelle, gibt SQLRetrieve alle bereitstehenden Ergebnisse in dieser Zelle sowie in den Zellen rechts und unterhalb dieser Zelle zurück.

Wenn DestinationRef nicht angegeben wird, werden die durch vorhergehende Aufrufe von SQLBind eingerichteten Bindungen verwendet, um die Ergebnisse zurückzugeben. Bestehen für die aktuelle Verbindung keine Bindungen, gibt SQLRetrieve den Fehler 2023 zurück.

Wenn eine bestimmte Ergebnisspalte nicht gebunden wurde und DestinationRef nicht angegeben wird, werden die Ergebnisse verworfen.

MaxColumns Optional. Die maximale Anzahl an Spalten, die an das Tabellenblatt ab der Position DestinationRef zurückgegeben werden.

Wenn MaxColumns die Anzahl der im Ergebnis verfügbaren Spalten überschreitet, legt SQLRetrieve Daten in den Spalten ab, für die Daten zur Verfügung stehen, und löscht die Inhalte alle weiteren Spalten.

Wenn MaxColumns weniger Spalten angibt, als im Ergebnis zur Verfügung stehen, wird die jeweils ganz rechts stehende Spalte solange von SQLRetrieve verworfen, bis die Ergebnisse im angegebenen Bereich Platz finden.

Die Reihenfolge, in der die Spalten von der Datenquelle zurückgegeben werden, legt die Spaltenposition fest.

Wenn MaxColumns nicht angegeben wird, werden alle Ergebnisse zurückgegeben.

MaxRows Optional. Die maximale Anzahl an Zeilen, die an das Tabellenblatt ab der Position DestinationRef zurückgegeben werden.

Wenn MaxRows die Anzahl der in den Ergebnissen verfügbaren Zeilen überschreitet, legt SQLRetrieve Daten in den Zeilen ab, für die Daten zur Verfügung stehen, und löscht die Inhalte alle weiteren Zeilen.

Wenn MaxRows weniger Zeilen angibt, als in den Ergebnissen zur Verfügung stehen, werden die Daten von SQLRetrieve in den ausgewählten Zeilen abgelegt, aber die zusätzlichen Zeilen werden nicht verworfen. Zusätzliche Zeilen können durch einen erneuten Aufruf von SQLRetrieve abgerufen werden, bei dem FetchFirstLogical auf False gesetzt wird.

Wenn MaxRows nicht angegeben wird, werden alle Ergebniszeilen zurückgegeben.

ColNamesLogical Optional. True, wenn in der ersten Zeile der Ergebnisse Spaltennamen zurückgegeben werden sollen. Das Argument muss False sein oder weggelassen werden, wenn keine Spaltennamen zurückgegeben werden sollen.

RowNumsLogical Optional. Wird nur verwendet, wenn DestinationRef im Funktionsaufruf angegeben wird. Hat das Argument den Wert True, so enthält die erste Spalte der Ergebnismenge Zeilennummern. Hat das Argument den Wert False oder wird es ausgelassen, so werden keine Zeilennummern zurückgegeben. Sie können Zeilennummern auch abrufen, indem Sie Spalte 0 (Null) mit SQLBind binden.

NamedRngLogical Optional. True, wenn Sie jede Spalte des Ergebnisses im Tabellenblatt als benannten Bereich deklarieren möchten. Der Name jedes Bereichs ist der Spaltenname des Ergebnisses. Der benannte Bereich enthält nur die Zeilen, die mit SQLRetrieve zurückgegeben werden. Der Standardwert ist False.

FetchFirstLogical Optional. Ermöglicht das Anfordern der Ergebnisse vom Anfang der Ergebnismenge. Wenn FetchFirstLogical auf False gesetzt ist, kann SQLRetrieve wiederholt aufgerufen werden, um die jeweils nächste Folge von Zeilen abzurufen, bis alle Ergebniszeilen zurückgegeben wurden. Wenn die Ergebnismenge keine weiteren Zeilen mehr enthält, gibt SQLRequest 0 (Null) zurück. Wenn Sie Ergebnisse vom Anfang der Ergebnismenge abrufen möchten, müssen Sie FetchFirstLogical auf True setzen. Um weitere Zeilen der Ergebnismenge abzurufen, setzen Sie FetchFirstLogical in nachfolgenden Aufrufen auf False. Der Standardwert ist False.

Rückgabewert

SQLRetrieve gibt die Anzahl der Zeilen in der Ergebnismenge zurück.

Wenn SQLRetrieve keine Ergebnisse von der angegebenen Datenquelle abrufen kann oder wenn keine Ergebnisse bereitstehen, gibt die Funktion den Fehler 2042 zurück. Wenn keine Daten gefunden werden, gibt SQLRetrieve 0 (Null) zurück.

Anmerkungen

Vor dem Aufruf von SQLRetrieve müssen folgende Aktionen ausgeführt werden:

  1. Stellen Sie mit SQLOpen eine Verbindung mit einer Datenquelle her.

  2. Verwenden Sie die in SQLOpen zurückgegebene Verbindungskennung, um eine Abfrage mit SQLExecQuery zu senden.


SQLRetrieveToFile-Funktion

Verwenden Sie nicht SQLRetrieveToFile und die anderen ODBC-Funktionen im Add-In XLODBC.XLA; arbeiten Sie stattdessen mit den Objekten, Methoden und Eigenschaften in der Microsoft ActiveX Data Objects (ADO)-Bibliothek. Weitere Informationen über ActiveX Data Objects finden Sie unter Willkommen bei ADO.

SQLRetrieveToFile ruft alle Ergebnisse einer zuvor ausgeführten Abfrage ab und speichert sie in einer Datei.

Vor dem Aufruf dieser Funktion müssen Sie mit SQLOpen eine Verbindung mit einer Datenquelle herstellen, mit SQLExecQuery eine Abfrage ausführen und die Ergebnisse der Abfrage bereithalten.

Diese Funktion ist im Add-In XLODBC.XLA enthalten. Bevor Sie diese Funktion verwenden können, müssen Sie mit Hilfe des Befehls Verweise (Menü Extras) einen Bezug zu dem Add-In herstellen.

Syntax

SQLRetrieveToFile(ConnectionNum, Destination, ColNamesLogical, ColumnDelimiter)

ConnectionNum Erforderlich. Die eindeutige Verbindungskennung, die von SQLOpen zurückgegeben wird und für die von SQLExecQuery erzeugte Ergebnismengen bereitstehen.

Ist ConnectionNum ungültig, gibt SQLExecQuery den Fehler 2015 zurück.

Destination Erforderlich. Eine Zeichenfolge, die den Namen und Pfad der Datei angibt, in der die Ergebnisse gespeichert werden sollen. Wenn die Datei existiert, wird ihr Inhalt durch die Ergebnismengen ersetzt. Wenn die Datei nicht existiert, erstellt SQLRetrieveToFile die Datei, öffnet sie und schreibt die Ergebnisse in die Datei.

Das Datenformat in der Datei ist mit dem .CSV-Dateiformat (comma-separated value) von Microsoft Excel kompatibel.

Spalten werden durch das Zeichen getrennt, das durch ColumnDelimiter angegeben wird, und die einzelnen Zeilen werden durch ein Wagenrücklaufzeichen getrennt.

Wenn die durch Destination angegebene Datei nicht geöffnet werden kann, gibt SQLRetrieveToFile den Fehler 2042 zurück.

ColNamesLogical Optional. True, wenn in der ersten Zeile der Ergebnisse Spaltennamen zurückgegeben werden sollen. False oder ausgelassen, wenn keine Spaltennamen zurückgegeben werden sollen.

ColumnDelimiter Optional. Eine Zeichenfolge, die das Zeichen angibt, das zum Trennen der Elemente in jeder Zeile verwendet wird. Verwenden Sie zum Beispiel ",", um das Komma als Trennzeichen anzugeben, oder ";", um ein Semikolon als Trennzeichen anzugeben. Wenn Sie ColumnDelimiter nicht angeben, wird das Listentrennzeichen verwendet.

Rückgabewert

Bei erfolgreicher Ausführung gibt SQLRetrieveToFile die Ergebnisse der Abfrage zurück, schreibt sie in eine Datei und gibt dann die Anzahl der Zeilen zurück, die in die Datei geschrieben wurden.

Wenn SQLRetrieveToFile die Ergebnisse nicht abrufen kann, wird der Fehler 2042 zurückgegeben. Die Datei wird in diesem Fall nicht geschrieben.

Wenn keine Ergebnisse in der Verbindung bereitstehen, gibt SQLRetrieveToFile den Fehler 2042 zurück.

Anmerkungen

Vor dem Aufruf von SQLRetrieveToFile müssen die folgenden Aktionen ausgeführt werden:

  1. Stellen Sie mit SQLOpen eine Verbindung mit der Datenquelle her.

  2. Verwenden Sie die von SQLOpen zurückgegebene Verbindungskennung, um eine Abfrage mit SQLExecQuery zu senden.


Beispiel zur SQLRetrieveToFile-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Die Ergebnismenge ist eine Liste sämtlicher Produkte, für die eine Bestellung aufgegeben wurde, und wird als Textdatei OUTPUT.TXT (mit Trennzeichen) im aktuellen Ordner gespeichert.

databaseName = "Northwind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
SQLRetrieveToFile chan, "OUTPUT.TXT", True
SQLClose chan


Neue Methoden (nach Objekten geordnet)

In Microsoft Excel 2000 wurden viele neuen Visual Basic für Applikationen-Methoden zu vorhandenen Objekten hinzugefügt. Diese Methoden sind in der folgenden Tabelle aufgeführt (nach dem Namen des Objekts sortiert).

Objekt | Methoden
Application | CalculateFull, GetPhonetic
Hyperlink | CreateNewDocument
Pane | ScrollIntoView
PivotCache | CreatePivotTable, ResetTimer
PivotCaches | Add
PivotTable | Format
PivotTables | Add
QueryTable | ResetTimer
Range | SetPhonetic
Window | PointsToScreenPixelsX, PointsToScreenPixelsY, RangeFromPoint, ScrollIntoView
Workbook | ReloadAs, WebPagePreview


AcceptAllChanges-Methode

Übernimmt alle Änderungen in der angegebenen gemeinsam genutzten Arbeitsmappe.

Syntax

Ausdruck.AcceptAllChanges

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.


Beispiel zur AcceptAllChanges-Methode

In diesem Beispiel werden alle Änderungen in der aktiven Arbeitsmappe übernommen.

ActiveWorkbook.AcceptAllChanges


Activate-Methode

Aktiviert das Objekt entsprechend der folgenden Tabelle:

Objekt | Beschreibung
Chart, ChartObject | Macht dieses Diagramm zum aktiven Diagramm.
Worksheet | Macht dieses Blatt zum aktiven Blatt. Entspricht dem Klicken auf das Register des Tabellenblatts.
OLEObject | Aktiviert das Objekt.
Pane | Aktiviert den Ausschnitt. Liegt der Ausschnitt nicht im aktiven Fenster, wird das Fenster, zu dem der Ausschnitt gehört, ebenfalls aktiviert. Fixierte Ausschnitte können nicht aktiviert werden.
Range | Aktiviert eine einzelne Zelle, die sich innerhalb der aktuellen Markierung befinden muss. Verwenden Sie die Select-Methode, um einen Zellbereich zu markieren.
Window | Bringt das Fenster an den Beginn der Z-Reihenfolge. Durch die Aktivierung wird kein der Arbeitsmappe zugeordnetes Auto_aktivieren-Makro oder Auto_deaktivieren-Makro ausgeführt (verwenden Sie die RunAutoMacros-Methode, um diese Makros auszuführen).
Workbook | Aktiviert das erste mit der Arbeitsmappe verbundene Fenster. Durch die Aktivierung wird kein der Arbeitsmappe zugeordnetes Auto_aktivieren- oder Auto_deaktivieren-Makro ausgeführt (verwenden Sie die RunAutoMacros-Methode, um diese Makros auszuführen).

Syntax

Ausdruck.Activate

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


ActivateMicrosoftApp-Methode

Aktiviert eine Microsoft-Anwendung. Falls die Anwendung bereits ausgeführt wird, aktiviert diese Methode das betreffende Anwendungsfenster. Wird die Anwendung noch nicht ausgeführt, startet die Methode eine neue Instanz der Anwendung.

Syntax

Ausdruck.ActivateMicrosoftApp(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Long erforderlich. Gibt die zu aktivierende Microsoft-Anwendung an. Zulässig ist eine der folgenden XlMSApplication-Konstanten: xlMicrosoftWord, xlMicrosoftPowerPoint, xlMicrosoftMail, xlMicrosoftAccess, xlMicrosoftFoxPro, xlMicrosoftProject oder xlMicrosoftSchedulePlus.


Beispiel zur ActivateMicrosoftApp-Methode

In diesem Beispiel wird Word gestartet und aktiviert.

Application.ActivateMicrosoftApp xlMicrosoftWord


ActivateNext-Methode

Aktiviert das angegebene Fenster und reiht es dann am Ende der Fenster-Z-Reihenfolge ein.

Syntax

Ausdruck.ActivateNext

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.


Beispiel zur ActivateNext-Methode

In diesem Beispiel wird das momentan aktive Fenster in den Hintergrund der Z-Reihenfolge gestellt.

ActiveWindow.ActivateNext


ActivatePrevious-Methode

Aktiviert das angegebene Fenster und anschließend das Fenster am Ende der Fenster-Z-Reihenfolge.

Syntax

Ausdruck.ActivatePrevious

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.


Beispiel zur ActivatePrevious-Methode

In diesem Beispiel wird das momentan aktive Fenster in den Hintergrund der Z-Reihenfolge gestellt.

ActiveWindow.ActivatePrevious


Add-Methode

Fügt einer Auflistung ein Objekt hinzu. Um weitere Informationen zu erhalten, klicken Sie auf ein Thema in der folgenden Liste.

AddIns

CalculatedFields

CalculatedItems

ChartObjects

Charts

CustomViews

FormatConditions

HPageBreaks

Hyperlinks

Names

OLEObjects

Parameters

Phonetics

PivotCaches

PivotFormulas

 PivotItems

PivotTables

PublishObjects

QueryTables

RecentFiles

Scenarios

SeriesCollection

Sheets

Styles

Trendlines

Validation

VPageBreaks

Workbooks

Worksheets


Add-Methode (AddIns-Auflistung)

Fügt der Liste der Add-Ins eine neue Add-In-Datei hinzu. Gibt ein AddIn-Objekt zurück.

Syntax

Ausdruck.Add(Filename, CopyFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

Filename String erforderlich. Der Name der Datei mit dem Add-In, das der Liste im Add-In-Manager hinzugefügt werden soll.

CopyFile Variant optional. Wird ignoriert, wenn sich die Add-In-Datei auf der Festplatte befindet. Falls sich das Add-In auf einem auswechselbaren Medium (Diskette oder CD) befindet und der Wert True ist, wird das Add-In auf die Festplatte kopiert. Falls der Wert False ist, wir das Add-In nicht kopiert. Wird dieses Argument nicht angegeben, lässt Sie Microsoft Excel in einem Dialogfeld wählen.

Anmerkungen

Diese Methode installiert das neue Add-In nicht. Dazu müssen Sie die Installed-Eigenschaft festlegen.


Beispiel zur Add-Methode (AddIns-Auflistung)

In diesem Beispiel wird das Add-In Myaddin.xla von Laufwerk A: eingefügt. Beim Ausführen dieses Beispiels kopiert Microsoft Excel die Datei A:\Myaddin.xla in den auf Ihrer Festplatte befindlichen Ordner "Makro" und fügt den Titel des Add-Ins der Liste im Dialogfeld Add-Ins hinzu.

Set myAddIn = AddIns.Add(Filename:="A:\MYADDIN.XLA", _
        CopyFile:=True)
MsgBox myAddIn.Title & " has been added to the list"


Add-Methode (CalculatedFields- oder CalculatedItems-Auflistung)

Erstellt ein neues berechnetes Feld oder berechnetes Element. Gibt ein PivotField- oder ein PivotItem-Objekt zurück.

Syntax

Objekt.Add(Name, Formula)

Objekt Erforderlich. Ein Ausdruck der ein CalculatedFields- oder ein CalculatedItems-Objekt zurückgibt.

Name String erforderlich. Der Feld- oder der Elementname.

Formula String erforderlich. Die Formel des Feldes oder des Elements.


Beispiel zur Add-Methode (CalculatedFields- oder CalculatedItems-Auflistung)

In diesem Beispiel wird dem ersten PivotTable-Bericht im ersten Tabellenblatt ein berechnetes Feld hinzugefügt.

Worksheets(1).PivotTables(1).CalculatedFields.Add "PxS", _
    "= Product * Sales"


AddCallout-Methode

Erstellt eine rahmenlose Legende mit Linie. Gibt ein Shape-Objekt zurück, das die neue Legende darstellt.

Syntax

Ausdruck.AddCallout(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Der Typ der Legendenlinie. Kann eine der folgenden MsoCalloutType-Konstanten sein: msoCalloutOne (eine horizontale oder vertikale Legendenlinie mit einem Abschnitt), msoCalloutTwo (eine frei drehbare Legendenlinie mit einem Abschnitt), msoCalloutThree (eine Legendenlinie mit zwei Abschnitten) oder msoCalloutFour (eine Legendenlinie mit drei Abschnitten).

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der Legende, relativ zu der oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Breite und Höhe (in Punkt) des Begrenzungsrechtecks der Legende.

Anmerkungen

Mit Hilfe der AddShape-Methode können Sie vielfältigere Legenden einfügen.


Beispiel zur AddCallout-Methode

In diesem Beispiel wird eine rahmenlose Legende mit einer aus einem Abschnitt bestehenden frei drehbaren Legendenlinie in myDocument eingefügt und anschließend der Legendenwinkel auf 30 Grad festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddCallout(msoCalloutTwo, _
    50, 50, 200, 100).Callout.Angle = msoCalloutAngle30


AddChartAutoFormat-Methode

Fügt der Liste verfügbarer Diagramm-AutoFormate ein benutzerdefiniertes Diagramm-AutoFormat hinzu.

Syntax

Ausdruck.AddChartAutoFormat(Chart, Name, Description)

Ausdruck Ein erforderlicher Ausdruck, der ein Application-Objekt zurückgibt.

Chart Chart erforderlich. Ein Diagramm mit dem Format, das dem neuen Diagramm als AutoFormat zugeordnet werden soll.

Name String erforderlich. Der Name des AutoFormats.

Description String optional. Eine Beschreibung des benutzerdefinierten AutoFormats.


Beispiel zur AddChartAutoFormat-Methode

In diesem Beispiel wird ein neues AutoFormat hinzugefügt, das auf Chart1 beruht.

Application.AddChartAutoFormat _
    Chart:=Charts("Chart1"), Name:="Presentation Chart"


AddComment-Methode

Fügt dem Bereich einen Kommentar hinzu.

Syntax

Ausdruck.AddComment(Text)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Text Variant optional. Der Kommentartext.


Beispiel zur AddComment-Methode

In diesem Beispiel wird der Zelle E5 des ersten Tabellenblattes ein Kommentar hinzugefügt.

Worksheets(1).Range("E5").AddComment "Current Sales"


AddConnector-Methode

Erstellt eine Verbindung. Gibt ein Shape-Objekt zurück, das die neue Verbindung darstellt. Mit dem Hinzufügen einer Verbindung ist die Verbindung noch nicht hergestellt. Mit Hilfe der Methoden BeginConnect und EndConnect können Sie Anfang und Ende der Verbindung anderen Formen im Dokument zuordnen.

Syntax

Ausdruck.AddConnector(Type, BeginX, BeginY, EndX, EndY)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Die Art der Verbindung. Kann eine der folgenden MsoConnectorType-Konstanten sein: msoConnectorCurve, msoConnectorElbow oder msoConnectorStraight.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Anfangspunktes der Verbindung, relativ zur oberen linken Ecke des Dokuments.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunktes der Verbindung, relativ zur oberen linken Ecke des Dokuments.

Anmerkungen

Wenn Sie einer Form eine Verbindung zuordnen, werden Größe und Position der Verbindung, wenn notwendig, automatisch angepasst. Deshalb bleiben die Position und die Abmessungen, die Sie beim Einfügen einer Verbindung angeben, unbeachtet (Abmessungen müssen ungleich Null sein).


Beispiel zur AddConnector-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und durch eine gekrümmte Verbindung verbunden. Beachten Sie, dass beim Zuordnen der Verbindung zu den Rechtecken Größe und Position der Verbindung automatisch angepasst werden; deshalb bleiben die Position und die Abmessungen, die Sie beim Einfügen der Legende angeben, unberücksichtigt (Abmessungen müssen ungleich Null sein).

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set c = s.AddConnector(msoConnectorCurve, 0, 0, 100, 100)
With c.ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    c.RerouteConnections
End With


 AddCurve-Methode

AddCurve-Methode

Erstellt eine Bézier-Kurve. Gibt ein Shape-Objekt zurück, das die neue Kurve darstellt.

Syntax

Ausdruck.AddCurve(SafeArrayOfPoints)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

SafeArrayOfPoints Variant erforderlich. Eine Matrix von Koordinatenpaaren, die Scheitelpunkte und Steuerpunkte der Kurve festlegt. Der zuerst angegebene Punkt bildet den Scheitelpunkt, die beiden folgenden stellen Steuerpunkte für das erste Bézier-Segment dar. Anschließend geben Sie für jedes weitere Kurvensegment einen Scheitel und zwei Steuerpunkte an. Der zuletzt festgelegte Punkt ist der Endscheitel der Kurve. Beachten Sie, dass immer 3n + 1 Punkte angegeben werden müssen, wobei n die Anzahl der Kurvensegmente ist.


Beispiel zur AddCurve-Methode

Im folgenden Beispiel wird in myDocument eine Bézier-Kurve mit zwei Segmenten eingefügt

Dim pts(1 To 7, 1 To 2) As Single
pts(1, 1) = 0
pts(1, 2) = 0
pts(2, 1) = 72
pts(2, 2) = 72
pts(3, 1) = 100
pts(3, 2) = 40
pts(4, 1) = 20
pts(4, 2) = 50
pts(5, 1) = 90
pts(5, 2) = 120
pts(6, 1) = 60
pts(6, 2) = 30
pts(7, 1) = 150
pts(7, 2) = 90
Set myDocument = Worksheets(1)
myDocument.Shapes.AddCurve pts


AddCustomList-Methode

Fügt eine benutzerdefinierte Liste für benutzerdefiniertes AutoAusfüllen und benutzerdefiniertes Sortieren hinzu.

Syntax

Ausdruck.AddCustomList(ListArray, ByRow)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

ListArray Variant erforderlich. Gibt die Quelldaten an, und zwar entweder als Matrix aus Zeichenfolgen oder als Range-Objekt.

ByRow Variant optional. Wird nur angegeben, wenn ListArray ein Range-Objekt ist. Wenn True, wird eine benutzerdefinierte Liste aus allen Zeilen des Bereichs erstellt. Wenn False, wird eine benutzerdefinierte Liste aus allen Spalten des Bereichs erstellt. Falls dieses Argument nicht angegeben ist und es in dem Bereich mehr Zeilen als Spalten gibt (oder die Anzahl der Zeilen und Spalten gleich ist), erstellt Microsoft Excel eine benutzerdefinierte Liste aus allen Spalten des Bereichs.

Anmerkungen

Falls Sie versuchen, eine bereits vorhandene Liste hinzuzufügen, verändert diese Methode nichts.


Beispiel zur AddCustomList-Methode

In diesem Beispiel wird eine Matrix aus Zeichenfolgen als benutzerdefinierte Liste hinzugefügt.

Application.AddCustomList Array("cogs", "sprockets", _
    "widgets", "gizmos")


 AddFields-Methode

AddFields-Methode

Fügt dem PivotTable-Bericht oder PivotChart-Bericht Zeilen-, Spalten- und Seitenfelder hinzu.

Syntax

Ausdruck.AddFields(RowFields, ColumnFields, PageFields, AddToTable, AppendField)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

RowFields Variant optional. Gibt einen Feldnamen (oder eine Matrix von Feldnamen) an, der bzw. die als Zeilen oder zu der Rubrikenachse hinzugefügt werden sollen.

ColumnFields Variant optional. Gibt einen Feldnamen (oder eine Matrix von Feldnamen) an, der bzw. die als Spalten oder zu der Rubrikenachse hinzugefügt werden sollen.

PageFields Variant optional. Gibt einen Feldnamen (oder eine Matrix von Feldnamen) an, der bzw. die als Seiten oder zu der Rubrikenachse hinzugefügt werden sollen.

AddToTable Variant optional. Gilt nur für PivotTable-Berichte. Falls True, werden dem Bericht die Felder hinzugefügt (ohne die existierenden Felder zu ersetzen). Wenn False, werden die existierenden Felder durch die neuen Felder ersetzt. Der Standardwert ist False.

AppendField Boolean optional. Gilt nur für PivotChart-Berichte. Falls True, werden dem Bericht die Felder hinzugefügt (ohne die existierenden Felder zu ersetzen). Wenn False, werden die existierenden Felder durch die neuen Felder ersetzt. Der Standardwert ist False.

Anmerkungen

Sie müssen eines der Argumente für Felder angeben.

Feldnamen geben den eindeutigen Namen an, der von der SourceName-Eigenschaft des PivotField-Objekts zurückgegeben werden.

Diese Methode steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur AddFields-Methode

In diesem Beispiel werden die existierenden Spaltenfelder in dem ersten PivotTable-Bericht in Sheet1 durch die Felder "Status" und "Closed_By" ersetzt.

Worksheets("Sheet1").PivotTables(1).AddFields _
    ColumnFields:=Array("Status", "Closed_By")


 AddFormControl-Methode

AddFormControl-Methode

Erstellt ein Microsoft Excel-Steuerelement. Gibt ein Shape-Objekt zurück, das das neue Steuerelement darstellt.

Syntax

Ausdruck.AddFormControl(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Der Typ des Microsoft Excel-Steuerelements. Dies kann eine der folgenden XlFormControl-Konstanten sein: xlButtonControl, xlCheckBox, xlDropDown, xlEditBox, xlGroupBox, xlLabel, xlListBox, xlOptionButton, xlScrollBar oder xlSpinner. In einem Tabellenblatt kann kein Bearbeitungsfeld erstellt werden.

Left, Top Long erforderlich. Die Anfangskoordinaten des neuen Objekts (in Punkt), relativ zur oberen linken Ecke der Zelle A1 in einem Tabellenblatt oder zur oberen linken Ecke eines Diagramms.

Width, Height Long erforderlich. Die Anfangsgröße des neuen Objekts in Punkt.

Anmerkungen

Verwenden Sie die AddOLEObject- oder die Add-Methode der OLEObjects-Auflistung, um ein ActiveX-Steuerelement zu erstellen.


Beispiel zur AddFormControl-Methode

In diesem Beispiel wird dem ersten Tabellenblatt ein Listenfeld hinzugefügt und der Bereich festgelegt, mit dem das Listenfeld ausgefüllt wird.

With Worksheets(1)
    Set lb = .Shapes.AddFormControl(xlListBox, 100, 10, 100, 100)
    lb.ControlFormat.ListFillRange = "A1:A10"
End With


AddItem-Methode

Fügt einem Listenfeld oder einem Kombinationsfeld ein Element hinzu.

Syntax

Ausdruck.AddItem(Text, Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ControlFormat-Objekt zurückgibt.

Text String erforderlich. Der hinzuzufügende Text.

Index Variant optional. Die Position des neuen Eintrags. Falls die Liste weniger Einträge besitzt als der angegebene Index, werden leere Elemente vom Ende der Liste an der angegebenen Position hinzugefügt. Wenn dieses Argument nicht angegeben wird, wird das Element an die bestehende Liste angehängt.

Anmerkungen

Wenn Sie diese Methode verwenden, werden alle mit der ListFillRange-Eigenschaft festgelegten Bereiche gelöscht.


Beispiel zur AddItem-Methode

In diesem Beispiel wird ein Listenfeld erstellt und mit Ganzzahlen von 1 bis 10 ausgefüllt.

With Worksheets(1)
    Set lb = .Shapes.AddFormControl(xlListBox, 100, 10, 100, 100)
    For x = 1 To 10
        lb.ControlFormat.AddItem x
    Next
End With


AddLabel-Methode

Erstellt eine Beschriftung. Gibt ein Shape-Objekt zurück, das die neue Beschriftung darstellt.

Syntax

Ausdruck.AddLabel(Orientation, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Orientation Long erforderlich. Die Ausrichtung des Textes innerhalb der Beschriftung. Kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke der Beschriftung, relativ zur oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Breite und Höhe der Beschriftung (in Punkt).


Beispiel zur AddLabel-Methode

In diesem Beispiel wird in myDocument eine vertikale Beschriftung mit dem Text "Testbeschriftung" eingefügt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddLabel(msoTextOrientationVertical, _
    100, 100, 60, 150) _
    .TextFrame.Characters.Text = "Test Label"


AddLine-Methode

Erstellt eine Linie. Gibt ein Shape-Objekt zurück, das die neue Linie darstellt.

Syntax

Ausdruck.AddLine(BeginX, Beginy, EndX, EndY)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

BeginX, BeginY Single erforderlich. Die Position (in Punkt) des Anfangspunktes der Linie, relativ zur oberen linken Ecke des Dokuments.

EndX, EndY Single erforderlich. Die Position (in Punkt) des Endpunktes der Linie, relativ zur oberen linken Ecke des Dokuments.


Beispiel zur AddLine-Methode

In diesem Beispiel wird in myDocument eine blau gestrichelte Linie eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


AddNodes-Methode

Fügt am Ende einer Freihandform, das gerade erstellt wird, einen neuen Abschnitt ein, und fügt die Knoten hinzu, durch die der Abschnitt definiert wird. Diese Methode können Sie beliebig oft verwenden, um einer Freihandform während der Erstellung Knoten hinzuzufügen. Haben Sie genügend Knoten hinzugefügt, verwenden Sie die ConvertToShape-Methode, um die gerade definierte Freihandform zu erstellen. Wenn Sie in einer bereits erstellten Freihandform Knoten einfügen möchten, verwenden Sie die Insert-Methode der ShapeNodes-Auflistung.

Syntax

Ausdruck.AddNodes(SegmentType, EditingType, X1, Y1, X2, Y2, X3, Y3)

Ausdruck Erforderlich. Ein Ausdruck, der ein FreeformBuilder-Objekt zurückgibt.

SegmentType Long erforderlich. Die Art des hinzuzufügenden Abschnitts. Kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.

EditingType Long erforderlich. Die Bearbeitungseigenschaften des Scheitelpunktes. Kann eine der beiden folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (kann nicht msoEditingSmooth oder msoEditingSymmetric sein). Wenn SegmentType den Wert msoSegmentLine besitzt, muss EditingType den Wert msoEditingAuto besitzen.

X1 Single erforderlich. Wenn EditingType des neuen Abschnitts den Wert msoEditingAuto besitzt, gibt dieses Argument die horizontale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Wenn EditingType des neuen Knotens den Wert msoEditingCorner besitzt, gibt dieses Argument die horizontale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Steuerpunkt des neuen Abschnitts an.

Y1 Single erforderlich. Wenn EditingType des neuen Abschnitts den Wert msoEditingAuto besitzt, gibt dieses Argument die vertikale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Wenn EditingType des neuen Knotens den Wert msoEditingCorner besitzt, gibt dieses Argument die vertikale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum ersten Steuerpunkt des neuen Abschnitts an.

X2 Single optional. Wenn EditingType des neuen Abschnitts den Wert msoEditingCorner besitzt, gibt dieses Argument die horizontale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Steuerpunkt des neuen Abschnitts an. Wenn EditingType des neuen Knotens den Wert msoEditingAuto besitzt, geben Sie keinen Wert für dieses Argument an.

Y2 Single optional. Wenn EditingType des neuen Abschnitts den Wert msoEditingCorner besitzt, gibt dieses Argument die vertikale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum zweiten Steuerpunkt des neuen Abschnitts an. Wenn EditingType des neuen Abschnitts den Wert msoEditingAuto besitzt, geben Sie keinen Wert für dieses Argument an.

X3 Single optional. Wenn EditingType des neuen Abschnitts den Wert msoEditingCorner besitzt, gibt dieses Argument die horizontale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Wenn EditingType des neuen Abschnitts den Wert msoEditingAuto besitzt, geben Sie keinen Wert für dieses Argument an.

Y3 Single optional. Wenn EditingType des neuen Abschnitts den Wert msoEditingCorner besitzt, gibt dieses Argument die vertikale Entfernung (in Punkt) von der oberen linken Ecke des Dokuments zum Endpunkt des neuen Abschnitts an. Wenn EditingType des neuen Abschnitts den Wert msoEditingAuto besitzt, geben Sie keinen Wert für dieses Argument an.


Beispiel zur AddNodes-Methode

In diesem Beispiel wird in myDocument ein Freihandobjekt mit vier Abschnitten eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


AddOLEObject-Methode

Erstellt ein OLE-Objekt. Gibt ein Shape-Objekt zurück, das das neue OLE-Objekt darstellt.

Syntax

Ausdruck.AddOLEObject(ClassType, FileName, Link, DisplayAsIcon, IconFileName, IconIndex, IconLabel, Left, Top, Width, Height, )

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

ClassType Variant optional. (Sie müssen entweder ClassType oder FileName angeben.) Eine Zeichenfolge, die den programmtechnischen Bezeichner des zu erstellenden Objekts enthält. Wenn ClassType angegeben ist, werden FileName und Link ignoriert. Weitere Informationen über programmtechnische Bezeichner finden Sie unter programmtechnische OLE-Bezeichner.

FileName Variant optional. Die Datei, aus der das Objekt erstellt werden soll. Ist kein Pfad angegeben, wird der aktuelle Arbeitsordner verwendet. Entweder muss das ClassType- oder das FileName-Argument für das Objekt angegeben werden; beide zusammen dürfen nicht angegeben werden.

Link Variant optional. True, um das OLE-Objekt mit der Datei zu verknüpfen, aus der es erstellt wurde. False, um das OLE-Objekt zu einer unabhängigen Kopie der Datei zu machen. Wenn Sie für ClassType einen Wert angegeben haben, muss dieses Argument den Wert False besitzen. Der Standardwert ist False.

DisplayAsIcon Variant optional. True, um das OLE-Objekt als Symbol anzuzeigen. Der Standardwert ist False.

IconFileName Variant optional. Die Datei, die das anzuzeigende Symbol enthält.

IconIndex Variant optional. Der Index des Symbols in IconFileName. Die Reihenfolge der Symbole in der angegebenen Datei entspricht der Reihenfolge, in der die Symbole im Dialogfeld Anderes Symbol erscheinen (auf das aus dem Dialogfeld Objekt einfügen heraus zugegriffen wird, wenn das Kontrollkästchen Als Symbol aktiviert ist). Das erste Symbol in der Datei besitzt die Indexnummer 0 (Null). Wenn kein Symbol mit der angegebenen Indexnummer in IconFileName existiert, wird das Symbol mit der Indexnummer 1 (das zweite Symbol in der Datei) verwendet. Der Standardwert ist 0 (Null).

IconLabel Variant optional. Eine Beschriftung, die unter dem Symbol angezeigt werden soll.

Left, Top Variant optional. Die Position (in Punkt) der oberen linken Ecke des neuen Objekts, relativ zur oberen linken Ecke des Dokuments. Der Standardwert ist 0 (Null).

Width, Height Variant optional. Die Anfangsabmessungen des OLE-Objekts in Punkt.


 Add-Methode (OLEObjects-Auflistung)

Add-Methode (OLEObjects-Auflistung)

Fügt einem Blatt ein neues OLE-Objekt hinzu. Gibt ein OLEObject-Objekt zurück.

Syntax

Ausdruck.Add(ClassType, FileName, Link, DisplayAsIcon, IconFileName, IconIndex, IconLabel, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der eine OLEObjects-Auflistung zurückgibt.

ClassType Variant optional. (Sie müssen entweder ClassType oder FileName angeben). Eine Zeichenfolge mit dem programmtechnischen Erkennungszeichen für das zu erstellende Objekt. Wenn ClassType angegeben wird, werden FileName und Link ignoriert. Weitere Informationen über programmtechnische Erkennungszeichen finden Sie unter programmtechnische OLE-Bezeichner.

FileName Variant optional. (Sie müssen entweder ClassType oder FileName angeben.) Eine Zeichenfolge, die die Datei angibt, aus der das OLE-Objekt erstellt werden soll.

Link Variant optional. True, wenn das neue auf Datei FileName basierende OLE-Objekt mit der Datei verknüpft werden soll. Wenn es nicht verknüpft wird, so wird das Objekt als Dateikopie erstellt. Der Standardwert ist False.

DisplayAsIcon Variant optional. True, wenn das neue OLE-Objekt als Symbol oder in seiner normalen Bilddarstellung angezeigt werden soll. Falls True, kann mit IconFileName und IconIndex ein Symbol angegeben werden.

IconFileName Variant optional. Eine Zeichenfolge, die die Datei angibt, die das anzuzeigende Symbol enthält. Dieses Argument wird nur verwendet, wenn DisplayAsIcon den Wert True hat. Wird dieses Argument nicht angegeben oder enthält die Datei keine Symbole, so wird das Standardsymbol für die OLE-Klasse verwendet.

IconIndex Variant optional. Die Nummer des Symbols in der Symboldatei. Dieses Argument wird nur verwendet, wenn DisplayAsIcon den Wert True hat und IconFileName auf eine gültige Datei mit Symbolen verweist. Falls ein Symbol mit diesem Index in der in IconFileName angegebenen Datei nicht existiert, wird das erste Symbol in der Datei verwendet.

IconLabel Variant optional. Eine Zeichenfolge, die eine unter dem Symbol anzuzeigende Beschriftung angibt. Dieses Argument wird nur verwendet, wenn DisplayAsIcon den Wert True hat. Wenn dieses Argument nicht angegeben wird oder die Zeichenfolge leer ("") ist, wird keine Beschriftung angezeigt.

Left, Top Variant optional. Die Anfangskoordinaten des Objekts in Punkt, relativ zur oberen linken Ecke der Zelle A1 eines Tabellenblattes oder zur oberen linken Ecke eines Diagramms.

Width, Height Variant optional. Die Anfangsgröße des neuen Objekts in Punkt.


Beispiel zur Add-Methode (OLEObjects-Auflistung)

In diesem Beispiel wird ein neues Microsoft Word OLE-Objekt in Sheet1 erstellt.

ActiveWorkbook.Worksheets("Sheet1").OLEObjects.Add _
    ClassType:="Word.Document"

In diesem Beispiel wird dem ersten Blatt eine Befehlsschaltfläche hinzugefügt.

Worksheets(1).OLEObjects.Add ClassType:="Forms.CommandButton.1", _
    Link:=False, DisplayAsIcon:=False, Left:=40, Top:=40, _
    Width:=150, Height:=10


Beispiel zur AddOLEObject-Methode

In diesem Beispiel wird in myDocument ein verknüpftes Word-Dokument eingefügt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddOLEObject Left:=100, Top:=100, _
    Width:=200, Height:=300, _
    FileName:="c:\my documents\testing.doc", link:=True

In diesem Beispiel wird in myDocument eine neue Befehlsschaltfläche eingefügt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddOLEObject Left:=100, Top:=100, _
    Width:=100, Height:=200, _
    ClassType:="Forms.CommandButton.1"


AddPicture-Methode

Erstellt ein Bild aus einer bestehenden Datei heraus. Gibt ein Shape-Objekt zurück, das das neue Bild darstellt.

Syntax

Ausdruck.AddPicture(FileName, LinkToFile, SaveWithDocument, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

FileName String erforderlich. Die Datei, aus der heraus das OLE-Objekt erstellt werden soll.

LinkToFile Long erforderlich. True, um das Bild mit der Datei zu verknüpfen, aus der heraus es erstellt wurde. False, um aus dem Bild eine unabhängige Kopie der Datei zu machen.

SaveWithDocument Long erforderlich. True, um das verknüpfte Bild zusammen mit der Datei zu speichern, in die es eingefügt wird. False, um nur die Verknüpfungsinformation im Dokument zu speichern. Dieses Argument muss den Wert True besitzen, wenn LinkToFile den Wert False besitzt.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Bildes, relativ zur oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Breite und Höhe des Bildes in Punkt.


Beispiel zur AddPicture-Methode

In diesem Beispiel wird in myDocument ein Bild, das aus der Datei music.bmp heraus erstellt wurde, eingefügt. Es ist mit der Datei, aus der heraus es erstellt wurde, verknüpft und wird zusammen mit myDocument gespeichert.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddPicture _
    "c:\microsoft office\clipart\music.bmp", _
    True, True, 100, 100, 70, 70


 AddPolyline-Methode

AddPolyline-Methode

Erstellt eine offene Polylinie oder ein geschlossenes Vieleck. Gibt ein Shape-Objekt zurück, das die neue Polylinie oder das neue Vieleck darstellt.

Syntax

Ausdruck.AddPolyline(SafeArrayOfPoints)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

SafeArrayOfPoints Variant erforderlich. Eine Matrix von Koordinatenpaaren, die die Scheitelpunkte der Polylinie festlegt.

Anmerkungen

Wenn Sie ein geschlossenes Vieleck erstellen möchten, weisen Sie dem ersten und dem letzten Scheitelpunkt der Polylinie dieselben Koordinaten zu.


Beispiel zur AddPolyline-Methode

In diesem Beispiel wird in myDocument ein Dreieck eingefügt. Da der erste und der letzte Punkt dieselben Koordinaten besitzen, wird das Vieleck geschlossen und ausgefüllt. Die Innenfarbe des Dreiecks entspricht der Füllfarbe der Standardform.

Dim triArray(1 To 4, 1 To 2) As Single
triArray(1, 1) = 25
triArray(1, 2) = 100
triArray(2, 1) = 100
triArray(2, 2) = 150
triArray(3, 1) = 150
triArray(3, 2) = 50
triArray(4, 1) = 25     ' Last point has same coordinates as first
triArray(4, 2) = 100
Set myDocument = Worksheets(1)
myDocument.Shapes.AddPolyline triArray


AddReplacement-Methode

Fügt der Matrix von AutoKorrektur-Ersetzungen einen Eintrag hinzu.

Syntax

Ausdruck.AddReplacement(What, Replacement)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoKorrektur-Objekt zurückgibt.

What String erforderlich. Gibt den zu ersetzenden Text an. Besteht diese Zeichenfolge bereits in der Matrix der AutoKorrektur-Ersetzungen, wird der bestehende Ersatztext mit dem neuen Text überschrieben.

Replacement String erforderlich. Gibt den Ersatztext an.


Beispiel zur AddReplacement-Methode

In diesem Beispiel wird das Wort "Temp." für das Wort "Temperature" in die Matrix der AutoKorrektur-Ersetzungen eingefügt.

With Application.AutoCorrect
    .AddReplacement "Temperature", "Temp."
End With


AddShape-Methode

Erstellt eine AutoForm. Gibt ein Shape-Objekt zurück, das die neue AutoForm darstellt.

Syntax

Ausdruck.AddShape(Type, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Type Long erforderlich. Gibt den Typ der zu erstellenden AutoForm an. Kann eine der MsoAutoShapeType-Konstanten sein.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der AutoForm, relativ zur oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Höhe und Breite des Begrenzungsrechtecks der AutoForm in Punkt.

Anmerkungen

Wenn Sie den Typ der hinzugefügten AutoForm ändern möchten, legen Sie die AutoShapeType-Eigenschaft fest.


Beispiel zur AddShape-Methode

In diesem Beispiel wird in myDocument ein Rechteck eingefügt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddShape msoShapeRectangle, 50, 50, 100, 200


AddTextbox-Methode

Erstellt ein Textfeld. Gibt ein Shape-Objekt zurück, das das neue Textfeld darstellt.

Syntax

Ausdruck.AddTextbox(Orientation, Left, Top, Width, Height)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Orientation Long erforderlich. Die Ausrichtung des Textes innerhalb der Beschriftung. Kann eine der folgenden MsoTextOrientation-Konstanten sein: msoTextOrientationDownward, msoTextOrientationHorizontal, msoTextOrientationHorizontalRotatedFarEast, msoTextOrientationMixed, msoTextOrientationUpward, msoTextOrientationVertical oder msoTextOrientationVerticalFarEast. Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Textfeldes, relativ zur oberen linken Ecke des Dokuments.

Width, Height Single erforderlich. Höhe und Breite des Textfeldes in Punkt.


Beispiel zur AddTextbox-Methode

In diesem Beispiel wird in myDocument ein Textfeld mit dem Text "Testfeld" eingefügt.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddTextbox(msoTextOrientationHorizontal, _
    100, 100, 200, 50) _
    .TextFrame.Characters.Text = "Test Box"


AddTextEffect-Methode

Erstellt ein WordArt-Objekt. Gibt ein Shape-Objekt zurück, das das neue WordArt-Objekt darstellt.

Syntax

Ausdruck.AddTextEffect(PresetTextEffect, Text, FontName, FontSize, FontBold, FontItalic, Left, Top)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

PresetTextEffect Long erforderlich. Der vordefinierte Texteffekt. Kann eine der folgenden MsoPresetTextEffect-Konstanten sein:

msoTextEffect1

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

msoTextEffect16

msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect2

msoTextEffect20

msoTextEffect21

msoTextEffect22

 msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect3

msoTextEffect30

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

Text String erforderlich. Der Text in der WordArt.

FontName String erforderlich. Der Name der in der WordArt verwendeten Schriftart.

FontSize Single erforderlich. Die Größe (in Punkt) der in der WordArt verwendeten Schriftart.

FontBold Long erforderlich. True, um die in der WordArt verwendete Schriftart fett zu formatieren.

FontItalic Long erforderlich. True, um die in der WordArt verwendete Schriftart kursiv zu formatieren.

Left, Top Single erforderlich. Die Position (in Punkt) der oberen linken Ecke des Begrenzungsrechtecks der WordArt, relativ zur oberen linken Ecke des Dokuments.

Anmerkungen

Wenn Sie einem Dokument eine WordArt hinzufügen, werden deren Höhe und Breite automatisch auf Grundlage von Größe und Menge des angegebenen Textes festgelegt.


Beispiel zur AddTextEffect-Methode

In diesem Beispiel wird in myDocument ein WordArt-Objekt mit dem Text "Test" eingefügt.

Set myDocument = Worksheets(1)
Set newWordArt = myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=10, _
    Top:=10)


AddToFavorites-Methode

Fügt dem Favoritenordner einen Shortcut zur Arbeitsmappe oder dem Hyperlink hinzu.

Syntax

Ausdruck.AddToFavorites

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook- oder ein Hyperlink-Objekt zurückgibt.


Beispiel zur AddToFavorites-Methode

In diesem Beispiel wird dem Favoritenordner ein Shortcut zur aktiven Arbeitsmappe hinzugefügt.

ActiveWorkbook.AddToFavorites


AdvancedFilter-Methode

Filtert oder kopiert Daten aus einer Liste basierend auf einem Kriterienbereich. Handelt es sich bei der Anfangsauswahl um eine einzelne Zelle, so wird ihr aktueller Bereich verwendet.

Syntax

Ausdruck.AdvancedFilter(Action, CriteriaRange, CopyToRange, Unique)

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.

Action Long erforderlich. Die Filter-Operation. Kann eine der folgenden XlFilterAction-Konstanten sein: xlFilterInPlace oder xlFilterCopy.

CriteriaRange Variant optional. Der Kriterienbereich. Falls das Argument nicht angegeben wird, gibt es keine Kriterien.

CopyToRange Variant optional. Der Zielbereich für die kopierten Zeilen, wenn Action den Wert xlFilterCopy hat. Andernfalls wird das Argument ignoriert.

Unique Variant optional. Wenn das Argument den Wert True hat, werden ausschließlich einmal vorhandene Datensätze gefiltert. Ist der Wert False, werden alle Datensätze gefiltert, die die Kriterien erfüllen. Der Standardwert ist False.


Beispiel zur AdvancedFilter-Methode

In diesem Beispiel wird die Datenbank "Database" basierend auf dem Kriterienbereich "Criteria" gefiltert.

Range("Database").AdvancedFilter _
    Action:=xlFilterInPlace, _
    CriteriaRange:=Range("Criteria")


Align-Methode

Richtet die Formen im angegebenen Formbereich aus.

Syntax

Ausdruck.Align(AlignCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

AlignCmd Long erforderlich. Gibt an, wie die Formen im angegebenen Formbereich ausgerichtet werden. Kann eine der folgenden MsoAlignCmd-Konstanten sein: msoAlignBottoms, msoAlignCenters, msoAlignLefts, msoAlignMiddles, msoAlignRights oder msoAlignTops.

RelativeTo Long erforderlich. Wird in Microsoft Excel nicht verwendet. Muss den Wert False besitzen.


Beispiel zur Align-Methode

In diesem Beispiel werden in myDocument die linken Ränder aller Formen im angegebenen Bereich am linken Rand der Form ausgerichtet, die im Bereich am weitesten links liegt.

Set myDocument = Worksheets(1)
myDocument.Shapes.SelectAll
Selection.ShapeRange.Align msoAlignLefts, False


Apply-Methode

Wird auf die angegebene Formformatierung angewendet, die mit Hilfe der PickUp-Methode kopiert wurde.

Syntax

Ausdruck.Apply

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.


ApplyCustomType-Methode

Weist einem Diagramm oder einer Datenreihe einen Standarddiagrammytp oder einen benutzerdefinierten Diagrammtyp zu.

Syntax

Ausdruck.ApplyCustomType(ChartType, TypeName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart- oder ein Series-Objekt zurückgibt.

ChartType Long erforderlich. Ein Standarddiagrammtyp (eine Liste der verfügbaren Konstanten finden Sie unter der ChartType-Eigenschaft). Bei Chart-Objekten kann dieses Argument auch eine der folgenden XlChartGallery-Konstanten sein: xlBuiltIn, xlUserDefined oder xlAnyGallery.

TypeName Variant optional (wird nur bei Chart-Objekten verwendet). Der Name des benutzerdefinierten Diagrammtyps, falls ChartType eine benutzerdefinierte Diagrammsammlung angibt.


Beispiel zur ApplyCustomType-Methode

In diesem Beispiel wir dem ersten Diagramm der Diagrammtyp "Linie mit Datenpunkten" zugewiesen.

Charts(1).ApplyCustomType xlLineMarkers


ApplyDataLabels-Methode

Weist dem Datenpunkt, der Datenreihe oder allen Datenreihen im Diagrammblatt Datenbeschriftungen zu.

Syntax

Ausdruck.ApplyDataLabels(Type, LegendKey, AutoText, HasLeaderLines)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-, Point- oder Series-Objekt zurückgibt.

Type Variant optional. Der Typ der Datenbeschriftung. Zulässig ist eine der folgenden XlDataLabelsType-Konstanten:

Konstante | Beschreibung
xlDataLabelsShowNone | Keine Datenbeschriftung.
xlDataLabelsShowValue | Wert für den Datenpunkt (wenn dieses Argument nicht angegeben wird, wird ein Wert angenommen).
XlDataLabelsShowPercent | Prozentsatz der Summe. Nur für Kreis- und Ringdiagramme verfügbar.
XlDataLabelsShowLabel | Rubrikenbeschriftung für den Datenpunkt. Dies ist der Standardwert.
XlDataLabelsShowLabelAndPercent | Prozentsatz der Summe und Rubrikenbeschriftung für den Datenpunkt. Nur für Kreis- und Ringdiagramme verfügbar.

LegendKey Variant optional. True, wenn Microsoft Excel die Legende neben dem Datenpunkt anzeigt. Der Standardwert ist False.

AutoText Optional Variant. Wahr, wenn das Objekt basierend auf dem Inhalt automatisch angemessenen Text erzeugt.

HasLeaderLines Optional Variant. Für die Chart- und Series-Objekte, Wahr, wenn die Reihe Führungslinien besitzt.


Beispiel zur ApplyDataLabels-Methode

In diesem Beispiel werden der ersten Datenreihe in Chart1 Rubrikenbeschriftungen zugewiesen.

Charts("Chart1").SeriesCollection(1). _
    ApplyDataLabels Type:=xlDataLabelsShowLabel


ApplyNames-Methode

Weist den Zellen im angegebenen Bereich Namen zu.

Syntax

Ausdruck.ApplyNames(Names, IgnoreRelativeAbsolute, UseRowColumnNames, OmitColumn, OmitRow, Order, AppendLast)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Names Variant optional. Eine Matrix mit den Namen, die zugewiesen werden sollen. Wird das Argument nicht angegeben, werden dem Bereich alle Namen des Tabellenblattes zugewiesen.

IgnoreRelativeAbsolute Variant optional. True, wenn Bezüge durch Namen ersetzt werden, ohne den Bezugstyp des Namens oder des Bezugs selbst zu berücksichtigen. False, wenn absolute Bezüge nur durch absolute Namen, relative Bezüge nur durch relative Namen und kombinierte Bezüge nur durch kombinierte Namen ersetzt werden. Der Standardwert ist True.

UseRowColumnNames Variant optional. True, wenn die Namen der Zeilen- und Spaltenbereiche verwendet werden, die den angegebenen Bereich enthalten, sofern Namen für diesen Bereich nicht gefunden werden können. False, wenn die Argumente OmitColumn und OmitRow nicht beachtet werden. Der Standardwert ist True.

OmitColumn Variant optional. True, wenn der gesamte Bezug mit dem zeilenorientierten Namen ersetzt wird. Der spaltenorientierte Name kann nur ausgelassen werden, sofern sich die Zelle, auf die der Bezug besteht, in derselben Spalte wie die Formel und in einem zeilenorientierten benannten Bereich befindet. Der Standardwert ist True.

OmitRow Variant optional. True, wenn der gesamte Bezug mit dem spaltenorientierten Namen ersetzt wird. Der zeilenorientierte Name kann nur ausgelassen werden, sofern sich die Zelle, auf die der Bezug besteht, in derselben Zeile wie die Formel und in einem spaltenorientierten benannten Bereich befindet. Der Standardwert ist True.

Order Variant optional. Legt fest, welcher Bereichsname zuerst erscheint, wenn ein Zellbezug durch einen zeilenorientierten und spaltenorientierten Bereichsnamen ersetzt wird. Zulässig ist eine der folgenden XlApplyNamesOrder-Konstanten: xlRowThenColumn oder xlColumnThenRow.

AppendLast Variant optional. True, wenn die Definitionen der Namen in Names sowie die Definitionen der zuletzt definierten Namen ersetzt werden. False, wenn nur die Definitionen der Namen in Names ersetzt werden. Der Standardwert ist False.

Anmerkungen

Mit der Array-Funktion können Sie eine Namensliste für das Argument Names erstellen.

Mit Cells.ApplyNames können Sie die Namen auf das gesamte Tabellenblatt anwenden.

Dieser Vorgang lässt sich nicht rückgängig machen. Löschen Sie Namen mit der Delete-Methode.


Beispiel zur ApplyNames-Methode

In diesem Beispiel werden Namen auf das gesamte Tabellenblatt angewendet.

Cells.ApplyNames Names:=Array("Sales", "Profits")


ApplyOutlineStyles-Methode

Weist einem angegebenen Bereich eine Formatvorlage für eine Gliederung zu.

Syntax

Ausdruck.ApplyOutlineStyles

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur ApplyOutlineStyles-Methode

Im folgenden Beispiel wird eine automatische Gliederungs-Formatvorlage für den ausgewählten Bereich festgelegt. Die Auswahl muss den gesamten Bereich enthalten, der gegliedert werden soll.

Selection.ApplyOutlineStyles


AreaGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Flächendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Flächendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.AreaGroups(Index)

Syntax 2

Ausdruck.AreaGroups

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Index Erforderlich für Syntax 1. Gibt die Diagrammgruppe an.


Beispiel zur AreaGroups-Methode

In diesem Beispiel werden Bezugslinien für die 2D-Flächendiagrammgruppe aktiviert.

Charts(1).AreaGroups(1).HasDropLines = True


Arrange-Methode

Ordnet die Fenster auf dem Bildschirm an.

Syntax

Ausdruck.Arrange(ArrangeStyle, ActiveWorkbook, SyncHorizontal, SyncVertical)

Ausdruck Erforderlich. Ein Ausdruck, der ein Windows-Objekt zurückgibt.

ArrangeStyle Variant optional. Zulässig ist eine der folgenden XlArrangeStyle-Konstanten:

Konstante | Beschreibung
xlArrangeStyleTiled | Die Fenster werden nebeneinander angeordnet (der Standardwert).
XlArrangeStyleCascade | Die Fenster werden überlappend angeordnet.
XlArrangeStyleHorizontal | Die Fenster werden horizontal unterteilt angeordnet.
XlArrangeStyleVertical | Die Fenster werden vertikal unterteilt angeordnet.

ActiveWorkbook Variant optional. True, wenn nur die sichtbaren Fenster der aktiven Arbeitsmappe angeordnet werden. False, wenn alle Fenster angeordnet werden. Der Standardwert ist False.

SyncHorizontal Variant optional. Wird ignoriert, wenn ActiveWorkbook entweder den Wert False hat oder ausgelassen wurde. True, wenn die Fenster der aktiven Arbeitsmappe beim horizontalen Bildlauf synchronisiert werden. False, wenn die Fenster nicht synchronisiert werden. Der Standardwert ist False.

SyncVertical Variant optional. Wird ignoriert, wenn ActiveWorkbook entweder den Wert False hat oder ausgelassen wurde. True, wenn die Fenster der aktiven Arbeitsmappe beim vertikalen Bildlauf synchronisiert werden. False, wenn die Fenster nicht synchronisiert werden. Der Standardwert ist False.


Beispiel zur Arrange-Methode

In diesem Beispiel werden alle Fenster der Anwendung nebeneinander angeordnet.

Application.Windows.Arrange ArrangeStyle:=xlArrangeStyleTiled


AutoComplete-Methode

Gibt eine AutoComplete-Übereinstimmung aus der Liste zurück. Besteht keine Übereinstimmung oder stimmt mehr als ein Listeneintrag mit der zu ergänzenden Zeichenfolge überein, gibt die Methode eine leere Zeichenfolge zurück.

Syntax

Ausdruck.AutoComplete(String)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt (muss eine einzelne Zelle sein).

String String erforderlich. Die Zeichenfolge, die vervollständigt werden soll.

Anmerkungen

Diese Methode arbeitet auch, wenn AutoComplete deaktiviert ist.


Beispiel zur AutoComplete-Methode

In diesem Beispiel wird die AutoComplete-Übereinstimmung der Teilzeichenfolge "Ap" zurückgegeben. Eine Übereinstimmung wird erzielt, wenn die Spalte, in der sich die Zelle A5 befindet, eine zusammenhängende Liste enthält und einer der Listeneinträge mit der Teilzeichenfolge übereinstimmt.

s = Worksheets(1).Range("A5").AutoComplete("Ap")
If Len(s) > 0 Then
    MsgBox "Completes to " & s
Else
    MsgBox "Has no completion"
End If


AutoFill-Methode

Füllt die Zellen in einem angegebenen Bereich automatisch aus.

Syntax

Ausdruck.AutoFill(Destination, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Destination Erforderliches Range-Objekt. Die auszufüllenden Zellen. Der Quellbereich muss im Objekt enthalten sein.

Type Variant optional. Bestimmt den Fülltyp. Zulässig ist eine der folgenden XlFillType-Konstanten: xlFillDefault, xlFillSeries, xlFillCopy, xlFillFormats, xlFillValues, xlFillDays, xlFillWeekdays, xlFillMonths, xlFillYears, xlLinearTrend oder xlGrowthTrend. Wenn das Argument ausgelassen oder xlFillDefault angegeben wird, wählt Microsoft Excel einen passenden Typ aus, basierend auf dem Quellbereich.


Beispiel zur AutoFill-Methode

In diesem Beispiel werden die Zellen A1:A20 in Sheet1 automatisch ausgefüllt, wobei der Quellbereich A1:A2 zugrunde gelegt wird. Geben Sie 1 in Zelle A1 und 2 in Zelle A2 ein, bevor Sie dieses Beispiel ausführen.

Set sourceRange = Worksheets("Sheet1").Range("A1:A2")
Set fillRange = Worksheets("Sheet1").Range("A1:A20")
sourceRange.AutoFill Destination:=fillRange


AutoFilter-Methode

Filtert eine Liste unter Verwendung von AutoFilter.

Anmerkung Weisen Sie die AutoFilter-Eigenschaft einem Worksheet-Objekt zu, um ein AutoFilter-Objekt zurückzugeben.

Syntax

Ausdruck.AutoFilter(Field, Criteria1, Operator, Criteria2, VisibleDropDown)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Field Variant optional. Der ganzzahlige Versatz (Offset) des Feldes, auf dem der Filter basieren soll (links in der Liste beginnend, wobei das Feld ganz links als erstes Feld verwendet wird).

Criteria1 Variant optional. Das Kriterium (eine Zeichenfolge, z. B. "101"). Verwenden Sie für die Suche nach leeren Feldern "=" und für die Suche nach nicht leeren Feldern "<>". Falls das Argument nicht angegeben wird, ist das Kriterium "All". Wenn Operator gleich xlTop10Items ist, gibt Criteria1 die Anzahl der Elemente an (z. B. "10").

Operator Variant optional. Kann eine der folgenden XlAutoFilterOperator-Konstanten sein: xlAnd, xlBottom10Items, xlBottom10Percent, xlOr, xlTop10Items oder xlTop10Percent. Verwenden Sie xlAnd und xlOr mit Criteria1 und Criteria2, um zusammengesetzte Kriterien zu erstellen.

Criteria2 Variant optional. Das zweite Kriterium (eine Zeichenfolge). Wird mit Criteria1 und Operator zum Erstellen von zusammengesetzten Kriterien verwendet.

VisibleDropDown Variant optional. Falls True, werden die Dropdownpfeile von AutoFilter für das gefilterte Feld angezeigt. Falls False, werden die Dropdownpfeile von AutoFilter für das gefilterte Feld ausgeblendet. Der Standardwert ist True.

Anmerkungen

Wenn keine Argumente angegeben werden, schaltet diese Methode lediglich die Anzeige der Dropdownpfeile von AutoFilter im angegebenen Bereich um.


Beispiel zur AutoFilter-Methode

In diesem Beispiel wird eine in Zelle A1 in Sheet1 beginnende Liste so gefiltert, dass nur diejenigen Einträge angezeigt werden, in denen das erste Feld die Zeichenfolge "Bobby" enthält.

Worksheets("Sheet1").Range("A1").AutoFilter _
    field:=1, _
    Criteria1:="Otis"
    VisibleDropDown:=False


AutoFit-Methode

Ändert die Spaltenbreite oder die Zeilenhöhe im angegebenen Bereich, um eine optimale Anpassung zu erreichen.

Syntax

Ausdruck.AutoFit

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Der zu optimierende Bereich, der aus einer oder mehreren Zeilen bzw. aus einer oder mehreren Spalten bestehen muss. Ist diese Voraussetzung nicht gegeben, so führt diese Methode zu einem Fehler.

Anmerkungen

Die Einheit für die Spaltenbreite entspricht der Breite eines Zeichens der Formatvorlage Standard.


Beispiel zur AutoFit-Methode

In diesem Beispiel wird die Breite der Spalten A bis I in Sheet1 optimiert.

Worksheets("Sheet1").Columns("A:I").AutoFit

In diesem Beispiel wird die Breite der Spalten A bis E in Sheet1 optimiert, wobei lediglich der Inhalt des Bereichs A1:E1 als Grundlage dient.

Worksheets("Sheet1").Range("A1:E1").Columns.AutoFit


AutoFormat-Methode

Formatiert den angegebenen Bereich automatisch mit einem vordefinierten Format.

Syntax

Ausdruck.AutoFormat(Format, Number, Font, Alignment, Border, Pattern, Width)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Format Variant optional. Das angegebene AutoFormat. Zulässig ist eine der folgenden XlRangeAutoFormat-Konstanten:

xlRangeAutoFormat3DEffects1

xlRangeAutoFormat3DEffects2

xlRangeAutoFormatAccounting1

xlRangeAutoFormatAccounting2

xlRangeAutoFormatAccounting3

xlRangeAutoFormatAccounting4

xlRangeAutoFormatClassic1

xlRangeAutoFormatClassic2

xlRangeAutoFormatClassic3

xlRangeAutoFormatClassicPivotTable

xlRangeAutoFormatColor1

xlRangeAutoFormatColor2

xlRangeAutoFormatColor3

xlRangeAutoFormatList1

xlRangeAutoFormatList2

xlRangeAutoFormatList3

xlRangeAutoFormatLocalFormat1

xlRangeAutoFormatLocalFormat2

xlRangeAutoFormatLocalFormat3

xlRangeAutoFormatLocalFormat4

xlRangeAutoFormatNone

xlRangeAutoFormatPTNone

 xlRangeAutoFormatReport1

xlRangeAutoFormatReport2

xlRangeAutoFormatReport3

xlRangeAutoFormatReport4

xlRangeAutoFormatReport5

xlRangeAutoFormatReport6

xlRangeAutoFormatReport7

xlRangeAutoFormatReport8

xlRangeAutoFormatReport9

xlRangeAutoFormatReport10

xlRangeAutoFormatSimple

xlRangeAutoFormatTable1

xlRangeAutoFormatTable2

xlRangeAutoFormatTable3

xlRangeAutoFormatTable4

xlRangeAutoFormatTable5

xlRangeAutoFormatTable6

xlRangeAutoFormatTable7

xlRangeAutoFormatTable8

xlRangeAutoFormatTable9

xlRangeAutoFormatTable10

Die Standardkonstante ist xlRangeAutoFormatClassic1. Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.

Number Variant optional. True, wenn Zahlenformate in die automatische Formatierung mit aufgenommen werden. Der Standardwert ist True.

Font Variant optional. True, wenn Schriftformate in die automatische Formatierung mit aufgenommen werden. Der Standardwert ist True.

Alignment Variant optional. True, wenn die Ausrichtung in die automatische Formatierung mit aufgenommen wird. Der Standardwert ist True.

Border Variant optional. True, wenn Rahmenformatierung in die automatischen Formatierung mit aufgenommen wird. Der Standardwert ist True.

Pattern Variant optional. True, wenn Musterformatierung in die automatischen Formatierung mit aufgenommen wird. Der Standardwert ist True.

Width Variant optional. True, wenn Spaltenbreite und Zeilenhöhe in die automatischen Formatierung mit aufgenommen werden. Der Standardwert ist True.

Anmerkungen

Handelt es sich bei dem Bereich um eine einzelne Zelle, so formatiert diese Methode auch den aktiven Bereich, der die Zelle umgibt, d. h. die beiden folgenden Anweisungen sind gleichbedeutend:

Cells("A1").AutoFormat
Cells("A1").CurrentRegion.AutoFormat


Beispiel zur AutoFormat-Methode

In diesem Beispiel werden die Zellen "A1:D8" in Sheet1 mit einem vordefinierten Format formatiert.

Worksheets("Sheet1").Range("A1:D8"). _
    AutoFormat Format:=xlRangeAutoFormatClassic1


AutomaticLength-Methode

Legt fest, dass der erste Abschnitt der Legendenlinie (der mit dem Textfeld der Legende verbundene) automatisch skaliert wird, wenn die Legende verschoben wird. Verwenden Sie die CustomLength-Methode, um festzulegen, dass der erste Abschnitt der Legendenlinie beim Verschieben der Legende die feste Länge beibehält, die die Length-Eigenschaft zurückgibt. Gilt nur für Legenden, deren Linien aus mehreren Abschnitten bestehen (Legenden des Typs msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.AutomaticLength

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Anmerkungen

Durch Anwenden dieser Methode wird die AutoLength-Eigenschaft auf True gesetzt.


Beispiel zur AutomaticLength-Methode

In diesem Beispiel wird zwischen automatischer Skalierung des ersten Abschnitts und Skalierung mit fester Länge der Legendenlinie in der ersten Form von myDocument hin- und hergeschaltet. Das Beispiel funktioniert nur, wenn es sich bei der Form um eine Legende handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


AutoOutline-Methode

Erstellt automatisch eine Gliederung für den angegebenen Bereich. Handelt es sich bei dem Bereich um eine einzelne Zelle, so erstellt Microsoft Excel eine Gliederung für das gesamte Blatt. Die neue Gliederung ersetzt eine bestehende Gliederung.

Syntax

Ausdruck.AutoOutline

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur AutoOutline-Methode

In diesem Beispiel wird eine Gliederung für den Bereich A1:G37 in Sheet1 erstellt. Der Bereich muss eine Zeilen- bzw. eine Spaltenzusammenfassung enthalten.

Worksheets("Sheet1").Range("A1:G37").AutoOutline


AutoShow-Methode

Zeigt die Anzahl oberer oder unterer Elemente für eine Zeile, eine Seite oder ein Spaltenfeld in dem angegebenen PivotTable-Bericht an.

Syntax

Ausdruck.AutoShow(Type, Range, Count, Field)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Type Long erforderlich. Verwenden Sie xlAutomatic, wenn in dem angegebenen PivotTable-Bericht die Elemente angezeigt werden sollen, die die angegebenen Kriterien erfüllen. Verwenden Sie xlManual, um diese Funktion zu deaktivieren.

Range Long erforderlich. Die Position, ab der Elemente angezeigt werden sollen. Dies kann eine der folgenden Konstanten sein: xlTop oder xlBottom.

Count Long erforderlich. Die Anzahl der anzuzeigenden Elemente.

Field String erforderlich. Der Name des Basisdatenfelds. Sie müssen den eindeutigen Namen (wie von der SourceName-Eigenschaft zurückgegeben) angeben und nicht den angezeigten Namen.


Beispiel zur AutoShow-Methode

In diesem Beispiel werden nach dem Kriterium des Gesamtumsatzes nur die beiden ersten Unternehmen angezeigt:

ActiveSheet.PivotTables("Pivot1").PivotFields("Company") _
    .AutoShow  xlAutomatic, xlTop, 2, "Sum of Sales"


AutoSort-Methode

Legt automatische Regeln für die Sortierung von Feldern in PivotTable-Berichten fest.

Syntax

Ausdruck.AutoSort(Order, Field)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Order Long erforderlich. Die Sortierreihenfolge. Dies kann eine der folgenden XlSortOrder-Konstanten sein: xlAscending oder xlDescending. Dies kann auch xlManual sein; damit wird die automatische Sortierung deaktiviert.

Field String erforderlich. Der Name des Sortierschlüsselfeldes. Sie müssen den eindeutigen Namen (wie von der SourceName-Eigenschaft zurückgegeben) angeben und nicht den angezeigten Namen.


Beispiel zur AutoSort-Methode

In diesem Beispiel wird das Feld "Unternehmen" nach dem Kriterium "Gesamtumsatz" in absteigender Reihenfolge sortiert.

ActiveSheet.PivotTables(1).PivotField("Company") _
    .AutoSort xlDescending, "Sum of Sales"


Axes-Methode

Gibt ein Objekt zurück, das eine einzelne Achse (ein Axis-Objekt, Syntax 1) oder eine Auflistung der Achsen des Diagramms (eine Axes-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.Axes(Type, AxisGroup)

Syntax 2

Ausdruck.Axes

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Type Variant optional. Gibt die zurückzugebende Achse an. Kann eine der folgenden XlAxisType-Konstanten sein: xlValue, xlCategory oder xlSeriesAxis (xlSeriesAxis ist nur für 3D-Diagramme gültig).

AxisGroup Variant optional. Gibt die Achsengruppe an. Kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Wird dieses Argument nicht angegeben, wird die Primärgruppe verwendet. 3D-Diagramme haben nur eine Achsengruppe.


Beispiel zur Axes-Methode

In diesem Beispiel wird der Rubrikenachse in Chart1 eine Beschriftung zugewiesen.

With Charts("Chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With

In diesem Beispiel werden die Hauptgitternetzlinien für die Rubrikenachse in Chart1 deaktiviert.

Charts("Chart1").Axes(xlCategory).HasMajorGridlines = False

In diesem Beispiel werden die Gitternetzlinien für alle Achsen in Chart1 deaktiviert.

For Each a In Charts("Chart1").Axes
    a.HasMajorGridlines = False
    a.HasMinorGridlines = False
Next a


BarGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Balkendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Balkendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.BarGroups(Index)

Syntax 2

Ausdruck.BarGroups

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur BarGroups-Methode

In diesem Beispiel wird der Abstand zwischen den Balkengruppen in der 2D-Balkendiagrammgruppe auf 50 Prozent der Balkenbreite festgelegt.

Charts(1).BarGroups(1).GapWidth = 50


BeginConnect-Methode

Ordnet einer angegebenen Form den Anfang der angegebenen Verbindung zu. Ist der Anfang der Verbindung schon mit einer anderen Form verbunden, wird diese Verbindung unterbrochen. Liegt der Anfang der Verbindung noch nicht an dem angegebenen Verbindungspunkt, verschiebt ihn diese Methode dorthin, und Größe sowie Position der Verbindung werden angepasst. Mit Hilfe der EndConnect-Methode können Sie einer Form das Ende einer Verbindung zuordnen.

Syntax

Ausdruck.BeginConnect(ConnectedShape, ConnectionSite)

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.

ConnectedShape Shape-Objekt erforderlich. Die Form, der der Anfang der Verbindung zugeordnet werden soll. Das angegebene Shape-Objekt muss sich in derselben Shapes-Auflistung wie die Verbindung befinden.

ConnectionSite Long erforderlich. Ein durch ConnectedShape festgelegter Verbindungspunkt auf der Form. Muss eine Ganzzahl zwischen 1 und der Ganzzahl sein, die die ConnectionSiteCount-Eigenschaft der angegebenen Form zurückgibt. Möchten Sie, dass die Verbindung automatisch auf dem kürzesten Weg zwischen den beiden Formen verläuft, geben Sie für dieses Argument eine gültige Ganzzahl ein und verwenden Sie, nachdem beide Verbindungsenden Formen zugeordnet wurden, die RerouteConnections-Methode.

Anmerkungen

Wenn Sie einem Objekt eine Verbindung zuordnen, werden Position und Größe der Verbindung, wenn notwendig, automatisch angepasst.


Beispiel zur BeginConnect-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und durch eine gekrümmte Verbindung miteinander verbunden. Beachten Sie, dass es auf Grund der RerouteConnections-Methode unerheblich ist, welche Werte Sie für das ConnectionSite-Argument der Methoden BeginConnect und EndConnect angeben.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set c = s.AddConnector(msoConnectorCurve, 0, 0, 100, 100)
with c.ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    c.RerouteConnections
End With


BeginDisconnect-Methode

Löst den Anfang der angegebenen Verbindung von der Form, der er zugeordnet ist. Größe oder Position der Verbindung werden durch diese Methode nicht geändert: Der Anfang der Verbindung verbleibt an dem Verbindungspunkt, es besteht jedoch keine Verbindung mehr. Mit Hilfe der EndDisconnect-Methode können Sie das Ende der Verbindung von einer Form lösen.

Syntax

Ausdruck.BeginDisconnect

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.


Beispiel zur BeginDisconnect-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und einer Verbindung zugeordnet, die automatisch auf den kürzesten Weg geleitet wird. Anschließend wird die Verbindung von den Rechtecken gelöst.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set c = s.AddConnector(msoConnectorCurve, 0, 0, 0, 0)
With c.ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    c.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


BorderAround-Methode

Umgibt einen Bereich mit einem Rahmen und legt die Eigenschaften Color, LineStyle und Weight für den neuen Rahmen fest.

Syntax

Ausdruck.BorderAround(LineStyle, Weight, ColorIndex, Color)

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.

LineStyle Variant optional. Die Linienart für den Rahmen. Kann eine der folgenden XlLineStyle-Konstanten sein: xlContinuous, xlDash, xlDashDot, xlDashDotDot, xlDot, xlDouble, xlLineStyleNone oder xlSlantDashDot. Der Standardwert ist xlContinuous.

Weight Variant optional. Die Rahmenstärke. Kann eine der folgenden XlBorderWeight-Konstanten sein: xlHairline, xlThin, xlMedium oder xlThick. Der Standardwert ist xlThin.

ColorIndex Variant optional. Die Rahmenfarbe als Farbindex in der aktuellen Farbpalette oder als eine der folgenden XlColorIndex-Konstanten: xlColorIndexAutomatic oder xlColorIndexNone.

Color Variant optional. Die Rahmenfarbe als RGB-Wert.

Anmerkungen

Sie müssen entweder ColorIndex oder Color angeben, nicht aber beide Argumente.

Sie können entweder LineStyle oder Weight angeben, aber nicht beide. Wenn Sie keines der Argumente angeben, verwendet Microsoft Excel Standard-Linienart und -stärke.

Diese Methode zieht eine Kontur um den gesamten Bereich, ohne ihn auszufüllen. Um die Rahmen aller Zellen zu bestimmen, legen Sie die Eigenschaften Color, LineStyle und Weight für die Borders-Auflistung fest. Um den Rahmen zu löschen, setzen Sie die LineStyle-Eigenschaft auf xlLineStyleNone für alle Zellen des Bereichs.


Beispiel zur BorderAround-Methode

In diesem Beispiel wird dem Bereich A1:D4 in Sheet1 ein breiter roter Rahmen hinzugefügt.

Worksheets("Sheet1").Range("A1:D4").BorderAround _
        ColorIndex:=3, Weight:=xlThick


BringToFront-Methode

Bringt das Objekt in den Vordergrund der Z-Reihenfolge.

Syntax

Ausdruck.BringToFront

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


Beispiel zur BringToFront-Methode

In diesem Beispiel wird das erste eingebettete Diagramm in Sheet1 in den Vordergrund der Z-Reihenfolge gebracht.

Worksheets("Sheet1").ChartObjects(1).BringToFront


BuildFreeform-Methode

Baut ein Freihandobjekt auf. Gibt ein FreeformBuilder-Objekt zurück, das die Freihandform während des Aufbaus darstellt. Verwenden Sie die AddNodes-Methode, um der Freihandform Abschnitte hinzuzufügen. Nachdem mindestens ein Abschnitt hinzugefügt wurde, können Sie mit der ConvertToShape-Methode das FreeformBuilder-Objekt in ein Shape-Objekt umwandeln, das die geometrische Beschreibung besitzt, die Sie im FreeformBuilder-Objekt definiert haben.

Syntax

Ausdruck.BuildFreeform(EditingType, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des ersten Knotens. Kann eine der beiden folgenden MsoEditingType-Konstanten sein: msoEditingAuto oder msoEditingCorner (kann nicht msoEditingSmooth oder msoEditingSymmetric sein).

X1, Y1 Single erforderlich. Die Position (in Punkt) des ersten Knotens der Freihandzeichnung, relativ zur oberen linken Ecke des Dokuments.


Beispiel zur BuildFreeform-Methode

In diesem Beispiel wird in myDocument ein Freihandobjekt mit fünf Scheitelpunkten eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Calculate-Methode

Diese Methode berechnet alle geöffneten Arbeitsmappen, ein bestimmtes Tabellenblatt einer Arbeitsmappe oder einen bestimmten Zellbereich in einem Tabellenblatt (siehe Tabelle unten).

Berechnetes Objekt | Beispiel
Alle geöffneten Arbeitsmappen | Application.Calculate (oder einfach Calculate)
Ein bestimmtes Tabellenblatt | Worksheets(1).Calculate
Ein bestimmter Bereich | Worksheets(1).Rows(2).Calculate

Syntax

Ausdruck.Calculate

Ausdruck Optional für Application-Objekte, erforderlich für Worksheet- und Range-Objekte. Es ist ein Ausdruck anzugeben, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


CalculatedFields-Methode

Gibt eine CalculatedFields-Auflistung zurück, die alle berechneten Felder des angegebenen PivotTable-Berichts darstellt. Schreibgeschützt.

Syntax

Ausdruck.CalculatedFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.


Beispiel zur CalculatedFields-Methode

In diesem Beispiel wird verhindert, dass berechnete Felder auf die Zeilenposition gezogen werden.

For Each fld in _
        Worksheets(1).PivotTables("Pivot1") _
        .CalculatedFields
    fld.DragToRow = False
Next


 CalculatedItems-Methode

CalculatedItems-Methode

Gibt eine CalculatedItems-Auflistung zurück, die alle berechneten Elemente des angegebenen PivotTable-Berichts darstellt. Schreibgeschützt.

Syntax

Ausdruck.CalculatedItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Anmerkungen

Für OLAP-Datenquellen gibt diese Methode eine Auflistung mit der Länge Null zurück.


Beispiel zur CalculatedItems-Methode

In diesem Beispiel wird eine Liste berechneter Elemente und ihrer Formeln erstellt.

Set pt = Worksheets(1).PivotTables(1)
For Each ci In pt.PivotFields("Sales").CalculatedItems
    r = r + 1
    With Worksheets(2)
        .Cells(r, 1).Value = ci.Name
        .Cells(r, 2).Value = ci.Formula
    End With
Next


CalculateFull-Methode

Erzwingt eine vollständige Berechnung der Daten in allen geöffneten Arbeitsmappen.


Beispiel zu CalculateFull-Methode

In diesem Beispiel wird die Version von Microsoft Excel mit derjenigen Version von Excel, in der die Arbeitsmappe zuletzt berechnet wurde, verglichen. Sind die beiden Versionsnummern unterschiedlich, wird eine vollständige Berechnung der Daten in allen geöffneten Arbeitsmappen durchgeführt.

If Application.CalculationVersion <> _
    Workbooks(1).CalculationVersion Then
    Application.CalculateFull
End If


CancelRefresh-Methode

Bricht alle Hintergrundabfragen der angegebenen Abfragetabelle ab. Verwenden Sie die Refreshing-Eigenschaft, um festzustellen, ob gerade eine Abfrage durchgeführt wird.

Syntax

Ausdruck.CancelRefresh

Ausdruck Erforderlich. Ein Ausdruck, der ein QueryTable-Objekt zurückgibt.


Beispiel zur CancelRefresh-Methode

In diesem Beispiel wird die Aktualisierung einer Abfragetabelle abgebrochen.

With Worksheets(1).QueryTables(1)
    If .Refreshing Then .CancelRefresh
End With


CentimetersToPoints-Methode

Wandelt eine Maßangabe von Zentimeter in Punkt (0,35 mm) um.

Syntax

Ausdruck.CentimetersToPoints(Centimeters)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Centimeters Double erforderlich. Legt den Zentimeterwert fest, der in Punkt umgerechnet werden soll.


Beispiel zur CentimetersToPoints-Methode

In diesem Beispiel wird der linke Rand von Sheet1 auf 5 Zentimeter eingestellt.

Worksheets("Sheet1").PageSetup.LeftMargin = _
        Application.CentimetersToPoints(5)


ChangeFileAccess-Methode

Ändert die Zugriffsberechtigungen zu der Arbeitsmappe. Dazu muss unter Umständen eine aktualisierte Version von der Festplatte bzw. Diskette geöffnet werden.

Syntax

Ausdruck.ChangeFileAccess(Mode, WritePassword, Notify)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Mode Variant optional. Gibt den neuen Zugriffsmodus an. Kann eine der folgenden XlFileAccess-Konstanten sein: xlReadWrite oder xlReadOnly.

WritePassword Variant optional. Gibt das Schreibschutzkennwort an, wenn die Datei schreibgeschützt ist und Mode den Wert xlReadWrite hat. Dieses Argument wird ignoriert, wenn für die Datei kein Kennwort existiert oder wenn Mode den Wert xlReadOnly hat.

Notify Variant optional. True (oder keine Angabe), um den Benutzer zu benachrichtigen, falls auf die Datei nicht sofort zugegriffen werden kann.

Anmerkungen

Wenn Sie eine Datei schreibgeschützt geöffnet haben, besitzen Sie keinen exklusiven Zugriff auf die Datei. Wenn Sie eine Datei von schreibgeschützt auf Schreib-Lese-Zugriff umstellen, muss Microsoft Excel eine neue Kopie der Datei laden. Dadurch wird sichergestellt, dass keine Änderungen durchgeführt wurden, so lange Sie die Datei schreibgeschützt geöffnet hatten.


Beispiel zur ChangeFileAccess-Methode

In diesem Beispiel wird für die aktive Arbeitsmappe ein Schreibschutz festgelegt.

ActiveWorkbook.ChangeFileAccess Mode:=xlReadOnly


ChangeLink-Methode

Ändert eine Verknüpfung von einem Dokument zu einem anderen Dokument.

Syntax

Ausdruck.ChangeLink(Name, NewName, Type)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Name String erforderlich. Der Name der zu ändernden Microsoft Excel- oder DDE/OLE-Verknüpfung, wie er von der LinkSources-Methode zurückgegeben wird.

NewName String erforderlich. Der neue Name der Verknüpfung.

Type Variant optional. Der Verknüpfungstyp. Kann eine der folgenden XlLinkType-Konstanten sein: xlLinkTypeExcelLinks oder xlLinkTypeOLELinks. Der Standardwert ist xlLinkTypeExcelLinks. Verwenden Sie xlLinkTypeOLELinks sowohl für DDE- als auch für OLE-Verknüpfungen.


Beispiel zur ChangeLink-Methode

In diesem Beispiel wird eine Microsoft Excel-Verknüpfung geändert.

ActiveWorkbook.ChangeLink "c:\excel\book1.xls", _
    "c:\excel\book2.xls", xlExcelLinks


ChangeScenario-Methode

Ändert das Szenario, so dass eine neue Gruppe von veränderbaren Zellen und (optional) Szenariowerten verwendet wird.

Syntax

Ausdruck.ChangeScenario(ChangingCells, Values)

Ausdruck Erforderlich. Ein Ausdruck, der ein Scenario-Objekt zurückgibt.

ChangingCells Variant erforderlich. Ein Range-Objekt, das die neuen veränderbaren Zellen für das Szenario festlegt. Die veränderbaren Zellen müssen sich im gleichen Tabellenblatt wie das Szenario befinden.

Values Variant optional. Eine Matrix, die die neuen Szenariowerte für die veränderbaren Zellen enthält. Wenn Sie dieses Argument weglassen, werden die aktuellen Szenariowerte in den veränderbaren Zellen verwendet.

Anmerkungen

Wenn Sie das Argument Values angeben, muss die Matrix für jede Zelle im Bereich ChangingCells ein Element enthalten, oder Microsoft Excel ruft eine Fehlermeldung hervor.


Beispiel zur ChangeScenario-Methode

Für Szenario eins wird in diesem Beispiel der Bereich A1:A10 in Sheet1 als Bereich der veränderbaren Zellen festgelegt.

Worksheets("Sheet1").Scenarios(1).ChangeScenario _
    Worksheets("Sheet1").Range("A1:A10")


Characters-Methode

Gibt ein Characters-Objekt zurück, das einen Bereich von Zeichen innerhalb des Textrahmens einer Form darstellt. Sie können mit dem Characters-Objekt Zeichen innerhalb des Textrahmens hinzufügen und formatieren.

Syntax

Ausdruck.Characters(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein Characters-Objekt in dem angegebenen Textrahmen zurückgibt.

Start Variant optional. Das erste zurückgegebene Zeichen. Wird dieses Argument auf 1 festgelegt oder ausgelassen, gibt die Characters-Methode einen Bereich von Zeichen zurück, der mit dem ersten Zeichen beginnt.

Length Variant optional. Die Anzahl der zurückgegebenen Zeichen. Wird dieses Argument ausgelassen, gibt die Characters-Methode den Rest der Zeichenfolge zurück (alles hinter dem Zeichen, das mit dem Start-Argument festgelegt wurde).

Anmerkungen

Das Characters-Objekt ist keine Auflistung.


Beispiel zur Characters-Methode

In diesem Beispiel wird das dritte Zeichen im Textrahmen der ersten Form im aktiven Tabellenblatt fett formatiert.

With ActiveSheet.Shapes(1).TextFrame
    .Characters.Text = "abcdefg"
    .Characters(3, 1).Font.Bold = True
End With


ChartGroups-Methode

Gibt ein Objekt zurück, das eine einzelne Diagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung aller Diagrammgruppen eines Diagramms (ein ChartGroups-Objekt, Syntax 2) darstellt. In der zurückgegebenen Auflistungsart sind alle Gruppenarten enthalten.

Syntax 1

Ausdruck.ChartGroups(Index)

Syntax 2

Ausdruck.ChartGroups

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Index Erforderlich für Syntax 1. Die Nummer der Diagrammgruppe.


Beispiel zur ChartGroups-Methode

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe in Chart1 eingeblendet. Danach werden den Balken entsprechende Farben zugewiesen. Wenden Sie dieses Makro auf ein 2D-Liniendiagramm an, das zwei Datenreihen beinhaltet, die sich in wenigstens einem Datenpunkt schneiden.

With Charts("Chart1").ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


ChartObjects-Methode

Gibt ein Objekt zurück, das ein einzelnes eingebettetes Diagramm (ein ChartObject-Objekt, Syntax 1) oder eine Auflistung aller eingebetteten Diagramme (ein ChartObjects-Objekt, Syntax 2) des Blattes darstellt.

Syntax 1

Ausdruck.ChartObjects(Index)

Syntax 2

Ausdruck.ChartObjects

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Eine Liste dieser Objekte erhalten Sie, wenn Sie auf Betrifft klicken. Wenn Sie ein Chart-Objekt angeben, muss es sich um ein Diagrammblatt handeln (kein eingebettetes Diagramm).

Index optional Variant. Der Name oder die Nummer des Diagramms. Dieses Argument kann eine Matrix sein, in der Sie mehrere Diagramme angeben können.

Anmerkungen

Diese Methode hat nicht die gleiche Wirkung wie die Charts-Eigenschaft. Diese Methode gibt eingebettete Diagramme; die Charts-Eigenschaft hingegen Diagrammblätter zurück. Mit der Chart-Eigenschaft geben Sie das Chart-Objekt für ein eingebettetes Diagramm zurück.


Beispiel zur ChartObjects-Methode

In diesem Beispiel wird dem ersten eingebetteten Diagramm in Sheet1 ein Titel hinzugefügt.

With Worksheets("Sheet1").ChartObjects(1).Chart
    .HasTitle = True
    .ChartTitle.Text = "1995 Rainfall Totals by Month"
End With

In diesem Beispiel wird eine neue Datenreihe im ersten eingebetteten Diagramm in Sheet1 erstellt. Die Datenquelle für die neue Datenreihe ist der Bereich B1:B10 in Sheet1.

Worksheets("Sheet1").ChartObjects(1).Activate
ActiveChart.SeriesCollection.Add _
    source:=Worksheets("Sheet1").Range("B1:B10")

Im folgenden Beispiel wird die Formatierung des ersten eingebetteten Diagramms in Sheet1 gelöscht.

Worksheets("Sheet1").ChartObjects(1).Chart.ChartArea.ClearFormats


ChartWizard-Methode

Verändert die Eigenschaften für ein bestimmtes Diagramm. Ermöglicht die schnelle Formatierung eines Diagramms, ohne jede einzelne Eigenschaft festzulegen. Diese Methode ist nicht interaktiv und ändert nur die angegebenen Eigenschaften.

Syntax

Ausdruck.ChartWizard(Source, Gallery, Format, PlotBy, CategoryLabels, SeriesLabels, HasLegend, Title, CategoryTitle, ValueTitle, ExtraTitle)

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Source Variant optional. Der Bereich, der die Quelldaten für das neue Diagramm enthält. Wird dieses Argument nicht angegeben, bearbeitet Microsoft Excel das aktive Diagrammblatt oder das ausgewählte Diagramm des aktiven Tabellenblatts.

Gallery Variant optional. Der Diagrammtyp. Kann eine der folgenden XlChartType-Konstanten sein: xlArea, xlBar, xlColumn, xlLine, xlPie, xlRadar, xlXYScatter, xlCombination, xl3DArea, xl3DBar, xl3DColumn, xl3DLine, xl3DPie, xl3DSurface, xlDoughnut oder xlDefaultAutoFormat.

Format Variant optional. Gibt die Optionsnummer für die integrierten AutoFormate an. Die Nummer liegt je nach Diagrammtyp im Bereich von 1 bis 10. Wenn dieses Argument nicht angegeben ist, wählt Microsoft Excel basierend auf dem Diagrammtyp und der Datenquelle einen Standardwert.

PlotBy Variant optional. Gibt an, ob sich die Daten für die jeweiligen Datenreihen in Zeilen oder Spalten befinden. Kann eine der folgenden XlRowCol-Konstanten sein: xlRows oder xlColumns.

CategoryLabels Variant optional. Eine ganze Zahl, die die Anzahl der Zeilen oder Spalten innerhalb des Quellbereichs angibt, in denen Rubrikenbeschriftungen enthalten sind. Zulässige Werte liegen im Bereich von Null bis zu dem Wert, der um eins kleiner ist als die maximale Anzahl der entsprechenden Rubriken oder Reihen.

SeriesLabels Variant optional. Eine ganze Zahl, die die Anzahl der Zeilen oder Spalten innerhalb des Quellbereichs angibt, in denen Datenreihenbeschriftungen enthalten sind. Zulässige Werte liegen im Bereich von Null bis zu dem Wert, der um eins kleiner ist als die maximale Anzahl der entsprechenden Rubriken oder Reihen.

HasLegend Variant optional. Hat das Argument den Wert True, so wird eine Legende angezeigt.

Title Variant optional. Der Text für den Diagrammtitel.

CategoryTitle Variant optional. Der Text für die Rubrikenachse.

ValueTitle Variant optional. Der Text für die Größenachse.

ExtraTitle Variant optional. Der Text für die Reihenachse in 3D-Diagrammen bzw. Beschriftung der sekundären Größenachse in 2D-Diagrammen.

Anmerkungen

Wurde Source nicht angegeben und handelt sich bei der Auswahl um kein eingebettetes Diagramm auf einer aktiven Tabelle oder enthält das aktive Blatt kein Diagramm, kann die Methode nicht angewandt werden, und es tritt ein Fehler auf.


Beispiel zur ChartWizard-Methode

In diesem Beispiel wird Chart1 in ein Liniendiagramm umformatiert. Anschließend werden dem Diagramm eine Legende sowie Beschriftungen für Rubriken- und Größenachse hinzugefügt.

Charts("Chart1").ChartWizard _
    Gallery:=xlLine, _
    HasLegend:=True, CategoryTitle:="Year", ValueTitle:="Sales"


CheckSpelling-Methode

Syntax 1: Prüft die Rechtschreibung eines Objekts. Bei dieser Syntax wird kein Wert zurückgegeben, sondern Microsoft Excel zeigt das Dialogfeld Rechtschreibung an.

Syntax 2: Prüft die Rechtschreibung eines einzelnen Wortes. Gibt True zurück, wenn das Wort in einem der Wörterbücher gefunden wird. Gibt False zurück, wenn das Wort nicht gefunden wird.

Syntax 1

Ausdruck.CheckSpelling(CustomDictionary, IgnoreUppercase, AlwaysSuggest, SpellLang)

Syntax 2

Ausdruck.CheckSpelling(Word, CustomDictionary, IgnoreUppercase)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft. Mit dem Application-Objekt können Sie ein einzelnes Wort überprüfen (Syntax 2).

CustomDictionary Variant optional. Eine Zeichenfolge, die den Dateinamen des Benutzerwörterbuches angibt, in dem ein Wort gesucht werden soll, das nicht im Standardwörterbuch zu finden ist. Wird das Argument nicht angegeben, wird das momentan angegebene Wörterbuch verwendet.

IgnoreUppercase Variant optional. Falls der Wert True ist, ignoriert Microsoft Excel alle Wörter in Großbuchstaben. Ist der Wert False, prüft Microsoft Excel auch Wörter, die in Großbuchstaben geschrieben sind. Wird das Argument nicht angegeben, wird die aktuelle Einstellung verwendet.

AlwaysSuggest Variant optional. Falls der Wert True ist, zeigt Microsoft Excel eine Liste mit alternativen Schreibweisen an, wenn ein falsch geschriebenes Wort gefunden wird. Ist der Wert False, wartet Microsoft Excel auf die Eingabe des richtig geschriebenen Wortes. Wird das Argument nicht angegeben, wird die aktuelle Einstellung verwendet.

Word String erforderlich (wird nur in Kombination mit dem Application-Objekt verwendet). Das zu überprüfende Wort.

SpellLang Variant optional. Die Sprache des verwendeten Wörterbuchs. Kann einer der MsoLanguageID-Werte sein, die von der LanguageID-Eigenschaft verwendet werden.

Anmerkungen

Um Kopf- und Fußzeilen sowie Objekte auf einem Tabellenblatt zu überprüfen, verwenden Sie diese Methode bei einem Worksheet-Objekt.

Wenn Sie nur Zellen und Anmerkungen überprüfen wollen, verwenden Sie diese Methode bei dem von der Cells-Methode zurückgegebenen Objekt.


Beispiel zur CheckSpelling-Methode

In diesem Beispiel wird die Rechtschreibung in Sheet1 geprüft.

Worksheets("Sheet1").CheckSpelling


CircleInvalid-Methode

Kreist ungültige Einträge im Tabellenblatt ein.

Syntax

Ausdruck.CircleInvalid

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.


Beispiel zur CircleInvalid-Methode

In diesem Beispiel werden Kreise um ungültige Einträge auf Tabellenblatt 1 gezeichnet.

Worksheets(1).CircleInvalid


Clear-Methode

ChartArea-, Legend- oder Range-Objekte: Löscht das gesamte Objekt.

ActiveX-Listenfeld oder Kombinationsfeld: Entfernt alle Einträge aus der Liste.

Syntax

Ausdruck.Clear

Ausdruck Ein erforderlicher Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


ClearArrows-Methode

Entfernt die Spurpfeile auf dem Tabellenblatt, die vom Detektiv hinzugefügt wurden.

Syntax

Ausdruck.ClearArrows

Ausdruck Ein erforderlicher Ausdruck, der ein Worksheet-Objekt zurückgibt.


Beispiel zur ClearArrows-Methode

In diesem Beispiel werden Spurpfeile in Sheet1 gelöscht.

Worksheets("Sheet1").ClearArrows


ClearCircles-Methode

Löscht Kreise von ungültigen Einträgen auf dem Tabellenblatt.

Syntax

Ausdruck.ClearCircles

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Anmerkungen

Mit der CircleInvalid-Methode zeichnen Sie einen Kreis um Zellen mit ungültigen Daten.


Beispiel zur ClearCircles-Methode

In diesem Beispiel werden die Kreise um ungültige Einträge in Tabellenblatt 1 gelöscht.

Worksheets(1).ClearCircles


ClearComments-Methode

Löscht alle Zellkommentare aus dem angegebenen Bereich.

Syntax

Ausdruck.ClearComments

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur ClearComments-Methode

In diesem Beispiel werden alle Kommentare aus der Zelle E5 gelöscht.

Worksheets(1).Range("e5").ClearComments


ClearContents-Methode

Löscht die Formeln aus dem Bereich. Löscht die Daten aus einem Diagramm, jedoch nicht die Formatierung.

Syntax

Ausdruck.ClearContents

Ausdruck Ein erforderlicher Ausdruck, der ein Chart- oder Range-Objekt zurückgibt.


Beispiel zur ClearContents-Methode

In diesem Beispiel werden die Formeln im Bereich A1:G37 in Sheet1 gelöscht, die Formatierung bleibt jedoch erhalten.

Worksheets("Sheet1").Range("A1:G37").ClearContents

In diesem Beispiel werden die Daten in Chart1 gelöscht, während die Formatierung erhalten bleibt.

Charts("Chart1").ChartArea.ClearContents


ClearFormats-Methode

Löscht die Formatierung des Objekts.

Syntax

Ausdruck.ClearFormats

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


Beispiel zur ClearFormats-Methode

In diesem Beispiel werden alle Formatierungen im Bereich A1:G37 in Sheet1 gelöscht.

Worksheets("Sheet1").Range("A1:G37").ClearFormats

Dieses Beispiel löscht die Formatierung des ersten eingebetteten Diagramms in Sheet1.

Worksheets("Sheet1").ChartObjects(1).Chart.ChartArea.ClearFormats


ClearNotes-Methode

Löscht Notizen und Audio-Notizen aus allen Zellen des angegebenen Bereichs.

Syntax

Ausdruck.ClearNotes

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur ClearNotes-Methode

In diesem Beispiel werden alle Notizen und Audio-Notizen in den Spalten A bis C in Sheet1 gelöscht.

Worksheets("Sheet1").Columns("A:C").ClearNotes


ClearOutline-Methode

Entfernt die Gliederung für den angegebenen Bereich.

Syntax

Ausdruck.ClearOutline

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur ClearOutline-Methode

In diesem Beispiel wird die Gliederung für den Bereich A1:G37 in Sheet1 entfernt.

Worksheets("Sheet1").Range("A1:G37").ClearOutline


Close-Methode

Schließt das Objekt. Für die Workbooks-Auflistung wird Syntax 1 verwendet. Für die Objekte Window und Workbook wird Syntax 2 verwendet.

Syntax 1

Ausdruck.Close

Syntax 2

Ausdruck.Close(SaveChanges, FileName, RouteWorkbook)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

SaveChanges Variant optional. Wenn die Arbeitsmappe im Fenster nicht geändert wurde, wird dieses Argument ignoriert. Wurden in der Arbeitsmappe Änderungen vorgenommen und erscheint diese Arbeitsmappe in weiteren geöffneten Fenstern, wird dieses Argument ebenfalls ignoriert. Wurden in der Arbeitsmappe Änderungen vorgenommen und erscheint diese Arbeitsmappe nicht in weiteren geöffneten Fenstern, gibt dieses Argument entsprechend der folgenden Liste an, ob die Änderungen gespeichert werden sollen:

Wert | Vorgang
True | Speichert die Änderungen in der Arbeitsmappe. Wurde der Arbeitsmappe noch kein Dateiname zugeordnet, wird FileName verwendet. Wenn FileName nicht angegeben ist, wird der/die Benutzer/in zur Eingabe eines Dateinamens aufgefordert.
False | Speichert die Änderungen in der Datei nicht.
Keine Angabe | Zeigt ein Dialogfeld an, in dem der/die Benutzer/in gefragt wird, ob er die Änderungen speichern möchte oder nicht.

FileName Variant optional. Gibt den Dateinamen an, unter dem die Änderungen gespeichert werden sollen.

RouteWorkbook Variant optional. Wenn die Arbeitsmappe nicht an den nächsten Empfänger weiterzuleiten ist (weil sie keinen Verteiler hat bzw. schon weitergeleitet wurde), wird dieses Argument ignoriert. Andernfalls leitet Microsoft Excel die Arbeitsmappe entsprechend der folgenden Liste weiter:

Wert | Bedeutung
True | Leitet die Arbeitsmappe an den nächsten Empfänger weiter.
False | Leitet die Arbeitsmappe nicht weiter.
Keine Angabe | Zeigt ein Dialogfeld an, in dem der/die Benutzer/in gefragt wird, ob die Arbeitsmappe weitergeleitet werden soll.

Anmerkungen

Wird eine Arbeitsmappe aus Visual Basic heraus geschlossen, werden keine Auto_schließen-Makros in der Arbeitsmappe ausgeführt. Verwenden Sie hierzu die RunAutoMacros-Methode.


Beispiel zur Close-Methode

In diesem Beispiel wird BOOK1.XLS geschlossen. Alle Änderungen werden verworfen.

Workbooks("BOOK1.XLS").Close SaveChanges:=False

In diesem Beispiel werden alle geöffneten Arbeitsmappen geschlossen. Wurden an einer Arbeitsmappe Änderungen vorgenommen, fordert Microsoft Excel den/die Benutzer/in durch Anzeigen der entsprechenden Eingabeaufforderungen und Dialogfelder zum Speichern der Änderungen auf.

Workbooks.Close


ColumnDifferences-Methode

Gibt ein Range-Objekt zurück, das alle Zellen darstellt, deren Inhalt sich von der Vergleichszelle in jeder Spalte unterscheidet.

Syntax

Ausdruck.ColumnDifferences(Comparison)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt mit den zu vergleichenden Zellen zurückgibt.

Comparison Variant erforderlich. Die Zelle, die mit dem angegebenen Bereich zu vergleichen ist.


Beispiel zur ColumnDifferences-Methode

In diesem Beispiel werden diejenigen Zellen in Spalte A in Sheet1 markiert, deren Inhalt sich von Zelle A4 unterscheidet.

Worksheets("Sheet1").Activate
Set r1 = ActiveSheet.Columns("A").ColumnDifferences( _
    Comparison:=ActiveSheet.Range("A4"))
r1.Select


ColumnGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Säulendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Säulendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.ColumnGroups(Index)

Syntax 2

Ausdruck.ColumnGroups

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur ColumnGroups-Methode

In diesem Beispiel wird der Abstand zwischen den Säulengruppen in der 2D-Säulendiagrammgruppe auf 50 Prozent der Spaltenbreite festgelegt.

Charts(1).ColumnGroups(1).GapWidth = 50


Consolidate-Methode

Konsolidiert Daten aus mehreren Bereichen verschiedener Tabellen zu einem einzigen Bereich in einem einzelnen Tabellenblatt.

Syntax

Ausdruck.Consolidate(Sources, Function, TopRow, LeftColumn, CreateLinks)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Sources Variant optional. Gibt die Quellen der Konsolidierung als eine Matrix von Textbezügen als Zeichenfolge in der Schreibweise Z1S1 an. Die Bezüge müssen den vollständigen Pfad der zu konsolidierenden Blätter enthalten.

Function Variant optional. Die Funktion, mit der die Konsolidierung ausgeführt werden soll. Zulässig ist eine der folgenden XlConsolidationFunction-Konstanten: xlAverage, xlCount, xlCountNums, xlMax, xlMin, xlProduct, xlStDev, xlStDevP, xlSum, xlVar oder xlVarP. Der Standardwert ist xlAverage.

TopRow Variant optional. True, wenn die Konsolidierung der Daten auf der Grundlage der Spaltenüberschriften in der ersten Zeile der Konsolidierungsbereiche durchgeführt wird. False, wenn die Daten nach der Position konsolidiert werden. Der Standardwert ist False.

LeftColumn Variant optional. True, wenn die Konsolidierung der Daten auf der Grundlage der Zeilenüberschriften in der linken Spalte der Konsolidierungsbereiche durchgeführt wird. False, wenn die Daten nach der Position konsolidiert werden. Der Standardwert ist False.

CreateLinks Variant optional. True, wenn die Konsolidierung Tabellenblattverknüpfungen verwendet. False, wenn die Konsolidierung die Daten kopiert. Der Standardwert ist False.


Beispiel zur Consolidate-Methode

In diesem Beispiel werden die Daten aus Sheet2 und Sheet3 in Sheet1 mit der Funktion SUM konsolidiert.

Worksheets("Sheet1").Range("A1").Consolidate _
    Sources:=Array("Sheet2!R1C1:R37C6", "Sheet3!R1C1:R37C6"), _
    Function:=xlSum


ConvertFormula-Methode

Diese Methode konvertiert Zellbezüge in Formeln zwischen den Bezugsarten A1 und Z1S1, zwischen relativen und absoluten Bezügen, oder beides.

Syntax

Ausdruck.ConvertFormula(Formula, FromReferenceStyle, ToReferenceStyle, ToAbsolute, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Formula Variant erforderlich. Eine Zeichenfolge, welche die zu konvertierende Formel enthält. Es muss eine gültige Formel sein, die mit einem Gleichheitszeichen beginnt.

FromReferenceStyle Long erforderlich. Die Bezugsart der Formel. Zulässig ist eine der folgenden XLReferenceStyle-Konstanten: xlA1 oder xlR1C1.

ToReferenceStyle Variant erforderlich. Die gewünschte Bezugsart für die Formel. Zulässig ist eine der folgenden XLReferenceStyle-Konstanten: xlA1 oder xlR1C1. Wird dieses Argument ausgelassen, so wird die Bezugsart nicht geändert, d. h., die Formel bleibt in der durch FromReferenceStyle angegebenen Bezugsart.

ToAbsolute Variant optional. Legt die konvertierte Bezugsart fest. Zulässig ist eine der folgenden XLReferenceType-Konstanten: xlAbsolute, xlAbsRowRelColumn, xlRelRowAbsColumn oder xlRelative. Ohne Angabe dieses Arguments bleibt die Bezugsart unverändert.

RelativeTo Variant optional. Ein Range-Objekt, das eine Zelle enthält. Relative Bezüge verweisen auf diese Zelle.


Beispiel zur ConvertFormula-Methode

In diesem Beispiel wird die Formel SUM mit Z1S1-Bezügen in eine gleichbedeutende Formel mit A1-Bezügen umgewandelt. Anschließend wird das Ergebnis angezeigt.

inputFormula = "=SUM(R10C2:R15C2)"
MsgBox Application.ConvertFormula( _
    formula:=inputFormula, _
    fromReferenceStyle:=xlR1C1, _
    toReferenceStyle:=xlA1)


ConvertToShape-Methode

Erstellt eine Form, die die geometrischen Eigenschaften des angegebenen FreeformBuilder-Objekts besitzt. Gibt ein Shape-Objekt zurück, das die neue Form darstellt.

Anmerkung Sie müssen die AddNodes-Methode mindestens einmal auf ein FreeformBuilder-Objekt anwenden, bevor Sie die ConvertToShape-Methode verwenden.

Syntax

Ausdruck.ConvertToShape

Ausdruck Erforderlich. Ein Ausdruck, der ein FreeformBuilder-Objekt zurückgibt.


Beispiel zur ConvertToShape-Methode

In diesem Beispiel wird ein Freihandobjekt mit fünf Scheitelpunkten in myDocument eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Copy-Methode

Syntax 1: Kopiert das Objekt in die Zwischenablage. Kopiert ein Bild des Datenpunktes oder der Datenreihe in die Zwischenablage.

Syntax 2: Kopiert das Range-Objekt in den angegebenen Bereich oder in die Zwischenablage.

Syntax 3: Kopiert die Tabelle an eine andere Position in der Arbeitsmappe.

Syntax 1

Ausdruck.Copy

Syntax 2

Ausdruck.Copy(Destination)

Syntax 3

Ausdruck.Copy(Before, After)

Ausdruck Ein erforderlicher Ausdruck, der ein Objekt zurückgibt, auf das diese Methode angewendet werden soll. Mit Syntax 3 wird ein Chart-Objekt kopiert, und zwar das gesamte Diagrammblatt. Verwenden Sie Syntax 1 mit dem ChartArea-Objekt, um nur den Diagrammbereich zu kopieren.

Destination Variant optional. Gibt den neuen Bereich an, in den der angegebene Bereich hineinkopiert wird. Wenn dieses Argument ausgelassen wird, kopiert Microsoft Excel den Bereich in die Zwischenablage.

Before Syntax 3: Variant optional. Das Blatt, vor das dieses Blatt kopiert wird. Sie können Before nicht angeben, wenn Sie After angegeben haben.

After Optional Variant. Das Blatt, hinter das dieses Blatt kopiert wird. Sie können After nicht angeben, wenn Sie Before angegeben haben.

Anmerkungen

Wenn Sie weder Before noch After angeben, erstellt Microsoft Excel eine neue Arbeitsmappe, die das kopierte Blatt enthält.


CopyFromRecordset-Methode

Kopiert den Inhalt eines ADO- oder DAO-Recordset-Objekts in ein Tabellenblatt, wobei an der linken oberen Ecke des angegebenen Bereichs begonnen wird. Enthält das Recordset-Objekt Felder mit OLE-Objekten, schlägt diese Methode fehl.

Syntax

Ausdruck.CopyFromRecordset(Data, MaxRows, MaxColumns)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Data Void erforderlich. Das Recordset-Objekt, das in den Bereich kopiert werden soll.

MaxRows Variant optional. Die maximale Anzahl der Datensätze, die in das Tabellenblatt kopiert werden sollen. Ohne Angabe werden alle Datensätze im Recordset-Objekt kopiert.

MaxColumns Variant optional. Die maximale Anzahl Felder, die in das Tabellenblatt kopiert werden sollen. Ohne Angabe werden alle Felder im Recordset-Objekt kopiert.

Anmerkungen

Das Kopieren beginnt mit der aktuellen Zeile des Recordset-Objekts. Nach dem Kopieren hat die EOF-Eigenschaft des Recordset-Objekts den Wert True.


Beispiel zur CopyFromRecordset-Methode

In diesem Beispiel werden die Feldnamen von einem DAO-Recordset-Objekts in die erste Zeile eines Tabellenblatts kopiert und fett formatiert. Anschließend wird in diesem Beispiel der Datensatz in das Tabellenblatt kopiert, beginnend in Zelle A2.

For iCols = 0 to rs.Fields.Count - 1
    ws.Cells(1, iCols + 1).Value = rs.Fields(iCols).Name
Next
ws.Range(ws.Cells(1, 1),  _
    ws.Cells(1, rs.Fields.Count)).Font.Bold = True
ws.Range("A2").CopyFromRecordset rs


CopyPicture-Methode

Kopiert das markierte Objekt als Bild in die Zwischenablage.

Syntax

Ausdruck.CopyPicture(Appearance, Format, Size)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Appearance Variant optional. Gibt an, wie die Grafik kopiert werden soll. Zulässig sind die XlPictureAppearance-Konstanten xlScreen und xlPrinter. Ist das Argument xlScreen, so wird die Grafik entsprechend der Bildschirmanzeige bestmöglich kopiert. Hat das Argument den Wert xlPrinter, so wird die Grafik kopiert, wie sie im Druck erscheint. Der Standardwert ist xlScreen.

Format Variant optional. Gibt das Grafikformat an. Zulässig sind die XlCopyPictureFormat-Konstanten xlPicture und xlBitmap. Der Standardwert ist xlPicture.

Size Variant optional. Wird nur mit Chart-Objekten verwendet. Gibt die Größe der kopierten Grafik an, wenn das Objekt ein Diagramm ist, das sich auf einem Diagrammblatt befindet und nicht in einem Tabellenblatt eingebettet ist. Zulässig sind die XlPictureAppearance-Konstanten xlScreen oder xlPrinter. Wenn xlScreen angegeben wird, so wird die Grafik entsprechend der Größe der Bildschirmanzeige bestmöglich kopiert. Wenn hingegen xlPrinter angegeben wird, so wird die Grafik bezüglich der Größe bestmöglich kopiert, wie sie im Druck erscheint. Der Standardwert ist xlPrinter.

Anmerkungen

Ein zu kopierender Bereich muss aus aneinandergrenzenden Zellen bestehen.


Beispiel zur CopyPicture-Methode

In diesem Beispiel wird die Bildschirmdarstellung des Bereichs A1:D4 in Sheet1 als Bitmap in die Zwischenablage kopiert und anschließend an anderer Stelle in Sheet1 eingefügt.

Worksheets("Sheet1").Range("A1:D4").CopyPicture xlScreen, xlBitmap
Worksheets("Sheet1").Paste _
    Destination:=Worksheets("Sheet1").Range("E6")


CreateNames-Methode

Diese Methode übernimmt Beschriftungen des Tabellenblattes als Namen für den angegebenen Bereich.

Syntax

Ausdruck.CreateNames(Top, Left, Bottom, Right)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Top Variant optional. True, wenn die Namen aufgrund der Beschriftungen in der obersten Zeile erstellt werden. Der Standardwert ist False.

Left Variant optional. True, wenn die Namen aufgrund der Beschriftungen in der linken Spalte erstellt werden. Der Standardwert ist False.

Bottom Variant optional. True, wenn die Namen aufgrund der Beschriftungen in der untersten Zeile erstellt werden. Der Standardwert ist False.

Right Variant optional. True, wenn die Namen aufgrund der Beschriftungen in der rechten Spalte erstellt werden. Der Standardwert ist False.

Anmerkungen

Wenn Sie Top, Left, Bottom oder Right nicht angeben, sucht Microsoft Excel, je nach Form des angegebenen Bereichs, die nächstliegende Position von Beschriftungen.


Beispiel zur CreateNames-Methode

In diesem Beispiel werden Namen für die Zellen B1:B3 festgelegt, wobei der Text in den Zellen A1:A3 als Grundlage dient. Es ist notwendig, die Zellen, die die Namen enthalten, in den Bereich einzuschließen, obwohl die Namen nur für die Zellen B1:B3 erstellt werden.

Set rangeToName = Worksheets("Sheet1").Range("A1:B3")
rangeToName.CreateNames Left:=True


CreateNewDocument-Methode

Erstellt ein neues Dokument, das mit dem angegebenen Hyperlink verknüpft ist.

Syntax

Ausdruck.CreateNewDocument(Filename, EditNow, Overwrite)

Ausdruck Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

Filename String erforderlich. Der Dateiname des angegebenen Dokuments.

EditNow Boolean erforderlich. True, damit das angegebene Dokument sofort in der dazugehörigen Editierumgebung geöffnet wird. Der Standardwert ist True.

Overwrite Boolean erforderlich. True, damit jede vorhandene gleichnamige Datei in demselben Ordner überschrieben wird. False, damit eine vorhandene gleichnamige Datei erhalten bleibt, wobei das Filename-Argument den neuen Dateinamen angibt. Der Standardwert ist False.


Beispiel zur CreateNewDocument-Methode

In diesem Beispiel wird ein neues Dokument erstellt, das auf dem neuen Hyperlink im ersten Tabellenblatt basiert, und dann wird das Dokument anschließend in Microsoft Excel zur Bearbeitung geladen. Das Dokument heißt Report.xls und überschreibt jede gleichnamige Datei im Ordner \\Server1\Annual.

With Worksheets(1)
    Set objHyper = _
        .Hyperlinks.Add(Anchor:=.Range("A10"), _
            Address:="\\Server1\Annual\Report.xls")
    objHyper.CreateNewDocument _
        FileName:="\\Server1\Annual\Report.xls", _
        EditNow:=True, Overwrite:=True
End With


CreatePivotTable-Methode

Erstellt einen PivotTable-Bericht, der auf einem PivotCache-Objekt basiert. Gibt ein PivotTable-Objekt zurück.

Syntax

Ausdruck.CreatePivotTable(TableDestination, TableName, ReadData)

Ausdruck Ein Ausdruck, der ein PivotCaches-Objekt zurückgibt.

TableDestination Variant erforderlich. Die Zelle in der oberen linken Ecke des Zielbereichs des PivotTable-Berichts (der Bereich im Tabellenblatt, in dem sich der resultierende PivotTable-Bericht befindet). Der Zielbereich muss sich in einem Tabellenblatt der Arbeitsmappe befinden, das das PivotCache-Objekt enthält, das durch Ausdruck angegeben wurde.

TableName Variant optional. Der Name des neuen PivotTable-Berichts.

ReadData Variant optional. True, damit ein PivotTable-Cache erstellt wird, der alle Datensätze aus der externen Datenbank enthält. Dieser Cache kann sehr groß sein. False, damit die Festlegung einiger Felder als serverbasierte Seitenfelder ermöglicht wird, bevor die eigentlichen Daten gelesen werden.

Anmerkungen

Eine alternative Möglichkeit, einen PivotTable-Bericht zu erstellen, der auf einem PivotTable-Cache basiert, finden Sie unter der Add-Methode des PivotTable-Objekts.


 Beispiel zur CreatePivotTable-Methode

Beispiel zur CreatePivotTable-Methode

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf dem Cache basiert.

With ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = True
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:= "PivotTable1"
End With
With ActiveSheet.PivotTables("PivotTable1")
    .SmallGrid = False
    .PivotCache.RefreshPeriod = 0
    With .CubeFields("[state]")
        .Orientation = xlColumnField
        .Position = 0
    End With
    With .CubeFields("[Measures].[Count Of au_id]")
        .Orientation = xlDataField
        .Position = 0
    End With
End With

In diesem Beispiel wird mit Hilfe einer ADO-Verbindung zu Microsoft Jet ein neuer PivotTable-Cache erstellt und dann in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht, der auf dem Cache basiert.

Dim cnnConn As ADODB.Connection
Dim rstRecordset As ADODB.Recordset
Dim cmdCommand As ADODB.Command

' Open the connection.
Set cnnConn = New ADODB.Connection
With cnnConn
    .ConnectionString = _
        "Provider=Microsoft.Jet.OLEDB.4.0"
    .Open "C:\perfdate\record.mdb"
End With

' Set the command text.
Set cmdCommand = New ADODB.Command
Set cmdCommand.ActiveConnection = cnnConn
With cmdCommand
    .CommandText = "Select Speed, Pressure, Time From DynoRun"
    .CommandType = adCmdText
    .Execute
End With

' Open the recordset.
Set rstRecordset = New ADODB.Recordset
Set rstRecordset.ActiveConnection = cnnConn
rstRecordset.Open cmdCommand

' Create a PivotTable cache and report.
Set objPivotCache = ActiveWorkbook.PivotCaches.Add( _
    SourceType:=xlExternal)
Set objPivotCache.Recordset = rstRecordset
With objPivotCache
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:="Performance"
End With

With ActiveSheet.PivotTables("Performance")
    .SmallGrid = False
    With .PivotFields("Pressure")
        .Orientation = xlRowField
        .Position = 1
    End With
    With .PivotFields("Speed")
        .Orientation = xlColumnField
        .Position = 1
    End With
    With .PivotFields("Time")
        .Orientation = xlDataField
        .Position = 1
    End With
End With

' Close the connections and clean up.
cnnConn.Close
Set cmdCommand = Nothing
Set rstRecordSet = Nothing
Set cnnConn = Nothing


CreateSummary-Methode

Erstellt ein neues Tabellenblatt mit einem zusammenfassenden Bericht der Szenarios im angegebenen Tabellenblatt.

Syntax

Ausdruck.CreateSummary(ReportType, ResultCells)

Ausdruck Erforderlich. Ein Ausdruck, der eine Scenarios-Auflistung zurückgibt.

ReportType Variant optional. Gibt den Berichtstyp an. Zulässig sind die XlSummaryReportType-Konstanten xlStandardSummary oder xlSummaryPivotTable.Der Standardwert ist xlStandardSummary.

ResultCells Variant optional. Ein Range-Objekt, das die Ergebniszellen im angegebenen Tabellenblatt enthält. Normalerweise bezieht sich dieser Bereich auf eine oder mehrere Zellen mit Formeln, die von den Werten der veränderbaren Zellen Ihres Modells abhängen, d. h. den Zellen, die die Ergebnisse eines bestimmten Szenarios enthalten. Ohne Angabe dieses Arguments werden keine Ergebniszellen in den Bericht aufgenommen.


Beispiel zur CreateSummary-Methode

In diesem Beispiel wird ein Übersichtsbericht der Szenarios in Sheet1 erstellt, wobei sich die Ergebniszellen im Bereich C4:C9 in Sheet1 befinden.

Worksheets("Sheet1").Scenarios.CreateSummary _
    ResultCells := Worksheets("Sheet1").Range("C4:C9")


CustomDrop-Methode

Legt den vertikalen Abstand (in Punkt) zwischen dem Rand des Begrenzungsrechtecks des Textes und dem Punkt fest, an dem die Legendenlinie dem Textfeld zugeordnet ist. Der Abstand wird vom oberen Rand des Textfeldes gemessen, solange die AutoAttach-Eigenschaft nicht den Wert True besitzt und das Textfeld links vom Ursprung der Legendenlinie (dem Punkt, auf den die Legendenlinie zeigt) liegt. In diesem Fall wird der Ansatzabstand vom unteren Rand des Textfeldes aus gemessen.

Syntax

Ausdruck.CustomDrop(Drop)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Drop Single erforderlich. Der Ansatzabstand in Punkt.


Beispiel zur CustomDrop-Methode

In diesem Beispiel wird festgelegt, dass der benutzerdefinierte Ansatzabstand 14 Punkt beträgt und immer vom oberen Rand aus gemessen wird. Damit dieses Beispiel funktioniert, muss es sich bei der dritten Form um eine Legende handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Callout
    .CustomDrop 14
    .AutoAttach = False
End With


CustomLength-Methode

Legt fest, dass der erste Abschnitt der Legendenlinie (der Abschnitt, der dem Textfeld der Legende zugeordnet ist) eine feste Länge beibehält, wenn die Legende verschoben wird. Mit Hilfe der AutomaticLength-Methode legen Sie fest, dass der erste Abschnitt der Legendenlinie bei jedem Verschieben der Legende automatisch skaliert wird. Betrifft nur Legenden, deren Linien aus mehreren Abschnitten bestehen (Legenden des Typs msoCalloutThree und msoCalloutFour).

Syntax

Ausdruck.CustomLength(Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

Length Single erforderlich. Die Länge (in Punkt) des ersten Abschnitts der Legende.

Anmerkungen

Durch Anwenden dieser Methode wird die AutoLength-Eigenschaft auf den Wert False und die Length-Eigenschaft auf den Wert gesetzt, der für das Argument Length angegeben wurde.


Beispiel zur CustomLength-Methode

In diesem Beispiel wird zwischen automatischer Skalierung des ersten Abschnitts und Skalierung mit fester Länge der Legendenlinie in der ersten Form von myDocument umgeschaltet. Das Beispiel funktioniert nur, wenn es sich bei der Form um eine Legende handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


Cut-Methode

Schneidet das Objekt aus, legt es in die Zwischenablage oder fügt es an einer angegebenen Stelle ein.

Syntax

Ausdruck.Cut(Destination)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Destination Variant optional. Wird nur in Kombination mit Range-Objekten verwendet. Gibt den Bereich an, in den das Objekt eingefügt werden soll. Wird dieses Argument nicht angegeben, so wird das ausgeschnittene Objekt in der Zwischenablage abgelegt.

Anmerkungen

Der ausgeschnittene Bereich muss aus angrenzenden Zellen bestehen.

Nur eingebettete Diagramme können ausgeschnitten werden.


Beispiel zur Cut-Methode

In diesem Beispiel wird der Bereich A1:G37 in Sheet1 ausgeschnitten und in der Zwischenablage abgelegt.

Worksheets("Sheet1").Range("A1:G37").Cut


DataLabels-Methode

Gibt ein Objekt zurück, das eine einzelne Datenbeschriftung (ein DataLabel-Objekt, Syntax 1) oder eine Auflistung aller Datenbeschriftungen der Datenreihe (eine DataLabels-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.DataLabels(Index)

Syntax 2

Ausdruck.DataLabels

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Index Variant optional. Die Nummer der Datenbeschriftung.

Anmerkungen

Wenn die Option Werte anzeigen für die Datenreihe eingeschaltet ist, kann die zurückgegebene Auflistung nur maximal eine Datenbeschriftung je Punkt erhalten. Die Datenbeschriftungen können für einzelne Punkte der Datenreihe ein- oder ausgeschaltet werden.

Wenn sich die Datenreihe auf einem Flächendiagramm befindet und die Option Beschriftung anzeigen eingeschaltet ist, enthält die zurückgegebene Auflistung nur eine einzige Beschriftung, und zwar die Beschriftung für die Flächendatenreihe.


Beispiel zur DataLabels-Methode

In diesem Beispiel werden die Datenbeschriftungen für die erste Datenreihe in Chart1 so festgelegt, dass das Legendensymbol angezeigt wird. Es wird vorausgesetzt, dass die Werte bei der Ausführung des Makros eingeblendet sind.

With Charts("Chart1").SeriesCollection(1)
    .HasDataLabels = True
    With .DataLabels
        .ShowLegendKey = True
        .Type = xlValue
    End With
End With


DataSeries-Methode

Erstellt im angegebenen Bereich eine Datenreihe.

Syntax

Ausdruck.DataSeries(Rowcol, Type, Date, Step, Stop, Trend)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Rowcol Variant optional. Zulässig ist die xlRows- oder xlColumns-Konstante, um die Datenreihen in Zeilen bzw. Spalten einzugeben. Ohne Angabe dieses Arguments wird die Größe und Form des Bereichs verwendet.

Type Variant optional. Zulässig ist eine der folgenden XlDataSeriesType-Konstanten: xlDataSeriesLinear, xlGrowth, xlChronological oder xlAutoFill. Der Standardwert ist xlDataSeriesLinear.

Date Variant optional. Wurde für das Type-Argument der Wert xlChronological angegeben, so bezeichnet das Date-Argument die Einheit, in der Datumsangaben fortgesetzt werden. Zulässig ist eine der folgenden XlDataSeriesDate-Konstanten: xlDay, xlWeekday, xlMonth oder xlYear. Der Standardwert ist xlDay.

Step Variant optional. Das Inkrement (die Schrittweite) für die Reihe. Der Standardwert ist 1.

Stop Variant optional. Der Endwert der Reihe. Wird kein Endwert angegeben, so füllt die Methode den Bereich bis zum Ende mit Daten auf.

Trend Variant optional. Wenn True, so erstellt die Methode eine Reihe mit einem linearen Trend oder einem Wachstums-Trend. Wenn False, erstellt die Methode eine Standard-Datenreihe. Der Standardwert ist False.


Beispiel zur DataSeries-Methode

In diesem Beispiel wird eine Datenreihe mit zwölf Datumsangaben erstellt. Die Reihe besteht aus dem letzten Tag jedes Monats des Jahres 1997 und wird im Bereich A1:A12 in Sheet1 erstellt.

Set dateRange = Worksheets("Sheet1").Range("A1:A12")
Worksheets("Sheet1").Range("A1").Formula = "31-JAN-1996"
dateRange.DataSeries Type:=xlChronological, Date:=xlMonth


DDEExecute-Methode

Dadurch wird über den angegebenen DDE-Kanal ein Befehl oder eine (bzw. mehrere) sonstige Aktion(en) in einer anderen Anwendung ausgeführt.

Syntax

Ausdruck.DDEExecute(Channel, String)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

String String erforderlich. Die Nachricht, die in der empfangenden Anwendung definiert wurde.

Anmerkungen

Die DDEExecute-Methode dient dazu, Befehle an eine andere Anwendung zu senden. Mit Hilfe dieser Methode lassen sich auch Tastenanschläge an die andere Anwendung senden, obwohl für diesen Zweck die SendKeys-Methode geeigneter ist. Das String-Argument kann jede einzelne Taste angeben, die mit ALT, STRG oder UMSCHALT sowie jeder Kombination dieser Tasten kombiniert wird. Jede Taste wird durch ein oder mehrere Zeichen repräsentiert, etwa "a" für das Zeichen a, oder "{ENTER}" für die EINGABETASTE.

Zur Angabe von Zeichen, die beim Drücken der entsprechenden Taste nicht angezeigt werden (z. B. EINGABE oder TAB), verwenden Sie die in der Tabelle unten angeführten Codes. Jeder Code in der Tabelle repräsentiert eine Taste auf Ihrer Tastatur.

Taste | Code
RÜCKTASTE | {RÜCKTASTE} oder {RÜCK}
UNTBR | {UNTBR}
FESTSTELLTASTE | {FEST}
CLEAR oder LÖSCHTASTE | {SÄUBERN}
LÖSCH oder ENTF | {ENTF} oder {LÖSCH}
NACH-UNTEN | {UNTEN}
ENDE | {ENDE}
EINGABETASTE (Zehnertastatur) | {EINGABE}
EINGABETASTE | ~ (Tilde)
ESC | {ESCAPE} oder {ESC}
HILFE | {HILFE}
POS1 | {POS1}
EINFG | {EINFG}
NACH LINKS | {LINKS}
NUM | {NUMFT}
BILD-AB | {BILDU}
BILD-AUF | {BILDO}
RETURNTASTE (Macintosh) | {EINGABE}
NACH RECHTS | {RECHTS}
ROLLEN | {ROLLEN}
TAB | {TAB}
NACH OBEN | {OBEN}
F1 bis F15 | {F1} bis {F15}

Sie können zudem Tasten angeben, die mit UMSCHALT und/oder STRG und/oder ALT kombiniert sind. Um eine Taste anzugeben, die mit einer oder mehreren der oben erwähnten Tasten kombiniert wird, verwenden Sie die folgende Tabelle.

Kombination mit | Vorangestelltes Zeichen
UMSCHALT | + (Pluszeichen)
STRG oder CTRL | ^ (Caret-Zeichen)
ALT | % (Prozentzeichen)


Beispiel zur DDEExecute-Methode

In diesem Beispiel wird ein Kanal zu Word geöffnet, dann wird das Word-Dokument Formletr.doc geöffnet und schließlich wird der Befehl FilePrint an WordBasic gesendet.

channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\FORMLETR.DOC")
Application.DDEExecute channelNumber, "[FILEPRINT]"
Application.DDETerminate channelNumber


DDEInitiate-Methode

Öffnet einen DDE-Kanal zu einer Anwendung.

Syntax

Ausdruck.DDEInitiate(App, Topic)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

App String erforderlich. Der Anwendungsname.

Topic String erforderlich. Beschreibt einen Bestandteil der Anwendung, zu der Sie einen Kanal öffnen - in der Regel ein Dokument dieser Anwendung.

Anmerkungen

Bei erfolgreichem Aufruf gibt die DDEInitiate-Methode die Nummer des geöffneten Kanals zurück. Alle nachfolgenden DDE-Funktionen verwenden diese Nummer, um diesen Kanal zu spezifizieren.


Beispiel zur DDEInitiate-Methode

In diesem Beispiel wird ein Kanal zu Word geöffnet, dann wird das Word-Dokument Formletr.doc geöffnet und schließlich wird der Befehl FilePrint an WordBasic gesendet.

channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\FORMLETR.DOC")
Application.DDEExecute channelNumber, "[FILEPRINT]"
Application.DDETerminate channelNumber


DDEPoke-Methode

Diese Methode sendet Daten an eine Anwendung.

Syntax

Ausdruck.DDEPoke(Channel, Item, Data)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

Item Variant erforderlich. Das Element, zu dem die Daten gesendet werden sollen.

Data Variant erforderlich. Die Daten, die an die Anwendung gesendet werden sollen.

Anmerkungen

Ist der Methodenaufruf nicht erfolgreich, tritt ein Fehler auf.


Beispiel zur DDEPoke-Methode

In diesem Beispiel wird ein Kanal zu Word geöffnet, dann das Word-Dokument Sales.doc, und schließlich wird der Inhalt der Zelle A1 (in Sheet1) am Anfang des Dokuments eingefügt.

channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\SALES.DOC")
Set rangeToPoke = Worksheets("Sheet1").Range("A1")
Application.DDEPoke channelNumber, "\StartOfDoc", rangeToPoke
Application.DDETerminate channelNumber


DDERequest-Methode

Mit dieser Methode können Sie Informationen von einer bestimmten Anwendung anfordern. Diese Methode gibt immer eine Matrix zurück; weitere Informationen erhalten Sie im Beispiel.

Syntax

Ausdruck.DDERequest(Channel, Item)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.

Item String erforderlich. Das Element, das angefordert wird.


Beispiel zur DDERequest-Methode

In diesem Beispiel wird ein Kanal zum Thema "System" in Word geöffnet, anschließend wird mit Hilfe des Elements "Topics" eine Liste aller geöffneten Dokumente ausgegeben. Die Liste wird in Spalte A von Sheet1 ausgegeben.

channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="System")
returnList = Application.DDERequest(channelNumber, "Topics")
For i = LBound(returnList) To UBound(returnList)
    Worksheets("Sheet1").Cells(i, 1).Formula = returnList(i)
Next i
Application.DDETerminate channelNumber


DDETerminate-Methode

Durch diese Methode wird ein Kanal zu einer anderen Anwendung geschlossen.

Syntax

Ausdruck.DDETerminate(Channel)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Channel Long erforderlich. Die Kanalnummer, die von der DDEInitiate-Methode zurückgegeben wird.


Beispiel zur DDETerminate-Methode

In diesem Beispiel wird ein Kanal zu Word geöffnet, dann wird das Word-Dokument Formletr.doc geöffnet und schließlich wird der Befehl FilePrint an WordBasic gesendet.

channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\FORMLETR.DOC")
Application.DDEExecute channelNumber, "[FILEPRINT]"
Application.DDETerminate channelNumber


Delete-Methode

Löscht das Objekt. Syntax 2 betrifft nur Range-Objekte.

Syntax 1

Ausdruck.Delete

Syntax 2

Ausdruck.Delete(Shift)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Shift Variant optional. Wird nur auf Range-Objekte angewendet. Gibt an, wie die umliegenden Zellen verschoben werden, um die gelöschten Zellen zu ersetzen. Zulässig ist eine der XlDeleteShiftDirection-Konstanten xlShiftToLeft oder xlShiftUp. Wenn dieses Argument ausgelassen wird, wählt Microsoft Excel einen Wert, der von der Form des ausgewählten Bereichs abhängt.

Anmerkungen

Durch Löschen eines Point- oder LegendKey-Objekts wird die gesamte Datenreihe gelöscht.

Sie können benutzerdefinierte Dokumenteigenschaften löschen, jedoch keine integrierte Dokumenteigenschaft.


DeleteChartAutoFormat-Methode

Entfernt ein benutzerdefiniertes Diagramm-AutoFormat aus der Liste verfügbarer Diagramm-AutoFormate.

Syntax

Ausdruck.DeleteChartAutoFormat(Name)

Ausdruck Ein erforderlicher Ausdruck, der ein Application-Objekt zurückgibt.

Name String erforderlich. Der Name des zu entfernenden benutzerdefinierten AutoFormats.


Beispiel zur DeleteChartAutoFormat-Methode

In diesem Beispiel wird das benutzerdefinierte AutoFormat "Presentation Chart" entfernt.

Application.DeleteChartAutoFormat name:="Presentation Chart"


DeleteCustomList-Methode

Löscht eine benutzerdefinierte Liste.

Syntax

Ausdruck.DeleteCustomList(ListNum)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

ListNum Long erforderlich. Die Nummer der benutzerdefinierten Liste. Diese Zahl muss größer oder gleich 5 sein, weil Microsoft Excel vier integrierte benutzerdefinierte Listen enthält, die nicht gelöscht werden können.

Anmerkungen

Es wird eine Fehlermeldung ausgegeben, wenn die Listennummer kleiner 5 ist, oder wenn die entsprechende benutzerdefinierte Liste nicht existiert.


Beispiel zur DeleteCustomList-Methode

In diesem Beispiel wird eine benutzerdefinierte Liste gelöscht.

n = Application.GetCustomListNum(Array("cogs", "sprockets", _
    "widgets", "gizmos"))
Application.DeleteCustomList n


DeleteNumberFormat-Methode

Löscht ein benutzerdefiniertes Zahlenformat aus der Arbeitsmappe.

Syntax

Ausdruck.DeleteNumberFormat(NumberFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

NumberFormat String erforderlich. Benennt das zu löschende Zahlenformat.


Beispiel zur DeleteNumberFormat-Methode

In diesem Beispiel wird das Zahlenformat "000-00-0000" in der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.DeleteNumberFormat("000-00-0000")


DeleteReplacement-Methode

Löscht einen Eintrag aus der Matrix der AutoKorrektur-Ersetzungen.

Syntax

Ausdruck.DeleteReplacement(What)

Ausdruck. Ein erforderlicher Ausdruck, der ein AutoCorrect-Objekt zurückgibt.

What String erforderlich. Gibt den zu ersetzenden Text an, so wie er in der zu löschenden Zeile der Matrix der AutoKorrektur-Ersetzungen angezeigt wird. Existiert diese Zeichenfolge nicht in der Matrix, schlägt die Methode fehl.


Beispiel zur DeleteReplacement-Methode

In diesem Beispiel wird das Wort "Temperatur" aus der Matrix der AutoKorrektur-Ersetzungen gelöscht.

With Application.AutoCorrect
    .DeleteReplacement "Temperature"
End With


Deselect-Methode

Hebt die Auswahl des angegebenen Diagramms auf.

Syntax

Ausdruck.Deselect

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.


Beispiel zur Deselect-Methode

Dieses Beispiel hat die gleiche Wirkung wie das Drücken von ESC im aktiven Diagramm. Wenden Sie das Beispiel auf ein Diagramm an, bei dem eine Komponente (z. B. eine Achse) markiert ist.

ActiveChart.Deselect


DialogBox-Methode

Zeigt ein Dialogfeld an, das durch eine Definitionstabelle für ein Dialogfeld in einer Makrovorlage aus der Version 4.0 von Microsoft Excel definiert wurde. Gibt die Nummer des ausgewählten Steuerelements zurück oder False, falls der Benutzer auf die Schaltfläche Abbrechen geklickt hat.

Syntax

Ausdruck.DialogBox

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Range muss auf eine Definitionstabelle für ein Dialogfeld in einer Microsoft Excel 4.0-Makrovorlage verweisen.


Beispiel zur DialogBox-Methode

In diesem Beispiel wird ein Microsoft Excel 4.0-Dialogfeld ausgeführt und anschließend der Rückgabewert in einem Meldungsfeld angezeigt. Die Variable dialogRange bezieht sich auf die Definitionstabelle für das Dialogfeld auf der Microsoft Excel 4.0-Makrovorlage "Makro1".

Set dialogRange = Excel4MacroSheets("Macro1").Range("myDialogBox")
result = dialogRange.DialogBox
MsgBox result


Distribute-Methode

Verteilt Formen im angegebenen Formbereich horizontal und vertikal.

Syntax

Ausdruck.Distribute(DistributeCmd, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

DistributeCmd Long erforderlich. Gibt an, ob die Formen in dem Bereich horizontal oder vertikal verteilt werden sollen. Kann eine der beiden folgenden MsoDistributeCmd-Konstanten sein: msoDistributeHorizontally oder msoDistributeVertically.

RelativeTo Long erforderlich. Wird in Microsoft Excel nicht verwendet. Muss den Wert False besitzen.


Beispiel zur Distribute-Methode

In diesem Beispiel wird ein Formbereich definiert, der alle AutoFormen in myDocument enthält. Anschließend werden alle Formen in diesem Bereich verteilt. Die am weitesten links gelegene Form behält ihre Position bei.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numAutoShapes = 0
        ReDim autoShpArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoAutoShape Then
                numAutoShapes = numAutoShapes + 1
                autoShpArray(numAutoShapes) = .Item(i).Name
            End If
        Next
        If numAutoShapes > 1 Then
            ReDim Preserve autoShpArray(1 To numAutoShapes)
            Set asRange = .Range(autoShpArray)
            asRange.Distribute msoDistributeHorizontally, False
        End If
    End If
End With


DoubleClick-Methode

Diese Methode entspricht Doppelklicken auf die aktive Zelle.

Syntax

Ausdruck.DoubleClick

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.


Beispiel zur DoubleClick-Methode

Im folgenden Beispiel erfolgt Doppelklicken auf die aktive Zelle in Sheet1.

Worksheets("Sheet1").Activate
Application.DoubleClick


DoughnutGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Ringdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Ringdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.DoughnutGroups(Index)

Syntax 2

Ausdruck.DoughnutGroups

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur DoughnutGroups-Methode

In diesem Beispiel wird der Anfangswinkel der ersten Ringdiagrammgruppe in Chart1 festgelegt.

Charts("Chart1").DoughnutGroups(1).FirstSliceAngle = 45


DragOff-Methode

Zieht einen Seitenwechsel aus dem Druckbereich heraus.

Syntax

Ausdruck.DragOff(Direction, RegionIndex)

Ausdruck Erforderlich. Ein Ausdruck, der ein HPageBreak- oder ein VPageBreak-Objekt zurückgibt.

Direction Long erforderlich. Die Richtung, in die der Seitenwechsel gezogen wird. Dies kann eine der folgenden XlDirection-Konstanten sein: xlDown, xlToLeft, xlToRight oder xlUp.

RegionIndex Long erforderlich. Der Index der Druckbereichsregion des Seitenwechsels (die Region, in der sich der Mauszeiger beim Drücken der Maustaste befindet, wenn der Benutzer den Seitenwechsel zieht). Falls es sich um einen zusammenhängenden Druckbereich handelt, gibt es nur eine Druckregion. Ist der Druckbereich nicht zusammenhängend, gibt es mehrere Druckregionen.

Anmerkungen

Diese Methode ist vorrangig für den Makro-Recorder bestimmt. Sie können die Delete-Methode verwenden, um mit Visual Basic einen Seitenwechsel zu löschen.


Beispiel zur DragOff-Methode

In diesem Beispiel wird der erste vertikale Seitenwechsel aus dem aktiven Blatt gelöscht, indem er über den rechten Rand der Druckregion gezogen wird.

ActiveSheet.VPageBreaks(1).DragOff xlToRight, 1


Duplicate-Methode

Dupliziert das Objekt und gibt einen Bezug auf die neue Kopie zurück.

Syntax

Ausdruck.Duplicate

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


Beispiel zur Duplicate-Methode

In diesem Beispiel wird das erste eingebettete Diagramm in Sheet1 dupliziert und anschließend die Kopie ausgewählt.

Set dChart = Worksheets("Sheet1").ChartObjects(1).Duplicate
dChart.Select


EndConnect-Methode

Ordnet einer angegebenen Form das Ende der angegebenen Verbindung zu. Ist das Ende der Verbindung schon mit einer anderen Form verbunden, wird diese Verbindung unterbrochen. Liegt das Ende der Verbindung noch nicht an dem angegebenen Verbindungspunkt, verschiebt ihn diese Methode dorthin, und Größe sowie Position der Verbindung werden angepasst. Mit Hilfe der BeginConnect-Methode können Sie einer Form den Anfang einer Verbindung zuordnen.

Syntax

Ausdruck.EndConnect(ConnectedShape, ConnectionSite)

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.

ConnectedShape Shape-Objekt erforderlich. Die Form, der das Ende der Verbindung zugeordnet werden soll. Das angegebene Shape-Objekt muss sich in derselben Shapes-Auflistung wie die Verbindung befinden.

ConnectionSite Long erforderlich. Ein durch ConnectedShape festgelegter Verbindungspunkt auf der Form. Muss eine Ganzzahl zwischen 1 und der Ganzzahl sein, die die ConnectionSiteCount-Eigenschaft der angegebenen Form zurückgibt. Möchten Sie, dass die Verbindung automatisch auf dem kürzesten Weg zwischen den beiden Formen verläuft, dann geben Sie für dieses Argument eine gültige Ganzzahl ein und verwenden Sie, nachdem beide Verbindungsenden Formen zugeordnet wurden, die RerouteConnections-Methode.

Anmerkungen

Wenn Sie einem Objekt eine Verbindung zuordnen, werden Position und Größe der Verbindung, wenn notwendig, automatisch angepasst.


Beispiel zur EndConnect-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und durch eine gekrümmte Verbindung miteinander verbunden. Beachten Sie, dass es auf Grund der RerouteConnections-Methode unerheblich ist, welche Werte Sie für das ConnectionSite-Argument der Methoden BeginConnect und EndConnect angeben.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set c = s.AddConnector(msoConnectorCurve, 0, 0, 100, 100)
With c.ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    c.RerouteConnections
End With


EndDisconnect-Methode

Löst das Ende der angegebenen Verbindung von der Form, der es zugeordnet ist. Größe oder Position der Verbindung werden durch diese Methode nicht geändert: Das Ende der Verbindung verbleibt an dem Verbindungspunkt, es besteht jedoch keine Verbindung mehr. Mit Hilfe der BeginDisconnect-Methode können Sie den Anfang der Verbindung von einer Form lösen.

Syntax

Ausdruck.EndDisconnect

Ausdruck Erforderlich. Ein Ausdruck, der ein ConnectorFormat-Objekt zurückgibt.


Beispiel zur EndDisconnect-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und einer Verbindung zugeordnet, die automatisch auf den kürzesten Weg geleitet wird. Anschließend wird die Verbindung von den Rechtecken gelöst.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
set c = s.AddConnector(msoConnectorCurve, 0, 0, 0, 0)
with c.ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    c.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


ErrorBar-Methode

Weist der Datenreihe Fehlerindikatoren zu.

Syntax

Ausdruck.ErrorBar(Direction, Include, Type, Amount, MinusValues)

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Direction Variant optional. Gibt die Richtung für die Fehlerindikatoren an. Zulässig sind die XlErrorBarDirection-Konstanten xlX und xlY. xlX lässt sich jedoch nur in Punktdiagrammen einsetzen. Der Standardwert ist xlY.

Include Variant optional. Gibt die Teile an, die der Fehlerindikator enthalten soll. Zulässig ist eine der folgenden XlErrorBarInclude-Konstanten: xlErrorBarIncludePlusValues, xlErrorBarIncludeMinusValues, xlErrorBarIncludeNone oder xlErrorBarIncludeBoth. Der Standardwert ist xlErrorBarIncludeBoth.

Type Variant optional. Gibt den Fehlerindikatortyp an. Zulässig ist eine der folgenden XlErrorBarType-Konstanten: xlErrorBarTypeFixedValue, xlErrorBarTypePercent, xlErrorBarTypeStDev, xlErrorBarTypeStError oder xlErrorBarTypeCustom.

Amount Variant optional. Der Fehlerbetrag. Wird nur für einen positiven Fehlerbetrag verwendet, wenn Type den Wert xlErrorBarTypeCustom annimmt.

MinusValues Variant optional. Der negative Fehlerbetrag, wenn Type den Wert xlErrorBarTypeCustom annimmt.


Beispiel zur ErrorBar-Methode

In diesem Beispiel werden der ersten Datenreihe Standardfehlerindikatoren in Y-Richtung zugewiesen. Die Fehlerindikatoren werden in negativer und positiver Richtung zugewiesen. Wenden Sie das Beispiel auf ein 2D-Liniendiagramm an.

Charts("Chart1").SeriesCollection(1).ErrorBar _
    Direction:=xlY, Include:=xlErrorBarIncludeBoth, _
    Type:=xlErrorBarTypeStError


Evaluate-Methode

Diese Methode konvertiert einen Microsoft Excel-Namen in ein Objekt oder in einen Wert.

Syntax

Ausdruck.Evaluate(Name)

Ausdruck Optional für Application, erforderlich für Chart, DialogSheet und Worksheet. Es ist ein Ausdruck anzugeben, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Name String erforderlich. Der Name des Objekts, wobei die für Microsoft Excel gültigen Namenskonventionen zu berücksichtigen sind.

Anmerkungen

Die folgenden Namenstypen sind in Microsoft Excel im Zusammenhang mit dieser Methode zulässig:

  • A1-Bezugsart. In dieser Bezugsart lassen sich beliebige Bezüge auf einzelne Zellen angeben. Bezüge in der A1-Bezugsart sind immer absolute Bezüge.

  • Bereiche. In Bezügen können Bereichs-, Schnittmengen- sowie Vereinigungsoperatoren (Doppelpunkt, Leerzeichen bzw. Kommas) verwendet werden.

  • Definierte Namen. Sie können jeden beliebigen Namen in der Sprache des Makros angeben.

  • Externe Bezüge. Mit Hilfe des Operators ! lassen sich Bezüge auf Zellen oder Namen in anderen Arbeitsmappen angeben, z. B. Evaluate("[MAPPE1.XLS]"Sheet1"!A1").

Anmerkung: Die Verwendung eckiger Klammern (etwa "[A1:C5]") entspricht dem Aufruf der Evaluate-Methode mit einem String-Argument. Die folgenden Ausdruckspaare beispielsweise haben dieselbe Bedeutung:

[a1].Value = 25
Evaluate("A1").Value = 25
trigVariable = [SIN(45)]
trigVariable = Evaluate("SIN(45)")
Set firstCellInSheet = Workbooks("BOOK1.XLS").Sheets(4).[A1]
Set firstCellInSheet = _
    Workbooks("BOOK1.XLS").Sheets(4).Evaluate("A1")

Der Vorzug bei der Verwendung eckiger Klammern liegt im kürzeren Code. Der Vorzug bei der Verwendung der Evaluate-Methode besteht darin, dass das Argument eine Zeichenfolge ist. Dies bedeutet, sie können die Zeichenfolge entweder direkt mit dem Code angeben oder eine Visual Basic-Variable verwenden.


Beispiel zur Evaluate-Methode

In diesem Beispiel wird der Inhalt der Zelle A1 in Sheet1 fett formatiert.

Worksheets("Sheet1").Activate
boldCell = "A1"
Application.Evaluate(boldCell).Font.Bold = True


ExclusiveAccess-Methode

Räumt dem aktuellen Benutzer oder der Benutzerin exklusiven Zugriff auf die geöffnete und für gemeinsamen Zugriff freigegebene Arbeitsmappe ein.

Syntax

Ausdruck.ExclusiveAccess

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Anmerkungen

Mit der ExclusiveAccess-Methode werden alle Änderungen gespeichert, die Sie an der Arbeitsmappe vorgenommen haben. Andere Benutzer/innen, die dieselbe Arbeitsmappe geöffnet haben, müssen ihre Änderungen in einer anderen Datei speichern.

Ist die angegebene Arbeitsmappe nicht für gemeinsamen Zugriff freigegeben, schlägt diese Methode fehl. Um festzustellen, ob eine Arbeitsmappe für gemeinsamen Zugriff freigegeben ist, verwenden Sie die MultiUserEditing-Eigenschaft.


Beispiel zur ExclusiveAccess-Methode

Im folgenden Beispiel wird festgestellt, ob die aktive Arbeitsmappe für gemeinsamen Zugriff freigegeben ist. Ist dies der Fall, erhält der/die aktuelle Benutzer/in exklusiven Zugriff.

If ActiveWorkbook.MultiUserEditing Then
    ActiveWorkbook.ExclusiveAccess
End If


ExecuteExcel4Macro-Methode

Mit dieser Methode können Sie eine Microsoft Excel 4.0-Makrofunktion ausführen. Es wird das Ergebnis der Funktion zurückgegeben. Der Datentyp dieses Rückgabewerts richtet sich nach der Funktion.

Syntax

Ausdruck.ExecuteExcel4Macro(String)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

String String erforderlich. Eine Funktion der Makrosprache aus Microsoft Excel 4.0 ohne Gleichheitszeichen. Alle Bezüge müssen als Z1S1-Zeichenfolgen angegeben sein. Falls in String doppelte Anführungszeichen eingebunden sind, müssen diese zweimal angegeben werden. Um etwa die Makrofunktion =MID("ein_text",1,4) auszuführen, müsste im Argument String die Zeichenfolge "MID(""ein_text"",1,4)" stehen.

Anmerkungen

Das Microsoft Excel 4.0-Makro wird in der aktuellen Arbeitsmappe bzw. im Tabellenblatt nicht ausgewertet. Deshalb sollten Bezüge als externe Bezüge angegeben sein und der Name einer Arbeitsmappe muss ausdrücklich angegeben werden. Um beispielsweise das Microsoft Excel 4.0-Makro "Makro_3" in MAPPE1 auszuführen, müssen Sie die Zeichenfolge "MAPPE1!Makro_3()" angeben. Ohne Angabe des Arbeitsmappennamens kann die Methode nicht erfolgreich ausgeführt werden.


Beispiel zur ExecuteExcel4Macro-Methode

Das folgende Beispiel führt die Makrofunktion GET.CELL(42) auf Zelle C3 in Sheet1 aus und zeigt das Ergebnis anschließend in einem Meldungsfeld an. Die GET.CELL(42)-Makrofunktion gibt den horizontalen Abstand vom linken Rand des aktiven Fensters bis zum linken Rand der aktiven Zelle zurück. Diese Makrofunktion besitzt keine direkte Entsprechung in Visual Basic.

Worksheets("Sheet1").Activate
Range("C3").Select
MsgBox ExecuteExcel4Macro("GET.CELL(42)")


Export-Methode

Exportiert das Diagramm in einem Grafikformat.

Syntax

Ausdruck.Export(FileName, FilterName, Interactive)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

FileName String erforderlich. Der Name der exportierten Datei.

FilterName Variant optional. Der sprachenunabhängige Name des Grafikfilters, wie er in der Registrierung erscheint.

Interactive Variant optional. True, falls das Dialogfeld angezeigt wird, das die filterspezifischen Optionen enthält. Falls dieses Argument den Wert False besitzt, verwendet Microsoft Excel für den Filter die Standardwerte. Der Standardwert ist False.


Beispiel zur Export-Methode

In diesem Beispiel wird das erste Diagramm als GIF-Datei exportiert.

Worksheets("Sheet1").ChartObjects(1) _
.Chart.Export _
    FileName:="current_sales.gif", FilterName:="GIF"


Extend-Methode

Fügt einer bestehenden Auflistung von Datenreihen neue Datenpunkte hinzu.

Syntax

Ausdruck.Extend(Source, Rowcol, CategoryLabels)

Ausdruck Ein erforderlicher Ausdruck, der ein SeriesCollection-Objekt zurückgibt.

Source Variant erforderlich. Die neuen Daten, die dem SeriesCollection-Objekt hinzugefügt werden sollen, entweder als Range-Objekt oder als eine Matrix von Datenpunkten.

Rowcol Variant optional. Wird ignoriert, wenn Source eine Matrix ist. Gibt an, ob sich die neuen Werte in den Zeilen oder Spalten des angegebenen Quellbereichs befinden. Kann eine der folgenden XlRowCol-Konstanten sein: xlRows oder xlColumns. Wird dieses Argument nicht angegeben, so versucht Microsoft Excel, die Position der Werte über die Größe und Ausrichtung des ausgewählten Bereichs oder über die Dimensionen der Matrix zu bestimmen.

CategoryLabels Variant optional. Wird ignoriert, wenn Source eine Matrix ist. True, wenn die erste Zeile oder Spalte den Namen der Rubrikenbeschriftungen enthält. False, wenn die erste Zeile oder Spalte den ersten Datenpunkt der Reihe enthält. Wird dieses Argument nicht angegeben, so versucht Microsoft Excel, die Position der Rubrikenbeschriftungen über den Inhalt der ersten Zeile oder Spalte zu bestimmen.

Anmerkungen

Diese Methode steht für PivotChart-Berichte nicht zur Verfügung.


Beispiel zur Extend-Methode

In diesem Beispiel wird die Datenreihe in Chart1 um die Daten des Bereichs "B1:B6" in Sheet1 erweitert.

Charts("Chart1").SeriesCollection.Extend _
        Source:=Worksheets("Sheet1").Range("B1:B6")


FillAcrossSheets-Methode

Kopiert einen Bereich in denselben Bereich aller anderen Tabellenblätter in einer Auflistung.

Syntax

Ausdruck.FillAcrossSheets(Range, Type)

Ausdruck Ein erforderlicher Ausdruck, der ein Sheets- oder Worksheets-Objekt zurückgibt.

Range Range erforderlich. Der Bereich, der in allen anderen Tabellenblättern der Auflistung ausgefüllt werden soll. Der Bereich muss aus einem Tabellenblatt der Auflistung stammen.

Type Variant optional. Gibt an, wie der Bereich kopiert wird. Kann eine der folgenden XlFillWith-Konstanten sein: xlFillWithAll, xlFillWithContents oder xlFillWithFormulas. Der Standardwert ist xlFillWithAll.


Beispiel zur FillAcrossSheets-Methode

In diesem Beispiel wird der Bereich A1:C5 in Sheet1, Sheet5 und Sheet7 mit dem Inhalt desselben Bereichs in Sheet1 gefüllt.

x = Array("Sheet1", "Sheet5", "Sheet7")
Sheets(x).FillAcrossSheets _
    Worksheets("Sheet1").Range("A1:C5")


FillDown-Methode

Füllt die Zellen eines Bereichs beginnend mit der oder den oberste(n) Zellen nach unten hin auf. Dabei werden der Inhalt und die Formatierung der Zelle(n) in der obersten Zeile eines Bereichs in alle anderen Zeilen des Bereichs kopiert.

Syntax

Ausdruck.FillDown

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur FillDown-Methode

In diesem Beispiel wird der Bereich A1:A10 in Sheet1 mit dem Inhalt der Zelle A1 gefüllt.

Worksheets("Sheet1").Range("A1:A10").FillDown


FillLeft-Methode

Füllt die Zellen eines Bereichs beginnend mit der oder den rechten Zelle(n) bis zum linken Ende auf. Dabei werden der Inhalt und die Formatierung der Zelle(n) in der rechten Spalte eines Bereichs in alle anderen Spalten des Bereichs kopiert.

Syntax

Ausdruck.FillLeft

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur FillLeft-Methode

In diesem Beispiel wird der Bereich A1:M1 in Sheet1 mit dem Inhalt der Zelle M1 gefüllt.

Worksheets("Sheet1").Range("A1:M1").FillLeft


FillRight-Methode

Füllt die Zellen eines Bereichs beginnend mit der oder den linken Zelle(n) bis zum rechten Ende auf. Dabei wird der Inhalt und die Formatierung der Zelle(n) in der linken Spalte eines Bereichs in alle anderen Spalten des Bereichs kopiert.

Syntax

Ausdruck.FillRight

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur FillRight-Methode

In diesem Beispiel wird der Bereich A1:M1 in Sheet1 mit dem Inhalt der Zelle A1 gefüllt.

Worksheets("Sheet1").Range("A1:M1").FillRight


FillUp-Methode

Füllt die Zellen eines Bereichs beginnend mit der oder den unteren Zelle(n) nach oben hin auf. Dabei wird der Inhalt und die Formatierung der Zelle(n) in der untersten Zeile eines Bereichs in alle anderen Zeilen des Bereichs kopiert.

Syntax

Ausdruck.FillUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur FillUp-Methode

In diesem Beispiel wird der Bereich A1:A10 in Sheet1 mit dem Inhalt der Zelle A10 gefüllt.

Worksheets("Sheet1").Range("A1:A10").FillUp


Find-Methode

Sucht bestimmte Informationen in einem Bereich und gibt ein Range-Objekt zurück, das die erste Zelle mit diesem Inhalt darstellt. Gibt Nothing zurück, wenn keine Übereinstimmung gefunden wird. Die Methode bleibt ohne Wirkung auf die aktuelle Markierung oder die aktive Zelle.

Informationen über die Verwendung der Tabellenfunktion Finden in Visual Basic finden Sie unter Verwenden von Tabellenfunktionen in Visual Basic.

Syntax

Ausdruck.Find(What, After, LookIn, LookAt, SearchOrder, SearchDirection, MatchCase, MatchByte)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

What Variant erforderlich. Der Inhalt, nach dem gesucht werden soll. Dabei kann es sich um eine Zeichenfolge oder einen beliebigen Microsoft Excel-Datentyp handeln.

After Variant optional. Gibt die Zelle an, nach der die Suche beginnen soll. Dies entspricht der Position der aktiven Zelle, wenn eine Suche von der Benutzeroberfläche aus durchgeführt wird. Bitte beachten Sie, dass After eine einzelne Zelle im Bereich sein muss. Beachten Sie, dass die Suche nach dieser Zelle beginnt, die angegebene Zelle wird also erst durchsucht, wenn der Suchlauf zur Ausgangszelle zurückkehrt. Wird das Argument nicht angegeben, so ist die obere linke Zelle des Bereichs der Startpunkt für die Suche.

LookIn Variant optional. Zulässig ist eine der folgenden XlFindLookIn-Konstanten: xlFormulas, xlValues oder xlComments.

LookAt Variant optional. Zulässig sind die XlLookAt-Konstanten xlPart oder xlWhole.

SearchOrder Variant optional. Zulässig sind die XlSearchOrder-Konstanten xlByColumns oder xlByRows.

SearchDirection Variant optional. Zulässig sind die XlSearchDirection-Konstanten xlNext oder xlPrevious. Die Standardkonstante ist xlNext.

MatchCase Variant optional. Wenn True, wird bei der Suche zwischen Groß- und Kleinschreibung unterschieden. Der Standardwert ist False.

MatchByte Variant optional. Wird nur verwendet, wenn double byte-Sprachunterstützung ausgewählt oder installiert wurde. Wenn True, werden double byte-Zeichen nur mit double byte-Zeichen verglichen. Wenn False, so können double byte-Zeichen mit den entsprechenden single byte-Zeichen übereinstimmen.

Anmerkungen

Die Angaben für LookIn, LookAt, SearchOrder und MatchByte werden jedesmal gespeichert, wenn Sie diese Methode verwenden. Falls Sie beim nächsten Aufruf dieser Methode keine Werte für die Argumente angeben, werden die gespeicherten Werte verwendet. Die Angabe dieser Argumente ändert die Einstellungen im Dialogfeld Suchen, und eine Änderung der Einstellungen im Dialogfeld Suchen ändert die gespeicherten Werte, die verwendet werden, wenn Sie die Argumente nicht angeben. Um Probleme zu vermeiden, sollten Sie bei jeder Verwendung dieser Methode diese Argumente ausdrücklich angeben.

Mit den Methoden FindNext und FindPrevious können Sie die Suche mit denselben Kriterien wiederholen.

Erreicht die Suche das Ende des angegebenen Suchbereichs, beginnt sie erneut am Anfang dieses Bereichs. Um zu verhindern, dass der Bereich erneut durchsucht wird, speichern Sie die Adresse der zuerst gefundenen Zelle, und vergleichen Sie dann jede nachfolgend gefundene Zelladresse mit dieser gespeicherten Adresse.

Wenn Sie bei der Suche von Zellen ein komplexeres Suchmuster verwenden wollen, können Sie eine For Each...Next-Anweisung in Kombination mit dem Like-Operator einsetzen. Der folgende Code durchsucht beispielsweise alle Zellen im Bereich A1:C5 nach einer Zelle, deren Schriftart mit den Buchstaben "Cour" anfängt. Im Falle einer Übereinstimmung wird die Schriftart in Times New Roman geändert:

For Each c In [A1:C5]
    If c.Font.Name Like "Cour*" Then
        c.Font.Name = "Times New Roman"
    End If
Next


FindFile-Methode

Zeigt das Dialogfeld Öffnen an.

Syntax

Ausdruck.FindFile

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Diese Methode zeigt das Dialogfeld Öffnen an und ermöglicht dem/der Benutzer/in das Öffnen einer Datei. Wird eine neue Datei erfolgreich geöffnet, gibt diese Methode den Wert True zurück. Klickt der/die Benutzer/in im Dialogfeld auf Abbrechen, wird der Wert False zurückgegeben.


Beispiel zur FindFile-Methode

In diesem Beispiel wird das Dialogfeld Öffnen angezeigt.

Application.FindFile


FindNext-Methode

Setzt eine Suche fort, die mit der Find-Methode begonnen wurde. Die Methode sucht nach der nächsten Zelle, die dieselben Suchkriterien erfüllt, und gibt ein Range-Objekt zurück, das diese Zelle darstellt. Die Methode bleibt ohne Wirkung auf die aktuelle Auswahl oder die aktive Zelle.

Syntax

Ausdruck.FindNext(After)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

After Variant optional. Das Argument gibt die erste Zelle an, nach der die Suche beginnen soll. Dies entspricht der Position der aktiven Zelle, wenn eine Suche über die Benutzeroberfläche durchgeführt wird. Beachten Sie, dass After eine einzelne Zelle im Bereich sein muss. Beachten Sie, dass die Suche nach dieser Zelle beginnt; die angegebene Zelle wird also erst durchsucht, wenn der Suchlauf zur Ausgangszelle zurückkehrt. Wird das Argument nicht angegeben, so ist die obere linke Zelle des Bereichs der Startpunkt für die Suche.

Anmerkungen

Erreicht die Suche das Ende des angegebenen Suchbereichs, beginnt sie erneut am Anfang dieses Bereichs. Um zu verhindern, dass der Bereich erneut durchsucht wird, speichern Sie die Adresse der zuerst gefundenen Zelle, und vergleichen Sie dann jede nachfolgend gefundene Zelladresse mit dieser gespeicherten Adresse.


Beispiel zur FindNext-Methode

Dieses Beispiel findet alle Zellen im Bereich A1:A500, die den Wert 2 enthalten. Anschließend werden diese Zellen grau formatiert.

With Worksheets(1).Range("a1:a500")
    Set c = .Find(2, lookin:=xlValues)
    If Not c Is Nothing Then
        firstAddress = c.Address
        Do
            c.Interior.Pattern = xlPatternGray50
            Set c = .FindNext(c)
        Loop While Not c Is Nothing And c.Address <> firstAddress
    End If
End With


FindPrevious-Methode

Setzt eine Suche fort, die mit der Find-Methode begonnen wurde. Die Methode sucht nach der vorhergehenden Zelle, die dieselben Suchkriterien erfüllt, und gibt ein Range-Objekt zurück, das diese Zelle darstellt. Die Methode bleibt ohne Wirkung auf die aktuelle Auswahl oder die aktive Zelle.

Syntax

Ausdruck.FindPrevious(After)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

After Variant optional. Das Argument gibt die erste Zelle an, von der aus rückwärts gesucht werden soll. Dies entspricht der Position der aktiven Zelle, wenn eine Suche über die Benutzeroberfläche durchgeführt wird. Beachten Sie, dass After eine einzelne Zelle im Bereich sein muss. Bedenken Sie, dass die Suche vor dieser Zelle beginnt; die angegebene Zelle wird also erst durchsucht, wenn der Suchlauf zur Ausgangszelle zurückkehrt. Wird das Argument nicht angegeben, so ist die obere linke Zelle des Bereichs der Startpunkt für die Suche.

Anmerkungen

Erreicht die Suche den Anfang des angegebenen Suchbereichs, beginnt sie erneut am Ende dieses Bereichs. Um zu verhindern, dass der Bereich erneut durchsucht wird, speichern Sie die Adresse der zuerst gefundenen Zelle, und vergleichen Sie dann jede nachfolgend gefundene Zelladresse mit dieser gespeicherten.


Beispiel zur FindPrevious-Methode

In diesem Beispiel wird gezeigt, wie die FindPrevious-Methode mit der Find- und FindNext-Methode zusammenarbeitet. Stellen Sie sicher, dass der Begriff "Phoenix" mindestens zweimal in Spalte B in Sheet1 vorkommt, bevor Sie dieses Beispiel ausführen.

Set fc = Worksheets("Sheet1").Columns("B").Find(what:="Phoenix")
    MsgBox "The first occurrence is in cell " & fc.Address
Set fc = Worksheets("Sheet1").Columns("B").FindNext(after:=fc)
    MsgBox "The next occurrence is in cell " & fc.Address
Set fc = Worksheets("Sheet1").Columns("B").FindPrevious(after:=fc)
    MsgBox "The previous occurrence is in cell " & fc.Address


Flip-Methode

Kippt die angegebene Form um ihre horizontale oder vertikale Achse.

Syntax

Ausdruck.Flip(FlipCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.

FlipCmd Long erforderlich. Gibt an, ob die Form horizontal oder vertikal gekippt werden soll. Kann eine der beiden folgenden MsoFlipCmd-Konstanten sein: msoFlipHorizontal oder msoFlipVertical.


Beispiel zur Flip-Methode

In diesem Beispiel wird in myDocument ein Dreieck eingefügt und dupliziert. Danach wird das Duplikat vertikal gekippt und rot gefärbt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRightTriangle, _
        10, 10, 50, 50).Duplicate
    .Fill.ForeColor.RGB = RGB(255, 0, 0)
    .Flip msoFlipVertical
End With


Follow-Methode

Zeigt ein zwischengespeichertes Dokument an, falls dieses bereits übertragen worden ist. Andernfalls stellt diese Methode den Hyperlink wieder her, überträgt das Zieldokument und zeigt es in der entsprechenden Anwendung an.

Syntax

Ausdruck.Follow(NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt zurückgibt.

NewWindow Variant optional. True, falls die Zielanwendung in einem neuen Fenster angezeigt wird. Der Standardwert ist False.

AddHistory Variant optional. Nicht verwendet. Für zukünftigen Einsatz reserviert.

ExtraInfo Variant optional. Ein String oder eine Byte-Matrix, durch die Zusatzinformationen angegeben werden, die HTTP zur Wiederherstellung des Hyperlinks verwendet. Sie können beispielsweise ExtraInfo verwenden, um die Koordinaten einer Imagemap, den Inhalt eines Formulars oder einen FAT-Dateinamen anzugeben.

Method Variant optional. Legt fest, wie ExtraInfo zugeordnet wird. Dies kann eine der folgenden MsoExtraInfoMethod-Konstanten sein.

Konstante | Beschreibung
msoMethodGet | ExtraInfo ist eine Zeichenfolge, die an die Adresse angehängt wird.
msoMethodPost | ExtraInfo wird als String oder Byte-Matrix abgelegt.

HeaderInfo Variant optional. Ein String, der die Header-Information für die HTTP-Abfrage festlegt. Der Standardwert ist eine leere Zeichenfolge.


FollowHyperlink-Methode

Zeigt ein zwischengespeichertes Dokument an, falls dieses bereits übertragen worden ist. Andernfalls stellt diese Methode den Hyperlink wieder her, überträgt das Zieldokument und zeigt es in der entsprechenden Anwendung an.

Syntax

Ausdruck.FollowHyperlink(Address, SubAddress, NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Address String erforderlich. Die Adresse des Zieldokuments.

SubAddress Variant optional. Die Position innerhalb des Zieldokuments. Der Standardwert ist eine leere Zeichenfolge.

NewWindow Variant optional. True, wenn die Zielanwendung in einem neuen Fenster angezeigt wird. Der Standardwert ist False.

AddHistory Variant optional. Nicht verwendet. Für zukünftigen Einsatz reserviert.

ExtraInfo Variant optional. Ein String oder eine Byte-Matrix, durch die Zusatzinformationen angegeben werden, die HTTP zur Wiederherstellung des Hyperlinks verwendet. Sie können beispielsweise ExtraInfo verwenden, um die Koordinaten einer Imagemap, den Inhalt eines Formulars oder einen FAT-Dateinamen anzugeben.

Method Variant optional. Legt fest, wie ExtraInfo zugeordnet wird. Dies kann eine der folgenden MsoExtraInfoMethod-Konstanten sein.

Konstante | Beschreibung
msoMethodGet | ExtraInfo ist eine Zeichenfolge, die an die Adresse angehängt wird.
msoMethodPost | ExtraInfo wird als String oder Byte-Matrix abgelegt.
msoMethodPostFile | ExtraInfo legt den Namen einer FAT-Datei fest; der Inhalt der Datei wird abgelegt.

HeaderInfo Variant optional. Ein String, der die Header-Information für die HTTP-Abfrage festlegt. Der Standardwert ist eine leere Zeichenfolge.


Beispiel zur FollowHyperlink-Methode

In diesem Beispiel wird das Dokument von der Adresse www.gohere.de in ein neues Fenster geladen und dem Verlaufsordner hinzugefügt.

ActiveWorkbook.FollowHyperlink Address:="http://www.gohere.com", _
    NewWindow:=True


Format-Methode

Stellt einen PivotTable-Bericht auf eines der vordefinierten Formate mit oder ohne Einzug bzw. Kreuztabellenformate ein.

Syntax

Ausdruck.Format(Type)

Ausdruck Ein Ausdruck der ein PivotTable-Objekt zurückgibt.

Type XlPivotFormatType erforderlich. Gibt den Typ der Berichtsformatierung an, die für den angegebenen PivotTable-Bericht anwendet werden soll. Kann eine der folgenden XlPivotFormatType-Konstanten sein: xlPTClassic, xlPTNone, xlReport1, xlReport2, xlReport3, xlReport4, xlReport5, xlReport6, xlReport7, xlReport8, xlReport9, xlReport10, xlTable1, xlTable2, xlTable3, xlTable4, xlTable5, xlTable6, xlTable7, xlTable8, xlTable9, xlTable10.


Beispiel zur Format-Methode

In diesem Beispiel wird das Einzugsformat xlReport4 für den vierten PivotTable-Bericht im aktiven Tabellenblatt angewendet.

ActiveSheet.PivotTables("PivotTable4").Format xlReport4


FunctionWizard-Methode

Aktiviert den Funktions-Assistenten für die linke obere Zelle des Bereichs.

Syntax

Ausdruck.FunctionWizard

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur FunctionWizard-Methode

In diesem Beispiel wird der Funktions-Assistent für die aktive Zelle in Sheet1 aufgerufen.

Worksheets("Sheet1").Activate
ActiveCell.FunctionWizard


GetChartElement-Methode

Gibt Informationen über das Diagrammelement an den angegebenen X- und Y-Koordinaten zurück. Diese Methode ist insofern ungewöhnlich, als Sie nur für die beiden ersten Argumente Werte festlegen. Microsoft Excel fügt die anderen Argumente ein. Ihr Code sollte diese Werte nach Beendigung der Methode untersuchen.

Syntax

Ausdruck.GetChartElement(X, Y, ElementID, Arg1, Arg2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

X Long erforderlich. Die X-Koordinate des Diagrammelements.

Y Long erforderlich. Die Y-Koordinate des Diagrammelements.

ElementID Long erforderlich. Nach Beendigung der Methode enthält dieses Argument den XLChartItem-Wert des Diagrammelements an den angegebenen Koordinaten. Weitere Informationen hierzu finden Sie im Abschnitt "Anmerkungen".

Arg1 Long erforderlich. Nach Beendigung der Methode enthält dieses Argument Informationen zu dem Diagrammelement. Weitere Informationen hierzu finden Sie im Abschnitt "Anmerkungen".

Arg2 Long erforderlich. Nach Beendigung der Methode enthält dieses Argument Informationen zu dem Diagrammelement. Weitere Informationen finden Sie im Abschnitt "Anmerkungen".

Anmerkungen

Der Wert von ElementID nach Beendigung der Methode bestimmt, ob Arg1 und Arg2, wie in der folgenden Tabelle aufgeführt, Informationen enthalten.

ElementID | Arg1 | Arg2
xlChartArea | Keine | Keine
xlChartTitle | Keine | Keine
xlPlotArea | Keine | Keine
xlLegend | Keine | Keine
xlFloor | Keine | Keine
xlWalls | Keine | Keine
xlCorners | Keine | Keine
xlDataTable | Keine | Keine
xlSeries | SeriesIndex | PointIndex
xlDataLabel | SeriesIndex | PointIndex
xlTrendline | SeriesIndex | TrendLineIndex
xlErrorBars | SeriesIndex | Keine
xlXErrorBars | SeriesIndex | Keine
xlYErrorBars | SeriesIndex | Keine
xlLegendEntry | SeriesIndex | Keine
xlLegendKey | SeriesIndex | Keine
xlAxis | AxisIndex | AxisType
xlMajorGridlines | AxisIndex | AxisType
xlMinorGridlines | AxisIndex | AxisType
xlAxisTitle | AxisIndex | AxisType
xlDisplayUnitLabel | AxisIndex | AxisType
xlUpBars | GroupIndex | Keine
xlDownBars | GroupIndex | Keine
xlSeriesLines | GroupIndex | Keine
xlHiLoLines | GroupIndex | Keine
xlDropLines | GroupIndex | Keine
xlRadarAxisLabels | GroupIndex | Keine
xlShape | ShapeIndex | Keine
xlPivotChartDropZone | DropZoneType | Keine
xlPivotChartFieldButton | DropZoneType | PivotFieldIndex
xlNothing | Keine | Keine

In der folgenden Tabelle wird die Bedeutung von Arg1 und Arg2 nach der Beendigung der Methode beschrieben.

Argument |  | Beschreibung
SeriesIndex | Gibt den Offset einer bestimmten Datenreihe innerhalb der Series-Auflistung an.
PointIndex | Gibt den Offset eines bestimmten Punktes in einer Datenreihe innerhalb der Points-Auflistung an. Ein Wert von – 1 bedeutet, dass alle Datenpunkte markiert sind.
TrendlineIndex | Gibt den Offset einer bestimmten Trendlinie in einer Datenreihe innerhalb der Trendlines-Auflistung an.
AxisIndex | Gibt an, ob es sich um eine Primär- oder Sekundärachse handelt. Kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary.
AxisType | Gibt den Achsentyp an. Kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeriesAxis oder xlValue.
GroupIndex | Gibt den Offset einer bestimmten Diagrammgruppe innerhalb der ChartGroups-Auflistung an.
ShapeIndex | Gibt den Offset einer bestimmten Form innerhalb der Shapes-Auflistung an.
DropZoneType | Gibt den Typ der Ablegezone an: Spalten-, Daten-, Seiten oder Zeilenfeld. Kann eine der folgenden XlPivotFieldOrientation-Konstanten sein: xlColumnField, xlDataField, xlPageField oder xlRowField. Die Spalten- und Zeilenfeldkonstanten geben die Datenreihen- bzw. Rubrikenfelder an.
PivotFieldIndex | Gibt den Offset in der PivotFields-Auflistung für ein bestimmtes Spalten- (Datenreihen-), Daten-, Seiten- oder Zeilen- (Rubriken-)feld an.


Beispiel zur GetChartElement-Methode

In diesem Beispiel erhält der Benutzer oder die Benutzerin eine Warnmeldung, wenn die Maus über die Diagrammlegende bewegt wird.

Private Sub Chart_MouseMove(ByVal Button As Long, _
        ByVal Shift As Long, ByVal X As Long, ByVal Y As Long)
    Dim IDNum As Long
    Dim a As Long
    Dim b As Long

    ActiveChart.GetChartElement X, Y, IDNum, a, b
    If IDNum = xlLegendEntry Then _
        MsgBox "WARNING: Move away from the legend"
End Sub


GetCustomListContents-Methode

Gibt eine benutzerdefinierte Liste (eine Matrix aus Zeichenfolgen) zurück.

Syntax

Ausdruck.GetCustomListContents(ListNum)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

ListNum Long erforderlich. Die Listennummer.


Beispiel zur GetCustomListContents-Methode

In diesem Beispiel werden die Elemente der ersten benutzerdefinierten Liste in die erste Spalte in Sheet1 geschrieben.

listArray = Application.GetCustomListContents(1)
For i = LBound(listArray, 1) To UBound(listArray, 1)
    Worksheets("sheet1").Cells(i, 1).Value = listArray(i)
Next i


GetCustomListNum-Methode

Gibt für eine Matrix aus Zeichenfolgen die Nummer der benutzerdefinierten Liste zurück. Es können benutzerdefinierte und integrierte Listen zusammengeführt werden, um diese Methode zu benutzen.

Syntax

Ausdruck.GetCustomListNum(ListArray)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

ListArray Variant erforderlich. Eine Matrix aus Zeichenfolgen.

Anmerkungen

Diese Methode generiert eine Fehlermeldung, wenn die entsprechende Liste nicht existiert.


Beispiel zur GetCustomListNum-Methode

In diesem Beispiel wird eine benutzerdefinierte Liste gelöscht.

n = Application.GetCustomListNum(Array("cogs", "sprockets", _
    "widgets", "gizmos"))
Application.DeleteCustomList n


GetData-Methode

Syntax

Ausdruck.GetData(Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Name String erforderlich. Beschreibt eine einzelne Zelle eines PivotTable-Berichts. Die verwendete Syntax ähnelt der PivotSelect-Methode oder den Bezügen von PivotTable-Berichten in berechneten Elementformeln.


Beispiel zur GetData-Methode

In diesem Beispiel wird die Summe der Einnahmen aus Äpfeln im Januar dargestellt (Datenfeld = Einnahme, Produkt = Äpfel, Monat = Januar).

Msgbox ActiveSheet.PivotTables(1) _
    .GetData("'Sum of Revenue' Apples January")


GetOpenFilename-Methode

Zeigt das Standarddialogfeld Öffnen an und bekommt einen Dateinamen vom Benutzer, ohne jedoch irgendwelche Dateien zu öffnen.

Syntax

Ausdruck.GetOpenFilename(FileFilter, FilterIndex, Title, ButtonText, MultiSelect)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

FileFilter Variant optional. Eine Zeichenfolge, die die Dateifilterkriterien angibt.

Diese Zeichenfolge besteht aus Zeichenfolgepaaren für den Dateifilter, gefolgt von einer MS-DOS-Platzhalterspezifikation für den Dateifilter, wobei jeder Teil und jedes Paar durch Kommas getrennt sind. Jedes einzelne Paar wird im Dropdownlistenfeld Dateityp angezeigt. Die folgende Zeichenfolge gibt beispielsweise die beiden Dateifilter Text und Add-In an: "Textdateien (*.txt), *.txt, Add-In-Dateien (*.xla), *.xla".

Um mehrere MS-DOS-Platzhalterausdrücke für einen einzelnen Dateifiltertyp anzugeben, trennen Sie die Platzhalterausdrücke mit Semikola. Beispiel: "Visual Basic-Dateien (*.bas; *.txt),*.bas;*.txt".

Wird dieses Argument ausgelassen, wird der Standardwert "Alle Dateien (*.*),*.*" verwendet.

FilterIndex Variant optional. Gibt die Indexnummer der Standarddatei-Filterkriterien an, von 1 bis zu der Anzahl der in FileFilter angegebenen Filter. Wird dieses Argument ausgelassen oder ist es größer als die Anzahl der vorhandenen Filter, wird der erste Dateifilter verwendet.

Title Variant optional. Gibt den Titel des Dialogfelds an. Wird dieses Argument ausgelassen, wird der Titel "Öffnen" verwendet.

ButtonText Variant optional. Nur bei Macintosh.

MultiSelect Variant optional. True, damit mehrere Dateinamen ausgewählt werden können. False, damit nur ein Dateiname ausgewählt werden kann. Der Standardwert ist False

Anmerkungen

Diese Methode gibt den ausgewählten Dateinamen oder den vom Benutzer eingegebenen Namen zurück. Der zurückgegebene Name kann eine Pfadangabe enthalten. Ist MultiSelect auf True eingestellt, bildet der Rückgabewert eine Matrix der ausgewählten Dateinamen (auch wenn lediglich ein Dateiname ausgewählt wurde). Gibt False zurück, wenn der Benutzer das Dialogfeld mit Abbrechen verlässt.

Diese Methode kann unter Umständen das aktuelle Laufwerk oder den aktuellen Ordner ändern.


Beispiel zur GetOpenFilename-Methode

In diesem Beispiel wird das Dialogfeld Öffnen mit einem Dateifilter für Textdateien angezeigt. Wenn der Benutzer einen Dateinamen wählt, wird dieser in einem Meldungsfeld angezeigt.

fileToOpen = Application _
    .GetOpenFilename("Text Files (*.txt), *.txt")
If fileToOpen <> False Then
    MsgBox "Open " & fileToOpen
End If


GetPhonetic-Methode

Gibt den japanischen phonetischen Text der angegebenen Textzeichenfolge zurück. Diese Methode ist nur verfügbar, wenn die japanische Sprachunterstützung für Microsoft Office ausgewählt oder installiert wurde.

Syntax

Ausdruck.GetPhonetic(Text)

Ausdruck Ein Ausdruck, der ein Application-Objekt zurückgibt.

Text Variant optional. Gibt den Text an, der in phonetischen Text konvertiert werden soll. Wird dieses Argument ausgelassen, wird die nächst mögliche phonetische Textzeichenfolge (sofern vorhanden) des zuvor angegebenen Text zurückgegeben. Sind keine weiteren möglichen phonetischen Textzeichenfolgen vorhanden, wird eine leere Zeichenfolge zurückgegeben.


Beispiel zu GetPhonetic-Methode

In diesem Beispiel werden alle möglichen phonetischen Textzeichenfolgen aus der angegebenen Zeichenfolge zurückgegeben.

strPhoText = Application.GetPhonetic("  junko   junko ")
While strPhoText <> ""
    MsgBox strPhoText
    strPhoText = Application.GetPhonetic()
Wend


GetSaveAsFilename-Methode

Zeigt das Standarddialogfeld Speichern unter an und bekommt einen Dateinamen vom Benutzer, ohne jedoch irgendwelche Dateien zu speichern.

Syntax

Ausdruck.GetSaveAsFilename(InitialFilename, FileFilter, FilterIndex, Title, ButtonText)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

InitialFilename Variant optional. Gibt den vorgeschlagenen Dateinamen an. Wird dieses Argument ausgelassen, verwendet Microsoft Excel den Namen der aktiven Arbeitsmappe.

FileFilter Variant optional. Eine Zeichenfolge, die die Dateifilterkriterien angibt.

Diese Zeichenfolge besteht aus Zeichenfolgepaaren für den Dateifilter, gefolgt von einer MS-DOS-Platzhalterspezifikation für den Dateifilter, wobei jeder Teil und jedes Paar durch Kommas getrennt sind. Jedes einzelne Paar wird im Dropdownlistenfeld Dateityp angezeigt. Die folgende Zeichenfolge gibt beispielsweise die beiden Dateifilter Text und Add-In an: "Textdateien (*.txt), *.txt, Add-In-Dateien (*.xla), *.xla".

Um mehrere MS-DOS-Platzhalterausdrücke für einen einzelnen Dateifiltertyp anzugeben, trennen Sie die Platzhalterausdrücke mit Semikola. Beispiel: "Visual Basic-Dateien (*.bas; *.txt),*.bas;*.txt".

Wird dieses Argument ausgelassen, wird der Standardwert "Alle Dateien (*.*),*.*" verwendet.

FilterIndex Variant optional. Gibt die Indexnummer der Standarddatei-Filterkriterien an, von 1 bis zu der Anzahl der in FileFilter angegebenen Filter. Wird dieses Argument ausgelassen oder ist es größer als die Anzahl der vorhandenen Filter, so wird der erste Dateifilter verwendet.

Title Variant optional. Gibt den Titel des Dialogfelds an. Wird dieses Argument ausgelassen, wird der Standardtitel verwendet.

ButtonText Variant optional. Nur bei Macintosh.

Anmerkungen

Diese Methode gibt den ausgewählten Dateinamen oder den vom Benutzer eingegebenen Namen zurück. Der zurückgegebene Name kann eine Pfadangabe enthalten. Gibt False zurück, wenn der Benutzer das Dialogfeld mit Abbrechen verlässt.

Diese Methode kann unter Umständen das aktuelle Laufwerk oder den aktuellen Ordner ändern.


Beispiel zur GetSaveAsFilename-Methode

In diesem Beispiel wird das Dialogfeld Speichern unter mit einem Dateifilter für Textdateien angezeigt. Wenn der Benutzer einen Dateinamen wählt, wird dieser in einem Meldungsfeld angezeigt.

fileSaveName = Application.GetSaveAsFilename( _
    fileFilter:="Text Files (*.txt), *.txt")
If fileSaveName <> False Then
    MsgBox "Save as " & fileSaveName
End If


GoalSeek-Methode

Berechnet die Werte, die zum Erreichen eines bestimmten Ziels notwendig sind. Handelt es sich bei dem Ziel um ein Ergebnis, das von einer Formel zurückgegeben werden soll, so berechnet diese Methode einen Wert, der beim Einsetzen in die Formel zum gewünschten Ergebnis führt. Der Rückgabewert ist True, wenn das Ziel erreicht wurde.

Syntax

Ausdruck.GoalSeek(Goal, ChangingCell)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Es muss sich hierbei um eine einzelne Zelle handeln.

Goal Variant erforderlich. Der Wert, der in dieser Zelle zurückgegeben werden soll (das Ziel).

ChangingCell Range erforderlich. In diesem Argument wird die Zelle angegeben, die zum Erreichen des gewünschten Zielwerts geändert werden soll.


Beispiel zur GoalSeek-Methode

In diesem Beispiel wird vorausgesetzt, dass in Sheet1 eine Zelle mit dem Namen "Polynom" vorhanden ist, die die Formel =(X^3)+(3*X^2)+6 enthält sowie eine weitere Zelle mit dem Namen "X", die leer ist. Es wird ein Wert für "X" gesucht, so dass "Polynom" den Wert 15 annimmt.

Worksheets("Sheet1").Range("Polynomial").GoalSeek _
    Goal:=15, _
    ChangingCell:=Worksheets("Sheet1").Range("X")


Goto-Methode

Markiert einen Bereich oder eine Visual Basic-Prozedur in einer beliebigen Arbeitsmappe und aktiviert diese, falls sie nicht bereits aktiv ist.

Syntax

Ausdruck.Goto(Reference, Scroll)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Reference Variant optional. Gibt das Ziel an. Kann ein Range-Objekt sein, eine Zeichenfolge, die einen Zellbezug in Z1S1-Schreibweise enthält, oder aber eine Zeichenfolge, die den Namen einer Visual Basic-Prozedur enthält. Wird dieses Argument nicht angegeben, ist das Ziel der letzte mit der Goto-Methode ausgewählte Bereich.

Scroll Variant optional. Wenn True, führt Microsoft Excel die nötigen Bildläufe durch, damit die obere linke Zelle des Bereichs als obere linke Zelle des Fensters erscheint. Wenn False, führt Microsoft Excel keine Bildläufe durch. Der Standardwert ist False.

Anmerkungen

Diese Methode unterscheidet sich folgendermaßen von der Select-Methode:

  • Wenn Sie einen Bereich in einem nicht aktiven Blatt angeben, wechselt Microsoft Excel vor dem Markieren zu diesem Tabellenblatt. (Wenn Sie Select auf einen Bereich eines Tabellenblatts anwenden, das nicht aktiv ist, wird der Bereich zwar markiert, das Blatt aber nicht aktiviert).

  • Für diese Methode können Sie das Argument Scroll angeben, um Bildläufe im Zielfenster durchzuführen.

  • Wenn Sie die Goto-Methode verwenden, wird die letzte Markierung (vor dem Ausführen der Goto-Methode) zur Matrix der vorhergehenden Markierungen hinzugefügt. (Weitere Informationen hierzu finden Sie in der Beschreibung der PreviousSelections-Eigenschaft). Hiermit können Sie schnell zwischen maximal vier Markierungen hin- und herspringen.

  • Die Select-Methode hat das Argument Replace, die Goto-Methode nicht.


Beispiel zur Goto-Methode

In diesem Beispiel wird Zelle A154 in Sheet1 markiert. Anschließend werden in dem Tabellenblatt solange Bildläufe durchgeführt, bis der Bereich angezeigt wird.

Application.Goto Reference:=Worksheets("Sheet1").Range("A154"), _
    scroll:=True


Group-Methode

Um weitere Informationen zu erhalten, klicken Sie auf eines der folgenden Objekte.

Range

ShapeRange


Group-Methode (Range-Objekt)

Wenn das Range-Objekt eine Gliederung ist, setzt die Group-Methode (Syntax 1) den Bereich zurück (oder anders ausgedrückt: sie erhöht die Gliederungsebene). Bei dem Bereich muss es sich um eine ganze Zeile oder Spalte oder einen Zeilen- oder Spaltenbereich handeln.

Wenn das Range-Objekt ein nicht zusammenhängender Bereich in einem PivotTable-Bericht ist, gruppiert die Group-Methode (Syntax 1) den Bereich.

Wenn das Range-Objekt eine einzelne Zelle im Datenbereich des PivotTable-Feldes darstellt, führt die Group-Methode (Syntax 2) eine Gruppierung nach Zahlen oder Datum in diesem Feld durch.

Syntax 1

Ausdruck.Group

Syntax 2

Ausdruck.Group(Start, End, By, Periods)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Bei Syntax 2 muss das Range-Objekt eine einzelne Zelle im Datenbereich des PivotTable-Feldes sein. Wenn Sie versuchen, diese Methode auf mehrere Zellen anzuwenden, führt sie zu einem Fehler (ohne jedoch eine Fehlermeldung anzuzeigen). Wie die Group-Methode auf diese Weise verwendet wird, sehen Sie im zweiten der zugehörigen Beispiele.

Start Variant optional. Der erste in die Gruppe aufzunehmende Wert. Wenn dieses Argument ausgelassen wird oder den Wert True besitzt, wird der erste Wert im Feld verwendet.

End Variant optional. Der letzte in die Gruppe aufzunehmende Wert. Wenn dieses Argument ausgelassen wird oder den Wert True besitzt, wird der letzte Wert im Feld verwendet.

By Variant optional. Wenn es sich um ein numerisches Feld handelt, gibt dieses Argument die Größe jeder Gruppe an.

Wenn es sich um ein Datumsfeld handelt, gibt dieses Argument an, wie viele Tage jede Gruppe enthält, unter der Voraussetzung, dass das Element 4 in der Periods-Matrix den Wert True und alle anderen Elemente den Wert False besitzen. Andernfalls wird das Argument ignoriert.

Wird dieses Argument nicht angegeben, wird von Microsoft Excel eine Standardgröße der Gruppe verwendet.

Periods Variant optional. Eine Matrix von booleschen Werten, die den Zeitraum für die Gruppe angeben, wie in der folgenden Auflistung dargestellt.

Matrixelement | Zeitraum
1 | Sekunden
2 | Minuten
3 | Stunden
4 | Tage
5 | Monate
6 | Quartale
7 | Jahre

Wenn ein Matrixelement den Wert True besitzt, wird für den betreffenden Zeitraum eine Gruppe erstellt. Besitzt das Element den Wert False, so wird keine Gruppe erstellt. Dieses Argument wird ignoriert, falls es sich bei dem Feld nicht um ein Datumsfeld handelt.


Beispiel zur Group-Methode (Range-Objekt)

In diesem Beispiel wird das Feld "Bestelldatum" in Perioden von 10 Tagen zusammengefasst.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Set groupRange = pvtTable.PivotFields("ORDER_DATE").DataRange
groupRange.Cells(1).Group by:=10, _
    periods:=Array(False, False, False, _
        True, False, False, False)


Group-Methode (ShapeRange-Objekt)

Gruppiert die Formen im angegebenen Bereich. Gibt die gruppierten Formen als einzelnes Shape-Objekt zurück.

Syntax

Ausdruck.Group

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Da eine Gruppe von Formen als einzelne Form behandelt wird, ändern sich durch Gruppieren und Aufheben der Gruppierung die Anzahl der Elemente in der Shapes-Auflistung sowie die Indexnummern der Elemente, die den betroffenen Elementen in der Auflistung nachfolgen.


Beispiel zur Group-Methode (ShapeRange-Objekt)

In diesem Beispiel werden in myDocument zwei Formen eingefügt und gruppiert. Die Gruppe wird mit einer Füllung versehen, gedreht und in der Zeichnungsebene nach hinten gelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    .AddShape(msoShapeCan, 50, 10, 100, 200).Name = "shpOne"
    .AddShape(msoShapeCube, 150, 250, 100, 200).Name = "shpTwo"
    With .Range(Array("shpOne", "shpTwo")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .Rotation = 45
        .ZOrder msoSendToBack
    End With
End With


Help-Methode

Öffnet ein Hilfethema.

Syntax

Ausdruck.Help(HelpFile, HelpContextID)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

HelpFile Variant optional. Der Name der Online-Hilfedatei, die angezeigt werden soll. Ohne Angabe dieses Arguments wird die Microsoft Excel-Hilfe angezeigt.

HelpContextID Variant optional. Hier können Sie die Identifikationsnummer für das betreffende Hilfethema angeben. Ohne Angabe dieses Arguments wird das Dialogfeld Hilfethemen angezeigt.


Beispiel zur Help-Methode

In diesem Beispiel wird das Thema Nummer 65527 der Hilfedatei Otisapp.hlp angezeigt.

Application.Help "OTISAPP.HLP", 65527


HighlightChangesOptions-Methode

Steuert, wie Änderungen in einer gemeinsam genutzten Arbeitsmappe dargestellt werden.

Syntax

Ausdruck.HighlightChangesOptions(When, Who, Where)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

When Variant optional. Die dargestellten Änderungen. Dies kann eine der folgenden XlHighlightChangesTime-Konstanten sein: xlSinceMyLastSave, xlAllChanges oder xlNotYetReviewed.

Who Variant optional. Der oder die Benutzer, deren Änderungen dargestellt werden. Dies kann "Jeder", "Jeder außer mir" oder die Namen des oder der Benutzer der gemeinsam genutzten Arbeitsmappe sein.

Where Variant optional. Ein Bereichsbezug in A1-Schreibweise, der den auf Änderungen zu überprüfenden Bereich festlegt.


Beispiel zur HighlightChangesOptions-Methode

In diesem Beispiel werden Änderungen an der gemeinsam genutzten Arbeitsmappe in einem eigenen Tabellenblatt dargestellt.

With ActiveWorkbook
    .HighlightChangesOptions _
        When:=xlSinceMyLastSave, _
        Who:="Everyone"
    .ListChangesOnNewSheet = True
End With


Import-Methode

Diese Methode sollte nicht benutzt werden. Audio-Notizen wurden aus Microsoft Excel entfernt.


 InchesToPoints-Methode

InchesToPoints-Methode

Wandelt eine Maßangabe von Zoll in Punkt um.

Syntax

Ausdruck.InchesToPoints(Inches)

Ausdruck Erforderlich. Ein Ausdruck für das Application-Objekt.

Inches Double erforderlich. Gibt den Zollwert an, der in Punkt umgerechnet werden soll.


Beispiel zur InchesToPoints-Methode

In diesem Beispiel wird der linke Rand von Sheet1 auf 2,5 Zoll (6,4 cm) eingestellt.

Worksheets("Sheet1").PageSetup.LeftMargin = _
        Application.InchesToPoints(2.5)


IncrementBrightness-Methode

Ändert die Helligkeit des Bildes um den angegebenen Wert. Verwenden Sie die Brightness-Eigenschaft, um die absolute Helligkeit des Bildes festzulegen.

Syntax

Ausdruck.IncrementBrightness(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel der Wert der Brightness-Eigenschaft des Bildes geändert werden soll. Ein positiver Wert macht das Bild heller, ein negativer Wert macht es dunkler.

Anmerkungen

Sie können die Helligkeit eines Bildes nicht über den oberen oder unteren Grenzwert der Brightness-Eigenschaft hinaus anpassen. Wurde die Brightness-Eigenschaft beispielsweise am Anfang auf 0,9 gesetzt, und Sie geben für das Argument Increment den Wert 0,3 an, führt dies nicht zu einem Helligkeitsgrad von 1,2, sondern von 1,0, was der Obergrenze der Brightness-Eigenschaft entspricht.


Beispiel zur IncrementBrightness-Methode

In diesem Beispiel wird von der ersten Form in myDocument ein Duplikat erstellt, das anschließend verschoben und dunkler gemacht wird. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder um ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Duplicate
    .PictureFormat.IncrementBrightness -0.2
    .IncrementLeft 50
    .IncrementTop 50
End With


IncrementContrast-Methode

Ändert den Kontrast des Bildes um den angegebenen Wert. Verwenden Sie die Contrast-Eigenschaft, um den absoluten Kontrast des Bildes festzulegen.

Syntax

Ausdruck.IncrementContrast(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein PictureFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an, um wie viel der Wert der Contrast-Eigenschaft des Bildes geändert werden soll. Ein positiver Wert erhöht den Kontrast, ein negativer verringert ihn.

Anmerkungen

Sie können den Kontrast eines Bildes nicht über den oberen oder unteren Grenzwert der Contrast-Eigenschaft hinaus anpassen. Wurde die Contrast-Eigenschaft beispielsweise am Anfang auf 0,9 gesetzt, und Sie geben für das Argument Increment den Wert 0,3 an, so führt dies nicht zu einem Kontrastgrad von 1,2, sondern von 1,0, was der Obergrenze der Contrast-Eigenschaft entspricht.


Beispiel zur IncrementContrast-Methode

In diesem Beispiel wird in myDocument bei allen Bildern, die noch nicht den maximalen Kontrastgrad besitzen, der Kontrast erhöht.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.Type = msoPicture Or s.Type = msoLinkedPicture Then
        s.PictureFormat.IncrementContrast 0.1
    End If
Next


IncrementLeft-Methode

Verschiebt die angegebene Form in horizontaler Richtung um den angegebenen Wert in Punkt.

Syntax

Ausdruck.IncrementLeft(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Punkt), wie weit die Form horizontal verschoben wird. Ein positiver Wert verschiebt die Form nach rechts, ein negativer nach links.


Beispiel zur IncrementLeft-Methode

In diesem Beispiel wird die erste Form in myDocument dupliziert. Das Duplikat wird mit einer Füllung versehen, um 70 Punkt nach rechts und um 50 Punkt nach oben verschoben sowie um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


IncrementOffsetX-Methode

Ändert die horizontale Versetzung des Schattens um den angegebenen Wert in Punkt. Verwenden Sie die OffsetX-Eigenschaft, um die absolute horizontale Versetzung des Schattens anzugeben.

Syntax

Ausdruck.IncrementOffsetX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Punkt), wie weit die Versetzung des Schattens horizontal verschoben werden soll. Ein positiver Wert verschiebt den Schatten nach rechts, ein negativer nach links.


Beispiel zur IncrementOffsetX-Methode

In diesem Beispiel wird der Schatten der dritten Form in myDocument um 3 Punkt nach links verschoben.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).Shadow.IncrementOffsetX -3


IncrementOffsetY-Methode

Ändert die vertikale Versetzung des Schattens um den angegebenen Wert in Punkt. Verwenden Sie die OffsetY-Eigenschaft, um die absolute vertikale Versetzung des Schattens anzugeben.

Syntax

Ausdruck.IncrementOffsetY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShadowFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Punkt), wie weit die Versetzung des Schattens vertikal verschoben werden soll. Ein positiver Wert verschiebt den Schatten nach unten, ein negativer nach oben.


Beispiel zur IncrementOffsetY-Methode

In diesem Beispiel wird der Schatten der dritten Form in myDocument um 3 Punkt nach oben verschoben.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).Shadow.IncrementOffsetY -3


 IncrementRotation-Methode

IncrementRotation-Methode

Ändert die Drehung der angegebenen Form um die Z-Achse um die angegebene Gradzahl. Verwenden Sie die Rotation-Eigenschaft, um die absolute Drehung der Form anzugeben.

Syntax

Ausdruck.IncrementRotation(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Grad), wie weit die Form horizontal gedreht werden soll. Ein positiver Wert dreht die Form im Uhrzeigersinn, ein negativer gegen den Uhrzeigersinn.

Anmerkungen

Um eine dreidimensionale Form um die X-Achse oder die Y-Achse zu drehen, verwenden Sie die Methoden IncrementRotationX bzw. IncrementRotationY.


Beispiel zur IncrementRotation-Methode

In diesem Beispiel wird die erste Form in myDocument dupliziert. Das Duplikat wird mit einer Füllung versehen, um 70 Punkt nach rechts und um 50 Punkt nach oben verschoben sowie um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


 IncrementRotationX-Methode

IncrementRotationX-Methode

Ändert die Drehung der angegebenen Form um die X-Achse um die angegebene Gradzahl. Verwenden Sie die RotationX-Eigenschaft, um die absolute Drehung der Form um die X-Achse anzugeben.

Syntax

Ausdruck.IncrementRotationX(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Grad), um wie viel die Rotation der Form um die X-Achse geändert werden soll. Kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert neigt die Form nach oben, ein negativer nach unten.

Anmerkungen

Sie können die Rotation der angegebenen Form um die X-Achse nicht über den oberen oder unteren Grenzwert der RotationX-Eigenschaft (90 Grad bis -90 Grad) hinaus anpassen. Wurde die RotationX-Eigenschaft beispielsweise am Anfang auf 80 gesetzt, und Sie geben für das Argument Increment den Wert 40 an, so führt dies nicht zu einer Rotation von 120 Grad, sondern von 90 Grad, was der Obergrenze der RotationX-Eigenschaft entspricht.

Um die Rotation einer Form um die Y-Achse zu ändern, verwenden Sie die IncrementRotationY-Methode. Um die Rotation einer Form um die Z-Achse zu ändern, verwenden Sie die IncrementRotation-Methode.


Beispiel zur IncrementRotationX-Methode

In diesem Beispiel wird die erste Form in myDocument um 10 Grad nach oben geneigt. Damit Sie die Auswirkungen des Codes sehen können, muss es sich bei der ersten Form um eine projizierte Form handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).ThreeD.IncrementRotationX 10


 IncrementRotationY-Methode

IncrementRotationY-Methode

Ändert die Drehung der angegebenen Form um die Y-Achse um die angegebene Gradzahl. Verwenden Sie die RotationY-Eigenschaft, um die absolute Drehung der Form um die Y-Achse anzugeben.

Syntax

Ausdruck.IncrementRotationY(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Grad), um wie viel die Rotation der Form um die Y-Achse geändert werden soll. Kann ein Wert zwischen -90 und 90 sein. Ein positiver Wert neigt die Form nach links, ein negativer nach rechts.

Anmerkungen

Um die Rotation einer Form um die X-Achse zu ändern, verwenden Sie die IncrementRotationX-Methode. Um die Rotation einer Form um die Z-Achse zu ändern, verwenden Sie die IncrementRotation-Methode.

Sie können die Rotation der angegebenen Form um die Y-Achse nicht über den oberen oder unteren Grenzwert der RotationY-Eigenschaft (90 Grad bis -90 Grad) hinaus anpassen. Wurde die RotationY-Eigenschaft beispielsweise am Anfang auf 80 gesetzt, und Sie geben für das Argument Increment den Wert 40 an, führt dies nicht zu einer Rotation von 120 Grad, sondern von 90 Grad, was der Obergrenze der RotationY-Eigenschaft entspricht.


Beispiel zur IncrementRotationY-Methode

In diesem Beispiel wird die erste Form in myDocument um 10 Grad nach rechts geneigt. Damit Sie die Auswirkungen des Codes sehen können, muss es sich bei der ersten Form um eine projizierte Form handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).ThreeD.IncrementRotationY -10


IncrementTop-Methode

Verschiebt die angegebene Form in vertikaler Richtung um den angegebenen Wert in Punkt.

Syntax

Ausdruck.IncrementTop(Increment)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape-Objekt zurückgibt.

Increment Single erforderlich. Gibt an (in Punkt), wie weit die Form vertikal verschoben wird. Ein positiver Wert verschiebt die Form nach unten, ein negativer nach oben.


Beispiel zur IncrementTop-Methode

In diesem Beispiel wird die erste Form in myDocument dupliziert. Das Duplikat wird mit einer Füllung versehen, um 70 Punkt nach rechts und um 50 Punkt nach oben verschoben sowie um 30 Grad im Uhrzeigersinn gedreht.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Duplicate
    .Fill.PresetTextured msoTextureGranite
    .IncrementLeft 70
    .IncrementTop -50
    .IncrementRotation 30
End With


 InputBox-Methode

InputBox-Methode

Öffnet ein Dialogfeld für eine Benutzereingabe. Zurückgegeben werden die Informationen, die in das Dialogfeld eingegeben wurden.

Syntax

Ausdruck.InputBox(Prompt, Title, Default, Left, Top, HelpFile, HelpContextID, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Prompt String erforderlich. Der Text, der im Dialogfeld angezeigt werden soll. Dies kann eine Zeichenfolge, eine Zahl, ein Datum oder ein boolescher Wert sein. (Vor der Anzeige erzwingt Microsoft Excel automatisch eine Umwandlung dieses Werts in den Datentyp String).

Title Variant optional. Der Titel für das Eingabefeld. Ohne Angabe dieses Arguments wird der Titel "Eingabe" vorgegeben.

Default Variant optional. Hier legen Sie einen Wert fest, der bei Aufruf des Dialogfelds im Textfeld vorgegeben wird. Ohne Angabe dieses Arguments bleibt das Textfeld leer. Dieser Wert kann auch ein Range-Objekt sein.

Left Variant optional. Hier geben Sie die x-Koordinate für die Dialogfeldposition in Punkt an, und zwar relativ zur linken oberen Bildschirmecke.

Top Variant optional. Hier geben Sie die y-Koordinate für die Dialogfeldposition in Punkt an, und zwar relativ zur linken oberen Bildschirmecke.

HelpFile Variant optional. Der Name der Hilfedatei für dieses Eingabefeld. Sind die Argumente HelpFile und HelpContextID vorhanden, erscheint automatisch eine Schaltfläche ? im Dialogfeld.

HelpContextID Variant optional. Die Identifikationsnummer des Hilfethemas in der HelpFile.

Type Variant optional. Hier geben Sie den Datentyp des Rückgabewertes an. Ohne Angabe dieses Arguments gibt das Dialogfeld Text zurück. Zulässig ist einer der folgenden Werte oder eine Summe dieser Werte:

Wert | Bedeutung
0 | Formel
1 | Zahl
2 | Text (Zeichenfolge)
4 | Logischer Wert (True oder False)
8 | Zellbezug, z. B. ein Range-Objekt
16 | Fehlerwert, z. B. #N/A
64 | Wertematrix

Sie können die zulässigen Werte für das Type-Argument auch als Summe angeben. Damit etwa in einem Eingabefeld sowohl Text als auch Zahlen eingegeben werden können, setzen Sie Type auf 1 + 2.

Anmerkungen

InputBox eignet sich zur Anzeige eines einfachen Dialogfelds, so dass Informationen eingegeben werden können, die in einem Makro verwendet werden. Ein solches Dialogfeld besitzt je eine Schaltfläche für OK und Abbrechen. Wird auf die OK geklickt, gibt InputBox den Wert des Dialogfeldes aus. Wird auf Abbrechen geklickt, gibt InputBox den Wert False zurück.

Wird das Type-Argument auf 0 gesetzt, gibt InputBox die Formel in Form von Text aus, etwa "=2*PI()/360". Umfasst die Formel Bezüge, so werden diese in der A1-Bezugsart ausgegeben. (Mit ConvertFormula können Sie zwischen den verschiedenen Bezugsarten wechseln.)

Wird das Type-Argument auf 8 gesetzt, gibt InputBox ein Range-Objekt zurück. Mit Hilfe der Set-Anweisung können Sie das Ergebnis, wie im folgenden Beispiel, einem Range-Objekt zuweisen.

Set myRange = Application.InputBox(prompt := "Sample", type := 8)

Ohne eine Set-Anweisung wird die Variable auf den Wert in dem Bereich gesetzt, nicht etwa auf das Range-Objekt selbst.

Wenn Sie die InputBox-Methode dazu verwenden, vom Benutzer eine Formel abzufragen, so müssen Sie die Formel mit Hilfe der FormulaLocal-Eigenschaft einem Range-Objekt zuweisen. Die Eingabe der Formel erfolgt in der Sprache des Benutzers.

Die InputBox-Methode unterscheidet sich von der InputBox-Funktion insofern als es mit ihr möglich ist, die Eingabe des Anwenders auszuwerten und sie mit Microsoft Excel-Objekten, -Fehlerwerten und -Formeln zu verwenden. Beachten Sie, dass Application.InputBox die InputBox-Methode aufruft; InputBox ohne Objektkennzeichner ruft die InputBox-Funktion auf.


Beispiel zur InputBox-Methode

Im folgenden Beispiel wird der Benutzer zur Eingabe einer Zahl aufgefordert.

myNum = Application.InputBox("Enter a number")

Dieses Beispiel fordert den Benutzer dazu auf, eine Zelle in Sheet1 zu markieren. Dabei wird das Type-Argument verwendet, um sicherzustellen, dass der Rückgabewert ein zulässiger Zellbezug (ein Range-Objekt) ist.

Worksheets("Sheet1").Activate
Set myCell = Application.InputBox( _
    prompt:="Select a cell", Type:=8)


Insert-Methode

Syntax 1 (Range-Objekt): Fügt eine Zelle oder einen Zellenbereich in das Tabellen- oder Makroblatt ein und verschiebt die anderen Zellen entsprechend.

Syntax 2 (Characters-Objekt): Fügt eine Zeichenfolge vor den markierten Zeichen ein.

Syntax 1

Ausdruck.Insert(Shift)

Syntax 2

Ausdruck.Insert(String)

Ausdruck Ein erforderlicher Ausdruck, der ein Characters- oder Range-Objekt zurückgibt.

Shift Variant optional. Gibt an, wie die Zellen verschoben werden. Kann eine der folgenden XlInsertShiftDirection-Konstanten sein: xlShiftToRight oder xlShiftDown. Wird das Argument weggelassen, wird die Richtung anhand der Form des Bereichs festgelegt.

String String erforderlich. Die einzufügende Zeichenfolge.


InsertIndent-Methode

Fügt zum angegebenen Bereich einen Einzug hinzu.

Syntax

Ausdruck.InsertIndent(InsertAmount)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

InsertAmount Long erforderlich. Der Betrag, der zum aktuellen Einzug zu addieren ist.

Anmerkungen

Wird diese Eigenschaft benutzt, um die Einzugsebene auf eine Zahl kleiner als 0 (null) oder größer als 15 zu setzen, führt dieses zu einem Fehler.

Verwenden Sie die IndentLevel-Eigenschaft, um die Einzugsebene eines Bereichs zurückzugeben.


Beispiel zur InsertIndent-Methode

In diesem Beispiel wird die Einzugsebene in Zelle A10 verringert.

With Range("a10")
    .InsertIndent -1
End With


Intersect-Methode

Diese Methode gibt ein Range-Objekt zurück, das die rechteckige Schnittmenge von zwei oder mehreren Bereichen darstellt.

Syntax

Ausdruck.Intersect(Arg1, Arg2, ...)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Arg1, Arg2, ... Range erforderlich. Die Schnittmengenbereiche. Hier müssen mindestens zwei Range-Objekte angegeben werden.


Beispiel zur Intersect-Methode

Im folgenden Beispiel wird die Schnittmenge der benannten Bereiche rg1 und rg2 in Sheet1 markiert. Wenn sich die beiden Bereiche nicht überschneiden, wird eine Meldung angezeigt.

Worksheets("Sheet1").Activate
Set isect = Application.Intersect(Range("rg1"), Range("rg2"))
If isect Is Nothing Then
    MsgBox "Ranges do not intersect"
Else
    isect.Select
End If


 Item

Item

Gibt ein einzelnes Mitglied einer Auflistung zurück. Schreibgeschützt.

Item stellt das Standardmitglied einer Auflistung dar. Die beiden folgenden Codezeilen sind beispielsweise gleichwertig.

ActiveWorkbook.Worksheets.Item(1)
ActiveWorkbook.Worksheets(1)

Weitere Informationen über die Rückgabe eines einzelnen Mitglieds einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Um spezielle Informationen über die Item-Methode oder Eigenschaft einer bestimmten Auflistung zu erhalten, wählen Sie den Namen der Auflistung in der folgenden Liste.

AddIns | Adjustments | Areas
Axes | Borders | CalculatedFields
CalculatedItems | ChartGroups | ChartObjects
Charts | Comments | CubeFields
CustomViews | DataLabels | Dialogs
Filters | FormatConditions | GroupShapes
HPageBreaks | Hyperlinks | LegendEntries
Names | ODBCErrors | OLEDBErrors
OLEObjects | Panes | Parameters
Phonetics | PivotCaches | PivotFields
PivotFormulas | PivotItems | PivotTables
Points | PublishObjects | QueryTables
Range | RecentFiles | Scenarios
SeriesCollection | ShapeNodes | ShapeRange
Shapes | Sheets | Styles
Trendlines | VPageBreaks | Windows
Workbooks | Worksheets |


Item-Eigenschaft (AddIns-Auflistung)

Gibt ein einzelnes AddIn-Objekt aus einer AddIns-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein AddIns-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Add-Ins.


Item-Eigenschaft (Adjustments-Objekt)

Gibt den Korrekturwert, der durch das Index-Argument angegeben wird, zurück oder legt diesen fest. Bei linearen Korrekturen bezieht sich ein Wert von 0.0 im Allgemeinen auf die linke oder oberste Ecke der Form, ein Wert von 1.0 hingegen auf die rechte oder unterste Ecke der Form. Bei einigen Formen können Korrekturen jedoch die Formgrenzen überschreiten. Bei radialen Korrekturen bezieht sich ein Wert von 1.0 auf die Breite der Form. Bei Winkelkorrekturen wird der Korrekturwert in Grad angegeben. Die Item-Eigenschaft wird nur auf Formen mit Korrekturen angewandt. Single Schreib-Lese-Zugriff.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Adjustments-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer der Korrektur.

Anmerkungen

AutoFormen, Verbindungen und WordArt-Objekte können bis zu acht Korrekturen haben.


Item-Eigenschaft (Areas-Auflistung)

Gibt ein einzelnes Range-Objekt aus einer Areas-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Areas-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Bereichs.


Beispiel zur Item-Eigenschaft (Areas-Auflistung)

In diesem Beispiel wird der erste Bereich der aktuellen Auswahl gelöscht, falls diese mehrere Bereiche besitzt.

If Selection.Areas.Count <> 1 Then
    Selection.Areas.Item(1).Clear
End If


Item-Eigenschaft (Borders-Auflistung)

Gibt ein Border-Objekt zurück, das einen der Ränder entweder eines Zellbereichs oder einer Formatvorlage zurückgibt. Schreibgeschützt.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine Borders-Auflistung zurückgibt.

Index Long erforderlich. Der zurückzugebende Rand. Kann eine der folgenden XlBordersIndex-Konstanten sein: xlInsideHorizontal, xlInsideVertical, xlDiagonalDown, xlDiagonalUp, xlEdgeBottom, xlEdgeLeft, xlEdgeRight oder xlEdgeTop.


Beispiel zur Item-Eigenschaft (Borders-Auflistung)

Im folgenden Beispiel wird die Farbe für den unteren Rand der Zellen A1:G1 festgelegt.

Worksheets("Sheet1").Range("a1:g1"). _
    Borders.Item(xlEdgeBottom).Color = RGB(255, 0, 0)


Item-Eigenschaft (Charts-Auflistung)

Gibt ein einzelnes Chart-Objekt aus einer Charts-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein Charts-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Diagramms.


Beispiel zur Item-Eigenschaft (Charts-Auflistung)

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, die sich die Trendlinie in Chart1 nach vorne und hinten erstreckt. Das Beispiel muss bei einem 2D-Säulendiagramm ausgeführt werden, das eine einzige Datenreihe mit einer Trendlinie enthält.

With Charts.Item("Chart1").SeriesCollection(1).Trendlines(1)
    .Forward = 5
    .Backward = .5
End With


Item-Eigenschaft (CubeFields-Auflistung)

Gibt ein einzelnes CubeField-Objekt aus der CubeFields-Auflistung zurück. Schreibgeschützt.

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein CubeFields-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des CubeField-Objekts.


 Beispiel zur Item-Eigenschaft (CubeFields-Auflistung)

Beispiel zur Item-Eigenschaft (CubeFields-Auflistung)

In diesem Beispiel wird der erste PivotTable-Bericht gesucht, dessen erster Cube-Feldname die Zeichenfolge "Paris" enthält. Die Variable blnFoundName vom Typ Boolean wird auf True festgelegt, falls der Name gefunden wird.

blnFoundName = False
For Each objPT in ActiveSheet.PivotTables
    Set objCubeField = _
        objPT.CubeFields.Item(1)
    If instr(1,objCubeField.Name, "Paris") <> 0 Then
        blnFoundName = True
        Exit For
    End If
Next objPT


Item-Eigenschaft (Dialogs-Auflistung)

Gibt ein Dialog-Objekt zurück, das ein einzelnes integriertes Dialogfeld darstellt. Schreibgeschützt.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der eine Dialogs-Auflistung zurückgibt.

Index Long erforderlich. Das zurückzugebende Dialogfeld. Kann eine beliebige XlBuiltInDialog-Konstante sein.

Anmerkungen

Mit Hilfe der Item-Eigenschaft der Dialogs-Auflistung und der Show-Methode können Sie ungefähr 200 integrierte Dialogfelder anzeigen. Jedem Dialogfeld ist eine Konstante zugewiesen; die Konstanten beginnen alle mit "xlDialog".

Eine Tabelle der verfügbaren Konstanten und ihrer entsprechenden Argumente finden Sie unter Integrierte Dialogfeld-Argumentlisten.

Die Item-Eigenschaft der Dialogs-Auflistung kann zu einem Fehler führen, wenn Sie versuchen, ein Dialogfeld in einem falschen Kontext anzuzeigen. Um beispielsweise das Dialogfeld Datenbeschriftung (unter Verwendung des Visual Basic Ausdrucks Application.Dialogs(xlDialogDataLabel).Show) anzuzeigen, muss das aktive Blatt ein Diagramm sein; andernfalls führt die Eigenschaft zu einem Fehler.


Beispiel zur Item-Eigenschaft (Dialogs-Auflistung)

In diesem Beispiel wird das Dialogfeld Öffnen angezeigt und die Option Schreibgeschützt markiert.

Application.Dialogs.Item(xlDialogOpen).Show arg3:=True


Item-Eigenschaft (Filters-Auflistung)

Gibt aus einer Filters-Auflistung ein einzelnes Filter-Objekt zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Filters-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Filters.


Beispiel zur Item-Eigenschaft (Filters-Auflistung)

In dem folgenden Beispiel wird eine Variable auf den Wert der On-Eigenschaft des Filters für die erste Spalte in dem gefilterten Bereich im Tabellenblatt "Crew" festgelegt.

Set w = Worksheets("Crew")
If w.AutoFilterMode Then
    filterIsOn = w.AutoFilter.Filters.Item(1).On
End If


Item-Eigenschaft (HPageBreaks-Auflistung)

Gibt ein einzelnes HPageBreak-Objekt aus einer HPageBreaks-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein HPageBreaks-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des horizontalen Seitenwechsels.


Beispiel zur Item-Eigenschaft (HPageBreaks-Auflistung)

In diesem Beispiel wird die Position des ersten horizontalen Seitenwechsels geändert.

Worksheets(1).HPageBreaks.Item(1).Location = .Range("e5")


Item-Eigenschaft (Hyperlinks-Auflistung)

Gibt ein einzelnes Hyperlink-Objekt aus einer Hyperlinks-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlinks-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Hyperlinks.


Beispiel zur Item-Eigenschaft (Hyperlinks-Auflistung)

Im folgenden Beispiel wird der erste Hyperlink in Zelle E5 aktiviert.

Worksheets(1).Range("E5").Hyperlinks.Item(1).Follow


Item-Eigenschaft (Panes-Auflistung)

Gibt ein einzelnes Pane-Objekt aus einer Panes-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Panes-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Ausschnitts.


Beispiel zur Item-Eigenschaft (Panes-Auflistung)

In diesem Beispiel wird das Fenster geteilt, in dem das erste Tabellenblatt angezeigt wird. Danach wird in dem Ausschnitt in der unteren linken Fensterecke ein Bildlauf durchgeführt, bis die fünfte Zeile oben im Ausschnitt zu sehen ist.

Worksheets(1).Activate
ActiveWindow.Split = True
ActiveWindow.Panes.Item(3).ScrollRow = 5


Item-Eigenschaft (Phonetics-Auflistung)

Gibt ein einzelnes Phonetic-Objekt aus der Phonetics-Auflistung zurück. Object Schreibgeschützt.

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein Phonetics-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Phonetic-Objekts.


Beispiel zur Item-Eigenschaft (Phonetics-Auflistung)

In diesem Beispiel wird die erste phonetische Textzeichenfolge in der aktiven Zelle angezeigt.

ActiveCell.Phonetics.Item(1).Visible = True


Item-Eigenschaft (PublishObjects-Auflistung)

Gibt ein PublishObject-Objekt aus der PublishObjects-Auflistung zurück. Schreibgeschützt.

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein PublishObjects-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des PublishObject-Objekts.


Beispiel zur Item-Eigenschaft (PublishObjects-Auflistung)

In diesem Beispiel wird der Bezeichner aus einem <DIV>-Tag bestimmt und die Zeile in einer Webseite (q198.htm) gesucht, die von einer Arbeitsmappe aus gespeichert wurde. In diesem Beispiel wird ebenfalls eine Kopie der Webseite erstellt (newq1.htm) und in der Kopie der Datei eine Kommentarzeile vor dem <DIV>-Tag eingefügt.

strTargetDivID = ActiveWorkbook.PublishObjects.Item(1).DivID
Open "\\server1\reports\q198.htm" For Input As #1
Open "\\server1\reports\newq1.htm" For Output As #2
While Not EOF(1)
    Line Input #1, strFileLine
    If InStr(strFileLine, strTargetDivID) > 0 And _
        InStr(strFileLine, "<div") > 0 Then
            Print #2, "<!--Saved item-->"
    End If
    Print #2, strFileLine
Wend
Close #2
Close #1


Item-Eigenschaft (Range-Objekt)

Gibt ein Range-Objekt zurück, das einen versetzten Bereich in Bezug zum angegeben Bereich darstellt. Schreibgeschützt.

Syntax 1

Ausdruck.Item(RowIndex, ColumnIndex)

Syntax 2

Ausdruck.Item(RowIndex)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

RowIndex Syntax 1: Variant erforderlich. Die Zeilennummer der Zelle, auf die Sie zugreifen möchten, beginnend mit 1 für die erste Zeile des Bereichs.

Syntax 2: Variant erforderlich. Der Index der Zelle, auf die Sie zugreifen möchten, in der Reihenfolge von links nach rechts und danach nach unten. Range.Item(1) gibt die obere linke Zelle des Bereichs zurück; Range.Item(2) gibt die nächste Zelle rechts der oberen linken Zelle zurück.

ColumnIndex Variant optional. Eine Zahl oder eine Zeichenfolge, die die Spaltennummer der Zelle angibt, auf die Sie zugreifen möchten, beginnend mit 1 bzw "A" für die erste Spalte des Bereichs.

Anmerkungen

Syntax 1 verwendet eine Zeilennummer und eine Spaltennummer bzw. Spaltenbuchstaben als Indexargumente. Weitere Informationen über diese Syntax finden Sie unter Range-Objekt. Die Argumente RowIndex und ColumnIndex geben einen relativen Versatz an. So gibt also ein RowIndex von 1 Zellen in der ersten Zeile des Bereichs, nicht in der ersten Zeile des Tabellenblattes zurück. Steht die Markierung beispielsweise auf Zelle C3, so gibt Selection.Cells(2, 2) die Zelle D4 zurück (Sie können die Item-Eigenschaft verwenden, um außerhalb des ursprünglichen Bereichs zu indizieren).


Beispiel zur Item-Eigenschaft (Range-Objekt)

In diesem Beispiel wird der Bereich A1:A10 der Sheet1 basierend auf dem Inhalt der Zelle A1 ausgefüllt.

Worksheets("Sheet1").Range.Item("A1:A10").FillDown


Item-Eigenschaft (RecentFiles-Auflistung)

Gibt ein einzelnes RecentFile-Objekt aus einer RecentFiles-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein RecentFiles-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer der Datei.


Beispiel zur Item-Eigenschaft (RecentFiles-Auflistung)

In diesem Beispiel wird die zweite Datei aus der Liste der zuletzt geöffneten Dateien geöffnet.

Application.RecentFiles.Item(2).Open


Item-Eigenschaft (Sheets-Auflistung)

Gibt ein einzelnes Chart- oder Worksheet-Objekt aus einer Sheets-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Sheets-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Blattes.


Beispiel zur Item-Eigenschaft (Sheets-Auflistung)

In diesem Beispiel wird Sheet1 aktiviert.

Sheets.Item("sheet1").Activate


Item-Eigenschaft (Styles-Auflistung)

Gibt ein einzelnes Style-Objekt aus einer Styles-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Styles-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Formatvorlage.


Beispiel zur Item-Eigenschaft (Styles-Auflistung)

In diesem Beispiel wird die Formatvorlage "Standard" der ersten Arbeitsmappe geändert, indem die Bold-Eigenschaft festgelegt wird.

ActiveWorkbook.Styles.Item("Normal").Font.Bold = True


Item-Eigenschaft (VPageBreaks-Auflistung)

Gibt ein einzelnes VPageBreak-Objekt aus einer VPageBreaks-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein VPageBreaks-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des vertikalen Seitenwechsels.


Beispiel zur Item-Eigenschaft (VPageBreaks-Auflistung)

In diesem Beispiel wird die Position des ersten vertikalen Seitenwechsels geändert.

Worksheets(1).VPageBreaks.Item(1).Location = .Range("e5")


Item-Eigenschaft (Windows-Auflistung)

Gibt ein einzelnes Window-Objekt aus einer Windows-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Windows-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des Fensters.


Beispiel zur Item-Eigenschaft (Windows-Auflistung)

In diesem Beispiel wird das aktive Fenster maximiert.

Windows.Item(1).WindowState = xlMaximized


Item-Eigenschaft (Workbooks-Auflistung)

Gibt ein einzelnes Workbook-Objekt aus einer Workbooks-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbooks-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Arbeitsmappe.


Beispiel zur Item-Eigenschaft (Workbooks-Auflistung)

In diesem Beispiel wird die Variable am auf die Arbeitsmappe mit "Meiaddin.xla" gesetzt.

Set wb = Workbooks.Item("myaddin.xla")


Item-Eigenschaft (Worksheets-Auflistung)

Gibt ein einzelnes Worksheet-Objekt aus einer Worksheets-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheets-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Tabellenblattes.


Beispiel zur Item-Eigenschaft (Worksheets-Auflistung)

In diesem Beispiel wird die Position des ersten vertikalen Seitenwechsels geändert.

Worksheets.Item(1).VPageBreaks(1).Location = .Range("e5")


Beispiel zur Item-Eigenschaft (AddIns-Auflistung)

In diesem Beispiel wird der Status des Add-Ins "Analysis ToolPak" angezeigt. Beachten Sie, dass die Zeichenfolge, die als Index zur AddIns-Methode verwendet wird, die Title-Eigenschaft des AddIn-Objekts ist.

If AddIns.Item("Analysis ToolPak").Installed = True Then
    MsgBox "Analysis ToolPak add-in is installed"
Else
    MsgBox "Analysis ToolPak add-in is not installed"
End If


Justify-Methode

Ordnet den Text in einem Bereich neu an, so dass er den Bereich gleichmäßig ausfüllt.

Syntax

Ausdruck.Justify

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Anmerkungen

Ist der Bereich nicht groß genug, so zeigt Microsoft Excel eine Meldung, dass der Text nach unten über den Bereich hinaus fortgesetzt wird. Wenn Sie auf OK klicken, wird der Inhalt in Zellen unterhalb des markierten Bereichs durch bündig angeordneten Text ersetzt. Soll diese Meldung nicht angezeigt werden, so legen Sie für die DisplayAlerts-Eigenschaft den Wert False fest. Der Zellinhalt unterhalb des markierten Bereichs wird dann ohne Meldung durch den Text ersetzt.


Beispiel zur Justify-Methode

In diesem Beispiel wird der Text in Zelle A1 in Sheet1 bündig angeordnet.

Worksheets("Sheet1").Range("A1").Justify


LargeScroll-Methode

Führt einen seitenweisen Bildlauf des Fensterinhalts durch.

Syntax

Ausdruck.LargeScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt ausgibt.

Down Variant optional. Die Anzahl der Seiten, um die der Bildlauf nach unten durchgeführt werden soll.

Up Variant optional. Die Anzahl der Seiten, um die der Bildlauf nach oben durchgeführt werden soll.

ToRight Variant optional. Die Anzahl der Seiten, um die der Bildlauf nach rechts durchgeführt werden soll.

ToLeft Variant optional. Die Anzahl der Seiten, um die der Bildlauf nach links durchgeführt werden soll.

Anmerkungen

Wird sowohl Down als auch Up festgelegt, wird der Bildlauf entsprechend der Differenz der beiden Argumente durchgeführt. Wenn z.B. Down den Wert 3 und Up den Wert 6 hat, wird der Bildlauf um drei Seiten nach oben durchgeführt.

Wird sowohl ToLeft als auch ToRight festgelegt, wird der Bildlauf entsprechend der Differenz der beiden Argumente durchgeführt. Wenn z.B. ToLeft den Wert 3 und ToRight den Wert 6 hat, wird der Bildlauf um drei Seiten nach rechts durchgeführt.

Für jedes der Argumente kann auch eine negative Zahl festgelegt werden.


Beispiel zur LargeScroll-Methode

In diesem Beispiel werden die Inhalte des aktiven Fensters in Sheet1 um drei Seiten nach unten durchgeführt.

Worksheets("Sheet1").Activate
ActiveWindow.LargeScroll down:=3


LegendEntries-Methode

Gibt ein Objekt zurück, das einen einzelnen Legendeneintrag (ein LegendEntry-Objekt, Syntax 1) oder eine Auflistung von Legendeneinträgen (ein LegendEntries-Objekt, Syntax 2) der Legende darstellt.

Syntax 1

Ausdruck.LegendEntries(Index)

Syntax 2

Ausdruck.LegendEntries

Ausdruck Ein erforderlicher Ausdruck, der ein Legend-Objekt zurückgibt.

Index Variant optional. Die Nummer des Legendeneintrags.


Beispiel zur LegendEntries-Methode

In diesem Beispiel wird die Schriftart für den ersten Legendeneintrag in Chart1 festgelegt.

Charts("Chart1").Legend.LegendEntries(1).Font.Name = "Arial"


LineGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Liniendiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Liniendiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.LineGroups(Index)

Syntax 2

Ausdruck.LineGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur LineGroups-Methode

In diesem Beispiel wird die 3D-Liniengruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird. Wenden Sie das Beispiel auf ein 2D-Diagramm an.

Charts("Chart1").LineGroups(1).VaryByCategories = True


LinkInfo-Methode

Gibt das Verknüpfungsdatum und den Aktualisierungsstatus zurück.

Syntax

Ausdruck.LinkInfo(Name, LinkInfo, Type, EditionRef)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Name String erforderlich. Der Name der Verknüpfung, wie er von der LinkSources-Methode zurückgegeben wird.

LinkInfo Long erforderlich. Die Art der zurückzugebenden Informationen. Kann eine der folgenden XlLinkInfo-Konstanten sein: xlUpdateState oder xlEditionDate. xlEditionDate ist nur für Auflagen gültig. Bei xlUpdateState gibt diese Methode 1 zurück, wenn die Verknüpfung automatisch aktualisiert wird, und 2, wenn sie manuell aktualisiert werden muss.

Type Variant optional. Die Art der zurückzugebenden Verknüpfung. Kann eine der folgenden XlLinkInfoType-Konstanten sein: xlLinkInfoOLELinks (auch für DDE-Verknüpfungen), xlLinkInfoPublishers oder xlLinkInfoSubscribers.

EditionRef Variant optional. Handelt es sich bei der Verknüpfung um eine Auflage, wird mit diesem Argument der Bezug auf die Auflage in der Z1S1-Schreibweise angegeben. Dieses Argument ist erforderlich, wenn die Arbeitsmappe mehrere Verleger oder Abonnenten mit demselben Namen enthält.


Beispiel zur LinkInfo-Methode

In diesem Beispiel wird ein Meldungsfeld angezeigt, falls die Verknüpfung automatisch aktualisiert wird.

If ActiveWorkbook.LinkInfo( _
        "Word.Document|Document1!'!DDE_LINK1", xlUpdateState, _
            xlOLELinks) = 1 Then
    MsgBox "Link updates automatically"
End If


LinkSources-Methode

Gibt eine Matrix mit Verknüpfungen in der Arbeitsmappe zurück. Die Namen in der Matrix entsprechen den Namen der verknüpften Dokumente, Auflagen oder DDE- bzw. OLE-Server. Wenn keine Verknüpfungen bestehen, wird Empty zurückgegeben.

Syntax

Ausdruck.LinkSources(Type)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Type Optional. Der Typ der zurückzugebenden Verknüpfung. Kann eine der folgenden XlLink-Konstanten sein: xlExcelLinks, xlOLELinks (auch für DDE-Verknüpfungen), xlPublishers oder xlSubscribers.

Anmerkungen

Das Format der Matrix ist für alle Typen eindimensional, mit Ausnahme von Verleger und Abonnent. Die zurückgegebenen Zeichenfolgen enthalten den Namen der Verknüpfungsquelle in der für den jeweiligen Verknüpfungstyp geeigneten Schreibweise. In DDE-Verknüpfungen wird z. B. die Syntax "Server|Dokument!Element" verwendet.

Bei Verleger- und Abonnentenverknüpfungen ist die zurückgegebene Matrix zweidimensional. Die erste Spalte der Matrix enthält die Namen der Auflage, und die zweite Spalte enthält die Bezüge auf die Auflagen in Form von Text.


Beispiel zur LinkSources-Methode

In diesem Beispiel wird eine Liste der OLE- und DDE-Verknüpfungen in der aktiven Arbeitsmappe angezeigt. Wenden Sie das Makro auf eine Arbeitsmappe an, die mindestens ein verknüpftes Microsoft Word-Objekt enthält.

aLinks = ActiveWorkbook.LinkSources(xlOLELinks)
If Not IsEmpty(aLinks) Then
    For i = 1 To UBound(aLinks)
        MsgBox "Link " & i & ":" & Chr(13) & aLinks(i)
    Next i
End If


List-Methode

Gibt die Texteinträge des angegebenen Listenfeldes oder des Kombinationsfeldes als Matrix von Zeichenfolgen zurück oder legt die Einträge fest. Gibt auch einen einzelnen Texteintrag zurück oder legt ihn fest. Befinden sich keine Einträge in der Liste, so tritt ein Fehler auf.

Syntax

Ausdruck.List(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ControlFormat-Objekt zurückgibt.

Index Variant optional. Die Indexnummer eines einzelnen zurückzugebenden oder festzulegenden Texteintrags. Wenn dieses Argument nicht angegeben wird, wird die gesamte Liste als Matrix von Zeichenfolgen zurückgegeben oder festgelegt.

Anmerkungen

Wenn Sie diese Methode verwenden, werden alle mit der ListFillRange-Eigenschaft festgelegten Bereiche gelöscht.


 ListFormulas-Methode

ListFormulas-Methode

Erstellt in einem eigenen Tabellenblatt eine Liste berechneter PivotTable-Elemente und -Felder.

Syntax

Ausdruck.ListFormulas

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Anmerkungen

Diese Methode steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur ListFormulas-Methode

In diesem Beispiel wird eine Liste berechneter Elemente und Felder des ersten PivotTable-Berichts im ersten Tabellenblatt erstellt

Worksheets(1).PivotTables(1).ListFormulas


ListNames-Methode

Fügt eine Liste aller nicht ausgeblendeten Namen im Tabellenblatt ein beginnend bei der ersten Zelle des Bereichs.

Syntax

Ausdruck.ListNames

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Anmerkungen

Mit der Names-Eigenschaft können Sie eine Auflistung aller Namen in einem Tabellenblatt zurückgeben.


Beispiel zur ListNames-Methode

In diesem Beispiel wird eine Liste der in Sheet1 auf Arbeitsmappen- und Tabellenblattebene definierten Namen in Zelle A1 in Sheet1 eingefügt.

Worksheets("Sheet1").Range("A1").ListNames


Location-Methode

Verschiebt das Diagramm an einen neuen Ort.

Syntax

Ausdruck.Location(Where, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Where Long erforderlich. Der Ort, an den das Diagramm verschoben werden soll. Dies kann eine der folgenden XlChartLocation-Konstanten sein: xlLocationAsNewSheet, xlLocationAsObject oder xlLocationAutomatic.

Name Variant optional; erforderlich wenn Where den Wert xlLocationAsObject besitzt. Der Name des Blatts, in das das Diagramm eingebettet wird, falls Where den Wert xlLocationAsObject besitzt, oder der Name des neuen Blatts, falls Where den Wert xlLocationAsNewSheet besitzt.


Beispiel zur Location-Methode

In diesem Beispiel wird das eingebettete Diagramm in das neue Diagrammblatt "Monthly Sales" verschoben.

Worksheets(1).ChartObjects(1).Chart _
    .Location xlLocationAsNewSheet, "Monthly Sales"


MacroOptions-Methode

Entspricht den Optionen im Dialogfeld Makrooptionen.

Syntax

Ausdruck.MacroOptions(Macro, Description, HasMenu, MenuText, HasShortcutKey, ShortcutKey, Category, StatusBar, HelpContextID, HelpFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Macro Variant optional. Der Name des Makros.

Description Variant optional. Die Beschreibung des Makros.

HasMenu Variant optional. Dieses Argument wird ignoriert.

MenuText Variant optional. Dieses Argument wird ignoriert.

HasShortcutKey Variant optional. Wenn True, wird dem Makro eine Tastenkombination zugeordnet (ShortcutKey muss ebenfalls angegeben werden). Wenn das Argument den Wert False besitzt, wird dem Makro keine Tastenkombination zugewiesen. Ist diesem Makro schon eine Tastenkombination zugeordnet, wird diese entfernt, wenn Sie das Argument auf False setzen. Der Standardwert ist False.

ShortcutKey Variant optional. Erforderlich, wenn HasShortcutKey den Wert True besitzt. Andernfalls wird das Argument ignoriert. Die Tastenkombination.

Category Variant optional. Eine Ganzzahl, die die Funktionskategorie des Makros angibt (z.B. Finanzmathematisch, Datum & Zeit oder Benutzerdefiniert).

StatusBar Variant optional. Der Statusleistentext des Makros.

HelpContextId Variant optional. Eine Ganzzahl, die die Hilfe-Identifikation für das Hilfe-Thema, das dem Makro zugeordnet ist, angibt.

HelpFile Variant optional. Der Name der Hilfedatei, die das Hilfethema beinhaltet, das durch das Argument HelpContextId angegeben wurde.


Beispiel zur MacroOptions-Methode

In diesem Beispiel wird dem Makro "DoRand" eine Tastenkombination zugewiesen.

Application.MacroOptions Macro:="DoRand", _
    HasShortcutKey:=True, ShortcutKey:="Z"


MailLogoff-Methode

Beendet eine von Microsoft Excel aufgebaute MAPI-Mail-Sitzung.

Syntax

Ausdruck.MailLogoff

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Diese Methode kann nicht zum Schließen oder Abmelden von Microsoft Mail verwendet werden.


Beispiel zur MailLogoff-Methode

In diesem Beispiel wird, falls vorhanden, die aufgebaute Mail-Sitzung beendet.

If Not IsNull(Application.MailSession) Then Application.MailLogoff


MailLogon-Methode

Meldet sich beim MAPI-Mail-System oder Microsoft Exchange an und baut eine Mail-Sitzung auf. Wenn Microsoft Mail noch nicht ausgeführt wird, müssen Sie diese Methode zum Aufbauen einer Mail-Sitzung verwenden, bevor die Funktionen zum Verteilen oder Weiterleiten von Dokumenten eingesetzt werden können.

Syntax

Ausdruck.MailLogon(Name, Password, DownloadNewMail)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Name Variant optional. Der Name des Mail-Kontos oder des Microsoft Exchange-Profils. Ohne Angabe wird der Standardname des Mail-Kontos eingesetzt.

Password Variant optional. Das Kennwort des Mail-Kontos. Dieses Argument wird in Microsoft Exchange ignoriert.

DownloadNewMail Variant optional. Wenn True, werden neue Nachrichten sofort geladen.

Anmerkungen

Zuvor von Microsoft Excel aufgebaute Mail-Sitzungen werden beendet, bevor versucht wird, eine neue Sitzung aufzubauen.

Um in der Mail-Standardsitzung des Systems zu arbeiten, geben Sie keinen Namen und kein Kennwort an.


Beispiel zur MailLogon-Methode

In diesem Beispiel erfolgt eine Anmeldung beim Mail-System. Neue Nachrichten werden sofort geladen.

If IsNull(Application.MailSession) Then
    Application.MailLogon "oscarx", "mypassword", True
End If


Merge-Methode

Syntax 1: Führt die Szenarios aus einem anderen Blatt in der Scenarios-Auflistung zusammen.

Syntax 2: Führt die Formatvorlagen aus einer anderen Arbeitsmappe in der Styles-Auflistung zusammen.

Syntax 3: Erstellt eine zusammengeführte Zelle aus dem angegebenen Range-Objekt.

Syntax 1

Ausdruck.Merge(Source)

Syntax 2

Ausdruck.Merge(Workbook)

Syntax 3

Ausdruck.Merge(Across)

Ausdruck Erforderlich. Ein Ausdruck, der ein Scenarios-Objekt (Syntax 1), ein Styles-Objekt (Syntax 2) oder ein Range-Objekt (Syntax 3) zurückgibt.

Source Variant erforderlich. Der Name des Blatts mit den Szenarios, die zusammengeführt werden sollen, oder ein Worksheet-Objekt, das das Blatt darstellt.

Workbook Variant erforderlich. Ein Workbook-Objekt, das die Arbeitsmappe mit den Formatvorlagen darstellt, die zusammengeführt werden sollen.

Across Variant optional. True, wenn Zellen in allen Zeilen des angegebenen Bereichs als einzelne zusammengeführte Zellen zusammengeführt werden. Der Vorgabewert ist False.

Anmerkungen

Der Wert eines zusammengeführten Bereichs ist der Wert, der in der oberen linken Ecke des zusammengeführten Bereichs für die Zelle angegeben ist.


MergeWorkbook-Methode

Führt Änderungen einer Arbeitsmappe in einer geöffneten Arbeitsmappe zusammen.

Syntax

Ausdruck.MergeWorkbook(Filename)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Filename String erforderlich. Der Dateiname der Arbeitsmappe mit den Änderungen, die in die geöffnete Arbeitsmappe eingefügt werden sollen.


Beispiel zur MergeWorkbook-Methode

In diesem Beispiel werden die Änderungen aus Mappe1.xls in der aktiven Arbeitsmappe zusammengeführt.

ActiveWorkbook.MergeWorkbook "Book1.xls"


Modify-Methode

Ändert die Datenüberprüfung oder das bedingte Format. Um weitere Informationen zu erhalten, klicken Sie auf das Objekt, das Sie ändern möchten.

FormatCondition

Validation


Modify-Methode (FormatCondition-Objekt)

Ändert ein bestehendes bedingtes Format.

Syntax

Ausdruck.Modify(Type, Operator, Formula1, Formula2)

Ausdruck Erforderlich. Ein Ausdruck, der ein FormatCondition-Objekt zurückgibt.

Type Long erforderlich. Legt fest, ob das bedingte Format auf einem Zellwert oder auf einem Ausdruck basiert. Dies kann eine der beiden folgenden XlFormatConditionType-Konstanten sein: xlCellValue oder xlExpression.

Operator Variant optional. Der bedingte Format-Operator. Dies kann eine der folgenden XlFormatConditionOperator-Konstanten sein: xlBetween, xlEqual, xlGreater, xlGreaterEqual, xlLess, xlLessEqual, xlNotBetween oder xlNotEqual. Wenn Type den Wert xlExpression besitzt, wird das Operator-Argument ignoriert.

Formula1 Variant optional. Der mit dem bedingten Format verknüpfte Wert oder Ausdruck. Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein.

Formula2 Variant optional. Der mit dem zweiten Teil des bedingten Formats verknüpfte Ausdruck, wenn Operator den Wert xlBetween oder xlNotBetween besitzt. Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein.


Beispiel zur Modify-Methode (FormatCondition-Objekt)

In diesem Beispiel wird ein bestehendes bedingtes Format für die Zellen E1:E10 geändert.

Worksheets(1).Range("e1:e10").FormatConditions(1) _
    .Modify xlCellValue, xlLess, "=$a$1"


Modify-Methode (Validation-Objekt)

Modifiziert Validierung für einen Bereich.

Syntax

Ausdruck.Modify(Type, AlertStyle, Operator, Formula1, Formula2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Validation-Objekt zurückgibt.

Type Long erforderlich. Der Gültigkeitstyp. Dabei kann es sich um eine der folgenden XlDVType-Konstanten handeln: xlValidateCustom, xlValidateDate, xlValidateDecimal, xlValidateInputOnly, xlValidateList, xlValidateTextLength, xlValidateTime oder xlValidateWholeNumber.

AlertStyle Variant optional. Der Stil der Validierungswarnung. Dabei kann es sich um eine der folgenden XlDVAlertStyle-Konstanten handeln: xlValidAlertInformation, xlValidAlertStop oder xlValidAlertWarning.

Operator Variant optional. Der Validierungs-Operator. Dabei kann es sich um eine der folgenden XlFormatConditionOperator-Konstanten handeln: xlBetween, xlEqual, xlGreater, xlGreaterEqual, xlLess, xlLessEqual, xlNotBetween oder xlNotEqual.

Formula1 Variant optional. Der erste Teil der Validierungsgleichung.

Formula2 Variant optional. Der zweite Teil der Validierung, wenn es sich bei dem Operator um xlBetween oder xlNotBetween handelt (sonst wird dieses Argument ignoriert).

Anmerkungen

Die Modify-Methode erfordert, abhängig vom Gültigkeitstyp, unterschiedliche Argumente, wie in der folgenden Tabelle dargestellt.

Gültigkeitstyp | Argumente
xlValidateCustom | Formula1 ist erforderlich, Formula2 wird ignoriert. Formula1 muss einen Ausdruck enthalten, der bei einer gültigen Dateneingabe True und bei einer ungültigen False zurückgibt.
xlInputOnly | AlertStyle, Formula1 und Formula2 werden nicht verwendet werden.
xlValidateList | Formula1 ist erforderlich, Formula2 wird ignoriert. Formula1 muss entweder eine durch Kommata getrennte Werteliste oder einen Verweis auf ein Tabellenblatt mit dieser Liste enthalten.
xlValidateWholeNumber, xlValidateDate, xlValidateDecimal, xlValidateTextLength oder xlValidateTime | Mindestens Formula1 oder Formula2 müssen, beide Werte können angegeben werden.


Beispiel zur Modify-Methode (Validation-Objekt)

In diesem Beispiel wird die Validierung für Zelle E5 geändert.

Range("e5").Validation _
    .Modify xlValidateList, xlValidAlertStop, _
    xlBetween, "=$A$1:$A$10"


Move-Methode

Verschiebt das Blatt an eine andere Position in der Arbeitsmappe.

Syntax

Ausdruck.Move(Before, After)

Ausdruck Ein erforderlicher Ausdruck, der ein Objekt zurückgibt, auf das diese Methode angewendet werden soll.

Before Variant optional. Das Blatt, vor das dieses Blatt geschoben wird. Sie können Before nicht angeben, wenn Sie After angegeben haben.

After Variant optional. Das Blatt, hinter das dieses Blatt geschoben wird. Sie können After nicht angeben, wenn Sie Before angegeben haben.

Anmerkungen

Wenn Sie weder Before noch After angeben, erstellt Microsoft Excel eine neue Arbeitsmappe, die das verschobene Blatt enthält.


Beispiel zur Move-Methode

In diesem Beispiel wird Sheet1 hinter Sheet3 in der aktiven Arbeitsmappe verschoben.

Worksheets("Sheet1").Move _
    after:=Worksheets("Sheet3")


NavigateArrow-Methode

Navigiert einen Spurpfeil des angegebenen Bereichs zu der oder den Vorgänger-, Nachfolger- oder fehlerverursachenden Zelle/n. Markiert die Vorgänger-, Nachfolger- oder fehlerverursachenden Zellen und gibt ein Range-Objekt zurück, das die neue Markierung darstellt. Diese Methode bewirkt einen Fehler, falls sie auf eine Zelle ohne sichtbare Spurpfeile angewendet wird.

Syntax

Ausdruck.NavigateArrow(TowardPrecedent, ArrowNumber, LinkNumber)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

TowardPrecedent Variant optional. Gibt die Richtung der Bewegung an: True geht zu Vorgängerzellen und False zu Nachfolgerzellen.

ArrowNumber Variant optional. Gibt die Nummer des Spurpfeils entsprechend dem nummerierten Bezug in der Zellformel an.

LinkNumber Variant optional. Falls der Pfeil ein externer Bezugspfeil ist, gibt dieses Argument an, welchem externen Bezug gefolgt werden soll. Ohne die Angabe dieses Arguments wird dem ersten externen Bezug gefolgt.


Beispiel zur NavigateArrow-Methode

In diesem Beispiel wird dem ersten Spurpfeil von Zelle A1 in Sheet1 zur Vorgängerzelle hin gefolgt. Das Beispiel sollte auf ein Tabellenblatt anwendet werden, das eine Formel in Zelle A1 enthält, die die Zellen D1, D2 und D3 verwendet (z. B. die Formel =D1*D2*D3). Blenden Sie die Symbolleiste Detektiv ein, markieren Sie die Zelle A1, und wählen Sie die Schaltfläche Spur zum Vorgänger, bevor Sie das Beispiel ausführen.

Worksheets("Sheet1").Activate
Range("A1").Select
ActiveCell.NavigateArrow True, 1


NewSeries-Methode

Erstellt eine neue Datenreihe. Gibt ein Series-Objekt zurück, das die neue Datenreihe darstellt.

Syntax

Ausdruck.NewSeries()

Ausdruck Erforderlich. Ein Ausdruck, der ein SeriesCollection-Objekt zurückgibt.

Anmerkungen

Diese Methode steht für PivotChart-Berichte nicht zur Verfügung.


Beispiel zur NewSeries-Methode

In diesem Beispiel wird dem ersten Diagramm eine neue Datenreihe hinzugefügt.

Set ns = Charts(1).SeriesCollection.NewSeries


NewWindow-Methode

Erstellt ein neues Fenster oder eine Kopie des angegebenen Fensters.

Syntax

Ausdruck.NewWindow

Ausdruck Erforderlich. Ein Ausdruck, der ein Window- oder ein Workbook-Objekt zurückgibt.


Beispiel zur NewWindow-Methode

In diesem Beispiel wird ein neues Fenster für die aktive Arbeitsmappe erstellt.

ActiveWorkbook.NewWindow


Next-Methode

Gibt ein Comment-Objekt zurück, das den nächsten Kommentar darstellt.

Syntax

Ausdruck.Next

Ausdruck Erforderlich. Ein Ausdruck, der ein Comment-Objekt zurückgibt.

Anmerkungen

Diese Methode funktioniert nur auf einem einzigen Blatt. Wird diese Methode auf den letzten Kommentar eines Blattes angewendet, so wird Null zurückgegeben (und nicht der nächste Kommentar auf dem nächsten Blatt).


Beispiel zur Next-Methode

In diesem Beispiel wird der nächste Kommentar ausgeblendet.

Range("a1").Comment.Next.Visible = False


NoteText-Methode

Gibt den mit der oberen linken Zelle des Bereichs verbundenen Zellkommentar zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Zellkommentare wurden durch Bereichskommentare ersetzt. Weitere Informationen finden Sie unter dem Comment-Objekt.

Syntax

Ausdruck.NoteText(Text, Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Text Variant optional. Der dem Kommentar hinzuzufügende Text (maximal 255 Zeichen). Der Text wird beginnend bei der Position Start hinzugefügt und ersetzt die durch das Argument Length angegebene Anzahl von Zeichen des bestehenden Kommentars. Wenn dieses Argument ausgelassen ist, gibt diese Methode den bestehenden Text des Kommentars zurück. Die Ausgangsposition ist Start. Length gibt die Anzahl der Zeichen an.

Start Variant optional. Gibt die Anfangsposition des Textes an, der festgelegt oder zurückgegeben werden soll. Wenn nicht angegeben, beginnt diese Methode beim ersten Zeichen. Wenn Sie dem bestehenden Kommentar Text hinzufügen möchten, geben Sie eine Zahl an, die größer als die Anzahl der Zeichen des bestehenden Kommentars ist.

Length Variant optional. Gibt die Anzahl der Zeichen an, die festgelegt oder zurückgegeben werden sollen. Wenn dieses Argument nicht angegeben ist, legt Microsoft Excel die Zeichen von der Anfangsposition bis zum Ende des Kommentars (maximal 255 Zeichen) fest oder gibt sie zurück. Wenn der Kommentar zwischen Start und Ende mehr als 255 Zeichen enthält, gibt diese Methode lediglich die ersten 255 Zeichen zurück.

Anmerkungen

Wenn Sie einen Kommentar hinzufügen möchten, der länger als 255 Zeichen ist, geben Sie zunächst mit dieser Methode die ersten 255 Zeichen an. Danach verwenden Sie die Methode erneut, um die restlichen Zeichen anzugeben (jeweils maximal 255).


Beispiel zur NoteText-Methode

In diesem Beispiel wird der Text des Kommentars für Zelle A1 in Sheet1 festgelegt.

Worksheets("Sheet1").Range("A1").NoteText "This may change!"


OLEObjects-Methode

Gibt ein Objekt zurück, das ein einzelnes OLE-Objekt (ein OLEObject, Syntax 1) oder eine Auflistung aller OLE-Objekte (eine OLEObjects-Auflistung, Syntax 2) des Diagramms oder Blattes darstellt. Schreibgeschützt.

Syntax 1

Ausdruck.OLEObjects(Index)

Syntax 2

Ausdruck.OLEObjects

Ausdruck Ein erforderlicher Ausdruck, der ein Chart- oder Worksheet-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des OLE-Objekts.


Beispiel zur OLEObjects-Methode

In diesem Beispiel wird eine Liste der Verknüpfungstypen für die OLE-Objekte in Sheet1 erstellt. Diese Liste wird in einem neuen Tabellenblatt angezeigt, das das Makro zuvor erstellt hat.

Set newSheet = Worksheets.Add
i = 2
newSheet.Range("A1").Value = "Name"
newSheet.Range("B1").Value = "Link Type"
For Each obj In Worksheets("Sheet1").OLEObjects
    newSheet.Cells(i, 1).Value = obj.Name
    If obj.OLEType = xlOLELink Then
        newSheet.Cells(i, 2) = "Linked"
    Else
        newSheet.Cells(i, 2) = "Embedded"
    End If
    i = i + 1
Next


OneColorGradient-Methode

Legt für die Füllung einen einfarbigen Verlauf fest.

Syntax

Ausdruck.OneColorGradient(GradientStyle, Variant, Degree)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

GradientStyle Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der einer der vier Varianten in der Registerkarte Graduell des Dialogfelds Fülleffekte entspricht. Falls GradientStyle die Konstante msoGradientFromCenter besitzt, kann das Argument Variant nur 1 oder 2 sein.

Degree Single erforderlich. Der Verlaufsgrad. Kann ein Wert zwischen 0,0 (dunkel) und 1,0 (hell) sein.


Beispiel zur OneColorGradient-Methode

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient And _
        c1f.GradientColorType = msoGradientOneColor Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .OneColorGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.GradientDegree
    End With
End If


OnKey-Methode

Führt die angegebene Prozedur aus, wenn eine bestimmte Taste oder Tastenkombination gedrückt wird.

Syntax

Ausdruck.OnKey(Key, Procedure)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Key String erforderlich. Eine Zeichenfolge, die die zu drückende Taste angibt.

Procedure Variant optional. Eine Zeichenfolge, die den Namen der auszuführenden Prozedur festlegt. Falls Procedure eine leere Zeichenfolge ("") ist, hat das Drücken von Key keine Wirkung. Diese Form von OnKey deaktiviert die normale Bedeutung von Tastenanschlägen in Microsoft Excel. Ist Procedure nicht angegeben, erhält Key ihre ursprüngliche Bedeutung in Microsoft Excel zurück, und alle bisher mit der OnKey -Methode vorgenommenen Tastenzuweisungen werden gelöscht.

Anmerkungen

Das Argument Key kann eine einzelne Taste angeben, kombiniert mit den Tasten ALT, STRG oder UMSCHALT oder jede Kombination dieser Tasten. Jede Taste wird durch ein oder mehrere Zeichen dargestellt, wie z. B. "a" für die Taste a, oder "{EINGABE}" für die EINGABETASTE.

Verwenden Sie für Zeichen, die beim Drücken einer Taste nicht angezeigt werden (z. B. EINGABE oder TAB), die Codes aus der folgenden Tabelle. Jeder Code in der Tabelle steht für eine Taste auf der Tastatur.

TASTE | Code
RÜCKTASTE | {BACKSPACE} oder {BS}
PAUSE | {BREAK}
FESTSTELLTASTE | {CAPSLOCK}
ENTF | {CLEAR}
ENTF | {DELETE} oder {DEL}
NACH-UNTEN-TASTE | {DOWN}
ENDE | {END}
EINGABETASTE (Zehnertastatur) | {ENTER}
EINGABETASTE | ~ (Tilde)
ESC | {ESCAPE} oder {ESC}
HILFE | {HELP}
POS1 | {HOME}
EINFG | {INSERT}
NACH-LINKS-TASTE | {LEFT}
NUM | {NUMLOCK}
BILD-AB | {PGDN}
BILD-AUF | {PGUP}
EINGABETASTE | {RETURN}
NACH-RECHTS-TASTE | {RIGHT}
ROLLEN | {SCROLLOCK}
TAB | {TAB}
NACH-OBEN-TASTE | {UP}
F1 bis F15 | {F1} bis {F15}

Sie können jede beliebige Tastenkombination mit UMSCHALT, STRG und ALT angeben. Kombinieren Sie eine Taste mit einer oder mehreren anderen Tasten entsprechend der folgenden Tabelle.

Kombinieren mit | Vorangestelltes Zeichen
UMSCHALT | + (Pluszeichen)
STRG | ^ (Caret-Zeichen)
ALT | % (Prozentzeichen)

Um einem der Sonderzeichen (+,^ ,%, usw.) eine Prozedur zuzuweisen, schließen Sie das Zeichen in geschweifte Klammern ein. Genauere Informationen finden Sie im zugehörigen Beispiel.


Beispiel zur OnKey-Methode

In diesem Beispiel wird der Tastenfolge STRG+PLUSZEICHEN "InsertProc" und der Tastenfolge UMSCHALT+STRG+NACH-RECHTS "SpecialPrintProc" zugewiesen.

Application.OnKey "^{+}", "InsertProc"
Application.OnKey "+^{RIGHT}", "SpecialPrintProc"

In diesem Beispiel wird UMSCHALT+STRG+NACH-RECHTS auf die normale Bedeutung zurückgesetzt.

Application.OnKey "+^{RIGHT}"

In diesem Beispiel wird die Tastenfolge UMSCHALT+STRG+NACH-RECHTS deaktiviert.

Application.OnKey "+^{RIGHT}", ""


OnRepeat-Methode

Legt den Text des Menübefehls Wiederholen und den Namen der Prozedur fest, die ausgeführt wird, wenn der Benutzer den Befehl Wiederholen (Menü Bearbeiten) wählt, nachdem die Prozedur ausgeführt worden ist, die diese Eigenschaft festlegt.

Syntax

Ausdruck.OnRepeat(Text, Procedure)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Text String erforderlich. Der Text, der mit dem Befehl Wiederholen (Menü Bearbeiten) angezeigt wird.

Procedure String erforderlich. Der Name der Prozedur, die ausgeführt wird, wenn der Benutzer den Befehl Wiederholen (Menü Bearbeiten) wählt.

Anmerkungen

Falls eine Prozedur die OnRepeat-Methode nicht verwendet, wiederholt der Befehl Repeat die Prozedur, die zuletzt ausgeführt wurde.

Die Prozedur muss die OnRepeat- und OnUndo-Methoden am Schluss aufrufen, um zu verhindern, dass die Prozeduren zum Wiederholen oder Rückgängigmachen durch nachfolgende Aktionen in der Prozedur überschrieben werden.


Beispiel zur OnRepeat-Methode

In diesem Beispiel werden die Prozeduren zum Wiederholen und zum Rückgängigmachen festgelegt.

Application.OnRepeat "Repeat VB Procedure", _
    "Book1.xls!My_Repeat_Sub"
Application.OnUndo "Undo VB Procedure", _
    "Book1.xls!My_Undo_Sub"


OnTime-Methode

Bewirkt, dass eine Prozedur zu einem bestimmten Zeitpunkt in der Zukunft (entweder zu einer bestimmten Zeit oder nachdem eine bestimmte Zeitspanne vergangen ist) ausgeführt wird.

Syntax

Ausdruck.OnTime(EarliestTime, Procedure, LatestTime, Schedule)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

EarliestTime Variant erforderlich. Die Zeit, zu der diese Prozedur ausgeführt werden soll.

Procedure String erforderlich. Der Name der auszuführenden Prozedur.

LatestTime Variant optional. Der letzte Zeitpunkt, zu dem die Prozedur ausgeführt werden kann. Wenn LatestTime beispielsweise gleich EarliestTime + 30 ist und Microsoft Excel sich zu der Zeit EarliestTime nicht im Bereitschafts-, Kopier-, Ausschneide- oder Suchmodus befindet, weil eine andere Prozedur ausgeführt wird, wartet Microsoft Excel 30 Sekunden auf das Ende der ersten Prozedur. Ist Microsoft Excel innerhalb dieser 30 Sekunden nicht im Bereitschaftsmodus, wird die Prozedur nicht ausgeführt. Ohne Angabe dieses Arguments wartet Microsoft Excel, bis die Prozedur ausgeführt werden kann.

Schedule Variant optional. True führt eine neue OnTime-Prozedur aus. False löscht eine vorher eingestellte Prozedur. Der Standardwert ist True.

Anmerkungen

Mit dem Ausdruck Now + TimeValue(time) können Sie etwas nach einer bestimmten Zeitspanne ausführen lassen. Mit TimeValue(time) führen Sie etwas zu einer bestimmten Zeit aus.


Beispiel zur OnTime-Methode

In diesem Beispiel wird "my_Procedure" nach 15 Sekunden ausgeführt.

Application.OnTime Now + TimeValue("00:00:15"), "my_Procedure"

Im folgenden Beispiel wird "my_Procedure" um 17 Uhr ausgeführt.

Application.OnTime TimeValue("17:00:00"), "my_Procedure"

In diesem Beispiel wird die OnTime-Einstellung aus dem vorherigen Beispiel gelöscht.

Application.OnTime EarliestTime:=TimeValue("17:00:00"), _
    Procedure:="my_Procedure", Schedule:=False


OnUndo-Methode

Legt den Text des Befehls Rückgängig und den Namen der Prozedur fest, die ausgeführt wird, wenn der Benutzer den Befehl Rückgängig (Menü Bearbeiten) wählt, nachdem die Prozedur ausgeführt worden ist, die diese Eigenschaft festlegt.

Syntax

Ausdruck.OnUndo(Text, Procedure)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Text String erforderlich. Der Text, der mit dem Befehl Rückgängig (Menü Bearbeiten) angezeigt wird.

Procedure String erforderlich. Der Name der Prozedur, die ausgeführt wird, wenn der Benutzer den Befehl Rückgängig (Menü Bearbeiten) wählt.

Anmerkungen

Falls eine Prozedur die OnUndo-Methode nicht ausführt, wird der Befehl Rückgängig deaktiviert.

Die Prozedur muss die Methoden OnRepeat und OnUndo am Schluss aufrufen, um zu verhindern, dass die Prozeduren zum Wiederholen oder Rückgängigmachen durch nachfolgende Aktionen in der Prozedur überschrieben werden.


Beispiel zur OnUndo-Methode

In diesem Beispiel werden die Prozeduren zum Wiederholen und zum Rückgängigmachen festgelegt.

Application.OnRepeat "Repeat VB Procedure", _
    "Book1.xls!My_Repeat_Sub"
Application.OnUndo "Undo VB Procedure", _
    "Book1.xls!My_Undo_Sub"


Open-Methode

Öffnet eine Arbeitsmappe.

Syntax

Ausdruck.Open(FileName, UpdateLinks, ReadOnly, Format, Password, WriteResPassword, IgnoreReadOnlyRecommended, Origin, Delimiter, Editable, Notify, Converter, AddToMRU)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbooks- oder ein RecentFile-Objekt zurückgibt.

FileName String erforderlich. Der Dateiname der zu öffnenden Arbeitsmappe.

UpdateLinks Variant optional. Gibt an, wie Verknüpfungen in einer Datei aktualisiert werden. Wenn dieses Argument nicht angegeben ist, wird der Benutzer dazu aufgefordert anzugeben, wie die Verknüpfungen aktualisiert werden sollen. Andernfalls hat dieses Argument einen der in der folgenden Tabelle aufgeführten Werte.

Wert | Bedeutung
0 | Keine Aktualisierung von Bezügen
1 | Aktualisierung von externen Bezügen, jedoch nicht von Remotebezügen
2 | Aktualisierung von Remotebezügen, jedoch nicht von externen Bezügen
3 | Aktualisierung von externen Bezügen und Remotebezügen

Wenn Sie in Microsoft Excel eine Datei im WKS-, WK1- oder WK3-Format öffnen und das Argument UpdateLinks den Wert 2 hat, dann erstellt Microsoft Excel Diagramme aus den Grafiken, die der Datei angehängt sind. Wenn das Argument den Wert Null hat, werden keine Diagramme erstellt.

ReadOnly Variant optional. Falls True, wird die Arbeitsmappe schreibgeschützt geöffnet.

Format Variant optional. Wenn Sie in Microsoft Excel eine Textdatei öffnen, gibt dieses Argument die in der folgenden Tabelle aufgelisteten Trennzeichen an. Wenn dieses Argument nicht angegeben ist, wird das aktuelle Trennzeichen verwendet.

Wert | Trennzeichen
1 | Tabstopps
2 | Kommas
3 | Leerzeichen
4 | Semikolons
5 | Keine
6 | Benutzerdefiniertes Trennzeichen (siehe Delimiter-Argument)

Password Variant optional. Eine Zeichenfolge, die das zum Öffnen einer geschützten Arbeitsmappe erforderliche Kennwort enthält. Fehlt dieses Argument und ist ein Kennwort für die Arbeitsmappe erforderlich, wird der Benutzer zur Kennworteingabe aufgefordert.

WriteResPassword Variant optional. Eine Zeichenfolge, die das zum Schreiben in eine Arbeitsmappe mit Schreiberlaubnis erforderliche Kennwort enthält. Fehlt dieses Argument und ist ein Kennwort für die Arbeitsmappe erforderlich, wird der Benutzer zur Kennworteingabe aufgefordert.

IgnoreReadOnlyRecommended Variant optional. Falls True, wird von Microsoft Excel keine Meldung angezeigt, die den schreibgeschützten Zugriff empfiehlt (falls die Arbeitsmappe mit der Option Schreibschutz empfehlen gespeichert wurde).

Origin Variant optional. Wenn es sich um eine Textdatei handelt, wird mit diesem Argument der Dateiursprung angegeben (damit Codeseiten und Wagenrücklauf/Zeilenvorschub (CR/LF) richtig umgesetzt werden können). Dies kann eine der folgenden XlPlatform-Konstanten sein: xlMacintosh, xlWindows oder xlMSDOS. Wenn dieses Argument nicht angegeben ist, wird das aktuelle Betriebssystem verwendet.

Delimiter Variant optional. Wenn es sich um eine Textdatei handelt und das Format-Argument den Wert 6 hat, gibt diese Zeichenfolge das zu verwendende Trennzeichen an. Zum Beispiel Chr(9) für Tabstopps, "," für Kommas, ";" für Semikolons, oder ein benutzerdefiniertes Zeichen. Verwendet wird nur das erste Zeichen der Zeichenfolge.

Editable Variant optional. Wenn die Datei ein Microsoft Excel 4.0-Add-In ist, wird das Add-In als sichtbares Fenster geöffnet, falls das Argument den Wert True hat. Wenn das Argument den Wert False hat oder ausgelassen ist, wird das Add-In ausgeblendet geöffnet, und es ist auch nicht möglich, es einzublenden. Diese Option gilt nicht für Add-Ins, die in Microsoft Excel 5.0 oder späteren Versionen erzeugt wurden. Wenn die Datei eine Excelvorlage ist, wird durch die Angabe von True die angegebene Vorlage zur Bearbeitung geöffnet und durch die Angabe von False eine neue Arbeitsmappe auf der Grundlage der angegebenen Vorlage geöffnet. Die Standardangabe lautet False.

Notify Variant optional. Wenn die Datei nicht im Schreib-Lese-Zugriff geöffnet werden kann, wird die Datei durch die Angabe von True der Benachrichtigungsliste hinzugefügt. Microsoft Excel öffnet die Datei schreibgeschützt, versucht weiterhin, die Datei zu öffnen und benachrichtigt dann den Benutzer, wenn die Datei im Schreib-Lese-Zugriff geöffnet werden kann. Wenn das Argument den Wert False hat oder ausgelassen ist, wird keine Benachrichtigung angefordert, und eine nicht zur Verfügung stehende Datei kann nicht geöffnet werden.

Converter Variant optional. Gibt den Index des ersten Dateikonvertierungsprogramms an, das verwendet werden soll, um eine Datei zu öffnen. Das angegebene Konvertierungsprogramm wird zuerst verwendet. Wenn es die Datei nicht lesen kann, wird mit allen anderen Konvertierungsprogrammen versucht, die Datei umzuwandeln. Der Index des Konvertierungsprogramms besteht aus seinen Zeilennummern, die von der FileConverters-Eigenschaft zurückgegeben werden.

AddToMru Variant optional. Falls True, wird diese Arbeitsmappe der Liste der zuletzt geöffneten Dateien hinzugefügt. Der Standardwert ist False.

Anmerkungen

Falls die zu öffnende Arbeitsmappe Auto_öffnen-Makros enthält, werden diese nicht ausgeführt, wenn Sie die Datei mit Visual Basic öffnen. Sollen Auto_öffnen-Makros dennoch ausgeführt werden, verwenden Sie die RunAutoMacros-Methode.


OpenLinks-Methode

Öffnet die benötigten Dokumente für eine oder mehrere Verknüpfungen.

Syntax

Ausdruck.OpenLinks(Name, ReadOnly, Type)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Name String erforderlich. Der Name der Microsoft Excel- oder DDE/OLE-Verknüpfung, wie er von der LinkSources-Methode zurückgegeben wird.

ReadOnly Variant optional. True, wenn die Dokumente schreibgeschützt geöffnet werden. Der Standardwert ist False.

Type Optional. Der Verknüpfungstyp. Kann eine der folgenden XlLink-Konstanten sein: xlExcelLinks, xlOLELinks (auch für DDE-Verknüpfungen), xlPublishers oder xlSubscribers.


Beispiel zur OpenLinks-Methode

In diesem Beispiel wird die erste OLE-Verknüpfung in der aktiven Arbeitsmappe geöffnet.

linkArray = ActiveWorkbook.LinkSources(xlOLELinks)
ActiveWorkbook.OpenLinks linkArray(1)

In diesem Beispiel werden alle verknüpften Microsoft Excel-Dokumente der aktiven Arbeitsmappe geöffnet.

ActiveWorkbook.OpenLinks _
    name:=ActiveWorkbook.LinkSources(xlExcelLinks)


OpenText-Methode

Lädt und analysiert eine Textdatei als neue Arbeitsmappe mit einem einzelnen Blatt, das die analysierten Daten enthält.

Syntax

Ausdruck.OpenText(Filename, Origin, StartRow, DataType, TextQualifier, ConsecutiveDelimiter, Tab, Semicolon, Comma, Space, Other, OtherChar, FieldInfo, DecimalSeparator, ThousandsSeparator)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbooks-Objekt zurückgibt.

Filename String erforderlich. Gibt den Dateinamen der zu öffnenden und zu analysierenden Textdatei an.

Origin Variant optional. Gibt die Herkunft der Textdatei an. Zulässig ist eine der folgenden XlPlatform-Konstanten: xlMacintosh, xlWindows oder xlMSDOS. Ohne Angabe dieses Arguments werden die aktuellen Einstellungen des Dateiursprungs des Textimport-Assistenten verwendet.

StartRow Variant optional. Die Zeilennummer, ab der der Text analysiert werden soll. Die Voreinstellung ist 1.

DataType Variant optional. Bestimmt das Spaltenformat der Daten in der Datei. Zulässig ist eine der folgenden XlTextParsingType-Konstanten: xlDelimited oder xlFixedWidth. Die Voreinstellung ist xlDelimited.

TextQualifier Variant optional, das den Textkennzeichner festlegt. Zulässig ist eine der folgenden XlTextQualifier-Konstanten: xlTextQualifierDoubleQuote, xlTextQualifierSingleQuote oder xlTextQualifierNone. Die Voreinstellung ist xlTextQualifierDoubleQuote.

ConsecutiveDelimiter Variant optional. True, falls aufeinander folgende Trennzeichen als ein Zeichen interpretiert werden sollen. Die Voreinstellung ist False.

Tab Variant optional. True, falls das Tabulatorzeichen das Trennzeichen ist (DataType muss den Wert xlDelimited haben). Die Voreinstellung ist False.

Semicolon Variant optional. True, falls das Semikolon das Trennzeichen ist (DataType muss den Wert xlDelimited haben). Die Voreinstellung ist False.

Comma Variant optional. True, falls das Komma das Trennzeichen ist (DataType muss den Wert xlDelimited haben). Die Voreinstellung ist False.

Space Variant optional. True, falls das Leerzeichen das Trennzeichen ist (DataType muss den Wert xlDelimited haben). Die Voreinstellung ist False.

Other Variant optional. True, falls das durch das Argument OtherChar angegebene Zeichen das Trennzeichen ist (DataType muss den Wert xlDelimited haben). Die Voreinstellung ist False.

OtherChar Variant optional (erforderlich, falls Other den Wert True hat). Gibt das Trennzeichen an, falls Other den Wert True hat. Wird mehr als ein Zeichen angegeben, wird nur das erste Zeichen verwendet und die restlichen Zeichen werden nicht beachtet.

FieldInfo Variant optional. Eine Matrix mit Informationen zur Analyse der einzelnen Datenspalten. Die Deutung hängt vom Wert von DataType ab.

Wenn die Daten getrennt sind, ist dieses Argument eine Matrix von aus zwei Elementen bestehenden Matrizen. Jede Matrix aus zwei Elementen gibt die Umwandlungsoptionen für eine bestimmte Spalte an. Das erste Element ist die Spaltennummer (beginnend mit 1) und das zweite Element ist eine der in der folgenden Tabelle aufgeführten xlColumnDataType-Konstanten, die angeben, wie die Spalte analysiert wird.

Konstante | Beschreibung
xlGeneralFormat | Standard
xlTextFormat | Text
xlMDYFormat | Datum im Format MTJ
xlDMYFormat | Datum im Format TMJ
xlYMDFormat | Datum im Format JMT
xlMYDFormat | Datum im Format MJT
xlDYMFormat | Datum im Format TJM
xlYDMFormat | Datum im Format JTM
xlEMDFormat | EMD-Datum
xlSkipColumn | Spalte überspringen

Sie können xlEMDFormat nur verwenden, wenn die Sprachunterstützung für Taiwan installiert und aktiviert ist. Die xlEMDFormat-Konstante gibt an, dass Kalenderangaben gemäß dem Taiwanesischen Kalender verwendet werden sollen.

Die Spaltenangaben können in beliebiger Reihenfolge erfolgen. Wird für eine Spalte keine Analysevorschrift angegeben, wird die Einstellung Standard verwendet. Im folgenden Beispiel wird die dritte Spalte übersprungen, die erste Spalte als Text und die restlichen Spalten mit der Einstellung Standard analysiert.

Array(Array(3, 9), Array(1, 2))

Falls die Quelldaten aus Spalten fester Breite bestehen, gibt das erste Element jeder zweielementigen Matrix die Position des ersten Zeichens in der Spalte (als Ganzzahl; das erste Zeichen hat die Nummer 0) an. Das zweite Element der Matrix legt mit einer Zahl zwischen 1 und 9 entsprechend obiger Liste fest, wie die Spalte analysiert wird.

Im folgenden Beispiel werden zwei Spalten einer Datei mit Spalten fester Breite analysiert. Die erste Spalte enthält Zeichen 1 bis 10. Die Zeichen 11, 12, 13, 14 und 15 werden übersprungen. Die zweite Spalte beginnt mit Zeichen 16 und erstreckt sich bis zum Zeilenende.

Array(Array(0, 1), Array(10, 9), Array(15, 1))

DecimalSeparator String optional. Das Dezimaltrennzeichen, das Microsoft Excel beim Erkennen von Zahlen verwendet. Standardeinstellung ist die Systemeinstellung.

ThousandsSeparator String optional. Das 1.000er-Trennzeichen, das Excel beim Erkennen von Zahlen verwendet. Standardeinstellung ist die Systemeinstellung.

In der folgenden Tabelle sind die Ergebnisse beim Importieren von Text in Excel für verschiedene Importeinstellungen gezeigt. Die numerischen Ergebnisse werden in der Spalte ganz rechts angezeigt.

Dezimaltrennzeichen des Systems | 1.000er-Trennzeichen des Systems | Wert für Dezimaltrennzeichen | Wert für 1.000er-Trennzeichen | Importierter Text | Zellwert (Datentyp)
Punkt | Komma | Komma | Punkt | 123.123,45 | 123,123.45 (numerisch)
Punkt | Komma | Komma | Komma | 123.123,45 | 123.123,45 (Text)
Komma | Punkt | Komma | Punkt | 123,123.45 | 123,123.45 (numerisch)
Punkt | Komma | Punkt | Komma | 123 123.45 | 123 123.45 (Text)
Punkt | Komma | Punkt | Leerzeichen | 123 123.45 | 123,123.45 (numerisch)


Beispiel zur OpenText-Methode

In diesem Beispiel wird die Datei DATA.TXT geöffnet. Dabei wird beim Einlesen der Textdatei in ein Tabellenblatt das Tabulatorzeichen als Trennzeichen verwendet.

Workbooks.OpenText filename:="DATA.TXT", _
    dataType:=xlDelimited, tab:=True


Parse-Methode

Analysiert einen Datenbereich und teilt ihn auf mehrere Zellen auf. Verteilt den Inhalt des Bereichs auf mehrere angrenzende Spalten. Der Bereich darf maximal eine Spalte breit sein.

Syntax

Ausdruck.Parse(ParseLine, Destination)

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.

ParseLine Variant optional. Eine Zeichenfolge, die linke und rechte eckige Klammern enthält, welche die Stellen anzeigen, an denen die Zellen aufgeteilt werden sollen. So gibt z. B. "[xxx][xxx]" an, dass die ersten 3 Zeichen in die erste Spalte und die nächsten 3 Zeichen in die zweite Spalte des Zielbereichs gelangen sollen. Wird das Argument nicht angegeben, so legt Microsoft Excel aufgrund der Trennzeichen in der oberen linken Zelle des Bereichs fest, an welchen Stellen die Spalten aufgeteilt werden sollen. Wenn Sie statt der oberen linken Zelle einen anderen Bereich analysieren wollen, können Sie das entsprechende Range-Objekt als ParseLine-Argument angeben. Bei diesem Bereich muss es sich um eine Zelle aus dem zu analysierenden Bereich handeln. Das Argument ParseLine kann maximal 255 Zeichen lang sein, einschließlich eckiger Klammern und Leerzeichen.

Destination Variant optional. Ein Range-Objekt, das die obere linke Ecke des Zielbereichs für die analysierten Daten angibt. Wird dieses Argument nicht angegeben, analysiert Microsoft Excel direkt im angegebenen Datenbereich.


Beispiel zur Parse-Methode

In diesem Beispiel werden Telefonnummern der Form 0231-9949949 in zwei Spalten aufgeteilt. Die erste Spalte enthält nur die Vorwahl, die zweite die siebenstellige Rufnummer mit dem Bindestrich.

Worksheets("Sheet1").Columns("A").Parse _
    parseLine:="[xxx] [xxxxxxxx]", _
    destination:=Worksheets("Sheet1").Range("B1")


Paste-Methode

Objekt | Beschreibung
Chart | Fügt Diagrammdaten aus der Zwischenablage in das angegebene Diagramm ein.
Point oder Series | Fügt ein Bild aus der Zwischenablage als Datenpunktmarkierung in den ausgewählten Datenpunkt oder die ausgewählte Datenreihe ein. Paste kann auf Säulen-, Balken-, Linien- oder Netzdiagramme angewendet werden. Die Methode setzt die MarkerStyle-Eigenschaft auf xlPicture.
SeriesCollection | Fügt Daten aus der Zwischenablage in die angegebene Datenreihenauflistung ein.
Worksheet | Fügt den Inhalt der Zwischenablage in das Blatt ein.
Walls oder Floor | Fügt den Inhalt der Zwischenablage in die Wände oder die Bodenfläche ein.


Paste-Methode (Chart-Objekt)

Fügt Diagrammdaten aus der Zwischenablage in das angegebene Diagramm ein.

Syntax

Ausdruck.Paste(Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Type Variant optional. Legt fest, welche Diagramminformationen einzufügen sind, wenn sich ein Diagramm in der Zwischenablage befindet. Zulässig ist eine der folgenden XlPasteType-Konstanten: xlFormats, xlFormulas oder xlAll. Der Standardwert ist xlAll. Befinden sich in der Zwischenablage andere als Diagrammdaten, so kann dieses Argument nicht verwendet werden.

Anmerkungen

Diese Methode ändert die aktuelle Markierung.


Beispiel zur Paste-Methode (Chart-Objekt)

In diesem Beispiel werden die Daten in Bereich B1:B5 von Sheet1 in Chart1 eingefügt.

Worksheets("Sheet1").Range("B1:B5").Copy
Charts("Chart1").Paste


Paste-Methode (Floor- oder Walls-Objekt)

Fügt ein Bild aus der Zwischenablage in die Bodenfläche oder in eine Wand des angegebenen Diagramms ein.

Syntax

Objekt.Paste

Objekt Erforderlich. Ein Ausdruck der ein Floor- oder ein Walls-Objekt zurückgibt.


Paste-Methode (Point- oder Series-Objekt)

Fügt ein Bild aus der Zwischenablage als Markierung in den ausgewählten Datenpunkt oder die ausgewählte Datenreihe ein. Diese Methode kann auf Säulen-, Balken-, Linien- oder Netzdiagramme angewendet werden. Sie legt die Eigenschaft MarkerStyle auf xlMarkerStylePicture fest.

Syntax

Ausdruck.Paste

Ausdruck Erforderlich. Ein Ausdruck, der ein Point- oder Series-Objekt zurückgibt.


Beispiel zur Paste-Methode (Point- oder Series-Objekt)

In diesem Beispiel wird ein Bild aus der Zwischenablage in die erste Datenreihe in Chart1 eingefügt.

Charts("Chart1").SeriesCollection(1).Paste


Paste-Methode (SeriesCollection-Auflistung)

Fügt Daten aus der Zwischenablage in die angegebene Datenreihenauflistung ein.

Syntax

Ausdruck.Paste(Rowcol, SeriesLabels, CategoryLabels, Replace, NewSeries)

Ausdruck Erforderlich. Ein Ausdruck, der ein SeriesCollection-Objekt zurückgibt.

Rowcol Variant optional. Legt fest, ob die einer bestimmten Datenreihe entsprechenden Werte sich in Zeilen oder Spalten befinden. Zulässig sind die XlRowCol-Konstanten xlRows oder xlColumns. Der Standardwert ist xlColumns.

SeriesLabels Variant optional. True, wenn der Inhalt der Zelle in der ersten Spalte jeder Zeile (bzw. der ersten Zeile jeder Spalte) als Name für die Datenreihe in der betreffenden Zeile (bzw. Spalte) verwendet wird. False, wenn der Inhalt der Zelle in der ersten Spalte jeder Zeile (bzw. der ersten Zeile jeder Spalte) als erster Datenpunkt der Datenreihe verwendet wird. Der Standardwert ist False.

CategoryLabels Variant optional. True, wenn der Inhalt der ersten Zeile (bzw. Spalte) der Auswahl als Rubriken des Diagramms verwendet wird. False, wenn der Inhalt der ersten Zeile (bzw. Spalte) als erste Datenreihe im Diagramm verwendet wird. Der Standardwert ist False.

Replace Variant optional. True, wenn beim Ersetzen vorhandener Rubriken durch Informationen aus dem kopierten Bereich Rubriken angewendet werden. False, wenn neue Rubriken eingefügt werden, ohne die alten zu ersetzen. Der Standardwert ist True.

NewSeries Variant optional. True, wenn die Daten als eine neue Datenreihe eingefügt werden. False, wenn die Daten als neue Datenpunkte in eine vorhandene Datenreihe eingefügt werden. Der Standardwert ist True.


Beispiel zur Paste-Methode (SeriesCollection-Auflistung)

In diesem Beispiel werden die Daten der Zellen C1:C5 in Sheet1 in die Zwischenablage kopiert und anschließend als neue Datenreihe in Chart1 eingefügt.

Worksheets("Sheet1").Range("C1:C5").Copy
Charts("Chart1").SeriesCollection.Paste


PasteSpecial-Methode

Range-Objekt: Fügt Daten aus der Zwischenablage in den angegebenen Bereich ein.

Worksheet-Objekt: Fügt Daten aus der Zwischenablage im angegebenen Format in das Tabellenblatt ein. Verwenden Sie diese Methode, um Daten aus anderen Anwendungen einzufügen oder um Daten in einem speziellen Format einzufügen.


PasteSpecial-Methode (Range-Objekt)

Fügt ein Range-Objekt aus der Zwischenablage in den angegebenen Bereich ein.

Syntax

Ausdruck.PasteSpecial(Paste, Operation, SkipBlanks, Transpose)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Paste Variant optional. Der Teil des Bereichs, der eingefügt werden soll. Zulässig ist eine der folgenden XlPasteType-Konstanten: xlPasteAll, xlPasteFormulas, xlPasteValues, xlPasteFormats, xlPasteNotes oder xlPasteAllExceptBorders. Der Standardwert ist xlPasteAll.

Operation Variant optional. Die Einfüge-Operation. Zulässig ist eine der folgenden XlPasteSpecialOperation-Konstanten: xlPasteSpecialOperationNone, xlPasteSpecialOperationAdd, xlPasteSpecialOperationSubtract, xlPasteSpecialOperationMultiply oder xlPasteSpecialOperationDivide. Der Standardwert ist xlPasteSpecialOperationNone.

SkipBlanks Variant optional. True, wenn leere Zellen im Bereich in der Zwischenablage nicht in den Zielbereich eingefügt werden. Der Standardwert ist False.

Transpose Variant optional. True, wenn Zeilen und Spalten beim Einfügen eines Bereichs vertauscht werden. Der Standardwert ist False.


Beispiel zur PasteSpecial-Methode (Range-Objekt)

In diesem Beispiel werden Daten in den Zellen D1:D5 in Sheet1 durch die Summe des vorhandenen Inhalts und den Zellen C1:C5 in Sheet1 ersetzt.

With Worksheets("Sheet1")
    .Range("C1:C5").Copy
    .Range("D1:D5").PasteSpecial _
        Operation:=xlPasteSpecialOperationAdd
End With


PasteSpecial-Methode (Worksheet-Objekt)

Fügt den Inhalt der Zwischenablage im angegebenen Format in das Tabellenblatt ein. Verwenden Sie diese Methode, um Daten aus anderen Anwendungen einzufügen oder um Daten in einem speziellen Format einzufügen.

Syntax

Ausdruck.PasteSpecial(Format, Link, DisplayAsIcon, IconFileName, IconIndex, IconLabel)

Ausdruck Erforderlich. Ein Ausdruck, der ein DialogSheet- oder Worksheet-Objekt zurückgibt.

Format Variant optional. Eine Zeichenfolge, die das Zwischenablageformat für die Daten festlegt.

Link Variant optional. True, wenn eine Verknüpfung zum Quelldokument der eingefügten Daten hergestellt wird. Eignen sich die Quelldaten nicht für das Verknüpfen, oder wird das Verknüpfen von der Quellanwendung nicht unterstützt, so wird dieser Parameter ignoriert. Der Standardwert ist False.

DisplayAsIcon Variant optional. True, wenn die eingefügten Daten als Symbol angezeigt werden. Der Standardwert ist False.

IconFileName Variant optional. Der Name der Datei mit dem zu verwendenden Symbol, wenn DisplayAsIcon den Wert True annimmt.

IconIndex Variant optional. Die Indexnummer des Symbols in der Symboldatei.

IconLabel Variant optional. Die Beschriftung für das Symbol.

Anmerkungen

Sie müssen den Zielbereich auswählen, bevor Sie diese Methode verwenden.

Diese Methode ändert gegebenenfalls in Abhängigkeit vom Inhalt der Zwischenablage die Position der Auswahl im Tabellenblatt.


Beispiel zur PasteSpecial-Methode (Worksheet-Objekt)

In diesem Beispiel wird ein Microsoft Word-Dokumentobjekt aus der Zwischenablage in Zelle D1 in Sheet1 eingefügt.

Worksheets("Sheet1").Range("D1").Select
ActiveSheet.PasteSpecial format:= _
    "Microsoft Word 8.0 Document Object"

Im folgenden Beispiel wird dasselbe Microsoft Word-Dokumentobjekt eingefügt und als Symbol angezeigt.

Worksheets("Sheet1").Range("F5").Select
ActiveSheet.PasteSpecial _
        Format:="Microsoft Word 8.0 Document Object", _
        DisplayAsIcon:=True


Patterned-Methode

Legt ein Muster für die angegebene Füllung fest.

Syntax

Ausdruck.Patterned(Pattern)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Pattern Long erforderlich. Der Mustertyp. Kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBricks

msoPatternDivot

msoPatternDottedDiamond

msoPatternDottedGrid

msoPatternHorizontalBrick

 msoPatternLargeCheckerBoard

msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamond

msoPatternPlaid

msoPatternShingle

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamond

msoPatternSphere

msoPatternTrellis

msoPatternWave

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal

msoPatternZigZag


Beispiel zur Patterned-Methode

In diesem Beispiel wird das Füllmuster des ersten Diagramms festgelegt.

With Charts(1).ChartArea.Fill
    .Patterned msoPatternDiagonalBrick
    .Visible = True
End With


PickUp-Methode

Kopiert die Formatierung der angegebenen Form. Verwenden Sie die Apply-Methode, um die kopierte Formatierung einer anderen Form zuzuweisen.

Syntax

Ausdruck.PickUp

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.


Beispiel zur PickUp-Methode

In diesem Beispiel wird in myDocument die Formatierung der ersten Form kopiert und anschließend der zweiten Form zugewiesen.

Set myDocument = Worksheets(1)
With myDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


PieGroups-Methode

Gibt für ein 2D-Diagramm ein Objekt zurück, das eine einzelne Kreisdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Kreisdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.PieGroups(Index)

Syntax 2

Ausdruck.PieGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur PieGroups-Methode

In diesem Beispiel wird die erste Kreisgruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird. Wenden Sie das Beispiel auf ein 2D-Diagramm an.

Charts("Chart1").PieGroups(1).VaryByCategories = True


PivotCache-Methode

Gibt ein PivotCache-Objekt zurück, das den Cache des angegebenen PivotTable-Berichts darstellt. Schreibgeschützt.

Syntax

Ausdruck.PivotCache

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.


PivotCaches-Methode

Gibt eine PivotCaches-Auflistung zurück, die alle PivotTable-Caches der angegebenen Arbeitsmappe enthält. Schreibgeschützt.

Syntax

Ausdruck.PivotCaches

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.


Beispiel zur PivotCaches-Methode

In diesem Beispiel wird der PivotTable-Cache bei jedem Öffnen einer Arbeitsmappe automatisch aktualisiert.

ActiveWorkbook.PivotCaches(1).RefreshOnFileOpen = True


 PivotFields-Methode

PivotFields-Methode

Gibt ein Objekt zurück, das entweder ein einzelnes PivotTable-Feld darstellt (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller ein- und ausgeblendeten Felder in dem PivotTable-Bericht (ein PivotFields-Objekt, Syntax 2). Schreibgeschützt.

Syntax 1

Ausdruck.PivotFields(Index)

Syntax 2

Ausdruck.PivotFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Felds.

Anmerkungen

Bei OLAP-Datenquellen gibt es keine verborgenen Felder. Das zurückgegeben Objekt oder die zurückgegebene Auflistung entspricht dem, was aktuell sichtbar ist.


Beispiel zur PivotFields-Methode

In diesem Beispiel werden die Feldnamen des PivotTable-Berichts in eine Liste auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.PivotFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


 PivotItems-Methode

PivotItems-Methode

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Element darstellt (ein PivotItem-Objekt, Syntax 1) oder eine Auflistung aller ein- und ausgeblendeten Elemente des angegebenen Felds (ein PivotItems-Objekt, Syntax 2). Schreibgeschützt.

Syntax 1

Ausdruck.PivotItems(Index)

Syntax 2

Ausdruck.PivotItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Elements.

Anmerkungen

Bei OLAP-Datenquellen wird die Auflistung anhand des eindeutigen Namens (der von der SourceName-Eigenschaft zurückgegebene Name) und nicht anhand des angezeigten Namens indiziert.


Beispiel zur PivotItems-Methode

In diesem Beispiel werden die Namen aller Elemente im Feld "Produkt" in eine Liste in einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtitem In pvtTable.PivotFields("product").PivotItems
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtitem.Name
Next


 PivotSelect-Methode

PivotSelect-Methode

Markiert einen Teil eines PivotTable-Berichts.

Syntax

Ausdruck.PivotSelect(Name, Mode)

Ausdruck Ein Ausdruck der ein PivotTable-Objekt zurückgibt.

Name String erforderlich. Die Markierung, im Standardmarkierungsformat des PivotTable-Berichts.

Mode Long optional. Legt den strukturierten Markierungsmodus fest. Kann eine der folgenden XlPTSelectionMode-Konstanten sein: xlBlanks, xlButton, xlDataAndLabel, xlDataOnly, xlFirstRow, xlLabelOnly oder xlOrigin. Die Standardkonstante istxlDataAndLabel.

Anmerkungen

Sie können den angegebenen Modus lediglich dazu verwenden, um das entsprechende Element in dem PivotTable-Bericht auszuwählen. Sie können beispielsweise mit dem xlButton-Modus keine Daten oder Beschriftungen auswählen; gleichermaßen können Sie mit dem xlDataOnly-Modus keine Schaltflächen auswählen.


Beispiel zur PivotSelect-Methode

In diesem Beispiel werden alle Datumsbeschriftungen in dem ersten PivotTable-Bericht auf dem ersten Tabellenblatt markiert.

Worksheets(1).PivotTables(1).PivotSelect "date[All]", xlLabelOnly


PivotTable-Methode

Gibt ein Objekt zurück, das ein einzelner PivotTable-Bericht (ein PivotTable-Objekt, Syntax 1) oder eine Auflistung aller PivotTable-Berichte in einem Tabellenblatt (ein PivotTables-Objekt, Syntax 2) darstellt. Schreibgeschützt.

Syntax 1

Ausdruck.PivotTables(Index)

Syntax 2

Ausdruck.PivotTables

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des Berichts.


Beispiel zur PivotTables-Methode

In diesem Beispiel wird festgelegt, dass das Feld "Sum of 1994" im ersten PivotTable-Bericht auf dem aktiven Blatt die Funktion SUM verwendet.

ActiveSheet.PivotTables("PivotTable1"). _
    PivotFields("Sum of 1994").Function = xlSum


PivotTableWizard-Methode

Erstellt ein PivotTable-Objekt. Bei dieser Methode wird der PivotTable-Assistent nicht angezeigt. Diese Methode steht für OLE DB-Datenquellen nicht zur Verfügung. Verwenden Sie die Add-Methode, um einen PivotTable-Cache hinzuzufügen, und erstellen Sie dann basierend auf dem Cache einen PivotTable-Bericht.

Syntax

Ausdruck.PivotTableWizard(SourceType, SourceData, TableDestination, TableName, RowGrand, ColumnGrand, SaveData, HasAutoFormat, AutoPage, Reserved, BackgroundQuery, OptimizeCache, PageFieldOrder, PageFieldWrapCount, ReadData, Connection)

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet- oder PivotTable-Objekt zurückgibt.

SourceType Variant optional. Die Quelle der Daten in dem Bericht. Zulässig ist eine der in der folgenden Tabelle aufgeführten XlPivotTableSourceType-Konstanten:

Konstante | Beschreibung
xlConsolidation | Mehrere Konsolidierungsbereiche
xlDatabase | Microsoft Excel-Datenbank oder -Liste
xlExternal | Externe Datenquelle
xlPivotTable | Gleiche Quelle wie ein anderer PivotTable-Bericht

Wird dieses Argument angegeben, müssen Sie auch das Argument SourceData angeben. Wenn SourceType und SourceData nicht angegeben werden, werden von Microsoft Excel als Quelltyp xlDatabase und als Quelldaten die Daten aus dem mit "Datenbank" benannten Bereich angenommen. Wenn kein entsprechend benannter Bereich existiert, verwendet Microsoft Excel den derzeitigen Bereich, wenn die derzeitige Auswahl in einem Bereich von mehr als 10 Zellen liegt, die Daten enthalten. Wenn diese Bedingung nicht erfüllt ist, verursacht diese Methode einen Fehler.

SourceData Variant optional. Der Datenbereich für den neuen Bericht. Es kann sich hierbei um ein Range-Objekt, eine Matrix von Bereichen oder eine Textkonstante handeln, die für den Namen eines anderen Berichts steht. Für eine externe Datenbank ist SourceData eine Matrix mit Zeichenfolgen, die die SQL-Abfragezeichenfolge enthalten, wobei jedes Element bis zu 255 Zeichen umfasst. Sie sollten mit dem Connection-Argument die ODBC-Verbindungszeichenfolge angeben. Aus Gründen der Kompatibilität mit früheren Versionen von Excel kann SourceData eine aus zwei Elementen bestehende Matrix sein. Das erste Element ist die Verbindungszeichenfolge zur Angabe der ODBC-Quelle der Daten. Das zweite Element ist die SQL-Abfragezeichenfolge, die verwendet wird, um die Daten abzurufen. Wird SourceData angegeben, müssen Sie ebenfalls SourceType angeben. Befindet sich die aktive Zelle innerhalb des SourceData-Bereichs, müssen Sie auch TableDestination angeben.

TableDestination Variant optional. Ein Range-Objekt, das die Position angibt, an der der Bericht im Tabellenblatt stehen soll. Wird dieses Argument nicht angegeben, wird der Bericht an die Stelle der aktiven Zelle gesetzt.

TableName Variant optional. Eine Zeichenfolge, die den Namen des zu erstellenden Berichts angibt.

RowGrand Variant optional. True, wenn der neue Bericht Gesamtergebnisse für Zeilen aufweist.

ColumnGrand Variant optional. True, wenn der neue Bericht Gesamtergebnisse für Spalten aufweist.

SaveData Variant optional. True, wenn die Daten zusammen mit dem Bericht gespeichert werden. False, wenn nur die Definition des Berichts gespeichert wird.

HasAutoFormat Variant optional. True, wenn Microsoft Excel den Bericht automatisch nach der Neuberechnung oder dem Verschieben von Feldern formatiert.

AutoPage Variant optional. Nur gültig, wenn für das Argument SourceType der Wert xlConsolidation angegeben wird. True, wenn für die Konsolidierung ein Seitenfeld erstellt wird. Wenn AutoPage False ist, müssen Sie das Seitenfeld bzw. die Seitenfelder selbst erstellen.

Reserved Variant optional. Von Microsoft Excel nicht verwendet.

BackgroundQuery Variant optional. True, wenn Excel die Abfragen für den Bericht asynchron (im Hintergrund) ausführen soll. Der Standardwert ist False.

OptimizeCache Variant optional. True, wenn der PivotTable-Cache bei der Erstellung optimiert werden soll. Der Standardwert ist False.

PageFieldOrder Variant optional. Die Reihenfolge, in der die Seitenfelder dem Layout des PivotTable-Berichts hinzugefügt werden. Es kann sich um folgende XlOrder-Konstanten handeln: xlDownThenOver oder xlOverThenDown. Der Standardwert ist xlDownThenOver.

PageFieldWrapCount Variant optional. Die Anzahl der Seitenfelder in jeder Spalte oder Zeile des PivotTable-Berichts. Der Standardwert ist 0 (null).

ReadData Variant optional. True, wenn ein PivotTable-Cache erstellt werden soll, der alle Datensätze aus einer externen Datenbank beinhaltet; dieser Cache kann sehr groß sein. Wenn ReadData False ist, können Sie einige Felder vor dem eigentlichen Lesen der Daten als serverbasierte Seitenfelder festlegen.

Connection Variant optional. Eine Zeichenfolge mit ODBC-Einstellungen, die eine Verbindung von Excel zu einer ODBC-Datenquelle ermöglicht. Die Verbindungszeichenfolge hat die Form "ODBC;<Verbindungszeichenfolge>". Dieses Argument überschreibt alle vorangegangenen Einstellungen der Connection-Eigenschaft des PivotCache-Objekts.


Beispiel zur PivotTableWizard-Methode

In diesem Beispiel wird ein neuer PivotTable-Bericht aus einer Microsoft Excel-Datenbank (im Bereich A1:C100) erstellt.

ActiveSheet.PivotTableWizard xlDatabase, Range("A1:C100")


Play-Methode

Diese Methode sollte nicht benutzt werden. Audio-Notizen wurden aus Microsoft Excel entfernt.


Points-Methode

Gibt ein Objekt zurück, das einen einzelnen Datenpunkt (ein Point-Objekt, Syntax 1) darstellt oder eine Auflistung aller Datenpunkte der Datenreihe (ein Points-Objekt, Syntax 2). Schreibgeschützt.

Syntax 1

Ausdruck.Points(Index)

Syntax 2

Ausdruck.Points

Ausdruck Erforderlich. Ein Ausdruck, der ein Series-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des Datenpunktes.


PointsToScreenPixelsX-Methode

Konvertiert ein horizontales Maß von Punkten (Dokumentkoordinaten) in Bildschirmpixel (Bildschirmkoordinaten). Gibt das konvertierte Maß als Wert vom Typ Long zurück.

Syntax

Ausdruck.PointsToScreenPixelsX(Points)

Ausdruck Ein Ausdruck, der ein Window-Objekt zurückgibt.

Points Long erforderlich. Die Anzahl der horizontalen Punkte entlang dem oberen Rand des Dokumentfensters (links beginnend).


Beispiel zur PointsToScreenPixelsX-Methode

In diesem Beispiel wird die Höhe und Breite (in Pixel) der markierten Zellen im aktiven Fenster bestimmt und die Werte in den Variablen lWinWidth und lWinHeight zurückgegeben.

With ActiveWindow
    lWinWidth = _
        .PointsToScreenPixelsX(.Selection.Width)
    lWinHeight = _
        .PointsToScreenPixelsY(.Selection.Height)
End With


PointsToScreenPixelsY-Methode

Konvertiert ein vertikales Maß von Punkten (Dokumentkoordinaten) in Bildschirmpixel (Bildschirmkoordinaten). Gibt das konvertierte Maß als Wert vom Typ Long zurück.

Syntax

Ausdruck.PointsToScreenPixelsY(Points)

Ausdruck Ein Ausdruck, der ein Window-Objekt zurückgibt.

Points Long erforderlich. Die Anzahl der vertikalen Punkte entlang dem linken Rand des Dokumentfensters (oben beginnend).


Beispiel zur PointsToScreenPixelsY-Methode

In diesem Beispiel wird die Höhe und Breite (in Pixel) der markierten Zellen im aktiven Fenster bestimmt und die Werte in den Variablen lWinWidth und lWinHeight zurückgegeben.

With ActiveWindow
    lWinWidth = _
        .PointsToScreenPixelsX(.Selection.Width)
    lWinHeight = _
        .PointsToScreenPixelsY(.Selection.Height)
End With


Post-Methode

Sendet die angegebene Arbeitsmappe an einen öffentlichen Ordner. Diese Methode funktioniert nur, wenn der Microsoft Exchange-Client mit einem Microsoft Exchange-Server verbunden ist.

Syntax

Ausdruck.Post(DestName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

DestName Variant optional. Dieses Argument wird ignoriert. Die Post-Methode fordert den Benutzer zur Angabe des Ziels für die Arbeitsmappe auf.


Beispiel zur Post-Methode

In diesem Beispiel wird die aktive Arbeitsmappe gesendet.

ActiveWorkbook.Post


PresetDrop-Methode

Legt fest, ob die Legendenlinie am oberen Rand, am unteren Rand oder in der Mitte des Textfeldes der Legende angefügt wird, oder an einem Punkt, der in einem angegebenen Abstand vom oberen bzw. unteren Rand des Textfeldes liegt.

Syntax

Ausdruck.PresetDrop(DropType)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalloutFormat-Objekt zurückgibt.

DropType Long erforderlich. Die Anfangsposition der Legendenlinie, relativ zum Textbegrenzungsrechteck. Kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter oder msoCalloutDropTop. Wenn Sie für dieses Argument den Wert msoCalloutDropCustom angeben, schlägt der Code fehl.


Beispiel zur PresetDrop-Methode

In diesem Beispiel wird festgelegt, dass in myDocument die Legendenlinie der ersten Form am oberen Rand des Textbegrenzungsrechtecks angefügt wird. Damit das Beispiel funktioniert, muss es sich bei der Form um eine Legende handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).Callout.PresetDrop msoCalloutDropTop

In diesem Beispiel wird in myDocument zwischen zwei vordefinierten Ansätzen umgeschaltet. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um eine Legende handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropTop Then
        .PresetDrop msoCalloutDropBottom
    ElseIf .DropType = msoCalloutDropBottom Then
        .PresetDrop msoCalloutDropTop
    End If
End With


PresetGradient-Methode

Legt für die angegebene Füllung einen voreingestellten Verlauf fest.

Syntax

Ausdruck.PresetGradient(GradientStyle, Variant, PresetGradientType)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

GradientStyle Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der einer der vier Varianten in der Registerkarte Graduell des Dialogfelds Fülleffekte entspricht. Falls GradientStyle die Konstante msoGradientFromCenter besitzt, kann das Argument Variant nur 1 oder 2 sein.

PresetGradientType Long erforderlich. Der Verlaufstyp. Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed


Beispiel zur PresetGradient-Methode

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .PresetGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.PresetGradientType
    End With
End If


PresetTextured-Methode

Legt das angegebene Füllformat für eine voreingestellte Struktur fest.

Syntax

Ausdruck.PresetTextured(PresetTexture)

Ausdruck Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PresetTexture Long erforderlich. Die voreingestellte Struktur. Kann einer der folgenden MsoPresetTexture-Werte sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat


Beispiel zur PresetTextured-Methode

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillTextured Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        If c1f.TextureType = msoTexturePreset Then
            .PresetTextured c1f.PresetTexture
        Else
            .UserTextured c1f.TextureName
        End If
    End With
End If


Previous-Methode

Gibt ein Comment-Objekt zurück, das den vorherigen Kommentar darstellt.

Syntax

Ausdruck.Previous

Ausdruck Erforderlich. Ein Ausdruck, der ein Comment-Objekt zurückgibt.

Anmerkungen

Diese Methode funktioniert nur auf einem einzigen Blatt. Wird diese Methode auf den ersten Kommentar eines Blattes angewendet, so wird Null zurückgegeben (und nicht der vorherige Kommentar auf dem vorherigen Blatt).


Beispiel zur Previous-Methode

In diesem Beispiel wird der vorherige Kommentar ausgeblendet.

Range("a1").Comment.Previous.Visible = False


PrintOut-Methode

Druckt das Objekt.

Syntax

Ausdruck.PrintOut(From, To, Copies, Preview, ActivePrinter, PrintToFile, Collate, PrToFileName)

Ausdruck Ein erforderlicher Ausdruck, der ein Objekt zurückgibt, das gedruckt werden soll.

From Variant optional. Die Nummer der ersten Seite, die gedruckt werden soll. Wenn Sie dieses Argument weglassen, wird von der ersten Seite an gedruckt.

To Variant optional. Die Nummer der letzten Seite, die gedruckt werden soll. Wenn Sie dieses Argument weglassen, wird bis zur letzten Seite gedruckt.

Copies Variant optional. Die Anzahl der zu druckenden Kopien. Ohne die Angabe des Arguments wird eine Kopie gedruckt.

Preview Variant optional. Wenn dieses Argument den Wert True hat, ruft Microsoft Excel die Seitenansicht auf, bevor das Objekt gedruckt wird. Wenn das Argument den Wert True hat oder nicht angegeben ist, wird das Objekt sofort gedruckt.

ActivePrinter Variant optional. Gibt den Namen des aktiven Druckers an.

PrintToFile Variant optional. Wenn dieses Argument den Wert True hat, erfolgt die Ausgabe in eine Datei. Microsoft Excel fordert den Benutzer zur Eingabe des Dateinamens auf.

Collate Variant optional. Wenn dieses Argument den Wert True hat, werden Mehrfachkopien sortiert.

PrToFileName Optional Variant. Falls PrintToFile auf True gesetzt ist, nennt dieses Argument den Namen der Datei, die Sie ausducken möchten.

Anmerkungen

Der Begriff "Seiten" in der Beschreibung der Argumente From und To bezieht sich auf gedruckte Seiten und nicht auf sämtliche Seiten des Blattes oder der Arbeitsmappe.


Beispiel zur PrintOut-Methode

In diesem Beispiel wird das aktive Tabellenblatt gedruckt.

ActiveSheet.PrintOut


PrintPreview-Methode

Zeigt ein Objekt so an, wie es gedruckt wird.

Syntax

Ausdruck.PrintPreview

Ausdruck Ein erforderlicher Ausdruck, der das anzuzeigende Objekt zurückgibt.


Beispiel zur PrintPreview-Methode

In diesem Beispiel wird Sheet1 in der Seitenansicht angezeigt.

Worksheets("Sheet1").PrintPreview


PrintQuality-Methode

Gibt die Druckqualität zurück oder legt sie fest.

Syntax

Ausdruck.PrintQuality(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PageSetup-Objekt zurückgibt.

Index Variant optional. Horizontale Druckqualität (1) oder vertikale Druckqualität (2). Einige Drucker unterstützen keine Einstellungen für die vertikale Druckqualität. Wenn Sie dieses Argument nicht angeben, gibt die PrintQuality-Methode eine Matrix mit zwei Elementen sowohl für die horizontale als auch für die vertikale Druckqualität zurück (bzw. legt eine solche Matrix fest).


Beispiel zur PrintQuality-Methode

In diesem Beispiel wird die Druckqualität eines Druckers festgelegt, der keine quadratischen Pixel druckt. Die Matrix gibt sowohl die horizontale als auch die vertikale Druckqualität an. Das Makro erzeugt möglicherweise (abhängig vom verwendeten Druckertreiber) einen Fehler.

Worksheets("Sheet1").PageSetup.PrintQuality = Array(240, 140)

In diesem Beispiel wird die aktuelle Einstellung für die horizontale Druckqualität festgelegt.

MsgBox "Horizontal Print Quality is " & _
    Worksheets("Sheet1").PageSetup.PrintQuality(1)


Protect-Methode

Schützt ein Diagramm oder Tabellenblatt (Syntax 1) bzw. eine Arbeitsmappe (Syntax 2), so dass es bzw. sie nicht geändert werden kann.

Syntax 1

Ausdruck.Protect(Password, DrawingObjects, Contents, Scenarios, UserInterfaceOnly)

Syntax 2

Ausdruck.Protect(Password, Structure, Windows)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart- oder Worksheet-Objekt (Syntax 1) bzw. ein Workbook-Objekt (Syntax 2) zurückgibt.

Password Variant optional. Eine Zeichenfolge, die ein von Groß-/Kleinschreibung abhängiges Kennwort für das Blatt oder die Arbeitsmappe festlegt. Wenn Sie dieses Argument weglassen, kann der Schutz des Blattes oder der Arbeitsmappe ohne Angabe eines Kennworts aufgehoben werden. Weisen Sie dagegen ein Kennwort zu, muss das Kennwort angegeben werden, um den Schutz des Blattes oder der Arbeitsmappe aufzuheben. Falls Sie das Kennwort vergessen, können Sie den Schutz des Blattes oder der Arbeitsmappe nicht wieder aufheben. Sie sollten daher eine Liste Ihrer Kennwörter und der zugehörigen Dateinamen an einem sicheren Ort aufbewahren.

DrawingObjects Variant optional. Wenn True, werden Formen geschützt. Die Voreinstellung ist False.

Contents Variant optional. Wenn True, wird der Inhalt geschützt. Bei einem Diagramm wird das gesamte Diagramm geschützt. Bei einem Tabellenblatt werden die einzelnen Zellen geschützt. Die Voreinstellung ist True.

Scenarios Variant optional. Wenn True, werden Szenarios geschützt. Das Argument gilt nur für Arbeitsmappen. Die Voreinstellung ist True.

Structure Variant optional. Wenn True, wird die Struktur der Arbeitsmappe geschützt (die relative Position der Blätter). Die Voreinstellung ist False.

UserInterfaceOnly Variant optional. Wenn True, wird die Benutzeroberfläche, jedoch keine Makros geschützt. Ohne Angabe dieses Arguments gilt der Schutz für Makros und die Benutzeroberfläche.

Windows Variant optional. Wenn True, werden die Fenster der Arbeitsmappe geschützt. Ohne Angabe dieses Arguments werden die Fenster nicht geschützt.

Anmerkungen

Wenn Sie die Protect-Methode mit dem auf True gesetzten UserInterfaceOnly-Argument bei einem Tabellenblatt anwenden und dann die Arbeitsmappe speichern, ist bei erneutem Öffnen der Arbeitsmappe das gesamte Tabellenblatt (und nicht nur die Oberfläche) geschützt. Um den Schutz des Tabellenblatts aufzuheben, die Benutzeroberfläche aber nach Öffnen der Arbeitsmappe weiter zu schützen, müssen Sie wieder die Protect -Methode mit dem auf True gesetzten UserInterfaceOnly anwenden.


ProtectSharing-Methode

Speichert eine Arbeitsmappe und schützt sie zur gemeinsamen Verwendung.

Syntax

Ausdruck.ProtectSharing(Filename, Password, WriteResPassword, ReadOnlyRecommended, CreateBackup, SharingPassword)

Ausdruck Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Filename Variant optional. Eine Zeichenfolge, die den Namen der gespeicherten Datei festlegt. Sie können einen vollständigen Pfad angeben; andernfalls speichert Microsoft Excel die Datei in dem aktuellen Ordner.

Password Variant optional. Eine von Groß-/Kleinschreibung abhängige Zeichenfolge, die das Schutzkennwort festlegt, das der Datei zugeordnet werden soll. Sie darf maximal 15 Zeichen umfassen.

WriteResPassword Variant optional. Eine Zeichenfolge, die das Kennwort zum Schreibzugriff auf die Datei festlegt. Wird eine Datei mit dem Kennwort gespeichert, und es wird beim Öffnen der Datei nicht angegeben, so wird die Datei schreibgeschützt geöffnet.

ReadOnlyRecommended Variant optional. Falls True, wird beim Öffnen der Datei eine Meldung angezeigt, die vorschlägt, die Datei schreibgeschützt zu öffnen.

CreateBackup Variant optional. Falls True, wird eine Sicherungskopie der Datei erstellt.

SharingPassword Variant optional. Eine Zeichenfolge, die das Kennwort festlegt, das benutzt werden muss, um die Datei für die gemeinsame Benutzung zu schützen.


Beispiel zur ProtectSharing-Methode

In diesem Beispiel wird die erste Arbeitsmappe gespeichert und für die gemeinsame Benutzung geschützt.

Workbooks(1).ProtectForSharing Password:="drowssap", _
    SharingPassword:="gnirahs"


Publish-Methode

Speichert ein Element oder eine Auflistung von Elementen in einem Dokument in einer Webseite.

Syntax

Ausdruck.Publish(Create)

Ausdruck Ein Ausdruck, der eine PublishObject-Objekt oder eine PublishObjects-Auflistung zurückgibt.

Create Variant optional. Dieses Argument wird nur bei einem PublishObject-Objekt verwendet. Ist eine HTML-Datei vorhanden, wird bei der Argumentsetzung auf True die Datei ersetzt und bei Argumentsetzung auf False das Element oder die Elemente am Ende der Datei eingefügt. Ist keine Datei vorhanden, wird unabhängig von dem Wert des Create-Argumentes eine Datei erstellt.

Anmerkungen

Die FileName-Eigenschaft gibt den Standort und die Bezeichnung der HTML-Datei zurück bzw. legt sie fest.


Beispiel zur Publish-Methode

In diesem Beispiel wird der Bereich D5:D9 in dem Tabellenblatt "First Quarter" in der aktiven Arbeitsmappe in einer Webseite mit dem Namen "stockreport.htm" gespeichert. Die Tabellenkomponente wird verwendet, um die Webseite mit einer Interaktivität zu erweitern.

ActiveWorkbook.PublishObjects.Add( _
    SourceType:=xlSourceRange, _
    Filename:="\\Server2\Q1\stockreport.htm", _
    Sheet:="First Quarter", _
    Source:="D5:D9", _
    HTMLType:=xlHTMLCalc).Publish


PurgeChangeHistoryNow-Methode

Entfernt Einträge aus dem Änderungsprotokoll der angegebenen Arbeitsmappe.

Syntax

Ausdruck.PurgeChangeHistoryNow(Days, SharingPassword)

Ausdruck Ein Ausdruck der ein Workbook-Objekt zurückgibt.

Days Long erforderlich. Die Anzahl der Tage, in denen Änderungen im Änderungsprotokoll behalten werden.

SharingPassword Variant optional. Das Kennwort, das den Freigabeschutz der Arbeitsmappe aufhebt. Falls die Arbeitsmappe mit einem Kennwort gegen Freigabe geschützt und dieses Argument nicht angegeben ist, wird der Benutzer zur Eingabe des Kennworts aufgefordert.


Beispiel zur PurgeChangeHistoryNow-Methode

In diesem Beispiel werden alle Änderungen, die älter als einen Tag sind, aus dem Änderungsprotokoll der aktiven Arbeitsmappe entfernt.

ActiveWorkbook.PurgeChangeHistoryNow Days:=1


Quit-Methode

Beendet Microsoft Excel.

Syntax

Ausdruck.Quit

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Wenn beim Aufruf dieser Methode ungespeicherte Arbeitsmappen geöffnet sind, gibt Ihnen Microsoft Excel mit einem Dialogfeld die Möglichkeit, die Änderungen zu speichern. Das Dialogfeld erscheint nicht, wenn Sie vor dem Aufruf der Quit-Methode die DisplayAlerts-Eigenschaft auf False setzen. In diesem Fall zeigt Microsoft Excel das Dialogfeld auch dann nicht an, wenn Sie das Programm beenden und noch ungespeicherte Arbeitsmappen haben, d. h., die Änderungen in den Arbeitsmappen gehen verloren.

Wenn Sie die Saved-Eigenschaft einer Arbeitsmappe auf True setzen, ohne die Arbeitsmappe auf der Festplatte zu speichern, wird Microsoft Excel ohne Aufforderung zum Speichern der Arbeitsmappe beendet.


Beispiel zur Quit-Methode

In diesem Beispiel werden alle geöffneten Arbeitsmappen gespeichert und Microsoft Excel anschließend beendet.

For Each w In Application.Workbooks
    w.Save
Next w
Application.Quit


RadarGroups-Methode

Gibt für ein 2D-Diagramm ein Objekt zurück, das eine einzelne Netzdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Netzdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.RadarGroups(Index)

Syntax 2

Ausdruck.RadarGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur RadarGroups-Methode

In diesem Beispiel wird die erste Netzgruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird. Wenden Sie das Beispiel auf ein 2D-Diagramm an.

Charts("Chart1").RadarGroups(1).VaryByCategories = True


RangeFromPoint-Methode

Gibt das Shape- oder Range-Objekt zurück, das sich an dem angegebenen Bildschirmkoordinatenpaar befindet. Wenn sich an den angegebenen Koordinaten keine Form befindet, gibt diese Methode Nothing zurück.

Syntax

Ausdruck.RangeFromPoint(x, y)

Ausdruck Ein Ausdruck, der ein Window-Objekt zurückgibt.

x Long erforderlich. Der Wert (in Pixel), der die horizontale Entfernung vom linken Bildschirmrand darstellt (oben beginnend).

y Long erforderlich. Der Wert (in Pixel), der die vertikale Entfernung vom oberen Bildschirmrand darstellt (links beginnend).


Beispiel zur RangeFromPoint-Methode

In diesem Beispiel wird der alternative Text für die Form unmittelbar unter dem Mauszeiger zurückgegeben, falls die Form ein Diagramm, eine Linie oder ein Bild ist.

Private Function AltText(ByVal intMouseX As Integer, _
        ByVal intMouseY as Integer) As String
    Set objShape = ActiveWindow.RangeFromPoint _
        (x:=intMouseX, y:=intMouseY)
    If Not objShape Is Nothing Then
        With objShape
            Select Case .Type
                Case msoChart, msoLine, msoPicture:
                    AltText = .AlternativeText
                Case Else:
                    AltText = ""
            End Select
        End With
    Else
        AltText = ""
    End If
End Function


Record-Methode

Diese Methode sollte nicht verwendet werden. Audionotizen wurden aus Microsoft Excel entfernt.


RecordMacro-Methode

Zeichnet Code auf, wenn der Makro-Recorder aktiviert ist.

Syntax

Ausdruck.RecordMacro(BasicCode, XlmCode)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

BasicCode Variant optional. Eine Zeichenfolge, die den Visual Basic-Code angibt, der bei der Aufzeichnung eines Makros in ein Visual Basic-Modul entsteht. Die Zeichenfolge wird in einer Zeile aufgezeichnet. Wenn die Zeichenfolge ein Wagenrücklaufzeichen (ASCII-Zeichen 10 oder Chr$(10) im Code) enthält, wird sie in mehreren Zeilen aufgezeichnet.

XlmCode Variant optional. Dieses Argument wird ignoriert.

Anmerkungen

Die RecordMacro-Methode kann nicht in das aktive Modul aufzeichnen (das Modul, in dem sich die RecordMacro-Methode befindet).

Wenn BasicCode nicht angegeben wird und die Anwendung in ein Visual Basic-Modul aufzeichnet, zeichnet Microsoft Excel eine entsprechende Application.Run-Anweisung auf.

Sie können die Aufzeichnung verhindern (zum Beispiel, wenn der Benutzer den Dialog abbricht), indem Sie diese Funktion mit zwei leeren Zeichenfolgen aufrufen.


Beispiel zur RecordMacro-Methode

In diesem Beispiel wird Visual Basic-Code aufgezeichnet.

Application.RecordMacro BasicCode:="Application.Run ""MySub"" "


Refresh-Methode

Aktualisiert den PivotTable-Cache oder die Abfragetabelle.

Syntax

Ausdruck.Refresh(BackgroundQuery)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-, PivotCache- oder ein QueryTable-Objekt zurückgibt. Beim PivotCache-Objekt muss dem Cache mindestens ein PivotTable-Bericht zugeordnet sein.

BackgroundQuery Variant optional. Wird nur bei Abfragetabellen verwendet, die auf den Ergebnissen einer SQL-Abfrage basieren. True, wenn die Steuerung wieder der Prozedur zurückgegeben wird, sobald die Datenbankverbindung hergestellt ist und die Abfrage gestartet wurde (die Abfrage wird im Hintergrund aktualisiert). False, wenn die Steuerung erst wieder an die Prozedur zurückgegeben wird, nachdem alle Daten aus dem Tabellenblatt geholt wurden. Wird dieses Argument nicht angegeben, so legt die Einstellung der BackgroundQuery-Eigenschaft den Abfragemodus fest.

Anmerkungen

Die folgenden Anmerkungen gelten für QueryTable-Objekte, die auf den Ergebnissen einer SQL-Abfrage basieren.

Durch die Refresh-Methode wird Microsoft Excel mit der Datenquelle der Abfragetabelle verbunden, führt die SQL-Abfrage aus und gibt die Daten an den Zielbereich der Abfragetabelle zurück. Bis diese Methode aufgerufen wird, kommuniziert die Abfragetabelle mit der Datenquelle nicht.

Beim Herstellen der Verbindung zur OLE DB- oder ODBC-Datenquelle verwendet Microsoft Excel die Verbindungszeichenfolge, die in der Connection-Eigenschaft festgelegt ist. Fehlen in der angegebenen Verbindungszeichenfolge benötige Werte, so zeigt der Treibermanager für den Datenzugriff oder der Treiber (oder beide) modale Dialogfelder an, in denen die Benutzerin oder der Benutzer zur Eingabe der benötigten Daten aufgefordert wird. Wenn die DisplayAlerts-Eigenschaft den Wert False besitzt, werden keine Dialogfelder angezeigt, und die Refresh-Methode bricht mit dem Fehler "Nicht ausreichende Verbindungsinformation" ab.

Nach dem erfolgreichen Verbindungsaufbau speichert Microsoft Excel die vervollständigte Verbindungszeichenfolge, so dass während dieser Bearbeitungssitzung bei erneuten Aufrufen der Refresh-Methode keine weiteren Eingabeaufforderungen angezeigt werden. Die vervollständigte Vebindungszeichenfolge erhalten Sie, wenn Sie den Wert der Connection-Eigenschaft untersuchen.

Nach dem Aufbau der Datenbankverbindung wird die SQL-Abfrage überprüft. Ist sie nicht richtig, so bricht die Refresh-Methode mit dem Fehler "SQL-Syntax-Fehler" ab.

Wenn die Abfrage Parameter benötigt, muss die Parameters-Auflistung mit Informationen initialisiert worden sein, durch die Parameter eingebunden wurden. Sind nicht genügend Parameter eingebunden, bricht die Refresh-Methode mit dem Fehler "Parameter Fehler-Ausnahme" ab. Wurde festgelegt, dass die Parameter erst nach Eingabeaufforderung angegeben werden, so werden dem Benutzer, unabhängig davon, wie die DisplayAlerts-Eigenschaft festgelegt ist, Dialogfelder angezeigt. Bricht die Benutzerin oder der Benutzer ein Parameter-Dialogfeld ab, so bricht die Refresh-Methode ab und gibt den Wert False zurück. Sind in die Parameters-Auflistung zusätzliche Parameter eingebunden, werden diese ignoriert.

Die Refresh-Methode gibt den Wert True zurück, wenn die Abfrage erfolgreich abgeschlossen oder begonnen wird; sie gibt den Wert False zurück, wenn die Benutzerin oder der Benutzer eine Verbindung oder ein Dialogfeld abbricht.

Um zu sehen, ob die Anzahl der geholten Zeilen die Anzahl der verfügbaren Zeilen im Tabellenblatt übersteigt, untersuchen Sie die FetchedRowOverflow-Eigenschaft. Sie wird bei jedem Aufruf der Refresh-Methode initialisiert.


RefreshAll-Methode

Aktualisiert alle externen Datenbereiche und PivotTable-Berichte in der angegebenen Arbeitsmappe.

Syntax

Ausdruck.RefreshAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Anmerkungen

Objekte, bei denen die BackgroundQuery-Eigenschaft auf True festgelegt ist, werden im Hintergrund aktualisiert.


Beispiel zur RefreshAll-Methode

In diesem Beispiel werden alle externen Datenbereiche und PivotTable-Berichte in der dritten Arbeitsmappe aktualisiert.

Workbooks(3).RefreshAll


RefreshTable-Methode

Aktualisiert den PivotTable-Bericht mit den Quelldaten. Gibt bei erfolgreicher Aktualisierung True zurück.

Syntax

Ausdruck.RefreshTable

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.


Beispiel zur RefreshTable-Methode

In diesem Beispiel wird der PivotTable-Bericht aktualisiert.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.RefreshTable


RegisterXLL-Methode

Lädt eine XLL-Code-Ressource und registriert automatisch die darin enthaltenen Funktionen und Befehle.

Syntax

Ausdruck.RegisterXLL(Filename)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Filename String erforderlich. Der Name der zu ladenden XLL.

Anmerkungen

Diese Methode gibt True zurück, falls die Code-Ressource erfolgreich geladen wird. Andernfalls gibt die Methode False zurück.


Beispiel zur RegisterXLL-Methode

In diesem Beispiel wird eine XLL-Datei geladen, und die darin enthaltenen Funktionen und Befehle werden registriert

Application.RegisterXLL "XLMAPI.XLL"


Regroup-Methode

Stellt die Gruppe wieder her, der der angegebene Formbereich zuvor angehörte. Gibt die neu gruppierten Formen als einzelnes Shape-Objekt zurück.

Syntax

Ausdruck.Regroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Die Regroup-Methode stellt die Gruppe der ersten zuvor gruppierten Form wieder her, die sie in der angegebenen ShapeRange-Auflistung findet. Wenn der angegebene Formbereich Formen enthält, die zuvor zu unterschiedlichen Gruppen gehörten, wird nur eine der Gruppen wiederhergestellt.

Beachten Sie, dass sich durch Bilden und Aufheben von Gruppen die Anzahl der Elemente in der Shapes-Auflistung und die Indexnummern der Elemente ändern, die den betroffenen Elementen in der Auflistung nachfolgen, weil eine Gruppe von Formen als einzelne Form behandelt wird.


Beispiel zur Regroup-Methode

In diesem Beispiel wird die Gruppierung der markierten Formen im aktiven Fenster wiederhergestellt. Wenn die Formen zuvor nicht gruppiert waren und die Gruppierung nicht aufgehoben wurde, schlägt dieses Beispiel fehl.

ActiveWindow.Selection.ShapeRange.Regroup


RejectAllChanges-Methode

Lehnt alle Änderungen in der angegebenen gemeinsam genutzten Arbeitsmappe ab.

Syntax

Ausdruck.RejectAllChanges

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.


Beispiel zur RejectAllChanges-Methode

In diesem Beispiel werden alle Änderungen in der aktiven Arbeitsmappe abgelehnt.

ActiveWorkbook.RejectAllChanges


ReloadAs-Methode

Lädt eine Arbeitsmappe, die auf einem HTML-Dokument basiert, erneut, wobei die angegebene Dokumentcodierung verwendet wird.

Syntax

Ausdruck.ReloadAs(Encoding)

Ausdruck Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Encoding msoEncoding erforderlich. Die zu verwendende Dokumentcodierung, wenn die angegebene Webseite erneut geladen wird. In Visual Basic-Editor finden Sie unter Objektkatalog eine Liste zulässiger Dokumentcodierungen.


Beispiel zur ReloadAs-Methode

In diesem Beispiel wird die erste Arbeitsmappe unter Verwendung der Western-Dokumentcodierung neu geladen.

Workbooks(1).ReloadAs Encoding:=msoEncodingWestern


RemoveAllItems-Methode

Entfernt alle Einträge aus Microsoft Excel-Listenfeldern oder Kombinationsfeldern. Verwenden Sie die Clear-Methode, um alle Elemente aus einem ActiveX-Listenfeld oder Kombinationsfeld zu entfernen.

Syntax

Ausdruck.RemoveAllItems

Ausdruck Erforderlich. Ein Ausdruck, der ein ControlFormat-Objekt zurückgibt.


Beispiel zur RemoveAllItems-Methode

In diesem Beispiel werden alle Elemente aus einem Listenfeld entfernt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Worksheets(1).Shapes(2).ControlFormat.RemoveAllItems


RemoveItem-Methode

Entfernt ein oder mehrere Elemente aus einem Listenfeld oder Kombinationsfeld.

Syntax

Ausdruck.RemoveItem(Index, Count)

Ausdruck Ein Ausdruck, der ein ControlFormat-Objekt zurückgibt.

Index Long erforderlich. Die Nummer des ersten zu entfernenden Elements. Gültige Werte sind 1 bis zur Anzahl der Elemente in der Liste (diese werden durch die ListCount-Eigenschaft zurückgegeben).

Count Variant optional. Die Anzahl der zu entfernenden Elemente, beginnend bei Index. Wird dieses Argument nicht angegeben, so wird ein Element entfernt. Wenn Index + Count die Anzahl der Elemente in der Liste übersteigt, werden alle Elemente der Liste von Index bis zum Ende der Liste ohne Auftreten eines Fehlers entfernt.

Anmerkungen

Falls für das angegebene Objekt ein Füllbereich definiert ist, schlägt diese Methode fehl.

Verwenden Sie die RemoveAllItems-Methode um alle Einträge aus einem Microsoft Excel-Listenfeld oder Kombinationsfeld zu entfernen. Verwenden Sie die Clear-Methode, um alle Elemente aus einem ActiveX-Listenfeld oder Kombinationsfeld zu entfernen.


Beispiel zur RemoveItem-Methode

In diesem Beispiel wird das markierte Element eines Listenfeldes entfernt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Set lbcf = Worksheets(1).Shapes(2).ControlFormat
lbcf.RemoveItem lbcf.ListIndex


RemoveSubtotal-Methode

Entfernt Teilergebnisse aus einer Liste.

Syntax

Ausdruck.RemoveSubtotal

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur RemoveSubtotal-Methode

In diesem Beispiel werden Teilergebnisse für den Bereich A1:G37 in Sheet1 entfernt. Wenden Sie das Beispiel auf eine Liste mit Teilergebnissen an.

Worksheets("Sheet1").Range("A1:G37").RemoveSubtotal


RemoveUser-Methode

Trennt den angegebenen Benutzer von der gemeinsam genutzten Arbeitsmappe.

Syntax

Ausdruck.RemoveUser(Index)

Ausdruck Erforderlich. Ein Ausdruck der ein Workbook-Objekt zurückgibt.

Index Long erforderlich. Der Benutzerindex.


Beispiel zur RemoveUser-Methode

In diesem Beispiel wird der Benutzer Zwei von der gemeinsam genutzten Arbeitsmappe getrennt.

Workbooks(2).RemoveUser 2


Repeat-Methode

Wiederholt die letzte Benutzeraktion.

Syntax

Ausdruck.Repeat

Ausdruck Ein erforderlicher Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Mit dieser Methode kann nur die Benutzeraktion wiederholt werden, die zuletzt vor der Ausführung des Makros durchgeführt wurde. Die Methode muss in der ersten Zeile des Makros aufgerufen werden. Das Wiederholen von Visual Basic-Befehlen ist mit dieser Methode nicht möglich.


Beispiel zur Repeat-Methode

In diesem Beispiel wird die letzte Benutzeraktion wiederholt. Das Beispiel muss am Anfang des Makros stehen.

Application.Repeat


Replace-Methode

Sucht und ersetzt Zeichen in Zellen des angegebenen Bereichs. Bei Verwendung dieser Methode wird weder die Markierung noch die aktive Zelle geändert.

Hilfe zur Verwendung der Ersetzen-Tabellenfunktion in Visual Basic finden Sie unter Verwenden von Tabellenfunktionen in Visual Basic.

Syntax

Ausdruck.Replace(What, Replacement, LookAt, SearchOrder, MatchCase, MatchByte)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

What String erforderlich. Die Zeichenfolge, die Microsoft Excel suchen soll.

Replacement String erforderlich. Die zu ersetzende Zeichenfolge.

LookAt Variant optional. Zulässig ist eine der folgenden XlLookAt-Konstanten: xlWhole oder xlPart.

SearchOrder Variant optional. Zulässig ist eine der folgenden XlSearchOrder-Konstanten: xlByRows oder xlByColumns.

MatchCase Variant optional. True, wenn Groß- und Kleinschreibung bei der Suche berücksichtigt wird.

MatchByte Variant optional. Sie können dieses Argument nur verwenden, wenn in Microsoft Excel die double byte-Sprachunterstützung ausgewählt oder installiert wurde. Wenn True, werden double byte-Zeichen nur mit double byte-Zeichen verglichen. Wenn False, so können double byte-Zeichen mit den entsprechenden single byte-Zeichen übereinstimmen.

Anmerkungen

Die Angaben für LookAt, SearchOrder, MatchCase und MatchByte werden jedesmal gespeichert, wenn Sie diese Methode verwenden. Falls Sie beim nächsten Aufruf dieser Methode keine Werte für die Argumente angeben, werden die gespeicherten Werte verwendet. Die Angaben dieser Argumente ändern die Angaben im Dialogfeld Suchen, und eine Änderung der Angaben im Dialogfeld Suchen ändert die gespeicherten Werte, die verwendet werden, falls diese Argumente angegeben werden. Um Probleme zu vermeiden, sollten Sie die Argumente bei jeder Verwendung dieser Methode ausdrücklich angeben.

Die Replace-Methode gibt immer True zurück.


ReplacementList-Methode

Gibt die Matrix der AutoKorrektur-Ersetzungen zurück oder legt sie fest.

Syntax

Ausdruck.ReplacementList(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein AutoCorrect-Objekt zurückgibt.

Index Variant optional. Die Zeile der Matrix der AutoKorrektur-Ersetzungen, die zurückgegeben werden soll. Die Zeile wird als eindimensionale Matrix mit zwei Elementen zurückgegeben. Das erste Element ist der Text in Spalte 1, das zweite Element der Text in Spalte 2. Befindet sich Index außerhalb des Bereichs, schlägt diese Methode fehl.

Wird Index nicht angegeben, gibt diese Eigenschaft eine zweidimensionale Matrix zurück. Jede Zeile in der Matrix enthält eine Ersetzung, wie in der folgenden Tabelle dargestellt.

Spalte | Inhalt
1 | Der zu ersetzende Text
2 | Der Ersatztext

Anmerkungen

Verwenden Sie die AddReplacement-Methode, um zur Liste der Ersetzungen einen Eintrag hinzuzufügen.


Beispiel zur ReplacementList-Methode

In diesem Beispiel wird die Ersetzungsliste nach "Temperature" durchsucht und der Ersatzeintrag angezeigt, falls dieser vorhanden ist.

repl = Application.AutoCorrect.ReplacementList
For x = 1 To UBound(repl)
        If repl(x, 1) = "Temperature" Then MsgBox repl(x, 2)
Next


RerouteConnections-Methode

Erstellt Verbindungen neu, so dass sie auf dem kürzesten Weg zwischen den Formen verlaufen, die sie verbinden. Zu diesem Zweck kann es vorkommen, dass die RerouteConnections-Methode die Enden einer Verbindung löst und sie an anderen Verbindungspunkten der verbundenen Formen anfügt.

Diese Methode erstellt alle Verbindungen neu, die der angegebenen Form angefügt sind. Handelt es sich bei der angegebenen Form um eine Verbindung, wird sie neu erstellt.

Syntax

Ausdruck.RerouteConnections

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Wird diese Methode auf eine Verbindung angewendet, wird nur diese Verbindung neu erstellt. Wird diese Methode auf eine verbundene Form angewendet, werden alle Verbindungen zu dieser Form neu erstellt.


Beispiel zur RerouteConnections-Methode

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und durch eine gekrümmte Verbindung verbunden. Anschließend wird die Verbindung neu erstellt, so dass sie auf dem kürzesten Weg zwischen den beiden Rechtecken verläuft. Beachten Sie, dass die RerouteConnections-Methode Größe und Position der Verbindung anpasst und festlegt, an welchen Verbindungspunkten sie angefügt wird. Deshalb sind die Werte, die Sie anfangs für die mit den Methoden BeginConnect und EndConnect verwendeten ConnectionSite-Argumente angegebenen haben, ohne Bedeutung.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, _
    100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, _
    300, 300, 200, 100)
Set newConnector = s.AddConnector(msoConnectorCurve, _
    0, 0, 100, 100)
With newConnector.ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
End With
newConnector.RerouteConnections


Reset-Methode

Setzt den Verteiler zurück, so dass eine neue Übermittlung mit dem gleichen Verteiler (mit der gleichen Empfängerliste und den gleichen Übermittlungsinformationen) eingeleitet werden kann. Das Weiterleiten muss abgeschlossen sein, bevor Sie diese Methode verwenden. Die Anwendung dieser Methode unter anderen Voraussetzungen führt zu einer Fehlermeldung.

Syntax

Ausdruck.Reset

Ausdruck Erforderlich. Ein Ausdruck, der ein RoutingSlip-Objekt zurückgibt.


ResetAllPageBreaks-Methode

Setzt alle Seitenwechsel im angegebenen Tabellenblatt zurück.

Syntax

Ausdruck.ResetAllPageBreaks()

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.


Beispiel zur ResetAllPageBreaks-Methode

In diesem Beispiel werden alle Seitenwechsel im ersten Tabellenblatt zurückgesetzt.

Worksheets(1).ResetAllPageBreaks


ResetColors-Methode

Setzt die Farbpalette auf die Standardfarben zurück.

Syntax

Ausdruck.ResetColors

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.


Beispiel zur ResetColors-Methode

In diesem Beispiel wird die Farbpalette der aktiven Arbeitsmappe zurückgesetzt.

ActiveWorkbook.ResetColors


ResetRotation-Methode

Setzt die Projektionsdrehung um die X- und die Y-Achse auf 0 (Null) zurück, so dass die Vorderseite der Projektion nach vorne zeigt. Die Drehung um die Z-Achse wird durch diese Methode nicht zurückgesetzt.

Syntax

Ausdruck.ResetRotation

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

Anmerkungen

Um die Projektionsdrehung um die X- und die Y-Achse auf einen anderen Wert als 0 (Null) zu setzen, verwenden Sie die Eigenschaften RotationX und RotationY des ThreeDFormat-Objekts. Um die Projektionsdrehung um die Z-Achse festzulegen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts, das die projizierte Form darstellt.


Beispiel zur ResetRotation-Methode

In diesem Beispiel wird in myDocument die Drehung der Projektion der ersten Form um die X- und die Y-Achse auf 0 (Null) zurückgesetzt.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).ThreeD.ResetRotation


ResetTimer-Methode

Setzt den Aktualisierungszeitgeber für die angegebene Abfragetabelle oder den angegebenen PivotTable-Bericht auf das Intervall ein, das zuletzt mit Hilfe der RefreshPeriod-Eigenschaft festgelegt wurde.

Syntax

Ausdruck.ResetTimer

Ausdruck Ein Ausdruck, der ein PivotCache- oder QueryTable-Objekt zurückgibt.


Beispiel zur ResetTimer-Methode

In diesem Beispiel wird der Aktualisierungszeitgeber für die erste Abfragetabelle im aktiven Tabellenblatt zurückgesetzt.

ActiveSheet.QueryTables(1).ResetTimer


Route-Methode

Leitet die Arbeitsmappe entsprechend den Einstellungen des aktuellen Verteilers weiter.

Syntax

Ausdruck.Route

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Anmerkungen

Durch Weiterleiten einer Arbeitsmappe wird die Routed-Eigenschaft auf True gesetzt.


Beispiel zur Route-Methode

In diesem Beispiel wird ein Verteiler für MAPPE1.XLS erstellt und die Arbeitsmappe den drei Empfängern nacheinander übermittelt.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
End With
Workbooks("BOOK1.XLS").Route


RowDifferences-Methode

Gibt ein Range-Objekt zurück, das alle Zellen darstellt, deren Inhalt sich vom Inhalt der Vergleichszelle jeder Zeile unterscheidet.

Syntax

Ausdruck.RowDifferences(Comparison)

Ausdruck Erforderlich. Ein Ausdruck, der den Bereich mit den zu vergleichenden Zellen zurückgibt.

Comparison Variant erforderlich. Eine einzelne Zelle, die mit dem angegebenen Bereich zu vergleichen ist.


Beispiel zur RowDifferences-Methode

In diesem Beispiel werden diejenigen Zellen in der ersten Zeile in Sheet1 markiert, deren Inhalt sich vom Inhalt der Zelle D1 unterscheidet.

Worksheets("Sheet1").Activate
Set c1 = ActiveSheet.Rows(1).RowDifferences( _
    comparison:=ActiveSheet.Range("D1"))
c1.Select


Run-Methode

Syntax 1: Führt ein Makro aus oder ruft eine Funktion auf. Diese Syntax eignet sich zur Ausführung eines Makros, das in Visual Basic oder der Microsoft Excel 4.0-Makrosprache geschrieben wurde, oder zur Ausführung einer Funktion in einer DLL oder XLL.

Syntax 2: Führt das Microsoft Excel 4.0-Makro an der aktuellen Position aus. Der Bereich muss sich in einer Makrovorlage befinden.

Syntax 1

Ausdruck.Run(Macro, Arg1, Arg2, ...)

Syntax 2

Ausdruck.Run(Arg1, Arg2, ...)

Ausdruck Optional für Application-Objekte; erforderlich für Range-Objekte. Ein Ausdruck, der die Anwendung zurückgibt, die das Makro enthält, oder den Bereich in einer Makrovorlage, der ein Microsoft Excel 4.0-Makro enthält.

Macro Variant erforderlich für Syntax 1 (wird in Syntax 2 nicht verwendet). Das auszuführende Makro. Es kann entweder eine Zeichenfolge mit dem Makronamen angegeben werden, oder ein Range-Objekt, welches die Position der Funktion bezeichnet, oder die Registerkennnummer einer registrierten DLL (XLL)-Funktion. Wenn eine Zeichenfolge verwendet wird, wird diese im Kontext des aktiven Blatts ausgewertet.

Arg1, Arg2, ... Variant optional. Die Argumente, die an die Funktion weiterzuleiten sind.

Anmerkungen

Benannte Argumente können mit dieser Methode nicht verwendet werden. Argumente müssen nach Position übergeben werden.

Die Run-Methode gibt den Rückgabewert des aufgerufenen Makros zurück. Objekte, die als Argumente an das Makro weitergeleitet werden, werden in Werte konvertiert (durch Zuweisung der Value-Eigenschaft an das Objekt). Das heißt, es ist mit der Run-Methode nicht möglich, Objekte an Makros weiterzuleiten.


RunAutoMacros-Methode

Führt die der Arbeitsmappe zugeordneten Makros "Auto_öffnen", "Auto_schließen", "Auto_aktivieren" und "Auto_deaktivieren" aus. Diese Methode wurde aufgenommen, um abwärts kompatibel zu sein. Wenn Sie im neuen Visual Basic Code programmieren, sollten Sie an Stelle dieser Makros die Ereignisse Open, Close, Activate und Deactivate verwenden.

Syntax

Ausdruck.RunAutoMacros(Which)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Which Erforderlich. Die auszuführenden Makros. Dies kann eine der folgenden XlRunAutoMacro-Konstanten sein:

Konstante | Beschreibung
xlAutoOpen | Auto_öffnen-Makros
xlAutoClose | Auto_schließen-Makros
xlAutoActivate | Auto_aktivieren-Makros
xlAutoDeactivate | Auto_deaktivieren-Makros


Beispiel zur RunAutoMacros-Methode

In diesem Beispiel wird die Arbeitsmappe ANALYSE.XLS geöffnet und das Makro "Auto_öffnen" ausgeführt.

Workbooks.Open "ANALYSIS.XLS"
ActiveWorkbook.RunAutoMacros xlAutoOpen

In diesem Beispiel wird das Makro "Auto_schließen" für die aktive Arbeitsmappe ausgeführt und die Arbeitsmappe geschlossen.

With ActiveWorkbook
    .RunAutoMacros xlAutoClose
    .Close
End With


Save-Methode

Speichert Änderungen in der angegebenen Arbeitsmappe.

Syntax

Ausdruck.Save

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Anmerkungen

Wenn Sie eine Arbeitsmappendatei öffnen möchten, verwenden Sie die Open-Methode.

Sie können eine Arbeitsmappe als gespeichert markieren, ohne sie auf einen Datenträger zu schreiben, indem Sie die zugehörige Saved-Eigenschaft auf True setzen.

Verwenden Sie beim ersten Speichern einer Arbeitsmappe die SaveAs-Methode, um einen Namen für die Datei anzugeben.


SaveAs-Methode

Speichert die in einem Blatt (Syntax 1) oder einer Arbeitsmappe (Syntax 2) vorgenommenen Änderungen in einer anderen Datei.

Syntax 1

Ausdruck.SaveAs(Filename, FileFormat, Password, WriteResPassword, ReadOnlyRecommended, CreateBackup, AddToMru, TextCodePage, TextVisualLayout)

Syntax 2

Ausdruck.SaveAs(Filename, FileFormat, Password, WriteResPassword, ReadOnlyRecommended, CreateBackup, AccessMode, ConflictResolution, AddToMru, TextCodePage, TextVisualLayout)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart- oder ein Worksheet-Objekt (Syntax 1) oder ein Workbook-Objekt (Syntax 2) zurückgibt.

Filename Variant optional. Eine Zeichenfolge, die den Namen der zu speichernden Datei angibt. Sie können den vollständigen Pfad angeben. Andernfalls speichert Microsoft Excel die Datei im aktuellen Ordner.

FileFormat Variant optional. Das beim Speichern der Datei zu verwendende Dateiformat. Eine Liste der gültigen Formate finden Sie unter der FileFormat-Eigenschaft. Bei einer vorhandenen Datei ist das Standardformat das zuletzt angegebene Dateiformat; bei einer neuen Datei wird standardmäßig das Format der eingesetzten Excel-Version verwendet.

Password Variant optional. Eine von der Groß-/Kleinschreibung abhängige Zeichenfolge (maximal 15 Zeichen), mit der das Schutzkennwort für die Datei angegeben wird.

WriteResPassword Variant optional. Eine Zeichenfolge, die das Kennwort für die Schreiberlaubnis der Datei angibt. Wenn eine Datei mit einem Kennwort gespeichert und das Kennwort beim Öffnen nicht angegeben wird, wird die Datei schreibgeschützt geöffnet.

ReadOnlyRecommended Variant optional. Falls True, wird beim Öffnen der Datei in einer Meldung empfohlen, die Datei schreibgeschützt zu öffnen.

CreateBackup Variant optional. Falls True, wird eine Sicherungsdatei erstellt.

AccessMode Variant optional. Der Zugriffsmodus der Arbeitsmappe. Dies kann eine der folgenden XlSaveAsAccessMode-Konstanten sein: xlShared (Freigabe), xlExclusive (Exklusivmodus) oder xlNoChange (Zugriffsmodus nicht ändern). Falls dieses Argument nicht angegeben wird, bleibt der Zugriffsmodus unverändert. Wenn Sie ein gemeinsam genutztes Dokument speichern, ohne den Dateinamen zu ändern, wird dieses Argument ignoriert. Verwenden Sie die ExclusiveAccess-Methode, um den Zugriffsmodus zu ändern.

ConflictResolution Variant optional. Gibt an, wie Änderungskonflikte gelöst werden, wenn die Arbeitsmappe ein gemeinsam genutztes Dokument ist. Dies kann eine der folgenden XlSaveConflictResolution-Konstanten sein: xlUserResolution (Anzeige des Dialogfelds Konflikte lösen), xlLocalSessionChanges (akzeptiert automatisch die Änderungen des lokalen Benutzers) oder xlOtherSessionChanges (Änderungen anderer Benutzer haben Vorrang vor denen des lokalen Benutzers). Falls dieses Argument nicht angegeben wird, wird das Dialogfeld Konflikte lösen angezeigt.

AddToMru Variant optional. Falls True, wird diese Arbeitsmappe der Liste der zuletzt geöffneten Dateien hinzugefügt. Der Standardwert ist False.

TextCodePage Variant optional. Wird in U.S. English Microsoft Excel nicht verwendet.

TextVisualLayout Variant optional. Wird in U.S. English Microsoft Excel nicht verwendet.


Beispiel zur SaveAs-Methode

In diesem Beispiel wird eine neue Arbeitsmappe erstellt. Danach wird der Benutzer aufgefordert, einen Dateinamen einzugeben; anschließend wird die Arbeitsmappe gespeichert.

Set NewBook = Workbooks.Add
Do
    fName = Application.GetSaveAsFilename
Loop Until fName <> False
NewBook.SaveAs Filename:=fName


SaveCopyAs-Methode

Speichert die in einem Blatt oder einer Arbeitsmappe vorgenommenen Änderungen in einer Datei, ändert aber nicht die geöffnete Arbeitsmappe im Speicher.

Syntax

Ausdruck.SaveCopyAs(Filename)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Filename Erforderlich. Gibt den Dateinamen für die Kopie an.


Beispiel zur SaveCopyAs-Methode

In diesem Beispiel wird die aktive Arbeitsmappe als Kopie gespeichert.

ActiveWorkbook.SaveCopyAs "C:\TEMP\XXXX.XLS"


SaveWorkspace-Methode

Speichert den aktuellen Arbeitsbereich.

Syntax

Ausdruck.SaveWorkspace(Filename)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Filename Variant optional. Der Name der gespeicherten Datei.


Beispiel zur SaveWorkspace-Methode

In diesem Beispiel wird der aktuelle Arbeitsbereich als "saved workspace.xlw" gespeichert.

Application.SaveWorkspace "saved workspace"


ScaleHeight-Methode

Skaliert die Höhe der Form um einen angegebenen Faktor. Bei Bildern und OLE-Objekten können Sie angeben, ob die Form relativ zu ihrer ursprünglichen oder ihrer aktuellen Größe skaliert werden soll. Andere Formen als Bilder und OLE-Objekte werden immer relativ zu ihrer aktuellen Höhe skaliert.

Syntax

Ausdruck.ScaleHeight(Factor, RelativeToOriginalSize, fScale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Legt das Verhältnis zwischen der Höhe der Form nach der Größenänderung und der aktuellen bzw. ursprünglichen Höhe fest. Um beispielsweise ein Rechteck um 50 Prozent zu vergrößern, muss für dieses Argument 1,5 angegeben werden.

RelativeToOriginalSize Long erforderlich. True, um die Form relativ zu ihrer Originalgröße zu skalieren. False, um sie relativ zu ihrer aktuellen Größe zu skalieren. Sie können für dieses Argument den Wert True nur dann festlegen, wenn es sich bei der angegebenen Form um ein Bild oder ein OLE-Objekt handelt.

fScale Long optional. Legt fest, welcher Teil der Form bei der Skalierung die Position beibehält. Kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight, msoScaleFromMiddle oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleHeight-Methode

In diesem Beispiel werden in myDocument alle Bilder und OLE-Objekte auf 175 Prozent ihrer ursprünglichen Höhe und Breite skaliert. Alle anderen Formen werden auf 175 Prozent ihrer aktuellen Höhe und Breite skaliert.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    Select Case s.Type
    Case msoEmbeddedOLEObject, _
            msoLinkedOLEObject, _
            msoOLEControlObject, _
            msoLinkedPicture, msoPicture
        s.ScaleHeight 1.75, True
        s.ScaleWidth 1.75, True
    Case Else
        s.ScaleHeight 1.75, False
        s.ScaleWidth 1.75, False
    End Select
Next


ScaleWidth-Methode

Skaliert die Breite der Form um einen angegebenen Faktor. Bei Bildern und OLE-Objekten können Sie angeben, ob die Form relativ zu ihrer ursprünglichen oder ihrer aktuellen Größe skaliert werden soll. Andere Formen als Bilder und OLE-Objekte werden immer relativ zu ihrer aktuellen Breite skaliert.

Syntax

Ausdruck.ScaleWidth(Factor, RelativeToOriginalSize, fScale)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.

Factor Single erforderlich. Legt das Verhältnis zwischen der Breite der Form nach der Größenänderung und der aktuellen bzw. ursprünglichen Breite fest. Um beispielsweise ein Rechteck um 50 Prozent zu vergrößern, muss für dieses Argument 1,5 angegeben werden.

RelativeToOriginalSize Long erforderlich. True, um die Form relativ zu ihrer Originalgröße zu skalieren. False, um sie relativ zu ihrer aktuellen Größe zu skalieren. Sie können für dieses Argument den Wert True nur dann festlegen, wenn es sich bei der angegebenen Form um ein Bild oder ein OLE-Objekt handelt.

fScale Long optional. Legt fest, welcher Teil der Form bei der Skalierung die Position beibehält. Kann eine der folgenden MsoScaleFrom-Konstanten sein: msoScaleFromBottomRight, msoScaleFromMiddle oder msoScaleFromTopLeft. Der Standardwert ist msoScaleFromTopLeft.


Beispiel zur ScaleWidth-Methode

In diesem Beispiel werden in myDocument alle Bilder und OLE-Objekte auf 175 Prozent ihrer ursprünglichen Höhe und Breite skaliert. Alle anderen Formen werden auf 175 Prozent ihrer aktuellen Höhe und Breite skaliert.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    Select Case s.Type
    Case msoEmbeddedOLEObject, _
            msoLinkedOLEObject, _
            msoOLEControlObject, _
            msoLinkedPicture, msoPicture
        s.ScaleHeight 1.75, True
        s.ScaleWidth 1.75, True
    Case Else
        s.ScaleHeight 1.75, False
        s.ScaleWidth 1.75, False
    End Select
Next


Scenarios-Methode

Gibt ein Objekt zurück, das ein einzelnes Szenario (ein Scenario-Objekt, Syntax 1) oder eine Auflistung der Szenarios (ein Scenarios-Objekt, Syntax 2) des Tabellenblattes darstellt.

Syntax 1

Ausdruck.Scenarios(Index)

Syntax 2

Ausdruck.Scenarios

Ausdruck Ein erforderlicher Ausdruck, der ein Worksheet-Objekt zurückgibt.

Index Erforderlich für Syntax 1. Der Name oder die Nummer des Szenarios. Mit einer Matrix kann mehr als ein Szenario angegeben werden.


Beispiel zur Scenarios-Methode

In diesem Beispiel wird der Kommentar für das erste Szenario in Sheet1 festgelegt.

Worksheets("Sheet1").Scenarios(1).Comment = _
    "Worst-case July 1993 sales"


ScrollIntoView-Methode

Führt einen Bildlauf im Dokumentfenster durch, so dass der Inhalt eines angegebenen rechteckigen Bereichs entweder in der oberen linken oder unteren rechten Ecke des Dokumentfensters bzw. -fensterausschnitts angezeigt wird (dies hängt vom Wert des Start-Arguments ab).

Syntax

Ausdruck.ScrollIntoView(Left, Top, Width, Height, Start)

Ausdruck Ein Ausdruck, der ein Pane- oder Window-Objekt zurückgibt.

Left Long erforderlich. Die horizontale Entfernung des Rechtecks (in Punkten) vom linken Rand des Dokumentfensters oder -fensterausschnitts.

Top Long erforderlich. Die vertikale Entfernung des Rechtecks (in Punkten) vom oberen Rand des Dokumentfensters oder -fensterausschnitts.

Width Long erforderlich. Die Breite des Rechtecks in Punkten.

Height Long erforderlich. Die Höhe des Rechtecks in Punkten.

Start Variant optional. True, damit die obere linke Ecke des Rechtecks in der oberen linken Ecke des Dokumentfensters oder -fensterausschnitts angezeigt wird. False, damit die untere rechte Ecke des Rechtecks in der unteren rechten Ecke des Dokumentfensters oder -fensterausschnitts angezeigt wird. Der Standardwert ist True.

Anmerkungen

Das Start-Argument ist nützlich, um die Bildschirmanzeige auszurichten, wenn das Rechteck größer als die Dokumentfenster oder der -fensterausschnitt ist.


Beispiel zur ScrollIntoView-Methode

In diesem Beispiel wird ein Rechteck der Größe 100 mal 200 Pixel im aktiven Dokumentfenster definiert, das sich 20 Pixel vom oberen Fensterrand und 50 Pixel vom linken Fensterrand entfernt befindet. In dem Beispiel wird dann ein Bildlauf nach oben und nach links im Dokument durchgeführt, so dass die obere linke Ecke des Rechtecks der oberen linken Ecke des Fensters entspricht.

ActiveWindow.ScrollIntoView _
    Left:=50, Top:=20, _
    Width:=100, Height:=200


ScrollWorkbookTabs-Methode

Blättert durch die Arbeitsmappenregister am unteren Rand des Fensters. Die Methode wirkt sich nicht auf das aktive Blatt in der Arbeitsmappe aus.

Syntax

Ausdruck.ScrollWorkbookTabs(Sheets, Position)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt zurückgibt.

Sheets Variant optional. Die Anzahl der Blätter, die weitergeblättert werden sollen. Bei positiven Werten wird vorwärts, bei negativen Werten rückwärts und bei dem Wert Null gar nicht geblättert. Sheets muss angegeben werden, wenn das Argument Position nicht angegeben wird.

Position Variant optional. Mit xlFirst blättern Sie zum ersten, mit xlLast zum letzten Blatt. Position muss angegeben werden, wenn das Argument Sheets nicht angegeben wird.


Beispiel zur ScrollWorkbookTabs-Methode

In diesem Beispiel wird zum letzten Tabellenblatt der Arbeitsmappe geblättert.

ActiveWindow.ScrollWorkbookTabs position:=xlLast


Select-Methode

Markiert das Objekt.

Syntax

Ausdruck.Select(Replace)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Replace Variant optional (wird nur bei Blättern verwendet). True, falls die aktuelle Markierung durch das angegebene Objekt ersetzt wird. False, falls die aktuelle Markierung auf vorher markierte Objekte und das angegebene Objekt erweitert werden soll.

Anmerkungen

Verwenden Sie die Select-Methode, um eine Zelle oder einen Zellbereich zu markieren. Verwenden Sie die Activate-Methode, um eine einzelne Zelle zur aktiven Zelle zu machen.


SelectAll-Methode

Markiert alle Formen der angegebenen Shapes-Auflistung.

Syntax

Ausdruck.SelectAll

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.


Beispiel zur SelectAll-Methode

In diesem Beispiel werden alle Formen in myDocument markiert und ein ShapeRange-Objekt erstellt, das alle Formen enthält.

Set myDocument = Worksheets(1)
myDocument.Shapes.SelectAll
Set sr = Selection.ShapeRange


SendKeys-Methode

Sendet Tastenkombination an die aktive Anwendung.

Syntax

Ausdruck.SendKeys(Keys, Wait)

Ausdruck Ein optionaler Ausdruck, der ein Application-Objekt zurückgibt.

Keys Variant erforderlich. Die Taste oder Tastenkombination, die Sie als Zeichenfolge an die Anwendung senden möchten.

Wait Variant optional. Falls True, wartet Microsoft Excel das Ende der Verarbeitung ab, bevor die Steuerung an das Makro zurückgegeben wird. False oder keine Angabe führt das Makro weiter aus, ohne auf einen Tastenkombination zu warten.

Anmerkungen

Diese Methode schreibt die Tastenkombination in einen Tastenpuffer. In einigen Fällen müssen Sie diese Methode vor der Methode aufrufen, die die Tastenkombination verarbeitet. Wenn Sie z. B. ein Kennwort an ein Dialogfeld senden möchten, müssen Sie zuerst die SendKeys-Methode aufrufen, bevor Sie das Dialogfeld anzeigen.

Das Argument Keys kann eine einzelne Taste oder eine Taste kombiniert mit einer oder mehreren der Tasten ALT, STRG oder UMSCHALT sein. Jede Taste wird durch ein oder mehrere Zeichen dargestellt, wie z. B. "a" für das Zeichen a oder "{EINGABE}" für die EINGABETASTE.

Wenn Sie Zeichen angeben möchten, die beim Drücken der entsprechenden Taste nicht angezeigt werden (z. B. EINGABE oder TAB), verwenden Sie die Codes aus der folgenden Tabelle. Jeder Code in der Tabelle steht für eine Taste auf der Tastatur.

Taste | Code
RÜCKTASTE | {RÜCKTASTE} oder {RÜCK}
UNTBR oder BREAK | {UNTBR}
FESTSTELLTASTE | {FESTSTELLTASTE}
CLEAR oder LÖSCHTASTE | {SÄUBERN}
ENTF oder LÖSCH | {ENTF} oder {LÖSCH}
NACH-UNTEN | {UNTEN}
ENDE | {ENDE}
EINGABETASTE (Zehnertastatur) | {EINGABE}
EINGABETASTE | ~ (Tilde)
ESC | {ESCAPE} oder {ESC}
HILFE | {HILFE}
POS1 | {POS1}
EINFG | {EINFG}
NACH-LINKS | {LINKS}
NUM | {NUMFT}
BILD-AB | {BILDU}
BILD-AUF | {BILDO}
RETURNTASTE | {EINGABE}
NACH-RECHTS | {RECHTS}
ROLLEN oder SCROLL | {UNTERBR}
TAB | {TAB}
NACH-OBEN | {OBEN}
F1 bis F15 | {F1} bis {F15}

Sie können jede beliebige Tastenkombination mit UMSCHALT, STRG und ALT angeben. Kombinieren Sie eine Taste mit einer oder mehreren anderen Tasten entsprechend der folgenden Tabelle.

Kombinieren mit | Vorangestelltes Zeichen
UMSCHALT | + (Pluszeichen)
STRG | ^ (Caret-Zeichen)
ALT | % (Prozentzeichen)


Beispiel zur SendKeys-Methode

In diesem Beispiel wird Microsoft Excel mit der SendKeys-Methode beendet.

Application.SendKeys("%fx")


SendMail-Methode

Sendet die Arbeitsmappe über das installierte Mail-System.

Syntax

Ausdruck.SendMail(Recipients, Subject, ReturnReceipt)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Recipients Variant erforderlich. Gibt den Namen des Empfängers als Text bzw. bei mehreren Empfängern als eine Matrix aus Textzeichenfolgen zurück. Es ist mindestens ein Empfänger anzugeben. Alle Empfänger werden in die An-Liste eingefügt.

Subject Variant optional. Gibt den Betreff der Nachricht zurück. Fehlt diese Angabe, wird der Name des Dokuments eingesetzt.

ReturnReceipt Variant optional. Wenn True, wird eine Empfangsbestätigung angefordert. Wenn False oder nicht angegeben, wird keine Empfangsbestätigung gesendet. Die Voreinstellung ist False.


Beispiel zur SendMail-Methode

In diesem Beispiel wird die aktive Mappe an einen einzelnen Empfänger gesendet.

ActiveWorkbook.SendMail recipients:="Jean Selva"


SendToBack-Methode

Stellt das Objekt in den Hintergrund der Z-Reihenfolge.

Syntax

Ausdruck.SendToBack

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.


Beispiel zur SendToBack-Methode

In diesem Beispiel wird das erste eingebettete Diagramm in Sheet1 in den Hintergrund der Z-Reihenfolge versetzt.

Worksheets("Sheet1").ChartObjects(1).SendToBack


SeriesCollection-Methode

Gibt ein Objekt zurück, das eine einzelne Datenreihe (ein Series-Objekt, Syntax 1) oder eine Auflistung aller Datenreihen (ein SeriesCollection-Objekt, Syntax 2) des Diagramms oder der Diagrammgruppe darstellt.

Syntax 1

Ausdruck.SeriesCollection(Index)

Syntax 2

Ausdruck.SeriesCollection

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt des Typs Chart oder ChartGroup zurückgibt.

Index Variant optional. Der Name oder die Nummer der Datenreihe.


Beispiel zur SeriesCollection-Methode

In diesem Beispiel werden die Datenbeschriftungen für die erste Datenreihe in Chart1 aktiviert.

Charts("Chart1").SeriesCollection(1).HasDataLabels = True


SetBackgroundPicture-Methode

Legt die Hintergrundgrafik für ein Tabellenblatt oder ein Diagramm fest.

Syntax

Ausdruck.SetBackgroundPicture(FileName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet- oder ein Chart-Objekt zurückgibt.

FileName String erforderlich. Der Name der Grafikdatei.


Beispiel zur SetBackgroundPicture-Methode

In diesem Beispiel wird die Hintergrundgrafik für das erste Tabellenblatt festgelegt.

Worksheets(1).SetBackgroundPicture "c:\graphics\watrmark.bmp"


SetDefaultChart-Methode

Gibt den Namen der Diagrammvorlage an, die in Microsoft Excel beim Erstellen neuer Diagramme verwendet wird.

Syntax

Ausdruck.SetDefaultChart(FormatName)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

FormatName Variant optional. Gibt den Namen eines benutzerdefinierten AutoFormats an. Dieser Name kann ein benutzerdefiniertes AutoFormat (als eine Zeichenfolge) oder aber die spezielle Konstante xlBuiltIn sein, mit der die integrierte Diagrammvorlage angegeben wird.


Beispiel zur SetDefaultChart-Methode

In diesem Beispiel wird als Standarddiagrammvorlage das benutzerdefinierte AutoFormat "Monthly Sales" festgelegt.

Application.SetDefaultChart FormatName:="Monthly Sales"


SetEditingType-Methode

Legt die Bearbeitungsart des durch Index angegebenen Knotens fest. Handelt es sich bei dem Knoten um einen Steuerpunkt eines gekrümmten Abschnitts, legt diese Methode die Bearbeitungsart des angrenzenden Knotens fest, der die beiden Abschnitte verbindet. Beachten Sie, dass diese Methode, je nach Bearbeitungsart, die Position der angrenzenden Knoten beeinflussen kann.

Syntax

Ausdruck.SetEditingType(Index, EditingType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Bearbeitungsart festgelegt werden soll.

EditingType Long erforderlich. Die Bearbeitungseigenschaft des Scheitelpunktes. Kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric.


Beispiel zur SetEditingType-Methode

In diesem Beispiel werden alle Eckknoten der dritten Form in myDocument zu Übergangsknoten gemacht. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


SetExtrusionDirection-Methode

Legt die Richtung fest, in der die Projektionsausdehnung von der projizierten Form wegführt.

Syntax

Ausdruck.SetExtrusionDirection(PresetExtrusionDirection)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetExtrusionDirection Long erforderlich. Legt die Projektionsrichtung fest. Kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft oder msoExtrusionTopRight.

Anmerkungen

Diese Methode legt für die PresetExtrusionDirection-Eigenschaft die Richtung fest, die durch das Argument PresetExtrusionDirection angegeben wird.


Beispiel zur SetExtrusionDirection-Methode

In diesem Beispiel wird festgelegt, dass in myDocument die Projektion der ersten Form in Richtung des oberen Randes der Form verläuft und die Beleuchtung der Projektion von links kommt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


SetLinkOnData-Methode

Legt den Namen einer Prozedur fest, die bei jeder Aktualisierung einer DDE-Verknüpfung ausgeführt wird.

Syntax

Ausdruck.SetLinkOnData(Name, Procedure)

Ausdruck Erforderlich. Ein Ausdruck der ein Workbook-Objekt zurückgibt.

Name String erforderlich. Der Name der DDE/OLE-Verknüpfung, wie er von der LinkSources-Methode zurückgegeben wird.

Procedure String erforderlich. Der Name der Prozedur, die bei jeder Aktualisierung einer Verknüpfung ausgeführt werden soll. Dabei kann es sich um ein Microsoft Excel 4.0-Makro oder um eine Visual Basic-Prozedur handeln. Mit einer leeren Zeichenfolge ("") für dieses Argument legen Sie fest, dass bei einer Aktualisierung der Verknüpfung keine Prozedur ausgeführt werden soll.


Beispiel zur SetLinkOnData-Methode

In diesem Beispiel wird der Name der Prozedur festgelegt, die beim Aktualisieren der DDE-Verknüpfung ausgeführt wird.

ActiveWorkbook.SetLinkOnData _
    "WinWord|'C:\MSGFILE.DOC'!DDE_LINK1", _
    "my_Link_Update_Macro"


SetParam-Methode

Definiert einen Parameter für die angegebene Abfragetabelle.

Syntax

Ausdruck.SetParam(Type, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein Parameter-Objekt zurückgibt.

Type Long erforderlich. Der Typ des Parameters. Dies kann eine der folgenden XlParameterType-Konstanten sein.

Konstante | Beschreibung
xlConstant | Es wird der durch das Argument Value festgelegte Wert verwendet.
xlPrompt | Es wird ein Dialogfeld angezeigt, das den Benutzer zur Eingabe des Wertes auffordert. Das Argument Value legt den im Dialogfeld angezeigten Text fest.
xlRange | Es wird der Wert der Zelle in der oberen linken Ecke des Bereichs verwendet. Das Argument Value legt ein Range-Objekt fest.

Value Variant erforderlich. Der Wert des angegebenen Parameters, wie in der Beschreibung des Arguments Type dargestellt.


Beispiel zur SetParam-Methode

In diesem Beispiel wird die SQL-Anweisung der ersten Abfragetabelle geändert. Der Teil "(city=?)" gibt an, dass es sich bei der Abfrage um eine Parameterabfrage handelt. Außerdem wird in dem Beispiel als Wert für "City" die Konstante "Oakland" festgelegt.

Set qt = Sheets("sheet1").QueryTables(1)
qt.Sql = "SELECT * FROM authors  WHERE (city=?)"
Set param1 = qt.Parameters.Add("City Parameter", _
    xlParamTypeVarChar)
param1.SetParam xlConstant, "Oakland"
qt.Refresh

In diesem Beispiel wird als Wert für "Stadt" der Wert der Zelle A2 des zweiten Tabellenblattes festgelegt.

Set qt = Sheets("sheet1").QueryTables(1)
qt.Sql = "SELECT * FROM authors  WHERE (city=?)"
Set param1 = qt.Parameters.Add("City Parameter", _
    xlParamTypeVarChar)
param1.SetParam xlRange, Range("sheet2!a1")
qt.Refresh


SetPhonetic-Methode

Erstellt Phonetic-Objekte für alle Zellen in dem angegebenen Bereich.

Syntax

Ausdruck.SetPhonetic

Ausdruck Ein Ausdruck, der ein Range-Objekt zurückgibt.

Anmerkungen

Alle vorhandenen Phonetic-Objekte in dem angegebenen Bereich werden automatisch von den neuen Objekten, die mit Hilfe dieser Methode hinzugefügt werden, überschrieben (gelöscht).


Beispiel zur SetPhonetic-Methode

In diesem Beispiel wird ein Phonetic-Objekt für allen Zellen im Bereich "A1:A10" des aktiven Tabellenblatts erstellt.

ActiveSheet.Range("A1:A10").SetPhonetic


SetPosition-Methode

Legt die Position des durch Index angegebenen Knotens fest. Beachten Sie, dass diese Methode, je nach Bearbeitungsart, die Position der angrenzenden Knoten beeinflussen kann.

Syntax

Ausdruck.SetPosition(Index, X1, Y1)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Position festgelegt werden soll.

X1, Y1 Single erforderlich. Die Position des neuen Knotens (in Punkt), relativ zur oberen linken Ecke des Dokuments.


Beispiel zur SetPosition-Methode

In diesem Beispiel wird in myDocument der zweite Knoten der dritten Form um 200 Punkt nach rechts und um 300 Punkt nach unten verschoben. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(0, 0)
    currYvalue = pointsArray(0, 1)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


SetSegmentType-Methode

Legt die Abschnittsart des Abschnitts fest, der dem durch Index angegebenen Knoten folgt. Handelt es sich bei dem Knoten um einen Steuerpunkt eines gekrümmten Abschnitts, legt diese Methode die Abschnittsart dieser Kurve fest. Beachten Sie, dass dies durch Einfügen und Löschen angrenzender Knoten die Gesamtzahl der Knoten beeinflussen kann.

Syntax

Ausdruck.SetSegmentType(Index, SegmentType)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Long erforderlich. Der Knoten, dessen Abschnittsart festgelegt werden soll.

SegmentType Long erforderlich. Legt fest, ob der Abschnitt gerade oder gekrümmt ist. Kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine.


Beispiel zur SetSegmentType-Methode

In diesem Beispiel werden in myDocument alle geraden Abschnitte der dritten Form in ungerade Abschnitte geändert. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


 SetShapesDefaultProperties-Methode

SetShapesDefaultProperties-Methode

Weist die Formatierung der angegebenen Form der Standardform zu. Formen, die nach dem Einsatz dieser Methode erstellt werden, besitzen standardmäßig diese Formatierung.

Syntax

Ausdruck.SetShapesDefaultProperties

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ShapeRange-Objekt zurückgibt.


Beispiel zur SetShapesDefaultProperties-Methode

In diesem Beispiel wird in myDocument ein Rechteck eingefügt, dessen Füllung formatiert und diese Formatierung der Standardform zugewiesen. Anschließend wird dem Dokument ein kleineres Rechteck hinzugefügt. Es besitzt die gleiche Füllung wie das erste.

Set myDocument = Worksheets(1)
With mydocument.Shapes
    With .AddShape(msoShapeRectangle, 5, 5, 80, 60)
        With .Fill
            .ForeColor.RGB = RGB(0, 0, 255)
            .BackColor.RGB = RGB(0, 204, 255)
            .Patterned msoPatternHorizontalBrick
        End With
        .SetShapesDefaultProperties
        ' Zuweisung des Formats für die Standardform
    End With
    .AddShape msoShapeRectangle, 90, 90, 40, 30
    ' Neue Form hat Standardformat
End With


SetSourceData-Methode

Legt den Quelldatenbereich des Diagramms fest.

Syntax

Ausdruck.SetSourceData(Source, PlotBy)

Ausdruck Erforderlich. Ein Ausdruck der ein Chart-Objekt zurückgibt.

Source Range erforderlich. Der Bereich, der die Quelldaten enthält.

PlotBy Variant optional. Legt fest, wie die Daten gezeichnet werden. Dies kann eine der beiden folgenden XlRowCol-Konstanten sein: xlColumns oder xlRows.


Beispiel zur SetSourceData-Methode

In diesem Beispiel wird der Quelldatenbereich des ersten Diagramms festgelegt.

Charts(1).SetSourceData Source:=Sheets(1).Range("a1:a10"), _
    PlotBy:=xlColumns


SetThreeDFormat-Methode

Legt das vorgegebene Projektionsformat fest. Jedes vorgegebene Projektionsformat enthält für die verschiedenen Eigenschaften der Projektion einen Satz vordefinierter Werte.

Syntax

Ausdruck.SetThreeDFormat(PresetThreeDFormat)

Ausdruck Erforderlich. Ein Ausdruck, der ein ThreeDFormat-Objekt zurückgibt.

PresetThreeDFormat Long erforderlich. Legt ein vordefiniertes Projektionsformat fest, das einer der Optionen entspricht (von links oben nach rechts unten nummeriert), die angezeigt werden, wenn Sie auf die Schaltfläche 3D der Symbolleiste Zeichnen klicken. Kann eine der folgenden MsoPresetThreeDFormat-Konstanten sein: msoThreeD1, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19, msoThreeD2, msoThreeD20, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8 oder msoThreeD9. Beachten Sie, dass es zu einem Fehler führt, wenn Sie für dieses Argument den Wert msoPresetThreeDFormatMixed angeben.

Anmerkungen

Diese Methode legt für die PresetThreeDFormat-Eigenschaft das Format fest, das durch das Argument PresetThreeDFormat angegeben wird.


Beispiel zur SetThreeDFormat-Methode

In diesem Beispiel wird in myDocument eine Ellipse eingefügt und als ihr Projektionsformat 3D-Art 12 festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeOval, _
        30, 30, 50, 25).ThreeD
    .Visible = True
    .SetThreeDFormat msoThreeD12
End With


Show-Methode

CustomView-Objekt (Syntax 1): Zeigt die benutzerdefinierte Ansicht an.

Range-Objekt (Syntax 1): Führt im aktiven Fenster einen Bildlauf durch, bis der Bereich erscheint. Der Bereich muss aus einer einzelnen Zelle des aktiven Dokuments bestehen.

Scenario-Objekt (Syntax 1): Zeigt das Szenario durch Einfügen der Szenariowerte in das Tabellenblatt an. Davon sind die Zellen betroffen, die sich im Szenario ändern.

Dialog-Objekt (Syntax 2): Zeigt das integrierte Dialogfeld an und erwartet Dateneingaben vom Benutzer.

Syntax 1

Ausdruck.Show

Syntax 2

Objekt.Show(arg1, arg2, ..., arg30)

Ausdruck Erforderlich. Bei Syntax 1, ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

arg1, arg2, ..., arg30 Variant optional. Stellt ausschließlich für integrierte Dialogfelder die Anfangsargumente für den Befehl bereit. Weitere Informationen finden Sie unter "Anmerkungen".

Anmerkungen

Diese Methode gibt für integrierte Dialogfelder den Wert True zurück, wenn auf OK geklickt wird, oder den Wert False, wenn auf "Abbrechen" geklickt wird.

Mit einem Dialogfeld können mehrere Eigenschaften gleichzeitig geändert werden. Mit dem Dialogfeld Zellen formatieren können beispielsweise alle Eigenschaften des Font-Objekts verändert werden.

Bei einigen integrierten Dialogfeldern (z. B. Öffnen) können Sie die Anfangswerte mit arg1, arg2,..., arg30 festlegen. Suchen Sie unter Liste der integrierten Dialogfeldargumente nach der entsprechenden Dialogfeldkonstante. Suchen Sie z. B. nach der xlDialogOpen-Konstante, um die Argumente für das Dialogfeld Öffnen zu erhalten. Weitere Informationen über integrierte Dialogfelder finden Sie unter der Dialogs-Auflistung.


ShowAllData-Methode

Blendet alle Zeilen für die momentan gefilterte Liste ein. Wird der AutoFilter verwendet, so ändert diese Methode die Pfeile in die Anzeige "Alle".

Syntax

Ausdruck.ShowAllData

Ausdruck Ein erforderlicher Ausdruck, der ein Worksheet-Objekt zurückgibt.


Beispiel zur ShowAllData-Methode

In diesem Beispiel werden alle Daten in Sheet1 eingeblendet. Wenden Sie das Makro auf ein Tabellenblatt an, das eine mit dem Befehl AutoFilter gefilterte Liste enthält.

Worksheets("Sheet1").ShowAllData


ShowDataForm-Methode

Zeigt die mit dem Tabellenblatt verknüpfte Datenmaske an.

Syntax

Ausdruck.ShowDataForm

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Anmerkungen

Das Makro pausiert, solange Sie die Datenmaske verwenden. Sobald Sie die Datenmaske schließen, wird das Makro in der Zeile, die auf die ShowDataForm-Methode folgt, weiter ausgeführt.

Diese Methode führt die benutzerdefinierte Datenmaske aus, falls eine vorhanden ist.


Beispiel zur ShowDataForm-Methode

In diesem Beispiel wird die Datenmaske für Sheet1 angezeigt.

Worksheets(1).ShowDataForm


ShowDependents-Methode

Zeichnet Spuren zu den direkten Nachfolgern des Bereichs.

Syntax

Ausdruck.ShowDependents(Remove)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Es muss sich hierbei um eine einzelne Zelle handeln.

Remove Variant optional. True, wenn eine Ebene von Spuren zu den direkten Nachfolgern entfernt wird. False, wenn eine Ebene von Spuren hinzugefügt wird. Der Standardwert ist False.


Beispiel zur ShowDependents-Methode

In diesem Beispiel werden Spuren zu den Nachfolgern der aktiven Zelle in Sheet1 gezeichnet.

Worksheets("Sheet1").Activate
ActiveCell.ShowDependents

In diesem Beispiel wird die Spur für eine Ebene von Nachfolgern der aktiven Zelle in Sheet1 entfernt.

Worksheets("Sheet1").Activate
ActiveCell.ShowDependents Remove:=True


ShowErrors-Methode

Zeichnet Spuren durch die Reihenfolge der Vorgängerzellen bis zu der Zelle, die die Fehlerquelle darstellt und gibt den Bereich zurück, der die Fehlerquelle enthält.

Syntax

Ausdruck.ShowErrors

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur ShowErrors-Methode

In diesem Beispiel wird ein roter Spurpfeil angezeigt, falls in der aktiven Zelle in Sheet1 ein Fehler aufgetreten ist.

Worksheets("Sheet1").Activate
If IsError(ActiveCell.Value) Then
    ActiveCell.ShowErrors
End If


ShowLevels-Methode

Zeigt die angegebene Anzahl der Zeilen- und/oder Spaltenebenen einer Gliederung an.

Syntax

Ausdruck.ShowLevels(RowLevels, ColumnLevels)

Ausdruck Erforderlich. Ein Ausdruck, der ein Outline-Objekt zurückgibt.

RowLevels Variant optional. Legt fest, wie viele Zeilenebenen einer Gliederung angezeigt werden sollen. Enthält die Gliederung weniger Ebenen als festgelegt, werden alle Ebenen angezeigt. Ist dieses Argument Null oder nicht angegeben, wird dieser Vorgang nicht für Zeilen durchgeführt.

ColumnLevels Variant optional. Legt fest, wie viele Spaltenebenen einer Gliederung angezeigt werden sollen. Enthält die Gliederung weniger Ebenen als festgelegt, werden alle Ebenen angezeigt. Ist dieses Argument Null oder nicht angegeben, wird dieser Vorgang nicht für Spalten durchgeführt.

Anmerkungen

Sie müssen mindestens ein Argument angeben.


Beispiel zur ShowLevels-Methode

In diesem Beispiel werden die Zeilenebenen 1 bis 3 und die Spaltenebene 1 der Gliederung in Sheet1 angezeigt.

Worksheets("Sheet1").Outline _
    .ShowLevels rowLevels:=3, columnLevels:=1


 ShowPages-Methode

ShowPages-Methode

Erstellt einen neuen PivotTable-Bericht für jedes Element im Seitenfeld. Jeder neuer Bericht wird in einem neuen Tabellenblatt erstellt.

Syntax

Ausdruck.ShowPages(PageField)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

PageField Variant optional. Eine Zeichenfolge, die ein einzelnes Seitenfeld des Berichts angibt.

Anmerkungen

Diese Methode steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur ShowPages-Methode

In diesem Beispiel wird für jedes Element im Seitenfeld "Country" ein neuer PivotTable-Bericht erstellt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.ShowPages "Country"


ShowPrecedents-Methode

Zeichnet Spuren zu den direkten Vorgängerzellen des Bereichs.

Syntax

Ausdruck.ShowPrecedents(Remove)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt. Es muss sich hierbei um eine einzelne Zelle handeln.

Remove Variant optional. True, wenn eine Ebene von Spuren zu den direkten Vorgängerzellen entfernt wird. False, wenn eine weitere Ebene von Spuren angezeigt wird. Der Standardwert ist False.


Beispiel zur ShowPrecedents-Methode

In diesem Beispiel werden Spuren zu den Vorgängern der aktiven Zelle in Sheet1 gezeichnet.

Worksheets("Sheet1").Activate
ActiveCell.ShowPrecedents

In diesem Beispiel wird der Spurpfeil für eine Ebene von Vorgängern der aktiven Zelle in Sheet1 entfernt.

Worksheets("Sheet1").Activate
ActiveCell.ShowPrecedents remove:=True


SmallScroll-Methode

Führt einen zeilen- oder spaltenweisen Bildlauf bei Fensterinhalten durch.

Syntax

Ausdruck.SmallScroll(Down, Up, ToRight, ToLeft)

Ausdruck Erforderlich. Ein Ausdruck, der ein Window-Objekt ausgibt.

Down Variant optional. Die Anzahl der Zeilen, um die der Bildlauf nach unten durchgeführt werden soll.

Up Variant optional. Die Anzahl der Zeilen, um die der Bildlauf nach oben durchgeführt werden soll.

ToRight Variant optional. Die Anzahl der Zeilen, um die der Bildlauf nach rechts durchgeführt werden soll.

ToLeft Variant optional. Die Anzahl der Zeilen, um die der Bildlauf nach links durchgeführt werden soll.

Anmerkungen

Wird sowohl Down als auch Up festgelegt, wird der Bildlauf entsprechend der Differenz der beiden Argumente durchgeführt. Wenn z.B. Down den Wert 3 und Up den Wert 6 hat, wird der Bildlauf um drei Zeilen nach oben durchgeführt.

Wird sowohl ToLeft als auch ToRight festgelegt, wird der Bildlauf entsprechend der Differenz der beiden Argumente durchgeführt. Wenn z.B. ToLeft den Wert 3 und ToRight den Wert 6 hat, wird der Bildlauf um drei Spalten nach rechts durchgeführt.

Für jedes dieser Argumente kann auch eine negative Zahl festgelegt werden.


Beispiel zur SmallScroll-Methode

In diesem Beispiel werden die Inhalte des aktiven Fensters in Sheet1 um drei Zeilen nach unten durchgeführt.

Worksheets("Sheet1").Activate
ActiveWindow.SmallScroll down:=3


Solid-Methode

Legt für die angegebene Füllung eine einheitliche Farbe fest. Verwenden Sie diese Methode, um eine fließende, strukturierte oder gemusterte Füllung oder eine Hintergrundfüllung wieder in eine einfarbige Füllung umzuwandeln.

Syntax

Ausdruck.Solid

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.


Beispiel zur Solid-Methode

In diesem Beispiel werden in myDocument alle Füllungen in einfarbiges Rot umgewandelt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    With s.Fill
        .Solid
        .ForeColor.RGB = RGB(255, 0, 0)
    End With
Next


Sort-Methode

Sortiert einen PivotTable-Bericht, einen Bereich bzw. den aktiven Bereich (wenn nur eine Zelle angegeben wird).

Syntax

Ausdruck.Sort(Key1, Order1, Key2, Type, Order2, Key3, Order3, Header, OrderCustom, MatchCase, Orientation, SortMethod)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Key1 Variant optional. Das erste Sortierfeld, als Text (ein PivotTable-Feld oder Bereichsname) oder als Range-Objekt (z. B. "Abtlg" oder Cells(1, 1)).

Order1 Variant optional. Zulässig ist eine der folgenden XlSortOrder-Konstanten: xlAscending oder xlDescending. Mit xlAscending wird Key1 in aufsteigender Reihenfolge sortiert. Mit xlDescending wird Key1 in absteigender Reihenfolge sortiert. Die Standardkonstante ist xlAscending.

Key2 Variant optional. Das zweite Sortierfeld, als Text (ein PivotTable-Feld oder Bereichsname) oder als Range-Objekt. Falls dieses Argument ausgelassen wird, gibt es kein zweites Sortierfeld. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Type Variant optional. Gibt an, welche Elemente sortiert werden sollen. Zulässig ist eine der folgenden XlSortType-Konstanten: xlSortLabels oder xlSortValues. Verwenden Sie dieses Argument nur beim Sortieren von PivotTable-Berichten.

Order2 Variant optional. Zulässig ist eine der folgenden XlSortOrder-Konstanten: xlAscending oder xlDescending. Verwenden Sie xlAscending, um Key2 in aufsteigender Reihenfolge zu sortieren. Verwenden Sie xlDescending, um Key2 in absteigender Reihenfolge zu sortieren. Die Standardkonstante ist xlAscending. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Key3 Variant optional. Das dritte Sortierfeld, als Text (ein Bereichsname) oder als Range-Objekt. Falls dieses Argument ausgelassen wird, gibt es kein drittes Sortierfeld. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Order3 Variant optional. Zulässig ist eine der folgenden XlSortOrder-Konstanten: xlAscending oder xlDescending. Verwenden Sie xlAscending, um Key3 in aufsteigender Reihenfolge zu sortieren. Verwenden Sie xlDescending, um Key3 in absteigender Reihenfolge zu sortieren. Die Standardkonstante ist xlAscending. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Header Variant optional. Legt fest, ob die erste Zeile Überschriften enthält oder nicht. Zulässig ist eine der folgenden xlGuess-Konstanten: xlGuess, xlNo oder xlYes. Mit xlYes enthält die erste Zeile Überschriften (die nicht sortiert werden). Mit xlNo gibt es keine Überschriften (der gesamte Bereich wird sortiert). Mit xlGuess übernimmt Microsoft Excel die Entscheidung, ob eine Überschrift vorhanden ist und falls vorhanden, wo sie sich befindet. Die Standardkonstante ist xlNo. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

OrderCustom Variant optional. Bei diesem Argument handelt es sich um einen ganzzahligen, bei 1 beginnenden Offset für die Liste der benutzerdefinierten Sortierreihenfolgen. Wird OrderCustom ausgelassen, wird 1 (Standard) verwendet.

MatchCase Variant optional. True, wenn beim Sortieren Groß- und Kleinschreibung berücksichtigt wird. False, wenn Groß- und Kleinschreibung nicht berücksichtigt wird. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Orientation Variant optional. Hat das Argument den Wert xlSortRows, so wird von oben nach unten sortiert (zeilenweise). Ist das Argument xlSortColumns, so erfolgt die Sortierung von links nach rechts (spaltenweise).

SortMethod Variant optional. Der Sortiertyp. Kann eine der folgenden XlSortMethod-Konstanten sein: xlPinYin oder xlStroke. Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.

Anmerkungen

Die Einstellungen für Header, Order1, Order2, Order3, OrderCustom und Orientation werden bei jeder Verwendung dieser Methode gespeichert. Wenn Sie für diese Argumente keine Werte angeben, werden beim nächsten Aufruf der Methode die gespeicherten Werte verwendet. Um Probleme zu vermeiden, legen Sie diese Argumente bei jeder Verwendung dieser Methode explizit fest.


SortSpecial-Methode

Syntax 1: Verwendet die ostasiatischen Sortiermethoden, um den Bereich zu sortieren, oder die Methode für die aktuelle Region, wenn der Bereich nur eine Zelle enthält. Bei Japanisch erfolgt die Sortierung beispielsweise in der Reihenfolge des Kana-Syllabus.

Syntax 2: Verwendet die ostasiatischen Sortiermethoden, um einen PivotTable-Bericht zu sortieren. Bei Japanisch erfolgt die Sortierung beispielsweise in der Reihenfolge des Kana-Syllabus. Weitere Informationen finden Sie in der Argumentliste.

Syntax 1

Ausdruck.SortSpecial(SortMethod, Key1, Order1, Key2, Type, Order2, Key3, Order3, Header, OrderCustom, MatchCase, Orientation)

Syntax 2

Ausdruck.SortSpecial(SortMethod, Key1, Order1, Type, OrderCustom, Orientation)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt ausgibt.

SortMethod Variant optional. Gibt an, wie der Bereich sortiert werden solle. Kann eine der folgenden XlSortMethod-Konstanten sein: xlPinYin oder xlStroke. Diese Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.

Key1 Variant optional. Das erste Sortierfeld, entweder Text (ein PivotTable-Feld oder Bereichsname) oder ein Range-Objekt (z. B. "Abteilung" oder Cells(1, 1)).

Order1 Variant optional. Es stehen folgende XlSortOrder-Konstanten zur Verfügung: xlAscending oder xlDescending. Mit xlAscending wird Key1 in aufsteigender, mit xlDescending in absteigender Reihenfolge sortiert. Die Standardkonstante ist xlAscending.

Key2 Variant optional. Das zweite Sortierfeld, als Text (ein PivotTable-Feld oder Bereichsname) oder als Range-Objekt. Falls dieses Argument ausgelassen wird, gibt es kein zweites Sortierfeld. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Type Variant optional. Gibt an, welche Elemente sortiert werden sollen. Zulässig ist eine der folgenden XlSortType-Konstanten: xlSortLabels oder xlSortValues. Verwenden Sie dieses Argument nur beim Sortieren von PivotTable-Berichten.

Order2 Variant optional. Zulässig ist eine der folgenden XlSortOrder-Konstanten: xlAscending oder xlDescending. Verwenden Sie xlAscending, um Key2 in aufsteigender Reihenfolge zu sortieren. Verwenden Sie xlDescending, um Key2 in absteigender Reihenfolge zu sortieren. Die Standardkonstante ist xlAscending. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Key3 Variant optional. Das dritte Sortierfeld, als Text (ein Bereichsname) oder als Range-Objekt. Falls dieses Argument ausgelassen wird, gibt es kein drittes Sortierfeld. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Order3 Variant optional. Zulässig ist eine der folgenden XlSortOrder-Konstanten: xlAscending oder xlDescending. Verwenden Sie xlAscending, um Key3 in aufsteigender Reihenfolge zu sortieren. Verwenden Sie xlDescending, um Key3 in absteigender Reihenfolge zu sortieren. Die Standardkonstante ist xlAscending. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Header Variant optional. Legt fest, ob die erste Zeile Spaltenüberschriften enthält. Es stehen folgende XlYesNoGuess-Konstanten zur Verfügung: xlYes, xlNo oder xlGuess. Mit xlYes enthält die erste Zeile Spaltenüberschriften (die nicht sortiert werden). Mit xlNo werden keine Spaltenüberschriften festgelegt (und der gesamte Bereich sortiert). Wenn Sie xlGuess verwenden, übernimmt Microsoft Excel die Entscheidung und legt gegebenenfalls eine Überschriftenzeile und deren Position fest. Die Standardkonstante ist xlNo. Wird beim Sortieren von PivotTable-Berichten nicht verwendet.

OrderCustom Variant optional. Bei diesem Argument handelt es sich um einen ganzzahligen, bei 1 beginnenden Offset für die Liste der benutzerdefinierten Sortierreihenfolgen. Wird OrderCustom ausgelassen, wird 1 (Standard) verwendet.

MatchCase Variant optional. True, wenn beim Sortieren Groß- und Kleinschreibung berücksichtigt wird. False, wenn Groß- und Kleinschreibung nicht berücksichtigt wird. Verwenden Sie dieses Argument beim Sortieren von PivotTable-Berichten nicht.

Orientation Variant optional. Wird dieses Argument auf xlTopToBottom festgelegt oder ausgelassen, wird zeilenweise von oben nach unten sortiert. Wird es auf xlLeftToRight festgelegt, wird spaltenweise von links nach rechts sortiert.


Beispiel zur SortSpecial-Methode

In diesem Beispiel wird der Bereich "A1:G37" in Sheet1 sortiert. "A1" ist der erste Sortierschlüssel, "C1" ist der zweite Sortierschlüssel. Es wird zeilenweise in aufsteigender Reihenfolge nach Pinselstrich sortiert, und es gibt keine Kopfzeile mit Spaltenüberschriften.

Worksheets("Sheet1").Range("A1:G37").SortSpecial _
    SortMethod:=xlStroke, _
    Key1:=Range("A1"), Order1:=xlAscending, _
    Key2:=Range("C1"), Order2:=xlAscending


SpecialCells-Methode

Gibt ein Range-Objekt zurück, das alle Zellen darstellt, die mit dem angegebenen Wert übereinstimmen.

Syntax

Ausdruck.SpecialCells(Type, Value)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Type Long erforderlich. Die einzuschließenden Zellen. Kann eine der folgenden XlCellType-Konstanten sein.

Konstante | Beschreibung
xlCellTypeAllFormatConditions | Zellen mit beliebigem Format
xlCellTypeAllValidation | Zellen mit Gültigkeitskriterien
xlCellTypeBlanks | Leere Zellen
xlCellTypeComments | Zellen mit Anmerkungen
xlCellTypeConstants | Zellen mit Konstanten
xlCellTypeFormulas | Zellen mit Formeln
xlCellTypeLastCell | Die letzte Zelle im benutzten Bereich
xlCellTypeSameFormatConditions | Zellen mit gleichem Format
xlCellTypeSameValidation | Zellen mit gleichen Gültigkeitskriterien
xlCellTypeVisible | Alle sichtbaren Zellen

Value Variant optional. Falls für Type entweder xlCellTypeConstants oder xlCellTypeFormulas angegeben wird, legen Sie mit diesem Argument fest, welche Typen von Zellen im Ergebnis mit eingeschlossen werden. Diese Werte können addiert werden, wenn mehrere Typen zurückgegeben werden sollen. Standardmäßig werden, unabhängig vom Typ, alle Konstanten und Werte ausgewählt. Kann eine der folgenden XlSpecialCellsValues-Konstanten sein: xlErrors, xlLogical, xlNumbers oder xlTextValues.


Beispiel zur SpecialCells-Methode

In diesem Beispiel wird die letzte Zelle im verwendeten Bereich von Sheet1 aktiviert.

Worksheets("Sheet1").Activate
ActiveSheet.Cells.SpecialCells(xlCellTypeLastCell).Activate


Subtotal-Methode

Erstellt Teilergebnisse für den Bereich (bzw. für die aktuelle Region, wenn der Bereich nur aus einer Zelle besteht).

Informationen über die Tabellenfunktion Teilergebnis in Visual Basic finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.

Syntax

Ausdruck.Subtotal(GroupBy, Function, TotalList, Replace, PageBreaks, SummaryBelowData)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

GroupBy Long erforderlich. Das Feld, nach dem gruppiert werden soll, und zwar als ganzzahliger, bei 1 beginnender Versatz (Offset). Weitere Informationen hierzu finden Sie im Beispiel.

Function Long erforderlich. Die Funktion zur Berechnung des Teilergebnisses. Zulässig ist eine der folgenden XlConsolidationFunction-Konstanten: xlAverage, xlCount, xlCountNums, xlMax, xlMin, xlProduct, xlStDev, xlStDevP, xlSum, xlVar oder xlVarP.

TotalList Variant erforderlich. Eine Matrix mit bei 1 beginnenden Feldversätzen. Diese bezeichnen die Felder, zu denen die Teilergebnisse hinzugefügt werden. Weitere Informationen hierzu finden Sie im Beispiel.

Replace Variant optional. True, wenn bestehende Teilergebnisse ersetzt werden. Der Standardwert ist False.

PageBreaks Variant optional. True, wenn nach jeder Gruppe ein Seitenwechsel eingefügt wird. Der Standardwert ist False.

SummaryBelowData Variant optional. Zulässig ist eine der folgenden xlSummaryRow-Konstanten: xlSummaryAbove oder xlSummaryBelow. Der Standardwert ist xlSummaryBelow.


Beispiel zur Subtotal-Methode

In diesem Beispiel werden Teilergebnisse für den ausgewählten Bereich in Sheet1 erstellt. Es handelt sich hierbei um Summen, die nach jeder Änderung im ersten Feld gruppiert werden. Die Teilergebnisse werden im zweiten und dritten Feld hinzu addiert.

Worksheets("Sheet1").Activate
Selection.Subtotal groupBy:=1, function:=xlSum, _
    totalList:=Array(2, 3)


Table-Methode

Erstellt eine Datentabelle basierend auf Eingabewerten und Formeln, die in einem Tabellenblatt definiert sind.

Syntax

Ausdruck.Table(RowInput, ColumnInput)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

RowInput Variant optional. Eine einzelne Zelle, die als Eingabe für die Zeilen der Tabelle dient.

ColumnInput Variant optional. Eine einzelne Zelle, die als Eingabe für die Spalten der Tabelle dient.

Anmerkungen

Mit Datentabellen können Sie eine "Was-wäre-wenn"-Analyse durchführen. Sie können bestimmte konstante Werte im Tabellenblatt ändern und anschließend die Auswirkung auf Werte in anderen Zellen beobachten.


Beispiel zur Table-Methode

In diesem Beispiel wird eine Multiplikations-Datentabelle im Bereich A1:K11 in Sheet1 erstellt und das Ergebnis formatiert.

Set dataTableRange = Worksheets("Sheet1").Range("A1:K11")
Set rowInputCell = Worksheets("Sheet1").Range("A12")
Set columnInputCell = Worksheets("Sheet1").Range("A13")

Worksheets("Sheet1").Range("A1").Formula = "=A12*A13"
For i = 2 To 11
    Worksheets("Sheet1").Cells(i, 1) = i - 1
    Worksheets("Sheet1").Cells(1, i) = i - 1
Next i
dataTableRange.Table rowInputCell, columnInputCell
With Worksheets("Sheet1").Range("A1").CurrentRegion
    .Rows(1).Font.Bold = True
    .Columns(1).Font.Bold = True
    .Columns.AutoFit
End With


Text-Methode

Legt den Kommentartext fest.

Syntax

Ausdruck.Text(Text, Start, Overwrite)

Ausdruck Erforderlich. Ein Ausdruck der ein Comment-Objekt zurückgibt.

Text Variant optional. Der hinzuzufügende Text.

Start Variant optional. Die Nummer des Zeichens, an dem der neue Text eingefügt wird. Wird dieses Argument nicht angegeben, wird bereits bestehender Text im Kommentar gelöscht.

Overwrite Variant optional. True, falls bereits bestehender Text überschrieben wird. Der Standardwert ist False (der Text wird eingefügt).


TextToColumns-Methode

Analysiert eine Spalte mit Zellen, die Text enthalten, und gibt das Ergebnis in mehreren Spalten aus.

Syntax

Ausdruck.TextToColumns(Destination, DataType, TextQualifier, ConsecutiveDelimiter, Tab, Semicolon, Comma, Space, Other, OtherChar, FieldInfo, DecimalSeparator, ThousandsSeparator)

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.

Destination Variant optional. Ein Range-Objekt, das angibt, an welcher Stelle Microsoft Excel das Ergebnis ausgeben soll. Ist der Bereich größer als eine einzelne Zelle, so wird die obere linke Zelle verwendet.

DataType Variant optional. Das Format des Textes, der in Spalten aufgeteilt werden soll. Kann eine der folgenden XlTextParsingType-Konstanten sein: xlDelimited oder xlFixedWidth. Der Standardwert ist xlDelimited.

TextQualifier Variant optional. Der Textkennzeichner. Kann eine der folgenden XlTextQualifier-Konstanten sein: xlTextQualifierDoubleQuote, xlTextQualifierSingleQuote oder xlTextQualifierNone. Der Standardwert ist xlTextQualifierDoubleQuote.

ConsecutiveDelimiter Variant optional. True, wenn Microsoft Excel sich wiederholende Trennzeichen als ein Trennzeichen interpretieren soll. Der Standardwert ist False.

Tab Variant optional. True, wenn DataType den Wert xlDelimited hat und das Tabulatorzeichen als Trennzeichen verwendet wird. Der Standardwert ist False.

Semicolon Variant optional. True, wenn DataType den Wert xlDelimited hat und das Semikolon als Trennzeichen verwendet wird. Der Standardwert ist False.

Comma Variant optional. True, wenn DataType den Wert xlDelimited hat und das Komma als Trennzeichen verwendet wird. Der Standardwert ist False.

Space Variant optional. True, wenn DataType den Wert xlDelimited hat und das Leerzeichen als Trennzeichen verwendet wird. Der Standardwert ist False.

Other Variant optional. True, wenn DataType den Wert xlDelimited hat und das durch das Argument OtherChar angegebene Zeichen als Trennzeichen verwendet wird. Der Standardwert ist False.

OtherChar Variant optional (erforderlich wenn Other den Wert True hat). Gibt das Trennzeichen an, wenn Other den Wert True hat. Wenn mehr als ein Zeichen angegeben ist, wird das erste Zeichen der Zeichenfolge verwendet. Die übrigen Zeichen werden ignoriert.

FieldInfo Variant optional. Eine Matrix, die Analyseinformationen über die Daten in den einzelnen Spalten enthält. Die Analyse hängt davon ab, welchen Wert DataType hat.

Wenn die Daten getrennt sind, ist dieses Argument eine Matrix aus zweielementigen Matrizen. Jede zweielementige Matrix gibt die Umwandlungsoptionen für eine bestimmte Spalte an. Das erste Element ist die Spaltennummer (beginnend mit 1) und das zweite Element ist eine der in der folgenden Tabelle aufgeführten xlColumnDataType-Konstanten, die angeben, wie die Spalte analysiert wird.

Konstante | Beschreibung
xlGeneralFormat | Allgemein
xlTextFormat | Text
xlMDYFormat | Datum im Format MTJ
xlDMYFormat | Datum im Format TMJ
xlYMDFormat | Datum im Format JMT
xlMYDFormat | Datum im Format MJT
xlDYMFormat | Datum im Format TJM
xlYDMFormat | Datum im Format JTM
xlEMDFormat | Datum im EMD-Format
xlSkipColumn | Spalte überspringen

Sie können xlEMDFormat nur verwenden, wenn die Sprachunterstützung für Taiwan installiert und aktiviert ist. Die xlEMDFormat-Konstante gibt an, dass Kalenderangaben gemäß dem Taiwanesischen Kalender verwendet werden sollen.

Die Spaltenangaben können in beliebiger Reihenfolge erfolgen. Wenn eine Spaltenangabe für eine bestimmte Spalte der Eingabedaten nicht vorhanden ist, wird die Spalte auf der Grundlage der Einstellung Allgemein analysiert. In diesem Beispiel wird die dritte Spalte übersprungen, die erste Spalte wird als Text analysiert und die übrigen Spalten der Quelldaten werden auf der Grundlage der Einstellung Allgemein analysiert.

Array(Array(3, 9), Array(1, 2))

Wenn für die Spalten der Quelldaten eine feste Spaltenbreite festgelegt ist, gibt das erste Element jeder zweiteiligen Matrix die Anfangsposition in der Spalte als eine ganze Zahl an (ausgehend von 0). Das zweite Element der zweiteiligen Matrix gibt die Analyseoption für die Spalte als eine Nummer von 1 bis 9 an, wie oben dargestellt.

Im folgenden Beispiel werden zwei Spalten einer Datei mit fester Spaltenbreite analysiert. In der ersten Spalte wird am Anfang der Zeile begonnen, und es werden die ersten 10 Zeichen berücksichtigt. In der zweiten Spalte ist die Anfangsposition 15; alle Zeichen bis zum Ende der Zeile werden berücksichtigt. Damit die Zeichen zwischen 10 und 15 nicht mitberücksichtigt werden, wird ein "Spalte überspringen-Eintrag" eingefügt.

Array(Array(0, 1), Array(10, 9), Array(15, 1))

DecimalSeparator String optional. Das Dezimaltrennzeichen, das Microsoft Excel beim Erkennen von Zahlen verwendet. Standardeinstellung ist die Systemeinstellung.

ThousandsSeparator String optional. Das 1.000er-Trennzeichen, das Excel beim Erkennen von Zahlen verwendet. Standardeinstellung ist die Systemeinstellung.

In der folgenden Tabelle sind die Ergebnisse beim Importieren von Text in Excel für verschiedene Importeinstellungen gezeigt. Die numerischen Ergebnisse werden in der Spalte ganz rechts angezeigt.

Dezimaltrennzeichen des Systems | 1.000er-Trennzeichen des Systems | Wert für Dezimaltrennzeichen | Wert für 1.000er-Trennzeichen | Originaltext | Zellwert (Datentyp)
Punkt | Komma | Komma | Punkt | 123.123,45 | 123,123.45 (numerisch)
Punkt | Komma | Komma | Komma | 123.123,45 | 123.123,45 (Text)
Komma | Punkt | Komma | Punkt | 123,123.45 | 123,123.45 (numerisch)
Punkt | Komma | Punkt | Komma | 123 123.45 | 123 123.45 (Text)
Punkt | Komma | Punkt | Leerzeichen | 123 123.45 | 123,123.45 (numerisch)


Beispiel zur TextToColumns-Methode

In diesem Beispiel wird der Inhalt der Zwischenablage (eine Tabelle mit Text, in der das Leerzeichen als Trennzeichen verwendet wird) in mehreren Spalten in Sheet1 ausgegeben. Sie können eine einfache Tabelle dieser Art im Editor oder mit WordPad (bzw. mit einem anderen Texteditor) erstellen, die Texttabelle in die Zwischenablage kopieren, zu Microsoft Excel wechseln und anschließend dieses Makro ausführen.

Worksheets("Sheet1").Activate
ActiveSheet.Paste
Selection.TextToColumns DataType:=xlDelimited, _
    ConsecutiveDelimiter:=True, Space:=True


ToggleVerticalText-Methode

Ändert den Textfluss in der angegebenen WordArt von horizontal in vertikal und umgekehrt.

Syntax

Ausdruck.ToggleVerticalText

Ausdruck Erforderlich. Ein Ausdruck, der ein TextEffectFormat-Objekt zurückgibt.

Anmerkungen

Das Verwenden der ToggleVerticalText-Methode vertauscht die Werte der Eigenschaften Width und Height des Shape-Objekts, das die WordArt darstellt. Die Eigenschaften Left und Top bleiben unverändert.

Die Flip-Methode und die Rotation-Eigenschaft des Shape-Objekts sowie die RotatedChars-Eigenschaft und die ToggleVerticalText-Methode des TextEffectFormat-Objekts wirken sich alle auf die Ausrichtung der Zeichen und die Richtung des Textflusses in einem Shape-Objekt aus, das die WordArt darstellt. Sie sollten durch Ausprobieren herausfinden, wie die Auswirkungen dieser Eigenschaften und Methoden zu kombinieren sind, damit Sie das gewünschte Ergebnis erhalten.


Beispiel zur ToggleVerticalText-Methode

In diesem Beispiel wird in myDocument eine WordArt mit dem Text "Test" eingefügt und von horizontalem Textfluss (dem Standardwert für die angegebene Formatvorlage der WordArt, msoTextEffect1) zu vertikalem Textfluss gewechselt.

Set myDocument = Worksheets(1)
Set newWordArt = myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=100, _
    Top:=100)
newWordArt.TextEffect.ToggleVerticalText


Trendlines-Methode

Gibt ein Objekt zurück, das eine einzelne Trendlinie (ein Trendline-Objekt, Syntax 1) darstellt oder eine Auflistung aller Trendlinien der Datenreihe (ein Trendlines-Objekt, Syntax 2).

Syntax 1

Objekt.Trendlines(Index)

Syntax 2

Objekt.Trendlines

Objekt Erforderlich. Das Series-Objekt.

Index Variant optional. Name oder die Nummer der Trendlinie.


Beispiel zur Trendlines-Methode

In diesem Beispiel wird der ersten Datenreihe in Chart1 eine lineare Trendlinie hinzugefügt.

Charts("Chart1").SeriesCollection(1).Trendlines.Add Type:=xlLinear


TwoColorGradient-Methode

Legt für die angegebene Füllung einen zweifarbigen Farbverlauf fest.

Syntax

Ausdruck.TwoColorGradient(Style, Variant)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

Style Long erforderlich. Die Verlaufsart. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientHorizontal oder msoGradientVertical.

Variant Long erforderlich. Die Verlaufsvariante. Kann ein Wert von 1 bis 4 sein, der einer der vier Varianten in der Registerkarte Graduell des Dialogfelds Fülleffekte entspricht. Falls Style die Konstante msoGradientFromCenter besitzt, kann das Argument Variant nur 1 oder 2 sein.


Beispiel zur TwoColorGradient-Methode

In diesem Beispiel werden Vordergrundfarbe, Hintergrundfarbe und Farbverlauf der Füllung im Diagrammbereich des ersten Diagramms festgelegt.

With Charts(1).ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


Undo-Methode

Macht die letzte Benutzeraktion rückgängig.

Syntax

Ausdruck.Undo

Ausdruck Ein erforderlicher Ausdruck, der ein Application-Objekt zurückgibt.

Anmerkungen

Mit dieser Methode kann nur die Aktion rückgängig gemacht werden, die der Benutzer zuletzt vor der Ausführung des Makros durchgeführt hat. Diese Methode muss in der ersten Zeile des Makros aufgerufen werden. Visual Basic-Befehle können mit dieser Methode nicht rückgängig gemacht werden.


Beispiel zur Undo-Methode

In diesem Beispiel wird die letzte Benutzeraktion rückgängig gemacht. Diese Zeile muss die erste Zeile im Makro sein.

Application.Undo


Ungroup-Methode

Um weitere Informationen zu erhalten, klicken Sie auf eines der folgenden Objekte.

Range

Shape

ShapeRange


Ungroup-Methode (Range-Objekt)

Hebt die Gruppierung eines Bereichs in einer Gliederung auf (stuft den Bereich um eine Gliederungsebene herunter). Bei dem angegebenen Bereich muss es sich um eine Zeile oder Spalte bzw. um einen Bereich von Zeilen oder Spalten handeln. Wenn der Bereich in einem PivotTable-Bericht liegt, wird die Gruppierung für die im Bereich enthaltenen Elemente aufgehoben.

Syntax

Ausdruck.Ungroup

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Anmerkungen

Wenn sich die aktive Zelle in der Feldkopfzeile eines übergeordneten Feldes befindet, wird die Gruppierung aller Gruppen in diesem Feld aufgehoben und das Feld aus dem PivotTable-Bericht entfernt. Wenn die Gruppierung der letzten Gruppe in einem übergeordneten Feld aufgehoben wird, wird das gesamte Feld aus dem Bericht entfernt.


Beispiel zur Ungroup-Methode (Range-Objekt)

In diesem Beispiel wird die Gruppierung für das Feld "ORDER_DATE" aufgehoben.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Set groupRange = pvtTable.PivotFields("ORDER_DATE").DataRange
groupRange.Cells(1).Ungroup


Ungroup-Methode (Shape- oder ShapeRange-Objekt)

Hebt die Gruppierung aller gruppierten Formen in der angegebenen Form oder dem Formbereich auf. Zerlegt Bilder und OLE-Objekte in der angegebenen Form oder dem Formbereich. Gibt die ungruppierten Formen als einzelnes ShapeRange-Objekt zurück.

Syntax

Ausdruck.Ungroup

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Anmerkungen

Da eine Gruppe von Formen als einzelnes Objekt behandelt wird, ändert das Bilden bzw. Aufheben von Formengruppen die Anzahl der Elemente in der Shapes-Auflistung sowie die Indexnummern der Elemente, die den betroffenen Elementen in der Auflistung nachfolgen.


Beispiel zur Ungroup-Methode (Shape- oder ShapeRange-Objekt)

In diesem Beispiel werden in myDocument alle Formengruppen aufgehoben und alle Bilder oder OLE-Objekte zerlegt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    s.Ungroup
Next

In diesem Beispiel werden in myDocument alle Formengruppen aufgehoben, ohne Bilder oder OLE-Objekte zu zerlegen.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.Type = msoGroup Then s.Ungroup
Next


Union-Methode

Gibt die Vereinigung von mindestens zwei Bereichen zurück.

Syntax

Ausdruck.Union(Arg1, Arg2, ...)

Ausdruck Ein optionaler Ausdruck, der ein Application-Objekt zurückgibt.

Arg1, Arg2, ... Range erforderlich. Es müssen mindestens zwei Range-Objekte angegeben werden.


Beispiel zur Union-Methode

In diesem Beispiel wird die Vereinigung der benannten Bereiche "Range1" und "Range2" mit der Formel =RAND() gefüllt.

Worksheets("Sheet1").Activate
Set bigRange = Application.Union(Range("Range1"), Range("Range2"))
bigRange.Formula = "=RAND()"


UnMerge-Methode

Löst einen zusammengeführten Bereich in einzelne Zellen auf.

Syntax

Ausdruck.UnMerge

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.


Beispiel zur UnMerge-Methode

In diesem Beispiel wird der zusammengeführte Bereich aufgelöst, der die Zelle A3 enthält.

With Range("a3")
    If .MergeCells Then
        .MergeArea.UnMerge
    Else
        MsgBox "not merged"
    End If
End With


Unprotect-Methode

Hebt den Schutz eines Blattes oder einer Arbeitsmappe auf. Diese Methode hat keine Wirkung, wenn das Blatt oder die Arbeitsmappe nicht geschützt ist.

Syntax

Ausdruck.Unprotect(Password)

Ausdruck Ein erforderlicher Ausdruck, der ein Chart-, Workbook- oder Worksheet-Objekt zurückgibt.

Password Variant optional. Eine Zeichenfolge, die das groß-/kleinschreibungsabhängige Kennwort angibt, um den Schutz des Blattes oder der Arbeitsmappe aufzuheben. Wenn das Blatt oder die Arbeitsmappe nicht durch ein Kennwort geschützt sind, wird dieses Argument ignoriert. Wenn Sie dieses Argument bei einem durch Kennwort geschützten Blatt auslassen, werden Sie zur Eingabe des Kennworts aufgefordert. Wenn Sie dieses Argument bei einer durch Kennwort geschützten Arbeitsmappe auslassen, versagt die Methode.

Anmerkungen

Wenn Sie das Kennwort vergessen, können Sie den Schutz des Blattes oder der Arbeitsmappe nicht wieder aufheben. Sie sollten daher eine Liste Ihrer Kennwörter und der zugehörigen Dateinamen an einem sicheren Ort aufbewahren.


UnprotectSharing-Methode

Schaltet den Schutz für die gemeinsame Nutzung aus und speichert die Arbeitsmappe.

Syntax

Ausdruck.UnprotectSharing(SharingPassword)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

SharingPassword Variant optional. Das Kennwort der Arbeitsmappe.


Beispiel zur UnprotectSharing-Methode

In diesem Beispiel wird der Schutz für die gemeinsame Benutzung ausgeschaltet und die aktive Arbeitsmappe gespeichert.

ActiveWorkbook.UnprotectSharing Password:="drowssap"


Update-Methode

Aktualisiert die Verknüpfung oder den PivotTable-Bericht.

Syntax

Ausdruck.Update

Ausdruck Ein erforderlicher Ausdruck, der ein OLEObject oder PivotTable-Objekt zurückgibt.


UpdateFromFile-Methode

Aktualisiert eine schreibgeschützte Arbeitsmappe mit der gespeicherten Version, falls die Version auf dem Datenträger neuer ist als die aktuelle Kopie der Arbeitsmappe im Arbeitsspeicher. Wurde die Kopie auf dem Datenträger seit dem Laden der Arbeitsmappe nicht verändert, wird die Kopie im Arbeitsspeicher nicht neu geladen.

Syntax

Ausdruck.UpdateFromFile

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Anmerkungen

Diese Methode bietet sich an, wenn eine Arbeitsmappe von Benutzer/in A schreibgeschützt und von Benutzer/in B mit Schreib-Lese-Zugriff geöffnet wird. Falls Benutzer/in B eine neuere Version der Arbeitsmappe auf dem Datenträger speichert, während Benutzer/in A die Arbeitsmappe noch geöffnet hat, kann Benutzer/in A die aktualisierte Kopie nicht einsehen, ohne die Arbeitsmappe zu schließen und erneut zu öffnen. Dabei gehen Einstellungen der Fensteranordnung verloren. Die UpdateFromFile-Methode aktualisiert die Kopie der Arbeitsmappe im Speicher entsprechend der Datei auf dem Datenträger.


Beispiel zur UpdateFromFile-Methode

In diesem Beispiel wird die aktive Arbeitsmappe aktualisiert und an die gespeicherte Version angepasst.

ActiveWorkbook.UpdateFromFile


UpdateLink-Methode

Aktualisiert eine Microsoft Excel- DDE- oder OLE-Verknüpfung (bzw. mehrere Verknüpfungen).

Syntax

Ausdruck.UpdateLink(Name, Type)

Ausdruck Ein erforderlicher Ausdruck, der ein Workbook-Objekt zurückgibt.

Name String erforderlich. Der Name der zu aktualisierenden Microsoft Excel- oder DDE/OLE-Verknüpfung, wie er von der LinkSources-Methode zurückgegeben wird.

Type Variant optional. Der Verknüpfungstyp. Kann eine der folgenden XlLinkType-Konstanten sein: xlLinkTypeExcelLinks oder xlLinkTypeOLELinks (auch für DDE-Verknüpfungen). Der Standardwert ist xlLinkTypeExcelLinks.


Beispiel zur UpdateLink-Methode

In diesem Beispiel werden alle Verknüpfungen in der aktiven Arbeitsmappe aktualisiert.

ActiveWorkbook.UpdateLink Name:=ActiveWorkbook.LinkSources


UseDefaultFolderSuffix-Methode

Stellt den Ordnersuffix für das angegebene Dokument auf den Standardsuffix für die ausgewählte oder installierte Sprachunterstützung ein.

Syntax

Ausdruck.UseDefaultFolderSuffix

Ausdruck Ein Ausdruck, der ein WebOptions-Objekt zurückgibt.

Anmerkungen

Microsoft Excel verwendet den Ordnersuffix, wenn Sie ein Dokument als Webseite speichern, lange Dateinamen verwenden und die Unterstützungsdateien in einem getrennten Ordner gespeichert werden sollen (d. h., wenn die UseLongFileNames- und OrganizeInFolder-Eigenschaften auf True eingestellt sind).

Der Suffix wird im Ordnernamen hinter dem Dokumentennamen angezeigt. Wenn das Dokument beispielsweise "Book1" heißt und die Sprache Englisch ist, lautet der Ordnername Book1_files. Die verfügbaren Ordnersuffixe sind im Thema FolderSuffix-Eigenschaft aufgeführt.


Beispiel zur UseDefaultFolderSuffix-Methode

In diesem Beispiel wird der Ordnersuffix der ersten Arbeitsmappe auf den Standardsuffix eingestellt.

Workbooks(1).WebOptions.UseDefaultFolderSuffix


UserPicture-Methode

Füllt die angegebene Form mit einem Bild.

Syntax

Ausdruck.UserPicture(PictureFile, PictureFormat, PictureStackUnit, PicturePlacement)

Ausdruck Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

PictureFile String erforderlich. Der Name der Bilddatei.

PictureFormat Long erforderlich. Das Bildformat. Dies kann eine der folgenden XlChartPictureType-Konstanten sein: xlStack, xlStackScale oder xlStretch.

PictureStackUnit Long erforderlich. Der Bildstapel oder die Skalierungseinheit (hängt von dem Argument PictureFormat ab).

PicturePlacement Long erforderlich. Die Position, an der das Bild angezeigt wird. Dies kann eine der folgenden XlChartPicturePlacement-Konstanten sein: xlAllFaces, xlEnd, xlEndSides, xlFront, xlFrontEnd, xlFrontSides oder xlSides.


Beispiel zur UserPicture-Methode

In diesem Beispiel wird das Füllformat des zweiten Diagramms festgelegt.

Charts(2).ChartArea.Fill.UserPicture "brick.bmp


UserTextured-Methode

Füllt die angegebene Form mit kleinen Kacheln eines Bildes. Möchten Sie die Form mit einem einzigen großen Bild füllen, so verwenden Sie die UserPicture-Methode.

Syntax

Ausdruck.UserTextured(TextureFile)

Ausdruck Erforderlich. Ein Ausdruck, der ein FillFormat-Objekt zurückgibt.

TextureFile String erforderlich. Der Name der Bilddatei.


Beispiel zur UserTextured-Methode

In diesem Beispiel wird das Füllformat des zweiten Diagramms festgelegt.

Charts(2).ChartArea.Fill.UserTextured "brick.bmp"


Verb-Methode

Sendet ein Verb an den Server des angegebenen OLE-Objekts.

Syntax

Ausdruck.Verb(Verb)

Ausdruck Ein erforderlicher Ausdruck, der ein OLEObject-Objekt zurückgibt.

Verb Variant optional. Das Verb, das der Server des OLE-Objekts bearbeiten soll. Fehlt diese Angabe, wird das Standardverb gesendet. Die verfügbaren Verben werden von der Quellanwendung des Objekts bestimmt. Typische Verben eines OLE-Objekts sind "öffnen" und das Primär-Verb (dargestellt durch die XlOLEVerb-Konstanten xlOpen und xlPrimary).


Beispiel zur Verb-Methode

In diesem Beispiel wird das Standardverb an den Server für das erste OLE-Objekt in Sheet1 gesendet.

Worksheets("Sheet1").OLEObjects(1).Verb


Volatile-Methode

Kennzeichnet eine benutzerdefinierte Funktion als flüchtig. Solche Funktionen werden immer neu berechnet, wenn in einer beliebigen Zelle des Tabellenblattes eine Berechnung durchgeführt wird. Nicht flüchtige Funktionen werden nur dann neu berechnet, wenn sich die Eingabevariablen ändern. Diese Methode wird in der Regel in einer benutzerdefinierten Funktion zur Berechnung einer Tabellenzelle verwendet, andernfalls hat sie keine Auswirkung.

Syntax

Ausdruck.Volatile(Volatile)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Volatile Variant optional. True, um die Funktion als flüchtig zu kennzeichnen. False, um die Funktion als nicht flüchtig zu kennzeichnen. Die Voreinstellung ist True.


Beispiel zur Volatile-Methode

In diesem Beispiel wird die benutzerdefinierte Funktion "My_Func" als flüchtig gekennzeichnet. Die Funktion wird jedesmal neu berechnet, wenn in einer beliebigen Zelle des Tabellenblatts eine Berechnung durchgeführt wird.

Function My_Func()
    Application.Volatile
    '
    '    Remainder of the function
    '
End Function


Wait-Methode

Hält das zurzeit ausgeführte Makro bis zu einem bestimmten Zeitpunkt an. Gibt zum angegebenen Zeitpunkt True zurück.

Anmerkung: Die Wait-Methode unterbricht alle Aktivitäten von Microsoft Excel und verhindert unter Umständen auch die Ausführung sonstiger Arbeiten auf dem Computer. Hintergrundprozesse, wie Drucken und Neuberechnung, werden jedoch fortgesetzt.

Syntax

Ausdruck.Wait(Time)

Ausdruck Ein erforderlicher Ausdruck, der ein Application-Objekt zurückgibt.

Time Variant erforderlich. Der Zeitpunkt, zu dem das Makro fortgesetzt werden soll (im Datumsformat von Microsoft Excel).


Beispiel zur Wait-Methode

In diesem Beispiel wird ein zurzeit ausgeführtes Makro bis 18.23 Uhr desselben Tages unterbrochen.

Application.Wait "18:23:00"

In diesem Beispiel wird ein zurzeit ausgeführtes Makro für ungefähr 10 Sekunden unterbrochen.

newHour = Hour(Now())
newMinute = Minute(Now())
newSecond = Second(Now()) + 10
waitTime = TimeSerial(newHour, newMinute, newSecond)
Application.Wait waitTime

In diesem Beispiel wird eine Meldung angezeigt, die anzeigt, dass 10 Sekunden abgelaufen sind.

If Application.Wait(Now + TimeValue("0:00:10")) Then
    MsgBox "Time expired"
End If


WebPagePreview-Methode

Zeigt eine Vorschau der angegebenen Arbeitsmappe, wie sie aussehen würde, wenn sie als Webseite gespeichert wäre.

Syntax

Ausdruck.WebPagePreview

Ausdruck Ein Ausdruck, der ein Workbook-Objekt zurückgibt.


Beispiel zur WebPagePreview-Methode

In diesem Beispiel wird eine Vorschau der ersten Arbeitsmappe als Webseite angezeigt.

Workbooks(1).WebPagePreview


XYGroups-Methode

Gibt in einem 2D-Diagramm ein Objekt zurück, das eine einzelne Punktdiagrammgruppe (ein ChartGroup-Objekt, Syntax 1) oder eine Auflistung der Punktdiagrammgruppen (eine ChartGroups-Auflistung, Syntax 2) darstellt.

Syntax 1

Ausdruck.XYGroups(Index)

Syntax 2

Ausdruck.XYGroups

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index Variant optional. Gibt die Diagrammgruppe an.


Beispiel zur XYGroups-Methode

In diesem Beispiel wird die erste XY-Gruppe (Punktdiagrammgruppe) so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird. Wenden Sie das Beispiel auf ein 2D-Diagramm an.

Charts("Chart1").XYGroups(1).VaryByCategories = True


ZOrder-Methode

Verschiebt die angegebene Form vor oder hinter andere Formen der Auflistung (d. h. die Position der Form in der Z-Reihenfolge wird geändert).

Syntax

Ausdruck.ZOrder(ZOrderCmd)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shape- oder ein ShapeRange-Objekt zurückgibt.

ZOrderCmd Long erforderlich. Legt fest, wohin die angegebene Form, relativ zu den anderen Formen, verschoben werden soll. Kann eine der folgenden MsoZOrderCmd-Konstanten sein: msoBringForward, msoBringToFront, msoSendBackward oder msoSendToBack. Die Konstanten msoBringInFrontOfText und msoSendBehindText werden in Microsoft Word nicht verwendet.

Anmerkungen

Verwenden Sie die ZOrderPosition-Eigenschaft, um die aktuelle Position einer Form in der Z-Reihenfolge festzustellen.


Beispiel zur ZOrder-Methode

In diesem Beispiel wird in myDocument eine Ellipse eingefügt und anschließend an der vorletzten Position in der Z-Reihenfolge positioniert, wenn in dem Dokument noch mindestens eine weitere Form existiert.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


 Neue Objekte

Neue Objekte

Objekte, die in Microsoft Excel 2000 zu Visual Basic für Applikationen hinzugefügt wurden, sind in der folgenden Tabelle aufgeführt.

Objekte und Auflistungen | Beschreibung
CubeField, CubeFields | Bietet neue Funktionalität für OLAP PivotTable-Berichte.
DefaultWebOptions, PublishObject, PublishObjects, WebOptions | Bietet neue Funktionalität zum Erstellen, Bearbeiten und Speichern von Webseiten.
DisplayUnitLabel | Bietet neue Einheitenbeschriftungen, um die Lesbarkeit der Teilstrichbeschriftungen auf den Diagrammachsen zu erleichtern.
OLEDBError, OLEDBErrors | Bietet neue OLE DB-Fehlerobjekte.
Phonetics | Bietet verbesserte phonetische Textverarbeitung zur Unterstützung von ostasiatischen Sprachen.
PivotLayout | Bietet neue Funktionalität für PivotChart-Berichte.


AddIn-Objekt

Stellt ein einzelnes installiertes oder nicht installiertes Add-In dar. Das AddIn-Objekt ist ein Element der AddIns-Auflistung. Die AddIns-Auflistung enthält eine Liste aller installierten und nicht installierten Add-Ins, die in Microsoft Excel zur Verfügung stehen. Diese Liste entspricht der Add-In-Liste im Dialogfeld Add-Ins (Menü Extras).

Verwenden des AddIn-Objekts

Verwenden Sie AddIns(Index), um ein einzelnes AddIn-Objekt zurückzugeben. Dabei ist Index der Add-In-Titel oder eine Indexzahl. Mit dem folgenden Beispiel wird das Add-In "Analyse-Funktionen" installiert.

AddIns("analysis toolpak").Installed = True

Der Add-In-Titel, der im Dialogfeld Add-Ins angezeigt wird, ist nicht mit dem Add-In-Namen (dem Dateinamen des Add-Ins) zu verwechseln. Die Schreibweise des Add-In-Titels, nicht jedoch die Groß-/Kleinschreibung, muss mit der im Dialogfeld Add-Ins übereinstimmen.

Die Indexzahl stellt die Position des Add-Ins im Feld Verfügbare Add-Ins im Dialogfeld Add-Ins dar. Mit dem folgenden Beispiel wird eine Liste erstellt, die die angegebenen Eigenschaften der verfügbaren Add-Ins enthält.

With Worksheets("sheet1")
    .Rows(1).Font.Bold = True
    .Range("a1:d1").Value = _
        Array("Name", "Full Name", "Title", "Installed")
    For i = 1 To AddIns.Count
        .Cells(i + 1, 1) = AddIns(i).Name
        .Cells(i + 1, 2) = AddIns(i).FullName
        .Cells(i + 1, 3) = AddIns(i).Title
        .Cells(i + 1, 4) = AddIns(i).Installed
    Next
    .Range("a1").CurrentRegion.Columns.AutoFit
End With

Anmerkungen

Die Add-Methode fügt der Liste verfügbarer Add-Ins ein Add-In hinzu, installiert es jedoch nicht. Setzen Sie die Installed-Eigenschaft des Add-In auf True, um das Add-In zu installieren. Wenn Sie ein Add-In installieren möchten, das nicht in der Liste verfügbarer Add-Ins erscheint, müssen Sie zuerst die Add-Methode verwenden und anschließend die Installed-Eigenschaft setzen. Dies ist in einem einzigen Arbeitsschritt möglich, wie im folgenden Beispiel gezeigt wird (Sie müssen bei der Add-Methode den Namen des Add-Ins verwenden und nicht den Titel).

AddIns.Add("generic.xll").Installed = True

Verwenden Sie Workbooks(Index), um einen Bezug auf die Arbeitsmappe zurückzugeben, die einem geladenen Add-In entspricht. Dabei ist Index der Dateiname des Add-Ins (nicht der Titel). Sie müssen den Dateinamen verwenden, da geladene Add-Ins normalerweise nicht in der Workbooks-Auflistung erscheinen. Im folgenden Beispiel wird der Variablen wb die Arbeitsmappe MYADDIN.XLA zugewiesen.

Set wb = Workbooks("myaddin.xla")

Im folgenden Beispiel wird der Variable wb die Arbeitsmappe des Add-Ins "Analyse-Funktionen" zugewiesen.

Set wb = Workbooks(AddIns("analysis toolpak").Name)

Wenn die Installed-Eigenschaft True zurückgibt, das Aufrufen von Add-In-Funktionen jedoch nicht funktioniert, wurde das Add-In möglicherweise nicht richtig geladen. Der Grund dafür ist, dass das AddIn-Objekt zwar Informationen über das Vorhandensein und den Installationsstatus des Add-Ins liefert, nicht aber über den tatsächlichen Inhalt der Arbeitsmappe des Add-Ins. Um sicherzustellen, dass ein installiertes Add-In auch geladen wurde, sollten Sie die Arbeitsmappe des Add-Ins öffnen. Im folgenden Beispiel wird die Arbeitsmappe des Add-Ins "My Addin" geöffnet, falls das Add-In nicht bereits in der Workbooks-Auflistung vorhanden ist.

On Error Resume Next    ' turn off error checking
Set wbMyAddin = Workbooks(Addins("My Addin").Name)
lastError = Err
On Error Goto 0         ' restore error checking
If lastError <> 0 Then
    ' the add-in workbook isn't currently open. Manually open it.
    Set wbMyAddin = Workbooks.Open(Addins("My Addin").FullName)
End If


AddIns-Auflistungsobjekt

Eine Auflistung von AddIn-Objekten, die alle installierten und nicht installierten Add-Ins darstellt, die in Microsoft Excel zur Verfügung stehen. Diese Liste entspricht der im Dialogfeld Add-Ins (Menü Extras) angezeigten Liste.

Verwenden der Addins-Auflistung

Verwenden Sie die AddIns-Methode, um die AddIns-Auflistung zurückzugeben. Mit dem folgenden Beispiel wird eine Liste mit den Namen und dem Installationsstatus aller verfügbaren Add-Ins erstellt.

Sub DisplayAddIns()
    Worksheets("Sheet1").Activate
    rw = 1
    For Each ad In Application.AddIns
        Worksheets("Sheet1").Cells(rw, 1) = ad.Name
        Worksheets("Sheet1").Cells(rw, 2) = ad.Installed
        rw = rw + 1
    Next
End Sub

Verwenden Sie die Add-Methode, um der Liste verfügbarer Add-Ins ein Add-In hinzuzufügen. Die Add-Methode fügt der Liste ein Add-In hinzu, installiert es jedoch nicht. Setzen Sie die Installed-Eigenschaft des Add-In auf True, um das Add-In zu installieren. Wenn Sie ein Add-In installieren möchten, das nicht in der Liste verfügbarer Add-Ins erscheint, müssen Sie zuerst die Add-Methode verwenden und anschließend die Installed-Eigenschaft setzen. Dies ist in einem einzigen Arbeitsschritt möglich, wie im folgenden Beispiel gezeigt wird. (Sie müssen bei der Add-Methode den Namen des Add-Ins verwenden und nicht den Titel).

AddIns.Add("generic.xll").Installed = True

Verwenden Sie AddIns(Index), um ein einzelnes AddIn-Objekt zurückzugeben. Dabei ist Index der Add-In-Titel oder eine Indexzahl. Mit dem folgenden Beispiel wird das Add-In "Analyse-Funktionen" installiert.

AddIns("analysis toolpak").Installed = True

Der Add-In-Titel, der im Dialogfeld Add-Ins angezeigt wird, ist nicht mit dem Add-In-Namen (dem Dateinamen des Add-Ins) zu verwechseln. Die Schreibweise des Add-In-Titels, nicht jedoch die Groß-/Kleinschreibung, muss mit der im Dialogfeld Add-Ins übereinstimmen.


Adjustments-Objekt

Enthält eine Auflistung von Anpassungswerten für die angegebene AutoForm, das WordArt-Objekt oder die Verbindung. Jeder Wert stellt dabei eine Anpassungsmöglichkeit des Korrekturziehpunktes dar. Da manche Ziehpunkte auf zwei Arten angepasst werden können, z. B. sowohl horizontal als auch vertikal, kann eine Form mehr Anpassungswerte als Korrekturziehpunkte besitzen. Die maximale Anzahl der Anpassungen einer Form beträgt acht.

Verwenden des Adjustments-Objekts

Verwenden Sie die Adjustments-Eigenschaft, um ein Adjustments-Objekt zurückzugeben. Mit Adjustments(Index), wobei Index die Indexnummer des Korrekturwertes ist, können Sie einen einzelnen Korrekturwert zurückgeben.

Unterschiedliche Formen besitzen eine unterschiedliche Anzahl von Korrekturwerten, unterschiedliche Arten von Korrekturen ändern die Geometrie einer Form auf unterschiedliche Weise und besitzen unterschiedliche Bereiche gültiger Werte. Beispielsweise zeigt die folgende Abbildung, in welcher Weise jeder der vier Korrekturwerte einer Legende mit Pfeil nach rechts an der Definition der Legendengeometrie beteiligt ist.

Legende mit Pfeil nach rechts mit unterschiedlichen Korrekturziehpunkten

Anmerkung Da jede veränderbare Form andere Korrekturmöglichkeiten besitzt, lässt sich das Verhalten einer bestimmten Form bei Korrekturen am besten überprüfen, indem Sie manuell ein Versuchsbeispiel der Form erstellen, die Korrekturen bei eingeschaltetem Makro-Recorder vornehmen und anschließend den aufgezeichneten Code untersuchen.

In der folgenden Tabelle sind die Bereiche der gültigen Anpassungswerte für verschiedene Anpassungsarten zusammengefasst. Wenn Sie einen Wert angeben, der außerhalb des gültigen Bereichs liegt, wird der Korrektur in den meisten Fällen der am nächsten liegende gültige Wert zugewiesen.

Anpassungsart | Anpassungswerte
Linear (horizontal oder vertikal) | Allgemein stellt der Wert 0,0 den linken oder den oberen Rand der Form und der Wert 1,0 den rechten oder den unteren Rand der Form dar. Gültige Werte entsprechen den gültigen Korrekturen, die an der Form manuell vorgenommen werden können. Lässt sich ein Korrekturziehpunkt beispielsweise manuell nur über die Hälfte der Form ziehen, so beträgt der Maximalwert der entsprechenden Korrektur 0,5. Bei Formen wie z. B. Verbindungen und Legenden, bei denen die Werte 0,0 und 1,0 die Begrenzungen des durch die Anfangs- und Endpunkte der Verbindung bzw. der Legende festgelegten Rechtecks darstellen, können negative Zahlen und Zahlen über 1,0 als gültige Werte verwendet werden.
Radial | Ein Anpassungswert von 1,0 entspricht der Breite der Form. Der Maximalwert beträgt 0,5 oder die halbe Breite der Form.
Winkel | Winkel werden in Grad angegeben. Wenn Sie einen Wert außerhalb des Bereichs - 180 bis 180 festlegen, wird er normalisiert, damit er im gültigen Bereich liegt.

Im folgenden Beispiel wird in myDocument eine Legende mit Pfeil nach rechts eingefügt und Anpassungswerte für die Legende festgelegt. Beachten Sie, dass die Legende nur drei Korrekturziehpunkte, aber vier Korrekturen besitzt. Die Korrekturen drei und vier entsprechen dem Ziehpunkt zwischen Spitze und Schaft des Pfeils.

Set myDocument = Worksheets(1)
Set rac = myDocument.Shapes.AddShape(msoShapeRightArrowCallout, _
    10, 10, 250, 190)
With rac.Adjustments
    .Item(1) = 0.5    ' adjusts width of text box
    .Item(2) = 0.15   ' adjusts width of arrow head
    .Item(3) = 0.8    ' adjusts length of arrow head
    .Item(4) = 0.4    ' adjusts width of arrow neck
End With


Application-Objekt

Stellt die gesamte Microsoft Excel-Anwendung dar. Das Application-Objekt enthält:

  • Anwendungsumfassende Einstellungen und Optionen (z. B. viele Optionen im Dialogfeld Optionen (Menü Extras)).

  • Methoden, die Objekte der Hauptebene zurückgeben, z. B. ActiveCell, ActiveSheet usw.

Verwenden des Application-Objekts

Verwenden Sie die Application-Eigenschaft, um das Application-Objekt zurückzugeben. Im folgenden Beispiel wird die Windows-Eigenschaft auf das Application-Objekt angewendet.

Application.Windows("book1.xls").Activate

Im folgenden Beispiel wird ein Microsoft Excel-Arbeitsmappenobjekt in einer anderen Anwendung erstellt und anschließend eine Arbeitsmappe in Microsoft Excel geöffnet.

Set xl = CreateObject("Excel.Sheet")
xl.Application.Workbooks.Open "newbook.xls"

Anmerkungen

Viele Eigenschaften und Methoden, die gängige Objekte der Benutzeroberfläche, wie z. B. die aktive Zelle (ActiveCell-Eigenschaft), zurückgeben, können ohne den Objektkennzeichner Application verwendet werden. An Stelle von Application.ActiveCell.Font.Bold = True können Sie beispielsweise Folgendes eingeben: ActiveCell.Font.Bold = True.


Areas-Auflistungsobjekt

Eine Auflistung aller Bereiche oder zusammenhängender Zellblöcke innerhalb einer Markierung. Es gibt kein separates Area-Objekt; die einzelnen Elemente der Areas-Auflistung sind Range-Objekte. Die Areas-Auflistung enthält ein Range-Objekt für jeden einzelnen, zusammenhängenden Zellbereich in der Markierung. Wenn die Markierung nur einen Bereich enthält, verfügt die Areas-Auflistung über ein einzelnes Range-Objekt, das dieser Markierung entspricht.

Verwenden der Areas-Auflistung

Verwenden Sie die Areas-Eigenschaft, um die Areas-Auflistung zurückzugeben. Im folgenden Beispiel wird die aktuelle Markierung gelöscht, wenn diese mehrere Bereiche enthält.

If Selection.Areas.Count <> 1 Then Selection.Clear

Verwenden Sie Areas(Index), um ein einzelnes Range-Objekt der Auflistung zurückzugeben. Dabei ist Index die Bereichsindexnummer. Die Indexnummern entsprechen der Reihenfolge, in der die Bereiche markiert wurden. Im folgenden Beispiel wird der erste Bereich in der aktuellen Markierung gelöscht, wenn die Markierung mehrere Bereiche umfasst.

If Selection.Areas.Count <> 1 Then
    Selection.Areas(1).Clear
End If

Einige Vorgänge können nur jeweils in einem Bereich der Markierung ausgeführt werden. In solchen Fällen ist es erforderlich, dass Sie die Bereiche der Markierung in einer Schleife durchlaufen und die Vorgänge in jedem einzelnen Bereich ausführen. Im folgenden Beispiel wird der Vorgang mit dem Namen "Vorgang1" im markierten Bereich ausgeführt, wenn die Markierung nur einen Bereich enthält. Enthält die Markierung mehrere Bereiche, wird im Beispiel der Vorgang1 in jedem einzelnen Bereich der Markierung ausgeführt.

Set rangeToUse = Selection
If rangeToUse.Areas.Count = 1 Then
    myOperation rangeToUse
Else
    For Each singleArea in rangeToUse.Areas
        myOperation singleArea
    Next
End If


AutoCorrect-Objekt

Enthält Microsoft Excel AutoCorrect-Attribute (Großschreibung von Tagen, Korrektur von zwei groß geschriebenen Anfangsbuchstaben, automatische Korrekturliste usw.).

Verwendung des AutoCorrect-Objekts

Verwenden Sie die AutoCorrect-Eigenschaft, um das AutoCorrect-Objekt zurückzugeben. Im folgenden Beispiel wird festgelegt, dass Microsoft Excel Wörter mit zwei groß geschriebenen Anfangsbuchstaben korrigiert.

With Application.AutoCorrect
    .TwoInitialCapitals = True
    .ReplaceText = True
End With


AutoFilter-Objekt

Stellt die automatische Filterung für das angegebene Tabellenblatt dar.

Verwenden des AutoFilter-Objekts

Verwenden Sie die AutoFilter-Eigenschaft, um das AutoFilterObjekt zurückzugeben. Verwenden Sie die Filters-Methode, um eine Auflistung der einzelnen Spaltenfilter zurückzugeben. Verwenden Sie die Range-Methode, um das Range-Objekt zurückzugeben, das den gesamten gefilterten Bereich darstellt. Im folgenden Beispiel werden die Adresse und Filterkriterien für die aktuelle Filterung gespeichert und anschließend neue Filter angewendet.

Dim w As Worksheet
Dim filterArray()
Dim currentFiltRange As String

Sub ChangeFilters()

Set w = Worksheets("Crew")
With w.AutoFilter
    currentFiltRange = .Range.Address
    With .Filters
        ReDim filterArray(1 To .Count, 1 To 3)
        For f = 1 To .Count
            With .Item(f)
                If .On Then
                    filterArray(f, 1) = .Criteria1
                    If .Operator Then
                        filterArray(f, 2) = .Operator
                        filterArray(f, 3) = .Criteria2
                    End If
                End If
            End With
        Next
    End With
End With

w.AutoFilterMode = False
w.Range("A1").AutoFilter field:=1, Criteria1:="S"

End Sub

Zum Erstellen eines AutoFilter-Objekts für ein Tabellenblatt, müssen Sie die automatische Filterung für einen Bereich in dem Tabellenblatt entweder manuell oder mit Hilfe der AutoFilter-Methode des Range-Objekts aktivieren. Das folgende Beispiel verwendet die in Variablen auf Modulebene gespeicherten Werte des vorherigen Beispiels, um die ursprüngliche automatische Filterung für das Tabellenblatt "Crew" wieder herzustellen.

Sub RestoreFilters()
Set w = Worksheets("Crew")
w.AutoFilterMode = False
For col = 1 To UBound(filterArray(), 1)
    If Not IsEmpty(filterArray(col, 1)) Then
        If filterArray(col, 2) Then
            w.Range(currentFiltRange).AutoFilter field:=col, _
                Criteria1:=filterArray(col, 1), _
                    Operator:=filterArray(col, 2), _
                Criteria2:=filterArray(col, 3)
        Else
            w.Range(currentFiltRange).AutoFilter field:=col, _
                Criteria1:=filterArray(col, 1)
        End If
    End If
Next
End Sub


Axis-Objekt

Stellt eine einzelne Achse in einem Diagramm dar. Das Axis-Objekt ist ein Element der Axes-Auflistung.

Verwenden des Axis-Objekts

Verwenden Sie Axes(Typ, Gruppe), um ein einzelnes Axis-Objekt zurückzugeben. Dabei ist Typ der Achsentyp und Gruppe die Achsengruppe. Typ kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeries oder xlValue. Gruppe kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Weitere Informationen finden Sie unter der Axes-Methode.

Im folgenden Beispiel wird der Titeltext für die Rubrikenachse im Diagrammblatt mit dem Namen Chart1 festgelegt.

With Charts("Chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Caption = "1994"
End With


Axes-Auflistungsobjekt

Eine Auflistung aller Axis-Objekte im angegebenen Diagramm.

Verwenden der Axes-Auflistung

Verwenden Sie die Axes-Methode, um die Axes-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Achsen im eingebetteten ersten Diagramm des ersten Tabellenblatts angezeigt.

With Worksheets(1).ChartObjects(1).Chart
    MsgBox .Axes.Count
End With

Verwenden Sie Axes(Typ, Gruppe), um ein einzelnes Axis-Objekt zurückzugeben. Dabei ist Typ der Achsentyp und Gruppe die Achsengruppe. Typ kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeries oder xlValue. Gruppe kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Weitere Informationen finden Sie unter der Axes-Methode.

Im folgenden Beispiel wird der Titeltext für die Rubrikenachse im Diagrammblatt mit dem Namen Chart1 festgelegt.

With Charts("chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Caption = "1994"
End With


AxisTitle-Objekt

Stellt eine Achsenbeschriftung in einem Diagramm dar.

Verwenden des AxisTitle-Objekts

Verwenden Sie die AxisTitle-Eigenschaft, um ein AxisTitle-Objekt zurückzugeben. Im folgenden Beispiel wird das erste eingebettete Diagramm aktiviert, der Text für die Beschriftung der Größenachse festgelegt, die Schriftart Bookman und der Schriftgrad 10 ausgewählt und schließlich das Wort "Millionen" kursiv formatiert.

Worksheets("sheet1").ChartObjects(1).Activate
With ActiveChart.Axes(xlValue)
    .HasTitle = True
    With .AxisTitle
        .Caption = "Revenue (millions)"
        .Font.Name = "bookman"
        .Font.Size = 10
        .Characters(10, 8).Font.Italic = True
    End With
End With

Anmerkungen

Das AxisTitle-Objekt steht nur dann zur Verfügung, wenn die HasTitle-Eigenschaft für die Achse True zurückgibt.


Border-Objekt

Stellt den Rahmen eines Objekts dar.

Verwenden des Border-Objekts

Die meisten Objekte mit Rahmen (alle, mit Ausnahme der Range- und Style-Objekte) haben einen Rahmen, der als Einheit behandelt wird, unabhängig davon, wie viele Ränder er aufweist. Der gesamte Rahmen muss als Einheit zurückgegeben werden. Verwenden Sie die Border-Eigenschaft, um das Border-Objekt für solche Objekte zurückzugeben. Im folgenden Beispiel wird ein Diagrammblatt mit dem Namen Chart1 aktiviert und die Diagrammfläche des aktiven Diagramms mit einem gestrichelten Rahmen sowie die Zeichnungsfläche mit einem punktierten Rahmen versehen.

Charts("Chart1").Activate
With ActiveChart
    .ChartArea.Border.LineStyle = xlDash
    .PlotArea.Border.LineStyle = xlDot
End With

Range- und Style-Objekte haben vier einzelne Rahmen – links, rechts, oben und unten –, die einzeln oder als Gruppe zurückgegeben werden. Verwenden Sie die Borders-Eigenschaft, um die Borders-Auflistung zurückzugeben, die alle vier Rahmen enthält. Im folgenden Beispiel erhält die Zelle A1 im ersten Tabellenblatt eine Doppellinie als Rahmen.

Worksheets(1).Range("a1").Borders.LineStyle = xlDouble

Verwenden Sie Borders(Index), um ein einzelnes Border-Objekt zurückzugeben. Dabei gibt Index den Rahmen an. Im folgenden Beispiel wird die Farbe des unteren Rahmens des Zellbereichs A1:G1 festgelegt.

Worksheets("Sheet1").Range("a1:g1"). _
    Borders(xlEdgeBottom).Color = RGB(255, 0, 0)

Index kann eine der folgenden XlBordersIndex-Konstanten sein: xlDiagonalDown, xlDiagonalUp, xlEdgeBottom, xlEdgeLeft, xlEdgeRight, xlEdgeTop, xlInsideHorizontal oder xlInsideVertical.


Borders-Auflistungsobjekt

Eine Auflistung von vier Border-Objekten, die die vier Rahmenlinien eines Range- oder Style-Objekts darstellen.

Verwenden der Borders-Auflistung

Verwenden Sie die Borders-Eigenschaft, um die Borders-Auflistung zurückzugeben, die alle vier Rahmenlinien enthält. Im folgenden Beispiel erhält die Zelle A1 im ersten Tabellenblatt eine Doppellinie als Rahmen.

Worksheets(1).Range("a1").Borders.LineStyle = xlDouble

Verwenden Sie Borders(Index), um ein einzelnes Border-Objekt zurückzugeben. Dabei gibt Index den Rahmen an. Im folgenden Beispiel wird für den unteren Rahmen des Zellbereichs A1:G1 die Farbe Rot festgelegt.

Worksheets("Sheet1").Range("a1:g1"). _
    Borders(xlEdgeBottom).Color = RGB(255, 0, 0)

Index Kann eine der folgenden XlBordersIndex-Konstanten sein: xlDiagonalDown, xlDiagonalUp, xlEdgeBottom, xlEdgeLeft, xlEdgeRight, oder xlEdgeTop, xlInsideHorizontal oder xlInsideVertical.

Anmerkungen

Sie können die Rahmeneigenschaften eines einzelnen Rahmens nur mit den Objekten Range und Style festlegen. Andere Objekte mit Rahmen, wie z. B. Kontrollkästchen oder Diagrammflächen, haben Rahmen, die als Einheit behandelt werden, unabhängig davon, wie viele Ränder sie aufweisen. Die Eigenschaften für diese Objekte müssen Sie für den gesamten Rahmen als Einheit zurückgeben und festlegen. Weitere Informationen finden Sie unter dem Border-Objekt.


 CalculatedFields-Auflistungsobjekt

CalculatedFields-Auflistungsobjekt

Eine Auflistung von PivotField-Objekten, die alle berechneten Felder des angegebenen PivotTable-Berichts darstellt. Beispielsweise könnte ein Bericht mit den Feldern "Einnahmen" und "Kosten" ein berechnetes Feld "Gewinn" besitzen, das als der Betrag des Feldes "Einnahmen" minus dem Betrag des Feldes "Kosten" definiert ist.

Anmerkungen

Bei OLAP-Datenquellen können Sie diese Auflistung nicht festlegen; es wird immer Nothing zurückgegeben.

Verwendung der CalculatedFields-Auflistung

Verwenden Sie die CalculatedFields-Methode, um die CalculatedFields-Auflistung zurückzugeben. Im folgenden Beispiel werden die berechneten Felder aus dem PivotTable-Bericht mit dem Namen "Pivot1" gelöscht.

For Each fld in _
        Worksheets(1).PivotTables("Pivot1").CalculatedFields
    fld.Delete
Next

Verwenden Sie CalculatedFields(Index), wobei Index der Name oder die Indexnummer des angegebenen Feldes ist, um ein einzelnes PivotField-Objekt aus der CalculatedFields-Auflistung zurückzugeben.


CalculatedItems-Auflistungsobjekt

Eine Auflistung von PivotItem-Objekten, die alle berechneten Elemente im angegebenen PivotTable-Bericht darstellen. Beispielsweise könnte ein PivotTable-Bericht mit den Elementen "Januar", "Februar" und "März" ein berechnetes Element "Erstes Quartal" besitzen, das als Summe der Beträge aus "Januar", "Februar" und "März" definiert ist.

Verwendung der CalculatedItems-Auflistung

Verwenden Sie die CalculatedItems-Methode, um die CalculatedItems-Auflistung zurückzugeben. Im folgenden Beispiel wird eine Liste der berechneten Elemente und ihrer Formeln im ersten PivotTable-Bericht im ersten Tabellenblatt erstellt.

Set pt = Worksheets(1).PivotTables(1)
For Each ci In pt.PivotFields("Sales").CalculatedItems
    r = r + 1
    With Worksheets(2)
        .Cells(r, 1).Value = ci.Name
        .Cells(r, 2).Value = ci.Formula
    End With
Next

Verwenden Sie CalculatedFields(index), wobei index den Namen oder die Indexnummer des Feldes angibt, um ein einzelnes PivotField-Objekt der CalculatedFields-Auflistung zurückzugeben.


CalloutFormat-Objekt

Enthält Eigenschaften und Methoden, die für Legenden mit Linien gelten.

Verwenden des CalloutFormat-Objekts

Verwenden Sie die Callout-Eigenschaft, um ein CalloutFormat-Objekt zurückzugeben. Im folgenden Beispiel werden in myDocument die folgenden Eigenschaften der dritten Form (einer Legende mit Linie) festgelegt: Die Legende besitzt eine vertikale Markierungsleiste, die den Text von der Legende trennt; der Winkel zwischen der Legendenlinie und der Seite des Legendentextfeldes beträgt 30 Grad; der Legendentext besitzt keinen Rahmen; die Legendenlinie wird am oberen Rand des Legendentextfeldes eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Callout
    .Accent = True
    .Angle = msoCalloutAngle30
    .Border = False
    .PresetDrop msoCalloutDropTop
    .Type = msoCalloutThree
End With


Characters-Objekt

Stellt Zeichen in einem Objekt dar, das Text enthält. Das Characters-Objekt ermöglicht Ihnen die Änderung einer beliebigen Zeichenfolge in dem Text.

Verwenden des Characters-Objekts

Verwenden Sie Characters(Start, Länge), um ein Characters-Objekt zurückzugeben. Dabei ist Start die Nummer des ersten Zeichens und Länge die Anzahl der Zeichen. Im folgenden Beispiel wird Text in Zelle B1 eingefügt und anschließend das zweite Wort fett formatiert.

With Worksheets("sheet1").Range("b1")
    .Value = "New Title"
    .Characters(5, 5).Font.Bold = True
End With

Anmerkungen

Die Characters-Methode ist nur dann erforderlich, wenn Sie einen Teil des in einem Objekt enthaltenen Textes ändern möchten, ohne dass sich der übrige Text ändert. (Sie können mit der Characters-Methode nur dann Text teilweise formatieren, wenn das Objekt gemischte Zelltextformate unterstützt.) Wenn Sie den gesamten Text ändern möchten, genügt es im Allgemeinen, wenn Sie die entsprechende Methode oder Eigenschaft direkt auf das Objekt anwenden. Im folgenden Beispiel wird der Inhalt von Zelle A5 kursiv formatiert.

Worksheets("sheet1").Range("a5").Font.Italic = True


Chart-Objekt

Stellt ein Diagramm in einer Arbeitsmappe dar, und zwar entweder ein eingebettetes Diagramm (enthalten in einem ChartObject) oder ein separates Diagrammblatt.

Verwenden des Chart-Objekts

In diesem Abschnitt werden die folgenden Eigenschaften und Methoden beschrieben, mit denen ein Chart-Objekt zurückgegeben wird:

  • Chart-Eigenschaft

  • Charts-Methode

  • ActiveChart-Eigenschaft

  • ActiveSheet-Eigenschaft

Chart-Eigenschaft

Verwenden Sie die Chart-Eigenschaft, um ein Chart-Objekt zurückzugeben, das das in einem ChartObject-Objekt enthaltene Diagramm darstellt. Im folgenden Beispiel wird das Muster für die Diagrammfläche des ersten eingebetteten Diagramms im Tabellenblatt mit dem Namen ""Sheet1"" festgelegt.

Worksheets("sheet1").ChartObjects(1).Chart. _
    ChartArea.Interior.Pattern = xlLightDown

Charts-Methode

Die Charts-Auflistung enthält ein Chart-Objekt für jedes Diagrammblatt einer Arbeitsmappe. Verwenden Sie Charts(Index), um ein einzelnes Chart-Objekt zurückzugeben. Dabei ist Index die Indexnummer oder der Name des Diagrammblatts. Im folgenden Beispiel wird die Farbe der ersten Datenreihe im ersten Diagrammblatt geändert.

Charts(1).SeriesCollection(1).Interior.Color = RGB(255, 0, 0)

Die Indexnummer des Diagramms stellt die Position des Diagrammblatts auf der Registerleiste der Arbeitsmappe dar. Charts(1) ist das erste Diagramm der Arbeitsmappe (von links), Charts(Charts.Count) das letzte (von rechts). Alle Diagrammblätter, einschließlich der ausgeblendeten, sind in der Durchnummerierung enthalten. Der Diagrammname wird auf dem Arbeitsmappenregister für das Diagramm angezeigt. Mit Hilfe der Name-Eigenschaft können Sie den Diagrammnamen festlegen oder zurückgeben.

Im folgenden Beispiel wird das Diagramm mit dem Namen "Verkäufe" an das Ende der aktiven Arbeitsmappe verschoben.

Charts("sales").Move after:=Sheets(Sheets.Count)

Das Chart-Objekt ist außerdem ein Element der Sheets-Auflistung. Die Sheets-Auflistung enthält alle Blätter der Arbeitsmappe (sowohl Diagrammblätter als auch Tabellenblätter). Verwenden Sie Sheets(Index), um ein einzelnes Blatt zurückzugeben. Dabei ist Index die Indexnummer oder der Name des Blatts.

ActiveChart-Eigenschaft

Wenn es sich bei dem aktiven Objekt um ein Diagramm handelt, können Sie die ActiveChart-Eigenschaft verwenden, um einen Bezug dazu herzustellen. Ein Diagrammblatt ist aktiv, wenn es vom Benutzer ausgewählt oder mit der Activate-Methode aktiviert wurde. Im folgenden Beispiel wird das erste Diagrammblatt aktiviert und anschließend Diagrammtyp und -titel festgelegt.

Charts(1).Activate
With ActiveChart
    .Type = xlLine
    .HasTitle = True
    .ChartTitle.Text = "January Sales"
End With

Ein eingebettetes Diagramm ist aktiv, wenn es vom Benutzer ausgewählt oder das darin enthaltene ChartObject-Objekt mit der Activate-Methode aktiviert wurde. Im folgenden Beispiel wird das erste eingebettete Diagramm im ersten Tabellenblatt aktiviert, und anschließend werden Diagrammtyp und -titel festgelegt. Beachten Sie, dass der Code in diesem Beispiel mit dem im vorhergehenden Beispiel identisch ist, sobald das eingebettete Diagramm aktiviert wurde. Mit der ActiveChart-Eigenschaft können Sie Visual Basic-Code schreiben, der sich entweder auf ein eingebettetes Diagramm oder auf ein Diagrammblatt beziehen kann, abhängig davon, was aktiviert wurde.

Worksheets(1).ChartObjects(1).Activate
ActiveChart.Type = xlLine
ActiveChart.HasTitle = True
ActiveChart.ChartTitle.Text = "January Sales"

ActiveSheet-Eigenschaft

Wenn es sich bei dem aktiven Blatt um ein Diagrammblatt handelt, können Sie die ActiveSheet-Eigenschaft verwenden, um einen Bezug dazu herzustellen. Im folgenden Beispiel wird mit der Activate-Methode das Diagrammblatt mit dem Namen Chart1 aktiviert und anschließend als Füllfarbe für die erste Datenreihe des Diagramms die Farbe Blau festgelegt.

Charts("Chart1").Activate
ActiveSheet.SeriesCollection(1).Interior.ColorIndex = 5


Charts-Auflistungsobjekt

Eine Auflistung aller Diagrammblätter in der angegebenen oder aktiven Arbeitsmappe. Jedes Diagrammblatt wird durch ein Chart-Objekt dargestellt. Hierzu gehören nicht die in Tabellen- oder Dialogblätter eingebetteten Diagramme. Informationen über eingebettete Diagramme finden Sie unter dem Chart- oder ChartObject-Objekt.

Verwenden der Charts-Auflistung

Verwenden Sie die Charts-Eigenschaft, um die Charts-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Diagrammblätter in der aktiven Arbeitsmappe gedruckt.

Charts.PrintOut

Verwenden Sie die Add-Methode, um ein neues Diagrammblatt zu erstellen und der Arbeitsmappe hinzuzufügen. Im folgenden Beispiel wird der aktiven Arbeitsmappe ein neues Diagrammblatt hinzugefügt und anschließend das neue Diagrammblatt hinter dem Tabellenblatt mit dem Namen Sheet1 eingefügt.

Charts.Add after:=Worksheets("sheet1")

Sie können die Add-Methode mit der ChartWizard-Methode verbinden, um ein neues Diagramm hinzuzufügen, das Daten aus einem Tabellenblatt enthält. Im folgenden Beispiel wird ein neues Liniendiagramm hinzugefügt, das auf den Daten im Zellbereich A1:A20 des Tabellenblatts mit dem Namen Sheet1 basiert.

With Charts.Add
    .ChartWizard source:=Worksheets("sheet1").Range("a1:a20"), _
        gallery:=xlLine, title:="February Data"
End With

Verwenden Sie Charts(Index), um ein einzelnes Chart-Objekt zurückzugeben. Dabei ist Index die Indexnummer oder der Name des Diagrammblatts. Im folgenden Beispiel wird für die erste Datenreihe im ersten Diagrammblatt die Farbe Rot festgelegt.

Charts(1).SeriesCollection(1).Interior.Color = RGB(255, 0, 0)

Die Sheets-Auflistung enthält alle Blätter in der Arbeitsmappe (sowohl Diagramm- als auch Tabellenblätter). Verwenden Sie Sheets(Index), um ein einzelnes Blatt zurückzugeben. Dabei ist Index der Name oder die Nummer des Blatts.


ChartArea-Objekt

Stellt die Diagrammfläche eines Diagramms dar. Die Diagrammfläche eines 2D-Diagramms besteht aus den Achsen, dem Diagrammtitel, den Achsenbeschriftungen und der Legende. Die Diagrammfläche eines 3D-Diagramms enthält den Diagrammtitel und die Legende. Sie enthält nicht die Zeichnungsfläche (die Fläche eines Diagramms, in der die Datenreihen gezeichnet werden). Informationen zur Formatierung der Zeichnungsfläche finden Sie im Abschnitt zum PlotArea-Objekt.

Verwenden des ChartArea-Objekts

Verwenden Sie die ChartArea-Eigenschaft, um das ChartArea-Objekt zurückzugeben. Im folgenden Beispiel wird das Muster für den Diagrammbereich im ersten eingebetteten Diagramm des Tabellenblatts mit dem Namen "Tabelle1" festgelegt.

Worksheets("sheet1").ChartObjects(1).Chart. _
    ChartArea.Interior.Pattern = xlLightDown


ChartColorFormat-Objekt

Wird nur bei Diagrammen verwendet. Stellt die Farbe eines einfarbigen Objekts oder die Vordergrund- bzw. Hintergrundfarbe eines Objekts mit frei beweglicher oder gemusterter Füllung dar.

Verwenden des ChartColorFormat-Objekts

Verwenden Sie eine der in der folgenden Tabelle aufgeführten Eigenschaften, um ein ChartColorFormat-Objekt zurückzugeben.

Um ein ChartColorFormat-Objekt zurückzugeben, das Folgendes darstellt: | Verwenden Sie folgende Eigenschaft | Mit folgendem Objekt
Hintergrundfüllfarbe (bei schattierter oder strukturierter Füllung ) | BackColor | ChartFillFormat
Vordergrundfüllfarbe (oder nur die Farbe einer einfarbigen Füllung) | ForeColor | ChartFillFormat


ChartFillFormat-Objekt

Wird nur bei Diagrammen verwendet. Stellt das Füllformat von Diagrammelementen dar.

Verwenden des ChartFillFormat-Objekts

Verwenden Sie die Fill-Eigenschaft, um ein ChartFillFormat-Objekt zurückzugeben. Im folgenden Beispiel werden für die Füllung des Diagrammbereichs im ersten Diagramm Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With Charts(1).ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient Style:=msoGradientHorizontal, Variant:=1
End With


ChartGroup-Objekt

Stellt eine oder mehrere Datenreihen dar, die unter Verwendung desselben Formats in ein Diagramm gezeichnet wurden. Ein Diagramm enthält eine oder mehrere Diagrammgruppen, jede Diagrammgruppe eine oder mehrere Datenreihen und jede Datenreihe einen oder mehrere Datenpunkte. Ein einzelnes Diagramm könnte z. B. eine Liniendiagrammgruppe mit allen im Liniendiagrammformat gezeichneten Datenreihen und eine Balkendiagrammgruppe mit allen im Balkendiagrammformat gezeichneten Datenreihen enthalten. Das ChartGroup-Objekt ist ein Element der ChartGroups-Auflistung.

Verwenden des ChartGroup-Objekts

Verwenden Sie ChartGroups(Index), um ein einzelnes ChartGroup-Objekt zurückzugeben. Dabei ist Index die Indexnummer der Diagrammgruppe. Im folgenden Beispiel werden der ersten Diagrammgruppe im ersten Diagrammblatt Bezugslinien hinzugefügt.

Charts(1).ChartGroups(1).HasDropLines = True

Nach der Aktivierung des Diagramms können Sie die ActiveChart-Eigenschaft verwenden.

Charts(1).Activate
ActiveChart.ChartGroups(1).HasDropLines = True

Die Indexnummer der Diagrammgruppe für ein bestimmtes Diagramm kann sich ändern, wenn das für die Gruppe verwendete Diagrammformat geändert wird. Aus diesem Grund empfiehlt es sich, für den Zugriff auf eine bestimmte Diagrammgruppe eine der benannten Shortcut-Methoden für Diagrammgruppen zu verwenden. Die PieGroups-Methode gibt die Auflistung der Kreisdiagrammgruppen in einem Diagramm, die LineGroups-Methode die Auflistung der Liniendiagrammgruppen zurück usw. Jede dieser Methoden kann mit einer Indexnummer verwendet werden, um ein einzelnes ChartGroup-Objekt zurückzugeben, oder ohne eine Indexnummer, um eine ChartGroups-Auflistung zurückzugeben. Die folgenden Diagrammgruppen-Methoden stehen zur Verfügung:

  • AreaGroups-Methode

  • BarGroups-Methode

  • ColumnGroups-Methode

  • DoughnutGroups-Methode

  • LineGroups-Methode

  • PieGroups-Methode


ChartGroups-Auflistungsobjekt

Eine Auflistung aller ChartGroup-Objekte im angegebenen Diagramm. Jedes ChartGroup-Objekt stellt eine oder mehrere Datenreihen dar, die unter Verwendung desselben Formats in ein Diagramm gezeichnet wurden. Ein Diagramm enthält eine oder mehrere Diagrammgruppen, jede Diagrammgruppe eine oder mehrere Datenreihen und jede Datenreihe einen oder mehrere Datenpunkte. Ein einzelnes Diagramm könnte z. B. eine Liniendiagrammgruppe mit allen im Liniendiagrammformat gezeichneten Datenreihen und eine Balkendiagrammgruppe mit allen im Balkendiagrammformat gezeichneten Datenreihen enthalten.

Verwenden der ChartGroups-Auflistung

Verwenden Sie die ChartGroups-Methode, um die ChartGroups-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der Diagrammgruppen im ersten eingebetteten Diagramm des ersten Tabellenblatts angezeigt.

MsgBox Worksheets(1).ChartObjects(1).Chart.ChartGroups.Count

Verwenden Sie ChartGroups(Index), um ein einzelnes ChartGroup-Objekt zurückzugeben. Dabei ist Index die Indexnummer der Diagrammgruppe. Im folgenden Beispiel werden der ersten Diagrammgruppe im ersten Diagrammblatt Bezugslinien hinzugefügt.

Charts(1).ChartGroups(1).HasDropLines = True

Nach der Aktivierung des Diagramms können Sie die ActiveChart-Eigenschaft verwenden.

Charts(1).Activate
ActiveChart.ChartGroups(1).HasDropLines = True

Die Indexnummer der Diagrammgruppe für ein bestimmtes Diagramm kann sich ändern, wenn das für die Gruppe verwendete Diagrammformat geändert wird. Aus diesem Grund empfiehlt es sich, für den Zugriff auf eine bestimmte Diagrammgruppe eine der benannten Shortcut-Methoden für Diagrammgruppen zu verwenden. Die PieGroups-Methode gibt die Auflistung der Kreisdiagrammgruppen in einem Diagramm, die LineGroups-Methode die Auflistung der Liniendiagrammgruppen zurück usw. Jede dieser Methoden kann mit einer Indexnummer verwendet werden, um ein einzelnes ChartGroup-Objekt zurückzugeben, oder ohne eine Indexnummer, um eine ChartGroups-Auflistung zurückzugeben. Die folgenden Diagrammgruppen-Methoden stehen zur Verfügung:

  • AreaGroups-Methode

  • BarGroups-Method

  • ColumnGroups-Methode

  • DoughnutGroups-Methode

  • LineGroups-Methode

  • PieGroups-Methode


ChartObject-Objekt

Stellt ein in ein Tabellenblatt eingebettetes Diagramm dar. Das ChartObject-Objekt dient als Container-Objekt für ein Chart-Objekt. Eigenschaften und Methoden für das ChartObject-Objekt bestimmen Darstellung und Größe des eingebetteten Diagramms im Tabellenblatt. Das ChartObject-Objekt ist ein Element der ChartObjects-Auflistung. Die ChartObjects-Auflistung enthält alle eingebetteten Diagramme eines einzelnen Blatts.

Verwenden des ChartObject-Objekts

Verwenden Sie ChartObjects(Index), um ein einzelnes ChartObject-Objekt zurückzugeben. Dabei ist Index die Indexnummer oder der Name des eingebetteten Diagramm. Im folgenden Beispiel wird das Muster für die Diagrammfläche des ersten eingebetteten Diagramms im Tabellenblatt mit dem Namen Sheet1 festgelegt.

Worksheets("Sheet1").ChartObjects(1).Chart. _
    ChartArea.Interior.Pattern = xlLightDown

Der Name des eingebetteten Diagramms wird im Feld "Name" angezeigt, wenn das eingebettete Diagramm markiert ist. Verwenden Sie die Name-Eigenschaft, um den Namen des ChartObject-Objekts zurückzugeben oder festzulegen. Im folgenden Beispiel werden die Ecken des eingebetteten Diagramms mit dem Namen Chart1 im Tabellenblatt mit dem Namen Sheet1 abgerundet.

Worksheets("Sheet1").ChartObjects("Chart1").RoundedCorners = True


ChartObjects-Auflistungsobjekt

Eine Auflistung aller ChartObject-Objekte im angegebenen Diagramm-, Dialog- oder Tabellenblatt. Jedes ChartObject-Objekt stellt ein eingebettetes Diagramm dar. Das ChartObject-Objekt dient als Container-Objekt für ein Chart-Objekt. Eigenschaften und Methoden für das ChartObject-Objekt bestimmen Darstellung und Größe des eingebetteten Diagramms im Blatt.

Verwenden der ChartObjects-Auflistung

Verwenden Sie die ChartObjects-Methode, um die ChartObjects-Auflistung zurückzugeben. Im folgenden Beispiel werden alle eingebetteten Diagramme im Tabellenblatt mit dem Namen Sheet1 gelöscht.

Worksheets("sheet1").ChartObjects.Delete

Verwenden Sie die Add-Methode, um ein neues, leeres eingebettetes Diagramm zu erstellen und zur Auflistung hinzuzufügen. Verwenden Sie die ChartWizard-Methode, um Daten hinzuzufügen und das neue Diagramm zu formatieren. Im folgenden Beispiel wird ein neues eingebettetes Diagramm erstellt, und anschließend werden die Daten aus dem Zellbereich A1:A20 als Liniendiagramm hinzugefügt.

Dim ch As ChartObject
Set ch = Worksheets("sheet1").ChartObjects.Add(100, 30, 400, 250)
ch.Chart.ChartWizard source:=Worksheets("sheet1").Range("a1:a20"), _
    gallery:=xlLine, title:="New Chart"

Verwenden Sie ChartObjects(Index), um ein einzelnes ChartObject-Objekt zurückzugeben. Dabei ist Index die Indexnummer oder der Name des eingebetteten Diagramms. Im folgenden Beispiel wird das Muster für die Diagrammfläche des ersten eingebetteten Diagramms im Tabellenblatt mit dem Namen Sheet1 festgelegt.

Worksheets("Sheet1").ChartObjects(1).Chart. _
    ChartArea.Interior.Pattern = xlLightDown


ChartTitle-Objekt

Stellt den Diagrammtitel dar.

Verwenden des ChartTitle-Objekts

Verwenden Sie die ChartTitle-Eigenschaft, um das ChartTitle-Objekt zurückzugeben. Im folgenden Beispiel wird dem ersten eingebetteten Diagramm im Tabellenblatt mit dem Namen "Tabelle1" ein Titel hinzugefügt.

With Worksheets("sheet1").ChartObjects(1).Chart
    .HasTitle = True
    .ChartTitle.Text = "February Sales"
End With

Anmerkungen

Das ChartTitle-Objekt steht nur dann zur Verfügung, wenn die HasTitle-Eigenschaft für das Diagramm True zurückgibt.


ColorFormat-Objekt

Stellt die Farbe eines einfarbigen Objekts, die Vordergrund- bzw. Hintergrundfarbe eines Objekts mit Farbverlaufs- bzw. Musterfüllung oder die Farbe des Zeigers dar. Sie können Farben durch Angabe eines expliziten Rot-Grün-Blau-Wertes (mit Hilfe der RGB-Eigenschaft) oder durch Auswahl einer Farbe der Farbskala (mit Hilfe der SchemeColor-Eigenschaft) festlegen.

Verwenden des ColorFormat-Objekts

Verwenden Sie eine der in der folgenden Tabelle aufgeführten Eigenschaften, um ein ColorFormat-Objekt zurückzugeben.

Verwenden Sie folgende Eigenschaft | Mit folgendem Objekt | Um ein ColorFormat-Objekt zurückzugeben, das Folgendes darstellt:
BackColor | FillFormat | Hintergrundfüllfarbe (bei schattierter oder gemusterter Füllung)
ForeColor | FillFormat | Vordergrundfüllfarbe (oder nur die Farbe einer einfarbigen Füllung)
BackColor | LineFormat | Hintergrundlinienfarbe (bei einer gemusterten Linie)
ForeColor | LineFormat | Vordergrundlinienfarbe (oder nur die Farbe einer einfarbigen Linie)
ForeColor | ShadowFormat | Schattenfarbe
ExtrusionColor | ThreeDFormat | Farbe der Seiten eines projizierten Objekts

Verwenden Sie die RGB-Eigenschaft, um für die Farbe einen expliziten Rot-Grün-Blau-Wert festzulegen. Im folgenden Beispiel wird in myDocument ein Rechteck eingefügt und anschließend für dessen Füllung Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


Comment-Objekt

Stellt einen Zellkommentar dar. Das Comment-Objekt ist ein Mitglied der Comments-Auflistung.

Verwendung des Comment-Objekts

Verwenden Sie die Comment-Eigenschaft, um ein Comment-Objekt zurückzugeben. Im folgenden Beispiel wird der Kommentartext in Zelle E5 geändert.

Worksheets(1).Range("E5").Comment.Text "reviewed on " & Date

Verwenden Sie Comments(index), wobei index die Kommentarnummer ist, um einen einzelnen Kommentar aus der Comments-Auflistung zurückzugeben. Im folgenden Beispiel wird der zweite Kommentar des ersten Tabellenblattes ausgeblendet.

Worksheets(1).Comments(2).Visible = False

Verwenden Sie die AddComment-Methode, um einem Bereich einen Kommentar hinzuzufügen. Im folgenden Beispiel wird der Zelle E5 des ersten Tabellenblattes ein Kommentar hinzugefügt.

With Worksheets(1).Range("e5").AddComment
    .Visible = False
    .Text "reviewed on " & Date
End With


Comments-Auflistungsobjekt

Eine Auflistung von Zellkommentaren. Jeder Kommentar wird durch ein Comment-Objekt dargestellt.

Verwendung der Comments-Auflistung

Verwenden Sie die Comments-Eigenschaft, um die Comments-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Kommentare des ersten Tabellenblattes ausgeblendet.

Set cmt = Worksheets(1).Comments
For Each c In cmt
    c.Visible = False
Next

Verwenden Sie die AddComment-Methode, um einem Bereich einen Kommentar hinzuzufügen. Im folgenden Beispiel wird der Zelle E5 des ersten Tabellenblattes ein Kommentar hinzugefügt.

With Worksheets(1).Range("e5").AddComment
    .Visible = False
    .Text "reviewed on " & Date
End With

Verwenden Sie Comments(index), wobei index die Kommentarnummer ist, um einen einzelnen Kommentar aus der Comments-Auflistung zurückzugeben. Im folgenden Beispiel wird der zweite Kommentar des ersten Tabellenblattes ausgeblendet.

Worksheets(1).Comments(2).Visible = False


ConnectorFormat-Objekt

Enthält Eigenschaften und Methoden, die für Verbindungen gelten. Eine Verbindung ist eine Linie, die zwei andere Formen an Punkten, den Verbindungspunkten, anfügt. Wenn Sie verbundene Formen neu anordnen, wird die Geometrie der Verbindung automatisch so angepasst, dass die Formen verbunden bleiben.

Verwenden des ConnectorFormat-Objekts

Verwenden Sie die ConnectorFormat-Eigenschaft, um ein ConnectorFormat-Objekt zurückzugeben. Mit Hilfe der BeginConnect- und der EndConnect-Methoden können Sie die Enden der Verbindung anderen Formen im Dokument zuordnen. Verwenden Sie die RerouteConnections-Methode, um automatisch den kürzesten Verbindungsweg zwischen den beiden verbundenen Formen zu finden. Mit Hilfe der Connector-Eigenschaft können Sie feststellen, ob es sich bei der Form um eine Verbindung handelt.

Beachten Sie, dass beim Hinzufügen einer Verbindung in die Shapes-Auflistung eine Größe und eine Position zugewiesen wird; beide werden jedoch automatisch angepasst, wenn Sie Anfang und Ende der Verbindung anderen Formen der Auflistung zuordnen. Deshalb sind beim Zuordnen einer Verbindung an andere Dokumente die für Größe und Position festgelegten Anfangswerte ohne Bedeutung. Ebenso geben Sie beim Zuordnen einer Verbindung den Verbindungspunkt auf einer Form an, an dem die Verbindung angefügt wird. Wenn Sie jedoch nach dem Anfügen der Verbindung die RerouteConnections-Methode verwenden, können sich die Verbindungspunkte ändern, und Ihre ursprünglich angegebenen Werte für die Verbindungspunkte bleiben ohne Bedeutung.

Im folgenden Beispiel werden in myDocument zwei Rechtecke eingefügt und durch eine gekrümmte Verbindung verbunden.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Setc c = s.AddConnector(msoConnectorCurve, 0, 0, 0, 0)
With c.ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
    c.RerouteConnections
End With

Anmerkungen

Verbindungspunkte werden allgemein nach den in der folgenden Tabelle aufgeführten Regeln nummeriert.

Formart | Nummerierungsart der Verbindungspunkte
AutoFormen, WordArt, Bilder und OLE-Objekte | Die Verbindungspunkte werden von oben gegen den Uhrzeigersinn nummeriert.
Freihandobjekte | Die Verbindungspunkte sind die Scheitelpunkte und entsprechen den Scheitelpunktnummern.

Um in einer komplexen Form herauszufinden, welche Nummer welchem Verbindungspunkt entspricht, können Sie mit der Form bei eingeschaltetem Makro-Recorder experimentieren und anschließend den aufgezeichneten Code untersuchen. Sie können auch eine Form erstellen, sie markieren und das folgende Beispiel ausführen. Der Code nummeriert jeden Verbindungsort und ordnet ihm eine Verbindung zu.

Set mainshape = ActiveWindow.Selection.ShapeRange(1)
With mainshape
    bx = .Left + .Width + 50
    by = .Top + .Height + 50
End With
With ActiveSheet
    For j = 1 To mainshape.ConnectionSiteCount
        With .Shapes.AddConnector(msoConnectorStraight, _
                bx, by, bx + 50, by + 50)
            .ConnectorFormat.EndConnect mainshape, j
            .ConnectorFormat.Type = msoConnectorElbow
            .Line.ForeColor.RGB = RGB(255, 0, 0)
            l = .Left
            t = .Top
        End With
        With .Shapes.AddTextbox(msoTextOrientationHorizontal, _
                l, t, 36, 14)
            .Fill.Visible = False
            .Line.Visible = False
            .TextFrame.Characters.Text = j
        End With
    Next j
End With


 ControlFormat-Objekt

ControlFormat-Objekt

Enthält Eigenschaften von Microsoft Excel-Steuerelementen.

Verwendung des ControlFormat-Objekts

Verwenden Sie die ControlFormat-Eigenschaft, um ein ControlFormat-Objekt zurückzugeben. Im folgenden Beispiel wird der Füllbereich einer Schaltfläche für ein Listenfeld im ersten Tabellenblatt festgelegt.

Worksheets(1).Shapes(1).ControlFormat.ListFillRange = "A1:A10"

Falls es sich bei der Form nicht um ein Steuerelement handelt, schlägt die ControlFormat-Eigenschaft fehl; ist das Steuerelement kein Listenfeld, so schlägt die ListFillRange-Eigenschaft fehl.


Corners-Objekt

Stellt die Ecken eines 3D-Diagramms dar. Dieses Objekt ist keine Auflistung.

Verwendung des Corners-Objekts

Verwenden Sie die Corners-Eigenschaft, um das Corners-Objekt zurückzugeben. Im folgenden Beispiel werden die Ecken des ersten Diagramms markiert.

Charts(1).Corners.Select

Ist das Diagramm kein 3D-Diagramm, schlägt die Corners-Eigenschaft fehl.


 CubeField-Objekt

CubeField-Objekt

Stellt ein Hierarchie- oder Measurefeld eines OLAP-Cubes dar. In einem PivotTable-Bericht ist das CubeField-Objekt Mitglied der CubeFields-Auflistung.

Verwenden des CubeField-Objekts

Verwenden Sie die CubeField-Eigenschaft, um das CubeField-Objekt zurückzugeben. In diesem Beispiel wird eine Liste der Cube-Feldnamen für alle Hierarchiefelder im ersten OLAP-basierten PivotTable-Bericht in Sheet1 erstellt.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objPF in _
    Worksheets("Sheet1").PivotTables(1).PivotFields
    If objPF.CubeField.CubeFieldType = xlHierarchy Then
        objNewSheet.Cells(intRow, 1).Value = objPF.Name
        intRow = intRow + 1
    End If
Next objPF

Verwenden Sie CubeFields(Index), wobei Index die Indexnummer des Cube-Feldes ist, um ein einzelnes CubeField-Objekt zurückzugeben. Im folgenden Beispiel wird der Name des zweiten Cube-Feldes im ersten PivotTable-Bericht im aktiven Tabellenblatt bestimmt.

strAlphaName = _
    ActiveSheet.PivotTables(1).CubeFields(2).Name


 CubeFields-Auflistungsobjekt

CubeFields-Auflistungsobjekt

Eine Auflistung aller CubeField-Objekte in einem PivotTable-Bericht, der auf einem OLAP-Cube basiert. Jedes CubeField-Objekt stellt ein Hierarchie- oder Measurefeld des Cubes dar.

Verwenden der CubeFields-Auflistung

Verwenden Sie die CubeFields-Eigenschaft, um die CubeFields-Auflistung zurückzugeben. In dem folgenden Beispiel wird eine Liste der Cube-Feldnamen der Datenfelder in dem ersten OLAP-basierten PivotTable-Bericht in Sheet1 erstellt.

Set objNewSheet = Worksheets.Add
intRow = 1
For Each objCubeFld In _
    Worksheets("Sheet1").PivotTables(1).CubeFields
    If objCubeFld.Orientation = xlDataField Then
        objNewSheet.Cells(intRow, 1).Value = objCubeFld.Name
        intRow = intRow + 1
    End If
Next objCubeFld

Verwenden Sie CubeFields(Index), wobei Index die Indexnummer des Cube-Feldes ist, um ein einzelnes CubeField-Objekt zurückzugeben. Im folgenden Beispiel wird der Name des zweiten Cube-Feldes im ersten PivotTable-Bericht im aktiven Tabellenblatt bestimmt.

strAlphaName = _
    ActiveSheet.PivotTables(1).CubeFields(2).Name


CustomView-Objekt

Stellt eine benutzerdefinierte Arbeitsmappenansicht dar. Das CustomView-Objekt ist ein Mitglied der CustomViews-Auflistung.

Verwendung des CustomView-Objekts

Verwenden Sie CustomViews(index), wobei index der Name oder die Indexnummer der benutzerdefinierten Ansicht ist, um ein CustomView-Objekt zurückzugeben. Im folgenden Beispiel wird die benutzerdefinierte Ansicht "Aktueller Bestand" dargestellt.

ThisWorkbook.CustomViews("Current Inventory").Show


CustomViews-Auflistungsobjekt

Eine Auflistung benutzerdefinierter Arbeitsmappenansichten. Jede Ansicht wird durch ein CustomView-Objekt dargestellt.

Verwendung der CustomViews-Auflistung

Verwenden Sie die CustomViews-Eigenschaft, um die CustomViews-Auflistung zurückzugeben. Verwenden Sie die Add-Methode, um eine neue benutzerdefinierte Ansicht zu erstellen und sie der CustomViews-Auflistung hinzuzufügen. Im folgenden Beispiel wird die neue benutzerdefinierte Ansicht "Zusammenfassung" erstellt.

ActiveWorkbook.CustomViews.Add "Summary", True, True


DataLabel-Objekt

Stellt die Datenbeschriftung eines Datenpunktes oder einer Trendlinie dar. In einer Datenreihe ist das DataLabel-Objekt ein Element der DataLabels-Auflistung. Die DataLabels-Auflistung enthält ein DataLabel-Objekt für jeden Datenpunkt. In einer Datenreihe ohne definierbare Punkte (z. B. einer Flächenreihe) enthält die DataLabels-Auflistung ein einzelnes DataLabel-Objekt.

Verwenden des DataLabel-Objekts

Verwenden Sie DataLabels(Index), um ein einzelnes DataLabel-Objekt zurückzugeben. Dabei ist Index die Indexnummer der Datenbeschriftung. Im folgenden Beispiel wird das Zahlenformat für die fünfte Datenbeschriftung der ersten Reihe im ersten eingebetteten Diagramm des ersten Tabellenblatts festgelegt.

Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).DataLabels(5).NumberFormat = "0.000"

Verwenden Sie die DataLabel-Eigenschaft, und das DataLabel-Objekt für einen einzelnen Punkt zurückzugeben. Im folgenden Beispiel wird die Datenbeschriftung für den zweiten Punkt der ersten Reihe im Diagrammblatt mit dem Namen "Diagramm1" aktiviert und als Datenbeschriftungstext "Samstag" festgelegt.

With Charts("chart1")
    With .SeriesCollection(1).Points(2)
        .HasDataLabel = True
        .DataLabel.Text = "Saturday"
    End With
End With

Auf einer Trendlinie gibt die DataLabel-Eigenschaft den für die Trendlinie angezeigten Text zurück. Dabei kann es sich um die Gleichung, das Bestimmtheitsmaß oder beides (wenn beides angezeigt wird) handeln. Im folgenden Beispiel wird der Trendlinientext so festgelegt, dass nur die Gleichung angezeigt wird, und anschließend wird der Datenbeschriftungstext in Zelle A1 des Tabellenblatts mit dem Namen "Tabelle1" eingefügt.

With Charts("chart1").SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = False
    .DisplayEquation = True
    Worksheets("sheet1").Range("a1").Value = .DataLabel.Text
End With


DataLabels-Auflistungsobjekt

Eine Auflistung aller DataLabel-Objekte für die angegebene Datenreihe. Jedes DataLabel-Objekt stellt eine Datenbeschriftung für einen Punkt oder eine Trendlinie dar. In einer Datenreihe ohne definierbare Punkte (z. B. einer Flächenreihe) enthält die DataLabels-Auflistung eine einzelne Datenbeschriftung.

Verwenden der Datalabels-Auflistung

Verwenden Sie die DataLabels-Methode, um die DataLabels-Auflistung zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die Datenbeschriftungen der ersten Datenreihe im ersten Diagrammblatt festgelegt.

With Charts(1).SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.NumberFormat = "##.##"
End With

Verwenden Sie DataLabels(Index), um ein einzelnes DataLabel-Objekt zurückzugeben. Dabei ist Index die Indexnummer der Datenbeschriftung. Im folgenden Beispiel wird das Zahlenformat für die fünfte Datenbeschriftung der ersten Reihe im ersten eingebetteten Diagramm des ersten Tabellenblatts festgelegt.

Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).DataLabels(5).NumberFormat = "0.000"


DataTable-Objekt

Stellt eine Diagrammdatentabelle dar.

Verwendung des DataTable-Objekts

Verwenden Sie die DataTable-Eigenschaft, um ein DataTable-Objekt zurückzugeben. Im folgenden Beispiel wird dem ersten eingebetteten Diagramm eine Datentabelle mit Außenrahmen hinzugefügt.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    .DataTable.HasBorderOutline = True
End With


DefaultWebOptions-Objekt

Enthält Attribute auf Anwendungsebene, die von Microsoft Excel verwendet werden, wenn Sie ein Dokument als Webseite speichern oder eine Webseite öffnen. Sie können Attribute auf der Anwendungsebene (global) oder der Arbeitsmappenebene zurückgeben oder festlegen. (Beachten Sie, dass Attributwerte sich von einer Arbeitsmappe zur anderen unterscheiden können; dies hängt von dem Attributwert zum Zeitpunkt des Speicherns der Arbeitsmappe ab.) Attributeinstellungen auf Arbeitsmappenebene überschreiben die Attributeinstellungen auf Anwendungsebene. Die Attribute aus Arbeitsmappenebene befinden sich im WebOptions-Objekt.

Verwenden des DefaultWebOptions-Objekts

Verwenden Sie die DefaultWebOptions-Eigenschaft, um das DefaultWebOptions-Objekt zurückzugeben. In dem folgenden Beispiel wird überprüft, ob PNG (Portable Network Graphics) als Bildformat zulässig ist; anschließend wird die Variable strImageFileType entsprechend eingestellt.

Set objAppWebOptions = Application.DefaultWebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        strImageFileType = "PNG"
    Else
        strImageFileType = "JPG"
    End If
End With


Dialog-Objekt

Stellt ein integriertes Microsoft Excel-Dialogfeld dar. Das Dialog-Objekt ist ein Element der Dialogs-Auflistung. Die Dialogs-Auflistung enthält alle integrierten Dialogfelder von Microsoft Excel. Sie können kein neues integriertes Dialogfeld erstellen oder zur Auflistung hinzufügen. Sie können ein Dialog-Objekt lediglich zusammen mit der Show-Methode verwenden, um das entsprechende Dialogfeld anzuzeigen.

Verwenden des Dialog-Objekts

Verwenden Sie Dialogs(Index), die das Dialogfeld kennzeichnet, um ein einzelnes Dialog-Objekt zurückzugeben. Dabei ist Index eine integrierte Konstante. Im folgenden Beispiel wird das integrierte Dialogfeld Öffnen (Menü Datei) angezeigt. Die Show-Methode gibt True zurück, wenn Microsoft Excel eine Datei öffnen kann, oder False, wenn der Benutzer das Dialogfeld schließt.

dlgAnswer = Application.Dialogs(xlDialogOpen).Show

Die Objektbibliothek von Microsoft Excel Visual Basic enthält integrierte Konstanten für eine Vielzahl von integrierten Dialogfeldern. Alle Konstanten werden aus dem Präfix "xlDialog" und dem englischen Namen des Dialogfeldes gebildet. Die Konstante für das Dialogfeld Namen übernehmen lautet beispielsweise xlDialogApplyNames, und die Konstante für das Dialogfeld Datei suchen lautet xlDialogFindFile. Diese Konstanten sind Elemente des Aufzählungstyps XlBuiltinDialog. Weitere Informationen über die verfügbaren Konstanten finden Sie unter Liste der integrierten Dialogfeldargumente.


Dialogs-Auflistungsobjekt

Eine Auflistung aller Dialog-Objekte in Microsoft Excel. Jedes Dialog-Objekt stellt ein integriertes Dialogfeld dar. Sie können kein neues integriertes Dialogfeld erstellen oder zur Auflistung hinzufügen. Sie können ein Dialog-Objekt lediglich zusammen mit der Show-Methode verwenden, um das entsprechende Dialogfeld anzuzeigen.

Verwenden der Dialogs-Auflistung

Verwenden Sie die Dialogs-Eigenschaft, um die Dialogs-Auflistung zurückzugeben. Im folgenden Beispiel wird die Anzahl der verfügbaren integrierten Microsoft Excel-Dialogfelder angezeigt.

MsgBox Application.Dialogs.Count

Verwenden Sie Dialogs(Index), die das Dialogfeld kennzeichnet, um ein einzelnes Dialog-Objekt zurückzugeben. Dabei ist Index eine integrierte Konstante. Im folgenden Beispiel wird das integrierte Dialogfeld Öffnen angezeigt.

dlgAnswer = Application.Dialogs(xlDialogOpen).Show

Die Objektbibliothek von Microsoft Excel Visual Basic enthält integrierte Konstanten für eine Vielzahl von integrierten Dialogfeldern. Alle Konstanten werden aus dem Präfix "xlDialog" und dem englischen Namen des Dialogfeldes gebildet. Die Konstante für das Dialogfeld Namen übernehmen lautet beispielsweise xlDialogApplyNames, und die Konstante für das Dialogfeld Datei suchen lautet xlDialogFindFile. Diese Konstanten sind Elemente des Aufzählungstyps XlBuiltinDialog. Weitere Informationen über die verfügbaren Konstanten finden Sie unter Liste der integrierten Dialogfeldargumente.


DisplayUnitLabel-Objekt

Stellt eine Einheitenbeschriftung auf einer Achse in dem angegebenen Diagramm dar. Einheitenbeschriftungen sind nützlich zum Anzeigen von großen Werten, z. B. in Millionen oder Milliarden. Sie können die Lesbarkeit des Diagramms steigern, indem Sie eine einzelne Einheitenbeschriftung an Stelle von großen Zahlen an jedem Teilstrich verwenden.

Verwenden des DisplayUnitLabel-Objekts

Verwenden Sie die DisplayUnitLabel-Eigenschaft, um das DisplayUnitLabel-Objekt zurückzugeben. In dem folgenden Beispiel wird die angezeigte Beschriftung auf der Größenachse in Chart1 als "Millions" festgelegt und dann die automatische Schriftskalierung deaktiviert.

With Charts("Chart1").Axes(xlValue).DisplayUnitLabel
    .Caption = "Millions"
    .AutoScaleFont = False
End With


DownBars-Objekt

Stellt die negativen Abweichungsbalken in einer Diagrammgruppe dar. Negative Abweichungsbalken verbinden Punkte der ersten Datenreihe mit niedrigeren Werten der letzten Datenreihe in einer Diagrammgruppe (die Linien verlaufen von den Punkten der ersten Reihe aus nach unten). Nur Diagrammgruppen mit 2D-Linien, die mindestens zwei Datenreihen aufweisen, können über negative Abweichungsbalken verfügen. Dieses Objekt ist keine Auflistung. Es gibt kein einzelnes DownBar-Objekt; die positiven und negativen Abweichungsbalken müssen für alle Punkte in einer Diagrammgruppe gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des DownBars-Objekts

Verwenden Sie die DownBars-Eigenschaft, um das DownBars-Objekt zurückzugeben. Im folgenden Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe des ersten eingebetteten Diagramms im Tabellenblatt mit dem Namen "Tabelle5" aktiviert. Anschließend wird in diesem Beispiel für positive Abweichungsbalken die Farbe Blau und für negative Abweichungsbalken die Farbe Rot gewählt.

With Worksheets("sheet5").ChartObjects(1).Chart.ChartGroups(1)
    .HasUpDownBars = True
    .UpBars.Interior.Color = RGB(0, 0, 255)
    .DownBars.Interior.Color = RGB(255, 0, 0)
End With

Anmerkungen

Wenn die HasUpDownBars-Eigenschaft False ist, sind die meisten Eigenschaften des DownBars-Objekts deaktiviert.


DropLines-Objekt

Stellt die Bezugslinien in einer Diagrammgruppe dar. Bezugslinien verbinden die Diagrammpunkte mit der X-Achse. Nur Linien- und Flächendiagrammgruppen können Bezugslinien aufweisen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Bezugslinie darstellt. Die Bezugslinien müssen für alle Punkte in einer Diagrammgruppe gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des DropLines-Objekts

Verwenden Sie die DropLines-Eigenschaft, um das DropLines-Objekt zurückzugeben. Im folgenden Beispiel werden die Bezugslinien für die erste Diagrammgruppe im ersten eingebetteten Diagramm aktiviert, und anschließend wird für die Bezugslinien die Farbe Rot festgelegt.

Worksheets("sheet1").ChartObjects(1).Activate
ActiveChart.ChartGroups(1).HasDropLines = True
ActiveChart.ChartGroups(1).DropLines.Border.ColorIndex = 3

Anmerkungen

Wenn die HasDropLines-Eigenschaft False ist, sind die meisten Eigenschaften des DropLines-Objekts deaktiviert.


ErrorBars-Objekt

Stellt die Fehlerindikatoren in einer Diagrammdatenreihe dar. Anhand der Fehlerindikatoren lassen sich Ungenauigkeiten der Diagrammdaten ablesen. Lediglich Datenreihen in Flächen-, Balken-, Säulen-, Linien- und Punkt-Diagrammgruppen in 2D-Diagrammen können Fehlerindikatoren aufweisen. Nur Datenreihen in Punkt-Diagrammgruppen können X- und Y-Fehlerindikatoren haben. Das Objekt ist keine Auflistung. Es gibt kein Objekt, das einen einzelnen Fehlerindikator darstellt; die X- und Y-Fehlerindikatoren müssen für alle Punkte einer Datenreihe gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des ErrorBars-Objekts

Verwenden Sie die ErrorBars-Eigenschaft, um das ErrorBars-Objekt zurückzugeben. Im folgenden Beispiel werden die Fehlerindikatoren für Datenreihe 1 im eingebetteten Diagramm1 aktiviert, und anschließend wird das Endformat der Fehlerindikatoren festgelegt.

Worksheets("sheet1").ChartObjects(1).Activate
ActiveChart.SeriesCollection(1).HasErrorBars = True
ActiveChart.SeriesCollection(1).ErrorBars.EndStyle = xlNoCap

Anmerkungen

Mit der ErrorBar-Methode werden Format und Typ der Fehlerindikatoren geändert.


FillFormat-Objekt

Stellt das Füllformat einer Form dar. Die Füllung einer Form kann einfarbig, fließend, strukturiert, ein Bild oder halbtransparent sein.

Verwenden des FillFormat-Objekts

Verwenden Sie die Fill-Eigenschaft, um ein FillFormat-Objekt zurückzugeben. Im folgenden Beispiel wird in myDocument ein Rechteck eingefügt, und danach werden Farbe und Farbverlauf seiner Füllung festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 80).Fill
    .ForeColor.RGB = RGB(0, 128, 128)
    .OneColorGradient msoGradientHorizontal, 1, 1
End With

Anmerkungen

Viele Eigenschaften des FillFormat-Objekts sind schreibgeschützt. Um eine dieser Eigenschaften festzulegen, müssen Sie die entsprechende Methode anwenden.


Filter-Objekt

Stellt einen Filter für eine einzelne Spalte dar. Das Filter-Objekt ist ein Element der Filters-Auflistung. Die Filters-Auflistung enthält alle Filter in einem automatisch gefilterten Bereich.

Verwenden des Filter-Objekts

Verwenden Sie Filters(Index), wobei Index den Namen oder die Indexnummer des Filters angibt, um ein einzelnes Filter-Objekt zurückzugeben. Das folgende Beispiel legt eine Variable auf den Wert der On-Eigenschaft des Filters für die erste Spalte im gefilterten Bereich im Tabellenblatt "Crew" fest.

Set w = Worksheets("Crew")
If w.AutoFilterMode Then
    filterIsOn = w.AutoFilter.Filters(1).On
End If

Beachten Sie, dass alle Eigenschaften des Filter-Objekts schreibgeschützt sind. Zum Festlegen dieser Eigenschaften wenden Sie die automatische Filterung manuell an, oder verwenden Sie die AutoFilter-Methode des Range-Objekts, wie im folgenden Beispiel gezeigt.

Set w = Worksheets("Crew")
w.Cells.AutoFilter field:=2, Criteria1:="Crucial", _
    Operator:=xlOr, Criteria2:="Important"


Filters-Auflistungsobjekt

Eine Auflistung aller Filter-Objekte, die alle Filter in einem automatisch gefilterten Bereich darstellt.

Verwenden der Filters-Auflistung

Verwenden Sie die Filters-Methode, um die Filters-Auflistung zurückzugeben. Das folgende Beispiel erstellt eine Liste, die die Kriterien und die Operatoren für die Filter im automatisch gefilterten Bereich im Tabellenblatt "Crew" enthält.

Dim f As Filter
Dim w As Worksheet
Const ns As String = "Not set"

Set w = Worksheets("Crew")
Set w2 = Worksheets("FilterData")
rw = 1
For Each f In w.AutoFilter.Filters
    If f.On Then
        c1 = Right(f.Criteria1, Len(f.Criteria1) - 1)
        If f.Operator Then
            op = f.Operator
            c2 = Right(f.Criteria2, Len(f.Criteria2) - 1)
        Else
            op = ns
            c2 = ns
        End If
    Else
        c1 = ns
        op = ns
        c2 = ns
    End If
    w2.Cells(rw, 1) = c1
    w2.Cells(rw, 2) = op
    w2.Cells(rw, 3) = c2
    rw = rw + 1
Next

Verwenden Sie Filters(Index), wobei Index den Namen oder die Indexnummer des Filters angibt, um ein einzelnes Filter-Objekt zurückzugeben. Das folgende Beispiel legt eine Variable auf den Wert der On-Eigenschaft des Filters für die erste Spalte im gefilterten Bereich im Tabellenblatt "Crew" fest.

Set w = Worksheets("Crew")
If w.AutoFilterMode Then
    filterIsOn = w.AutoFilter.Filters(1).On
End If


Floor-Objekt

Stellt die Bodenfläche eines 3D-Diagramms dar.

Verwenden des Floor-Objekts

Verwenden Sie die Floor-Eigenschaft, um das Floor-Objekt zurückzugeben. Im folgenden Beispiel wird die Farbe für die Bodenfläche des ersten eingebetteten Diagramms festgelegt. Das Beispiel kann nicht nachvollzogen werden, wenn kein 3D-Diagramm gewählt ist.

Worksheets("sheet1").ChartObjects(1).Activate
ActiveChart.Floor.Interior.Color = RGB(0, 255, 255)


Font-Objekt

Enthält Schriftartattribute (Schriftartbezeichnung, Schriftgröße, Farbe usw.) für ein Objekt.

Verwenden des Font-Objekts

Verwenden Sie die Font-Eigenschaft, um das Font-Objekt zurückzugeben. Im folgenden Beispiel wird der Zellbereich A1:C5 fett formatiert.

Worksheets("sheet1").Range("a1:c5").Font.Bold = True

Wenn Sie nicht den gesamten in einer Zelle oder einem Grafikobjekt enthaltenen Text einheitlich formatieren möchten, verwenden Sie die Characters-Methode, um einen Teil des Textes zurückzugeben.


FormatCondition-Objekt

Stellt ein bedingtes Format dar. Das FormatCondition-Objekt ist ein Mitglied der FormatConditions-Auflistung. Die FormatConditions-Auflistung kann für einen gegebenen Bereich bis zu drei bedingte Formate enthalten.

Verwendung des FormatCondition-Objekts

Verwenden Sie FormatConditions(index), wobei index die Indexnummer des bedingten Formats ist, um ein FormatCondition-Objekt zurückzugeben. Im folgenden Beispiel werden die Formateigenschaften für ein bestehendes bedingtes Format der Zellen E1:E10 festgelegt.

With Worksheets(1).Range("e1:e10").FormatConditions(1)
    With .Borders
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = 6
    End With
    With .Font
        .Bold = True
        .ColorIndex = 3
    End With
End With

Anmerkungen

Verwenden Sie die Add-Methode, um ein neues bedingtes Format zu erstellen. Wenn Sie versuchen, mehr als drei bedingte Formate für einen einzigen Bereich zu erstellen, schlägt die Add-Methode fehl. Besitzt ein Bereich drei Formate, können Sie mit der Modify-Methode eines der Formate ändern, oder mit der Delete-Methode ein Format löschen und anschließend mit der Add-Methode ein neues erstellen.

Verwenden Sie die Eigenschaften Font, Border und Interior des FormatCondition-Objekts, um das Aussehen der formatierten Zellen zu steuern. Einige Eigenschaften dieser Objekte werden durch das Objektmodell des bedingten Formats nicht unterstützt. Die Eigenschaften, die mit der bedingten Formatierung verwendet werden können, sind in der folgenden Tabelle aufgeführt.

Objekt Eigenschaften
Font Bold

Color

ColorIndex

FontStyle

Italic

Strikethrough

Underline

Die Unterstreichungsarten "Buchhaltung" können nicht verwendet werden.
Border Bottom

Color

Left

Right

Style

Folgende Rahmenarten können verwendet werden (alle anderen werden nicht unterstützt): xlNone, xlSolid, xlDash, xlDot, xlDashDot, xlDashDotDot, xlGray50, xlGray75 und xlGray25.

Top

Weight

Folgende Rahmenstärken können verwendet werden (alle anderen werden nicht unterstützt): xlWeightHairline und xlWeightThin.
Interior Color

ColorIndex

Pattern

PatternColorIndex


FormatConditions-Auflistungsobjekt

Stellt die Auflistung der bedingten Formate in einem einzigen Bereich dar. Die FormatConditions-Auflistung kann bis zu drei bedingte Formate enthalten. Jedes Format wird durch ein FormatCondition-Objekt dargestellt.

Verwendung der FormatConditions-Auflistung

Verwenden Sie die FormatConditions-Eigenschaft, um ein FormatConditions-Objekt zurückzugeben. Verwenden Sie die Add-Methode, um ein neues bedingtes Format zu erstellen. Mit der Modify-Methode können Sie ein bestehendes bedingtes Format ändern.

Im folgenden Beispiel wird den Zellen E1:E10 ein bedingtes Format hinzugefügt.

With Worksheets(1).Range("e1:e10").FormatConditions _
        .Add(xlCellValue, xlGreater, "=$a$1")
    With .Borders
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = 6
    End With
    With .Font
        .Bold = True
        .ColorIndex = 3
    End With
End With

Anmerkungen

Wenn Sie versuchen, mehr als drei bedingte Formate für einen Bereich zu erstellen, schlägt die Add-Methode fehl. Besitzt ein Bereich drei bedingte Formate, können Sie mit der Modify-Methode eines der Formate ändern, oder mit der Delete-Methode ein Format löschen und anschließend mit der Add-Methode ein neues erstellen.

Weitere Informationen über bedingte Formate finden Sie unter dem FormatCondition-Objekt.


FreeformBuilder-Objekt

Stellt die Geometrie eines Freihandobjekts während seiner Erstellung dar.

Verwenden des FreeformBuilder-Objekts

Verwenden Sie die BuildFreeform-Methode, um ein FreeformBuilder-Objekt zurückzugeben. Mit Hilfe der AddNodes-Methode können Sie dem Freihandobjekt Knoten hinzufügen. Verwenden Sie die ConvertToShape-Methode, um die im FreeformBuilder-Objekt definierte Form zu erstellen und sie der Shapes-Auflistung hinzuzufügen. Im folgenden Beispiel wird in myDocument ein Freihandobjekt mit vier Abschnitten eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.BuildFreeform(msoEditingCorner, 360, 200)
    .AddNodes msoSegmentCurve, msoEditingCorner, _
        380, 230, 400, 250, 450, 300
    .AddNodes msoSegmentCurve, msoEditingAuto, 480, 200
    .AddNodes msoSegmentLine, msoEditingAuto, 480, 400
    .AddNodes msoSegmentLine, msoEditingAuto, 360, 200
    .ConvertToShape
End With


Gridlines-Objekt

Stellt Hauptgitternetzlinien oder Hilfsgitternetzlinien auf einer Diagrammachse dar. Gitternetzlinien erweitern die Teilstriche auf einer Diagrammachse, so dass leichter zu erkennen ist, welche Werte den Datenpunkten zugeordnet sind. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Gitternetzlinie darstellt; alle Gitternetzlinien für eine Achse müssen gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des Gridlines-Objekts

Verwenden Sie die MajorGridlines-Eigenschaft, um das GridLines-Objekt zurückzugeben, das die Hauptgitternetzlinien der Achse darstellt. Verwenden Sie die MinorGridlines-Eigenschaft, um das GridLines-Objekt zurückzugeben, das die Hilfsgitternetzlinien darstellt. Haupt- und Hilfsgitternetzlinien können gleichzeitig zurückgegeben werden.

Im folgenden Beispiel werden die Hauptgitternetzlinien für die Rubrikenachse im Diagrammblatt mit dem Namen "Diagramm1" aktiviert und anschließend die Gitternetzlinien als blaue, gestrichelte Linien formatiert.

With Charts("chart1").Axes(xlCategory)
    .HasMajorGridlines = True
    .MajorGridlines.Border.Color = RGB(0, 0, 255)
    .MajorGridlines.Border.LineStyle = xlDash
End With


GroupShapes-Auflistungsobjekt

Stellt die einzelnen Formen innerhalb einer gruppierten Form dar. Jede Form wird durch ein Shape-Objekt dargestellt. Wenn Sie die Item-Methode mit diesem Objekt verwenden, können Sie mit einzelnen Formen innerhalb einer Gruppe arbeiten, ohne die Gruppe aufheben zu müssen.

Verwenden der GroupShapes-Auflistung

Verwenden Sie die GroupItems-Eigenschaft, um die GroupShapes-Auflistung zurückzugeben. Verwenden Sie GroupItems(Index), wobei Index die Nummer der einzelnen Form innerhalb der Gruppe ist, um eine einzelne Form der GroupShapes-Auflistung zurückzugeben. Im folgenden Beispiel werden drei Dreiecke in myDocument eingefügt, zu einer Gruppe zusammengefasst, der eine Farbe zugewiesen wird, und anschließend nur die Farbe des zweiten Dreiecks geändert.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, _
        10, 10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, _
        150, 10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, _
        300, 10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


HiLoLines-Objekt

Stellt die Spannweitenlinien in einer Diagrammgruppe dar. Spannweitenlinien verbinden den jeweils höchsten und niedrigsten Punkt der einzelnen Kategorien in einer Diagrammgruppe. Nur 2D-Diagrammgruppen können Spannweitenlinien aufweisen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Spannweitenlinie darstellt; die Spannweitenlinien müssen für alle Punkte in einer Diagrammgruppe gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des HiLoLines-Objekts

Verwenden Sie die HiLoLines-Eigenschaft, um das HiLoLines-Objekt zurückzugeben. Im folgenden Beispiel wird mit der AutoFormat-Methode ein Diagramm mit dem Höchst-, Tiefst- und Schlusskurs von Aktien im ersten eingebetteten Diagramm erstellt (das Diagramm muss drei Datenreihen enthalten). Im Beispiel werden anschließend die Spannweitenlinien blau formatiert.

Worksheets(1).ChartObjects(1).Activate
ActiveChart.AutoFormat gallery:=xlLine, format:=8
ActiveChart.ChartGroups(1).HiLoLines.Border.Color = RGB(0, 0, 255)

Anmerkungen

Wenn die HasHiLoLines-Eigenschaft False ist, sind die meisten Eigenschaften des HiLoLines-Objekts deaktiviert.


HPageBreak-Objekt

Stellt einen horizontalen Seitenwechsel dar. Das HPageBreak-Objekt ist ein Mitglied der HPageBreaks-Auflistung.

Verwendung des HPageBreak-Objekts

Verwenden Sie HPageBreaks(index), wobei index die Indexnummer des Seitenwechsels ist, um ein HPageBreak-Objekt zurückzugeben. Im folgenden Beispiel wird die Position des ersten horizontalen Seitenwechsels geändert.

Worksheets(1).HPageBreaks(1).Location = Worksheets(1).Range("e5")


HPageBreaks-Auflistungsobjekt

Die Auflistung der horizontalen Seitenwechsel im Druckbereich. Jeder horizontale Seitenwechsel wird durch ein HPageBreak-Objekt dargestellt.

Verwendung der HPageBreaks-Auflistung

Verwenden Sie die HPageBreaks-Eigenschaft, um die HPageBreaks-Auflistung zurückzugeben. Verwenden Sie die Add-Methode, um einen horizontalen Seitenwechsel hinzuzufügen. Im folgenden Beispiel wird über der aktiven Zelle ein horizontaler Seitenwechsel eingefügt.

ActiveSheet.HPageBreaks.Add Before:=ActiveCell

Beim Hinzufügen eines Seitenwechsels, der den Druckbereich nicht überschneidet, wird das neu hinzugefügte HPageBreak-Objekt nicht in der HPageBreaks-Auflistung für den Druckbereich angezeigt. Der Inhalt der Auflistung kann sich ändern, wenn die Größe des Druckbereichs geändert oder der Druckbereich neu definiert wird.


Hyperlink-Objekt

Stellt einen Hyperlink dar. Das Hyperlink-Objekt ist ein Mitglied der Hyperlinks-Auflistung.

Verwendung des Hyperlink-Objekts

Verwenden Sie die Hyperlink-Eigenschaft, um den Hyperlink einer Form zurückzugeben (eine Form kann nur einen einzigen Hyperlink besitzen). Im folgenden Beispiel wird der Hyperlink der ersten Form aktiviert.

Worksheets(1).Shapes(1).Hyperlink.Follow NewWindow:=True

Ein Bereich oder ein Tabellenblatt kann mehrere Hyperlinks besitzen. Verwenden Sie Hyperlinks(Index), wobei Index die Nummer des Hyperlinks ist, um zurückzugeben ein einzelnes Hyperlink-Objekt zurückzugeben. Im folgenden Beispiel wird der zweite Hyperlink im Bereich A1:B2 aktiviert.

Worksheets(1).Range("A1:B2").Hyperlinks(2).Follow


Hyperlinks-Auflistungsobjekt

Stellt die Auflistung der Hyperlinks in einem Tabellenblatt oder einem Bereich dar. Jeder Hyperlink wird durch ein Hyperlink-Objekt dargestellt.

Verwendung der Hyperlinks-Auflistung

Verwenden Sie die Hyperlinks-Eigenschaft, um die Hyperlinks-Auflistung zurückzugeben. Im folgenden Beispiel wird geprüft, ob sich im ersten Tabellenblatt ein Hyperlink befindet, der das Wort "Microsoft" enthält.

For Each h in Worksheets(1).Hyperlinks
    If Instr(h.Name, "Microsoft") <> 0 Then h.Follow
Next

Verwenden Sie die Add-Methode, um einen Hyperlink zu erstellen und ihn der Hyperlinks-Auflistung hinzuzufügen. Im folgenden Beispiel wird ein neuer Hyperlink für die Zelle E5 erstellt.

With Worksheets(1)
    .Hyperlinks.Add .Range("E5"), "http://www.gohere.com"
End With


Interior-Objekt

Stellt den Innenbereich eines Objekts dar.

Verwenden des Interior-Objekts

Verwenden Sie die Interior-Eigenschaft, um das Interior-Objekt zurückzugeben. Im folgenden Beispiel wird als Füllfarbe für die Zelle A1 die Farbe Rot festgelegt.

Worksheets("sheet1").Range("a1").Interior.ColorIndex = 3


LeaderLines-Objekt

Stellt Führungslinien eines Diagramms dar. Mit Führungslinien werden Datenbeschriftungen mit Datenpunkten verbunden. Dieses Objekt ist keine Auflistung; es existiert kein Objekt, das eine einzelne Führungslinie darstellt.

Verwendung des LeaderLines-Objekts

Verwenden Sie die LeaderLines-Eigenschaft, um das LeaderLines-Objekt zurückzugeben. Im folgenden Beispiel werden der ersten Datenreihe im ersten Diagramm Datenbeschriftungen und blaue Führungslinien hinzugefügt.

With Worksheets(1).ChartObjects(1).Chart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


Legend-Objekt

Stellt die Legende in einem Diagramm dar. Jedes Diagramm kann nur eine Legende aufweisen. Das Legend-Objekt enthält ein oder mehrere LegendEntry-Objekte; jedes LegendEntry-Objekt enthält ein LegendKey-Objekt.

Verwenden des Legend-Objekts

Verwenden Sie die Legend-Eigenschaft, um das Legend-Objekt zurückzugeben. Im folgenden Beispiel wird eine Fettschrift für die Legende im ersten eingebetteten Diagramm des ersten Tabellenblatts festgelegt.

Worksheets(1).ChartObjects(1).Chart.Legend.Font.Bold = True

Anmerkungen

Die Diagrammlegende ist nur dann sichtbar, wenn die HasLegend-Eigenschaft True ist. Hat diese Eigenschaft den Wert False, stehen die Eigenschaften und Methoden des Legend-Objekts nicht zur Verfügung.


LegendEntry-Objekt

Stellt einen Legendeneintrag in einer Diagrammlegende dar. Das LegendEntry-Objekt ist ein Element der LegendEntries-Auflistung. Die LegendEntries-Auflistung enthält alle LegendEntry-Objekte der Legende.

Jeder Legendeneintrag besteht aus zwei Teilen: dem Eintragstext, also dem Namen der mit dem Legendeneintrag verknüpften Datenreihe, und einem Legendensymbol, das den Legendeneintrag visuell mit der verknüpften Datenreihe oder Trendlinie im Diagramm verbindet. Die Formatierungseigenschaften für das Legendensymbol und für die damit verknüpfte Datenreihe oder Trendlinie sind im LegendKey-Objekt enthalten.

Der Text eines Legendeneintrags kann nicht geändert werden. LegendEntry-Objekte unterstützen die Zeichenformatierung und können gelöscht werden. Einzelne Legendeneinträge können nicht mit einem Muster hinterlegt werden. Position und Größe der Einträge sind festgelegt.

Verwenden des LegendEntry-Objekts

Verwenden Sie LegendEntries(Index), um ein einzelnes LegendEntry-Objekt zurückzugeben. Dabei ist Index die Indexnummer des Legendeneintrags. Sie können auf Legendeneinträge nicht mit Hilfe des Namens zugreifen.

Die Indexnummer stellt die Position des Legendeneintrags in der Legende dar. LegendEntries(1) befindet sich oben in der Legende, LegendEntries(LegendEntries.Count) unten. Im folgenden Beispiel wird die Schrift des Legendeneintrags oben in der Legende (in der Regel die Legende für die erste Datenreihe) im ersten eingebetteten Diagramm des Tabellenblatts mit dem Namen "Tabelle1" kursiv formatiert.

Worksheets("sheet1").ChartObjects(1).Chart _
    .Legend.LegendEntries(1).Font.Italic = True

Anmerkungen

Der direkte Zugriff auf die Datenreihe oder Trendlinie, die dem jeweiligen Legendeneintrag entspricht, ist nicht möglich.

Gelöschte Legendeneinträge können nur durch Löschen und erneutes Erstellen der Legende wiederhergestellt werden, in der sie enthalten waren. Zu diesem Zweck muss die HasLegend-Eigenschaft für das Diagramm auf False und anschließend wieder auf True gesetzt werden.


LegendEntries-Auflistungsobjekt

Eine Auflistung aller LegendEntry-Objekte in der angegebenen Diagrammlegende. Jeder Legendeneintrag besteht aus zwei Teilen: dem Eintragstext, also dem Namen der mit dem Legendeneintrag verknüpften Datenreihe oder Trendlinie, und dem Legendensymbol, das den Legendeneintrag visuell mit der verknüpften Datenreihe oder Trendlinie im Diagramm verbindet. Die Formatierungseigenschaften für das Legendensymbol und für die damit verknüpfte Datenreihe oder Trendlinie sind im LegendKey-Objekt enthalten.

Verwenden der LegendEntries-Auflistung

Verwenden Sie die LegendEntries-Methode, um die LegendEntries-Auflistung zurückzugeben. Im folgenden Beispiel wird die Auflistung der Legendeneinträge im ersten eingebetteten Diagramm in einer Schleife bearbeitet und die Schriftfarbe der Einträge geändert.

With Worksheets("sheet1").ChartObjects(1).Chart.Legend
    For i = 1 To .LegendEntries.Count
        .LegendEntries(i).Font.ColorIndex = 5
    Next
End With

Verwenden Sie LegendEntries(Index), um ein einzelnes LegendEntry-Objekt zurückzugeben. Dabei ist Index die Indexnummer des Legendeneintrags. Sie können auf Legendeneinträge nicht mit Hilfe des Namens zugreifen.

Die Indexnummer stellt die Position des Legendeneintrags in der Legende dar. LegendEntries(1) befindet sich oben in der Legende, LegendEntries(LegendEntries.Count) unten. Im folgenden Beispiel wird die Schrift des Legendeneintrags oben in der Legende (in der Regel die Legende für die erste Datenreihe) im ersten eingebetteten Diagramm kursiv formatiert.

Worksheets("sheet1").ChartObjects(1).Chart _
    .Legend.LegendEntries(1).Font.Italic = True


LegendKey-Objekt

Stellt ein Legendensymbol in einer Diagrammlegende dar. Jedes Legendensymbol ist eine Grafik, die einen Legendeneintrag visuell mit der verknüpften Datenreihe oder Trendlinie im Diagramm verbindet. Das Legendensymbol ist mit der verknüpften Datenreihe bzw. Trendlinie verbunden, so dass sich bei einer Änderung der Formatierung von Punkten und Linien die Darstellung im Legendensymbol automatisch anpasst, und umgekehrt.

Verwenden des LegendKey-Objekts

Verwenden Sie die LegendKey-Eigenschaft, um das LegendKey-Objekt zurückzugeben. Im folgenden Beispiel wird die Hintergrundfarbe der Punktmarkierung für den oberen Legendeneintrag im ersten eingebetteten Diagramm im Tabellenblatt "Tabelle1" geändert. Dadurch ändert sich gleichzeitig das Format aller Datenpunkte der mit diesem Legendeneintrag verknüpften Datenreihe. Die verknüpfte Datenreihe muss Datenpunktmarkierungen unterstützen.

Worksheets("sheet1").ChartObjects(1).Chart _
    .Legend.LegendEntries(1).LegendKey.MarkerBackgroundColorIndex = 5


LineFormat-Objekt

Stellt die Formatierung von Linie und Pfeilspitze dar. Bei einer Linie enthält das LineFormat-Objekt Formatinformationen zur Linie selbst; bei einer Form mit Rahmen enthält dieses Objekt Formatinformationen zum Rahmen der Form.

Verwenden des LineFormat-Objekts

Verwenden Sie die Line-Eigenschaft, um ein LineFormat-Objekt zurückzugeben. Im folgenden Beispiel wird in myDocument eine blau gestrichelte Linie eingefügt. An ihrem Anfangspunkt befindet sich eine kurze, enge Ellipse und an ihrem Endpunkt ein langes, breites Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


LinkFormat-Objekt

Enthält Eigenschaften von verknüpften OLE-Objekten.

Verwendung des LinkFormat-Objekts

Verwenden Sie die LinkFormat-Eigenschaft, um das LinkFormat-Objekt zurückzugeben. Im folgenden Beispiel wird ein OLE-Objekt in der Shapes-Auflistung aktualisiert.

Worksheets(1).Shapes(1).LinkFormat.Update

Falls das Shape-Objekt kein verknüpftes Objekt darstellt, schlägt die LinkFormat-Eigenschaft fehl.


Name-Objekt

Stellt einen definierten Namen für einen Zellbereich dar. Namen können integriert (z. B. Datenbank, Druckbereich und Auto_öffnen) oder benutzerdefiniert sein.

Application-, Workbook- und Worksheet-Objekte

Das Name-Objekt ist ein Element der Names-Auflistung für die Application-, Workbook- und Worksheet-Objekte. Verwenden Sie Names(Index), um ein einzelnes Name-Objekt zurückzugeben. Dabei ist Index die Indexnummer des Namens oder der definierte Name.

Die Indexnummer gibt die Position des Namens innerhalb der Auflistung an. Namen werden in alphabetischer Reihenfolge von a bis z aufgelistet, unabhängig von der Groß-/Kleinschreibung (die Reihenfolge entspricht der in den Dialogfeldern Namen definieren und Namen übernehmen, die durch Klicken auf den Befehl Name im Menü Einfügen aufgerufen werden). Im folgenden Beispiel wird der Zellbezug für den ersten Namen in der Application-Auflistung angezeigt.

MsgBox Names(1).RefersTo

Im folgenden Beispiel wird der Name "meineReihenfolge" aus der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.Names("mySortRange").Delete

Verwenden Sie die Name-Eigenschaft, um den Namenstext selbst festzulegen oder zurückzugeben. Im folgenden Beispiel wird der Name des ersten Name-Objekts in der aktiven Arbeitsmappe geändert.

Names(1).Name = "stock_values"

Range-Objekte

Ein Range-Objekt kann zwar mehrere Namen haben, es gibt aber keine Names-Auflistung für das Range-Objekt. Verwenden Sie Name mit einem Range-Objekt, um den ersten Namen einer (alphabetisch sortierten) Liste von Namen zurückzugeben, die dem Bereich zugeordnet sind. Im folgenden Beispiel wird die Visible-Eigenschaft für den ersten Namen festgelegt, der dem Zellbereich A1:B1 des ersten Tabellenblatts zugeordnet ist.

Worksheets(1).Range("a1:b1").Name.Visible = False


Names-Auflistungsobjekt

Eine Auflistung aller Name-Objekte in der Anwendung oder Arbeitsmappe. Jedes Name-Objekt stellt einen festgelegten Namen für einen Zellbereich dar. Namen können integriert (z. B. Datenbank, Druckbereich und Auto_öffnen) oder benutzerdefiniert sein.

Verwenden der Names-Auflistung

Verwenden Sie die Names-Eigenschaft, um die Names-Auflistung zurückzugeben. Im folgenden Beispiel wird eine Liste aller Namen in der aktiven Arbeitsmappe sowie der Adressen erstellt, auf die sie sich beziehen.

Set nms = ActiveWorkbook.Names
Set wks = Worksheets(1)
For r = 1 To nms.Count
    wks.Cells(r, 2).Value = nms(r).Name
    wks.Cells(r, 3).Value = nms(r).RefersToRange.Address
Next

Verwenden Sie die Add-Methode, um einen Namen zu erstellen und zur Auflistung hinzuzufügen. Im folgenden Beispiel wird ein neuer Name erstellt, der sich auf den Zellbereich A1:C20 im Tabellenblatt mit dem Namen "Tabelle1" bezieht.

Names.Add Name:="test", RefersTo:="=sheet1!$a$1:$c$20"

Das RefersTo-Argument muss in der A1-Schreibweise einschließlich eines Dollarzeichens ($) angegeben werden, sofern dies erforderlich ist. Wenn beispielsweise in Tabelle1 die Zelle A10 markiert ist und Sie mit dem RefersTo-Argument "=Tabelle1!A1:B1" einen Namen definieren, bezieht sich der neue Name auf den Zellbereich A10:B10 (da Sie einen relativen Bezug angegeben haben). Um einen absoluten Bezug anzugeben, verwenden Sie "=Tabelle1!$A$1:$B$1".

Verwenden Sie Names(Index), um ein einzelnes Name-Objekt zurückzugeben. Dabei ist Index die Indexnummer des Namens oder der definierte Name. Im folgenden Beispiel wird der Name "meineReihenfolge" aus der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.Names("mySortRange").Delete


ODBCError-Objekt

Stellt einen ODBC-Fehler dar, der durch die zuletzt ausgeführte ODBC-Abfrage erzeugt wurde. Das ODBCError-Objekt ist ein Element der ODBCErrors-Auflistung. Wird die angegebene ODBC-Abfrage ohne Fehler ausgeführt, so ist die ODBCErrors-Auflistung leer. Die Fehler in der Auflistung werden in der Reihenfolge mit einem Index versehen, in der sie von der ODBC-Datenquelle erzeugt werden.

Verwendung des ODBCError-Objekts

Verwenden Sie ODBCErrors(Index), wobei Index die Indexnummer des Fehlers darstellt, um ein einzelnes ODBCError-Objekt zurückzugeben. Im folgenden Beispiel wird die erste Abfragetabelle aktualisiert und der erste auftretende ODBC-Fehler angezeigt.

With Worksheets(1).QueryTables(1)
    .Refresh
    If Application.ODBCErrors.Count > 0 Then
        Set er = Application.ODBCErrors(1)
        MsgBox "The following error occurred:" &
            er.ErrorString & " : " & er.SqlState
    Else
        MsgBox "Query complete: all records returned."
    End If
End With


ODBCErrors-Auflistungsobjekt

Eine Auflistung von ODBCError-Objekten. Jedes ODBCError-Objekt stellt einen Fehler dar, der durch die zuletzt ausgeführte ODBC-Abfrage zurückgegeben wurde. Wird die angegebene ODBC-Abfrage ohne Fehler ausgeführt, so ist die ODBCErrors-Auflistung leer. Die Fehler in der Auflistung werden in der Reihenfolge mit einem Index versehen, in der sie von der ODBC-Datenquelle erzeugt werden. Der Auflistung können keine Elemente hinzugefügt werden.

Verwendung der ODBCErrors-Auflistung

Verwenden Sie die ODBCErrors-Eigenschaft, um auf die ODBCErrors-Auflistung zuzugreifen. Im folgenden Beispiel wird die erste Abfragetabelle aktualisiert und jeder auftretende ODBC-Fehler angezeigt.

With Worksheets(1).QueryTables(1)
    .Refresh
    Set errs = Application.ODBCErrors
    If errs.Count > 0 Then
        Set r = .Destination.Cells(1)
        r.Value = "The following errors occurred:"
        c = 0
        For Each er In errs
            c = c + 1
            r.offset(c, 0).value = er.ErrorString
            r.offset(c, 1).value = er.SqlState
        Next
    Else
        MsgBox "Query complete: all records returned."
    End If
End With


OLEDBError-Objekt

Stellt einen OLE DB-Fehler dar, der von der zuletzt ausgeführten OLE DB-Abfrage zurückgegeben wurde. Das OLEDBError-Objekt ist ein Mitglied der OLEDBErrors-Auflistung. Wird die angegebene OLE DB-Abfrage ohne Fehler ausgeführt, so ist die OLEDBErrors-Auflistung leer. Die Fehler in der Auflistung werden in der Reihenfolge mit einem Index versehen, in der sie von dem OLE DB-Provider erzeugt werden.

Verwenden des OLEDBError-Objekts

Verwenden Sie OLEDBErrors(Index), wobei Index die Indexnummer des OLE DB-Fehlers ist, um ein einzelnes OLEDBError-Objekt zurückzugeben. In dem folgenden Beispiel wird die Fehlerbeschreibung und der Wert der SqlState-Eigenschaft für den ersten Fehler angezeigt, der von der letzten OLE DB-Abfrage zurückgegeben wurde.

Set objEr = Application.OLEDBErrors(1)
MsgBox "The following error occurred:" & _
    objEr.ErrorString & " : " & objEr.SqlState


OLEDBErrors-Auflistungsobjekt

Eine Auflistung von OLEDBError-Objekten. Jedes OLEDBError-Objekt stellt einen Fehler dar, der von der letzten OLE DB-Abfrage zurückgegeben wurde. Wird die OLE DB-Abfrage fehlerfrei ausgeführt, ist die OLEDBErrors-Auflistung leer. Die Fehler in der Auflistung sind in der Reihenfolge indiziert, in der sie vom OLE DB-Provider erzeugt werden. Sie können der Auflistung keine Mitglieder hinzufügen.

Verwenden der OLEDBErrors-Auflistung

Verwenden Sie die OLEDBErrors-Eigenschaft, um die OLEDBErrors-Auflistung zurückzugeben. In dem folgenden Beispiel wird die Fehlerbeschreibung und der Wert der SqlState-Eigenschaft für alle OLE DB-Fehler in der Auflistung angezeigt.

For Each objEr in Application.OLEDBErrors
    MsgBox "The following error occurred:" & _
        objEr.ErrorString & " : " & objEr.SqlState
Next objEr

Verwenden Sie OLEDBErrors(Index), wobei Index die Indexnummer des OLE DB-Fehlers ist, um ein einzelnes OLEDBError-Objekt zurückzugeben. In dem folgenden Beispiel wird die Fehlerbeschreibung und der Wert der SqlState-Eigenschaft für den ersten Fehler angezeigt, der von der letzten OLE DB-Abfrage zurückgegeben wurde.

Set objEr = Application.OLEDBErrors(1)
MsgBox "The following error occurred:" & _
    objEr.ErrorString & " : " & objEr.SqlState


OLEFormat-Objekt

Enthält Eigenschaften von OLE-Objekten.

Verwendung des OLEFormat-Objekts

Verwenden Sie die OLEFormat-Eigenschaft, um das OLEFormat-Objekt zurückzugeben. Im folgenden Beispiel wird ein OLE-Objekt in der Shapes-Auflistung aktiviert.

Worksheets(1).Shapes(1).OLEFormat.Activate

Falls das Shape-Objekt kein verknüpftes oder eingebettetes Objekt darstellt, schlägt die OLEFormat-Eigenschaft fehl.


OLEObject-Objekt

Stellt ein ActiveX-Steuerelement oder ein verknüpftes oder eingebettetes OLE-Objekt eines Tabellenblattes dar. Das OLEObject-Objekt ist ein Mitglied der OLEObjects-Auflistung. Die OLEObjects-Auflistung enthält alle OLE-Objekte eines einzelnen Tabellenblattes.

Verwendung des OLEObject-Objekts

Verwenden Sie OLEObjects(index), wobei index der Name oder die Nummer des Objekts ist, um ein OLEObject-Objekt zurückzugeben. Im folgenden Beispiel wird das erste OLE-Objekt im ersten Tabellenblatt gelöscht.

Worksheets("sheet1").OLEObjects(1).Delete

Im folgenden Beispiel wird das OLE-Objekt "ListBox1" gelöscht.

Worksheets("sheet1").OLEObjects("ListBox1").Delete

Anmerkungen

Die Eigenschaften und Methoden des OLEObject-Objekts werden auf jedes ActiveX-Steuerelement eines Tabellenblattes kopiert. Dadurch kann der Visual Basic Code über den Namen des Steuerelements auf diese Eigenschaften zugreifen. Im folgenden Beispiel wird das Steuerelement eines Kontrollkästchens namens "MyCheckBox" markiert, an der aktiven Zelle ausgerichtet und anschließend das Steuerelement aktiviert.

With MyCheckBox
    .Value = True
    .Top = ActiveCell.Top
    .Activate
End With

Weitere Informationen finden Sie unter Verwenden von ActiveX-Steuerelementen in Tabellenblättern.


OLEObjects-Auflistungsobjekt

Eine Auflistung aller OLEObject-Objekte in dem angegebenen Tabellenblatt. Jedes OLEObject-Objekt stellt ein ActiveX-Steuerelement oder ein verknüpftes bzw. eingebettetes OLE-Objekt dar.

Verwenden der OLEObjects-Auflistung

Verwenden Sie die OLEObjects-Methode, um die OLEObjects-Auflistung zurückzugeben. Im folgenden Beispiel werden alle OLE-Objekte des ersten Tabellenblattes ausgeblendet.

Worksheets(1).OLEObjects.Visible = False

Verwenden Sie die Add-Methode, um ein neues OLE-Objekt zu erstellen und zur OLEObjects-Auflistung hinzuzufügen. Im folgenden Beispiel wird ein neues OLE-Objekt erstellt, das die Bitmap-Datei arcade.bmp darstellt und zum ersten Tabellenblatt hinzufügt.

Worksheets(1).OLEObjects.Add FileName:="arcade.bmp"

Im folgenden Beispiel wird ein neues ActiveX-Steuerelement (ein Listenfeld) erstellt und zum ersten Tabellenblatt hinzugefügt.

Worksheets(1).OLEObjects.Add ClassType:="Forms.ListBox.1"

Weitere Informationen finden Sie unter Verwenden von ActiveX-Steuerelementen in Tabellenblättern.

Anmerkungen

Ein ActiveX-Steuerelement in einem Tabellenblatt verfügt über zwei Namen: den Namen der das Steuerelement enthaltenden Form, der beim Anzeigen des Blatts im Feld Name angezeigt wird, sowie den Codenamen für das Steuerelement, der im Fenster Eigenschaften in der Zelle rechts neben (Name) angezeigt wird. Beim erstmaligen Hinzufügen eines Steuerelements zu einem Blatt, sind Formname und Codename identisch. Wenn Sie jedoch den Formnamen oder den Codenamen ändern, wird der andere Name nicht automatisch entsprechend geändert.

Sie verwenden den Codenamen eines Steuerelements in den Namen der entsprechenden Ereignisprozeduren. Wenn Sie jedoch ein Steuerelement aus der Shapes- oder der OLEObjects-Auflistung für ein Blatt zurückgeben möchten, müssen Sie den Formnamen und nicht den Codenamen verwenden, um sich auf das Steuerelement anhand des Namens zu beziehen. Nehmen Sie beispielsweise an, dass Sie zu einem Blatt ein Kontrollkästchen hinzufügen und sowohl der Standardformname als auch der Standardcodename "CheckBox1" lauten. Wenn Sie anschließend den Codenamen des Steuerelements ändern, indem Sie chkFinished im Fenster Eigenschaften neben (Name) eingeben, müssen Sie in den Namen von Ereignisprozeduren "chkFinished" verwenden. Sie müssen jedoch weiterhin "CheckBox1" verwenden, um das Steuerelement aus der Shapes- oder der OLEObject-Auflistung zurückzugeben, wie im folgenden Beispiel gezeigt.

Private Sub chkFinished_Click()
    ActiveSheet.OLEObjects("CheckBox1").Object.Value = 1
End Sub


Outline-Objekt

Stellt die Gliederung eines Tabellenblatts dar.

Verwenden des Outline-Objekts

Verwenden Sie die Outline-Eigenschaft, um ein Outline-Objekt zurückzugeben. Im folgenden Beispiel wird die Gliederung für das Tabellenblatt mit dem Namen "Tabelle4" so eingestellt, dass nur die erste Gliederungsebene angezeigt wird.

Worksheets("sheet4").Outline.ShowLevels 1


PageSetup-Objekt

Stellt die Beschreibung der Seiteneinrichtung dar. Das PageSetup-Objekt enthält alle Attribute zur Seiteneinrichtung (linker Rand, unterer Rand, Papiergröße usw.) als Eigenschaften.

Verwenden des PageSetup-Objekts

Verwenden Sie die PageSetup-Eigenschaft, um ein PageSetup-Objekt zurückzugeben. Im folgenden Beispiel wird das Papierformat auf Querformat gesetzt und das Tabellenblatt gedruckt.

With Worksheets("sheet1")
    .PageSetup.Orientation = xlLandscape
    .PrintOut
End With

Mit Hilfe der With-Anweisung lassen sich besonders leicht mehrere Eigenschaften gleichzeitig festlegen. Im folgenden Beispiel werden alle Ränder für das erste Tabellenblatt gesetzt.

With Worksheets(1).PageSetup
    .LeftMargin = Application.InchesToPoints(0.5)
    .RightMargin = Application.InchesToPoints(0.75)
    .TopMargin = Application.InchesToPoints(1.5)
    .BottomMargin = Application.InchesToPoints(1)
    .HeaderMargin = Application.InchesToPoints(0.5)
    .FooterMargin = Application.InchesToPoints(0.5)
End With


Pane-Objekt

Stellt einen Ausschnitt eines Fensters dar. Pane-Objekte gibt es nur für Tabellenblätter und Microsoft Excel 4.0-Makrovorlagen. Das Pane-Objekt ist ein Element der Panes-Auflistung. Die Panes-Auflistung enthält alle in einem einzelnen Fenster gezeigten Ausschnitte.

Verwenden des Pane-Objekts

Verwenden Sie Panes(Index), um ein einzelnes Pane-Objekt zurückzugeben. Index gibt die Indexnummer des Ausschnitts an.

Worksheets(1).Activate
ActiveWindow.Split = True
ActiveWindow.Panes(3).ScrollRow = 5


Panes-Auflistungsobjekt

Eine Auflistung aller im angegebenen Fenster gezeigten Pane-Objekte. Pane-Objekte gibt es nur für Tabellenblätter und Excel 4.0-Makrovorlagen.

Verwenden der Panes-Auflistung

Verwenden Sie die Panes-Eigenschaft, um die Panes-Auflistung zurückzugeben. Im folgenden Beispiel werden Ausschnitte im aktiven Fenster fixiert, wenn das Fenster mehr als einen Ausschnitt enthält.

If ActiveWindow.Panes.Count > 1 Then _
    ActiveWindow.FreezePanes = True

Verwenden Sie Panes(Index), wobei Index die Indexnummer des Ausschnitts ist, um ein einzelnes Pane-Objekt zurückzugeben. Im folgenden Beispiel wird im linken oberen Ausschnitt des Fensters, das das Tabellenblatt mit dem Namen Sheet1 zeigt, geblättert.

Worksheets("sheet1").Activate
Windows(1).Panes(1).LargeScroll down:=1


Parameter-Objekt

Stellt einen einzelnen Parameter einer Parameterabfrage dar. Das Parameter-Objekt ist ein Element der Parameters-Auflistung.

Verwendung des Parameter-Objekts

Verwenden Sie Parameters(Index), wobei Index die Indexnummer des Parameters darstellt, um auf ein einzelnes Parameter-Objekt zuzugreifen. Im folgenden Beispiel wird die Zeichenfolge für die Eingabeaufforderung des ersten Parameters geändert.

With Worksheets(1).QueryTables(1).Parameters(1)
    .SetParam xlPrompt, "Please " & .PromptString
End With


Parameters-Auflistungsobjekt

Eine Auflistung von Parameter-Objekten der angegebenen Abfragetabelle. Jedes Parameter-Objekt stellt einen einzelnen Abfrageparameter dar. Jede Abfragetabelle enthält eine Parameters-Auflistung; diese ist jedoch leer, wenn in der Abfragetabelle keine Parameterabfrage angewendet wird.

Verwendung der Parameters-Auflistung

Verwenden Sie die Parameters-Eigenschaft, um auf die Parameters-Auflistung zuzugreifen. Im folgenden Beispiel wird die Anzahl der Parameter in der ersten Abfragetabelle angezeigt.

MsgBox Workbooks(1).ActiveSheet.QueryTables(1).Parameters.Count

Verwenden Sie die Add-Methode, um einen neuen Parameter für eine Abfragetabelle zu erstellen. Im folgenden Beispiel wird die SQL-Anweisung der ersten Abfragetabelle geändert. Der Teil "(city=?)" gibt an, dass es sich bei der Abfrage um eine Parameterabfrage handelt. Außerdem wird in dem Beispiel als Wert für "City" die Konstante "Oakland" festgelegt.

Set qt = Sheets("sheet1").QueryTables(1)
qt.Sql = "SELECT * FROM authors  WHERE (city=?)"
Set param1 = qt.Parameters.Add("City Parameter", _
    xlParamTypeVarChar)
param1.SetParam xlConstant, "Oakland"
qt.Refresh

Die Add-Methode kann bei einer Abfragetabelle mit URL-Verbindung nicht verwendet werden. Bei Abfragetabellen mit URL-Verbindung erstellt Microsoft Excel die Parameter auf Grundlage der Eigenschaften Connection und PostText.


Phonetic-Objekt

Enthält Informationen über eine bestimmte phonetische Textzeichenfolge in einer Zelle. In Microsoft Excel 97 enthielt dieses Objekt die Formatierattribute für beliebigen phonetischen Text in dem angegebenen Bereich.

Verwenden des Phonetic-Objekts

Verwenden Sie Phonetics(Index), wobei Index die Indexnummer des phonetischen Textes ist, um ein einzelnes Phonetic-Objekt zurückzugeben. In dem folgenden Beispiel wird die erste phonetische Textzeichenfolge in der aktiven Zelle auf " furigana furigana furigana furigana " festgelegt.

ActiveCell.Phonetics(1).Text = "  furigana   furigana   furigana   furigana "

Die Phonetic-Eigenschaft bietet Kompatibilität mit früheren Versionen von Microsoft Excel. Sie sollten Phonetics(Index) verwenden, wobei Index die Indexnummer des phonetischen Textes ist, um ein einzelnes Phonetic-Objekt zurückzugeben. Um die Kompatibilität mit früheren Versionen von Microsoft Excel zu zeigen, werden in dem folgenden Beispiel Furigana-Zeichen zu dem Bereich "A1:C4" hinzugefügt. Wenn Sie Furigana-Zeichen zu einem Bereich hinzufügen, wird automatisch ein Phonetic-Objekt erstellt.

With Range("A1:C4").Phonetic
    .CharacterType = xlHiragana
    .Alignment = xlPhoneticAlignCenter
    .Font.Name = "MS P  goshikku   goshikku   goshikku   goshikku "
    .Font.FontStyle = "  hyoujun   hyoujun "
    .Font.Size = 6
    .Font.Strikethrough = False
    .Font.Underline = xlUnderlineStyleNone
    .Font.ColorIndex = xlAutomatic
    .Visible = True
End With


Phonetics-Auflistungsobjekt

Eine Auflistung aller Phonetic-Objekte in dem angegebenen Bereich. Jedes Phonetic-Objekt enthält Informationen über eine bestimmte, phonetische Textzeichenfolge.

Verwenden der Phonetics-Auflistung

Verwenden Sie die Phonetics-Eigenschaft, um die Phonetics-Auflistung zurückzugeben. in dem folgenden Beispiel wird jeglicher phonetischer Text im Bereich "A1:C4" angezeigt.

Range("A1:C4").Phonetics.Visible = True

Verwenden Sie Phonetics(Index), wobei Index die Indexnummer des phonetischen Textes ist, um ein einzelnes Phonetic-Objekt zurückzugeben. In dem folgenden Beispiel wird die erste phonetische Textzeichenfolge in der aktiven Zelle auf " furigana furigana furigana furigana " festgelegt.

ActiveCell.Phonetics(1).Text = "  furigana   furigana   furigana   furigana "


PictureFormat-Objekt

Enthält Eigenschaften und Methoden, die für Bilder und OLE-Objekte gelten. Das LinkFormat-Objekt enthält Eigenschaften und Methoden, die nur für verknüpfte OLE-Objekte gelten. Das OLEFormat-Objekt enthält Eigenschaften und Methoden, die für verknüpfte und nicht verknüpfte OLE-Objekte gelten.

Verwenden des PictureFormat-Objekts

Verwenden Sie die PictureFormat-Eigenschaft, um ein PictureFormat-Objekt zurückzugeben. Im folgenden Beispiel werden für die erste Form in myDocument Helligkeit, Kontrast sowie Farbumwandlung festgelegt und die Form anschließend an der unteren Seite um 18 Punkt zugeschnitten. Damit dieses Beispiel funktioniert, muss es sich bei der ersten Form entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = 0.7
    .ColorType = msoPictureGrayScale
    .CropBottom = 18


PivotCache-Objekt

Stellt den Speicher-Cache eines PivotTable-Berichts dar. Das PivotCache-Objekt ist ein Mitglied der PivotCaches-Auflistung.

Verwendung des PivotCache-Objekts

Verwenden Sie die PivotCache-Methode, um ein PivotCache-Objekt eines PivotTable-Berichts zurückzugeben (jeder Bericht besitzt nur einen Cache). Im folgenden Beispiel wird festgelegt, dass der erste PivotTable-Bericht im ersten Tabellenblatt beim Öffnen aktualisiert wird.

Worksheets(1).PivotTables(1).PivotCache.RefreshOnFileOpen = True

Verwenden Sie PivotCaches(Index), wobei Index die Nummer des PivotTable-Cache ist, um ein einzelnes PivotCache-Objekt der PivotCaches-Auflistung einer Arbeitsmappe zurückzugeben. Im folgenden Beispiel wird der erste Cache aktualisiert.

ActiveWorkbook.PivotCaches(1).Refresh


PivotCaches-Auflistungsobjekt

Stellt die Auflistung der Cachespeicher der PivotTable-Berichte in einer Arbeitsmappe dar. Jeder Cachespeicher wird durch ein PivotCache-Objekt dargestellt.

Verwendung der PivotCaches-Auflistung

Verwenden Sie die PivotCaches-Methode, um die PivotCaches-Auflistung zurückzugeben. Im folgenden Beispiel wird die RefreshOnFileOpen-Eigenschaft für alle Cachespeicher der aktiven Arbeitsmappe festgelegt.

For Each pc In ActiveWorkbook.PivotCaches
    pc.RefreshOnFileOpen = True
Next


PivotField-Objekt

Pivot Fields-Auflistung (PivotField-Objekt)

Stellt ein Feld in einem PivotTable-Bericht dar. Das PivotField-Objekt ist ein Element der PivotFields-Auflistung. Die PivotFields-Auflistung enthält alle Felder eines PivotTable-Berichts, einschließlich ausgeblendeter Felder.

Verwenden des PivotField-Objekts

Verwenden Sie PivotFields(Index), wobei Index der Name oder die Indexnummer des Feldes ist, um ein PivotField-Objekt zurückzugeben. Im folgenden Beispiel wird das Feld "Year" in dem ersten PivotTable-Bericht des Tabellenblatts Sheet3 zu einem Zeilenfeld erklärt.

Worksheets("sheet3").PivotTables(1) _
    .PivotFields("year").Orientation = xlRowField

Gelegentlich ist es einfacher, eine Eigenschaft zu verwenden, die eine Untermenge der PivotTable-Felder zurückgibt. Folgende Eigenschaften stehen zur Verfügung:

  • ColumnFields-Eigenschaft

  • DataFields-Eigenschaft

  • HiddenFields-Eigenschaft

  • PageFields-Eigenschaft

  • RowFields-Eigenschaft

  • VisibleFields-Eigenschaft


PivotFields-Auflistungsobjekt

Pivot Fields-Auflistung (PivotField-Objekt)

Eine Auflistung aller PivotField-Objekte in einem PivotTable-Bericht.

Verwenden der PivotFields-Auflistung

Verwenden Sie die PivotFields-Methode zum Zugriff auf die PivotFields-Auflistung. Im folgenden Beispiel werden die Feldnamen in dem ersten PivotTable-Bericht des Tabellenblatts Sheet3 aufgezählt.

With Worksheets("sheet3").PivotTables(1)
    For i = 1 To .PivotFields.Count
        MsgBox .PivotFields(i).Name
    Next
End With

Verwenden Sie PivotFields(Index), wobei Index der Name oder die Indexnummer des Feldes ist, um ein PivotField-Objekt zurückzugeben. Im folgenden Beispiel wird das Feld "Year" in dem ersten PivotTable-Bericht des Tabellenblatts Sheet3 zu einem Zeilenfeld erklärt.

Worksheets("sheet3").PivotTables(1) _
    .PivotFields("year").Orientation = xlRowField

Gelegentlich ist es einfacher, eine Eigenschaft zu verwenden, die eine Untermenge der PivotTable-Felder zurückgibt. Folgende Zugriffsmethoden stehen zur Verfügung:

  • ColumnFields-Eigenschaft

  • DataFields-Eigenschaft

  • HiddenFields-Eigenschaft

  • PageFields-Eigenschaft

  • RowFields-Eigenschaft

  • VisibleFields-Eigenschaft


 PivotFormula-Objekt

PivotFormula-Objekt

Stellt eine Formel dar, die zur Berechnung von Ergebnissen in einem PivotTable-Bericht verwendet wird.

Anmerkungen

Dieses Objekt und die dazu gehörigen Eigenschaften und Methoden stehen für OLAP-Datenquellen nicht zur Verfügung, da berechnete Felder und Elemente nicht unterstützt werden.

Verwendung des PivotFormula-Objekts

Verwenden Sie PivotFormulas(Index), wobei Index die Nummer der Formel oder die Zeichenfolge auf der linken Seite der Formel ist, um das PivotFormula-Objekt zurückzugeben. Im folgenden Beispiel wird die Indexnummer der ersten Formel im ersten PivotTable-Bericht im ersten Arbeitsblatt so geändert, dass diese Formel nach der zweiten Formel berechnet wird.

Worksheets(1).PivotTables(1).PivotFormulas(1).Index = 2


 PivotFormulas-Auflistungsobjekt

PivotFormulas-Auflistungsobjekt

Stellt die Auflistung von Formeln eines PivotTable-Berichts dar. Jede Formel wird durch ein PivotFormula-Objekt dargestellt.

Anmerkungen

Dieses Objekt und die dazugehörigen Eigenschaften und Methoden stehen für OLAP-Datenquellen nicht zur Verfügung, da berechnete Felder und Elemente nicht unterstützt werden.

Verwendung der PivotFormulas-Auflistung

Verwenden Sie die PivotFormulas-Methode, um die PivotFormulas-Auflistung zurückzugeben. Im folgenden Beispiel wird eine Liste der PivotTable-Formeln in dem ersten PivotTable-Bericht im aktiven Arbeitsblatt erstellt.

For Each pf in ActiveSheet.PivotTables(1).PivotFormulas
    Cells(r, 1).Value = pf.Formula
    r = r + 1
Next


PivotItem-Objekt

Stellt ein Element eines PivotTable-Feldes dar. Die Elemente sind die einzelnen Dateneinträge in einer Feldkategorie. Das PivotItem-Objekt ist ein Element der PivotItems-Auflistung. Die PivotItems-Auflistung umfasst alle Elemente eines PivotField-Objekts.

Verwenden des PivotItem-Objekts

Verwenden Sie PivotItems(Index), wobei Index der Name oder die Indexnummer des Elements ist, um ein PivotItem-Objekt zurückzugeben. Im folgenden Beispiel werden die Einträge in dem ersten PivotTable-Bericht des Tabellenblatts Sheet3 ausgeblendet, die im Feld "Year" den Wert "1998" enthalten.

Worksheets("sheet3").PivotTables(1) _
    .PivotFields("year").PivotItems("1998").Visible = False


PivotItems-Auflistungsobjekt

Pivot Fields-Auflistung (PivotField-Objekt)

Eine Auflistung aller PivotItem-Objekte eines PivotTable-Feldes. Die Elemente sind die einzelnen Dateneinträge in einer Feldkategorie.

Verwenden der PivotItems-Auflistung

Verwenden Sie die PivotItems-Methode zum Zugriff auf die PivotItems-Auflistung. Im folgenden Beispiel wird für den ersten PivotTable-Bericht des Tabellenblatts Sheet4 eine nummerierte Liste der Feldnamen und der Elemente in diesen Feldern erstellt.

Worksheets("Sheet4").Activate
With Worksheets("Sheet3").PivotTables(1)
    c = 1
    For i = 1 To .PivotFields.Count
        r = 1
        Cells(r, c) = .PivotFields(i).Name
        r = r + 1
        For x = 1 To .PivotFields(i).PivotItems.Count
            Cells(r, c) = .PivotFields(i).PivotItems(x).Name
            r = r + 1
        Next
        c = c + 1
    Next
End With

Verwenden Sie PivotItems(Index), wobei Index der Name oder die Indexnummer des Elements ist, um ein PivotItem-Objekt zurückzugeben. Im folgenden Beispiel werden die Einträge in dem ersten PivotTable-Bericht des Tabellenblatts Sheet3 ausgeblendet, die im Feld "Year" den Wert "1998" enthalten.

Worksheets("Sheet3").PivotTables(1) _
    .PivotFields("year").PivotItems("1998").Visible = False


PivotLayout-Objekt

Stellt die Position der Felder in einem PivotChart-Bericht dar.

Verwendung des Pivot-Layoutobjekts

Verwenden Sie die PivotLayout-Eigenschaft, um das PivotLayout-Objekt zurückzugeben. Im folgenden Beispiel wird eine Liste der PivotTable-Feldnamen erstellt, die im ersten PivotChart-Bericht verwendet werden.

Set objNewSheet = Worksheets.Add
intRow = 1
For Each objPF In _
    Charts("Chart1").PivotLayout.PivotFields
    objNewSheet.Cells(intRow, 1).Value = objPF.Caption
    intRow = intRow + 1
Next objPF


PivotTable-Objekt

Pivot Fields-Auflistung (PivotField-Objekt)

Stellt einen PivotTable-Bericht in einem Tabellenblatt dar. Das PivotTable-Objekt ist ein Element der PivotTables-Auflistung. Die PivotTables-Auflistung umfasst alle PivotTable-Objekte eines einzelnen Tabellenblatts.

Verwenden des PivotTable-Objekts

Verwenden Sie PivotTables(Index), wobei Index der Name oder die Indexnummer der Pivot-Tabelle ist, um ein PivotTable-Objekt zurückzugeben. Im folgenden Beispiel wird das Feld "Year" zu einem Zeilenfeld im ersten PivotTable-Bericht im Tabellenblatt Sheet3 erklärt.

Worksheets("Sheet3").PivotTables(1) _
    .PivotFields("year").Orientation = xlRowField

Anmerkungen

Da die Programmierung von PivotTable-Berichten komplex sein kann, ist der leichteste Weg meist der, die Aktionen für den PivotTable-Bericht aufzuzeichnen und den Code anschließend zu überarbeiten. Um ein Makro aufzuzeichnen, zeigen Sie im Menü Extras auf Makro und klicken dann auf Aufzeichnen.


PivotTables-Auflistungsobjekt

Pivot Fields-Auflistung (PivotField-Objekt)

Eine Auflistung aller PivotTable-Objekte in dem angegebenen Tabellenblatt.

Verwenden der PivotTables-Auflistung

Verwenden Sie die PivotTables-Methode zum Zugriff auf die PivotTables-Auflistung. Im folgenden Beispiel wird die Anzahl der PivotTable-Berichte im Tabellenblatt Sheet3 angezeigt.

MsgBox Worksheets("Sheet3").PivotTables.Count

Verwenden Sie die PivotTableWizard-Methode, um einen neuen PivotTable-Bericht zu erstellen und der Auflistung hinzuzufügen. Im folgenden Beispiel wird ein neuer PivotTable-Bericht aus einer Microsoft Excel-Datenbank (liegt im Bereich A1:C100) erstellt.

ActiveSheet.PivotTableWizard xlDatabase, Range("A1:C100")

Verwenden Sie PivotTables(Index), wobei Index der Name oder die Indexnummer der Pivot-Tabelle ist, um ein PivotTable-Objekt zurückzugeben. Im folgenden Beispiel wird das Feld "Year" zu einem Zeilenfeld des ersten PivotTable-Berichts im Tabellenblatt Sheet3 erklärt.

Worksheets("Sheet3").PivotTables(1) _
    .PivotFields("year").Orientation = xlRowField

Anmerkungen

Da die Programmierung von PivotTable-Berichten komplex sein kann, ist der leichteste Weg häufig der, die Aktionen für den PivotTable-Bericht aufzuzeichnen und den Code anschließend zu überarbeiten. Um ein Makro aufzuzeichnen, zeigen Sie im Menü Extras auf Makro und klicken dann auf Aufzeichnen.


PlotArea-Objekt

Stellt die Zeichnungsfläche eines Diagramms dar. Das ist die Fläche, in der Ihre Diagrammdaten gezeichnet werden. Die Zeichnungsfläche in einem 2D-Diagramm enthält die Datenpunktmarkierungen, Gitternetzlinien, Datenbeschriftungen, Trendlinien und optionalen Diagrammelemente für die Diagrammfläche. Die Zeichnungsfläche in einem 3D-Diagramm enthält neben den genannten Elementen die Wände, die Bodenfläche, die Achsen und Achsenbeschriftungen sowie die Teilstrichbeschriftungen für das Diagramm.

Die Zeichnungsfläche ist von der Diagrammfläche umgeben. Die Diagrammfläche in einem 2D-Diagramm enthält die Achsen, den Diagrammtitel, die Achsenbeschriftungen und die Legende. Die Diagrammfläche in einem 3D-Diagramm enthält den Diagrammtitel und die Legende. Informationen über das Formatieren der Diagrammfläche finden Sie unter dem ChartArea-Objekt.

Verwenden des PlotArea-Objekts

Verwenden Sie die PlotArea-Eigenschaft, um ein PlotArea-Objekt zurückzugeben. Im folgenden Beispiel wird das Diagrammblatt mit dem Namen "Diagramm1" aktiviert, die Diagrammfläche für das aktive Diagramm mit einem gestrichelten Rahmen und die Zeichnungsfläche mit einem gepunkteten Rahmen umgeben.

Charts("Chart1").Activate
With ActiveChart
    .ChartArea.Border.LineStyle = xlDash
    .PlotArea.Border.LineStyle = xlDot
End With


Point-Objekt

Stellt einen einzelnen Punkt einer Reihe in einem Diagramm dar. Das Point-Objekt ist ein Element der Points-Auflistung. Die Points-Auflistung enthält alle Punkte einer Datenreihe.

Verwenden des Point-Objekts

Verwenden Sie Points(Index), wobei Index die Indexnummer des Punktes ist, um ein Point-Objekt zurückzugeben. Die Punkte der Reihe werden von links nach rechts nummeriert. Points(1)ist der Punkt am weitesten links, Points(Points.Count) der am weitesten rechts liegende Punkt. Im folgenden Beispiel wird die Markierungsart für den dritten Punkt der ersten Reihe im ersten eingebetteten Diagramm des ersten Tabellenblatts festgelegt. Die angegebene Reihe muss eine 2D-Linien-, -Punkt- oder -Netzreihe sein.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Points(3).MarkerStyle = xlDiamond


Points-Auflistungsobjekt

Eine Auflistung aller Point-Objekte der angegebenen Reihe in einem Diagramm.

Verwenden der Points-Auflistung

Verwenden Sie die Points-Methode zum Zugriff auf die Points-Auflistung. Im folgenden Beispiel wird in dem ersten eingebetteten Diagramm des ersten Tabellenblatts dem letzten Punkt der ersten Reihe eine Datenbeschriftung hinzugefügt.

Dim pts As Points
Set pts = Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Points
pts(pts.Count).ApplyDataLabels type:=xlShowValue

Verwenden Sie Points(Index), wobei Index die Indexnummer des Punktes ist, um ein Point-Objekt zurückzugeben. Die Punkte der Reihe werden von links nach rechts nummeriert. Points(1)ist der Punkt, der am weitesten links, Points(Points.Count) der am weitesten rechts liegende. Im folgenden Beispiel wird die Markierungsart für den dritten Punkt der ersten Reihe im ersten eingebetteten Diagramm des ersten Tabellenblatts festgelegt. Die angegebene Reihe muss eine 2D-Linien-, -Punkt- oder -Netzreihe sein.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Points(3).MarkerStyle = xlDiamond


PublishObject-Objekt

Stellt ein Element in einer Arbeitsmappe dar, das auf einer Webseite gespeichert wurde, und entsprechend den Werten, die durch die Eigenschaften und Methoden des PublishObject-Objekts angegeben wurden, aktualisiert werden kann. Das PublishObject-Objekt ist ein Mitglied der PublishObjects-Auflistung.

Verwenden des PublishObject-Objekts

Verwenden Sie PublishObjects(Index), wobei Index die Indexnummer des angegebenen Elements in der Arbeitsmappe darstellt, um ein einzelnes PublishObject-Objekt zurückzugeben. Im folgenden Beispiel wird der Speicherort festgelegt, an dem das erste Element in der dritten Arbeitsmappe gespeichert wird.

Workbooks(3).PublishObjects(1).FileName = _
    "\\myserver\public\finacct\statemnt.htm"


PublishObjects-Auflistungsobjekt

Eine Auflistung aller PublishObject-Objekte in der Arbeitsmappe. Jedes PublishObject-Objekt stellt ein Element in einer Arbeitsmappe dar, das in einer Webseite gespeichert wurde, und entsprechend den Werten, die durch die Eigenschaften und Methoden des Objekts angegeben wurden, aktualisiert werden kann.

Verwenden der PublishObjects-Auflistung

Verwenden Sie die PublishObjects-Eigenschaft, um die PublishObjects-Auflistung zurückzugeben. Im folgenden Beispiel werden alle statischen PublishObject-Objekte der aktiven Arbeitsmappe auf der Webseite gespeichert.

Set objPObjs = ActiveWorkbook.PublishObjects
For Each objPO in objPObjs
    If objPO.HtmlType = xlHTMLStatic Then
        objPO.Publish
    End If
Next objPO

Verwenden Sie PublishObjects(Index), wobei Index die Indexnummer des angegebenen Elements in der Arbeitsmappe darstellt, um ein einzelnes PublishObject-Objekt zurückzugeben. Im folgenden Beispiel wird der Speicherort festgelegt, an dem das erste Element in der dritten Arbeitsmappe gespeichert wird.

Workbooks(3).PublishObjects(1).FileName = _
    "\\myserver\public\finacct\statemnt.htm"


QueryTable-Objekt

Stellt die Tabelle eines Tabellenblattes dar, deren Daten aus einer externen Datenquelle, z.B. einem SQL Server oder einer Microsoft Access-Datenbank, zurückgegeben werden. Das QueryTable-Objekt ist ein Element der QueryTables-Auflistung.

Verwendung des QueryTable-Objekts

Verwenden Sie QueryTables(Index), wobei Index die Indexnummer der Abfragetabelle darstellt, um auf ein einzelnes QueryTable-Objekt zuzugreifen. Im folgenden Beispiel wird festgelegt, dass bei jeder Aktualisierung der ersten Abfragetabelle alle Formeln rechts von der Tabelle aktualisiert werden.

Sheets("sheet1").QueryTables(1).FillAdjacentFormulas = True


QueryTables-Auflistungsobjekt

Eine Auflistung von QueryTable-Objekten. Jedes QueryTable-Objekt stellt eine Tabelle eines Tabellenblattes dar, deren Daten aus einer externen Datenquelle zurückgegeben werden.

Verwendung der QueryTables-Auflistung

Verwenden Sie QueryTables-Eigenschaft, um auf die QueryTables-Auflistung zuzugreifen. Im folgenden Beispiel wird die Anzahl der Abfragetabellen des aktiven Tabellenblattes angezeigt.

MsgBox ActiveSheet.QueryTables.Count

Verwenden Sie die Add-Methode, um eine neue Abfragetabelle zu erstellen und sie der QueryTables-Auflistung hinzuzufügen. Im folgenden Beispiel wird eine neue Abfragetabelle erstellt.

Dim qt As QueryTable
sqlstring = "select 96Sales.totals from 96Sales where profit < 5"
connstring = _
    "ODBC;DSN=96SalesData;UID=Rep21;PWD=NUyHwYQI;Database=96Sales"
With ActiveSheet.QueryTables.Add(Connection:=connstring, _
        Destination:=Range("B1"), Sql:=sqlstring)
    .Refresh
End With


Range-Objekt

Stellt eine Zelle, eine Zeile, eine Spalte, eine Auswahl von Zellen aus einem oder mehreren zusammenhängenden Zellblöcken oder einen 3D-Bereich dar.

Verwenden des Range-Objekts

In diesem Abschnitt werden die folgenden Eigenschaften und Methoden beschrieben, um ein Range-Objekt zurückzugeben:

  • Range-Eigenschaft

  • Cells-Eigenschaft

  • Range und Cells

  • Offset-Eigenschaft

  • Union-Methode

Range-Eigenschaft

Verwenden Sie Range(Arg), wobei arg den Bereich benennt, um ein Range-Objekt zurückzugeben, das eine einzelne Zelle oder einen Zellbereich darstellt. Im folgenden Beispiel wird der Wert der Zelle A1 in Zelle A5 übertragen.

Worksheets("Sheet1").Range("A5").Value = _
    Worksheets("Sheet1").Range("A1").Value

Im folgenden Beispiel wird der Bereich A1:H8 mit Zufallszahlen aufgefüllt, indem für jede Zelle des Bereichs die Formel festgelegt wird. Bei Verwendung ohne Objektkennzeichner (das Objekt links vom Punkt) gibt die Range-Eigenschaft einen Bereich im aktiven Blatt zurück. Ist das aktive Blatt kein Tabellenblatt, schlägt die Methode fehl. Aktivieren Sie mit Hilfe der Activate-Methode ein Tabellenblatt, bevor Sie die Range-Eigenschaft ohne expliziten Objektkennzeichner einsetzen.

Worksheets("sheet1").Activate
Range("A1:H8").Formula = "=rand()"    ' Range is on the active sheet

Im folgenden Beispiel wird der Inhalt des Bereichs mit dem Namen "Kriterien" gelöscht.

Worksheets(1).Range("criteria").ClearContents

Wenn Sie als Bereichsadresse ein Textargument einsetzen, müssen Sie die Adresse im A1-Bezugssystem angeben (die Z1S1-Schreibweise kann nicht verwendet werden).

Cells-Eigenschaft

Verwenden Sie Cells(Reihe, Spalte), wobei Reihe der Zeilenindex und Spalte der Spaltenindex ist, um eine einzelne Zelle zurückzugeben. Im folgenden Beispiel wird der Wert von Zelle A1 auf 24 gesetzt.

Worksheets(1).Cells(1, 1).Value = 24

Im folgenden Beispiel wird die Formel von Zelle A2 festgelegt.

ActiveSheet.Cells(2, 1).Formula = "=sum(B1:B5)"

Sie können die Zelle A1 auch mit Range("A1") angeben - gelegentlich ist jedoch die Cells-Eigenschaft praktischer, da sie die Angabe der Zeile oder Spalte durch eine Variable ermöglicht. Im folgenden Beispiel werden Zeilen- und Spaltenbeschriftungen in dem Tabellenblatt mit dem Namen Sheet1 erstellt. Beachten Sie, dass nach der Aktivierung des Tabellenblatts die Cells-Eigenschaft ohne explizite Blattangabe verwendet werden kann (sie gibt eine Zelle im aktiven Blatt zurück).

Sub SetUpTable()
Worksheets("sheet1").Activate
For theYear = 1 To 5
    Cells(1, theYear + 1).Value = 1990 + theYear
Next theYear
For theQuarter = 1 To 4
    Cells(theQuarter + 1, 1).Value = "Q" & theQuarter
Next theQuarter
End Sub

Sie könnten zwar die Visual Basic-Zeichenfolgenfunktionen verwenden, um Bezüge in der A1-Schreibweise zu ändern, es ist jedoch erheblich einfacher (und wesentlich besserer Programmierstil), die Schreibweise Cells(1, 1) zu verwenden.

Verwenden Sie Ausdruck.Cells(Reihe, Spalte) , wobei Ausdruck für einen Ausdruck steht, der ein Range-Objekt zurückgibt, und Reihe und Spalte relativ zur linken oberen Ecke des Bereichs angegeben werden, um einen Teilbereich zurückzugeben. Im folgenden Beispiel wird die Formel von Zelle C5 festgelegt.

Worksheets(1).Range("C5:C10").Cells(1, 1).Formula = "=rand()"

Range und Cells

Verwenden Sie Range(Zelle1, Zelle2), wobei Zelle1 und Zelle2 Range-Objekte sind, die die Anfangs- und Endzellen festlegen, um ein Range-Objekt zurückzugeben. Im folgenden Beispiel wird die Linienart des Rahmens um die Zellen A1:J10 festgelegt.

With Worksheets(1)
    .Range(.Cells(1, 1), _
        .Cells(10, 10)).Borders.LineStyle = xlThick
End With

Beachten Sie den Punkt vor jedem Aufruf der Cells-Eigenschaft. Der Punkt bewirkt, dass das Ergebnis der vorhergehenden With-Anweisung auf die Cells-Eigenschaft angewendet wird - in diesem Fall wird dadurch ausgedrückt, dass sich die Zellen im ersten Tabellenblatt befinden (ohne den Punkt würde die Cells-Eigenschaft Zellen im aktiven Blatt zurückgeben).

Offset-Eigenschaft

Verwenden Sie Offset(Reihe, Spalte), wobei Reihe und Spalte für den Versatz von Zeilen und Spalten stehen, um einen Bereich mit einem bestimmten Versatz zu einem anderen Bereich zurückzugeben. Im folgenden Beispiel wird die Zelle markiert, die sich eine Spalte rechts und drei Zeilen unter der linken oberen Eckzelle der aktuellen Auswahl befindet. Es ist nicht möglich, eine Zelle zu markieren, die sich nicht im aktiven Blatt befindet. Daher müssen Sie zunächst das Tabellenblatt aktivieren.

Worksheets("sheet1").Activate
  ' can't select unless the sheet is active
Selection.Offset(3, 1).Range("A1").Select

Union-Methode

Verwenden Sie Union(Bereich1, Bereich2, ...), um Mehrflächen-Bereiche, d.h. Bereiche aus zwei oder mehr zusammenhängenden Zellblöcken, zurückzugeben. Im folgenden Beispiel wird ein Objekt erstellt und als Vereinigung der Bereiche A1:B2 und C3:D4 definiert und ausgewählt.

Dim r1 As Range, r2 As Range, myMultiAreaRange As Range
Worksheets("sheet1").Activate
Set r1 = Range("A1:B2")
Set r2 = Range("C3:D4")
Set myMultiAreaRange = Union(r1, r2)
myMultiAreaRange.Select

Bei der Arbeit mit einer Auswahl, die mehrere Bereiche umfasst, erweist sich die Areas-Eigenschaft als nützlich. Sie teilt eine Mehrbereichsauswahl in einzelne Range-Objekte auf und gibt diese als Auflistung zurück. Mit Hilfe der Count-Eigenschaft können Sie die zurückgegebene Auflistung auf eine Auswahl überprüfen, die mehrere Bereiche umfasst, wie im folgenden Beispiel dargestellt.

Sub NoMultiAreaSelection()
    numberOfSelectedAreas = Selection.Areas.Count
    If numberOfSelectedAreas > 1 Then
        MsgBox "You cannot carry out this command " & _
            "on multi-area selections"
    End If
End Sub


RecentFile-Objekt

Stellt eine Datei in der Liste der zuletzt verwendeten Dateien dar. Das RecentFile-Objekt ist ein Mitglied der RecentFiles-Auflistung.

Verwendung des RecentFile-Objekts

Verwenden Sie RecentFiles(index), wobei index die Nummer der Datei ist, um ein RecentFile-Objekt zurückzugeben. Im folgenden Beispiel wird die zweite Datei in der Liste der zuletzt verwendeten Dateien geöffnet.

Application.RecentFiles(2).Open


RecentFiles-Auflistungsobjekt

Stellt die Liste der zuletzt verwendeten Dateien dar. Jede Datei wird durch ein RecentFile-Objekt dargestellt.

Verwendung der RecentFiles-Auflistung

Verwenden Sie die RecentFiles-Eigenschaft, um die RecentFiles-Auflistung zurückzugeben. Im folgenden Beispiel wird die maximale Anzahl der Dateien festgelegt, die in der Liste der zuletzt verwendeten Dateien erscheinen.

Application.RecentFiles.Maximum = 6


RoutingSlip-Objekt

Workbooks-Auflistung (Workbook-Objekt )

Stellt den Verteiler einer Arbeitsmappe dar. Der Verteiler dient zum Versenden einer Arbeitsmappe über das elektronische Mail-System.

Verwenden des RoutingSlip-Objekts

Verwenden Sie die RoutingSlip-Eigenschaft, um das RoutingSlip-Objekt zurückzugeben. Im folgenden Beispiel wird die Auslieferungsart für den Verteiler festgelegt, der mit der aktiven Arbeitsmappe verknüpft ist. Ein ausführlicheres Beispiel finden Sie unter der RoutingSlip-Eigenschaft.

ActiveWorkbook.HasRoutingSlip = True
ActiveWorkbook.RoutingSlip.Delivery = xlOneAfterAnother

Anmerkungen

Das RoutingSlip -Objekt ist nur vorhanden und zugänglich, wenn die HasRoutingSlip-Eigenschaft für die Arbeitsmappe den Wert True besitzt.


Scenario-Objekt

Stellt ein Szenario in einem Tabellenblatt dar. Ein Szenario ist ein Satz von Eingabewerten (sog. veränderbaren Zellen), der benannt und gespeichert wird. Das Scenario-Objekt ist ein Element der Scenarios-Auflistung. Die Scenarios-Auflistung enthält alle definierten Szenarios eines Tabellenblatts.

Verwenden des Scenario-Objekts

Verwenden Sie Scenarios(Index), wobei Index den Namen oder die Indexnummer des Szenarios angibt, um ein einzelnes Scenario-Objekt zurückzugeben. Im folgenden Beispiel wird das Szenario mit dem Namen "Typisch" im Tabellenblatt "Optionen" angezeigt.

Worksheets("options").Scenarios("typical").Show


Scenarios-Auflistungsobjekt

Eine Auflistung aller Scenario-Objekte des angegebenen Tabellenblatts. Ein Szenario ist ein Satz von Eingabewerten (sog. veränderbaren Zellen), der benannt und gespeichert wird.

Verwenden der Scenarios-Auflistung

Verwenden Sie die Scenarios-Methode zum Zugriff auf die Scenarios-Auflistung. Im folgenden Beispiel wird für die Szenarios des Tabellenblatts "Optionen" eine Zusammenfassung mit den Zellen J10 und J20 als Ergebniszellen erstellt.

Worksheets("options").Scenarios.CreateSummary _
    resultCells:=Worksheets("options").Range("j10,j20")

Verwenden Sie die Add-Methode, um ein neues Szenario zu erstellen und der Auflistung hinzuzufügen. Im folgenden Beispiel wird dem Tabellenblatt "Optionen" ein neues Szenario mit dem Namen "Typisch" hinzugefügt. Das neue Szenario weist zwei veränderbare Zellen, A2 und A12, mit den Werten 55 bzw. 60 auf.

Worksheets("options").Scenarios.Add name:="Typical", _
    changingCells:=Worksheets("options").Range("A2,A12"), _
    values:=Array("55", "60")

Verwenden Sie Scenarios(Index), wobei Index den Namen oder die Indexnummer des Szenarios angibt, um ein einzelnes Scenario-Objekt zurückzugeben. Im folgenden Beispiel wird das Szenario mit dem Namen "typical" im Tabellenblatt "options" angezeigt.

Worksheets("options").Scenarios("typical").Show


Series-Objekt

Stellt eine Datenreihe in einem Diagramm dar. Das Series-Objekt ist ein Element der SeriesCollection-Auflistung.

Verwenden des Series-Objekts

Verwenden Sie SeriesCollection(Index), um ein einzelnes Series-Objekt zurückzugeben. Index ist dabei die Indexnummer oder der Name der Datenreihe. Im folgenden Beispiel wird die Füllfarbe der ersten Reihe im ersten eingebetteten Diagramm des Tabellenblatts "Tabelle1" festgelegt.

Worksheets("sheet1").ChartObjects(1).Chart. _
    SeriesCollection(1).Interior.Color = RGB(255, 0, 0)

Die Indexnummer der Datenreihe gibt die Reihenfolge an, in der die Datenreihen dem Diagramm hinzugefügt wurden. SeriesCollection(1) ist die erste hinzugefügte Datenreihe, SeriesCollection(SeriesCollection.Count) die letzte.


SeriesCollection-Auflistungsobjekt

Eine Auflistung aller Series-Objekte im angegebenen Diagramm bzw. der Diagrammgruppe.

Verwenden der SeriesCollection-Auflistung

Verwenden Sie die SeriesCollection-Methode für den Zugriff auf die SeriesCollection-Auflistung. Im folgenden Beispiel werden einer bestehenden Reihe in der SeriesCollection-Auflistung im ersten eingebetteten Diagramm die Daten aus dem Zellbereich C1:C10 des ersten Tabellenblatts hinzugefügt.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection.Extend Worksheets(1).Range("c1:c10")

Verwenden Sie die Add-Methode, um eine neue Datenreihe zu erstellen und diese dem Diagramm hinzuzufügen. Im folgenden Beispiel werden dem Diagrammblatt "Diagramm1" die Daten aus dem Zellbereich A1:A19 als neue Datenreihe hinzugefügt.

Charts("chart1").SeriesCollection.Add _
    source:=Worksheets("sheet1").Range("a1:a19")

Verwenden Sie SeriesCollection(Index), wobei Index die Indexnummer oder der Name der Datenreihe ist, um ein einzelnes Series-Objekt zurückzugeben. Im folgenden Beispiel wird die Füllfarbe der ersten Reihe im ersten eingebetteten Diagramm des Tabellenblatts "Tabelle1" festgelegt.

Worksheets("sheet1").ChartObjects(1).Chart. _
    SeriesCollection(1).Interior.Color = RGB(255, 0, 0)


SeriesLines-Objekt

Stellt Verbindungslinien in einer Diagrammgruppe dar. Verbindungslinien verbinden die Datenwerte jeder Reihe. Nur gestapelte 2D-Balken- oder -Säulendiagrammgruppen können Verbindungslinien aufweisen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Verbindungslinie darstellt; die Verbindungslinien für alle Punkte einer Diagrammgruppe müssen gleichzeitig aktiviert oder deaktiviert werden.

Verwenden des SeriesLines-Objekts

Verwenden Sie die SeriesLines-Eigenschaft um ein SeriesLines-Objekt zurückzugeben. Im folgenden Beispiel werden Verbindungslinien zu der ersten Diagrammgruppe im ersten eingebetteten Diagramm des ersten Tabellenblatts hinzugefügt (das Diagramm muss ein gestapeltes 2D-Balken- oder -Säulendiagramm sein).

With Worksheets(1).ChartObjects(1).Chart.ChartGroups(1)
    .HasSeriesLines = True
    .SeriesLines.Border.Color = RGB(0, 0, 255)
End With

Anmerkungen

Weist die HasSeriesLines-Eigenschaft den Wert False auf, sind die meisten Eigenschaften des SeriesLines-Objekts nicht verfügbar.


ShadowFormat-Objekt

Stellt die Schattenformatierung einer Form dar.

Verwenden des ShadowFormat-Objekts

Verwenden Sie die Shadow-Eigenschaft, um ein ShadowFormat-Objekt zurückzugeben. Im folgenden Beispiel wird in myDocument ein schattiertes Rechteck eingefügt. Der halbtransparente blaue Schatten ist vom Rechteck um 5 Punkt nach rechts und 3 Punkt nach oben versetzt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        50, 50, 100, 200).Shadow
    .ForeColor.RGB = RGB(0, 0, 128)
    .OffsetX = 5
    .OffsetY = -3
    .Transparency = 0.5
    .Visible = True
End With


Shape-Objekt

Stellt ein Objekt in der Zeichnungsebene dar, z. B. eine AutoForm, ein Freihandobjekt, ein OLE-Objekt oder ein Bild. Das Shape-Objekt ist ein Element der Shapes-Auflistung. Die Shapes-Auflistung enthält alle Formen einer Folie.

Anmerkung Es gibt drei Objekte, die Formen darstellen: Die Shapes-Auflistung stellt alle Formen eines Dokuments dar; die ShapeRange-Auflistung stellt einen angegebenen Teilbereich der Formen eines Dokuments dar (beispielsweise könnte ein ShapeRange-Objekt die erste und die vierte Form oder alle markierten Formen in einem Dokument darstellen); und das Shape-Objekt stellt eine einzelne Form eines Dokuments dar. Wenn Sie mit mehreren Formen gleichzeitig oder mit Formen innerhalb einer Markierung arbeiten möchten, verwenden Sie eine ShapeRange-Auflistung. Einen Überblick über die Arbeit mit einer einzelnen Form oder mit mehreren Formen gleichzeitig finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwenden des Shape-Objekts

Dieser Abschnitt beschreibt:

  • Das Zurückgeben einer bestehenden Form.

  • Das Zurückgeben einer Form innerhalb der Markierung.

  • Das Zurückgeben der Formen, die den Enden einer Verbindung zugeordnet sind.

  • Das Zurückgeben eines neu erstellten Freihandobjekts.

  • Das Zurückgeben einer Form aus einer Gruppe.

  • Das Zurückgeben einer neu gebildeten Gruppe von Formen.

Zurückgeben einer bestehenden Form

Verwenden Sie Shapes(Index), wobei Index der Name oder die Indexnummer der Form ist, um ein Shape-Objekt zurückzugeben, das die eine Form darstellt. Im folgenden Beispiel werden in myDocument das erste Rechteck und das Rechteck "Rechteck1" horizontal gekippt.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).Flip msoFlipHorizontal
myDocument.Shapes("Rectangle 1").Flip msoFlipHorizontal

Jeder Form wird ein Standardname zugewiesen, wenn Sie sie der Shapes-Auflistung hinzufügen. Wenn Sie der Form einen aussagekräftigeren Namen geben möchten, verwenden Sie die Name-Eigenschaft. Im folgenden Beispiel wird in myDocument ein Rechteck eingefügt. Ihm werden der Name "Red Square" sowie Vordergundfarbe und Linienart zugewiesen.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        144, 144, 72, 72)
    .Name = "Red Square"
    .Fill.ForeColor.RGB = RGB(255, 0, 0)
    .Line.DashStyle = msoLineDashDot
End With

Zurückgeben einer Form innerhalb der Markierung

Verwenden Sie Selection.ShapeRange(Index), wobei Index der Name oder die Indexnummer der Form ist, um ein Shape-Objekt zurückzugeben, das eine Form innerhalb der Markierung darstellt. Im folgenden Beispiel wird davon ausgegangen, dass mindestens eine Form markiert ist, und die Füllung für die erste Form der Markierung im aktiven Fenster festgelegt.

ActiveWindow.Selection.ShapeRange(1).Fill.ForeColor.RGB = _
    RGB(255, 0, 0)

Zurückgeben der Formen, die den Enden einer Verbindung zugeordnet sind

Um ein Shape-Objekt zurückzugeben, das eine der Formen, die einer Verbindung zugeordnet sind, darstellt, verwenden Sie die BeginConnectedShape- oder die EndConnectedShape-Eigenschaft.

Zurückgeben eines neu erstellten Freihandobjekts

Verwenden Sie die BuildFreeform- und die AddNodes-Methode, um die Geometrie eines neuen Freihandobjekts zu definieren, und die ConvertToShape-Methode, um das Freihandobjekt zu erstellen und das Shape-Objekt, das es darstellt, zurückzugeben.

Zurückgeben einer Form aus einer Gruppe

Verwenden Sie GroupItems(Index), wobei Index Name oder Indexnummer der Form innerhalb der Gruppe ist, um ein Shape-Objekt zurückzugeben, das eine einzelne Form aus einer Gruppe darstellt.

Zurückgeben einer neu gebildeten Gruppe von Formen

Verwenden Sie die Group- oder die Regroup-Methode, um einen Formbereich zu gruppieren und ein einzelnes Shape-Objekt zurückzugeben, das die neu gebildete Gruppe darstellt. Nach dem Bilden einer Gruppe können Sie mit ihr auf die gleiche Weise arbeiten wie mit einer anderen Form.


Shapes-Auflistungsobjekt

Eine Auflistung aller Shape-Objekte in dem angegebenen Tabellenblatt. Jedes Shape-Objekt stellt ein Objekt in der Zeichnungsebene dar, wie z. B. eine AutoForm, eine Freihandform, ein OLE-Objekt oder ein Bild.

Anmerkung Wenn Sie mit einer Teilmenge der Formen in einem Dokument arbeiten möchten, um beispielsweise nur für die AutoFormen im Dokument oder für die markierten Formen eine Aktion durchzuführen, müssen Sie eine ShapeRange-Auflistung erstellen, die die Formen enthält, mit denen Sie arbeiten möchten. Einen Überblick über das Arbeiten mit einer einzigen Form bzw. mit mehreren Formen gleichzeitig finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwenden der Shapes-Auflistung

Verwenden Sie die Shapes-Eigenschaft, um die Shapes-Auflistung zurückzugeben. Im folgenden Beispiel werden alle Formen in myDocument markiert.

Set myDocument = Worksheets(1)
myDocument.Shapes.SelectAll

Anmerkung Wenn Sie für alle Formen in einem Tabellenblatt gleichzeitig eine Aktion durchführen möchten (wie z. B. Löschen oder Festlegen einer Eigenschaft), wählen Sie alle Formen aus, erstellen Sie mit der ShapeRange-Eigenschaft für die Auswahl ein ShapeRange-Objekt, das alle Formen in dem Tabellenblatt enthält, und wenden dann die entsprechende Eigenschaft oder Methode auf das ShapeRange-Objekt an.

Verwenden Sie Shapes(Index), wobei Index den Namen oder die Indexnummer der Form darstellt, um ein einzelnes Shape-Objekt zurückzugeben. Im folgenden Beispiel wird für die erste Form in myDocument der Füllbereich auf eine vordefinierte Form festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).Fill.PresetGradient _
    msoGradientHorizontal, 1, msoGradientBrass

Verwenden Sie Shapes.Range(Index), wobei Index den Namen oder die Indexnummer der Form oder eine Matrix mit Namen oder Indexnummern von Formen ist, um eine ShapeRange-Auflistung zurückzugeben, die eine Teilmenge der Shapes-Auflistung darstellt. Im folgenden Beispiel wird das Füllmuster für die erste und dritte Form in myDocument festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes.Range(Array(1, 3)).Fill.Patterned _
    msoPatternHorizontalBrick

Anmerkungen

Ein ActiveX-Steuerelement in einem Tabellenblatt besitzt zwei Namen: den Namen der Form, die das Steuerelement enthält, und der beim Anzeigen des Arbeitsblatts im Feld Name angezeigt wird, sowie den Codenamen für das Steuerelement, das im Fenster Eigenschaften in der Zelle rechts neben (Name) angezeigt wird. Wenn Sie ein Steuerelement zu einem Arbeitsblatt hinzufügen, stimmen Formname und Codename überein. Wenn der Formname oder der Codename geändert wird, wird der andere nicht automatisch entsprechend geändert.

Sie verwenden den Codenamen eines Steuerelements in den Namen der entsprechenden Ereignisprozeduren. Wenn Sie jedoch ein Steuerelement aus der Shapes- oder der OLEObjects-Auflistung für ein Blatt zurückgeben möchten, müssen Sie den Formnamen und nicht den Codenamen verwenden, um sich auf das Steuerelement anhand des Namens zu beziehen. Nehmen Sie beispielsweise an, dass Sie zu einem Blatt ein Kontrollkästchen hinzufügen, und sowohl der Standardformname als auch der Standardcodename "CheckBox1" lauten. Wenn Sie anschließend den Codenamen des Steuerelements ändern, indem Sie chkFinished im Fenster Eigenschaften neben (Name) eingeben, müssen Sie in den Namen von Ereignisprozeduren "chkFinished" verwenden. Sie müssen jedoch weiterhin "CheckBox1" verwenden, um das Steuerelement aus der Shapes- oder der OLEObject-Auflistung zurückzugeben, wie im folgenden Beispiel gezeigt.

Private Sub chkFinished_Click()
    ActiveSheet.OLEObjects("CheckBox1").Object.Value = 1
End Sub


ShapeNode-Objekt

Stellt die Geometrie und die Bearbeitungseigenschaften der Geometrie der Knoten in einem benutzerdefinierten Freihandobjekt dar. Knoten schließen die Scheitelpunkte zwischen den Abschnitten des Freihandobjekts und die Steuerpunkte der gekrümmten Abschnitte ein. Das ShapeNode-Objekt ist ein Element der ShapeNodes-Auflistung. Die ShapeNodes-Auflistung enthält alle Knoten eines Freihandobjekts.

Verwenden des ShapeNode-Objekts

Verwenden Sie Nodes(Index), wobei Index die Indexnummer des Knotens ist, um ein einzelnes ShapeNode-Objekt zurückzugeben. Falls es sich bei dem ersten Knoten der dritten Form in myDocument um einen Eckpunkt handelt, wird er im folgenden Beispiel zu einem Übergangspunkt gemacht. Damit das Beispiel funktioniert, muss es sich bei der dritten Form um ein Freihandobjekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeNodes-Auflistungsobjekt

Eine Auflistung aller ShapeNode-Objekte des angegebenen Freihandobjekts. Jedes ShapeNode-Objekt stellt entweder einen Knoten zwischen Abschnitten oder einen Steuerpunkt eines gekrümmten Abschnitts eines Freihandobjekts dar. Sie können ein Freihandobjekt manuell oder mit Hilfe der Methoden BuildFreeform und ConvertToShape erstellen.

Verwenden der ShapeNodes-Auflistung

Verwenden Sie die Nodes-Eigenschaft, um die ShapeNodes-Auflistung zurückzugeben. Im folgenden Beispiel wird in myDocument der vierte Knoten der dritten Form gelöscht. Damit das Beispiel funktioniert, muss es sich bei der dritten Form um ein Freihandobjekt mit mindestens vier Knoten handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).Nodes.Delete 4

Verwenden Sie die Insert-Methode um einen neuen Knoten zu erstellen und ihn der ShapeNodes-Auflistung hinzuzfügen. Im folgenden Beispiel wird in myDocument nach dem vierten Knoten der dritten Form ein Übergangsknoten mit einem gekrümmten Abschnitt eingefügt. Damit das Beispiel funktioniert, muss es sich bei der dritten Form um ein Freihandobjekt mit mindestens vier Knoten handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With

Verwenden Sie Nodes(Index), wobei Index die Indexnummer des Knotens ist, um ein einzelnes ShapeNode-Objekt zurückzugeben. Falls es sich bei dem ersten Knoten der dritten Form in myDocument um einen Eckpunkt handelt, wird er im folgenden Beispiel zu einem Übergangspunkt gemacht. Damit das Beispiel funktioniert, muss es sich bei der dritten Form um ein Freihandobjekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Nodes(1).EditingType = msoEditingCorner Then
        .Nodes.SetEditingType 1, msoEditingSmooth
    End If
End With


ShapeRange-Auflistungsobjekt

Stellt einen Formbereich dar, der aus einem Satz von Formen in einem Dokument besteht. Ein Formbereich kann aus nur einer einzigen Form oder aus beliebig vielen Formen des Dokuments bestehen. Sie können beliebige Formen aus dem Dokument oder aus der Markierung in einen Formenbereich aufnehmen. Beispielsweise könnten Sie eine ShapeRange-Auflistung bilden, die die ersten drei Formen, alle markierten Formen oder alle Freihandobjekte eines Dokuments enthält.

Einen Überblick über die Arbeit mit einer einzelnen Form oder mit mehreren Formen gleichzeitig finden Sie unter Arbeiten mit Formen (Zeichnungsobjekte).

Verwenden der ShapeRange-Auflistung

Dieser Abschnitt beschreibt:

  • Das Zurückgeben eines Satzes von Formen, die durch Name oder Indexnummer angegeben sind.

  • Das Zurückgeben aller oder einiger markierter Formen eines Dokuments.

Zurückgeben eines Satzes von Formen, die durch Name oder Indexnummer angegeben sind

Verwenden Sie Shapes.Range(Index), wobei Index der Name oder die Indexnummer der Form oder eine Matrix ist, die entweder Namen oder Indexnummern von Formen enthält, um eine ShapeRange-Auflistung zurückzugeben, die einen Satz von Formen eines Dokuments darstellt. Mit Hilfe der Array-Funktion können Sie eine Matrix mit Namen oder Indexnummern bilden. Im folgenden Beispiel wird in myDocument für die erste und dritte Form ein Füllmuster festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes.Range(Array(1, 3)).Fill.Patterned _
    msoPatternHorizontalBrick

Im folgenden Beispiel wird in myDocument für die Formen "Ellipse 4" und "Rechteck 5" ein Füllmuster festgelegt.

Set myDocument = Worksheets(1)
Set myRange = myDocument.Shapes.Range(Array("Oval 4", _
    "Rectangle 5"))
myRange.Fill.Patterned msoPatternHorizontalBrick

Sie können zwar mit Hilfe der Range-Eigenschaft eine beliebige Anzahl von Formen oder Folien zurückgeben, doch ist es einfacher, die Item-Methode zu verwenden, wenn Sie nur ein einzelnes Element der Auflistung zurückgeben möchten. Beispielsweise ist Shapes(1) einfacher als Shapes.Range(1).

Zurückgeben aller oder einiger markierter Formen eines Dokuments

Verwenden Sie die ShapeRange-Eigenschaft des Selection-Objekts, um alle Formen in der Markierung zurückzugeben. Im folgenden Beispiel wird davon ausgegangen, dass mindestens eine Form markiert ist und für alle markierten Formen im ersten Fenster die Füllfarbe des Vordergrundes festgelegt ist.

Windows(1).Selection.ShapeRange.Fill.ForeColor.RGB = _
    RGB(255, 0, 255)

Verwenden Sie Selection.ShapeRange(Index), wobei Index der Name oder die Indexnummer der Form ist, um eine einzelne Form der Markierung zurückzugeben. Im folgenden Beispiel wird davon ausgegangen, dass mindestens zwei Formen markiert sind und für die zweite Form in der Auflistung der markierten Formen im ersten Fenster die Füllfarbe des Vordergrundes festgelegt ist.

Windows(1).Selection.ShapeRange(2).Fill.ForeColor.RGB = _
    RGB(255, 0, 255)


Sheets-Auflistungsobjekt

Eine Auflistung aller Blätter in der angegebenen oder aktiven Arbeitsmappe. Die Sheets-Auflistung kann Chart-oder Worksheet-Objekte enthalten.

Über die Sheets-Auflistung kann auf Blätter eines beliebigen Typs zugegriffen werden. Sollten Sie nur mit Blättern eines bestimmten Typs arbeiten, lesen Sie unter dem betreffenden Blattyp nach.

Verwenden der Sheets-Auflistung

Verwenden Sie die Sheets-Eigenschaft zum Zugriff auf die Sheets-Auflistung. Im folgenden Beispiel werden alle Blätter der aktiven Arbeitsmappe gedruckt.

Sheets.PrintOut

Verwenden Sie die Add-Methode, um ein neues Blatt zu erstellen und dieses der Auflistung hinzuzufügen. Im folgenden Beispiel werden in der aktiven Arbeitsmappe zwei neue Diagrammblätter hinter dem zweiten Blatt eingefügt.

Sheets.Add type:=xlChart, count:=2, after:=Sheets(2)

Verwenden Sie Sheets(Index), wobei Index der Name oder die Indexnummer des Blattes ist, um ein einzelnes Chart- oder Worksheet-Objekt zurückzugeben. Im folgenden Beispiel wird das Blatt "Tabelle1" aktiviert.

Sheets("sheet1").Activate

Verwenden Sie Sheets(Matrix), um mehrere Blätter anzugeben. Im folgenden Beispiel werden die Blätter "Tabelle4" und "Tabelle5" an den Anfang der Arbeitsmappe verschoben.

Sheets(Array("Sheet4", "Sheet5")).Move before:=Sheets(1)


SoundNote-Objekt

Dieses Objekt sollte nicht benutzt werden. Audio-Notizen wurden aus Microsoft Excel entfernt.


Style-Objekt

Stellt eine Formatvorlagenbeschreibung für einen Bereich dar. Das Style-Objekt enthält alle Formatattribute (Schriftart, Zahlenformat, Ausrichtung usw.) als Eigenschaften. Es gibt eine Reihe integrierter Formatvorlagen, wie etwa "Standard", "Währung" und "Prozent". Das Style-Objekt bietet eine effiziente Möglichkeit, mehrere Formatierungseigenschaften für viele Zellen gleichzeitig zu ändern.

Für das Workbook-Objekt ist das Style-Objekt ein Element der Styles-Auflistung. Die Styles-Auflistung enthält alle definierten Formatvorlagen für die Arbeitsmappe.

Verwenden des Style-Objekts

Verwenden Sie die Style-Eigenschaft zur Rückgabe des Style-Objekts, das mit einem Range-Objekt verwendet wird. Im folgenden Beispiel wird die Formatvorlage "Prozent" den Zellen A1:A10 des Blattes "Tabelle1" zugewiesen.

Worksheets("sheet1").Range("a1:a10").Style.Name = "percent"

Sie können das Erscheinungsbild einer Zelle ändern, indem Sie Eigenschaften der Formatvorlage ändern, die der Zelle zugewiesen wurden. Beachten Sie jedoch, dass durch die Änderung einer Formatvorlageneigenschaft alle bereits mit dieser Vorlage formatierten Zellen beeinflusst werden.

Verwenden Sie Styles(Index), wobei Index die Indexnummer oder der Name der Formatvorlage ist, um ein einzelnes Style-Objekt aus der Styles-Auflistung der Arbeitsmappe zurückzugeben. Im folgenden Beispiel wird die Formatvorlage "Standard" durch Setzen der Bold-Eigenschaft geändert.

ActiveWorkbook.Styles("Normal").Font.Bold = True

Die Formatvorlagen sind alphabetisch nach dem Formatvorlagennamen sortiert. Die Indexnummer der Formatvorlagen bezieht sich auf die Position der angegebenen Formatvorlage in der sortierten Liste der Formatvorlagennamen. Styles(1) ist die erste Formatvorlage in der alphabetischen Liste, Styles(Styles.Count) die letzte.

Weitere Informationen über das Erstellen und Ändern einer Formatvorlage finden Sie unter dem Styles-Objekt.


Styles-Auflistungsobjekt

Eine Auflistung aller Style-Objekte in der angegebenen oder aktiven Arbeitsmappe. Jedes Style-Objekt stellt eine Formatvorlagenbeschreibung für einen Bereich dar. Das Style-Objekt enthält alle Formatattribute (Schriftart, Zahlenformat, Ausrichtung usw.) als Eigenschaften. Es gibt eine Reihe integrierter Formatvorlagen, wie etwa "Standard", "Währung" und "Prozent", die im Feld Formatvorlagenname des Dialogfelds Formatvorlage (Menü Format) aufgeführt sind.

Verwenden der Styles-Auflistung

Verwenden Sie die Styles-Eigenschaft zum Zugriff auf die Styles-Auflistung. Im folgenden Beispiel wird im ersten Tabellenblatt der aktiven Arbeitsmappe eine Liste von Formatvorlagennamen erstellt.

For i = 1 To ActiveWorkbook.Styles.Count
    Worksheets(1).Cells(i, 1) = ActiveWorkbook.Styles(i).Name
Next

Verwenden Sie die Add-Methode, um eine neue Formatvorlage zu erstellen und diese der Auflistung hinzuzufügen. Im folgenden Beispiel wird eine neue Formatvorlage, ausgehend von der Formatvorlage "Standard" erstellt, der Rahmen und die Schriftart geändert und anschließend die neue Formatvorlage den Zellen A25:A30 zugewiesen.

With ActiveWorkbook.Styles.Add(name:="bookman top border")
    .Borders(xlTop).LineStyle = xlDouble
    .Font.Bold = True
    .Font.Name = "bookman"
End With
Worksheets(1).Range("a25:a30").Style = "bookman top border"

Verwenden Sie Styles(Index), wobei Index die Indexnummer oder der Name der Formatvorlage ist, um ein einzelnes Style-Objekt aus der Styles-Auflistung der Arbeitsmappe zurückzugeben. Im folgenden Beispiel wird die Formatvorlage "Standard" durch Setzen der Bold-Eigenschaft geändert.

ActiveWorkbook.Styles("Normal").Font.Bold = True


TextEffectFormat-Objekt

Enthält Eigenschaften und Methoden, die für WordArt-Objekte gelten.

Verwenden des TextEffectFormat-Objekts

Verwenden Sie die TextEffect-Eigenschaft, um ein TextEffectFormat-Objekt zurückzugeben. Im folgenden Beispiel werden in myDocument für die erste Form Schriftartname und Formatierung festgelegt. Damit diese Beispiel funktioniert, muss es sich bei der ersten Form um ein WordArt-Objekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).TextEffect
    .FontName = "Courier New"
    .FontBold = True
    .FontItalic = True
End With


 TextFrame-Objekt

TextFrame-Objekt

Stellt den Textrahmen in einem Shape-Objekt dar. Enthält sowohl den Text als auch die Eigenschaften und Methoden zur Steuerung von Ausrichtung und Verankerung des Textrahmens.

Verwenden des TextFrame-Objekts

Verwenden Sie die TextFrame-Eigenschaft, um ein TextFrame-Objekt zurückzugeben. Im folgenden Beispiel wird in myDocument ein Rechteck mit Text eingefügt, und anschließend werden die Seitenränder des Textrahmens festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .Characters.Text = "Here is some test text"
    .MarginBottom = 10
    .MarginLeft = 10
    .MarginRight = 10
    .MarginTop = 10
End With


ThreeDFormat-Objekt

Stellt die dreidimensionale Formatierung einer Form dar.

Verwenden des ThreeDFormat-Objekts

Verwenden Sie die ThreeD-Eigenschaft, um ein ThreeDFormat-Objekt zurückzugeben. Im folgenden Beispiel wird in myDocument eine Ellipse eingefügt und anschließend festgelegt, dass sie auf eine Tiefe von 50 Punkt projiziert wird und die Projektionsfarbe Violett ist.

Set myDocument = Worksheets(1)
Set myShape = myDocument.Shapes.AddShape(msoShapeOval, _
    90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    ' RGB value for purple
End With

Anmerkungen

Einigen Arten von Formen, z. B. abgeschrägten Formen oder mehrfach unverbundenen Pfaden, kann keine dreidimensionale Formatierung zugewiesen werden. Die meisten Eigenschaften und Methoden des ThreeDFormat-Objekts für eine solche Form schlagen fehl.


TickLabels-Objekt

Stellt die Teilstrichbeschriftungen, die mit den Teilstrichen einer Diagrammachse verknüpft sind, dar. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Teilstrichbeschriftung darstellt; Sie müssen auf alle Teilstrichbeschriftungen gleichzeitig zugreifen.

Den Text für die Teilstrichbeschriftung der Rubrikenachse liefert der Name der jeweiligen Rubrik in dem Diagramm. Standardmäßig werden die Teilstriche der Rubrikenachse jeweils mit der Nummer beschriftet, die die Position der Rubrik von links angibt. Zur Änderung der Anzahl unbeschrifteter Teilstriche zwischen den Teilstrichbeschriftungen müssen Sie die TickLabelSpacing-Eigenschaft für die Rubrikenachse ändern.

Der Teilstrich-Beschriftungstext für die Größenachse wird auf der Grundlage der MajorUnit-, MinimumScale- und MaximumScale-Eigenschaften der Größenachse berechnet. Sie müssen die Werte dieser Eigenschaften ändern, wenn Sie den Teilstrich-Beschriftungstext für die Größenachse ändern möchten.

Verwenden des TickLabels-Objekts

Verwenden Sie die TickLabels-Eigenschaft um das TickLabels-Objekt zurückzugeben. Im folgenden Beispiel wird das Zahlenformat für die Teilstrichbeschriftungen auf der Größenachse im ersten eingebetteten Diagramm des Tabellenblatts "Sheet" festgelegt.

Worksheets("sheet1").ChartObjects(1).Chart _
    .Axes(xlValue).TickLabels.NumberFormat = "0.00"


 TreeviewControl-Objekt

TreeviewControl-Objekt

Stellt das hierarchische Steuerelement zur Auswahl von Mitgliedern eines Cube-Feldes dar. Sie verwenden dieses Objekt hauptsächlich zur Aufzeichnung von Makros; es dient keinem anderen Zweck.

Verwenden des TreeviewControl-Objekts

Verwenden Sie die TreeviewControl-Eigenschaft, um das TreeviewControl-Objekt zurückzugeben. In dem folgenden Beispiel wird das Steuerelement im zweiten PivotTable-Bericht im aktiven Tabellenblatt für die Staaten "Kalifornien" (CA) und "Maryland" (MD) in den Status "Drilled" (eingeblendet oder sichtbar) festgelegt.

ActiveSheet.PivotTables("PivotTable2") _
    .CubeFields(1).TreeviewControl.Drilled = _
        Array(Array("", ""), _
        Array("[state].[states].[CA]", _
            "[state].[states].[MD]"))


Trendline-Objekt

Stellt eine Trendlinie in einem Diagramm dar. Eine Trendlinie zeigt den Trend, d.h. den Richtungsverlauf, einer Datenreihe an. Das Trendline-Objekt ist ein Element der Trendlines-Auflistung. Die Trendlines-Auflistung enthält alle Trendline-Objekte einer einzelnen Datenreihe.

Verwenden des Trendline-Objekts

Verwenden Sie Trendlines(Index), wobei Index die Indexnummer der Trendlinie ist, um ein einzelnes Trendline-Objekt zurückzugeben. Im folgenden Beispiel wird der Trendlinientyp der ersten Datenreihe im ersten eingebetteten Diagramm des ersten Tabellenblatts geändert. Verfügt die Reihe über keine Trendlinie, lässt sich dieses Beispiel nicht ausführen.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Trendlines(1).Type = xlMovingAvg

Die Indexnummer stellt die Reihenfolge dar, in der die Trendlinien der Datenreihe hinzugefügt wurden. Trendlines(1) ist die als erste hinzugefügte Trendlinie, Trendlines(Trendlines.Count) die zuletzt hinzugefügte.


Trendlines-Auflistungsobjekt

Eine Auflistung aller Trendline-Objekte für die angegebene Datenreihe. Jedes Trendline-Objekt stellt eine Trendlinie in einem Diagramm dar. Eine Trendlinie zeigt den Trend, d.h. den Richtungsverlauf, einer Datenreihe an.

Verwenden der Trendlines-Auflistung

Verwenden Sie die Trendlines-Methode zum Zugriff auf die Trendlines-Auflistung. Im folgenden Beispiel wird die Anzahl der Trendlinien für die erste Datenreihe des ersten Diagramms angezeigt.

MsgBox Charts(1).SeriesCollection(1).Trendlines.Count

Verwenden Sie die Add-Methode, um eine neue Trendlinie zu erstellen und diese der Reihe hinzuzufügen. Im folgenden Beispiel wird der ersten Reihe im ersten eingebetteten Diagramm des Tabellenblatts "Tabelle1" eine lineare Trendlinie hinzugefügt.

Worksheets("sheet1").ChartObjects(1).Chart.SeriesCollection(1) _
    .Trendlines.Add type:=xlLinear, name:="Linear Trend"

Verwenden Sie Trendlines(Index), wobei Index die Indexnummer der Trendlinie ist, um ein einzelnes Trendline-Objekt zurückzugeben. Im folgenden Beispiel wird der Trendlinientyp der ersten Datenreihe im ersten eingebetteten Diagramm des ersten Tabellenblatts geändert. Verfügt die Reihe über keine Trendlinie, lässt sich dieses Beispiel nicht ausführen.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Trendlines(1).Type = xlMovingAvg

Die Indexnummer stellt die Reihenfolge dar, in der die Trendlinien der Datenreihe hinzugefügt wurden. Trendlines(1) ist die als erste hinzugefügte Trendlinie, Trendlines(Trendlines.Count) die zuletzt hinzugefügte.


UpBars-Objekt

Stellt die positiven Abweichungen in einer Diagrammgruppe dar. Positive Abweichungen verbinden Punkte der ersten Reihe mit höheren Werten der letzten Reihe in der Diagrammgruppe (die Linien führen von der ersten Reihe nach oben). Nur 2D-Liniengruppen, die mindestens zwei Reihen enthalten, können positive Abweichungen besitzen. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das einen einzelnen positiven Abweichungen darstellt; Sie müssen die positiven Abweichungen für alle Punkte einer Diagrammgruppe gleichzeitig ein- oder ausschalten.

Verwenden des UpBars-Objekts

Verwenden Sie die UpBars-Eigenschaft um das UpBars-Objekt zurückzugeben. Im folgenden Beispiel werden positive und negative Abweichungen für die erste Diagrammgruppe im ersten eingebetteten Diagramm des Tabellenblatts "sheet5" eingeschaltet. Anschließend wird in dem Beispiel die Farbe der positiven Abweichungen auf Blau festgelegt und die der negativen Abweichungen auf Rot.

With Worksheets("sheet5").ChartObjects(1).Chart.ChartGroups(1)
    .HasUpDownBars = True
    .UpBars.Interior.Color = RGB(0, 0, 255)
    .DownBars.Interior.Color = RGB(255, 0, 0)
End With

Anmerkungen

Weist die HasUpDownBars-Eigenschaft den Wert False auf, sind die meisten Eigenschaften des UpBars-Objekts nicht verfügbar.


Validation-Objekt

Stellt die Datenüberprüfung eines Tabellenblattbereichs dar.

Verwendung des Validation-Objekts

Verwenden Sie die Validation-Eigenschaft, um das Validation-Objekt zurückzugeben. Im folgenden Beispiel wird die Datenüberprüfung der Zelle E5 geändert.

Range("e5").Validation _
    .Modify xlValidateList, xlValidAlertStop, "=$A$1:$A$10"

Verwenden Sie die Add-Methode, um einem Bereich eine Datenüberprüfung hinzuzufügen und ein neues Validation-Objekt zu erstellen. Im folgenden Beispiel wird der Zelle E5 eine Datenüberprüfung hinzugefügt.

With Range("e5").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:=xlValidAlertInformation, _
        Minimum:="5", Maximum:="10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


VPageBreak-Objekt

Stellt einen vertikalen Seitenwechsel dar. Das VPageBreak-Objekt ist ein Mitglied der VPageBreaks-Auflistung.

Verwendung des VPageBreak-Objekts

Verwenden Sie VPageBreaks(index), wobei index die Indexnummer des Seitenwechsels ist, um ein VPageBreak-Objekt zurückzugeben. Im folgenden Beispiel wird die Position des ersten vertikalen Seitenwechsels geändert.

Worksheets(1).VPageBreaks(1).Location = Worksheets(1).Range("e5")


VPageBreaks-Auflistungsobjekt

Eine Auflistung vertikaler Seitenwechsel innerhalb des Druckbereichs. Jeder vertikale Seitenwechsel wird durch ein VPageBreak-Objekt dargestellt.

Verwendung der VPageBreaks-Auflistung

Verwenden Sie die VPageBreaks-Eigenschaft, um die VPageBreaks-Auflistung zurückzugeben. Verwenden Sie die Add-Methode, um einen vertikalen Seitenwechsel hinzuzufügen. Im folgenden Beispiel wird links von der aktiven Zelle ein vertikaler Seitenwechsel eingefügt.

ActiveSheet.VPageBreaks.Add Before:=ActiveCell

Beim Hinzufügen eines Seitenwechsels, der den Druckbereich nicht überschneidet, wird das neu hinzugefügte VPageBreak-Objekt nicht in der VPageBreak-Auflistung für den Druckbereich angezeigt. Der Inhalt der Auflistung kann sich ändern, wenn die Größe des Druckbereichs geändert oder der Druckbereich neu definiert wird.


Walls-Objekt

Stellt die Wände eines 3D-Diagramms dar. Dieses Objekt ist keine Auflistung. Es gibt kein Objekt, das eine einzelne Wand darstellt; Sie können nur auf alle Wände gleichzeitig zugreifen.

Verwenden des Walls-Objekts

Verwenden Sie die Walls-Eigenschaft, um das Walls-Objekt zurückzugeben. Im folgenden Beispiel wird das Muster der Wände für das erste eingebettete Diagramm im Tabellenblatt Sheet1 festgelegt. Das Beispiel lässt sich nur ausführen, wenn es sich um ein 3D-Diagramm handelt.

Worksheets("Sheet1").ChartObjects(1).Chart _
    .Walls.Interior.Pattern = xlGray75


WebOptions-Objekt

Enthält Attribute auf Arbeitsmappenebene, die von Microsoft Excel verwendet werden, wenn Sie ein Dokument als Webseite speichern oder eine Webseite öffnen. Sie können Attribute auf der Anwendungsebene (global) oder der Arbeitsmappenebene zurückgeben oder festlegen. (Beachten Sie, dass Attributwerte sich von einer Arbeitsmappe zur anderen unterscheiden können; dies hängt von dem Attributwert zum Zeitpunkt des Speicherns der Arbeitsmappe ab.) Attributeinstellungen auf Arbeitsmappenebene überschreiben die Attributeinstellungen auf Anwendungsebene. Die Attribute auf Anwendungsebene befinden sich im DefaultWebOptions-Objekt.

Verwenden des WebOptions-Objekts

Verwenden Sie die WebOptions-Eigenschaft, um das WebOptions-Objekt zurückzugeben. Im folgenden Beispiel wird überprüft, ob PNG (Portable Network Graphics) als Bildformat zulässig ist; anschließend wird die Variable strImageFileType entsprechend eingestellt.

Set objAppWebOptions = Workbooks(1).WebOptions
With objAppWebOptions
    If .AllowPNG = True Then
        strImageFileType = "PNG"
    Else
        strImageFileType = "JPG"
    End If
End With


Window-Objekt

Stellt ein Fenster dar. Viele Tabellenblattelemente, wie Bildlaufleisten und Gitternetzlinien, sind in Wirklichkeit Eigenschaften des Fensters. Das Window-Objekt ist ein Element der Windows-Auflistung. Die Windows-Auflistung für das Application-Objekt enthält alle Fenster der Anwendung, während die Windows-Auflistung für das Workbook-Objekt nur die Fenster in der angegebenen Arbeitsmappe enthält.

Verwenden des Window-Objekts

Verwenden Sie Windows(Index), wobei Index der Name oder die Indexnummer des Fensters ist, um ein einzelnes Window-Objekt zurückzugeben. Im folgenden Beispiel wird das aktive Fenster maximiert.

Windows(1).WindowState = xlMaximized

Beachten Sie, dass das aktive Fenster immer Windows(1) ist.

Die Fensterbeschriftung ist der Text, der in der Titelleiste oben im Fenster angezeigt wird, wenn das Fenster nicht maximiert ist. Die Beschriftung wird auch in der Liste der geöffneten Dateien unten im Menü Fenster angezeigt. Verwenden Sie die Caption-Eigenschaft, um die Fensterbeschriftung festzulegen oder zurückzugeben. Eine Änderung der Fensterbeschriftung hat keine Auswirkung auf den Namen der Arbeitsmappe. Im folgenden Beispiel werden die Zellgitternetzlinien für das Tabellenblatt ausgeschaltet, das im Fenster "Book1.xls:1" angezeigt wird.

Windows("book1.xls":1).DisplayGridlines = False


Windows-Auflistungsobjekt

Eine Auflistung aller Window-Objekte in Microsoft Excel. Die Windows-Auflistung für das Application-Objekt enthält alle Fenster der Anwendung, während die Windows-Auflistung für das Workbook-Objekt nur die Fenster in der angegebenen Arbeitsmappe umfasst.

Verwenden der Windows-Auflistung

Verwenden Sie die Windows-Eigenschaft zum Zugriff auf die Windows-Auflistung. Im folgenden Beispiel werden alle derzeit in Microsoft Excel angezeigten Fenster überlappend angeordnet.

Windows.Arrange arrangeStyle:=xlCascade

Verwenden Sie die NewWindow-Methode, um ein neues Fenster zu erstellen und dieses der Auflistung hinzuzufügen. Im folgenden Beispiel wird ein neues Fenster für die aktive Arbeitsmappe erstellt.

ActiveWorkbook.NewWindow

Verwenden Sie Windows(Index), wobei Index der Name oder die Indexnummer des Fensters ist, um ein einzelnes Window-Objekt zurückzugeben. Im folgenden Beispiel wird das aktive Fenster maximiert.

Windows(1).WindowState = xlMaximized

Beachten Sie, dass das aktive Fenster immer Windows(1) ist.


Workbook-Objekt

Stellt eine Microsoft Excel-Arbeitsmappe dar. Das Workbook-Objekt ist ein Element der Workbooks-Auflistung. Die Workbooks-Auflistung enthält alle derzeit in Microsoft Excel geöffneten Workbook-Objekte.

Verwenden des Workbook-Objekts

In diesem Abschnitt werden die folgenden Eigenschaften zur Rückgabe eines Workbook-Objekts beschrieben:

  • Workbooks-Eigenschaft

  • ActiveWorkbook-Eigenschaft

  • ThisWorkbook-Eigenschaft

Workbooks-Eigenschaft

Verwenden Sie Workbooks(Index), wobei Index der Name oder die Indexnummer der Arbeitsmappe ist, um ein einzelnes Workbook-Objekt zurückzugeben. Im folgenden Beispiel wird die erste Arbeitsmappe aktiviert.

Workbooks(1).Activate

Die Indexnummer gibt die Reihenfolge an, in der die Arbeitsmappen geöffnet oder erstellt wurden. Workbooks(1) ist die zuerst erstellte Arbeitsmappe, Workbooks(Workbooks.Count) die zuletzt erstellte. Durch das Aktivieren einer Arbeitsmappe wird ihre Indexnummer nicht geändert. Alle Arbeitsmappen sind in der Nummerierung enthalten, auch dann, wenn sie ausgeblendet sind.

Die Name-Eigenschaft gibt den Arbeitsmappennamen zurück. Es ist nicht möglich, den Namen mittels dieser Eigenschaft festzulegen. Wenn Sie den Namen ändern müssen, speichern Sie die Arbeitsmappe mit der SaveAs-Methode unter einem anderen Namen. Im folgenden Beispiel wird das Tabellenblatt Sheet1 in der Arbeitsmappe "Cogs.xls" aktiviert (die Arbeitsmappe muss bereits in Microsoft Excel geöffnet sein).

Workbooks("cogs.xls").Worksheets("sheet1").Activate

ActiveWorkbook-Eigenschaft

Die ActiveWorkbook-Eigenschaft gibt die derzeit aktive Arbeitsmappe zurück. Im folgenden Beispiel wird der Name des Autors für die aktive Arbeitsmappe festgelegt.

ActiveWorkbook.Author = "Jean Selva"

ThisWorkbook-Eigenschaft

Die ThisWorkbook-Eigenschaft gibt die Arbeitsmappe zurück, in der der Visual Basic-Code ausgeführt wird. Meist ist diese mit der aktiven Arbeitsmappe identisch. Ist allerdings der Visual Basic-Code Teil eines Add-Ins, gibt die ThisWorkbook-Eigenschaft nicht die aktive Arbeitsmappe zurück. In diesem Fall ist die aktive Arbeitsmappe diejenige, die das Add-In aufruft, während die ThisWorkbook-Eigenschaft die Add-In-Arbeitsmappe zurückgibt.

Wenn Sie ein Add-In aus Ihrem Visual Basic-Code erstellen möchten, sollten Sie alle Anweisungen mit der ThisWorkbook-Eigenschaft qualifizieren, die in der Arbeitsmappe ausgeführt werden müssen, die Sie in das Add-In umwandeln.


Workbooks-Auflistungsobjekt

Eine Auflistung aller Workbook-Objekte, die momentan in der Anwendung Microsoft Excel geöffnet sind.

Verwenden der Workbooks-Auflistung

Verwenden Sie die Workbooks-Eigenschaft zum Zugriff auf die Workbooks-Auflistung. Im folgenden Beispiel werden alle geöffneten Arbeitsmappen geschlossen.

Workbooks.Close

Verwenden Sie die Add-Methode, um eine neue, leere Arbeitsmappe zu erstellen und diese der Auflistung hinzuzufügen. Im folgenden Beispiel wird Microsoft Excel eine neue, leere Arbeitsmappe hinzugefügt.

Workbooks.Add

Verwenden Sie die Open-Methode, um eine Datei zu öffnen. Dadurch wird eine neue Arbeitsmappe für die geöffnete Datei erstellt. Im folgenden Beispiel wird die Datei "Array.xls" als schreibgeschützte Arbeitsmappe geöffnet.

Workbooks.Open fileName:="array.xls", readOnly:=True

Weitere Informationen über das Verwenden eines einzelnen Workbook-Objekts finden Sie unter dem Workbook-Objekt.


Worksheet-Objekt

Stellt ein Tabellenblatt dar. Das Worksheet-Objekt ist ein Element der Worksheets-Auflistung. Die Worksheets-Auflistung enthält alle Worksheet-Objekte einer Arbeitsmappe.

Verwenden des Worksheet-Objekts

In diesem Abschnitt werden folgende Eigenschaften zur Rückgabe eines Worksheet-Objekts beschrieben:

  • Worksheets-Eigenschaft

  • ActiveSheet-Eigenschaft

Worksheets-Eigenschaft

Verwenden Sie Worksheets(Index), wobei Index die Indexnummer oder der Name des Tabellenblatts ist, um ein einzelnes Worksheet-Objekt zurückzugeben. Im folgenden Beispiel wird das erste Tabellenblatt der aktiven Arbeitsmappe ausgeblendet.

Worksheets(1).Visible = False

Die Tabellenblatt-Indexnummer gibt die Position des Tabellenblatts in der Registerleiste der Arbeitsmappe an. Worksheets(1) ist das erste Tabellenblatt der Arbeitsmappe (von links), Worksheets(Worksheets.Count) das letzte. Alle Tabellenblätter sind in der Nummerierung enthalten, auch dann, wenn sie ausgeblendet sind.

Der Tabellenblattname steht auf dem Register für das Tabellenblatt. Verwenden Sie die Name-Eigenschaft, um den Tabellenblattnamen festzulegen oder zurückzugeben. Im folgenden Beispiel werden die Szenarios im Tabellenblatt Sheet1 geschützt.

Worksheets("sheet1").Protect password:="drowssap", scenarios:=True

Das Worksheet-Objekt ist auch ein Element der Sheets-Auflistung. Die Sheets-Auflistung enthält alle Blätter der Arbeitsmappe (Diagrammblätter wie auch Tabellenblätter).

ActiveSheet-Eigenschaft

Auf das aktive Blatt können Sie sich mit der ActiveSheet-Eigenschaft beziehen. Im folgenden Beispiel wird die Activate-Methode verwendet, um das Tabellenblatt Sheet1 zu aktivieren, die Seitenausrichtung auf Querformat zu setzen und das Tabellenblatt zu drucken.

Worksheets("sheet1").Activate
ActiveSheet.PageSetup.Orientation = xlLandscape
ActiveSheet.PrintOut


Worksheets-Auflistungsobjekt

Eine Auflistung aller Worksheet-Objekte in der angegebenen oder aktiven Arbeitsmappe. Jedes Worksheet-Objekt stellt ein Tabellenblatt dar.

Verwenden der Worksheets-Auflistung

Verwenden Sie die Worksheets-Eigenschaft zum Zugriff auf die Worksheets-Auflistung. Im folgenden Beispiel werden alle Tabellenblätter an das Ende der Arbeitsmappe verschoben.

Worksheets.Move after:=Sheets(Sheets.Count)

Verwenden Sie die Add-Methode, um ein neues Tabellenblatt zu erstellen und dieses der Auflistung hinzuzufügen. Im folgenden Beispiel werden zwei neue Tabellenblätter vor dem ersten Blatt der aktiven Arbeitsmappe eingefügt.

Worksheets.Add count:=2, before:=Sheets(1)

Verwenden Sie Worksheets(Index), wobei Index die Indexnummer oder der Name des Tabellenblatts ist, um ein einzelnes Worksheet-Objekt zurückzugeben. Im folgenden Beispiel wird das erste Tabellenblatt der aktiven Arbeitsmappe ausgeblendet.

Worksheets(1).Visible = False

Das Worksheet ist auch ein Element der Sheets-Auflistung. Die Sheets-Auflistung enthält alle Blätter (Diagrammblätter wie auch Tabellenblätter) der Arbeitsmappe.


WorksheetFunction-Objekt

Wird als Container für Tabellenfunktionen von Microsoft Excel verwendet, die aus Visual Basic aufgerufen werden können.

Verwenden des WorksheetFunction-Objekts

Verwenden Sie WorksheetFunction-Eigenschaft, um das WorksheetFunction-Objekt zurückzugeben. Im folgenden Beispiel wird das Ergebnis der Anwendung der Tabellenfunktion Min auf den Bereich A1:A10 angezeigt.

Set myRange = Worksheets("Sheet1").Range("A1:C10")
answer = Application.WorksheetFunction.Min(myRange)
MsgBox answer


Neue Eigenschaften (nach Objekten geordnet)

In Microsoft Excel 2000 wurden viele neuen Visual Basic für Applikationen-Eigenschaften zu vorhandenen Objekten hinzugefügt. Diese Eigenschaften sind in der folgenden Tabelle aufgeführt (nach dem Namen des Objekts sortiert).

Objekt | Eigenschaften
Application | AnswerWizard, AutoPercentEntry, CalculationVersion, COMAddIns, DefaultWebOptions, ExtendList, FeatureInstall, LanguageSettings, OLEDBErrors, ProductCode, ShowWindowsInTaskbar, UserLibraryPath
Axis | DisplayUnit, DisplayUnitCustom, DisplayUnitLabel, HasDisplayUnitLabel
Chart | HasPivotFields, PivotLayout, Scripts
DataLabel | NumberFormatLocal
DataLabels | NumberFormatLocal
Hyperlink | EmailSubject, ScreenTip, TextToDisplay
OLEObject | AltHTML
OLEObjects | AltHTML
Parameter | RefreshOnChange
PivotCache | CommandText, CommandType, LocalConnection, MaintainConnection, QueryType, Recordset, RefreshPeriod, UseLocalConnection
PivotField | Caption, CubeField, CurrentPageName, DragToData, DrilledDown, LayoutBlankLine, LayoutForm, LayoutPageBreak, LayoutSubtotalLocation, SubtotalName, Subtotals
PivotItem | Caption, DrilledDown
PivotTable | CubeFields, GrandTotalName, PrintTitles, RepeatItemsOnEachPrintedPage, SmallGrid
QueryTable | AdjustColumnWidth, CommandText, CommandType, MaintainConnection, PreserveColumnInfo, PreserveFormatting, QueryType, RefreshPeriod, TextFileColumnDataTypes, TextFileCommaDelimiter, TextFileConsecutiveDelimiter, TextFileDecimalSeparator, TextFileFixedColumnWidths, TextFileOtherDelimiter, TextFileParseType, TextFilePlatform, TextFilePromptOnRefresh, TextFileSemicolonDelimiter, TextFileSpaceDelimiter, TextFileStartRow, TextFileTabDelimiter, TextFileTextQualifier, TextFileThousandsSeparator, WebConsecutiveDelimitersAsOne, WebDisableDateRecognition, WebFormatting, WebPreFormattedTextToColumns, WebSelectionType, WebSingleBlockTextImport, WebTables
Range | ID, Phonetics
Shape | AlternativeText, Script
ShapeRange | AlternativeText
TickLabels | Alignment, Depth, NumberFormatLocal, Offset
Workbook | CalculationVersion, EnvelopeVisible, HTMLProject, PublishObjects, VBASigned, WebOptions
Worksheet | DisplayRightToLeft, Scripts


Accent-Eigenschaft

True, wenn Legendentext und Legendenlinie durch eine Markierungsleiste voneinander getrennt sind. Long Schreib-Lese-Zugriff.


Beispiel zur Accent-Eigenschaft

In diesem Beispiel werden eine Ellipse und eine Legende, die auf die Ellipse zeigt, in myDocument eingefügt. Der Legendentext besitzt keinen Rahmen, jedoch eine vertikale Markierungsleiste, durch die er von der Legendenlinie getrennt wird.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.Characters.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


AcceptLabelsInFormulas-Eigenschaft

True, wenn Beschriftungen in Tabellenblattformeln benutzt werden können. Der Standardwert lautet True. Boolean Schreib-Lese-Zugriff.


Beispiel zur AcceptLabelsInFormulas-Eigenschaft

In diesem Beispiel wird die AcceptLabelsInFormulas-Eigenschaft für die aktive Arbeitsmappe festgelegt, und dann werden die Zellen B1:D1 in Tabellenblatt 1 als Spaltenbeschriftungen bestimmt.

ActiveWorkbook.AcceptLabelsInFormulas = True
Worksheets(1).Range("b1:d1").FormulaLabel = xlColumnLabels


ActiveCell-Eigenschaft

Diese Eigenschaft gibt ein Range-Objekt zurück, das die aktive Zelle entweder im aktiven Fenster (das Fenster im Vordergrund) oder im angegebenen Fenster repräsentiert. Wird im betreffenden Fenster kein Tabellenblatt angezeigt, führt diese Eigenschaft zu einem Fehler. Schreibgeschützt.

Anmerkungen

Wenn Sie keinen Objektkennzeichner angeben, gibt diese Eigenschaft die aktive Zelle des aktiven Fensters zurück.

Achten Sie darauf, dass Sie zwischen der aktiven Zelle und der Markierung unterscheiden. Unter der aktiven Zelle versteht man eine einzelne Zelle innerhalb der aktuellen Markierung. Eine Markierung kann mehrere Zellen umfassen, von denen aber nur eine die aktive Zelle ist.

Die folgenden Ausdrücke sind gleichbedeutend. Sie geben als Ergebnis jeweils die aktive Zelle zurück.

ActiveCell
Application.ActiveCell
ActiveWindow.ActiveCell
Application.ActiveWindow.ActiveCell


Beispiel zur ActiveCell-Eigenschaft

Dieses Beispiel verwendet ein Meldungsfeld, um den Wert der aktiven Zelle anzuzeigen. Da die ActiveCell-Eigenschaft zu einem Fehler führt, wenn das aktive Blatt kein Tabellenblatt ist, wird im Beispiel zunächst Sheet1 geöffnet und erst danach die ActiveCell-Eigenschaft angewendet.

Worksheets("Sheet1").Activate
MsgBox ActiveCell.Value

Das nächste Beispiel ändert die Schriftformatierung der aktiven Zelle.

Worksheets("Sheet1").Activate
With ActiveCell.Font
    .Bold = True
    .Italic = True
End With


ActiveChart-Eigenschaft

Gibt ein Chart-Objekt zurück, das das aktive Diagramm (entweder ein eingebettetes Diagramm oder ein Diagrammblatt) darstellt. Ein eingebettetes Diagramm ist aktiv, wenn es entweder markiert oder aktiviert ist. Wenn kein Diagramm aktiv ist, gibt diese Eigenschaft Nothing zurück. Schreibgeschützt.

Anmerkungen

Wenn Sie keinen Objektkennzeichner angeben, gibt diese Eigenschaft das aktive Diagramm in der aktiven Arbeitsmappe zurück.


Beispiel zur ActiveChart-Eigenschaft

In diesem Beispiel wird die Legende für das aktive Diagramm eingeblendet.

ActiveChart.HasLegend = True


ActivePane-Eigenschaft

Gibt ein Pane-Objekt zurück, das den aktiven Ausschnitt des Fensters darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft kann nur in Tabellenblättern und Makroblättern verwendet werden.

Diese Eigenschaft gibt ein Pane-Objekt zurück. Wenn Sie den Index des aktiven Ausschnitts erhalten möchten, müssen Sie die Index-Eigenschaft verwenden.


Beispiel zur ActivePane-Eigenschaft

In diesem Beispiel wird der nächste Ausschnitt im aktiven Fenster von BOOK1.XLS aktiviert. Sie können den nächsten Abschnitt nicht aktivieren, wenn die Abschnitte fixiert sind. Sie müssen das Beispiel von einer anderen Arbeitsmappe als BOOK1.XLS starten. Stellen Sie sicher, dass das aktive Tabellenblatt von BOOK1.XLS entweder zwei oder vier Ausschnitte enthält, bevor Sie das Beispiel ausführen.

Workbooks("BOOK1.XLS").Activate
If not ActiveWindow.FreezePanes Then
    With ActiveWindow
        i = .ActivePane.Index
        If i = .Panes.Count Then
            .Panes(1).Activate
        Else
            .Panes(i+1).Activate
        End If
    End With
End If


ActivePrinter-Eigenschaft

Diese Eigenschaft gibt den Namen des aktiven Druckers zurück oder stellt ihn ein. String Schreib-Lese-Zugriff.


Beispiel zur ActivePrinter-Eigenschaft

Das folgende Beispiel zeigt den Namen des aktiven Druckers an.

MsgBox "The name of the active printer is " & _
    Application.ActivePrinter


ActiveSheet-Eigenschaft

Gibt ein Objekt zurück, das das aktuelle Blatt (das oberste Blatt) in der aktiven oder angegebenen Arbeitsmappe bzw. im angegebenen Fenster darstellt. Ist kein Blatt aktiv, wird Nothing zurückgegeben. Schreibgeschützt.

Anmerkungen

Wenn Sie keinen Objektkennzeichner angeben, gibt diese Eigenschaft das aktive Blatt in der aktiven Arbeitsmappe zurück.

Wenn eine Arbeitsmappe in mehreren Fenstern erscheint, kann die ActiveSheet-Eigenschaft in verschiedenen Fenstern unterschiedliche Werte haben.


Beispiel zur ActiveSheet-Eigenschaft

In diesem Beispiel wird der Name des aktiven Blattes angezeigt.

MsgBox "The name of the active sheet is " & ActiveSheet.Name


ActiveWindow-Eigenschaft

Gibt ein Window-Objekt zurück, das das aktive Fenster (das Fenster im Vordergrund) repräsentiert. Schreibgeschützt. Sind keine Fenster geöffnet, wird als Ergebnis Nothing zurückgegeben.


Beispiel zur ActiveWindow-Eigenschaft

Dieses Beispiel zeigt den Namen (Caption-Eigenschaft) des aktiven Fensters an.

MsgBox "The name of the active window is " & ActiveWindow.Caption


ActiveWorkbook-Eigenschaft

Gibt ein Workbook-Objekt zurück, das die Arbeitsmappe im aktiven Fenster (das Fenster im Vordergrund) repräsentiert. Schreibgeschützt. Sind keine Fenster geöffnet oder ist das aktive Fenster das Info- oder Zwischenablagefenster, so wird Nothing zurückgegeben.


Beispiel zur ActiveWorkbook-Eigenschaft

Das folgende Beispiel zeigt den Namen der aktiven Arbeitsmappe an.

MsgBox "The name of the active workbook is " & ActiveWorkbook.Name


AddIndent-Eigenschaft

True, wenn Text automatisch eingezogen wird, sofern die Textausrichtung in einer Zelle horizontal oder vertikal auf gleich verteilt festgelegt ist. Variant Schreib-Lese-Zugriff.

Anmerkungen

Um die Textausrichtung auf gleiche Verteilung festzulegen, können Sie die VerticalAlignment-Eigenschaft auf xlVAlignDistributed festlegen, wenn der Wert der Orientation-Eigenschaft xlVertical ist, und Sie können die HorizontalAlignment-Eigenschaft auf xlHAlignDistributed festlegen, wenn der Wert der Orientation-Eigenschaft xlHorizontal ist.


Beispiel zur AddIndent-Eigenschaft

In diesem Beispiel wird die horizontale Ausrichtung für den Text in Zelle "A1" in Sheet1 auf gleiche Verteilung festgelegt, und der Text anschließend eingezogen.

With Worksheets("Sheet1").Range("A1")
    .HorizontalAlignment = xlHAlignDistributed
    .AddIndent = True
End With


AddIns-Eigenschaft

Gibt eine AddIns-Auflistung zurück, die alle im Dialogfeld Add-Ins (Menü Extras) aufgeführten Add-Ins darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Methode ohne einen Objektkennzeichner hat die gleiche Funktion wie Application.Addins.


Beispiel zur AddIns-Eigenschaft

In diesem Beispiel wird der Status des Add-Ins Analyse-Funktionen angezeigt. Die als Index für die AddIns-Auflistung verwendete Zeichenfolge ist der Titel des Add-Ins, nicht der Dateiname des Add-Ins.

If AddIns("Analysis ToolPak").Installed = True Then
    MsgBox "Analysis ToolPak add-in is installed"
Else
    MsgBox "Analysis ToolPak add-in is not installed"
End If


Address-Eigenschaft

Hyperlink-Objekt (Syntax 1): Gibt die Adresse des Zieldokuments zurück oder legt sie fest. String Schreib-Lese-Zugriff.

Range-Objekt (Syntax 2): Gibt den Bezug auf einen Bereich in der Sprache des Makros zurück. String Schreibgeschützt.

Syntax 1

Ausdruck.Address

Syntax 2

Ausdruck.Address(RowAbsolute, ColumnAbsolute, ReferenceStyle, External, RelativeTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Hyperlink-Objekt (Syntax 1) oder ein Range-Objekt (Syntax 2) zurückgibt.

RowAbsolute Variant optional. Ist das Argument True, wird der Bezugsteil mit der Zeilenangabe als absoluter Bezug zurückgegeben. Die Voreinstellung ist True.

ColumnAbsolute Variant optional. Ist das Argument True, wird der Bezugsteil mit der Spaltenangabe als absoluter Bezug zurückgegeben. Die Voreinstellung ist True.

ReferenceStyle Variant optional. Kann eine der folgenden XlReferenceStyle-Konstanten sein: xlA1 oder xlR1C1. Verwenden Sie xlA1, um einen Bezug in der A1-Schreibweise zurückzugeben. Verwenden Sie xlR1C1, um einen Bezug in der Z1S1-Schreibweise zurückzugeben. Die Voreinstellung ist xlA1

External Variant optional. Ist das Argument True, wird ein externer Bezug zurückgegeben. Ist das Argument False, wird ein lokaler Bezug zurückgegeben. Die Voreinstellung ist False.

RelativeTo Variant optional. Sind RowAbsolute und ColumnAbsolute beide False und wird für ReferenceStyle der Wert xlR1C1 angegeben, müssen Sie einen Startpunkt für den relativen Bezug angeben. Dieses Argument ist ein Range-Objekt und definiert den Startpunkt.

Anmerkungen

Enthält der Bezug mehrere Zellen, so beziehen sich RowAbsolute und ColumnAbsolute auf alle Zeilen und Spalten.


AddressLocal-Eigenschaft

Gibt den Bereichsbezug für den angegebenen Bereich in der Sprache des Benutzers oder der Benutzerin zurück. String Schreibgeschützt.

Syntax

Ausdruck.AddressLocal(RowAbsolute, ColumnAbsolute, ReferenceStyle, External, RelativeTo)

RowAbsolute Variant optional. Wenn True, wird der Bezugsteil mit der Zeilenangabe als absoluter Bezug zurückgegeben. Die Voreinstellung ist True.

ColumnAbsolute Variant optional. Wenn True, wird der Bezugsteil mit der Spaltenangabe als absoluter Bezug zurückgegeben. Die Voreinstellung ist True.

ReferenceStyle Variant optional. Kann eine der folgenden XlReferenceStyle-Konstanten sein: xlA1 oder xlR1C1. Verwenden Sie xlA1, um einen Bezug in der A1-Schreibweise zurückzugeben, oder verwenden Sie xlR1C1, um einen Bezug in der Z1S1-Schreibweise zurückzugeben. Die Standardkonstante ist xlA1.

External Variant optional. Wenn True, wird ein externer Bezug zurückgegeben. Wenn False, wird ein lokaler Bezug zurückgegeben. Die Voreinstellung ist False.

RelativeTo Variant optional. Sind RowAbsolute und ColumnAbsolute beide auf False eingestellt, und ist ReferenceStyle auf xlR1C1 festgelegt, müssen Sie einen Startpunkt für den relativen Bezug angeben. Dieses Argument ist ein Range-Objekt und definiert den Startpunkt für den Bezug.

Anmerkungen

Enthält der Bezug mehrere Zellen, so beziehen sich RowAbsolute und ColumnAbsolute auf alle Zeilen bzw. alle Spalten.


Beispiel zur AddressLocal-Eigenschaft

Gehen Sie davon aus, dass das folgende Beispiel mit der deutschen Sprachunterstützung erstellt und dann mit der US-amerikanischen Sprachunterstützung ausgeführt wurde. Das Makro zeigt den in den Kommentaren aufgeführten Text an.

Set mc = Worksheets(1).Cells(1, 1)
MsgBox mc.AddressLocal()                         ' $A$1
MsgBox mc.AddressLocal(RowAbsolute:=False)       ' $A1
MsgBox mc.AddressLocal(ReferenceStyle:=xlR1C1)   ' Z1S1
MsgBox mc.AddressLocal(ReferenceStyle:=xlR1C1, _
    RowAbsolute:=False, _
    ColumnAbsolute:=False, _
    RelativeTo:=Worksheets(1).Cells(3, 3))       ' Z(-2)S(-2)


AdjustColumnWidth-Eigenschaft

True, wenn die Spaltenbreiten beim Aktualisieren einer Abfragetabelle immer automatisch optimal angepasst werden. False, wenn die Spaltenbreiten bei einer Aktualisierung nicht automatisch angepasst werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die maximale Spaltenbreite beträgt Zweidrittel der Fensterbreite.


Beispiel zur AdjustColumnWidth-Eigenschaft

In diesem Beispiel wird die automatische Anpassung der Spaltenbreite für die neu hinzugefügte Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe deaktiviert.

With Workbooks(1).Worksheets(1).QueryTables _
    .Add(Connection:= varDBConnStr, _
        Destination:=Range("B1"), _
        Sql:="Select Price From CurrentStocks " & _
            "Where Symbol = 'MSFT'")
    .AdjustColumnWidth = False
    .Refresh
End With


Adjustments-Eigenschaft

Gibt ein Adjustments-Objekt zurück, das Anpassungswerte für alle Anpassungen der angegebenen Form enthält. Gilt für jedes Shape- oder ShapeRange-Objekt, das eine AutoForm, eine WordArt oder eine Verbindung darstellt. Schreibgeschützt.


Beispiel zur Adjustments-Eigenschaft

In diesem Beispiel wird in myDocument der ersten Anpassung der ersten Form der Wert 0,25 zugewiesen.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).Adjustments(1) = 0.25


AlertBeforeOverwriting-Eigenschaft

True, wenn Microsoft Excel eine Meldung einblendet, bevor nicht leere Zellen während einer Drag & Drop-Operation überschrieben werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AlertBeforeOverwriting-Eigenschaft

In diesem Beispiel wird von Microsoft Excel eine Warnung eingeblendet, bevor mit einer Drag & Drop-Operation nicht leere Zellen überschrieben werden.

Application.AlertBeforeOverwriting = True


AlertStyle-Eigenschaft

Gibt den Stil der Gültigkeitswarnung zurück. Dabei kann es sich um eine der folgenden XlDVAlertStyle-Konstanten handeln: xlValidAlertInformation, xlValidAlertStop oder xlValidAlertWarning. Long Schreibgeschützt.

Anmerkungen

Mit der Add-Methode legen Sie einen Warnungstil für einen Bereich fest. Wurde der Bereich bereits mit einer Validierung versehen, ändern Sie den Warnungstil mit der Modify-Methode.


Beispiel zur AlertStyle-Eigenschaft

In diesem Beispiel wird der Warungsstil für E5 angezeigt.

MsgBox Range("e5").Validation.AlertStyle


Alignment-Eigenschaft

Gibt die Ausrichtung für den angegebenen phonetischen Text, die angegebene Teilstrichbeschriftung oder die angegebene WordArt zurück oder legt diese fest.

Bei phonetischem Text kann diese Eigenschaft eine der folgenden XlPhoneticAlignment-Konstanten sein: xlPhoneticAlignCenter, xlPhoneticAlignDistributed, xlPhoneticAlignLeft oder xlPhoneticAlignNoControl.

Bei Teilstrichbeschriftungen kann diese Eigenschaft eine der folgenden XlHAlign-Konstanten sein: xlHAlignCenter, xlHAlignLeft oder xlHAlignRight.

Bei WordArt-Objekten kann diese Eigenschaft eine der folgenden MsoTextEffectAlignment-Konstanten sein: msoTextEffectAlignmentCentered, msoTextEffectAlignmentLeft, msoTextEffectAlignmentLetterJustify, msoTextEffectAlignmentMixed, msoTextEffectAlignmentRight, msoTextEffectAlignmentStretchJustify oder msoTextEffectAlignmentWordJustify. Schreib-Lese-Zugriff Long.


Beispiel zur Alignment-Eigenschaft

In diesem Beispiel wird dem ersten Tabellenblatt ein WordArt-Objekt hinzugefügt und anschließend rechtsbündig ausgerichtet.

Set mySh = Worksheets(1).Shapes
Set myTE = mySh.AddTextEffect(PresetTextEffect:=msoTextEffect1, _
    Text:="Test Text", FontName:="Palatino", FontSize:=54, _
    FontBold:=True, FontItalic:=False, Left:=100, Top:=50)
myTE.TextEffect.Alignment = msoTextEffectAlignmentRight


AllowPNG-Eigenschaft

True, falls PNG (Portable Network Graphics) als Bildformat beim Speichern von Dokumenten als Webseite zugelassen ist. False, wenn PNG nicht als Ausgabeformat zugelassen ist. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Beim Speichern von Bildern im PNG-Format kann im Gegensatz zu anderen Dateiformaten die Bildqualität verbessert oder die Größe der entsprechenden Bilddateien reduziert und somit die Downloadzeit verringert werden, sofern die Zielwebbrowser das PNG-Format unterstützen.


Beispiel zur AllowPNG-Eigenschaft

In diesem Beispiel wird PNG als Ausgabeformat für die erste Arbeitsmappe zugelassen.

Application.Workbooks(1).WebOptions.AllowPNG = True

Alternativ kann PNG bei neu erstellten Dokumenten als globales Standardformat für die Anwendung aktiviert werden.

Application.DefaultWebOptions.AllowPNG = True


AlternativeText-Eigenschaft

Gibt die beschreibende (alternative) Zeichenfolge für ein Shape- oder ShapeRange-Objekt zurück, wenn das Objekt in einer Webseite gespeichert wird, oder legt diese fest. String Schreib-Lese-Zugriff.

Anmerkungen

Der alternative Text kann im Webbrowser entweder an Stelle des Bilds, der Form oder direkt über dem Bild angezeigt werden, wenn sich der Mauszeiger über dem Bild befindet (sofern der Browser diese Features unterstützt).


Beispiel zur AlternativeText-Eigenschaft

In diesem Beispiel wird der alternative Text für die erste Form im ersten Tabellenblatt auf eine Beschreibung der Form festgelegt.

Worksheets(1).Shapes(1).AlternativeText = "Concentric circles"


AltHTML-Eigenschaft

Gibt den alternativen HTML-Code zurück, der beim Speichern des Dokuments als Webseite an Stelle eines oder mehrerer ActiveX-Steuerelemente oder OLE-Objekte angezeigt wird, oder legt diesen fest. Der alternative HTML-Code wird dann verwendet, wenn der Webbrowser keine ActiveX-Steuerelemente oder OLE-Objekte unterstützt. String Schreib-Lese-Zugriff.


Beispiel zur AltHTML-Eigenschaft

In diesem Beispiel wird ein Textabsatz als alternativer HTML-Code für ein Listenfeld im aktiven Tabellenblatt festgelegt.

ActiveSheet.OLEObjects("ListBox1").AltHTML = "<P>List box</P>"


AltStartupPath-Eigenschaft

Diese Eigenschaft gibt den Namen des alternativen Startordners zurück bzw. legt diesen fest. String Schreib-Lese-Zugriff.


Beispiel zur AltStartupPath-Eigenschaft

Dieses Beispiel legt den alternativen Startordner fest.

Application.AltStartupPath = "C:\EXCEL\MACROS"


AlwaysSaveInDefaultEncoding-Eigenschaft

True, wenn beim Speichern einer Webseite oder eines Textdokuments die Standardcodierung verwendet wird, unabhängig von der ursprünglichen Codierung der Datei beim Öffnen. False, wenn die ursprüngliche Codierung der Datei verwendet wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Mit Hilfe der Encoding-Eigenschaft kann die Standardcodierung festgelegt werden.


Beispiel zur AlwaysSaveInDefaultEncoding-Eigenschaft

In diesem Beispiel wird die Codierung auf die Standardcodierung eingestellt. Die Codierung wird beim Speichern des Dokuments als Webseite verwendet.

Application.DefaultWebOptions.AlwaysSaveInDefaultEncoding = True


Angle-Eigenschaft

Gibt den Winkel der Legendenlinie zurück oder legt ihn fest. Wenn die Legendenlinie mehr als einen Linienabschnitt enthält, gibt diese Eigenschaft den Winkel des Abschnitts zurück, der am weitesten von dem Textfeld der Legende entfernt ist. Kann eine der folgenden MsoCalloutAngleType-Konstanten sein: msoCalloutAngle30, msoCalloutAngle45, msoCalloutAngle60, msoCalloutAngle90, msoCalloutAngleAutomatic oder msoCalloutAngleMixed. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie für diese Eigenschaft einen anderen Wert als msoCalloutAngleAutomatic festlegen, behält die Legendenlinie einen festen Winkel bei, wenn Sie die Legende ziehen.


Beispiel zur Angle-Eigenschaft

In diesem Beispiel wird für den Legendenwinkel der Legende "Legende1" in myDocument ein Wert von 90 Grad festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes("callout1").Callout.Angle = msoCalloutAngle90


AnswerWizard-Eigenschaft

Gibt das AnswerWizard-Objekt für Microsoft Excel zurück. Schreibgeschützt.


Beispiel zur AnswerWizard-Eigenschaft

In diesem Beispiel wird die Dateiliste des Antwort-Assistenten zurückgesetzt.

Application.AnswerWizard.ResetFileList


Application-Eigenschaft

Ohne Objektkennzeichner gibt diese Eigenschaft ein Application-Objekt zurück, das die Anwendung Microsoft Excel repräsentiert. Mit Objektkennzeichner hingegen gibt diese Eigenschaft ein Application-Objekt zurück, das die Erstellungsanwendung des angegebenen Objekts repräsentiert. (Diese Eigenschaft eignet sich zur Ermittlung der zu einem OLE-Automatisierungsobjekt gehörigen Anwendung.) Schreibgeschützt.


Beispiel zur Application-Eigenschaft

Das folgende Beispiel zeigt eine Meldung an, die ausgibt, mit welcher Anwendung das Objekt meinObjekt erstellt wurde.

Set myObject = ActiveWorkbook
If myObject.Application.Value = "Microsoft Excel" Then
    MsgBox "This is a Microsoft Excel object"
Else
    MsgBox "This is not a Microsoft Excel object"
End If


ApplyPictToEnd-Eigenschaft

True, wenn eine Grafik dem Ende des Punkts oder aller Punkte der Datenreihe zugeordnet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToEnd-Eigenschaft

In diesem Beispiel werden Grafiken dem Ende aller Punkte in der ersten Datenreihe zugeordnet. Es müssen bereits Grafiken der Datenreihe zugeordnet worden sein (durch die Einstellung dieser Eigenschaft ändert sich die Ausrichtung der Grafik).

Charts(1).SeriesCollection(1).ApplyPictToEnd = True


ApplyPictToFront-Eigenschaft

True, wenn eine Grafik dem Anfang des Punkts oder aller Punkte der Datenreihe zugeordnet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToFront-Eigenschaft

In diesem Beispiel werden dem Anfang aller Punkte der ersten Datenreihe Grafiken zugeordnet. Der Datenreihe müssen bereits Grafiken zugeordnet worden sein (durch die Einstellung dieser Eigenschaft ändert sich die Ausrichtung der Grafik).

Charts(1).SeriesCollection(1).ApplyPictToFront = True


ApplyPictToSides-Eigenschaft

True, wenn den Seiten des Punkts oder aller Punkte der Datenreihe eine Grafik zugeordnet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ApplyPictToSides-Eigenschaft

In diesem Beispiel werden den Seiten aller Punkte der ersten Datenreihe Grafiken zugeordnet. Der Datenreihe müssen bereits Grafiken zugeordnet worden sein (durch die Einstellung dieser Eigenschaft ändert sich die Ausrichtung der Grafik).

Charts(1).SeriesCollection(1).ApplyPictToSides = True


Area3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Flächendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Area3DGroup-Eigenschaft

In diesem Beispiel werden Bezugslinien für die 3D-Flächendiagrammgruppe aktiviert.

Charts(1).Area3DGroup.HasDropLines = True


Areas-Eigenschaft

Gibt eine Areas-Auflistung zurück, die alle Bereiche in einer Mehrfachmarkierung darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Bei einer einfachen Markierung gibt die Areas-Eigenschaft eine Auflistung eines Objekts zurück (das ursprüngliche Range-Objekt selbst). Bei einer Mehrfachmarkierung gibt die Areas-Eigenschaft eine Auflistung zurück, die jeweils ein Objekt für jeden markierten Bereich enthält.


Beispiel zur Areas-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn der Benutzer versucht, einen Befehl auszuführen, und mehr als ein Bereich markiert ist. Dieses Makro muss von einem Tabellenblatt ausgeführt werden.

If Selection.Areas.Count > 1 Then
    MsgBox "Cannot do this to a multi-area selection."
End If


AskToUpdateLinks-Eigenschaft

True, wenn Microsoft Excel den Benutzer fragt, ob beim Öffnen von Dateien mit Verknüpfungen diese Verknüpfungen aktualisiert werden sollen. False, wenn Verknüpfungen automatisch ohne Dialogfeld aktualisiert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AskToUpdateLinks-Eigenschaft

In diesem Beispiel wird der Benutzer von Microsoft Excel beim Öffen einer Datei, die Verknüpfungen enthält, aufgefordert, diese Verknüpfungen zu aktualisieren.

Application.AskToUpdateLinks = True


Assistant-Eigenschaft

Gibt ein Assistant-Objekt für Microsoft Excel zurück.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne Objektkennzeichner hat die gleiche Wirkung wie Application.Assistant.


Beispiel zur Assistant-Eigenschaft

Mit diesem Beispiel wird der Office-Assistent sichtbar gemacht.

Assistant.Visible = True


Author-Eigenschaft

Gibt den Autor des Kommentars zurück oder legt ihn fest. String Schreibgeschützt.


Beispiel zur Author-Eigenschaft

In diesem Beispiel werden im aktiven Blatt alle Kommentare gelöscht, die von Jean Selva hinzugefügt wurden.

For Each c in ActiveSheet.Comments
    If c.Autor = "Jean Selva" Then c.Delete
Next


AutoAttach-Eigenschaft

True, wenn sich der Ort, an dem die Legendenlinie mit dem Legendentext verbunden ist, in Abhängigkeit davon ändert, ob der Ursprung der Legendenlinie (wohin die Legende zeigt) links oder rechts von dem Textfeld der Legende liegt. Long Schreib-Lese-Zugriff.

Anmerkungen

Besitzt diese Eigenschaft den Wert True, wird der Ansatzwert (der vertikale Abstand zwischen dem Rand des Textfeldes der Legende und dem Ort, and dem die Legende verbunden ist) von der Oberkante des Textfeldes gemessen, wenn sich das Textfeld rechts vom Ursprung befindet, oder von der Unterkante des Textfeldes, wenn das Textfeld links vom Ursprung liegt. Besitzt diese Eigenschaft den Wert False, wird der Ansatzwert immer von der Oberkante des Textfeldes gemessen, egal wie Textfeld und Ursprung zueinander liegen. Verwenden Sie die CustomDrop-Methode zum Festlegen und die Drop-Eigenschaft zum Zurückgeben des Ansatzwertes.

Durch das Festlegen dieser Eigenschaft wird eine Legende nur dann beeinflusst, wenn sie einen explizit festgelegten Ansatzwert besitzt - d. h. wenn die DropType-Eigenschaft den Wert msoCalloutDropCustom besitzt. Standardmäßig besitzen Legenden bei der Erstellung explizit festgelegte Ansatzwerte.


Beispiel zur AutoAttach-Eigenschaft

In diesem Beispiel werden in myDocument zwei Legenden eingefügt. Wenn Sie die Textfelder dieser beiden Legenden auf die linke Seite der Legendenlinie ziehen, ändert sich bei der automatisch verbundenen Legende der Ort, an dem die Legendenlinie mit dem Textfeld verbunden ist.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    With .AddCallout(msoCalloutTwo, 420, 170, 200, 50)
        .TextFrame.Characters.Text = "auto-attached"
        .Callout.AutoAttach = True
    End With
    With .AddCallout(msoCalloutTwo, 420, 350, 200, 50)
        .TextFrame.Characters.Text = "not auto-attached"
        .Callout.AutoAttach = False
    End With
End With


AutoCorrect-Eigenschaft

Gibt ein AutoCorrect-Objekt zurück, das die AutoKorrektur-Attribute in Microsoft Excel darstellt. Schreibgeschützt.


Beispiel zur AutoCorrect-Eigenschaft

In diesem Beispiel wird das Wort "Temp." für das Wort "Temperature" in die Matrix der AutoKorrektur-Ersetzungen eingefügt.

With Application.AutoCorrect
    .AddReplacement "Temperature", "Temp."
End With


AutoFilter-Eigenschaft

Gibt ein AutoFilter-Objekt zurück, sofern die Filterung aktiviert ist. Ist keine Filterung aktiv, wird Nothing zurückgegeben. Schreibgeschützt.

Anmerkungen

Zum Erstellen eines AutoFilter-Objekts für ein Tabellenblatt muss die automatische Filterung für einen Bereich in der Tabelle entweder manuell oder mit Hilfe der AutoFilter-Methode des Range-Objekts aktiviert werden.


AutoFilterMode-Eigenschaft

True, wenn die Dropdownpfeile für AutoFilter momentan im Blatt angezeigt werden. Diese Eigenschaft ist von der FilterMode-Eigenschaft unabhängig. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat den Wert True, wenn die Dropdownpfeile momentan angezeigt werden. Sie können diese Eigenschaft auf False setzen, um die Pfeile zu entfernen, jedoch nicht auf True, um sie einzublenden. Verwenden Sie hierzu die AutoFilter-Methode, mit deren Hilfe Sie eine Liste filtern und sich somit die Dropdownpfeile anzeigen lassen können.


Beispiel zur AutoFilterMode-Eigenschaft

In diesem Beispiel wird der aktuelle Status der AutoFilterMode-Eigenschaft in Sheet1 angezeigt.

If Worksheets("Sheet1").AutoFilterMode Then
    isOn = "On"
Else
    isOn = "Off"
End If
MsgBox "AutoFilterMode is " & isOn


AutoLength-Eigenschaft

True, wenn der erste Abschnitt der Legendenlinie (der mit dem Textfeld der Legende verbundene) immer automatisch skaliert wird, wenn die Legende verschoben wird. False, wenn die Legendenlinie bei jedem Verschieben der Legende die durch die Length-Eigenschaft festgelegte Länge beibehält. Gilt für Legenden, deren Linien aus mehr als einem Abschnitt bestehen (Legenden des Typs msoCalloutThree und msoCalloutFour). Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Sie können ihr mit der AutomaticLength-Methode den Wert True und mit der CustomLength-Methode den Wert False zuweisen.


Beispiel zur AutoLength-Eigenschaft

In diesem Beispiel wird zwischen automatischer Skalierung des ersten Abschnitts und Skalierung mit fester Länge der Legendenlinie in der ersten Form von myDocument hin- und hergeschaltet. Das Beispiel funktioniert nur, wenn es sich bei der Form um eine Legende handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .AutoLength Then
        .CustomLength 50
    Else
        .AutomaticLength
    End If
End With


AutoLoad-Eigenschaft

True, falls das OLE-Objekt automatisch geladen wird, wenn die Arbeitsmappe, in der es enthalten ist, geöffnet wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird von ActiveX-Steuerelementen ignoriert. ActiveX-Steuerelemente werden immer geladen, wenn eine Arbeitsmappe geöffnet wird.

Bei den meisten OLE-Objektarten sollte diese Eigenschaft nicht auf True gesetzt werden. Standardmäßig ist die AutoLoad-Eigenschaft bei neuen OLE-Objekten auf False gesetzt; dies spart Zeit und Speicherplatz, wenn Microsoft Excel Arbeitsmappen lädt. Das automatische Laden von OLE-Objekten besitzt den Vorteil, dass bei Objekten, die veränderliche Daten darstellen, Verknüpfungen zu den Quelldaten sofort wiederhergestellt und die Objekte, falls notwendig, erneut aufgebaut werden können.


Beispiel zur AutoLoad-Eigenschaft

In diesem Beispiel wird die AutoLoad-Eigenschaft des ersten OLE-Objekts im aktiven Blatt festgelegt.

ActiveSheet.OLEObjects(1).AutoLoad = False


AutoMargins-Eigenschaft

True, falls Microsoft Excel den Seitenrand des Textrahmens automatisch berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft den Wert True besitzt, werden die Eigenschaften MarginLeft, MarginRight, MarginTop und MaginBottom ignoriert.


Beispiel zur AutoMargins-Eigenschaft

In diesem Beispiel berechnet Microsoft Excel den Seitenrand des Textrahmens für Text in der ersten Form automatisch.

Worksheets(1).Shapes(1).TextFrame.AutoMargins = True


AutomaticStyles-Eigenschaft

True, wenn für die Gliederung die automatischer Formatierung verwendet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutomaticStyles-Eigenschaft

In diesem Beispiel wird festgelegt, dass in der Gliederung in Sheet1 automatische Formatvorlagen verwendet werden.

Worksheets("Sheet1").Outline.AutomaticStyles = True


AutoPercentEntry-Eigenschaft

True, wenn Einträge in Zellen, die als Prozentzahlen formatiert sind, bei der Eingabe nicht automatisch mit 100 multipliziert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoPercentEntry-Eigenschaft

In diesem Beispiel wird die automatische Multiplikation mit 100 für nachfolgende Eingaben in Zellen, die als Prozentzahlen formatiert sind, aktiviert.

Application.AutoPercentEntry = False


AutoScaleFont-Eigenschaft

True, wenn die Schriftgröße des Textes im Objekt bei einer Änderung der Objektgröße geändert wird. Der Standardwert lautet True. Variant Schreib-Lese-Zugriff.


Beispiel zur AutoScaleFont-Eigenschaft

In diesem Beispiel wird das eingebettete Diagramm 1 im aktiven Tabellenblatt mit einem Titel versehen. Die Schriftart des Titels bleibt dabei gleich, auch wenn sich die Größe des Diagramms ändert.

With ActiveSheet.ChartObjects(1).Chart
    .HasTitle = True
    .ChartTitle.Text = "1996 sales"
    .ChartTitle.AutoScaleFont = False
End With


AutoScaling-Eigenschaft

True, wenn Microsoft Excel die Größe eines 3D-Diagramms an die Größe des entsprechenden 2D-Diagramms anpasst. Die RightAngleAxes-Eigenschaft muss True sein. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoScaling-Eigenschaft

In diesem Beispiel wird Chart1 automatisch skaliert. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden.

With Charts("Chart1")
    .RightAngleAxes = True
    .AutoScaling = True
End With


AutoShapeType-Eigenschaft

Gibt den Formtyp des angegebenen Shape- oder ShapeRange-Objekts zurück, das eine AutoForm darstellen muss, die keine Linie, Freihandzeichnung oder Verbindung ist. Long Schreib-Lese-Zugriff.

Anmerkung Wenn Sie den Typ der Form ändern, bleiben Größe, Farbe und andere Eigenschaften der Form erhalten.

Kann eine der folgenden MsoAutoShapeType-Konstanten sein:

msoShape16pointStar

msoShape24pointStar

msoShape32pointStar

msoShape4pointStar

msoShape5pointStar

msoShape8pointStar

msoShapeActionButtonBackorPrevious

msoShapeActionButtonBeginning

msoShapeActionButtonCustom

msoShapeActionButtonDocument

msoShapeActionButtonEnd

msoShapeActionButtonForwardorNext

msoShapeActionButtonHelp

msoShapeActionButtonHome

msoShapeActionButtonInformation

msoShapeActionButtonMovie

msoShapeActionButtonReturn

msoShapeActionButtonSound

msoShapeArc

msoShapeBalloon

msoShapeBentArrow

msoShapeBentUpArrow

msoShapeBevel

msoShapeBlockArc

msoShapeCan

msoShapeChevron

msoShapeCircularArrow

msoShapeCloudCallout

msoShapeCross

msoShapeCube

msoShapeCurvedDownArrow

msoShapeCurvedDownRibbon

msoShapeCurvedLeftArrow

msoShapeCurvedRightArrow

msoShapeCurvedUpArrow

msoShapeCurvedUpRibbon

msoShapeDiamond

msoShapeDonut

msoShapeDoubleBrace

msoShapeDoubleBracket

msoShapeDoubleWave

msoShapeDownArrow

msoShapeDownArrowCallout

msoShapeDownRibbon

msoShapeExplosion1

msoShapeExplosion2

msoShapeFlowchartAlternateProcess

msoShapeFlowchartCard

msoShapeFlowchartCollate

msoShapeFlowchartConnector

msoShapeFlowchartData

msoShapeFlowchartDecision

msoShapeFlowchartDelay

msoShapeFlowchartDirectAccessStorage

msoShapeFlowchartDisplay

msoShapeFlowchartDocument

msoShapeFlowchartExtract

msoShapeFlowchartInternalStorage

msoShapeFlowchartMagneticDisk

msoShapeFlowchartManualInput

msoShapeFlowchartManualOperation

msoShapeFlowchartMerge

msoShapeFlowchartMultidocument

msoShapeFlowchartOffpageConnector

msoShapeFlowchartOr

msoShapeFlowchartPredefinedProcess

msoShapeFlowchartPreparation

msoShapeFlowchartProcess

msoShapeFlowchartPunchedTape

msoShapeFlowchartSequentialAccessStorage

 msoShapeFlowchartSort

msoShapeFlowchartStoredData

msoShapeFlowchartSummingJunction

msoShapeFlowchartTerminator

msoShapeFoldedCorner

msoShapeHeart

msoShapeHexagon

msoShapeHorizontalScroll

msoShapeIsoscelesTriangle

msoShapeLeftArrow

msoShapeLeftArrowCallout

msoShapeLeftBrace

msoShapeLeftBracket

msoShapeLeftRightArrow

msoShapeLeftRightArrowCallout

msoShapeLeftRightUpArrow

msoShapeLeftUpArrow

msoShapeLightningBolt

msoShapeLineCallout1

msoShapeLineCallout1AccentBar

msoShapeLineCallout1BorderandAccentBar

msoShapeLineCallout1NoBorder

msoShapeLineCallout2

msoShapeLineCallout2AccentBar

msoShapeLineCallout2BorderandAccentBar

msoShapeLineCallout2NoBorder

msoShapeLineCallout3

msoShapeLineCallout3AccentBar

msoShapeLineCallout3BorderandAccentBar

msoShapeLineCallout3NoBorder

msoShapeLineCallout4

msoShapeLineCallout4AccentBar

msoShapeLineCallout4BorderandAccentBar

msoShapeLineCallout4NoBorder

msoShapeMixed

msoShapeMoon

msoShapeNoSymbol

msoShapeNotchedRightArrow

msoShapeNotPrimitive

msoShapeOctagon

msoShapeOval

msoShapeOvalCallout

msoShapeParallelogram

msoShapePentagon

msoShapePlaque

msoShapeQuadArrow

msoShapeQuadArrowCallout

msoShapeRectangle

msoShapeRectangularCallout

msoShapeRegularPentagon

msoShapeRightArrow

msoShapeRightArrowCallout

msoShapeRightBrace

msoShapeRightBracket

msoShapeRightTriangle

msoShapeRoundedRectangle

msoShapeRoundedRectangularCallout

msoShapeSmileyFace

msoShapeStripedRightArrow

msoShapeSun

msoShapeTrapezoid

msoShapeUpArrow

msoShapeUpArrowCallout

msoShapeUpDownArrow

msoShapeUpDownArrowCallout

msoShapeUpRibbon

msoShapeUTurnArrow

msoShapeVerticalScroll

msoShapeWave

Anmerkungen

Verwenden Sie die Type-Eigenschaft des ConnectorFormat-Objekts, um die Verbindungsart festzulegen oder zurückzugeben.


Beispiel zur AutoShapeType-Eigenschaft

In diesem Beispiel werden in myDocument alle Sterne mit 16 Punkten durch Sterne mit 32 Punkten ersetzt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.AutoShapeType = msoShape16pointStar Then
        s.AutoShapeType = msoShape32pointStar
    End If
Next


AutoShowCount-Eigenschaft

Gibt die Anzahl der Kopf- oder Fußelemente zurück, die in dem angegebenen PivotTable-Feld automatisch angezeigt werden. Long Schreibgeschützt.


Beispiel zur AutoShowCount-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoShow-Parameter des Feldes "Salesman" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("salesman")
    If .AutoShowType = xlAutomatic Then
        r = .AutoShowRange
        If r = xlTop Then
            rn = "top"
        Else
            rn = "bottom"
        End If
        MsgBox "PivotTable report is showing " & rn & " " & _
            .AutoShowCount & " items in " & .Name & _
            " field by " & .AutoShowField
    Else
        MsgBox "PivotTable report is not using AutoShow for this field"
    End If
End With


AutoShowField-Eigenschaft

Gibt den Namen des Datenfeldes zurück, mit dem festgelegt wird, welche Kopf- oder Fußelemente automatisch in dem angegebenen PivotTable-Feld dargestellt werden. String Schreibgeschützt.


Beispiel zur AutoShowField-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoShow-Parameter des Feldes "Salesman" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("salesman")
    If .AutoShowType = xlAutomatic Then
        r = .AutoShowRange
        If r = xlTop Then
            rn = "top"
        Else
            rn = "bottom"
        End If
        MsgBox "PivotTable report is showing " & rn & " " & _
            .AutoShowCount & " items in " & .Name & _
            " field by " & .AutoShowField
    Else
        MsgBox "PivotTable report is not using AutoShow for this field"
    End If
End With


AutoShowRange-Eigenschaft

Gibt xlTop zurück, falls die Kopfelemente automatisch in dem angegebenen PivotTable-Feld dargestellt werden; gibt xlBottom zurück, falls die Fußelemente dargestellt werden. Long Schreibgeschützt.


Beispiel zur AutoShowRange-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoShow-Parameter des Feldes "Salesman" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("salesman")
    If .AutoShowType = xlAutomatic Then
        r = .AutoShowRange
        If r = xlTop Then
            rn = "top"
        Else
            rn = "bottom"
        End If
        MsgBox "PivotTable report is showing " & rn & " " & _
            .AutoShowCount & " items in " & .Name & _
            " field by " & .AutoShowField
    Else
        MsgBox "PivotTable report is not using AutoShow for this field"
    End If
End With


AutoShowType-Eigenschaft

Gibt xlAutomatic zurück, falls AutoShow für das angegebene PivotTable-Feld aktiviert ist; gibt xlManual zurück, falls AutoShow deaktiviert ist. Long Schreibgeschützt.


Beispiel zur AutoShowType-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoShow-Parameter des Feldes "Salesman" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("salesman")
    If .AutoShowType = xlAutomatic Then
        r = .AutoShowRange
        If r = xlTop Then
            rn = "top"
        Else
            rn = "bottom"
        End If
        MsgBox "PivotTable report is showing " & rn & " " & _
            .AutoShowCount & " items in " & .Name & _
            " field by " & .AutoShowField
    Else
        MsgBox "PivotTable report is not using AutoShow for this field"
    End If
End With


AutoSize-Eigenschaft

True, wenn sich die Größe des Objekts automatisch dem zugehörigen Text anpasst. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoSize-Eigenschaft

In diesem Beispiel wird die Größe des Textrahmens in der ersten Form automatisch dem Text angepasst.

Worksheets(1).Shapes(1).TextFrame.AutoSize = True


AutoSortField-Eigenschaft

Gibt den Namen des Datenfeldes zurück, nach dem das angegebene PivotTable-Feld automatisch sortiert wird. String Schreibgeschützt.


Beispiel zur AutoSortField-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoSort-Parameter des Feldes "Product" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("product")
    Select Case .AutoSortOrder
        Case xlManual
            aso = "manual"
        Case xlAscending
            aso = "ascending"
        Case xlDescending
            aso = "descending"
    End Select
    MsgBox " sorted in " & aso & _
        " order by " & .AutoSortField
End With


AutoSortOrder-Eigenschaft

Gibt die Reihenfolge zurück, nach der das angegebene PivotTable-Feld automatisch sortiert wird. Dies kann eine der folgenden XlSortOrder-Konstanten sein: xlAscending oder xlDescending (oder xlManual, wenn die automatische Sortierung deaktiviert ist). Long Schreibgeschützt.


Beispiel zur AutoSortOrder-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die AutoSort-Parameter des Feldes "Product" darstellt.

With Worksheets(1).PivotTables(1).PivotFields("product")
    Select Case .AutoSortOrder
        Case xlManual
            aso = "manual"
        Case xlAscending
            aso = "ascending"
        Case xlDescending
            aso = "descending"
    End Select
    MsgBox " sorted in " & aso & _
        " order by " & .AutoSortField
End With


AutoText-Eigenschaft

True, wenn das Objekt automatisch geeigneten Text aufgrund des Kontextes erstellt. Boolean Schreib-Lese-Zugriff.


Beispiel zur AutoText-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Datenbeschriftungen der ersten Datenreihe in Chart1 automatisch einen passenden Text erzeugen.

Charts("Chart1").SeriesCollection(1).DataLabels.AutoText = True


AutoUpdate-Eigenschaft

True, wenn das OLE-Objekt automatisch aktualisiert wird, sobald sich die Quelldaten ändern. Nur gültig, wenn das Objekt verknüpft ist (seine OLEType-Eigenschaft muss xlOLELink sein). Boolean Schreibgeschützt.


AutoUpdateFrequency-Eigenschaft

Gibt die Anzahl der Minuten zwischen automatischen Aktualisierungen der gemeinsam genutzten Arbeitsmappe zurück oder legt diese Zeitspanne fest. Wenn diese Eigenschaft auf Null (0) gesetzt wird, erfolgen Aktualisierungen nur beim Speichern der Arbeitsmappe. Long Schreib-Lese-Zugriff.


Beispiel zur AutoUpdateFrequency-Eigenschaft

Mit diesem Beispiel wird die gemeinsam genutzte Arbeitsmappe automatisch alle drei Minuten aktualisiert.

ActiveWorkbook.AutoUpdateFrequency = 3


AutoUpdateSaveChanges-Eigenschaft

True, wenn aktuelle Änderungen an der gemeinsam genutzten Arbeitsmappe an andere Benutzer weitergeleitet werden, sobald die Arbeitsmappe automatisch aktualisiert wird. False, wenn Änderungen nicht weitergeleitet werden (die Arbeitsmappe wird jedoch weiterhin mit Änderungen anderer Benutzer abgeglichen). Die Voreinstellung ist True. Boolean Lese- und Schreibzugriff.

Anmerkungen

Die AutoUpdateFrequency-Eigenschaft muss auf einen Wert zwischen 5 und 1440 eingestellt werden, damit sie wirksam wird.


Beispiel zur AutoUpdateSaveChanges-Eigenschaft

In diesem Beispiel werden Änderungen an der gemeinsam genutzten Arbeitsmappe an andere Benutzer weitergeleitet, sobald die Arbeitsmappe automatisch aktualisiert wird.

ActiveWorkbook.AutoUpdateSaveChanges = True


AxisBetweenCategories-Eigenschaft

True, wenn die Größenachse die Rubrikenachse zwischen den Rubriken schneidet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur gültig für Rubrikenachsen. Sie gilt nicht für 3D-Diagramme.


Beispiel zur AxisBetweenCategories-Eigenschaft

In diesem Beispiel schneidet die Größenachse in Chart1 die Rubrikenachse zwischen den Rubriken.

Charts("Chart1").Axes(xlCategory).AxisBetweenCategories = True


AxisGroup-Eigenschaft

Gibt die Gruppe für die angegebene Achse, Diagrammgruppe oder Datenreihe zurück. Kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Long Schreib-Lese-Zugriff für Series-Objekte; Long Schreibgeschützt für Axis- und ChartGroup-Objekte.

Anmerkungen

Für 3D-Diagramme ist nur die Gruppe xlPrimary gültig.


Beispiel zur AxisGroup-Eigenschaft

In diesem Beispiel wird die Größenachse in Chart1 gelöscht, wenn sie sich in der Sekundärgruppe befindet.

With Charts("Chart1").Axes(xlValue)
    If .AxisGroup = xlSecondary Then .Delete
End With


AxisTitle-Eigenschaft

Diese Eigenschaft gibt ein AxisTitle-Objekt zurück, das die Beschriftung der angegebenen Achse darstellt. Schreibgeschützt.


Beispiel zur AxisTitle-Eigenschaft

In diesem Beispiel wird die Achsenbeschriftung der Rubrikenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With


BackColor-Eigenschaft

ChartFillFormat-Objekt: Gibt ein ChartColorFormat-Objekt zurück, das die angegebene Füllfarbe des Hintergrunds darstellt. Schreibgeschützt.

Alle anderen Objekte: Gibt ein ColorFormat-Objekt zurück, das die angegebene Füllfarbe des Hintergrunds darstellt. Schreibgeschützt.


Beispiel zur BackColor-Eigenschaft

In diesem Beispiel werden für die Füllung des Diagrammbereichs im ersten Diagramm Vordergundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With Charts(1).ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


Background-Eigenschaft

Gibt die Art des Texthintergrunds zurück oder legt diese fest. Dies kann eine der folgenden Konstanten sein: xlBackgroundAutomatic, xlBackgroundOpaque oder xlBackgroundTransparent. Diese Eigenschaft trifft nur auf Text in Diagrammen zu. Long Schreib-Lese-Zugriff.


 BackgroundQuery-Eigenschaft

BackgroundQuery-Eigenschaft

True, wenn Abfragen der PivotTable-Bericht oder der Abfragetabelle asynchron (im Hintergrund) durchgeführt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist diese Eigenschaft schreibgeschützt und gibt immer False zurück.


Beispiel zur BackgroundQuery-Eigenschaft

In diesem Beispiel werden Abfragen für den ersten PivotTable-Bericht im ersten Tabellenblatt im Hintergrund ausgeführt.

Worksheets(1).PivotTables("Pivot1") _
    .PivotCache.BackgroundQuery = True


Backward-Eigenschaft

Gibt die Anzahl der Perioden (bzw. Einheiten in einem Punkt (XY)-Diagramm) zurück, um die sich eine Trendlinie rückwärts erstreckt, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Backward-Eigenschaft

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, um die sich die Trendlinie in Chart1 vorwärts und rückwärts erstreckt. Wenden Sie dieses Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

With Charts("Chart1").SeriesCollection(1).Trendlines(1)
    .Forward = 5
    .Backward = .5
End With


Bar3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Balkendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Bar3DGroup-Eigenschaft

In diesem Beispiel wird der Abstand zwischen den Balkengruppen in der 3D-Balkendiagrammgruppe auf 50 Prozent der Balkenbreite festgelegt.

Charts(1).BarGroup3DGroup.GapWidth = 50


BarShape-Eigenschaft

Gibt die mit einem 3D-Balkendiagramm oder Säulendiagramm verwendete Form zurück oder legt Sie fest. Kann eine der folgenden XlBarShape-Konstanten sein: xlBox, xlConeToMax, xlConeToPoint, xlCylinder, xlPyramidToMax oder xlPyramidToPoint. Long Schreib-Lese-Zugriff.


Beispiel zur BarShape-Eigenschaft

In diesem Beispiel wird die mit der ersten Reihe im ersten Diagramm verwendete Form festgelegt.

Charts(1).SeriesCollection(1).BarShape = xlConeToPoint


 BaseField-Eigenschaft

BaseField-Eigenschaft

Gibt das Basisfeld für eine benutzerdefinierte Berechnung zurück oder legt es fest. Diese Eigenschaft ist nur für Datenfelder gültig. Variant Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für OLAP-Datenquellen nicht verfügbar.


Beispiel zur BaseField-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Datenfeld des PivotTable-Berichts in Sheet1 den Unterschied zum Basisfeld berechnet. Das Feld "ORDER_DATE" wird als Basisfeld festgelegt und anschließend das Element "5/16/89" als Basiselement.

With Worksheets("Sheet1").Range("A3").PivotField
    .Calculation = xlDifferenceFrom
    .BaseField = "ORDER_DATE"
    .BaseItem = "5/16/89"
End With


 BaseItem-Eigenschaft

BaseItem-Eigenschaft

Gibt das Element im Basisfeld für die benutzerdefinierte Berechnung zurück oder weist ihm einen Wert zu. Nur für Datenfelder gültig. Variant Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für OLAP-Datenquellen nicht verfügbar.


Beispiel zur BaseItem-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Datenfeld des PivotTable-Berichts in Sheet1 den Unterschied zum Basisfeld berechnet. Das Feld "ORDER_DATE" wird als Basisfeld festgelegt und anschließend das Element "5/16/89" als Basiselement.

With Worksheets("Sheet1").Range("A3").PivotField
    .Calculation = xlDifferenceFrom
    .BaseField = "ORDER_DATE"
    .BaseItem = "5/16/89"
End With


BaseUnit-Eigenschaft

Gibt die Basiseinheit für die angegebene Rubrikenachse zurück oder legt sie fest. Dabei kann es sich um eine der folgenden XlTimeUnit-Konstanten handeln: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Einstellung dieser Eigenschaft hat keine sichtbaren Auswirkungen, wenn die CategoryType-Eigenschaft für die angegebene Achse auf xlCategoryScale gesetzt wird. Der Sollwert bleibt jedoch erhalten und tritt in Kraft, wenn die CategoryType-Eigenschaft auf xlTimeScale gesetzt wird.

Sie können diese Eigenschaft nicht für eine Größenachse festlegen.


BaseUnitIsAuto-Eigenschaft

True, wenn Microsoft Excel geeignete Basiseinheiten für die angegebene Rubrikenachse wählt. Der Standardwert lautet True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie können diese Eigenschaft nicht für eine Größenachse festlegen.


Beispiel zur BaseUnitIsAuto-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse im eingebetteten Chart1 des Tabellenblatts festgelegt, dass eine Zeitskala mit automatischen Basiseinheiten benutzt wird.

With Worksheets(1).ChartObjects(1).Chart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnitIsAuto = True
    End With
End With


BeginArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt die Länge fest. Kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadLength-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt die Art fest. Kann eine der folgenden MsoArrowheadStyle-Konstanten sein: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadStyle-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginArrowheadWidth-Eigenschaft

Gibt die Breite der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt die Breite fest. Dies kann eine der folgenden MsoArrowheadWidth-Konstanten sein: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur BeginArrowheadWidth-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


BeginConnected-Eigenschaft

True, wenn der Anfang der angegebenen Verbindung mit einer Form verbunden ist. Long Schreibgeschützt.


BeginConnectedShape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Form darstellt, der der Anfang der angegebenen Verbindung zugeordnet ist. Schreibgeschützt.

Anmerkung Wenn der Anfang der angegebenen Verbindung nicht einer Form zugeordnet ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur BeginConnectedShape-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass myDocument bereits zwei Formen enthält, denen die Verbindung "Verb1mit2" zugeordnet ist. Der Code fügt in myDocument ein Rechteck sowie eine Verbindung ein. Der Anfang der neuen Verbindung wird demselben Verbindungspunkt zugeordnet wie der Anfang der Verbindung "Verb1mit2". Das Ende der neuen Verbindung wird dem ersten Verbindungspunkt auf dem neuen Rechteck zugeordnet.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 450, 190, 200, 100)
    .AddConnector(msoConnectorCurve, 0, 0, 10, 10).Name = _
        "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        beginConnSite1 = .BeginConnectionSite
        Set beginConnShape1 = .BeginConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect beginConnShape1, beginConnSite1
        .EndConnect r3, 1
    End With
End With


BeginConnectionSite-Eigenschaft

Gibt eine Ganzzahl zurück, die den Verbindungspunkt angibt, mit dem der Anfang einer Verbindung verbunden ist. Long Schreibgeschützt.

Anmerkung Wenn der Anfang der angegebenen Verbindung nicht einer Form zugeordnet ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur BeginConnectionSite-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass myDocument bereits zwei Formen enthält, denen die Verbindung "Verb1mit2" zugeordnet ist. Der Code fügt in myDocument ein Rechteck sowie eine Verbindung ein. Der Anfang der neuen Verbindung wird demselben Verbindungspunkt zugeordnet wie der Anfang der Verbindung "Verb1mit2". Das Ende der neuen Verbindung wird dem ersten Verbindungspunkt auf dem neuen Rechteck zugeordnet.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, 450, 190, 200, 100)
    .AddConnector(msoConnectorCurve, 0, 0, 10, 10).Name = _
        "Conn1To3"
    With .Item("Conn1To2").ConnectorFormat
        beginConnSite1 = .BeginConnectionSite
        Set beginConnShape1 = .BeginConnectedShape
    End With
    With .Item("Conn1To3").ConnectorFormat
        .BeginConnect beginConnShape1, beginConnSite1
        .EndConnect r3, 1
    End With
End With


BlackAndWhite-Eigenschaft

True, wenn die Elemente des Dokuments in schwarzweiß gedruckt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft betrifft nur Seiten von Tabellenblättern.


Beispiel zur BlackAndWhite-Eigenschaft

In diesem Beispiel wird Sheet1 in schwarzweiß gedruckt.

Worksheets("Sheet1").PageSetup.BlackAndWhite = True


BlackWhiteMode-Eigenschaft

Diese Eigenschaft wird in Microsoft Excel nicht verwendet. Sie wird lediglich bereitgestellt, um mit den Zeichnungsobjektmodellen anderer Microsoft Office-Programme kompatibel zu sein.


Bold-Eigenschaft

True, wenn die Schriftart Fett ist. Variant Schreib-Lese-Zugriff.


Beispiel zur Bold-Eigenschaft

In diesem Beispiel wird die Schriftart für den Bereich A1:A5 in Sheet1 fett formatiert.

Worksheets("Sheet1").Range("A1:A5").Font.Bold = True


Border-Eigenschaft

Gibt ein Border-Objekt zurück, das den Rahmen des Objekts darstellt. Schreibgeschützt.


Borders-Eigenschaft

Gibt eine Borders-Auflistung zurück, die den gesamten Rahmen einer Formatvorlage oder eines Zellbereichs darstellt (einschließlich eines Bereichs, der als Teil eines bedingten Formats definiert ist). Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Borders-Eigenschaft

In diesem Beispiel wird der unteren Rahmenlinie von Zelle B2 in Sheet1 die Farbe Rot zugewiesen.

With Worksheets("Sheet1").Range("B2").Borders(xlBottom)
    .LineStyle = xlContinuous
    .Weight = xlThin
    .ColorIndex = 3
End With


 BottomMargin-Eigenschaft

BottomMargin-Eigenschaft

Gibt die Breite des unteren Randes in Punkt zurück oder legt diese fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Ränder werden in Punkt festgelegt oder zurückgegeben. Mit den Methoden InchesToPoints und CentimetersToPoints können Sie die Maßeinheiten umwandeln.


Beispiel zur BottomMargin-Eigenschaft

In den zwei folgenden Beispielen wird der untere Rand von Sheet1 auf 0,5 Zoll (36 Punkt) festgelegt.

Worksheets("Sheet1").PageSetup.BottomMargin = _
        Application.InchesToPoints(0.5)

Worksheets("Sheet1").PageSetup.BottomMargin = 36

In diesem Beispiel wird die aktuelle Einstellung des unteren Randes für Sheet1 festgelegt.

marginInches = Worksheets("Sheet1").PageSetup.BottomMargin / _
    Application.InchesToPoints(1)
MsgBox "The current bottom margin is " & marginInches & " inches"


BottomRightCell-Eigenschaft

Gibt ein Range-Objekt zurück. Dieses repräsentiert diejenige Zelle, die unter der unteren rechten Ecke des Objekts liegt. Schreibgeschützt.


Beispiel zur BottomRightCell-Eigenschaft

In diesem Beispiel wird die Adresse der Zelle angezeigt, die unterhalb der rechten unteren Ecke des in Sheet1 eingebetteten Diagramms liegt.

MsgBox "The bottom right corner is over cell " & _
    Worksheets("Sheet1").ChartObjects(1).BottomRightCell.Address


Brightness-Eigenschaft

Gibt die Helligkeit des angegebenen Bildes oder OLE-Objekts zurück oder legt sie fest. Der Wert dieser Eigenschaft muss eine Zahl zwischen 0,0 (dunkelste Einstellung) und 1,0 (hellste Einstellung) sein. Single Schreib-Lese-Zugriff.


Beispiel zur Brightness-Eigenschaft

In diesem Beispiel wird die Helligkeit der ersten Form in myDocument festgelegt. Bei der Form muss es sich um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).PictureFormat.Brightness = 0.3


BubbleScale-Eigenschaft

Gibt den Skalenfaktor für Blasen in der angebenen Diagrammgruppe zurück oder legt ihn fest. Dabei kann es sich um einen ganzzahligen Wert zwischen 0 (Null) und 300 handeln, der einem Prozentsatz der Standardgröße entspricht. Betrifft nur Blasen-Diagramme. Long Schreib-Lese-Zugriff.


Beispiel zur BubbleScale-Eigenschaft

In diesem Beispiel wird die Blasengröße in der Diagrammgruppe auf 200% der Standardgröße gesetzt.

With Worksheets(1).ChartObjects(1).Chart
    .ChartGroups(1).BubbleScale = 200
End With


BubbleSizes-Eigenschaft

Gibt eine Zeichenfolge in A1-Schreibweise zurück oder legt diejenige fest, die sich auf die Zellen des Tabellenblatts bezieht, die die Größenangabe für das Blasen-Diagramm enthalten. Betrifft nur Blasen-Diagramme. Variant Schreib-Lese-Zugriff.


Beispiel zur BubbleSizes-Eigenschaft

In diesem Beispiel wird der Zellbezug für die Zellen mit den Größenangaben für das Blasen-Diagramm angezeigt.

MsgBox Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).BubbleSizes


Build-Eigenschaft

Gibt die Versionsnummer von Microsoft Excel zurück. Long Schreibgeschützt.

Anmerkungen

Normalerweise ist es sicherer, Version-Eigenschaft zu überprüfen, wenn Sie nicht unbedingt die Versionsnummer benötigen.


Beispiel zur Build-Eigenschaft

In diesem Beispiel wird die Build-Eigenschaft überprüft.

If Application.Build > 2500 Then
    ' build-dependent code here
End If


BuiltIn-Eigenschaft

True, wenn die Formatvorlage integriert ist. Boolean Schreibgeschützt.


BuiltinDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle integrierten Dokumenteigenschaften für die angegebene Arbeitsmappe darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft gibt die vollständige Auflistung integrierter Dokumenteigenschaften zurück. Verwenden Sie die Item-Methode, um ein einzelnes Element der Auflistung (ein DocumentProperty-Objekt) zurückzugeben, indem Sie entweder den Namen der Eigenschaft oder den Auflistungsindex (als Zahl) angeben.

Sie können auf Dokumenteigenschaften entweder durch den Indexwert oder einen Namen verweisen. Die folgende Liste zeigt die verfügbaren integrierten Namen von Dokumenteigenschaften:

Titel

Thema

Autor

Schlüsselwörter

Kommentare

Vorlage

Letzter Autor

Revisionsnummer

Anwendungsname

Letztes Druckdatum

 Erstellungsdatum

Zuletzt gespeichert

Gesamtbearbeitungszeit

Seitenanzahl

Wortanzahl

Zeichenanzahl

Sicherheit

Kategorie

Format

Manager

 Unternehmen

Anzahl Byte

Anzahl Zeilen

Anzahl Absätze

Anzahl von Folien

Anzahl Anmerkungen

Anzahl versteckter Folien

Anzahl von Multimedia-Clips

Hyperlink-Basis

Zeichenanzahl (mit Leerzeichen)

Container-Anwendungen müssen nicht für jede integrierte Dokumenteigenschaft Werte festlegen. Wenn Microsoft Excel keinen Wert für integrierte Dokumenteigenschaften festlegt, wird beim Lesen der Eigenschaft Value für diese Dokumenteigenschaft ein Fehler verursacht.

Da die Item-Methode die Standardmethode für die DocumentProperties-Auflistung ist, sind die folgenden Anweisungen gleichwertig:

BuiltinDocumentProperties.Item(1)
BuiltinDocumentProperties(1)

Verwenden Sie die CustomDocumentProperties-Eigenschaft, um die Auflistung benutzerdefinierter Dokumenteigenschaften zurückzugeben.


Beispiel zur BuiltinDocumentProperties-Eigenschaft

In diesem Beispiel werden die Namen der integrierten Dokumenteigenschaften als Liste im ersten Tabellenblatt angezeigt.

rw = 1
Worksheets(1).Activate
For Each p In ActiveWorkbook.BuiltinDocumentProperties
    Cells(rw, 1).Value = p.Name
    rw = rw + 1
Next


CacheIndex-Eigenschaft

Gibt den Index des PivotTable-Cache zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie die CacheIndex-Eigenschaft so festlegen, dass ein PivotTable-Bericht den Cache für einen zweiten PivotTable-Bericht verwendet, müssen die Felder des ersten Berichts eine zulässige Untermenge der Felder des zweiten Berichts sein.


Beispiel zur CacheIndex-Eigenschaft

In diesem Beispiel wird der Cache des PivotTable-Berichts "Pivot1" auf den Cache des PivotTable-Berichts "Pivot2" gesetzt.

Worksheets(1).PivotTables("Pivot1").CacheIndex = _
    Worksheets(1).PivotTables("Pivot2").CacheIndex


CalculateBeforeSave-Eigenschaft

True, wenn Arbeitsmappen vor dem Speichern berechnet werden (wenn die Calculation-Eigenschaft auf xlManual gesetzt ist). Diese Eigenschaft bleibt erhalten, selbst wenn Sie die Calculation-Eigenschaft ändern. Boolean Schreib-Lese-Zugriff.


Beispiel zur CalculateBeforeSave-Eigenschaft

Das folgende Beispiel stellt Microsoft Excel so ein, dass Arbeitsmappen vor dem Speichern berechnet werden.

Application.Calculation = xlManual
Application.CalculateBeforeSave = True


 Calculation-Eigenschaft

Calculation-Eigenschaft

Application-Objekt: Gibt die Berechnungsart zurück oder legt sie fest. Kann eine der folgenden XlCalculation-Konstanten sein: xlCalculationAutomatic, xlCalculationManual oder xlCalculationSemiautomatic.

PivotField-Objekt: Gibt die vom angegebenen Feld durchgeführte Berechnungsart zurück oder legt sie fest. Kann eine der folgenden XlPivotFieldCalculation-Konstanten sein: xlDifferenceFrom, xlIndex, xlNormal, xlPercentDifferenceFrom, xlPercentOf, xlPercentOfColumn, xlPercentOfRow, xlPercentOfTotal oder xlRunningTotal. Diese Eigenschaft ist nur für Datenfelder gültig. Long Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen kann für diese Eigenschaft nur xlNormal zurückgegeben oder festgelegt werden.


CalculationVersion-Eigenschaft

Gibt eine Zahl zurück, deren vier rechts stehende Ziffern die Nummer der Unterversion des Berechnungsmoduls und deren andere Ziffern (links) die Hauptversion von Microsoft Excel darstellen. Für ein WorkbookObjekt gibt diese Eigenschaft die Version von Excel zurück, unter der die Arbeitsmappe zuletzt vollständig neu berechnet wurde. Schreibgeschützt Long.

Anmerkungen

Wenn die Arbeitsmappe in einer älteren Version von Excel gespeichert wurde, und wenn die Arbeitsmappe nicht vollständig neu berechnet wurde, gibt diese Eigenschaft 0 zurück.


Beispiel zur CalculationVersion-Eigenschaft

In diesem Beispiel wird die Version von Microsoft Excel mit derjenigen Version von Excel, in der die Arbeitsmappe zuletzt berechnet wurde, verglichen. Sind die beiden Versionsnummern unterschiedlich, wird die blnFullCalc-Variable in dem Beispiel auf True festgelegt.

If Application.CalculationVersion <> _
    Workbooks(1).CalculationVersion Then
    blnFullCalc = True
Else
    blnFullCalc = False
End If


Caller-Eigenschaft

Gibt Informationen darüber zurück, wie Visual Basic aufgerufen wurde (weitere Informationen finden Sie unter "Anmerkungen").

Syntax

Ausdruck.Caller(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Variant optional. Ein Index für die Matrix. Dieses Argument wird nur verwendet, wenn die Eigenschaft eine Matrix zurückgibt (weitere Informationen finden Sie unter "Anmerkungen").

Anmerkungen

Diese Eigenschaft gibt Informationen darüber zurück, wie Visual Basic aufgerufen wurde. Dies wird in der folgenden Tabelle beschrieben.

Aufruf | Rückgabewert
Eine benutzerdefinierte Funktion, die in eine einzelne Zelle eingegeben wurde | Ein Range-Objekt, das diese Zelle angibt
Eine benutzerdefinierte Funktion als Teil einer Matrixformel in einem Zellbereich | Ein Range-Objekt, das diesen Zellbereich angibt
Ein Auto_Open-, Auto_Close-, Auto_Activate- oder Auto_Deactivate-Makro | Der Name des Dokuments als Text
Ein Makro, das durch die Eigenschaft OnDoubleClick oder OnEntry festgelegt wird | Der Objektkennzeichner des Diagramms oder Zellbezugs (falls vorhanden), auf das dieses Makro angewendet wird
Das Dialogfeld Makro (Menü Extras) oder ein anderer Aufruf, der in dieser Tabelle nicht aufgeführt ist | Der Fehlerwert #BEZUG!


Beispiel zur Caller-Eigenschaft

In diesem Beispiel werden Informationen darüber angezeigt, wie Visual Basic aufgerufen wurde.

Select Case TypeName(Application.Caller)
    Case "Range"
        v = Application.Caller.Address
    Case "String"
        v = Application.Caller
    Case "Error"
        v = "Error"
    Case Else
        v = "unknown"
End Select
MsgBox "caller = " & v


Callout-Eigenschaft

Gibt ein CalloutFormat-Objekt zurück, das Formateigenschaften für eine Legende im angegebenen Bereich enthält. Betrifft Shape- oder ShapeRange-Objekte, die Legenden mit Linien darstellen. Schreibgeschützt.


Beispiel zur Callout-Eigenschaft

In diesem Beispiel werden in myDocument eine Ellipse und eine Legende, die auf die Ellipse zeigt, eingefügt. Der Legendentext besitzt keinen Rahmen, jedoch eine vertikale Markierungsleiste, die den Text von der Legendenlinie trennt.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    .AddShape msoShapeOval, 180, 200, 280, 130
    With .AddCallout(msoCalloutTwo, 420, 170, 170, 40)
        .TextFrame.Characters.Text = "My oval"
        With .Callout
            .Accent = True
            .Border = False
        End With
    End With
End With


CanPlaySounds-Eigenschaft

Diese Eigenschaft sollte nicht verwendet werden. Audio-Notizen wurden aus Microsoft Excel entfernt


CanRecordSounds-Eigenschaft

Diese Eigenschaft sollte nicht verwendet werden. Audio-Notizen wurden aus Microsoft Excel entfernt.


CapitalizeNamesOfDays-Eigenschaft

True, wenn die Anfangsbuchstaben von Wochentagsnamen automatisch großgeschrieben werden. Diese Eigenschaft steht nur in Microsoft Excel für Windows 95 zur Verfügung. Boolean Schreib-Lese-Zugriff.


Beispiel zur CapitalizeNamesOfDays-Eigenschaft

In diesem Beispiel wird Microsoft Excel so eingestellt, dass die Anfangsbuchstaben der Wochentage großgeschrieben werden.

With Application.AutoCorrect
    .CapitalizeNamesOfDays = True
    .ReplaceText = True
End With


 Caption-Eigenschaft

Caption-Eigenschaft

Die Eigenschaft hat mehrere verschiedene Bedeutungen, die vom Objekttyp abhängen, auf den sie angewendet wird. String Schreib-Lese-Zugriff mit den in der folgenden Tabelle gekennzeichneten Ausnahmen.

Objekttyp | Bedeutung
Application | Der Name in der Titelleiste des Microsoft Excel-Hauptfensters. Wird kein Name festgelegt oder der Name auf Empty gesetzt, gibt diese Eigenschaft "Microsoft Excel" zurück.
AxisTitle | Die Achsenbeschriftung.
Characters | Der Text dieses Bereichs von Zeichen.
ChartTitle | Der Diagrammtitel.
CubeField, PivotItem, PivotField | Der Beschriftungstext für das Cube-Feld, PivotTable-Feld oder PivotTable-Element.
DataLabel | Der Text der Datenbeschriftung.
Window | Der Name in der Titelleiste des Dokumentfensters. Wenn Sie den Namen festlegen, können Sie ihn als Index für die Windows-Eigenschaft verwenden (siehe zweites Beispiel).

Die folgende Tabelle zeigt Beispielwerte der Caption-Eigenschaft und verwandter Eigenschaften bei einer OLAP-Datenquelle mit dem eindeutigen Namen "[Europa].[Frankreich].[Paris]" und einer Nicht-OLAP-Datenquelle mit dem Elementnamen "Paris".

Eigenschaft | Wert (OLAP-Datenquelle) | Wert (Nicht-OLAP-Datenquelle)
Caption | Paris | Paris
Name | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | Paris
SourceName | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | (Identisch mit SQL-Eigenschaftenwert; Schreibgeschützt)
Value | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | Paris

Wenn Sie einen Index in der PivotItems-Auflistung angeben, können Sie die in der folgende Tabelle gezeigte Syntax verwenden.

Syntax (OLAP-Datenquelle) | Syntax (Nicht-OLAP-Datenquelle)
Ausdruck.PivotItems("[Europa].[Frankreich].[Paris]") | Ausdruck.PivotItems("Paris")

Wenn die Item-Eigenschaft verwendet wird, um auf ein bestimmtes Mitglied einer Auflistung zu verweisen, können Sie die in der folgenden Tabelle gezeigten Textindexnamen verwenden.

Name (OLAP-Datenquelle) | Name (Nicht-OLAP-Datenquelle)
[Europa].[Frankreich].[Paris] | Paris


Beispiel zur Caption-Eigenschaft

In diesem Beispiel wird der Name, der in der Titelleiste des Hauptfensters von Microsoft Excel angezeigt wird, als benutzerdefinierter Name festgelegt.

Application.Caption = "Blue Sky Airlines Reservation System"

In diesem Beispiel wird für das erste Fenster in der aktiven Arbeitsmappe der Name "Konzernbilanz" festgelegt. Dieser Name wird dann als Index für die Windows-Eigenschaft verwendet.

ActiveWorkbook.Windows(1).Caption = "Consolidated Balance Sheet"
ActiveWorkbook.Windows("Consolidated Balance Sheet") _
    .ActiveSheet.Calculate


Category-Eigenschaft

Wenn sich der Name auf eine benutzerdefinierte Funktion oder einen Befehl bezieht, gibt diese Eigenschaft die Kategorie des Namens als Zeichenfolge zurück oder legt sie fest. Der Name wird in die Sprache übersetzt, in der das Makro geschrieben wurde. String Schreib-Lese-Zugriff.


CategoryLocal-Eigenschaft

Wenn sich der Name auf eine benutzerdefinierte Funktion oder einen benutzerdefinierten Befehl bezieht, gibt diese Eigenschaft die Namenskategorie als Zeichenfolge in der Sprache des Benutzers an, oder legt einen Wert für sie fest. String Schreib-Lese-Zugriff.


Beispiel zur CategoryLocal-Eigenschaft

In diesem Beispiel wird in der Sprache des Benutzers die Kategorie einer mit einer Makrovorlage von Microsoft Excel 4.0 erstellten benutzerdefinierten Funktion bzw. eines benutzerdefinierten Befehls angezeigt. Es wird vorausgesetzt, dass das benutzerdefinierte Element der einzige Name ist, der in der Arbeitsmappe vorkommt.

With ActiveWorkbook.Names(1)
    If .MacroType <> xlNone Then
        MsgBox "The category for this name is " & .CategoryLocal
    Else
        MsgBox "This name does not refer to" & _
            " a custom function or command."
    End If
End With


CategoryNames-Eigenschaft

Gibt alle Rubrikennamen der angegebenen Achse als Textmatrix zurück oder legt sie fest. Wenn Sie diese Eigenschaft festlegen, können Sie ihr eine Matrix oder ein Range-Objekt mit den Rubrikennamen zuweisen. Variant Schreib-Lese-Zugriff.

Anmerkungen

Die Rubrikennamen sind eigentlich eine Eigenschaft der Datenreihe "Spezial" in einer Achsengruppe. Durch das Löschen oder Ändern dieser speziellen Datenreihe werden die Rubrikennamen aller Datenreihen verändert, die die Achse benutzen.


Beispiel zur CategoryNames-Eigenschaft

In diesem Beispiel werden die Werte im Bereich B1:B5 in Sheet1 als Rubrikennamen für Chart1 festgelegt.

Set Charts("Chart1").Axes(xlCategory).CategoryNames = _
    Worksheets("Sheet1").Range("B1:B5")

Im nächsten Beispiel wird eine Matrix verwendet, um individuelle Rubrikennamen für Chart1 festzulegen.

Charts("Chart1").Axes(xlCategory).CategoryNames = _
    Array ("1985", "1986", "1987", "1988", "1989")


CategoryType-Eigenschaft

Gibt den Typ der Rubrikenachse zurück oder legt ihn fest. Dabei kann es sich um eine der folgenden XlCategoryType-Konstanten handeln: xlCategoryScale, xlTimeScale oder xlAutomaticScale. Long Schreib-Lese-Zugriff.

Anmerkungen

Sie können diese Eigenschaft nicht für eine Größenachse festlegen.


Beispiel zur CategoryType-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse im eingebetteten Chart1 des ersten Tabellenblatts festgelegt, eine Zeitskala mit Monaten als Basiseinheit zu verwenden.

With Worksheets(1).ChartObjects(1).Chart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnit = xlMonths
    End With
End With


CellDragAndDrop-Eigenschaft

True, wenn Drag & Drop (Ziehen und Ablegen von Zellen) aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur CellDragAndDrop-Eigenschaft

In diesem Beispiel wird Drag & Drop aktiviert.

Application.CellDragAndDrop = True


 Cells-Eigenschaft

Cells-Eigenschaft

Application-Objekt: Gibt ein Range-Objekt zurück, das alle Zellen im aktiven Tabellenblatt repräsentiert. Wenn das aktive Dokument kein Tabellenblatt ist, gibt die Eigenschaft einen Fehlerwert zurück. Schreibgeschützt.

Range-Objekt: Gibt ein Range-Objekt zurück, das die Zellen im angegebenen Bereich darstellt. Schreibgeschützt.

Worksheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zellen im Tabellenblatt darstellt (nicht nur die zurzeit verwendeten Zellen). Schreibgeschützt.

Anmerkungen

Da die Item-Eigenschaft die Standardeigenschaft des Range-Objekts ist, können Sie den Zeilen- und Spaltenindex unmittelbar nach dem Cells-Schlüsselwort angeben. Weitere Informationen finden Sie unter der Item-Eigenschaft und den Beispielen zu diesem Thema.

Wenn Sie diese Eigenschaft ohne einen Objektkennzeichner verwenden, wird ein Range-Objekt zurückgegeben, das alle Zellen im aktiven Tabellenblatt darstellt.


Beispiel zur Cells-Eigenschaft

In diesem Beispiel wird die Schriftgröße der Zelle C5 in Sheet1 auf 14 Punkt festgelegt.

Worksheets("Sheet1").Cells(5, 3).Font.Size = 14

In diesem Beispiel wird die Formel in der ersten Zelle in Sheet1 gelöscht.

Worksheets("Sheet1").Cells(1).ClearContents

In diesem Beispiel wird die Schriftart für alle Zellen in Sheet1 auf Arial, 8 Punkt, festgelegt.

With Worksheets("Sheet1").Cells.Font
    .Name = "Arial"
    .Size = 8
End With

Das folgende Beispiel bearbeitet in einer Schleife die Zellen A1:J4 in Sheet1. Hat eine dieser Zellen einen Wert, der kleiner ist als 0,001, wird dieser Wert durch Null (0) ersetzt.

For rwIndex = 1 to 4
    For colIndex = 1 to 10
        With Worksheets("Sheet1").Cells(rwIndex, colIndex)
            If .Value < .001 Then .Value = 0
        End With
    Next colIndex
Next rwIndex

In diesem Beispiel wird die Schrift der Zellen A1:C5 in Sheet1 auf kursiv gesetzt.

Worksheets("Sheet1").Activate
Range(Cells(1, 1), Cells(5, 3)).Font.Italic = True

Dieses Beispiel durchsucht die Spalte "myRange", die Daten enthält. Wenn eine Zelle denselben Wert besitzt wie die darüber liegende Zelle, wird die Adresse der Zelle mit den doppelten Daten angezeigt.

Set r = Range("myRange")
For n = 1 To r.Rows.Count
    If r.Cells(n, 1) = r.Cells(n + 1, 1) Then
        MsgBox "Duplicate data in " & r.Cells(n + 1, 1).Address
    End If
Next n


CenterFooter-Eigenschaft

Gibt den mittleren Teil der Fußzeile zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Fußzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur CenterFooter-Eigenschaft

In diesem Beispiel werden der Name der Arbeitsmappe und die Seitenzahl unten auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.CenterFooter = "&F page &P"


CenterHeader-Eigenschaft

Gibt den mittleren Teil der Kopfzeile zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Kopfzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur CenterHeader-Eigenschaft

In diesem Beispiel werden Datum und Seitenzahl oben auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.CenterHeader = "&D page &P of &N"


CenterHorizontally-Eigenschaft

True, falls das Tabellenblatt horizontal auf der Druckseite zentriert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur CenterHorizontally-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken horizontal zentriert.

Worksheets("Sheet1").PageSetup.CenterHorizontally = True


CenterVertically-Eigenschaft

True, falls das Tabellenblatt vertikal auf der Druckseite zentriert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur CenterVertically-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken vertikal zentriert.

Worksheets("Sheet1").PageSetup.CenterVertically = True


ChangeHistoryDuration-Eigenschaft

Gibt die Anzahl der Tage zurück, die im Änderungsprotokoll einer gemeinsam genutzten Arbeitsmappe angezeigt werden, oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Alle Änderungen im Änderungsprotokoll, die älter als die in dieser Eigenschaft festgelegte Einstellung sind, werden beim Schließen der Arbeitsmappe entfernt.


Beispiel zur ChangeHistoryDuration-Eigenschaft

In diesem Beispiel wird die Anzahl der Tage festgelegt, die im Änderungsprotokoll der aktiven Arbeitsmappe dargestellt werden, falls die Protokollierung der Änderungen aktiviert ist. Alle Änderungen im Änderungsprotokoll, die älter als die in dieser Eigenschaft festgelegten Einstellung sind, werden beim Schließen der Arbeitsmappe entfernt.

With ActiveWorkbook
    If .KeepChangeHistory Then
        .ChangeHistoryDuration = 7
    End If
End With


ChangingCells-Eigenschaft

Gibt ein Range-Objekt zurück, das die veränderbaren Zellen eines Szenarios darstellt. Schreibgeschützt.


Beispiel zur ChangingCells-Eigenschaft

In diesem Beispiel werden die veränderbaren Zellen für Szenario eins in Sheet1 ausgewählt.

Worksheets("Sheet1").Activate
ActiveSheet.Scenarios(1).ChangingCells.Select


Characters-Eigenschaft

Gibt ein Characters-Objekt zurück, das einen Bereich von Zeichen innerhalb des Objekttextes darstellt. Mit dem Characters-Objekt können Sie Zeichen innerhalb einer Zeichenfolge formatieren.

Syntax

Ausdruck.Characters(Start, Length)

Ausdruck Erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Start Variant optional. Das erste zurückzugebende Zeichen. Falls dieses Argument den Wert 1 besitzt oder nicht angegeben wird, gibt diese Eigenschaft einen Zeichenbereich zurück, der mit dem ersten Zeichen beginnt.

Length Variant optional. Die Anzahl der zurückzugebenden Zeichen. Falls dieses Argument nicht angegeben wird, gibt diese Eigenschaft den Rest der Zeichenfolge zurück (alle Zeichen nach Start).

Anmerkungen

Das Characters-Objekt ist keine Auflistung.

Beim TextFrame-Objekt ist Characters eine Methode.


Beispiel zur Characters-Eigenschaft

In diesem Beispiel wird das dritte Zeichen in Zelle A1 der Sheet1 fett formatiert.

With Worksheets("Sheet1").Range("A1")
    .Value = "abcdefg"
    .Characters(3, 1).Font.Bold = True
End With


CharacterType-Eigenschaft

Gibt den Typ des phonetischen Textes in der angegebenen Zelle zurück oder legt diesen fest. Kann eine der folgenden XlPhoneticCharacterType-Konstanten sein: xlHiragana, xlKatakana, xlKatakanaHalf oder xlNoConversion. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Konstanten stehen nur zu Verfügung, wenn die japanische Sprachunterstützung ausgewählt oder installiert wurde.


Beispiel zur CharacterType-Eigenschaft

In diesem Beispiel wird die erste phonetische Textzeichenfolge in der aktiven Zelle von Furigana in Hiragana geändert.

ActiveCell.Phonetics(1).CharacterType = xlHiragana


Chart-Eigenschaft

Gibt ein Chart-Objekt zurück, das das im Objekt enthaltene Diagramm darstellt. Schreibgeschützt.


ChartArea-Eigenschaft

Gibt ein ChartArea-Objekt zurück, das die vollständige Diagrammfläche des Diagramms darstellt. Schreibgeschützt.


Beispiel zur ChartArea-Eigenschaft

In diesem Beispiel wird dem Innenraum von Chart1 die Farbe Rot und dem Rahmen die Farbe Blau zugewiesen.

With Charts("Chart1").ChartArea
    .Interior.ColorIndex = 3
    .Border.ColorIndex = 5
End With


Charts-Eigenschaft

Application-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Diagrammblätter der aktiven Arbeitsmappe darstellt. Schreibgeschützt.

Workbook-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Diagrammblätter in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Wenn Sie diese Eigenschaft ohne Objektkennzeichner verwenden, werden alle Diagrammblätter der aktiven Arbeitsmappe zurückgegeben.

Informationen über das Zurückgeben jeweils eines Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


ChartSize-Eigenschaft

Gibt die Art zurück, die beim Skalieren eines Diagramms (Anpassen an die Seite) verwendet wird, oder legt diese entsprechend nachstehender Tabelle fest. Long Schreib-Lese-Zugriff.

Es stehen folgende XlObjectSize-Konstanten zur Verfügung.

Konstante | Bedeutung
xlScreenSize | Druckt das Diagramm in der gleichen Größe wie es auf dem Bildschirm erscheint.
xlFitToPage | Druckt das Diagramm möglichst groß, wobei das Seitenverhältnis von Höhe zu Breite der Bildschirmdarstellung erhalten bleibt.
xlFullPage | Passt das Diagramm beim Druck so an, dass es genau auf die Druckseite passt, wobei das Verhältnis von Höhe zu Breite gegebenenfalls geändert wird.

Anmerkungen

Diese Eigenschaft gilt nur für Diagramm-Blätter. Sie kann nicht bei eingebetteten Diagrammen verwendet werden.


Beispiel zur ChartSize-Eigenschaft

In diesem Beispiel wird das erste Diagramm in der aktiven Arbeitsmappe so skaliert, dass es genau auf eine Seite passt.

ActiveWorkbook.Charts(1).PageSetup.ChartSize = xlFullPage


ChartTitle-Eigenschaft

Gibt ein ChartTitle-Objekt zurück, das den Titel des angegebenen Diagramms darstellt. Schreibgeschützt.


Beispiel zur ChartTitle-Eigenschaft

In diesem Beispiel wird der Text des Titels von Chart1 festgelegt.

With Charts("Chart1")
    .HasTitle = True
    .ChartTitle.Text = "First Quarter Sales"
End With


ChartType-Eigenschaft

Gibt den Diagrammtyp zurück oder legt diesen fest. Long Schreib-Lese-Zugriff.

Kann eine der folgenden XlChartType-Konstanten sein.

Diagrammtyp | Beschreibung | Konstante
Säulendiagramm | Säulen (gruppiert) | xlColumnClustered
 | 3D-Säulen (gruppiert) | xl3DColumnClustered
 | Gestapelte Säulen. Vergleicht die Beiträge einzelner Werte mit dem Gesamtwert aller Kategorien. | xlColumnStacked
 | 3D-Gestapelte Säulen. Vergleicht die Beiträge einzelner Werte mit dem Gesamtwert aller Kategorien. | xl3DColumnStacked
 | Säulen (100%, gestapelt) | xlColumnStacked100
 | 3D-Säulen (100%, gestapelt) | xl3DColumnStacked100
 | 3D-Säulen | xl3DColumn
Balkendiagramm | Balken (gruppiert) | xlBarClustered
 | 3D-Balken (gruppiert) | xl3DBarClustered
 | Balken (gestapelt) | xlBarStacked
 | 3D-Balken (gestapelt) | xl3DBarStacked
 | Balken (100%, gestapelt) | xlBarStacked100
 | 3D-Balken (100%, gestapelt) | xl3DBarStacked100
Liniendiagramm | Linie | xlLine
 | Linien mit Datenpunkten | xlLineMarkers
 | Linien (gestapelt) | xlLineStacked
 | Linien (gestapelt) mit Datenpunkten | xlLineMarkersStacked
 | Linien (100%, gestapelt) | xlLineStacked100
 | Linien (100%, gestapelt, mit Datenpunkten) | xlLineMarkersStacked100
 | 3D-Linien | xl3DLine
Kreisdiagramm | Kreis | xlPie
 | Kreis (explodiert) | xlPieExploded
 | 3D-Kreis | xl3DPie
 | 3D-Kreis (explodiert) | xl3DPieExploded
 | Kreis aus Kreis | xlPieOfPie
 | Balken aus Kreis | xlBarOfPie
Punkt (XY)-Diagramm | Punkte | xlXYScatter
 | Punkte mit interpolierten Linien | xlXYScatterSmooth
 | Punkte mit interpolierten Linien ohne Datenpunkte | xlXYScatterSmoothNoMarkers
 | Punkte mit Linien | xlXYScatterLines
 | Punkte mit Linien ohne Datenpunkte | xlXYScatterLinesNoMarkers
Blasendiagramm | Blasen | xlBubble
 | Blasen mit 3D-Effekt | xlBubble3DEffect
Flächendiagramm | Flächen | xlArea
 | 3D-Flächen | xl3DArea
 | Flächen (gestapelt) | xlAreaStacked
 | 3D-Flächen (gestapelt) | xl3DAreaStacked
 | Flächen (100%, gestapelt) | xlAreaStacked100
 | 3D-Flächen (100%, gestapelt) | xl3DAreaStacked100
Ringdiagramm | Ring | xlDoughnut
 | Ring (explodiert) | xlDoughnutExploded
Netzdiagramm | Netz | xlRadar
 | Netz mit Datenpunkten | xlRadarMarkers
 | Netz (gefüllt) | xlRadarFilled
Oberflächendiagramm | 3D-Oberfläche | xlSurface
 | Oberfläche (Draufsicht) | xlSurfaceTopView
 | 3D-Oberfläche (Drahtmodell) | xlSurfaceWireframe
 | Oberfläche (Draufsicht, Drahtmodell) | xlSurfaceTopViewWireframe
Kursdiagramm | Höchst-Tiefst-Geschlossen | xlStockHLC
 | Volumen-Höchst-Tiefst-Geschlossen | xlStockVHLC
 | Geöffnet-Höchst-Tiefst-Geschlossen | xlStockOHLC
 | Volumen-Öffnung-Höchst-Tiefst-Geschlossen | xlStockVOHLC
Zylinderdiagramm | Zylindersäulen (gruppiert) | xlCylinderColClustered
 | Zylinderbalken (gruppiert) | xlCylinderBarClustered
 | Zylindersäulen (gestapelt) | xlCylinderColStacked
 | Zylinderbalken (gestapelt) | xlCylinderBarStacked
 | Zylindersäulen (100%, gestapelt) | xlCylinderColStacked100
 | Zylinderbalken (100%, gestapelt) | xlCylinderBarStacked100
 | 3D-Zylindersäulen | xlCylinderCol
Kegeldiagramm | Kegelsäulen (gruppiert) | xlConeColClustered
 | Kegelbalken (gruppiert) | xlConeBarClustered
 | Kegelsäulen (gestapelt) | xlConeColStacked
 | Kegelbalken (gestapelt) | xlConeBarStacked
 | Kegelsäulen (100%, gestapelt) | xlConeColStacked100
 | Kegelbalken (100%, gestapelt) | xlConeBarStacked100
 | 3D-Kegelsäulen | xlConeCol
Pyramidendiagramm | Pyramidensäulen (gruppiert) | xlPyramidColClustered
 | Pyramidenbalken (gruppiert) | xlPyramidBarClustered
 | Pyramidensäulen (gestapelt) | xlPyramidColStacked
 | Pyramidenbalken (gestapelt) | xlPyramidBarStacked
 | Pyramidensäulen (100%, gestapelt) | xlPyramidColStacked100
 | Pyramidenbalken (100%, gestapelt) | xlPyramidBarStacked100
 | 3D-Pyramidensäulen | xlPyramidCol

Anmerkungen

Einige Diagrammtypen sind für PivotChart-Berichte nicht verfügbar.


Beispiel zur ChartType-Eigenschaft

In diesem Beispiel wird die Blasengröße in der Diagrammgruppe 1 auf 200% der Standardgröße gesetzt, wenn es sich beim Diagramm um ein 2D-Blasen-Diagramm handelt.

With Worksheets(1).ChartObjects(1).Chart
    If .ChartType = xlBubble Then
        .ChartGroups(1).BubbleScale = 200
    End If
End With


CheckIfOfficeIsHTMLEditor-Eigenschaft

True, wenn Microsoft Excel beim Starten von Excel überprüft, ob eine Office-Anwendung der Standard-HTML-Editor ist. False, wenn Excel diese Überprüfung nicht durchführt. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird nur dann verwendet, wenn der verwendete Webbrowser HTML-Bearbeitung und HTML-Editoren unterstützt.

Um einen anderen HTML-Editor zu verwenden, müssen Sie diese Eigenschaft auf False einstellen und anschließend den Editor als Standard-HTML-Editor für das System registrieren.


Beispiel zur CheckIfOfficeIsHTMLEditor-Eigenschaft

In diesem Beispiel wird veranlasst, dass Microsoft Excel keine Überprüfung durchführt, ob Office als Standard-HTML-Editor festgelegt wird.

Application.DefaultWebOptions.CheckIfOfficeIsHTMLEditor = False


 ChildField-Eigenschaft

ChildField-Eigenschaft

Gibt ein PivotField-Objekt zurück, das das untergeordnete Feld für das angegebene Feld darstellt (wenn das Feld eine Gruppierung und ein untergeordnetes Feld hat). Schreibgeschützt.

Anmerkungen

Wenn das angegebene Feld kein untergeordnetes Feld hat, führt diese Eigenschaft zu einem Fehler.

Diese Eigenschaft ist für OLAP-Datenquellen nicht verfügbar.


Beispiel zur ChildField-Eigenschaft

In diesem Beispiel wird der Name des dem Feld "REGION2" untergeordneten Felds angezeigt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
MsgBox "The name of the child field is " & _
    pvtTable.PivotFields("REGION2").ChildField.Name


 ChildItems-Eigenschaft

ChildItems-Eigenschaft

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Element (ein PivotItem-Objekt, Syntax 1) oder eine Auflistung aller Elemente (ein PivotItems-Objekt, Syntax 2) darstellt, die untergeordnete Gruppenelemente im angegebenen Feld oder untergeordnete Elemente des angegebenen Elements sind. Schreibgeschützt.

Syntax 1

Ausdruck.ChildItems(Index)

Syntax 2

Ausdruck.ChildItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField- oder PivotItem-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des Elements (kann eine Matrix zur Angabe mehrerer Elemente sein).

Anmerkungen

Diese Eigenschaft ist für OLAP-Datenquellen nicht verfügbar.


Beispiel zur ChildItems-Eigenschaft

In diesem Beispiel werden die Namen aller dem Element "Nordwesten" untergeordneten Elemente in ein Listenfeld auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtItem In _
        pvtTable.PivotFields("product")
        .PivotItems("vegetables").ChildItems
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtItem.Name
Next pvtItem


CircularReference-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den ersten Zirkelbezug des Blattes enthält. Wenn kein Zirkelbezug vorhanden ist, wird Nothing zurückgegeben. Der Zirkelbezug muss entfernt werden, bevor die Berechnung fortgesetzt werden kann. Schreibgeschützt.


Beispiel zur CircularReference-Eigenschaft

In diesem Beispiel wird die erste Zelle des ersten Zirkelbezugs in Sheet1 markiert.

Worksheets("Sheet1").CircularReference.Select


ClipboardFormats-Eigenschaft

Gibt die Formate, die zurzeit in der Zwischenablage enthalten sind, als eine Matrix numerischer Werte zurück. Um festzustellen, ob ein bestimmtes Format vorhanden ist, vergleichen Sie jedes Element der Matrix mit der entsprechenden Konstante, die unter "Anmerkungen" aufgeführt ist.

Syntax

Ausdruck.ClipboardFormats(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Variant optional. Das Matrixelement, das zurückgegeben werden soll. Wenn dieses Argument entfällt, gibt die Eigenschaft die gesamte Matrix der Formate zurück, die zurzeit in der Zwischenablage enthalten sind. Weitere Informationen finden Sie unter "Anmerkungen".

Anmerkungen

Diese Eigenschaft gibt eine Matrix numerischer Werte zurück. Um festzustellen, ob ein bestimmtes Format vorhanden ist, vergleichen Sie jedes Element der Matrix mit einer der folgenden XlClipboardFormat-Konstanten:

xlClipboardFormatBIFF

xlClipboardFormatBIFF2

xlClipboardFormatBIFF3

xlClipboardFormatBIFF4

xlClipboardFormatBinary

xlClipboardFormatBitmap

xlClipboardFormatCGM

xlClipboardFormatCSV

xlClipboardFormatDIF

xlClipboardFormatDspText

xlClipboardFormatEmbeddedObject

xlClipboardFormatEmbedSource

xlClipboardFormatLink

xlClipboardFormatLinkSource

xlClipboardFormatLinkSourceDesc

xlClipboardFormatMovie

xlClipboardFormatNative

 xlClipboardFormatObjectDesc

xlClipboardFormatObjectLink

xlClipboardFormatOwnerLink

xlClipboardFormatPICT

xlClipboardFormatPrintPICT

xlClipboardFormatRTF

xlClipboardFormatScreenPICT

xlClipboardFormatStandardFont

xlClipboardFormatStandardScale

xlClipboardFormatSYLK

xlClipboardFormatTable

xlClipboardFormatText

xlClipboardFormatToolFace

xlClipboardFormatToolFacePICT

xlClipboardFormatVALU

xlClipboardFormatWK1


CodeName-Eigenschaft

Gibt den Codenamen für das Objekt zurück. String Schreibgeschützt.

Anmerkung Der Wert, der im Fenster Eigenschaften in der Zelle rechts neben (Name) angezeigt wird, ist der Codename des ausgewählten Objekts. Sie können den Codenamen eines Objekts beim Entwurf ändern, indem Sie diesen Wert ändern. Eine programmgesteuerte Änderung dieser Eigenschaft während der Ausführung des Programms ist nicht möglich.

Anmerkungen

Der Codename für ein Objekt kann an Stelle eines Ausdrucks verwendet werden, der das Objekt zurückgibt. Wenn der Codename des ersten Tabellenblatts Sheet1 lautet, stimmen die beiden folgenden Ausdrücke miteinander überein:

Worksheets(1).Range("a1")
Sheet1.Range("a1")

Der Blattname kann sich vom Codenamen unterscheiden. Beim Erstellen eines Blatts stimmen Blattname und Codename überein. Die Änderung des Blattnamens wirkt sich jedoch nicht auf den Codenamen aus, und die Änderung des Codenamens (mit Hilfe des Fensters Eigenschaften im Visual Basic-Editor) ändert nicht den Blattnamen.


Beispiel zur CodeName-Eigenschaft

In diesem Beispiel wird der Code-Name des ersten Tabellenblattes angezeigt.

MsgBox Worksheets(1).CodeName


Color-Eigenschaft

Gibt die Primärfarbe des Objekts zurück bzw. legt sie fest, wie in der folgenden Tabelle aufgeführt. Zur Erstellung des Farbwerts verwenden Sie die RGB-Funktion. Long Schreib-Lese-Zugriff.

Objekt | Farbe
Border | Die Farbe des Rahmens.
Borders | Die Farbe aller vier Rahmenseiten eines Bereichs. Color gibt 0 (Null) zurück, wenn sie verschieden sind.
Font | Die Farbe der Schriftart.
Interior | Die Farbe des Innenbereichs der Zellen bzw. des Zeichenobjekts.


ColorIndex-Eigenschaft

Gibt die Farbe des Rahmens, der Schriftart oder des Innenraums entsprechend der folgenden Tabelle zurück. Die Farbe wird als Indexwert in der aktuellen Farbpallette oder als XlColorIndex-Konstante (xlColorIndexAutomatic oder xlColorIndexNone) zurückgegeben. Variant Schreib-Lese-Zugriff.

Objekt | ColorIndex
Border | Die Farbe des Rahmens.
Borders | Die Farbe aller vier Rahmen. Gibt Null zurück, wenn nicht alle vier Farben gleich sind.
Font | Die Farbe der Schriftart. Geben Sie xlColorIndexAutomatic an, um die Farbe automatisch zu verwenden.
Interior | Die Füllfarbe des Innenraums. Weisen Sie dieser Eigenschaft xlColorIndexNone zu, um den Innenraum nicht zu füllen; weisen Sie xlColorIndexAutomatic zu, um diesen automatisch zu füllen (bei Zeichnungsobjekten).

Anmerkungen

Diese Eigenschaft gibt die Farbe als einen Index der Farbpalette in der Arbeitsmappe an. Verwenden Sie die Colors-Methode, um sich die aktuelle Farbpalette zurückgeben zu lassen.

Die folgende Abbildung zeigt die Farbindexwerte der Standard-Farbpalette.

Farbindexwerte der Standard-Farbpalette


Beispiel zur ColorIndex-Eigenschaft

In den folgenden Beispielen wird vorausgesetzt, dass die Standard-Farbpalette verwendet wird.

In diesem Beispiel wird die Farbe der Schriftart von Zelle A1 in Sheet1 in die Farbe Rot geändert.

Worksheets("Sheet1").Range("A1").Font.ColorIndex = 3

In diesem Beispiel wird die Farbe der Hauptgitternetzlinien der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 5    ' set color to blue
    End If
End With

In diesem Beispiel wird dem Innenraum von Chart1 die Farbe Rot und dem Rahmen die Farbe Blau zugewiesen.

With Charts("Chart1").ChartArea
    .Interior.ColorIndex = 3
    .Border.ColorIndex = 5
End With


Colors-Eigenschaft

Gibt die Farben in der Palette der Arbeitsmappe zurück oder legt sie fest. Die Palette hat 56 Einträge, die jeweils als RGB-Wert angegeben werden. Variant Schreib-Lese-Zugriff.

Syntax

Ausdruck.Colors(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbook-Objekt zurückgibt.

Index Variant optional. Die Farbnummer (von 1 bis 56). Wird dieses Argument nicht angegeben, wird eine Matrix mit allen 56 Farben der Palette zurückgegeben.


Beispiel zur Colors-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Farbpalette von BOOK2.XLS für die aktive Arbeitsmappe übernommen wird.

ActiveWorkbook.Colors = Workbooks("BOOK2.XLS").Colors

In diesem Beispiel wird die Farbe Nr. 5 in der Farbpalette für die aktive Arbeitsmappe festgelegt.

ActiveWorkbook.Colors(5) = RGB(255, 0, 0)


ColorType-Eigenschaft

Gibt die auf das angegebene Bild oder OLE-Objekt angewendete Art der Farbumwandlung zurück oder legt sie fest. Kann eine der folgenden MsoPictureColorType-Konstanten sein: msoPictureAutomatic, msoPictureBlackAndWhite, msoPictureGrayscale, msoPictureMixed oder msoPictureWatermark. Long Schreib-Lese-Zugriff.


Beispiel zur ColorType-Eigenschaft

In diesem Beispiel werden für die Farbumwandlung der ersten Form in myDocument Graustufen festgelegt. Bei der ersten Form muss es sich um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).PictureFormat.ColorType = msoPictureGrayScale


Column-Eigenschaft

Gibt die erste Spalte am Anfang des angegebenen Bereichs als Zahl zurück. Long Schreibgeschützt.

Anmerkungen

Spalte A entspricht dem Rückgabewert 1, Spalte B dem Wert 2 usw.

Die Zahl der letzten Spalte in dem Bereich können Sie folgendermaßen zurückgeben:

myRange.Columns(myRange.Columns.Count).Column


Column3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Säulendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Column3DGroup-Eigenschaft

In diesem Beispiel wird der Abstand zwischen den Säulengruppen in der 3D-Säulendiagrammgruppe auf 50 Prozent der Spaltenbreite festgelegt.

Charts(1).Column3DGroup.GapWidth = 50


ColumnFields-Eigenschaft

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Feld (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller Felder (ein PivotFields-Objekt, Syntax 2) darstellt, die zurzeit als Spaltenfelder angezeigt werden. Schreibgeschützt.

Syntax 1

Ausdruck.ColumnFields(Index)

Syntax 2

Ausdruck.ColumnFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des Feldes (kann eine Matrix zur Angabe mehrerer Felder sein).


Beispiel zur ColumnFields-Eigenschaft

In diesem Beispiel werden die Namen der Spaltenfelder des PivotTable-Berichts in eine Liste auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.ColumnFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


ColumnGrand-Eigenschaft

True, wenn im PivotTable-Bericht Spaltengesamtergebnisse angezeigt werden. Boolean Lese- und Schreibzugriff.


Beispiel zur ColumnGrand-Eigenschaft

In diesem Beispiel wird festgelegt, dass im PivotTable-Bericht Spaltengesamtergebnisse angezeigt werden.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.ColumnGrand = True


ColumnRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den Spaltenbereich des PivotTable-Berichts enthält. Schreibgeschützt.


Beispiel zur ColumnRange-Eigenschaft

In diesem Beispiel werden die Spaltenköpfe für den PivotTable-Bericht ausgewählt.

Worksheets("Sheet1").Activate
Range("A3").Select
ActiveCell.PivotTable.ColumnRange.Select


Columns-Eigenschaft

Application-Objekt: Gibt ein Range-Objekt zurück, das alle Spalten des aktiven Tabellenblatts darstellt. Wenn das aktive Dokument kein Tabellenblatt ist, verursacht die Columns-Eigenschaft einen Fehler. Schreibgeschützt.

Range-Objekt: Gibt ein Range-Objekt zurück, das die Spalten im angegebenen Bereich darstellt. Schreibgeschützt.

Worksheet-Objekt: Gibt ein Range-Objekt zurück, das alle Spalten im angegebenen Tabellenblatt darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Wenn Sie diese Eigenschaft ohne einen Objektkennzeichner verwenden, hat sie die gleiche Funktion wie ActiveSheet.Columns.

Wenn diese Eigenschaft auf ein Range-Objekt angewendet wird, das eine Mehrfachmarkierung enthält, gibt sie lediglich die Spalten aus dem ersten Teil des Bereichs zurück. Wenn das Range-Objekt zum Beispiel zwei Bereiche – A1:B2 und C3:D4 – aufweist, gibt Selection.Columns.Count nicht 4, sondern 2 zurück. Wenn Sie diese Eigenschaft auf einen Bereich anwenden möchten, der möglicherweise eine Mehrfachmarkierung enthält, prüfen Sie mit Areas.Count, ob dies der Fall ist. Wenn der Bereich eine Mehrfachmarkierung enthält, müssen Sie die Eigenschaft in einer Schleife auf jeden Bereich einzeln anwenden.


Beispiel zur Columns-Eigenschaft

In diesem Beispiel wird die Schriftart der ersten Spalte (Spalte A) in Sheet1 fett formatiert.

Worksheets("Sheet1").Columns(1).Font.Bold = True

Dieses Beispiel setzt den Wert aller Zellen in der ersten Spalte im Bereich "MyRange" auf 0 (Null).

Range("myRange").Columns(1).Value = 0

Im folgenden Beispiel wird die Anzahl der Spalten in der Markierung in Sheet1 angezeigt. Sind mehrere Bereiche markiert, werden alle Bereiche in einer Schleife bearbeitet.

Worksheets("Sheet1").Activate
areaCount = Selection.Areas.Count
If areaCount <= 1 Then
    MsgBox "The selection contains " & _
        Selection.Columns.Count & " columns."
Else
    For i = 1 To areaCount
        MsgBox "Area " & i & " of the selection contains " & _
            Selection.Areas(i).Columns.Count & " columns."
    Next i
End If


ColumnWidth-Eigenschaft

Gibt die Breite aller Spalten im angegebenen Bereich zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.

Anmerkungen

Die Einheit für die Spaltenbreite entspricht der Breite eines Zeichens in der Formatvorlage Standard. Bei Proportionalschriftarten wird die Breite des Zeichens 0 (Null) verwendet.

Wenn Sie die Breite einer Spalte in Punkt zurückgeben wollen, müssen Sie die Width-Eigenschaft verwenden.

Besitzen alle Spalten in dem Bereich dieselbe Breite, so gibt ColumnWidth-Eigenschaft diese Breite zurück. Sind die Spalten unterschiedlich breit, so gibt die Eigenschaft Null zurück.


Beispiel zur ColumnWidth-Eigenschaft

In diesem Beispiel wird die Breite der Spalte A in Sheet1 verdoppelt.

With Worksheets("Sheet1").Columns("A")
    .ColumnWidth = .ColumnWidth * 2
End With


COMAddIns-Eigenschaft

Gibt die COMAddIns-Auflistung für Microsoft Excel zurück, die die aktuell installierten COM-Add-Ins darstellt. Schreibgeschützt.


Beispiel zur COMAddIns-Eigenschaft

In diesem Beispiel wird die Anzahl der aktuell installierten COM-Add-Ins angezeigt.

Set objAI = Application.COMAddIns
MsgBox "Number of COM add-ins available:" & _
    objAI.Count


CommandBars-Eigenschaft

Gibt ein CommandBars-Objekt zurück, das die Microsoft Excel-Command-Bars darstellt. Schreibgeschützt.

Anmerkungen

In Verbindung mit dem Application-Objekt gibt diese Eigenschaft die Einstellung der integrierten und benutzerdefinierten Command-Bars, die für die Anwendung zur Verfügung stehen, zurück.

Ist die Arbeitsmappe in eine andere Anwendung eingegliedert und von dem Anwender durch einen Doppelklick auf die Arbeitsmappe aktiviert, gibt diese Eigenschaft in Verbindung mit einem Workbook-Objekt die Einstellungen der Microsoft Excel-Command-Bars, die innerhalb anderer Anwendungen zur Verfügung stehen, zurück. In allen anderen Fällen gibt diese Eigenschaft in Verbindung mit einem Workbook-Objekt Nothing zurück.

Die mit einer Arbeitsmappe verbundene Einstellung von Command-Bars kann nicht zurückgegeben werden.


Beispiel zur CommandBars-Eigenschaft

In diesem Beispiel werden alle benutzerdefinierten Befehlsleisten gelöscht, die nicht sichtbar sind.

For Each bar In Application.CommandBars
    If Not bar.BuiltIn And Not bar.Visible Then bar.Delete
Next


CommandText-Eigenschaft

Gibt die Befehlszeichenfolge für die angegebene Datenquelle zurück oder legt diese fest. Variant Schreib-Lese-Zugriff.

Anmerkungen

Sie sollten die CommandText-Eigenschaft an Stelle der SQL-Eigenschaft verwenden, die es jetzt hauptsächlich aus Kompatibilitätsgründen mit früheren Versionen von Microsoft Excel gibt. Werden beide Eigenschaften verwendet, hat der Wert der CommandText-Eigenschaft Vorrang.

Bei OLE DB-Quellen beschreibt die CommandType-Eigenschaft den Wert der CommandText-Eigenschaft.

Bei ODBC-Quellen funktioniert die CommandText-Eigenschaft genauso wie die SQL-Eigenschaft. Beim Einstellen der Eigenschaft werden die Daten aktualisiert.


Beispiel zur CommandText-Eigenschaft

In diesem Beispiel wird die Befehlszeichenfolge für die ODBC-Datenquelle der ersten Abfragetabelle festgelegt. Beachten Sie, dass es sich bei der Befehlszeichenfolge um eine SQL-Anweisung handelt.

Set qtQtrResults = _
    Workbooks(1).Worksheets(1).QueryTables(1)
With qtQtrResults
    .CommandType = xlCmdSQL
    .CommandText = _
        "Select ProductID From Products Where ProductID < 10"
    .Refresh
End With


 CommandType-Eigenschaft

CommandType-Eigenschaft

Gibt eine der in der folgenden Tabelle aufgeführten XlCmdType-Konstanten zurück oder legt diese fest. Die zurückgegebene oder festgelegte Konstante beschreibt den Wert der CommandText-Eigenschaft. Der Standardwert ist xlCmdSQL. XlCmdType Schreib-Lese-Zugriff.

Konstante | Beschreibung
xlCmdCube | Enthält einen Cube-Namen für eine OLAP-Datenquelle.
xlCmdDefault | Enthält Befehlstext, der vom OLE DB-Provider verstanden wird.
xlCmdSQL | Enthält eine SQL-Anweisung.
xlCmdTable | Enthält einen Tabellennamen für den Zugriff auf OLE DB-Datenquellen.

Anmerkungen

Sie können die CommandType-Eigenschaft nur dann festlegen, wenn der Wert der QueryType-Eigenschaft für die Abfragetabelle oder den PivotTable-Cache xlOLEDBQuery lautet.

Wenn der Wert der CommandType-Eigenschaft xlCmdCube lautet, können Sie diesen Wert nicht ändern, falls der Abfragetabelle ein PivotTable-Bericht zugeordnet wurde.


Beispiel zur CommandType-Eigenschaft

In diesem Beispiel wird die Befehlszeichenfolge für die ODBC-Datenquelle der ersten Abfragetabelle festgelegt. Bei der Befehlszeichenfolge handelt es sich um eine SQL-Anweisung.

Set qtQtrResults = _
    Workbooks(1).Worksheets(1).QueryTables(1)
With qtQtrResults
    .CommandType = xlCmdSQL
    .CommandText = _
        "Select ProductID From Products Where ProductID < 10"
    .Refresh
End With


CommandUnderlines-Eigenschaft

Gibt den Status der CommandUnderlines (unterstrichene Buchstaben in Befehlen) in Microsoft Excel für den Macintosh zurück bzw. stellt den Status ein. Zulässig sind folgende XlCommandUnderlines-Konstanten: xlCommandUnderlinesOn, xlCommandUnderlinesOff oder xlCommandUnderlinesAutomatic. Long Schreib-Lese-Zugriff.

Anmerkungen

In Microsoft Excel für Windows wird beim Lesen dieser Eigenschaft immer der Wert xlCommandUnderlinesOn zurückgegeben. Wenn Sie einen anderen Wert als xlCommandUnderlinesOn einstellen, wird ein Fehler zurückgegeben.


Beispiel zur CommandUnderlines-Eigenschaft

Das folgende Beispiel deaktiviert CommandUnderlines in Microsoft Excel für den Macintosh.

Application.CommandUnderlines = xlCommandUnderlinesOff


Comment-Eigenschaft

Range-Objekt: Gibt ein Comment-Objekt zurück, das den Kommentar darstellt, der mit der Zelle in der linken oberen Ecke des Bereichs verknüpft ist. Schreibgeschützt.

Scenario-Objekt: Gibt den Kommentar zurück, der mit dem Szenario verknüpft ist, oder legt ihn fest. Der Kommentartext kann bis zu 255 Zeichen lang sein. String Schreib-Lese-Zugriff.


Comments-Eigenschaft

Gibt eine Comments-Auflistung zurück, die alle Kommentare in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über das Zurückgeben jeweils eines Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Comments-Eigenschaft

In diesem Beispiel werden alle von Jean Selva hinzugefügten Kommentare im aktiven Blatt gelöscht.

For Each c in ActiveSheet.Comments
    If c.Autor = "Jean Selva" Then c.Delete
Next


ConflictResolution-Eigenschaft

Gibt die Methode zum Lösen von Konflikten bei der Aktualisierung einer gemeinsam genutzten Arbeitsmappe zurück oder legt sie fest. XlSaveConflictResolution Schreib-Lese-Zugriff.

Kann eine der folgenden XlSaveConflictResolution-Konstanten sein:

Konstante | Beschreibung
xlLocalSessionChanges | Die Änderungen des lokalen Benutzers werden immer akzeptiert.
xlOtherSessionChanges | Die Änderungen des lokalen Benutzers werden immer zurückgewiesen.
xlUserResolution | Der Benutzer wird in einem Dialogfeld aufgefordert, den Konflikt zu lösen.


Beispiel zur ConflictResolution-Eigenschaft

In diesem Beispiel werden die Änderungen des lokalen Benutzers akzeptiert, sobald ein Konflikt in der gemeinsam genutzten Arbeitsmappe auftritt.

ActiveWorkbook.ConflictResolution = xlLocalSessionChanges


 Connection-Eigenschaft

Connection-Eigenschaft

Gibt eine Zeichenfolge zurück, die eines der folgenden Elemente enthält: OLE DB-Einstellungen, die es Microsoft Excel ermöglichen, die Verbindung zu einer OLE DB-Datenquelle aufzubauen; ODBC-Einstellungen, die es Microsoft Excel ermöglichen, die Verbindung zu einer ODBC-Datenquelle aufzubauen; ein URL, der es Microsoft Excel ermöglicht, die Verbindung zu einer Webdatenquelle aufzubauen; der Pfad und der Dateiname einer Textdatei oder der Pfad und der Dateiname einer Datei, die eine Datenbank oder eine Webabfrage festlegt. Variant Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der Connection-Eigenschaft wird die Verbindung zur Datenquelle nicht sofort eingeleitet. Zum Aufbau der Verbindung und zum Abrufen der Daten müssen Sie die Refresh-Methode verwenden.

Legen Sie beim Verwenden einer Offline-Cube-Datei die UseLocalConnection-Eigenschaft auf True fest, und verwenden Sie die LocalConnection-Eigenschaft an Stelle der Connection-Eigenschaft.

Weitere Informationen über die Syntax der Verbindungszeichenfolge finden Sie unter der Add-Methode der QueryTables-Auflistung und die Add-Methode der PivotCachesAuflistung.

Um die Leistung zu steigern, können Sie stattdessen mit Hilfe der Microsoft ADO-Bibliothek (ActiveX Data Objects) direkt auf eine Datenquelle zugreifen. Weitere Information zu ActiveX Data Objects finden Sie unter Willkommen bei ADO.


ConnectionSiteCount-Eigenschaft

Gibt die Anzahl der Verbindungspunkte der angegebenen Form zurück. Long Schreibgeschützt.


Beispiel zur ConnectionSiteCount-Eigenschaft

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und mit zwei Verbindungen aneinandergefügt. Die Anfangspunkte beider Verbindungen sind dem ersten Verbindungspunkt des ersten Rechtecks zugeordnet, die Endpunkte dem ersten und letzten Verbindungspunkt des zweiten Rechtecks.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, _
    100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, _
    300, 300, 200, 100)
lastsite = secondRect.ConnectionSiteCount
With s.AddConnector(msoConnectorCurve, _
        0, 0, 100, 100).ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, _
        ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, _
        ConnectionSite:=1
End With
With s.AddConnector(msoConnectorCurve, _
        0, 0, 100, 100).ConnectorFormat
    .BeginConnect ConnectedShape:=firstRect, _
        ConnectionSite:=1
    .EndConnect ConnectedShape:=secondRect, _
        ConnectionSite:=lastsite
End With


Connector-Eigenschaft

True, wenn es sich bei der angegebenen Form um eine Verbindung handelt. Long Schreibgeschützt.


ConnectorFormat-Eigenschaft

Gibt ein ConnectorFormat-Objekt zurück, das Formateigenschaften einer Verbindung enthält. Gilt für Shape- oder ShapeRange-Objekte, die Verbindungen darstellen. Schreibgeschützt.


Beispiel zur ConnectorFormat-Eigenschaft

In diesem Beispiel werden in myDocument zwei Rechtecke eingefügt und mit einer Verbindung versehen, die automatisch auf dem kürzesten Weg verläuft. Anschließend wird die Verbindung von den Rechtecken gelöst.

Set myDocument = Worksheets(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(msoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(msoShapeRectangle, 300, 300, 200, 100)
Set c = s.AddConnector(msoConnectorCurve, 0, 0, 0, 0)
with c.ConnectorFormat
    .BeginConnect firstRect, 1
    .EndConnect secondRect, 1
    c.RerouteConnections
    .BeginDisconnect
    .EndDisconnect
End With


ConsolidationFunction-Eigenschaft

Gibt den für die aktuelle Konsolidierung verwendeten Funktionscode zurück. Kann eine der folgenden XlConsolidationFunction-Konstanten sein: xlAverage, xlCount, xlCountNums, xlMax, xlMin, xlProduct, xlStDev, xlStDevP, xlSum, xlUnknown, xlVar oder xlVarP. Long Schreibgeschützt.


Beispiel zur ConsolidationFunction-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn in der aktuellen Konsolidierung die Funktion SUM verwendet wird.

If Worksheets("Sheet1").ConsolidationFunction = xlSum Then
    MsgBox "Sheet1 uses the SUM function for consolidation."
End If


ConsolidationOptions-Eigenschaft

Gibt eine Matrix mit drei Elementen für die Konsolidierungsoptionen zurück, wie in der folgenden Tabelle dargestellt. Wenn ein Element den Wert True besitzt, wird die entsprechende Option festgelegt. Variant Schreibgeschützt.

Element | Bedeutung
1 | Bezeichnungen in oberster Zeile
2 | Bezeichnungen in linker Spalte
3 | Verknüpfungen zu Quelldaten erstellen


Beispiel zur ConsolidationOptions-Eigenschaft

In diesem Beispiel werden die Konsolidierungsoptionen für Sheet1 angezeigt. Die Liste wird in einem neuen Tabellenblatt angezeigt, die das Makro zuvor erstellt hat.

Set newSheet = Worksheets.Add
aOptions = Worksheets("Sheet1").ConsolidationOptions
newSheet.Range("A1").Value = "Use labels in top row"
newSheet.Range("A2").Value = "Use labels in left column"
newSheet.Range("A3").Value = "Create links to source data"
For i = 1 To 3
    If aOptions(i) = True Then
        newSheet.Cells(i, 2).Value = "True"
    Else
        newSheet.Cells(i, 2).Value = "False"
    End If
Next i
newSheet.Columns("A:B").AutoFit


ConsolidationSources-Eigenschaft

Gibt eine Matrix mit Zeichenfolgen zurück, die die Quellblätter für die aktuelle Konsolidierung des Arbeitsblattes bezeichnen. Es wird Empty zurückgegeben, falls es keine Konsolidierung für das Blatt gibt. Variant Schreibgeschützt.


Beispiel zur ConsolidationSources-Eigenschaft

In diesem Beispiel werden die Namen der Quellbereiche für die Konsolidierung in Sheet1 angezeigt. Die Liste wird in einem neuen Tabellenblatt angezeigt, die das Makro zuvor erstellt hat.

Set newSheet = Worksheets.Add
newSheet.Range("A1").Value = "Consolidation Sources"
aSources = Worksheets("Sheet1").ConsolidationSources
If IsEmpty(aSources) Then
    newSheet.Range("A2").Value = "none"
Else
    For i = 1 To UBound(aSources)
        newSheet.Cells(i + 1, 1).Value = aSources(i)
    Next i
End If
newSheet.Columns("A:B").AutoFit


ConstrainNumeric-Eigenschaft

True, wenn die Handschrifterkennung nur auf Zahlen und Zeichensetzung beschränkt ist. Boolean Schreib-Lese-Zugriff.

Anmerkung: Diese Eigenschaft ist für Microsoft Windows für Pen Computing verfügbar. Wenn Sie diese Eigenschaft auf irgendeinem anderen System verwenden, erhalten Sie einen Fehler.


Beispiel zur ConstrainNumeric-Eigenschaft

In diesem Beispiel wird die Handschrifterkennung auf Ziffern und Zeichensetzung eingeschränkt, falls der Computer unter Microsoft Windows für Pen Computing arbeitet.

If Application.WindowsForPens Then
    Application.ConstrainNumeric = True
End If


Container-Eigenschaft

Gibt das Objekt zurück, das die angegebene eingebettete Arbeitsmappe enthält. Object Schreibgeschützt.

Anmerkungen

Verwenden Sie diese Eigenschaft bei einer eingebetteten Arbeitsmappe, um das Container-Objekt zu erhalten. Falls das Container-Objekt OLE-Automation nicht unterstützt oder die Arbeitsmappe nicht eingebettet ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur Container-Eigenschaft

In diesem Beispiel wird der zweite Abschnitt in der Sammelmappe, die die aktive Microsoft Excel-Arbeitsmappe enthält, ausgeblendet und dann der Wert der Zelle A1 auf 345,67 gesetzt. Die Sammelmappe ist in diesem Beispiel Binder1.obd

Set myBinder = GetObject("Binder1.obd", "Office.Binder")
Set myWorkbook = myBinder.Sections(1).Object
With myWorkbook
    .Container.Sections(2).Visible = False
    .Sheets(1).Cells(1, 1).Value = 345.67
End With


Contrast-Eigenschaft

Gibt den Kontrast des angegebenen Bildes oder OLE-Objekts zurück oder legt ihn fest. Der Wert dieser Eigenschaft muss eine Zahl zwischen 0,0 (geringster Kontrast) und 1,0 (höchster Kontrast) sein. Single Schreib-Lese-Zugriff.


Beispiel zur Contrast-Eigenschaft

In diesem Beispiel wird der Kontrast der ersten Form in myDocument festgelegt. Bei der Form muss es sich entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).PictureFormat.Contrast = 0.8


ControlCharacters-Eigenschaft

True, wenn Microsoft Excel für Sprachen mit Schreibweise von links nach rechts Steuerzeichen anzeigt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann nur festgelegt werden, wenn die Unterstützung für Sprachen mit Schreibweise von rechts nach links installiert und aktiviert wurde.


Beispiel zur ControlCharacters-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel Steuerzeichen interpretiert.

Application.ControlCharacters = True


 ControlFormat-Eigenschaft

ControlFormat-Eigenschaft

Gibt ein ControlFormat-Objekt zurück, das Eigenschaften von Microsoft Excel-Steuerelementen besitzt. Schreibgeschützt.


Beispiel zur ControlFormat-Eigenschaft

In diesem Beispiel wird das markierte Element aus einem Listenfeld entfernt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Set lbcf = Worksheets(1).Shapes(2).ControlFormat
lbcf.RemoveItem lbcf.ListIndex


CopyObjectsWithCells-Eigenschaft

True, wenn die Objekte mit Zellen ausgeschnitten, kopiert, gesucht oder sortiert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur CopyObjectsWithCells-Eigenschaft

In diesem Beispiel wird festgelegt, dass Objekte in Microsoft Excel mit den Zellen ausgeschnitten, kopiert, gesucht und sortiert werden.

Application.CopyObjectsWithCells = True


Corners-Eigenschaft

Gibt ein Corners-Objekt zurück, das die Ecken eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur Corners-Eigenschaft

In diesem Beispiel werden die Ecken von Chart1 ausgewählt. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden (die Select-Methode erzeugt einen Fehler, wenn sie mit einem anderen Diagrammtyp verwendet wird).

With Charts("Chart1")
    .Activate
    .Corners.Select
End With


CorrectCapsLock-Eigenschaft

True, falls Microsoft Excel die unbeabsichtigte Verwendung der FESTSTELLTASTE automatisch korrigiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectCapsLock-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel die unbeabsichtigte Verwendung der FESTSTELLTASTE automatisch korrigiert.

Application.AutoCorrect.CorrectCapsLock = True


CorrectSentenceCap-Eigenschaft

True, falls Microsoft Excel die Großschreibung des ersten Wortes in einem Satz automatisch korrigiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur CorrectSentenceCap-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel die Großschreibung des ersten Wortes in einem Satz automatisch korrigiert.

Application.AutoCorrect.CorrectSentenceCap = True


 Count-Eigenschaft

Count-Eigenschaft

Gibt die Anzahl der Objekte der Auflistung zurück. Long Schreibgeschützt.

Informationen über die Tabellenfunktion Anzahl der Exemplare in Visual Basic, finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.

Anmerkungen

Bei OLAP-Datenquellen werden lediglich die sichtbaren Felder in einem PivotTable-Bericht gezählt.


Beispiel zur Count-Eigenschaft

Im folgenden Beispiel wird die Anzahl der markierten Spalten in Sheet1 angezeigt. Es wird auch auf eine Mehrfachmarkierung geprüft. Trifft dies zu, werden alle Teile der Mehrfachmarkierung in einer Schleife bearbeitet.

Worksheets("Sheet1").Activate
areaCount = Selection.Areas.Count
If areaCount <= 1 Then
    MsgBox "The selection contains " & _
        Selection.Columns.Count & " columns."
Else
    For i = 1 To areaCount
        MsgBox "Area " & i & " of the selection contains " & _
            Selection.Areas(i).Columns.Count & " columns."
    Next i
End If

In diesem Beispiel wird das letzte Zeichen in Zelle A1 hoch gestellt.

n = Worksheets("Sheet1").Range("A1").Characters.Count
Worksheets("Sheet1").Range("A1").Characters(n, 1) _
    .Font.Superscript = True


CreateBackup-Eigenschaft

True, wenn beim Speichern der Datei eine Sicherungsdatei erstellt wird. Boolean Schreibgeschützt.


Beispiel zur CreateBackup-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn beim Speichern der aktiven Arbeitsmappe eine Sicherungsdatei erstellt wird.

If ActiveWorkbook.CreateBackup = True Then
    MsgBox "Remember, there is a backup copy of this workbook"
End If


Creator-Eigenschaft

Gibt die Anwendung, in der dieses Objekt erstellt wurde, als 32-Bit-Ganzzahl zurück. Wurde das Objekt in Microsoft Excel erstellt, gibt die Eigenschaft die Zeichenfolge XCEL zurück, die der Hexadezimalzahl 5843454C entspricht. Long Schreibgeschützt.

Anmerkungen

Die Creator-Eigenschaft wurde speziell für den Einsatz in Microsoft Excel für den Macintosh geschaffen, wo jede Anwendung einen Urheber-Code aus vier Zeichen besitzt. Der Urheber-Code für Microsoft Excel lautet XCEL.


Beispiel zur Creator-Eigenschaft

In diesem Beispiel wird eine Meldung über den Urheber von meinObjekt angezeigt.

Set myObject = ActiveWorkbook
If myObject.Creator = &h5843454c Then
    MsgBox "This is a Microsoft Excel object"
Else
    MsgBox "This is not a Microsoft Excel object"
End If


Criteria1-Eigenschaft

Gibt den ersten gefilterten Wert für die angegebene Spalte in einem gefilterten Bereich zurück. Variant Schreibgeschützt.


Beispiel zur Criteria1-Eigenschaft

Im folgenden Beispiel wird eine Variable auf den Wert der Criteria1-Eigenschaft des Filters für die erste Spalte in dem gefilterten Bereich im Tabellenblatt "Crew" festgelegt.

With Worksheets("Crew")
    If .AutoFilterMode Then
        With .AutoFilter.Filters(1)
            If .On Then c1 = .Criteria1
        End With
    End If
End With


Criteria2-Eigenschaft

Gibt den zweiten gefilterten Wert für die angegebene Spalte in einem gefilterten Bereich zurück. Variant Schreibgeschützt.

Anmerkungen

Beim Versuch, auf die Criteria2-Eigenschaft eines Filters zuzugreifen, der nur ein Kriterium verwendet, tritt ein Fehler auf. Überprüfen Sie vor dem Versuch, auf die Criteria2-Eigenschaft zuzugreifen, ob die Operator-Eigenschaft eines Filter-Objekts ungleich Null (0) ist.


Beispiel zur Criteria2-Eigenschaft

In dem folgenden Beispiel wird eine Variable auf den Wert der Criteria2-Eigenschaft des Filters für die erste Spalte in dem gefilterten Bereich im Tabellenblatt "Crew" festgelegt.

With Worksheets("Crew")
    If .AutoFilterMode Then
        With .AutoFilter.Filters(1)
            If .On And .Operator Then
                c2 = .Criteria2
            Else
                c2 = "Not set"
            End If
        End With
    End If
End With


CropBottom-Eigenschaft

Gibt die Anzahl der Punkte zurück, um die das angegebene Bild oder OLE-Objekt an der unteren Seite zugeschnitten wird, oder legt die Anzahl fest. Single Schreib-Lese-Zugriff.

Anmerkung Das Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Fügen Sie beispielsweise ein ursprünglich 100 Punkt hohes Bild ein, skalieren es auf eine Höhe von 200 Punkt und legen danach für die CropBottom-Eigenschaft den Wert 50 fest, dann wird das Bild an der unteren Seite um 100 Punkt (und nicht um 50) zugeschnitten.


Beispiel zur CropBottom-Eigenschaft

In diesem Beispiel wird die dritte Form in myDocument um 20 Punkt an der unteren Seite zugeschnitten. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).PictureFormat.CropBottom = 20

Wenn Sie folgendes Beispiel verwenden, können Sie den Prozentsatz angeben, um den Sie die markierte Form an der unteren Seite zuschneiden möchten, unabhängig davon, ob die Form skaliert wurde oder nicht. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

percentToCrop = InputBox( _
    "What percentage do you want to crop off" & _
    " the bottom of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropBottom = cropPoints


CropLeft-Eigenschaft

Gibt die Anzahl der Punkte zurück, um die das angegebene Bild oder OLE-Objekt an der linken Seite zugeschnitten wird, oder legt die Anzahl fest. Single Schreib-Lese-Zugriff.

Anmerkung Das Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Fügen Sie beispielsweise ein ursprünglich 100 Punkt breites Bild ein, skalieren es auf eine Breite von 200 Punkt und legen danach für die CropLeft-Eigenschaft den Wert 50 fest, dann wird das Bild an der linken Seite um 100 Punkt (und nicht um 50) zugeschnitten.


Beispiel zur CropLeft-Eigenschaft

In diesem Beispiel wird die dritte Form in myDocument um 20 Punkt an der linken Seite zugeschnitten. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).PictureFormat.CropLeft = 20

Wenn Sie folgendes Beispiel verwenden, können Sie den Prozentsatz angeben, um den Sie die markierte Form an der linken Seite zuschneiden möchten, unabhängig davon, ob die Form skaliert wurde oder nicht. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

percentToCrop = InputBox( _
    "What percentage do you want to crop" & _
    " off the left of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropLeft = cropPoints


CropRight-Eigenschaft

Gibt die Anzahl der Punkte zurück, um die das angegebene Bild oder OLE-Objekt an der rechten Seite zugeschnitten wird, oder legt die Anzahl fest. Single Schreib-Lese-Zugriff.

Anmerkung Das Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Fügen Sie beispielsweise ein ursprünglich 100 Punkt breites Bild ein, skalieren es auf eine Breite von 200 Punkt und legen danach für die CropRight-Eigenschaft den Wert 50 fest, dann wird das Bild an der rechten Seite um 100 Punkt (und nicht um 50) zugeschnitten.


Beispiel zur CropRight-Eigenschaft

In diesem Beispiel wird die dritte Form in myDocument um 20 Punkt an der rechten Seite zugeschnitten. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).PictureFormat.CropRight = 20

Wenn Sie folgendes Beispiel verwenden, können Sie den Prozentsatz angeben, um den Sie die markierte Form an der rechten Seite zuschneiden möchten, unabhängig davon, ob die Form skaliert wurde oder nicht. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

percentToCrop = InputBox( _
    "What percentage do you want to crop" & _
    " off the right of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleWidth 1, True
    origWidth = .Width
    .Delete
End With
cropPoints = origWidth * percentToCrop / 100
shapeToCrop.PictureFormat.CropRight = cropPoints


CropTop-Eigenschaft

Gibt die Anzahl der Punkte zurück, um die das angegebene Bild oder OLE-Objekt an der oberen Seite zugeschnitten wird, oder legt die Anzahl fest. Single Schreib-Lese-Zugriff.

Anmerkung Das Zuschneiden wird relativ zur Originalgröße des Bildes berechnet. Fügen Sie beispielsweise ein ursprünglich 100 Punkt hohes Bild ein, skalieren es auf eine Höhe von 200 Punkt und legen danach für die CropTop-Eigenschaft den Wert 50 fest, dann wird das Bild an der oberen Seite um 100 Punkt (und nicht um 50) zugeschnitten.


Beispiel zur CropTop-Eigenschaft

In diesem Beispiel wird die dritte Form in myDocument um 20 Punkt an der oberen Seite zugeschnitten. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(3).PictureFormat.CropTop = 20

Mit folgendem Beispiel können Sie den Prozentsatz angeben, um den Sie die markierte Form an der oberen Seite zuschneiden möchten, unabhängig davon, ob die Form skaliert wurde oder nicht. Damit das Beispiel funktioniert, muss es sich bei der Form entweder um ein Bild oder ein OLE-Objekt handeln.

percentToCrop = InputBox( _
    "What percentage do you want to crop" & _
    " off the top of this picture?")
Set shapeToCrop = ActiveWindow.Selection.ShapeRange(1)
With shapeToCrop.Duplicate
    .ScaleHeight 1, True
    origHeight = .Height
    .Delete
End With
cropPoints = origHeight * percentToCrop / 100
shapeToCrop.PictureFormat.CropTop = cropPoints


Crosses-Eigenschaft

Gibt auf der angegebenen Achse den Schnittpunkt mit der anderen Achse zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Kann eine der in der folgenden Tabelle aufgeführten XlAxisCrosses-Konstanten sein.

Konstante | Bedeutung
xlAxisCrossesAutomatic | Microsoft Excel legt den Achsenschnittpunkt fest.
xlMinimum | Der Schnittpunkt liegt am Minimalwert.
xlMaximum | Der Schnittpunkt liegt am Maximalwert.
xlAxisCrossesCustom | Der Schnittpunkt wird von der CrossesAt-Eigenschaft angegeben.

Anmerkungen

Diese Eigenschaft steht für Netzdiagramme nicht zur Verfügung. Bei 3D-Diagrammen kennzeichnet diese Eigenschaft, wo die durch die Rubrikenachse definierte Ebene die Größenachse schneidet.

Diese Eigenschaft kann sowohl bei Rubriken- als auch bei Größenachsen angewendet werden. Bei der Rubrikenachse legt xlMinimum den Schnittpunkt mit der Größenachse in der ersten Rubrik fest, und xlMaximum legt den Schnittpunkt mit der Größenachse in der letzten Rubrik fest.

Die Werte xlMinimum und xlMaximum können je nach Achse verschiedene Bedeutungen haben.


CrossesAt-Eigenschaft

Gibt auf der Größenachse den Schnittpunkt mit der Rubrikenachse zurück oder legt ihn fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird der Wert der Crosses-Eigenschaft in xlAxisCrossesCustom geändert.

Diese Eigenschaft kann für Netzdiagramme nicht verwendet werden. Bei 3D-Diagrammen kennzeichnet diese Eigenschaft, wo die durch die Rubrikenachse definierte Ebene die Größenachse schneidet.


Beispiel zur CrossesAt-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Rubrikenachse in Chart1 die Größenachse im Wert 3 schneidet.

With Charts("Chart1").Axes(xlValue)
    .Crosses = xlCustom
    .CrossesAt = 3
End With


CubeField-Eigenschaft

Gibt das CubeField-Objekt zurück, von dem das angegebene PivotTable-Feld stammt. Schreibgeschützt.


 CubeFields-Eigenschaft

CubeFields-Eigenschaft

Gibt die CubeFields-Auflistung zurück. Jedes CubeField-Objekt enthält die Eigenschaften des Cube-Feldelements. Schreibgeschützt.


 Beispiel zur CubeFields-Eigenschaft

Beispiel zur CubeFields-Eigenschaft

In diesem Beispiel wird eine Liste der Cube-Feldnamen für die Datenfelder in dem ersten OLAP-basierten PivotTable-Bericht in Sheet1 erstellt.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objCubeFld In Worksheets("Sheet1").PivotTables(1).CubeFields
    If objCubeFld.Orientation = xlDataField Then
        objNewSheet.Cells(intRow, 1).Value = objCubeFld.Name
        intRow = intRow + 1
    End If
Next objCubeFld


 CubeFieldType-Eigenschaft

CubeFieldType-Eigenschaft

Bezeichnet, ob das OLAP-Cube-Feld ein Hierarchiefeld oder ein Measurefeld ist. Kann eine der folgenden XlCubeFieldType-Konstanten sein: xlHierarchy oder xlMeasure. XlCubeFieldType Schreibgeschützt.


 Beispiel zur CubeFieldType-Eigenschaft

Beispiel zur CubeFieldType-Eigenschaft

In diesem Beispiel wird eine Liste der Cube-Feldnamen für die Felder der Maßeinheiten in dem ersten OLAP-basierten PivotTable-Bericht in Sheet1 erstellt.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objCubeFld in Worksheets("Sheet1").PivotTables(1).CubeFields
    If objCubeFld.CubeFieldType = xlMeasure Then
        objNewSheet.Cells(intRow, 1).Value = objCubeFld.Name
        intRow = intRow + 1
    End If
Next objCubeFld


CurrentArray-Eigenschaft

Wenn die angegebene Zelle Teil einer Matrix ist, gibt die Eigenschaft ein Range-Objekt zurück, das die gesamte Matrix darstellt. Schreibgeschützt.


Beispiel zur CurrentArray-Eigenschaft

In diesem Beispiel wird vorausgesetzt, dass Zelle A1 in Sheet1 aktiv und Teil einer Matrix ist, die die Zellen A1:A10 umfasst. In diesem Beispiel wird der Bereich A1:A10 in Sheet1 markiert.

ActiveCell.CurrentArray.Select


 CurrentPage-Eigenschaft

CurrentPage-Eigenschaft

Gibt die aktuelle Seite zurück, die im Seitenfeld angezeigt wird (nur gültig für Seitenfelder). PivotItem Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen gibt diese Eigenschaft eine Zeichenfolge zurück, die den eindeutigen Seitennamen (wie durch die SourceName-Eigenschaft angegeben) enthält, oder legt diese fest. Ist die CurrentPage-Eigenschaft auf einen Name festgelegt, der nicht existiert, wird der Name des Elements, das die aktuelle Seite darstellt, auf den neuen Namen festgelegt.


CurrentPageName-Eigenschaft

Gibt die aktuell angezeigte Seite des angegebenen PivotTable-Berichts zurück oder legt diese fest. Der Name der Seite wird im Seitenfeld angezeigt. Beachten Sie, dass diese Eigenschaft nur dann funktioniert, wenn die aktuell angezeigte Seite bereits existiert. String Schreib-Lese-Zugriff.


Beispiel zur CurrentPageName-Eigenschaft

In diesem Beispiel wird der Name der aktuell angezeigten Seite des ersten PivotTable-Berichts im aktiven Tabellenblatt auf "United States" festgelegt.

ActiveSheet.PivotTables("PivotTable1") _
    .PivotFields("Country").CurrentPageName = _
        "United States"


CurrentRegion-Eigenschaft

Gibt ein Range-Objekt zurück, das den aktuellen Bereich darstellt. Der aktuelle Bereich wird von einer beliebigen Kombination leerer Zeilen und Spalten umschlossen. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft bietet sich bei vielen Operationen an, die die Markierung automatisch auf den gesamten aktuelle Bereich erweitern (z. B. die AutoFormat-Methode).

Diese Eigenschaft kann nicht bei geschützten Tabellenblättern verwendet werden.


Beispiel zur CurrentRegion-Eigenschaft

In diesem Beispiel wird die aktuelle Region in Sheet1 markiert.

Worksheets("Sheet1").Activate
ActiveCell.CurrentRegion.Select

In diesem Beispiel wird vorausgesetzt, dass das erste Tabellenblatt eine Tabelle mit einer Kopfzeile enthält. Die Tabelle wird mit Ausnahme der Kopfzeile markiert, wobei sich die aktive Zelle vor dem Ausführen des Beispiels innerhalb der Tabelle befinden muss.

Set tbl = ActiveCell.CurrentRegion
tbl.Offset(1, 0).Resize(tbl.Rows.Count - 1, _
    tbl.Columns.Count).Select


Cursor-Eigenschaft

Gibt das Aussehen des Mauszeigers in Microsoft Excel zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Es stehen folgende XlMousePointer-Konstanten zur Verfügung.

Konstante | Beschreibung
xlDefault | Der Standardzeiger
xlWait | Der Sanduhrzeiger Sanduhrzeiger
xlNorthwestArrow | Der Nordwestpfeil-Zeiger Nordwestpfeil-Zeiger
xlIBeam | Der I-Mauszeiger I-Mauszeiger

Anmerkungen

Die Cursor-Eigenschaft wird nicht automatisch zurückgesetzt, wenn die Ausführung des Makros beendet ist. Sie sollten den Mauszeiger auf xlDefault zurücksetzen, bevor das Makro anhält.


CursorMovement-Eigenschaft

Gibt einen Wert, der anzeigt, ob ein visueller Cursor oder ein logischer Cursor verwendet wird, zurück oder legt diesen fest. Kann eine der folgenden Konstanten sein: xlVisualCursor oder xlLogicalCursor. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur CursorMovement-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft den visuellen Cursor verwendet.

Application.CursorMovement = xlVisualCursor


CustomDocumentProperties-Eigenschaft

Gibt eine DocumentProperties-Auflistung zurück, die alle benutzerdefinierten Dokumenteigenschaften für die angegebene Arbeitsmappe darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft gibt die vollständige Auflistung benutzerdefinierter Dokumenteigenschaften zurück. Verwenden Sie die Item-Methode, um ein einzelnes Element der Auflistung (ein DocumentProperty-Objekt) zurückzugeben, indem Sie entweder den Namen der Eigenschaft oder den Auflistungsindex (als Zahl) angeben.

Da die Item-Methode die Standardmethode für die DocumentProperties-Auflistung ist, sind die folgenden Anweisungen gleichwertig:

CustomDocumentProperties.Item("Complete")
CustomDocumentProperties("Complete")

Verwenden Sie die BuiltinDocumentProperties-Eigenschaft, um die Auflistung integrierter Dokumenteigenschaften zurückzugeben.


Beispiel zur CustomDocumentProperties-Eigenschaft

In diesem Beispiel werden die Namen und Werte der benutzerdefinierten Dokumenteigenschaften als Liste im ersten Tabellenblatt angezeigt.

rw = 1
Worksheets(1).Activate
For Each p In ActiveWorkbook.CustomDocumentProperties
    Cells(rw, 1).Value = p.Name
    Cells(rw, 2).Value = p.Value
    rw = rw + 1
Next


CustomListCount-Eigenschaft

Gibt die Anzahl der benutzerdefinierten Listen (einschließlich der integrierten Listen) zurück. Long Schreibgeschützt.


Beispiel zur CustomListCount-Eigenschaft

In diesem Beispiel wird die Anzahl der aktuell benutzerdefinierten Listen angezeigt.

MsgBox "There are currently " & Application.CustomListCount & _
    " defined custom lists."


CustomViews-Eigenschaft

Gibt eine CustomViews-Auflistung zurück, die alle benutzerdefinierten Ansichten der Arbeitsmappe darstellt.

Weitere Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur CustomViews-Eigenschaft

In diesem Beispiel wird die neue benutzerdefinierte Ansicht "Summary" in der aktiven Arbeitsmappe erstellt.

ActiveWorkbook.CustomViews.Add "Summary", True, True


CutCopyMode-Eigenschaft

Diese Eigenschaft gibt den Status des Ausschneide- oder Kopiermodus zurück bzw. stellt diesen ein. Zulässig sind True, False oder eine Konstante des Typs XLCutCopyMode (siehe Tabelle unten). Long Schreib-Lese-Zugriff.

Rückgabewert | Beschreibung
False | Weder im Ausschneide- noch im Kopiermodus
xlCopy | Im Kopiermodus
xlCut | Im Ausschneidemodus

Eingestellter Wert | Beschreibung
False | Deaktiviert den Ausschneide- bzw. Kopiermodus und entfernt den Laufrahmen.
True | Deaktiviert den Ausschneide- bzw. Kopiermodus und entfernt den Laufrahmen.


Beispiel zur CutCopyMode-Eigenschaft

In diesem Beispiel wird der Status des Ausschneide- bzw. Kopiermodus in einem Meldungsfeld angezeigt.

Select Case Application.CutCopyMode
    Case Is = False
        MsgBox "Not in Cut or Copy mode"
    Case Is = xlCopy
        MsgBox "In Copy mode"
    Case Is = xlCut
        MsgBox "In Cut mode"
End Select


DashStyle-Eigenschaft

Gibt für die angegebene Linie die Formatvorlage der Strichelung zurück oder legt sie fest. Kann eine der folgenden MsoLineDashStyle-Konstanten sein: msoLineDash, msoLineDashDot, msoLineDashDotDot, msoLineDashStyleMixed, msoLineLongDash, msoLineLongDashDot, msoLineRoundDot, msoLineSolid oder msoLineSquareDot. Long Schreib-Lese-Zugriff.


Beispiel zur DashStyle-Eigenschaft

In diesem Beispiel wird in myDocument eine blau gestrichelte Linie eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


DataBodyRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den Datenbereich im PivotTable-Bericht enthält. Schreibgeschützt.


Beispiel zur DataBodyRange-Eigenschaft

In diesem Beispiel wird der aktive Datenbereich im PivotTable-Bericht ausgewählt.

Worksheets("Sheet1").Activate
Range("A3").Select
ActiveCell.PivotTable.DataBodyRange.Select


DataEntryMode-Eigenschaft

Gibt den Dateneingabemodus zurück bzw. stellt diesen ein (siehe Tabelle unten). Im Dateneingabemodus können Sie Daten eingeben, jedoch nur in nicht geschützte Zellen des aktuell markierten Zellbereichs. Long Schreib-Lese-Zugriff.

Wert | Bedeutung
xlOn | Dateneingabemodus ist aktiviert.
xlOff | Dateneingabemodus ist nicht aktiviert.
xlStrict | Dateneingabemodus ist aktiviert und lässt sich auch nicht durch Drücken von ESC deaktivieren.


Beispiel zur DataEntryMode-Eigenschaft

Das folgende Beispiel deaktiviert den Dateneingabemodus, falls er aktiviert ist.

If (Application.DataEntryMode = xlOn) Or _
    (Application.DataEntryMode = xlStrict) Then
        Application.DataEntryMode = xlOff
End If


DataFields-Eigenschaft

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Feld (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller Felder (ein PivotFields-Objekt, Syntax 2) darstellt, die derzeit als Datenfelder angezeigt werden. Schreibgeschützt.

Syntax 1

Ausdruck.DataFields(Index)

Syntax 2

Ausdruck.DataFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Feldes (kann eine Matrix zur Angabe mehrerer Felder sein).


Beispiel zur DataFields-Eigenschaft

In diesem Beispiel werden die Namen der Datenfelder in der Pivot-Tabelle in ein Listenfeld auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.DataFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


DataLabel-Eigenschaft

Gibt ein DataLabel-Objekt zurück, das die mit dem Datenpunkt oder der Trendlinie verbundene Datenbeschriftung darstellt. Schreibgeschützt.


DataLabelRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der die Beschriftungen der Datenfelder im PivotTable-Bericht enthält. Schreibgeschützt.


Beispiel zur DataLabelRange-Eigenschaft

In diesem Beispiel wird die Datenkopfzeile des PivotTable-Berichts ausgewählt.

Worksheets("Sheet1").Activate
Range("A3").Select
ActiveCell.PivotTable.DataLabelRange.Select


DataRange-Eigenschaft

Gibt ein Range-Objekt entsprechend der folgenden Tabelle zurück. Schreibgeschützt.

Objekt | Datenbereich
Datenfeld | Im Feld enthaltene Daten
Zeilen-, Spalten- oder Seitenfeld | Im Feld enthaltene Elemente
Element | Durch das Element gekennzeichnet Daten


Beispiel zur DataRange-Eigenschaft

In diesem Beispiel werden die PivotTable-Elemente im Feld "REGION" ausgewählt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Worksheets("Sheet1").Activate
pvtTable.PivotFields("REGION").DataRange.Select


DataTable-Eigenschaft

Gibt ein DataTable-Objekt zurück, das die Diagrammdatentabelle darstellt. Schreibgeschützt.


Beispiel zur DataTable-Eigenschaft

In diesem Beispiel wird eine Datentabelle mit einem äußeren Rahmen dem eingebetteten Diagramm hinzugefügt.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    .DataTable.HasBorderOutline = True
End With


DataType-Eigenschaft

PivotField-Objekt: Gibt eine Konstante zur Beschreibung des Datentyps im PivotTable-Feld zurück. Kann eine der folgenden XlPivotFieldDataType-Konstanten sein: xlText, xlNumber oder xlDate. Long Schreibgeschützt.

Parameter-Objekt: Gibt den Datentyp des angegebenen Abfrageparameters zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.

Kann eine der folgenden XlParameterDataType-Konstanten sein:

xlParamTypeBigInt

xlParamTypeBinary

xlParamTypeBit

xlParamTypeChar

xlParamTypeDate

xlParamTypeDecimal

xlParamTypeDouble

xlParamTypeFloat

xlParamTypeInteger

xlParamTypeLongVarBinary

xlParamTypeWChar

 xlParamTypeLongVarChar

xlParamTypeNumeric

xlParamTypeReal

xlParamTypeSmallInt

xlParamTypeTime

xlParamTypeTimeStamp

xlParamTypeTinyInt

xlParamTypeUnknown

xlParamTypeVarBinary

xlParamTypeVarChar


Beispiel zur DataType-Eigenschaft

In diesem Beispiel wird der Datentyp des Felds "ORDER_DATE" angezeigt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Select Case pvtTable.PivotFields("ORDER_DATE").DataType
    Case Is = xlText
        MsgBox "The field contains text data"
    Case Is = xlNumber
        MsgBox "The field contains numeric data"
    Case Is = xlDate
        MsgBox "The field contains date data"
End Select


Date1904-Eigenschaft

True, falls in dieser Arbeitsmappe das 1904-Datumssystem verwendet wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur Date1904-Eigenschaft

In diesem Beispiel verwendet Microsoft Excel das 1904-Datumssystem für die aktive Arbeitsmappe.

ActiveWorkbook.Date1904 = True


DDEAppReturnCode-Eigenschaft

Gibt den zu einer bestimmten Anwendung gehörigen DDE-Rückgabecode zurück, der in der letzten von Microsoft Excel empfangenen DDE-Bestätigungsnachricht enthalten war. Long Schreibgeschützt.


Beispiel zur DDEAppReturnCode-Eigenschaft

In diesem Beispiel wird der Variablen appErrorCode der DDE-Rückgabecode zugewiesen.

appErrorCode = Application.DDEAppReturnCode


DefaultFilePath-Eigenschaft

Gibt den Standardpfad zurück, den Microsoft Excel beim Öffnen von Dateien verwendet, oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur DefaultFilePath-Eigenschaft

In diesem Beispiel wird der aktuelle Standardpfad angezeigt.

MsgBox "The current default file path is " & _
    Application.DefaultFilePath


DefaultSaveFormat-Eigenschaft

Gibt das Standardformat beim Speichern von Dateien zurück oder legt es fest. Eine Liste der gültigen Konstanten finden Sie unter der FileFormat-Eigenschaft. Long Schreib-Lese-Zugriff.


Beispiel zur DefaultSaveFormat-Eigenschaft

In diesem Beispiel wird das Standardformat beim Speichern von Dateien festgelegt.

Application.DefaultSaveFormat = xlExcel4Workbook


DefaultSheetDirection-Eigenschaft

Gibt die Standardrichtung, in der Microsoft Excel neue Fenster und Tabellenblätter anzeigt, zurück oder legt diese fest. Kann eine der folgenden Konstanten sein: xlRTL (von rechts nach links) oder xlLTR (von links nach rechts). Long Schreib-Lese-Zugriff.

Anmerkungen

Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur DefaultSheetDirection-Eigenschaft

In diesem Beispiel wird die Standardrichtung von rechts nach links festlegt.

Application.DefaultSheetDirection = xlRTL


DefaultWebOptions-Eigenschaft

Gibt das DefaultWebOptions-Objekt zurück, das globale Attribute auf Anwendungsebene enthält, die von Microsoft Excel bei jedem Speichern eines Dokuments als Webseite oder beim Öffnen einer Webseite verwendet werden. Schreibgeschützt.


Beispiel zur DefaultWebOptions-Eigenschaft

In diesem Beispiel wird überprüft, ob die Standardeinstellung für die Codierung von Dokumenten "Western" lautet; anschließend wird die Zeichenfolge strDocEncoding entsprechend festgelegt.

If Application.DefaultWebOptions.Encoding = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Other"
End If


Delivery-Eigenschaft

Gibt die Verteilungsart zurück, die beim Weiterleiten verwendet wird. Zulässig sind die XlRoutingSlipDelivery-Konstanten xlOneAfterAnother und xlAllAtOnce. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann nicht mehr angegeben werden, wenn die Übermittlung bereits begonnen hat.


Beispiel zur Delivery-Eigenschaft

In diesem Beispiel wird MAPPE1.XLS nacheinander an drei Empfänger weitergeleitet.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
End With
Workbooks("BOOK1.XLS").Route


Dependents-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich mit allen von einer Zelle abhängigen Zellen (Nachfolgern) darstellt. Dabei kann es sich um eine Mehrfachauswahl (eine Vereinigung mehrerer Range-Objekte) handeln, falls mehrere Zellen abhängig sind. Schreibgeschützt.


Beispiel zur Dependents-Eigenschaft

In diesem Beispiel werden die Nachfolger von Zelle A1 in Sheet1 markiert.

Worksheets("Sheet1").Activate
Range("A1").Dependents.Select


Depth-Eigenschaft

Gibt für das ThreeDFormat-Objekt die Richtungstiefe einer Form zurück oder legt sie fest. Kann ein Wert von -600 bis 9600 sein (bei positiven Werten ist die Vorderseite der Projektion die ursprüngliche Form; bei negativen Werten ist die Rückseite der Projektion die ursprüngliche Form). Single Schreib-Lese-Zugriff.

Gibt für das TickLabels-Objekt die Ebenenanzahl der Kategorien-Teilstrichbeschriftungen zurück. Schreibgeschützt Long.


DepthPercent-Eigenschaft

Gibt die Tiefe eines 3D-Diagramms als Prozentsatz der Diagrammbreite (zwischen 20 und 2000 Prozent) zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur DepthPercent-Eigenschaft

In diesem Beispiel wird die Tiefe von Chart1 auf 50 Prozent der Diagrammbreite festgelegt. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden (die DepthPercent-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird).

Charts("Chart1").DepthPercent = 50


Destination-Eigenschaft

Die Zelle in der oberen linken Ecke des Zielbereichs der Abfragetabelle (der Bereich, in dem die sich ergebende Abfragetabelle positioniert wird). Der Zielbereich muss sich auf dem Tabellenblatt befinden, das das QueryTable-Objekt enthält. Range Schreibgeschützt.


Beispiel zur Destination-Eigenschaft

In diesem Beispiel wird im aktiven Fenster ein Bildlauf durchgeführt, bis sich die obere linke Ecke der ersten Abfragetabelle in der oberen linken Fensterecke befindet.

Set d = Worksheets(1).QueryTables(1).Destination
With ActiveWindow
    .ScrollColumn = d.Column
    .ScrollRow = d.Row
End With


Dialogs-Eigenschaft

Gibt eine Dialogs-Auflistung aller internen Dialogfelder zurück. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Dialogs-Eigenschaft

In diesem Beispiel wird das Dialogfeld Öffnen (Menü Datei) angezeigt.

Application.Dialogs(xlDialogOpen).Show


DirectDependents-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der die direkten Nachfolger einer Zelle enthält. Dabei kann es sich um eine Mehrfachauswahl (eine Vereinigung mehrerer Range-Objekte) handeln, falls mehrere Zellen abhängig sind. Schreibgeschützt.


Beispiel zur DirectDependents-Eigenschaft

In diesem Beispiel werden die direkt von Zelle A1 in Sheet1 abhängigen Nachfolgerzellen markiert.

Worksheets("Sheet1").Activate
Range("A1").DirectDependents.Select


DirectPrecedents-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der die direkten Vorgänger einer Zelle enthält. Dabei kann es sich um eine Mehrfachauswahl (eine Vereinigung mehrerer Range-Objekte) handeln, falls mehrere Vorgängerzellen vorhanden sind. Schreibgeschützt.


Beispiel zur DirectPrecedents-Eigenschaft

In diesem Beispiel werden die direkten Vorgänger von Zelle A1 in Sheet1 markiert.

Worksheets("Sheet1").Activate
Range("A1").DirectPrecedents.Select


DisplayAlerts-Eigenschaft

True, wenn Microsoft Excel bestimmte Warnungen und Meldungen anzeigt, während ein Makro ausgeführt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Der Standardwert ist True. Legen Sie diese Eigenschaft auf False fest, wenn Sie während der Ausführung eines Makros nicht durch Eingabeaufforderungen und Warnmeldungen unterbrochen werden wollen und stattdessen Microsoft Excel die Standardantwort auswählen soll.

Wenn Sie diese Eigenschaft auf False eingestellt haben, setzt Microsoft Excel sie nach Beendigung des Makros nicht automatisch auf True zurück. Ihr Makro sollte die Eigenschaft stets auf True zurücksetzen, wenn es beendet wird.


Beispiel zur DisplayAlerts-Eigenschaft

In diesem Beispiel wird die Arbeitsmappe BOOK1.XLS geschlossen. Der Anwender wird nicht aufgefordert, Änderungen zu speichern, und diese werden auch nicht gespeichert.

Application.DisplayAlerts = False
Workbooks("BOOK1.XLS").Close
Application.DisplayAlerts = True

Dieses Beispiel unterdrückt die Meldung, die beim Öffnen eines DDE-Kanals zu einer noch nicht gestarteten Anwendung angezeigt wird.

Application.DisplayAlerts = False
channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\FORMLETR.DOC")
Application.DisplayAlerts = True
Application.DDEExecute channelNumber, "[FILEPRINT]"
Application.DDETerminate channelNumber
Application.DisplayAlerts = True


DisplayBlanksAs-Eigenschaft

Gibt zurück, wie leere Zellen in einem Diagrammblatt dargestellt werden bzw. schreibt dies vor. Zulässig ist eine der folgenden XlDisplayBlanksAs-Konstanten: xlNotPlotted, xlInterpolated oder xlZero. Long Schreib-Lese-Zugriff.


Beispiel zur DisplayBlanksAs-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel leere Zellen in Chart1 nicht darstellt.

Charts("Chart1").DisplayBlanksAs = xlNotPlotted


DisplayCommentIndicator-Eigenschaft

Gibt zurück oder legt fest, wie Zellen Kommentare und Indikatoren anzeigen. Dies kann eine der folgenden XlCommentDisplayMode-Konstanten sein: xlNoIndicator, xlCommentIndicatorOnly oder xlCommentAndIndicator. Long Schreib-Lese-Zugriff.


Beispiel zur DisplayCommentIndicator-Eigenschaft

In diesem Beispiel werden Zelltipps ausgeblendet, Kommentarindikatoren jedoch angezeigt.

Application.DisplayCommentIndicator = xlCommentIndicatorOnly


DisplayDrawingObjects-Eigenschaft

Gibt die Art der Anzeige für Zeichnungsobjekte zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Zulässig ist eine der folgenden XlDisplayDrawingObjects-Konstanten:

Konstante | Beschreibung
xlDisplayShapes | Alle Zeichnungsobjekte anzeigen.
XlPlaceholders | Nur Platzhalter anzeigen.
XlHide | Alle Zeichnungsobjekte ausblenden.


Beispiel zur DisplayDrawingObjects-Eigenschaft

In diesem Beispiel werden alle Zeichnungsobjekte in der aktiven Arbeitsmappe ausgeblendet.

ActiveWorkbook.DisplayDrawingObjects = xlHide


DisplayEquation-Eigenschaft

True, wenn die Gleichung der Trendlinie im Diagramm angezeigt wird (in derselben Datenbeschriftung wie das Bestimmtheitsmaß). Wird diese Eigenschaft auf True gesetzt, so werden automatisch auch die Datenbeschriftungen angezeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayEquation-Eigenschaft

In diesem Beispiel werden das Bestimmtheitsmaß und die Gleichung für die erste Trendlinie in Chart1 angezeigt. Wenden Sie das Beispiel auf ein 2D-Säulendiagramm mit einer Trendlinie für die erste Datenreihe an.

With Charts("Chart1").SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = True
    .DisplayEquation = True
End With


DisplayErrorString-Eigenschaft

True, wenn der PivotTable-Bericht eine benutzerdefinierte Fehlerzeichenfolge in Zellen anzeigt, die Fehler enthalten. Der Standardwert ist False. Boolean Lese- und Schreibzugriff.

Anmerkungen

Verwenden Sie die ErrorString-Eigenschaft, um die benutzerdefinierte Fehlerzeichenfolge festzulegen.

Diese Eigenschaft ist besonders nützlich, um die Division durch Null zu unterdrücken, wenn berechnete Felder pivotiert werden.


Beispiel zur DisplayErrorString-Eigenschaft

In diesem Beispiel zeigt der PivotTable-Bericht einen Bindestrich in Zellen an, die Fehler enthalten.

With Worksheets(1).PivotTables("Pivot1")
    .ErrorString = "-"
    .DisplayErrorString = True
End With


DisplayExcel4Menus-Eigenschaft

True, wenn Microsoft Excel die Menüleisten der Version 4.0 anzeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayExcel4Menus-Eigenschaft

In diesem Beispiel wird zu den Menüs von Microsoft Excel, Version 4.0, gewechselt.

Application.DisplayExcel4Menus = True


DisplayFormulaBar-Eigenschaft

True, wenn die Bearbeitungsleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayFormulaBar-Eigenschaft

Im folgenden Beispiel wird die Bearbeitungsleiste ausgeblendet.

Application.DisplayFormulaBar = False


DisplayFormulas-Eigenschaft

True, wenn im Fenster Formeln angezeigt werden. False, wenn im Fenster Werte angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.


Beispiel zur DisplayFormulas-Eigenschaft

In diesem Beispiel wird das Anzeigen von Formeln für das aktive Fenster in BOOK1.XLS aktiviert.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.DisplayFormulas = True


DisplayFullScreen-Eigenschaft

True, wenn Microsoft Excel den ganzen Bildschirm zur Anzeige nutzt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Im Vollbildmodus wird das Anwendungsfenster maximiert. Es wird der gesamte Bildschirm belegt und die Titelleiste der Anwendung verdeckt. Symbolleisten, die Statusleiste und die Bearbeitungsleiste behalten ihre unterschiedlichen Einstellungen für den Vollbildmodus und dem Normalmodus bei.


Beispiel zur DisplayFullScreen-Eigenschaft

In diesem Beispiel wird die Vollbilddarstellung für Microsoft Excel gewählt.

Application.DisplayFullScreen = True


DisplayGridlines-Eigenschaft

True, wenn Gitternetzlinien angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.

Diese Eigenschaft bezieht sich nur auf die Bildschirmanzeige von Gitternetzlinien. Verwenden Sie die PrintGridlines-Eigenschaft, um festzulegen, ob die Gitternetzlinien gedruckt werden sollen.


Beispiel zur DisplayGridlines-Eigenschaft

In diesem Beispiel werden Gitternetzlinien im aktiven Fenster von BOOK1.XLS angezeigt, wenn sie vorher ausgeblendet waren, bzw. ausgeblendet, wenn sie vorher sichtbar waren.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.DisplayGridlines = Not(ActiveWindow.DisplayGridlines)


DisplayHeadings-Eigenschaft

True, wenn sowohl Zeilen- als auch Spaltenüberschriften angezeigt werden. False, wenn sie nicht angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.

Diese Eigenschaft bezieht sich nur auf die Bildschirmanzeige von Überschriften. Verwenden Sie die PrintHeadings-Eigenschaft, um festzulegen, ob die Überschriften gedruckt werden sollen oder nicht.


Beispiel zur DisplayHeadings-Eigenschaft

In diesem Beispiel werden Zeilen- und Spaltenköpfe im aktiven Fenster von BOOK1.XLS nicht mehr angezeigt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.DisplayHeadings = False


DisplayHorizontalScrollBar-Eigenschaft

True, wenn die horizontale Bildlaufleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayHorizontalScrollBar-Eigenschaft

In diesem Beispiel wird die horizontale Bildlaufleiste für das aktive Fenster eingeblendet.

ActiveWindow.DisplayHorizontalScrollBar = True


DisplayNoteIndicator-Eigenschaft

True, wenn in Zellen mit Notizen die QuickNotiz und die Notizanzeiger (kleine Punkte in der rechten oberen Ecke) angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayNoteIndicator-Eigenschaft

In diesem Beispiel werden die Notizanzeiger ausgeblendet.

Application.DisplayNoteIndicator = False


DisplayNullString-Eigenschaft

True, wenn der PivotTable-Bericht eine benutzerdefinierte Zeichenfolge in Zellen anzeigt, die einen Nullwert enthalten. Der Standardwert ist True. Boolean Lese- und Schreibzugriff.

Anmerkungen

Verwenden Sie die NullString-Eigenschaft, um die benutzerdefinierte Zeichenfolge für Nullwerte festzulegen.


Beispiel zur DisplayNullString-Eigenschaft

In diesem Beispiel wird in dem PivotTable-Bericht in Zellen, die einen Nullwert enthalten, "NA" angezeigt.

With Worksheets(1).PivotTables("Pivot1")
    .NullString = "NA"
    .DisplayNullString = True
End With

In diesem Beispiel wird in dem PivotTable-Bericht in Zellen, die einen Nullwert enthalten, 0 (Null) angezeigt.

Worksheets(1).PivotTables("Pivot1").DisplayNullString = False


DisplayOutline-Eigenschaft

True, wenn Gliederungssymbole angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.


Beispiel zur DisplayOutline-Eigenschaft

In diesem Beispiel werden Gliederungssymbole für das aktive Fenster von BOOK1.XLS angezeigt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.DisplayOutline = True


DisplayPageBreaks-Eigenschaft

True, wenn Seitenumbrüche (automatische und manuelle) auf dem angegebenen Tabellenblatt angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann nur festgelegt werden, wenn ein Drucker installiert ist.


Beispiel zur DisplayPageBreaks-Eigenschaft

In diesem Beispiel wird Sheet1 so eingestellt, dass Seitenumbrüche angezeigt werden.

Worksheets("Sheet1").DisplayPageBreaks = True


DisplayRecentFiles-Eigenschaft

True, wenn die Liste der zuletzt geöffneten Dateien im Menü Datei angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayRecentFiles-Eigenschaft

In diesem Beispiel wird die Liste der zuletzt verwendeten Dateien ausgeblendet.

Application.DisplayRecentFiles = False


DisplayRightToLeft-Eigenschaft

True, wenn das angegebene Fenster oder Tabellenblatt von rechts nach links anstatt von links nach rechts angezeigt wird. False, wenn das Objekt von links nach rechts angezeigt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann nur festgelegt werden, wenn die Unterstützung für Sprachen mit Schreibweise von rechts nach links installiert und aktiviert wurde.


Beispiel zur DisplayRightToLeft-Eigenschaft

In diesem Beispiel wird festgelegt, dass das erste Fenster in der aktiven Arbeitsmappe von rechts nach links angezeigt wird.

ActiveWorkbook.Windows(1).DisplayRightToLeft = True


DisplayRSquared-Eigenschaft

True, wenn das Bestimmtheitsmaß der Trendlinie im Diagramm angezeigt wird (in derselben Datenbeschriftung wie die Gleichung). Wird diese Eigenschaft auf True gesetzt, so werden automatisch auch die Datenbeschriftungen angezeigt. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayRSquared-Eigenschaft

In diesem Beispiel werden das Bestimmtheitsmaß und die Gleichung für die erste Trendlinie in Chart1 angezeigt. Wenden Sie dieses Beispiel auf ein 2D-Säulendiagramm mit einer Trendlinie für die erste Datenreihe an.

With Charts("Chart1").SeriesCollection(1).Trendlines(1)
    .DisplayRSquared = True
    .DisplayEquation = True
End With


DisplayScrollBars-Eigenschaft

True, wenn Bildlaufleisten für alle Arbeitsmappen sichtbar sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayScrollBars-Eigenschaft

In diesem Beispiel werden die Bildlaufleisten in allen Arbeitsmappen ausgeblendet.

Application.DisplayScrollBars = False


DisplayStatusBar-Eigenschaft

True, wenn die Statusleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayStatusBar-Eigenschaft

In diesem Beispiel wird die aktuelle Einstellung der DisplayStatusBar-Eigenschaft gespeichert. Danach wird die Eigenschaft auf True gesetzt, so dass die Statusleiste sichtbar wird.

saveStatusBar = Application.DisplayStatusBar
Application.DisplayStatusBar = True


DisplayUnit-Eigenschaft

Gibt die Einheitenbeschriftung für die angegebene Achse zurück oder legt diese fest. Kann eine der folgenden XlDisplayUnit-Konstanten sein: xlNone, xlHundreds, xlThousands, xlTenThousands, xlHundredThousands, xlMillions, xlTenMillions, xlHundredMillions, xlThousandMillions, xlMillionMillions oder xlCustom. Ist der Wert xlCustom, gibt die DisplayUnitCustom-Eigenschaft den Wert der angezeigten Einheiten zurück oder legt diese fest. XlDisplayUnit Schreib-Lese-Zugriff.

Anmerkungen

Die Verwendung von Einheitenbeschriftungen erhöht die Lesbarkeit von Teilstrichbeschriftungen bei der Darstellung von großen Werten. Wenn Sie beispielsweise die Größenachse in Einheiten von Hunderten, Tausenden oder Millionen beschriften, können Sie auf der Größenachse an den Teilstrichen kleinere numerische Werte verwenden.


DisplayUnitCustom-Eigenschaft

Wenn der Wert der DisplayUnit-Eigenschaft xlCustom lautet, gibt die DisplayUnitCustom-Eigenschaft den Wert der angezeigten Einheiten zurück oder legt diese fest. Der Wert muss im Bereich von 0 bis 10E307 liegen. Double Schreib-Lese-Zugriff.

Anmerkungen

Die Verwendung von Einheitenbeschriftungen erhöht die Lesbarkeit von Teilstrichbeschriftungen bei der Darstellung von großen Werten. Wenn Sie beispielsweise die Größenachse in Einheiten von Hunderten, Tausenden oder Millionen beschriften, können Sie auf der Größenachse an den Teilstrichen kleinere numerische Werte verwenden.


Beispiel zur DisplayUnitCustom-Eigenschaft

In diesem Beispiel werden die in Chart1 auf der Größenachse angezeigten Einheiten auf die Schrittweite 500 festgelegt.

With Charts("Chart1").Axes(xlValue)
    .DisplayUnit = xlCustom
    .DisplayUnitCustom = 500
    .HasTitle = True
    .AxisTitle.Caption = "Rebate Amounts"
End With


DisplayUnitLabel-Eigenschaft

Gibt das DisplayUnitLabel-Objekt für die angegebene Achse zurück. Gibt Null zurück, falls die HasDisplayUnitLabel-Eigenschaft auf False eingestellt ist. Schreibgeschützt.


Beispiel zur DisplayUnitLabel-Eigenschaft

In diesem Beispiel wird die Beschriftung für die Größenachse in Chart1 auf "Millions" eingestellt und dann die automatische Schriftskalierung deaktiviert.

With Charts("Chart1").Axes(xlValue).DisplayUnitLabel
    .Caption = "Millions"
    .AutoScaleFont = False
End With


DisplayVerticalScrollBar-Eigenschaft

True, wenn die vertikale Bildlaufleiste angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayVerticalScrollBar-Eigenschaft

In diesem Beispiel wird die vertikale Bildlaufleiste für das aktive Fenster eingeblendet.

ActiveWindow.DisplayVerticalScrollBar = True


DisplayWorkbookTabs-Eigenschaft

True, wenn die Arbeitsmappenregister angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur DisplayWorkbookTabs-Eigenschaft

In diesem Beispiel werden die Arbeitsmappenregister eingeblendet.

ActiveWindow.DisplayWorkbookTabs = True


DisplayZeros-Eigenschaft

True, wenn Nullwerte angezeigt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.


Beispiel zur DisplayZeros-Eigenschaft

In diesem Beispiel wird festgelegt, dass im aktiven Fenster von BOOK1.XLS Nullwerte angezeigt werden.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.DisplayZeros = True


DivID-Eigenschaft

Gibt den eindeutigen Bezeichner zurück, der zum Kennzeichnen eines HTML <DIV>-Tag auf einer Webseite verwendet wird. Das Tag wird einem Element in einem Dokument zugeordnet, das in einer Webseite gespeichert wurde. Bei einem Element kann es sich um eine vollständige Arbeitsmappe, ein Tabellenblatt, einen ausgewählten Druckbereich, einen AutoFilter-Bereich, einen Zellbereich, ein Diagramm, einen PivotTable-Bericht oder eine Abfragetabelle handeln. String Schreibgeschützt.


Beispiel zur DivID-Eigenschaft

In diesem Beispiel wird ein Zellbereich in einer Webseite gespeichert und dann der Bezeichner des <DIV>-Tags des betreffenden Elements bestimmt sowie die Zeile in der gespeicherten Webseite (q198.htm) gesucht. In diesem Beispiel wird weiterhin eine Kopie der Webseite erstellt (newq1.htm) und in der Kopie der Datei eine Kommentarzeile vor dem <DIV>-Tag eingefügt.

Set objPO = ActiveWorkbook.PublishObjects.Add( _
    SourceType:=xlSourceRange, _
    Filename:="\\Server1\Reports\q198.htm", _
    Sheet:="Sheet1", _
    Source:="C2:D6", _
    HtmlType:=xlHtmlCalc)
objPO.Publish
strTargetDivID = objPO.DivID
Open "\\Server1\Reports\q198.htm" For Input As #1
Open "\\Server1\Reports\newq1.htm" For Output As #2
While Not EOF(1)
    Line Input #1, strFileLine
    If InStr(strFileLine, strTargetDivID) > 0 And _
        InStr(strFileLine, "<div") > 0 Then
            Print #2, "<!--Saved item-->"
    End If
    Print #2, strFileLine
Wend
Close #2
Close #1


DoughnutHoleSize-Eigenschaft

Gibt die Innenringgröße einer Ringdiagrammgruppe zurück oder legt sie fest. Die Innenringgröße wird als Prozentwert der Diagrammgröße angegeben und kann im Bereich von 10 bis 90 Prozent liegen. Long Schreib-Lese-Zugriff.


Beispiel zur DoughnutHoleSize-Eigenschaft

In diesem Beispiel wird die Innenringgröße für die erste Ringdiagrammgruppe in Chart1 festgelegt. Wenden Sie das Beispiel auf ein 2D-Ringdiagramm an.

Charts("Chart1").DoughnutGroups(1).DoughnutHoleSize = 10


DownBars-Eigenschaft

Gibt ein DownBars-Objekt zurück, das die negativen Abweichungsbalken eines Liniendiagramms darstellt. Nur gültig für Liniendiagramme. Schreibgeschützt.


Beispiel zur DownBars-Eigenschaft

In diesem Beispiel werden positive und negative Balken für die erste Diagrammgruppe in Chart1 eingeblendet. Anschließend werden den Balken entsprechende Farben zugewiesen. Es ist sinnvoll, dieses Beispiel auf ein 2D-Liniendiagramm anzuwenden, das zwei Datenreihen enthält, die sich in wenigstens einem Datenpunkt schneiden.

With Charts("Chart1").ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


DownloadComponents-Eigenschaft

True, wenn die erforderlichen Microsoft Office Web Components beim Anzeigen des gespeicherten Dokuments in einem Webbrowser gedownloadet werden, jedoch nur dann, wenn die Komponenten noch nicht installiert wurden. False, wenn die Komponenten nicht gedownloadet werden. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie können die LocationOfComponents-Eigenschaft auf einen zentralen URL (im Intranet oder World Wide Web) oder Pfad (lokal oder Netzwerk) zu einem Speicherort einstellen, von dem aus berechtigte Benutzer beim Anzeigen des gespeicherten Dokuments Komponenten downloaden können. Der Pfad muss zulässig sein und auf ein Verzeichnis zeigen, das die notwendigen Komponenten enthält; der Benutzer muss über eine gültige Microsoft Office 2000-Lizenz verfügen.

Office Web Components fügen Interaktivität zu Dokumenten hinzu, die Sie als Webseiten speichern. Wenn Sie eine Webseite in einem Browser auf einem Computer anzeigen, auf dem die Komponenten nicht installiert sind, verhalten sich die interaktiven Teile der Seite statisch.


Beispiel zur DownloadComponents-Eigenschaft

In diesem Beispiel wird zugelassen, dass die Office Web Components mit der angegebenen Webseite gedownloadet werden, sofern sie noch nicht installiert wurden.

Application.DefaultWebOptions.DownloadComponents = True
Application.DefaultWebOptions.LocationOfComponents = _
    Application.Path & Application.PathSeparator & "foo"


Draft-Eigenschaft

True, wenn das Blatt ohne Grafiken gedruckt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie diese Eigenschaft auf True setzen, wird der Druckvorgang zwar beschleunigt, es werden jedoch keine Grafiken ausgegeben.


Beispiel zur Draft-Eigenschaft

In diesem Beispiel wird das Drucken von Grafiken für Sheet1 ausgeschaltet.

Worksheets("Sheet1").PageSetup.Draft = True


 DragToColumn-Eigenschaft

DragToColumn-Eigenschaft

True, wenn das angegebene Feld auf die Spaltenposition gezogen werden kann. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert für Measurefelder False.


Beispiel zur DragToColumn-Eigenschaft

In diesem Beispiel wird verhindert, dass das Feld "Year" im ersten PivotTable-Bericht des ersten Tabellenblatts auf die Spaltenposition gezogen wird.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").DragToColumn = False


DragToData-Eigenschaft

True, wenn das angegebene Feld auf die Datenposition gezogen werden kann. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur DragToData-Eigenschaft

In diesem Beispiel wird verhindert, dass das Feld "Year" im ersten PivotTable-Bericht des ersten Tabellenblatts auf die Datenposition heraus gezogen wird.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").DragToData = False


 DragToHide-Eigenschaft

DragToHide-Eigenschaft

True, wenn das Feld ausgeblendet werden kann, indem es aus dem PivotTable-Bericht gezogen wird. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert True, wenn das Feld aus der PivotTable-Berichtsansicht entfernt werden kann.


Beispiel zur DragToHide-Eigenschaft

In diesem Beispiel wird verhindert, dass das Feld "Year" im ersten PivotTable-Bericht des ersten Tabellenblatts aus dem Bericht heraus gezogen wird.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").DragToHide = False


 DragToPage-Eigenschaft

DragToPage-Eigenschaft

True, wenn das Pivotfeld auf die Seitenposition gezogen werden kann. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert für Measurefelder False.


Beispiel zur DragToPage-Eigenschaft

In diesem Beispiel wird verhindert, dass das Feld "Year" im ersten PivotTable-Bericht des ersten Tabellenblatts auf die Seitenposition gezogen wird.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").DragToPage = False


 DragToRow-Eigenschaft

DragToRow-Eigenschaft

True, wenn das Pivotfeld auf die Zeilenposition gezogen werden kann. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert für Measurefelder False.


Beispiel zur DragToRow-Eigenschaft

In diesem Beispiel wird verhindert, dass das Feld "Year" im ersten PivotTable-Bericht des ersten Tabellenblatts auf die Zeilenposition gezogen wird.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").DragToRow = False


 Drilled-Eigenschaft

Drilled-Eigenschaft

Gibt den Status "Drilled" (eingeblendet oder sichtbar) der Cube-Feldmitglieder in dem Steuerelement für die hierarchische Mitgliedsauswahl eines Cube-Felds zurück oder legt diesen fest. Diese Eigenschaft wird hauptsächlich zur Makroaufzeichnung verwendet und ist nicht für andere Zwecke gedacht. Schreib-Lese-Zugriff.

Anmerkungen

Die Drilled-Eigenschaft gibt eine Matrix zurück oder legt diese fest. Jedes Element der Matrix entspricht einer Ebene des Cube-Feldes, das eingeblendet wurde. Die maximale Anzahl der Elemente entspricht der Anzahl der Ebenen im Cube-Feld. Jedes Element der Matrix ist eine Matrix vom Typ String, die die eindeutigen Mitgliedernamen enthält, die auf der entsprechenden Ebene des Steuerelements sichtbar (eingeblendet) sind. Sie können mit Hilfe der Hidden-Eigenschaft des TreeviewControl-Objekts feststellen, ob Mitglieder in einer erweiterten Ansicht ausdrücklich ausgeblendet sind.


 DrilledDown-Eigenschaft

DrilledDown-Eigenschaft

True, wenn das Kennzeichen für das angegebene PivotTable-Feld oder PivotTable-Element auf "Drilled" (eingeblendet oder sichtbar) festgelegt wurde. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie können diese Eigenschaft nur für OLAP-Datenquellen verwenden.

Sie können diese Eigenschaft nicht festlegen, wenn das Feld oder das Element ausgeblendet ist.


Beispiel zur DrilledDown-Eigenschaft

In diesem Beispiel werden die Kennzeichen für alle Elemente im Feld "state" im dritten PivotTable-Bericht des aktiven Tabellenblatts auf "Not Drilled" festgelegt.

ActiveSheet.PivotTables("PivotTable3") _
    .PivotFields("state").DrilledDown = False


Drop-Eigenschaft

Bei Legenden mit explizit festgelegtem Ansatzwert gibt diese Eigenschaft den vertikalen Abstand (in Punkt) vom Rand des Textbegrenzungsrechtecks zu dem Punkt zurück, dem die Legendenlinie des Textfeldes zugeordnet ist. Der Abstand wird vom oberen Rand des Textfeldes gemessen, solange die AutoAttach-Eigenschaft nicht den Wert True besitzt und das Textfeld links vom Ursprung der Legendenlinie (dem Punkt, auf den die Legendenlinie zeigt) liegt. In diesem Fall wird der Ansatz-Abstand vom unteren Rand des Textfeldes aus gemessen. Single Schreibgeschützt.

Anmerkungen

Verwenden Sie die CustomDrop-Methode, um den Wert dieser Eigenschaft festzulegen.

Der Wert dieser Eigenschaft gibt die Position, an der die Legendenlinie dem Textfeld zugeordnet ist, nur dann genau wieder, wenn die Legende einen explizit festgelegten Ansatzwert besitzt - d. h. wenn die DropType-Eigenschaft den Wert msoCalloutDropCustom besitzt.


DropDownLines-Eigenschaft

Gibt die Anzahl der Listenzeilen, die im Dropdownbereich eines Kombinationsfeldes angezeigt werden, zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur DropDownLines-Eigenschaft

In diesem Beispiel wird ein Kombinationsfeld mit 10 Zeilen erstellt.

With Worksheets(1).Shapes.AddFormControl(xlDropDown, _
        Left:=10, Top:=10, Width:=100, Height:=10)
    .ControlFormat.DropDownLines = 10
End With


DropLines-Eigenschaft

Gibt ein DropLines-Objekt zurück, das die Bezugslinien für eine Datenreihe eines Linien- oder Flächendiagramms darstellt. Nur für Linien- oder Flächendiagramme gültig. Schreibgeschützt.


Beispiel zur DropLines-Eigenschaft

In diesem Beispiel werden die Bezugslinien der ersten Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, dieses Beispiel auf ein 2D-Liniendiagramm anzuwenden, das eine Datenreihe beinhaltet.

With Charts("Chart1").ChartGroups(1)
    .HasDropLines = True
    With .DropLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


DropType-Eigenschaft

Gibt einen Wert zurück, der angibt, wo die Legendenlinie dem Legendentextfeld zugeordnet ist. Kann eine der folgenden MsoCalloutDropType-Konstanten sein: msoCalloutDropBottom, msoCalloutDropCenter, msoCalloutDropCustom, msoCalloutDropMixed oder msoCalloutDropTop. Long Schreibgeschützt.

Anmerkungen

Wenn der Ansatz-Typ der Legende den Wert msoCalloutDropCustom besitzt, wird durch die Eigenschaften Drop und AutoAttach sowie durch die relativen Positionen von Legendentextfeld und Ursprung der Legendenlinie (dem Ort, auf den die Legende zeigt) festgelegt, wo die Legendenlinie dem Textfeld zugeordnet wird.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die PresetDrop-Methode, um ihren Wert festzulegen.


Beispiel zur DropType-Eigenschaft

In diesem Beispiel wird der benutzerdefinierte Ansatz der ersten Form in myDocument durch einen von zwei vordefinierten Ansätzen ersetzt. Welcher der vordefinierten Ansätze eingesetzt wird, hängt davon ab, ob der benutzerdefinierte Ansatzwert größer oder kleiner ist als die halbe Höhe des Legendentextfeldes. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um eine Legende handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropCustom Then
        If .Drop < .Parent.Height / 2 Then
            .PresetDrop msoCalloutDropTop
        Else
            .PresetDrop msoCalloutDropBottom
        End If
    End If
End With


EditDirectlyInCell-Eigenschaft

True, wenn Microsoft Excel direkte Zellbearbeitung zulässt. Boolean Schreib-Lese-Zugriff.


Beispiel zur EditDirectlyInCell-Eigenschaft

In diesem Beispiel wird die direkte Zellbearbeitung aktiviert.

Application.EditDirectlyInCell = True


EditingType-Eigenschaft

Wenn es sich bei dem angegebenen Knoten um einen Scheitelpunkt handelt, gibt diese Eigenschaft einen Wert zurück, der angibt, wie an dem Knoten vorgenommene Änderungen die beiden mit dem Knoten verbundenen Abschnitte beeinflussen. Kann eine der folgenden MsoEditingType-Konstanten sein: msoEditingAuto, msoEditingCorner, msoEditingSmooth oder msoEditingSymmetric. Wenn es sich bei dem Knoten um einen Steuerpunkt für einen gekrümmten Abschnitt handelt, gibt diese Eigenschaft die Bearbeitungsart des angrenzenden Scheitelpunktes zurück. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetEditingType-Methode, um ihren Wert festzulegen.


Beispiel zur EditingType-Eigenschaft

In diesem Beispiel werden alle Eckknoten der dritten Form in myDocument zu Übergangsknoten gemacht. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    For n = 1 to .Count
        If .Item(n).EditingType = msoEditingCorner Then
            .SetEditingType n, msoEditingSmooth
        End If
    Next
End With


Elevation-Eigenschaft

Gibt die Betrachtungshöhe für 3D-Diagramme in Grad zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Betrachtungshöhe eines Diagramms ist die Perspektive oder der Winkel in Grad, aus dem das Diagramm gesehen wird. Die Voreinstellung für die meisten Diagrammtypen ist 15 Grad. Der Wert dieser Eigenschaft muss zwischen -90 und 90 liegen. Für 3D-Balkendiagramme muss der Wert zwischen 0 und 44 liegen.


Beispiel zur Elevation-Eigenschaft

In diesem Beispiel wird die Betrachtungshöhe von Chart1 auf 34 Grad festgelegt. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden (die Elevation-Eigenschaft erzeugt einen Fehler, wenn Sie auf 2D-Diagramme angewendet wird).

Charts("Chart1").Elevation = 34


EmailSubject-Eigenschaft

Gibt die Textzeichenfolge der E-Mail-Betreffzeile des angegebenen Hyperlinks zurück oder legt diese fest. Die Betreffzeile wird an die Adresse des Hyperlinks angehängt. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird normalerweise bei E-Mail-Hyperlinks verwendet.

Der Wert dieser Eigenschaft hat Vorrang vor allen E-Mail-Betreffzeilen, die mit der Address-Eigenschaft desselben Hyperlink-Objekts angegeben wurden.


Beispiel zur EmailSubject-Eigenschaft

In diesem Beispiel wird die E-Mail-Betreffzeile für den ersten Hyperlink im ersten Tabellenblatt festgelegt.

Worksheets(1).Hyperlinks(1).EmailSubject = "Quote Request"


EnableAnimations-Eigenschaft

True, wenn der Animationseffekt für Einfügen und Löschen aktiviert ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ist die Animation aktiviert, werden in das Tabellenblatt eingefügte Zeilen und Spalten langsam eingeblendet; aus der Tabelle gelöschte Zeilen und Spalten verschwinden langsam.


Beispiel zur EnableAnimations-Eigenschaft

Im folgenden Beispiel wird der Animationseffekt für Einfügen und Löschen deaktiviert.

Application.EnableAnimations = False


EnableAutoComplete-Eigenschaft

True, wenn AutoComplete aktiviert ist. Boolean Schreib-Lese Zugriff.


Beispiel zur EnableAutoComplete-Eigenschaft

In diesem Beispiel wird AutoComplete aktiviert.

Application.EnableAutoComplete = True


EnableAutoFilter-Eigenschaft

True, falls AutoFilter-Pfeile aktiviert sind, wenn der Schutz "Nur-Benutzerschnittstelle" eingeschaltet ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft git für jedes einzelne Tabellenblatt und wird nicht mit dem Tabellenblatt oder der Sitzung gespeichert.


Beispiel zur EnableAutoFilter-Eigenschaft

In diesem Beispiel werden die AutoFilter-Pfeile in einem geschützten Tabellenblatt aktiviert.

ActiveSheet.EnableAutoFilter = True
ActiveSheet.Protect contents:=True, userInterfaceOnly:=True


EnableCalculation-Eigenschaft

True, falls Microsoft Excel, wenn notwendig, das Tabellenblatt automatisch neu berechnet. False, falls Excel das Tabellenblatt nicht neu berechnet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn der Wert der Eigenschaft False lautet, können Sie keine Neuberechnung anfordern. Wenn Sie den Wert von False zu True ändern, berechnet Excel das Tabellenblatt automatisch neu.


Beispiel zur EnableCalculation-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel das erste Tabellenblatt nicht automatisch neu berechnet.

Worksheets(1).EnableCalculation = False


EnableCancelKey-Eigenschaft

Steuert, wie Microsoft Excel Unterbrechungen einer ausgeführten Prozedur durch STRG+UNTBR (oder ESC bzw. BEFEHL+PUNKT) behandelt. Long Schreib-Lese-Zugriff.

Zulässig ist eine der folgenden XlEnableCancelKey-Konstanten:

Konstante | Bedeutung
xlDisabled | Das Drücken der Abbruchtasten wird nicht beachtet.
xlInterrupt | Die aktuelle Prozedur wird unterbrochen, und der/die Benutzer/in kann die Prozedur testen oder beenden.
xlErrorHandler | Die Unterbrechung wird als Fehler an die momentan ausgeführte Prozedur gesendet. Dieser Fehler kann dort durch eine Fehlerbehandlungsroutine behandelt werden, die mit einer On Error GoTo-Anweisung festgelegt wurde. Der Fehlercode des auffangbaren Fehlers ist 18.

Anmerkungen

Verwenden Sie diese Eigenschaft sehr vorsichtig. Falls Sie die Einstellung xlDisabled wählen, besteht keine Möglichkeit, eine Endlosschleife oder anderen nicht selbständig endenden Code zu unterbrechen. Falls Sie xlErrorHandler verwenden, die Fehlerbehandlungsroutine die Ausführung aber immer mit der Resume-Anweisung fortsetzt, besteht ebenfalls keine Möglichkeit, Endloscode zu unterbrechen.

Die EnableCancelKey-Eigenschaft wird immer auf xlInterrupt zurückgesetzt, sobald Microsoft Excel Leerlaufzeit hat und kein Code ausgeführt wird. Um Unterbrechungen in einer Prozedur aufzufangen oder zu sperren, müssen Sie die EnableCancelKey-Eigenschaft bei jedem Aufruf der Prozedur explizit ändern.


Beispiel zur EnableCancelKey-Eigenschaft

In diesem Beispiel wird gezeigt, wie mit der EnableCancelKey-Eigenschaft eine benutzerdefinierte Abbruchbehandlung eingerichtet werden kann.

On Error GoTo handleCancel
Application.EnableCancelKey = xlErrorHandler
MsgBox "This may take a long time: press ESC to cancel"
For x = 1 To 1000000    ' Do something 1,000,000 times (long!)
    ' do something here
Next x

handleCancel:
If Err = 18 Then
    MsgBox "You cancelled"
End If


Enabled-Eigenschaft

True, wenn das Objekt aktiviert ist. Boolean Schreib-Lese-Zugriff.


 EnableDrilldown-Eigenschaft

EnableDrilldown-Eigenschaft

True, wenn Drilldown aktiviert ist. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft für einen PivotTable-Bericht festgelegt, so gilt sie für alle Felder dieses Berichts.

Bei OLAP-Datenquellen ist der Wert immer True.


Beispiel zur EnableDrilldown-Eigenschaft

In diesem Beispiel wird Drilldown für alle Felder im ersten PivotTable-Bericht des ersten Tabellenblatts deaktiviert.

Worksheets(1).PivotTables("Pivot1").EnableDrilldown = False


EnableEditing-Eigenschaft

True, falls der Benutzer die angegebene Abfragetabelle bearbeiten kann. False, falls der Benutzer die Abfragetabelle nur aktualisieren kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableEditing-Eigenschaft

In diesem Beispiel wird festgelegt, dass der Benutzer die erste Abfragetabelle nicht bearbeiten kann.

Worksheets(1).QueryTables(1).EnableEditing = False


EnableEvents-Eigenschaft

True, wenn Ereignisse für das angegebene Objekt aktiviert sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableEvents-Eigenschaft

In diesem Beispiel werden Ereignisse vor dem Speichern einer Datei deaktiviert, so dass das Ereignis BeforeSave nicht auftritt.

Application.EnableEvents = False
ActiveWorkbook.Save
Application.EnableEvents = True


EnableFieldDialog-Eigenschaft

True, falls das Dialogfeld PivotTable-Feld verfügbar ist, wenn der Benutzer auf das PivotTable-Feld doppelklickt. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft für einen PivotTable-Bericht festgelegt, so gilt sie für alle Felder dieses Berichts.


Beispiel zur EnableFieldDialog-Eigenschaft

In diesem Beispiel wird das Dialogfeld PivotTable-Feld des Feldes Jahr deaktiviert.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Year").EnableFieldDialog = False


EnableOutlining-Eigenschaft

True, falls die Gliederungssymbole aktiviert sind, wenn der Schutz "Nur-Benutzerschnittstelle" eingeschaltet ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft git für jedes einzelne Tabellenblatt und wird nicht mit dem Tabellenblatt oder der Sitzung gespeichert.


Beispiel zur EnableOutlining-Eigenschaft

In diesem Beispiel werden die Gliederungssymbole in einem geschützten Tabellenblatt akiviert.

ActiveSheet.EnableOutlining = True
ActiveSheet.Protect contents:=True, userInterfaceOnly:=True


EnablePivotTable-Eigenschaft

True, falls die Steuerelemente und -aktionen für PivotTables aktiviert sind, wenn der Schutz "Nur-Benutzerschnittstelle" eingeschaltet ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft gilt für jedes einzelne Tabellenblatt und wird nicht mit dem Tabellenblatt oder der Sitzung gespeichert.

Es muss eine ausreichende Anzahl an ungesperrten Zellen unter und rechts dem PivotTable-Bericht vorliegen, damit Microsoft Excel den PivotTable-Bericht neu berechnen und anzeigen kann.


Beispiel zur EnablePivotTable-Eigenschaft

In diesem Beispiel werden die Steuerelemente für eine Pivot-Tabelle in einem geschützten Tabellenblatt aktiviert.

ActiveSheet.EnablePivotTable = True
ActiveSheet.Protect contents:=True, userInterfaceOnly:=True


 EnableRefresh-Eigenschaft

EnableRefresh-Eigenschaft

True, wenn der PivotTable-Cache oder die Abfragetabelle von der Benutzerin oder dem Benutzer aktualisiert werden kann. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die RefreshOnFileOpen wird ignoriert, wenn die EnableRefresh-Eigenschaft den Wert False erhält.

Bei OLAP-Datenquellen deaktiviert die Einstellung dieser Eigenschaft auf False Aktualisierungen.


Beispiel zur EnableRefresh-Eigenschaft

In diesem Beispiel wird festgelegt, dass der erste PivotTable-Bericht im ersten Tabellenblatt nicht aktualisiert werden kann.

Worksheets(1).PivotTables("Pivot1") _
    .PivotCache.EnableRefresh = False


EnableResize-Eigenschaft

True, wenn die Größe des Fensters verändert werden kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableResize-Eigenschaft

Mit diesem Beispiel wird festgelegt, dass die Größe des aktiven Fensters nicht verändert werden kann.

ActiveWindow.EnableResize = False


EnableSelection-Eigenschaft

Gibt die Elemente zurück, die auf dem Blatt markiert werden können, bzw. legt diese Elemente fest. Dies kann eine der folgenden XlEnableSelection-Konstanten sein: xlNoRestrictions, xlNoSelection oder xlUnlockedCells. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist nur wirksam, wenn das Tabellenblatt geschützt ist: xlNoSelection verhindert jegliche Markierung auf dem Blatt, xlUnlockedCells gestattet nur die Markierung der Zellen, deren Locked-Eigenschaft False ist, und xlNoRestrictions erlaubt die Markierung einer beliebigen Zelle.


Beispiel zur EnableSelection-Eigenschaft

In diesem Beispiel wird festgelegt, dass im ersten Tabellenblatt nichts markiert werden kann.

With Worksheets(1)
    .EnableSelection = xlNoSelection
    .Protect Contents:=True, UserInterfaceOnly:=True
End With


EnableSound-Eigenschaft

True, falls der Klang in Microsoft Office aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnableSound-Eigenschaft

In diesem Beispiel wird die Klangausgabe deaktiviert.

Application.EnableSound = False


EnableWizard-Eigenschaft

True, wenn der PivotTable-Assistent verfügbar ist. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft festgelegt wird, werden die "field wells" im Tabellenblatt nicht angezeigt.


Beispiel zur EnableWizard-Eigenschaft

In diesem Beispiel wird der PivotTable-Assistent für den ersten PivotTable-Bericht des ersten Tabellenblatts deaktiviert.

Worksheets(1).PivotTables("Pivot1").EnableWizard = False


Encoding-Eigenschaft

Gibt die Codierung des Dokuments (Codepage oder Zeichensatz), die vom Webbrowser beim Anzeigen des gespeicherten Dokuments verwendet wird, zurück oder legt diese fest. Kann eine der MsoEncoding-Konstanten sein, die im Visual Basic-Objektkatalog aufgeführt sind. Standardeinstellung ist die Systemcodepage. MsoEncoding Schreib-Lese-Zugriff.

Anmerkungen

Sie können keine Konstanten mit dem Suffix AutoDetect verwenden. Diese Konstanten werden von der ReloadAs-Methode verwendet.


Beispiel zur Encoding-Eigenschaft

In diesem Beispiel wird überprüft, ob die Standardcodierung für Dokumente "Western" lautet; anschließend wird die Zeichenfolge strDocEncoding entsprechend festgelegt.

If Application.DefaultWebOptions.Encoding = msoEncodingWestern Then
    strDocEncoding = "Western"
Else
    strDocEncoding = "Other"
End If


End-Eigenschaft

Gibt ein Range-Objekt zurück, das die Zelle am Ende der Region darstellt, die den Quellbereich enthält. Diese Methode entspricht dem Drücken von ENDE + NACH OBEN, ENDE + NACH UNTEN, ENDE + NACH LINKS oder ENDE + NACH RECHTS. Schreibgeschützt.

Syntax

Ausdruck.End(Direction)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt.

Direction Long erforderlich. Gibt die Richtung der Bewegung an. Kann eine der folgenden XlDirection-Konstanten sein: xlToLeft, xlToRight, xlUp oder xlDown.


EndArrowheadLength-Eigenschaft

Gibt die Länge der Pfeilspitze am Ende der angegebenen Linie zurück oder legt die Länge fest. Kann eine der folgenden MsoArrowheadLength-Konstanten sein: msoArrowheadLengthMedium, msoArrowheadLengthMixed, msoArrowheadLong oder msoArrowheadShort. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadLength-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadStyle-Eigenschaft

Gibt die Art der Pfeilspitze am Ende der angegebenen Linie zurück oder legt die Art fest. Kann eine der folgenden MsoArrowheadStyle-Konstanten sein: msoArrowheadDiamond, msoArrowheadNone, msoArrowheadOpen, msoArrowheadOval, msoArrowheadStealth, msoArrowheadStyleMixed oder msoArrowheadTriangle. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadStyle-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndArrowheadWidth-Eigenschaft

Gibt die Breite der Pfeilspitze am Anfang der angegebenen Linie zurück oder legt die Breite fest. Kann eine der folgenden MsoArrowheadWidth-Konstanten sein: msoArrowheadNarrow, msoArrowheadWide, msoArrowheadWidthMedium oder msoArrowheadWidthMixed. Long Schreib-Lese-Zugriff.


Beispiel zur EndArrowheadWidth-Eigenschaft

In diesem Beispiel wird in myDocument eine Linie eingefügt. Der Anfangspunkt der Linie ist mit einer kurzen, engen Ellipse versehen, ihr Endpunkt mit einem langen, breiten Dreieck.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(100, 100, 200, 300).Line
    .BeginArrowheadLength = msoArrowheadShort
    .BeginArrowheadStyle = msoArrowheadOval
    .BeginArrowheadWidth = msoArrowheadNarrow
    .EndArrowheadLength = msoArrowheadLong
    .EndArrowheadStyle = msoArrowheadTriangle
    .EndArrowheadWidth = msoArrowheadWide
End With


EndConnected-Eigenschaft

True, wenn das Ende der angegebenen Verbindung mit einer Form verbunden ist. Long Schreibgeschützt.


EndConnectedShape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Form darstellt, der das Ende der angegebenen Verbindung zugeordnet ist. Schreibgeschützt.

Anmerkung Wenn das Ende der angegebenen Verbindung nicht einer Form zugeordnet ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur EndConnectedShape-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass myDocument bereits zwei Formen enthält, denen die Verbindung "Verb1mit2" zugeordnet ist. Der Code fügt in myDocument ein Rechteck sowie eine Verbindung ein. Das Ende der neuen Verbindung wird demselben Verbindungspunkt zugeordnet wie das Ende der Verbindung "Verb1mit2". Der Anfang der neuen Verbindung wird dem ersten Verbindungspunkt auf dem neuen Rechteck zugeordnet.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, _
        100, 420, 200, 100)
    With .Item("Conn1To2").ConnectorFormat
        endConnSite1 = .EndConnectionSite
        Set endConnShape1 = .EndConnectedShape
    End With
    With .AddConnector(msoConnectorCurve, _
            0, 0, 10, 10).ConnectorFormat
        .BeginConnect r3, 1
        .EndConnect endConnShape1, endConnSite1
    End With
End With


EndConnectionSite-Eigenschaft

Gibt eine Ganzzahl zurück, die den Verbindungspunkt angibt, mit dem das Ende einer Verbindung verbunden ist. Long Schreibgeschützt.

Anmerkung Wenn das Ende der angegebenen Verbindung nicht einer Form zugeordnet ist, erzeugt diese Eigenschaft einen Fehler.


Beispiel zur EndConnectionSite-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass myDocument bereits zwei Formen enthält, denen die Verbindung "Verb1mit2" zugeordnet ist. Der Code fügt in myDocument ein Rechteck sowie eine Verbindung ein. Das Ende der neuen Verbindung wird demselben Verbindungspunkt zugeordnet wie das Ende der Verbindung "Verb1mit2". Der Anfang der neuen Verbindung wird dem ersten Verbindungspunkt auf dem neuen Rechteck zugeordnet.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    Set r3 = .AddShape(msoShapeRectangle, _
        100, 420, 200, 100)
    With .Item("Conn1To2").ConnectorFormat
        endConnSite1 = .EndConnectionSite
        Set endConnShape1 = .EndConnectedShape
    End With
    With .AddConnector(msoConnectorCurve, _
            0, 0, 10, 10).ConnectorFormat
        .BeginConnect r3, 1
        .EndConnect endConnShape1, endConnSite1
    End With
End With


EndStyle-Eigenschaft

Gibt zurück oder legt fest, wie die Enden der Fehlerindikatoren formatiert werden. Zulässig ist eine der XlEndStyleCap-Konstanten xlCap oder xlNoCap. Long Schreib-Lese-Zugriff.


Beispiel zur EndStyle-Eigenschaft

In diesem Beispiel wird das Endformat der Fehlerindikatoren für die erste Datenreihe in Chart1 festgelegt. Das Beispiel sollte auf ein 2D-Liniendiagramm angewendet werden, bei dem für die Y-Achse der ersten Datenreihe Fehlerindikatoren vorhanden sind.

Charts("Chart1").SeriesCollection(1).ErrorBars.EndStyle = xlCap


EntireColumn-Eigenschaft

Gibt ein Range-Objekt zurück, das eine oder mehrere ganze Spalten darstellt, die den angegebenen Bereich enthalten. Schreibgeschützt.


Beispiel zur EntireColumn-Eigenschaft

In diesem Beispiel wird der Wert für die erste Zelle der Spalte gesetzt, in der sich die aktive Zelle befindet. Das Beispiel muss von einem Tabellenblatt aus ausgeführt werden.

ActiveCell.EntireColumn.Cells(1, 1).Value = 5


EntireRow-Eigenschaft

Gibt ein Range-Objekt zurück, das eine oder mehrere ganze Zeilen darstellt, die den angegebenen Bereich enthalten. Schreibgeschützt.


Beispiel zur EntireRow-Eigenschaft

In diesem Beispiel wird der Wert für die erste Zelle der Zeile gesetzt, die die aktive Zelle enthält. Das Beispiel muss von einem Tabellenblatt aus ausgeführt werden.

ActiveCell.EntireRow.Cells(1, 1).Value = 5


EnvelopeVisible-Eigenschaft

True, wenn der E-Mail-Editorkopfbereich und die Umschlagsymbolleiste sichtbar sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur EnvelopeVisible-Eigenschaft

In diesem Beispiel wird überprüft, ob der E-Mail-Editorkopfbereich und die Umschlagsymbolleiste im ersten Tabellenblatt sichtbar sind. Wenn ja, legt das Beispiel die Variable strSubject auf den Text der E-Mail-Betreffzeile fest.

If Workbooks(1).EnvelopeVisible = True Then
    strSubject = "Please read: Review immediately"
End If


ErrorBars-Eigenschaft

Gibt ein ErrorBars-Objekt zurück, das die Fehlerindikatoren für die Datenreihe darstellt. Schreibgeschützt.


Beispiel zur ErrorBars-Eigenschaft

In diesem Beispiel wird die Farbe der Fehlerindikatoren für die erste Datenreihe in Chart1 festgelegt. Wenden Sie das Beispiel auf ein 2D-Liniendiagramm mit Fehlerindikatoren für die erste Datenreihe an.

With Charts("Chart1").SeriesCollection(1)
    .ErrorBars.Border.ColorIndex = 8
End With


ErrorMessage-Eigenschaft

Gibt die Fehlermeldung zur Validierung zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur ErrorMessage-Eigenschaft

In diesem Beispiel wird Validierung in Zelle E5 hinzugefügt und die Eingabe- und Fehlermeldungen festgelegt.

With Range("e5").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:= xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", Formula2:="10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


ErrorString-Eigenschaft

PivotTable-Objekt: Gibt die in Zellen, die Fehler enthalten, angezeigte Zeichenfolge zurück oder legt sie fest, wenn die DisplayErrorString-Eigenschaft den Wert True besitzt. Der Standardwert ist eine leere Zeichenfolge (""). String Schreib-Lese-Zugriff.

ODBCError-Objekt: Gibt die ODBC-Fehlerzeichenfolge zurück. String Schreibgeschützt.


Beispiel zur ErrorString-Eigenschaft

In diesem Beispiel wird in Zellen des angegebenen PivotTable-Berichts, die Fehler enthalten, ein Bindestrich angezeigt.

With Worksheets(1).PivotTables("Pivot1")
    .ErrorString = "-"
    .DisplayErrorString = True
End With


ErrorTitle-Eigenschaft

Gibt den Titel des Dialogfelds zu Fehlern bei der Gültigkeitsprüfung zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur ErrorTitle-Eigenschaft

In diesem Beispiel wird der Zelle E5 eine Gültigkeitsprüfung hinzugefügt.

With Range("e5").Validation
    .Add xlValidateWholeNumber, _
        xlValidAlertInformation, xlBetween, "5", "10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


Excel4IntlMacroSheets-Eigenschaft

Gibt eine Sheets-Auflistung zurück, die alle Microsoft Excel 4.0-Internationalen Makroblätter der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft mit dem Application-Objekt oder ohne einen Objektkennzeichner hat die gleiche Funktion wie ActiveWorkbook.Excel4IntlMacroSheets.


Beispiel zur Excel4IntlMacroSheets-Eigenschaft

In diesem Beispiel wird die Anzahl der Microsoft Excel 4.0-Internationalen Makroblätter in der aktiven Arbeitsmappe angezeigt.

MsgBox "There are " & _
    ActiveWorkbook.Excel4IntlMacroSheets.Count & _
    " Microsoft Excel 4.0 international macro sheets" & _
    " in this workbook."


Excel4MacroSheets-Eigenschaft

Gibt eine Sheets-Auflistung, die alle Microsoft Excel 4.0-Makroblätter der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft mit dem Application-Objekt oder ohne einen Objektkennzeichner hat die gleiche Funktion wie ActiveWorkbook.Excel4MacroSheets.


Beispiel zur Excel4MacroSheets-Eigenschaft

In diesem Beispiel wird die Anzahl der Microsoft Excel 4.0-Makroblätter in der aktiven Arbeitsmappe angezeigt.

MsgBox "There are " & ActiveWorkbook.Excel4MacroSheets.Count & _
    " Microsoft Excel 4.0 macro sheets in this workbook."


Explosion-Eigenschaft

Gibt den prozentualen Auszug von Kreisdiagramm- oder Ringdiagramm-Segmenten zurück oder legt diesen fest. Null bedeutet kein Auszug (d.h., die Spitze des Kreissegments liegt in der Mitte des Diagramms). Long Schreib-Lese-Zugriff.


Beispiel zur Explosion-Eigenschaft

In diesem Beispiel wird der Wert für den Auszug des zweiten Punkts in Chart1 festgelegt. Es ist sinnvoll, das Beispiel auf ein Kreisdiagramm anzuwenden.

Charts("Chart1").SeriesCollection(1).Points(2).Explosion = 20


ExtendList-Eigenschaft

True, wenn Microsoft Excel automatisch Formatierung und Formeln für neue Daten erweitert, die zu einer Liste hinzugefügt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Damit Formate und Formeln erweitert werden können, müssen sie in mindestens drei der ersten fünf Zeilen oder Spalten vor der neuen Zeile oder Spalte angezeigt werden, und Sie müssen die Daten unterhalb oder rechts von der Liste eingeben.


Beispiel zur ExtendList-Eigenschaft

In diesem Beispiel wird festgelegt, dass Excel keine Formatierung und Formeln für Daten anwendet, die nachfolgend zu einer vorhandenen Liste hinzugefügt werden.

Application.ExtendList = False


Extent-Eigenschaft

Gibt die Art des angegebenen Seitenwechsels zurück: auf dem ganzen Bildschirm oder nur innerhalb des Druckbereichs. Dies kann eine der beiden folgenden XlPageBreakExtent-Konstanten sein: xlPageBreakFull oder xlPageBreakPartial. Long Schreibgeschützt.


Beispiel zur Extent-Eigenschaft

In diesem Beispiel wird die gesamte Anzahl der horizontalen Seitenwechsel des ganzen Bildschirms und des Druckbereichs angezeigt.

For Each pb in Worksheets(1).HPageBreaks
    If pb.Extent = xlPageBreakFull Then
        cFull = cFull + 1
    Else
        cPartial = cPartial + 1
    End If
Next
MsgBox cFull & " full-screen page breaks, " & cPartial & _
    " print-area page breaks"


ExtrusionColor-Eigenschaft

Gibt ein ColorFormat-Objekt zurück, das die Farbe der Projektion der Form darstellt. Schreibgeschützt.


ExtrusionColorType-Eigenschaft

Gibt einen Wert zurück oder legt einen Wert fest, der angibt, ob die Projektionsfarbe auf der Füllung der Form (der Vorderseite der Projektion) aufbaut und sich automatisch ändert, wenn sich die Füllung der Form ändert, oder ob die Projektionsfarbe von der Füllung der Form unabhängig ist. Kann eine der folgenden MsoExtrusionColorType-Konstanten sein: msoExtrusionColorAutomatic (Projektionsfarbe auf Grundlage der Füllung der Form), msoExtrusionColorCustom (Projektionsfarbe unabhängig von der Füllung der Form oder msoExtrusionColorTypeMixed. Long Lese- und Schreibzugriff.


Beispiel zur ExtrusionColorType-Eigenschaft

Wenn die Projektionsfarbe in myDocument automatisch festgelegt wird, wird der Projektion in diesem Beispiel eine benutzerdefinierte gelbe Farbe zugewiesen.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    If .ExtrusionColorType = msoExtrusionColorAutomatic Then
        .ExtrusionColor.RGB = RGB(240, 235, 16)
    End If
End With


FeatureInstall-Eigenschaft

Gibt einen Wert (Konstante) zurück oder legt diesen fest. Dieser Wert zeigt an, wie Microsoft Excel Aufrufe von Methoden und Eigenschaften, die noch nicht installierte Features erfordern, verarbeitet. Kann eine der in der folgenden Tabelle aufgeführten MsoFeatureInstall-Konstanten sein. Long Schreib-Lese-Zugriff.

Konstante | Wert | Beschreibung
msoFeatureInstallNone | 0 | Erzeugt zur Laufzeit einen allgemeinen Automatisierungsfehler, wenn nicht installierte Features aufgerufen werden. Dies ist die Standardkonstante.
msoFeatureInstallOnDemand | 1 | Fordert den Benutzer auf, die neuen Features zu installieren.
msoFeatureInstallOnDemandWithUI | 2 | Zeigt während der Installation den Status an; der Benutzer wird nicht aufgefordert, die neuen Features zu installieren.

Anmerkungen

Während ein Feature installiert wird, können Sie mit der msoFeatureInstallOnDemandWithUI-Konstante verhindern, dass die Benutzer denken, die Anwendung reagiere nicht. Verwenden Sie die msoFeatureInstallNone-Konstante, wenn der Entwickler als Einziger Features installieren können soll.

Wenn die DisplayAlerts-Eigenschaft auf False festgelegt ist, werden die Benutzer nicht aufgefordert, neue Features zu installieren, auch wenn die FeatureInstall-Eigenschaft auf msoFeatureInstallOnDemand eingestellt ist. Ist die DisplayAlerts-Eigenschaft auf True festgelegt, wird eine Statusanzeige angezeigt, wenn die FeatureInstall-Eigenschaft auf msoFeatureInstallOnDemand eingestellt ist.


Beispiel zur FeatureInstall-Eigenschaft

In diesem Beispiel wird eine neue Instanz von Microsoft Word aktiviert und der Wert der FeatureInstall-Eigenschaft wird überprüft. Ist die Eigenschaft auf msoFeatureInstallNone eingestellt, zeigt der Code ein Meldungsfenster, das den Benutzer fragt, ob er die Einstellung der Eigenschaft ändern möchte. Bejaht der Benutzer, wird die Eigenschaft auf msoFeatureInstallOnDemand festgelegt.

Dim WordApp As New Word.Application, Reply As Integer
With WordApp
    .ActivateMicrosoftApp
    If .FeatureInstall = msoFeatureInstallNone Then
        Reply = MsgBox("Uninstalled features for this " _
            & "application " & vbCrLf _
            & "may cause a run-time error when called." & vbCrLf _
            & vbCrLf _
            & "Would you like to change this setting" & vbCrLf _
            & "to automatically install missing features?" _
            , 52, "Feature Install Setting")
        If Reply = 6 Then
            .FeatureInstall = msoFeatureInstallOnDemand
        End If
    End If
End With


FetchedRowOverflow-Eigenschaft

True, falls die Anzahl der Zeilen, die bei der letzten Verwendung der Refresh-Methode zurückgegeben wurden, größer ist als die Anzahl der in dem Tabellenblatt verfügbaren Zeilen. Boolean Schreibgeschützt.


Beispiel zur FetchedRowOverflow-Eigenschaft

In diesem Beispiel wird die erste Abfragetabelle aktualisiert. Falls die Anzahl der von der Abfragetabelle zurückgegebenen Zeilen größer ist als die in dem Tabellenblatt verfügbaren Zeilen, wird eine Fehlermeldung angezeigt.

With Worksheets(1).QueryTables(1)
    .Refresh
    If .FetchedRowOverflow Then
        MsgBox "Query too large: please redefine."
    End If
End With


FieldNames-Eigenschaft

True, falls Feldnamen aus der Datenquelle als Spaltenüberschriften der zurückgegebenen Daten erscheinen. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur FieldNames-Eigenschaft

In diesem Beispiel wird festgelegt, dass in der ersten Abfragetabelle keine Feldnamen erscheinen.

Worksheets(1).QueryTables(1).FieldNames = False


FileConverters-Eigenschaft

Gibt Informationen über alle installierten Dateiumwandlungsprogramme zurück. Gibt Null zurück, wenn keine Umwandlungsprogramme installiert sind. Variant Schreibgeschützt.

Syntax

Ausdruck.FileConverters(Index1, Index2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index1 Variant optional. Der ausgeschriebene Name des Umwandlungsprogramms, einschließlich der Zeichenfolge zum Suchen des jeweiligen Dateiformats in Windows (zum Beispiel, "Lotus 1-2-3 Dateien (*.wk*)").

Index2 Variant optional. Der Pfad der DLL-Datei oder des Quellcodes des Umwandlungsprogramms.

Anmerkungen

Wenn Sie die Indexargumente nicht angeben, gibt diese Eigenschaft eine Matrix mit Informationen über alle installierten Dateiumwandlungsprogramme zurück. Jede Zeile der Matrix enthält Informationen über jeweils ein Dateiumwandlungsprogramm, wie aus der folgenden Tabelle hervorgeht.

Spalte | Inhalt
1 | Der ausgeschriebene Name des Umwandlungsprogramms
2 | Der Pfad der DLL-Datei oder des Quellcodes des Umwandlungsprogramms
3 | Die Suchzeichenfolge der Dateinamenerweiterung


FileFormat-Eigenschaft

Gibt das Dateiformat und/oder den Typ der Arbeitsmappe zurück. Long Schreibgeschützt

Kann eine der folgenden XlFileFormat-Konstanten sein:

xlAddIn

xlCSV

xlCSVMac

xlCSVMSDOS

xlCSVWindows

xlCurrentPlatformText

xlDBF2

xlDBF3

xlDBF4

xlDIF

xlExcel2

xlExcel2FarEast

xlExcel3

xlExcel4

xlExcel4Workbook

xlExcel5

xlExcel7

xlExcel9795

xlHTML

xlIntlAddIn

xlIntlMacro

 xlSYLK

xlTemplate

xlTextMac

xlTextMSDOS

xlTextPrinter

xlTextWindows

xlUnicodeText

xlWJ2WD1

xlWK1

xlWK1ALL

xlWK1FMT

xlWK3

xlWK4

xlWK3FM3

xlWKS

xlWorkbookNormal

xlWorks2FarEast

xlWQ1

xlWJ3

xlWJ3FJ3

Anmerkungen

Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur FileFormat-Eigenschaft

In diesem Beispiel wird die aktive Arbeitsmappe im Standard-Dateiformat gespeichert, falls sie momentan das Dateiformat WK3 aufweist.

If ActiveWorkbook.FileFormat = xlWK3 Then
    ActiveWorkbook.SaveAs fileFormat:=xlNormal
End If


FileName-Eigenschaft

Gibt den URL (im Intranet oder World Wide Web) oder Pfad (lokal oder Netzwerk) zu dem Speicherort, in dem das angegebene Quellobjekt gespeichert wurde, zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Die FileName-Eigenschaft erzeugt einen Fehler, wenn ein Ordner in dem angegebenen Pfad nicht vorhanden ist.


Beispiel zur FileName-Eigenschaft

In diesem Beispiel wird der Speicherort festgelegt, in dem das erste Element in der aktiven Arbeitsmappe gespeichert werden soll.

ActiveWorkbook.PublishObjects(1).FileName = _
    "\\Server2\Q1\StockReport.htm"


FileSearch-Eigenschaft

Gibt ein FileSearch-Objekt zur Verwendung bei Dateisuchen zurück. Diese Eigenschaft ist nur in Microsoft Windows verfügbar.


Beispiel zur FileSearch-Eigenschaft

In diesem Beispiel wird ein FoundFiles-Objekt erstellt, das alle Microsoft Excel-Arbeitsmappen im Ordner "My Documents" darstellt.

With Application.FileSearch
    .LookIn = "c:\my documents"
    .FileType = msoFileTypeExcelWorkbooks
    .Execute
End With


Fill-Eigenschaft

Gibt ein FillFormat-Objekt zurück, das Füllformateigenschaften des angegebenen Diagramms oder der angegebenen Form darstellt. Schreibgeschützt.


FillAdjacentFormulas-Eigenschaft

True, falls Formeln, die sich rechts von der angegebenen Abfragetabelle befinden, immer automatisch aktualisiert werden, wenn die Abfragetabelle aktualisiert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur FillAdjacentFormulas-Eigenschaft

In diesem Beispiel wird festgelegt, dass Formeln, die sich rechts von der ersten Abfragetabelle befinden, immer automatisch aktualisiert werden, wenn die Abfragetabelle aktualisiert wird.

Sheets("sheet1").QueryTables(1).FillAdjacentFormulas = True


FilterMode-Eigenschaft

True, wenn sich das Tabellenblatt im Filter-Modus befindet. Boolean Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist True, wenn das Tabellenblatt eine gefilterte Liste beinhaltet, die keine verborgenen Zeilen enthält.


Beispiel zur FilterMode-Eigenschaft

In diesem Beispiel wird der Filterstatus von Sheet1 in einem Meldungsfeld angezeigt.

If Worksheets("Sheet1").FilterMode = True Then
    MsgBox "Filter mode is on"
Else
    MsgBox "Filter mode is off"
End If


Filters-Eigenschaft

Gibt eine Filters-Auflistung zurück, die alle Filter in einem automatisch gefilterten Bereich darstellt. Schreibgeschützt.


Beispiel zur Filters-Eigenschaft

Im folgenden Beispiel wird eine Variable auf den Wert der Criteria1-Eigenschaft des Filters für die erste Spalte im gefilterten Bereich von Tabellenblatt "Crew" festgelegt.

With Worksheets("Crew")
    If .AutoFilterMode Then
        With .AutoFilter.Filters(1)
            If .On Then c1 = .Criteria1
        End With
    End If
End With


FirstPageNumber-Eigenschaft

Gibt die erste Seitenzahl zurück, die beim Drucken des Blattes verwendet wird, oder legt diese fest. Beim Standardwert xlAutomatic wählt Microsoft Excel die erste Seite. Long Schreib-Lese-Zugriff.


Beispiel zur FirstPageNumber-Eigenschaft

In diesem Beispiel wird für die erste Seite von Sheet1 die Seitenzahl 100 festgelegt.

Worksheets("Sheet1").PageSetup.FirstPageNumber = 100


FirstSliceAngle-Eigenschaft

Gibt für ein Kreis-, 3D-Kreis- oder Ringdiagramm den Winkel des ersten Kreis- oder Ringsegments zurück oder legt diesen fest. Nur für Kreis-, 3D-Kreis- oder Ringdiagramme gültig. Long Schreib-Lese-Zugriff.


Beispiel zur FirstSliceAngle-Eigenschaft

In diesem Beispiel wird der Winkel des ersten Segments der ersten Diagrammgruppe in Chart1 festgelegt. Es ist sinnvoll, das Makro auf ein 2D-Kreisdiagramm anzuwenden.

Charts("Chart1").ChartGroups(1).FirstSliceAngle = 15


FitToPagesTall-Eigenschaft

Gibt die Anzahl der Seiten zurück (oder legt diese fest), auf die das Tabellenblatt während des Druckens in der Höhe skaliert wird. Nur gültig für Tabellenblätter. Variant Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft den Wert False hat, skaliert Microsoft Excel entsprechend der FitToPagesWide-Eigenschaft.

Wenn die Zoom-Eigenschaft den Wert True hat, wird die FitToPagesTall-Eigenschaft ignoriert.


Beispiel zur FitToPagesTall-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken in Breite und Höhe genau auf eine Seite angepasst.

With Worksheets("Sheet1").PageSetup
    .Zoom = False
    .FitToPagesTall = 1
    .FitToPagesWide = 1
End With


FitToPagesWide-Eigenschaft

Gibt die Anzahl der Seiten zurück (oder legt diese fest), auf die das Tabellenblatt während des Druckens in der Breite skaliert wird. Nur gültig für Tabellenblätter. Variant Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft den Wert False hat, skaliert Microsoft Excel entsprechend der FitToPagesTall-Eigenschaft.

Wenn die Zoom-Eigenschaft den Wert True hat, wird die FitToPagesWide-Eigenschaft ignoriert.


Beispiel zur FitToPagesWide-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken in Breite und Höhe genau auf eine Seite angepasst.

With Worksheets("Sheet1").PageSetup
    .Zoom = False
    .FitToPagesTall = 1
    .FitToPagesWide = 1
End With


FixedDecimal-Eigenschaft

Nachdem diese Eigenschaft auf True gesetzt wurde, werden alle eingegebenen Daten mit einer festen Anzahl an Dezimalstellen formatiert, die durch die FixedDecimalPlaces-Eigenschaft gesetzt wurde. Boolean Schreib-Lese-Zugriff.


FixedDecimalPlaces-Eigenschaft

Diese Eigenschaft setzt oder gibt die Anzahl fester Dezimalstellen zurück, die verwendet werden, wenn die FixedDecimal-Eigenschaft auf True gesetzt ist. Long Schreib-Lese-Zugriff.


Beispiel zur FixedDecimalPlaces-Eigenschaft

Dieses Beispiel setzt die FixedDecimal-Eigenschaft auf True und setzt anschließend die FixedDecimalPlaces-Eigenschaft auf 4. Wenn Sie nach der Ausführung dieses Beispiels "30000" eingeben, wird auf dem Tabellenblatt der Wert "3" produziert und nach Eingabe von "12500" wird "1,25" produziert.

Application.FixedDecimal = True
Application.FixedDecimalPlaces = 4


Floor-Eigenschaft

Gibt ein Floor-Objekt zurück, das die Bodenfläche eines 3D-Diagramms darstellt. Schreibgeschützt.

Hilfe zur Verwendung der Floor-Tabellenfunktion in Visual Basic finden Sie unter Verwenden von Tabellenfunktionen in Visual Basic.


Beispiel zur Floor-Eigenschaft

In diesem Beispiel wird die Farbe der Bodenfläche von Chart1 auf Blau festgelegt. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden (die Floor-Eigenschaft erzeugt einen Fehler, wenn Sie auf 2D-Diagramme angewendet wird).

Charts("Chart1").Floor.Interior.ColorIndex = 5


FolderSuffix-Eigenschaft

Gibt das von Microsoft Excel verwendete Ordnersuffix zurück, wenn Sie ein Dokument als Webseite speichern, lange Dateinamen verwenden und die Unterstützungsdateien in einem getrennten Ordner gespeichert werden sollen (d. h., wenn die UseLongFileNames- und OrganizeInFolder-Eigenschaften auf True festgelegt sind). String Schreibgeschützt.

Anmerkungen

Neu erstellte Dokumente verwenden das Suffix, das von der FolderSuffix-Eigenschaft des DefaultWebOptions-Objekts zurückgegeben wird. Der Wert der FolderSuffix-Eigenschaft des WebOptions-Objekts kann sich von dem des DefaultWebOptions-Objekts unterscheiden, falls das Dokument zuvor in einer anderen Sprachversion von Microsoft Excel bearbeitet wurde. Sie können mit Hilfe der UseDefaultFolderSuffix-Methode das Suffix in die Sprache ändern, die aktuell in Microsoft Office 2000 verwendet wird.

Standardmäßig besteht der Name des Unterstützungsordners aus dem Namen der Webseite und einem Unterstrich (_), einem Punkt (.) oder einem Bindestrich (-) sowie dem Wort "files" (das in der Sprache der Version von Excel angezeigt wird, in der die Datei als Webseite gespeichert wurde). Wenn Sie beispielsweise die dänische Sprachversion von Excel verwenden, um eine Datei "Page1" als Webseite zu speichern, lautet der Standardname des Unterstützungsordners Page1_bestanden.

In der folgenden Tabelle sind alle Sprachversionen von Office 2000 aufgeführt sowie der dazugehörige LanguageID-Eigenschaftenwert und das Ordnersuffix. Bei Sprachen, die nicht in der Tabelle aufgeführt sind, wird das Suffix ".files" verwendet.

Sprache | LanguageID | Ordnersuffix
Arabisch | 1025 | .files
Baskisch | 1069 | _fitxategiak
Brasilianisch | 1046 | _arquivos
Bulgarisch | 1026 | .files
Chinesisch - Traditionell | 1028 | .files
Chinesisch - Vereinfacht | 2052 | .files
Dänisch | 1030 | -filer
Deutsch | 1031 | -Dateien
Englisch | 1033 | _files
Estnisch | 1061 | _failid
Finnisch | 1035 | _tiedostot
Französisch | 1036 | _fichiers
Griechisch | 1032 | .files
Hebräisch | 1037 | .files
Italienisch | 1040 | -file
Japanisch | 1041 | .files
Katalanisch | 1027 | _fitxers
Koreanisch | 1042 | .files
Kroatisch | 1050 | _datoteke
Lettisch | 1062 | _fails
Litauisch | 1063 | _bylos
Niederländisch | 1043 | _bestanden
Norwegisch | 1044 | -filer
Polnisch | 1045 | _pliki
Portugiesisch | 2070 | _ficheiros
Rumänisch | 1048 | .files
Russisch | 1049 | .files
Schwedisch | 1053 | -filer
Serbisch (Kyrillisch) | 3098 | .files
Serbisch (Lateinisch) | 2074 | _fajlovi
Slowakisch | 1051 | .files
Slowenisch | 1060 | _datoteke
Spanisch | 3082 | _archivos
Thailändisch | 1054 | .files
Tschechisch | 1029 | _soubory
Türkisch | 1055 | _dosyalar
Ukrainisch | 1058 | .files
Ungarisch | 1038 | _elemei
Vietnamesisch | 1066 | .files


Beispiel zur FolderSuffix-Eigenschaft

In diesem Beispiel wird das Ordnersuffix zurückgegeben, das von der ersten Arbeitsmappe verwendet wird. Das Suffix wird in der Zeichenfolgenvariablen strFolderSuffix zurückgegeben.

strFolderSuffix = Workbooks(1).WebOptions.FolderSuffix


Font-Eigenschaft

Gibt ein Font-Objekt zurück, das die Schriftart des angegebenen Objekts darstellt. Schreibgeschützt.


FontBold-Eigenschaft

True, wenn die Schriftart in der angegebenen WordArt fett ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontBold-Eigenschaft

In diesem Beispiel wird in myDocument die Schriftart der dritten Form fett formatiert, wenn es sich bei der Form um eine WordArt handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


FontItalic-Eigenschaft

True, wenn die Schriftart in der angegebenen WordArt kursiv ist. Long Schreib-Lese-Zugriff.


Beispiel zur FontItalic-Eigenschaft

In diesem Beispiel wird die Schriftart der Form "WordArt4" in myDocument kursiv formatiert.

Set myDocument = Worksheets(1)
myDocument.Shapes("WordArt 4").TextEffect.FontItalic = True


FontName-Eigenschaft

Gibt den Schriftartnamen der angegebenen WordArt zurück oder legt den Namen fest. String Schreib-Lese-Zugriff.


Beispiel zur FontName-Eigenschaft

In diesem Beispiel wird für den Schriftartnamen der dritten Form in myDocument "Courier New" festgelegt, wenn es sich bei der Form um eine WordArt handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontName = "Courier New"
    End If
End With


Fonts-Eigenschaft

Gibt die WebPageFonts-Auflistung zurück, die die Schriftarten darstellt, die Microsoft Excel beim Öffnen einer Webseite in Excel verwendet, sofern keine Schriftartinformationen in der Webseite angegeben wurden, oder wenn die aktuelle Standardschriftart den Zeichensatz in der Webseite nicht anzeigen kann. Schreibgeschützt.


FontSize-Eigenschaft

Gibt den Schriftgrad der angegebenen WordArt in Punkt zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


Beispiel zur FontSize-Eigenschaft

In diesem Beispiel wird für den Schriftgrad der Form "WordArt4" in myDocument 16 Punkt festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes("WordArt 4").TextEffect.FontSize = 16


FontStyle-Eigenschaft

Gibt den Schriftschnitt zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie diese Eigenschaft ändern, können auch andere Font-Eigenschaften (wie Fett und Kursiv) betroffen sein.


Beispiel zur FontStyle-Eigenschaft

In diesem Beispiel wird für Zelle A1 in Sheet1 der Schriftschnitt Fett und Kursiv festgelegt.

Worksheets("Sheet1").Range("A1").Font.FontStyle = "Bold Italic"


 FooterMargin-Eigenschaft

FooterMargin-Eigenschaft

Gibt den Abstand der Fußzeile vom unteren Rand der Seite in Punkt zurück oder legt ihn fest. Double Schreib-Lese-Zugriff.


Beispiel zur FooterMargin-Eigenschaft

In diesem Beispiel wird der Fußzeilenrand von Sheet1 auf 0,5 Zoll gesetzt.

Worksheets("Sheet1").PageSetup.FooterMargin = _
        Application.InchesToPoints(0.5)


ForeColor-Eigenschaft

ChartFillFormat-Objekt: Gibt ein ChartColorFormat-Objekt zurück, das die angegebene Füllfarbe des Hintergrunds darstellt. Schreibgeschützt.

Alle anderen Objekte: Gibt ein ColorFormat-Objekt zurück, das die angegebene Füllfarbe des Hintergrunds oder die Farbfläche darstellt. Schreibgeschützt.


Beispiel zur ForeColor-Eigenschaft

In diesem Beispiel werden für die Füllung des Diagrammbereichs im ersten Diagramm Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

With Charts(1).ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


FormatConditions-Eigenschaft

Gibt eine FormatConditions-Auflistung zurück, die alle bedingten Formate des angegebenen Bereichs darstellt. Schreibgeschützt.

Informationen über den Zugriff auf ein einzelnes Element einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur FormatConditions-Eigenschaft

In diesem Beispiel wird ein bestehendes bedingtes Format für die Zellen E1:E10 geändert.

Worksheets(1).Range("e1:e10").FormatConditions(1) _
    .Modify xlCellValue, xlLess, "=$a$1"


 FormControlType-Eigenschaft

FormControlType-Eigenschaft

Gibt den Typ eines Microsoft Excel-Steuerelementes zurück. Dies kann eine der folgenden XlFormControl-Konstanten sein: xlButtonControl, xlCheckBox, xlDropDown, xlEditBox, xlGroupBox, xlLabel, xlListBox, xlOptionButton, xlScrollBar oder xlSpinner. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft kann bei ActiveX-Steuerelementen nicht verwendet werden (die Type-Eigenschaft des Shape-Objekts muss msoFormControl zurückgeben).


Beispiel zur FormControlType-Eigenschaft

In diesem Beispiel werden alle Microsoft Excel-Kontrollkästchen des ersten Tabellenblattes gelöscht.

For Each s In Worksheets(1).Shapes
    If s.Type = msoFormControl Then
        If s.FormControlType = xlCheckBox Then _
            s.ControlFormat.Value = False
    End If
Next


 Formula-Eigenschaft

Formula-Eigenschaft

Gibt die Formel des Objekts im A1-Bezugssystem entsprechend der Ländereinstellung für die Makrosprache zurück oder legt sie fest. Variant Schreib-Lese-Zugriff für Range-Objekte, String Schreib-Lese-Zugriff für alle anderen Objekte.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.

Enthält die Zelle eine Konstante, so gibt diese Eigenschaft die Konstante zurück. Ist die Zelle leer, so gibt Formula eine leere Zeichenfolge zurück. Enthält die Zelle eine Formel, so gibt Formula die Formel als Zeichenfolge in demselben Format zurück, mit dem sie auch in der Bearbeitungsleiste angezeigt wird (einschließlich des Gleichheitszeichens).

Wenn Sie den Wert oder die Formel einer Zelle in ein Datum umwandeln, überprüft Microsoft Excel, ob die Zelle bereits mit einem Datums- oder Zeitformat formatiert ist. Ist das nicht der Fall, so wird das Zahlenformat in das kurze Standard-Datumsformat geändert.

Ist der Bereich ein- oder zweidimensional, so können Sie die Formel als Visual Basic-Matrix mit denselben Dimensionen angeben. Ebenso können Sie die Formel in eine Visual Basic-Matrix einfügen.

Beim Festlegen der Formel für einen Bereich mit mehreren Zellen wird die Formel in alle Zellen des Bereichs eingetragen.


Formula1-Eigenschaft

Gibt den mit dem bedingten Format oder der Datenüberprüfung verknüpften Wert oder Ausdruck zurück. Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein. String Schreibgeschützt.


Beispiel zur Formula1-Eigenschaft

In diesem Beispiel wird die Formel für das erste bedingte Format der Zellen E1:E10 geändert, wenn in der Formel "weniger als 5" angegeben ist.

With Worksheets(1).Range("e1:e10").FormatConditions(1)
    If .Operator = xlLess And .Formula1 = "5" Then
        .Modify xlCellValue, xlLess, "10"
    End If
End With


Formula2-Eigenschaft

Gibt den mit dem zweiten Teil des bedingten Formats oder Datenüberprüfung verknüpften Wert oder Ausdruck zurück. Wird nur dann verwendet, wenn die Operator-Eigenschaft des bedingten Formats oder der Datenüberprüfung den Wert xlBetween oder xlNotBetween besitzt. Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein. String Schreibgeschützt.


Beispiel zur Formula2-Eigenschaft

In diesem Beispiel wird die Formel für das erste bedingte Format der Zellen "E1:E10" geändert, wenn in der Formel "zwischen 5 und 10" angegeben ist.

With Worksheets(1).Range("e1:e10").FormatConditions(1)
    If .Operator = xlBetween And _
            .Formula1 = "5" And _
            .Formula2 = "10" Then
        .Modify xlCellValue, xlLess, "10"
    End If
End With


FormulaArray-Eigenschaft

Gibt die Matrixformel eines Bereichs zurück oder legt sie fest. Der Rückgabewert (oder der Wert, den Sie der Eigenschaft zuweisen können) ist eine einzelne Formel oder eine Visual Basic-Matrix. Handelt es sich bei dem angegebenen Bereich nicht um eine Matrixformel, so gibt diese Eigenschaft Null zurück. Variant Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie diese Eigenschaft zur Eingabe einer Matrixformel verwenden, müssen Sie die Z1S1-Schreibweise verwenden, nicht die A1-Schreibweise (siehe zweites Beispiel).


Beispiel zur FormulaArray-Eigenschaft

In diesem Beispiel wird die Zahl 3 als Matrixkonstante in die Zellen A1:C5 in Sheet1 eingegeben.

Worksheets("Sheet1").Range("A1:C5").FormulaArray = "=3"

In diesem Beispiel wird die Formel =SUM(Z1S1:Z3S3) in die Zellen E1:E3 in Sheet1 eingegeben.

Worksheets("Sheet1").Range("E1:E3").FormulaArray = _
    "=Sum(R1C1:R3C3)"


FormulaHidden-Eigenschaft

True, falls die Formel ausgeblendet wird, wenn die Arbeitsmappe oder das Tabellenblatt geschützt ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Verwechseln Sie diese Eigenschaft nicht mit der Hidden-Eigenschaft.


Beispiel zur FormulaHidden-Eigenschaft

In diesem Beispiel werden die Formeln in Spalte A in Sheet1 ausgeblendet, wenn das Tabellenblatt geschützt ist.

Worksheets("Sheet1").Columns("A").FormulaHidden = True


FormulaLabel-Eigenschaft

Gibt die Art der Formelbeschriftung für den angegebenen Bereich zurück oder legt sie fest. Dabei kann es sich um ein xlNone-Konstante handeln, wenn der Bereich keine Beschriftungen enthält, oder um eine der folgenden XlFormulaLabel-Konstanten: xlRowLabels, xlColumnLabels oder xlMixedLabel. Variant Schreib-Lese-Zugriff.


Beispiel zur FormulaLabel-Eigenschaft

In diesem Beispiel wird die AcceptLabelsInFormulas-Eigenschaft gesetzt und dann werden die Zellen B1:D1 als Spaltenbeschriftungen bestimmt.

ActiveWorkbook.AcceptLabelsInFormulas = True
Worksheets(1).Range("b1:d1").FormulaLabel = xlColumnLabels


FormulaLocal-Eigenschaft

Gibt die Formel für das Objekt unter Verwendung von A1-Bezügen in der Sprache des Benutzers zurück oder legt einen Wert für sie fest. Variant Schreib-Lese-Zugriff für Range-Objekte, String Schreib-Lese-Zugriff für Series-Objekte.

Anmerkungen

Wenn die Zelle eine Konstante enthält, gibt diese Eigenschaft eine Konstante zurück. Ist die Zelle leer, wird eine leere Zeichenfolge zurückgegeben. Enthält die Zelle eine Formel, wird diese als Zeichenfolge zurückgegeben, und zwar in dem gleichen Format, in dem sie in der Bearbeitungsleiste angezeigt würde (einschließlich Gleichheitszeichen).

Wenn Sie für den Wert oder die Formel ein Datum festlegen, prüft Microsoft Excel, ob die Zelle bereits in einem Datums- oder Zeitformat formatiert ist. Ist dies nicht der Fall, wird das Zahlenformat standardmäßig auf das kurze Datumsformat eingestellt.

Handelt es sich um einen ein- oder zweidimensionalen Bereich, können Sie für die Formel eine Visual Basic-Matrix derselben Dimension festlegen. Außerdem können Sie die Formel in einer Visual Basic-Matrix ablegen.

Beim Festlegen der Formel für einen mehrzelligen Bereich werden alle Zellen des Bereichs mit der Formel ausgefüllt.


Beispiel zur FormulaLocal-Eigenschaft

Angenommen, die Formel =SUMME(A1:A10) in Zelle A11 in Sheet1 wurde mit der deutschen Version von Microsoft Excel erstellt. Wenn Sie diese Arbeitsmappe auf einem Computer öffnen, auf dem die US-amerikanische Version installiert ist, wird nach Ausführung des folgenden Makros die Formel =SUM(A1:A10) in einem Meldungsfeld angezeigt.

MsgBox Worksheets(1).Range(A11).FormulaLocal


FormulaR1C1-Eigenschaft

Gibt die Formel für das Objekt unter Verwendung von Z1S1-Bezügen in der Sprache des Makros zurück oder legt einen Wert für sie fest. Variant Schreib-Lese-Zugriff für Range-Objekte, String Schreib-Lese-Zugriff für Series-Objekte.

Anmerkungen

Wenn die Zelle eine Konstante enthält, gibt diese Eigenschaft eine Konstante zurück. Ist die Zelle leer, wird eine leere Zeichenfolge zurückgegeben. Enthält die Zelle eine Formel, wird diese als Zeichenfolge zurückgegeben, und zwar in dem gleichen Format, in dem sie in der Bearbeitungsleiste angezeigt würde (einschließlich Gleichheitszeichen).

Wenn Sie für den Wert oder die Formel ein Datum festlegen, prüft Microsoft Excel, ob die Zelle bereits in einem Datums- oder Zeitformat formatiert ist. Ist dies nicht der Fall, wird das Zahlenformat standardmäßig auf das kurze Datumsformat eingestellt.

Handelt es sich um einen ein- oder zweidimensionalen Bereich, können Sie für die Formel eine Visual Basic-Matrix derselben Dimension festlegen. Außerdem können Sie die Formel in einer Visual Basic-Matrix ablegen.

Beim Festlegen der Formel für einen mehrzelligen Bereich werden alle Zellen des Bereichs mit der Formel ausgefüllt.


FormulaR1C1Local-Eigenschaft

Gibt die Formel für das Objekt unter Verwendung von Z1S1-Bezügen in der Sprache des Makros zurück oder legt einen Wert für sie fest. Variant Schreib-Lese-Zugriff für Range-Objekte, String Schreib-Lese-Zugriff für Series-Objekte.

Anmerkungen

Wenn die Zelle eine Konstante enthält, gibt diese Eigenschaft eine Konstante zurück. Ist die Zelle leer, wird eine leere Zeichenfolge zurückgegeben. Enthält die Zelle eine Formel, wird diese als Zeichenfolge zurückgegeben, und zwar in dem gleichen Format, in dem sie in der Bearbeitungsleiste angezeigt würde (einschließlich Gleichheitszeichen).

Wenn Sie für den Wert oder die Formel ein Datum festlegen, prüft Microsoft Excel, ob die Zelle bereits in einem Datums- oder Zeitformat formatiert ist. Ist dies nicht der Fall, wird das Zahlenformat standardmäßig auf das kurze Datumsformat eingestellt.

Handelt es sich um einen ein- oder zweidimensionalen Bereich, können Sie für die Formel eine Visual Basic-Matrix derselben Dimension festlegen. Außerdem können Sie die Formel in einer Visual Basic-Matrix ablegen.

Beim Festlegen der Formel für einen mehrzelligen Bereich werden alle Zellen des Bereichs mit der Formel ausgefüllt.


Beispiel zur FormulaR1C1Local-Eigenschaft

Angenommen, die Formel =SUMME(A1:A10) in Zelle A11 in Sheet1 wurde mit der deutschen Version von Microsoft Excel erstellt. Wenn Sie die Arbeitsmappe danach auf einem Computer öffnen, auf dem die US-amerikanische Version installiert ist, wird die Formel =SUM(R(-10)C:R(-1)C) in einem Meldungsfeld angezeigt, wenn Sie das folgende Makro ausführen.

MsgBox Worksheets(1).Range("A11").FormulaR1C1Local


Forward-Eigenschaft

Gibt die Anzahl der Perioden (bzw. Einheiten in einem Punktdiagramm) zurück, um die sich eine Trendlinie vorwärts erstreckt, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Forward-Eigenschaft

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, um die sich die Trendlinie in Chart1 vorwärts und rückwärts erstreckt. Wenden Sie dieses Beispiel auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

With Charts("Chart1").SeriesCollection(1).Trendlines(1)
    .Forward = 5
    .Backward = .5
End With


FreezePanes-Eigenschaft

True, wenn geteilte Fensterausschnitte fixiert sind. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die FreezePanes-Eigenschaft kann den Wert True und gleichzeitig kann die Split-Eigenschaft den Wert False annehmen und umgekehrt.

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.


Beispiel zur FreezePanes-Eigenschaft

In diesem Beispiel werden geteilte Ausschnitte im aktiven Fenster von BOOK1.XLS fixiert.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.FreezePanes = True


FullName-Eigenschaft

Diese Eigenschaft gibt den Namen des Objekts einschließlich Pfadangabe als Zeichenfolge zurück. String Schreibgeschützt.

Anmerkungen

Diese Eigenschaft entspricht der Path-Eigenschaft gefolgt vom aktuellen Dateisystem-Trennzeichen und der Name-Eigenschaft.


Beispiel zur FullName-Eigenschaft

Dieses Beispiel zeigt den Pfad und Dateinamen jedes verfügbaren Add-Ins an.

For Each a In AddIns
    MsgBox a.FullName
Next a

Und dieses Beispiel zeigt Pfad und Dateinamen der aktiven Arbeitsmappe an (vorausgesetzt die Arbeitsmappe wurde gespeichert).

MsgBox ActiveWorkbook.FullName


 Function-Eigenschaft

Function-Eigenschaft

Gibt die für die Aufsummierung des PivotTable-Feldes (nur Datenfelder) verwendete Funktion zurück oder weist ihr einen Wert zu. Zulässig ist eine der folgenden XlConsolidationFunction-Konstanten: xlAverage, xlCount, xlCountNums, xlMax, xlMin, xlProduct, xlStDev, xlStDevP, xlSum, xlUnknown, xlVar oder xlVarP. Long Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist diese Eigenschaft schreibgeschützt und gibt immer xlUnknown zurück. Bei anderen Datenquellen kann diese Eigenschaft nicht auf xlUnknown eingestellt werden.


Beispiel zur Function-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Funktion SUM für das Feld "Sum of 1997" im ersten PivotTable-Bericht des aktiven Tabellenblatts verwendet wird.

ActiveSheet.PivotTables("PivotTable1") _
    .PivotFields("Sum of 1994").Function = xlSum


Gap-Eigenschaft

Gibt den horizontalen Abstand (in Punkt) zwischen dem Ende der Legendenlinie und dem Textbegrenzungsrechteck zurück oder legt ihn fest. Single Schreib-Lese-Zugriff.


GapDepth-Eigenschaft

Gibt den Zwischenraum zwischen den Datenreihen in einem 3D-Diagramm als Prozentwert der Markierungsbreite (zwischen 0 und 500) zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.


Beispiel zur GapDepth-Eigenschaft

In diesem Beispiel wird der Abstand zwischen den Datenreihen in Chart1 auf 200 Prozent der Markierungsbreite festgelegt. Es ist sinnvoll, das Beispiel auf ein 3D-Diagramm anzuwenden (die GapDepth-Eigenschaft erzeugt einen Fehler, wenn sie auf 2D-Diagramme angewendet wird).

Charts("Chart1").GapDepth = 200


GapWidth-Eigenschaft

Balken- und Säulendiagramme: Gibt den Abstand zwischen Balken- oder Säulengruppen als Prozentsatz der Balken- oder Säulenbreite zurück oder legt den Abstand fest. Der Wert dieser Eigenschaft muss zwischen 0 und 500 liegen. Long Schreib-Lese-Zugriff.

Kreise von Kreisdiagrammen und Balken von Kreisdiagrammen: Gibt den Abstand zwischen den primären und sekundären Abschnitten des Diagramms zurück bzw. legt ihn fest. Der Wert dieser Eigenschaft muss zwischen 5 und 200 liegen. Long Schreib-Lese-Zugriff.


Beispiel zur GapWidth-Eigenschaft

In diesem Beispiel wird der Abstand zwischen den Säulengruppen in Chart1 auf 50 Prozent der Säulenbreite festgelegt.

Charts("Chart1").ChartGroups(1).GapWidth = 50


GradientColorType-Eigenschaft

Gibt den Farbverlaufstyp der angegebenen Füllfarbe zurück. Dies kann eine der folgenden MsoGradientColorType-Konstanten sein: msoGradientColorMixed, msoGradientOneColor, msoGradientPresetColors oder msoGradientTwoColors. Long Schreibgeschützt.


Beispiel zur GradientColorType-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient And _
        c1f.GradientColorType = msoGradientOneColor Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .OneColorGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.GradientDegree
    End With
End If


GradientDegree-Eigenschaft

Gibt den Verlaufsgrad der angegebenen einfarbigen schattierten Füllung als Gleitkommawert zwischen 0,0 (dunkel) und 1,0 (hell) zurück. Single Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die OneColorGradient-Methode, um den Verlaufsgrad der Füllung festzulegen.


Beispiel zur GradientDegree-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient And _
        c1f.GradientColorType = msoGradientOneColor Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .OneColorGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.GradientDegree
    End With
End If


GradientStyle-Eigenschaft

Gibt die Verlaufsart der angegebenen Füllung zurück. Dies kann eine der folgenden MsoGradientStyle-Konstanten sein: msoGradientDiagonalDown, msoGradientDiagonalUp, msoGradientFromCenter, msoGradientFromCorner, msoGradientFromTitle, msoGradientHorizontal, msoGradientMixed oder msoGradientVertical. Die msoGradientFromTitle-Konstante wird in Microsoft Excel nicht verwendet. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die Methoden OneColorGradient oder TwoColorGradient, um die Verlaufsart der Füllung festzulegen.


Beispiel zur GradientStyle-Eigenschaft

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient And _
        c1f.GradientColorType = msoGradientOneColor Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .OneColorGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.GradientDegree
    End With
End If


GradientVariant-Eigenschaft

Gibt die Schattierungsvariante der angegebenen Füllung als Ganzzahl zwischen 1 und 4 zurück. Die Werte dieser Eigenschaft entsprechen den Verlaufsvarianten (Nummerierung von links nach rechts und von oben nach unten) in der Registerkarte Graduell des Dialogfelds Fülleffekte. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die Methoden OneColorGradient oder TwoColorGradient, um die Verlaufsvariante der Füllung festzulegen.


Beispiel zur GradientVariant-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient And _
        c1f.GradientColorType = msoGradientOneColor Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .OneColorGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.GradientDegree
    End With
End If


GrandTotalName-Eigenschaft

Gibt die Beschriftung, die im Spaltengesamtergebnis oder in der Zeilenüberschrift im angegebenen PivotTable-Bericht angezeigt wird, als Textzeichenfolge zurück oder legt diese fest. Der Standardwert ist die Zeichenfolge "Gesamtsumme". String Schreib-Lese-Zugriff.


Beispiel zur GrandTotalName-Eigenschaft

In diesem Beispiel wird die Überschrift für die Gesamtsumme im zweiten PivotTable-Bericht des aktiven Tabellenblatts auf "Regional Total" festgelegt.

ActiveSheet.PivotTables("PivotTable2").GrandTotalName = "Regional Total"


GridlineColor-Eigenschaft

Gibt die Farbe der Gitternetzlinien als einen RGB-Wert zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


GridlineColorIndex-Eigenschaft

Gibt die Farbe der Gitternetzlinien als Indexwert oder als XlColorIndex-Konstanten zurück oder legt diese fest. Es stehen die Konstanten xlColorIndexAutomatic oder xlColorIndexNone zur Verfügung. Variant Schreib-Lese-Zugriff.

Anmerkungen

Weisen Sie dieser Eigenschaft xlColorIndexAutomatic zu, um die Farbe Automatisch zu verwenden.

Die folgende Abbildung zeigt die Farbindexwerte der Standard-Farbpalette.

Farbindexwerte der Standard-Farbpalette


Beispiel zur GridlineColorIndex-Eigenschaft

In diesem Beispiel wird den Gitternetzlinien im aktiven Fenster die Farbe Blau zugewiesen.

ActiveWindow.GridlineColorIndex = 5


GroupItems-Eigenschaft

Gibt ein GroupShapes-Objekt zurück, das die einzelnen Formen der angegebenen Gruppe darstellt. Verwenden Sie die Item-Methode des GroupShapes-Objekts, um eine einzelne Form der Gruppe zurückzugeben. Betrifft Shape- oder ShapeRange-Objekte, die gruppierte Formen darstellen. Schreibgeschützt.


Beispiel zur GroupItems-Eigenschaft

In diesem Beispiel werden in meinDocument drei Dreiecke eingefügt und gruppiert. Für die gesamte Gruppe wird eine Farbe festgelegt und anschließend nur die Farbe des zweiten Rechtecks geändert.

Set meinDocument = Worksheets(1)
With meinDocument.Shapes
    .AddShape(msoShapeIsoscelesTriangle, _
        10, 10, 100, 100).Name = "shpOne"
    .AddShape(msoShapeIsoscelesTriangle, _
        150, 10, 100, 100).Name = "shpTwo"
    .AddShape(msoShapeIsoscelesTriangle, _
        300, 10, 100, 100).Name = "shpThree"
    With .Range(Array("shpOne", "shpTwo", "shpThree")).Group
        .Fill.PresetTextured msoTextureBlueTissuePaper
        .GroupItems(2).Fill.PresetTextured msoTextureGreenMarble
    End With
End With


 GroupLevel-Eigenschaft

GroupLevel-Eigenschaft

Gibt die Position des angegebenen Feldes innerhalb einer Gruppe von Feldern zurück (wenn das Feld zu einer aus Feldern bestehenden Gruppe gehört). Schreibgeschützt.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.

Das höchste übergeordnete Feld (das am weitesten links liegende übergeordnete Feld) liegt auf Ebene 1, das untergeordnete Feld auf Ebene zwei usw.


Beispiel zur GroupLevel-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn das aktive Feld das höchste übergeordnete Feld ist.

Worksheets("Sheet1").Activate
If ActiveCell.PivotField.GroupLevel = 1 Then
    MsgBox "This is the highest-level parent field."
End If


Has3DEffect-Eigenschaft

True, wenn die Datenreihen ein dreidimensionales Aussehen haben. Bezieht sich nur auf Blasen-Diagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur Has3DEffect-Eigenschaft

In diesem Beispiel werden Datenreihen in einem eingebetteten Blasen-Diagramm mit einem dreidimensionalen Aussehen versehen.

With Worksheets(1).ChartObjects(1).Chart
    .SeriesCollection(1).Has3DEffect = True
End With


HasAutoFormat-Eigenschaft

True, wenn der PivotTable-Bericht nach dem Neuberechnen oder Verschieben von Feldern automatisch formatiert wird. Boolean Lese- und Schreibzugriff.


Beispiel zur HasAutoFormat-Eigenschaft

In diesem Beispiel wird der PivotTable-Bericht nach dem Aktualisieren oder dem Verschieben von Feldern automatisch neu formatiert.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.HasAutoFormat = True


Has3DShading-Eigenschaft

True, falls die Diagrammgruppe eine 3D-Schattierung besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur Has3DShading-Eigenschaft

In diesem Beispiel wird der ersten Diagrammgruppe im ersten Diagramm eine 3D-Schattierung hinzugefügt.

Charts(1).ChartGroups(1).Has3DShading = True


HasArray-Eigenschaft

True, wenn die angegebene Zelle Teil einer Matrixformel ist. Variant Schreibgeschützt.


Beispiel zur HasArray-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn die aktive Zelle in Sheet1 Teil einer Matrixformel ist.

Worksheets("Sheet1").Activate
If ActiveCell.HasArray =True Then
    MsgBox "The active cell is part of an array"
End If


HasAxis-Eigenschaft

Gibt zurück oder legt fest, welche Achsen im Diagramm vorhanden sind. Variant Schreib-Lese-Zugriff.

Syntax

Ausdruck.HasAxis(Index1, Index2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Chart-Objekt zurückgibt.

Index1 Variant optional. Der Achsentyp. Dies kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlValue oder xlSeriesAxis. Reihenachsen gelten nur für 3D-Diagramme.

Index2 Variant optional. Die Achsengruppe. Kann eine der beiden folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. 3D-Diagramme besitzen nur eine Achsengruppe.

Anmerkungen

Es kann vorkommen, dass Microsoft Excel Achsen erstellt oder löscht, wenn Sie den Diagrammtyp oder die AxisGroup-Eigenschaft ändern.


Beispiel zur HasAxis-Eigenschaft

In diesem Beispiel wird in Chart1 die primäre Größenachse eingeschaltet.

Charts("Chart1").HasAxis(xlValue, xlPrimary) = True


HasBorderHorizontal-Eigenschaft

True, wenn die Diagrammdatentabelle horizontale Zellrahmenlinien besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderHorizontal-Eigenschaft

In diesem Beispiel wird festgelegt, dass die eingebettete Diagrammdatentabelle mit einem Gesamtrahmen, jedoch ohne Zellrahmen, angezeigt wird.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasBorderOutline-Eigenschaft

True, wenn die Diagrammdatentabelle Gesamtrahmenlinien besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderOutline-Eigenschaft

In diesem Beispiel wird festgelegt, dass die eingebettete Diagrammdatentabelle mit einem Gesamtrahmen, jedoch ohne Zellrahmen, angezeigt wird.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasBorderVertical-Eigenschaft

True, wenn die Diagrammdatentabelle vertikale Zellrahmenlinien besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasBorderVertical-Eigenschaft

In diesem Beispiel wird festgelegt, dass die eingebettete Diagrammdatentabelle mit einem Gesamtrahmen, jedoch ohne Zellrahmen, angezeigt wird.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasDataLabel-Eigenschaft

True, wenn der Datenpunkt eine Datenbeschriftung enthält. Boolean Schreib-Lese-Zugriff.


HasDataLabels-Eigenschaft

True, wenn die Datenreihe Datenbeschriftungen hat. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDataLabels-Eigenschaft

In diesem Beispiel werden Datenbeschriftungen für die dritte Reihe in Chart1 eingeblendet.

With Charts("Chart1").SeriesCollection(3)
    .HasDataLabels = True
    .ApplyDataLabels Type:=xlValue
End With


HasDataTable-Eigenschaft

True, wenn das Diagramm eine Datentabelle besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDataTable-Eigenschaft

In diesem Beispiel wird festgelegt, dass die eingebettete Diagrammdatentabelle mit einem Gesamtrahmen, jedoch ohne Zellrahmen, angezeigt wird.

With Worksheets(1).ChartObjects(1).Chart
    .HasDataTable = True
    With .DataTable
        .HasBorderHorizontal = False
        .HasBorderVertical = False
        .HasBorderOutline = True
    End With
End With


HasDisplayUnitLabel-Eigenschaft

True, wenn die durch die DisplayUnit- oder die DisplayUnitCustom-Eigenschaft angegebene Beschriftung an der angegebenen Achse angezeigt wird. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDisplayUnitLabel-Eigenschaft

In diesem Beispiel werden die in Chart1 auf der Größenachse angezeigten Einheiten auf die Schrittweite 500 festgelegt; die Einheitenbeschriftung bleibt jedoch ausgeblendet.

With Charts("Chart1").Axes(xlValue)
    .DisplayUnit = xlCustom
    .DisplayUnitCustom = 500
    .AxisTitle.Caption = "Rebate Amounts"
    .HasDisplayUnitLabel = False
End With


HasDropLines-Eigenschaft

True, wenn im Linien- oder Flächendiagramm Bezugslinien angezeigt werden. Nur gültig für Linien- oder Flächendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasDropLines-Eigenschaft

In diesem Beispiel werden die Bezugslinien der ersten Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, das Beispiel auf ein 2D-Liniendiagramm anzuwenden, das eine Datenreihe beinhaltet.

With Charts("Chart1").ChartGroups(1)
    .HasDropLines = True
    With .DropLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasErrorBars-Eigenschaft

True, wenn die Datenreihe Fehlerindikatoren enthält. Diese Eigenschaft ist in 3D-Diagrammen nicht verfügbar. Boolean Lese- und Schreibzugriff.


Beispiel zur HasErrorBars-Eigenschaft

In diesem Beispiel werden die Fehlerindikatoren für die erste Datenreihe in Chart1 entfernt. Wenden Sie das Beispiel auf ein 2D-Liniendiagramm mit Fehlerindikatoren für die erste Datenreihe an.

Charts("Chart1").SeriesCollection(1).HasErrorBars = False


HasFormula-Eigenschaft

True, wenn alle Zellen im Bereich Formeln enthalten. False, wenn keine Zelle im Bereich eine Formel enthält. Ansonsten hat die Eigenschaft den Wert Null. Variant Schreibgeschützt.


Beispiel zur HasFormula-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, einen Bereich in Sheet1 auszuwählen. Wenn alle Zellen in diesem Bereich eine Formel enthalten, wird eine Meldung angezeigt.

Worksheets("Sheet1").Activate
Set rr = Application.InputBox( _
    prompt:="Select a range on this worksheet", _
    Type:=8)
If rr.HasFormula = True Then
    MsgBox "Every cell in the selection contains a formula"
End If


HasHiLoLines-Eigenschaft

True, wenn das Liniendiagramm Spannweitenlinien enthält. Nur gültig für Liniendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasHiLoLines-Eigenschaft

In diesem Beispiel werden Spannweitenlinien für die erste Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, das Makro auf ein 2D-Liniendiagramm anzuwenden, das eine Datenreihe mit Börsennotizen (Höchstkurs, Tiefstkurs, Schlusskurs) oder Ähnlichem beinhaltet.

With Charts("Chart1").ChartGroups(1)
    .HasHiLoLines = True
    With .HiLoLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasLeaderLines-Eigenschaft

True, wenn die Datenreihe Führungslinien besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasLeaderLines-Eigenschaft

In diesem Beispiel werden der ersten Datenreihe des Kreisdiagramms Datenbeschriftungen und blaue Führungslinien hinzugefügt.

With Worksheets(1).ChartObjects(1).Chart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


HasLegend-Eigenschaft

True, wenn das Diagramm eine Legende besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasLegend-Eigenschaft

In diesem Beispiel wird die Legende von Chart1 aktiviert. Anschließend wird dieser Legende die Farbe Blau zugewiesen.

With Charts("Chart1")
    .HasLegend = True
    .Legend.Font.ColorIndex = 5
End With


HasMajorGridlines-Eigenschaft

True, wenn die Achse über Hauptgitternetzlinien verfügt. Nur Achsen in der Primärachsengruppe können Gitternetzlinien besitzen. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasMajorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hauptgitternetzlinien für die Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 3    ' set color to red
    End If
End With


HasMinorGridlines-Eigenschaft

True, wenn die Achse über Hilfsgitternetzlinien verfügt. Nur Achsen in der Primärachsengruppe können Gitternetzlinien besitzen. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasMinorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hilfsgitternetzlinien der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    If .HasMinorGridlines Then
        .MinorGridlines.Border.ColorIndex = 4
            ' set color to green
    End If
End With


HasPassword-Eigenschaft

True, wenn die Arbeitsmappe ein Schutzkennwort besitzt. Boolean Schreibgeschützt.

Anmerkungen

Sie können einer Arbeitsmappe mit Hilfe der SaveAs-Methode ein Schutzkennwort zuweisen.


Beispiel zur HasPassword-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, falls die aktive Arbeitsmappe durch ein Kennwort geschützt ist.

If ActiveWorkbook.HasPassword = True Then
    MsgBox "Remember to obtain the workbook password" & Chr(13) & _
        " from the Network Administrator."
End If


HasPivotFields-Eigenschaft

True, wenn die PivotChart-Steuerelemente in dem angegebenen PivotChart-Bericht angezeigt werden. Der Standardwert ist True. Bei einem Standarddiagramm gibt diese Eigenschaft immer False zurück, und diese kann nicht eingestellt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasPivotFields-Eigenschaft

In diesem Beispiel werden die PivotChart-Steuerelemente im Diagramm "Sales" der Arbeitsmappe "1996 Report" deaktiviert.

Workbooks("1996 Report").Charts("Sales") _
    .PivotLayout.HasPivotFields = False


HasRadarAxisLabels-Eigenschaft

True, wenn ein Netzdiagramm Achsenbeschriftungen enthält. Nur gültig für Netzdiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasRadarAxisLabels-Eigenschaft

In diesem Beispiel werden Netzachsenbeschriftungen für die erste Diagrammgruppe in Chart1 eingeblendet und die zugehörige Farbe festgelegt. Es ist sinnvoll, das Makro auf ein Netzdiagramm anzuwenden.

With Charts("Chart1").ChartGroups(1)
    .HasRadarAxisLabels = True
    .RadarAxisLabels.Font.ColorIndex = 3
End With


HasRoutingSlip-Eigenschaft

True, wenn die Arbeitsmappe einen Verteiler besitzt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird für diese Eigenschaft der Wert True festgelegt, so wird ein neuer Verteiler mit Standardeinstellungen erstellt. Wird der Wert hingegen auf False gesetzt, so wird der Verteiler gelöscht.


Beispiel zur HasRoutingSlip-Eigenschaft

In diesem Beispiel wird ein Verteiler für MAPPE1.XLS erstellt und die Arbeitsmappe den drei Empfängern nacheinander übermittelt.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
End With
Workbooks("BOOK1.XLS").Route


HasSeriesLines-Eigenschaft

True, wenn ein gestapeltes Säulendiagramm oder ein Balkendiagramm Verbindungslinien haben oder wenn ein Kreis aus Kreis-Diagramm oder ein Balken aus Kreis-Diagramm Verbindungslinien zwischen den beiden Abschnitten hat. Diese Eigenschaft kann nur auf gestapelte Säulendiagramme, Balkendiagramme, Kreis aus Kreis-Diagramme und Balken aus Kreis-Diagramme angewendet werden. Boolean Lese- und Schreibzugriff.


Beispiel zur HasSeriesLines-Eigenschaft

In diesem Beispiel werden Verbindungslinien für die erste Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, das Beispiel auf ein gestapeltes 2D-Säulendiagramm mit mindestens zwei Datenreihen anzuwenden.

With Charts("Chart1").ChartGroups(1)
    .HasSeriesLines = True
    With .SeriesLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HasTitle-Eigenschaft

True, wenn die Achse eine sichtbare Beschriftung oder das Diagrammblatt einen sichtbaren Titel aufweist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Eine Achsenbeschriftung ist ein AxisTitle-Objekt.

Ein Diagrammtitel ist ein ChartTitle-Objekt.


Beispiel zur HasTitle-Eigenschaft

In diesem Beispiel wird die Rubrikenachse in Chart1 mit einer Beschriftung versehen.

With Charts("Chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "July Sales"
End With


HasUpDownBars-Eigenschaft

True, wenn ein Liniendiagramm positive und negative Abweichungsbalken anzeigt. Nur gültig für Liniendiagramme. Boolean Schreib-Lese-Zugriff.


Beispiel zur HasUpDownBars-Eigenschaft

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe in Chart1 eingeblendet und die zugehörige Farbe festgelegt. Es ist sinnvoll, dieses Beispiel auf ein 2D-Liniendiagramm anzuwenden, das zwei Datenreihen beinhaltet, die sich in mindestens einem Datenpunkt schneiden.

With Charts("Chart1").ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


 HeaderMargin-Eigenschaft

HeaderMargin-Eigenschaft

Gibt den Abstand der Kopfzeile vom oberen Rand der Seite in Punkt zurück oder legt ihn fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Ränder werden in Punkt festgelegt oder zurückgegeben. Mit der InchesToPoints- und der CentimetersToPoints-Methode können Sie die Maßeinheit in Zoll oder Zentimeter umwandeln.


Beispiel zur HeaderMargin-Eigenschaft

In diesem Beispiel wird der Kopfzeilenrand von Sheet1 auf 0,5 Zoll gesetzt.

Worksheets("Sheet1").PageSetup.HeaderMargin = _
        Application.InchesToPoints(0.5)


 Height-Eigenschaft

Height-Eigenschaft

Gibt die Höhe eines Objekts gemessen in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff mit Ausnahmen entsprechend der folgenden Tabelle.

Anmerkungen

Die Bedeutung der Eigenschaft Height hängt vom angegebenen Objekt ab.

Objekttyp | Höhe
Application | Die Höhe des Haupt-Anwendungsfensters. Wenn das Fenster zum Symbol minimiert wurde, ist diese Eigenschaft schreibgeschützt und gibt die Höhe des Symbols an. Ist das Fenster maximiert, kann diese Eigenschaft nicht gesetzt werden. Den Zustand des Fensters können Sie mit der WindowState-Eigenschaft ermitteln.
Axis, LegendEntry, LegendKey | Die Höhe des Objekts. Schreibgeschützt.
Range | Die Höhe des Bereichs. Schreibgeschützt.
Window | Die Höhe des Fensters. Mit der UsableHeight-Eigenschaft bestimmen Sie die maximale Größe des Fensters. Sie können diese Eigenschaft nicht festlegen, wenn das Fenster maximiert oder zum Symbol minimiert ist. Mit der WindowState-Eigenschaft bestimmen Sie den Zustand des Fensters.
ChartArea, ChartObject, Legend, OLEObject, PlotArea, Shape, ShapeRange | Die Höhe des Objekts. Bei ChartArea Schreibgeschützt.


HeightPercent-Eigenschaft

Gibt die Höhe eines 3D-Diagramms als Prozentsatz der Breite des Diagramms zurück (zwischen 5 und 500 Prozent) bzw. legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur HeightPercent-Eigenschaft

In diesem Beispiel wird die Höhe von Chart1 auf 80% der Breite festgelegt. Das Beispiel sollte auf ein 3D-Diagramm angewandt werden.

Charts("Chart1").HeightPercent = 80


 Hidden-Eigenschaft

Hidden-Eigenschaft

Das Range-Objekt: True, wenn die Zeilen oder Spalten ausgeblendet sind. Der angegebene Bereich muss eine ganze Zeile oder Spalte umfassen. Variant Schreib-Lese-Zugriff.

Das Scenario-Objekt: True, wenn das Szenario ausgeblendet ist. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

TreeviewControl-Objekt: Gibt den Ausblendstatus der Cube-Feldmitglieder in dem Steuerelement für die hierarchische Mitgliederauswahl eines Cube-Felds zurück oder legt diesen fest. Diese Eigenschaft wird hauptsächlich zur Makroaufzeichnung verwendet und ist nicht für einen anderweitigen Einsatz gedacht. Schreib-Lese-Zugriff.

Anmerkungen

Verwechseln Sie diese Eigenschaft nicht mit der FormulaHidden-Eigenschaft.

TreeviewControl-Objekt: Die Hidden-Eigenschaft gibt eine Matrix zurück oder legt diese fest. Jedes Element der Matrix entspricht einer Ebene des ausgeblendeten Cube-Feldes. Die maximale Anzahl der Elemente entspricht der Anzahl der Ebenen im Cube-Feld. Jedes Element der Matrix ist eine Matrix vom Typ String, das die eindeutigen Mitgliedernamen enthält, die auf der entsprechenden Ebene des Steuerelements ausgeblendet sind. Sie können mit der Drilled-Eigenschaft des TreeviewControl-Objekts feststellen, ob Mitglieder im Steuerelement sichtbar (eingeblendet) sind.


 HiddenFields-Eigenschaft

HiddenFields-Eigenschaft

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Feld (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller Felder (ein PivotFields-Objekt, Syntax 2) darstellt, die derzeit nicht als Zeilen-, Spalten- oder Datenfeld angezeigt werden. Schreibgeschützt.

Syntax 1

Ausdruck.HiddenFields(Index)

Syntax 2

Ausdruck.HiddenFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Feldes (kann eine Matrix zur Angabe mehrerer Felder sein).

Anmerkungen

Bei OLAP-Datenquellen gibt diese Eigenschaft immer eine leere Auflistung zurück.


Beispiel zur HiddenFields-Eigenschaft

In diesem Beispiel werden die Namen der ausgeblendeten Felder in eine Liste auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.HiddenFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


 HiddenItems-Eigenschaft

HiddenItems-Eigenschaft

Gibt ein Objekt zurück, das ein ausgeblendetes PivotTable-Element (ein PivotItem-Objekt, Syntax 1) oder eine Auflistung aller ausgeblendeten Elemente (ein PivotItems-Objekt, Syntax 2) des angegebenen Feldes darstellt. Schreibgeschützt.

Syntax 1

Ausdruck.HiddenItems(Index)

Syntax 2

Ausdruck.HiddenItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Elements (kann eine Matrix zur Angabe mehrerer Elemente sein).

Anmerkungen

Bei OLAP-Datenquellen gibt diese Eigenschaft immer eine leere Auflistung zurück.


Beispiel zur HiddenItems-Eigenschaft

In diesem Beispiel werden die Namen aller ausgeblendeten Elemente im Feld "PRODUKT" in eine Liste auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtItem In pvtTable.PivotFields("product").HiddenItems
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtItem.Name
Next pvtItem


 HiddenLevels-Eigenschaft

HiddenLevels-Eigenschaft

Gibt die oberste Ebene der angegebenen Hierarchie, die ausgeblendet sind, zurück oder legt diese fest. Der Standardwert ist 0 (Null), d. h., es werden keine Ebenen ausgeblendet. Integer Schreib-Lese-Zugriff.

Anmerkungen

Um den Wert dieser Eigenschaft auf eine ganze Zahl größer 0 festzulegen, müssen Sie den Wert zunächst auf 0 festlegen.


Beispiel zur HiddenLevels-Eigenschaft

In diesem Beispiel werden die beiden obersten Ebenen der Hierarchie im zweiten Cube-Feld im ersten PivotTable-Bericht des aktiven Tabellenblatts ausgeblendet.

ActiveSheet.PivotTables(1).CubeFields(2).HiddenLevels = 2


HighlightChangesOnScreen-Eigenschaft

True, falls Änderungen an der gemeinsam genutzten Arbeitsmappe auf dem Bildschirm hervorgehoben werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur HighlightChangesOnScreen-Eigenschaft

In diesem Beispiel werden Änderungen an der gemeinsam genutzten Arbeitsmappe hervorgehoben.

ThisWorkbook.HighlightChangesOnScreen


HiLoLines-Eigenschaft

Gibt ein HiLoLines-Objekt zurück, das Spannweitenlinien für eine Datenreihe eines Liniendiagramms darstellt. Nur gültig für Liniendiagramme. Schreibgeschützt.


Beispiel zur HiLoLines-Eigenschaft

In diesem Beispiel werden Spannweitenlinien für die erste Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, Stärke und die Farbe festgelegt. Es ist sinnvoll, das Beispiel auf ein 2D-Liniendiagramm anzuwenden, das drei Datenreihen mit Börsennotizen (Höchstkurs, Tiefstkurs, Schlusskurs) oder Ähnlichem beinhaltet.

With Charts("Chart1").ChartGroups(1)
    .HasHiLoLines = True
    With .HiLoLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


HorizontalAlignment-Eigenschaft

Gibt die horizontale Ausrichtung für das angegebene Objekt zurück oder legt sie fest. Zulässig für alle Objekte ist eine der folgenden XlHAlign-Konstanten: xlHAlignCenter, xlHAlignDistributed, xlHAlignJustify, xlHAlignLeft oder xlHAlignRight. Für das Range- oder Style-Objekt kann diese Eigenschaft auch auf xlHAlignCenterAcrossSelection, xlHAlignFill oder xlHAlignGeneral gesetzt werden. Variant Schreib-Lese-Zugriff.

Anmerkungen

Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur HorizontalAlignment-Eigenschaft

In diesem Beispiel wird der Bereich "A1:A5" in Sheet1 linksbündig ausgerichtet.

Worksheets("Sheet1").Range("A1:A5").HorizontalAlignment = xlLeft


HorizontalFlip-Eigenschaft

True, wenn die angegebene Form um die horizontale Achse gekippt wurde. Long Schreibgeschützt.


Beispiel zur HorizontalFlip-Eigenschaft

In diesem Beispiel wird jede Form in myDocument, die horizontal oder vertikal gekippt wurde, wieder in ihren ursprünglichen Zustand versetzt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


HPageBreaks-Eigenschaft

Gibt eine HPageBreaks-Auflistung zurück, die die horizontalen Seitenwechsel des Blatts darstellt. Schreibgeschützt.

Informationen über den Zugriff auf ein einzelnes Element einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur HPageBreaks-Eigenschaft

In diesem Beispiel wird die Anzahl der horizontalen Seitenwechsel des ganzen Bildschirms und des Druckbereichs angezeigt.

For Each pb in Worksheets(1).HPageBreaks
    If pb.Extent = xlPageBreakFull Then
        cFull = cFull + 1
    Else
        cPartial = cPartial + 1
    End If
Next
MsgBox cFull & " full-screen page breaks, " & cPartial & _
    " print-area page breaks"


HTMLProject-Eigenschaft

Gibt das HTMLProject-Objekt in der angegebenen Arbeitsmappe zurück, das einen Projektzweig auf der obersten Ebene wie im Projekt-Explorer im Microsoft Skript-Editor zurückgibt. Schreibgeschützt.


Beispiel zur HTMLProject-Eigenschaft

In diesem Beispiel wird das HTML-Projekt in der aktiven Arbeitsmappe aktualisiert.

ActiveWorkbook.HTMLProject.RefreshProject


HtmlType-Eigenschaft

Gibt den Typ des HTML-Codes, der von Microsoft Excel beim Speichern des angegebenen Elements in einer Webseite erzeugt wird, zurück oder legt diesen fest. Kann eine der in der folgenden Tabelle aufgeführten XlHtmlType-Konstanten sein, die angeben, ob sich das Element in der Webseite statisch oder interaktiv verhält. Der Standardwert ist xlHtmlStatic. XlHtmlType Schreib-Lese-Zugriff.

Konstante | Beschreibung
xlHtmlStatic | Für die Anzeige wird lediglich statischer (nicht-interaktiver) HTML-Code verwendet.
xlHtmlCalc | Die Tabellenblattkomponente wird verwendet.
xlHtmlList | Die PivotTable-Komponente wird verwendet.
xlHtmlChart | Die Diagrammkomponente wird verwendet.


Beispiel zur HtmlType-Eigenschaft

In diesem Beispiel wird der Bereich "D5:D9" im Tabellenblatt "First Quarter" in der aktiven Arbeitsmappe in einer Webseite mit der Bezeichnung stockreport.htm gespeichert. Die Tabellenkomponente wird verwendet, um die Webseite mit einer Interaktivität zu erweitern.

ActiveWorkbook.PublishObjects.Add( _
    SourceType:=xlSourceRange, _
    Filename:="\\Server2\Q1\stockreport.htm", _
    Sheet:="First Quarter", _
    Source:="D5:D9", _
    HtmlType:=xlHTMLCalc).Publish


Hyperlink-Eigenschaft

Gibt ein Hyperlink-Objekt zurück, das den Hyperlink der Form darstellt.


Hyperlinks-Eigenschaft

Gibt eine Hyperlinks-Auflistung zurück, die die Hyperlinks des Bereichs oder des Tabellenblattes darstellt.

Weitere Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Hyperlinks-Eigenschaft

In diesem Beispiel wird überprüft, ob Hyperlinks des ersten Tabellenblattes das Wort "Microsoft" enthalten.

For Each h in Worksheets(1).Hyperlinks
    If Instr(h.Name, "Microsoft") <> 0 Then h.Follow
Next


ID-Eigenschaft

Gibt die identifizierende Bezeichnung der angegebenen Zelle zurück oder legt diese fest, wenn die Seite als Webseite gespeichert wird. String Schreib-Lese-Zugriff.

Anmerkungen

Sie können eine Beschriftung in anderen HTML-Dokumenten oder auf derselben Webseite als Hyperlinkverweis verwenden.


Beispiel zur ID-Eigenschaft

In diesem Beispiel wird die ID der Zelle "A1" im aktiven Tabellenblatt auf "target" festgelegt.

ActiveSheet.Range("A1").ID = "target"

Das Dokument wird dann als Webseite gespeichert und die folgende HTML-Zeile zu der Webseite hinzugefügt.

<A HREF="#target">Quarterly earnings</A>

Wenn der Benutzer die Seite anschließend in einem Webbrowser anzeigt und auf den Hyperlink klickt, zeigt der Browser die Zelle an.


IgnoreBlank-Eigenschaft

True, wenn leere Werte durch die Validierung des Bereichs erlaubt sind. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn die IgnoreBlank-Eigenschaft auf True gesetzt ist, werden Zellendaten als gültig betrachtet, wenn die Zelle leer ist, oder wenn eine Zelle leer ist, auf die entweder mit der MinVal- oder MaxVal-Eigenschaft Bezug genommen wird.


Beispiel zur IgnoreBlank-Eigenschaft

In diesem Beispiel wird die Validierung für Zelle E5 veranlasst, leere Werte zuzulassen.

Range("e5").Validation.IgnoreBlank = True


IgnoreRemoteRequests-Eigenschaft

True, wenn DDE-Fernabfragen ignoriert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur IgnoreRemoteRequests-Eigenschaft

Dieses Beispiel stellt die IgnoreRemoteRequests -Eigenschaft auf True, so dass DDE-Fernabfragen ignoriert werden.

Application.IgnoreRemoteRequests = True


IMEMode-Eigenschaft

Gibt die Beschreibung der japanischen Eingaberegeln zurück oder legt diese fest. Kann eine der in der folgenden Tabelle aufgeführten XlIMEMode-Konstanten sein. Long Schreib-Lese-Zugriff.

Konstante | Beschreibung
xlIMEModeAlpha | Alphanumerisch mit halber Breite
xlIMEModeAlphaFull | Alphanumerisch mit voller Breite
xlIMEModeDisable | Deaktivieren
xlIMEModeHiragana | Hiragana
xlIMEModeKatakana | Katakana
xlIMEModeKatakanaHalf | Katakana (halbe Breite)
xlIMEModeNoControl | Keine Steuerung
xlIMEModeOff | Aus (deutscher Betrieb)
xlIMEModeOn | Ein

Anmerkungen

Beachten Sie, dass diese Eigenschaft nur festgelegt werden kann, wenn die japanische Sprachunterstützung installiert und aktiviert wurde.


Beispiel zur IMEMode-Eigenschaft

In diesem Beispiel wird die Dateneingaberegel für Zelle E5 festgelegt.

With Range("E5").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:= xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", Formula2:="10"
    .InputTitle = "  seisuuchi   seisuuchi   seisuuchi "
    .ErrorTitle = "  seisuuchi   seisuuchi   seisuuchi "
    .InputMessage = "5   kara   kara  10   no   seisuu   seisuu   o   nyuuryoku   nyuuryoku   shite   shite   kudasai   kudasai   kudasai   kudasai   . "
    .ErrorMessage = "  nyuuryoku   nyuuryoku   dekirunowa   dekirunowa   dekirunowa   dekirunowa   dekirunowa  5   kara   kara  10   madeno   madeno   madeno   ne   desu   desu   . "
    .IMEMode = xlIMEModeAlpha
End With


InCellDropdown-Eigenschaft

True, wenn die Validierung ein Dropdownlistenfeld mit gültigen Werten anzeigt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird ignoriert, wenn es sich beim Gültigkeitstyp nicht um xlValidateList handelt.

Verwenden Sie das Minimum-Argument der Add- oder Modify-Methode des Validation-Objekts, um den gültigen Wertebereich festzulegen.


Beispiel zur InCellDropdown-Eigenschaft

In diesem Beispiel wird die Zelle E5 mit Validierung versehen. Der Bereich A1:A10 enthält die gültigen Werte für die Zelle, und die Zelle zeigt ein Dropdownlistenfeld mit diesen Werten an.

With Range("e5").Validation
    .Add xlValidateList, xlValidAlertStop, xlBetween, "=$A$1:$A$10"
    .InCellDropdown = True
End With


IncludeAlignment-Eigenschaft

True, wenn die Formatvorlage die Eigenschaften AddIndent, HorizontalAlignment, VerticalAlignment, WrapText und Orientation mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeAlignment-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, die Ausrichtung mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludeAlignment = True


IncludeBorder-Eigenschaft

True, wenn die Formatvorlage die Rahmeneigenschaften Color, ColorIndex, LineStyle und Weight mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeBorder-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, den Rahmen mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludeBorder = True


IncludeFont-Eigenschaft

True, wenn die Formatvorlage die Schriftarteigenschaften Background, Bold, Color, ColorIndex, FontStyle, Italic, Name, OutlineFont, Shadow, Size, Strikethrough, Subscript, Superscript und Underline mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeFont-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, die Schriftart mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludeFont = True


IncludeNumber-Eigenschaft

True, wenn die Formatvorlage die Eigenschaft NumberFormat mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeNumber-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, das Zahlenformat mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludeNumber = True


IncludePatterns-Eigenschaft

True, wenn die Formatvorlage die Innenbereicheigenschaften Color, ColorIndex, InvertIfNegative, Pattern, PatternColor und PatternColorIndex mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludePatterns-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, Muster mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludePatterns = True


IncludeProtection-Eigenschaft

True, wenn die Formatvorlage die Schutzeigenschaften FormulaHidden und Locked mit einschließt. Boolean Schreib-Lese-Zugriff.


Beispiel zur IncludeProtection-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Formatvorlage, die Zelle A1 in Sheet1 zugeordnet ist, den Zellschutz mit einschließt.

Worksheets("Sheet1").Range("A1").Style.IncludeProtection = True


IndentLevel-Eigenschaft

Gibt die Einzugsebene für den Bereich oder die Formatvorlage zurück bzw. legt sie fest. Dies kann eine Ganzzahl zwischen 0 und 15 sein. Variant Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft benutzt, um die Einzugsebene auf eine Zahl kleiner als 0 (null) oder größer als 15 zu setzen, führt dies zu einem Fehler.


Beispiel zur IndentLevel-Eigenschaft

In diesem Beispiel wird die Einzugsebene in Zelle A10 auf Ebene 15 erhöht.

With Range("a10")
    .IndentLevel = 15
End With


Index-Eigenschaft

Gibt die Indexnummer des Objekts in einer Auflistung ähnlicher Objekte zurück. Long Schreibgeschützt.

Informationen über die Verwendung der Tabellenfunktion Index in Visual Basic finden Sie unter Verwenden von Tabellenfunktionen in Visual Basic.


Beispiel zur Index-Eigenschaft

In diesem Beispiel wird die Registernummer des eingegebenen Tabellennamens angezeigt. Wenn Diagramm1 beispielsweise das dritte Register der aktiven Arbeitsmappe ist, erscheint die Zahl "3" in einem Meldungsfeld.

sheetname = InputBox("Type a sheet name, such as Sheet12")
MsgBox "This sheet is tab number " & Sheets(sheetname).Index


 InnerDetail-Eigenschaft

InnerDetail-Eigenschaft

Gibt den Namen des Feldes zurück oder legt ihn fest, das als Detail angezeigt wird, wenn die ShowDetail-Eigenschaft für das innerste Zeilen- oder Spaltenfeld den Wert True besitzt. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur InnerDetail-Eigenschaft

In diesem Beispiel wird der Name des Feldes angezeigt, das mit Details dargestellt wird, wenn die ShowDetail-Eigenschaft für das am weitesten innen liegende Zeilen- oder Spaltenfeld auf True gesetzt ist.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
MsgBox pvtTable.InnerDetail


InputMessage-Eigenschaft

Gibt die Eingabemeldung der Validierung zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur InputMessage-Eigenschaft

In diesem Beispiel wird die Zelle E5 mit Validierung versehen, und die Eingabe- und Fehlermeldungen werden festgelegt.

With Range("e5").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:= xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", Formula2:="10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


InputTitle-Eigenschaft

Gibt den Titel des Dialogfelds zur Eingabe der Gültigkeitsprüfung zurück oder legt ihn fest. String Schreib-Lese-Zugriff.


Beispiel zur InputTitle-Eigenschaft

In diesem Beispiel wird die Gültigkeitsprüfung in Zelle E5 eingeschaltet.

With Range("e5").Validation
    .Add xlValidateWholeNumber, _
        xlValidAlertInformation, xlBetween, "5", "10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


 InsideHeight-Eigenschaft

InsideHeight-Eigenschaft

Gibt die Innenhöhe der Zeichnungsfläche in Punkt an. Double Schreibgeschützt.

Anmerkungen

Zur Zeichnungsfläche, die für diese Maßeinheit verwendet wurde, gehört nicht die Achsenbeschriftung. Die Height-Eigenschaft für die Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftung enthält.


Beispiel zur InsideHeight-Eigenschaft

In diesem Beispiel wird ein gepunktetes Rechteck um die Innenseiten der Zeichnungsfläche in Chart1 gezeichnet.

With Charts("Chart1")
    Set pa = .PlotArea
    With .Shapes.AddShape(msoShapeRectangle, _
            pa.InsideLeft, pa.InsideTop, _
            pa.InsideWidth, pa.InsideHeight)
        .Fill.Transparency = 1
        .Line.DashStyle = msoLineDashDot
    End With
End With


 InsideLeft-Eigenschaft

InsideLeft-Eigenschaft

Gibt den Abstand vom Diagrammrand zum inneren linken Rand der Zeichnungsfläche in Punkt an. Double Schreibgeschützt.

Anmerkungen

Zur Zeichnungsfläche, die für diese Maßeinheit verwendet wurde, gehört nicht die Achsenbeschriftung. Die Left-Eigenschaft für die Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftung enthält.


Beispiel zur InsideLeft-Eigenschaft

In diesem Beispiel wird ein gepunktetes Rechteck um die Innenseite der Zeichnungsfläche in Chart1 gezeichnet.

With Charts("Chart1")
    Set pa = .PlotArea
    With .Shapes.AddShape(msoShapeRectangle, _
            pa.InsideLeft, pa.InsideTop, _
            pa.InsideWidth, pa.InsideHeight)
        .Fill.Transparency = 1
        .Line.DashStyle = msoLineDashDot
    End With
End With


 InsideTop-Eigenschaft

InsideTop-Eigenschaft

Gibt den Abstand vom Diagrammrand zum inneren oberen Rand der Zeichnungsfläche in Punkt an. Double Schreibgeschützt.

Anmerkungen

Zur Zeichnungsfläche, die für diese Maßeinheit verwendet wurde, gehört nicht die Achsenbeschriftung. Die Top-Eigenschaft für die Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftung enthält.


Beispiel zur InsideTop-Eigenschaft

In diesem Beispiel wird ein gepunktetes Rechteck um die Innenseite der Zeichnungsfläche in Chart1 gezeichnet.

With Charts("Chart1")
    Set pa = .PlotArea
    With .Shapes.AddShape(msoShapeRectangle, _
            pa.InsideLeft, pa.InsideTop, _
            pa.InsideWidth, pa.InsideHeight)
        .Fill.Transparency = 1
        .Line.DashStyle = msoLineDashDot
    End With
End With


 InsideWidth-Eigenschaft

InsideWidth-Eigenschaft

Gibt die Innenbreite der Zeichnungsfläche in Punkt an. Double Schreibgeschützt.

Anmerkungen

Zur Zeichnungsfläche, die für diese Maßeinheit verwendet wurde, gehört nicht die Achsenbeschriftung. Die Width-Eigenschaft für die Zeichnungsfläche verwendet das Begrenzungsrechteck, das die Achsenbeschriftung enthält.


Beispiel zur InsideWidth-Eigenschaft

In diesem Beispiel wird ein gepunktetes Rechteck um die Innenseite der Zeichnungsfläche in Chart1 gezeichnet.

With Charts("Chart1")
    Set pa = .PlotArea
    With .Shapes.AddShape(msoShapeRectangle, _
            pa.InsideLeft, pa.InsideTop, _
            pa.InsideWidth, pa.InsideHeight)
        .Fill.Transparency = 1
        .Line.DashStyle = msoLineDashDot
    End With
End With


Installed-Eigenschaft

True, wenn das Add-In installiert ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft auf True gesetzt, so wird das Add-In installiert und seine Auto_installieren-Funktionen werden aufgerufen. Wird diese Eigenschaft hingegen auf False gesetzt, wird das Add-In entfernt und seine Auto_entfernen-Funktionen werden aufgerufen.


Beispiel zur Installed-Eigenschaft

Das folgende Beispiel zeigt in einem Meldungsfeld den Installationsstatus des Add-Ins Solver an.

Set a = AddIns("Solver Add-In")
If a.Installed = True Then
    MsgBox "The Solver add-in is installed"
Else
    MsgBox "The Solver add-in is not installed"
End If


Interactive-Eigenschaft

True, wenn sich Microsoft Excel im interaktiven Modus befindet. In der Regel ist diese Eigenschaft True. Setzen Sie diese Eigenschaft auf False, so wird von Microsoft Excel jegliche Eingabe von Tastatur oder Maus blockiert (ausgenommen hiervon sind Eingaben in Dialogfelder, die aus Ihrem Code aufgerufen werden). Eine Blockierung der Benutzereingabe verhindert eine Störung des Makros, wenn Microsoft Excel Objekte während des Ablaufs verschoben oder aktiviert werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft eignet sich besonders für den Einsatz von DDE oder der OLE-Automatisierung für eine Kommunikation mit Microsoft Excel aus einer anderen Anwendung heraus.

Wenn Sie diese Eigenschaft auf False setzen, dürfen Sie auf keinen Fall die Rücksetzung auf True vergessen. Denn nach der Ausführung des Makros wird sie von Microsoft Excel nicht automatisch wieder auf True gesetzt.


Beispiel zur Interactive-Eigenschaft

Dieses Beispiel setzt die Interactive-Eigenschaft auf False, solange es DDE in Windows verwendet und setzt die Eigenschaft anschließend wieder auf True. Dadurch wird verhindert, dass der Benutzer das Makro unterbricht.

Application.Interactive = False
Application.DisplayAlerts = False
channelNumber = Application.DDEInitiate( _
    app:="WinWord", _
    topic:="C:\WINWORD\FORMLETR.DOC")
Application.DDEExecute channelNumber, "[FILEPRINT]"
Application.DDETerminate channelNumber
Application.DisplayAlerts = True
Application.Interactive = True


Intercept-Eigenschaft

Gibt den Punkt zurück, auf dem die Trendlinie die Größenachse schneidet, oder legt ihn fest. Double Schreib-Lese-Zugriff.

Informationen über die Tabellenfunktion Achsenabschnitt in Visual Basic finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.

Anmerkungen

Das Setzen dieser Eigenschaft bewirkt, dass die InterceptIsAuto-Eigenschaft auf False gesetzt wird.


InterceptIsAuto-Eigenschaft

True, wenn der Schnittpunkt der Trendlinie mit der Größenachse automatisch von der Regression bestimmt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Das Setzen der Intercept-Eigenschaft bewirkt, dass diese Eigenschaft auf False gesetzt wird.


Beispiel zur InterceptIsAuto-Eigenschaft

In diesem Beispiel bestimmt Microsoft Excel automatisch den Trendlinienschnittpunkt für Chart1. Wenden Sie dieses Beispiel auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

Charts("Chart1").SeriesCollection(1).Trendlines(1) _
    .InterceptIsAuto = True


Interior-Eigenschaft

Gibt ein Interior-Objekt zurück, das den Innenbereich des angegebenen Objekts darstellt. Schreibgeschützt.


Beispiel zur Interior-Eigenschaft

In diesem Beispiel wird dem Innenraum von Zelle A1 in Sheet1 die Farbe Zyan zugewiesen.

Worksheets("Sheet1").Range("A1").Interior.ColorIndex = 8


International-Eigenschaft

Gibt Informationen über die aktuellen landesspezifischen und internationalen Einstellungen zurück. Variant Schreibgeschützt.

Syntax

Ausdruck.International(Index)

Elements

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Long optional. Die zurückzugebende Einstellung. Kann eine der in der folgenden Tabelle aufgeführten XlApplicationInternational-Konstanten sein:

Index | Typ | Bedeutung
xlCountryCode | Long |  | Die landesspezifische Version von Microsoft Excel.
xlCountrySetting | Long |  | Die aktuelle Ländereinstellung in der Windows-Systemsteuerung.
xlDecimalSeparator | String |  | Das Dezimaltrennzeichen.
xlThousandsSeparator | String |  | Das Null- oder 1.000er-Trennzeichen.
xlListSeparator | String |  | Das Listentrennzeichen.
xlUpperCaseRowLetter | String |  | Ein Großbuchstabe für Zeilenangaben (in Z1S1-Bezügen).
xlUpperCaseColumnLetter | String |  | Ein Großbuchstabe für Spaltenangaben.
xlLowerCaseRowLetter | String |  | Ein Kleinbuchstabe für Zeilenangaben.
xlLowerCaseColumnLetter | String |  | Ein Kleinbuchstabe für Spaltenangaben.
xlLeftBracket | String |  | Das Zeichen, das in Z1S1-Bezügen an Stelle der linken eckigen Klammer ([) verwendet wird.
xlRightBracket | String |  | Das Zeichen, das in Z1S1-Bezügen an Stelle der rechten eckigen Klammer (]) verwendet wird.
xlLeftBrace | String |  | Das Zeichen, das in einer Matrix an Stelle der linken geschweiften Klammer ({) verwendet wird.
xlRightBrace | String |  | Das Zeichen, das in einer Matrix an Stelle der rechten geschweiften Klammer (}) verwendet wird.
xlColumnSeparator | String |  | Das Zeichen, mit dem Spalten in einer Matrix getrennt werden.
xlRowSeparator | String |  | Das Zeichen, mit dem Zeilen in einer Matrix getrennt werden.
xlAlternateArraySeparator | String |  | Das alternative Trennzeichen für Matrix-Elemente, das verwendet werden soll, wenn das aktuelle Matrix-Trennzeichen mit dem Dezimaltrennzeichen identisch ist.
xlDateSeparator | String |  | Das Datumstrennzeichen (/).
xlTimeSeparator | String |  | Das Uhrzeittrennzeichen (:).
xlYearCode | String |  | Das Jahressymbol in Zahlenformaten (y).
xlMonthCode | String |  | Das Monatssymbol (m).
xlDayCode | String |  | Das Tagessymbol (d).
xlHourCode | String |  | Das Stundensymbol (h).
xlMinuteCode | String |  | Das Minutensymbol (m).
xlSecondCode | String |  | Das Sekundensymbol (s).
xlCurrencyCode | String |  | Das Währungssymbol.
xlGeneralFormatName | String |  | Der Name des Standard-Zahlenformats.
xlCurrencyDigits | Long |  | Die Anzahl der Nachkommastellen in Währungsformaten.
xlCurrencyNegative | Long |  | Währungsformat für negative Währungswerte: 0 = (Symbolx) oder (xSymbol) 1 = -Symbolx oder -xSymbol 2 = Symbol-x oder x-Symbol 3 = Symbolx- oder xSymbol, wobei Symbol das Währungssymbol des Landes oder der Region darstellt. Beachten Sie, dass die Position des Währungssymbols durch xlCurrencyBefore bestimmt wird.
xlNoncurrencyDigits | Long |  | Die Anzahl der Nachkommastellen für Nicht-Währungsformate.
xlMonthNameChars | Long |  | Gibt aus Gründen der Abwärtskompatibilität immer drei Zeichen zurück. Abgekürzte Monatsnamen werden aus Microsoft Windows gelesen und können eine beliebige Länge besitzen.
xlWeekdayNameChars | Long |  | Gibt aus Gründen der Abwärtskompatibilität immer drei Zeichen zurück. Abgekürzte Wochentagsnamen werden aus Microsoft Windows gelesen und können eine beliebige Länge besitzen.
xlDateOrder | Long |  | Die Reihenfolge der Datumselemente: 0 = Monat-Tag-Jahr 1 = Tag-Monat-Jahr 2 = Jahr-Monat-Tag
xl24HourClock | Boolean |  | True beim 24-Stunden-Zeitformat, False beim 12-Stunden-Zeitformat.
xlNonEnglishFunctions | Boolean |  | True, wenn Funktionen nicht in Englisch angezeigt werden.
xlMetric | Boolean |  | True, wenn das metrische System verwendet wird. False, wenn das englische Maßsystem verwendet wird.
xlCurrencySpaceBefore | Boolean |  | True, wenn vor dem Währungssymbol ein Leerzeichen eingefügt wird.
xlCurrencyBefore | Boolean |  | True, wenn das Währungssymbol dem Betrag vorangeht, False, wenn es nachgestellt ist.
xlCurrencyMinusSign | Boolean |  | True, wenn vor negativen Zahlen ein Minuszeichen angegeben wird. False, wenn Klammern verwendet werden.
xlCurrencyTrailingZeros | Boolean |  | True, wenn nachstehende Nullen bei Nullbeträgen angezeigt werden.
xlCurrencyLeadingZeros | Boolean |  | True, wenn führende Nullen bei Nullbeträgen angezeigt werden.
xlMonthLeadingZero | Boolean |  | True, wenn bei als Zahlen dargestellten Monaten führende Nullen angezeigt werden.
xlDayLeadingZero | Boolean |  | True, wenn bei Tagen eine führende Null angezeigt wird.
xl4DigitYears | Boolean |  | True, wenn Jahreszahlen mit 4 Ziffern angezeigt werden. False, wenn nur 2 Ziffern verwendet werden.
xlMDY | Boolean |  | True, wenn im langen Datumsformat die Datumsreihenfolge Monat-Tag-Jahr lautet. False, wenn die Reihenfolge Tag-Monat-Jahr ist.
xlTimeLeadingZero | Boolean |  | True, wenn bei Uhrzeiten führende Nullen angezeigt werden.

Anmerkungen

Die in der obigen Tabelle gezeigten Symbol, Trennzeichen und Währungsformate können sich von den in Ihrer Sprache oder geografischen Region verwendeten unterscheiden und stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


InvertIfNegative-Eigenschaft

True, wenn Microsoft Excel das Muster in dem Element invertiert, falls sein Wert negativ ist. Variant Schreib-Lese-Zugriff für das Interior-Objekt, Boolean Schreib-Lese-Zugriff für alle anderen Objekte.


Beispiel zur InvertIfNegative-Eigenschaft

In diesem Beispiel wird das Muster für negative Werte der ersten Datenreihe in Chart1 invertiert. Wenden Sie das Beispiel auf ein 2D-Säulendiagramm an.

Charts("Chart1").SeriesCollection(1).InvertIfNegative = True


IsAddin-Eigenschaft

True, falls die Arbeitsmappe als Add-In ausgeführt wird. Boolean Lese- und Schreibzugriff.

Anmerkungen

Wenn Sie diese Eigenschaft auf True setzen, besitzt die Arbeitsmappe folgende Kennzeichen:

  • Sie werden nicht aufgefordert, die Arbeitsmappe zu speichern, falls Änderungen vorgenommen werden, während die Arbeitsmappe geöffnet ist.

  • Das Arbeitsmappenfenster ist nicht sichtbar.

  • Eventuell in der Arbeitsmappe enthaltene Makros werden im Makro-Dialogfeld nicht dargestellt (das Dialogfeld wird angezeigt, wenn Sie auf Makro im Extras-Menü zeigen und auf Makros klicken).

  • Makros der Arbeitsmappe können, obwohl sie nicht dargestellt werden, über das Makro-Dialogfeld ausgeführt werden. Außerdem müssen Makronamen nicht mit dem Namen der Arbeitsmappe qualifiziert werden.

  • Wenn Sie die UMSCHALTTASTE gedrückt halten, hat dies keine Wirkung.


Beispiel zur IsAddin-Eigenschaft

In diesem Beispiel wird der Teil eines Codes ausgeführt, falls es sich bei der Arbeitsmappe um ein Add-In handelt.

If ThisWorkbook.IsAddin Then
    ' this code runs when the workbook is an add-in
End If


 IsCalculated-Eigenschaft

IsCalculated-Eigenschaft

True, wenn das PivotTable-Feld oder PivotTable-Element ein berechnetes Feld oder Element ist. Boolean Schreibgeschützt.

Anmerkungen

Bei OLAP-Datenquellen gibt diese Eigenschaft immer False zurück.


Beispiel zur IsCalculated-Eigenschaft

In diesem Beispiel wird das Dialogfeld PivotTable-Feld deaktiviert, wenn der PivotTable-Bericht berechnete Felder enthält.

set pt = Worksheets(1).PivotTables("Pivot1")
For Each fld in pt.PivotFields
    If fld.IsCalculated Then pt.EnableFieldDialog = False
Next


IsInPlace-Eigenschaft

True, wenn die angegebene Arbeitsmappe direkt bearbeitet wird. False, wenn die Arbeitsmappe zur Bearbeitung in Microsoft Excel geöffnet wurde. Boolean Schreibgeschützt.


Beispiel zur IsInPlace-Eigenschaft

In diesem Beispiel wird angezeigt, ob die Arbeitsmappe zur direkten Bearbeitung oder zur Bearbeitung in Microsoft Excel geöffnet wurde.

Private Sub Workbook_Open()
    If ThisWorkbook.IsInPlace = True Then
        MsgBox "Editing in place"
    Else
        MsgBox "Editing in Microsoft Excel"
    End If
End Sub


Italic-Eigenschaft

True, wenn die Schriftart Kursiv ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur Italic-Eigenschaft

In diesem Beispiel wird die Schriftart für den Bereich A1:A5 in Sheet1 kursiv formatiert.

Worksheets("Sheet1").Range("A1:A5").Font.Italic = True


Iteration-Eigenschaft

True, wenn Zirkelbezüge in Microsoft Excel durch Iteration aufgelöst werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur Iteration-Eigenschaft

Dieses Beispiel setzt die Iteration-Eigenschaft auf True, so dass Zirkelbezüge durch Iteration aufgelöst werden.

Application.Iteration = True


KeepChangeHistory-Eigenschaft

True, falls die Protokollierung der Änderungen in der gemeinsam genutzten Arbeitsmappe aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur KeepChangeHistory-Eigenschaft

In diesem Beispiel wird in der aktiven Arbeitsmappe die Anzahl der im Änderungsprotokoll aufgenommenen Tage festgelegt, falls die Protokollierung der Änderungen aktiviert ist.

With ActiveWorkbook
    If .KeepChangeHistory Then
        .ChangeHistoryDuration = 7
    End If
End With


KernedPairs-Eigenschaft

True, wenn Zeichenpaare in der angegebenen WordArt unterschnitten werden. Long Schreib-Lese-Zugriff.


Beispiel zur KernedPairs-Eigenschaft

In diesem Beispiel wird in myDocument die Unterschneidung für die dritte Form eingeschaltet, wenn es sich bei ihr um eine WordArt handelt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.KernedPairs = True
    End If
End With


LabelRange-Eigenschaft

PivotField-Objekt: Gibt ein Range-Objekt zurück, das die Zelle (oder Zellen) darstellt, die die Feldbeschriftung enthält. Schreibgeschützt.

PivotItem-Objekt: Gibt ein Range-Objekt zurück, das alle Zellen des PivotTable-Berichts darstellt, die das Element enthalten. Schreibgeschützt.


Beispiel zur LabelRange-Eigenschaft

In diesem Beispiel wird die Schaltfläche für das Feld "ORDER_DATE" ausgewählt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Set pvtField = pvtTable.PivotFields("ORDER_DATE")
Worksheets("Sheet1").Activate
pvtField.LabelRange.Select


LanguageSettings-Eigenschaft

Gibt das LanguageSettings-Objekt zurück, das Informationen über die Ländereinstellungen in Microsoft Excel enthält. Schreibgeschützt.


Beispiel zur LanguageSettings-Eigenschaft

In diesem Beispiel wird die Länderkennung der Sprache, die beim Installieren von Microsoft Excel gewählt wurde, zurückgegeben.

Set objLangSet = Application.LanguageSettings
MsgBox objLangSet.LanguageID(msoLanguageIDInstall)


LargeChange-Eigenschaft

Gibt einen Wert zurück oder legt ihn fest, um den das Bildlauffeld bei einem Bildlauf nach oben oder unten geändert wird (wenn der Benutzer auf der Bildlaufleiste ober- bzw. unterhalb des Bildlauffeldes klickt). Long Schreib-Lese-Zugriff.


Beispiel zur LargeChange-Eigenschaft

In diesem Beispiel wird eine Bildlaufleiste erstellt und ihre Werte für "LinkedCell", "Min", "Max", "LargeChange" und "SmallChange" festgelegt.

Set sb = Worksheets(1).Shapes.AddFormControl(xlScrollBar, _
    Left:=10, Top:=10, Width:=10, Height:=200)
With sb.ControlFormat
    .LinkedCell = "D1"
    .Max = 100
    .Min = 0
    .LargeChange = 10
    .SmallChange = 2
End With


 LayoutBlankLine-Eigenschaft

LayoutBlankLine-Eigenschaft

True, wenn hinter dem angegebenen Zeilenfeld in einem PivotTable-Bericht eine leere Zeile eingefügt wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann für jedes PivotTable-Feld festgelegt werden; die leere Zeile wird jedoch nur dann angezeigt, wenn es sich bei dem angegebenen Feld um ein Zeilenfeld handelt, das nicht das innerste Zeilenfeld (unterste Ebene) ist. Der Wert dieser Eigenschaft ändert sich nicht, wenn das Feld anders angeordnet oder zu dem PivotTable-Bericht hinzugefügt wird.

Sie können im PivotTable-Bericht keine Daten in die leere Zeile eingeben.


Beispiel zur LayoutBlankLine-Eigenschaft

In diesem Beispiel wird hinter dem Feld "state" im ersten PivotTable-Bericht der aktiven Arbeitsmappe eine leere Zeile eingefügt.

With ActiveSheet.PivotTables("PivotTable1") _
        .PivotFields("state")
    .LayoutBlankLine = True
End With


 LayoutForm-Eigenschaft

LayoutForm-Eigenschaft

Gibt die Art der Anzeige des angegebenen PivotTable-Elements, Tabellenformat oder Gliederungsformat, zurück oder legt diese fest. Kann eine der folgenden XlLayoutFormType-Konstanten sein: xlTabular oder xlOutline. Wird xlOutline angegeben oder zurückgegeben, gibt die LayoutSubtotalLocation-Eigenschaft an, wo das Teilergebnis im PivotTable-Bericht angezeigt wird. Der Standardwert ist xlTabular. XlLayoutFormType Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann für jedes PivotTable-Feld festgelegt werden; die Formatierung wird jedoch nur dann angezeigt, wenn es sich bei dem angegebenen Feld um ein Zeilenfeld handelt, das nicht das innerste Zeilenfeld (unterste Ebene) ist. Der Wert dieser Eigenschaft ändert sich nicht, wenn das Feld anders angeordnet oder zu dem PivotTable-Bericht hinzugefügt wird.


Beispiel zur LayoutForm-Eigenschaft

In diesem Beispiel wird das Feld "state" im ersten PivotTable-Bericht des aktiven Tabellenblatts im Gliederungsformat mit den Teilergebnissen über dem Feld angezeigt.

With ActiveSheet.PivotTables("PivotTable1") _
        .PivotFields("state")
    .LayoutForm = xlOutline
    .LayoutSubtotalLocation = xlTop
End With


 LayoutPageBreak-Eigenschaft

LayoutPageBreak-Eigenschaft

True, wenn hinter jedem Feld ein Seitenumbruch eingefügt wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Obwohl diese Eigenschaft für jedes PivotTable-Feld festgelegt werden kann, wird die Druckoption nur dann angezeigt, wenn es sich bei dem angegebenen Feld um ein Zeilenfeld handelt, das nicht das innerste Zeilenfeld (unterste Ebene) ist. Der Wert dieser Eigenschaft ändert sich nicht, wenn das Feld anders angeordnet oder zu dem PivotTable-Bericht hinzugefügt wird.


Beispiel zur LayoutPageBreak-Eigenschaft

In diesem Beispiel wird hinter dem Feld "state" im ersten PivotTable-Bericht der aktiven Arbeitsmappe ein Seitenumbruch eingefügt.

With ActiveSheet.PivotTables("PivotTable1") _
        .PivotFields("state")
    .LayoutPageBreak = True
End With


 LayoutSubtotalLocation-Eigenschaft

LayoutSubtotalLocation-Eigenschaft

Gibt die Position der Teilergebnisse des PivotTable-Felds in Bezug auf das angegebene Feld (darüber oder darunter) zurück oder legt diese fest. Kann eine der folgenden XlSubtotalLocationType-Konstanten sein: xlAtTop oder xlAtBottom. Der Standardwert ist xlAtBottom. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann für jedes PivotTable-Feld im Gliederungsformat festgelegt werden; die Formatierung wird jedoch nur dann angezeigt, wenn es sich bei dem angegebenen Feld um ein Zeilenfeld handelt, das nicht das innerste Zeilenfeld (unterste Ebene) ist. Der Wert dieser Eigenschaft ändert sich nicht, wenn das Feld anders angeordnet oder zu dem PivotTable-Bericht hinzugefügt wird.

Die LayoutForm-Eigenschaft bestimmt, ob der Bericht im Tabellenformat oder im Gliederungsformat angezeigt wird.


Beispiel zur LayoutSubtotalLocation-Eigenschaft

In diesem Beispiel wird das Feld "state" im ersten PivotTable-Bericht des aktiven Tabellenblatts im Gliederungsformat mit den Teilergebnissen über dem Feld angezeigt.

With ActiveSheet.PivotTables("PivotTable1") _
        .PivotFields("state")
    .LayoutForm = xlOutline
    .LayoutSubtotalLocation = xlAtTop
End With


LeaderLines-Eigenschaft

Gibt ein LeaderLines-Objekt zurück, das die Führungslinien der Datenreihe darstellt. Schreibgeschützt.


Beispiel zur LeaderLines-Eigenschaft

In diesem Beispiel werden der ersten Datenreihe des Kreisdiagramms Datenbeschriftungen und blaue Führungslinien hinzugefügt.

With Worksheets(1).ChartObjects(1).Chart.SeriesCollection(1)
    .HasDataLabels = True
    .DataLabels.Position = xlLabelPositionBestFit
    .HasLeaderLines = True
    .LeaderLines.Border.ColorIndex = 5
End With


 Left-Eigenschaft

Left-Eigenschaft

Gibt die Position des angegebenen Objekts in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff mit Ausnahmen entsprechend der folgenden Tabelle.

Anmerkungen

Die Left-Eigenschaft hat je nach dem angegebenen Objekt verschiedene Bedeutungen.

Objekt | Bedeutung
Application | Der Abstand von der linken Seite des Bildschirms zur linken Seite des Microsoft Excel-Hauptfensters.
Axis, LegendEntry, LegendKey | Der Abstand von der linken Seite des Objekts zur linken Seite des Diagrammbereichs. Schreibgeschützt.
Range | Der Abstand von der linken Seite von Spalte A zur linken Seite des Bereichs. Ist der Bereich nicht zusammenhängend, wird der erste Bereich verwendet. Ist der Bereich mehrere Spalten breit, wird die linke Spalte des Bereichs verwendet. Schreibgeschützt.
Window | Der Abstand von der linken Seite des Client-Bereichs zur linken Seite des Fensters.
AxisTitle, ChartArea, ChartTitle, DataLabel, Legend, OLEObject, PlotArea, Shape, ShapeRange | Der Abstand von der linken Seite des Objekts zur linken Seite von Spalte A (in einem Tabellenblatt) oder zur linken Seite des Diagrammbereichs (in einem Diagramm). Schreibgeschützt bei ChartArea.

Ist das Fenster maximiert, gibt Application.Left einen negativen Wert zurück, der von der Breite des Fensterrands abhängt. Wenn Sie Application.Left auf 0 (Null) setzen, wird das Fenster geringfügig kleiner als beim Maximieren des Anwendungsfensters. Das heißt, in diesem Fall ist der linke Rand des Microsoft Excel-Hauptfensters gerade noch auf dem Bildschirm sichtbar.


LeftFooter-Eigenschaft

Gibt den linken Teil der Fußzeile zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Fußzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur LeftFooter-Eigenschaft

In diesem Beispiel wird die Seitenzahl links unten auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.LeftFooter = "&P"


LeftHeader-Eigenschaft

Gibt den linken Teil der Kopfzeile zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Kopfzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur LeftHeader-Eigenschaft

In diesem Beispiel wird das Datum links oben auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.LeftHeader = "&D"


 LeftMargin-Eigenschaft

LeftMargin-Eigenschaft

Gibt die Breite des linken Randes in Punkt zurück oder legt diese fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Ränder werden in Punkt festgelegt oder zurückgegeben. Mit den Methoden InchesToPoints und CentimetersToPoints können Sie die Maßeinheiten umwandeln.


Beispiel zur LeftMargin-Eigenschaft

In diesem Beispiel wird der linke Rand von Sheet1 auf 1,5 Zoll festgelegt.

Worksheets("Sheet1").PageSetup.LeftMargin = _
        Application.InchesToPoints(1.5)

In diesem Beispiel wird der linke Rand von Sheet1 auf 2 Zentimeter festgelegt.

Worksheets("Sheet1").PageSetup.LeftMargin = _
        Application.CentimetersToPoints(2)

In diesem Beispiel wird die aktuelle Einstellung des linken Randes für Sheet1 angezeigt.

marginInches = Worksheets("Sheet1").PageSetup.LeftMargin / _
    Application.InchesToPoints(1)
MsgBox "The current left margin is " & marginInches & " inches"


Legend-Eigenschaft

Gibt ein Legend-Objekt zurück, das die Legende des Diagramms darstellt. Schreibgeschützt.


LegendKey-Eigenschaft

Gibt ein LegendKey-Objekt zurück, das den dem Eintrag zugeordneten Legendenschlüssel darstellt.


Beispiel zur LegendKey-Eigenschaft

In diesem Beispiel wird ein Dreieck als Legendensymbol für den ersten Legendeneintrag in Chart1 festgelegt. Wenden Sie das Makro auf ein 2D-Liniendiagramm an.

Charts("Chart1").Legend.LegendEntries(1).LegendKey _
    .MarkerStyle = xlMarkerStyleTriangle


Length-Eigenschaft

Wenn bei einem CalloutFormat-Objekt die AutoLength-Eigenschaft der angegebenen Legende den Wert False besitzt, gibt die Length-Eigenschaft die Länge (in Punkt) des ersten Abschnitts der Legendenlinie (des Abschnitts, der dem Textfeld der Legende zugeordnet ist) zurück. Gilt nur für Legenden, deren Linien aus mehreren Abschnitten bestehen (Legenden des Typs msoCalloutThree und msoCalloutFour). Single Schreibgeschützt.

Bei einem Phonetic-Objekt gibt die Length-Eigenschaft die Anzahl der Zeichen des phonetisches Textes ab der Position, die mit der Start-Eigenschaft angegeben wurde, zurück. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die CustomLength-Methode, um für ein CalloutFormat-Objekt den Wert dieser Eigenschaft festzulegen.


Beispiel zur Length-Eigenschaft

Wenn der erste Linienabschnitt der Legende "callout1" eine feste Länge besitzt, wird in diesem Beispiel festgelegt, dass die Länge des ersten Linienabschnitts der Legende "callout2" im ersten Tabellenblatt ebenfalls konstant bleibt. Dieses Beispiel funktioniert nur, wenn beide Legenden Linien mit mehreren Abschnitten besitzen.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    With .Item("callout1").Callout
        If Not .AutoLength Then len1 = .Length
    End With
    If len1 Then .Item("callout2").Callout.CustomLength len1
End With

In diesem Beispiel wird die Länge der zweiten phonetischen Textzeichenfolge in der aktiven Zelle zurückgegeben.

ActiveCell.FormulaR1C1 = "  toukyouto   toukyouto   toukyouto   shibuyaku   shibuyaku   shibuyaku   yoyogi   yoyogi   yoyogi "
ActiveCell.Phonetics.Add Start:=1, Length:=3, Text:="  toukyouto    toukyouto   toukyouto    toukyouto   toukyouto   toukyouto "
ActiveCell.Phonetics.Add Start:=4, Length:=3, Text:="  shibuyaku    shibuyaku   shibuyaku   shibuyaku "
MsgBox ActiveCell.Phonetics(2).Length


LibraryPath-Eigenschaft

Diese Eigenschaft gibt den Pfad zum Bibliotheks-Ordner zurück; allerdings ohne abschließendes Pfadtrennzeichen. String Schreibgeschützt.


Beispiel zur LibraryPath-Eigenschaft

In diesem Beispiel wird die Datei Oscar.xla im Bibliotheksordner geöffnet.

pathSep = Application.PathSeparator
f = Application.LibraryPath & pathSep & "Oscar.Xla"
Workbooks.Open filename:=f


Line-Eigenschaft

Gibt ein LineFormat-Objekt zurück, das Linienformateigenschaften der angegebenen Form enthält. (Bei einer Linie stellt das LineFormat-Objekt die Linie selbst dar; bei einer Form mit Rahmen stellt das LineFormat-Objekt den Rahmen dar.) Schreibgeschützt.


Line3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Liniendiagrammgruppe in einem 3D-Diagramm darstellt. Schreibgeschützt.


Beispiel zur Line3DGroup-Eigenschaft

In diesem Beispiel wird die 3D-Liniengruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird.

Charts("Chart1").Line3DGroup.VaryByCategories = True


LineStyle-Eigenschaft

Gibt die Linienart des Rahmens zurück oder legt sie fest. Dies kann eine der folgenden XlLineStyle-Konstanten sein: xlContinuous, xlDash, xlDashDot, xlDashDotDot, xlDot, xlDouble, xlSlantDashDot oder xlLineStyleNone. Variant Schreib-Lese-Zugriff.


Beispiel zur LineStyle-Eigenschaft

In diesem Beispiel wird um die Diagrammfläche und die Zeichnungsfläche in Chart1 ein Rahmen gelegt.

With Charts("Chart1")
    .ChartArea.Border.LineStyle = xlDashDot
    With .PlotArea.Border
        .LineStyle = xlDashDotDot
        .Weight = xlThick
    End With
End With


LinkedCell-Eigenschaft

Gibt den mit dem Wert des Steuerelements verknüpften Tabellenblattbereich zurück oder legt ihn fest. Wenn Sie in der Zelle einen Wert ablegen, nimmt das Steuerelement diesen Wert an. Ebenso wird, wenn Sie den Wert des Steuerelements ändern, dieser Wert auch in der Zelle abgelegt. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann bei Listenfeldern mit Mehrfachauswahl nicht verwendet werden.


Beispiel zur LinkedCell-Eigenschaft

In diesem Beispiel wird dem ersten Tabellenblatt ein Kontrollkästchen hinzugefügt und dessen Wert mit der Zelle A1 verknüpft.

With Worksheets(1)
    Set cb = .Shapes.AddFormControl(xlCheckBox, 10, 10, 100, 10)
    cb.ControlFormat.LinkedCell = "A1"
End With


LinkFormat-Eigenschaft

Gibt ein LinkFormat-Objekt zurück, das die Eigenschaften der verknüpften OLE-Objekte enthält. Schreibgeschützt.


Beispiel zur LinkFormat-Eigenschaft

In diesem Beispiel werden alle verknüpften OLE-Objekte des ersten Tabellenblattes aktualisiert.

For Each s In Worksheets(1).Shapes
    If s.Type = msoLinkedOLEObject Then s.LinkFormat.Update
Next


ListChangesOnNewSheet-Eigenschaft

True, falls Änderungen an der gemeinsam genutzten Arbeitsmappe in einem eigenen Tabellenblatt dargestellt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ListChangesOnNewSheet-Eigenschaft

In diesem Beispiel werden Änderungen an der gemeinsam genutzten Arbeitsmappe in einem eigenen Tabellenblatt dargestellt.

With ActiveWorkbook
    .HighlightChangesOptions _
        When:=xlSinceMyLastSave, _
        Who:="Everyone"
    .ListChangesOnNewSheet = True
End With


ListCount-Eigenschaft

Gibt die Anzahl der Einträge in einem Listenfeld oder Kombinationsfeld zurück. Gibt 0 (Null) zurück, falls die Liste keine Einträge enthält. Long Schreibgeschützt.


Beispiel zur ListCount-Eigenschaft

In diesem Beispiel wird ein Kombinationsfeld so angepasst, dass es alle Einträge seiner Liste anzeigt. Falls Shapes(2) kein Kombinationsfeld darstellt, schlägt dieses Beispiel fehl.

Set cf = Worksheets(1).Shapes(1).ControlFormat
cf.DropDownLines = cf.ListCount


ListFillRange-Eigenschaft

Gibt den Tabellenblattbereich zurück, mit dem das angegebene Listenfeld ausgefüllt wird, oder legt ihn fest. Ist diese Eigenschaft festgelegt, werden alle im Listenfeld bereits bestehenden Listen zerstört. String Schreib-Lese-Zugriff.

Anmerkungen

Microsoft Excel liest den Inhalt jeder Zelle des Bereichs und fügt die Zellwerte in das Listenfeld ein. In der Liste werden Änderungen in den Zellen des Bereichs protokolliert.

Falls die Liste im Listenfeld mit der AddItem-Methode erstellt wurde, gibt diese Eigenschaft eine leere Zeichenfolge zurück ("").


Beispiel zur ListFillRange-Eigenschaft

In diesem Beispiel wird dem ersten Tabellenblatt ein Listenfeld hinzugefügt und der Bereich festgelegt, mit dem das Listenfeld ausgefüllt wird.

With Worksheets(1)
    Set lb = .Shapes.AddFormControl(xlListBox, 100, 10, 100, 100)
    lb.ControlFormat.ListFillRange = "A1:A10"
End With


ListHeaderRows-Eigenschaft

Gibt die Anzahl der Überschriftenzeilen für den angegebenen Bereich zurück. Long Schreibgeschützt.

Anmerkungen

Bevor Sie diese Eigenschaft verwenden, sollten Sie mit Hilfe der CurrentRegion-Eigenschaft die Begrenzungen des Bereichs ermitteln.


Beispiel zur ListHeaderRows-Eigenschaft

In diesem Beispiel wird die Variable rTbl auf den Bereich gesetzt, der den aktuellen Bereich für die aktive Zelle darstellt. Spaltenköpfe werden nicht mit eingeschlossen.

Set rTbl = ActiveCell.CurrentRegion
' remove the headers from the range
iHdrRows = rTbl.ListHeaderRows
If iHdrRows > 0 Then
    ' resize the range minus n rows
    Set rTbl = rTbl.Resize(rTbl.Rows.Count - iHdrRows)
    ' and then move the resized range down to
    ' get to the first non-header row
    Set rTbl = rTbl.Offset(iHdrRows)
End If


ListIndex-Eigenschaft

Gibt die Indexnummer des aktuell markierten Elements in einem Listenfeld oder einem Kombinationsfeld zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft kann in Listenfeldern mit Mehrfachmarkierung nicht verwendet werden.


Beispiel zur ListIndex-Eigenschaft

In diesem Beispiel wird das markierte Element aus dem Listenfeld entfernt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Set lbcf = Worksheets(1).Shapes(2).ControlFormat
lbcf.RemoveItem lbcf.ListIndex


LoadPictures-Eigenschaft

True, wenn Bilder beim Öffnen eines Dokuments in Microsoft Excel geladen werden. Dies ist normalerweise der Fall, wenn die Bilder und das Dokument nicht in Microsoft Excel erstellt wurden. False, wenn die Bilder nicht geladen werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur LoadPictures-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Bilder beim Öffnen des Dokuments in Excel geladen werden.

Application.DefaultWebOptions.LoadPictures = True


 LocalConnection-Eigenschaft

LocalConnection-Eigenschaft

Gibt die Verbindungszeichenfolge zu einer Offline-Cubedatei zurück oder legt diese fest. String Schreib-Lese-Zugriff.

Anmerkungen

Bei einer Nicht-OLAP-Datenquelle ist der Wert der LocalConnection-Eigenschaft eine leere Zeichenfolge, und die UseLocalConnection-Eigenschaft wird auf False festgelegt.

Beim Festlegen der LocalConnection-Eigenschaft wird die Verbindung zu der Datenquelle nicht sofort initiiert. Sie müssen zunächst mit der Refresh-Methode eine Verbindung herstellen und die Daten laden.

Der Wert der LocalConnection-Eigenschaft wird verwendet, wenn die UseLocalConnection-Eigenschaft auf True eingestellt ist. Ist die UseLocalConnection-Eigenschaft auf False eingestellt, gibt die Connection-Eigenschaft die Verbindungszeichenfolge für Abfragetabellen an, die auf anderen Quellen und nicht auf lokalen Cube-Dateien basieren.

Weitere Informationen zur Syntax von Verbindungszeichenfolgen finden Sie im Hilfethema zur Add-Methode der PivotTables-Auflistung.


 Beispiel zur LocalConnection-Eigenschaft

Beispiel zur LocalConnection-Eigenschaft

In diesem Beispiel wird die Verbindungszeichenfolge des ersten PivotTable-Cache als Bezug auf eine Offline-Cubedatei verwendet.

With ActiveWorkbook.PivotCaches(1)
    .LocalConnection = _
        "OLEDB;Provider=MSOLAP;Data Source=C:\Data\DataCube.cub"
    .UseLocalConnection = True
End With


Location-Eigenschaft

Gibt für das HPageBreak- und VPageBreak-Objekt die Zelle zurück oder legt diese fest (ein Range-Objekt), die die Position des Seitenwechsels definiert. Horizontale Seitenwechsel sind am oberen Rand der Positionszelle ausgerichtet; vertikale Seitenwechsel sind am linken Rand der Positionszelle ausgerichtet. Range Schreib-Lese-Zugriff.


LocationInTable-Eigenschaft

Gibt eine Konstante zurück, die denjenigen Teil des PivotTable-Berichts beschreibt, der die linke obere Ecke des angegebenen Bereichs enthält. Kann eine der folgenden XlLocationInTable-Konstanten sein: xlRowHeader, xlColumnHeader, xlPageHeader, xlDataHeader, xlRowItem, xlColumnItem, xlPageItem, xlDataItem oder xlTableBody. Long Schreibgeschützt.


Beispiel zur LocationInTable-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, in dem die Position der aktiven Zelle des PivotTable-Berichts beschrieben wird.

Worksheets("Sheet1").Activate
Select Case ActiveCell.LocationInTable
Case Is = xlRowHeader
    MsgBox "Active cell is part of a row header"
Case Is = xlColumnHeader
    MsgBox "Active cell is part of a column header"
Case Is = xlPageHeader
    MsgBox "Active cell is part of a page header"
Case Is = xlDataHeader
    MsgBox "Active cell is part of a data header"
Case Is = xlRowItem
    MsgBox "Active cell is part of a row item"
Case Is = xlColumnItem
    MsgBox "Active cell is part of a column item"
Case Is = xlPageItem
    MsgBox "Active cell is part of a page item"
Case Is = xlDataItem
    MsgBox "Active cell is part of a data item"
Case Is = xlTableBody
    MsgBox "Active cell is part of the table body"
End Select


LocationOfComponents-Eigenschaft

Gibt den zentralen URL (im Intranet oder World Wide Web) oder Pfad (lokal oder Netzwerk) zu dem Speicherort, von dem aus berechtigte Benutzer beim Anzeigen des gespeicherten Dokuments Microsoft Office Web Components downloaden können, zurück oder legt diesen fest. Standardwert ist der lokale oder Netzwerkinstallationspfad für Microsoft Office. Schreib-Lese-Zugriff String.

Anmerkungen

Die Office Web Components werden automatisch mit der angegebenen Webseite gedownloadet, wenn die DownloadComponents-Eigenschaft auf True festgelegt ist, die Komponenten noch nicht installiert wurden, der Pfad zulässig ist und auf ein Verzeichnis zeigt, das die notwendigen Komponenten enthält, und der Benutzer über eine gültige Microsoft Office 2000-Lizenz verfügt.


Beispiel zur LocationOfComponents-Eigenschaft

In diesem Beispiel wird der Pfad zu dem Speicherplatz festlegt, von dem die Benutzer Microsoft Office Web Components downloaden können.

Application.DefaultWebOptions.DownloadComponents = True
Application.DefaultWebOptions.LocationOfComponents = _
    Application.Path & Application.PathSeparator & "foo"


LockAspectRatio-Eigenschaft

True, wenn die angegebene Form bei einer Größenänderung ihre ursprünglichen Proportionen beibehält. False, wenn bei einer Größenänderung der Form Höhe und Breite unabhängig voneinander geändert werden können. Long Schreib-Lese-Zugriff.


Beispiel zur LockAspectRatio-Eigenschaft

In diesem Beispiel wird in myDocument ein Würfel eingefügt. Er kann verschoben und in der Größe, jedoch nicht in seinen Proportionen, geändert werden.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddShape(msoShapeCube, _
    50, 50, 100, 200).LockAspectRatio = True


Locked-Eigenschaft

True, wenn das Objekt gesperrt ist. False, wenn das Objekt geändert werden kann, obwohl das Blatt geschützt ist. Gibt Null zurück, wenn der angegebene Bereich sowohl gesperrte als auch nicht gesperrte Zellen umfasst. Variant Schreib-Lese-Zugriff für das Range-Objekt; Boolean Schreib-Lese-Zugriff für alle anderen Objekte.


LockedText-Eigenschaft

True, falls der Text in dem angegebenen Objekt gesperrt wird, um Änderungen zu vermeiden, wenn die Arbeitsmappe geschützt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur LockedText-Eigenschaft

In diesem Beispiel wird Text im eingebetteten Diagramm gesperrt, wenn die Arbeitsmappe geschützt wird.

Worksheets(1).ChartObjects(1).LockedText = True


MacroType-Eigenschaft

Gibt zurück bzw. legt fest, auf was sich der Makroname bezieht. Long Schreib-Lese-Zugriff.

Zulässig ist eine der folgenden XlMacroType-Konstanten:

Konstante | Bedeutung
xlCommand | Der Name bezieht sich auf ein benutzerdefiniertes Makro.
xlFunction | Der Name bezieht sich auf eine benutzerdefinierte Funktion.
xlNotXLM | Der Name bezieht sich weder auf eine Funktion noch auf ein Makro.


Beispiel zur MacroType-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass eine benutzerdefinierte Funktion bzw. ein benutzerdefinierter Befehl in einer Makrovorlage von Microsoft Excel, Version 4.0, erstellt wurde. Die Funktionskategorie wird in der Sprache des Makros angezeigt. Es wird vorausgesetzt, dass der Name der benutzerdefinierten Funktion bzw. des benutzerdefinierten Befehls der einzige Name ist, der in der Arbeitsmappe vorkommt.

With ActiveWorkbook.Names(1)
    If .MacroType <> xlNotXLM Then
        MsgBox "The category for this name is " & .Category
    Else
        MsgBox "This name does not refer to" & _
            " a custom function or command."
    End If
End With


MailSession-Eigenschaft

Gibt die Nummer einer MAPI-Mail-Sitzung in Form einer hexadezimalen Zeichenfolge zurück. Wenn keine Sitzung aufgebaut wurde, wird der Wert Null zurückgegeben. Variant Schreibgeschützt.

Anmerkungen

Diese Eigenschaft gilt nur für Mail-Sitzungen, die in Microsoft Excel erstellt wurden. Für Microsoft Mail wird keine Sitzungsnummer zurückgegeben.

Diese Eigenschaft kann in PowerTalk-Mail-Systemen nicht verwendet werden.


Beispiel zur MailSession-Eigenschaft

In diesem Beispiel wird die Mail-Sitzung, falls vorhanden, beendet.

If Not IsNull(Application.MailSession) Then Application.MailLogoff


MailSystem-Eigenschaft

Gibt den Namen der Mail-Sitzung zurück, die auf dem Hostcomputer installiert ist. Es stehen folgende XlMailSystem-Konstanten zur Verfügung: xlNoMailSystem, xlMAPI oder xlPowerTalk. Long Schreibgeschützt.


Beispiel zur MailSystem-Eigenschaft

In diesem Beispiel wird der Name des auf dem Computer installierten Mail-Systems angezeigt.

Select Case Application.MailSystem
    Case xlMAPI
        MsgBox "Mail system is Microsoft Mail"
    Case xlPowerTalk
        MsgBox "Mail system is PowerTalk"
    Case xlNoMailSystem
        MsgBox "No mail system installed"
End Select


MaintainConnection-Eigenschaft

True, wenn die Verbindung zu der angegebenen Datenquelle nach der Aktualisierung bis zum Schließen der Arbeitsmappe aufrecht erhalten bleibt. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die MaintainConnection-Eigenschaft kann nur dann festgelegt werden, wenn die QueryType-Eigenschaft der Abfragetabelle oder des PivotTable-Cache auf xlOLEDBQuery eingestellt ist.

Wenn häufige Abfragen an einen Server erfolgen, kann die Festlegung dieser Eigenschaft auf True unter Umständen die Leistung steigern, indem die Zeit für den erneuten Verbindungsaufbau reduziert wird. Wird die Eigenschaft auf False eingestellt, wird eine geöffnete Verbindung geschlossen.


 Beispiel zur MaintainConnection-Eigenschaft

Beispiel zur MaintainConnection-Eigenschaft

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf dem Cache basiert. In dem Beispiel wird die Verbindung nach der ersten Aktualisierung beendet.

With ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = False
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:= "PivotTable1"
End With
With ActiveSheet.PivotTables("PivotTable1")
    .SmallGrid = False
    .PivotCache.RefreshPeriod = 0
    With .CubeFields("[state]")
        .Orientation = xlColumnField
        .Position = 0
    End With
    With .CubeFields("[Measures].[Count Of au_id]")
        .Orientation = xlDataField
        .Position = 0
    End With
End With


MajorGridlines-Eigenschaft

Gibt ein Gridlines-Objekt zurück, das die Hauptgitternetzlinien für die angegebene Achse darstellt. Nur Achsen in der Primärachsengruppe können Gitternetzlinien besitzen. Schreibgeschützt.


Beispiel zur MajorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hauptgitternetzlinien der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    If .HasMajorGridlines Then
        .MajorGridlines.Border.ColorIndex = 5    ' set color to blue
    End If
End With


MajorTickMark-Eigenschaft

Gibt die Art der Hauptteilstriche für die angegebene Achse zurück oder legt sie fest. Kann eine der folgenden XlTickMark-Konstanten sein: xlTickMarkNone, xlTickMarkInside, xlTickMarkOutside oder xlTickMarkCross. Long Schreib-Lese-Zugriff.


Beispiel zur MajorTickMark-Eigenschaft

In diesem Beispiel werden der Größenachse in Chart1 außen liegende Hauptteilstriche zugewiesen.

Charts("Chart1").Axes(xlValue).MajorTickMark = xlTickMarkOutside


MajorUnit-Eigenschaft

Gibt die Haupteinheiten auf der Größenachse zurück oder legt sie fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MajorUnitIsAuto-Eigenschaft auf False gesetzt.

Mit der TickMarkSpacing-Eigenschaft können Sie den Abstand zwischen den Teilstrichen auf der Rubrikenachse festlegen.


MajorUnitIsAuto-Eigenschaft

True, wenn Microsoft Excel die Hilfseinheiten für die Größenachse automatisch berechnet. Nur gültig für die Größenachse. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MajorUnit-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MajorUnitIsAuto-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse in Chart1 automatisch berechnet.

With Charts("Chart1").Axes(xlValue)
    .MajorUnitIsAuto = True
    .MinorUnitIsAuto = True
End With


MajorUnitScale-Eigenschaft

Gibt das Hauptintervall der Skalierung auf der Rubrikenachse zurück oder legt es fest, wenn die CategoryType-Eigenschaft auf xlTimeScale gesetzt ist. Dies kann eine der folgenden XlTimeUnit-Konstanten sein: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.


Beispiel zur MajorUnitScale-Eigenschaft

In diesem Beispiel werden für die Rubrikenachse eine Zeitskala sowie ein Haupt- und ein Hilfsintervall festgelegt.

With Charts(1).Axes(xlCategory)
    .CategoryType = xlTimeScale
    .MajorUnit = 5
    .MajorUnitScale = xlDays
    .MinorUnit = 1
    .MinorUnitScale = xlDays
End With


ManualUpdate-Eigenschaft

True, wenn der PivotTable-Bericht lediglich auf Anfrage des Benutzers neu berechnet wird. Der Standardwert ist False. Boolean Lese- und Schreibzugriff.

Anmerkungen

Diese Eigenschaft wird unmittelbar nach dem Beenden des Programms und nach dem Ausführen der Anweisung im Fenster Direkt von Microsoft Visual Basic-Editor auf False festgelegt.


Beispiel zur ManualUpdate-Eigenschaft

In diesem Beispiel wird der PivotTable-Bericht nur auf Anfrage des Benutzers und vor dem Sichern der Arbeitsmappe neu berechnet.

With Worksheets(1).PivotTables("Pivot1")
    .ManualUpdate = True
    .UpdateBeforeSave = True
End With


MarginBottom-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem unteren Rand des Textrahmens und dem unteren Rand des beschrifteten Rechtecks der Form zurück, die den Text enthält, oder legt den Abstand fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginBottom-Eigenschaft

In diesem Beispiel wird in myDocument ein Rechteck eingefügt und mit Text versehen. Anschließend werden die Abstände des Textrahmens festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .AutoMargins = False
    .Characters.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginLeft-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem linken Rand des Textrahmens und dem linken Rand des beschrifteten Rechtecks der Form zurück, die den Text enthält, oder legt den Abstand fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginLeft-Eigenschaft

In diesem Beispiel wird in myDocument ein Rechteck eingefügt und mit Text versehen. Anschließend werden die Abstände des Textrahmens festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .AutoMargins = False
    .Characters.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginRight-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem rechten Rand des Textrahmens und dem rechten Rand des beschrifteten Rechtecks der Form zurück, die den Text enthält, oder legt den Abstand fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginRight-Eigenschaft

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .AutoMargins = False
    .Characters.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarginTop-Eigenschaft

Gibt den Abstand (in Punkt) zwischen dem oberen Rand des Textrahmens und dem oberen Rand des beschrifteten Rechtecks der Form zurück, die den Text enthält, oder legt den Abstand fest. Single Schreib-Lese-Zugriff.


Beispiel zur MarginTop-Eigenschaft

In diesem Beispiel wird in myDocument ein Rechteck eingefügt und mit Text versehen. Anschließend werden die Abstände des Textrahmens festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        0, 0, 250, 140).TextFrame
    .AutoMargins = False
    .Characters.Text = "Here is some test text"
    .MarginBottom = 0
    .MarginLeft = 100
    .MarginRight = 0
    .MarginTop = 20
End With


MarkerBackgroundColor-Eigenschaft

Gibt die Hintergrundfarbe für die Markierungen als RGB-Wert zurück oder legt sie fest. Nur für Linien-, Punkt- und Netzdiagramme. Long Schreib-Lese-Zugriff.


MarkerBackgroundColorIndex-Eigenschaft

Gibt die Hintergrundfarbe für Markierungen als Index der aktuellen Farbpalette zurück bzw. stellt diese ein. Zulässig ist auch eine der folgenden XlColorIndex-Konstanten: xlColorIndexAutomatic oder xlColorIndexNone. Kann nur Linien-, Punkt- und Netzdiagrammen zugewiesen werden. Long Schreib-Lese-Zugriff.

Anmerkungen

Die folgende Abbildung zeigt die Farbindexwerte der Standard-Farbpalette.

Farbindexwerte der Standard-Farbpalette


Beispiel zur MarkerBackgroundColorIndex-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe in Chart1 festgelegt.

With Charts("Chart1").SeriesCollection(1).Points(2)
    .MarkerBackgroundColorIndex = 4    ' green
    .MarkerForegroundColorIndex = 3    ' red
End With


MarkerForegroundColor-Eigenschaft

Gibt die Vordergrundfarbe für Markierungen als RGB-Wert zurück oder legt sie fest. Nur für Linien-, Punkt- und Netzdiagramme. Long Schreib-Lese-Zugriff.


MarkerForegroundColorIndex-Eigenschaft

Gibt die Vordergrundfarbe für Markierungen als Index der aktuellen Farbpalette zurück bzw. stellt sie ein. Zulässig ist auch eine der folgenden XlColorIndex-Konstanten: xlColorIndexAutomatic oder xlColorIndexNone. Nur für Linien-, Punkt- und Netzdiagramme. Long Schreib-Lese-Zugriff.

Anmerkungen

Die folgende Abbildung zeigt die Farbindexwerte der Standard-Farbpalette.

Farbindexwerte der Standard-Farbpalette


Beispiel zur MarkerForegroundColorIndex-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe in Chart1 festgelegt.

With Charts("Chart1").SeriesCollection(1).Points(2)
    .MarkerBackgroundColorIndex = 4    ' green
    .MarkerForegroundColorIndex = 3    ' red
End With


 MarkerSize-Eigenschaft

MarkerSize-Eigenschaft

Gibt die Größe der Datenpunktmarkierung in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur MarkerSize-Eigenschaft

In diesem Beispiel wird die Größe der Datenpunktmarkierung für alle Datenpunktmarkierungen der ersten Datenreihe festgelegt.

Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).MarkerSize = 10


MarkerStyle-Eigenschaft

Gibt die Art der Markierung für einen Datenpunkt oder für eine Datenreihe in einem Liniendiagramm, Punktdiagramm oder Netzdiagramm zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Zulässig ist eine der folgenden XlMarkerStyle-Konstanten:

Konstante | Beschreibung
xlMarkerStyleNone | Keine Markierung.
xlMarkerStyleAutomatic | Automatische Markierungen.
xlMarkerStyleSquare | Quadratische Markierungen.
xlMarkerStyleDiamond | Rautenförmige Markierungen.
xlMarkerStyleTriangle | Dreieckige Markierungen.
xlMarkerStyleX | Quadratische Markierungen mit einem X.
xlMarkerStyleStar | Quadratische Markierungen mit einem Sternchen.
xlMarkerStyleDot | Kurze Balken als Markierungen.
xlMarkerStyleDash | Lange Balken als Markierungen.
xlMarkerStyleCircle | Runde Markierungen.
xlMarkerStylePlus | Quadratische Markierungen mit einem Pluszeichen.
xlMarkerStylePicture | Bildmarkierungen.


Beispiel zur MarkerStyle-Eigenschaft

In diesem Beispiel wird die Art der Markierung für die erste Datenreihe in Chart1 festgelegt. Wenden Sie das Beispiel auf ein 2D-Liniendiagramm an.

Charts("Chart1").SeriesCollection(1) _
    .MarkerStyle = xlMarkerStyleCircle


MathCoprocessorAvailable-Eigenschaft

True, wenn Ihr System über einen mathematischen Koprozessor verfügt. Boolean Schreibgeschützt.


Beispiel zur MathCoprocessorAvailable-Eigenschaft

Dieses Beispiel zeigt ein Meldungsfeld an, wenn kein mathematischer Koprozessor vorhanden ist.

If Not Application.MathCoprocessorAvailable Then
    MsgBox "This macro requires a math coprocessor"
End If


Max-Eigenschaft

Gibt den Maximalwert eines Bildlaufleisten- oder Drehfeldbereichs zurück oder legt ihn fest. Die Bildlaufleiste oder das Drehfeld nehmen keine Werte an, die diesen Maximalwert übersteigen. Long Lese- und Schreibzugriff.

Weitere Informationen über die Tabellenfunktion Max in Visual Basic finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.

Anmerkungen

Der Wert der Max-Eigenschaft muss über dem der Min-Eigenschaft liegen.


MaxChange-Eigenschaft

Diese Eigenschaft gibt die maximal zulässige Anzahl an Änderungen zwischen jeder Iteration beim Auflösen von Zirkularbezügen in Microsoft Excel zurück bzw. stellt diese ein. Double Schreib-Lese-Zugriff.

Anmerkungen

Um hingegen die maximal zulässige Anzahl an Iterationen beim Auflösen von Zirkularbezügen in Microsoft Excel einzustellen, verwenden Sie die MaxIterations-Eigenschaft.


Beispiel zur MaxChange-Eigenschaft

Dieses Beispiel stellt die für jede Iteration maximal zulässige Anzahl von Änderungen auf 0,1 ein.

Application.MaxChange = 0.1


Maximum-Eigenschaft

Gibt die maximale Anzahl der Dateien in der Liste der zuletzt geöffneten Dateien zurück oder legt sie fest. Kann ein Wert von 0 (Null) bis 9 sein. Long Schreib-Lese-Zugriff.


MaximumScale-Eigenschaft

Gibt das Maximum auf der Größenachse zurück oder legt ihn fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MaximumScaleIsAuto-Eigenschaft auf False gesetzt.


MaximumScaleIsAuto-Eigenschaft

True, wenn Microsoft Excel den Maximalwert für die Größenachse berechnet. Nur gültig für die Größenachse. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MaximumScale-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MaximumScaleIsAuto-Eigenschaft

In diesem Beispiel werden der höchste und der niedrigste Wert für die Größenachse in Chart1 automatisch berechnet.

With Charts("Chart1").Axes(xlValue)
    .MinimumScaleIsAuto = True
    .MaximumScaleIsAuto = True
End With


MaxIterations-Eigenschaft

Gibt die maximale Anzahl von Iterationsschritten zurück, die bei der Auflösung von Zirkularbezügen durchlaufen werden können, oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Die MaxChange-Eigenschaft legt die maximale Änderung zwischen zwei Iterationsschritten fest, die Microsoft Excel beim Auflösen von Zirkularbezügen für jede Iteration verwendet.


Beispiel zur MaxIterations-Eigenschaft

In diesem Beispiel wird die maximale Anzahl von Iterationsschritten auf 1000 gesetzt.

Application.MaxIterations = 1000


MemoryFree-Eigenschaft

Gibt die Größe des Arbeitsspeichers in Byte zurück, der Microsoft Excel noch zur Verfügung steht. Long Schreibgeschützt.


Beispiel zur MemoryFree-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Größe des freien Arbeitsspeichers angezeigt.

MsgBox "Microsoft Excel has " & _
    Application.MemoryFree & " bytes free"


MemoryTotal-Eigenschaft

Gibt die Größe des gesamten Arbeitsspeichers in Byte zurück, der Microsoft Excel zur Verfügung steht, einschließlich des bereits belegten Speicherplatzes. Long Schreibgeschützt.

Anmerkungen

MemoryTotal hat den gleichen Wert wie die Summe von MemoryUsed und MemoryFree.


Beispiel zur MemoryTotal-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Größe des insgesamt zur Verfügung stehenden Arbeitsspeichers angezeigt.

MsgBox "Microsoft Excel has " & Application.MemoryTotal & _
    " total bytes available"


MemoryUsed-Eigenschaft

Application-Objekt: Gibt den Speicherplatz in Byte zurück, den Microsoft Excel gegenwärtig verwendet. Long Schreibgeschützt.

PivotCache- oder PivotField-Objekt: gibt den Speicherplatz in Byte zurück, den das Objekt gegenwärtig verwendet. Long Schreibgeschützt.

Anmerkungen

Bei PivotCache-Objekten gibt diese Eigenschaft den Übergangszustand des Cache zum Zeitpunkt der Abfrage wieder.

Ist dem PivotCache-Objekt kein PivotTable-Bericht zugeordnet, gibt diese Eigenschaft 0 (Null) zurück.


Beispiel zur MemoryUsed-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Byte-Anzahl angezeigt, die Microsoft Excel gegenwärtig verwendet.

MsgBox "Microsoft Excel is currently using " & _
    Application.MemoryUsed & " bytes"


MergeArea-Eigenschaft

Gibt ein Range-Objekt zurück, das den zusammengeführten Bereich mit der angegebenen Zelle darstellt. Wenn sich die angegebene Zelle nicht in einem zusammengeführten Bereich befindet, gibt diese Eigenschaft die angegebene Zelle zurück. Variant Schreibgeschützt.


Beispiel zur MergeArea-Eigenschaft

In diesem Beispiel wird der Wert des zusammengeführten Bereichs festgelegt, der die Zelle A3 enthält.

Set ma = Range("a3").MergeArea
If ma.Address = "$A$3" Then
    MsgBox "not merged"
Else
    ma.Cells(1, 1).Value = "42"
End If


MergeCells-Eigenschaft

True, wenn der Bereich oder die Formatvorlage zusammengeführte Zellen enthalten. Variant Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie einen Bereich mit zusammengeführten Zellen markieren, kann sich die daraus resultierende Markierung von der beabsichtigten Markierung unterscheiden. Prüfen Sie die Adresse des markierten Bereichs mit der Address-Eigenschaft.


Beispiel zur MergeCells-Eigenschaft

In diesem Beispiel wird der Wert des zusammengeführten Bereichs festgelegt, der die Zelle A3 enthält.

Set ma = Range("a3").MergeArea
If Range("a3").MergeCells Then
    ma.Cells(1, 1).Value = "42"
End If


MergeLabels-Eigenschaft

True, wenn für die Beschriftungen von Elementen der äußeren Zeile des angegebenen PivotTable-Berichts, von Spaltenelementen, von Teilergebnissen und Gesamtsummen zusammengeführte Zellen verwendet werden. Boolean Lese- und Schreibzugriff.


Beispiel zur MergeLabels-Eigenschaft

In diesem Beispiel werden für die Beschriftungen von Elementen der äußeren Zeile des ersten PivotTable-Berichts im ersten Tabellenblatt, von Spaltenelementen, von Teilergebnissen und Gesamtsummen zusammengeführte Zellen verwendet.

Worksheets(1).PivotTables(1).MergeLabels = True


Message-Eigenschaft

Gibt den Nachrichtentext des Verteilers zurück oder legt ihn fest. Dieser Text erscheint als Nachrichtentext des Verteilers, der zusammen mit der Arbeitsmappe weitergeleitet wird. String Schreib-Lese-Zugriff.


Beispiel zur Message-Eigenschaft

In diesem Beispiel wird MAPPE1.XLS nacheinander an drei Empfänger weitergeleitet.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
End With
Workbooks("BOOK1.XLS").Route


Min-Eigenschaft

Gibt den Minimalwert eines Bildlaufleisten- oder Drehfeldbereichs zurück oder legt ihn fest. Die Bildlaufleiste oder das Drehfeld nehmen keine Werte an, die unter diesem Minimalwert liegen. Long Lese- und Schreibzugriff.

Weitere Informationen über die Tabellenfunktion Min in Visual Basic finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.

Anmerkungen

Der Wert der Min-Eigenschaft muss unter dem der Max-Eigenschaft liegen.


MinimumScale-Eigenschaft

Gibt den Minimalwert auf der Größenachse zurück oder legt ihn fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MinimumScaleIsAuto-Eigenschaft auf False gesetzt.


MinimumScaleIsAuto-Eigenschaft

True, wenn Microsoft Excel das Minimum für die Größenachse berechnet. Nur gültig für die Größenachse. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MinimumScale-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MinimumScaleIsAuto-Eigenschaft

In diesem Beispiel werden der höchste und der niedrigste Wert für die Größenachse in Chart1 automatisch berechnet.

With Charts("Chart1").Axes(xlValue)
    .MinimumScaleIsAuto = True
    .MaximumScaleIsAuto = True
End With


MinorGridlines-Eigenschaft

Gibt ein Gridlines-Objekt zurück, das die Hilfsgitternetzlinien für die angegebene Achse darstellt. Nur Achsen in der Primärachsengruppe können Gitternetzlinien besitzen. Schreibgeschützt.


Beispiel zur MinorGridlines-Eigenschaft

In diesem Beispiel wird die Farbe der Hilfsgitternetzlinien der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    If .HasMinorGridlines Then
        .MinorGridlines.Border.ColorIndex = 5    ' set color to blue
    End If
End With


MinorTickMark-Eigenschaft

Gibt die Art der Hilfsteilstriche für die angegebene Achse zurück oder legt sie fest. Kann eine der folgenden XlTickMark-Konstanten sein: xlTickMarkNone, xlTickMarkInside, xlTickMarkOutside oder xlTickMarkCross. Long Schreib-Lese-Zugriff.


Beispiel zur MinorTickMark-Eigenschaft

In diesem Beispiel werden der Größenachse in Chart1 innen liegende Hilfsteilstriche zugewiesen.

Charts("Chart1").Axes(xlValue).MinorTickMark = xlTickMarkInside


MinorUnit-Eigenschaft

Gibt die Hilfseinheit auf der Größenachse zurück oder legt sie fest. Nur gültig für die Größenachse. Double Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft wird die MinorUnitIsAuto-Eigenschaft auf False gesetzt.

Mit der TickMarkSpacing-Eigenschaft können Sie den Abstand zwischen den Teilstrichen auf der Rubrikenachse festlegen.


MinorUnitIsAuto-Eigenschaft

True, wenn Microsoft Excel die Hilfseinheiten für die Größenachse berechnet. Nur gültig für die Größenachse. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Durch Festlegen der MinorUnit-Eigenschaft wird diese Eigenschaft auf False gesetzt.


Beispiel zur MinorUnitIsAuto-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse in Chart1 automatisch berechnet.

With Charts("Chart1").Axes(xlValue)
    .MajorUnitIsAuto = True
    .MinorUnitIsAuto = True
End With


MinorUnitScale-Eigenschaft

Gibt das Hilfsintervall der Skalierung auf der Rubrikenachse zurück oder legt es fest, wenn die CategoryType-Eigenschaft auf xlTimeScale gesetzt ist. Dies kann eine der folgenden XlTimeUnit-Konstanten sein: xlDays, xlMonths oder xlYears. Long Schreib-Lese-Zugriff.


Beispiel zur MinorUnitScale-Eigenschaft

In diesem Beispiel werden für die Rubrikenachse eine Zeitskala sowie ein Haupt- und ein Hilfsintervall festgelegt.

With Charts(1).Axes(xlCategory)
    .CategoryType = xlTimeScale
    .MajorUnit = 5
    .MajorUnitScale = xlDays
    .MinorUnit = 1
    .MinorUnitScale = xlDays
End With


MouseAvailable-Eigenschaft

True, wenn eine Maus angeschlossen ist. Boolean Schreibgeschützt


Beispiel zur MouseAvailable-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn keine Maus vorhanden ist.

If Application.MouseAvailable = False Then
    MsgBox "Your system does not have a mouse"
End If


MoveAfterReturn-Eigenschaft

True, wenn die aktive Zelle nach dem Drücken der EINGABETASTE verschoben wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie die MoveAfterReturnDirection-Eigenschaft, um anzugeben, in welche Richtung die aktive Zelle verschoben werden soll.


MoveAfterReturnDirection-Eigenschaft

Gibt zurück oder legt fest, wohin die aktive Zelle nach dem Drücken der EINGABETASTE verschoben wird. Kann eine der folgenden XlDirection-Konstanten sein: xlToLeft, xlToRight, xlUp oder xlDown. Long Schreib-Lese-Zugriff.

Anmerkungen

Gibt die MoveAfterReturn-Eigenschaft als Ergebnis False zurück, wird die Markierung nicht verschoben. Dies ist unabhängig davon, wie die MoveAfterReturnDirection-Eigenschaft festgelegt ist.


Beispiel zur MoveAfterReturnDirection-Eigenschaft

Im folgenden Beispiel wird die aktive Zelle nach dem Drücken der EINGABETASTE nach rechts verschoben.

Application.MoveAfterReturn = True
Application.MoveAfterReturnDirection = xlToRight


MultiSelect-Eigenschaft

Gibt den Auswahlmodus des angegebenen Listenfeldes zurück oder legt ihn fest. Dies kann eine der folgenden Konstanten sein: xlNone, xlSimple oder xlExtended. Long Schreib-Lese-Zugriff.

Anmerkungen

Einfache Auswahl (xlNone) ermöglicht nur das Markieren jeweils eines Elements. Durch Drücken der LEERTASTE oder Klicken der Maustaste wird die Markierung des momentan markierten Elements aufgehoben und das Element markiert, auf das geklickt wurde.

Schlichte Mehrfachauswahl (xlSimple) schaltet die Markierung eines Elements in der Liste um, wenn mit der Maus darauf geklickt wird oder wenn die LEERTASTE gedrückt wird, während das Element den Fokus hat. Dieser Modus ist bei Auswahllisten sinnvoll, in denen oft mehrere Elemente markiert werden.

Erweiterte Mehrfachauswahl (xlExtended) arbeitet normalerweise wie ein Listenfeld mit einfacher Auswahl, d. h. durch das Klicken auf ein Element wird die Markierung aller anderen Elemente aufgehoben. Wird beim Klicken mit der Maus oder beim Drücken der Pfeiltasten die UMSCHALTTASTE gedrückt gehalten, so werden alle Elemente zwischen dem anfänglich markierten und dem danach markierten Element als Block markiert. Wird beim Klicken mit der Maus STRG gedrückt, können einzelne unzusammenhängende Elemente markiert werden. Dieser Modus bietet sich an, wenn Mehrfachmarkierungen zwar erlaubt, aber nicht oft verwendet werden.

Mit den Eigenschaften Value oder ListIndex können Sie das markierte Element in einem Listenfeld mit einfacher Auswahl zurückgeben und festlegen.

Listenfelder mit Mehrfachauswahl können nicht über die LinkedCell-Eigenschaft verknüpft werden.


Beispiel zur MultiSelect-Eigenschaft

In diesem Beispiel wird ein Listenfeld mit schlichter Mehrfachauswahl erstellt.

Set lb = Worksheets(1).Shapes.AddFormControl(xlListBox, _
    Left:=10, Top:=10, Height:=100, Width:100)
lb.ControlFormat.MultiSelect = xlSimple


MultiUserEditing-Eigenschaft

True, wenn die Arbeitsmappe für gemeinsamen Zugriff freigegeben ist. Boolean Schreibgeschützt.

Anmerkungen

Um eine Arbeitsmappe im Freigabemodus zu speichern, verwenden Sie die SaveAs-Methode. Um die Arbeitsmappe vom Freigabemodus in den Exklusivmodus zu setzen, verwenden Sie die ExclusiveAccess-Methode.


Beispiel zur MultiUserEditing-Eigenschaft

Im folgenden Beispiel wird festgestellt, ob die aktive Arbeitsmappe im Exklusivmodus geöffnet ist. Ist dies der Fall, wird sie im Freigabemodus gespeichert.

If Not ActiveWorkbook.MultiUserEditing Then
    ActiveWorkbook.SaveAs fileName:=ActiveWorkbook.FullName, _
        accessMode:=xlShared
End If


 Name-Eigenschaft

Name-Eigenschaft

Gibt den Namen des Objekts zurück oder setzt ihn fest. Der Name eines Range-Objekts ist ein Name-Objekt. Für alle anderen Objekte besteht der Name aus einer Zeichenfolge.

Die folgende Tabelle enthält Beispielwerte der Name-Eigenschaft und verwandter Eigenschaften. Dabei wird von einer OLAP-Datenquelle mit dem eindeutigen Namen "[Europa].[Frankreich].[Paris]" und einer Nicht-OLAP-Datenquelle mit dem Elementnamen "Paris" ausgegangen.

Eigenschaft | Wert (OLAP-Datenquelle) | Wert (Nicht-OLAP-Datenquelle)
Caption | Paris | Paris
Name | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | Paris
SourceName | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | (Identisch mit SQL-Eigenschaftenwert, Schreibgeschützt)
Value | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | Paris

Wenn Sie einen Index in der PivotItems-Auflistung angeben, können Sie die in der folgende Tabelle gezeigte Syntax verwenden.

Syntax (OLAP-Datenquelle) | Syntax (Nicht-OLAP-Datenquelle)
Ausdruck.PivotItems("[Europa].[Frankreich].[Paris]") | Ausdruck.PivotItems("Paris")

Wenn die Item-Eigenschaft für einen Verweis auf ein bestimmtes Mitglied einer Auflistung verwendet wird, können Sie die in der folgenden Tabelle aufgeführten Textindexnamen verwenden.

Name (OLAP-Datenquelle) | Name (Nicht-OLAP-Datenquelle)
[Europa].[Frankreich].[Paris] | Paris


NameIsAuto-Eigenschaft

True, wenn Microsoft Excel den Namen der Trendlinie automatisch festlegt. Boolean Schreib-Lese-Zugriff.


Beispiel zur NameIsAuto-Eigenschaft

In diesem Beispiel wird der Name der ersten Trendlinie in Chart1 automatisch festgelegt. Wenden Sie dieses Beispiel auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

Charts("Chart1").SeriesCollection(1) _
    .Trendlines(1).NameIsAuto = True


NameLocal-Eigenschaft

Gibt den Namen des Objekts in der Sprache des Benutzers zurück oder legt ihn fest. String Schreib-Lese-Zugriff für das Objekt Name, String Schreibgeschützt für das Objekt Style.

Anmerkungen

Wenn es sich um eine integrierte Formatvorlage handelt, gibt diese Eigenschaft den Namen der Formatvorlage in der Sprache zurück, die im aktuellen Gebietsschema festgelegt wurde.


Beispiel zur NameLocal-Eigenschaft

In diesem Beispiel werden der Name und der lokalisierte Name der ersten Formatvorlage in der aktiven Arbeitsmappe angezeigt.

With ActiveWorkbook.Styles(1)
    MsgBox "The name of the style is " & .Name
    MsgBox "The localized name of the style is " & .NameLocal
End With


Names-Eigenschaft

Application-Objekt: Gibt eine Names-Auflistung aller Namen der aktiven Arbeitsmappe zurück. Schreibgeschützt.

Workbook-Objekt: Gibt eine Names-Auflistung aller Namen der angegebenen Arbeitsmappe (einschließlich aller tabellenblattspezifischen Namen) zurück. Schreibgeschützt.

Worksheet-Objekt: Gibt eine Names-Auflistung aller tabellenblattspezifischen Namen (Namen mit dem Präfix "TabellenblattName!") zurück. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne Objektkennzeichner hat die gleiche Funktion wie ActiveWorkbook.Names.


Beispiel zur Names-Eigenschaft

In diesem Beispiel wird der Name "myName" für Zelle A1 in Sheet1 definiert.

ActiveWorkbook.Names.Add Name:="myName", RefersToR1C1:= _
    "=Sheet1!R1C1"


Native-Eigenschaft

Gibt einen providerspezifischen numerischen Wert zurück, der einen Fehler angibt. Die Fehlernummer entspricht einer Fehlerbedingung, die nach der letzten OLE DB-Abfrage aufgetreten ist. Long Schreibgeschützt.


Beispiel zur Native-Eigenschaft

In diesem Beispiel werden die systemspezifische Fehlernummer sowie weitere Fehlerinformationen angezeigt, die von der letzten OLE DB-Abfrage zurückgegeben wurden.

Set objEr = Application.OLEDBErrors(1)
MsgBox "The following error occurred:" & _
    objEr.Number & ", " & objEr.Native & ", " & _
    objEr.ErrorString & " : " & objEr.SqlState


NetworkTemplatesPath-Eigenschaft

Gibt den Netzwerkpfad zurück, unter dem Vorlagen gespeichert sind. Existiert der Netzwerkpfad nicht, gibt die Eigenschaft eine leere Zeichenfolge zurück. String Schreibgeschützt.


Beispiel zur NetworkTemplatesPath-Eigenschaft

In diesem Beispiel wird der Netzwerkpfad zurückgegeben, unter dem Vorlagen gespeichert sind.

Msgbox Application.NetworkTemplatesPath


Next-Eigenschaft

Gibt ein Chart-, Range- oder Worksheet-Objekt zurück, das das nächste Blatt oder die nächste Zelle darstellt. Schreibgeschützt.

Anmerkungen

Ist das Objekt ein Bereich, so emuliert diese Eigenschaft die TAB-Taste. Allerdings gibt die Eigenschaft die nächste Zelle zurück, ohne sie zu markieren.

In einem geschützten Blatt gibt diese Eigenschaft die nächste nicht gesperrte Zelle zurück. In einem ungeschützten Blatt wird immer die Zelle unmittelbar rechts von der angegebenen Zelle zurückgegeben.


Beispiel zur Next-Eigenschaft

In diesem Beispiel wird die nächste nicht gesperrte Zelle in Sheet1 markiert. Wenn Sheet1 nicht geschützt ist, handelt es sich um die Zelle unmittelbar rechts neben der aktiven Zelle.

Worksheets("Sheet1").Activate
ActiveCell.Next.Select


Nodes-Eigenschaft

Gibt eine ShapeNodes-Auflistung zurück, die die geometrische Beschreibung der angegebenen Form darstellt. Betrifft Shape- oder ShapeRange-Objekte, die eine Freihandzeichnung darstellen.


Beispiel zur Nodes-Eigenschaft

In diesem Beispiel wird in myDocument nach dem vierten Knoten in der dritten Form ein Übergangsknoten mit einem gekrümmten Abschnitt eingefügt. Bei der dritten Form muss es sich um eine Freihandzeichnung mit mindestens vier Knoten handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    .Insert 4, msoSegmentCurve, msoEditingSmooth, 210, 100
End With


NormalizedHeight-Eigenschaft

True, wenn alle Zeichen (sowohl Großbuchstaben als auch Kleinbuchstaben) in der angegebenen WordArt die gleiche Höhe besitzen. Long Schreib-Lese-Zugriff.


Beispiel zur NormalizedHeight-Eigenschaft

In diesem Beispiel wird in myDocument eine WordArt mit dem Text "Test Effect" eingefügt und mit dem Namen "texteff1" versehen. Anschließend weist der Code allen Zeichen der Form, die den Namen "texteff1" besitzen, die gleiche Höhe zu.

Set myDocument = Worksheets(1)
myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, _
    Text:="Test Effect", FontName:="Courier New", _
    FontSize:=44, FontBold:=True, _
    FontItalic:=False, Left:=10, Top:=10).Name = "texteff1"
myDocument.Shapes("texteff1").TextEffect.NormalizedHeight = True


NullString-Eigenschaft

Gibt die in Zellen, die Nullwerte enthalten, angezeigte Zeichenfolge zurück oder legt sie fest, wenn die DisplayNullString-Eigenschaft den Wert True besitzt. Der Standardwert ist eine leere Zeichenfolge (""). String Schreib-Lese-Zugriff.


Beispiel zur NullString-Eigenschaft

In diesem Beispiel wird in dem PivotTable-Bericht in Zellen, die einen Nullwert enthalten, "NA" angezeigt.

With Worksheets(1).PivotTables("Pivot1")
    .NullString = "NA"
    .DisplayNullString = True
End With


Number-Eigenschaft

Gibt einen numerischen Wert zurück, der einen Fehler angibt. Die Fehlernummer entspricht einer eindeutigen Trapnummer, die einer Fehlerbedingung entspricht, die nach der letzten OLE DB-Abfrage aufgetreten ist. Schreibgeschützt Long.


NumberFormat-Eigenschaft

Gibt den Formatierungscode für das Objekt zurück oder legt ihn fest. Gibt Null zurück, wenn nicht alle Zellen im angegebenen Bereich dasselbe Zahlenformat besitzen. Variant Lese- und Schreibzugriff für das Range-Objekt, String Lese- und Schreibzugriff für alle anderen Objekte.

Anmerkungen

Beim PivotField-Objekt kann die NumberFormat-Eigenschaft nur für ein Datenfeld festgelegt werden.

Der Formatierungscode hat dieselbe Zeichenfolge wie die Option Formatierungscode im Dialogfeld Zellen formatieren. Die Zeichenfolge des Formatierungscodes bei der Format-Funktion ist anders als bei den Eigenschaften NumberFormat und NumberFormatLocal.


NumberFormatLinked-Eigenschaft

True, wenn das Zahlenformat mit den Zellen verknüpft ist (so dass das Zahlenformat in den Beschriftungen ebenfalls geändert wird, sobald es in den Zellen geändert wird). Boolean Schreib-Lese-Zugriff.


Beispiel zur NumberFormatLinked-Eigenschaft

In diesem Beispiel wird das Zahlenformat der Teilstrichbeschriftungen mit den entsprechenden Zellen für die Größenachse in Chart1 verknüpft.

Charts("Chart1").Axes(xlValue).TickLabels.NumberFormatLinked = True


NumberFormatLocal-Eigenschaft

Gibt den Formatierungscode des Objekts als Zeichenfolge in der Sprache des Benutzers zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Die Format-Funktion verwendet andere Zeichenfolgen im Formatierungscode als die Eigenschaften NumberFormat und NumberFormatLocal.


Beispiel zur NumberFormatLocal-Eigenschaft

In diesem Beispiel wird das Zahlenformat für Zelle A1 in Sheet1 in der Sprache des Benutzers angezeigt.

MsgBox "The number format for cell A1 is " & _
    Worksheets("Sheet1").Range("A1").NumberFormatLocal


Object-Eigenschaft

Gibt das OLE-Automatisierung-Objekt zurück, das mit diesem OLE-Objekt verknüpft ist. Object Schreibgeschützt.


Beispiel zur Object-Eigenschaft

In diesem Beispiel wird Text am Anfang eines eingebetteten Microsoft Word-Dokuments in Sheet1 eingefügt. Die drei Anweisungen in der With-Kontrollstruktur sind WordBasic-Anweisungen.

Set wordObj = Worksheets("Sheet1").OLEObjects(1)
wordObj.Activate
With wordObj.Object.Application.WordBasic
    .StartOfDocument
    .Insert "This is the beginning"
    .InsertPara
End With


Obscured-Eigenschaft

True, wenn der Schatten der angegebenen Form gefüllt und durch sie verdeckt angezeigt wird, auch wenn die Form selbst keine Füllung besitzt. False, wenn der Schatten keine Füllung besitzt und seine Kontur durch die Form zu sehen ist, wenn die Form keine Füllung besitzt. Long Schreib-Lese-Zugriff.


Beispiel zur Obscured-Eigenschaft

In diesem Beispiel wird die horizontale und vertikale Versetzung des Schattens der dritten Form in myDocument festgelegt. Der Schatten wird 5 Punkt nach rechts und 3 Punkt über die Form versetzt. Besitzt die Form noch keinen Schatten, so fügt ihr dieses Beispiel einen hinzu. Der Schatten wird gefüllt und von der Form verdeckt, auch wenn diese keine Füllung besitzt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
    .Obscured = True
End With


ODBCErrors-Eigenschaft

Gibt eine ODBCErrors-Auflistung zurück, die alle ODBC-Fehler enthält, die durch die zuletzt durchgeführte Operation der Abfragetabelle oder des PivotTable-Berichts ausgelöst wurden. Schreibgeschützt.

Weitere Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Werden mehrere Abfragen gleichzeitig ausgeführt , enthält die ODBCErrors-Auflistung die ODBC-Fehler der Abfrage, die zuletzt beendet wurde.


Beispiel zur ODBCErrors-Eigenschaft

In diesem Beispiel wird die erste Abfragetabelle aktualisiert und alle auftretenden ODBC-Fehler angezeigt.

With Worksheets(1).QueryTables(1)
    .Refresh
    Set errs = Application.ODBCErrors
    If errs.Count > 0 Then
        Set r = .Destination.Cells(1)
        r.Value = "The following errors occurred:"
        c = 0
        For Each er In errs
            c = c + 1
            r.offset(c, 0).value = er.ErrorString
            r.offset(c, 1).value = er.SqlState
        Next
    Else
        MsgBox "Query complete: all records returned."
    End If
End With


ODBCTimeout-Eigenschaft

Gibt die zeitliche Begrenzung der ODBC-Abfrage in Sekunden zurück oder legt sie fest. Der Standardwert ist 45 Sekunden. Long Schreib-Lese-Zugriff.

Anmerkungen

Der Wert 0 (Null) setzt die zeitliche Begrenzung auf unendlich.


Beispiel zur ODBCTimeout-Eigenschaft

In diesem Beispiel wird für die ODBC-Abfrage eine zeitliche Begrenzung von 15 Sekunden festgelegt.

Application.ODBCTimeout = 15


Offset-Eigenschaft

Um weitere Informationen zu dieser Eigenschaft zu erhalten, klicken Sie auf einen der folgenden Auflistungsnamen:

Range

TickLabels


Offset-Eigenschaft (Range-Objekt)

Gibt ein Range-Objekt zurück, das einen Bereich darstellt, der gegenüber dem angegebenen Bereich versetzt ist. Schreibgeschützt.

Syntax

Ausdruck.Offset(RowOffset, ColumnOffset)

Ausdruck Ein erforderlicher Ausdruck, der ein Range-Objekt zurückgibt.

RowOffset Variant optional. Die Anzahl der Zeilen (positiv, negativ oder 0 (Null)), um die der Bereich versetzt werden soll. Bei positiven Werten erfolgt ein Versatz nach unten, bei negativen Werten ein Versatz nach oben. Der Standardwert ist 0.

ColumnOffset Variant optional. Die Anzahl der Spalten (positiv, negativ oder 0 (Null)), um die der Bereich versetzt werden soll. Bei positiven Werten erfolgt ein Versatz nach rechts, bei negativen Werten ein Versatz nach links. Der Standardwert ist 0.


Beispiel zur Offset-Eigenschaft (Range-Objekt)

In diesem Beispiel wird die Zeile, die sich drei Spalten rechts und drei Zeilen unter der aktiven Zelle in Sheet1 befindet, aktiviert.

Worksheets("Sheet1").Activate
ActiveCell.Offset(rowOffset:=3, columnOffset:=3).Activate

In diesem Beispiel wird davon ausgegangen, dass Sheet1 eine Tabelle mit einer Überschrift enthält. In dem Beispiel wird die Tabelle markiert, ohne die Überschrift zu markieren. Die aktive Zelle muss sich an einer beliebigen Stelle in der Tabelle befinden, bevor das Beispiel ausgeführt wird.

Set tbl = ActiveCell.CurrentRegion
tbl.Offset(1, 0).Resize(tbl.Rows.Count - 1, _
    tbl.Columns.Count).Select


Offset-Eigenschaft (TickLabels-Auflistung)

Gibt den Abstand zwischen den Beschriftungsebenen und den Abstand zwischen der ersten Ebene und der Achsenlinie zurück oder legt diese fest. Der Standardabstand beträgt 100 Prozent und stellt den Standardabstand zwischen den Achsenbeschriftungen und der Achsenlinie dar. Der Wert kann eine ganze Prozentzahl von 0 bis 1000 sein, relativ zur Schriftgröße der Achsenbeschriftung. Long Schreib-Lese-Zugriff.


Beispiel zur Offset-Eigenschaft (TickLabels-Auflistung)

In diesem Beispiel wird der Beschriftungsabstand der Größenachse in Chart1 auf das Doppelte der aktuellen Einstellung festgelegt, falls der Offset kleiner als 500 ist.

With Charts("Chart1").Axes(xlValue).TickLabels
    If .Offset < 500 then
        .Offset = .Offset * 2
    End If
End With


OffsetX-Eigenschaft

Gibt die horizontale Versetzung des Schattens (in Punkt) von der angegebenen Form an. Ein positiver Wert versetzt den Schatten auf die rechte Seite der Form, ein negativer Wert auf deren linke. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie einen Schatten von seiner aktuellen Position aus horizontal oder vertikal versetzen möchten, verwenden Sie die Methoden IncrementOffsetX oder IncrementOffsetY.


Beispiel zur OffsetX-Eigenschaft

In diesem Beispiel werden die horizontale und die vertikale Versetzung des Schattens der dritten Form in myDocument festgelegt. Der Schatten wird 5 Punkt nach rechts und 3 Punkt über die Form versetzt. Besitzt die Form noch keinen Schatten, fügt ihr dieses Beispiel einen hinzu.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OffsetY-Eigenschaft

Gibt die vertikale Versetzung des Schattens (in Punkt) von der angegebenen Form an. Ein positiver Wert versetzt den Schatten auf die rechte Seite der Form, ein negativer Wert auf deren linke. Single Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie einen Schatten von seiner aktuellen Position aus horizontal oder vertikal versetzen möchten, verwenden Sie die Methoden IncrementOffsetX oder IncrementOffsetY.


Beispiel zur OffsetY-Eigenschaft

In diesem Beispiel werden die horizontale und die vertikale Versetzung des Schattens der dritten Form in myDocument festgelegt. Der Schatten wird 5 Punkt nach rechts und 3 Punkt über die Form versetzt. Besitzt die Form noch keinen Schatten, fügt ihr dieses Beispiel einen hinzu.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Shadow
    .Visible = True
    .OffsetX = 5
    .OffsetY = -3
End With


OLEDBErrors-Eigenschaft

Gibt die OLEDBErrors-Auflistung zurück, die die Fehlerinformationen darstellt, die von der letzten OLE DB-Abfrage zurückgegeben wurden. Schreibgeschützt.


Beispiel zur OLEDBErrors-Eigenschaft

In diesem Beispiel werden die Fehlerbeschreibung und der Wert der SqlState-Eigenschaft für einen OLE DB-Fehler angezeigt, der von der letzten OLE DB-Abfrage zurückgegeben wurde.

Set objEr = Application.OLEDBErrors.Item(1)
MsgBox "The following error occurred:" & _
    objEr.ErrorString & " : " & objEr.SqlState


OLEFormat-Eigenschaft

Gibt ein OLEFormat-Objekt zurück, das OLE-Objekteigenschaften enthält. Schreibgeschützt.


Beispiel zur OLEFormat-Eigenschaft

In diesem Beispiel wird ein OLE-Objekt aktiviert. Falls Shapes(1) kein eingebettetes OLE-Objekt darstellt, schlägt dieses Beispiel fehl.

Worksheets(1).Shapes(1).OLEFormat.Activate


OLEType-Eigenschaft

Gibt den OLE-Objekttyp zurück. Kann eine der folgenden XlOLEType-Konstanten sein: xlOLELink oder xlOLEEmbed. Gibt xlOLELink zurück, wenn das Objekt verknüpft ist (es existiert außerhalb der Datei), bzw. gibt xlOLEEmbed zurück, wenn das Objekt eingebettet ist (es ist vollständig in der Datei enthalten). Long Schreibgeschützt.


Beispiel zur OLEType-Eigenschaft

In diesem Beispiel wird eine Liste der Verknüpfungstypen für die OLE-Objekte in Sheet1 erstellt. Diese Liste wird in einem neuen Tabellenblatt angezeigt, das das Makro zuvor erstellt hat.

Set newSheet = Worksheets.Add
i = 2
newSheet.Range("A1").Value = "Name"
newSheet.Range("B1").Value = "Link Type"
For Each obj In Worksheets("Sheet1").OLEObjects
    newSheet.Cells(i, 1).Value = obj.Name
    If obj.OLEType = xlOLELink Then
        newSheet.Cells(i, 2) = "Linked"
    Else
        newSheet.Cells(i, 2) = "Embedded"
    End If
    i = i + 1
Next


On-Eigenschaft

True, wenn der angegebene Filter aktiviert ist. Boolean Schreibgeschützt.


OnAction-Eigenschaft

Gibt den Namen des Makros, das ausgeführt wird, wenn Sie auf das Objekt klicken, zurück oder legt ihn fest. String Lese- und Schreibzugriff.

Anmerkungen

Durch Festlegen dieser Eigenschaft für ein Menüelement werden alle benutzerdefinierten, für das Menüelement eingerichteten Hilfeinformationen mit den für das zugewiesene Makro eingerichteten Informationen überschrieben.


Beispiel zur OnAction-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel immer die ShapeClick-Prozedur ausführt, wenn auf Form eins geklickt wird.

Worksheets(1).Shapes(1).OnAction = "ShapeClick"


OnWindow-Eigenschaft

Gibt den Namen der Prozedur zurück, die ausgeführt wird, wenn ein Fenster aktiviert wird, oder legt ihn fest. String Lese- und Schreibzugriff.

Anmerkungen

Die von dieser Eigenschaft angegebene Prozedur wird nicht ausgeführt, wenn durch eine andere Prozedur zu dem Fenster gewechselt oder wenn der Befehl zum Wechseln des Fensters über einen DDE-Kanal erhalten wird. Die Prozedur reagiert nur auf Benutzeraktionen, wie dem Klicken mit der Maus auf ein Fenster, der Wahl des Befehls Gehe zu aus dem Menü Bearbeiten usw.

Wenn für ein Tabellenblatt oder ein Makroblatt ein Auto_aktivieren- oder Auto_deaktivieren-Makro festgelegt ist, werden diese Makros im Anschluss an die Prozedur ausgeführt, die durch die OnWindow-Eigenschaft festgelegt wurde.


Beispiel zur OnWindow-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Prozedur "WindowActivate" immer ausgeführt wird, wenn das erste Fenster aktiviert wird.

ThisWorkbook.Windows(1).OnWindow = "WindowActivate"


OperatingSystem-Eigenschaft

Gibt den Namen und die Versionsnummer des aktuellen Betriebssystems zurück, wie z. B. "Windows 4.00 (32 Bit)" oder "Macintosh 7.00". String Schreibgeschützt.


Beispiel zur OperatingSystem-Eigenschaft

In diesem Beispiel wird der Name des Betriebssystems angezeigt.

MsgBox "Microsoft Excel is using " & Application.OperatingSystem


Operator-Eigenschaft

FormatCondition- oder Validation-Objekt: Gibt den Operator für das bedingte Format bzw. die Datenüberprüfung zurück. Kann eine der folgenden XlFormatConditionOperator-Konstanten sein: xlBetween, xlEqual, xlGreater, xlGreaterEqual, xlLess, xlLessEqual, xlNotBetween oder xlNotEqual. Long Schreibgeschützt.

Filter-Objekt: Gibt den Operator zurück, der die beiden Kriterien verbindet, die von dem angegebenen Filter angewendet werden. Kann eine der folgenden XlAutoFilterOperator-Konstanten sein: xlAnd, xlBottom10Items, xlBottom10Percent, xlOr, xlTop10Items oder xlTop10Percent. Long Schreibgeschützt.


Beispiel zur Operator-Eigenschaft

In diesem Beispiel wird die Formel für das erste bedingte Format der Zellen E1:E10 geändert, wenn in der Formel "weniger als 5" angegeben ist.

With Worksheets(1).Range("e1:e10").FormatConditions(1)
    If .Operator = xlLess And .Formula1 = "5" Then
        .Modify xlCellValue, xlBetween, "5", "15"
    End If
End With


OptimizeCache-Eigenschaft

True, wenn der PivotTable-Cache beim Aufbau optimiert wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die Optimierung des Caches führt zu zusätzlichen Abfragen und vermindert die Anfangsleistung des PivotTable-Berichts.

Bei OLE DB-Datenquellen ist diese Eigenschaft schreibgeschützt und gibt immer False zurück.


Beispiel zur OptimizeCache-Eigenschaft

In diesem Beispiel wird der PivotTable-Cache des ersten PivotTable-Berichts im ersten Tabellenblatt beim Aufbau optimiert.

Worksheets(1).PivotTables("Pivot1") _
    .PivotCache.OptimizeCache = True


Order-Eigenschaft

PageSetup-Objekt: Gibt die Reihenfolge zurück oder legt diese fest, in der Microsoft Excel die Seiten eines großen Tabellenblattes beim Drucken nummeriert. Es stehen folgende XlOrder-Konstanten zur Verfügung: xlDownThenOver und xlOverThenDown. Nur für Tabellenblätter gültig. Long Schreib-Lese-Zugriff.

Trendline-Objekt: Gibt die Reihenfolge der Trendlinie zurück oder legt diese fest (eine Ganzzahl größer als 1), wenn es sich beim Typ um xlPolynomial handelt. Long Schreib-Lese-Zugriff.


Beispiel zur Order-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken in Seiten aufgeteilt. Die Seiten werden von links nach rechts und von oben nach unten nummeriert und gedruckt.

Worksheets("Sheet1").PageSetup.Order = xlOverThenDown


OrganizationName-Eigenschaft

Gibt den Namen der registrierten Organisation (als Zeichenfolge) zurück. String Schreibgeschützt.


Beispiel zur OrganizationName-Eigenschaft

In diesem Beispiel wird der Name der registrierten Organisation angezeigt.

MsgBox "The registered organization is " & _
    Application.OrganizationName


OrganizeInFolder-Eigenschaft

True, wenn alle Unterstützungsdateien, wie z. B. Hintergrundstrukturen und Grafiken, beim Speichern des angegebenen Dokuments als Webseite in einem separaten Ordner angeordnet werden. False, wenn die Unterstützungsdateien im gleichen Ordner wie die Webseite gespeichert werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Der neue Ordner wird in dem Ordner erstellt, in dem die Webseite gespeichert wurde, und nach dem Dokument benannt. Werden lange Dateinamen verwendet, wird ein Suffix zu dem Ordnernamen hinzugefügt. Die FolderSuffix-Eigenschaft gibt den Ordnersuffix für die ausgewählte oder installierte Sprachunterstützung bzw. den Standardordnersuffix zurück.

Wenn Sie ein Dokument speichern, das vorher gespeichert wurde und dort die OrganizeInFolder-Eigenschaft auf einen anderen Wert eingestellt war, verschiebt Microsoft Excel die Unterstützungsdateien automatisch in oder aus dem Ordner.

Wenn Sie keine langen Dateinamen verwenden (d. h., wenn die UseLongFileNames-Eigenschaft auf False eingestellt ist), speichert Microsoft Excel alle Unterstützungsdateien in einem separaten Ordner. Die Dateien können nicht im gleichen Ordner gespeichert werden wie die Webseite.


Beispiel zur OrganizeInFolder-Eigenschaft

In diesem Beispiel wird angegeben, dass alle Unterstützungsdateien beim Speichern des Dokuments als Webseite im gleichen Ordner gespeichert werden.

Application.DefaultWebOptions.OrganizeInFolder = False


 Orientation-Eigenschaft

Orientation-Eigenschaft

Gibt die Ausrichtung des Objekts zurück oder legt sie fest, entsprechend der folgenden Liste. Long Schreib-Lese-Zugriff.

Objekt | Ausrichtung
ChartObject, ChartObjects | Platzierung des eingebetteten Diagramms. Dies kann eine der folgenden XlPlacement-Konstanten sein: xlFreeFloating, xlMove oder xlMoveAndSize.
PageSetup | Hoch- oder Querformat beim Drucken. Dies kann eine der folgenden XlPageOrientation-Konstanten sein: xlLandscape oder xlPortrait.
PivotField, CubeFields | Die Position des Feldes in dem angegebenen PivotTable-Bericht. Dies kann eine der folgenden XlPivotFieldOrientation-Konstanten sein: xlColumnField, xlDataField, xlHidden, xlPageField oder xlRowField.
AxisTitle, ChartTitle, DataLabel, DisplayUnitLabel, Range, Style, TextFrame | Die Textausrichtung. Dies kann eine Ganzzahl von – 90 bis 90 Grad oder eine der folgenden XlOrientation-Konstanten sein: xlDownward, xlHorizontal, xlUpward oder xlVertical.
TickLabels | Die Textausrichtung. Dies kann eine Ganzzahl zwischen – 90 bis 90 Grad oder eine der folgenden XlTickLabelOrientation-Konstanten sein: xlTickLabelOrientationAutomatic, xlTickLabelOrientationDownward, xlTickLabelOrientationHorizontal, xlTickLabelOrientationUpward oder xlTickLabelOrientationVertical.

Anmerkungen

Wenn diese Eigenschaft bei OLAP-Datenquellen für ein Feld in einer Hierarchie festgelegt wird, wird ebenfalls die Ausrichtung der anderen Felder in derselben Hierarchie festgelegt. Dimensionsfelder können nur in Zeilen-, Spalten- und Seitenfeldbereichen des PivotTable-Berichts angeordnet sein. Measurefelder dagegen können nur in im Datenbereich angeordnet sein. Wird eine Hierarchie oder ein Datenfeld auf xlHidden eingestellt, wird die Hierarchie oder das Feld aus dem PivotTable-Bericht entfernt.


Beispiel zur Orientation-Eigenschaft

In diesem Beispiel wird die Ausrichtung für das Feld "BESTELLDATUM" angezeigt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
Set pvtField = pvtTable.PivotFields("ORDER_DATE")
Select Case pvtField.Orientation
    Case xlHidden
        MsgBox "Hidden field"
    Case xlRowField
        MsgBox "Row field"
    Case xlColumnField
        MsgBox "Column field"
    Case xlPageField
        MsgBox "Page field"
    Case xlDataField
        MsgBox "Data field"
End Select

In diesem Beispiel wird festgelegt, dass Sheet1 im Querformat gedruckt wird.

Worksheets("Sheet1").PageSetup.Orientation = xlLandscape


Outline-Eigenschaft

Gibt ein Outline-Objekt zurück, das die Gliederung für die angegebene Tabelle darstellt. Schreibgeschützt.


OutlineFont-Eigenschaft

True, falls die Schriftart eine Konturschriftart ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat in Microsoft Windows keine Wirkung, jedoch bleibt ihr Wert erhalten (er kann festgelegt und zurückgegeben werden).


Beispiel zur OutlineFont-Eigenschaft

In diesem Beispiel wird Zelle A1 in Sheet1 eine Konturschriftart zugewiesen.

Worksheets("Sheet1").Range("A1").Font.OutlineFont = True


OutlineLevel-Eigenschaft

Gibt die aktuelle Zeilen- oder Spalten-Gliederungsebene für die angegebene Zeile oder Spalte zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.

Anmerkungen

Ebene1 ist die äußerste Gliederungsebene.


Beispiel zur OutlineLevel-Eigenschaft

In diesem Beispiel wird die Gliederungsebene für die zweite Zeile in Sheet1 festgelegt.

Worksheets("Sheet1").Rows(2).OutlineLevel = 1


Overlap-Eigenschaft

Bestimmt die Positionierung von Balken und Säulen. Zulässige Werte liegen zwischen -100 und 100. Nur gültig für 2D-Balken- und 2D-Säulendiagramme. Long Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft auf -100 festgelegt, dann werden die Balken mit dem Abstand einer Balkenbreite positioniert. Beträgt der Wert 0, so besteht kein Abstand zwischen den Balken (die Balken folgen direkt nacheinander). Beträgt der Wert 100, werden die Balken genau übereinander positioniert.


Beispiel zur Overlap-Eigenschaft

In diesem Beispiel wird der ersten Diagrammgruppe der Überlappungswert – 50 zugewiesen. Es ist sinnvoll, dieses Makro auf ein 2D – Säulendiagramm mit mindestens zwei Datenreihen anzuwenden.

Charts("Chart1").ChartGroups(1).Overlap = -50


PageBreak-Eigenschaft

Gibt die Position eines Seitenumbruchs zurück oder legt sie fest. Dies kann eine der folgenden XlPageBreak-Konstanten sein: xlPageBreakAutomatic, xlPageBreakManual oder xlPageBreakNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Mit dieser Eigenschaft kann zwar die Position automatischer oder manueller Seitenumbrüche zurückgegeben werden, allerdings können Sie nur manuelle Seitenumbrüche selbst festlegen (die Eigenschaft kann nur auf xlPageBreakManual oder xlPageBreakNone eingestellt werden).

Wenn Sie alle manuellen Seitenumbrüche aus dem Tabellenblatt entfernen möchten, weisen Sie Cells.PageBreak den Wert xlPageBreakNone zu.


Beispiel zur PageBreak-Eigenschaft

In diesem Beispiel wird ein manueller Seitenumbruch oberhalb von Zeile 25 in Sheet1 eingefügt.

Worksheets("Sheet1").Rows(25).PageBreak = xlPageBreakManual

In diesem Beispiel wird ein manueller Seitenumbruch links von Spalte J in Sheet1 eingefügt.

Worksheets("Sheet1").Columns("J").PageBreak = xlPageBreakManual

In diesem Beispiel werden die beiden in den obigen Beispielen eingefügten Seitenumbrüche wieder gelöscht.

Worksheets("Sheet1").Rows(25).PageBreak = xlPageBreakNone
Worksheets("Sheet1").Columns("J").PageBreak = xlNone


PageFieldOrder-Eigenschaft

Gibt die Reihenfolge zurück, in der Seitenfelder dem Layout des PivotTable-Berichts hinzugefügt werden, oder legt sie fest. Kann eine der folgenden XlOrder-Konstanten sein: xlDownThenOver oder xlOverThenDown. Die Standardkonstante ist xlDownThenOver. Long Lese- und Schreibzugriff.


Beispiel zur PageFieldOrder-Eigenschaft

In diesem Beispiel zeichnet der PivotTable-Bericht vor einem neuen Zeilenbeginn drei Seitenfelder in jeder Zeile.

With Worksheets(1).PivotTables("Pivot1")
    .PageFieldOrder = xlOverThenDown
    .PageFieldWrapCount = 3
End With


PageFields-Eigenschaft

Gibt ein Objekt zurück, das ein einzelnes PivotTable-Feld (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller Felder (ein PivotFields-Objekt, Syntax 2) darstellt, die derzeit als Seitenfelder angezeigt werden. Schreibgeschützt.

Syntax 1

Ausdruck.PageFields(Index)

Syntax 2

Ausdruck.PageFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des zurückzugebenden Feldes (kann eine Matrix zur Angabe mehrerer Felder sein).

Anmerkungen

Eine Hierarchie kann nur ein Seitenfeld enthalten.

Bei einem PivotTable-Bericht, der auf einem PivotTable-Cache basiert, gibt die zurückgegebene Auflistung der PivotTable-Felder den aktuellen Inhalt im Cache wieder.


PageFieldStyle-Eigenschaft

Gibt die im eingebundenen Seitenfeldbereich verwendete Formatvorlage zurück oder legt sie fest. Der Standardwert ist eine leere Zeichenfolge (standardmäßig wird keine Formatvorlage zugewiesen). String Schreib-Lese-Zugriff.

Anmerkungen

Diese Formatvorlage wird als Standardformatvorlage für den Hintergrundbereich verwendet und zugewiesen, bevor eine Formatierung durch den Benutzer vorgenommen wird. Zellen, die frei werden, wenn ein Feld von einem Seitenfeldbereich auf eine andere Position pivotiert wird, behalten diese Formatvorlage bei.


Beispiel zur PageFieldStyle-Eigenschaft

In diesem Beispiel wird für den Seitenfeldbereich des ersten PivotTable-Berichts im ersten Tabellenblatt die Formatvorlage "PurpleAndGold" festgelegt.

Worksheets(1).PivotTables("Pivot1") _
    .PageFieldStyle = "PurpleAndGold"


PageFieldWrapCount-Eigenschaft

Gibt die Anzahl der Seitenfelder in jeder Spalte bzw. Zeile in dem PivotTable-Bericht zurück oder legt sie fest. Long Lese- und Schreibzugriff.


Beispiel zur PageFieldWrapCount-Eigenschaft

In diesem Beispiel zeichnet der PivotTable-Bericht vor einem neuen Zeilenbeginn drei Seitenfelder in jeder Zeile.

With Worksheets(1).PivotTables("Pivot1")
    .PageFieldOrder = xlOverThenDown
    .PageFieldWrapCount = 3
End With


PageRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den Seitenbereich in dem PivotTable-Bericht enthält. Schreibgeschützt.


PageRangeCells-Eigenschaft

Gibt ein Range-Objekt zurück, das nur die Zellen eines PivotTable-Berichts darstellt, die Seitenfelder und Element-Dropdownlisten enthalten.


Beispiel zur PageRangeCells-Eigenschaft

In diesem Beispiel werden nur die Zellen in einem PivotTable-Bericht markiert, die Seitenfelder und Element-Dropdownlisten enthalten.

Worksheets(1).PivotTables(1).PageRangeCells.Select


PageSetup-Eigenschaft

Gibt ein PageSetup-Objekt zurück, das alle Seiteneinstellungen für das angegebene Objekt enthält. Schreibgeschützt.


Beispiel zur PageSetup-Eigenschaft

In diesem Beispiel wird der Text der mittleren Kopfzeile für Chart1 festgelegt.

Charts("Chart1").PageSetup.CenterHeader = "December Sales"


Panes-Eigenschaft

Gibt eine Panes-Auflistung zurück, die alle Ausschnitte im angegebenen Fenster darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Diese Eigenschaft steht in einem Fenster nur zur Verfügung, wenn dessen Split-Eigenschaft auf True gesetzt werden kann.


Beispiel zur Panes-Eigenschaft

In diesem Beispiel wird die Anzahl der Ausschnitte im aktiven Fenster von BOOK1.XLS angezeigt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
MsgBox "There are " & ActiveWindow.Panes.Count & _
    " panes in the active window"

In diesem Beispiel wird der linke obere Ausschnitt im aktiven Fenster von BOOK1.XLS aktiviert.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.Panes(1).Activate


PaperSize-Eigenschaft

Gibt die Größe des Papiers zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Es stehen folgende XlPaperSize-Konstanten zur Verfügung. (Einige Drucker unterstützen nicht alle Formate.)

Konstante | Bedeutung
xlPaperLetter | US-Letter (8-1/2 x 11 Zoll)
xlPaperLetterSmall | US-Letter Small (8-1/2 x 11 Zoll)
xlPaperTabloid | US-Tabloid (11 x 17 Zoll)
xlPaperLedger | Ledger 17 x 11 in (17 x 11 Zoll)
xlPaperLegal | Legal 81/2 x 14 in (8 1/2 x 14 Zoll)
xlPaperStatement | US-Statement (5 1/2 x 8 1/2 Zoll)
xlPaperExecutive | US-Executive (7 1/2 x 10 1/2 Zoll)
xlPaperA3 | A3 (297 x 420 mm)
xlPaperA4 | A4 (210 x 297 mm)
xlPaperA4Small | A4 klein (210 x 297 mm)
xlPaperA5 | A5 (148 x 210 mm)
xlPaperB4 | B4 (250 x 354 mm)
xlPaperB5 | B5 (182 x 257 mm)
xlPaperFolio | Folio 81/2 x 13 in (21,59 x 33,02 cm)
xlPaperQuarto | Quarto 215 x 275 mm (215 x 275 mm)
xlPaper10x14 | US-10 x 14 Zoll
xlPaper11x17 | US-11 x 17 Zoll
xlPaperNote | Note 81/2 x 11 in (21,59 x 27,94 cm)
xlPaperEnvelope9 | Envelope #9 (3 7/8 x 8 7/8 Zoll)
xlPaperEnvelope10 | Envelope #10 (4 1/8 x 9 ½ Zoll)
xlPaperEnvelope11 | Envelope #11 (4 1/2 x 10 3/8 Zoll)
xlPaperEnvelope12 | Envelope #12 (4 1/2 x 11 Zoll)
xlPaperEnvelope14 | Envelope #14 (5 x 11 1/2 Zoll)
xlPaperCsheet | US paper size C
xlPaperDsheet | US paper size D
xlPaperEsheet | US paper size E
xlPaperEnvelopeDL | Briefumschlag DL (110 x 220 mm)
xlPaperEnvelopeC3 | Briefumschlag C3 (324 x 458 mm)
xlPaperEnvelopeC4 | Briefumschlag C4 (229 x 324 mm)
xlPaperEnvelopeC5 | Briefumschlag C5 (162 x 229 mm)
xlPaperEnvelopeC6 | Briefumschlag C6 (114 x 162 mm)
xlPaperEnvelopeC65 | Briefumschlag C65 (114 x 229 mm)
xlPaperEnvelopeB4 | Briefumschlag B4 (250 x 353 mm)
xlPaperEnvelopeB5 | Briefumschlag B5 (176 x 250 mm)
xlPaperEnvelopeB6 | Briefumschlag B6 (176 x 125 mm)
xlPaperEnvelopeItaly | Briefumschlag (110 x 230 mm)
xlPaperEnvelopeMonarch | US-Envelope Monarch (3 7/8 x 7 1/2 Zoll)
xlPaperEnvelopePersonal | US-Envelope (3 5/8 x 6 1/2 Zoll)
xlPaperFanfoldUS | US-Standard-Endlos (14 7/8 x 11 Zoll)
xlPaperFanfoldStdGerman | Deutsch-Standard-Endlos (8 1/2 x 12 Zoll)
xlPaperFanfoldLegalGerman | Deutsch-Legal-Endlos (8 1/2 x 13 Zoll)
xlPaperUser | Benutzerdefiniert


Beispiel zur PaperSize-Eigenschaft

In diesem Beispiel wird für Sheet1 die Papiergröße A4 eingestellt.

Worksheets("Sheet1").PageSetup.PaperSize = xlPaperLegal


Parameters-Eigenschaft

Gibt eine Parameters-Auflistung zurück, die die Parameter der Abfragetabelle darstellt. Schreibgeschützt.

Weitere Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Parameters-Eigenschaft

In diesem Beispiel wird die Parameters-Auflistung einer bestehenden Parameterabfrage zurückgegeben. Falls für den ersten Parameter der Datentyp Zeichen verwendet wird, so wird dem Benutzer mitgeteilt, dass er im Eingabedialogfeld nur Zeichen eingeben darf.

With Sheets("sheet1").QueryTables(1).Parameters(1)
    If .DataType = xlParamTypeVarChar Then
        .SetParam xlPrompt, "Enter a character only"
    End If
End With


Parent-Eigenschaft

Gibt das übergeordnete Objekt für das angegebene Objekt zurück. Schreibgeschützt.


 ParentField-Eigenschaft

ParentField-Eigenschaft

Gibt ein PivotField-Objekt zurück, das ein PivotTable-Feld darstellt, das die übergeordnete Gruppe des angegebenen Objekts bildet. Das Feld muss in einer Gruppe enthalten sein und ein übergeordnetes Feld haben. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur ParentField-Eigenschaft

In diesem Beispiel wird der Name des Felds angezeigt, das die übergeordnete Gruppe des Felds darstellt, das die aktive Zelle enthält.

Worksheets("Sheet1").Activate
MsgBox "The active field is a child of the field " & _
    ActiveCell.PivotField.ParentField.Name


 ParentItem-Eigenschaft

ParentItem-Eigenschaft

Gibt ein PivotItem-Objekt zurück, das das übergeordnete PivotTable-Element im übergeordneten PivotField-Objekt darstellt (das Feld muss einer Gruppe angehören, so dass es über ein übergeordnetes Feld verfügt). Schreibgeschützt.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.


 ParentItems-Eigenschaft

ParentItems-Eigenschaft

Gibt ein Objekt zurück, das entweder ein einzelnes PivotTable-Element darstellt (ein PivotItem-Objekt, Syntax 1) oder eine Auflistung aller Elemente, die im angegebenen Feld übergeordnet sind (ein PivotItems-Objekt, Syntax 2). Das angegebene Feld muss innerhalb einer Gruppe einem anderen Feld übergeordnet sein. Schreibgeschützt.

Syntax 1

Ausdruck.ParentItems(Index)

Syntax 2

Ausdruck.ParentItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Index Variant optional. Die Nummern oder Namen der zurückgegebenen Elemente (zur Spezifikation mehrerer Elemente ist auch die Angabe einer Matrix zulässig).

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur ParentItems-Eigenschaft

In diesem Beispiel wird eine Liste mit den Namen aller Elemente erstellt, die innerhalb der Gruppe im Feld "product" übergeordnet sind.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtItem In pvtTable.PivotFields("product").ParentItems
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtItem.Name
Next pvtItem


 ParentShowDetail-Eigenschaft

ParentShowDetail-Eigenschaft

True, wenn das angegebene Element angezeigt wird, weil eines seiner übergeordneten Elemente mit Details angezeigt wird. False, wenn das angegebene Element nicht angezeigt wird, weil eines seiner übergeordneten Elemente die Details verdeckt. Diese Eigenschaft steht nur zur Verfügung, wenn das Element gruppiert ist. Boolean Schreibgeschützt.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.


Beispiel zur ParentShowDetail-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn das Element, das die aktive Zelle enthält, sichtbar ist, weil das übergeordnete Element mit Details angezeigt wird.

Worksheets("Sheet1").Activate
Set pvtItem = ActiveCell.PivotItem
If pvtItem.ParentShowDetail = True Then
    MsgBox "Parent item is showing detail"
End If


Path-Eigenschaft

Gibt den vollständigen Pfad des Objekts (als Zeichenfolge) zurück ohne das abschließende Trennzeichen und den Namen des Objekts. String Schreibgeschützt.

Anmerkungen

Wird kein Objektkennzeichner angegeben, gibt diese Eigenschaft den Pfad für die Microsoft Excel-Anwendung zurück (entspricht Application.Path).


PathSeparator-Eigenschaft

Gibt in Windows einen umgekehrten Schrägstrich ( "\" ) zurück. String Schreibgeschützt.


Beispiel zur PathSeparator-Eigenschaft

In diesem Beispiel wird das aktuelle Pfadtrennzeichen angezeigt.

MsgBox "The path separator character is " & _
    Application.PathSeparator


Pattern-Eigenschaft

Interior-Objekt: Gibt das Muster des Innenbereichs zurück oder legt es fest. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlPattern-Konstanten sein:

xlPatternAutomatic

xlPatternChecker

xlPatternCrissCross

xlPatternDown

xlPatternGray16

xlPatternGray25

xlPatternGray50

xlPatternGray75

xlPatternGray8

xlPatternGrid

 xlPatternHorizontal

xlPatternLightDown

xlPatternLightHorizontal

xlPatternLightUp

xlPatternLightVertical

xlPatternNone

xlPatternSemiGray75

xlPatternSolid

xlPatternUp

xlPatternVertical

FillFormat-Objekt: Gibt das Füllmuster zurück oder legt es fest. Long Schreibgeschützt.

Dies kann eine der folgenden MsoPatternType-Konstanten sein:

msoPattern10Percent

msoPattern20Percent

msoPattern25Percent

msoPattern30Percent

msoPattern40Percent

msoPattern50Percent

msoPattern5Percent

msoPattern60Percent

msoPattern70Percent

msoPattern75Percent

msoPattern80Percent

msoPattern90Percent

msoPatternDarkDownwardDiagonal

msoPatternDarkHorizontal

msoPatternDarkUpwardDiagonal

msoPatternDarkVertical

msoPatternDashedDownwardDiagonal

msoPatternDashedHorizontal

msoPatternDashedUpwardDiagonal

msoPatternDashedVertical

msoPatternDiagonalBrick

msoPatternDivits

msoPatternDottedGrid

msoPatternHorizontalBrick

msoPatternLargeCheckerBoard

 msoPatternLargeConfetti

msoPatternLargeGrid

msoPatternLightDiamonds

msoPatternLightDownwardDiagonal

msoPatternLightHorizontal

msoPatternLightUpwardDiagonal

msoPatternLightVertical

msoPatternMixed

msoPatternNarrowHorizontal

msoPatternNarrowVertical

msoPatternOutlinedDiamonds

msoPatternPlaid

msoPatternShingles

msoPatternSmallCheckerBoard

msoPatternSmallConfetti

msoPatternSmallGrid

msoPatternSolidDiamonds

msoPatternSpheres

msoPatternTrellis

msoPatternWaves

msoPatternWavyLines

msoPatternWeave

msoPatternWideDownwardDiagonal

msoPatternWideUpwardDiagonal


PatternColor-Eigenschaft

Gibt die Musterfarbe für den Innenbereich als RGB zurück. Variant Schreib-Lese-Zugriff.


PatternColorIndex-Eigenschaft

Gibt die Musterfarbe des Innenraums als Index der aktuellen Farbpalette zurück oder legt sie fest. Zulässig als Rückgabe- und Einstellungswert ist auch eine der folgenden XlColorIndex-Konstanten: xlColorIndexAutomatic oder xlColorIndexNone. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie dieser Eigenschaft xlColorIndexAutomatic zuordnen, wird für Zellen das automatische Muster und für Zeichnungs-Objekte die automatische Ausfüllart festgelegt. Ordnen Sie dieser Eigenschaft xlColorIndexNone zu, wird kein Muster festgelegt. (Dies entspricht dem Festlegen von xlPatternNone für die Pattern-Eigenschaft des Interior-Objekts.)

Anmerkungen

Die folgende Abbildung zeigt die Farbindexwerte der Standard-Farbpalette.

Farbindexwerte der Standard-Farbpalette


Beispiel zur PatternColorIndex-Eigenschaft

In diesem Beispiel wird die Musterfarbe für den Innenraum des ersten Rechtecks in Sheet1 festgelegt.

With Worksheets("Sheet1").Rectangles(1).Interior
    .Pattern = xlChecker
    .PatternColorIndex = 5
End With


Period-Eigenschaft

Gibt bei Trendlinien für gleitenden Durchschnitt die Perioden der Trendlinie zurück oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur Period-Eigenschaft

In diesem Beispiel wird die Periode für die erste Trendlinie für gleitenden Durchschnitt in Chart1 festgelegt. Wenden Sie das Makro auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit 10 Datenpunkten und eine Trendlinie mit gleitendem Durchschnitt enthält.

With Charts("Chart1").SeriesCollection(1).Trendlines(1)
    If .Type = xlMovingAvg Then .Period = 5
End With


PersonalViewListSettings-Eigenschaft

True, wenn Filter- und Sortiereinstellungen für Listen in der persönlichen Benutzeransicht der gemeinsam genutzten Arbeitsmappe enthalten sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur PersonalViewListSettings-Eigenschaft

In diesem Beispiel werden Druck- sowie Filter- und Sortiereinstellungen aus der persönlichen Benutzeransicht der zweiten Arbeitsmappe entfernt.

With Workbooks(2)
    .PersonalViewListSettings = False
    .PersonalViewPrintSettings = False
End With


PersonalViewPrintSettings-Eigenschaft

True, wenn Druckeinstellungen in der persönlichen Benutzeransicht der gemeinsam genutzten Arbeitsmappe enthalten sind. Boolean Schreib-Lese-Zugriff.


Beispiel zur PersonalViewPrintSettings-Eigenschaft

In diesem Beispiel werden Druck- sowie Filter- und Sortiereinstellungen aus der persönlichen Benutzeransicht der zweiten Arbeitsmappe entfernt.

With Workbooks(2)
    .PersonalViewListSettings = False
    .PersonalViewPrintSettings = False
End With


Perspective-Eigenschaft

Gibt die Perspektive für die Ansicht eines 3D-Diagramms zurück oder legt sie fest. Der Wert muss zwischen 0 und 100 liegen. Diese Eigenschaft wird nicht beachtet, wenn die RightAngleAxes-Eigenschaft den Wert True besitzt. Long Schreib-Lese-Zugriff.


Beispiel zur Perspective-Eigenschaft

In diesem Beispiel wird der Perspektive für Chart1 der Wert 70 zugewiesen. Wenden Sie das Beispiel auf ein 3D-Diagramm an.

Charts("Chart1").RightAngleAxes = False
Charts("Chart1").Perspective = 70


Phonetic-Eigenschaft

Gibt das Phonetic-Objekt zurück, das Informationen über eine bestimmte phonetische Textzeichenfolge in einer Zelle enthält.

Anmerkungen

Diese Eigenschaft bietet Kompatibilität mit früheren Versionen von Microsoft Excel. Sie sollten Phonetics(Index) verwenden, wobei Index die Indexnummer des phonetischen Textes ist, um ein einzelnes Phonetic-Objekt zurückzugeben.

Hilfe zur Verwendung der phonetischen Tabellenfunktion in Microsoft Visual Basic finden Sie unter Verwenden von Microsoft Excel-Tabellenfunktionen in Visual Basic.


PhoneticCharacters-Eigenschaft

Gibt den phonetischen Text in dem angegebenen Characters-Objekt zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Anstatt diese Eigenschaft zu verwenden, sollten Sie die Add-Methode der Phonetics-Auflistung verwenden, um phonetische Informationen zu einer Zelle hinzuzufügen, und die Text-Eigenschaft des Phonetic-Objekts, um die phonetischen Textzeichenfolgen in einer Zelle zurückzugeben oder festzulegen.

Sie können diese Eigenschaft nur bei Characters-Objekten verwenden, die auf einer einzelnen Zelle basieren.


Beispiel zur PhoneticCharacters-Eigenschaft

In diesem Beispiel wird das vierte Zeichen vom Anfang des Textes in der aktiven Zelle durch Furigana-Zeichen ersetzt.

ActiveCell.Characters(1,3).PhoneticCharacters = "  furigana   furigana   furigana   furigana "


Phonetics-Eigenschaft

Gibt die Phonetics-Auflistung des Bereichs zurück. Phonetics Schreibgeschützt.


Beispiel zur Phonetics-Eigenschaft

In diesem Beispiel werden alle Phonetic-Objekte in der aktiven Zelle angezeigt.

Set objPhon = ActiveCell.Phonetics
With objPhon
    For Each objPhonItem in objPhon
        MsgBox "Phonetic object: " & .Text
    Next
End With


PictureFormat-Eigenschaft

Gibt ein PictureFormat-Objekt zurück, das Bildformatierungseigenschaften der angegebenen Form enthält. Betrifft Shape- oder ShapeRange-Objekte, die Bilder oder OLE-Objekte darstellen. Schreibgeschützt.


Beispiel zur PictureFormat-Eigenschaft

In diesem Beispiel werden in myDocument Helligkeit und Kontrast der ersten Form festgelegt. Bei der ersten Form muss es sich um ein Bild oder ein OLE-Objekt handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).PictureFormat
    .Brightness = 0.3
    .Contrast = .75
End With


PictureType-Eigenschaft

Gibt zurück oder legt fest, wie Bilder in Säulen- oder Balkengrafikdiagrammen sowie an den Wänden oder Stirnflächen von 3D-Diagrammen angezeigt werden. Variant Schreib-Lese-Zugriff.

Dies kann eine der folgenden XlPictureType-Konstanten sein.

Wert | Bedeutung
xlStretch | Streckt das Bild, um den erforderlichen Wert zu erreichen.
xlStack | Stapelt die Bilder, um den erforderlichen Wert zu erreichen.
xlScale | Stapelt die Bilder, bestimmt aber die Einheit für die einzelnen Bilder mit der PictureUnit-Eigenschaft.
xlTile | Ordnet Bilder nebeneinander an.


Beispiel zur PictureType-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Bilder der ersten Datenreihe in Chart1 gestreckt werden. Wenden Sie das Beispiel auf ein 2D-Säulendiagramm mit Bildern als Datenpunktmarkierungen an.

Charts("Chart1").SeriesCollection(1).PictureType = xlStretch


PictureUnit-Eigenschaft

Gibt zurück oder legt fest, wie viele Einheiten einem Bild in einem Säulen- oder Balkengrafikdiagramm entsprechen, wenn die PictureType-Eigenschaft auf xlScale festgelegt ist (ist das nicht der Fall, wird diese Eigenschaft ignoriert). Long Schreib-Lese-Zugriff.


Beispiel zur PictureUnit-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Bilder der ersten Datenreihe in Chart1 gestapelt werden und jedes Bild fünf Einheiten darstellt. Wenden Sie das Beispiel auf ein 2D-Säulendiagramm mit Bildern als Datenpunktmarkierungen an.

With Charts("Chart1").SeriesCollection(1)
    .PictureType = xlScale
    .PictureUnit = 5
End With


Pie3DGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Kreisdiagrammgruppe in einem 3D-Diagramm darstellt. Schreibgeschützt.


Beispiel zur Pie3DGroup-Eigenschaft

In diesem Beispiel wird die 3D-Kreisgruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird.

Charts("Chart1").Pie3DGroup.VaryByCategories = True


PivotCache-Eigenschaft

Gibt das PivotCache-Objekt zurück. Schreibgeschützt.


Beispiel zur PivotCache-Eigenschaft

In diesem Beispiel wird der Aktualisierungszeitraum für den PivotTable-Cache ("PivotTable3") auf 15 Minuten festgelegt.

Set objPC = Worksheets("Sheet1").PivotTables("PivotTable3").PivotCache
objPC.RefreshPeriod = 15


PivotField-Eigenschaft

Gibt ein PivotField-Objekt zurück, das das PivotTable-Feld darstellt, das die linke obere Ecke des angegebenen Bereichs enthält. Schreibgeschützt.


PivotFields-Eigenschaft

Gibt die PivotFields-Auflistung zurück. Diese Auflistung enthält alle PivotTable-Felder, einschließlich derer, die zurzeit auf dem Bildschirm nicht sichtbar sind. Schreibgeschützt.


Beispiel zur PivotFields-Eigenschaft

In diesem Beispiel wird eine Liste aller PivotTable-Feldnamen erstellt, die im ersten PivotChart-Bericht verwendet werden.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objPF In _
    Charts("Chart1").PivotLayout.PivotFields
    objNewSheet.Cells(intRow, 1).Value = objPF.Caption
    intRow = intRow + 1
Next objPF


 PivotFormulas-Eigenschaft

PivotFormulas-Eigenschaft

Gibt ein PivotFormulas-Objekt zurück, das die Auflistung der Formeln für den angegebenen PivotTable-Bericht darstellt. Schreibgeschützt.

Syntax

Ausdruck.PivotFormulas()

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Anmerkungen

Bei OLAP-Datenquellen gibt diese Eigenschaft eine leere Auflistung zurück.


Beispiel zur PivotFormulas-Eigenschaft

In diesem Beispiel wird eine Liste der Formeln für die erste Pivot-Tabelle erstellt.

For Each pf in ActiveSheet.PivotTables(1).PivotFormulas
    r = r + 1
    Cells(r, 1).Value = pf.Formula
Next


PivotItem-Eigenschaft

Gibt ein PivotItem-Objekt zurück, das das PivotTable-Element darstellt, das den linken oberen Teil des angegebenen Bereichs enthält. Schreibgeschützt.


Beispiel zur PivotItem-Eigenschaft

In diesem Beispiel wird der Name des PivotTable-Elements angezeigt, das die aktive Zelle in Sheet1 enthält.

Worksheets("Sheet1").Activate
MsgBox "The active cell is in the item " & _
    ActiveCell.PivotItem.Name


PivotLayout-Eigenschaft

Gibt ein PivotLayout-Objekt zurück, das die Anordnung der Felder in einem PivotTable-Bericht sowie die Anordnung der Achsen in einem PivotChart-Bericht darstellt. Schreibgeschützt.

Anmerkungen

Falls es sich bei dem angegebenen Diagramm nicht um einen PivotChart-Bericht handelt, beträgt der Wert dieser Eigenschaft Nothing.


Beispiel zur PivotLayout-Eigenschaft

In diesem Beispiel wird eine Liste aller PivotTable-Feldnamen erstellt, die im ersten PivotChart-Bericht verwendet werden.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objPF In _
    Charts("Chart1").PivotLayout.PivotFields
    objNewSheet.Cells(intRow, 1).Value = objPF.Caption
    intRow = intRow + 1
Next objPF


 PivotSelection-Eigenschaft

PivotSelection-Eigenschaft

Gibt die PivotTable-Markierung im Standardmarkierungsformat des PivotTable-Berichts zurück oder legt sie fest. String Schreib-/Lesezugriff.

Anmerkungen

Das Festlegen dieser Eigenschaft entspricht dem Aufruf der PivotSelect-Methode, wenn deren Mode-Argument auf xlDataAndLabel gesetzt wurde.


Beispiel zur PivotSelection-Eigenschaft

In diesem Beispiel werden Daten und Beschriftung für den Verkäufer Bob in dem ersten PivotTable-Bericht des ersten Tabellenblatts markiert.

Worksheets(1).PivotTables(1).PivotSelection = "Salesman[Bob]"


PivotTable-Eigenschaft

Gibt ein PivotTable-Objekt zurück, das den PivotTable-Bericht darstellt, der die linke obere Ecke des angegebenen Bereichs enthält, bzw. den dem PivotChart-Bericht zugeordneten PivotTable-Bericht. Schreibgeschützt.


PivotTableSelection-Eigenschaft

True, falls in PivotTable-Berichten die strukturierte Auswahl verwendet wird. Boolean Lese- und Schreibzugriff.


Beispiel zur PivotTableSelection-Eigenschaft

In diesem Beispiel wird die strukturierte Auswahl aktiviert und anschließend festgelegt, dass in dem ersten PivotTable-Bericht des ersten Tabellenblatts nur Daten ausgewählt werden dürfen.

Application.PivotTableSelection = True
Worksheets(1).PivotTables(1).SelectionMode = xlDataOnly


PixelsPerInch-Eigenschaft

Gibt die Dichte (Pixel pro Zoll) von Grafikbildern und Tabellenzellen auf einer Webseite zurück oder legt diese fest. Der Einstellungsbereich beträgt normalerweise 19 bis 480; gebräuchliche Einstellungen für verbreitete Bildschirmgrößen betragen 72, 96 und 120. Die Standardeinstellung ist 96. Long Lese-/Schreibzugriff.

Anmerkungen

Diese Eigenschaft bestimmt die Größe der Bilder und Zellen auf der angegebenen Webseite relativ zu der Textgröße, wenn das gespeicherte Dokument in einem Webbrowser angezeigt wird. Die physikalischen Abmessungen des resultierenden Bilds oder der resultierenden Zelle ergeben sich aus den ursprünglichen Abmessungen (in Zoll) multipliziert mit der Anzahl der Pixel pro Zoll.

Mit Hilfe der ScreenSize-Eigenschaft legen Sie die optimale Bildschirmgröße für die Zielwebbrowser fest.


Beispiel zur PixelsPerInch-Eigenschaft

In diesem Beispiel wird die Pixeldichte abhängig von der Bildschirmgröße des Zielbrowsers festgelegt. Bei Bildschirmen mit 800x600 Pixel beträgt die Dichte 72 Pixel pro Zoll. Bei Bildschirmen mit 1024x768 Pixel beträgt die Dichte 96 Pixel pro Zoll. In allen anderen Fällen wird eine Dichte von 120 Pixel pro Zoll verwendet.

With Application.DefaultWebOptions
    Select Case .ScreenSize
        Case msoScreenSize800x600
            .PixelsPerInch = 72
        Case msoScreenSize1024x768
            .PixelsPerInch = 96
        Case Else
            .PixelsPerInch = 120
    End Select
End With


Placement-Eigenschaft

Gibt zurück oder legt fest, wie das Objekt den darunter liegenden Zellen zugeordnet ist. Zulässig ist eine der folgenden XlPlacement-Konstanten: xlMoveAndSize, xlMove oder xlFreeFloating. Kann nur auf Objekte in einem Tabellenblatt angewendet werden. Long Schreib-Lese-Zugriff.


Beispiel zur Placement-Eigenschaft

In diesem Beispiel wird das erste, in Sheet1 eingebettete Diagramm als unverankertes Objekt festgelegt (es wird weder mit den darunter liegenden Zellen verschoben noch ist es von deren Größe abhängig).

Worksheets("Sheet1").ChartObjects(1).Placement = xlFreeFloating


PlotArea-Eigenschaft

Gibt ein PlotArea-Objekt zurück, das die Zeichnungsfläche eines Diagramms darstellt. Schreibgeschützt.


Beispiel zur PlotArea-Eigenschaft

In diesem Beispiel wird der Zeichnungsfläche in Chart1 die Farbe Zyan zugewiesen.

Charts("Chart1").PlotArea.Interior.ColorIndex = 8


PlotBy-Eigenschaft

Gibt die Art zurück oder legt sie fest, wie Spalten und Zeilen als Datenreihen in einem Diagramm verwendet werden. Dabei kann es sich um eine der folgenden XlRowCol-Konstanten handeln: xlColumns oder xlRows. Long Lese-/Schreibzugriff. Bei PivotChart-Berichten ist diese Eigenschaft schreibgeschützt und gibt immer xlColumns zurück.


Beispiel zur PlotBy-Eigenschaft

In diesem Beispiel wird ein eingebettetes Diagramm angewiesen, Daten nach Spalten zu zeichnen.

Worksheets(1).ChartObjects(1).Chart.PlotBy = xlColumns


PlotOrder-Eigenschaft

Gibt die Reihenfolge der Zeichnungsflächen für die markierte Datenreihe innerhalb einer Diagrammgruppe zurück oder legt sie fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Die Reihenfolge der Zeichnungsflächen kann nur innerhalb einer Diagrammgruppe festgelegt werden (wenn Sie mit mehreren Diagrammtypen in einem Diagramm arbeiten, können Sie die Reihenfolge der Zeichnungsflächen nicht für das gesamte Diagramm festlegen). Eine Diagrammgruppe ist eine Gruppe von Datenreihen mit demselben Diagrammtyp.

Wird die Reihenfolge der Zeichnungsflächen einer Datenreihe geändert, so wird die Reihenfolge der Zeichnungsflächen der anderen Datenreihen in der Diagrammgruppe automatisch entsprechend angepasst.


Beispiel zur PlotOrder-Eigenschaft

In diesem Beispiel wird festgelegt, dass die zweite Datenreihe in Chart1 an dritter Stelle in der Reihenfolge der Zeichnungsflächen angezeigt wird. Wenden Sie das Makro auf ein 2D-Säulendiagramm mit drei oder mehr Datenreihen an.

Charts("Chart1").ChartGroups(1).SeriesCollection(2).PlotOrder = 3


PlotVisibleOnly-Eigenschaft

True, wenn nur die eingeblendeten Zellen geplottet werden sollen. False, wenn sowohl eingeblendete als auch ausgeblendete Zellen dargestellt werden sollen. Boolean Schreib-Lese-Zugriff.


Beispiel zur PlotVisibleOnly-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel nur die sichtbaren Zellen in Chart1 darstellen soll.

Charts("Chart1").PlotVisibleOnly = True


 Points-Eigenschaft

Points-Eigenschaft

Gibt die Position des angegebenen Knotens als Koordinatenpaar zurück. Jede Koordinate wird in Punkt ausgedrückt. Variant Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetPosition-Methode, um den Wert dieser Eigenschaft festzulegen.


Beispiel zur Points-Eigenschaft

In diesem Beispiel wird in myDocument der zweite Knoten der dritten Form um 200 Punkt nach rechts und 300 Punkt nach unten verschoben. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    pointsArray = .Item(2).Points
    currXvalue = pointsArray(1, 1)
    currYvalue = pointsArray(1, 2)
    .SetPosition 2, currXvalue + 200, currYvalue + 300
End With


Position-Eigenschaft

Gibt die Position des angegebenen Objekts zurück oder legt sie entsprechend der folgenden Liste fest. Long Schreib-Lese-Zugriff.

Objekt | Position
DataLabel, DataLabels | Position der Datenbeschriftung. Dies kann eine der folgenden XlDataLabelPosition-Konstanten sein: xlLabelPositionAbove, xlLabelPositionBelow, xlLabelPositionBestFit, xlLabelPositionCenter, xlLabelPositionCustom, xlLabelPositionInsideBase, xlLabelPositionInsideEnd, xlLabelPositionLeft, xlLabelPositionMixed, xlLabelPositionOutsideEnd oder xlLabelPositionRight.
Legend | Position der Legende auf dem Diagramm. Dies kann eine der folgenden XlLegendPosition-Konstanten sein: xlLegendPositionBottom, xlLegendPositionCorner, xlLegendPositionLeft, xlLegendPositionRight, oder xlLegendPositionTop.
PivotField, CubeFields | Position des Feldes (erste, zweite, dritte Position usw.) unter allen Feldern derselben Ausrichtung (Zeilen, Spalten, Seiten, Daten). Bei einer CubeFields-Auflistung ist dies die Position des Hierarchiefeldes im PivotTable-Bericht, wenn es aus der Feldliste der PivotTable-Symbolleiste gezogen wird.
PivotItem | Position des Elements im Feld, wenn das Element derzeit angezeigt wird.


Beispiel zur Position-Eigenschaft

In diesem Beispiel wird die Diagrammlegende an den unteren Rand des Dokuments verschoben.

Charts(1).Legend.Position = xlLegendPositionBottom

In diesem Beispiel wird die Positionsnummer des aktiven PivotTable-Elements angezeigt.

Worksheets("Sheet1").Activate
MsgBox "The active item is in position number " & _
    ActiveCell.PivotItem.Position


PostText-Eigenschaft

Gibt die Zeichenfolge zurück, die mit der Versandmethode zur Dateneingabe in einen Web-Server verwendet wird, um auf Daten aus einer Webabfrage zuzugreifen, oder legt die Zeichenfolge fest. String Schreib-Lese-Zugriff.

Anmerkungen

Microsoft Excel enthält Webabfragen als Beispiele, die Sie modifizieren können, indem Sie den HTML-Code mit WordPad oder einem anderen Texteditor ändern. Die Beispiele finden Sie in dem Ordner "Queries", an der Stelle, an der Sie Microsoft Office installiert haben.


Precedents-Eigenschaft

Gibt ein Range-Objekt zurück, das alle Vorgänger einer Zelle darstellt. Dabei kann es sich um eine Mehrfachauswahl handeln (eine Vereinigung von Range-Objekten), falls mehrere Vorgänger vorhanden sind. Schreibgeschützt.


Beispiel zur Precedents-Eigenschaft

In diesem Beispiel werden die Vorgänger von Zelle A1 in Sheet1 markiert.

Worksheets("Sheet1").Activate
Range("A1").Precedents.Select


PrecisionAsDisplayed-Eigenschaft

True, wenn die Berechnungen in dieser Arbeitsmappe nur mit der Genauigkeit durchgeführt werden, mit der die Zahlen angezeigt werden. Boolean Lese- und Schreibzugriff.


Beispiel zur PrecisionAsDisplayed-Eigenschaft

In diesem Beispiel werden Berechnungen in der aktiven Arbeitsmappe nur mit der Genauigkeit durchgeführt, mit der die Zahlen angezeigt werden.

ActiveWorkbook.PrecisionAsDisplayed = True


PrefixCharacter-Eigenschaft

Gibt das Präfix für die Zelle zurück. Variant Schreibgeschützt.

Anmerkungen

Hat die TransitionNavigKeys-Eigenschaft den Wert False, ist das Präfix entweder das Zeichen ' für eine Textbezeichnung oder leer. Hat die TransitionNavigKeys-Eigenschaft den Wert True, so ist das Präfix das Zeichen ' für eine links ausgerichtete Bezeichnung, " für eine rechts ausgerichtete Bezeichnung, ^ für eine zentrierte Bezeichnung, \ für eine wiederholte Bezeichnung oder leer.


Beispiel zur PrefixCharacter-Eigenschaft

In diesem Beispiel wird das Präfix für Zelle A1 in Sheet1 angezeigt.

MsgBox "The prefix character is " & _
    Worksheets("Sheet1").Range("A1").PrefixCharacter


PreserveColumnInfo-Eigenschaft

True, wenn Sortier-, Filter- und Layoutinformationen einer Spalte erhalten bleiben, wenn eine Abfragetabelle aktualisiert wird. Der Standardwert ist False. Boolean Lese-/Scheibzugriff.

Anmerkungen

Diese Eigenschaft hat nur dann Auswirkungen, wenn die Abfragetabelle eine Datenbankverbindung verwendet.

Sie können diese Eigenschaft aus Gründen der Kompatibilität mit früheren Versionen von Microsoft Excel auf False festlegen.


Beispiel zur PreserveColumnInfo-Eigenschaft

In diesem Beispiel werden die Sortier-, Filter- und Layoutinformationen aus Gründen der Kompatibilität mit früheren Versionen von Microsoft Excel erhalten.

Dim cnnConnect As ADODB.Connection
Dim rstRecordset As ADODB.Recordset

Set cnnConnect = New ADODB.Connection
cnnConnect.Open "Provider=SQLOLEDB;" & _
    "Data Source=srvdata;" & _
    "User ID=wadet;Password=4me2no;"

Set rstRecordset = New ADODB.Recordset
rstRecordset.Open _
    Source:="Select Name, Quantity, Price From Products", _
    ActiveConnection:=cnnConnect, _
    CursorType:=adOpenDynamic, _
    LockType:=adLockReadOnly, _
    Options:=adCmdText

With ActiveSheet.QueryTables.Add( _
        Connection:=rstRecordset, _
        Destination:=Range("A1"))
    .Name = "Contact List"
    .FieldNames = True
    .RowNumbers = False
    .FillAdjacentFormulas = False
    .PreserveFormatting = True
    .RefreshOnFileOpen = False
    .BackgroundQuery = True
    .RefreshStyle = xlInsertDeleteCells
    .SavePassword = True
    .SaveData = True
    .AdjustColumnWidth = True
    .RefreshPeriod = 0
    .PreserveColumnInfo = True
    .Refresh BackgroundQuery:=False
End With


PreserveFormatting-Eigenschaft

Bei PivotTable-Berichten ist diese Eigenschaft True, falls die Formatierung erhalten bleibt, wenn der Bericht aktualisiert oder durch Operationen wie Pivotieren, Sortieren oder Ändern der Seitenfeldelemente neu berechnet wird.

Bei Abfragetabellen ist diese Eigenschaft True, falls eine Formatierung, die in den ersten fünf Datenzeilen gleich ist, für neue Datenzeilen in der Abfragetabelle übernommen wird. Nicht verwendete Zellen werden nicht formatiert. Die Eigenschaft ist False, falls der letzte AutoFormat-Vorgang der Abfragetabelle für neue Datenzeilen angewendet wird. Der Standardwert ist True (es sei denn, die Abfragetabelle wurde in Microsoft Excel 97 erstellt und die HasAutoFormat-Eigenschaft ist True; in diesem Fall ist PreserveFormatting False).

Boolean Schreib-/Lesezugriff.

Anmerkungen

Bei Datenbankabfragetabellen lautet die Standardformateinstellung xlSimple.

Die neue AutoFormat-Art wird von der Abfragetabelle beim Aktualisieren der Tabelle übernommen. AutoFormat wird auf None zurückgesetzt, sobald PreserveFormatting auf False festgelegt wird. Daher hat jedes AutoFormat, das vor dem Festlegen von PreserveFormatting auf False und vor dem Aktualisieren der Abfragetabelle eingestellt wurde, keine Auswirkungen, und auf die resultierende Abfragetabelle wird keine Formatierung angewendet.


Beispiel zur PreserveFormatting-Eigenschaft

In diesem Beispiel bleibt die Formatierung des ersten PivotTable-Berichts im ersten Tabellenblatt erhalten.

Worksheets(1).PivotTables("Pivot1").PreserveFormatting = True

In diesem Beispiel wird gezeigt, wie die Einstellung von PreserveFormatting auf False dazu führt, dass AutoFormat auf das xlRangeAutoFormatNone-Format und nicht auf das angegebene xlRangeAutoFormatColor1-Format festgelegt wird.

With Workbooks(1).Worksheets(1).QueryTables(1)
    .Range.AutoFormat = xlRangeAutoFormatColor1
    .PreserveFormatting = False
    .Refresh

End With


PresetExtrusionDirection-Eigenschaft

Gibt die Richtung zurück, in der die Projektionsausdehnung von der projizierten Form (die Vorderseite der Projektion) aus verläuft. Kann eine der folgenden MsoPresetExtrusionDirection-Konstanten sein: msoExtrusionBottom, msoExtrusionBottomLeft, msoExtrusionBottomRight, msoExtrusionLeft, msoExtrusionNone, msoExtrusionRight, msoExtrusionTop, msoExtrusionTopLeft, msoExtrusionTopRight oder msoPresetExtrusionDirectionMixed. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Um ihren Wert festzulegen, verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur PresetExtrusionDirection-Eigenschaft

In diesem Beispiel wird jede Projektion in myDocument, die sich zur oberen linken Ecke der Vorderseite der Projektion ausdehnt, in eine Projektion geändert, die sich zur unteren linken Ecke der Vorderseite ausdehnt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    With s.ThreeD
        If .PresetExtrusionDirection = msoExtrusionTopLeft Then
            .SetExtrusionDirection msoExtrusionBottomRight
        End If
    End With
Next


PresetGradientType-Eigenschaft

Gibt den voreingestellten Verlaufstyp der angegebenen Füllung zurück. Long Schreibgeschützt.

Dies kann eine der folgenden MsoPresetGradientType-Konstanten sein:

msoGradientBrass

msoGradientCalmWater

msoGradientChrome

msoGradientChromeII

msoGradientDaybreak

msoGradientDesert

msoGradientEarlySunset

msoGradientFire

msoGradientFog

msoGradientGold

msoGradientGoldII

msoGradientHorizon

msoGradientLateSunset

 msoGradientMahogany

msoGradientMoss

msoGradientNightfall

msoGradientOcean

msoGradientParchment

msoGradientPeacock

msoGradientRainbow

msoGradientRainbowII

msoGradientSapphire

msoGradientSilver

msoGradientWheat

msoPresetGradientMixed

Verwenden Sie die PresetGradient-Methode, um den voreingestellten Verlaufstyp der Füllung festzulegen.


Beispiel zur PresetGradientType-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillGradient Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        .PresetGradient c1f.GradientStyle, _
            c1f.GradientVariant, c1f.PresetGradientType
    End With
End If


PresetLightingDirection-Eigenschaft

Gibt die Position der Lichtquelle relativ zur Projektion zurück oder legt die Position fest. Kann eine der folgenden MsoPresetLightingDirection-Konstanten sein: msoLightingBottom, msoLightingBottomLeft, msoLightingBottomRight, msoLightingLeft, msoLightingNone, msoLightingRight, msoLightingTop, msoLightingTopLeft, msoLightingTopRight oder msoPresetLightingDirectionMixed. Long Schreib-Lese-Zugriff.

Anmerkung Sie können die festgelegten Lichteffekte nicht sehen, wenn die Projektion eine Drahtrahmenoberfläche besitzt.


Beispiel zur PresetLightingDirection-Eigenschaft

In diesem Beispiel wird festgelegt, dass sich die Projektion der ersten Form in myDocument in Richtung des oberen Randes der Form ausdehnt und dass das Licht für die Projektion von links einfällt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


PresetLightingSoftness-Eigenschaft

Gibt die Stärke der Projektionsbeleuchtung zurück oder legt die Stärke fest. Kann eine der folgenden MsoPresetLightingSoftness-Konstanten sein: msoLightingBright, msoLightingDim, msoLightingNormal oder msoPresetLightingSoftnessMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetLightingSoftness-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Projektion der ersten Form in myDocument von der linken Seite hell beleuchtet werden soll.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetLightingSoftness = msoLightingBright
    .PresetLightingDirection = msoLightingLeft
End With


PresetMaterial-Eigenschaft

Gibt das Oberflächenmaterial der Projektion zurück oder legt es fest. Kann eine der folgenden MsoPresetMaterial-Konstanten sein: msoMaterialMatte, msoMaterialMetal, msoMaterialPlastic, msoMaterialWireFrame oder msoPresetMaterialMixed. Long Schreib-Lese-Zugriff.


Beispiel zur PresetMaterial-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Projektion der ersten Form in myDocument eine Drahtrahmenoberfläche besitzen soll.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .PresetMaterial = msoMaterialWireFrame
End With


PresetShape-Eigenschaft

Gibt die Form der angegebenen WordArt zurück oder legt die Form fest. Long Schreib-Lese-Zugriff.

Kann eine der folgenden MsoPresetTextEffectShape-Konstanten sein:

msoTextEffectShapeArchDownCurve

msoTextEffectShapeArchDownPour

msoTextEffectShapeArchUpCurve

msoTextEffectShapeArchUpPour

msoTextEffectShapeButtonCurve

msoTextEffectShapeButtonPour

msoTextEffectShapeCanDown

msoTextEffectShapeCanUp

msoTextEffectShapeCascadeDown

msoTextEffectShapeCascadeUp

msoTextEffectShapeChevronDown

msoTextEffectShapeChevronUp

msoTextEffectShapeCircleCurve

msoTextEffectShapeCirclePour

msoTextEffectShapeCurveDown

msoTextEffectShapeCurveUp

msoTextEffectShapeDeflate

msoTextEffectShapeDeflateBottom

msoTextEffectShapeDeflateInflate

msoTextEffectShapeDeflateInflateDeflate

msoTextEffectShapeDeflateTop

 msoTextEffectShapeDoubleWave1

msoTextEffectShapeDoubleWave2

msoTextEffectShapeFadeDown

msoTextEffectShapeFadeLeft

msoTextEffectShapeFadeRight

msoTextEffectShapeFadeUp

msoTextEffectShapeInflate

msoTextEffectShapeInflateBottom

msoTextEffectShapeInflateTop

msoTextEffectShapeMixed

msoTextEffectShapePlainText

msoTextEffectShapeRingInside

msoTextEffectShapeRingOutside

msoTextEffectShapeSlantDown

msoTextEffectShapeSlantUp

msoTextEffectShapeStop

msoTextEffectShapeTriangleDown

msoTextEffectShapeTriangleUp

msoTextEffectShapeWave1

msoTextEffectShapeWave2

Anmerkungen

Durch Festlegen der PresetTextEffect-Eigenschaft wird automatisch die PresetShape-Eigenschaft festgelegt.


Beispiel zur PresetShape-Eigenschaft

In diesem Beispiel wird für die Form aller WordArts in myDocument ein gebogener Richtungspfeil festgelegt, dessen Zentrum nach unten zeigt.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetShape = msoTextEffectShapeChevronDown
    End If
Next


PresetTextEffect-Eigenschaft

Gibt die Formatvorlage der angegebenen WordArt zurück oder legt die Formatvorlage fest. Die Werte für diese Eigenschaft entsprechen den Formaten im Dialogfeld WordArt-Katalog (von links oben nach rechts unten nummeriert). Long Schreib-Lese-Zugriff.

Kann eine der folgenden MsoPresetTextEffect-Konstanten sein:

msoTextEffect1

msoTextEffect2

msoTextEffect3

msoTextEffect4

msoTextEffect5

msoTextEffect6

msoTextEffect7

msoTextEffect8

msoTextEffect9

msoTextEffect10

msoTextEffect11

msoTextEffect12

msoTextEffect13

msoTextEffect14

msoTextEffect15

msoTextEffect16

 msoTextEffect17

msoTextEffect18

msoTextEffect19

msoTextEffect20

msoTextEffect21

msoTextEffect22

msoTextEffect23

msoTextEffect24

msoTextEffect25

msoTextEffect26

msoTextEffect27

msoTextEffect28

msoTextEffect29

msoTextEffect30

msoTextEffectMixed

Anmerkungen

Durch das Festlegen der PresetTextEffect-Eigenschaft werden automatisch viele andere Formateigenschaften der angegebenen Form festgelegt.


Beispiel zur PresetTextEffect-Eigenschaft

In diesem Beispiel wird allen WordArts in myDocument die erste im Dialogfeld WordArt-Katalog aufgeführte Formatvorlage zugewiesen.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.Type = msoTextEffect Then
        s.TextEffect.PresetTextEffect = msoTextEffect1
    End If
Next


PresetTexture-Eigenschaft

Gibt die voreingestellte Struktur der angegebenen Füllung zurück. Long Schreibgeschützt.

Dies kann einer der folgenden MsoPresetTexture-Werte sein:

msoPresetTextureMixed

msoTextureBlueTissuePaper

msoTextureBouquet

msoTextureBrownMarble

msoTextureCanvas

msoTextureCork

msoTextureDenim

msoTextureFishFossil

msoTextureGranite

msoTextureGreenMarble

msoTextureMediumWood

msoTextureNewsprint

msoTextureOak

 msoTexturePaperBag

msoTexturePapyrus

msoTextureParchment

msoTexturePinkTissuePaper

msoTexturePurpleMesh

msoTextureRecycledPaper

msoTextureSand

msoTextureStationery

msoTextureWalnut

msoTextureWaterDroplets

msoTextureWhiteMarble

msoTextureWovenMat

Verwenden Sie die PresetTextured-Methode, um die voreingestellte Struktur der Füllung festzulegen.


Beispiel zur PresetTexture-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillTextured Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        If c1f.TextureType = msoTexturePreset Then
            .PresetTextured c1f.PresetTexture
        Else
            .UserTextured c1f.TextureName
        End If
    End With
End If


PresetThreeDFormat-Eigenschaft

Gibt das Projektionsformat zurück oder legt es fest. Jedes voreingestellte Projektionsformat enthält einen Satz voreingestellter Werte für die verschiedenen Eigenschaften der Projektion. Besitzt die Projektion an Stelle eines voreingestellten Formats ein benutzerdefiniertes, gibt diese Eigenschaft msoPresetThreeDFormatMixed zurück. Kann eine der folgenden MsoPresetThreeDFormat-Konstanten sein: msoPresetThreeDFormatMixed, msoThreeD1, msoThreeD10, msoThreeD11, msoThreeD12, msoThreeD13, msoThreeD14, msoThreeD15, msoThreeD16, msoThreeD17, msoThreeD18, msoThreeD19, msoThreeD2, msoThreeD20, msoThreeD3, msoThreeD4, msoThreeD5, msoThreeD6, msoThreeD7, msoThreeD8 oder msoThreeD9. Die Werte dieser Eigenschaft entsprechen den Optionen (von links oben nach rechts unten nummeriert), die angezeigt werden, wenn Sie auf die Schaltfläche 3D der Symbolleiste Zeichnen klicken. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Zur Festlegung des Projektionsformats verwenden Sie die SetThreeDFormat-Methode.


Beispiel zur PresetThreeDFormat-Eigenschaft

In diesem Beispiel wird für das Projektionsformat der ersten Form in myDocument die 3D-Art 12 festgelegt, wenn die Form anfangs ein benutzerdefiniertes Projektionsformat besaß.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    If .PresetThreeDFormat = msoPresetThreeDFormatMixed Then
        .SetThreeDFormat msoThreeD12
    End If
End With


Previous-Eigenschaft

Gibt ein Chart-, Range- oder Worksheet-Objekt zurück, das das vorherige Blatt oder die vorherige Zelle darstellt. Schreibgeschützt.

Anmerkungen

Ist das Objekt ein Bereich, so emuliert diese Eigenschaft die Tastenkombination UMSCHALT+TAB. Im Gegensatz zur Tastenkombination wird jedoch die vorhergehende Zelle zurückgegeben, ohne sie zu markieren.

In einem geschützten Blatt gibt diese Eigenschaft die vorhergehende nicht gesperrte Zelle zurück. In einem ungeschützten Blatt wird immer die Zelle links von der angegebenen Zelle zurückgegeben.


PreviousSelections-Eigenschaft

Gibt eine Matrix der vier zuletzt markierten Bereiche oder Namen zurück. Jedes Matrixelement ist ein Range-Objekt. Variant Schreibgeschützt.

Syntax

Ausdruck.PreviousSelections(Index)

Ausdruck Optional. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index Variant optional. Die Indexnummer (von 1 bis 4) des vorherigen Bereichs oder Namens.

Anmerkungen

Sobald Sie sich mit dem Feld Name oder dem Befehl Gehe zu (Menü Bearbeiten) zu einem Bereich oder einer Zelle bewegen oder sobald ein Makro die Goto-Methode aufruft, wird der zuvor markierte Bereich zu dieser Matrix als erstes Element hinzugefügt. Die anderen Elemente in der Matrix werden nach unten verschoben.


Beispiel zur PreviousSelections-Eigenschaft

In diesem Beispiel werden die Zelladressen aller in der Matrix der zuletzt markierten Bereiche oder Namen enthaltenen Elemente angezeigt. Wurden zuvor noch keine Bereiche oder Namen markiert, gibt die LBound-Funktion einen Fehler zurück. Dieser Fehler wird abgefangen und ein Meldungsfeld angezeigt.

On Error GoTo noSelections
For i = LBound(Application.PreviousSelections) To _
            UBound(Application.PreviousSelections)
    MsgBox Application.PreviousSelections(i).Address
Next i
Exit Sub
On Error GoTo 0

noSelections:
    MsgBox "There are no previous selections"


PrintArea-Eigenschaft

Gibt den Druckbereich als Zeichenfolge in der Sprache des Makros zurück oder legt ihn fest. Die Zeichenfolge verwendet den Bezug in der A1-Schreibweise. String Schreib-Lese-Zugriff.

Anmerkungen

Setzen Sie diese Eigenschaft auf False oder auf die leere Zeichenfolge (""), um das gesamte Blatt als Druckbereich festzulegen.

Diese Eigenschaft gilt nur für Seiten von Tabellenblättern.


Beispiel zur PrintArea-Eigenschaft

In diesem Beispiel wird der Bereich A1:C5 in Sheet1 als Druckbereich festgelegt.

Worksheets("Sheet1").PageSetup.PrintArea = "$A$1:$C$5"

In diesem Beispiel wird der markierte Bereich in Sheet1 als Druckbereich festgelegt. Beachten Sie, dass die Address-Methode verwendet wird, um eine Adresse in der Bezugsart A1 zurückzugeben.

Worksheets("Sheet1").Activate
ActiveSheet.PageSetup.PrintArea = _
    ActiveCell.CurrentRegion.Address


PrintComments-Eigenschaft

Gibt die Art zurück, in der Kommentare zusammen mit dem Blatt ausgedruckt werden, oder legt sie fest. Dies kann eine der folgenden XlPrintLocation-Konstanten sein: xlPrintInPlace, xlPrintNoComments oder xlPrintSheetEnd. Long Schreib-Lese-Zugriff.


Beispiel zur PrintComments-Eigenschaft

In diesem Beispiel wird festgelegt, dass bei einem Ausdruck des ersten Tabellenblatts Kommentare als Endnoten gedruckt werden.

Worksheets(1).PageSetup.PrintComments = xlPrintSheetEnd


PrintGridlines-Eigenschaft

True, wenn Gitternetzlinien gedruckt werden sollen. Gilt nur für Tabellenblätter. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintGridlines-Eigenschaft

In diesem Beispiel werden beim Drucken von Sheet1 die Zellen einschließlich Gitternetzlinien gedruckt.

Worksheets("Sheet1").PageSetup.PrintGridlines = True


PrintHeadings-Eigenschaft

True, falls Zeilen- und Spaltenköpfe gedruckt werden sollen. Gilt nur für Tabellenblätter. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Die Eigenschaft DisplayHeadings bestimmt die Anzeige der Zeilen- und Spaltenköpfe auf dem Bildschirm.


Beispiel zur PrintHeadings-Eigenschaft

In diesem Beispiel wird das Drucken der Zeilen- und Spaltenköpfe für Sheet1 deaktiviert.

Worksheets("Sheet1").PageSetup.PrintHeadings = False


PrintNotes-Eigenschaft

True, wenn Notizen als Endnoten zusammen mit dem Blatt gedruckt werden. Gilt nur für Tabellenblätter. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Mit der PrintComments-Eigenschaft können Sie Kommentare als Textfelder oder Endnoten drucken.


Beispiel zur PrintNotes-Eigenschaft

In diesem Beispiel wird das Drucken von Notizen ausgeschaltet.

Worksheets("Sheet1").PageSetup.PrintNotes = False


PrintObject-Eigenschaft

True, wenn das Objekt zusammen mit dem Dokument gedruckt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur PrintObject-Eigenschaft

In diesem Beispiel wird festgelegt, dass das erste, in Sheet1 eingebettete Diagramm zusammen mit dem Tabellenblatt gedruckt wird.

Worksheets("Sheet1").ChartObjects(1).PrintObject = True


PrintSettings-Eigenschaft

True, falls die benutzerdefinierte Ansicht die Druckeinstellungen beinhaltet. Boolean Schreibgeschützt.


Beispiel zur PrintSettings-Eigenschaft

In diesem Beispiel wird eine Liste der benutzerdefinierten Ansichten in der aktiven Arbeitsmappe sowie deren Druck-, Zeilen- und Spalteneinstellungen erstellt.

With Worksheets(1)
    .Cells(1,1).Value = "Name"
    .Cells(1,2).Value = "Print Settings"
    .Cells(1,3).Value = "RowColSettings"
    rw = 0
    For Each v In ActiveWorkbook.CustomViews
        rw = rw + 1
        .Cells(rw, 1).Value = v.Name
        .Cells(rw, 2).Value = v.PrintSettings
        .Cells(rw, 3).Value = v.RowColSettings
    Next
End With


PrintTitleColumns-Eigenschaft

Gibt die Spalten, die links auf jeder Seite als Beschriftung wiederholt werden sollen, als Zeichenfolge in der Sprache des Makros zurück oder legt sie fest. Die Zeichenfolge verwendet den Bezug in der A1-Schreibweise. String Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie nur einen Teil einer oder mehrerer Spalten angeben, erweitert Microsoft Excel den Bereich auf ganze Spalten.

Setzen Sie diese Eigenschaft auf False oder auf die leere Zeichenfolge (""), um die Spaltenbeschriftungen auszublenden.

Diese Eigenschaft gilt nur für Seiten von Tabellenblättern.


Beispiel zur PrintTitleColumns-Eigenschaft

In diesem Beispiel wird festgelegt, dass die dritte Zeile als Titelzeile und die ersten drei Spalten als Titelspalten gedruckt werden.

Worksheets("Sheet1").Activate
ActiveSheet.PageSetup.PrintTitleRows = ActiveSheet.Rows(3).Address
ActiveSheet.PageSetup.PrintTitleColumns = _
        ActiveSheet.Columns("A:C").Address


PrintTitleRows-Eigenschaft

Gibt die Zeilen, die oben auf jeder Seite als Beschriftung wiederholt werden sollen, als Zeichenfolge in der Sprache des Makros zurück oder legt sie fest. Die Zeichenfolge verwendet den Bezug in der A1-Schreibweise. String Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie nur einen Teil einer oder mehrerer Zeilen angeben, erweitert Microsoft Excel den Bereich auf ganze Zeilen.

Setzen Sie diese Eigenschaft auf False oder auf die leere Zeichenfolge (""), um die Zeilenbeschriftungen auszublenden.

Diese Eigenschaft gilt nur für Seiten von Tabellenblättern.


Beispiel zur PrintTitleRows-Eigenschaft

In diesem Beispiel wird festgelegt, dass die dritte Zeile als Titelzeile und die ersten drei Spalten als Titelspalten gedruckt werden.

Worksheets("Sheet1").Activate
ActiveSheet.PageSetup.PrintTitleRows = ActiveSheet.Rows(3).Address
ActiveSheet.PageSetup.PrintTitleColumns = _
        ActiveSheet.Columns("A:C").Address


PrintTitles-Eigenschaft

True, wenn die Drucktitel des Tabellenblatts auf der Grundlage des PivotTable-Berichts festgelegt werden. Die Zeilendrucktitel werden auf die Zeilen, die die Spaltenfeldelemente des PivotTable-Berichts enthalten, festlegt. Die Spaltendrucktitel werden auf die Spalten festgelegt, die die Zeilenelemente enthalten. False, wenn die Drucktitel des Tabellenblatts verwendet werden. Der Standardwert ist False. Boolean Schreib-/Lesezugriff.

Anmerkungen

Bei dem PivotTable-Bericht muss es sich um den einzigen im Druckbereich handeln. Zum Festlegen eines Einzugsformats für einen PivotTable-Bericht verwenden Sie die Format-Methode.


Beispiel zur PrintTitles-Eigenschaft

In diesem Beispiel wird angegeben, dass der für das Tabellenblatt festgelegte Drucktitel gedruckt wird, wenn der vierte PivotTable-Bericht im aktiven Tabellenblatt gedruckt wird.

ActiveSheet.PivotTables("PivotTable4").PrintTitles = True


ProductCode-Eigenschaft

Gibt die GUID (Globally Unique Identifier) für Microsoft Excel zurück. String Schreibgeschützt.


Beispiel zur ProductCode-Eigenschaft

In diesem Beispiel wird die GUID (Globally Unique Identifier) für Microsoft Excel angezeigt.

MsgBox Application.ProductCode


ProgId-Eigenschaft

Gibt die programmtechnischen Erkennungszeichen des Objekts zurück. String Schreibgeschützt.

Weitere Informationen über programmtechnische Erkennungzeichen finden Sie unter programmtechnische OLE-Bezeichner.


Beispiel zur ProgId-Eigenschaft

In diesem Beispiel wird eine Liste der programmtechnischen Erkennungszeichen der OLE-Objekte im ersten Tabellenblatt erstellt.

rw = 0
For Each o in Worksheets(1).OLEObjects
    With Worksheets(2)
        rw = rw + 1
        .cells(rw, 1).Value = o.ProgId
    End With
Next


PromptForSummaryInfo-Eigenschaft

True, wenn Microsoft Excel beim ersten Speichern von Dateien nach den Datei-Informationen fragt. Boolean Schreib-Lese-Zugriff.


Beispiel zur PromptForSummaryInfo-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, Dateiinformationen einzugeben, wenn eine Datei zum ersten Mal gespeichert wird.

Application.PromptForSummaryInfo = True


PromptString-Eigenschaft

Gibt die Zeichenfolge zurück, mit der der Benutzer bei einer Parameterabfrage zur Eingabe eines Parameterwertes aufgefordert wird. String Schreibgeschützt.


Beispiel zur PromptString-Eigenschaft

In diesem Beispiel wird die Zeichenfolge der Eingabeaufforderung für den Parameter in der ersten Abfragetabelle geändert.

With Worksheets(1).QueryTables(1).Parameters(1)
    .SetParam xlPrompt, "Please " & .PromptString
End With


ProtectChartObject-Eigenschaft

True, wenn der Rahmen eines eingebetteten Diagramms nicht verschoben, gelöscht oder wenn seine Größe nicht geändert werden kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur ProtectChartObject-Eigenschaft

In diesem Beispiel wird das eingebettete Diagramm in Tabellenblatt 1 geschützt.

Worksheets(1).ChartObjects(1).ProtectChartObject = True


ProtectContents-Eigenschaft

True, wenn der Inhalt des Blattes geschützt ist. Bei einem Diagramm wird das gesamte Diagramm geschützt. Bei einem Tabellenblatt werden die einzelnen Zellen geschützt. Boolean Schreib-Lese-Zugriff.


Beispiel zur ProtectContents-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn der Inhalt von Sheet1 geschützt ist.

If Worksheets("Sheet1").ProtectContents = True Then
    MsgBox "The contents of Sheet1 are protected."
End If


ProtectData-Eigenschaft

True, wenn Datenreihenformeln nicht durch die Benutzerin oder den Benutzer modifiziert werden können. Boolean Schreib-Lese-Zugriff.


Beispiel zur ProtectData-Eigenschaft

In diesem Beispiel werden die Daten im eingebetteten Diagramm in Tabellenblatt 1 geschützt.

Worksheets(1).ChartObjects(1).Chart.ProtectData = True


ProtectDrawingObjects-Eigenschaft

True, wenn Formen geschützt sind. Boolean Schreibgeschützt.


Beispiel zur ProtectDrawingObjects-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn die Formen in Sheet1 geschützt sind.

If Worksheets("Sheet1").ProtectDrawingObjects = True Then
    MsgBox "The shapes on Sheet1 are protected."
End If


ProtectFormatting-Eigenschaft

True, wenn die Diagrammformatierung nicht durch die Benutzerin oder den Benutzer modifiziert werden kann. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft auf True gesetzt ist, wird der Befehl Objekt im Menü Format deaktiviert und Diagrammelemente können nicht hinzugefügt, verschoben, gelöscht oder ihre Größe kann nicht geändert werden.


Beispiel zur ProtectFormatting-Eigenschaft

In diesem Beispiel wird die Formatierung des eingebetteten Diagramms in Tabellenblatt 1 geschützt.

Worksheets(1).ChartObjects(1).Chart.ProtectFormatting = True


ProtectGoalSeek-Eigenschaft

True, wenn der Benutzer die Datenpunkte eines Diagramms nicht mit Mausaktionen modifizieren kann. Boolean Schreib-Lese-Zugriff.


Beispiel zur ProtectGoalSeek-Eigenschaft

In diesem Beispiel werden die Datenpunkte im eingebetteten Diagramm in Tabellenblatt 1 geschützt.

Worksheets(1).ChartObjects(1).Chart.ProtectGoalSeek = True


ProtectionMode-Eigenschaft

True, wenn der Schutzmodus Nur-Benutzerschnittstelle aktiviert ist. Um den Schutz für Nur-Benutzerschnittstelle zu aktivieren, verwenden Sie die Protect-Methode, und setzen Sie das Argument UserInterfaceOnly auf True. Boolean Schreibgeschützt.


Beispiel zur ProtectionMode-Eigenschaft

In diesem Beispiel wird der Status der ProtectionMode-Eigenschaft zurückgegeben.

MsgBox ActiveSheet.ProtectionMode


ProtectScenarios-Eigenschaft

True, wenn die Tabellenblatt-Szenarios geschützt sind. Boolean Schreibgeschützt.


Beispiel zur ProtectScenarios-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, falls die Szenarios in Sheet1 geschützt sind.

If Worksheets("Sheet1").ProtectScenarios Then _
    MsgBox "Scenarios are protected on this worksheet."


ProtectSelection-Eigenschaft

True, wenn Diagrammelemente nicht gewählt werden können. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft auf True gesetzt ist, können Formen nicht in ein Diagramm aufgenommen werden, und die Click- und DoubleClick-Ereignisse treten für Diagrammelemente nicht auf.


Beispiel zur ProtectSelection-Eigenschaft

In diesem Beispiel wird verhindert, dass Diagrammelemente im eingebetteten Diagramm in Tabellenblatt 1 gewählt werden.

Worksheets(1).ChartObjects(1).Chart.ProtectSelection = True


ProtectStructure-Eigenschaft

True, wenn die Reihenfolge der Blätter in der Arbeitsmappe geschützt ist. Boolean Schreibgeschützt.


Beispiel zur ProtectStructure-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, falls die Reihenfolge der Blätter in der aktiven Arbeitsmappe geschützt ist.

If ActiveWorkbook.ProtectStructure = True Then
    MsgBox "Remember, you cannot delete, add, or change " & _
        Chr(13) & _
        "the location of any sheets in this workbook."
End If


ProtectWindows-Eigenschaft

True, wenn die Fenster der Arbeitsmappe geschützt sind. Boolean Schreibgeschützt.


Beispiel zur ProtectWindows-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, falls die Fenster der aktiven Arbeitsmappe geschützt sind.

If ActiveWorkbook.ProtectWindows = True Then
    MsgBox "Remember, you cannot rearrange any" & _
        " window in this workbook."
End If


PublishObjects-Eigenschaft

Gibt die PublishObjects-Auflistung zurück. Schreibgeschützt.


Beispiel zur PublishObjects-Eigenschaft

In diesem Beispiel werden alle statischen PublishObject-Objekte der aktiven Arbeitsmappe auf der Webseite veröffentlicht.

Set objPObjs = ActiveWorkbook.PublishObjects
For Each objPO in objPObjs
    If objPO.HtmlType = xlHTMLStatic Then
        objPO.Publish
    End If
Next objPO


QueryTable-Eigenschaft

Gibt ein QueryTable-Objekt zurück, das die Abfragetabelle darstellt, die den angegebenen Bereich schneidet. Schreibgeschützt.


QueryTables-Eigenschaft

Gibt die QueryTables-Auflistung zurück, die alle Abfragetabellen des angegebenen Tabellenblattes darstellt. Schreibgeschützt.

Weitere Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur QueryTables-Eigenschaft

In diesem Beispiel werden alle Abfragetabellen des ersten Tabellenblattes aktualisiert.

For Each qt in Worksheets(1).QueryTables
    qt.Refresh
Next

In diesem Beispiel wird festgelegt, dass Formeln, die sich rechts von der ersten Abfragetabelle befinden, immer automatisch aktualisiert werden, wenn die Abfragetabelle aktualisiert wird.

Sheets("sheet1").QueryTables(1).FillAdjacentFormulas = True


 QueryType-Eigenschaft

QueryType-Eigenschaft

Gibt eine der in der folgenden Tabelle aufgeführten xlQueryType-Konstanten zurück. Diese Konstanten bezeichnen den Typ der von Microsoft Excel verwendeten Abfrage, um die Abfragetabelle oder den PivotTable-Cache aufzufüllen. xlQueryType Schreibgeschützt.

Konstante | Beschreibung
xlADORecordset | Basierend auf der Abfrage einer ADO-Datensatzgruppe
xlDAORecordset | Basierend auf der Abfrage einer DAO-Datensatzgruppe (nur für Abfragetabellen)
xlODBCQuery | Basierend auf einer ODBC-Datenquelle
xlOLEDBQuery | Basierend auf einer OLE DB-Abfrage, einschließlich OLAP-Datenquellen
xlTextImport | Basierend auf einer Textdatei (nur für Abfragetabellen)
xlWebQuery | Basierend auf einer Webseite (nur für Abfragetabellen)

Anmerkungen

Sie geben die Datenquelle im Präfix für den Wert der Connection-Eigenschaft an.


Beispiel zur QueryType-Eigenschaft

In diesem Beispiel wird die erste Abfragetabelle des ersten Tabellenblatts aktualisiert, falls die Tabelle auf einer Webseite basiert.

Set qtQtrResults = _
    Workbooks(1).Worksheets(1).QueryTables(1)
With qtQtrResults
    if .QueryType = xlWebQuery Then
        .Refresh
    End If
End With


RadarAxisLabels-Eigenschaft

Gibt ein TickLabels-Objekt zurück, das die Achsenbeschriftung eines Netzdiagramms für die angegebene Diagrammgruppe darstellt. Schreibgeschützt.


Beispiel zur RadarAxisLabels-Eigenschaft

In diesem Beispiel werden Netzachsenbeschriftungen für die erste Diagrammgruppe in Chart1 eingeblendet und die zugehörige Farbe festgelegt. Es ist sinnvoll, das Beispiel auf ein Netzdiagramm anzuwenden.

With Charts("Chart1").ChartGroups(1)
    .HasRadarAxisLabels = True
    .RadarAxisLabels.Font.ColorIndex = 3
End With


Range-Eigenschaft

Um weitere Informationen zu erhalten, klicken Sie auf eines der folgenden Objekte.

Application

AutoFilter

Hyperlink

Range

Shapes

Worksheet


Range-Eigenschaft (AutoFilter-Objekt)

Gibt ein Range-Objekt zurück, das den Bereich darstellt, für den der angegebene AutoFilter gilt. Schreibgeschützt.


Beispiel zur Range-Eigenschaft (AutoFilter-Objekt)

Im folgenden Beispiel wird die Adresse für den AutoFilter, der im Tabellenblatt "Crew" angewendet wird, in einer Variablen gespeichert.

rAddress = Worksheets("Crew").AutoFilter.Range.Address


Range-Eigenschaft (Hyperlink-Objekt)

Gibt ein Range-Objekt zurück, das den Bereich darstellt, dem der angegebene Hyperlink zugeordnet ist. Schreibgeschützt.


Beispiel zur Range-Eigenschaft (Hyperlink-Objekt)

In diesem Beispiel wird im Arbeitsmappenfenster ein Bildlauf durchgeführt, bis sich der Hyperlinkbereich in der oberen linken Ecke des aktiven Fensters befindet.

Workbooks(1).Activate
Set hr = ActiveSheet.Hyperlinks(1).Range
ActiveWindow.ScrollRow = hr.Row
ActiveWindow.ScrollColumn = hr.Column


RangeSelection-Eigenschaft

Gibt ein Range-Objekt zurück, das die markierten Zellen im Tabellenblatt im angegebenen Fenster umfasst, selbst wenn im Tabellenblatt ein Grafikobjekt aktiv oder markiert ist. Schreibgeschützt.

Anmerkungen

Wenn in einem Tabellenblatt ein Grafikobjekt markiert ist, gibt die Selection-Eigenschaft das Grafikobjekt an Stelle eines Range-Objekts zurück; die RangeSelection-Eigenschaft gibt den Zellbereich zurück, der markiert war, bevor das Grafikobjekt markiert wurde.

Diese Eigenschaft und die Eigenschaft Selection geben identische Werte zurück, wenn auf dem Tabellenblatt ein Bereich (also kein Grafikobjekt) markiert ist.

Wenn es sich bei dem aktiven Blatt im angegebenen Fenster nicht um ein Tabellenblatt handelt, erzeugt diese Eigenschaft eine Fehlermeldung.


Beispiel zur RangeSelection-Eigenschaft

In diesem Beispiel wird die Adresse der markierten Zellen des Tabellenblattes im aktiven Fenster angezeigt.

MsgBox ActiveWindow.RangeSelection.Address


ReadingOrder-Eigenschaft

Gibt die Lesereihenfolge für das angegebene Objekt zurück oder legt diese fest. Kann eine der folgenden Konstanten sein: xlRTL (von rechts nach links), xlLTR (von links nach rechts) oder xlContext. Long Schreib-Lese-Zugriff.

Anmerkungen

Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur ReadingOrder-Eigenschaft

In diesem Beispiel wird die Lesereihenfolge für den Diagrammtitel von Chart1 auf von rechts nach links festgelegt.

Charts("Chart1").ChartTitle.ReadingOrder = xlRTL


ReadOnly-Eigenschaft

True, wenn die Arbeitsmappe schreibgeschützt geöffnet wurde. Boolean Schreibgeschützt.


ReadOnlyRecommended-Eigenschaft

True, wenn die Arbeitsmappe mit Schreibschutz empfehlen gespeichert wurde. Boolean Schreibgeschützt.

Anmerkungen

Beim Öffnen einer Arbeitsmappe, die mit Schreibschutz empfehlen gespeichert wurde, empfiehlt Ihnen Microsoft Excel in einer Meldung, die Arbeitsmappe als schreibgeschützt zu öffnen.

Verwenden Sie die SaveAs-Methode, um diese Eigenschaft zu ändern.


Beispiel zur ReadOnlyRecommended-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn die aktive Arbeitsmappe mit der Option Schreibschutz empfehlen gespeichert wird.

If ActiveWorkbook.ReadOnlyRecommended = True Then
    MsgBox "This workbook is saved as read-only recommended"
End If


RecentFiles-Eigenschaft

Gibt eine RecentFiles-Auflistung zurück, die die Liste der zuletzt geöffneten Dateien darstellt.

Informationen über den Zugriff auf ein einzelnes Objekt einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung


Beispiel zur RecentFiles-Eigenschaft

In diesem Beispiel wird die maximale Anzahl der Einträge in der Liste der zuletzt geöffneten Dateien auf 6 gesetzt.

Application.RecentFiles.Maximum = 6


Recipients-Eigenschaft

Gibt die Empfänger im Verteiler zurück oder legt diese fest.

Syntax

Ausdruck.Recipients(Index)

Ausdruck Ein erforderlicher Ausdruck, der ein RoutingSlip-Objekt zurückgibt.

Index Variant optional. Der Empfänger. Wird dieses Argument nicht angegeben, gibt die Recipients-Eigenschaft eine Matrix zurück, die alle Empfänger enthält (bzw. legt diese fest).

Anmerkungen

Die Reihenfolge der Empfängerliste definiert die Reihenfolge der Übermittlung, wenn die Übermittlungsoption für den Verteiler xlOneAfterAnother ist.

Findet momentan eine Verteilung statt, werden nur die Empfänger, die das Dokument noch nicht erhalten und weitergeleitet haben, zurückgegeben oder festgelegt.


Beispiel zur Recipients-Eigenschaft

In diesem Beispiel wird die geöffnete Arbeitsmappe nacheinander an drei Empfänger gesendet.

With ThisWorkbook
    .HasRoutingSlip = True
    With .RoutingSlip
        .Delivery = xlOneAfterAnother
        .Recipients = Array("Adam Bendel", _
            "Jean Selva", "Bernard Gabor")
        .Subject = "Here is the workbook"
        .Message = "Here is the workbook. What do you think?"
        .ReturnWhenDone = True
End With
    .Route
End With


RecordCount-Eigenschaft

Gibt die Anzahl der Sätze im PivotTable-Cache oder die Anzahl der Cache-Sätze, die das angegebene Element enthalten, zurück. Long Lese-Zugriff.

Anmerkungen

Diese Eigenschaft gibt den Übergangszustand des Cache zum Zeitpunkt der Abfrage wider. Der Cache kann sich zwischen Abfragen ändern.


Beispiel zur RecordCount-Eigenschaft

In diesem Beispiel wird die Anzahl der Cache-Sätze angezeigt, die "Kiwi" im Feld "Produkt" enthalten.

MsgBox Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Product").PivotItems("Kiwi").RecordCount


RecordRelative-Eigenschaft

True, wenn Makros mit relativen Bezügen aufgezeichnet werden. False, wenn die Aufzeichnung absolut erfolgt. Boolean Schreibgeschützt.


Beispiel zur RecordRelative-Eigenschaft

In diesem Beispiel wird die Adresse der aktiven Zelle in Sheet1 in der Bezugsart A1 angezeigt, falls RecordRelative den Wert False hat. Andernfalls wird die Adresse in der Schreibweise Z1S1 angezeigt.

Worksheets("Sheet1").Activate
If Application.RecordRelative = False Then
    MsgBox ActiveCell.Address(ReferenceStyle:=xlA1)
Else
    MsgBox ActiveCell.Address(ReferenceStyle:=xlR1C1)
End If


Recordset-Eigenschaft

Gibt ein Recordset-Objekt zurück, das als Datenquelle für die angegebene Abfragetabellen- oder PivotTable-Cache verwendet wird, oder legt es fest. Lese- und Schreibzugriff.

Anmerkungen

Wird diese Eigenschaft verwendet, um einen bestehenden Recordset zu überschreiben, so treten die Änderungen in Kraft, wenn die Refresh-Methode ausgeführt wird.


Beispiel zur Recordset-Eigenschaft

In diesem Beispiel wird das Recordset-Objekt, das mit der ersten Abfragetabelle im ersten Tabellenblatt verwendet wird, geändert und anschließend die Abfragetabelle aktualisiert.

With Worksheets(1).QueryTables(1)
    .Recordset = _
        OpenDatabase("c:\Nwind.mdb") _
        .OpenRecordset("employees")
    .Refresh
End With

In diesem Beispiel wird mit Hilfe einer ADO-Verbindung zu Microsoft Jet ein neuer PivotTable-Cache erstellt und dann in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht, der auf dem Cache basiert.

Dim cnnConn As ADODB.Connection
Dim rstRecordset As ADODB.Recordset
Dim cmdCommand As ADODB.Command

' Open the connection.
Set cnnConn = New ADODB.Connection
With cnnConn
    .ConnectionString = _
        "Provider=Microsoft.Jet.OLEDB.4.0"
    .Open "C:\perfdate\record.mdb"
End With

' Set the command text.
Set cmdCommand = New ADODB.Command
Set cmdCommand.ActiveConnection = cnnConn
With cmdCommand
    .CommandText = "Select Speed, Pressure, Time From DynoRun"
    .CommandType = adCmdText
    .Execute
End With

' Open the recordset.
Set rstRecordset = New ADODB.Recordset
Set rstRecordset.ActiveConnection = cnnConn
rstRecordset.Open cmdCommand

' Create a PivotTable cache and report.
Set objPivotCache = ActiveWorkbook.PivotCaches.Add( _
    SourceType:=xlExternal)
Set objPivotCache.Recordset = rstRecordset
With objPivotCache
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:="Performance"
End With

With ActiveSheet.PivotTables("Performance")
    .SmallGrid = False
    With .PivotFields("Pressure")
        .Orientation = xlRowField
        .Position = 1
    End With
    With .PivotFields("Speed")
        .Orientation = xlColumnField
        .Position = 1
    End With
    With .PivotFields("Time")
        .Orientation = xlDataField
        .Position = 1
    End With
End With

' Close the connections and clean up.
cnnConn.Close
Set cmdCommand = Nothing
Set rstRecordSet = Nothing
Set cnnConn = Nothing


ReferenceStyle-Eigenschaft

Gibt die Einstellung zurück oder legt fest, wie Microsoft Excel Zellbezüge sowie Zeilen- und Spaltenköpfe in der Z1S1- oder A1-Schreibweise anzeigt. Kann eine der folgenden XlReferenceStyle-Konstanten sein: xlA1 oder xlR1C1. Long Schreib-Lese-Zugriff.


Beispiel zur ReferenceStyle-Eigenschaft

In diesem Beispiel wird die aktuelle Bezugsart angezeigt.

If Application.ReferenceStyle = xlR1C1 Then
    MsgBox ("Microsoft Excel is using R1C1 references")
Else
    MsgBox ("Microsoft Excel is using A1 references")
End If


RefersTo-Eigenschaft

Gibt die Formel, auf die sich der Name bezieht, als Zeichenfolge in der Sprache des Makros zurück oder legt sie fest. Die Zeichenfolge verwendet den Bezug in der A1-Schreibweise und beginnt mit einem Gleichheitszeichen. String Schreib-Lese-Zugriff.


RefersToLocal-Eigenschaft

Gibt eine Zeichenfolge in der Sprache des Benutzers in A1-Schreibweise, beginnend mit einem Gleichheitszeichen zurück oder legt sie fest. Diese Zeichenfolge enthält die Formel, auf die sich der Name bezieht. String Schreib-Lese-Zugriff.


Beispiel zur RefersToLocal-Eigenschaft

In diesem Beispiel wird ein neues Tabellenblatt erstellt und anschließend eine Liste aller Namen in der aktiven Arbeitsmappe zusammen mit den zugehörigen Formeln in A1-Schreibweise in der Sprache des Benutzers eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.NameLocal
    newSheet.Cells(i, 2).Value = "'" & nm.RefersToLocal
    i = i + 1
Next


RefersToR1C1-Eigenschaft

Gibt eine Formel in Z1S1-Schreibweise, beginnend mit einem Gleichheitszeichen, in der Sprache des Makros zurück oder legt sie fest. Diese Zeichenfolge enthält die Formel, auf die sich der Name bezieht. String Schreib-Lese-Zugriff.


RefersToR1C1Local-Eigenschaft

Gibt eine Formel in Z1S1-Schreibweise, beginnend mit einem Gleichheitszeichen, in der Sprache des Makros zurück oder legt sie fest. Diese Zeichenfolge enthält die Formel, auf die sich der Name bezieht. String Schreib-Lese-Zugriff.


Beispiel zur RefersToR1C1Local-Eigenschaft

In diesem Beispiel wird ein neues Tabellenblatt erstellt und anschließend eine Liste aller Namen in der aktiven Arbeitsmappe zusammen mit den zugehörigen Formeln in Z1S1-Schreibweise in der Sprache des Benutzers eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.NameLocal
    newSheet.Cells(i, 2).Value = "'" & nm.RefersToR1C1Local
    i = i + 1
Next


RefersToRange-Eigenschaft

Gibt das Range-Objekt zurück, auf das sich das Name-Objekt bezieht. Schreibgeschützt.

Anmerkungen

Bezieht sich das Name-Objekt nicht auf einen Bereich (sondern beispielsweise auf eine Konstante oder Formel), schlägt diese Eigenschaft fehl.

Um den Bereich zu ändern, auf den sich ein Name bezieht, verwenden Sie die RefersTo-Eigenschaft.


Beispiel zur RefersToRange-Eigenschaft

In diesem Beispiel wird die Anzahl der Zeilen und Spalten im Druckbereich des aktiven Tabellenblatts angezeigt.

p = Names("Print_Area").RefersToRange.Value
MsgBox "Print_Area: " & UBound(p, 1) & " rows, " & _
    UBound(p, 2) & " columns"


 RefreshDate-Eigenschaft

RefreshDate-Eigenschaft

Gibt das Datum der letzten Aktualisierung des PivotTable-Berichts oder des PivotTable-Caches zurück. Date Schreibgeschützt.

Anmerkungen

Bei PivotCache-Objekten muss der Cache mindestens einem PivotTable-Bericht zugeordnet sein.

Bei OLAP-Datenquellen wird diese Eigenschaft nach jeder Abfrage aktualisiert.


Beispiel zur RefreshDate-Eigenschaft

In diesem Beispiel wird das Datum der letzten Aktualisierung des PivotTable-Berichts angezeigt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
dateString = Format(pvtTable.RefreshDate, "Long Date")
MsgBox "The data was last refreshed on " & dateString


Refreshing-Eigenschaft

True, falls für die angegebene Abfragetabelle gerade eine Hintergrundabfrage durchgeführt wird. Boolean Lese- und Schreibzugriff.

Anmerkungen

Verwenden Sie die CancelRefresh-Methode, um Hintergrundabfragen abzubrechen.


Beispiel zur Refreshing-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, falls für die erste Abfragetabelle gerade eine Hintergrundabfrage durchgeführt wird.

With Worksheets(1).QueryTables(1)
    If .Refreshing Then
        MsgBox "Query is currently refreshing: please wait"
    Else
        .Refresh BackgroundQuery := False
        .ResultRange.Select
    End If
End With


 RefreshName-Eigenschaft

RefreshName-Eigenschaft

Gibt den Namen desjenigen Benutzers oder der Benutzerin zurück, der die Daten des PivotTable-Berichts oder den PivotTable-Cache zuletzt aktualisiert hat. String Schreibgeschützt.

Anmerkungen

Bei OLAP-Datenquellen wird diese Eigenschaft nach jeder Abfrage aktualisiert.


Beispiel zur RefreshName-Eigenschaft

In diesem Beispiel wird der Name der Person angezeigt, die den PivotTable-Bericht zuletzt aktualisiert hat.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
MsgBox "The data was last refreshed by " & pvtTable.RefreshName


RefreshOnChange-Eigenschaft

True, wenn die angegebene Abfrage bei jeder Änderung des Parameterwerts einer Parameterabfrage aktualisiert wird. Boolean Schreib-/Lesezugriff.

Anmerkungen

Sie können diese Eigenschaft nur dann auf True festlegen, wenn Sie Parameter vom Typ xlRange verwenden und der referenzierte Parameterwert sich in einer einzelnen Zelle befindet. Die Aktualisierung erfolgt, wenn Sie den Wert der Zelle ändern.


Beispiel zur RefreshOnChange-Eigenschaft

In diesem Beispiel wird die SQL-Anweisung für die erste Abfragetabelle in Sheet1 geändert. Die Klausel "(ContactTitle=?)" kennzeichnet, dass es sich bei der Abfrage um eine Parameterabfrage handelt. Der Wert des Titels wird auf den Wert der Zelle "D4" festgelegt. Die Abfragetabelle wird immer dann automatisch aktualisiert, wenn sich der Wert dieser Zelle ändert.

Set objQT = Worksheets("Sheet1").QueryTables(1)
objQT.CommandText = "Select * From Customers Where (ContactTitle=?)"
Set objParam1 = objQT.Parameters _
    .Add("Contact Title", xlParamTypeVarChar)
objParam1.RefreshOnChange = True
objParam1.SetParam xlRange, Range("D4")


RefreshOnFileOpen-Eigenschaft

True, wenn der PivotTable-Cache oder die Abfragetabelle jedes Mal automatisch aktualisiert wird, wenn die Arbeitsmappe geöffnet wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Abfragetabellen und PivotTable-Berichte werden nicht automatisch aktualisiert, wenn Sie die Arbeitsmappe mit der Open-Methode in Visual Basic öffnen. Mit der Refresh-Methode können Sie die Daten nach dem Öffnen der Arbeitsmappe aktualisieren.


Beispiel zur RefreshOnFileOpen-Eigenschaft

In diesem Beispiel wird der PivotTable-Cache bei jedem Öffnen der Arbeitsmappe automatisch aktualisiert.

ActiveWorkbook.PivotCaches(1).RefreshOnFileOpen = True


RefreshPeriod-Eigenschaft

Gibt die Anzahl der Minuten zwischen Aktualisierungen fest. Long Schreib-/Lesezugriff.

Anmerkungen

Wird der Zeitraum auf 0 (Null) festgelegt, sind zeitabhängige automatische Aktualisierungen deaktiviert. Dies entspricht der Einstellung dieser Eigenschaft auf Null.

Der Wert der RefreshPeriod-Eigenschaft kann eine ganze Zahl zwischen 0 und 32767 sein.


Beispiel zur RefreshPeriod-Eigenschaft

In diesem Beispiel wird der Aktualisierungszeitraum für den PivotTable-Cache ("PivotTable3") auf 15 Minuten festgelegt.

Set objPC = Worksheets("Sheet1").PivotTables("PivotTable3").PivotCache
objPC.RefreshPeriod = 15


RefreshStyle-Eigenschaft

Gibt zurück oder legt fest, wie Zeilen in dem angegeben Tabellenblatt hinzugefügt oder gelöscht werden, damit die Anzahl der Zeilen eines Recordset, der von einer Abfrage zurückgegeben wird, eingefügt werden können. Long Schreib-Lese-Zugriff.

Dies kann eine der folgenden xlCellInsertionMode-Konstanten sein.

Konstante | Beschreibung
xlOverwriteCells | Dem Tabellenblatt werden keine neue Zellen oder Zeilen hinzugefügt. Daten in umgebenden Zellen werden überschrieben, um die zusätzlichen Daten einfügen zu können.
xlInsertDeleteCells | Teile von Zeilen werden hinzugefügt oder gelöscht, damit die genaue Anzahl der für den neuen Recordset benötigten Zeilen erreicht wird.
xlInsertEntireRows | Falls notwendig, werden ganze Zeilen eingefügt, um zusätzliche Daten aufzunehmen. Aus dem Tabellenblatt werden keine Zellen oder Zeilen gelöscht.


Beispiel zur RefreshStyle-Eigenschaft

In diesem Beispiel wird der Sheet1 eine Abfragetabelle hinzugefügt. Mit der RefreshStyle-Eigenschaft werden dem Tabellenblatt nach Bedarf neue Zeilen hinzugefügt, um die Ergebnisdaten aufzunehmen.

Dim qt As QueryTable
Set qt = Sheets("sheet1").QueryTables _
    .Add(Connection:="Finder;c:\myfile.dqy", _
        Destination:=Range("sheet1!a1"))
With qt
    .RefreshStyle = xlInsertEntireRows
    .Refresh
End With


RegisteredFunctions-Eigenschaft

Gibt Informationen über Funktionen in Dynamic-Link Libraries (DLLs) oder Code-Ressourcen zurück, die mit den Makrofunktionen REGISTER oder REGISTER.KENNNUMMER registriert wurden. Variant Schreibgeschützt.

Syntax

Ausdruck.RegisteredFunctions(Index1, Index2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Application-Objekt zurückgibt.

Index1 Variant optional. Der Name der DLL oder Code-Ressource.

Index2 Variant optional. Der Name der Funktion.

Anmerkungen

Wenn Sie keine Indexargumente angeben, gibt diese Eigenschaft eine Matrix mit einer Liste aller registrierten Funktionen zurück. Jede Zeile der Matrix enthält Informationen über jeweils eine Funktion, wie in der folgenden Tabelle beschrieben.

Spalte | Inhalt
1 | Der Name der DLL oder Code-Ressource
2 | Der Name der Prozedur in der DLL oder Code-Ressource
3 | Zeichenfolgen, die die Datentypen der Rückgabewerte sowie die Anzahl und Datentypen der Argumente angeben

Wenn keine registrierten Funktionen vorhanden sind, gibt diese Eigenschaft Null zurück.


Beispiel zur RegisteredFunctions-Eigenschaft

In diesem Beispiel wird eine Liste der registrierten Funktionen erstellt, wobei jeweils eine Funktion pro Zeile in Sheet1 angezeigt wird. Spalte A beinhaltet den vollständigen Pfad und Dateinamen der DLL oder der Code-Ressource, Spalte B den Funktionsnamen und Spalte C die Datentypen der Argumente.

theArray = Application.RegisteredFunctions
If IsNull(theArray) Then
    MsgBox "No registered functions"
Else
    For i = LBound(theArray) To UBound(theArray)
        For j = 1 To 3
            Worksheets("Sheet1").Cells(i, j). _
                Formula = theArray(i, j)
        Next j
    Next i
End If


RelyOnVML-Eigenschaft

True, wenn aus Zeichnungsobjekten beim Speichern eines Dokuments als Webseite keine Bilddateien erstellt werden. False, wenn Bilder erstellt werden. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie können die Dateigrößen reduzieren, indem Sie keine Bilder für Zeichnungsobjekte erstellen, falls Ihr Webbrowser VML (Vector Markup Language) unterstützt. Microsoft Internet Explorer 5 unterstützt beispielsweise dieses Feature; Sie sollten die RelyOnVML-Eigenschaft auf True festlegen, wenn dieser Browser als Zielbrowser verwendet wird. Bei Browsern, die VML nicht unterstützen, wird das Bild beim Anzeigen einer Webseite, bei der diese Eigenschaft beim Speichern aktiviert wurde, nicht angezeigt.

Sie sollten beispielsweise keine Bilder erstellen, wenn die Webseite Bilddateien verwendet, die früher erstellt wurden, und wenn der Speicherort, an dem das Dokument gespeichert wird, sich von dem endgültigen Speicherort der Seite auf dem Webserver unterscheidet.


Beispiel zur RelyOnVML-Eigenschaft

In diesem Beispiel wird angegeben, dass beim Speichern des Tabellenblatts als Webseite Bilder erstellt werden.

Workbooks(1).WebOptions.RelyOnVML = False


RepeatItemsOnEachPrintedPage-Eigenschaft

True, wenn Zeilen-, Spalten und Elementbeschriftungen beim Drucken des angegebenen PivotTable-Berichts in der ersten Zeile jeder Seite angezeigt werden. False, wenn die Beschriftungen lediglich auf der ersten Seite gedruckt werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei dem PivotTable-Bericht muss es sich um den einzigen im Druckbereich handeln. Zum Festlegen eines Einzugsformats für einen PivotTable-Bericht verwenden Sie die Format-Methode.

Microsoft Excel druckt Zeilen- und Spaltenbeschriftungen an Stelle von Drucktiteln, die für das Tabellenblatt festgelegt wurden. Mit Hilfe der PrintTitles-Eigenschaft können Sie feststellen, ob für den PivotTable-Bericht Drucktitel festgelegt wurden.


Beispiel zur RepeatItemsOnEachPrintedPage-Eigenschaft

In diesem Beispiel wird festgelegt, dass Microsoft Excel die Beschriftungen auf jeder Seite wiederholt, wenn der vierte PivotTable-Bericht im aktiven Tabellenblatt gedruckt wird.

ActiveSheet.PivotTables("PivotTable4") _
    .RepeatItemsOnEachPrintedPage = True


ReplaceText-Eigenschaft

True, wenn Text, der einem Eintrag in der AutoKorrektur-Ersetzungsliste entspricht, automatisch ersetzt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ReplaceText-Eigenschaft

In diesem Beispiel wird die automatische Textersetzung ausgeschaltet.

With Application.AutoCorrect
    .CapitalizeNamesOfDays = True
    .ReplaceText = False
End With


Resize-Eigenschaft

Ändert die Größe des angegebenen Bereichs. Gibt ein Range-Objekt zurück, das den geänderten Bereich darstellt.

Syntax

Ausdruck.Resize(RowSize, ColumnSize)

Ausdruck Erforderlich. Ein Ausdruck, der ein Range-Objekt zurückgibt, dessen Größe zu ändern ist.

RowSize Variant optional. Die Anzahl der Zeilen im neuen Bereich. Falls dieses Argument nicht angegeben wird, bleibt die Anzahl der Zeilen im Bereich unverändert.

ColumnSize Variant optional. Die Anzahl der Spalten im neuen Bereich. Falls dieses Argument nicht angegeben wird, bleibt die Anzahl der Spalten im Bereich unverändert.


Beispiel zur Resize-Eigenschaft

In diesem Beispiel wird die Markierung in Sheet1 um eine Zeile und eine Spalte erweitert.

Worksheets("Sheet1").Activate
numRows = Selection.Rows.Count
numColumns = Selection.Columns.Count
Selection.Resize(numRows + 1, numColumns + 1).Select

In diesem Beispiel wird vorausgesetzt, dass das erste Tabellenblatt eine Tabelle mit einer Überschriftenzeile enthält. Die Tabelle wird mit Ausnahme der Überschriftenzeile markiert, wobei sich die aktive Zelle vor dem Ausführen des Beispiels innerhalb der Tabelle befinden muss.

Set tbl = ActiveCell.CurrentRegion
tbl.Offset(1, 0).Resize(tbl.Rows.Count - 1, _
    tbl.Columns.Count).Select


ResultRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den von der angegebenen Abfragetabelle eingenommenen Bereich des Tabellenblattes darstellt. Schreibgeschützt.

Anmerkungen

Der Bereich umfasst nicht die Feldnamenzeile oder die Zeilennummernspalte.


Beispiel zur ResultRange-Eigenschaft

In diesem Beispiel werden die Daten in der ersten Spalte der ersten Abfragetabelle addiert. Die Summe der ersten Spalte wird unterhalb des Datenbereichs angezeigt.

Set c1 = Sheets("sheet1").QueryTables(1).ResultRange.Columns(1)
c1.Name = "Column1"
c1.End(xlDown).Offset(2, 0).Formula = "=sum(Column1)"


ReturnWhenDone-Eigenschaft

True, wenn die Arbeitsmappe zum Absender zurückgeleitet wird, sobald das Weiterleiten abgeschlossen ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn gerade eine Übermittlung stattfindet, lässt sich diese Eigenschaft nicht anwenden.


Beispiel zur ReturnWhenDone-Eigenschaft

In diesem Beispiel wird MAPPE1.XLS nacheinander an drei Empfänger weitergeleitet und an den Absender zurückgeleitet, sobald das Weiterleiten abgeschlossen ist.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
    .ReturnWhenDone = True
End With
Workbooks("BOOK1.XLS").Route


ReversePlotOrder-Eigenschaft

True, wenn Microsoft Excel Datenpunkte (Rubriken) in umgekehrter Reihenfolge, also beginnend mit dem letzten Datenpunkt, darstellt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft ist für Netzdiagramme nicht verfügbar.


Beispiel zur ReversePlotOrder-Eigenschaft

In diesem Beispiel werden Datenpunkte auf der Größenachse in Chart1 in umgekehrter Reihenfolge dargestellt.

Charts("Chart1").Axes(xlValue).ReversePlotOrder = True


RevisionNumber-Eigenschaft

Gibt als Ergebnis zurück, wie oft die Arbeitsmappe im Freigabemodus gespeichert wurde. Ist die Arbeitsmappe im Exklusivmodus geöffnet, gibt diese Eigenschaft 0 (Null) zurück. Long Schreibgeschützt.

Anmerkungen

Die RevisionNumber-Eigenschaft wird nur dann aktualisiert, wenn die lokale Kopie der Arbeitsmappe gespeichert wird, nicht jedoch beim Speichern der Kopien weiterer Benutzer/innen.


Beispiel zur RevisionNumber-Eigenschaft

Im folgenden Beispiel wird die Änderungsnummer verwendet, um festzustellen, ob die aktive Arbeitsmappe im Exklusivmodus geöffnet ist. Ist dies der Fall, wird die aktive Arbeitsmappe im Freigabemodus gespeichert.

If ActiveWorkbook.RevisionNumber = 0 Then
    ActiveWorkbook.SaveAs _
        filename:=ActiveWorkbook.FullName, _
        accessMode:=xlShared, _
        conflictResolution:= _
            xlOtherSessionChanges
End If


RGB-Eigenschaft

ChartColorFormat-Objekt: Gibt den Rot-Grün-Blau-Wert der angegebenen Farbe zurück. Long Schreibgeschützt.

ColorFormat-Objekt: Gibt den Rot-Grün-Blau-Wert der angegebenen Farbe zurück oder legt ihn fest. Long Schreib-Lese-Zugriff.


Beispiel zur RGB-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Innenbereichsfarbe des Bereichs A1:A10 der Vordergrundfüllfarbe des Flächendiagramms im ersten Diagramm entspricht.

Worksheets(1).Range("A1:A10").Interior.Color = _
    Charts(1).ChartArea.Fill.ForeColor.RGB


RightAngleAxes-Eigenschaft

True, wenn die Diagrammachsen im rechten Winkel zueinander stehen, unabhängig von der Drehung oder der Betrachtungshöhe des Diagramms. Nur für 3D-Linien-, Säulen- und Balkendiagramme gültig. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn diese Eigenschaft den Wert True hat, wird die Perspective-Eigenschaft nicht beachtet.


Beispiel zur RightAngleAxes-Eigenschaft

In diesem Beispiel werden die Achsen in Chart1 so eingestellt, dass sie sich im rechten Winkel schneiden. Wenden Sie das Beispiel auf ein 3D-Diagramm an.

Charts("Chart1").RightAngleAxes = True


RightFooter-Eigenschaft

Gibt den rechten Teil der Fußzeile zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Fußzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur RightFooter-Eigenschaft

In diesem Beispiel wird die Seitenzahl oben rechts auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.RightFooter = "&P"


RightHeader-Eigenschaft

Gibt den rechten Teil der Kopfzeile zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Im Kopfzeilentext können außerdem spezielle Formatcodes verwendet werden.


Beispiel zur RightHeader-Eigenschaft

In diesem Beispiel wird das Datum rechts oben auf jeder Seite gedruckt.

Worksheets("Sheet1").PageSetup.RightHeader = "&F"


 RightMargin-Eigenschaft

RightMargin-Eigenschaft

Gibt die Breite des rechten Randes in Punkt zurück oder legt diese fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Ränder werden in Punkt festgelegt oder zurückgegeben. Mit den Methoden InchesToPoints und CentimetersToPoints können Sie die Maßeinheiten umwandeln.


Beispiel zur RightMargin-Eigenschaft

In diesem Beispiel wird der rechte Rand für Sheet1 auf 1,5 Zoll eingestellt.

Worksheets("Sheet1").PageSetup.RightMargin = _
        Application.InchesToPoints(1.5)

In diesem Beispiel wird der rechte Rand für Sheet1 auf 2 Zentimeter eingestellt.

Worksheets("Sheet1").PageSetup.RightMargin = _
        Application.CentimetersToPoints(2)

In diesem Beispiel wird die aktuelle Einstellung des rechten Rands für Sheet1 angezeigt.

marginInches = Worksheets("Sheet1").PageSetup.RightMargin / _
    Application.InchesToPoints(1)
MsgBox "The current right margin is " & marginInches & " inches"


RollZoom-Eigenschaft

True, falls die IntelliMouse vergrößert, statt einen Bildlauf durchzuführen. Boolean Schreib-Lese-Zugriff.


Beispiel zur RollZoom-Eigenschaft

In diesem Beispiel wird festgelegt, dass die IntelliMouse vergrößert, statt einen Bildlauf durchzuführen.

Application.RollZoom = True


RotatedChars-Eigenschaft

True, wenn Zeichen in der angegebenen WordArt um 90 Grad, relativ zur Begrenzungsform der WordArt, gedreht werden. False, wenn Zeichen in der angegebenen WordArt ihre ursprüngliche Ausrichtung, relativ zur Begrenzungsform, beibehalten. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn die WordArt horizontalen Text besitzt, führt das Setzen der RotatedChars-Eigenschaft auf den Wert True zu einer 90-Grad-Drehung der Zeichen gegen den Uhrzeigersinn. Wenn die WordArt vertikalen Text besitzt, führt das Setzen der RotatedChars-Eigenschaft auf den Wert False zu einer 90-Grad-Drehung der Zeichen im Uhrzeigersinn. Verwenden Sie die ToggleVerticalText-Methode, um zwischen horizontalem und vertikalem Textfluss umzuschalten.

Die Flip-Methode und die Rotation-Eigenschaft des Shape-Objekts sowie die RotatedChars-Eigenschaft und die ToggleVerticalText-Methode des TextEffectFormat-Objekts wirken sich alle auf die Ausrichtung der Zeichen und die Richtung des Textflusses in einem Shape-Objekt aus, das die WordArt darstellt. Sie sollten durch Ausprobieren herausfinden, wie die Auswirkungen dieser Eigenschaften und Methoden zu kombinieren sind, damit Sie das gewünschte Ergebnis erhalten.


Beispiel zur RotatedChars-Eigenschaft

In diesem Beispiel wird in myDocument eine WordArt mit dem Text "Test" eingefügt und die Zeichen um 90 Grad gegen den Uhrzeigersinn gedreht.

Set myDocument = Worksheets(1)
Set newWordArt = myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=10, _
    Top:=10)
newWordArt.TextEffect.RotatedChars = True


Rotation-Eigenschaft

Chart-Objekt: Gibt die Drehung für die Ansicht des 3D-Diagramms (die Drehung der Diagrammfläche um die z-Achse in Grad) zurück oder legt sie fest. Dieser Wert muss zwischen 0 und 360 liegen. Bei 3D-Balkendiagrammen muss der Wert zwischen 0 und 44 liegen. Die Voreinstellung ist 20. Nur gültig für 3D-Diagramme. Variant Schreib-Lese-Zugriff.

Shape- oder ShapeRange-Objekt: Gibt die Drehung der Form in Grad zurück oder legt sie fest. Single Schreib-Lese-Zugriff.


Beispiel zur Rotation-Eigenschaft

In diesem Beispiel wird die Drehung von Chart1 auf 30 Grad festgelegt. Es ist sinnvoll, das Makro auf ein 3D-Diagramm anzuwenden.

Charts("Chart1").Rotation = 30


 RotationX-Eigenschaft

RotationX-Eigenschaft

Gibt die Rotation der projizierten Form um die X-Achse in Grad an. Kann ein Wert von -90 bis 90 sein. Ein positiver Wert steht für eine Drehung nach oben, ein negativer Wert für eine Drehung nach unten. Single Schreib-Lese-Zugriff.

Anmerkungen

Um die Rotation der projizierten Form um die Y-Achse festzulegen, verwenden Sie die RotationY-Eigenschaft des ThreeDFormat-Objekts. Um die Rotation der projizierten Form um die Z-Achse festzulegen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts. Um die Richtung der Projektionsausdehnung zu ändern, ohne ihre Vorderseite zu drehen, verwenden Sie die SetExtrusionDirection-Methode.


 RotationY-Eigenschaft

RotationY-Eigenschaft

Gibt die Rotation der projizierten Form um die Y-Achse in Grad an. Kann ein Wert von -90 bis 90 sein. Ein positiver Wert steht für eine Drehung nach links, ein negativer Wert für eine Drehung nach rechts. Single Schreib-Lese-Zugriff.

Anmerkungen

Um die Rotation der projizierten Form um die X-Achse festzulegen, verwenden Sie die RotationX -Eigenschaft des ThreeDFormat-Objekts. Um die Rotation der projizierten Form um die Z-Achse festzulegen, verwenden Sie die Rotation-Eigenschaft des Shape-Objekts. Um die Richtung der Projektionsausdehnung zu ändern, ohne ihre Vorderseite zu drehen, verwenden Sie die SetExtrusionDirection-Methode.


Beispiel zur RotationY-Eigenschaft

In diesem Beispiel werden in myDocument drei identische projizierte Ellipsen eingefügt und für ihre Drehung um die X-Achse ein Wert von -30, 0, bzw. 30 Grad festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    With .AddShape(msoShapeOval, 30, 30, 50, 25).ThreeD
        .Visible = True
        .RotationY = -30
    End With
    With .AddShape(msoShapeOval, 30, 70, 50, 25).ThreeD
        .Visible = True
        .RotationY = 0
    End With
    With .AddShape(msoShapeOval, 30, 110, 50, 25).ThreeD
        .Visible = True
        .RotationY = 30
    End With
End With


RoundedCorners-Eigenschaft

True, wenn das eingebettete Diagramm abgerundete Ecken besitzt. Boolean Schreib-Lese-Zugriff.


Beispiel zur RoundedCorners-Eigenschaft

In diesem Beispiel erhält das erste eingebettete Diagramm in Sheet1 abgerundete Ecken.

Worksheets("Sheet1").ChartObjects(1).RoundedCorners = True


Routed-Eigenschaft

True, wenn die Arbeitsmappe bereits an den nächsten Empfänger weitergeleitet wurde. False, wenn sie noch weitergeleitet werden muss. Boolean Schreibgeschützt.

Anmerkungen

Falls die Arbeitsmappe nicht an den aktuellen Empfänger weitergeleitet wurde, ist diese Eigenschaft immer False (z. B. wenn das Dokument keinen Verteiler enthält oder gerade erst ein Verteiler erstellt wurde).


Beispiel zur Routed-Eigenschaft

In diesem Beispiel wird die Arbeitsmappe an den nächsten Empfänger weitergeleitet.

If ActiveWorkbook.HasRoutingSlip And _
    Not ActiveWorkbook.Routed Then
        ActiveWorkbook.Route
End If


RoutingSlip-Eigenschaft

Gibt ein RoutingSlip-Objekt zurück, das den Verteiler für die Arbeitsmappe darstellt. Wenn beim Lesen dieser Eigenschaft kein Verteiler existiert, wird ein Fehler erzeugt. (Überprüfen Sie zuerst die HasRoutingSlip-Eigenschaft). Schreibgeschützt.


Beispiel zur RoutingSlip-Eigenschaft

In diesem Beispiel wird ein Verteiler für MAPPE1.XLS erstellt und die Arbeitsmappe den drei Empfängern nacheinander übermittelt.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
End With
Workbooks("BOOK1.XLS").Route


Row-Eigenschaft

Gibt die Nummer der ersten Zeile im ersten Bereich zurück. Long Schreibgeschützt.


RowColSettings-Eigenschaft

True, falls in der benutzerdefinierten Ansicht Einstellungen zu ausgeblendeten Zeilen und Spalten (einschließlich Filterinformationen) enthalten sind. Boolean Schreibgeschützt.


Beispiel zur RowColSettings-Eigenschaft

In diesem Beispiel wird eine Liste der benutzerdefinierten Ansichten in der aktiven Arbeitsmappe sowie deren Druck-, Zeilen- und Spalteneinstellungen erstellt.

With Worksheets(1)
    .Cells(1,1).Value = "Name"
    .Cells(1,2).Value = "Print Settings"
    .Cells(1,3).Value = "RowColSettings"
    rw = 0
    For Each v In ActiveWorkbook.CustomViews
        rw = rw + 1
        .Cells(rw, 1).Value = v.Name
        .Cells(rw, 2).Value = v.PrintSettings
        .Cells(rw, 3).Value = v.RowColSettings
    Next
End With


RowFields-Eigenschaft

Gibt ein Objekt zurück, das entweder ein einzelnes Feld in einem PivotTable-Bericht darstellt (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller Felder, die momentan als Zeilenfelder sichtbar sind (ein PivotFields-Objekt, Syntax 2). Lese-Zugriff.

Syntax 1

Ausdruck.RowFields(Index)

Syntax 2

Ausdruck.RowFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Name oder Zahl des zurückzugebenden Feldes (zur Angabe mehrerer Felder kann hier auch eine Matrix verwendet werden).


Beispiel zur RowFields-Eigenschaft

In diesem Beispiel werden die Namen der Zeilenfelder des PivotTable-Berichts in eine Liste in einer neuen Tabelle aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.RowFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


RowGrand-Eigenschaft

True, wenn in dem PivotTable-Bericht Gesamtergebnisse für Zeilen angezeigt werden. Boolean Lese- und Schreibzugriff.


Beispiel zur RowGrand-Eigenschaft

In diesem Beispiel wird festgelegt, dass in dem PivotTable-Bericht Gesamtergebnisse für Zeilen angezeigt werden.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.RowGrand = True


 RowHeight-Eigenschaft

RowHeight-Eigenschaft

Gibt die Höhe aller Zeilen im angegebenen Bereich in Punkt zurück. Gibt Null zurück, wenn die Zeilen im angegebenen Bereich nicht alle dieselbe Höhe haben. Variant Lese- und Schreibzugriff.

Anmerkungen

Bei einzelnen Zeilen ist der Wert der Height-Eigenschaft identisch mit dem Wert der RowHeight-Eigenschaft. Mit der Height-Eigenschaft können Sie allerdings auch die Gesamthöhe eines Zellbereichs zurückgeben.

Weitere Unterschiede zwischen RowHeight und Height:

  • Height ist schreibgeschützt.

  • Bei mehreren Zeilen gibt RowHeight entweder die Höhe einer einzelnen Zeile zurück (wenn alle Zellen gleich hoch sind) oder Null (wenn die Höhe der Zellen unterschiedlich ist). Die Height-Eigenschaft gibt bei mehreren Zeilen die Gesamthöhe aller Zeilen zurück.


Beispiel zur RowHeight-Eigenschaft

In diesem Beispiel wird die Höhe der ersten Zeile in Sheet1 verdoppelt.

With Worksheets("Sheet1").Rows(1)
    .RowHeight = .RowHeight * 2
End With


RowNumbers-Eigenschaft

True, falls Zeilennummern als erste Spalte der Abfragetabelle hinzugefügt werden. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wird diese Eigenschaft auf True gesetzt, erscheinen die Zeilennummern nicht sofort, sondern nach der nächsten Aktualisierung der Abfragetabelle. Sie werden bei jeder Aktualisierung der Abfragetabelle neu konfiguriert.


Beispiel zur RowNumbers-Eigenschaft

In diesem Beispiel werden der Abfragetabelle Zeilennummern und Feldnamen hinzugefügt.

With Worksheets(1).QueryTables("ExternalData1")
    .RowNumbers = True
    .FieldNames = True
    .Refresh
End With


RowRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den Zeilenbereich in dem PivotTable-Bericht enthält. Schreibgeschützt.


Beispiel zur RowRange-Eigenschaft

In diesem Beispiel werden die Zeilenüberschriften in dem PivotTable-Bericht markiert.

Worksheets("Sheet1").Activate
Range("A3").Select
ActiveCell.PivotTable.RowRange.Select


Rows-Eigenschaft

Application-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen des aktiven Tabellenblatts darstellt. Wenn das aktive Dokument kein Tabellenblatt ist, verursacht die Rows-Eigenschaft einen Fehler. Schreibgeschützt.

Range-Objekt: Gibt ein Range-Objekt zurück, das die Zeilen im angegebenen Bereich darstellt. Schreibgeschützt.

Worksheet-Objekt: Gibt ein Range-Objekt zurück, das alle Zeilen im angegebenen Tabellenblatt darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne einen Objektkennzeichner hat die gleiche Funktion wie ActiveSheet.Rows.

Wenn diese Eigenschaft auf ein Range-Objekt angewendet wird, das eine Mehrfachmarkierung enthält, gibt sie lediglich die Zeilen aus dem ersten Teil des Bereichs zurück. Wenn das Range-Objekt zum Beispiel zwei Bereiche – A1:B2 und C3:D4 – aufweist, gibt Selection.Rows.Count nicht 4, sondern 2 zurück. Wenn Sie diese Eigenschaft auf einen Bereich anwenden möchten, der möglicherweise eine Mehrfachmarkierung enthält, prüfen Sie mit Areas.Count, ob dies der Fall ist. Wenn der Bereich eine Mehrfachmarkierung enthält, müssen Sie die Eigenschaft in einer Schleife auf jeden Bereich einzeln anwenden (siehe Beispiel 3).


Beispiel zur Rows-Eigenschaft

In diesem Beispiel wird die dritte Zeile in Sheet1 gelöscht.

Worksheets("Sheet1").Rows(3).Delete

In diesem Beispiel werden Zeilen im aktuellen Bereich in Tabellenblatt 1 gelöscht, deren erste Zelle jeweils den gleichen Wert hat, wie die erste Zelle der vorherigen Zeile.

For Each rw In Worksheets(1).Cells(1, 1).CurrentRegion.Rows
    this = rw.Cells(1, 1).Value
    If this = last Then rw.Delete
    last = this
Next

In diesem Beispiel wird die Anzahl der Zeilen in der Markierung in Sheet1 angezeigt. Liegt eine Mehrfachmarkierung vor, werden alle Teile der Mehrfachmarkierung in einer Schleife bearbeitet.

Worksheets("Sheet1").Activate
areaCount = Selection.Areas.Count
If areaCount <= 1 Then
    MsgBox "The selection contains " & _
        Selection.Rows.Count & " rows."
Else
    i = 1
    For Each a In Selection.Areas
        MsgBox "Area " & i & " of the selection contains " & _
            a.Rows.Count & " rows."
        i = i + 1
    Next a
End If


Saved-Eigenschaft

True, wenn die angegebene Arbeitsmappe seit dem letzten Speichern nicht geändert wurde. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Falls eine Arbeitsmappe noch nie gespeichert wurde, gibt ihre Path-Eigenschaft eine leere Zeichenfolge zurück ("").

Sie können diese Eigenschaft auf True setzen, wenn Sie eine geänderte Arbeitsmappe schließen möchten, ohne sie zu speichern oder ohne zum Speichern aufgefordert zu werden.


 SaveData-Eigenschaft

SaveData-Eigenschaft

True, wenn die Daten des PivotTable-Berichts zusammen mit der Arbeitsmappe gespeichert werden. False, wenn nur die Definition des Berichts gespeichert wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist diese Eigenschaft immer auf False eingestellt.


Beispiel zur SaveData-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Daten des PivotTable-Berichts zusammen mit der Arbeitsmappe gespeichert werden.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.SaveData = True


SaveHiddenData-Eigenschaft

True, falls Daten außerhalb des angegebenen Bereichs beim Speichern des Dokuments als Webseite gespeichert werden. Diese Daten können für das Funktionieren von Formeln benötigt werden. False, falls Daten außerhalb des angegebenen Bereichs nicht mit der Webseite gespeichert werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn die Daten außerhalb des angegebenen Bereichs nicht gespeichert werden sollen, werden Verweise auf die betreffenden Daten in der Formel in statische Werte konvertiert. Wenn sich die Daten in einem anderen Tabellenblatt oder einer anderen Arbeitsmappe befinden, wird das Ergebnis der Formel als statischer Wert gespeichert.


Beispiel zur SaveHiddenData-Eigenschaft

In diesem Beispiel wird verhindert, dass ausgeblendete Daten mit Webseiten gespeichert werden.

Application.DefaultWebOptions.SaveHiddenData = False


SaveLinkValues-Eigenschaft

True, wenn Microsoft Excel externe Verknüpfungswerte mit der aktiven Arbeitsmappe speichert. Boolean Schreib-Lese-Zugriff.


Beispiel zur SaveLinkValues-Eigenschaft

In diesem Beispiel speichert Microsoft Excel externe Verknüpfungswerte mit der aktiven Arbeitsmappe.

ActiveWorkbook.SaveLinkValues = True


SavePassword-Eigenschaft

True, falls die Kennwortinformationen in einer ODBC-Verbindungs-Zeichenfolge zusammen mit der angegebenen Abfrage gespeichert wird. False, falls das Kennwort gelöscht wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft betrifft nur ODBC-Abfragen.


Beispiel zur SavePassword-Eigenschaft

In diesem Beispiel wird festgelegt, dass bei jedem Speichern der ersten Tabelle die Kennwortinformationen aus der ODBC-Verbindungszeichenfolge gelöscht werden.

Worksheets(1).QueryTables(1).SavePassword = False


ScaleType-Eigenschaft

Gibt die Art der Skalierung für die Größenachse zurück oder legt sie fest. Kann eine der folgenden XlScaleType-Konstanten sein: xlScaleLinear oder xlScaleLogarithmic. Nur gültig für die Größenachse. Long Schreib-Lese-Zugriff.

Anmerkungen

Eine logarithmische Skalierung verwendet Logarithmen zur Basis 10.


Beispiel zur ScaleType-Eigenschaft

In diesem Beispiel wird für die Größenachse in Chart1 eine logarithmische Skalierung verwendet.

Charts("Chart1").Axes(xlValue).ScaleType = xlScaleLogarithmic


SchemeColor-Eigenschaft

Gibt die Farbe eines Color-Objekts als Index der aktuellen Farbskala zurück oder legt die Farbe fest. Long Schreib-Lese-Zugriff.


Beispiel zur SchemeColor-Eigenschaft

In diesem Beispiel werden Vordergrundfarbe, Hintergrundfarbe und Farbverlauf der Füllung im Diagrammbereich des ersten Diagramms festgelegt.

With Charts(1).ChartArea.Fill
    .Visible = True
    .ForeColor.SchemeColor = 15
    .BackColor.SchemeColor = 17
    .TwoColorGradient msoGradientHorizontal, 1
End With


ScreenSize-Eigenschaft

Gibt die ideale minimale Bildschirmgröße (Breite mal Höhe in Pixel) zurück oder legt diese fest, die beim Anzeigen des gespeicherten Dokuments in einem Webbrowser verwendet werden sollte. Kann eine der nachfolgend aufgeführten MsoScreenSize-Konstanten sein. Die Standardkonstante ist msoScreenSize800x600. MsoScreenSize Schreib-Lese-Zugriff.

msoScreenSize1024x768

msoScreenSize1152x882

msoScreenSize1152x900

msoScreenSize1280x1024

msoScreenSize1600x1200

msoScreenSize1800x1440

 msoScreenSize1920x1200

msoScreenSize544x376

msoScreenSize640x480

msoScreenSize720x512

msoScreenSize800x600


Beispiel zur ScreenSize-Eigenschaft

In diesem Beispiel wird die Zielbildschirmgröße auf 800x600 Pixel festgelegt.

Application.DefaultWebOptions.ScreenSize = _
    msoScreenSize800x600


ScreenTip-Eigenschaft

Gibt den QuickInfo-Text für den angegebenen Hyperlink zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Nachdem das Dokument in einer Webseite gespeichert wurde, kann der QuickInfo-Text beispielsweise angezeigt werden, wenn der Mauszeiger über den Hyperlink positioniert wird, während das Dokument in einem Webbrowser angezeigt wird. Einige Webbrowser unterstützen möglicherweise keine QuickInfo.


Beispiel zur ScreenTip-Eigenschaft

In diesem Beispiel wird der QuickInfo für den ersten Hyperlink im aktiven Tabellenblatt festgelegt.

ActiveSheet.Hyperlinks(1).ScreenTip = "Return to the home page"


ScreenUpdating-Eigenschaft

True, wenn die Bildschirmaktualisierung aktiviert ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie können die Geschwindigkeit Ihres Makros erhöhen, wenn Sie die Bildschirmaktualisierung deaktivieren. Allerdings können Sie dann das Makro nicht mehr am Bildschirm mitverfolgen.

Denken Sie daran, die ScreenUpdating-Eigenschaft nach Beendigung des Makros auf True zurückzusetzen.


Beispiel zur ScreenUpdating-Eigenschaft

In diesem Beispiel wird gezeigt, wie das Deaktivieren der Bildschirmaktualisierung die Ausführung des Makros beschleunigt. Jede zweite Spalte in Sheet1 wird ausgeblendet, während die für diese Operation benötigte Zeit gespeichert wird. Beim ersten Schleifendurchlauf werden die Spalten ausgeblendet, die Bildschirmaktualisierung ist aktiviert. Beim zweiten Durchlauf ist die Bildschirmaktualisierung deaktiviert. Wenn Sie das Makro ausführen, haben Sie die Möglichkeit, die beiden in einem Meldungsfeld angezeigten Zeiten zu vergleichen.

Dim elapsedTime(2)
Application.ScreenUpdating = True
For i = 1 To 2
    If i = 2 Then Application.ScreenUpdating = False
    startTime = Time
    Worksheets("Sheet1").Activate
    For Each c In ActiveSheet.Columns
        If c.Column Mod 2 = 0 Then
            c.Hidden = True
        End If
    Next c
    stopTime = Time
    elapsedTime(i) = (stopTime - startTime) * 24 * 60 * 60
Next i
Application.ScreenUpdating = True
MsgBox "Elapsed time, screen updating on: " & elapsedTime(1) & _
        " sec." & Chr(13) & _
        "Elapsed time, screen updating off: " & elapsedTime(2) & _
        " sec."


Script-Eigenschaft

Gibt das Script-Objekt zurück, das einen Skript- oder Codeblock in der angegebenen Webseite darstellt. Enthält die Seite kein Skript, wird nothing zurückgegeben. Lese-Zugriff.


Scripts-Eigenschaft

Gibt die Scripts-Auflistung zurück, die die Script-Objekte enthält, die die Skript- oder Codeblöcke in dem angegebenen Dokument darstellen, wenn dieses als Webseite gespeichert wird. Lese-Zugriff.


Beispiel zur Scripts-Eigenschaft

In diesem Beispiel wird ein neuer VBScript-Block zu der Scripts-Auflistung im aktiven Tabellenblatt hinzugefügt.

Set objScrs = ActiveSheet.Scripts
Set objNewScr = objScrs.Add
objNewScr.Language = msoScriptLanguageVisualBasic


ScrollArea-Eigenschaft

Gibt den Bereich, in dem Bildlauf erlaubt ist, in der Schreibweise des A1-Bezugssystems zurück oder legt ihn fest. Zellen außerhalb des Bildlaufbereichs können nicht markiert werden. String Schreib-Lese-Zugriff.

Anmerkungen

Setzen Sie diese Eigenschaft auf eine leere Zeichenfolge (""), um die Zellmarkierung für das gesamte Blatt zu aktivieren.


Beispiel zur ScrollArea-Eigenschaft

In diesem Beispiel wird der Bildlaufbereich des ersten Tabellenblatts festgelegt.

Worksheets(1).ScrollArea = "a1:f10"


ScrollColumn-Eigenschaft

Gibt die Nummer der Spalte, die sich auf der linken Seite des Ausschnitts oder des Fensters befindet, zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn das Fenster geteilt ist, bezieht sich die ScrollColumn-Eigenschaft des Window-Objekts auf den linken oberen Ausschnitt. Sind die Ausschnitte fixiert, schließt die ScrollColumn-Eigenschaft des Window-Objekts die fixierten Bereiche aus.


Beispiel zur ScrollColumn-Eigenschaft

In diesem Beispiel wird die dritte Spalte an die äußerste linke Position im Fenster verschoben.

Worksheets("Sheet1").Activate
ActiveWindow.ScrollColumn = 3


ScrollRow-Eigenschaft

Gibt die Nummer der Zeile, die sich auf der oberen Seite des Ausschnitts oder des Fensters befindet, zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn das Fenster geteilt ist, bezieht sich die ScrollRow-Eigenschaft des Window-Objekts auf den linken oberen Ausschnitt. Sind die Ausschnitte fixiert, schließt die ScrollRow-Eigenschaft des Window-Objekts die fixierten Bereiche aus.


Beispiel zur ScrollRow-Eigenschaft

In diesem Beispiel wird die zehnte Zeile an den oberen Rand des Fensters verschoben.

Worksheets("Sheet1").Activate
ActiveWindow.ScrollRow = 10


SecondaryPlot-Eigenschaft

True, wenn sich der Punkt im sekundären Abschnitt eines Kreis aus Kreis-Diagrammen oder Balken aus Kreis-Diagrammen befindet. Trifft nur auf Punkte zu, die sich auf Kreis aus Kreis-Diagrammen oder Balken aus Kreis-Diagrammen befinden. Boolean Schreib-Lese-Zugriff.


Beispiel zur SecondaryPlot-Eigenschaft

Dieses Beispiel muss entweder mit einem Kreis aus Kreis-Diagramm oder einem Balken aus Kreis-Diagramm ausgeführt werden. In diesem Beispiel wird Punkt 4 in den sekundären Abschnitt des Diagramms verschoben.

With Worksheets(1).ChartObjects(1).Chart.SeriesCollection(1)
    .Points(4).SecondaryPlot = True
End With


SecondPlotSize-Eigenschaft

Gibt die Größe des sekundären Abschnitts eines Kreis aus Kreis-Diagramms oder Balken aus Kreis-Diagramms als Prozentangabe relativ zur Größe des primären Abschnitts zurück oder legt sie fest. Dabei kann es sich um einen Wert von 5 bis 200 handeln. Long Schreib-Lese-Zugriff.


Beispiel zur SecondPlotSize-Eigenschaft

Dieses Beispiel muss entweder mit einem Kreis aus Kreis-Diagramm oder einem Balken aus Kreis-Diagramm ausgeführt werden. Dieses Beispiel teilt die beiden Bereiche des Diagramms nach Wert auf, fasst dabei alle Werte unter 10 im primären Kreissegment zusammen und zeigt sie im sekundären Abschnitt an. Der sekundäre Abschnitt hat 50% der Größe des primären Kreises.

With Worksheets(1).ChartObjects(1).Chart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
    .SecondPlotSize = 50
End With


SegmentType-Eigenschaft

Gibt einen Wert zurück, der angibt, ob der dem angegebenen Knoten zugeordnete Abschnitt gerade oder gekrümmt ist. Kann eine der beiden folgenden MsoSegmentType-Konstanten sein: msoSegmentCurve oder msoSegmentLine. Wenn es sich bei dem angegebenen Knoten um einen Steuerpunkt eines gekrümmten Abschnitts handelt, gibt diese Eigenschaft msoSegmentCurve zurück. Long Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist schreibgeschützt. Verwenden Sie die SetSegmentType-Methode, um den Wert dieser Eigenschaft festzulegen.


Beispiel zur SegmentType-Eigenschaft

In diesem Beispiel werden in myDocument alle geraden Abschnitte der dritten Form in gekrümmte Abschnitte geändert. Bei der dritten Form muss es sich um eine Freihandzeichnung handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3).Nodes
    n = 1
    While n <= .Count
        If .Item(n).SegmentType = msoSegmentLine Then
            .SetSegmentType n, msoSegmentCurve
        End If
        n = n + 1
    Wend
End With


SelectedSheets-Eigenschaft

Gibt eine Sheets-Auflistung zurück, die alle im angegebenen Fenster markierten Blätter darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur SelectedSheets-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn Sheet1 in BOOK1.XLS markiert ist.

For Each sh In Workbooks("BOOK1.XLS").Windows(1).SelectedSheets
    If sh.Name = Sheet1 Then
        MsgBox "Sheet1 is selected"
        Exit For
    End If
Next


Selection-Eigenschaft

Application-Objekt: Gibt das markierte Objekt im aktiven Fenster zurück.

Window-Objekt: Gibt das markierte Objekt im angegebenen Fenster zurück.

Anmerkungen

Der zurückgegebene Objekttyp richtet sich nach der aktuellen Auswahl (bei Auswahl einer Zelle gibt diese Eigenschaft beispielsweise ein Range-Objekt zurück). Die Eigenschaft Selection gibt Nothing zurück, wenn nichts markiert wurde.

Die Verwendung dieser Eigenschaft ohne Objektkennzeichner hat die gleiche Wirkung wie Application.Selection.


SelectionMode-Eigenschaft

Gibt den strukturierten Markierungsmodus eines PivotTable-Berichts zurück oder legt ihn fest. Kann eine der folgenden XlPTSelectionMode-Konstanten sein: xlLabelOnly, xlDataAndLabel, xlDataOnly oder, wenn das angegebene PivotTable-Feld in Form einer Gliederung vorliegt, die Summe aller dieser Konstanten plus xlFirstRow. Long Schreib-Lese-Zugriff.

Anmerkungen

Liegt das PivotTable-Feld nicht in Form einer Gliederung vor, entspricht die Angabe der Summe einer beliebigen Konstante und xlFirstRow der Angabe der einzelnen Konstante.


Beispiel zur SelectionMode-Eigenschaft

In diesem Beispiel wird der strukturierte Markierungsmodus aktiviert und dann der PivotTable-Bericht im ersten Tabellenblatt so eingestellt, dass nur Daten ausgewählt werden können.

Application.PivotTableSelection = True
Worksheets(1).PivotTables(1).SelectionMode = xlDataOnly

In diesem Beispiel befindet sich der PivotTable-Bericht in der Gliederungsform.

Application.PivotTableSelection = True
Worksheets(1).PivotTables(1).SelectionMode = _
    xlDataOnly + xlFirstRow


SeriesLines-Eigenschaft

Gibt ein SeriesLines-Objekt zurück, das die Verbindungslinien der Datenreihen für ein gestapeltes Balken- oder Säulendiagramm darstellt. Nur gültig für gestapelte Balken- oder Säulendiagramme. Schreibgeschützt.


Beispiel zur SeriesLines-Eigenschaft

In diesem Beispiel werden Verbindungslinien für die erste Diagrammgruppe in Chart1 angezeigt. Danach werden die Linienart, die Stärke und die Farbe festgelegt. Es ist sinnvoll, das Beispiel auf ein gestapeltes 2D-Säulendiagramm mit mindestens zwei Datenreihen anzuwenden.

With Charts("Chart1").ChartGroups(1)
    .HasSeriesLines = True
    With .SeriesLines.Border
        .LineStyle = xlThin
        .Weight = xlMedium
        .ColorIndex = 3
    End With
End With


 ServerBased-Eigenschaft

ServerBased-Eigenschaft

True, wenn es sich bei der Datenquelle des angegebenen PivotTable-Berichts um eine externe Datenquelle handelt und nur die Elemente abgerufen werden, die dem markierten Seitenfeld entsprechen. Boolean Schreib-Lese-Zugriff.

Diese Eigenschaft gilt nicht für OLAP-Datenquellen und ist immer False.

Wenn diese Eigenschaft True ist, werden aus der Datenbank nur Datensätze abgerufen, die dem markierten Seitenfeldelement entsprechen. Sobald der Benutzer die Seitenfeldmarkierung ändert, wird von diesem Augenblick an das neu markierte Seitenfeldelement der Abfrage als Parameter übergeben und der Cache aktualisiert.

Diese Eigenschaft kann nicht eingestellt werden, wenn eine der folgenden Bedingungen erfüllt ist:

  • Das Feld gehört einer Gruppe an.

  • Die Datenquelle ist nicht extern.

  • Der Cache wird von mindestens zwei PivotTable-Berichten gemeinsam verwendet.

  • Das Feld hat einen Datentyp, der nicht serverbasiert sein kann (ein Memo-Feld oder ein OLE-Objekt).


Beispiel zur ServerBased-Eigenschaft

In diesem Beispiel werden alle serverbasierten Seitenfelder aufgelistet.

For Each fld in ActiveSheet.PivotTables(1).PageFields
    If fld.ServerBased = True Then
        r = r + 1
        Worksheets(2).Cells(r, 1).Value = fld.Name
    End If
Next


Shadow-Eigenschaft

True, wenn die Schriftart eine schattierte Schriftart ist oder das Zeichenobjekt einen Schatten besitzt. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Unter Microsoft Windows hat diese Eigenschaft beim Font-Objekt keine Wirkung. Ihr Wert wird jedoch beibehalten (er kann festgelegt und zurückgegeben werden).


Beispiel zur Shadow-Eigenschaft

In diesem Beispiel wird dem Titel von Chart1 ein Schatten hinzugefügt.

Charts("Chart1").ChartTitle.Shadow = True


Shape-Eigenschaft

Gibt ein Shape-Objekt zurück, das die Form darstellt, die dem angegebenen Kommentar oder Hyperlink zugeordnet ist.


ShapeRange-Eigenschaft

Gibt ein ShapeRange-Objekt zurück, das ein oder mehrere angegebene Objekte darstellt. Schreibgeschützt.


Beispiel zur ShapeRange-Eigenschaft

In diesem Beispiel wird ein Formbereich erstellt, der die eingebetteten Diagramme des ersten Tabellenblattes darstellt.

Set sr = Worksheets(1).ChartObjects.ShapeRange


Shapes-Eigenschaft

Gibt ein Shapes-Objekt zurück, das alle Formen des Tabellenblattes oder des Diagrammblattes darstellt. Schreibgeschützt.

Informationen über das Zurückgeben eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Shapes-Eigenschaft

In diesem Beispiel wird dem ersten Tabellenblatt eine blau gestrichelte Linie hinzugefügt.

With Worksheets(1).Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With


Sheet-Eigenschaft

Gibt den Namen des Blatts für das angegebene PublishObject-Objekt zurück. String Lese-Zugriff.


Sheets-Eigenschaft

Application-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Blätter in der aktiven Arbeitsmappe darstellt. Schreibgeschützt.

Workbook-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Blätter in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne einen Objektkennzeichner hat die gleiche Funktion wie ActiveWorkbook.Sheets.


SheetsInNewWorkbook-Eigenschaft

Gibt die Anzahl der Blätter zurück, die Microsoft Excel automatisch in neue Arbeitsmappen einfügt, oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur SheetsInNewWorkbook-Eigenschaft

In diesem Beispiel wird die Anzahl der Blätter angezeigt, die automatisch in eine neue Arbeitsmappe eingefügt werden.

MsgBox "Microsoft Excel inserts " & _
    Application.SheetsInNewWorkbook & _
    " sheet(s) in each new workbook"


ShortcutKey-Eigenschaft

Gibt den Shortcut für einen Namen zurück, der als benutzerdefinierter Makrobefehl für Microsoft Excel, Version 4.0, definiert wurde, oder legt den Shortcut fest. String Schreib-Lese-Zugriff.


Beispiel zur ShortcutKey-Eigenschaft

In diesem Beispiel wird der Shortcut für den ersten Namen in der aktiven Arbeitsmappe festgelegt. Wenden Sie das Makro auf eine Arbeitsmappe an, bei der sich der erste Name auf ein Makro mit Befehlen der Makrosprache von Microsoft Excel, Version 4.0, bezieht.

ActiveWorkbook.Names(1).ShortcutKey = "K"


 ShowAllItems-Eigenschaft

ShowAllItems-Eigenschaft

True, falls alle Elemente in einem PivotTable-Bericht angezeigt werden, auch wenn sie keine Zusammenfassungsdaten enthalten. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert immer False.


Beispiel zur ShowAllItems-Eigenschaft

In diesem Beispiel werden alle Zeilen des Feldes "Month" im ersten PivotTable-Bericht des ersten Tabellenblatts angezeigt, einschließlich der Monate, für die keine Daten existieren.

Worksheets(1).PivotTables("Pivot1") _
    .PivotFields("Month").ShowAllItems = True


ShowChartTipNames-Eigenschaft

True, wenn in Diagrammen Diagramm-Spitzennamen angezeigt werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowChartTipNames-Eigenschaft

In diesem Beispiel werden Diagramm-Spitzennamen und -werte ausgeschaltet.

With Application
    .ShowChartTipNames = False
    .ShowChartTipValue = False
End With


ShowChartTipValues-Eigenschaft

True, wenn in Diagrammen Diagramm-Spitzenwerte angezeigt werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowChartTipValues-Eigenschaft

In diesem Beispiel werden Diagramm-Spitzennamen und -werte ausgeschaltet.

With Application
    .ShowChartTipNames = False
    .ShowChartTipValue = False
End With


ShowConflictHistory-Eigenschaft

True, wenn die Konfliktprotokoll-Tabelle in der geöffneten und freigegebenen Arbeitsmappe sichtbar ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft führt zu einem Fehler, wenn die angegebene Arbeitsmappe nicht freigegeben wurde. Ob der Freigabemodus aktiviert ist, lässt sich anhand der MultiUserEditing-Eigenschaft feststellen.


Beispiel zur ShowConflictHistory-Eigenschaft

Im folgenden Beispiel wird festgestellt, ob die aktive Arbeitsmappe für gemeinsamen Zugriff freigegeben ist. Ist dies der Fall, wird die Konfliktprotokoll-Tabelle angezeigt.

If ActiveWorkbook.MultiUserEditing Then
    ActiveWorkbook.ShowConflictHistory = True
End If


 ShowDetail-Eigenschaft

ShowDetail-Eigenschaft

True, wenn die Gliederung für den angegebenen Bereich erweitert ist (so dass die Details der Spalte bzw. Zeile sichtbar sind). Der angegebene Bereich muss eine einzelne Hauptspalte oder -zeile in einer Gliederung sein. Variant Schreib-Lese-Zugriff.

Beim PivotItem-Objekt (oder beim Range-Objekt, wenn es sich um einen Bereich in einem PivotTable-Bericht handelt) wird diese Eigenschaft auf True festgelegt, wenn die Details des Elementes angezeigt werden.

Anmerkungen

Diese Eigenschaft steht für OLAP-Datenquellen nicht zur Verfügung.

Bitte beachten Sie folgende Punkte, wenn sich der angegebene Bereich nicht in einem PivotTable-Bericht befindet:

  • Der Bereich muss sich in einer einzelnen Hauptzeile oder Hauptspalte befinden.

  • Die Eigenschaft gibt False zurück, wenn mindestens eine der untergeordneten Zellen der Zeile oder Spalte ausgeblendet ist.

  • Das Setzen der Eigenschaft auf True ist gleichbedeutend mit dem Einblenden aller untergeordneten Zellen der Hauptzeile oder -spalte.

  • Das Setzen der Eigenschaft auf False ist gleichbedeutend mit dem Ausblenden aller untergeordneten Zellen der Hauptzeile oder -spalte.

Handelt es sich um einen Bereich in einem PivotTable-Bericht, kann diese Eigenschaft für mehrere Zellen gleichzeitig festgelegt werden, sofern der Bereich zusammenhängend ist. Zum Zurückgeben dieser Eigenschaft muss der Bereich eine einzelne Zelle sein.


Beispiel zur ShowDetail-Eigenschaft

In diesem Beispiel werden die Details der Hauptzeile der Gliederung in Sheet1 angezeigt. Erstellen Sie eine einfache Gliederung mit einer einzigen Hauptzeile, bevor Sie dieses Makro ausführen, und blenden Sie die Gliederung anschließend aus, so dass lediglich die Hauptzeile angezeigt wird. Markieren Sie eine der Zellen in der Hauptzeile und führen Sie dann das Beispiel aus.

Worksheets("Sheet1").Activate
Set myRange = ActiveCell.CurrentRegion
lastRow = myRange.Rows.Count
myRange.Rows(lastRow).ShowDetail = True


ShowError-Eigenschaft

True, falls die Fehlermeldung der Datenüberprüfung immer angezeigt wird, wenn der Benutzer ungültige Daten eingibt. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowError-Eigenschaft

In diesem Beispiel wird der Zelle A10 des ersten Tabellenblattes eine Datenüberprüfung hinzugefügt. Der Eingabewert muss zwischen 5 und 10 liegen; gibt der Benutzer ungültige Daten ein, wird eine Fehlermeldung, jedoch keine Eingabemeldung angezeigt.

With Worksheets(1).Range("A10").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:=xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", _
        Formula2:="10"
    .ErrorMessage = "value must be between 5 and 10"
    .ShowInput = False
    .ShowError = True
End With


ShowInput-Eigenschaft

True, falls die Eingabemeldung der Datenüberprüfung immer angezeigt wird, wenn der Benutzer eine Zelle im Datenüberprüfungsbereich markiert. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowInput-Eigenschaft

In diesem Beispiel wird der Zelle A10 eine Datenüberprüfung hinzugefügt. Der Eingabewert muss zwischen 5 und 10 liegen; gibt der Benutzer ungültige Daten ein, wird eine Fehlermeldung, jedoch keine Eingabemeldung angezeigt.

With Worksheets(1).Range("A10").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:=xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", _
        Formula2:="10"
    .ErrorMessage = "value must be between 5 and 10"
    .ShowInput = False
    .ShowError = True
End With


ShowLegendKey-Eigenschaft

True, wenn das Legendensymbol der Datenbeschriftung angezeigt wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowLegendKey-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Datenbeschriftungen der ersten Datenreihe in Chart1 mit dem zugehörigen Wert und dem Legendensymbol angezeigt werden.

With Charts("Chart1").SeriesCollection(1).DataLabels
    .ShowLegendKey = True
    .Type = xlShowValue
End With


ShowNegativeBubbles-Eigenschaft

True, wenn in der Diagrammgruppe negative Blasen angezeigt werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowNegativeBubbles-Eigenschaft

In diesem Beispiel werden in der ersten Diagrammgruppe negative Blasen sichtbar gemacht.

Worksheets(1).ChartObjects(1).Chart _
    .ChartGroups(1).ShowNegativeBubbles = True


ShowToolTips-Eigenschaft

True, wenn QuickInfo aktiviert ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur ShowToolTips-Eigenschaft

In diesem Beispiel wird die QuickInfo von Microsoft Excel aktiviert.

Application.ShowToolTips = True


ShowWindow-Eigenschaft

True, wenn das eingebettete Diagramm in einem separaten Fenster angezeigt wird. Das mit dieser Eigenschaft verwendete Chart-Objekt muss sich auf ein eingebettetes Diagramm beziehen. Boolean Schreib-Lese-Zugriff.


ShowWindowsInTaskbar-Eigenschaft

True, wenn es für jede geöffnete Arbeitsmappe eine eigene Schaltfläche auf der Windows-Taskleiste gibt. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei Einstellung auf True simuliert diese Eigenschaft das Aussehen einer Oberfläche für ein einzelnes Dokument, wodurch die Navigation zwischen geöffneten Arbeitsmappen erleichtert wird. Wenn Sie jedoch mit mehreren Arbeitsmappen arbeiten und andere Anwendungen geöffnet sind, ist es möglicherweise vorzuziehen, diese Eigenschaft auf False einzustellen, um ein Auffüllen der Taskleiste mit unnötigen Schaltflächen zu vermeiden.

Diese Eigenschaft steht nur dann zur Verfügung, wenn Sie Microsoft Office mit dem Windows Desktop Update, Windows 98 oder Windows 2000 verwenden.


Beispiel zur ShowWindowsInTaskbar-Eigenschaft

In diesem Beispiel wird angegeben, dass nicht jede geöffnete Arbeitsmappe über eine eigene Schaltfläche auf der Windows-Taskleiste verfügt.

Application.ShowWindowsInTaskbar = False


ShrinkToFit-Eigenschaft

True, wenn sich die Textgröße automatisch an die zur Verfügung stehende Spaltenbreite anpasst. Gibt Null zurück, wenn diese Eigenschaft nicht für alle Zellen im angegebenen Bereich denselben Wert aufweist. Variant Lese- und Schreibzugriff.


Beispiel zur ShrinkToFit-Eigenschaft

In diesem Beispiel wird veranlasst, dass sich die Textgröße in Reihe 1 automatisch an die verfügbare Spaltenbreite anpasst.

Rows(1).ShrinkToFit = True


Size-Eigenschaft

Gibt die Größe der Schriftt (den Schriftgrad) zurück oder legt sie fest. Variant Schreib-Lese-Zugriff.


SizeRepresents-Eigenschaft

Gibt zurück oder legt fest, was die Blasengröße auf einem Blasendiagramm darstellt. Dies kann eine der folgenden XlSizeRepresents-Konstanten sein: xlSizeIsArea oder xlSizeIsWidth. Long Schreib-Lese-Zugriff.


Beispiel zur SizeRepresents-Eigenschaft

In diesem Beispiel wird festgelegt, was die Blasengröße in der Diagrammgruppe bedeutet.

Charts(1).ChartGroups(1).SizeRepresents = xlSizeIsWidth


SizeWithWindow-Eigenschaft

True, wenn Microsoft Excel die Größe des Diagramms an die Größe des Diagrammblattfensters anpasst. False, wenn sich die Diagrammgröße nicht mit der Fenstergröße ändert. Nicht gültig für eingebettete Diagramme, sondern nur für Diagrammblätter. Boolean Schreib-Lese-Zugriff.


Beispiel zur SizeWithWindow-Eigenschaft

In diesem Beispiel wird festgelegt, dass sich die Größe von Chart1 der Größe des zugehörigen Fensters anpasst.

Charts("Chart1").SizeWithWindow = True


SmallChange-Eigenschaft

Gibt den Wert zurück oder legt den Wert fest, um den die Bildlaufleiste oder das Drehfeld nach oben oder nach unten geändert wird (wenn der Benutzer auf einen Pfeil klickt). Long Schreib-Lese-Zugriff.


Beispiel zur SmallChange-Eigenschaft

In diesem Beispiel wird eine Bildlaufleiste erstellt. Deren Werte werden für "LinkedCell", "Min", "Max", "LargeChange" und "SmallChange" festgelegt.

Set sb = Worksheets(1).Shapes.AddFormControl(xlScrollBar, _
    Left:=10, Top:=10, Width:=10, Height:=200)
With sb.ControlFormat
    .LinkedCell = "D1"
    .Max = 100
    .Min = 0
    .LargeChange = 10
    .SmallChange = 2
End With


SmallGrid-Eigenschaft

True, wenn Microsoft Excel ein Raster verwendet, das für einen neu erstellten PivotTable-Bericht eine Breite und eine Tiefe von zwei Zellen besitzt. False, wenn Excel eine leere Schablonenkontur verwendet. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie sollten die Schablonenkontur verwenden. Das Raster wird nur deshalb zur Verfügung gestellt, da es eine Kompatibilität mit früheren Versionen von Excel ermöglicht.


 Beispiel zur SmallGrid-Eigenschaft

Beispiel zur SmallGrid-Eigenschaft

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf diesem Cache basiert. In dem Beispiel wird die Schablonenkontur an Stelle des Zellrasters verwendet.

With ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = True
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:= "PivotTable1"
End With
With ActiveSheet.PivotTables("PivotTable1")
    .SmallGrid = False
    .PivotCache.RefreshPeriod = 0
    With .CubeFields("[state]")
        .Orientation = xlColumnField
        .Position = 0
    End With
    With .CubeFields("[Measures].[Count Of au_id]")
        .Orientation = xlDataField
        .Position = 0
    End With
End With


Smooth-Eigenschaft

True, wenn Kurven des Linien- oder Punktdiagramms geglättet werden. Nur gültig für Linien- und Punktdiagramme. Schreib-Lese-Zugriff.


Beispiel zur Smooth-Eigenschaft

In diesem Beispiel wird für die erste Datenreihe in Chart1 die Kurvenglättung aktiviert. Wenden Sie das Beispiel auf ein 2D-Liniendiagramm an.

Charts("Chart1").SeriesCollection(1).Smooth = True


SoundNote-Eigenschaft

Diese Eigenschaft sollte nicht verwendet werden. Audionotizen wurden aus Microsoft Excel entfernt.


Source-Eigenschaft

Gibt den eindeutigen Namen zurück, der Elemente bezeichnet, die einen SourceType-Eigenschaftenwert vonxlSourceRange, xlSourceChart, xlSourcePrintArea, xlSourceAutoFilter, xlSourcePivotTable oder xlSourceQuery besitzen. Wenn die SourceType-Eigenschaft auf xlSourceRange eingestellt ist, gibt diese Eigenschaft einen Bereich zurück, bei dem es sich um einen definierten Namen handeln kann. Wenn die SourceType-Eigenschaft auf xlSourceChart, xlSourcePivotTable oder xlSourceQuery eingestellt ist, gibt diese Eigenschaft den Namen des Objekts zurück, wie z. B. ein Diagrammname, ein PivotTable-Berichtname oder ein Abfragetabellenname. String Lese-Zugriff.


SourceData-Eigenschaft

Gibt die Datenquelle für den PivotTable-Bericht gemäß nachstehender Tabelle zurück. Variant Lese-Zugriff.

Datenquelle | Rückgabewert
Microsoft Excel Liste oder Datenbank | Der Zellbezug als Text.
Externe Datenquelle | Eine Matrix. Jede Zeile enthält die Zeichenfolge für eine SQL-Verbindung und die in Segmente von je 255 Zeichen unterteilte Abfragezeichenfolge als Elemente.
Mehrere Konsolidierungsbereiche | Eine zweidimensionale Matrix. Jede Zeile besteht aus einem Bezug und den zugeordneten Seitenfeldelementen.
Ein anderer PivotTable-Bericht | Eine der drei oben aufgeführten Informationen.

Anmerkungen

Diese Eigenschaft steht für OLE DB-Datenquellen nicht zur Verfügung.


Beispiel zur SourceData-Eigenschaft

Es wird davon ausgegangen, dass eine externe Datenquelle zum Erstellen eines PivotTable-Berichts in Sheet1 verwendet wurde. In diesem Beispiel werden die SQL-Verbindungszeichenfolge und die Abfragezeichenfolge in ein neues Tabellenblatt eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
sdArray = Worksheets("Sheet1").UsedRange.PivotTable.SourceData
For i = LBound(sdArray) To UBound(sdArray)
    newSheet.Cells(i, 1) = sdArray(i)
Next i


 SourceName-Eigenschaft

SourceName-Eigenschaft

OLEObject-, OLEObjects-Objekte: Geben den Quellnamen der Verknüpfung des Objekts zurück oder legen ihn fest. String Schreib-Lese-Zugriff.

CubeField-, PivotField-, PivotItem-Objekte: Geben den Namen des angegebenen Objekts zurück, so wie er in den ursprünglichen Quelldaten für den angegebenen PivotTable-Bericht erscheint. Dieser Name ist eventuell nicht mit dem derzeitigen Elementnamen identisch, wenn nämlich der Benutzer das Element nach Erstellung des PivotTable-Berichts umbenannt hat. String Lese-Zugriff.

Die folgende Tabelle enthält Beispielwerte der SourceName-Eigenschaft und verwandter Eigenschaften. Dabei wird von einer OLAP-Datenquelle mit dem eindeutigen Namen "[Europa].[Frankreich].[Paris]" und einer Nicht-OLAP-Datenquelle mit dem Elementnamen "Paris" ausgegangen.

Eigenschaft | Wert (OLAP-Datenquelle) | Wert (Nicht-OLAP-Datenquelle)
Caption | Paris | Paris
Name | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | Paris
SourceName | [Europa].[Frankreich].[Paris] (Lese-Zugriff) | (identisch mit SQL-Eigenschaftenwert, Lese-Zugriff)
Value | [Europa].[Frankreich].[Paris] (Lese-Zugriff) | Paris

Wenn Sie einen Index in der PivotItems-Auflistung angeben, können Sie die in der folgende Tabelle gezeigte Syntax verwenden.

Syntax (OLAP-Datenquelle) | Syntax (Nicht-OLAP-Datenquelle)
Ausdruck.PivotItems("[Europa].[Frankreich].[Paris]") | Ausdruck.PivotItems("Paris")

Wenn die Item-Eigenschaft für einen Verweis auf ein bestimmtes Mitglied einer Auflistung verwendet wird, können Sie die in der folgenden Tabelle aufgeführten Textindexnamen verwenden.

Name (OLAP-Datenquelle) | Name (Nicht-OLAP-Datenquelle)
[Europa].[Frankreich].[Paris] | Paris


Beispiel zur SourceName-Eigenschaft

In diesem Beispiel wird der ursprüngliche Name (der Name in der Quelldatenbank) des Elements, das die aktive Zelle enthält, angezeigt.

Worksheets("Sheet1").Activate
ActiveSheet.PivotTables(1).PivotSelect "1998", xlDataAndLabel
MsgBox "The original item name is " & _
    ActiveCell.PivotItem.SourceName


SourceRange-Eigenschaft

Gibt ein Range-Objekt zurück, das die Zelle darstellt, die den Wert des angegebenen Abfrageparameters enthält. Schreibgeschützt.


Beispiel zur SourceRange-Eigenschaft

In diesem Beispiel wird der Wert der Zelle, die als Quellbereich der Abfrage verwendet wird, geändert.

Set qt = Sheets("sheet1").QueryTables(1)
Set param1 = qt.Parameters(1)
Set r = param1.SourceRange
r.Value = "New York"
qt.Refresh


SourceType-Eigenschaft

Gibt einen Wert zurück, der den Typ des veröffentlichten Elements bezeichnet. Kann eine der folgenden XlSourceType-Konstanten sein: xlSourceAutoFilter, xlSourceChart, xlSourcePivotTable, xlSourcePrintArea, xlSourceQuery, xlSourceRange, xlSourceSheet oder xlSourceWorkbook. Die Source-Eigenschaft gibt den eindeutigen Namen des Objekts zurück. XlSourceType Lese-Zugriff.


Beispiel zur SourceType-Eigenschaft

In diesem Beispiel wird der eindeutige Name des ersten Diagramms (in der ersten Arbeitsmappe) bestimmt, das als Webseite gespeichert wurde. Anschließend wird die Variable blnChartFound vom Typ Boolean auf True festgelegt. Wenn keine Elemente im Dokument als Diagrammkomponenten gespeichert wurden, ist blnChartFound False.

blnChartFound = False
For Each objPO In Workbooks(1).PublishObjects
    If objPO.SourceType = xlSourceChart Then
        strFirstPO = objPO.Source
        blnChartFound = True
        Exit For
    End If
Next objPO


Split-Eigenschaft

True, wenn das Fenster geteilt ist. Boolean Schreib-Lese-Zugriff.

Anmerkungen

FreezePanes kann den Wert True haben, und gleichzeitig kann Split den Wert False haben und umgekehrt.

Diese Eigenschaft ist nur für Tabellenblätter und Makroblätter gültig.


SplitColumn-Eigenschaft

Gibt die Nummer der Spalte zurück, an der das Fenster in Ausschnitte geteilt wird (Zahl der Spalten links von der Teilungslinie), oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur SplitColumn-Eigenschaft

In diesem Beispiel wird das Fenster so geteilt, dass links von der Trennungslinie eineinhalb Spalten stehen.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.SplitColumn = 1.5


 SplitHorizontal-Eigenschaft

SplitHorizontal-Eigenschaft

Gibt die Position der horizontalen Fensterteilung in Punkt zurück oder legt sie fest. Double Schreib-Lese-Zugriff.


Beispiel zur SplitHorizontal-Eigenschaft

In diesem Beispiel wird das aktive Fenster bei 216 Punkt (7,56 cm) horizontal geteilt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.SplitHorizontal = 216


SplitRow-Eigenschaft

Gibt die Nummer der Zeile zurück, an der das Fenster in Ausschnitte geteilt wird (Anzahl der Zeilen oberhalb der Teilungslinie), oder legt sie fest. Long Schreib-Lese-Zugriff.


Beispiel zur SplitRow-Eigenschaft

In diesem Beispiel wird das aktive Fenster so geteilt, dass oberhalb der Teilungslinie 10 Zeilen stehen.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.SplitRow = 10


SplitType-Eigenschaft

Gibt die Art zurück oder legt fest, wie entweder ein Kreis aus Kreis-Diagramm oder ein Balken aus Kreis-Diagramm geteilt wird. Dabei kann es sich um eine der folgenden XlChartSplitType-Konstanten handeln: xlSplitByPosition, xlSplitByPercentValue, xlSplitByCustomSplit oder xlSplitByValue. Long Schreib-Lese-Zugriff.


Beispiel zur SplitType-Eigenschaft

Dieses Beispiel muss entweder mit einem Kreis aus Kreis-Diagramm oder einem Balken aus Kreis-Diagramm ausgeführt werden. Dieses Beispiel teilt die beiden Bereiche des Diagramms nach Wert auf, fasst dabei alle Werte unter 10 im primären Kreissegment zusammen und zeigt sie im sekundären Abschnitt an.

With Worksheets(1).ChartObjects(1).Chart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
End With


SplitValue-Eigenschaft

Gibt den Schwellenwert, der zwei Abschnitte eines Kreises aus Kreis-Diagramm oder Balken aus Kreis-Diagramm teilt, zurück oder legt ihn fest. Variant Schreib-Lese-Zugriff.


Beispiel zur SplitValue-Eigenschaft

Dieses Beispiel muss entweder mit einem Kreis aus Kreis-Diagramm oder einem Balken aus Kreis-Diagramm ausgeführt werden. Dieses Beispiel teilt die beiden Bereiche des Diagramms nach Wert auf, fasst dabei alle Werte unter 10 im primären Kreissegment zusammen und zeigt sie im sekundären Abschnitt an.

With Worksheets(1).ChartObjects(1).Chart.ChartGroups(1)
    .SplitType = xlSplitByValue
    .SplitValue = 10
    .VaryByCategories = True
End With


 SplitVertical-Eigenschaft

SplitVertical-Eigenschaft

Gibt die Position der vertikalen Fensterteilung in Punkt zurück oder legt sie fest. Double Schreib-Lese-Zugriff.


Beispiel zur SplitVertical-Eigenschaft

In diesem Beispiel wird das aktive Fenster bei 216 Punkt (7,56 cm) vertikal geteilt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.SplitVertical = 216


SqlState-Eigenschaft

Gibt den SQL-Statusfehler zurück. String Schreibgeschützt.

Anmerkungen

Die Erklärung eines bestimmten Fehlers finden Sie in Ihrer SQL-Dokumentation.


Beispiel zur SqlState-Eigenschaft

In diesem Beispiel wird die erste Abfragetabelle aktualisiert und alle auftretenden ODBC-Fehler angezeigt.

With Worksheets(1).QueryTables(1)
    .Refresh
    Set errs = Application.ODBCErrors
    If errs.Count > 0 Then
        Set r = .Destination.Cells(1)
        r.Value = "The following errors occurred:"
        c = 0
        For Each er In errs
            c = c + 1
            r.offset(c, 0).value = er.ErrorString
            r.offset(c, 1).value = er.SqlState
        Next
    Else
        MsgBox "Query complete: all records returned."
    End If
End With


Stage-Eigenschaft

Gibt einen numerischen Wert zurück, der das Stadium eines Fehlers angibt, der nach der letzten OLE DB-Abfrage aufgetreten ist. Long Schreibgeschützt.


Beispiel zur Stage-Eigenschaft

In diesem Beispiel werden die Fehlernummern, das Stadium und weitere Fehlerinformationen angezeigt, die von der letzten OLE DB-Abfrage zurückgegeben wurden.

Set objEr = Application.OLEDBErrors(1)
MsgBox "The following error occurred:" & _
    objEr.Number & ", " & objEr.Native & ", " & _
    objEr.Stage & ", " & _
    objEr.ErrorString & " : " & objEr.SqlState


StandardFont-Eigenschaft

Gibt den Namen der Standardschriftart als Zeichenfolge zurück oder legt diesen fest. String Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie die Schriftart mit dieser Eigenschaft ändern, wird diese Änderung erst dann durchgeführt, wenn Sie Microsoft Excel erneut starten.


 StandardFontSize-Eigenschaft

StandardFontSize-Eigenschaft

Gibt den Standardschriftgrad in Punkt zurück oder legt diesen fest. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie den Schriftgrad mit dieser Eigenschaft ändern, wird diese Änderung erst dann durchgeführt, wenn Sie Microsoft Excel erneut starten.


Beispiel zur StandardFontSize-Eigenschaft

In diesem Beispiel wird der Standardschriftgrad auf 12 Punkt gesetzt.

Application.StandardFontSize = 12


 StandardHeight-Eigenschaft

StandardHeight-Eigenschaft

Gibt die Standardhöhe aller Zeilen des Tabellenblattes in Punkt zurück. Double Schreib-Lese-Zugriff.


Beispiel zur StandardHeight-Eigenschaft

In diesem Beispiel wir die erste Zeile in Sheet1 auf die Standardhöhe gesetzt.

Worksheets("Sheet1").Rows(1).RowHeight = _
    Worksheets("Sheet1").StandardHeight


StandardWidth-Eigenschaft

Gibt die Standardbreite aller Spalten eines Tabellenblattes zurück oder legt sie fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Eine Einheit der Spaltenbreite ist gleich der Breite eines Zeichens in der Formatvorlage Standard. Bei Proportionalschriftarten wird die Breite des Zeichens 0 (Null) verwendet.


Beispiel zur StandardWidth-Eigenschaft

In diesem Beispiel wird die erste Spalte in Sheet1 auf die Standardbreite gesetzt.

Worksheets("Sheet1").Columns(1).ColumnWidth = _
    Worksheets("Sheet1").StandardWidth


Start-Eigenschaft

Gibt die Position zurück, die das erste Zeichen einer phonetischen Textzeichenfolge in der angegebenen Zelle darstellt. Long Schreibgeschützt.


StartupPath-Eigenschaft

Gibt den vollständigen Pfad des Startordners ohne das abschließende Trennzeichen zurück. String Schreibgeschützt.


Beispiel zur StartupPath-Eigenschaft

In diesem Beispiel wird der vollständige Pfad zum Startordner von Microsoft Excel angezeigt.

MsgBox Application.StartupPath


Status-Eigenschaft

Gibt den Status des Verteilers zurück. Zulässig ist eine der folgenden XlRoutingSlipStatus-Konstanten: xlNotYetRouted, xlRoutingInProgress oder xlRoutingComplete. Long Schreibgeschützt.


StatusBar-Eigenschaft

Gibt den Text der Statusleiste zurück oder legt ihn fest. String Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft gibt False zurück, wenn die Statusleiste von Microsoft Excel gesteuert wird. Setzen Sie die Eigenschaft auf False, um die vorgegebene Statusleistenmeldung wiederherzustellen. Dies ist auch bei ausgeblendeter Statusleiste möglich.


Beispiel zur StatusBar-Eigenschaft

In diesem Beispiel wird die Statusleistenmeldung auf "Please be patient..." gesetzt, bevor die Arbeitsmappe LARGE.XLS geöffnet wird. Dann wird die Standardmeldung wiederhergestellt.

oldStatusBar = Application.DisplayStatusBar
Application.DisplayStatusBar = True
Application.StatusBar = "Please be patient..."
Workbooks.Open filename:="LARGE.XLS"
Application.StatusBar = False
Application.DisplayStatusBar = oldStatusBar


Strikethrough-Eigenschaft

True, wenn die Schriftart horizontal durchgestrichen ist. Boolean Schreib-Lese-Zugriff.


Beispiel zur Strikethrough-Eigenschaft

In diesem Beispiel wird die Schriftart für die aktive Zelle in Sheet1 durchgestrichen formatiert.

Worksheets("Sheet1").Activate
ActiveCell.Font.Strikethrough = True


Style-Eigenschaft

Gibt ein Style-Objekt zurück, das die Formatvorlage des angegebenen Bereichs darstellt. Schreibgeschützt.


Styles-Eigenschaft

Gibt eine Styles-Auflistung zurück, die alle Formatvorlagen in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur Styles-Eigenschaft

In diesem Beispiel wird die benutzerdefinierte Formatvorlage "Stock Quote Style" aus der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.Styles("Stock Quote Style").Delete


SubAddress-Eigenschaft

Gibt die Position innerhalb des mit dem Hyperlink verbundenen Dokuments zurück oder legt sie fest. String Schreib-Lese-Zugriff.


Beispiel zur SubAddress-Eigenschaft

In diesem Beispiel wird dem Hyperlink der ersten Form die Position eines Bereichs hinzugefügt.

Worksheets(1).Shapes(1).Hyperlink.SubAddress = "A1:B10"


Subject-Eigenschaft

Gibt den Betreff für die Wurfsendung oder die Verteiler zurück, oder legt diese fest. String Schreib-Lese-Zugriff.

Anmerkungen

Der Betreff für das RoutingSlip-Objekt dient als Betreff für die Mail-Nachrichten, mit denen die Arbeitsmappe weitergeleitet wird.


Beispiel zur Subject-Eigenschaft

In diesem Beispiel wird der Betreff eines Verteilers für die offene Arbeitsmappe festgelegt. Damit Sie dieses Makro ausführen können, muss Microsoft Exchange installiert sein.

With ThisWorkbook
    .HasRoutingSlip = True
    With .RoutingSlip
        .Delivery = xlOneAfterAnother
        .Recipients = Array("Adam Bendel", _
            "Jean Selva", "Bernard Gabor")
        .Subject = "Here is the workbook"
        .Message = "Here is the workbook. What do you think?"
        .ReturnWhenDone = True
End With
    .Route
End With


Subscript-Eigenschaft

True, wenn die Zeichen tief gestellt formatiert sind. Diese Eigenschaft hat die Voreinstellung False. Variant Schreib-Lese-Zugriff.


Beispiel zur Subscript-Eigenschaft

In diesem Beispiel wird das zweite Zeichen in Zelle A1 tief gestellt.

Worksheets("Sheet1").Range("A1") _
    .Characters(2, 1).Font.Subscript = True


 SubtotalHiddenPageItems-Eigenschaft

SubtotalHiddenPageItems-Eigenschaft

True, wenn ausgeblendete Seitenfeldelemente des PivotTable-Berichts in Zeilen- und Spaltenteilergebnisse, Blocksummen oder Gesamtsummen enthalten sind. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Bei OLAP-Datenquellen ist der Wert immer True.


Beispiel zur SubtotalHiddenPageItems-Eigenschaft

In diesem Beispiel wird festgelegt, dass in dem ersten PivotTable-Bericht im ersten Tabellenblatt ausgeblendete Seitenfeldelemente bei Zwischenergebnissen ausgeschlossen werden.

Worksheets(1).PivotTables("Pivot1").SubtotalHiddenPageItems = True


SubtotalName-Eigenschaft

Gibt die Textzeichenfolge der Beschriftung zurück oder legt diese fest, die in der Teilergebnisspalte oder Zeilenüberschrift des angegebenen PivotTable-Berichts angezeigt wird. Der Standardwert ist die Zeichenfolge "Teilergebnis". Schreib-Lese-Zugriff String.


Beispiel zur SubtotalName-Eigenschaft

In diesem Beispiel wird die Teilergebnisbeschriftung im Feld "state" im zweiten PivotTable-Bericht des aktiven Tabellenblatts auf "Regional Subtotal" (an Stelle der Standardzeichenfolge "Teilergebnis") festgelegt.

ActiveSheet.PivotTables("PivotTable2") _
    .PivotFields("state").SubtotalName = "Regional Subtotal"


 Subtotals-Eigenschaft

Subtotals-Eigenschaft

Gibt die mit dem angegebenen Feld angezeigten Gesamtergebnisse zurück oder legt diese fest. Nur zulässig für Felder, bei denen es sich um keine Datenfelder handelt. Variant Schreib-Lese-Zugriff.

Syntax

Ausdruck.Subtotals(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Index Variant optional. Ein Teilergebnisindex, wie in der folgenden Tabelle gezeigt. Wenn dieses Argument ausgelassen wird, gibt die Subtotals-Methode eine Matrix zurück, die für jedes Teilergebnis einen Wert vom Typ Boolean enthält.

Index | Bedeutung
1 | Automatisch
2 | Summe
3 | Anzahl
4 | Mittelwert
5 | Maximum
6 | Minimum
7 | Produkt
8 | Anzahl Zahlen
9 | Standardabweichung (Stichprobe)
10 | Standardabweichung (Grundgesamtheit)
11 | Varianz
12 | Varianz (Grundgesamtheit)

Ist ein Index True, wird in dem Feld das betreffende Teilergebnis angezeigt. Ist Index 1 (Automatisch) True, werden alle anderen Werte auf False festgelegt.

Anmerkungen

Bei OLAP-Datenquellen kann Index nur 1 (Automatisch) zurückgegeben bzw. auf diesen Wert festlegt werden. Die zurückgegebene Matrix enthält für das erste Matrixelement immer True oder False und für alle anderen Elemente immer False. Eine Matrix, in der alle Elementwerte False sind, kennzeichnet, dass es keine Teilergebnisse gibt.


Beispiel zur Subtotals-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Feld, das die aktive Zelle enthält, Teilergebnisse alle Summe anzeigt.

Worksheets("Sheet1").Activate
ActiveCell.PivotField.Subtotals(2) = True


Summary-Eigenschaft

True, wenn es sich bei dem Bereich um eine Hauptzeile oder Hauptspalte einer Gliederung handelt. Der Bereich sollte eine Zeile oder Spalte sein. Variant Schreibgeschützt.


SummaryColumn-Eigenschaft

Gibt gemäß folgender Tabelle die Position der Hauptspalten in der Gliederung zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Wert | Bedeutung
xlLeft | Die Hauptspalte der Gliederung wird links neben den Detailspalten positioniert.
xlRight | Die Hauptspalte der Gliederung wird rechts neben den Detailspalten positioniert.


Beispiel zur SummaryColumn-Eigenschaft

In diesem Beispiel wird eine Gliederung mit automatischen Formatvorlagen erstellt, in der sich die Hauptzeile über den Detailzeilen und die Hauptspalte rechts neben den Detailspalten befindet.

Worksheets("Sheet1").Activate
Selection.AutoOutline
With ActiveSheet.Outline
    .SummaryRow = xlAbove
    .SummaryColumn = xlRight
    .AutomaticStyles = True
End With


SummaryRow-Eigenschaft

Gibt gemäß folgender Tabelle die Position der Hauptzeilen in der Gliederung zurück oder legt diese fest. Long Schreib-Lese-Zugriff.

Wert | Bedeutung
xlAbove | Die Hauptzeile der Gliederung befindet sich über den Detailspalten.
xlBelow | Die Hauptzeile der Gliederung befindet sich unter den Detailspalten

Anmerkungen

Setzen Sie SummaryRow auf xlAbove bei Gliederungen im Microsoft Word-Format, in denen sich Rubriküberschriften über den Detaildaten befinden. Setzen Sie SummaryRow auf xlBelow bei Gliederungen im Buchführungsformat, in denen sich Summenberechnungen unter den Detaildaten befinden.


Beispiel zur SummaryRow-Eigenschaft

In diesem Beispiel wird eine Gliederung mit automatischen Formatvorlagen erstellt, in der sich die Hauptzeile über den Detailzeilen, und die Hauptspalte rechts neben den Detailspalten befindet.

Worksheets("Sheet1").Activate
Selection.AutoOutline
With ActiveSheet.Outline
    .SummaryRow = xlAbove
    .SummaryColumn = xlRight
    .AutomaticStyles = True
End With


Superscript-Eigenschaft

True, wenn die Schriftart hoch gestellt ist. Diese Eigenschaft hat die Voreinstellung False. Variant Schreib-Lese-Zugriff.


Beispiel zur Superscript-Eigenschaft

In diesem Beispiel wird das letzte Zeichen in Zelle A1 hoch gestellt.

n = Worksheets("Sheet1").Range("A1").Characters.Count
Worksheets("Sheet1").Range("A1") _
    .Characters(n, 1).Font.Superscript = True


SurfaceGroup-Eigenschaft

Gibt ein ChartGroup-Objekt zurück, das die Oberflächendiagrammgruppe eines 3D-Diagramms darstellt. Schreibgeschützt.


Beispiel zur SurfaceGroup-Eigenschaft

In diesem Beispiel wird die 3D-Oberflächengruppe in Chart1 so definiert, dass für jeden Datenpunkt eine andere Farbe verwendet wird. Wenden Sie das Beispiel auf ein 3D-Diagramm an.

Charts("Chart1").SurfaceGroup.VaryByCategories = True


TableRange1-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den gesamten PivotTable-Bericht enthält, jedoch ohne die Seitenfelder. Schreibgeschützt.

Anmerkungen

Die TableRange2-Eigenschaft umfasst auch die Seitenfelder.


Beispiel zur TableRange1-Eigenschaft

In diesem Beispiel wird der gesamte PivotTable-Bericht mit Ausnahme der Seitenfelder markiert.

Worksheets("Sheet1").Activate
Range("A3").PivotTable.TableRange1.Select


TableRange2-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich darstellt, der den gesamten PivotTable-Bericht einschließlich der Seitenfelder enthält. Schreibgeschützt.

Anmerkungen

Die TableRange1-Eigenschaft umfasst keine Seitenfelder.


Beispiel zur TableRange2-Eigenschaft

In diesem Beispiel wird der gesamte PivotTable-Bericht einschließlich der Seitenfelder markiert.

Worksheets("Sheet1").Activate
Range("A3").PivotTable.TableRange2.Select


TableStyle-Eigenschaft

Gibt die im Datenbereich des PivotTable-Berichts verwendete Formatvorlage zurück oder legt sie fest. Der Standardwert ist eine leere Zeichenfolge (keine Formatvorlage wird standardmäßig zugewiesen). String Lese- und Schreibzugriff.

Anmerkungen

Diese Formatvorlage wird als Standardformatvorlage für den Hintergrundbereich verwendet und zugewiesen, bevor eine Formatierung durch den Benutzer vorgenommen wird.


Beispiel zur TableStyle-Eigenschaft

In diesem Beispiel wird für den Datenbereich des PivotTable-Berichts die Formatvorlage "PurpleAndGold" festgelegt.

Worksheets(1).PivotTables("Pivot1").TableStyle = "PurpleAndGold"


TabRatio-Eigenschaft

Gibt das Längenverhältnis der Arbeitsmappenregister zur horizontalen Bildlaufleiste des Fensters (als Zahl zwischen Null und Eins) zurück oder legt es fest. Der Standardwert ist 0,6. Double Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft hat keine Wirkung, wenn DisplayWorkbookTabs die Einstellung False hat. (Der Wert kann zwar festgelegt und gelesen werden, wirkt sich jedoch nicht auf die Anzeige aus.)


Beispiel zur TabRatio-Eigenschaft

In diesem Beispiel werden die Arbeitsmappenregister auf die halbe Breite der horizontalen Bildlaufleiste eingestellt.

ActiveWindow.TabRatio = 0.5


Tag-Eigenschaft

Gibt eine Zeichenfolge zurück, die mit dem PivotTable-Bericht gespeichert wird, oder legt sie fest. String Lese- und Schreibzugriff.


Beispiel zur Tag-Eigenschaft

In diesem Beispiel wird die Tag-Eigenschaft des PivotTable-Berichts festgelegt.

Worksheets(1).PivotTables("Pivot1").Tag = "Product Sales by Region"


TemplateRemoveExtData-Eigenschaft

True, falls externe Datenbezüge gelöscht werden, wenn die Arbeitsmappe als Vorlage gespeichert wird. Boolean Schreib-Lese-Zugriff.


Beispiel zur TemplateRemoveExtData-Eigenschaft

In diesem Beispiel wird die Arbeitsmappe als Vorlage ohne externe Daten gespeichert.

With ThisWorkbook
    .TemplateRemoveExtData = True
    .SaveAs "current", xlTemplate
    .TemplateRemoveExtData = False
End With


TemplatesPath-Eigenschaft

Gibt den lokalen Pfad zurück, unter dem Vorlagen gespeichert sind. String Schreibgeschützt.


Beispiel zur TemplatesPath-Eigenschaft

In diesem Beispiel wird der lokale Pfad zurückgegeben, unter dem Vorlagen gespeichert sind.

Msgbox Application.TemplatesPath


Text-Eigenschaft

Gibt den Text für das angegebene Objekt zurück oder legt ihn fest. String Lese-Zugriff beim Range-Objekt, String Schreib-Lese-Zugriff bei allen anderen Objekten.

Informationen über die Verwendung der Tabellenfunktion Text in Visual Basic finden Sie unter Verwenden von Tabellenfunktionen in Visual Basic.

Anmerkungen

Bei Phonetic-Objekt gibt diese Eigenschaft ihren phonetischen Text zurück oder legt diesen fest. Sie können diese Eigenschaft nicht auf Null einstellen.


TextEffect-Eigenschaft

Gibt ein TextEffectFormat-Objekt zurück, das Formateigenschaften des Texteffekts der angegebenen Form enthält. Gilt für Shape- oder ShapeRange-Objekte, die eine WordArt darstellen. Schreibgeschützt.


Beispiel zur TextEffect-Eigenschaft

In diesem Beispiel wird in myDocument die Schriftart für die dritte Form fett festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Type = msoTextEffect Then
        .TextEffect.FontBold = True
    End If
End With


TextFileColumnDataTypes-Eigenschaft

Gibt eine geordnete Matrix von Konstanten zurück oder legt diese fest, die die Datentypen angeben, die den entsprechenden Spalten in der Textdatei, die in eine Abfragetabelle importiert wird, zugewiesen wurde. Die Standardkonstante für jede Spalte lautet xlGeneral. Variant Schreib-Lese-Zugriff.

Sie können die in der folgenden Tabelle aufgeführten xlColumnDataType-Konstanten verwenden, um die verwendeten Spaltendatentypen oder die beim Datenimport durchgeführten Aktionen anzugeben.

Konstante | Beschreibung
xlGeneralFormat | Standard
xlDMYFormat | Datum im Format TMJ
xlDYMFormat | Datum im Format TJM
xlEMDFormat | Datum im EMD-Format
xlMDYFormat | Datum im Format MTJ
xlMDYFormat | Datum im Format MTJ
xlSkipColumn | Spalte überspringen
xlTextFormat | Text
xlYDMFormat | Datum im Format JTM
xlYMDFormat | Datum im Format JMT

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten aus einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).

Werden mehr Elemente in der Matrix angegeben, als Spalten vorhanden sind, werden diese Werte ignoriert.

Sie können xlEMDFormat nur verwenden, wenn die Sprachunterstützung für Taiwan installiert und aktiviert ist. Die xlEMDFormat-Konstante gibt an, dass Kalenderangaben gemäß dem Taiwanesischen Kalender verwendet werden sollen.


Beispiel zur TextFileColumnDataTypes-Eigenschaft

In diesem Beispiel wird eine Textdatei mit fester Breite in eine neue Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe importiert. Die erste Spalte in der Textdatei ist fünf Zeichen breit und wird als Text importiert. Die zweite Spalte ist vier Zeichen breit und wird übergangen. Der Rest der Textdatei wird in die dritte Spalte importiert, wobei das Standardformat verwendet wird.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1, 1))
With qtQtrResults
    .TextFileParseType = xlFixedWidth
    .TextFileFixedColumnWidths = Array(5, 4)
    .TextFileColumnDataTypes = _
        Array(xlTextFormat, xlSkipColumn, xlGeneralFormat)
    .Refresh
End With


TextFileCommaDelimiter-Eigenschaft

True, wenn beim Importieren einer Textdatei in eine Abfragetabelle als Trennzeichen Kommas verwendet werden. False, wenn ein anderes Zeichen als Trennzeichen verwendet wird. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten aus einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur dann, wenn der Wert der TextFileParseType-Eigenschaft xlDelimited lautet.


Beispiel zur TextFileCommaDelimiter-Eigenschaft

In diesem Beispiel werden Kommas als Trennzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und die Abfragetabelle anschließend aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1, 1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileCommaDelimiter = True
    .Refresh
End With


TextFileConsecutiveDelimiter-Eigenschaft

True, wenn aufeinander folgende Trennzeichen beim Importieren einer Textdatei in eine Abfragetabelle als einzelnes Trennzeichen behandelt werden. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten aus einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur dann, wenn der Wert der TextFileParseType-Eigenschaft xlDelimited lautet.


Beispiel zur TextFileConsecutiveDelimiter-Eigenschaft

In diesem Beispiel werden Leerzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe als Trennzeichen festgelegt und anschließend die Abfragetabelle aktualisiert. Aufeinanderfolgende Leerzeichen werden als einzelnes Trennzeichen behandelt.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1, 1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileSpaceDelimiter = True
    .TextFileConsecutiveDelimiter = True
    .Refresh
End With


TextFileDecimalSeparator-Eigenschaft

Gibt das Dezimaltrennzeichen, das von Microsoft Excel beim Importieren einer Textdatei in eine Abfragetabelle verwendet wird, zurück oder legt dieses fest. Standardmäßig wird das Dezimaltrennzeichen des Systems verwendet. String Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragedatei auf Daten aus einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist) und die Datei Dezimal- und 1.000er-Trennzeichen enthält, die sich von den auf dem Computer verwendeten auf Grund einer anderen Ländereinstellung unterscheiden.

In der folgenden Tabelle sind die Ergebnisse beim Importieren von Text in Microsoft Excel mit verschiedenen Trennzeichen gezeigt. Die numerischen Ergebnisse werden in der Spalte ganz rechts angezeigt.

Dezimaltrennzeichen des Systems | 1.000er-Trennzeichen des Systems | Dezimaltrennzeichen der Textdatei | 1.000er-Trennzeichen der Textdatei | Importierter Text | Zellwert (Datentyp)
Punkt | Komma | Komma | Punkt | 123.123,45 | 123,123.45 (numerisch)
Punkt | Komma | Komma | Komma | 123.123,45 | 123.123,45 (Text)
Komma | Punkt | Komma | Punkt | 123,123.45 | 123,123.45 (numerisch)
Punkt | Komma | Punkt | Komma | 123 123.45 | 123 123.45 (Text)
Punkt | Komma | Punkt | Leerzeichen | 123 123.45 | 123,123.45 (numerisch)


Beispiel zur TextFileDecimalSeparator-Eigenschaft

In diesem Beispiel wird das ursprüngliche Dezimaltrennzeichen gespeichert und als Dezimaltrennzeichen für die erste Abfragetabelle in Sheet1 wird das Komma festgelegt. Dies dient beispielsweise zur Vorbereitung des Imports einer französischen Textdatei in die US-englische Version von Microsoft Excel.

strDecSep = Worksheets("Sheet1").QueryTables(1) _
    .TextFileDecimalSeparator
Worksheets("Sheet1").QueryTables(1) _
    .TextFileDecimalSeparator = ","


TextFileFixedColumnWidths-Eigenschaft

Gibt eine Matrix mit ganzen Zahlen, die den Breiten der Spalten (in Zeichen) in der Textdatei, die in eine Abfragetabelle importiert wird, entsprechen, zurück oder legt diese fest. Gültige Breiten reichen von 1 bis 32767 Zeichen. Variant Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur, wenn der Wert der TextFileParseType-Eigenschaft xlFixedWidth lautet.

Sie müssen eine zulässige, nichtnegative Spaltenbreite angeben. Wenn Sie Spalten angeben, die die Breite der Textdatei überschreiten, werden diese Werte ignoriert. Ist die Breite der Textdatei größer als die Gesamtbreite der angegebenen Spalten, werden die überschüssigen Zeichen der Textdatei in eine zusätzliche Spalte importiert.


Beispiel zur TextFileFixedColumnWidths-Eigenschaft

In diesem Beispiel wird eine Textdatei mit fester Breite in eine neue Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe importiert. Die erste Spalte in der Textdatei ist fünf Zeichen breit und wird als Text importiert. Die zweite Spalte ist vier Zeichen breit und wird übergangen. Der Rest der Textdatei wird in die dritte Spalte importiert, wobei das Standardformat verwendet wird.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1, 1))
With qtQtrResults
    .TextFileParseType = xlFixedWidth
    .TextFileFixedColumnWidths = Array(5, 4)
    .TextFileColumnDataTypes = _
        Array(xlTextFormat, xlSkipColumn, xlGeneralFormat)
    .Refresh
End With


TextFileOtherDelimiter-Eigenschaft

Gibt das Zeichen, das beim Importieren einer Textdatei in eine Abfragetabelle als Trennzeichen verwendet wird, zurück oder legt dieses fest. Der Standardwert ist Null. String Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur dann, wenn der Wert der TextFileParseType-Eigenschaft xlDelimited lautet.

Wird in der Zeichenfolge mehr als ein Zeichen angegeben, wird lediglich das erste Zeichen verwendet.


Beispiel zur TextFileOtherDelimiter-Eigenschaft

In diesem Beispiel wird das Nummernzeichen (#) als Trennzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und die Abfragetabelle anschließend aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileOtherDelimiter = "#"
    .Refresh
End With


TextFileParseType-Eigenschaft

Gibt das Spaltenformat der Daten in der in eine Abfragetabelle importierten Textdatei zurück oder legt dieses fest. Kann eine der folgenden XlTextParsingType-Konstanten sein: xlDelimited (die Datei verwendet Trennzeichen) oder xlFixedWidth (die Daten in der Datei sind in Spalten mit festen Breiten angeordnet) Der Standardwert ist xlDelimited. XlTextParsingType Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).


Beispiel zur TextFileParseType-Eigenschaft

In diesem Beispiel wird eine Textdatei mit fester Breite in eine neue Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe importiert. Die erste Spalte in der Textdatei ist fünf Zeichen breit und wird als Text importiert. Die zweite Spalte ist vier Zeichen breit und wird übergangen. Der Rest der Textdatei wird in die dritte Spalte importiert, wobei das Standardformat verwendet wird.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1, 1))
With qtQtrResults
    .TextFileParseType = xlFixedWidth
    .TextFileFixedColumnWidths = Array(5, 4)
    .TextFileColumnDataTypes = _
        Array(xlTextFormat, xlSkipColumn, xlGeneralFormat)
    .Refresh
End With


TextFilePlatform-Eigenschaft

Gibt die Herkunft der in die Abfragetabelle importierten Textdatei zurück oder legt diese fest. Diese Eigenschaft bestimmt, welche Codepage beim Datenimport verwendet wird. Kann eine der folgenden XlPlatform-Konstanten sein: xlMacintosh, xlMSDOS oder xlWindows. Der Standardwert ist die aktuelle Einstellung der File Origin-Option im Textkonvertierungs-Assistent. XlPlatform Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).


Beispiel zur TextFilePlatform-Eigenschaft

In diesem Beispiel wird eine MS-DOS-Textdatei in die Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe importiert und anschließend die Abfragetabelle aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFilePlatform = xlMSDOS
    .TextFileParseType = xlDelimited
    .TextFileTabDelimiter = True
    .Refresh
End With


TextFilePromptOnRefresh-Eigenschaft

True, wenn der Name der importierten Textdatei bei jeder Aktualisierung der Abfragetabelle angegeben werden soll. In dem Dialogfeld Textdatei importieren können Sie Pfad und Dateiname angeben. Der Standardwert ist False. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).

Ist der Wert dieser Eigenschaft True, wird beim ersten Aktualisieren einer Abfragetabelle kein Dialogfeld angezeigt.

Der Standardwert in der Benutzeroberfläche ist True.


Beispiel zur TextFilePromptOnRefresh-Eigenschaft

In diesem Beispiel wird der Benutzer bei jeder Aktualisierung der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe nach dem Namen der Textdatei gefragt.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFilePromptOnRefresh = True
    .TextFileTabDelimiter = True
    .Refresh
End With


TextFileSemicolonDelimiter-Eigenschaft

True, wenn beim Importieren einer Textdatei in eine Abfragetabelle als Trennzeichen ein Semikolon verwendet wird, und der Wert der TextFileParseType-Eigenschaft xlDelimited lautet. Der Standardwert ist False. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).


Beispiel zur TextFileSemicolonDelimiter-Eigenschaft

In diesem Beispiel werden Semikolons als Trennzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und die Abfragetabelle anschließend aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileSemicolonDelimiter = True
    .Refresh
End With


TextFileSpaceDelimiter-Eigenschaft

True, wenn beim Importieren einer Textdatei in eine Abfragetabelle als Trennzeichen Leerzeichen verwendet werden. Der Standardwert ist False. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur dann, wenn der Wert der TextFileParseType-Eigenschaft xlDelimited lautet.


Beispiel zur TextFileSpaceDelimiter-Eigenschaft

In diesem Beispiel werden Leerzeichen als Trennzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und die Abfragetabelle anschließend aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileSpaceDelimiter = True
    .Refresh
End With


TextFileStartRow-Eigenschaft

Gibt die Zeilennummer, bei der die Textanalyse beim Importieren einer Textdatei in eine Abfragetabelle beginnt, zurück oder legt diese fest. Zulässige Werte sind ganze Zahlen von 1 bis 32767. Der Standardwert ist 1. Long Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).


Beispiel zur TextFileStartRow-Eigenschaft

In diesem Beispiel wird die fünfte Zeile als Anfangszeile für die Textanalyse in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und anschließend die Abfragetabelle aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileStartRow = 5
    .TextFileTabDelimiter = True
    .Refresh
End With


TextFileTabDelimiter-Eigenschaft

True, wenn beim Importieren einer Textdatei in eine Abfragetabelle das Tabulatorzeichen als Trennzeichen verwendet wird. Der Standardwert ist False. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), und nur dann, wenn der Wert der TextFileParseType-Eigenschaft xlDelimited lautet.


Beispiel zur TextFileTabDelimiter-Eigenschaft

In diesem Beispiel werden Tabulatorzeichen als Trennzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt und die Abfragetabelle anschließend aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileTabDelimiter = True
    .Refresh
End With


TextFileTextQualifier-Eigenschaft

Gibt das Texterkennungszeichen beim Importieren einer Textdatei in eine Abfragetabelle zurück oder legt diesen fest. Das Texterkennungszeichen gibt an, dass die eingeschlossenen Daten im Textformat vorliegen. Kann eine der folgenden XlTextQualifier-Konstanten sein: xlTextQualifierDoubleQuote, xlTextQualifierNone oder xlTextQualifierSingleQuote. Die Standardkonstante ist xlTextQualifierDoubleQuote. XlTextQualifier Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist).


Beispiel zur TextFileTextQualifier-Eigenschaft

In diesem Beispiel wird das einfache Anführungszeichen als Texterkennungszeichen für die Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe festgelegt.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "TEXT;C:\My Documents\19980331.txt", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParseType = xlDelimited
    .TextFileTextQualifier = xlTextQualifierSingleQuote
    .Refresh
End With


TextFileThousandsSeparator-Eigenschaft

Gibt das 1.000er-Trennzeichen, das von Microsoft Excel beim Importieren einer Textdatei in eine Abfragetabelle verwendet wird, zurück oder legt dieses fest. Standardmäßig wird das 1.000er-Trennzeichen des Systems verwendet. String Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die Abfragetabelle auf Daten einer Textdatei basiert (wobei die QueryType-Eigenschaft auf xlTextImport festgelegt ist), insbesondere wenn die Datei Dezimal- und 1.000er-Trennzeichen enthält, die sich von den auf dem Computer verwendeten auf Grund einer anderen Ländereinstellung unterscheiden.

In der folgenden Tabelle sind die Ergebnisse beim Importieren von Text in Microsoft Excel mit verschiedenen Trennzeichen gezeigt. Die numerischen Ergebnisse werden in der Spalte ganz rechts angezeigt.

Dezimaltrennzeichen des Systems | 1.000er-Trennzeichen des Systems | Dezimaltrennzeichen der Textdatei | 1.000er-Trennzeichen der Textdatei | Importierter Text | Zellwert (Datentyp)
Punkt | Komma | Komma | Punkt | 123.123,45 | 123,123.45 (numerisch)
Punkt | Komma | Komma | Komma | 123.123,45 | 123.123,45 (Text)
Komma | Punkt | Komma | Punkt | 123,123.45 | 123,123.45 (numerisch)
Punkt | Komma | Punkt | Komma | 123 123.45 | 123 123.45 (Text)
Punkt | Komma | Punkt | Leerzeichen | 123 123.45 | 123,123.45 (numerisch)


Beispiel zur TextFileThousandsSeparator-Eigenschaft

In diesem Beispiel wird das ursprüngliche 1.000er-Trennzeichen gespeichert und als 1.000er-Trennzeichen für die erste Abfragetabelle in Sheet1 wird das Komma festgelegt. Dies dient beispielsweise zur Vorbereitung des Imports einer französischen Textdatei in die US-englische Version von Microsoft Excel.

strDecSep = Worksheets("Sheet1").QueryTables(1) _
    .TextFileThousandsSeparator
Worksheets("Sheet1").QueryTables(1) _
    .TextFileThousandsSeparator = "."


TextFrame-Eigenschaft

Gibt ein TextFrame-Objekt zurück, das die Eigenschaften der Ausrichtung und der Verankerung der angegebenen Form enthält. Schreibgeschützt.


Beispiel zur TextFrame-Eigenschaft

In diesem Beispiel wird der Text des Textrahmens der ersten Form im Blocksatz ausgerichtet. Besitzt die erste Form keinen Textrahmen, so schlägt dieses Beispiel fehl.

Worksheets(1).Shapes(1).TextFrame _
    .HorizontalAlignment = xlHAlignJustify


TextToDisplay-Eigenschaft

Gibt den Text, der für den angegebenen Hyperlink angezeigt werden soll, zurück oder legt diesen fest. Standardmäßig wird die Adresse des Hyperlinks verwendet. String Lese-/Schreibzugriff.


Beispiel zur TextToDisplay-Eigenschaft

In diesem Beispiel wird der Text, der für den ersten Hyperlink im aktiven Tabellenblatt angezeigt werden soll, festgelegt.

ActiveSheet.Hyperlinks(1).TextToDisplay = _
    "Company Home Page"


TextureName-Eigenschaft

Gibt den Namen der benutzerdefinierten Strukturdatei der angegebenen Füllung zurück. String Schreibgeschützt.

Verwenden Sie die Methoden UserPicture oder UserTextured, um die Strukturdatei der Füllung festzulegen.


Beispiel zur TextureName-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillTextured Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        If c1f.TextureType = msoTexturePreset Then
            .PresetTextured c1f.PresetTexture
        Else
            .UserTextured c1f.TextureName
        End If
    End With
End If


TextureType-Eigenschaft

Gibt den Strukturtyp der angegebenen Füllung zurück. Dies kann eine der folgenden MsoTextureType-Konstanten sein: msoTexturePreset, msoTextureTypeMixed oder msoTextureUserDefined. Long Schreibgeschützt.

Verwenden Sie die UserTextured-Methode, um den Strukturtyp der Füllung festzulegen.


Beispiel zur TextureType-Eigenschaft

In diesem Beispiel wird festgelegt, dass das Füllformat des zweiten Diagramms dem des ersten entspricht.

Set c1f = Charts(1).ChartArea.Fill
If c1f.Type = msoFillTextured Then
    With Charts(2).ChartArea.Fill
        .Visible = True
        If c1f.TextureType = msoTexturePreset Then
            .PresetTextured c1f.PresetTexture
        Else
            .UserTextured c1f.TextureName
        End If
    End With
End If


ThisWorkbook-Eigenschaft

Gibt ein Workbook-Objekt zurück, das die Arbeitsmappe darstellt, in der das aktuelle Makro ausgeführt wird. Schreibgeschützt.

Anmerkungen

Verwenden Sie diese Eigenschaft, um einen Bezug zu der Arbeitsmappe herzustellen, die Ihr Makro enthält. Nur mit ThisWorkbook ist es möglich, von einem Add-In aus zu einer Add-In-Arbeitsmappe einen Bezug herzustellen. Die ActiveWorkbook-Eigenschaft gibt nicht die Add-In-Arbeitsmappe zurück, sondern die das Add-In aufrufende Arbeitsmappe. Die Workbooks-Eigenschaft kann hierbei einen Fehler verursachen, da der Arbeitsmappenname bei der Erstellung des Add-Ins wahrscheinlich geändert wurde. ThisWorkbook gibt immer die Arbeitsmappe zurück, in der das Makro ausgeführt wird.

Verwenden Sie beispielsweise den folgenden Code, um ein Dialogblatt zu aktivieren, das in Ihrer Add-In-Arbeitsmappe gespeichert ist.

ThisWorkbook.DialogSheets(1).Show

Diese Eigenschaft kann nur von Microsoft Excel aus verwendet werden. Sie kann nicht für den Zugriff auf eine Arbeitsmappe von einer anderen Anwendung aus verwendet werden.


Beispiel zur ThisWorkbook-Eigenschaft

In diesem Beispiel wird die Arbeitsmappe geschlossen, die den Beispielcode enthält. Falls Änderungen an der Arbeitsmappe vorgenommen wurden, werden sie nicht gespeichert.

ThisWorkbook.Close SaveChanges:=False


ThreeD-Eigenschaft

Gibt ein ThreeDFormat-Objekt zurück, das Formateigenschaften des 3D-Effekts der angegebenen Form enthält. Schreibgeschützt.


Beispiel zur ThreeD-Eigenschaft

In diesem Beispiel werden für den 3D-Effekt der dritten Form in myDocument Projektionsfarbe und -richtung sowie Beleuchtungsrichtung festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).ThreeD
    .Visible = True
    .Depth = 50
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    ' RGB value for purple
    .SetExtrusionDirection msoExtrusionTop
    .PresetLightingDirection = msoLightingLeft
End With


TickLabelPosition-Eigenschaft

Beschreibt die Position der Teilstrichbeschriftungen der angegebenen Achse. Kann eine der folgenden XlTickLabelPosition-Konstanten sein: xlTickLabelPositionNone, xlTickLabelPositionLow, xlTickLabelPositionHigh oder xlTickLabelPositionNextToAxis. Long Schreib-Lese-Zugriff.


Beispiel zur TickLabelPosition-Eigenschaft

In diesem Beispiel werden die Teilstrichbeschriftungen der Rubrikenachse in Chart1 über dem Diagramm angeordnet.

Charts("Chart1").Axes(xlCategory) _
    .TickLabelPosition = xlTickLabelPositionHigh


TickLabels-Eigenschaft

Gibt ein TickLabels-Objekt zurück, das die Teilstrichbeschriftungen für die angegebene Achse darstellt. Schreibgeschützt.


TickLabelSpacing-Eigenschaft

Gibt die Anzahl der Rubriken bzw. Datenreihen zwischen Teilstrichbeschriftungen zurück oder legt sie fest. Nur gültig für Rubriken- und Datenreihenachsen. Long Schreib-Lese-Zugriff.

Anmerkungen

Der Abstand zwischen den Beschriftungen auf der Größenachse wird immer von Microsoft Excel berechnet.


Beispiel zur TickLabelSpacing-Eigenschaft

In diesem Beispiel wird die Anzahl der Rubriken zwischen Teilstrichbeschriftungen auf der Rubrikenachse in Chart1 festgelegt.

Charts("Chart1").Axes(xlCategory).TickLabelSpacing = 10


TickMarkSpacing-Eigenschaft

Gibt die Anzahl der Rubriken oder Datenreihen zwischen Teilstrichen zurück oder legt sie fest. Nur gültig für Rubriken- und Datenreihenachsen. Long Schreib-Lese-Zugriff.

Anmerkungen

Mit den Eigenschaften MajorUnit und MinorUnit können Sie den Abstand zwischen Teilstrichen auf der Größenachse festlegen.


Beispiel zur TickMarkSpacing-Eigenschaft

In diesem Beispiel wird die Anzahl der Rubriken zwischen Teilstrichen auf der Rubrikenachse in Chart1 festgelegt.

Charts("Chart1").Axes(xlCategory).TickMarkSpacing = 10


Title-Eigenschaft

Gibt den Titel der Webseite, wenn das Dokument als Webseite gespeichert wird, zurück oder legt diesen fest. String Lese-/Schreibzugriff.

Anmerkungen

Der Titel wird normalerweise in der Fenstertitelleiste angezeigt, wenn das Dokument im Webbrowser angezeigt wird.


Beispiel zur Title-Eigenschaft

In diesem Beispiel wird der Titel der Webseite auf "Sales Forecast" festgelegt, wenn das erste Element in der ersten Arbeitsmappe als Webseite gespeichert wird.

Workbooks(1).PublishObjects(1).Title = "Sales Forecast"


 Top-Eigenschaft

Top-Eigenschaft

Gibt die Position des angegebenen Objekts in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff mit Ausnahmen entsprechend der folgenden Tabelle.

Anmerkungen

Die Bedeutung der Top-Eigenschaft hängt von dem angegebenen Objekt ab.

Objekt | Bedeutung
Application | Der Abstand vom oberen Rand des Bildschirms zum oberen Rand des Microsoft Excel-Hauptfensters. Diese Eigenschaft legt die Position des Fenstersymbols fest (beliebige Position auf dem Bildschirm), wenn das Anwendungsfenster minimiert ist.
Range | Der Abstand des oberen Randes von Zeile 1 zum oberen Rand des Bereichs. Wenn der Bereich nicht zusammenhängend ist, wird der erste Bereich verwendet. Ist der Bereich höher als eine Zeile, so wird die oberste Zeile des Bereichs (die Zeile mit der niedrigsten Nummer) verwendet. Lese-Zugriff.
Window | Der Abstand des oberen Fensterrandes zum oberen Rand des nutzbaren Bereichs (unterhalb der Menüleiste, den befestigten Symbolleisten, und der Bearbeitungsleiste). Bei einem maximierten Fenster kann diese Eigenschaft nicht festgelegt werden. Mit Hilfe der WindowState-Eigenschaft können Sie den Status des Fensters zurückgeben oder festlegen.
Axis, AxisTitle, ChartArea, ChartObject, ChartTitle, DataLabel, Legend, LegendEntry, LegendKey, OLEObject, PlotArea | Der Abstand des oberen Objektrands zum oberen Rand von Zeile 1 (in einem Tabellenblatt) bzw. zum oberen Rand des Diagrammbereichs (in einem Diagramm). Schreibgeschützt für Axis, ChartArea, LegendEntry und LegendKey.


TopLeftCell-Eigenschaft

Gibt ein Range-Objekt zurück, das die Zelle darstellt, die unter der oberen linken Ecke des Objekts liegt. Schreibgeschützt.


Beispiel zur TopLeftCell-Eigenschaft

In diesem Beispiel wird die Adresse der Zelle angezeigt, die unterhalb der linken oberen Ecke des ersten eingebetteten Diagramms in Sheet1 liegt.

MsgBox "The top left corner is over cell " & _
    Worksheets("Sheet1").ChartObjects(1).TopLeftCell.Address


 TopMargin-Eigenschaft

TopMargin-Eigenschaft

Gibt die Breite des oberen Randes in Punkt zurück oder legt diese fest. Double Schreib-Lese-Zugriff.

Anmerkungen

Ränder werden in Punkt festgelegt oder zurückgegeben. Mit den Methoden InchesToPoints und CentimetersToPoints können Sie die Maßeinheiten umwandeln.


Beispiel zur TopMargin-Eigenschaft

In den zwei folgenden Beispielen wird der obere Rand von Sheet1 auf 0,5 Zoll (36 Punkt) festgelegt.

Worksheets("Sheet1").PageSetup.TopMargin = _
        Application.InchesToPoints(0.5)

Worksheets("Sheet1").PageSetup.TopMargin = 36

In diesem Beispiel wird die aktuelle Einstellung des unteren Randes festgelegt.

marginInches = ActiveSheet.PageSetup.TopMargin / _
    Application.InchesToPoints(1)
MsgBox "The current top margin is " & marginInches & " inches"


 TotalLevels-Eigenschaft

TotalLevels-Eigenschaft

Gibt die Gesamtanzahl der Felder in der aktuellen Feldgruppierung zurück. Wenn das Feld nicht gruppiert oder die Datenquelle OLAP-basiert ist, gibt TotalLevels den Wert 1 zurück. Long Schreibgeschützt.

Anmerkungen

Alle Felder in einer Feldgruppierung haben den gleichen TotalLevels-Wert.


Beispiel zur TotalLevels-Eigenschaft

In diesem Beispiel wird die Gesamtanzahl der Felder in der Gruppe mit der aktiven Zelle angezeigt.

Worksheets("Sheet1").Activate
MsgBox "This group has " & _
    ActiveCell.PivotField.TotalLevels & " levels."


TotalsAnnotation-Eigenschaft

True, wenn neben jedem Teilergebnis- und Gesamtergebniswert in dem angegebenen PivotTable-Bericht ein Sternchen (*) angezeigt wird, sofern der Bericht auf einer OLAP-Datenquelle basiert. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Ist diese Eigenschaft auf True eingestellt, kennzeichnet das Sternchen, dass in der Gesamtsumme ausgeblendete Elemente enthalten sind. Das Sternchen wird unabhängig davon, ob Elemente in dem Bericht ausgeblendet wurden, angezeigt.

Für Nicht-OLAP-Datenquellen ist der Wert dieser Eigenschaft immer False.


Beispiel zur TotalsAnnotation-Eigenschaft

In diesem Beispiel werden die Sternchen im ersten PivotTable-Bericht des aktiven Tabellenblatts deaktiviert.

ActiveSheet.PivotTables(1).TotalsAnnotation = False


Tracking-Eigenschaft

Gibt das Verhältnis zwischen dem horizontalen Raum, den jedes Zeichen in der angegebenen WordArt einnehmen darf, und der Zeichenbreite zurück, oder legt das Verhältnis fest. Kann ein Wert zwischen 0 (Null) und 5 sein. (Hohe Werte führen bei dieser Eigenschaft zu großen Abständen zwischen den Zeichen; bei Werten unter 1 kann es zu einer Überschneidung der Zeichen kommen.) Single Lese- und Schreibzugriff.

In der folgenden Tabelle sind die Wert der Tracking-Eigenschaft aufgeführt, die den verfügbaren Einstellungen auf der Benutzeroberfläche entsprechen.

Einstellung der Benutzeroberfläche | Entsprechender Wert der Tracking-Eigenschaft
Sehr eng | 0.8
Eng | 0.9
Normal | 1.0
Weit | 1.2
Sehr weit | 1.5


Beispiel zur Tracking-Eigenschaft

In diesem Beispiel wird in myDocument eine WordArt mit dem Text "Test" eingefügt und eine sehr enge Laufweite der Zeichen festgelegt.

Set myDocument = Worksheets(1)
Set newWordArt = myDocument.Shapes.AddTextEffect( _
    PresetTextEffect:=msoTextEffect1, Text:="Test", _
    FontName:="Arial Black", FontSize:=36, _
    FontBold:=False, FontItalic:=False, Left:=100, _
    Top:=100)
newWordArt.TextEffect.Tracking =0.8


TrackStatus-Eigenschaft

True, wenn der Status des Verteilers verfolgt wird. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Wenn gerade eine Übermittlung stattfindet, lässt sich diese Eigenschaft nicht anwenden.


Beispiel zur TrackStatus-Eigenschaft

In diesem Beispiel wird MAPPE1.XLS an drei Empfänger mit aktivierter Statusverfolgung weitergeleitet.

Workbooks("BOOK1.XLS").HasRoutingSlip = True
With Workbooks("BOOK1.XLS").RoutingSlip
    .Delivery = xlOneAfterAnother
    .Recipients = Array("Adam Bendel", _
        "Jean Selva", "Bernard Gabor")
    .Subject = "Here is BOOK1.XLS"
    .Message = "Here is the workbook. What do you think?"
    .ReturnWhenDone = True
    .TrackStatus = True
End With
Workbooks("BOOK1.XLS").Route


TransitionExpEval-Eigenschaft

True, wenn Microsoft Excel für dieses Arbeitsblatt die Lotus 1-2-3-Regeln zur Formelberechnung verwendet. Boolean Schreib-Lese-Zugriff.


Beispiel zur TransitionExpEval-Eigenschaft

In diesem Beispiel verwendet Microsoft Excel für Sheet1 die Lotus 1-2-3-Regeln zur Formelberechnung.

Worksheets("Sheet1").TransitionExpEval = True


TransitionFormEntry-Eigenschaft

True, wenn Microsoft Excel in diesem Tabellenblatt die Lotus 1-2-3-Regeln zur Formeleingabe verwendet. Boolean Schreib-Lese-Zugriff.


Beispiel zur TransitionFormEntry-Eigenschaft

In diesem Beispiel verwendet Microsoft Excel in Sheet1 die Lotus 1-2-3-Regeln zur Formeleingabe.

Worksheets("Sheet1").TransitionFormEntry = True


TransitionMenuKey-Eigenschaft

Diese Eigenschaft gibt die Taste für das Microsoft Excel-Menü bzw. die Microsoft Excel-Hilfe (in der Regel "/") zurück bzw. stellt diese ein. String Lese- und Schreibzugriff.


TransitionMenuKeyAction-Eigenschaft

Sprachspezifische Informationen

Gibt die Aktion zurück, die beim Drücken der Menütaste von Microsoft Excel ausgeführt wird, oder legt sie fest. Kann entweder xlExcelMenus oder xlLotusHelp sein. Long Lese-/Schreibzugriff.


Beispiel zur TransitionMenuKeyAction-Eigenschaft

Sprachspezifische Informationen

In diesem Beispiel wird festgelegt, dass beim Drücken der Menütaste von Microsoft Excel die Lotus 1-2-3-Hilfe ausgeführt wird.

Application.TransitionMenuKeyAction = xlLotusHelp


TransitionNavigKeys-Eigenschaft

True, wenn die alternativen Bewegungstasten aktiviert sind. Boolean Lese-/Schreibzugriff.


Beispiel zur TransitionNavigKeys-Eigenschaft

Das folgende Beispiel zeigt den aktuellen Status der Option Alternative Bewegungstasten an.

If Application.TransitionNavigKeys Then
    keyState = "On"
Else
    keyState = "Off"
End If
MsgBox "The Transition Navigation Keys option is " & keyState


Transparency-Eigenschaft

Gibt den Deckungsgrad der angegebenen Füllung als Wert zwischen 0,0 (deckend) bis 1,0 (transparent) zurück. Double Schreib-Lese-Zugriff.

Anmerkungen

Der Wert dieser Eigenschaft verändert nur einfarbige Füllungen und Linien; er hat keine Auswirkungen auf gestrichelte Linien oder die Fülleffekte "Fließend", "Struktur", "Grafik" und "Muster".


 TransparencyColor-Eigenschaft

TransparencyColor-Eigenschaft

Gibt die transparente Farbe des angegebenen Bildes als Rot-Grün-Blau-(RGB-)Wert zurück oder legt sie fest. Damit diese Eigenschaft wirksam wird, muss die TransparentBackground-Eigenschaft den Wert True besitzen. Gilt nur für Bitmaps. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie durch die transparenten Teile des Bildes hindurch bis auf die Objekte hinter dem Bild schauen möchten, müssen Sie für die Visible-Eigenschaft des FillFormat-Objekts den Wert False festlegen. Besitzt Ihr Bild eine transparente Farbe und die Visible-Eigenschaft des FillFormat-Objekts den Wert True, ist die Füllung des Bildes durch die transparente Farbe sichtbar, die Objekte hinter dem Bild bleiben jedoch verdeckt.


Beispiel zur TransparencyColor-Eigenschaft

In diesem Beispiel wird als transparente Farbe der ersten Form in myDocument die Farbe festgelegt, die den durch die Funktion RGB(0, 0, 255) zurückgegebenen RGB-Wert besitzt. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um eine Bitmap handeln.

blueScreen = RGB(0, 0, 255)
Set myDocument = Worksheets(1)
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


TransparentBackground-Eigenschaft

True, wenn die Teile des Bildes, die die als transparent definierte Farbe besitzen, transparent erscheinen. Verwenden Sie die TransparencyColor-Eigenschaft, um die transparente Farbe festzulegen. Gilt nur für Bitmaps. Long Schreib-Lese-Zugriff.

Anmerkungen

Wenn Sie durch die transparenten Teile des Bildes hindurch bis auf die Objekte hinter dem Bild schauen möchten, müssen Sie für die Visible-Eigenschaft des FillFormat-Objekts den Wert False festlegen. Besitzt Ihr Bild eine transparente Farbe und die Visible-Eigenschaft des FillFormat-Objekts den Wert True, ist die Füllung des Bildes durch die transparente Farbe sichtbar, die Objekte hinter dem Bild bleiben jedoch verdeckt.


Beispiel zur TransparentBackground-Eigenschaft

In diesem Beispiel wird als transparente Farbe der ersten Form in myDocument die Farbe festgelegt, die den durch die Funktion RGB(0,24,240) zurückgegebenen RGB-Wert besitzt. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um ein Bitmap handeln.

blueScreen = RGB(0, 0, 255)
Set myDocument = Worksheets(1)
With myDocument.Shapes(1)
    With .PictureFormat
        .TransparentBackground = True
        .TransparencyColor = blueScreen
    End With
    .Fill.Visible = False
End With


 TreeviewControl-Eigenschaft

TreeviewControl-Eigenschaft

Gibt das TreeviewControl-Objekt des CubeField-Objekts zurück, das das Steuerelement für die Cube-Manipulation eines OLAP-basierten PivotTable-Berichts darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft ist nur dann verfügbar, wenn das Steuerelement sichtbar ist.


Beispiel zur TreeviewControl-Eigenschaft

In diesem Beispiel wird das Steuerelement des ersten Cube-Felds für die Staaten Kalifornien (CA) und Maryland (MD) im zweiten PivotTable-Bericht des aktiven Tabellenblatts auf "Drilled" festgelegt.

ActiveSheet.PivotTables("PivotTable2") _
    .CubeFields(1).TreeviewControl.Drilled = _
        Array(Array("", ""), _
        Array("[state].[states].[CA]", _
            "[state].[states].[MD]"))


TwoInitialCapitals-Eigenschaft

True, wenn Wörter, die mit zwei großgeschriebenen Anfangsbuchstaben beginnen, automatisch korrigiert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur TwoInitialCapitals-Eigenschaft

In diesem Beispiel wird Microsoft Excel so eingestellt, dass Wörter automatisch korrigiert werden, die mit zwei großgeschriebenen Anfangsbuchstaben beginnen.

With Application.AutoCorrect
    .TwoInitialCapitals = True
    .ReplaceText = True
End With


Type-Eigenschaft

Gibt den Objekttyp zurück oder legt ihn fest, wie in der folgenden Tabelle aufgeführt.

Objekt | Typ
Axis | Typ Achse. Dies kann eine der folgenden XlAxisType-Konstanten sein: xlCategory, xlSeriesAxis oder xlValue. Long Schreib-Lese-Zugriff.
Color | Typ Farbe. Dies kann eine der folgenden MsoColorType-Konstanten sein: msoColorTypeMixed, msoColorTypeRGB oder msoColorTypeScheme. Long Schreibgeschützt.
ConnectorFormat | Typ Verbindung. Dies kann eine der folgenden MsoConnectorType-Konstanten sein: msoConnectorCurve, msoConnectorElbow, msoConnectorStraight oder msoConnectorTypeMixed. Long Schreib-Lese-Zugriff.
DataLabel, DataLabels | Typ Datenbeschriftung. Dies kann eine der folgenden XlDataLabelsType-Konstanten sein: xlDataLabelsShowBubbleSizes, xlDataLabelsShowLabel, xlDataLabelsShowLabelAndPercent, xlDataLabelsShowNone, xlDataLabelsShowPercent oder xlDataLabelsShowValue. Long Schreib-Lese-Zugriff.
FillFormat | Typ Füllung. Dies kann eine der folgenden MsoFillType-Konstanten sein: msoFillBackground, msoFillGradient, msoFillMixed, msoFillPatterned, msoFillPicture, msoFillSolid oder msoFillTextured. Die msoFillBackground-Konstante wird in Microsoft Excel nicht verwendet. Long Schreibgeschützt.
FormatCondition | Typ Bedingte Formatierung. Dies kann eine der folgenden xlFormatConditionType-Konstanten sein: xlCellValue oder xlExpression. Long Schreibgeschützt.
HPageBreak, VPageBreak | Typ Seitenwechsel. Dies kann eine der folgenden XlPageBreak-Konstanten sein: xlPageBreakAutomatic oder xlPageBreakManual. Long Schreib-Lese-Zugriff.
Hyperlink | Typ Hyperlink (die Zuordnung des Hyperlinks). Dies kann eine der folgenden MsoHyperlinkType-Konstanten sein: msoHyperlinkInlineShape, msoHyperlinkRange oder msoHyperlinkShape. Long Schreibgeschützt.
Parameter | Typ Parameter. Dies kann eine der folgenden XlParameterType-Konstanten sein: xlConstant, xlPrompt oder xlRange. Long Schreib-Lese-Zugriff.
Shape, ShapeRange | Typ Form. Dies kann eine der folgenden MsoShapeType-Konstanten sein: msoAutoShape, msoCallout, msoChart, msoComment, msoEmbeddedOLEObject, msoFormControl, msoFreeform, msoGroup, msoLine, msoLinkedOLEObject, msoLinkedPicture, msoMedia, msoOLEControlObject, msoPicture, msoPlaceholder, msoShapeTypeMixed oder msoTextEffect. Long Schreibgeschützt. In Microsoft Excel kann diese Eigenschaft nicht msoMedia oder msoPlaceholder sein (diese Konstanten werden mit Formen bereits in anderen Microsoft Office-Anwendungen benutzt).
Trendline | Typ Trendlinie. Dies kann eine der folgenden XlTrendlineType-Konstanten sein: xlExponential, xlLinear, xlLogarithmic, xlMovingAvg, xlPolynomial oder xlPower. Long Schreib-Lese-Zugriff.
Validation | Typ Datenüberprüfung. Dies kann eine der folgenden XlDVType-Konstanten sein: xlValidateCustom, xlValidateDate, xlValidateDecimal, xlValidateInputOnly, xlValidateList, xlValidateTextLength, xlValidateTime oder xlValidateWholeNumber. Long Schreibgeschützt.
Window | Typ Fenster. Dies kann eine der folgenden XlWindowType-Konstanten sein: xlChartAsWindow, xlChartInPlace, xlClipboard, xlInfo oder xlWorkbook. Long Schreibgeschützt.
Worksheet | Typ Tabellenblatt. Dies kann einer der folgenden Werte sein: xlWorksheet, xlExcel4MacroSheet oder xlExcel4IntlMacroSheet. Long Schreibgeschützt.


Beispiel zur Type-Eigenschaft

In diesem Beispiel wird der Trendlinientyp der ersten Datenreihe im ersten eingebetteten Diagramm des ersten Tabellenblattes geändert. Besitzt die Datenreihe keine Trendlinie, so schlägt das Beispiel fehl.

Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).Trendlines(1).Type = xlMovingAvg


Underline-Eigenschaft

Gibt die Art der Unterstreichung entsprechend der folgenden XlUnderlineStyle-Konstanten zurück: xlUnderlineStyleNone, xlUnderlineStyleSingle, xlUnderlineStyleDouble, xlUnderlineStyleSingleAccounting oder xlUnderlineStyleDoubleAccounting. Long Schreib-Lese-Zugriff.


Beispiel zur Underline-Eigenschaft

In diesem Beispiel wird die Schriftart für die aktive Zelle in Sheet1 einfach unterstrichen formatiert.

Worksheets("Sheet1").Activate
ActiveCell.Font.Underline = xlUnderlineStyleSingle


UpBars-Eigenschaft

Gibt ein UpBars-Objekt zurück, das die positive Abweichung in einem Liniendiagramm darstellt. Nur gültig für Liniendiagramme. Schreibgeschützt.


Beispiel zur UpBars-Eigenschaft

In diesem Beispiel werden positive und negative Abweichungsbalken für die erste Diagrammgruppe in Chart1 eingeblendet und die zugehörige Farbe festgelegt. Es ist sinnvoll, dieses Beispiel auf ein 2D-Liniendiagramm anzuwenden, das zwei Datenreihen beinhaltet, die sich in mindestens einem Datenpunkt schneiden.

With Charts("Chart1").ChartGroups(1)
    .HasUpDownBars = True
    .DownBars.Interior.ColorIndex = 3
    .UpBars.Interior.ColorIndex = 5
End With


UpdateLinksOnSave-Eigenschaft

True, wenn Hyperlinks und Pfade zu allen Unterstützungsdateien automatisch aktualisiert werden, bevor das Dokument als Webseite gespeichert wird, damit gewährleistet ist, dass die Verknüpfungen beim Speichern des Dokuments aktuell sind. False, wenn die Verknüpfungen nicht aktualisiert werden. Der Standardwert ist True. Boolean Lese-/Schreibzugriff.

Anmerkungen

Sie sollten diese Eigenschaft auf False setzen, wenn der Speicherort, an dem das Dokument gespeichert wird, sich von dem endgültigen Speicherort auf dem Webserver unterscheidet und die Unterstützungsdateien am ersten Speicherort nicht zur Verfügung stehen.


Beispiel zur UpdateLinksOnSave-Eigenschaft

In diesem Beispiel wird angegeben, dass Verknüpfungen vor dem Speichern des Dokuments nicht aktualisiert werden.

Application.DefaultWebOptions.UpdateLinksOnSave = False


UpdateRemoteReferences-Eigenschaft

True, wenn Remotebezüge für die Arbeitsmappe aktualisiert werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur UpdateRemoteReferences-Eigenschaft

In diesem Beispiel werden Remotebezüge in der aktiven Arbeitsmappe aktualisiert.

ActiveWorkbook.UpdateRemoteReferences = True


 UsableHeight-Eigenschaft

UsableHeight-Eigenschaft

Gibt in Punkt die maximale Höhe der Fläche zurück, die ein Fenster innerhalb des Anwendungsfensters einnehmen kann. Double Schreibgeschützt.


Beispiel zur UsableHeight-Eigenschaft

In diesem Beispiel wird das aktive Fenster auf die maximal mögliche Größe erweitert (vorausgesetzt, das Fenster ist noch nicht maximiert).

With ActiveWindow
    .WindowState = xlNormal
    .Top = 1
    .Left = 1
    .Height = Application.UsableHeight
    .Width = Application.UsableWidth
End With


 UsableWidth-Eigenschaft

UsableWidth-Eigenschaft

Gibt die Breite der Fläche zurück, die von einem Fenster innerhalb des Anwendungsfensters eingenommen werden kann. Die Breite wird in Punkt angegeben. Double Schreibgeschützt.


Beispiel zur UsableWidth-Eigenschaft

In diesem Beispiel wird das aktive Fenster auf die maximal mögliche Größe erweitert (vorausgesetzt, das Fenster ist noch nicht maximiert).

With ActiveWindow
    .WindowState = xlNormal
    .Top = 1
    .Left = 1
    .Height = Application.UsableHeight
    .Width = Application.UsableWidth
End With


UsedRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den verwendeten Bereich im angegebenen Tabellenblatt repräsentiert. Schreibgeschützt.


Beispiel zur UsedRange-Eigenschaft

In diesem Beispiel wird der verwendete Bereich in Sheet1 ausgewählt.

Worksheets("Sheet1").Activate
ActiveSheet.UsedRange.Select


UseLocalConnection-Eigenschaft

True, wenn mit Hilfe der LocalConnection-Eigenschaft die Zeichenfolge angegeben wird, mit der Microsoft Excel eine Verbindung zu einer Datenquelle herstellen kann. False, wenn die durch die Connection-Eigenschaft angegebene Verbindungszeichenfolge verwendet wird. Boolean Lese-/Schreibzugriff.


 Beispiel zur UseLocalConnection-Eigenschaft

Beispiel zur UseLocalConnection-Eigenschaft

In diesem Beispiel wird die Verbindungszeichenfolge des ersten PivotTable-Cache als Bezug auf eine Offline-Cube-Datei verwendet.

With ActiveWorkbook.PivotCaches(1)
    .LocalConnection = _
        "OLEDB;Provider=MSOLAP;Data Source=C:\Data\DataCube.cub"
    .UseLocalConnection = True
End With


UseLongFileNames-Eigenschaft

True, wenn beim Speichern des Dokuments als Webseite lange Dateinamen verwendet werden. False, wenn keine langen Dateinamen sondern das DOS-Dateinamenformat (8.3) verwendet wird. Der Standardwert ist True. Boolean Lese-/Schreibzugriff.

Anmerkungen

Falls keine langen Dateinamen verwendet werden und das Dokument über Unterstützungsdateien verfügt, speichert Microsoft Excel alle Unterstützungsdateien automatisch in einem separaten Ordner. Verwenden Sie andernfalls die OrganizeInFolder-Eigenschaft, um zu bestimmen, ob Unterstützungsdateien in einem getrennten Order gespeichert werden.


Beispiel zur UseLongFileNames-Eigenschaft

In diesem Beispiel wird die Verwendung von langen Dateinamen als globale Standardeinstellung für die Anwendung deaktiviert.

Application.DefaultWebOptions.UseLongFileNames = False


UserControl-Eigenschaft

True, wenn die Anwendung sichtbar ist oder vom Benutzer erstellt oder gestartet wurde. False, wenn die Anwendung als Programm mit Hilfe der Funktionen CreateObject oder GetObject gestartet wurde, und die Anwendung ausgeblendet ist. Boolean Lese-/Schreibzugriff.

Anmerkungen

Wenn die UserControl-Eigenschaft für ein Objekt den Wert False hat, so wird dieses Objekt freigegeben, wenn der letzte programmtechnische Bezug auf das Objekt freigegeben wird. Besitzt diese Eigenschaft den Wert False, wird Microsoft Excel beendet, wenn das letzte Objekt in der Sitzung freigegeben wird.


Beispiel zur UserControl-Eigenschaft

In diesem Beispiel wird der Status der UserControl-Eigenschaft angezeigt.

If Application.UserControl Then
    MsgBox "This workbook was created by the user"
Else
    MsgBox "This workbook was created programmatically"
End If


UserLibraryPath-Eigenschaft

Gibt den Pfad zu dem Speicherort auf dem Computer des Benutzers zurück, an dem die COM-Add-Ins installiert sind. String Schreibgeschützt.


Beispiel zur UserLibraryPath-Eigenschaft

In diesem Beispiel wird festgestellt, wo die COM-Add-Ins auf dem Computer des Benutzers installiert sind und die Zeichenfolge wird der Variablen strLibPath zugewiesen.

strLibPath = Application.UserLibraryPath


UserName-Eigenschaft

Gibt den Namen des aktuellen Benutzers zurück oder legt ihn fest. String Schreibgeschützt.


Beispiel zur UserName-Eigenschaft

In diesem Beispiel wird der Name des aktuellen Benutzers angezeigt.

MsgBox "Current user is " & Application.UserName


UserStatus-Eigenschaft

Gibt eine zweidimensionale Matrix, deren Index mit 1 beginnt, zurück. Sie enthält Informationen über jeden Benutzer, der die Arbeitsmappe im Freigabemodus geöffnet hat. Das erste Element der zweiten Dimension ist der Benutzername; das zweite Element gibt Datum und Uhrzeit des Öffnens der Arbeitsmappe durch den/die Benutzer/in an; das dritte Element ist eine Zahl, die den Modus angibt (1 steht für Exklusivmodus, 2 für Freigabemodus). Variant Schreibgeschützt.

Anmerkungen

Die UserStatus-Eigenschaft gibt keine Informationen über Benutzer/innen zurück, die die angegebene Arbeitsmappe schreibgeschützt (Schreibgeschützt) geöffnet haben.


Beispiel zur UserStatus-Eigenschaft

Im folgenden Beispiel wird eine neue Arbeitsmappe erstellt, und Informationen über alle Benutzer/innen, die die aktive Arbeitsmappe im Freigabemodus geöffnet haben, werden hinzugefügt.

users = ActiveWorkbook.UserStatus
With Workbooks.Add.Sheets(1)
    For row = 1 To UBound(users, 1)
        .Cells(row, 1) = users(row, 1)
        .Cells(row, 2) = users(row, 2)
        Select Case users(row, 3)
            Case 1
                .Cells(row, 3).Value = "Exclusive"
            Case 2
                .Cells(row, 3).Value = "Shared"
        End Select
    Next
End With


UseStandardHeight-Eigenschaft

True, wenn die Zeilenhöhe des Range-Objekts mit der Standardhöhe für das Blatt übereinstimmt. Gibt Null zurück, wenn der Bereich mehrere Zeilen umfasst und diese unterschiedliche Höhe besitzen. Variant Lese- und Schreibzugriff.


Beispiel zur UseStandardHeight-Eigenschaft

In diesem Beispiel wird die Höhe der ersten Zeile in Sheet1 auf die Standardhöhe gesetzt.

Worksheets("Sheet1").Rows(1).UseStandardHeight = True


UseStandardWidth-Eigenschaft

True, wenn die Spaltenbreite des Range-Objekts mit der Standardbreite für das Blatt übereinstimmt. Gibt Null zurück, wenn der Bereich mehrere Spalten umfasst und diese unterschiedliche Breite besitzen. Variant Lese- und Schreibzugriff.


Beispiel zur UseStandardWidth-Eigenschaft

In diesem Beispiel wird die Breite von Spalte A in Sheet1 auf die Standardbreite gesetzt.

Worksheets("Sheet1").Columns("A").UseStandardWidth = True


VacatedStyle-Eigenschaft

Gibt die Formatvorlage von Zellen zurück, die frei werden, wenn der PivotTable-Bericht aktualisiert wird, oder legt sie fest. Der Standardwert ist eine leere Zeichenfolge (standardmäßig wird keine Formatvorlage zugewiesen). String Lese- und Schreibzugriff


Beispiel zur VacatedStyle-Eigenschaft

In diesem Beispiel wird für die frei gewordenen Zellen in dem PivotTable-Bericht die Formatvorlage "BlackAndBlue" festgelegt.

Worksheets(1).PivotTables("Pivot1").VacatedStyle = "BlackAndBlue"


Validation-Eigenschaft

Gibt das Validation-Objekt zurück, das Validierung für den angegebenen Bereich darstellt. Schreibgeschützt.


Beispiel zur Validation-Eigenschaft

In diesem Beispiel wird die Zelle E5 mit Validierung versehen, um leere Werte zuzulassen.

Range("e5").Validation.IgnoreBlank = True


 Value-Eigenschaft

Value-Eigenschaft

Die Bedeutung der Value-Eigenschaft hängt von dem Objekt ab, auf das die Eigenschaft angewendet wird, wie in der folgenden Tabelle beschrieben.

Objekt | Wert
Application | Gibt immer "Microsoft Excel" zurück. Schreibgeschützt.
Borders | Synonym für Borders.LineStyle.
Name | Eine Zeichenfolge, die die Formel enthält, die den Bezug des Namens in A1-Schreibweise in der Sprache des Makros, beginnend mit einem Gleichheitszeichen, angibt. Lese-Zugriff.
Parameter | Der Parameterwert. Weitere Informationen finden Sie unter dem Parameter-Objekt.
PivotField | Der Name des angegebenen Feldes in dem PivotTable-Bericht.
PivotItem | Der Name des angegebenen Elements im Feld der Pivot-Tabelle.
PivotTable | Der Name des PivotTable-Berichts.
Range | Der Wert der angegebenen Zelle. Ist die Zelle leer, so gibt Value den Wert Empty zurück (verwenden Sie die Funktion IsEmpty, um diesen Fall zu prüfen). Wenn das Range-Objekt mehr als eine Zelle enthält, gibt dieses Objekt eine Matrix von Werten zurück (verwenden Sie die Funktion IsArray, um diesen Fall zu prüfen).
Style | Der Name der angegebenen Formatvorlage.
Validation | True, falls alle Gültigkeitskriterien erfüllt werden (d.h. wenn der Bereich gültige Daten enthält).

Die folgende Tabelle zeigt Beispielwerte der Value-Eigenschaft und verwandter Eigenschaften bei einer OLAP-Datenquelle mit dem eindeutigen Namen "[Europa].[Frankreich].[Paris]" und einer Nicht-OLAP-Datenquelle mit dem Elementnamen "Paris".

Eigenschaft | Wert (OLAP-Datenquelle) | Wert (Nicht-OLAP-Datenquelle)
Caption | Paris | Paris
Name | [Europa].[Frankreich].[Paris] (Schreibgeschüzt) | Paris
SourceName | [Europa].[Frankreich].[Paris] (Schreibgeschützt) | (identisch mit SQL-Eigenschaftenwert, schreibgeschützt)
Value | [Europa].[Frankreich].[Paris] (schreibgeschützt) | Paris

Wenn Sie einen Index in der PivotItems-Auflistung angeben, können Sie die in der folgende Tabelle gezeigte Syntax verwenden.

Syntax (OLAP-Datenquelle) | Syntax (Nicht-OLAP-Datenquelle)
Ausdruck.PivotItems("[Europa].[Frankreich].[Paris]") | Ausdruck.PivotItems("Paris")

Wenn die Item-Eigenschaft für den Verweis auf ein bestimmtes Mitglied einer Auflistung verwendet wird, können Sie die folgenden Textindexnamen benutzen.

Name (OLAP-Datenquelle) | Name (Nicht-OLAP-Datenquelle)
[Europa].[Frankreich].[Paris] | Paris


Value2-Eigenschaft

Gibt den Zellwert zurück oder legt ihn fest. Variant Schreib-Lese-Zugriff.

Anmerkungen

Der einzige Unterschied zwischen dieser Eigenschaft und der Value-Eigenschaft besteht darin, dass die Value2-Eigenschaft die Datentypen Currency und Date nicht verwendet. Sie können auf Werte, die mit diesen Datentypen formatiert sind, als Gleitkommazahlen zugreifen, indem Sie den Datentyp Double verwenden.


Beispiel zur Value2-Eigenschaft

In diesem Beispiel wird die Value2-Eigenschaft verwendet, um die Werte zweier Zellen zu addieren.

Range("a1").Value2 = Range("b1").Value2 + Range("c1").Value2


Values-Eigenschaft

Scenario-Objekt: Gibt eine Matrix mit den aktuellen Werten der veränderbaren Zellen des Szenarios zurück. Variant Lese-Zugriff.

Series-Objekt: Gibt eine Auflistung aller Werte der Datenreihe zurück oder legt sie fest. Dabei kann es sich um einen Tabellenblattbereich oder um eine Matrix konstanter Werte handeln (aber nicht um eine Kombination aus beiden). Detaillierte Informationen hierzu finden Sie in den Beispielen. Variant Schreib-Lese-Zugriff.

Bei PivotChart-Berichten ist diese Eigenschaft schreibgeschützt.


Beispiel zur Values-Eigenschaft

In diesem Beispiel werden die Werte für eine Datenreihe aus einem Bereich übernommen.

Charts("Chart1").SeriesCollection(1).Values = _
    Worksheets("Sheet1").Range("C5:T5")

Verwenden Sie eine Matrix, um jedem einzelnen Datenpunkt einen konstanten Wert zuzuweisen.

Charts("Chart1").SeriesCollection(1).Values = _
    Array(1, 3, 5, 7, 11, 13, 17, 19)


VaryByCategories-Eigenschaft

Hat diese Eigenschaft den Wert True, weist Microsoft Excel jeder Datenpunktmarkierung eine andere Farbe oder ein anderes Muster zu. Das Diagramm darf nur eine Datenreihe enthalten. Boolean Schreib-Lese-Zugriff.


Beispiel zur VaryByCategories-Eigenschaft

In diesem Beispiel wird jeder Datenpunktmarkierung in der ersten Diagrammgruppe eine andere Farbe oder ein anderes Muster zugewiesen. Es ist sinnvoll, das Beispiel auf ein 2D-Liniendiagramm anzuwenden, bei dem Datenpunktmarkierungen für eine Datenreihe vorhanden sind.

Charts("Chart1").ChartGroups(1).VaryByCategories = True


VBASigned-Eigenschaft

True, wenn das Visual Basic für Applikationen-Projekt für die angegebene Arbeitsmappe digital signiert wurde. Boolean Schreibgeschützt.


Beispiel zur VBASigned-Eigenschaft

In diesem Beispiel wird eine Arbeitsmappe mit dem Namen mybook.wbk geladen und dann überprüft, ob ihr Visual Basic für Applikationen-Projekt über eine digitale Signatur verfügt. Ist keine digitale Signatur vorhanden, wird in dem Beispiel eine Warnmeldung angezeigt.

Workbooks.Open FileName:="c:\My Documents\mybook.wbk", _
    ReadOnly:=False
If Workbook.VBASigned = False Then
    MsgBox "Warning! The project " _
    "has not been digitally signed." _
    , vbCritical, "Digital Signature Warning"
End If


VBE-Eigenschaft

Gibt ein VBE-Objekt zurück, das den Visual Basic-Editor darstellt. Schreibgeschützt.


Beispiel zur VBE-Eigenschaft

In diesem Beispiel wird der Name des aktiven Visual Basic-Projekts geändert.

Application.VBE.ActiveVBProject.Name = "TestProject"


VBProject-Eigenschaft

Gibt ein VBProject-Objekt zurück, das das Visual Basic-Projekt in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.


Beispiel zur VBProject-Eigenschaft

In diesem Beispiel wir der Name des Visual Basic-Projekts in der Arbeitsmappe geändert.

ThisWorkbook.VBProject.Name = "TestProject"


Version-Eigenschaft

Gibt die Versionsnummer von Microsoft Excel zurück. String Schreibgeschützt.


Beispiel zur Version-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld mit der Versionsnummer von Microsoft Excel und dem Namen des Betriebssystems angezeigt.

MsgBox "Welcome to Microsoft Excel version " & _
    Application.Version & " running on " & _
    Application.OperatingSystem & "!"


VerticalAlignment-Eigenschaft

Gibt die vertikale Ausrichtung des angegebenen Objekts zurück. Zulässig ist eine der folgenden XlVAlign-Konstanten: xlVAlignBottom, xlVAlignCenter, xlVAlignDistributed, xlVAlignJustify oder xlVAlignTop. Long Schreib-Lese-Zugriff.

Anmerkungen

Einige dieser Konstanten stehen Ihnen, abhängig von der ausgewählten oder installierten Sprachunterstützung (z. B. Deutsch), möglicherweise nicht zur Verfügung.


Beispiel zur VerticalAlignment-Eigenschaft

In diesem Beispiel wird die Höhe der zweiten Zeile in Sheet1 auf das Doppelte der Standardhöhe gesetzt und danach die vertikale Ausrichtung zentriert.

Worksheets("Sheet1").Rows(2).RowHeight = _
    2 * Worksheets("Sheet1").StandardHeight
Worksheets("Sheet1").Rows(2).VerticalAlignment = xlVAlignCenter


VerticalFlip-Eigenschaft

True, wenn die angegebene Form um die vertikale Achse gekippt ist. Long Schreibgeschützt.


Beispiel zur VerticalFlip-Eigenschaft

In diesem Beispiel wird in myDocument der Originalzustand jeder Form wiederhergestellt, die horizontal oder vertikal gekippt wurde.

Set myDocument = Worksheets(1)
For Each s In myDocument.Shapes
    If s.HorizontalFlip Then s.Flip msoFlipHorizontal
    If s.VerticalFlip Then s.Flip msoFlipVertical
Next


 Vertices-Eigenschaft

Vertices-Eigenschaft

Gibt die Koordinaten der Scheitelpunkte der angegebenen Freihandzeichnung (und Steuerpunkte für Bézier-Kurven) als Reihe von Koordinatenpaaren zurück. Sie können die von dieser Eigenschaft zurückgegebene Matrix als Argument für die AddCurve- oder die AddPolyLine-Methode verwenden. Variant Schreibgeschützt.

Die folgende Tabelle verdeutlicht, wie die Vertices-Eigenschaft die Werte der Matrix vertArray() mit den Koordinaten der Scheitelpunkte eines Rechtecks verbindet.

vertArray-Element | Enthält
vertArray(1, 1) | Der horizontale Abstand zwischen dem ersten Scheitelpunkt und der linken Seite des Dokuments
vertArray(1, 2) | Der vertikale Abstand zwischen dem ersten Scheitelpunkt und der oberen Seite des Dokuments
vertArray(2, 1) | Der horizontale Abstand zwischen dem zweiten Scheitelpunkt und der linken Seite des Dokuments
vertArray(2, 2) | Der vertikale Abstand zwischen dem zweiten Scheitelpunkt und der oberen Seite des Dokuments
vertArray(3, 1) | Der horizontale Abstand zwischen dem dritten Scheitelpunkt und der linken Seite des Dokuments
vertArray(3, 2) | Der vertikale Abstand zwischen dem dritten Scheitelpunkt und der oberen Seite des Dokuments


Beispiel zur Vertices-Eigenschaft

In diesem Beispiel werden die Scheitelpunktkoordinaten der ersten Form in myDocument der Matrixvariablen vertArray() zugewiesen und die Koordinaten des ersten Scheitelpunktes angezeigt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1)
    vertArray = .Vertices
    x1 = vertArray(1, 1)
    y1 = vertArray(1, 2)
    MsgBox "First vertex coordinates: " & x1 & ", " & y1
End With

In diesem Beispiel wird in myDocument eine Kurve erstellt, die die gleiche geometrische Beschreibung besitzt wie die erste Form. Damit dieses Beispiel funktioniert, muss die erste Form 3n+1 Scheitelpunkte besitzen.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    .AddCurve .Item(1).Vertices
End With


View-Eigenschaft

Gibt die im Fenster dargestellte Ansicht zurück oder legt sie fest. Kann eine der beiden folgenden XlWindowView-Konstanten sein: xlNormalView oder xlPageBreakPreview. Long Schreib-Lese-Zugriff.


Beispiel zur View-Eigenschaft

In diesem Beispiel wird die Ansicht im aktiven Fenster auf Seitenumbruch-Vorschau geändert.

ActiveWindow.View = xlPageBreakPreview


Visible-Eigenschaft

True, wenn das Objekt sichtbar ist. Bei einem Diagramm oder Tabellenblatt kann diese Eigenschaft auf xlVeryHidden eingestellt werden. Dadurch wird das Objekt ausgeblendet und kann nur sichtbar gemacht werden, indem diese Eigenschaft auf True ersetzt wird. (Der Anwender selbst kann das Objekt nicht einblenden.) Boolean oder Long Lese-/Schreibzugriff.

Anmerkungen

Die Visible-Eigenschaft für ein PivotTable-Element ist True, wenn das Element zum betreffenden Zeitpunkt in der Tabelle angezeigt wird.

Wenn Sie der Visible-Eigenschaft für einen Namen den Wert False zuweisen, erscheint der Name nicht im Dialogfeld Namen definieren.


 VisibleFields-Eigenschaft

VisibleFields-Eigenschaft

Gibt ein Objekt zurück, das entweder ein einzelnes Feld in einem PivotTable-Bericht darstellt (ein PivotField-Objekt, Syntax 1) oder eine Auflistung aller eingeblendeten Felder (ein PivotFields-Objekt, Syntax 2). Eingeblendete Felder werden als Zeile, Spalte, Seite oder Datenfelder angezeigt. Schreibgeschützt.

Syntax 1

Ausdruck.VisibleFields(Index)

Syntax 2

Ausdruck.VisibleFields

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTable-Objekt zurückgibt.

Index Variant optional. Name oder Anzahl der zurückzugebenden Felder (zur Angabe mehrerer Felder kann auch eine Matrix verwendet werden).

Anmerkungen

Bei OLAP-Datenquellen gibt es keine ausgeblendeten Felder, und diese Eigenschaft gibt alle Felder im PivotTable-Cache zurück.


Beispiel zur VisibleFields-Eigenschaft

In diesem Beispiel werden die Namen der eingeblendeten Felder in eine Liste in einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.VisibleFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


 VisibleItems-Eigenschaft

VisibleItems-Eigenschaft

Gibt ein Objekt zurück, das entweder ein einzelnes PivotTable-Element darstellt (ein PivotItem-Objekt, Syntax 1) oder eine Auflistung aller eingeblendeten Elemente im angegebenen Feld (ein PivotItems-Objekt, Syntax 2). Schreibgeschützt.

Syntax 1

Ausdruck.VisibleItems(Index)

Syntax 2

Ausdruck.VisibleItems

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotField-Objekt zurückgibt.

Index Variant optional. Name oder Anzahl der zurückzugebenden Elemente (zur Angabe mehrerer Elemente kann auch eine Matrix verwendet werden).

Anmerkungen

Bei OLAP-Datenquellen ist diese Eigenschaft schreibgeschützt und gibt immer True zurück. Es gibt keine ausgeblendeten Elemente.


Beispiel zur VisibleItems-Eigenschaft

In diesem Beispiel werden die Namen aller eingeblendeten Elemente im Feld "Produkt" in eine Liste in einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtItem In pvtTable.PivotFields("Product").VisibleItems
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtItem.Name
Next


VisibleRange-Eigenschaft

Gibt ein Range-Objekt zurück, das den Bereich von Zellen darstellt, die im Fenster oder Ausschnitt sichtbar sind. Spalten oder Zeilen, die teilweise sichtbar sind, gehören diesem Bereich ebenfalls an. Schreibgeschützt.


Beispiel zur VisibleRange-Eigenschaft

In diesem Beispiel wird die Anzahl der sichtbaren Zellen in Sheet1 angezeigt.

Worksheets("Sheet1").Activate
MsgBox "There are " & Windows(1).VisibleRange.Cells.Count _
    & " cells visible"


VPageBreaks-Eigenschaft

Gibt eine VPageBreaks-Auflistung zurück, die die vertikalen Seitenwechsel eines Blatts darstellt. Schreibgeschützt.

Informationen über den Zugriff auf ein einzelnes Element einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.


Beispiel zur VPageBreaks-Eigenschaft

In diesem Beispiel wird die gesamte Anzahl der horizontalen Seitenwechsel des ganzen Bildschirms und des Druckbereichs angezeigt.

For Each pb in Worksheets(1).VPageBreaks
    If pb.Extent = xlPageBreakFull Then
        cFull = cFull + 1
    Else
        cPartial = cPartial + 1
    End If
Next
MsgBox cFull & " full-screen page breaks, " & cPartial & _
    " print-area page breaks"


Walls-Eigenschaft

Gibt ein Walls-Objekt zurück, das die Wände eines 3D-Diagramms darstellt. Schreibgeschützt.

Anmerkungen

Diese Eigenschaft lässt sich nicht auf 3D-Kreisdiagramme anwenden.


WallsAndGridlines2D-Eigenschaft

True, wenn die Gitternetzlinien in einem 3D-Diagramm zweidimensional gezeichnet werden. Boolean Schreib-Lese-Zugriff.


Beispiel zur WallsAndGridlines2D-Eigenschaft

In diesem Beispiel zeichnet Microsoft Excel 2D-Gitternetzlinien in Chart1.

Charts("Chart1").WallsAndGridlines2D = True


WebConsecutiveDelimitersAsOne-Eigenschaft

True, wenn aufeinander folgende Trennzeichen beim Importieren von Daten aus HTML <PRE>-Tags in einer Webseite in eine Abfragetabelle als einzelnes Zeichen behandelt werden, und die Datenanalyse in Spalten erfolgen soll. False, wenn aufeinander folgende Trennzeichen als mehrere Trennzeichen behandelt werden sollen. Der Standardwert ist True. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle auf xlWebQuery festgelegt ist, die Abfrage ein HTML-Dokument zurückgibt und die WebPreFormattedTextToColumns-Eigenschaft auf True festgelegt ist.


Beispiel zur WebConsecutiveDelimitersAsOne-Eigenschaft

In diesem Beispiel wird das Leerzeichen in der Abfragetabelle im ersten Tabellenblatt der ersten Arbeitsmappe als Trennzeichen festgelegt und anschließend die Abfragetabelle aktualisiert. Aufeinanderfolgende Leerzeichen werden als einzelnes Leerzeichen behandelt.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebConsecutiveDelimitersAsOne = True
    .Refresh
End With


WebDisableDateRecognition-Eigenschaft

True, wenn Daten, die Datumsangaben darstellen, beim Importieren einer Webseite in eine Abfragetabelle als Text analysiert werden. False, wenn die Datumserkennung verwendet wird. Der Standardwert ist False. Boolean Lese-/Schreibzugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle auf xlWebQuery festgelegt ist und die Abfrage ein HTML-Dokument zurückgibt.


Beispiel zur WebDisableDateRecognition-Eigenschaft

In diesem Beispiel wird die Datumserkennung deaktiviert, so dass die Daten der Webseite, die Kalenderangaben darstellen, als Text importiert werden. Anschließend wird in dem Beispiel die Abfragetabelle aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebDisableDateRecognition = True
    .Refresh
End With


WebFormatting-Eigenschaft

Gibt einen Wert, der gegebenenfalls den Umfang der Formatierung einer Webseite festlegt, die beim Importieren der Seite in eine Abfragetabelle übernommen wird, zurück oder legt diesen fest. Kann eine der folgenden xlWebFormatting-Konstanten sein: xlAll, xlNone oder xlRTF. Die Standardkonstante lautet xlNone. xlWebFormatting Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle auf xlWebQuery festgelegt ist und die Abfrage ein HTML-Dokument zurückgibt.


Beispiel zur WebFormatting-Eigenschaft

In diesem Beispiel wird eine neue Webabfragetabelle zum ersten Tabellenblatt der ersten Arbeitsmappe hinzugefügt, die gesamte Formatierung der Daten in der Webseite importiert und anschließend die Abfragetabelle aktualisiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebFormatting = xlAll
    .Refresh
End With


WebOptions-Eigenschaft

Gibt die WebOptions-Auflistung zurück, die die von Microsoft Excel verwendeten Attribute auf Arbeitsmappenebene enthält, wenn ein Dokument als Webseite gespeichert oder eine Webseite geöffnet wird. Lese-Zugriff.


Beispiel zur WebOptions-Eigenschaft

In diesem Beispiel wird angegeben, dass Cascading Style Sheets und die Dokument-Kodierung "Westlich" verwendet wird, wenn die Elemente in der ersten Arbeitsmappe in einer Webseite gespeichert werden.

Set objWO = Workbooks(1).WebOptions
objWO.RelyOnCSS = True
objWO.Encoding = msoEncodingWestern


WebPreFormattedTextToColumns-Eigenschaft

Gibt zurück oder legt fest, ob die Analyse der Daten in HTML <PRE>-Tags der Webseite beim Importieren der Seite in eine Abfragetabelle in Spalten erfolgen soll. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Diese Eigenschaft wird nur dann verwendet, wenn die QueryType-Eigenschaft der Abfragetabelle xlWebQuery lautet und die Abfrage ein HTML-Dokument zurückgibt.


Beispiel zur WebPreFormattedTextToColumns-Eigenschaft

In diesem Beispiel wird eine neue Webabfragetabelle zum ersten Blatt der aktiven Arbeitsmappe hinzugefügt. Beachten Sie, dass in dem Beispiel keine Analyse in Spalten für die Daten zwischen HTML <PRE>-Tags erfolgt.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebFormatting = xlNone
    .WebPreFormattedTextToColumns = False
    .Refresh
End With


WebSelectionType-Eigenschaft

Gibt einen Wert, der bestimmt, ob eine ganze Webseite, alle Tabellen in der Webseite oder lediglich bestimmte Tabellen in der Webseite in eine Abfragetabelle importiert werden, zurück oder legt diesen fest. Kann eine der folgenden xlWebSelectionType-Konstanten sein: xlAllTables, xlEntirePage oder xlSpecifiedTables. Die Standardkonstante ist xlAllTables. xlWebSelectionType Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle auf xlWebQuery festgelegt ist und die Abfrage ein HTML-Dokument zurückgibt.

Wenn der Wert dieser Eigenschaft xlSpecifiedTables lautet, können Sie mit Hilfe der WebTables-Eigenschaft die Tabellen angeben, die importiert werden sollen.


Beispiel zur WebSelectionType-Eigenschaft

In diesem Beispiel wird eine neue Webabfragetabelle zu dem ersten Tabellenblatt der ersten Arbeitsmappe hinzugefügt und anschließend die Daten aus der ersten und der zweiten Tabelle in der Webseite importiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebFormatting = xlNone
    .WebSelectionType = xlSpecifiedTables
    .WebTables = "1,2"
    .Refresh
End With


WebSingleBlockTextImport-Eigenschaft

True, wenn die Daten aus den HTML <PRE>-Tags in der angegebenen Webseite beim Importieren der Seite in eine Abfragetabelle gleichzeitig verarbeitet werden sollen. False, wenn die Daten blockweise in zusammenhängenden Zeilen importiert werden, damit Überschriften als solche erkannt werden. Der Standardwert ist False. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle auf xlWebQuery festgelegt ist und die Abfrage ein HTML-Dokument zurückgibt.


Beispiel zur WebSingleBlockTextImport-Eigenschaft

In diesem Beispiel wird eine neue Webabfragetabelle zum ersten Tabellenblatt der ersten Arbeitsmappe hinzugefügt und anschließend die Daten aller HTML <PRE>-Tags gleichzeitig importiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebSingleBlockTextImport = True
    .Refresh
End With


WebTables-Eigenschaft

Gibt eine durch Kommata getrennte Liste der Tabellennamen oder Tabellenindexnummern zurück oder legt diese fest, wenn eine Webseite in eine Abfragetabelle importiert wird. String Schreib-Lese-Zugriff.

Anmerkungen

Verwenden Sie diese Eigenschaft nur, wenn die QueryType-Eigenschaft der Abfragetabelle aus xlWebQuery festgelegt ist, die Abfrage ein HTML-Dokument zurückgibt und der Wert der WebSelectionType-Eigenschaft xlSpecifiedTables ist.


Beispiel zur WebTables-Eigenschaft

In diesem Beispiel wird eine neue Webabfragetabelle zu dem ersten Tabellenblatt der ersten Arbeitsmappe hinzugefügt und anschließend die Daten aus der ersten und der zweiten Tabelle in der Webseite importiert.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables _
    .Add(Connection := "URL;http://datasvr/98q1/19980331.htm", _
        Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .WebFormatting = xlNone
    .WebSelectionType = xlSpecifiedTables
    .WebTables = "1,2"
    .Refresh
End With


Weight-Eigenschaft

Gibt die Stärke des Rahmens zurück oder legt ihn fest. Zulässig ist eine der folgenden XlBorderWeight-Konstanten: xlHairline, xlThin, xlMedium oder xlThick. Long Schreib-Lese-Zugriff.


Beispiel zur Weight-Eigenschaft

In diesem Beispiel wird die Rahmenstärke für die erste Ellipse in Sheet1 festgelegt.

Worksheets("Sheet1").Ovals(1).Border.Weight = xlMedium


 Width-Eigenschaft

Width-Eigenschaft

Gibt die Breite eines Objekts in Punkt zurück oder legt sie fest. Long Schreib-Lese-Zugriff mit Ausnahmen entsprechend der folgenden Tabelle.

Anmerkungen

Die Bedeutung der Width-Eigenschaft hängt von dem angegebenen Objekt ab.

Objekt | Beschreibung
Application | Der Abstand zwischen dem linken und rechten Rand des Anwendungsfensters.
Axis, LegendEntry, LegendKey | Die Breite des Objekts. Schreibgeschützt.
Range | Die Breite des Bereichs.
Window | Die Breite des Fensters. Bestimmen Sie die maximale Größe des Fensters mit der UsableWidth-Eigenschaft. Wenn das Fenster maximiert oder minimiert ist, können Sie diese Eigenschaft nicht festlegen. Den Status des Fensters können Sie mit der WindowState-Eigenschaft abfragen.
ChartArea, ChartObject, Legend, OLEObject, PlotArea, Shape, ShapeRange, Window | Die Breite des Objekts. Lese-Zugriff bei ChartArea.

Wenn Sie das Fenster minimieren, ist Application.Width schreibgeschützt und gibt die Breite des Fenstersymbols zurück.


Beispiel zur Width-Eigenschaft

In diesem Beispiel wird die Breite des eingebetteten Diagramms festgelegt.

Worksheets("Sheet1").ChartObjects(1).Width = 360

In diesem Beispiel wird das aktive Fenster auf die maximal mögliche Größe erweitert (vorausgesetzt, das Fenster ist noch nicht maximiert).

With ActiveWindow
    .WindowState = xlNormal
    .Top = 1
    .Left = 1
    .Height = Application.UsableHeight
    .Width = Application.UsableWidth
End With


WindowNumber-Eigenschaft

Gibt die Fensternummer zurück. Ein Fenster mit dem Titel "Mappe1.xls:2" hat z. B. die Fensternummer 2. Die meisten Fenster haben die Fensternummer 1. Long Schreibgeschützt.

Anmerkungen

Die Fensternummer ist nicht identisch mit dem Fensterindex (dem Rückgabewert der Index-Eigenschaft), welcher die Position in der Windows-Auflistung bestimmt.


Beispiel zur WindowNumber-Eigenschaft

In diesem Beispiel wird vom aktiven Fenster ein neues Fenster erstellt. Danach wird die Fensternummer des neuen Fensters angezeigt.

ActiveWindow.NewWindow
MsgBox ActiveWindow.WindowNumber


Windows-Eigenschaft

Application-Objekt: Gibt eine Windows-Auflistung zurück, die alle Fenster in allen Arbeitsmappen darstellt. Schreibgeschützt.

Workbook-Objekt: Gibt eine Windows-Auflistung zurück, die alle Fenster in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne einen Objektkennzeichner hat die gleiche Funktion wie Application.Windows.

Diese Eigenschaft gibt eine Auflistung sichtbarer und ausgeblendeter Fenster zurück.


WindowsForPens-Eigenschaft

True, wenn der Computer unter Microsoft Windows für Pen-Computer läuft. Boolean Schreibgeschützt.


Beispiel zur WindowsForPens-Eigenschaft

In diesem Beispiel wird die Handschriftenerkennung auf Ziffern und Zeichensetzung eingeschränkt, falls Microsoft Windows für Pen Computing aktiv ist.

If Application.WindowsForPens Then
    Application.ConstrainNumeric = True
End If


WindowState-Eigenschaft

Gibt den Zustand des Fensters an oder legt ihn fest. Kann eine der folgenden XlWindowState-Konstanten sein: xlMaximized, xlMinimized oder xlNormal. Long Schreib-Lese-Zugriff.


Beispiel zur WindowState-Eigenschaft

In diesem Beispiel wird das Anwendungsfenster in Microsoft Excel maximiert.

Application.WindowState = xlMaximized

In diesem Beispiel wird das aktive Fenster auf die maximale Größe erweitert (vorausgesetzt, das Fenster ist nicht bereits maximiert).

With ActiveWindow
    .WindowState = xlNormal
    .Top = 1
    .Left = 1
    .Height = Application.UsableHeight
    .Width = Application.UsableWidth
End With


Workbooks-Eigenschaft

Gibt eine Workbooks-Auflistung zurück, die alle geöffneten Arbeitsmappen darstellt. Schreibgeschützt.

Informationen über die Zurückgabe eines einzelnen Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Die Verwendung dieser Eigenschaft ohne einen Objektkennzeichner hat die gleiche Funktion wie Application.Workbooks.

Die von der Workbooks-Eigenschaft zurückgegebene Auflistung schließt geöffnete Add-Ins aus, da es sich bei ihnen um eine Art ausgeblendete Arbeitsmappe handelt. Wenn Sie den Dateinamen kennen, kann ein einzelnes geöffnetes Add-In zurückgegeben werden. Workbooks("OSKAR.XLA") gibt beispielsweise das geöffnete Add-In "OSKAR.XLA" als ein Workbook-Objekt zurück.


Beispiel zur Workbooks-Eigenschaft

In diesem Beispiel wird die Arbeitsmappe BOOK1.XLS aktiviert.

Workbooks("BOOK1").Activate

In diesem Beispiel wird die Arbeitsmappe LARGE.XLS geöffnet.

Workbooks.Open filename:="LARGE.XLS"

Das folgende Beispiel schließt sämtliche Arbeitsmappen und speichert die darin vorgenommenen Änderungen, mit Ausnahme der Arbeitsmappe, aus der das Makro ausgeführt wird.

For Each w In Workbooks
    If w.Name <> ThisWorkbook.Name Then
        w.Close savechanges:=True
    End If
Next w


Worksheet-Eigenschaft

Gibt ein Worksheet-Objekt zurück, das das Tabellenblatt mit dem angegebenen Bereich darstellt. Schreibgeschützt.


WorksheetFunction-Eigenschaft

Gibt das WorksheetFunction-Objekt zurück. Schreibgeschützt.


Beispiel zur WorksheetFunction-Eigenschaft

In diesem Beispiel wird das Ergebnis der Tabellenfunktion Min angezeigt, die auf den Bereich A1:A10 angewendet wird.

Set myRange = Worksheets("Sheet1").Range("A1:C10")
answer = Application.WorksheetFunction.Min(myRange)
MsgBox answer


Worksheets-Eigenschaft

Application-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Tabellenblätter in der aktiven Arbeitsmappe darstellt. Schreibgeschützt.

Workbook-Objekt: Gibt eine Sheets-Auflistung zurück, die alle Tabellenblätter in der angegebenen Arbeitsmappe darstellt. Schreibgeschützt.

Informationen über das Zurückgeben jeweils eines Elements einer Auflistung finden Sie unter Zurückgeben eines Objekts aus einer Auflistung.

Anmerkungen

Wenn kein Objektkennzeichner verwendet wird, werden alle Tabellenblätter in der aktiven Arbeitsmappe zurückgegeben.

Diese Eigenschaft gibt keine Makroblätter zurück. Verwenden Sie die Excel4MacroSheets-Eigenschaft oder die Excel4IntlMacroSheets-Eigenschaft, um diese Blätter zurückzugeben.


Beispiel zur Worksheets-Eigenschaft

In diesem Beispiel wird der Wert von Zelle A1 in Sheet1 der aktiven Arbeitsmappe angezeigt.

MsgBox Worksheets("Sheet1").Range("A1").Value

In diesem Beispiel wird der Name aller Tabellenblätter in der aktiven Arbeitsmappe angezeigt.

For Each ws In Worksheets
    MsgBox ws.Name
Next ws

In diesem Beispiel wird der aktiven Arbeitsmappe ein neues Tabellenblatt hinzugefügt. Danach wird der Name des Tabellenblatts festgelegt.

Set newSheet = Worksheets.Add
newSheet.Name = "current Budget"


WrapText-Eigenschaft

True, wenn Microsoft Excel den Text im Objekt umbricht. Gibt Null zurück, wenn der angegebene Bereich einige Zellen enthält, in denen der Text umbrochen wird, und andere, in denen er nicht umbrochen wird. Variant Lese- und Schreibzugriff für das Range-Objekt, Boolean Lese- und Schreibzugriff für das Style-Objekt.

Anmerkungen

Falls erforderlich, passt Microsoft Excel die Zeilenhöhe im Bereich an die Texthöhe an.


Beispiel zur WrapText-Eigenschaft

In diesem Beispiel wird ein Text in Zelle B2 in Sheet1 eingetragen und so formatiert, dass er umbrochen wird.

Worksheets("Sheet1").Range("B2").Value = _
    "This text should wrap in a cell."
Worksheets("Sheet1").Range("B2").WrapText = True


WriteReserved-Eigenschaft

True, wenn die Arbeitsmappe ein Schreibschutz-Kennwort besitzt. Boolean Schreibgeschützt.

Anmerkungen

Verwenden Sie die SaveAs-Methode, um diese Eigenschaft zu setzen.


WriteReservedBy-Eigenschaft

Gibt den Namen des Benutzers zurück, der momentan Schreiberlaubnis für die Arbeitsmappe besitzt. String Nur Lese-Zugriff.


Beispiel zur WriteReservedBy-Eigenschaft

Falls die aktive Arbeitsmappe ein Schreibschutz-Kennwort besitzt, wird in diesem Beispiel der Name des Benutzers, der die Datei mit dem Schreibschutz gespeichert hat, zurückgegeben.

With ActiveWorkbook
    If .WriteReserved = True Then
        MsgBox "Please contact " & .WriteReservedBy & Chr(13) & _
            " if you need to insert data in this workbook."
    End If
End With


XValues-Eigenschaft

Gibt eine Matrix mit X-Werten für eine Diagrammreihe zurück oder legt sie fest. Der XValues-Eigenschaft kann ein Bereich in einem Tabellenblatt oder eine Matrix mit Werten zugewiesen werden. Eine Kombination beider Möglichkeiten ist jedoch nicht erlaubt. Variant Schreib-Lese-Zugriff.

Bei PivotChart-Berichten ist diese Eigenschaft schreibgeschützt.


Beispiel zur XValues-Eigenschaft

In diesem Beispiel wird der Bereich "B1:B5" in Sheet1 für die X-Werte der ersten Datenreihe in Chart1 verwendet.

Charts("Chart1").SeriesCollection(1).XValues = _
        Worksheets("Sheet1").Range("B1:B5")

In diesem Beispiel werden die Werte für die einzelnen Datenpunkte der ersten Datenreihe in Chart1 mit einer Matrix festgelegt.

Charts("Chart1").SeriesCollection(1).XValues = _
        Array(5.0, 6.3, 12.6, 28, 50)


Zoom-Eigenschaft

PageSetup-Objekt:

Gibt den Prozentsatz zurück, um den Microsoft Excel das Tabellenblatt beim Drucken vergrößert oder verkleinert (zwischen 10% und 400%), oder legt ihn fest. Gilt nur für Tabellenblätter. Variant Schreib-Lese-Zugriff.

Wenn diese Eigenschaft den Wert False aufweist, wird die Skalierung des Tabellenblatts mit den Eigenschaften FitToPagesWide und FitToPagesTall gesteuert.

Window-Objekt:

Gibt die Größe der Bildschirmanzeige für das Fenster als prozentualen Wert zurück oder legt diesen fest. Der Wert 100 bedeutet Anzeige in normaler Größe, 200 bedeutet Anzeige des Fensters in doppelter Größe usw. Variant Schreib-Lese-Zugriff.

Für diese Eigenschaft kann auch der Wert True festgelegt werden. Damit wird die Fenstergröße an die aktuelle Auswahl angepasst.

Anmerkungen

PageSetup-Objekt:

Das Seitenverhältnis des ursprünglichen Tabellenblatts wird bei der Skalierung in jedem Fall beibehalten.

Window-Objekt:

Diese Funktion wirkt sich nur auf das Tabellenblatt aus, das im Fenster derzeit aktiv ist. Wenn Sie diese Eigenschaft auf andere Tabellenblätter anwenden möchten, müssen Sie diese zuerst aktivieren.


Beispiel zur Zoom-Eigenschaft

In diesem Beispiel wird Sheet1 beim Drucken um 150% vergrößert.

Worksheets("Sheet1").PageSetup.Zoom = 150


ZOrder-Eigenschaft

Gibt die Position in der Z-Reihenfolge des Objekts zurück. Long Schreibgeschützt.

Anmerkungen

In jeder Auflistung von Objekten ist das Objekt ganz hinten in der Z-Reihenfolge Auflistung(1), und das Objekt ganz vorne in der Z-Reihenfolge ist Auflistung(Auflistung.Count). Wenn das aktive Blatt beispielsweise eingebettete Diagramme enthält, so ist ActiveSheet.ChartObjects(1) das Diagramm im Hintergrund. Das Diagramm im Vordergrund der Z-Reihenfolge ist ActiveSheet.ChartObjects(ActiveSheet.ChartObjects.Count).


ZOrderPosition-Eigenschaft

Gibt die Position der angegebenen Form in der Z-Reihenfolge zurück. Long Schreibgeschützt.

Diese Eigenschaft ist schreibgeschützt. Um die Position einer Form in der Z-Reihenfolge festzulegen, verwenden Sie die ZOrder-Methode.

Anmerkungen

Die Position einer Form in der Z-Reihenfolge entspricht ihrer Indexnummer in der Shapes-Auflistung. Befinden sich beispielsweise in myDocument vier Formen, gibt der Ausdruck myDocument.Shapes(1) die Form am Ende der Z-Reihenfolge und der Ausdruck myDocument.Shapes(4) die Form am Anfang der Z-Reihenfolge zurück.

Jede neue Form, die einem Dokument hinzugefügt wird, wird standardmäßig am Anfang der Z-Reihenfolge eingefügt.


Beispiel zur ZOrderPosition-Eigenschaft

In diesem Beispiel wird in myDocument eine Ellipse eingefügt und anschließend an der vorletzten Position in der Z-Reihenfolge positioniert, wenn in dem Dokument noch mindestens eine weitere Form existiert.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeOval, 100, 100, 100, 300)
    While .ZOrderPosition > 2
        .ZOrder msoSendBackward
    Wend
End With


Beispiel zur Clone-Methode

In diesem Beispiel wird ein benutzerdefiniertes Dialogfeld angezeigt, das die Datenlisten aus den Feldern KONTAKT und KUNDEN_ID der Datensatzgruppe Kunde der Datenbank Nwindex.mdb enthält.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database
Dim rs1 As Recordset, rs2 As Recordset
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs1 = db.OpenRecordset("SELECT * FROM Customer" _
    & " WHERE [REGION] = 'WA' ORDER BY [CUSTMR_ID];")
Set companySheet = Worksheets.Add
companySheet.Name = "COMPANY"
Set idSheet = Worksheets.Add
idSheet.Name = "CUSTMR_ID"
Set rs2 = rs1.Clone()
rs2.MoveFirst
Do Until rs1.EOF
    companySheet.Cells(rs1.AbsolutePosition + 1, 1).Value = _
        rs1.Fields("COMPANY").Value
    rs1.MoveNext
Loop
Do Until rs2.EOF
    idSheet.Cells(rs2.AbsolutePosition + 1, 1).Value = _
        rs2.Fields("CUSTMR_ID").Value
    rs2.MoveNext
Loop
rs1.Close
rs2.Close
db.Close


Beispiel zur Close-Methode

In diesem Beispiel wird der Datensatz Kunde der Datenbank Nwindex.mdb geöffnet. Die verfügbaren Sätze werden gezählt, und die Zahl in Sheet1 eingegeben.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer")
Set resultsSheet = Worksheets.Add
With resultsSheet.Cells(1, 1)
    .Value = "Records in " & rs.Name & " table:"
    .Font.Bold = True
    .EntireColumn.AutoFit
End With
rs.MoveLast
resultsSheet.Cells(1, 2).Value = rs.RecordCount
rs.Close
db.Close


Beispiel zu den Methoden CreateDatabase, CreateTableDef und Append

In diesem Beispiel wird die neue Datenbank Nwindex.mdb erstellt. Ihr werden zwei Tabellen aus dem Ordner C:\Programme\Gemeinsame Dateien\Microsoft Shared\MSquery zugeordnet. (In Windows NT liegen die beiden Tabellen in dem Ordner C:\Windows\Msapps\Msquery.)

Dim nWindEx As Database, customerTable As TableDef
Dim orderTable As TableDef, employeeTable As TableDef
Dim dataSource As String
dataSource = "dBASE IV;" & _
    "DATABASE=C:\Program Files\Microsoft Office\Office"
appPath = Application.DefaultFilePath
Set nWindEx = Workspaces(0) _
    .CreateDatabase(Application.DefaultFilePath _
    & "\NWINDEX.MDB", dbLangGeneral)
' add Customer table
Set customerTable = nWindEx.CreateTableDef("Customer")
customerTable.Connect = dataSource
customerTable.SourceTableName = "Customer"
nWindEx.TableDefs.Append customerTable
' add Orders table
Set orderTable = nWindEx.CreateTableDef("Orders")
orderTable.Connect = dataSource
orderTable.SourceTableName = "Orders"
nWindEx.TableDefs.Append orderTable
' add Employee table
Set employeeTable = nWindEx.CreateTableDef("Employee")
employeeTable.Connect = dataSource
employeeTable.SourceTableName = "Employee"
nWindEx.TableDefs.Append employeeTable
MsgBox "The database " & nWindEx.Name & " has been created."
nWindEx.Close


Beispiel zur Delete-Methode

In diesem Beispiel wird der Tabelle Produkt.dbf (eine dBASE IV-Tabelle, die sich im Ordner C:\Programme\Gemeinsame Dateien\Microsoft Shared\Msquery befindet) ein neuer Satz hinzugefügt. (In Windows NT liegt Produkt.dbf im Ordner C:\Windows\Msapps\Msquery.)

Dim db As Database, rs As Recordset
Set newRecord = Worksheets.Add.Rows(1)
With newRecord
    .Cells(1).Value = 10047
    .Cells(2).Value = "FOODG"
    .Cells(3).Value = 333
    .Cells(4).Value = #8/1/95#
    .Cells(5).Value = 752.91
End With
Set db = _
    OpenDatabase("C:\Program Files\Microsoft Office\Office", _
    False, False, "dBASE IV")
Set rs = db.OpenRecordset("ORDERS.DBF", dbOpenTable)
rs.AddNew
With newRecord
    rs("ORDER_ID") = .Cells(1).Value
    rs("CUSTMR_ID") = .Cells(2).Value
    rs("EMPLOY_ID") = .Cells(3).Value
    rs("ORDER_DATE") = .Cells(4).Value
    rs("ORDER_AMT") = .Cells(5).Value
End With
rs.Update
MsgBox "The new record has been created."
Stop
rs.Move 0, rs.LastModified
rs.Delete
MsgBox "The record you just created has been deleted."
rs.Close
db.Close


Beispiel zur GetRows-Methode

In diesem Beispiel werden aus der Datensatzgruppe Kunde der Datenbank Nwindex.mdb ausgewählte Sätze in Tabelle1 kopiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
Dim data As Variant
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset( _
    "SELECT CUSTMR_ID, REGION FROM Customer;")
data = rs.GetRows(6)
Set theSheet = Worksheets.Add
For r = 1 To UBound(data, 2) + 1
    For c = 1 To 2
        theSheet.Cells(r, c).Value = data(c - 1, r - 1)
    Next
Next
rs.Close
db.Close


Beispiel zur MoveNext-Methode

In diesem Beispiel werden Werte im Feld KON_TITEL der Sätze in der Datensatzgruppe Kunde der Datenbank Nwindex.mdb ersetzt und danach die Anzahl der durchgeführten Ersetzungen angezeigt.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset, sQLText As String
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
sQLText = "SELECT * FROM Employee WHERE " _
    & "EMP_TITLE = 'Sales Representative';"
Set rs = db.OpenRecordset(sQLText)
i = 0
Do Until rs.EOF
    With rs
        .Edit
        .Fields("EMP_TITLE").Value = "Account Executive"
        .Update
        .MoveNext
    End With
    i = i + 1
Loop
MsgBox i & " replacements were made."
rs.Close
db.Close


Beispiel zur Move-Methode

In diesem Beispiel wird der Benutzer aufgefordert, eine Datensatznummer auszuwählen. Der ausgewählte Satz wird danach aus der Datensatzgruppe Kunde der Datenbank Nwindex.mdb in Tabelle1 kopiert.

Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset( _
    "SELECT [CUSTMR_ID], [COMPANY], [REGION] " _
    & "FROM Customer")
rs.MoveLast
lst = rs.RecordCount
Sheets("Sheet1").Activate
aDistance = Application.InputBox("What record (1 - " & _
        lst & ") do you want to copy", Type:=1)
If aDistance = False Or aDistance > lst Then
    Exit Sub
End If
rs.MoveFirst
rs.Move aDistance - 1
For i = 0 To 2
    ActiveCell.Offset(, i).Value = rs.Fields(i).Value
Next
rs.Close
db.Close


Beispiel zur OpenDatabase-Methode

In diesem Beispiel wird die Datenbank Nwindex.mdb geöffnet, sofern sie sich im Standarddateipfad befindet.

Dim db As Database
ChDir Application.DefaultFilePath
a = Dir("NWINDEX.MDB")
If a = "" Then
    MsgBox "NWINDEX.MDB not found"
    Exit Sub
End If
Set db = Workspaces(0).OpenDatabase(a)
MsgBox "NWINDEX.MDB is now open"
' use database here
db.Close


Beispiel zur OpenRecordset-Methode

In diesem Beispiel wird ein benutzerdefiniertes Dialogfeld angezeigt, das eine Liste aller verfügbaren Datensatzgruppen der Datenbank Nwindex.mdb enthält. Eine neue Datensatzgruppe, die auf der vom Benutzer markierten Datensatzgruppe aufbaut, wird geöffnet und die Sätze in Tabelle1 kopiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs1 As Recordset
Set db = _
    Workspaces(0).OpenDatabase(Application. _
    DefaultFilePath & "\NWINDEX.MDB")
prmpt = "Enter the name of the recordset to import:" & vbCr
i = 0
Do Until i = db.TableDefs.Count
    ' omit protected system tables
    If InStr(LCase(db.TableDefs(i).Name), "msys") = 0 Then
        tbls = tbls & vbCr & db.TableDefs(i).Name
    End If
    i = i + 1
Loop
res = Application.InputBox(Prompt:=prmpt & tbls, _
    Title:="Import Recordset", Type:=2)
If res = False Then GoTo 500
On Error GoTo 490
Set rs1 = db.OpenRecordset(res)
Set reportsheet = Worksheets.Add
With reportsheet
    .Activate
    .Cells(1).CopyFromRecordset rs1
    .Cells(1).CurrentRegion.Columns.AutoFit
End With
rs1.Close
GoTo 500
490: MsgBox "Not a valid table name"
500: db.Close


Beispiel zur Seek-Methode

In diesem Beispiel wird Customer.dbf (eine dBASE IV-Tabelle, die im Ordner C:\Program Files\Microsoft Office\Office liegt) geöffnet. Anschließend wird ein Datensatz gesucht, und danach die Werte des Datensatzes in die Zellen B2:C2 in Sheet1 kopiert.

Dim db As Database, td As TableDef, idx As Index
Dim fld As Field, rs As Recordset
Set db = _
    OpenDatabase("C:\Program Files\Microsoft Office\Office", _
    False, False, "dBASE IV")
' create a temporary index
Set td = db.TableDefs("Customer")
Set idx = td.CreateIndex("CUSTMR_ID")
Set fld = idx.CreateField("CUSTMR_ID", dbText, 255)
idx.Fields.Append fld
td.Indexes.Append idx
' find the records
Set rs = db.OpenRecordset("CUSTOMER.DBF", dbOpenTable)
rs.Index = "CUSTMR_ID"
rs.Seek "=", "FOODG"
If rs.NoMatch Then
    MsgBox "Couldn't find any records"
Else
    With Sheets("Sheet1")
        .Cells(2, 2) = rs.Fields("COMPANY").Value
        .Cells(3, 2) = rs.Fields("CITY").Value
    End With
End If
rs.Close
' delete the temporary index
td.Indexes.Delete "CUSTMR_ID"
db.Close


Beispiel zur Update-Methode

In diesem Beispiel wird Produkt.dbf (eine dBASE IV-Tabelle, die im Ordner C:\Programme\Gemeinsame Dateien\Microsoft Shared\MSquery liegt) geöffnet. Ein Satz, in dem PRODUKT den Wert 1 hat wird gefunden und danach das Feld RUBRIK auf den Wert in Zelle B2 in Sheet1 gesetzt. (In Windows NT liegt Produkt.dbf im Ordner C:\Windows\Msapps\Msquery .)

Sheets("Sheet1").Activate
Set categoryCell = ActiveSheet.Cells(2, 2)
categoryCell.Value = "777"
Set db = OpenDatabase("C:\Program Files\Microsoft Office\Office", _
    False, False, "dBASE IV")
' create a temporary index
Set td = db.TableDefs("Employee")
Set idx = td.CreateIndex("EMPLOY_ID")
Set fld = idx.CreateField("EMPLOY_ID", dbInteger, 255)
idx.Fields.Append fld
td.Indexes.Append idx
' change the record
Set rs = db.OpenRecordset("EMPLOYEE.DBF", dbOpenTable)
With rs
    .Index = "EMPLOY_ID"
    .Seek "=", "555"
    .Edit
    .Fields("REPORTS_TO").Value = categoryCell.Value
    .Update
End With
MsgBox "The field has been updated with " & categoryCell.Value
rs.Close
' delete the temporary index
td.Indexes.Delete "EMPLOY_ID"
db.Close


Beispiel zur AbsolutePosition-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, eine Datensatznummer einzugeben. Diese Nummer wird verwendet, um zu einem Satz in der Datensatzgruppe Kunde zu gelangen. Danach werden die Werte von drei ausgewählten Feldern in Sheet1 kopiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer", dbOpenSnapshot)
rs.MoveLast
lst = rs.RecordCount
Sheets("Sheet1").Activate
recordnumber = Application _
    .InputBox(Prompt:="Record number (1 - " & _
    lst & ") to copy to Sheet1", _
    Title:="Record to copy", Type:=1)
If recordnumber = False Or recordnumber > rs.RecordCount Then
    Exit Sub
End If
rs.AbsolutePosition = recordnumber - 1
With ActiveCell
    .Value = rs.Fields("COMPANY").Value
    .Offset(, 1).Value = rs.Fields("CITY").Value
    .Offset(, 2).Value = rs.Fields("REGION").Value
End With
rs.Close
db.Close


Beispiel zu den Eigenschaften Bookmark und Bookmarkable

In diesem Beispiel wird der Benutzer aufgefordert, eine Abkürzung aus zwei Buchstaben für einen Staat einzugeben. Mit diesem Wert werden bis zu 101 übereinstimmende Sätze in der Datensatzgruppe Kunde der Datenbank Nwindex.mdb gesucht. Danach wird jeder Satz mit einer Textmarke versehen und der Wert des ersten und des dritten Feldes in Sheet1 kopiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim Found(100)
i = 0
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer")
Set theSheet = Sheets("Sheet1")
regionWanted = Application.InputBox( _
    "What state do you want data from?", _
    "Specify two letters (e.g. 'WA')", Type:=2)
If regionWanted = False Then    ' user cancelled InputBox
    Exit Sub
End If
criteria = "[REGION] = '" & regionWanted & "'"
rs.FindFirst criteria
If rs.NoMatch Or rs.Bookmarkable = False Then
    MsgBox "No records for this state"
    Exit Sub
Else
    Do Until rs.NoMatch = True
        i = i + 1
        Found(i) = rs.Bookmark
        rs.FindNext criteria
    Loop
End If
For n = 1 To i
    rs.Bookmark = Found(n)
    theSheet.Cells(n + 1, 1).Value = rs.Fields(0).Value
    theSheet.Cells(n + 1, 2).Value = rs.Fields(2).Value
Next
MsgBox "There are " & i & " records from this region"
rs.Close
db.Close


Beispiel zur Count-Eigenschaft

In diesem Beispiel wird die Anzahl der Datensatzgruppen der Datenbank Nwindex.mdb angezeigt und deren Namen danach in das Tabellenblatt1 eingetragen.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, i As Integer
Sheets("Sheet1").Activate
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
With Sheets("Sheet1")
    .Cells(1, 1).Value = "TableDef list for " & db.Name
    .Cells(1, 1).EntireColumn.AutoFit
    For i = 0 To db.TableDefs.Count - 1
        .Cells(i + 2, 1).Value = db.TableDefs(i).Name
    Next I
End With
MsgBox "There are " & db.TableDefs.Count & " TableDefs"
db.Close


Beispiel zu den Eigenschaften DateCreated und LastUpdated

In diesem Beispiel werden Datum und Zeit angezeigt, an denen die Datensatzgruppe Kunde der Datenbank Nwindex.mdb erstellt und zum letzten Mal aktualisiert wurde.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim creation As Variant, changed As Variant
Dim db As Database, td As TableDef
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set td = db.TableDefs("Customer")
creation = td.DateCreated
changed = td.LastUpdated
MsgBox "The " & td.Name & " table was created on " & creation _
    & " and updated on " & changed
db.Close


Beispiel zur Filter-Eigenschaft

In diesem Beispiel wird eine neue Datensatzgruppe erstellt, die Sätze aus der Datensatzgruppe Lieferant der Datenbank Nwindex.mdb enthält. Danach wird der Inhalt der Datensatzgruppe in Sheet1 kopiert. Die Sätze enthalten nur Daten über Lieferanten, die sich in Kanada befinden. Im Beispiel wird eine neue, sortierte Datensatzgruppe nach Microsoft Excel kopiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset, sortedSet As Recordset
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer", dbOpenDynaset)
rs.Filter = "[REGION] = 'NY'"
Set sortedSet = rs.OpenRecordset()
Sheets("Sheet1").Activate
ActiveCell.CopyFromRecordset sortedSet
sortedSet.Close
rs.Close
db.Close


Beispiel zur LockEdits-Eigenschaft

In diesem Beispiel wird die Datensatzgruppe Customer in der Datenbank Nwindex.mdb gesperrt, bevor der Wert in dem Feld CUSTMR_ID des ersten Datensatzes mit dem Wert in Zelle A1 im Tabellenblatt1 aktualisiert wird. Das Sperren der Datensatzgruppe stellt sicher, dass während der Aktualisierung kein Benutzer den Datensatz ändern kann.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
Sheets("Sheet1").Cells(1, 1).Value = "ALWSO"
databasePath = Application.DefaultFilePath & "\NWINDEX.MDB"
Set db = DBEngine.Workspaces(0).OpenDatabase(databasePath)
Set rs = db.OpenRecordset("Customer")
valueToAdd = Sheets("Sheet1").Cells(1, 1).Value
With rs
    .LockEdits = True
    .Edit
    .Fields("CUSTMR_ID").Value = valueToAdd
    .Update
    MsgBox "The new value of CUSTMR_ID is " & _
        .Fields("CUSTMR_ID").Value
End With
rs.Close
db.Close


Beispiel zur Name-Eigenschaft

In diesem Beispiel wird in der aktiven Zelle von Sheet1 der Name der ersten Datensatzgruppe der Datenbank Nwindex.mdb eingegeben.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, td As TableDef
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set td = db.TableDefs(0)
Sheets("Sheet1").Activate
ActiveCell.Value = td.Name
db.Close


Beispiel zur NoMatch-Eigenschaft

In diesem Beispiel werden einer Liste im ersten Tabellenblatt alle Kontaktnamen im Bundesstaat Washington hinzugefügt. Die Daten werden aus der Datensatzgruppe Kunde der Datenbank Nwindex.mdb herausgezogen.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
rw = 0
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("SELECT * FROM Customer")
criteria = "[REGION] = 'WA'"
Set wk = Worksheets.Add
rs.FindFirst criteria
Do Until rs.NoMatch
    rw = rw + 1
    wk.Cells(rw, 1).Value = rs.Fields("COMPANY").Value
    rs.FindNext criteria
Loop
rs.Close
db.Close


Beispiel zur PercentPosition-Eigenschaft

In diesem Beispiel werden Sätze in der Datensatzgruppe Kunde der Datenbank Nwindex.mdb ausgewählt und geändert. Danach wird die Datenbankgruppe in Sheet1 kopiert. Die Statusleiste zeigt den Prozentsatz der geänderten Sätze an.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset, sQLText As String
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
sQLText = "SELECT [ORDER_ID], [ORDER_AMT] FROM Orders;"
Set rs = db.OpenRecordset(sQLText, dbOpenDynaset)
rs.MoveFirst
Sheets("Sheet1").Activate
Do While Not rs.EOF
    rs.Edit
    cur = rs.Fields("ORDER_AMT").Value
    rs.Fields("ORDER_AMT").Value = cur + 8.33
    rs.Update
    Application.StatusBar = rs.PercentPosition & "% of the" _
        & " records have been replaced."
    rs.MoveNext
Loop
Application.StatusBar = "Done"
rs.MoveFirst
numberOfRows = ActiveCell.CopyFromRecordset(rs)
MsgBox numberOfRows & " Records have been changed"
rs.Close
db.Close


Beispiel zur RecordCount-Eigenschaft

In diesem Beispiel wird die Anzahl der Sätze der Datensatzgruppe Kunde in der Datenbank Nwindex.mdb angezeigt.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
Set db = Workspaces(0).OpenDatabase(Application.DefaultFilePath _
    & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer")
On Error GoTo errorHandler
rs.MoveLast
MsgBox "There are " & rs.RecordCount & " records in " _
    & rs.Name
rs.Close
db.Close
Exit Sub
errorHandler:
MsgBox "There are no records in " & rs.Name
rs.Close
db.Close


Beispiel zu den Eigenschaften Size und Type

In diesem Beispiel werden alle Felder des Typs Double aus Orddtail.dbf (eine dBASE IV-Tabelle, die im Ordner C:\Programme\Gemeinsame Dateien\Microsoft Shared\MSquery liegt) in Sheet1 kopiert. (In Windows NT befindet sich Orddtail.dbf im Ordner C:\Windows\Msapps\Msquery.)

Dim db As Database, recordsToCopy As Recordset, tDef As Recordset
Dim fieldsToStore(100), fileName As String
fileName = "ORDERS.DBF"
Set db = Workspaces(0) _
    .OpenDatabase("C:\Program Files\Microsoft Office\Office", _
    False, False, "dBASE IV")
Set tDef = db.OpenRecordset(fileName)
n = 0
Sheets("Sheet1").Activate
For Each fld In tDef.Fields
    If fld.Type = dbDouble Then
        fieldsToStore(n) = fld.Name
        n = n + 1
    End If
Next
If fieldsToStore(0) = "" Then
    MsgBox "There are no number fields in this table."
    Exit Sub
End If
For i = 0 To n - 1
    records = "SELECT " & "[" & fieldsToStore(i) & "]" _
        & " from " & db.Recordsets(fileName).Name & ";"
    Set recordsToCopy = db.OpenRecordset(records)
    With ActiveSheet.Cells(1, i + 1)
        .CopyFromRecordset recordsToCopy
        .ColumnWidth = recordsToCopy.Fields(0).Size
    End With
Next
recordsToCopy.Close
tDef.Close
db.Close


Beispiel zur Sort-Eigenschaft

In diesem Beispiel wird aus der Datensatzgruppe Lieferant der Datenbank Nwindex.mdb eine neue Datensatzgruppe erstellt und anschließend in Sheet1 kopiert. Die neue Datensatzgruppe wird auf der Grundlage des Feldes LAND in aufsteigender Reihenfolge sortiert.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset, sortedSet As Recordset
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer", dbOpenDynaset)
rs.Sort = "[REGION]"
Set sortedSet = rs.OpenRecordset()
Sheets("Sheet1").Activate
ActiveCell.CopyFromRecordset sortedSet
sortedSet.Close
rs.Close
db.Close


Beispiel zu den Eigenschaften Connect und SourceTableName

In diesem Beispiel wird die Tabelle Produkt.dbf (eine dBASE IV-Tabelle, die im Ordner C:\Programme\Gemeinsame Dateien\Microsoft Shared\MSquery liegt) der Datenbank Nwindex.mdb zugeordnet. (In Windows NT liegt Produkt.dbf im Ordner C:\Windows\Msapps\Msquery.)

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim nWindEx As Database, tDef As TableDef
Dim dataSource As String
dataSource = "dBASE IV;" & _
    "DATABASE=C:\Program Files\Microsoft Office\Office"
Set nWindEx = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set tDef = nWindEx.CreateTableDef("Orders2")
tDef.Connect = dataSource
tDef.SourceTableName = "Orders"
nWindEx.TableDefs.Append tDef
nWindEx.Close


Beispiel zur CreateQueryDef-Methode und zur SQL-Eigenschaft

In diesem Beispiel wird eine neue Abfrage erstellt, die auf der Datensatzgruppe Kunde der Datenbank Nwindex.mdb basiert. Die Abfrage wählt einen Snapshot aller Kunden im Bundesstaat Washington aus und kopiert ihn anschließend in Sheet1.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, qDef As QueryDef, rs As Recordset
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set qDef = db.CreateQueryDef("WA Region")
qDef.Sql = "SELECT * FROM Customer WHERE [Region] = 'WA';"
Set rs = db.OpenRecordset("WA Region")
numberOfRows = Sheets("Sheet1").Cells(1, 1).CopyFromRecordset(rs)
MsgBox numberOfRows & " records have been copied."
rs.Close
db.Close


Beispiel zur Updatable-Eigenschaft

In diesem Beispiel wird der Benutzer aufgefordert, eine Zelle auszuwählen, die einen Wert für das Feld KONTAKT in der Datensatzgruppe Kunde der Datenbank Nwindex.mdb enthält. Danach erfolgt eine Überprüfung, ob der Datensatz aktualisiert werden kann. Ist dies der Fall, wird der Datensatzgruppe unter Verwendung des Wertes in der ausgewählten Zelle ein neuer Satz hinzugefügt.

Um die Datenbank Nwindex.mdb zu erstellen, führen Sie das Microsoft Excel-Beispiel zur CreateDatabase-Methode aus.

Dim db As Database, rs As Recordset
Sheets("Sheet1").Activate
cellToCopy = Application.InputBox("What cell value do you want" _
    & " to update as company?", Type:=8)
If cellToCopy = False Then  ' user cancelled InputBox
    Exit Sub
End If
Set db = Workspaces(0).OpenDatabase(Application _
    .DefaultFilePath & "\NWINDEX.MDB")
Set rs = db.OpenRecordset("Customer")
With rs
    If .Updatable = True Then
        .AddNew
        rs("COMPANY") = cellToCopy
        .Update
        .MoveLast
        MsgBox "The new company is " & rs("COMPANY").Value
    Else
        MsgBox "The recordset cannot be modified."
    End If
End With
rs.Close
db.Close


RefEdit-Steuerelement

Dieses Steuerelement zeigt in einem Benutzerformular die Adresse eines Zellbereichs, der in einem oder mehreren Tabellenblättern eingegeben oder markiert wurde. Zum Markieren eines Bereichs klicken Sie auf die Schaltfläche im Steuerelement, um das Benutzerformular auszublenden, markieren Sie den Bereich, und klicken Sie dann erneut auf die Schaltfläche im Steuerelement, um das Benutzerformular einzublenden.

Ist das RefEdit-Steuerelement in einem Tabellenblatt eingebettet, können Sie den Inhalt des Steuerelements mit einer Zelle in einem beliebigen Tabellenblatt der betreffenden Arbeitsmappe verknüpfen.

Anmerkungen

Die Standardeigenschaft für ein RefEdit-Steuerelement ist Value.

Das Standardereignis für ein RefEdit-Steuerelement ist BeforeDragOver.

Sie können ein RefEdit-Steuerelement nicht in einem ungebundenen Benutzerformular verwenden. Mit der ShowModal-Eigenschaft können Sie ein Benutzerformular als gebunden festlegen.


Beispiel zum RefEdit-Steuerelement

In diesem Beispiel wird der Text des Tipps des Steuerelements für das RefEdit1-Steuerelement in UserForm1 festgelegt und anschließend das Benutzerformular angezeigt.

UserForm1.RefEdit1.ControlTipText = _
    "The selected range of data in the worksheet"
UserForm1.Show

Später klickt der Benutzer in UserForm1 auf CommandButton1. In diesem Beispiel für eine Ereignisbehandlungsprozedur wird die Adresse des markierten Tabellenblattbereichs angezeigt und anschließend das Programm beendet.

Private Sub CommandButton1_Click()
    MsgBox RefEdit1.Value
    End
End Sub


Add-Methode

Bei Microsoft Excel gibt das Argument linkSource einen Namen in der Arbeitsmappe an.


Beispiel zur Add-Methode

In diesem Beispiel wir die statische benutzerdefinierte Eigenschaft "Komplett" hinzugefügt.

With ActiveWorkbook.CustomDocumentProperties
    .Add name := "Complete", linkToContent := False, _
        type := msoPropertyTypeBoolean, value := False
End With

In diesem Beispiel wird eine mit dem Namen "Gesamtsumme" verknüpfte Eigenschaft hinzugefügt.

With ActiveWorkbook.CustomDocumentProperties
    .Add name := "Total Sales", linkToContent := True, _
        linkSource := "Grand_Total"
End With


Beispiel zur Delete-Methode

In diesem Beispiel wird die benutzerdefinierte Dokumenteigenschaft "Gesamtumsatz" aus der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.CustomDocumentProperties("Total Sales").Delete


Beispiel zur Item-Methode (Microsoft Excel)

In diesem Beispiel wird eine Liste erstellt, die die Namen aller integrierten Dokumenteigenschaften der aktiven Arbeitsmappe enthält.

Set wk = Worksheets(1)
Set builtinProps = ActiveWorkbook.BuiltinDocumentProperties
For i = 1 To builtinProps.Count
    wk.Cells(i, 1).Value = builtinProps.Item(i).Name
Next


DocumentProperties-Auflistungsobjekt

Jede Arbeitsmappe besitzt eine Auflistung integrierter Dokumenteigenschaften und eine Auflistung benutzerdefinierter Dokumenteigenschaften. Jede Auflistung wird durch ein DocumentProperties-Objekt dargestellt und enthält einzelne DocumentProperty-Objekte.

Verwenden Sie die BuiltinDocumentProperties-Eigenschaft, um die Auflistung der integrierten Dokumenteigenschaften zurückzugeben und die CustomDocumentProperties-Eigenschaft, um die Auflistung der benutzerdefinierten Dokumenteigenschaften zurückzugeben.

Im folgenden Beispiel werden die Namen der integrierten Dokumenteigenschaften als Liste im ersten Tabellenblatt dargestellt.

rw = 1
Worksheets(1).Activate
For Each p In ActiveWorkbook.BuiltinDocumentProperties
    Cells(rw, 1).Value = p.Name
    rw = rw + 1
Next


DocumentProperty-Objekt

Jede Arbeitsmappe besitzt eine Auflistung integrierter Dokumenteigenschaften und eine Auflistung benutzerdefinierter Dokumenteigenschaften. Jede Auflistung wird durch ein DocumentProperties-Objekt dargestellt und enthält einzelne DocumentProperty-Objekte.

Verwenden Sie die BuiltinDocumentProperties-Eigenschaft, um die Auflistung der integrierten Dokumenteigenschaften zurückzugeben und die CustomDocumentProperties-Eigenschaft, um die Auflistung der benutzerdefinierten Dokumenteigenschaften zurückzugeben. Mit der Item-Eigenschaft können Sie auf ein einzelnes Element der Auflistung zugreifen.

Im folgenden Beispiel wird der Wert der integrierten Dokumenteigenschaft "Titel" festgelegt.

ActiveWorkbook.BuiltinDocumentProperties.Item("Title") _
    .Value = "Year-End Sales Results"


HTMLProjectItem-Objekt

Stellt ein einzelnes Projektelement dar, das ein Projektelementzweig im Projekt-Explorer von Microsoft Skript-Editor ist. Das HTMLProjectItem-Objekt ist ein Mitglied der HTMLProjectItems-Auflistung.

Verwenden des HTMLProjectItem-Objekts

Verwenden Sie HTMLProjectItems(Index), wobei Index der Name oder die Indexnummer eines Projektelements ist, um ein einzelnes HTMLProjectItem-Objekt zurückzugeben. Verwenden Sie die Name-Eigenschaft, um den angezeigten Namen des Projektelements zurückzugeben. Im folgenden Beispiel wird der Name des ersten Projektelements in der HTMLProjectItems-Auflistung für die aktive Arbeitsmappe zurückgegeben.

MsgBox ("The first item is " & _
    ActiveWorkbook.HTMLProject _
    .HTMLProjectItems(1).Name)

Verwenden Sie die Open-Methode, um ein Projektelement in der Standardansicht zu öffnen, sowie die IsOpen-Eigenschaft, um festzustellen, ob das Projektelement in der Ansicht Entwurf, der Ansicht Quelle oder der Ansicht Vorschau angezeigt werden kann. Im folgenden Beispiel wird das Projektelement mit dem Namen Sheet1 (in der aktiven Arbeitsmappe) in der Standardansicht geöffnet und dann eine Meldung angezeigt, ob das Element ordnungsgemäß geöffnet wurde.

With ActiveWorkbook.HTMLProject.HTMLProjectItems("Sheet1")
    .Open
    If .IsOpen Then
        MsgBox ("Opened project item " & .Name)
    End If
End With

Verwenden Sie die SaveCopyAs-Methode, um das Projektelement unter einem neuen Dateinamen zu speichern. Im folgenden Beispiel wird eine Kopie von Sheet1 als "New" gespeichert.

With ActiveWorkbook.HTMLProject.HTMLProjectItems("Sheet1")
    .Open
    .SaveCopyAs("C:\New.xls")
End With

Unter der Annahme, dass die Textdatei C:\New.xls existiert, verwendet das folgende Beispiel die LoadFromFile-Methode, um den Text von Sheet1 auf den in der Datei enthaltenen Text festzulegen. In dem Beispiel wird die Text-Eigenschaft verwendet, um den neuen Text in einem Meldungsfeld anzuzeigen.

With ActiveWorkbook.HTMLProject.HTMLProjectItems("Sheet1")
    MsgBox .Text
    .LoadFromFile("C:\New.xls")
    MsgBox .Text
End With


HTMLProjectItems-Auflistungsobjekt

Eine Auflistung von HTMLProjectItem-Objekten, die die HTML-Projektelemente darstellen, die im HTMLProject-Objekt enthalten sind.

Verwenden der HTMLProjectItems-Auflistung

Verwenden Sie die HTMLProjectItems-Eigenschaft des HTMLProject-Objekts, um die HTMLProjectItems-Auflistung zurückzugeben. Verwenden Sie die Count-Eigenschaft der HTMLProjectItems-Auflistung, um die Anzahl der Projektelemente in dem HTML-Projekt der angegebenen Arbeitsmappe zurückzugeben. In dem folgenden Beispiel wird die Anzahl der Projektelemente in der HTMLProjectItems-Auflistung für die aktive Arbeitsmappe zurückgegeben.

Select Case _
    ActiveWorkbook.HTMLProject.HTMLProjectItems.Count
    Case 0
        strCount = "are no"
    Case 1
        strCount = "is 1"
    Case Else
        strCount = "are " & _
            ActiveWorkbook.HTMLProject _
                .HTMLProjectItems.Count
End Select

MsgBox ("There " & strCount & _
    " HTML project items in this workbook.")

Verwenden Sie die Item-Methode der HTMLProjectItems-Auflistung, um ein einzelnes Projektelement in Microsoft Skript-Editor zurückzugeben. Im folgenden Beispiel wird der Name des ersten Projektelements in der HTMLProjectItems-Auflistung für die aktive Arbeitsmappe zurückgegeben.

MsgBox ("The first item is " & _
    ActiveWorkbook.HTMLProject _
    .HTMLProjectItems.Item(1).Name)

Beim Speichern einer Arbeitsmappe, die ein einzelnes Tabellenblatt enthält, als Webseite, speichert Microsoft Excel den HTML-Code in einer einzelnen Datei. Der Projekt-Explorer im Skript-Editor zeigt lediglich ein Arbeitsmappen-Projektelement an, das sowohl die Arbeitsmappe als auch das Tabellenblatt darstellt. Enthält die Arbeitsmappe jedoch zwei oder mehr Tabellenblätter, speichert Excel den HTML-Code in mehreren Dateien. Der Projekt-Explorer zeigt mehrere Projektelemente an, die die Arbeitsmappe, das Registersteuerelement der Arbeitsmappe und jedes Tabellenblatt darstellen. Ein Arbeitsmappenelement bzw. Tabellenblattelement besitzt den gleichen Namen wie die entsprechende Arbeitsmappe bzw. das entsprechende Tabellenblatt. In dem folgenden Beispiel wird HTML-Code am Ende jedes Tabellenblatts eingefügt, jedoch nur dann, wenn die aktive Arbeitsmappe mehr als ein Tabellenblatt enthält.

With ActiveWorkbook.HTMLProject
    If .HTMLProjectItems.Count > 1 Then
        For Each objHTMLItem In .HTMLProjectItems
            ' Loop through the workbooks and worksheets
            ' in the project.
            With objHTMLItem
                If .Name <> ActiveWorkbook.Name And _
                    .Name <> "Tab" Then
                    ' Insert the HTML only if it's not
                    ' a workbook or a tab.
                    Call InsertHTML(.Text, strHTML)
                End If
            End With
        Next objHTMLItem
    End If
End With


HTMLProject-Objekt

Stellt einen Projektzweig auf oberster Ebene wie im Projekt-Explorer in Microsoft Skript-Editor dar.

Verwenden des HTMLProject-Objekts

Verwenden Sie die Open-Methode des HTMLProject-Objekts, um ein HTML-Projekt im HTML-Editor des Skript-Editors zu öffnen. Das Projekt wird in der Standardansicht für die aktive Arbeitsmappe gespeichert. In dem folgenden Beispiel wird ein HTML-Projekt in der aktiven Arbeitsmappe geöffnet.

ActiveWorkbook.HTMLProject.Open

Sie können die HTML-Ansicht des Projekts mit Hilfe der RefreshProject-Methode aktualisieren. Im folgenden Beispiel wird das Projekt in der aktiven Arbeitsmappe aktualisiert.

ActiveWorkbook.HTMLProject.RefreshProject


Context-Eigenschaft

Diese Eigenschaft gibt in Microsoft Excel eine leere Zeichenfolge zurück und wird anderweitig nicht unterstützt.


Beispiel zur Count-Eigenschaft

In diesem Beispiel wird die Anzahl der benutzerdefinierten Dokumenteigenschaften der aktiven Arbeitsmappe angezeigt.

MsgBox ActiveWorkbook.CustomDocumentProperties.Count


LinkSource-Eigenschaft

Bei Microsoft Excel ist die Quelle ein Name der Arbeitsmappe.


Beispiel zur LinkSource-Eigenschaft

In diesem Beispiel wird die benutzerdefinierte Dokumenteigenschaft "Gesamtumsatz" mit dem benannten Bereich "Umsatzzahlen" in der aktiven Arbeitsmappe verknüpft.

ActiveWorkbook.CustomDocumentProperties _
    .Item("TotalSales").LinkSource = "SalesNumbers"


Beispiel zur LinkToContent-Eigenschaft

In diesem Beispiel wird der verknüpfte Status jeder Dokumenteigenschaft der aktiven Arbeitsmappe als Liste im ersten Tabellenblatt angezeigt.

rw = 1
With Worksheets(1)
    For Each pro In ActiveWorkbook.CustomDocumentProperties
        .Cells(rw, 1) = pro.Name
        .Cells(rw, 2) = pro.LinkToContent
        If pro.LinkToContent Then
            .Cells(rw, 3) = pro.LinkSource
        End If
        rw = rw + 1
    Next
End With


Beispiel zur Name-Eigenschaft

In diesem Beispiel wird der Name der ersten benutzerdefinierten Dokumenteigenschaft in der aktiven Arbeitsmappe angezeigt.

MsgBox ActiveWorkbook.CustomDocumentProperties(1).Name


Beispiel zur Type-Eigenschaft

In diesem Beispiel wird der Typ der ersten benutzerdefinierten Dokumenteigenschaft in der aktiven Arbeitsmappe angezeigt.

MsgBox ActiveWorkbook.CustomDocumentProperties(1).Type


Beispiel zur Value-Eigenschaft

In diesem Beispiel wird der Wert der ersten benutzerdefinierten Dokumenteigenschaft in der aktiven Arbeitsmappe angezeigt.

MsgBox ActiveWorkbook.CustomDocumentProperties(1).Value


Sprachspezifische Informationen

Sprachspezifische Hilfethemen gelten nur, wenn das sprachspezifische Feature zur Verfügung steht. Informieren Sie sich, wie Sie in einer anderen Sprache arbeiten oder die Korrekturhilfen für eine andere Sprache installieren, oder fragen Sie Ihre Systemadministration nach weiteren Einzelheiten.


Beispiel zur Array-Funktion

In diesem Beispiel wird der Bereich "A1:C5" in Sheet1, Sheet5 und Sheet7 mit dem Inhalt des gleichen Bereichs in Sheet1 ausgefüllt.

x = Array("Sheet1", "Sheet5", "Sheet7")
Sheets(x).FillAcrossSheets _
    Worksheets("Sheet1").Range("A1:C5")

In diesem Beispiel werden Daten aus Sheet2 und Sheet3 mit Hilfe der SUM-Funktion auf Sheet1 konsolidiert.

Worksheets("Sheet1").Range("A1").Consolidate _
    sources:=Array("Sheet2!R1C1:R37C6", "Sheet3!R1C1:R37C6"), _
    Function:=xlSum

In diesem Beispiel wird eine Matrix von Zeichenfolgen als benutzerdefinierte Liste hinzugefügt.

Application.AddCustomList Array("cogs", "sprockets", _
    "widgets", "gizmos")

In diesem Beispiel werden Chart1, Chart3 und Chart5 ausgeblendet. Beachten Sie, dass die Charts-Eigenschaft in diesem Beispiel ein Sheets-Objekt anstatt eines Charts-Objekts zurückgibt.

Charts(Array("Chart1", "Chart3", "Chart5")).Visible = False

In diesem Beispiel werden die Eingaben im ersten Listenfeld als Dialog1 festgelegt.

DialogSheets("Dialog1").ListBoxes(1).List = _
    Array("cogs", "widgets", "sprockets", "gizmos")

In diesem Beispiel wird eine Gruppierung erstellt, die die Zeichnungsobjekte Eins, Drei und Fünf in Sheet1 enthält.

Set myGroup = Worksheets("Sheet1") _
    .DrawingObjects(Array(1, 3, 5)).Group
Worksheets("Sheet1").Activate
myGroup.Select


Beispiel zur Chr-Funktion

In diesem Beispiel wird das erste Listenfeld in Dialog1 mit den Buchstaben A bis Z ausgefüllt.

For i = 65 To 90
    DialogSheets("Dialog1").ListBoxes(1).AddItem Text:=Chr(i)
Next i

In diesem Beispiel wird mit Hilfe der Chr-Funktion ein Zeilenwechsel in einem Meldungsfeld erstellt.

msgText = "The current folder is:" & Chr(13) & CurDir()
MsgBox msgText


Beispiel zur CVErr-Funktion

In diesem Beispiel werden sieben Zellfehlerwerte in die Zellen A1:A7 des Sheet1 eingefügt.

myArray = Array(xlErrDiv0, xlErrNA, xlErrName, xlErrNull, _
    xlErrNum, xlErrRef, xlErrValue)
For i = 1 To 7
    Worksheets("Sheet1").Cells(i, 1).Value = CVErr(myArray(i - 1))
Next i

In diesem Beispiel wird eine Meldung angezeigt, falls die aktive Zelle in Sheet1 einen Zellfehlerwert enthält. Sie können dieses Beispiel als Grundgerüst für eine Fehlerroutine für Zellfehlerwerte verwenden.

Worksheets("Sheet1").Activate
If IsError(ActiveCell.Value) Then
    errval = ActiveCell.Value
    Select Case errval
        Case CVErr(xlErrDiv0)
            MsgBox "#DIV/0! error"
        Case CVErr(xlErrNA)
            MsgBox "#N/A error"
        Case CVErr(xlErrName)
            MsgBox "#NAME? error"
        Case CVErr(xlErrNull)
            MsgBox "#NULL! error"
        Case CVErr(xlErrNum)
            MsgBox "#NUM! error"
        Case CVErr(xlErrRef)
            MsgBox "#REF! error"
        Case CVErr(xlErrValue)
            MsgBox "#VALUE! error"
        Case Else
            MsgBox "This should never happen!!"
    End Select
End If


Format-Funktion

Beim Zuweisen eines Zeichenfolgewerts im Datumsformat zu einer Zelle geht Microsoft Excel davon aus, dass Zeichenfolgen im Format xx/yy/zz im US-englischen Datumsformat (mm/tt/jj) vorliegen. Excel zeigt den Wert in der Zelle im lokalen Datumsformat an. Denken Sie daran, dass die Format-Funktion das Datum als Zeichenfolge im lokalen Datumsformat zurückgibt.

Lautet das lokale Datumsformat tt/mm/jj, führt das Zuweisen eines General Date- oder Short Date-Zeichenfolgewerts, der von der Format-Funktion zurückgegeben wurde, zu einer Zelle zu einem von zwei möglichen Ergebnissen. Wenn der Tag im Monat kleiner ist als 13 und der Monat kleiner als 12, geht Excel davon aus, dass die Zeichenfolge im Format mm/tt/jj vorliegt; das Datum wird mit vertauschtem Monat und Tag angezeigt. Andernfalls zeigt Excel das Datum im richtigen lokalen Format an, da der Monat niemals größer als 12 sein kann.

Nehmen Sie beispielsweise an, dass die Ländereinstellung des Systems Englisch (Kanada) und das Datum der 11. August 1998 ist. Im folgenden Beispiel wird der Wert "8/11/98" (mm/tt/jj) der Zelle "A1" im aktiven Tabellenblatt zugewiesen, obwohl als Wert "11/08/98" (tt/mm/jj) erwartet wird.

ActiveSheet.Range("A1").Value = Format(Date, "Short Date")

In diesem Fall geht Excel davon aus, dass die Zeichenfolge "11/08/98", die von der Format-Funktion zurückgegeben wurde, im US-englischen Format vorliegt und konvertiert sie in das lokale Format, wobei der Zelle das Datum 8. November 1998 zugewiesen wird.


Beispiel zur IsEmpty-Funktion

In diesem Beispiel werden die Daten in der ersten Spalte von Sheet1 sortiert und anschließend alle Zeilen gelöscht, die doppelt vorhandene Daten enthalten.

Worksheets("Sheet1").Range("A1").Sort _
    key1:=Worksheets("Sheet1").Range("A1")
Set currentCell = Worksheets("Sheet1").Range("A1")
Do While Not IsEmpty(currentCell)
    Set nextCell = currentCell.Offset(1, 0)
    If nextCell.Value = currentCell.Value Then
        currentCell.EntireRow.Delete
    End If
    Set currentCell = nextCell
Loop


Beispiel zur IsNull-Funktion

In diesem Beispiel wird eine Liste registrierter Funktionen erstellt, von denen jede in eine eigene Zeile in Sheet1 gesetzt wird. Spalte A enthält den vollständigen Pfad und den Dateinamen der DDL oder der Code-Ressource, Spalte B den Funktionsnamen und Spalte C den Code für das Argument des Datentyps.

theArray = Application.RegisteredFunctions
If IsNull(theArray) Then
    MsgBox "No registered functions"
Else
    For i = LBound(theArray) To UBound(theArray)
        For j = 1 To 3
            Worksheets("Sheet1").Cells(i, j).Formula = _
                theArray(i, j)
        Next j
    Next i
End If


Beispiel zur LBound-Funktion

In diesem Beispiel werden die Elemente der ersten benutzerdefinierten Liste in die erste Spalte in Sheet1 geschrieben.

listArray = Application.GetCustomListContents(1)
For i = LBound(listArray, 1) To UBound(listArray, 1)
    Worksheets("sheet1").Cells(i, 1).Value = listArray(i)
Next i

In diesem Beispiel wird davon ausgegangen, dass Sie zur Erstellung eines PivotTable-Berichts in Sheet1 der aktiven Arbeitsmappe eine externe Datenquelle verwendet haben. Die Zeichenfolge der SQL-Verbindung und die Zeichenfolge der SQL-Abfrage werden in ein neues Tabellenblatt eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
sdArray = Worksheets("Sheet1").UsedRange.PivotTable.SourceData
For i = LBound(sdArray) To UBound(sdArray)
    newSheet.Cells(i, 1) = sdArray(i)
Next i


Beispiel zur RGB-Funktion

In diesem Beispiel wird die Farbe der Gitternetzlinien im aktiven Fenster der Book1.xls auf Rot festgelegt.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.GridlineColor = RGB(255,0,0)

In diesem Beispiel wird die Farbe der Teilstrichbeschriftungen auf der Größenachse in Chart1 auf Grün festgelegt.

Charts("Chart1").Axes(xlValue).TickLabels _
    .Font.Color = RGB(0, 255, 0)

In diesem Beispiel wird für den zweiten Punkt in der ersten Datenreihe des Chart1 die Hintergrundfarbe der Markierung auf Grün und die Vordergrundfarbe auf Rot festgelegt.

With Charts("Chart1").SeriesCollection(1).Points(2)
    .MarkerBackgroundColor = RGB(0,255,0)    ' green
    .MarkerForegroundColor = RGB(255,0,0)    ' red
End With

In diesem Beispiel wird für das Innenmuster des ersten Rechtecks in Sheet1 die Farbe Rot festgelegt.

With Worksheets("Sheet1").Rectangles(1).Interior
    .Pattern = xlGrid
    .PatternColor = RGB(255,0,0)
End With


Beispiel zur TypeName-Funktion

In diesem Beispiel wird der Visual Basic-Objekttyp der Markierung angezeigt. Sie können das Beispiel ausführen, wenn Zellen, eine einzelne Ellipse oder mehrere unterschiedliche Grafikobjekte markiert sind.

Worksheets("Sheet1").Activate
MsgBox "The selection object type is " & TypeName(Selection)


Beispiel zur UBound-Funktion

In diesem Beispiel werden die Elemente der ersten benutzerdefinierten Liste in die erste Spalte in Sheet1 geschrieben.

listArray = Application.GetCustomListContents(1)
For i = LBound(listArray, 1) To UBound(listArray, 1)
    Worksheets("sheet1").Cells(i, 1).Value = listArray(i)
Next i

In diesem Beispiel wird davon ausgegangen, dass Sie zur Erstellung eines PivotTable-Berichts in Sheet1 der aktiven Arbeitsmappe eine externe Datenquelle verwendet haben. Die Zeichenfolge der SQL-Verbindung und die Zeichenfolge der SQL-Abfrage werden in ein neues Tabellenblatt eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
sdArray = Worksheets("Sheet1").UsedRange.PivotTable.SourceData
For i = LBound(sdArray) To UBound(sdArray)
    newSheet.Cells(i, 1) = sdArray(i)
Next i


Auffangbare Fehler

Microsoft Excel verwendet, zusätzlich zu den von Visual Basic benutzten, folgende auffangbare Fehler. Sie können in Visual Basic auch mit Microsoft Excel-Zellfehlerwerten arbeiten. Weitere Informationen finden Sie unter Zellfehlerwerte.

Code Meldung
1000 Das '[Objektname]'-Objekt hat nicht die '[Eigenschaftsname]'-Eigenschaft.

Die Eigenschaft existiert für dieses Objekt nicht. Weitere Informationen finden Sie in der Hilfe unter dem Namen des Objekts.
1001 Das '[Objektname]'-Objekt hat nicht die '[Methodenname]'-Methode.

Die Methode existiert für dieses Objekt nicht. Weitere Informationen finden Sie in der Hilfe unter dem Namen des Objekts.
1002 Das erforderliche '[Argumentname]'-Argument fehlt.

Die Methode erfordert ein Argument, das nicht angegeben wurde. Fügen Sie dem Code das Argument hinzu. Um eine Liste der erforderlichen Argumente anzeigen zu lassen, suchen Sie in der Hilfe nach dem Namen der Methode.
1003 Ungültige Anzahl von Argumenten.

In der Methode wurde eine falsche Anzahl von Argumenten angegeben. Dies ist beispielsweise der Fall, wenn Sie Argumente durch ihre Position anstatt durch ihren Namen angegeben haben oder zu viele Argumente angegeben haben. Um die für die Methode gültigen Argumente anzeigen zu lassen, suchen Sie in der Hilfe nach dem Namen der Methode.
1004 Die '[Methodenname]'-Methode des '[Objektname]'-Objekts ist fehlerhaft.

Die Methode kann nicht auf das Objekt angewendet werden. Mögliche Gründe dafür können folgende sein:

  • Ein Argument enthält einen ungültigen Wert. Eine häufige Ursache dieses Problems ist der Zugriffsversuch auf ein Objekt, das nicht existiert (wenn Sie z.B. versuchen, Workbooks(5) zu verwenden, obwohl nur drei Arbeitsmappen geöffnet sind).

  • Die Methode kann im angewendeten Zusammenhang nicht verwendet werden. Bei einigen Methoden des Range-Objekts ist es beispielsweise erforderlich, dass der Bereich Daten enthält. Ist dies nicht der Fall, schlägt die Methode fehl.

  • Ein externer Fehler ist aufgetreten, wie z.B. ein Fehler beim Lese- oder Schreib-Zugriff auf eine Datei.

Weitere Informationen zu der Methode finden Sie in der Hilfe unter dem Namen der Methode.
1005 Die '[Eigenschaftsname]'-Eigenschaft des '[Objektname]'-Objekts kann nicht festgelegt werden.

Die Eigenschaft kann nicht geändert werden. Mögliche Gründe dafür können folgende sein:

  • Der in der Eigenschaft verwendete Wert ist ungültig (z. B. wenn Sie den Wert einer Eigenschaft als Zeichenfolge angeben, diese aber einen booleschen Wert erfordert).

  • Die Eigenschaft verfügt nur über Lese-Zugriff.

Weitere Informationen zu der Eigenschaft finden Sie in der Hilfe unter dem Namen der Eigenschaft.
1006 Die '[Eigenschaftsname]'-Eigenschaft des '[Objektname]'-Objekts kann nicht zugeordnet werden.

Die Eigenschaft kann nicht gelesen werden. Ein möglicher Grund dafür ist, dass die Eigenschaft im angewendeten Kontext nicht verwendet werden kann. Der Code ActiveChart.Legend.Font.Color = RGB(255, 0, 0) verursacht beispielsweise einen Fehler, wenn das aktive Diagramm keine Legende enthält.

Weitere Informationen zu der Eigenschaft finden Sie in der Hilfe unter dem Namen der Eigenschaft.


Beispiel zum Is-Operator

In diesem Beispiel wird die Schnittmenge zweier benannter Bereiche ("rg1" und "rg2") in Sheet1 markiert. Existiert für die Bereiche keine Schnittmenge, wird eine Meldung angezeigt.

Worksheets("Sheet1").Activate
Set isect = Application.Intersect(Range("rg1"), Range("rg2"))
If isect Is Nothing Then
    MsgBox "Ranges do not intersect"
Else
    isect.Select
End If

In diesem Beispiel wird in Spalte B von Sheet1 nach dem Vorkommen des Wortes "Phoenix" gesucht und anschließend die Zelle angezeigt, in der dieses Wort enthalten ist. Wird das Wort nicht gefunden, wird eine Meldung angezeigt.

Set foundCell = Worksheets("Sheet1").Columns("B").Find("Phoenix")
If foundCell Is Nothing Then
    MsgBox "The word was not found"
Else
    MsgBox "The word was found in cell " & foundCell.Address
End If


Beispiel zum Like-Operator

In diesem Beispiel wird jeder definierte Name gelöscht, der "temp" enthält. Die Anweisung Option Compare Text muss oben bei jedem Modul stehen, das dieses Beispiel enthält.

For Each nm In ActiveWorkbook.Names
    If nm.Name Like "*temp*" Then
        nm.Delete
    End If
Next nm

In diesem Beispiel wird jeder Form in Sheet1, die das Wort "Line" in seinem Namen hat, eine Pfeilspitze hinzugefügt.

For Each d In Worksheets("Sheet1").DrawingObjects
    If d.Name Like "*Line*" Then
        d.ArrowHeadLength = xlLong
        d.ArrowHeadStyle = xlOpen
        d.ArrowHeadWidth = xlNarrow
    End If
Next


Beispiel zum Mod-Operator

In diesem Beispiel wird die Spaltenbreite jeder zweiten Spalte in Sheet1 auf 4 Punkt gesetzt.

For Each col In Worksheets("Sheet1").Columns
    If col.Column Mod 2 = 0 Then
        col.ColumnWidth = 4
    End If
Next col

In diesem Beispiel wird die Zeilenhöhe jeder zweiten Zeile in Sheet1 auf 4 Punkt gesetzt.

For Each rw In Worksheets("Sheet1").Rows
    If rw.Row Mod 2 = 0 Then
        rw.RowHeight = 4
    End If
Next rw

In diesem Beispiel wird jedes zweite Element im ersten Listenfeld in Sheet1 markiert.

Dim items() As Boolean
Set lbox = Worksheets("Sheet1").ListBoxes(1)
ReDim items(1 To lbox.ListCount)
For i = 1 To lbox.ListCount
    If i Mod 2 = 1 Then
        items(i) = True
    Else
        items(i) = False
    End If
Next
lbox.MultiSelect = xlExtended
lbox.Selected = items


ShowModal-Eigenschaft

Da Sie das RefEdit-Steuerelement nicht in einem ungebundenen Benutzerformular verwenden können, sollten Sie ein vorhandenes, gebundenes Benutzerformular nicht als ungebunden festlegen, falls es ein RefEdit-Steuerelement enthält.


Beispiel zur Do...Loop-Anweisung

In diesem Beispiel werden die Daten in der ersten Spalte des Sheet1 sortiert und anschließend alle Zeilen gelöscht, die doppelt vorhandene Daten enthalten.

Worksheets("Sheet1").Range("A1").Sort _
    key1:=Worksheets("Sheet1").Range("A1")
Set currentCell = Worksheets("Sheet1").Range("A1")
Do While Not IsEmpty(currentCell)
    Set nextCell = currentCell.Offset(1, 0)
    If nextCell.Value = currentCell.Value Then
        currentCell.EntireRow.Delete
    End If
    Set currentCell = nextCell
Loop


Beispiel zur For Each...Next-Anweisung

In diesem Beispiel wird über die Zellen A1:D10 in Sheet1 eine Schleife durchlaufen. Wenn eine der Zellen einen Wert unter 0,001 besitzt, ersetzt der Code den Wert mit 0 (Null).

For Each c in Worksheets("Sheet1").Range("A1:D10")
    If c.Value < .001 Then
        c.Value = 0
    End If
Next c

In diesem Beispiel wird im Bereich "Testbereich" eine Schleife durchlaufen und anschließend die Anzahl der leeren Zellen des Bereichs angezeigt.

numBlanks = 0
For Each c In Range("testRange")
    If c.Value = "" Then
        numBlanks = numBlanks + 1
    End If
Next c
MsgBox "There are " & numBlanks & " empty cells in this range."

In diesem Beispiel werden alle Arbeitsmappen außer derjenigen, in der das Beispiel ausgeführt wird, geschlossen und Änderungen gespeichert.

For Each w In Workbooks
    If w.Name <> ThisWorkbook.Name Then
        w.Close savechanges:=True
    End If
Next w

In diesem Beispiel werden alle Tabellenblätter in der aktiven Arbeitsmappe gelöscht, ohne das Bestätigungsdialogfeld anzuzeigen. Es muss noch mindestens eine weitere sichtbare Tabelle in der Arbeitsmappe vorhanden sein.

Application.DisplayAlerts = False
For Each w In Worksheets
    w.Delete
Next w
Application.DisplayAlerts = True

In diesem Beispiel wird ein neues Tabellenblatt erstellt, in das anschließend eine Liste aller Namen in der aktiven Arbeitsmappe, einschließlich ihrer Formeln in der Schreibweise der A1-Formatvorlage und in der Sprache des Benutzers, eingefügt wird.

Set newSheet = ActiveWorkbook.Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.NameLocal
    newSheet.Cells(i, 2).Value = "'" & nm.RefersToLocal
    i = i + 1
Next nm


Beispiel zur For...Next-Anweisung

In diesem Beispiel wird die Anzahl der markierten Spalten in Sheet1 angezeigt. Falls mehr als ein Bereich markiert ist, werden die Bereiche nacheinander in einer Schleife bearbeitet.

Worksheets("Sheet1").Activate
areaCount = Selection.Areas.Count
If areaCount <= 1 Then
    MsgBox "The selection contains " & _
        Selection.Columns.Count & " columns."
Else
    For i = 1 To areaCount
        MsgBox "Area " & i & " of the selection contains " & _
            Selection.Areas(i).Columns.Count & " columns."
    Next i
End If

In diesem Beispiel wird ein neues Tabellenblatt erstellt. In die erste Spalte dieses Tabellenblatts wird anschließend eine Liste der Tabellenblattnamen der aktiven Arbeitsmappe eingefügt.

Set newSheet = Sheets.Add(Type:=xlWorksheet)
For i = 1 To Sheets.Count
    newSheet.Cells(i, 1).Value = Sheets(i).Name
Next i

In diesem Beispiel wird jedes zweite Element im ersten Listenfeld von Sheet1 markiert.

Dim items() As Boolean
Set lbox = Worksheets("Sheet1").ListBoxes(1)
ReDim items(1 To lbox.ListCount)
For i = 1 To lbox.ListCount
    If i Mod 2 = 1 Then
        items(i) = True
    Else
        items(i) = False
    End If
Next
lbox.MultiSelect = xlExtended
lbox.Selected = items


Beispiel zur If...Then...Else-Anweisung

Dieses Beispiel durchläuft die Zellen A1:D10 in Sheet1 in einer Schleife. Wenn eine der Zellen einen Wert unter 0,001 besitzt, ersetzt der Code den Wert mit 0 (Null).

For Each c in Worksheets("Sheet1").Range("A1:D10")
    If c.Value < .001 Then
        c.Value = 0
    End If
Next c

In diesem Beispiel wird im Bereich "Testbereich" eine Schleife durchlaufen und anschließend die Anzahl der leeren Zellen des Bereichs angezeigt.

numBlanks = 0
For Each c In Range("testRange")
    If c.Value = "" Then
        numBlanks = numBlanks + 1
    End If
Next c
MsgBox "There are " & numBlanks & " empty cells in this range."

In diesem Beispiel wird als Standardschriftart Geneva (bei Apple Macintosh) oder Arial (in Windows) festgelegt.

If Application.OperatingSystem Like "*Macintosh*" Then
    Application.StandardFont = "Geneva"
Else
    Application.StandardFont = "Arial"
End If


Beispiel zur Select Case-Anweisung

In diesem Beispiel wird der Name des auf dem Computer installierten Mail Systems angezeigt.

Select Case Application.MailSystem
    Case Is = xlMAPI
        MsgBox "Mail system is Microsoft Mail"
    Case Is = xlPowerTalk
        MsgBox "Mail system is PowerTalk"
    Case Is = xlNoMailSystem
        MsgBox "No mail system installed"
End Select

In diesem Beispiel wird ein Meldungsfeld angezeigt, das die Position der aktiven Zelle im PivotTable-Bericht angibt.

Worksheets("Sheet1").Activate
Select Case ActiveCell.LocationInTable
Case Is = xlRowHeader
    MsgBox "Active cell is part of a row header"
Case Is = xlColumnHeader
    MsgBox "Active cell is part of a column header"
Case Is = xlPageHeader
    MsgBox "Active cell is part of a page header"
Case Is = xlDataHeader
    MsgBox "Active cell is part of a data header"
Case Is = xlRowItem
    MsgBox "Active cell is part of a row item"
Case Is = xlColumnItem
    MsgBox "Active cell is part of a column item"
Case Is = xlPageItem
    MsgBox "Active cell is part of a page item"
Case Is = xlDataItem
    MsgBox "Active cell is part of a data item"
Case Is = xlTableBody
    MsgBox "Active cell is part of the table body"
End Select

In diesem Beispiel wird eine Meldung angezeigt, falls die aktive Zelle in Sheet1 einen Zellfehlerwert enthält. Sie können dieses Beispiel als Grundgerüst für eine Fehlerroutine für Zellfehlerwerte verwenden.

Worksheets("Sheet1").Activate
If IsError(ActiveCell.Value) Then
    errval = ActiveCell.Value
    Select Case errval
        Case CVErr(xlErrDiv0)
            MsgBox "#DIV/0! error"
        Case CVErr(xlErrNA)
            MsgBox "#N/A error"
        Case CVErr(xlErrName)
            MsgBox "#NAME? error"
        Case CVErr(xlErrNull)
            MsgBox "#NULL! error"
        Case CVErr(xlErrNum)
            MsgBox "#NUM! error"
        Case CVErr(xlErrRef)
            MsgBox "#REF! error"
        Case CVErr(xlErrValue)
            MsgBox "#VALUE! error"
        Case Else
            MsgBox "This should never happen!!"
    End Select
End If


Beispiel zur Set-Anweisung

In diesem Beispiel wird der aktiven Arbeitsmappe ein neues Tabellenblatt hinzugefügt und anschließend der Name des Tabellenblattes festgelegt.

Set newSheet = Worksheets.Add
newSheet.Name = "1995 Budget"

In diesem Beispiel wird ein neues Tabellenblatt erstellt, in das anschließend eine Liste aller Namen in der aktiven Arbeitsmappe, einschließlich ihrer Formeln in der A1-Schreibweise und in der Sprache des Benutzers, eingefügt wird.

Set newSheet = ActiveWorkbook.Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.NameLocal
    newSheet.Cells(i, 2).Value = "'" & nm.RefersToLocal
    i = i + 1
Next


Beispiel zur Static-Anweisung

In diesem Beispiel wird mit Hilfe der Tabellenfunktion Pmt die Rückzahlung eines Hypothekendarlehens berechnet. Beachten Sie, dass dabei die InputBox-Methode anstatt der InputBox-Funktion verwendet wird, damit die Methode eine Typenüberprüfung durchführen kann. Auf Grund der Static-Anweisungen behält Visual Basic die Werte der drei Variablen bei; sie werden als Standardwerte angezeigt, wenn Sie das Beispiel erneut ausführen.

Static loanAmt
Static loanInt
Static loanTerm
loanAmt = Application.InputBox _
    (Prompt:="Loan amount (100,000 for example)", _
        Default:=loanAmt, Type:=1)
loanInt = Application.InputBox _
    (Prompt:="Annual interest rate (8.75 for example)", _
        Default:=loanInt, Type:=1)
loanTerm = Application.InputBox _
    (Prompt:="Term in years (30 for example)", _
        Default:=loanTerm, Type:=1)
payment = Application.Pmt(loanInt / 1200, loanTerm * 12, loanAmt)
MsgBox "Monthly payment is " & Format(payment, "Currency")


Beispiel zur With-Anweisung

In diesem Beispiel wird in den Zellen A1:K11 in Sheet1 eine formatierte Multiplikationstabelle erstellt.

Set dataTableRange = Worksheets("Sheet1").Range("A1:K11")
Set rowInputCell = Worksheets("Sheet1").Range("A12")
Set columnInputCell = Worksheets("Sheet1").Range("A13")

Worksheets("Sheet1").Range("A1").Formula = "=A12*A13"
For i = 2 To 11
    Worksheets("Sheet1").Cells(i, 1) = i - 1
    Worksheets("Sheet1").Cells(1, i) = i - 1
Next i
dataTableRange.Table rowInputCell, columnInputCell
With Worksheets("Sheet1").Range("A1").CurrentRegion
    .Rows(1).Font.Bold = True
    .Columns(1).Font.Bold = True
    .Columns.AutoFit
End With


Beispiel zum Select-Ereignis

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn der Benutzer den Diagrammtitel markiert.

Private Sub Chart_Select(ByVal ElementID As Long, _
        ByVal Arg1 As Long, ByVal Arg2 As Long)
    If ElementId = xlChartTitle Then
        MsgBox "please don't change the chart title"
    End If
End Sub


Beispiel zur SolverFinish-Funktion

In diesem Beispiel wird das zuvor berechnete und in Sheet1 gespeicherte Solvermodell geladen, das Modell erneut ausgewertet und in einem neuen Tabellenblatt ein Antwortbericht erstellt.

Worksheets("Sheet1").Activate
SolverLoad loadArea:=Range("A33:A38")
SolverSolve userFinish:=True
SolverFinish keepFinal:=1, reportArray:=Array(1)


Beispiel zur SolverOK-Funktion

In diesem Beispiel werden die Solver-Funktionen verwendet, um den Gesamtgewinn in einem Geschäftsproblem zu maximieren. Mit der Funktion SolverOK und durch die Argumentwerte SetCell, MaxMinVal und ByChange wird die Aufgabe definiert.

Worksheets("Sheet1").Activate
SolverReset
SolverOptions precision:=0.001
SolverOK setCell:=Range("TotalProfit"), _
    maxMinVal:=1, _
    byChange:=Range("C4:E6")
SolverAdd cellRef:=Range("F4:F6"), _
    relation:=1, _
    formulaText:=100
SolverAdd cellRef:=Range("C4:E6"), _
    relation:=3, _
    formulaText:=0
SolverAdd cellRef:=Range("C4:E6"), _
    relation:=4
SolverSolve userFinish:=False
SolverSave saveArea:=Range("A33")


Beispiel zur SQLRetrieve-Funktion

In diesem Beispiel wird eine Abfrage der Northwind-Datenbank ausgeführt. Die in Sheet1 angezeigte Ergebnismenge ist eine Liste sämtlicher Produkte, für die eine Bestellung aufgegeben wurde.

databaseName = "NorthWind"
queryString = _
    "SELECT * FROM product.dbf WHERE (product.ON_ORDER<>0)"
chan = SQLOpen("DSN=" & databaseName)
SQLExecQuery chan, queryString
Set output = Worksheets("Sheet1").Range("A1")
SQLRetrieve chan, output, , , True
SQLClose chan


Hinzufügen von Steuerelementen zu einem Dokument

Um Steuerelemente einem Dokument hinzuzufügen, zeigen Sie die Steuerelement-Toolbox an, klicken Sie auf das hinzuzufügende Steuerelement und anschließend auf das Dokument. Passen Sie Größe und Form des Steuerelements unter Verwendung eines seiner Ziehpunkte nach Ihren Wünschen an.

Anmerkung Durch das Zurückziehen eines Steuerelements (oder mehrerer "gruppierter" Steuerelemente) vom Formular in die Steuerelement-Toolbox wird eine Vorlage des Steuerelements erstellt, die wiederverwendet werden kann. Dies ist von Nutzen, wenn Sie in Ihre Programme standardmäßig "look and feel" einbauen möchten.


Einfügen von Steuerelementen in ein Benutzerformular

Um Steuerelemente einem UserForm hinzuzufügen, suchen in der Toolbox das gewünschte Steuerelement und ziehen Sie es auf das Formular. Anschließend passen Sie Größe und Form des Steuerelements unter Verwendung eines seiner Ziehpunkte nach Ihren Wünschen an.

Anmerkung Durch das Zurückziehen eines Steuerelements (oder mehrerer "gruppierter" Steuerelemente) vom Formular in die Toolbox wird eine Vorlage des Steuerelements erstellt, die wiederverwendet werden kann. Dies ist von Nutzen, wenn Sie in Ihre Programme standardmäßig "look and feel" einbauen möchten.

Wenn Sie dem Formular Steuerelemente hinzugefügt haben, passen Sie mit den Befehlen des Menüs Format des Visual Basic Editors Ausrichtung und Zwischenabstände der Steuerelemente an.


Ereignisse des Application-Objekts

Application-Ereignisse treten ein, wenn eine Arbeitsmappe erstellt oder geöffnet wird, oder wenn sich ein beliebiges Blatt in einer beliebigen geöffneten Arbeitsmappe ändert. Um Ereignisprozeduren für das Application-Objekt zu schreiben, müssen Sie unter Verwendung des Schlüsselwortes WithEvents in einem Klassenmodul ein neues Objekt erstellen. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

NewWorkbook

SheetActivate

SheetBeforeDoubleClick

SheetBeforeRightClick

SheetCalculate

SheetChange

SheetDeactivate

SheetFollowHyperlink

SheetSelectionChange

 WindowActivate

WindowDeactivate

WindowResize

WorkbookActivate

WorkbookAddinInstall

WorkbookAddinUninstall

WorkbookBeforeClose

WorkbookBeforePrint

WorkbookBeforeSave

WorkbookDeactivate

WorkbookNewSheet

WorkbookOpen


Ereignisse des Chart-Objekts

Chart-Ereignisse treten ein, wenn der Benutzer ein Diagramm aktiviert oder ändert. Ereignisse in Diagrammblättern sind standardmäßig aktiviert. Um die Ereignisprozeduren für ein Blatt anzuzeigen, klicken Sie mit der rechten Maustaste auf das Blattregister und wählen Sie im Kontextmenü Code anzeigen aus. Wählen Sie den Ereignisnamen im Dropdownlistenfeld Prozedur aus.

Activate

BeforeDoubleClick

BeforeRightClick

Calculate

Deactivate

DragOver

 DragPlot

MouseDown

MouseMove

MouseUp

Resize

Select

SeriesChange

Anmerkung Um Ereignisprozeduren für ein eingebettetes Diagramm zu schreiben, müssen Sie unter Verwendung des Schlüsselwortes WithEvents in einem Klassenmodul ein neues Objekt erstellen. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem Application-Objekt.

Im folgenden Beispiel ändert sich die Rahmenfarbe des Punktes, wenn der Benutzer den Punktwert ändert.

Private Sub Chart_SeriesChange(ByVal SeriesIndex As Long, _
        ByVal PointIndex As Long)
    Set p = ActiveChart.SeriesCollection(SeriesIndex). _
        Points(PointIndex)
    p.Border.ColorIndex = 3
End Sub


Steuerelement- und Dialogfeldereignisse

Nachdem Sie in Ihr Dialogfeld oder Dokument Steuerelemente eingefügt haben, fügen Sie Ereignisprozeduren hinzu, um festzulegen, wie die Steuerelemente auf Benutzeraktionen reagieren.

Benutzerformulare und und Steuerelemente besitzen einen vordefinierten Ereignissatz. Eine Befehlsschaltfläche besitzt beispielsweise ein Click-Ereignis, das auftritt, wenn der Benutzer auf die Befehlsschaltfläche klickt, und Benutzerformulare besitzen ein Initialize-Ereignis, das beim Laden des Formulars ausgeführt wird.

Um eine Ereignisprozedur für ein Steuerelement oder ein Formular zu schreiben, öffnen Sie ein Modul, indem Sie auf das Formular oder das Steuerelement doppelklicken und das Ereignis im Dropdownlistenfeld Prozedur auswählen.

Ereignisprozeduren beinhalten den Namen des Steuerelements. Beispielsweise lautete der Name der Click-Ereignisprozedur für die Befehlsschaltfläche "Schaltfläche1" "Schaltfläche1_Click".

Wenn Sie einer Ereignisprozedur Code hinzufügen und anschließend den Namen des Steuerelements ändern, bleibt Ihr Code mit dem vorherigen Namen in den Prozeduren.

Angenommen, sie fügen beispielsweise dem Click-Ereignis für "Befehl1" Code hinzu und benennen danach das Steuerelement in "Befehl2" um. Wenn Sie auf "Befehl2" doppelklicken, werden Sie in der Click-Ereignisprozedur keinen Code sehen. Sie müssen den Code von "Befehl1_Click" nach "Befehl2_Click" verschieben.

Um die Entwicklung zu vereinfachen, ist es ratsam, Ihre Steuerelemente korrekt zu benennen, bevor Sie Code schreiben.


Erstellen eines Benutzerformulars

Um ein benutzerdefiniertes Dialogfeld zu erstellen, müssen Sie ein Benutzerformular erstellen. Zum Erstellen eines Benutzerformulars klicken Sie von im Visual Basic-Editor im Menü Einfügen auf UserForm.

Ändern Sie im Eigenschaftsfenster Name, Verhalten und Erscheinungsbild des Formulars. Beispielsweise legen Sie zur Änderung der Formularbeschriftung die Caption-Eigenschaft fest.


Anzeigen eines benutzerdefinierten Dialogfeldes

Um Ihr Dialogfeld im Visual Basic Editor zu testen, klicken Sie auf Sub/Formular ausführen im Menü Jetzt abfragen des Visual Basic Editors.

Wenn Sie ein Dialogfeld aus Visual Basic anzeigen möchten, verwenden Sie die Show-Methode. Im folgenden Beispiel wird das Dialogfeld "UserForm" angezeigt.

Private Sub GetUserName()
    UserForm1.Show
End Sub


Hilfe zu Macintosh-Schlüsselwörtern

Sie haben für ein Visual Basic-Schlüsselwort Hilfe angefordert, das nur auf dem Macintosh verwendet wird. Informationen zu diesem Schlüsselwort finden Sie in der Sprachreferenzhilfe von Microsoft Office 98 Macintosh Edition.


Initialisieren von Steuerelementeigenschaften

Sie können Steuerelemente zur Laufzeit initialisieren, indem Sie Visual Basic-Code in einem Makro verwenden. Beispielsweise könnten Sie ein Listenfeld ausfüllen, Textwerte oder Optionsfelder festlegen.

Im folgenden Beispiel werden Daten mit Hilfe der AddItem-Methode einem Listenfeld hinzugefügt. Anschließend wird der Wert eines Textfeldes festgelegt und das Formular angezeigt.

Private Sub GetUserName()
    With UserForm1
        .lstRegions.AddItem "North"
        .lstRegions.AddItem "South"
        .lstRegions.AddItem "East"
        .lstRegions.AddItem "West"
        .txtSalesPersonID.Text = "00000"
        .Show
        ' ...
    End With
End Sub

Mit Hilfe von Code im Initialize-Ereignis können Sie auch Anfangswerte für Steuerelemente auf dem Formular festlegen. Das Festlegen von Anfangswerten im Initialize-Ereignis hat den Vorteil, dass der Initialisierungscode beim Formular bleibt. Sie können das Formular in ein anderes Projekt kopieren. Wenn Sie dann die Show-Methode ausführen, um das Dialogfeld anzuzeigen, werden die Steuerelemente initialisiert.

Private Sub UserForm_Initialize()
    UserForm1.lstNames.AddItem "Test One"
    UserForm1.lstNames.AddItem "Test Two"
    UserForm1.txtUserName.Text = "Default Name"
End Sub


Ereignisse des QueryTable-Objekts

Abfragetabellenereignisse treten auf, wenn eine Abfragetabelle aktualisiert wird. Diese Ereignisse sind standardmäßig aktiviert. Zum Anzeigen der für ein bestimmtes Blatt verfügbaren Ereignisprozeduren klicken Sie mit der rechten Maustaste auf die Blattregisterkarte, und klicken Sie dann im Kontextmenü auf Code anzeigen. Klicken Sie im Fenster Code im Dropdownlistenfeld Prozedur auf den Namen des Ereignisses, das Sie verwenden möchten.

AfterRefresh
BeforeRefresh

Anmerkung Um Ereignisprozeduren für eine Abfragetabelle zu schreiben, müssen Sie unter Verwendung des Schlüsselwortes WithEvents in einem Klassenmodul ein neues Objekt erstellen. Weitere Informationen finden Sie unter Verwendung von Ereignissen mit dem QueryTable-Objekt.


Verweisen auf alle Zellen in dem Tabellenblatt

Wenn Sie die Cells-Eigenschaft ohne Angabe einer Indexnummer auf ein Tabellenblatt anwenden, gibt die Methode ein Range-Objekt zurück, das alle Zellen des Tabellenblattes darstellt. Die folgende Sub-Prozedur löscht die Inhalte aller Zellen der ersten Tabelle in der aktiven Arbeitsmappe.

Sub ClearSheet()
    Worksheets("Sheet1").Cells.ClearContents
End Sub


Verweisen auf Zellen und Bereiche der A1-Schreibweise

Sie können im A1-Bezugssystem auf eine Zelle oder einen Zellbereich verweisen, indem Sie die Range-Methode verwenden. Mit der folgenden Sub-Prozedur werden die Zellen "A1:D5" fett formatiert.

Sub FormatRange()
    Workbooks("Book1").Sheets("Sheet1").Range("A1:D5") _
        .Font.Bold = True
End Sub

Die folgende Tabelle verdeutlicht, wie Bezüge in A1-Schreibweise mit der Range-Methode verwendet werden können.

Bezug | Bedeutung
Range("A1") | Zelle A1
Range("A1:B5") | Zellen A1 bis B5
Range("C5:D9,G9:H16") | Eine Mehrfachmarkierung eines Bereichs
Range("A:A") | Spalte A
Range("1:1") | Zeile 1
Range("A:C") | Spalten A bis C
Range("1:5") | Zeilen 1 bis 5
Range("1:1,3:3,8:8") | Zeilen 1, 3 und 8
Range("A:A,C:C,F:F") | Spalten A, C und F


Verweisen auf Zellen mit Indexnummern

Sie können mit der Cells-Eigenschaft auf eine einzelne Zelle verweisen, indem Sie die Indexnummern der jeweiligen Zeile und Spalte verwenden. Diese Eigenschaft gibt ein Range-Objekt zurück, das eine einzelne Zelle darstellt. Im folgenden Beispiel gibt Cells(6,1) die Zelle A6 des ersten Tabellenblattes zurück. Danach wird die Value-Eigenschaft auf 10 gesetzt.

Sub EnterValue()
    Worksheets("Sheet1").Cells(6, 1).Value = 10
End Sub

Die Cells-Eigenschaft eignet sich besonders gut dafür, Zellbereiche in einer Schleife zu durchlaufen, da Sie für die Indexzahlen Variablen einsetzen können. Dies macht das folgende Beispiel deutlich.

Sub CycleThrough()
    Dim counter As Integer
    For counter = 1 To 20
        Worksheets("Sheet1").Cells(counter, 3).Value = counter
    Next counter
End Sub

Anmerkung Möchten Sie schnell die Eigenschaften eines Zellbereichs ändern oder diesem eine Methode zuweisen, verwenden Sie die Range-Eigenschaft. Weitere Informationen finden Sie unter In der A1-Schreibweise auf Zellen verweisen.


Verweisen auf Zellen mit relativem Bezug zu anderen Zellen

Die Offset-Eigenschaft dient dazu, auf eine Zelle zu verweisen, die in relativem Bezug zu einer anderen Zelle steht. Im folgenden Beispiel wird der Inhalt der Zelle, die sich eine Zeile unter und drei Spalten neben der aktiven Zelle im aktiven Tabellenblatt befindet, doppelt unterstrichen.

Sub Underline()
    ActiveCell.Offset(1, 3).Font.Underline = xlDouble
End Sub

Anmerkung Sie können Makros aufzeichnen, die an Stelle von absoluten Bezügen die Offset-Eigenschaft verwenden. Zeigen Sie im Menü Extras auf Makro aufzeichnen, und klicken Sie danach auf Relative Aufzeichnung.

Um einen Zellbereich in einer Schleife zu bearbeiten, verwenden Sie eine Variable mit der Cells-Eigenschaft in einer Schleife. Im folgenden Beispiel werden die ersten 20 Zellen der dritten Spalte mit Werten zwischen 5 und 100 ausgefüllt, die in Schrittgrößen von 5 erhöht werden. Die Variable Zähler wird als Zeilenindex für die Cells-Eigenschaft verwendet.

Sub CycleThrough()
    Dim counter As Integer
    For counter = 1 To 20
        Worksheets("Sheet1").Cells(counter, 3).Value = counter * 5
    Next counter
End Sub


Verweisen auf Zellen mit einem Range-Objekt

Wenn Sie eine Objektvariable für ein Range-Objekt festlegen, können Sie den Bereich durch Verwenden des Variablennamens leicht ändern.

Die folgende Prozedur erstellt die Objektvariable myRange, und weist sie danach dem Bereich "A1:D5" der ersten Tabelle in der aktiven Arbeitsmappe zu. Die nachfolgenden Anweisungen ändern Eigenschaften des Bereichs, indem sie für das Bereichsobjekt den Variablennamen einsetzen.

Sub Random()
    Dim myRange As Range
    Set myRange = Worksheets("Sheet1").Range("A1:D5")
    myRange.Formula = "=RAND()"
    myRange.Font.Bold = True
End Sub


Verweisen auf Zellen in Kurzschreibweise

Sie können entweder das A1-Bezugssystem oder einen benannten Bereich innerhalb einer eckigen Klammer als Abkürzung für die Range-Eigenschaft verwenden. Sie müssen weder das Wort "Range" eingeben noch Anführungszeichen verwenden, wie in den folgenden Beispielen gezeigt wird.

Sub ClearRange()
    Worksheets("Sheet1").[A1:B5].ClearContents
End Sub

Sub SetValue()
    [MyRange].Value = 30
End Sub


Verweisen auf mehrere Blätter

Sie können zur Angabe einer Gruppe von Blättern die Array-Funktion verwenden. Im folgenden Beispiel werden drei Blätter der aktiven Arbeitsmappe ausgewählt.

Sub Several()
    Worksheets(Array("Sheet1", "Sheet2", "Sheet4")).Select
End Sub


Verweisen auf mehrere Bereiche

Bei Verwendung der geeigneten Methode ist es einfach, auf mehrere Bereiche zu verweisen. Verwenden Sie die Range- und Union-Methoden, um auf eine beliebige Gruppe von Bereichen zu verweisen, und verwenden Sie die Areas-Eigenschaft, um auf eine in dem Tabellenblatt markierte Gruppe von Bereichen zu verweisen.

Verwenden der Range-Eigenschaft

Sie können mit der Range-Eigenschaft auf mehrere Bereiche verweisen, indem Sie zwischen zwei oder mehr Bereichen Kommata setzen. Im folgenden Beispiel werden die Inhalte von drei Bereichen in Sheet1 gelöscht.

Sub ClearRanges()
    Worksheets("Sheet1").Range("C5:D9,G9:H16,B14:D18"). _
        ClearContents
End Sub

Handelt es sich um benannte Bereiche, vereinfacht sich die Verwendung der Range-Eigenschaft bei der Arbeit mit mehreren Bereichen. Das folgende Beispiel funktioniert, wenn sich alle drei benannten Bereiche in derselben Tabelle befinden.

Sub ClearNamed()
    Range("MyRange, YourRange, HisRange").ClearContents
End Sub

Verwenden der Union-Methode

Sie können anhand der Union-Methode mehrere Bereiche in einem Range-Objekt zusammenfassen. Im folgenden Beispiel wird ein Range-Objekt mit dem Namen myMultipleRange erstellt und als die Bereiche "A1:B2" und "C3:D4" definiert. Anschließend werden die zusammengefassten Bereiche in fett formatiert.

Sub MultipleRange()
    Dim r1, r2, myMultipleRange As Range
    Set r1 = Sheets("Sheet1").Range("A1:B2")
    Set r2 = Sheets("Sheet1").Range("C3:D4")
    Set myMultipleRange = Union(r1, r2)
    myMultipleRange.Font.Bold = True
End Sub

Verwenden der Areas-Eigenschaft

Sie können die Areas-Eigenschaft verwenden, um auf den markierten Bereich bzw. die Auflistung von Bereichen in einer Mehrfachmarkierung zu verweisen. Die folgende Prozedur zählt die Bereiche in der Markierung. Bei mehr als einem Bereich wird eine Warnmeldung angezeigt.

Sub FindMultiple()
    If Selection.Areas.Count > 1 Then
        MsgBox "Cannot do this to a multiple selection."
    End If
End Sub


Verweisen auf benannte Bereiche

Bereiche lassen sich leichter durch Namen als durch die A1-Schreibweise identifizieren. Um einen markierten Bereich mit einem Namen zu versehen, klicken Sie auf das Namenfeld am linken Ende der Bearbeitungsleiste, geben einen Namen ein und drücken die EINGABETASTE.

Verweisen auf einen benannten Bereich

Im folgenden Beispiel wird auf den Bereich mit Namen "myRange" in der Arbeitsmappe "myBook.xls" verwiesen.

Sub FormatRange()
    Range("MyBook.xls!MyRange").Font.Italic = True
End Sub

Im folgenden Beispiel wird auf den tabellenblattspezifischen Bereich mit Namen "Sheet1!Sales" in der Arbeitsmappe "Report.xls" verwiesen.

Sub FormatSales()
    Range("[Report.xls]Sheet1!Sales").BorderAround weight:=xlthin
End Sub

Um einen benannten Bereich zu markieren, verwenden Sie die GoTo-Methode. Sie aktiviert die Arbeitsmappe und das Tabellenblatt und markiert anschließend den Bereich.

Sub ClearRange()
    Application.Goto Reference:="MyBook.xls!MyRange"
    Selection.ClearContents
End Sub

Das folgende Beispiel zeigt, wie die gleiche Prozedur für die aktive Arbeitsmappe geschrieben würde.

Sub ClearRange()
    Application.Goto Reference:="MyRange"
    Selection.ClearContents
End Sub

Durchlaufen von Zellen in einem benannten Bereich in einer Schleife

Im folgenden Beispiel wird jede Zelle in einem benannten Bereich in einer Schleife durchlaufen. Hierzu wird die For Each...Next-Schleife verwendet. Überschreitet der Wert einer Zelle in dem Bereich den Wert von Grenze, wird die Farbe der Zelle in Gelb geändert.

Sub ApplyColor()
    Const limit As Integer = 25
    For Each c In Range("MyRange")
        If c.Value > limit Then
            c.Interior.ColorIndex = 27
        End If
    Next c
End Sub


Verweisen auf Zeilen und Spalten

Verwenden Sie die Eigenschaften Rows oder Columns, um mit ganzen Zeilen oder Spalten zu arbeiten. Diese Eigenschaften geben ein Range-Objekt zurück, das einen Zellbereich darstellt. Im folgenden Beispiel gibt Rows(1) die erste Zeile des ersten Tabellenblattes zurück. Anschließend wird die Bold-Eigenschaft des Font-Objekts für diesen Bereich auf True festgelegt.

Sub RowBold()
    Worksheets("Sheet1").Rows(1).Font.Bold = True
End Sub

Die folgende Tabelle verdeutlicht, wie Zeilen- und Spaltenbezüge mit den Eigenschaften Rows und Columns verwendet werden können.

Bezug | Bedeutung
Rows(1) | Zeile eins
Rows | Alle Zeilen des Tabellenblattes
Columns(1) | Spalte eins
Columns("A") | Spalte eins
Columns | Alle Spalten des Tabellenblattes

Um gleichzeitig mit mehreren Zeilen oder Spalten zu arbeiten, erstellen Sie eine Objektvariable und verwenden Sie die Union-Methode, um mehrere Aufrufe mit der Rows- bzw. Columns-Eigenschaft zu verbinden. Im folgenden Beispiel wird das Format der Zeilen eins, drei und fünf im ersten Tabellenblatt der aktiven Arbeitsmappe in fett geändert.

Sub SeveralRows()
    Worksheets("Sheet1").Activate
    Dim myUnion As Range
    Set myUnion = Union(Rows(1), Rows(3), Rows(5))
    myUnion.Font.Bold = True
End Sub


 Zurückgeben eines Objekts aus einer Auflistung

Zurückgeben eines Objekts aus einer Auflistung

Die Item-Eigenschaft gibt ein einzelnes Objekt einer Auflistung zurück. Im folgenden Beispiel wird die Variable firstBook auf ein Workbook-Objekt gesetzt, das die erste Arbeitsmappe darstellt.

Set firstBook = Workbooks.Item(1)

Die Item-Eigenschaft ist die Standardeigenschaft für die meisten Auflistungen. Deshalb können Sie dieselbe Anweisung durch Weglassen des Schlüsselworts Item verkürzen.

Set firstBook = Workbooks(1)

Weitere Informationen über eine bestimmte Auflistung finden Sie unter dem Hilfethema für die betreffende Auflistung oder unter der Item-Eigenschaft für die Auflistung.

Benannte Objekte

In der Regel können Sie bei der Item-Eigenschaft zwar einen Ganzzahlwert angeben, es ist jedoch eventuell einfacher, ein Objekt mit Hilfe seines Namens zurückzugeben. Sie müssen das Objekt zuerst benennen, bevor Sie bei der Item-Eigenschaft mit einem Namen arbeiten können. Dies erfolgt meistens durch Festlegen der Name-Eigenschaft des Objekts. Im folgenden Beispiel wird ein benanntes Tabellenblatt in der aktiven Arbeitsmappe erstellt, und anschließend wird das Tabellenblatt mit Hilfe seines Namens angegeben.

ActiveWorkbook.Worksheets.Add.Name = "a new sheet"
With Worksheets("a new sheet")
    .Range("a5:a10").Formula = "=rand()"
End With

Vordefinierte Indexwerte

Einige Auflistungen haben vordefinierte Indexwerte, mit deren Hilfe Sie einzelne Objekte zurückgeben können. Jeder vordefinierte Indexwert wird durch eine Konstante dargestellt. Sie geben zum Beispiel eine XlBordersIndex-Konstante bei der Item-Eigenschaft der Borders-Auflistung an, um einen einzelnen Rahmen zurückzugeben.

Im folgenden Beispiel wird für den unteren Rahmen des Zellbereichs A1:G1 in Sheet1 eine doppelte Linie festgelegt.

Worksheets("Sheet1").Range("a1:g1"). _
    Borders.Item(xlEdgeBottom).LineStyle = xlDouble


Verwenden von Steuerelementen während der Code-Ausführung

Manche Steuerelement-Eigenschaften können festgelegt und zurückgegeben werden, während Visual Basic-Code ausgeführt wird. Im folgenden Beispiel wird für die Text-Eigenschaft eines Textfeldes "Hello" festgelegt.

TextBox1.Text = "Hello"

Daten, die von einem Benutzer in ein Formular eingegeben werden, gehen beim Schließen des Formulars verloren. wenn Sie die Werte von Steuerelementen auf einem Formular zurückgeben, nachdem das Formular aus dem Speicher entfernt wurde, erhalten Sie nicht die vom Benutzer eingegebenen Werte, sondern die Anfangswerte der Steuerelemente.

Möchten Sie die auf einem Formular eingegebenen Daten sichern, können Sie die Informationen in Variablen der Modulebene speichern, während das Formular noch ausgeführt wird. Im folgenden Beispiel wird ein Formular angezeigt, und die Formulardaten werden gespeichert.

' Code in module to declare public variables.
Public strRegion As String
Public intSalesPersonID As Integer
Public blnCancelled As Boolean

' Code in form.
Private Sub cmdCancel_Click()
    Module1.blnCancelled = True
    Unload Me
End Sub

Private Sub cmdOK_Click()
    ' Save data.
    intSalesPersonID = txtSalesPersonID.Text
    strRegion = lstRegions.List(lstRegions.ListIndex)
    Module1.blnCancelled = False
    Unload Me
End Sub

Private Sub UserForm_Initialize()
    Module1.blnCancelled = True
End Sub

' Code in module to display form.
Sub LaunchSalesPersonForm()
    frmSalesPeople.Show
    If blnCancelled = True Then
        MsgBox "Operation Cancelled!", vbExclamation
    Else
        MsgBox "The Salesperson's ID is: " &
            intSalesPersonID & _
            "The Region is: " & strRegion
    End If
End Sub


 Festlegen von Steuerelementeigenschaften

Festlegen von Steuerelementeigenschaften

Manche Eigenschaften eines Steuerelements lassen sich während des Entwurfs festlegen. Klicken Sie im Entwurfsmodus mit der rechten Maustaste auf ein Steuerelement, und klicken Sie anschließend auf Eigenschaften, um das Eigenschaftsfenster anzuzeigen. Die Eigenschaftsnamen stehen in der linken Spalte des Fensters, die Eigenschaftswerte in der rechten Spalte. Um einen Eigenschaftswert festzulegen, geben Sie den neuen Wert rechts neben dem Eigenschaftsnamen ein.


Verwenden von Ereignissen mit dem Application-Objekt

Bevor Sie ein Ereignis mit dem Application-Objekt verwenden können, müssen Sie ein neues Klassenmodul erstellen und für Ereignisse ein Objekt vom Typ Application deklarieren. Nehmen Sie beispielsweise an, dass ein neues Klassenmodul erstellt wird, das EventClassModule heißt. Das neue Klassenmodul enthält den folgenden Code.

Public WithEvents App As Application

Nachdem das neue Objekt mit Ereignissen deklariert wurde, wird es im Klassenmodul im Dropdownlistenfeld Objekt angezeigt, und Sie können Ereignisprozeduren für das neue Objekt schreiben. (Wenn Sie das neue Objekt im Feld Objekt auswählen, werden die gültigen Ereignisse für dieses Objekt im Dropdownlistenfeld Prozedur angezeigt.)

Bevor die Prozeduren ausgeführt werden könne, müssen Sie jedoch das deklarierte Objekt im Klassenmodul mit dem Application-Objekt verbinden. Sie können dazu in allen Modulen den folgenden Code verwenden.

Dim X As New EventClassModule

Sub InitializeApp()
    Set X.App = Application
End Sub

Nachdem die InitializeApp-Prozedur ausgeführt wurde, zeigt das App-Objekt im Klassenmodul auf das Application-Objekt von Microsoft Excel, und die Ereignisprozeduren im Klassenmodul werden ausgeführt, wenn die Ereignisse auftreten.


Verwendung von Ereignissen mit eingebetteten Diagrammen

Ereignisse sind für Diagrammblätter standardmäßig aktiviert. Bevor Sie Ereignisse mit einem Chart-Objekt, das ein eingebettetes Diagramm darstellt, verwenden können, müssen Sie ein neues Klassenmodul erstellen und ein Objekt des Typs Chart mit Ereignissen deklarieren. Nehmen Sie beispielsweise an, unter dem Namen "EreignisKlassenmodul" wurde ein neues Klassenmodul erstellt. Es enthält folgenden Code.

Public WithEvents myChartClass As Chart

Nachdem das neue Objekt mit Ereignissen deklariert wurde, erscheint es im Dropdownlistenfeld Objekt im Klassenmodul, und sie können für das Objekt Ereignisprozeduren schreiben. (Wenn Sie das neue Objekt im Objekt-Feld markieren, werden die gültigen Ereignisse im Dropdownlistenfeld Prozedur aufgeführt.)

Bevor Ihre Prozeduren ausgeführt werden können, müssen Sie das deklarierte Objekt im Klassenmodul mit dem eingebetteten Diagramm verbinden. Dazu können Sie aus jedem beliebigen Modul heraus folgenden Code verwenden.

Dim myClassModule As New EventClassModule

Sub InitializeChart()
    Set myClassModule.myChartClass = _
        Worksheets(1).ChartObjects(1).Chart
End Sub

Nachdem Sie die InitializeChart-Prozedur ausgeführt haben, zeigt das myChartClass-Objekt im Klassenmodul auf das eingebettete Diagramm im ersten Arbeitsblatt. Die Ereignisprozeduren werden ausgeführt, wenn die Ereignisse auftreten.


Verwenden von Ereignissen mit dem QueryTable-Objekt

Bevor Sie ein Ereignis mit dem QueryTable-Objekt verwenden können, müssen Sie zunächst ein neues Klassenmodul erstellen und für Ereignisse ein QueryTable-Objekt deklarieren. Nehmen Sie beispielsweise an, dass Sie ein neues Klassenmodul mit dem Namen ClsModQT erstellt haben. Dieses Modul enthält den folgenden Code:

Public WithEvents qtQueryTable As QueryTable

Nachdem das neue Objekt mit Hilfe von Ereignissen deklariert wurde, wird es im Klassenmodul im Dropdownlistenfeld Object angezeigt.

Bevor die Prozeduren ausgeführt werden können, müssen Sie jedoch das deklarierte Objekt im Klassenmodul mit dem angegebenen QueryTable-Objekt verbinden. Sie können dazu den folgenden Code im Klassenmodul eingeben:

Sub InitQueryEvent(QT as Object)
    Set qtQueryTable = QT
End Sub

Nachdem die Initialisierungsprozedur ausgeführt wurde, zeigt das im Klassenmodul deklarierte Objekt auf das angegebene QueryTable-Objekt. Sie können das Ereignis in einem Modul initialisieren, indem Sie das Ereignis aufrufen. In dem folgenden Beispiel wird die erste Abfragetabelle im aktiven Arbeitsblatt mit dem qtQueryTable-Objekt verbunden.

Dim clsQueryTable as New ClsModQT

Sub RunInitQTEvent
    clsQueryTable.InitQueryEvent _
        QT:=ActiveSheet.QueryTables(1)
End Sub

Sie können in der Klasse des Objekts weitere Ereignisprozeduren schreiben. Wenn Sie im Feld Objekt auf das neue Objekt klicken, werden die gültigen Ereignisse für das betreffende Objekt im Dropdownlistenfeld Prozedur angezeigt.


Ereignisse für Workbook-Objekte

Workbook-Ereignisse treten ein, wenn sich die Arbeitsmappe oder ein beliebiges Blatt darin ändert. Sie sind standardmäßig aktiviert. Um die Ereignisprozeduren für eine Arbeitsmappe anzuzeigen, klicken Sie mit der rechten Maustaste auf die Titelleiste eines wiederhergestellten oder minimierten Arbeitsmappenfensters und klicken im Kontextmenü auf Code anzeigen. Wählen Sie den Ereignisnamen im Dropdownlistenfeld Prozedur aus.

AddinUninstall

BeforeClose

BeforePrint

BeforeSave

Deactivate

NewSheet

Open

SheetActivate

SheetBeforeDoubleClick

 SheetBeforeRightClick

SheetCalculate

SheetChange

SheetDeactivate

SheetFollowHyperlink

SheetSelectionChange

WindowActivate

WindowDeactivate

WindowResize

In diesem Beispiel wird Microsoft Excel beim Öffnen der Arbeitsmappe maximiert.

Sub Workbook_Open()
    Application.WindowState = xlMaximized
End Sub


Ereignisse des Worksheet-Objekts

Ereignisse in Blättern sind standardmäßig aktiviert. Um die Ereignisprozeduren für ein Blatt anzuzeigen, klicken Sie mit der rechten Maustaste auf das Blattregister und wählen im Kontextmenü Code anzeigen. Wählen Sie den Ereignisnamen in dem Dropdownlistenfeld Prozedur aus.

Activate

BeforeDoubleClick

BeforeRightClick

Calculate

 Change

Deactivate

FollowHyperlink

SelectionChange

Ereignisse auf Tabellenblattebene treten ein, wenn ein Tabellenblatt aktiviert wird, oder der Benutzer eine Zelle des Blattes ändert. Im folgenden Beispiel werden die Spalten A bis F in der Größe angepasst.

Private Sub Worksheet_Calculate()
    Columns("A:F").AutoFit
End Sub

Manche Ereignisse können als Ersatz für eine Aktion im Standardverhalten der Anwendung verwendet werden, oder um kleine Änderungen im Standardverhalten vorzunehmen.

Private Sub Worksheet_BeforeRightClick(ByVal Target As Range, _
        Cancel As Boolean)
    For Each icbc In Application.CommandBars("cell").Controls
        If icbc.Tag = "brccm" Then icbc.Delete
    Next icbc
    If Not Application.Intersect(Target, Range("b1:b10")) _
            Is Nothing Then
        With Application.CommandBars("cell").Controls _
            .Add(Type:=msoControlButton, before:=6, _
                temporary:=True)
           .Caption = "New Context Menu Item"
           .OnAction = "MyMacro"
           .Tag = "brccm"
        End With
    End If
End Sub


Formatcodes für Kopf- und Fußzeilen

Die folgenden speziellen Formatcodes können in die Kopf- und Fußzeilen aufgenommen werden (LeftHeader, CenterHeader, RightHeader, LeftFooter, CenterFooter, RightFooter).

Formatcode | Beschreibung
&L | Richtet nachfolgende Zeichen links aus.
&C | Zentriert das nachfolgende Zeichen.
&R | Richtet nachfolgende Zeichen rechts aus.
&E | Schaltet Doppelt Unterstreichen ein oder aus.
&X | Schaltet Hochstellen ein oder aus.
&Y | Schaltet Tiefstellen ein oder aus.
&B | Schaltet Fettdruck ein oder aus.
&I | Schaltet Kursivdruck ein oder aus.
&U | Schaltet Unterstreichen ein oder aus.
&S | Schaltet Durchstreichen ein oder aus.
&D | Druckt das aktuelle Datum.
&T | Druckt die aktuelle Zeit.
&F | Druckt den Namen des Dokuments.
&A | Druckt den Namen des Registers einer Arbeitsmappe.
&P | Druckt die Seitenzahl.
&P+Zahl | Druckt die Seitenzahl zuzüglich der angegebenen Zahl.
&P+Zahl | Druckt die Seitenzahl abzüglich der angegebenen Zahl.
&& | Druckt ein einzelnes kaufmännisches Und-Zeichen.
&"Schriftart" | Druckt die nachfolgenden Zeichen in der angegebenen Schriftart. Schriftart muss von Anführungszeichen eingeschlossen sein.
&nn | Druckt die nachfolgenden Zeichen im angegebenen Schriftgrad. Geben Sie eine zweistellige Zahl an, um den Schriftgrad anzugeben.
&N | Druckt die Gesamtanzahl der Seiten eines Dokumentes.


ActiveX-Steuerelemente

Um weitere Informationen über ein bestimmtes Steuerelement zu erhalten, aktivieren Sie ein Objekt aus der folgenden Liste. Um weitere Informationen über Ereignisse zu erhalten, aktivieren Sie ein Steuerelement, und klicken Sie oben im Thema auf "Ereignisse".

CheckBox

ComboBox

CommandButton

Frame

Image

Label

ListBox

 MultiPage

OptionButton

RefEdit

ScrollBar

SpinButton

TabStrip

TextBox

ToggleButton


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Datenzugriffsobjekt-Hilfe nicht gefunden werden kann, bzw. nicht installiert oder entfernt wurde.

So installieren Sie die Datenzugriffsobjekt-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie in der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen und blenden Sie in der Liste der Features Office Tools ein.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Auswahlmöglichkeiten für die Installation anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Microsoft Office Visual Basic-Hilfe nicht gefunden werden kann, bzw. nicht installiert oder entfernt wurde.

So installieren Sie die Microsoft Office Visual Basic-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie in der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen und blenden Sie in der Liste der Features Office Tools ein.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Auswahlmöglichkeiten für die Installation anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Visual Basic für Applikationen-Hilfe nicht gefunden werden kann, oder nicht installiert bzw. entfernt wurde.

So installieren Sie die Visual Basic für Applikationen-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie in der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen und blenden Sie in der Liste der Features Office Tools ein.

  4. Klicken Sie auf das Symbol neben Visual Basic-Hilfe, um die Auswahlmöglichkeiten für die Installation anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Hilfethema nicht verfügbar

Das Hilfethema kann nicht angezeigt werden, weil die Microsoft Excel-Hilfe nicht gefunden werden kann, oder nicht installiert bzw. entfernt wurde.

So installieren Sie die Microsoft Excel-Hilfe

  1. Doppelklicken Sie in der Systemsteuerung auf Software.

  2. Klicken Sie auf der Registerkarte Installieren/Deinstallieren auf die installierte Version von Microsoft Office 2000 und dann auf Hinzufügen/Entfernen.

  3. Klicken Sie auf Features hinzufügen/entfernen, und blenden Sie dann in der Liste der Features Microsoft Excel für Windows ein.

  4. Klicken Sie auf das Symbol neben Hilfe, um die Auswahlmöglichkeiten für die Installation anzuzeigen.

  5. Klicken Sie auf Vom Arbeitsplatz starten oder Vom Netzwerk starten und dann auf Jetzt aktualisieren.


Zellfehlerwerte

Sie können mit der CVErr-Funktion einen Zellfehlerwert in eine Zelle einfügen oder den Wert einer Zelle auf einen Fehlerwert testen. Zellfehlerwerte können die nachfolgend aufgeführten XlCVError-Konstanten sein:

Konstante | Fehlernummer | Zellfehlerwert
xlErrDiv0 | 2007 | #DIV/0!
XlErrNA | 2042 | #NV
xlErrName | 2029 | #NAME?
XlErrNull | 2000 | #NULL!
XlErrNum | 2036 | #ZAHL!
XlErrRef | 2023 | #BEZUG!
XlErrValue | 2015 | #WERT!


Beispiel zu Zellfehlerwerten

In diesem Beispiel werden die sieben möglichen Zellfehlerwerte in die Zellen A1:A7 in Sheet1 eingefügt.

myArray = Array(xlErrDiv0, xlErrNA, xlErrName, xlErrNull, _
    xlErrNum, xlErrRef, xlErrValue)
For i = 1 To 7
    Worksheets("Sheet1").Cells(i, 1).Value = CVErr(myArray(i - 1))
Next i

In diesem Beispiel wird eine Meldung angezeigt, wenn die aktive Zelle in Sheet1 einen Zellfehlerwert enthält. Sie können dieses Beispiel als Vorlage für eine Routine zur Behandlung von Zellfehlerwerten verwenden.

Worksheets("Sheet1").Activate
If IsError(ActiveCell.Value) Then
    errval = ActiveCell.Value
    Select Case errval
        Case CVErr(xlErrDiv0)
            MsgBox "#DIV/0! error"
        Case CVErr(xlErrNA)
            MsgBox "#N/A error"
        Case CVErr(xlErrName)
            MsgBox "#NAME? error"
        Case CVErr(xlErrNull)
            MsgBox "#NULL! error"
        Case CVErr(xlErrNum)
            MsgBox "#NUM! error"
        Case CVErr(xlErrRef)
            MsgBox "#REF! error"
        Case CVErr(xlErrValue)
            MsgBox "#VALUE! error"
        Case Else
            MsgBox "This should never happen!!"
    End Select
End If


Änderungen an Visual Basic in Microsoft Excel für Windows 95

Dieses Thema behandelt Änderungen am Visual Basic-Objektmodell, die zwischen Microsoft Excel Version 5.0 und Microsoft Excel für Windows 95 vorgenommen wurden. Weitere Informationen über Änderungen, die gegenüber Microsoft Excel für Windows 95 und Microsoft Excel 97 vorgenommen wurden, finden Sie unter Änderungen am Microsoft Excel 97-Objektmodell.

In Visual Basic in Microsoft Excel für Windows 95 wurden bestehende Eigenschaften und Methoden geändert sowie mehrere neue Eigenschaften, Methoden und Objekte hinzugefügt. Um weitere Informationen über diese Änderungen und Neuerungen zu erhalten, aktivieren Sie ein Element der folgenden Liste, oder führen Sie einen Bildlauf durch dieses Thema durch, bis Sie die gewünschte Information gefunden haben.

Geänderte Eigenschaften und Methoden

Unterstützung von AutoKorrektur

Unterstützung von OLE-Dokumenteigenschaften

Unterstützung von AutoEingabe

Steuerung von Schutzmechanismen

Steuerung des Erscheinungsbildes

Verschiedenes

Geänderte Eigenschaften und Methoden

Folgende Eigenschaften und Methoden wurden geändert, um neue Merkmale von Microsoft Excel zu unterstützen oder schon bestehende zu verbessern.

Thema | Beschreibung
GetOpenFileName-Methode | Mit dem neuen Argument MultiSelect können Sie mehrere Dateinamen im Dialogfeld "Öffnen" auswählen.
Names-Eigenschaft | Wurde dem Worksheet-Objekt zur Handhabung von Namen hinzugefügt, die sich über das gesamte Blatt erstrecken.
PasteSpecial-Methode | Bei der Verwendung des Range-Objekts können Sie mit einer neuen Konstante für das Argument Paste den Inhalt und die Formatierung eines Bereichs, ausschließlich seiner Rahmenformatierung, einfügen.
Protect-Methode | Mit dem neuen Argument UserInterfaceOnly können Sie einen Schutz gegen Änderungen durch den Benutzer festlegen; Änderungen durch Visual Basic-Code werden jedoch weiterhin angenommen.
SaveAs-Methode | Mit neuen Argumenten können Sie festlegen, wie gemeinsamer Zugriff geregelt wird und Änderungskonflikte gelöst werden.
StatusBar-Eigenschaft | Wurde dem ToolbarButton-Objekt hinzugefügt.

Unterstützung von AutoKorrektur

Folgende neuen Objekte, Eigenschaften und Methoden wurden zur Unterstützung von automatischen Korrekturen hinzugefügt.

Thema | Beschreibung
AddReplacement-Methode | Fügt der Matrix der AutoKorrektur-Ersetzungen, die von der ReplacementList-Methode zurückgegeben wird, eine Zeile hinzu.
AutoCorrect-Objekt | Enthält AutoKorrektur-Eigenschaften (Großschreibung von Wochentagen, Korrektur von zwei großgeschriebenen Anfangsbuchstaben, automatische Korrekturliste usw.)
AutoCorrect-Eigenschaft | Gibt ein AutoCorrect-Objekt zurück, das die AutoKorrektur-Eigenschaften darstellt.
CapitalizeNamesOfDays-Eigenschaft | True, falls die Anfangsbuchstaben von Wochentagen (und deren Abkürzungen) automatisch großgeschrieben werden.
DeleteReplacement-Methode | Löscht eine Zeile aus der Matrix der AutoKorrektur-Ersetzungen, die von der ReplacementList-Methode zurückgegeben wird.
ReplacementList-Methode | Gibt die gesamte Matrix oder eine Zeile der AutoKorrrektur-Ersetzungen zurück oder legt sie fest.
ReplaceText-Eigenschaft | True, falls Text in der ersten Spalte der Matrix der AutoKorrektur-Ersetzungen automatisch durch Text aus der zweiten Spalte ersetzt wird.
TwoInitialCapitals-Eigenschaft | True, falls zwei großgeschriebene Anfangsbuchstaben in einem Wort automatisch ersetzt werden.

Unterstützung von OLE-Dokumenteigenschaften

Die folgenden neuen Eigenschaften, Methoden und Objekte wurden zur Unterstützung von OLE-Dokumenteigenschaften hinzugefügt. Mit Dokumenteigenschaften können in Microsoft Excel ein Standardsatz von integrierten Dokumenteigenschaften sowie zusätzliche, benutzerdefinierte Dokumenteigenschaften angezeigt werden.

Thema | Beschreibung
BuiltinDocumentProperties-Eigenschaft | Gibt ein DocumentProperties-Auflistungsobjekt zurück, das die integrierten Dokumenteigenschaften des Objekts enthält.
CustomDocumentProperties-Eigenschaft | Gibt ein DocumentProperties-Auflistungsobjekt zurück, das die benutzerdefinierten Dokumenteigenschaften des Objekts enthält.
DocumentProperties-Objekt | Stellt die Auflistung der Dokumenteigenschaften (entweder integrierte oder benutzerdefinierte) dar.
DocumentProperty-Objekt | Stellt eine einzelne Dokumenteigenschaft dar.
LinkToContent-Eigenschaft | True, falls der Wert einer benutzerdefinierten Dokumenteigenschaft mit dem Inhalt des Dokuments, in dem sie enthalten ist, verknüpft ist; False, falls die Eigenschaft ein statischer Wert ist.
LinkSource-Eigenschaft | Legt die Quelle einer benutzerdefinierten Dokumenteigenschaft fest, die mit dem Inhalt des Dokuments verknüpft ist.

Unterstützung von AutoVervollständigen

Folgende Methode und Eigenschaft wurden zur Unterstützung der AutoVervollständigen-Funktion hinzugefügt.

Thema | Beschreibung
AutoComplete-Methode | Gibt eine eingegebene Zeichenfolge aus der Liste zurück oder eine leere Zeichenfolge, falls keine Eingabe vorgenommen wurde oder eine Übereinstimmung mit mehr als einem Eintrag der Liste auftritt.
EnableAutoComplete-Eigenschaft | True, falls die AutoEingabe-Funktion aktiviert ist.

Steuerung von Schutzmechanismen

Folgende Eigenschaften wurden hinzugefügt, damit Sie steuern können, inwieweit der Benutzer Symbolleisten, gefilterte Listen, PivotTable-Berichte und Gliederungen ändern kann.

Thema | Beschreibung
EnableAutoFilter-Eigenschaft | True, falls AutoFilter-Pfeile aktiviert sind, wenn der Schutz "Nur-Benutzeroberfläche" eingeschaltet ist.
EnableOutlining-Eigenschaft | True, falls Gliederungssymbole (Detail einblenden oder Detail ausblenden) aktiviert sind, wenn der Schutz "Nur-Benutzeroberfläche" eingeschaltet ist.
EnablePivotTable-Eigenschaft | True, falls PivotTable-Steuerelemente und -Aktionen aktiviert sind, wenn der Schutz "Nur-Benutzeroberfläche" eingeschaltet ist.

Steuerung des Erscheinungsbildes

Folgende Eigenschaften und Methoden wurden hinzugefügt, um das Erscheinungsbild des Mauszeigers zu steuern, animiertes Einfügen und Löschen ein- und auszuschalten, ein Textfeld zur Kennworteingabe zu erstellen und die Hintergrundgrafik für ein Arbeitsblatt oder ein Diagramm festzulegen.

Thema | Beschreibung
Cursor-Eigenschaft | Legt das Erscheinungsbild des Mauszeigers in Microsoft Excel fest.
EnableAnimations-Eigenschaft | True, falls animiertes Einfügen und Löschen aktiviert ist.
SetBackgroundPicture-Methode | Legt die Hintergrundgrafik für ein Arbeitsblatt oder ein Diagramm fest.

Verschiedenes

Thema | Beschreibung
AutoLoad-Eigenschaft | True, falls das OLE-Objekt automatisch geladen wird, wenn die Arbeitsmappe, die das Objekt enthält, geöffnet wird.
CopyFromRecordset-Methode | Kopiert den Inhalt eines DAO Recordset-Objekts in eine Zelle eines Arbeitsblattes, beginnend an der ersten Zelle des angegebenen Bereichs.
ListHeaderRows-Eigenschaft | Gibt die Anzahl der Überschriftenzeilen des angegebenen Bereichs zurück.
MoveAfterReturnDirection-Eigenschaft | Steuert, in welche Richtung die aktive Zelle verschoben wird, nachdem der Benutzer die EINGABETASTE gedrückt hat.
NetworkTemplatesPath-Eigenschaft | Gibt den Netzwerkpfad zurück, in dem Vorlagen gespeichert werden. Existiert der Netzwerkpfad nicht, gibt die Eigenschaft eine leere Zeichenfolge zurück.
Post-Methode | Veröffentlicht die angegebene Arbeitsmappe in einem öffentlichen Ordner unter Microsoft Exchange oder in einer Lotus Notes-Datenbank.
ProtectionMode-Eigenschaft | True, falls der Schutz "Nur-Benutzeroberfläche" eingeschaltet ist.
RangeSelection-Eigenschaft | Gibt ein Range-Objekt zurück, das die markierten Zellen des Arbeitsblattes im angegebenen Fenster darstellt, auch wenn ein Grafikobjekt in dem Arbeitsblatt aktiv oder markiert ist.
RefersToRange-Eigenschaft | Gibt das Range-Objekt zurück, auf das durch ein Name-Objekt Bezug genommen wird.
TemplatesPath-Eigenschaft | Gibt den lokalen Pfad zurück, in dem Vorlagen gespeichert werden.


Ausgeblendete Objekte

Die gegenüber dem Microsoft Excel 97 Visual Basic-Objektmodell ausgeblendeten Objekte sind in der folgenden Tabelle aufgeführt. Diese Objekte werden aus Gründen der Abwärtskompatibilität unterstützt; für neuen Code sollten Sie die Ersatzfunktionalität für Microsoft Excel 97 verwenden. Zum Anzeigen ausgeblendeter Objekte im Objektbrowser klicken Sie mit der rechten Maustaste auf das Fenster Objektbrowser, und klicken Sie im Kontextmenü auf Ausgeblendete Elemente anzeigen. Weitere Informationen über die Änderungen des Microsoft Excel 97-Objektmodells finden Sie in den folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Eigenschaften und Methoden

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Ausgeblendete Objekte | Ersatz
Arc, Arcs, Drawing, DrawingObjects, Drawings, Label, Labels, Line, Lines, Oval, Ovals, Picture, Pictures, Rectangle, Rectangles | Neue Zeichenebene für Formen
Button, Buttons, CheckBox, CheckBoxes, DialogFrame, DropDown, DropDowns, EditBox, EditBoxes, GroupBox, GroupBoxes, GroupObject, GroupObjects, ListBox, ListBoxes, OptionButton, OptionButtons, ScrollBar, ScrollBars, Spinner, Spinners, TextBox, TextBoxes | ActiveX-Steuerelemente
Menu, MenuBar, MenuBars, MenuItem, MenuItems, Menus, Toolbar, ToolbarButton, ToolbarButtons, Toolbars | Befehlsleisten
Module, Modules | Objektmodel für VBE-Erweiterbarkeit
DialogSheet, DialogSheets | Benutzerdefinierte Formulare


Ausgeblendete Objekte

Im Objektmodell von Microsoft Excel 2000 Visual Basic für Applikationen wurden keine neuen Objekte ausgeblendet. Ausgeblendete Objekte werden normalerweise nur aus Gründen der Abwärtskompatibilität unterstützt; für neuen Code sollten Sie die Ersatzfunktionalität verwenden. Zum Anzeigen ausgeblendeter Objekte im Objektbrowser klicken Sie mit der rechten Maustaste auf das Fenster Objektbrowser, und klicken Sie im Kontextmenü auf Ausgeblendete Elemente anzeigen.


Ausgeblendete Eigenschaften und Methoden

Ausgeblendete Eigenschaften und Methoden für sichtbare Objekte sind in der folgenden Tabelle aufgeführt. Die meisten Eigenschaften und Methoden wurden gegenüber Microsoft Excel 97 durch die neue Funktionalität ersetzt. Diese Eigenschaften und Methode werden nur aus Gründen der Abwärtskompatibilität unterstützt; für neuen Code sollten Sie die Ersatzfunktionalität für Microsoft Excel 97 verwenden. Weitere Informationen über die Änderungen des Microsoft Excel 97-Objektmodells finden Sie in den folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Objekte

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Objekte | Ausgeblendete Eigenschaft oder Methode | Ersatz
Application | ActiveDialog | ActiveX-Steuerelemente
Application | ActiveMenuBar | Befehlsleisten
Chart, Worksheet | Arcs | Formen
AddIn, Workbook | Autor | DocumentProperties
Chart | AutoFormat | ApplyCustomType-Methode
Chart, Worksheet | Buttons | ActiveX-Steuerelemente
Chart, Worksheet | CheckBoxes | ActiveX-Steuerelemente
Application | ColorButtons | kein Ersatz
AddIn, Workbook | Comments | DocumentProperties
Application, Workbook | DialogSheets | Benutzerdefinierte Formulare und ActiveX-Steuerelemente
Worksheet | DisplayAutomaticPageBreaks | DisplayPageBreaks-Eigenschaft
Application | DisplayInfoWindow | kein Ersatz
Chart, Worksheet | DrawingObjects | Formen
Chart, Worksheet | Drawings | Formen
Chart, Worksheet | DropDowns | ActiveX-Steuerelemente
Application | EnableTipWizard | Assistent
ChartObjects, OLEObjects | Group | Formen
Chart, Worksheet | GroupBoxes | Formen
Chart, Worksheet | GroupObjects | Formen
AddIn, Workbook | Keywords | DocumentProperties
Chart, Worksheet | Labels | Formen
Application | LargeButtons | kein Ersatz
Chart, Worksheet | Lines | Formen
Chart, Worksheet | ListBoxes | ActiveX-Steuerelemente
Application | MenuBars | Befehlsleisten
Application, Workbook | Modules | VBE
ChartObject, ChartObjects, OLEObject, OLEObjects | OnAction | Change- oder SheetChange-Ereignis
Application, Worksheet | OnCalculate | Calculate-Ereignis
Application, Worksheet | OnData | Change- oder SheetChange-Ereignis
Application, Chart, Worksheet | OnDoubleClick | BeforeDoubleClick-Ereignis
Application, Worksheet | OnEntry | Change-Ereignis
Workbook | OnSave | BeforeSave-Ereignis
Application, Chart, Workbook, Worksheet | OnSheetActivate | Activate- oder SheetActivate-Ereignis
Application, Chart, Workbook, Worksheet | OnSheetDeactivate | Deactivate- oder SheetDeactivate-Ereignis
Chart, Worksheet | OptionButtons | ActiveX-Steuerelemente
Chart, Worksheet | Ovals | ActiveX-Steuerelemente
Chart, Worksheet | Pictures | Formen
Chart, Worksheet | Rectangles | Formen
Application | ResetTipWizard | Assistent
Application | Save | SaveWorkspace-Methode
Chart, Worksheet | ScrollBars | ActiveX-Steuerelemente
Window | SetInfoDisplay | kein Ersatz
Application | ShortcutMenus | Befehlsleisten
Chart, Worksheet | Spinners | ActiveX-Steuerelemente
AddIn, Workbook | Subject | DocumentProperties
Chart, ChartGroup | SubType | ChartType-Eigenschaft
Chart, Worksheet | TextBoxes | ActiveX-Steuerelemente
AddIn, Workbook | Title | DocumentProperties
Application | Toolbars | Befehlsleisten
Chart, ChartGroup | Type | ChartType-Eigenschaft


Ausgeblendete Eigenschaften und Methoden

Die ausgeblendeten Eigenschaften für sichtbare Objekte in Microsoft Excel 2000 sind in der folgenden Tabelle aufgeführt. Methoden wurden nicht ausgeblendet. Die meisten der ausgeblendeten Eigenschaften wurden durch neue Excel-Funktionalität ersetzt. Diese Eigenschaften werden nur aus Gründen der Abwärtskompatibilität unterstützt; für neuen Code sollten Sie die Ersatzfunktionalität von Microsoft Excel 2000 verwenden.

Objekte | Ausgeblendete Eigenschaft | Ersatz
Application | UILanguage | LanguagePreferredForEditing
PivotCache, QueryTable | Sql | CommandText
QueryTable | TablesOnlyFromHTML | WebSelectionType


Sprachspezifische Eigenschaften, Methoden und Funktionen

Das Objektmodell von Microsoft Excel 2000 Visual Basic für Applikationen verfügt über sprachspezifische Elemente für den Einsatz mit asiatischen Sprachen und Sprachen mit Schreibweise von rechts nach links. Weitere Informationen über sprachspezifische Features finden Sie unter Sprachspezifische Informationen.

Methoden, die über sprachspezifische Argumente verfügen, sind in der folgenden Tabelle aufgeführt. Auf Methoden, die neue Argumente oder weniger Argumente als in Microsoft Excel 97 verfügen, wird hingewiesen.

Methode | Objekte | Kommentare
Add | Phonetics |
AddLabel | Shapes |
AddTextbox | Shapes |
AutoFormat | Range |
CheckSpelling | Application, Chart, Range, Worksheet | SpellLang wurde hinzugefügt; IgnoreInitialAlefHamza und IgnoreFinalYaa wurden entfernt
Find | Application, Range | MatchControlCharacters, MatchDiacritics, MatchKashida und MatchAlefHamza wurden entfernt
GetPhonetic | Application |
Replace | Range | MatchControlCharacters, MatchDiacritics, MatchKashida und MatchAlefHamza wurden entfernt
SetPhonetic | Range |
Sort | Range | IgnoreControlCharacters, IgnoreDiacritics und IgnoreKashida wurden entfernt
SortSpecial | Range |

Eigenschaften, die sprachspezifische Attribute zurückgeben oder festlegen, sind in der folgenden Tabelle aufgeführt.

Eigenschaft | Objekte
AddIndent | Range, Style
AddressLocal | Range
Alignment | Phonetic, Phonetics, TextEffectFormat, TickLabels
CharacterType | Phonetic, Phonetics
ControlCharacters | Application
CursorMovement | Application
DefaultSheetDirection | Application
DisplayRightToLeft | Window, Worksheet
FileFormat | Workbook
HorizontalAlignment | AxisTitle, ChartTitle, DataLabel, DataLabels, DisplayUnitLabel, Range, Style, TextFrame
IMEMode | Validation
International | Application
Item | Phonetics
Length | Phonetics
Phonetic | Range
PhoneticCharacters | Characters
Phonetics | Range
ReadingOrder | AxisTitle, ChartTitle, DataLabel, DataLabels, DisplayUnitLabel, Range, Style, TextFrame, TickLabels
Start | Phonetics
VerticalAlignment | AxisTitle, ChartTitle, DataLabel, DataLabels, DisplayUnitLabels, Range, Style, TextFrame

Nachstehend finden Sie eine Liste der sprachspezifischen Tabellenfunktionen:


Methoden mit neuen Argumenten

Methoden mit Argumenten, die gegenüber Microsoft Excel 97 neu hinzugefügt wurden, sind in der folgenden Tabelle aufgeführt. Weitere Informationen über Änderungen des Microsoft Excel 97-Objektmodells finden Sie in den folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Objekte

Ausgeblendete Eigenschaften und Methoden

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Methode | Objekte | Neue Argumente
Add | OLEObjects | Left, Top, Width, Height
ApplyDataLabels | Chart, Series | AutoText, HasLeaderLines
ApplyDataLabels | Point | AutoText
AutoFilter | Range | VisibleDropDown
CheckSpelling | Chart, Range, Worksheet | IgnoreInitialAlefHamza, IgnoreFinalYaa, SpellScript (diese Argumente werden in der deutschen Version von Microsoft Excel nicht verwendet)
Find | Range | MatchControlCharacters, MatchDiacritics, MatchKashida, MatchAlefHamza (diese Argumente werden in der deutschen Version von Microsoft Excel nicht verwendet)
Open | Workbooks | AddToMru
OpenText | Workbooks | TextVisualLayout (wird in der deutschen Version von Microsoft Excel nicht verwendet)
PivotTableWizard | Worksheet | BackgroundQuery, OptimizeCache, PageFieldOrder, PageFieldWrapCount, ReadData, Connection
PrintPreview | Chart, Charts, Range, Sheets, Window, Workbook, Worksheet, Worksheets | EnableChanges
RegisteredFunctions | Application | Index1, Index2
Replace | Range | MatchControlCharacters, MatchDiacritics, MatchKashida, MatchAlefHamza (diese Argumente werden in der deutschen Version von Microsoft Excel nicht verwendet)
Run | Application | Verwendet nun eine Argument-Matrix von variabler Länge
SaveAs | Chart, Workbook, Worksheet | AddToMru, TextCodepage, TextVisualLayout (die letzten beiden Argumente werden in der deutschen Version von Microsoft Excel nicht verwendet)
SetDefaultChart | Application | Gallery
Sort | Range | SortMethod, IgnoreControlCharacters, IgnoreDiacritics, IgnoreKashida (die letzten drei Argumente werden in der deutschen Version von Microsoft Excel nicht verwendet)


Methoden mit neuen, geänderten oder gelöschten Argumenten

Methoden mit Argumenten, die in Microsoft Excel 2000 hinzugefügt, geändert oder entfernt wurden, sind in der folgenden Tabelle aufgeführt.

Methode | Objekte | Argumente
Add | Hyperlinks | ScreenTip und TextToDisplay wurden hinzugefügt.
CheckSpelling | Chart, Range, Worksheet | SpellLang wurde hinzugefügt; SpellScript, IgnoreInitialAlefHamza und IgnoreFinalYaa wurden entfernt (die letzten beiden Argumente wurden in der deutschen Version von Microsoft Excel nicht verwendet).
Find | Range | MatchControlCharacters, MatchDiacritics, MatchKashida und MatchAlefHamza wurden entfernt (diese Argumente wurden in der deutschen Version von Microsoft Excel nicht verwendet).
OpenText | Workbooks | DecimalSeparator und ThousandsSeparator wurden hinzugefügt.
PivotSelect | PivotTable | Mode wurde in optional geändert.
PrintOut | Chart, Charts, Range, Sheets, Worksheet, Worksheets | PrToFileName wurde hinzugefügt.
Replace | Range | MatchControlCharacters, MatchDiacritics, MatchKashida und MatchAlefHamza wurden entfernt (diese Argumente wurden in der deutschen Version von Microsoft Excel nicht verwendet).
Sort | Range | IgnoreControlCharacters, IgnoreDiacritics und IgnoreKashida wurden entfernt (diese Argumente wurden in der deutschen Version von Microsoft Excel nicht verwendet).
TextToColumns | Range | DecimalSeparator und ThousandsSeparator wurden hinzugefügt.


Neue Methoden (alphabetische Liste)

In Microsoft Excel 2000 wurden viele neuen Visual Basic für Applikationen-Methoden zu vorhandenen Objekten hinzugefügt. Diese Methoden sind in der folgenden Tabelle aufgeführt (alphabetisch nach dem Namen der Methode sortiert).

Methode | Objekte
Add | PivotCaches, PivotTables
CalculateFull | Application
CreateNewDocument | Hyperlink
CreatePivotTable | PivotCache
Format | PivotTable
GetPhonetic | Application
PointsToScreenPixelsX | Window
PointsToScreenPixelsY | Window
RangeFromPoint | Window
ReloadAs | Workbook
ResetTimer | PivotCache, QueryTable
ScrollIntoView | Pane, Window
SetPhonetic | Range
WebPagePreview | Workbook


Neue Objekte

Objekte, die zu Visual Basic gegenüber Microsoft Excel 97 hinzugefügt wurden, sind in der folgenden Tabelle aufgeführt. Weitere Informationen zu den Änderungen des Microsoft Excel 97-Objektmodells finden Sie in den folgenden Themen:

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Objekte

Ausgeblendete Eigenschaften und Methoden

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Objekte | Beschreibung
CalculatedFields, CalculatedItems | Neue Funktionalität für PivotTable-Berichte
Comment, Comments | Neue Funktionalität für Kommentare; ersetzt Zellnotizen
ControlFormat, LinkFormat, OLEFormat | Anzeigen alter Microsoft Excel-Steuerelemente und OLE-Objekte in der Shapes-Auflistung
CustomView, CustomViews | Neues Feature für benutzerdefinierte Ansichten
DataTable | Diagrammdatentabelle
ChartFillFormat, FillFormat | Formatierung von Diagrammen und Formfülleffekten
FormatCondition, FormatConditions | Neues Feature für bedingte Formate
HPageBreak, HPageBreaks, VPageBreak, VPageBreaks | Neue Features für horizontale und vertikale Seitenumbrüche
Hyperlink, HyperLinks | Bereichs- und Formhyperlinks
LeaderLines | Diagrammführungslinien zum Verbinden von Datenbeschriftungen mit Datenpunkten
ODBCError, ODBCErrors, Parameter, Parameters, QueryTable, QueryTables, | Neue Features für parametrisierte Abfragen
PivotCache, PivotCaches, PivotFormula, PivotFormulas | Neue Features für PivotTable-Berichte
RecentFile, RecentFiles | Liste der zuletzt verwendeten Dateien
Adjustments, CalloutFormat, ChartColorFormat, ColorFormat, ConnectorFormat, FreeformBuilder, GroupShapes, LineFormat, PictureFormat, ShadowFormat, Shape, ShapeNode, ShapeNodes, Shapes, TextEfectFormat, TextFrame, ThreeDFormat | Neue Zeichnungsebenen- und Diagrammfülleffekte
Validation | Überprüfung des Datenbereichs


Neue Eigenschaften und Methoden (alphabetische Liste)

Eigenschaften und Methode, die zu vorhandenen Objekten gegenüber Microsoft Excel 97 hinzugefügt wurden, sind in der folgenden Tabelle aufgeführt (alphabetisch nach dem Namen der Eigenschaft oder Methode sortiert). Weitere Informationen zu den Änderungen des Microsoft Excel 97-Objektmodells finden Sie in den folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Ausgeblendete Objekte

Ausgeblendete Eigenschaften und Methoden

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Neue Eigenschaft oder Methode | Objekte
AcceptAllChanges-Methode | Workbook
AcceptLabelsInFormulas-Eigenschaft | Workbook
Add-Methode | PivotItems
AddComment-Methode | Range
AddToFavorites-Methode | Workbook
ApplyCustomType-Methode | Chart, Series
ApplyPictToEnd-Eigenschaft | Point, Series
ApplyPictToFront-Eigenschaft | Point, Series
ApplyPictToSides-Eigenschaft | Point, Series
Assistant-Eigenschaft | Application
AutoLoad-Eigenschaft | OLEObjects
AutoScaleFont-Eigenschaft | AxisTitle, ChartArea, ChartTitle, DataLabel, DataLabels, Legend, LegendEntry, TickLabels
AutoShow-Methode | PivotField
AutoShowCount-Eigenschaft | PivotField
AutoShowField-Eigenschaft | PivotField
AutoShowRange-Eigenschaft | PivotField
AutoShowType-Eigenschaft | PivotField
AutoSort-Methode | PivotField
AutoSortField-Eigenschaft | PivotField
AutoSortOrder-Eigenschaft | PivotField
AutoUpdateFrequency-Eigenschaft | Workbook
AutoUpdateSaveChanges-Eigenschaft | Workbook
BarShape-Eigenschaft | Chart, Series
BaseUnit-Eigenschaft | Axis
BaseUnitIsAuto-Eigenschaft | Axis
BubbleScale-Eigenschaft | ChartGroup
BubbleSizes-Eigenschaft | Series
BuiltIn-Eigenschaft | Style
CacheIndex-Eigenschaft | PivotTable
CalculatedFields-Methode | PivotTable
CalculatedItems-Methode | PivotField
CategoryType-Eigenschaft | Axis
ChangeHistoryDuration-Eigenschaft | Workbook
ChartType-Eigenschaft | Chart, Series
CircleInvalid-Methode | Worksheet
Clear-Methode | Legend
ClearCircles-Methode | Worksheet
ClearComments-Methode | Range
CodeName-Eigenschaft | Chart, Workbook, Worksheet
CommandBars-Eigenschaft | Application, Workbook
Comment-Eigenschaft | Range
Comments-Eigenschaft | Worksheet
ConflictResolution-Eigenschaft | Workbook
ControlCharacters-Eigenschaft | Application
CorrectCapsLock-Eigenschaft | AutoCorrect
CorrectSentenceCap-Eigenschaft | AutoCorrect
CursorMovement-Eigenschaft | Application
CustomViews-Eigenschaft | Workbook
DataTable-Eigenschaft | Chart
DefaultSaveFormat-Eigenschaft | Application
DefaultSheetDirection-Eigenschaft | Application
Delete-Methode | PivotField, PivotItem
DisplayCommentIndicator-Eigenschaft | Application
DisplayErrorString-Eigenschaft | PivotTable
DisplayNullString-Eigenschaft | PivotTable
DisplayPageBreaks-Eigenschaft | Worksheet
DisplayRightToLeft-Eigenschaft | Worksheet
DragToColumn-Eigenschaft | PivotField
DragToHide-Eigenschaft | PivotField
DragToPage-Eigenschaft | PivotField
DragToRow-Eigenschaft | PivotField
EnableCalculation-Eigenschaft | Worksheet
EnableDrilldown-Eigenschaft | PivotTable
EnableEvents-Eigenschaft | Application
EnableFieldDialog-Eigenschaft | PivotTable
EnableResize-Eigenschaft | Window
EnableSelection-Eigenschaft | Worksheet
EnableSound-Eigenschaft | Application
EnableWizard-Eigenschaft | PivotTable
ErrorString-Eigenschaft | PivotTable
Export-Methode | Chart
FileSearch-Eigenschaft | Application
Fill-Eigenschaft | AxisTitle, ChartArea, ChartTitle, DataLabel, DataLabels, DownBars, Floor, Legend, LegendKey, PlotArea, Point, Series, UpBars, Walls
FollowHyperlink-Methode | Workbook
FormatConditions-Eigenschaft | Range
Formula-Eigenschaft | PivotField, PivotItem
FormulaLabel-Eigenschaft | Range
GetChartElement-Methode | Chart
GetData-Methode | PivotTable
Has3DEffect-Eigenschaft | Series
Has3DShading-Eigenschaft | ChartGroup
HasDataTable-Eigenschaft | Chart
HasLeaderLines-Eigenschaft | Series
Height-Eigenschaft | Axis, LegendEntry, LegendKey
HighlightChangesOnScreen-Eigenschaft | Workbook
HighlightChangesOptions-Methode | Workbook
HPageBreaks-Eigenschaft | Charts, Sheets, Worksheet, Worksheets
Hyperlinks-Eigenschaft | Chart, Range, Worksheet
IndentLevel-Eigenschaft | Range, Style
Index-Eigenschaft | ChartGroup
InsertIndent-Methode | Range
InsideHeight-Eigenschaft | PlotArea
InsideLeft-Eigenschaft | PlotArea
InsideTop-Eigenschaft | PlotArea
InsideWidth-Eigenschaft | PlotArea
InvertIfNegative-Eigenschaft | Interior
IsAddin-Eigenschaft | Workbook
IsCalculated-Eigenschaft | PivotField, PivotItem
KeepChangeHistory-Eigenschaft | Workbook
LeaderLines-Eigenschaft | Series
Left-Eigenschaft | Axis, LegendEntry, LegendKey
LinkedCell-Eigenschaft | OLEObject
ListChangesOnNewSheet-Eigenschaft | Workbook
ListFillRange-Eigenschaft | OLEObject
ListFormulas-Methode | PivotTable
Location-Methode | Chart
MajorUnitScale-Eigenschaft | Axis
ManualUpdate-Eigenschaft | PivotTable
MarkerSize-Eigenschaft | LegendKey, Point, Series
MemoryUsed-Eigenschaft | PivotField
Merge-Methode | Range
MergeArea-Eigenschaft | Range
MergeCells-Eigenschaft | Range, Style
MergeLabels-Eigenschaft | PivotTable
MergeWorkbook-Methode | Workbook
MinorUnitScale-Eigenschaft | Axis
NewSeries-Methode | SeriesCollection
NullString-Eigenschaft | PivotTable
ODBCErrors-Eigenschaft | Application
ODBCTimeout-Eigenschaft | Application
PageFieldOrder-Eigenschaft | PivotTable
PageFieldStyle-Eigenschaft | PivotTable
PageFieldWrapCount-Eigenschaft | PivotTable
PageRangeCells-Eigenschaft | PivotTable
Paste-Methode | Floor, Walls
PersonalViewListSettings-Eigenschaft | Workbook
PersonalViewPrintSettings-Eigenschaft | Workbook
PictureType-Eigenschaft | Floor, LegendKey, Walls
PictureUnit-Eigenschaft | LegendKey, Walls
PivotCache-Methode | PivotTable
PivotCaches-Methode | Workbook
PivotFormulas-Eigenschaft | PivotTable
PivotSelect-Methode | PivotTable
PivotSelection-Eigenschaft | PivotTable
PivotTableSelection-Eigenschaft | Application
PivotTableWizard-Methode | PivotTable
PlotBy-Eigenschaft | Chart
Position-Eigenschaft | DataLabel, DataLabels
PreserveFormatting-Eigenschaft | PivotTable
PrintComments-Eigenschaft | PageSetup
ProgId-Eigenschaft | OLEObject
ProtectChartObject-Eigenschaft | ChartObject
ProtectData-Eigenschaft | Chart
ProtectFormatting-Eigenschaft | Chart
ProtectGoalSeek-Eigenschaft | Chart
ProtectSelection-Eigenschaft | Chart
ProtectSharing-Methode | Workbook
PurgeChangeHistoryNow-Methode | Workbook
QueryTable-Eigenschaft | Range
QueryTables-Eigenschaft | Worksheet
ReadingOrder-Eigenschaft | AxisTitle, ChartTitle, DataLabel, DataLabels, Range, Style, TickLabels
RecentFiles-Eigenschaft | Application
RecordCount-Eigenschaft | PivotItem
Refresh-Methode | Chart
RefreshAll-Methode | Workbook
RejectAllChanges-Methode | Workbook
RemoveUser-Methode | Workbook
ResetAllPageBreaks-Methode | Worksheet
ResetColors-Methode | Workbook
RollZoom-Eigenschaft | Application
SaveWorkspace-Methode | Application
ScrollArea-Eigenschaft | Worksheet
SecondaryPlot-Eigenschaft | Point
SecondPlotSize-Eigenschaft | ChartGroup
SelectionMode-Eigenschaft | PivotTable
ServerBased-Eigenschaft | PivotField
SetSourceData-Methode | Chart
Shadow-Eigenschaft | LegendKey, Point, Series
ShapeRange-Eigenschaft | ChartObject, ChartObjects, OLEObject, OLEObjects
Shapes-Eigenschaft | Chart, Worksheet
ShowAllItems-Eigenschaft | PivotField
ShowChartTipNames-Eigenschaft | Application
ShowChartTipValues-Eigenschaft | Application
ShowNegativeBubbles-Eigenschaft | ChartGroup
ShowWindow-Eigenschaft | Chart
ShrinkToFit-Eigenschaft | Range, Style
SizeRepresents-Eigenschaft | ChartGroup
SourceName-Eigenschaft | OLEObject, OLEObjects
SplitType-Eigenschaft | ChartGroup
SplitValue-Eigenschaft | ChartGroup
SubtotalHiddenPageItems-Eigenschaft | PivotTable
TableStyle-Eigenschaft | PivotTable
Tag-Eigenschaft | PivotTable
TemplateRemoveExtData-Eigenschaft | Workbook
Top-Eigenschaft | Axis, LegendEntry, LegendKey
UnMerge-Methode | Range
UnprotectSharing-Methode | Workbook
Update-Methode | PivotTable
UserControl-Eigenschaft | Application, Workbook
VacatedStyle-Eigenschaft | PivotTable
Validation-Eigenschaft | Range
Value2-Eigenschaft | Range
VBE-Eigenschaft | Application
VBProject-Eigenschaft | Workbook
View-Eigenschaft | Window
VPageBreaks-Eigenschaft | Charts, Sheets, Worksheet, Worksheets
Width-Eigenschaft | Axis, LegendEntry, LegendKey
WorksheetFunction-Eigenschaft | Application


Neue Eigenschaften (alphabetische Liste)

In Microsoft Excel 2000 wurden viele neuen Visual Basic für Applikationen-Eigenschaften zu vorhandenen Objekten hinzugefügt. Diese Eigenschaften sind in der folgenden Tabelle aufgeführt (alphabetisch nach dem Namen der Eigenschaft sortiert).

Eigenschaft | Objekte
AdjustColumnWidth | QueryTable
Alignment | TickLabels
AlternativeText | Shape, ShapeRange
AltHTML | OLEObject, OLEObjects
AnswerWizard | Application
AutoPercentEntry | Application
CalculationVersion | Application, Workbook
Caption | PivotField, PivotItem
COMAddIns | Application
CommandText | PivotCache, QueryTable
CommandType | PivotCache, QueryTable
CubeField | PivotField
CubeFields | PivotTable
CurrentPageName | PivotField
DefaultWebOptions | Application
Depth | TickLabels
DisplayRightToLeft | Worksheet
DisplayUnit | Axis
DisplayUnitCustom | Axis
DisplayUnitLabel | Axis
DragToData | PivotField
DrilledDown | PivotField, PivotItem
EmailSubject | Hyperlink
EnvelopeVisible | Workbook
ExtendList | Application
FeatureInstall | Application
GrandTotalName | PivotTable
HasDisplayUnitLabel | Axis
HasPivotFields | Chart
HTMLProject | Workbook
ID | Range
LanguageSettings | Application
LayoutBlankLine | PivotField
LayoutForm | PivotField
LayoutPageBreak | PivotField
LayoutSubtotalLocation | PivotField
LocalConnection | PivotCache
MaintainConnection | PivotCache, QueryTable
NumberFormatLocal | DataLabel, DataLabels, TickLabels
Offset | TickLabels
OLEDBErrors | Application
Phonetics | Range
PivotLayout | Chart
PreserveColumnInfo | QueryTable
PreserveFormatting | QueryTable
PrintTitles | PivotTable
ProductCode | Application
PublishObjects | Workbook
QueryType | PivotCache, QueryTable
Recordset | PivotCache
RefreshOnChange | Parameter
RefreshPeriod | PivotCache, QueryTable
RepeatItemsOnEachPrintedPage | PivotTable
ScreenTip | Hyperlink
Script | Shape
Scripts | Chart, Worksheet
ShowWindowsInTaskbar | Application
SmallGrid | PivotTable
SubtotalName | PivotField
Subtotals | PivotField
TextFileColumnDataTypes | QueryTable
TextFileCommaDelimiter | QueryTable
TextFileConsecutiveDelimiter | QueryTable
TextFileDecimalSeparator | QueryTable
TextFileFixedColumnWidths | QueryTable
TextFileOtherDelimiter | QueryTable
TextFileParseType | QueryTable
TextFilePlatform | QueryTable
TextFilePromptOnRefresh | QueryTable
TextFileSemicolonDelimiter | QueryTable
TextFileSpaceDelimiter | QueryTable
TextFileStartRow | QueryTable
TextFileTabDelimiter | QueryTable
TextFileTextQualifier | QueryTable
TextFileThousandsSeparator | QueryTable
TextToDisplay | Hyperlink
UseLocalConnection | PivotCache
UserLibraryPath | Application
VBASigned | Workbook
WebConsecutiveDelimitersAsOne | QueryTable
WebDisableDateRecognition | QueryTable
WebFormatting | QueryTable
WebOptions | Workbook
WebPreFormattedTextToColumns | QueryTable
WebSelectionType | QueryTable
WebSingleBlockTextImport | QueryTable


Neue Eigenschaften und Methoden (nach Objekten geordnet)

Eigenschaften und Methoden, die bereits bestehenden Objekten gegenüber Microsoft Excel 97 neu hinzugefügt wurden, sind in der folgenden Tabelle (nach Objekten geordnet) aufgeführt. Weitere Informationen über Änderungen am Microsoft Excel 97-Objektmodell finden Sie unter folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Objekte

Ausgeblendete Eigenschaften und Methoden

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95

Objekt | Neue Eigenschaften und Methoden
Application | Assistant-Eigenschaft, CommandBars-Eigenschaft, ControlCharacters-Eigenschaft, CursorMovement-Eigenschaft, DefaultSaveFormat-Eigenschaft, DefaultSheetDirection-Eigenschaft, DisplayCommentIndicator-Eigenschaft, EnableEvents-Eigenschaft, EnableSound-Eigenschaft, FileSearch-Eigenschaft, ODBCErrors-Eigenschaft, ODBCTimeout-Eigenschaft, PivotTableSelection-Eigenschaft, RecentFiles-Eigenschaft, RollZoom-Eigenschaft, SaveWorkspace-Methode, ShowChartTipNames-Eigenschaft, ShowChartTipValues-Eigenschaft, UserControl-Eigenschaft, VBE-Eigenschaft, WorksheetFunction-Eigenschaft
AutoCorrect | CorrectCapsLock-Eigenschaft, CorrectSentenceCap-Eigenschaft
Axis | BaseUnit-Eigenschaft, BaseUnitIsAuto-Eigenschaft, CategoryType-Eigenschaft, Height-Eigenschaft, Left-Eigenschaft, MajorUnitScale-Eigenschaft, MinorUnitScale-Eigenschaft, Top-Eigenschaft, Width-Eigenschaft
AxisTitle | AutoScaleFont-Eigenschaft, Fill-Eigenschaft, ReadingOrder-Eigenschaft
Chart | ApplyCustomType-Methode, BarShape-Eigenschaft, ChartType-Eigenschaft, CodeName-Eigenschaft, DataTable-Eigenschaft, Export-Methode, GetChartElement-Methode, HasDataTable-Eigenschaft, Hyperlinks-Eigenschaft, Location-Methode, PlotBy-Eigenschaft, ProtectData-Eigenschaft, ProtectFormatting-Eigenschaft, ProtectGoalSeek-Eigenschaft, ProtectSelection-Eigenschaft, Refresh-Methode, SetSourceData-Methode, Shapes-Eigenschaft, ShowWindow-Eigenschaft
ChartArea | AutoScaleFont-Eigenschaft, Fill-Eigenschaft
ChartGroup | BubbleScale-Eigenschaft, Has3DShading-Eigenschaft, Index-Eigenschaft, SecondPlotSize-Eigenschaft, ShowNegativeBubbles-Eigenschaft, SizeRepresents-Eigenschaft, SplitType-Eigenschaft, SplitValue-Eigenschaft
ChartObject | ProtectChartObject-Eigenschaft, ShapeRange-Eigenschaft
ChartObjects | ShapeRange-Eigenschaft
Charts | HPageBreaks-Eigenschaft, VPageBreaks-Eigenschaft
ChartTitle | AutoScaleFont-Eigenschaft, Fill-Eigenschaft, ReadingOrder-Eigenschaft
DataLabel | AutoScaleFont-Eigenschaft, Fill-Eigenschaft, Position-Eigenschaft, ReadingOrder-Eigenschaft
DataLabels | AutoScaleFont-Eigenschaft, Fill-Eigenschaft, Position-Eigenschaft, ReadingOrder-Eigenschaft
DownBars | Fill-Eigenschaft
Floor | Fill-Eigenschaft, Paste-Methode, PictureType-Eigenschaft
Interior | InvertIfNegative-Eigenschaft
Legend | AutoScaleFont-Eigenschaft, Clear-Methode, Fill-Eigenschaft
LegendEntry | AutoScaleFont-Eigenschaft, Height-Eigenschaft, Left-Eigenschaft, Top-Eigenschaft, Width-Eigenschaft
LegendKey | Fill-Eigenschaft, Height-Eigenschaft, Left-Eigenschaft, MarkerSize-Eigenschaft, PictureType-Eigenschaft, PictureUnit-Eigenschaft, Shadow-Eigenschaft, Top-Eigenschaft, Width-Eigenschaft
OLEObject | LinkedCell-Eigenschaft, ListFillRange-Eigenschaft, ProgId-Eigenschaft, ShapeRange-Eigenschaft, SourceName-Eigenschaft
OLEObjects | AutoLoad-Eigenschaft, ShapeRange-Eigenschaft, SourceName-Eigenschaft
PageSetup | PrintComments-Eigenschaft
PivotField | AutoShow-Methode, AutoShowCount-Eigenschaft, AutoShowField-Eigenschaft, AutoShowRange-Eigenschaft, AutoShowType-Eigenschaft, AutoSort-Methode, AutoSortField-Eigenschaft, AutoSortOrder-Eigenschaft, CalculatedItems-Methode, Delete-Methode, DragToColumn-Eigenschaft, DragToHide-Eigenschaft, DragToPage-Eigenschaft, DragToRow-Eigenschaft, Formula-Eigenschaft, IsCalculated-Eigenschaft, MemoryUsed-Eigenschaft, ServerBased-Eigenschaft, ShowAllItems-Eigenschaft
PivotItem | Delete-Methode, Formula-Eigenschaft, IsCalculated-Eigenschaft, RecordCount-Eigenschaft
PivotItems | Add-Methode
PivotTable | CacheIndex-Eigenschaft, CalculatedFields-Methode, DisplayErrorString-Eigenschaft, DisplayNullString-Eigenschaft, EnableDrilldown-Eigenschaft, EnableFieldDialog-Eigenschaft, EnableWizard-Eigenschaft, ErrorString-Eigenschaft, GetData-Methode, ListFormulas-Methode, ManualUpdate-Eigenschaft, MergeLabels-Eigenschaft, NullString-Eigenschaft, PageFieldOrder-Eigenschaft, PageFieldStyle-Eigenschaft, PageFieldWrapCount-Eigenschaft, PageRangeCells-Eigenschaft, PivotCache-Methode, PivotFormulas-Eigenschaft, PivotSelect-Methode, PivotSelection-Eigenschaft, PivotTableWizard-Methode, PreserveFormatting-Eigenschaft, SelectionMode-Eigenschaft, SubtotalHiddenPageItems-Eigenschaft, TableStyle-Eigenschaft, Tag-Eigenschaft, Update-Methode, VacatedStyle-Eigenschaft
PlotArea | Fill-Eigenschaft, InsideHeight-Eigenschaft, InsideLeft-Eigenschaft, InsideTop-Eigenschaft, InsideWidth-Eigenschaft
Point | ApplyPictToEnd-Eigenschaft, ApplyPictToFront-Eigenschaft, ApplyPictToSides-Eigenschaft, Fill-Eigenschaft, MarkerSize-Eigenschaft, SecondaryPlot-Eigenschaft, Shadow-Eigenschaft
Range | AddComment-Methode, ClearComments-Methode, Comment-Eigenschaft, FormatConditions-Eigenschaft, FormulaLabel-Eigenschaft, Hyperlinks-Eigenschaft, IndentLevel-Eigenschaft, InsertIndent-Methode, Merge-Methode, MergeArea-Eigenschaft, MergeCells-Eigenschaft, QueryTable-Eigenschaft, ReadingOrder-Eigenschaft, ShrinkToFit-Eigenschaft, UnMerge-Methode, Validation-Eigenschaft, Value2-Eigenschaft
Series | ApplyCustomType-Methode, ApplyPictToEnd-Eigenschaft, ApplyPictToFront-Eigenschaft, ApplyPictToSides-Eigenschaft, BarShape-Eigenschaft, BubbleSizes-Eigenschaft, ChartType-Eigenschaft, Fill-Eigenschaft, Has3DEffect-Eigenschaft, HasLeaderLines-Eigenschaft, LeaderLines-Eigenschaft, MarkerSize-Eigenschaft, Shadow-Eigenschaft
SeriesCollection | NewSeries-Methode
Sheets | HPageBreaks-Eigenschaft, VPageBreaks-Eigenschaft
Style | BuiltIn-Eigenschaft, IndentLevel-Eigenschaft, MergeCells-Eigenschaft, ReadingOrder-Eigenschaft, ShrinkToFit-Eigenschaft
TickLabels | AutoScaleFont-Eigenschaft, ReadingOrder-Eigenschaft
UpBars | Fill-Eigenschaft
Walls | Fill-Eigenschaft, Paste-Methode, PictureType-Eigenschaft, PictureUnit-Eigenschaft
Window | EnableResize-Eigenschaft, View-Eigenschaft
Workbook | AcceptAllChanges-Methode, AcceptLabelsInFormulas-Eigenschaft, AddToFavorites-Methode, AutoUpdateFrequency-Eigenschaft, AutoUpdateSaveChanges-Eigenschaft, ChangeHistoryDuration-Eigenschaft, CodeName-Eigenschaft, CommandBars-Eigenschaft, ConflictResolution-Eigenschaft, CustomViews-Eigenschaft, FollowHyperlink-Methode, HighlightChangesOnScreen-Eigenschaft, HighlightChangesOptions-Methode, IsAddin-Eigenschaft, KeepChangeHistory-Eigenschaft, ListChangesOnNewSheet-Eigenschaft, MergeWorkbook-Methode, PersonalViewListSettings-Eigenschaft, PersonalViewPrintSettings-Eigenschaft, PivotCaches-Methode, ProtectSharing-Methode, PurgeChangeHistoryNow-Methode, RefreshAll-Methode, RejectAllChanges-Methode, RemoveUser-Methode, ResetColors-Methode, TemplateRemoveExtData-Eigenschaft, UnprotectSharing-Methode, UserControl-Eigenschaft, VBProject-Eigenschaft
Worksheet | CircleInvalid-Methode, ClearCircles-Methode, CodeName-Eigenschaft, Comments-Eigenschaft, DisplayPageBreaks-Eigenschaft, DisplayRightToLeft-Eigenschaft, EnableCalculation-Eigenschaft, EnableSelection-Eigenschaft, HPageBreaks-Eigenschaft, Hyperlinks-Eigenschaft, QueryTables-Eigenschaft, ResetAllPageBreaks-Methode, ScrollArea-Eigenschaft, Shapes-Eigenschaft, VPageBreaks-Eigenschaft
Worksheets | HPageBreaks-Eigenschaft, VPageBreaks-Eigenschaft


Änderungen am Microsoft Excel 97-Objektmodell

An dem Microsoft Excel 97 Visual Basic-Objektmodell wurden umfangreiche Änderungen vorgenommen, um die neuen und verbesserten Features in der Anwendung zu unterstützen. Viele Objekte, Eigenschaften und Methoden wurden ersetzt. Aus Gründen der Abwärtskompatibilität wurden die meisten der ersetzten Komponenten ausgeblendet und nicht entfernt. Das bedeutet, dass sie im Objektbrowser standardmäßig nicht angezeigt werden, jedoch alter Code, der die ausgeblendeten Komponenten verwendet, ohne Änderungen einwandfrei funktioniert. Beim Schreiben von neuem Code sollten Sie jedoch die neuen Objekte, Eigenschaften und Methoden verwenden.

Die wesentlichen Änderungen von Visual Basic-Features gegenüber Microsoft Excel 97 sind in der folgenden Tabelle aufgeführt.

Feature | Beschreibung
Formen | Die Zeichnungsschicht (Kreisbogen, Ellipse, Linie und so weiter) wurde in allen Microsoft Office-Anwendungen durch ein konsistentes und verbessertes Objektmodell ersetzt.
Benutzerformulare, ActiveX-Steuerelemente | Bietet in allen Microsoft Office-Anwendungen eine konsistente und erweiterbare Oberfläche für Steuerelemente und Dialogfelder.
Befehlsleisten | Bietet in allen Microsoft Office-Anwendungen eine konsistente und erweiterbare Oberfläche für Menüs und Symbolleisten.

Weitere Informationen finden Sie in den folgenden Themen:

Neue Objekte

Neue Eigenschaften und Methoden (nach Objekten geordnet)

Neue Eigenschaften und Methoden (alphabetische Liste)

Ausgeblendete Objekte

Ausgeblendete Eigenschaften und Methoden

Methoden mit neuen Argumenten

Änderungen an Visual Basic in Microsoft Excel für Windows 95


Beispiel zur Activate-Methode

In diesem Beispiel wird Sheet1 aktiviert.

Worksheets("Sheet1").Activate

In diesem Beispiel wird der Bereich A1:C3 in Sheet1 markiert und dann B2 zur aktiven Zelle gemacht.

Worksheets("Sheet1").Activate
Range("A1:C3").Select
Range("B2").Activate

In diesem Beispiel wird die Arbeitsmappe MAPPE4.XLS aktiviert. Falls MAPPE4.XLS aus mehreren Fenstern besteht, wird das erste Fenster (MAPPE4.XLS:1) aktiviert.

Workbooks("BOOK4.XLS").Activate


 Add-Methode (ChartObjects-Auflistung)

Add-Methode (ChartObjects-Auflistung)

Erstellt ein neues eingebettetes Diagramm. Gibt ein ChartObject-Objekt zurück.

Syntax

Objekt.Add(Left, Top, Width, Height)

Objekt Erforderlich. Ein Ausdruck der ein ChartObjects-Objekt zurückgibt.

Left, Top Long erforderlich. Die Anfangskoordinaten des neuen Objekts (in Punkt), relativ zur oberen linken Ecke der Zelle A1 oder zur oberen linken Ecke eines Diagramms.

Width, Height Long erforderlich. Die Anfangsgröße des neuen Objekts in Punkt.


Beispiel zur Add-Methode (ChartObjects-Auflistung)

In diesem Beispiel wird ein neues eingebettetes Diagramm erstellt.

Set co = Sheets("Sheet1").ChartObjects.Add(50, 40, 200, 100)
co.Chart.ChartWizard Source:=Worksheets("Sheet1").Range("A1:B2"), _
    Gallery:=xlColumn, Format:=6, PlotBy:=xlColumns, _
    CategoryLabels:=1, SeriesLabels:=0, HasLegend:=1


Add-Methode (Charts-Auflistung)

Erstellt ein neues Diagrammblatt. Gibt ein Chart-Objekt zurück.

Syntax

Ausdruck.Add(Before, After, Count)

Ausdruck Erforderlich. Ein Ausdruck, der ein ein Charts-Objekt zurückgibt.

Before Variant optional. Ein Objekt, das das Blatt festlegt, vor dem das neue Blatt eingefügt wird.

After Variant optional . Ein Objekt, das das Blatt festlegt, nach dem das neue Blatt eingefügt wird.

Count Variant optional. Die Anzahl der Blätter, die hinzugefügt werden sollen. Der Standardwert ist Eins.

Anmerkungen

Wenn Before und After nicht angegeben werden, wird das neue Diagramm vor dem aktiven Blatt eingefügt.


Beispiel zur Add-Methode (Charts-Auflistung)

In diesem Beispiel wird ein leeres Diagrammblatt erstellt und vor dem letzten Tabellenblatt eingefügt.

ActiveWorkbook.Charts.Add Before:=Worksheets(Worksheets.Count)


Add-Methode (CustomViews-Objekt)

Erstellt eine neue benutzerdefinierte Ansicht. Gibt ein CustomView-Objekt zurück, das die neue Ansicht darstellt.

Syntax

Ausdruck.Add(ViewName, PrintSettings, RowColSettings)

Ausdruck Erforderlich. Ein Ausdruck, der ein CustomViews-Objekt zurückgibt.

ViewName String erforderlich. Der Name der neuen Ansicht.

PrintSettings Variant optional. True, falls Druckeinstellungen in der benutzerdefinierten Ansicht enthalten sind.

RowColSettings Variant optional. True, falls Einstellungen zu ausgeblendeten Zeilen und Spalten (einschließlich Filterinformationen) in der benutzerdefinierten Ansicht enthalten sind.


Beispiel zur Add-Methode (CustomViews-Objekt)

In diesem Beispiel wird die neue benutzerdefinierte Ansicht "Summary" in der aktiven Arbeitsmappe erstellt.

ActiveWorkbook.CustomViews.Add "Summary", True, True


Add-Methode (FormatConditions-Auflistung)

Fügt ein neues bedingtes Format hinzu. Gibt ein FormatCondition-Objekt zurück, das das neue bedingte Format darstellt.

Syntax

Ausdruck.Add(Type, Operator, Formula1, Formula2)

Ausdruck Erforderlich. Ein Ausdruck der ein FormatConditions-Objekt zurückgibt.

Type Long erforderlich. Legt fest, ob das bedingte Format auf einem Zellwert oder auf einem Ausdruck basiert. Dies kann eine der beiden folgenden XlFormatConditionType-Konstanten sein: xlCellValue oder xlExpression.

Operator Variant optional. Der Operator für das bedingte Format. Dies kann eine der folgenden XlFormatConditionOperator-Konstanten sein: xlBetween, xlEqual, xlGreater, xlGreaterEqual, xlLess, xlLessEqual, xlNotBetween oder xlNotEqual. Wenn Type den Wert xlExpression besitzt, wird das Operator-Argument ignoriert.

Formula1 Variant optional. Der mit dem bedingten Format verknüpfte Wert oder Ausdruck. Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein.

Formula2 Variant optional. Der mit dem zweiten Teil des bedingten Formats verknüpfte Ausdruck, wenn Operator den Wert xlBetween oder xlNotBetween besitzt (andernfalls wird dieses Argument ignoriert). Dies kann ein konstanter Wert, ein Zeichenfolgenwert, ein Zellbezug oder eine Formel sein.

Anmerkungen

Sie können für einen Bereich höchstens drei bedingte Formate definieren. Verwenden Sie die Modify-Methode, um ein bestehendes bedingtes Format zu ändern, oder die Delete-Methode, um vor dem Hinzufügen eines neuen Formats ein bestehendes zu löschen.


Beispiel zur Add-Methode (FormatConditions-Auflistung)

In diesem Beispiel wird den Zellen E1:E10 ein bedingtes Format hinzugefügt.

With Worksheets(1).Range("e1:e10").FormatConditions _
        .Add(xlCellValue, xlGreater, "=$a$1")
    With .Borders
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = 6
    End With
    With .Font
        .Bold = True
        .ColorIndex = 3
    End With
End With


Add-Methode (HPageBreaks-Auflistung)

Fügt einen horizontalen Seitenwechsel ein. Gibt ein HPageBreak-Objekt zurück.

Syntax

Objekt.Add(Before)

Objekt Erforderlich. Ein Ausdruck der ein HPageBreaks-Objekt zurückgibt.

Before Object erforderlich. Ein Range-Objekt. Der Bereich, über dem der neue Seitenwechsel eingefügt wird.


Beispiel zur Add-Methode (HPageBreaks-Auflistung)

In diesem Beispiel wird über der Zelle F25 ein horizontaler und links neben ihr ein vertikaler Seitenwechsel eingefügt.

With Worksheets(1)
    .HPageBreaks.Add .Range("F25")
    .VPageBreaks.Add .Range("F25")
End With


Add-Methode (Hyperlinks-Auflistung)

Fügt dem angegebenen Bereich oder der angegebenen Form einen Hyperlink hinzu. Gibt ein Hyperlink-Objekt zurück.

Syntax

Objekt.Add(Anchor, Address, SubAddress, ScreenTip, TextToDisplay)

Objekt Erforderlich. Ein Ausdruck der ein Hyperlinks-Objekt zurückgibt.

Anchor -Objekt erforderlich. Die Verankerung des Hyperlinks. Kann ein Range- oder ein Shape-Objekt sein.

Address String erforderlich. Die Adresse des Hyperlinks.

SubAddress Variant optional. Die Unteradresse des Hyperlinks.

ScreenTip Variant optional. Das anzuzeigende QuickInfo, wenn sich der Mauszeiger auf dem Hyperlink befindet.

TextToDisplay Variant optional. Der Text, der für den Hyperlink angezeigt werden soll.


Beispiel zur Add-Methode (Hyperlinks-Auflistung)

In diesem Beispiel wird der Zelle A5 ein Hyperlink hinzugefügt.

With Worksheets(1)
    .Hyperlinks.Add Anchor:=.Range("a5"), _
        Address:="http://example.microsoft.com", _
        ScreenTip:="Microsoft Web Site", _
        TextToDisplay:="Microsoft"
End With

In diesem Beispiel wird der Zelle A5 ein E-Mail-Hyperlink hinzugefügt.

With Worksheets(1)
    .Hyperlinks.Add Anchor:=.Range("a5"), _
        Address:="mailto:someone@microsoft.com?subject=hello", _
        ScreenTip:="Write us today", _
        TextToDisplay:="Support"
End With


Add-Methode (Names-Auflistung)

Legt einen neuen Namen fest. Gibt ein Name-Objekt zurück.

Syntax

Ausdruck.Add(Name, RefersTo, Visible, MacroType, ShortcutKey, Category, NameLocal, RefersToLocal, CategoryLocal, RefersToR1C1, RefersToR1C1Local)

Ausdruck Erforderlich. Ein Ausdruck, der ein Names-Objekt zurückgibt.

Name Variant optional. Erforderlich, wenn NameLocal nicht angegeben wird. Der als Name zu verwendende Text (in der Sprache des Makros). Namen dürfen keine Leerzeichen enthalten und nicht mit Zellbezügen zu verwechseln sein.

RefersTo Variant optional. Erforderlich, wenn nicht eines der anderen RefersTo-Argumente angegeben wird. Beschreibt, worauf sich der Name bezieht (in der Sprache des Makros unter Verwendung der A1-Schreibweise).

Visible Variant optional. Wenn True, wird der Name normal angegeben. Wenn False, wird der Name als ausgeblendeter Name festgelegt (er wird dann nicht in den Dialogfeldern Namen definieren, Namen einfügen oder Gehe zu angezeigt). Der Standardwert ist True.

MacroType Variant optional. Der Makrotyp, gemäß der folgenden Tabelle.

Wert | Bedeutung
1 | benutzerdefinierte Funktion (Function-Prozedur)
2 | Makro (Sub-Prozedur)
3 oder nicht angegeben | keine Bedeutung (der Name hat keinen Bezug auf eine benutzerdefinierte Funktion bzw. auf ein benutzerdefiniertes Makro.)

ShortcutKey Variant optional. Der Shortcut des Makros. Es muss sich um einen einzelnen Buchstaben, z.B. "z" oder "Z" handeln. Dieses Argument gilt nur für Befehlsmakros.

Category Variant optional. Die Kategorie des Makros oder der Funktion, wenn MacroType 1 oder 2 ist. Die Kategorie wird im Funktions-Assistenten verwendet. Der Bezug auf bestehende Funktionen kann in Form einer Nummer (beginnend mit 1) oder eines Namens (in der Sprache des Makros) hergestellt werden. Microsoft Excel erstellt eine neue Kategorie, wenn die angegebene Kategorie noch nicht existiert.

NameLocal Variant optional. Erforderlich, wenn Name nicht angegeben ist. Der als Name zu verwendende Text (in der Sprache des Benutzers). Namen dürfen keine Leerzeichen enthalten und nicht mit Zellbezügen zu verwechseln sein.

RefersToLocal Variant optional. Erforderlich, es sei denn, eines der anderen RefersTo-Argumente ist angegeben. Beschreibt, worauf sich der Name bezieht (in der Sprache des Benutzers unter Verwendung der A1-Schreibweise).

CategoryLocal Variant optional. Erforderlich, wenn Category nicht angegeben ist. Text, der die Kategorie einer benutzerdefinierten Funktion in der Sprache des Benutzers angibt.

RefersToR1C1 Variant optional. Erforderlich, es sei denn, eines der anderen RefersTo-Argumente ist angegeben. Beschreibt, worauf sich der Name bezieht (in der Sprache des Makros unter Verwendung der Z1S1-Schreibweise).

RefersToR1C1Local Variant optional. Erforderlich, es sei denn, eines der anderen RefersTo-Argumente ist angegeben. Beschreibt, worauf sich der Name bezieht (in der Sprache des Benutzers unter Verwendung der Z1S1-Schreibweise).


Beispiel zur Add-Methode (Names-Auflistung)

In diesem Beispiel wird ein neuer Name für den Bereich A1:D3 in Sheet1 definiert.

ActiveWorkbook.Names.Add _
    Name:="tempRange", _
    RefersTo:="=Sheet1!$A$1:$D$3"


Add-Methode (Parameters-Auflistung)

Erstellt einen neuen Abfrageparameter. Gibt ein Parameter-Objekt zurück, das den neuen Abfrageparameter darstellt.

Syntax

Ausdruck.Add(Name, DataType)

Ausdruck Erforderlich. Ein Ausdruck, der ein Parameters-Objekt zurückgibt.

Name String erforderlich. Der Name des angegebenen Parameters. Der Name muss der Parameterangabe in der SQL-Anweisung entsprechen.

DataType Variant optional. Der Datentyp des Parameters. Dies kann eine der folgenden XlParameterDataType-Konstanten sein.

xlParamTypeBigInt

xlParamTypeBinary

xlParamTypeBit

xlParamTypeChar

xlParamTypeDate

xlParamTypeDecimal

xlParamTypeDouble

xlParamTypeFloat

xlParamTypeInteger

xlParamTypeLongVarBinary

xlParamTypeWChar

 xlParamTypeNumeric

xlParamTypeLongVarChar

xlParamTypeReal

xlParamTypeSmallInt

xlParamTypeTime

xlParamTypeTimeStamp

xlParamTypeTinyInt

xlParamTypeUnknown

xlParamTypeVarBinary

xlParamTypeVarChar

Diese Werte entsprechen ODBC-Datentypen. Sie geben den Wertetyp an, den der ODBC-Treiber erwartet. Microsoft Excel und der ODBC-Treiber-Manager machen aus dem in Microsoft Excel angegebenen Wert den korrekten Datentyp für den Treiber.


Beispiel zur Add-Methode (Parameters-Auflistung)

In diesem Beispiel wird die SQL-Anweisung der ersten Abfragetabelle geändert. Der Teil "(city=?)" gibt an, dass es sich bei der Abfrage um eine Parameterabfrage handelt. Außerdem wird in dem Beispiel als Wert für "City" die Konstante "Oakland" festgelegt.

Set qt = Sheets("sheet1").QueryTables(1)
qt.Sql = "SELECT * FROM authors  WHERE (city=?)"
Set param1 = qt.Parameters.Add("City Parameter", _
    xlParamTypeVarChar)
param1.SetParam xlConstant, "Oakland"
qt.Refresh


Add-Methode (Phonetics-Auflistung)

Fügt phonetischen Text zu der angegebenen Zelle hinzu und erstellt ein neues Phonetic-Objekt.

Syntax

Ausdruck.Add(Start, Length, Text)

Ausdruck Ein Ausdruck, der ein Phonetics-Objekt zurückgibt.

Start Long erforderlich. Die Position, die das erste Zeichen in der angegebenen Zelle darstellt.

Length Long erforderlich. Die Anzahl der Zeichen von der Start-Position bis zum Ende des Textes in der Zelle.

Text String erforderlich. Zusammengefasst die Zeichen, die den phonetischen Text in der Zelle darstellen.


Beispiel zur Add-Methode (Phonetics-Auflistung)

In diesem Beispiel werden drei phonetische Textzeichenfolgen zu der aktiven Zelle hinzugefügt. In dem Beispiel wird der Zeichentyp auf Hiragana, die Schriftfarbe auf Blau und der Text auf sichtbar eingestellt.

ActiveCell.FormulaR1C1 = "  toukyouto   toukyouto   toukyouto   shibuyaku   shibuyaku   shibuyaku   yoyogi   yoyogi   yoyogi "
ActiveCell.Phonetics.Add Start:=1, Length:=3, Text:="  toukyouto    toukyouto   toukyouto    toukyouto   toukyouto    toukyouto "
ActiveCell.Phonetics.Add Start:=4, Length:=3, Text:="  shibuyaku    shibuyaku   shibuyaku    shibuyaku "
ActiveCell.Phonetics.Add Start:=7, Length:=3, Text:="  yoyogi   yoyogi   yoyogi "
ActiveCell.Phonetics.CharacterType = xlHiragana
ActiveCell.Phonetics.Font.Color = vbBlue
ActiveCell.Phonetics.Visible = True


Add-Methode (PivotCaches-Auflistung)

Fügt einen neuen PivotTable-Cache zu einer PivotCaches-Auflistung hinzu. Gibt ein PivotCache-Objekt zurück.

Syntax

Ausdruck.Add(SourceType, SourceData)

Ausdruck Ein Ausdruck, der ein PivotCaches-Objekt zurückgibt.

SourceType XlPivotTableSourceType optional. Die Quelle der PivotTable-Cachedaten. Kann eine der in der folgenden Tabelle aufgeführten XlPivotTableSourceType-Konstanten sein.

Konstante | Beschreibung
xlConsolidation | Mehrere Konsolidierungsbereiche
xlDatabase | Eine Microsoft Excel-Liste oder -Datenbank
xlExternal | Daten von einer anderen Anwendung (SourceData darf nicht angegeben werden)
xlPivotTable | Gleiche Datenquelle wie ein anderer PivotTable-Bericht

SourceData Variant optional. Die Daten für den neuen PivotTable-Cache. Dieses Argument ist erforderlich, falls SourceType nicht xlExternal ist. Kann ein Range-Objekt, eine Matrix von Bereichen oder eine Textkonstante sein, die den Namen eines vorhandenen PivotTable-Berichts darstellt. Bei einer externen Datenbank handelt es sich um eine Matrix mit zwei Elementen. Das erste Element ist die Verbindungszeichenfolge, die den Provider der Daten angibt. Das zweite Element ist die SQL-Abfragezeichenfolge, die zum Abrufen der Daten verwendet wird. Wenn Sie dieses Argument angeben, müssen Sie auch SourceType angeben.

Anmerkungen

Falls auf den PivotTable-Cache kein Verweis von einem PivotTable-Objekt erfolgt, wird der PivotTable-Cache vor dem Speichern der Arbeitsmappe automatisch gelöscht.


 Beispiel zur Add-Methode (PivotCaches-Auflistung)

Beispiel zur Add-Methode (PivotCaches-Auflistung)

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf dem Cache basiert.

With ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = True
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:= "PivotTable1"
End With
With ActiveSheet.PivotTables("PivotTable1")
    .SmallGrid = False
    .PivotCache.RefreshPeriod = 0
    With .CubeFields("[state]")
        .Orientation = xlColumnField
        .Position = 0
    End With
    With .CubeFields("[Measures].[Count Of au_id]")
        .Orientation = xlDataField
        .Position = 0
    End With
End With

In diesem Beispiel wird mit Hilfe einer ADO-Verbindung zu Microsoft Jet ein neuer PivotTable-Cache erstellt und dann in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht, der auf dem Cache basiert.

Dim cnnConn As ADODB.Connection
Dim rstRecordset As ADODB.Recordset
Dim cmdCommand As ADODB.Command

' Open the connection.
Set cnnConn = New ADODB.Connection
With cnnConn
    .ConnectionString = _
        "Provider=Microsoft.Jet.OLEDB.4.0"
    .Open "C:\perfdate\record.mdb"
End With

' Set the command text.
Set cmdCommand = New ADODB.Command
Set cmdCommand.ActiveConnection = cnnConn
With cmdCommand
    .CommandText = "Select Speed, Pressure, Time From DynoRun"
    .CommandType = adCmdText
    .Execute
End With

' Open the recordset.
Set rstRecordset = New ADODB.Recordset
Set rstRecordset.ActiveConnection = cnnConn
rstRecordset.Open cmdCommand

' Create a PivotTable cache and report.
Set objPivotCache = ActiveWorkbook.PivotCaches.Add( _
    SourceType:=xlExternal)
Set objPivotCache.Recordset = rstRecordset
With objPivotCache
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:="Performance"
End With

With ActiveSheet.PivotTables("Performance")
    .SmallGrid = False
    With .PivotFields("Pressure")
        .Orientation = xlRowField
        .Position = 1
    End With
    With .PivotFields("Speed")
        .Orientation = xlColumnField
        .Position = 1
    End With
    With .PivotFields("Time")
        .Orientation = xlDataField
        .Position = 1
    End With
End With

' Close the connections and clean up.
cnnConn.Close
Set cmdCommand = Nothing
Set rstRecordSet = Nothing
Set cnnConn = Nothing


Add-Methode (PivotFormulas-Auflistung)

Erstellt eine neue PivotTable-Formel. Gibt ein PivotFormula-Objekt zurück.

Syntax

Objekt.Add(Formula)

Objekt Erforderlich. Ein Ausdruck der ein PivotFormulas-Objekt zurückgibt.

Formula String erforderlich. Die neue PivotTable-Formel.


Beispiel zur Add-Methode (PivotFormulas-Auflistung)

In diesem Beispiel wird eine neue PivotTable-Formel für den ersten PivotTable-Bericht im ersten Tabellenblatt erstellt.

Worksheets(1).PivotTables(1).PivotFormulas _
    .Add "Year['1998'] Apples = (Year['1997'] Apples) * 2"


Add-Methode (PivotItems-Auflistung)

Erstellt ein neues PivotTable-Element. Gibt ein PivotItem-Objekt zurück.

Syntax

Objekt.Add(Name)

Objekt Erforderlich. Ein Ausdruck, der ein PivotFormulas-Objekt zurückgibt.

Name String erforderlich. Der Name des neuen PivotTable-Elements.


Beispiel zur Add-Methode (PivotItems-Auflistung)

In diesem Beispiel wird ein neues PivotTable-Element im ersten PivotTable-Bericht des ersten Tabellenblatts erstellt.

Worksheets(1).PivotTables(1).PivotFields("Year").Add "1998"


Add-Methode (PivotTable-Auflistung)

Fügt einen neuen PivotTable-Bericht hinzu. Gibt ein PivotTable-Objekt zurück.

Syntax

Ausdruck.Add(PivotCache, TableDestination, TableName, ReadData)

Ausdruck Ein Ausdruck, der ein PivotTables-Objekt zurückgibt.

PivotCache PivotCache erforderlich. Der PivotTable-Cache, auf dem der neue PivotTable-Bericht basiert. Der Cache stellt die Daten für den Bericht zur Verfügung.

TableDestination Variant erforderlich. Die Zelle in der oberen linken Ecke des Zielbereichs des PivotTable-Berichts (der Bereich im Tabellenblatt, in dem sich der resultierende Bericht befinden wird). Sie müssen einen Zielbereich in dem Arbeitsblatt angeben, das das PivotTables-Objekt enthält, das durch Ausdruck angegeben wurde.

TableName Variant optional. Der Name des neuen PivotTable-Berichts.

ReadData Variant optional. True, damit ein PivotTable-Cache erstellt wird, der alle Datensätze aus der externen Datenbank enthält. Dieser Cache kann sehr groß sein. False, damit die Festlegung einiger Felder als serverbasierte Seitenfelder ermöglicht wird, bevor die eigentlichen Daten gelesen werden.


 Beispiel zur Add-Methode (PivotTable-Auflistung)

Beispiel zur Add-Methode (PivotTable-Auflistung)

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A1" im ersten Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf dem Cache basiert.

Set objPC = _
    ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)

With objPC
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = True
End With

Set objPT = Worksheets(1).PivotTables _
    .Add(PivotCache:=objPC, _
    TableDestination:=Range("A1"))

In diesem Beispiel wird mit Hilfe einer ADO-Verbindung zu Microsoft Jet ein neuer PivotTable-Cache erstellt und dann in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht, der auf dem Cache basiert.

Dim cnnConn As ADODB.Connection
Dim rstRecordset As ADODB.Recordset
Dim cmdCommand As ADODB.Command

' Open the connection.
Set cnnConn = New ADODB.Connection
With cnnConn
    .ConnectionString = _
        "Provider=Microsoft.Jet.OLEDB.4.0"
    .Open "C:\perfdate\record.mdb"
End With

' Set the command text.
Set cmdCommand = New ADODB.Command
Set cmdCommand.ActiveConnection = cnnConn
With cmdCommand
    .CommandText = "Select Speed, Pressure, Time From DynoRun"
    .CommandType = adCmdText
    .Execute
End With

' Open the recordset.
Set rstRecordset = New ADODB.Recordset
Set rstRecordset.ActiveConnection = cnnConn
rstRecordset.Open cmdCommand

' Create a PivotTable cache and report.
Set objPivotCache = ActiveWorkbook.PivotCaches.Add( _
    SourceType:=xlExternal)
Set objPivotCache.Recordset = rstRecordset

ActiveSheet.PivotTables.Add _
    PivotCache:=objPivotCache, _
    TableDestination:=Range("A3"), _
    TableName:="Performance"

With ActiveSheet.PivotTables("Performance")
    .SmallGrid = False
    With .PivotFields("Pressure")
        .Orientation = xlRowField
        .Position = 1
    End With
    With .PivotFields("Speed")
        .Orientation = xlColumnField
        .Position = 1
    End With
    With .PivotFields("Time")
        .Orientation = xlDataField
        .Position = 1
    End With
End With

' Close the connections and clean up.
cnnConn.Close
Set cmdCommand = Nothing
Set rstRecordSet = Nothing
Set cnnConn = Nothing


Add-Methode (PublishObjects-Auflistung)

Erstellt ein Objekt, das ein Element in einem Dokument darstellt, das in einer Webseite gespeichert wurde. Solche Objekte erleichtern nachfolgende Aktualisierungen der Webseite, wenn in Microsoft Excel automatisierte Änderungen an dem Dokument vorgenommen werden. Gibt ein PublishObject-Objekt zurück.

Syntax

Ausdruck.Add(SourceType, Filename, Sheet, Source, HtmlType, DivID, Title)

Ausdruck Ein Ausdruck, der ein PublishObjects-Objekt zurückgibt.

SourceType XlSourceType erforderlich. Bezeichnet das Quellobjekt. Kann eine der in der folgenden Tabelle aufgeführten XlSourceType-Konstanten sein.

Konstante | Beschreibung
xlSourceAutoFilter | Ein AutoFilter-Bereich
xlSourceChart | Ein Diagramm
xlSourcePivotTable | Ein PivotTable-Bericht
xlSourcePrintArea | Ein Zellbereich, der zum Drucken markiert ist
xlSourceQuery | Eine Abfragetabelle (externer Datenbereich)
xlSourceRange | Ein Zellbereich
xlSourceSheet | Ein ganzes Tabellenblatt

Filename String erforderlich. Der URL (im Intranet oder World Wide Web) oder Pfad (lokal oder im Netzwerk), an dem das Quellobjekt gespeichert wurde.

Sheet Variant optional. Der Name des Tabellenblatts, das als Webseite gespeichert wurde.

Source Variant optional. Ein eindeutiger Name, der zur Kennzeichnung von Elementen verwendet wird, die eine der folgenden Konstanten als SourceType-Argument besitzen können: xlSourceAutoFilter, xlSourceChart, xlSourcePivotTable, xlSourcePrintArea, xlSourceQuery oder xlSourceRange. Wenn SourceType gleich xlSourceRange ist, gibt Source einen Bereich an, bei dem es sich um einen definierten Namen handeln kann. Wenn SourceType gleich xlSourceChart, xlSourcePivotTable oder xlSourceQuery ist, gibt Source den Namen eines Diagramms, eines PivotTable-Berichts bzw. einer Abfragetabelle an.

HtmlType Variant optional. Gibt an, ob das Element als interaktive Microsoft Office-Webkomponente oder als statischer Text mit statischen Bildern gespeichert werden soll. Kann eine der in der folgenden Tabelle aufgeführten XlHTMLType-Konstanten sein.

Konstante | Beschreibung
xlHTMLCalc | Eine Tabellenkomponente
xlHTMLChart | Eine Diagrammkomponente
xlHTMLList | Eine PivotTable-Komponente
xlHTMLStatic | Statischer (nicht interaktiver) HTML-Code

DivID Variant optional. Der eindeutige Bezeichner, der in dem HTML DIV-Tag verwendet wird, um das Element auf der Webseite zu kennzeichnen.

Title Variant optional. Der Titel der Webseite.


Beispiel zur Add-Methode (PublishObjects-Auflistung)

In diesem Beispiel wird der Bereich "D5:D9" im Tabellenblatt "First Quarter" in der aktiven Arbeitsmappe in einer Webseite mit der Bezeichnung "Stockreport.htm" gespeichert. Die Tabellenkomponente wird verwendet, um die Webseite mit Interaktivität zu erweitern.

ActiveWorkbook.PublishObjects.Add( _
    SourceType:=xlSourceRange, _
    Filename:="\\Server2\Q1\Stockreport.htm", _
    Sheet:="First Quarter", _
    Source:="D5:D9", _
    HTMLType:=xlHTMLCalc).Publish


Add-Methode (QueryTables-Auflistung)

Erstellt eine neue Abfragetabelle. Gibt ein QueryTable-Objekt zurück, das die neue Abfragetabelle darstellt.

Syntax

Ausdruck.Add(Connection, Destination, Sql)

Ausdruck Erforderlich. Ein Ausdruck, der ein QueryTables-Objekt zurückgibt.

Connection Variant erforderlich. Die Datenquelle der Abfragetabelle. Dies kann Folgendes sein:

  • Eine Zeichenfolge mit einer OLE DB- oder ODBC-Verbindungszeichenfolge. Die ODBC-Verbindungszeichenfolge besitzt die Form "ODBC;<Verbindungszeichenfolge>".

  • Ein QueryTable-Objekt, von dem die Abfrageinformation am Anfang kopiert wird. Dies beinhaltet die Verbindungszeichenfolge und den SQL-Text, jedoch nicht den Destination-Bereich. Bei Angabe des QueryTable-Objekts wird das Argument Sql ignoriert.

  • Ein ADO- oder DAO-RecordSet-Objekt. Die Daten werden aus der ADO- oder DAO-Datensatzgruppe gelesen. Microsoft Excel behält die Datensatzgruppe, bis die Abfragetabelle gelöscht oder die Verbindung geändert wird. Die sich ergebende Abfragetabelle kann nicht bearbeitet werden.

  • Eine Webabfrage. Eine Zeichenfolge der Form "URL;<url>", wobei "URL;" erforderlich, nicht aber lokalisiert ist, und die übrige Zeichenfolge für den URL der Webabfrage verwendet wird.

  • Abfrage. Eine Zeichenfolge der Form "FINDER;<Dateipfad zu Abfrage>", wobei "FINDER;" erforderlich, nicht aber lokalisiert ist. Die übrige Zeichenfolge gibt Pfad und Dateinamen einer Abfragedatei (*.dqy oder *.iqy) an. Die Datei wird gelesen, wenn die Add-Methode ausgeführt wird; danach folgende Aufrufe der Connection-Eigenschaft der Abfragetabelle geben Zeichenfolgen zurück, die mit "ODBC;" bzw. "URL;" beginnen.

  • Eine Textdatei. Eine Zeichenfolge in der Form "TEXT;<Pfad und Name der Textdatei>", wobei "TEXT" erforderlich, aber nicht lokalisiert ist.

Destination Range erforderlich. Die Zelle in der oberen linken Ecke des Zielbereichs der Abfragetabelle (der Bereich, in dem die sich ergebende Abfragetabelle positioniert wird). Der Zielbereich muss sich auf dem Tabellenblatt befinden, das das mit Ausdruck festgelegte QueryTables-Objekt enthält.

Sql Variant optional. Die Zeichenfolge der SQL-Abfrage, die der ODBC-Datenquelle übergeben werden soll. Dieses Argument ist optional, wenn Sie eine ODBC-Datenquelle verwenden (wenn Sie es nicht an dieser Stelle angeben, sollten Sie es durch die Sql-Eigenschaft festlegen, bevor die Tabelle aktualisiert wird). Dieses Argument kann nicht verwendet werden, wenn ein QueryTable-Objekt, eine Textdatei oder ADO- bzw. DAO-Recordset-Objekt als Datenquelle festgelegt ist.

Anmerkungen

Eine durch diese Methode erstellte Abfrage wird erst ausgeführt, wenn die Refresh-Methode aufgerufen wird.


Beispiel zur Add-Methode (QueryTables-Auflistung)

In diesem Beispiel wird eine Abfragetabelle erstellt, der eine ADO-Datensatzgruppe zu Grunde liegt. In dem Beispiel werden die vorhandenen Einstellungen für Spaltensortierung und -filterung sowie Layoutinformationen aus Gründen der Abwärtskompatibilität beibehalten.

Dim cnnConnect As ADODB.Connection
Dim rstRecordset As ADODB.Recordset

Set cnnConnect = New ADODB.Connection
cnnConnect.Open "Provider=SQLOLEDB;" & _
    "Data Source=srvdata;" & _
    "User ID=testac;Password=4me2no;"

Set rstRecordset = New ADODB.Recordset
rstRecordset.Open _
    Source:="Select Name, Quantity, Price From Products", _
    ActiveConnection:=cnnConnect, _
    CursorType:=adOpenDynamic, _
    LockType:=adLockReadOnly, _
    Options:=adCmdText

With ActiveSheet.QueryTables.Add( _
        Connection:=rstRecordset, _
        Destination:=Range("A1"))
    .Name = "Contact List"
    .FieldNames = True
    .RowNumbers = False
    .FillAdjacentFormulas = False
    .PreserveFormatting = True
    .RefreshOnFileOpen = False
    .BackgroundQuery = True
    .RefreshStyle = xlInsertDeleteCells
    .SavePassword = True
    .SaveData = True
    .AdjustColumnWidth = True
    .RefreshPeriod = 0
    .PreserveColumnInfo = True
    .Refresh BackgroundQuery:=False
End With

In diesem Beispiel wird eine Textdatei mit fester Breite in eine neue Abfragetabelle importiert. Die erste Spalte in der Textdatei ist fünf Zeichen breit und wird als Text importiert. Die zweite Spalte ist vier Zeichen breit und wird übergangen. Der Rest der Textdatei wird in die dritte Spalte importiert, wobei das Standardformat verwendet wird.

Set shFirstQtr = Workbooks(1).Worksheets(1)
Set qtQtrResults = shFirstQtr.QueryTables.Add( _
    Connection := "TEXT;C:\My Documents\19980331.txt",
    Destination := shFirstQtr.Cells(1,1))
With qtQtrResults
    .TextFileParsingType = xlFixedWidth
    .TextFileFixedColumnWidths := Array(5,4)
    .TextFileColumnDataTypes := _
        Array(xlTextFormat, xlSkipColumn, xlGeneralFormat)
    .Refresh
End With

In diesem Beispiel wird auf dem aktiven Tabellenblatt eine neue Abfragetabelle erstellt.

sqlstring = "select 96Sales.totals from 96Sales where profit < 5"
connstring = _
    "ODBC;DSN=96SalesData;UID=Rep21;PWD=NUyHwYQI;Database=96Sales"
With ActiveSheet.QueryTables.Add(Connection:=connstring, _
        Destination:=Range("B1"), Sql:=sqlstring)
    .Refresh
End With


Add-Methode (RecentFiles-Auflistung)

Fügt der Liste der zuletzt geöffneten Dateien eine Datei hinzu. Gibt ein RecentFile-Objekt zurück.

Syntax

Objekt.Add(Name)

Objekt Erforderlich. Ein Ausdruck, der ein RecentFiles-Objekt zurückgibt.

Name String erforderlich. Der Dateiname.


Beispiel zur Add-Methode (RecentFiles-Auflistung)

In diesem Beispiel wird "Oskar.xls" der Liste der zuletzt geöffneten Dateien hinzugefügt.

Application.RecentFiles.Add Name:="oscar.xls"


Add-Methode (Scenarios-Auflistung)

Erstellt ein neues Szenario und fügt es der für das aktuelle Tabellenblatt verfügbaren Szenarioliste hinzu. Gibt ein Szenario-Objekt zurück.

Syntax

Ausdruck.Add(Name, ChangingCells, Values, Comment, Locked, Hidden)

Ausdruck Erforderlich. Ein Ausdruck, der ein Scenarios-Objekt zurückgibt.

Name String erforderlich. Der Name des Szenarios.

ChangingCells Variant erforderlich. Ein Range-Objekt, das sich auf die veränderbaren Zellen des Szenarios bezieht.

Values Variant optional. Eine Matrix mit den Szenariowerten für die Zellen in ChangingCells. Wird das Argument nicht angegeben, so werden die aktuellen Werte in ChangingCells als Szenariowerte angenommen.

Comment Variant optional. Eine Zeichenfolge, die einen Kommentar für das Szenario festlegt. Wenn ein neues Szenario hinzugefügt wird, werden Autorenname und Datum automatisch am Anfang des Kommentars hinzugefügt.

Locked Variant optional. True, wenn das Szenario gesperrt ist, um Änderungen zu verhindern. Der Standardwert ist True.

Hidden Variant optional. True, wenn das Szenario ausgeblendet ist. Der Standardwert ist False.

Anmerkungen

Der Name eines Szenarios muss eindeutig sein. Microsoft Excel gibt eine Fehlermeldung aus, wenn Sie ein Szenario mit einem bereits verwendeten Namen erstellen wollen.


Beispiel zur Add-Methode (Scenarios-Auflistung)

In diesem Beispiel wird in Sheet1 ein neues Szenario hinzugefügt.

Worksheets("Sheet1").Scenarios.Add Name:="Best Case", _
    ChangingCells:=Worksheets("Sheet1").Range("A1:A4"), _
    Values:=Array(23, 5, 6, 21), _
    Comment:="Most favorable outcome."


Add-Methode (SeriesCollection-Auflistung)

Fügt der SeriesCollection-Auflistung eine oder mehrere Datenreihen hinzu.

Syntax

Ausdruck.Add(Source, Rowcol, SeriesLabels, CategoryLabels, Replace)

Ausdruck Erforderlich. Ein Ausdruck, der ein SeriesCollection-Objekt zurückgibt.

Source Variant erforderlich. Die neuen Daten, entweder als Range-Objekt oder als Matrix aus Datenpunkten.

Rowcol Variant optional. Gibt an, ob sich die neuen Werte in den Zeilen oder Spalten des angegebenen Bereichs befinden. Kann eine der folgenden XlRowCol-Konstanten sein: xlRows oder xlColumns. Der Standardwert ist xlColumns.

SeriesLabels Variant optional. Wird ignoriert, wenn Source eine Matrix ist. True, wenn die erste Zeile oder Spalte den Namen der Datenreihe enthält. False, wenn die erste Zeile oder Spalte den ersten Datenpunkt der Datenreihe enthält. Wird dieses Argument nicht angegeben, so versucht Microsoft Excel, die Position des Datenreihennamens mittels des Inhaltes der ersten Zeile oder Spalte zu bestimmen.

CategoryLabels Variant optional. Wird ignoriert, wenn Source eine Matrix ist. True, wenn die erste Zeile oder Spalte die Rubrikenbeschriftung enthält. False, wenn die erste Zeile oder Spalte den ersten Datenpunkt der Datenreihe enthält. Wird dieses Argument nicht angegeben, so versucht Microsoft Excel, die Position der Rubrikenbeschriftung mittels des Inhaltes der ersten Zeile oder Spalte zu bestimmen.

Replace Variant optional. Wenn CategoryLabels den Wert True und Replace den Wert True besitzen, ersetzen die angegebenen Rubriken die aktuellen Rubriken der Datenreihe. Wenn Replace den Wert False besitzt, so werden die bestehenden Rubriken nicht ersetzt. Der Standardwert ist False.

Anmerkungen

Diese Methode steht für PivotChart-Berichte nicht zur Verfügung.


Beispiel zur Add-Methode (SeriesCollection-Auflistung)

In diesem Beispiel wird eine neue Datenreihe in Chart1 erstellt. Die Datenquelle ist der Bereich "B1:B10" in Sheet1.

Charts("Chart1").SeriesCollection.Add _
    Source:=ActiveWorkbook.Worksheets("Sheet1").Range("B1:B10")

In diesem Beispiel wird eine neue Datenreihe in dem eingebetteten Diagramm in Sheet1 erstellt.

Worksheets("Sheet1").ChartObjects(1).Activate
ActiveChart.SeriesCollection.Add _
    Source:=Worksheets("Sheet1").Range("B1:B10")


Add-Methode (Sheets-Auflistung)

Erstellt ein neues Tabellenblatt, Diagramm oder Makroblatt.

Syntax

Ausdruck.Add(Before, After, Count, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Sheets-Objekt zurückgibt.

Before Variant optional. Ein Objekt, das das Blatt festlegt, vor dem das neue Blatt eingefügt werden soll.

After Variant optional. Ein Objekt, das das Blatt festlegt, nach dem das neue Blatt eingefügt werden soll.

Count Variant optional. Die Anzahl der hinzuzufügenden Blätter. Der Standardwert ist Eins.

Type Variant optional. Legt den Blattyp fest. Kann eine der folgenden XlSheetType-Konstanten sein: xlWorksheet, xlChart, xlExcel4MacroSheet oder xlExcel4IntlMacroSheet. Der Standardwert ist xlWorksheet.

Anmerkungen

Wenn Before und After nicht angegeben werden, wird das neue Blatt vor dem aktiven Blatt eingefügt.


Beispiel zur Add-Methode (Sheets-Auflistung)

In diesem Beispiel wird ein neues Tabellenblatt vor dem letzten Tabellenblatt in der aktiven Arbeitsmappe eingefügt.

ActiveWorkbook.Sheets.Add Before:=Worksheets(Worksheets.Count)


Add-Methode (Styles-Auflistung)

Erstellt eine neue Formatvorlage und fügt sie der Liste mit den für die aktuelle Arbeitsmappe verfügbaren Formatvorlagen hinzu. Gibt ein Style-Objekt zurück.

Syntax

Ausdruck.Add(Name, BasedOn)

Ausdruck Erforderlich. Ein Ausdruck, der ein Styles-Objekt zurückgibt.

Name String erforderlich. Der neue Formatvorlagenname.

BasedOn Variant optional. Ein Range-Objekt, das sich auf eine Zelle bezieht, die die Grundlage für die neue Formatvorlage darstellt. Wird dieses Argument nicht angegeben, so wird als neue Formatvorlage Standard verwendet.

Anmerkungen

Falls bereits eine Formatvorlage mit dem angegebenen Namen besteht, definiert diese Methode die Formatvorlage neu, basierend auf der in BasedOn angegebenen Zelle. Im folgenden Beispiel wird die Formatvorlage Standard basierend auf der aktiven Zelle neu definiert.

ActiveWorkbook.Styles.Add Name := "Normal", _
    BasedOn := ActiveCell


Beispiel zur Add-Methode (Styles-Auflistung)

In diesem Beispiel wird eine neue Formatvorlage basierend auf der Zelle A1 in Sheet1 definiert.

Worksheets("Sheet1").Activate
ActiveWorkbook.Styles.Add Name:="myNewStyle", _
    BasedOn:=ActiveSheet.Range("A1")

In diesem Beispiel wird eine neue Formatvorlage definiert, die lediglich Schriftarteigenschaften enthält.

With ActiveWorkbook.Styles.Add(Name:="theNewStyle")
    .IncludeNumber = False
    .IncludeFont = True
    .IncludeAlignment = False
    .IncludeBorder = False
    .IncludePatterns = False
    .IncludeProtection = False
    .Font.Name = "Arial"
    .Font.Size = 18
End With


Add-Methode (Trendlines-Auflistung)

Erstellt eine neue Trendlinie. Gibt ein Trendline-Objekt zurück.

Syntax

Ausdruck.Add(Type, Order, Period, Forward, Backward, Intercept, DisplayEquation, DisplayRSquared, Name)

Ausdruck Erforderlich. Ein Ausdruck, der ein Trendlines-Objekt zurückgibt.

Type Variant optional. Die Art der Trendlinie. Kann eine der folgenden XlTrendlineType-Konstanten sein: xlLinear, xlLogarithmic, xlExponential, xlPolynomial, xlMovingAvg oder xlPower. Der Standardwert ist xlLinear.

Order Variant optional. Erforderlich, wenn Type den Wert xlPolynomial besitzt. Der Grad der Trendlinie. Muss eine ganze Zahl zwischen 1 und 6 (einschließlich) sein.

Period Variant optional. Erforderlich, wenn Type den Wert xlMovingAvg besitzt. Die Periode der Trendlinie. Muss eine ganze Zahl größer Eins und kleiner als die Anzahl der Datenpunkte der Reihe sein, der Sie eine Trendlinie hinzufügen.

Forward Variant optional. Die Anzahl der Perioden (oder Einheiten in einem Punktdiagramm), über die sich eine Trendlinie nach vorne erstreckt.

Backward Variant optional. Die Anzahl der Perioden (oder Einheiten in einem Punktdiagramm), über die sich eine Trendlinie zurück erstreckt.

Intercept Variant optional. Der Schnittpunkt der Trendlinie. Wird dieses Argument nicht angegeben, so wird der Schnittpunkt automatisch durch Regression festgelegt.

DisplayEquation Variant optional. True, wenn die Gleichung der Trendlinie des Diagramms angezeigt wird (in demselben Beschriftungsfeld wie das Bestimmtheitsmaß). Der Standardwert ist False.

DisplayRSquared Variant optional. True, wenn das Bestimmtheitsmaß der Trendlinie des Diagramms angezeigt wird (in demselben Beschriftungsfeld wie die Gleichung). Der Standardwert ist False.

Name Variant optional. Der Name der Trendlinie als Text. Wenn dieses Argument nicht angegeben wird, so erstellt Microsoft Excel einen Namen.


Beispiel zur Add-Methode (Trendlines-Auflistung)

In diesem Beispiel wird eine neue lineare Trendlinie in Chart1 erstellt.

ActiveWorkbook.Charts("Chart1").SeriesCollection(1).Trendlines.Add


Add-Methode (Validation-Objekt)

Fügt dem angegebenen Bereich Validierung zu.

Syntax

Ausdruck.Add(Type, AlertStyle, Operator, Formula1, Formula2)

Ausdruck Erforderlich. Ein Ausdruck, der ein Validation-Objekt zurückgibt.

Type Long erforderlich. Der Gültigkeitstyp. Dabei kann es sich um eine der folgenden XlDVType-Konstanten handeln: xlValidateCustom, xlValidateDate, xlValidateDecimal, xlValidateInputOnly, xlValidateList, xlValidateTextLength, xlValidateTime oder xlValidateWholeNumber.

AlertStyle Variant optional. Der Stil der Validierungswarnung. Dabei kann es sich um eine der folgenden XlDVAlertStyle-Konstanten handeln: xlValidAlertInformation, xlValidAlertStop oder xlValidAlertWarning.

Operator Variant optional. Der Validierungs-Operator. Dabei kann es sich um eine der folgenden XlFormatConditionOperator-Konstanten handeln: xlBetween, xlEqual, xlGreater, xlGreaterEqual, xlLess, xlLessEqual, xlNotBetween oder xlNotEqual.

Formula1 Variant optional. Der erste Teil der Validierungsgleichung.

Formula2 Variant optional. Der zweite Teil der Validierung wenn es sich bei dem Operator um xlBetween oder xlNotBetween handelt (sonst wird dieses Argument ignoriert).

Anmerkungen

Die Add-Methode benötigt, abhängig vom Gültigkeitstyp, verschiedene Argumente, wie in der Tabelle dargestellt.

Gültigkeitstyp | Argumente
xlValidateCustom | Formula1 ist erforderlich, Formula2 wird ignoriert. Formula1 muss einen Ausdruck enthalten, der bei einer gültigen Dateneingabe True und bei einer ungültigen False zurückgibt.
xlInputOnly | AlertStyle, Formula1 oder Formula2 werden benutzt.
xlValidateList | Formula1 ist erforderlich, Formula2 wird ignoriert. Formula1 muss entweder eine durch Kommata getrennte Werteliste oder einen Verweis auf ein Tabellenblatt mit dieser Liste enthalten.
xlValidateWholeNumber, xlValidateDate, xlValidateDecimal, xlValidateTextLength oder xlValidateTime | Mindestens Formula1 oder Formula2 müssen, beide Werte können angegeben werden.


Beispiel zur Add-Methode (Validation-Objekt)

In diesem Beispiel wird die Zelle E5 mit Validierung versehen.

With Range("e5").Validation
    .Add Type:=xlValidateWholeNumber, _
        AlertStyle:= xlValidAlertStop, _
        Operator:=xlBetween, Formula1:="5", Formula2:="10"
    .InputTitle = "Integers"
    .ErrorTitle = "Integers"
    .InputMessage = "Enter an integer from five to ten"
    .ErrorMessage = "You must enter a number from five to ten"
End With


Add-Methode (VPageBreaks-Auflistung)

Fügt einen vertikalen Seitenwechsel ein. Gibt ein VPageBreak-Objekt zurück.

Syntax

Objekt.Add(Before)

Objekt Erforderlich. Ein Ausdruck der ein VPageBreaks-Objekt zurückgibt.

Before Object erforderlich. Ein Range-Objekt. Der Bereich, auf dessen linker Seite der neue Seitenwechsel eingefügt wird.


Beispiel zur Add-Methode (VPageBreaks-Auflistung)

In diesem Beispiel wird über der Zelle F25 ein horizontaler und links neben ihr ein vertikaler Seitenwechsel eingefügt.

With Worksheets(1)
    .HPageBreaks.Add .Range("F25")
    .VPageBreaks.Add .Range("F25")
End With


Add-Methode (Workbooks-Auflistung)

Erstellt eine neue Arbeitsmappe, die zur aktiven Arbeitsmappe wird. Gibt ein Workbook-Objekt zurück.

Syntax

Ausdruck.Add(Template)

Ausdruck Erforderlich. Ein Ausdruck, der ein Workbooks-Objekt zurückgibt.

Template Variant optional. Legt fest, wie die neue Arbeitsmappe erstellt wird. Falls dieses Argument eine Zeichenfolge ist, die den Namen einer bestehenden Microsoft Excel-Datei angibt, wird diese Datei als Formatvorlage für die neue Arbeitsmappe verwendet. Falls dieses Argument eine Konstante ist, enthält die neue Arbeitsmappe ein einzelnes Blatt des angegebenen Typs. Kann eine der folgenden XlWBATemplate-Konstanten sein: xlWBATChart, xlWBATExcel4IntlMacroSheet, xlWBATExcel4MacroSheet oder xlWBATWorksheet. Wird dieses Argument nicht angegeben, erstellt Microsoft Excel eine neue Arbeitsmappe mit mehreren leeren Blättern (die Anzahl der Blätter wird durch die SheetsInNewWorkbook-Eigenschaft festgelegt).

Anmerkungen

Falls das Argument Template eine Datei angibt, kann der Dateiname einen Pfad enthalten.


Beispiel zur Add-Methode (Workbooks-Auflistung)

In diesem Beispiel wird eine neue Arbeitsmappe erstellt.

Workbooks.Add


Add-Methode (Worksheets-Auflistung)

Erstellt ein neues Tabellenblatt, das zum aktiven Blatt wird. Gibt ein Worksheet-Objekt zurück.

Syntax

Ausdruck.Add(Before, After, Count, Type)

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheets-Objekt zurückgibt.

Before Variant optional. Ein Objekt, das das Blatt festlegt, vor dem das neue Blatt eingefügt werden soll.

After Variant optional. Ein Objekt, das das Blatt festlegt, nach dem das neue Blatt eingefügt werden soll.

Count Variant optional. Die Anzahl der hinzuzufügenden Blätter. Der Standardwert ist Eins.

Type Variant optional. Die Art des Tabellenblattes. Kann eine der folgenden XlSheetType-Konstanten sein: xlWorksheet, xlExcel4MacroSheet oder xlExcel4IntlMacroSheet. Der Standardwert ist xlWorksheet.

Anmerkungen

Wenn Before und After nicht angegeben werden, wird das neue Blatt vor dem aktiven Blatt eingefügt.


Beispiel zur Add-Methode (Worksheets-Auflistung)

In diesem Beispiel wird ein neues Tabellenblatt erstellt, das vor dem aktiven Blatt eingefügt wird.

ActiveWorkbook.Worksheets.Add

In diesem Beispiel wird ein neues Tabellenblatt nach dem letzten Blatt der aktiven Arbeitsmappe eingefügt.

Worksheets.Add.Move after:=Worksheets(Worksheets.Count)


Beispiel zur Apply-Methode

In diesem Beispiel wird in myDocument die Formatierung der ersten Form kopiert und anschließend auf die zweite Form angewendet.

Set myDocument = Worksheets(1)
With myDocument
    .Shapes(1).PickUp
    .Shapes(2).Apply
End With


Beispiel zur Calculate-Methode

Dieses Beispiel berechnet die Formeln in den Spalten A, B und C im verwendeten Bereich der Sheet1.

Worksheets("Sheet1").UsedRange.Columns("A:C").Calculate


Beispiel zur Clear-Methode

In diesem Beispiel werden Formeln und Formatierungen im Bereich A1:G37 in Sheet1 gelöscht.

Worksheets("Sheet1").Range("A1:G37").Clear

Dieses Beispiel löscht die Diagrammfläche (die Diagrammdaten und die Formatierung) von Chart1.

Charts("Chart1").ChartArea.Clear


Beispiel zur ClipboardFormats-Eigenschaft

In diesem Beispiel wird ein Meldungsfeld angezeigt, wenn sich in der Zwischenablage ein Objekt im RTF-Format befindet. RTF-Objekte können durch Kopieren von Text aus einem Word-Dokument erstellt werden.

aFmts = Application.ClipboardFormats
For Each fmt In aFmts
    If fmt = xlClipboardFormatRTF Then
        MsgBox "Clipboard contains rich text"
    End If
Next


Beispiel zur Copy-Methode

In diesem Beispiel wird Sheet1 kopiert und die Kopie hinter Sheet3 eingefügt.

Worksheets("Sheet1").Copy after := Worksheets("Sheet3")

Im folgenden Beispiel wird der verwendete Bereich in Sheet1 kopiert und ein neues Tabellenblatt erstellt. Anschließend werden die Werte des kopierten Bereichs darin eingefügt.

Worksheets("Sheet1").UsedRange.Copy
Set newSheet = Worksheets.Add
newSheet.Range("A1").PasteSpecial Paste:=xlValues

In diesem Beispiel werden die Formeln im Bereich A1:D4 von Sheet1 in die Zellen E5:H8 in Sheet2 kopiert.

Worksheets("Sheet1").Range("A1:D4").Copy _
    destination:=Worksheets("Sheet2").Range("E5")


Beispiel zur Delete-Methode

In diesem Beispiel wird der Bereich A1:D10 in Sheet1 gelöscht. Die übrigen Zellen werden nach links verschoben.

Worksheets("Sheet1").Range("A1:D10").Delete Shift:=xlShiftToLeft

Dieses Beispiel löscht Sheet3 der aktiven Arbeitsmappe, ohne ein Dialogfeld zur Bestätigung anzuzeigen.

Application.DisplayAlerts = False
Worksheets("Sheet3").Delete
Application.DisplayAlerts = True

In diesem Beispiel werden die Daten der ersten Spalte in Sheet1 sortiert. Anschließend werden Zeilen mit doppelt vorhandenen Daten gelöscht.

Worksheets("Sheet1").Range("A1").Sort _
        key1:=Worksheets("Sheet1").Range("A1")
Set currentCell = Worksheets("Sheet1").Range("A1")
Do While Not IsEmpty(currentCell)
    Set nextCell = currentCell.Offset(1, 0)
    If nextCell.Value = currentCell.Value Then
        currentCell.EntireRow.Delete
    End If
    Set currentCell = nextCell
Loop


Beispiel zur FileConverters-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, wenn das Umwandlungsprogramm für Multiplan installiert ist.

installedCvts = Application.FileConverters
foundMultiplan = False
If Not IsNull(installedCvts) Then
    For arrayRow = 1 To UBound(installedCvts, 1)
        If installedCvts(arrayRow, 1) Like "*Multiplan*" Then
            foundMultiplan = True
            Exit For
        End If
    Next arrayRow
End If
If foundMultiplan = True Then
    MsgBox "Multiplan converter is installed"
Else
    MsgBox "Multiplan converter is not installed"
End If


Beispiel zur Find-Methode

Dieses Beispiel findet alle Zellen im Bereich "A1:A500" des ersten Tabellenblatts, die den Wert 2 enthalten. Anschließend werden diese Zellen grau formatiert.

With Worksheets(1).Range("a1:a500")
    Set c = .Find(2, lookin:=xlValues)
    If Not c Is Nothing Then
        firstAddress = c.Address
        Do
            c.Interior.Pattern = xlPatternGray50
            Set c = .FindNext(c)
        Loop While Not c Is Nothing And c.Address <> firstAddress
    End If
End With


Beispiel zur Follow-Methode

In diesem Beispiel wird das Dokument geladen, das dem Hyperlink in der ersten Form des ersten Tabellenblattes zugeordnet ist.

Worksheets(1).Shapes(1).Hyperlink.Follow NewWindow:=True


Beispiel zur Insert-Methode

In diesem Beispiel wird eine neue Zeile vor Zeile 4 in Sheet1 eingefügt.

Worksheets("Sheet1").Rows(4).Insert

In diesem Beispiel werden neue Zellen im Bereich A1:C5 in Sheet1 eingefügt und dann nach unten verschoben.

Worksheets("Sheet1").Range("A1:C5").Insert Shift:=xlShiftDown

In diesem Beispiel wird eine neue Zelle an der aktiven Zelle eingefügt. Dieses Beispiel muss aus einem Tabellenblatt ausgeführt werden.

ActiveCell.EntireRow.Insert


Beispiel zur International-Eigenschaft

In diesem Beispiel wird das internationale Dezimaltrennzeichen angezeigt.

MsgBox "The decimal separator is " & _
    Application.International(xlDecimalSeparator)


Item-Methode (Axes-Auflistung)

Gibt ein einzelnes Axis-Objekt aus einer Axes-Auflistung zurück.

Syntax

Ausdruck.Item(Type, AxisGroup)

Ausdruck Erforderlich. Ein Ausdruck, der ein Axes-Objekt zurückgibt.

Type Variant erforderlich. Der Achsentyp. Dies kann eine der folgenden XlAxisType-Konstanten sein: xlValue, xlCategory oder xlSeriesAxis (xlSeriesAxis gilt nur bei 3D-Diagrammen).

AxisGroup Variant optional. Die Achsengruppe. Dies kann eine der folgenden XlAxisGroup-Konstanten sein: xlPrimary oder xlSecondary. Der Standardwert ist xlPrimary.


Beispiel zur Item-Methode (Axes-Auflistung)

In diesem Beispiel wird der Titeltext der Rubrikenachse im ersten Diagramm festgelegt.

With Charts("chart1").Axes.Item(xlCategory)
    .HasTitle = True
    .AxisTitle.Caption = "1994"
End With


Item-Methode (CalculatedFields-Auflistung)

Gibt ein einzelnes PivotField-Objekt aus einer CalculatedFields-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalculatedFields-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des PivotTable-Feldes.


Beispiel zur Item-Methode (CalculatedFields-Auflistung)

In diesem Beispiel wird die Formel für das erste berechnete Feld festgelegt.

Worksheets(1).PivotTables(1).CalculatedFields.Item(1) _
    .Formula = "=Revenue - Cost"


Item-Methode (CalculatedItems-Auflistung)

Gibt ein einzelnes PivotItem-Objekt aus einer CalculatedItems-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein CalculatedItems-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des PivotTable-Elementes.


Beispiel zur Item-Methode (CalculatedItems-Auflistung)

In diesem Beispiel wird das erste berechnete Element ausgeblendet.

Worksheets(1).PivotTables(1).PivotFields("year") _
    .CalculatedItems.Item(1).Visible = False


Item-Methode (ChartGroups-Auflistung)

Gibt ein einzelnes ChartGroup-Objekt aus einer ChartGroups-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartGroups-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer der Diagrammgruppe.


Beispiel zur Item-Methode (ChartGroups-Auflistung)

In diesem Beispiel werden der ersten Diagrammgruppe des ersten Diagrammblattes Bezugslinien hinzugefügt.

Charts(1).ChartGroups.Item(1).HasDropLines = True


Item-Methode (ChartObjects-Auflistung)

Gibt ein einzelnes ChartObject-Objekt aus einer ChartObjects-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ChartObjects-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des eingebetteten Diagramms.


Beispiel zur Item-Methode (ChartObjects-Auflistung)

In diesem Beispiel wird das erste eingebettete Diagramm aktiviert.

Worksheets("sheet1").ChartObjects.Item(1).Activate


Item-Methode (Comments-Auflistung)

Gibt ein einzelnes Comment-Objekt aus einer Comments-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Comments-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Kommentars.


Beispiel zur Item-Methode (Comments-Auflistung)

In diesem Beispiel wird der zweite Kommentar ausgeblendet.

Worksheets(1).Comments.Item(2).Visible = False


Item-Methode (CustomViews-Auflistung)

Gibt ein einzelnes CustomView-Objekt aus einer CustomViews-Auflistung zurück.

Syntax

Ausdruck.Item(ViewName)

Ausdruck Erforderlich. Ein Ausdruck, der ein CustomViews-Objekt zurückgibt.

ViewName Variant erforderlich. Der Name oder die Indexnummer der benutzerdefinierten Ansicht.


Beispiel zur Item-Methode (CustomViews-Auflistung)

In diesem Beispiel werden Druckeinstellungen in die benutzerdefinierte Ansicht "Aktuelle Bestände" aufgenommen.

ThisWorkbook.CustomViews.Item("Current Inventory") _
    .PrintSettings = True


Item-Methode (DataLabels-Auflistung)

Gibt ein einzelnes DataLabel-Objekt aus einer DataLabels-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein DataLabels-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Datenbeschriftung.


Beispiel zur Item-Methode (DataLabels-Auflistung)

In diesem Beispiel wird für die fünfte Datenbeschriftung der ersten Datenreihe im ersten eingebetteten Diagramm des ersten Tabellenblattes das Zahlenformat festgelegt.

Worksheets(1).ChartObjects(1).Chart _
    .SeriesCollection(1).DataLabels.Item(5).NumberFormat = "0.000"


Item-Methode (FormatConditions-Auflistung)

Gibt ein einzelnes FormatCondition-Objekt aus einer FormatConditions-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein FormatConditions-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des bedingten Formats.


Beispiel zur Item-Methode (FormatConditions-Auflistung)

In diesem Beispiel werden die Formateigenschaften für ein bestehendes bedingtes Format in den Zellen E1:E10 festgelegt.

With Worksheets(1).Range("e1:e10").FormatConditions.Item(1)
    With .Borders
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = 6
    End With
End With


Item-Methode (GroupShapes-Auflistung)

Gibt ein einzelnes Shape-Objekt einer GroupShapes-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein GroupShapes-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Form.


Item-Methode (LegendEntries-Auflistung)

Gibt ein einzelnes LegendEntry-Objekt aus einer LegendEntries-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein LegendEntries-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des Legendeneintrags.


Beispiel zur Item-Methode (LegendEntries-Auflistung)

In diesem Beispiel wird im ersten eingebetteten Diagramm in Sheet1 die Schriftart für den Text des Legendeneintrags am Kopf der Legende (gewöhnlich die Legende der ersten Datenreihe) geändert.

Worksheets("sheet1").ChartObjects(1).Chart _
    .Legend.LegendEntries.Item(1).Font.Italic = True


Item-Methode (Names-Auflistung)

Gibt ein einzelnes Name-Objekt aus einer Names-Auflistung zurück.

Syntax

Ausdruck.Item(Index, IndexLocal, RefersTo)

Ausdruck Erforderlich. Ein Ausdruck, der ein Names-Objekt zurückgibt.

Index Variant optional. Der Name oder die Nummer des definierten Namens, der zurückgegeben werden soll.

IndexLocal Variant optional. Der Name des definierten Namens in der Sprache des Benutzers. Bei Angabe dieses Arguments werden keine Namen übersetzt.

RefersTo Variant optional. Worauf sich der Name bezieht. Dieses Argument wird verwendet, um einen Namen nach seinem Bezug zu identifizieren.

Anmerkungen

Sie dürfen nur ein einziges dieser Argumente angeben.


Beispiel zur Item-Methode (Names-Auflistung)

In diesem Beispiel wird der Name "mySortRange" aus der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.Names.Item("mySortRange").Delete


Item-Methode (ODBCErrors-Auflistung)

Gibt ein einzelnes ODBCError-Objekt aus einer ODBCErrors-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ODBCErrors-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des ODBCError-Objekts.


Beispiel zur Item-Methode (ODBCErrors-Auflistung)

In diesem Beispiel wird ein ODBC-Fehler angezeigt.

Set er = Application.ODBCErrors.Item(1)
MsgBox "The following error occurred:" &
    er.ErrorString & " : " & er.SqlState


Item-Methode (OLEDBErrors-Auflistung)

Gibt ein einzelnes OLEDBError-Objekt aus der OLEDBErrors-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Ein Ausdruck, der ein OLEDBErrors-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des OLEDBError-Objekts.


Beispiel zur Item-Methode (OLEDBErrors-Auflistung)

In diesem Beispiel wird ein OLE DB-Fehler angezeigt.

Set objEr = Application.OLEDBErrors.Item(1)
MsgBox "The following error occurred:" & _
    objEr.ErrorString & " : " & objEr.SqlState


Item-Methode (OLEObjects-Auflistung)

Gibt ein einzelnes OLEObject-Objekt aus einer OLEObjects-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein OLEObjects-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des OLEObject-Objekts.


Beispiel zur Item-Methode (OLEObjects-Auflistung)

In diesem Beispiel wird das erste OLE-Objekt in Sheet1 gelöscht.

Worksheets("sheet1").OLEObjects.Item(1).Delete


Item-Methode (Parameters-Auflistung)

Gibt ein einzelnes Parameter-Objekt aus einer Parameters-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Parameters-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Parameters.


Beispiel zur Item-Methode (Parameters-Auflistung)

In diesem Beispiel wird die Zeichenfolge der Eingabeaufforderung für den Parameter geändert.

With Worksheets(1).QueryTables(1).Parameters.Item(1)
    .SetParam xlPrompt, "Please " & .PromptString
End With


Item-Methode (PivotCaches-Auflistung)

Gibt ein einzelnes PivotCache-Objekt aus einer PivotCaches-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotCaches-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des Zwischenspeichers der Pivot-Tabelle.


Beispiel zur Item-Methode (PivotCaches-Auflistung)

In diesem Beispiel wird der erste Cache aktualisiert.

ActiveWorkbook.PivotCaches.Item(1).Refresh


 Item-Methode (PivotFields-Auflistung)

Item-Methode (PivotFields-Auflistung)

Gibt ein einzelnes PivotField-Objekt aus einer PivotFields-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotFields-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des PivotTable-Feldes.

Anmerkungen

Der Textname des Objektes entspricht dem Wert der Name- und Value-Eigenschaften. Bei einer OLAP-Datenquelle stimmt der Wert mit dem Wert der SourceName-Eigenschaft überein; bei anderen Datenquellen stimmt der Wert mit dem Wert der Caption-Eigenschaft überein.


Beispiel zur Item-Methode (PivotFields-Auflistung)

In diesem Beispiel wird das Feld "Year" in dem ersten PivotTable-Bericht von Sheet3 zu einem Zeilenfeld gemacht.

Worksheets("sheet3").PivotTables(1) _
    .PivotFields.Item("year").Orientation = xlRowField


Item-Methode (PivotFormulas-Auflistung)

Gibt ein einzelnes PivotFormula-Objekt aus einer PivotFormulas-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotFormulas-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer der PivotTable-Formel.


Beispiel zur Item-Methode (PivotFormulas-Auflistung)

In diesem Beispiel wird die erste Formel der ersten Pivot-Tabelle im ersten Tabellenblatt angezeigt.

MsgBox Worksheets(1).PivotTables(1).PivotFormulas.Item(1).Formula


Item-Methode (PivotItems-Auflistung)

Gibt ein einzelnes PivotItem-Objekt aus einer PivotItems-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotItems-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des PivotTable-Elementes.


Beispiel zur Item-Methode (PivotItems-Auflistung)

In diesem Beispiel wird das Element "1998" im ersten PivotTable-Bericht von Sheet3 ausgeblendet.

Worksheets("sheet3").PivotTables(1) _
    .PivotFields("year").PivotItems.Item("1998").Visible = False


Item-Methode (PivotTables-Auflistung)

Gibt ein einzelnes PivotTable-Objekt aus einer PivotTables-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein PivotTables-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des PivotTable-Berichts.


Beispiel zur Item-Methode (PivotTables-Auflistung)

In diesem Beispiel wird das Feld "Year" in ein Zeilenfeld im ersten PivotTable-Bericht von Sheet3 umgewandelt. Bei der angegebenen Datenreihe muss es sich um eine 2D-Linien-, Punkt- oder Netzdatenreihe handeln.

Worksheets("sheet3").PivotTables.Item(1) _
    .PivotFields("year").Orientation = xlRowField


Item-Methode (Points-Auflistung)

Gibt ein einzelnes Point-Objekt aus einer Points-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Points-Objekt zurückgibt.

Index Long erforderlich. Die Indexnummer des Punktes.


Beispiel zur Item-Methode (Points-Auflistung)

In diesem Beispiel wird die Markierungsart für den dritten Punkt der ersten Datenreihe im ersten eingebetteten Diagramm des ersten Tabellenblattes festgelegt. Bei der angegebenen Datenreihe muss es sich um eine 2D-Linien-, Punkt- oder Netzdatenreihe handeln.

Worksheets(1).ChartObjects(1).Chart. _
    SeriesCollection(1).Points.Item(3).MarkerStyle = xlDiamond


Item-Methode (QueryTables-Auflistung)

Gibt ein einzelnes QueryTable-Objekt aus einer QueryTables-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein QueryTables-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer der Abfragetabelle.


Beispiel zur Item-Methode (QueryTables-Auflistung)

In diesem Beispiel wird für eine Abfragetabelle festgelegt, dass bei jeder Aktualisierung alle Formeln rechts der Abfragetabelle automatisch aktualisiert werden.

Sheets("sheet1").QueryTables.Item(1).FillAdjacentFormulas = True


Item-Methode (Scenarios-Auflistung)

Gibt ein einzelnes Scenario-Objekt aus einer Scenarios-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Scenarios-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer des Szenarios.


Beispiel zur Item-Methode (Scenarios-Auflistung)

In diesem Beispiel wird das Szenario "Typical" im Tabellenblatt "Options" dargestellt.

Worksheets("options").Scenarios.Item("typical").Show


Item-Methode (SeriesCollection-Auflistung)

Gibt ein einzelnes Series-Objekt aus einer SeriesCollection-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein SeriesCollection-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Datenreihe.


Beispiel zur Item-Methode (SeriesCollection-Auflistung)

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, die sich die Trendlinie in Chart1 nach vorne und hinten erstreckt. Das Beispiel muss bei einem 2D-Säulendiagramm ausgeführt werden, das eine einzige Datenreihe mit einer Trendlinie enthält.

With Charts("Chart1").SeriesCollection.Item(1).Trendlines.Item(1)
    .Forward = 5
    .Backward = .5
End With


Item-Methode (ShapeNodes-Auflistung)

Gibt ein einzelnes ShapeNode-Objekt einer ShapeNodes-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeNodes-Objekt zurückgibt.

Index Variant erforderlich. Die Indexnummer des Formknotens.


Item-Methode (ShapeRange-Auflistung)

Gibt ein einzelnes Shape-Objekt aus einer ShapeRange-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein ShapeRange-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Form.


Beispiel zur Item-Methode (ShapeRange-Auflistung)

In diesem Beispiel wird die OnAction-Eigenschaft für die zweite Form eines Formbereichs festgelegt. Falls die Variable sr kein ShapeRange-Objekt darstellt, schlägt dieses Beispiel fehl.

sr.Item(2).OnAction = "ShapeAction"


Item-Methode (Shapes-Auflistung)

Gibt ein einzelnes Shape-Objekt aus einer Shapes-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Index Variant erforderlich. Der Name oder die Indexnummer der Form.


Beispiel zur Item-Methode (Shapes-Auflistung)

In diesem Beispiel wird die OnAction-Eigenschaft für die zweite Form einer Shapes-Auflistung festgelegt. Falls die Variable ss kein Shapes-Objekt darstellt, schlägt dieses Beispiel fehl.

ss.Item(2).OnAction = "ShapeAction"


Item-Methode (Trendlines-Auflistung)

Gibt ein einzelnes Trendline-Objekt aus einer Trendlines-Auflistung zurück.

Syntax

Ausdruck.Item(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Trendlines-Objekt zurückgibt.

Index Variant optional. Der Name oder die Indexnummer der Trendlinie.


Beispiel zur Item-Methode (Trendlines-Auflistung)

In diesem Beispiel wird die Anzahl der Einheiten festgelegt, die sich die Trendlinie in Chart1 nach vorne und hinten erstreckt. Das Beispiel muss bei einem 2D-Säulendiagramm ausgeführt werden, das eine einzige Datenreihe mit einer Trendlinie enthält.

With Charts("Chart1").SeriesCollection(1).Trendlines.Item(1)
    .Forward = 5
    .Backward = .5
End With


Beispiel zur List-Methode

In diesem Beispiel werden die Einträge in einem Listenfeld des ersten Tabellenblattes festgelegt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Worksheets(1).Shapes(2).ControlFormat.List = _
    Array("cogs", "widgets", "sprockets", "gizmos")

In diesem Beispiel wird der vierte Eintrag in einem Listenfeld des ersten Tabellenblattes festgelegt. Falls Shapes(2) kein Listenfeld darstellt, schlägt dieses Beispiel fehl.

Worksheets(1).Shapes(2).ControlFormat.List(4) = "gadgets"


Beispiel zur Merge-Methode

In diesem Beispiel werden die Formatvorlagen aus der Arbeitsmappe TEMPLATE.XLS in der aktiven Arbeitsmappe zusammengeführt.

ActiveWorkbook.Styles.Merge Workbook:=Workbooks("TEMPLATE.XLS")


Beispiel zur Open-Methode

In diesem Beispiel wird die Arbeitsmappe ANALYSIS.XLS geöffnet und das Makro "Auto_Open" ausgeführt.

Workbooks.Open "ANALYSIS.XLS"
ActiveWorkbook.RunAutoMacros xlAutoOpen


Paste-Methode (Worksheet-Objekt)

Fügt den Inhalt der Zwischenablage in das Tabellenblatt ein.

Syntax

Ausdruck.Paste(Destination, Link)

Ausdruck Erforderlich. Ein Ausdruck, der ein Worksheet-Objekt zurückgibt.

Destination Variant optional. Ein Range-Objekt, das festlegt, wo der Inhalt der Zwischenablage einzufügen ist. Ohne Angabe dieses Arguments wird die aktuelle Auswahl verwendet. Dieses Argument kann nur angegeben werden, wenn der Inhalt der Zwischenablage in einen Bereich eingefügt werden kann. Wenn dieses Argument angegeben wird, ist es nicht möglich, auch das Link-Argument anzugeben.

Link Variant optional. True, wenn eine Verknüpfung zum Quelldokument der eingefügten Daten hergestellt wird. Wenn dieses Argument angegeben wird, ist es nicht möglich, auch das Destination-Argument anzugeben. Der Standardwert ist False.

Anmerkungen

Wenn Sie kein Destination-Argument angeben, müssen Sie den Zielbereich markieren, bevor Sie diese Methode verwenden.

Diese Methode ändert gegebenenfalls in Abhängigkeit vom Inhalt der Zwischenablage die Position der Auswahl im Tabellenblatt.


Beispiel zur Paste-Methode (Worksheet-Objekt)

In diesem Beispiel werden die Daten der Zellen C1:C5 in Sheet1 in die Zellen D1:D5 in Sheet1 kopiert.

Worksheets("Sheet1").Range("C1:C5").Copy
ActiveSheet.Paste Destination:=Worksheets("Sheet1").Range("D1:D5")


Beispiel zur PivotCache-Methode

In diesem Beispiel wird der Cache für den ersten PivotTable-Bericht auf dem ersten Tabellenblatt beim Aufbau optimiert.

Worksheets(1).PivotTables("Pivot1") _
    .PivotCache.OptimizeCache = True


Beispiel zur Points-Methode

In diesem Beispiel wird dem ersten Datenpunkt der ersten Datenreihe in Chart1 eine Beschriftung zugewiesen.

Charts("Chart1").SeriesCollection(1).Points(1).ApplyDataLabels


Beispiel zur Protect-Methode

In diesem Beispiel wird die aktive Arbeitsmappe geschützt.

ActiveWorkbook.Protect Password := "drowssap"


Beispiel zur Refresh-Methode

In diesem Beispiel wird der PivotTable-Cache des ersten PivotTable-Berichts im ersten Tabellenblatt aktualisiert.

Worksheets(1).PivotTables(1).PivotCache.Refresh


Beispiel zur Replace-Methode

In diesem Beispiel wird jedes Vorkommen der trigonometrischen Funktion SIN durch die Funktion COS ersetzt. Diese Operation ist auf Spalte "A" in Sheet1 beschränkt.

Worksheets("Sheet1").Columns("A").Replace _
    What:="SIN", Replacement:="COS", _
    SearchOrder:=xlByColumns, MatchCase:=True


Beispiel zur Reset-Methode

In diesem Beispiel wird der Verteiler für BOOK1.XLS nach Abschluss des Weiterleitens zurückgesetzt.

With Workbooks("BOOK1.XLS").RoutingSlip
    If .Status = xlRoutingComplete Then
        .Reset
    Else
        MsgBox "Cannot reset routing; not yet complete"
    End If
End With


Beispiel zur Run-Methode

Dieses Beispiel verdeutlicht, wie Sie das Funktionsmakro "My_Func_Sum" aufrufen, das in der Makrovorlage "Mycustom.xlm" definiert ist (die Makrovorlage muss geöffnet sein). Die Funktion verarbeitet zwei numerische Argumente (hier 1 und 5).

mySum = Application.Run("MYCUSTOM.XLM!My_Func_Sum", 1, 5)
MsgBox "Macro result: " & mySum


Beispiel zur Save-Methode

In diesem Beispiel wird die aktive Arbeitsmappe gespeichert.

ActiveWorkbook.Save

In diesem Beispiel werden alle geöffneten Arbeitsmappen gespeichert. Anschließend wird Microsoft Excel beendet.

For Each w In Application.Workbooks
    w.Save
Next w
Application.Quit


Beispiel zur Select-Methode

In diesem Beispiel werden die Zellen A1:B3 von Sheet1 markiert.

Worksheets("Sheet1").Activate
Range("A1:B3").Select


Beispiel zur Show-Methode

In diesem Beispiel wird das Dialogfeld Öffnen angezeigt.

Application.Dialogs(xlDialogOpen).Show


Beispiel zur Sort-Methode

In diesem Beispiel wird der Bereich "A1:C20" in Sheet1 sortiert. "A1" ist der erste Sortierschlüssel, "B1" ist der zweite Sortierschlüssel. Es wird zeilenweise in aufsteigender Reihenfolge sortiert, und es gibt keine Überschriften.

Worksheets("Sheet1").Range("A1:C20").Sort _
    Key1:=Worksheets("Sheet1").Range("A1"), _
    Key2:=Worksheets("Sheet1").Range("B1")

In diesem Beispiel wird der Bereich, der Zelle "A1" (der aktive Bereich) in Sheet1 enthält, nach den Daten der ersten Spalte sortiert, wobei eine vorhandene Überschriftenzeile automatisch verwendet wird. Die Sort-Methode legt die aktive Region automatisch fest.

Worksheets("Sheet1").Range("A1").Sort _
    Key1:=Worksheets("Sheet1").Columns("A"), _
    Header:=xlGuess


Beispiel zur Text-Methode

In diesem Beispiel wird der Zelle E5 des ersten Blattes ein Kommentar hinzugefügt.

With Worksheets(1).Range("e5").AddComment
    .Visible = False
    .Text "reviewed on " & Date
End With


Beispiel zur Unprotect-Methode

In diesem Beispiel wird der Schutz der aktiven Arbeitsmappe aufgehoben.

ActiveWorkbook.Unprotect


Beispiel zur Update-Methode

In diesem Beispiel wird die Verknüpfung des ersten OLE-Objekts in Sheet1 aktualisiert.

Worksheets("Sheet1").OLEObjects(1).Update


Beispiel zur Address-Eigenschaft

Im folgenden Beispiel werden vier unterschiedliche Darstellungen der gleichen Zelladresse in Sheet1 angezeigt. Die Kommentare geben die in den Meldungsfeldern angezeigten Adressen an.

Set mc = Worksheets("Sheet1").Cells(1, 1)
MsgBox mc.Address()                              ' $A$1
MsgBox mc.Address(RowAbsolute:=False)            ' $A1
MsgBox mc.Address(ReferenceStyle:=xlR1C1)        ' R1C1
MsgBox mc.Address(ReferenceStyle:=xlR1C1, _
    RowAbsolute:=False,     _
    ColumnAbsolute:=False,  _
    RelativeTo:=Worksheets(1).Cells(3, 3))        ' R[-2]C[-2]


Beispiel zur AutoFilter-Eigenschaft

Im folgenden Beispiel wird eine Variable auf den Wert der Criteria1-Eigenschaft des Filters für die erste Spalte im gefilterten Bereich von Tabellenblatt "Crew" festgelegt.

With Worksheets("Crew")
    If .AutoFilterMode Then
        With .AutoFilter.Filters(1)
            If .On Then c1 = .Criteria1
        End With
    End If
End With


Beispiel zur AutoUpdate-Eigenschaft

In diesem Beispiel wird der Status der automatischen Aktualisierung für alle OLE-Objekte in Sheet1 angezeigt.

Worksheets("Sheet1").Activate
Range("A1").Value = "Name"
Range("B1").Value = "Link Status"
Range("C1").Value = "AutoUpdate Status"
i = 2
For Each obj In ActiveSheet.OLEObjects
    Cells(i, 1) = obj.Name
    If obj.OLEType = xlOLELink Then
        Cells(i, 2) = "Linked"
        Cells(i, 3) = obj.AutoUpdate
    Else
        Cells(i, 2) = "Embedded"
    End If
    i = i + 1
Next


Beispiel zur Background-Eigenschaft

In diesem Beispiel wird dem ersten eingebetteten Diagramm in Sheet1 ein Titel zugewiesen. Anschließend werden Schriftgröße und Art des Hintergrunds für den Titel festgelegt.

With Worksheets("Sheet1").ChartObjects(1).Chart
    .HasTitle = True
    .ChartTitle.Text = "1995 Rainfall Totals by Month"
    With .ChartTitle.Font
        .Size = 10
        .Background = xlBackgroundTransparent
    End With
End With


Beispiel zur BaseUnit-Eigenschaft

In diesem Beispiel wird für die Rubrikenachse im eingebetteten Chart1 des Tabellenblatts festgelegt, eine Zeitskala mit der Basiseinheit Monat zu benutzten.

With Worksheets(1).ChartObjects(1).Chart
    With .Axes(xlCategory)
        .CategoryType = xlTimeScale
        .BaseUnit = xlMonths
    End With
End With


Beispiel zur BeginConnected-Eigenschaft

Wenn es sich bei der dritten Form in myDocument um eine Verbindung handelt, deren Anfang mit einer Form verbunden ist, werden in diesem Beispiel die Nummer des Verbindungspunktes in der Variablen oldBeginConnSite und ein Bezug auf die verbundene Form in der Objektvariablen oldBeginConnShape gespeichert. Anschließend wird der Anfang der Verbindung von der Form getrennt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Connector Then
        With .ConnectorFormat
            If .BeginConnected Then
                oldBeginConnSite = .BeginConnectionSite
                Set oldBeginConnShape = .BeginConnectedShape
                .BeginDisconnect
            End If
        End With
    End If
End With


Beispiel zur Border-Eigenschaft

In diesem Beispiel wird dem Rahmen der Fläche von Chart1 die Farbe Rot zugewiesen.

Charts("Chart1").ChartArea.Border.ColorIndex = 3


Beispiel zur BuiltIn-Eigenschaft

In diesem Beispiel wird in Tabellenblatt 1 eine Liste erstellt, die die Namen und den integrierten Status aller Formatvorlagen der aktiven Arbeitsmappe enthält.

r = 0
Worksheets(1).Activate
For Each s In ActiveWorkbook.Styles
    r = r + 1
    Cells(r, 1).Value = s.Name
    Cells(r, 2).Value = s.BuiltIn
Next


Beispiel zur Calculation-Eigenschaft

In diesem Beispiel berechnet Microsoft Excel Arbeitsmappen, bevor sie gespeichert werden.

Application.Calculation = xlCalculateManual
Application.CalculateBeforeSave = True

In diesem Beispiel wird festgelegt, dass das Datenfeld des PivotTable-Berichts in Sheet1 den Unterschied zum Basisfeld berechnet. Das Feld "ORDER_DATE" wird als Basisfeld festgelegt und anschließend das Element "5/16/89" als Basiselement.

With Worksheets("Sheet1").Range("A3").PivotField
    .Calculation = xlDifferenceFrom
    .BaseField = "ORDER_DATE"
    .BaseItem = "5/16/89"
End With


Beispiel zur Category-Eigenschaft

In diesem Beispiel wird davon ausgegangen, dass eine benutzerdefinierte Funktion bzw. ein benutzerdefinierter Befehl in einer Makrovorlage von Microsoft Excel, Version 4.0, erstellt wurde. Die Funktionskategorie wird in der Sprache des Makros angezeigt. Es wird vorausgesetzt, dass der Name der benutzerdefinierten Funktion bzw. des benutzerdefinierten Befehls der einzige Name ist, der in der Arbeitsmappe vorkommt.

With ActiveWorkbook.Names(1)
    If .MacroType <> xlNone Then
        MsgBox "The category for this name is " & .Category
    Else
        MsgBox "This name does not refer to" & _
            " a custom function or command."
    End If
End With


Beispiel zur Charts-Eigenschaft

In diesem Beispiel wird der Text für den Titel von Chart1 festgelegt.

With Charts("Chart1")
    .HasTitle = True
    .ChartTitle.Text = "First Quarter Sales"
End With

In diesem Beispiel werden alle Diagrammblätter in der aktiven Arbeitsmappe gelöscht.

ActiveWorkbook.Charts.Delete

In diesem Beispiel werden Chart1, Chart3 und Chart5 ausgeblendet.

Charts(Array("Chart1", "Chart3", "Chart5")).Visible = False


Beispiel zur Chart-Eigenschaft

In diesem Beispiel wird dem ersten eingebetteten Diagramm in Sheet1 ein Titel hinzugefügt.

With Worksheets("Sheet1").ChartObjects(1).Chart
    .HasTitle = True
    .ChartTitle.Text = "1995 Rainfall Totals by Month"
End With


Beispiel zur Color-Eigenschaft

In diesem Beispiel wird die Farbe der Teilstrichbeschriftungen für die Größenachse in Chart1 festgelegt.

Charts("Chart1").Axes(xlValue).TickLabels.Font.Color = _
    RGB(0, 255, 0)


Beispiel zur Column-Eigenschaft

In diesem Beispiel wird die Breite jeder zweiten Spalte in Sheet1 auf 4 Punkt festgelegt.

For Each col In Worksheets("Sheet1").Columns
    If col.Column Mod 2 = 0 Then
        col.ColumnWidth = 4
    End If
Next col


Beispiel zur Comment-Eigenschaft

In diesem Beispiel wird der Kommentar für das Szenario eins in Sheet1 festgelegt.

Worksheets("Sheet1").Scenarios(1).Comment = _
    "Worst case July 1993 sales"


 Beispiel zur Connection-Eigenschaft

Beispiel zur Connection-Eigenschaft

In diesem Beispiel wird ein neuer PivotTable-Cache erstellt, der auf einem OLAP-Anbieter basiert, und anschließend in Zelle "A3" im aktiven Tabellenblatt ein neuer PivotTable-Bericht erstellt, der auf dem Cache basiert.

With ActiveWorkbook.PivotCaches.Add(SourceType:=xlExternal)
    .Connection = _
        "OLEDB;Provider=MSOLAP;Location=srvdata;Initial Catalog=National"
    .MaintainConnection = True
    .CreatePivotTable TableDestination:=Range("A3"), _
        TableName:= "PivotTable1"
End With
With ActiveSheet.PivotTables("PivotTable1")
    .SmallGrid = False
    .PivotCache.RefreshPeriod = 0
    With .CubeFields("[state]")
        .Orientation = xlColumnField
        .Position = 0
    End With
    With .CubeFields("[Measures].[Count Of au_id]")
        .Orientation = xlDataField
        .Position = 0
    End With
End With

In diesem Beispiel werden der ersten Abfragetabelle im ersten Tabellenblatt neue ODBC-Verbindungsinformationen bereit gestellt.

Worksheets(1).QueryTables(1) _
    .Connection:="ODBC;DSN=96SalesData;UID=Rep21;PWD=NUyHwYQI;"

In diesem Beispiel wird eine Textdatei angegeben.

Worksheets(1).QueryTables(1) _
    Connection := "TEXT;C:\My Documents\19980331.txt"


Beispiel zur Connector-Eigenschaft

In diesem Beispiel werden in myDocument alle Verbindungen gelöscht.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    For i = .Count To 1 Step -1
        With .Item(i)
            If .Connector Then .Delete
        End With
    Next
End With


Beispiel zur Crosses-Eigenschaft

In diesem Beispiel wird festgelegt, dass die Größenachse in Chart1 die Rubrikenachse (x-Achse) in deren Maximum schneidet.

Charts("Chart1").Axes(xlCategory).Crosses = xlMaximum


 Beispiel zur CubeField-Eigenschaft

Beispiel zur CubeField-Eigenschaft

In diesem Beispiel wird eine Liste der Cube-Feldnamen für alle Hierarchiefelder in dem ersten OLAP-basierten PivotTable-Bericht in Sheet1 erstellt.

Set objNewSheet = Worksheets.Add
objNewSheet.Activate
intRow = 1
For Each objPF in _
    Worksheets("Sheet1").PivotTables(1).PivotFields
    If objPF.CubeField.CubeFieldType = xlHierarchy Then
        objNewSheet.Cells(intRow, 1).Value = objPF.Name
        intRow = intRow + 1
    End If
Next objPF


Beispiel zur CurrentPage-Eigenschaft

In diesem Beispiel wird der Name der aktuellen Seite für den PivotTable-Bericht im ersten Tabellenblatt in der Zeichenfolgevariablen strPgName zurückgegeben.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
strPgName = pvtTable.PivotFields("Country").CurrentPage.Name


Beispiel zur Cursor-Eigenschaft

In diesem Beispiel wird der Mauszeiger in einen I-Mauszeiger geändert und nach einer Pause wieder in den Standardzeiger umgewandelt.

Sub ChangeCursor()
    Application.Cursor = xlIBeam
    For x = 1 To 1000
        For y = 1 to 1000
        Next y
    Next x
    Application.Cursor = xlDefault
End Sub


Beispiel zur DataLabel-Eigenschaft

In diesem Beispiel wird die Beschriftung für Datenpunkt 7 der dritten Datenreihe in Chart1 aktiviert. Danach wird der Datenbeschriftung die Farbe Blau zugewiesen.

With Charts("Chart1").SeriesCollection(3).Points(7)
    .HasDataLabel = True
    .ApplyDataLabels type:=xlValue
    .DataLabel.Font.ColorIndex = 5
End With


Beispiel zur Depth-Eigenschaft

In diesem Beispiel wird in myDocument eine Ellipse eingefügt und anschließend auf eine Tiefe von 50 Punkt projiziert. Der Projektion wird die Farbe Violett zugewiesen.

Set myDocument = Worksheets(1)
Set myShape = myDocument.Shapes.AddShape(msoShapeOval, _
    90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    ' RGB value for purple
End With


Beispiel zur DisplayUnit-Eigenschaft

In diesem Beispiel werden die auf der Größenachse in Chart1 angezeigten Einheiten auf Hundert eingestellt.

With Charts("Chart1").Axes(xlValue)
    .DisplayUnit = xlHundreds
    .HasTitle = True
    .AxisTitle.Caption = "Rebate Amounts"
End With


 Beispiel zur Drilled-Eigenschaft

Beispiel zur Drilled-Eigenschaft

In diesem Beispiel werden die Mitglieder der zweiten Ebene des ersten Cube-Feldes im ersten PivotTable-Bericht des aktiven Arbeitsblatts eingeblendet.

ActiveSheet.PivotTables("PivotTable1").CubeFields(1) _
    .TreeviewControl.Drilled = _
        Array(Array("", "", "", "", "", "", "", "", _
        "", "", "", ""), _
        Array("[state].[states].[AB]", _
        "[state].[states].[CA]", _
        "[state].[states].[IN]", _
        "[state].[states].[KS]", _
        "[state].[states].[KY]", _
        "[state].[states].[MD]", _
        "[state].[states].[MI]", _
        "[state].[states].[OH]", _
        "[state].[states].[OR]", _
        "[state].[states].[TN]", _
        "[state].[states].[UT]", _
        "[state].[states].[WA]"))


Beispiel zur Drop-Eigenschaft

In diesem Beispiel wird der benutzerdefinierte Ansatz der ersten Form in myDocument durch einen von zwei vordefinierten Ansätzen ersetzt. Welcher der vordefinierten Ansätze eingesetzt wird, hängt davon ab, ob der benutzerdefinierte Ansatzwert größer oder kleiner ist als die halbe Höhe des Legendentextfeldes. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um eine Legende handeln.

Set myDocument = Worksheets(1)
With myDocument.Shapes(1).Callout
    If .DropType = msoCalloutDropCustom Then
        If .Drop < .Parent.Height / 2 Then
            .PresetDrop msoCalloutDropTop
        Else
            .PresetDrop msoCalloutDropBottom
        End If
    End If
End With


Beispiel zur Enabled-Eigenschaft

In diesem Beispiel wird das eingebettete Chart1 in Tabellenblatt 1 deaktiviert.

Worksheets(1).ChartObjects(1).Enabled = False


Beispiel zur EndConnected-Eigenschaft

Wenn das Ende der Verbindung, die durch die dritte Form in myDocument dargestellt wird, mit einer Form verbunden ist, werden in diesem Beispiel die Nummer des Verbindungspunktes in der Variablen oldBeginConnSite und ein Bezug auf die verbundene Form in der Objektvariablen oldBeginConnShape gespeichert. Anschließend wird das Ende der Verbindung von der Form getrennt.

Set myDocument = Worksheets(1)
With myDocument.Shapes(3)
    If .Connector Then
        With .ConnectorFormat
            If .EndConnected Then
                oldEndConnSite = .EndConnectionSite
                Set oldEndConnShape = .EndConnectedShape
                .EndDisconnect
            End If
        End With
    End If
End With


Beispiel zur End-Eigenschaft

In diesem Beispiel wird die oberste Zelle in Spalte B in dem Bereich markiert, der die Zelle B4 enthält.

Range("B4").End(xlUp).Select

In diesem Beispiel wird die Zelle am Ende der vierten Zeile in dem Bereich markiert, der die Zelle B4 enthält.

Range("B4").End(xlToRight).Select

In diesem Beispiel wird die Markierung von Zelle B4 bis zur letzten Zelle in der vierten Zeile erweitert, die Daten enthält.

Worksheets("Sheet1").Activate
Range("B4", Range("B4").End(xlToRight)).Select


Beispiel zur ExtrusionColor-Eigenschaft

In diesem Beispiel wird in myDocument eine Ellipse eingefügt, auf eine Tiefe von 50 Punkt projiziert und als Projektionsfarbe Violett festgelegt.

Set myDocument = Worksheets(1)
Set myShape = myDocument.Shapes.AddShape(msoShapeOval, _
    90, 90, 90, 40)
With myShape.ThreeD
    .Visible = True
    .Depth = 50
    .ExtrusionColor.RGB = RGB(255, 100, 255)
    ' RGB value for purple
End With


Beispiel zur Fill-Eigenschaft

In diesem Beispiel wird in myDocument ein Rechteck eingefügt und für dessen Füllung Vordergrundfarbe, Hintergrundfarbe und Farbverlauf festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeRectangle, _
        90, 90, 90, 50).Fill
    .ForeColor.RGB = RGB(128, 0, 0)
    .BackColor.RGB = RGB(170, 170, 170)
    .TwoColorGradient msoGradientHorizontal, 1
End With


Beispiel zur FixedDecimal-Eigenschaft

Dieses Beispiel stellt die FixedDecimal-Eigenschaft auf True, und stellt anschließend die FixedDecimalPlaces-Eigenschaft auf 4. Wenn Sie nach der Ausführung dieses Beispiels "30000" eingeben, wird auf dem Tabellenblatt der Wert "3" produziert und nach Eingabe von "12500" wird "1,25" produziert.

Application.FixedDecimal = True
Application.FixedDecimalPlaces = 4


Beispiel zur Fonts-Eigenschaft

In diesem Beispiel wird die Standardfestbreitenschrift für den Zeichensatz "Englisch/Westeuropäisch/Anderer Lateinischer Zeichensatz" auf "Courier New", 14 Punkte festgelegt.

With Application.DefaultWebOptions _
    .Fonts(msoCharacterSetEnglishWesternEuropeanOtherLatinScript)
        .FixedWidthFont = "Courier New"
        .FixedWidthFontSize = 14
End With


Beispiel zur Font-Eigenschaft

In diesem Beispiel wird die Schriftart von Zelle B5 in Sheet1 auf 14 Punkt, fett und kursiv gesetzt.

With Worksheets("Sheet1").Range("B5").Font
    .Size = 14
    .Bold = True
    .Italic = True
End With


Beispiel zur FormulaR1C1-Eigenschaft

In diesem Beispiel wird die Formel für Zelle B1 in Sheet1 festgelegt.

Worksheets("Sheet1").Range("B1").FormulaR1C1 = "=SQRT(R1C1)"


Beispiel zur Formula-Eigenschaft

In diesem Beispiel wird die Formel für Zelle A1 in Sheet1 festgelegt.

Worksheets("Sheet1").Range("A1").Formula = "=$A$4+$A$10"


Beispiel zur Gap-Eigenschaft

In diesem Beispiel wird für die erste Form in myDocument der Abstand zwischen Legendenlinie und Textbegrenzungsrechteck auf 3 Punkt festgelegt. Damit das Beispiel funktioniert, muss es sich bei der ersten Form um eine Legende handeln.

Set myDocument = Worksheets(1)
myDocument.Shapes(1).Callout.Gap = 3


Beispiel zur GridlineColor-Eigenschaft

In diesem Beispiel wird den Gitternetzlinien im aktiven Fenster von BOOK1.XLS die Farbe Rot zugewiesen.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.GridlineColor = RGB(255,0,0)


Beispiel zur HasDataLabel-Eigenschaft

In diesem Beispiel wird die Beschriftung für Datenpunkt 7 der dritten Datenreihe in Chart1 aktiviert. Danach wird der Datenbeschriftung die Farbe Blau zugewiesen.

With Charts("Chart1").SeriesCollection(3).Points(7)
    .HasDataLabel = True
    .ApplyDataLabels Type:=xlValue
    .DataLabel.Font.ColorIndex = 5
End With


Beispiel zur Height-Eigenschaft

In diesem Beispiel wird die Höhe des eingebetteten Diagramms festgelegt.

Worksheets("Sheet1").ChartObjects(1).Height = 288


 Beispiel zur Hidden-Eigenschaft

Beispiel zur Hidden-Eigenschaft

In diesem Beispiel wird Spalte C in Sheet1 ausgeblendet.

Worksheets("Sheet1").Columns("C").Hidden = True

In diesem Beispiel wird das Mitglied [state].[states].[CA].[Covelo] der zweiten Ebene des ersten Cube-Feldes im ersten PivotTable-Bericht ausgeblendet.

ActiveSheet.PivotTables("PivotTable1").CubeFields(1) _
    .TreeviewControl.Hidden = _
        Array(Array(""), Array(""), _
        Array("[state].[states].[CA].[Covelo]"))


Beispiel zur Hyperlink-Eigenschaft

In diesem Beispiel wird das Dokument geladen, das dem Hyperlink in der ersten Form zugeordnet ist.

Worksheets(1).Shapes(1).Hyperlink.Follow NewWindow:=True


Beispiel zur Intercept-Eigenschaft

In diesem Beispiel wird festgelegt, dass die erste Trendlinie in Chart1 die Größenachse auf Punkt 5 schneidet. Wenden Sie dieses Beispiel auf ein 2D-Säulendiagramm an, das eine einzelne Datenreihe mit einer Trendlinie enthält.

Charts("Chart1").SeriesCollection(1).Trendlines(1).Intercept = 5


Beispiel zur Left-Eigenschaft

In diesem Beispiel wird die linke Seite des eingebetteten Diagramms an der linken Seite der Spalte B ausgerichtet.

With Worksheets("Sheet1")
    .ChartObjects(1).Left = .Columns("B").Left
End With


Beispiel zur Legend-Eigenschaft

In diesem Beispiel wird die Legende von Chart1 aktiviert. Anschließend wird der Legende die Farbe Blau zugewiesen.

Charts("Chart1").HasLegend = True
Charts("Chart1").Legend.Font.ColorIndex = 5


Beispiel zur Line-Eigenschaft

In diesem Beispiel wird in myDocument eine blau gestrichelte Linie eingefügt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddLine(10, 10, 250, 250).Line
    .DashStyle = msoLineDashDotDot
    .ForeColor.RGB = RGB(50, 0, 128)
End With

In diesem Beispiel wird in myDocument ein Kreuz eingefügt und anschließend dessen Rahmen auf eine Stärke von 8 Punkt sowie auf die Farbe Rot gesetzt.

Set myDocument = Worksheets(1)
With myDocument.Shapes.AddShape(msoShapeCross, 10, 10, 50, 70).Line
    .Weight = 8
    .ForeColor.RGB = RGB(255, 0, 0)
End With


Beispiel zur Location-Eigenschaft

In diesem Beispiel wird die Position des horizontalen Seitenwechsels verschoben.

Worksheets(1).HPageBreaks(1).Location = Worksheets(1).Range("e5")


Beispiel zur Locked-Eigenschaft

In diesem Beispiel wird die Sperre für den Bereich A1:G37 in Sheet1 aufgehoben, so dass Änderungen möglich sind, wenn das Blatt geschützt ist.

Worksheets("Sheet1").Range("A1:G37").Locked = False
Worksheets("Sheet1").Protect


Beispiel zur MajorUnit-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    .MajorUnit = 100
    .MinorUnit = 20
End With


Beispiel zur MarkerBackgroundColor-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe in Chart1 festgelegt.

With Charts("Chart1").SeriesCollection(1).Points(2)
    .MarkerBackgroundColor = RGB(0,255,0)    ' green
    .MarkerForegroundColor = RGB(255,0,0)    ' red
End With


Beispiel zur MarkerForegroundColor-Eigenschaft

In diesem Beispiel werden die Hinter- und Vordergrundfarbe des zweiten Datenpunktes der ersten Datenreihe in Chart1 festgelegt.

With Charts("Chart1").SeriesCollection(1).Points(2)
    .MarkerBackgroundColor = RGB(0,255,0)    ' green
    .MarkerForegroundColor = RGB(255,0,0)    ' red
End With


Beispiel zur MaximumScale-Eigenschaft

In diesem Beispiel werden der höchste und der niedrigste Wert für die Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    .MinimumScale = 10
    .MaximumScale = 120
End With


Beispiel zur Maximum-Eigenschaft

In diesem Beispiel wird die maximale Anzahl der Einträge in der Liste der zuletzt geöffneten Dateien auf 6 gesetzt.

Application.RecentFiles.Maximum = 6


Beispiel zur Max-Eigenschaft

In diesem Beispiel wird eine Bildlaufleiste erstellt, und ihre Werte für "LinkedCell", "Min", "Max", "LargeChange" und "SmallChange" werden festgelegt.

Set sb = Worksheets(1).Shapes.AddFormControl(xlScrollBar, _
    Left:=10, Top:=10, Width:=10, Height:=200)
With sb.ControlFormat
    .LinkedCell = "D1"
    .Max = 100
    .Min = 0
    .LargeChange = 10
    .SmallChange = 2
End With


Beispiel zur MinimumScale-Eigenschaft

In diesem Beispiel werden der höchste und der niedrigste Wert für die Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    .MinimumScale = 10
    .MaximumScale = 120
End With


Beispiel zur MinorUnit-Eigenschaft

In diesem Beispiel werden die Haupt- und Hilfsintervalle der Größenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlValue)
    .MajorUnit = 100
    .MinorUnit = 20
End With


Beispiel zur Min-Eigenschaft

In diesem Beispiel wird eine Bildlaufleiste erstellt und ihre Werte für "LinkedCell", "Min", "Max", "LargeChange" und "SmallChange" festgelegt.

Set sb = Worksheets(1).Shapes.AddFormControl(xlScrollBar, _
    Left:=10, Top:=10, Width:=10, Height:=200)
With sb.ControlFormat
    .LinkedCell = "D1"
    .Max = 100
    .Min = 0
    .LargeChange = 10
    .SmallChange = 2
End With


Beispiel zur MoveAfterReturn-Eigenschaft

In diesem Beispiel wird die MoveAfterReturn-Eigenschaft auf True gesetzt.

Application.MoveAfterReturn = True


Beispiel zur Name-Eigenschaft

In diesem Beispiel wird der Name von der ersten Formatvorlage in der aktiven Arbeitsmappe zunächst in der Sprache des Makros und anschließend in der Sprache des Benutzers oder der Benutzerin angezeigt.

With ActiveWorkbook.Styles(1)
    MsgBox "The name of the style is " & .Name
    MsgBox "The localized name of the style is " & .NameLocal
End With


Beispiel zur NumberFormat-Eigenschaft

In diesen Beispielen wird das Zahlenformat für Zelle A17, erste Zeile, sowie für Spalte C in Sheet1 festgelegt.

Worksheets("Sheet1").Range("A17").NumberFormat = "General"
Worksheets("Sheet1").Rows(1).NumberFormat = "hh:mm:ss"
Worksheets("Sheet1").Columns("C"). _
    NumberFormat = "$#,##0.00_);[Red]($#,##0.00)"


Beispiel zur Number-Eigenschaft

In diesem Beispiel werden die Fehlernummer sowie weitere Fehlerinformationen angezeigt, die von der letzten OLE DB-Abfrage zurückgegeben wurden.

Set objEr = Application.OLEDBErrors(1)
MsgBox "The following error occurred:" & _
    objEr.Number & ", " & objEr.Native & ", " & _
    objEr.ErrorString & " : " & objEr.SqlState


Beispiel zur On-Eigenschaft

Im folgenden Beispiel wird eine Variable auf den Wert der Criteria1-Eigenschaft des Filters für die erste Spalte im gefilterten Bereich von Tabellenblatt "Crew" festgelegt.

With Worksheets("Crew")
    If .AutoFilterMode Then
        With .AutoFilter.Filters(1)
            If .On Then c1 = .Criteria1
        End With
    End If
End With


Beispiel zur Outline-Eigenschaft

In diesem Beispiel wird festgelegt, dass in der Gliederung in Sheet1 automatische Formatvorlagen verwendet werden.

Worksheets("Sheet1").Outline.AutomaticStyles = True


Beispiel zur PageFields-Eigenschaft

In diesem Beispiel werden die Namen der Seitenfelder in ein Listenfeld auf einem neuen Tabellenblatt aufgenommen.

Set nwSheet = Worksheets.Add
nwSheet.Activate
Set pvtTable = Worksheets("Sheet2").Range("A1").PivotTable
rw = 0
For Each pvtField In pvtTable.PageFields
    rw = rw + 1
    nwSheet.Cells(rw, 1).Value = pvtField.Name
Next pvtField


Beispiel zur PageRange-Eigenschaft

In diesem Beispiel werden die Seitenköpfe in dem PivotTable-Bericht markiert.

Worksheets("Sheet1").Activate
Range("A3").Select
ActiveCell.PivotTable.PageRange.Select


Beispiel zur ParentItem-Eigenschaft

In diesem Beispiel wird der Name des übergeordneten Elements für das Element angezeigt, das die aktive Zelle enthält.

Worksheets("Sheet1").Activate
MsgBox "This item is a subitem of " & _
    ActiveCell.PivotItem.ParentItem.Name


Beispiel zur Parent-Eigenschaft

Das folgende Beispiel zeigt den Namen des Diagramms an, welches das Objekt myAxis enthält.

Set myAxis = Charts(1).Axes(xlValue)
MsgBox myAxis.Parent.Name


Beispiel zur Path-Eigenschaft

In diesem Beispiel wird der vollständige Pfad zu Microsoft Excel angezeigt.

MsgBox "The path is " & Application.Path


Beispiel zur PatternColor-Eigenschaft

In diesem Beispiel wird die Musterfarbe für den Innenraum des ersten Rechtecks in Sheet1 festgelegt.

With Worksheets("Sheet1").Rectangles(1).Interior
    .Pattern = xlGrid
    .PatternColor = RGB(255,0,0)
End With


Beispiel zur Pattern-Eigenschaft

In diesem Beispiel wird der Innenbereich von Zelle A1 in Sheet1 mit einer Kreuzschraffur formatiert.

Worksheets("Sheet1").Range("A1"). _
    Interior.Pattern = xlPatternCrissCross


Beispiel zur Phonetic-Eigenschaft

In diesem Beispiel wird die erste phonetische Textzeichenfolge in der aktiven Zelle auf " furigana furigana furigana furigana " festgelegt.

ActiveCell.Phonetics(1).Text = "  furigana   furigana   furigana   furigana "

Um die Kompatibilität mit früheren Versionen von Microsoft Excel zu zeigen, werden in diesem Beispiel die Furigana-Zeichen in Zelle C5 ausgeblendet.

Range("C5").Phonetic.Visible = False


Beispiel zur PivotField-Eigenschaft

In diesem Beispiel wird der Name des PivotTable-Felds angezeigt, das die aktive Zelle enthält.

Worksheets("Sheet1").Activate
MsgBox "The active cell is in the field " & _
    ActiveCell.PivotField.Name


Beispiel zur PivotTable-Eigenschaft

In diesem Beispiel wird die Seite "Canada" als aktuelle Seite für den PivotTable-Bericht in Sheet1 festgelegt.

Set pvtTable = Worksheets("Sheet1").Range("A3").PivotTable
pvtTable.PivotFields("Country").CurrentPage = "Canada"

In diesem Beispiel wird der PivotTable-Bericht bestimmt, der dem Diagramm "Sales" im aktiven Tabellenblatt zugeordnet ist. Anschließend wird die Seite mit dem Namen "Oregon" als aktuelle Seite des PivotTable-Berichts festgelegt.

Set objPT = _
    ActiveSheet.Charts("Sales").PivotLayout.PivotTable
objPT.PivotFields("State").CurrentPageName = "Oregon"


Beispiel zur Previous-Eigenschaft

In diesem Beispiel wird die vohergehende nicht gesperrte Zelle in Sheet1 ausgewählt. Falls Sheet1 nicht geschützt ist, handelt es sich um die Zelle, die sich unmittelbar links neben der aktiven Zelle befindet.

Worksheets("Sheet1").Activate
ActiveCell.Previous.Select


Beispiel zur QueryTable-Eigenschaft

In diesem Beispiel wird die Abfragetabelle aktualisiert, die die Zelle A10 des ersten Tabellenblattes schneidet.

Worksheets(1).Range("a10").QueryTable.Refresh


Range-Eigenschaft (Shapes-Auflistung)

Gibt ein ShapeRange-Objekt zurück, das einen Teilbereich der Formen in einer Shapes-Auflistung darstellt.

Syntax

Ausdruck.Range(Index)

Ausdruck Erforderlich. Ein Ausdruck, der ein Shapes-Objekt zurückgibt.

Index Variant erforderlich. Die einzelnen Formen, die in den Bereich aufgenommen werden sollen. Kann eine Ganzzahl sein, die die Indexnummer der Form angibt, eine Zeichenfolge, die den Namen der Form angibt, oder eine Matrix, die entweder Ganzzahlen oder Zeichenfolgen enthält.

Anmerkungen

Obwohl Sie mit der Range-Eigenschaft eine beliebige Anzahl von Formen zurückgeben können, ist es einfacher, die Item-Methode zu verwenden, wenn Sie nur ein einzelnes Element der Auflistung zurückgeben möchten. Beispielsweise ist Shapes(1) einfacher als Shapes.Range(1).

Um für Index eine Matrix aus Ganzzahlen oder Zeichenfolgen festzulegen, können Sie die Array-Funktion verwenden. Beispielsweise gibt die folgende Anweisung zwei durch Namen festgelegte Formen zurück.

Dim arShapes() As Variant
Dim objRange As Object
arShapes = Array("Oval 4", "Rectangle 5")
Set objRange = ActiveSheet.Shapes.Range(arShapes)

In Microsoft Excel kann diese Eigenschaft nicht verwendet werden, um ein ShapeRange-Objekt zurückzugeben, das alle Shape-Objekte eines Tabellenblattes enthält. Zu diesem Zweck verwenden Sie folgenden Code:

Worksheets(1).Shapes.Select        ' select all shapes
set sr = Selection.ShapeRange      ' create ShapeRange


Beispiel zur Range-Eigenschaft (Shapes-Auflistung)

In diesem Beispiel wird das Füllmuster für die erste und die dritte Form in myDocument festgelegt.

Set myDocument = Worksheets(1)
myDocument.Shapes.Range(Array(1, 3)) _
    .Fill.Patterned msoPatternHorizontalBrick

In diesem Beispiel wird das Füllmuster für die Formen "Ellipse 4" und "Rechteck 5" in myDocument festgelegt.

Dim arShapes() As Variant
Dim objRange As Object
Set myDocument = Worksheets(1)
arShapes = Array("Oval 4", "Rectangle 5")
Set objRange = myDocument.Shapes.Range(arShapes)
objRange.Fill.Patterned msoPatternHorizontalBrick

In diesem Beispiel wird das Füllmuster für die erste Form in myDocument festgelegt.

Set myDocument = Worksheets(1)
Set myRange = myDocument.Shapes.Range(1)
myRange.Fill.Patterned msoPatternHorizontalBrick

In diesem Beispiel wird eine Matrix erstellt, die alle AutoFormen in myDocument enthält. Mit der Matrix wird ein Formbereich definiert, anschließend werden alle Formen dieses Bereichs horizontal verteilt.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    numShapes = .Count
    If numShapes > 1 Then
        numAutoShapes = 1
        ReDim autoShpArray(1 To numShapes)
        For i = 1 To numShapes
            If .Item(i).Type = msoAutoShape Then
                autoShpArray(numAutoShapes) = .Item(i).Name
                numAutoShapes = numAutoShapes + 1
            End If
        Next
        If numAutoShapes > 1 Then
            ReDim Preserve autoShpArray(1 To numAutoShapes)
            Set asRange = .Range(autoShpArray)
            asRange.Distribute msoDistributeHorizontally, False
        End If
    End If
End With


Range-Eigenschaft (Application-, Range- oder Worksheet-Objekt)

Gibt ein Range-Objekt zurück, das eine Zelle oder einen Zellbereich darstellt.

Syntax 1

Ausdruck.Range(Cell1)

Syntax 2

Ausdruck.Range(Cell1, Cell2)

Ausdruck Bei Application optional, bei Range und Worksheet erforderlich. Ein Ausdruck, der ein Objekt zurückgibt. Um eine Liste der verfügbaren Objekte zu erhalten, klicken Sie auf Betrifft.

Cell1 Syntax 1: Variant erforderlich. Der Name des Bereichs. Es muss ein Bezug in A1-Schreibweise in der Sprache des Makros sein. Es kann den Bereichsoperator (Doppelpunkt), den Schnittmengenoperator (Leerzeichen) oder den Vereinigungsoperator (Komma) enthalten. Auch Dollarzeichen können enthalten sein, werden jedoch ignoriert. Sie können in jedem Teil des Bereichs einen lokal definierten Namen verwenden. Bei diesem Namen wird davon ausgegangen, dass er aus der Sprache des Makros stammt.

Syntax 2: Variant erforderlich. Die Zelle in der linken oberen Ecke des Bereichs. Es kann ein Range-Objekt sein, das eine einzelne Zelle, eine gesamte Spalte oder eine gesamte Zeile enthält, oder eine Zeichenfolge, die eine einzelne Zelle in der Sprache des Makros bezeichnet.

Cell1, Cell2 Variant optional. Die Zellen in der oberen linken und unteren rechten Ecke des Bereichs. Es kann ein Range-Objekt sein, das eine einzelne Zelle, eine gesamte Zeile oder eine gesamte Spalte enthält, oder eine Zeichenfolge, die eine einzelne Zelle in der Sprache des Makros bezeichnet.

Anmerkungen

Wenn diese Eigenschaft mit einem Objektkennzeichner verwendet wird, so ist sie ein Shortcut für ActiveSheet.Range (sie gibt einen Bereich aus dem aktiven Blatt zurück; handelt es sich dabei nicht um ein Tabellenblatt, führt die Eigenschaft zu einem Fehler).

Bei Anwendung auf ein Range-Objekt verhält sich die Eigenschaft relativ zu dem Range-Objekt. Besteht die Auswahl beispielsweise aus der Zelle C3, so gibt Selection.Range("B1") Zelle D3 zurück, da sie sich relativ zu dem Range-Objekt verhält, das von der Selection-Eigenschaft zurückgegeben wird. Dagegen gibt der Code ActiveSheet.Range("B1") immer die Zelle B1 zurück.


Beispiel zur Range-Eigenschaft (Application-, Range- oder Worksheet-Objekt)

In diesem Beispiel wird der Wert der Zelle A1 in Sheet1 auf 3,14159 gesetzt.

Worksheets("Sheet1").Range("A1").Value = 3.14159

In diesem Beispiel wird in der Zelle A1 der Sheet1 eine Formel erstellt.

Worksheets("Sheet1").Range("A1").Formula = "=10*RAND()"

In diesem Beispiel werden die Zellen A1:D10 der Sheet1 in einer Schleife bearbeitet. Ist der Wert einer dieser Zellen kleiner als 0,001, wird er durch 0 (Null) ersetzt.

For Each c in Worksheets("Sheet1").Range("A1:D10")
    If c.Value < .001 Then
        c.Value = 0
    End If
Next c

In diesem Beispiel wird der Bereich testRange in einer Schleife bearbeitet und die Anzahl der leeren Zellen des Bereiches angezeigt.

numBlanks = 0
For Each c In Range("testRange")
    If c.Value = "" Then
        numBlanks = numBlanks + 1
    End If
Next c
MsgBox "There are " & numBlanks & " empty cells in this range"

In diesem Beispiel wird die Schriftstil in den Zellen A1:C5 der Sheet1 auf kursiv gesetzt. Dabei wird Syntax 2 der Range-Eigenschaft verwendet.

Worksheets("Sheet1").Range(Cells(1, 1), Cells(5, 3)). _
    Font.Italic = True


Beispiel zur ReadOnly-Eigenschaft

In diesem Beispiel wird die aktive Arbeitsmappe unter NEWFILE.XLS gespeichert, falls sie schreibgeschützt ist.

If ActiveWorkbook.ReadOnly Then
    ActiveWorkbook.SaveAs fileName:="NEWFILE.XLS"
End If


Beispiel zur RefersToR1C1-Eigenschaft

In diesem Beispiel wird ein neues Tabellenblatt erstellt und anschließend eine Liste aller Namen in der aktiven Arbeitsmappe zusammen mit den zugehörigen Formeln in Z1S1-Schreibweise in der Sprache des Makros eingefügt.

Set newSheet = ActiveWorkbook.Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.Name
    newSheet.Cells(i, 2).Value = "'" & nm.RefersToR1C1
    i = i + 1
Next


Beispiel zur RefersTo-Eigenschaft

In diesem Beispiel wird eine Liste aller Namen in der aktiven Arbeitsmappe erstellt. Die zugehörigen Formeln werden in A1-Schreibweise in der Sprache des Makros angezeigt. Die Liste wird in ein neues Tabellenblatt eingefügt, das das Makro zuvor erstellt hat.

Set newSheet = Worksheets.Add
i = 1
For Each nm In ActiveWorkbook.Names
    newSheet.Cells(i, 1).Value = nm.Name
    newSheet.Cells(i, 2).Value = "'" & nm.RefersTo
    i = i + 1
Next
newSheet.Columns("A:B").AutoFit


RelyOnCSS-Eigenschaft

True, falls Cascading Style Sheets (CSS) beim Anzeigen eines gespeicherten Dokuments in einem Webbrowser zur Schriftformatierung verwendet werden. Microsoft Excel erstellt eine CSS-Datei und speichert sie entweder im angegebenen Ordner oder im gleichen Ordner wie die Webseite. Dies hängt vom Wert der OrganizeInFolder-Eigenschaft ab. False, falls HTML <FONT>-Tags und Cascading Style Sheets verwendet werden. Der Standardwert ist True. Boolean Schreib-Lese-Zugriff.

Anmerkungen

Sie sollten diese Eigenschaft auf True festlegen, falls Ihr Webbrowser Cascading Style Sheets unterstützt, da Sie dadurch eine präzisere Kontrolle über Layout und Formatierung auf der Webseite erreichen und das Aussehen mehr dem Dokument entspricht (wie es in Microsoft Excel angezeigt wird).


Beispiel zur RelyOnCSS-Eigenschaft

In diesem Beispiel wird die Verwendung von Cascading Style Sheets als globale Standardeinstellung für die Anwendung aktiviert.

Application.DefaultWebOptions.RelyOnCSS = True


Beispiel zur RotationX-Eigenschaft

In diesem Beispiel werden in myDocument drei identische projizierte Ellipsen eingefügt und für ihre Drehung um die X-Achse ein Wert von -30, 0, bzw. 30 Grad festgelegt.

Set myDocument = Worksheets(1)
With myDocument.Shapes
    With .AddShape(msoShapeOval, 30, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = -30
    End With
    With .AddShape(msoShapeOval, 90, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 0
    End With
    With .AddShape(msoShapeOval, 150, 60, 50, 25).ThreeD
        .Visible = True
        .RotationX = 30
    End With
End With


Beispiel zur Row-Eigenschaft

In diesem Beispiel wird die Höhe jeder zweiten Zeile in Sheet1 auf 4 Punkt festgelegt.

For Each rw In Worksheets("Sheet1").Rows
    If rw.Row Mod 2 = 0 Then
        rw.RowHeight = 4
    End If
Next rw


Beispiel zur Saved-Eigenschaft

In diesem Beispiel wird eine Meldung angezeigt, falls Änderungen in der aktiven Arbeitsmappe noch nicht gespeichert wurden.

If Not ActiveWorkbook.Saved Then
    MsgBox "This workbook contains unsaved changes."
End If

In diesem Beispiel wird die Arbeitsmappe, die den Beispielcode enthält, geschlossen. Alle Änderungen werden verworfen, indem der Saved-Eigenschaft der Wert True zugewiesen wird.

ThisWorkbook.Saved = True
ThisWorkbook.Close


Beispiel zur Script-Eigenschaft

In diesem Beispiel wird der Typ der Skriptsprache angezeigt, die in der ersten Form des aktiven Tabellenblatts verwendet wird.

Set objScr = ActiveSheet.Shapes(1).Script
If Not (objScr Is Nothing) Then
    Select Case objScr.Language
        Case msoScriptLanguageVisualBasic
            MsgBox "VBScript"
        Case msoScriptLanguageJava
            MsgBox "JavaScript"
        Case msoScriptLanguageASP
            MsgBox "Active Server Pages"
        Case Else
            Msgbox "Other scripting language"
    End Select
End If


Beispiel zur Selection-Eigenschaft

In diesem Beispiel wird die Auswahl in Sheet1 gelöscht (es wird vorausgesetzt, dass ein Zellbereich markiert ist).

Worksheets("Sheet1").Activate
Selection.Clear

In diesem Beispiel wird der Visual Basic Objekttyp der Auswahl angezeigt.

Worksheets("Sheet1").Activate
MsgBox "The selection object type is " & TypeName(Selection)


Beispiel zur Shape-Eigenschaft

In diesem Beispiel wird der zweite Kommentar des aktiven Blattes markiert.

ActiveSheet.Comments(2).Shape.Select


Beispiel zur Sheets-Eigenschaft

In diesem Beispiel wird eine neue Arbeitsmappe erstellt und anschließend eine Liste mit den Namen der Blätter in der aktiven Arbeitsmappe in die erste Spalte eingefügt.

Set newSheet = Sheets.Add(Type:=xlWorksheet)
For i = 1 To Sheets.Count
    newSheet.Cells(i, 1).Value = Sheets(i).Name
Next i


Beispiel zur Sheet-Eigenschaft

In diesem Beispiel wird der Name des Tabellenblatts bestimmt, das das erste PublishObject-Objekt enthält, das in der Webseite als statischer HTML-Code gespeichert wurde. Anschließend wird in dem Beispiel die Variable blnSheetFound vom Typ Boolean auf True festgelegt. Wurden keine Elemente in dem Dokument als statischer HTML-Code gespeichert, ist blnSheetFound False.

blnSheetFound = False
For Each objPO In Workbooks(1).PublishObjects
    If objPO.HtmlType = xlHTMLStatic Then
        strFirstPO = objPO.Sheet
        blnSheetFound = True
        Exit For
    End If
Next objPO


Beispiel zur ShowWindow-Eigenschaft

In diesem Beispiel wird das eingebettete Diagramm in einem separaten Fenster angezeigt.

Worksheets(1).ChartObjects(1).Chart.ShowWindow = True


Beispiel zur Size-Eigenschaft

In diesem Beispiel wird der Schriftgrad für den Bereich A1:D10 in Sheet1 auf 12 Punkt eingestellt.

With Worksheets("Sheet1").Range("A1:D10")
    .Value = "Test"
    .Font.Size = 12
End With


Beispiel zur Source-Eigenschaft

In diesem Beispiel wird der eindeutige Name des ersten Diagramms (in der ersten Arbeitsmappe) bestimmt, das als Webseite gespeichert wurde. Anschließend wird die Variable blnChartFound vom Typ Boolean auf True festgelegt. Wenn keine Elemente im Dokument als Diagrammkomponenten gespeichert wurden, ist blnChartFound False.

blnChartFound = False
For Each objPO In Workbooks(1).PublishObjects
    If objPO.SourceType = xlSourceChart Then
        strFirstPO = objPO.Source
        blnChartFound = True
        Exit For
    End If
Next objPO


Beispiel zur Split-Eigenschaft

In diesem Beispiel wird das aktive Fenster von BOOK1.XLS bei Zelle B2 ohne Fixierung der Ausschnitte geteilt. Dadurch gibt die Split-Eigenschaft den Wert True zurück.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
With ActiveWindow
    .SplitColumn = 2
    .SplitRow = 2
End With

Die im vorherigen Beispiel herbeigeführte Teilung kann auf zwei Arten wieder aufgehoben werden.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.Split = False                  ' method one
Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
ActiveWindow.SplitColumn = 0                ' method two
ActiveWindow.SplitRow = 0

In diesem Beispiel wird die Teilung eines Fensters aufgehoben. Bevor Sie die Teilung aufheben können, müssen Sie der FreezePanes-Eigenschaft den Wert False zuweisen, um die Fixierung der Ausschnitte aufzuheben.

Workbooks("BOOK1.XLS").Worksheets("Sheet1").Activate
With ActiveWindow
    .FreezePanes = False
    .Split = False
End With


Beispiel zur StandardFont-Eigenschaft

In diesem Beispiel wird als Standardschriftart Geneva (auf dem Macintosh) oder Arial (unter Windows) eingestellt.

If Application.OperatingSystem Like "*Macintosh*" Then
    Application.StandardFont = "Geneva"
Else
    Application.StandardFont = "Arial"
End If


Beispiel zur Start-Eigenschaft

In diesem Beispiel wird die Startposition der zweiten phonetischen Textzeichenfolge in der aktiven Zelle zurückgegeben.

ActiveCell.FormulaR1C1 = "  toukyouto   toukyouto   toukyouto   shibuyaku   shibuyaku   shibuyaku   yoyogi   yoyogi   yoyogi "
ActiveCell.Phonetics.Add Start:=1, Length:=3, Text:="  toukyouto   toukyouto   toukyouto   toukyouto   toukyouto   toukyouto "
ActiveCell.Phonetics.Add Start:=4, Length:=3, Text:="  shibuyaku   shibuyaku   shibuyaku   shibuyaku "
MsgBox ActiveCell.Phonetics(2).Start


Beispiel zur Status-Eigenschaft

In diesem Beispiel wird der Verteiler für BOOK1.XLS nach Abschluss des Weiterleitens zurückgesetzt.

With Workbooks("BOOK1.XLS").RoutingSlip
    If .Status = xlRoutingComplete Then
        .Reset
    Else
        MsgBox "Cannot reset routing; not yet complete."
    End If
End With


Beispiel zur Style-Eigenschaft

In diesem Beispiel wird Zelle A1 in Sheet1 die Formatvorlage "Normal" zugewiesen.

Worksheets("Sheet1").Range("A1").Style.Name = "Normal"

Unter der Voraussetzung, dass Zelle B4 in Sheet1 zurzeit die Formatvorlage "Normal" zugewiesen ist, wird der Zelle in diesem Beispiel die Formatvorlage "Percent" zugewiesen.

If Worksheets("Sheet1").Range("B4").Style.Name = "Normal" Then
    Worksheets("Sheet1").Range("B4").Style.Name = "Percent"
End If


Beispiel zur Summary-Eigenschaft

In diesem Beispiel wird die vierte Zeile in Sheet1 fett und kursiv formatiert, wenn es sich um die Hauptspalte einer Gliederung handelt.

With Worksheets("Sheet1").Rows(4)
    If .Summary = True Then
        .Font.Bold = True
        .Font.Italic = True
    End If
End With


Beispiel zur Text-Eigenschaft

In diesem Beispiel wird der Text für den Titel von Chart1 festgelegt.

With Charts("Chart1")
    .HasTitle = True
    .ChartTitle.Text = "First Quarter Sales"
End With

In diesem Beispiel wird der Text der Rubrikenachse in Chart1 festgelegt.

With Charts("Chart1").Axes(xlCategory)
    .HasTitle = True
    .AxisTitle.Text = "Month"
End With

Dieses Beispiel illustriert den Unterschied zwischen den Eigenschaften Text und Value von Zellen, die formatierte Zahlen enthalten.

Set c = Worksheets("Sheet1").Range("B14")
c.Value = 1198.3
c.NumberFormat = "$#,##0_);($#,##0)"
MsgBox c.Value
MsgBox c.Text


Beispiel zur TickLabels-Eigenschaft

In diesem Beispiel wird die Farbe für die Teilstrichbeschriftungen auf der Größenachse in Chart1 festgelegt.

Charts("Chart1").Axes(xlValue).TickLabels.Font.ColorIndex = 3


Beispiel zur Top-Eigenschaft

In diesem Beispiel wird der obere Rand des eingebetteten Diagramms am oberen Rand von Zeile 2 ausgerichtet.

With Worksheets("Sheet1")
    .ChartObjects(1).Top = .Rows(2).Top
End With

In diesem Beispiel wird das aktive Fenster auf die maximal mögliche Größe erweitert (vorausgesetzt, das Fenster ist noch nicht maximiert).

With ActiveWindow
    .WindowState = xlNormal
    .Top = 1
    .Left = 1
    .Height = Application.UsableHeight
    .Width = Application.UsableWidth
End With


Beispiel zur TransitionMenuKey-Eigenschaft

Im folgenden Beispiel wird die alternative Menü- oder Hilfetaste auf "/" gesetzt (was der Vorgabe entspricht).

Application.TransitionMenuKey = "/"


Beispiel zur Transparency-Eigenschaft

In diesem Beispiel wird der Schatten der Form drei auf Tabellenblatt eins auf semitransparent rot festgelegt. Wenn die Form keinen Schatten hat, wird hier einer hinzugefügt.

With Worksheets(1).Shapes(3).Shadow
    .Visible = True
    .ForeColor.RGB = RGB(255, 0, 0)
    .Transparency = 0.5
End With


Beispiel zur Value-Eigenschaft

In diesem Beispiel wird der Wert von Zelle A1 in Sheet1 auf 3,14159 gesetzt.

Worksheets("Sheet1").Range("A1").Value = 3.14159

In diesem Beispiel werden die Zellen A1:D10 in Sheet1 in einer Schleife bearbeitet. Ist der Wert einer dieser Zellen kleiner als 0,001, wird er durch 0 (Null) ersetzt.

For Each c in Worksheets("Sheet1").Range("A1:D10")
    If c.Value < .001 Then
        c.Value = 0
    End If
Next c


Beispiel zur Visible-Eigenschaft

In diesem Beispiel wird Sheet1 ausgeblendet.

Worksheets("Sheet1").Visible = False

In diesem Beispiel wird Sheet1 eingeblendet.

Worksheets("Sheet1").Visible = True

Im folgenden Beispiel werden sämtliche Tabellenblätter der aktiven Arbeitsmappe eingeblendet.

For Each sh In Sheets
    sh.Visible = True
Next sh

Das nächste Beispiel erstellt ein neues Tabellenblatt und setzt dessen Visible-Eigenschaft auf xlVeryHidden. Verwenden Sie die Objektvariable neuesTabellenblatt (siehe die letzte Zeile des Beispiels), um einen Bezug zu dem Tabellenblatt herzustellen. Um die Objektvariable neuesTabellenblatt in einer anderen Prozedur verwenden zu können, müssen Sie sie am Anfang des Moduls vor allen Sub- oder Function-Prozeduren als öffentliche Variable deklarieren (Public neuesTabellenblatt As-Objekt).

Set newSheet = Worksheets.Add
newSheet.Visible = xlVeryHidden
newSheet.Range("A1:D4").Formula = "=RAND()"


Beispiel zur Walls-Eigenschaft

In diesem Beispiel wird den Kanten der Wände von Chart1 die Farbe Rot zugewiesen. Wenden Sie das Beispiel auf ein 3D-Diagramm an.

Charts("Chart1").Walls.Border.ColorIndex = 3


Beispiel zur Windows-Eigenschaft

In diesem Beispiel wird das erste sichtbare oder ausgeblendete Fenster in Microsoft Excel geschlossen.

Application.Windows(1).Close

In diesem Beispiel wird "Consolidated Balance Sheet" als Name des ersten Fensters in der Arbeitsmappe festgelegt. Diese Bezeichnung wird dann als Index für die Windows-Auflistung verwendet.

ActiveWorkbook.Windows(1).Caption = "Consolidated Balance Sheet"
ActiveWorkbook.Windows("Consolidated Balance Sheet") _
    .ActiveSheet.Calculate


Beispiel zur Worksheet-Eigenschaft

In diesem Beispiel wird der Name des Tabellenblatts angezeigt, das die aktive Zelle enthält. Dieses Beispiel muss von einem Tabellenblatt aus ausgeführt werden.

MsgBox ActiveCell.Worksheet.Name

In diesem Beispiel wird der Name des Tabellenblatts angezeigt, das den Bereich "testRange" enthält.

MsgBox Range("testRange").Worksheet.Name


Beispiel zur WriteReserved-Eigenschaft

Falls die aktive Arbeitsmappe ein Schreibschutz-Kennwort besitzt, wird in diesem Beispiel der Name des Benutzers, der die Datei mit dem Schreibschutz gespeichert hat, in einer Meldung angezeigt.

With ActiveWorkbook
    If .WriteReserved = True Then
        MsgBox "Please contact " & .WriteReservedBy & Chr(13) & _
            " if you need to insert data in this workbook."
    End If
End With


Beispiel zur ZOrder-Eigenschaft

In diesem Beispiel wird die Z-Position des ersten eingebetteten Diagramms in Sheet1 angezeigt.

MsgBox "The chart's z-order position is " & _
    Worksheets("Sheet1").ChartObjects(1).ZOrder


Microsoft Excel-Objekte (ChartGroups-Auflistung)

Pfeil nach oben

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach oben Klicken Sie auf den Pfeil, um zum vorherigen Diagramm zurückzukehren.


Microsoft Excel-Objekte (Charts-Auflistung)

Pfeil nach oben

Pfeil nach rechts

Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie auf den Pfeil, um das Diagramm zu erweitern.

Pfeil nach oben Klicken Sie auf den Pfeil, um zum vorherigen Diagramm zurückzukehren.


Microsoft Excel-Objekte (Shapes-Auflistung)

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt


Microsoft Excel-Objekte (Worksheets-Auflistung)

Pfeil nach oben

Pfeil nach rechts

Legende

Gelbes Feld Objekt und Auflistung
Blaues Feld nur Objekt

Pfeil nach rechts Klicken Sie auf den Pfeil, um das Diagramm zu erweitern.

Pfeil nach oben Klicken Sie auf den Pfeil, um zum vorherigen Diagramm zurückzukehren.

Pivot Fields-Auflistung (PivotField-Objekt)

Pfeil nach rechts