Rebuild Master-Dienstprogramm

Mit dem Rebuild Master-Dienstprogramm reparieren Sie eine beschädigte master-Datenbank oder ändern den Zeichensatz, die Sortierreihenfolge oder die Unicode-Sortierreihenfolge für eine Microsoft® SQL Server™-Installation. Bevor Sie das Rebuild Master-Dienstprogramm ausführen, sollten Sie sich vergewissern, dass sowohl die Skripts zum erneuten Erstellen der Datenbankobjekte als auch eine Sicherung für das erneute Laden der Daten vorhanden sind. Beim erneuten Erstellen einer master-Datenbank werden alle Datenbankobjekte und Daten entfernt. Nachdem Sie die master-Datenbank erneut erstellt haben, können Sie die Datenbankobjekte erneut erstellen und die Daten neu laden.

Quellverzeichnis mit Datendateien
Wählen Sie den Pfad zum Datenverzeichnis, von dem aus die master-Datenbank ursprünglich installiert wurde. Klicken Sie auf Durchsuchen, um ein Verzeichnis auszuwählen. In Abhängigkeit davon, wie Sie SQL Server installiert haben, legen Sie entweder die SQL Server-CD ein und wählen das Verzeichnis Data im Stammverzeichnis der CD aus, oder wählen Sie das Datenverzeichnis auf dem freigegebenen Netzwerkinstallationslaufwerk aus.
Einstellungen für Zeichensatz, Sortierreihenfolge und Unicode-Sortierreihenfolge
Klicken Sie auf Einstellungen, um für die SQL Server-Installation den Zeichensatz, die Sortierreihenfolge oder die Unicode-Sortierreihenfolge zu ändern.
Datenverzeichnis
Zeigt das lokale Verzeichnis an, in dem die master-Datenbank gespeichert ist.

Klicken Sie auf Erneut erstellen, um die master-Datenbank mit den angegebenen Einstellungen für den Zeichensatz, die Sortierreihenfolge und die Unicode-Sortierreihenfolge neu zu erstellen.